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MAXON Computer License Agreement
for CINEMA 4D / BodyPaint 3D

NOTICE TO USER

WITH THE INSTALLATION OF CINEMA 4D / BODYPAINT 3D A CONTRACT IS CONCLUDED
BETWEEN YOU AND MAXON COMPUTER GMBH, IN THE FOLLOWING CALLED THE
“LICENSOR”, A COMPANY UNDER GERMAN LAW WITH RESIDENCE IN FRIEDRICHSDORF,
GERMANY. “YOU“ AND THE “USER“ REFERS TO THE LICENSEE.

WHEREAS BY INDICATING YOUR ACCEPTANCE BELOW, YOU ACCEPT ALL THE TERMS AND
CONDITIONS OF THIS AGREEMENT. IN THE CASE OF NON-ACCEPTANCE OF THIS LICENSE YOU
ARE NOT PERMITTED TO INSTALL THE SOFTWARE.

IF YOU DO NOT ACCEPT THIS LICENSE PLEASE SEND THE SOFTWARE TOGETHER WITH THE
DOCUMENTATION TO MAXON COMPUTER OR TO THE SUPPLIER WHERE YOU BOUGHT THE
SOFTWARE.

1. General

Under this contract the licensor grants to you a non-exclusive license to use CINEMA 4D /
BodyPaint 3D, which is software and documentation, in the following called the ”software“. The
software itself as well as the copy of the software or any other copy you are authorized to make
under this contract remain the property of the licensor.

2. Use of the Software

(1) The user of this license is authorized to copy the software as far as the copy is necessary to use
the software. Necessary copies are the installation of the program from the original disk to the mass
storage medium of your hardware as well as the loading of the program into RAM.

(2) Furthermore the user is entitled to make a backup copy. However only one backup copy may be
made and kept in store. This backup copy must be identified as a backup copy of the licensed
software. (3) Further copies ARE NOT ALLOWED; this also covers the making of a hard copy of the
program code on a printer as well as copies, in any form, of the documentation.

3. Multiple use and network operation

(1) The user may use the software on any hardware available to him. However, should the user
change the hardware he is obliged to delete the software from the mass storage medium of the
hardware used up to then. A simultaneous installation or use on more than one hardware IS NOT
ALLOWED.

(2) The use of the licensed software for network operation or other client server systems is
prohibited if this opens the possibility of simultaneous multiple use of the software. In the case that
the user intends to use the software in network operation or other client server system he has to



take care that a multiple use is not possible by employing the necessary access security or otherwise
the user has to pay to the licensor a special network license fee, the amount of which is determined
by the number of users admitted to the network.

(3) The license fee for networks will be communicated to the licensee by the licensor immediately
after the user has indicated the number of admitted users in writing. The correct address of the
licensor is given in the manual and also at the end of this contract. The network use may start only
after the pertaining license fee is completely paid.

4. Transfer

(1) You may not rent, lease, sublicense or lend the software or documentation. You may, however,
transfer all your rights to use the software to another person or legal entity provided that you
transfer this agreement, the software, including all copies, updates or prior versions as well as all
copies of the font software converted to other formats and all documentation to such person or
entity and that you retain no copies, including copies stored on a computer and that the other
person agrees that the terms of this agreement remain valid and that his acceptance is
communicated to the licensor.

(2) The user is obliged to carefully store the terms of the agreement. Prior to the transfer of the
software the user has to inform the new user of these terms. In case the user does not have the
terms at hand at the time of the transfer of the software, he is obliged to request a second copy
from the licensor, the cost of which is born by the licensee.

(3) In case of transfer the license of the former user expires.

5. Recompilation and changes of the software

(1) The recompilation of the provided program code in other code forms as well as all other types of
reverse engineering of the different phases of software production including any alterations of the
software are not allowed.

(2) The removal of the security against copy or similar safety systems is only permitted if a faultless
performance of the software is impaired or hindered by such security. The burden of proof for the
fact that the performance of the program is impaired or hindered by the security device rests with
the user.

(3) Copyright notices, serial numbers or other identifications of the software may not be removed or
changed. The software is owned by the licensor and its structure, organization and code are the
valuable trade secrets of the licensor. It is also protected by United States Copyright and
International Treaty provisions. Except as stated above, this agreement does not grant you any
intellectual property rights on the software.



6. Limited warranty

(1) The parties hereto agree, that at present it is not possible to develop and produce software in
such a way that it is fit for any conditions of use without problems. The licensor warrants that the
software will perform substantially in accordance with the documentation. The licensor does not
warrant that the software and the documentation comply with certain requirements and purposes of
the user or works together with other software used by the licensee. The user is obliged to check the
software and the documentation carefully immediately upon receipt and has to inform the licensor in
writing of apparent defects 14 days after receipt. Latent defects have to be communicated in the
same manner immediately after their discovery. Otherwise the software and documentation are
considered to be faultless. The defects, in particular the symptoms that occurred, are to be described
in detail in as much as the user is able to do so. The warranty is granted for a period of 6 months
from delivery of the software (for the date of which the date of the purchase according to the
invoice is decisive, respectively in case of shipment by the licensor the date of the invoice). The
licensor is free to cure the defects by free repair or provision of a faultless update.

The licensor and its suppliers do not and cannot warrant the performance and the results you may
obtain by using the software or documentation. The foregoing states the sole and exclusive remedies
for the licensor’s or its suppliers’ breach of warranty, except for the foregoing limited warranty. The
licensor and its suppliers make no warranties, express or implied, as to noninfringement of third
party rights, merchantability, or fitness for any particular purpose. In no event will the licensor or its
suppliers be liable for any consequential, incidental or special damages, including any lost profits or
lost savings, even if a representative of licensor has been advised of the possibility of such damages
or for any claim by any third party.

If the licensor is unable to repair or replace the program in such way that it fulfils this agreement, the
user is entitled to withdraw from the agreement or is entitled to a reduction in the license fee. If the
creation of a program in the sense of this agreement is not possible with reasonable effort and within
a reasonable time, the licensor is entitled to withdraw from the agreement.

(2) In the case of enforcement of guarantee by the user, the user is obliged to return the program
and manuals together with proof of purchase. The cost of the return is to be borne by the licensor.

(3) The licensor accepts no liability should the software infringe third-party rights unless the
infringement was caused by gross negligence or is shown to be culpable. In this case only, the
licensor will excuse the user from any possible costs for the judicial defence of the enforcement of
copyrights and damages by the third party.

Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or
special damages, or the exclusion of implied warranties or limitations on how long an implied
warranty may last, so the above limitations may not apply to you. In this case a special limited
warranty is attached as exhibit to this agreement, which becomes part of this agreement. To the
extent permissible, any implied warranties are limited to 6 months. This warranty gives you specific
legal rights. You may have other rights which vary from state to state or jurisdiction to jurisdiction. In
the case that no special warranty is attached to your contract please contact the licensor for further
warranty information.



7. Damage in transit

The user is obliged to immediately inform the transport agent in writing of any eventual damages in
transit and has to provide the licensor with a copy of said correspondence, since all transportation is
insured by the licensor if shipment was procured by him.

8. Secrecy

The user is obliged to take careful measures to protect the programs and their documentation, in
particular the serial number, from access by third parties. The user is not permitted to duplicate or
pass on the programs or documentation. These obligations apply equally to the user’s employees or
other persons engaged by the user to operate the programs. The user will pass on these obligations
to such persons. The user is liable for damages in all instances where these obligations have not been
met.

9. Information

In case of transfer of the software the user is obliged to inform the licensor of the name and full
address of the transferee in writing. The address of the licensor is stated in the manual and at the
end of this contract.

10. Data Protection

For the purpose of customer registration and control of proper use of the programs licensor will store
personal data of the users in accordance with the German law on Data Protection
(Bundesdatenschutzgesetz). This data may only be used for the above-mentioned purposes and will
not be accessible to third parties. Upon request of the user the licensor will at any time inform the
user of the data stored with regard to him.

11. Other

(1) This contract includes all rights and obligations of the parties. There are no other agreements.
Any changes or alterations of this agreement have to be performed in writing with reference to this
agreement and have to be signed by both contracting parties. This also applies to the agreement on
abolition of the written form.

(2) This agreement is governed by German law. Place of jurisdiction is the competent court in
Frankfurt am Main. This agreement will not be governed by the United Nations Convention on
Contracts for the International Sale of Goods, the application of which is expressly excluded.

(3) If any part of this agreement is found void and unenforceable, it will not affect the validity of the
balance of the agreement which shall remain valid and enforceable according to its terms.



12. Termination

This agreement shall automatically terminate upon failure by you to comply with its terms despite
being given an additional period to do so. In case of termination due to the aforementioned reason,
user is obliged to return the program and all documentation to licensor. Furthermore, upon request
of licensor user has to submit written declaration that he is not in possession of any copy of the
program on data storage devices or on the computer itself.

13. Information and Notices

Should you have any questions concerning this agreement or if you desire to contact MAXON
COMPUTER for any reason and for all notifications to be performed under this agreement, please
write to:

MAXON Computer
GmbH Max-Planck-Str. 20
D-61381
Friedrichsdorf
Germany

or for North and South America to:

MAXON Computer Inc.
566 St. Charles Drive, Suite 2
Thousand Oaks, CA 91360
USA

We also shall be glad to provide you with the address of your nearest supplier.
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INTRODUCTION • 1

BodyPaint 3D enables you to create and hand paint textures for each
channel of a material directly on to a 3D model. This makes adding
detail, that is specific to the geometry of a model, easier than ever
before.

These tutorials will take you through the process of creating brushes
and colors with which to paint. This should help you to explore the
different settings, so that you can easily and quickly create the types of
brushes and colors for the look you want in any particular scene.

While we can show you how to use the tools of the program and our
results, BodyPaint 3D won’t paint an object for you and we cannot
teach you how to be an artist. The artistic part (actually putting paint to
texture) is still up to you. So, with this in mind, we offer some
suggestions.

Utilize reference material whenever you can. The art of painting is the
ultimate challenge of hand-eye coordination. The challenge is to take
what you see or can visualize in your head and reproduce it.

Everyone can create a mental image of something in their head. These
images are a reconstruction from memory. However, these mental
images are not an exact duplication of the real thing. Mental images
are really only a personal perception of reality. The mind cannot
possibly store all the information necessary to create a realistic
reproduction. The best results will come from what you can look at and
make reference to while working.

A sketchbook can be an indispensable tool. It’s a place where you can
plan future projects, keep a journal, a workbook, and it’s a
brainstorming tool. Take it with you when you are examining outdoor
reference material. Use your sketchbook to make field sketches of
reference material to remind your inner eye what something looked
like.

A camera, better yet a digital camera, is another way of capturing
reference material for painting later. The advantage of going digital is
the ability to easily bring the images into BodyPaint 3D or another
image-editing program for reference.

We will start the tutorial with an in-depth look into UV mapping, the
cornerstone of 3D painting and texturing.

Introduction
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Texture Map Projection Modes
How a material is mapped to an object affects the way paint is applied
to the object. CINEMA 4D offers Cubic, Cylindrical, Spherical, Frontal,
Spatial, Shrink-Wrap, and UVW mapping. All these modes can be used
within BodyPaint 3D as well. However, UVW offers the most control
and the best results when painting in 3D.

What is UVW Mapping?
A UVW mesh is an unwrapped, two-dimensional representation of a
3D surface. The points of a UVW mesh directly correspond to the
points of the 3D object. Although the mesh may become distorted
when manipulated, this point relationship always remains connected.
So a UVW mapped material or texture is actually pinned to the points
of the object.

For many reasons, UVW mapping will be the preferred method of
mapping a material or texture for painting in 3D. If the model is
deformed when animating, the material will move and stretch with the
points of the object. UVW mapping is also the only mode in which you
can manually change the position of the specific coordinates of a
material so that you can paint more accurately on a model. This
accuracy is dependent on how well defined the UVW coordinates are
over the entire surface of your model.

The manipulation and modification of an object’s UVW mesh is the
most important step to painting accurately on your 3D model with
BodyPaint 3D or any other 3D painting program

A clear illustration of how UVW map projection works is a Mercator
projection. A Mercator projection is a mathematical method of creating
a seamless rectangular map of the globe on a flat surface.

1 An Introduction to UVW

If you learn only one thing
from this manual, please
make it an understanding of
UVW mapping.
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Gerhardus Mercator developed this projection in 1568. Before his
technique, navigation charts for sailors did not correctly account for the
recent discovery that the world was round.

Applying the Mercator equation to a UVW mesh preserves the basic
shapes and directions, but causes size distortion. So the image of the
map (the UVW mesh) is stretched to conform to the shape of the
globe. However, the basic relationship still exists for accurate
navigation.

Imagine inflating a balloon inside a cylinder. First it will touch the
cylinder wall at the equator of the balloon. As you continue to blow it
up, each point on the balloon is pressed against the wall of the cylinder.
Although the equator of the balloon will not change much, the top and
bottom will be stretched more and more until it touches the ends of the
cylinder.

Although this is a good example of how a mesh might be changed to
accommodate the shape of a 3D object, the distortion that occurs at
the top and bottom of the balloon is actually an undesired effect when
preparing your UVW mesh for painting in BodyPaint 3D. You actually
want to avoid such distortion when preparing your UVW mesh. Ideally
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you want to scale equally in both directions - east-west (U) and north-
south (V) on the mesh. This will not always be possible, especially with
complex organic models. The idea is to keep the distortion ratio as low
as possible so you can accurately paint on your 3D model. If drastic
distortion occurs, when painting, you will experience varying results as
a brush moves from UVW polygon to polygon - a greatly undesired
effect.

For the best results, you want to balance the amount of distortion and
number of seams. Both should be at a minimum. However, both are
bound to occur when preparing a UVW mesh for painting.

UVW Coordinates
In geometry, coordinates are defined by X, Y and Z. This is a reference
system for placing geometry in three-dimensional space. UVW
coordinates only measure repetitions along each axis. When looking at
a bit map texture, the origin (U=0, V=0) is always the upper left corner.
The lower left is U=0, V=1, the upper right is U=1, V=0, and the lower
right is U=1, V=1. Basically, 0 is 0% and 1 is 100% of the whole image.
This is true regardless of the size or shape of the texture, or how you
scale or stretch a material or texture.

The actual numbers in UVW coordinates measure the repetitions or
tiling of materials and textures applied to an object. The coordinate
defined as U represents side to side, while V represents up and down,
and W represents depth. When a texture has been tiled, the space
between U=0, V=0 and U=1, V=1 is one repetition of the texture. Each
tile adds 1 to the U and/or the V coordinates (or subtracts 1 if you tile
in a negative direction). So a set of texture coordinates from U=0, V=0
to U=2, V=2 would be a grid of four tiles.

When viewing UV coordinates in the Structure manager, you can see
that every UVW polygon has four points and each point has three
numeric coordinates (e.g. U(A), V(A), W(A) ). That is, each point has a
U, V and W coordinate.
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Manipulating a UV Mesh
An Exercise
Let’s start with a simple example of how UVW works and some of the
tools for changing the way UVW affects texture placement. For the
purposes of this exercise, you will not be manipulating the W
coordinate of the UVW mesh. The W coordinate is only important
when using volume shaders, affecting the depth of the shader. You will
only be modifying the placement of a flat 2D texture in this exercise.

You will begin with a simple texture map of a red circle on a white
plane. Open the 'UV1.c4d' project located in the 'Tutorials: US:
BodyPaint 3D' folder (use File > Open for this).

You’ll note you already have a single polygon plane object in the scene
with a material applied.  Since the object is a single polygon model, it
has only one set of UV coordinates. You can see the UV coordinates of
your model by turning on Show UV Mesh. Before you do that though
make sure that the texture is selected in the Texture View (Texture
View – Textures > UV1.b3d) and that you can see the whole texture
(zoom in or out with Texture View – View > Zoom In/Zoom Out).

Activating the UV Mesh
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You will see a light blue border around the edges of the texture map.
This border represents the UV Map.

You can see that the UV Map is the same shape as the polygon it
represents. This is not always the case. For now, you will work with this
simple setup.

If you are in the Top View of the Perspective View window, the
textured polygon looks like the texture view.

Now you can change the UV Mesh and see what happens to the circle
on the object.

We are going to select tools from the UV Editor Tab which is the tab
that is attached to the Texture View; it may be along the top of the
window or to the side, depending on your preferences. Example tabs
are shown below, as we select the tools.

So, from the UV Editor Tab, select the Points mode as shown:



8 • INTRODUCTION TO UVW • CHAPTER 1

You should see four points selected, one at each corner of the UV
mesh; zoom out the Texture View until you see these. Now select the
UV Move Tool:

Click once on the upper left corner to select that point.
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Click and drag to move this point towards the center of the texture
map, about half way to the center.

Your UV Mesh should look something like this.
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If you look in the Perspective View, you can see that the circle in the
Texture Map is now stretched to fill most of the upper left corner of the
polygon.

This is because the circle now occupies more of the UV mesh’s upper
left corner. If you move the other points around you can see their effect
on the map as well.

Now you will look at the effect of scaling the UV mesh. First, restore
the UV mesh back to its original state for clarity (Texture View: Edit >
Undo).

Switch to Edit Polygon mode in the UV Editor Tab:
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Select the UV Scale tool from the UV Editor Tab:

Click once to select the UV polygon. Then click and drag to scale down
the UV polygon.
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Looking in the Perspective View, you will see that the circle is now
much larger on the object. This is for the same reason as before, the
circle in the texture map now fills more of the UV mesh.

Now you will rotate the UV and see what that does to the final image.

Begin by opening the 'UV2.c4d' project located in the 'Tutorial
Projects:UV Projects' folder.

Once this has loaded select the 'UV2.b3d' texture in the Texture View
(Textures > UV2.b3d). You’ll notice there is an arrow pointing up on
the texture map.

Also, you’ll note you already have a single polygon plane object in the
scene with a material applied. Since the object is a single polygon
model, it has only one set of UV coordinates. You can see the UV
coordinates of your model by turning on Show UV Mesh, if it’s not
already on.
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This will display a light blue border around the edges of the texture
map. This border represents the UV map. You can see that the UV map
is the same shape as the polygon it represents. This is not always the
case. For now, you will work with this simple setup.

In the UV-Editor tab select the UV Rotate Tool:

With the UV polygon selected, rotate the UV approx. 45 degrees.

You’ll note that the corners of the UV are now off of the texture map.

Looking in the Perspective View you will see that the arrow is now
rotated on the object.
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Editing the UV Mesh of a Cube
An Exercise
Now you will try these techniques on a slightly more complicated
object, a cube. Actually, a cube presents a number of challenges to
creating a usable UV map.

One of the important things to consider when UV mapping is defining
the criteria by which you will judge the 'correctness' of your map.

There are several criteria to choose from and balance. A partial list of
criteria would include:

– Correspondence of UV mesh to actual geometry.

– Number of disconnected surfaces or seams.

– Number of overlapping surfaces.

– Ability to paint in the 2D texture view.

– Recognizability of major geometric surfaces.

Each person is going to weigh these criteria differently. The two
following examples illustrate this; the first would be the order of
importance for someone who plans to do most of their painting in the
3D (Perspective) view, the second for someone who intends to do most
of their painting in the 2D Texture View.

3D/Perspective View:

– Number of overlapping surfaces.

– Correspondence of UV mesh to actual geometry.

– Number of disconnected surfaces or seams.

– Ability to paint in the 2D texture view.

– Recognizability of major geometric surfaces.

2D View:

– Number of overlapping surfaces.

– Ability to paint in the 2D texture view.

– Recognizability of major geometric surfaces.

– Number of disconnected surfaces or seams.

– Correspondence of UV mesh to actual geometry.
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So what do each of these criteria mean?

Correspondence of UV Mesh to Actual Geometry

This is a measure of how closely a UV polygon resembles the actual
geometric polygon to which it belongs. The closer these two are, the
less brush distortion you will experience when painting in the 3D view.
However, because you are taking a 3D surface and converting it to 2D,
there is no way to achieve perfect 1 to 1 correspondence. In addition,
as you increase correspondence, it is likely that you will increase the
number of disconnected or overlapping surfaces.

Number of Disconnected Surfaces or Seams

This is how many places there are in the UV map where the edges have
been separated, even though the edges in the model are connected. As
this number increases, it becomes harder to paint across the model in
the 3D view without having seams appear in the render. These seams
can be painted out with careful use of the brushes. Disconnecting some
surfaces can help to increase the correspondence of the UV mesh to
the actual geometry.

Number of Overlapping Surfaces

This is the amount of the UV mesh that occupies the same space on a
texture map. For example, if you cylindrically map a coffee cup, parts
of the handle’s UV will be at the same location on the texture map as
part of the cup. In most cases, you don’t want any UV’s to overlap one
another. The only exception would be for the purposes of placing the
exact same portion of the texture map in several places, such as
different faces of a cube or to be able to paint on two sides of a
symmetrical object simultaneously.

Ability to Paint in the 2D View

This is how easy it is to create a continuous brush stroke in the 2D view
across surfaces that are connected in the model (for example the
forehead and the nose). Usually, increasing paintability in the 2D view
will decrease correspondence to the geometry as it requires distorting
the UV mesh.

Recognizability of Major Geometric Surfaces

This determines whether or not you can identify which portion of the
UV mesh represents which portion of the geometry. Increasing the
recognizability will make it easier to paint in the correct location in the

Adding a texture for the Color channel
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2D view. However, it is also likely to increase the number of seams in
the UV mesh as you will often need to disconnect branching surfaces
(surfaces that go off in a different direction from the rest of the model,
such as a horn on a Viking helmet).

The default UV map setting for a cube has you painting the same
texture on all six sides of the cube. What if you want to paint across
the faces of the cube continuously?

For this, you will have to go through the steps of setting up the UV
map for the cube. There are many different ways you can do this. In
this case you will use a method which makes the UV look like the
unfolded cube. Going back to our criteria, this will be based mostly on
the 2D paintability. We will have several disconnected surfaces. The
geometric shape will still be recognizable and there will no longer be
any overlapping surfaces.

Time to get started.

Open the 'UVcube.c4d' scene from the 'Tutorials: US: BodyPaint 3D'
folder. Or if you already have CINEMA 4D XL integrated with
BodyPaint 3D, just create a cube and make it editable.

Create a new material.

Apply this material to the cube by dragging the material to the Object
manager and dropping it onto the cube. Accept the default mapping of
UVW.

In the Layer manager, add a texture map to the Color channel of the
material.

Accept the default size in the dialog, name your texture and click OK.

Make the texture active in the Texture View. There are many ways to
do this - you can drag the texture layer (here labeled 'Background' on
the right of the Layer manager) up to the Texture View or you can
double-click on the texture’s name in the Layer manager or you can
select the texture from the Textures menu in the Texture View.

Turn on Show UV Mesh.

The Structure manager

Selecting UVW Mode in the
Structure manager
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Zoom out in the texture view so that you can fit five copies of your
texture on the screen (to approximately 12%).

Texture View: View > Zoom Out (as many times as you need, probably
about 8 times) or Texture View: View > Set Zoom... to 12%.

You’ll need to have the Structure manager (Window > Structure
manager) available in order to accomplish the next step.

First, set the Structure manager to UVW mode.

Select the first UV by clicking on the number 1 in the Polygon column.
A red outline should appear around the texture map, indicating you
have this UV polygon selected.

The Active Tool window for UV Move
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Select the UV Move tool (Texture View: Tools > Move).

Go to the Active Tool manager (click on the tab or select Active Tool
manager from the main Window menu).

Make sure Keep Face Neighbors is off in the Options tab and Point
Snapping is on in the Snapping tab. Increase the radius to 10%. This
will make snapping much easier, and in a simple situation like this, it is
unlikely you’ll have any problems.

Click the upper left corner of the selected polygon and drag it to the
right, to the upper right corner of the texture map until it snaps into
place. You will see that the UV mesh has moved.

Select UV polygon 3 in the Structure manager. Click on the upper right
corner of this polygon and drag it to the upper left corner of the
texture map until it snaps in place.
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Select polygon 0 in the Structure manager. Click on the bottom right
corner of this polygon and drag it up until it snaps to the upper right
corner of the texture map.

Now select polygon 2 in the Structure manager. Click on its upper left
corner and drag down until it snaps into place at the bottom left corner
of the texture map.
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Select polygon 4 and click on its upper left corner. Drag it down until it
snaps into place at the bottom left corner of polygon 2. Your UV map
should look like a 't' as shown.

Now you can test this setup to see if it is ready for final painting. First,
you need to make the texture map the same size as the UV map. You
could scale down the UV map, but instead you’ll use the Fit Canvas to
UV function to grow the texture to the size of the UV.

To use this function simply select Fit Canvas to UV from the Functions
menu of the Texture View.
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Your texture map should now be as large as the UV map and no larger.
There will be some wasted space, but that is ok. You will only see the
texture map on the parts of the texture where the UV are placed

Now that the map is the correct size, you need to test it.

To test the map, simply paint from one face to another in the 3D/
Perspective View. First, make sure you are in painting mode

and that you have a brush selected

then select a brush color from the Color manager, and paint.

Watch the results in the 2D view to determine if it is working. A good
way to check a cube is to paint corner to corner diagonally. This lets
you see if the brush stroke really is lining up correctly. In the Texture
View, it should look like you are painting straight lines. If it looks like
the pen is jumping all over, then the UV map still needs work.

You may notice that Polygon 2 (the first polygon under the horizontal
part of the 't') is not working properly, it is probably flipped in both the
U and V directions from where it should be.
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To fix this, select the polygon (Tools > Live Selection in the
Texture View) and select Mirror U from the Functions menu of
the Texture View.

Now flip it on the V by choosing Mirror V.

Now retest this polygon to be certain that it works properly. At
this point, the vertical part of the 't' should be painting correctly.
Now you just need to fix the two outer parts of the 't'.

If you paint on the wings of the 't' you will notice that Polygon 3
is rotated 90˚ from where it should be. To fix this, select this
polygon and run Transform.

In the Rotation field, enter 90 and click OK. Be sure to do a paint
test again to ensure this has fixed the problem.

Finally, check the last polygon in this row. It too has been rotated
incorrectly. Rotate it -90˚ to correct the problem.

Your cube should now be easily paintable with no distortions. You
will have to be careful painting across the disconnected seams,
but this is not too much of an issue.
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2 Painting an Eyeball
An eyeball is a great place to begin, as it will be relatively simple
to paint and will simply illustrate how to use BodyPaint 3D.

Basically, you will create a new material that utilizes the Color,
Bump and Specular channels. This will be the material that
defines the surface aspects of the eyeball. After the material has
been created you will create textures for the Color and Bump
channels in the Texture manager. Then you will paint these
textures to define what the eye looks like.

Step 1: Open the 'EyeBall.c4d' Project located in the 'Tutorials:
US: BodyPaint 3D'  folder.
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Step 2: Create a new Material.

Double-click on the text 'New' under the gray sphere
representing the new material in the Material manager. This
opens a dialog that allows you to change the name of the
material. Change it to 'Eyeball'. Click OK.

Step 3: Apply the material to the Eye model by dragging the
material icon from the Material manager onto the Eye in the
Object manager. When you drop the material, a dialog will open
with options for how the material is projected onto the Eye.

The default, UVW Mapping is what you want to use, so click OK
to close the Texture dialog.

Step 4: Create a new texture for the Color channel of the
material.

Ensure the Eyeball material is active in the Material manager. Go
to the Layer manager and create a texture for the Color channel.

In the dialog that opens, name the texture 'EyeColor' (',b3d' will
be added, automatically, as the file extension). Set the map size
to 300x300 pixels with a resolution of 72dpi. Using a small
texture map here is all that is needed and helps to conserve
project and file size. Anything larger would be overkill.

Note

The higher the resolution of the image you are painting, the more
RAM required. For the best results, use only the maximum size
texture you will need for the final render. A scene with several
textures in RAM, will greatly reduce the performance of
BodyPaint 3D. Even just a few high-resolution images in one
material can be very RAM intensive. You can remove textures
from RAM but using the Enable checkbox in the Layer manager.
With a material selected, uncheck the Enable checkbox. This
removes the textures of this material from RAM. If changes have
been made to those textures, you will be asked if you want to
save those changes.

At the bottom of this dialog you can also set the overall color for
the texture.

Step 3: The Texture dialog

Step 2: Naming the material

Step 4: Selecting the Color channel and
naming the texture



CHAPTER 2 • PAINTING AN EYEBALL • 25

Clicking on the color box to the right of the Color pull down
menu will open your system color picker. However, for the
purposes of remaining platform independent, you will add the
base color later.

Click OK to accept the settings you have input.

Step 5: Create a new texture for the Bump channel of the
material.

Make sure the Eyeball material is still active in the Material
manager. In the Layer manager, create a texture for the Bump
channel.

This will automatically enable the bump channel of your material.

In the dialog that opens, name the texture 'EyeBump'. Set the
size to 300x300, keep the resolution at 72dpi.

Note

When you have textures on multiple channels of a material, it is
best to make all textures the same size. You cannot use multi-
channel brushes and colors, unless the texture maps are the same
size. If needed, you can use different sized textures on material
channels, as long as you do not intend on using multi-channel
brushes and colors.

The default of 50% gray color is exactly what you want for a
bump map. Gray is a neutral color and therefore creates no bump
at all. Painting white on a bump texture will create raised areas
and painting black will create sunken areas.

Later you will paint white on this map to define raised areas on
the iris of the eye. By clicking on the Color and Bump names in
the Layer manager you can jump between painting the image
maps that define the eye.

Click OK to accept the settings you have input.

Step 6: Make the color texture active in the Texture View so you
can paint it. There are a number of ways to do this - you can drag
the relevant texture layer (here labeled 'Background') up to the
Texture View or you can double-click on the texture color icon or
you can select the name of the color channel texture in the
Textures menu of the Texture View.

Step 5: Creating and naming the texture for
the Bump channel
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Step 7: The first thing you want to do is fill the texture with an
overall base color. To do this, click on the foreground color of the
color channel; the icon for the color channel foreground/
background colors is shown on the left and is to be found at the
top right of the Paint tab (there are separate foreground/
background colors for each channel). This will open/activate the
Color Settings dialog.

Now choose the color for the eyeball. You can choose any color
you like. The settings we used are R=100%, Green: 100%, Blue:
98%, Brightness: 100%.

The Color Settings window is a non-modal dialog, so you can
leave it open, let it float, dock it some place else or just close it.

To fill the EyeColor texture with the foreground color you have
just chosen, go to the Texture View and use the Fill Layer tool.

Step 8: Now you will paint the iris. To do this, you will select only
the area of the eyeball that represents the pupil and fill it with a
color.

First make the UV mesh visible if it isn’t already.

Use the rectangle selection tool

to select the area of the texture that defines the front of the
eyeball  i.e. drag out the rectangle selection until you have
enclosed the required area of the UV mesh, then let go of the
mouse button. In this case the required area is the second 'row'
of the UV mesh (see next page).

Step 7: Selecting the Foreground color to
bring up the Color Settings
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The Texture View shown below  illustrates what you are trying to
achieve.

Now choose the color for the iris. Open the Color Settings dialog
again by clicking on it, if it is still open, or by clicking on the
foreground color of the color channel.

The settings we used for this color were R=60%, Green: 70%,
Blue: 100%, Brightness: 100%.

Fill the selected UVs with the new foreground color

Note

To locate a specific area on a model
you can do two things: you can
paint on the model to see its
relation to the 2D UV map in the
Texture View, then undo what you
have painted. Or, you can select the
polygons of the object and see the
related area. You will see it is fairly
obvious where the pupil is located
on this map.
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Step 9: Now you will paint the pupil. To do this, you will select
only the area of the eyeball that represents the pupil and fill it
with black.

Use the rectangle selection tool again to select the area of the
texture that defines the front of the eyeball as shown (the black
area in the picture below - this shows the area already filled with
black).

Switch the foreground and background colors. You do this by
clicking on the angled line with arrows on the bottom left of the
foreground and background colors. Black should now be the
foreground color. If it isn’t, edit the Color Settings to get black.

Fill the selected UVs with the black foreground color.
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Here’s what the final result should look like so far:

Now, we’ll move on to work the outside of the iris.
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Step 10. To simulate the dark border of color surrounding the iris
of the eye, you will make another small selection on the very
outside of your color bar and fill it using a darker shade of the
blue used for the eye.

So, make a small selection at the bottom of the iris color area
with the rectangular selection in the Texture View window.

The selection should look like the dark blue area shown in the
Texture View below (we have shown the selection already filled
with dark blue).
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Then click on the Eyedropper icon

or select it from Painter > Tools > Eyedropper. Use this to get the
color of the iris (blue) into the Color Settings and then change the
Brightness value in the Color Settings to 60%. This gives a color
that is a darker hue of the original iris color.

Fill this small selection.
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Step 11: The transition of color between the different shades of
blue hardly looks subtle. So you will use a filter to improve it.

Use the rectangle selection tool to select all the blue color of the
texture in the Texture View window.

Next, use the Noise > Noise… filter to randomize this area of the
texture.

Set the Noise to 99.9% and toggle Monochromatic on so you
only get black and white noise and lots of it.

After the effect has been applied use the Motion Blur plugin filter
to soften the effect.

Set the Angle to 90˚, Length to 10 and Blend to 100%. This will
produce the color streaks within the iris.

Click OK. View the results; here’s what the Texture View should
look like:

Step 11: Applying noise and motion blur
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and the Perspective View:

Step 12: To add a few veins on this eye, you will need to build a
really small brush that blends with the surface of the eye. First,
let’s create a new brush. From the Brush manager, select File >
New….

In the dialog that opens, name the new Brush 'EyeVeins'.

Double-click on the new brush (EyeVeins) in the Brush window to
open the Brush Settings dialog.

In the Brush Settings make a brush with Shape: Circle, Profile:
Round and a Size of 1 (as small as it gets). Set the Spacing on
(checkbox selected) and to 18%, Pressure to 34%, Hardness to
100% and no Jitter (deselect the checkbox). Set the Filter to
Smudge with a Color Mix of 75%. This will help blend a little. As
usual, the Brush Settings so you do not need to close it before
you move on.

Step 12: Setting up a brush
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Go to the Color Settings and choose a reddish color. The settings
we used were Red: 75%, Green: 20%, Blue: 25%, Brightness:
100%.

Select the white of the eye in the Texture View window with the
rectangle selection tool.

You are effectively selecting everything below what you have
already painted.

Go back and select the new brush you built in the Brush manager
and select the brush tool icon (or Painter > Tools > Brush)

and then lightly draw (mostly vertical) veins in the Texture View
window as shown. The more you draw, the more tired the
character will become!

Step 12: Setting the brush color
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You’ll end up with an eye that should look something like this:

Step 13: For a more realistic look, the pupil and the iris of the
eyeball need to be raised a little on the surface. This is easily done
on the bump channel using the selection tool and the line tool.

First, select the area of the colored iris and pupil with the
rectangle selection tool to define the area you want raised.

Go to the Layer manager and select the Bump Channel texture.
Double-click on the Bump texture in your Layer manager (or
select Textures > Eyebump.b3d in the Texture View). This will
bring the bump texture into the Texture View, while maintaining
the rectangular selection.
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Now you need to select a white-ish color from your Color
Settings.

Open the Color Settings dialog (if not already open) by clicking
on the foreground color of the bump channel. This opens/
activates the Color Settings dialog.

Choose a pure white. The settings we used are Red:100%,
Green: 100%, Blue: 100%, Brightness: 100%. This will really
offset the raised area on the surface of the pupil.

Activate the Draw Line tool.

Go to the Active Tool manager and define some settings for this
line. You want a fat line with a smooth gradient of color. This will
create a bulging area where the pupil and iris reside. Set the
Endings at None, Line Width: 100, Feather: 50.

Step 13: Selecting a white color for the
Draw Line tool
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Draw a line horizontally along the top of the selected area in your
Texture View window as shown.

This effect will not show in the Perspective View; you can see the
results of your bump placement by doing a quick preview render.

Step 14: An eyeball has a uniform shininess or specularity. You
won’t need to create and paint a texture map in BodyPaint to
simulate this. Instead you will just turn on the Specular channel in
your material.

Double-click on the Eyeball material icon in the Material manager
to open the Material dialog. Click on Specular in the channel list
to bring up its options. You will want a really shiny, wet looking
eye so set the Width to 3% and the Height to 100%. This will
give you the wet eye you need.
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Click Refresh in the right corner of the Material manager to show
your settings and then close the window.

Give the Perspective View window a quick render to see how
your work looks and tweak the settings to your personal tastes.
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Now it’s time to start the rest of the head. The process will start
out very similarly to the eye you just painted, generating texture
layers of color, bump, and now diffusion to surface the model.
You’ll build several different brushes to paint skin, lips, eyebrows,
freckles, stubble, blemishes, scars, veins and tattoos into those
layers simultaneously. Sounds pretty daunting, but after this walk
through you’ll be painting your own models with confidence.

Step 1: You need to first generate an overall base face material.
This is where you will start and build all the other details on top
of that.

Open the 'PlainHead.c4d' project located in the 'Tutorials: US:
BodyPaint 3D' folder.

3 Painting a Base Skin Texture
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Step 2: Create a new Material.

Double-click on the text 'New' under the gray sphere
representing the new material in the Material manager. This
opens a dialog that allows you to change the name of the
material. Change it to 'Face' Click OK.

Step 3: Apply the Material to the head model by dragging the
material icon from the Material manager onto the head object in
the Object manager (ensure the Object manager is open first).
When you drop the material, a dialog will open with options for
how the material is applied to the head.

The default, UVW Mapping is what you want to use, so click OK
to close the dialog.

Step 4: Now you can create the textures for each of the channels
you will be painting. First, you will create a new texture for the
Color channel of the material.

Make sure the Face material is active in the Material manager. Go
to the Layer manager and create a texture for the Color channel.

In the dialog that opens, name the texture 'FaceColor'. At this
point, as always, you have a choice of size for the texture map
you are creating. We will use 1200x1200 pixels (medium
resolution) with a density of 72dpi but you can opt for a higher
resolution if you have sufficient memory in your computer.

Note that we have chosen a resolution significantly larger than
the eye map, because there will be a lot of minute detail in the
skin (pores, etc.). Bear in mind, as you work through subsequent
projects, that if you have chosen a resolution different to
1200x1200 you must use appropriate settings for your brushes as
the size of the texture greatly affects how a brush works.

Note

The texture size you choose to create depends on the resolution at
which the project will be rendered. For print resolution and
animations rendered in close up, a high resolution could be
necessary. The resolution we have chosen for this project
(1200x1200 pixels) will be suitable for most situations. An evenStep 4: A Color channel for the face texture

Step 3: Applying the Face material to
the head object

Step 2: Creating a new Face material
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lower resolution version could be used for some projects like
characters for games where detail needs are low. Large textures
require a significant amount of RAM to maintain smooth
workflow. If you find you cannot work efficiently with a high
resolution texture, please consider using a lower resolution
version.

How much RAM is needed for painting texture maps in
BodyPaint 3D?

Each texture or layer needs a minimum of (x*y*4)*(number of
layers+1) bytes. For instance, your color channel texture
(1200x1200 pixels) needs just over 11Mb of RAM
(1200x1200x8), assuming one layer. A high-resolution version
(say 2500x2500 pixels) needs 50Mb of RAM (2500x2500x8).
Normal textures, those that aren’t being painted, take up much
less RAM. In addition, undo memory can take up several times
the amount of RAM depending on the undo settings; consider
reducing the number of undo steps if memory is tight. Grayscale
images (like those used for bump, specularity, reflection, etc.)
require much less RAM.

Back to the plot. At the bottom of the texture channel dialog you
can also set the overall color for the texture. Clicking on the black
box to the right of the Color pull down menu will open your
system color picker. However, for the purposes of remaining
platform independent, you will add the base color in a moment.

Click OK to accept the settings you have input.

Step 5: Make the color texture active in the Texture View so you
can paint it. There are many ways to do this - you can drag the
texture layer (here labeled 'Background') up to the Texture View
or you can double-click on the channel name in the Layer
manager or you can select the texture name from the Textures
menu of the Texture View.

Step 6: Now, fill the color texture with an overall base color. To
do this, click on the foreground color of the Color channel. This
will open/activate the Color Settings dialog.

Now choose the color for the skin color. You can choose any color
you’d like. The settings we used are Red: 90%, Green: 75%,
Blue: 65%, Brightness: 90%.

The Color Settings window is a non-modal dialog, so you can
leave it open, let it float, dock it some place else or just close it.

Step 5: The new Color channel in the
Layer manager

Step 6: Setting the color for the texture
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To fill the FaceColor texture with the foreground color you have
just chosen, go to the Texture View and use the Fill Layer tool.

Step 7: Now to save this flesh color for future use. In the Color
Settings use the Add Single Channel Preset function from the File
menu.

Name this color Flesh in the dialog that appears and click OK.
The color has now been added to the color presets and you can
just click on it in the Color manager to reactivate it.

Step 8: Create a new texture for the bump channel of the
material.

Make sure the Face material is still active in the Material manager.
In the Layer manager, create a texture for the Bump channel.

This will automatically enable the bump channel of your material.

In the dialog that opens, name the texture 'FaceBump' Set the
size to 1200x1200 or the same as you used for the size of the
Color channel. Keep the resolution at 72dpi. Since you will be
painting the skin with multi-channel brushes and colors, the
texture maps will need to be the same size.

Step 7: Naming and saving a color preset

Step 8: The FaceBump bump channel



CHAPTER 3 • PAINTING A BASE SKIN TEXTURE • 43

The default of 50% gray color is exactly what you want for a
bump map. Gray is a neutral color and therefore creates no bump
at all.

Step 9: Double-click on the Background bump icon in the Layer
manager to make the new bump texture map active in the
Texture View window.

Note

By double-clicking on the any layer in the Layer manager you can
jump between the texture maps.

Now you will use the Noise filter to create the effect of pores on
the skin texture. First, open the Noise filter (Bitmap Filter > Noise
> Noise… within the Texture View).

Set the Noise to 12%, make sure Monochromatic is not active
and click OK. This will create a base gray tone with variation for
the pores, the dark areas define the depth of a pore. The darker
the area, the deeper the pore. White areas in the bump channel
will appear raised when rendered.

Double-click on the Face material in the Material manager, go to
the Bump channel (select Bump on the left-hand side of the
Material dialog) and set the bump Strength to 20%. This will
soften the effect.

Step 9: One way of activating a texture in
the Texture View; double-click on its
layer icon, in this case Background

Step 9: Using a noise filter to create skin
texture
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Step 10: Create a new texture for the Specular Color channel of
the material.

Make sure the Face material is still active in the Material manager.
In the Layer manager, create a texture for the Specular Color
channel.

This will automatically enable the Specular and Specular Color
channels of your material.

In the dialog that opens, name the texture 'FaceSpec'. Set the
size to 1200x1200, keep the resolution at 72dpi. Since you will be
painting the skin with multi-channel brushes and colors, the
texture maps need to be the same size.

At the bottom of this dialog you can also set the overall color for
the texture. Clicking on the white box to the right of the Color
pull down menu will open your system color picker. You can do
that now to avoid the next step if you like.

Click OK to accept the settings you have input.

Step 11: Double-click on the Specular Color texture to activate it
in the Texture View.

Step 12: Next, fill the Specular texture with an overall base color.
To do this, click on the foreground color of the specular channel.
This will open/activate the Color Settings dialog.

Now choose the color for the skin specularity. Ensure Solid Color
is checked; now you can choose any color you like. The settings
we used are Red: 20%, Green: 20%, Blue: 20%, Brightness:
100%. This will give you a base dark gray in your specular color
layer.

The Color Settings window is a non-modal dialog, so you can
leave it open, let it float, dock it some place else or just close it.

To fill the FaceSpec texture with the foreground color you have
just chosen, go to the Texture View and use the fill tool.

Step 10: Creating a Specular Color channel

Step 11: Activating the Specular Color texture

Step 12: The Specular Color texture’s color
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Step 13: Create a new texture for the diffusion channel of the
material.

Make sure the Face material is still active in the Material manager.
In the Layer manager, create a texture for the Diffusion channel.

This will automatically enable the diffusion channel of your
material.

In the dialog that opens, name the texture 'FaceDiff'. Set the size
to 1200x1200, keep the density at 72dpi. Again, since you will be
painting the skin with multi-channel brushes and colors, the
texture maps will need to be the same size.

Click OK to accept the settings you have input.

Step 14: Double-click on the Diffusion texture to activate it in the
Texture View.

Step 15: Next, fill the Diffusion texture with an overall base color.
To do this, click on the foreground color of the color channel. This
will open/activate the Color Settings dialog.

Now choose the color for the skin diffusion. You can choose any
color you’d like. The settings we used are Red: 85%, Green:
85%, Blue: 85%, Brightness: 100%. This will give you a base
light gray in your diffusion layer. This will slightly darken the skin
surface. This is the effect of the map filtering out light refracted
back to the viewer’s eye. It’s the last layer of realism.

To fill the FaceDiff texture with the foreground color you have
just chosen, go to the Texture View and use the fill tool.

Step 13: Creating a Diffusion channel

Step 14: Activating the Diffusion channel

Step 15: The Diffusion channel color
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Step 16: The last step in the overall skin texture will be to define
the specularity.

Double-click on the Face material icon in the Material manager to
open the Material dialog. Click on Specular in the channel list to
bring up its options.

Here you will define the overall shine of the model. The Specular
map helps 'dull down' areas of the face. Set the Width of the
highlight to 20%, set the Height of the highlight to 26%.

Click Refresh in the right corner of the Material dialog to update
your settings on the face and then close the window.

Give the Perspective View window a quick render to see how
your work looks and tweak the settings to your personal tastes.

Step 16: Setting the Specular parameters
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With all these maps in place it is time to move on. Next, you will
learn to build brushes that paint in one or many channels. These
are called single and multi-channel brushes. You use then to
paint wrinkles, scars, freckles and all types of detail onto your
model.
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Now you need to add a little coloration and overall specularity to
the face. To achieve this you need a few different single-channel
brushes. You will start with single-channel brushes before moving
on to the multi-channel brushes.

One brush will be used to paint in a little redness onto the face in
the color channel, one to create a darker area around the eye,
one to highlight and add some randomness to the color. You will
also paint white into the specular channel to shine up the
forehead and the bridge of the nose.

After weeks of staring at people’s faces and playing with brush
settings, we've come to a conclusion. Skin is hard to paint. The
settings given here are not perfect for a photorealistic face - they
are only meant to get you started in BodyPaint 3D.

The rest of the tutorial sections consist of suggestions for skin
detail, instructions on how to define brushes and the results that
we painted with the very same brush. Feel free to explore and
experiment.

In the next sections you’ll import bitmaps to use as brushes. You’ll
add random rotation, size and pressure to simulate the blood
vessels under the skin. A reddened version of the original skin
tone will be used and the brush will be saved to your presets. The
second brush is a darker version of the first.

Step 1: Your ongoing project should already be open. If not, you
can use the 'BaseHead.c4d' project which includes the head with
just the basic skin and eye textures already applied. It’s located in
the 'Tutorials: US: BodyPaint 3D' folder.

If you are continuing with the project from the previous section,
you are going to want to take care of memory management. The
more textures and layers you have in memory, the more RAM is
required. Even just a few textures can be RAM intensive. A quick
way to save memory is to flatten the layers of each channel.

4 Adding Highlights and Coloration
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You do that by selecting the particular channel in the Layer
manager and using Functions > Flatten Layers.

Step 2: In the previous tutorial you created a new color preset
called Flesh. You are now going to use this same method to
create variations of color for the face.

First, activate the Color Settings. Now set up a new color as
follows:

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 90%, G: 60%, B: 60%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Save this as a new preset color; in the Color Settings box select
File > Add Single Channel Preset.

Name this color 'Flush' in the dialog that appears and click OK.
Now you can just click on this color in the Color manager to
reactivate the same color.

Step 3: Now create an even darker color to be used just under the
eyes. The settings used here are:

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 70%, G: 45%, B: 50%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Save this as a new preset color, in the same way that you did for
the 'Flush' color, in Step 2 above. Name it 'EyeFlush'; it will be
added to the color presets.

Step 2: The 'Flush' color

Step 2: Saving the color as a
preset

Step 3: The 'EyeFlush' color
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Step 4: Lastly, create a lighter color for all around coloration. The
settings we used are:

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 95%, G: 90%, B: 85%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A
Now save this as a new preset color and name it 'LtFlesh'. See
Step 2 if you are unsure how to do this.

Step 5: Now to create a single channel brush.

The first brush we make will be one to draw the highlights and
general flesh patterning on the face and the top of the head. So,
create a new brush, using the Brush manager (File > New…).

In the dialog that opens, name the new Brush 'LtFlesh'.

Double click on the new brush in the Brush manager to open the
Brush Settings dialog. The settings used here are:

Type: Bitmap
Store Color: Enabled
Bitmap: flesh3.jpg
Size: 50
Pressure: 11%
Spacing: 100% (to space out the bitmap images as you paint)
Jitter: None (unchecked)
Rotation: 0

Toggle on the Effector Settings (click the … to the
right of Rotation), enable Randomness and accept
the 0-100% default (this will spin the bitmap brush in
random rotations to keep the map looking natural
and not repetitive)

Filter: None
Color Mix: None

Remember, the Brush Settings is a non-modal dialog so you can
leave it open, the changes take effect immediately.

Step 4: The 'LtFlesh' color

Step 5: Creating a new brush
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Note

If you ever want to add your own bitmap brush, all you have to
do is choose Load From Disk…  from the Bitmap  pull down
directory within the Brush Settings dialog. Once you have selected
the bitmap you want, you will be given the option to add it to the
presets.

Note for Graphic Tablet users

To modify the Effector Settings of a brush characteristic, just click
the box next to the setting for the attribute of the brush. Each
characteristic can be mapped to a different function for better pen
and tablet interactivity. For this brush you should open the dialog
for the Pressure  Effector Settings and set Pen Pressure  on. This
will give you more control by making your brush pressure
dependent upon how hard down you press on the tablet with the
pen. Alternately you can use the mouse wheel if you do not use a
tablet. The linear default curve is fine. Click OK.

Step 6: Lastly, make sure the color is locked into this brush. In the
Color manager, select 'LtFlesh' so it is active in the window.

Go back to the Brush Settings dialog and make sure Store Color is
active (you should have already checked this option but we’re
just being careful!).

Your first brush is now ready. All you have to do is save it in the
Brush manager (File > Save As Default…).

Click Yes in the dialog that appears This will save your brush to
use later, even after closing the project.

Step 7: Next, you need a brush to draw the tiny veins that color
the face giving it a flushed look. Create a new brush.

In the dialog that opens, name the new brush 'BlushBrush'.

Double click on the new brush in the Brush manager to open the
Brush Settings dialog. Set up the brush as follows:

Type: Bitmap
Store Color: Enabled
Bitmap: flesh1.jpg
Size: 30
Pressure: 11%
Spacing: 100% (to space out the bitmap images as you paint)

Step 5: The Rotation Effector Settings for
our new brush

Step 6: Saving our first brush

Step 7: Creating the 'BlushBrush' brush
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Jitter: None (unchecked)
Rotation: 0

Toggle on the Effector Settings (click the … to the
right of Rotation), enable Randomness and accept
the 0-100% default (this will spin the bitmap brush in
random rotations to keep the map looking natural
and not repetitive)

Filter: None
Color Mix: None

Note for Graphic Tablet users

Click on the Pressure  Effector Settings and set Pen Pressure  on.
This will give you more control by making your brush pressure
dependent upon how hard down you press on the tablet with the
pen. Alternately you can use the mouse wheel if you do not use a
tablet. The linear default curve is fine. Click OK.

Step 8: Lastly, make sure the color we want is locked into this
brush. In the Color manager, select 'Flush' so it is active in the
window.

Go back to the Brush Settings dialog and make sure Store Color is
active. Now save it in the Brush manager as shown on the left
(File > Save As Default). This will save your brush to use later,
even after closing the project.

Step 9: Next you need a brush to darken the area around this
character’s eyes.

It will be very similar to the BlushBrush you just created. This time
you will include a blurred vein map and a darker tone. Create a
new brush.

In the dialog that opens, name the new brush 'EyeFlush'.

Double click on the new brush in the Brush manager to open the
Brush Settings dialog. Set the brush up as follows:

Type: Bitmap
Store Color: Enabled
Bitmap: flesh2.jpg
Size: 15
Pressure: 90%
Spacing: 100% (to space out the bitmap images as you paint)
Jitter: None (unchecked)

Step 7: The settings for 'BlushBrush'

Step 8: Saving the 'BlushBrush' brush

Step 9: Creating a new 'EyeFlush' brush
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Rotation: 0
Toggle on the Effector Settings (click the … to the
right of Rotation), enable Randomness and accept
the 0-100% default (this will spin the bitmap brush in
random rotations to keep the map looking natural
and not repetitive)

Filter: None
Color Mix: None

Note for Graphic Tablet users

Click on the Pressure  Effector Settings and set Pen Pressure  on.
This will give you more control by making your brush pressure
dependent upon how hard down you press on the tablet with the
pen. Alternately you can use the mouse wheel if you do not use a
tablet. The linear default curve is fine. Click OK.

Step 10: Lastly, make sure the color is locked into this brush.

In the Color manager, select 'EyeFlush' so it is active in the
window. Go back to the Brush Settings dialog and make sure
Store Color is active. Now save it in the Brush manager. This will
save your brush to use later, even after closing the project.

Step 11: Now you need a layer to paint on. Instead of painting
directly in the color channel, you will add a new layer on top of
the color channel and paint on that. This helps organize the
coloration better. If you wanted to add a tattoo later on you
would paint it on a layer. If you change your mind later, the layer
could be deleted leaving your original map intact. This also helps
conserve file size.

Select the Color channel in the Layer manager. Now, make the
Color texture active in the Texture View; again, either drag the
texture layer up to the Texture View or double click on the
texture to activate it in the Texture View.

Create a new layer for this texture.

Step 9: The brush setup for the
'EyeFlush' brush

Step 10: Saving the color and other
settings for the 'EyeFlush' brush
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Name the new layer.

Name it 'Blush' and close the dialog.

Double-click on this layer to make it active in the Texture View.

Step 12: Now you are ready to paint on this layer.

Firstly, make sure that you have the FACEPOLY object selected in
the Object manager. Now, make its UV mesh visible.

Select your LtFlesh brush from the Brush manager and add some
color to the model. Use the LtFlesh color to fill in the areas
around the seams. You can do this easily in the 2D Texture View.

Note

A word about seams. When a model’s UV polygons are split apart
to lie on a flat 2D texture (as this model’s are) it inevitably causes
seams. The problem for the 3D painter is that when you paint on
a seam, there can be a difference when a brush stroke flows
between the two map edges. More often than not, the result is a
minor flaw that may not be noticeable. To work around the seam
in the head you may need to paint solid color over these seams to
avoid possible unsightly flaws.

You can paint in any view you like. It is recommended in some
instances to go from the 3D Perspective View to the Texture View
window and back. It is especially useful when working around
seams to be sure they are even.

After laying down some color with these settings, you should
explore and be creative with the settings for the best results. Add
a little randomness by increasing the size of the brush to 100 in
the Brush Settings, then paint a little with it. You can also darken
the flesh color a little to 95% by dragging the Brightness slider in
the Color Settings dialog, and paint a little more.

Step 11: The 'Blush' layer
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Here’s an example of what you are trying to achieve; a tonal
depth to the skin.

And here’s the texture map.

Feel free to keep adding colors, changing brush sizes etc. until
you are happy with the results.
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Step 13: Next use the EyeBrush you created to darken the areas
around the eyes and the ears.

Your results may look strange at first. That’s why you will blur it a
little.
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When you are ready, choose the Blur filter (Texture View: Bitmap
Filters > Blur…).

Set the blur Horizontal Radius to 5 (with Synchronize Sliders
selected). Click OK. This blurs the entire layer a bit, blending
what you have added. The effect is subtle; all make-up takes
some time, so you may need to use many brush strokes.

Feel free to go back and add more color. Then, blur again at any
time.

Step 14: Next, add some blush to the cheeks, chin and wherever
else you like. Again, many brush strokes may be needed.

First, activate the BlushBrush you created and then start laying
down color on the cheeks, chin, etc. Play around a little. After all,
you have lots of undos to work with.

Note

A word about the eraser tool. You
have one, use it. You also have
plenty of undos, so don't be shy, be
creative!
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Step 15: Now a little specularity needs to be added.

The forehead, bridge of the nose and cheeks seem to be the
shiniest spots on the face. Therefore, with a soft white brush in
the Specular color channel, you will paint in this attribute.

First double-click on the Specular Color channel in the Layer
manager to make it active in the Texture View. Then create a new
layer.

Next name the new layer.

Name it 'Shine' and confirm the dialog.

Double-click on this layer to make it active in the Texture View.

Step 16: In the Color Settings, make sure you have a subtle gray
as your setting.

Blending Mode: Normal, slider set to 50%
Ignore Filter: Disabled
Type: Solid Color
R: 100%, G: 100%, B: 100%
Brightness: 45%
Wallpaper: None
Percentage: N/A
Mode: N/A

Step 17: Now create a generic, circular brush with the following
attributes:

Type: Generic
Store Color: Enabled
Shape: Circle
Profile: Round
Size: 80
Pressure: 90%
Hardness: 100%

Step 15: Adding the 'Shine' layer to the
Specular Color channel

Step 16: A subtle shade of gray
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Spacing: 25%
Jitter: None (unchecked)
Squeeze: 0%
Rotation: 0%
Filter: None
Color Mix: None

Note for Graphic Tablet users

Click on the Pressure  Effector Settings and set Pen Pressure  on.
This will give you more control by making your brush pressure
dependent upon how hard down you press on the tablet with the
pen. Alternatively you can use the mouse wheel if you do not use
a tablet. The linear default curve is fine. Click OK.

Paint the top of the head, the bridge of the nose and a some of
the cheeks to add a little shine. You can see where we painted to
get a better idea.

Step 17: A brush for adding some
shine

Step 17: The Pressure Effector Settings –
useful for users of graphic tablets
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It’s best to start off painting a characteristic that will cover a large
area of the face. This warrior is going to need some stubble to
make him look manly and unkempt. To do this, you will make a
multi-channel brush for this exercise. This brush will use the
Color, Diffusion, Bump and Specular channels.

Step 1: Your ongoing project should already be open. If not, you
can use the 'BaseHead.c4d' project which includes the head with
just the basic skin and eye textures already applied. It’s located in
the 'Tutorial Projects' folder.

If you are continuing with the project from the previous section,
you going to want to take care of memory management. The
more textures and layers you have in memory, the more RAM
that is required. Even just a few textures can be RAM intensive. A
quick way to save memory is to flatten the layers of each
channel.

You do that by selecting the channel in the Layer manager and
using the Flatten Layers function from the Functions menu.

Step 2: Now add a new layer to the Color channel of your
material.

With the Face material selected and the Color channel active in
the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'StubbleColor' and close the dialog.

Double-click on this layer to make it active in the Texture View.

5 Painting Stubble

Step 1: Flattening the Color channel
layers

Step 2: Creating a new Color layer
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Step 3: A new Diffusion layer

Step 3: Now, in a similar way, add a new layer to the Diffusion
channel of your material.

With the Face material selected and the Diffusion channel active,
create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'StubbleDiff' and close the dialog.

Step 4: Now, just the same, add a new layer to the Bump channel
of your material.

With the Face material selected and the Bump channel active,
create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'StubbleBump' and close the dialog.

Step 5: Finally, layer-wise, add a new layer to the Specular
channel of your material.

With the Face material selected and the Specular Color channel
active, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'StubbleSpec' and close the dialog.

Step 4: A new Bump layer
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Step 6: A brush for painting stubble

Step 6: Next, you will create a brush for adding stubble to the
skin. Create a new brush.

In the dialog that opens, name the new brush 'StubbleBrush'.

Double-click on the new brush in the Brush manager to open the
Brush Settings dialog and enter the following values.

Type: Bitmap
Store Color: Enabled
Bitmap: stubble.jpg
Size: 20
Pressure: 100%
Spacing: 50%
Jitter: 6
Rotation: 5˚
Filter: None
Color Mix: None

Note for Graphic Tablet users

Click on the Jitter Effector Settings and set Randomness  on. Set
the Randomness  from 0% (Min) to 15% (Max). Alternatively
you can use the mouse wheel if you do not use a tablet. The
linear default curve is fine. Click OK.

Step 7: The next step involves setting the color for each of the
channels you will be painting on.

First you must enable multi-channel painting. You do that by
clicking on the multi-channel icon (next to the channel icons on
the Painter icon bar) so that the green checkbox is showing.

Next you must enable the channels you wish to paint on by
clicking on each channel icon in the Layer manager so that you
can see the pencil in the icon. This indicates that the channel is
active for painting.

The color settings we used here are given on the next page.
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Color Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 30%, G: 20%, B: 20%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Diffusion Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 80%, G: 80%, B: 80%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Bump Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 100%, G: 100%, B: 100%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Specular Color Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 75%, G: 75%, B: 75%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

The Color Settings for the
various channels of our first
multi-channel brush

The Bump channel color will
make the hairs seem to rise off
the face a little.

The Specular channel color will give
the stubble some shine.



CHAPTER 5 • PAINTING STUBBLE • 65

Step 7: Saving the multi-channel color

Step 8: Saving the 'StubbleBrush' brush

Now save all these colors together, as a new multi-channel preset;
in the Color Settings dialog select the Add Multi-Channel Preset
function from the File menu.

Name this preset 'Stubble' in the dialog that appears and click
OK. Now you can just click in the Color manager to activate this
multi-channel color, at any time. Note that all the color attributes
of all the active channels will be added into this preset.

Step 8: Lastly, make sure this color is locked into the
StubbleBrush. In the Color manager, make sure the Stubble color
is active in the window.

Go back to the Brush Settings dialog for the StubbleBrush and
ensure Store Color is active. Now save it in the Brush manager
with File > Save As Default….

Confirm the dialog that appears. This will save your brush to use
later, even after closing the project.

Step 9: Now paint all the stubble this guy needs! You can even go
so far as to do the top of the head if you wish; have fun with it.
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The lips need to be handled in two parts; the bump alone, then
the color and the specularity. This is because the bump map will
be radically different from the color map.

You’ll need to build two brushes for this.

Step 1: Your ongoing project should already be open. If not, you
can use the 'BaseHead.c4d' project which includes the head with
just the basic skin and eye textures already applied. It is located in
the 'Tutorials: US: BodyPaint 3D' folder.

If you are continuing with the project from the previous section,
you going to want to take care of memory management. The
more textures and layers you have in memory, the more RAM
that is required. Even just a few textures can be RAM intensive. A
quick way to save memory is to flatten the layers of each
channel.

You do that by selecting the channel in the Layer manager and
using the Flatten Layers function from the Functions menu.

Step 2:First you will add a new layer to the bump channel of your
face material.

With the Face material selected and the bump channel active in
the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'LipsBump' and close the dialog.

Double-click on this layer to make it active in the Texture View.

6 Painting Lips

Step 1: Flattening the Color channel
layers to save memory

Step 2: Creating a new Bump layer
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Step 3: A brush for painting lip wrinkles

Step 4: A new Bump layer

Step 3:Next you will create a brush to draw the tiny wrinkles in
the lips.

So, create a new brush from the Brush manager.

In the dialog that opens, name the new brush 'LipBump'.

Double-click on the new brush in the Brush manager to open the
Brush Settings dialog and set up this brush as follows.

Type: Bitmap
Store Color: Disabled
Bitmap: lip2.jpg
Size: 25
Pressure: 100%
Spacing: 75%
Jitter: None (disabled)
Rotation: 0˚
Filter: None
Color Mix: None

Ensure that you turn off the Effector settings for Rotation; when
you set up a new brush, the settings from the previous brush are
used – in this case you would have the wrong Effector settings.

Now save it in from the File menu in the Brush manager.

Confirm the save dialog. This will save your brush to use later,
even after closing the project.

Step 4: Now you need to let BodyPaint 3D know this is a single
channel brush.

At the top of the foreground/background tabs is the multi-
channel enable button. Toggle it off

and ensure that only the bump layer has a pencil icon active,
indicating that it will be the painted channel.
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Step 4: A good color for lip wrinkles

Set up a brush color for this bump channel:

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 20%, G: 20%, B: 20%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

This will be good for creating the subtle creases in the lips.

Then brush on lip bump in the Texture Window. Applying the
bump here rather than the 3D view offers more precision and is
easier to control the placement of paint in such a small area of
the model. Lay down enough texture to create a solid looking lip.

Note

Always remember to check that you have a relevant object and
texture selected (in this case FACEPOLY and Face respectively)
and that the channel on which you want to paint is the one in the
Texture View.

Then get ready for more painting in the color channel with a new
brush.
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Step 5: Now it’s time to add some color to the lips.

First you will add a new layer to the color channel of your
material. With the Face material selected and the Color texture
channel active in the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'LipsColor' and close the dialog.

Double-click on this layer to make it active in the Texture View.

Step 6: Now select a brush for painting the lips.

For this, you will only need a generic circular brush.

Type: Generic
Store Color: Enabled
Shape: Circle
Profile: Round
Size: 30
Pressure: 11%
Hardness: 100%
Spacing: 20%
Jitter: None (disabled)
Squeeze: 100%
Rotation: 0˚
Filter: None
Color Mix: None

Note for Graphic Tablet users

Click on the Pressure Effector Settings and set Pen Pressure  on.
Alternatively you can use the mouse wheel if you do not use a
tablet. The linear default curve is fine. Click OK.

Step 5: Creating the 'LipsColor' layer

Step 6: A generic brush for painting the lips
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Step 7: A good lip color

Step 7: Now you need to let BodyPaint 3D know this is a single
channel brush. At the top of the foreground/background tabs is
the multi-channel enable button.

Toggle it off

and ensure that only the color layer has a pencil icon active,

indicating that it will be the painted channel.

Now set up a brush color for the Color channel as follows.

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 85%, G: 55%, B: 55%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A
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Step 8: Then brush on lip color in the Texture Window. Again,
applying the color here rather than the 3D/Perspective View
offers more precision and it is easier to control the placement of
paint in such a small area of the model.
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Time to add some freckles to the face.

Our artist stared at his girlfriend’s face for hours, and came to the
conclusion the freckle brush is only a single channel brush using
the color channel.

Step 1: Your ongoing project should already be open. If not, you
can, as usual, use the 'BaseHead.c4d' project which includes the
head with just the basic skin and eye textures already applied. It’s
located in the 'Tutorials: US: BodyPaint 3D' folder.

If you are continuing with the project from the previous section,
you should remember to take care of memory management. The
more textures and layers you have in memory, the more RAM
that is required. Even just a few textures can be RAM intensive. A
quick way to save memory is to flatten the layers of each
channel.

You do that by selecting the channel in the Layer manager and
using the Flatten Layers function from the Functions menu.

Step 2: First you will need to add a new layer to the Color
channel of your material.

With the Face material selected and the color channel active in
the Layer manager, create a new layer, as shown on the left.

Then open the Bitmap Info dialog.

Rename the layer 'Freckles' and close the dialog.

Double-click on this layer to make it active in the Texture View.

7 Painting Freckles

Step 1: Flattening the Color channel
layers to save memory

Step 2: Creating a new Color layer
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Step 3: A brush for painting freckles

Step 3: Next, you will create a brush for adding freckles to the
skin of the face.

Create a new brush in the Brush manager.

In the dialog that opens, name the new brush 'FreckleBrush'.

Double-click on the new brush in the Brush manager to open the
Brush Settings dialog and set it up as follows.

Type: Bitmap
Store Color: Enabled
Bitmap: freckle.psd
Size: 20

Toggle on the Effector Settings (click the … to the
right of Size), enable Randomness and accept the 0
to 100% default:

Pressure: 38%
Toggle on the Effector Settings (click the … to the
right of Pressure), enable Randomness and accept
the 0-100% default:
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Spacing: 200%
Jitter: 15

Toggle on the Effector Settings (click the … to the
right of Jitter), enable Randomness and accept the 0
to 100% default:

Rotation: 0
Toggle on the Effector Settings (click the … to the
right of Rotation), enable Randomness and accept
the 0-100% default:

Filter: None
Color Mix: None
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Step 4: A good color for freckles

Step 5: Ensuring we have the 'Freckles'
color locked to our brush

Step 4: Create the color for our freckle brush.

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 50%, G: 30%, B: 25%
Brightness: 60%
Wallpaper: None
Percentage: N/A
Mode: N/A

Now save this as a new preset color. In the Color Settings dialog,
select Add Single Channel Preset from the File menu.

Name this color 'Freckles' in the dialog that appears and confirm
the dialog. Now, whenever you need this color, you can just
select it in the Color manager.

Step 5: Lastly, make sure that this color is locked into the Freckles
brush. In the Color manager, make sure the Freckle color is active
in the window.

Go back to the Brush Settings dialog for the FreckleBrush and
make sure Store Color is active. Now go to the Brush manager
and select File > Save As Default….

Confirm the save dialog. This will save your brush to use later,
even after closing the project.

Step 4: Saving our freckles color
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Step 6: Now you need to let BodyPaint 3D know this is a single
channel brush.

At the left of the foreground/background tabs is the multi-
channel enable button. Toggle it off

and ensure that only the Color channel has a pencil icon active

indicating that it will be the painted channel.

Now try out a few freckles around the cheeks and nose. This is
frequently where freckles end up on a face. Feel free to modify
the settings as you please.
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Now you will create a brush that will scatter color over the face to
simulate blemishes and pimples.

This is very similar to the Freckle brush, only this time your brush
and color will need to work on multiple channels - Color,
Diffusion, Bump and Specular all at the same time.

Step 1: Your ongoing project should already be open.

If not, you can use the 'BaseHead.c4d' project which includes the
head with just the basic skin and eye textures already applied. It’s
located in the 'Tutorials: US: BodyPaint 3D' folder.

If you are continuing with the project from the previous section,
you should do the memory housekeeping before continuing. The
more textures and layers you have in memory, the more RAM
that is required. Even just a few textures can be RAM intensive. A
quick way to save memory is to flatten the layers of each
channel.

You do that by selecting the channel in the Layer manager and
using the Flatten Layers function from the Functions menu.

Step 2: First you will need to add a new layer to the Color
channel of your material.

With the Face material selected and the Color texture channel
active in the Layer manager, create a new layer, in the usual way.

Open the Bitmap Info dialog.

Rename the layer 'BlemColor' and close the dialog.

Double-click on this layer to make it active in the Texture View.

8 Painting Blemishes

Step 1: Flattening the Color channel
layers to save memory

Step 2: Creating a new Color layer
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Steps 3-5:
Creating new layers for Diffusion,
Bump & Specular Color channels
(we’ve omitted the dialog for Bump)

Step 3: Now add a new layer to the Diffusion channel of your
face material.

With the Face material selected and the diffusion texture active in
the Layer manager, create a new layer with Functions > New
Layer.

Open the Bitmap Info dialog.

Rename the layer 'BlemDiff' and close the dialog.

Step 4: Add another new layer, this time to the Bump channel of
your material.

With the Face material selected and the bump texture active in
the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'BlemBump' and close the dialog.

Step 5: Now add a final, new layer;  to the Specular channel of
your material.

With the Face material selected and the specular texture active in
the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'BlemSpec' and close the dialog.
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Step 6: Next, you will build a brush for adding blemishes etc. to
the skin.

Create a new brush in the usual way, as shown on the left.

In the dialog that opens, name the new brush 'BlemishBrush'.

Double-click on the new brush in the Brush manager to open the
Brush Settings dialog and use the following settings.

Type: Bitmap
Store Color: Enabled
Bitmap: freckle.psd
Size: 10
Pressure: 40%
Spacing: 250%
Jitter: None (disabled)
Rotation: 0˚
Filter: None
Color Mix: None

Note for Graphic Tablet users

Click on the Pressure  Effector Settings and set Pen Pressure  on.
This will give you more control by making your brush pressure
dependent upon how hard down you press on the tablet with the
pen. Alternatively you can use the mouse wheel if you do not use
a tablet. The linear default curve is fine. Click OK.

Step 7: The next step involves setting the color for each of the
channels on which you will be painting.

First you must enable multi-channel painting.

You do that by clicking on the multi-channel icon so that the
green checkbox is showing.

Step 6: Creating a new blemish brush

Step 6: The Brush Settings for
'BlemishBrush'

Step 6: Owners of graphic tablets can use
the Effector Settings to increase pen
responsiveness
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Next you must enable the channels on which you wish to paint
by clicking on each channel icon so that you can see the pencil in
the icon.

This indicates that the channel is active for painting.

Step 8: Now you must create the color settings for each of the
active channels. Click on the foreground color

of each channel to open the Color settings dialog. The settings
we used are as follows:

Color Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 90%, G: 45%, B: 50%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Diffusion Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 80%, G: 80%, B: 80%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A
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Bump Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 95%, G: 95%, B: 95%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Specular Color Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 70%, G: 70%, B: 70%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Now save all these colors as a new multi-channel preset.

In the Color Settings box select Add Multi-Channel Preset from
the File menu.

Name this color 'Blemishes' in the dialog that appears and click
OK. Now, at any time, you can select this multi-channel color
from the Color manager simply by clicking on it.

Step 8: Saving our multi-channel color
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Step 9: Lastly, make sure this color is locked into the
BlemishBrush.

In the Color manager, make sure the Blemishes color is active in
the window.

Go back to the Brush Settings dialog for the BlemishBrush and
make sure Store Color is active. Now save the brush from the
Brush manager, by selecting Save As Default… from the File
menu.

Confirm the Save dialog. This will save your brush for later use,
even after closing the project.

Step 10: Now try placing a few blemishes around the chin, cheeks
and nose. The effect is very subtle, so you may need to make a
few brush strokes to see results.

Again, feel free to change the settings if you please.

Step 9: Ensuring that the Blemishes
color is stored with the
BlemishBrush brush

Step 9: Saving the BlemishBrush brush
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Wrinkles always add that extra bit of realism to a character. To
create them, you will build a multi-channel brush that paints on
the Diffusion, Bump, and Specular channels in one stroke.

Step 1: Your ongoing project should already be open. If not, you
can use the 'BaseHead.c4d' project which includes the head with
just the basic skin and eye textures already applied. It is located in
the 'Tutorials: US: BodyPaint 3D' folder.

If you are continuing with the project from the previous section,
remember to take care of memory management. The more
textures and layers you have in memory, the more RAM that is
required. Even just a few textures can be RAM intensive. A quick
way to save memory is to flatten the layers of each channel.

You do that by selecting the channel in the Layer manager and
using the Flatten Layers function from the Functions menu.

Step 2: Now add a new layer to the Diffusion channel of your
face material.

With the Face material selected and the diffusion texture active in
the Layer manager, create a new layer as shown on the left.

Then open the Bitmap Info dialog.

Rename the layer 'WrinkleDiff' and close the dialog.

Double-click on this layer to make it active in the Texture View.

9 Painting Wrinkles

Step 1: Flattening the Color channel
layers to save memory

Step 2: Creating a new Diffusion layer



86 • PAINTING WRINKLES • CHAPTER 9

Steps 3 & 4:
Creating new layers for the Bump
and Specular Color channels

Step 3: Now you’ll add a new layer to the Bump channel of your
material, in a similar way.

With the Face material selected and the bump texture active in
the Layer manager, create a new layer, as before.

Open the Bitmap Info dialog.

Rename the layer 'WrinkleBump' and close the dialog.

Step 4: Now add a final new layer to the Specular Color channel
of your material.

With the Face material selected and the specular color channel
active in the Layer manager, create another new layer.

Open the Bitmap Info dialog.

Rename the layer 'WrinkleSpec' and close the dialog.

Step 5: Next, you will design a new brush for adding wrinkles to
the skin.

First, create a new brush from the Brush manager, by selecting
File > New….

In the dialog that opens, name the new brush 'WrinkleBrush'.

Double-click on the new brush in the Brush manager to open the
Brush Settings dialog and enter the values shown on the next
page.
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Step 6: Creating a new brush for wrinkles

Step 6: The Brush Settings for
WrinkleBrush

Type: Generic
Store Color: Enabled
Shape: Circle
Profile: Round
Size: 2
Pressure: 80%
Hardness: 0%
Spacing: 25%
Jitter: None (unchecked)
Squeeze: 100%
Rotation: 0˚
Filter: None
Color Mix: None

Note for Graphic Tablet users

Click on the Pressure  Effector Settings (the … to the right of the
Pressure value) and set Pen Pressure  on. This will give you more
control by making your brush pressure dependent upon how hard
you press down on the tablet with the pen. Alternatively you can
use the mouse wheel if you do not use a tablet. The linear default
curve is fine. Click OK.

You may also want to change the Effector Settings for Size and
Hardness – feel free to experiment until you get the right feel.

Step 6: The next step involves setting the color for each of the
channels on which you will be painting. First you must enable
multi-channel painting. You do that by clicking on the multi-
channel icon (on the Paint icon bar, to the left of the channel
icons) so that the green tick is showing.

Next you must enable the channels on which you wish to paint
by clicking on each channel icon in the Layer manager so that
you can see the pencil in the icon.

Step 6: Owners of graphic tablets can use
the Effector Settings to increase pen
responsiveness
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This indicates that the channel is active for painting. Here we
need Diffusion, Bump and Specular Color channels to be selected.

Now we can get down to the task of creating the colors for our
multi-channel color preset. The easy way to do this is to select the
foreground color (from the Paint icon bar)

of each channel in turn and assign the color attributes that we
want. Then we save the colors for the selected channels as one
multi-color preset.

Here are the colors we used for the wrinkle color.

Diffusion Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 90%, G: 90%, B: 90%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Bump Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 25%, G: 25%, B: 25%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A
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Step 6: Saving the Wrinkles multi-
channel color

Now save all these colors together, as a new multi-channel preset;
in the Color manager select Add Multi-Channel Preset from the
File menu.

Name this color 'Wrinkles' in the dialog that appears and then
confirm the dialog (click OK). Now you can just click on this
preset in the Color manager to select the vein multi-channel
colors.

Step 7: Lastly, make sure this color is locked into the WrinkleBrush
brush. First, in the Color manager, ensure that the Wrinkles color
is selected.

Go back to the Brush Settings dialog for the WrinkleBrush (check
that this is selected in the Brush manager) and make sure that
Store Color is active. Now select File > Save As Default… in the
Brush manager to save the settings for this brush.

Confirm the save dialog. This will save your brush for use later,
even after closing the project.

Specular Color Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 20%, G: 20%, B: 20%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Step 7: Ensuring the Wrinkles color is
saved with the WrinkleBrush
brush settings
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Step 8: Now you can begin painting a few wrinkles on the
forehead and around the eyes.

If these settings do not work for you, feel free to change and
modify them to your liking.
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This guy doesn’t look mean enough – and what implies mean
better than bulging veins?

So. again, you will build a multi-channel brush for this exercise.
This one will use, as you might expect, the Color, Diffusion, Bump
and Specular channels.

Step 1: Your ongoing project should already be open. If not, you
can use the 'BaseHead.c4d' project which includes the head with
just the basic skin and eye textures already applied. It’s located in
the 'Tutorials: US: BodyPaint 3D' folder.

If you are continuing with the project from the previous section,
remember to take care of memory management. The more
textures and layers you have in memory, the more RAM that is
required. Even just a few textures can be RAM intensive. A quick
way to save memory is to flatten the layers of each channel.

You do that by selecting the channel in the Layer manager and
using the Flatten Layers function from the Functions menu.

Step 2: Now you’ll add a new layer to the Color channel of your
face material.

With the Face material selected and the color channel active in
the Layer manager, create a new layer as shown on the left.

Open the Bitmap Info dialog.

Name the layer 'VeinColor' and close the dialog.

Double-click on this layer to make it active in the Texture View.

10 Painting Veins

Step 1: Flattening the Color channel
layers to save memory

Step 2: Creating a new Color layer
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Steps 3-5:
Creating new layers for Diffusion,
Bump & Specular Color channels
(we’ve omitted the dialog for Bump)

Step 3: Now a new layer for the Diffusion channel.

With the Face material selected and the diffusion channel selected
in the Layer manager, create another new layer.

Open the Bitmap Info dialog.

Rename the layer 'VeinDiff' and close the dialog.

Step 4: Add a new layer to the Bump channel of your material.

Note

First, make sure that the Bump channel is set to the default 20%
within the Material Editor.

With the Face material selected in the Material manager and the
bump channel selected in the Layer manager, create another new
layer.

Open the Bitmap Info dialog.

Rename the layer 'VeinBump' and close the dialog.

Step 5: Now, finally in this layer section, add a new layer to the
Specular Color channel of your material.

With the Face material selected and the specular color channel
selected in the Layer manager, create another new layer.

Again, open the Bitmap Info dialog.

Rename the layer 'VeinSpec' and close the dialog.
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Step 6: Creating a new brush and the
settings for our vein brush

Step 6: Next, you will create a brush for adding veins to the skin.

First off, let’s get a new brush; go to the Brush manager and
select New from the file menu.

In the dialog that opens, name the new brush 'VeinBrus'.

Double-click on this new brush in the Brush manager to open the
Brush Settings dialog. Enter the following values.

Type: Generic
Store Color: Enabled
Shape: Circle
Profile: Round
Size: 3
Pressure: 100%
Hardness: 0%
Spacing: 25%
Jitter: None (unchecked)
Squeeze: 100%
Rotation: 0˚
Filter: None
Color Mix: None

Note for Graphic Tablet users

Click on the Pressure  Effector Settings and set Pen Pressure  on.
This will give you more control by making your brush pressure
dependent upon how hard you press down on the tablet with the
pen. Alternatively you can use the mouse wheel if you do not use
a tablet. Adjust the curve so that it appears similar to the one in
the illustration to the left. Click OK.

Step 7: The next step involves setting the color for each of the
channels on which you will be painting.

First you must enable multi-channel painting. You do that by
clicking on the multi-channel icon (on the Paint icon bar, to the
left of the channel icons) so that the green tick is showing.

Step 6: Owners of graphic tablets can use
the Effector Settings to increase pen
responsiveness
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Next you must enable the channels on which you wish to paint
by clicking on each channel icon so that you can see the pencil in
the icon. This indicates that the channel is active for painting. In
this example of veins, we will be painting on four channels.

This is how we set up the vein colors for the various channels.

Color Channel

Blending Mode: Normal, 50%
Ignore Filter: Disabled
Type: Solid Color
R: 70%, G: 50%, B: 55%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

This should be a good vein color.

Diffusion Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 95%, G: 95%, B: 95%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

This will darken the veins
extremely subtly.
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Step 7: Saving our multi-channel
Veins color

Bump Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 90%, G: 90%, B: 90%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

This will make the veins seem to
rise off the face a little.

Specular Color Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 50%, G: 50%, B: 50%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

This will give the veins some
shine.

Now save all these colors together, as a new multi-channel preset;
in the Color manager select Add Multi-Channel Preset from the
File menu.

Name this color 'Veins' in the dialog that appears and then
confirm the dialog (click OK). Now you can just click on this
preset in the Color manager to select the vein multi-channel
colors.

Step 8: Lastly, make sure this color is locked into the VeinBrush
brush. First, in the Color manager, ensure that the Veins color is
selected.

Go back to the Brush Settings dialog for the VeinBrush (check
that this is selected in the Brush manager) and make sure that
Store Color is active. Now select File > Save As Default… in the
Brush manager to save the settings for this brush.

Confirm the save dialog. This will save your brush for use later,
even after closing the project.

Step 8: Saving the settings for the
VeinBrush brush
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Step 9: Now you can begin painting a few veins on the temple.

If these settings do not work for you, feel free to change and
modify them to your liking.

Here we have used the bump channel to illustrate the map
because its far more visible than the color channel.

Here’s what the Color channel looks like.
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In this next part of the BodyPaint 3D tutorial, you will add some
scars to make this warrior look somewhat battle-worn.

It is important to note that everyone scars differently. Some scar a
light shade and the skin tends to draw inward. Others, however,
scar outward and the tone of the skin is darker. Be sure to play
with the settings to paint a scar that fits your character. The scars
we will create are more dramatic, gory scars. This warrior doesn’t
stitch his wounds and wears them with pride.

This is another multi-channel brush exercise;  we will concurrently
paint on the Color, Diffusion, Bump and Specular channels.

Step 1: Your ongoing project should already be open. If not, you
can use the 'BaseHead.c4d' project which includes the head with
the basic skin and eye textures applied. As you may well know by
now, it’s located in the 'Tutorials: US: BodyPaint 3D' folder.

If you are continuing with the project from the previous section,
remember that, the more textures and layers you have in
memory, the more RAM is required. Even just a few textures can
be RAM intensive. A quick way to save memory is to flatten the
layers of each channel.

You do that by selecting the channel in the Layer manager and
using the Flatten Layers function from the Functions menu.

Step 2: Now add a new layer to the Color channel of your face
material. With the Face material selected and the color texture
active in the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'ScarColor' and close the dialog.

Double-click on this layer to make it active in the Texture View.

11 Painting a Scar

Step 1: Flattening the Color channel
layers to save memory

Step 2: Creating a new Color layer
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Steps 3-5:
Creating new layers for Diffusion,
Bump & Specular Color channels
(we’ve omitted the dialog for Bump)

Step 3: Now add a new layer to the Diffusion channel.

With the Face material selected and the diffusion channel selected
in the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'ScarDiff' and close the dialog.

Step 4: Now you will add another new layer, this time to the
Bump channel of your material.

With the Face material selected and the bump texture active in
the Layer manager, create a new layer, in the usual way.

Open the Bitmap Info dialog.

Name this layer 'ScarBump' and close the dialog.

Step 5: Now, finally as far as layers go for the moment, add a
new layer to the Specular channel of your material.

With the Face material selected and the specular texture selected
in the Layer manager, create another new layer.

Open the Bitmap Info dialog.

Name this last layer 'ScarSpec' and close the dialog.
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Step 6: Creating a brush for scarring

Step 6: Owners of graphic tablets can use
the Effector Settings to increase pen
responsiveness

Step 6: Next, you will make a brush for adding scars to our hero’s
already less-than-perfect skin.

Start by selecting a new brush from the File menu of the Brush
manager.

In the dialog that opens, name the new brush 'ScarBrush'.

Double-click on this new brush in the Brush manager to open the
Brush Settings dialog.

Now, to get a good brush for scars, set up this dialog as follows.

Type: Generic
Store Color: Enabled
Shape: Circle
Profile: Round
Size: 8
Pressure: 100%
Hardness: 0%
Spacing: 20%
Jitter: 8
Squeeze: 100%
Rotation: 0˚
Filter: None
Color Mix: None

Note for Graphic Tablet users

Click on the Pressure  Effector Settings and set Pen Pressure  on.
This will give you more control by making your brush pressure
dependent upon how hard you press down on the tablet with the
pen. Alternatively you can use the mouse wheel if you do not use
a tablet. The linear default curve is fine. Click OK.

Also, click on the Jitter Effector Settings and set Randomness on.
Set the Randomness value to 15%. Alternatively you can use the
mouse wheel if you do not use a tablet. The linear default curve is
fine. Click OK.

Step 7: The next step involves setting the color for each of the
channels on which you will be painting.
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First you must enable multi-channel painting. You do that by
clicking on the multi-channel icon (found on the Paint icon bar, to
the left of the channel icons at the top of the screen) so that the
green tick is showing.

Next you must enable the channels on which you wish to paint,
by clicking on each channel icon so that you can see the pencil in
the icon. This indicates that the channel is active for painting. In
this case we need all four channels selected in the Layer manager.

This is how we set up the scar colors for the various channels.

Color Channel

Blending Mode: Normal, 50%
Ignore Filter: Disabled
Type: Solid Color
R: 85%, G: 65%, B: 60%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

This should be a good scar color.

Diffusion Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 95%, G: 95%, B: 95%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

This will darken the scar very subtly.
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Step 7: Saving our multi-channel
scar color

Bump Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 100%, G: 100%, B: 100%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

This will make the scars seem to
rise off the face a little. If you
want indented scars, take the
Brightness down to about 10%.

Specular Color Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 35%, G: 35%, B: 35%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

This makes the scars less shiny
than the rest of the face.

Now save all these colors together, as a new multi-channel preset;
in the Color manager select Add Multi-Channel Preset from the
File menu.

Name this color 'Scars' in the dialog that appears and then
confirm the dialog. Now you can just click on this preset in the
Color manager to select the multi-channel colors.

Step 8: Lastly, you should make sure this color is locked into the
ScarBrush brush. First, in the Color manager, ensure that the Scars
color is selected.

Go back to the Brush Settings dialog for the ScarBrush (check that
this is selected in the Brush manager) and make sure that Store
Color is active. Now select File > Save As Default… in the Brush
manager to save the settings for this brush.

Confirm the save dialog. This will save your brush for use later,
even after closing the project.

Step 8: Saving the 'ScarBrush'
brush settings
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Step 9: Now paint all the scars you want. You can even go so
far as to deface the whole head if you wish, have fun with it.

Here we have used the bump channel to illustrate the map
because it is far more visible than the color channel.
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One of the most challenging brushes is the eyebrow brush.

It will be accomplished with two bitmap brushes, and some play
with the rotation setting in the Brush Settings dialog. This way
you can get pretty close to a random feel, and rotate the brush as
you need while painting – to match the arc of the eyebrow. This
brush will use the Color, Diffusion, Bump and Specular channels.

Step 1: Your ongoing project should already be open.

If not, you can use the 'BaseHead.c4d' project which includes the
head with just the basic skin and eye textures already applied. It’s
located in the 'Tutorials: US: BodyPaint 3D' folder.

If you are continuing with the project from the previous section,
remember your memory management. The more textures and
layers you have in memory, the more RAM that is required. Even
just a few textures can be RAM intensive. A quick way to save
memory is to flatten the layers of each channel.

You do that by selecting the channel in the Layer manager and
using the Flatten Layers function from the Functions menu.

Step 2: Now you’ll add a new layer to the Color channel of your
face material.

With the Face material selected and the color texture active in the
Layer manager, create a new layer, as shown on the left.

Open the Bitmap Info dialog.

Rename the layer 'BrowColor' and close the dialog.

Double-click on this layer to make it active in the Texture View.

12 Painting Eyebrows

Step 1: Flattening the Color channel
layers to save memory

Step 2: Creating a new Color layer
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Steps 3-5:
Creating new layers for Diffusion,
Bump & Specular Color channels
(we’ve omitted the dialog for Bump)

Step 3: Now, in a similar way, add a new layer to the Diffusion
channel of your material.

With the Face material selected and the diffusion channel active
in the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'BrowDiff' and close the dialog.

Step 4: Now, in just the same way, add another new layer, but
this time for the Bump channel of your material.

With the Face material selected and the bump channel active in
the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Name the layer 'BrowBump' and close the dialog.

Step 5: Finally, layer-wise, add a new layer to the Specular Color
channel of your material.

With the Face material selected and the specular color channel
active in the Layer manager, create a new layer.

Open the Bitmap Info dialog.

Rename the layer 'BrowSpec' and close the dialog.
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Step 6: A new brush, which will be our
right eyebrow brush

Step 6: The right (top) and left
eyebrow brushes (on a
Macintosh!)

Step 6: Next, you will create two multi-channel brushes for
painting right and left eyebrows on to the skin.

First, let’s have a new brush; go to the Brush manager and select
New… from the File menu.

In the dialog that opens, name the new brush 'BrowBrushR' and
confirm the dialog.

Double-click on the new brush in the Brush manager to open the
Brush Settings dialog and use the following values.

Type: Bitmap
Store Color: Enabled
Bitmap: eyebrow1.jpg
Size: 40
Pressure: 100%
Spacing: 35%
Jitter: None (disabled)
Rotation: 0˚
Filter: None
Color Mix: None

Now save this, which is our right eyebrow brush, from within the
Brush manager using File > Save As Default….

Confirm the save dialog. This will save your brush for later use,
even after closing the project.

Now repeat the above steps to create a left eyebrow brush. Call
this brush 'BrowBrushL' and use 'eyebrow2.jpg' as the bitmap
within the Brush Settings; otherwise, everything else is the same.

Note

You may find it just as easy to duplicate your right eyebrow brush
by selecting it in the Brush manager and using Edit > Duplicate
from within the Brush manager’s menu. You then name this new
brush 'BrowBrushL' and change the Brush Settings to look for the
'eyebrow2.jpg' bitmap. Then save as before.

Alternatively, you can create just one brush and switch the
bitmaps, live, as and when you need a different base image.
Normally, though, it would be more sensible, and easier to use, to
create two, separate brushes.
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Step 7: The next step involves setting the color for each of the
channels you will be painting on. First you must enable multi-
channel painting. You do that by clicking on the multi-channel
icon so that the green checkbox is showing.

Next you must enable the channels you wish to paint on by
clicking on each channel icon so that you can see the pencil in the
icon. This indicates that the channel is active for painting. We
need all the channels set.

This is how we set up the colors for the various channels.

Step 6: Saving a brush, with default
settings (see above)

Color Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 30%, G: 20%, B: 20%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Diffusion Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 80%, G: 80%, B: 80%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Step 6: Using Duplicate to obtain a
new brush (see above)
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Step 7: Saving our multi-channel color

Bump Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 100%, G: 100%, B: 100%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Specular Color Channel

Blending Mode: Normal
Ignore Filter: Disabled
Type: Solid Color
R: 35%, G: 35%, B: 35%
Brightness: 100%
Wallpaper: None
Percentage: N/A
Mode: N/A

Now save all these colors as a new multi-channel preset. In the
Color Settings dialog select Add Multi-Channel Preset from the
file menu.

Name this preset 'Brow' in the dialog that appears and click OK.
Now you can just click on this preset in the Color manager to
reactivate the same multi-channel color, whenever you need it.

Step 8: Lastly, let’s be sure that this color is locked into the
BrowBrush.

First, in the Color manager, make sure the Brow color is selected.

Then go back to the Brush Settings dialog (with the BrowBrush
selected in the Brush manager) and ensure that Store Color is
active. Now save the brush settings as the default for this brush.

Confirm the save dialog. This will save your brush for use later,
even after closing the project.

Step 8: Saving the settings for the
'BrowBrush'
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Step 9: Now try out the eyebrow brushes on both sides, switching
between the two brushes for the right and the left eyebrows; perhaps
even a little goatee beard!

We hope you have enjoyed this BodyPaint 3D tutorial and, above all,
have found it a useful starting point for future work.

Any 3D painting task is complicated and it will take much practice,
together with trial and error to achieve the results you are looking for.
Now, with BodyPaint 3D at your disposal, you have all the tools to
achieve remarkable results.

Have fun!
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