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END-USER LICENSE AGREEMENT
NOTICE.  Please read this Agreement before using the accompanying software and
any documentation (the “Software”).  By using the Software, you agree to be bound by the
terms of this legal Agreement between you, the end user (“User”), and Maui Software.  If
you do not agree to these terms, Maui Software is unwilling to license the Software to you
and you should promptly return the Software together with all accompanying items, disc (if
applicable), package (if applicable) and proof of payment to Maui Software for a full re-
fund.  If you have any questions regarding this Agreement, please contact Maui Software.
LICENSE GRANT.  The copy of the Software accompanying this Agreement is owned by
Maui Software and protected by United States copyright laws and international treaties.  All
rights not expressly granted are reserved by Maui Software.  Upon receipt of full payment
for the Software, Maui Software grants User the right to use one copy of the Software on a
single computer for User's own personal use only.  If User would like to use the Software on
more than one computer, User must purchase a separate license for each additional com-
puter on which the Software is to operate.  RESTRICTIONS.  User may not make any
copies of the Software, except a single backup copy used solely for backup purposes. User
may not decompile, reverse engineer, disassemble, decode or otherwise reduce the Soft-
ware to a human perceivable form.  User may not modify, network, rent, lend, loan, distrib-
ute or create derivative works based upon the Software, in whole or in part.  User may not
electronically transmit the Software from one computer to another or over a network.  User
may not remove from the Software or accompanying materials any copyright or trademark
notices, logos, product or company names, labels or identifications.  WARRANTY DIS-
CLAIMER.  MAUI SOFTWARE DOES NOT WARRANT THAT THIS SOFTWARE WILL
MEET YOUR REQUIREMENTS OR THAT ITS OPERATION WILL BE UNINTER-
RUPTED OR ERROR-FREE.  MAUI SOFTWARE EXCLUDES AND EXPRESSLY DIS-
CLAIMS ALL EXPRESS AND IMPLIED WARRANTIES, INCLUDING THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PUR-
POSE. THESE WARRANTY LIMITATIONS MAY NOT APPLY TO USERS IN SOME
STATES.  DEFECTIVE DISC.  For Users who received from Maui Software the Software
recorded on a disc, User's sole and exclusive remedy for a defective disc shall be either
replacement of the defective medium or refund of the license fee, at Maui Software’s op-
tion, upon return of the Software to Maui Software within thirty (30) days of purchase,
together with all accompanying items, disc, documentation, package (if applicable) and
proof of payment.  LIMITATION OF LIABILITY.  MAUI SOFTWARE SHALL NOT BE
LIABLE FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUEN-
TIAL DAMAGES (INCLUDING LOST PROFITS) ARISING OUT OF THE USE OF, OR
INABILITY TO USE, THE SOFTWARE, EVEN IF MAUI SOFTWARE HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  THESE LIABILITY LIMI-
TATIONS MAY NOT APPLY TO USERS IN SOME STATES.  TERMINATION.  This
license and User’s right to use the Software automatically terminates if User:  (i) fails to
comply with any of the provisions of this Agreement, (ii) destroys the copy and any backup
copy of the Software in User’s possession, or (iii) voluntarily returns the Software to Maui
Software.  Upon termination, User shall cease all use of the Software and destroy, or return
to Maui Software, all copies of the Software then in User's possession, and take such other
actions as Maui Software may reasonably require to ensure that no copies of the Software
remain in User's possession.  GENERAL PROVISIONS.  This is the entire agreement be-
tween the parties relating to the Software, and this Agreement supersedes any purchase
order, communication, advertising or representation concerning these matters.  This Agree-
ment will be governed by and construed in accordance with the laws of the State of Hawaii,
and any dispute arising from this Agreement shall be settled in, and the parties consent to
jurisdiction in, the State of Hawaii.  Should any provision of this Agreement be held to be
void, invalid or unenforceable by a court, the validity and enforceability of the other provi-
sions shall not be affected thereby.  Failure of a party to enforce any provision of this Agree-
ment shall not constitute or be construed as a waiver of such provision or of the right to
enforce such provision.  REGISTRATION AND TECHNICAL SUPPORT.  User shall be
entitled to reasonable technical support from Maui Software only if User registers with
Maui Software by following the registration instructions in the Software.
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Introduction
TimeSlice is a Macintosh application that works in native
mode on both 68K and Power Macintosh computers.
TimeSlice is used for tracking time events while you work, or
when you want to track application use, or any other situa-
tion when time-tracking and recording time events is impor-
tant.

What is the best way to use TimeSlice?
The answer is “whatever works for you is the best way.”
People use TimeSlice in a variety of ways.  It’s suggested
that you read this manual and spend some time experi-
menting with TimeSlice.  Learn its features, and find out
what works best for you.  See the chapter on Hints & Tips
for more information on how to best use TimeSlice.

Technical Support
Before you contact technical support, please search this
document for terms related to your questions.  More than
likely your questions are answered within this manual.

Notes

 This icon precedes an important related note.

Graphics
Some of the graphics  may be hard to see.   If so, try changing the view size or print the manual.
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New for TimeSlice 1.7
❏ Balloon Help.

❏ Apple Guide.

❏ New “Column Names” preference setting allows you to
change the column names.

❏ New comma-delimited export option allows exporting
TimeSlice data as a comma-delimited file.  Some DOS
and Windows applications can only import data in this
format.

❏ Mark Special has a new “match Notes text” option.  This
allows you to mark time records that match text in the
Notes.

❏ New "no sort" option.  Normally to sort by a column you
click on the column title.  Now if you click on the column
title again, sorting is disabled.  Click again, and sorting is
enabled.

❏ And a few minor bug fixes.

In MacOS 8, Balloon Help and the TimeSlice Guide are
available under the Help menu.



rt
Quick Sta

❏ Start TimeSlice by double-clicking on the TimeSlice appli-

cation icon.  It looks like this: 

❏ If you haven't already done so, personalize TimeSlice with
your name, organization and serial number.  A new
TimeSlice window appears.

❏ Click on the Start button  and then click on the Stop

button 

❏ You’ve just created your first time record.  From here you
can add ts, Categories, and Clients to the file.  Edit
the time  using the Edit Time Record window or In-
Line Edi
manual 
 Projec
 values
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ting.  Please see the related chapters in this
for more information.
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Terms used in this manual
Time Record

Each time-line of information on the main window is re-
ferred to as a “time record” or sometimes a “time entry.”

Field
Fields are the individual components of a time record.  For
example, the elapsed time is a field.  So is the paused
time, the start time, and so on.  All the individual fields
make up one time record.

Job
Categories, Clients, and Projects are “Jobs.”

Application
TimeSlice is an application.  Also referred to as a program.

File
You create and save files with TimeSlice.  Also referred to
as a document.

Highlight
Or select, as in highlighting (selecting) a time record (so
that it displays in reverse)

In the figure above, there are two time records highlighted, or selected.

Tracking time
Also referred to as recording time to a TimeSlice docu-
ment.



Page 9

Basics

You can have as many TimeSlice documents open as you
want at the same time (as many as memory permits).  For
example, let’s say you’re working on the document
“Johnson,” and you get a phone call from Mr. Jones.  You
can pause the Johnson document and start the Jones docu-
ment.  When the phone call ends, you stop the Jones docu-
ment, and resume the Johnson document.

The time record with the italicized text is the active time
record, or the time record that is tracking time.  To stop or
pause an active time record, click on the Stop or Pause
button.

Click on a time record to select (highlight) it.  To unselect it,
hold down the command key when clicking on a time record.
Unselect all time records by selecting “Unselect All” from the
Edit menu, or scroll to the end of the list and click just below
the last time record.
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Basic TimeSlice Window Parts
A B C D E F G H I

J K L

A. Tool bar. The icons across the top represent button
shortcuts to the menu items.

B. Status indicator. Green means the timer is active, red  is
off, and yellow is paused.  Set the indicator to black, gray,
and white by clicking on it.

C. Total Marked indicator. When visible, the totals are
calculated from the marked time records.  Otherwise, the
totals are calculated from all time records.

D. Total Elapsed time from all time records or from marked
time records.

E. Grand Total from all time records or from marked time
records (Total Charge plus Total Expenses).

F. On-line help messages. Move the cursor around the
window to display the messages.

G. Total Paused time from all time records or from marked
time records.

H. Total Charge from all time records or from marked time
records.

I. Total Expenses from all time records or from marked
time records.

J. Number of time records in the current document.
K. Charge Budget displays the charge budget, if any.
L. Time Budget displays the time budget, if any.
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TimeSlice Tool Bar

Click on one of the buttons to preform the related action.

Minimize or Maximize the window.

Start recording time.  A new time record is appended
to the list of time records, and the button becomes
the Stop button.  The new time record is the active
time record, and it is displayed in italicized text.

Restart the selected time record or copy & start a
new record (see Preferences—Start/Stop for more
information). This button looks just like the Start
button above except the minute hand is ten after the
hour.  This button is available when only one time
record is selected.

Stop recording time. This button then becomes the
Start button.

Pause recording time. This button then becomes the
Resume button.

Resume recording time. This button then becomes
the Pause button.

Total All time records. This button then becomes the
Total Marked button.
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Total Marked time records. This button then be-
comes the Total All  button.

Mark/unmark the time records given certain specifi-
cations you set.

Edit the selected time records.

Print the time records.

Export the time records.

Preferences.

Time Display options.

Charge and Time Budget.

Mark/unmark the selected time records.

Delete the selected time records.

Search the time records for some text.

Statistics about the time records.

Turn on and off the on-line help messages.
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Creating a Template
Why create a template?  Instead of selecting New from the
File menu and customizing the new file as you want it, you
can instead start a new file from a template.  A template is a
special kind of file that preserves your Categories, Projects,
Clients, window size, and many other of your settings.  Once
you create and save the template, double-click on it next
time you need a new file.  The following steps show how to
create a template file.

Select New from the File menu.
This starts a new TimeSlice document.

Customize the file to your own style.
Adjust the column widths, adjust the size of the window,
set the Time Display, and adjust any other items that you
would like set differently than the default settings.

Create a set of jobs.
Select Projects, Categories, or Clients from the Edit menu
to build your list of jobs.  There is no set way for naming
jobs—whatever works for you is the best way.

Save the file.
Select “Save As Template…“ from the File menu.  Now
when you need a new file with the same settings, instead
of selecting New from the File menu, double-click on the
template file you just created (or select Open from the File
menu).  Instead of the template opening, TimeSlice makes
a copy of the template for you without changing the origi-
nal, and you start working with the copy.
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Editing Time Records

Also see the chapter “In-Line Editing.”

There are several ways to open the Edit Time Record win-
dow:
❏ double-click on a time record, or
❏ click once on the time record(s) and click on the Edit

button in the Tool Bar, or
❏ highlight the time record(s) and select “Time Record…”

from the Edit menu, or
❏ highlight the time record(s) and press the Return or Enter

key.

Click on the Apply button to see the changes before clicking
the OK button.  Click on the Reset button to start over.
Press the Tab key to go from field to field.

Time and Date.  If the time record is the active time record,
then only the Start Time and Start Date can be changed.
Click in one of the time/date fields, and change the value by
clicking on the up or down buttons, or by pressing the up or
down arrow keys on the keyboard.  You can also edit the
values directly using the keyboard.
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These keys preform special functions when editing time and
date values:
Key Function
= Inserts the current day or time
Shift When used with the up and down buttons,

larger increment changes occur.

Adjust Elapsed time.  When checked, the elapsed time is
adjusted automatically when editing some of the time or date
values.  You will probably always want this checked.

Adjust Paused time.  When checked, the paused time is
adjusted automatically when editing some of the time or date
values.

Category, Client, and Project. Use the pop-up menus to
change these items.

Color. Use the pop-up menu to change the color of the time
record.  Caution: changing this value will override the default
value set in the Edit Category, Client, and Project window.

Notes.  Use the Notes section for notes about each time
record.  The standard Macintosh editing commands are
available when entering notes (cut, copy, paste, and clear).
The number above the Notes field shows how many charac-
ters you’ve entered.  The limit is 255 characters.

Expenses. Use the pop-up menu to choose Expenses.
Enter a monetary value for any purpose you want, indepen-
dent of the time settings.  For example, during a time period
you purchased $20 of paper.  You’d enter 20 as the expense,
and maybe describe the purchase in the Notes section.

Hourly Rate.  Use the pop-up menu to choose Hourly Rate.
Caution: changing this value will override the default set in
the Edit Category, Client, and Project window.  To revert
back to the default hourly rate, enter the default hourly rate,
or a minus one (-1).

Mark/Unmark.  Check the box next to “Mark” to mark the
time record.  Uncheck it to unmark the time record.
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In-Line Editing
In-line Editing is a quick and easy way to directly edit a time
record without having to use the Edit Time Record window.
Also see the chapter “Preferences—In-Line Editing.”

All In-line Editing is done by clicking on a highlighted time
record and holding the mouse button down for a short period
of time (approximately 1 second).  See the chapter on Pref-
erences—In-Line Editing to adjust this time period.  The field
available for editing is the field you held the mouse down on.

When the cursor is over an in-line edit field, it will change to
one of the following cursors.

In-line pop-up cursor. This is valid for in-line editing the
Color, Project, Category, or Client fields.

In-line text editing cursor.  This is valid for in-line editing the
Start Date, Start Time, Stop Date, Stop Time, Elapsed,
Paused, Hr Rate, Expenses, and Notes fields.

Mark editing cursor.  This is valid for in-line editing the Mark
field.
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To edit a date or time value, hourly rate, expense, or the
notes, click in the respective field.  Hold the mouse down
until just the field highlights.  Type directly into the field to
make changes.  Press the Enter key or click anywhere
outside of this field when you’re finished editing.

When editing the Stop Time or Stop Date, the time or
date you edit will be the actual stop time or stop date
instead of the displayed stop time or stop date.

When in a time or date field, pressing the = (equals)
key will automatically insert the current date or time.

To edit a job such as a category, project, or client, click in
the respective field.  Hold the mouse down until a pop-up
menu appears.  Choose the job of choice, or select Edit… to
add, delete, or edit the jobs.

To have the pop-up menu selection apply to all highlighted
time records, press the Option key before you use the pop-
up menu.
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To change the color of a time record, click in the color
column.  Hold the mouse down until a pop-up menu ap-
pears.  Choose the color of choice.

To have the pop-up menu selection apply to all highlighted
time records, press the Option key before you use the pop-
up menu.

Selecting a color here will override the color default set
in the Edit Category, Client, and Project window.

To Mark or Unmark a time record, click in the Mark field.
Hold the mouse down until the record toggles to either
marked or unmarked.

To have the selection apply to all highlighted time records,
press  the Option key before you click on the field.
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Projects, Categories, and Clients
Select Projects, Categories, or Clients from the Edit menu to
edit a Job (a Job in this context refers to either a project,
category or client).

Each TimeSlice file has its own list of Jobs.

Add adds jobs to the list.  A window appears where you
enter the job, color, and hourly rate for the job.
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 To quickly add multiple jobs, press the Option key
when clicking OK.  That'll keep this window open.

Edit edits the selected job (or double-click on the job).  A
window appears similar to the Add window where you edit
the job.

Import… imports jobs from another TimeSlice file (the file
you're importing from must not be open).

Export… exports the job list to a tab-delimited text file.  The
format is a list of jobs where each line has the job name, a
tab character, the hourly rate, a tab character, the color, and
then a return character.   Each line is separated by a return
character.

Show unused highlights any jobs not used in the current
document.

Show duplicates highlights duplicate named jobs.

?… displays additional information.

Delete removes the selected jobs.

Sort arranges the jobs alphabetically.

Use hourly rates from pop-up menu lets you choose to use
the hourly rates from either the client, category, or project
list.

Include rates in menu, if checked, also displays the hourly
rate next to the job in any related menus.

Use color from pop-up menu lets you choose to use the
color from either the client, category, or project list.

Always Sort items.  If checked, the jobs in the list are
always sorted.

To keep your changes, click on OK.  To cancel your changes,
click on Cancel.
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Default Time Record

Select Defaults… from the Time menu to set the defaults for
new time records.

New time records can have the same characteristics as the
previously created time record, or they can have the charac-
teristics assigned in this window.

In the figure above, when a new time record is created and
appended to the list of time records, it will have the category,
client, and project as shown in the Defaults window.  The
color and hourly rate are determined by either the project,
category, or client (see the chapter on Project, Categories,
and Clients for more information).  If the check box “Marked”
is checked, new time records will be marked.
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Time Display

Select Display from the Time menu or click on the Time
Display button on the Tool Bar to display the Time Display
window.

This window allows you to change the way TimeSlice dis-
plays the elapsed and paused time for the current file.  When
the display time is changed, the actual time record is not
altered.  Instead some time and date values such as the
Elapsed time, Stop time and Stop date are set to the nearest
increment.  For example, if you set the Time Increment
Rounding to Round up, click on 6 minute increments, and
you work for 13 minutes, the time record will display 18
minutes.  Decimal notation is not available for increments of
1 second.

If Elapsed Time only is selected in the “Apply Time Incre-
ment to” box, the paused time is displayed in one second
increments.
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Password Protection

Select Password Protect… from the File menu to display the
Password window.  Setting a password for a file is described
in the above figure.
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Sorting Time Records
To Sort the time records in ascending order, click on a col-
umn title.  To sort in descending order, hold down the Option
key when clicking on a column title.

To disable sorting, click again on the same column title.
Click again, and sorting is enabled.

The column with the underlined title dictates the sort order.
When you start a new time record, edit a time record, or
even while tracking time, the time records are continually
arranged to maintain the sort order.
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Find
Select Find from the Time menu or click on the Find button
to display this window.  Enter some text and click on Find.

All time records are searched starting from the first time
record.  Upper and lower case letters do not matter.  If the
search text is found in a time record, that time record is
selected and scrolled into view, and the Find button changes
to Find Next.

To find the next time record that contains the search text,
click on Find Next.  If no more time records are found that
contain the search text, the Mac beeps, the search text is
highlighted, and the button reverts to Find.
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Resizing the Columns
1) Move the cursor over a column line in the column title

area.  You’ll see the cursor change.

2) When the cursor changes, hold down on the mouse
button and move the column line to a new location.  In the
example below, the right side of the column Project is
being moved to make the column larger.

3) Release the mouse button.  That’s it!

If the column will not enlarge, increase the document window
size, and try again.

 To obtain the best size for the column data, hold down
the Option key when resizing and the column line will
“snap” to the best size after you release the mouse.
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Combining Time Records

Select Combine… from the Time menu to bring up the Com-
bine Records window.  Combining Time Records combines
two or more similar time records into one record  (similar in
this case means having the same category, client, project,
hourly rate, color and mark characteristics).

The steps involved are:
1) Select two or more similar time records*.
2) Select Combine from the Time menu.
3) Choose the options in the Combine window, and click on

Combine.  If “Combine Notes” is checked, the Notes are
appended together (as much as room permits) and are
separated by a “|” character.

* You can easily select similar time records using the Mark
Special command:

1) Select Mark Special… from the Time menu.
2) Select the category, client, project, and color combinations

of the time records you want to combine.  Click OK.
3) Select “Select Marked” from the Time menu.
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Change Font and Font Size

This window appears after clicking the Change… button
when in the General Preferences window or the Print win-
dow.  Choose a new Font and Font Size from the respective
pop-up menus.

 The more fonts you have installed, the longer it takes
the Font pop-up menu to build, and the longer this
window may take to appear.
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Preferences
For most preferences, click on the Preferences button from
the Tool Bar and select the preference of choice from the
pop-up menu.

Or choose an item in the Preferences sub-menu from the
Edit menu.  However, there are several preferences which
are set by other means.

Status Indicator
Choose a color or black & white status light by clicking on
the status indicator.  This is the indicator that tells if a docu-
ment is recording time, paused, or stopped.  If you have a
black and white monitor, or you are color blind, you may be
better off with the black and white indicator.

Click on the Status indicator to 
change it from a color indicator 
to a black & white indicator.

Help messages on/off.
To turn the on-line button on or off for all documents, click on
the Question mark button in the Tool Bar (it's the last button).
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Preferences—General

For all Preference windows, the box in the lower left portion
of the window displays help messages.  Go to other Prefer-
ence windows by using the pop-up Preferences menu, or
click on the up/down arrows next to the pop-up menu.

Column Settings
Select a column from the Column pop-up menu, and then
set the justification and whether or not to display the column.

Font and text Size
Click the Change… button to change the font and text size
for all time records.

 Some fonts do not display the mark symbol • very
well.  Geneva is a good font to read on the screen.

Display last two currency digits
If Always is checked, numbers such as 123 and 456.78 will
be displayed as 123.00 and 456.78.  If Only when they are
not zero is checked, the same numbers will be displayed as
123 and 456.78.  If Never is checked, the same numbers will
be displayed as 123 and 457.
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Stop date & time are calculated as
If Elapsed Time plus Paused Time is checked, the Stop
date & time are calculated as the Start Time plus the
Elapsed Time plus the Paused Time.  If Elapsed Time only
is checked, the Stop date & time are calculated as the Start
Time plus the Elapsed Time.

Show dates as
Choose how the Start Date and Stop Date are displayed.

Preferences—Auto-Link

Auto-Link “links” other applications to TimeSlice documents.
When TimeSlice is running and the linked application starts
up or is brought to the front of other applications, the linked
TimeSlice document opens (if it is not already open) and
starts tracking time.  When the linked application quits or is
put in the background, the linked TimeSlice document stops
tracking time.

For compatibility reasons, Auto-Link does not link
documents from other applications to TimeSlice
documents—only applications can be linked to
TimeSlice documents.
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“Auto-File Saving” must be on before Auto-Link can be
turned on.  See “Preferences—File Saving” for more infor-
mation on Auto-File Saving.  Additionally, TimeSlice must be
running when you want to use Auto-Link; however, it can be
running in the background.

In the middle of the Auto-Link window is a list of applications
and associated TimeSlice documents.  You can have mul-
tiple applications linked to one TimeSlice document, but you
cannot have one application linked to multiple TimeSlice
documents.

To create a new link, click on the New Link… button.

To edit an existing link, click on the Edit Link… button.

Click on the top Select… button to select the TimeSlice
document.  Click on the bottom Select… button to select the
application.  Click OK to add the items to the Auto-Link list or
make the changes to an existing item in the list.

To delete a link, select an item in the list and click on the
Delete Link button.

To obtain additional help, click on the More Help… button.

To have the name of the application placed in the Notes,
check Put the name of the application in the Notes.
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For example, in the figure above, when Eudora Pro or Claris
Home Page are brought to the front, TimeSlice opens the file
“Johnson” (if it's not already open), creates a new time
record, and puts “Eudora Pro” in the Notes field.

When the timer starts.
If Create a new time record is checked, a new time record
is created every time the linked application is brought to the
front.  If Restart the last time record is checked, the last
time record in the document is restarted.  If you checked
Create a new time record and you get a lot of time records
in your document, see the chapter “Combining Time
Records.“  Combining time records will combine all the
similar time records into one time record.

Preferences—Auto-Pause

Auto-Pause, when activated, automatically places TimeSlice
in Pause mode after a set number of minutes of inactivity, or
when the cursor is moved to a screen “hot-spot.”  If you have
two monitors, the hot-spots refer only to the main monitor
(the monitor that has the menu bar).

In the example above, if there is no mouse movement or
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keys pressed within 10 minutes, or if the cursor is moved to
the upper right corner of the screen, all active TimeSlice
documents go into pause mode.  Afterwards, if the mouse is
moved or a key is pressed, previously active documents
return to tracking mode.

Add idle time to paused time, when checked, it means the
idle time is added to the paused time and subtracted from
the elapsed time when pause mode is activated.  For ex-
ample, if TimeSlice goes into pause mode after 5 minutes of
inactivity, the pause time is increased by 5 minutes and the
elapsed time is decreased by 5 minutes.

Auto-Pause front window only, when checked, means the
frontmost TimeSlice window only will pause.

Preferences—File Saving

Auto-Save files.  Click the On button to have all TimeSlice
files saved to disk at every time interval you select in the
minutes field.

Which time records are highlighted, when checked, tells
TimeSlice to save the highlight state of the time records, and
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highlight them again when the file is reopened.

Scrolled position, when checked, tells TimeSlice to save
which time records are displayed, and scrolls to that position
when the file is reopened.

Timer state, when checked, tells TimeSlice to save the
mode or state of the timer, whether it’s tracking time, paused,
or idle (neither tracking or paused).  When the file is re-
opened, the timer state is resumed.  For example, if you quit
TimeSlice while a file was tracking time, TimeSlice will restart
the timer immediately once the file is reopened.

Save temporary files to the Trash, when checked, it tells
TimeSlice to save any temporary files to the Trash instead of
deleting them.  Each time you save a TimeSlice file to disk,
TimeSlice also creates a temporary file.  Normally this tem-
porary file is deleted after a successful save, but if this option
is checked, the temporary file is instead moved to the Trash.
This  temporary file can be used as a back up file in case of
an emergency (such as a hard disk crash).  However, since
a temporary file is created each time a TimeSlice file is
saved, the temporary files can add up in a hurry, so don’t run
out of disk space!

When this option is checked, the temporary files are moved
to the Trash.
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Preferences—Start Up

Choose how TimeSlice behaves when it starts.

When you double-click on the TimeSlice application icon, it
can open a new document (same as selecting New from the
File menu), display the file open window (same as selecting
Open from the File menu), or neither.

However, if you double-click on a TimeSlice document icon
to start TimeSlice (instead of the application icon), only the
file that you double-click on opens regardless of what is set
here.
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Preferences—Speech

You can choose to have TimeSlice “speak” to you at times.
For example, TimeSlice will speak some error messages and
greet you upon start up if Text to Speech is activated.

If you don’t have Apple’s Text to Speech installed, you will
not be able to use this feature.  To obtain Text to Speech,
visit your nearest Apple dealer, or download a copy from
http://speech.apple.com/.  In the U.S., you can call 800-
SOS-APPL.

Text to Speech, when checked, activates Text to Speech.
Choose the voice of choice from the Voice pop-up menu.
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Preferences—In-Line Editing

Also see the chapter “In-Line Editing.”

Auto-adjust, when on, either the elapsed time or paused
time is adjusted automatically when you in-line edit some of
the time and date values.  You will probably always want
this on.

Activate in-line editing.  To initiate in-line editing of text
items such as the date, time, expenses, and notes, you
move the mouse over one of these fields and hold the
mouse button down for a short time period.  How long you
hold the mouse button down is set by this sliding scale.
When the scale is set to faster, in-line editing is initiated
quickly.  When the scale is set to slower, in-line editing is
initiated slowly (the mouse has to be held down longer).
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Preferences—Start/Stop

When one time record is selected (highlighted), and no time
is being tracked to the file, clicking on the Start button can do
one of several things:

Restarts the selected time record, if selected, causes time
to start recording to that time record again when you click on
the Start button.  Time from when it was previously stopped
up to when it was restarted is recorded as paused time.

Copies the record & Starts a new record with the same
properties, if selected, causes a new time record to be
created and start recording time when you click on the Start
button.  The new time record inherits all the properties of the
previously selected time record, with the possible exception
of the Notes.

Always unselect the active time record when tracking
stops, if checked, clicking on the Stop button will always
unselect the active time record if it is selected.  Otherwise it
is left as is.
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Preferences—Color

The first seven items in the color menu are fixed.  However,
you can assign different colors and names to the remaining
eight items in the color menu.  Enter any text and click on
one of the color rectangle boxes to
change a color.

Use enhanced color highlighting, if
checked, may make most time records
easier to read when they are highlighted,
however, display time may be slower.

Use Label data for the first 7 items, if
checked, the Label data from the Finder
is used for the first 7 items in the color
menu.
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Preferences—Column Names

To change a column name, click on a name in the column
name list, and then edit the name.  Click on another name in
the list to see your changes.  There is a maximum of 31
characters per name.  To reset the names to the default
names, click on the “Set Default Names” button.

In the example above, the column name “Client” has been
changed to “Job Number.”
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File Notes

Select File Notes from the Edit menu to bring up this window.

Enter notes here that are specific to the file.  You can enter
up to 32,768 characters in this window.  If you want to print
what is in this window, select all the text, copy it to the clip-
board, and paste into another application such as
SimpleText.

 Opening and saving a TimeSlice file with TimeSlice
version 1.3 or less will delete the File Notes.

Panning

Panning is a quick and easy way to scroll the time records.
To activate panning, hold down the Space bar, and the
cursor turns into a hand.  With the Space bar down and the
cursor over the time records, press the mouse button and
move the mouse around.  The time records will scroll along
with you.
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Numbers, Dates and Time
Use the Numbers and Date & Time Control Panels to
change the way TimeSlice displays dates, time, and cur-
rency.  This is especially useful for people outside the U.S.
The Control Panels on this page are from System 7.5.

Changes made to these Control Panels will not take effect
until you quit and restart TimeSlice.
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Exporting TimeSlice Data

Click on the Export button or select Export from the File
menu to Display this window.

Exporting extracts the data from the current TimeSlice docu-
ment and saves it to a text file in tab-delimited or comma-
delimited format.   The exported file is readable by almost
every database, spreadsheet, and word processing program.
If you can’t find the file type you want in the File Type pop-up
menu, select “Tab delimited”.

Why export?  For example, let’s say you want to further
analyze and/or customize the printing of the TimeSlice data.
Export the data, and then import it into a database program,
such as FileMaker Pro.  Now you will have much greater
control over how the information looks and prints.

Depending on the application you are exporting to, you may
instead be able to copy the time records from TimeSlice to
the clipboard, and paste them into your database applica-
tion, or drag and drop them from TimeSlice onto another
application (such as Excel).

Export exact time values exports the exact Time values
ignoring how the Time Display is set.
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Export time as it’s displayed exports the Time values as
they are displayed on the TimeSlice window.

Create a new file creates a new file and exports the data to
the new file.

Append to an existing file exports and appends the data to
an existing file.

First record contains the column names inserts the col-
umn names as the first record.

Remove carriage returns from Notes removes the car-
riage return character from the Notes.  The carriage return
character may interfere with some database applications so
it’s recommended to have this checked.

First field of each record contains file name creates an
extra field for each record containing the file name.  This
may be useful in identifying the data in your database appli-
cation.

Always use short dates (more compatible) always exports
the date in short format, which is what most database appli-
cations expect.

Remove currency symbols removes the currency symbols
from fields such as the Expenses.

Export all time records exports all time records.

Export marked time records exports only time records that
are marked.

Export all columns exports all columns whether or not they
are displayed.

Export displayed columns exports only the displayed
columns.

Default Settings sets the options of this window to the
factory default settings.
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Printing TimeSlice Data

Click on the Print button on the Tool Bar or select Print from
the File menu to display this window.

Print exact time values prints the exact Time values ignor-
ing how the Time Display is set.

Print time as it’s displayed prints the Time values as they
are displayed on the TimeSlice window.

File header & page number prints a header and page
number on each printed page.

Column names prints the column names above the col-
umns.

Notes on the next line starts a new line before printing the
Notes.  This gives more room for printing your Notes.

Blank line between records places a blank line between
time records.

Totals prints the totals at the bottom of the last page.

Grid prints a grid.  This usually makes it easier to read the
values.
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Print marked time records prints only time records that are
marked.

Print all time records prints all time records.

Print all columns prints all the columns.

Print displayed columns prints only the columns that are
displayed on the TimeSlice window.

Font & Font Size Change… displays a new window to
change the font and font size for printing the TimeSlice data.

Page Setup… displays the normal Macintosh Page Setup
window.

Print Preview… displays the Print Preview window.

This allows you to view how the TimeSlice data will look
before you print it.

If there are additional pages to view, click on the >> button to
advance to the next page.  Click on the << button to go
backwards.  When the cursor turns to a magnifying glass
icon with a + in it, move it to an area that you want to zoom
into and click.  To zoom back out, click again.

Try changing the column widths, font, font size, or Page
Setup options to fit the data differently on the page.
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Edit Charge Amount
The “Edit Charge Amount” window allows you to quickly
adjust either the elapsed time or the hourly rate of one or
more selected time records given a charge amount.  Select
Charge… from the Edit menu to edit the charge amount.

For example, in the figure below the highlighted time record
shows the hourly rate is $110, and the elapsed time is 4
hours for a total charge of $440.

Even though the job took 4 hours, you have a minimum fee
of $500.  Select the time record you want to adjust, select
Charge… from the Edit menu, enter 500, and click OK.  The
elapsed time is adjusted to 4:33 hours.  Notice that the
charge is adjusted to $500.50.  That’s as close as TimeSlice
can get to $500 given the values it has to work with.
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However, if you wanted to keep the elapsed time at 4 hours
and adjust the hourly rate instead, click on the Adjust
hourly rate button, and click OK.

The hourly rate is then adjusted so that the hourly rate multi-
plied by the elapsed time equals $500.  Remember that this
will override the default hourly rate associated with the job.
If you later change the job for this time record, the hourly
rate will not change.  To reset the hourly rate back to the
default hourly rate associated with the job, enter minus one
(-1) as the hourly rate, using either In-Line Editing or the Edit
Time Record window.
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Set Budget

Select “Set Budget…” under the Time menu, or click on the
Budget button on the Tool Bar, or click on the Charge or Time
budget on the main window to bring up the Budget window.
The budgets you set are for the current document.  Enter a
charge amount and/or an elapsed time amount to set the
budget.

Choose whether or not you want the budget calculated using
all time records or just marked time records, and also the
display options.

After setting up the budget, the budget values are displayed
at the bottom of the TimeSlice document.  The budget, status
bar, and percentage are updated continuously.

Budget remaining or spent Status bar Percentage remaining or spent

If the Charge or TIme goes over budget, the display will be in red.
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Marking Time Records
Marked time records normally represent a subset of a
document’s time records.  This subset can be sorted,
printed, and exported, giving you valuable information.

All totals such as the Total Elapsed and Total Charge are
calculated either from all time records or from marked time
records.  To tell how the totals are calculated on a document,
look for the Total Marked indicator.  It is the black dot just
below the Status Light.

Total Marked indicator

Totals button

When the Total Marked indicator is visible, the totals are
calculated from marked time records.  If it’s not visible, the
totals are calculated from all time records.  Switch between
the two by clicking on the Totals button on the Tool Bar (4th
button from the left), or by selecting “Total Marked Time” or
“Total All Time” from the Time Menu.

Marking New Time Records
Available in the Defaults window, under the Time menu (see
the chapter “Default Time Record”).  When “Marked” is
checked, all new time records are marked.  This could allow
you to total records for a particular session. At the end of the
session you could export just these newly marked time
records to a database program.

Mark Special
This command (under the Time menu or click the Mark
Special button) allows you to mark a subset of time records.
(see the chapter “Mark Special” for more information).
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Mark Special

Select Mark Special from the Time menu or click on the
Mark Special button to bring up the Mark Special window.

Select the category, client, project, and color combination of
the time records you want marked from the pop-up menus
on the right side of the window.  If you want to specify a date
range for the Start Date, use the calendar.  Check Notes
contain the text below if the entered text should be in the
Notes field.  Check Unmark others if you want unmatched
records unmarked.

After clicking OK on this window, you can have the totals on
the main window calculated by the specifications you set
here.  Click on the Totals button on the Tool Bar so that the
Total Marked indicator is visible.

Tips on using the calendar.
❏ Click on a day to select it.
❏ Click on the year or month to advance the year or month.

Press the shift key and the values change faster.
❏ Hold down the option key to move backwards when

selecting the year or month.
❏ Click on “S M T W T F S” to display today’s date.
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Statistics

Select Statistics under the Time menu, or click on the Statis-
tics button on the Tool Bar to bring up this window.

As you click on the various options, the Average Hourly Rate
is calculated and displayed by the methods described in the
window.
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Importing Time Records
TimeSlice imports time values from a text file in tab-delimited
format.  Select Import… from the File menu and select the
text file you want to import.  TimeSlice then displays the data
from the file on the following window.

Click on the << or >> button to scan the data.  The data must
be in the order shown in the window, however, some of the
fields can be missing.  If a field is missing, uncheck the
field's box and the succeeding fields will scroll down.  For
example, in the window below the file that is being imported
does not contain Charge data, so you would uncheck the
Charge box.

Click on the Import button to import the data.
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File Menu
New creates a new, untitled TimeSlice
document.

Open… opens a previously created
TimeSlice document.

Close closes the current TimeSlice
document.

Save saves the current TimeSlice docu-
ment to disk.

Save As… saves the current TimeSlice
document to disk with another name.

Save As Template… saves the current TimeSlice document
to disk as a template or Stationery pad file.  See the chapter
“Creating a Template” and your Macintosh manual for more
information.

Page Setup… displays the standard Mac Page Setup win-
dow.

Print… displays  the standard Mac Print window.

Print One Copy prints the current TimeSlice document once
without bringing up any Print windows.

Export… displays the File Export window.

Import… displays the File Import window.

Password Protect… displays the Password Protection
window.

Minimize/Maximize minimizes or maximizes the current
TimeSlice document.

Quit quits TimeSlice.
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Edit Menu
Cut, Copy, Paste, and Clear
work with text or time records.

Select All either selects all time
records or selects all the text if
you’re working with text.

Unselect All unselects all time
records.

Time Record… displays the
Edit Time Record window.

Charge… displays the Edit
Charge window.

File Notes… displays the File
Notes window.

Projects, Categories, and Clients… displays the Edit Job
window.

Preferences  displays the preferences sub-menu.  Select
one of the items in the sub-menu to bring up that preference
selection.
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Time Menu
Display… displays the Time Display
window.

Defaults… displays the Defaults window.

Combine… displays the Combine Time
Records window.

Mark • Unmark marks or unmarks the
selected time records.

Mark All marks all time records.

Unmark All unmarks all time records.

Select Marked selects (highlights) all
marked time records and unselects
unmarked time records.

Mark Special… displays the Mark Spe-
cial window.

Set Budget… displays the Budget window.

Statistics… displays the Statistics window.

Find… displays the Find window.

Sort… displays a window informing you to click on a column
title to sort the records.

Start, Restart, Copy & Start, Stop, Pause, Resume—
Starts, restarts, copies & starts, stops, pauses, or resumes a
time record.

Total Marked Time when checked, the totals are calculated
from marked time records.

Total All Time when checked, the totals are calculated from
all time records.

Restart
Copy & Start
Stop
Pause
Resume

G
B

H
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Windows Menu
Zoom zooms the current window.  This is the
same as clicking on the window’s Zoom box.

Cascade cascades all open TimeSlice win-
dows to a neat orderly arrangement.

The remaining menu lists all open TimeSlice
documents.  A check mark (√) is next to the name of the
current (frontmost) document.  To bring one of the other
documents to the front, select it from this menu.
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Hints & Tips
Combining multiple files

Suppose you have several people using TimeSlice, and at
the end of some time period (a week, month, etc.), you
want to combine the data.  There are several ways to do
this, two of which are listed here:

Method 1:
1) Have each person give you their TimeSlice file for the

time period.
2) Open all the files.
3) Create a new document.
4) Copy and paste, or drag and drop, the contents of each

file to the newly created document.
5) This new document now contains the combined data.

From here you can print, export, or archive the data.

Method 2:
1) Have each person export their TimeSlice data for the

time period, and have them send you the exported file.
2) Using a database application such as FileMaker Pro,

import each file into the database application.
3) The database application now contains the combined

data.  From here you can print, export, or archive the
data.

Toggle back and forth between Pause and Resume
 for all open documents by pressing the Escape key.

Edit a time record by
❏ Double-clicking on the time record, or
❏ Click on a time record and then select “Time Record…”

from the Edit menu, or
❏ Click on a time record and press the Enter key, or
❏ Click on a time record and click the Edit button.
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Start TimeSlice every time you start your Mac
Put an alias of TimeSlice or of a TimeSlice document in
the “Startup Items” folder.  Here’s how:
1) Click once on the TimeSlice application or a TimeSlice

document to highlight it.
2) Select “Make Alias” from the File menu.
3) Place the alias in the “Startup Items” folder (it’s inside

the System folder).
4) Select Restart from the Special menu.

Printing
Use Legal Paper in Landscape mode if the TimeSlice data
prints off the printed page.  Select Page Setup from the
TimeSlice File menu to set the legal and landscape set-
tings:

Better yet, export the data and import it into a database or
spreadsheet application for better print control and quality.

Exporting
Bypass exporting TimeSlice data and importing into a
database by highlighting the desired time records, select
Copy from the Edit menu, open your database or spread-
sheet file, and select Paste from the Edit menu.  Or if you
have Drag and Drop available, you can drag the time
records and drop them onto another application, or onto
the desktop to create a text clipping file.



Page 61

Display the Totals for the current or active time record
If you want the totals to represent only the active time
record, first unmark all time records, and then mark the
active time record.  Click on the Totals button on the Tool
Bar so that Total Marked Indicator is visible (totals calcu-
lated from marked time records only).  Now the totals are
calculated from the active time record only.  This is espe-
cially handy when the window is minimized.

Create a Template or Stationery pad file
Then you don’t have to recreate your category, client, and
project list every time you start a new file.  See the chap-
ter “Creating a Template” for more information.

Unselect all time records and start a new record
Press Command-U followed by Command-G.

Delete time records quickly
To bypass the delete confirmation alert, hold down the
Option key when clicking on the Trash button.

In-line edit multiple records
To have an in-line edit apply to all highlighted time
records, hold down the Option key when using an in-line
pop-up menu (see the chapter on “In-Line Editing” for
more information).
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Troubleshooting
If TimeSlice starts crashing...

Delete the file “TimeSlice Preferences”
This file is located in the Preferences folder within the
System folder (quit TimeSlice before you delete this file).

Allocate more RAM to TimeSlice
To do this, quit TimeSlice, click once on the TimeSlice
application icon, and select “Get Info” from the File menu.
A small window appears.  Change the Preferred size to a
value larger than the Suggested size.

Increase this number if you have a 
lot of TimeSlice documents open or if 
your TimeSlice files are large.

Restart with Extensions disabled
Select Restart from the Special menu.  After the Mac
makes the startup chime, hold down the Shift key (release
the Shift key after you see the message “Extensions
disabled”).  If TimeSlice works okay now, and it didn’t
previously, you most likely have a system extension or
control panel that is causing a conflict with TimeSlice (and
possibly other applications).  You should remove the
offending extension or control panel, or have it updated.
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Conflicts
Aaron

Does this look familiar?  If so, it's the fault of an extension
called Aaron.  If you suspect a bug in TimeSlice, first restart
your Macintosh with all extensions off (restart the Mac, and
then hold down the Shift key).  If the problem does not hap-
pen with extensions off, then the problem is not with
TimeSlice.
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