
1:  Getting Started
Color It!™ is a powerful, professional-level image editor that  nonetheless maintains
MicroFrontier’s tradition of an intuitive and easy to use program. With Color It!, you can create
original works or manipulate existing images with ease.

This manual contains a Tour section (Chapters 3–7) that takes you step-by-step through the basic
operations of the program, followed by a reference section that explains the features offered by
the program, arranged by palette and menu.

System Requirements
• A color-capable Macintosh (a Mac with a 68020 or greater processor such as SE/30, Mac II,

LC, Performa, Centris, Quadra, most PowerBooks or PowerMacs, or the iMac)

• At least 6 megabytes of random access memory (RAM)

• A hard disk with at least 10 megabytes free

• The MacOS system software version 7.0 or greater

• Video that supports at least 256 grays or colors

The Color It! Program Package
In addition to this manual, your Color It! package should contain the Color It! CD-ROM (or, if
you have the floppy disk version, the disks in a license agreement envelope).

If any of these items are missing, please call MicroFrontier at (515) 225-9800 (outside of the U.S.
or Canada contact your local MicroFrontier distributor or dealer).

Before You Begin
Make a Backup of the Color It! program

If you received the program on floppy disks, it’s a good idea to make a backup copy of the files
on the program disks, just in case anything happens to the original. The original disks are
shipped unlocked. We strongly recommend that you lock these disks to prevent them from
being accidentally erased or overwritten. Store the original and backup disks in a safe place.

Complete and Return the Registration Card
Unless you ordered this copy direct from MicroFrontier, a Registration Card is included with the
software. Returning your card allows us to keep you informed of the latest changes and
improvements in the program.. You must be a registered user to receive technical support.

Know Your Basic Macintosh Operatrions
This manual assumes you are familiar with the basic Macintosh operations—point, click, drag,
open, save, etc. If you are not familiar with these operations, refer to the manual that came with
your Macintosh for more information.

Installing Color It!
It is recommended that you have at least 10 megabytes of free space on your hard drive before
installing.

NOTE: For floppy disk installation, we suggest you first restart your Mac with Extensions off by holding
down the [Shift] key until you see “Welcome to Macintosh. Extensions off.” Certain Extensions may interfere with
the installation (for example, when installing from floppies, you may be asked repeatedly to insert Disk 1, then Disk
2, then Disk 1, etc.)
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To install Color It!, insert the CD-ROM or the first floppy disk in the drive. Double click on
the Color It!™ 4.0 Installer icon to launch the installer program.

A splash screen giving information about the program will appear. Click the Continue button.

Another dialog box with important information about the program and the license follows. Be
sure to read this information before continuing. Click Continue when ready to proceed.

Choose Easy Install from the pop-
up menu to install the complete
package. Custom Install permits
installing individual parts. Click
the Install Location pop-up at the
bottom if you wish to install Color
It! on a different disk than the one
displayed, or if you wish to locate it
in a particular folder. Click the
Install button to proceed with the
installation. Clicking Quit cancels
the installation.

A progress bar will be displayed as
the installation progresses. If you
are installing from floppy disks, 

you will be asked to insert the other disks as the process continues.

A dialog box appears when the installation is complete. Click the Quit button to end the
installation process.

The installer creates a Color It!™ 4.0 folder at the lowest level
within the selected hard disk.

Open the Color It! 4.0 folder and double-click on the
Color It!™ 4.0 icon to start the program.

NOTE: If you wish to start Color It! without loading any third-party
plug-ins (scanner, acquire, export or filter plug-ins), simply hold down
the [Option] key during startup of the program.

NOTE: If you wish to quit Color It! during the startup process, simply type [Command]-[.] (period).
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The first time you use Color It!, you
will be asked to enter your name,
organization (optional) and registra-
tion number. Your registration
number can be found on the back of
the sleeve containing the CD-ROM
or on the back of Disk 1 if you
received Color It! on floppy disks. Be
careful to enter the correct charac-
ters. Once a valid registration
number is entered, the Register
button becomes active. Click the
Register button to log this informa-
tion and finish opening the program.

NOTE: Be sure to write down your Registration number and keep it in a safe place. You will need it
again if you should have to re-install Color It! in the future.

A splash screen for Color It!
appears each time the program is
started. It contains important
information such as the version of
the program, the Registration
information just entered, and how
to reach us at MicroFrontier.

If you are running virtual memory (or programs that
simulate it such as RAM Doubler) this dialog box may
appear. Color It! has its own virtual memory which has
been known to conflict with other virtual memory,
particularly on non-PowerMacintosh computers. Make
sure Color It!’s Preferred Size in the Get Info (in the Finder)
is less than the available RAM for best the performance.

Or you may choose to turn virtual memory off if it is causing problems when using Color It!
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Color It! Document Windows
Color It!’s windows have the same features found in most standard Macintosh windows. There
are also some features unique to this program (see the desktop image below):

The Tools and other palettes always float above your document. For more screen space, the
palettes may be shrunk to just the title bar by clicking on the zoom box (upper right corner of the
palette). Clicking again expands them.

The Magnification Pop-up Menu shows the current magnification or reduction view of
the document. You can change the setting quickly by clicking on the menu and selecting
a new level.

Clicking on the Magnification Buttons changes the view level by one step.
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Magnification Pop-Up Menu

Magnification Buttons

Tools palette

Colors palette

A Special Note for Scanners and
Digital Camera Owners:

If your scanner or digital camera manufacturer provides the
necessary files, you can import files directly into Color It!

See Chapter 3 and consult the documentation provided with
your scanner or camera for more information.



2: What’s New in Version 4.0
Already an easy-to-use, award-winning program, several useful and powerful features have
been added to Color It! version 4.0, particularly in the realm of graphics for the World Wide
Web. A brief summary of the new features follows below. For a more complete description, see
the appropriate chapter in the reference section of the manual.

The Paint Controls Palette
This palette adds several new modes: Multiply, Lighten, Darken and Difference. See
Chapter 8, The Tools Palette for a complete discussion.

The Mouse Coordinates Palette
The new Color pop-up at the top lets you choose to display the color readouts in Decimal,
Percent, or Hex (for Web images). See Chapter 8, the Tools Menu for more information.

The Web Map Palette
This new palette makes it possible
to create and modify web image
maps (a text file that describes 

clickable regions within a graphic that link to an HTML page). See Chapter 10, The Web Map
Palette for more information.

The Animation Palette
This new palette is used to create GIF images
which contain multiple frames that may be
played back in sequence as an animation for
Web pages. See Chapter 11, The Animation
Palette for more information.
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Catalog Palettes
Catalog palettes display thumbnail images of a group of graphic images. Double-
clicking the thumbnails opens the corresponding document in Color It! for editing.
For more information, see Chapter 12, Catalog Palettes.

The File Menu
The Open Recent command displays a submenu of the last 10
documents opened in Color It! Selecting one from the submenu
re-opens it.

The Show pop-up in the Open dialog adds a new file format:
PNG. See Chapter14, the File Menu for more information.

The Save/Save As… dialog adds the new PNG file format, and a number of
other file formats have new options settings:

Macintosh PICT adds the option to save the selection active at
the time the image is saved as a Alpha Channel. (Alpha chan-
nels are used by programs such as Photoshop.)
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JPEG adds the option to save as a progressive JPEG, where a
low-resolution version of the entire image is displayed
immediately on a Web page. Although it may appear coarse
or fuzzy at first, as more data is downloaded, the image
becomes clearer. This permits the viewer see the entire image
quickly and decide whether or not to wait for the rest of the
image information to download.

PostScript adds the option to save a selection as a
clipping path. This permits an irregularly-shaped
image to be placed in another program like
QuarkXPress or Adobe PageMaker without the area
of the image outside of the clipping path visible.

Compuserve GIF adds the option to minimize the color table
for the document. Although GIF is a 256-color file format, an
image using fewer colors can be made smaller by eliminating
unused colors.

The new PNG file format is designed for Web
graphics. It combines some of the best features of
both GIF and JPEG: it is 24-bit (full-color);
supports interlacing/progressive display, and uses
lossless compression. PNG is only supported on the
most recent Web browsers, however.
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The Page Setup dialog now lets
you choose to output your image
with crop and registration marks
(selectable under the  Color It! 4.0
pop-up).

The Print dialog box now offers
options to transmit PostScript
settings to the output device as
ASCII or Binary. Checking
Selection to Clipping Path will
make active selections at the time
of printing function as clipping
paths, so areas of the image out-
side the path will not appear on
the printout.

See Chapter 14, The File Menu for more information on the changes to this menu.

The Edit Menu
General Preferences adds the Auto-
Save on Scan/Import which permits
saving multiple images from digital
cameras or scanners with document
feeders.
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Display Preferences adds a Color Unit pop-up menu that
lets you choose Decimal, Percent or Hex as the default
units for displaying color information.

File Preferences adds a Save Painting Data Only
option that reduces the size of files by saving just the
data fork of the file—especially useful for files being
uploaded to Web servers.

Tool Preferences adds the option to assign any tool
from Color It! to the eraser tip on a tablet stylus that
supports the Wacom Eraser. Simply select the tool
from the pop-up menu.

See Chapter 15, The Edit Menu for more information on the changes to this menu.
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The Image Menu
The Image Type submenu adds three types for color images. CMYK is a 
4-color process (Cyan, Magenta, Yellow, Black) format for color separations.
HSV (Hue, Saturation, Value) and HSL (Hue, Saturation, Lightness) let you
view and edit these values in individual channels.

See Chapter 16, The Image Menu for more information on the changes to this menu.

The Selection Menu
The Add to Web Image Map command adds the active selection to the Web
image map for the document. See Chapter 17, The Web Image Map Palette
for more information.

See Chapter 17, The Selection Menu for more information on the changes to
this menu.

The Filter Menu
The Auto Enhance command is a quick
method of improving poor quality images.
Exposure and contrast can be adjusted the
equivalent of 6 ƒ-stops up or down in
increments of one-third.
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Adjust HSL… has individual sliders to
adjust the hue, saturation and lightness of
an image.

The Remove Red-eye filter automatically searches for the range of colors reflected
by the pupils of an eye when a flash is too close to the camera’s lens  and turns them
to a more normal black color.

Before

After

In the Noise sub-menu, the Quick Dust-off cleans up small imperfections in an image.

The Remove Scratches… filter has
controls to remove or reduce scratches
and larger imperfections.

See Chapter 18, The Filter Menu for more information on the changes to this menu.
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The Tools Menu
The Tools menu adds commands to show or hide two new palettes: The
Animation palette and the Catalogs palette. See Chapter 11, The Animation
Palette and Chapter 12, The Catalog Palette for more information.

See Chapter 19, The Tools Menu for more information on the changes to this
menu.
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3:  Scanning & Importing
The next 5 chapters are a step-by-step tour to familiarize you with the basic tools and functions
available in Color It! By creating an actual design, you will learn to use the tools required to
create it. As each section builds on the steps before it, it’s best to go through this tutorial in
sequential order. Functions and tools not covered in the tutorial section are detailed in the
reference section that follows.

Using Color It! With A Scanner or Digital Camera
Color It! does not provide any direct interfaces with scanners or digital cameras. Generally, the
manufacturer provides a Photoshop-compatible plug-in (usually on a separate disk). That file
may be used to bring images directly into Color It!.

The plug-in file needs to be in a special place on your hard drive
for Color It! to use it. First, make sure you have quit the Color It!
program. then, open the Color It! folder on your hard drive.

Inside you will find a folder named Color It! Stuff. Open that
folder.

Inside you will find a folder named Plug-ins. The plug-
in file must be put inside the Plug-ins folder for it to
work with Color It!.

One you have properly located the plug-in, restart the Color It! program. From the File menu,
choose File-> Scan/Import.

A submenu will have TWAIN Acquire… and Select TWAIN
Source… listed. If you have installed the plug-in properly, its
name will appear on this submenu below Select TWAIN
Source…. If the plug-in’s name does not appear on the menu,
you have not installed it correctly.
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NOTE: Some manufacturers will use TWAIN as a method of bring scans into Color It!. In such a case, follow their
installation instructions, and use the Select TWAIN Source… command to locate the module the first time, and
TWAIN Acquire… thereafter to scan in images.

Each manufacturer produces their own interface for their plug-in. Here’s a sample of how some
of them look:

Microtek’s ScanWizard™ Plug-in Interface (version 3.0.7 shown)

Mustek’s F/B Scanner Plug-in Interface (version 3.0 shown)

For information on how to use the plug-in interface for your particular scanner or digital camera,
consult the documentation provided by the manufacturer or contact their technical support
department.
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What Resolution Should I Use to Scan?
Most scanners today scan between 300 and 1,200dpi (dots per inch). Many people make the
mistake of assuming that scanning at the highest resolution available makes the sharpest scans.
Particularly when scanning continuous-tone images, this is not true. The resulting gigantic file
eats up valuable space on your hard drive, take forever to send to your printer, and once the
information gets to the printer it throws out the excess.

The types of images you would be most likely to scan fall into three major categories: continuous
tone, line art, and halftones.

Continuous Tone
Continuous tone images have areas of color that gradually blend into one
another. The most common type of continuous tone image is a photograph,
although paintings and pencil sketches with varying tones also fall into this
category.

Line Art
Line art is what most people consider to be drawings. The image is comprised of
solid areas of pure black (or a color) and pure white, with no areas of color blend-
ing from one into another.

Halftones
Halftoning is a method used to reproduce continuous tone images in printed mat-
ter such as magazines. It uses a pattern of tiny dots to fool your eye into believing 

the image is a continuous tone. The dots may cause a disagreeable pat-
tern known as a moiré when scanned.

Images for screen display or for the World Wide Web can be safely
scanned at 72dpi. For images to be printed, the most important answer

to know is the resolution of the printer or output device to be used.

Each type of image is handled differently when scanned:

CONTINUOUS TONE IMAGES

Scan at twice the halftone resolution (lines per inch) of the printer. A 300dpi printer, for example,
produces halftones of about 60 lines per inch. Therefore, your scan should be made at 120dpi (2x
60 lpi). For a 600 dpi printer (which produces 75lpi halftones), scan at 150dpi (2x 75 lpi).

LINE ART IMAGES

Scan at the spot resolution of the printer (300dpi for a 300dpi printer, 600dpi for a 600dpi printer,
etc.) You need never scan line art at more than 1,000dpi.

In most cases with multi-color originals, you will want to scan at the highest possible bit depth.
The more colors you capture, the closer the image matches the original. Higher bit depths also
give you more precise control over filtering and image manipulations.
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HALFTONES

This one’s a bit tricky—generally, you should scan at the same settings as for a continuous tone
image, but because of the halftone pattern you may need to experiment. Unless your scanner
plug-in provides a method of descreening to reduce the effect of the pattern, try applying a
Despeckle filter followed by Unsharp Masking in Color It! to help eliminate the unwanted pat-
tern of the halftone dots.

Memory Requirements of Scans
There are three factors which affect the size of the file created by a scan:

Physical size
Physical size is the actual width and height of the area scanned. All other things being equal, an
image that is taller or wider will be a larger file size.

Resolution
The resolution of an image is number of picture elements (pixels) in an image, usually measured
in pixels per inch (ppi) or dots per inch (dpi). As the resolution increases, more detail is captured
and the file size increases. Images scanned at higher resolutions more closely match the appear-
ance of the original image, but there is a point where higher resolution ceases to improve the
image (see What Resolution Should I Use To Scan? earlier in this chapter).

The dpi of a scanner or printer refers to the number of pixels scanned or spots of ink printed in a
square inch. 300dpi means that each square inch of an image is broken into 300 rows and 300
columns, creating a total of 90,000 cells. Likewise, a 600dpi image contains 600 rows and 600
columns, which is a total of 360,000 cells. Thus a 600dpi image contains not twice as much but 4
times as much information as a 300dpi image.

Bit Depth or Color Depth
Bit depth determines how many different colors can be stored in an image, determined by the
Image Type in Color It! Generally, greater bit depths more closely match the colors in the
original:

Image Type Bits per pixel Number of Colors
Black & White (line art) 1 2
16 Colors 4 16
256 Colors 8 256
Thousands of Colors 16 65,536
Millions of Colors 24 16,777,216

Most scanner plug-ins will show you the size your file will be based on these factors. Color It!
calculates the file size in the New Image dialog box as well:
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Here’s some examples of how increasing the bit depth or resolution affects the file size:

Physical Image Size: 2" x 2"

Resolution Bit Depth File Size

72 dpi 1 (B&W) 3 k (kilobytes)
300 dpi 1 (B&W) 45 k
600 dpi 1 (B&W) 176 k

72 dpi 8 (256 colors) 20 k
300 dpi 8 (256 colors) 352 k
600 dpi 8 (256 colors) 1,400 k

1,200 dpi 8 (256 colors) 5,500 k

72 dpi 16 (Thousands) 40 k
300 dpi 16 (Thousands) 703 k
600 dpi 16 (Thousands) 2,700 k

1,200 dpi 16 (Thousands) 11,000 k

72 dpi 24 (Millions) 81 k
300 dpi 24 (Millions) 1,400 k
600 dpi 24 (Millions) 5,500 k

1,200 dpi 24 (Millions) 22,000 k

As you can see,  as the scanning resolution and bits depths increase, the file size increases rapid-
ly. Files may become so large that just a few images may fill your entire hard drive, and working
with very large files takes a long time. Always consider how the scanned image will eventually
be used (on-screen, inkjet printer, laser printer imagesetter or slide presentations, for example).
Capturing more information in a scan than you can use may make huge, unwieldy files that do
not improve the final appearance of the image.

72dpi–too low 300dpi–just right 600dpi–too high
for print output for 150-line screen 4x larger than 300dpi

87k 1MB 4.1MB
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Good Originals Make Good Scans
Images with a good balance of colors and contrast produce the best scans. If the image you are
scanning is imperfect, it is still possible to get fairly good results. The options under Adjustment
in the Filter menu (Levels, Curves, Brightness, etc.) and sharpening can be used to help
compensate for poor quality originals, sometimes with surprisingly good results. The Remove
Scratches filter and Stamp tool are particularly effective in fixing flaws in the original image such
as folds in the paper, streaks, dirt, scratches or other background noise. And you never can tell
what other improvements you can make with Color It!

Original Image

Modified Image

(Levels adjusted, contrast adjusted, unsharp
mask applied, power lines and pole
removed; extra window added on left side)
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4:  The Basics

Tools Palette Introduction
This section introduces the Tools palette and the names of the tools. Most of the
tools appear and perform the same as many other paint programs. For detailed
information about any of the tools, refer to Chapter 8, The Tools Palette, in the
reference section.

If a tool is not visible in the Tools palette, it can be found in the Tool pop-up
menu. The Tool pop-up is located on the top right of the Tools palette.

The Tools palette contains six families of tools:

General Tools: Pointer, Mover, Magnify, and Eyedropper.

Selection Tools: Shape Selection, Lasso, Magic Wand, Zap, Scissors, Crop, and
Bezier.

Brush Tools: Brush, Eraser, Pencil, Air Brush, Blur, Sharpen, Stamp, Smudge, Lighten
and Darken.

Paint Tools: Shape Objects, Paint Bucket, Line, Text, and Gradient tools.

Filter Tool: Kernel Brush tool.

Creating the Background Image 
To begin this tour, we open a less than desirable background image. Next, using several Color It!
filters, the background image is transformed into a visually appealing element in our design.

Layers and Filters
1. Double-click the Color It! icon to start the program.

2. Open the Background.tif located in the Tour folder.

3. In the File menu, select Save As and rename the file Tutorial.tif.

NOTE: Always create a new file before retouching or altering an image to prevent the original from being changed.

4. Double-click the Mover tool to quickly select the fit to window option.
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5. From the Selection menu, choose Selection Type->Off.

Color It! is capable of performing actions on either the entire
image or in a selected area.

6. From the Filter menu, select Image Map->Equalize.

Notice the dramatic difference. Filters can be used to drastically or
subtly alter images. Filters sharpen, distort, alter color, alter style, or
even rectify unusable images such as Background.tif.

7. From the Filter menu, select Adjustment->
Auto Contrast.

Notice the subtle difference this filter has on the
image. Auto Contrast improves an image by
optimizing the brightness and contrast.

8. From the Filter menu, select Adjustment->Curves.

9. Select the Line tool. Click and drag to draw the histogram left to right as shown.

10. Select Contrast in the Selection pop-up menu.

11. Move the Contrast Slider to +45.

12. Click OK.

NOTE: You can alter specific RGB channels, brightness, contrast, gamma, and posterization of an image using the
Slider tool.

Line tool

Slider toolSelection pop-up

Histogram
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NOTE: Your background may not be exactly as displayed in the example. Click Reset if you are not satisfied with
the results and try again.

13. Click OK.

14. Select Save in the File menu or press [Command-S].

Cropping and Changing the Canvas Size
1. From the Selection menu, choose Selection Type-> 

Selection.

2. From the Window menu, choose Show Rulers.

3. Select the Crop tool from the Tool pop-up.

4. Click and drag to select the area in the image you desire for your 
background (approximately 7" wide by 4.25" high).

5. Place the Crop icon inside of the selection.

The Crop tool automatically turns into a Scissor icon within the selection 
when you release the mouse.

6. Click the Scissor icon inside of the selected area.

The portion of the document outside of the selection is deleted.

7. Save your file [Command-S].

8. From the Image menu, select Canvas Size.

The Canvas Size command lets you add extra space to the outside of an image. This can be very
useful when combining images into a new single image, or when you want additional space
around the outside of an image.
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9. Uncheck the Keep aspect ratio check
box.

10. Set the Width .5” wider, approximately
7.5”.

11. Set the Height 1” higher, approximate-
ly 5.25”.

Color It! can increase or decrease canvas sizes
proportionally or in a specified direction. When
adjusting the canvas size of an image, remem-

ber to use the Align pop-up menus to determine where your present image fits in the canvas.
For this Example, leave both Align settings at Center.

12. Click Resize.

13. From the Selection menu, choose Select All or press [Command-A].

14. Select the Mover tool.

15. Click and drag to reposition your image so it fits centered within the new canvas size 
if necessary.

16. Save your image.

NOTE: Select Undo from the Edit menu or press [Command-Z] to revert your actions. Color It! can be set to
undo up to 16 levels. To increase or decrease Undo levels, select Edit->Preferences->General Preferences.

Exploring Image Edges
Now that your background image is smaller than the actual canvas size, the edges are open for
creative opportunities.

1. Click the Magnify tool three times on the top left corner of the image.

NOTE: Press [Option] and the Magnifying Glass tool to decrease your view of the image. Press [Command]
and the Magnifying Glass tool to return to a 1:1 view of the image.

2. Select the Eyedropper.

The Eyedropper is used to pick up a color from the picture or the Colors palette to be used with 
other tools. To select a color from the Colors palette, double-click the Eyedropper.

3. Click in the top left corner of the image to select a fill or foreground color.

Step 11

Step 25

Step 13

Step 22
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NOTE: You can also select gradient colors present in the image. Select the Eyedropper tool. Click and drag within
the image. The Color Bar at the lower left corner of the Tools palette becomes a gradient. The first
color selected is at one end of the gradient and the last color selected is at the other end.

4. Select the Blur tool.

5. Click and hold the Brush Type pop-up.

6. Select the brush second from the left in the top row.

7. Click and hold the Brush Size pop-up.

8. Select 10x10 as the brush size.

9. Click and hold the Blur Intensity pop-up.

10. Select Medium as the Blur Intensity.

11. Click on the left top corner of the image.

12. Hold the [Shift] key and drag to the top right corner of the image.

13. Click on the top right corner of the image.

NOTE: Holding the [Shift] key constrains movement to a horizontal or vertical direction. Notice how the blur con-
nected the two corners.

14. Select the Smudge tool from the Tool pop-up.

15. Click and hold the Brush Type pop-up.

16. Select the brush second from the left in the second row from the top.

NOTE: Solid black brush shapes are not antialiased (soft-edged).

17. Click and hold the Brush Size pop-up.

18. Hold the [Command] key and select 19x6 as the brush size.

Holding the [Command] key permits brushes to be non-proportional.

19. Click and hold the Smudge Options pop-up.

20. Select 30% as the Pressure.

21. Click the Image Only option.

Selecting Image Only allows the Smudge tool to use colors in
the image. Selecting Fill Color allows Smudge to use a specific 

color selected from the Colors palette or from within the image. 
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22. Start from the top right corner of the image; click and drag the mouse in a 
zigzag motion to the bottom right corner.

23. Select the Mover tool. 

24. Drag the image so you are viewing the top left corner again.

NOTE: Hold down [Shift] while using a tool to constrain the scrolling movements to a vertical or hori-
zontal direction.

25. Repeat step 22 on the left side of the image.

Do not alter the bottom edge of the picture.

26. Double-click the Mover tool to restore the image size. 

27. Press [Command-S] to save the image.

NOTE: Feathering is another way to create interesting edges—a soft edge that fades away. See Chapter 6,
Special Effects for more information.

Finishing the Background

1. From the Filter menu, select Noise->Despeckle.

2. In the dialog box, select 10 using the 
slider bar or type 10 in the textbox.

3. Click OK.

4. Save the image.

Below are views showing how the Back-
ground.tif image looked before and after
the steps in this chapter have been com-
pleted. In the next chapter, we learn how
to take selections from one image and
combine them with another.

Before After
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5:  Combining Images
In this section of the tour, you will learn how to extract images from photographs and add them
to your image. Next, you will retouch an image.

1. In the File menu, select Open or type [Command-O].

2. Open Balloon1.tif located in the Tutorial folder.

3. In the File menu, select Save As and save the file as Balloon.tif.

4. In the File menu, select Open or type [Command-O].

5. Open Rose1.tif located in the Tutorial folder.

6. In the File menu, select Save As and save the file as Rose.tif.

NOTE:  All open files are listed at the bottom of the Window menu. A checkmark appears next to the active file.

Adding the Balloon Image
Typically, you locate an image within portions of photographs you desire to use. These portions
must be separated from the overall image before you can manipulate them.

Selecting and Cutting the Balloon
There are several ways to select part of an image; we will explore several of them.

1. Select Balloon.tif from the Window menu. 

2. Double-click the Hand tool to size the image.

3. Select the Lasso tool.

4. Click and hold the Set Lasso Range pop-up.

5. In the Lasso Range display, select Normal.

6. Click and drag the Lasso to draw a circle
around the balloon.

7. Release the mouse near your starting point to 
complete the selection.

The edges of the selection show moving black and white dotted lines (also called “marching
ants”) to indicate the active selection.

Lasso area

Scissor area 

Zap area
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This selects the balloon area of the image. You can also use the other selection tools to reach the
same results. Selections are used by certain tools and procedures in Color It! to define areas.

8. Select the Magnify tool.

9. Click on the bottom right edge of the balloon basket three times to enlarge the 
image view.

10. Select the Scissors tool from the Tool pop-up.

11. Click and hold the Scissors Size pop-up located on the bottom of the Tools palette.

12. Select 2x2 as the Scissors Size.

NOTE: To cut with the Scissors, click at the start point and drag to create small cuts around
the shape. Each cut must overlap. When you reach the end, drag the final cut on top of the
beginning cut point.

13. Click, drag, and click to create small cuts around the inside edge of the balloon. Use the
scroll bars when needed to see other parts of the image.

If you make a mistake, select Undo in the Edit menu or type [Command-Z].

NOTE:  The cuts you made with the Scissors must be connected to remove the outside selection.

14. Select the Magnify tool. Hold down the [Option] key and click three times to reduce 
the image view.

15. Select the Zap tool from the Tool pop-up menu.

16. Click between the balloon area cut with the Scissors tool and the first Lasso area.

The Zap tool deselects the Lasso selection and leaves the balloon cut out selection active.

17. Save the Balloon.tif image.

18. With the balloon still selected, choose Copy from the Edit menu.

19. Choose New from the File menu.

20. From the Fill With pop-up, choose Clipboard.

The settings in the New Image dialog change to reflect
those of the image on the Clipboard.
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20. Click the New button.

A new document is created with the clipboard contents. Since the
Clipboard contained a selection, it appears in the document with a white
background. This can be very useful when a separated image such as the
balloon may need to be used again.

21. Click the Close box in the upper left corner of the window. When 
asked if you wish to save changes, click the Don’t Save button.

Here’s another method to select and remove the balloon:

1. From the Tool pop-up, select the Bezier tool.

The Bezier tool draws an outline with curves that can be adjusted.

2. Click once on the lower left corner of the basket. Then click on the lower right 
corner.

Clicking with the Bezier tool creates straight line segments.

3. Select the Magnify tool.

4. Click on the bottom right edge of the balloon basket twice to enlarge 
the image view.

5. Click once more at the top right corner of the basket. Then click and 
drag down and to the left at the point where the passenger meets 
the bottom of the balloon.

Clicking and dragging creates curved outline segments. A small box called a
control handle is created at the end of a straight line from your click point. The
control handles may be used to reposition a curve after it has been set.
Selecting a control handle with the [Command] key held down snaps both
control handles to points on a single line but maintains the previous lengths.
Selecting a control point with the [Control] key held down permits the single 

control handle to be moved independently. For more information on the Bezier tool, see Chapter
XX, The Tools Palette.

6. Continue to outline the balloon using the Bezier tool.

Use the control handles to fine-tune the outline’s position.

7. When the balloon is outlined and the cursor moves over the starting 
point, a small open circle appears to the right of the cursor.

This indicates that clicking this point will close the outline path.

8. Click on the starting point to close the path.
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9. Move the cursor inside the path and click to make the closed path 
a selection.

A small dotted line square to the right of the cursor indicates that the path
will become a selection. Once clicked, the selection is indicated with moving
black and white dotted lines.

10. Copy the selection using [Command-C].

Scale, Copy and Paste
Besides basic features like cut, copy, and paste, Color It! provides a powerful scaling option you
can use to alter the size of your image proportionally or non-proportionally.

1. Close and save the Balloon.tif image.

2. Select your Tutorial.tif image from the Window menu (or open it from the Tour 
folder if not still open from the previous tutorial chapter).

3. Select Show Rulers in the Window menu.

4. From the Edit menu,select Paste or type [Command-V] to add the balloon to the 
Tutorial.tif image.

5. From the Filter menu, select Adjustment
->Auto Contrast.

The filter is applied only to the active layer.

6. Select Auto Contrast again.

7. From the Filter menu, select Adjustment
->Lighten/Darken or press [Command-L].

NOTE: The last filter used displays as the first option
under the Filter menu. Select Adjustment->
Auto Contrast from the Filter menu or press
[Command-F].

Move the cursor to the small image view
on the far left. Your cursor changes into
the Mover tool allowing you to move the
portion of the image shown in the Before
and After views.

8. Select -10 using the slider or type 
the number in the % text box and 
click OK.

9. From the Image menu, select 
Scale.
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10. Check Smooth scaling.

11. Check Keep aspect ratio.

12. Type 75.00 in the Width Scaling
textbox.

13. Click Scale.

The selected portion of the image is reduced in
size.

14. Click and drag the balloon so the bottom of the basket is 
1.75” from the left and 2.75” from the top.

15. From the Selection menu, select Mask 
Operations->Selection To Mask.

A new mask document is created and appears in front of
the Balloon.tif image. This mask will be used later in the
tour.

16. From the File menu, select Save As and rename the mask Balloon.tif (Mask).

17. From the Window menu, choose Tutorial.tif.

18. From the Selection menu, choose Select None or type [Command-D].

The balloon image becomes part of the image immediately below it.

19. From the File menu, select Save As and 
save the image in the Tiff format. When 
asked “Replace ‘Tutorial.tif’?”, click 
Replace.
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Sharpening Using a Selection Mask
Masks are very powerful tools. They function much like stencils to protect areas allowing you the
ability to add filters, paint, and paste within or outside of the selected mask. Two types of masks
are supported in Color It!: document masks and selection masks. 

Selection masks are created using any of the selection tools. These are temporary masks used to
protect the unselected area.

Document masks are actual files linked to the original document. Document masks are used for
blends, special effects, and image manipulation.

1. Select the Magnify tool and click once to zoom in on the balloon’s basket.

2. From the Selection menu, choose 
Selection Type->Selection.

3. Choose the Shape Selection tool.

4. From the shape selector pop-up, choose the polygon option as in the example 
to the left.

5. Outline the basket of the balloon by clicking around
the basket.

When you return to the first point, the basket is selected.

6. Select the Sharpen tool.

7. Select the settings for the pop-up 
options as shown on the left.

8. Double-click the Sharpen tool to display the Intensity pop-up.

9. Select the Intensity radio button and set the pop-up menu to 50%.

10. Click and drag the Sharpen tool over the selected balloon basket.

The sharpening effect is applied only to the area within the selection.

Before Sharpening After Sharpening

11. Save the image [Command-S].

Using the Balloon Mask Document
Using the Balloon.tif (Mask) document created earlier, you will mask off the balloon in your
image to darken around the right edge of the balloon. Darkening behind the balloon contrasts it
against the background so it appears to be floating.

1. Select the Magnify tool and hold the [Option] key down. Click once to reduce the
image view.
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2. In the Selection menu, select Document Mask-> 
Balloon.tif (Mask).

Notice that the balloon area in the mask is white. White areas in masks are transparent
and accept all actions you perform on the image, including paste, paint or filter. Black
areas are 100% opaque and are completely protected from your actions. Gray areas
allow some of your actions to be applied to the image, depending on the gray level.
Light gray allows greater change than dark gray.

3. From the Window menu, select your Tutorial.tif image.

4. From the Selection menu, choose Selection Type-> Document.

The Selection Type options act as a toggle and turn masks or selections on and off.

5. From the Selection menu, choose Mask Operations->Invert Mask.

This inverts the mask so the balloon is black and the background is white. This allows you to
alter the background without changing the balloon.

6. Select the Darken tool from the Tool pop-up.

7. Select the settings for the pop-up options as shown on 
the left.

8. Click and drag from the top right side of the 
balloon (where the balloon meets the back
ground image), around the image and stop at 
the bottom of the basket.

The Lighten and Darken tools only affect
the image once regardless of how many
times you go over the image. To darken or
lighten more, release the mouse and reapply.

9. Select Magnify and zoom in on the top right corner where you began to darken.

10. Select the Eraser tool.

11. Select the Square Eraser shape.

12. Click and hold the Eraser Size pop-up.
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13. Select the Eraser Size displayed in the example at the left.

14. Press and hold the [Shift] key as you drag the Eraser to remove 
the undesirable shadow against the white edge area.

Remember your mask is still active so you do not have to worry about eras-
ing your balloon. Holding the [Shift] key constrains the Eraser tool to a ver-
tical or horizontal movement.

15. Select the Blur tool.

16. Click and hold the Blur Intensity box.

17. Select Medium as the Blur Intensity.

18. From the Selection menu, choose Selection Type->Off.

19. Click and drag under the balloon basket where the edges appear to be 
unnatural.

20. From the File menu, select Save or type [Command-S].

Creating Basic Shapes
1. Select the Shape Object tool.

2. Click and hold the Shape Object Type pop-up and select the Square Shape
Object tool.

3. Click and hold the Shape Object Frame Width pop-up and select 
1x1 in the Frame Width size.

4. Select and hold the Frame/Fill pop-up and choose the Fill Only option.

5. Click the Fill color area (the smallest area) in the Tools palette.

The 256-color grid appears, and you may also choose colors from this grid.

6. Click on the fifth color from the end of the first column (a gold).
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7. With the Shape Object tool still selected, draw a 
solid color rectangle similar to that shown here.

8. Select the Text tool.

9. Set the pop-up settings to Times, 
Align Left, Bold and Italic, and 36 
Point.

10. Type Sailing Away.

11. From the Colors palette, select the Color Grid button 4th from the left, 
third row from the top.

12. Hold down the [Control] key and drag the type into the position as 
shown.

13. Deselect the type [Command-D].

14. Save the image [Command-S].

Retouching an Image
It is not uncommon for photographs to have imperfections associated with them. Imperfections
occur from hairs on a lens, scratches on the scanned image, and other obscurities such as
computer glitches. Color It! offers a variety of ways to correct imperfections. This tutorial
describes several basic techniques; however, you may choose an alternative method.

1. Select the Rose.tif image in the Window menu.

NOTE: The rose has been previously cut out from a photograph using the Lasso, Scissors, and Zap method used
in extracting the balloon image.

2. Select the Magnify tool and click three times on the petal imperfections.
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Retouching Using the Pencil
1. Select the Pencil tool.

2. Select the square shape in the lower left of the Tools palette.

3. Click and hold the size box.

4. Select the smallest pencil size in upper left corner.

5. Press [Option] and click near the top imperfection.

When you press the [Option] key, the Pencil tool temporarily turns into the Eyedropper
tool for color selection.

6. Click in the imperfection until it is filled.

Retouching Using the Paint Bucket
1. Select the Paint Bucket tool.

2. Click and hold the Fill Sensitivity pop-up in the lower left of the Tools
palette, and select 75% as the Fill Sensitivity.

3. Press [Option] and click near the middle imperfection.

When you press [Option], the Paint Bucket tool temporarily turns into the 
Eyedropper tool for color selection.

4. Click once in the imperfection.

NOTE: Notice that the imperfection did not fill in completely.

5. Open the Tools menu.

Antialiasing blends the fill with the adjacent colors. Note that it
has a checkmark indicating it is on. The Antialiasing command
is a toggle. 

6. Select Antialiasing to turn it off.

7. Click in the imperfection a second time.

This time the imperfection is corrected.

Retouching Using the Brush
1. Select the Brush tool.

2. Set the Brush options as in the example to the left.

3. Press [Option] and click near the middle imperfection.

When you press [Option], the Brush tool temporarily turns into the Eyedropper tool for color
selection.

4. Paint over one of the imperfections.
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Retouching Using the Stamp Tool
1. Select the Stamp tool.

2. Click and hold the Brush Type pop-up in the lower left of the Tools 
palette.

3. Select the Brush Type second from the left in the top row.

4. Click and hold the Brush Size pop-up and select 2x2 as the 
Brush Size.

5. Click and hold the Stamp Operation pop-up, and 
select the Clone Relative option.

6. Press [Option] and click near the middle 
imperfection.

When you press [Option], the Stamp tool places a reference mark that is used as the Stamp tool’s
copy point.

7. Click and drag over the imperfection.

Fixing the Fix
Sometimes after you fix an imperfection it still is not quite right.

1. Select the Smudge tool from the pop-up.

2. Smudge the imperfection using a Smudge Size of 7 and a Pressure around 60.

3. Save the image [Command-S].

Adding the Rose
If you plan to use an image that has been separated from a larger image on a regular basis, you
should save the separated image to a different file (as we did with the balloon in the “Selecting
and Cutting”section earlier in this chapter). This saves time as you do not have to repeatedly cut
the desired portion from the larger file. These cut out images can also be converted and used as
masked images. The rose you will be working with in this section of the tutorial has been saved
in this manner.

The Magic Wand
1. Double click on the Magnify tool to return to a 1:1 view of the Rose.tif file.

2. Select the Magic Wand tool.

3. Click and hold the Wand Sensitivity pop-up located on the bottom left of the 
Tools palette.

4. Select 20% as the Sensitivity.

5. Click on the white area around the rose to select it.

6. From the Selection menu, choose Invert Selection. 

All of the portions of the image not previously selected is now selected (the rose).

NOTE: This is a useful technique when you which to select a multi-colored image against a mostly solid-colored
background.



7. From the Edit menu, select Copy or type [Command-C].

8. Close the Rose.tif image.

Sharpening the Entire Rose
1. From the Window menu, select the Tutorial.tif image.

2. Paste [Command-V] the Rose.tif image.

3. Click and drag the rose into the position 
show in the example below.

4. From the Selection menu, choose Mask 
Operations->Selection To Mask.

A new mask document is created. The rose shape
appears white and the background black. This
mask will be used later in the tutorial.

5. Select Save As in the File menu and 
rename the mask Rose.tif (Mask).

Although Color It! creates a default name for a
mask, it is best to name each mask if you plan to
have multiple masks.

6. From the Window menu, choose Tutorial.tif.

7. With the rose still selected by the mask, select Sharpen->Sharpen (1) from the Filter
menu.

Only the rose is sharpened.

8. Press [Command-S] to save the image.
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6: Special Effects
After finishing this section of the tour, you will understand why Color It! is such a powerful
image editing program. Color It! is limited only by your imagination when it comes to producing
special effects. Have fun and don’t forget [Command-Z] (Undo) when unexpected results occur.

Pattern Effects

Air Brushing with Masks
1. Press [Command-O] and open your Tutorial.tif image.

2. From the Selection menu, choose Document Mask->Open Mask and open the 
Rose.tif (Mask).

3. From the Window menu, select the Tutorial.tif image.

4. From the Selection menu, choose Mask Operations->Invert Mask.

This inverts the mask, making the rose opaque (black) and the background transparent (white).

5. From the Selection menu, choose Selection->Type->Document.

6. Press [Command-Y] or select Colors in the Tools menu to open the Colors palette.

7. Click the Fill rectangle at the top right and click the Pattern button 
underneath it on the right.

8. Select Cool Patterns from the pop-up menu.

9. Select the pattern second from the left in the top row.

You can also create custom patterns by clicking the Edit button.

10.Select the Air Brush tool.

11.Select the round antialiased Brush Type.

12.Select the Brush Size of 30x30.

13. Click and hold the Spray Options pop-up.

14. Select a Flow of 80% and a 46 second Repeat Rate.

15. Double-click the Air Brush icon.

The Brush Options palette opens.

16. Select Fade and a value near 20.

17. Click and drag the Airbrush around the rose image.

As you move the Airbrush tool around the rose, the mask protects it, and the pat-
tern appears only on the image outside of the rose. With the Airbrush, the longer
you hold it in one position, the darker or more opaque the pattern appears.
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18. Save the image.

19. From the Window menu, select the Rose.tif (Mask). Close and save the image.

Adding Text Effects
1. From the Tools palette, select the Text tool.

2. Use the pop-up menus to choose Times, Align Left, Bold and 42 point. 
(Choose Other and enter 42 for the point size in the dialog box).

3. Type the word Ballooning.

To reposition the type box on the image, hold down the [Control] key and click and drag the
text box.

4. Double-click on the Text tool to make the type a selection.

5. Select the Eyedropper tool from the Tools palette.

6. In the Colors palette, click the Eyedropper on the red square that is third from the 
left in the third row. Drag down to the blue square that is third from the left in the 
eighth row.

This creates a gradient blend between the colors that is displayed in the Color Bar on the
Tools palette. Colors may also be selected from an image the same way.

7. Select the Gradient tool from the Tools palette.

8. Click just to the left of the selected type, and drag horizontally 
until the cursor is just to the right of the end of the type.

Holding down the [Shift] key when dragging constrains the cursor
movement to a vertical or horizontal direction.

9. When you release the mouse button, the gradient shown 
in the Color Bar fills the selected type.

10. From the Selection menu, choose Drop Shadow.

11. In the dialog box, set the Feather slider to 5, 
the Intensity to 60%, and the Offset to 4 
pixels horizontal and vertical. Click OK.
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The type now has a soft, natural-looking drop shadow beneath it.

12. Press [Command-S] to save the image.

Adding and Subtracting to Selections
1. Select the Square Selection tool.

2. Create a square as shown at the left.

3. On the Selection Calculator on the Tools palette, Select 
the Plus button.

The [Shift] key is a shortcut for the Plus button on the Selection Calculator.

4. Create a second rectangle to join with the first.

Notice how the two rectangles joined to form one selection.

5. From the pop-up at the lower left corner of the 
Tools palette, select the circular shape.

6. Click the Subtract button or hold down the [Command] key 
and create a circle as shown at the left.

Notice the new circle was cut out of the first rectangle to create the final
irregularly-shaped selection.

Pasting Into Selections
1. Open the Flower.tif file in the Tutorial folder.

2. Press [Command-A] or from the Selection menu, choose Select All.

3. From the Edit menu, choose Copy or press [Command-C].

4. From the Window menu, select the Tutorial.tif.

5. From the Edit menu, select Paste To Fit.

Color It! is capable of pasting clipboard images based on the
current selection. Paste Into places the contents of the Clipboard
into the current selection at the size of the image. Paste Behind
places the contents of the Clipboard behind the selection. Paste To 
Fit places the contents of the Clipboard sized to just fit into the
selection.

6. Save the image [Command-S].



Feather
1. From the Edit menu, select Undo Paste to empty the selection again.

2. With the selection still active, from the Selection menu, choose Feather.

3. In the Feather dialog, Click Outward and enter 20 as the Width 
in the textbox.

4. Click Feather.

The selection area indicated by the moving black and white lines expands
to indicate the new feathered area. Feathering gradually fades the edges of
a selection with its background.

5. From the Edit menu, select Paste to Fit.

The image from the Clipboard is pasted into the soft-edged selection.

6. From the Selection menu, choose [Select None] or type [Command-D].

7. Press [Command-S] to save.

Here is a view of the final document we
have created. The features we have
demonstrated in this chapter show just
some of the broad capabilities of Color
It! to easily produce intricate, exciting
and appealing images. Be sure to check
the reference section of the manual for
complete descriptions of all of Color
It!’s features.

So far, we’ve learned how to bring an
image into Color It! with a scanner or
digital camera; how to work with items
in the Tools palette to create and modi-
fy images; how to isolate portions of
images and combine them with others;
how to utilize layers and masks; and

how to retouch images and perform special effects like painting with patterns, applying gradients to
selections, creating drop shadows and feathering. In the next chapter we’ll discuss how to prepare the
images we’ve created for print output or Web display, and to create animated GIFs.
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7:  File Preparation
After creating an image, certain file preparation is required depending on how it will be used.

File Formats
Color It! can save images in a number of different formats. Each has its own advantages and
uses.

Saving Images in Specific Formats
1. From the File menu, select Save As.

2. Enter a file name in the Save Image As field. 

3. Select a format in the Format pop-up menu.
4. Click the Options button if available.

Several file formats have important Options choices. for more information, see
Chapter 14, the File Menu.

5. Select the appropriate options and click OK.

6. Click Save.

What Is The Best Use For Each Format?
Each format is appropriate for specific uses. For more information on each format and the
specific options available, see Chapter 14, The File Menu.

TIFF is primarily used when the end result is printed output. It is generally the best format to
use when creating graphics to be brought into desktop publishing programs such as
QuarkXPress or PageMaker.

PICT is a universal format for interchange between Macintosh programs. It is fine for on-screen
displays.

JPEG is a compressed format used mostly for Web graphics.

PostScript is used mostly for export to other applications or for print output.

Paint is the old MacPaint file format. Images saved in this format are 8"x10", 72 pixels per inch
black and white only. Images larger than 8"x10" are cropped to that size from the center of the
image.

CompuServe GIF is a compressed format used primarily for Web graphics.

Photoshop 2.0 and 3.0 are used for export to other applications. Selections may be saved as an
Alpha Channel for programs that utilize them. The Photoshop 3.0 file format is the only format
that may be used if you have layered document and wish to retain the layers.

StartUpScreen is the format used to create a graphic for your Mac to display on your screen at
startup instead of the usual “Welcome to Mac OS” graphic. To use an image for this purpose,
name it “StartUpScreen” (no quotes or spaces) and save it in this format inside your System fold-
er.

Photone Prepress is a proprietary format that can only be opened in Color It!™, Color It! or
Photone Prepress. It is used primarily for color-separated images to be imported into other
applications.

Scitex CT (“CT stands for “contone” which is short for “continuous tone”) is a format used by
some high-end color separators for image assembly. It is only available for CMYK images.

QuickTime PICT is a format that permits you to compress images using a form of JPEG
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compression within the QuickTime system extension. It is not the same format as JPEG and you
must have QuickTime installed to open these images.

Web Graphics Formats
Graphics Interchange Format (GIF) is the most popular Web graphics file format. It is supported
by every Web browser, so if you use the GIF format, you can be assured that everyone, every-
where, can view your image.

GIF files also support transparency, which is an attribute that
enables an image to turn the background color transparent so
the Web page behind it shows through. GIF’s compression
scheme is most efficient with areas of solid color.

Data from an interlaced GIF file is arranged to allow for a
faster perceived display. Interlaced GIF files appear on the
screen in a coarse form almost immediately, and then get
progressively sharper.

There are drawbacks to saving your image as a GIF file,
however. GIF is limited to 8-bit color (256 colors). For this
reason, GIF is not the best format to use for multi-color
images and color photographs. GIF delivers better results 

and smaller files for line art and solid colors, icons, graphics, and thumbnail images.

JPEG’s name is derived from the working ISO committee that developed it, the Joint
Photographic Experts Group. Unlike GIF, JPEG does not have transparency but does support an
interlaced option called progressive JPEG, which is supposedly faster than interlaced GIF. JPEG
decompression takes considerably longer than opening GIF files, but saves in 24-bit (full-color)
format. If your image does not need transparency, or if it is a photographic image with a lot of
color depth and shading, JPEG is the better choice.

PNG is a relatively new format designed specifically for Web graphics. It combines some of the
best features of GIF and JPEG: It is 24-bit, supports interlacing, and has lossless compression. The
only disadvantage (at the time of this writing) is that PNG is not yet widely supported in Web
browsers.

Compression
Compression of color graphic images is necessary for Web use. The compression process speeds
up the transfer of graphics images from the Web onto the viewer’s computer screen.

There are two different forms of image-compression techniques: lossless and lossy. With lossless
compression, your decompressed image is identical to the original, which means you get back
exactly what you put in. Lossless compression works well on images that have large solid areas
of color, but it is less effective on more complex images. PNG and GIF uses a lossless form of
compression provides relatively modest amount of compression — about 2:1.

With lossy compression, some image information is
permanently lost. JPEG allows very high compression ratios
— 100:1 or more — but at the expense of fairly obvious blocky
artifacts in the image. The trade-off is between file size and
image quality. Most observers agree that ratios of 10:1 produce
a result that is visually indistinguishable from the original.
Generally, the best setting in Color It!’s options for JPEG is
High.

JPEG compression is a multistage process. It takes the image
data and performs a regularizing process that makes it contain

more repeating patterns than it did originally.
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Decompression is the factor working against JPEG. JPEG decompression takes considerably
longer than opening GIF files, so the time saved by sending a smaller file across the Internet is
usually lost through the decompression process. Thus the contents of your image and the relative
importance of the accuracy of the color reproduction will determine the format to be used.

Preparing An Image For Print

CMYK Color Separation
1. Press [Command-O] and open your Tutorial.tif image.

2. In order to separate the image into its component process colors, choose Image->
Image Type->CMYK.

This converts the image to a process color (Cyan, Magenta, Yellow, Black [K]) image.

NOTE: Once a document is converted to CMYK, you will only be able to view and edit individual channels of the
document. Other than choosing Edit->Undo Conversion, you will NOT be able to return to a full-color composite
view. To be able to accurately edit further in color a document that you wish to convert to CMYK, save a copy in
both the original (RGB) form and, after converting to CMYK, choose Save As… to save a separate CMYK version.
You may wish to add “CMYK” to the end of the file name to distinguish between the two.

Printing An Image
1. From the File menu, select Page Setup.

2. Click the Screen button.

3. Enter the line Frequency and Angle required by 
your image.

4. Select LPI (lines per inch) from the pop-up menu.

5. Select the shape of the dots as 
Round from the Shape pop-up.

NOTE: Checking Use Printer Defaults overrides the
previous options.

6. Click OK to close the Screen dialog.

7. Click OK in the Page Setup dialog box.

8. From the File menu, choose Print.

NOTE: Your print dialog box may differ slightly based on the selected printer and printer driver.
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9. Click the PostScript or Color 
PostScript radio buttons (if you 
have a PostScript printer) or the 
QuickDraw radio button (if you 
have a non-PostScript printer).

NOTE: Most inkjet printers such as
Hewlett Packard, Epson and Apple’s
StyleWriter series are not PostScript print-
ers. The PostScript options will be grayed
out on non-PostScript printers.

NOTE: The Custom Dither option is
used to choose various types of black and
white output.

10. Click Preview.

It is a good habit to always preview
your image before you print it. The
Print Preview dialog allows you to
choose the position on the paper you
want the image to print, either by using
the buttons or by clicking and dragging
the preview image itself.

11. Click OK to close the Print 
Preview dialog.

12. Click Print.

Preparing An Image For The Web
Graphics for the World Wide Web are in many ways the opposite of graphics for print output:
your goal is to produce a low-resolution image while still maintaining a good appearance) and
with the file size as small as possible. 

Resolution is the amount of information stored in an image. Images to be viewed only on-screen
or for display on Web pages only need a low resolution of 72 pixels per inch.

1. Press [Command-O] and open an image.

2. From the Image menu, select Change Resolution.
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3. Enter 72 in the X and Y resolution fields if they are 
not already.

4. Select the Keep aspect ratio option to maintain a 
uniform proportion (width and height) in your 
image.

If you deselect this checkbox, the X and Y resolution may be
changed independently of each other.

5. Click OK.

6. From the File menu, select Save As.

The file formats that can be used for the Web are
CompuServe™ GIF, JPEG or PNG. We’ll use GIF
for this example.

NOTE: Some images are more difficult to convert than
others. Such images (usually photographs, or images
with many shades of the same color) may be better saved
as a JPEG file in Millions of Colors.

7. Click the Options button.

8. Check the Interlaced GIF and Minimize Color 
Table boxes and click OK.

9. In the Save As… dialog box, click OK.

10. With a Millions or Thousands of Colors image, 
you will be asked to convert to 256 Colors.
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NOTE: Once you have reduced the number of colors in an image the information for the larger number of colors is
permanently lost. You may change back to a greater number of colors, but the information is not restored.

Dithering and various color sets are available to be used in the conversion to help you adjust the
image to make it look as good as possible after the conversion. It’s also important to remember
that while most Macintoshes support thousands or millions of colors, many PC/Windows
computers are limited to only 256 colors.

Choosing Netscape Optimized from the Color Set/Other pop-up will use the 216 colors
common to both the Mac and Windows versions of Netscape Navigator that do not dither when
viewed on either platform. Experimenting with various Dither and Color Set settings, the results
can be viewed in the After image at the bottom of the dialog box.

The Optimized radio button has a pop-up to select fewer bits to reduce the bit
depth of the image (and thus reduce file size). The After preview shows the
effect so you may choose the bit depth that best meets your needs or balances
file size and appearance.

11. Choose Netscape Optimized from the Other
pop-up and click OK.

The image is now converted to a 256-color GIF image ready for use on the Web.

For more information on file types and color sets, see Chapter 14, The File Menu and Chapter 9,
The Colors Palette.
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Creating Animated GIFs
An animated GIF is a special type of GIF file that contains multiple images that play back in
sequence on a Web page. Unlike many motion effects for Web pages, no plug-ins are required to
view animated GIFs as they are supported by all modern Web browsers.

Following is the step-by-step process used to create two basic animated GIFs. More information
and specifics about the other options in the animation palette, see Chapter 11, The Animation
Palette.

A simple Cell-Type Animation
1. From the Tools menu, choose the Animation command to make the palette visible if 

it is not already.

2. From the pop-up 
triangle at the 
right choose New 
Animation.

A specialized New
Image dialog box
opens.

3. Use the following settings: Color Set: 256 colors; 
Fill With: White, Width, Height: 72 pixels; 
Resolution: 72 pixels per inch. Click the New 
Button.

A new standard docu-
ment window appears.
Just like in still images
in Color It!, this is
where images or
frames are created and
manipulated.

4. From the Tools palette, select the round Shape Object tool.

5. From the Frame/Fill pop-up on the Tools palette, choose Fill only.

6. From the Colors palette, select the fourth color square from the third row down
for our fill color (red).

7. Create a 20 x 20 pixel red ball in the document.

This may be easier to do with the Mouse Coordinates palette open. Holding the [Shift]
key down when creating the ball constrains it to round shapes only.

8. Use the Rectangular Selection tool, and select the area around the ball.

After the selection is made, Copy [Command-C] for easy repetition of the image.
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9. Move the ball to the upper left of the image as shown.

10. From the palette pop-up, select Add New Frame.

11. In the document, Paste [Command-V] to add the red ball again.

12. Position the ball as shown.

13. From the palette pop-up, select Add New Frame.

14. In the document, Paste [Command-V] to add the red ball again.

15. Position the ball as shown.

16. From the palette pop-up, select Add New Frame.

17. In the document, Paste [Command-V] to add the red ball again.\

18. Position the ball as shown.

19. To give the ball some flexibility, choose Image->Effect->Stretch/Shrink. Drag 
the top handle down to flatten the ball a bit.

20. From the palette pop-up, select Add New Frame. Repeat twice to add two 
more frames.

21. Click on frame 1 in the Animation 
palette to make it the current frame. 
Select All [command-A] in the 
document window, and Copy
[command-C].

22. Click on frame 7 to make it the current 
frame, and Paste [command-V].

23. With Frame 7 still current, choose Flip->Horizontal from the Image menu.

24. Repeat steps 21 and 22 for the remaining frames: 2 & 6 and 3 and 5.

When completed, frames 1, 2 and 3 should be mirror images of frames 5, 6, and 7.

25. Save the image as ball.gif.

26. Click the Run button on the Animation palette to see how your animation looks.

From the pop-up menu, choose Frame Characteristics to adjust the speed of the animation, and
Set Loop Limit to control how many times the animation repeats. Save the image again to retain
these new settings.

That concludes the Color It! tour. Now you’re ready to use the program on your own to create
powerful graphics and great works of art. Be sure to review the reference section that follows for
specific information about all the many features of Color It!. And be sure to visit our web site at
http://www.microfrontier.com/ for tips, updates and other valuable information.
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8:  The Tools Palette
The Tools palette is a floating palette that contains tools that let you view, select and
modify documents.

The palette is closed by clicking the close box in the top left corner. The Tools Palette
command in the Tools menu [Command-T] is a toggle which opens and closes the
palette. The palette is moved by clicking on the title bar and dragging it to a new
position. The Antialiasing command  in the Tools menu is a toggle which turns
antialiasing on and off for many tools.

Additional Tools
Several additional tools are available in the pop-up menu in the upper right side of the
Tools palette. When a tool is chosen, it appears above the pop-up pointer when the menu
closes.

Tools can be re-arranged within the main tool display and between the display and the
additional tools pop-up. See Editing the Tool Palette at the end of this chapter for more
information.

Modifier Tool Shortcuts
Several shortcuts are available by using modifier keys. Unless otherwise noted under the
review for an individual tool, the following are common for all tools:

[Shift]:  constrains the action of the tool to horizontal or vertical movement.
[Option]: changes to the Eyedropper tool.
[Spacebar]: changes to the Mover tool.
[Spacebar-Command]: changes to an enlarging Magnify tool.
[Spacebar-Command-Option]: changes to a reducing Magnify tool.

Note that many tools have features that appear at the bottom of the Tools palette when a
tool is selected. See the section for each tool for specific features for that tool.

General Tools
The General tools are the Pointer, Mover, Magnify and Eyedropper.

Pointer
The Pointer tool lets you move a selection without moving its contents. Clicking outside of a
selection with the Pointer does not deactivate the selection; rather it repositions the selection, 
centered on the mouse click.

While the Pointer tool is selected, you can open the Mouse Coordinates palette by double-click-
ing on the Pointer tool.

Mover
The Mover tool lets you scroll the document when it is too large to fit in the active window. An
active selection is picked up and moved like a floating paste; it does not affect the background 
until deselected.

The three icons at the bottom of the palette control how the document is displayed. The left
icon is Normal Window mode which displays all the standard Macintosh window elements 

as well as Color It!’s magnification pop-up and buttons.

The center icon is Full Screen mode. The document fills the entire screen (except the menu bar) if
the view is large enough. If the view of the document is not large enough, a solid color back-
ground fills the rest of the screen.

The right icon is No Menubar mode, similar to the Full Screen mode except the menu bar is
hidden as well. Although hidden, the menu bar will appear when the mouse button is held
down as you click in the menu bar area at the top of the screen.
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(See Chapter 20, The Window Menu for more information on these modes).

Double-clicking on the Mover zooms the window to fill the screen and resizes the document
view to Fit. Double-clicking again changes the view to 1:1.

[Option] + Mover drags an outline of a mask. This is useful for positioning when one document
is the mask for another.

Magnify
The Magnify tool lets you reduce or enlarge your view of the document.

Clicking and dragging the Magnify tool over a region fills the window with that region when the 
mouse button is released.

Double-clicking on the Magnify tool sets the document view to 1x magnification.

[Command] + Magnify tool sets the document view to 1x magnification and centers the click
point in the window.

[Option] + Magnify tool sets it to reduction mode.

Eyedropper
The Eyedropper tool lets you pick up a color from the document. When you select it, a color bar
and an area selector feature is added to the bottom of the Tools palette.

Clicking in the document fills the bar with the color at the point clicked.

Clicking and dragging fills the bar with a gradient blending from the color where you first
clicked to the color where you released the mouse (If Smooth Gradients is not checked in 

the Preferences (Edit->Preferences->Tools), only solid colors will show in the color bar). The
most recent color becomes the foreground, background or frame color depending upon the color
region currently selected.

Holding the [Option] key while clicking sets the starting color; holding the [Command]
key sets the ending color.

Holding the [Shift] key while clicking or dragging between colors creates a multi-color
blend with up to 16 colors.

Clicking the Eyedropper inside the color bar selects a specific color.

The contents of the color bar can be assigned to the Paint Is and Image Is color bars in the Paint
Controls palette by choosing the Current Colors command.

Clicking on the pop-up at the bottom right corner of the Tools palette changes the
size of the sample area the Eyedropper uses. The color value selected is the average
of the pixels in the area chosen.

Double-clicking on the Eyedropper displays or hides the Colors palette.

[Shift + Option] + Eyedropper changes to the Mover tool.

Selection Tools
The selection tools are the Shape Selection, Lasso, Magic Wand, Zap, Scissors, Crop, and
Bezier.

A selection from these tools can be repositioned from the keyboard. Pressing an [arrow] key
nudges the selection 1 pixel at a time. [Shift-arrow] nudges the selection 10 pixels.

Several of the selection tools (the Shape Selection, Lasso and Magic Wand) tools share the
Grow/Shrink Selection and Selection Calculator features.
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The Grow/Shrink Selection opens a dialog box that
lets you increase or decrease the current selection
area by the percentage you set in the dialog box. As
you move the mouse over the graduated bar, black
pointers show the current range selected. Holding 

the [Command] key down selects only colors lighter than the current selection. Holding the
[Option] key down selects only colors darker than the current selection.

The Selection Calculator Equals button lets you make a new selection. The Plus button (or 
[Shift]) adds and the Minus button (or [Command])
subtracts from the current selection. Selecting with
[Command-Shift] selects the intersection of the two
selections.

Shape Selection
The Shape Selection tool selects an area of a document. When this tool is chosen, the
Grow/Shrink Selection and Selection Calculator (discussed previously) and the Shape Selector
appear at the bottom of the Tools palette.

The Shape Selector offers eleven standard shapes and a custom shape option. Choose
a shape by moving the cursor over the shape and releasing the mouse. The chosen
shape then appears in the Tools palette.

Choosing the Custom Selection from the
shape selector opens a dialog box where the
size and some selection attributes (as well as
adding completely customized shapes) are
chosen for the Shape Selection tool.

Select a shape
from the Shape
pop-up menu. All
of the preset
shapes from the
shape selector are
listed, and can be
customized using
the Constrain to
Ratio (proportion-

al width/height) or Fixed Size buttons. Enter numbers in the Width and Height textboxes for
the ratio or fixed size to be used. The Units pop-up menu next to the Width and Height textbox-
es lets you choose from pixels, inches, centimeters, picas or points.

To create a completely customized shape, first make a selection in the document using any of the
selection tools. With the selection still active, choose one of the Shape Selection tools, hold down
the [Option] key and double-click on the tool to open the Custom Selection dialog box.
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Choose Selection from the Shape pop-up
menu. The  active selection in the document
appears in the square to the right. Choose any
of the other options if desired, and click the
OK button. The selection is now available as
Custom in the Shape pop-up menu and
remains until the process is repeated to create
another custom selection.

Checking the Draw From Center command
draws geometric shape selections expanding
outward from the starting point as the mouse
is dragged.

Double-clicking on the Shape Selection tool toggles between the Select All and Select None
commands.

[Option] + double-clicking on the Shape Selection tool opens the Custom Selection dialog.

Lasso
The Lasso tool lets you make a tight selection around an irregularly shaped object.

Color It! defaults to selecting Normal (all colors). Clicking on the Lasso Range pop-up lets you 
select from other modes.In Normal mode, the Lasso
will grab the entire contents of your selection. Dark
Colors mode selects only darker colors; Light
Colors selects only lighter colors.

Modifier keys permit precise control over the range of colors selected. The [Option] and
[Command] keys change the display to a graduated bar. Dragging the mouse over the bar 

selects all colors from black to that point with the [Option] key
or from white to that point with the [Command] key. As you
move the mouse, a pointer moves along the bar with a selection
box indicating the colors chosen. The Wrap Lasso Around 
Pixels in Range box displays the percentage and color values 
for the range selected. Release the mouse button when the range
you wish is selected, and the Lasso will only select colors in that
range.

The Grow/Shrink Selection and Selection Calculator features are the same as described at the
beginning of the Selection Tools earlier in this chapter.

Double-clicking on the Lasso tool toggles between Select All and Select None.

Magic Wand
The Magic Wand tool is a very powerful and flexible selection tool. A single click on a document
selects a contiguous color area. Dragging the Magic Wand reads all of the colors it passes 
through and selects any contiguous areas containing that range of colors.

Selecting the Magic Wand tool adds a Wand Sensitivity pop-up menu to the bot-
tom left of the Tools palette that controls how many colors are selected when you
click or drag the tool on a document (for example, clicking on a color with a 10%
sensitivity selects all colors within 5% on each side of the selected colors). Low
sensitivity expands the selected range of colors only a few levels; higher sensitivi-
ty adds more levels to those chosen with the tool. As you change the sensitivity, a 

black pointer shows the current level and a gray pointer the previous level.

The Grow/Shrink Selection and Selection Calculator features are the same as described earlier
in this chapter.
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Double-clicking on the Magic Wand toggles between Select All and Select None.

Zap
The Zap tool deletes portions of a selection by clicking on them. Multiple separate regions can be
deleted at one time by clicking and dragging a line through them.

Scissors
The Scissors tool cuts unwanted portions of a selection. 

To use the Scissors tool, click and drag through a selection to cut off
unwanted regions. When the mouse button is released the selection is
divided into separate regions. The Zap tool can then be used to delete
regions.

With the Scissors tool selected, a Line Width feature appears at the bottom left of the
Tools palette. Clicking on it opens a dialog box where the line width can be set.
Moving the cursor within the left box resizes the line widths as you move. Holding
down the [Command] key makes the sizing non-proportional. The width of horizon-
tal and vertical lines are displayed in the box at the upper right.

Crop
The Crop tool deletes any areas of a document outside of the current selection. Only the portion
within the selection is left as the entire document.

After selecting the tool, click on the document and drag to create the selection. Grow
handles are placed at the corners of the selection. Click on one of the handles and
drag to resize the selection.

Moving the cursor inside the selection changes it to a scissor cursor. Clicking crops
the document to the selected area.

Double-clicking the Crop tool opens the Crop Options dia-
log box. You can crop the document to a specific size by
entering values in the Width and Height text boxes. The
Unit pop-up lets you choose pixels, inches, centimeters,
picas or points.

Enter a value in the Resolution text box and choose pixels
per inch or centimeters per inch from the pop-up menu. If
no value is entered in the Resolution text box, the docu-
ment’s present resolution will be used.

Bezier
The Bezier tool draws an outline with modifiable straight segments and smooth curves that may
be used to create a selection.

Click to set the first point, then click at a different point to connect a straight line
with the previous point. Clicking and dragging creates a curved line. To close the
selection, click again on the first point. To make the closed outline a selection,
click inside the outlined area (a dotted line square will appear next to the Bezier
cursor when the outline can be made a selection).
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Curved online points also have control handles that modify
the curves. Moving the control handles adjusts the curves.

The modifier keys change the way online points and con-
trol handles are adjusted. Holding down the [Command]
and [Option] keys adds another point when clicking on the
Bezier line. Selecting an online point with the [Command]
key held down moves the online point.

Selecting a control handle with no modifier keys snaps both control handles to points on a single
line with the same length. Selecting a control handle with the [Command] key held down snaps 

both control handles to points on a single line but
maintains the previous lengths. Selecting a control
point with the [Control] key held down permits the
single control handle to be moved independently.

Once a path is created, clicking the Stroke… button at the bottom of the Tools palette opens a 
dialog where you may click on the Brush, Eraser, Pencil, Airbrush, Blur,
Sharpen, Stamp, Lighten, Darken, Smudge or Kernel Brush and then click
the Stroke button to stroke the Bezier path. The selected tool uses its existing
settings for width, opacity, etc.

The Grow/Shrink Selection and Selection Calculator features are the same
as described at the beginning of the Selection Tools earlier in this chapter.

Brush Tools
The Brush tools are Brush, Eraser, Pencil, Air Brush, Blur, Sharpen, Stamp, Smudge,
Lighten and Darken.

Brush
The Brush tool applies paint and is used to retouch a document. The first two features that
appear at the bottom of the Tools palette when Brush is selected—the Brush Type and Brush 

Size—are common to most of the brush tools: Brush, Air Brush, Blur, Sharpen, Stamp,
Smudge, Lighten and Darken.

The Brush Type pop-up menu contains the different brushes available. The
current brush has a square outline around it, and the outline follows the cur-
sor as you move it over the different brushes. To select a different brush type,
move the cursor over it and release the mouse button. The solid black brush
shapes indicate tools that are not antialiased (soft-edged).

When you click on the Brush Size pop-up (second from the left), a box appears where
the brush size can be set. Moving the cursor within the upper left box resizes the
brush size as you move. Holding down the [Command] key makes the sizing non-
proportional. The width and height of the brush is displayed in pixels in the box at
the upper right.

When you click on the the Brush Opacity pop-up (third from
the left) a box opens that controls the opacity of the paint. As
you change the opacity by moving the cursor over the bar, a
black pointer shows the current level and a gray pointer the
previous level. The percentage shows the current opacity.
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Double-clicking on the Brush tool shows or hides the Brush Options palette. The
Brush Options palette lets you set several controls for a brush at one time. As you
click on the buttons for each box, the slider at the top changes to reflect the setting
for that option. The Opacity functions the same as the Brush Opacity pop-up
described earlier. As you move the button on the slider, the values in the pop-up
menu change.

You can add predefined values by clicking on the pop-up for each control and choosing 
Other… which opens a dialog where a new value can be typed in
the text box. Checking the Add to list checkbox adds the value to
the pop-up menu listing.

Add or delete values to the list by choosing Edit… from the pop-up.
An Edit List dialog box opens with a scrolling list. Click on a value
in the list, and then the Remove button to delete. Typing a new
value in the text box and clicking the Add button adds the value to
the list.

The Gradient option adjusts the overall level of antialiasing for the
brush tools. The amount can be selected with the slider or with the
pop-up using the Edit… or Other… choices described above.

A 0% gradient antialiases from the center in a linear manner. A low percent gradient
creates a smooth but less soft edge. A heavy gradient (100%) creates a harsh edge.

The Spacing option adjusts the spacing of the paint/retouching effect in per-
cent from 0% to 999%. The amount can be selected with the slider or with the
pop-up using the Edit… or Other… choices described above.

The greater the spacing selected, the more space between the areas where a
brush applies paint. With a spacing of 0%, that the computer tries to keep up
with the mouse, but rapid movements may leave gaps in the stroke.

The Repeat option adjusts (in seconds) how quickly Color It! applies paint to
the document. A higher repeat rate results in a faster application. The amount
can be selected with the slider or with the pop-up using the Edit… or Other…
choices described above.
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The Fade option adjusts the type and distance of a brush stroke fade. The top
pop-up menu lets you select a distance in inches for a fade.

The bottom pop-up menu lets you select from seven different types of fades.

When a pressure sensitive device such as a Wacom or
Calcomp tablet is connected, a Tablet option appears at
the bottom of the Brush Options palette. The stylus pen

may be used just like a mouse for pointing, selecting, and dragging.

When used with the Brush, Air Brush, Blur, Sharpen, Stamp, Lighten, Darken or Smudge tools
the stylus pressure can be used to vary tool characteristics such as thickness, opacity, repeat rate
or spacing through the pop-up menu.

The Heavier and Lighter commands control the opacity for the Brush or Stamp, the intensi-
ty of the Blur, Sharpen, Lighten or Darken and the flow of the Air Brush. The Wider and
Thinner commands vary the size of the Brush, Air Brush or Stamp. The Farther and Closer
commands vary the spacing of the tool selected (this overrides the setting in the Spacing
option). The Faster and Slower commands vary the repeat rate (this overrides the setting in
the Repeat option). This works best with the Air Brush to control the frequency of spray.

The command name indicates the direction in which the variable will change as you
increase the stylus pressure (for example, greater stylus pressure with Wider selected
produces a wider stroke as you paint; greater stylus pressure with Thinner selected
produces a thinner stroke as you paint).

NOTE:  Each tool saves its own tablet settings between uses.

The percentage setting represents the sensitivity of the stylus. A sensitivity of 50% means that
each change in pressure will result in a corresponding change in the current option. At low per-
centages, greater pressure is required for even small changes in the option chosen. At high per-
centages, even small pressure changes result in a large change in the option. The amount can be
selected with the slider at the top of the palette or with the pop-up using the Edit… or Other…
choices discussed under the Opacity option.

NOTE: While tablet sensitivity controls the pressure sensitive options, the tablet threshold (usually set in a control
panel) sets the pressure level at which the pen begins to respond. Any pressure level applied below this threshold
will be ignored by the tablet.

If you are working with a tablet but the Tablet option does not appear, check
your connections and the tablet’s control panel. If the tablet is turned off or the
settings are incorrect, a warning message appears at the bottom of the palette. 

Once the tablet is turned back on or readjusted, the Tablet option box will be displayed.

The Paint Controls [Command-U] command opens a palette that controls paint,
paste and filter operations. For paste operations, the slider adjusts the image in real
time. For paint and filter operations, the slider must be set before the operation is
performed.

The Paint Range area of the palette can be hidden or shown
by clicking on the small lever icon at the right side of the
palette.

The Mode pop-up menu controls the effect the operation has on the document.

The slider sets the percentage of the effect. For paste operations, the slider
adjusts the image in real time. For paint and filter operations, the slider
must be set before the operation is performed.
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Blend combines the colors of the original image with those of the image being pasted, painted or
filtered. The Opacity slider controls how much of the original image shows through.

Add lightens the original image by adding the values of the colors you are pasting, painting or
filtering (for example, an area that has a value of 128 with a value of 50 added becomes a value of
178).

Subtract darkens the original image by subtracting the values of the colors you are pasting,
painting or filtering (for example, an area that has a value of 128 with a value of 50 subtracted
becomes a value of 78).

Colorize keeps the luminance of the original image and adds the hue (color) of the new image.
By varying the percentages of the original and new images or paint, you can create color tinting
effects.

Multiply darkens the image by examining the darker areas of the original image and comparing
it to the paste, paint or filter operation being applied.

Lighten compares the value of each pixel in the original image with those of the paste, paint or
filter operation being applied and uses the lighter value.

Darken compares the value of each pixel in the original image with those of the paste, paint or
filter operation being applied and uses the darker value.

Difference compares the value of each pixel in the original image and inverts it based on the
value of the paint or filter operation being applied.

The Paint Is and Image Is pop-up menus let you select from several different options:

The All Colors command uses every color in the Colors palette. Selecting All
Colors for both operations performs a normal paste, filter or paste operation.

The Current Gradient command uses the colors in the Tools palette color bar. The
gradient is created when you drag the Eyedropper tool across the image or when 

you drag the Eyedropper from one color to another in the Colors palette.

In the Equal To or Not Equal To commands, clicking the color bar opens the current 256-color
palette, where you can choose any color you wish. Only the colors in the image which are equal
or not equal to the one selected will be affected by the operation to be performed.

Eraser
The Eraser tool wipes away the image leaving the background color

Two features appear at the bottom of the Tools palette when the Eraser is selected.
The left feature selects a square or round shape. The current shape has an outline
around it.

The pop-up menu on the right side lets you select a size for the Eraser. The current
size has an outline around it. Select the size from the Eraser Size pop-up by moving
the cursor over the shape you wish.

Double-clicking the Eraser erases the entire image on the active layer.

[Shift] +[Option] + Eraser acts as an un-erase tool, returning the erased area to its
state before the last operation was performed.

NOTE: When not in a 1:1 (100%) image view, Choose Tools->Cursor-> Crosshair and Tools->Cursor->
Brush Size to give you a view of the area to be affected by the Eraser.
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Pencil
The Pencil tool changes selected pixels to the foreground color.

Two features appear at the bottom of the Tools palette when the Pencil is selected. The
left feature lets you select either a square or round shape. The current shape has an
outline around it.
The pop-up menu on the right side lets you select a size for the Pencil. The current size
has an outline around it. The Pencil Size pop-up lets you select a size for the tool by
moving the cursor over the shape you wish.

Double-clicking on the Pencil tool toggles between 1x and 8x views of the document.
The 8x magnification makes pixel editing with the Pencil easier.

NOTE: When not in a 1:1 (100%) image view, Choose Tools->Cursor-> Crosshair and Tools->Cursor->
Brush Size to give you a view of the area to be affected by the Pencil.

Air Brush
The Air Brush tool sprays the current foreground color on a document. Selecting the Air Brush
tool adds a number of pop-up features to the bottom of the Tool palette. The Brush Type and
Brush Size pop-ups are described under the Brush tool earlier in this chapter.

The Spray Options pop-up adjusts the Flow and Repeat Rate
of the tool. Entering a higher Flow setting applies more paint to
your document. A lower Flow setting allows more of the docu-
ment to show through. The Repeat Rate adjusts (in seconds)
how quickly paint is applied to the document. As you change
the settings by moving the cursor over the bars, a black pointer
shows the current level and a gray pointer the previous level.
The percentage readouts change to indicate the current settings.

Double-clicking on the Air Brush displays the Brush Options palette (described earlier with the
Brush tool).

[Option] + Air Brush changes to the Eyedropper tool.

Blur
The Blur tool smooths or blurs the document. Selecting the Blur tool adds a number of pop-up
features to the bottom of the Tools palette. The Brush Type and Brush Size pop-ups are 
described under the Brush tool earlier in this chapter.

The Blur Intensity pop-up opens a Blur Intensity display that adjusts the intensi-
ty of the tool as Light, Medium, or Heavy. The heavier the setting, the larger the
sampled region of the document used in the blur process.

The smoothing effect of the tool does not accumulate as you make multiple passes
over the same region—the smoothing is applied only once. To increase the
smoothing effect, first release the mouse then press and drag over the region again.

58 Chapter 8: The Tools Palette Color It!™ 4.0 Manual



If you want a finer adjustment, open the Brush Options palette and use the
Intensity option to change the percentage. The amount can be selected with the
slider or with the pop-up using the Edit… or Other… choices described under the
Brush section earlier in this chapter.

Double-clicking on the Blur tool displays/hides the Brush Options palette.

[Option] + Blur changes to the Eyedropper tool.

Sharpen
The Sharpen tool enhances edges to bring out detail. Selecting the Sharpen tool adds several pop-
up features to the bottom of the Tools palette. The Brush Type and Brush Size pop-ups are 
described under the Brush tool earlier in this chapter.

The Sharpen Intensity pop-up opens a Sharpen Intensity display that adjusts the
intensity of the tool as Light, Medium, or Heavy. The heavier the setting, the
larger the sampled region of the document used in the sharpening process.

The sharpening effect of the tool does not accumulate as you make multiple pass-
es over the same region—the sharpen is applied only once. To increase the sharp-
ening effect release the mouse then press and drag over the region again.

If you want a finer adjustment, open the Brush Options palette and use the
Intensity option to change the percentage. The amount can be selected with the
slider or with the pop-up using the Edit… or Other… choices described under the
Brush section earlier in this chapter.

Double-clicking on the Sharpen tool displays the Brush Options palette.

[Option] + Sharpen changes to the Eyedropper tool.

Stamp
The Stamp tool paints a copy of a document from a point you choose anywhere else in that
document—or from another document.

Selecting the Stamp tool adds a number of pop-up features to the bottom of the Tools palette.
The Brush Type and Brush Size pop-ups are described under the Brush tool earlier in this
chapter.

The Stamp Operation pop-up opens a box that offers several
choices. Clone Relative and Clone Aligned allow you to
select a region of a document by holding down the [Option]
key and clicking on the portion of the document you wish to 

duplicate (you may also select a portion of another document). When painting begins, a copy of
the selected part of the image is painted on top of the current image. Clone Relative paints a 

copy of the selected image from the exact location you first selected,
and each paint operation starts anew from the point set with the
[Option] key. Clone Aligned aligns the image you are painting with
the original location and locks the copied image to the point where
painting first began.

The Snapshot commands differs from the Clone commands in that an image of the entire
document is taken when the Snapshot commands are first applied. Unlike the Clone commands,
any subsequent painting does not reflect changes made by the earlier Snapshot painting—the
original image is still available for painting with the Stamp.
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Last Undo returns the stamped area to its state before the last operation performed. Last Saved
returns the stamped area to its state as of the last save.

Double-clicking Stamp opens the Brush Options palette.

[Option] + Stamp and clicking sets the reference point for the Stamp tool.

Smudge
The Smudge tool smears the document with the fill (foreground) color or the colors in the
document. The effect is similar to dragging your finger across wet ink.

Selecting the Smudge tool adds a number of pop-up features to the bottom of the Tools palette.
The Brush Type and Brush Size pop-ups are described under the Brush tool earlier in this
chapter.

The Smudge Options pop-up opens a display with several
choices. As you change the pressure settings by moving the
cursor over the bar, a black pointer shows the current level
and a gray pointer the previous level. The percentage changes
to indicate the current pressure. The percentage indicates the
amount of color blended with the background. 100% smudges 

an exact copy of the brush stroke over the top of the document. The lower the pressure percent-
age, the shorter the smudge effect is drawn into an edge. The bottom portion lets you choose
whether the smudge uses the fill color or the document image. The current selection is marked
with a black border.

If you want a finer adjustment, open the Brush Options palette and use the
Pressure option to change the percentage. The amount can be selected with the
slider or with the pop-up using the Edit… or Other… choices described under the
Brush section earlier in this chapter.

Double-clicking on the Smudge tool displays the Brush Options palette.

[Shift] + [Option] + Smudge uses only the fill color when smudging.

Lighten
Painting with the Lighten tool lightens the image under the brush. Selecting the Lighten tool
adds a number of pop-up features to the bottom of the Tools palette. The Brush Type and Brush 
Size pop-ups are described under the Brush tool earlier in this chapter. The Lighten Amount 

pop-up opens a dialog box that lets you adjust the effect. As
you change the settings by moving the cursor over the bar, a
black pointer shows the current level and a gray pointer the
previous level. The percentage readouts change to indicate the
current settings.

Double-clicking on the Lighten tool displays the Brush Options palette.

[Option] + Lighten changes to the Eyedropper tool.

Darken
Painting with the Darken tool darkens the image under the brush. Selecting the Darken tool adds
a number of pop-up features to the bottom of the Tools palette. The Brush Type and Brush Size
pop-ups are described under the Brush tool earlier in this chapter. The Darken Amount pop-up 
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opens a dialog box that lets you adjust the effect. As you
change the settings by moving the cursor over the bar, a black
pointer shows the current level and a gray pointer the previous
level. The percentage readouts change to indicate the current
settings.

Double-clicking on the Darken tool displays the Brush Options palette.

[Option] + Darken changes to the Eyedropper tool.

Paint Tools
The paint tools are the Shape Object, Line, Paint Bucket, Text, and Gradient.

Shape Object
The Shape Object tool lets you draw filled shapes. Selecting this tool adds a number of pop-up
features to the bottom of the Tools palette.

The Shape pop-up on the left opens the Shape Selector that lets you choose from 11
predefined shapes or create a custom shape. Choose a shape by moving the cursor
over the shape and releasing the mouse. The chosen shape then appears in the Tools
palette.

Choosing Custom from the pop-up menu or double-clicking on the Shape Object tool opens the
Custom Shape dialog box. See the Custom Selection discussion under the Shape Selection tool
earlier in this chapter for more information.

In the Frame Width pop-up, moving the cursor within the upper left box resizes the
line widths as you move. Holding down the [Command] key makes the sizing non-
proportional. The frame thicknesses in pixels are displayed in the box at the upper
right.

The Frame/Fill pop-up menu lets you select the frame and fill options for the
shape. Frame Only draws a frame for the shape without any fill. Fill Only draws
the selected shape without a frame. Frame and Fill draws the frame of the select-
ed shape and fills it with the fill or foreground color.

Line
The Line tool lets you draw lines. Selecting the Line tool adds a pop-up feature to the bottom of
the Tools palette.

The Line Width pop-up lets you set the width of the lines. Moving the cursor within
the upper left box resizes the line widths as you move. Holding down the [Command]
key makes the sizing non-proportional. The width of horizontal and vertical lines are
displayed (in pixels) in the box at the upper right.

[Shift] + Line constrains the line to horizontal, vertical, or a 45° angle.

[Option] + Line changes to the Eyedropper tool.

Paint Bucket
The Paint Bucket tool fills an area with the fill color. Selecting this tool adds a feature to the
bottom of the palette.

The pop-up opens the Fill Sensitivity menu. Choosing a high percentage of
spread fills the document completely. With a lower percentage of spread, the
Paint Bucket fills until it reaches a boundary or object defined by a color change.
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NOTE: If the edges of a filled area appear fuzzy, Undo the operation, turn off Antialiasing in the Tools menu
(Tools->Antialiasing), and try the Paint Bucket fill again.

Double-clicking on the Paint Bucket fills the entire document.

[Option] + Paint Bucket changes to the Eyedropper tool.

Text
The Text tool lets you add text to a document. When you select the Text tool, Fonts, Style,

Alignment and Size pop-ups are added to the bottom of the Tools palette.

The Font pop-up menu shows all fonts installed in your System and any loaded with
third-party font-organizing products such as Suitcase, Master Juggler or ATM Deluxe.
The current font is indicated with a check mark.

The Style pop-up lets you select the style for text. The current style is
indicated with a check mark.

The Text Alignment pop-up lets you choose the alignment for the text. The current
alignment is indicated with a check mark.

The Text Size pop-up lets you choose a point size for the text. The current size is indicat-
ed with a check mark.

Choosing Other… opens a dialog box where the point
size for the type may be entered in the textbox.

Clicking on a document with the
Text tool creates a rectangular box
with a cursor in it. Text may be
entered by typing or by pasting

from the Clipboard, with most of the normal text editing features available. Double-
clicking on a word in the text box selects it. Clicking while holding down the [Shift] key extends
the selection. The text box can be resized by clicking on one of the handles at the corners of the
text box and dragging. [Shift]-clicking the handles constrains the box to the aspect ratio of the
original. [Command]-clicking the handles varies only the width of the text box. [Control]-click-
ing and dragging permits the text area to be repositioned.

Deselecting the text by clicking outside the box, choosing Selection->Select None [Command-D]
or using a different tool after entering the text combines it with the underlying image and it is no
longer editable by typing.

To convert the text to a selection, double-click the Text tool. The selection can then be
moved. Once it is no longer selected, the text becomes part of the underlying image and is
no longer editable by typing.

Gradient
The Gradient tool lets you create a gradient between colors or custom gradients with up to 16
blends. When you select the Gradient tool, a gradient color bar and a gradient type pop-up is 
added to the bottom of the Tools palette.

The gradient Color It! creates exactly matches the gradient bar at the bottom of the Tools
palette. When you move the crosshair over the active window, two parallel lines show 
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where Color It! will create the gradient.

The line that appears on the side of the crosshair where you start is the
beginning point of the gradient and the opposite line is the ending point.

[Shift] + Gradient constrains the gradients to horizontal, vertical, or 45
degree angle gradients.

Clicking the Gradient Type pop-up opens a dialog where
you choose between Linear (straight line) or Radial 
(circular) gradients.

If no selection is made before using the Gradient
tool, an alert appears informing you that the entire
document will be filled if you proceed.

NOTE: The Smooth Gradients checkbox in Preferences (Edit-> Preferences->Tools) must be checked in order
for gradients to be created.

Clicking on the color bar in the Tools palette opens the Gradient
Editor dialog box with the current gradient displayed at the top.
Here, custom gradients may be created or existing ones modified.
To save a gradient in the top view, click the Add button. To modify
a gradient, click on it from the scrolling list on the left (click again
on the gradient to deselect it). The selected gradient appears at the
top. The triangle pointers indicate a chosen color at that point in the
gradient. Colors can be removed from a gradient by clicking on a
pointer and dragging it away from the display.

To add a color to a gradient, click
on a square. The standard Apple
color picker opens. Select a color, 
click OK, and it appears in the
display showing a blend with the
colors on either side.The color 

can be repositioned by dragging the pointer to any other square. Each color bar can contain up to
16 colors for gradients.

The Append button lets you add custom gradients from other documents. The Remove button
removes a selected gradient from the scrolling list.

Checking the Gradate checkbox for a gradient shows the colors
smoothly blending into one another. Unchecking the Gradate 
checkbox changes the colors to solids with no blending of colors.

NOTE: See the section on the Eyedropper tool earlier in this chapter for more information on creating gradients.

Filter Tool
Kernel

The Kernel tool applies certain filters to an image with the brush settings. Selecting this tool adds
several pop-up features to the bottom of the Tools palette. The Brush Type and Brush Size pop-
ups are described under the Brush tool earlier in this chapter. The Filter List pop-up shows the
same filters that are available by choosing Filter-> Convolution->Kernel.
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Select a filter from the list, choose your brush shape and size and begin paint-
ing on the document. The chosen filter will be applied to the area painted with

the brush.

See Chapter 18, The Filter Menu for more
information about filters.

Editing the Tools Palette
You can edit and save custom tool sets in Color It! Tools can be placed wherever you wish within
the palette and specific attributes can be assigned to each tool. For example, two brushes can
appear in the same palette, one with a round shape and one with a diagonal shape with different
opacities.

To edit the Tools palette, click on a tool and hold down the mouse button. As you
drag the mouse, an outline of the tool follows the pointer. When the outline is moved
over another tool, that tool is highlighted. Releasing the mouse button places a dupli-
cate of the selected tool in that position, and the tool originally in that position is
moved to the Additional Tools pop-up list. Tools in the pop-up can be moved to the
main tool display as well.

NOTE: The Allow Editing of Tool Positions checkbox in the Tool Preferences dialog (Edit->Preferences-
>Tool Preferences) must be checked before the Tools palette can be changed.

The Tool Set Pop-up Menu
The Tool Set pop-up menu controls editing of the Tools palette. It lets you create,
save, reset and select different palettes.

It is important to save any tool sets you wish to keep before rearranging tools. Any
modifications made to the Tools palette are saved when you quit Color It!.

The New Tool Set... command opens a dialog to create a new
tool set based on the current Tools palette. The new tool set
name appears at the bottom of the Tool Set pop-up.

The Reset… command opens a dialog box where you
may return to the Tools palette active when Color It!
was last opened or the original palette settings that
shipped with the program.

All of the available tool palettes are listed at the bot-
tom of the Tool Set pop-up menu. Selecting one
makes it the current palette. To remove a tool set from 

the list, quit Color It! and open the Tool Sets folder in the Color It! Stuff folder. Select the tool set
you wish to remove and drag it to the trash.
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9:  The Colors Palette
The Colors palette is used to select and edit colors and patterns. It can be opened
from the Tools menu [Command-Y] or by double-clicking the Eyedropper tool.

The Back box indicates the color or pattern used for the background color. This fills
holes created when selections not on layers are moved, cleared or cut. The Frame
box indicates the color or pattern chosen for frames. The Fill box indicates the color
or pattern used in painting and fill operations. Click on one of the boxes to select it.
The selected color type is shown with a gray border.

Six different displays are available for the bottom portion of the Colors palette:
HSB Range, Color Wheel, Sliders, Color Grid, Scratch Pad, and Patterns.

HSB Color Range
The HSB Color Range (shown above) displays a graduated range of colors. The color saturation
increases as you move from left to right. The color brightness increases as you move from bottom

to top. The hue for the display is selected by moving the slider at the very bottom of the
palette. Clicking on the H, S or B letters opens a pop-up that lets you re-arrange the posi-
tion for Hue, Saturation or Brightness or change the display to RGB (Red/Green/Blue).
Select a color by clicking in the display.

Color Wheel
The Color Wheel shows a graduated range of colors., Hues or colors shown are
fully saturated at the outside edge and decrease as you move toward the center.

The pop-up menu lets you choose between HSB Wheel (Hue-
Saturation-Brightness) and HSL Wheel (Hue-Saturation-Lightness).

In HSB Wheel, the slider at the bottom controls the brightness. In HSL Wheel, the
slider controls the lightness.

Sliders
Sliders displays controls used to change the selected color. The pop-up lets you

choose between RGB, HSB, CMY and Grayscale sliders. The
sliders are adjusted by clicking and dragging on the button.
Clicking on the pointers at each end changes the settings one
unit at a time. Changes made are reflected in the selected color 

box (Back, Frame or Fill) at the top of the palette.
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Color Grid
The Color Grid displays colors that may be chosen by clicking on a color square.

The pop-up menu gives you a choice of palettes of different
colors. The number of colors displayed depends on the type
of document open. A grid of 256 colors will appear for
documents with 256 colors to millions of colors; documents

with 16 or fewer
colors will display
a grid of 16 colors.
Grayscale docu-
ments with 256
levels show a grid
of 256 grays;
documents with 16 

or fewer grays display a grid of 16 gray levels. Specialized color sets or those you create or
modify appear at the bottom of the list.

NOTE: The Netscape Optimized color set contains the 216 colors common to both the Mac and Windows
versions of Netscape and other browsers. These colors will not dither when used on a web page.

Clicking the Edit button brings up a dialog box where color
sets are edited or created. Clicking on the Color Set pop-up

at the upper left lets you choose
from existing sets or create a new
color set.

Selecting New
Set… opens a
dialog box where
the name of the
new set is
entered. The
Color Set Size
pop-up lets you 

choose the number of colors in the set (16, 36, 64 or 256). Clicking OK saves the new set in the
Color Sets folder inside the Color It! Stuff folder). New sets are always grayscale until edited.

Color squares are selected by clicking on them. Use the Copy and Paste buttons to place selected
colors in other grid squares.

Clicking the Clear button changes selected color squares to black.

The Undo/Redo button is a toggle that lets you reverse the last action taken for selected squares.

The Pick button opens the standard Apple color picker, where a color can be selected by clicking
within the color wheel, moving sliders, or entering values in the text boxes.
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A range of squares can be selected by clicking and dragging.
The Blend button changes the selected color squares to a
blend between the first and last squares selected.

The Sort button opens a
dialog box that lets you
choose methods of sorting
the colors in the set.

The Primary and Secondary pop-up menus
offer several choices for sort methods.

The Reverse button swaps the order of the
selected color squares (upper left corner to
lower right corner).

The Warm, Cool, Light and Dark buttons
change the selected colors by changing their
color values. Clicking the button again
repeats the operation on the newly-changed
color.

The Tint… button opens a dialog box where a value from -20% to +20%
can be entered. The  starting color square is tinted by the value entered in
the next square, and repeated to the ending square (for 5%, the second
square is 5% lighter, the next 10% lighter, etc.) Positive ranges lighten the
selected colors; negative values darken the selected colors.

Scratch Pad
The Scratch Pad allows you to experiment with Color It!’s brush tools, test changes
to a portion of the image without changing the original image, and store a range of
colors for use on the original.

The commands in the Options pop-up menu let you
import images into the Scratch Pad.

The Grab From Image… command lets you grab a portion of the document and
place it on the Scratch Pad. When you select the command, a dialog box appears
where you can select a portion of your document to copy to the Scratch Pad.
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To make a new selection, move the
cursor over the selection rectangle,
then click and drag the rectangle
to select a different portion of the
document. For finer control, move
the cursor over the box on the left,
then click and drag to nudge the
selection. Once you have selected
a new area, click the Grab button.

The Paste From Clipboard command pastes the clipboard contents into the Scratch
Pad. Clipboard images are scaled to fit.

The Clear command deletes the contents of the Scratch Pad.

The Save command saves the contents of the Scratch Pad.

The Revert command undoes any changes to the Scratch Pad since the last save.

Clicking the Eyedropper checkbox turns tools moved over the Scratch Pad into the
Eyedropper tool. Clicking on the Scratch Pad then selects the color at the point
selected.

Patterns
Pattern fills can be used like any other fill with selections, as paint for brushes, etc.
Color It! comes with a number of patterns. Patterns and sets can also be created or
modified.

The Pattern Set pop-up lets you choose from the patterns and sets
stored in the Pattern Sets folder in the Color It! Stuff folder.

Select a pattern by clicking on the sample square. The selected pattern has a grey
frame around it, and the pattern appears in the selected color square at the top of
the Colors and in the Tools palettes. The scroll bar and scroll arrows at the bottom
of the palette can be used to make more of the patterns in the set visible.

A pattern may be used as a fill or as paint for a brush. Any
attributes that can be applied to a brush such as style, size
and opacity can be used.

Clicking the Edit button opens the Pattern Edit dialog box where
patterns can be created or modified. Clicking on a pattern square selects
it and adds a gray frame. The scroll bar and scroll arrows at the bottom
of the dialog box can be used to make more the patterns in the set visi-
ble. Each pattern set can hold up to 90 patterns.

Patterns are arranged in sets. The Set pop-
up menu lets you choose a set, convert a
Color It! or Color It! 2.0 set, or create a new
pattern set.
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The New Set… command brings up a standard Open
dialog box showing the Pattern Sets folder (located in
the Color It! Stuff folder.)

The Convert 2.0 Set… command also brings up a
standard Open dialog box where you can locate
existing Color It! or Color It! 2.0 patterns.

Patterns within sets can be changed and moved with-
in the Pattern Edit dialog box using the Cut, Copy,
Paste and Undo buttons. The Modify button opens a
dialog box where existing patterns can be modified or
new patterns created.

The pattern width or
height can be changed
by entering numbers in
the New Size or Percent
textboxes. Unchecking
the Keep Aspect Ratio
lets you change the
width or height
independently.

Clicking the Convert To checkbox lets you convert any pattern into one
of three types:

Direct Color patterns always appear exactly as they were created. All of 
the color information of the original picture is saved, and it is not be affected by changes to the
fill or background colors.

Gradient patterns are displayed using the colors in the color bar in the Tools
palette. The grays in the pattern will be directly replaced by the colors in the color
bar. The white regions of the pattern use the colors at the left side of the color bar;
the darker regions of the pattern use the colors at the right side of the color bar.

Two Colors patterns use only solid white and black. The white is replaced with the color at the
left end of the color bar; the black is replaced with the color at the right end of the color bar.

Checking Display Pattern Tiled fills the left end of the Modify Pattern dialog box with the
pattern.
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Clicking the Grab button at the bottom of the Pattern Edit dialog opens
another dialog where either the entire active document or a portion of it
may be used to create a new pattern. 

Enter numbers in the textboxes to set the
Width and Height (in pixels) for the pattern.
Patterns may be up to 256 by 256 pixels.

Click and drag the selection rectangle in the
view on the right to select a portion of the
document. For finer control, click and drag in
the view on the left.

Checking the Display Pattern Tiled check-
box shows the pattern repeated in the box on
the left.

Once you have selected a new area, click the
Grab button. You are returned to the Pattern
Edit dialog box.

Clicking the Done button opens a dialog box where
changes to the pattern set may be saved by clicking
the Save button. The new pattern is now saved in
the set, and will appear when the modified set is
displayed the Colors palette.
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11:  The Web Map Palette
The Web Map palette is a float-
ing palette that is used to create
and modify web image maps. 

It can be opened or closed from the pop-up menu at the right. A web image map is a text file that
describes the regions within a graphic that link to an HTML web page or location within a Web
page. When a viewer clicks on this area, they will be immediately transferred to that page or
location.

The leftmost button, the Arrow, is used to reposition regions after they are drawn.

The four drawing tool buttons (Rectangle, Oval, Polygon and Point) are used to create
map regions on an image. 

In the example to the left, the Rectangle was
used to create region (1) for “Surfing”; the
Polygon to create region (2) for “Sunset Tours”
and the Oval to create region (3) for “Weather.”

Once the regions have been drawn, their
arrangement can be changed by using the layer-
ing buttons.

The Move to Front button moves
a selected region to the frontmost

position; likewise the next button, Move to Back
moves the region to the lowest layer. The next
two buttons, Move Forward and Move
Backward shuffle the selected region up or
down one level per click. Layering is important
because when regions overlap, only the topmost
link is activated.

The Color Picker button opens the standard Apple Color Picker where you may select a color for
the lines defining the map regions.

NOTE: Options available in the Color Picker may differ depending on the extensions loaded in your System.
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Clicking the URL button opens a dialog box where you may enter the Universal Resource
Locator (URL) the image map will link to.

To change the default URL, click on the
image outside of the numbered regions
and click the URL button. Enter the
new name of the default URL you wish
to use in the dialog box.

The Image Map
Options pop-up at
the right end of the
palette lets you open
existing image maps,
save image maps or
close image maps.

When Save Map or Save Map As… is chosen, a
dialog box opens with the options to save the image
map in two server-side types: NCSA or CERN (the
type chosen depends on the type your server
supports; ask your provider). These maps are
opened automatically if the map file is named the
same as the image file (except for the .map extension
at the end) and both are located in the same folder.

Checking the Save Client-side map also checkbox
will save a client-side version of the map in HTML
format in addition to the server-side type you
choose. This HTML image map file is immediately
useable. The CERN or NCSA maps as described
above must be in the same folder for the image
map to appear when the image file is opened.
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11:  The Animation Palette
The Animation palette is a floating palette that is
used to create and animated GIF images. It can
be opened or closed from the Animation com-
mand on Tools menu. An animated GIF is a
special type of GIF file that contains multiple
images that play back in sequence on a Web
page.

The main portion of the palette displays the frames in the animation. If all frames are not visible,
the scroll bar at the bottom of the palette will be active. The palette may be expanded horizontal-
ly by clicking and dragging the size box in the lower right corner.

The four buttons at the left control functions for frames. From left to right, the buttons are
Add New Frame (added to the right of the selected frame), Duplicate Frame(s) (duplicate 

frames are added to the right of the selected frames), Reverse Order of the selected frames, and
Delete Frame(s). These functions are also available from the pop-up menu at the far right.

The Current Frame is identified to the right of these buttons as the frame number, followed by a
slash and the total number of frames in the animation.

NOTE: The Current Frame and the Selected Frame (highlighted in the thumbnail images) are not necessarily the
same, as the animations may be changed while they play and more than one frame can be selected at once.

The group of four buttons to the right control the playing of the animation in the palette.
From left to right, the buttons are Step Back (moves the Current Frame back (to the left) 

one frame; Stop (stops the animation from playing), Run (plays the animation), and Step
Forward (moves the Current Frame forward (to the right) one frame. These functions are also
available from the pop-up menu at the far right.

The Frame Characteristics button opens a dialog where the characteristics for a frame are set.
This function is also available from the pop-up menu at the far right.

The pop-up menu is accessed by clicking the right-facing triangle at the far
right of the palette. Many of the functions are described above for their
respective buttons.

Selecting the New
Animation… command
opens a New Image
dialog where many
aspects of the animated
GIF are set. While this is
similar to the dialog that
appears when selecting
New from the File menu,
it differs in several ways.
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The GIF file format is limited to no more than 256 colors. The color sets that
may be used appear in this pop-up.

NOTE: The Netscape Optimized color set is a good choice, as it uses the 216 colors that
are common to both Mac and Windows platforms. Colors from this set will not be
dithered when displayed on a web page.

The Fill With pop-up controls the initial appearance of the new animation. You
may select white or black fills for the background.

Current Document is available only when an existing document is open. The
new animation duplicates the contents of the document active at the time you
chose New Animation…. The height and width boxes automatically change to 

show the dimensions of the current document.

Active Selection is available only when a selection is active. The new document duplicates the
contents of the active selection. The height and width boxes automatically change to show the
dimensions of the current selection.

Clipboard is available only when an image is stored on the Clipboard. The new document
duplicates the contents of the clipboard. The height and width boxes automatically show the
dimensions of the clipboard image.

Width, Height: These text boxes control the size of the new document. The Document icon
pop-up menu lets you quickly select from several common sizes (see
Chapter 14, The File Menu for more information on these sizes). The
sizes in the bottom section are standard sizes for Web Advertising
Banners (460 x 55 pixels) and Web Button/Badges (88 x 31 pixels).

The Units pop-up menu lets you specify the units to be used for width and height:
pixels, inches, centimeters, picas, or points.

The Resolution Unit pop-up menu lets you select pixels per inch or per centimeter.

The Image Size listing is an estimate of the amount of disk space needed for the
animation based on the color depth, width, and height entered.

Once a new animation is created, a new untitled
document appears and a first blank frame
appears on the Animation palette. Additional
frames may be created by selecting Add New
Frame from the pop-up menu or duplicating an
existing frame. Any of the normal tools or
operations that may be performed on an image
may also be done on each individual frame.
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The Set Loop Limit… command opens the Animation Loop
dialog box where the number of times the animation loops or
repeats itself are set. You may choose to have the animation loop
forever, or enter a specific number of times in the textbox.

The Set Frame Characteristics… command opens a
a dialog box where many aspects of the animation
are set. Delay times may be set in 100ths of a
second.

The Disposal Method controls how the data from the previous frame is
handled by the next frame. The pop-up offers Unspecified (where the
particular web browser determines how to handle the data); Do Not
Dispose which retains image data; Restore to Background Color returns 

any portions of the image not used by the next frame to the background color of the web page
where the animation is being displayed; and Restore to Previous returns to the image data there
before a particular was displayed.

The Transparency checkbox controls whether transparency is used in the
animation or not. The pop-up offers three ways of handling transparency:
Current Frame Index makes all areas of the image the same color as the
current frame color index transparent. Current Foreground Color makes 

those areas in the animation the same color as Color It!’s Foreground Color transparent; likewise
Current Background Color does the same with Color It!’s current background color.

When checked, the Apply to All Frames checkbox applies all frame characteristics set in this
dialog box to every frame in the animation. Frame Characteristics may later be set individually
frame-by-frame as needed.

Experimentation is probably one of the best ways for you to see what effects various settings
have on the animation. Settings may be changed on the fly while the animation is running.

It is important to remember that the document window itself is where
the Current Frame is displayed and where the frame contents are
created or modified. When the Run button is clicked, the document
window is where the animation is shown.

The Animation palette is where frames are
selected or rearranged. Clicking on a frame
thumbnail selects it  and makes it the current
frame displayed in the document window
(Shift-clicking is used to select multiple frames
as shown at the left).
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Frames are rearranged in the Animation palette
by clicking on a frame thumbnail to select it and
dragging to a new location. A frame outline
moves with the cursor. The vertical white lines
between frames becomes bold when the spot
between the two adjacent frames is selected (in
the example to the left, frame 2 is being moved
between frames 4 and 5). Once over the new 

location, release the mouse button to place the selected frame(s) in that position. Frames may be
added, deleted or repositioned while the animation is playing in the document window.

The best way to learn the Animation palette is to actually create an animated GIF. See Chapter
14, File Preparation, for step-by-step examples.
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12:  The Catalog Palettes
Catalog palettes are a convenient method of cataloging images in thumbnail form.
Each catalog may hold up to 200 thumbnails. Images to be cataloged may be in any
of the formats Color It! opens, and may reside on your hard drive or on stock image
and PhotoCDs. Catalogs may also be automatically created when multiple images
are acquired from a scanner or digital camera if the Acquire/import auto-save box is
checked in Preferences (Edit-> Preferences->General). See Chapter 15, The Edit
Menu for more information).

As with other palettes in Color It!, the floating catalog palettes may be closed by
clicking the close box in the top left corner, and clicking the zoom box in the top
right corner is a toggle that shrinks the palette to a minimal size without closing.
Catalog palettes will have a scroll bar with arrows if more images are in the palette
than are visible, and the palette may also be resized by clicking and dragging the
size box in the lower right corner to display more of the images in a palette.

Catalog palettes are created under the Tools menu (Tools->
Catalogs->New Catalog).

A dialog box opens where the new
palette can be named.

The Open other… command opens other
catalog files not presently visible. All
open catalog files are listed at the bottom
of the Catalogs submenu.

The Catalog pop-up at the top of the palette lists the available thumbnail catalogs.
Catalogs shown in open palettes are indicated with a checkmark and are grayed out.
To display another catalog in the that palette, select one of the non-grayed catalogs
from the list.

The Image pop-up lists the thumbnails in the current catalog.Selecting an image
thumbnail from the list brings that thumbnail to the top row of images.

Once a catalog file is created, a triangle at the top right
opens an Action pop-up menu with commands for
working with catalog and images.
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The Rename catalog … command opens
a dialog box where a new name may be
entered for the current catalog.

The Rename image folder…
command opens a dialog box
where a new name may be
entered for the current image
folder.

The Delete catalog command opens a
dialog box where you may choose
Cancel, Delete Catalog Only (just the
thumbnail images) or Delete Catalog
and Images (both the thumbnails and
the original images).

The Add image… command opens a
standard Open dialog appear where
an image may be chosen to be added
to the catalog.

The frontmost open image in Color It! may be added by selecting the Add active image
command.

If the image has not yet been saved, a dialog
opens giving you the option to save the image
first.
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The Add thumbnails from… command opens a
dialog box listing the available catalog files (by
default, these files are stored in the Catalogs folder
inside the Color It! Stuff folder). Selecting a catalog
name imports the thumbnail images from that
catalog into the current catalog.

Thumbnails within a catalog may be selected by clicking
on them; [Shift]-clicking may be used to select multiple
images. Selected images have a wider grey border
surrounding them. Double-clicking a thumbnail opens
the original image in Color It! for editing.

Choosing the Delete selected image (s) command from
the Action pop-up removes the selected thumbnails
from that catalog.

The Add folder of images… command opens a
dialog box where a folder containing images may be
selected, and thumbnails of the images within the
selected folder will be added to the catalog. The
Selected button chooses the highlighted folder. The
Current button chooses the folder presently open.

The New…
button creates a
new folder you
may name and
locate.

The Gather images to… command collects a set of
copies of the original images in a catalog to another
location.
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If individual thumbnails within the
catalog are selected when this
command is chosen, a dialog box
appears asking whether to Move All
Images in the catalog or just Selected
Images Only.

A dialog appears where a location may be selected
for gathering the images. The button under the
window listing will show either the currently open
folder or the folder highlighted in the list.

Checking the Delete Originals checkbox will perma-
nently remove the original images from their original
location.

The Open new catalog palette… com-
mand in the Action pop-up functions the
same as the New Catalog command in the
Catalogs submenu. A dialog box appears
where the new palette can be named.

Up to three catalog palettes may be open at one time.
When more than one palette is open, thumbnail images
may be added to another catalog by dragging and drop-
ping from one catalog palette to another. Holding down
the [Option] key when dragging between palettes
moves the thumbnail image from the original catalog to
the destination catalog.
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13:  The Apple Menu

The Apple menu contains the desk accessories installed in your system.

The first command About Color It!… opens a dialog box.

The dialog displays the version num-
ber and the name and organization
information entered when the program
was first personalized.

Clicking the Plug-Ins pop-up displays a list with information about any
installed third-party plug-ins. 

NOTE:  The list displayed is simply a sample. These plug-ins do not ship with
Color It!.

Selecting a plug-in from the list displays any information the third party
plug-in company provides. There is a wide range of information made

made available, from this rather minimalist
design from Andromeda to the more elabo-
rate one for Alien Skin Software’s Xenofex
below:
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Some plug-in vendors even include their help files in the plug-in information, such as this from
Kai’s Power Tools:

Clicking the Done button closes the dialog box and returns you to the program.
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14:  The File Menu
The File menu contains commands for creating new documents as well as opening,
closing, saving and printing of documents. The File menu also controls the scan-
ning, importing and exporting of images.

New…
The New... command [Command-N] opens a new, empty document where you can
create or import images or graphics. When you select New… from the File menu,
the New Image dialog box opens where the image type, a fill color, dimensions, 

and the resolution of the new
document are specified. It also
lists the approximate size of the
new image in the lower left
corner.

The Image Type pop-up menu lets you choose the type of document Color It!
creates: Millions of Colors, Thousands of Colors, 256 Colors or 16 Colors for
color documents; 256 Grays or 16 Grays for grayscale documents; and Black and
White.

The Fill With pop-up controls the initial appearance of the new document. You
may create a new empty image with white or black fills (background) or duplicate
the contents of the current document, active selection or clipboard.

Current Document is available only when an existing document is open. The new
document duplicates the contents of the document active at the time you chose 

New…. The height and width boxes automatically change to show the dimensions of the current
document.

Active Selection is available only when a selection is active. The new document duplicates the
contents of the active selection. The height and width boxes automatically change to show the
dimensions of the current selection.

Clipboard is available only when an image is stored on the Clipboard. The new document dupli-
cates the contents of the clipboard. The height and width boxes automatically show the dimen-
sions of the clipboard image.

Width, Height: These text boxes control the size of the new
document. The Document icon pop-up menu lets you quickly
select from several common sizes: US Letter-Tall (8.5" x 11");
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US Legal-Tall (8.5" x 14"); A4 Letter-Tall (210mm x 297mm); 3" x 5"
and 8" x 10".

The sizes in the lower two sections are common Macintosh screen
sizes in pixels: 640 x 480 (13" screen); 512 x 342 (9" screen); and 512 x
384 (12" screen). The 646 x 486 and 532 x 388 are sizes that work well
for video or images on a 14" screen.

The sizes in the bottom section are standard sizes for Web
Advertising Banners (460 x 55 pixels) and Web Button/Badges (88 x
31 pixels).

The Units pop-up menu lets you specify the units
to be used for width and height: pixels, inches,
centimeters, picas, or points.

The Resolution text box controls how much information Color It! stores in the document.
Higher resolution takes more disk space, preserves more image details and the final printed
image more precisely duplicates the original.

The pop-up menu lets you select pixels per inch or per centimeter.

Image Size: Color It! estimates the amount of disk space needed for the
document about to be created based on the Image Type, width, height and

resolution entered.

NOTE: Screen image resolution is measured in pixels per inch. It differs from output device resolution,
measured in dots per inch. See Chapter 3, Scanning & Importing for a tour and more information.

Open…
The Open... command [Command-O] opens existing documents.

Color It! uses a virtual memory scheme that uses hard disk space to hold documents too large to
fit in RAM, it can have many documents opened at one time (limited only by your disk space).

Documents display at 72 dpi or at their resolution depending on the setting in Display
Preferences (Edit-> Preferences->Display…) when opened. High resolution documents may
appear much larger than you expect. To view all documents at their reproduction size select
Display At Resolution in the Display Preferences dialog box. To temporarily display the active
document at its reproduction size, choose Display at Resolution from the Window menu.

The Open dialog box has all the features of a standard Macintosh Open dialog box, plus a few
features found just in Color It!:

Checking Show Preview at the bottom
expands the dialog to show a preview
for a document. If the document has no
preview and the format is supported by
Color It!, clicking the Create button
creates a preview. Documents with
previews also list the program which
created the document and last
modification date and time.
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The Show pop-up lets you select the file formats to be listed in the scroll box,
and speeds the process of searching for documents in a specific file format by
limiting the types of files shown.

Supported Formats shows all documents in formats that Color It! can open. All
Files shows all files regardless of format. If the document selected is not a sup-
ported format, Color It! will try to determine its format and open the document.
If you choose one of the other formats (such as TIFF) only files in that format will
be shown.

Open Recent…
The Open Recent… command
displays a submenu of the last ten
documents opened in Color It! for
quick access.

Close
The Close command [Command-W] closes the active window. If more than one document is
open, the next open window comes to the front.

If you made changes to the document since it was
last saved, a dialog appears asking if you want to
save the changes. If the document is new and has
never been saved, the Save As dialog (described
below) opens.

Save
The Save command [Command-S] saves the most recent version of the document. When work-
ing on an existing document, Color It! saves all changes under the current file name and format.
If the document is new and has never been saved, the Save As dialog opens.

Save As…
Save As... lets you name and save a new document
or save an existing document under a new name, a
new file format or in a different location.

The Save As… command opens a dialog with the
current file name (or “untitled” for a new docu-
ment).

If you click the Save button for a document
with a name that
already exists in that
folder, a dialog
opens asking if you
want to replace it.

The Save Selected Area Only checkbox at the bottom is available only if a selection is active in
the document. If checked, the selected region will be saved as the new document.

NOTE: Be sure the Save Selected Area Only checkbox is not checked if you mean to save the entire document.
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The Format pop-up menu is used to select the specific file format in which to
save the document. Formats include TIFF, Macintosh PICT, JPEG, PostScript®,
Paint, CompuServe GIF™, Photoshop™ 2.0 and 2.5, StartUpScreen, Photone™

Prepress, Scitex CT (in CMYK only), QuickTime™ PICT and PNG.

The Options button opens a dialog box allowing you to set format-specific
preferences.

NOTE: Paint is the old MacPaint file format. Documents saved in this file format are
black and white 8" x 10" images only.

NOTE:  Paint, StartUpScreen, Photone Prepress, Scitex CT and QuickTime PICT
formats do not have any options.

TIFF Format Options
Compression:  Select from None, RLE (Run-Length Encoding), LZW
(Lempel-Ziv-Welch) and LZW Horiz. Diff. All are lossless (no data is
lost in the compression process).

Format: Select either Macintosh (Motorola) or IBM (Intel) formats.

Checking Include Selection saves a selection so it reappears when the
document is reopened. This option is useful for saving complex selec-
tion masks you have created.

The Include Info Strings checkbox is used for older versions of pro-
grams that may not be able to read TIFFs without info strings. (If you
have a TIFF document which you cannot open in a program, reopen it
in Color It! and save it with the Include Info Strings unchecked. You
may then be able to open it.)

Macintosh PICT Format Options
You may save the document as either version 2 or version 1.
Version 1 should be used only if you are saving a black and
white document for an older paint program.

Checking Include Selection as Alpha Channel saves a
selection so it reappears when the document is reopened. 

JPEG Format Options
JPEG is a popular compressed file format for Web use. The
Quality buttons set the quality of the image and the compres-
sion: Low quality images are highly compressed and result in
small file sizes. High is the quality setting used most often,
with a good balance of image quality and file size. The Format
buttons let you choose between Baseline or standard JPEG
and Progressive, where the the image first appears as fuzzy,
and gradually becomes clearer as the balance of the image
information is downloaded. This allows the viewer to see the
entire image immediately, and they may stop further
downloading if the y wish.

NOTE: Because JPEG discards data from the original image (called lossy compression), you cannot restore this
data once an image is stored in the JPEG file format.
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PostScript® (EPSF) Format Options
Saving PostScript documents in Binary format is
usually preferred, as it transfers faster to the printer.
Some programs may require ASCII Text  however.

Many programs open and display a PICT screen
image for a PostScript file to help you position the
image. You may select None , a black and white
representation, or a color/grayscale image.

Checking the Transparent Line Art checkbox makes
all pure white areas of PostScript images transparent.
This option is available only for black and white
images.

Checking Save as Desktop Color Separation Files saves CMYK images in five separate files—
one for each process color and one for a color preview (available only for CMYK images).

Checking the Save Selection as Clipping Path enables you to drop out the background areas
outside of the selection for export to page layout programs such as QuarkXPress or PageMaker.

CompuServe GIF™ Format Options
GIF is a popular compressed format for Web. The File Type
Signature area lets you choose Macintosh GIF Format for
images to be displayed on Macs or Text and Binary for
images to be displayed for other types of computers and Web
pages. Checking the Make Background Color Transparent
option makes the current background color (usually white)
transparent when displayed on a Web page. Note that all
areas of an image consisting of that color will turn transpar-
ent. Be sure to set the desired background color in the Tools
or Colors palette before saving.

When you re-open a GIF file saved in Color It! with the Make
Background Color Transparent option chosen, the color 

saved as transparent is selected, and the Background color is changed to that color.

Checking the Interlaced GIF option causes the image to display on Web pages in a progressive
manner: first as coarse or fuzzy and gradually getting clearer as the balance of the image infor-
mation is downloaded. This lets the viewer see the entire image immediately and stop further
downloading if they wish.

Checking the Minimize Color Table option saves the image in the fewest number of colors
possible to reduce downloading time.

NOTE: If the Image Type of the document being saved in
GIF format is Millions or Thousands of Colors, a dialog box
will open telling you the file must be converted to 256 colors
to save in GIF format. Clicking the Convert button opens a
dialog where the conversion can be made. See Chapter 16,
The Image Menu for more information.

Photoshop™ 2.0 Format Options
Checking Include Selection as Alpha Channel saves a
selection so it reappears when the document is reopened.
The selection is also saved as an alpha channel for use in
programs that support channels such as Photoshop.
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Photoshop™ 2.5 Format Options
RLE (Run Length Encoding) compressed the file to reduce its
size on disk.

Checking Include Selection as Alpha Channel saves a selection
so it reappears when the document is reopened. The selection is
also saved as an alpha channel for use in programs that support
channels such as Photoshop.

PNG Format Options
PNG is a format used for Web graphics. Interlacing
displays images in a progressive manner, first as
coarse or fuzzy, and gradually getting clearer as the
balance of the image information is downloaded.
This lets the viewer see the entire image immedi-
ately, and they may stop further downloading if
the image is of no interest. Choosing Adam-7
makes seven passes as it displays the image.

Filter Types (Sub, Up, Average and Paeth) are
different methods of comparing pixels already 

compressed to those not yet compressed to speed the process.

Revert to Saved
The Revert To Saved command returns the document to the last version saved on the disk. It is
available only if the document has been changed since the last save.

Scan & Import
The Scan & Import menu displays any scanning and import
plug-ins that let you communicate with scanners and other 

third party hardware. Color It! works with any scanner or digital camera which has a Photoshop-
compatible plug-in. The TWAIN Acquire… and Select TWAIN Source… options let you select
any installed scanner plug-ins that meet the TWAIN scanner standard specifications.

NOTE: If you have a scanner or digital camera, the manufacturer usually provides a TWAIN or Photoshop-
compatible plug-in. To be able to access a scanner from within Color It!, the Photoshop plug-in provided
by the scanner/digital camera manufacturer must be installed by placing the plug-in file in the Plug-ins
folder located inside the Color It! Stuff folder, inside the Color It! folder (see Chapter 3, Scanning for more
information). If Color It! is running you must quit and restart the program to use the plug-in. If the plug-in is
installed properly, it appears on the Scan/Import menu below the TWAIN commands.

Export
Third party export plug-ins permit you to export a document to compression hardware/soft-
ware or a printer not accessed through the Print command, or to save a document in an file
format not supported by Color It! Third party export plug-ins are installed by placing the plug-in
file in the Plug-ins folder located inside the Color It! Stuff folder, inside the Color It! folder. If
Color It! is running you must quit and restart the program to use the plug-in. If the plug-in is
installed properly, it appears on the Export menu.

Page Setup…
The Page
Setup... com-
mand opens the

standard Page Setup dialog box for
your specific printer. Options for Color
It! appear when Color It! 4.0 is chosen
from the top pop-up menu.
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Checking Crop Marks adds these marks to the printed output. Checking Registration Marks
adds them to the printed output.

Clicking the Screen… button opens a dialog where
screen settings are made.

Frequency controls the size of the halftone spots used to
print the image. Choose Lines per Inch (LPI) or Lines per

Centimeter (LPC) from the pop-up.

Angle controls the halftone screen angle.

The Shape pop-up lets you choose the
shape of the halftone spots used to print the
image.

Checking Use Printer Defaults overrides these settings and uses the printer’s normal built-in settings.

NOTE:  Screen settings only affect output on PostScript printers.

Print…
The Print…
command
[Command-
P] opens the
standard
Macintosh
Print dialog
for your spe-

cific printer. Options for Color It!
appear when Color It! 4.0 is chosen
from the top pop-up menu. The type of
printer determines the choices you
have.

PostScript and Color PostScript are the printing methods used by printers with a PostScript
interpreter. The Screen options in the Page Setup dialog function only with these types of
printers.

You may select ASCII or Binary as a method of sending the image information. Different types
of printer work better with ASCII or Binary. Binary format is usually preferred, as it is half the
size of ASCII and transfers faster to the printer.

Checking Selection to Clipping Path will drop out the background outside of a selection so it
does not show when printed.

QuickDraw is the printing method used by non-PostScript printers, including most inkjet
printers. No options are available.

Custom Dither prints only black and white. Clicking the Options… button opens the Convert
dialog box.
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The Dither Style area offers several
different styles:

Diffusion has a pop-up menu with
several choices for diffusion dither
methods.

Ordered Dither has
a pop-up menu with
several choices for

dither levels.
Mezzotint converts the image to a
random dither.

Threshold converts the image to a 
posterized image consisting of pure blacks and whites. The percent entered in the textbox
determines the level at which the black-to-white change takes place.
None does not dither the image when converting.

NOTE: The Color Set area does not apply when selecting Custom Dither from the Print dialog box.

Clicking the Preview… button opens a dialog
with the options to position the image on the
printed page size by using the horizontal and
vertical alignment buttons or by clicking and
dragging the image itself. Click OK when the
image is where you want it on the page.

Quit
The Quit command [Command-Q] closes all open documents and quits Color It!. If there are any
documents with unsaved changes, a dialog box opens with options to save the document or 

discard any changes made.
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15: The Edit Menu
The Edit menu contains commands that allow you to cut, copy, paste, clear, and
fill a document or a portion of a document. There are also commands for publish-
ing and setting various preferences.

Undo
The Undo command [Command-Z] reverses the last action performed in a
document. The menu displays the last action taken that can be undone (such as
Undo Selection) at the top. If the change can’t be reversed, the Edit menu
displays Can’t Undo.

Color It! provides multiple levels of Undo—you can undo up to 16 of the last
operations performed in a document, in reverse order. The number of undos are
set in the General Preferences dialog (Edit->Preferences->General). When you
switch to a different document, Color It! keeps only the most recent undo for the
inactive documents.

Redo
The Redo command [Command-R] lets you restore an action you reversed with the Undo
command.

Like the Undo command, Color It! provides up to 16 levels of Redo. When you switch to a differ-
ent document, Color It! keeps only the most recent Redo for the inactive documents.

Cut
The Cut command [Command-X] removes the active selection from the document (leaving a
hole filled with the background color) and places it on the Clipboard.

Copy
The Copy command [Command-C] copies the active selection and places a duplicate of it on the
Clipboard.

Paste
The Paste command [Command-V] places a copy of the Clipboard contents into a document
while keeping a copy of the image on the Clipboard.

Clear
The Clear command functions much like the Cut command: it removes the active selection from
the document (leaving a hole filled with the background color) but does not add to the
Clipboard.

Paste Into
The Paste Into command puts the contents of the Clipboard into the document, keep-
ing its original proportions but it is visible only within the selected area. The marquee
lines show the shape of the pasted image, and it can be moved to position the portion
you wish to show through the selection.
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Paste Behind
The Paste Behind command puts the contents of the Clipboard into the document but
outside of a selection rather than into it. The original image shows within the
selection. The pasted image can be moved to reposition it behind the selection.

Paste To Fit
The Paste To Fit command changes the proportions of the contents of the Clipboard
so that the pasted image completely fills the selection.

Fill
The Fill command [Option] + [Delete]fills a selection with the foreground color or pattern. If no
selection is active, the entire document is filled.

Frame…
The Frame… command opens a dialog where the width of a frame for a
selection in pixels is entered. Clicking the Frame button puts a frame of
the specified width using the Frame color within the selection.

Publishing
In System 7.0 or above, Color It! adds publishing options to
the Edit menu.

The ability to ‘publish’ images is a very powerful feature. Any
document or selection can be published and then be subscribed to by other documents. Once this link is
made, any changes in the original image will automatically be updated in any subscribing documents.

Create Publisher… allows any
part of a document to be pub-
lished. This command opens a
dialog box where the location and
name for the new publisher
document is specified. Once a
publisher is created, it can be sub-
scribed to in other Macintosh
programs that support Publish
and Subscribe.

To create a publisher, first select an area of the document with any selection tools. If there is no
active selection, the entire document will be published. Next select Create Publisher… and
choose a location and a file name in the open dialog. Click Publish to publish the selection.
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Publisher Options… Whenever a
document that contains publishers is
saved, changes to areas that have
been published will be automatically
saved to the publisher files (indicated
by the On Save radio button).

You can choose to override this
option by clicking on the Manually
radio button. While this setting is in 

effect, the publisher will only be updated when you click the Send Edition Now button in the
Publisher Options dialog box. To update publishers each time a document is saved, click the On
Save radio button.

Clicking the Cancel Publisher button removes the publisher from the document. Clicking on the
pop-up at the top of the dialog shows the path to the current publisher.

The Show Borders/Hide Borders command is a toggle that displays or hides grey borders
around each published region in a document. To select a publisher, click on its border with the
Pointer tool. This converts the published region into an active selection. Whenever the file is
saved, any changes made to the contents of this selection will automatically be updated in any
document which subscribes to this region.

Preferences
The Preferences command [Command-K] sets preferences defaults for many areas of Color It!.
Related preferences are grouped under a tab in the Preferences dialog box, and include General,
Display, Files, Tools, Rulers and Separation. 

General Preferences
The Startup area controls what hap-
pens when Color It! first starts. The 

Startup With
pop-up lets
you select
Untitled

Document, New Dialog, Open
Dialog, or Nothing. The Define
Document… button (active only
when Untitled Document is chosen)
opens the New Image dialog box,
where options are set for the docu-
ment appearing at startup. The
options are described in Chapter 14,
The File Menu.

The Clipboard area controls images copied to the clipboard. Checking Export to other applica-
tions stores the image in a form useable by other programs. The Mode pop-up lets you select 

Normal, Dither, or Transparent modes. In Transparent mode, pure white areas of the
image become transparent when pasted into other applications.

The Color Optimization area improves images displayed on monitors supporting 
fewer colors than the image contains—for example, viewing a Millions of Colors document on a
256-color screen. Enter the percent of colors in the image to be optimized in the Amount check-
box. It is generally best to leave this at the default setting of 75% to allow for new colors intro-
duced through paint or paste operations.
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Check either the After opening or Before saving checkboxes to determine when optimization
occurs. Checking After opening ensures images from other programs have the same image
quality as those created in Color It!

The Undo area sets the number of Undo and Redo operations available in Color It! from 1 to 16.

The After Long Operations area lets you select notification methods when operations are com-
pleted. The menubar flashes when the Flash Menubar box is checked. You can also select a
sound alert from the Mode pop-up menu.

Checking Auto-save on Scan/Import will automatically save groups of images brought into
Color It! from products such as digital cameras.

Display Preferences
The Open Images area lets you select how images are
displayed.

The Where pop-up menu lets
you choose a monitor in
multiple-monitor systems. On

Best Screen opens the window on the screen with the
highest resolution when multiple screens are used. On
Alternate Screens keeps the same number of windows on
each screen when multiple screens are used. On Main
Screen opens all windows on the screen containing the
menu bar (the main monitor).

Checking Display at Resolution displays documents in the
same physical dimensions as they will print out. If this is
not checked, all documents are displayed at 72dpi—thus a
300dpi document appears on-screen roughly four times its
size (300 ÷ 72 = 4.167).

Checking Fit in Window displays documents so the entire document fits within the window.

The Document Border area controls borders surrounding the document image in the main
window. None displays the image without a border; Thin displays a 4 pixel wide border; Thick 

displays a wider border around the image. The Color pop-up menu lets you select a
border of Gray, Black, White, or Other Color (which opens the standard Apple Color
Picker to choose a color).

Checking Dither on monitors without enough colors dithers images if your monitor does not support as
many colors as the document contains.

Checking Show image info in head-
er of windows displays the file size,
measurements (in units set in the
Ruler Preferences dialog box) and
the file type.

Check Display values in percentage if you wish to do so.

94 Chapter 15: The Edit Menu Color It!™ 4.0 Manual 



Files… Preferences
The Format pop-up menu
selects the default file format
that appears in the Save
dialog for new files.
The Options button opens a
dialog box allowing you to
set format-specific prefer-
ences. The options for each
format are discussed under
Save As… in Chapter 14, The
File Menu.

Checking Prompt for Options each Save As opens the
Options dialog each time a Save As is performed.

Checking Create Previews creates a preview of the document that is displayed in the Open
dialog box.

Checking Create Thumbnail Icons creates miniature views of the document for the
icon views in the Finder.

The Temporary Files area specifies the volume where
Color It! stores the temporary files it needs to maintain
Undo capability. The default location is the Virtual
Images folder inside Color It! Stuff folder.

Clicking the Add button brings up an Open dialog
box allowing you to choose additional storage areas.
The Selected button chooses the highlighted folder.
The Current button chooses the folder presently
open. The New… button creates a new folder you
can name and locate.
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Tools Preferences
Antialiasing eliminates the jagged edges of text or
colored objects. These buttons let you select the
amount of antialiasing. In most cases, the difference
between Good and Best is virtually indistinguish-
able.

Paint Dither sets the palette for dither patterns.
Fine uses 33 patterns; Medium uses 17; Coarse 
uses 9.

Drag Updates controls how images are displayed
when moved with the mouse. With Outline Only
the mouse button must be released before the screen
updates. With Brief Delay the screen updates after 

a slight pause and before the mouse button is released. With Long Delay the screen updates after
a longer pause and before the mouse button is released.

Checking the Allow Editing of Tool Positions permits repositioning of the tools within the
Tools palette. See Chapter 8, The Tools Palette for more information.

Checking Average Selection Effects smooths images that have been rotated.

Checking Smooth Gradients displays blends between two colors smoothly.

The Wacom Eraser Tool pop-up (at left) selects any tool from Color It! to be used
when the eraser tip on a stylus from a pressure-sensitive tablet that supports the
Wacom Eraser is activated.

Rulers… Preferences
The
Units
pop-
up
menu

lets you select ruler
measurements in pixels,
inches, centimeters,
picas or points.

Major Divisions appear in the rulers as a full-height vertical tick mark
followed by a number. The pop-up menu has several selected increments,
or others can be entered in the text box.

Minor Divisions are shorter vertical tick marks between the major
divisions. The pop-up menu has several selected increments, or others
can be entered in the text box.

As changes are made, the ruler in the the dialog box automatically
updates to reflect the current values.
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Separation Preferences
Black Generation offers 2 methods: UCR
(Undercolor Removal) or GCR (Grey Component
Replacement).

UCR is a technique that replaces some of the cyan,
magenta and yellow components of the neutral
gray and dark shadow areas with black. This helps
compensate for some of the trapping and related
problems that occur in multicolor printing.

Extreme UCR is not practical. If too much of the
three-color gray component is removed, detail and
density will be lost. By reducing three colors (cyan,
magenta and yellow) and increasing one color
(black), UCR reduces total ink coverage (and print-
ing expense) significantly.

GCR replaces gray components in the colored areas of a reproduction with black. The least
prominent color is reduced or removed completely along with proportional amounts of the other
two colors to define a gray component which is replaced with black ink.

Total Coverage Limit is the maximum ink coverage of the four process colors. It can be set from
200% to 400%.

Black Ink Limit is the maximum ink coverage of process black. It can be set from 0% to 200%.

Black Starts At identifies the percent of coverage where black ink begins to be used. It can be set
from 0% to 90%.

GCR Black Generation can be set from 0 to 90.

The Transfer… button opens the Transfer Curves dialog.

The Transfer Curves dialog sets the
compensation for dot gain. The
curves also enable you to set the
points for the darkest printable
shadow and the lightest printable
highlight.

The dots on the curve represent the
shadow, quartertone, midtone, three-
quartertone, and highlight points.
The points can be adjusting by click-

ing and dragging. A curve that slopes above a 45° straight line makes the tones darker; curving
below the 45° line makes the tones lighter. Shift-clicking will move the same dot in all four ink
colors at the same time.

Clicking the Inks… button opens the Ink Calibration dialog.
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The Hue and Grayness area usually
should remain at the default settings.
Densitometer readings should be
taken for each of the percentages list-
ed. Numbers can be entered in the
Gray Balance textboxes to compen-
sate for color shifts in order to pro-
duce a neutral gray from the three
process colors.

Clicking the Components… button opens the Ink
Components Bias dialog. Numbers may be entered in the
textboxes for both Gray and Color 1/4 Tone, Mid Tone and
3/4 Tone to adjust for impurities in the process inks.

The Load… button in the Separations Preferences
tab opens a standard dialog showing the folder where
pre-defined curves may be chosen and applied.
Several standard settings are provided with Color It!.

You may create and define your own curves and use
the Save… button in the Separations Preferences tab
to open a dialog letting you name and store your own
settings.

If any of the changes in settings made are not
within the limits for that setting, an alert
dialog is displayed.

98 Chapter 15: The Edit Menu Color It!™ 4.0 Manual 



16:  The Image Menu
The Image menu contains commands that allow you to convert image types,
view color channels, change the scale, resolution or size of a document, or rotate,
stretch, skew, distort, or apply perspective to a selection or the entire document.

Image Type
The Image Type command lets you change the color
or gray levels of a document. The current image type
is indicated with a check mark in the menu.

When you convert to fewer color or gray levels, the
Convert dialog box opens.

The effect of the conversion choice
is shown in the After image at the
lower left. You can choose the
portion of the image shown by
clicking and dragging the selection
rectangle in the small image at the
top left.

The Dither Style area has radio
buttons to choose the conversion
type:

Diffusion creates a random pattern of pixels to simulate
colors or grays. The pop-up has choices for several
diffusion dither methods. Choosing one in the pop-up

changes the display in the After image in the lower left.

Ordered Dither creates a regular pattern of pixels. The pop-up menu has
choices for several different dither levels.

Mezzotint converts the image to a random pattern of pixels in different sizes, similar to a
mezzotint effect in engraving.

Threshold converts the image to a posterized image consisting of pure blacks
and whites. The percent entered in the textbox determines the level at which
the black-to-white change takes place.

None does not dither the image when converting.
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The Color Sets area allows you to choose the group of colors are chosen when converting to an image
with fewer colors. Current Document Set selects those colors that will most closely reproduce the colors
in the existing document. System Colors selects the standard colors used by the Mac’s operating system.

Optimized has a pop-up to select fewer bits to reduce the bit depth of the
image (and thus reduce file size). The After preview shows the effect so you
may choose the bit depth that best meets your needs or balances file size and
appearance.

Color It! comes with a number of color sets available
by selecting the Other radio button. The Netscape
Optimized color set is particularly useful for Web
graphics as it contains the 216 colors common in
both Mac and Windows that do not dither.

Color sets may be created or modified. See Chapter 9, The Colors Palette for more information.

Scale…
The Scale… command opens a dialog where the
width and height of a selection or document
may be changed by entering new numbers for
either in the Scaling (percent) or New (measure-
ments) textboxes.

The Units pop-up menu lets
you change measurements to
pixels, inches, centimeters,
picas or points.

Unchecking Keep Aspect Ratio enables the width or height to be changed independently.
Checking Smooth Scaling improves the appearance of images which are scaled 2 or more times
their original size. Normally the image appears more pixilated or blocky as you increase the
magnification, but the transitions are smoother with this option chosen.

The Reset button returns the values in the Scaling boxes to their original settings.

Change Resolution…
The Change Resolution  command permits changing the
both the physical size and the resolution of a document.

Width and Height may be changed by entering new
numbers in these textboxes. The Units pop-up menu lets
you change measurements to pixels, inches, centimeters,
picas or points.

Entering numbers in the X or Y textboxes changes the
image resolution. The pop-up menu lets you choose Pixels
per Inch or Pixels per Centimeter.

Checking Convert to changes the color depth of the image.
The pop-up menu offers the same options as the Image
Type command described earlier in this chapter.

Checking Keep Aspect Ratio changes width and height
proportionally.

Checking Keep pixels constant keeps the file size the same 
screen image the same despite differences in X and Y resolution.

Choosing Smooth scaling improves the appearance of images which are scaled 2 or more times
their original size.

The Reset button returns the values in Size and Resolution to their original settings.
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Canvas Size…
The Canvas Size… command lets you change
the size of a document without changing the
size of the existing image. Enter numbers in the
Width and Height textboxes for the new docu-
ment dimensions. (Unchecking Keep Aspect
Ratio enables width and height to be changed
independently).

The Align pop-ups
let you position the
present image 

within the area defined by the new document dimensions. The Units pop-up lets you change
measurement units. The Reset button returns the values in the Width and Height and to their
original settings.

Crop to Selection
The Crop to Selection command deletes any of the image outside of the current selection. Only
the portion of the image within the selection is left as the entire image.

Grow to Selection
The Grow to Selection command is only available when part of the active selection is moved
beyond the edges of the document. Grow to Selection increases the canvas area of the document
enough to include the active selection. The additional area on the Base Image layer is filled with
white. This is useful when pasting an image larger than the current document.

Flip
The Flip commands make the active selection or entire document appear as
through they have been turned over.

Flip Horizontal flips the image left to right; Flip
Vertical flips the image top to bottom.

Rotate
The Rotate com-
mand displays a
menu with several
commands for
rotating the image
for a document or
selection.

The Arbitrary… command allows you to rotate the selection or the entire
document in 0.01 degree increments. Rotate in a right (clockwise) or left
(counterclockwise) direction by choosing the appropriate radio button.

The Free Rotate command permits rotating a selection
by hand. Color It! places grow handles at the four
corners of the selection. Click on one of the handles and
drag to rotate the selection.
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The Rotate 90° Right (CW) command rotates the active selection
(or the entire image if there is no active selection) 90 degrees to the
right (in a clockwise direction).

The Rotate 90° Left (CCW) command rotates the active selection
(or the entire image if there is no active selection) 90 degrees to the
left (in a counter-clockwise direction).

NOTE: Neither the Rotate 90° Right (CW) nor Rotate 90° Left (CCW) commands crop the image when it is
rotated.

The Rotate 180° command rotates the active selection (or the entire
image if there is no active selection) 180 degrees. Portions of the
image that extent beyond the edges of the document are lost, so use
the Canvas Size command to add extra area before rotating

Effects
The Effects command displays a menu with several commands for modifying the
image for a selection or the entire document. Portions of the image that extent
beyond the edges of the document are lost, so use the Canvas Size command to
add extra area before rotating

The Stretch/Shrink command permits interactively scaling
of an image. When you choose the command, Color It!
places grow handles at the four corners of the selection.
Click and drag one of the handles to stretch or shrink the
selection. Holding down the [Shift] key while dragging
retains the image’s proportions.

The Skew command slants the active selection along either
the horizontal or vertical axis. When the command is chosen,
Color It! places grow handles at the four corners of the selec-
tion. Click and drag one of the handles to skew the selection.
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The Perspective command changes the perspective of the active
selection. When the command is chosen, Color It! places grow
handles at the four corners of the selection. Click and drag one of
the handles to create either a horizontal or vertical perspective of
the selection.

The Distort command creates a number of special effects. When
the command is chosen, Color It! places grow handles at the four
corners of the selection. Click and drag one of the handles to to
distort the image. Successive distortions can be made to a
selection without causing any degradation to the image. 

Optimize Colors
The Optimize Colors command [Command-E] improves images displayed on monitors with
fewer colors than in the image—for example, viewing a Millions of Colors document on a 256-
color screen.

Get Info…
The Get Info... dialog box displays document information. The top area lists basic information:

File Type shows the document’s file
format.

Creator shows the name (or four-
character creator identity) of the
program which created the document.

Size is the amount of space the docu-
ment occupies in kilobytes (k) when
open.

Image Type lists the number of colors
in the document.

Width is the size of the document in
pixels.

Height is the size of the document in
pixels.

The second Size shows the size of the file when stored on a disk. This may differ from the
Opened File Size because documents on disk may be compressed. Depending on the block size
of the disk on which the image is stored, a second size (in parentheses) lists the disk space the
actual file itself requires.

Information can be entered in the textboxes below that are saved with the document:

Artist:  The name of the person who created the document.

Software:  The creator program (“Color It! 4.0” by default, but it may be changed.)

Computer: The type of computer used to create the document. (“Apple Macintosh” by default
but it may be changed.)

Device Make: The hardware used to create the document.

Device Model: Specific model information.

Description: Notes or other comments you wish to add about the document.
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Histogram…
The Histogram… command opens a dialog box displaying a
graphic representation of the frequency distribution of the
number of pixels in an image at a specific color level.

The Channel pop-up lists the various channels that
can be displayed. The composite channel displays a
combination of all three individual channels—Red,
Green, and Blue.

The Display pop-up adjusts the way the
histogram is displayed. Selected options are
marked with a bullet.

The top portion lets you choose between dis-
playing Whole Image or Selection Only.

Normal includes all the blacks, whites and
colors in the image. No Black/White ignores all
pixels at the first index (0) and the last index 

(255). Some filters group pixels at these extreme positions, so it is common for the large number
of pixels at these locations to overshadow the others in between.

Compressed compresses the high peaks in the histogram, making
the distribution of the other values in the image easier to see.

Cumulative sums the number of pixels in the image that are darker
than a selected color level.

The bottom portion of the pop-up controls the type of display for the histogram. Gradient
displays a gradient range that depicts the light-to-dark color levels in the image. Solid Black fills
the histogram area with black. Outline displays the histogram as a line.

104 Chapter 16: The Image Menu Color It!™ 4.0 Manual 



17:  The Selection Menu
The Selection menu contains commands that let you create, save, open, and
manipulate selections and masks; perform special effects like Drop Shadow
and Extrude, and save selections for use as a mask or a Web Image Map.

Selection Type
The Selection Type menu offers three choices for selections:

Off: The document has no selections or masks.

Selection: The document has a selection mask.

Document: The document has a separate document acting as a selection or mask.

Masks control how paint, paste, and filter operations affect a document. Color It!
supports two types of masks: Selection masks and Document masks.

Selection Masks are made with any of the selection tools, and temporarily protect portions of a docu-
ment, similar to the way a stencil or masking tape protects portions of a surface as you paint.

Document Masks are used for special effects and blends. A document mask is 
a second grayscale-only document linked to the original. The gray levels in the document mask
control how paste, paint or filter operations affect the original document, almost like a stencil
with variable opacity. Pure white areas in the Document Mask act as if completely transparent—
any changes made to the original document completely replace the image that already exists on
the active layer. Pure black areas in the Document Mask completely protect the original docu-
ment from changes to the active layer. In the gray areas of the Document Mask (between pure
white and pure black), the amount of change to the original image is based on the gray level in
the document mask: the lighter the gray in an area of the document mask, the greater the effect
of changes in the active layer of the original document. For example, if an image has a Document
Mask filled with a 70% grey and you filled the original image with a solid red, only 30% of the
solid red would be applied to the original image.

Masks can be turned on and off by selecting the appropriate choice in the Selection Type
submenu: Off, Selection or Document.

Document Mask
The Document Mask submenu has several options for masks:

The New Mask command automatically creates a new blank grayscale document the
same size and resolution of the original document with a white background, brings it to 

the front and names it by adding (Mask) to the end of original document’s name.
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The Open Mask… command brings up a standard Open dialog box where you may choose an
existing document to use as a mask.

Any document open at the same time as the original document can be used as a document mask.
To use an existing open document as a document mask, choose Selection-> Document Mask
and select it from the list at the bottom of the submenu (any other open documents are listed at
the bottom). The selected document is linked to the original as a document mask and is brought
to the front.

Document Masks must be grayscale images. An alert
dialog opens if you choose a color document. To use it as
a mask, it must be converted to a grayscale image with
the same resolution as the original image.

When the document mask is active, the original document appears in the Document
Mask submenu with a bullet (•) in front of it.

When the original document is active, the current document mask appears in the
Document Mask sub-menu with a diamond (◆) in front of it.

Mask Operations
The Mask Operations command displays a menu with commands for
modifying masks.

Invert Mask reverses the mask image. White becomes black; black becomes
white; 30% black becomes 70% black, etc.

Selection To Mask converts an active selection in the original document to a
new Document Mask. Anything inside of the selection in the original is white
(unprotected) in the mask; anything outside of the selection in the original
image becomes black (protected) in the Document Mask.

This differs from a Selection mask, which only temporarily masks part of the original document.
The Selection To Mask command creates a mask document which may be used over and over.

Mask To Selection does the reverse of the Selection to Mask command—it uses the areas in the
Document Mask to create a selection in the original document.

Add Selection adds a selection from the original document to the Document Mask.

Subtract Selection deletes a selection from the original document from the Document Mask.

If the Document Mask is active and the Colors palette is closed, Choose Mask
Colors… is the last command in the submenu. Choosing this command opens
the Colors palette where you may choose up to 16 colors from the palette by
holding down the [Shift] key and clicking in the Colors palette. The colors are
shown in the gradient at the bottom of the Tools palette (selecting the Gradient

tool displays the gradient bar).

Once the colors are chosen, the Add Colors command adds the gradient bar
colors to the mask. These areas are protected in active layer of the original
document.
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The Subtract Colors command subtracts all of the colors in the gradient bar from the mask
document so these areas in the active layer of the original document fully accept any paint, paste
or filter operations.

If the Colors palette is open, the last command in the submenu is Palette Colors
To Mask. This command masks off all of the colors in the gradient bar.

For more information on using Document Masks, see Chapter XX, Special
Effects.

Select All
The Select All command [Command-A] makes the entire contents of a document the active
selection (or, in a layered document, selects just the non-transparent areas of the active layer).
Double-clicking any selection tool also performs a Select All.

Select None
The Select None command [Command-D] turns off or deselects any current selection.

Invert Selection
The Invert Selection command lets you select everything except the currently selected region.
This command is very helpful for creating masks.

Grow Selection…
The Grow Selection… command expands the size of the current
selection. Enter the size from 1 to 16 pixels in the Width and click the
Border button.

Shrink Selection…
The Shrink Selection… command reduces the size of the current
selection. Enter the size from 1 to 16 pixels in the Width and click the
Border button.

Select Similar
The Select Similar command selects all pixels in a document with the same color values as the
active selection, whether they are contiguous (next to each other) or not.

Feather…
The Feather… command controls the blending between the active selection
and the area surrounding it. The greater the amount of feathering, the
wider the area where the image blends into the background. Normal feath-
ers half the width inside the selection edge and half outside. Inward and
Outward types feather only on one side of the selection edge. Widths of 1
to 64 pixels may be entered.
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Border…
The Border… command creates a feathered selection with the edge of the
current selection as its center. In this mode, the selection is feathered both
inside and outside half the number of pixels entered in the Width
textbox.

Smooth Edges…
The Smooth Edges command cleans up rough or jagged selections. It has
three settings: Light, Medium, and Heavy which control the amount of
smoothing.

Drop Shadow…

The Drop Shadow… command creates shadows for selections and type. The left
side of the dialog box gives a visual reference to the shadow’s positioning.

The Feather slider controls the softness of the shadow edge. Values are entered by moving the
slider bar, clicking on the pointers at either end of the slider or entering a number of pixels in the
textbox.

The Intensity slider controls the opacity of the shadow. Values are entered by moving the slider
bar, clicking on the pointers at either end of the slider or entering a percent in the textbox.

The Offset area controls the positioning of the shadow in relation to the
selection. Enter numbers in the Horiz (Horizontal) and Vert (Vertical)
textboxes. The shadow may also be repositioned by moving the cursor over the
display area on the left and clicking and dragging.
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The Units pop-up lets you choose from pixels, inches, centimeters, picas, points or
percent.

Extrude…

The Extrude… command creates a 3D appearance for selections and type. The left
side of the dialog box gives a visual reference to the extrusion’s positioning.

The Distance slider controls the depth of the extrusion. Values are entered by moving the slider
bar, clicking on the pointers at each end of the slider or entering a number of pixels in the
textbox.

The Direction radio buttons control the angle of the extrusion. Click the button that corresponds
to the direction you wish.

The Operation radio buttons let you choose between Fill Solid (filling the
extrusion area with a solid color such as the example above) or Select (making the
extrusion a selection on the active layer which can later be modified, as shown in
the example at the left).

Show/Hide Marquee
The Show/Hide Marquee command [Command-H] is a toggle which controls the display of the
moving dotted lines showing the edges of a selection.

Pick Up/Put Down Selection
This toggle command lets you pick up and move a selection or place a selection while keeping it
active. 

Use Selection As Mask
When checked, this command lets you paint or perform other operations within a selection on
the active layer while protecting the area outside of the selection.
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Add to Web Image Map
This command adds the active selection to the
Web image map for the document. For more
information, see Chapter 10, The Web Image
Map Palette.
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18:  The Filter Menu
The Filter menu contains commands for adjusting color levels, tone, brightness/-
contrast; to lighten or darken an image; for adjusting or replacing colors, removing
red eye, and to apply image maps and filters. It also lets you apply third party plug-
in filters (such as those compatible with Adobe Photoshop).

Last Filter
The Last Filter command [Command-F] is the first command listed in the Filter
menu. The command changes to reflect the last filter used, and is a shortcut to apply
that filter with the same settings once again.

Adjustment
The Adjustment command displays a submenu with commands for
adjusting the image for a document or selection.

Levels…
The Levels… command lets you adjust the
brightness, contrast  and gamma in an image.
The command opens a dialog box containing a
histogram of the image. (A histogram displays
the frequency distribution of the number of
pixels in an image at a specific color level.)

The three pointers on the bottom of the
histogram control the Input levels—shadows,
Gamma (midtones), and highlights—and
increase the contrast. Values can also be
entered for each in the textboxes above the
histogram display.

The Output levels reduce the contrast. Values
can be entered in the textboxes, or the two
pointers on the Output bar can be moved.

The effect of the adjustments to the image are
shown in the After image at the lower left. You 

can choose the portion of the image to be shown in the Before and After boxes by clicking and
dragging the selection rectangle in the small image at the top left or in the Before view.

The Channel pop-up menu lets you select which channels are displayed in the histogram:
Red, Green, Blue, or Composite (all individual channels combined).
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The Display pop-up menu adjusts the histogram display. Selected options are marked
with a bullet.

Normal includes all the blacks, whites and colors in the image. No Black/White ignores
all pixels at the first index (0) and the last index (255). Some filters group pixels at these
extreme positions, so it is common for the large number of pixels at these locations to
overshadow the others in between.

Compressed compresses the high peaks in the histogram, making the distribution of the 
other colors in the image easier to see. Cumulative sums the number of pixels in the image that
are darker than a selected level.

The bottom portion of the pop-up menu controls the type of display for the histogram. Gradient
displays a gradient range that accurately depicts the black, white and grays in the image. Solid
Black fills the histogram area with black. Outline displays the histogram as a line.

Checking the Live checkbox applies changes to the entire screen and removes the Before and
After views.

Curves…
The Curves… command adjusts an image’s bright-
ness, contrast and gamma at any point along the
color scale. It opens a dialog box that displays an
image map. The horizontal axis in the chart repre-
sents the colors in the original image (shadows to
the left, highlights to the right). The vertical axis
represents the colors in the output image (shadows
at the bottom, highlights at the top). The 45° line
indicates the original and output images are the
same.

The effect of the adjustments to the image are
shown in the After image at the lower left. You can
choose the portion of the image  shown in the
Before and After boxes by clicking and dragging
the selection rectangle in the small image at the top
left or in the Before view.

The tools to the right of the curve display are used to make adjustments in the curve. The Pointer
tool selects a region of the map. The Pencil tool makes free-form modifications to the map. The
Line tool draws straight lines in the map. The Fixed Point tool places a point when you click on
the curve that holds the curve to that value at that point. Clicking and dragging on the curve
moves it smoothly around any fixed points. You may also click and drag to reposition any set
points. Double-clicking creates nine evenly-spaced points on the curve. The Curve tool draws a
1.6 gamma curve in the map. Dragging the curve horizontally produces a shallower curve; drag-
ging vertically produces a steeper curve.

The Map pop-up menu lets you open existing image maps and save new maps.

The Channel pop-up is identical to the pop-up described earlier in this chapter under
the Levels command.
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The Slider pop-up lets you adjust Brightness, Contrast, Gamma and Posterization of the
image. Adjustments can be made by moving the slider button or clicking the pointers at
each end. The Reset button returns the settings to their defaults.

The preview selection image, Before and After images and the Live checkbox all function as
described under the Levels command earlier in this chapter.

Auto Enhance…
The Auto Enhance command is a quick
method of improving poor quality images.
Much like a camera, the Exposure amount
can be adjusted the equivalent of 6 ƒ-stops
up or down in 1/3-stop increments by
clicking on the arrows. The Contrast can
be adjusted up or down in 1/2-stop incre-
ments. The Contrast according to high-
light checkbox optimizes the image based
on its highlights and is most effective on
images with lots of white or highlight
areas.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection 

rectangle in the small image at the top left or in the Before view.

Checking the Live checkbox applies changes to the entire screen and removes the Before and
After views.

The Reset button returns the settings to their defaults.

Auto Contrast
The Auto Contrast command is a shortcut to improve an image by optimizing the brightness and
contrast, and has no dialog box. This is often the only contrast adjustment needed to improve the
image.

Brightness/Contrast…
The Brightness/Contrast… command
[Command-B] also adjusts the brightness
and contrast of an image. The command
opens a dialog box with sliders. The top
slider adjusts Brightness in percentages
±100%. The bottom slider adjusts Contrast
in percentages ±100%. Adjustments are
made by moving the slider bar, clicking on
the pointers at each end of the slider or
entering a +/- percent in the textbox.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

Checking the Live checkbox applies changes to the entire screen and removes the Before and
After views.

The Reset button returns the settings to their defaults.
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Lighten/Darken…
The Lighten/Darken… command
[Command-L] opens a dialog box to
adjust the image levels. Vary the amount
of lightening or darkening by moving the
slider bar, clicking on the pointers at each
end of the slider or entering a +/- percent
in the textbox.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

Checking the Live checkbox applies changes to the entire screen and removes the Before and
After views.

The Reset button returns the settings to their defaults.

Brightness RGB…
The Brightness RGB … command opens a
dialog box similar to Brightness/Contrast,
but with individual sliders for the red,
green and blue channels. Adjustments are
made by moving the slider bar, clicking on
the pointers at each end of the slider or
entering a +/- percent in the textbox. 

Checking the Lock checkbox links all 3
sliders together.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

Checking the Live checkbox applies changes to the entire screen and removes the Before and
After views.

The Reset button returns the settings to their defaults.
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Contrast RGB…
The Contrast RGB … command opens a
dialog box similar to Brightness RGB,
with individual sliders for the red, green
and blue channels. Adjustments are made
by moving the slider bar, clicking on the
pointers at each end of the slider or enter-
ing a +/- percent in the textbox. 

Checking the Lock checkbox links all
sliders together.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

Checking the Live checkbox applies changes to the entire screen and removes the Before and
After views.

The Reset button returns the settings to their defaults.

Adjust HSL…
This command opens a dialog similar to
Contrast RGB, but with sliders for Hue,
Saturation and Lightness. With this filter,
it is easy to change the entire color balance
and intensity of an image.

Adjustments are made by moving the slid-
er bar, clicking on the pointers at each end
of the slider or entering a +/- percent in
the textbox. 

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

The Reset button returns the settings to their defaults.

Remove Red-eye
This command automatically searches for the range of colors 

reflected by eye pupils when a flash is too close to
the camera. Because skin tones may share many of
these colors, it is best to select the pupils first (with 
he Lasso tool, for example) before applying the
filter.

Before After
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Image Map
The Image Map command displays a submenu with commands for changing the map for
a document or selection.

Invert
The Invert command [Command-I] creates a negative of the image: white becomes black; black
becomes white; 30% black becomes 70% black, etc.

Equalize
The Equalize command adjusts the distribution of the colors in the image to make all saturation
levels more even.

Threshold…
The Threshold… command opens a dialog
box to convert the image to only pure
black and white areas.

Levels below the threshold point turn
black and levels above the threshold point
turn white. The threshold point may be set
by moving the slider bar, clicking on the
pointers at each end of the slider or enter-
ing a number from 1–255 in the textbox.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by 

clicking and dragging the selection rectangle in the small image at the top left or in the Before
view.

Checking the Live checkbox applies changes to the entire screen and removes the Before and
After views.

Posterize…
The Posterize… command allows you to
create special effects by limiting the num-
ber of color levels in the image. The num-
ber of levels is entered in the text box or by
moving the slider bar, clicking on the
pointers at each end of the slider or enter-
ing a number from 1–255 in the textbox.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

Checking the Live checkbox applies changes to the entire screen and removes the Before and
After views.
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Blur
The Blur command displays a menu with several blur options.

The first Blur… command opens a dialog
box where the image can be blurred by
moving the slider bar, clicking on the
pointers at each end of the slider or enter-
ing a number in the textbox.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

The Blur (1) and Blur More (2) commands
are pre-set and have no dialog box. They
apply directly to the image.

Convolution
The Convolution command displays a menu with two options.

Kernel…
The Kernel… command opens a dialog
box with a pop-up menu of all the kernel
filters available 

through the Kernel brush on the Tools palette. No sliders or controls are
featured, just the before and after view as shown.
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Custom Convolution…
The Custom Convolution…
command opens a dialog box
that lets you create and/or
apply a convolution filter to a
document or selection.

A convolution filter is an “area
operator.” The filter looks at
an area, performs a mathemat-
ical operation, and then
decides how to change the
center pixel.

The Size pop-up
lets you choose
from several types
of grids.

The Symmetry pop-up menu lets you choose between None, Horizontal, Vertical,
Horz/Vert, or Radial.

The Divide by pop-up menu lets you choose between One, Auto Sum and Other.

The Post-Process pop-up menu offers None, Scale, Offset, Difference or Sub Diff
(Subtract Difference).

The center pixel cell in the grid is the point all convolution kernels calculate for. Select
a grid cell by clicking on it and enter a number in the box.

The Test button lets you apply the convolution to the After image to see the effect.

The New button resets all cells in the grid (except the center) to zero.

The Open button opens a standard Open box that lets you open existing kernels stored in the
Convolution folder in the Color It! Stuff folder.

The Save button opens a standard Save dialog that lets you save any convolution kernels created
for later use.

Noise
The Noise command displays a menu of methods for adding or subtracting noise
from an image. Noise is pixels of random colors scattered throughout an image
that may or may not be desirable.

118 Chapter 18: The Filter Menu Color It!™ 4.0 Manual 



Add Noise…
The Add Noise… command opens a dia-
log box that just the Levels (the harshness)
by moving the slider bar, clicking on the
pointers at each end or entering a number
in the textbox.

The Area slider sets the color levels to be
affected (light to dark areas); and is adjust-
ed by moving the slider bar or clicking on
the pointers at each end. Positioning the
slider knob in the middle evenly distrib-
utes the noise throughout an image.

Two type of noise (Uniform or Gaussian)
are available: Uniform applies random
noise along a linear distribution; Gaussian
selects the values along a Gaussian curve.

The effect of the adjustments to the image are shown in the After image. You can choose the
portion of the image to be shown in the Before and After boxes by clicking and dragging the
selection rectangle in the small image at the top left or in the Before view.

De-Speckle…
The De-speckle… command opens a dia-
log box used to reduce noise in an image.
Adjust the Intensity by moving the slider
bar, clicking on the pointers at each end of
the slider or entering a number between 1
and 16 in the textbox.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

Quick Dust-off
The Quick Dust-off command helps to remove small specks and imperfections within an image.
The command is pre-set and has no dialog box—it is applied directly to the image.
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Remove Scratches…
The Remove Scratches… command opens
a dialog box where dust marks, scratches
and other small imperfections can be min-
imized or removed from an image. The
Scratch Size slider controls the size of the
imperfections to be removed. As the
Scratch Size increases, more detail is lost
in the image. The Image Quality slider
helps to replace some of this lost detail. It
can be set from 0 to 255.

Adjust the controls by moving the slider
bar, clicking on the pointers at each end of
the slider or entering a number between 0
and 16 in the text box for the Scratch Size
and 0 to 255 for the Image Quality.

The effect of the adjustments to the image
are shown in the After image. You can 

choose the portion of the image to be shown in the Before and After boxes by clicking and
dragging the selection rectangle in the small image at the top left or in the Before view.

Sharpen…
The Sharpen command opens a submenu of commands that sharpens fuzzy images
by increasing the contrast of adjacent pixels.

Unsharp Mask… opens a dialog box that
allows you to adjust the image sharpness.
Adjust the Intensity by moving the slider bar,
clicking on the pointers at each end of the slider
or entering a number from1–16 in the text box.

The Percent text box determines the amount of
sharpening. Values above 100% magnify the
intensity of the sharpening.

The Level text box sets how much contrast and
difference must exist between the sharpening
pixel and the original before replacing it.

The effect of the adjustments to the image are
shown in the After image. You can choose the
portion of the image to be shown in the Before 

and After boxes by clicking and dragging the selection rectangle in the small image at the top left
or in the Before view.

The Sharpen (1) and Sharpen More (2) commands are preset and have no dialog box. The effect
is applied directly to the image.
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Stylize
The Stylize command opens a submenu with commands for altering the visual appearance
of the image.

Mosaic
The Mosaic command opens a dialog box that
lets you group pixels into mosaic squares. The
filter averages the color values of the pixels
within the square and changes them all to that
value. Adjust the Levels by moving the slider
bar, clicking on the pointers at each end of the
slider or entering a value between 2 to 64 in the
text box.

The effect of the adjustments to the image are
shown in the After image. You can choose the
portion of the image to be shown in the Before
and After boxes by clicking and dragging the 

selection rectangle in the small image at the top left or in the Before view.

Solarize
The Solarize command applies an image map that changes the
image by inverting the upper 50% of the colors.

Video
The Video command opens a submenu with commands for adjusting images for
video use.

The NTSC Video Safe…command changes the image to eliminate extremely
dark or light (saturated) colors which do not display well on standard NTSC
video devices such as televisions and video recorders.

The Compressed radio button remaps gray levels of 0–255 to 12–243.

The Cropped radio button remaps gray levels by changing all levels below 12
to 12. All levels above 243 are changed to 243.

The De-Interlace… command opens a dialog box where several methods
can be chosen for de-interlacing images from video devices.
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Other
The Other command opens a submenu with other commands for adjusting images.

Minimum…
The Minimum command opens a dialog
box where  the Intensity can be adjusted
by moving the slider bar, clicking on the
pointers at each end of the slider or enter-
ing a number from 1–16 in the text box.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

Maximum…
The Maximum command opens a dialog
box where the Intensity can be adjusted by
moving the slider bar, clicking on the
pointers at each end of the slider or enter-
ing a number from 1–16 in the text box.

The effect of the adjustments to the image
are shown in the After image. You can
choose the portion of the image to be
shown in the Before and After boxes by
clicking and dragging the selection rectan-
gle in the small image at the top left or in
the Before view.

Third Party Plug-in Filters
Color It! supports third-party plug-in filters compatible with Adobe Photoshop™. These filters
must be put in the Plug-ins folder inside the Color It! Stuff folder (the Color It! Stuff folder is
located inside the Color It! folder). If Color It! is running, you must quit and restart the applica-
tion for these plug-in filters to be available. The filters may appear in different sub-menus on the
Filters menu.
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19:  The Tools Menu
The Tools menu lets you display or hide the different palettes, set the 
antialiasing and drag updates for the tools, and set the cursor style.

Tools
The Tools command [Command-T] is a toggle that displays or hides the Tools
palette. Like most commands in this menu, a check appears by the command when
the palette is open.

Clicking on the Zoom box in the top right corner of the title bar of all palettes shrinks
them to a reduced version to save space.

See Chapter 8, The Tools Palette for a thorough discussion of the Tools palette.

Colors
The Colors command [Command-Y] is a toggle that displays or hides the Colors
palette, which is used to select and edit colors and patterns. The number of colors
available depends on the image type of the document: Millions of Colors,
Thousands of Colors, 256 Colors or Grays, 16 Colors or Grays or Black and White.

See Chapter 9, The Colors Palette for a complete discussion of the Colors palette.

Paint Controls
The Paint Controls command [Command-U] is a toggle that displays or hides the
Paint Controls palette.

See Chapter 8, The Tools Palette for a complete discussion of the Paint Controls
palette.

Color It!™ 4.0 Manual Chapter 19: The Tools Menu 123



Brush Options
The Brush Options command is enabled when you select the Brush, Air Brush,
Blur, Sharpen, Stamp, Smudge, Lighten or Darken tools from the Tools palette.
Selecting the command opens the Brush Options palette, allowing you to set
several controls for a tool at one time. The Gradient, Spacing, Repeat, and Fade
are common to all brush tools. The slider and top option vary with the tool
selected—Opacity when the Brush or Stamp tools are selected; Pressure when
Smudge is selected; Flow when Air Brush is selected; Intensity when the Sharpen,
Blur, Lighten or Darken tools are selected.

See Chapter 8, The Tools Palette for a complete discussion of the Brush Options
palette.

Mouse Coordinates
The Mouse Coordinates command is a toggle that displays or hides the Mouse
Coordinates palette. Double-clicking the Pointer also toggles this palette.

The top area indicates the percentages of colors at the cursor point.
The Color pop-up lets you select how to display the RGB values. The Hex
setting is used for color specification for Web images.

The next area indicates the width and height of any selections, measured in the chosen
units.

The Units pop-up menu lets you select which measurement units to display.

X and Y identify the cursor location, based on the ruler origin point (normally
the upper left corner of the active window).

The fourth area indicates the straight-line distance from the point where the mouse button was
held down to the current cursor position. The angle of this straight-line distance is also indicated,
measured in the chosen units.

The Web Map Palette
The Web Map palette is a floating
palette that is used to create and
modify web image maps. It can be 

opened or closed from the Web Map Palette Tools menu. A web image map is a text file that
describes the regions within a graphic that link to an HTML web page or location within a Web
page. 

See Chapter 10, The Web Map Palette for a complete discussion of the this palette.

The Animation Palette
This palette is used to create GIF images which
contain multiple frames that may be played
back in sequence as an animation for Web
pages.

See Chapter 11, The Animation Palette for
more information.
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Catalogs Palettes
The Catalogs command opens a submenu where new catalogs can be created or
existing catalogs opened. A catalog is a floating palette containing thumbnails of
images assembled from documents. Thumbnails made be added or deleted, or moved
from one catalog to another. Original images can be opened for editing, moved to new
locations or deleted from within the catalog.

See Chapter 12, The Catalog Palettes for a complete discussion.

Show/Hide Palettes
The Show Hide Palettes command [Tab] is a toggle that removes and restores any open palettes
from view without closing them.

Antialiasing
The Antialiasing command is a toggle that eliminates jagged
edges of text or objects by blending the sharp contrasts between
the different colors, making the images appear smoother on
screen. It is available only when the Shape Selection, Shape 

Object, Line, Paint Can, Text, Scissors, Zap or Bezier tools are in use. When 
you select Antialiasing for a tool, a check mark appears next to the
command in the Tool menu.

Drag Delay
The Drag Delay command is a toggle that controls when pastes, object and line screen redraws
are updated as you move or draw them. The normal setting (with no check mark next to the
command in the menu) has no delay. With large or complex objects, the screen redraws may be
slow. Activating the command shows only an outline of an item as it is moved and redraws
according to the settings in Edit->Preferences->Tools.

Paint Dither
The Paint Dither command is a toggle that indicates when a document has been dithered.
Dithering creates the illusion of a third color by placing pixels of different colors next to one
another (using blue and yellow to create green for example).

Left: Antialiased Shape;
Right: Antialiasing Off
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Cursor
The Cursor command displays a menu where a cursor style can be
selected. The command applies to all tools except the Hand, Magnify,
Dropper, and Text tools. Either Tool Icon or Crosshair views may be
chosen.

The Brush Size is a toggle that displays an outline showing the size and shape of the current
brush tool as it moves for finer control of brush stroke placement.

Custom Selection…
The Custom Selection… command opens a dialog box where a custom selection can be created.
See Chapter 8, The Tools Palette for more information.
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20:  The Window Menu
The Window menu controls how documents are viewed. All open documents
are listed at the bottom of the Window menu. The active document is identified
with a check mark next to it.

Show Rulers/Hide Rulers
The Show Rulers/Hide Rulers command is a toggle that displays or hides the screen rulers, displayed
along the top and left side of the current window.

The exact horizontal and vertical location of the cursor is indi-
cated as gray lines on the rulers.

The default location for the ruler origin (0,0) is the top left cor-
ner of the document. To change the origin, click in the box at
the corner where the rulers meet and drag into the document.
The new origin will be set where the mouse button is released.
To restore the default ruler origin, double-click in the box.

Inches are the default measurement units for the rulers. Other
units can be selected in either the Mouse Coordinates palette
or with the Rulers... command in the File menu (File->
Preferences->Rulers…).

Magnification
The Magnification menu controls the enlargement or reduction of the document
view. It is similar to the pop-up menu at the bottom left corner of the document
window.

The Other command [Command-M] opens a
dialog box where a custom magnification factor is
chosen. Select a new value from 1 to 32 by entering
a number or using the arrows and select either the
Magnify or Reduce buttons.

The Zoom In [Command-+] and Zoom Out
[Command-–] commands change the document view to the next magnification
factor listed at the bottom of the menu.

Window Mode
Color It! supports three types of window modes—Normal Window, Full Screen,
and No Menubar.

The default mode is Normal Windows, which displays all the standard Macintosh 
window elements as well as Color It!’s magnification pop-up.
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In Full Screen mode, the document fills the screen (except the menu bar) if the view is large
enough. If the view of the document is not large enough, a solid color background fills the rest of
the screen. The background color is chosen from the Document Border pop-up menu in the
Display Preferences dialog box (Edit->Preferences->Display…).

The No Menubar mode is similar to the Full Screen mode except the menu bar is hidden as well.
Although hidden, menus will appear when the mouse button is held down as you click in the
menu bar area at the top of the screen.

New View
The New View command opens another view of the active document. This permits viewing the
same document at different magnifications.

Split Screen
The Split Screen command displays a menu that allows you to view the active
document in a window with a second document selected from the open document
list. Two documents (or two views of the same document) must be open for this
command to be available.

When two documents are seen in a split screen view, the active document is in the left or top
position, depending on whether you choose Left and Right or Top and Bottom from the menu.
To return to a single document view, select the No Split Screen command.

In Split Screen mode, any paint
operation performed in the
right/bottom document window
appears in the left/top document.
This can be very useful when
using Document Masks, as docu-
ments in Split Screen mode are
always perfectly aligned.

See Chapter 17, The Selection
Menu for more information about
using masks.

Display at Resolution
The Display at Resolution command displays the document at its true reproduction size (in a
one-to-one ratio). Color It! displays documents either in 72dpi or at the document’s resolution
depending on the settings in the Display Preferences dialog box (Edit->Preferences->
Display…). High resolution documents displayed at their resolution appear to be magnified (a
300dpi document appears approximately 4 times larger on screen, for example).

Checking Display at Resolution displays documents in the same physical dimensions as they
will print out and were saved in. Left unchecked, all documents are displayed at 72dpi—thus a
300dpi document appears on-screen roughly four times its size (300 ÷ 72 =.4.167).
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memFullErr = -108
Problem: You’ll encounter this error message if
you do not have enough System memory available
to complete an operation. 

Solution: If you are running under the System 7
Finder, you can solve this problem by increasing
the program’s partition size. Sometimes quitting
the program and reloading can free up the memo-
ry.

outOfVDiskErr = -905
Problem: You’ll encounter this error message if
you do not have enough hard disk space for a vir-
tual image.

Solution: You can solve this problem by clearing
space on your hard disk for the virtual image. You
can also set the minimum required free to a lower
number in Files Preferences. If you have more
than one hard disk attached or you have another
partition, you can open the Files Preferences dia-
log and select a different drive or partition to store
virtual images. 

outOfVMemErr= -906
Problem: You’ll encounter this error message if
you do not have enough memory for a virtual
image operation. 

Solution: This is usually a result of fragmented
memory, and you can solve the problem by quit-
ting the program and relaunching it.

imgFileNotSupp = 1
Problem: Color It! doesn’t support the format of
the image file you are trying to open.

Solution: Open the image with the program you
created it with and save it in a format that Color It!
can read.

badPNTGFileErr = 2
Problem: The file has incomplete paint informa-
tion.

Solution: The paint image is damaged or was
saved incompletely, and Color It! cannot read it.

badTIFFData = 3
Problem: The file has incomplete TIFF
Information. 

Solution: The TIFF image is damaged or it was
saved incompletely, and Color It! cannot read it.

badTIFFPack = 4
Problem: The TIFF image was saved with a com-
pression type that Color It! does not support. 
Solution: Open the image with the program that
created it and save using a compression type that
Color It! can read. Color It! supports PackBits com-
pression types.
badTIFFPhoto = 5
Problem: The TIFF image was saved in a type that
Color It! cannot read.
Solution: Open the image with the program that
created it and save the it in a format that Color It!
can read.
noTIFFImage = 6
Problem: The program didn’t save the main TIFF
image, that is, it only saved the image Mask.
Solution: Open the image with the program that
created it and save the entire TIFF image.
badTIFFVers = 7
Problem: Color It! cannot read the TIFF version 
Solution: The file has been saved in a new TIFF
version that Color It! cannot read. Open the file
with the program that created it and save it in the
older TIFF format.
plugInNotFound = 8
Problem: Color It! cannot find the plug-in module
you have selected. 
Solution: Locate the plug-in and place it in the
“Plug-ins” folder inside the “Color It! Stuff” folder.
badPlugInVers = 9
Problem: The version of the plug-in is not support-
ed.
Solution: This may happen if Photoshop develops
new formats for their plug-ins. Check to see if
Color It! has been upgraded or use an older ver-
sion of the plug-in.
badImageType = 10
Problem: Color It! does not support the plug-in’s
image type.

Solution: Open the plug-in and save the image in a
format that Color It! can read.

blankResErr = 11
Problem: Color It! could not find a resource, so it
created a NewHandle.

Solution: This is a serious problem; you should
quit Color It! and relaunch it. If the error persists,
call MicroFrontier.
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pathTooLongErr = 12
Problem: The path name is longer than 255 char-
acters. Usually this happens when a virtual image
folder is inside several layers of folders.

Solution: Move the virtual image folder up a few
levels or rename it with a shorter name.

badSplitDocErr = 13
Problem: Color It! couldn’t find the split screen
document.

Solution: Quit and relaunch Color It!.

ptsTooBigErr = 14
Problem: The points list is too long. You’ll see this
if you have drawn very complex shapes with the
Lasso, Magic Wand, or Shape tools.

Solution: Draw or select with the tool again mak-
ing simpler shapes.

noUndoBufErr = 15
Problem: The required undo buffer does not exist.

Solution: Clear some space on your disk.

noSelMaskErr = 16
Problem: Color It! couldn’t get the required selec-
tion mask.

Solution: Clear some space on your disk.

noSelBitsErr = 17
Problem: Color It! couldn’t expand selection to
image form.

Solution: Clear some space on your disk.

badDithImgErr = 18
Problem: The dither operation wasn’t successful.
Generally this happens when converting a gray-
scale image to a black and white dither.

Solution: Retry the operation converting the
image to a different type. If the problem persists,
call MicroFrontier.

badEPSFVers = 19
Problem: Color It! cannot read the EPSF file.

Solution: You may see this error if you are using
Photoshop. The file has been saved in a new EPSF
version that Color It! cannot read. Open the file
with the program that created it and save it in a
format Color It! can read.

imgTooBigErr = 20
Problem: The image is too big. This usually hap-
pens after you scale an image or you anti-alias
text.

Solution: Images cannot be larger than 16,383 pix-
els vertically and horizontally. Make the image a
smaller size.

imgTooSmlErr = 21
Problem: The image is too small.

Solution: The image is empty or is not one pixel
wide. You must make it bigger.

badPIMsgErr = 22
Problem: Color It! cannot understand the plug-in
message.

Solution: Reinstall the plug-in or contact the
developer or MicroFrontier.
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