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DOCUMENTATION

Note:  Before using MediaEdit, please read the Software License which is 
included on your CD.

     Thank you for purchasing MediaEdit, a powerful frame-by-frame video 
editing application.  With it you can digitally manipulate your movies; touch 
them up, add clips, and even add special effects that would have otherwise 
been very expensive.  MediaEdit is perfect for almost all of your movie and 
image editing projects.  It has many advanced features, including:

• A built in movie theatre for watching movies
• 3 modes for editing media
• Advanced selection tools; marquee, magic wand, and lasso
• Unlimited movie undos
• Integrated imaging tools that allow you to draw directly onto the movie
• Over 100 transitions
• Tonnes of cool effects
• Support for all major picture formats
• A Track window that allows you to easily manage tracks
• Zoom tools that allow you to edit your images with precision
• Support for MIDI and digital camcorders

• Graphic equaliser in view mode

How this Document is Organised
     This document is arranged into several sections.  It is also fully 
searchable with Acrobat’s searching tools.  If you are looking for a particular 
topic, you can also refer to the index at the end of this document.

MediaEdit Online Help
     MediaEdit has online help, just like many other Macintosh applications.  To 
have this installed, you must be running at least System 7.5.5.  You can 
access MediaEdit’s online help through the Help menu.
     MediaEdit also has a small window called the Help Window which will give 
you a short description of a tool when you move your mouse over it.
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System Requirements
     Since MediaEdit works with digital video, it tends to be very demanding on 
the system.  Here are MediaEdit’s minimum working requirements:

-PowerPC Processor
-System 7.1
-Quicktime 4.0
-64 MB RAM

     Without these three things installed in your Macintosh you won’t be able 
to run MediaEdit.  These are also the minimum requirements.  If you are 
working with high-resolution images or long video clipping then you will need a 
G3 processor for decent speeds.  RAM is also something that will help out 
immensely.  If you are working on video then you should probably invest in at 
least 256 MB of RAM.  Turning off virtual memory will also allow MediaEdit to 
run much faster.

Note:  MediaEdit will run on System 7.1 or any newer Mac OS release.  It will 
also run on all current releases of OS X.  Both the OS X and regular versions 
are included on your MediaEdit CD.
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Basic Tools
     MediaEdit has many basic tools that are described in this section of the 
documentation.  Many of these are common to other Macintosh applications.  
If you have experience using other graphics applications on the Mac then you 
can skip this section entirely.
     MediaEdit's basic tools are located in the File, Edit, and Format menus.  
The basic drawing tools are in the "Tools" window.

Menus:

 The File Menu:
     This is where you can create, open, save, and close new documents.  The 
"New" submenu allows you to create either a picture or a movie.  This will 
bring up a window where you can give MediaEdit parameters for the new 
document.  For more information on creating documents in MediaEdit, refer 
to the tutorial section.
     In the file menu there are also the Save, Open, Close, and Quit functions.  
In order to keep your movies and pictures for later use you must save them.  
It's recommended that you do this quite often in case something goes wrong.  
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Save As is also another way to save your document, but it makes another 
copy at the chosen location.  Save will only ask you for the location of the 
document the first time you save it.  To make backups, use Save As.  
     Close is used to close your opened documents.  It will close the document 
in the frontmost window.  You can also print your documents in the File 
menu.  Other File menu options will be discussed later.

The Edit Menu:
     The “Edit” menu contains Copy, Paste, Cut, Undo, Clear, Select All, and 
Zoom functions.  Most of these are common to all Macintosh applications.  
You can use the zoom functions at the bottom of the menu to work on a 
smaller part of your document in more detail by zooming in or out.  You can 
also specify a percentage of the normal size of your document.  A 
percentage larger than 100 will make it appear larger, while one that is less 
than 100 will make the document appear smaller.  You can zoom out to see 
the entire document on your screen if it would not normally fit.
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The Format Menu:
     This menu is where you can control text attributes.  When you are adding 
text via the toolbar and have the text window open, you can change the size, 
colour, and style of the text with this menu.

The Toolbar:
     The toolbar contains most of the basic picture editing tools that you will 
use on both movie frames and pictures.  It allows you to decide whether or 
not you want shapes to be filled with the fill colour, what the line size should 
be, and what the fill and line colours are.  In addition to this it has the 
drawing tools:
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Pencil tool- This is for freehand drawing.  For more accuracy, zoom in before 
drawing.

Selection tool- This allows you to select part of your picture or frame to 
edit. By default it uses the rectangular delection tool.  This can be changed 
by double-clicking the tool.  This is also available in a circular shape.

Paintbrush- This is very similar to the pencil tool.  It is a freehand drawing 
tool which draws with a circular shaped brush, which is also antialiased.

Shape tools- These are used to draw rectangular or ovoid shapes. (Using the 
line colour)

Text tool- This allows you to put text into your picture or movie.  When you 
click on part of a document a text window will come up which allows you to 
type in the text that you would like to add.  The format menu is used to 
change the style of the text that you are editing.  When you click "OK" to add 
the text to your document it is automatically selected so that you can 
position it.

Filled Shape- This checkbox will fill in any shapes that you create with the fill 
colour if it is checked.  If not, only the outline of the shape will be drawn.

Line Size- This allows you to set the thickness of the lines that are drawn.  
This will affect both lines drawn with the line tool and shapes.

Paint Bucket- The paint bucket is for filling in areas with the "fill" colour.  It 
will only fill in an area that is all the same colour.

Eraser Tool-  This tool is used to erase parts of your document.

Lasso Tool- This is a freehand selection tool which allows you to select any 
part of your document.  (You can also use "Invert Selection", from the 
selection menu to select all of your document but a certain area).

Magic Wand- This is another selection tool which works in a way similar to the 
painbucket tool.  It will automatically select an area of a picture which is of 
one colour.

Line Tool- This allows you to draw lines.  (Hold down the shift key to draw 
lines at angles that are multiples of 90 and 45 degrees)
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Eyedrop Tool- This will change the "fill" colour to the colour of the area that 
you click on.  It is useful for using the same colour throughout your picture.

Zoom in/Zoom out- These buttons will zoom in or out on your document.  This 
can also be done through the Edit menu, or with the button in the bottom of 
every document's window.

Fill Colour/Line Colours
These display the current line and fill colours.  You can change these 

colours with the colour picker which will appear when you click on the boxes, 
or with the eyedropper tool.

You can also select the colour that you want to use by clicking on the 
icon next to the coloured box (either the pencil or the paint can).  Another 
way to change the colours is to use the colour window, shown below:

With this palette you can chose RGB, CMYK, or HSV colour.  To change 
the colour, simply drag the triangles around on the sliders.  You can also click 
on the coloured area above to set the colour.
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More Tools
     In addition to MediaEdit’s tools which are common to many applications 
are the tools that it uses which are specific to video editing or MediaEdit 
alone.  This section explains these tools in detail.

Note:  Frames and Effects are not covered in this part of the 
documentation.  If you are looking for information on them, please refer to 
the sections Working with Frames and Working with Effects.

     MediaEdit’s other tools are found throughout the application.  This section 
will first discuss the tools in MediaEdit’s menus.

 The File menu:
     In addition to the items covered in the section “Basic Tools”, there are 
other tools in the File menu.  The first one is “Insert Picture…”, which is 
used to add a picture to the current image or frame that you are working on.  
If you have no documentation open then it will not be enabled.
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     You will also find “Picture Settings…” in the File menu.  This is where you 
can choose how much compression and what kind of compression to use on 
your image or movie frame.  There are over 20 options to choose from, and 
each has its specific use.  Try out several different formats to see which 
one works best with your project.  (Keep in mind that some formats, like 
JPEG, are much more supported than others).
     The last tools in the File menu are the Import/Export and 
Create/Preview/Capture movie tools.  The exporting functions are used to 
save copies of your media outside of MediaEdit for use with other 
applications.  Creating a movie simply exports the movie in one of several 
formats.
     MediaEdit’s capture tool is used to capture video or audio through your 
Macintosh’s audio and video ports or internal mic.  The capture tool allows 
you to playback the video and/or audio that you record.  You can then add it 
to your current movie and edit it.
     The capture tool has both video and sound options.  You can change these 
by clicking on the “Video…” or “Sound…” buttons in the MediaEdit capture 
window.
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Movie Tools:
There are several tools which you will need to know how to use in order 

to edit video in MediaEdit.  Most of these can be found in either the “Movie” 
menu (above), the “Frame” window (below), and the “track” window.

The “Movie” menu contains most of the functions for moving around in 
video, although for some of them the frame window can also be used.  The 
“Movie” menu has seven different items in it for navigating through frames 
in your movies.  Instead of using the “Next Frame”, “Previous Frame”, and 
similar items, you can use the “Frame” window.  To go to a certain frame in 
the frame window, simply click on it.  You can also select multiple frames in 
the frame window by shift-clicking.  To delete selected frames, hit the delete 
key.

To add frames to your movie, go to “New Frame” in the “Movie” menu.  
This will add another frame to the end of your movie.

In the “Movie” menu you can also insert transitions.  There are over 
100 transitions to chose from and you can experiment to find the right one 
for your particular frame.
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The final tools in the “Movie” menu are the Settings and Annotations 
menu items.  Selecting “Settings” will bring up the following window:

In this window you can set the scale, depth, and dimensions of your 
movie.  The size of your movie file will be greatly influenced by the movie 
settings.  To reduce a movie’s physical size, reduce its FPS or Depth.  If you 
reduce a movie to 16-bit from 32-bit, for example, your movie file will be 
roughly half as large.

The final tool in the “Movie” menu is the annotation editor.  This is 
where you can add comments and information to your movie.  To add a new 
annotation, click on the “New…” button in the bottom left-hand corner of 
the window, then select the type of annotation that you would like to make.  
Type the information in the editfield that appears below.

As a final note, you can change the frames window to display its 
contents by frame or time with the popup menu in the bottom right-hand 
corner.
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MediaEdit Tutorial- Working with a Movie File
This section of the documentation describes in detail the various tools 

that you have at your disposal to create and edit movie files.  It is divided 
into several steps.  Most of the tools covered in this section have already 
been discussed.

Step 1- Creating the Movie File
To create a new movie, go to “New”->”New Movie…” in the file menu.  

This will bring up the following window:

This window allows you to set some of your movie’s basic attributes.  
You can change these later on but it is a better idea to decide them in the 
beginning.  Here are some basic definitions of movie attributes for those who 
have never edited video in the past:

-Width/Height:  These define the physical dimensions of your movie.  This can 
be specified either in pixels, inches, millimetres, or centimetres.  This will 
have a large effect on the size of your movie and how quickly it runs on 
slower machines.  The minimum size for normal video is 320x240 pixels.  The 
maximum dimensions, however, are limited only by the amount of RAM that 
you have available.

-Depth:  This is the number of bits that your computer uses to define the 
colour of each pixel.  A larger bit depth means that your movie will have more 
colours, and will therefore look better (in most cases).  Colour depth also has 
a large effect on the size of your movie file.  A 32-bit movie will be almost 
twice as large as a 16-bit one.
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-Scale:  Represented in FPS, or Frames Per Second, this is how quickly your 
movie’s frames are shown.  If this number is higher, you will need more 
frames for a movie of the same length.  In general, it is a good idea to run 
video at 30 fps or higher.  Below this level will cause the image to flicker and 
will make the movie look less realistic.

Step 2- Editing your First Frame
Once you have your movie created, you are free to edit your first 

frame.  In general, this is done with the tools from the toolbar window.  To 
add some text, for example, click on the button with the letter “A” in the 
toolbar, then click on the location where you want to place the text.  You can 
change the text’s attributes in the “Format” menu.

When you have your text added to the movie frame, it will 
automatically be selected.  It should look something like this:

You can click within the bounds of the selection and drag the text 
around to put it where you want it.  Once you click outside of the text, it will 
no longer be selected.  You will have to re-select it at that point if you want 
to move it again.
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Let’s try out some other tools.  To fill in part of the frame with a 
certain colour, use the paint tool.  Here’s a picture of the original frame with 
some of the text and the background coloured in, and with some shapes 
added:

When you use the paint tool, it will fill in an entire region of the frame 
which shares a certain colour.  That’s why it painted the entire background 
(which was all white), and not all of the text.  If you want to change the 
colour of the paint tool, click on the coloured box next to the paint can icon 
in the bottom of the toolbar.  That will bring up a colour picker that you can 
use to select your new colour.  The other coloured box below is for the line 
colour, which is the black colour that you see around the green box above.

If you want to edit a part of the frame that you’ve previously worked 
on, you will need to know how to use the selection tools.  There are three 
selection tools, arranged in the second row of buttons in the toolbar window.  
Here’s what they look like:
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The rectangle marquee is for selecting a rectangular part of your 
movie frame.  The lasso is a freehand selection tool- you can drag it around 
to select what you want.  Finally, the Magic Wand is similar to the pain tool.  
It selects a region of the current frame which has the same colour.  The 
picture below shows how you can select part of your frame with the lasso 
tool:

You can drag the selected (outlined) part of the frame just like you 
could drag the text around.  You can also resize the selection with the 
squares in the corners of the selection.

There are also more selection tools in the “Selection” menu, shown 
below:
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“Bind to Edges” and “Unbind to Edges” both change the size and 
dimensions of the selection.  “Bind Selection” will remove all white edges 
from the selection.  “Unbind Selection” changes the selection to a rectangle 
that includes everything that was previously selected.

“Inverse Selection” will select everything that is not selected and 
deselect everything that is selected.  It’s useful if you want to select all of 
the image but a certain part.

The last item in the “Selection” menu is an option.  When “Use Selector 
Only” is enabled you can drag the selection outline itself around.  This will 
leave the actual image that was selected before where it was.

Another way to select part of an image is with the mask editor, which 
is found in the “Effects” menu.  This is described in the next section of the 
documentation, called “Working with Effects”

The rest of the tools in the toolbar are fairly simple.  You can play 
around with them to find out what they do.  If you make a mistake then you 
can Undo it with Command+Z or through the “Edit” menu.

Step 3- Adding and Working with Frames
When you finish your first frame, you can add another with “New 

Frame” in the “Movie” menu.  When you add the new frame, the document 
window will display it.  The new frame will also be added to the list of frames 
in the frames window.  To go back to your old frame, you can click on it in 
the Frame window or you can select “Prev Frame” from the “Movie” menu 
(Or hit Command+2).

If you decide that you no longer want to keep your frame, you can 
select it in the Frame window and then hit the Delete key.

You can also add transitions between frames.  To add a transition, 
select the frame where you want the transition to start and go to “Movie” -> 
“Insert Transition”.  MediaEdit will then bring up a menu where you can select 
the transition that you’d like to add.

In addition to frames, MediaEdit also allows you to work with audio 
tracks in your movies.
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Working with Effects
If you look under the “Effects” menu you will see that there are many 

effects which MediaEdit includes for you to use when editing images or movie 
frames.  MediaEdit even has a plugin engine which allows you to make your 
own effects.  (This is covered in detail near the end of the documentation)

This section of the documentation will cover all of the Effects tools in 
MediaEdit.  The first tool is the Contrast and Brightness tool.  When you 
select the tool it will bring up the following window:

In this window there are two sliders, one for brightness and one for 
contrast.  By dragging the bars on them back and forth you can change the 
brightness and contrast values for your image.  By default these are both 
set to 0.

By reducing the contrast you reduce the different between colours.  
The image above shows two rounded rectangles (one green and one red) at 
30% contrast.  Note how the colours look “washed-out”.  The lower the 
contrast, the stronger this effect.  When the contrast is set to -100% the 
entire image will be one colour.
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The brightness slider affects the amount of “light” in the image.  At 
100% the image will be as bright as possible (white) and at -100% it will be 
completely black.  The effect from lowering the brightness is similar to the 
effect from the lowering of contrast.

The next item in the “Effects” window is “Image Filters”, which will 
bring up the following window:

There are too many effects to go into detail on every one, but you can 
select them from the popupmenu on the left and try them out for yourself.  
The “Weight” slider to the right controls how much the filter affects the 
image.  The higher the weight, the stronger the filter.  You can also remove 
either red, green, or blue parts of the image’s colour by deselecting the 
checkboxes in the lower left hand corner of the window.  To keep your 
changes, click OK.  If you do not wish to apply the filter, click Cancel.
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The third tool in the “Effects” window is a powerful tool called the 
Mask Editor which allows you to edit your selection or mask out a part of the 
image.  This is where you can add transparency to an image.  When editing 
the mask of an image most of the regular image manipulation tools are 
available.  To make a part of the image completely transparent, colour its 
corresponding part of the mask white.  A black section of the image will be 
completely opaque.  MediaEdit can also use grays in its masks to make part 
of an image semi-transparent.

The next few tools in the menu are for rotating your image. After 
these you will find Fill, Pick Up, Invert, and Grayscale.  All of these will work 
on a selection.  Fill will make the selection completely white.  Invert reverses 
the colours (similar to a negative), and Grayscale will take all colour out of 
the selection.  Pick up allows you to change the colour of the selected part 
of the current image to the fill colour.

The rest of the tools in this menu are all filters and plugins which you 
can test individually to find out what they do.   In general, you can customise 
the effects of these tools with “Effect Weight”, in the effect menu.  The 
higher the effect weight, the stronger the effect of the filter or plugin.  For 
example, if you try “blur” with an effect weight of 1, the image will be 
blurred much less than at an effect weight of 10.
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Extras
MediaEdit has additional tools which you can use to play movies or 

change MediaEdit’s appearance.  You’ll find these in the “Viewer” and 
“Special” menus, shown below.

                 

The “Viewer” menu contains all of the controls for MediaEdit’s viewer.  
These all work in a way similar to the tools that you’ll find in the Quicktime 
Player, along with some extras.  You can also open a movie online with “Open 
URL”.

The “Special” menu contains the VCD Player, MediaEdit Theatre, and 
Skin selection.  The VCD player is used to play CDs with video on them.  To 
play a VCD, put it into your CD-ROM drive and select this option from the 
special menu.  A window will come up which will allow you to open the tracks 
like any other MediaEdit movie.
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MediaEdit theatre is an extra tool which contains trailers and other 
movies that you can watch.  These are all served online.  Simply navigate 
around in the MediaEdit theatre in the same way that you would move around 
in a “Save” dialogue box.  You can also share movies on the MediaEdit theatre 
so that others can view them.

Note: The MediaEdit Theatre is meant for things like movie trailers and home 
made movies.  Movies with pornographic or copyrighted content are not 
allowed!  In order to use the theatre, you must agree to the messagebox 
which comes up when you go to access it, and you must also have an internet 
connection.  There is no guarantee that MediaEdit Theatre’s server will 
always be operational.
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