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Introduction

About Microspot PrintmiX

Microspot PrintmiX makes it easy to arrange and print out multiple images on one sheet of 
paper.

PrintmiX provides a selection of layouts and frames. After choosing a layout, simply drag and 
drop images into the PrintmiX template directly from a PhotoXtra or iPhoto album or from the 
Finder, or place an image into the template using the Insert Image tool. Reduce or enlarge the 
images within PrintmiX, and add frames around them if desired. When you are happy with 
your layout, send the page to print.

Requirements

Mac OS X version Classic version

• Macintosh with G4 processor • Macintosh 68020 or greater.

• CD Drive • CD Drive

• Mac OS X • Mac OS 7.1 or later

• 5MB free RAM • 5MB free RAM

• QuickTime 3.0

• Drag & Drop manager.
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Installing the Application.

To install Microspot PrintmiX:

1. Double-click the PrintmiX Installer icon on the PrintmiX CD.

2. Follow the instructions that display.

The Microspot PrintmiX folder is installed at the location specified. An alias to the Print-
miX application is placed on the desktop.

Launching and Enabling the Application

To launch the PrintmiX application:

• Double-click the PrintmiX icon within the Microspot PrintmiX folder.

or

• Click the PrintmiX alias on the desktop.

The application opens.

The first time you launch PrintmiX you are asked to enter a name and valid serial number to 
enable the software.
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To enable Microspot PrintmiX:

1. Enter a name and valid serial number (the organization name is optional) in the dialog 
that displays.

The serial number must be valid for the version you are using. This is supplied with the 
PrintmiX software when purchased.

2. The OK button is available only when you type in a valid serial number.

• Click OK to open the application.

• Click Cancel and the application runs in demo mode. Images will print with the word 
‘Demo’ across them.
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When running PrintmiX in demo mode, select Enter Serial Number from the PrintmiX menu to 
enter a serial number and enable the application.

Getting Help

The Help Palette

The first time PrintmiX is launched, the Help palette displays automatically.

• Click on the various tabs to display information about that subject.

• Close the palette by clicking on the Close box in the top left corner of the palette.
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• Display the palette again at any time by clicking on the Help tool in the PrintmiX tool 
area.

The Microspot PrintmiX Manual

The PrintmiX manual is included on the Microspot PrintmiX CD in pdf format. An installer for 
Adobe™ Acrobat™ Reader is also included. The manual is installed on your hard drive during 
the installation process.

Once Acrobat Reader is installed, select PrintmiX Manual from the Help menu and Acrobat 
Reader will launch and open the manual. You can then navigate through and read the manual on 
screen, or print sections for your reference.

Registration

Register Microspot PrintmiX via the internet, or by filling in and returning the registration card 
included with the product.

To register via the internet:

1. Launch Microspot PrintmiX.

2. Select Registration Information from the Help menu.
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The Registration Information dialog displays:

3. Click Connect to go to the Microspot product registration web page.

4. Follow the registration instructions.

Once you have registered the product, Microspot can send you information about 
upgrades and new products.

Upgrades

To obtain any available information about upgrades from the Microspot web site, select 
Upgrade Information from the Help menu in PrintmiX.

Technical Support

You must register your product to be entitled to receive technical support.
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For technical support in North America, South America, Australia and New Zealand, please con-
tact:

Macro Enter Corp.
1756 Costa del Sol
Boca Raton, FL 33432
USA

Technical Support: (561) 395-9704; International: + 1-561-395+9704
FAX: (561) 395-9941; International: + 1-561-395-9941

Email: support@macroenter.com
Web Pages: www.macroenter.com

In Europe and other parts of the world, please contact:

Microspot Limited (Worldwide Headquarters)
Concorde House
10-12 London Road
Maidstone
Kent
ME16 8QA
England

Phone: 01622-687771; International: + 44-1622-687771
FAX: 01622-690801; International: + 44-1622-690801

Email: support@microspot.co.uk
Web Pages: www.microspot.co.uk
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Using Microspot PrintmiX

Getting Started

When PrintmiX is launched, a layout window like the one shown below displays automatically:

• The preview area displays a preview of how your pictures will be printed.

• The Layout tab holds a selection of different layouts used to organize your pictures on a 
page.

• The Frames tab contains a selection of different frames that can be applied around your 
pictures on the layout.

PreviewLayout Tab

Frames Tab

Tool Area
8Microspot PrintmiX



      
• The top part of the tool area contains tools used to insert and manipulate images. At the 
bottom of the tool area are three further buttons used to access the Page Setup and Print 
dialogs, and to display the Help palette.

Layouts cannot be saved, but multiple PrintmiX windows can be open at the same time (mem-
ory permitting). To open a new layout at any time, select New from the File menu.

Choosing the Layout

You choose a layout from the selection available in the Layout tab. Each layout contains one or 
more ‘panes’ into which you can insert images. The layout chosen determines the number of 
images printed on a page, the size of those images, and the position of the images on the page.

To choose a layout:

1. Click the Layout tab to select it, then use the scroll bar to view the layouts available.

2. When you have decided the layout to use, position the cursor over that layout, press and 
hold down the mouse button and move the cursor over the preview area.

Insert Image

Zoom In

Zoom Out

Move

Delete

Page Setup

Print

Help Palette
9Microspot PrintmiX



  
3. Release the mouse button.

The layout selected is applied to the page in the preview area.
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If the images you want to print via PrintmiX are wider than they are tall, you may want to 
change the orientation of the page. This is done via the Page Setup dialog.

4. To display the Page Setup dialog, select Page Setup from the File menu or click on the 
Page Setup icon in the PrintmiX window.

The Page Setup dialog displays.

5. Choose portrait or landscape orientation according to your requirements.

6. Click OK to close the dialog.
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If you wish to print images of a set size, click the ‘Do not resize to page’ checkbox at the 
bottom left of the PrintmiX window.

 

The size of each pane displays on the preview. 

If this box is not checked, the layout is scaled to fill the page.

Placing Images in a Layout

Adding Images

Inserting pictures into the PrintmiX layout is very easy. Pictures can be dropped in directly 
from a PhotoXtra or iPhoto album or the Finder, or inserted using the Insert Image tool.
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NOTE: It is important that the images placed in the PrintmiX layout are of a resolution appro-
priate to the printer to be used to print the images, and to the required size of the printed 
images. If very large image files are placed in the PrintmiX layout, it requires a large amount 
of memory to perform any actions and may be slow to use.

To place an image from a PhotoXtra or iPhoto album into the layout:

1. Open Microspot PhotoXtra or iPhoto. (See the PhotoXtra manual for more information.)

2. Open the PhotoXtra or iPhoto album that contains the image to be placed in the PrintmiX 
layout.

3. Position the album and the PrintmiX window on screen so that both can be seen.

4. Choose an image in the album to place on the PrintmiX layout.

5. Click the image in the album to select it and, holding down the mouse button, drag the 
image over the layout pane that you want to place it in.

6. Release the mouse button.
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The chosen image is displayed in the appropriate pane of the PrintmiX layout.

7. Repeat the process to insert images in the other panes of the layout.

NOTE: To fill up all empty panes with the same picture, hold down the Command key when 
releasing the mouse button to drop the image into the layout.

To place an image into the layout using the Insert Image tool:

1. Select the Insert Image tool in the PrintmiX tool area.

2. Move the cursor over the layout.
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The cursor changes to the Insert Image cursor.

3. Click a pane in the layout preview.

A standard open dialog displays.

4. Locate and select the image you wish to insert in the pane and click Open.

The image selected appears in the appropriate pane of the layout.

5. Repeat the process to insert images in the other panes of the layout.

To place an image from the Finder into the layout:

1. In the Finder, locate the image to place in the layout.

2. Drag the image icon from the Finder and drop it into the desired pane.

3. Repeat the process to insert images in the other panes of the layout.

NOTE: To fill up all the empty panes with the same picture, hold down the Command key when 
releasing the mouse button to drop the image into the layout.

Replacing Images

To replace an image in a pane of the layout with another image, simply insert another image 
over the original.

Deleting Images

To delete an image from a pane, select the Delete tool in the PrintmiX tool area and click the 
image to be deleted.
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Changing the Display of Images

Zooming In and Out

Once an image is placed in the PrintmiX layout, you can use the Zoom In and Zoom Out tools 
to resize the image in the pane.

1. Select the Zoom In tool in the PrintmiX tool area.

2. Click the image on the layout that you wish to zoom in on. Click and hold down the 
mouse button to zoom in more quickly.
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3. Release the mouse button when the image reaches the desired magnification

NOTE: Select the Zoom In tool and hold down the Option key to switch to the Zoom Out tool.

Use the Zoom Out tool in the same way as the Zoom In tool.

Moving the Image in the Layout

When an image is placed in the PrintmiX layout, the Hand tool may be used to position the 
image within the pane.
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1. Click the Hand tool in the PrintmiX tool area to select it.

2. Position the cursor over the image to be moved, then click and hold down the mouse but-
ton.

3.  Drag the image into a new position and release the mouse button.

Using Frames

If you wish, you can choose to include a frame around some or all of the images on the layout.
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Adding Frames

You choose a frame from the selection available in the Frames tab.

To add a frame:

1. Click the Frames tab to select it, then use the scroll bar to view the frames available.

2. When you have decided which frame to use, position the cursor over that frame, press 
and hold down the mouse button, then move the cursor over the preview area.

3. Release the mouse button.

The frame selected is applied to the chosen pane in the layout.
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NOTE: The image in the pane may be resized to fit within the outside edges of the frame. The 
image can still be resized or repositioned after a frame has been applied to it. See Changing 
the Display of Images on page 16.

4. Repeat this process for each pane that you wish to apply a frame to.

NOTES:
A frame can be applied to a pane that does not yet contain an image. Images are added to 
panes that contain frames in the same way as they are applied to empty panes. See Adding 
Images on page 12 for more details.
If there are no frames available in the Frames tab, the Frames folder may have been moved or 
incorrectly installed. Ensure it is located in the same folder as the PrintmiX application.

Replacing Frames

To replace a frame applied to a pane in the layout with another frame, simply drag and drop 
another frame over the first.
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Deleting Frames

To delete a frame and image from a pane, select the Delete tool in the PrintmiX tool area and 
click the frame and image to be deleted.

NOTE: A frame cannot be deleted without also deleting any image in the pane.

Printing

When you have applied images and frames to the layout, and have adjusted the images as 
desired, you are ready to print your layout.

1. Select Print from the File menu or click the Print icon in the PrintmiX tool area.

A Print dialog similar to the one below displays.

2. Enter the number of copies you wish to print.
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3. Click the Print button.

The layout is printed.

Quitting Microspot PrintmiX

When you have printed your layout, close the window by clicking the close box in the top left 
corner of the window, or by selecting Close from the File menu. Layouts cannot be saved

To quit the application:

• Select Quit from the File menu.

The application closes.
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Menus

PrintmiX Menu

About PrintmiX

Displays a window containing information about the PrintmiX application.

Enter Serial Number

If the serial number is not entered when the application is launched, it runs in demo mode. 
Select Enter Serial Number to enter the PrintmiX serial number into a dialog and fully enable 
the application.

Preferences

As there are no preference settings for PrintmiX this option is always grayed out.
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Services

The Services submenu is supplied by the System. Refer to your system documentation for 
details.

Hide PrintmiX

Hides the PrintmiX application and all its palettes and windows.

Hide Others

Hides the windows and palettes of all applications other than PrintmiX.

Show All

Shows the windows and palettes of all applications including PrintmiX.

Quit PrintmiX

Exits from the application. Any open layouts are closed. Layouts cannot be saved.

File Menu
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New

Opens a new PrintmiX layout window.

Close

Closes the current PrintmiX layout window. Layouts cannot be saved.

Page Setup

Displays the Page Setup dialog used to specify how you want your document to appear on the 
printed page. Options include paper size, orientation and scale.

Print

Displays the Print dialog for the currently selected printer.

Edit Menu

The Edit menu is included in the PrintmiX application for reasons of consistency, but as no edit 
options are available, they are always grayed out.
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Window Menu

Minimize Window

Moves a window out of the way by minimizing it, which puts the window into the Dock. This 
is an alternative to clicking the middle button in the top left corner of a window.

Bring All To Front

Brings all the PrintmiX document windows to the front, above the windows of any other appli-
cations.

[Layout Names]

Open layouts are listed at the bottom of the Window menu. Select the layout name to make it 
the active layout.
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Help Menu

Show/Hide Help Palette

Display or hides the PrintmiX help palette.

PrintmiX Manual

Opens the PrintmiX manual.

Registration Information

Displays the Registration Information dialog used to register the product via the internet.

Upgrade Information

Displays the Upgrade Information dialog used to obtain any available information about 
upgrades from Microspot’s web pages.
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