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Right out of the box, Mac OS X comes with a healthy assortment of nearly 50 
freebies: programs for sending email, writing documents, doing math, even 
playing games. Some are dressed-up versions of Mac programs that have been 

around for years. Others, though, are new programs that not only show off some 
of Mac OS X’s most dramatic new technologies, but also let you get real work done 
without having to invest in additional software.

Note: Several of the freebie programs described here are also the subject of other books in this series, includ-
ing iMovie 6 & iDVD: The Missing Manual and iPhoto 6: The Missing Manual. By popular request (and, in 
some cases, indignant request), this chapter now includes concise crash courses in these programs. But the 
full scoop on each of these powerful programs—including tips, tricks, customization advice, troubleshooting 
chapters, and so on—requires a whole other book. 

Your Free Mac OS X Programs
You’ve got a broad assortment of programs in the Applications folder in the main 
hard drive window. The Applications→Utilities folder holds another couple dozen 
mini-programs that handle such workaday jobs as setting up printers and network 
connections, fixing problems on your hard disk, and monitoring the behind-the-scenes 
processing performed by your Mac whenever you launch and run programs. 

All of these programs have been either written expressly for Mac OS X (Cocoa ap-
plications) or adapted for it (Carbonized—see page 170). This chapter guides you 
through every item in your new software library, one program at a time. (Depending 
on your Mac model, you may find other programs in your Applications folder. Apple 

The Free Programs

MacOSX4e_Ch10_RB.indd   307 10/9/2006   1:54:03 PM



308	 mac os x: the missing manual

occasionally includes software of its own, or from other companies, to spice up the 
collection for, say, iMacs or Power Macs.) 

Tip: A reminder: You can jump straight to the Applications folder in the Finder by pressing Shift--A (the 
shortcut for Go→Applications), or by clicking the Applications folder icon in the Sidebar. You might consider 
adding the Application folder’s icon to the right side of your Dock, too, so that you can access it no matter 
what program you’re in. Shift--U (or Go→Utilities) takes you, of course, to the Utilities folder.

Address Book
The Address Book is a database that stores names, addresses, email addresses, phone 
numbers, and other contact information. Address Book is described beginning on 
page 694. 

AppleScript
This folder contains all of the scripts and tools described in Chapter 8.

Calculator
The new Calculator is far more potent than the humble, black-and-white, four-func-
tion program—the last remaining bit of the Mac OS’s original 1984 design—that 
chugged along until 2002. The Tiger Calculator can act as a scientific calculator for 
students and scientists, a conversion calculator for metric and U.S. measures, and 
even a currency calculator for world travelers.

The little Calculator widget in the Dashboard is quicker to open, and it’s great for 
quick four-function number crunches. But the standalone Calculator program is far 
more powerful. For example:

	 •	The calculator has three modes: Basic, Advanced, and—new in Tiger—Programmer 
(Figure 10-1). Switch among them by choosing from the View menu (or pressing 
-1 for Basic, -2 for Advanced, or -3 for Programmer). 

Tip: You can also cycle among the three modes by repeatedly clicking what, on most windows, is the Zoom 
button (the green round dot at upper-left). It’s a first for the Mac—a Zoom button that changes function each 
time you click it—but it’s kind of neat.

	 •	You can operate the calculator by clicking the onscreen buttons, but it’s much 
easier to press the corresponding number and symbol keys on your keyboard. 

	 •	As you go, you can make Calculator speak each key you press. The Mac’s voice 
ensures that you don’t mistype as you keep your eyes on the receipts in front of 
you, typing by touch.

Just choose Speech→Speak Button Pressed to turn this feature on or off. (You 
choose which voice does the talking in the Speech panel of System Preferences.) 

Your Free Mac OS X 
Programs
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Tip: If you have a laptop, don’t miss the embedded numeric keypad, superimposed on the right side of 
the keyboard and labeled on the keys in a different color ink. When you press the Fn key in the lower-left 
corner of the keyboard, typing these keys produces the numbers instead of the letters. (You can also press 
the NumLock key to stay in number mode, so you don’t have to keep pressing Fn.)

	 •	Press the C key to clear the calculator display.

	 •	Once you’ve calculated a result, you can copy it (using Edit→Copy, or -C) and 
paste it directly into another program.

	 •	The Calculator even offers Reverse Polish Notation (RPN), a system of entering 
numbers that’s popular with some mathematicians, programmers, and engineers, 
because it lets them omit parentheses. Choose View→RPN to turn it on and off.

Tip: How cool is this? In most programs, you don’t need Calculator or even a Dashboard widget. Just 
highlight an equation (like 56*32.1-517) right in your document, and press -Shift-8. Presto—Mac OS X 
replaces the equation with  right answer. This trick works in TextEdit, Mail, Entourage, FileMaker, and many 
other programs.

Conversions
Calculator is more than a calculator; it’s also a conversion program. No matter what 
units you’re trying to convert—meters, grams, inches, miles per hour—the Calculator 
is ready. Truth is, the Units Converter in Dashboard is simpler and better than this older 
Calculator feature. But if you’ve already got the Calculator open, here’s the drill:

Calculator

Figure 10-1:
The Calculator program offers a four-function Basic 
mode, a full-blown scientific calculator mode, and a 
programmer’s hex calculator (shown here). 

The first two modes offer a “paper tape” feature 
(View→Show Paper Tape) that lets you correct errors 
made way back in a calculation. 

To edit one of the numbers on the paper tape, drag 
through it, retype, and then click Recalculate Totals. 
You can also save the tape as a text file or print it, by 
choosing File→Save Tape As, or File→Print Tape.
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	1.	Clear the Calculator (for example, type the letter C on your keyboard). Type in 
the starting measurement.

To convert 48 degrees Celsius to Fahrenheit, for example, type 48.

	2.	From the Convert menu, choose the kind of conversion you want.

In this case, choose Temperature. When you’re done choosing, a dialog box ap-
pears.

	3.	Use the pop-up menus to specify which units you want to convert to and from.

To convert Celsius to Fahrenheit, choose Celsius from the first pop-up menu, and 
Fahrenheit from the second. 

	4.	Click OK.

That’s it. The Calculator displays the result—in degrees Fahrenheit, in this ex-
ample.

The next time you want to make this kind of calculation, you can skip steps 2, 3, and 
4. Instead, just choose your desired conversion from the Convert→Recent Conver-
sions submenu.

Calculator is especially amazing when it comes to currency conversions—from pesos 
to American dollars, for example—because it actually does its homework. It goes 
online to download up-to-the-minute currency rates to ensure that the conversion 
is accurate (choose Convert→Update Currency Exchange Rates). 

Tip: If you Control-click the Calculator’s results display, the shortcut menu offers an option called Large Type. 
If you choose it, you get huge, enormous, gigantic type, superimposed upon a smoky background window 
for contrast—a great way to make sure the peons in the back row can see the answer.

Chess
Mac OS X comes with only one game, but it’s a beauty (Figure 10-2). Chess is a tra-
ditional chess game played on a gorgeously rendered board with a set of realistic 3-D 
pieces. You can rotate the board in space, as described in Figure 10-2. 

The program is actually a 20-year-old Unix-based chess program, GNU Chess, that 
Apple packaged up in a new wrapper. 

Playing a Game of Chess
When you launch Chess, you’re presented with a fresh, new game that’s set up in 
Human vs. Computer mode—meaning that you (the Human, with the light-colored 
pieces) get to play against the Computer (your Mac, on the dark side). Drag the chess 
piece of your choice into position on the board, and the game is afoot. 

If you choose Game→New Game, however, you’re offered a pop-up menu with choices 
like Human vs. Computer, Human vs. Human, and so on. If you switch the pop-up 
menu to Computer vs. Human, you and your Mac trade places; the Mac takes the 
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white side of the board and opens the game with the first move, and you play the 
black side. 

Tip: The same New Game dialog box also offers a pop-up menu called Variant, which offers three other 
chess-like games: Crazyhouse, Suicide, and Losers. The Chess help screens (choose Help→Chess Help, click 
“Starting a new chess game”) explains these variations.

On some night when the video store is closed and you’re desperate for entertainment, 
you might also want to try the Computer vs. Computer option, which pits your Mac 
against itself. Pour yourself a beer, open a bag of chips, and settle in to watch until 
someone—either the Mac or the Mac—gains victory.

Chess Prefs
Choose Chess→Preferences to find some useful controls like these: 

	 •	Style. Apple has gone nuts with the computer-generated materials options in this 
program. (Is it a coincidence that Steve Jobs is also the CEO of Pixar, the computer-
animation company?) 

Figure 10-2:
You don’t have to be 
terribly exact about 
grabbing the chess 
pieces when it’s time 
to make your move. 
Just click anywhere 
within a piece’s current 
square to drag it into 
a new position on the 
board (shown here in 
its Marble incarnation). 
And how did this chess 
board get rotated like 
this? Because you can 
grab a corner of the 
board and rotate it in 
3-D space. Cool!

Chess
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In any case, you can choose all kinds of wacky materials for the look of your game 
board—Wood, Metal, Marble, or Grass (?)—and for your playing pieces (Wood, 
Metal, Marble, or Fur). 

	 •	Computer Plays. Use this slider to determine how frustrated you want to get when 
trying to win at Chess. The further you drag the slider toward the Stronger side, 
the more calculations the computer runs before making its next move—and, thus, 
the harder it gets for you to outthink it. At the Faster setting, Chess won’t spend 
more than five seconds ruminating over possible moves. Drag the slider all the 
way to the right, however, and the program may analyze each move for as long as 
10 fun-filled hours. This hardest setting, of course, makes it all but impossible to 
win a game (which may stretch on for a week or more anyway). 

Choosing the Faster setting makes it only mildly impossible.

	 •	Speech. The two checkboxes here let you play Chess using the Mac’s built-in voice-
recognition features, telling your chess pieces where to go instead of dragging 
them, and listening to the Mac tell you which moves it’s making. Page 559 has the 
details.

Tip: If your Chess-playing skills are less than optimal, the Moves menu will become your fast friend. The 
three commands tucked away there undo your last move (great for recovering from a blunder), suggest a 
move when you don’t have a clue what to do next, and display your opponent’s previous move (in case you 
failed to notice what the computer just did).

Saving Your Games
You can choose Game→Save Game to save any game in progress, so you can resume 
it later. 

To archive the moves making up an entire game instead, use the Game Log command, 
which displays the history of your game, move by move. A typical move would be 
recorded as “Nb8 – c6,” meaning the knight on the b8 square moved to the c6 square.  

Death to the Clock?
Hey! Where’s the Clock? I used to love that little Mac OS 
X app. 

Mac OS X no longer comes with a program called Clock in 
your Applications folder.

However, if it’s a clock you want, it’s a clock you shall have; 
Tiger has two of them for you—not counting the one in the 
menu bar.

Clock 1 is one of the Dashboard widgets (page 196). 

To find Clock 2, open System Preferences, click Date & Time, 
click the Clock tab, turn on “Show the date and time,” choose 
“View in: Window,” and “View as: Analog.” There’s your old 
friend, floating in its own little window like always. 

The advantage of Clock 2 is that you can keep it open along 
with your other programs, rather than disappearing as soon 
as you close Dashboard.

nostalgia corner

Chess
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Equipped with a Chess list document, you could recreate an entire game, move by 
move. 

Tip: If you open this window before you begin a new game, you can see the game log fill in the moves as 
they happen.

Dictionary
For word nerds everywhere, the Dictionary (and Thesaurus) is one of Tiger’s most 
welcome enhancements. For the first time, the Mac system software comes with a 
handy way to look up word definitions, pronunciations, and synonyms. To be pre-
cise, Mac OS X comes with an electronic version of the entire New Oxford American 
Dictionary and Oxford American Writers Thesaurus.

Mac OS X also comes with about a million ways to look up a word:

	 •	Double-click the Dictionary icon. You get the window shown at top in Figure  
10-3. As you type into the Spotlight-y search box, you home in on matching words; 
double-click a word, or highlight it and press Enter, to view a full, typographically 
elegant definition, complete with sample sentence and pronunciation guide.

Figure 10-3:
When you open the Diction-
ary, it generally assumes 
that you want a word’s 
definition. If you prefer to 
see the Thesaurus at startup 
time instead (to look up a 
word’s synonyms), choose 
Dictionary→Preferences—
and drag Oxford American 
Writers Thesaurus upward 
so that it precedes New 
Oxford American Dictionary. 
That’s all there is to it!

Chess
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Tip: And if you don’t recognize a word in the definition, double-click that word to look up its definition. You 
can then double-click again in that definition—and on, and on, and on. 

(You can then use the History menu, the Back and Forward buttons on the toolbar, or the -[ and -] 
keystrokes to go back and forward in your chain of lookups.)

It’s worth exploring the Dictionary→Preferences dialog box, by the way. There, 
you can choose U.S. or British pronunciations, adjust the font size, and indicate 
whether you prefer synonyms or definitions. 

	 •	Press F12. Yes, the Dictionary is one of the widgets in Dashboard (page 190).

	 •	Control-click a highlighted word in a Cocoa program. From the shortcut menu, 
choose Look Up in Dictionary. The Dictionary program opens to that word. (If 
opening the entire Dictionary application seems a bit overkill, visit its Preferences 
dialog box and choose “Open Dictionary panel.” Now you get a handy panel that 
pops right out of the highlighted word instead.)

	 •	Point to a word in any Cocoa program and press Control--D. That keystroke 
makes the definition panel sprout right from the word you were pointing to. (The 
advantage here, of course, is that you don’t have to highlight the word first.)

Tip: Here’s a trick for the informationally thirsty Mac fan (or speed reader). Once you’ve invoked the Control-
-D keystroke, keep the Control and  keys pressed. Now drag the cursor across the text. As you push the 
mouse around, the definition pops up for every word you touch.

Got a big screen or poor eyesight? Then bump up the type size. Dictionary’s toolbar has bigger/smaller 
buttons, and there’s a Font Size pop-up menu in the Preferences window.

DVD Player
DVD Player, your Mac’s built-in movie projector, is described in Chapter 11.

Font Book
For details on this font-management program, see Chapter 14.

Front Row
If your Mac came with a thin white remote control, see page 572.

GarageBand
For a starter course on Apple’s homemade-music machine, download the free iLife 
Mini Manual that’s available at www.missingmanuals.com.

Dictionary
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iCal
In many ways, iCal is not so different from those “Hunks of the Midwest Police Sta-
tions” paper calendars people leave hanging on the walls for months past their natural 
life span. But iCal offers several advantages over paper calendars. For example:

	 •	It can automate the process of entering repeating events, such as weekly staff meet-
ings or gym workout dates.

	 •	iCal can give you a gentle nudge (with a sound, a dialog box, or even an email) 
when an important appointment is approaching.

	 •	iCal can share information with your Address Book program, with Mail, with your 
iPod, with other Macs, with “published” calendars on the Internet, or with a Palm 
organizer. Some of these features require one of those .Mac accounts described 
in Chapter 19, and some require iSync (Chapter 19). But iCal also works fine on 
a single Mac, even without an Internet connection.

	 •	iCal can subscribe to other people’s calendars. For example, you can subscribe to 
your spouse’s calendar, thereby finding out when you’ve been committed to after-
dinner drinks on the night of the big game on TV.

Working with Views
When you open iCal, you see something like Figure 10-4. By clicking one of the View 
buttons on the bottom edge of the calendar, you can switch among these views:

	 •	Day shows the appointments for a single day in the main calendar area, broken 
down by time slot.

If you choose iCal→Preferences, you can specify what hours constitute a workday. 
This is ideal both for those annoying power-life people who get up at 5 a.m. for 
two hours of calisthenics, as well as for the more reasonable people who sleep until 
11 a.m. before rolling out of bed. 

Tip: iCal provides a quick way to get to the current day’s date—choose View→Go to Today, or press -T. 

	 •	Week fills the main display area with seven columns, reflecting the current week. 
(You can establish a five-day work week instead in iCal→Preferences.)

	 •	Month shows the entire month that contains the current date. Double-click a date 
number to jump to the day view for that date.

Tip: To save space, iCal generally doesn’t show you the times of your appointments in Month view. If you’d like 
to see them anyway, choose iCal→Preferences, click General, and turn on “Show time in month view.” 

	 •	List view is available as a split-screen option that you can summon while using any 
of the three main views. You open the list view by clicking the little list-view icon, 
third from right at the bottom of the iCal window. It offers you a tidy chronological 
list of everything you’ve got going on, from today forward.

iCal
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Tip: If your mouse has a scroll wheel, you can use it to great advantage in iCal. For example, when entering 
a date, turning the wheel lets you jump forward or backward in time. It also lets you change the priority level 
of a To Do item you’re entering, or even the time zone as you’re setting it. 

Making an Appointment
The basic iCal calendar is easy to figure out. After all, with the exception of one un-
fortunate Gregorian incident, we’ve been using calendars successfully for centuries. 

Even so, there are two ways to record a new appointment: a simple way and a more 
flexible, elaborate way.

The easy way
You can quickly record an appointment using any of several techniques, listed here 
in order of decreasing efficiency:

Figure 10-4:
Left: Week view. The min-
iature navigation calendar 
provides an overview of ad-
jacent months. You can jump 
to a different week or day by 
clicking the triangle buttons, 
and then clicking within the 
numbers. If the event is re-
curring, its upper “grip strip” 
shows two stacked squares. 

Right: Month view. You can 
hide the To Do list either by 
using the Window→Hide To 
Dos command or by clicking 
the thumbtack button identi-
fied here. 

Calendars
(categories)

Navigation
calendar

Hide/show the
navigation calendar

Hide/show Search results

Hide/show To Do list

Hide/show Info drawer

Week view Month view

iCal
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	 •	Double-click the appointed time on the calendar, in any view. A colored box ap-
pears; this is where you type the name for your new appointment. 

	 •	When viewing a day or week view, drag vertically through the time slots that rep-
resent the appointment’s duration, and then type inside the newly created colored 
box.

	 •	Using the month view, double-click in a blank area of the appropriate date’s square, 
and then type in the newly created colored bar. 

	 •	Choose File→New Event (or press -N). A new appointment appears on the cur-
rently selected day, regardless of the current view. 

	 •	In any view, Control-click a date and choose New Event from the shortcut 
menu.

Unless you use the drag-over-hours method, a new event believes itself to be one hour 
long, but you can adjust its duration by dragging the bottom edge vertically. Drag the 
dark top bar up or down to adjust the start time. 

In many cases, that’s all there is to it. You have just specified the day, time, and title 
of the appointment. Now you can get on with your life.

The long way
The information drawer shown in Figure 10-5 contains all the details for a certain 
appointment. (If it’s not already open, you can open a selected event’s drawer using 
any of the techniques described in Figure 10-5.) Using this drawer, you can create far 
more specific appointments, decked out with far more bells and whistles. 

For each appointment, you can Tab your way to the following information areas:

	 •	Subject. That’s the large, bold type at the top—the name of your appointment. 
For example, you might type Fly to Phoenix.

	 •	Location. This field makes a lot of sense; if you think about it, almost everyone 
needs to record where a meeting is to take place. You might type a reminder for 
yourself like My place, a specific address like 212 East 23, or some other helpful 
information like a contact phone number or flight number.

	 •	all-day. An “all-day” event, of course, refers to something that has no specific time 
of day associated with it: a holiday, a birthday, a book deadline. When you turn on 
this box, you see the name of the appointment jump to the top of the iCal screen, 
in the area reserved for this kind of thing (see Figure 10-4).

	 •	from, to. You can adjust the times shown here by typing, clicking buttons, or both. 
Press Tab to jump from one setting to another, and from there to the hours and 
minutes of the starting time.

For example, start by clicking the hour, then increase or decrease this number 
either by pressing your up and down arrow keys or by typing a number. Press Tab 
to highlight the minutes and repeat the arrow buttons-or-keys business. Finally, 

iCal
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press Tab to highlight the AM/PM indicator, and type either A or P—or press the 
up or down arrow key—to change it, if necessary. 

Tip: If you specify a different ending date, a banner appears across the top of the calendar.

	 •	repeat. The pop-up menu here contains common options for recurring events: 
every day, every week, and so on. It starts out saying None. 

Once you’ve made a selection, you get an end pop-up menu that lets you specify 
when this event should stop repeating. If you choose “Never,” you’re stuck seeing 
this event repeating on your calendar until the end of time (a good choice for 
recording, say, your anniversary, especially if your spouse might be consulting the 
same calendar). You can also turn on “after” (a certain number of times), which is 
a useful option for car and mortgage payments. And if you choose “on date,” you 
can specify the date that the repetitions come to an end; use this option to indicate 
the last day of school, for example. 

	 •	attendees. If the appointment is a meeting or some other gathering, you can type 
the participants’ names here. If a name is already in your Address Book program, 
iCal proposes auto-completing the name for you. (Alternatively, you can use the 

Figure 10-5:
You can open this Info drawer by 
double-clicking an appointment’s 
colored title strip (Day or Week view). 
Alternatively, if an appointment is 
already highlighted, you can click the  

 button, choose View→Show Info, 
or press -I. Incidentally, you can 
hide the drawer in the same ways.

iCal
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“attendees” label as a pop-up menu; choose Open Address Book, find the person 
you want, and drag the name directly into the attendees spot.)

If you separate several names by commas, iCal automatically turns each into a 
shaded oval pop-up button. You can click it for a pop-up menu of commands like 
Remove Attendee and Send Email. (That last option appears only if the person 
in your Address Book has an email address, or if you typed a name with an email 
address in brackets, like this: Chris Smith <chris@yahoo.com>.) 

Once you’ve specified some attendees, a Send button appears at the bottom of the 
Info drawer. If you click it, iCal fires up Mail and prepares ready-to-send messages, 
each with an iCal.ics attachment: a standard calendar-program invitation file.

Your guest will get an email message that says, “Chris Smith has invited you to the 
event: Company Hoedown, scheduled for Wednesday, February 02, 2005 at 3:00 
PM. To accept or decline this invitation, click the link below.”

Unfortunately, there generally is no link below unless your guests happen to use 
Mac OS X and Mail. It’s a great idea for a feature, but extremely limited in scope 
at the moment.

If your lucky recipient does use Mail, clicking the iCal.ics attachment opens up 
a dialog box that offers Accept and Decline. When your guest clicks one of these 
buttons, an RSVP message goes back to you. Once Mail has downloaded the 
response, you’ve opened its attachment, and you’ve clicked OK, iCal updates the 
invitee’s status in the Event Info window. You now see the word Pending, Accepted, 
or Declined next to each name. (Your guests, meanwhile, will be delighted to find 
that the appointment has automatically appeared on their calendars.)

Note: Attendees without email addresses disappear from the list the next time you open the event.

	 •	status. The little icon next to each attendee’s name changes as they accept or decline 
invitations. 

	 •	calendar. A calendar, in iCal’s confusing terminology, is a subset—a category—into 
which you can place various appointments. You can create one for yourself, another 
for family-only events, another for book-club appointments, and so on. Later, you’ll 
be able to hide and show these categories at will, adding or removing them from 
the calendar with a single click. Details begin on page 322.

Tip: Use this same pop-up menu to change an appointment’s category. If you filed something in Company 
Memos that should have been in Sweet Nothings for Honey-Poo, open the event’s information drawer and 
reassign it. Quick. 

	 •	alarm. This pop-up menu tells iCal how to notify you when a certain appointment 
is about to begin. iCal can send any of four kinds of flags to get your attention. It 
can display a message on the screen (with a sound, if you like), send you an email, 
run a script of the sort described in Chapter 8, or open a file on your hard drive. 
(You could use this unusual option to ensure that you don’t forget a work dead-

iCal
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line by flinging the relevant document open in front of your face at the eleventh 
hour.)

Once you’ve specified an alarm mechanism, a new pop-up menu appears to let 
you specify how much advance notice you want for this particular appointment. 
If it’s a TV show you like to watch, you might set up a reminder only five minutes 
before airtime. If it’s a birthday, you might set up a two-day warning to give yourself 
enough time to buy a present, and so on. 

	 •	url. What Apple really means here, of course, is URL—a Uniform Resource Loca-
tor, better known as a Web address like www.apple.com. If there’s a URL relevant 
to this appointment, by all means type it here. Type more than one, if it will help 
you; just be sure to separate each with a comma.

	 •	Notes. Here’s your chance to customize your calendar event. You can type, paste, 
or drag any text that you like in the notes area—driving directions, contact phone 
numbers, a call history, or whatever.

Your newly scheduled event now shows up on the calendar, complete with the color 
coding that corresponds to the calendar category you’ve assigned. 

What to Do with an Appointment
Once you’ve entrusted your agenda to iCal, you can start putting it to work. iCal is 
only too pleased to remind you (via pop-up messages) of your events, reschedule 
them, print them out, and so on. Here are a few of the possibilities.

Editing events
To edit a calendar event’s name, double-click it.

To edit any of the appointment’s other characteristics, you have to open its Info drawer, 
as described in Figure 10-5. 

Tip: If you simply want to change an appointment’s “calendar” category, you can bypass the Info drawer. 
Instead, just Control-click the appointment’s name (or anywhere on its block), and choose the category you 
want from the resulting shortcut menu. 

You don’t have to bother with this if all you want to do is reschedule an event, however, 
as described next.

Rescheduling events
If an event in your life gets rescheduled, you can drag an appointment block verti-
cally in its column to make it later or earlier the same day, or horizontally to another 
date in day or week view. (If you reschedule a recurring event, iCal asks if you want 
to change only this occurrence, or this and all future ones.)

If something is postponed for, say, a month or two, you’re in trouble, since you can’t 
drag an appointment beyond its month window. You have no choice but to open the 
Info drawer and edit the starting and ending dates or times—or just cut and paste 
the event to a different date.

iCal
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Lengthening or shortening events
If a scheduled meeting becomes shorter or your lunch hour becomes a lunch hour-
and-a-half (in your dreams), changing the length of the representative calendar event 
is as easy as dragging the top or bottom border of its block in any column view (see 
Figure 10-6). 

Tip: In week view, if you’ve grabbed the top or bottom edge of an appointment’s block so that the cursor 
changes, you can drag horizontally to make an appointment cross the midnight line and extend into a 
second day.

Printing events
To commit your calendar to paper, choose File→Print, or press -P. The resulting 
Print dialog box has been dramatically reworked in Tiger. Now you can include only 
a certain range of dates, only events on certain calendars, with or without to-do lists 
or mini-month calendars, and so on.

Deleting events
To delete an appointment, just select it and then press the Delete key. If you delete a 
recurring event (like a weekly meeting), iCal asks whether you want to delete only that 
particular instance of the event or the whole series from that point forward.

Tip: If you’re a laptop-toting traveler, iCal can keep right up with your changing time zones. In iCal→Prefer-
ences, click the Advanced tab and turn on “Turn on time zone support.” From now on, the Info drawer shown 
in Figure 10-5 offers a new pop-up menu for each appointment. Its Other command lets you tell it where 
you’ll be on that day (you click to pinpoint your location on a tiny world map).

Then, as you travel, use the new pop-up menu of time zones in the upper-right corner of iCal’s window. 
You’ll see all of your appointments snap to the correct time slots for your current location, so that you’re 
always on time and up-to-date. 

Figure 10-6:
You can resize any iCal calendar event just by dragging its border. As your cursor 
touches the bottom edge of a calendar event, it turns into a double-headed arrow. You 
can now drag the event’s edge to make it take up more or less time on your calendar.

iCal
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Searching for Events
You should recognize the oval text box at the bottom of the iCal screen immediately: 
It’s almost identical to the Spotlight box. This search box is designed to let you hide 
all appointments except those matching what you type into it. Figure 10-7 has the 
details.

The “Calendar” Category Concept
Just as iTunes has playlists that let you organize songs into subsets, and iPhoto has 
albums that let you organize photos into subsets, iCal has calendars that let you organize 
appointments into subsets. They can be anything you like. One person might have 
calendars called Home, Work, and TV Reminders. Another might have Me, Spouse 
’n’ Me, and Whole Family. A small business could have categories called Deductible 
Travel, R&D, and R&R. 

To create a calendar, double-click any white space in the Calendar list (below the 
existing calendars), or click the + button at the lower-left corner of the iCal window. 
Type a name that defines the category in your mind.

Tip: Click a calendar name before you create an appointment. That way, the appointment will already belong 
to the correct calendar.

Figure 10-7:
As you type into the search 
box, iCal filters your calendar 
until only events with match-
ing text are visible. It screens 
out both the text list and the 
colored boxes on the calendar 
itself, so that you can produce, 
in seconds, a calendar that 
shows only events pertain-
ing to a particular client or 
project. (You can also open 
up this list view by clicking the 
rightmost button of the two 
identified here.)

Search bar Hide/Show
the results list
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To change the color-coding of your category, click the  button, or choose View→
Show Info (-I). The Calendar Info drawer appears, looking a lot like the Event Info 
drawer. Here, you can change the name, color, or description of this category. 

You assign an appointment to one of these categories using the pop-up menu on its 
Info drawer, or by Control-clicking an event and choosing a calendar name from the 
shortcut menu. After that, you can hide or show an entire category of appointments 
at once just by turning on or off the appropriate checkbox in the Calendars list.

Tip: The Tiger edition of iCal introduces the concept of calendar groups: calendar containers that consolidate 
the appointments from several other calendars. Super-calendars like this make it easier to manage, print, 
hide, show, print, and search subsets of your appointments.

To create a calendar group, choose File→New Calendar Group. Name the resulting item in the Calendar 
list; for the most part, it behaves like any other calendar. Drag other calendar names onto it to include them. 
Click the flippy triangle to hide or show the component calendars. 

“Publishing” Calendars to the Web
One of iCal’s best features is its ability to post your calendar on the Web, so that 
other people (or you, on a different computer) can subscribe to it, which adds your 
appointments to their calendars. If you have a .Mac account, then anyone with a Web 
browser can also view your calendar, right online.

For example, you might use this feature to post the meeting schedule for a club that 
you manage, or to share the agenda for a series of upcoming financial meetings that 
all of your co-workers will need to consult. 

Figure 10-8:
If you click “Pub-
lish calendar on 
.Mac,” iCal posts the 
calendar—the actual, 
viewable calendar—on 
the Web, as shown in 
Figure 10-9. If you click 
“Publish calendar on 
a private server,” you 
have the freedom to 
upload the calendar 
to your own personal 
Web site, if it’s Web-
DAV-compatible. In 
this case, your fans 
will be able to down-
load (and subscribe 
to) the calendar, but 
won’t be able to view 
it online.

iCal

MacOSX4e_Ch10_RB.indd   323 10/9/2006   1:54:07 PM



324	 mac os x: the missing manual

Publishing
Begin by clicking the calendar category you want in the left-side list. (To publish more 
than one calendar, create a calendar group.)

Then choose Calendar→Publish; the dialog box shown at top in Figure 10-8 appears. 
This is where you customize how your saved calendar is going to look and work. You 
can even turn on “Publish changes automatically,” so whenever you edit the calendar, 
iCal connects to the Internet and updates the calendar automatically.

When you click Publish, your Mac connects to the Web and then shows you the Web 
address (URL) of the finished page, complete with a Send Mail button that lets you 
fire the URL off to your colleagues (Figure 10-8, bottom).

Subscribing
If somebody else has published a calendar, you subscribe to it by choosing Calendar→
Subscribe. In the Subscribe to Calendar dialog box, type in the Internet address you 
received from the person who published the calendar. Alternatively, click the Subscribe 
button on any iCal Web page (Figure 10-9, lower left).

Either way, you can also specify how often you want your own copy to be updated 
(assuming you have a full-time Internet connection), and whether or not you want 
to be bothered with the publisher’s alarms and notes.

Figure 10-9:
Your calendar is now 
live on the Web. Your 
visitors can control 
the view, switch 
dates, double-click 
an appointment for 
details—it’s like iCal 
Live! This feature 
of iCal is a brilliant 
solution to the old, 
“My spouse and I each 
have a Palm, but we 
can’t see each other’s 
calendars” problem. In 
conjunction with iSync 
(described starting on 
page 659), each per-
son can now summon 
the other’s calendar to 
the screen on demand.
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When it’s all over, you see a new “calendar” category in your left-side list, representing 
the published appointments. 

Tip: Want to try it out right now? Visit www.icalshare.com, a worldwide clearinghouse for sets of iCal ap-
pointments. You can subscribe to calendars for shuttle launches, Mac trade shows, National Hockey League 
teams, NASCAR races, soccer matches, the Iron Chef and Survivor TV shows, holidays, and much more. You’ll 
never suffer from empty-calendar syndrome again.

To Do Lists
iCal’s Tasks feature lets you make a to-do list and shepherds you along by giving you 
gentle reminders, if you so desire (Figure 10-10).

To see the list, click the pushpin button at the lower-right corner of the iCal screen. Add 
a new task by double-clicking in the To Do Items list that appears. In this same Info 
panel, you can also specify the task’s priority, alarm, repeating pattern, and so on.

To change a task’s priority, use the “priority” pop-up menu. To sort the list (by priority, 
for example), use the pop-up menu at the top of the to-do list. To delete a task, click 
it and then press the Delete key. 

Tip: You have lots of control over what happens to a task listing after you check it off. In iCal→Preferences, 
for example, you can make tasks auto-hide or auto-delete themselves after, say, a week or a month. (And 
if you asked them to auto-hide themselves, you can make them reappear temporarily using the Show All 
Completed Items command in the pop-up menu at the top of the to-do list.)

Figure 10-10:
Using the To Do Info drawer (right), you 
can also give your note a priority, a calen-
dar (category), or a due date. Tasks that 
come due won’t show up on the calendar 
itself, but a little exclamation point triangle 
appears in the To Do Items list.
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iChat, iSync
For a briefing on the iSync utility, see Chapter 19. Details on the iChat instant- 
messaging program can be found in Chapter 21.

iDVD
You have iDVD only if you bought a new Mac containing a SuperDrive DVD burner, 
or you bought Apple’s iLife software suite. iDVD lets you turn your digital photos or 
camcorder movies into DVDs that work on almost any DVD player, complete with 
menus, slideshow controls, and other navigation features. iDVD handles the technol-
ogy; you control the style. 

Sure, you can export your finished iMovie project back to a good old VHS cassette. 
But preserving your work on a DVD gives you a boatload of benefits, including bet-
ter durability, dramatically better quality, no rewinding, duplication without quality 
loss, and cheaper shipping. (And besides, you can fit a lot more DVDs on a shelf than 
VHS tapes.) 

Note: DVD players sold since 2002 are generally a safe bet for playing back homemade DVDs, but check 
the master player compatibility list at www.videohelp.com if you’re in doubt. Some players are fussy about 
which DVD-R brand discs they play, too.

Here’s the basic routine for converting an iMovie movie into a Blockbuster-style 
DVD. (The following pages describe iDVD 5, although other versions of iDVD are 
similar enough.)

Phase 1: Insert Chapter Markers
DVD chapters let viewers skip to predefined starting points within a movie, either 
using a Scene menu or pressing the Next Chapter or Previous Chapter buttons on the 
remote control. Thanks to the partnership of iMovie and iDVD, you can add markers 
that replicate this feature to your own movies. 

	1.	In iMovie, click the iDVD button to open the iDVD palette.

You’ll find it among the other palette buttons, just to the right of the Effects but-
ton, as shown in Figure 10-11.

	2.	Move the Playhead to the position for your new chapter. Click Add Chapter. Type 
a chapter title into the Chapter Title box.

Whatever you type here winds up as the chapter name in the finished DVD 
menu. 

	3.	Repeat step 2 until you’ve created all the chapters for your movie. Save your 
project.

If you’ve added a chapter in error, select it and then click Remove Chapter.

iChat, iSync
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Phase 2: Hand Off to iDVD
Now you’re ready to hand off the movie to iDVD, where you design your menu and 
burn your DVD.

Save your project, and then click Create iDVD Project at the bottom of the chapter 
list. Your hard drive whirs, thunder rolls somewhere, and after a few minutes, you 
wind up in iDVD itself. You’ll know when you get there: Empty postcards scroll slowly 
from right to left, confirming your arrival in iDVD land. (That’s the Travel 1 theme, 
described in a moment.)

Tip: To turn off the Apple logo that appears in the lower-right corner of every iDVD Project, choose iDVD→
Preferences, click General, and turn off “Show Apple logo watermark.”

Phase 3: Design the Menu Screen
‑ and the font for your buttons are all part of a theme—a unified design scheme that 
governs how the menus look and behave.

A wide range of canned themes awaits your inspection. To see them, click Customize 
to open the Customize drawer, if it isn’t already open (Figure 10-12). Click the Themes 
button. Then, from the pop-up menu at the top of the drawer, choose All. 

Figure 10-11:
The iDVD palette lets you add, remove, and name chap-
ters—and then publish your iMovies to iDVD. New iMovie 
chapters are numbered sequentially, as they appear in your 
movie from beginning to end. Chapter references appear in 
your timeline as small yellow diamonds just above the video 
track. iMovie can add up to 99 chapters per movie with the 
iDVD palette.

iDVD
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Now scroll through the list of themes. You can click each one to see what it looks 
like in the main work area, or just rely on the thumbnail icons to get a sense of the 
theme’s flavor. 

Select a theme by clicking its thumbnail. The main menu screen takes on your chosen 
theme instantly. If your DVD menu system has other screens—a scene-selection screen 
that lists your chapter markers, for example—choose Advanced→Apply Theme to 
Project, so that every screen looks alike.

Phase 4: Edit Titles and Buttons
On the main menu screen now before you, you’ll find two buttons: 

	 •	Play. On the finished DVD, this button means, “Play the movie from the beginning.”

Figure 10-12:
The Customize button reveals iDVD’s Cus-
tomize drawer. When you click one of the 
buttons at the top, the pane changes to 
show its contents. For example, Themes 
lets you choose a design scheme. The Set-
tings pane lets you choose motion menu 
duration, background video and audio, 
title fonts, and the look and placement of 
buttons. 

The Media pane lets you survey your 
Mac’s lists of music (if it’s kept in iTunes), 
photos (from iPhoto), and movies (what’s 
in your Movies folder and any other 
folders you’ve added in the Preferences 
dialog box). Status lets you see how close 
you are to filling up your DVD.

iDVD
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	 •	Scene Selection. On the finished DVD, this button takes your audience to a second 
screen, which is filled with individual buttons for the chapters you created. (This 
second screen may have arrows that lead to third and fourth screens, because iDVD 
can fit only six buttons per screen.)

You can edit these text buttons just as you would Finder icon names: Click inside the 
text to open up an editing box, type your changes, and then press Enter or Return.

Editing button names works almost the same way, except that you single-click the 
button first, and then click the text itself to open the editing box.

Phase 5: Burning Your DVD
Once your menu screens look pretty good, you’re almost ready to burn the DVD. 
Before you use up a blank disc, however, you should test your creation to make sure 
that it works on the virtual DVD player known as the Macintosh.

	 •	Preview the DVD. iDVD’s Preview button lets you test your menu system to 
avoid unpleasant surprises. When you click it, iDVD enters Preview mode, which 
simulates how your DVD works on a regular DVD player. You even get a simu-
lated remote control to help you navigate. Click Stop (the filled square) or reclick 
Preview to return to iDVD’s Edit mode.

	 •	Check the length. iDVD prefers to burn 60-minute DVDs, because they have the 
best quality. The instant you try to add the 61st minute of footage to your project, 
though, iDVD invites you to switch to 90-minute mode—at lower quality—or to 
delete some video from the project to make it fit within 60 minutes again.

When you’ve finished editing your disc and testing it thoroughly, it’s time to proceed 
with your burn. 

Drop Zones
 

gem in the rough
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	1.	Check your Motion setting.

The Motion button at the bottom of the window determines whether or not your 
finished DVD will have animated menus, buttons, and backgrounds, and whether 
or not music will play. If the Motion button is green, you get all of the above. If 
you turn the Motion button off (gray), then motion and audio features won’t 
appear on the final disc.

	2.	Choose File→Save. Click the Burn button twice.

The first click on the gray, closed Burn button “opens” it, revealing a throbbing 
yellow-and-black button. The second click begins the burning process.

	3.	Insert a blank DVD-R disc when the Mac asks for it.

Be sure you’re using the correct kind of blank DVD for the speed of your DVD 
burner. For example, don’t attempt to burn 1x or 2x blanks at 4x speed.

You can use DVD-RW (rewritable) discs, too, although they don’t work in as many 
DVD players.

Tip: Depending on your Mac model, you may be able to use either blank DVD-R discs or blank DVD+R discs. 
(Yes, these are two different kinds—note the punctuation. They’re essentially identical after burning—but some 
Macs can’t burn DVD+R.) Your Mac may even be able to burn dual-layer DVDs (page 402).

To find out which kinds of discs your Mac can burn, open System Profiler (in your Applications→Utilities 
folder). Expand the Hardware triangle, and click the Disc Burning category. 

At the right side of the display, you can see what kind of drive your Mac has: “CD-Write: -R, -RW” (you can 
record CDs), for example. 

If it also says “DVD-Write: -R, -RW, +R, +RW,” then you can burn CDs and DVDs—you have a SuperDrive. 

After a while, or a bit more than a while, a freshly burned DVD automatically ejects 
from your SuperDrive. 

Image Capture
This unsung little program is something of an orphan. It was designed to download 
pictures from a USB digital camera and then process them automatically (turning 
them into a Web page, scaling them to emailable size, and so on). Of course, after 
Image Capture’s birth, iPhoto came along, generally blowing its predecessor out of 
the water. 

Even so, Apple includes Image Capture with Mac OS X for these reasons:

	 •	Image Capture makes it easy to download only some pictures from your camera 
(Figure 10-13). iPhoto, by contrast, always downloads the entire contents of your 
camera’s memory card. 

	 •	Image Capture can grab images from Mac OS X–compatible scanners, too, not 
just digital cameras.

iDVD
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	 •	Image Capture can download your sounds (like voice notes) from a digital still 
camera; iPhoto can’t.

	 •	Image Capture can turn a compatible digital camera into a Webcam, broadcast-
ing whatever it “sees” to anyone on your office network—or the whole Internet. 
Similarly, it can share a scanner with all the networked Macs in your office.

You can open Image Capture in either of two ways. You can simply double-click its 
icon in your Applications folder or you can set it up to open automatically whenever 
you connect a USB digital camera and turn it on. To set up that arrangement, open 
Image Capture manually. Choose Image Capture→Preferences, click the General tab, 
and choose Image Capture from the “When a camera is connected, open” pop-up 
menu.

Figure 10-13:
Top: You can set up Image 
Capture to open automati-
cally when you attach a 
USB camera to your Mac. 
One click (on Download 
All) transfers its pictures to 
your hard drive. 

Bottom: If you click 
Download Some, you get 
this “slide-sorter” window, 
where you can choose the 
individual pictures you 
want to download, to ro-
tate selected shots (using 
the buttons at the top), or 
delete shots from the cam-
era. In slide-sorter view, 
Shift-click the thumbnails 
of the individual pictures 
you want. In list view, 
Shift-click or -click as 
though they’re Finder list-
view files.

Image Capture
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Once Image Capture is open, it looks like Figure 10-13.

In Image Capture, you can use the following pop-up menus.

Download Folder
Use this pop-up menu to choose a destination folder for the pictures. Image Capture 
proposes putting photos, sounds, and movies from the camera into your Home folder’s 
Pictures, Music, and Movies folders, respectively. When the downloading process is 
complete, Mac OS X opens the corresponding folder automatically, saving you the 
trouble of finding it.

Automatic Task
Download, schmownload—Image Capture is just warming up. It comes equipped to 
process the downloaded photos in several useful ways. For example: 

	 •	None. Translation: “Just download the pictures, please.”

	 •	Build slide show. After the download is complete, your screen goes black, and a 
smooth full-screen slideshow begins, featuring the newly downloaded pictures 
gracefully cross-fading one to the next (without musical accompaniment, alas). 

	 •	Build web page. Creates an actual, and very attractive, Web page of your down-
loaded shots. Against a black background, you get thumbnail images of the pictures 
in a Web page document called index.html. (You’ll find it in your Home folder→
Pictures→webpage folder, which also contains the graphics files incorporated into 
this HTML document.) Image Capture automatically opens up this page in your 
Web browser, proud of its work.

Just click one of the small images to view it at full size, exactly as your Web site 
visitors will be able to do once this page is actually on the Web. (Getting it online 
is up to you, although Apple’s HomePage feature—part of the .Mac subscription 
program described on page 651—is one of the easiest methods.) 

iPhoto offers more Web page options and better-looking results, but Image Capture 
is handy when you just need something quick and dirty.

Image Capture Super-Prefs
Apple spared no expense on this baby. Lurking in the dialog 
box that appears when you click the Options button (shown 
in Figure 10-13) are some very powerful features. They’re 
well worth exploring.

The Download Options controls, for example, let you set 
Image Capture to grab pictures automatically when you plug 
in the camera, saving you a click on the Download button. 

Here’s where you specify, too, that you want to delete the 
photos from the camera after they’ve been downloaded to the 
Mac—another step-saving option that prepares your memory 
card for more pictures. 

The Information tab, meanwhile, tells you some highly 
specific technical details about the camera or scanner that’s 
currently hooked up.

gem in the rough
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	 •	Crop to 3 x 5, fit to 3 x 5…. Each option here creates a photo gallery as a PDF 
document (page 518), ready to print out and then, presumably, to cut apart with 
scissors or a paper cutter. Each offers neatly arranged photos in the dimensions 
you’ve selected. 

And what if a photo doesn’t precisely fit the proportions you’ve selected? The “crop 
to” options center each photo within the specified shape and then trim the outer 
borders if necessary. The “fit to” options shrink the photo as necessary to fit into 
the specified dimensions, sometimes leaving blank white margins.

Note: The “crop” commands never touch the actual downloaded photos. The downloaded image files 
themselves retain their full size and resolution.

	 •	Preview. This option opens the fresh pictures in Preview (page 361), so that you 
can get a better (and bigger) look at them.

	 •	Other. The beauty of the Image Capture system is that people can, in theory, write 
additional processing scripts. Once you’ve written or downloaded them, drop them 
into your System→Library→Image Capture→Automated Tasks folder. Then enjoy 
their presence in the newly enhanced Automatic Task pop-up menu.

Download Some, Download All
Clicking Download All, of course, begins the process of downloading the photos to 
the folder you’ve selected. A progress dialog box appears, showing you thumbnail 
images of each picture that flies down the wire.

Clicking Download Some, however, opens the picture browser shown at bottom in 
Figure 10-13. Now you can select the photos you want to download, rotate, or delete 
from the camera. (In icon view, you click and Shift-click to select a bunch of consecu-
tive photos, and -click to add individual photos to the selection. In icon view, you 
can only click and Shift-click to select individual photos.)

Downloading from Across the Network
You’re sitting in front of Macintosh #1, but the digital camera is connected to Macin-
tosh #2 downstairs, elsewhere on the network. What’s a Mac fan to do?

All right, that situation may not exactly be the scourge of modern computing. Still, 
downloading pictures from a camera attached to a different computer can occasionally 
be useful. In a graphics studio, for example, when a photographer comes back from 
the field, camera brimming with fresh shots, he can hook up the camera to his Mac so 
that his editor can peruse the pictures on hers, while he heads home for a shower. 

To share your camera on the network, hook it up, choose Image Capture→Preferences, 
click the Sharing tab, turn on “Share my devices,” and select the camera in question 
(Figure 10-14). (This trick works with scanners, too.)

Image Capture

MacOSX4e_Ch10_RB.indd   333 10/9/2006   1:54:09 PM



334	 mac os x: the missing manual

On the other Mac, open Image Capture and choose Devices→“Browse devices.” Open 
the flippy triangle, select the camera, click OK, and proceed to view and download 
the photos exactly as though the camera’s connected to your Mac.

Downloading from Across the Internet
You can also share your camera’s contents with the whole Internet, assuming your Mac 
has its own, publicly accessible IP address (page 644). Figure 10-14 has the details 
for the setup.

Figure 10-14:
Connect the camera 
and turn it on. 

Top: Choose Im-
age Capture→
Preferences, click the 
Sharing tab, turn on 
“Share my devices,” 
and then turn on 
“Enable Web Shar-
ing.” Click OK. 

Bottom: Now 
anyone else on the 
Internet can open 
Safari, type the IP 
address provided 
by the Preferences 
dialog box (see it, 
just underneath 
the “Enable Web 
Sharing” checkbox 
at top?) into their 
address bar, and 
peep at the contents 
of your Mac’s digital 
camera! (“Meet 
George Jetson…”) 

Image Capture
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Image Capture as Web Spycam
All digital cameras can share what’s currently on their memory cards via the Internet as 
previously described. If you have one of a few newer models, in fact, you can actually 
control the camera remotely. You can spy on whatever’s in the room where the camera 
is, taking snapshots on demand. (Can you say, “Babysittercam”?)

Note: Some of the Webcammable cameras are the Canon A60, A70, S400, S50/60/70, and G5; HP C618 
and 912; Kodak DC280, DC4800, DC5000; and Nikon D1, D1X, and D1H—and their successors.

To set this up, begin as shown in Figure 10-14. Then, if your camera is one of the 
compatible models, the Remote Monitor tab (shown dimmed in Figure 10-14) springs 
to life, along with the buttons labeled Delete, Take Picture, and so on. 

Clicking Take Picture captures a picture exactly as you would if you’d been next to 
the camera and pressed the shutter button. 

If you click the Remote Monitor tab, you see, at full size, whatever the camera is 
seeing; the image is updated once every minute. (The pictures are blasted to you via 
the Internet, but not captured onto the memory card.) Click the light-switch icon to 
change the shutter interval. 

Figure 10-15:
Assuming your scanner is 
compatible with Mac OS X 
(that is, if it’s TWAIN-compat-
ible), this preview window 
appears automatically when 
you turn on the scanner and 
open Image Capture. Open 
the drawer to specify the di-
mensions and resolution you 
want. Click Overview if you 
need to repeat the preview. 
Next, drag across the image 
to indicate which part you 
want to capture (otherwise, 
the Scan button is dimmed), 
and then click Scan when 
you’re ready to go. 

Click here to open the drawer Zoom in/Zoom out

Image Capture
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Scanning
Assuming you haven’t changed the “Open scanner window when Image Capture is 
launched” setting (in Image Capture→Preferences→Scanner), you should see the 
window shown in Figure 10-15 as soon as you turn on your scanner and fire up Im-
age Capture.

iMovie
If you have a digital camcorder and a few hours of free time—all right, a few weekends 
of it—iMovie helps you make astonishingly high-quality, fully edited movies. Digital 
video is great: You can transfer the footage back and forth between the Mac and the 
camcorder a hundred times, and never see any deterioration in quality. The latest 
version of iMovie can even edit high-definition footage (from HDV camcorders like 
Sony’s HDR-HC1).

Note: Although this writeup covers iMovie HD, other versions of iMovie work similarly.

Figure 10-16:
Here’s iMovie in a 
nutshell. Save your 
project onto the 
drive that has the 
most space (if you 
have more than 
one), because digi-
tal video files are 
enormous. They 
require 3.6 MB of 
hard drive space 
per second or 13 
gigabytes per one-
hour tape (and 
much, much more 
if you shot in high 
definition). Choose 
a screen resolu-
tion that’s 1024 
x 768 or higher 
(using the Displays 
panel of System 
Preferences). Poor 
iMovie can’t even 
run at a lower 
setting.

Monitor Clips pane

Project
Trash

Home, Play,
Full Screen

Clip Viewer
(Movie Track)

Clip Viewer/
Timeline Viewer

switch

Free
space

Camera/Edit
Mode switch

Scrubber bar Playhead Volume Pane buttons
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Phase 1: Set Up iMovie
The first time you run iMovie, it asks you whether you want to open an existing iMovie 
file (called a project) or start a new one. After that, each time you launch iMovie, it 
automatically opens up the movie you most recently worked on. 

If you click Create Project, you’re asked to select a name and location for the movie 
you’re about to make. (You can ignore the “Video format” pop-up menu; iMovie 
auto-detects what kind of camcorder you have once you begin importing footage.) 
Once you’ve saved your project, you finally arrive at the main iMovie window (Figure 
10-16). 

Phase 2: Import Camcorder Footage
After you’ve shot some footage, connect the camcorder to the Mac using a FireWire 
cable. If you have the proper cable, the six-pin connector fits your Mac, and the 
much smaller end (the four-pin connector) goes into the FireWire connector on 
your camcorder, which, depending on the brand, may be labeled FireWire, i.Link, 
DV In/Out, or IEEE 1394.

Put the camcorder into VTR mode, also known as VCR or Playback mode. If neces-
sary, click iMovie’s Camera button, identified in Figure 10-16.

The Monitor window says, “Camera Connected.” Now you can click the Play, Rewind, 
Fast Forward, and other buttons on the screen to control the camcorder. Scan your 
tape to find the sections that you want to include in your edited movie. 

Every time you click the Import button—or tap the Space bar—iMovie imports the 
footage you’re watching, saving it as a series of digital-video movie files on the Mac’s 
hard drive. For each scene, iMovie creates what looks like a slide in the Clips pane, 
as shown in Figure 10-16. That’s a clip—a single piece of footage that makes up one 
of the building blocks of an iMovie movie. Its icon is a picture of the first frame. On 
the clip’s upper-left corner, you can see the length of the clip expressed as “seconds:
frames.” (There are roughly 30 frames per second in North American video or HDTV; 
25 in the European format.)

Automatic Scene Detection
If you let the tape continue to roll, you’ll notice that each 
time a new scene begins, a new clip icon appears in the 
Clips pane. 

iMovie is studying the date and time stamp that DV camcord-
ers record into every frame. When iMovie detects a break 
in time, it assumes that you stopped recording,—if only for 

a moment—and therefore that the next piece of footage 
should be considered a new shot. It turns each new shot 
into a new clip. 

If you’d prefer manual control over when each clip begins and 
ends, choose iMovie→Preferences, click Import, and turn off 
“Start a new clip at each scene break.”

gem in the rough

iMovie
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How iMovie organizes its files
Every time you save a project file, iMovie creates an icon that bears your project’s 
name. But it’s not really a document icon. It’s a package icon, which, to Mac OS X 
aficionados, is code for “a thinly disguised folder.” It opens up like a document when 
double-clicked—but if you Control-click it and, from the shortcut menu, choose Show 
Package Contents, you can open it instead like a folder and survey the pieces that make 
up an iMovie movie. (Don’t move, rename, or delete the components, however.)

If you open, edit, and even save a project made by a previous iMovie version, though, 
it remains in the older project format: a regular folder (called, for example, Disney 
Trip) containing an iMovie document (with the same name) and a Media folder that 
contains all of your video clips. You can turn such a project into the newer package 
format for convenience, if you like, by choosing File→Save As.

Phase 3: Arrange the Clips
As you’re building your movie, you can store your clips in either of two places: the 
Clips pane or the storyboard strip—the Movie Track, for want of an official name—at 
the bottom of the window (Figure 10-16). You put clips on the Clips pane before 
deciding what to do with them and drag them down to the Movie Track once you’ve 
decided where they fit into your movie.

The Movie Track can appear in either of two ways, depending on which button you 
click (the film strip or the clock):

	 •	Clip Viewer. In this view (the filmstrip button), each clip appears as an icon, like 
a slide on a slide viewer. Each is sized identically, regardless of length. 

	 •	Timeline Viewer. Here (the clock button), each clip is represented by a horizontal 
bar whose length is proportional to the amount of time it occupies in the whole 
movie. Parallel bars below the clips indicate the soundtracks playing simultane-
ously.

You can do several things to a clip, whether it’s in the Clips pane or the Movie Track. 
For example:

	 •	Select a clip. Click a clip’s icon to view its first frame and, below on the Movie 
Track, its duration relative to the whole movie.

To highlight several consecutive clips in the Movie Track, click one clip, and then 
Shift-click the last one, or -click to select several that aren’t adjacent. In the Clips 
pane, you can also drag diagonally across a batch of them.

	 •	Play a clip. To play a highlighted clip, press the Space bar. You can also drag the 
playhead (see Figure 10-16) to view earlier or later parts of the clip. By pressing the 
right and left arrow keys when playback is stopped, you can view your clip one frame 
at a time, as though you’re watching the world’s least interesting slideshow.

Tip: Adding the Shift key to your arrow-key presses is often more useful, since it lets you jump 10 frames at 
a time. The Page Up/Page Down keys jump to the beginning and end of the clip.

iMovie
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	 •	Reorganize the clips. You can drag clips from cubbyhole to cubbyhole on the 
Clips pane. In fact, you can drag a clip (or even a mass of highlighted clips) onto 
an occupied cubbyhole. iMovie automatically creates enough new cubbyholes to 
hold them all, and shuffles existing clips out of the way if necessary. 

	 •	Trash a clip. You can get rid of a clip either by selecting it and then pressing the 
Delete key or by dragging it directly onto the project Trash icon (once again, shown 
in Figure 10-16). 

The iMovie Trash has a lot in common with the Finder’s Trash or the Windows 
Recycle Bin. Like them, it’s a safety net. It’s a holding tank for clips, photos, and 
sounds that you intend to throw out. They’re not really gone, though, until you 
use the File→Empty Trash command (Shift--Delete). 

You can open the Trash “folder,” look over and even play back the clips inside, 
and rescue or delete individual audio and video clips without emptying the whole 
Trash. 

To open the Trash window, click the Trash icon or choose File→Show Trash. 

The fact that you can open the Trash window isn’t the only startling change in 
iMovie HD. You should also be aware that emptying the Trash saves your file—and 
when you save your file, you lose the ability to Undo your previous steps. Emptying the 
Trash also disables the Revert to Saved command and vaporizes whatever’s on your 
Clipboard. (You can still use the Revert Clip to Original command, however.)

Why Emptying the Trash Doesn’t Restore Disk Space
When I emptied the Trash, the little “free disk space remain-
ing” counter didn’t change at all! I had 532 megs available 
before I emptied the Trash, and the same amount after!

In iMovie HD, you can use the Revert Clip to Original com-
mand any time, even after emptying the Trash, even months 
or years later. You can also add back a missing chunk from 
the middle of a clip that you’d previously lobotomized—again, 
even after emptying the Trash. You can chop, truncate, split, 
and shorten clips to your heart’s content, and at any time, 
restore what you’d eliminated. (In previous iMovie versions, 
emptying the Trash meant that portions you cut from clips 
were gone forever.)

Unfortunately, these features work because iMovie quietly 
preserves the entire copy of every clip you import. If you 
split a clip in half, drag the second part to the Trash, and then 
empty the Trash, you don’t get back one single byte of disk 

space. iMovie is hanging onto the entire original clip, just in 
case you change your mind someday.

The only time emptying the Trash actually frees up disk space, 
in fact, is if you’ve put an entire clip into it. (Even then, you may 
have to empty the Finder Trash to complete the transaction.) 
If even one frame of it appears in the Timeline, iMovie still 
preserves the entire original clip on your hard drive.

So what if you imported a 40-minute tape all in one clip and 
you intend to work with only the first five minutes’ worth? 
Will that iMovie project occupy 40 minutes’ worth of space 
on your hard drive forever?

Yes, unless you export the entire movie project as a full- 
quality DV clip and then reimport it.

frequently asked question

iMovie
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	 •	Trim a clip (Clips pane, Clips viewer). Unless you have some godlike ability to 
control precisely when the subjects of your life—your pets, your children, your 
geysers—are at their most video-worthy, you probably don’t need to preserve every 
frame of your captured footage for future generations. 

To target footage for deletion, click a clip, position your cursor within the Scrubber 
bar, and drag horizontally until the triangle handles surround the footage you want 
to keep (Figure 10-16). If you choose Cut or Clear from the Edit menu, iMovie 
promptly trims away whatever was highlighted between the triangles. 

If you choose Edit→Crop instead, iMovie deletes whatever was outside the high-
lighted portion.

Tip: Here’s a quick trick for highlighting only the first portion of a selected clip: Shift-click within the Scrubber 
bar at the point where you’d like the selection to end. Instantly, iMovie highlights everything from the left 
end of the clip to the position of your click. 

	 •	Trim a clip (Timeline viewer). Drag the edges of a clip’s colored bar inward to 
shorten it from either end. (Drag outward again if you change your mind.)

Phase 4: Assemble the Movie
Drag the edited clips out of the Clips pane and into the correct order on the Movie 
Track, exactly as though you’re building a storyboard or timeline. (To magnify the 
Timeline Viewer for a better look, drag the slider at the lower-left corner of the win-
dow. It adjusts the relative sizes of the bars that represent your clips.)

Play as you go
As you work, you’ll want to play back your movie to check its flow. You may discover 
that, in the context of the whole movie, some clips are too long, too short, in the 
wrong order, and so on.

	 •	To play back your entire Movie Track, press the Home key, which means Rewind. 
When you tap the Space bar, iMovie plays your movie from the beginning, one 
clip after another, seamlessly.

	 •	To play back only a certain chunk of the movie, first select the clips you want, then 
click the Play button or press the Space bar. 

	 •	The Play Full Screen button (the darkened triangle to the right of the round 
Play button) makes the playback—even if it’s already under way—fill the entire 
computer screen. To interrupt the movie showing, click the mouse or press any 
key on the keyboard (except the Space bar, which pauses or resumes playing the 
movie). 

Note: The quality of the full-screen playback may look a tad grainy. Don’t panic. When you transfer your 
finished movie back to your camcorder for TV playback, you get crystal-clear playback.

iMovie

MacOSX4e_Ch10_RB.indd   340 10/9/2006   1:54:11 PM



	 chapter 10: the free programs	 341

Phase 5: Transitions, Effects, Titles, Audio, and Photos
Professional film and video editors have at their disposal a wide range of transitions—
special effects that smooth the juncture between one clip and the next. For example, 
apart from a simple cut, the world’s most popular transition is the crossfade or dissolve, 
in which the end of one clip gradually fades away as the next one fades in. 

iMovie offers a long list of transitions, of which crossfades are only the beginning. To 
see them, click the Trans button (Figure 10-17). 

When you drag a transition into your Movie Track, the Mac now creates the 
crossfade—renders it—by superimposing the end of one clip with the beginning of 
the next. When the red progress bar is finished, click in your timeline just before the 
transition, press the Space bar to play, and marvel in your new ability to make home 
movies look pro.

Tip: You can continue working on other parts of your movie, or even switch into another Mac OS X program, 
while the rendering is going on.

To delete a transition, click its icon in the timeline and then press Delete. To edit it 
(by changing its length, for example), click its icon, return to the Transitions palette, 
make the adjustment, and then click Update. 

Figure 10-17:
Click the name of the transition you want. 
Use the slider above the Transitions palette 
to specify how many seconds long you 
want the transition to last. (One second 
is fairly standard.) Once you’ve done so, 
drag the name of the transition into the 
Movie Track, between the two clips. They 
scoot apart to make room for the new 
transition icon that appears.

Preview screen

Duration slider

Transitions list

Transitions button

Direction control

iMovie
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Effects
The Effects button summons a panel full of additional visual effects. Most are de-
signed to create actual special effects that simulate fog, rain, earthquakes, lightning, 
flashbulbs, and bad LSD. (Most are weird and distracting. Use sparingly.)

To apply an effect, first specify which region of footage you want to be affected. iMovie 
can apply effects only to entire clips. It may have to split your clip at the endpoints 
of the selection and then apply the effect to the central clip.

Then, on the Effects pane, specify when the effect should begin and end (use the Effect 
In and Effect Out sliders), its intensity, and so on. Finally, click Apply. As usual, the ren-
dering telegraphs its progress with a miniature red progress bar on the selected clip.

If you click a clip and then press the Delete key, you’re saying: “Throw away the ef-
fect. Bring back my original, unmodified clip.” To adjust the start time, stop time, or 
other parameters of a special effect, you must first delete the effect altogether, and 
then reapply it using new settings.

Tip: It’s perfectly possible to combine effects by applying first one, and then another. For example, after using 
the Black & White effect, you may want to use the Brightness & Contrast control to adjust its gray tones. You 
can even apply a single effect repeatedly, intensifying its effect. For instance, you could apply Rain twice at 
different intensities to add depth to your simulated deluge.

If you click such a clip, you can retrace your steps, removing one effect after another with each press of the 
Delete key.

Titles and credits
To add rolling credits, opening titles, subtitles, or MTV-style music video credits to 
your masterpiece, start by clicking the Titles button. A list of title animation styles 
pops up. In the tiny text box underneath the list, type the text you want to appear. 
(Some of the effects, like Rolling Credits, offer pairs of text blobs; see Figure 10-18.)

If you want to insert this title before or after a clip (as credits, say), so that the text ap-
pears on a black background, turn on the Over Black checkbox. If you’d rather have 
the text appear on top of the video, leave that box unchecked. (Superimposing a title 
usually breaks the clip in half. The part with the title superimposed is now one clip, 
and the unaffected part is separate.)

Click the Preview button to see what the title will look like. Adjust the timing slider 
above the list, and then drag the name of the title type (such as Centered Title) into 
the Movie Track.

To eliminate a title, click its icon in the timeline and then press Delete. To edit, click 
its icon, make changes in the Titles palette, and then click Update. 

Audio
The top horizontal band of the Timeline Viewer displays the video component of 
your movie. For the most part, you won’t do much with this strip when you’re editing 
audio; its primary purpose is to show where you are in the movie.

iMovie
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The two skinnier horizontal strips underneath it are your playground for audio clips 
(Figure 10-19); they play in tandem. Each audio track can hold sound from any of 
these sources:

	 •	iTunes tracks. When you click the Audio button, iMovie displays your complete 
iTunes music collection, including playlists, making it easy for you to choose 
background music for your flick. Double-click a song to listen to it; drag its name 
onto one of the audio tracks to use it in your movie. 

	 •	Narration. This can be anything that you’ve recorded with your microphone. Drag 
the Playhead to a spot just before you want the narration to begin, click the round 
Record Voice button on the Audio pane, and begin to speak. You can watch the 
video play as you narrate. (If the level meter isn’t dancing as you speak, check the 
selected sound source in the Sound panel of System Preferences.)

	 •	Sound effects. From the pop-up menu at the top of the Audio pane, choose iMovie 
Sound Effects. Now you can add any of iMovie’s sound effects (laughing, crickets, 
and so on) to your movie just by dragging them into an audio track.

Figure 10-18:
After you’ve typed in a couple of 
pairs of text lines, click the + button 
to tack on yet another pair to your 
credits. The program automati-
cally adds the dots and lines up the 
names (just like real live credits!), or 
places the subtitle beneath the main 
title, as shown here.

Preview screen

Duration sliders

Text color

Title
Subtitle

Titles button

Directional arrows

Effects list

Font menu
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	 •	MP3, WAV, AAC, and AIFF audio files. Import these popular music formats using 
the File→Import command. 

	 •	Music from a CD. You can insert a standard audio CD and transfer a song into 
iMovie to serve as the music for a scene. (Its contents appear in the Audio palette, 
and iTunes usually opens automatically to help you catalog the CD.) As usual, drag 
the name of a song to an audio track to install it there.

	 •	Your camcorder audio. You can turn the ordinarily invisible audio portion of a 
video clip into an independent sound clip, which you can manipulate just like any 
other kind of sound clip (great for creating voice-overs, echoes, audio flashbacks, 
and so on). To do that, highlight the audio clip and then choose Advanced→Extract 
Audio.

Tip: You can use the three checkboxes at the right end of these tracks to control which ones play back. When 
you want to isolate only one track for playback, turn off the other two checkboxes. 

Figure 10-19:
Top: In the Timeline Viewer, 
horizontal strips represent 
narration, CD tracks, music 
from iTunes, or sound effects. 
To identify a sound clip, 
either click it so that its name 
appears at the bottom of the 
window, or just point to it 
without clicking.

Middle: If the soundwave 
scribbles are a little distract-
ing, you can adjust their size 
by tapping the up and down 
arrow keys. See how the 
top audio clip has smaller 
waveforms now? (This doesn’t 
affect the volume level, only 
the onscreen graphics.)

Bottom: You can also turn 
off those visual soundwaves 
altogether by choosing View→ 
Show Audio Waveforms. 
Hiding waveforms reduces 
visual clutter and reveals each 
clip’s name right on the clip. 
Leaving them visible is a good 
way to align video with audio 
“hits.”

Selected audio clipSound tracks
Selected clip’s

name and length
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Fortunately, you can do more with your audio clips than just insert them into the 
Timeline Viewer. You can lengthen them or shorten them, make them fade in or out, 
shift them to play earlier or later in time, and even superimpose them. Best of all, you 
can make their volume rise and fall over the length of the clip.

	 •	Whole-clip volume adjustments. To make a selected clip louder or quieter, use the 
Clip pop-up menu at the bottom edge of the window. You can make it so quiet that 
it’s absolutely silent, or you can boost it to 50 percent louder than the original. 

	 •	Volume adjustments within a clip. You can also make the volume of a clip rise and 
fall along its length. For example, you can “pull back” the music when somebody 
is speaking, and then bring it back to full volume in between speeches. 

When you choose View→Show Clip Volume Levels (-Shift-L), a horizontal line 
appears on every audio and video clip, stretching from edge to edge. This line is 
a graph of the clip’s volume.

Click directly on the line and drag upward or downward to produce a temporary 
volume fluctuation (Figure 10-20).

Note: When Show Clip Volume Levels is turned on, you can’t drag clips’ edges to shorten or lengthen them 
in the Timeline Viewer.

Photos
You might want to import a graphics file into iMovie for any number of reasons—to 
use as a less distracting still image behind your titles and credits, for example, or 
to create a video photo album. If you keep your pictures in iPhoto, a useful feature 
awaits.

When you click the Photos button (Figure 10-21), you’re shown the contents of your 
entire iPhoto Library. Using the pop-up menu, you can even limit your view to the 
contents of one iPhoto album or another.

Once you’ve pinpointed the picture you want, use the controls at the top of the Photos 
palette to specify the amount of time the photo will remain on the screen. If you like, 
you can also turn the Ken Burns effect, where the “movie camera” pans and zooms 
smoothly across photos, in essence animating them and directing the viewer’s atten-

Figure 10-20:
Each “knot” in the line (the round handle) represents a 
new volume level that sticks until the end of the clip or 
the next volume level, whichever comes first. To remove 
a volume change, click the orange “knot” to select it, and 
then press the Delete key.

iMovie
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tion. (Ken Burns is the creator of PBS documentaries like The Civil War and Baseball, 
which use this effect in abundance.)

Finally, drag the photo out of the thumbnail palette and into the Movie Track. The 
other clips scoot out of the way to make room, and the photo becomes, in effect, a 
new silent video clip with the duration you specified. (If you turned on the Ken Burns 
effect, iMovie takes a few moments to render the animation. The familiar red progress 
bar inches across the face of the clip.)

Note: If you don’t routinely keep your photos in iPhoto, you can also import a graphics file, or even a 
QuickTime movie, from your hard drive by choosing File→Import. 

Phase 6: Meet Your Public
When the movie’s looking good on your Mac screen, you’re ready to distribute it to 
the adoring masses. iMovie offers three ways to do that:

	 •	Export it as a QuickTime movie. Choose File→Share. Click QuickTime at the top 
of the dialog box, and choose a quality setting from the pop-up menu: Email, 

Figure 10-21:
To set up a Ken Burns effect, click 
Start. Use the Zoom controls until 
the photo is as big as you want it at 
the beginning of its time onscreen. 
Drag inside the Preview screen to 
adjust the photo’s position. Then 
click End, and set up the picture’s 
final size and position. (Shift-drag to 
constrain your dragging to perfect 
vertical or perfect horizontal adjust-
ments.) In short, what you’ve done 
is set up the starting and ending 
conditions for the photo.

Photos pane

Ken Burns controls

Thumbnails

Album list
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CD-ROM, or Expert (that is, manual settings for compression, frame rate, and 
size).

	 •	Play it back to your camcorder. Put the camcorder into VTR or VCR mode, connect 
the FireWire cable to your Mac, choose File→Share, and click the Videocamera 
button.

From there, by connecting your camcorder to a VCR, you can copy the movie 
onto a regular VHS tape for submission to the Sundance film festival, Cannes, or 
your mother.

	 •	Email it. The movie you export with these settings is fairly blurry, and the size of 
the QuickTime screen is closer in size to a Wheat Thin than a Cineplex. 

Still, the resulting QuickTime file is relatively tiny. At about 1 MB for a minute-
long movie, it’s within the realm of possibility that you could email this thing 
to somebody without incurring their wrath. And iMovie makes it easy for you; 
after compressing the movie, it opens your email program (whichever one you’ve 
selected in the Share dialog box’s pop-up menu), creates a new outgoing message, 
and attaches the movie. Address and send. 

	 •	Post it on the Web. By far the easiest way to post your movies on the Internet is to 
use one of Apple’s $100-per-year .Mac accounts (Chapter 19). In iMovie, you can 
post your finished masterpiece on a .Mac Web page with little more than a couple 
of clicks. Choose File→Share; in the resulting dialog box, click HomePage. Type a 
name for your movie and then click Share.

iMovie springs into action, compressing your movie to Web proportions and 
uploading it to the .Mac Web site. (This is not a particularly quick process.)

When the uploading is complete, you’re asked for your .Mac name and password 
and offered about a dozen standard iMovie Web-page templates, such as Invite, 
Baby, and so on; click the “theater” style you prefer. Finally, on the “Edit your page” 
page, fill in the movie title, description underneath the movie, and so on. Your 
movie is now live on the Web!

	 •	Turn it into a DVD. If your Mac came equipped with a SuperDrive (a drive that 
reads and records both CDs and DVDs), you can create professional-quality DVD 
discs just like the ones that come out of Hollywood. See “iDVD,” earlier in this 
chapter, for complete instructions.

Internet Connect
Internet Connect is primarily designed for people who connect to the Internet via 
dial-up modem, but it’s also handy for managing AirPort and Bluetooth connections. 
Here’s what you can accomplish with Internet Connect:

	 •	Click Connect to dial out using your current modem settings.

	 •	Once you’re hooked up, check the status display to confirm whether or not your 
modem successfully connected to your ISP—or if you’ve been disconnected. 

iMovie
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	 •	You can also check your connection speed to find out if you’re really connected at  
56 K (ha!).

	 •	A timer shows how long you’ve been connected.

	 •	Internet Connect keeps a log of your connection activity (choose Window→Con-
nection Log). Reading this log is about as exciting as reading random entries from 
the White Pages. Nonetheless, if you’re having serious connection problems, it can 
be a useful troubleshooting tool.

	 •	The “Show modem status in menu bar” checkbox (on the Internal Modem panel) 
lets you use a menu bar icon to dial and observe your connections—without using 
Internet Connect at all.

Even then, you don’t really need Internet Connect to get online. If your dial-up set-
tings are configured correctly, your Mac automatically dials whenever you launch a 
program that requires one (such as Safari).

What else is Internet Connect good for?

	 •	Internet Connect is your gateway to Virtual Private Networking, a feature that lets 
you tunnel into corporate networks from the road (page 751). 

	 •	You can use it to initiate PPPoE (PPP over Ethernet, a connection required by 
certain DSL modems). 

	 •	If you use your Bluetooth-equipped Mac to dial the Net using a Bluetooth-equipped 
cellphone as a wireless modem in your pocket (man, is that cool!), you can once 
again use Internet Connect to start and stop the connection. See Chapter 13.

	 •	Internet Connect now incorporates the setup programs for AirPort wireless net-
works (Chapter 13).

iPhoto
Once you’re hooked on using a digital camera, your free, filmless photos pile up quickly. 
Before you know it, you have 6,000 pictures of your kid playing soccer. Just organizing 
and keeping track of all these photos is enough to drive you insane.

Apple’s answer to all these problems is iPhoto, a simple and uncluttered program 
designed to organize, edit, and distribute digital photos without nightmarish hassles. 
Here’s the executive summary of iPhoto 5.

Importing Pictures
Plugging a USB camera into your Mac is the easiest way to transfer pictures into 
iPhoto. The whole process practically happens by itself.

	1.	With your camera turned off, connect it to your Mac using the USB cable that 
came with it. 

Internet Connect
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iPhoto opens automatically as soon as you switch on the camera (unless you’ve 
changed the factory settings in Image Capture).

Note: If this is the first time you’ve ever run iPhoto, it asks if you always want it to run when you plug in 
the camera. If you value your time, say yes.

	2.	Turn on the camera.

iPhoto detects that there are new photos available for download. The entire screen 
changes to show you a “Ready to import” message, and your camera’s icon appears 
in the Source list at the left side. 

	3.	If you like, type in a roll name and description for the pictures you’re about to 
import.

Each time you import a new set of photos into iPhoto—whether from your hard 
drive, a camera, or a memory card—that batch of imported photos is called a 
film roll. 

Typing in a name for each new batch as you import it—Disney, First Weekend, Baby 
Meets Lasagna—will help you organize and find your pictures later on. Use the 
Description box for more elaborate textual blurbs, if you like. You could specify 
who was on the trip, the circumstances of the shoot, and so on.

	4.	Turn on “Delete items from camera after importing,” if you like.

If you turn on this box, iPhoto automatically deletes all photos from your camera’s 
memory card once they’re safely on the Mac. Your card is now ready for you to fill 
with more pictures. (iPhoto doesn’t delete your pictures until after it has success-
fully copied them all to the Photo Library.)

	5.	Click the Import button.

If you chose the auto-erase feature, you see a final “Confirm Move” dialog box, 
affording you one last chance to back out of that decision. 

A different message appears if you’re about to import photos you’ve already im-
ported, offering to skip the duplicates.

In any case, iPhoto swings into action, copying each photo from your camera to 
your hard drive. You get to see them as they parade by.

When the process is over, your freshly imported photos appear in the main iPhoto 
window, awaiting your organizational talents. You can now turn off your camera 
and unplug it. 

Tip: You can also import photos, or even folders or disks full of them, by dragging their icons (or the disk 
or folder icons) directly into the iPhoto window.

iPhoto

MacOSX4e_Ch10_RB.indd   349 10/9/2006   1:54:14 PM



350	 mac os x: the missing manual

Organizing Photos
You now see a neatly arranged grid of thumbnails (Figure 10-22). You’re looking 
at what iPhoto refers to as your Library—your entire photo collection, including 
every last picture you’ve ever imported. Use the Size slider at lower right to adjust 
the thumbnail size.

Last Roll
Most of the time, you’ll probably work with the photos that you just downloaded 
from your camera. That’s the purpose of the roll-of-film icon called Last Roll. With 
one click, iPhoto displays only your most recent photos, hiding all the others. To 
return to the grand overview of all your pictures, click the Library icon at the top of 
the Source list. 

Deleting photos
As every photographer knows—make that every good photographer—not every photo 
is a keeper. To delete a photo, click its icon and then press the Delete key. Instead of 
deleting the photo immediately, iPhoto lets it sit there in the Trash, awaiting perma-
nent disposal via the Empty Trash command. 

Whatever pictures you erase this way also disappear from any albums you’ve created. 
(Deleting a photo from an album is different, as described in a moment.)

Albums
An album is a subset of pictures from your Photo Library, grouped together for easy 
access and viewing. It’s represented by a little album-book icon in the Source list. 

Figure 10-22:
Meet iPhoto. The large photo-
viewing area is where thumb-
nails of your imported photos 
appear. The icons at the bot-
tom of the window represent 
all the stuff you can do with 
your photos. The lower-left 
corner can show you informa-
tion, a list of keywords, or the 
iPhoto calendar (click to see 
photos taken during a certain 
day, week, or month). 

Photo viewing areaSource list

Share buttons Zoom in/Zoom out

Drag to adjust
panel sizes

iPhoto
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(If you’ve used playlists in iTunes or folders in Mail, you’ll recognize the concept.) 
Albums make finding photos much faster. Furthermore, only in an album can you 
drag your photos into a different order. 

Tip: You can also plop several albums into a single folder in order to tidy up your Source list. Create a folder 
by choosing File→New Folder.

To create an iPhoto album, choose File→New Album (-N), or click the + button in 
the iPhoto window, below the album list. A dialog box appears. Type in a descriptive 
name (Yellowstone 2005, Edna in Paris, or whatever), click OK, and watch as a new 
photo album icon appears in the Source list. (See Figure 10-23.)

Tip: You can also drag a thumbnail (or a batch of them) from the photo-viewing area directly into an empty 
portion of the Source list. In a flash—well, in about three seconds—iPhoto creates a new album for you, named 
Album-1 (or whatever number it’s up to). The photos you dragged are automatically dumped inside. 

In fact, you can drag a bunch of graphics files, or a folder full, from the desktop into the Source list. In one 
step, iPhoto imports the photos, creates a new photo album, names it after the folder you dragged in (if 
that’s how you did it), and puts the newly imported photos into that album.

To rename an album, double-click its name or icon (or, if it’s already highlighted, 
just press Return). A renaming rectangle appears, with text highlighted and ready to 
be edited. 

To add photos to an album, drag them onto its icon. 

Figure 10-23:
There’s no limit to the number of albums you can 
add, so make as many as you need to logically 
organize all the photos in your Photo Library. New 
albums are always added to the end of the list, but 
you can change the order in which they appear by 
simply dragging them up or down in the list.

iPhoto
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Putting photos in an album doesn’t actually move or copy them. You’re just creating 
references to, or aliases of, the photos in your master Photo Library. In other words, 
each photo can appear in as many different albums as you want.

Deleting photos or albums
To remove a photo from an album, click the album name to view its contents, click 
the photo you want to remove, and then press Delete. The thumbnail disappears from 
the album, but it’s not really gone from iPhoto. 

To delete a selected album, choose Photos→Delete Album or press the Delete key. 
Deleting an album doesn’t delete any photos, just the references to those photos. Even 
if you delete all your albums, your Photo Library remains intact.

Editing
The easiest way to open a photo for editing is to double-click its thumbnail (or high-
light it and then click the Edit button at the bottom of the window). Unless you’ve 
changed iPhoto’s settings, the photo opens in the main iPhoto window, scaled to fit 
into the viewing area. 

iPhoto aficionados prefer, however, to use iPhoto’s much smarter, but less obvious, 
methods that open each picture in its own window. For example, you can:

	 •	Choose iPhoto→Preferences and, on the General pane, change the photo-opening 
setting. Under the “Double-click photo:” heading, select the “Opens photo in edit 
window” button. Then close the dialog box.

	 •	Control-click a photo. Choose “Edit in separate window” from the shortcut menu. 
(If you choose “Edit in external editor,” you can edit the photo in another pro-
gram—Photoshop, for example, or whatever program you chose in the Preferences 
dialog box described above.)

When a photo opens in its own window, you can look at multiple full-size images 
at the same time—a critical feature when comparing a series of similar shots. And 
you can keep your other thumbnails in view, allowing you to easily open additional 
photos without closing the ones you already have open. 

Opening a photo also summons these editing tools:

	 •	Enhance. With one click, this tool endeavors to make photos look more vibrant 
by tweaking the brightness and contrast settings and adjusting the saturation to 
compensate for washed-out or oversaturated colors. 

	 •	Cropping. The cropping tool lets you cut away the outer portions of a photo to 
improve its composition or to make it the right size for a printout or Web page. 
Choose a fixed proportion from the Constrain menu, if you like, then drag across 
the photo to indicate how you want it cropped. Finally, click Crop.

	 •	Retouch. This little brush lets you paint out minor imperfections like blemishes, 
freckles, and scratches.

iPhoto
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	 •	Red-Eye. This little filter gets rid of a very common photo glitch—those shining 
red dots that sometimes appear in a person’s eyes as the result of flash photography. 
Who wants to look like a werewolf? 

	 •	B & W. Turns your color photos into moody black-and-white art shots. 

	 •	Sepia. Makes new photos look faded and brownish, for that old-time daguerreotype 
look.

	 •	Adjust. Opens the new Adjust panel, whose sliders offer ridiculous amounts of 
control over color balance, exposure, and other parameters (Figure 10-24). (Some 
of its sliders are unavailable on Macs with G3 processors.) 

Tip: By pressing and releasing the Control key, you can toggle between the “before” and “after” versions 
of the photo to assess the results of the enhancement. Remember, too, that no matter what changes you 
make to a photo, you can always restore it to its original camera condition—even years later—by clicking it 
and then choosing Photos→Revert to Original. That’s a nice safety net, indeed.

Figure 10-24:
Top: Here’s a promising 
landscape shot, along 
with its histogram—a 
self-updating visual 
representation of the 
dark and light tones 
that make up your 
photograph. The 
amount of the photo’s 
darker shades appears 
toward the left side of 
the graph; the lighter 
tones are graphed 
on the right side. 
Unfortunately, in this 
shot, much of the tonal 
information is bunched 
in the middle of the 
graph. As a result, the 
photo looks a little 
“flat,” without much 
contrast. 

Bottom: Step one in 
the repair job, then, is 
to move the Exposure 
slider a little to the 
right to improve the 
midtones. Because the 
graph in the histogram 
is elongated as a 
result, you’ve also im-
proved the contrast.

iPhoto
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Sharing Your Pix
The payoff for all of this organizational effort is, of course, showing your photos to 
other people. iPhoto is endlessly talented in this department. After you select some 
photos or an album, here are the bottom-of-the-screen icons you can click:

Print
iPhoto can print out your photos on standard sizes of inkjet photo paper, or you can 
use a template that clusters several photos onto each sheet, saving paper and ink.

Slideshow
Onscreen slideshows are easy to set up, they’re free, and they make your photos look 
fantastic. The Mac presents the pictures in full-screen mode—no windows, no menus, 
no borders—with your images filling every inch of the monitor. Each picture fades 
gently into the next, producing a smooth, cinematic effect. If you want, you can even 
add a musical soundtrack to accompany the presentation. And if you wiggle the mouse, 
you get a control bar that lets you rotate, delete, or rate each photo as it goes by.

Starting in iPhoto 5, you can try three different kinds of slideshows:

	 •	Instant. Click an album (or highlight a group of thumbnails), and then Option-
click the Play button under the Info pane. A moment later, your Mac’s screen fades 

Figure 10-25:
In this dialog box, you can adjust 
how fast the slides change, how 
you want the show to repeat, and 
which song (from your iTunes col-
lection) you want as the slideshow’s 
soundtrack. (Use the Music tab to 
choose any playlists that you’ve al-
ready created using iTunes, or hand 
pick them right here in iPhoto.)

iPhoto
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to black and the show begins. If this is the first time you’ve triggered a slideshow 
from this album, J. S. Bach’s Minuet in G plays in the background. When you’ve 
had enough, click the mouse or press almost any key. 

	 •	Quick. If you click the Play button (instead of Option-clicking), you get a dia-
log box where you can fine-tune the timing and music of the slideshow (Figure  
10-25).

	 •	Saved. A saved slideshow appears as an icon in your Source list. The beauty of 
this system is that you can tweak a slideshow to death—you can even set up dif-
ferent transitions, zooming characteristics, and speed settings for each individual 
slide—and then save all your work as an independent clickable icon, ready for 
playback whenever you’ve got company.

The key to all of this is the Slideshow icon at the bottom of the iPhoto window. It 
tosses you into the Slideshow editing mode, which has some features of Edit mode 
and some features of regular old thumbnail-organizing mode.

Email
Full-size photos are usually too big to email. They take forever to download, they run 
the risk of exceeding your recipient’s Inbox limit, and they open up much too large 
on your victims’ screens. Fortunately, iPhoto can automatically send a scaled-down, 
reasonably sized version of your photo instead. 

Start by choosing the email program you use in the iPhoto→Preferences→General 
pane, and then close the window. Next, highlight the photos you want to send, and 
click the Email icon on the panel at the bottom of the iPhoto window. In the resulting 
dialog box, choose a size for your photos. “Medium (640 x 480)” yields a file that will 
fill a nice chunk of your recipient’s screen, with plenty of detail. 

Finally, click Compose. iPhoto processes your photos and then opens your email pro-
gram, creates a new message, and attaches your photos to it. Just type your recipient’s 
email address into the “To:” box, and then click Send.

Order prints
This option uploads your selected photos and—for a fee—converts them into hand-
some Kodak prints that get mailed back to you.

Book
iPhoto’s Book feature lets you design and order (via the Internet) a gorgeous, linen-
covered, 8.5-x-11-inch hardbound book—or a softcover book in any of three sizes. 
All books are printed at a real bindery and shipped back to you in a slipcover. Your 
photos are printed on the glossy, acid-free, single- or double-sided pages, complete 
with captions, if you like. 

Book prices start at $10. That’s about the least you could hope to pay for a hand-
some, emotionally powerful gift guaranteed never to wind up in an attic, garage sale, 
or eBay. 

iPhoto
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Once you’ve selected an album or a batch of photos, click the Book button below the 
main picture area (Figure 10-22), or choose File→New Book. Now you see something 
like Figure 10-26: a dialog box in which you can specify what you want your book to 
look like. You can choose hardcover or softcover, single- or double-sided pages, and 
which design scheme you want.

When you click Choose Theme, a message appears to let you know you have two 
choices for placing photos onto the book-page layouts: either click the Autoflow but-
ton (identified in Figure 10-27), which makes the Mac do the job for you—or drag 
photos individually into the placeholders. Click OK.

At this point, two things happen. First, a new icon appears in your Source list, rep-
resenting the book layout you’re about to create. You can work with it as you would 
other kinds of Source-list icons. For example, you can delete it by dragging it to the 
iPhoto Trash, rename it by double-clicking, file it in a folder by dragging it there, 
and so on. 

Note: If you’re used to previous iPhoto versions, this is a happy bit of news. It means that a book is no longer 
tied to an album. Therefore, rearranging or reassigning photos to the original album no longer wreaks havoc 
with the book design that’s associated with it.

Second, you now see something like Figure 10-27. The page you’re working on ap-
pears at nearly full size in the main part of the window. Up above, you see a set of 
thumbnails, either of your photos or of your pages (more on this in a moment); that’s 
the photo browser. iPhoto has just turned into a page-layout program.

Figure 10-26:
You can change 
these settings 
later, even after 
you’ve started 
laying out your 
book’s pages. 
But if you have 
the confidence to 
make these deci-
sions now, you’ll 
save time, effort, 
and (if you want 
captions for your 
photos) possibly 
a lot of typing.

iPhoto
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Once you’ve selected an album and a theme, the most time-consuming phase begins: 
designing the individual pages.

	 •	Choose a Page Type. iPhoto always proposes varying the number of photos per 
page. Two-per-page on the first page, a big bold one on the next, a set of four on 
the next, and so on. 

If you approve of the photos-per-page proposal, great. Sooner or later, though, 
there will come a time when you want three related photos to appear on a page 
that currently holds only two. That’s the purpose of the Page Type pop-up menu. 
It’s a list of the different page designs that Apple has drawn up to fit the overall 
design theme you’ve selected: Cover, Introduction, One (photo per page), Two 
(photos), and so on.

	 •	Pick a layout variation. Once you’ve chosen how many photos you want on a 
page, the Page Design pop-up menu becomes available to you. It contains tiny 
thumbnail representations of the various photo layouts available. 

Figure 10-27:
In Book mode, 
there’s a miniature 
page-layout 
program right in 
iPhoto. Note that 
the picture-size 
slider is still present. 
You can use it to 
zoom in or out from 
the page you’re 
working on, which 
can be handy when 
you’re editing text 
(including captions) 
at small type 
sizes. Also note the 
single-page/two-
page switch at the 
lower-left corner. 
For books with 
two-sided printing, 
it lets you specify 
whether you want 
to edit one page 
at a time, or one 
two-page spread at 
a time.

Page/photo browserPage thumbnails
Unplaced photos

Single-page view/Double-page view Zoom in/
Zoom out

Previous page/
Next page

Autoflow
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	 •	Lay out the book. The key to understanding iPhoto 5’s book-layout mode is real-
izing that all photos are draggable (Figure 10-28). You can swap two photos by 
dragging one directly on top of the other; move a photo to a different page of the 
book by dragging it onto a different page in the photo browser; remove a photo 
from a page by clicking its icon and then pressing your Delete key (which makes 
its icon move up into the unplaced-photos area); add an unplaced photo to a 
page by dragging it out of the unplaced-photos browser onto a blank spot of the 
page; fill in an empty gray placeholder frame by dragging a photo onto it from the 
unplaced-photos area; and so on.

Tip: You can also enlarge or crop a picture, right there on the page, by double-clicking it. A tiny zoom slider 
appears above the photo, which you can use to magnify the picture or shift it inside its boundary “frame.” 
For now, it’s worth remembering that this trick is helpful when you want to call attention to one part of the 
photo, or to crop a photo for book-layout purposes without actually editing the original.

Photos aren’t the only ones having all the fun. You can drag and manipulate the pages 
themselves, too. Here’s how: 

	 •	Move pages around within the book by dragging their thumbnails horizontally 
in the photo browser.

	 •	Remove a page from the book by clicking its photo-browser icon and then either 
pressing Delete or choosing Edit→Remove Page. (If you use the Delete-key method, 
iPhoto asks if you’re sure you know what you’re doing.) Note that removing a page 
never removes any pictures from the book. 

	 •	Insert a new page into the book by clicking the Add Page button at the bottom of 
the window, or by choosing Edit→Add Page.

Before blowing a bunch of money on a one-shot deal, you’d be wise to proofread and 
inspect it from every possible angle, either by printing it (File→Print) or by saving 
it as a PDF file (choose File→Print and, from the PDF pop-up button, clicking the 
Save as PDF button).

When you think your book is ready for birth, click Buy Book. After several minutes 
of converting your screen design into an Internet-transmittable file, iPhoto offers you 
a dialog box where you can choose a cover color (hardback books only), indicate the 
quantity, and place your order.

HomePage
If you have a .Mac account, you can turn an album or a selection of photos into an 
instant gallery on your Web page, complete with fast-downloading thumbnail images 
that your visitors can click to magnify. All you have to do is send your fans the Web 
address provided by the .Mac account.

iPhoto
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Tip: If you already have a Web site (not a .Mac account), you can also generate an online gallery by choos-
ing Share→Export and clicking the Web Page tab. iPhoto saves, to your hard drive, a complete set of HTML 
documents and linked, nested folders (containing both thumbnails and full-size images), ready to upload to 
your site. (You just won’t have access to all of Apple’s canned design schemes.)

Figure 10-28:
iPhoto’s book-
layout mode is 
absolutely crawling 
with tricks that let 
you move photos 
around, add them 
to pages, remove 
them, and so on. 

The fun begins 
when you under-
stand the difference 
between the page 
browser (top) and 
the unplaced-photo 
browser (bottom). 
For example, 
you can add new 
photos to your 
book only via the 
unplaced-photo 
browser. Use the 
page browser more 
as a navigational 
tool. 

Rearrange pages

Move photo to a different page

Swap photos

Page browser

Unplaced photos browser

Swap photos

Add another
photo

Remove photo
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.Mac slides
When you send your photos out into the world as .Mac slides, other people who use 
Mac OS X can subscribe to your show, displaying your pictures as their screen saver. 

To create a .Mac slideshow, select the album or photos you want to share, and then 
choose Share→.Mac Slides. Click Publish to upload your photos. When the process is 
complete, click Announce Slideshow to email your friends about your slides.

To view someone else’s .Mac slideshow, see page 279.

Desktop (or screen saver)
This button plasters any selected photo onto your desktop as a wallpaper background. 
Neat!

If you select multiple photos (or an album), this button opens up the Desktop & 
Screen Saver pane of System Preferences. If you leave the Desktop pane selected, the 
photos become a self-changing desktop background, alternating every 30 minutes (or 
whatever you choose from the pop-up menu).

If you click the Screen Saver button instead, they become grist for the Mac OS X screen 
saver. Wait long enough, and they’ll appear all by themselves, in gorgeous, panning, 
cross-fading fashion. 

Burn Disc
iPhoto CDs are discs (either CDs or DVDs) that you can create directly from within 
iPhoto to archive your entire Photo Library—or any selected portion of it—with 
just a few mouse clicks. This is a great way to back up your photos; transfer them to 
another copy of iPhoto without losing all your keywords, descriptions, and titles; share 
discs with other iPhoto fans; offload photos to CD or DVD as your photo collection 
grows; or merge separate Photo Libraries (such as the one on your iBook and the one 
on your iMac) into a single master library.

These discs do not play in Windows or Mac OS 9. They’re exclusively for iPhoto’s 
use.

Note: The Burn Disc button doesn’t start out installed at the bottom of the iPhoto screen. Use the Share→
Show in Toolbar submenu to specify which icons appear there.

Select the albums or photos that you want to include on the disc, and then click the 
Burn icon. Pop in a blank CD or DVD.

Now open the Info panel just below the Source list (click the  button). If the set of 
photos you want to burn is larger than 650 or 700 megabytes (for a CD) or about 
4.3 gigabytes (for a single-layer DVD), it’s not going to fit. You’ll have to split your 
backup operation across multiple discs. Select whatever number of photo albums or 
individual pictures that will fit on a single disc. After burning the first disc, select the 
next set of photos, and then burn another CD or DVD. 

iPhoto
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Finally, click the Burn icon again. When the process is done, your Mac spits out the 
finished CD (named “iPhoto Disc”), ready to use.

Later, if you want to view the contents of your finished disc in iPhoto, pop it back 
into the drive. The icon for the disc appears in the Source list of the iPhoto window. 
If you click the icon, the photos it contains appear in the photo-viewing area, just as 
if they were stored in your Photo Library. 

iSync
See Chapter 19 for details on this file-synchronization software.

iTunes
iTunes is Apple’s beloved digital music–library program. Chapter 11 tells all.

Mail
Mail, the Mac OS X email program, received a significant upgrade in Tiger. See Chapter 
20 for the whole story.

Photo Booth
This hilariously wacky photo-taking program is described on page 534.

Peview
Preview is Mac OS X’s built-in graphics viewer. It’s also the program you use to view 
incoming faxes (Chapter 14), as well as a nearly full-blown clone of Adobe Reader (for-
merly Acrobat Reader), the free program that most people use to read PDF files. 

In fact, because Preview now includes searching PDF documents, copying text out 
of them, adding comments, filling in forms, and clicking live hyperlinks—features 
that used to be available only in Adobe Reader—Apple doesn’t even include Adobe 
Reader with Mac OS X. 

Preview as Graphics Viewer
Preview’s hallmark is its surprising versatility. It can display and manipulate pictures 
saved in a wide variety of formats, including common painting formats like JPEG, 
TIFF, PICT, and GIF; less commonly used formats like BMP, PNG, SGI, TGA, and 
MacPaint; and even Photoshop, EPS, and PDF graphics. You can even open animated 
GIFs by adding a Play button to the toolbar, as described below.

Cropping graphics
To crop graphics in Preview, drag across the part of the graphic that you want to keep. 
To back out or redraw, click outside the highlighted area; or, to proceed with the crop, 
choose Tools→Crop Image. (The keyboard shortcut is -K, just as it is in iMovie.)

iPhoto
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If you don’t think you’ll ever need the original again, save the document. Otherwise, 
choose File→Save As to spin the cropped image out as a separate file, preserving the 
original in the process. 

Tip: You can also rotate an image—even a PDF document—in 90-degree increments and then flip it vertically 
or horizontally, using the commands in the Tools menu.

Converting file formats
Preview doesn’t just open all these file formats—it can also convert between most of 
them. You can pop open some old Mac PICT files and turn them into BMP files for 
a Windows user, pry open some SGI files created on a Silicon Graphics workstation 
and turn them into JPEGs for use on your Web site, and so on. 

Tip: What’s even cooler is you can open raw PostScript files right into Preview (usually, anyway), which 
converts them into PDF files on the spot. You no longer need a PostScript laser printer to print out high-end 
diagrams and page layouts that come to you as PostScript files. Thanks to Preview, even an inkjet printer 
can handle them. 

All you have to do is open the file you want to convert and choose File→Save As. In 
the dialog box that appears, choose the new format for the image using the Format 
pop-up menu. Finally, click Save to export the file.

The Thumbnails drawer
The Thumbnails drawer slides out from the side of the main Preview window whenever 
(a) you open a multipage PDF or TIFF file, or (b) you highlight a bunch of graphics 
files in the Finder and open them all at once. (If your PDF file has been prepared with 
a table of contents, the drawer shows that.)

The idea is that these thumbnails let you navigate pages or graphics without having 
to open a rat’s nest of individual windows. Figure 10-29 expands on the idea.

Preview as PDF Reader
Preview is a nearly full-blown equivalent of Acrobat Reader, the free program used 
by millions to read PDF documents. Here are the basics:

	 •	Zoom in and out using -plus and -minus. 

Note: You can no longer Option-click the magnifying glass icons on the toolbar to zoom in or out only five 
percent per click, as you could in Mac OS X 10.3.

	 •	Use the View→PDF Display submenu to control how the PDF document appears: as 
two-page spreads; single scrolling sheets of paper towel; with borders that indicate 
ends of pages; and so on.

	 •	Use -left arrow and -right arrow to page through a document. (Your Page Up 
and Page Down keys aren’t quite the same thing; they shift to the previous or next 
part of the same page, if it wasn’t already visible.) 

Preview
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Tip: Some PDF documents include a table of contents, which you’ll see in Preview’s drawer, complete with 
flippy triangles that denote major topics or chapter headings. You can use the up arrow and down arrow 
keys alone to walk through these chapter headings, and then expand one that looks good by pressing the 
right arrow key. Collapse it again with the left arrow key. 

In other words, you expand and collapse flippy triangles in Preview just as you do in a Finder list view. 

	 •	Bookmark your place by choosing Bookmarks→Add Bookmark (-D); type a 
clever name. In future, you’ll be able to return to that spot by choosing its name 
from the Bookmarks menu.

	 •	Type in notes as shown in Figure 10-30.

Note: Once you save the document, you can’t move or change the notes or ovals you’ve added. If being 
able to restore the original document is important to you, use the File→Save As to spin out a copy of it 
before you annotate.

	 •	Turn antialiasing (font smoothing) on or off to improve readability. To find the 
on/off switch, choose Preview→Preferences and click the PDF tab. (Though  
antialiased text generally looks great, it’s sometimes easier to read very small type 
with antialiasing turned off. It’s a little jagged, but clearer nonetheless.)

Figure 10-29:
To open or close the 
Thumbnails drawer 
(right), click the Thumb-
nails icon at the left end 
of the toolbar. Inciden-
tally, you can change the 
size of these miniatures 
by choosing Preview→
Preferences and adjust-
ing the slider under the 
General tab. 

Preview
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	 •	Turn on View→PDF Display→Continuous to scroll through multipage PDF docu-
ments in one continuous stream, instead of jumping from page to page when you 
use the scroll bars. 

	 •	To find a word or phrase somewhere in a PDF document, press -F (or choose 
Edit→Find→Find) to open the Find drawer. Proceed as shown in Figure 10-31.

	 •	If you want to copy some text out of a PDF document—for pasting into a word 
processor, for example, where you can edit it—click the Text tool (the letter A on 
the toolbar) or choose Tools→Text Tool. Now you can drag through some text and 
then choose Edit→Copy, just as though the PDF document is a Web page. You can 
even drag across page boundaries.

Figure 10-30:
Click the Annotation tool 
on the toolbar. Drag diago-
nally to define a notes box; 
double-click inside, and 
then type! Click outside the 
box when you’re finished. 
At this point, you can drag 
or delete the box. If you 
choose Oval Annotation 
from the Annotate Tool’s 
pop-up menu, you can 
also circle something on 
the page, in red, to draw 
attention to it.

Figure 10-31:
Once the Find drawer is 
open (press -F), begin 
typing into the Find 
box (top right). Preview 
presents a list of match-
ing phrases in the list as 
you type, exactly as in 
the Finder’s search box. 
(The numbers next to 
the occurrences repre-
sent page numbers.) To 
jump to the spot on the 
actual page, click any of 
the results.

Preview
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Tip: Ordinarily, dragging across text selects the text from one edge of the page to the other. But if you want 
to copy only the first column of several, for example, Option-drag. Preview now lets you drag out any arbitrary 
selection rectangle, thereby highlighting any block of text you like, ready for copying. 

	 •	Preview is now a mini-iPhoto, complete with color-correction tools. With a photo 
on the screen, choose Tools→Image Correction. A passel of sliders appears (Satura-
tion, Contrast, Exposure, and so on), for your image-tweaking pleasure.

	 •	You can save a single page from a PDF as a TIFF file in order to use it in other 
graphics, word processing, or page layout programs that might not directly rec-
ognize PDF. 

To extract a page, use the usual File→Save As command, making sure to choose the 
new file format from the pop-up menu. (If you choose a format like Photoshop or 
JPEG, Preview converts only the currently selected page of your PDF document. 
That’s because there’s no such thing as a multipage Photoshop or JPEG graphic. 
But you already knew that.)

	 •	Add keywords (Tools→Get Info) to a graphic or PDF. Later, you’ll be able to call 
up these documents with a quick Spotlight search for those details.

The Toolbar
You can have hours of fun with Preview’s toolbar. Exactly as with the Finder toolbar, 
you can customize it (by choosing View→Customize Toolbar—or by Option--
clicking the upper-right toolbar button), rearrange its icons (by -dragging them 
sideways), and remove icons (by -dragging them downward).

Tip: Unhappy about the full inch of screen space consumed by the toolbar? No problem. Just -click the 
toolbar button (the white capsule in the upper-right corner). With each click, you cycle to the next toolbar 
style: large icons, small icons, no text labels, only text labels, and so on. 

QuickTime Player
There’s a lot to say about Apple’s new QuickTime player, but it’s all in Chapter 15.

Safari
Apple’s first and only Web browser feels decidedly faster and more modern than 
Internet Explorer, and there are enough tips and tricks lurking inside to last you a 
lifetime. Details in Chapter 21.

Sherlock
Sherlock is something like a Web browser that’s dedicated to certain common kinds 
of info-searches. Chapter 21 has the scoop.

Preview

MacOSX4e_Ch10_RB.indd   365 10/9/2006   1:54:19 PM



366	 mac os x: the missing manual

Stickies
Stickies creates virtual Post-it notes that you can stick anywhere on your screen—a 
triumphant software answer to the thousands of people who stick notes on the edges 
of their actual monitors. This little program isn’t quite as handy as the Stickies widget 
in Dashboard—you can’t make it spring to your screen with a keystroke, for example. 
However, it’s a lot more powerful. 

You can use Stickies to type quick notes and to-do items, paste in Web addresses or 
phone numbers you need to remember, or store any other little scraps and snippets 
of text you come across. Your electronic Post-it Notes show up whenever the Stickies 
program is running (Figure 10-32).

Creating Sticky Notes
The first time you launch Stickies, a few sample notes appear automatically, describing 
some of the program’s features. You can quickly dispose of each sample by clicking the 
close button in the upper-left corner of each note or by choosing File→Close (-W). 
Each time you close a note, a dialog box asks if you want to save it. If you click Don’t 
Save (or press -D), the note disappears permanently. 

To create a new note, choose File→New Note (-N). Then start typing or:

	 •	Drag text in from any other program, such as TextEdit, AppleWorks, or Microsoft 
Word. Or drag text clippings from the desktop directly into your note. You can 

Figure 10-32:
In the old days of the Mac, the notes you 
created with Stickies were text-only, single-
font deals. Today, however, you can use a 
mix of fonts, text colors, and styles within 
each note. You can even paste in graphics, 
sounds, and movies (like PICT, GIF, JPEG, 
QuickTime, AIFF, whole PDF files, and so 
on), creating the world’s most elaborate 
reminders and to-do lists. 

Stickies
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also drag a PICT, GIF, JPEG, or TIFF file into a note to add a picture. You can even 
drag a sound or movie in. (A message will ask if you’re sure you want to copy the 
whole whomping QuickTime movie into a little Stickies note.) 

	 •	Drag the icon of a PDF file into a note. (Stickies can even accommodate multipage 
PDF files. At first, you see only the first page, but a scroll bar is available to see the 
rest.)

	 •	How weird is this? In Tiger, you can even drag a Microsoft Word document into a 
note! 

	 •	Choose File→Import and select any plain text file or RTF (Rich Text Format) 
document to bring it into a note.

	 •	Drag URLs into a note directly from a Web browser’s address bar.

Tip: If one particular note contains your most important information—your to-do list, say—you can force it 
to remain in front of all other windows, even if Stickies itself gets shunted to the background. Just click the 
note and then choose Note→Floating Window. 

	 •	In TextEdit, Mail, or other Cocoa applications, select a chunk of text and then 
choose Make New Sticky Note from the program’s Services menu (page 175). 
This command launches Stickies, creates a new note, and fills it with your selected 
text—all in one step.

Note: All your notes are stored in a file called StickiesDatabase, located in your Home→Library folder. You’re 
free to copy it, pass it along, and so on, just as you would any file.

Have a favorite style for your sticky notes? First create a new note, choosing the color 
and text style that you like and setting it to the size you prefer. Then choose Note→
Use as Default. All new notes you create will now appear in the size, font, and color 
of your choice. 

Growing and Shrinking Notes
Stickies includes a few built-in tricks for managing a deskful of notes:

	 •	There’s a small resize handle on the lower-right corner of each note. Drag it to 
make notes larger or smaller onscreen. 

	 •	Use the small triangle in the upper-right corner of each note to zoom and shrink 
note windows with a single click. The first click collapses a note down to a more 
compact size. Another click pops the note back open to normal size.

	 •	The best option: Double-click anywhere along the dark strip at the top of each 
note to collapse it into a compact one-line mininote, as shown in Figure 10-33. 
You also can collapse a selected note by choosing Window→Miniaturize Window 
(-M).

Stickies
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Tip: The most efficient way to use Stickies is to keep the notes in their collapsed state, as shown in Figure 
10-33. When a note is collapsed, the first line of text shows up in tiny type in the collapsed title bar of the 
note, so you don’t have to expand the note to remember what’s in it. And since many—if not most—of your 
notes can probably be summed up in a couple of words (“pick up dry cleaning,” “call Mom”), it’s possible 
to keep your sticky notes in their collapsed state permanently.

Formatting Notes
Stickies has several word processor–like commands for creating designer sticky notes, 
with any combination of fonts, colors, and styles. You can also choose from six back-
ground colors from the Color menu. For the full scoop on Mac OS X’s Font panel, 
choosing colors, and other typographic finery, see page 525. 

Saving Sticky Notes
The notes you create in Stickies last only as long as you keep them open. If you close 
a note to get it out of the way (and click Don’t Save in the confirmation box), it 
vanishes permanently.

Figure 10-33:
If the first line of text gets truncated, as in the third note shown 
here, you can tug the right corner of the note and drag it wider 
without de-miniaturizing it.

The Hidden Stickies Commands
The casual Stickies user may miss some of the program’s 
more interesting commands, which are accessible only 
through the shortcut menus that pop up when you Control-
click a sticky note. Here’s what you’ll find only in the shortcut 
pop-up menus:

Check Spelling As You Type. Turning on this spell check 
option (in the Spelling menu) flags misspelled words the 
moment you type them. You must turn this option on or off 
for each note individually. 

Speech. Don’t just read your notes—listen to them. You can 
use the Mac’s Text-to-Speech feature to hear your notes read 
aloud. Choose Speech→Start Speaking to hear the Mac read 

a selected portion of a note, or use the command with noth-
ing selected to hear the entire contents of a note. The only 
way to stop the speech is to Control-click again and choose 
Speech→Stop Speaking. 

(To pick the voice and speed of the reader, go to the Speech 
pane of System Preferences, as described on page 558).

Writing Direction. This feature is intended to let you type 
in non-English languages. But even in English, you can have 
plenty of fun with unsuspecting suckers by choosing Right 
to Left, so that all your text is right-justified and the insertion 
point moves to the left as you type.

power users' clinic
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If you want to preserve the information you’ve stuffed into your notes in a more perma-
nent form, use File→Export Text to save each note as a standalone TextEdit document. 
When you use the Export Text command, you have the following options:

	 •	Plain Text. This option saves your note as a plain text file, with neither formatting 
nor pictures. 

	 •	RTF stands for Rich Text Format, a special exchange format that preserves most 
formatting, including font, style, and color choices. You can open the resulting 
RTF file in just about any word processor with all of your formatting still intact.

	 •	RTFD. RTFD, a strange and powerful variant of RTF, is a Rich Text Format docu-
ment with attachments. How do you “attach” items to an RTFD file? Drag the icon 
of an actual application (Preview, Calculator, or whatever) or a multipage PDF 
file, into a sticky note. The icon for the program or document appears in the note, 
but double-clicking the icon doesn’t do anything. When you export the note as an 
RTFD file, the result is a TextEdit document that has embedded within it the entire 
program or document that you dragged in. The program icon appears just as it 
did in the sticky note, but if you double-click the icon, the program now actually 
opens. (For more about RTFD files, see the box on page 376.)

You can also paste a graphic into your sticky note. When you export the note as an 
RTFD document, the resulting package file includes a graphics file of the format 
that you pasted.

If you don’t have embedded programs or documents in your notes, then exported 
RTFD files are exactly the same as their RTF counterparts.

Tip: You can import the Stickies file from your old Mac OS 9 System Folder. Just choose File→Import 
Classic Stickies. In the Open File dialog box, navigate to the old System Folder→Preferences→Stickies File 
document and open it. 

System Preferences
This program opens the door to the nerve center of Mac OS X’s various user prefer-
ences, settings, and options. Chapter 9 covers every option in detail.

TextEdit
TextEdit: It’s not just for Read Me files anymore. 

As always, TextEdit (Figure 10-34) is a basic word processor—but it’s not nearly as 
basic as it used to be. You can create real documents with real formatting, using style 
sheets, colors, automatic numbering and bullets, tables, and customized line spacing, 
and—get this—even save the result as a Microsoft Word document. There’s even a 
multiple-level Undo command. If you had to, you could write a novel in TextEdit 
and it would look pretty decent. 

Stickies
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TextEdit’s Two Personalities
The one confusing aspect of TextEdit is that it’s both a plain text editor (no formatting; 
globally compatible) and a true word processor (fonts, sizes, styles; compatible with 
other word processors). You need to keep your wits about you as you edit, because 
the minute you add formatting to your document, TextEdit no longer lets you save 
it as a plain text file. 

Here’s the scheme: 

	 •	You can change a plain text document to a formatted one by choosing Format→
Make Rich Text. The ruler appears automatically to remind you that a new world 
of formatting has just become available.

	 •	Conversely, you can change a formatted document (a Word file you’ve opened, 
for example) to a plain text document by choosing Format→Make Plain Text. An 
alert message appears to point out that you’re about to lose all formatting.

	 •	If you know what kind of document you always want to open, go to the  
TextEdit→Preferences dialog box; on the New Document pane, select Rich Text or 
Plain Text. That’s the kind of document you get each time you choose File→New. 

Figure 10-34:
The text ruler gives 
you control over tab 
stops, line spac-
ing, paragraph 
justification, and so 
on. Pressing -R 
makes it appear and 
disappear. The Style 
pop-up menu lists 
canned sets of char-
acter and paragraph 
formatting, so you 
can apply them con-
sistently throughout a 
document.

TextEdit
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Working in TextEdit
As you begin typing, all the usual word processing rules apply, with a few twists:

	 •	Choose Bold, Italic, and font sizes using the Format→Font submenu, or choose 
Format→Font→Show Fonts (-T) to open up the standard Mac OS X Font panel 
(page 525). You can even create subscript or superscript, change the color of the 
text (Format→Font→Show Colors), and so on.

	 •	Common paragraph-alignment options—Align Left, Align Right, Center, Jus-
tify—are all available as ruler buttons and also reside in the Format→Text sub-
menu. Adjust the line spacing (single, double, or any fraction or multiple) using 
the Spacing pop-up menu in the ruler.

	 •	New in Tiger: The ruler also offers automatic bulleting and numbering of high-
lighted (or about-to-be-typed) paragraphs. Just choose the numbering style you 
prefer from the Lists pop-up menu.

	 •	Also new in Tiger: You can select several bits of text simultaneously. To pull this off, 
highlight your first piece of text by dragging, and then press  as you use the mouse 
to select more text. Bingo: You’ve highlighted two separate chunks of text.

When you’re done selecting bits of text here and there, you can operate on them en 
masse. For example, you can make them all bold or italic with one fell swoop. You 
can even use the Cut, Copy, and Paste commands, as described in the next section. 
When you cut or copy, the command acts upon all your selections at once.

The Deal with Microsoft Word
Yes, you read that correctly: Humble TextEdit can now open 
and create Microsoft Word documents! Your savings: the $400 
price of Microsoft Office!

Well, sort of.

When you open a Microsoft Word document, most of the 
formatting comes through alive: bold, italic, font choices, 
colors, line spacing, alignment, and so on. Even very basic 
tables make it into TextEdit, although with different column 
widths. 

A lot of Word-specific formatting does not survive crossing the 
chasm, however: borders, style sheets, footnotes, and the like. 
Bullets and numbered lists don’t make it, either, even though 
TextEdit can create its own versions of these. And TextEdit 

doesn’t recognize the comments and change tracking that 
your collaborators might use to mark up your manuscript.

Saving a TextEdit document as a Word document (File→Save 
As) is a better bet, because Word understands the many kinds 
of formatting that TextEdit can produce—including bullets, 
numbering, and tables. The one disappointment is that Word 
doesn’t recognize any style sheets you’ve set up in TextEdit. 
The formatting applied by those style names survives—just 
not the style names themselves.

Even so, a built-in Word-document editor is a huge, huge step 
for the Mac OS. It means that in many cases, you can be a 
first-class citizen on the playing field of American business. 
Nobody ever needs to know that you’re (a) using a Mac, and 
(b) not using the real Microsoft Word.

up to speed

TextEdit
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You also drag any one of the highlighted portions to a new area, confident that 
the other chunks will come along for the ride. All of the selected areas wind up 
consolidated in their new location.

Tip: If you Option-drag one of the highlighted bits, you copy it, leaving the original in place.

	 •	Similarly, you can use the Find command to highlight a certain term everywhere it 
appears in a document. To do that, choose Edit→Find→Find (or just press -F). 
Fill in the “Find” and “Replace with” boxes—and then press the Control key. The 
Replace All button changes to say Select All.

Advanced Typography in TextEdit
If you just sprayed your coffee upon reading the heading of 
this sidebar, you’re forgiven. Advanced typography in TextEdit? 
Isn’t that a little bit like saying, “page layout in Note Pad”?

Not at all. TextEdit is a gleaming showcase for Mac OS X’s 
typographical smarts.

Most of the commands in the Format→Font submenu should 
be familiar to you: Bold, Italic, Underline, and so on. But a 
few were once found only in expensive page-layout programs 
like PageMaker and QuarkXPress. 
For example:

Kern. Use these commands, such 
as Tighten and Loosen, to nudge 
the letters of the selected text 
closer together or farther apart—an 
especially useful feature when you’re fiddling with headlines 
and headings. 

There are no controls to set how much you want to kern the 
text, but you can apply these commands repeatedly to the 
same text selection to intensify them. If you want your text 
to be very tight, for example, just keep choosing the Tighten 
command. The characters creep closer and closer together 
until they crash into each other.

Ligature. Ligatures are letter pairs, such as fl and ff, that, in 
fancy typesetting, are often conjoined into special combination 

characters, as shown here. If you choose Format→Font→
Ligature→Use Default (or Use All), TextEdit displays these 
letter pairs with the appropriate ligatures. (This works only 
if the font you’re using has those ligatures built into it. New 
York, Charcoal, Apple Chancery, and all Adobe Expert fonts 
do, for example, but many other fonts don’t.)

Baseline. The baseline is the imaginary “floor” for text charac-
ters in a line of type. You can push text above this line or sink 
it below the baseline using the Raise and Lower commands 

in the Baseline submenu. The 
Superscript and Subscript com-
mands, meanwhile, shift characters 
far above or below the baseline, so 
you can write stuff like H20. 

Character Shape. In a few fonts, such as Adobe Expert fonts, 
this submenu offers a choice between Traditional Form and 
specialized type treatments like Small Caps.

Copy Style/Paste Style. If mastering the new Styles pop-
up menu (described on the facing page) is too much effort, 
these commands offer another way to copy and paste just 
the font formatting to other text in your document—the font, 
color, style, and size, but none of the actual text or paragraph 
attributes, such as alignment.

power users' clinic
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Tip: Oh, don’t get TextEdit started on secret keystrokes in the Find box. If you press Option, for example, the 
Replace All button changes to say In Selection (meaning that you’ll search-and-replace only the highlighted 
blob of text). 

You can combine the two previous tricks, too. If you press Control and Option, the Replace All button 
changes to say In Selection—but now you’re selecting, not replacing, all occurrences of the search text just 
within the highlighted block.

	 •	If you Option-drag vertically, you can freely select an arbitrary column of text (not 
necessarily the entire page width). This technique is very useful when you want 
to select only one column in a multicolumn layout, or when you want to select 
the numbers in a list (“1.,” “2.,” and so on) and format them all at once. (As noted 
earlier, this trick also works in Preview PDF documents.)

Style Sheets
A style is a prepackaged collection of formatting attributes that you can apply and 
reapply with a click of the mouse (bold, 24-point Optima, double-spaced, centered, 
for instance). You can create as many styles as you need: chapter headings, sidebar 
styles, and so on. You end up with a collection of custom-tailored styles for each of 
the repeating elements of your document.

Once you’ve created your styles, you can apply them as you need them, safe in the 
knowledge that they’ll be consistent throughout the document. During the editing 
process, if you notice you accidentally styled a headline using the Subhead style, you 
can fix the problem by simply reapplying the correct style. 

Note: Unlike a real word processor, TextEdit doesn’t let you change a style’s formatting and thereby update 
every occurrence of it. You can’t search and replace by style, either.

	 •	Creating a named style. To create a style, start by formatting some text so that it 
looks the way you like it, complete with font, color, line spacing, tab settings, and 
so on. 

Then, from the Styles pop-up menu in the ruler, choose Other (Figure 10-35, top). 
Click Add to Favorites, type a name for the style, turn on both checkboxes (Figure 
10-35, bottom), and click Add. 

	 •	Applying a style. Later, when you want to reuse the formatting you set up, highlight 
some text and then choose the appropriate name from the Styles pop-up menu. 
TextEdit applies the formatting immediately.

Tip: If you simply click inside a paragraph, applying a style affects only paragraph attributes like line spacing, 
tab stops, and alignment. If you highlight text instead, applying a style affects only character attributes like 
the font and type size. 

If you highlight an entire paragraph, however, both text and paragraph formatting appears.

TextEdit
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	 •	Deleting a style. To delete a superfluous style, choose Other from the Styles pop-up 
menu on the ruler. Click the Favorite Styles button, choose the unwanted style’s 
name from the pop-up menu, and click Remove From Favorites. (Deleting a style 
doesn’t affect any formatting that’s already in your document; it just removes the 
name from the Styles menu.) 

	 •	Copying by example. In Word and most other “serious” word processors, the 
routines above correctly describe how you use styles. In TextEdit, however, you 
can use Option--C and Option--V (Format→Copy Style and Format→Paste 
Style) to grab formatting from one place in your document and reuse it elsewhere. 
(Of course, you can’t apply styles in text-only documents.)

Tables
Tables can make life a heck of a lot easier when you want to create a résumé, agenda, 
program booklet, list, multiple-choice test, Web page, or another document where 
numbers, words, and phrases must be aligned across the page. In the bad old days, 
people did it by pressing the Tab key to line up columns—a technique that turned 
into a nightmare as soon as you tried to add or delete text. But using a word proces-
sor’s table feature is light-years easier and more flexible, because each row of a table 
expands infinitely to contain whatever you put into it. Everything else on its row 
remains aligned. 

Figure 10-35:
Highlight the text you want to 
format. Then, from the Styles 
pop-up menu in the ruler, choose 
Other. With each click of a 
triangle button, you summon a 
snippet of the next chunk of for-
matting. When you find one you 
like, you can either click Apply 
(to zap the highlighted text into 
submission) or Add To Favorites 
(to reuse this canned style later). 
In the latter case, you can give 
the new style a name (bottom).

TextEdit
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Tip: Tables are also critical for designing Web pages, as any Web designer can tell you. Even though you 
can’t see the table outlines, many a Web page is filled with columns of text that are aligned invisibly by 
tables. And now that TextEdit can save your work as an HTML document, it’s suddenly a viable candidate 
for designing basic Web pages.

	 •	Create a table by choosing Format→Text→Table. The floating Table palette ap-
pears (Figure 10-36). Use it to specify how many rows and columns you want. The 
placeholder table in your document adjusts itself in real time.

	 •	Format the table using the other controls in the Table palette. The Alignment 
controls let you specify how the text in one of the table cells hugs its border. Cell 
Border controls the thickness of the line around the selected cells’ borders (or, if 
you enter 0, makes the table walls invisible). The color swatch next to Cell Border 
specifies the color of the solid lines. The Cell Background controls let you color 
in the table cells with colors of your choice. (Choose Color Fill from the pop-up 
menu, and then click the color swatch.) This is an especially valuable option for 
Web designers. 

	 •	Adjust the rows and columns by dragging the cell borders. 

Figure 10-36:
Note to Web designers: 
TextEdit may not be 
Dreamweaver, but 
it’s great for spinning 
out quick Web pages, 
thanks to the table 
features. Here, you can 
see that a big table 
forms the underlying 
structure for this Web 
page, along with a 
couple of nested ones 
and color selections.

TextEdit
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	 •	Merge two selected cells by clicking Merge Cells in the Table palette. Once you’ve 
done that, you can use the Split Cell button to split them apart again. (Split Cell 
doesn’t work except in cells you’ve previously merged.) 

	 •	Nest one table inside a cell of another by clicking in the cell and then clicking Nest 
Table. Change the numbers in the Rows and Columns boxes to set up its dimen-
sions (Figure 10-36).

TextEdit as Web Designer
The new Table palette isn’t the only clue that Apple intends TextEdit to be a quick-
and-dirty Web page design program. Consider these other tools:

	 •	You can easily add graphics to the page by dragging or pasting them into a docu-
ment. The program understands TIFF, PICT, JPG, and GIF formats. 

	 •	You can add Web-style hyperlinks by highlighting “Click here” (or whatever the 
link says), choosing Format→Text→Link, and entering the Web address in the 
resulting dialog box. Or just drag a link in from Safari, Mail, or another program. 
(To edit the link later, Control-click it and choose Edit Link.)

	 •	To save a document as an HTML (Web page) file, choose File→Save As; from the 
File Format pop-up menu, choose Web Archive. 

TextEdit

Files Within Files Within Files
It’s no surprise that you can include formatted text and 
pictures in a TextEdit document, but here’s a shocker. You 
can also embed an entire program or document within a 
TextEdit file. 

Try this experiment: Create a 
new TextEdit document in Rich 
Text mode. Drag a couple of 
program icons into the TextEdit 
document. Do the same with 
some documents that were 
created using native Mac OS 
X programs (another TextEdit 
document, for example). 

When you save the file, Mac OS 
X saves embedded copies of the applications and documents 
you dragged into the TextEdit document itself. (The TextEdit 
file is saved in a format called RTFD, which is a Rich Text 
Format document with attachments.) 

Once you’ve saved the file, you can double-click any of the 
icons in the file to launch the embedded items. In the TextEdit 
document shown here, you could launch the Chess, DVD 

Player, and Mail programs—all 
right from within the file.

To make things even wilder, it’s 
possible to drag a TextEdit file 
containing embedded items 
into another TextEdit file, saving 
a file within a file within a file.

One important point: The 
double-clickable icons you 
create in TextEdit using this 
method are not aliases or links 

to your original documents and programs. They’re actual, 
full copies. If you embed a 10 MB program into a TextEdit 
document, you’ll end up with a 10 MB TextEdit file!

gem in the rough
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	 •	Don’t miss the HTML options in TextEdit→Preferences. On the “Open and Save” 
tab, you can specify what kind of HTML document you want to produce, what 
cascading style sheets (CSS) setting you want, and whether or not you want TextEdit 
to include code to preserve blank areas (white space) in your layout.

Tip: When you open a Web page document—that is, an HTML document—TextEdit is faced with a quandary. 
Should it open up the page as though it’s a Web page, interpreting the HTML code as though it’s a browser? 
Or should it reveal the underlying HTML code itself?

Actually, that’s up to you. When you choose File→Open, turn on “Ignore rich text commands” to make the 
document open up as HTML code. (To make this change permanent, check out the same checkbox on the 
“Open and Save” pane of the TextEdit→Preferences dialog box.)

The TextEdit Preferences
Most of the settings in the TextEdit Preferences→New Document pane have no effect 
on documents that are already open—only on documents you open or create from 
now on. Most of the settings are self-explanatory; nonetheless, handy explanatory 
balloons appear if you point to an option without clicking. Here are a few settings 
that may not be immediately clear:

	 •	Font. If Helvetica 12 doesn’t especially float your boat, you can change TextEdit’s 
starting font. Note that you can set two default fonts—one for Rich Text documents 
and another one for Plain Text files. 

Note: By definition, plain text files don’t have any formatting. So whatever font you choose here for Plain 
Text files is for your editing pleasure only. If you plan to send the file to anyone else, remember that the font 
choice won’t be saved with the document.

	 •	Window Size. These settings have no effect unless you’re in Wrap to Window mode 
(in which the text rewraps to fit the window width), as opposed to Wrap to Page 
mode. If you are in Wrap to Window mode, then these dimensions determine the 
size of the window that appears each time you create a new TextEdit document.

	 •	Properties. These boxes—Author, Company, and Copyright—are some of the 
tags that Spotlight inspects when it searches your Mac. If you’d like to be able to 
round up your documents by these characteristics, fill them in here to specify the 
information you want to use for most documents. (To fill them in differently for 
individual documents, choose File→Show Properties instead.)

TextEdit’s Other Writing Tools
TextEdit includes a few other very useful document-editing tools:

	 •	Allow Hyphenation. When you select this command from the Format menu, 
TextEdit breaks up words by syllable and inserts hyphens when necessary in order 
to create more visually pleasing line breaks. 

TextEdit
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Tip: It’s especially important to turn this feature on if your paragraph alignment is set to Justify, or if you 
create narrow columns of text. If hyphenation is turned off, TextEdit won’t break up whole words at the end 
of a line—even if it leaves big, ugly white gaps between words. 

	 •	Prevent Editing. When you turn this option on (again, in the Format menu), 
you’re locked out. You can select and copy text to your heart’s content, but you 
can’t change anything. Prevent Editing mode can be useful if you want to prevent 
yourself from making accidental changes to a file, but it’s not much of a security 
feature. (All anyone has to do is choose Format→Allow Editing to regain full edit-
ing privileges.)

	 •	Spell Checking. If the Edit→Spelling→Check Spelling As You Type command is 
turned on, you get interactive spell checking, just as in Microsoft Word and other 
word processors. That is, misspelled words get flagged with a dashed red line the 
moment you type them. 

To open the full Spelling panel at any time, choose Edit→Spelling→Spelling (or 
press Shift--:). Using the panel, you can correct errors (choosing from the sug-
gestions generated by Apple’s built-in spelling dictionary) or tell TextEdit to learn 
or ignore other suspected misspellings. 

The quickest way to handle spelling corrections is shown in Figure 10-37.

Tip: This feature isn’t really a TextEdit function—it’s a system-wide spell checker that you’ll also find in Stickies, 
Mail, iCal, iPhoto, and other programs. You learn it once, you’ve learned it forever.

	 •	AutoComplete. This feature is ideal for anyone who’s in a hurry, who’s unsure 
of a spelling, or who’s trying to solve a crossword puzzle. See Figure 10-38 for 
details, and note that AutoComplete is actually available in almost every Cocoa 
program.

Figure 10-37:
You’re never more than a Control-click away from more 
accurate spelling in TextEdit. Once you Control-click a ques-
tionable word, the suggestions of Apple’s built-in dictionary 
appear right in the shortcut pop-up menu, along with the 
Learn and Ignore commands.

TextEdit
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Utilities: Your Mac OS X Toolbox
The Utilities folder (inside your Applications folder) is home to another batch 
of freebies: another couple of dozen tools for monitoring, tuning, tweaking, and 
troubleshooting your Mac. 

The truth is that you’re likely to use only about six of these utilities. The rest are very 
specialized gizmos primarily of interest to network administrators or Unix geeks 
who are obsessed with knowing what kind of computer-code gibberish is going on 
behind the scenes. 

Tip: Even so, Apple obviously noticed that as the sophistication of Mac OS X fans grows, more people open 
the Utilities folder more often. That’s why Tiger features a menu command and a keystroke that can take 
you there. In the Finder, choose Go→Utilities (Shift--U).

Activity Monitor
Activity Monitor is designed to let the technologically savvy Mac fan see how much 
of the Mac’s available power is being tapped at any given moment. 

The Processes table
Even when you’re only running a program or two on your Mac, dozens of compu-
tational tasks (processes) are going on in the background. The top half of the dialog 

Figure 10-38:
Once you’ve begun typing a word, press either F5 or 
Option-Esc to produce the list of possible word comple-
tions shown here. If TextEdit correctly anticipates the 
rest of the word, great; press Tab, Return, or the Space 
bar to accept the suggestion, and then keep right on 
typing. If TextEdit guesses wrong, you can either select 
a different word in the list (using the mouse or the 
arrow keys), or tap Esc to ignore the suggestions and 
continue typing. 

Utilities: Your Mac 
OS X Toolbox
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box, which looks like a table, shows you all the different processes—visible and invis-
ible—that your Mac is handling at the moment. 

Check out how many items appear in the Process Listing Window, even when you’re 
just staring at the desktop. It’s awesome to see just how busy your Mac is! Some are 
easily recognizable programs (such as Finder), while others are background system-
level operations you don’t normally see. For each item, you can see the percentage of 
CPU being used, who’s using it (either your account name, someone else’s, or root, 
meaning the Mac itself), and how much memory it’s using. 

The System monitor tabs
At the bottom of Activity Monitor, you’re offered five tabs that reveal intimate details 
about your Mac and its behind-the-scenes efforts (Figure 10-39):

	 •	CPU. As you go about your usual Mac business, opening a few programs, dragging 
a playing QuickTime movie across the screen, playing a game, and so on, you can 
see the CPU graph rise and fall, depending on how busy you’re keeping the CPU. 
On multiple-processor Macs, you see a different bar for each chip, enabling you 
to see how efficiently Mac OS X is distributing the work among them.

Tip: You may also want to watch this graph right in your Dock (choose View→Dock Icon→Show CPU History) 
or in a bar at the edge of your screen (choose Window→Floating CPU Window→ Horizontally).

Finally, there’s View→”Show CPU monitors on top of other windows”—the one and only non-capitalized 
menu command in all of Mac OS X. It makes the little bar float on top of all your other programs, so you 
can’t miss it.

	 •	System Memory. Here’s a colorful graph that reveals the state of your Mac’s RAM 
at the moment. 

The number below the graph shows how much memory is installed in your Mac. If, 
when your Mac is running a typical complement of programs, the Wired number 
plus the Active number nearly equals your total RAM amount, it’s time to consider 
buying more memory. You’re suffocating your Mac.

	 •	Disk Activity. Even when you’re not opening or saving a file, your Mac’s hard 
drive is frequently hard at work, shuffling chunks of program code into and out 
of memory, for example. Here’s where the savvy technician can see exactly how 
frantic the disk is at the moment.

	 •	Disk Usage. This little graph offers one of the quickest ways to check out how full 
your hard drive is at the moment. (If you have more than one drive—say, a flash 
drive, tape-backup drive, or whatever—choose another drive’s name from the 
pop-up menu.)

	 •	Network. Keep an eye on how much data is shooting across your office network 
with this handy EKG-ish graph.

Utilities: Your  
Mac OS X Toolbox
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AirPort Admin Utility
You don’t use the AirPort Admin Utility to set up AirPort connections—that is, wireless 

Figure 10-39:
The many faces of 
Activity Monitor. 

Top: It can be a 
graph of your 
processor (CPU) ac-
tivity, your RAM us-
age at the moment, 
your disk capacity, 
and so on. 

Bottom: If you 
double-click a 
process’s name, 
you’re treated to 
a three-tab dialog 
box that offers stun-
ningly complete 
reams of data 
(mostly of interest 
only to program-
mers) about what 
that program is up 
to. (The Open Files 
and Ports tab, for 
example, shows 
you how many 
files that program 
has opened, often 
invisibly.) The most 
handy feature of 
this dialog box is 
the Quit button. It’s 
a convenient way to 
jettison a locked-up 
program when all 
else fails.
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networks like those described in Chapter 13—initially. For that task, use the AirPort 
Setup Assistant (described below). 

After you’re set up, you can use AirPort Admin Utility to monitor the connections in 
an existing AirPort network. You can also use this utility to set up new connections 
manually, rather than using the step-by-step approach offered by the Assistant.

AirPort Setup Assistant(s)
An Assistant, in Apple-ese, is an interview program. It presents a series of screens, 
posing one question at a time. At the end of the interview, the Assistant program in-
corporates your answers into a finished product. For example, it configures numerous 
System Preferences all at once.

The AirPort Setup Assistant walks you through setting up and using AirPort wireless 
networking. You’re asked to name your network, provide a password for accessing it, 
and so on. Once you’ve followed the steps and answered the questions, your AirPort 
hardware will be properly configured and ready to use.

Note: Weirdly enough, Tiger gives you two AirPort Setup Assistant programs. AirPort Setup Assistant sets up 
AirPort Express or AirPort Extreme base stations, while AirPort Setup Assistant for Graphite and Snow works 
with the old, non-Extreme base stations.

Audio MIDI Setup
Maybe you’ve heard that Mac OS X comes with spectacular internal wiring for music, 
sound, and MIDI (Musical Instrument Digital Interface, a standard “language” for 
inter-synthesizer communication). It’s available, that is, to music software companies 
that write their wares to capitalize on these new tools. (The big-name programs, 
including Digital Performer, are ready to go.)

This configuration program offers two tabs. The first, Audio Devices, is the master 
control panel for all your various sound inputs and outputs: microphones, line inputs, 
external speakers, and so on. For most people, this is meaningless, because most Macs 
have only one input (the microphone) and one output (the speakers). But if you’re 
sitting in your darkened music studio, humming with high-tech audio gear whose 
software has been designed to work with this little program, you’re smiling. 

The second tab, MIDI Devices, should look familiar to synthesizer fans who have used 
software like OMS or FreeMIDI to teach the Mac about their studio configurations. 
By clicking Add Device, you create a new icon that represents one of your pieces of 
gear. Double-click the icon to specify its make and model. Finally, by dragging lines 
from the “in” and “out” arrows, you teach your Mac and its MIDI software how the 
various components are wired together.

Bluetooth File Exchange
One of the luxuries of using a Mac that has Bluetooth is the ability to shoot files (to 
colleagues who own similarly clever gadgets) through the air, up to 30 feet away. 
Bluetooth File Exchange makes it possible, as described on page 223.

Utilities: Your  
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ColorSync Utility
If you use ColorSync (because you’re in the high-end color printing business, for 
instance), you might be surprised to find that the ColorSync pane is gone from the 
System Preferences program. Instead, that pane’s settings have been merged into this 
beefed-up program.

This bet-you’ll-never-touch-it utility combines two functions:

	 •	Its Profile First Aid tab performs a fairly esoteric task: repairing ColorSync pro-
files that may be “broken” because they don’t strictly conform to the ICC profile 
specifications. (ICC [International Color Consortium] profiles are part of Apple’s 
ColorSync color management system, as described on page 527.) If a profile for 
your specific monitor or printer doesn’t appear in the Profiles tab of this program 
when it should, Profile First Aid is the tool you need to fix it. 

	 •	The Profiles tab lets you review all the ColorSync profiles installed on your sys-
tem. The area on the right side of the window displays information about each 
ColorSync profile you select from the list on the left.

	 •	The other tabs are described on page 528.

Console
Console is a viewer for all of Mac OS X’s text logs—the behind-the-scenes, internal 
Unix status messages being passed between the Mac OS X and other applications.

Opening the Console log is a bit like stepping into an operating room during a 
complex surgery: You’re exposed to stuff the average person just isn’t supposed 
to see. (Typical Console entries: “kCGErrorCannotComplete” or “doGetDisplay 
TransferByTable.”) You can adjust the font and word wrapping using Console’s Font 
menu, but the truth is that the phrase “CGXGetWindowType: Invalid window –1” 
looks ugly in just about any font! 

Console isn’t useless, however. These messages can be of significant value to program-
mers who are debugging software or troubleshooting a messy problem, or, occasionally, 
to someone you’ve called for tech support. 

DigitalColor Meter
DigitalColor Meter can grab the exact color value of any pixel on your screen, which 
can be helpful when matching colors in Web page construction or other design work. 
After launching the DigitalColor Meter, just point anywhere on your screen. A mag-
nified view appears in the meter window, and the RGB (red-green-blue) color value 
of the pixels appears in the meter window. You can display the color values as RGB 
percentages or actual values, in Hex form (which is how colors are defined in HTML; 
white is represented as #FFFFFF, for example), and in several other formats.

Here are some tips for using the DigitalColor Meter to capture color information 
from your screen:

Utilities: Your  
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	 •	To home in on the exact pixel (and color) you want to measure, drag the Aperture 
Size slider to the smallest size—one pixel. Then use the arrow keys to move the 
aperture to the precise location you want.

	 •	Press Shift--C (Color→Copy Color as Text) to put on the Clipboard the numeric 
value of the color you’re pointing to.

	 •	Press Shift--H (Color→Hold Color) to “freeze” the color meter on the color 
you’re pointing to—a handy stunt when you’re comparing two colors onscreen. 
You can point to one color, hold it using Shift--H, and then move your mouse 
to the second color. Pressing Shift--H again releases the hold on the color.

	 •	When the Aperture Size slider is set to view more than one pixel, DigitalColor 
Meter measures the average value of the pixels being examined.

Directory Access
If you use your Mac at home, or if it’s not connected to a network, you’ll never have 
to touch Directory Access. Even if you are connected to a network, there’s only a 
remote chance you’ll ever have to open Directory Access—unless you happen to be 
a network administrator, that is. 

This utility controls the access that each individual Mac on a network has to Mac  
OS X’s directory services—special databases that store information about users and 
servers. Directory Access also governs access to LDAP directories (Internet- or intranet-
based “white pages” for Internet addresses).

A network administrator can use Directory Access to do things like select NetInfo 
domains, set up search policies, and define attribute mappings. If those terms don’t 
mean anything to you, just pretend you never read this paragraph and get on with 
your life. 

Disk Utility
This important program serves two key functions:

	 •	It serves as Mac OS X’s own little Norton Utilities: a powerful hard drive adminis-
tration tool that lets you repair, erase, format, and partition disks. In everyday life, 
you’ll probably use Disk Utility most often for its Repair Permissions feature, which 
solves an uncanny number of weird little Mac OS X glitches. But it’s also worth 
keeping in mind, in case you ever find yourself facing a serious disk problem.

	 •	Disk Utility also creates and manages disk images, electronic versions of disks or 
folders that you can exchange electronically with other people. 

The following discussion tackles the program’s two personalities one at a time.

Disk Utility, the hard drive–repair program
Here are some of the tasks you can perform with this half of Disk Utility:

	 •	Repair folders, files, and program that don’t work because you supposedly don’t 
have sufficient “access privileges.” This is by far the most common use of Disk 
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Utility, not to mention the most reliable and satisfying. Using the Repair Disk 
Permissions button fixes an astonishing range of bizarre Mac OS X problems, from 
programs that won’t open to menulets that freeze up the works. 

	 •	Get size and type information about any disks attached to your Mac.

	 •	Fix disks that won’t appear on your desktop or behave properly.

	 •	Completely erase disks—including rewritable CDs (CD-RW).

	 •	Partition a disk into multiple volumes (that is, subdivide a drive so that its segments 
appear on the desktop with separate disk icons).

	 •	Set up a RAID array (a cluster of separate disks that acts as a single volume).

Note: In Mac OS X 10.4.3 and later, Disk Utility can, for the first time in Mac history, check the startup disk 
for damage—the disk on which your system software is currently running. (You used to have to start up from 
a different disk first.) It can also fix the permissions of the disk it’s on, thank goodness.

Any other operation, like reformatting, erasing, partitioning, or actually repairing the disk, still requires the Mac 
to start up from a different disk (your Tiger DVD, for example). Otherwise, it’d be like a surgeon performing 
an appendectomy on himself—not a great idea.

The left Disk Utility panel lists your hard drive and any other disks in or attached to 
your Mac at the moment. When you click the name of your hard drive’s mechanism, 
like “74.5 GB Hitachi iC25N0…” (not the “Macintosh HD” partition label below it), 
you see a panel with five tabs, one for each of the main Disk Utility functions:

	 •	First Aid. This is the disk-repair part of Disk Utility, and it does a terrific job at fix-
ing many disk problems. When you’re troubleshooting, Disk Utility should always 
be your first resort. To use it, click the icon of a disk and then click either Verify 
Disk (to get a report on the disk’s health) or Repair Disk (which fixes whatever 
problems the program finds). In other words, First Aid attempts to perform the 
same healing effects on a sick hard drive as, say, a program like Norton Utilities. 

If Disk First Aid reports that it’s unable to fix the problem, then it’s time to invest 
in a program like DiskWarrior (www.alsoft.com).

Tip: If Disk Utility finds nothing wrong with a disk, it reports, “No repairs were necessary.” Don’t be alarmed 
at the not-so-congratulatory wording of that message—that’s the strongest vote of confidence Disk Utility can 
give. (Besides, it’s a lot better than the old wording, “The disk appears to be OK.”)

You may wind up using the Verify and Repair Disk Permissions buttons even more 
often. Their function is to straighten out problems with the invisible Unix file per-
missions that keep you from moving, changing, or deleting files or folders. (The 
occasional software installer can create problems like this.) You’d be surprised how 
often running one of these permission checks solves little Mac OS X glitches.

Chapter 12 has a much more detailed discussion of permissions.
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	 •	Erase. Select a disk, choose a format (always Mac OS Extended, unless you’re 
formatting a disk for use on an ancient Mac running Mac OS 8.1 or earlier), give 
it a name, and click Erase to wipe a disk clean. 

	 •	Partition. With the Partition tools, you can erase a hard drive in such a way that 
you subdivide its surface. Each chunk is represented on your screen by another 
hard drive icon (Figure 10-40).

There are some very good reasons not to partition a drive these days: A parti-
tioned hard drive is more difficult to resurrect after a serious crash, requires more 
navigation when you want to open a particular file, and offers no speed or safety 
benefits. 

Figure 10-40:
To partition your 
drive—which involves 
erasing it complete-
ly—launch Disk Utility, 
switch to the Partition 
pane, and select the 
hard drive you want to 
partition from the list 
on the left. From the 
Volume Scheme pop-
up menu, choose the 
number of partitions 
you want (or, for two 
equal chunks, click 
Split below the map). 
Now drag the horizon-
tal divider in the Vol-
umes map to specify 
the relative sizes of the 
partitions you want to 
create. Assign a name 
and format for each 
partition in the Volume 
Information area, and 
then click Partition.

Dude, Where’s My Erase Disk Command?
Erasing a disk on a Mac used to be easy. All you had to do 
was select the disk in the Finder and choose Special→Erase 
Disk. But in Mac OS X, there’s no Special menu, and the Erase 
Disk command is nowhere to be found.

That’s because the Disk Utility program now handles your 
disk-erasing needs. Launch it, click the Erase tab, and blow 
away the data on the disk of your choice, whether it’s a floppy, 
hard drive, rewriteable CD, or rewriteable DVD.

nostalgia corner
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On the other hand, there’s one very good reason to do it. On older Macs that can 
still restart in Mac OS 9, keeping Mac OS 9 and Mac OS X on different partitions 
can save you time when you switch between them, as described on page 213.

	 •	RAID. RAID stands for Redundant Array of Independent Disks, and refers to a 
special formatting scheme in which a group of separate disks are configured to 
work together as one very large, very fast drive. In a RAID array, multiple disks 
share the job of storing data—a setup that can improve speed and reliability. 

Most Mac users don’t use or set up RAID arrays, probably because most Mac  
users only have one hard drive (and Disk Utility can’t make your startup disk part 
of a RAID array). 

If you’re using multiple external hard disks, though, you can use Apple RAID to 
merge them into one giant disk. Just drag the icons of the relevant disks (or disk 
partitions) from the left-side list of disks into the main list (where it says, “Drag 
disks or volumes here to add to set”). Use the RAID Type pop-up menu to specify 
the RAID format you want to use (Stripe is a popular choice for maximizing disk 
speed), name your new mega-disk, and then click Create. The result is a single 
“disk” icon on your desktop that actually represents the combined capacity of all 
the RAID disks.

	 •	Restore. This tab lets you make a perfect copy of a disk or a disk image, much like 
the popular shareware programs CarbonCopy Cloner and SuperDuper. You might 
find this useful when, for example, you want to make an exact copy of your old 
Mac’s hard drive on your new one. You can’t do that just by copying your old files 
and folders manually. If you try, you won’t get the thousands of invisible files that 
make up a Mac OS X installation. If you use the Restore function, they’ll come 
along for the ride.

Start by dragging the disk or disk image you want to copy from into the Source box. 
Then drag the icon of the disk you want to copy to into the Destination box.

Tip: If you want to copy an online disk image onto one of your disks, you don’t have to download it first. 
Just type its Web address into the Source field. You might find this trick convenient if you keep disk images 
on your iDisk, for example.

If you turn on Erase Destination, Disk Utility obliterates all the data on your target 
disk before copying the data. If you leave this checkbox off, however, Disk Utility 
simply copies everything onto your destination, preserving all your old data in 
the process. (The Skip Checksum checkbox is available only if you choose to erase 
your destination disk. If you’re confident that all of the files on the source disk are 
100% healthy and whole, turn on this checkbox to save time. Otherwise, leave it 
off for extra safety.)

Finally, click the Restore button. (You might need to type in an administrator 
password.) Restoring can take a long time for big disks, so go ahead and make 
yourself a cup of coffee while you’re waiting.
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Tip: Instead of clicking a disk icon and then clicking the appropriate Disk Utility tab, you can just Control-click 
a disk’s name and choose Information, First Aid, Erase, Partition, RAID, or Restore from the shortcut menu.

Disk Utility, the disk-image program
The world’s largest fan of disk images is Apple itself; the company often releases new 
software in disk-image form. A lot of Mac OS X add-on software arrives from your 
Web download in disk-image form, too, as shown below. 

Disk images are popular for software distribution for a simple reason: Each image file 
precisely duplicates the original master disk, complete with all the necessary files in 
all the right places. When a software company sends you a disk image, it ensures that 
you’ll install the software from a disk that exactly matches the master disk.

It’s important to understand the difference between a disk-image file and the mounted 
disk (the one that appears when you double-click the disk image). Figure 10-41 makes 
the distinction clear. 

Tip: After you double-click a disk image, click Skip in the verification box that appears. If something truly got 
scrambled during the download, you’ll know about it right away—your file won’t decompress correctly, or 
it’ll display the wrong icon, for example. 

In fact, you can make Disk Utility always skip that verification business, which is a relic from the days of floppy 
disks. To do so, choose Disk Utility→Preferences, click the Mounting tab, and turn off Verify Checksums.

You can create disk images, too. Doing so can be very handy in situations like the 
following:

Figure 10-41:
The usual life cycle of a disk-image file: First, 
you download it from the Internet. The result 
is an icon whose name usually ends in .img 
or .dmg (upper left). (Files that end with .smi 
are also disk images, but self-mounting ones 
that don’t require Disk Utility.) Second, when 
you double-click this icon, an invisible program 
called DiskImageMounter creates an icon that 
simulates a new disk (upper right). Finally, when 
you double-click this icon, you see exactly what 
the original creator of the image wanted you to 
see (bottom).
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	 •	You want to create a backup of an important CD. By turning it into a disk-image 
file on your hard drive, you’ll always have a safety copy, ready to burn back onto a 
new CD. (This is an essential practice for educational CDs that kids will be handling 
soon after eating peanut butter and jelly.) 

	 •	You want to replicate your entire hard drive—complete with all of its files, pro-
grams, folder setups, and so on—onto a new, bigger hard drive (or a new, better 
Mac), using the new Restore feature described earlier.

	 •	You want to back up your entire hard drive, or maybe just a certain chunk of it, 
onto an iPod or another disk. (Again, you can later use the Restore function to 
complete the transaction.) 

	 •	You bought a game that requires its CD to be in the drive at all times. Many pro-
grams like these run equally well off of a mounted disk image that you made from 
the original CD.

	 •	You want to send somebody else a copy of a disk via the Internet. You simply create 
a disk image, and then send that—preferably in compressed form.

Here’s how you make a disk image.

	 •	To image-ize a disk or partition. Click the name of the disk you want in the left-
panel list, where you see the disks currently in, or attached to, your Mac. (The 
topmost item is the name of your drive, like “484.0 MB MATSHITADVD-R” for a 
DVD drive or “74.5 GB Hitachi” for a hard drive. Beneath that entry, you generally 
see the name of the actual partition, like “Macintosh HD,” or the CD’s name as it 
appears on the screen.) 

Then choose File→New→Disk Image from [whatever the disk or partition’s name 
is].

	 •	To image-ize a folder. Choose File→New→Disk Image from Folder. In the Open 
dialog box, click the folder you want and then click Image.

Tip: Disk Utility can’t turn an individual file into a disk image. But you can put a single file into a folder, and 
then make a disk image of it.

Either way, the next dialog box (Figure 10-42) offers some fascinating options.

	 •	Image Format. If you choose “read/write,” your disk image file, when double-
clicked, turns into a superb imitation of a hard drive. You can drag files and folders 
onto it, drag them off of it, change icons’ names on it, and so on.

If you choose “read-only,” however, the result behaves more like a CD. You can 
copy things off of it, but not make any changes to it.

The “compressed” option is best if you intend to send the resulting file by email, 
or if you’d like to preserve the disk image on some backup disk for a rainy day. It 
takes a little longer to create a simulated disk when you double-click the disk image 
file, but it takes up a lot less disk space than an uncompressed version.
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Finally, choose “DVD/CD master” if you’re copying a CD or a DVD. The resulting 
file is a perfect mirror of the original disc, ready for copying onto a blank CD or 
DVD when the time comes. 

	 •	Encryption. Here’s an easy way to lock private files away into a vault that nobody 
else can open. If you choose “AES-128 (recommended),” you’re asked to assign a 
password to your new image file. Nobody can open it without the password—not 
even you. On the other hand, if you save it into your Keychain (page 471), it’s not 
such a disaster if you forget the password. 

	 •	Save As. Choose a name and location for your new image file. The name you choose 
here doesn’t need to match the original disk or folder name.

When you click Save (or press Enter), if you opted to create an encrypted image, 
you’re asked to make up a password at this point.

Otherwise, Disk Utility now creates the image and then mounts it—that is, turns the 
image file into a simulated, yet fully functional, disk icon on your desktop. 

When you’re finished working with the disk, eject it as you would any disk (Control-
click it and choose Eject, for example). Hang onto the .dmg disk image file itself, 
however. This is the file you’ll need to double-click if you ever want to recreate your 
“simulated disk.” 

Turning an image into a CD
One of the other most common disk-image tasks is turning a disk image back into a 
CD or DVD—provided you have a CD or DVD burner on your Mac, of course.

All you have to do is drag the .dmg file into the Disk Utility window, select it, and click 
the Burn icon on the toolbar (or, alternatively, Control-click the .dmg icon and choose 
Burn from the shortcut menu). Insert a blank CD or DVD, and then click Burn.

Figure 10-42:
These two pop-up menus let you specify 
(a) what kind of disk image you want, 
and (b) whether or not you want it pass-
word-protected. The latter option is great 
when you want to password-protect one 
folder, without bothering with your entire 
Home folder.
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Grab
Grab takes pictures of your Mac’s screen, for use when you’re writing up instructions, 
illustrating a computer book, or collecting proof of some secret screen you found 
buried in a game. You can take pictures of the entire screen (press -Z, which for 
once in its life does not mean Undo) or capture only the contents of a rectangular 
selection (press Shift--A). When you’re finished, Grab displays your snapshot in a 
new window, which you can print, close without saving, or save as a TIFF file, ready 
for emailing or inserting into a manuscript.

Now, as experienced Mac enthusiasts already know, the Mac OS has long had its own 
built-in shortcuts for capturing screenshots: Press Shift--3 to take a picture of the 
whole screen, and Shift--4 to capture a rectangular selection. 

So why use Grab instead? In many cases, you shouldn’t. The Shift--3 and Shift--4 
shortcuts work like a dream. But there are some cases in which it might make more 
sense to opt for Grab. Here are three:

	 •	Grab can make a timed screen capture (choose Capture→Timed Screen, or press 
Shift--Z), which lets you enjoy a 10-second delay before the screenshot is actually 
taken. After you click the Start Timer button, you have an opportunity to activate 
windows, pull down menus, drag items around, and otherwise set up the shot 
before Grab shoots the picture.

	 •	When you capture a screenshot using Grab’s Selection command, the size of your 
selection is displayed, in pixels, right under the pointer as you drag. If you need 
to capture a 256-pixel-wide square, for example, you can do so with pinpoint ac-
curacy. (Choose Edit→Inspector to read the dimensions of a screenshot after you 
capture it.)

	 •	With Grab, you have the option of including the cursor in the picture, which is 
extremely useful when you’re showing a menu being pulled down or a button be-
ing clicked. (Mac OS X’s screenshot keystrokes, by contrast, always eliminate the 
pointer.) Use the technique described in Figure 10-43 to add the pointer style of 
your choice to a Grab screenshot.

Figure 10-43:
Unlike the Shift--3 or Shift--4 keystrokes, Grab lets you include the 
pointer/cursor in the picture—or hide it. Choose Grab→Preferences and pick 
one of the eight different pointer styles, or choose to keep the pointer hidden 
by activating the blank button in the upper-left corner.
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Tip: Actually, if you’re going to write a book or manual about Mac OS X, the program you really need is 
Snapz Pro X (available for download from www.missingmanuals.com, among other places). It offers far 
more flexibility than any of Mac OS X’s own screenshot features. For example, you have a choice of file 
format, you can neatly snip out just one dialog box or window with a single click, and you can even capture 
movies of screen activity.

Grapher
Yes, kids, it’s the next episode of Apple’s on-again, off-again love affair with the graph-
ing calculator! Now you, too, can create 2-D or 3-D graphs of staggering beauty and 
complexity.

But seriously, folks. This equation grapher is an amazing piece of work.

When you first open Grapher, you’re asked to choose what kind of virtual “graph pa-
per” you want: two-dimensional (standard, polar, logarithmic) or three-dimensional 
(cubic, spherical, cylindrical). Click a name to see a preview; when you’re happy with 
the selection, click Open.

Now the main Grapher window appears (Figure 10-44). Do yourself a favor. Spend 
a few wow-inducing minutes choosing canned equations from the Examples menu, 
and watching how Grapher whips up gorgeous, colorful, sometimes animated graphs 
on the fly.

Figure 10-44:
In general, you type equa-
tions into Grapher just as you 
would on paper (like z=2xy). 
If in doubt, check the online 
help, which offers enough 
hints on functions, constants, 
differential equations, series, 
and periodic equations to 
keep the A Beautiful Mind 
guy busy  
for days. 
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When you’re ready to plug in an equation of your own, type it into the text box at 
the top of the window. If you’re not such a math hotshot, or you’re not sure of the 
equation format, work from the canned equations and mathematical building blocks 
that appear when you choose Equation→New Equation from Template or Window→
Show Equation Palette (a floating window containing a huge selection of math sym-
bols and constants). 

Tip: If you don’t know the keystroke that produces a mathematical symbol like pi or theta, you can just type 
the word pi or theta. Grapher replaces it with the correct symbol automatically.

Once the graph is up on the screen, you can tailor it like this:

	 •	To move a 2-D graph in the window, choose View→Move Tool and then drag; to 
move a 3-D graph, -drag it. 

	 •	To rotate a 3-D graph, drag in any direction. If you add the Option key, you flip 
the graph around only one axis.

	 •	To change the colors, line thicknesses, 3-D “walls,” and other graphic elements, 
click the  button (or choose Window→Show Inspector) to open the formatting 
palette. The controls you find here vary by graph type, but rest assured that Grapher 
can accommodate your every visual whim.

	 •	To change the fonts and sizes, choose Grapher→Preferences. On the Equations 
panel, the four sliders let you specify the relative sizes of the text elements. If you 
click the sample equation, the Font panel appears (page 525), so you can fiddle 
with the type.

	 •	Add your own captions, arrows, ovals, or rectangles using the Object menu.

When it’s all over, you can preserve your masterpiece using any of these techniques:

	 •	Export a graphic by choosing File→Export.

For Mathematicians (and Physicists, Scientists, and Students) Only
If you’re into math, science, or studying math or science, 
Grapher is a tremendous addition to Mac OS X. There’s a 
whole lot to it—but if you’re just getting started, here are a 
few features not to miss:

•	 You can calculate values, intercepts, derivatives, and 
integrals (even indefinite integrals) by using the 
Equation→Evaluation and Equation→Integration 
commands.

•	 Some useful ready-made equation components 
await in the pop-up button at the right side of the 
equation text box. Using the Sum and Product 
symbols, for example, you can quickly calculate 
summations and products.

•	 That same pop-up menu can help you generate 
piecewise, parametric, and other specialized kinds 
of graphs (this means you, math students).

power users' clinic
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	 •	Copy an equation to the Clipboard by Control-clicking it and choosing Copy As→
TIFF (or EPS, or whatever) from the shortcut menu. Now you can paste it into 
another program.

	 •	Export an animation by choosing Equation→Create Animation. The resulting 
dialog box lets you specify how long you want the movie to last (and a lot of other 
parameters). 

Tip: If you Shift-drag the starting or ending images at the bottom, you can change their size. 

Finally, click Create Animation. After a moment, the finished movie appears. If 
you like it the way it is, choose File→Save As to preserve it on your hard drive for 
future generations.

Installer
You’ll never launch this. It’s the engine that drives the Mac OS X installer program 
and other software installers. There’s nothing for you to configure or set up.

Java 
Programmers generally use the Java programming language to create small programs 
that they then embed into Web pages—animated effects, clocks, calculators, stock 
tickers, and so on. Your browser automatically downloads and runs such applets (as-
suming that you have “Enable Java” turned on in your browser).

Your Java folder contains several Java-related tools, which exist primarily for the 
benefit of Web programmers and Web programs (including Safari).

Keychain Access
Keychain Access manages all your secret information—passwords for network access, 
file servers, FTP sites, Web pages, and other secure items. For instructions on using 
Keychain Access, see Chapter 12.

Migration Assistant
This little cutie, new in Tiger, automates the transfer of all your stuff from one Mac 
to another—your Home folder, network settings, programs, and more. This comes 
in extremely handy when you buy a newer, better Mac. Migration Assistant assumes 

Key Caps: Missing In Action?
Hey, where’s Key Caps!? I used to use this program all the 
time to figure out how to type special symbols (like ¢) with 
hidden key combinations (like Option-4). Now it’s not even 
there any more!

Well, that’s not quite true. It’s now called Keyboard Viewer. 
You get to it via System Preferences→International→Input 
Menu.

Page 291 tells all.

frequently asked question
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that you’ve connected them using a FireWire cable, because it relies on Target Disk 
Mode (page 221) to get the copying done quickly. (It can also copy everything over 
from a secondary hard drive or partition.)

The instructions on the screen guide you through the setup process; then the Assistant 
automates the transfer. 

NetInfo Manager
NetInfo is the central Mac OS X database that keeps track of user and group accounts, 
passwords, access privileges, email configurations, printers, computers, and just about 
anything else network related. NetInfo Manager is where a network administrator (or 
a technically inclined Mac guru) goes to view and edit these various settings. 

You can find more information about NetInfo in these places:

	 •	The tutorials in the relevant sections of this book, such as on pages 444 and 460.

	 •	Article #106416 (“NetInfo: What is it? How to Set Up NetInfo”) at http://kbase.
info.apple.com, and the associated downloadable PDF manual.

Network Utility
The Network Utility gathers information about Web sites and network citizens. It 
offers a suite of standard Internet tools like NetStat, Ping, Traceroute, Finger, and 
Whois—advanced tools, to be sure, but ones that even Mac novices may be asked to 
fire up when calling a technician for Internet help.

Otherwise, you probably won’t need to use Network Utility to get your work done. 
However, Network Utility can be useful when you’re performing Internet detective 
work.

	 •	Whois (“who is”) can gather an amazing amount of information about the owners 
of any particular domain (such as www.apple.com)—including name and address 
info, telephone numbers, and administrative contacts. It uses the technique shown 
in Figure 10-45.

Sleuthing Around with NetInfo Manager
While most of NetInfo Manager is of little use to a typical 
Mac fan, a few parts of this utility can be valuable even to a 
non–system administrator.

To dive into NetInfo Manager, start by clicking the padlock 
button at the bottom of the main window and enter an ad-
ministrator’s password. Then examine the various parameters 
in the top-left Directory Browser list. As you’ll quickly discover, 
most of these settings are written in Unix techno-speak. 

A few, however, are easy enough to figure out. If you click 
users in the middle list, you’ll see, in the next column, a list 
of accounts you’ve created. Click one of the account names 
there, and you’ll see, in the properties pane at the bottom of 
the screen, some parameters that may come in handy—such 
as each person’s name, password, and password hint. 

By double-clicking one of these info items, you can edit it, 
which may sometimes be more convenient than changing or 
looking up passwords in System Preferences.

up to speed

Utilities: Your  
Mac OS X Toolbox

MacOSX4e_Ch10_RB.indd   395 10/9/2006   1:54:25 PM



396	 mac os x: the missing manual

	 •	Use Ping to enter a Web address (such as www.google.com), and then “ping” (send 
out a “sonar” signal to) the server to see how long it takes for it to respond to your 
request. Network Utility reports the response time in milliseconds—a useful test 
when you’re trying to see if a remote server (a Web site, for example) is up and 
running. (The time it takes for the ping to report back to you also tells you how 
busy that server is.)

	 •	Traceroute lets you track how many “hops” are required for your Mac to com-
municate with a certain Web server. Just type in the network address or URL, and 
then click Trace. You’ll see that your request actually jumps from one trunk of the 
Internet to another, from router to router, as it makes its way to its destination. 
You’ll learn that a message sometimes crisscrosses the entire country before it ar-
rives at its destination. You can also see how long each leg of the journey took, in 
milliseconds.

ODBC Administrator
This program is designed to arbitrate ODBC access requests. Any questions?

If you have no idea what that means, and no corporate system administrator has sat 
down to explain it to you, then your daily work probably doesn’t involve working 
with corporate ODBC (Open Database Connectivity) databases. You can ignore this 
program or throw it away.

Printer Setup Utility
This is the hub of your Mac’s printing operations. You can use the Printer Setup Utility 
(formerly called Print Center) to set up and configure new printers, and to check on 
the status of print jobs, as described in Chapter 14.

Figure 10-45:
The Whois tool is a 
powerful part of Network 
Utility. First enter a 
domain that you want 
information about, then 
choose a Whois server 
from the pop-up menu 
(you might try whois.
networksolutions.com). 
When you click the 
Whois button, you get 
a surprisingly revealing 
report about the owner 
of the domain, including 
phone numbers, fax 
numbers, contact names, 
and so on.
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System Profiler
System Profiler (once called Apple System Profiler) is a great tool for learning exactly 
what’s installed on your Mac and what’s not—in terms of both hardware and software. 
The people who answer the phones on Apple’s tech-support line are particularly fond 
of System Profiler, since the detailed information it reports can be very useful for 
troubleshooting nasty problems.

Tip: Instead of burrowing into your Applications→Utilities folder to open System Profiler, it’s sometimes 
faster to use this trick: Choose a→About This Mac. In the resulting dialog box, click the More Info button. 
Boom—System Profiler opens. (And if you click your Mac OS X version number twice in the About box, you 
get to see your Mac’s serial number!)

When you launch System Profiler, it reports information about your Mac in a list 
down the left side (Figure 10-46). 

They fall into these categories:

	 •	Hardware. Click this word to see precisely which model Mac you have, what kind of 
chip is inside (and how many), how much memory it has, and its serial number.

If you expand the flippy triangle, you get to see details about which Memory slots 
are filled and the size of the memory module in each slot; what kind of Disc Burn-
ing your Mac can do (DVD-R, DVD+R, and so on); what PCI Cards are installed 

Utilities: Your  
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Figure 10-46:
Does your PowerBook’s 
chip run at 800 MHz or 
1.25 GHz? What percent-
age of your external 
hard drive is filled up? 
Want a comprehensive 
list of every program 
installed on your Mac, 
with version numbers? 
And (shown here): Does 
your laptop have any 
open slots for extra 
RAM?
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in your expansion slots; what Graphics/Displays circuitry you have (graphics card 
and monitor); what’s attached to your ATA bus (internal drives, like your DVD 
drive and hard drive); what’s connected to your SCSI, USB, and FireWire chains, 
if anything; and much more.

	 •	Network. This section reveals details on your AirPort Card (if you have one), what 
Modems you have, what Internet connection Locations you’ve established (page 	
645), and so on.

	 •	Software. Click this heading to see exactly which version of Mac OS X you have, 
and what your computer’s name is, as far as the network is concerned (“Chris’s 
Computer,” for example).

The Applications list documents every program on your system, with version 
information—a quick inventory of what you’ve installed on your Mac. It’s useful 
for spotting duplicate copies of programs.

Utilities: Your  
Mac OS X Toolbox

The Xcode Tools
The Tiger DVD includes a special batch of programs, known 
as the XCode Tools, just for developers (programmers) who 
write Mac OS X software. You’ll need some of these programs 
if you want to get into some of the more esoteric (or, as some 
would say, fun) Mac OS X tricks and tips.

To install these tools, open Xcode Tools→XcodeTools.mpkg 
in the DVD window. After following 
the onscreen prompts, you wind up 
with a new folder called Developer 
on your hard drive. Its Applications→
Utilities folder contains a few programs 
that are user-friendly enough even for 
nonprogrammers.

CrashReporterPrefs, for example, 
lets you tell Mac OS X when to display 
the “Application Unexpectedly Quit” 
dialog box. If you choose Server, you’ll never see one of those 
annoying dialog boxes again—perfect if you have a program 
that just won’t stop crashing.

Also, if you open Developer→Applications→Graphics Tools, 
you’ll find Quartz Composer. This program, new in Tiger, 
lets you build screen savers, animations, and tons of other 

graphical goodies without writing a single line of code. (Use 
File→New from Template to get started with some pre- 
assembled possibilities.)

Finally, don’t miss Core Image Fun House (also in Devel-
oper→ Applications→Graphics Tools). It’s intended to be a 
showcase for Tiger’s new Core Image technologies, which 

is a ready-to-use photo-transforma-
tion toolkit that software companies 
can build into their programs. It lets 
you apply dozens of mind-blowing 
visual effects to your images and mov-
ies—distortions, color corrections, solar 
flares, and so on—with nothing more 
than a few clicks. (If your Mac is fast 
enough, you can even adjust filters in 
real time, so you can see the result of 
your modifications as you make them.) 

One possibility is shown here.

When you’re done psychedelicizing your image, you can 
export it to a standard JPEG or TIFF image by choosing File→

Save As. From there, you can show it off on a Web site, email 
it to your friends, or make it your desktop background.
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Tip: The right-hand column of the Applications list identifies each program as being either Universal or 
PowerPC. (A Universal program can run natively—at full speed—on either Intel-based Macs or earlier models; 
a PowerPC program runs natively on older Macs, but somewhat slower on Intel Macs because it has to go 
through the Rosetta translator described on page 11). This list is a handy summary of which programs have 
been updated for the Intel generation.

Similar information shows up in the Extensions panel. In this sense, “extensions” 
doesn’t mean system extensions like those that made life a living hell in Mac  
OS 9 and earlier. In Mac OS X, the term extensions refers to a different kind of 
add-on component to the core system software. Generally, these are drivers for the 
Mac’s various components, which sit in the System→Library→Extensions folder. 
Whatever’s in that folder is what you see listed in this panel. 

Other categories include self-explanatory lists like Fonts, Preference Panes, and 
Startup Items. 

Finally, the Logs panel reveals your Mac’s secret diary: a record of the traumatic 
events that it experiences from day to day. (Many of these are the same as those 
revealed by the Console utility; see page 383.) Some reveal crash logs, which are 
detailed technical descriptions of what went wrong when various programs crashed, 
and what was stored in memory at the time.

Unfortunately, there’s not much plain English here to help you understand the 
crash, or how to avoid it in the future. Most of it runs along the lines of “Exception: 
EXC_BAD_ACCESS (0x0001); Codes: KERN_INVALID_ADDRESS (0x0001) at 
0x2f6b657d.” In other words, it’s primarily for the benefit of programmers. Still, tech-
support staff may occasionally ask to see the information in one of these logs. 

Tip: If any of these screens is showing you more or less technical information than you’d like, use the View 
menu to choose Mini Profile, Basic Profile, or Full Profile.

Saving a report
To create a handsomely formatted report that you can print or save, choose File→
Save, and then choose Rich Text Format from the File Format pop-up menu. Note, 
however, that the resulting report can be well over 100 pages long. In many cases, 
you’re better off simply making a screen shot of the relevant Profiler screen, as de-
scribed on page 531.

Terminal
Terminal opens a terminal window with a command line interface, taking you deep 
into the world of Unix, the operating system on which Mac OS X is based. Chapters 
16 and 17 offer a crash course on this powerful window into the Mac’s shadow op-
erating system.

VoiceOver Utility
For details on this new screen-reader software, see page 560.

Utilities: Your  
Mac OS X Toolbox
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