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Tutorial 1: Creating a Photorealistic Image

      
Overview
This tutorial introduces you to the basic functions of ElectricImage 
while guiding you through the steps to create the photorealistic 
image shown below (except that your image will be in color!).

By working with this tutorial, you will learn:

• How to create a new ElectricImage project, including how to add 
models to the project, position the Camera and the models in a 
scene, and render an image.

• How to apply surface attributes such as color, reflectivity and 
transparency to models.

• How to apply textures and reflections to models.

• How to use lighting to achieve a photorealistic effect.
1-2 ElectricImage™ Animation System



 

Overview

             
What You Will Need

To complete this tutorial, make sure that all of the ElectricImage 
application files and folders (including the Tutorials folders) have 
been installed on your hard disk in the same folder.

The models and textures you will need are located in two folders 
within the Tutorial 1 folder:

• The Models folder, which should contain the following files:

— Sphere

— Cone

— Room Model

— Lamp Model

• The Textures folder, which should contain the following files:

— Plaster SM 

— Sandstone SM

— Weird Hi-Con

For processing, you will need at least 32 MB of RAM allocated to the 
Camera application, either physical or virtual (though processing will 
be extremely slow using virtual RAM).

w
Please note: It is very important that you pay close attention to detail 
during the course of this tutorial. Successful completion of this project 
depends on text entry of many precise values, and it only takes one 
misplaced decimal point to produce unwanted results. Should you find, 
at any time, that your results do not match those shown in the tutorial, 
it may be due to an incorrect or missing value, and you should go back 
over the steps to locate the error.

Also: This is a lengthy tutorial, and it has been split into sections so 
that you can take breaks between them. Remember, you don’t have to 
complete the entire tutorial in one sitting. At any time you can save 

w
your project file and quit ElectricImage to return at another time.
The ElectricImage™ Tutorial 1-3



 

Tutorial 1: Creating a Photorealistic Image

                                   
Creating a Project File
The first step in creating an image (or animation) is to create a new 
project file.

1. Open the ElectricImage folder and double-click on the 
ElectricImage™ icon to launch the ElectricImage application.

Information about ElectricImage will appear, with a request that you 
click to continue.

2. Click the mouse to continue.

3. Select New… from the File menu (keyboard equivalent is -N).

A directory dialog box opens, 
requesting that you name and 
save the new project file.

4. Type “Tutorial 1 ” in front of 
the word “Project” and either 
click Save or press return.

Another directory dialog box 
opens, this one prompting you 
to add a model to the project.

5. Locate and open the 
Tutorial 1 folder, then the 
Models folder, and add the 
model named “Sphere.”

The model is added to the project 
and the dialog box reopens.

6. Add the model named “Cone.”

The model is added to the project and the dialog box reopens.
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Creating a Project File

         
7. These are the only models we need right now, so click Done.

The ElectricImage workspace opens, with the three World View 
windows (top, front and side views) and the Camera View window 
arranged on your monitor as shown below.

When a project is created, it contains a Camera and one radial light 
(plus any models that you’ve added). In the illustration above, we’ve 
indicated for you the appearance of the icons that represent the 
models, the Camera, and the light.

Light’s icon

Model’s icon

Camera’s icon

Cone model

Sphere model
The ElectricImage™ Tutorial 1-5



 

Tutorial 1: Creating a Photorealistic Image

                  
Getting Acquainted With the Workspace
At this point, take some time to get a feel for moving things around 
in the World View windows (Top, Front and Side). You can look at 
the Camera View window to see what the Camera sees.

8. First, drag each of the models around and watch how the 
Camera View window changes as you re-position the models.

9. Now move the Camera. First, drag the Camera body (the 
rectangle) only. Notice the effect of moving the Camera body 
without moving its reference point (the point at which the 
Camera is aimed).

Next, drag the reference 
point (the arrowhead) only, 
and watch the effect.

Finally, drag the view vector 
(the line), and watch the 
effect of moving both the 
Camera body and reference 
point simultaneously.

10. Now drag the light icon to re-position the light.

If it falls within the view of the Camera, you will see it in the Camera 
View window (though it will not be rendered as a visible object).

11. To preview the effect of the light on the models, click the 
shading button (the middle of three buttons) in the lower left 
corner of the Camera View window.

The models are shaded temporarily (until you change the scene).

w
This type of shading can be set as a permanent preference through 

w
the use of the Drawing… command in the Edit menu.

Reference Point

View Vector

Camera body
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Getting Acquainted With the Workspace

                                    
Now that you’ve had a chance to acquaint yourself with the 
workspace, we can clear the project of the Sphere and Cone models 
(we won’t be using them for our final image).

Please continue on to the next part of the tutorial.

12. Now change the area displayed in the World View windows:

• Use the zoom icons in the lower right corner of each 
window to zoom in and out on your view of the models, 
Camera and light.

• Hold down the option key and drag a rectangle into which 
the view will zoom when you let go of the mouse.

• Hold down the option key while clicking either of the zoom 
icons in the lower right corner of the window; this action 
centers the objects in the window.

w
Throughout the tutorials in this book, when we say to “center the 
window,” we are referring to this action—holding down the option 

w
key and clicking one of the window’s zoom icons.

13. Choose Sphere from the Model List menu, as shown at left.

14. Choose Clear from the Edit menu (or press delete).

The Sphere model is removed from the project.

15. Choose Cone from the Model List menu.

16. Choose Clear from the Edit menu (or press delete).

The Cone model is removed from the project.
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Tutorial 1: Creating a Photorealistic Image

           
Building the Scene
Now we can set the scene for the final image we want to create 
(page 1-2). There are two models in your Tutorial 1 Models folder, 
one for the lamp and one combining all of the room elements.

Adding Models to the Project

ElectricImage offers two ways to add models to a project once you’ve 
created the project file. We’ll use both methods, one for each model.

Using the File Menu First we’ll use the File menu to add the room model.

17. Choose Add, then Model… from the hierarchical File menu, as 
shown at left.

The directory dialog box used to add models to the project opens.

18. Find and select the model named “Room Model.”

A dialog box opens, informing you that the model is comprised of 
groups that are not hierarchically structured.

19. We want the WALLS group to be the parent group (to which all 
other groups in the model are linked), and since WALLS is 
already selected (in the Parent Group pop-up menu) either click 
Select or press return.

The model is added to the project and the directory dialog box reopens.

20. Although we still have one more model to add, click Done.
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Building the Scene
Using the Object Palette The other way to add a model is by using the Object Palette, which is 
a graphical interface for adding objects to the project. Let’s use it to 
add the lamp model.

21. Choose Object Palette from the Windows menu ( -E).

The Object Palette opens.

22. Click on the first button in the palette, as shown at left (the 
button’s icon represents a model in ElectricImage FACT format).

The directory dialog box used to add models to the project opens.

23. Find and select the model named “Lamp Model.”

Again, you are asked what to do about the hierarchical structure.

24. We want the GLASSBASE group to be the parent, and since it is 
already selected, either click Select or press return.

25. We now have all the models we need, so click Done.

As for the Object Palette, you can either drag it somewhere out 
of the way, or close it (we won’t need it again for this tutorial).
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Tutorial 1: Creating a Photorealistic Image
Opening the Project Window

Now let’s open the Project window, where we can work with a listing 
of all of the project’s elements.

26. Choose Project Window from the Windows menu ( -L).

The Project window opens, as 
shown at left.

27. Use the resizing icon in the window’s lower right corner to resize 
the Project window as it is shown at left, then drag it where you 
want it (so that it does not block the Camera View window).

w
While the Project window provides a complete overview of all 
project data (and is used extensively in animations), we’ll only be 
using it in this tutorial to select objects for modification and 

w
manipulation (other tutorials will show you more of its uses).

Note that there are 13 objects listed in the Project window for 
this project: Camera 1 (the Camera), Light 1 (the default light 
source), and the groups that comprise the Room Model and 
Lamp Model.

Also note how the groups are hierarchically displayed according 
to the hierarchical structure of the models. The “children” in 
each model are shown indented beneath their respective 
“parents.” As children, they will inherit certain characteristics 
from their parents (such as position and rotation).
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Building the Scene
Positioning the Camera

Now it’s time to position the Camera. As you’ve seen, the Camera 
and its reference point can be moved by dragging them in the World 
View windows. For more precise placement, however, exact 
coordinates can be entered. We’ll use the Camera Info window to 
enter the coordinates.

28. In the Project window, double-click on the Camera’s icon, as 
shown at left—or single-click it to select the Camera and then 
choose Camera Info from the File menu ( -I).

The Camera Info window opens.

29. Position the Camera by typing the coordinate values shown at 
left in the X, Y and Z Camera and Reference edit boxes.

w
If you want to experiment with Camera roll, click and drag in the 
circle with the artificial horizon and watch the effect in the 
Camera View window. Just make sure you return the Roll value to 

w
0.0 and that all of the values appear as shown at left.

30. Close the Camera Info window ( -W).
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Tutorial 1: Creating a Photorealistic Image
Positioning the Light

Now that we have our models in place and the Camera’s coordinates 
have been set, let’s place our default light source inside the Room 
Model so that we can see what’s in there when we render the image.

31. In the Project window, double-click on the light’s icon, as shown 
at left—or single-click it to select the light and then choose 
Light Info from the File menu ( -I).

The Light Info window opens.

32. Position the light by typing the coordinate values shown at left 
in the X, Y and Z Position edit boxes.

w
We are not considering the light’s reference point at this time 
because the light is of the radial type—that is, it gives off light in 
all directions, and so we don’t need to aim it. (When we’re dealing 

w
with shadows, we will need to aim the light—but that’s for later.)

33. Close the Light Info window ( -W).
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Building the Scene
Rendering the Image

Now that the scene is set, let’s save the project and render it.

34. Choose Save from the File menu ( -S).

w

w
As with any application, it is wise to save your work frequently.

35. Choose Render… from the File menu ( -R).

The Render Control window opens.

w
The Render Control window has extensive controls for image 
quality, for enabling special effects, for adding backgrounds, for 
selecting which frames of an animation to render, and for 
launching the ElectricImage Camera to render the project. For this 
tutorial, we need not be concerned about all of these 
controls—they are not, for the most part, applicable, and the 

w
default settings will produce very pleasing results.
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Tutorial 1: Creating a Photorealistic Image
w
While your project is being rendered, you can watch the progress of the 
rendering; or, you can take a break and leave the computer to do its 

w
work (the faster your processor, the shorter the rendering time).

When the rendering has been completed, the Camera application 
closes and theElectricImage application is launched .

36. Save the project file again ( -S).

37. Click Go or press return to launch the Camera application.

A dialog box opens, asking you to name and save the rendered image 
file (it defaults to “Tutorial 1 Image”):

38. Let’s use the default name, so either click Save or press return.

The ElectricImage application closes and the Camera application is 
launched to render the project.
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Building the Scene
Displaying the
Rendered Image

Let’s take a look at what we’ve done so far.

39. Choose Display… from the File menu ( -B).

A directory dialog box opens for you to select the file to display.

40. Find and select “Tutorial 1 Image.”

Your rendered image is displayed. It should look like the image below.

w
At this point in the project, the lamp, shelf, mirror and wall 
appear as solid, three-dimensional shapes, but they do not have 
any color or surface characteristics. Also, the mirror does not 
reflect and the glass elements of the lamp are not transparent. 

w
We’ll attend to these details as the tutorial proceeds.
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Tutorial 1: Creating a Photorealistic Image
Now that you’ve seen what the image looks like without modifying 
the original models, and using only the default light source, let’s take 
a break.

In the next section of this tutorial, we’ll apply surface attributes to 
the group components of the models, the first step in achieving a 
photorealistic image.

If you want, you can quit ElectricImage ( -Q) and reopen the project 
at another time, or continue on.
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Applying Surface Attributes
Applying Surface Attributes
Now it’s time to apply surface attributes to our models (re-open the 
project if you had closed it at the end of the previous section).

The Brass Objects 1. In the Project window, double-click on the group icon for 
BRASSSTUFF—or single-click to select it and then choose 
Group Info from the File menu ( -I).

The Group Info window for 
BRASSSTUFF opens.

Organize the workspace so 
that you can see both the 
Project window and the 
Group Info window at the 
same time (and be sure the 
Surface button in the Current 
Stats portion of the Group 
Info window remains visible).

2. Open the Surface Editor by clicking on the Surface button.

The Surface Editor opens, as 
shown at left.

We’ll be using the following 
controls to apply surface 
attributes:

• The display sphere.

• The Attribute pop-up 
menu.

• The slider bars and edit 
boxes. 

Surface button

Slider bars Edit boxes  Display sphere

Attribute
pop-up

menu

Edit boxes
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Tutorial 1: Creating a Photorealistic Image
To apply surface attributes to a group, you either drag the slider bars 
(try it and see how the display sphere in the upper right corner of the 
Surface Editor changes) or enter specific values in the edit boxes 
above the slider bars. For this tutorial, we have specific values for you 
to use, and you can either set the slider bars to those values or type 
them into the edit boxes.

3. First we’ll set the Group Color attribute (the group’s base color). 
Change the values in the Hue, Sat(uration) and Val(ue) edit 
boxes to match those shown at left.

4. Now choose Reflectivity from the Attribute pop-up menu, as 
shown at left.

w
The Reflectivity attribute settings do not automatically cause the 
group to reflect its surroundings. They only enable and modify a 
reflection image which is assigned and defined in a separate 

w
procedure (more on this later).

5. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

This will help to achieve a more brass-like effect by imparting a level 
of reflectivity with a brass-like tint.

Notice how the display sphere changes to indicate the new 
Reflectivity settings.

The checkerboard pattern is reflected in the display sphere.

w
The background for the display sphere can be changed from the 
checkerboard pattern to a solid black, white or color. Hold down 
the option key while clicking the display sphere. A pop-up menu 
opens to give you a choice of backgrounds. You can try different 

w
backgrounds, but be sure to return to the checkerboard pattern.
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Applying Surface Attributes
The Chimney Clips
and Knob

We now have the attributes for the brass objects defined and copied, 
so we can paste them into the Group Info windows for the chimney 
clips and knob.

6. Now we want to copy these attributes (so that we can use them 
for the other brass objects). To do so:

• Click on the display sphere to highlight it, as shown at left 
(unless it is already highlighted).

• Choose Copy Surface Color from the Edit menu ( -C).

7. Close the Surface Editor by clicking the Current Time button 
(or press return).

w
Since we are working with a still image and not a sequence of 

w
frames, we’ll use Current Time for all of our attribute settings.

8. In the Project window, double-click on the icon for the 
CHIMNEYCLIPS group.

Notice that the Group Info window changes to show data for the 
CHIMNEYCLIPS group.

9. Choose Paste Surface Color from the Edit menu ( -V).

The attributes from the BRASSSTUFF group are pasted to the 
CHIMNEYCLIPS group. Notice how the Surface button changes in the 
Group Info window.

10. Now repeat Step 8 and Step 9 for the KNOB group.
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Tutorial 1: Creating a Photorealistic Image
The Oil in the Lamp Let’s move on to the oil in the base of the lamp. (The oil wasn’t 
visible in your first rendering because it is inside the base of the lamp; 
after we assign transparency to the base you’ll be able to see it.)

11. In the Project window, double-click on the icon for OIL.

12. Open the Surface Editor for the group.

13. Set the group’s base color by changing the values in the Hue, Sat 
and Val edit boxes to match those shown at left.

14. Choose Diffuse from the Attribute pop-up menu.

w
The Diffuse attribute determines the amount and color of light 

w
scattered from the group.

15. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

These settings, by reducing the diffuse level down to zero, will 
eliminate scattered light from the surface of the oil, helping to keep it 
transparent.

Notice how the display sphere changes to indicate the new 
Diffuse settings.

The display sphere appears black because the diffuse level is zero.

16. Choose Specular from the Attribute pop-up menu.

w
The Specular attribute controls the size and color of highlights 
that might appear on the object’s surface (depending on its 
position relative to a light source). The quality of the highlight can 
affect the apparent texture of the object, ranging from hard and 

w
shiny to soft and dull.
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Applying Surface Attributes
17. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

This setting will reduce the brightness of the oil’s highlights.

18. Change the value in the 
Specular edit box to match 
that shown at left.

This setting will slightly increase the size of the oil’s highlights 
(spreading them out).

19. Choose Transparency from the Attribute pop-up menu.

20. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

This will help to achieve a more realistic effect by imparting a level of 
transparency to the oil.

Notice how the display sphere changes to indicate the new 
Transparency settings.

The display sphere becomes almost invisible in its transparency.

21. Choose Edge Density from the Attribute pop-up menu.

w
The Edge Density attribute is used to enhance the appearance of a 
rounded transparent object by increasing the apparent opacity of 

w
the object as seen through its edges.

22. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

These settings impart a dark yellow tint to the oil.
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Tutorial 1: Creating a Photorealistic Image
The Glass Base Now let’s do the glass elements of the lamp, starting with the base.

23. Change the value in the Edge 
Density edit box to match 
that shown at left.

Notice how the display sphere changes to indicate the new Edge 
Density settings.

The checkerboard pattern is visible through the display sphere, 
however the sphere’s edges appear denser.

24. Close the Surface Editor.

25. In the Project window, double-click on the icon for GLASSBASE.

26. Open the Surface Editor for the group.

27. Set the group’s base color by changing the values in the Hue, Sat 
and Val edit boxes to match those shown at left.

28. Choose Diffuse from the Attribute pop-up menu.

29. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

These settings will help prevent the glass from washing out.

30. Choose Ambient from the Attribute pop-up menu.

w
The Ambient attribute determines the amount and color of 

w
ambient light reflected by the group.
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Applying Surface Attributes
31. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

These settings, by eliminating the sensitivity to ambient light, will 
also help prevent the glass from washing out.

32. Choose Reflectivity from the Attribute pop-up menu.

33. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

Notice how the display sphere changes to indicate the new 
Reflectivity settings.

The checkerboard pattern is reflected in the display sphere.

34. Choose Transparency from the Attribute pop-up menu.

35. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

Notice how the display sphere changes to indicate the new 
Transparency settings.

The checkerboard pattern is visible through the display sphere.

36. Choose Edge Density from the Attribute pop-up menu.

37. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

These settings will impart a bluish tint to the glass.

38. Change the value in the Edge 
Density edit box to match 
that shown at left.
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The Glass Chimney We now have the attributes for the glass elements of the lamp 
defined and copied, so we can paste them into the Group Info 
window for the GLASSCHIMNEY group.

The Lamp’s Wick Now we’ll do the wick of the lamp.

Notice how the display sphere changes to indicate the new Edge 
Density settings.

The checkerboard pattern is visible through the display sphere, 
however the sphere’s edges appear denser.

39. Now copy these attributes by selecting the display sphere and 
choosing Copy Surface Color from the Edit menu ( -C).

40. Close the Surface Editor.

41. In the Project window, double-click on the icon for 
GLASSCHIMNEY.

42. Paste the attributes ( -V).

The attributes from the GLASSBASE group are assigned to the 
GLASSCHIMNEY group. Notice how the Surface Editor button 
changes in the Group Info window.

43. In the Project window, double-click on the icon for WICK.

44. Open the Surface Editor for the group.

45. Set the group’s base color by changing the values in the Hue, Sat 
and Val edit boxes to match those shown at left.

46. Choose Specular from the Attribute pop-up menu.
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Applying Surface Attributes
The Walls of the Room Let’s turn our attention now to the Room Model, beginning with the 
WALLS group:

47. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

Because we want the wick to appear soft and dull, we use these 
settings to eliminate any highlights from appearing on the group when 
the lighting is set up.

Notice how the display sphere changes to indicate the new 
Specular settings.

The specular highlight is now gone from the display sphere.

48. Close the Surface Editor.

49. In the Project window, double-click on the icon for WALLS.

50. Open the Surface Editor.

51. Set the group’s base color by changing the values in the Hue, Sat 
and Val edit boxes to match those shown at left.

52. Choose Specular from the Attribute pop-up menu.

53. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

These settings will eliminate any highlights from appearing on the 
group when the lighting is set up.

54. Close the Surface Editor.
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The Shelf Next, let’s do the shelf:

The Mirror’s Glass Next, let’s do the glass of the mirror:

55. In the Project window, double-click on the icon for SHELF.

56. Open the Surface Editor.

w
We’ll use the default group color for the shelf because we’re going 
to apply a texture map to it (in the next section of this tutorial), 
which will override the base color of the group. We will, however, 

w
need to assign a specular highlight value.

57. Choose Specular from the Attribute pop-up menu.

58. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

59. Close the Surface Editor.

60. In the Project window, double-click on the icon for 
MIRROR_GLASS.

61. Open the Surface Editor.

62. Set the group’s base color by changing the values in the Hue, Sat 
and Val edit boxes to match those shown at left.

63. Choose Diffuse from the Attribute pop-up menu.

64. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.
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Applying Surface Attributes
Notice how the display sphere changes to indicate the new 
Diffuse settings.

The display sphere appears black because we have severely reduced the 
amount of light that will be scattered from the glass. If we were to use 
a high diffuse value, the image in the mirror would be washed out.

65. Choose Ambient from the Attribute pop-up menu.

66. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

67. Choose Specular from the Attribute pop-up menu.

68. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

These settings will eliminate highlights when the lighting is set up.

69. Choose Reflectivity from the Attribute pop-up menu.

70. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

Notice how the display sphere changes to indicate the new 
Reflectivity settings.

The checkerboard pattern is reflected in the display sphere, with a 
bluish tint to the reflection.

71. Close the Surface Editor.
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The Mirror’s Frame The last group to surface is the mirror’s frame. For this group, you 
have free reign to apply surface attributes as you please (go for it).

Rendering the Image

Now that the surface attributes have all been applied, let’s save the 
project and render it again to observe our progress.

72. In the Project window, double-click on the icon for 
MIRROR_FRAME.

73. Open the Surface Editor.

74. Apply surface attributes as you see fit, using the display sphere as 
an indicator of your settings.

75. Close the Surface Editor when done.

76. Save the project file ( -S).

77. Open the Render Control window ( -R) and click Go.

A directory dialog box opens, asking you to name and save the 
rendered image file (it still defaults to “Tutorial 1 Image”).

78. Save the file into the same folder as before.

A dialog box will open to ask you what to do (cancel or replace)—
click Replace. The ElectricImage application closes and the Camera 
application is launched to render the project.

w
The rendering process will take longer than it did before, because 
the shading of objects is now more complex (particularly with 
transparent objects). So this might be a good time to take a break, 

w
unless you want to watch the progress of the rendering.
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Applying Surface Attributes
When the rendering has been completed, the Camera application 
closes and the ElectricImage application is launched.

Let’s take a look at what we’ve done.

79. Choose Display… from the File menu ( -B).

A directory dialog box opens for you to select the file to display.

80. Find and select “Tutorial 1 Image.”

Your rendered image is displayed. It should look like the image below 
(except, perhaps for the mirror frame).

w
Now we can see color and transparency (though it is difficult to 
discern the lamp’s glass chimney against the blackness of the 
mirror’s surface, which still doesn’t reflect anything). We need to 

w
add textures and reflections to the groups (that’s coming next).
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In the next section of this tutorial, we’ll apply texture maps and 
reflections to the group components of the models.
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Applying Textures and Reflections
Now it’s time to apply textures and reflections to our models (re-open 
the project if you had closed it at the end of the previous section).

Creating Textures

The Walls We’ll begin with the walls of the room.

1. In the Project window, single-click the icon for WALLS to select 
it, then choose Group’s Texture from the Tools menu.

w
Another way to open the Group Texture window is to click the Tool 
Palette’s Group’s Texture tool (if the palette is open). You can also 

w
press the Command key while double-clicking the group’s icon.

The Group Texture window for WALLS opens, as shown at left.

2. We’re going to apply a single texture to this group (up to two 
textures per group are possible), so double-click on the 
Texture 1 edit box at the top of the window, as shown at left.

A directory dialog box, as shown below, opens for you to select the 
texture file.

3. Open the Textures Folder 
folder within the Tutorial 1 
folder and add the texture 
named “Plaster SM Image.”

Either double-click on it, or 
single-click on it and either 
click Add or press return.
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When a texture is mapped to a group, it is scaled to fit the entire 
group. This may cause unwanted distortions or a loss of resolution in 
the texture when it is blown up to fit, so we can scale the texture 
down in size and make it repeat in small sections or “tiles.”

The texture is loaded into the project and appears in the Texture 1 
boxes at the top of the window, as shown at left.

4. Choose Cubic from the Map type pop-up menu, as shown at left.

w
Textures can be mapped in a flat, cubic, spherical or cylindrical 
projection. Because the shape of the WALLS group is closest to that 
of a cube, using a cubic mapping projection will provide the most 

w
pleasing result.

Leave the Align pop-up menu set to Midpoint.

w
Textures can be aligned to the top, bottom, midpoint (the default), 

w
back, front, left and right sides of a group.

5. Notice that the bottom portion of the window contains edit 
boxes for the X, Y and Z scale of the texture. Type new values in 
these edit boxes to change the values to those shown at left.
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Applying Textures and Reflections
Finally, let’s set the texture’s RGB and alpha channel usage.

The Shelf Now let’s apply a texture to the shelf.

6. Click the Mirror X and Mirror Y check boxes to disable them, as 
shown at left.

w
Mirroring, the default, would cause the texture to map into a 
pattern of adjacent tiles that are mirror images of each other. 

w
Disabling the function causes the tiles to repeat without mirroring.

7. Choose Disabled from the RGB pop-up menu, as shown at left.

w
By default, the group’s surface color values are replaced with the 
RGB channel of the texture. For this image, however, we want to 
disable the texture’s RGB channel (to maintain the base color of 

w
the group).

8. Choose Bump from the Alpha pop-up menu, as shown at left.

w
This setting uses the texture’s alpha channel information to add 
some apparent surface texture to the group. The technique is 
referred to as “bump mapping.” If the texture had no alpha 

w
channel, the RGB channel would be used for the information.

9. Close the Group Texture window ( -W)

10. Open the Group Texture window for the group SHELF.

11. Add the texture called “Sandstone SM Image” as Texture 1.
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Whereas we scaled down and tiled the texture for the WALLS group, 
we’ll apply the texture in one section to the SHELF group. So let’s just 
set the group’s RGB and alpha channel usage.

The Lamp’s Base
and Chimney

Let’s turn our attention now to the lamp, and apply a bump map to 
the glass base and the glass chimney.

12. Choose Cubic from the Map type pop-up menu.

13. Choose Top from the Align pop-up menu, as shown at left.

This setting will cause the texture image to be mapped onto the top of 
the shelf rather than its midpoint.

14. Leave the RGB pop-up menu set to Surface.

This setting will replace the group’s surface color with the texture’s 
RGB channel.

15. Choose Bump from the Alpha pop-up menu.

This setting will use the texture’s alpha channel information to create 
a “bump map.”

16. Close the Group Texture window ( -W).

17. Open the Group Texture window for the GLASSBASE group.

18. Add the texture called “Plaster SM Image” as Texture 1.

19. Choose Cylindrical from the Map type pop-up menu.

20. Choose Midpoint from the Align pop-up.
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Now we want to copy this texture (so that we can paste it onto the 
lamp’s glass chimney).

Now let’s paste the texture onto the lamp’s glass chimney.

Creating Reflections

Applying textures is only part of the process to create photorealistic 
images. The surfaces of objects reflect light and the images of other 
objects, so we need to apply images to some of the groups as 
reflection maps. There are three ways to apply reflections to objects:

21. Choose Disabled from the RGB pop-up menu (since we only 
want to use the texture as a bump map).

22. Choose Bump from the Alpha pop-up menu.

23. Set the Bump Factor value to 0.5, as shown at left.

This setting is used to create a “hand-blown” look to the glass. 
(Rendered glass often looks too perfect—adding a bump map makes it 
look more real.)

24. Choose Copy Texture 1 Map from the Edit menu ( -C).

25. Close the Group Texture window ( -W).

26. Open the Group Texture window for the GLASSCHIMNEY 
group.

27. Choose Paste Texture from the Edit menu ( -V).

The texture is applied to the GLASSCHIMNEY group as Texture 1.

28. Close the Group Texture window ( -W).
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• Apply an image as a reflection.

• Apply automatic mirror mapping (for flat objects).

• Apply automatic environment mapping (for multi-sided objects).

Using a Reflection Image First, let’s see how to apply an image as a reflection (in this case to the 
GLASSBASE group).

Now let’s copy this reflection (so that we can paste it onto the brass 
elements of the lamp).

Now let’s paste the image onto the brass elements of the lamp.

29. Open the Group Texture window for the group GLASSBASE.

30. Double-click on the Reflection edit box at the top of the 
window, as shown at left.

A directory dialog box opens for you to select a texture. Notice that, 
unlike the dialog box you used to add Texture 1, this dialog box has 
two buttons at the bottom: Mirror and Environment. You can ignore 
these for now; we’ll use them later.

31. Find and add the texture file called “Weird Hi-Con.”

The texture is loaded into the project and appears in the Reflection 
box at the top of the window, as shown at left.

32. Choose Copy Reflection Map from the Edit menu ( -C).

33. Close the Group Texture window ( -W).
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34. Open the Group Texture window for the BRASSSTUFF group.

35. Choose Paste Texture from the Edit menu ( -V).

The texture is applied to the BRASSSTUFF group as Reflection.

36. Close the Group Texture window ( -W).

37. Repeat Step 34 through Step 36 for the CHIMNEYCLIPS group.

38. Repeat Step 34 through Step 36 for the KNOB group.
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Automatic Mirroring Our next method of reflection mapping is automatic mirroring (in 
this case for the mirror on the wall).

Environment Mapping Finally, let’s apply automatic environment mapping (in this case to 
the lamp’s glass chimney).

39. Open the Group Texture window for the group 
MIRROR_GLASS.

40. Double-click on the Reflection edit box.

The directory dialog box opens for you to select a file. Notice that for 
reflections there are two additional buttons at the bottom of the box, 
one for Mirror, the other for Environment.

41. Instead of selecting a file, click the Mirror button, as shown at 
left.

Automatic mirroring is set for the group, as shown at left. That’s all 
there is to it!

42. Close the Group Texture window ( -W).

43. Open the Group Texture window for the group 
GLASSCHIMNEY.

44. Double-click on the Reflection edit box.

The directory dialog box opens for you to select a reflection.

45. This time, instead of selecting a file or clicking the Mirror 
button, click the Environment button, as shown at left.

Automatic environment mapping is set for the group, as shown at left.
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Rendering the Image

Now that we’ve applied textures and reflections to our models, let’s 
save the project and render it again to see how things look.

When the rendering has been completed, the Camera application 
closes and the ElectricImage application is launched.

46. Change the value in the 
Buffer Size edit box to match 
that shown at left.

This setting is sufficient for the image and will save rendering time.

47. Close the Group Texture window ( -W).

48. Save the project file ( -S).

49. Open the Render Control window ( -R) and click Go.

A directory dialog box opens, asking you to name and save the 
rendered image file (which still defaults to “Tutorial 1 Image”).

50. Save the file into the same folder as before.

A dialog box will open to ask you what to do (cancel or replace)—
click Replace. The ElectricImage application closes and the Camera 
application is launched to render the project.

w
Rendering time will be considerably longer than it was on the 
previous renderings, as the environment and mirror maps must be 

w
rendered in addition to the other elements in the scene.
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In the next section of this tutorial, we’ll make the lamp the light 
source that illuminates the scene.

51. Choose Display… from the File menu ( -B).

A directory dialog box opens for you to select the file to display.

52. Find and select “Tutorial 1 Image.”

Your rendered image is displayed. It should look like the image below.

w
Now we have realistic renderings of surface textures and 

w
reflections. The next step is to control the lighting of the image.
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Lighting the Scene
Lighting the Scene
Now it’s time to create the lighting effects for the final image, the last 
step in making it photorealistic (re-open the project if you had closed 
it at the end of the previous section).

Configuring the Light

We’ll begin by using our existing light source (Light 1) and changing 
its position and characteristics.

1. In the Project window, double-click on the icon for Light 1—or 
single-click to select it and then choose Light Info from the File 
menu ( -I).

The Light Info window for Light 1 opens.

Notice the Light Modes 
pop-up menu in the upper 
left corner of the window. 
This is where we set the type 
of light (such as Radial, 
Parallel, Spot, etc.).

Since the lamp in our scene is 
a light source that radiates 
light in all directions, it is 
appropriate to use a Radial 
light mode for this light. And 
since Radial is the default, we 
don’t have to change the 
setting in the pop-up menu.

Light Modes pop-up menu
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Let’s set the light’s position, color, intensity and dropoff distance.

2. Type the X, Y and Z Position coordinates shown at left in the 
Current Stats portion of the window.

(We’ll deal with the Reference coordinates later.)

3. Click the Light Color button in the Current Stats portion of the 
window, as shown at left.

The Color Editor opens.

This dialog box should look 
familiar to you, as it has 
slider bars similar to the ones 
you used in the Surface 
Editor.

4. Set the light’s color by changing the values in the Hue, Sat and 
Val edit boxes to match those shown at left.

5. Click Current Time or press return to close the Color Editor.

Notice how the Light Color button in the Light Info window has 
changed to show the new color of the light.

6. Type the Intensity and Dropoff values shown at left in the 
Current Stats portion of the window.

w
Dropoff refers to the distance from the light at which the light’s 
illumination ends. The area beyond the dropoff distance will not 
be affected by the light. Intensity refers to the brightness of the 
light. It is especially important as a control when using multiple 

w
lights in a scene (to avoid “over lighting” the scene).
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Creating Shadows

Now we’ll set up the light’s shadow casting qualities.

w
Lights do not automatically cast shadows in ElectricImage. You must 
enable shadows for each light. (By default, every group is set to cast and 

w
receive shadows, and you can disable shadow casting on a group level.)

7. Click the Enable Shadow check box in the Shadow Info portion 
of the window, as shown at left.

8. Notice that a new edit box, Shadow Cone, appears in the 
Current Stats portion of the window. Change the value in the 
edit box to that shown at left.

w
Even though the light source radiates light in all directions, you 
can control the angle of coverage for its shadow casting ability 

w
with the Shadow Cone value and the reference point coordinates.

9. Type the X, Y and Z Reference coordinates shown at left in the 
Current Stats portion of the window.
The ElectricImage™ Tutorial 1-43



Tutorial 1: Creating a Photorealistic Image
Creating a Glow Effect

Up to this point, the settings for the light will only affect what the 
light illuminates, not how the light itself will look as a visible object. 
By default, lights in ElectricImage are not visible. To make the light 
visible, we’ll enable the Glow effect.

10. Click the Enable Glow check box in the Special Effects portion 
of the window, as shown at left.

w
A glowing light can be any color, and its color can modulate from 
the center of the light (the inside color) to its edges (the outside 
color). For this light, we want the inside of the glow to be white 

w
(the default), and the outside to be a pale yellow.

11. Click the Outside Color button, as shown at left.

The Color Editor opens.

12. Use the Color Editor controls to set a pale yellow color for the 
outside of the glow, then close the Color Editor.

13. Type the Inner Radius, Outer Radius and Factor values shown 
at left in the Special Effects portion of the window.

w
The inner and outer radii control the size and appearance of the 
glow. Within the inner radius the glow is opaque; at the outer 
radius it becomes clear. The rate of dropoff in opacity from the 

w
inner radius to the outer radius is controlled by the Factor value.

14. Close the Light Info window ( -W).
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Adding a Light for the Mirror

Our lamp light is now set. There’s one more thing to consider, 
however—the mirror. In reality, the light from the lamp would not 
only illuminate the room directly; it would bounce off the mirror. To 
simulate this additional illumination, we need to add another light.

w
There are a number of ways to add lights to the project, including the 
Add Light command in the File menu and the Add a Light tool in the 
Object Palette. What we’ll do here is add another light by duplicating 

w
our existing light.

15. With Light 1 still selected in the Project window, choose 
Duplicate from the Edit menu ( -D).

The new light appears in the Project window’s object list, with the 
same name as the original and already selected, as shown at left.

16. Click on the name of the new light, as shown at left.

The name is put into the Project window’s edit box so that you can 
edit it, as shown below. But you must first hit the enter key to enable 
editing.

17. Hit the enter key to enable 
editing and then type the 
name “Light 2” and press 
return.

The new light is renamed.

Edit box
The ElectricImage™ Tutorial 1-45



Tutorial 1: Creating a Photorealistic Image
Creating a Spot Now we’ll configure this second light to be a spot light.

18. Open the Light Info window for Light 2.

19. Choose Spot from the Light Modes pop-up menu.

This setting simulates a directional, limited area light source that 
places a pool of light over a specified area.

w
Because we created this light by duplicating our other light, it has 
the same attributes, including the glow effect. We don’t want this 

w
light to be visible, however, so we need to disable the glow effect.

20. Click the Enable Glow check box in the Special Effects portion 
of the window to disable the function.

21. Type the Position, 
Reference, Dropoff, 
Intensity, Outer Cone and 
Inner Cone values shown at 
left in the Current Stats 
portion of the window.

These settings will cause the 
reflected light to be dimmer 
than the direct light, and to cast 
a shadow on the shelf.

w
The inner and outer cones control the angle of coverage for the 
light. Within the angle of the inner cone, the spot provides full 
illumination; at the outer cone, the illumination drops off. The 

w
rate of dropoff is controlled by the Factor value.

22. Close the Light Info window ( -W).
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Changing the Background Color

The last thing we want to do is change the color of the background. 
When you last rendered the image, you could see a black background 
through a window reflected in the mirror (page 1-40). To heighten 
the realism of the image, let’s change the background color to a dark 
blue (to simulate a night sky).

23. Open the Render Control window ( -R).

24. Click on the Background button in the upper right section of 
the window, as shown at left.

The Color Editor opens for you to set a background color.

25. Change the values in the Hue, Sat and Val edit boxes to match 
those shown at left.

26. Close the Color Editor.

Notice how the Background button in the Render Control window has 
changed to show the new color of the background.
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Rendering the Image

That’s it. The lighting is now set and the lamp should appear to be 
the light source for the room. Let’s render the project one last time to 
see how the new lighting effects work.

When the rendering has been completed, the Camera application 
closes and the ElectricImage application is launched.

27. Save the project file ( -S).

28. In the Render Control window, click Go.

A directory dialog box opens, asking you to name and save the 
rendered image file (it still defaults to “Tutorial 1 Image”).

29. Save the file into the same folder as before.

A dialog box will open to ask you what to do (cancel or replace)—
click Replace. The ElectricImage application closes and the Camera 
application is launched to render the project.

w
Rendering time will be considerably longer than it was on the 
previous renderings, as the lighting effects must now be rendered 

w
in addition to the other elements in the scene.
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Congratulations! You’ve just completed your first ElectricImage 
tutorial. Now that you’ve created the image that we’ve set up for you, 
feel free to experiment with different settings and values for the 
many elements in the project, and see what you can create on your 
own. Then, when you have the time, go on to the other tutorials, in 
which you’ll learn about the animation techniques of ElectricImage.

30. Display “Tutorial 1 Image.”

Your rendered image is displayed. It should look like the image below.

w
As you can see, the lighting has considerably changed the image, 

w
giving it a photorealistic effect.
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Tutorial 2: Creating a Simple Animation
Overview
This tutorial introduces you to the basic concepts of deformation 
while guiding you through the steps to create a simple sequence, 
excerpts from which are shown below.

In this project, a ball travels through a narrow pipe which bulges 
outward to accommodate the larger diameter of the ball. A pair of 
eyeballs observe the action.

By working with this tutorial, you will learn:

• How to create a bulge deformation for a group.

• How to animate the region of deformation within a group.

• How to use the “Look at Object” function to force one object to 
always look at another object.

• How to output your animation directly to QuickTime.
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Overview
What You Will Need

This tutorial builds on the knowledge you have gained from the 
previous tutorial. As such, it does not fully describe certain 
procedures that were introduced in that tutorial. For this reason, we 
strongly urge you not to attempt this tutorial until you have 
successfully completed Tutorial 1.

To complete this tutorial, make sure QuickTime™ (1.6 or later) is 
currently running and, as always, make sure that all of the 
ElectricImage applications and folders (including the Tutorials 
folders) have been installed on your hard disk in the same folder.

The files you will need is located in the Tutorial 3 folder:

• Cylinder

• Sphere

• Eyeballs Model

w
Please note: It is very important that you pay close attention to detail 
during the course of this tutorial. Successful completion of this project 
depends on text entry of many precise values, and it only takes one 
misplaced decimal point to produce unwanted results. Should you find, 
at any time, that your results do not match those shown in the tutorial, 
it may be due to an incorrect or missing variable, and you should go 

w
back over the steps to locate the error.
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Building the Scene
We’ll begin by opening a new project in ElectricImage.

Adding the Cylinder The first object we want to add to the project is a cylinder, which will 
serve as the pipe.

1. Launch ElectricImage and create a new project called 
“Tutorial 3 Project.”

Do not add any models to the project at this time (click Done).

2. Open the Project window ( -L).

Re-size and position it so that it covers the Front View and Side 
View windows.

3. Center the Project window’s Time Scale (option-zoom).

4. Set the duration of the animation to 3.0 seconds by dragging the 
red “stop sign” indicator to the 3 second mark.

5. Center the Time Scale again (option-zoom).

6. Choose Add > Model… from the File menu. You will find the 
Cylinder model in the Tutorial 3 folder.

7. Rename the Cylinder to “Pipe.”
2-4 ElectricImage™ Animation System



Building the Scene
Modifying the
Cylinder’s Axes

Notice that the cylinder was added to the project in an upright 
position. We’d like to have it lying down, so we need to exchange its 
X and Y axes.

Adding the Sphere Now let’s add the ball and configure it.

8. With the Pipe group selected, choose Modify Axes from the 
Tools menu.

The Modify Axes window, as shown at left, opens.

9. Click the Exchange X & Y button, then close the window.

10. Open the Group Info window for the Pipe group and click on 
the Surface button to open the Surface Editor.

11. Set the Group Color values as shown at left.

12. Close the Surface Editor and the Group Info window.

Choose Add > Model… from the 
file menu, select the Sphere from 
the Tutorial 3 folder.

The Sphere is added to the project.

13. Rename the Sphere to “Ball.”

14. Open the Group Info window for the Ball group and set its 
Y Position coordinate to 100.0.

This places the ball in the center of the pipe.
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Positioning the Camera

Now let’s position the Camera.

15. Click on the Surface button to open the Surface Editor and set 
the Group Color values as shown at left.

16. Close the Surface Editor and the Group Info window.

17. Open the Camera Info window, set the Camera and Reference 
coordinates as shown at left, then close the window.

w
We’re not concerned with lighting in this tutorial, so we can leave 

w
the light in its default position.
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Creating the Deformation
It’s time now to create a deformation for the pipe. We’ll make it bulge 
out so that it can accommodate the larger diameter of the ball as the 
ball passes through it.

1. Center the Top View window (option-zoom).

2. Option-drag a rectangle around the Ball group as shown at left.

The window zooms in on the Ball group.

3. Select the Pipe group.

4. Click the Group Deformation 
tool, as shown at left.

The Group Deformation 
window opens.

Move the window so that the 
Top View window is visible.
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5. Click the New… button under the Region list.

A dialog box asks you to name the region.

6. Click OK to use the default name of “Region 1.”

w
The deformation region defines the area to be affected by the 
deformation. It can be sized and positioned, relative to the center 
point of the group, by either click-and-drag in the World View 
windows or by numeric input in the Region section at the bottom 
of the Group Deformation window. For this tutorial, we’ll enter 

w
numeric values (so that you can duplicate the tutorial exactly).

7. Set the X Minimum value to 
-35.5 and the X Maximum 
value to 35.5.

Note how the region is 
displayed in the Top View 
window.

w
By default, a Bend type deformation is selected There are a 
number of different deformation types available, and you can 
choose one based on your needs. Also, multiple deformation types 
can be applied to the same group and their attributes can be 
animated. For this tutorial, we want to use a Bulge type 

w
deformation.

8. Choose Bulge from the Type pop-up menu.
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Creating the Deformation
9. Configure the bulge as 
follows:

• Set Bulge % to 150.0.

• Set Along Axis to X.

• Set Deform Axes to 
Y and Z.

10. We want to create a filleted bulge, which will have more 
rounded edges, so click the Options… button.

A dialog box, as shown below, opens.

11. Click the Filleted Bulge 
check box, then click OK.

Notice how the bulge is 
shown in the Top View and 
Camera View windows. The 
pipe has bulged out to 
enclose the ball.

12. Close the Group Deformation 
window.

13. Zoom out the Top View 
window until you can see the 
entire pipe.
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Animating the Ball through the Pipe
Now we can animate the ball to travel through the pipe, and also 
animate the deformation region so that the bulge will travel down 
the length of the pipe in synch with the ball.

First we’ll animate the ball.

Previewing the
Animation

Before we go any further, let’s preview the animation.

1. Open the Group Info window for the Ball group and set its 
X Position coordinate to -150.0.

Close the Group Info window.

2. In the Project window, drag the Time Selector to the 3.0 second 
position (at the end of the animation).

3. In the Group Info window, set the Ball group’s X Position 
coordinate to 150.0.

Close the Group Info window.

4. Open the preview options pop-up menu by option-clicking the 
camera icon at the lower left of the Camera View window.

5. Make sure that the Output to Screen, Draw Extents and Use 
No Background options are chosen.

6. Click the camera icon again to start the preview.

The ball travels from left to right across the screen, through the pipe. 
However, the bulge in the pipe is still in the center where we created it.
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Animating the Ball through the Pipe
Animating the
Deformation Region

Now let’s animate the pipe’s deformation region so that the bulge 
will move along with the ball.

7. Set the current time to 0.0 seconds.

8. Open the Group Deformation window for the Pipe group (a 
keyboard shortcut is to hold down the command and control keys 
while double-clicking the group.

9. In the Region section at the bottom of the window, set the 
X Position coordinate to -150 (which is the same coordinate as 
the Ball group’s position at this point in time).

w
Even though the deformation region is now outside the physical 
space occupied by the pipe, it can be seen in the Top View window 

w
(and should be surrounding the ball).

10. Close the Group Deformation window.

11. Set the current time to 3.0 seconds.

12. Open the Group Deformation window for the Pipe group again 
(command-control-double-click).

13. In the Region section at the bottom of the window, set the 
X Position coordinate to 150 (which is the same coordinate as 
the Ball group’s position at this point in time).

14. Close the Group Deformation window and preview the 
animation again.

The pipe should now be seen to bulge as the ball travels into it, 
through it and out the other end.
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Tutorial 2: Creating a Simple Animation
Keeping Our Eyes on the Ball
Now we’ll add a couple of eyeballs to watch the action, making use of 
ElectricImage’s “Look at Object” function.

w
The Look at Object function forces one object to look at another. It is 
useful for keeping the Camera or a spot light aimed at a moving object 
or, in this case, to automatically rotate an object so that it is always 

w
facing another object.

That’s all there is to it. You can now view the results of your efforts.

1. Choose Add > Model… from the File menu and add the 
“Eyeballs Model” from the Tutorial 3 folder.

The eyeballs are added to the project.

w
This model has been pre-configured so that it is automatically 

w
placed in the proper position for the tutorial.

2. Set the current time to 0.0.

3. Select the RIGHT EYE group.

4. Click the Look at Object tool 
in the Project window’s tool 
bar, as shown at left.

In the menu bar, a prompt asks you to select the object to look at.

5. In the Project window, click the Ball group to select it.

A status window opens, indicating the creation of custom frames for 
the RIGHT EYE group.

6. Now make the LEFT EYE group look at the Ball group.
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Creating a QuickTime Movie
Creating a QuickTime Movie
We’re now ready to create a QuickTime movie so that we can see the 
animation. To do so, we’ll use the preview function of the Camera 
View window.

First let’s disable the display of lights in the Camera View window 
and then select our previewing options.

1. Hold down the option key and click on the shading icon button 
in the lower left corner of the Camera View window (shown at 
left) to drop its menu.

2. Choose Display Lights from the menu, as shown at left.

This will disable the display of lights in the Camera View window.

3. Now hold down the option key and click on the camera icon 
preview button (to the left of the shading icon button) to drop 
its menu.

4. Choose Output to QuickTime, as shown at left.

5. Open the menu again and 
choose Draw Pixel Shaded.

These settings will create a 
QuickTime movie with greater 
rendering detail.
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Generating the
QuickTime Movie

Now we can generate and play the QuickTime movie.

6. Click the camera icon button again (no option key this time).

A directory dialog box opens for you to save the QuickTime movie.

7. Save it with the default name of “Tutorial QuickTime.”

An Output status window opens while the preview is created.

If this window is covering all or part of the Camera View 
window, you may want to drag it out of the way so that you can 
watch the progress of the preview.

After the last frame has been completed, a QuickTime display window 
opens to display your QuickTime movie. 

8. Use the window’s controls to stop, re-start, etc. When done, 
close the window.

w
If the QuickTime movie’s display is jerky and/or the animation 
does not seem to be synchronized with the soundtrack, it could be 
because you have something operating in the background which is 
causing additional overhead for your computer. For optimal 
playback conditions, you should have a fast machine with little or 

w
no overhead outside the ElectricImage application.

9. To display the QuickTime movie again, choose Display… from 
the File menu.
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