
BEFORE YOU BEGIN:

❏ Is the computer's sound turned up?

❏ Is QuickTime installed?

❏ Is the microphone plugged in?

❏ Is the date set correctly?

❏ Do you have a blank, formatted disk for your project?

❏ From the Edit  menu, choose Preferences… and make sure the
"I'm an experienced HyperStudio user" option is not selected.

This step-by-step tutorial for creating a project on France assumes
you are comfortable with the mouse, eraser, and selector tool. If you
haven't used a paint program before, you should spend some time
experimenting with the different tools. There are short descriptions of
the most frequently used tools on page 7. Since this workbook is for
use with both Macintosh and Windows some of the screen shots may
be slightly different from what you see on your screen.

ROGER WAGNER PUBLISHING , INC.
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POINTS TO PONDER

It is impossible to overstate the enormity of changes in literacy
and literacy practices wrought by developments in electronic
technologies. Because we can't comprehend what is happening,
we search for apt metaphors or for historical examples which
might serve to explain what is happening. So let me ask: "Are we
in the middle of a second Gutenberg revolution?" The answer is:
"No, we're not"; what is taking place in the field of literacy is
more far-reaching and more fundamental.

- Gunther Kress
Preface A-Z 21st Century Literacy Handbook

As the publishing and entertainment industries are rushing to
deliver information in a multimedia CD-ROM form, now is the
time to prepare our students to become effective communicators
in this new style of expression and information. HyperStudio is a
creative environment where users can bring graphics, sound, and
text together in a simple, intuitive, and exciting way. The goal of
this workshop is to learn the basic skills needed to use
HyperStudio. We created this project to show how creative
multimedia gives you some very important and powerful tools
with which to express yourself.

HOW TO USE THIS BOOK

The right-hand pages are the "Project Activities" or action pages.
Follow these directions carefully. Use the little check boxes (❏)
to keep track of the steps you have completed. The left-hand
pages are filled with "Tips and Reminders." These will be refer-
enced on the action pages. Refer to the tips as your interest dictates
and then return to the action page.
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ABOUT THIS PROJECT

We will be creating a four-card project. We have chosen a project
on France, as this subject touches on many possible themes:
travel, business, family history, and school projects.

On the title card you will learn how to get a border from the
HyperStudio clip art library. You will be adding a digitized picture
(which is  provided in HyperStudio), or you can create your own
if you have an AV Macintosh or digitizer such as ComputerEyes,
or have an Apple QuickTake or Kodak digital camera. This digitized
picture could be, for example, one of a student, a corporate office,
a salesperson, a company, or a school logo. A button which
includes the sound of your voice will take you to Card 2.

On the second card, you will add a map of Europe and an invisible
button to take you to Card 3.

On Card 3, you will add a text object with text and a graphic
object of a street artist which will appear when you click on the
phrase in the text object, a hypertext link . You will also create a
button to take you to Card 4.

Finally, we will add a Ready-Made Card of a bibliography template
as Card 4. Once we are done, we will return to Card 3 to play a
QuickTime movie.

A WORD ABOUT PROJECT DESIGN

This book suggests only one method of creating a stack. There
isn't an incorrect way to do this. You can create the cards all at once
and then add buttons to connect them, or add buttons each time you
create a new card. It is up to you to decide which you prefer.

Stacks can be linear, such as in a book, where the cards are connected
sequentially. Other projects can use the branching method, where
one card (such as a Table of Contents) connects to cards throughout
the stack. A circular-style stack might be used for projects which
demonstrate cycles.
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CARD 1

➧ You will create a title card using
this cameo-style photograph.

➧ The "Let's Go!" button will take
you to Card 2, a map of Europe.

O V E R V I E W  O F  T H E  P R O J E C T

CARD 2

➧ The map of Europe is from the
HyperStudio clip art library.

➧ Clicking on France, the country,
will take you to Card 3.

CARD 3

➧ The map is copied from Card 2.

➧ Clicking on the film strip shows
a QuickTime movie.

➧ Clicking the phrase “street artist”
displays the street artist graphic.

➧ Clicking on the mouse icon will
take you to Card 4.

CARD 4

➧ This Bibliography is a Ready-
Made Card Template which is
part of the HyperStudio package.
It is a good idea to end all
projects with this card, and fill in
the appropriate information!

FIGURE 1—PROJECT OVERVIEW
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Arrow Tool:
Use this tool when you want
to edit, move, resize or delete
objects which include
buttons, text objects, and
graphic objects.

➧ To tear away the Tools menu, drag the mouse down past the
tools, without releasing the mouse button, until you can see
that the tool palette has been torn away. This lets you place
the menu on the card so that you may choose a tool without
pulling down the menu each time.

➧ Reposition it by dragging the small bar across the top.

➧ To put the menu away, click in the small square window at
the top left corner of the palette.

Paint Text Tool:
Paint text on a card with this tool. You can edit the text, use the
delete key, choose a different color, size, and font, and even use
the spell-check before you click away from the painted text
typed with the T tool. Once you click the mouse away from the
text you have just typed, you will no longer be able to easily
make changes to that text.

Eraser:
This tool sets the eraser color
and erases portions of the
background.

Selector Tool:
This tool lets you capture a
rectangular area. Now you
can copy it, cut it, delete it,
move it, flip it, rotate it, or
resize it.

Browse Tool:
Use this tool to navigate your
way through stacks.

Circular Selector:
This tool lets you capture an
oval area.

A B O U T  S O M E  O F  T H E  T O O L S

Fill Tool:
This tool lets you fill a closed
shape with the currently
selected color or pattern.
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T I P S  &  R E M I N D E R S

Tip #1: Stack Size

➧ A good rule of thumb is to try and keep each stack under one
megabyte. You can check the size of your stack by choosing
About this Stack… from the Objects menu.

FIGURE 2—OBJECTS MENU

FIGURE 3—ABOUT STACK DIALOG

➧ Larger projects can be created by connecting stacks together,
like chapters in a book. To do this, choose Another Stack…
under "Places to Go" in the Actions dialog box.
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BEGINNING YOUR PROJECT

❏ From the File menu [FIGURE 4] choose New Stack. This will give
you the first card on which you can start building your project.

FIGURE 4—FILE MENU

ADDING A BORDER

We will be importing a full-screen image and then deleting its center.

❏ From the File menu [FIGURE 4] choose Import Background.

❏ If you have a video digitizer or digital camera software
installed, you will see this message [FIGURE 5] asking where
you want to get the picture from. Click on Disk file and OK.

FIGURE 5—IMAGE SOURCE DIALOG

Windows: ❏ From the hsart directory, scroll down the list,
and choose dingbats2.bmp and click on OK.

Macintosh: ❏ From the HS Art  folder, scroll down the list,
and choose Dingbats 2 and click on Open.
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T I P S  &  R E M I N D E R S

Tip #2: When an Area is Selected with the Selector Tool

➧ You can move the selected area by placing the mouse
within the selected area and dragging the mouse to a new
position.

➧ You can erase the selected area by pressing the delete key.

➧ You can make a copy of the selected area by pressing the
Option key (Macintosh) or the CTRL key (Windows) as you
click and drag the mouse.

➧ You can resize the image by grabbing the lower-right-hand
corner of the selected area and dragging the mouse. (The
cursor will switch to a two-headed diagonal arrow.)

➧ You can place or drop the selected area on the card by
clicking outside of the selected area. Clicking outside an area
without moving it just de-selects the area.

➧ You can create special effects in the selected area by using the
Flip Sideways, Flip Upside Down, Scale & Rotate, Replace
Colors, Gradients, Cookie Cutter, and Plug-ins commands.
From the Edit  menu, choose Effects and then select one of
the available commands.

Tip #3: If You Make a Mistake

➧ Choose Undo from the Edit  menu, or...

• Macintosh: press the Command key and the letter Z.

• Windows: press the Control key (CTRL) and the
letter Z.
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P R O J E C T  A C T I V I T I E S

Your card should look like this:

❏ From the Tools menu [FIGURE 6] choose the Selector tool.

FIGURE 6—THE SELECTOR TOOL

❏ Practice using it to select an area. To do this, begin above and
to the left of the area you want to capture, then drag the
mouse diagonally down and to the right, past the area you
want to select. While you see the flashing dots, the area is
selected. (Tip #2, Page 10)

❏ Press the delete key to erase the selected area. (Tip #2, Page 10)

❏ Using the Selector tool delete the remaining items in the
center section of the card, leaving the border only.
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T I P S  &  R E M I N D E R S

Tip #4: HyperStudio and Captured Images

➧ If you have either a video digitizer or digital camera,
HyperStudio offers you some options when you Add Clip Art,
Load a Background, or Add a Graphic Object to a card. You
can either:

1. Get the already digitized image from Disk file; this
means that the file is on the hard drive, a floppy disk,
or a CD.

2. Let HyperStudio instantly digitize an image from a
camcorder, VCR, or laserdisc player by choosing the
"Video" option. In this case your camcorder must be
connected to the "Video In" of your computer, and you
must be using a digitizer such as ComputerEyes or an
AV Macintosh.

3. Attach your digital camera and let HyperStudio go
directly to the camera to show you thumbnails of the
pictures you have taken. You can choose the picture you
want without having to leave the HyperStudio program.

4. Capture images from a TWAIN-compatible image source,
such as a scanner or digital camera. (Windows only.)

Tip #5: Selecting Large Graphics

➧ If you are selecting something which is taller than the clip art
window [such as one of the columns in dingbats2.bmp
(Windows) or Dingbats 2 (Macintosh)], here is some advice:
start at the upper left of the column and drag down as you
select. When you reach the edge of the window, keep
dragging. It will automatically scroll to allow you to select
more of the screen.
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P R O J E C T  A C T I V I T I E S

ADDING A DIGITIZED PICTURE

We will be adding a picture from the Photos directory, or you can
now make your own if you have a digital camera or a video
digitizer (See Tip # 4, page 12).

❏ From the File menu [FIGURE 4], choose Add Clip Art.

❏ If you have a video digitizer or digital camera software
installed, you'll get the message asking where you want to get
the picture from. Click on Disk file and OK [FIGURE 5].

Windows: ❏ From the hsart directory, open the photos
directory; select boyboats.bmp (a digitized
photograph) and click on OK.

Macintosh: ❏ From the HS Art  folder, open the Photos
folder; select Boy with Boats (a digitized
photograph) and click on Open.

❏ Using the Selector tool, select about a two- or three-inch
square of the picture. Start a little to the left and above the
tallest tree (on the left of the picture) and drag diagonally
down and to the right until you have selected the image of the
boy and the boats (Tip #5, Page 12).

❏ Click on OK.

❏ As you move the cursor across the square, it will become a
4-way directional arrow. It is with this arrow that you can
drag the selected image by holding down the mouse button.
Drag the picture toward the bottom right-hand area of the
card. Click away from the flashing dots to place the picture.
Do not cover the border.

CREATING A CAMEO

❏ To cut a cameo from the photograph, choose the Circular
Selector tool from the Tools menu [FIGURE 6].

❏ Begin above and to the left of the area you want to select, and
drag diagonally down and to the right until you have a
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T I P S  &  R E M I N D E R S

Tip #6: The Circular Selector Tool and Perfect Circles

➧ The Circular Selector tool will give you an oval. Holding
down the shift key will give you a circle.

Tip #7: Using the T Tool

➧ You can: edit the text, use the spell-check, use the delete key,
change the color, size, and font before you click away from
painted text typed with the T tool. Please check your title and
spelling before you click away from the last character you
typed.

➧ You can move the painted text by selecting it with the Selector
tool and then dragging the selected image to a new position on
the card.



ROGER WAGNER PUBLISHING —HYPERSTUDIO  WORKBOOK 15

P R O J E C T  A C T I V I T I E S

pleasing oval. Click away from the flashing dots to turn them
off if you need to try again (Tip #6, Page 14).

❏ Once you have a nice area selected, do not click away from
the flashing dots.

❏ Drag it away from the original photograph and move it to the
lower left-side of the card. Click away from the flashing dots
to place the image.

❏ Using the square Selector tool from the Tools menu, select the
remainder of the original picture on the right and then press
the delete key to remove it from the card.

ADDING A TITLE TO THE CARD

We will be painting a title on the background of this card.

❏ From the Options menu choose Text Style. [FIGURE 7]

FIGURE 7—TEXT STYLE DIALOG

❏ Choose Times (New Roman), Bold, Size 72, medium blue.

❏ Click on OK.

❏ Choose the T (Text tool) from the Tools menu [FIGURE 6].

❏ The cursor will change to a text cursor. Set the cursor down
on the card by clicking the mouse where you want the first
character. Allow enough space for the total height of the
character you will be typing. Begin one inch below the border
and one inch in from the left edge [FIGURE 1].

❏ Type the title, "France" (Tip #7, Page 14).
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T I P S  &  R E M I N D E R S

Tip #8: Saving Your Stack

➧ Use Save Stack As… the first time you save a project or when
you want to make a backup under another name.

➧ Once you save, the stack name will appear at the top your
card.

➧ Once it has been saved, you can choose Save Stack from the
File menu, or the keyboard shortcut CTRL+S (Windows) or
Command-S (Macintosh).
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P R O J E C T  A C T I V I T I E S

SAVING YOUR STACK

We'll be saving the project onto a floppy disk.

❏ Place a formatted floppy disk in the disk drive.

❏ From the File menu, choose Save Stack As…

Windows: ❏ Select the a:/ drive.

❏ Name the stack Project [FIGURE 8W] and
click on OK ( Tip #8, Page 16).

FIGURE 8W—SAVING THE STACK / WINDOWS

Macintosh: ❏ Save your stack on the floppy disk, by
clicking the Desktop button and navigating
to the floppy disk.

❏ Name the stack Project. [FIGURE 8M] and
click on Save ( Tip #8, Page 16)

FIGURE 8M—SAVING THE STACK / MACINTOSH
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T I P S  &  R E M I N D E R S

Tip #9: Adding New Cards to a Stack

➧ Don't worry when adding a new card to your stack and the
one you were looking at seems to disappear; your other
card(s) will still be there. When you add a new card, it is
added right after the card you are currently looking at.
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ADDING A SECOND CARD TO YOUR STACK

❏ From the Edit menu [FIGURE 9] choose New Card (Tip #9,
Page 18).

FIGURE 9—ADDING A NEW CARD

IMPORTING A BACKGROUND FOR THE ENTIRE CARD

❏ Choose Import Background from the File menu [FIGURE 4].

❏ If you have a video digitizer or digital camera software
installed, you'll get the message asking where you want to get
the picture from. Click on Disk file and OK. [FIGURE 5]

Windows: ❏ You'll be in the photos directory. To get
back to the hsart directory, double-click on
hsart under Directories. [FIGURE 10W]

FIGURE 10W—HSART DIRECTORY / WINDOWS
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Tip #10: Moving Manually Through a Stack

➧ In addition to any buttons you may have created to take you to
another card, there are menu items and keyboard shortcuts
which will allow you to move around in your stack. From the
Move menu, you can choose:

Menu Item Windows Macintosh

• Move Back CTRL + ~ Command - ~
• Move First Card CTRL + 1 Command - 1
• Move Next Card CTRL + > Command - >
• Move Back CTRL + < Command - <

The good news here is that it's pretty difficult to get lost in a
2-card stack!

Tip #11: Button Stuff

➧ Buttons are places on the screen where you click to make
things happen. When ever you create a button, HyperStudio
needs to know 3 things:

1. What the button should look like.
2. Where you want it.
3. What it will do.

HyperStudio will automatically guide you through these three
decisions each time you create a button, with the
"Appearance" and "Actions" dialog boxes.

➧ It is not a good idea to use the double-ringed visible button on
a card where there is a text object, because this type of button
is normally activated by pressing the Return key or Enter key.
It's also not a good idea to have more than one double-ringed
button on the same card, since HyperStudio will not know
which button you intended to activate.
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❏ From the hsart directory choose
europe.bmp and click on OK.

Macintosh: ❏ You'll be in the Photos folder. To get back to
the HS Art  folder use the directories list at
the top of the dialog box. Choose HS Art .
[FIGURE 10M]

FIGURE 10M—HS ART FOLDER / MACINTOSH

❏ From the HS Art  folder choose Europe and
click on Open.

❏ The map of Europe should now be on Card 2.

MOVING BACK TO CARD 1

❏ To move back to the first card, choose Previous Card from the
Move menu (Tip #10, Page 20).

MAKING A VISIBLE BUTTON

TO CONNECT TWO CARDS

We'll be creating a button with an icon to link the two cards. We'll
then edit the button (a useful skill) to add some sound.

❏ To make a button choose Add a Button from the Objects
menu [FIGURE 2] (Tip #11, Page 20).

❏ At the Button Appearance screen [FIGURE 11] choose the
rectangular button with the shadow. Write the name "Let's
Go!" Click on medium blue for the name of the button, and
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Tip #12: Help Messages When You Make a Button

➧ When you make a button for the first time, and you do not
have "I'm an experienced user" checked in Preferences,
HyperStudio will put up a help screen, reminding you of the
procedure for making a button.
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click on yellow for the background color of the button.

FIGURE 11—BUTTON APPEARANCE

❏ Click on Icons to select an icon for the button [FIGURE 11].

FIGURE 12—BUTTON ICONS

❏ Select the icon of the hand pointing toward the right.

❏ Click on OK [FIGURE 12].

❏ Click on OK at the Button Appearance screen.

❏ An instruction screen appears. Click on OK (Tip #12, Page 22).

❏ You'll see the button floating over the card and waiting to be
placed.

❏ Place the mouse cursor in the center of the button and drag the
button to the bottom right-hand corner of the card, just next to
the border.

❏ Click outside the flashing dots to place the button there.

❏ As soon as you click away from the button, you will see the
Actions screen [FIGURE 13].
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Tip #13: Transitions

➧ You can create some really neat effects by using certain
transitions for a button. You can have new text revealed if you
use the Left to Right transition, things can seem to appear
magically when you use the transition titled Dissolve, or fade
away if you select the transition Fade to Black.

➧ The Transition Screen will allow you to try each option and
view its effect before making your final selection.

Tip #14: Editing Buttons

➧ If you create a button and then want to move it, delete it, or
change what it does, you can use the Arrow tool.

➧ Use the Arrow tool to edit a button and use the Browse tool to
navigate your way through a stack.

➧ Be sure to switch back to the Browse tool after you have
edited a button.

➧ Pressing shift-tab will toggle back and forth between the
Browse and Arrow tools.

➧ You can bypass the Button Appearance screen and go directly
to the Actions screen by double-clicking the button with the
Arrow tool while pressing the Command key (Macintosh) or
the Control key (Windows).

Tip #15: Recording Sound

➧ While you are recording, the "gas gauge" will move showing
the memory you are using up while recording. It's a good idea
to be prepared with what you want to say before you click on
the Record button.

➧ When recording your own sound in the Tape deck, hold down
the Command key when you click "record" for better sound
quality. Keep in mind, however, that this mode uses twice as
much memory for your recording. (Macintosh only.)
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FIGURE 13—THE ACTIONS SCREEN

❏ On the Places To Go side click on Next Card. This will
automatically take you to the Transitions screen [FIGURE 14]
where you will choose a visual effect to take you to Card 2
(Tip #13, Page 24).

FIGURE 14—TRANSITIONS SCREEN

❏ Choose Barn Open and then click on Try It to see what the
sequence will look like. Then click on OK.
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Tip #16: Sample Sounds

Windows:

➧ Sounds that show up in the Samples list are stored in the stack
samples.stk located in the HStudio directory. If you move the
HyperStudio application to a new directory and don't also
move that stack (samples.stk) to the new directory, you will
get an error message. If you want to change the sample
sounds, you can open samples.stk and add or delete any
sounds you wish.

Macintosh:

➧ Sounds that show up in the Samples list are stored in the stack
HS Samples Library located in the HyperStudio folder. If
you move the HyperStudio application to a new folder and
don't also move that stack (HS Samples Library) to the new
folder, you will get an error message. If you want to change
the sample sounds, you can open HS Samples Library stack
and add or delete any sounds you wish.

Tip #17: Changing the Color of a Card

➧ You can change the entire background to any color you wish
by choosing Erase Background from the Edit  menu. Note: If
you already have Clip Art on the card it will be erased also.
You must change the background before you add the Clip Art.
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❏ This will bring you back to the Actions screen [FIGURE 13].

❏ Click on Done (your button is now complete).

❏ Click on your button to try it out. If you are in the T mode,
you'll have to switch back to the Browse tool to try it out.

❏ Once you get to Card 2, move back to Card 1 (remember Tip
#10, Pg. 20).

EDITING A BUTTON

We'll edit the button and add some sound to it.

❏ To edit a button choose the Arrow tool from the Tools menu
[FIGURE 6] (remember Tip #14, Page 24).

❏ Using the Arrow tool, double-click on the button to open it up.

❏ At the Button Appearance screen [FIGURE 11] click on Actions.
This will take you to the Actions screen [FIGURE 13].

PLAYING A SOUND

❏ At the Actions screen, on the Things to Do side, click on Play a
Sound. This will bring you to the Tape deck [FIGURE 15] (Tip
#16, Page 26).

FIGURE 15—THE TAPE DECK
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Tip #18: The Map Button Tool

➧ This is a great tool for making irregularly shaped states,
provinces and countries into buttons. It works in any place
that you might be able to use the Fill tool. Another example
where you might use this button is in making the different
colored areas of a beach ball into buttons.

Tip #19: Clicking on Position vs. OK at the Button
Appearance Screen

➧ Clicking on Position will bring you back to the Button
Appearance screen after you've placed your button; clicking
on OK will take you directly to the Actions screen.

➧ Either method will do the job. Clicking on Position will give
you the opportunity to use Position again, just in case you
accidentally "drop" the button, or decide to change its
appearance.
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❏ Click on the Record button.

❏ Speaking into the microphone say, "Welcome to France"
(Tip #15, Page 24).

❏ Click the Stop button to stop recording.

❏ Click on Play to listen to your recording.

❏ Click on OK [FIGURE 15].

❏ Click on Done at the Actions screen [FIGURE 13].

❏ Click on your button to go to Card 2 using the Browse tool.

❏ Now would be a good time to save! (Review Tip #8, Page 16)

ADDING ANOTHER CARD

❏ From the Edit menu, choose New Card. (See Tip #17, Page 26,
about changing the color of a card).

❏ Move back to Card 2 (Review Tip #10, Page 20).

LINKING TWO CARDS

WITH AN INVISIBLE BUTTON

We'll be adding a button in the shape of France to link the two cards.

❏ Choose Add a Button from the Objects menu. [FIGURE 2]
(Review Tip #11, Page 20).

❏ At the Button Appearance screen [FIGURE 11], choose the map
button tool. This is the bottom button on the left (Tip #18,
Page 28).

❏ Click on Position (Tip #19, Page 28).

❏ You'll get a prompt telling you to click inside your shape.
Click on OK.

❏ Click within France.

❏ Click on OK now that the button shape has been defined.

❏ Click on OK at the Button Appearance screen.
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❏ At the Actions screen choose Next card.

❏ Choose the transition Iris Open.

❏ Click on OK.

❏ Click on Done.

❏ Click on your button to try it.

COPYING AN IMAGE

FROM ONE CARD TO ANOTHER

We'll be copying a portion of the map from one card and pasting
it on another card.

❏ Move back to Card 2.

❏ Using the square Selector tool, begin above and to the left of
France, and drag diagonally down and to the right until you
have selected an area larger than France.

❏ While you see the flashing dots, choose Copy from the Edit menu.

❏ Manually move to the next card by pressing CTRL+>
(Windows) or Command-> (Macintosh) or choose Next Card
from the Move menu.

❏ Once you are on Card 3, choose Paste from the Edit menu.

❏ Drag the map to the upper left-hand area of the card, leaving
approximately one inch above and to the left of the map
[FIGURE 1]. Do not click away from the flashing dots to place
the image, as we will be resizing it. If you clicked away from
the image by mistake, you can select the area again with the
Selector tool or choose Undo.

RESIZING AN IMAGE

We'll be enlarging the map to 125% of its original size.

❏ From the Edit menu [FIGURE 9] choose the Effects item to
Scale… Note that the area to be scaled must be actively
selected (surrounded by flashing dots).
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Tip #20: Graphic Objects vs. Clip Art

➧ The difference between graphic objects and clip art is that
graphic objects float over the card. You cannot erase graphic
objects with the Eraser tool. Graphic objects must be deleted
with the Arrow tool. This tool will move them, resize them,
delete them and allow you to edit their actions.

➧ The reasons you would add an image as a graphic object are:

1. They can be hidden and shown with the click of a
button (HideShow NBA [New Button Action]).

2. You can drag them across the screen with the Browse
tool (as in moveable puzzle pieces).

3. They can be used in stacks that use Group Cards,
where you want to have a common background but
unique images on each card.

4. Since graphic objects can be moved easily with the
Arrow tool, they become the better choice when
working on a complex background. An example of
this would be turning painted text title into a graphic
object so it can be easily moved over a card that might
have a photograph as a background. Even a simple
horizontal line can be a useful graphic element when
turned into a graphic object.

➧ The reasons you would add an image as clip art  are:

1. They can be edited by using any of the paint tools.

2. You can Scale and Rotate the clip art to fit the size and
angle you need.

3. They can be used in stacks that use Group Cards, where
you want to have a common background and the same
images on each card.

➧ You can easily change a selected area of the background into a
Graphic Object: Select an area with one of the selection tools,
then choose Add a Graphic Object from the Objects menu.
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❏ Type in 125% for the Scale factor. [FIGURE 16]

FIGURE 16—SCALE & ROTATE

❏ Click on OK.

❏ Click outside the flashing dots to place the resized image.

ADDING A GRAPHIC OBJECT

(See Tip #20, Page 32)

❏ From the Objects menu, choose Add a Graphic Object.
[FIGURE 2]

❏ Click on Disk File and OK if appropriate.

Windows: ❏ From the hsart directory choose
startist.bmp from the photos directory.

❏ Click on OK.

Macintosh: ❏ From the HS Art  folder choose Street Artist
from the Photos folder.

❏ Click on Open.

❏ Using the Selector tool, select the picture.



34 TIPS & REMINDERS

T I P S  &  R E M I N D E R S

Tip #21: The Graphic Appearance Menu

➧ It is not necessary to name graphic objects unless you have
more than one on a card that will be addressed by a New
Button Action or a Logo script.

➧ You can select a frame for a graphic object if you wish. This
is a great way to create "outlined" text and other objects.

Tip #22: Text Objects

➧ While you see the flashing dots, the text item can be stretched
or reduced in size by dragging the mouse just inside one of
the corners of the text object.  The cursor will change to a two
headed diagonal arrow.

➧ If you are in the Browse mode, you'll have to switch to the
Editing tool (arrow) to stretch or shrink the text item.

➧ You can change the color of one or as many words as you'd
like within a text object.  To change the style of the text, first
switch to Browse mode, then highlight the words you want
changed by dragging the mouse across the words.  Once the
text has been selected, select the new color you want from the
Colors menu.
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❏ Click on OK.

❏ The first time you add a graphic object you'll get a help
message [FIGURE 17] describing how to place a graphic object
onto the card. Click on OK.

FIGURE 17—GRAPHIC ITEM MESSAGE

❏ Drag the picture to the right-hand area of the card, beside the
map. Click outside the flashing dots to place it there.

❏ At the Graphic Appearance screen, name the object Artist .
Choose a medium blue frame and click on the up arrow to get
a frame width of 2.

❏ Click on OK (Tip #21, Page 34).

ADDING A TEXT OBJECT

We'll be adding a text object in which you can write and edit text
easily, or import existing text.

❏ To add a text object, choose Add a Text Object from the
Objects menu [FIGURE 2].

❏ A help message will appear. Read it and click on OK.

❏ The flashing dots on your card represent the size and location
of the text object you are creating.

❏ Drag the text object to just below the images you have added
to this card (Tip #22, Page 34).
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❏ Stretch the text object so it is almost the width of the card (leaving
an inch on the right-hand side so we can add a button later) and fits
between the images and the bottom of the card [FIGURE 1].

❏ Click outside the text object to place it.

❏ This brings you to the Text Appearance screen [FIGURE 18].

FIGURE 18—TEXT APPEARANCE SCREEN

❏ Click on the Style button to change the size and type of the font.

❏ This will take you to the Text Style screen [FIGURE 19] where
you can choose a smaller font for the text. Let's choose Times
(New Roman), Size 14, Plain, Text Color-white, Background
Color- medium blue. Click on OK.

FIGURE 19—TEXT STYLE SCREEN

❏ At the Text Appearance screen click on OK.
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Tip #23: Changing the Color or Style of Text in a Text Object

➧ You can change the style of one word or as many as you'd like
within a text object. To change the style of the text, highlight
the words you want changed by dragging the mouse across the
words. Once the text has been selected, go to Text Style in the
Options menu and choose either underline, italics, bold, etc.

➧ To change the color of all of the contents in the text object,
use the Editing (Arrow) tool to select the text object. Once
you see the flashing dots, click on the color of the text you'd
prefer with the Colors menu (you can also use Text Style in
the Options menu and change the color and/or the font there).
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❏ Type text directly into the text object. Write a paragraph about
the things you might want to see on a trip to France. Be sure
to include the phrase "street artist", as we will be making a
button out of those words. To change the color or font of
selected words or the whole text item see Tip #23, Page 38.

❏ To let your users know that this is a hypertext link, it is a good
idea to underline the words. (Tip #23, Page 38.)

ADDING A HYPERTEXT LINK

We will now make a button out of the phrase "street artist" which
will make the graphic artist appear.

❏ To select the phrase, choose the Browse tool and drag the
mouse across the words "street artist".

❏ From the Objects menu [FIGURE 2] choose Hypertext Links.

❏ Street artist will appear in the lower window.

❏ Click on Add link.

❏ Click on Action.

❏ At the Actions screen [FIGURE 13], under "Things to Do", click
on New Button Actions.

❏ HideShow 2 is a sample NBA (New Button Action) and
should already be highlighted. If not, select it now.

❏ Click on Use this NBA.

❏ Name the object Artist .

❏ Click on graphic.

❏ Click on show it.

❏ Click on Show Effect…

❏ At the Transitions screen, choose "Bars".

❏ Click on OK.

❏ At the HideShow 2 action screen, click on OK.

❏ At the New Button Actions screen, click on OK.

❏ At the Actions screen, click Done.
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❏ At the Hypertext Links screen, click Done.

Note: The first time you click on this hypertext link nothing will
happen because the graphic object is already showing. What we
will do is create a card action that will hide the graphic object
when leaving that card.

GIVING A CARD AN ACTION WHEN LEAVING THAT CARD

❏ From the Objects menu choose About this Card.

❏ At the About Card screen click on Things to do when:
leaving this card...

❏ At the Actions screen, choose New Button Actions.

❏ The HideShow 2 NBA should already be highlighted. If not,
select it now.

❏ Click on Use this NBA.

❏ Name the object Artist .

❏ Click on graphic.

❏ Click on hide it.

❏ Click on OK.

❏ Click on OK at the New Button Actions screen.

❏ Click on Done at the Actions screen.

❏ Click on OK at the About Card screen.

❏ Save your stack.

ADDING A READY MADE CARD TEMPLATE

We'll be adding a clip card, or pre-made card of a bibliography
template. Bibliographies are the way we can share (with other
users) the source of information where we got our graphics, text,
sounds and movies. In this particular project all the files were taken
from the HyperStudio package. In your future projects these
sources might include CD-ROM titles, URLs from the Internet,
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Tip #24: Ready Made Cards

➧ The same way that you can have clip art and clip sounds, you
can have clip cards. Ready Made Cards can be templates for
individual cards that you would like to use over and over again.

➧ To make your own Ready Made Card which will be added to
the list, save the card as a one card stack in the Ready Made
Cards folder (Macintosh) or the Rdymcard directory
(Windows). The next time you launch HyperStudio this card
will appear in the ready-made card list.
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books scanned or quoted, or your name and information in cases
where you created the information yourself. Bibliographies help
other users get further information.

❏ From the Edit  menu, choose the item Ready Made Cards and
select the Biblio.stk  (Windows) or the Bibliography
Template (Macintosh). (Tip #24, Page 42.)

ADDING A BUTTON TO

LINK TWO CARDS AND PLAY A SOUND

We'll be making a button to link two cards. Move back to card 3.
Notice that the graphic of the artist is now hidden! Try your
hypertext link by clicking on street artist.

❏ From the Objects menu choose Add a Button.

❏ At the Button Appearance screen [FIGURE 11] choose the
invisible button which looks like a dotted rectangle.

❏ Click on Icons.

❏ Choose the icon of the mouse. Click on OK.

❏ Click on OK at the Button Appearance screen.

❏ Drag the button to the right-hand area of the card, just beside
the text object.

❏ Click away from the flashing dots to place it there.

❏ At the Actions screen choose Next card.

❏ Choose the transition Left to Right, at a Slow speed.

❏ Click on OK.

❏ Choose Play a Sound at the Action screen.

❏ Click on Disk Library… at the Tape deck. [FIGURE 15]

Windows: ❏ From the hssounds directory choose ElecHarp.

Macintosh: ❏ From the HS Sounds folder choose Electric
Harp .

❏ Click on Open or OK.
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❏ Click on OK at the Tape Deck.

❏ Click on Done at the Actions screen.

❏ Click on the button to move to the Bibliography card.

PLAYING A QUICKTIME™ MOVIE

Let's move back to Card 3 and play a QuickTime movie.

❏ Manually move to Card 3.

❏ From the Objects menu [FIGURE 2] choose Add a Button.

❏ Choose the invisible rectangular button.

❏ Click on Icons.

❏ Select the VHS tape icon. You may need to scroll down to see it.

❏ Click on OK.

❏ Click on OK at the Button Appearance screen. [FIGURE 11]

❏ Drag your button to the right and just below the map, and
click outside the flashing dots to place it there. If you don't
have enough room remember that you can move the cursor to
the corner of the button until it becomes a two-headed
diagonal arrow. The button can then be resized by dragging
the corner. If you have already clicked outside the flashing dots,
you can always resize the button later with the Arrow tool.

❏ At the Action screen, click on Play a Movie or Video...

❏ Choose Disk File (QuickTime or AVI movies) at the
Video/Movie Source screen. [FIGURE 20]

FIGURE 20—VIDEO/MOVIE SOURCE
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Tip #25: QuickTime and AVI Tips

➧ A QuickTime or AVI movie can be added as a button action
(when you click on the button the movie is played).

➧ Choose Erase when done, when you want the last frame of the
movie to disappear after the movie has played.

➧ Choose Loop movie, when you want the movie to play
continuously until you leave the card.

➧ Choose Show first frame, if you want the first frame of the
movie showing when you first arrive at the card. You can
double-click on this image to start the movie when there is a
controller bar.

➧ Choose Use movie controller, when you want to have access
to the slider to control the movie. Choose Use movie
controller and Show first frame if you want to be able to start
the movie by double-clicking on the first frame. You can
pause the movie by clicking once on a frame.

➧ You can also make a movie dissolve and disappear after it has
been played. When you create the button to play a movie also
check Another Card under Places to Go on the Actions
Screen. Instead of navigating to another card choose the
current card with the transition Dissolve. This button will play
the movie then dissolve into the same card, making it seem as
though the movie is melting away.
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❏ Click on OK.

Macintosh: ❏ From the QuickTime Movies folder choose
the Seine movie and click on Open.

Windows: ❏ From the QTMovies directory choose the
Seine.mov movie and click on OK.

❏ The help message which appears will only appear the first
time you add a QuickTime movie. Click on OK.

❏ The movie will be floating over the card, just as clip art,
waiting to be placed. Drag the movie toward the left side of
the card and place it over the map of France.

❏ Click outside the flashing dots to place the movie.

❏ You can preview the movie at the QuickTime Movies screen.
[FIGURE 21] (Tip #25, Page 46) (Also see Tip #26, Page 48)

FIGURE 21—QUICKTIME MOVIES DIALOG

❏ Click on OK.

❏ At the Actions [FIGURE 13] screen click on Done.

❏ Click on your VHS tape button to see the movie.

❏ Save your work.
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Tip #26: Resizing and Repositioning QuickTime Movies

➧ To resize or reposition the movie, you will have to edit the
button.

Using the arrow tool, double-click on the button to open it up.

➧ At the Button Appearance Screen click on Actions.

➧ At the Actions screen click on Play a movie or video.

➧ At the QuickTime Movies screen click on Position to be able
to reposition the movie. You can also grab the corner at this
time to make the movie smaller or larger so that it fits behind
the stencil.

➧ Click away from the movie when you are done.

➧ Click on OK at the QuickTime Movies screen.

➧ Click on Done at the Actions screen.
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Congratulations! You have completed your first project! Move
back to Card one and click through your stack. You might want to
create buttons which move back to previous cards, or add some
artwork with the paint tools. You now know the core set of skills
that most people use in creating HyperStudio projects.

BONUS ACTIVITY

If you would like to spend a little more time on your project now, you
can learn how to use HyperStudio’s Actor-Based Path Animation!

❏ From the Tools menu, switch to the Arrow tool.

❏ Double-click on the “Artist” graphic and click Actions.

❏ At the Action screen choose Play Animation…

❏ An information screen may appear. Read it, then click on OK.

❏ A dialog appears asking, "Where would you like to get your
image from?". Click on the Disk Library icon.

❏ In the HSAnim directory (Windows) or the HS Animation folder
(Macintosh) select SmalBird.gif and click on Open or OK.

❏ The image (small bird) which appears on the screen will
become your cursor. Place it where you would like the path to
start, press the mouse button down and drag the mouse to
create your desired path.

❏ Release the mouse button to complete the animation. The
Animation screen will appear.

❏ Choose Erase when Done and Play for: 1 path repeats

❏ If you would like the image to float over objects on the
screen, click the Path menu and select Path Options. Select
Float Over (under "Going") and click on OK.

❏ Click on OK at the Animation screen, Done at the Actions
screen, and, if necessary, OK at the Graphic Appearance screen.

❏ To play the animation you must switch to Browse mode
(Shift-Tab) before clicking on the graphic. Note: Remember
that to show the graphic, you must click on the hypertext link.
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Tip #27: Roll Credits

➧ If you don't have enough text to scroll, set your cursor down
at the end of the text and press the Enter or Return key several
times to add some blank lines. This will allow your text to
scroll up to the top of the Text Object and then out of view.
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EVEN MORE THINGS TO DO

This would be a good time to explore some of the New Button
Actions (NBAs) which can be found at the "Things to do" side of
the Actions screen. Each NBA has instructions. Try these out:

1. Netpage NBA: If you have  direct connection to the Internet
(SLIP/PPP Account) and either the Netscape Navigator or
Microsoft Internet Explorer browser, you can link from within
a HyperStudio project to information resources on the World
Wide Web.
❏ Move to Card 2
❏ Under the Objects menu, choose Add a Button.
❏ Choose the rectangular button as your button type.
❏ Name the button "Let's Visit France!"
❏ Click on OK.
❏ Drag your button to the bottom right corner of the card.
❏ Click outside of the button to place it on the card.
❏ At the Actions menu, choose New Button Actions.
❏ Click on the NetPage NBA and click Use This NBA.
❏ In the Uniform Resource Locator (URL) box type:

http://www.tourisme.fr
❏ Click on OK. Click Done.

❏ Change back to Browse mode (Tools) and click the button.

If your connection is working, HyperStudio will launch your
browser (Navigator or Explorer) and take you to the site of the
French Office of Tourism!

2. Roll Credits: This NBA allows you to automatically scroll text
in a Text Object. You can use this, for example, to create a
"credits" screen, much like you see at the end of a movie! Be
sure you have enough text in the Text Object so that it can
scroll. If the Text Object has a "filled-in" scroll bar, then you
have enough. (Tip #27, Page 50.)

3. Ghost Writer: This NBA allows text to be automatically typed
into a text object one letter at a time, as if a ghost was sitting
at the keyboard!
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