
JKey Help Contents

The Contents lists Help topics available for JKey. Use the scroll bar to see entries not currently visible in the Help 
window.

To learn how to use Help, press F1 or choose Using Help from the Help menu

Overview
Commands
Procedures

Performance Hint: See Starting JKey.



Overview

JKey is a Windows utility that enhances your keyboard for use with Windows applications. JKey has two primary 
capabilities:

        it adds mnemonic macro capabilities to all Windows applications
        it alters the behavior of your keyboard

Using the first capability, you can easily enter the current date and time into an application, easily access international
and typographic characters such as Ü and ©, or startup another application. To enter the current date and time into 
an application, press and release the trigger key (by default, this is the Ctrl key found to the right of the space bar), 
this will activate the JKey indicator window. Type "dt" ( a mnemonic for Date Time). The current date and time will 
then entered into the application. To get the copyright symbol, use "co" as the mnemonic. The complete list of 
currently defined sequences and their results are listed within the JKey's main window.

Using the second capability you can change the behavior of your keyboard so that the CapsLock and Ctrl keys are 
reversed, or so that the Shift key always upper cases, or alter the behavior of the NumLock and ScrollLock keys.
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Commands

File Menu
Options Menu
Main Window



File Menu

New
Use New to unload the current set of sequences and create an empty table.

Open
Use Open to unload the current set of sequences and open another one.

Save
Use Save to save the currently defined set of sequences to the file from which they were originally loaded. This will 
enable all definitions in the table. There is also a Save button in the main JKey window for this purpose. If you 
would like to use the currently defined sequences but aren't ready to commit them to your file, click on the Use 
button in the main Jkey window. This will cause them to be saved to a temporary file.

SaveAs
Like Save, but you can specify an alternate file.

Print
Use Print to print the current table of sequences to the default printer. To change the target printer, use Print Setup 
or the Control Panel application. See Printing.

Print Setup
Use Print Setup to specify a different printer other than the current default or to change operating characteristics of 
the printer.

Exit
Exits JKey, prompting you to save any modifications you might have made.



Options Menu

Trigger Key
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Trigger Key

JKey can be used from within another Windows application by pressing a specially defined trigger key. After the 
trigger key is pressed and released, a special window appears in the bottom right hand corner of the screen. You can 
then begin to type the characters of a JKey sequence.

By default, the trigger key is the Ctrl key located on the right hand side of the space bar. This key definition will 
usually not interfere with a Windows application. If another key is used while pressing that Ctrl key, JKey will not be 
activated. This means that Ctrl-PageDown will behave as expected. If your keyboard does not have two Ctrl keys or if
you would like to define another trigger key, use the Trigger Key item on the Options menu to activate a dialog box 
that will allow you to define your own trigger key.

Be careful when defining a new trigger key. It is usually best to avoid the Alt key as that is heavily used by Windows 
and Windows applications, although combinations like Alt-ScrollLock can be safe. Many Ctrl key combination are 
used by Windows applications, so be careful when choosing one of these.



Enabling and Disabling JKey

Should you find JKey interfering with another application, you can easily disable JKey by selecting Disable from the 
Options menu or by clicking the disable button in the main JKey window. JKey can be re-enabled in the same 
fashion.



Table Font

You can change the default font used within the table of defined sequences by selecting Table Font from the Options 
menu. A font dialog appears from which you can select your font. Changes to the font will last across JKey sessions. 
Note that if a sequence has been defined for a specific font, the result will be rendered using that font rather than the 
default table font.



Keyboard Behavior

JKey can alter your keyboard's behavior in the following ways:

 JKey can control the state of the NumLock and ScrollLock keys:
      Normal, toggles on and off, not affected when JKey starts
      Always on
      Always off
      Initially on when JKey starts
      Initially off when JKey starts

The Shift key can be made to always upper case. Many people find the interaction between the CapsLock and Shift
keys to be confusing. Normally on a PC, the Shift key upper/lower cases using the opposite of the CapsLock 
toggle, producing some unexpected typing. JKey can alter the keyboard's behavior so that the Shift key always 
upper cases.

JKey can also swap the behavior of the CapsLock and Ctrl keys. Unlike the now-traditional enhanced keyboard, 
some keyboards have the Ctrl key just left of the letter A. JKey can provide this same behavior by treating the 
CapsLock key (which is just left of the letter A) as the Ctrl Key, and using the Ctrl key as the CapsLock key.

Access the Keyboard Behavior dialog box from the Options menu.



Problem Applications

When JKey is activated, it switches focus to the indicator that appears in the lower right hand corner of the screen. 
This ensures that keys that you press will not be seen by the current application. Some applications, like Paintbrush, 
will not return to the previous state when focus is switched back to it. You can tell JKey to NOT switch focus for 
applications like these. It should work well as long as the application is not doing low-level keyboard processing, such
as a high-end spreadsheet application might do.

Another problem is that some desktop accessories raise windows to the top as the mouse pointer passes over them. 
This gives the "raised" window the input focus. Because JKey redirects focus to the JKey indicator there will be a 
conflict when the desktop accessory immediately sets focus back to the window under the mouse pointer. To work 
around this problem, you can tell JKey to move the mouse pointer to the indicator when JKey is activated. Access the
Problem Applications dialog box from the Options menu.



JKey's Main Window

JKey's main window is comprised of:

A Menu

A group of buttons for controlling JKey's behavior: Enabling/Disabling JKey and Defining a new trigger key

A group of buttons for using and saving changes made to the table of key sequences. See File Menu

A table of key sequences

A group of buttons used to edit the table



Table of Key Sequences

The table of key sequences displayed in JKey's main windows contains a list of defined key sequences each of which
can have the following information:

Sequence    the characters that will result in a valid sequence and cause the Result field to be sent to the active 
application.

Case Sensitive    A Yes or No field that indicates if the Sequence is case sensitive or not.

Result    the result of the sequence that will be sent to the active application. See Macros and Keystrokes.

Font    the suggested font to use to achieve the desired result. May be blank.

Application    the specification application for which this result should be used. May be blank.

Comment    may be blank

ANSI Result    a non-editable field useful when Font is a non-textual font and you want to know what ANSI keystrokes 
might be used with that font.

This fields may be edited. See Editing the Table of Key Sequences.



Editing the Table of Key Sequences

You can add, delete, and modify the table of key sequences displayed in JKey's main window.

To add a sequence to the end of the list, click on the Add button.

To add a sequence above another, select a sequence and click on the Insert Above button.

To add a sequence below another, select a sequence and click on the Insert Below button.

To delete a sequence, select it and click on the the Delete button.

To edit a sequence, double click on it or select it and click on the Edit button.

If adding or modifying a sequence, a secondary dialog box will appear. See Editing a keyboard sequence.



Procedures

Starting JKey
Using JKey from other applications
Enabling and disabling JKey
Defining a new trigger key
Editing the table of key sequences
Changing the table of key sequences font
Problem applications
Controlling the behavior of the NumLock and ScrollLock keys
Controlling the behavior of the Shift key
Swapping the CapsLock and Ctrl keys
Printing
Keystrokes and other macros that can be performed by JKey
Choosing characters with the Characters dialog box
Editing a keyboard sequence



Starting JKey

There are various ways to start JKey, but there are two primary methods:

Start it from the JKey group that was added to Program Manager when JKey was installed.

Once you know JKey, the best    way to start it is to add it to your Start Up group and run it minimized. This 
significantly reduces start up time as the loading of the main window is delayed until it is actually needed. Even 
though JKey's user interface has not been loaded, the JKey trigger key is still fully functional.



Using JKey From Other Applications

To use JKey from another Windows application (not DOS), press and release JKey's trigger key which is displayed in
the main JKey window. You can then enter the characters of a sequence and the result will automatically be entered 
into the current application. For instance, "dt" would result in the current date and time being entered. Also see 
Trigger Key.



Printing

JKey provides only very rudimentary printing capabilities at this time. Use the Print Setup menu item on the File menu
to select a printer or alter its operating characteristics. Select Print from the file menu to print the current set of JKey 
sequences.



Macros and Keystrokes

JKey uses the Visual Basic SendKeys function to send key strokesto other applications, so the syntax is the same 
with a few additions. To specify a single keyboard character, use the character itself. The plus sign (+), caret (^), 
percent sign (%), tilde (~), parentheses (), brackets ([ ]), and braces ({ }) are special characters and must be enclosed
in braces if they are meant to be used uninterpreted.

To specify a shifted key, use the plus sign (+). To specify a control key combination use the caret (^). To specify an alt 
key combination, use the percent sign. To specify a series of characters modified by one of these keys, enclose those
characters within parentheses. As an example,

      ^Cab+(XYZ)%F+1 results in

...Control-C, Shift key down, XYZ, Shift key up, Alt-F, Shift-1

More complex keys can also be sent by specifying them within braces:

Backspace {BACKSPACE} or {BS}
Break {BREAK}
Caps Lock {CAPSLOCK}
Clear {CLEAR}
Del {DELETE} or {DEL}
Down Arrow {DOWN}
Enter {ENTER} or ~
Esc {ESCAPE} or {ESC}
Help {HELP}
Home {HOME}
Insert {INSERT}
Left Arrow {LEFT}
Num Lock {NUMLOCK}
Page Down {PGDN}
Page Up {PGUP}
Right Arrow {RIGHT}
Scroll Lock {SCROLLLOCK}
Tab {TAB}
Up Arrow {UP}
F1 {F1}
F2 {F2}
F3 {F3}
F4 {F4}
F5 {F5}
F6 {F6}
F7 {F7}
F8 {F8}
F9 {F9}
F10 {F10}
F11 {F11}
F12 {F12}
F13 {F13}
F14 {F14}
F15 {F15}
F16 {F16}

Current date {Date:format string}
Current time {Time:format string}
Chars dlg {CHARSDLG}
Reboot {EXIT:REBOOT}
Exit Windows {EXIT}
Restart Windows {EXIT:RESTART}
Activate window {ACTIVATE:window title}



Start application {SHELL:filename.exe}



Characters Dialog Box

The characters dialog box (by default, this can be brought up with the <space><space> sequence) provides a dialog 
box by which you can choose the characters that you would like sent to the application.

It is also handy for scanning the characters of symbol and specialty fonts.



Editing A Keyboard Sequence

The Edit Sequence dialog box lets you define the following fields of a JKey sequence:
Sequence    the characters that will result in a valid sequence and cause the Result field to be sent to the active 
application. This field is required.

Case Sensitive    A Yes or No field that indicates if the Sequence is case sensitive or not. This field is required.

Result    the result of the sequence that will be sent to the active application. See Macros and Keystrokes. This field is
required.

Font    the suggested font to use to achieve the desired result. May be left blank, indicating that the font is relevant. It 
also sometimes handy to put the fontname here but with a preceding quote so that the result string is NOT rendered 
with the font.

Application    the specification application for which this result should be used. May be left blank, indicating that this 
sequence is valid for any Windows application.

Comment    may be left blank



Date and Time Format String

JKeys uses the Visual Basic Format function to format dates and times. That function allows the following formatting:

Long Date long date format defined by Control Panel
Medium Date short date format defined by Control Panel, but with month spelled
Short Date short date format defined by Control Panel

Long Time long time format defined by Control Panel
Medium Time hours and minutes,12 hour format with AM/PM
Short Time 24 hour format

d day as a number without a leading zero (1-31)
dd day as a number with a leading zero (01-31)
ddd day as an abbreviation (Sun)
dddd day as a fullname (Sunday)

w day of the week as number (1-7)
ww week of the year as number (1-53)

m month as number without leading zero (1-12)
mm month as number with a leading zero (01-12)
mmm month as an abbreviation (Feb)
mmmm month as a fullname (February)

q quarter of the year as a number (1-4)

y day of the year as a number (1-366)
yy year as a two digit number (00-99)
yyyy year as a four digit number (100-9999)

h hour without leading zero (0-24)
hh hour with leading zero (00-24)

n minute without leading zero (0-59)
nn minute with leading zero (00-59)

s seconds without leading zero (0-59)
ss seconds with leading zero (00-59)

AM/PM AM or PM
am/pm am or pm
A/P A or P
a/p a or p




