
Contents
 Introduction
 Basics
 Quick Start Tutorial
 Figures
 Connectors
 Labels
 Connector Labels
 General Editing
 Text
 Getting Around in a Diagram
 Figure Styles
 Label Styles
 Connector Styles
 Diagram Settings
 Options
 File Operations
 Glossary
 Index



Introduction
EDGE Diagrammer understands what makes diagrams special. It knows how parts of a diagram 
relate to one another, what items should stay connected, what items should line up, what items 
should remain attached, and so on. By eliminating the tedious tasks, EDGE frees you to concentrate 
on the diagram itself rather than on the process of creating it.

EDGE Diagrammer keeps track of a group of figures (shapes) that make up a particular type of 
diagram. It remembers how figures are connected, combined with text, and arranged. EDGE also 
helps you add text anywhere on your diagram including within figures. When you edit text in a figure, 
EDGE can cause the figure to grow automatically to fit perfectly to the new amount of text. If you 
move a figure, EDGE can automatically adjust any lines that are connected to that figure. When 
these lines move, EDGE can move any labels connected to the lines.

EDGE Diagrammer is great for flowcharts, org charts, and block diagrams. However, it is also useful 
for custom diagrams. You can decide how objects look and behave in your custom diagrams. EDGE 
doesn't presume to know exactly how you want to diagram. Rather it attempts to provide the most 
complete set of diagramming features possible, giving you freedom to diagram in the way that is best
for you.



Basics
You'll need to know the following topics in order to use EDGE Diagrammer effectively.

The Diagram
Diagram Components
Styles and Properties
Using the Mouse
Using Controls
The Workspace
The Style Bar
The Snap Grid
Modes



The Diagram
We use the term diagram in a slightly different way than you might be accustomed. Ordinarily, the 
term diagram can refer to nearly any type of illustration. The things that EDGE Diagrammer creates 
are a little more specific. For instance, a pie chart, bar chart, or a table might legitimately be 
described as diagrams, but they do not fall within the narrower definition of EDGE Diagrammer 
diagrams.

To EDGE Diagrammer, a diagram is a collection of symbols which we'll call figures, PLUS a 
collection of lines (often with arrowheads) which we'll call connectors, PLUS any text that the user 
might want to add. The combination of these simple components with an ample number of styles and
customizations leads to a very powerful and flexible model. With this model you can build diagrams 
that show complex procedures, demonstrate plans, express ideas, organize thoughts, present 
proposals, record decisions, and much more. As the EDGE product line continues to evolve, the 
scope of its diagrams will continue to grow.



Diagram Components
Figures

Figures are the primary components of a diagram. They often represent steps in a process or 
components of a design. A figure can have any shape or design such as a circle, square, or 
illustration.

Connectors

Connectors are lines that connect two figures. They usually represent a path between two figures or 
some other relationship between figures. Each end of a connector can have an attached shape such 
as an arrowhead.

Junctions

Junctions are the points at which multiple segments of a connector meet. Junctions make it possible 
for a connector to bend around corners, wrap around figures, and connect to other connectors.

Labels

Labels are stand-alone text objects that serve as titles, annotations, and paragraphs. You can place 
any number of labels anywhere in a diagram.

Connector Labels

Connector labels are special labels which attach themselves to a connector and remain attached 
when you move the connector.



Styles and Properties
Styles
EDGE Diagrammer objects start from an object style - a set of default properties and characteristics. 
EDGE Diagrammer styles are a lot like paragraph styles in word processors. Rather than describing 
paragraphs, they describe figures, labels, and connectors.

Figure styles
A figure style contains a figure symbol definition plus stylistic attributes such as colors, text 
justification, and border width. A figure style also contains a set of rules that define how figures of the 
style behave and interact with other objects.

Figure Symbols
Figure symbols are mathematical definitions that describe the shape of the figure and the location of 
any text regions within the figure. EDGE Diagrammer comes with over a hundred figure symbols 
from which you can build figure styles of your own. You can also create custom figure symbol 
definitions for your unique needs.

Label Styles
Label styles are very similar to figure styles except they include only those attributes which apply to 
labels.

Connector Styles
A connector style contains a connector end symbol definition for each end plus a number of stylistic 
attributes such as colors and width. A connector style also contains a set of rules that define how 
connectors of the style behave and interact with other objects.

End Symbols
End symbols are mathematical definitions that describe the shape of either end of a connector (for 
example an arrowhead). EDGE Diagrammer comes with several predefined end symbols from which
you can build connector styles of your own. You can also create custom end symbol definitions for 
your unique needs.

Properties
An individual object such as a figure, label, or connector, has its own properties which it initially 
receives from an appropriate object style. For example, fill color is a property of a particular figure. 
The initial color comes from the figure style definition used to create the figure. You can change the 
fill color of this figure either by changing the figure style from which it was created (which also affects 
all other figures created from that style), or by changing the fill color property of the particular figure 
alone. 



Using the Mouse
EDGE Diagrammer requires a mouse or trackball. Any standard mouse installed in Windows will 
work fine. EDGE uses the mouse like most other Windows programs. The left mouse button is used 
for clicking on objects and choosing commands.

Right mouse button (shortcuts)
If you press the right mouse button while in Select mode or Seltext mode (modes are explained 
elsewhere), a small menu appears near the cursor. You may then choose from a number of 
frequently used commands that make sense at the time. For example, if you select a single figure 
and press the right mouse button, the menu contains features that apply to that figure. When you 
press the right mouse button while in any other mode, it serves as a shortcut method to return to 
Select mode (or Seltext mode if you used that mode last.)



Using Controls
In general the user interface controls are standard Windows controls like buttons, scroll bars, list 
boxes, pull-down lists, and so on. These work just like you would expect. If you are unfamiliar with 
these basic controls, refer to your Windows documentation. EDGE Diagrammer also has a few 
unique controls that require some additional explanation.

Pick menus
Pick menus are special buttons like the "Figures>>" button that cause a menu to pop-up when you 
press the button down. The menu contains some number of graphical selections to choose from. You
simply move the mouse over your choice and release the mouse button. Pick menus are also used 
for colors and line styles.

Edit Boxes
Some edit boxes have special behaviors. When entering a measurement, you can type "3 in." to 
mean three inches, but you can also type "3.0 inches", or just "3"; all are equivalent. Your entries are 
always assumed to be in the current measurement units (inches or centimeters). If the field expects 
inches and you enter "3 ft." or "3 cm", it is treated as three inches. The same goes for point 
measurements for text size and line thicknesses. If a point measurement is called for, you can enter 
"2 pts" or "2 points" or "2.0", and so on.



The Workspace
In addition to the display area for the diagram, the EDGE Diagrammer workspace contains the 
following components.

Title bar
Shows the program name and the name of the active diagram.

Tool bar
Contains buttons that provide easy access to frequently used commands.

Style bar
The area on the left of the screen that contains controls to access label, figure, and connector styles.

Message bar
The area along the bottom of the workspace that shows brief help information and the zoom 
magnification.

Scroll bars
Show your position in the diagram and allow you to move around.

Rulers
Show real-life measurements of the diagram.



The Style Bar
The style bar is the area to the left of the diagram that contains controls to access label, figure, and 
connector styles. The purpose of the style bar is to make it very easy to choose a style to create an 
object.

The style bar contains three main sections, one for labels, one for figures, and one for connectors. If 
the diagram contains no styles of one of these types, the section will not appear in the style bar. 
Each of these sections contains three types of controls, all of which do the same thing in different 
ways!

Style pick menu
At the top of each section is a Style Pick Menu button. You use this button to choose a style from a 
pick menu, a pop-up menu that contains a graphic representation of every style of the type in this 
section. When pressed, it expands to show the styles:
The graphic representations in the pick menu are only approximations of the styles. For example, 
they do not include line thickness.

Style combo box
Under the pick menu button is the style combo box. This control serves two purposes. The style 
combo box displays the name of the current style if one is selected. It also allows you to change the 
style by picking another style by name. The end result is the same as if you had used the pick menu 
to choose the style.

Style bar buttons
Under the style combo box are optional style bar buttons. Each style bar button represents a single 
style. You can choose the style by simply pressing the button.
Though style bar buttons are the easiest way to choose a style, they also take up a lot of room. 
Therefore, they typically represent only the most frequently used styles. The representation of the 
style is only approximate. For example it does not show color.

Customizing the style bar
For each style, you can choose whether or not it has a style bar button.
You can also control the width of the style bar, the number of style bar buttons in each row, and the 
height of the buttons. These settings are saved with each diagram.

Changing style bar layout



Changing style bar layout
You can control the appearance of the style bar so that it is most appropriate for each diagram.    You 
can adjust the width of the whole style bar, the height of style bar buttons, and the number of buttons 
per row.

To change the width of the style bar
1 Hold down the SHIFT key and move the mouse over the right hand edge of the style bar. The 

style bar sizing cursor replaces the standard cursor.
2 While holding the SHIFT key, press the left mouse button and keep it held.
3 Drag the mouse to the left or right to change the size of the style bar.
4 Release the mouse button.

The style bar sizing cursor.
To change the height of style bar buttons and the buttons per row
1 Hold down the SHIFT key and move the mouse over the lower right hand corner of a style bar 

button. The style bar button size cursor replaces the standard cursor.
2 While holding the SHIFT key, press the left mouse button and keep it held.
3 Drag the mouse to choose the height of the buttons and the number of buttons per row (indicated

by the dotted lines).
4 Release the mouse button.

The style bar button size cursor.



The Snap Grid
The snap grid is a very powerful tool that helps you line up figures in your diagram. The snap grid 
contains two components that you can use together or separately, the visible grid and the snap grid.

The visible grid
The visible grid is a grey-colored set of horizontal and vertical grid lines that appear behind your 
diagram. By itself, the visible grid is only a visual aid, it does not have ANY effect on your 
diagramming. You can control the grid spacing by choosing Properties from the Diagram menu. All of
the grid lines may not always be visible. When you zoom way back, grid lines that would appear too 
close to one another on the screen drop out.

You can turn the visible grid on and off by pressing the tool bar button that looks like a grid or by 
checking Show Grid in the Diagram menu.
The snap grid
The snap grid is NOT visible but when enabled it does affect your diagramming. The snap grid 
automatically controls where figures and connectors can be placed and how large figures can be. For
example, if you set the snap spacing to a half inch, you can only place figures at exactly one half inch
intervals. Therefore, you know that if two figures look lined up they are lined up, if they look the same
size they are the same size, if a line looks straight it is straight. When you print your diagram you 
won't be surprised to find that what looked right on the screen is slightly wrong on paper.

You can turn snap on and off by pressing the tool bar button that looks like a magnet or by checking 
Snap in the Diagram menu. You can control the snap spacing by choosing Properties from the 
Diagram menu.
You can use either the visible grid or the snap grid without using both. However, when you use both 
together, you get the greatest benefit. Most often, you will want to choose a grid spacing that is larger
than your snap spacing, twice as large is the default



Modes
While you are working in EDGE Diagrammer, you are always in one of several modes. There is a 
mode for selecting and moving objects, a mode for creating figures, a mode for creating labels and 
editing text, a mode for creating connectors, and a mode for zooming into a certain area of a 
diagram. You'll enter each mode to perform certain operations. Following is a brief summary of each 
mode.

Select Mode
The default mode is select mode. In this mode you can select objects, move objects, size objects, 
and perform many other functions. You will probably spend most of your time in this mode since this 
is the mode in which most features are available.

To enter select mode, click on the select mode tool bar button. You can tell that you are in select 
mode when the select mode tool bar button is pressed and the select cursor appears.

The select mode cursor.
Text Mode
You enter text mode to work with text. In this mode you can create labels, add text to figures, and edit
figure text.

To enter text mode, click on the button in the text mode tool barbutton. You can tell you are in text 
mode when the text mode button in the tool bar is pressed and the text cursor appears. You will also 
enter text mode if you select a label style from the style bar.

The text mode cursor.
SelText Mode
This mode is a special combination of text mode and select mode. It is just like select mode except 
that you can also edit text as if you were in text mode. 
Using this mode rather than select mode will prevent you from having to switch modes as often. The 
trade-off is that both selection and text editing require more precise pointing with the mouse.

To enter seltext mode, click on the tool bar button that looks like an arrow and the letter "T" together.  
The cursor is the same as the select mode cursor.
Zoom Mode
You enter zoom mode to zoom in to a part of your diagram and view it in greater detail.

 To enter zoom mode, click on the zoom mode button in the tool bar.

The zoom mode cursor.
Figure Create Mode
You enter figure create mode to create figures in your diagram of a chosen figure style. To enter 
figure create mode, select a figure style from the style bar. There is no button on the tool bar 



because you must indicate the style of figure you want to create.

You can tell you are in figure create mode when the cursor is in the shape of a figure or the create 
figure cursor shown below. If the figure style you are creating has a button on the style bar, that 
button will be pressed as well.

The create figure cursor.
Connect Mode
You enter connect mode to create connectors in your diagram of a chosen connector style. To enter 
connect mode, select a connector style from the style bar. There is no button on the tool bar because
you must indicate the style of connector you want to create. The connect cursor appears. If the 
connector style you are creating has a button on the style bar, that button will be pressed as well.

The connect cursor.



Quick Start Tutorial
This section is a tutorial that leads you through the creation of a very simple diagram. You will learn 
the basic functionality of EDGE Diagrammer and become comfortable with its use. Before continuing,
we suggest that you read the previous sections called Introduction and Basics.

Install EDGE Diagrammer if you have not yet done so.    Don't worry, you can uninstall later if you 
want to remove the program from your computer.

See Installing EDGE Diagrammer
See Uninstalling EDGE Diagrammer
Jump Label
Start EDGE Diagrammer by double clicking on the EDGE Diagrammer icon in the Pacestar Software 
program group. You'll now see the basic workspace.    We'll proceed to create a very simple diagram 
step-by-step.

Step 1: Create a diagram
Step 2: Create a figure
Step 3: Create a second figure
Step 4: Create a connector
Step 5: Add text to a figure
Step 6: Move a figure
Step 7: Save the diagram
Step 8: Exit
You should now have a good idea of what EDGE Diagrammer does and how it is used. Of course, 
we've just scratched the surface of the available features and commands.



Installing EDGE Diagrammer
Before you can run EDGE Diagrammer, you must install it on your computer from the program floppy
disk.

To install EDGE Diagrammer on your computer
1 Insert the program diskette into a floppy disk drive. We'll assume the floppy disk drive is A:. If 

yours is different substitute your drive letter where necessary.
2 From the Windows Program Manager, choose Run from the File menu.
3 Type "a:setup" and press the OK button.
4 Follow the instructions as directed.
The installation and setup process will create a Windows program group called Pacestar Software 
with a program item labeled EDGE Diagrammer.    You can run EDGE Diagrammer by double clicking
on the icon.



Uninstalling EDGE Diagrammer
You can remove EDGE Diagrammer completely from your computer by taking the following steps.

To uninstall EDGE Diagrammer
1 Delete the C:/WINEDGE directory and all subdirectories.
2 Delete the EDGE.INI file from your /WINDOWS directory.
3 Delete the Pacestar Software program group from the Program Manager.



Step 1: Create a diagram
At this point, you can either open an existing diagram or create a new diagram. We'll create a new 
one now.

Create a new diagram
1 Choose New from the File menu. A dialog box will appear prompting you to choose a diagram 

template as the starting point for your diagram.
2 Click on FLOWCHRT.EDG and then click OK.
A new blank flowchart appears in the main window area. You can now add figures, labels, and 
connectors to the diagram using the styles from the diagram template.

Proceed to step 2



Step 2: Create a figure
The next step will be to create a figure for the first time.

Create a figure
1 Locate the figure style buttons on the Style bar under the button marked Figures>>.
2 Click on the upper left figure style button, the rectangle.
3 Move the mouse pointer over the diagram area to where you want to create the figure.
4 Click the left mouse button (press and release immediately). A new figure will be created where 

you clicked.
The diagram now contains a single rectangular figure.

Proceed to step 3



Step 3: Create a second figure
Now we'll create a second figure of the same type.

Create another figure
1 Move the mouse to another position on the diagram (near the previous figure).
2 Click again to create a second figure.
The diagram now contains two rectangular figures.

Proceed to step 4



Step 4: Create a connector
Next we'll connect the two figures we just created with a connector.

Create a connector
1 Locate the connector style buttons on the style bar under the button marked Connectors>>.
2 Click on the upper right connector style button, the one with a simple arrow pointing to the right.
3 Move the mouse pointer over the first figure you created and click the left mouse button.
4 Move the mouse pointer over the second figure you created and click the left mouse button 

again. A new connector will be created connecting the two figures together.
The diagram now contains two rectangular figures connected by an arrow.

Proceed to step 5



Step 5: Add text to a figure
More often than not, you'll want to add text to figures. We'll now add some simple text to one of the 
figures we just created.

Add text to a figure
1 Enter text mode by clicking on the button in the tool bar that has a capital letter "T". The text 

cursor appears.
2 Move the mouse pointer over one of the figures you created in the previous steps. The cursor will

change to a text cursor surrounded by a box to indicate that clicking here will edit the text of the 
figure located below the mouse pointer.

3 Click the left mouse button. The cursor will be replaced by a flashing text caret near the center of
the figure.

4 Type a small amount of text such as your name.
5 Exit text mode by clicking on the select mode button in the tool bar that looks like a standard 

cursor (an arrow pointing up and to the left.)
The diagram now contains two rectangular figures connected by an arrow.
At this point, you are in select mode having created a figure with some text connected by an arrow to
a figure without any text.

Proceed to step 6



Step 6: Move a figure
We'll now move one of the figures to demonstrate how EDGE Diagrammer keeps figures and their 
text together and how it keep connected figures together.

Move a figure
1 Make sure you are in select mode (the cursor looks like the standard Windows cursor and the 

tool bar button with a picture of a standard cursor is depressed.)
2 Move the mouse pointer above the figure that contains the text and click the left mouse button 

(press and release immediately). The figure will now appear with eight red handles indicating it is
selected.

3 Move the mouse pointer over the selected figure. The move cursor appears. (It points in four 
directions).

4 Press and continue to hold the left mouse button.
5 Without releasing the button, drag the figure to another location.
6 Release the mouse button. The figure moves to the new location.

Notice that moving the figure also moved the connector so that the two figures remain connected.    
Also notice that the figure's text moves with the figure.

Proceed to step 7



Step 7: Save the diagram
We've now created a very simple diagram. We'll finish up by saving the diagram and exiting the 
program.

Save the diagram
1 Choose Save As from the File menu.
2 Enter a file name such as DIAGRAM.EDG.
3 Press OK.
The diagram is now saved.    You can later return to the diagram by using the Open feature and 
choosing the DIAGRAM.EDG file that you saved above.

Proceed to step 8



Step 8: Exit
Finally, we'll simply quit the program.

Exit EDGE Diagrammer
1 Choose Exit from the File menu.
Done



Figures
Figures are the building blocks of diagrams. Figures can have any geometric shape like a rectangle, 
circle, or triangle, or they can have the shape of a person, a computer, a phone, or anything else. 
Figures can also have one or more rectangular areas for text and can be connected together by 
connectors.

Creating Figures
Changing the Size of Figures
Moving Figures
Aligning Figures
Making Figures the Same Size
Sizing Figures to Text
Spacing Figures Evenly
Centering Figures on the Page
Changing Figure Properties
Advanced Properties



Creating Figures
Creating a new figure takes a few simple steps. You choose a figure style to provide the initial shape 
and properties of the figure, then you use that style to create a figure on the diagram.

To choose a figure style and initiate create mode
· Click on the style bar button that represents the figure type you want to create. If the style you 

want does not have a button in the style bar, you can use one of the following methods instead.
· OR, Press and hold the Figures>> button in the style bar to activate the figure style pick menu. 

Move to the representation of the style, and release the mouse button.
· OR, Choose the figure style by name from the figure style combo box.
If the figure style has a default size, the cursor becomes an outline of the figure when you move the 
mouse over the diagram. Otherwise the create cursor appears.

To create a new figure
1 Use the mouse to position the new figure.
2 Press the mouse button.
3 If the figure has a default size and you want to create a figure of this size, release the mouse 

button immediately. Otherwise, while continuing to hold the mouse button, resize the figure to the
desired size. Before releasing the mouse button, you can press ESC to cancel.

4 Release the mouse button
If the figure has default text, the newly created figure will contain the default text.



Changing the Size of Figures
A figure can be any size from a sixteenth of an inch to a hundred inches in height and width. You can 
size a figure as you create it. You can also change the size of an existing figure.

To change the size of a figure
1 Select the figure.
2 Move the mouse over one of the eight red handles. The cursor's shape indicates how the figure 

will size with each handle.
3 Press the mouse button.
4 Drag the handle and resize the figure to the desired size. If you decide to cancel at this time 

before releasing the mouse button, press ESC.
5 Release the mouse button.
How the figure resizes depends on several things. If the figure has the Center Remains Stationary 
When Resizing property, then the figure gets larger or smaller in all directions as you drag the 
handle, but the center stays in the same place. If the figure does not have this property, it extends 
only in the direction that you drag the handle.

If snap is enabled and the figure has the Height and Width Snap to Grid property, the height and 
width can only change such that the edges of the figure are positioned along snap grid lines. In 
effect, this means that the height and width will always be a factor of twice the snap spacing.

If the figure contains text, you will not be permitted to resize the figure such that it will be too small to 
contain the text. If the figure has the word-wrap property, the text will reformat when you resize the 
figure, therefore there is no minimum width.

There are also other ways to change the size of a figure. When you type text in a figure, the figure 
can resize automatically. You can change the size of figures by using the Make Same Size feature. 
You can also set the height and width of figures explicitly in the Figure Properties dialog box.



Moving Figures
There are several ways to move figures from one place in a diagram to another. When you move a 
figure, all text that is part of the figure, and all connectors that are attached to the figure move as 
well.

To move a single figure without first selecting it
1 Make sure you are in select mode.
2 Move the mouse over the figure. The move cursor appears.
3 Press the mouse button.
4 Drag the figure to a new location and release the mouse button.
The procedure above works from seltext mode as well as from select mode. However, if you are in 
seltext mode, but be sure that the cursor is actually over a figure and not over a text area within the 
figure before attempting to move it this way. You can tell that you can move the figure when the move
cursor appears.

To move one or more selected figures
1 Move the mouse cursor over any selected figure. The move cursor appears.
2 Press the mouse button.
3 While holding the mouse button down, drag the figures to the new location. While dragging the 

figures, you can cancel by pressing ESC before releasing the mouse button.
4 Release the mouse button.
To move selected figures more precisely
1 Enter select mode.
2 Select one or more objects.
3 Use the up, down, right, or left arrow keys on the keyboard to move the objects a small 

increment in any direction.
The amount the objects move each time you press an arrow key depends on the snap-to-grid 
diagram property (the button on the tool bar that resembles a magnet). With snap enabled, each 
press of an arrow key moves the objects by a distance equal to the snap grid spacing. Otherwise, the
objects move by one screen pixel.

There are many other ways to move figure indirectly such as aligning, centering on the page, 
spacing, and so on. You can also set the location of figures explicitly in the Figure Properties dialog 
box.



Aligning Figures
To align a group of figures
1 Select the figures.
2 Choose one of the selected figures to be the model figure, the figure with which the other 

selected figures are aligned. By default the last figure selected is the model figure. To force a 
different selected figure to become the model figure, hold down the SHIFT key and click on a 
different figure.

3 Choose one of the alignment methods from the Align submenu under the Figures menu.



Making Figures the Same Size
EDGE Diagrammer contains many aids for creating figures with a uniform size. One way is to use 
the figure style default size property and another is to use the snap grid. If you still end up with 
figures of different sizes that you wish to make the same, you can use the Make Same Size feature.

To make a number of figures the same size
1 Select the figures.
2 Choose one of the selected figures to be the model figure, the figure whose size indicates the 

size to make the other selected figures. By default the last figure selected is the model figure. To 
force a different selected figure to become the model figure, hold down the SHIFT key and click 
on a different figure

3 Choose one of the sizing methods (Height, Width, or Both) from the Make Same Size submenu 
under the Figures menu.

All of the selected figures will become the same size as the model figure.
There are cases where a figure cannot be made the exact size as the model figure. One example is 
a figure that has more text than would fit in the figure if it were made as small as the model figure. In 
this case, the figure is made as small as possible.



Sizing Figures to Text
A figure can be no smaller than the text it contains. Occasionally you may want to make a figure as 
small as possible for the current text. You can do this by dragging the figure's sizing handles, or more
conveniently by using this feature.

To adjust the size of a figure to the text it contains
1 Select a figure (or group of figures).
2 Choose Size to Text from the Figures menu.
Each selected figure will shrink to the smallest size possible for its text. If the snap grid is enabled 
and the figure's properties cause its height and width to snap to the grid, the figure's size may not be 
as small as possible to contain the text. If this is not the effect you want, turn off the snap grid first. If 
you want a figure to remain sized to its text automatically when the text changes, you can set its 
Keep sized to text property.



Spacing Figures Evenly
The snap grid is very useful for spacing figures across the diagram or from top to bottom at equal 
intervals. The Space Evenly feature is useful for this same purpose.

To space a group of figures evenly from left to right or top to bottom
1 Select at least three figures.
2 Choose either Across or Down from the Space Evenly submenu under the Figures menu.
3 The selected figures will be spaced evenly from right to left if you chose across, or top to bottom 

if you chose down.
 
The spacing is determined by the average spacing between the right-most and left-most of the 
selected figures (in the across case), therefore the left-most figure does not move. The space is 
measured from the center of one figure to the center of another, not by the amount of space between
the edges of figures. If the snap grid is enabled, the spacing between figures is an even multiple of 
the snap spacing. The left-to-right or top-to-bottom ordering of the figures does not change.



Centering Figures on the Page
You can use this feature to center a group of figures on the page, length-wise, width-wise or both. 
This feature is only available if you have Show Page Boundaries checked under the Options menu.

To center figures on the page
1 Select a group of objects (not necessarily only figures).
2 From the Center on Page submenu under the Figures menu, choose the icon that represents 

length-wise centering, width-wise centering, or both.
3 All selected objects are centered as a group on the current page.
Note that when you center many objects on the page, they do not all end up overlapped at the center
of the page. Rather, they are centered as if they were one larger object (as a group). This feature is 
especially useful for final formatting of your diagram. For example, when your diagram is complete, 
you can Select All and then Center on Page, neatly centering your entire diagram on the page for 
printing.
If you have multiple pages defined (postering), the objects are centered relative to the whole poster 
rather than a single page. You should also be aware that if you change the print set-up, such as the 
paper size, the orientation, or even the printer, page dimensions can change and you will probably 
have to re-center your diagram.



Changing Figure Properties
Each figure has a set of properties that define how it looks, how it behaves, and where it's located 
within the diagram. Most of the initial properties of a figure come from its original figure style. This 
section describes how to change the figure properties.

To view and modify the properties of a figure
1 Select the figure.
2 Choose Properties from the Figures menu or from the right mouse button menu.
Or
1 Double click on the figure (whether selected or not).
Use the Figure Properties dialog box to view and modify the figure's properties.

Figure Properties Dialog Box



Figure Properties Dialog Box
Use the Figure Properties Dialog Box to view and modify the properties of one or more figures.    To 
cause a particular property to be applied to the selected objects, you must actually modify that 
property. For example, if you select five figures that all have different heights and widths, and you 
edit their properties and change only the Width field not even touching the Height field, all five figures
will acquire the new width and retain their previous height.

Left
To change the position of the figure, enter a new location for the left-most edge. The value is the 
distance from the origin point on the ruler bar (0,0) or equivalently from the left edge of the page 
(positive measurements are to the right).

Top
To change the position of the figure, enter a new location for the top-most edge. The value is the 
distance from the origin point on the ruler bar (0,0) or equivalently from the top edge of the page 
(positive measurements are downward).

Width
To change the width of the figure, enter a new width.

Height
To change the height of the figure, enter a new height.

Border
To change the thickness of the lines that make up the border (outline) of the figure, enter a new 
border width.

The exact point size you want is not always available. For example, 10 points is not valid and is 
rounded to 10.25 points.

Style
To change the figure's style, pick a new style from either the combo box or the figure style pick menu.

Bind to style
Check this box to choose whether or not a figure's properties are bound to the style. If a figure's 
properties are bound to its style, then anytime the style properties change, the figure gets the new 
properties automatically. You will generally want to set this option for figures.

Text Color
To change the color of the figure's text, choose a different color from the current palette. You can 
change the palette by selecting Set Color Palette from the Diagram menu. Text must be a color that 
can be drawn solid on your screen. If you select a color that cannot be drawn solid, Windows draws 
the text in the nearest solid color.

Border Color
To change the color of the figure's border, choose a different color from the current palette. Borders 
must be a color that can be drawn solid on your screen. If you select a color that cannot be drawn 
solid, Windows draws the text in the nearest solid color.



Fill Color
To change the color of the interior of the figure, choose a different color from the current palette.

Drop Shadow
Check this box to add a drop shadow to the figure to give it a three-dimensional look. All drop 
shadows in a diagram are the same size and color. You control the size from within the Diagram 
Properties dialog box, and the color from the Set Colors dialog box.

Font
Press this button to change the font style and size of the text in the figure. A dialog box appears that 
contains all of the fonts available on your system. You can choose the font, its size, and whether to 
make it bold or italic.

Advanced
Press this button to access and modify the advanced properties of the figure.

See Advanced Properties Dialog Box
Text
Press these buttons to modify the justification of the figure's text. Text can be left, center, or right 
justified within a figure, and it can be top, center, or bottom justified. This is the same as using the 
similar buttons from the main tool bar.

OK
Press OK when you've made your changes to the figure's properties. The selected figure acquires 
the new properties.



Advanced Properties Dialog Box
Line too long
This property controls what happens when typed becomes too wide for the figure. If set to Prevent, 
additional characters are not allowed. If set to Expand, the figure automatically grows wider as you 
continue typing. The direction of expansion is controlled by the Growth property. If set to Wrap, the 
width of the figure does not change and the text word-wraps automatically to the next line.

Too many lines
This property controls what happens when typed text exceeds the number of lines that fit in a figure 
of this style. If set to Prevent, additional lines are not allowed. If set to Expand, the figure 
automatically grows taller as you add lines. The direction of expansion is controlled by the Growth 
property.

Growth
This property controls in which directions the figure will grow when it grows automatically, such as 
when the text causes the figure to expand. Use the icon buttons to choose directions for horizontal 
and vertical expansion.

Center remains stationary when resizing
Check this property to cause the center of the figure to remain in the same place when you resize it 
by dragging the handles. You will generally want to set this property for figures that can be connected
to other figures.

Center snaps to grid
Check this property to cause the figure's center to snap to the snap grid when you create, move, or 
resize it (provided snap is enabled). You will generally want to set this property for figures that are 
connected to other figures, otherwise it could be more difficult to keep the figures aligned vertically or
horizontally.

Height and width snap to grid
When this property is checked (and the snap grid is enabled), the figure's edges align with the snap 
grid when you create, move, or resize the figure. If you set this property, you'll want to set the Center 
snaps to grid property as well.

When the height and width snap to the grid, both sides are aligned with snap grid lines which are not 
necessarily the same as the visible grid lines. In effect, the total width or height is always a multiple 
of twice the snap spacing. For example, if the snap spacing is one quarter of an inch and a figure has
the Height and width snap to grid property, that figure width can be 1/2 in., 1 in., 1 1/2 in. and so on, 
but it cannot be 3/4 in. This behavior helps to keep figures and connectors properly aligned by 
guaranteeing that the center point and all boundaries fall exactly on the grid. If you find this 
disturbing, you might try setting the snap spacing to half the grid spacing.

Keep sized to text
When this property is checked, the figure is always sized to exactly fit the amount of text it contains. 
For example, if you edit text for a figure such that the figure has less text than it had before, the 
figure will automatically resize itself to shrink down around the new text as soon as you complete 
editing the text.



Advanced Properties
Each figure has a set of advanced properties that control behaviors of the figure. The advanced 
properties are separated from the basic properties because they are not only more advanced 
conceptually, but because they are less often used.

To change the advanced properties of a figure
1 Press the Advanced button in the Figure Properties dialog box. This button invokes the 

Advanced Properties dialog box.
2 Change the properties as you like.
3 Press OK to accept the changes.
Advanced Properties Dialog Box



Connectors
Connectors identify relationships between figures. A typical connector is a line between two figures. 
Each end of a connector can have a symbol or geometric shape (commonly an arrowhead). A 
connector can have multiple straight segments that bend and turn corners, and each segment can 
have an attached label. 
The initial properties of a connector come from the connector style used to create it

· Any two figures can be connected by a single connector.
· A single figure may have any number of connectors to other figures.
· Connectors are always straight, they may not curve.
· Connectors remain attached to the figures they connect, even when those figures move.
· A connector need not be connected to a figure at either end.
Creating Connectors
Segmented Connectors and Junctions
Splitting Connectors
Deleting Connector Junctions
Moving the Ends of Connectors
Flipping Connectors
Changing Connector Properties
Thick Connectors



Creating Connectors
Creating a new connector takes a few simple steps. You choose a connector style to provide the 
initial shape and properties of the connector, then you use that style to create a connector on the 
diagram.

To choose a connector style and initiate connect mode
1 Click on the button in the style bar that represents the connector type you want to create. If the 

style you want does not have a button in the style bar, you can use one of the following methods 
instead.

2 OR, Click on the Connectors>> button in the style bar, move to the representation of the style, 
and release the mouse button.

3 OR, Choose the connector style by name from the list box directly below the Connectors>> 
button.

The connect cursor indicates you are in connect mode.

To connect two figures with a connector
1 While in connect mode, move the connect cursor over a figure. The cursor changes from white 

arrow to black indicating that you are about to connect to a figure.
2 Press the mouse button. You can either release the mouse button immediately or keep it pressed

until step four.
3 Move the mouse until it is over the second figure. The cursor color (white or black) indicates 

whether you are over the second figure.
4 Click the mouse button again (or release it for the first time). A connector of the style you chose 

now connects the two figures.
You can also create connectors which are not attached to figures or which are attached at only one 
end to a figure.

To create an unattached connector
1 While in connect mode, move the mouse cursor to a position NOT over a figure. The white 

connect cursor indicates that you are not over a figure.
2 Press the mouse button. You can either release the mouse button immediately or keep it pressed

until step four.
3 Move the mouse to the point at which you want the other end to terminate (not over a figure).
4 Double click the mouse to force the end of the connector.
When you are creating a connector, you also have the option of attaching either end of the connector
to the middle of a previously existing connector.

To connect to another connector
Create the connector as described above but click either end on an existing connector. The previous 
connector is split in two and a junction is created with the new connector.



Segmented Connectors and Junctions
A connector can be more than a simple straight line. It can have multiple straight segments that meet
at junctions where the connector can turn and bend along its path.

To create a multi-segment connector
Create a connector by any of the usual methods. Instead of clicking the end in a figure or connector, 
click it where it is not above another object (do not double click or the connector will terminate.) A 
junction appears and a new segment of the connector forms. Add up to fifty segments this way. 
Finally, click on a figure or double click while not on a figure to terminate the connector.

To select a multi-segment connector
Select a multi-segment connector just like any other object. If you select any segment of a connector 
or any junction of a connector, the entire connector (all segments) becomes selected. However, all 
junctions do not necessarily become selected.

Selected junctions are indicated by four corners of a small red box.

You can always re-arrange the connector by dragging any of its handles. If however, you drag a 
selected junction, all selected junctions and figures move together.



Splitting Connectors
You can split a single-segment connector into a multi-segment connector and create a junction in the 
process.

To split a connector
1 While pressing and holding the ALT key, move the mouse over the connector at the point you 

want it split.
2 While still holding the ALT key, press the mouse button. A new junction appears where the mouse

points. Before releasing the mouse button you can move the new junction.
3 Release the mouse button.
You can repeat this process over and over to create any number of junctions and segments.



Deleting Connector Junctions
You can rejoin segments of a connector by deleting junctions. When you delete a junction, the two 
segments on either side join to form a single segment.

To remove a segment of a connector
1 Select the junction that connects the two segments.
2 Choose Delete Junctions from the Edit menu.
When you delete a junction, two segments join to become one. Either or both of these segments 
could have an attached connector label. If just one of the segments has a connector label, the label 
moves to the final segment. If both original segments have attached connector labels, one moves to 
the final segment, the other is deleted.
Naturally, you can select and delete any number of junctions at a time.



Moving the Ends of Connectors
You can move either of the endpoints of a connector. If the endpoint is connected to a figure, you can
detach it from the figure, or attach it to a different figure.

To move one end of a connector
1 Select the connector. Red handles appear at both endpoints of the connector and at each 

junction if the connector has more than one segment.
2 Move the mouse cursor over one of the handles at the end of the connector. The resize cursor 

appears.
3 Press the mouse button and hold it.
4 Move the end of the connector.
5 Release the mouse button.



Flipping Connectors
You can flip connectors so that the ends swap with one another. Flipping works for simple connectors
and multi-segment connectors as well.

To flip one or more connectors
1 Select one or more connectors to flip.
2 Choose Flip from the Connectors menu.



Changing Connector Properties
Each connector has a set of properties that define how it looks and behaves. Most of the initial 
properties of a connector come from its original connector style. This section describes how to 
change the connector properties.

To view and modify the properties of connectors
1 Select one or more connectors.
2 Choose Properties from the Connectors menu.
Or
1 Double click on the connector (whether selected or not).
Use the Connector Properties dialog box to view and modify the connector's properties.

Connector Properties Dialog Box



Connector Properties Dialog Box
Use the Connector Properties dialog box to view and modify the properties of one or more 
connectors. To cause a particular property to be applied to the selected objects, you must actually 
modify that property. For example, if you select five connectors that all have different colors and 
thicknesses, and you edit their properties and change only the Color field not even touching the 
Thickness field, all five connectors will acquire the new color and retain their previous thickness.

Style
To change the connector's style, pick a new style from either the combo box or the connector style 
pick menu.

Bind to style
Check this box to choose whether or not a connector's properties are bound to the style. If a 
connector's properties are bound to its style, then anytime the style properties change, the connector
gets the new properties automatically. You will generally want to set this option for connectors.

End 1
To change the originating end of the connector, choose a color, size, and end symbol. You can 
choose the color from the current palette. The color does not have to be solid.

End 2
To change the terminating end of the connector, choose a color, size, and end symbol. You can 
choose the color from the current palette. The color does not have to be solid.

Thick
To change the thickness of the connector, enter a thickness or use the up and down arrows to the 
right.

Borders
To change the width of the borders around the connector ends, enter a border width or use the up 
and down arrows to the right.

For borders, thickness, and end size, the exact point size you want is not always available. For 
example, 10 points is not valid and is rounded to 10.25 points.

Style
To change the connector's line style, choose a new line style from the pick menu. Line styles other 
than solid are only allowed for a thickness of a quarter point (thinnest possible).

Color
To change the color of the connector, choose a different color from the current palette. Text must be a
color that can be drawn solid on your screen. If you select a color that cannot be drawn solid, 
Windows draws the connector in the nearest solid color.



Thick Connectors
Normally, connectors are simple lines that show a relationship between two figures. They are 
typically as thin as a quarter of a point to as thick as three points. Connectors that are thicker than 
three points are special and require some special treatment by EDGE Diagrammer.

The shape of connector ends becomes significant when connectors are thick. Normally, connector 
ends are rounded. However, when a thick connector is vertical or horizontal or meets another 
connector at a ninety degree angle, EDGE Diagrammer squares off the ends for a cleaner 
appearance.

The end caps (squared off portions of thick connectors) are restricted to colors that can be drawn 
solid on the output device. One obvious consequence is when you print thick connectors to a black 
and white printer, a connector of any color but black or white may not look as nice as you'd like.

Connector labels are allowed on thick connectors but are a bit tricky and can result in odd-looking 
results if you are not careful. Rather than breaking around the label, thick connectors run right 
through it. You are responsible for choosing contrasting colors for the connector and label. You are 
also responsible for keeping the label in front of the connector. You might want to limit labeling to only
horizontal thick connectors.



Labels
Labels are free-floating words, phrases, sentences, and paragraphs that you can position anywhere 
in your diagram. Labels are very useful for titles, notes, descriptions, and so on. A label consists of 
text and a set of properties such as justification, font, and color. The initial properties of a label come 
from the label style used to create it.

Creating Labels
Deleting Labels
Changing Label Properties



Creating Labels
ParagraphCreating a new label takes a few simple steps. You choose a figure style to provide the 
initial properties of the label, then you use that style to create a label on the diagram.

To choose a label style and initiate text mode
1 Press and hold the Labels>> button in the style bar to activate the label style pick menu. Move to

the representation of the style, and release the mouse button.
2 OR, choose the label style by name from the label style combo box.
3 OR, press the text button in the tool bar to create a label of the most recently used label style.
To create a label
1 Use the mouse to position the new label. The text cursor points to the position where the bottom 

left corner of the label will be located (for a left-justified label).
2 Click the mouse button.
3 Type the label text.
4 When you are done adding or changing the text, you can either press ESC to save your changes

and remain in text mode, press the right mouse button to save your changes and return to select 
mode, or simply click on the diagram to create another label.

To create a label (automatic method)
1 From text mode or select mode or seltext mode...
2 Point the mouse at the location where you want to place the label
3 Start typing text on the keyboard. A label is created automatically containing the text you type.



Deleting Labels
Deleting labels is similar to deleting figures.

To delete a label (standard method)
1 Select the label.
2 Choose Clear from the Edit menu, or press the DEL key.
To delete a label (automatic method)
1 Edit the text in the label, and delete all the text.
2 Labels that contain no text are deleted automatically.



Changing Label Properties
Each label has a set of properties that define how it looks and behaves. Most of the initial properties 
of a label come from its original label style. This section describes how to change label properties.

To view and modify the properties of a single label
1 Select the label.
2 Choose Properties from the Labels menu.
Or
1 Double click on the label (whether selected or not).
Use the Label Properties dialog box to view and modify the label's properties.

Label Properties Dialog Box



Label Properties Dialog Box
Use the Label Properties dialog box to view and modify properties for one or more labels. To cause a
particular property to be applied to the selected objects, you must actually modify that property. For 
example, if you select five labels that all have different heights and widths, and you edit their 
properties and change only the Width field not even touching the Height field, all five labels will 
acquire the new width and retain their previous height.

Left
To change the position of the label, enter a new location for the left-most edge. The value is the 
distance from the origin point on the ruler bar (0,0) or equivalently from the left edge of the page 
(positive measurements are to the right).

Top
To change the position of the label, enter a new location for the top-most edge. The value is the 
distance from the origin point on the ruler bar (0,0) or equivalently from the top edge of the page 
(positive measurements are downward).

Width
To change the width of the label, enter a new width.

Height
To change the height of the label, enter a new height.

Style
To change the label's style, pick a new style from either the combo box or the pick menu.

Bind to style
Check this box to choose whether or not a label's properties are bound to the style. If a label's 
properties are bound to its style, then anytime the style properties change, the label gets the new 
properties automatically. You will NOT generally want to set this option for labels.

Text Color
To change the color of the label's text, choose a different color from the current palette.    Text must 
be a color that can be drawn solid on your screen. If you select a color that cannot be drawn solid, 
Windows draws the text in the nearest solid color.

Font
Press this button to change the font style and size of the text in the label. A dialog box appears that 
contains all of the fonts available on your system. You can choose the font, its size, and whether to 
make it bold or italic.

Advanced
Press this button to access and modify the advanced properties of the label. With labels, you will 
usually want to leave the advanced properties alone and use the defaults.

See Advanced Properties dialog box.
Text
Press these buttons to modify the justification of the label's text. Text can be left, center, or right 
justified within a label, and it can be top, center, or bottom justified. This is the same as using the 
similar buttons from the main tool bar.





Connector Labels
Labels can be attached to connectors to form connector labels. Connector labels are useful for 
describing the purpose of a connector or the relationship that the connector represents between two 
figures.

· A connector can have only one label. Multi-segment connectors, described later in this chapter, 
can have one label per segment.

· The center of a connector label attaches to any point on the connector. When the connector is 
drawn, it breaks around the label rather than going through it.

· The center of a connector label attaches to any point on the connector. When the connector is 
drawn, it breaks around the label rather than going through it.

· The center of a connector label attaches to any point on the connector. When the connector is 
drawn, it breaks around the label rather than going through it..
When the connector moves, any attached connector label moves as well. The connector label 
remains attached to the same point on the connector at the connector's new location.

Creating Connector Labels
Moving Connector Labels
Deleting Connector Labels



Creating Connector Labels
You create a connector label just like an ordinary label except that you attach it to a connector.

To create a connector label
1 Enter text mode by pressing the text mode button on the tool bar or by choosing a label style 

from the style bar.
2 Move the mouse over a connector. The mouse cursor changes (has an X through it)    to indicate 

that you are over a connector.
3 Click the left mouse button to create the connector label.
4 Type in the text for the label.
A single segment of a connector can have only one connector label.



Moving Connector Labels
Once you've created a connector label, you can adjust its position on the connector, or move it to a 
different connector.

To move a connector label
1 In select mode, move the mouse over the connector label. The move cursor appears (points in 

four directions).
2 Press the left mouse button and hold it down.
3 Drag the connector label. The label slides across to the point on the connector nearest the 

mouse, or to a point on a different connector.
4 Release the mouse button. If the label does not move to the new location, there is something 

wrong with the location - the connector may already have a label.



Deleting Connector Labels
Deleting a connector label is just like deleting an ordinary label with a few minor exceptions.

To delete a connector label
1 Select the label.
2 Choose Clear from the Edit menu, or press the DEL key.
Or
1 Edit the text in the label, and delete all the text.
A connector label, like any other label, is automatically deleted when it contains no text.

When you delete the connector to which the label is attached, the label is deleted automatically.



General Editing
Selecting and Deselecting Objects
Moving Objects to the Front and Back
Deleting Objects
Cutting Objects
Copying Objects
Duplicating Objects
Pasting Objects
Undo
Moving Objects
Moving Objects with Precision



Selecting and Deselecting Objects
Most features affect one or more objects, but generally not all objects in a diagram. Before you 
perform a feature, you can select the objects to which the feature will apply.

When an object is selected, its handles become visible as small red squares along the border of the 
object.

Lasso Select
Click Select
Select All
Deselect All
Selecting More Objects



Lasso Select
One way to select objects is to form a lasso around a group of objects. A lasso is a box that you form 
to choose a rectangular area of the diagram.

To lasso select objects
1 Move the cursor to an area of the diagram where there are no objects. The cursor becomes the 

standard arrow shape.
2 Press the left mouse button, keep it held, and move the mouse to form a rectangular lasso area. 

The lasso area displays as a dotted box.
3 Release the mouse button. All objects that are located entirely within the lasso area become 

selected.



Click Select
While in select mode select individual objects by clicking on the objects with the left mouse button. To
select a particular object, move the mouse over the figure, connector, or label and click.



Select All
Select all the objects in a diagram by choosing Select All from the Edit menu.



Deselect All
To deselect all selected objects, click the left mouse button on the diagram where there are no 
objects, or choose Deselect All from the Edit menu.



Selecting More Objects
Normally, if some objects are selected and you attempt to select objects with any of the other 
methods, the previously selected objects become deselected before the new objects become 
selected. If you'd like the previously selected objects to remain selected in addition to the newly 
selected objects, hold down the SHIFT key while selecting. This process is called extending a 
selection.



Moving Objects to the Front and Back
All objects have an order within the diagram. New objects are in front of previously created objects 
and are drawn on top of them. Two features change an object's order in the diagram, and let you 
choose which objects are in front of or in back of other objects.

To move one or more selected objects to the front
1 Select one or more objects.
2 Choose Front from the Edit menu. The selected objects move in front of all other objects in the 

diagram.
To move one or more selected objects to the back
1 Select one or more objects.
2 Choose Back from the Edit menu. The selected objects moves in back of all other objects in the 

diagram.



Deleting Objects
You can remove any objects from your diagram at any time by deleting them. Deleting objects is also
called clearing. Clearing objects is a little different than cutting objects because you cannot Paste 
following Clear. Clear is also slightly faster and does not modify the Windows clipboard.

As a rule of thumb, use Clear to remove objects permanently, and use Cut to remove objects from 
one location and Paste them to another location.

To delete objects from a diagram
1 Select one or more objects to delete.
2 Choose Clear from the Edit menu or press the DEL key.
When you delete selected objects, additional objects may be deleted automatically. For example, if 
you delete a connector, not only will all segments of the connector be deleted, but all connector 
labels that were attached to those segments will also be deleted whether or not they were selected.

If you delete a figure to which a connector is attached, that connector is also deleted. If you want to 
delete a figure but not delete an attached connector, detach the connector first.



Cutting Objects
Cutting is another way to remove objects from a diagram. Unlike clear, a copy of the deleted objects 
is first saved in the Windows clipboard. You can later Paste these objects back into the diagram or 
even into a different diagram.

As a rule of thumb, use Clear to remove objects permanently, and use Cut to remove objects from 
one location and Paste them to another location.

To cut objects from a diagram
1 Select the objects you want to cut.
2 Choose Cut from the Edit menu or press CTRL-X on the keyboard.
Like Clear, when you cut selected objects, additional objects may be cut automatically.

Cut or copied data remains in the clipboard until you cut or copy more data, leave Windows, turn off 
your computer, or if you exit EDGE Diagrammer and request that the clipboard be cleared.



Copying Objects
You can use the Windows clipboard to copy a selected set of objects within the same diagram or to a
different diagram.

To copy objects in a diagram
1 Select one or more objects to copy.
2 Choose Copy from the Edit menu or press CTRL-C on the keyboard.
3 Choose Paste from the Edit menu or press CTRL-V on the keyboard. A copy of the objects 

appear at the center of the screen selected for you.
4 Move the new objects if you want.
If you like, you can Paste the same objects over and over again.

To copy objects from one diagram to another
1 Select one or more objects to copy.
2 Choose Copy from the Edit menu or press CTRL-C on the keyboard.
3 Open a different diagram.
4 Choose Paste from the Edit menu or press CTRL-V on the keyboard. A copy of the objects 

appear at the center of the screen selected for you.
5 Move the new objects if you want.
If you like, you can Paste the same objects over and over again.

See Copying Objects to Other Programs



Copying Objects to Other Programs
In addition to copying objects within and between EDGE diagrams, you can also copy objects from 
EDGE diagrams to other programs such as Microsoft Word. However, since other programs do not 
understand the meaning of EDGE data, EDGE copies the objects to the clipboard in a format that 
many other programs do know, namely a Windows Metafile.

To copy objects from a diagram to a different program
1 Select one or more objects to copy.
2 Choose Copy from the Edit menu or press CTRL-C on the keyboard.
3 Run the target program (MS Word in our example).
4 Choose Paste in the target program.
Cut or copied data remains in the clipboard until you cut or copy more data, leave Windows, turn off 
your computer, or if you exit EDGE Diagrammer and request that it be cleared.



Duplicating Objects
Another faster way to copy objects is to duplicate them. Duplicating does not use the Windows 
clipboard and therefore does not work between different diagrams or between EDGE Diagrammer 
other Windows applications. Use duplicate to make multiple copies of objects within the same 
diagram.

To duplicate objects in the same diagram
1 Enter select mode.
2 Move the mouse over any object or over one in a group of selected objects.
3 While holding down the CONTROL key, drag the objects. A set of duplicate objects appears.
4 Position the duplicate objects and release the mouse button.



Pasting Objects
You can paste objects from the clipboard that were previously placed there by an earlier Cut or Copy 
operation. Pasting is most often the second half of a Cut-and-Paste or Copy-and-Paste operation.

To paste objects from the clipboard
1 Choose Paste from the Edit menu. If the Paste feature is grayed in the menu, it means that there

is no diagram data in the clipboard.
2 A copy of the objects in the clipboard appears at the center of the screen. 

Move the new objects where you want them.
Once you paste objects, they remain in the clipboard so you can paste them repeatedly to create 
multiple copies.



Undo
The undo feature lets you undo a change you made to the diagram. If you make a change by 
mistake, you can reverse the effects of the mistake by using the undo feature immediately. However, 
you can only undo the last operation. Once you execute a second operation, the prior operation 
cannot be undone.

To undo any operation
Choose Undo from the Edit menu. The undo menu item indicates exactly which operation will be 
undone.

Changes you make to styles cannot be undone. It is a good idea to save your diagram before making
any changes to styles.



Moving Objects
Once you've created figures, labels, and connectors in your diagram, you can use the mouse to 
move them around and rearrange them. There are a couple methods available for moving objects.

To move a single object without selecting it first
1 Enter select mode.
2 Move the mouse over an object so that the move cursor appears (it points in four directions).
3 Press the left mouse button and hold it.
4 Move the object to another location.
5 Release the mouse button.
Objects move in accordance with their properties. If the snap grid is enabled and the figure has the 
snap center to grid property, it will only move to points on the grid.

To move a group of selected objects
1 Enter select mode.
2 Select one or more objects to move.
3 Move the mouse over a selected object so that the move cursor appears.
4 Press the left mouse button and hold it.
5 Move the object to another location.
6 Release the mouse button.



Moving Objects with Precision
To move objects with precision
1 Enter select mode.
2 Select one or more objects.
3 Use the up, down, right, or left arrow keys on the keyboard to move the objects a small 

increment in any direction.
The amount the objects move each time you press an arrow key depends on the snap-to-grid 
diagram property (the button on the tool bar that resembles a magnet). With snap enabled, each 
press of an arrow key moves the objects by a distance equal to the snap grid spacing. Otherwise, the
objects move by one screen pixel.



Text
Text plays a very important role in most diagrams. You can use text to add descriptions for figures, 
labels for connectors, titles, comments, annotations, instructions, and so on. EDGE Diagrammer 
allows you to add text just about anywhere quickly and easily.

The Text Area
Text Mode Cursors
Adding Text to Figures and Labels
Editing Text
Selecting Text
Using the Keyboard to Edit Text
Cutting Copying Pasting Text
Replacing Text
Special Considerations for Text



The Text Area
Most figures have an outline shape and reserve the majority of the inside of the shape for text. The 
portion of the figure that is reserved for text is called a text area. You cannot see the text area on the 
screen but it is there, and it is the only part of a figure that can contain text.

A label always has one and only one text area that is the same size as the label. A figure, on the 
other hand, can have any number of text areas. If a figure has no text area, you cannot add any text 
to the figure. If it has multiple text areas, you can add text to each of the areas independently.

The number of text areas, and their locations within a figure, are part of the figure symbol definition.



Text Mode Cursors
The cursor can take onw of several shapes when you are in connect mode.    Each shapes provides 
information about what will hapen when you click at the current mouse position.

The normal text mode cursor.    If you click when the cursor is this shape, you will create a new label.

If you click when the cursor is this shape, you will edit text in an existing figure or label.    This shape 
indicates that you are over a label or a figure's text area.

If you click when the cursor is this shape, you will create a connector label - a new label that is 
attached to the connector beneath the cursor.



Adding Text to Figures and Labels
You can add text to a text area of any label or figure (see previous section for a discussion of text 
areas).

To add text to a figure or label
1 Enter text mode.
2 Move the cursor anywhere over a label or over a figure's text area. The cursor is surrounded by 

the corners of a box to indicate you are over a text area.
3 Click the mouse button to begin adding text.
Figures can have multiple text areas. You can add text to any of these areas by clicking on different 
parts of the figure.

To add text to a figure (automatic method)
1 Move the cursor over a figure's text area.
2 Start typing text on the keyboard. You are automatically placed in text mode entering text. If the 

figure contained any previous text, the typed text replaces it.
Adding Text to Labels
Labels are similar to figures except that a label cannot exist if it has no text. Consequently, you add 
text to a label when you create it. If you do not add any text when creating a label, or if you later 
remove all the text, the label is deleted automatically.

See also:
Text mode cursors



Editing Text
To edit figure or label text
1 Enter text mode.
2 Move the cursor anywhere over a label or over a figure's text area. A framed text cursor indicates

the cursor is over text.
3 Click the mouse button to begin editing the text.
See also:
Text mode cursors
The text area
Using the keyboard to edit text



Using the Keyboard to Edit Text
The following table lists the functions available from the keyboard when working with text:

ESC        Quit editing text
RIGHT      Move right one character
LEFT       Move left one character
UP         Move up one line
DOWN       Move down one line
CTRL-RIGHT Move right one word
CTRL-LEFT  Move left one word
HOME       Move to the start of the current line
END        Move to the end of the current line
CTRL-HOME  Move to the start of all text
CTRL-END   Move to the end of all text
TAB        Move to the next text area
SHIFT-TAB  Move to the previous text area
BACKSPACE  Delete the character to the left of the cursor
DEL        Delete the character to the right of the cursor
ENTER      Add a "hard" line break

You can use any of the keys that move the cursor in combination with the SHIFT key to extend the 
current text selection.

A few obscure punctuation characters are not allowed.



Selecting Text
To perform operations such as Cut, Copy, and Clear, you need to select a range of text.

To select a range of text
1 Enter text mode.
2 Move the cursor anywhere over a label or over a figure's text area. A framed text cursor indicates

the cursor is over text.
3 Press the left mouse button and hold it down to begin selecting the text.
4 Drag the mouse to select text. The selected text becomes highlighted.
To select a word of text
1 Enter text mode.
2 Move the cursor anywhere over a label or over a figure's text area.
3 Double-click the left mouse button to select the word beneath the cursor.
To select all text within a label or figure
1 Enter text mode.
2 Move the cursor over a label or a figure's text area.
3 Triple-click the left mouse button.
To extend a text selection
While holding down the SHIFT key, click the mouse on additional text to select.



Cutting Copying Pasting Text
Selected text can be cut to the Windows clipboard, copied to the clipboard, and pasted from the 
clipboard. The combination of these features allows you to move text from one figure to another, 
copy text from one figure to another, or copy text from one diagram to another. You can also copy 
text to and from other programs.

To delete text (without moving it to the clipboard)
1 Select a range of text.
2 Press the DEL key or choose Clear from the Edit menu.
To cut text (and move it to the clipboard)
1 Select a range of text.
2 Choose Cut from the Edit menu.
To copy text to the clipboard
1 Select a range of text.
2 Choose Copy from the Edit menu.
To paste text from the clipboard
1 Position the cursor to the location in the text where you want to add the text from the clipboard.
2 Choose Paste from the Edit menu. The text from the clipboard is added at the cursor position. If 

any text was selected, the pasted text replaced the selected text.
See also:
Replacing text



Replacing Text
If any text is selected when you type from the keyboard or Paste, the selected text is first deleted 
before the new text is entered. This is a handy way to replace text.

To replace a range of text
1 Select the range of text to replace.
2 Type the replacement text from the keyboard or Paste the replacement text from the clipboard.
3 The text that was originally selected is deleted before the new text is added.
See also:
Cutting, copying, and pasting text



Special Considerations for Text
· EDGE Diagrammer prohibits the use of a few special characters within figure and label text. You 

are not permitted to enter a tilde ~, an accent grave `, or a vertical bar | while editing text. If you 
paste text from the clipboard containing any of these characters, they are stripped out.

· When typing in a figure or label with word-wrap active, EDGE Diagrammer remembers the 
difference between hard carriage returns (those you insert by pressing the RETURN key), and 
soft carriage returns that are inserted automatically during word wrap. Hard carriage returns 
remain in effect until you delete them. Soft carriage returns get added and deleted automatically 
every time the text is reformatted, such as when you resize the figure.

· A single figure or label can contain a maximum of 511 characters including those that are not 
visible such as carriage returns. This limit applies to the sum of all text in all text areas of a 
figure.

· Text entry is always insert mode as opposed to overstrike mode. In overstrike mode, each new 
character you type would replace the next character in the previous text. Some other programs 
use the INSERT key to toggle between insert and overstrike mode. EDGE Diagrammer does not.

· Undo is not supported for individual operations within text mode, for example, to undo the 
deletion of a single word. You can use Undo to undo all text changes since you started editing 
the figure or label.



Getting Around in a Diagram
Limitations of the modern computer screen present the single greatest obstacle to working on a 
diagram. Typical diagrams extend well beyond the size and degree of detail that you can view 
effectively within a single window. This section describes the methods EDGE Diagrammer provides 
to overcome this obstacle. With these features, you can control precisely both the portion of the 
diagram and the degree of detail that are shown.

Using the Scroll Bars
Autoscroll
Zoom



Using the Scroll Bars
You can use scroll bars to move your view of the diagram up-and-down and left-and-right without 
affecting the degree of detail shown.

To add or remove the scroll bars from the display
Choose the Show Scroll Bars entry from the Options menu.
A check beside Show Scroll Bars indicates that scroll bars are shown.

The only thing unusual about EDGE Diagrammer's scroll bars is the large area of the diagram that 
lies beyond the extents of the printed page boundary. For the common diagram that fits on a single 
piece of paper, the entire diagram is located very near the center position of the scroll bars. With 
these diagrams, the slider portion of the scroll bar won't be particularly useful.

The scroll bar buttons scroll the diagram by a small amount in the direction of the arrow. With the 
CONTROL key pressed, the scroll bar buttons scroll the diagram by a single screen pixel. Clicking in 
the region of the scroll bar between the slider and a button scrolls by a half screen in the direction of 
the button.



Autoscroll
When you drag an object past the edge of the screen, the diagram automatically scrolls to follow the 
cursor.



Zoom
Zoom features allow you to move quickly between different views of the diagram and to increase and
decrease the degree of detail displayed in the diagram window. Some of these features allow you to 
zoom-in and zoom-out your view of the diagram. By changing the zoom magnification, you can 
control how much of the diagram is visible and how much detail is displayed. Other zoom features let
you move instantly to a special view of the diagram.

For all zoom features, the absolute limit of the zoom range is from 10% (one tenth printed size) to 
1000% (ten times printed size).

Zooming to a special view
Zooming in and out
Using Zoom mode



Zooming to a special view
The following features move you directly to a special view of the diagram regardless of your present 
location. They are especially useful for returning to a known view when you become disoriented. 
These features are found at the top of the Zoom menu.

To zoom to a view of the entire page area
Choose Whole Page from the Zoom menu.

To zoom to a view of the top of the page area
Choose Page Width from the Zoom menu.

To zoom to a view of all the objects in the diagram
Choose All Objects from the Zoom menu.

To zoom to a view of all selected objects in the diagram
1 Select one or more objects.
2 Choose Selected Objects from the Zoom menu.



Zooming in and out
The following features let you increase or decrease the detail of the diagram shown in the diagram 
window.

To zoom in - using the keyboard
Press the PLUS key on the keypad. The view is magnified by a small amount so that objects appear 
larger and less of the diagram is visible. Normally, the view remains centered at the same location of 
the diagram prior to zooming in. However, if any objects were selected, the new view is centered on 
those objects.

To zoom out - using the keyboard
Press the MINUS key on the keypad. The view is shrunk by a small amount so that objects appear 
smaller and more of the diagram is visible. Normally, the view remains centered at the same location 
of the diagram prior to zooming out. However, if any objects were selected, the new view is centered 
on those objects.

To zoom to one of the preset zoom intervals
Choose a specific percentage from the Zoom menu. The status bar at the bottom of the screen 
displays the current zoom percentage. At one hundred percent, the size of the diagram on the screen
exactly matches the printed size - assuming your screen height is set accurately.

To zoom in to the next zoom interval
Press the tool bar button that looks like a magnifying glass with a big "+". The view will zoom to the 
next higher of the fixed zoom intervals.

To zoom out to the next zoom interval
Press the tool bar button that looks like a magnifying glass with a big "-". The view will zoom to the 
next lower of the fixed zoom intervals.

To set custom zoom intervals
1 Choose Set from the Zoom menu.
2 Use the Set Zoom Intervals dialog box to set your own zoom intervals.
3 Press OK to make your changes. The new percentages are sorted and entered into the Zoom 

menu. Choose the new percentage from the zoom menu to change the zoom magnification.



Using Zoom mode

Zoom mode provides even greater control to select a view of your diagram. You enter zoom mode by
clicking on the zoom mode button in the tool bar. You can tell you are in zoom mode when the zoom 
mode button is pressed and the zoom mode cursor appears.

The zoom mode cursor.
.

To zoom in incrementally in zoom mode
1 Enter zoom mode.
2 Move the mouse over a part of the diagram that you want to view in greater detail.
3 Click the left mouse button (press and release immediately) to zoom in a little closer.
4 Repeat until the view is sufficiently detailed.
To zoom in to a specific location in zoom mode
1 First you might want to zoom out so that the entire area you want to view is visible on the screen.

Zoom Page is useful for this purpose.
2 Enter zoom mode.
3 Choose the area of the diagram that you want to view in detail. Move the mouse to the upper left-

hand corner of that area.
4 Press and hold the left mouse button.
5 Drag the mouse to create a rectangular region covering the area of interest.
6 Release the mouse button. The rectangular region will fill the entire window.



Figure Styles
Like paragraph styles in word processors, styles are the true definitions of objects in EDGE 
Diagrammer. In order to create any object, a figure, label, or connector, you must start with a 
predefined style. The style defines the initial characteristics and behaviors of the object. The shape, 
the location of the text, the text justification, the initial color, and so on, are all parts of the figure style.
When you create a figure, you choose one of the predefined styles to become the basis for the new 
figure.

To work with figure styles choose Styles from the Figures menu. If no styles are defined, you are 
immediately prompted to create a new style. If any styles are defined, the Define Figure Styles dialog
box appears.

Define Figure Styles Dialog Box



Define Figure Styles Dialog Box
This dialog box allows you to view and modify attributes of the existing styles, delete old styles, and 
create new styles. The upper left corner contains a model of the style with its current attributes. The 
name of the current style is shown at the upper center.

To make changes to a figure style
1 Use the controls to modify the style.
2 Press the Apply button to make the changes to take effect.
To exit the Define Figure Styles dialog box
Press the Close button.

To view a different style
1 Choose a different style by name from the style combo box by clicking on the current style name.
2 OR, use the spin control (the up and down arrow to the right of the style name) to cycle through 

the styles alphabetically.
3 OR, use the style pick menu button ">>" located to the left of the style name to select a different 

style by its appearance
When you choose a different style, the controls reflect the properties of the style and the style model 
at the upper left displays a sample of the style with its current properties.

If you attempt to switch styles after making changes to the current style properties but before you 
apply those changes to the style, you will be asked whether you want to apply the changes before 
switching to the new style.

Other Controls
The Figure Styles dialog box contains many other controls. Some are common to all style types 
(figures, connectors, and labels).

Common Style Properties
Common Style Controls
Setting the graphic definition for a figure style
Setting the border width for a figure style
Setting the text justification for a figure style
Setting the colors for a figure style
Setting the font for a figure style
Setting the default text for a figure style
Setting the default size for a figure style
Setting the advanced properties for a style



Common Style Properties
These are properties that are found in Figure Styles, Label Styles, and Connector Styles dialog 
boxes.    They work the same in each case.

Bind to style
When this property is checked, any object created with this style is automatically bound to the style. 
This means that if the style changes in the future, the object will change as well. If an object does not
have this property, changes to the style will not effect the object.    The default is checked for figure 
and connector styles, unchecked for label styles.

Style bar button
When this option is checked, a button with a representation of the style is included in on the style 
bar. Style bar buttons are useful for frequently used styles. Because the representation on a style bar
button is not exact (contains no color or line thickness), they are not useful for every style.    The 
default is checked for figure and connector styles, unchecked for label styles.

Description
The style description is a short text description of the style. This description is displayed in the status 
bar when the style is selected to remind you of its purpose.



Common Style Controls
These are controls (buttons) that are found in Figure Styles, Label Styles, and Connector Styles 
dialog boxes.    They work the same in each case.

Delete style
Press this button to delete the current style. You will be asked to confirm the deletion before it takes 
effect. Be very careful. Deleting a style cannot be undone. When you delete a style, any objects in 
the diagram that were created with this style and bound to it become unbound.

New style
Press this button to create a new style. The New Style dialog box appears to prompt for the name of 
the new style. Press OK immediately to accept the default name or enter a more descriptive name of 
your own. The name must not match the name of any existing style.

Copy style
Press this button to create a new style that is a copy of the current style. Enter a descriptive name for
the style as with New Style above.



Setting the graphic definition for a figure style
Every figure style must have a graphic definition that describes the shape of the figure style. The 
graphic can be either a predefined EDGE Diagrammer symbol or any Windows metafile graphic.

Using an EDGE Diagrammer symbol as a figure style graphic
EDGE Diagrammer comes with many predefined figure symbols that can be used for figure style 
graphics. Each symbol contains information about shape, appearance, and text areas.

The predefined symbols are located in .EDF files located in the SYMBOLS subdirectory. You can 
create your own symbols with a text editor and install them by creating new files in this directory.

To choose a figure symbol as the figure style graphic
1 Press the Symbol button to invoke the Select Figure Symbol dialog box.
2 The Select Figure Symbol dialog box displays all of the installed figure symbols that are available

for use. The blue box identifies the selected symbol. At the bottom left is information about the 
selected symbol including its name, the file where it is defined, and some descriptive information.

3 Click on a figure symbol.
4 Press OK to use the symbol. (or double click on a symbol)
Drop shadow
Check this box to create a drop shadow for figures of this style. Use the Diagram menu to set the 
color and size of drop shadows.

See also
Using a Windows Metafile as a figure style graphic



Using a Windows Metafile as a figure style graphic
You can define a figure style using an imported graphic or clipart image. Microsoft standard Windows
Metafiles (*.WMF) can be used to define the shape of a figure.
WMF is the vector graphics file exchange standard supported by the Windows clipboard and OLE 
2.0. Many popular Windows drawing programs can produce metafile graphics. Other graphics 
formats can often be converted into WMF files either by popular applications or graphic conversion 
programs.

We've included a few sample metafiles and a sample diagram called SAMPNET.EDG that uses 
them. In your diagrams, you can use any of the metafiles that come with Visual Basic, Word for 
Windows, MicroSoft Draw, CorelDraw, or similar programs. In order for EDGE Diagrammer to 
recognize a Windows metafile as valid, it must conform to the Windows standard for exchangeable 
metafiles, and it must have a placeable header. If EDGE Diagrammer determines that a metafile is 
not valid, it will produce an error message when you try to load it.

To choose a Windows Metafile (WMF) as the figure style graphic
1 Press the Metafile button in the Define Figure Style dialog box.
2 Select a metafile and press OK.
Under some circumstances, EDGE Diagrammer may not be able to draw some metafiles in your 
diagram. Occasionally, this is caused by a technical limitation or a restriction imposed by Windows. 
More frequently, it is caused by zooming so far back that the particular graphic is too small to draw. 
When a metafile cannot be displayed properly for any reason, it is replaced by the symbol shown 
below.
If a metafile cannot be displayed on a the style bar button, try increasing the size of the buttons. 
Metafiles should always appear properly when printed. If they do not appear properly when printed, 
or if they do not appear properly with 100% zoom, you may be low on memory.



Setting the border width for a figure style
You can change the width of the border or outline of figures of the style by changing the number in 
the Border Width box or by using the spin buttons to the right of the box to choose a new width.

The exact point size you want is not always available. For example, 10 points is not valid and is 
rounded to 10.25 points.



Setting the text justification for a figure style
Use the text justification buttons to justify the text to the left, center, or right horizontally, and the top, 
middle, or bottom vertically.



Setting the colors for a figure style
Use the color pick menus to choose colors for the figure borders, fill area, and the text. You can 
choose from the colors in the current palette. Change the palette by selecting Set Color Palette from 
the Diagram menu. Text and border colors must be colors that can be drawn solid on your screen. If 
you select a color that cannot be drawn solid, Windows draws the text in the nearest solid color.

Text Color
The color of the words in the figure.    All words in one figure are the same color.

Border Color
The color of the outline shape of the figure.

Fill Color
The color of the interior of the figure.



Setting the font for a figure style
Each figure has a font.    The font is the style, size, and boldness of the text that the figure contains.    
You can choose a font from any that you have installed on your machine under Windows.    
Remember that if you move a diagram from one machine to another, you need to make sure the 
fonts it uses are on the other machine as well.

To change the text font for the figure style
1 Press the font button. The font dialog box appears.
2 Choose the font, font style, and point size for the font.
3 Press OK to make the change.



Setting the default text for a figure style
Most figure styles do not include any text by default. That is to say, when you create a figure of the 
style, the figure contains no text until you add it. This makes sense for most styles because every 
figure contains its own unique text.

However, when you design a figure style that will always contain the same text, it's convenient to 
define default text for the style. That way, every figure you create from the style will initially contain 
the default text. Once you create the figure, you can edit the text as usual.

To set the default text of a figure style
1 Press the Default Text button in the Define Figure Styles dialog box. The Default Text dialog box 

appears.
2 Type the default text in the edit box. If you have a single figure selected, you can choose From 

Selected to copy the figure's text and use it as the default text for the style.
3 Press OK to make the change.
If the figure style has multiple text areas, the dialog box contains a spin control (an up and down 
arrows) to switch between text areas. Clear All clears the text in all text areas.



Setting the default size for a figure style
Typically, each figure style has a default size. It is this size that is used to initially create the figure. If 
there is no default size (a default size of 0 by 0), the user is forced to size the figure as he creates it.

To change the default size of a figure style
1 Press the Default Size button in the Define Figure Styles dialog box to invoke the Default Size 

dialog box.
2 Enter a default height and width.
3 Press OK to accept the new default height and width.
To set the default size of a figure style from an existing figure in the diagram
1 Select the figure whose text you want to use as the style's default text. Make sure you select only

one figure.
2 Choose Styles from the Figures menu.
3 Press the Default Size button to invoke the Figure Style Default Size dialog box.
4 Press the From Selected button to use the size of the selected figure as the default for the figure 

style.
5 Press OK to accept the change.



Setting the advanced properties for a style
A figure style has a group of advanced properties that define how figures of the style behave and 
interact with other objects. The advanced properties are separated from the basic properties 
because they are not only more advanced conceptually, but because they are less often used.

To change the advanced properties of a figure style
1 Press the Advanced button in the Define Figure Styles dialog box to invoke the Advanced 

Properties dialog box.
2 Change the properties.
3 Press OK to accept the changes.
Line too long
This property controls what happens when typed becomes too wide for a figure of this style. If set to 
Prevent, additional characters are not allowed. If set to Expand, the figure automatically grows wider 
as you continue typing. The direction of expansion is controlled by the Growth property. If set to 
Wrap, the width of the figure does not change and the text word-wraps automatically to the next line.

Too many lines
This property controls what happens when typed text exceeds the number of lines that fit in a figure 
of this style. If set to Prevent, additional lines are not allowed. If set to Expand, the figure 
automatically grows taller as you add lines. The direction of expansion is controlled by the Growth 
property.

Growth
This property controls in which directions the figure grows automatically, such as when the text 
causes the figure to expand. Use the icons to choose a method of horizontal and vertical expansion.

Center remains stationary when resizing
When this property is checked, the center of the figure remains in the same place when you resize it 
using its resize handles. You will usually want to enable this property for figures that can be 
connected to other figures with connectors.

Center snaps to grid
When this property is checked, AND snap-to-grid is enabled for the diagram, the figure's center 
snaps to the snap grid when you create, move, or resize the figure. You will usually want this 
property enabled for figures that are connected to other figures with connectors, otherwise it may be 
difficult to keep the figures aligned vertically or horizontally.

Height and width snap to grid
When this property is checked and the snap grid is enabled, the figure's edges align with the snap 
grid when you create, move, or resize the figure. If you set this property, you'll want to set the Center 
snaps to grid property as well.

When the height and width snap to the grid, both sides are aligned with snap grid lines which are not 
necessarily the same as the visible grid lines. In effect, the total width or height is always a multiple 
of twice the snap spacing. For example, if the snap spacing is one quarter of an inch and a figure has
the Height and width snap to grid property, that figure width can be 1/2 in., 1 in., 1 1/2 in. and so on, 
but it cannot be 3/4 in. This behavior helps to keep figures and connectors properly aligned by 
guaranteeing that the center point and all boundaries fall exactly on the grid. If you find this 
disturbing, you might try setting the snap spacing to half the grid spacing.



Keep sized to text
When this property is checked, the figure is always sized to exactly fit the amount of text it contains. 
For example, if you edit text for a figure such that the figure has less text than it had before, the 
figure will automatically resize itself to shrink down around the new text as soon as you complete 
editing the text.



Label Styles
Label styles are similar to figure styles. Label styles define the initial characteristics and behaviors of 
labels. Labels are essentially specialized figures. Therefore, working with label styles is very much 
like working with figure styles.

To work with label styles, choose Styles from the Labels menu. If no styles are defined, you are 
immediately prompted to create a new style. If any styles are defined, the Define Label Styles dialog 
box appears.

Define Label Styles Dialog Box
Connector Label Styles



Define Label Styles Dialog Box
This dialog box allows you to view and modify attributes of the existing label styles, delete old styles, 
and create new styles. The upper left corner contains a model of the style with its current attributes. 
The name of the style is shown at the upper center.

To make changes to a label style
1 Use the controls to modify the style.
2 Press the Apply button to force the changes to take effect.
To exit the Define Label Styles dialog box
Press the Close button.

To view a different style
1 Choose a different style by name from the style combo box by clicking on the current style name.
2 OR, use the spin control (the up and down arrow to the right of the style name) to cycle through 

the styles alphabetically.
3 OR, use the style pick menu button ">>" located to the left of the style name to select a different 

style by its appearance.
When you choose a different style, the controls reflect the properties of the style and the style model 
at the upper left displays a sample of the style with its current properties.

If you attempt to switch styles after making changes to the current style properties but before you 
apply those changes to the style, you will be asked whether you want to apply the changes before 
switching to the new style.

Other Controls
The Label Styles dialog box contains many other controls. Some are common to all style types 
(figures, connectors, and labels).

Common Style Properties
Common Style Controls
Setting the text justification for a label style
Setting the text color for a label style
Setting the font for a label style
Setting the default text for a label style
Setting the default size for a label style
Setting the advanced properties for a label style



Setting the text justification for a label style
Use the text justification buttons to justify the text to the left, center, or right horizontally, and the top, 
middle, or bottom vertically.



Setting the text color for a label style
Use the color pick menu to choose a color for the label text. You can choose from the colors in the 
current palette. Change the palette by selecting Set Color Palette from the Diagram menu. The text 
color must be one that can be drawn solid on your screen. If you select a color that cannot be drawn 
solid, Windows draws the text in the nearest solid color.



Setting the font for a label style
Each label has a font.    The font is the style, size, and boldness of the text that the label contains.    
You can choose a font from any that you have installed on your machine under Windows.    
Remember that if you move a diagram from one machine to another, you need to make sure the 
fonts it uses are on the other machine as well.

To change the text font for the label style
1 Press the font button. The font dialog box appears.
2 Choose the font, font style, and point size for the font.
3 Press OK to make the change.



Setting the default text for a label style
Most label styles do not include any default text. Normally, you add text as you create each label. 
However, when you design a label style that will always contain the same text, it's convenient to 
define default text for the style. That way, every label you create from the style will initially contain the
default text. Once you create the label, you can edit the text as usual.

To set the default text of a label style
1 Press the Default Text button in the Define Label Styles dialog box. The Default Text dialog box 

appears.
2 Type the default text in the edit box. If you have a single label selected, you can choose From 

Selected to copy the label's text and use it as the default text for the style.
3 Press OK to make the change.



Setting the default size for a label style
Like figure styles, label styles can have a default size. In most cases, the default label size is not 
used because a label's size is usually determined by its text. However, if the label style has the 
Prevent or Wrap setting for the Line too long property, or the Prevent setting for the Too many lines 
property, a default size is important. Set a label style's default size just like you would for a figure 
style.

See Setting a the default size for a figure style



Setting the advanced properties for a label style
Label styles have the same advanced properties as figures. With labels, you will usually want to 
leave the advanced properties alone and use the defaults.

See Advanced Properties



Connector Label Styles
Connector labels are just ordinary labels and do not require a new kind of style. You can create a 
connector label from any label style. A connector label has a few added restrictions that a standard 
label does not have. For instance, a connector label is always center-justified vertically and 
horizontally and always expands when text is added and always grows from the center. The 
corresponding style properties are ignored for connector labels.



Connector Styles
Connector styles define the initial characteristics and behaviors of connectors. This section describes
how to define, create, modify and delete connector styles.

To work with connector styles, choose Styles from the Connectors menu. If no styles are defined, you
are immediately prompted to create a new style. If any styles are defined, the Define Connector 
Styles dialog box appears.

Define Connector Styles Dialog Box



Define Connector Styles Dialog Box
This dialog box allows you to view and modify attributes of the existing connector styles, delete old 
styles, and create new styles. The upper left corner contains a model of the style with its current 
attributes. The name of the style is shown at the upper center.

To make changes to a connector style
1 Use the controls to modify the style.
2 Press the Apply button to force the changes to take effect.
To exit the Define Connector Styles dialog box
Press the Close button.

To view a different style
1 Choose a different style by name from the style combo box by clicking on the current style name.
2 OR, use the spin control (the up and down arrow to the right of the style name) to cycle through 

the styles alphabetically.
3 OR, use the style pick menu button ">>" located to the left of the style name to select a different 

style by its appearance.
When you choose a different style, the controls reflect the properties of the style and the style model 
at the upper left displays a sample of the style with its current properties.

If you attempt to switch styles after making changes to the current style properties but before you 
apply those changes to the style, you will be asked whether you want to apply the changes before 
switching to the new style.

Other Controls
The Connector Styles dialog box contains many other controls. Some are common to all style types 
(figures, connectors, and labels).

Common Style Properties
Common Style Controls
Setting the end symbols for a connector style
Setting the end fill colors for a connector style
Setting the end sizes for a connector style
Setting the thickness of a connector style
Setting the color of a connector style
Setting the line style of a connector style
Setting the border width of a connector style



Setting the end symbols for a connector style
The ends of a connector style require symbols to define their shapes. Choose a symbol for each end 
of the connector style from the connector end styles you have installed.

To choose an end symbol for the connector style
1 Press one of the Symbol buttons to invoke the Select End Symbol dialog box.
2 The Select End Symbol dialog box displays all of the installed end symbols. The blue box 

identifies the selected symbol. At the bottom left is information about the selected symbol 
including its name, the file where it is defined, and a description.
In addition to displaying the shape of the end symbol, the dialog box shows two pieces of 
information on the highlighted symbol, whether it is drawn centered at the end point, and whether
it rotates with the connector. These attributes are built in to the end definition.

3 Use the mouse to click on the symbol for the connector end.
4 Press OK to use the symbol. (or double click on a symbol)



Setting the end fill colors for a connector style
Use the color pick menu for either end to choose the fill color from the colors in the current palette. 
You can change the palette by selecting Set Color Palette from the Diagram menu.



Setting the end sizes for a connector style
Use the size edit box or the spin buttons to the right of the box to choose the length of either end 
symbol. The length of the end symbol is TWICE the distance from the endpoint of the connector to 
the end of the end symbol.



Setting the thickness of a connector style
Use the thickness edit box or the spin buttons to the right of the box to choose the thickness (width) 
of the connector.

The exact point size you want is not always available. For example, 10 points is not valid and is 
rounded to 10.25 points.



Setting the color of a connector style
Use the color pick menu to choose the color of the connector from the colors in the current palette. 
You can change the palette by selecting Set Color Palette from the Diagram menu. The color must 
be one that can be drawn solid on your screen. If you select a color that cannot be drawn solid, 
Windows chooses the nearest solid color.



Setting the line style of a connector style
The line that connects the ends of the connector can have one of several line styles such as solid, 
dotted, or dashed.

Use the Style pick menu to choose a line style for the connector.

If the line style is not solid, the thickness must be 1/4 pt.



Setting the border width of a connector style
The end symbols are drawn with a width or line-thickness that you control.
Use the Borders edit box to choose the border width for both end symbols. You cannot control the 
two end symbol borders independently.

The exact point size you want is not always available. For example, 10 points is not valid and is 
rounded to 10.25 points.



Diagram Settings
The Diagram Settings are a set of options that are saved as part of the diagram. They control some 
of the behaviors unique to the diagram. The diagram settings are available from the Diagram menu.

Smart Connect
Show Grid
Snap
Set Colors
Diagram Properties



Smart Connect
Smart connect toggles whether connectors know whether a figure or another connector is beneath 
the cursor. When smart connect is checked, you can attach connectors to figures and other 
connectors in the usual way. When smart connect is not checked, you cannot attach connectors to 
figures or other connectors.

The advantage of unattached connectors is that they can start and end anywhere on the diagram 
and they can form simple lines. The disadvantage of unattached connectors is that they do not move 
automatically when other objects move, you must move them separately yourself.



Show Grid
Show grid toggles whether the alignment grid is visible. This option controls ONLY the display of the 
grid, not whether objects snap to it.

You can also turn the grid on and off with the grid button on the tool bar.
You can set the spacing of the grid in the Diagram Properties dialog box.

See also
The Snap Grid



Snap
Snap toggles whether objects snap to the snap grid when you create, move, and resize them. If this 
option is checked, objects snap to the grid if they contains a property that causes them to do so.

You can also turn snap on and off with the snap button on the tool bar.
You can set the spacing of the snap grid in the Diagram Properties dialog box.

See also
The Snap Grid



Set Colors
Choose Set Colors from the Diagram menu to invoke the Set Colors dialog box. You can use this 
dialog box to change the color palette - the set of colors available to the diagram. This set of colors is
used for all color pick menus to select colors for figures, connectors, borders, text, and so on.

To change any of the diagram colors
1 Click on the color to change.
2 Use the color selection dialog box to pick a color and press OK.
Diagram colors
Each diagram can use up to sixteen colors at a time. These colors can be any sixteen you choose. 
Depending on your graphics card and your video mode, some colors may be composite or dithered. 
If you look closely, some colors are made up of patterns of two or more solid colors, a process called 
dithering. Dithered colors are fine for fill colors but should be avoided for lines and text. If you choose
a dithered color for a line (such as a figure border) or a text color, Windows will not be able to draw 
the line or text in the color you choose. Instead, it will pick the nearest color that can be drawn solid. 
We suggest you choose primarily solid colors when you create your palette. If you are using a 
display mode that can display only 16 colors, there are only 16 solid colors available. If you are using
a display mode that can display 256 colors or more you will have fewer restrictions.

Drop shadows
Figures with the drop shadow property draw their drop shadow in this color. The default drop shadow
color is dark gray.

To change the drop shadow color
1 Click on the drop shadows box.
2 Use the color selection dialog box to pick a color and press OK.



Diagram Properties
To view and modify the properties of the diagram, choose Properties from the Diagram menu.

Drop shadow offset
Enter the distance that a drop shadow protrudes from beneath a figure that has the drop shadow 
property.

Grid spacing
Choose the spacing between grid lines on the visible alignment grid.

Snap spacing
Choose the spacing for snap alignment. A snap spacing that is smaller than the grid spacing works 
well. For instance, try a snap spacing of an eighth inch and a grid spacing of a quarter inch. 



Options
Options reflect your personal preferences and your program set-up. Your options are remembered 
for you and do not change unless you change them. Unlike diagram settings (discussed elsewhere) 
your options are NOT saved and loaded with diagrams. You can view and change options from the 
Options menu.

Show Status Bar
Show Scroll Bars
Show Rulers
Show Page Boundaries
More Options



Show Status Bar
Choose Show Status Bar from the Options menu to turn on or off the status bar at the bottom of the 
screen. The status bar displays help information, the current zoom magnification, and the status of 
some keyboard keys.



Show Scroll Bars
Choose Show Scroll Bars from the Options menu to turn on or off the scroll bars at the right and 
bottom of the diagram window. The scroll bars show you where you are in the diagram and help you 
move around.



Show Rulers
Choose Show Rulers from the Options menu to turn on or off the rulers at the top and left edges of 
the diagram.



Show Page Boundaries
Choose Show Page Boundaries from the Options menu to turn on or off the display of page 
boundaries and margins in the diagram. The page boundaries show you how the diagram will print 
on the page using the current printer set-up.

There are some features that are not available unless Show Page Boundaries is enabled. For 
example, the Center on Page feature is not available.



More Options
Choose More Options from the Options menu to change the remainder of the options.

Measurements
Choose either English (inches) or Metrics (centimeters) as your measurement units. All 
measurements are displayed in these units.

Measurements such as line widths and font sizes are measured in points (abbreviated pts). There 
are 72 points to the inch. Your choice of measurement units does not effect these measurements - 
they are points both for english and for metrics.

Screen size
You are asked to provide the exact measurement (use a ruler) of the actual picture on your monitor 
from the top to the bottom. The default is set for a standard fourteen inch monitor.

EDGE Diagrammer needs to know this measurement so that it knows what 100% zoom means. If 
you have this value set correctly and zoom is set to 100%, you can actually measure the object on 
the screen and it will match its true size. This only affects the display, printing will always be exact 
because Windows knows what 100% means for your printer.

Create one figure at a time
When you create a figure and this option is checked, the new figure automatically becomes selected 
and the mode changes back to select mode as soon as one figure is created. To create another 
figure, you'll have to press the figure style button again and repeat the process. Without this option 
checked, you remain in figure create mode until you change modes yourself.

Create one connector at a time
When you create a connector and this option is checked, the new connector automatically becomes 
selected and the mode changes back to select mode as soon as one connector is created. To create 
another connector, you'll have to press the connector style button again and repeat the process. 
Without this option checked, you remain in connect mode until you change modes yourself.

Save all fields
You will not ordinarily check this option. EDGE Diagrammer saves as few fields as necessary in your 
diagram files to minimize their size and the time it takes to save and open. In the future, there may 
be special circumstances that require you to force a complete save of ALL fields of your diagram 
regardless of their values. For instance, if you have another program that reads EDGE Diagrammer 
files for some purpose, that program may require a full save. To force a full save, set this option and 
then save the diagram in the usual way.



File Operations
A number of features are available from the File menu to perform file-level or system operations. 
These features allow you to load files (diagrams), save files, print files, and so on.

Creating a New Diagram
Creating Custom Templates
Opening an Existing Diagram
Converting an Old Diagram
Saving a Diagram
Copying Styles from a Diagram
Exporting a File
Setting Page Boundaries
Poster
Printing
Exiting



Creating a New Diagram
There are two ways to create a new diagram. You can create a new diagram from one of the existing 
diagram templates that contain predefined figure, connector, and label styles. Alternately, you can 
create a new diagram without any predefined styles.

To create a new diagram without predefined styles
1 Choose New from the File menu.
2 Press the None button in the Choose a Diagram Template dialog box.
A new diagram with no predefined styles still contains a single label style. Without at least one label 
style, many operations would not be possible.

To create a new diagram from a diagram template
1 Choose New from the File menu.
2 Select a diagram template file (in the TEMPLATE subdirectory) from the Choose a Diagram 

Template dialog box.
EDGE Diagrammer comes with some basic diagram templates such as the flowcharting template.



Creating Custom Templates
When you create a new diagram, you can start from a diagram template that contains an initial set of 
figure, connector, and label styles. In addition to the few templates that come with EDGE 
Diagrammer, you can create you own templates for your custom diagrams.

EDGE Diagrammer templates are very much like ordinary saved EDGE Diagrammer files. The main 
difference is that templates contain no actual figures, connectors, or labels, only styles and symbol 
definitions. When you create a new diagram by choosing New from the File menu, you can choose to
start from any diagram template located in the \WINEDGE\TEMPLATE subdirectory. Therefore, all 
you have to do to create your own diagram template is to create an empty diagram in this 
subdirectory.

To create a custom diagram template
1 Create a custom diagram with all of your own figure, connector, and label styles.

Remove all objects from the diagram. One way to do so is by choosing Select All and then Clear 
from the Edit menu.

2 Save the diagram in the template directory. You can so by choosing Save As from the File menu 
and changing the directory to \WINEDGE\TEMPLATE.

3 The next time you create a new diagram, you can choose your custom template as the starting 
point.



Opening an Existing Diagram
To open a diagram that was previously saved
1 Choose Open from the File menu.
2 Select the file that contains the diagram.
3 If the file is one of the four that you most recently used, you can open it more conveniently.
To open a recently used diagram
Choose the diagram by filename from the File menu.



Converting an Old Diagram
If you have used one our DOS programs EDGEFLOW or EDGE Flowcharter to create diagrams, you
can convert those diagrams for use with EDGE Diagrammer.    Because the programs are very 
different, the conversion is only an approximation and may require hand tuning following the 
conversion.

To convert an EDGE Flowcharter diagram for use with EDGE Diagrammer
1 Choose Convert from the File menu.
2 Select the file that contains the old (source) diagram.
3 Choose a file name for the new (destination) diagram that will be created.
4 The Convert Diagram dialog box appears.
5 If the original diagram was created and formatted with a dot matrix printer driver selected, check 

the box marked "Source file is formatted for dot matrix printer".    This helps the conversion 
process decide how to scale the diagram.

6 If you want to increase or decrease the size of the entire diagram (an option that's not as easy 
once the diagram is converted), you can choose a scale other than 100%.    You can choose any 
size from 20% to 500%.

7 Press the Convert button.    After the conversion is complete, you can Open the new file.



Saving a Diagram
To save changes to a diagram
If the diagram already has a file name and you want to save your changes back to the same file, 
simply choose Save from the File menu.

To save a diagram to a file
If the diagram is new and has never been saved to a file, or to save a diagram to a different file, 
choose Save As from the File menu and select the file name.



Copying Styles from a Diagram
You can copy all of the figure, label, and connector styles from another diagram into the current 
diagram, merging the other diagram styles with those in the current diagram.

To copy styles from another diagram
1 Choose Copy Styles From from the File menu.
2 Select the diagram by file name.
If the file you choose contains styles that have the same names as any in the current diagram, you 
will be asked whether the duplicate style should replace the current style by the same name or 
whether it should be ignored.



Exporting a File
You can export a diagram to a disk file in a standard graphic format so that you can later import the 
diagram into a different program. For example, if you export a diagram to a file as a Windows 
Metafile, you can then use Microsoft Word's Insert Picture feature to add the diagram to a Microsoft 
Word document.

To export the current diagram to a file as a Windows Metafile
1 Choose Export from the File menu.
2 Select a file name and press OK.
You can transfer diagrams and portions of diagrams to other programs more conveniently through 
the Windows clipboard by using Cut and Copy. However, there are a few advantages to using Export
instead. Once you export a diagram to a file, you can easily store and transport that file. You can also
use other commercially available programs to convert the file to other graphics formats that EDGE 
Diagrammer does not support.

Once you export a diagram to a file, you cannot reload that file into EDGE Diagrammer as a diagram.
The exported file is essentially a snapshot of the image of the diagram and does not contain the 
actual diagram definition.

It is NOT possible to export a diagram to a metafile and then import that metafile as a figure style 
graphic.



Setting Page Boundaries
EDGE Diagrammer does not force you to use page boundaries for your diagrams. However, you will 
most likely want to print your diagram at some point so we recommend that you set up your page 
boundaries before constructing your diagram. Your page boundaries can be affected in two areas 
Print Setup and Poster, both available from the File menu.

Setting page type
Choose Setup from the File menu. Select the printer, paper size, and printing orientation (portrait or 
landscape). Since all of these might effect the shape of your printed page area, you can save 
yourself some work by setting them before starting work on your diagram.

See also
Poster



Poster
Postering is EDGE Diagrammer's way to handle very large diagrams.

If you have a very large diagram, you might want to construct it so that you can print it on several 
sheets of paper and then tape together all the pieces into a large wall poster. EDGE Diagrammer 
helps you do this kind of postering by letting you set up a poster grid that will display with your page 
boundaries.

Setting a poster grid
1 Choose Poster from the File menu.
2 Use the Poster dialog box to choose the number of pieces of paper that will make up your poster.

The Poster dialog box has the following controls:

Rows
Enter the number of rows in the grid. Rows and columns are both limited to six but they may be 
limited to a smaller number for larger paper sizes.

Columns
Enter the number of columns in the grid. Rows and columns are both limited to six but they may be 
limited to a smaller number for larger paper sizes.

Print crop marks
If you select this option, thin crop marks print in the corners of each page. Since it is impossible for 
today's printers to print to the very edge of the paper, you will need to cut the margins off of every 
sheet before taping together your poster. Crop marks guide you to cut the proper amount. You should
choose this option unless you use one row and one column.



Printing
Printing EDGE diagrams is similar to printing in any other Windows program.

To print a diagram
1 Use Print Setup to make sure that your printer is set up properly with the correct paper and so 

on. You do not need to set-up your printer each time you print.
2 Choose Print from the File menu.
3 Choose the options you want in the Print dialog box then press OK.
When you print a diagram that has more than one page, you can select a range of pages to print 
rather than printing the whole diagram. Page numbering is from left to right and top to bottom. For 
example, page one is at the upper left corner, page two is immediately to the right of page one, and 
the last page is at the lower right corner.



Exiting
To exit EDGE Diagrammer
1 Choose Exit from the File menu. Other standard Windows methods of exiting programs work 

also, such as pressing ALT-F4 or choosing Close from the System menu.
2 If your diagram contains changes that have not been saved, you will be prompted to save them 

before exiting.
3 If you have cut or copied many diagram objects to the clipboard, you will be asked if you want to 

clear them from the clipboard before exiting. If you are done using EDGE Diagrammer, you might
be advised to clear the clipboard to free up memory for other applications. However, if you intend
to run EDGE Diagrammer again later and paste the contents of the clipboard into another 
diagram, do not clear it now. In any case, the clipboard will be lost if you exit Windows or power 
down your computer.
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autoscroll
The feature that automatically causes the diagram to scroll to follow the cursor when it moves beyond 
the visible portion of the diagram.



connector label
A connector label is a special type of label that is attached to a connector.    When the connector moves, 
the connector label follows.



connector segment
A segment is a "leg" of a connector that runs in a straight line from a figure or junction to another figure 
or junction.



connector
A connectors is a line that connects two figures. A connector    usually represents a path between two 
figures or some other logical relationship. Each end of a connector can have an attached shape such as 
an arrowhead.



diagram
A diagram is a complete set of objects, styles, definitions, and properties which are saved together in 
one file.



drop shadow
A shadow that shows from beneath a figure giving the figure a three dimensional appearance.



end symbol
A mathematical definition for the shape of either end of a connector    - such as an arrowhead.



figure symbol
A mathematical description of the shape of a figure and the number, size, and locations of text areas 
within the figure.



figure
A figure is the most common type of object in a diagram.    It can be a circle or a box or any other shape. 
It can have descriptive text, and it can be connected to other figures with connectors.



junction
A junction is the point at which two or more connector segments meet and bend in a different direction.



label
A label is a text object located anywhere in a diagram.    A label can be used for a note, a title, a 
comment, an annotation, and so on.



message bar
The area below the diagram that contains help messages, the zoom percentage, and keyboard status.



object
An object is any component of a diagram such as a figure, label, connector, or junction.



poster
You can create a diagram that is larger than a single page by arranging several pages into a grid.    
When you print the pages, you can attach them together to make a large wall poster.



properties
The internal attributes of an object such as size, shape, and color.



select mode
When you are in this mode, you can select and move objects and perform many other operations.    
When you are in this mode, the cursor looks like the standard Windows cursor.



seltext mode
This mode is a combination of select mode and text mode.    You can select items but you can also edit 
text.    The enter seltext mode, press the tool bar button that has an arrow cursor and the letter "T".



snap grid
The invisible grid that control how objects "snap" to particular sizes and locations.    You can turn the 
snap grid on or off by pressing the tool bar button that looks like a magnet.



style bar
The style bar is the large area to the left of the diagram that contains buttons and list boxes.    All of the 
controls on the style bar help you choose a style in order to create a new object.



style
A style is a basic object definition.    Like paragraph styles in word processors, EDGE Diagrammer has 
figure styles, connector styles, and label styles.    When you create any of these types of objects, the 
style defines the initial characteristics of the object.



template
A file that contains predefined styles.    When you create a new diagram you can begin with a diagram 
template.



text area
A rectangular area within a figure where text is permitted.



text mode
In text mode, you can create labels and edit figure text.    Enter text mode by clicking on the "T" button or
by choosing a label style.    When you are in text mode, the cursor looks like a text caret.



tool bar
The tool bar is the area above the diagram that contains small square buttons.    Tool bar buttons provide
a shortcut for commands that can also be found in menus.



unattached connector
Most connectors are attached to figures and move when the figures move.    Unattached connectors are 
free-standing and have to be moved separately.



visible grid
The grey-colored grid that appears beneath the diagram objects.    The visible grid is a visual aid only.    It
helps you line up objects by sight.






