
About CorelDREAM 3D
CorelDREAM 3D provides all the features necessary to create full-color 3D illustrations. Its Bezier-based modeler 
uses tools you are familiar with from your favorite 2D drawing program to create 3D objects. The program also 
has a Modeling Wizard to guide you through the steps of creating a 3D object.
Once you've created an object, you can paint colors and textures on it with realistic properties like transparency 
and reflection. You can even apply real-world textures like wood grain or marble.
To enhance realism and three-dimensional effects, various types of light sources can be added to your scene. 
Just by changing a few light source settings, a cafe scene can be changed from early morning, to midday, to 
evening.
Because you are working in three dimensions, you can view your scene from any angle and at any degree of 
magnification simply by placing cameras at different positions in the 3D workspace.
Rendering is the culmination of a CorelDREAM project. Like taking a photograph, rendering, reduces the three-
dimensional scene to a two-dimensional image. The rendered image is compatible with many popular Windows 
2D graphics and page layout programs, so you will have no trouble compositing renderings with other images or 
integrating them with text.



The CorelDREAM 3D Workplace
Documents created in CorelDREAM 3D are called scenes. A scene is the collection of objects, light sources, and 
cameras, saved together in a file. Each new scene has two document windows, the Perspective and Hierarchy 
windows. When you have saved a scene, its file name appears in the title bars of the Perspective and Hierarchy 
windows.
You can have multiple scenes open and switch between them at any time. You can even copy objects between 
scenes and view the same scene from different angles by opening it in multiple Perspective windows.
When you open CorelDREAM for the first time, you see two windows: Perspective (left) and Hierarchy (right). Two 
additional windows. the Objects Browser and the Shaders Browser. can be opened as needed using commands in
the File and Windows menus. These are the primary work windows.
As you work, you may resize windows, move them around your scene, and customize your workspace. When you
quit, CorelDREAM remembers your settings and uses them the next time you launch the program. If you like, you
can use the Workspace command on the Windows menu to save different workspace layouts and recall them at 
any time.
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Warning: Applying a shader that includes information in multiple channels
You are attempting to apply multiple channel's worth of information into only one channel of a shader.



Warning: Applying a shader that is better adapted to color channels
You are attempting to place information into a channel that will give better results if you placed it into the color 
channel. For example, you are placing a color value into the transparency channel.



Warning: Unable to apply a shader with data in multiple channels
You are attempting to place more than one channel's worth of information into only one channel. Some 
information will not be applied. Do you want to continue?



Warning: Applying a shader that contains information that does not affect the selected channel
You are attempting to place information into a channel that will not affect the selected channel. Do you want to 
continue?



3D Paint Advice (Previewing Shading)
To use the 3D Paint Brush tools, the display mode must be set to Better Preview. Click Switch to automatically 
switch to Better Preview mode. Switching to Better Preview mode allows you to view the shaded results of your 
3D Paint application. By staying in Preview mode, you will have faster feedback, but you will see only the paint 
shape outline.



3D Paint Advice (Object Shading Layer)
The shading shape you are selecting is part of the object master shading layer. You can select and modify it only 
when working with the object master.



Shape Numerical (Shapes)
The changes you made to the current shape have not been applied. Do you want to discard them?



Shape Numerical (Paint Shape)
The change you are making in the paint shape will result in information loss. Do you want to continue?



3D Paint Advice (Paint Shape)

To edit the shader of this paint shape, exit this dialog box and double-click on the shape with the  tool.



3D Paint Advice (Scene Instance)
The object you are trying to paint on is part of a scene instance. You can select and modify only its shading when
working with the scene master. To be able to paint on this object you can do either of the following:

Edit the scene master by double-clicking on it in the current scene's perspective.
Open the scene instance in the Hierarchy window. The Scene instance will be replaced by its content.



3D Paint Advice (3D Paint Tools)
You can use the 3D Paint Tools in Preview or Better Preview mode only.



Shader Type Checking (Applying to non-color channels)
You are attempting to place information into a channel that will give better results if you placed it into a non-
color channel. The information will be converted to grayscale colors before being used in the selected channel. 
For example, you are placing a pattern shader into a refraction channel. In this case the pattern would be 
converted to grayscale before being used in the refraction channel.



Create Camera Advice
You are about to open a scene instance that does not have a camera. If you select OK, a new camera will be 
created for this scene.
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Rendering Warning
CorelDREAM detected that something happened to the scene currently rendering. You may choose to keep on 
rendering by clicking OK, or abort the rendering by clicking Cancel.



Rendering Aborted
CorelDREAM detected that something changed in the scene currently rendering and therefore was forced to 
abort the rendering.



Advice
You are about to open an object that is an instance of a master. If you select OK, a new master will be created for
this object. Any changes made to the original master object will not appear in this new master.
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Advice for a Group
You are about to open a group that is a scene instance. If you select OK, a new master will be created for this 
group. Any changes made to the original scene master will not appear in this new master.
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Open Group Advice
You are about to open a group that is a Group instance. If you select OK, a new master will be created for this 
group. Any changes made to the original group master will not appear in this new master.
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Arranging: Overview
Arranging is the process of positioning and orienting objects. The most significant part of an object's 
arrangement is its spatial relationship to other objects. In most cases, the absolute arrangement (in relation to 
the Global Universe) is relevant only to the extent that the objects should seem upright to you. For example, 
you'd probably find it confusing to work in an upside down scene, and a glass of wine placed at any attitude 
other than upright would seem to defy gravity if the wine did not spill.
If you like, you can create a tilted or upside down world simply by changing the attitude of your camera. This is 
far easier than working in a skewed universe.
Arranging one object relative to another may require a series of positioning, orientation, and alignment 
operations. Many of these commands operate under the constraints of the working box. Setting the working box 
appropriately before starting an operation will greatly simplify the procedure.
Except where noted, all of the positioning, orienting, aligning, and resizing commands work with either simple or 
grouped objects.
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About the Global Universe
CorelDREAM’s three-dimensional workspace is called the universe. The universe is displayed in the Perspective 
window. Objects in the universe are referenced using a Cartesian coordinate system (x, y, z).
All the tools you need to arrange that is, align, orient and position
objects in a scene are provided in the toolbox, located, by default, along the left side of the main window. You can

show or hide the toolbox (and the toolbar along the top of the main window) using the View, Toolbars command.
The size of the universe is determined by the size you set for your objects. However, the maximum volume of 
the universe is a 3.32 kilometer cube. On the other end of the scale, the minimum dimension of an object is 
0.006 millimeters. You can specify your object sizes in the units of measurement of your choice.

{button ,AL(`perspective_window;coordinate_systems;;;',0,"Defaultoverview",)} Related Topics



About the Perspective Window
The main work window in CorelDREAM 3D is called the Perspective window. This window shows a view of the 3D 
workspace, where objects are created and arranged in three dimensions to create a scene. The workspace itself 
is called the universe.
By default, CorelDREAM opens new scenes with one camera and one light in the universe. This camera provides 
the point of view for the display in the Perspective window. You can zoom in or out of the Perspective window 
with the Magnifying glass to get a better view of your scene. The Magnifying glass does not move the camera 
closer, but merely enlarges the view displayed in the window.
When objects are opened for editing, the Perspective window zooms in on the object (to the exclusion of other 
objects) and places different menus and special modeling/drawing tools in the main window.

{button ,AL(`modeling_window;;',0,"Defaultoverview",)} Related Topics



To open a new Perspective window on a scene
Click Windows, Perspective.

Note
You must have the Perspective window open to keep the scene open.



About the Working Box
The working box is a set of three intersecting grid planes. It is a reference superimposed on the universe. It helps
you visualize the spatial relationships of your objects and allows you to constrain arrangement operations within 
certain bounds.
The grid walls of the working box do not confine your scene in any way. You may place objects anywhere in the 
universe, within or beyond the grid planes of the working box. You can choose to display or hide all the planes or 
select which planes are displayed and which is the active plane. Furthermore, the working box is mobile: you can
rotate it, resize it, and move it to different positions in the universe.
The working box has its own coordinate system: the Working Box System. So too does the universe and each 
object or group in a scene.
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About Coordinate Systems
CorelDREAM 3D uses a Cartesian coordinate system (x, y, z) for referencing objects in the universe. The term 
Global Universe is used to refer to this coordinate system. The origin (0, 0, 0) of the Global Universe is at the 
center of the working box when you open a new scene.
The working box has its own coordinate system: the Working Box System. The attitude of the Working Box 
System axes and the position of its origin (at the center of the working box) change as you move and re-orient 
the working box.
Groups and individual objects also define their own coordinate systems. From outside the group or object, this 
system is referred to as the Object/Group System. When you jump into a group, the coordinate system is called 
the Local Root Universe. 
Having these different coordinate systems enables you to position and align an object with respect to another 
object, a group, or the entire universe.



To show or hide all working box planes
On the Display menu, click Planes.



To show or hide individual working box planes
Click the plane on the 

 button you wish to show or hide.



To make a Working box plane the preferred plane
Press the ALT key and click the plane on the 

 button you wish to make the active plane.



To set up the working box grid
1. On the View menu, click Grid.
2. Select the options and settings you want.
3. Click OK.



To move the working box

1. Choose the  tool.
2. Hold down the CTRL key and drag the working box.



To resize the working box

1. Choose the  tool.
2. Hold down the CTRL key and drag a corner of one of the grid planes.



To orient the working box with the Virtual Trackball tool

1. Choose the  tool.
2. Hold down the CTRL key and click on the working box grid.
3. Release the CTRL key and drag the circle enclosing the working box.
Tip
Holding down the SHIFT key while dragging, constrains rotation to the angle specified using the Preferences 
command on the File menu.



To position or orient the working box numerically
1. Choose the  tool.
2. Hold down the CTRL key and click on the working box to select it.
3. On the Edit menu, click Object Properties.
4. Select the reference coordinate system you want to use.
5. Set the yaw, pitch, and roll values to orient the working box.
6. Set the x, y, z position values.



To align the working box to an object or group
1. Select an object or group.
2. On the Arrange menu, click Align Working Box.

The planes of the working box are set parallel to the sides of the selected object's or group's bounding box.
The coordinate systems of the working box and object (or group) are now aligned.



To send the working box to a position
1. If you want to send the working box to an object or group, select it.
2. On the Arrange menu, select Send Working Box To.
3. Choose the position you want: Global Universe, Local Root Universe, or Selection if you have one.



To find an object using the Find command
1. On the Edit menu, click Find.
2. Enter the name of the object to find.
3. Select the search criteria that you want.
4. Click Find.

If an object is found that matches the search criteria, its icon will be highlighted in the Hierarchy window and 
the object will be selected in the Perspective window.



To select objects
Do any of the following:

Use the  tool to click on the object's preview or on one of its projections.
Point to the object’s preview or projection and hold the mouse button. A pop-up menu will appear, listing 

all of the objects beneath the cursor at that point. Select the object you want from the pop-up. (Selecting the object 
name followed by XY or 3D selects the object. Selecting the object name followed by HP selects the object’s Hot 
Point.)

Click on the object's icon in the Hierarchy window.
Drag a marquee around the objects in the Hierarchy window.
On the Edit menu, click Find and type the name of the object you want to select.

Tip
In either window or in the pop-up menu, you may hold down the SHIFT key and click on objects to add them to or
remove them from the selection.



To rename objects
1. Click on the object's name in the Hierarchy window.
2. Enter the new name.
3. Click OK.



About the Hot Point
The hot point is the single point of an object that identifies the object's location in the universe. If you look at the
numerical position of an object, the x, y, z coordinates refer to the hot point. Groups also have a hot point. The 
hot point is used in a number of arrangement operations.
The hot point of selected objects and groups appears in the Perspective windows as a small 3D sphere, which 
also casts 2D projections.
By default, an object or group's hot point is at the center of its bounding box. You can move the hot point to any 
point in, on the surface, or some distance from the object. Where you should put the hot point depends on the 
type of arrangement operation you are planning. Different operations suggest different placements of the hot 
point.
For example, with the hot point at the center of an object, a rotate command will spin the object in place. 
However, with the hot point placed some distance from the object, rotate will orbit the object around its hot 
point.



To move a hot point by dragging
1. Select the object or group.
2. Drag the hot point in 3D or drag one of its projections.

If you drag with the CAPS LOCK key down, the object will move with its hot point.
If you drag in 3D with the CTRL key down, the hot point will snap to the surface of the object beneath it.
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To put the hot point back to the center of the object
1. Select the object or group.
2. On the Arrange menu, click Center Hot Point.
Tip
You can also center the hot point by selecting it, then click the command followed by Send to Center and Apply.
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To move a hot point numerically
1. Select the object or group.
2. Select the hot point or one of its projections.
3. On the Edit menu, click Object Properties.
4. Click the box at the bottom-right corner of the dialog box and select the Coordinate System you want.
5. Enter new position values to move the hot point.

If you enable the Lock to Object option, the object will move with its hot point.
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To move an object by dragging
Do any of the following:

To move an object parallel to the preferred plane, drag its preview.
To move it perpendicular to the preferred plane, hold down the ALT key while dragging its preview.
To move an object along one of the other planes, drag the projection in that plane.
To constrain the direction of travel within a plane, hold down the SHIFT key while dragging. This will 

constrain the direction of travel to the nearest increment of the angular constraint setting which is 45 degrees.



To move an object by nudging
Select one or several objects, then press one of the Arrow keys.

Each time you press an Arrow key, the selected objects move parallel to the preferred plane one increment of 
the grid setting. You can set the grid increment using the View, Grid command.

Tips
To increase the nudge in increments of 5, hold down the SHIFT key while nudging.
To nudge perpendicular to the preferred plane, hold down the ALT key and use the Up or Down Arrow key.



To position an object or group numerically
1. Select an object or group.
2. On the Edit menu, click Object Properties.
3. Click the box at the bottom-right corner of the dialog box and select the Coordinate System you want.
4. Enter new values in the x, y, and z fields in the Position box.

A value of 0 in the x, y, or z Position box field corresponds to the center of the x, y, or z working plane.
5. Click Apply to update your changes to the selected object or group. 

When Auto (Apply) is enabled, the object's position will be updated automatically.
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To resize an object or group
1. Select an object or group.

Groups may not be resized disproportionately.
2. With the {bmc arrow.bmp) tool, drag one of the corners of the object's bounding box.

Holding down the SHIFT key while dragging resizes from the hot point out.
3. When you are satisfied with the object's new size, release the mouse button. 
Tip
You can set constraints on the resize operation by holding down modifier keys as you drag a corner. Start 
dragging, press down the modifier keys, release the mouse button, then release the keys.
SHIFT key: Maintain proportions.
ALT key: Resize only in the axis perpendicular to the preferred plane.
CTRL key: Resize using the object's hot point as a reference.



To resize an object or group numerically
1. Select the object.
2. On the Edit menu, click Object Properties.

If you want to maintain the ratio between an object's height, width, and depth, enable Keep Proportions.
To return the object to its original size, click the Reset button.

3. Click Apply to update your changes to the object.
When Auto (Apply) is enabled, the object's position will be updated automatically.

Note
Numerical resizing uses the hot point as the reference.



To orient an object or group with the Virtual Trackball tool

1. Select the  tool.
2. Click once on the object(s) or group you want to rotate.

A circle will appear around one hot point (usually the one belonging to your first selection).
3. Drag within the circle to “roll” the Virtual Trackball. Drag outside of the circle to rotate in relation to the 

monitor screen.
Tip

To constrain rotation to a given plane, choose the  tool. Then select the projections in the plane in which you 
wish to constrain rotation and drag the projection in a circular path. If you hold down the SHIFT key while you 
drag, rotation will be in increments of the angular constraint setting, which you can specify using the File, 
Preferences command.



To orient an object or group numerically
1. Select an object or group.
2. On the Edit menu, click Object Properties.
3. Click the box at the bottom-right corner of the dialog box and select the Coordinate System you want.
4. Enter new values in the Yaw, Pitch, and Roll fields.
5. Click Apply to update your changes to the selected object or group. When Auto (Apply) is enabled, the object's 

orientation automatically updates.



To mirror an object or group's orientation
1. Select an object or group.
2. On the Edit menu, click Object Properties.
3. Click the Mirrored checkbox.
4. Click Apply to update your changes to the selected object or group. When Auto (Apply) is enabled, the object's 

orientation automatically updates.
The object’s orientation changes to one that mirrors the object's current orientation across an imaginary plane 
passing through the object's hot point.



To align objects with the working box
1. Select one or more objects.
2. On the Arrange menu, select Align and click On Working Box or Fullly On Working Box.

CorelDREAM will rotate the object so that it’s bounding box is parallel to the planes of the working box.
If you choose Fullly On Working Box, CorelDREAM will restore the object's original orientation, then set its 
bounding box parallel to the planes of the working box.
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To align an object with the universe
1. Select the objects.
2. On the Arrange menu, select Align and click On Universe.

CorelDREAM will restore the object's original orientation and set its bounding box parallel to the axes of the 
universe. 
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To align objects on gravity
1. Select the object.
2. On the Arrange menu, select Align and click On Gravity.

CorelDREAM sets the Roll of the selected object to zero, without affecting its Pitch or Yaw.



To align objects relative to one another
1. Select the set of objects you wish to align.
2. On the Arrange menu, click Align Objects.
3. Select the axis of constraint from the Axis pop-up menu.

If you click the arrow at the top of the window, the window will open larger, and you can work with the x, y, 
and z axes simultaneously.

4. Select the alignment command you want for this axis: Align, Distribute, Contact, or Space.
5. Click the red arrow buttons in the Alignment window to select the anchor object.

All of the other objects will move in relation to this object.
The projection of the selected anchor object is shown in red.
For the Distribute command, click the blue arrow buttons to select the second anchor.

6. Select the reference point on the objects.
Not all object reference points are usable in some of the alignment commands.

7. Click Apply. If Auto (Apply) is enabled, your selections will be applied to the objects automatically as you make 
them.

8. When you've achieved the alignment you want in this constraint axis, move on to the next one. (Return to step
2.)



To duplicate an object
1. Select one object.
2. On the Edit menu, click Duplicate or Duplicate with Symmetry if you want to mirror the object relative to an 

imaginary plane parallel to the bottom plane.
Note
Duplicated objects are multiple instances of a single object master.
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Structuring a Scene: Overview
Structuring your scene according to the spatial or logical relationships of the objects in it, you can simplify the 
process of rearranging the scene.
The hierarchy of a scene is created as you introduce objects, group them, and create links. The hierarchy is 
displayed as a tree of elements, each represented by a named icon. Elements may be objects, groups, cameras, 
or light sources. The highest level of the hierarchy is the root. It is represented by an icon entitled universe. It 
encompasses your entire scene. Beneath the universe, you may have any number of branches and sub 
branches.
You add levels to the hierarchy by creating groups and often, nesting one group within another. You change the 
contents of groups, move objects to different levels, and create the parent-child link simply by dragging the 
icons of elements to different locations in the Hierarchy window.



About Master Objects
Most scenes use one or more duplicates (copies) of some particular object. Each duplicate is not a different 
object, but another instance of an original master object. For example, the four legs of a table are not four 
separate objects, but four instances of a master table leg.
The position, orientation, size, hot point location, and shading of each object instance may be unique. The shape,
however, must be common. If you change the geometry of an instance, you will create a new master.
Shading of instances may be unique or common. A good example of common shading would be a dozen bottles 
on a shelf, all having the same label. Working at the master level, you could change the labels on all twelve 
bottles in one operation. Working at the instance level, you could put a stain on one of the labels. Later, you 
could change all of the labels without affecting the stain.
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Linking Objects: the Parent-Child Relationship
The parent-child link enables you to easily manipulate multiple objects from a number of reference points. This 
feature is useful in creating articulations.
For example, if you wanted to create a fully articulated arm (that is, you could bend it at the shoulder), the 
elbow, the wrist, and each of the three finger joints: you should arrange the objects to construct the arm, then 
link them in the appropriate order.
Thereafter, when you rotate the upper arm (parent) around the shoulder joint (put the hot point here), the rest of
the arm (all descendants of the upper arm) goes with it. When you rotate the forearm (parent) at the elbow (put 
the hot point here), the hand and fingers go with it. And so on, down to the pinky finger. 



Distinguishing an Instance from a Master
You control the object instances in the Perspective and Hierarchy windows, and you control the master objects 
through the Hierarchy window.
The Master Objects page in the Hierarchy window shows the hierarchy of all master objects in your scene. You 
will create a new master each time you introduce a new object into the scene. If you edit an object instance and 
modify its shape, you will create a new master object.
You may have multiple instances with the same name, but you may not have two masters with the same name. 
When you create a new master by modifying an instance, CorelDREAM will name the new master by appending a
suffix to the old name.
If you modify an instance when you had intended to modify the master, you can easily get back on track by 
replacing the master object with your modified instance.
The Perspective and Hierarchy windows display a preview or icon for each object instance. You will create a new 
instance each time you duplicate an object.



About the Objects Browser Window
The Objects Browser provides an easily accessible catalog of 3D clipart objects. You can add objects from the 
Browser simply by dragging them into your scene.
You can think of the Browser as the card catalog of your clipart library. When you select one of these libraries via 
the Browse 3D Clipart command in Files menu, the window displays icons for all the objects contained in that 
library. Select an icon, and the name of the object appears at the top right hand corner of the Browser window.



About the Hierarchy Window
The Hierarchy window provides a way to manage the contents of a scene. While it is possible to work without 
using the hierarchy, you will find it indispensable as you develop more complex scenes.
The Perspective and Hierarchy windows are synchronized: as you add or remove objects from one, the display in 
the other updates automatically.
The Hierarchy window shows a logical (as opposed to visual) representation of the scene. All objects, cameras, 
and lights that you bring into the universe are represented by icons in the hierarchy. 
The Hierarchy window provides certain information on the scene’s construction that is not immediately apparent 
in the Perspective window; for example, how several elements may be grouped.



To add clipart objects using the Objects Browser
1. From the File menu, click Browse 3D Clipart.
2. Select the directory containing the object you want.

CorelDREAM will display icons for each of the available objects in the selected directory. To determine the 
name of an object, click once on the icon. The name will appear at the top of the Browser window.

3. Drag the clipart object into the Perspective or Hierarchy window.



To add an object from another scene
Drag the icon representing the object you want from the source Hierarchy window to the destination 

Perspective or Hierarchy window.
When you drag into the Hierarchy window, you can place the object in a group by dragging directly onto the 
group box.



To delete an object
Select the object in the Perspective or Hierarchy window and press the Delete key, or click Delete on the 

Edit menu.
Note
When you delete a parent object, you automatically delete all of its children. Likewise, when you delete a group 
box, you delete its contents. If this is not what you want, change the hierarchy to place the child or contents at 
some other level before proceeding.



To replace a single object or group
1. Select the object or group you want to use.
2. On the Edit menu, click Copy.
3. Select the object or group you want to replace.

You may select it either in the Perspective or in the Hierarchy window.
4. On the Edit menu, click Paste.
Note
If you are pasting an object (not a group), a dialog box will give you the option of scaling the replacement to the 
size of its predecessor (i.e., the object will occupy the same space), or scaling the replacement by the same 
factor that its predecessor was scaled. Make your choice and click OK. You can return this object to its original 
size with the Reset button in the Numerical dialog box.



To open an object for editing
Double-click the object’s preview in the Perspective window or its icon in the Hierarchy window.

You can also select the object, then click Object, Edit on the Edit menu.



To open an object for editing in a separate window
On the Edit menu, click Object, Edit in New Window.

With this feature, you can model the object in one window while checking the results in another window.
Note
Editing in a new window is not recommended for systems with limited RAM.



To edit an object in a group
Do either of the following:

Double-click the group box icon in the Hierarchy window.
Select the group, then click Object, Edit on the Edit menu.



To create a new group
1. Select the objects you want to place in the group.

You can select them in the Perspective or Hierarchy window. 
2. On the Arrange menu, click Group.

A box icon appears in the Hierarchy window under the current root. By default, group boxes are named Group 
x, where x is a sequential number (1, 2, 3...). To change the name, select the group icon in the Hierarchy 
window. Click on the name and make the changes.



To add objects to a group
Drag the icons of the objects you wish to add onto the group box icon.

Tip
To bring an object into the scene and immediately place it in a group, drag it from the source Hierarchy window 
(or the Objects Browser for clipart objects) directly onto a group box icon.



To move objects from one group to another
Drag the selected objects to another point in the hierarchy. For example, you can drag onto the universe 

icon. This will put the objects on the main branch.
Make sure you drag onto an icon.



To attach an object as a child of another
In the Hierarchy window, drag the object onto the icon of the desired parent.

Tip
To attach an object to a parent not currently visible in the Hierarchy window, drag the new element with the Alt 
key held down.
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To detach a child object from its parent
Drag it to another point in the Hierarchy window.

Make sure you drag onto an icon.
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To close a group box
In the Hierarchy window, click the 

 box next to the group.
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To open a closed group box
In the Hierarchy window, click the 

 box next to the group.
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To modify a master object
1. Click the Master Objects tab in the Hierarchy window.
2. Double-click the master object’s icon.
3. Use the appropriate tools to modify the object.
4. Click Done to close the object.

CorelDREAM updates each instance of the master object with the changes you've made.
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To replace a master object
1. If the icon of the master object you want to replace is currently visible in the Hierarchy window, drag the 

preview of your replacement onto it from the Perspective window.
2. If the master object is not visible:

Copy the object you want to use.
In the Hierarchy window, click the master objects page.
Click the master object you want to replace.
On the Edit menu, choose Paste.
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To use a group as a master
1. Arrange the set of objects.
2. Group them.
3. Drag the group's icon in the Objects page of the Hierarchy window onto the tab for the Master Objects page or 

drag the group's preview from the Perspective window into the Master Object page.
If the current scene is already selected in the Browser, you can drag into the icon area.

Note
This operation, by itself, does not duplicate the group. It merely identifies to the application that you are going to
duplicate the group, and you want the power and flexibility of master control available when you do.
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File Menu Commands
New
Opens a Perspective and Hierarchy window so that you can start a new scene.

Open
Opens an existing scene or a rendered image in a new window.

Close
Closes the active Perspective, Hierarchy or Image window. Closing a Perspective window closes its Hierarchy 
window but not vice versa. If a scene is displayed in more than one Perspective window, closing the initial 
window closes them all.

Save
Saves the active scene or rendered image with the same name and in the same location and format previously 
specified in the Save As dialog box.

Save As
Displays a dialog box so that you can specify a name and location for the active scene or rendered image.

Import
Imports a 3D DXF file into the current scene or a 2D vector graphic into CorelDREAM’s Free Form modeler.

Export
Saves a scene as a 3D DXF file or a rendered image in a variety of popular 2D formats.

Browse 3D Clipart
Opens a window containing previews of 3D objects in a selected folder. You can add these objects to a scene by 
dragging them into the Perspective or Hierarchy window.

Print
Prints the active rendered image according to options you specify. Before using this command, you must install 
and select a printer. See your Windows documentation for information on installing and selecting a printer.

Print Setup
Lists installed printers, sets the default printer, and provides options for configuring the selected printer.

Preferences
Customizes the CorelDREAM workplace to suit the way you like to work.

Recent Files
Lists the names of the scenes you worked on recently. Selecting the name of the scene opens it.

Exit
Ends the current CorelDREAM session. CorelDREAM prompts you to save any unsaved changes.



Edit Menu Commands
Cut
Removes selected objects and place them on the clipboard. From the clipboard, you can paste the object into 
another CorelDREAM scene, but not another program.

Copy
Places a copy of the selected objects on the clipboard. From the clipboard, you can paste the object into another 
CorelDREAM scene, but not another program.

Paste
Inserts a copy of the clipboard contents to the active window. The contents replace the selected object (if any) in
the Perspective window. 3D objects cut or copied to the clipboard cannot be pasted as 2D objects and vice versa.
For example, a 3D object copied from the Perspective window cannot be pasted into the Free Form modeler.

Delete
Removes the selected object. You cannot reinsert the deleted object but you can restore it by immediately 
choosing the Undo command on the Edit menu.

Duplicate
Adds a copy of the selected object. The copy is placed on top of the original and is automatically selected. The 
Duplicate command is available when working in a Perspective window only.

Duplicate with Symmetry
Adds a copy of the selected object mirroring it relative to a line that is parallel to the ground plane of the working
box.

Select All
Selects all objects including lights and cameras.

Select All Objects
Selects all objects other than lights and cameras. The Select All Objects command is available when working in a
Perspective or Hierarchy window, but not in the Free Form modeler.

Find
Searches for objects with the name you specify. Although the Find command is available when the Free Form 
modeler is active, it only works if the modeler contains a free form object.

Object
Displays a flyout menu with commands for opening the selected object for editing either in the active window or 
a new one and for closing the editor when you are finished.

Object Properties
Displays a dialog box where you can change the name of the selected object and resize, re-orient, and reposition
it with numerical precision. When working in the Free Form modeler, the Object Properties command allows you 
to resize and reposition cross section shapes. When the Objects Browser is active, information about the object 
selected in the Browser is displayed.

Object Shading Properties
Displays a dialog box where you can edit the paint shapes applied to the selected object or apply new ones.



View Menu Commands
Type
Displays a flyout menu with commands for changing the display in the active window. With a Perspective window
active, the commands enable you to view the scene from the top, bottom, front back etc. With a Hierarchy 
window active, the commands enable you to view the hierarchy horizontally, vertically, without icons etc.

Status Bar
Displays or hides the Status Bar, a strip along the bottom on the main window that provides information about 
the current operation in progress.

Toolbars
Displays or hides the various toolbars available in CorelDREAM. 

Default Quality
Sets the level of detail displayed for all objects in the Perspective window. Displaying less detail improves the 
program’s performance.

Object Quality
Sets the level of detail displayed for the selected object. The object quality overrides the default quality set using
the Default Quality command.

Planes
Displays or hides all the working box and modeling box planes. Individual planes can be displayed/hidden using 
the Planes button on the toolbar.

Production Plane
Displays or hides the box showing the area of the scene that will be included in the rendered image.

Grid
Controls the display and spacing of grid lines and whether the mouse pointer snaps to the grid when moving and
drawing.

Modeling Box Size
Controls the size of the modeling box allowing you to model an object to a specific scale.

Next Channel
Displays the next channel of information for the image in the Image window.

Previous Channel
Displays the previous channel of information for the image in the Image window.



Arrange Menu Commands 
Align
Aligns the selected object(s) with the working box, the universe or with gravity. The Align command is available 
when an object is selected in the Perspective or Hierarchy windows.

Align Objects
Aligns two or more selected objects with respect to each other. The Align command is available when an object is
selected in the Perspective or Hierarchy windows.

Group
Makes two or more objects into a single selectable entity. Once grouped, the objects respond collectively to 
certain operations such as moving and resizing. 

Ungroup
Breaks up the selected group into its individual objects. If you have grouped groups together, Ungroup breaks up
one level of grouping at a time.

Point At
Changes the viewpoint on the active scene by re-orienting the current camera so that it points at the selected 
object’s hot point. If both an object and a specific camera or light are selected, then the selected camera or light 
is re-oriented to point at the object.

Center Hot Point
Repositions the hot point of the selected object to the center of its bounding box.

Flip
Reflects the selected object across an imaginary line that runs parallel to the ground plane of the working box 
and bisects the left plane of the working box.

Align Working Box
Re-orients the working box so that it’s planes are parallel with the sides of the selected object’s bounding box. 
The Align Working Box command is available when a Perspective window is active.

Send Working Box To
Re-orients the working box so that it’s planes are parallel with the sides of the selected object’s bounding box, 
the global universe, or the selected group’s local universe. The Local Universe command becomes available 
when you double-click the group to open it for editing.

Combine
Combines two or more shapes in the Free Form modeler into a single shape. Any shape which is completely 
enclosed by another shape cuts away from the larger shape like the hole in a donut.

Break Apart
Splits shapes combined using the Combine command back into individual shapes.

Convert Text to Curves
Turns text created in the Free Form modeler into a series of Bezier curves. By editing the curves you can change 
the shape of individual letters.

Paint Shape Order
Changes the layering order of paint shapes on the selected object.



Scene Menu Commands
Camera Settings
Switches the view of the scene to a different camera and changes the camera type, lens, orientation and 
position.

Light Settings
Changes the characteristics of specific light sources. The Light Settings command becomes available when a 
light is selected in the Perspective or Hierarchy windows.

Ambient Light
Changes the characteristics of the ambient light source in the current scene.

Background
Adds a background color, bitmap, or gradient to the current scene. The background is only visible in a rendered 
image of the scene.

Atmosphere
Adds an atmospheric shader to the current scene. CorelDREAM supplies a fog shader that simulates the 
appearance of fog. Other atmospheric shaders may be available from third party sources.

Render
Renders the current scene according to the settings specified using the Render Setup command. You can choose 
to render a low-resolution preview to check your work before rendering a final high-resolution image.

Render Setup
Sets the size, resolution, file format, G-Buffer information, rendering options and rendering camera for the 
current scene. You can specify two groups of settings: one for the low-resolution preview and another for the final
high-resolution image.

Render Queue
Puts selected scenes in a queue for unsupervised rendering.

Filter
Opens a dialog box where you select and apply an Adobe plug-in image filter to a rendered image.

Filter Again
Reapplies the last image filter selected using the Filter command to a rendered image.



Cross-Section Menu Commands
Commands on the Cross-Section menu are available only when editing a free form object in the Free Form 
modeler.

Next
Moves to the object's next cross section.

Previous
Moves to the object's previous cross section.

Go To
Moves to a specifically numbered cross section of the object.

Create
Adds a cross section at the selected vertex on the sweep path.

Create Multiple
Adds a specified number of cross sections between the current one and the next one.

Remove
Removes the current cross section.

Show
Displays all cross sections or the current one only.

Show Shapes Numbers
Displays or hides numbers used to control the correspondence between shapes on adjacent cross sections. 
Shapes with the same number are swept together to form a three-dimensional object.

Options
Controls whether a cross section shape should be filled, whether it should be connected to the next cross section
and what type of skinning should be used between it and the next cross section.



Geometry Menu Commands
Except for the Surface Fidelity command, all commands on the Geometry menu are available only when an 
individual free form object has been opened for editing in the Free Form modeler.

Scale
Resizes the selected cross section shape by a specified percentage.

Rotate
Rotates the selected cross section shape a specified numbered of degrees.

Extrusion Method
Controls how shapes on adjacent cross sections are extruded. In Pipeline mode, cross sections remain 
perpendicular to the sweep path. In Translation mode, cross sections remain perpendicular to the ground plane 
of the modeling box.

Extrusion Preset
Creates a spiral, circular (torus) or straight sweep path allowing you make objects like springs, donuts and 
beams.

Extrusion Envelope
Adds or removes two pairs of Bezier curves (called path description lines) used to control how the surface of an 
object curves between cross sections. The envelope types determine whether the description lines are edited as 
a group (Symmetrical), in pairs (Symmetrical in Plane) or individually (Free).

Reset Envelope
Reverses all modifications made to a object's extrusion envelope.

Surface Fidelity
Controls how smooth the surfaces of the object appear when the object is rendered.



Windows Menu Commands
New
Opens a new Perspective window onto the current scene. Having additional Perspective windows is useful when 
you want to view the scene from more than one angle at the same time.

Workspace
Saves and loads configuration profiles containing information about the size and location of CorelDREAM's    
windows and tool bars.

Shaders Browser
Displays or hides the Shaders Browser, which is used to organize and apply shaders to objects.

Shader Editor
Displays or hides the Shader Editor, which is used to modify the attributes of shaders.

Hierarchy of Doc1, 2, 3...
Opens the Hierarchy window for the selected scene or activates it if it is already displayed.

Perspective of Doc1, 2, 3...
Activates the Perspective window for the selected scene.

Objects Browser for Doc1, 2, 3...
Displays the selected Objects Browser. This command is available only when an Objects Browser window has 
been opened using the Browse 3D Clipart command on the File menu. When you choose an open Object Browser 
window, the clipart objects in the window become available for placement in any open scene.



Objects Browser Commands
Select Directory (File menu)
Opens a directory containing 3D clipart objects so that you can add them to a scene.

Jump In New Window (File menu)
Starts a new scene with the selected clipart object.

Object Info (File menu)
Displays the name of the selected clipart object and any previously added comments. You can change the name 
and comments.



Shaders Browser Commands
New File (File menu)
Creates a new shaders family (i.e., file) after the last column in the Shaders Browser. Whenever you make 
changes in the Shaders Browser you must save them using the Files, Save All command to retain the changes.

Add/Remove Files (File menu)
Adds or removes shader files from the Shaders Browser. Removing a shader file does not delete the file, but 
removes it from the list of files the Browser loads.

Save All (File menu)
Saves shaders in all families currently displayed in the Shaders Browser.

Revert All (File menu)
Reverses all changes made in the Shaders Browser since the shaders were last saved using the Save All 
command.

New (Shader menu)
Adds a new shader with empty channels to the selected family.

Delete (Shader menu)
Removes the selected shader from the Shaders Browser.

Duplicate (Shader menu)
Makes of copy of the selected shader.

Info (Shader menu)
Displays the name of the selected shader and any previously added comments. You can change the name and 
comments.

Show Family Name (View menu)
Displays or hides the file names above the columns of shaders in the Shaders Browser.

Small Previews (View menu)
Uses small previews for displaying all shaders.

Large Previews (View menu)
Uses large previews for displaying all shaders.



Shader Editor Commands
The Shader Editor commands can be applied to a shader in the Shaders Browser, an object's surface, or a paint 
shape.

Value (Type menu)
Sets the level for a particular shader channel (except the Color channel).

Color (Type menu)
Sets the color of the Color and Highlight channel.

Texture Map (Type menu)
Loads a bitmap image for use in a shader.

Operators (Type menu)
Mixes, adds, subtracts or multiplies the values of a particular channel in two different shaders.

Pattern Functions (Type menu)
Produces a checkerboard or grid pattern.

Natural Functions (Type menu)
Produces a pattern resembling wood, spots or marble.

Only One Level (View menu)
Displays just the first level of the shader tree under the selected channel.

Expand All Levels (View menu)
Displays all levels of the shader tree under the selected channel.

Jump Out (View menu)
Returns to the next highest level in the shader tree when jumped into a subshader.

Jump In (View menu)
Displays controls for editing a subshader that is, a shader located above the lowest branch on the shader tree.

Flat Preview (View menu)
Shows the shader as it would look on a flat surface. Useful when you want an undistorted view of a texture map.

Sphere Preview (View menu)
Shows how the shader will look on the surface of an object.



Toolbar/Toolbox: Overview
The toolbar along the top of the main CorelDREAM window contain buttons that provide quick mouse access to 
many of CorelDREAM's commands and features. For example, there are buttons for starting new scenes, printing 
rendered images, and copying and pasting objects.
The toolbox, which is displayed along the left side of the main window contains tools for adding and 
manipulating objects and for zooming in and out on objects. The tools displayed in the toolbox change when a 
free form object is opened for editing in the Free Form modeler.
You can display or hide individual toolbar and toolbox using the Toolbars command on the View menu. You can 
also move the them anywhere on the screen by placing the mouse pointer on an empty area on the toolbar and 
dragging. To return the toolbar and toolbox to its usual place, drag it to the menu bar or to the left side of the 
main window.
When you point to a button with the mouse, the button name will appear in a box.



Standard Toolbar

The buttons on the Standard toolbar perform some of the most common tasks in CorelDREAM, such as opening 
new scenes, printing rendered images and copying and pasting objects.

{button ,AL(`toolbar overview;',0,"Defaultoverview",)} Related Topics



Toolbox
The buttons on the Manipulation toolbar are used to manipulate objects and magnify objects in a scene.

 
 Selection Tool
Selects objects in the Perspective, Hierarchy and Objects Browser windows. After you select an object you can 
modify it using commands in the menus or other tools. Use the  tool to select paint shapeson the surface of 
objects.

 
 Rotation Tool
Use to rotate selected objects. The Rotation tool rotates the object along one axis. To rotate the object in three 
dimensions use the Virtual Trackball tool.

 

 Zoom/Pan Tool

Use to enlarge or reduce your view of objects in the Perspective window or the Free Form modeler. Use the    
tool to pan the view in a Perspective or Modeling window.

 Free Form tool
Use to create a 3D object from scratch in the Free Form modeler.

 3D Text Tool

Use to add 3D text objects. 3D text is edited using the 3D text editor. For greater flexibility, you can use the  
tool in the Free Form modeler to create 2D text and then use the modeler to control how it is extruded.

 Wizard Tool
Displays a series of dialog boxes that lead you through the steps of creating a particular style of 3D object.

 Basic 3D Objects
Adds a simple geometric object such a cone, cube or sphere to the current scene. Unlike free form objects, basic 
objects cannot be modified in the Free Form modeler.

 Pen Tool
Use to draw Bezier curves. Depending on where the curves are drawn, they define the shape of the object being 
created, or the path along which it is extruded. The Pen tool becomes available when you add a free form object 
or open one for editing in the Freeform modeler.

 Vertex Editing Tool
Use to select, add, and delete points on a path and to convert corner points to curve points and vice versa. The 
Vertex Editing tool becomes available when you add a free form object or open one for editing in the Freeform 
modeler.

 2D Primitive Tools
Use the draw basic 2D shapes such as rectangles and ellipses. The 2D Primitive tool becomes available when 
you add a free form object or open one for editing in the Freeform modeler.

 2D Text Tool
Use to add text which can be modified in the Free Form modeler. The 2D Text tool becomes available when you 
add a free form object or open one for editing in the Freeform modeler.

 Add Light
Adds a light source to the active scene.

 Add Camera
Adds a camera to the active scene.

 Render Area Tool
Use to select an area of the Perspective window so that you can preview shaders with maximum detail.

 Paint Shading Shape Tool
Use to define a rectangular, circular or polygonal paint shapes.

 3D Paint Brush
Use to designs on the surface of an object in a completely free form manner.



 Shader Eyedropper
Use to copy one object's shader to another object
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Open/Import dialog box
Use to open an existing CorelDREAM scene, a rendered image file, or a bitmap file created in another program. 
CorelDREAM files open in a Perspective window, and the other file types open in an Image window.



Save As/Export dialog box
Use to save a scene or a collection of shaders to disk. You save a scene in CorelDREAM’s native format (*.DRM) 
or in DXF format. Use the Files of Type box to choose the format you want to save the current scene in. Shaders 
are saved in a file with an SHD extension.



Preferences dialog box
Use to customize the CorelDREAM environment. Under General Preferences, you can choose the units of 
measure, the default color model, whether the program always starts with an empty scene, whether it shows the
Scratch Disk Activity, and whether it uses Zoom Effect when opening the Modeling window.
To set the other preferences, choose a category from the list box near the top of the dialog box. Click the topics 
below for information on the preference settings in each of the categories.
Imaging, Scratch Disk Preferences
Shader Editor Preferences
3D Paint Preferences
Free-Form Modeler Preferences
Objects Browser Preferences
Shaders Browser Preferences
Perspective Preferences
Hierarchy Preferences
The preferences take effect immediately and remain in effect until you change them.



Imaging, Scratch Disk Preferences
Scratch Disk
CorelDREAM 3D uses free space on your hard drive to store portions of the scene you are working on. The disk 
that CorelDREAM uses for this is called the scratch disk. For optimum performance, choose a scratch disk that 
has plenty of free space. If scratch disk space and memory are limited, zooming will also be limited. You may 
want to use a disk utility to keep your scratch disk optimized.
By default, CorelDREAM chooses your startup disk as the scratch disk. However, you may select any of your hard
disks as the scratch disk.

Plug-Ins
Identifies the directory where CorelDREAM looks for plug-in filters. To specify another directory, click the 
Directory button and click the directory. If you plan to share filters between applications, move them all to a 
single directory so that CorelDREAM can access all of them.

Screen Display
Specifies whether colors displayed on screen are dithered.



Shader Editor Preferences
Skip type incompatibility warnings
Enable this check box to skip warnings when placing information in a channel and the information is not 
compatible with the type of information expected in this channel.

Skip multiple channels warnings
Enable this check box to skip warnings when adding channel information containing multiple components of 
information into one component.

Do not pause preview while applying
Enable this check box to continue the redrawing of the Shader Editor preview while you are applying the shader.

Default Apply Mode
Choose whether you want all shaders channels applied to an object's primer or non-empty channels only.
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3D Paint Preferences
Stroke/Shape redraw
For immediate feedback as you use the 3D Paint tools, enable Refresh as Stroke is Drawn. For improved 
performance, enable Wait for End of Stroke to Refresh.
When enabled, Show Transparency/Reflection produces better results in previews, but slows the program’s 
performance.

Paint Brush Shapes
Resolution slider: Increasing the resolution slows redraw time but produces better results in previews.
Beep when creating new shape: Click to have CorelDREAM beep when a new paint shape is created.

Advice
Skip Preview Mode warning:    Enable if you do not want CorelDREAM to warn you that the operation you are 
requesting must be performed in preview mode.
Skip Wrong Layer warning:    Enable if you do not want CorelDREAM to warn you that the operation you are 
attempting is placing data in the wrong layer of the shader.

Shape Outlines Colors
Click to change the color of the Paint Shape marquee.

Rubberband
Affects the visual feedback CorelDREAM provides when painting with the brush tool.
Use Color Outline: Enable to use actual outline color but at the expense of performance.
Invert: Enable to reverse the outline so that it appears white against a dark background or vice versa. Results in 
faster performance.
Adapt to Video Performance: Enable to have CorelDREAM decide whether to use a color or inverted outline based
on the performance characteristics of your system.
Rubberband fidelity: Increase to draw smoother curves but at the expense of performance.



Free Form Modeler Preferences
Ask for name when creating a new object
Enable this check box to have CorelDREAM prompt you for a name when creating a new object. Otherwise, 
CorelDREAM names the objects Free Form 1, Free Form 2, etc. You can rename the objects by clicking the name 
in the Hierarchy window.

Resize Shapes and Groups
Specify whether you want shapes and groups resized from the center out or from the corner you are dragging.
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Object Browser Preferences
Enable the Drop Clip Art As Scene Instance check box to use any clip art object as an instance object, not a 
master object.
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Shaders Browser Preferences
Saving Shader Database On Quit
Ask For Confirmation: Enable to have CorelDREAM prompt you to confirm the saving of changes to the Shaders 
Browser when quitting.
Save: Enable to have CorelDREAM automatically save changes to the Shaders Browser when quitting.
Don't Save: Enable if you want CorelDREAM to prompt you to save changes to the Shaders Browser when 
quitting.

Default Apply Mode
Enable Apply All Channels if you want to completely replace an object’s primer with the shader you are applying 
rather than just replacing the channels that have information in them.
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Perspective Preferences
Working Box Color
Click to customize the colors used for the inactive and active planes of the working box and the border of the 
working box.

Working Box
Sets the size of the working box and choose the default units of measurement.

Initial Grid Values
Sets the default grid values for the working box.

Constraints
Sets the angle that the working box will be constrained to when rotated with the SHIFT key held down.
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Hierarchy Preferences
Warnings
Skip Open Scene Alerts: Enable to prevent CorelDREAM from displaying a warning that a scene is already open.
Skip Jump-In Instance Alerts: Enable to prevent CorelDREAM from displaying a warning when jumping into an 
object instance.
Skip Create Camera Alerts: Enable to prevent CorelDREAM from displaying a warning when creating a new 
camera.

Display
Horizontal: Click to display the contents of the Hierarchy window horizontally from the root.
Vertical: Click to display the contents of the Hierarchy window vertically under the root.
Centered: Click to display the contents of the Hierarchy window centered under the root.
Outline: Click to display the contents of the Hierarchy window using the same hierarchical conventions as the File
Manager. Groups correspond to folders, and objects correspond to files.
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Folder Selection dialog box
To select the folder where CorelDREAM looks for extensions
1. Click the Drives list box and select the drive containing your extensions.
2. Click the folder in the Folder list containing your extensions.
Notes

By default, CorelDREAM searches for extensions in the EXT folder created during installation.
If you plan to share extensions between applications, move all your filters into a single folder so that 

CorelDREAM can access all of them.



Camera Parameters dialog box
Use to add a new camera to the current scene. Although you can have more than one camera per scene, you 
can view the scene through only one camera at a time.

Name
Type a name for the new camera or use the name CorelDREAM provides.

Type
Click the type of camera you want to use: A conical camera is patterned after the standard 35mm single lens 
reflex (SLR) camera. An isometric camera gives a view in which object size is not related to distance from the 
camera there is no vanishing point.

Lens Type/Zoom Factor
Click the type of lens for a conical camera. Use the Zoom slider to set the focal length for a conical camera with 
a telephoto lens or to set the field of view for an isometric camera.



Filter dialog box
Use to select the filter you want to use to process a rendered image or a texture map in the Shaders Editor.
CorelDREAM does not have filters but most of those included with Adobe Photoshop or from a third party are 
compatible with CorelDREAM. If a filter is incompatible it will not display in the Filter dialog box.
To use filters you must first identify the folder containing your plug-in modules (filters) using the File, Preferences
command.



Ambient Light dialog box
Use to set the color and brightness of the ambient light source in the current scene.

Color
You can choose colors using either the RGB or the CMYK color model. Or, double-click the color swatch to choose 
your color using the color picker.

Brightness
Drag the slider to set the brightness or type a value from 0 to 100.



Background/Atmosphere dialog box
Use to add a background or atmospheric shader to the current scene.

Background
In a rendering, regions of the image where there are no objects are considered background areas. A background 
can be a color, a bitmap, a bi-gradient or nothing.
Clicking Bitmap displays controls for choosing and manipulating (rotating, tiling, filtering, etc.) the image file.
Clicking Bi-gradient displays controls for choosing the colors used to create the gradient.

Atmosphere
CorelDREAM comes with a single atmospheric shader for mimicking fog. Other atmospheric shaders may be 
available from third parties. In a foggy atmosphere, objects farther away from the viewpoint are fainter (hidden 
behind fog) than objects that are close.
Clicking Fog displays controls for specifying where the fog begins and how dense it is.



Preview Settings/Final Settings dialog box
Use to adjust settings for rendering a scene. You must render a scene before it can be printed or opened in a 
photo-retouching or page layout program.
The two Rendering commands (Preview and Final) provide access to the same settings. This enables you to set 
your final settings while you experiment with different settings for previews.

Size
Sets the dimensions and resolution of the rendered image. Because pixels are a different size on devices of 
different resolution, set the image size according to the output device you will use.
Click the Estimate button to check how long the rendering will take. If time is more important than quality, type a
time limit in the Best Resolution In boxes. CorelDREAM will determine the optimum resolution possible for 
rendering within the allotted time. Click the Best Resolution button to check the resolution.

File Format
Sets the format to save the rendered image, and sets what kind of data describing your rendered scene is put 
into the final rendered image.
CorelDREAM can put data describing your rendered scene in more than a dozen separate channels. If you are 
interested only in the image, the three color channels contain all the data you need. However, if you are 
planning to composite this image or do other advanced post-production work, such as 3D filtering, you may 
place G-Buffer (Geometry Buffer) data in other channels.
For information about the other channels, see G-Buffer Channels.

Options
Sets the type of renderer to use, ray tracing options, and the rendering camera.
Two renderers are provided with CorelDREAM: the Z-Buffer and the Ray Tracer. Other renderers may be available 
from Corel or from a third party as an extension.
The Z-Buffer renderer is fast, but is not capable of the more complex lighting effects: shadow, transparency, and 
reflection. If you need these effects, you should choose ray tracing. The settings displayed when you choose Ray 
Tracing enable you to select which lighting effects channels to use. For more information, see Ray Tracing 
Options.



G-Buffer Channels
The data in each of the G-Buffer channels describe the point in your 3D scene that each pixel in the image 
represents. For example, if the scene shows a drinking glass on a wooden table, each pixel in the rendered 
image corresponds to a point on the glass or on the table in your 3D scene.
Not all file formats are capable of storing all of the channels possible. To retain all of the channels you enable, 
use the Adobe Photoshop format. Each channel adds to the file size considerably.

Pixel color
Determined not only by shading, but also by lighting effects. For example, looking through a drinking glass, we 
can see the wooden table behind. The color of a specific pixel in the glass appears as the color of the wood 
filtered through the translucent glass.

Mask
A mask is a shadow image of your scene. It describes where objects are, versus where they are not. The mask is 
used as a stencil to enable portions of your image when you paste onto a background in a photo-retouching 
program. Pasting a foreground image onto a background is called compositing.
CorelDREAM puts the mask data in channel #4, the Alpha channel, which is where masks are usually kept in 
applications like Adobe Photoshop.

Distance
Describes the distance of the given point from the viewpoint. A 3D filter might use this channel to put points 
beyond a certain range out of focus to simulate the depth-of-field effect in photography.

Object index
Relates each pixel in the image to the object its corresponding point belongs to. With an object index, you might 
customize the Corel PHOTO-PAINT Magic Wand tool to select individual objects regardless of color. This works as 
long as the objects do not overlap.

Normal vector
Describes the vector that is perpendicular to the object surface at the given point. Information in this channel 
could be used to simulate additional light sources.

Position
Describes the coordinate of each point in the image. 3D position uses three channels, one for the x value, one 
for the y, and one for the z.

Surface coordinate
Describes the location of the point on the object in relation to the object surface coordinate system. This is a 
two-dimensional mapping system.



Ray Tracing Options
The rendering time for ray tracing depends primarily on the resolution. The rendering time also depends on the 
number of light sources and the shading characteristics of objects.
Because of these variables, CorelDREAM allows you to disable any or all of these lighting effects channels and to 
set maximums. For example, there must be a limit to the number of reflections. This ensures that two mirrors 
placed in facing each other do not reflect each other endlessly. (In which case, rendering would never finish!)

Reflection
Enable to render reflective surfaces. The maximum value for reflection sets the number of times a light ray will 
bounce off objects as it travels through the scene.

Transparency
Enable to render transparent surfaces. The maximum value for transparency sets the number of transparent 
objects a light ray will travel through before stopping.

Refraction
Enable to render refractive surfaces. The maximum value for refraction sets the number of times a light ray will 
bend as it travels through refractive objects.

Shadows
Enable to render shadows.

Lighting Through Transparent Objects
Enable to render lighting effects through transparent objects. This adds to the rendering time and should not be 
used if your scene does not include transparent objects.

Bump
Enable to render effects created using the Bump channel in the shader editor.

Adaptive Oversampling
Enable to use adaptive oversampling. Adaptive oversampling is a technique that resamples the picture, resulting
in a smoother image.

Silhouette Quality
Use the slider bar to adjust how accurately the edges of objects are calculated during the rendering. Increasing 
Silhouette Quality increases rendering time.



Add/Remove Files dialog box
Use to add files to, or remove them from, a list. In the Render Queue, the list corresponds to files to be rendered.
In the Shaders Browser, the list corresponds to the shaders that are automatically loaded into the Shaders 
Browser when CorelDREAM is started.



Object Properties dialog box
Use to position, resize, and orient a 3D object, a light, a camera, and the working box precisely in relation to the 
coordinate system. If you are working with 2D shapes, see Object Properties dialog box for 2D shapes.

X, Y, Z (Position)
Enter the x, y, z position for the selected objects. A position of 0, 0, 0 corresponds to the center of the x, y, and z
working planes. The x, y, z values describe the position of the hot point in the selected object.

Yaw, Pitch, Roll (Orientation)
Enter the Yaw, Pitch, and Roll values, measured in degrees, for the selected object. Orientation is the rotation of 
the object in 3D space.

SizeX, SizeY, SizeZ (Size)
Enter the value for the size of the selected object. By changing any of the Size x, y, or z values an object can be 
lengthened or shortened in any dimension. Click the list box to the right of the size values to change the unit of 
measurement.

Keep Proportions
Enable to make any changes in the size of the selected object proportional.

Mirrored
Enable to apply an orientation to the selected object that is the opposite or mirror of the current orientation.

Auto
Enable to automatically apply any changes to the object.

Apply
Click to apply the changes to the currently selected object.

Global, Wbox, Object (Coordinate System)
Use the coordinate system pop-up found in the lower right corner of the Numerical dialog box to select the 
system you want. The Numerical dialog box displays the currently selected coordinate system in an abbreviated 
format.
Global = Global Universe
Wbox = Working Box
Object = Object/Group
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Object Properties dialog box for 2D shapes
Use to position and resize a 2D shape precisely in relation to the coordinate system. Applies only to shapes in 
the Free Form modeler.

Left, Top: Position
Enter the numerical position for the left and top sides of the selected shape's bounding box. A position of 0.00 
corresponds to the center of the drawing plane. 

Width, Height: Size
Enter the value for the size of the selected shape. Click the list box to the right of the size values to change the 
unit of measurement.

Keep Proportions
Enable to make any changes in the size of the selected shape proportional. 

Auto
Enable to automatically apply any changes to the shape.

Apply
Click to apply the changes to the currently selected shape.



Alignment dialog box
Use to arrange objects in the Perspective window with respect to each other.

Axis of Constraint
Choose the axis (x, y or z) in which to align the selected objects. If you click the arrow at the top of the window, 
the window becomes larger, and you can work with the x, y, and z dimensions simultaneously.
Anchor
Specifies the object that you want to keep its position. All the other objects move in relation to this object.
Click the red arrows to select the anchor object. For the Distribute command, click the blue arrows to select the 
second anchor.
Alignment Options
Align: Sets the reference point of each object to the reference point of the anchor object along the axis of 
constraint.
Distribute: Places the reference point of each object, evenly spaced in relation to the two anchor objects, along 
the axis of constraint. The reference objects do not move in distribution. Therefore, Distribute has no effect on a 
selection of only two objects.
Contact: Brings the BoxMax of each object into contact with the BoxMin of the next object along the axis of 
constraint.
Space: Puts the specified distance between the reference points of each object. Enter a value and use the pop-
up to set the units.
None: Shows the objects at their original position.

Reference Points
Specifies the reference point used to align the selected objects.
Hot point: Aligns on each object's hot point.
Box Min: Aligns the edge of each object's bounding box with the lower coordinate value (closer to the 
intersection of the three planes of the working box) along the axis of constraint.
Center: Aligns using the center of each object's bounding box.
Box Max: Aligns the edge of each object's bounding box with the higher coordinate value (farther from the 
intersection of the three planes of the working box) along the axis of constraint.
Sides: Aligns the sides of the object's bounding box.

Auto
Enable to automatically apply any changes to the object.

Apply
Click to apply the changes to the currently selected object.



Save Workspace dialog box
Use to save different workspace layouts (i.e., window size and position) in configuration profiles, which you can 
load at any time.
To save a workspace profile:    Set the workspace as you like it. Then, choose Workspace on the Windows 
menu and click Save. Type a name and click OK.
To load a saved profile: On the Windows menu, choose Workspace and click the name of the profile you want 
to load.
To remove a workspace profile: If you no longer need a particular profile, choose Workspace on the Windows 
menu and click Remove. Then, select the name of the profile and click Remove.



Shading Properties dialog box
Use to edit an object's 3D Paint shapes with numerical precision. All the positioning, sizing, and layering 
operations that you can perform on the surface of an object with the 3D Paint tools can also be performed 
through the Shading Info dialog box. The Shading Info dialog box also allows you to convert a paint shape from 
one type to another, change an object's mapping mode, and work with the object instance and master shading 
layers.

Shading Layer
Specifies whether to edit all instances of the selected object or the individual instance only.

Mapping Mode
Changes the way CorelDREAM applies the paint shape to the selected object’s surface. From left to right the 
icons represent the mapping modes as follows: surface mapping (the default mode), box mapping, spherical 
mapping or cylindrical mapping. For best results, choose the mode that most closely resembles the shape of the 
object you are mapping.
For box mapping, choose the face of the box to map the paint shape onto. For spherical or cylindrical mapping, 
choose the orientation of the paint shape with respect to the object.

Shape Shade List
Lists the paint shapes applied to the selected object. Any changes you make in the Shading Info dialog box are 
applied to the shape selected in this list.

New
Creates a new paint shape on the surface of the object, using the default size, position, shape, and shader. You 
can change all but the shader from the Shading Info dialog box.

Delete
Deletes the selected paint shape from the selected object.

Move Forward, Move Backward
Moves the paint shape selected in the Shape Shade list forward or backward in the layering order. The topmost 
paint shape appears at the top of the list.

Shape
Changes the selected paint shape from one type to another.

Position, Size
Sets the position of the selected paint shape. The Size values determine the size of the paint shape's bounding 
rectangle. The Position values determine the position of the paint shape's upper left corner on the surface of the 
object.
The numbers immediately to the right of the Size and Position boxes represent the range of possible values for 
each dimension.

Opacity
Sets the opacity of the selected paint shape. The opacity of a paint shape is not related to the transparency 
value you set in the Shader Editor. A shader's transparency setting determines the degree to which light passes 
through a surface; the opacity setting determines the extent to which a particular paint shape hides or shows the
paint shapes below it.

Apply
Applies the changes to the selected paint shape.



Cameras Settings dialog box
Use to adjust the camera currently selected in the Hierarchy window.

Name
Selects the camera from which to view the scene and whose settings you want to change.

Type
Sets the type of camera. A conical camera is patterned after the standard 35mm single lens reflex (SLR) camera.
An isometric camera gives a view in which object size is not related to distance from the camera there is no 
vanishing point.

Lens Type/Zoom Factor
Sets the type of lens for a conical camera. Use the Zoom slider to set the focal length for a conical camera with a
telephoto lens or to set the field of view for an isometric camera.

Position
Sets a preset position for the camera. The default presets are at the top of the list box. Use Save Position if you 
have set a camera position you want to reuse in other scenes. The presets you save are added at the bottom of 
the Position list box. When the camera position and orientation are not at one of the default presets, the 
Position list box displays Custom.

Click to display the Camera Increments dialog box where you can change the distance or degree a camera 
moves with each click of the Rotate and Translate controls.

Rotate and Track
Click the arrows to change the orientation and position (tracking) of the camera. The tracking directions are 
relative to the camera’s current attitude not an axis of the global universe or working box.



Camera Increments dialog box
Use to change the distance or degree a camera moves with each click of the controls in the Camera Settings 
dialog box.

Track
Type the distance you want the camera to move with each click of the Tracking controls. Use the adjacent list box
to change the unit of measure.

Rotation
Type the number of degrees you want the camera to rotate with each click of the Rotation controls.



Grid dialog box
Use to set up the grid. The grid settings apply to both working box in the Perspective window and the modeling 
box in the Free Form modeler.

Grid Increment
The grid increment sets the spacing between the grid lines. It also sets the nudge distance i.e., the distance an 
object moves with each press of an Arrow key.
The value and unit you choose should correlate to the scene you are developing. For example, if you're creating 
a building, one foot or meter should provide enough accuracy for most operations.

Show
Enable to display the grid on screen.

Snap to Grid 
Enable to have objects you move by dragging snap to the nearest grid increment.
You can temporarily toggle Snap to Grid on or off by pressing the CTRL key while moving a selected object.
The hot point of the object, not the edge of the projection, is what snaps to the grid.

Draw Line Every
Sets the number of increments between displayed grid lines. When the setting is 1, the increment and displayed 
grid lines correspond directly.
Sets the number of increments between displayed grid lines to a value greater than 1 if you want fine control 
over the Snap to Grid function but do not want many grid lines visible.



Cross Section Options dialog box
Use to set several parameters for a particular cross section.

Fill Cross Section
Specifies whether or not to fill the section. For example, a cylinder with its first and last sections not filled would 
be a tube that you could look through.

Disconnect from next Cross Section
Enable to turn off extrusion between this section and the next one. Use this parameter to create an intermittent 
object.

Skinning Type
Skin Shape-to-Shape: This is the default setting and it will yield good results in most cases. Shape-to-shape 
skinning is especially well suited for creating smooth surfaces. It is far superior to point-to-point skinning when 
connecting cross sections whose shapes are significantly different; if adjacent cross sections have different 
numbers of vertices, shape-to-shape skinning is the only option available.
Skin Point-to-Point: Use point-to-point skinning when adjacent cross sections contain very similar shapes, and 
you want each vertex in one cross section to be connected directly to the corresponding vertex in the next cross 
section. This option is useful when you model an object that requires straight, sharp edges.



Edit Object Name dialog box
Use to edit the name of the object instance. Type the new name and click OK.
New objects are named by default Type xx, where Type gives the object description (Free Form, Sphere, Text, 
etc.) and xx is an incremental number. Naming objects is useful in managing the contents of your scene. As the 
number of objects in a scene increases and their spatial proximity becomes close, finding the object's name in 
the hierarchy or with the Find command is often easier than picking it out of a cluster of similar objects.



Number of Sides dialog box
Enter the number of sides for the polygon. The maximum number of sides is 128.



Size of Pasted Object dialog box
When you replace an object, the replacement takes on the positioning, alignment, and size characteristics of the 
object it is replacing. If you are pasting an object (not a group), a dialog box gives the following options for sizing
the replacement:

Fit in Box
Scales the replacement to the size of its predecessor (i.e., the object will occupy the same space).

Keep scaling
Scales the replacement by the same factor that its predecessor was scaled.
You can return the pasted object to its original size with the Reset Button in the Numerical window.



Shader Info dialog box
Shows the current shader's name (you can change it) and a box in which you can type comments.



Create Shader dialog box
Use to create a new shader in the Shaders Browser. Enter the name for the new shader and click OK.



Go To dialog box
Use to move to a particular cross section by specifying its number. Cross sections are numbered from left to 
right.
You can also use the Next and Previous commands on the Cross Section menu to move the drawing plane 
between adjacent cross sections.
You can CTRL+Right Arrow key to advance to the next cross section and CTRL+Left Arrow key to go back to the 
previous cross section.



Create in-between Cross Sections dialog box
Use to create a specific number of evenly-spaced cross sections between the current cross section and the next. 
A new point will be added to the sweep path for each cross section created.
The shapes on the new cross sections will be interpolated from the shapes on the existing cross sections. This 
process is similar to blending between two shapes in a 2D illustration program: each shape on the new cross 
sections will be like one step in the blend.



Surface Fidelity dialog box
Use to set the surface fidelity of the selected object. The higher the surface fidelity value, the smoother the 
object will appear when rendered.
The surface fidelity value is resolution independent. That is, if a particular value yields good results for a given 
object in a given scene at low resolution, it should yield good results at higher resolutions as well.
Higher surface fidelity settings increase the RAM requirements for the scene.



Options dialog box (Opening .DXF files)
Use to specify how you want CorelDREAM to translate information in the .DXF file.
If the .DXF file does not import correctly, verify that the file contains only 3D faces, meshes, or extruded poly-
lines .DXF files containing points, lines, and arcs are not supported by CorelDREAM.
Import and extrude 2D objects
Enable to extrude 2D .DXF files. This is useful to automatically build the walls of a floor map done in ClarisCAD, 
Vellum or AutoCAD and exported as a .DXF file. The extrusion value is based on the same unit system that was 
used in the original file.
Smooth Surfaces
Enable to have smooth shading on surfaces. A minimum smoothing angle can be set. For example, with a 30 
smoothing angle, the surface at the junction of any two facets with less than 30 of difference will be smoothed. 
Group all 3DFACE in a single object
Enable to group all imported 3D faces (3DFACE is a 3D face with 4 vertices) in one single object. This is useful 
when importing 3D type, a logo, or a CAD object that benefits from being treated as a single object.
Separate 3DFACE by Layers and Color
Enable if objects need to be separated by layers and colors. 3D faces that are in the same layer and of the same 
color will be treated as a single object. 
Import only 3DFACE entities
Most 3D packages export only 3DFACE information, but some of them add other entities like lines or 2D layout 
drawings that may not be needed during the importation. Enable this option if you do not want this other 
information.
Coordinate System to use
If you are not familiar with AutoCAD and/or do not want to worry about this option, leave the WORLD system 
enabled. WORLD stands for the WCS (World Coordinate System) and CURRENT for the UCS (User Coordinate 
System) used when the .DXF file was saved.
Not all CAD software uses both UCS and WCS; many use only WCS. If this is the case, leave the WORLD 
coordinate system enabled.

Scaling Conversion Factor
Relates the scale of the original .DXF drawing to a unit value. In the 1 .DXF unit equals____ box, enter a value. 
Then, select the appropriate unit of measurement in the adjacent list box.
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Importing .DXF Files
DXF is a public export file format used by Autodesk and other CAD vendors.
CorelDREAM can import both 2D and 3D .DXF data. However, since CorelDREAM deals exclusively with 3D data, 
2D .DXF data can be automatically extruded to generate 3D objects.
Because the .DXF file format does not support the higher level notion of objects, models and scenes created 
in .DXF-compatible packages should, whenever possible, be designed with separate objects in separate layers. 
Facets in separate layers are assumed to belong to different objects.
Also, 3D facets with different colors are assumed to belong to different objects. Objects in the same layer but 
made of different colors will be imported as separate objects.
During .DXF importation, a flat hierarchy is created. Objects found in a single layer are grouped.
Occasionally, after importing a .DXF file you will see many objects in CorelDREAM. If that happens, go back to 
the original program and select the appropriate options to save the data as 3DFACE entities.



Object Info dialog box
Use to change the name of, and add comments to, a clipart object in the Objects Browser.

Object Name
Displays the name of the currently selected object in the Objects Browser. You can type in this box to change the 
name.

Comment
Enter any comments regarding the selected objects.



Torus dialog box
Use to create a donut-like object called a torus. In the Distance to Axis box, type the distance of the cross section
from the torus' central axis. This value determines the radius of the torus.



Spiral dialog box
Use to automatically set up a spiral sweep path for creating objects like a spring or slinky.
NOTE: The Spiral command makes changes to the object that cannot be undone.

Number of Turns
Sets the number of turns with one turn equal to 360 degrees.

Length
Sets the length of the spiral sweep path. The relationship between the number of turns and the length 
determines how 'tightly' the coils of the spiral are spaced.

Distance to Axis
Determines the size of each coil by setting the distance between the cross section shape and the spiral's central 
axis.

Cross Section Scaling
Shrinks or enlarges the cross section shape as it sweeps along the spiral path. Values less than 100% shrink the 
shape; values greater than 100% enlarge the shape.

Spiral Scaling
Decreases or increases the distance to the axis as the cross section shape sweeps along the path. Values less 
than 100% taper the spiral; values greater than 100% widen it.



Modeling Box Size dialog box
Use to set the scale of the modeling box in relation to objects in the scene. By default, the Modeling window will 
open at a scale consistent with the proportions of objects in the scene. If you want to work with this particular 
object at some other scale, you may.

Box Size
Sets the dimensions of the modeling box.

Scale object with Modeling Box
Disable if you want to resize the modeling box without resizing the object.



Resizing dialog box
Use to resize a cross section. Resizing cross sections directly is seldom necessary. The scaling envelope can 
accomplish the same results more easily and powerfully.

Horizontal
Sets the percentage increase or decrease in the shape's width. Values greater than 100 increase the width; 
values less than 100 decrease the width.

Vertical
Sets the percentage increase or decrease in the shape's height. Values greater than 100 increase the height; 
values less than 100 decrease the height.



Rotate dialog box
Use to rotate a cross section.

Angle
Sets the degree of rotation and the direction: clockwise (CW) or counter-clockwise (CCW).

Twist Surface
Enable to rotate the surface of the object to give it a twisted appearance like the threads of a screw. To specify 
multiple twists, enter values greater than 360 for Angle.

Rotation Center
Determines whether the object rotates about its own center or the drawing plane's center.



Render Queue dialog box
Use to batch several rendering jobs in a queue for deferred, unsupervised processing. By default, batched files 
are rendered automatically using the saved artwork settings from the file. However, render queue rendering 
parameters can be set to use specific artwork settings for the entire batch or to use different settings for each 
file in the render queue.
During rendering, CorelDREAM displays and processes each scene one at a time. Rendered images can be saved,
then opened or edited in photo retouching programs. Files in the render queue can be added or removed at any 
time.

Scene File/Image File/Status
Lists the files contained in the render queue. File names are followed by the size set in the Artwork Settings 
dialog box for that file.
Files displayed in a grayed out font have been rendered and saved. The file displayed in a bold font is currently 
being rendered. A standard font displays files not yet rendered.

Add
Displays a file selection dialog box for selecting scenes to render. Select the scenes you want to render, then 
click Add followed by Close to return to the Render Queue dialog box.

Delete
Deletes the selected file from the queue.

Clear
Deletes all files in the queue.

Settings
Displays the Artwork Settings dialog box so that you specify how to render the selected file.

Launch/Abort
Click Launch to start processing files in the render queue. Click Abort to stop processing of files in the render 
queue.

Pause/Resume
Click Pause to temporarily stop processing files in the render queue. Click Resume to restart processing of files.



2D Text dialog box
Use to add 2D text that can be manipulated in the Free Form modeler like any other cross section shape.

Text entry box
Type the text you want to add to the cross section.

Font/Style
Lists the available fonts and styles. Only TrueType and Adobe Type 1 fonts are available for text objects.

Alignment
Sets the alignment (left, centered or right) for multiple lines of text.

Leading
Sets the spacing between lines of text as a percentage of the font size. Values above 100 increases leading; 
values below 100 decreases leading.

Font Size
Sets the size of the text in points. To determine how large the text object will appear in the Universe divide the 
font size by two. This calculation will give you the approximate height in inches. For example a 72 point text 
object would be about 36 inches tall in the universe.

Word Spacing
Sets the spacing between words in points.

Scaling
Sets the percentage increase or decrease in the width of the text. Values greater than 100 increase the width; 
values less than 100 decrease the width.

Letter Spacing
Sets the spacing between letters in points.



Toolbars dialog box
Use to hide or show the various toolbars available in CorelDREAM. Select the toolbars you want to hide leaving 
those you want to show checked.
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Creating Objects: Overview
The first step toward creating a 3D illustration is to build and assemble the objects that make up your scene. 
Some basic objects (sphere, cone, cube) have been included in CorelDREAM 3D. You can also create your own 
objects using the Free From Modeler. Use the Text tools to create text objects.
To create an object, you'll need to draw cross section shapes and extrusion paths on the appropriate planes in 
the Modeling window. Each plane in the modeling window is a separate 2D drawing environment with a grid. At 
any given time you'll work on a single plane. The currently selected plane is called the drawing plane.
All 2D shapes and curves you draw in CorelDREAM are Bezier Curves
CorelDREAM's drawing tools are similar to those found in traditional Bezier-based 2D drawing applications. The 
drawing tools enable you to create curves and shapes, and to edit and modify those shapes point-by-point.
CorelDREAM allows you to import shapes from many popular 2D graphics programs.
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To set up the drawing plane grid
1. On the View menu, click Grid.
2. Choose the settings you want.
3. Click OK.



To create a new object
1. Click the tool in the toolbox corresponding to the type of object you want to create.
2. In the Perspective window, drag to create a bounding box approximately the size that you want the object to 

be or click to create an object of default size.
The object is placed in your scene. In the case of a Free Form object, CorelDREAM opens it in a Modeling 
window. In the case of a Text object, CorelDREAM opens it in the 3D Text editor.



To create an object using the Modeling Wizard
1. Click the  tool.
2. Follow the Wizard's instructions, simply double-clicking on your choices.



To draw a new path
1. Click the  tool then click in the Perspective window.
2. Click the  tool.

3. Click anywhere on the drawing plane to start the new path with a corner point. Click and drag to start with 
a curve point.
4. Click or click and drag to add each subsequent point. As you add each point, the segment of the path 
connecting the previous point to the new point will be drawn.
5. Click on a path's opposite endpoint to close the path.

Tip
Hold down the SHIFT key to constrain the position of a new point in relation to the previous point. The angle 
between the two points will be constrained to increments of 45 degrees.



To view points on a path
Click the path with the 

 tool.
Hold down the SHIFT key and click on additional paths to view the points on multiple paths.
Hold down the SHIFT key and click on a path whose points are visible to make them invisible.
Click in an empty area of the drawing plane to make all points invisible.



To select points on a path
Click on a point with the 

 tool to select it.
Hold down the SHIFT key and click on additional points to increase your selection.
Hold down the ALT key and click on a path to select all of the points on the path.



 To deselect points on a path
Click on the point with the 

 tool.
Hold down the SHIFT key and click other selected points to deselect them.
Click in an empty area of the drawing plane to deselect all points.



To move points on a path
Drag the points with the 

 tool.
Tip
Hold down the SHIFT key while you drag to constrain the movement of the points in relation to their previous 
positions. Their movement will be restricted to angles of 45 degree increments.



To modify the shape of a curve path
1. Select a point on the path with the  tool.
2. Drag the handles to adjust the curve at the selected point.

As you drag, the curve will be redrawn. By default, parallel handles move in pairs; when you move a handle, 
the opposite handle will move to remain parallel to the one you're moving.
Hold down the SHIFT key while you drag to constrain the angle of a handle's motion to 45 degree increments.
Hold down the ALT key while you drag to break apart a pair of parallel handles. You can then move each 
handle independently.



To convert a corner point to a curve point (and vice versa)

1. Click the  tool.
2. Do any of the following:

Drag on a corner point with no handles to make a curve point.
As you drag, a pair of handles will extend from the point.

Click and drag on one of a corner point's free handles to make a curve point.
When you click on the free handle, it will be re-joined with its opposite handle. As you drag, the handles will 
move together, remaining parallel.

Click on a curve point to make a corner point with no handles.
The point's handles will retract.

Click and drag on one of a curve point's handles to make a corner point.
When you click on the handle, it will be freed from its opposite handle. As you drag, it will move 
independently.



To add points to a path

1. Hold the mouse button down on the {2dsmooth.bmp} tool and click .
2. Click anywhere on an existing path to add a new point.

CorelDREAM determines whether to add a corner point or a curve point, depending on the shape of the path.
Tip
When you add a point to the sweep path, you can simultaneously add a cross section at that point; simply hold 
down the ALT key as you click to add the new point.



To add points to the end of an open path
1. Click the  tool.
2. Click on either endpoint of the path.
3. Click or click and drag to add the next point.
4. Continue adding points to complete the path.



To delete points and segments on a path
1. Hold the mouse button down on the  tool and click 

.
2. Click on a point to delete it.

If you delete a point on the sweep path, any cross section associated with that point will be deleted as well.
3. Click on a path segment to delete it.
Note
Deleting path segments applies to cross section shapes only; you cannot delete a segment from the sweep path 
or the scaling envelope.



To draw an ellipse
1. Click the  tool.
2. Drag or click in the Perspective window.

3. Hold the mouse button down on the  tool and click 

.
4. Drag to draw an ellipse.

Hold the SHIFT key down while dragging to create a circle.
Notes

The Ellipse tool and the other 2D Primitive tools work only on a cross section plane.
After creating a shape with one of the 2D Primitive tools, you won't immediately be able to edit its points; 

you'll need to ungroup it first.

{button ,AL(`ungrouping shapes;;;;;',0,"Defaultoverview",)} Related Topics



To draw a rectangle
1. Click the  tool.
2. Drag or click in the Perspective window.
3. Select the  tool.

4. Drag from one corner of the rectangle to the opposite corner.
Hold the SHIFT key down while dragging to create a square.

Notes
The Rectangle tool and the other 2D Primitive tools work only on a cross section plane.
After creating a shape with one of the 2D Primitive tools, you won't immediately be able to edit its points; 

you'll need to ungroup it first.

{button ,AL(`ungrouping shapes;;;;;',0,"Defaultoverview",)} Related Topics



To draw a rounded rectangle
1. Click the  tool.
2. Drag or click in the Perspective window.
3. Hold the mouse button down on the  tool and click 

.
4. Drag from one corner of the rectangle to the opposite corner.

Hold the SHIFT key down while dragging to create a square with rounded corners.
5. When you release the mouse button, a dialog box will open that lets you set the radius of curvature on the 

corners.
Notes

The Rounded Rectangle tool and the other 2D Primitive tools work only on a cross section plane.
After creating a shape with one of the 2D Primitive tools, you won't immediately be able to edit its points; 

you'll need to ungroup it first.

{button ,AL(`ungrouping shapes;;;;;',0,"Defaultoverview",)} Related Topics



To draw a polygon
1. Click the  tool.
2. Drag or click in the Perspective window.
3. Hold the mouse button down on the  tool and click 

.
4. Drag to draw a polygon. 

Hold the SHIFT key down while dragging to keep all angles equal.
When you release the mouse button, CorelDREAM opens a dialog box that lets you set the number of sides for 
the polygon.

Notes
The Rectangle tool and the other 2D Primitive tools work only on a cross section plane.
After creating a shape with one of the 2D Primitive tools, you won't immediately be able to edit its points; 

you'll need to ungroup it first.

{button ,AL(`ungrouping shapes;;;;;',0,"Defaultoverview",)} Related Topics



To create a 3D text object
1. Click the  tool then click in the Perspective window.
2. Use the controls in the top left portion of the dialog box to set front and back bevels for the text, if you like.
3. Enable the check box for the Front and/or Back face.
4. Select the bevel type you want.
5. Enter values in the Height and Depth fields to specify the slope or contour.
6. Set the extrusion depth in the top right portion of the dialog box.
7. Set the font and its characteristics. These settings determine how text you type will be created.
8. In the field at the bottom of the dialog box, type the text you want.
9. When you have finished creating or editing the Text object, click the Done button or press Enter.
Note
You can determine how large a text object will appear in the Universe by dividing its font size by three. This 
calculation will give you the approximate height in inches. For example a 24 point text object will be about 36 
inches tall in the Universe.



To create text that you can modify in the Modeling window
1. Click the  tool then click in the Perspective window.
2. Click the  tool.

3. Click in the Modeling box.
4. Select the font, size, alignment and spacing you want.
5. In the field at the bottom of the dialog box, type the text you want.
6. Click OK.

Note
You can determine how large a text object will appear in the Universe by dividing its font size by three. This 
calculation will give you the approximate height in inches. For example a 72 point text object will be about 24 
inches tall in the Universe.



 To edit text created in the Modeling window
1. Select the  tool and double-click the text to open the Modeling window.
2. Select the  tool.

3. Move the drawing plane to the cross section containing the text you want to edit.
4. Double-click the text.
5. Make any changes you want in the Text dialog box and click OK.
6. If the text is extruded across multiple cross sections, move to the next cross section and repeat step 4 and 
5.
7. Repeat step 6 until the changes have been applied to all the cross sections.

{button ,AL(`edit 2D text;move drawing plane;;;;',0,"Defaultoverview",)} Related Topics



To edit the letter shapes of text created in the Modeling window
1. Double-click the text to open the Modeling window.
2. On the Arrange menu, click Convert Text to Curves.

Each letter in the text string is now a separate object.
3. Using the  tool, select the letter you want to shape.

4. On the Arrange menu, click Break Apart.
5. Use the  and 
 tools to modify the shape of the paths that make up the letter.

{button ,AL(`shape path;;;;;',0,"Defaultoverview",)} Related Topics



To import 3D objects
1. On the File menu, click Import.
2. From the List of Files Type box, select the file format of the objects you want to import.
3. Locate the file containing the objects you want to import.
4. Click OK.
5. If you are importing a DXF file, a dialog box appears so that you can specify how you want CorelDREAM to 

interpret the file.
Note
Occasionally when importing a DXF file you will see many objects in CorelDREAM. If that happens, go back to the
original program and select the appropriate options to save the data as 3DFace entities.



To import 2D shapes into a cross section
1. Activate the cross section on which you want to import the shape.
2. On the File menu, click Import.
3. From the List of Files Type box, select the file format you want to import.
4. Locate and select the file containing the shapes you want to import.
5. Click OK.

{button ,AL(`move drawing plane;cross sections;importing;;;',0,"Defaultoverview",)} Related Topics



To import a 2D shape for use as a Sweep Path
1. Set the active plane to sweep path.
2. On the File menu, click Import.
3. From the List Files of Type box, select the file format you want to import.
4. Locate and select the file containing the shape you want to import.
5. Click OK.
Note:
If there is more than one shape in the file, only the first one will be imported.

{button ,AL(`;sweep path;importing;;;',0,"Defaultoverview",)} Related Topics



To import a 2D shape for use as a Scaling Envelope
1. Set the active plane to sweep path.
2. On the Geometry menu, select Geometry and choose Symmetrical, Symmetrical in Plane, or Free.
3. On the File menu, click Import.
4. From the List of Files Type box, select the file format you want to import.
5. Locate and select the file containing the shape.
6. Click OK.
Note:
If there is more than one shape in the file, only the first one will be imported.

{button ,AL(`scaling envelope;importing;;;',0,"Defaultoverview",)} Related Topics



2D Information CorelDREAM imports
When you import a file, CorelDREAM reads most of the information contained in the file. However, some 
advanced features of 2D drawing programs are not supported by CorelDREAM and are therefore ignored when 
the file is imported. Any information that cannot be used is displayed in the Import Report dialog box.
CorelDREAM reads the following information from all types of imported files:
Basic Drawing Elements
CorelDREAM recognizes all of the basic elements contained in a 2D illustration file, including open and closed 
paths, lines, and geometric primitives such as ovals and rectangles. Groups of elements are also supported.
Text Elements
Text elements from imported files do not remain editable as text in CorelDREAM.
Stroke and Fill Attributes
CorelDREAM keeps the line weight and color information from 2D strokes, and the color information from 2D fills.



No related topics were found.



No procedure topics were found.



Setting Lights and Cameras: Overview
Much like in the real world, the appearance of objects in the CorelDREAM universe is determined greatly by the 
light in which they are viewed. By default, your 3D scene will contain two kinds of light sources: ambient and 
directional light.
Lighting effects are not shown in the regular Preview display mode. When you create a ray-traced rendering of 
your scene, it will show color, shading, and all of the complex lighting effects, including reflection, shadows, 
transparency, and refraction. Before starting the rendering process, you can see accurate light source effects 
while working in your scene by using the Render Preview tool to render a marqueed area of your scene.
Cameras provide viewpoints for the Perspective window and for renderings. You can position several cameras in 
your scene and switch among them to get various perspectives. You can even create a second Perspective 
window to view your scene from two angles at once. When you're ready to render, choose a camera as the 
viewpoint. The camera position and settings combine with the rendering format to determine the scale and 
framing of the scene.



About Gels
A gel is an image placed in front of a light that acts as a mask or transparency. You can use a gel to project 
complex patterns and images on your scene.
Some basic gel effects are included in the software. These are called procedural gels because they are calculated
by mathematical procedures. You may also load an image to use as a gel.
If the gel is a 1-bit image, it becomes a mask. White regions of the mask transmit the light and black regions 
block it. Bitmap gels can create intricate effects, such as the shadow of a chain-link fence, or the dappled shade 
under a tree. 
Grayscale or color images create transparencies when used as a gel. Their image is projected into your scene, 
just as a slide projector sends an image across the room. With a color image, you can achieve magical effects, 
like sunlight filtering through a stained glass window. An 8-bit gel will probably provide all the color you need.



To create a new camera
1. Click the  button in the toolbox.
2. Click at the location in the Perspective window where you want to position the camera.
3. Use the Scene, Camera Settings command to set the camera type, position and other parameters.
Tip
To create a camera with the same settings as an existing camera, first select the camera, then click Duplicate on
the Edit menu.

{button ,AL(`background;move camera;',0,"Defaultoverview",)} Related Topics



To change a camera's lens
1. Double-click on the camera you wish to adjust in the Hierarchy window.
2. Select the camera type you want: Conical, or Perspective, or Isometric.

The Perspective camera has four settings: Normal, Wide Angle, Zoom, and Telephoto. If you select Zoom, drag 
the slider to set a focal length.



To move the current camera to a preset position
1. On the Scene menu, click Camera Settings.
2. Choose the preset position you want.

The default presets are at the top of the menu. The presets you've saved are at the bottom of the menu. When
the camera position and orientation is not at one of the presets, the Position pop-up will display “Custom.”

Note
When you jump into the Modeling window using any of the default preset positions, the camera goes with you
i.e., it will establish the preset position and orientation relative to the local universe you've jumped into. A 
custom position, on the other hand, is kept as is when you jump in. This could result in an empty window when 
you jump into a group. Choose a default preset or select an object and click Point At on the Arrange menu to see 
the contents of the group.



To point a camera or light at an object
1. Select the camera or light and the object you want to point at. You'll probably find it easiest to select it in the 

Hierarchy window.
You can select multiple cameras and lights, but only one object. If you don't select a camera or light, 
CorelDREAM will point the current camera.

2. On the Arrange menu, click Point At.
The light or camera will point at the hot point of the selected object.

Tip
To direct a camera to a particular area in your scene, you can create a temporary object, point at it, and then 
delete the object.



To navigate the current camera
1. On the Scene menu, click Camera Settings.
2. Click the arrow buttons in the Rotate and Translate panels to change the orientation and position of the 

camera.
The tracking directions are in relation to the camera's current attitude not on the axes of the Global Universe 
or working box.

Tip
To change the distance or degree each click moves the camera, click the Increment button at the upper right 
corner of the Camera Settings window. Then, enter the values you want for Rotation (Rotate and Pan tools) and 
Translation (tracking tools).



To save a camera position as a preset
1. On the Scene menu, click Camera Settings.
2. From the Position list box, select Save Position.
3. Enter a name for this camera position and click OK.
Note
This saves the position and orientation, not the lens setting. The view from this position will depend on the lens 
setting of the camera that is sent here.



To remove a camera position preset
1. On the Scene menu, click Camera Settings.
2. From the Position list box, select Delete Position.
3. Select the position you wish to remove.



To switch the view between cameras
1. From the Scene menu, click Camera Settings.
2. From the Name box, click the camera you want to switch to.
Tips

If you want to look at your scene from this viewpoint as well as the original one, choose New Perspective.
You can also look at your scene through the viewpoint of a light to check where the light is cast. To do so, 

click Camera Settings on the Scene menu and click the light in the Position list.



To create a new light source
1. Click the  button in the toolbox.
2. Click at the location in the Perspective window where you want to position the light.
3. Click Light Settings on the Scene menu and set the light parameters you want for the new camera.
4. Click OK.
Tip
To create a light with the same settings as an existing light, first select the existing light, then, on the Edit menu, 
click Copy then Paste or click Duplicate.



To set ambient light
1. On the Scene menu, click Ambient Light.
2. Set the color for the ambient light.

You can select colors using either RGB or CMYK color models. Or, double-click the color swatch to choose your 
color using the Apple color picker.

3. Drag the slider to set the brightness.
As you increase the brightness of ambient light, the intensity of shadows and other effects generated by your 
other lights decreases.

4. Click OK.
Note
The effect of Ambient Light can be noticed only on physical objects. To see the effect of Ambient Light on the 
background of your rendered image, you must create a backdrop object.

{button ,AL(`background;;',0,"Defaultoverview",)} Related Topics



To set a light's parameters
1. Double-click on the light's icon in the Hierarchy window.

If it's a bulb light or a spot light, you may double-click on it in the Perspective window. Distant lights, however, 
are outside of the universe and do not have projections.

2. Select the type of light you want.
3. Specify the lighting characteristics (color, brightness, shadows etc.) you want.
4. Choose OK.



To set the direction of a distant light source
1. Double-click on the light's icon in the Hierarchy window.
2. Drag the highlight on the surface of the sphere to position the light source.
3. To shine the light from behind, click the Back button.
4. Choose OK.



To point a spot light at an object
1. Using the {arrow.bmp} tool, select the light and the object you want to point it at.

You can select multiple lights, but only one object.
2. On the Arrange menu, click Point At.

The light will point at the hot point of the selected object.
Tip
You can move spot lights anywhere in the 3D workspace and change their direction using the  and 

 tools or the Edit, Object Properties command.

{button ,AL(`moving;positioning;orienting;;',0,"Defaultoverview",)} Related Topics



To use a gel
1. Double-click the light in either the Perspective or Hierarchy window.
2. Set the light type.

Gels are generally used on distant or spot lights. Your choice will depend on the effect you want.
3. Select one of the built-in procedural gels, or Image if you want to use your own.

If you select Bitmap Gel, choose the image file to use. Hold down the disk icon and select Open or Import to 
select the desired file.

4. Set the other light options.
5. Position and aim the light.
Note
To see the effect of your gel, you must put the Perspective window in Better Preview display mode. You might 
also generate a preview rendering.



Modeling Objects: Overview
Use CorelDREAM 3D's Free Form modeler whenever you want to create a custom object. The Free Form modeler 
is based on a simple concept called extrusion. You create an object by drawing a 2D shape, then drawing a 
sweep path perpendicular to the shape. CorelDREAM sweeps the shape along the path to form a 3D object.
The 2D shape is usually referred to as the cross-section. The sweep path is sometimes referred to as the 
extrusion path.
CorelDREAM also provides a picture-based assistant called the Modeling Wizard

that guides you through the basic steps of creating a 3D object.

{button ,AL(`modeling_window;cross sections;sweep path;lathing;;',0,"Defaultoverview",)} Related 
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About the Free Form Modeler
Whenever you create or edit a Free Form object, you'll work in the Free Form Modeling window. The window 
opens automatically when you add a new Free Form object, temporarily replacing your scene's Perspective 
window. New menus appear, and modeling tools and a close-up view of the object replace the view of the scene. 
The Hierarchy window reflects this change, showing only the icon for the object you are working on.
The Modeling Box is the primary feature of the Modeling Window. On the planes of the Modeling box, you'll draw 
and edit the various elements which the Free Form modeler uses to build a 3D object: cross section shapes, the 
sweep path, and the scaling envelope.
Within the Modeling Box, you'll work on a single plane at a time. At any given time, the plane you're working on 
is the current drawing plane. When you want to edit a particular element, you simply designate the plane 
containing that element to be the drawing plane. The drawing plane is shown in color, while the other, inactive 
planes are dimmed.

{button ,AL(`perspective_window;;;;;',0,"Defaultoverview",)} Related Topics



To use the Modeling Wizard
1. Click the  button on the toolbar.
2. Follow the Wizard's instructions, simply double-clicking on your choices.



To display Free form objects in the Modeling window for editing
Double-click the object in the Perspective or Hierarchy window, or select the object and    click Object, Edit 

or Edit in New Window on the Edit menu.
To exit the Modeling window, click the Done button at the bottom of the window. Or, click Object, Close and 
Return on the Edit menu.



To return to the Perspective view from the Modeling window
Do any of the following:

Click the Done button at the bottom of the window.
On the Edit menu, click Object, Close and Return.
Double-click the object's icon in the Hierarchy window.
Hold the mouse button down on the object's icon in the Hierarchy window and use the pop-up menu to 

select a higher level in the hierarchy.



To look at an object from a different view
Do either of the following:

Select the  tool and drag the object.
On the View menu, select Type and choose the perspective you want: Reference, Drawing Plane, Top, 

Bottom, Left, Right, Front, or Back.
Note
An object's orientation in the Modeling window has no connection to its orientation in the scene. You may rotate 
the object without worrying about its orientation in the scene.



To show or hide modeling box planes
Click the planes on the 

 button in the toolbar.
The Plane Display button has four active areas: the three planes and the object preview. Simply click on the 
plane you wish to hide or show.



To set the size of the modeling box and object size
1. On the View menu, click Modeling Box Size.
2. Enter a dimension and select the units you want.

If you want to resize the modeling box without resizing the object, disable the Scale object with Modeling Box 
check box.



To set the surface fidelity (resolution) for objects
1. If the object isn’t already in the Modeling window, double-click it to open the Modeling window.
2. On the Geometry menu, click Surface Fidelity.
3. Drag the slider to increase or decrease the object's surface fidelity.
The surface fidelity value is resolution-independent. That is, if a particular value yields good results for a given 
object in a given scene at low resolution, it should yield good results at higher resolutions as well.
Note
If none of the objects in your scene render as smoothly as you'd like, you can increase the rendering Silhouette 
Quality using the Scene, Render Setup, Final command instead.



To reposition shapes in the Free Form modeler by dragging
Drag the shape with 

. Hold down the SHIFT key to keep the shape the same distance from the side or bottom plane.



To reposition shapes in the Free Form modeler numerically
1. Select the shape you want to reposition.
2. On the Edit menu, click Object Properties.
3. Enter new values in the Top and Left boxes.
4. Click Apply.



To resize shapes in the Free Form modeler by dragging
Using the 

 tool, drag a corner of the shape’s bounding box. Hold down the SHIFT key to maintain proportions.



To resize shapes in the Free Form modeler numerically
1. Select the shape you want to resize.
2. On the Geometry menu, click Scale.
3. Enter percentages for resizing.
4. Click OK.



To set specific dimensions for a shape in the Free Form modeler
1. Select the shape you want set dimensions for.
2. On the Edit menu, click Object Properties.
3. Type measurements in the Width and Height boxes.
4. Click Apply



To rotate a shape in the Free Form modeler by dragging
1. Select the  tool.
2. Click on the shape to select it.
3. Drag it in a circular path.

A shape always rotates around its center. You can accomplish an eccentric rotation in two steps: rotate the 
shape normally, then change its position on the plane.



To rotate a shape in the Free Form modeler numerically
1. Select the shape with the .
2. On the Geometry menu, click Rotate.
3. Select the rotation center; the shape's center, or the drawing plane's center.
4. Enter a value for degree of rotation.
5. Select clockwise (CW) or counter-clockwise (CCW).
6. Click OK.



To twist an extrusion
1. Double-click the free form object to open it in the Modeling Window.
2. Using the  tool select a cross section shape.

3. Hold down the ALT key while rotating the cross section shape with the  tool.
Tip
For precise twisting, click Geometry, Rotate and enable the Twist check box. Specify an angle and click OK.
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To group and ungroup shapes in the Free Form modeler
1. Select the shape(s) you want to group or ungroup.
2. On the Arrange menu, click Group or Ungroup.

Once grouped, objects can be manipulated as a single entity.



To combine shapes in the Free Form modeler
1. Select the shapes you want to combine.
2. On the Arrange menu, click Combine.
Note
Combined shapes are allowed only on a cross section plane.



To break apart a combined shape in the Free Form modeler
1. Select the combined shape you want to break apart.
2. On the Arrange menu, click Break Apart.



About Cross Sections
A basic Free Form object, like a box, has one cross section at the start of the path. The shape on this first section 
is swept to the end of the extrusion path. To create more complex forms, you can add any number of cross 
sections along the length of the path. Since each cross section, in turn, can contain any number of shapes, you'll 
be able to model even very intricate objects.
The Free Form modeler automatically extrudes between each cross section and the next, basing the surface of 
the object on the shapes contained in the cross sections.



To model with multiple cross sections
1. Open the Modeling window.
2. Draw (or import) the first cross section shape.
3. Add as many cross sections as you need at the appropriate points along the sweep path.
4. Draw (or import) shapes onto each cross section. You can Copy and Paste to move shapes between sections.
5. If one or more of your cross sections contain multiple shapes, use Shape Numbering to control the 

correspondence between sections.
6. Modify the sweep path, if necessary.
7. Continue refining your object, changing the number of sections, shapes, or the shape correspondence.
8. Use the scaling envelope to alter the contours of the object between the cross sections (optional).
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To create a new cross section
Do one of the following:

If a vertex exists at the point on the sweep path where you want the new cross section, simply select the 
vertex and on the Cross-Section menu, click Create.
If no vertex exists at that point, select the  tool. Then hold down the SHIFT key and click on the sweep path at 
the point where you want to create the new cross section.

Tip
If you are working on one cross section, you can create a new cross section at the next vertex on the sweep path
in a single step. Simply click Create on the Cross-Section menu.
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To automatically generate intermediate cross sections
1. Activate a cross section. The new ones you generate will be added after this one.
2. On the Cross-Sections menu, click Create Multiple.
3. Specify how many cross sections you wish to create.
4. Click OK.

{button ,AL(`move drawing plane;;;;;',0,"Defaultoverview",)} Related Topics



To remove a cross section
1. Activate the cross section you want to remove, or select the corresponding point on the sweep path.
2. On the Cross-Sections menu, click Remove.
3. If you want to remove the cross section and delete its corresponding vertex from the path, use the  tool to 

delete the vertex from the path.

{button ,AL(`move drawing plane;delete points;;;;',0,"Defaultoverview",)} Related Topics



To move the drawing plane between cross sections
Do any of the following:

On the Cross-Section menu, click Next or Previous.
Press the Right Arrow key to advance to the next cross section or the Left Arrow key to go to the previous cross
section.
On the Cross-Section menu, click Go To and enter the number of the section you want.



To control shape-to-shape correspondence
1. On the Cross-Section menu, click Show Shapes Numbers.

A number appears beside each shape in the drawing plane.
A group or compound is assigned a single shape number.

2. Click on the number for the shape whose correspondence you wish to change.
3. Type in the number for the shape you want it to correspond to, then click OK.

If you enter the number of another shape in this plane, the program will swap the correspondence number 
with that shape.
If you enter a unique number, make sure that you assign the same number to the appropriate shape in the 
adjacent cross section(s).

Note
Any shape that has no correspondence (i.e., its number does not match any shape number in an adjacent 
section) is not extruded. 



About the Sweep Path
The sweep path, also known as the extrusion path, 'travels' through three-dimensional space. It is the path along
which cross section shapes are extruded. The path is defined by two, two-dimensional lines which appear on the 
bottom and side walls of the modeling box.
You can think of these path description lines as horizontal and vertical projections of the path. The path itself is 
displayed for modeling purposes only and is not a visible part of the object. It extends between the centers of 
the first and last cross section. You can draw straight, curved, or irregular sweep paths.
The Free Form modeler allows you to draw a true 3D sweep path, making it possible to model objects like the 
chair frame in the Wizard. You can even close the sweep path. CorelDREAM also provides tools for automatically 
creating complex sweep paths like the spiral.
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About the Scaling Envelope
The contours of a Free Form object are largely determined by the cross sections you place along the sweep path. 
Wherever you change the size or shape of a cross section, the object's surface changes accordingly. Sometimes, 
however, you'll want finer control than cross sections alone can provide. The scaling envelope gives you this 
control, enabling you to specify how an object's surface should curve from one cross section to the next.
By default, the scaling envelope is not used; CorelDREAM stretches the object's surface over the cross sections 
as simply as possible. When you turn the envelope on, it appears as four envelope description lines, one on 
either side of each path description line. Initially, the envelope conforms to the dimensions of the object's cross 
sections, widening and narrowing only if the cross sections vary in size.
Like the path description lines, the envelope description lines are Bezier curves. By editing these curves, you can
alter an object's contours.
Symmetrical is the default envelope constraint setting. However, you can also edit the envelope description lines
in pairs (Symmetrical in Plane), or individually (Free). This allows you to model asymmetrical objects.

{button ,AL(`scaling envelope sweep path;scaling envelope cross section;;;',0,"Defaultoverview",)} 
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How the Scaling Envelope relates to the Sweep Path
The envelope and the sweep path are closely related. In fact, each point on the scaling envelope corresponds to 
a point on the sweep path.
Moving an envelope point perpendicular to the sweep path controls the scaling of the object at that point on the 
path. When you move an envelope point parallel to the sweep path, the corresponding point on the sweep path 
moves as well; the points are 'locked' together in the direction of the sweep path.
To maintain this relationship, when you add a point to the scaling envelope, a point is also added to the sweep 
path. Likewise, when you delete a point from the envelope, the corresponding point is deleted from the sweep 
path.
The scaling envelope works best on objects which use the Translation extrusion mode. If you need to use the 
envelope on a Pipeline object, you should model the object as completely as possible using the sweep path and 
cross sections only, then adjust the scaling envelope as a final step.
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How the Scaling Envelope relates to Cross Sections
Editing the scaling envelope may also affect an object's cross section shapes. If you edit the envelope at a point 
where there is no cross section, only the surface between cross sections will be affected. However, if you edit the
envelope at a point where a cross section exists, the shapes on the cross section will be scaled accordingly. If 
you delete a point from the envelope, you will also delete any cross section located at that point.
When using the scaling envelope in conjunction with multiple-shape cross sections, note that the scaling 
reference point is the sweep path, not the center of each shape. If you want a cross section's individual shapes 
to be scaled while maintaining their distance from each other, you should resize each shape individually on the 
cross section plane, rather than use the scaling envelope.
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To show the scaling envelope
On the Geometry menu, click Extrusion Envelope and choose an envelope type: Symmetrical, Symmetrical 

in Plane, or Free.
The envelope type determines whether the four description lines are edited as a group (Symmetrical), in pairs 
(Symmetrical in Plane) or individually (Free).



To modify the scaling envelope
Use the 

 tools to edit the envelope description lines. You can add and delete vertices, as well as adjust existing vertices and
control points.

Tips
If you make changes to the scaling envelope that you don't like, click Reset Envelope on the Geometry 

menu. Choosing Extrusion Envelope, None on the Geometry menu will also undo the effects of the envelope.
By default, the scaling envelope is kept symmetrical. If you want to modify the lines of the scaling 

envelope independently, you can change their symmetry constraint. On the Geometry menu, choose Extrusion 
Envelope and select the scaling constraint you want.



About Lathing
Lathing tools are common in 3D modeling applications. Lathing allows you to create many types of symmetrical 
objects. Typically, a 2D lathe profile is rotated around a straight axis to create a 3D volume. Rotation may be 
circular or angular, around 360 degrees or less.
CorelDREAM does not have a separate lathe modeler. Instead, you'll create lathe objects in the Free Form 
modeler, just as you create other objects.
With the Free Form modeler's universal interface, you're not constrained by the limitations of a dedicated lathe 
modeler. Because your lathe object is actually a Free Form object, you can edit it in ways that traditional lathing 
tools don't allow. For example, you can create a symmetrical lathe object, then deform it using the Free Form 
modeler's other tools.
Depending on the specific object you want to create, you can choose from two different lathing methods. Most of
the time, you'll use the scaling envelope to create a lathe object. In some cases, you'll want to sweep the lathe 
profile around a circular extrusion path instead.



To create a lathe object with the scaling envelope
1. Create a new Free Form object in the Perspective window.
2. Using the  tool, hold down the SHIFT key and drag on the cross section plane to draw a circle. Use the 

 tool if you want a polygonal lathe.
Draw your circle (or polygon) at an appropriate size for the object you are creating, as the initial diameter 

of your object depends on the size of the cross section.
3. On the Geometry menu, click Extrusion Method and make sure that Translation mode is selected.
4. On the Geometry menu, click Extrusion Envelope, Symmetrical.

5. Using the  tool, click once on either sweep path plane to make it the current drawing plane, being careful not 
to select the sweep path or either of the envelope description lines.

6. (Optional) On the View menu, click Type, Drawing Plane.
7. Using the  tool, click or click and drag on the drawing plane to place the second point of the lathe profile. 
Remember, the first point of the lathe profile is determined by the size of the cross section.

8. Continue drawing the lathe profile, placing additional points with the  tool.
For the best results, be careful not to cross over the sweep path as you draw the lathe profile.
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To create a lathe object using a circular sweep path
1. Create a new Free Form object.
2. Draw your lathe profile in the cross section plane.
3. On the Geometry menu, click Extrusion Preset, Torus.
4. Specify the distance of the cross section from the torus' central axis. This value determines the radius of the 

torus.
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Post Production: Overview
Rendering produces a 2D, photorealistic, bitmap image of your scene. Anything you do with that image is 
considered post production. Post production might include compositing, filtering, cropping, and retouching the 
image in a photoretouching application or placing the image in a page layout application.
CorelDREAM is a 3D illustration tool. It does not provide comprehensive post production features. You may use an
image editing or paint application like CorelPHOTO-PAINT    or Adobe Photoshop for the best in post production 
results. In some cases, you might want to use your imaging application to adjust colors or contrast, apply an 
image filter, or paint directly onto the image.
CorelDREAM saves renderings in file formats that are compatible with virtually any pre-press or layout 
application.
CorelDREAM's post production features are available when an Image window is active either from having 
rendered a scene or from having opened an image using the File, Open command.



To identify the folder containing your plug-in modules (filters)
1. On the File menu, click Preferences.
2. From the list box at the top of the Preferences dialog box, select Imaging, Scratch Disk.
3. Click the Folder button to identify the folder containing the plug-in modules.
4. Locate the folder that contains the plug-in modules and make it the active folder.

CorelDREAM does not display any files in the active folder.
5. Click the Select Current Folder button.
6. Click OK.



To apply a filter to the image in the Image window
1. On the File menu, click Open.
2. From the List Files of Type list box, choose Image Files.
3. Type or select the name of the image file you want to use with the filter.
4. On the Scene menu, click Filter.
5. Select the Filter you want to use.
6. Click OK.



To use filters in the Shader Editor
1. On the Windows menu, click Shader Editor.
2. Select the channel containing the texture map you want to filter.

3. Click the  button.
4. Click Filter and select the filter you want to use.
5. Click OK.



To select and setup a printer
1. Click Print Setup on the File menu.
2. Select the printer you want to use from the Name box.

Only the names of installed printers appear. See your Windows documentation for information on installing 
printers.

3. Select the Paper, Orientation and other options you want.
4. Click OK.
Tip
For help on using the Print Setup dialog box, click the ? button at the top of the dialog box and then on the item 
you want help with.



To print an image from CorelDREAM
1. On the File menu, click Open.
2. From the List Files of Type list box, choose Image Files.
3. Type or select the name of the image file you want to print.
4. On the File menu, click Print.
5. Set the options you want to use to print the image.
6. Click OK.



To save an image in a different format
1. Using the File, Open command open the image you wish to save in a different format.
2. On the File menu, click Save As.
3. From the List Files of Type list box, select the file format you want.
4. Enter a file name and select the destination.
5. Click OK.



Rendering a Scene: Overview
Rendering is the process of capturing a view of your three-dimensional scene and saving it as a 2D image. You 
can think of a rendering as taking a photograph of your scene. You can take any number of renderings of your 
scene: from different angles and, perhaps, under different lighting conditions. 
The rendered image does not contain objects. It is an image, comprised entirely of colored dots called pixels. A 
rendering is distinct from the scene from which it was taken. It is a separate file, stored on disk, in a different 
format. CorelDREAM lets you save renderings in many of the popular image formats: BMP, TIFF, Adobe 
Photoshop, TGA, and PCX.
You must render the image before it can be printed or opened in a photo retouching or page layout application.
The G-Buffer is a special feature of CorelDREAM renderings. The G-Buffer allows you to include special 
information in data channels that are saved with the image. These channels can be used in a photo retouching 
application to apply more sophisticated 3D-type special effects that require such information.



About Renderers
RDI Z-Buffer
The Z-Buffer is a fairly old computer graphics technique that produces pictures of environments with hidden 
surfaces. The result is a fully shaded draft of the scene, with highlights, texture maps, and solid textures 
accurately represented. The Z-Buffer is not capable of the more complex lighting effects: shadow, transparency, 
and reflection. If you need these effects, you should choose ray tracing.
With a limited number of objects, the Z-Buffer can create a relatively high resolution rendering quickly.

RDI Ray Tracer
Ray tracing calculates the effects of hypothetical light rays that emanate from your light sources as they 
encounter the objects in your scene. Ray tracing shows most of the real world lighting effects, including 
transparency, shadow, reflection, and bump maps.
The rendering time for ray tracing depends primarily on the resolution. The rendering time also depends on the 
number of light sources and the shading characteristics of objects.
Because of these variables, CorelDREAM allows you to disable any or all of these lighting effects channels and to 
set maximums. For example, there must be a limit to the number of reflections. This ensures that two mirrors 
placed in front of each other will not reflect each other ad infinitum. (In which case, rendering would never 
finish!)



To add a background to a scene
1. On the Scene menu, click Background.
2. From the Backgrounds list box, select the background you want.

If you choose None, there will be no background in the scene. The background areas will appear white in 
the final rendered image.

If you choose Bitmap, you can choose an image file to use as a background. Click the 
 button and then click Open or Import. Select the file you want to use and click OK.

If you choose Color, you can set a solid color to use as a background.
If you choose BiGradient, you can create a gradation or blend to use as a background.

Notes
The background must be selected to see the full extent of Atmospheric effects such as fog. Other 

backgrounds may be available from a third party developers.
The background effect will only be visible in the final rendered image.



To add an atmospheric shader
1. On the Scene menu, click Atmosphere.
2. From the Atmospheres list box, select Fog.
3. Choose the Fog Color by clicking once on the color swatch, then use the color picker to choose a color.
4. Click OK.
5. Enter the Fog Starts distance.

The Fog starts distance is the distance from the rendering camera. This is where the fog effect begins.
6. Enter the Visibility distance.

The Visibility distance determines the distance past the start of the fog where the fog becomes so thick that 
visibility through it becomes 0%.

7. Click OK.
Note
The atmospheric effect will only be visible in the final rendered image.
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To calculate the distance from the camera to objects
1. Select the camera that provides the viewpoint for the scene by clicking on its icon in the Hierarchy window.
2. On the Edit menu, click Object Properties.
3. Record the x, y, z values in the Numerical dialog box which describe the position of the selected camera.
4. Select the object for which you want to determine the camera distance.
5. On the Edit menu, click Object Properties.
6. Record the x, y, z values in the Numerical dialog box which describe the position of the selected object.
7. Subtract the object x, y and z values from the corresponding camera values.
8. Square each value.
9. Add those three numbers together then calculate the square root of the sum.

The resulting number is the distance between the camera and the selected object.
Notes

The x,y,z position information displayed by the numerical box gives the position for the center of the 
object. You may need to account for the object size when determining where the atmospheric effect will begin or 
where visibility ends.

To see atmospheric effects in background areas, you must set background to something other than none.



To set the image size, resolution and format
1. On the Scene menu, click Render Setup, Final.
2. Click the radio button for the resolution you want: High, Medium, or Other.
3. If you select Other, in the Width and Height fields, enter the dimensions you want for the picture. Set the size 

according to your final output.
4. In the Resolution field, enter the resolution (dots per inch) of the expected output device.
5. Click the File Format radio button.
6. From the Save Format list box, select the file format for your rendered image.
7. Click the Options button and select additional options you want to use to render the image.

The availability of Options button depends on the file format selected.
Tip
Previews are typically between 300 x 200 and 640 x 480 pixels. This resolution should give you enough detail to 
see the overall shading and construction of the scene without taking too long to render.



To limit rendering time
1. On the Scene menu, click Render Setup, Final.
2. Select the Size, File Format and Options you want.
3. Click the Estimate button to see how long the rendering will take.
4. Type into the Time field how long you want CorelDREAM to work on the rendering.

CorelDREAM will automatically determine the optimum resolution to finish the job in the time you have 
allotted, plus or minus a few minutes.



To display the production frame
With the Perspective window active, click Production Frame on the View menu.

If the frame does not describe the portion of the scene you want rendered, you must adjust the camera. The 
most convenient way to do this is with the Camera Settings command on the Scene menu.
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To select the renderer
1. On the Scene menu, click Render Setup, Final.
2. Click the Options radio button.
3. From the Renderers list box, choose the renderer you want to use.
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To select the camera from which to render the scene
1. On the Scene menu, click Render Setup, Final or Preview.
2. Click the Options radio button at the top right of the dialog box.
3. Use the Rendering camera pop-up menu to select the camera you want.



To start rendering
On the Scene menu, click Render, Preview or Final.

The image will gradually appear in an Image window as rendering progresses. If you want to keep the 
rendering once it is complete, save the file using the Save command on the File menu.

Note
Ray tracing is computationally intensive, and jobs may take several hours to complete, depending on the 
production format and other settings. Rendering can run in the background. You can go on working with 
CorelDREAM and even launch other applications: if memory permits. 
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About the Image Window
The image window allows you to view a bitmapped image rendered in CorelDREAM or created in another 
application.
The zoom ratio (scaling) appears in the top left. The ratio is screen pixels to image pixels. When the ratio is 1:1, 
one screen dot represents one image pixel. When the ratio is 1:2, one screen dot represents two image pixels. 
The ratio will change as you zoom in or out with the magnifying glass tool.
The image resolution, color depth, and size of the image (in K, for kilobytes, or MB, for Megabytes) appear at the 
top right.
Use the  tool to move an image within the Image Window. Use the 

 tool to zoom in. To zoom out, hold down the ALT key and use the 

 tool.



To render several scenes in a row
1. On the Scene menu, click Render Queue.
2. Click Add.
3. Select the files to include then click Add.
4. If you want to remove a file from the queue, select it and press the Delete key.
5. If you want to change the settings for a file, select the file or set of files you wish to change.
6. Click the Settings button.
7. Adjust the image size, file format, and set the options you want.
8. Click Done.
9. To start batch processing click Launch.

Renderings generated from the Render Queue are automatically saved to disk. You can open these files to 
view them using the File, Open command.



To render a scene more than once from different cameras
1. On the Scene menu, click Render Setup, Final.
2. Choose the rendering camera.
3. On the File menu, click Save As and save the file with a different name than the original. This creates a copy of

the scene with the new name.
4. Repeat steps 1-3 until all cameras or positions have been selected.
5. In the Render Queue, add the scenes created in steps 1-3.
6. When all the scenes are added click Done or press the Enter key.
7. To start batch processing, click Launch.



To view a rendered image in CorelDREAM
1. On the File menu, click Open.
2. From the List Files of Type list box, select Image Files.
3. Select the file containing the rendered image.
4. Click OK.

The image opens in the Image Window.
Note
You can also use the Open command to view images created in other programs.



To save a rendered image
1. On the File menu, click Save.
2. If you want to save the file in a different file format from the one specified when the image was rendered, 

select it from    the List Files of Type list box.
3. Type a name for the file and select a destination for it.
4. Click OK.
Notes

Renderings generated from the Render Queue are automatically saved to disk. You can open these files to 
view them by simply double-clicking on the file icon.

Images produced by CorelDREAM are rendered and stored on disk in 24-bit format.



Set up
Q. The Corel Setup program does not install CorelDREAM 3D on my machine. What can I do?
A. To install the complete CorelDREAM 3D including the tutorial files you will need to have 10 MB of free space 

available on your hard drive. If you have enough hard drive space and are still having problems, try 
rebooting the computer with    the following turned off:
Any virus protection software.
Any TSR (Terminate and Stay Resident) application not required to run Windows.
Note: See TSR section for instructions on how to turn off TSR's.
Then reinstall CorelDREAM 3D. If installation is still unsuccessful, contact Corel Technical Support.



Memory
Q. Is there a limit to the size of image that CorelDREAM 3D can produce?
A. If there is enough RAM or scratch disk space available to open the file, CorelDREAM 3D renders images of 

up to 16,000 X 16,000 pixels.
Q. How do I select the scratch drive for CorelDREAM 3D?
A. On the File menu, click Preferences and you will see the option for selecting the scratch drive.
Q. How can I increase the memory available to CorelDREAM 3D?
A. To change the total amount of memory available to CorelDREAM 3D:

Quit CorelDREAM 3D if it is already running.
Close down any running applications that you really don't need. 
Release System Resources. To display the percentage of system resources available click Start then choose 
Settings, Control Panel. In the Control Panel window, double-click System and click the Performance tab. If 
the percentage of free system resources is less than 20, problems may occur.
To increase Free system resources:
Close all open windows on the desktop.
Close all unnecessary application windows.
Ensure you are using the most current version of Windows.
If you are using DOS 5, upgrade to the most current version of DOS.
Consider purchasing more memory.

Q. If I upgrade my computer by adding more memory will CorelDREAM render faster?
A. Adding more memory might allow the computer to render some images without using the scratch disk so 

you may see a significant improvement in the speed, especially if your image includes texture maps. It's 
not really working faster, it just doesn't have to go to the disk as often.

Q. I don't have a lot of memory. Can I use virtual memory?
A. CorelDREAM 3D uses scratch disk space when there is not enough RAM available to load and render a 

scene. We recommend that virtual memory be on when using CorelDREAM 3D. (It's on by default.)



TSR Programs
Q. What is a TSR (Terminate and Stay Resident) application?
A. A TSR or memory resident program is a program that stays in memory once it is loaded and works in the 

background. The program normally responds only to a specific command or event (such as the deletion of a
file or a specific key stroke combination). 

Q. Can TSR's cause conflicts and how can I resolve them?
A. A TSR conflict occurs when a specific TSR conflicts with another TSR, an application, or a function within an 

application. You can resolve a possible TSR conflict by:
Restarting the computer with only those TSR's required to run Windows on.
Retry the operation. If the conflict does not recur, the problem is probably caused by a TSR conflict.
Note:    If restarting with TSRs off resolves the problem, a TSR conflict is probably the cause. Try to identify 
the specific TSR or combination of TSRs that cause the problem. Once identified, verify with the 
manufacturer that the version is up-to-date. Then contact Corel Technical Support for additional 
instructions.



Modeling
Q. Can I extrude line art I created in CorelDRAW or Adobe Illustrator?
A. Yes, you can import CorelDRAW, Adobe Illustrator and many other line art formats into cross sections.
Q. After I use the Rectangle tool to draw a square (by holding down the Shift key to constrain it.) I

want to edit the shape. How do I convert this shape to a Bezier shape?
A. To convert your square to Bezier curves so you can edit the shape, click Ungroup on the Geometry menu.
Q. How do I create an object with holes in it?
A. Create the object and the hole(s) on a cross section. With the object and the hole(s) selected hold down the

SHIFT key and select the hole(s). On the Geometry menu, click Combine.
Q. The object I made using the Modeling Wizard is not exactly what I want. How do I edit it? Can I 

use the Modeling Wizard to modify an object made in the modeler?
A. The Modeling Wizard is only for creating objects. Double click on the object in the Perspective window to 

launch the Modeler. Edit the object then exit the Modeler by clicking the Done button. But remember, any 
Wizard object can be recreated with eight mouse clicks or fewer, so it's not too inconvenient to start over 
again.

Q. How can I rotate the plane of the cross section like the Modeling Wizard does when it makes 
the banana?

A. No magic here. Simply choose Pipeline instead of Translation as the Extrusion Method on the Geometry 
menu. With Translation (the default) the cross section remains parallel to the drawing plane. With Pipeline, 
the cross section remains perpendicular to the sweep path, so the plane of the cross section rotates as the 
sweep path curves.

Q. When I imported my 3D DXF file, all I got was an empty bounding box or so many objects I 
could not make any sense out of it. How can I fix this problem?

A. CorelDREAM 3D imports files based on the DXF standard created by AutoDesk, the manufacturer of 
AutoCAD. Before you export from your DXF application, ensure that objects are saved as 3D faces. Then 
your file should import correctly in CorelDREAM 3D 

Q. My imported DXF file produces an object that is just an extruded outline, like a paper thin wall 
with no endcaps. What's wrong?

A. CorelDREAM is looking for a DXF face or mesh. It can not deal with points or lines. A line drawn with a line 
tool will not create the right kind of information for a 3D face. A line drawn with the Polyline tool will create 
a mesh so CorelDREAM will be able to use it to extrude a line.



Shading
Q. At what resolution should I save my bitmap image in order to use it as a texture map in 

CorelDREAM 3D?
A. You will get the best results if the original image is saved at the size and resolution required for the final 

output. So if your final image will be rendered at 300 dpi and the texture map will be about one inch square
in the final image (300 X 300 pixels), you will want your original to have a size of 300 X 300 pixels (one inch
square at 300 dpi). The closer you are to a one-to-one ratio between the original artwork and the final 
output, the better your texture map will look. Making the texture map larger (or higher resolution) will 
increase the rendering time but will not increase the quality of the final image!

Q. Does CorelDREAM 3D support PANTONE colors?
A. CorelDREAM 3D supports the RGB color model. PANTONE colors are not supported directly, but you can use 

the CMYK equivalent to select your original color. Remember that colors are manipulated in order to create 
a 3D image. If you start with a specified color, you don't necessarily end up with it after you have added 
lights, reflection, and transparency, and allowed for the shading that indicates the curvature of your 
objects. The final artwork rendered from CorelDREAM will always be in the RGB mode. Of course, you can 
do post production work in an image manipulation program, such as Corel PHOTO-PAINT, to specify 
PANTONE colors.

Q. What is the priority order for solid textures on objects? Say I have a transparent object with a 
bank of wood texture and part of the wood has a gold band “inlaid” in it. What will I see? How 
can I control the priority order?

A. On the View menu, click Object Shading Properties to change the order of paint layers. Use the Send to 
Front and Send to Back commands to prioritize the paint layers.

Q. If I change the shape of my paint region will the texture map tile or stretch?
A. It will stretch. Remember that you can use the Object Shading Properties command on the Edit menu to 

change the size of your paint region. Set the size to a size that is proportionate to your artwork to avoid 
distortion.

Q. If I have a long thin object how can I get my texture to tile correctly?
A. In the Shader Editor (Windows menu) you can set the number of tiles you want in the vertical and 

horizontal planes to get the effect you are looking for.
Q. How can I make the bumps show up better? I want them to appear higher or I want the indents 

to appear deeper?
A. Experiment with your lighting. Try not to have any light aimed directly at the bump or it will wash out. 

Indirect lighting will show the bump map shadows.
Q. I want to use some filters on my object but I can not access them. Why?
A. You need to tell CorelDREAM where to find the filters by using the Preferences command (File menu) to 

identify the directory containing the plug-in filters. Remember that filters can only be applied to a rendered 
image. Filtering is a post-production process.



Arranging
Q. When I drag a new object into the Perspective window, sometimes I can not find its projections.

I have the feeling that the object is not where I think it is.
A. It does make a difference where you drop your object. Experiment with it. Generally you should aim for the 

center of the Universe. However, should you really have a problem, you can always send your object to the 
center yourself. First, select the object in the Hierarchy window. Then open the Numerical dialog box 
clicking Edit, Object Properties. Set the x, y and z coordinates to 0, 0, and 0 and click apply.

Q. Even using various views I have a hard time lining things up precisely.
A. Use Edit, Object Properties and the Arrange, Align Objects commands to place objects precisely. You may 

also want to adjust the hot point on specific objects in order to get the exact placement you need.
Q. I've tried using Object Properties and Align Objects commands to place my objects exactly 

where I want them, but they don't seem to align as I would expect. They don't seem to rotate 
correctly either.

A. Make sure the Hot Points are set correctly. To return the hot point to the default setting, select the hot point 
and click the Send to Center button in the Numerical window.

Q. I understand how to point a light or camera at an object but what if I want the light to point at 
a spot where there is no object? It seems I should be able to do that.

A. Create a dummy object and place it at the spot where you want the light (or camera) to point. Remember 
that it points at the Hot Spot. After using the Point At command (Arrange menu), select your dummy object 
and delete it. The Point At command does not link the camera or light to the object, so if you move the 
object, and want the camera or light to continue to point at the object, you will need to aim it again.

Q. I really like the Virtual Trackball tool, but sometimes I have a hard time understanding how it is
rotating the object. What am I missing?

A. Be sure to start your rotation with the cursor inside the circle. If you need more control, hold down the 
SHIFT key and your rotation will be constrained to 15 degree increments. Your object will rotate around its 
Hot Point.

Q. How come the Hierarchy window doesn't scroll automatically?
A. If you want to have the Hierarchy window scroll while you drag, hold down the ALT key. Otherwise, it 

behaves just like a window on the Windows desktop behaves.



Lights and Cameras
Q. How can I control the intensity of the shadows?
A. Double click on the light in the Hierarchy window and use the Shadow Intensity slider bar to adjust the 

intensity of the shadow. You can also try increasing the ambient light (just a little), but remember that 
ambient light affects the whole scene.

Q. I set up my scene by placing the objects and adjusting the lights, but when I render the scene, 
everything appears to be washed out. Why is that happening?

A. Be sure you do not to set the lights too bright. If you adjusted the lights by assigning a very light yellow or 
white color, you are probably flooding the scene with too much light. Try rendering the scene with the lights
set to a lower intensity.

Q. I set the ambient light to a nice clear white, but I am not getting the results I expected. What's 
wrong?

A. Ambient light refers to the light that is simply there in the room during the day. If you set the light to white 
it will probably wash out all the color and texture of your objects. Usually you will want to leave it set to the 
default neutral gray. Sometimes you may want a colored light for special effects, but don't make it too 
bright!

Q. I added Fog to my scene but it doesn't seem to do anything. I don't see any fog.
A. Fog will only show if it is in front of something. Is your object in front of the fog? You may need to adjust the 

area where the fog starts, or move your object into the fog. See Calculating the distance from the camera 
to objects for information on how to determine where fog begins and ends.

Q. My object looks foggy now, but shouldn't fog affect the whole scene?
A. In order to see the fog in the rest of the scene, you will need to provide a background. The same is true of 

Ambient Light. Choose a background under the Scene menu or create a background object and position it 
behind the scene.



Rendering
Q. Can I interrupt a rendering once it has started? If so, how do I resume, or do I need to start 

over again?
A. If you are using the Render Queue, you can pause a rendering by clicking on the Pause button in the Render

Queue window. You can then resume that rendering by clicking on the Resume button in the Render Queue 
window. The contents of the Render Queue are kept so you can resume a paused rendering later, even if 
you quit CorelDREAM and re-launch it. However, once you clear the Render Queue window, you will not be 
able to resume the rendering. Of course, you can abort a rendering by typing ESC, but an aborted rendering
can not be resumed.

Q. When using the render queue, my rendering did not show the latest changes I made to my 
scene.

A. The render queue renders the scene from the last version saved to your hard drive. (It's a good idea to save
frequently!) The Render command on the Scene menu will render your scene as currently shown, working 
from the copy held in RAM, showing the latest changes even if not yet saved to the hard drive. If you're 
happy with the output remember to save it!

Q. How long will it take to render my image?
A. Image rendering time depends on a variety of factors, including computer speed, rendering resolution, 

scene complexity, lights, transparencies and reflections, types and complexity of textures. Generally, more 
complex scenes will take longer to render than simpler scenes. Use the Estimate Render Time button in the 
Final Settings (or Preview Settings ) dialog box (Scene menu, Render Setup command) for information 
specific to your scene.

Q. What kind of image will I get if I choose to have the computer give me the best image possible 
in the time available instead of doing a full rendering? How will it relate to the Production 
format I have set? Will it keep the dpi constant and change the size or keep the size I set and 
change the dpi?

A. It will keep the image size and adjust the resolution to the best quality available in the time you have 
specified.

Q. What's the difference between addDepth and CorelDREAM? Can I take artwork from one to the 
other? Why would I want both products?

A. There are two ways the computer defines a graphic image: vector-based or pixel-based. Vector-based 
graphics are defined by mathematical formulas that tell the computer how to draw the curves and lines 
that make up a shape. This is the way the PostScript language works. It allows for scale changes at the last 
minute. CorelDRAW, Adobe Illustrator and CorelDEPTH are vector-based graphics packages.
Pixel-(or bitmap)based graphics programs define a picture pixel-by-pixel. Each pixel is assigned a specific 
color. This allows you to create very high quality photo-realistic images which include true shadows, 
reflection, and transparency. Corel PHOTO-PAINT and CorelDREAM create pixel-based graphic output. 
(CorelDREAM 3D does vector-based modeling, but the output is pixel-based.)
Vector-based programs and pixel-based programs do not share information very well. CorelDREAM 3D uses 
vector-based modeling, object control and paint (shader) control. Objects or complete scenes from 
CorelDREAM however, cannot be brought into CorelDRAW or CorelDEPTH.



Printing
Q. I created a scene in CorelDREAM 3D and rendered it. I can't seem to print the rendered image. 

Help!
A. Ensure that you have the most current version of your printer driver. This can be verified by contacting the 

printer manufacturer.
Q. I created a really neat 3D object but I can't figure out how to print it. Help!
A. Set up cameras and lights. Render your image. Open the rendered image, then click Print on the File menu.
Q. I printed my rendered image but it seems to be really poor resolution. On screen it looks pretty

good. What's going wrong?
A. It is up to you to choose the size and resolution you desire. The default is 72 dpi (screen resolution) which is

very poor quality for printing but great for previewing your scene on screen. Set the resolution for your 
image before rendering, by using the Artwork Settings dialog box (Scene menu, Render Setup command).



Shading: Overview
In CorelDREAM 3D, you control the appearance of objects by applying shaders to them. A shader is simply a set 
of surface characteristics. Each shader may contain settings for one or more of the following attributes: Color, 
Highlight, Shininess, Bump, Reflection, Transparency, and Refraction. A single shader, by defining several of 
these attributes, can simulate such complex materials as polished wood, hammered gold, or rough granite.
Each object you create in CorelDREAM has a base shader called the primer, which covers the entire object. By 
applying a shader to an object's primer, you can easily control the appearance of the object's surface. But many 
real-world objects have non-uniform surfaces. Variations on an object's surface might be as simple as a painted-
on logo, or as complex as an intricate inlaid wood design.
To achieve effects such as these, you can use CorelDREAM's 3D Paint tools. The 3D Paint tools allow you to apply 
different shaders to various regions on the surface of an object. These regions, called paint shapes, may take the
form of geometric shapes, or of freely brushed designs. Once created, paint shapes can be selected, moved 
along the surface of the object, modified (in shape or size), layered, or deleted.

{button ,AL(`About Shaders Browser;About Shader Editor;primer paint 
shapes;',0,"Defaultoverview",)} Related Topics



About the Shaders Browser
The Shaders Browser is the hub of shader activity. Located by default in the lower right corner of your monitor, 
the Shaders Browser provides you with a visual catalog of all currently available shaders. You'll use the Shaders 
Browser to apply shaders, create new shaders, delete shaders, organize shaders in families, save shaders in 
files, and load saved shader files.



About the Shader Editor
The Shader Editor gives you complete control over the appearance of your shaders. You can use the Shader 
Editor to edit shaders stored in the Shaders Browser, or shaders you've applied to objects in your scene.
The channel tabs give you access to the seven shader channels each channel controls one aspect of the shader's
appearance. The preview shows how your shader will appear on the surface of an object and provides immediate
feedback when you change shading parameters.

{button ,AL(`Shader Channels;Basic Components;Menu;Shader Editor 
Commands',0,"Defaultoverview",)} Related Topics



Shader Channels
A shader channel is a attribute which determines a particular aspect of a shader’s appearance.
Color
Defines the general color of the object or paint shape. Depending on the subshader you place beneath the Color 
channel, you can specify anything from a plain color to a complex, multi-color pattern.
Highlight and Shininess
Most objects in the real world show highlights when illuminated. These bright spots or streaks are direct 
reflections of light sources, like the sun glinting off a chrome bumper. You can control the color, intensity and size
of an object's highlights by placing shader components beneath the Highlight and Shininess channels.
Bump
Simulates variations on the surface of an object or paint shape. By placing shader components beneath the 
Bump channel, you can perturb a smooth surface to produce irregularities. This technique is known as bump 
mapping. Bump mapping can produce subtle effects like the bumps and pits on the surface of an orange, or 
more pronounced effects like the seams on a baseball.
To simulate bumps, the components you place beneath the Bump channel must specify some variation in the 
colors or values of adjacent pixels. Texture maps and functions produce the best results in the bump channel. 
Like the other non-color channels, the Bump channel always converts color information to grayscale.
Reflection
Controls the reflectivity of the object or paint shape. Most types of metal and glass are partially reflective, as are 
some types of plastic. A mirror is so reflective that it takes nearly all of its color from the environment around it. 
CorelDREAM allows you to specify reflectiveness by placing shader components beneath the Reflection channel. 
Often, you'll choose to place a simple Value component in the Reflection channel. If you want varying levels 
across the surface of an object or paint shape, you can use a Texture maps or an operator.
Transparency
When light strikes an opaque surface, it simply bounces off. When it strikes a semi-transparent surface, some 
light bounces off, but some passes through. You can specify an object's transparency by placing shader 
components beneath the Transparency channel. If you want to specify a uniform level of transparency, simply 
place a Value component in the Transparency channel. If you want varying levels of transparency, you can use a 
texture map or an operator.
Refraction
When light rays pass through a semi-transparent object like glass or fluids, their trajectories are deflected. This 
phenomenon is known as refraction. CorelDREAM allows you to set the amount of refraction for objects with at 
least some degree of transparency. If you want to specify a uniform level of refraction, simply place a Value 
component in the Refraction channel. If you want varying levels of refraction, you can use a texture map or an 
operator.



Shader Types
To create a shader, you add subshaders to the shader tree, placing them beneath the channels. The subshaders 
beneath a particular channel represent the settings for that channel. Depending on the subshaders you use, the 
settings in each channel may be simple or complex. For example, the Color channel might specify either a plain 
color or a multi-color pattern.
Color
Color subshaders are used most often in the Color channel, although you can place them under any channel. 
When you place the Color subshader on the shader tree, it appears as a color swatch. Clicking the swatch 
displays controls for creating a color or selecting one from a Color Picker.
Values
A Value subshader varies the level of the shader channel in which it is placed. You will use the Value subshader 
frequently in every channel but the Color channel. When you place the Value subshader on the shader tree, it 
appears as a slider. Dragging the slider sets the level.
Texture Map
A Texture Map subshader allows you to use a 2D image, such as a scanned photograph, in your shader. Texture 
maps are extremely useful in the Color channel. You might import a product logo as a texture map and apply it 
like a decal to 3D package model. After selecting the image, a set of controls appears allowing you to flip, rotate 
or tile the image.
Operators
Operators produces a composite by either mixing, summing, subtracting, or multiplying the values of two 
subshaders. The Multiply operator for example, can be used to tint a grayscale bitmap by multiplying the bitmap 
subshader by a color subshader.
When you place an operator on the shader tree, it appears as a node with a left and right branch plus a center 
branch if you are using the Mix operator. The left and right branches are placeholders for the two subshaders you
want to apply the operator to. The middle branch is for the function.
Functions
Functions produce specific patterns like a checkboard or wood grain. Functions are used almost exclusively with 
the Mix operator, although they can be used by themselves. When you place a function on the shader tree, it 
appears as a set of controls, which allow you to adjust the appearance of the pattern.



To set the level of preview detail for shading
On the View menu, choose Default Quality and select the preview mode you want.

The Box and Wireframe modes provide no preview of the shaders in your scene. The standard Preview mode 
displays only the average color of an object across its entire surface. To see your shaders in detail, you must 
switch to Better Preview mode or use the Render Preview tool.

{button ,AL(`Render Preview Tool;;',0,"Defaultoverview",)} Related Topics



To use the Render Preview tool
1 Select the  tool.
2. In the Perspective or Modeling window, drag a marquee to select the area to be previewed.

CorelDREAM will ray trace the area you have selected.
Tip
To work efficiently, keep the size of your render previews small. Larger areas take longer to ray trace, and require
more memory. If you want to preview a large portion of your scene, use the Render, Preview command, in the 
Scene menu.



To apply a shader to an object's primer
Do one of the following:

Drag a shader from the Shaders Browser onto an object in the Perspective window, or onto an object's icon in 
the Hierarchy window.
Select a shader in the Shaders Browser then select one or more objects in the Perspective or Hierarchy 
window. Click the Apply button in the Shaders Browser.

Note
To see the shader in detail, the preview mode must be set to Better Preview. Use the View, Default Quality and 
View, Object Quality to set the preview mode.



To apply a shader to a master object
1. Click the Master Objects tab in the Hierarchy window.
2. Double-click on the icon of the master you want to shade.

The master will be opened for editing in the Modeling window.
3. Shade the master in the Modeling window.
4. Click the Done button to return to the Perspective window.
Note
To see the shader, the preview mode must be set to Better Preview. Use the View, Default Quality and View, 
Object Quality to set the preview mode.

{button ,AL(`class_objects;shade primer;',0,"Defaultoverview",)} Related Topics



To apply another object’s shader to an object's primer
1. Select the object to be shaded in the Perspective or Hierarchy window.
2. Using the  tool, click the shader you want to use from an object in the Perspective window.

3. Click the Apply button in the Shader Editor.
Note
To see the shader in detail, the preview mode must be set to Better Preview. Use the View, Default Quality and 
View, Object Quality to set the preview mode.



To replace an object's primer (apply all channels)
1. Select the object in the Perspective or Hierarchy window.
2. Select a shader in the Shaders Browser, or use the  tool to grab the shader from an object in the Perspective 

window.
3. Hold the mouse button down on the Apply button in the Shaders Browser or Shader Editor.
4. From the pop-up menu, choose Apply All Channels.

Note
To see the shader in detail, the preview mode must be set to Better Preview. Use the View, Default Quality and 
View, Object Quality to set the preview mode.

{button ,AL(`Shader Channels;;',0,"Defaultoverview",)} Related Topics



To replace a paint shape's shader
1. Use the  tool to select one or more paint shapes.

Multiple paint shapes may be selected only if they are on the surface of the same object.
2. Select a shader in the Shaders Browser, or use the  tool to grab the shader from an object in the Perspective 

window.
3. Click the Apply button in the Shaders Browser or Shader Editor.

Notes
When you apply a shader to a paint shape, all channels (including empty channels) are copied directly into 

the paint shape. When a paint shape has an empty channel, it inherits the contents of that channel from the paint 
shape directly below it, or from the primer.

To see the shader in detail, the preview mode must be set to Better Preview. Use the View, Default Quality 
and View, Object Quality to set the preview mode.

{button ,AL(`Shaders Browser;Shader Editor;',0,"Defaultoverview",)} Related Topics



To change the layering order of paint shapes
1. Using the  tool, select one of the shapes you want to re-order.
2. On the Arrange menu, click Paint Shape Order, To Front or To Back.
Note
You can also change the layering order of paint shapes using the Object Shading Properties command on the Edit
menu.



Layering: How Primer and Paint Shapes Interact
When you create a paint shape on the surface of an object, the paint shape's shader overrides the shading 
characteristics of the object's primer. Likewise, when several paint shapes overlap, the topmost paint shape's 
shader overrides those below. There is one important corollary to this rule, however. When a paint shape's 
shader has one or more empty channels, it inherits the settings for these channels from the paint shape 
immediately below it (or from the primer, if there is no paint shape below).
For example, if you paint on a semi-transparent object, any paint shape you create will also be semi-transparent 
unless the shader you're painting with specifies a different transparency value. To create an opaque paint shape 
on a semi-transparent object, you would use a shader with a value of zero in the Transparency channel.
The Object Shading Properties command (Edit menu) allows you to control the size, position, and layering of 
paint shapes with numerical precision. It also allows you to specify an object's mapping mode and switch 
between its master and instance shading layers.

{button ,AL(`layering order;',0,"Defaultoverview",)} Related Topics



To edit an existing shader from the Shaders Browser
1. Double-click on the shader you want to edit. Or, if the Shader Editor is already open, just click once on the 

shader you want to edit.
2. Edit the shader tree by adding, removing, and modifying subshaders.



To create a new shader
1. Select a shader in the family in which you want the new shader added.
2. On the Shaders menu in the Shaders Browser, click New Shader.
3. Type a name for the new shader.

A new shader will appear in the Browser, immediately after the last shader in the current family. The new 
shader appears as a red sphere.



To edit an object's primer or a paint shape's shader
1. Select the  tool.
2. Double-click on an object to edit its primer make sure you click on an area where there are no paint shapes.

3. Double-click on a paint shape to edit its shader.
4. Edit the shader tree by adding, removing, and modifying subshaders.
5. When you are satisfied with the changes you've made, click the Apply button in the Shader Editor.



To jump into a subshader
1. On the Windows menu, click Shader Editor.
2. Do any of the following:

Double-click the preview of the subshader.
Click once on the downward-pointing arrow above the preview.
Click on the preview to select it, then click Jump In on the View menu in the Shader Editor.



To jump out of a subshader in the Shader Editor
1. On the Windows menu, click Shader Editor.
2. Do any of the following:

Click once on the upward-pointing arrow.
Click Jump Out on the View menu in the Shader Editor.
Click on the main preview, above the channel tabs, and hold the mouse button down. A pop-up menu 

appears, letting you choose any level above.



To select a subshader in the Shader Editor
1. On the Windows menu, click Shader Editor.
2. Click on the subshader you want to select.

If the subshader you select branches into lower level subshaders, the entire branch will be selected.
You can also select an empty branch.



To place a subshader on the Shader Tree
1. On the Windows menu, click Shader Editor.
2. Do any of the following:

Select an empty branch, or a branch whose contents you want to replace. Then choose the type of 
subshader you want to add from the Shader Type menu in the Shader Editor.

Drag a subshader from any location on the shader tree and drop it onto an empty branch or a branch 
whose contents you want to replace.

Drag a shader from the Shaders Browser and drop it onto an empty branch or a branch whose contents 
you want to replace.

Note
Even if the shader you're dropping contains information in several channels, only the information pertaining to 
the channel you're editing will be used. The entire contents of the applicable channel will be placed as a 
subshader on the branch where you drop the shader.



To remove a subshader
Select the subshader and click Delete on the Edit menu or press the Delete key.

If the subshader you remove branches into lower level subshaders, the entire branch will be removed.



To use a 3D Paint tool
1. Click the shader you want to use in the Shaders Browser, or use the  tool to grab the shader from another 

object.
2. Select a 3D Paint tool.
3. Do one of the following:

Drag to create a rectangle or ellipse.
Click once to position each vertex of a polygon and double-click at the last vertex to automatically close 

the shape.
Paint on the surface of the object in the Perspective or Modeling window. The object need not be selected.

Tip

When you draw with the  or 

 tool the resulting paint shape will not normally wrap all the way around the object. If you want the shape to 
wrap the other way around your object, hold down the ALT key as you drag.



To set brush options
1. Select the  tool to open the Brushes palette.
2. Click the icon for the brush type you want: Paint Brush or Eraser.
3. Drag the Size slider to make the brush smaller or larger.
4. Drag the Advance slider to set the frequency at which the brush shape is drawn along the path of the moving 

mouse. 
5. Drag the Hardness slider to adjust the weight of the brush stroke.
6. Drag the Flatness slider to adjust the width of the brush.
7. Drag the Angle slider to adjust the angle of the brush.



To paint with the Brush tool
1. Select the shader you want to use in the Shaders Browser, or use the  tool to grab the shader from an object 

in the Perspective window.
2. Select the  tool.

3. Choose a brush and set the brush options.
4. Hold down the mouse button and drag the brush cursor over the surface of an object to apply a brush 
stroke. Drag again to apply additional brush strokes.

A brushed shape may contain any number of brush strokes, but only one shader. You can also add to or 
subtract from an existing paint shape.

{button ,AL(`add to brushed shape;erase brushed shape;',0,"Defaultoverview",)} Related Topics



To add to a brushed shape
1. Use the  tool to select a brushed shape.
2. Use the  tool to grab the shader from the selected brush shape, or select the same shader from the Shaders 

Browser.
When you add to a brushed shape, you must use the same shader.

3. Add brush strokes, starting your first stroke within the bounds of the selected brushed shape.

{button ,AL(`erase brushed shape;',0,"Defaultoverview",)} Related Topics



To erase part of a brushed shape
1. Use the  tool to select a brushed shape.
2. Select the Brush tool  and choose the 

 icon from the Brush palette.
3. Drag the eraser across the portions of the brushed shape you wish to remove.



To import a brushed shape
1. Using CorelDRAW or other 2D art program, prepare the image you want to import.
2. Select a shader from the Shaders Browser.
3. Select the  tool.

4. In the Brush palette, select the  icon.
5. Drag a marquee across the surface of your object to define the limits of your imported brushed shape.
6. Select the image file from the Open dialog box.



To select a paint shape
Click on the shape with the 

 tool.



To move a paint shape
With the 

 tool, drag the paint shape anywhere on the surface of the object.
Note
You can also move paint shapes using the Object Shading Properties command on the Edit menu.



To delete a paint shape
1. Select the  tool and click the paint shape you want to delete.
2. Click Delete on the Edit menu or press the Delete key.



To resize a paint shape
With the 

 tool, drag a corner of the shape's bounding rectangle.
Note
You can also resize paint shapes using the Object Shading Properties command on the Edit menu.



To get information about an object's shader
1. Select the  tool and click an object.
2. On the Edit menu, click Object Shading Properties.



To change the layering order of an object's paint shapes
1. Select the  tool and click an object.
2. On the Edit menu, click Object Shading Properties.
3. Select a paint shape from the list on the left of the dialog box.

The topmost paint shape appears at the top of the list.
4. Click the Move forward button to move the selected paint shape toward the top of the list. Click the Send 

backward button to move the selected paint shape toward the bottom of the list.
5. Repeat the steps above until you are satisfied with the layering order.
Notes

When you are finished making changes you must click OK to confirm your choices. If you exit the dialog 
box by clicking Cancel, any changes you have made will be canceled.

You can also change the layering order of paint shapes using the Paint Shaper Order commands on the 
Arrange menu.



To create a new paint shape
1. Select the  tool and click an object.
2. On the Edit menu, click Object Shading Properties.
3. Click the New button.

A new paint shape will be created on the surface of the object, using the default size, position, and shader.
Note
When you are finished making changes you must click OK to confirm your choices. If you exit the dialog box by 
clicking Cancel, any changes you have made will be canceled.



To delete a paint shape in the Shading Info dialog box
1. Select the  tool and click an object.
2. On the Edit menu, click Object Shading Properties.
3. Select a paint shape from the list on the left of the dialog box.
4. Click the Delete button.
Tip
You can also delete a paint shape by selecting it with the  tool and pressing the Delete key.
Note
When you are finished making changes you must click OK to confirm your choices. If you exit the dialog box by 
clicking Cancel, any changes you have made will be canceled.



To edit a paint shape's size and position
1. Select the  tool and click an object.
2. On the Edit menu, click Object Shading Properties.
3. Select a paint shape from the list on the left of the dialog box.
4. Edit the values in the Size and Position fields.

The numbers immediately to the right of the Size and Position fields represent the range of possible values for 
each dimension.
The Position values determine the position of the paint shape's upper left corner on the surface of the object.

5. Click the Apply button.
Note
When you are finished making changes you must click OK to confirm your choices. If you exit the dialog box by 
clicking Cancel, any changes you have made will be canceled.



To set a paint shape's opacity
1. Select the  tool and click an object.
2. On the Edit menu, click Object Shading Properties.
3. Use the Opacity slider to set a value between zero and 100%.
Note
When you are finished making changes you must click OK to confirm your choices. If you exit the dialog box by 
clicking Cancel, any changes you have made will be canceled.



To change a paint shape from one type to another
1. Select the  tool and click an object.
2. On the Edit menu, click Object Shading Properties.
3. Select a paint shape from the list on the left of the dialog box.
4. Choose a new paint shape type from the Shape list box.
5. Click the Apply button.
Note
When you are finished making changes you must click OK to confirm your choices. If you exit the dialog box by 
clicking Cancel, any changes you have made will be canceled.



To change an object's mapping mode
1. Select the  tool and click an object.
2. On the Edit menu, click Object Shading Properties.
3. Click on one of the Mapping Mode icons to choose a mapping mode. From left to right, the icons represent 

surface mapping, box mapping, cylindrical mapping, and spherical mapping.
If you have chosen one of the projection mapping modes, a set of additional controls will appear to the right of
the Mapping Mode icons.

4. For box mapping, choose the face you want to map onto.
5. For cylindrical or spherical mapping, choose the orientation of the mapping primitive.
Note
When you are finished making changes you must click OK to confirm your choices. If you exit the dialog box by 
clicking Cancel, any changes you have made will be canceled.



To save shaders files
In the Shaders Browser, click Save All on the Files menu.



To select a shader
Click once on the shader's preview in the Shaders Browser.

A border appears around the selected shader and its name appears in the top of the Browser window. The 
selected shader is used when you use a paint tool to shade your object or when you drag the shader onto the 
object.



To get information on a shader in the Shaders Browser
1. Click once on the shader's preview in the Shaders Browser.
2. On the Shaders menu in the Shaders Browser, click Shader Info.
3. If you want, change the name of the shader and add comments.



To duplicate a shader
1. Select the shader you want to duplicate in the Shaders Browser.
2. In the Shaders Browser, click Shader, Duplicate Shader.
Note
The duplicate is given the same name as the original. To avoid confusion, you may want to rename the duplicate 
using the Shader Info command in the Shaders Browser.



To create a new shader from the Shader Editor
1. On the Windows menu, click Shader Editor.
2. Drag the preview from the editor into the family in the Browser where you want it.



To delete a shader
1. In the Shaders Browser, select the shader you want to delete.
2. On the Shaders menu, click Delete.



To move a shader to a different Shaders family
Drag the shader's preview into an open area in the column for the family where you want it.



To create a new Shaders family
1. On the File menu in the Shaders Browser, click New.
2. Type a name for the new family.

The family is added after the rightmost column in the Shaders Browser. Use the scroll bar to bring it into view.



To add or remove Shader families from the Shaders Browser
1. On the Files menu in the Shaders Browser, click Add/Remove Files.
2. Select the Shader family files you want to add or remove, then click the Add, Add All or Remove button.
3. When you are finished, click Close.
Note
Removing a shaders family file doesn't delete the file, but removes it from the list that the Browser loads. To 
permanently remove a shaders file, use the File Manager to delete the file.



Menu command Keys
File menu
Edit menu
View menu
Arrange menu
Geometry menu
Scene menu
Cross Section menu
Windows menu
Help menu



File menu command keys
CTRL+N New
CTRL+O Open
CTRL+S Save
CTRL+P Print
ALT+F1 Browse 3D Clipart
ALT+F4 Exit

Edit menu command keys
CTRL+Z Undo

ALT+BKSP Undo
ALT+RETURN Redo

CTRL+R Repeat
CTRL+Return Repeat

CTRL+X Cut
SHIFT+DEL Cut

CTRL+C Copy
CTRL+INS Copy

CTRL+V Paste
SHIFT+INS Paste

DEL Delete
CTRL+D Duplicate

CTRL+ALT+D Duplicate with Symmetry
CTRL+ALT+A Select All Objects

CTRL+F Find
ALT+F7 Object Properties

ALT+F10 Object Properties

View menu command keys
CTRL+O Type, Reference
CTRL+5 Type, Drawing Plane
CTRL+8 Type, Top
CTRL+2 Type, Bottom
CTRL+4 Type, Left
CTRL+6 Type, Right
CTRL+1 Type, Front
CTRL+3 Type, Back
CTRL+Y Default Quality , Bounding 

Box
CTRL+SHIFT+Y Default Quality, Wireframe

CTRL+ALT+ SHIFT+Y Default Quality, Preview
CTRL+ALT+Y Default Quality, Better 

Preview
CTRL+J Grid

Arrange menu command keys
CTRL+ALT+SHIFT+K Align, Fully on Working Box

CTRL+SHIFT+K Align, On Working Box



CTRL+ALT+K Align, On Universe
CTRL+SHIFT+G Align, On Gravity

CTRL+A Align Objects
CTRL+ALT+B8 Send Working Box To, Global Universe

CTRL+B Send Working Box To, Local Universe
CTRL+ALT+SHIFT+8 Send Working Box To, Selection

SHIFT+PGDN Paint Shape, Order To Back
SHIFT+PGUP Paint Shape, Order To Front
CTRL+PGUP Paint Shape Order Forward one
CTRL+PGDN Paint Shape, Order Backward one

CTRL+G Group
CTRL+U Ungroup
CTRL+L Combine
CTRL+K Break apart
CTRL+Q Convert to curves (TBD)

Geometry menu command keys
ALT+F9 Scale
ALT+F8 Rotate

Scene menu command keys
CTRL+E Camera Settings

F9 Render, Preview

Cross Section menu command keys 
CTRL+SHIFT+N Show Shape Numbers

CTRL+ALT+N Options

Window menu command keys
CTRL+7 New Perspective
CTRL+/ Shader Editor

CTRL+F4 Close document window
CTRL+F6 Switch document window

Help menu command keys
CTRL+F1 Search for help on

F1 Help contents

Toolbox Keys
Pick tools
Text tools
Viewing tools
Rotation tools
Drawing tools
3D Paint tools



Pick tool keys
CTRL+SPACE Toggles pick tool and last selected tool

Space Toggle Pick tool and last selected tool
Click+T Adds or removes objects from current selection

Click+T+ CTRL Selects the working box
Double-click ALT+T Opens/closes the selected group.

Drag+T Moves along the preferred plane at 45 degree angle
Drag+ALT Moves object perpendicular to the preferred plane

Drag+CTRL Moves working box along the preferred plane
Drag+CTRL+ALT Moves working box perpendicular to the preferred 

plane
Drag+CTRL+SHIFT Contrains movement of working box along the 

preferred plane to a 45 degree angle
Drag handle on bounding box

or projection+T
On bounding box: Resizes proportionally. (Opposite 
corner does not move.
On projection: Resizes proportionally in 2D. 
(Opposite corner does not move.)

Drag handle on bounding box
or projection+T+CTRL

Before dragging: Resizes working box along 
preferred plane.
While dragging: Resizes object. (Hot point does not 
move.)

Drag handle on bounding box
or projection+SHIFT+ALT

Resizes proportionally in 3D. (Opposite corner does 
not move.)

Drag handle on bounding box
or projection+CTRL+ALT

Before dragging: Resizes working box proportionally
using the direction perpendicular to the preferred 
plane.

Drag handle on bounding box
or projection+CTRL+SHIFT

While dragging on bounding box: Resizes 
proportionally. (Hot point does not move.)
While dragging on projection: Resizes proportionally
in 2D. (Hot point does not move.)

Drag handle on bounding box
or

projection+CTRL+SHIFT+ALT

While dragging: Resizes object proportionally in 3D. 
(Hot point does not move.)

Text tool keys
Pressing Selects

CTRL+T Text tool
F8 2D text & 3D text tools

Viewing tool keys
Pressing/

clicking
Selects

Rotation
Tool+Q+ALT

Twists the surface as you rotate the cross section shape.

Rotation
Tool+V+CTRL

Orients the working box in 3D space.

Rotation tool keys
Pressing/

clicking
Selects

F3 Zoom out
SHIFT+F4 Zoom to whole page

F2 Zoom in



F4 Zoom to fit
SHIFT+F2 Zoom to selected object

Display Plane
tool+R

Sets the preferred plane

Drawing tool keys
Pressing Selects

F5 2D Bezier tool & 3D free form tool
F6 2D Rectangle & 3D Basic object
F7 2D Ellipse & 3D Basic object

Bezier
tool+SHIFT

Constrains angle of control points to 45 degree angle

3D Paint tool keys
Pressing Selects

Paint Shape Selection
tool+W+SHIFT

Click on paint shape:Adds or removes paint shapes from 
the current selection
Drag a paint shape: Constrains proportions of paint 
shape.

Paint Shape Selection
tool+W+SHIFT+ALT

Drag a paint shape handle: Wraps the paint shape 
around the back of the 3D object.

3D Paintbrush+B Forces the creation of a new brush shape.
Bezier tool+SHIFT Constrains angle of control points to 45 degree angle

Text Editing keys
Press To

CTRL+Left Arrow Moves to previous word
CTRL+Right Arrow Move to next word

CTRL+Home Move to start of frame
CTRL+End Move to end of frame

SHIFT+Right Select right character
CTRL+SHIFT+Left Select left word
CTRL+SHIFT Right Select right word

SHIFT+Home Select to start of line
SHIFT+End Select to end of line

CTRL +SHIFT+Home Select to end of frame
CTRL+SHIFT+End Select to start of frame

CTRL+I Italic

Graphic Editing Keys
Press To

Esc Deselects all objects
Tab Select next object

SHIFT+Tab Select previous object
Up Nudge Up

Down Nudge Down
Left Nudge Left

Right Nudge Right





Starting a Scene: Overview
A CorelDREAM 3D document is called a scene. All objects are part of a scene, so you must have a scene open to 
work with its objects.
You can create a new scene, open an existing one, save your work, or close a scene by choosing the appropriate 
command from the File menu or its corresponding keyboard shortcut.
The Save As command creates a copy of the scene under a different name. If you close the initial Perspective 
window for a scene (you may have several open at the same time), you close the scene.



To create a new scene
On the File menu, click New.



To open an existing scene
1. On the File menu, click Open.
2. Type or select the name of the scene you want to open. You may need to locate the directory or drive that 

contains the scene.
3. Click OK.
Tip
You can also open a scene you worked on recently by clicking on its name at the bottom of the File menu.



To save a scene
1. On the File menu, click Save.
2. If you have not saved the scene before, type a name for it in the File Name box.



To close a scene
1. Click File, Close.
2. Click Save.
Note
Closing a scene’s Perspective window closes the scene. If you have several Perspective windows open on a 
scene, the scene remains open until the initial window is closed.



To create a copy of the scene
1. On the File menu, click Save As.
2. Enter a new name for the scene in the File Name box.
3. Click OK.



To magnify or reduce views in the Perspective or Modeling windows
Select the 

 tool and drag to enclose the portion of the window you want to magnify.
Tip
You can also use the pop-up box in the bottom left corner of the window to select the zoom level you want. (At 
1:1, one inch on the screen equates to one inch of image in a rendering.)



To zoom in on selected objects only
1. Hold the mouse button down on the  tool.

2. Click .
3. Click anywhere in the Perspective or Modeling window.



To view a scene or object in the Modeling box at actual size
1. Hold the mouse button down on the  tool.

2. Click .
3. Click anywhere in the Perspective or Modeling window.

Tip
You can also set the view to actual size by clicking the pop-up box in the bottom left corner of the Perspective or 
Modeling window and selecting 1:1.



To view all objects in the Perspective or Modeling window
Click 

 on the toolbar.



To view all objects in the working or modeling box
Click 

.on the toolbar.



To scroll the Perspective or Modeling window
Do any of the following:

Click the arrows at either end of the scroll bar to move the current view 10% in selected direction
Click an elevator to move the view by one window length or width
Click a thumb and drag to move the view an arbitrary amount in any direction



To pan the view in the Perspective or Modeling window
1. Hold the mouse button down on the  tool and click 

.
2. Drag in the Perspective or Modeling window.



To set the amount of detail displayed in all objects
On the View menu, choose Default Quality and select the preview mode you want:

Box: Displays projections for the visible working planes plus bounding boxes for each object.
Wireframe: Displays objects in skeleton form.
Preview: Displays objects as solid with flat color information. Only the outlines of painted shapes are 
displayed.
Better Preview: Displays objects using ambient light and your specific light sources to show color, highlights,
gel effects, and depth shading. Displays shading, texture maps, and paint regions, in detail. Provides better 
details of the shape and color of objects but increases the time required to calculate and draw or redraw the 
Perspective window.

{button ,AL(`individual_object_detail;;;;',0,"Defaultoverview",)} Related Topics



To set the amount of detail displayed for an individual object
1. Select the object by clicking on it with the  tool.
2. On the View menu, select Object Quality and click the preview mode you want.

Box: Displays projections for the visible working planes plus a bounding boxes.
Invisible: Hides the object in the Perspective window only. To make the object visible again, select it the 
Hierarchy window and choose another display mode from the Object Quality submenu.
Wireframe: Displays the object in skeleton form.
Preview: Displays objects as solid with flat color information. Only the outlines of painted shapes are 
displayed.
Better Preview: Displays objects using ambient light and your specific light sources to show color, highlights,
gel effects, and depth shading. Displays shading, texture maps, and paint regions, in detail. Provides better 
details of the shape and color of objects but increases the time required to calculate and draw or redraw the 
Perspective window.



To hide or show objects in the Perspective window
1. Select the object by clicking on it with the  tool.
2. On the View menu, select Object Quality and click Invisible.
3. To make the object visible again, select it the Hierarchy window and choose another display mode from the 

Object Quality submenu.




