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Credits and License Terms
Mapedit, copyright 1994, 1995 by Thomas Boutell. Mapedit is not free software. See the "about"
option of the Help menu for details of the license governing this copy of the product. 



What's New in Version 1.5
1.5 fixes the following bugs in previous versions:
GIFs produced by Photoshop now load correctly.
Mapedit no longer fails to load maps containing hotspots without URLs.
Mapedit no longer attempts to add comments to CERN-format imagemaps. (The CERN 
imagemap program does not support comments and rejects maps that contain them.)
Mapedit 1.5 is a much    better citizen of the Microsoft    Windows environment when compared 
to version 1.2 and earlier. Version 1.5 should be compatible with all    graphics cards, at some 
expense in quality in graphics modes with a modest range of colors. 



What is Mapedit?

mapedit is a WYSIWYG (What You See Is What You Get) editor for imagemap files.
Imagemap files are a feature of NCSA, CERN and practically all other httpd servers; they allow 
you to turn a    GIF into a clickable map by designating polygons, circles and rectangles within 
the GIF and specifying a URL for each to link to.
Unfortunately, creating good image maps by hand is a lot of work, because the points must be 
located using an editor not explicitly designed for the purpose.
mapedit allows you to load your GIF image into a scrollable, resizable window and then draw 
polygons, circles and rectangles on top of it, specifying a URL for each. It also allows you to go 
back and delete these "hot spots", set a default URL for clicks outside of the "hot" areas, and so 
on. In addition, it allows you to associate comments of arbitrary length with each object if you 
are creating an NCSA-format map.



What else do I need to use Mapedit?

To use Mapedit for Windows, you will need    a World Wide Web server on which cgi scripts, 
specifically the imagemap program (not this program!), have been installed. In order to add your 
maps to the server's collection of imagemaps, you will probably need access to the map 
configuration file which lists them; see the server documentation and talk to your server 
administrator. This is not documented this here because it varies from one web server to another. 
Again, please read your web server's documentation!
The server does NOT have to reside on your MS Windows system, although that is possible. You
can run Mapedit to your heart's content without a server. A server simply must exist somewhere 
so the imagemaps you create can actually be used.
If you do not know what a World Wide Web server is, I suggest you consult the World Wide Web
FAQ, available at the URL:
http://sunsite.unc.edu/boutell/faq/www_faq.html
If you don't know what a URL is, see the newsgroup comp.infosystems.www.misc to begin to 
learn more    about the web.



How do I get started editing an imagemap? 

Mapedit's menu bar contains a File menu, a Tools menu and a Help menu. Initially most options 
are disabled, since you have not yet opened an image and a map.
Using the mouse, pull down the File menu and select Open/Create Map... A dialog box will 
appear.
In this dialog box you should enter the filename you would like to give to your map, which need 
not already exist, and the filename of a .gif image the map will be of, which must exist. (mapedit 
is not a paint program. To create your own GIFs, use any paint program. Conversion utilities are 
available to convert .bmp files into .gif format.)
"Why can't I use a .BMP file?" Because you won't be able to use it on the server in any case. 
(Most web browsers can't display .BMP files inline, so they are not useful for imagemaps.)
Type in a map filename, such as "test.map", and also enter the location of a GIF image for which 
you want to create a map. (Give paths in the file system, of course, not URLs!) You can click on 
the Browse buttons to explore your directories and select files with the mouse.
Click on either the NCSA or the CERN radio button to indicate which type of server you have. 
(They use two different imagemap formats.) Mapedit will remember this setting for future use in 
its mapedit.ini file.
Press RETURN or click on OK when you have entered the filenames.
If the map file does not already exist, you will be asked if you want to create it. Click on OK to 
continue. If the map does exist, mapedit will automatically determine the server type of the file 
regardless of the radio button setting; you can change the file's type using the Save As... dialog 
box.
mapedit will now load your GIF image into memory. This will take a few moments, depending 
on the size of the image.
When the image has been loaded, it will appear in the main mapedit window, which should 
expand or shrink to suit the image. If the image is large, scrollbars for horizontal and vertical 
movement may appear. 
You can navigate the image using the scrollbars; you can also resize the window arbitrarily.



How come my GIF is being dithered?
Mapedit uses your system palette's colors to approximate the colors in the image as closely as 
possible. If you have 65536 colors or more, the display is much better, and on a "truecolor" 
display it should be perfect; but I developed it in a 16-color mode and find it quite usable there as
well. Your GIF image is not actually changed!



How do I make "hot spots"?
Image maps consist of areas that have been designated as "hot spots" which users can click on to 
fetch particular URLs. Mapedit allows you to draw these graphically on the screen.
How do I specify polygons?
How do I specify rectangles?
How do I specify circles?



How do I specify polygons?
Select Polygon from the Tools menu to begin drawing a polygonal hot spot. Now click the left 
mouse button at some    point on the edge of an area of interest in the image.
Move the mouse pointer to another point on the edge of the area of interest, tracing its outline. 
Note that a "rubber-band" line follows you from the point of the initial click.
Click again at this second point. Continue clicking points until you have outlined all but the final 
connection back to the first point. (You do not need to hold down the mouse button.)
(Note that if you don't like the way your polygon is turning out, you can press the ESC key to 
cancel it; then start over with the left mouse button.)
To complete the polygon, click the right mouse button. 
Another window will pop up, prompting you for the URL that this polygon should link to. If you 
don't yet know the URL, type in a name that is meaningful to you so you will be able to 
recognize it later.    Also add any comments you wish in the comments window if you are 
creating an NCSA-format map.    Click on OK or press RETURN to continue.    (The RETURN 
key only has this effect in the URL window, since multiple-line comments are allowed in the 
comments window.)
The polygon will now be traced in solid white, and a final side between the last point and the 
first point will be automatically added. (If the white outline is not easily visible on this image, try
selecting Edit Sketch Color... from the File menu.)



How do I specify rectangles?
Select Rectangle from the Tools menu. Click the left mouse button in one corner of a rectangular 
region of interest in the image. Now move the mouse pointer to the opposite corner, tracing out a
rectangle. (You do not need to hold down the mouse button.) 
Click the right mouse button to accept the rectangle, and enter a URL for it as you did for the 
polygon. (Just as for polygons, the escape key can be used to cancel the rectangle while you are 
tracing it out.)



How do I specify circles?
Select Circle from the Tools menu. Circles work just like rectangles, except that the left mouse 
click positions the center of the circle, and you can then move the mouse pointer to any point on 
the edge of the desired circle and click the right mouse button to accept it. As before, the escape 
key.



Editing the hot spot color

You can edit the hot spot color by selecting Edit sketch color... from the File menu. You will be 
presented with the standard color selection dialog box, in which you can click on a color of your 
choice. Look for a color that contrasts well with the colors present in your images.
Mapedit will remember your choice of color indefinitely.



How do I test my hot spots?
Select Test/Edit from the Tools menu. Now click at various points in the image. When you click 
in a hot spot, such as a polygon, rectangle or circle you have designated, the URL window will 
pop up, showing the URL assocated with that hot spot. Also, the region within the hot spot will 
be displayed in reverse video.
Important note: when hot spots overlap, the oldest gets the click. This is important because this is
how the actual imagemap program will behave when your users click on your map in practice.



How do I go back and edit URLs and comments?
Often you will not know the final URL for each hot spot at first, or you will want to change it. 
You can do so by selecting Test/Edit from the Tools menu and clicking in the hot spot in 
question, editing the URL that appears, and then clicking on OK or pressing RETURN. You can 
also edit in the comments window at this time. (The RETURN key does not dismiss the popup 
while in the comments window; click on the OK button instead.) Note that you can cut, copy and
paste in the URL window and URL Comments window using the control-x, control-c and 
control-v keys (just as in all other Windows applications).



How do I delete unwanted hot spots?
Select Test/Edit... from the Tools menu.    Note that a Delete button appears in the URL dialog 
box when you select a hot spot. By clicking this button, you can remove that hot spot from the 
map.
NOTE: When you delete a hot spot (object), comments associated with that hot spot are also 
deleted!



How do I set a default URL?
There is one more component in an imagemap file: a default URL to be loaded if the click is not 
in any region. To set a default URL, pull down the file menu, select Edit Default URL..., and 
enter    a default URL in the window that appears. Click on OK or press RETURN to accept it.
You may also, on the other hand, want to get rid of the default URL completely. Once you have 
set a default URL, a Delete button will appear in the Edit Default URL dialog box. Click this 
button to remove the default URL.
Note: The testing tool does not indicate when the default URL would be used. It was felt that not 
popping up anything indicates clearly that the click is not in any hot spot, and displaying the 
default URL might be misleading.



How do I save my work?
Pull down the file menu and select Save. mapedit will write your map to the file you specified 
when you opened it.
If a problem is encountered while writing this file (if you entered a bad path when you first 
created the map, for instance), use the Save As file menu option to enter a new name for the map 
file. 



Can I edit my existing imagemap files?
Yes. mapedit can read existing imagemap files without difficulty. In addition, mapedit preserves 
comments in your imagemap file! However, keep in mind that when you delete a hot spot, 
comments associated with it are also deleted. Also note that comments are associated with the 
object that follows them. 
Mapedit will also silently preserve any comments placed at the very end of the imagemap file, 
and will not delete these comments (but see below).
Since the CERN imagemap program does not support comments and rejects maps that contain 
them, Mapedit version 1.5 and later will not store comments in such maps.
MS Windows note: the comments for a single object cannot exceed 4K. The comments at the end
of the file cannot exceed 64K.



Can I convert from NCSA to CERN or vice versa?
Yes. Use the Save As file menu option and change the setting of the Style menu that appears    in 
the Save As dialog box, then click OK to save your map in the new format. That's all there is to 
it!



If you have problems
If you have any difficulties with mapedit, feel free to contact the author, Thomas Boutell 
(boutell@boutell.com). Please read    this manual thoroughly first.




