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1: Getting Started

 

This chapter contains system requirements information, installation instructions, and a 
general overview of the Arrange-It software windows, menus, and toolbar.

 

System and Software Requirements

 

The following sections detail the recommended system configuration and software 
requirements.

 

System Hardware

 

To use Arrange-It software, you require an 

 

IBM PC

 

 or compatible with at least a 25 MHz 
80386 processor and a mouse.

 

Memory and Disk Space

 

Arrange-It software requires a minimum of 8 megabytes of 

 

RAM

 

 and at least 40 
megabytes of free hard disk space. For optimum performance, it is recommended that 
you have at least 16 megabytes of 

 

RAM

 

 and 60 megabytes of free hard disk space.

 

Display

 

Arrange-It software works with most display adapters supported by 

 

WINDOWS

 

 
software. It is recommended that you use a 24-bit color display adapter and compatible 
monitor (for example, a Super

 

VGA

 

 monitor). As a minimum requirement, you should 
have a 256-color display adapter.

 

CD-ROM Drive

 

To access images stored on Photo CD Master discs or Photo CD Catalog discs, you need 
a 

 

CD-ROM XA

 

 Mode 2, Form 1 drive. 

 

CD-ROM

 

 drives displaying the Photo CD symbol 
(shown on the cover of this book) indicate that Kodak has certified the drive as capable 
of reading Photo CD discs.

Refer to “Software Support” on the Information Card for a telephone number that you 
can call to obtain information on Photo CD-compatible 

 

CD-ROM

 

 drives.
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System Software

 

In addition to Arrange-It software, you require

 

■

 

M

 

ICROSOFT

 

 

 

WINDOWS

 

 3.1 software, running in enhanced mode

 

■

 

MS-DOS

 

 5.0 software or later

 

Installing Arrange-It Software

 

This section contains an explanation of Arrange-It software files in their default 
directories. You may find this information useful when you

 

■

 

Do a partial installation

 

■

 

Need more disk space and are looking for things to discard

 

■

 

Want to know more about Arrange-It software auxiliary files

 

■

 

Reinstall all or part of Arrange-It software

 

■

 

Encounter a problem installing Arrange-It software

 

■

 

Just want to know all the details

Arrange-It software consists of the following main components:

 

■

 

ARRANGIT.EXE

 

 is the software application file located in the 

 

C:\ARRANGIT

 

 
directory after a default installation. Whenever you move the application, you 
should move it with its entire directory. Arrange-It software looks for its auxiliary 
files in this directory. If you do not move these files together, you may get some 
unexpected results with files you created earlier.

 

■

 

C:\ARRANGIT\SMPDATA

 

 directory contains the files that you use in the tutorial. 
You may move this directory or delete it once you have finished the tutorial lessons.

 

■

 

C:\ARRANGIT\PLUGINS

 

 directory is the default location of the plug-ins used to 
emulate various models of Photo CD players. This directory must remain a 
subdirectory of the directory containing the Arrange-It software application.

To install Arrange-It software on your hard disk, you need approximately 8 megabytes 
of free hard disk space.

If you have any virus detection software installed on your computer, you should disable 
it before you begin the Arrange-It software installation procedure.
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To install the Arrange-It software from the Program Manager:

 

1.

 

Insert the 

 

KODAK 

 

Arrange-It Photo CD Portfolio Layout Software

 

 

 

with Photo Sampler II 

 

disc into the 

 

CD-ROM

 

 drive.

 

2.

 

Choose Run from the File menu.

The Run dialog box appears. 

 

3.

 

Enter 

 

D:\ARRANGIT\SETUP.EXE

 

 in the Command Line text box, assuming the 

 

CD-ROM

 

 drive is the D drive. 

 

4.

 

Click OK

The 

 

KODAK

 

 Arrange-It Setup dialog box appears, followed by the 

 

KODAK

 

 
Arrange-It Custom Installation dialog box.

 

5.

 

Click Change Path if you want to install to a different drive and directory than the 
default path. The default installation drive and directory are 

 

C:\ARRANGIT

 

. 

 

6.

 

Click the appropriate check boxes in the Installation Options section of the Custom 
Installation dialog box. The default installation selects all three check boxes.

 

KODAK

 

 Arrange-It Software Program Files

 

KODAK

 

 Arrange-It Software Tutorial Files

Add Items to New Program Manager Group

Run dialog box

KODAK Arrange-It Custom 
Installation dialog box
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You may not want to install the tutorial files if you already know how to use 
Arrange-It software and want to save disk space.

 

7.

 

Click Install.

All the files install in the specified drive and directories. When installation is 
completed, the Setup Complete message box appears.

 

8.

 

Click OK to return to the Program Manager. 

Unless you deselected the Add Items to New Program Manager Group check box in 
the Kodak Arrange-It Custom Installation dialog box, the 

 

KODAK

 

 Arrange-It 
Program Group appears in the Program Manager. The Program Group contains the 

 

KODAK

 

 Arrange-It software icon and a Notepad file called 

 

README.TXT

 

.

 

9.

 

Double-click the 

 

README.TXT

 

 icon to see important information about changes 
made to Arrange-It software after this book was printed.

 

Starting Arrange-It Software

 

To start Arrange-It software:

 

1.

 

Switch to the 

 

WINDOWS

 

 software Program Manager. 

 

2.

 

Double-click the 

 

KODAK

 

 Arrange-It Program Group.

 

3.

 

Double-click the 

 

KODAK

 

 Arrange-It software icon in the Program Group.

The Arrange-It software welcome screen appears showing application copyright 
information.

Immediately following the welcome screen, the Arrange-It software application 
window appears containing the Untitled Document-1 and Default Collection windows.

Arrange-It software 
welcome screen
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Using the Arrange-It Software Application Window

 

You use the Arrange-It software application window to create a presentation using 
Photo CD, 

 

TIFF

 

, 

 

YCC TIFF

 

, and bitmap (

 

BMP

 

) images, as well as audio (

 

WAV

 

) files. An 
Arrange-It software document lets you graphically outline your presentation. 

The Arrange-It software application window contains the menu bar, toolbar, collection 
window, document window, and status bar. 

 

■

 

Menu bar

 

 contains nine Arrange-It software menus.

 

■

 

Toolbar

 

 contains the tools that you use to build a presentation.

 

■

 

Collection window

 

 displays a collection of images and audio files that can be used 
in a presentation. You can have multiple collection windows open in the application 
window. You can also close the collection windows and increase the size of the 
document window. 

 

■

 

Document

 

 

 

window

 

 displays the work area where you construct your presentation. 

 

■

 

Status bar

 

 displays information about actions taking place in the application 
window and describes the currently active tool or menu item.

Arrange-It software supports only one open document (presentation) at a time. To open 
an existing document, choose Open from the File menu and select the document that 
you want to open. Arrange-It software automatically closes the current document and 
opens the file that you selected.

Arrange-It software application 
window

Collection window

Document window

Toolbar

Status bar
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Arrange-It Software Menus

 

The Arrange-It software menu bar contains nine menus. 

 

File Menu

 

The File menu provides the following commands:

 

■

 

New

 

 creates a new document or collection.

 

■

 

Open

 

 opens an existing document or collection.

 

■

 

Close

 

 closes the current document or collection.

 

■

 

Save

 

 saves the current document.

 

■

 

Save As

 

 saves the current document or collection using a different name or location.

 

■

 

Revert

 

 reverts to the last saved version of the current document.

 

■

 

Text Outliner

 

 creates a document with the text outline language.

 

■

 

Import 

 

PLAYLIST.PCD

 

 creates a document from a Photo CD Portfolio disc.

 

■

 

Recent File

 

 lists up to four of the latest document files you have opened. You can 
select a filename from the list to quickly reopen it.

 

■

 

Exit

 

 quits the Arrange-It software application.

 

Edit Menu

 

The Edit menu provides the following commands:

 

■

 

Undo

 

 cancels the effects of the last action.

 

■ Cut deletes the selected item from the document and puts it on the Clipboard.

■ Copy puts a copy of the selected item on the Clipboard.

■ Paste inserts the contents of the Clipboard into the document.

■ Clear deletes the selected item from the document. 

■ Select All selects every item in the document. 

■ Duplicate makes a copy of the selected item.

■ Global Modify lets you modify multiple values or settings in your document.

■ Preferences lets you change the default values or settings of any new items that you 
create.
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View Menu
The View menu provides the following commands:

■ Zoom Out resizes and scales the contents of the document window, so that each 
item is smaller and a larger overview is displayed. 

■ Zoom In resizes and scales the contents of the document window so that each item 
is magnified and the details of a smaller part of the document can be viewed. 

■ View All Nodes zooms out, so that all items in the document can be viewed in the 
document window. 

■ Restore View returns the view size back to normal. 

■ Columns arranges items in columns according to the height of the collection 
window. 

■ Rows arranges items in rows according to the width of the collection window. 

■ Better Color Quality displays images using the best possible color match on 
systems with 256 colors or less, optimizing color quality at the expense of speed.

■ Better Speed displays images faster, but at the expense of color accuracy.

Collections Menu
The Collections menu provides the following commands:

■ New creates a new collection.

■ Open opens an existing collection.

■ Remove removes all items in the current collection from the document.

■ Edit opens the Edit Collection dialog box for the selected collection.

Node Menu
The Node menu provides the following commands:

■ Edit opens the Edit Node dialog box for the selected node.

■ Color allows you to change the color of the selected node.

■ Align Nodes opens a cascading menu that lets you choose how the selected nodes 
are aligned.

■ Show As Group displays two or more selected nodes as a single grouped item.

■ Show As Nodes expands selected group nodes into component nodes.
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■ Find Node locates a specific node and displays it in the center of the document 
window.

■ Set Start Node assigns the selected node as the start node for the presentation.

■ Show Start Node locates the start node and displays it in the center of the document 
window.

■ Set Restart Node assigns the selected node as the restart node for the presentation. 

■ Show Restart Node locates the restart node and displays it in the center of the 
document window.

■ Menu Node makes any new nodes menu nodes.

■ Sequence Node makes any new nodes sequence nodes.

■ Arrange Nodes redraws and arranges the nodes and paths, so that the document is 
more readable.

Path Menu
The Path menu provides the following commands:

■ Show Paths sets which paths are displayed in the document window.

■ Color changes the color of the selected node and its associated paths.

■ Align Vertices displays a cascading menu that allows you to select an alignment for 
the selected path vertices.

■ Add Vertex adds a vertex to the selected path at its midpoint.

■ Show Origin displays the node where the selected path starts.

■ Show Destination displays the node where the selected path ends.

Script Menu
The Script menu provides the following commands:

■ Set Startup Image sets the startup image for the document.

■ Show Startup Image displays the startup image in the center of the document 
window.

■ Copy Directory to Photo CD allows you to select a directory to be copied onto the 
final Photo CD Portfolio disc.

■ Preview Presentation allows you to the view the presentation as it would play on a 
KODAK Photo CD player.
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■ Verify checks your document for errors before building the script.

■ Verify Next continues verification of the current document.

■ Build Script builds the document script used to create the Photo CD Portfolio disc. 

Window Menu
The Window menu provides the following commands: 

■ Toolbar displays or hides the toolbar.

■ Status Bar displays or hides the status bar.

■ Cascade arranges and resizes the windows in the Arrange-It software application 
window in an overlapping pattern.

■ Tile arranges and resizes the windows side by side, so that all windows are visible.

■ Arrange Icons organizes the icons of minimized documents and collections along 
the lower edge of the application window.

■ 1 [filename], 2 [filename] lists all open windows. The active window title is 
preceded by a checkmark.

Help Menu
The Help menu provides the following commands:

■ Contents opens the Help table of contents window. Press F1 at any time to open the 
Help contents window.

■ About Arrange-It displays a screen showing Arrange-It software copyright 
information and version number.

Toolbar
The toolbar at the top of the application window contains the tools used to build and edit 
an Arrange-It software document. Each tool is represented by a distinctive icon. To 
activate a command, click its icon.

New

Creates a new document or collection.
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Open

Save

Cut

Copy

Paste

Menu Node

Sequence Node

View All Nodes

Opens an existing document or collection.

Saves changes made to the current document.

Removes the selected item and places it on the Clipboard.

Makes a copy of the selected item and places it on the Clipboard.

Inserts the contents of the Clipboard into the active document.

Creates menu nodes when icon selected.

Creates sequence nodes when icon selected.

Redraws the document window, so that all nodes in the document are 
visible.
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Restore View

Preview Presentation

Arrow

Speaker

Mover Hand

Magnifying Glass (+)

Magnifying Glass (-)

Returns a document window back to previous magnification after a 
View All.

Previews the current presentation document.

Selects items in the collection or document windows.

Plays audio files in the collection window or in nodes in the document 
window.

Provides an alternative to scrolling with scroll bars. Press and hold down 
the mouse button and drag the mover hand in the document window. The 
document window scrolls according to how you drag the mover hand.

Zooms into the document window.

Zooms out of the document window.
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Collection Window
A collection window contains images and audio files from an open collection file.

Images and audio files are selected from the collection window and placed in the 
document window to create a presentation. Refer to Chapter 3, “Working With 
Collections,” for a description of collections and the collection window.

Document Window
The document window provides the work area where you construct a presentation. You 
can zoom the window in or out, depending on how much of the document you want to 
view and how much detail you need to see. You can use the scroll bars or mover hand 
to see items that are out of view. 

Collection window

Arrange-It software document 
window
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