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2: Using the Tutorial

 

This tutorial is designed to familiarize you with the fundamentals of 

 

KODAK

 

 Arrange-It 
Photo CD Portfolio Layout software. It is organized into seven easy-to-follow lessons. 
At the end of Lesson 7, you will have created a sample presentation that contains a menu 
with three themes. You can display and play the presentation from beginning to end, or 
you can select and display one or more of the themes in any order.

Each lesson is set up so that you can save your work and return to the tutorial later or 
proceed immediately to the next lesson. Each tutorial lesson deals with producing a 
different aspect or portion of your presentation.

 

Lesson 1 

 

starts the application, saves a new document to your hard disk, and opens an 
existing collection.

 

Lesson 2 

 

selects and previews two files—an image and an audio file—before importing 
them into the tutorial collection, and reviews editing features available for files in the 
collection window. 

 

Lesson 3 

 

introduces the concept of a menu node, creates a menu node in the document, 
adds two files to the menu node, creates two menu selection tabs and defines hot spots, 
and applies transitions and delays for the menu node files.

 

Lesson 4 

 

introduces the concept of sequence nodes and provides instructions for 
creating six sequence nodes.

 

Lesson 5

 

 creates paths to connect the menu node and the sequence nodes, and adds 
vertices to the paths so they are easier to follow.

 

Lesson 6 

 

reviews the verification process used to find errors in running your 
presentation, views a completed presentation to see how it plays, and previews your 
presentation using the player emulator.

 

Lesson 7 

 

covers the steps necessary to build a script and prepare your presentation to be 
placed on a 

 

KODAK

 

 Photo CD Portfolio disc.

 

IMPORTANT: This tutorial assumes that you have performed the default installation with all 
Installation Options selected. If you have installed the

 

 

 

application in a drive 
and directory other than the default, you must take this into account when you 
are opening and saving tutorial files.
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Lesson 1: Creating a New Document

 

In Lesson 1, you learn how to start the Arrange-It software application, save a new 
document to your hard disk, and open an existing collection.

If you have not already installed Arrange-It software, refer to Chapter 1, “Getting 
Started,” for installation instructions. All the files that you need to complete your sample 
presentation are installed with the software.

 

Starting the Arrange-It Software Application

 

To start Arrange-It software from the Program Manager:

 

1.

 

Double-click the 

 

KODAK

 

 Arrange-It Program Group.

 

2.

 

Double-click the 

 

KODAK

 

 Arrange-It software icon.

The Arrange-It software application window appears containing the Default 
Collection with a Null Image in the collection window. 

A new document window, “Untitled Document-1,” displays below the collection 
window. 

 

Saving the Document

 

You use the Save As command from the File menu to save the untitled Arrange-It 
software document to your hard disk. The Save As dialog box allows you to select the 
drive and directory where you want to save the sample presentation and to name it. You 
can also use the Save As command to make a duplicate copy of your presentation.

Arrange-It software 
application window

Collection window

Document window

Toolbar

Status bar
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To save the untitled Arrange-It software window:

 

1.

 

Click in the document window to select it.

 

2.

 

Choose Save As from the File menu.

The Save As dialog box appears.

 

3.

 

Double-click 

 

SMPDATA

 

 in the Directories list box, which is a subdirectory of the 

 

C:\ARRANGIT

 

 directory created when you installed the application.

 

4.

 

Delete the asterisk (*) in the File Name text box and type 

 

MYDOC.

 

5.

 

Click OK.

 

MYDOC.ARR

 

 is written to the 

 

SMPDATA

 

 directory, and the document window title 
bar changes to 

 

MYDOC.ARR

 

.

 

Opening an Existing Collection

 

You are now ready to open a collection of images and display it in the application 
window. The sample presentation uses images in 

 

TUTORIAL.COL

 

, which was installed 
with Arrange-It software. 

To open the 

 

TUTORIAL.COL 

 

collection:

 

1.

 

Choose Open from the Collections menu. 

The Open dialog box appears.

Save As dialog box

Open collection dialog 
box



 

2: Using the Tutorial

 

28

 

2.

 

Double-click 

 

SMPDATA

 

 in the Directories list box.

 

3.

 

Select 

 

TUTORIAL.COL

 

 from the File Name list box.

 

4.

 

Click OK. 

The 

 

TUTORIAL.COL

 

 collection window opens above the 

 

MYDOC.ARR

 

 document 
window.

 

Ending Lesson 1

 

If you do not plan to proceed to Lesson 2

 

1.

 

Click the 

 

MYDOC.ARR

 

 document window to make it the active window and choose 
Close from the File menu.

 

2.

 

Click the 

 

TUTORIAL.COL

 

 collection window to make it the active window and 
choose Close from the File menu.

 

Lesson 2: Importing Files Into the Collection

 

In Lesson 2, you will learn how to select and preview two files before importing them 
into 

 

TUTORIAL.COL

 

, and review editing features available for files in the collection 
window.

 

Setting Up for Lesson 2

 

If you just completed Lesson 1, your screen should display the 

 

TUTORIAL.COL

 

 collection 
and 

 

MYDOC.ARR

 

 document window. 

TUTORIAL.COL collection 
and MYDOC.ARR 
document windows

TUTORIAL.COL collection 
window

MYDOC.ARR document 
window
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If you stopped after Lesson 1, you need to start the Arrange-It software application and 
open 

 

MYDOC.ARR

 

 to continue with Lesson 2. 

To open 

 

MYDOC.ARR

 

:

 

1.

 

Choose Open from the File menu (

 

CTRL+O

 

).

 

2.

 

Double-click 

 

SMPDATA

 

 in the Directories list box.

 

3.

 

Select 

 

MYDOC.ARR

 

 from the File Name list box.

 

4.

 

Click OK.

The 

 

MYDOC.ARR

 

 document window opens.

Open the 

 

TUTORIAL.COL

 

 from the 

 

SMPDATA

 

 directory.

 

1.

 

Choose Open from the Collections menu.

 

2.

 

Double-click 

 

TUTORIAL.COL

 

 in the 

 

SMPDATA

 

 directory.

The 

 

TUTORIAL.COL

 

 collection window opens.

 

Selecting, Previewing, and Importing Files

 

For the sample presentation, you will need to import two files into 

 

TUTORIAL.COL

 

. 
These files are contained in the 

 

SMPDATA

 

 directory, which was installed on your hard 
disk with Arrange-It software.

To preview and import the files into 

 

TUTORIAL.COL

 

:

 

1.

 

Click the 

 

TUTORIAL.COL

 

 collection window to make it the active window.

 

2.

 

Choose Edit from the Collections menu.

The Edit Collection dialog box appears.

Edit Collection dialog box
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3.

 

Click Import.

The Edit Collection–Import dialog box appears.

 

4.

 

Select, play, and import the 

 

QUEST.WAV

 

 audio file.

 

❚

 

Select Windows Sound (*.wav) from the List Files of Type drop-down list box.

 

❚

 

Select the 

 

QUEST.WAV

 

 audio file from the File Name list box.

 

❚

 

Click Play to listen to the 

 

QUEST.WAV

 

 audio file. A message box containing the 
filename, type, time, and size is displayed while the sound plays. 

 

❚

 

Click OK to close the Edit Collection–Import dialog box.

The 

 

QUEST.WAV

 

 audio file is imported and appears in the Image/Audio bar in the 
Edit Collection dialog box. 

 

5.

 

Click Import.

 

6.

 

Select and preview the 

 

MENU.TIF

 

 Image Pac file.

 

❚

 

Select 

 

TIFF (*.TIF)

 

 from the List Files of Type drop-down list box.

Edit Collection–Import 
dialog box

Import sound file
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❚

 

Select 

 

MENU.TIF

 

 from the File Name list box.

 

❚

 

Click Preview to display the 

 

MENU.TIF

 

 in the Image Preview window.

 

❚

 

Click OK to close the Image Preview window. 

 

❚

 

Click OK to close the Edit Collection–Import dialog box. The 

 

MENU.TIF file 
appears in the Image/Audio bar in the Edit Collection dialog box.

Import TIFF file

Image Preview window 
showing MENU.TIF file

Edit Collection dialog 
box showing two files 
added to TUTORIAL.COL
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7. Click OK in the Edit Collection dialog box to save the changes to TUTORIAL.COL and 
return to the MYDOC.ARR document window.

The TUTORIAL.COL collection now shows QUEST.WAV and MENU.TIF as the last two 
frames in the collection window.

Editing Imported Files
You can also use the Edit Collection dialog box to edit images or audio files contained in 
the collection. For example, you can play audio files, remove images or audio files, 
assign new names to images and files, and reorder them in the collection. 

For the sample presentation, we will rotate one of the images in the collection window. 
Refer to “Editing a Collection” in Chapter 3 for information on other Arrange-It software 
editing features.

If you closed the Edit Collections dialog box, select the TUTORIAL.COL collection 
window and choose Edit from the Collections menu. 

To rotate an image:

1. Click MENU.TIF, which is the last frame in the collection window in the Edit 
Collection dialog box. 

NOTE: You can also use the Item drop-down list box in the Edit Collection dialog 
box to select the image.

A red frame surrounds the selected image. Notice that the Rotate button activates 
when you select the image.

2. Click Rotate.

MENU.TIF rotates 90 degrees clockwise.

3. Click Rotate a second time.

MENU.TIF rotates another 90 degrees clockwise.

4. Continue to click Rotate until MENU.TIF returns to its original orientation.

5. Click OK to return to the MYDOC.ARR document window.

TUTORIAL.COL with two files 
added
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Ending Lesson 2
If you do not plan to proceed to Lesson 2

1. Click the MYDOC.ARR document window to make it the active window.

2. Choose Close from the File menu.

The MYDOC.ARR document window closes. 

3. Click the TUTORIAL.COL collection window to make it the active window.

4. Choose Close from the File menu.

The TUTORIAL.COL collection window closes.

Lesson 3: Create a Menu Node
In Lesson 3, you will learn about a menu node, create a menu node in the document, add 
two files to the menu node, create two menu selection tabs and define hot spots, and 
apply transitions and delays for the menu node files.

Every presentation contains at least one menu node. The startup node in your document 
must be a menu node. A menu node can contain one image and one optional sound 
element. 

NOTE: The menu node image can only be a horizontal (landscape) image.

Menu node tabs, located on the right side of the node, are used to connect the menu node 
to sequence nodes. You will learn about sequence nodes in Lesson 4. Each menu node 
contains the following tabs:

■ Home tab (gray tab) is the place where other nodes connect to this node.

■ P (Previous) indicates which node displays when the Previous button is selected on 
the player remote control.

■ N (Next) indicates which node displays when the Next button is selected on the 
player remote control.

■ T (Time-out) indicates which node will display if the user does not make a menu 
selection in a predetermined amount of time.

■ E (Error) is the path to the node that displays if an error has been made when 
selecting a menu path.

■ 1 (Menu 1) is the path to the first menu selection.

■ M (Menu) is used to create more menu selection paths.
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Setting Up for Lesson 3
If you are continuing from Lesson 2, the TUTORIAL.COL collection and MYDOC.ARR 
document window should be displayed.

If you stopped after Lesson 2, you need to start the Arrange-It software application, 
open MYDOC.ARR and the TUTORIAL.COL collection to continue with Lesson 3. 

To open MYDOC.ARR:

1. Choose Open from the File menu (CTRL+O).

The Open dialog box appears.

2. Double-click SMPDATA in the Directories list box.

3. Select MYDOC.ARR from the File Name list box.

4. Click OK.

The MYDOC.ARR document window opens.

Open the TUTORIAL.COL from the SMPDATA directory.

1. Choose Open from the Collections menu.

2. Double-click TUTORIAL.COL in the SMPDATA directory.

The TUTORIAL.COL collection window opens.

Creating a Menu Node
To create a menu node in the document:

1. Click the Arrow button on the toolbar and then click the Menu Node button, also 
located on the toolbar.

2. Create the menu node.

❚ Click MENU.TIF in the collection window to select it. If necessary, use the scroll 
bar to scroll the images in the collection window until the file displays.

❚ Hold down the mouse button and drag the image from the collection window 
into the document window. As you drag the image, the arrow pointer becomes a 
menu node icon.
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❚ Release the mouse button. Arrange-It software creates a menu node in the 
document window containing the MENU.TIF image. The number 1 displays in the 
upper-left corner of the menu node.

3. Add the QUEST.WAV file to Menu Node 1.

❚ Click QUEST.WAV in the collection window to select it.

❚ Hold down the mouse button and drag the audio file from the collection window 
onto Menu Node 1.

❚ Release the mouse button. The sound file is added to the menu node and its name 
displays below the image.

❚ Click the Speaker button on the toolbar. Notice that the arrow changes to a 
speaker when you move it into the collection window or document window.

❚ Click Menu Node 1 to listen to the QUEST.WAV audio file.

4. Position Menu Node 1 in the document window.

❚ Click the Arrow button on the toolbar

❚ Click Menu Node 1 to select it.

❚ Hold down the mouse button and drag the menu node to the middle of the 
document window and as far left as possible.

❚ Release the mouse button.

Menu node containing 
MENU.TIF image

Home tab

Path tabs
Node name

Image

Menu node with 
optional audio file

Audio file
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Defining and Positioning Hot Spots
Since Photo CD Portfolio discs can also be viewed on CD-I or 3DO players, which do not 
have a numbered remote control, you need to create rectangular hot spots associated 
with each menu Item on MENU.TIF. When the final presentation is viewed on CD-I or 
3DO players, the menu Item is selected by positioning the trackball or joystick over the 
menu Item and then clicking inside the associated menu Item hot spot.

The sample presentation has three menu Items, which are already contained in 
MENU.TIF added to Menu Node 1. These menu Items are

1. Vacation Scenes

2. Entertainment

3. Education Scenes

Since Menu Node 1 contains only one menu selection tab, you will need to create two 
additional menu selection tabs and define the hot-spot frames for all three menu Items 
in MENU.TIF. 

To create menu selection tabs and define the hot-spot frames:

1. Click Menu Node 1 in the document window to select it.

2. Choose Edit from the Node menu.

The Edit Menu Node dialog box appears showing the Menu modification screen.

Arrange-It software includes a default hot-spot frame in the upper-left corner on the 
image. When you have multiple hot-spot frames, the active frame is highlighted.

Menu screen from the Edit 
Menu Node dialog box
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3. Create a hot-spot frame for MENU.TIF item, “1. Vacation Scenes.” 

❚ Click the arrow cursor in the center of the hot-spot frame. Hold down the mouse 
button and drag the hot-spot frame until it is centered over “1.” Release the 
mouse button.

❚ Click the lower-right corner of the hot-spot frame. Hold down the mouse button 
and drag the corner of the frame to the right until it encloses “1. Vacation Scenes.” 
Release the mouse button. 

The values in the Hotspot section of the Edit Menu Node dialog box update to 
indicate the dimensions of the hot-spot frame that you just created. 

You can enter specific dimensions in the Hotspot text boxes to fine tune the 
dimensions for the Top, Left, Height, and Width of each hot-spot frame. This is 
useful when lining up multiple menu Items.

4. Add a second menu selection tab on Menu Node 1 and create a hot-spot frame for 
MENU.TIF item, “2. Entertainment Scenes.”

This step uses the Add button in the Edit Menu Node dialog box to create a hot-spot 
frame, producing the same effect as clicking the M tab on a menu node.

Hot-spot frame 
positioned over “1.”

Hot-spot frame 
enclosing text of the 
first item in MENU.TIF
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❚ Click Add to create a second hot-spot frame on MENU.TIF. The arrow pointer 
disappears and a cross appears in the upper-left corner of the image.

❚ Move the cross to the upper left of “2.” Hold down the mouse button and drag 
the cross down and to the right to draw a new hot-spot frame. 

❚ Release the mouse button when the frame encloses the menu Item.

❚ Click the lower-right corner of the hot-spot frame. Hold down the mouse button, 
and drag the corner of the frame to make any size adjustments.

❚ Click the middle of the hot-spot frame. Hold down the mouse button and drag to 
adjust the position.

5. Add a third menu selection tab to Menu Node 1 and create a third hot-spot frame 
for MENU.TIF Item, “3. Education Scenes.”

❚ Click Add to display the cross in the upper-left corner of the image.

❚ Define the third hot-spot frame over the menu Item, “3. Education Scenes,” using 
the procedure described in Step 4.

Second hot-spot frame

Hot-spot frame 
enclosing text of the 
second Item in 
MENU.TIF

Completed hot spots
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6. Click OK in the Edit Menu Node dialog box to return to MYDOC.ARR.

7. Click anywhere in the document window to deselect Menu Node 1.

Menu Node 1 now contains three menu selection tabs.

Applying Transitions and Delays
A transition is the manner in which the image on the screen is replaced by the next 
image. Two examples of transitions are Cross Fade and Top to Bottom.

You can also control the amount of delay after an image is displayed on the screen or a 
sound file is played. For example, if there are two images in a sequence node and you 
want the first image to remain on-screen for 15 seconds, you set the delay to 15 seconds. 
If an image is followed by an audio file, you may want to set the delay to zero (0), so that 
the audio file plays immediately.

To apply the transition and delay for Menu Node 1:

1. Click Menu Node 1 in the document window to select it.

2. Choose Edit from the Node menu and click the Playback icon in the Edit Menu 
Node category list box.

Menu Item tab connectors

One menu 
Item tab

Three menu 
Item tabs

Playback modification 
screen from the Edit 
Menu Node dialog box
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3. Select Cross Fade from the Transition drop-down list box.

4. Click the Image icon in the Edit Menu Node category list box.

The Image modification screen displays in the Edit Node dialog box.

5. Select 0.5 seconds from the Delay drop-down list box.

6. Click OK to apply the transition and set the delay.

Ending Lesson 3
If you do not plan to proceed to Lesson 4, close MYDOC.ARR and the TUTORIAL.COL 
collection. Make sure you save the changes that you made to the document. 

If you do plan to proceed to Lesson 4, choose Save from the File menu (CTRL+S) to save 
any changes to the sample presentation, but do not close the MYDOC.ARR document 
window.

Transition drop-down list 
box

Image modification screen 
from the Edit Node dialog 
box

Delay drop-down list box
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Lesson 4: Create Sequence Nodes
In Lesson 4, you learn about sequence nodes and create six sequence nodes in the 
MYDOC.ARR document. 

Sequence nodes can hold any number of images and sound files. Unlike a menu node, 
sequence nodes do not contain menu selection tabs, but they do contain path tabs, which 
are located on the left side of the node. Each sequence node contains the following tabs:

■ Home tab (gray tab) is the place where other nodes connect to this node.

■ P (Previous) indicates which node displays when the Previous button is selected on 
the player remote control.

■ N (Next) indicates which node displays when the Next button is selected on the 
player remote control.

Setting Up for Lesson 4
If you just completed Lesson 3, your screen should display the MYDOC.ARR document 
window. 

If you stopped after Lesson 3, you need to open MYDOC.ARR and the TUTORIAL.COL 
collection located in the C:\ARRANGIT\SMPDATA directory to continue with Lesson 4. 
Refer to “Setting Up for Lesson 3”if you need to review complete instructions for 
opening MYDOC.ARR and the TUTORIAL.COL collection.

Creating Sequence Node 2
Since the first node in the sample presentation is Menu Node 1, the sequence nodes will 
begin with the number 2. Sequence Node 2 will contain two images from TUTORIAL.COL 
collection—the red flower (FLOWER.PCD) and the research scientists (SCIENCE.PCD). 

To create Sequence Node 2 in the document window:

1. Click the Arrow button on the toolbar and then the click Sequence Node button, also 
located on the toolbar.

2. Create the sequence node using FLOWER.PCD as the first image in the sequence 
node. 

❚ Click the image in the collection window to select it.

❚ Hold down the mouse button and drag FLOWER.PCD from the collection window 
into the document window.
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❚ Release the mouse button when the sequence node icon is in the document 
window.

Sequence Node 2 displays in the document window and contains the image of the 
red flower.

3. Add SCIENCE.PCD as the second image in Sequence Node 2.

❚ Click the image in the collection window to select it.

❚ Hold down the mouse button and drag the image from the collection window 
into the document window and to the right side of the sequence node.

❚ Release the mouse button when the sequence node icon becomes an insertion 
icon—a double-headed arrow.

Sequence Node 2 now contains the image of the research scientists positioned to the 
right of the red flower image.

As you noticed when you were dragging the SCIENCE.PCD image from the 
collection window to the sequence node, the sequence node icon became a double-
headed arrow or four inward-pointing arrows over the sequence node, depending 
on where you had the image within the sequence. These icons determine the 
placement of the image or audio file in the sequence node. 

❚ A double-headed arrow is an insertion icon. The image or audio file is inserted 
at the indicated position. 

Sequence Node 2 with 
one image

Sequence Node 2

Menu node

Minimize button

Scroll bar

Home tab

Path tabs

Sequence Node 2 
with two images
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❚ Four inward-pointing arrows constitute a replacement icon. The image or audio 
file that you are dragging from the collection window replaces the file at the 
indicated position.

4. Position Sequence Node 2 in the document window.

❚ Click Sequence Node 2 to select it.

❚ Hold down the mouse button and drag the sequence node into the document 
window. 

❚ Release the mouse button when you have positioned the sequence node as low 
as possible in the middle of the document window. MYDOC.ARR should now look 
like the following example.

Create Sequence Nodes 3 through 7
You will use the same procedure described in creating Sequence Node 2 to create the 
remaining sequence nodes and add images. 

When the step asks you to use the drag-and-drop method to create a sequence node or 
to add an image, you should:

1. Click the image in the collection window to select it.

2. Hold down the mouse button.

3. Drag the image from the collection window into the document window and 
position it as instructed in the step.

4. Release the mouse button at the location designated in the step.

You are now ready to create the remaining sequence nodes for the sample presentation. 

1. Create Sequence Node 3, which will contain one image—the zebra (ZEBRA.PCD).

MYDOC.ARR with Menu 
Node 1 and Sequence 
Node 2
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❚ Click the Sequence Node button on the toolbar.

❚ Click ZEBRA.PCD to select it.

❚ Use the drag-and-drop method to place the image in the document window and 
create Sequence Node 3. Release the mouse button when the sequence node icon 
appears in the document window.

❚ Click Sequence Node 3 to select it. Use the drag-and-drop method to position the 
sequence node in the lower right-hand corner of the document window and to 
the right of Sequence Node 2.

2. Create Sequence Node 4, which will contain two images—the man and child on the 
beach (BEACH.PCD) and the woman on the beach (WOMAN.PCD).

❚ Click BEACH.PCD to select it.

❚ Use the drag-and-drop method to place BEACH.PCD in the document window 
and create Sequence Node 4. Release the mouse button when the sequence node 
icon appears in the document window.

❚ Click WOMAN.PCD to select it. Use the drag-and-drop method to position the 
image to the right side of BEACH.PCD. Release the mouse button when the 
insertion icon appears. 

❚ Click Sequence Node 4 to select it. Use the drag-and-drop method to position the 
sequence node as high up as possible in the middle of the document window.

3. Create Sequence Node 5, which will contain one image—the baby in the sky 
(BABY.PCD). 

❚ Click BABY.PCD to select it. 

❚ Use the drag-and-drop method to place the image in the document and create 
Sequence Node 5. Release the mouse button when the sequence node icon 
appears in the document window.

❚ Click Sequence Node 5 to select. Use the drag-and-drop method to position the 
sequence node in the upper right-hand corner of the document window and to 
the right of Sequence Node 4.

4. Create Sequence Node 6, which will contain one image—the speedboat (BOAT.PCD). 

❚ Click BOAT.PCD to select it.

❚ Use the drag-and-drop method to place the image in the document and create 
Sequence Node 6. Release the mouse button when the sequence node icon 
appears in the document window.

❚ Click Sequence Node 6 to select it. Use the drag-and-drop method to position the 
sequence node in the middle of the document window and to the right of Menu 
Node 1.
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5. Create Sequence Node 7, which will contain two images—the roller coaster 
(COASTER.PCD) and the Manhattan skyline (SKYLINE.PCD). 

❚ Click COASTER.PCD to select it.

❚ Use the drag-and-drop method to place the image in the document and create 
Sequence Node 7. Release the mouse button when the sequence node icon 
appears in the document window.

❚ Click SKYLINE.PCD. Use the drag-and-drop method to position the image to the 
right side of the image of the roller coaster. Release the mouse button when the 
insertion icon appears.

❚ Click Sequence Node 7 to select it. Use the drag-and-drop method to position the 
sequence node in the middle of the screen and as far to the right of Sequence 
Node 6 as possible.

The MYDOC.ARR document window should now look like this example.

If your document does not have the sequence nodes positioned as shown in the 
example, you should reposition them at this time. 

Ending Lesson 4
If you do not plan to proceed with Lesson 5, close the TUTORIAL.COL collection and 
MYDOC.ARR. Make sure you save the changes that you made to the document.

If you plan to proceed to Lesson 5, save the changes made to this point.

MYDOC.ARR after creating 
Menu Node 1 and six 
sequence nodes
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Lesson 5: Connecting Nodes
In Lesson 5, you will create paths to connect the menu node and the six sequence nodes, 
and add vertices to the paths, so that they are easier to follow in the document.

Arrange-It software uses paths to visually describe the order in which nodes are 
displayed by a Photo CD player. Each node has a set of tabs along its side for making 
path connections. Paths always begin at a numbered or lettered tab and end at the top-
most gray tab, called the home tab. 

Setting Up for Lesson 5
If you are continuing from Lesson 4, you should have the TUTORIAL.COL collection and 
MYDOC.ARR document window displayed on your screen showing Menu Node 1 and 
the six sequence nodes.

If you stopped after Lesson 4, you need to open MYDOC.ARR and the TUTORIAL.COL 
collection located in the C:\ARRANGIT\SMPDATA directory to continue with Lesson 5. 
Refer to “Setting Up for Lesson 3”if you need to review complete instructions for 
opening MYDOC.ARR and the TUTORIAL.COL collection.

Creating Paths to Connect the Nodes
To create the paths between Menu Node 1 and the sequence nodes:

1. Click the Arrow button on the toolbar.

2. Create a path between the P tab on Menu Node 1 (Previous path) and Sequence 
Node 4.

❚ Click the P tab on Menu Node 1 to select it.

❚ Hold down the mouse button and drag the cursor across the document window 
toward the middle of Sequence Node 4. 

As you drag the cursor, a line displays indicating the connection between the P 
tab on Menu Node 1 and Sequence Node 4.
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❚ Release the mouse button when the line is over Sequence Node 4. The path line 
automatically snaps to the home tab. You have now created the Previous path.

3. Use the following table to create the remaining path connections.

Click Tab … From Node…
Hold Down Mouse Button 

and Drag to … To Create Path …

N Menu 1 Sequence 4 Next 

T Menu 1 Sequence 4 Time-out 

E Menu 1 Sequence 4 Error 

1 Menu 1 Sequence 4 Menu 1

2 Menu 1 Sequence 6 Menu 2 

3 Menu 1 Sequence 2 Menu 3 

P Sequence 4 Menu 1 Previous

N Sequence 4 Sequence 5 Next

P Sequence 5 Sequence 4 Previous

N Sequence 5 Menu 1 Next 

P Sequence 6 Menu 1 Previous

N Sequence 6 Sequence 7 Next

P Sequence 7 Sequence 6 Previous

N Sequence 7 Menu 1 Next 

P Sequence 2 Menu 1 Previous

N Sequence 2 Sequence 3 Next 

P Sequence 3 Sequence 2 Previous

N Sequence 3 Menu 1 Next 

Path connection for 
the P tab on Menu 
Node 1 and the home 
tab on Sequence 
Node 4
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The MYDOC.ARR document window should now look like the following example.

Adding a Vertex to a Path
As you can see from the path connections made between Menu Node 1 and the sequence 
nodes, crossing paths can quickly confuse the look of your presentation, making it 
difficult to read and understand the paths. You can add vertices to a path, which make 
it easier to follow the paths. A vertex is a small square located on a path that allows the 
path to bend. There is no limit to the number of vertices that you can add to a path.

You can add a vertex at the time you create the path or you can add a vertex to an 
existing path. Refer to “Adding Vertices” in Chapter 5 for instructions on creating a 
vertex on a path at the time that you create it.

To add vertices to the existing paths:

1. Create a vertex on the P tab path.

❚ Press and hold down the ALT key.

❚ Click the P tab path originating on Menu Node 1. A vertex forms at the point 
where you clicked on the path.

❚ Hold down the mouse button and drag the created vertex to the desired location.

MYDOC.ARR showing all path 
connections
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❚ Release the mouse button when the vertex is at the desired location.

2. Add a vertex to each of the path connections.

You can create your own vertices following the instructions in Step 1 or you can 
choose Arrange Nodes from the Node menu. For the sample presentation, we 
suggest that you choose Arrange Nodes from the Node menu to add the vertices.

3. Choose Save from the File menu (CTRL+S).

Ending Lesson 5
If you do not plan to proceed with Lesson 6, close TUTORIAL.COL and MYDOC.ARR. 
Make sure you save any changes that you made to the document.

Vertex on the path 
connecting P tab on 
Menu Node 1 and 
home tab on Sequence 
Node 4

MYADOC.ARR after using 
Arrange Nodes from 
Node menu



2: Using the Tutorial

50

Lesson 6: Verify and Preview Presentation
In Lesson 6, you will use the Arrange-It software verification process to find errors in 
running your presentation, view a completed presentation to see how your presentation 
should play, and preview your presentation using the player emulator.

Setting Up for Lesson 6
If you are continuing from Lesson 5, you should have the MYDOC.ARR document 
window displayed on your screen showing the path connections for Menu Node 1 and 
the six sequence nodes.

If you stopped after Lesson 5, you need to open MYDOC.ARR and the TUTORIAL.COL 
collection located in the C:\ARRANGIT\SMPDATA directory to continue with Lesson 6. 
Refer to “Setting Up for Lesson 3”if you need to review complete instructions for 
opening MYDOC.ARR and the TUTORIAL.COL collection.

Verify Presentation
Arrange-It software provides a verification process that helps you find errors in your 
presentation. The types of errors the verification process finds include:

■ Unconnected Paths—A node with one or more path connectors having no path. You 
may verify selected path types.

■ Nodes With No Exit—A node with no paths leaving the Previous tab, Next tab, or 
other tabs that you have created on the node. 

■ Orphaned Nodes—A node with no paths connecting to its home tab.

■ Valid Start Node—Assures that the selected start node is valid.

■ Sequences Without Images—Assures that sequence nodes contain at least one 
image. 

■ Null Backgrounds in Sequences—Assures there are no Null backgrounds in 
sequence nodes. 

■ Missing Source Files—As part of the build process, you copy the source files to a 
directory that is sent to the script processing system for final disc creation. Check 
this item to make sure you are not missing any files that you need to build the script.

■ Modified Source Files—Checks if any of the images or audio files have been 
changed. 
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■ Calculate Transfer Size—Calculates the amount of space needed to hold the files 
that you will transfer to a Photo CD disc.

■ Overlapping Hot Spots—Makes sure that there are no hot spots that overlap on the 
image display screen.

The verification process is lengthy. It may be easier to verify one or two items at a time. 
To verify MYDOC.ARR:

1. Insert the KODAK Arrange-It Photo CD Portfolio Layout Software with Photo Sampler II 
disc into your CD-ROM drive. This disc contains the source files that were shipped 
in the Arrange-It software package.

Since the verification process searches for all source files used in your presentation 
document, you need to be sure you have this disc in the CD-ROM drive.

2. Choose Verify from the Script menu. 

The Verify dialog box appears.

3. Check the parameters to be verified.

NOTE: You may not want to select the Missing Source Files check box until you 
build your script in Lesson 7.

4. Click OK in the Verify dialog box.

If one or more errors are discovered, a Verify Error message box displays showing 
the first error.

❚ Make note of the error that displays in the message box.

Verify dialog box

Verify Error message 
box
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❚ Click Skip to display the next error without modifying your document or OK to 
close the Verify Status message box.

5. Correct the error(s) in your presentation document.

6. Choose Verify Next from the Script menu.

The verification process rechecks the last error that you corrected and displays the 
next error in the Verify Error message box.

7. Correct all the errors in your presentation document.

8. Choose Save from the File menu (CTRL+S).

Viewing the Tutorial Document
Before previewing your own presentation, it might be helpful to view TUTORIAL.ARR, a 
completed presentation that was installed with Arrange-It software, and take notes on 
the sequence in which the presentation plays. Taking time to view this presentation will 
give you an opportunity to see what the final results of your work should look like when 
you play it. 

To view the TUTORIAL.ARR document:

1. Choose Open from the File menu (CTRL+O).

The Open dialog box appears.

2. Select the drive and directory where you installed Arrange-It software.

3. Select TUTORIAL.ARR from the SMPDATA directory.

4. Click OK.

Open dialog box
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TUTORIAL.ARR opens in the application window and the TUTORIAL.COL collection 
opens in the collection window. The document window should look like the 
MYDOC.ARR document that you created.

5. Click the TUTORIAL.ARR document window to make it the active window.

6. Choose Preview Presentation from the Script menu. 

The Remote Control and the Player window appear. Arrange-It software 
automatically begins the presentation in the Player window.

7. Click Close in the Remote Control to return to the TUTORIAL.ARR document. 

8. Choose Close from the File menu to close the TUTORIAL.ARR document window.

TUTORIAL.ARR document

Player Remote and 
Display window
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Preview Your Presentation
If you played the TUTORIAL.ARR document and made notes on the presentation 
sequence, you can use these notes to verify the sequences in your sample presentation. 
If you did not play the TUTORIAL.ARR document, it is recommended that you take notes 
on your newly created document (for example, the images or sounds contained in each 
node, their paths, and modifications) before starting the preview. 

As the player emulation runs for MYDOC.ARR, verify that the document plays as 
expected. If your presentation does not play as expected, make corrections to the 
presentation document after you finish running the preview.

To preview MYDOC.ARR:

1. Open MYDOC.ARR, if it is not already in the application window.

2. Click the MYDOC.ARR document window to make it the active window.

3. Choose Preview Presentation from the Script menu.

The Remote Control and the Player window appear. Arrange-It software 
automatically begins the presentation in the Player window at Menu Node 1.

4. Click the Remote Control buttons as appropriate.

❚ Play plays the images and sounds of the presentation in the order designated in 
the document.

❚ Prev replays the previous image in a sequence or advances to another node 
following the Previous path.

❚ Next advances to the next image in a sequence or advances to another node 
following the Next path.

❚ Pause temporarily stops the emulation. Click again to resume playing your 
presentation.

Player Remote and 
Display window
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❚ Stop halts the presentation and restarts at the beginning of the presentation.

❚ Number keys select a menu path when the Display window contains a menu 
node. Click Play or wait for a time-out.

❚ Go To advances to any desired node in the presentation.

5. Click Close to return to the MYDOC.ARR document window.

Ending Lesson 6
If you do not plan to proceed with Lesson 7, close MYDOC.ARR and the TUTORIAL.COL 
collection. Make sure you save any changes that you made to the document.

If you plan to proceed to Lesson 7, save any changes before continuing.

Lesson 7: Building a Script
In Lesson 7, you will review the steps necessary to build a script and prepare your 
presentation to place it on a KODAK Photo CD Portfolio disc. 

Setting Up for Lesson 7
If you are continuing from Lesson 6, you should have MYDOC.ARR and the 
TUTORIAL.COL collection displayed on your screen showing the path connections for 
Menu Node 1 and the six sequence nodes.

If you stopped after Lesson 6, you need to open MYDOC.ARR and the TUTORIAL.COL 
collection located in the C:\ARRANGIT\SMPDATA directory to continue with Lesson 7. 
Refer to “Setting Up for Lesson 3”if you need to review complete instructions for 
opening MYDOC.ARR and the TUTORIAL.COL collection.

Building the Script
When you finish creating your presentation document, the next step is to build the 
script. The build-script process automatically copies all the necessary files used in 
creating your document and uses these files to construct your final presentation. The 
build-script process produces a script file—MyDocument.script— in the sample 
presentation. These files will be transferred to the script processing system.

Before building a script, it is a good idea to run the verification process with all items 
selected to make sure any changes that you made to your presentation document do not 
result in script errors. 
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NOTE: If you elected to verify your document with the Missing Source Files check box 
deselected, select it now and recheck your document before building a script.

To build the script for MYDOC.ARR: 

1. Choose Build Script from the Script menu.

The Save To New Directory dialog box appears.

2. Create a new directory to be used for the script.

❚ Enter MYSCR in the Directory Name text box.

❚ Click OK. 

The Script File dialog box appears.

3. Enter MYDOC.SCR in the File Name text box in the Script File dialog box.

4. Click OK.

A progress indicator appears as the script directory is created.

NOTE: To interrupt the build-script process, click Stop in the progress indicator.

The build process may take a few minutes, particularly if your document contains 
large Photo CD images, BMP and TIFF images, or WAV audio files.

Save To New Directory 
dialog box

Script File dialog box
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Preparing Document for Placing on a Portfolio Disc
For the tutorial presentation that you created, we assume that you will not place your 
presentation document on a Photo CD Portfolio disc. Therefore, instructions in this 
section do not include specific directories and files that you select, but rather provide an 
overview of the procedure.

You need the following items that you used in creating your presentation document in 
order to have the presentation placed on a Photo CD Portfolio disc:

■ The directory that contains the script

■ All Photo CD disc(s) that contain source Photo CD images

■ All source BMP and TIFF images

■ All source WAV audio files

You use Copy Directory to Photo CD from the Script menu to include additional 
directories not involved with the creation of the actual presentation and its source files. 
The script will simply copy these directories onto the Photo CD Portfolio disc. 

You cannot select individual files when using Copy Directory to Photo CD. They must 
be selected and copied before building the script.

To include these additional directories in the script:

1. Choose Copy Directory to Photo CD from the Script menu.

The Copy Directory to Photo CD dialog box appears.

Copy Directory to 
Photo CD dialog box
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2. Click Add Directory.

The Select Directory dialog box appears.

3. Locate the directory that contains your presentation in the Directories list box.

4. Click Select to select the current directory.

The Select Directory dialog box closes and the name of the selected directory 
displays on the right side of the Copy Directory to Photo CD dialog box.

5. Repeat Steps 2 through 4 until you have indicated all the directories to be copied.

6. Display the total size of all files within a directory.

❚ Select the name of a directory from the list box.

❚ Click Calculate Directory Size. 

The size of the selected directory displays in the Total Size section of the Copy 
Directory to Photo CD dialog box.

7. Click OK.

Select Directory dialog 
box

Copy Directory to 
Photo CD dialog box 
with directory added
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Selecting Media Formats
The directory containing the files necessary to create a Photo CD Portfolio disc can be 
submitted on any combination of the following media:

■ IBM PC compatible formatted floppy disk (1.44 MB)

■ IBM PC compatible formatted removable Syquest cartridge (44 MB or 88 MB)

■ KODAK Photo CD Master discs

It is recommended that you contact your authorized KODAK Photo CD Portfolio service 
provider for further details on the best medium to use to deliver the script and other 
elements of your presentation for processing.

Locating a Photo CD Service Provider
Once the necessary items are assembled, simply take them to any authorized KODAK 
Photo CD Portfolio service provider. In a matter of days, you will be able to pick up your 
Photo CD Portfolio disc containing your presentation created with Arrange-It software, 
as well as your original documents. 

If you own KODAK Build-It Photo CD Portfolio Disc Production software, refer to the 
KODAK Build-It Software User’s Guide for script-processing information.

Refer to “Photofinishing Information” on the Information Card included in the 
Arrange-It software package for information on locating service providers in your area 
that offer a Photo CD system.

Your Photo CD Portfolio presentation can be viewed on any KODAK Photo CD player!
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