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5: Connecting With Paths

 

Arrange-It software uses paths to visually describe the order in which nodes in the 
presentation are displayed by a Photo CD player. Each node has a set of tabs along its 
left or right side for path connections. Paths always begin at a numbered or lettered tab 
and end at the top-most gray tab, called the home tab. A path can be undefined, 
connected to a different node, or pointed back to its node of origin. When a node is first 
created, its paths are undefined.

NOTE: Not all path tabs need to have a defined path. Be careful, however, not to create 
a situation where a node has no connected paths (an island node) or no paths 
connected to its home tab (an orphan node).

Menu node path tabs are located on the right side of the node. A menu node contains 
the following tabs:

 

■

 

Home tab

 

 (gray tab) is the place where other nodes connect to this node.

 

■

 

P

 

 

 

(Previous)

 

 indicates which node displays when the Previous button is selected on 
the player remote control.

 

■

 

N (Next)

 

 indicates which node displays when the Next button is selected on the 
player remote control.

 

■

 

T

 

 

 

(Time-out)

 

 indicates which node will display if the user does not make a menu 
selection in a predetermined amount of time.

 

■

 

E

 

 

 

(Error)

 

 is the path to the node that displays if an error has been made when 
selecting a menu path.

 

■

 

1 (Menu 1)

 

 is the path to the first menu selection.

 

■

 

M

 

 

 

(Menu)

 

 is used to create more menu selection paths.

Sequence node path tabs are located on the left side of the node. A sequence node 
contains only the home tab and the Previous and Next tabs.

 

Creating Paths

 

There are three ways to create paths between nodes. You can use the

 

■

 

Drag-and-drop method to create a path by dragging from the path tab of a node. 

 

■

 

Selection method to select a path destination point from the node of origin. 
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■

 

Path modification screen from the Edit Node dialog box to change the destination of 
paths associated with the selected nodes. Refer to Chapter 6, “Modifying Nodes,” 
for a discussion of this method for creating paths.

 

Using the Drag-and-Drop Method

 

To create a path using the drag-and-drop method:

 

1.

 

Move the arrow pointer to a path tab from the node of origin in the document 
window.

 

2.

 

Press and hold down the mouse button, and drag a path from the path tab to the 
center of the destination node.

 

3.

 

Release the mouse button when the cursor is over the destination node.

The path tab connects to the home tab of the destination node If you do not release 
the mouse button over a node, the path is undefined—it does not connect.

 

Using the Selection Method

 

To create a path using the selection method:

 

1.

 

Move the arrow pointer to a path tab from the node of origin.

Creating a path using the 
drag-and-drop method

Dragging the path

Successful path 
connection
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2.

 

Press and hold down the 

 

ALT 

 

key, and press and hold down the mouse button.

A list box appears showing with the numbers or names of the nodes in the 
document.

 

3.

 

Select the desired destination node from the list box.

 

4.

 

Release the mouse button and the 

 

ALT

 

 key.

The path connecting the node of origin and destination node appears.

 

Creating Menu Selection Paths

 

Every Arrange-It software document must contain at least one menu node. The startup 
node must be a menu node. Menu nodes can contain only horizontal (landscape) 
images. 

The menu node contains one or more menu selections from which a path to another 
node may be chosen. Menu selections are optional paths that can be added to the 
document. When the final presentation is viewed on a Photo CD player, the numbered 
buttons on the remote control are used to make these selections.

Photo CD Portfolio discs can also be viewed on 

 

CD-I

 

 and 

 

3DO

 

 players, which do not have 
a numbered remote control. For this reason, you need to create rectangular hot spots 
associated with each menu Item. When the final presentation is viewed on 

 

CD-I

 

 and 

 

3DO

 

 
players, the menu selection is made using the trackball or joystick to select the menu 
Item and then clicking inside the associated menu Item hot spot.

Menu nodes may have one or more numbered menu selection paths. The first menu 
selection path is automatically defined as path tab 1 for a menu node. The M path tab 
never has an associated path, since it is used to create additional menu selection paths. 

You can create numbered menu selection paths from the M path tab using either method 
described to create paths. Once a path is created from the M path tab, the node redraws 
in the document window, so that the menu selection path just created now originates 

Creating a path using the 
selection method

Node name list box
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from a numbered path tab and the M path tab moves to the bottom of the numbered 
menu path tabs.

New menu selection path tabs can be created without defining paths. To do this, simply 
click the M path tab. The menu node redraws and another numbered path tab is added 
to the menu node. Keep in mind that whenever you add a new menu tab, you also add 
a new hot spot to the menu node image. For example, if three numbered path tabs are 
displayed for a menu node, the menu image has three hot spots.

NOTE: You can also create and delete menu selection tabs using the Menu screen from 
the Edit Menu Node dialog box.

Multiple menu node paths allow each of the menu node selection path tabs to be linked 
to a specific group of nodes. In terms of the presentation, these selection tabs are user 
choices that determine what information is played next.

For example, the 

 

MYDOC.ARR

 

 uses three menu Items. When the 

 

MENU.TIF

 

 image is 
displayed during the presentation, the viewer can enter the number 1 using the 
Photo CD player remote control to view Vacation Scenes, the number 2 to view 
Entertainment Scenes, and the number 3 to view Education Scenes.

 

Defining Hot Spots

 

To define and position a hot spot for a menu Item:

 

1.

 

Click the Arrow button on the toolbar and click a menu node to select it.

 

2.

 

Choose Edit from the Node menu.

Menu Item tab connectors

One menu 
Item tab

Three menu 
Item tabs



 

5: Connecting With Paths

 

93

 

The Edit Menu Node dialog box displays the Menu modification screen. Hot-spot 
frames are initially located at the upper-left corner of the image. If there is more than 
one frame, the selected frame has a highlighted border.

 

3.

 

Use the drag-and-drop method to move a hot-spot frame over the first menu Item.

 

❚

 

Click the center of a hot-spot frame to select it.

 

❚

 

Hold down the mouse button and drag the hot-spot frame to the upper-left part 
of the menu Item in the image.

 

❚

 

Release the mouse button.

 

4.

 

Resize the hot-spot frame so that it encloses the first menu Item.

 

❚

 

Click Adjust to open the Adjust Hotspots dialog box.

 

❚

 

Move the arrow pointer to the lower-right corner of the hot-spot frame.

Menu screen from the 
Edit Menu Node dialog 
box

Single hot-spot frame

Adjust Hotspots 
dialog box
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❚

 

Press and hold down the mouse button, and drag the corner of the frame down 
and to the right until it encloses the desired area for the first menu Item.

 

❚

 

Release the mouse button.

 

❚

 

Click OK to close the Adjust Hotspots dialog box.

The values in the Hotspot section of the Menu modification screen update to 
indicate the dimensions (in pixels) of the hot spot that you just created. You can enter 
specific dimensions in the Hotspot text boxes to fine tune the dimensions for the 
Top, Left, Height, and Width of the hot spot. This is useful when lining up multiple 
menu Items.

To create a new hot-spot frame for the image displayed in the Menu modification screen:

 

1.

 

Click Add in the Edit Menu Node dialog box.

The arrow pointer changes to a cross and appears on the image.

 

2.

 

Move the cross to the upper-left corner where you want to begin to create a new hot-
spot frame.

 

3.

 

Press and hold down the mouse button. 

The cross changes to a double-headed arrow. 

 

4.

 

Drag the double-headed arrow down and to the right until it encloses the new menu 
Item.

 

5.

 

Release the mouse button to create a new hot-spot frame.

NOTE: Creating an additional hot-spot frame adds another numbered path tab to 
the menu node, producing the same effect as clicking on the M tab.

The values displayed in Menu Item # text box and the four values in the Hotspot section 
of the dialog box update according to the location and size of the new menu Item. To 

Three completed hot-spot 
frames centered over menu 
selection items
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select a different menu Item, click the Menu Item # drop-down list box, located in the 
upper-right corner of the Edit Menu Node dialog box, and select a menu node number.

You can create additional hot-spot frames by clicking Copy in the Edit Menu Node 
dialog box to make a copy of the selected frame. To delete a hot-spot frame, select a hot-
spot frame and click Delete.

 

Adding Vertices

 

As you begin to connect nodes in the document, crossing paths can quickly confuse the 
look of your presentation, making it difficult to read and understand. Arrange-It 
software lets you add vertices to a path, so that it is easier to follow the paths. 

A vertex is a small square in a path where it can bend. Adding vertices can make it easier 
to find the node of origin and destination nodes of the path. There is no limit to the 
number of vertices you can add to a path. You can add vertices as you create a new path 
or to an existing path.

 

Adding a Vertex When Creating a Path

 

To add a vertex while creating a path:

 

1.

 

Click a node tab to select it.

Adding vertices to a path

Paths between nodes

Paths between nodes 
with vertices added
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2.

 

Hold down the mouse button and drag the end of the path to a point approximately 
halfway between the node of origin and the destination node.

 

3.

 

Press the 

 

ALT 

 

key while holding down the mouse button and continue to drag the 
path to the destination node.

The path bends at the point where you pressed the 

 

ALT

 

 key.

 

4.

 

Release the mouse button over the destination node.

The path connects the node tab and the destination node with a vertex where you 
pressed the 

 

ALT

 

 key. 

You can use the drag-and-drop method to move the vertex to the position that you want.

 

Adding a Vertex to an Existing Path

 

Arrange-It software provides three ways to add vertices to existing paths in the 
document window. You can 

 

■

 

Use the 

 

ALT

 

 key

 

■

 

Choose Add Vertex from the Path menu

 

■

 

Choose Arrange Nodes from the Node menu

 

ALT Key

 

To add a vertex to a path using the 

 

ALT

 

 key:

 

1.

 

Press and hold down the 

 

ALT

 

 key. 

 

2.

 

Click a path to select it.

Adding vertex using the 
ALT key
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3.

 

Release the 

 

ALT

 

 key and the mouse button.

A vertex appears on the selected path at the point where you clicked.

To reposition the vertex:

 

1.

 

Click the vertex to select it.

 

2.

 

Hold down the mouse button and drag the vertex to the desired location in the 
document window.

 

3.

 

Release the mouse button.

 

Add Vertex Command

 

To add a vertex to a path using the Add Vertex command from the Path menu:

 

1.

 

Click a path in the document window to select it. You can 

 

SHIFT+CLICK

 

 multiple 
paths to select them.

The selected path appears as a broken line.

Vertex added using the 
ALT key

Adding vertex using Add 
Vertex command
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2.

 

Choose Add Vertex from the Path menu. 

A vertex is added at the midpoint of each path that you selected. 

 

Arrange Nodes

 

Arrange-It software provides an alternative to manually creating vertices on the paths 
or adding a vertex at the midpoint of the path. You can use Arrange Nodes from the 
Node menu to automatically redraw the nodes and paths, so that the entire document is 
more readable.

Vertex added at midpoint 
using Add Vertex 
command

Paths before and after using 
Arrange Nodes

Paths before using 
Arrange Nodes

Paths after using 
Arrange Nodes
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Aligning Vertices

 

Aligning vertices is another way to make your Arrange-It software document more 
organized and readable. To align vertices in the document window:

1. Click the first vertex that you want to align.

2. SHIFT+CLICK the remainder of the vertices to be aligned.

3. Choose Align Vertices from the Path menu.

4. Select how you want the vertices to be aligned from the cascading menu.

Left aligns along the left edge of the left-most vertex.
Top aligns along the top-most vertex.
Right aligns along the right-most vertex. 
Bottom aligns along bottom-most vertex.

Choose Undo from the Edit menu to return the vertices to their original locations.

Align Vertices cascading 
menu from the Path menu

Aligning Vertices

Aligned vertices

Random vertices
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Showing and Hiding Paths
Arrange-It software lets you hide selected paths, which is helpful when the document 
becomes crowded. Paths can be hidden and displayed as necessary.

To show or hide selected paths:

1. Choose Show Paths from the Path menu. 

The Show Paths dialog box appears showing the paths currently selected for display 
in the document window.

2. Click the check boxes to select or deselect the types of paths that you want to display 
in the document window.

3. Click OK.

The paths appear in the document window as you defined them. 

The number of the node for a hidden path displays next to path tabs that are 
connected by hidden paths.

Show Paths dialog box

Paths displayed in the 
document window
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Changing Path Color
Arrange-It software lets you color individual paths for the selected node. To change a 
path color:

1. Click a path to select it.

2. Choose Color from the Path menu.

The WINDOWS software Color dialog box appears.

3. Select a color from the Basic Colors or Custom Colors section.

4. Click OK or Cancel.

OK changes the selected path to the new path color.

Cancel leaves the path color unchanged.

Showing the Origin and Destination of a Path
Arrange-It software allows you to locate the origin and destination of any path in the 
document.To display the origin of a path:

1. Click a path in the document window to select it.

2. Choose Show Origin from the Path menu. 

The node of origin appears in the center of the document window.

WINDOWS software 
Color dialog box
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To display the destination of a path:

1. Click a path in the document window to select it.

2. Choose Show Destination from the Path menu. 

The destination node appears in the center of the document window.
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