Microsoft FrontPage Express の特長

FrontPage Express は、HTML (Hypertext Markup Language) の豊富な機能にすべて対応した Web ページ エディタです。FrontPage Express では、HTML の書式やレイアウトを実際に表示しながら Web ページを作成したり、書式を設定したりすることができます。

FrontPage Express は、フォルダのカスタマイズ ウィザードでも使われているため、フォルダの表示方法を簡単に変更することができます。フォルダのカスタマイズ ウィザードは、マイ コンピュータや Windows エクスプローラで [表示] メニューの [このフォルダのカスタマイズ] をクリックすると起動します。

FrontPage Express には、本格的な Web ページを簡単に作成するためのさまざまな機能が用意されています。たとえば、次のような機能があります。

  • ツール バーに用意されている HTML タグの一覧から目的のタグを挿入でき、タグを手作業で入力する必要はありません。

  • 文字列や段落を選び、ツール バーのボタンをクリックするだけで、書式や配置を設定できます。

  • 作成した画像や、クリップ アート集からイメージを挿入できます。ただし、FrontPage Express には、クリップ アート集は付属していません。

  • 自分のコンピュータやネットワーク上のファイルを開いたり、Web 発行ウィザードがインストールされている場合は、ページを Web サイトから直接開いたりすることができます。

  • 作成したページは、ファイルに保存するだけでなく、Web 発行ウィザードを使って Web サイトに直接保存することができます。

  • マーキー (スクロールする文字列) を追加できます。

FrontPage Express は、Microsoft FrontPage Editor をベースに設計されており、多くの機能を継承しています。FrontPage Express から FrontPage には簡単に移行でき、操作方法やページの作成手順を練習し直す必要はありません。FrontPage は、FrontPage Editor と FrontPage Explorer で構成され、さらに高度な機能が用意されています。


フォルダを Web ページとして表示する

Web ページを作るときと同じように、ハード ディスクのフォルダを操作できます。

コンピュータの中の項目を Web ページとして表示している場合は、フォルダのカスタマイズ ウィザードを使ってフォルダ ウィンドウの背景を自由に設定することができます。フォルダのカスタマイズ ウィザードは、マイ コンピュータや Windows エクスプローラで [表示] メニューの [このフォルダのカスタマイズ] をクリックして起動します。また、フォルダのカスタマイズ ウィザードで FrontPage Express を使うと、フォルダに表示する Web ページを作成できます。

フォルダを Web ページとして表示している場合は、FrontPage Express を使って Outlook Express などのコンポーネントへのリンクを追加したり、ActiveX コントロールやウォーターマークを挿入したり、フォントのスタイルとサイズを設定したりすることができます。この機能は、個人的な楽しみのために使うことも、共有フォルダで最新の業務情報を公開するために使うこともできます。どのような目的でも、ニーズに合った独自のフォルダを作ることができます。


FrontPage Express の高度な機能

FrontPage Express には、本格的なページを簡単に作るためのさまざまな機能が用意されています。

  • 背景色やウォーターマークを追加できます

  • WebBot コンポーネントを使うと、複雑なプログラムを記述しなくても高度な機能を追加できます。WebBot は、ページの製作者がサーバーにページを保存するときや、ユーザーがページを表示したときに実行される "動的オブジェクト" です。FrontPage Express には、タイム スタンプ、挿入、および検索の機能をページに追加する WebBot が用意されています。Microsoft FrontPage にアップグレードすると、フォームの処理、ナビゲーション バーなど、さまざまな種類の WebBot をすべて利用できます。

  • ActiveX コントロールを使ってページの機能を拡張できます

  • [HTML マークアップ] コマンドを使うと、新しく追加されたタグを挿入できます。

  • ページに挿入した HTML タグを直接表示して編集できます。FrontPage Express では、コンテンツと区別しやすいように、タグは色分けして表示されます。


FrontPage へのアップグレード

さらに高度な Web ページを作成したいと思うようになったら、FrontPage Express から Microsoft FrontPage に手軽に移行することができます。FrontPage Express は、FrontPage に含まれる FrontPage Editor をベースにして設計されているため、FrontPage に移行しても、使い方はすぐに習得できます。

FrontPage は、Web ページの製作者と Web サイトの管理者向けの総合パッケージです。企業など、Web ページの表示と作成に関するニーズがユーザーごとに大きく異なる場合は、FrontPage Express と FrontPage を使い分けると非常に効果的です。たとえば、基本的な表示機能と編集機能があれば十分というユーザーは FrontPage Express を使い、高度な表示機能と編集機能のほかに Web の管理機能が必要なユーザーは FrontPage を使うといった使い分けが考えられます。

FrontPage の高度な Web 製作環境は、次の 2 つのコンポーネントで実現されています。

  • FrontPage Editor は、HTML ドキュメントを作成、表示、および保存するためのコンポーネントです。FrontPage Editor には、さまざまなテンプレート、ウィザード、および WebBot コンポーネントが用意されているので、高度な Web ページを簡単に作成できます。FrontPage Editor は簡易ブラウザとしても機能するので、インターネットやイントラネットのサイトからページをインポートすることもできます。

  • FrontPage Explorer は、Web サイトを管理、表示、および操作するためのコンポーネントです。Web サイトの開発とテストを自分のコンピュータ上で行ってから、サイト全体を Web サーバーにコピーすることができます。また、FrontPage Explorer は個人用の Web サーバーとしても使用できるため、デスクトップから直接 Web サイトを実行し、イントラネットや World Wide Web で公開することができます。