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What’s in this package
The Fireworks package contains:

◆ A CD-ROM containing the Fireworks installer 
and the sample artwork.

◆ Using Fireworks, the manual you are now reading.

System requirements
Fireworks runs on either the Windows or Macintosh 
operating systems. Before you install Fireworks, you 
need the following equipment: 

Windows:

◆ Windows 95, Windows 98, or Windows NT 4 
(with Service Pack 3) or later 

◆ Intel Pentium 120 MHz processor required 
(Pentium II recommended) 32 MB of system 
RAM on Windows 95 or Windows 98 (40 MB or 
more recommended for Windows NT) 

◆ 60 MB of available hard disk space (100 MB or 
more recommended) 

◆ CD-ROM drive 

◆ Mouse or digitizing tablet 

◆ 640x480 resolution, 256-color monitor required 
(1024x768 resolution, millions of colors 
recommended) 

Macintosh:

◆ System 7.5.5 or higher 

◆ Adobe Type Manager 4 or higher to use Type 1 
fonts 

◆ Power Macintosh processor required (G3 
recommended) 

◆ 24MB of application RAM with virtual memory 
on (32 MB or more with virtual memory off 
recommended) 

◆ 60 MB of available hard disk space (100 MB or 
more recommended) 

◆ CD-ROM drive 

◆ Mouse or digitizing tablet 

◆ 640x480 resolution, 256-color monitor required 
(1024x768 resolution, millions of colors 
recommended) 
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Installing and starting 
Fireworks
Before installing Fireworks, make sure your computer 
meets the system requirements listed in “System 
requirements” on page 10. Read the ReadMe document 
on the Fireworks CD-ROM for late-breaking 
information.

To install and start Fireworks on Windows NT 4 or 
Windows 95 or 98:

1 Insert the Fireworks CD-ROM in your CD-ROM 
drive.

2 Follow the instructions that appear on screen.

The installer application prompts you to enter 
required information.

3 When Fireworks is installed, launch Fireworks 
from the Start menu.

Windows NT 4 and Windows 95 or 98 have four 
alternative ways to install Fireworks:

◆ Double-click the installation application Setup.exe.

◆ Click the Install button in the Add/Remove 
Programs module in the Control Panel and 
navigate to the Setup.exe application in the 
Fireworks folder.

◆ Use the Run command in the Start menu and 
navigate to the Setup.exe application in the 
Fireworks folder.

◆ Select the CD-ROM icon in the Windows 
Explorer or My Computer, right-click to display the 
menu, and choose AutoPlay.

Note: To disable AutoPlay, hold down the Shift key 
while inserting the Fireworks CD-ROM.

To install and start Fireworks on a Macintosh:

1 Disable virus-protection extensions and restart 
your computer.

2 Insert the Fireworks CD-ROM in your CD-
ROM drive.

3 Double-click to launch the Fireworks Installer.

4 Follow the instructions that appear on screen.

5 Double-click the Fireworks icon to launch 
Fireworks from the Finder.
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Uninstalling Fireworks
Use the uninstaller to ensure that all Fireworks files are 
removed from the computer. 

To uninstall Fireworks on Windows NT 4, 
Windows 95, or Windows 98: 

1 Choose Start > Settings > Control Panel. 

2 Double-click Add/Remove Programs. 

3 Select Macromedia Fireworks 2 in the list box. 
Click the Add/Remove button.

4 Follow the instructions that appear on screen.

The uninstaller removes all Fireworks 2 program 
files from your system. 

On Windows, manual uninstallation may fail to 
remove several DLLs and registry database entries. 

To uninstall Fireworks on the Macintosh:

1 Run the Fireworks 2 installer and choose Remove 
from the Options pop-up. 

2 Follow the instructions that appear on screen. 

The uninstaller removes all Fireworks application 
files from your computer. 

On the Macintosh, manually removing Fireworks can 
fail to remove several preference files in the System 
folder. 

If you used Custom installation to install Fireworks in a 
different folder than the default location, you must 
specify the same location when uninstalling. 

Resources for learning 
Fireworks
Use these resources to learn Fireworks quickly:

◆ Fireworks Help

Fireworks Help, available whenever the Fireworks 
application is active, includes information on every 
Fireworks tool, panel, dialog box, and preference. 

◆ Fireworks Tutorials

Fireworks tutorials, available from the Help menu 
whenever the Fireworks application is active, 
contain step-by-step lessons for the most common 
Fireworks tasks, such as optimizing GIFs and 
JPEGs, and creating animations, image maps, and 
rollovers. 

◆ Fireworks Application

The Fireworks application contains many dialog 
boxes and ToolTips designed to assist you in using 
the program. ToolTips appear when your cursor 
pauses over a user interface element. Instructional 
dialog boxes appear when you attempt to use certain 
tools incorrectly. 

◆ Using Fireworks manual

The Using Fireworks manual includes information 
about basic and advanced Fireworks features. 

◆ www.macromedia.com

Macromedia’s award-winning web site contains 
Fireworks tutorials, sample art, and updates. 

◆ TechNotes

Navigate to http://www.macromedia.com/support/
Fireworks/ to search for frequently updated 
technical information on Fireworks. 

◆ Fireworks Discussion Group

For discussion on Fireworks topics with Fireworks 
users, technical support representatives, and the 
Fireworks development team, use a news group 
reader to go to news://forums.macromedia.com/
macromedia.fireworks. 
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What’s unique about 
Fireworks?
The premier production tool for creating web graphics, 
Fireworks has features that can save hours by 
simplifying the web-graphic creation workflow. 
Fireworks was created from the ground up specifically 
for the web. 

Live effects—Create drop shadows, bevels, glows, and 
embosses that are fully editable. Watch them update 
automatically! 

Vector tool flexibility with an organic bitmap 
look—Bézier paths and shapes have bitmap brush 
strokes and textured fills. Apply customizable Live 
Effects to objects. 

Total text control—Retain the precise text control of 
an illustration tool in an image-editing application. 
Control kerning, leading, text effects, alignment, and 
more. Apply Live Effects to text. Text is always editable, 
all the time. Change text after applying a Live Effect and 
watch the effect update automatically. 

Export Preview—Directly view the graphic after each 
adjustment of export settings without switching to your 
web browser. Compare up to four alternative files 
simultaneously to choose the best mix of quality and 
file-size reduction. 

Export optimization—Simplify file format, palette 
settings, dithering, and more to optimize your web 
graphics. Or, use the Export Wizard to optimize 
automatically. 

Batch processing—Choose export settings, and find 
and replace graphics and text when batch processing 
custom groups of images or an entire site. 

Image maps—Create editable, color-coded hotspots on 
an overlay above the image. Enter a URL link and 
browser status bar message for each hotspot. 

JavaScript rollovers—Automatically generate code for 
interactive rollovers and other graphics. 

Slice images—Slice images on export. Automatically 
generate HTML table code to reassemble images and 
add links. 

Compatibility with Macromedia Dreamweaver—
Export JavaScript rollovers that can be edited and 
changed in Dreamweaver. Or, export complex 
graphics as Dreamweaver library objects, easily 
placing and reusing navigation bars and complex 
rollovers. With Dreamweaver 2, launch Fireworks 
from within Dreamweaver to easily and quickly make 
changes to a graphic. 
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Welcome to Fireworks

What is Fireworks?

Fireworks creates the smallest, highest-quality JPEG 
and GIF graphics in the fewest number of steps. It is a 
total solution for creating and producing web graphics. 
Fireworks simplifies and streamlines the process of 
making web and screen graphics, while providing the 
ultimate in flexibility and editability. 

Fireworks also makes it easy to minimize file size 
without sacrificing quality, which results in faster web 
sites and higher satisfaction among web site visitors. 

Without Fireworks, for example, a web designer creates 
an image in a vector-based drawing program such as 
FreeHand, then imports the vector art into a bitmap 
graphics program to rasterize and apply filters. 

Continuing the creative process, the designer exports the 
graphic for import into a color palette-conversion utility 
and then optimizes the palette and image format for 
either web- or screen-based delivery. The designer might 
also use an animation tool or image map utility to create 
a dynamic image. 

To test the graphic, the designer must view it in a web 
browser application. Revising the graphic at this point 
may force the designer to start from the beginning and 
repeat every step. 

With Fireworks, the designer’s creativity is no longer 
complicated by switching from tool to tool, and 
valuable time is saved by avoiding repetitive procedures. 
Fireworks is a single tool that handles all the 
necessary steps. 

By creating editable paths with bitmap attributes, 
Fireworks ensures that your work is fully editable 
throughout every stage of the design process. Fireworks’ 
powerful export preview capabilities integrated with 
color palette and graphic formatting offer the designer 
control over exporting. 

Fireworks is a solution to the challenges faced by web 
designers. Accordingly, Fireworks is not optimal for 
creating or modifying images intended for traditional 
commercial printing. The Fireworks environment is 
based on the RGB color model, ideally suited for images 
rendered at screen, rather than print, resolutions. 

The advantages to using Fireworks over other tools 
include efficiency, convenience, and adaptability. With 
Fireworks, the designer is free to focus on design and 
creation without the distraction of switching from tool 
to tool. 

This efficient workflow is even more convenient with 
Fireworks’ incredible power over color palettes and file 
formats. Advanced preview capabilities allow the 
designer to see the effect of palette and color depth 
changes without the time-consuming step of viewing 
graphics in a browser. 

Amazingly, both text and objects in a Fireworks graphic 
are fully editable at any time. This means that graphics 
can be easily modified without recreating them. 
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Using the document 
window
Fireworks is both a vector graphics and a bitmap 
graphics application. Vector objects are composed of 
paths, and bitmap objects are composed of individual 
pixels. Fireworks combines the organic look of bitmap 
objects with the flexibility, control, and editability of 
Bézier paths. 

Launching Fireworks displays the document window, 
your interface to the illustration. A Fireworks canvas 
can be up to 6000 pixels wide by 6000 pixels tall. Move, 
resize, or hide the panels, Toolbox, and toolbars to 
customize your environment. 

Main toolbar (Windows only)

Modify toolbar 
(Windows only)

View Controls 
toolbar 
(Windows only)

VCR Animation 
Controls

Toolbox

Fireworks on Windows

Status bar
(Windows only)

Styles panel

Behaviors inspector

Object inspector Layers panel
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Toolbox 

The Toolbox contains 35 tools, some of which are 
contained in tool groups, as shown. To display a tool 
group, click and hold any tool with a triangle in the 
lower-right corner. 

Click an alternate tool to choose it from the tool group. 

Pressing letter keys switches quickly between tools. 
Press the letter key shown in the following chart to 
choose a tool. 

Fireworks documents contain four types of objects–
vector objects, which are path based; image objects, 
which are pixel-based; text; and web objects, which are 
special objects used to define areas of interactivity or 
image slicing. 

 

Press and hold a tool to reveal tool groups.

Use this tool To Activate by 
pressing

Pointer

Select and drag 
objects.

v
or

0 (zero)

Select 
Behind

Select objects behind 
other objects.

v
or

0 (zero)

Crop

Discard or add canvas 
area.

c

Export Area

Export a portion of a 
document.

j

Subselect

Select an object within 
a group or points on a 
path.

a or 1

Marquee

Select a rectangular 
pixel area in image edit 
mode.

m

Ellipse 
Marquee

Select an elliptical pixel 
area in image edit 
mode.

m

Lasso

Select a freeform pixel 
area in image edit 
mode.

l

Polygon 
Lasso

Select a polygonal pixel 
area in image edit 
mode.

l
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Magic Wand

Select pixel areas of 
similar color in image 
edit mode.

w

Hand

Pan the view of the 
document.

spacebar
or
h

Magnify

Change view 
magnification (zoom in 
or zoom out).

z

Line

Draw straight lines. n

Pen

Draw paths by 
anchoring points.

p

Rectangle

Draw rectangles, 
rounded rectangles, 
and squares.

r

Ellipse

Draw ellipses and 
circles.

r

Polygon

Draw polygons and 
stars.

g

Text

Create text blocks. t

Pencil

Draw one-pixel pencil 
strokes.

y

Use this tool To Activate by 
pressing

Brush

Draw brush strokes 
using Stroke panel 
settings.

b

Redraw Path

Redraw portions of a 
selected path.

b

Scale

Resize and rotate 
objects.

q

Skew

Slant and rotate 
objects, and change 
perspective.

q

Distort

Distort and rotate 
objects.

q

Freeform

Pull a path segment or 
push a path segment 
using a resizable 
cursor.

f

Reshape 
Area

Reshape a selected 
path within the area of 
the resizable cursor.

f

Path 
Scrubber (+)

Increase stroke 
characteristics 
controlled by pressure 
or speed.

u

Path 
Scrubber (–)

Decrease stroke 
characteristics 
controlled by pressure 
or speed.

u

Eyedropper

Sample a color and 
apply it to the active 
color well.

I

Use this tool To Activate by 
pressing
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Main toolbar (Windows only)

Paint Bucket

Fill objects with color, 
gradients, or patterns 
and adjust fills with 
Paint Bucket handles.

k

Eraser

Remove or replace 
portions of image 
objects and cut paths.

e

Rubber 
Stamp

Clone portions of an 
image object.

s

Rectangle 
Hotspot

Draw URL hotspots in 
the shape of rectangles 
or squares.

Circle 
Hotspot

Draw URL hotspots in 
the shape of circles.

Polygon 
Hotspot

Draw URL hotspots in 
the shape of irregular 
polygons.

Slice

Create rectangular slice 
objects.

Use this tool To Activate by 
pressing

Use To

New

Create a new document.

Open

 Open an existing document.

Save

 Save the active document.

Import

 Import a file.

Export

 Export a file.

Print

 Print the active document.

Undo

 Undo the last action.

Redo

 Redo the last action.

Cut

Cut selected objects to the Clipboard.

Copy

Copy selected objects to the 
Clipboard.
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ToolTips name or describe each button's function as 
well as other user-interface features throughout 
Fireworks. Pause the cursor over a button on a toolbar to 
display a small label, which disappears when you move 
the cursor away from the item.

Info panel

The Info panel provides feedback for selected objects, 
depending on object type and current action. Feedback 
includes the color of the pixel beneath the cursor in the 
current color model values, the position of the cursor, 
the location of the selected object's bounding box, and 
the selected object's dimensions. Choose Window > Info 
to show or hide the Info panel. 

The Info panel's Options pop-up contains settings for 
your document's color model and unit of measurement.

Paste

Paste the Clipboard’s contents into 
the active document.

Object 
Inspector

Open the Object inspector to view 
properties for the selected object.

Color Mixer

 Open the Color Mixer.

Stroke

 Open the Stroke panel.

Fill

 Open the Fill panel.

Layers

 Open the Layers panel.

Help

 Access Fireworks Help.

Use To

Options for choosing a color model 
and document unit of measurement

Color of pixel beneath cursor

Alpha opacity measured in 
increments from 0 to 255

Cursor position

Position of 
bounding box’s 
upper-left corner 
point

Dimensions of selected object
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Object inspector

Use the Object inspector to set characteristics such as 
opacity, blending mode, and placement of the brush 
stroke in relation to a path. The Object inspector 
contains status information for selected objects. The 
Object inspector operates in one of eight different 
modes, depending on the object type selected.

Components of the Object inspector

The different iterations of the Object inspector share 
common elements, as shown in the table below. These 
elements will become familiar as you work with various 
object types.

Use To When
selecting

Object Opacity Set the opacity of a 
single object

Anything 
except 
hotspot or 
slice objects.

Blending Mode Set an object's 
blending mode

Anything 
except 
hotspot or 
slice objects.

Stroke Settings Control the 
interaction of an 
object's stroke and 
fill

Any text or 
path object.

Transformation 
Method

Transform text as 
pixels or as paths

Text.

Group Type Define object 
group as mask or 
traditional group

Grouped 
objects.

Object type

Link to URL
Alt tag
Color well

Slice name

Clipping path 
setting

Define how the 
mask group 
appears

A mask 
group.

Export Settings Assign export 
presets to exported 
slice objects

Slice objects.

Link to URL Assign URLs Slice objects 
and hotspot 
objects.

Alt tag Assign alternative 
tag to be used 
when the image is 
unavailable

Slice objects 
and hotspot 
objects.

Link target Specify the 
window or frame 
in which the link is 
displayed

Slice objects 
and hotspot 
objects.

Color well Set color Slice objects 
and hotspot 
objects.

Hotspot shape Choose to change 
the shape of a 
hotspot object

Hotspot 
objects.

Auto-name Choose default or 
custom slice names

Slice objects.

Use To When
selecting
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Opacity and blending mode in detail

Use the Object inspector to set opacity and blending 
mode. Opacity and blending modes are important in 
the process of compositing. Compositing is the process 
of varying the transparency of two or more overlapping 
objects to create a variety of graphic elements. An 
opacity setting of 100 renders an object completely 
opaque. Conversely, an opacity setting of 0 renders an 
object completely transparent.

View Controls toolbar 

Use the View Controls toolbar to change document 
magnification and display mode. Click the Preview 
Page button to view document dimensions and pixel 
resolution. 

Note: On the Macintosh, the View controls are located 
at the lower-left corner of the document window. 

Using the toolbars

Fireworks on Windows has several toolbars: 

◆ Toolbox

◆ Main toolbar 

◆ Modify toolbar 

◆ View Controls toolbar 

Each toolbar is moveable and dockable. This section 
describes the default location and configuration of the 
toolbars. 

To show or hide the Toolbox, choose Window > Toolbox. 

On Macintosh, use the menu to duplicate functions 
found on the Windows Main toolbar and Modify 
toolbar. 

On Windows, choose Window > Toolbars and choose a 
toolbar to show or hide individual toolbars. 

Tool Options panel 

Options related to the active tool appear on the Tool 
Options panel. 

The Tool Options panel contains settings for all 
Fireworks tools. For example, the Pointer tool options, 
shown above, include Mouse Highlight and Preview 
Drag. Double-click a tool in the Toolbox to open and 
close the Tool Options panel.

To Do this

Set the opacity of a 
single object

Set the value using the opacity 
slider.

Apply the same 
opacity changes to 
multiple objects

Group the objects and alter 
the group's opacity using the 
opacity slider.

Return individual 
objects to the 
previous opacity 
before grouping

Ungroup the objects.

Set the blending 
mode of a single 
object

Choose from the blending 
mode pop-up.

Apply the same 
blending mode to 
multiple objects

Group the objects and alter 
the group's blending mode 
using the blending mode pop-
up.

Return individual 
objects to the 
previous blending 
mode before 
grouping

Ungroup the objects.

Options related to the active tool 
appear on the Tool Options panel.
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Swatches panel 

The Swatches panel shows Fireworks’ current color 
palette. Choose from this palette when designing 
graphics. Select a preset palette or import a palette using 
the Options pop-up. Use the Save Swatches command 
to save custom palettes for later import. Extract the color 
table from a GIF image using the Add Swatches 
command.

When moving the cursor over the Swatches panel, the 
cursor becomes an Eyedropper tool. Click a color to 
apply it automatically to selected objects and color wells. 

To choose a color, you need not access the Swatches 
panel or Color Mixer. Just click any color well in 
Fireworks, such as in the Toolbox, Fill panel, or Color 
Mixer, to access all the swatches in the current color 
palette. Then click to pick a color from the pop-up set of 
color swatches.

To Choose this from the 
Options pop-up

Add swatches to the 
panel

Add Swatches.

Replace all swatches with 
an external set

Replace Swatches.

Save swatches to an 
external set

Save Swatches.

Delete all swatches from 
the panel

Clear Swatches.

Change to Macintosh, 
Windows, Web 216, or 
Grayscale palette

A palette.

Sort the swatches by 
color

Sort by Color.

Use the custom color 
palette from the Export 
Preview

Current Export Palette.

Add a color to the 
palette by clicking 
in an empty area.

Use the Options 
pop-up to add, 
replace, delete, 
save, and sort 
swatches, and 
choose a color 
palette.

Pop-up color swatches

Eyedropper tool

Color picker tool
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Color Mixer 

Create colors using the Color Mixer, then apply colors 
to strokes, fills, effects, and text. Use the Options pop-up 
to select a color mode: RGB, Hexadecimal, CMY, HSB, 
or grayscale. The Color Mixer automatically responds to 
the type of object selected. For example, select an object 
with a fill and no stroke and the Color Mixer 
automatically selects the Fill color well. Conversely, 
select an object with a stroke and no fill and the Color 
Mixer automatically selects the Stroke color well.

To Do this

Apply color changes to 
the selected object’s 
brush stroke

Click the Stroke color 
well before choosing a 
new color.

Apply color changes to 
the selected object’s fill

Click the Fill color well 
before choosing a new 
color.

Apply color changes to an 
object having only a 
brush stroke

Choose a new color. The 
Stroke color well is 
selected automatically.

Apply color changes to an 
object having only a fill

Choose a new color. The 
Fill color well is selected 
automatically.

Apply color changes to 
the selected object’s 
effect 

Click the Effect color well 
in the Effect panel 
before choosing a new 
color.

Pick a color from the 
color bar.

Select stroke 
or Fill color.

Choose a color mode 
from the Options pop-
up.

Set color values.

Use default colors.

Swap stroke and fill colors.

Apply color to selected 
text 

Choose a new color. The 
Fill color well is selected 
automatically.

Switch color modes Choose the desired color 
mode from the Color 
Mixer Options pop-up.

Switch brush and fill color Click the Swap Colors 
button.

Revert to default colors Click the Default Colors 
button.

Define colors using the 
system color picker

Double-click color well.

Change color models in 
the color bar only

Point to the color bar 
and use Shift-click 
(Windows) or Option-
click (Macintosh).

To Do this
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Stroke panel 

Use the Stroke panel to design and modify strokes, as 
well as alter the appearance of paths that have already 
been drawn. Changing stroke settings affects selected 
paths and paths drawn after the settings are changed. 

To choose a color in the Stroke panel, you need not 
access the Swatches panel. Just click the pop-up to the 
right of the color well to access all the swatches in the 
current color palette. Then click to pick a color from the 
pop-up set of color swatches. 

Choose Edit Stroke from the Options pop-up to open 
the Edit Stroke dialog box. The Options, Shape, and 
Sensitivity panels within the Edit Stroke dialog box 
control current stroke attributes. Save, delete, and 
rename custom strokes using the Options pop-up. 

Click the show/hide triangle at the bottom of the Stroke 
panel to show and hide the Stroke preview. 

Checking Auto-Apply automatically updates selected 
path and text objects as you change stroke settings. If 
the preview is hidden, Auto-Apply is automatically 
turned on. If the preview is visible and Auto-Apply is 
turned off, click Apply to manually apply changes to 
selected paths.

Fill panel 

Use the Fill panel to control how objects are filled. 
Choose from the available fill categories, and then choose 
one of the many fill types from within each category. 

To choose a color in the Fill panel, you need not access 
the Swatches panel. Just click the pop-up to the right of 
the color well to access all the swatches in the current 
color palette. Then click to pick a color from the pop-up 
set of color swatches. 

Modify any fill by choosing a texture and intensity, fill 
color, anti-aliasing, feather, or hard edge. Check 
Transparent for a transparent fill texture and enter a 
texture amount greater than zero. Use the Fill Options 
pop-up to save, name, and delete Gradient fills. 

Click the show/hide triangle at the bottom of the Fill 
panel to show and hide the Fill preview. 

Check Auto-Apply to automatically update the fill of 
selected objects as you change fill settings. If the preview 
is hidden, Auto-Apply is automatically turned on. If the 
preview is visible and Auto-Apply is turned off, click 
Apply to manually apply fill changes to selected objects.

Save, edit, name, and 
delete strokes using the 
Options pop-up.

Choose a brush stroke.

Preview and apply 
the brush stroke.

Choose stroke-specific 
settings.

Save, edit, name, and 
delete gradients using 
the Options pop-up.

Choose a fill.

Preview and apply 
a fill.

Choose fill-specific 
settings.
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Effect panel 

Use the Effect panel to apply and modify Live Effects in 
your document. Effects applied using the Effect panel 
are maintained and updated when the affected object is 
altered. For example, if you apply an edge bevel to a 
rectangular object and then make the object circular, the 
beveled edge adjusts accordingly. Modify effects after 
applying them to an object by changing settings in the 
Effect panel. Effects that can be altered in this way are 
known as Live Effects. 

To choose a color in the Effect panel, you need not access 
the Swatches panel. Just click the pop-up to the right of 
the color well to access all the swatches in the current 
color palette. Then click to pick a color from the pop-up 
set of color swatches. 

Like the Stroke and Fill panels, the Effect panel has 
controls for selecting effect type and name. Use the 
Options pop-up to save, name, and delete custom 
effect settings. 

Choose a single effect from the Effect Category pop-up, 
or choose Multiple to apply more than one effect. 

Click the show/hide triangle at the bottom of the Effect 
panel to show and hide the Effect preview. 

Check Auto-Apply to automatically update the effect of 
selected objects as you change effect settings. If the 
preview is hidden, Auto-Apply is automatically turned 
on. If the preview is visible and Auto-Apply is turned 
off, click Apply to manually apply effect changes to 
selected objects.

Save, edit, name, and 
delete effects using 
the Options pop-up.

Choose an effect.

Preview and apply 
an effect.

Choose effect-
specific settings.
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Text Editor 

Use the Text Editor to create and edit text. Unlike text in 
many other applications, Fireworks text is always 
editable all the time. Edit text quickly and easily after 
custom effects have been applied.

To choose a color in the Text Editor, you need not access 
the Swatches panel. Just click the pop-up to the right of 
the color well to access all the swatches in the current 
color palette. Then click to pick a color from the pop-up 
set of color swatches. 

Open the Text Editor by clicking on a document with 
the Text tool, drawing a rectangular text block with the 
Text tool, double-clicking a text container, or selecting a 
text block and choosing Text > Editor. 

After closing the Text Editor, resize the text block by 
pulling or pushing handles. Move selected text blocks 
with the Pointer tool.

Check to anti-alias text.

Check to automatically kern text.

Add color to text.

Set orientation, alignment, and flow.

Set horizontal scaling and baseline shift.

Type or edit text.

Apply changes to the document 
without closing the text editor.

Adjust kerning and leading.
Set font, size, and style.

Apply an underline to text.
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Layers panel and Frames panel

Use the Layers and Frames panels to organize and 
animate your illustration. Layers divide an 
illustration into discrete planes, as though the 
components of the illustration were drawn on 
separate tracing paper overlays. 

Use the Layers panel to manage multilayered 
documents. The Options pop-up includes commands 
for creating, deleting, and renaming layers and 
commands for viewing and locking all layers. Choose 
Share Layer to share the selected layer across all frames 
in the document. Choose Single-Layer Editing to 
prevent accidental changes to layers other than the 
selected layer.

The Web Layer, reserved for web objects such as 
hotspots and slices, and cannot be renamed or deleted.

To show or hide individual layers, click the Show/Hide 
icon at the left of the layer name. When the icon is 
visible, the layer is also visible. Similarly, clicking the 
Lock/Unlock icon locks and unlocks individual layers. 
When a layer is locked, items on that layer may not be 
moved or deleted. 

To move a selected object to another layer, drag the 
“Selected Objects” icon. 

Use the Frame pop-up to quickly choose a different 
frame in your document without switching to the 
Frames panel. 

Navigate quickly to 
a specific frame.

Lock and unlock individual layers.

Change global view and lock 
settings; create, delete, and rename 
layers using the Options pop-up.

Show or hide individual layers.

Drag to rearrange 
layers. Double-click 
to rename a layer.
Drag to assign selected 
objects to another layer.

See “Icon buttons” 
on page 28.

Create, delete, and duplicate frames. 
Distribute items across frames. Copy 
selected items to specific frames.

Drag to rearrange 
frames.

Activate and 
control onion 
skinning.

See “Icon buttons” 
on page 28.

Share objects across frames.
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The Frames panel is the key to Fireworks animation 
and rollovers. Use the Frames panel and the Animation 
panel in the Export Preview to create animated GIFs. 
The Frames panel lists each frame of an animation and 
has controls for adding and deleting frames. Use the 
Options pop-up to add, delete, duplicate, and copy 
objects to specific frames.

Icon buttons

Use the buttons at the bottom right of the Layers and 
Frames panels as shortcuts to create, distribute, 
duplicate, or delete layers or frames. Select a frame or 
layer and then click a button, or drag and drop a frame 
or layer onto a button.

Find & Replace panel

Use Find & Replace to search for and replace various 
elements of a document, such as text, URLs, fonts, and 
colors. Find & Replace can search the current document 
or multiple files. Also, Fireworks can track changes 
made during a Find & Replace operation and store a log 
of the changes in the Project Log panel.

To Do this

Distribute a selected 
group of objects 
across frames

Click the Distribute button 
after selecting objects
or
Drag the square “Selected 
Objects” icon from the right 
column of the Layers or 
Frames panel to the Distribute 
button.

Distribute an entire 
layer's objects to 
specific frames

Drag a layer name to the 
Distribute button.

Create a new blank 
layer or frame

Click the New/Duplicate 
button.

Duplicate a current 
layer or frame

Drag the current layer or 
frame name to the New/ 
Duplicate button.

Delete

New/Duplicate

Distribute to Frames

Duplicate selected 
objects onto a new 
layer or frame

Drag the square “Selected 
Objects” icon from the right 
column of the Layers or 
Frames panel to the New/ 
Duplicate button.

Delete a current 
layer or frame

Click the Delete icon
or
Drag the current layer or 
frame name to the Delete 
button.

Delete currently 
selected objects

Drag the square “Selected 
Objects” icon from the right 
column of the Layers or 
Frames panel to the Delete 
button.

To Do this
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Project Log panel

The Project Log panel stores a log of changes made 
during Find & Replace operations when searching 
multiple files. 

Any documents changed during a Find & Replace are 
automatically recorded in the Project Log. Use the 
Project Log to navigate through selected files, export 
selected files using their last export settings, or select files 
to be batch processed. Add files to the Project Log to 
search them during a batch process or find and replace.

Behaviors inspector

Use the Behaviors inspector to add actions to specific 
user events, which are called behaviors. Behaviors are 
assigned to web objects, either hotspots or slices. A 
typical behavior is a pop-up status message assigned to 
a hotspot region so that the message is displayed 
(action) when the user points to it with the mouse 
cursor (event). 

The Behaviors inspector lists all behaviors assigned to 
the currently selected web object. Use the Behaviors 
inspector to edit or remove existing behaviors.

URL Manager

Add, load, and save URLs using the URL Manager.

URL stands for Uniform Resource Locator, which is an 
address of a specific page or file on the Internet. 
Fireworks can import URLs from any HTML file. 
Fireworks can read bookmark files saved with Netscape 
Navigator (typically stored in a file named 
Bookmarks.htm) or favorites files saved with Microsoft 
Internet Explorer. 

When a document is first opened, Fireworks adds all 
URLs in the document to the URL Manager's History 
pop-up. Assign URLs to selected objects using the 
History pop-up or by clicking a URL in the Library 
window. URLs in the History pop-up are not retained 
when the application is closed. To save the active 
History URL into the URL Library, click the Add to 
Library Button next to the History pop-up.
Getting Your Bearings 29



Working with the URL Manager

Styles panel

The Styles panel provides a library of built-in styles for 
text and graphics, which are viewed as large or small 
graphical icons. A style can include any attribute such as 
font, point size, color, fill, stroke, or effect. More than one 
style can be applied to any individual object. 

Use the Styles panel to create new styles, or edit or delete 
existing styles. Style libraries are stored in Fireworks 
Styles files. Import or export styles to or from a 
Fireworks document.

To Do this

Add a Fireworks 
file's URLs to the 
URL Manager

Open the file. All URLs are 
automatically added to the 
History pop-up. 

Determine what URL 
is assigned to an 
object

Select the object and note the 
URL’s name in the History 
field.

Assign a URL to an 
object

Select the object and choose a 
URL from the History pop-up
or
Select the object and click a 
URL in the Library window.

Add a URL to the 
URL Library

1.Enter or select the URL in 
the History pop-up.

2.Click the Add to Library 
button (+) to the right of 
the History pop-up

or
1.Choose Add URL from the 

Options pop-up
2.Enter a URL in the New URL 

dialog box
or
Choose Add History to Library 
from the Options pop-up

Edit URL in the URL 
Library

1.Select the URL in the URL 
Library.

2.Choose Edit URL from the 
Options pop-up.

Delete a URL in the 
URL Library

1.Select the URL in the URL 
Library.

2.Choose Delete URL from the 
Options pop-up.

Export current URL 
Library

1.Choose Export URLs from 
the Options pop-up.

2.Name the exported library 
and choose a destination.

Import a URL Library 1.Choose Import URLs from 
the Options pop-up.

2.Select desired library, HTML, 
or bookmark file.

Create a new URL 
Library

1.Choose New URL Library 
from the Options pop-up.

2.Name the new URL Library 
in the New URL Library 
dialog box.

or
Place an HTML bookmark file 
in the Fireworks 2/Settings/ 
URL Libraries folder.

To Do this
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Using panels

Fireworks panels float above the document. Place them 
anywhere on your screen. Click a tab to display a 
particular panel. View and hide all panels as described 
below. These tabbed panels can be moved, separated, or 
grouped by dragging their tabs. Use the Window menu 
to show and hide panels individually.

Fireworks includes the following tabbed panels:

◆ Tool Options panel

◆ Swatches panel 

◆ Color Mixer 

◆ Stroke panel 

◆ Fill panel 

◆ Effect panel 

◆ Layers panel 

◆ Frames panel

◆ Info panel

◆ Object inspector

◆ Find & Replace panel

◆ Project Log panel

◆ Behaviors inspector

◆ URL Manager

◆ Styles panel

To hide all panels:

Choose View > Hide Panels or press the Tab key. All 
currently open panels will be hidden.

To view hidden panels:

Choose View > Hide Panels to uncheck the Hide Panels 
option or press the Tab key. All hidden panels appear. 
Panels that were closed when the Hide Panels option 
was activated will remain hidden when Hide Panels is 
unchecked.

To group a panel with another panel:

To remove a panel:
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To return the panels to their default positions and reset 
application-level preferences, quit Fireworks, delete the 
preferences file named Fireworks Preferences located in 
the Fireworks folder, and relaunch Fireworks. 

Close any of these panels using the standard close box. 
Open or close them by choosing the appropriate 
command from the Window menu. 

Navigating and viewing the 
document

Setting document magnification

Fireworks magnification ranges from 6 percent to 
6400 percent.

 

To Do this

Enlarge a document 
view level

Choose the Magnify tool and 
click inside a document 
window
or
Choose an increment from the 
Magnification pop-up 
or
Choose View > Magnification 
and choose a magnification 
level.

Reduce a document 
view level

Choose the Magnify tool, hold 
down Alt (Windows) or Option 
(Macintosh) and click in a 
document
or
Choose an increment from the 
Magnification pop-up
or
Choose View > Magnification 
and choose a magnification 
level.

Choose a magnification 
setting from the pop-up.
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Magnification shortcuts

Shortcut menus

Click the right mouse button (Windows) or Control-
click (Macintosh) to display a shortcut menu 
containing a variety of commands. These menus vary 
according to which tool is chosen or which objects are 
selected. For example, one shortcut menu is available 
when selecting objects, while another shortcut menu is 
available when in image edit mode. Experiment with 
shortcut menus to speed your work.

Multiple document views

Use multiple views to see one document at two different 
view modes or magnifications simultaneously. 

Zoom to the highest 
magnification

Choose 6400% from the 
Magnification pop-up
or
Choose View > 
Magnification > 6400%
or
Press Control-6 (Windows) or 
Command-6 (Macintosh).

Zoom to the lowest 
magnification

Choose 6% from the 
Magnification pop-up
or
Choose View > 
Magnification > 6%.

Zoom in to view a 
specific area

Choose the Magnify tool and 
drag a selection area.

Zoom out Choose the Magnify tool and 
hold down Alt (Windows) or 
Option (Macintosh) and drag a 
selection area.

To Do this

To Press

Set view to 50% Control-5 (Windows) or 
Command-5 (Macintosh).

Set view to 100% Control-1 (Windows) or 
Command-1 (Macintosh).

Set view to 200% Control-2 (Windows) or 
Command-2 (Macintosh).

Set view to 400% Control-4 (Windows) or 
Command-4 (Macintosh).

Set view to 800% Control-8 (Windows) or 
Command-8 (Macintosh).

Set view to 3200% Control-3 (Windows) or 
Command-3 (Macintosh).

Set view to 6400% Control-6 (Windows) or 
Command-6 (Macintosh).

Zoom in Control-Spacebar (Windows) 
or Command-Spacebar 
(Macintosh)
or
Control-+ (Windows) or 
Command-+ (Macintosh).

Zoom out Control-[minus] (Windows) or 
Command-[minus] 
(Macintosh).
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To open a second document view:

1 Choose Window > New Window. 

2 Change the view and magnification of the new 
document window.

To close a document view window, click the window’s 
close box.

Optimizing document redraw

Choose one of two view modes from the View menu: 
Full Display or Draft Display. View modes affect a 
document’s on-screen representation, not its object data 
or output quality. 

When in Draft Display, switch to Full Display by 
choosing View > Full Display or by using the Display 
Mode pop-up on the View Controls toolbar 
(Windows) or in the lower-left corner of the document 
window (Macintosh). 

Choosing a display mode

Note: For easier editing, objects selected while in Draft 
Display mode display in full detail.

A Case Study: With and 
Without Fireworks
Before Fireworks, creating graphics for the web involved 
several applications, with each contributing to a portion 
of the task. Imagine that a web designer named Diana is 
asked by a client to create an artist’s palette to serve as a 
navigation graphic on a web page. The graphic will be 
used to link to other places on the client’s web site and 
must contain rich textures and effects to capture the 
viewer’s attention. Accordingly, the graphic must 
contain web-safe colors, text, textures, Live Effects, and 
hotspot links.

How Diana approaches this task without 
Fireworks:

1 Create a line drawing of an artist’s palette using 
an application, such as Macromedia FreeHand. 

2 Import the vector graphic into an image-editing 
application, such as Adobe Photoshop, to 
rasterize the graphic (convert the vectors to 
pixels). 

3 Apply third-party filter effects, such as bevels and 
drop shadows. 

4 Use a utility, such as Equilibrium DeBabelizer, to 
convert the image to a web-safe color palette in 
the proper graphics file format with an 
optimized size. 

5 Painstakingly add hotspot objects or animation 
using yet another application. 

6 Manually attach hyperlinks to the hotspots that 
link to the client’s web pages. 

7 View the results of this process in a web browser. 

Unfortunately, if the graphic has the slightest flaw, 
Diana must often begin again and redo every step to 
reproduce the graphic. In adjusting file-size 
optimization, Diana may need to retrace all or some of 
these steps. Even if the result is acceptable to the 
designer, client-driven changes such as text edits may 
result in repeating these steps many times until the final 
product is complete. 

Choose To

Full Display Display the document in all 
available colors with full 
detail.

Draft Display Display paths as one pixel 
wide with no fill. Each image 
object appears as an X-box.

Display controls 
(Windows)
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The Fireworks way

With Fireworks, Diana doesn’t need those other 
programs. She needs only Fireworks to produce this 
graphic from start to finish. Even better, modifications 
are easy, even after the graphic has been loaded onto the 
web site. 

How Diana uses Fireworks to make this job easy:

1 Open a new Fireworks document or import an 
existing document.

In our example, the vector framework is created in 
Fireworks using the intuitive vector tools. 
Fireworks imports all major web design file formats. 
Alternatively, Diana can create this vector art in 
FreeHand and open it directly in Fireworks. 

2 Apply strokes, fills, and effects.

Apply realistic strokes, fills, and effects using the 
Stroke, Fill, and Effect panels. Use the Effect panel to 
bevel the edge of the palette. In this example, Diana 
uses the vector tools to alter the number and 
location of the paint wells on the artist’s palette. She 
then applies a wood pattern fill and bevel effect to 
produce this image.

3 Reshape the object.

Alter the shape of the artist’s palette using the 
Reshape Area tool. 

Create vector art in Fireworks or open FreeHand 
documents directly.
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4 Add text.

Use Fireworks’ Text Editor to create and 
modify text.

5 Add a drop shadow to the text.

Apply a live drop shadow effect to the text using the 
Effect panel. Even though a drop shadow effect has 
been added, the text can still be modified.

6 Create the image map.

Use the hotspot tools in the Toolbox to add hotspot 
objects to the paint wells. These hotspots can link to 
any URL. Use the Object inspector to define map 
type, background URL, and alternate image 
descriptions. In our example, Diana selects the three 
labeled paint wells and chooses Insert > Hotspot. 
This command creates a hotspot object the same 
size, shape, and location as the original path. With 
each path selected, Diana defines the linked hotspot 
using the Object inspector. 
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7 Optimize the graphic upon export.

Exporting from Fireworks is a dynamic experience 
offering live feedback and total control over color 
depth, file format, palette selections, and animation. 
View up to four simultaneous live previews as you 
compare output options and see the results on 
screen before exporting.

8 Revise.

Diana's client loves the graphic but requests two 
changes. The client wants a different color on the 
Feedback paint well and wants the text’s drop 
shadow to be changed to an inner bevel. No 
problem! Diana opens the file in Fireworks, changes 
the color of the Feedback paint well, changes the 
drop shadow to an inner bevel, and exports again 
using the previous export settings.

Objects created in Fireworks are always editable, all 
the time.

Setting up your document
Consider your document’s design and final output 
requirements. Decide in advance which settings are best. 

Canvas size

Set the canvas size in the New Document dialog box to 
define the size of your document. Set canvas dimensions 
using pixels, inches, or centimeters. Alter the canvas size 
by choosing Modify > Document > Canvas Size or by 
using the Crop tool to crop the image.

Resolution

Resolution is defined in the New Document dialog box 
as either pixels per inch or pixels per centimeter. 
Consider the intended delivery medium when assigning 
resolution. For example, web graphics are usually saved 
at 72 pixels per inch.

Canvas color

The canvas is at the bottom layer of the document. 
Choose a white canvas, a transparent canvas, or a color 
canvas in the New Document dialog box. Change 
canvas color later by choosing Modify > Document > 
Canvas Color. To choose a color in the Canvas Color 
dialog box, click the pop-up to the right of the color 
well to access all the swatches in the current color 
palette. Then click to pick a color from the pop-up set 
of color swatches. 
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Number of undo steps

Choose File > Undo to reverse an action. Enter a value of 
up to 100 in the General > “Undo Steps” preference field. 
RAM requirements increase as the number of undo 
steps increases.

Note: Changes to the Undo preference do not take 
effect until Fireworks is restarted.

Unit of measurement

Define canvas size using pixels, inches, or centimeters in 
the New Document dialog box. The unit you choose 
appears in the Info panel. Change the unit using the 
Info panel's Options pop-up. 

Note: Regardless of the document’s unit of 
measurement, rulers always display in pixels.

Rulers

To show or hide rulers, choose View > Rulers. To set the 
ruler’s zero point, click and drag the zero-point marker 
from the upper-left corner of the document window to a 
new location. The zero point represents the intersection 
of the horizontal and vertical rulers. Double-click the 
zero point marker to reset the zero point to its 
default position.

Grid

The grid is a non-exporting background of horizontal 
and vertical lines. Choose View > Grid to display the 
grid. With View > Snap to Grid checked, dragging an 
object near a grid line causes that object to snap to 
the grid.

Set grid color.

Set horizontal 
grid spacing.
Set vertical 
grid spacing.
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Guides

Use guides, which are non-exporting guidelines, to 
precisely align and place objects. Choose View > Guides 
to show or hide guides.

To add a guide with the page rulers active, drag from 
either the horizontal or the vertical ruler. 

With View > Snap to Guides checked, objects snap 
when dragged near guides.

Editing guides

Choose View > Edit Guides to open the Guides 
dialog box.

Working with the grid and guides

Use To

Color Change the guides’ color.

Show Guides Show or hide guides.

Snap to 
Guides

Easily align objects to guides.

Lock Guides Prevent guides from moving.

Clear All Remove all ruler guides, not slice 
guides.

Slice Color Change the color of slice guides.

Show Slice 
Guides

Show or hide slice guides.

To Do this

Show or hide 
the grid

Choose View > Grid
or
Check Show Grid in the Grid 
dialog box.

Snap objects to 
the grid

Choose View > Snap to Grid
or
Check Snap to Grid in the 
Edit Grid dialog box.

Modify the grid Choose View > Grid Options 
> Edit Grid.

Show or hide rulers Choose View > Rulers.

Show or hide ruler 
guides

Choose View > Guides.

Show or hide slice 
guides

Choose View > Slice Guides.

Snap objects to 
guides

Choose View > Guide 
Options > Snap to Guides
or
Check Snap to Guides in the 
Edit Guides dialog box.

Edit guides Choose View > Guide 
Options > Edit Guides.

Lock guides Choose View > Guide 
Options > Lock Guides.
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Importing and Exporting
Fireworks can import a wide variety of vector and 
bitmap graphic formats and can export many bitmap 
graphic formats. Discussed in “Using Export Preview,” 
one of Fireworks’ greatest strengths is the ability to 
export many formats with extensive export preview 
capabilities. 

Export Preview provides immediate and dynamic 
feedback on the appearance and technical specifications 
of your graphics before exporting them. Use the Export 
Preview to experiment with export formats, color depth, 
and palette assignments and immediately see the results. 

Importing bitmap images

Fireworks imports BMP, GIF, JPEG, PICT 
(Macintosh), PNG, TIFF, xRes LRG, Targa, and 
Photoshop files. When imported, these files are fully 
editable using Fireworks bitmap editing tools and many 
Photoshop third-party plug-ins while in image edit 
mode. In addition to file name and location, the Import 
File dialog box shows file size, format, and a thumbnail 
preview, if available.

To import a bitmap graphic:

1 Choose File > Import or use Command-R 
(Macintosh) or Control-R (Windows). 

2 Choose the file to import.

3 Position the import cursor where the upper-left 
corner of the graphic is to appear.

4 Click the mouse button to place the graphic at its 
default size, or click and drag the import cursor 
to resize the image while importing.

Importing vector art

Fireworks imports vector graphics from Macromedia 
FreeHand 7 and 8, Adobe Illustrator 7 and 8, and 
uncompressed CorelDRAW 7 and 8. Imported paths 
are fully editable as if they were created in Fireworks. 

Fireworks offers several choices for importing multilayer 
documents, including layer-to-layer and layer-to-frame 
interpretations. See “Importing FreeHand, Illustrator, or 
CorelDRAW files” on page 89 for more information on 
importing vector graphics. 
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Exporting

Check to optimize
the exported graphic.

Choose a color
depth.

Choose a color
palette.

Check to dither
the image.

Choose a format.

Preview and
edit the colors
in the image’s

palette.

Choose the
type of

transparency.

Use frame 
controls to 
preview 
frames or play 
an animated 
GIF.

Use the Magnification 
tool to magnify the 
preview area.

Enter a maximum number of colors for the exported file.

Preview up to four previews.

Choose the 
number of 
views shown 
in the preview 
area.

Add to or
remove colors

from the
transparency.

Click to edit, save, or load a palette.

Click to launch the
Export Wizard.

Click to launch the
Export to Size

Wizard.
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To export a graphic:

1 Choose File > Export or use Control-Shift-R 
(Windows) or Command-Shift-R (Macintosh) to 
open the Export Preview.

2 Choose settings on the Options, File, and 
Animation panels.

3 View the effect of your settings in the preview 
area. The preview area can display up to four 
views simultaneously.

4 Click Next when you are ready to export the file 
with the current settings.

Export Wizard

Activate the Fireworks Export Wizard by choosing 
File > Export Wizard or by clicking the Export Wizard 
button in the Export Preview. The Export Wizard asks 
questions regarding your exported file’s intended use and 
suggests appropriate graphic formats. 

Export dialog box

Use the Export dialog box to choose the location and 
name of your exported files. Use the Export dialog box 
pop-ups to set slicing and HTML style options.

Document Properties

The Document Properties dialog box contains 
document-specific export settings. Change these settings 
to control slicing and image map options. Save your 
defaults using the Set Defaults button. 

Select the Shim type for 
HTML tables: none, 
Transparent Image, or 
Shims from Image.

Set Slice 
variables.

Set Image Map 
characteristics.
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Object mode and image edit 
mode
Computer graphics are one of two types: vector 
drawings created in an application such as Macromedia 
FreeHand, or bitmap images created in an application 
such as Adobe Photoshop.

Paths are the basic elements of vector graphics. 
Generated mathematically, a path has at least two points. 
Each point joins path segments and point handles 
control the shape and length of adjacent segments.

Pixels, the basic elements of bitmap graphics, are tiny 
squares that combine like the tiles of a mosaic to create 
an image. A bitmap image becomes more granulated as 
magnification reveals the individual pixels.

Fireworks blurs the distinction between vector graphics 
and bitmap image graphics. The path of a Fireworks 
object is an editable vector path. Yet it may also have a 
wide, textured stroke, an image fill, and an effect such as 
a drop shadow, bevel, or glow.

Magnifying any Fireworks object reveals pixels. Yet the 
object's pixels redraw in response to vector editing. Even 
effects—previously reserved for bitmap image 
applications—redraw after an object is edited.

Fireworks can edit both types of objects—vector objects 
and image objects. Some tools behave in different ways 
when editing either type of object.

Object mode is the default mode, where vector graphic 
creation and some image manipulation occurs. Image 
edit mode is where pixel editing occurs within an image 
object. A blue and black striped border outlines the 
current document, signifying that Fireworks is in image 
edit mode.

Fireworks has up to 100 undo steps, which are available 
in both image edit mode and object mode. The default 
number of Undo Steps in File > Preferences is 8. 

Fireworks drawing and editing tools

The table below describes each tool's basic function on 
each type of object. Some tools work only on one type of 
object, while others work on both. The characteristics of 
some tools change according to the type of object being 
edited.

Fireworks drawing and editing tools use smart cursors 
which show what tool is being used by the shape of the 
cursor. For example, the paintbrush tool cursor is a small 
paintbrush and the pencil tool cursor is a small pencil.

To replace these smart cursors with more precise 
crosshair cursors, check the File > Preferences > Editing > 
“Precise Cursors” preference. Press the Caps Lock 
button to temporarily enable precise cursors without 
using this preference.

Tools that behave exactly the same on both types of 
objects are not in this table.

This tool In object mode In image edit mode

Pointer Selects and moves 
paths on the 
screen.

Moves the image or 
moves pixels bound 
by a marquee. 
Double-click an 
image to edit its 
pixels.

Select 
Behind

Selects an object 
behind the selected 
object.

Moves the image or 
moves pixels bound 
by a marquee.

Crop Discards portions of 
a document.

Discards portions of 
a floating image 
document.

Sub-
selection

Selects and moves 
paths on screen, 
selects an object 
within a group or 
symbol, displays 
points on a path, 
and selects points.

Moves the image or 
moves pixels bound 
by a marquee.

Marquee 
or Ellipse 
Marquee

Activates image 
edit mode and 
selects or moves a 
rectangular or 
elliptical area of 
pixels.

Selects or moves a 
rectangular or 
elliptical area of 
pixels.
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Editing path objects
In object mode, paths and points are the basic elements 
of graphic design. Upon magnification, Fireworks path 
objects appear pixelated, as if painted in an image-editing 
application. However, at the root, path objects remain 
editable. Fireworks combines the editability of Bézier 
curves with the organic look of bitmap images.

Activities in object mode include:

◆ Drawing paths by dragging a basic shape tool or the 
Line tool, placing points with the Pen tool, or 
drawing paths with a pixel-wide stroke with the 
Pencil tool.

◆ Drawing paths with a wide variety of brush strokes, 
including textures and patterns with the Brush tool.

◆ Editing paths with the Freeform, Reshape Area, 
Eraser, Redraw Path, Path Scrubber, and other tools.

◆ Editing paths by moving points and adjusting 
Bézier handles.

◆ Editing paths by using a path operation, such as 
Union, Intersect, Punch, Crop, Simplify, Expand 
Stroke, and Inset Path.

◆ Typing and editing text.

◆ Importing, positioning, and applying effects to 
bitmap images.

◆ Importing and editing documents with vector 
graphics created in applications such as FreeHand.

Lasso or 
Polygon 
Lasso

Activates image 
edit mode and 
selects or moves a 
freeform area of 
pixels.

Selects or moves a 
freeform area of 
pixels.

Magic 
Wand

Activates image 
edit mode and 
selects or moves a 
area of similarly 
colored pixels.

Selects an area of 
similarly colored 
pixels.

Line and 
Basic 
Shapes

Draws objects as 
editable paths.

Paints pixel brush 
strokes on an image 
object.

Pen Draws objects as 
editable paths.

Leaves image edit 
mode and draws 
objects as editable 
paths.

Text Creates and edits 
text blocks and 
opens the Text 
Editor.

Leaves image edit 
mode, creates text 
blocks, and opens 
the Text Editor.

Pencil Draws one-pixel 
pencil strokes as 
freeform paths. 

Draws one-pixel 
pencil strokes as 
pixels.

Brush Draws brush 
strokes as paths.

Paints brush strokes 
as pixels.

Freeform Pulls or pushes a 
selected path to 
reshape it.

Leaves image edit 
mode.

Reshape 
Area

Reshapes the parts 
of a selected path 
that lie within the 
Reshape Area 
cursor area.

Leaves image edit 
mode.

Path 
Scrubber

Alters a path’s 
pressure and speed 
characteristics 
without changing 
its shape.

Leaves image edit 
mode.

Eraser
(Knife)

Cuts a selected 
path into separate 
paths.

Erases pixels from an 
image.

Rubber 
Stamp

Activates image 
edit mode and 
clones portions of 
an image object.

Clones portions of 
an image object.

This tool In object mode In image edit mode

A vector object with an 
editable path and points.

A bitmap image with a 
rectangular image 
bounding box.
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Brush strokes created in image edit mode may appear 
the same as those drawn in object mode, but they are 
strictly bitmap images. Conventional vector-editing 
techniques cannot edit these images. Working in image 
edit mode is similar to other image-editing applications. 

Open and closed paths

Open—An open path has a beginning point and an 
ending point that do not connect.

Closed—A closed path has a beginning point and an 
ending point that connect. 

A single path can overlap itself to create a loop that 
appears to enclose an area, but that is not a closed path. 
Only joined endpoints create a closed path. Either type 
of path can have a fill. Paths drawn with basic shape 
tools are closed paths.

To resume drawing an existing open path, use the Pen 
tool or the Redraw Path tool to click the ending point 
and continue the path.

Completing open and closed paths

To end an open path when using the Pen tool, double-
click the Pen tool at the ending point when a small 
arrow appears next to the cursor. To end an open 
path when using other drawing tools, release the 
mouse button.

To close a path with any drawing tool, return the cursor 
to the starting point of the path and click when a black 
square appears next to the cursor.

Drawing paths

Use the Pen tool to draw paths by plotting points, as in 
FreeHand, or use the Brush tool to paint paths, as in 
Photoshop. Either way, a brush stroke with a path and 
points is created when in object mode.

Displaying and selecting paths

All path objects in object mode are editable. The active 
tool and the status of the Hide Edges command 
determine which path and point information is 
displayed.

Displayed path and hidden points—Use the Pointer 
tool to drag a selection area around any part of one or 
more paths or click a path to select it.

Open path Closed path

When this square appears, 
release the mouse button to 
close the path.

Pen tool Brush tool

An object selected with the Pointer tool displays the path of the 
object without points.
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Displayed path and points—Choose the 
Subselection tool to automatically display the points on 
all selected paths. Use the Subselection tool to drag a 
selection area around one or more paths, displaying the 
path and points of all selected objects, or click a path to 
select it.

Hidden path and points—Choose View > 
Hide Edges to hide the paths and points of 
selected objects.

With Hide Edges checked, choosing the Subselection 
tool shows the points of selected objects without the 
path.

Note: With Hide Edges checked, look at the Status bar 
(Windows) or Object inspector to identify the currently 
selected object. Hide Edges also hides marquees in 
image edit mode.

To add more objects to a current selection, hold down 
Shift and select the additional objects. To select a path 
behind another path, use the Select Behind tool.

Editing points to reshape paths

Points are the framework for a vector path. The position 
and length of each point handle determine the shape 
and position of adjacent path segments.

To select an individual point, use the Subselection tool. 
Either click individual points or drag a selection area 
around one or more points. To move a point, drag it with 
the Subselection tool.

Fireworks has two point types:

Curve—Adjacent segments are curved. Clicking a curve 
point with the Pen tool converts it to a corner point, 
retracting the handles and straightening the adjacent 
segments. 

Corner—One or both adjacent segments are straight 
lines. Clicking a corner point and dragging away from it 
with the Pen tool converts it to a curve point, extending 
the handles and curving the adjacent segments.

To change the shape of an adjacent path segment, drag a 
point handle. The path preview shows the result of 
moving the handles. 

If handles are not visible, hold down Alt (Windows) or 
Options (Macintosh) and drag from a point using the 
Subselection tool so that the point handles appear.

An object selected with the Subselection tool displays the path of 
the object with points.

A selected object displays no path when Hide Edges is checked.

Select Behind tool

Subselection tool

Drag a point handle with the Subselection tool to edit 
adjacent path segments. 

Subselection cursor

Point handle

Path preview

Selected point

Path
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To bend only one adjacent segment, leaving the other 
segment unedited, hold down Alt (Windows) or 
Option (Macintosh) and drag a point handle from the 
point with the Subselection tool.

Using path operations to reshape paths

A powerful way to create complex paths is to use path 
operations to combine or alter paths.

To apply a path operation, first select objects. Then, 
choose one of the path operation commands from the 
Modify > Combine or Modify > Alter Path submenus.

Applying Union, Intersect, Punch, or Crop to objects 
may yield a composite path, which consists of individual 
paths joined together.

Note: Using a path operation removes all pressure and 
speed information from the affected paths.

Drawing in object mode

Draw paths in any of three ways:

◆ Use the Brush tool or Pencil tool to draw freeform 
paths.

◆ Use the Line, Rectangle, Ellipse, or Polygon tool to 
draw paths by dragging.

◆ Use the Pen tool to draw paths by plotting points.

Drawing by dragging

To draw using the Line tool or a basic shape tool, hold 
down the mouse button to start a path, drag to draw, 
and release the mouse button to complete the path.

Use To

Union Combine two or more closed paths 
into a single path enclosing the entire 
area of the original paths. Stroke and 
fill attributes of the back object are 
applied to the resulting path.

Intersect Create a path enclosing the area 
common to all selected, closed paths. 
Stroke and fill attributes of the back 
object are applied to the resulting 
path.

Punch Remove portions of selected, closed 
paths below the frontmost, closed 
path. Stroke and fill attributes remain 
unchanged.

Crop Remove portions of selected, closed 
paths outside the area of the 
frontmost, closed path. Stroke and fill 
attributes remain unchanged.

Simplify Remove points from a path while 
maintaining the same overall shape.

Expand 
Stroke

Convert the perimeter of the stroke of 
the selected path into a closed path.

Inset Path Expand or contract one or more closed 
paths by a specified amount.

Use Shift with the To constrain shapes to

Rectangle tool Squares.

Ellipse tool Circles.

Polygon tool Polygons oriented at 
increments of 45 degrees.

Line tool Lines at increments of 45 
degrees.

Pencil tool Horizontal or vertical lines.

Brush tool Horizontal or vertical lines.

Line tool Basic shape tools
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To draw a basic shape from a specific centerpoint, hold 
down Alt (Windows) or Option (Macintosh) and 
drag a drawing tool. The Polygon tool always draws 
from a centerpoint.

To both constrain a shape and draw from the 
centerpoint, hold down Shift-Alt (Windows) or Shift-
Option (Macintosh) while using a drawing tool.

The corner rounding percentage setting on the 
Rectangle Tool Options panel determines the 
curvature of the corners of rectangles drawn using the 
Rectangle tool. To assign a rounding percentage value 
to the corners of a rectangle, enter a value or use the 
slider on the Rectangle Tool Options panel before 
drawing the rectangle.

Use the Polygon tool to draw stars and other polygons. 
Use the Polygon Tool Options panel to set the number 
of sides, choose stars or shapes, and set angle acuteness.

Drawing by plotting points

To draw using the Pen tool:

1 Choose the Pen tool.

2 Click to plot corner points.

Press and hold the mouse button on a point, then 
drag to draw curves.

3 End the path.

◆ To create an open path, double-click the last 
point.

◆ To create a closed path, click the starting point 
when a solid square appears next to the cursor.

Note: Hold Shift while drawing with the Pencil tool or 
Brush tool to plot a path point by point.

An eight-point star 
with Angle = 10

A five-side 
polygon

A five-point star 
with Angle = 
Automatic

Draw paths with the Pen tool by plotting point by point. 

Pen cursor

Path preview

Point handle
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Reorienting the brush stroke

An object’s brush stroke is centered on the path by 
default, but options for placing the brush stroke 
completely inside or outside the path are available.

To move the brush stroke of one or more objects 
inside or outside the path:

1 Select one or more objects.

2 Choose Window > Object.

3 Choose a stroke placement button.

Normally, the stroke appears over the fill. To draw the fill 
on top of the stroke, check Draw Fill over Stroke in the 
Object inspector.

Checking Draw Fill over Stroke in the Object inspector 
fills selected objects all the way to the paths. With this 
option checked, opaque fills may obscure the brush 
strokes inside paths. Fills with a degree of transparency 
may tint or blend with brush strokes inside paths.

Editing in object mode

In addition to dragging point handles, several Fireworks 
tools edit paths in object mode.

Centered stroke

Stroke inside

Stroke outside
The Freeform, Reshape Area, Path Scrubber, Redraw Path, 
and Eraser (Knife) tools are the object mode editing tools. 
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Freeform tool—Push or pull any part of a selected 
path. Fireworks automatically adds, moves, or deletes 
points along the path as you edit it. On the Tool 
Options panel, enter a value in the Size field or use the 
pop-up slider to set the size of the push cursor and the 
length of the path segment the pull cursor affects.

Reshape Area tool—Pull the area of a selected path 
within the outer circle of the Reshape Area cursor. On 
the Tool Options panel, enter a value in the Size field or 
use the pop-up slider to set the size of the reshape area 
cursor. Enter a value in the Strength field or use the pop-
up slider to set the size of the inner circle of the reshape 
area cursor. The inner circle is the boundary of the tool 
at full strength. The area between the inner and outer 
circle reshapes paths at less than full strength.

Path Redraw tool—Redraw a segment of a selected 
path, retaining the brush, fill, and effect characteristics of 
the path.

Knife tool—Drag the knife cursor across a selected path 
to slice it into two or more paths.

See Fireworks Help for more information about 
these tools.

This cursor Indicates

The Freeform tool or the Reshape Area 
tool is in use. Move onto a selected 
path to activate the pull cursor. Click 
and hold away from a selected path to 
activate the push cursor or reshape 
cursor.

The Freeform tool is in use. The pull 
cursor is in position to pull the 
selected path. Click and hold the 
mouse and drag to reshape the path.

The Freeform tool is in use. The pull 
cursor is pulling the selected path. 
Release to redraw the path.

The Freeform tool is in use. The push 
cursor is active. Push the selected path 
with the adjustable circle to reshape 
the path.

The Reshape Area tool is in use and the 
cursor is active. Drag the area of the 
selected path under the cursor. The 
area from the inner circle to the outer 
circle represents reduced strength.

The Redraw Path tool is in use. The 
redraw path cursor is on a selected 
path to be redrawn.

The Path Scrubber tool is in use. The 
path scrubber plus cursor is active. 
Trace a path to change the path’s 
pressure- or speed-sensitive data.

The Path Scrubber tool is in use. The 
path scrubber minus cursor is active. 
Trace a path to change the path’s 
pressure- or speed-sensitive data.

The knife cursor is active. Drag the 
knife line across the selected path to 
cut it into two or more paths.

The Freeform tool pulls a path segment.

Specified length

The Freeform tool 
pushes a path segment.

The path redraws to 
reflect the push.

The Path Redraw tool redraws a path segment.
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Image edit mode basics
Switch to image edit mode to directly edit pixels in an 
image. Activities in image edit mode include:

◆ Editing imported images, such as GIFs, JPEGs, and 
PNGs.

◆ Editing pixels with the Pencil tool.

◆ Painting in color with the Brush tool.

◆ Erasing to transparency or to another color.

◆ Applying Xtra filters to pixel selections.

◆ Replicating image elements with the Rubber Stamp 
tool.

◆ Compositing images.

Switching to image edit mode

Although graphics created in object mode may have 
bitmap image characteristics, Fireworks also has a mode 
specifically for editing bitmap images pixel by pixel. In 
image edit mode, each pixel of a selected image object is 
editable.

Note: An image imported in object mode remains an 
image. A vector object can be converted to an image by 
choosing Modify > Merge Images.

When you enter image edit mode, a striped border 
appears around the entire document. You can draw or 
edit pixels anywhere within the document. When you 
leave image mode, the excess empty space is trimmed off 
of the edges of the image object you were editing.

To prevent the editable area of an image from expanding 
to fill the screen when the image is edited, choose File > 
Preferences > Editing and uncheck “Expand to Fill 
Document.”

To temporarily hide the striped border, choose View > 
Hide Edges. Once you leave image edit mode, Hide 
Edges is turned off. To force edges to remain visible until 
Hide Edges is chosen again, choose File > Preferences > 
Editing and uncheck Turn off “Hide Edges.” 

Leaving image edit mode

Return to object mode from image edit mode in any of 
five ways:

◆ Double-click an empty area of the document with 
any selection tool

◆ Click the Stop button on the Status bar.

◆ Choose Modify > Exit Image Edit.

◆ Press Control-Shift-D (Windows) or Command-
Shift-D (Macintosh).

◆ Press the Esc key.

To Do this

Edit an image 
object

Select the object, and then 
choose Modify > Image Object
or
Double-click the object using 
the Pointer tool
or
Use any of these tools on the 
image object: Marquee, Ellipse 
Marquee, Lasso, Polygon Lasso, 
Magic Wand, Paint Bucket, 
Eraser, or Rubber Stamp.

Create a new 
image object

Choose Insert > Empty Image.

A striped border outlines the canvas in image edit mode.

Stop buttonStop cursor
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Selecting an image object

Each bitmap image in Fireworks has a rectangular 
bounding box. This box is highlighted when an image is 
selected in object mode with View > Hide Edges 
unchecked. To switch to image edit mode, double-click a 
visible part of the image.

Fireworks 1 Background layer image

In Fireworks 1, the background layer is a permanent 
image stretching across the entire canvas under which 
no objects or layers can be placed. Fireworks 2 does not 
have a permanent background layer.

When opening Fireworks 1 documents in Fireworks 2, 
the Background layer from Fireworks 1 is converted into 
an image object and is placed as a shared layer on the 
bottom of the document.

For more information about layers, see “Using layers” on 
page 72.

Using marquees

In image edit mode, the primary selection tools are the 
Marquee and Ellipse Marquee tools, the Lasso and 
Polygon Lasso tools, and the Magic Wand tool.

Use these tools to highlight an area of pixels to edit, 
move, cut, or copy. Each draws a marquee that becomes 
a flickering dotted shape when complete. To remove a 
marquee, draw another one, choose Edit > Deselect, or 
exit image edit mode.

Note: Hold down Shift to draw square or circular 
marquees or to constrain lasso lines to 45-degree 
increments. Hold down Control (Windows) or Option 
(Macintosh) to draw from the centerpoint.

For more information about the Marquee and Lasso 
tools, see Fireworks Help.

Marquee tools Lasso tools

Use this tool To

Marquee Highlight a rectangular area of 
pixels.

Elliptical 
Marquee

Highlight an elliptical area of 
pixels.

Lasso Highlight a freeform area of pixels.

Polygon Lasso Highlight an area of pixels bound 
by a polygon.

Magic Wand Highlight an area of pixels of 
similar color.

An object in image edit mode with a circle marquee
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Trimming the canvas

Once an image is edited in image edit mode, its size is 
automatically trimmed to a rectangular shape in the size 
of the used pixels, removing transparent space around 
the image. Use Modify > Document > Trim Canvas to 
remove excess pixels from around the edge of the 
document.

◆ The canvas is cropped to the outermost edge of all 
pixels in the document.

◆ If multiple frames exist in the document, Trim 
Canvas crops to include all objects in all frames, not 
just the current frame.

Converting an object to an image

Choose Modify > Merge Images, which converts selected 
objects into a single image object. A path-to-image 
conversion is irreversible, except when choosing Edit > 
Undo is still an option.

Using Xtras

The Xtras menu has effects that are not reversible. Once 
these effects are applied to a vector object, the object is no 
longer editable as paths and becomes a floating image 
object. Fireworks Xtras include Blur, Invert, and 
Sharpen.

Photoshop plug-ins also work in Fireworks. Copy 
Photoshop plug-ins into the Fireworks Xtras folder to 
add them to the Xtras menu. Alternatively, use the 
Preferences dialog box to target an additional plug-in 
folder.

For more information about Xtras, see Fireworks Help.

Transforming and distorting objects

Use the Transform tools or menu items to scale, rotate, 
distort, or skew an object, a group of objects, or a pixel 
selection area.

Choosing any Transform tool or menu item displays the 
transform handles. The handles frame the entirety of 
selected objects. In image edit mode, the transform 
handles frame the pixel selection.

Drag any transform handle to edit the selected objects 
interactively. The cursor changes to indicate the available 
activity.

When dragging a transform handle in transform mode 
hold down Alt (Windows) or Option (Macintosh)to 
scale objects bi-directionally.

Transform tools

Original object

Rotated

Scaled

Skewed Distorted

Center point

Transformation handles
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When moving the cursor beyond the handles in 
transform mode to rotate selected objects interactively:

◆ Hold down Shift to constrain rotation.

◆ Drag the round centerpoint away from the center of 
the handles to relocate the axis of rotation.

When dragging a transform handle in distort mode:

◆ Hold down Shift to constrain handle movement to 
45-degree angles.

◆ Hold down Control (Windows) or Command 
(Macintosh) to achieve the illusion of perspective 
(corner handles only).

◆ Hold down Alt (Windows) or Option 
(Macintosh) to distort the object symmetrically.

When moving the cursor beyond the handles in distort 
mode to skew the object, hold down Alt (Windows) or 
Option (Macintosh) to skew the object relative to the 
centerpoint.

To move the centerpoint back to the center of the 
transform handles, double-click the centerpoint.

Numeric transformations

To scale or rotate selected objects, images, and pixel 
selections by specific measurements, choose Modify > 
Transform > Numeric Transform to open the Numeric 
Transform dialog box. Select the type of transformation 
to perform on the current selection from the pop-up, 
and input numeric values to transform the selection.

Check Constrain Proportions when scaling or resizing 
to keep the horizontal and vertical size of the selection 
proportional when transforming.

Check Scale Attributes to transform the fill, stroke, and 
effect of the object along with the object. If Scale 
Attributes is unchecked, the stroke, fill, and effect on the 
object do not increase in size; only the path is scaled.

Using color
Use the Color Mixer and the Swatches panel to create or 
choose colors for brush strokes, fills, and effects. 

Color Mixer

Choose a color model.

Create a color.

Pick a color.

Click to apply a color to the fill color well.

Click to apply a color to the brush color well.

Click to restore default brush and fill colors.

Click to switch brush and fill colors.

Swatches panel

Add, replace, save, clear, 
or sort swatches, or 
choose a palette.

Choose a swatch.

Click to add the active 
swatch to the palette.
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Using the Color Mixer

By default, the Color Mixer identifies colors as 
Hexadecimal RGB, displaying a color’s values of red (R), 
green (G), and blue (B) color components. RGB values 
are calculated based on a range from 00 to FF.

To create a color in the Color Mixer:

1 Choose Window > Color Mixer, if necessary, to 
display the Color Mixer.

2 Click either the stroke color well or fill color well, 
or display the Stroke, Fill, or Effect panel, to 
choose the destination for the new color.

3 Choose a color model from the Color Mixer 
Options pop-up, if necessary.

4 Enter values in the color component fields, 
use the pop-up sliders, or pick a color from the 
color bar.

The cursor becomes the eyedropper cursor when it 
moves over the color bar. Click to pick a color. Deselect 
all objects before mixing a color to prevent unwanted 
object editing as you mix colors.

Choose alternative color models from the Color Mixer 
Options pop-up. The current color’s component values 
and the color bar change with each new color model.

Clicking the color bar while holding down Shift toggles 
the color bar through the RGB, Hexadecimal, and 
Grayscale color models. The fields on the Color Mixer 
do not change.

Note: When the Hexadecimal color bar is displayed, 
color choices are restricted to the Web 216 palette.

To take a color from the document and put it into 
the Color Mixer, click the color using the Eyedropper 
tool from the Toolbox. The highlighted color well 
displays the color and the Color Mixer displays the 
component values.

Viewing color information

The Info panel displays the component values of the 
color at the current cursor location. Choose an 
alternate Info panel color model in the Info panel 
Options pop-up.

Choose To express color components as

RGB Values of Red, Green, and Blue, 
where each component has a 
value from 0 to 255, where 0-0-0 is 
black and 255-255-255 is white.

Hexadecimal Values of Red, Green, and Blue, 
where each component has a 
hexadecimal value of 00 to FF, 
where 00-00-00 is black and 
FF-FF-FF is white.

HSB Values of Hue, Saturation, and 
Brightness, where Hue has a value 
from 0 to 360 degrees, and 
Saturation and Brightness have a 
value from 0 to 100 percent.

CMY Values of Cyan, Magenta, and 
Yellow, where each component 
has a value from 0 to 255, where 
0-0-0 is white and 255-255-255 is 
black.

Grayscale A percentage of black. The single 
Black (K) component has a value of 
0 to 100 percent, where 0 is white 
and 100 is black, and in between 
are shades of gray.

Choose To express color components as

The Info panel displays information about the color at the 
current cursor location.

View the color values of the color under the cursor.
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Using the Swatches panel

Choose Window > Swatches to display the Swatches 
panel, which contains a group of colors. Click a color 
swatch to choose a stroke, fill, or effect color for selected 
objects and objects to be drawn later.

Note: The Swatches panel displays the current 
Fireworks palette, not the current document’s palette.

When the cursor points to a swatch, it becomes one of 
three Eyedropper tool icons. Clicking a swatch 
automatically assigns that color to the active color well 
and applies the color to the stroke, fill, or effect of all 
selected objects.

By default, the Swatches panel contains the Web 216 
color palette. Choose alternative color palettes or 
customize a palette using the Swatches panel Options 
pop-up.

Customizing palettes

To add the active color to the current palette:

1 Move the cursor to the open space after the last 
swatch on the Swatches panel.

The cursor becomes the paint bucket cursor.

2 Click to add the swatch.

Choosing Edit > Undo does not undo swatch 
additions or deletions.

To replace a swatch with the active color:

1 Hold down Shift and point to a swatch.

The cursor becomes the paint bucket cursor.

2 Click the swatch.

The active color replaces the original swatch.

To delete a swatch from the palette:

1 Hold down Control (Windows) or Command 
(Macintosh) and point to a swatch.

The cursor becomes the scissors cursor.

2 Click the swatch to delete it.

To clear the entire Swatches panel, choose Clear 
Swatches from the Swatches panel Options pop-up.

To append a palette to the current palette:

1 Choose Add Swatches from the Options pop-up.

A File dialog box opens.

2 Choose a palette file.

Fireworks adds swatches from either of two types of 
files: Photoshop ACO palette files and GIFs. The 
new swatches are appended to the end of the 
current swatches.

Note: Except when displaying Current Export Palette, 
the Swatches panel is unrelated to the Export Preview 
swatch display. For more information about swatches in 
the Export Preview, as well as optimizing color palettes, 
see “Options panel” on page 95.

This eyedropper Applies a color to

The stroke color well and the 
stroke of each selected object.

The fill color well and the fill of 
each selected object.

The effect color well and the 
effect of each selected object.

To Do this

Revert a color 
palette to its 
original swatches

Reselect the color palette from 
the Options pop-up.

Save a custom 
palette

Choose Save Palette from the 
Swatches panel Options pop-
up, and then either name the 
new palette or leave the 
previous name to replace the 
original palette.

Use the current 
custom color palette 
from the Export 
Preview dialog box

Choose Current Export Palette 
from the Swatches panel 
Options pop-up.
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System color pickers

Double-clicking any color well displays the Windows 
Color dialog box (Windows) or the Apple Color Picker 
(Macintosh). Colors created using either of these 
methods bypass the Color Mixer and Swatches panel.

Using color wells

The current stroke and fill colors are displayed in the 
stroke and fill color wells on the Color Mixer. Duplicate 
color wells appear in the Toolbox.

In addition, a duplicate stroke color well appears on the 
Stroke panel and a duplicate fill color well appears on 
the Fill panel. An Effect color well appears on the Effect 
panel when color is an element of the effect.

To swap colors so that the stroke color becomes the fill 
color and the fill color becomes the stroke color, click 
the Swap Colors button in the Color Mixer or in 
the Toolbox.

To reset to the default colors, click the Default Colors 
button. Specify default colors using the General > “Color 
Defaults” preference.

Click to activate the 
stroke color well.

Click to activate the Fill 
color well. The Fill color 
well is shown as active.

Click to switch the colors 
in the stroke and fill color 
wells.

Click to reset to the default stroke and 
fill colors specified in the Preferences.

The stroke and fill color wells and the color well buttons 
appear in both the Color Mixer and the Toolbox.

To activate the Do this

Stroke color 
well

Click the color well with the brush 
next to it in the Toolbox or in the 
Color Mixer
or
Click the color well in the Stroke 
panel.

Fill color well Click the color well with the paint 
bucket next to it in the Toolbox or 
in the Color Mixer
or
Click the color well in the Fill panel.

Effect color well Click the color well in the Effect 
panel. Neither the Toolbox nor the 
Color Mixer has an Effect 
color well. Some effects do not 
use color.
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Using color well pop-up swatches

Click the box next to any color well to display pop-up 
swatches and choose a color to apply to that color well 
and any selected objects. The color well pop-up contains 
the swatches currently in Fireworks Swatches panel. 

Applying color to the canvas

The canvas is the bottom surface of the Fireworks 
document. Specify a canvas color in either of two ways:

◆ When opening a new document, choose White, 
Transparent, or Custom in the New Document 
dialog box. To choose a canvas color using the 
system color picker, click the Custom color well.

◆ With an existing document, choose Modify > 
Document > Canvas Color, and then choose White, 
Transparent, or Custom.

Applying strokes and fills
Use the Stroke panel to choose a brush stroke and to 
apply a brush stroke to selected objects. Use the Fill 
panel to fill selected objects and subsequently drawn 
objects. Use the Stroke panel Options pop-up and Fill 
panel Options pop-up to adjust stroke and fill settings 
and to create and save custom brushes and fills.

The Stroke panel and Fill panel combine to form the 
control center for creating brush strokes and fills. Save 
your favorite stroke and fill settings to use again.

Saving a stroke or fill only saves it for use within the 
current document. To reuse a saved stroke or fill in 
another document, copy and paste an object with the 
saved stroke or fill into the document. The saved stroke 
is added to the Stroke panel for use within the 
document.

Alternatively, use the Styles panel to save a stroke or fill 
and reuse it later.

To Do this

Get a color from 
anywhere on the 
screen

Click the eyedropper button, 
and then click anywhere on 
the screen.

Get a color from the 
system color picker

Click the color picker button, 
and then choose a color from 
the system color picker.

Apply transparency. Click the transparency button.

Color Well Pop-up swatches

Stroke panel Fill panel
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The Stroke panel

The Brush tool is the primary freeform drawing tool in 
Fireworks. The Pen tool is the primary Bézier 
curve drawing tool. Use either to create paths with a 
wide range of possible characteristics in both object 
mode and image edit mode, from thin, pencil-like 
paths to wide swaths resembling spray paint or 
splattered oil. A variety of stroke textures add to the 
range of creative possibilities.

Stroke editing features offer full control of every brush 
nuance, including ink amount, tip size and shape, edge 
effect, and aspect. Also, sensitivity settings control how a 
pressure-sensitive pen affects strokes.

A newly created brush stroke assumes the current color 
displayed in the brush color well, whether in object 
mode or image edit mode.

Using the Edit Stroke panels

Choose Edit Stroke from the Stroke panel Options
pop-up to display the Edit Stroke panels: Options, 
Shape, and Sensitivity.

The stroke preview at the bottom of any Stroke panel 
shows the current brush with the current settings. A 
stroke in the preview that tapers or fades or otherwise 
changes from left to right illustrates the current pressure- 
and speed-sensitivity settings.

Save, edit, rename, and 
delete strokes.
Choose a stroke category.
Choose a specific stroke.

Show current stroke shape.

Choose a stroke texture.

Preview stroke.

Alter stroke edge.

Alter stroke size.

Change intensity of the 
brush stroke texture.

Alter stroke color.

Stroke panel

Brush tool Pen tool

Set ink amount, spacing, and flow rate.

Overlap brush stamps for 
dense strokes.

Set brush texture amount.

Set texture on the edges.

Choose an edge effect.

Set the number of tips.

Set spacing of multiple tips.

Choose the color variation 
between multiple tips.

Edit Stroke Options panel

Edit Stroke Shape panel

Preview the brush tip shape.

Check for a square brush tip.

Set the brush tip size, edge 
softness, tip aspect, and tip 
angle.

Preview the brush stroke.
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Saving stroke settings

Any change to stroke settings is saveable. Use the Stroke 
panel Options pop-up to save strokes, change stroke 
characteristics, rename the current stroke, or delete the 
current stroke.

Saving a stroke only saves it for use within the current 
document. To reuse a saved stroke in another document, 
copy and paste an object with the saved brush stroke 
into the document. The saved stroke is added to the 
Stroke panel for use within the document.

Use the Styles panel to store a stroke and its settings. 
Select an object then click a stroke in the Styles panel to 
apply the stored stroke to the object. Stroke styles in the 
Styles panel may be exported and then imported into 
other Fireworks documents.

The Fill panel

Fireworks fill categories are None, Solid, Pattern, Web 
Dither and various gradient shapes. Combine fill types 
with textures to quickly create complex artwork.

A newly created closed path drawn with the Pen tool or 
a basic shape tool assumes the current fill displayed in 
the Fill panel. Paths drawn with other drawing tools 
have a default fill of None.

Saving and reusing fills

Saved fills are stored within the current document. To 
reuse a saved fill in another document, copy and paste an 
object with the saved fill into the other document. The 
saved fill is added to the Fill panel.

Use the Styles panel to store a fill and its settings. Select 
an object then click a fill in the Styles panel to apply the 
stored fill to the object. Fill styles in the Styles panel may 
be exported and then imported into other Fireworks 
documents.

Editing and saving a gradient color ramp

All fill categories other than None, Solid, Pattern, and 
Web Dither are Gradient fills. Use the Fill panel 
Options pop-up to edit, save, rename, or delete the 
current Gradient.

Edit Stroke Sensitivity panel

Preview the stroke.

Assign the stroke 
property for sensitivity 
data to control.

Set the degree to which 
sensitivity data affects the 
current stroke property. Choose a fill category.

Save, edit, name, and 
delete gradients.

Control edge feathering.

Choose a fill texture and 
intensity and control 
transparency.

Fill panel

Choose Anti-Alias, Hard 
Edge, or Feathered edge.

Preview fill.
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Choosing Edit Gradient opens the Edit Gradient dialog 
box. Choose a preset Gradient from the Preset Options 
pop-up. Click an area under the color ramp to add a 
color well. Click and drag any color well below the color 
ramp to change the transition between colors in the fill. 
Double-click any color well to pick a color from the 
color palette pop-up menu. Add as many colors to the 
color ramp as you want.

Editing a fill with the Paint Bucket tool

Choose the Paint Bucket tool to quickly edit a selected 
object’s fill. 

◆ When the Fill panel has a fill of None, Solid, or 
Web Dither, clicking inside the object with the 
Paint Bucket tool adds the color in the fill color well 
as a Solid or Web Dither fill.

◆ When the Fill panel has a Pattern or Gradient fill, 
clicking the Paint Bucket tool places the round 
paint bucket handle, which represents the center or 
starting point of the fill.

◆ When choosing a new Pattern or Gradient fill type 
in the Fill panel, clicking inside a selected object 
applies the new fill type to the object.

Filling areas of similar color

On image objects, use the Paint Bucket tool to fill areas 
of similar color. With the Paint Bucket tool selected, set 
the tolerance on the Tool Options panel to determine 
the range of similar colors to be filled.

A tolerance setting of 0 (zero) causes the Paint Bucket 
tool to fill a solid area of a single color. Higher tolerance 
settings will cause the Paint Bucket tool to fill adjoining 
areas near in color to the color that was clicked.

To fill the entire image or selection, rather than similar 
colors, check Fill Selection Only on the Tool Options 
panel when the Paint Bucket tool is selected.

Adjusting a fill interactively

To change or distort a selected object’s Pattern or 
Gradient fill, choose the Paint Bucket tool. An L-shaped 
or linear set of handles appears on or near the object. Use 
these handles to adjust the object’s fill. 

Edit Gradient dialog box

Paint Bucket tool

Use the Paint Bucket tool handles to interactively adjust a 
Pattern or Gradient fill.

Drag to 
adjust fill 
width and 
skew.

Drag to 
adjust fill 
angle.

Drag to 
place a fill’s 
center or 
first color.
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The round starting handle specifies the starting point of 
the fill. Drag the starting handle to move the fill within 
the object without changing the size, width, skew, or 
angle of the fill.

The ending handle represents the ending point of the fill. 
The distance between the ending handle and the width 
handle sets the fill angle. Dragging the ending handle 
does not move the other handles. The width handle 
represents both aspect (or width) and skew.

The Web Dither fill

When exporting using a web-safe palette, colors in the 
image that are not web-safe are shifted to a web-safe 
color or dithered. Use Web Dither fill to create the 
appearance of a color outside the web-safe palette that 
will neither shift nor dither when exported with a web-
safe palette. Use a Web Dither to fill an object with a 
dither pattern based on two web-safe colors.

When a color is selected in the Web Dither Fill panel, a 
dither pattern is created from the two web-safe colors 
that are closest in value to the color that is to be 
approximated.

Note: Setting a Soft Edge or a Feathered Edge for a 
Web Dither fill will result in colors that are not web-safe.

Note: To create the illusion of a true transparent fill in a 
web browser, apply a Web Dither fill to an object and 
check Transparent on the Fill panel. Then, export the 
object as a GIF or PNG with Index Transparency or 
Alpha Channel Transparency set. When viewed in a web 
browser, the web page's background will show through 
every other pixel of the transparent Web Dither fill, 
creating the effect of transparency.

Using styles

Use styles to maintain visual consistency and to 
simplify formatting. Use the Styles panel to store and 
apply stroke, fill, effect, and text styles to objects or text.

Styles in Fireworks behave like an artist's palette, not like 
styles in a word processor. When a style is applied to an 
object, that object takes on the style's characteristics. 
However, Fireworks does not keep track of which style 
was applied to the object, and the object does not update 
if the style is edited.

To apply a style to an object, select an object or text, and 
then click a style in the Styles panel.

To add a new style:

1 Create an object or text block with the stroke, fill, 
and text settings you want.

2 With the object selected, choose New Style from 
the Styles panel Options pop-up, or click the New 
Style button at the bottom of the Styles panel.

Web Dither Fill panel

Choose two web-safe colors 
to create a dither pattern.

Styles panel
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3 Enter a name for the style and check the 
properties you want to apply with the style.

Properties left unchecked will not be applied to an 
object with the style.

4 Click OK.

An icon for the style appears on the Styles panel 
showing a quick preview of the style.

Editing and deleting styles

Importing and exporting styles

Styles can be exported and shared with other Fireworks 
users.

Adding texture

Both the Stroke panel and the Fill panel have an option 
for adding a texture to the brush stroke or fill.

The Amount of texture field next to the Texture name 
pop-up controls the depth of the texture from 0 to 100 
percent. Lower percentages result in lighter texture and 
higher percentages result in heavier texture.

On the Fill panel, check Transparent to make the light 
parts of the texture transparent.

To Do this

Edit a style Double-click a style or click a 
style in the Styles panel and 
then choose Edit Style from 
the Options pop-up.
In the Edit Style dialog box, 
check or uncheck components 
of the style that will be 
applied.
Specific style characteristics, 
such as fill or stroke type, 
cannot be changed by using 
Edit Style. To change fill, 
stroke, or effect settings for a 
style, create a new style.

Delete a style Click a style in the Styles panel, 
and then choose Delete Style 
from the Options pop-up or 
click the Delete Style button at 
the bottom of the Styles 
panel.
Hold down the Shift key while 
clicking styles to select 
multiple styles for deleting.

Reset the Styles 
panel to the default 
styles

Choose Reset Styles from the 
Options pop-up.

make the style 
preview icons larger

Choose Large Icons from the 
Options pop-up. Choose Large 
Icons again to switch back to 
the small previews.

To Do this

Import styles Choose Import Styles from the 
Options pop-up, and then 
choose a saved styles 
document to import.
All styles in the selected styles 
document are imported and 
placed directly after the 
currently selected style on the 
Styles panel.

Export styles Select styles on the Styles 
panel. Hold down the Shift as 
you select to select multiple 
styles.
Choose Export Styles from the 
Options pop-up.
Enter a name and a location 
for the saved styles document, 
and then click Save. 

Preview a texture.

The Texture name pop-up displays a preview of the 
highlighted texture.

Adjust texture and
transparency.
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Applying effects to objects
Use the Effect panel and Xtras menu commands to 
enhance graphics with many Live Effects and filters. 
Easily achieve common web effects such as Bevel, Glow, 
Drop Shadow, and Emboss, or apply combinations of 
any of those effects. Alter images with Xtra filter effects 
such as Blur, Unsharp Mask, and Invert.

Live Effects

Live Effects are pixel-based effects that apply to path, 
image, and text objects and redraw to reflect subsequent 
editing. Applying a Live Effect does not permanently 
change the original object.

◆ The object to which the effect is applied remains 
editable.

◆ The effect itself remains editable and removable.

For example, create a button by applying an Outer Bevel 
effect on the button itself and apply Drop Shadow to the 
text on the button. The button shape and the text on the 
button all remain fully editable.

Inner Bevel effect

Outer Bevel effect

Drop Shadow effect

Emboss effect

Glow effect
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To apply an effect to an object:

1 Select the object.

2 Choose the effect from the Effect panel.

To edit an effect:

1 Select the object.

2 Adjust effect characteristics in the Effect panel.

Use the Effect panel Options pop-up to save custom 
effect settings, rename an effect, and delete an effect.

Saved effects are stored only within the current 
document. To reuse a saved effect in another document, 
copy and paste an object with the saved effect into 
the other document. The saved effect is added to the 
Effect panel.

Applying multiple effects

Choose Multiple from the category pop-up of the Effect 
panel to apply multiple effects.

To apply multiple effects to an object:

1 Select the object.

2 Choose Multiple from the Effect panel category 
pop-up. 

3 Check the box next to each effect you wish to 
apply. 

Each time you check an effect, make specific 
settings for that particular effect in the dialog box 
that opens.

To edit an effect that is part of a multiple effect:

1 Select the object.

2 Click the edit button next to the effect you want 
to edit.

3 Change settings in the dialog box that appears, 
and then click OK.

Note: When opening Fireworks 2 documents in 
Fireworks 1, objects that contain multiple effects will 
retain only the first effect.

Save, edit, name, and 
delete effects.

Choose a specific effect.

Set effect-specific 
options such as width, 
contrast, and softness.

Choose an effect category.

Effect panel

Choose bevel appearance.

Multiple Effect panel

Click to open the Effect 
panel for the checked effect.

Check to apply the effect 
and open the Effect panel.

Choose Multiple to apply 
more than one effect to 
selected objects.
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Saving, renaming, or deleting multiple 
effect settings

Once a multiple effect is set, you can save that setting so 
that it can be quickly applied at a later time.

Using Subselect or Superselect with effects

When applying various effects to a group, masking 
group, or Symbol:

◆ Choose Select > Subselect to select all objects within 
a selected group, masking group, or Symbol.

◆ Choose Select > Superselect to select the group, 
masking group, or Symbol that contains the 
selected object.

Using Xtras

The Xtras menu has effects that are not reversible. Once 
these effects are applied to an object, the object is no 
longer editable and becomes a floating image object. 
Fireworks Xtras include Blur, Invert, and Sharpen.

Photoshop plug-ins also work in Fireworks. Copy 
Photoshop plug-ins into the Fireworks Xtras folder to 
add them to the Xtras menu. Alternatively, target an 
additional plug-in folder in the Preferences dialog box.

Using text
Add text using the Text tool and the Text Editor. Apply 
brush strokes, fills, and effects to text. Edit text and its 
stroke, fill, and effect attributes redraw accordingly.

In Fireworks, text is neither a path nor an image. Text 
initially has no stroke and a solid fill. A stroke can be 
added using the Stroke panel. Check Anti-Alias in the 
Text Editor to give text an anti-aliased edge. Also, text 
edges can be changed using the Fill panel. A text block 
is a moveable and resizable object.

Text is convertible to an image or to paths; however, 
converting text renders it uneditable as text. 

To enter text:

1 Choose the Text tool and click the canvas.

The Text Editor opens.

2 Choose font, size, spacing, and other text 
characteristics.

3 Type the text.

To see changes in the document as you edit the text 
in the Text Editor, check the auto-apply checkbox in 
the Text Editor. 

To change text characteristics in the Text Editor, 
select the text in the Text Editor, then apply changes. 

4 Click OK or press Enter. 

The text appears in a text block in the Fireworks 
document.

To Do this

Save a multiple 
effect setting

Choose Save Effect As from 
the Effect panel Options pop-
up, enter a name for the 
effect, then click OK. The 
effect will appear in the 
Multiple Effect presets pop-up 
on the Effect panel.

Rename a multiple 
effect setting

Select the effect you want to 
rename from the Multiple 
Effect presets pop-up, choose 
Rename Effect from the Effect 
panel Options pop-up, enter a 
new name, then click OK.

Delete a multiple 
effect setting

Select the effect you want to 
delete from the Multiple Effect 
presets pop-up, then choose 
Delete Effect from the Effect 
panel Options pop-up.

Text tool

Drag any text block handle to 
resize a text block.

Text block
Creating and Editing a Graphic 67



5 Resize and move the text block with the Pointer 
tool.

6 Add a stroke or effect, or change the fill.

To edit text, double-click a text block. Within a single 
block of text, you can vary all aspects of text, including 
size, font, spacing, leading, baseline shift, and more. To 
resize a text block, pull any text block selection handle.

To use Type 1 fonts on the Macintosh, Fireworks 
requires Adobe Type Manager 4 or higher.

Using the Text Editor

The Text Editor is where you enter and edit text and 
change text attributes. Select all or part of the text in the 
Text Editor preview area and apply changes.

To view the results of changes in the document, move 
the Text Editor so that the selected text block is visible, 
then click Apply to see the changes without closing the 
Text Editor.

Choose fonts from the Font pop-up.

Apply a Bold, Italic, or 
Underline style.

Set text block alignment to 
Left, Center, Right, Justified, 
or Stretched.

Adjust leading.

Type and edit text.

Set the direction of text 
flow as left to right or 
right to left.

Adjust kerning or
range kerning.

Adjust baseline shift.

Adjust horizontal scale.

Adjust point size.

Orient text horizontally or vertically.

Resize the Text Editor.Check to show actual
fonts and sizes in the

Text Editor.

Apply color to text.
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Attaching text to a path

To place text on a path:

1 Select a text block and a path.

2 Choose Text > Attach to Path.

3 Optionally, choose Text > Orientation, then 
choose an orientation option.

Choose any of four orientation options for text on a 
path: Rotate around Path, Vertical, Skew Vertical, or 
Skew Horizontal.

To edit text attached to a path, double-click the text-and-
path object to open the Text Editor.

To edit the shape of the path, choose Text > Detach from 
Path to detach the text from the path and edit the path. 
After editing the path, select it and the text block and 
choose Attach to Path.

A path to which text is attached temporarily loses its 
stroke, fill, and effect attributes. Subsequently applied 
stroke, fill, and effect attributes are applied to the text, not 
the path. A path regains its stroke, fill, and effect 
attributes when text is detached from it.

If text attached to an open path exceeds the length of the 
path, the remaining text returns and repeats the shape of 
the path.

To move the starting point of text attached to a 
path:

1 Select the text-and-path object.

2 Choose Modify > Object to display the Object 
inspector.

3 Enter a value in the Text Offset field.

A negative offset value is valid when text is attached to a 
closed path or when text is center aligned. The attached 
text’s alignment and flow—set in the Text Editor—affects 
the outcome of Text Offset.

Converting text to paths and images

After text is converted into an image object or to paths, it 
is no longer editable as text. The conversion is 
irreversible, except when Edit > Undo is available.

To convert text to paths:

1 Select the text.

2 Choose Text > Convert to Paths.

Text converted to paths retains all of its properties and is 
now editable only as paths.

To convert text to an image object:

1 Select the text.

2 Choose Modify > Merge Images.

Text converted to an image object retains its current 
appearance.

Firew
orks

Vertical text on a path with 
Vertical Orientation

Horizontal text on a path

Text on a path returns and repeats the path shape.
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Controlling document size and 
resolution

Choose Modify > Document > Image Size to open the 
Image Size dialog box and change the document's 
dimensions, print size, and resolution.

To resize an image in Fireworks:

1 Choose Modify > Document > Image Size.

The Image Size dialog box opens.

2 Enter numbers in the Pixel Dimensions fields to 
set the new horizontal and vertical dimensions 
for the image.

By default, the document's current dimensions are 
displayed in the Pixel Dimensions fields. If 
Resample Image is unchecked, Pixel Dimensions 
cannot be changed–only the resolution or Print 
Size may be changed.

3 Enter numbers in the Print Size fields to set the 
new horizontal and vertical dimensions of the 
image when it is printed.

4 Enter a number in the Resolution field to change 
the resolution of the image.

If Resample Image is checked, changing the 
Resolution also changes the Pixel Dimensions.

5 To maintain the same ratio between the 
document's horizontal and vertical dimensions, 
check Constrain Proportions.

Uncheck Constrain Proportions to resize the width 
and height independently from one another.

6 Check Resample Image to add or remove pixels 
when resizing the image to approximate the 
same appearance at a different size.

7 Click OK.

Resampling

Resizing bitmap images always presents a unique 
problem–do you add or remove pixels to resize the 
image, or do you change the number of pixels per inch or 
centimeter?

One way to adjust the size of a pixelated image is to 
adjust the resolution, which changes the size of the pixels 
in the image so that more or fewer pixels fit in a given 
space. Another way to adjust the image's size is to 
resample the image.

When an image is resampled, pixels must be added or 
removed to make the bitmap larger or smaller. Either 
way, the image is altered, which can result in some 
quality loss at the target resolution.

◆ Downsampling, or removing pixels to make the 
image smaller, always causes quality loss because 
pixels are discarded to resize the image.

◆ Resampling up, or adding pixels to make the image 
larger, may result in quality loss because some pixels 
are being added to make the image larger, and the 
pixels that are added do not always correspond pixel-
for-pixel to the original image.

Resampling in Fireworks differs from most image 
editing applications; Fireworks contains pixel-based 
bitmap image objects and vector-based path objects.

When an image object is resampled, pixels are added to 
or removed from the image object to make it larger or 
smaller. When a path object is resampled, little quality 
loss occurs because the path is redrawn mathematically 
at a larger or smaller size.

However, since path objects in Fireworks are composed 
of pixels, some strokes or fills may appear slightly 
different after resampling because the pixels that 
compose the stroke or fill must be redrawn.

Note: When you resize an image, guides, hotspot 
objects, and slice objects are resized with the image.

Image Size dialog box
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Organizing your document
Fireworks has several features that help organize a 
document as it grows more complex.

◆ Group and ungroup individual objects.

◆ Arrange objects behind or in front of other objects.

◆ Arrange, lock or unlock, and show or hide layers.

◆ Organize layers and frames within a document.

◆ Arrange frames.

◆ Hide individual objects.

Grouping objects

Grouping two or more selected objects freezes their 
positions and stacking order relative to one another, so 
you can manipulate them as a single object. Objects 
within a group retain their individual characteristics, 
unless you modify the entire group.

To group two or more selected objects, choose
Modify > Group. To ungroup, select the group and 
choose Modify > Ungroup.

To work with individual objects within a group, either 
ungroup the objects or use the Subselection tool to 
subselect only the objects you want to modify. 
Modifying attributes of a subselected object changes 
only the subselected object and not the entire group. 
Moving a subselected object to another layer will 
remove the object from its original group.

When editing a group, masking group, or symbol:

◆ Choose Edit > Subselect to select all objects within a 
selected group, masking group, or symbol.

◆ Choose Edit > Superselect to select the group, 
masking group, or symbol that contains the 
selected object.

Group selected objects as a single object.

Subselect an object within a group.
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Arranging objects on a layer

Arranging objects on the same layer

Use the Arrange commands to change the stacking 
order of objects. However, you may not see the change in 
the stacking order if the objects are not overlapping.

Using layers

Layers divide a Fireworks document into discrete 
planes, as though the graphic components were drawn 
on separate tracing paper overlays. Each object in a 
graphic resides on a layer. Create all layers before you 
draw, or add layers as needed.

Only objects on visible, unlocked layers are editable. The 
canvas is below all other layers, but it is not actually a 
layer. Change the canvas color by choosing Modify > 
Document > Canvas Color and then selecting a different 
canvas color.

The name of the active layer is highlighted. Drawn, 
imported, or pasted objects initially reside on the active 
layer.

To Do this

Move an object 
forward on the 
same layer

Select the object and choose 
Modify > Arrange > Bring 
Forward.

Move an object 
to the front of 
a layer

Select the object and choose 
Modify > Arrange > Bring to 
Front.

Move an object 
backward on 
the same layer

Select the object and choose 
Modify > Arrange > Send 
Backward.

Move an object 
to the back of 
a layer

Select the object and choose 
Modify > Arrange > Send to 
Back.

Choose a different frame.
Add, duplicate, rename, 
and delete layers. Hide 
and show layers. Lock 
and unlock layers.

Show or hide a layer.

Lock or unlock a layer.

View and rearrange the 
stacking order of layers.

Layers panel
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To show or hide the Layers panel choose Window > 
Layers. The Layers panel displays the current state of all 
layers in the current frame of a document.

Use the Options pop-up to add, duplicate, rename, 
remove, hide or show, lock or unlock, and share layers. 
Check Single Layer Editing to restrict editing to the 
current layer.

Use the Current Frame pop-up to navigate among 
frames. Alternatively, use the frame controls on the 
bottom of the document window to navigate among 
frames.

Hiding a layer hides all objects on that layer, but does 
not remove them from the document. A hidden layer 
cannot be an active layer. Showing a layer shows all 
objects on that layer.

Hiding selected objects from view

To hide all selected objects, select them and then choose 
View > Hide Selection. Hide Selection does not hide 
guides. Hidden objects remain hidden when the 
document is closed and reopened.

To show all hidden objects, choose View > Show All.

The Web Layer 

The Web Layer is a special layer that appears at the top 
of every new document. The Web Layer contains web 
objects used for assigning interactivity to exported 
Fireworks documents.

The Web Layer may be moved in the Layers panel, but 
it may not be deleted. Moving a path object to the Web 
Layer creates a hotspot in the shape of that object. The 
Web Layer is always shared across all frames.

Sharing a layer across frames

Set a layer so that it is shared across all the frames in the 
document in either of two ways:

◆ Double-click a layer, and then in the Layer Options 
dialog box check Share Across Frames. 

◆ Select a layer you want to share, then check Share 
Layer on the Options pop-up of the Layers panel.

To Do this

Add a layer Choose New Layer from the 
Options pop-up on the Layers 
panel
or
Click the New Layer button
or 
Choose Insert > Layer.

Delete a layer Drag a layer to the Delete 
Layer button, select a layer 
and click the Delete Layer 
button
or
Select a layer and choose 
Delete Layer from the Options 
pop-up on the Layers panel.

Move a layer Drag a layer name up or down 
on the Layers panel.

Show or hide a layer Click the square in the first 
column to the left of a layer 
name.
A show/hide icon indicates 
that a layer is visible.

Lock a layer Click the square in the second 
column to the left of a layer 
name.
A padlock indicates that a 
layer is locked. Objects on a 
locked layer are not editable 
until the layer is unlocked.

Duplicate a layer Drag a layer to the New Layer 
button, select a layer and click 
the New Layer button
or
Select a layer and choose 
Duplicate Layer from the 
Options pop-up on the Layers 
panel.

Move selected 
objects to another 
layer

Drag the square selection icon 
to the desired layer.
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Using frames

Frames comprise the structure for an animated 
Fireworks document, or contain the alternate states for 
behaviors. Each frame within a document is the same 
size and has the same layers in the same order as the 
other frames.

To show or hide the Frames panel choose Window > 
Frames. Frames are automatically named in numerical 
order, beginning with Frame 1.

Add, duplicate, or delete frames using the Frames panel 
Options pop-up. Use Copy to Frames to copy the 
current selection and paste it into the frame specified in 
the Copy to Frames dialog box. Use Distribute to 
Frames to distribute all selected objects across frames 
according to the stacking order from bottom to top.

For more information about using frames for animation, 
see “Creating animation” on page 124. For more 
information on using frames for rollovers see “JavaScript 
rollovers” on page 120.

Find and Replace
Use Find & Replace to search for and replace different 
elements in a document, such as text, URLs, fonts, and 
colors. When you use Find & Replace, Fireworks can 
search the current document or multiple files.

Also, Fireworks can track changes made during a Find 
& Replace operation and store a log of the changes in the 
Project Log panel. Find and Replace only works on 
Fireworks PNG files, or on files containing vector 
objects, such as Macromedia FreeHand files, 
CorelDRAW files, or Adobe Illustrator files.

To find and replace elements of a document:

1 Choose Edit > Find & Replace to open the Find & 
Replace panel.

2 Choose an attribute to search for from the 
Attributes pop-up.

3 Set the Find and Change to fields to define 
attributes to find and replace.

4 Click one of the three buttons at the bottom of 
the Find & Replace panel:

◆ Choose Find Next to find the next instance of 
the element in the Find field. Found elements 
appear selected in the document.

◆ Choose Replace to replace a found element 
with the contents of the Change to field.

◆ Choose Replace All to find and replace every 
instance of a found element throughout the 
search range.

Add, duplicate, and 
delete frames; copy to 
frames; or distribute 
the selection.

Frames panel

Find & Replace panel
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Selecting the source for the search

Fireworks can perform a find and replace in any of five 
locations. Choose an option from the Search In field to 
select the range of content you want to find and replace:

Selection—Find and replace elements only among the 
currently selected objects and text.

Frame—Find and replace elements only within the 
current frame.

Document—Find and replace elements in the active 
document.

Project log—Find and replace elements in files listed in 
the Project Log.

Files—Find and replace elements across multiple files. 
When you choose Files from the Search In pop-up, the 
Open Multiple Files dialog box opens. Navigate to a file 
you want to search, and then click Add to add that file 
to the find and replace list. Click Add All to add all files 
in the current folder to the find and replace list.

Managing multiple file searches

When finding and replacing among multiple files, select 
Replace Options from the Options pop-up to set how 
multiple opened files are backed up after the file has been 
searched.

Check Save and Close Files to save and close all files in a 
multiple file find and replace. Each file is saved and 
closed after the find and replace is performed. Only the 
original active documents remain open.

Choose an option from the Backups pop-up to make 
backups of changed files from a find and replace.

◆ Choose No Backups to make no backups. The 
changed files replace the original files.

◆ Choose Overwrite Existing Backups to create only 
one backup of each original file. If additional find 
and replace operations are performed, the previous 
original file always replaces the backup copy. The 
backup copies are stored in subfolders called 
Original Files, which are created in the folders of 
each file that was replaced during a find and replace. 
If an Original Files folder already exists, it is used 
instead of a new folder.

Choose Incremental Backups to save every instance of a 
changed file. The original files are moved to an Original 
Files subfolder of their current folder, and an 
incremental number is appended to each file name.

If additional find and replace operations are performed, 
the original file is copied to the Original Files folder and 
the next higher number is added to its file name.

For example, for a file named Drawing.png, the first 
time a find and replace is executed, the backup file is 
named Drawing-1.png. The second time a find and 
replace is run, the backup file is named Drawing-2.png, 
and so on.

Managing searches with the Project Log

The Project Log helps track and control changes made 
in multiple files when using Find and Replace or when 
batch processing. Any documents changed during a 
Find & Replace are recorded in the Project Log.

Use the Project Log to navigate through selected files, 
export selected files using their last export settings, or 
select files to be batch processed.

Project Log panel
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The Project Log records each changed document and 
displays which frame of the document contained the 
change, as well as the date and time of the change.

Viewing and printing the Project Log

The latest version of the Project Log is stored as an 
HTML file in the Fireworks 2 \ Settings folder. Open 
the Project_Log.htm file in a browser to view or print 
the Project Log.

Finding and replacing text

Choose Text from the Attributes pop-up of the Find 
and Replace panel to search for and replace words, 
phrases, or text strings in Fireworks documents. Enter 
the text to search for in the Find field. Enter the 
replacement text in the Change to field.

◆ Check Whole Word to find the text in the same 
form as it appears in the Find field, and not as part 
of any other word.

◆ Check Match Case to distinguish between 
uppercase and lowercase letters when searching text.

◆ Check RegExp to use regular expressions when 
searching. Use regular expressions to match parts of 
words or numbers conditionally during a search. 
For more information on using regular expressions, 
see http://developer.netscape.com/docs/manuals/
communicator/jsguide/regexp.htm.

To Do this

Manually add files 
to the Project Log

Choose Add Files from the 
Project Log Options pop-up 
and navigate to the file you 
want to add.

Open or display files 
listed in the Project 
Log

Select a file listed in the 
Project Log and click Open, or 
double-click a file listed in the 
Project Log.

Remove an entry 
from the Project Log

Select one or more entries and 
choose Clear Selection from 
the Project Log Options pop-
up.

Remove all entries 
from the Project Log

Choose Clear All from the 
Project Log Options pop-up.

Export a file listed in 
the Project Log 
using its last export 
settings

Select a file or files in the 
Project Log and choose Export 
Again from the Project Log 
Options pop-up.

Find & Replace Text panel
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Finding and replacing fonts

Choose Font from the Attributes pop-up of the Find 
and Replace panel to search for and replace fonts in a 
Fireworks document or documents. Specify the font or 
font characteristics to find in the Find area. Specify the 
font or font characteristics used to replace found fonts in 
the Change to area.

◆ In the Min field, enter the minimum point size to 
find of the selected font.

◆ In the Max field, enter the maximum point size to 
find of the selected font.

◆ In the Size field, enter a point size to apply to 
found fonts.

Finding and Replacing colors

Choose Color from the Attributes pop-up to search for 
and replace colors in Fireworks documents. Choose the 
color to be replaced from the Find color well pop-up. 
Choose the replacement color from the Change to color 
well pop-up.

Choose an item from the Apply to pop-up to determine 
how the colors found in the find and replace are applied:

Fills—Find and replace a fill color, except for a Pattern 
fill that is based on a bitmap image.

Strokes—Find and replace stroke colors only.

Fills and Strokes—Find and replace both fill and 
stroke colors.

Effects—Find and replace effect colors only.

Everything—Find and replace fill, stroke, and 
effect colors.

Find & Replace Fonts panel Find & Replace Colors panel
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Finding and Replacing URLs

Choose URL from the Attributes pop-up of the Find 
and Replace panel to search for and replace URLs 
assigned to web objects in Fireworks documents.

Enter or choose the URL to be replaced in the Find 
field. Enter or choose the replacement URL in the 
Change to field. The Find and Change to pop-ups 
display all URLs present in the active document.

Symbols and instances
Use symbols and instances to simplify Fireworks 
animations and improve editability. Instances are 
representations of an original Fireworks object, which is 
designated as the symbol. When the symbol object (the 
original) is edited, the instances (copies) automatically 
change to reflect the modifications to the symbol.

Use symbols and instances to:

◆ Simplify modifications to existing animations by 
changing only the symbol object and having the 
instance objects update automatically.

◆ Easily modify complex illustrations containing 
multiple copies of objects.

◆ Share components across rollover states.

Creating a symbol

Create a symbol from any object, text, or group. Choose 
Insert > Symbol to turn one or more selected objects into 
a symbol. To add objects to an existing symbol, select the 
symbol and the objects and choose Insert > Symbol 
Options > Add to Symbol. Symbols cannot include 
instances and other symbols.

Find & Replace URLs panel

A plus icon represents a 
symbol object.
Chapter 278



Creating an instance

Create an instance using any of these methods:

◆ Copy and paste a symbol.

◆ Duplicate a symbol.

◆ Clone a symbol.

◆ Choose a symbol and select Copy to Frames from 
the Frames panel.

◆ Press Alt (Windows) or Option (Macintosh) after 
you begin dragging a symbol.

Modifying a symbol

Modify a symbol to automatically modify all associated 
instances. Symbols behave as groups when modified or 
transformed. For example, apply different opacities to 
components within a symbol by subselecting objects 
and using the Object inspector. For more information 
on modifying opacity within grouped objects, see 
“Object inspector” on page 20 and “Using the Object 
inspector” on page 81.

Modifying an instance

Instance object modifications are limited to 
transformations, opacity, blending modes, and Live 
Effects. When applied to an instance, transformations 
and Live Effects do not affect an instance’s symbol 
object. Changes to an instance are automatically 
reapplied when its symbol is modified.

Working with symbols and instances

Note: Symbol and instance functions are available only 
in object mode.

An arrow icon represents 
an instance object.

To Do this

Create a symbol Select an object or group of 
objects and choose Insert > 
Symbol.

Add items to an 
existing symbol

Select the symbol and the 
items and choose Insert > 
Symbol Options > Add to 
Symbol.

Create an instance Copy and paste, duplicate, or 
clone a symbol or instance
or
Select a symbol and choose 
Copy to Frames from the 
Frames panel
or
Press Alt (Windows) or Option 
(Macintosh) after you begin 
dragging a symbol.

Delete all instances 
while retaining a 
symbol

Select the symbol and choose 
Insert > Symbol Options > 
Delete Instances.

Delete a symbol and 
all associated 
instances

Delete the symbol and confirm 
in the resulting dialog box to 
delete all Instances.

Break the link 
between a symbol 
and its instances

Select the symbol, choose 
Insert > Symbol Options > 
Break Link, and then click 
Group from the resulting 
dialog box. The Instances are 
retained as unlinked groups.

Find a symbol for a 
particular Instance

Select an instance and choose 
Insert > Symbol Options > 
Find Symbol.

Move a symbol and 
its instances 
simultaneously

Select the symbol, choose 
Edit > Subselect, and move 
the contents of the symbol.
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Tweening

Choose Insert > Tween Instances to blend a symbol and 
one or more of its instances, creating interim instance 
objects with transitional attributes. This is known as 
tweening. Alternatively, tween two or more instances 
without using a symbol.

Instance objects created by tweening derive attributes 
from the symbol or instance objects used. For 
example, tween a vertical symbol with a horizontal 
instance to produce instance objects that rotate 
progressively to form a blend from the vertical object to 
the horizontal object.

Tweening can apply to these object characteristics:

Transformations—Tween between objects with 
different rotation, scaling, or skew transformations.

Opacity—Tween between opacity settings of the same 
opacity type.

Live Effects—Tween between settings of the same Live 
Effects. To tween:

1 Select objects to be tweened.

Select a symbol and one or more of its instances 
or select two or more instances of the same 
symbol object.

2 Choose Insert > Tween Instances.

3 Enter the number of tween steps in the Tween 
Instances dialog box and click OK.

Check Distribute to frames to distribute the 
tweened objects to separate animation frames.

Tweened from 100% opacity to 25% opacity.
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Compositing
Compositing is the process of varying the transparency 
or color interaction of two or more overlapping objects 
to create a variety of graphic elements. 

Using the Object inspector

Use the Object inspector to adjust the opacity of selected 
objects and to apply blending modes. A setting of 100 
renders an object completely opaque. A setting of 0 
(zero) renders an object completely transparent.

Using blending modes

Blending modes manipulate the color values of 
overlapping objects to create effects. They also add a 
dimension of control to the opacity effect.

Choosing a blending mode applies it to the entire 
appearance of selected objects. Objects within a single 
document or a single layer can have blending modes that 
differ from other objects within the document or layer. 
To set a default blending mode for newly drawn objects, 
choose Edit > Deselect, then choose a blending mode.

When objects with different blending modes are 
grouped, the group’s blending mode overrides individual 
blending modes. Ungrouping the objects restores the 
objects’ individual blending modes.

A blending mode has four elements:

Blend color—The color or colors of the object to which 
the blending mode is applied.

Opacity—The opacity of the object to which the 
blending mode is applied.

Base color—The color of pixels underneath the blend 
color.

Result color—The result of the blending mode’s effect 
on the base color or colors.

Adjust opacity.
Choose a blending mode.

Set opacity and choose a blending mode in the Object inspector.
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Blending mode behavior

◆ In object mode, a blending mode affects the 
selected object.

◆ In image edit mode, a blending mode affects the 
floating selection of pixels.

◆ In image edit mode without a floating selection, a 
blending mode affects the brushes and fills of 
subsequently drawn objects.

◆ The effect of a blending mode in image edit mode 
describes how new pixels blend against other pixels 
in the same image.

For more information on blending modes, including 
examples, see Fireworks Help.

Choose To

Normal Apply no blending mode.

Multiply Multiply the base color by the blend 
color, resulting in darker colors.

Screen Multiply the inverse of the blend color 
by the base color, resulting in a 
bleaching effect.

Darken Select the darker of the blend color and 
base color to use as the result color. 
This color replaces only pixels that are 
lighter than the blend color.

Lighten Select the lighter of the blend color and 
base color to use as the result color. 
This color replaces only pixels that are 
darker than the blend color.

Difference Subtract the blend color from the base 
color or the base color from the blend 
color. The color with less brightness is 
subtracted from the color with more 
brightness.

Hue Combine the hue value of the blend 
color with the luminance and 
saturation of the base color to create 
the result color.

Saturation Combine the saturation of the blend 
color with the luminance and hue of 
the base color to create the result 
color.

Color Combine the hue and saturation of the 
blend color with the luminance of the 
base color to create the result color, 
preserving the gray levels for coloring 
monochrome images and tinting color 
images.

Luminosity Combine the luminance of the blend 
color with the hue and saturation of 
the base color to create the result 
color.

Invert Invert the base color to create the 
result color.

Tint Add gray to the base color to create 
the result color.

Erase Remove all base color pixels, including 
those in the background image, to 
reveal the canvas color.
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Masking

In Fireworks, masks are created by grouping two objects 
together as a mask group. The top object acts as the 
mask, while the bottom object is the image to be masked. 
Create masks from any element in Fireworks, including 
images, path objects, or text. A mask group has two 
primary uses:

◆ Pasting an object inside another object, so that the 
top object continues to be visible. This is known as a 
paste inside or clipping path in FreeHand. It crops 
an image to its shape.

◆ Pasting an object inside another object, so that the 
top object is not visible and the alpha of each pixel in 
the top object becomes part of the mask or filter of 
the bottom object. This is known as a layer mask in 
Photoshop. A typical application of a mask is to use 
the top image to define gradient transparency for 
the bottom object.

Image and clipping path

Paste inside

Mask group
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To create a clipping path mask:

1 Position the object to be pasted in front of the 
destination path.

2 Cut the object to the Clipboard.

3 Select a path inside which the object on the 
Clipboard is to be pasted.

4 Choose Edit > Paste Inside.

The object on the Clipboard is pasted inside the 
selected object in the same position from which it 
was cut. The Object inspector identifies this 
element as a clip group.

To create a mask similar to a layer mask:

1 Position two or more objects, one on top of the 
other, so that the top object is the object to be 
used as the mask and the bottom object is the 
object to be masked.

2 Select the objects.

3 Choose Modify > Mask Group.

The top object is converted to an alpha object whose 
grayscale values are used to mask the bottom object.

Note: The top object need not be a path for this type of 
masking. It can be an image.

Editing objects within a mask group

Subselect objects within a mask group to edit or 
move them. Use the Subselection tool or double-click 
the mask group handle to select the contents of the 
mask group.

◆ To convert a paste inside into a mask group, select 
the paste inside, choose Window > Object, and then 
choose Clip to Top Object’s Image.

◆ To convert a mask group into a paste inside, select 
the mask group, choose Window > Object, and then 
choose Clip to Top Object’s Path.
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Fireworks in the workflow
Although Fireworks greatly reduces the need for other 
applications within the graphic creation workflow, it is 
highly compatible with other applications associated 
with producing web graphics. 

◆ Import graphics created in applications such as 
FreeHand or Photoshop, and edit them using 
familiar tools and similar document-organization 
features such as layers and frames. 

◆ Export optimized graphics, HTML, and JavaScript 
for use in Dreamweaver or in a web browser. 

◆ Import and export a wide variety of file formats. 

◆ Use Export Preview to quickly determine the best 
balance of size and quality for exported graphics 
without switching to and from a browser. 

◆ Batch process all files within a folder and name and 
save export presets. 

Importing
Import graphics or text in any of four ways: 

◆ Import 

◆ Open 

◆ Drag and drop 

◆ Copy and paste 

Import File dialog box

To import a graphic using the Import File dialog 
box:

1 Choose File > Import. 

2 Select a file and click Open.

When available, a preview of the selected file is 
shown along with file information such as file type 
and file size. 

3 Position the import cursor where you want the 
upper-left corner of the object to appear. 

4 Click the mouse button to place the object at its 
default size. Click and drag to scale the object. 

Imported bitmap images are placed as image objects. 
For more information about image objects, see 
“Image edit mode basics” on page 52.

Fireworks can import these formats:

◆ PNG 

◆ GIF 

◆ JPEG 

◆ BMP 

◆ TIFF 

◆ xRes LRG 

◆ ASCII 

◆ RTF 
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◆ Adobe Photoshop 3, 4, 5 

◆ Adobe Illustrator 7 

◆ Macromedia FreeHand 7, 8 

◆ CorelDRAW 7 

◆ Targa 

Drag and drop

Drag and drop objects, images, or text into Fireworks 
from any application that supports OLE Drag and 
Drop (Windows) or Macintosh Drag and Drop 
(Macintosh), such as: 

◆ Macromedia FreeHand 7, 8 

◆ Macromedia Flash 3

◆ Adobe Photoshop 4, 5 

◆ Adobe Illustrator 7, 8 

◆ Microsoft Office 97, 98

◆ Microsoft Internet Explorer 3, 4 

◆ Netscape Navigator 3, 4 

◆ CorelDRAW 7, 8 

To drag and drop into Fireworks:

1 Select a graphic in another application and drag 
it over an open Fireworks document. 

2 Position the cursor where you want to drop the 
selection and release the mouse button. 

Copy and paste

Objects that are pasted into Fireworks from another 
application are centered in the active document. When 
using copy and paste, Fireworks accepts these formats 
from the Clipboard: 

◆ FreeHand 7, 8 

◆ Illustrator 

◆ PNG 

◆ PICT (Macintosh) 

◆ DIB (Windows) 

◆ BMP (Windows) 

◆ ASCII text 

Resampling

Resampling adds pixels to or subtracts pixels from a 
resized image to match the appearance of the original 
image as closely as possible. Resampling an image to a 
higher resolution typically causes little data or quality 
loss. Resampling to a lower resolution always causes data 
loss and a drop in quality. 

When pasting an image with a resolution that differs 
from the destination Fireworks document, Fireworks 
displays a dialog box asking if the image is to be 
resampled: 

◆ Click Resample to maintain the pasted data’s 
original width and height, adding or subtracting 
pixels as necessary. 

◆ Click Don’t Resample to keep all the original pixels, 
which may make the relative size of the pasted 
image larger or smaller than expected. 
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Pasting

Each edit mode handles pasted data differently: 

◆ In object mode, pasting a pixel selection yields a 
rectangular image object, which uses alpha 
transparency to maintain the appearance of the 
selection. 

◆ In image edit mode, pasting a vector graphic or 
image object pastes a pixel selection that remains 
floating until it is deselected. When deselected, the 
selection becomes part of the current image. 

Importing text

Import text into Fireworks using the same methods for 
importing graphics. Fireworks imports two text formats: 
RTF (Rich Text Format) and ASCII (plain text). 

RTF

Choose File > Open or File > Import to import RTF text. 
When RTF text is imported, Fireworks maintains these 
attributes: 

◆ Font 

◆ Size 

◆ Style (bold, italic) 

◆ Alignment (left, right, center, justified) 

◆ Leading 

◆ Baseline shift 

◆ Range kerning 

◆ Horizontal scale 

◆ First character's color 

All other RTF information is ignored. 

Note: Fireworks cannot import RTF text using copy and 
paste or drag and drop. 

ASCII

Import ASCII text using any of the four import 
methods. Imported ASCII text is set to the default font, 
12 pixels high, and uses the current fill color. 

Importing Fireworks files

Import saved Fireworks files into the current drawing 
layer of an active Fireworks document. When 
importing a Fireworks file: 

◆ Hotspot objects and slice objects are placed on the 
Web Layer of the Layers panel. For more 
information about URLs, see “Creating an image 
map” on page 116.

◆ Layers within the imported file are merged. 

◆ In files with multiple frames, only the first frame is 
imported. 

Imported objects from a Fireworks file are selected when 
they are first imported so they may be easily grouped, 
moved, or distributed immediately after import. 
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Importing FreeHand, Illustrator, or 
CorelDRAW files

Import objects or files from Macromedia FreeHand, 
Adobe Illustrator, or CorelDRAW using any four of 
the import methods. When opening or importing a 
vector-based file, use the Vector File Options dialog box 
to define specific settings. Vector File Options do not 
apply when pasting or dragging.

Scale—Specify the scale percentage for the imported file.

Width and Height—Specify in pixels the width and 
height of the imported file.

Resolution—Specify the resolution of the imported file.

File Conversion—Specify how multipage documents 
are handled when imported.

◆ Open a page—Import only the specified page.

◆ Open pages as frames—Import all the pages 
from the document, and place each on a separate 
frame in Fireworks.

◆ Remember layers—Maintain the layer structure 
of the imported file.

◆ Convert layers to frames—Place each layer of 
the imported document onto a separate frame in 
Fireworks.

Include Invisible Layers—Import objects on layers 
that have been turned off. Otherwise, invisible layers 
are ignored.

Include Background Layers—Import objects from 
the document’s background layer. Otherwise, the 
background layer is ignored.

Render as images—Rasterize complex groups, blends, 
or Tiled fills and place them as a single image object in a 
Fireworks document. Enter a number in the field to 
determine how many objects a group, blend, or Tiled fill 
can contain before it is rasterized during import.

Anti-Aliased—Anti-alias imported objects. 

Note: Use Modify > Edge after importing to change 
selected objects to Anti-Alias or Hard Edge.

Importing Illustrator files

These vector file import options are not available when 
importing Illustrator files: 

◆ File Conversion > Page options.

◆ File Conversion > Include Background layers.

◆ Render as images > Blends over <number> steps.

Importing CorelDRAW files

Fireworks can import uncompressed CDR files that 
have been created with CorelDRAW 7 or 8 for 
Windows. These vector file import options are not 
available when importing CDR files: 

◆ File Conversion > Include Background layers.

◆ Render as images > Blends over <number> steps.

◆ Render as images > Tiled Fills over <number> objects.

Note: Fireworks cannot open or import CMX files or 
compressed CDR files. 
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Because CorelDRAW supports a different set of 
features than Fireworks, the following changes occur 
when importing CDR files:

Master pages—The contents of the master pages are 
repeated on each Fireworks frame. 

Blends—Fireworks only imports the two end objects of 
the CorelDRAW blend. The objects are grouped 
after import. 

Dimensions—Converted to vector objects. 

Text—Only basic text is imported. Most character and 
paragraph parameters are unsupported. 

Colors—Colors are generally converted to RGB colors if 
possible. 

Importing animated GIFs

Choose File > Open to import animated GIFs. When 
opening an animated GIF, Fireworks places each frame 
of the animated GIF on a separate frame in the 
Fireworks document. Also, Fireworks creates a 
Background layer based on the common pixels found in 
all the imported frames. 

Importing from a scanner or digital 
camera

Import images from scanners or digital cameras directly 
into Fireworks using TWAIN modules or Photoshop 
Acquire plug-ins (Macintosh). Images imported into 
Fireworks from a scanner or digital camera are opened 
as a new document. 

To import an image from a scanner or digital 
camera:

1 Connect the scanner or camera to your 
computer.

Follow the connection instructions included with 
the camera or scanner to ensure correct installation.

2 Install the software that accompanies the 
scanner or camera.

Fireworks cannot scan images unless the 
appropriate software drivers, modules, and 
plug-ins have been installed. Again, consult the 
documentation for the scanner or camera for 
specific instructions on correct installation 
and setup.

3 In Fireworks, choose File > Scan and select a 
TWAIN module or Photoshop Acquire plug-in 
that corresponds to the device from which you 
are importing an image.

For most TWAIN modules or acquire plug-ins, 
additional dialog boxes will ask you to set options 
for the module or plug-in.

4 Follow instructions and make settings as needed.

For more specific instructions about settings and 
options, consult the documentation for the 
TWAIN module or acquisition plug-in that you 
are using.

The imported image is opened as a new Fireworks 
document.

Using Photoshop Acquire plug-ins 
(Macintosh)

To use Photoshop Acquire plug-ins in Fireworks, one of 
two things must be done during or after installation:

◆ Install the Photoshop Acquire plug-in in the 
Fireworks 2\Settings\Xtras folder.

◆ Install the Photoshop Acquire plug-in in the 
Photoshop Plug-ins folder or in another folder. 
Then, in Fireworks, choose File > Preferences, click 
the Folders tab, check Photoshop Plug-Ins and 
browse to the folder containing the Acquire plug-in.
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Exporting
Finding a good balance between quality and speed 
when exporting a graphic for the web can be a daunting 
task. Fireworks offers several methods to help develop 
top-quality graphics with the lowest possible file size. 

Fireworks exports graphics through these methods: 

◆ Drag and drop 

◆ Copy and paste 

◆ Export 

◆ Export Area tool 

◆ Export as Files 

◆ Export as CSS Layers 

◆ Export Again 

◆ Export Wizard 

To export a graphic:

1 Choose File > Export to display the Export 
Preview. 

2 Choose settings. 

3 Click Next. 

4 In the Export dialog box, type a name for the file, 
select slicing options and HTML style, select the 
destination, and click Save (Windows) or Export 
(Macintosh).

Choose File > Export Again to quickly export a file using 
its previous export settings. Export Again bypasses the 
Export Preview. 

Export dialog box

Click Next in the Export Preview to open the Export 
dialog box. 

Use the Export dialog box to:

◆ Select a location for exported files.

◆ Provide a base name for automatically named 
exported files (for example, slice objects).

◆ Choose slicing options.

◆ Choose HTML style.

◆ Select a location for associated HTML.

◆ Access the Document Properties dialog box using 
the Setup button.
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Export Wizard

Use the Export Wizard (File > Export Wizard) to help 
optimize your exported files. Answer questions about 
the file's destination and intended use, and the Export 
Wizard suggests file type and optimization settings. In 
addition, the Export Wizard attempts to optimize an 
exported file to fit within the size constraint you set in 
the Target export file size field.

Constrain file size from the Export Preview using the 
Export to Size Wizard. Click the Export to Size button 
to open the Export to Size Wizard and enter a file size.

The Export to Size Wizard attempts to match the 
requested file size using the following methods:

◆ Adjusting JPEG quality.

◆ Modifying JPEG smoothing.

◆ Altering the number of colors in 8-bit images.

◆ Changing dither settings in 8-bit images.

◆ Enabling or disabling Optimization.

Slicing options available:

◆ None: Use no slice options when exporting.

◆ Use Slice Objects: Export slice objects as defined 
using the Slice tool.

◆ Slice Along Guides: Slice exported objects along 
existing guides.

Default HTML styles available:

◆ None

◆ Dreamweaver Library.lbi

◆ Dreamweaver 2

◆ Fireworks

◆ FrontPage

◆ Generic

For more information about using HTML styles, see 
“Exporting HTML with a Fireworks file” on page 130.

Export Commands 

Export to Size button

To Do this

Export Open the Export Preview and 
choose export settings.

Export Special > 
Export As Files

Export images contained on 
multiple frames, layers, or 
slices of a document as 
individual images.

Export as CSS Layers Export document as Dynamic 
HTML.

Export Again Export the current document 
using the previous export 
settings.

Export Wizard Launch the Export Wizard to 
help select optimal export 
settings. 

Export Area tool Export a specific portion of an 
image.
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Using Export Preview
Use the Export Preview to try different settings for the 
chosen file format, compare the effects of different color 
palettes and transparencies, customize palettes and 
animation settings, and preview the file pixel-for-pixel as 
it will be exported.

Check to optimize
the exported graphic.

Choose a color
depth.

Choose a color
palette.

Check to dither
the image.

Choose a format.

Preview and
edit the colors
in the image’s

palette.

Use frame 
controls to 
preview 
frames or play 
an animated 
GIF.

Use the Magnification 
tool to magnify the 
preview area.

Enter a maximum number of colors for the exported file.

Preview up to four previews.

Choose the 
number of 
views shown 
in the preview 
area.

Add to or
remove colors

from the
transparency.

Click to edit, save, or load a palette.

Choose the
type of

transparency.

Click to launch the
Export Wizard.

Click to launch the
Export to Size

Wizard.
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Preview area

The preview area displays the graphic exactly as it will be 
exported and estimates file size and download time with 
the current export settings.

When exporting animated GIFs or JavaScript rollovers, 
the estimated file size is a total of all frames.

Note: To speed redraw of the Export Preview, uncheck 
Preview. To stop the redraw of the preview area when 
changing settings, press Esc.

Split view

Click a button to divide the preview area into one, 
two, or four previews. Each preview window can 
display a preview of the exported graphic with different 
export settings. 

Because each preview accurately reflects the exported 
graphic, you can use split views to compare different 
settings and create the smallest file size while 
maintaining an acceptable level of quality. 

Magnification and pan control

Choose the Magnify tool, and then click to magnify the 
preview. Use Alt-click (Windows) or Option-click 
(Macintosh) to zoom out.

Choose the Pointer tool and drag in a preview to pan.

When multiple views are open, all previews are 
magnified to the same level and all previews pan 
simultaneously to display the same portion of the image. 

Saving export presets

Save Export Preview settings for future exports or batch 
processing. Settings within the Options panel are 
included in the saved export settings. In addition, the 
Animation settings are saved when the export file 
format is animated GIF. When applying export presets 
to animated GIFs, ensure that the imported presets 
contain an equal or greater number of frames; otherwise, 
remaining frames in the animation will be set to the 
Fireworks default settings, which are unspecified 
disposal, 20/100 delay. 

Applying preset export settings does not override 
custom cropping and scaling previously applied within 
the Export Preview. 

To save export presets:

1 Click the + in the preview area of the Export 
Preview. 

2 Type a name for the export preset and click OK. 

The preset is saved in the 
Fireworks 2\Settings\ Export Settings folder. 

To apply saved export presets to a preview, choose a 
preset from the Export Presets pop-up in any 
preview area. To delete an export preset, remove or 
delete its file from the Fireworks 2\Settings\Export 
Settings folder.

Choose a saved set of options for
the selected export preview.

Click to save 
the export 
settings 
used in the 
active view.

View and
compare

file size
and

download
time

estimates
for the
related

preview.

Check to preview the results 
of the chosen export settings.

Preview area of the Export Preview dialog box

Split View buttons on the Export Preview
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Options panel

Use the Options panel to choose file format and format-
specific settings for exporting. Although some settings 
are common to many formats, other settings are unique 
to a single format.

Format

Select the file format for the exported image. Fireworks 
exports these formats:

◆ GIF 

◆ JPEG 

◆ PNG 

◆ TIFF 

◆ PICT (Macintosh) 

◆ xRes LRG 

◆ BMP 

Color depth

Color depth is the number of colors used in the exported 
graphic. Although most web images are exported in 8-
bit color (256 colors), Fireworks exports some formats 
with 24-bit and 32-bit depths. 

Higher color depths create larger exported files, and are 
typically not ideal for web graphics. Use JPEG with 24- 
or 32-bit color depths when exporting photographic 
images with continuous tones or complex gradient 
blends of colors.

Bit depth Maximum number of 
colors

Fireworks export 
formats supporting 
this bit depth

1-bit 2 colors GIF, PNG, PICT, 
TIFF, LRG

8-bit 256 colors GIF, PNG, PICT, 
BMP, TIFF, LRG

24-bit 16.7 million colors 
(millions)

JPEG, PNG, PICT, 
BMP, LRG, TIFF

32-bit 16.7 million colors 
and an 8-bit alpha 
channel

PNG, LRG, TIFF
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Working with color palettes
Color palettes are groups of colors, 8-bit or less, which 
are stored within an image file or as a separate palette file. 

◆ Use palettes when creating graphics to control 
which colors are available. For example, if you have a 
group of five corporate colors, you can create a 
palette with only those colors so that they may be 
quickly and precisely selected when drawing.

◆ Use palettes when exporting a graphic to limit the 
colors included in the exported file.

Using palettes for drawing and creating

When creating an image that will be exported with a 
palette, draw or create an image using colors from the 
palette you will use during export. Since the Fireworks 
document window always displays the image in millions 
of colors (24-bit), using a palette when creating an image 
can help minimize color shifting or dithering when you 
force the image to 8-bit color or less during export. 

If you are not sure which color palette will be used for 
the exported image, use the default palette for the 
Swatches panel, which is the Web 216 palette. 

To replace all the colors in the Swatches panel 
with colors from a palette:

1 In the Swatches panel Options pop-up, choose 
Replace Swatches.

2 Browse to a saved color palette or GIF image 
file that contains colors you want to add, and 
click OK.

Colors from the saved palette or GIF image file 
appear in the Swatches panel.

To add colors from a palette to the Swatches 
panel:

1 In the Swatches panel Options pop-up, choose 
Add Swatches. 

2 Browse to the saved color palette or GIF image 
file that contains colors you want to add, and 
click OK.

Colors from the saved palette or GIF image file are 
added to the colors in the Swatches panel.

Note: Adding or removing colors from the Swatches 
panel does not alter colors already appearing in the 
document.

Fireworks does not restrict itself to colors in the 
Swatches panel when drawing. When creating glows, 
feathered edges, anti-aliased edges, gradients, or other 
transparent effects, colors other than those that appear in 
the Swatches panel are used. This may cause dithering or 
color shifting when exporting with some palettes. To 
prevent dithering or color shifting, limit use of gradients, 
export using an adaptive palette, or export in a file 
format that supports higher than 8-bit color.

For more information about the Swatches panel, see 
“Using the Swatches panel” on page 57.
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Using palettes for exporting

Optimize or customize palettes during export using the 
Options panel of the Export Preview. When exporting 
an image with a color depth of 8-bits or less, palette 
options appear in the Export Preview. Choose a palette 
from the Palette pop-up, and then optimize it as desired. 

These palettes are available by default: 

Adaptive—A custom palette derived from the actual 
colors in the document. Adaptive palettes most often 
produce the highest quality image with the smallest 
possible file size. 

WebSnap Adaptive—An adaptive palette in which 
colors that are near in value to web-safe colors are 
converted to the closest web-safe color. 

Web 216—A palette of the 216 colors common to both 
Windows and Macintosh computers. This palette is 
often called a web-safe or browser-safe palette, because it 
produces fairly consistent results on different platforms 
and with different browsers. 

Exact—A palette containing the exact colors used in the 
image. Only images created with 256 colors or less may 
use the Exact palette. If the image contains more than 
256 colors, the palette reverts to Adaptive. 

System (Windows) and System (Macintosh)—Each 
palette contains the 256 colors as defined by the 
Windows or Macintosh platform standards. 

Grayscale—A palette of 256 or fewer shades of gray. 
Using this palette will effectively convert the exported 
image to grayscale. 

Black and White—A two-color palette that converts 
the image to black and white. 

Uniform—A mathematical palette based on RGB pixel 
values. 

Custom—A palette that has been modified or loaded 
from an external palette or a GIF file. Choose Load 
Palette from the Export Preview Options pop-up to 
load a palette. 

Setting the number of colors in the 
palette

Enter a number in the Number of Colors pop-up to set 
the maximum number of colors desired in the exported 
image. The number below the entry field displays the 
actual number of colors used in the image. Create 
smaller files by reducing the number of colors. 

Setting the number of colors to a number lower than the 
actual number of colors in an image forces some colors 
to be lost, beginning with the least used colors. Pixels 
containing lost colors will be converted to the closest 
color remaining in the palette.

Number of Colors pop-up
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Editing colors in a palette

The palette view displays colors used in the current 
preview of the image when working in 8-bit color or less. 
Use the palette view to preview or modify the palette for 
an image. The preview window updates to reflect 
changes made in the palette view. 

 

Select a color by clicking it on the palette or in the 
preview area. To select multiple colors, hold down 
Control (Windows) or Command (Macintosh) as you 
click colors. Hold Shift and then click a second color to 
select a range of colors. 

Locking colors

Individual colors may be locked so that they are not 
removed or changed when changing palettes or reducing 
the number of colors in a palette.

Locked colors are indicated by a small square in the 
lower-right corner of the swatch, as shown here:

This symbol Indicates

The color has been edited.
Note: This does not change the color 
in the document, only for export.

The color is locked.

The color is transparent.

The color is web-safe.

The color has multiple attributes. In 
this case, the color is web-safe, 
locked, and it has been edited.

To Do this

Lock a selected color Click the Lock button on the 
bottom of the Palette view or 
choose Lock Color from the 
Options pop-up.

Unlock a color Select a color and then click 
the Lock button on the 
bottom of the Palette view or 
choose Lock Color from the 
Options pop-up.

Unlock all colors Choose Unlock All Colors from 
the Options pop-up.
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If you switch to another palette after colors have been 
locked, locked colors are added to the new palette 
according to the following table:

Editing colors

Change a color in the palette by editing it in the Export 
Preview. Editing a color replaces all instances of that 
color in the exported image. Editing does not replace the 
color in the original image; however, edited colors are 
retained the next time the Export Preview is accessed.

To edit a color, select the color, and then click the Edit 
button below the Preview area or choose Edit from the 
Options pop-up. Change the color using the system 
color picker. The new color replaces every instance of the 
replaced color in the preview area.

Edited colors are indicated on the Palette view with a 
small square in the lower-left of the swatch, as shown 
here:

Note: Use shortcut menus to edit colors. Right-click 
(Windows) or Control-click (Macintosh) a color in the 
palette to display a shortcut menu of edit options for 
the color.

When switching to Locked colors are

Adaptive or 
WebSnap Adaptive

Forced into the new palette.

Web 216 or Uniform Added to the palette if not 
already present. Only the first 
40 locked colors from the 
previous palette are added. 
Additional locked colors are 
discarded.

Exact Added until the total number 
of colors in the palette equals 
256. If the addition of locked 
colors causes the total number 
of colors in the palette to 
exceed 256, the palette 
switches to WebSnap 
Adaptive and locked colors are 
included accordingly.

Black/White, 
Macintosh, 
Windows, or 
Grayscale

Discarded.

Custom Added until the total number 
of colors in the palette equals 
256. Additional locked colors 
are discarded.

Click to open the System color picker.
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Removing edits to colors

Remove any edit made to a color by selecting the color 
and choosing Remove Edit from the Options pop-up. 
Also, individual edits may be removed by selecting a 
color and then deselecting the button of the edit you 
wish to remove.

Setting web-safe colors

Web-safe colors are colors that are common to both 
Macintosh and Windows platforms. These colors are 
not dithered when viewed in a web browser on a 
computer display set to 256 colors. 

Web-safe colors are indicated on the Palette view with 
a small diamond in the center of the swatch, as 
shown here:

Fireworks has several methods of applying and using 
web-safe colors.

◆ Choose the Web 216 palette to force all colors to 
web-safe colors.

◆ Choose the WebSnap Adaptive palette to create an 
adaptive palette in which colors that are near in 
value to web-safe colors are converted to the closest 
web-safe color.

◆ Select a color and click the Web-Safe button, or 
choose Snap to Web-Safe from the Options pop-up 
to force that color to its closest web-safe equivalent.

Changing colors to web-safe in the Export Preview does 
not effect the actual image, only the exported version of 
the image. However, all colors set to web-safe are 
retained each time Export Preview is used.

Saving a palette

Custom palettes may be saved as Photoshop palette 
files. Saved palettes may be used with other Fireworks 
documents, or in other applications that support 
Photoshop palettes, such as Adobe Photoshop, 
Macromedia FreeHand, or Macromedia Director.

To save a custom color palette: 

1 Choose Save Palette from the pop-up next to 
the Format pop-up. 

2 Type a name for the palette and choose a 
destination folder. 

3 Click Save. 

The saved palette file can be loaded into the 
Swatches panel or used when exporting other 
documents. 

Using Dithering

Use dithering to approximate colors not in the current 
palette. Dithering is especially effective when exporting 
images with complex blends or gradients or when 
exporting photographic images to an indexed image 
format, such as GIF. 

Note: Dithering can greatly increase file size, especially 
the size of a GIF. 

To dither the exported image, check Dither in the 
Export Preview, then enter a percentage value in the 
Dither Amount field. Higher numbers increase 
dithering and file size. 

Web-safe button
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Adjusting transparency

Use the Transparency tools on the Options panel to 
specify which colors are transparent in exported GIFs or 
PNGs. Also, make colors transparent by selecting them 
in the Palette view and then clicking the Transparency 
button. A gray and white checkerboard denotes 
transparent areas in both the preview area and the 
palette view.

Setting colors to transparent does not effect the actual 
image, only the exported version of the image. However, 
all colors set to transparent are retained each time 
Export Preview is used.

Select any of three transparency types:

None—No transparency is saved with this file. 

Index Color—Select a color or colors for the 
transparency using the transparency eyedropper tools. 
By default, this color is the document’s canvas color. 

Alpha Channel—Choose to define transparency with a 
document’s alpha channel. Only PNGs support 
multilevel alpha transparency. 

Transparency Eyedropper tools

Use the transparency eyedropper tools to add or remove 
colors from the transparent area of the exported image. 
Changing transparency does not affect the original 
image. It only affects the exported image. 

Using a matte color

Use a matte color to redefine the background color of 
the image when exporting. 

When viewing transparent web graphics in a browser, 
an off-colored ring of pixels often appears around the 
borders of the non-transparent parts of the graphic. This 
visual mistake is created when the graphic is created over 
a background color that differs from the background 
color of the web page on which the graphic is viewed. 

Use To

Select 
Transparency tool

Select a single color for 
transparency by clicking in the 
preview area or the palette 
display.

Add to 
Transparency tool

Add colors to the transparency 
by clicking in the preview area 
or palette display.

Subtract from 
Transparency tool

Remove colors from the 
transparency by clicking in the 
preview area or palette display.
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One solution is to set the Fireworks canvas color to be 
the same as the background color of the web page. 
Another solution is to use the Matte color in the Export 
Preview to change the canvas color during export to 
match the background color of the web page. This way, a 
commonly reused image can quickly be re-exported to 
match a variety of web page background colors. 

To set the matte color, select a color from the Matte pop-
up in the Export Preview. The matte color replaces the 
canvas color in the exported image.

Optimize

Check Optimize to create the smallest file with the least 
number of colors. Uncheck Optimize to include all 
colors in the palette, whether or not they are used in the 
exported image.

Interlacing

Check to make the exported GIF or PNG interlaced. 
When viewed in a web browser, interlaced images 
quickly appear at a low resolution and then transition to 
full resolution as they continue to download. 

File panel

Use the File panel to set the scale or exported area of the 
exported document. 

Scale

The Scale settings increase or decrease the size of the 
image when exporting. Use either of two scaling 
methods: 

◆ Enter a percentage or choose from the pop-up slider 
to increase or decrease the exported image size by a 
percentage. The W (width) and H (height) pixel 
dimensions update automatically. 

◆ Enter numbers in the W and H fields to scale the 
graphic to a specific pixel width and height. 

Check Constrain to keep width and height proportional 
when scaling. 

Animation panel

Use the Animation panel when exporting an animated 
GIF. 

For more information about the Animation panel, see 
“Previewing an animation” on page 128. 
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Export Area
Use the Export Area tool to export a part of a Fireworks 
graphic.

To export a portion of a document:

1 Choose the Export Area tool from the Toolbox. 

2 Click and drag a marquee over the portion of the 
document to export.

When you release the mouse button, the export area 
remains highlighted by a marquee. Drag any of 
eight marquee handles to resize the export area. 

◆ Hold down Shift while dragging to resize the 
export area marquee proportionally. 

◆ Hold down Alt (Windows) or Option 
(Macintosh) while dragging to resize the 
marquee from the center. 

◆ Hold down Alt-Shift (Windows) or Option-
Shift (Macintosh) while dragging to constrain 
the proportions and resize from the center. 

3 Double-click inside the export area marquee or 
click the Export button on the Tool Options panel 
to open the Export Preview.

The Export Preview displays the area defined by the 
export area marquee. 

4 Adjust settings in the Export Preview and click 
Next. 

5 In the Export dialog box, type a file name and 
choose a destination folder, then click Save. 

To cancel without exporting, double-click outside the 
export area marquee, press Esc, or select another tool. 

Web export formats
GIF, JPEG, and PNG are graphic file formats that are 
common in web development because they are highly 
compressible, making for faster transfer across the 
Internet. However, a graphic’s visual integrity can 
vary from one format to another, depending upon 
each format’s method of compression. Therefore, base 
your choice of file format upon the design and use of 
your graphic.

GIF

Graphics Interchange Format, or GIF, is the most 
popular web graphic format. Although it can contain 
only 256 colors, GIF offers good, lossless image 
compression. Also, GIFs can contain a transparent area 
and multiple frames for animation. 

Compression

Lossless compression means that no image quality is lost 
when an image is compressed. A GIF compresses by 
scanning horizontally across a row of pixels, finding solid 
areas of color, and then abbreviating identical areas of 
pixels in the file. Therefore, images with repetitive areas 
of solid color compress best when saved as GIFs. A GIF 
is usually ideal for cartoon-like graphics, logos, graphics 
with transparent areas, or animations.

Note: Dithering or anti-aliasing GIF images produces 
larger files.

Export Area tool
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JPEG

JPEG is an alternative to GIF developed by the Joint 
Photographic Experts Group specifically for 
photographic images. JPEG supports millions of 
colors (24-bit). 

Compression

JPEG is a lossy format, which means that some image 
data is discarded when it is compressed, reducing the 
quality of the final file. However, image data can often be 
discarded with little or no noticeable difference in 
quality. When exporting a JPEG, use the Quality pop-
up slider in the Export Preview to determine how much 
quality is lost when compressing the file.

◆ Use a high percentage setting to maintain image 
quality but compress less, producing larger files. 

◆ Use a low percentage setting to yield a small file, but 
produce a lower-quality image.

Use the Export Preview to test and compare the 
appearance and estimated file size with different Quality 
settings for an exported JPEG.

Check either Optimized or Progressive to export the 
JPEG using optimized compression tables that can 
reduce file size.

Smoothing

Use smoothing to help lower the file size of JPEGs. 
Smoothing blurs hard edges, which do not compress 
well in JPEGs.

To use smoothing, select a level from the Smoothing 
pop-up in the Export Preview. Higher numbers produce 
more blurring in the exported JPEG, typically creating 
smaller files.

Sharpening color edges

Check Sharpen Color Edges to help preserve fine edges 
between two colors. Use Sharpen Color Edges when 
exporting JPEGs with text or hard color transitions to 
preserve the sharpness of these areas.

Progressive 

Check Progressive in the Export Preview to export a 
progressive JPEG. Progressive JPEGs, like interlaced 
GIFs, display at low resolution and then increase in 
quality as they continue to download.

The JPEG format is best for scanned photographs, 
images using textures, images with gradient color 
transitions, or any images that require more than 
256 colors.

Note: Many image editing applications cannot open 
progressive JPEGs.
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PNG

The Portable Network Graphic, or PNG, is the most 
versatile of the web graphic formats. However, not all 
web browsers can take full advantage of PNG 
characteristics. A PNG supports up to 32-bit color, can 
contain transparency or an alpha channel, and can be 
progressive. 

Web format comparison

Compression

PNG compression is lossless, even in high color depths. 
It compresses across rows and columns of pixels, yielding 
better compression than GIF, which only scans rows. A 
PNG can compress more than a GIF or JPEG of the 
same color depth and quality.

The PNG format is best suited for creating complex live 
transparency, high-color graphics, or better compressed 
low-color graphics.

GIF JPEG PNG

Color depth 8-bit maximum Up to 24-bit Up to 32-bit

Compression Lossless; compresses 
solid areas of color

Lossy; compresses subtle 
color transitions

Lossless

Transparency support Yes No Yes

Advantages Lossless compression
Transparency

Ability to control quality 
loss in compression
Excellent compression of 
photographic images

Lossless compression
Alpha transparency
High color support

Disadvantages Maximum of 256 colors
Does not compress 
gradient colors well

No transparency
Loss of quality when 
compressed

Not completely 
supported by common 
browsers without using 
plug-ins

Typical Uses Cartoon images
Logos
Animated banners

Scanned photographs
Images with complex 
textures
Images with complex 
gradient colors

Images with high 
numbers of colors
Complex, live 
transparency
Importing and Exporting 105



Other export formats
Fireworks exports other image formats which support 
up to 32-bit color. 

TIFF

Tagged-Image File Format, or TIFF, is used for high-
resolution images that are printed. TIFF is not suitable 
for use on the web because it is not highly compressible, 
yielding very large files. 

PICT

PICT is the standard image format for the Macintosh, 
and is typically used to transfer image data when 
copying and pasting from one application to another. 

BMP

BMP is the standard bitmap image format for 
Microsoft Windows. 

xRes LRG

xRes LRG is the format used by Macromedia xRes. 

Batch processing
Use batch processing to convert a group of graphic files. 
When batch processing, you can convert a selection of 
files to another format; convert a selection of files to the 
same format with different settings; and find and replace 
text, colors, URLs, or fonts.

To batch process files:

1 Choose File > Batch Process. 

2 Choose the files to process.

◆ Choose Current Open Files to perform the 
batch processing actions on all open documents.

◆ Choose Project Panel (All Files) to perform the 
batch processing actions on all files listed in the 
Project Log panel.

◆ Choose Project Panel (Selected Files) to 
perform the batch processing actions on the 
files currently selected in the Project Log panel.

◆ Choose Custom or click the edit button to 
display the Open Multiple dialog box and select 
files to batch process.

3 Choose Actions to perform during the batch 
process.

◆ Check Find and Replace and make settings in 
the Batch Replace dialog box to find and replace 
text, URLs, colors, or fonts in the batch 
processed files.

◆ Check Export and make settings in the Batch 
Export dialog box to change export settings, 
naming conventions, and scaling options 
applied to the batched files.
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4 Choose backup options for the original files.

To create backup copies of the original files, check 
Backup Original Files and make settings in the Save 
Backups dialog box. 

5 Click OK to run the batch process, or click Script 
to create a script of the current Batch Processing 
dialog box settings. 

A status message displays the number of files 
currently processed out of the total files appearing in 
the selected folder. 

Click Cancel to cancel the batch process. 

Finding and Replacing during a batch 
process

Check Find and Replace in the Batch Process dialog 
box to find and replace text, fonts, colors, or URLs 
when batch processing. When you check Find and 
Replace, the Batch Replace dialog box appears, 
prompting you to enter elements to find and replace 
during the batch process.

Batch Replace only affects the following file 
formats: Fireworks PNG, Illustrator, FreeHand, and 
CorelDRAW. Batch Replace does not affect GIFs 
and JPEGs.

To select elements to find and replace:

1 Select the type of element to find and replace 
from the Attributes pop-up. 

Choose either text, fonts, colors, or URLs. Different 
sub-options are available for each type of element.

2 In the Find field, enter or choose the specific 
element to find. 

3 In the Change to field, enter or choose the 
specific element to use to replace found items.

4 To add changed files to the Project Log, check 
Update Project Log.

5 Click OK to store Find and Replace settings and 
return to the Batch Process dialog box.

For more information about Find and Replace options, 
see “Find and Replace” on page 74.

Note: While URLs may be found and replaced during a 
batch process, no new HTML files are generated.

Changing file settings with a batch 
process

Check Export in the Batch Process dialog box to change 
file type, file optimization, or scaling settings when 
performing a batch process. When you check Export, 
the Batch Export dialog box appears, prompting you to 
enter settings to apply during the batch process.
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To set file conversion options for a batch process:

1 Choose the Export Settings to apply to files 
during the batch process.

◆ Choose Use Settings from Each File to use each 
file's previous export settings during the batch 
process. For example, when batch processing a 
folder of GIFs and JPEGs, the resulting files 
will still be GIFs and JPEGs, and the original 
palette and compression settings are used when 
exporting each file.

◆ Choose Custom to open the Export Preview 
and enter custom export settings for the batch 
process.

◆ Choose a preset export setting or a previously 
saved user export setting to use for the batch 
process. All preset settings and saved user export 
settings appear in the Export Settings pop-up.

2 Choose naming options for batch processed files.

◆ Choose Original Name to leave file names 
unchanged.

◆ Choose Add Prefix and enter text in the File 
Name field to add the specified text to the 
beginning of the file name of each batch 
processed file.

◆ Choose Add Suffix and enter text in the File 
Name field to add the specified text to the end 
of the file name before the file extension. For 
example, if “_thumb” is entered in the File 
Name field, then the file GETCO.gif would be 
renamed to GETCO_thumb.gif when it is 
batch processed.

3 Choose scaling options for the batch processed 
files.

◆ To scale images so that they each fit within a 
specified width and height range, choose Scale 
to Fit Area and enter Max Width and Max 
Height to scale batch processed files 
proportionally.

Note: Choose Scale to Fit Area to convert a group of 
images to thumbnail images.

◆ To scale to an exact width and height, choose 
Scale to Size, then enter a width and height.

To scale images proportionally but restrict width or 
height, choose Scale to Size, then enter or choose a 
value in either the Horizontal Scaling field or 
Vertical Scaling field, and then select Variable in the 
other. 

For example, to proportionally scale images to be 50 
pixels wide, type 50 in the Horizontal Scaling field 
and choose Variable in the Vertical Scaling field.

◆ Choose Scale to Percentage to scale images by 
percentage.

4 Click OK to store Batch Export settings and return 
to the Batch Process dialog box.
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Backing up batch processed files

Check Backup Original Files and make settings in the 
Save Backups dialog box to create backup copies of the 
original files in a batch process. Backup copies of files are 
placed in an Original Files subfolder in the same folder 
as each original file. If an Original Files subfolder already 
exists, the backup copies are placed in the existing folder.

In the Save Backups dialog box, choose either of two 
options:

◆ Choose Overwrite Existing Backups to keep only 
one backup copy of the previous file. When a new 
batch process is run, the old backup copy is replaced 
by the new backup copy.

◆ Choose Incremental Backups to keep copies of all 
the backup files. When a new batch process is run, a 
number is appended to the end of the file name of 
the new backup copy. For example, if a file called 
Picture.gif was being backed up using Incremental 
Backups, the first time the batch process runs, a file 
called Picture.gif would be copied to an Original 
Files subfolder. The second time a batch process is 
run on Picture.gif, a file called Picture-1.gif would be 
copied to the Original Files subfolder. The third 
time the file would be called Picture-2.gif, and so on.

Note: If Backup Original Files is unchecked, batch 
processing to the same file format overwrites the 
original file. However, batch processing into a different 
file format creates a new file in that format and does not 
move or delete the original file.

Using batch Scriptlets

Save batch process settings as cross-platform Scriptlets to 
easily recreate the batch process multiple times in the 
future.

To create a batch Scriptlet:

1 Choose File > Batch Processing.

2 Make settings in the Batch Processing dialog box.

Check the Actions to perform and make settings in 
the Batch Replace and Batch Export dialog boxes. 
Each time the saved Scriptlet is run, Fireworks asks 
which files are to be batch processed.

3 Click Script in the Batch Processing dialog box.

4 Enter a name and destination for the Scriptlet 
and click OK.

To run a batch Scriptlet:

1 Choose File > Run Script.

2 Choose the files to process with the Scriptlet.

For more information on choosing files, “To batch 
process files:” on page 106.

3 Click OK.

Running Scriptlets by dragging and 
dropping

Execute Fireworks Scriptlets by dragging and dropping 
them onto the Fireworks application.

◆ Dragging a Scriptlet file plus readable files to the 
Fireworks application launches Fireworks and 
immediately processes those files.

◆ Dragging multiple Scriptlet files and multiple 
graphic files onto Fireworks processes the graphics 
files multiple times, once for each script.

Using the Project Log

Use the Project Log to set up and track files that are part 
of a batch process. The Project Log lists any files changed 
by a batch process.

For more information about the Project Log, see 
“Managing searches with the Project Log” on page 75.
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Working with Dreamweaver
Macromedia Dreamweaver is a powerful visual web 
page authoring tool. Use Dreamweaver and Fireworks 
together to streamline your web design process. 

Fireworks images in Dreamweaver

The most common way to use Fireworks and 
Dreamweaver is to create web graphics and HTML in 
Fireworks and then include them on web pages created 
with Dreamweaver. Fireworks supports CSS 
(Cascading Style Sheet) layers and Dreamweaver 
libraries on export. Use CSS layer information in an 
HTML editor, such as Dreamweaver, to precisely 
position and animate objects. 

Use library items in Dreamweaver for content that 
appears on many pages in your site and for content that 
must be updated frequently. Library files must have an 
“.LBI” extension and must be located in a folder named 
Library at the site root. 

To place Fireworks images on a web page using 
Dreamweaver:

1 Export images from Fireworks to a web format.

Use GIF, JPEG, or PNG. 

2 Copy or move Fireworks images into your 
Dreamweaver project folder.

Although you can include a file from anywhere on 
your hard drive, it is easier to find and upload the 
files from Dreamweaver if you keep all your images 
in the same place in your Dreamweaver project 
folder. 

3 Click the location in the Dreamweaver document 
where you want to place an image, and then 
choose Insert > Image. 

4 In the Insert Image dialog box, choose an image 
and click OK. 

Be sure the path between the HTML document 
and the image exactly matches the path used on 
your web server. 

The link to the image is formed and the image 
appears on the Dreamweaver page much as it would 
appear in most web browsers. 

Note: Remember to upload the image to your web 
server along with the Dreamweaver HTML document. 
The image must be placed on the server in the same 
place in relation to the HTML document as it was in 
your project folder. 

Editing Fireworks images that are placed in 
Dreamweaver

Edit Fireworks images placed in Dreamweaver by 
launching Fireworks from Dreamweaver and editing 
the image. Edit GIFs and JPEGs in place in 
Dreamweaver using a Fireworks source file or optimize 
the image without affecting the source.

To launch and edit Fireworks graphics that are 
placed in Dreamweaver 2:

1 In Dreamweaver, choose Edit > Preferences > 
External Editor and set Fireworks as the Image 
Editor. 

2 In Dreamweaver, choose Window > Properties to 
open the Properties inspector if necessary. 

3 Select an image and click Edit on the Properties 
inspector.

Dreamweaver launches Fireworks, if it is not 
already running. 

4 Dreamweaver displays the following message: 
“Do you wish to use an existing Fireworks 
document as the source of <name of the 
graphic>?”

◆ If a Fireworks source PNG file exists, click Yes, 
browse to the PNG source file and click OK. 

◆ If no Fireworks source file exists or if you only 
want to edit the bitmap image placed in 
Dreamweaver, click No. 

5 Edit the graphic in Fireworks. 

6 Choose File > Update.

When Dreamweaver launches and edits a graphic 
in Fireworks, Update replaces Save on the File 
menu. Choosing Update exports the image using 
the last Export Preview settings, replaces the GIF or 
JPEG used by Dreamweaver, and saves the PNG 
source file if a source file was selected. 
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7 Close the Fireworks document. 

8 Switch to Dreamweaver.

The placed image updates to reflect the changes 
made in Fireworks. 

To launch and edit Fireworks graphics that are 
placed in Dreamweaver 1.2:

1 In Dreamweaver, choose Edit > Preferences and 
select Fireworks as an External Editor. 

2 In Dreamweaver, choose Window > Properties to 
open the Properties inspector if necessary. 

3 Select an image and click the Edit Image button 
on the Properties inspector.

Dreamweaver launches Fireworks, if it is not 
already running.

Dreamweaver searches the same folder as the 
graphic for a PNG file with the same name as the 
placed file in Dreamweaver, which it assumes is the 
Fireworks source file. 

4 Edit the graphic in Fireworks. 

5 Choose File > Export Again.

The Save As dialog box opens. 

6 In the dialog box, type a file name, choose a 
destination folder, and then click Save. 

7 Close the Fireworks document. 

8 Switch to Dreamweaver.

The placed image updates to reflect the changes 
made in Fireworks. 

Optimizing a graphic in Fireworks

In Dreamweaver 2, choose Command > Optimize in 
Fireworks to open and optimize the selected image in 
the Fireworks Export Preview. Make changes in the 
Export Preview and then click Update to save the image 
and return to Dreamweaver. Launch and optimize does 
not work in Dreamweaver 1 or in Dreamweaver 1.2. 

To include Dreamweaver libraries on export:

1 Choose Dreamweaver Library.lbi from the HTML 
Style pop-up. 

2 Save the file with an .LBI extension into a folder 
named “Library” located at the site root.

If necessary, Fireworks prompts you to create this 
folder. 

3 Click Export and save your files. 
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HTML and JavaScript

Fireworks generates HTML files when exporting image 
maps, JavaScript rollovers, or slices. Although 
Dreamweaver can generate the same data, it is often 
much faster to copy and paste the HTML generated 
from Fireworks into the Dreamweaver document. 

When copying JavaScript from Fireworks into 
Dreamweaver, be sure to: 

◆ Copy the HTML into the Dreamweaver HTML 
inspector and not directly into the Dreamweaver 
page. 

◆ Copy all of the JavaScript code, as well as the tags for 
placing the image. 

Note: Export as Dreamweaver libraries to simplify 
moving complex Fireworks elements into Dreamweaver.

Editing Fireworks images in other 
image editors

Fireworks PNG files can be edited in other image 
editors that support the PNG format. However, when 
other editors open and save a Fireworks PNG, the 
image is flattened and all path, frame, layer, and text 
information is lost.
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Producing web components
Fireworks has tools for creating many common web 
components, such as image maps, buttons, and animated 
GIFs. Also, Fireworks simplifies many web graphic 
preparation tasks, such as slicing large graphics into 
multiple files and creating JavaScript rollovers. 

Features for web production

There are eight primary features used to produce 
hotspots, slices, and rollovers. Those features are:

Hotspot Object tools—Draw hotspot objects in the 
shape of rectangles, circles, or polygons. 

Slice tool—Draw rectangular slice objects used to 
separate the image into multiple image files when 
exported.

Object inspector—Set specific properties of hotspot 
objects or slice objects.

Behaviors inspector—Assign interactive behaviors to 
web objects.

URLs Manager—Create, import, or export URLs to 
attach to web objects. 

Frames panel—Store alternative appearances for 
rollovers and rollover buttons, or for cels of an 
animation.

File > Document Properties—Change how 
Fireworks-generated HTML files or sliced graphics are 
named and make image map settings.

Export Preview—Optimize graphics for export, 
previewing different export settings before you export 
the graphic.

Web objects: The basics of 
web production
The key component of hotspot and rollover graphics in 
Fireworks is the web object. Web objects are objects 
drawn to designate an area of the graphic that triggers 
an event when the image is viewed in a browser. 

All web objects have these characteristics:

URLs—Attach URLs to web objects to create a link to 
another web page when clicked in a browser.

Alternate text—Enter alternate text to be displayed in 
a browser while the image is loading or unavailable.

Behaviors—Apply behaviors to web objects to create 
interactivity through JavaScript.

Web Layer—Web objects appear on the Web Layer of 
the Layers panel. The Web Layer is shared across all 
frames. The Web Layer may be locked or hidden, but 
may not be deleted.

Fireworks has two types of web objects: the hotspot 
object and the slice object.

Hotspot objects—These are rectangles, circles, or 
polygons drawn using the Hotspot tools. Also, hotspot 
objects can be created from existing objects in a 
Fireworks document using the Insert > Hotspot 
command. Hotspot objects designate clickable regions 
for an image map or designate the event area for a 
rollover behavior.

Slice objects—These are rectangular web objects that 
slice the image into multiple image files when the image 
is exported. Also, slice objects define regions of the 
graphic that may be targeted by rollover behaviors.
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Creating web objects

Use the Hotspot tools or Slice tool to draw a web object.

Use an Insert menu command to create a hotspot or 
slice based on a selected object.

Setting web object properties

Use the Object inspector to view and change properties 
of selected web objects. Since slice objects and hotspot 
objects have slightly different characteristics, the Object 
inspector displays different controls when each type of 
object is selected.

Note: The color of the web object does not affect 
export. It only defines the color of the web object in 
Fireworks so you can categorize and label web objects.

Use the To

Rectangle Hotspot 
tool

Draw a rectangular hotspot 
object.

Circle Hotspot tool

Draw a circular hotspot object.

Polygon Hotspot 
tool

Draw a polygonal hotspot 
object.

Slice tool

Draw a slice object.

To Do this

Create a hotspot 
object in the exact 
shape of another 
object or objects

Select the object and choose 
Insert > Hotspot. If multiple 
objects are selected, a dialog 
box asks you to create either a 
single rectangular hotspot 
object that covers all the 
selected objects or multiple 
hotspot objects.

Create a slice object 
that completely 
covers a selected 
object or objects

Select the object and choose 
Insert > Slice. If multiple 
objects are selected, a dialog 
box asks you to create either a 
single slice object that covers 
all the selected objects or 
multiple slice objects.

Hotspot Object inspector

Choose a hotspot color.
Choose a hotspot shape.

Enter a URL.

Specify the frame or window 
where the link is to open.

Enter alternative text.

Slice Object inspector

Enter alternative text.
Choose a slice object color.

Choose an export preset.

Specify the frame or window 
where the link is to open.

Enter a URL.

Check to automatically name 
slices or enter a slice name.
Web Design Features 115



Creating an image map
An image map is a graphic with URLs assigned to 
hotspot regions of the graphic from within an HTML 
file. Clicking a hotspot in a web browser opens the web 
page to which the URL links.

Choosing an image map source graphic

A source graphic is the graphic over which an image 
map is laid. The graphic can be imported or created in 
Fireworks. When choosing a graphic on which to build 
an image map, choose one with elements that people are 
likely to perceive as hotspots.

Creating a hotspot

A hotspot is an area of a graphic that is linked to a URL. 
When a hotspot is clicked, the web browser jumps to 
the web page specified by the linked URL. In 
Fireworks, define hotspots by creating hotspot objects.

To create a hotspot:

1 Create or open a source graphic on which to 
place a hotspot. 

2 Choose a hotspot tool from the Toolbox.

Click and hold on the hotspot tool to select the 
Rectangle Hotspot tool, Circle Hotspot tool, or 
Polygon Hotspot tool. 

3 Create a hotspot region by dragging a hotspot 
tool.

4 On the Object inspector, enter a URL to which 
the hotspot will link, enter an alternative (alt) 
description, and enter a target.

Alternative descriptions and targets are optional.

5 Optionally, click the Overlay Color color well and 
choose a color for viewing on The Web Layer.

Setting image map options

After creating the image map, choose File > Document 
Properties to set additional options for it.

◆ Specify whether the image map is client-side, server-
side, or both.

◆ Choose a URL for parts of the image not defined by 
hotspot objects.

◆ Enter a description that will appear when the image 
is disabled or unavailable.

Hotspot tool group

Document Properties dialog box
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Client-side and server-side image maps

A client-side image map requires image map 
information to be stored within the HTML document. 
A client-side image map shows the actual URL in the 
status bar message at the bottom of the browser window. 

A server-side (NCSA) image map requires the image 
map information to be saved within a separate file stored 
on a server and accessed by a CGI script. This type of 
image map is far more complicated to set up, and is not 
supported by all servers. 

Server-side image map behavior varies from system to 
system, even among different systems using the same 
server. A server-side image map shows mouse 
coordinates at the bottom of the screen. 

Note: Contact your service provider to find out how 
your server handles server-side image maps. 

Exporting image maps

Export image maps just like you export other images. 
Make settings in the Export Preview and then click 
Next to open the Export dialog box. In the Export dialog 
box, choose an HTML Style format. This causes 
Fireworks to generate an HTML document when 
exporting the image. That HTML document will 
contain MAP information that defines the hotspot 
regions of the image map or it will contain a link to a 
MAP file, or both.

Exporting image maps can result in the following files: 

The HTML file—The suffix or extension HTM is added 
to the file name being exported.

The MAP file—Generated for server-side image maps, 
this file is created when the user specifies a Map Type of 
Both or Server-Side in the File > Document Properties 
dialog box.

For server side image maps, you must edit the exported 
HTML file and enter the URL path to the map file 
where it is placed on the server.

Slicing images when 
exporting
A common method of creating navigation bars or 
navigation graphics for web sites is to create a graphic 
and then cut it into pieces that are then reassembled on a 
web page using an HTML table. The graphic appears 
seamless in the web browser but is actually made up of 
multiple pieces, each a separate file. 

Using slicing to create a navigation graphic has several 
advantages.

◆ In HTML, creating a link from an entire image is 
often easier than using an image map.

◆ If a section of the graphic is updated frequently, such 
as today's date or a current news item, a single piece 
may be replaced rather than the entire graphic.

◆ Parts of a graphic can be optimized individually, 
resulting in optimum file size and quality.

◆ Slices designate a part of the image to swap out 
using a JavaScript rollover.

Slice objects as event areas

Use slice objects as the target, or event area, of behaviors. 
For example, use a slice to mark an area that is swapped 
with another image when a hotspot is triggered 
somewhere else in the image.

Creating a sliced image

In Fireworks, use the Slice tool to draw rectangular slice 
objects. Slice objects define parts of the image that are 
exported as individual files.
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Fireworks creates the smallest number of slices possible 
by intelligently combining sections of the image that do 
not contain slice objects.

Slice guides

Slice guides are automatically created when slice objects 
are drawn. They display exactly how the image will be 
divided when exported as slices. Slice guides cannot be 
edited like normal guides; they are only changed by 
adding, moving, or resizing slice objects.

Creating slices to fit one or more objects

Create slice objects based on the dimensions of a selected 
object or objects. Choose Insert > Slice to create a slice 
object that completely covers the selected object. 

If multiple objects are selected, choosing Insert > Slice 
will display a dialog box prompting you specify whether 
to create a single slice or multiple slices.

◆ Clicking Single creates a single slice object that 
covers all of the selected objects.

◆ Clicking Multiple creates a slice object for each 
selected object.

Exporting an image in multiple slices

1 Using the Slice tool, draw slice objects to define 
areas of the image you want to export as 
individual files with specific settings.

Alternatively, select an object and choose Insert > 
Slice to create a slice object that covers a selection.

Slice guides are displayed indicating how the image 
will be sliced when exported.

2 Set object properties for each slice object by 
selecting the slice object and then making 
changes on the Object inspector.

For more information about slice object properties, 
see “Setting web object properties” on page 115. 

3 Choose File > Export to open the Export Preview, 
set the default export settings for undefined 
slices, then click Next.

Slices that were assigned custom export settings use 
the custom settings rather than the settings made in 
the Export Preview during this step.

4 In the Export dialog box, choose a setting from 
the Slicing pop-up.

Choose Use Slice Objects to slice the image 
according to the slice objects.

Choose Slice Along Guides to slice the image 
according to regular guides (not slice guides).

Note: If you choose Slice Along Guides, slice objects will 
not be used for slicing the image, and any behaviors 
applied to slice objects will be ignored.

To Do this

Hide or view slice 
guides

Choose View > Slice Guides.

Change the color of 
slice guides

Choose View > Guide 
Options > Edit Guides and 
choose a new color from the 
Slice Color pop-up.

When a slice object is 
drawn, slice guides 
appear indicating how 
the image will be sliced 
into multiple files 
when exported.

Each slice is exported as 
a separate file.

Slice object

Slice guides
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5 Choose an HTML output format, select a 
destination folder, and click Export.

Each region is exported as a separate graphic using 
the name entered in the Object inspector. If no 
name is entered, then the slice is named according to 
settings in the File > Document Properties dialog 
box. See “Setting slice auto-naming.” for more 
information on how slice names are generated.

Specifying export settings for slice 
objects

Each slice object can use different export settings when 
the image is exported. To specify an export setting for a 
slice object, select the slice object and then choose a 
setting from the Export Settings pop-up on the Object 
inspector. The settings listed in this pop-up are presets 
saved from the Export Preview, including any presets 
that you create.

◆ Choose Export Defaults to export the slice using the 
document's export settings.

◆ Choose an export preset for exporting the slice.

◆ Choose Custom to open the Export Preview and set 
specific settings for the selected slice.

◆ Choose Text (No Image) and enter text to export 
text or HTML code for the slice object and not the 
underlying image.

To apply a custom export setting to a slice, click the 
button to the right of the Export Settings pop-up to 
open the Export Preview and enter specific settings for 
the selected slice object.

Naming slices

Enter a slice name to define the file name of the slice 
when it is exported and to label the slice when targeting 
it from a rollover behavior.

To enter a custom name for a slice, select the slice, 
uncheck Auto-Name Slices on the Object inspector, 
and enter a name in the slice name field below the 
checkbox. Unnamed slices default to the naming 
conventions set in the File > Document Properties 
dialog box.

Setting slice auto-naming

Slices that are not custom named are automatically 
named by Fireworks. However, you can control how 
Fireworks auto-names slices. To change auto-naming 
settings, choose File > Document Properties. Then, in 
the Document Properties dialog box, choose a different 
setting from the Auto-naming pop-up.

The basename of the slice is the name you enter when 
exporting the document. The following table illustrates 
the auto-naming options if you enter a basename of 
MyFile.

Choose To name slices like this

Basename_Row#_Col# MyFile_r01_c01
MyFile_r01_c02
MyFile_r02_c01 

BaseName_Numeric MyFile_01
MyFile_02
MyFile_03 

BaseName_Alphabetical MyFile_a
MyFile_b
MyFile_c

Row#_Col#_BaseName r01_c01_MyFile
r01_c02_MyFile
r02_c01_MyFile

Numeric_BaseName 01_MyFile
02_MyFile
03_MyFile

Alphabetical_BaseName a_MyFile
b_MyFile
c_MyFile
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JavaScript rollovers
JavaScript rollovers are images that change appearance 
in a web browser when you move the mouse over them 
or click them. JavaScript rollovers are created by drawing 
different rollover states, and then using JavaScript 
within an HTML file to switch to a different image for 
certain events, such as moving the mouse over the image 
or clicking the image.

To create a JavaScript rollover:

1 Draw each rollover state on a separate frame, 
with each state positioned at the same location 
on each frame.

2 Draw slice objects or hotspot objects to define 
event areas.

An event area is the area used to trigger a rollover.

3 Select each event area, and then choose a 
rollover behavior from the Add Behaviors pop-up 
on the Behaviors inspector.

4 Choose File > Export, optimize the image in the 
Export Preview, then click Next.

5 In the Export dialog box, choose an HTML output 
format, specify a destination for the images and 
the HTML file, and then click Export or Save.

When exporting rollovers, Fireworks automatically 
generates the JavaScript necessary to display the 
rollovers in a web browser and exports that JavaScript in 
an HTML file. View this HTML file in a web browser 
to preview the JavaScript rollover.

Button rollovers

A common use of JavaScript rollovers is to create 
buttons that change appearance when the cursor is 
moved over them in a web browser. Each appearance, or 
state, of a button is a different image. Four states can be 
used when creating a button: Up, Over, Down, and 
OverDown. Each state is drawn on a different frame 
using frames one through four.

The following table describes the buttons states and on 
which frame to draw them.

To create a JavaScript rollover button:

1 Draw each button state on its appropriate frame. 

2 Draw a slice object over the button.

3 Select the button's slice object, and then choose 
Simple Rollover from the Add Behaviors pop-up 
on the Behaviors inspector.

4 If the button has a Down state or an OverDown 
state, check Include Down state or Include 
OverDown state in the Simple Rollover dialog 
box, and then click OK.

5 Choose File > Export, optimize the image in the 
Export Preview, then click Next.

6 In the Export dialog box, choose an HTML output 
format, specify a destination for the images and 
the HTML file, and then click Export.

State Description Location

Up Default button appearance. Frame1

Over Button appearance when the 
cursor moves over it.

Frame 2

Down Button appearance on its 
destination page.
See “The Down state” for 
more information. 

Frame 3

OverDown Button appearance as it is 
clicked. Or, when creating a 
toggle-group rollover, 
OverDown is the appearance 
of a Down state when the 
cursor is moved over it.

Frame 4
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The Down state

The Down state of a rollover button depicts the button's 
state on the destination web page. For example, the 
Down state is commonly used to show which button 
was clicked to view the current web page.

If you choose Simple Rollover, and include the Down 
state (Frame 3), Fireworks exports the JavaScript 
necessary to make buttons appear in their correct state 
(Down, Up, and so on) when placed either in a browser 
frame or within multiple HTML documents.

Using bevel effects to draw button states

Any object may be used to create a rollover state. 
However, because buttons are the most common type of 
JavaScript rollovers, Fireworks includes Live Effect 
presets to simplify the creation of common button 
appearances. Apply an Inner Bevel or Outer Bevel effect 
to an object, and then choose Raised, Highlighted, Inset, 
or Inverted from the Button Presets pop-up on the 
Effect panel.

Assigning URL links to rollovers

To assign a URL link to a rollover, select the hotspot 
object or slice object, and then choose or enter a URL in 
the URL link pop-up on the Object inspector. 

Swapping parts of the image

When creating rollovers, use slice objects to define the 
parts of the image that will swap out. When the rollover 
is activated in a browser, the area specified by a slice 
object is swapped with either images from another frame 
in the Fireworks source file or with an external file.

To target a specific part of the image to swap out 
when a rollover is activated:

1 Draw a slice object over the target area.

The target area is the area that changes appearance 
when the rollover is triggered.

2 Draw a hotspot object or slice object over the 
event area.

The event area is the area that triggers the rollover 
when the specified mouse event occurs.

3 Select the event area object and choose Swap 
Image from the Add Behavior pop-up on the 
Behaviors inspector.

4 In the Swap Image dialog box, choose a slice for 
the target area.

The Target list displays all of the slice objects in the 
document by their currently assigned name. The 
slice preview displays how the document is sliced. 
Click a slice or a name of a slice to choose the slice 
for the target area.

Button Presets effect Description

Raised The bevel appears 
raised up from the 
underlying objects.

Highlighted The button’s colors 
lighten.

Inset The bevel appears 
sunken into the 
underlying objects.

Inverted The bevel appears 
sunken into the 
underlying objects and 
the colors lighten.
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5 In the Swap Image dialog box, choose the Source 
for the swap, and then click OK.

Choose the source for the swap by either clicking 
the name of a slice in the In Slice field, or by clicking 
a slice in the slice preview to the right of the In Slice 
field.

The source for the swap can be the contents of 
another frame or an external file.

◆ When the source is another frame, only the area 
immediately below the target slice object on the 
specified frame is used.

◆ When the source is another file, the browser 
resizes the file to fit within the slice object if the 
source file is not already the same size as the 
slice object. Resizing the file may reduce its 
quality, especially for animated GIFs. To resize a 
selected slice object to specific dimensions, 
choose Modify > Transform > Numeric 
Transform, choose Resize from the pop-up, and 
enter a width and height.

◆ Check Restore Image onMouseOut to swap 
the original image back into the slice when the 
cursor is moved away from the image.

6 Choose an event for the Swap Image behavior 
from the Events pop-up on the Behaviors 
inspector.

The events are:

◆ onMouseOver—The event is triggered when the 
cursor is moved over the event area.

◆ onMouseOut—The event is triggered when the 
cursor is moved out of the event area.

◆ onClick—The event is triggered when the mouse is 
clicked in the event area.

7 Export the image.

To simultaneously swap more than one slice, apply 
multiple Swap Image behaviors to the same event area.

Using external files for rollover source

Fireworks can use GIFs, animated GIFs, JPEGs, and 
PNGs as the source for a rollover. When an external file 
is chosen as the rollover source, that file is exchanged 
with the target slice when the rollover is activated in a 
web browser. Use an external image file as rollover source 
when you want a rollover state to be an animated GIF.

Choose Image File in the Swap Image dialog box to 
select an external file as the source for a rollover.

Note: Fireworks does not pre-cache rollovers that use 
external files for rollover states. This is done to prevent 
interrupted display in browsers when using animated 
GIFs as rollover states. If you want to pre-cache these 
rollovers, you must customize the Fireworks output 
HTML.

Using irregularly shaped rollovers

Creating irregularly shaped rollovers is a difficult task in 
web design. JavaScript rollovers can only swap out entire 
images. All bitmap images are rectangular; therefore, to 
create the appearance of an irregularly shaped rollover, 
the irregular shape is drawn over the rectangular image 
area. Creating shapes that extend beyond that 
rectangular area or shapes that interlock require complex 
JavaScript and slicing to create the effect of irregularly 
shaped rollovers.

Fireworks simplifies the task of creating irregularly 
shaped rollovers. A hotspot object may be drawn in any 
shape or created from any object. Then, those hotspots 
can be used to target a slice object that defines the area of 
the rollover, even if the hotspot is within the area of the 
slice object.
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Creating toggle group rollovers

A toggle group is a series of rollovers grouped so that 
when one rollover is triggered, the others in the group 
are triggered as well. For example, in a group of buttons 
used for navigating a site, pressing one button might 
cause it to appear sunken while at the same time raising 
the previously pressed button.

Using toggle group rollovers also eliminates the graphic 
flicker sometimes seen in certain instances of Simple 
Rollover or Swap Image rollovers. The flicker happens 
when you move the mouse from one rollover area to the 
next, and the first rollover's Restore onMouseOut 
function is executed before the onMouseOver for the 
second rollover is executed. A toggle group rollover 
handles the transition between rollover areas smoothly.

To create a toggle group rollover:

1 Draw each rollover state on its appropriate 
frame.

2 Draw a slice object over each rollover area.

3 Assign rollover behaviors to slice objects, as 
previously described.

4 Select a slice object, and then choose Toggle 
Group from the Add Behaviors pop-up on the 
Behaviors inspector.

5 Enter or choose a Group Name for the toggle 
group to which the slice or hotspot belongs.

All slices in a single toggle group must be assigned 
the same name.

6 If the assigned behavior is Simple Rollover, and 
Down states or OverDown states have been 
assigned to the slices, check Include Down state 
or Include OverDown state in the Toggle Group 
dialog box, and then click OK.

7 Repeat steps 4 and 5 for each slice in the toggle. 

8 If you want one slice to appear in its Down state 
when initially viewed, select the slice, double-
click its toggle group behavior on the Behaviors 
inspector, and check Make this slice the initial 
state.

9 Choose File > Export, optimize the image in the 
Export Preview, then click Next.

10 In the Export dialog box, choose an HTML Style, 
specify a destination for the images and the 
HTML file, and then click Export.

Exported JavaScript code

When JavaScript rollovers are exported, an HTML file 
is also exported that includes JavaScript used to display 
the rollover in a web browser. The JavaScript exported 
from Fireworks includes browser detection, and is 
compatible with versions 3 or higher of both Netscape 
Navigator and Microsoft Internet Explorer. Some 
browsers, such as Internet Explorer 3, cannot display all 
four JavaScript rollover states. In that case, the JavaScript 
exported by Fireworks allows those browsers to display 
the Up state and link to the appropriate URL.

Pre-caching

The JavaScript generated by Fireworks performs pre-
caching of rollover states. This means that when the 
HTML file is first loaded into the web browser, all 
rollover images, even those not initially visible, are loaded 
into the browser’s memory. When the cursor is moved 
over a Fireworks JavaScript rollover, the alternative (alt) 
state is immediately swapped, instead of waiting for it to 
be downloaded from the server.

Pre-caching does not occur when rollover source 
consists of an external file. This is to prevent interrupted 
play of animated GIFs in browsers when animated GIFs 
are used as rollover states.

Customizing HTML and JavaScript output

Customize Fireworks HTML and JavaScript output by 
editing the HTML style templates. For more 
information on customizing Fireworks HTML, see 
“Using Fireworks HTML” on page 130.
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Creating animation
Fireworks provides all the tools you need to create 
animated GIFs. Fireworks animation capabilities are 
perfect for creating web banner ads or for adding simple 
motion to your web site. Open and edit existing 
animated GIFs or create new animated GIFs from 
scratch.

An animated GIF is a GIF89a file containing multiple 
images. These images act as successive frames of 
animation when the GIF is viewed in a web browser.

Fireworks animation features

These are the five primary Fireworks features for 
creating animation:

Frames panel—The Frames panel is the backbone for 
animation. Organize, manage, and preview successive 
frames of animation.

Layers panel—When creating animations, the Layers 
panel becomes a strong counterpart to the Frames panel. 
Organize parts of the drawing on layers and share entire 
layers across all frames, easily creating backgrounds or 
static objects.

VCR controls—Use the VCR control buttons at the 
bottom of any document window to easily flip through 
frames of the document or to play a preview of the 
animation directly in the document window.

Symbols and instances—Use symbols and instances 
to simplify the animation process. Make a symbol of any 
object or group. Then, create instances of that symbol on 
other frames that may be moved or transformed 
independently of the symbol. However, if a new color is 
applied to the symbol, or if part of the symbol is edited, 
then all instances update as well.

Animation panel of the Export Preview—Use the 
Animation panel of the Export Preview to set frame 
delay, disposal method, frame visibility, and looping for 
an animation.

Opening an animation

Open existing animated GIFs in Fireworks and edit 
them. When an animated GIF is opened, Fireworks:

◆ Creates a shared layer named “Background” based 
on common pixels found in more than half of the 
imported frames.

◆ Places the animated components from each frame 
onto a separate frame of the Frames panel. These 
components are placed as image objects on a layer 
named GIF.

To edit an animated GIF, choose a frame on the Frames 
panel and make changes.

Opening multiple files as an animation

Fireworks can create an animation based on a group of 
image files. For example, if you are creating a banner ad 
based on several existing graphics, use File > Open 
Multiple to open those graphics and place them on 
separate frames of the same document.

To open multiple files as an animation:

1 Choose File > Open Multiple.

The Open Multiple Files dialog box appears.

2 Browse to a file or files and add files to open as 
frames in the animation.

◆ Click Add to add a file to the list.

◆ Click Add All to add all files in the current 
folder to the list.

◆ Select a file from the added file list and click 
Remove to remove it from the added file list.

3 Check Open as Animation and click OK.

Fireworks opens the files into a single document, 
each file placed on a separate frame in the order they 
were chosen in the Open Multiple Files dialog box.
Chapter 4124



Drawing an animation

Creating an animation in Fireworks is simple. Create a 
new document, then use the Frames panel to add 
multiple frames to the document. Draw objects on 
separate frames, starting with Frame 1.

Managing frames

Use the Frames panel to add, copy, or delete frames, or to 
copy or distribute objects across multiple frames.

Sharing layers across frames

Layers on the Layers panel may be set so that the objects 
on those layers appear on all frames of the animation. To 
share a layer across frames, double-click the layer to open 
the Layer Options dialog box. Alternatively, select Layer 
Options from the Options pop-up on the Layers panel, 
and then check Share Across Frames.

Objects on shared layers may be edited on any frame, 
and those edits are reflected on all other frames.

To disable sharing a particular layer across frames, 
double-click the shared layer and then uncheck Share 
Across Frames in the Layer Options dialog box. When 
disabling a shared layer, choose to copy objects from that 
layer to the current frame or choose to copy the objects 
on the shared layer to all frames.

Note: The Web Layer, which only contains slice objects 
and hotspot objects, is always shared across all frames.

To Do this

Add a frame as the 
last frame on the 
Frames panel

Click the Add Frames button 
at the bottom of the Frames 
panel
or
Choose Insert > Frame.

Add one or more 
frames to a specific 
place on the Frames 
panel

Choose Add Frames from the 
Frames panel Options pop-up. 
In the Add Frames dialog box, 
enter the number of frames to 
add and choose where the 
new frames will be inserted.

Create copies of a 
frame

Drag an existing frame to the 
Add Frames button at the 
bottom of the Frames panel.

Create one or more 
copies of a frame 
and place the copies 
in a specific place on 
the Frames panel

Choose Duplicate Frame from 
the Frames panel Options pop-
up. In the Duplicate Frames 
dialog box, enter the number 
of duplicates to create for the 
selected frame, and choose 
where the duplicate frames 
will be inserted.

Delete the selected 
frame

Click the Delete Frame button 
on the bottom of the Frames 
panel
or
Choose Delete Frame from the 
Frames panel Options pop-up.
or
Drag a frame to the Delete 
Frame button.

The Frames panel above shows that the Web Layer and 
Layer 2 are shared across frames in the document.

Shared-across-frames icon
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Onion skinning

Use onion skinning to view the contents of frames 
preceding and following the currently selected frame. 
Onion skinning helps you to smoothly animate frames 
without having to flip back and forth through frames. 
The term “onion skinning” comes from a traditional 
animation technique of using thin, translucent tracing 
paper to view animated sequences.

When onion skinning is turned on, objects on frames 
before or after the current frame are displayed but are 
dimmed so that you can distinguish them from objects 
on the current frame. You may adjust how many frames 
before and after the current frame are visible by choosing 
various options from the Onion Skinning pop-up on 
the Frames panel.

When playing an animation using the Frame controls 
at the bottom of the document window, onion skinning 
is temporarily turned off.

Before and After Onion Skinning is applied to the frame 
containing the middle bird.

Display the Onion Skinning pop-up from the Frames panel.

Choose To

No Onion Skinning Turn off onion skinning and 
only display the contents of 
the current frame.

Show Next Frame Display the contents of the 
current frame and the next 
frame.

Before and After Display the contents of the 
current frame and the frames 
immediately before and 
immediately after the current 
frame.

Show All Display the contents of all 
frames.

Custom Enter custom settings for 
which frames are viewed 
when onion skinning.
Choose Custom to view more 
than three frames at once or 
to control the opacity of the 
frames before and after the 
current frame when onion 
skinning.

Multi-Frame Editing Choose to turn on multiframe 
editing so that objects on 
other frames may be selected 
and edited when onion 
skinning.
Chapter 4126



Symbols and instances

Use symbols and instances to simplify animation and 
improve editability across frames. When the original 
object (the symbol) is modified, the copies (instances) 
automatically change to reflect the modifications to the 
symbol.

For example, when animating the word “Cow” across 
ten frames, create a symbol from the word “Cow” on the 
first frame, and then place instances of “Cow” on the 
other nine frames. Move them, transform them, and 
apply effects to them.

To change the word to “Llama,” change the symbol on 
the first frame from “Cow” to “Llama” using the Text 
Editor. Every instance of that symbol is updated to 
“Llama,” but each instance retains its characteristics— 
only the text changes.

Optimizing and controlling the 
animation

Use the Options panel in the Export Preview to 
optimize the animated GIF. Use the Animation panel 
to set the frame delay and disposal method of each 
frame, and to set how the animated GIF loops when 
viewed in a web browser.

Disposal method

The disposal method determines how pixels of the 
selected frame are replaced by the next frame when 
viewed in a web browser. The four disposal methods are: 

Unspecified—No disposal method is specified. 
Fireworks automatically selects the disposal method for 
each frame.

Choose Unspecified to create the smallest possible 
animated GIFs. 

None—The frame is not disposed before the new frame 
is displayed. The next frame appears on top of the 
current frame.

Choose None to add a smaller object to the 
existing frame. 

Restore to Background—Erases the current frame's 
image and restores the area to the background color or 
pattern that appears in the web browser.

Choose Restore to Background when moving an object 
in a transparent animated GIF. 

Restore to Previous—Erases the current frame's image 
and restores that area to the previous frame's image.

Choose Restore to Previous to animate objects across a 
background image.

Transparency

Fireworks exports transparent animated GIFs if the 
canvas is transparent or if transparency has been defined 
on the Options panel of the Export Preview.

Note: Not all web browsers support transparent 
animated GIFs.

Frame delay

Set the frame delay to determine how long the current 
frame is displayed. Frame delay is specified in 
hundredths of a second. For example, a setting of 50 
displays for half a second, while a setting of 300 displays 
for 3 seconds.

◆ To make frames display as quickly as possible, set the 
frame delay to 0.

◆ To enter a frame delay value, choose a frame from 
the list and then enter a number in the Frame 
delay field.
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Looping

Use the Loop settings to determine how many times the 
animation plays.

Note: If an animated GIF is set to play only once, the 
first frame appears as a static graphic after the 
animation has played.

Turning on and turning off frames for 
export and playback

Use the Animation panel of the Export Preview to turn 
on or turn off frames for export and preview. Choose 
File > Export, then click on the Animation tab to view 
the Animation panel.

Then, on the Animation panel, click the view/hide 
column next to a frame to turn that frame on or off. If a 
frame is turned off, it will not be exported with the 
animation, nor will it be displayed if the animation is 
previewed in Fireworks.

Previewing an animation

Preview animations created in Fireworks in either of 
two ways:

Preview an animation in the workspace—Use the 
frame controls at the bottom of the document window 
to quickly preview an animation without opening the 
Export Preview.

◆ Frame rate settings made in the Animation panel of 
the Export Preview affect how long each frame is 
displayed in the document window.

◆ Frames that are turned off in the Animation panel 
of the Export Preview will not be displayed when 
previewing the animation.

◆ The animation repeats until stopped, regardless of 
the Loop settings in the Export Preview.

◆ The animation preview displays the source graphics 
at full resolution, not the optimized 8-bit preview 
that will be used for the exported animated GIF.

Click To

Play once button

Set the exported animated GIF 
to play once and then stop.

Loop button

Set the exported animated GIF 
to replay the animation the 
number of times specified in 
the Number of Loops pop-up.
For example, entering 4 plays 
the animation the first time, 
then replays it four more 
times.
Choose Forever from the 
Number of Loops pop-up to 
play the animation 
continuously.

Export Preview Animation panel
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Preview an animation in the Export Preview—Use 
the frame controls in the Export Preview to display an 
animated GIF exactly as it will be exported. The Export 
Preview shows looping, optimization, disposal methods, 
and frame delay.

Exporting an animation

After creating an animation, export it as either an 
animated GIF or as multiple files.

To export as an animated GIF:

1 Choose File > Export.

2 Click the Options tab and choose Animated GIF 
from the Format pop-up.

3 Make changes to the Palette, Dither, or 
Transparency options.

4 On the Animation panel of the Export Preview, 
set the disposal method and frame delay for each 
frame and choose loop settings.

◆ To select a range of frames, select the first frame, 
hold down the Shift key, and then select the last 
frame in the range.

◆ To select multiple frames, hold down the 
Control key (Windows) or Command key 
(Macintosh) while selecting individual frames.

5 Click Next.

6 In the Export dialog box, type a name for the file 
and select the destination.

To export as multiple files:

1 Choose File > Export Special > Export as Files.

2 In the Export dialog box, choose Frames in the 
Files From pop-up.

3 Type a name for the files and select the 
destination.

Transparency
Using Fireworks, create web graphics with fine-tuned 
transparencies. Transparency is supported in two 
graphic formats: GIF and PNG.

GIF transparency

Transparency is defined in GIF files by designating one 
or more colors to be transparent. The designated color is 
transparent when the GIF is viewed in a browser.

Use the Export Preview to set or adjust the transparent 
area in a GIF. Use the Transparency Eyedropper tools to 
add or remove colors from the transparent area.

PNG alpha transparency

Exported PNG files can contain alpha transparency 
settings. Alpha transparency is different from GIF 
transparency in that gradient levels of transparency can 
be specified. This means that pixels may be set to blend 
with the web browser's background color or 
background image.

However, alpha transparency is not supported fully by 
current browsers. Netscape Navigator 4.04 supports 
PNG, but not alpha channels. Microsoft Internet 
Explorer 4 partially supports PNG alpha channels, but 
sometimes displays inconsistently when complex 
gradient transparency is defined.
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To include alpha transparency in an exported 
PNG:

1 Create an image in Fireworks using a transparent 
canvas.

Images with feathered edges, anti-aliasing, or varied 
opacity settings benefit from alpha transparency.

2 Choose File > Export.

3 Choose PNG from the Formats pop-up on the 
Options panel of the Export Preview.

Choose a bit depth of 8-bits to avoid creating 
extremely large files.

4 Choose Alpha Channel from the Transparency 
pop-up.

5 Click Next.

6 In the Export dialog box, type a name for the file 
and select the destination.

Using Fireworks HTML
Fireworks can generate HTML when exporting. 
Fireworks-generated HTML always contains a link to 
the exported image and HTML that sets the 
background color for the web page to be the same as the 
canvas or matte color in the exported graphic.

Fireworks can export all the HTML and JavaScript 
needed to create image maps, rollovers, tables to 
reassemble sliced graphics, status bar messages, and 
other actions defined using the Behaviors inspector.

View HTML files exported by Fireworks by opening 
them in a web browser. HTML files may be edited by 
opening them in a text editor, such as NotePad 
(Windows) or SimpleText (Macintosh), or in a web 
authoring tool like Macromedia Dreamweaver. Portions 
of Fireworks HTML files may be copied and pasted 
into other HTML files.

Exporting HTML with a Fireworks file

To export HTML for a graphic, choose a style from the 
HTML Style pop-up in the Export dialog box when 
exporting. Use the HTML Style pop-up to select from 
different styles of HTML output suitable for use in a 
variety of HTML editors.

These output styles are available with Fireworks:

None—No HTML is generated during export.

Dreamweaver 2—This style is easy to edit in 
Dreamweaver 2. When this HTML is opened in 
Dreamweaver 2, behaviors applied to objects appear in 
the Dreamweaver Behaviors inspector. This means that 
rollovers, and other JavaScript behaviors may be edited 
in Dreamweaver's Behaviors inspector.
Chapter 4130



Dreamweaver Library.lbi—This style imports objects 
as library objects within Dreamweaver. Use library 
items in Dreamweaver for content that appears on 
many pages in your site, for content that must be 
updated frequently, and for rapid prototyping. Library 
files must have an “.LBI” extension and must be located 
in a folder named Library at the site root.

FrontPage—This style is easy to edit in Microsoft 
FrontPage.

Generic—This style adheres to basic HTML standards, 
but favors no particular HTML editor.

Exporting as Files and CSS layers

Use the File > Export Special > Export as Files command 
to export individual images. Use the Files From pop-up 
to export images from layers, slice objects, and frames as 
individual export files.

Export as CSS Layers to create an HTML document 
with Cascading Style Sheet (CSS) layers. Use CSS layer 
information in an HTML editor such as Dreamweaver 
to precisely position and animate objects.

Editing Fireworks HTML output styles

Add, remove, or edit HTML output styles by making 
changes to templates located in the 
Fireworks 2\Settings\HTML Code folder. Template 
files are written in JavaScript, which is executed by 
Fireworks during export.

Edit Fireworks output styles to customize HTML 
exported by Fireworks. In addition, use JavaScript to 
create dialog boxes or alerts when exporting. For 
example, you could create a dialog box that allowed you 
to enter a custom title for the HTML page exported, or 
to output different HTML code for specific tasks.

Template files are written in JavaScript. Therefore, a 
working knowledge of JavaScript is required to 
successfully edit a template. If an edited template file 
contains any errors in the JavaScript, the export process 
stops. Fireworks does not correct JavaScript errors; it 
only executes valid JavaScript when exporting.

To Do this

Add an output style Create, duplicate, or place a 
new folder in the 
Fireworks 2\Settings\HTML 
Code folder. Place copies of 
the Imagemap.htt, slices.htt, 
and ServerMap.mtt files in the 
new folder.
The folder name determines 
the name of the style as it 
appears in the HTML Output 
pop-up

Remove an output 
style

Delete the folder of the 
unwanted style from the 
Fireworks 2\Settings\HTML 
Code folder.

Edit an output style 1. In the 
Fireworks 2\Settings\HTML 
Code folder, open the folder 
of the style you want to 
edit.

2.Open the document in a 
text editor, make changes, 
and save.

Be sure to use the same name 
and path when saving the 
document.
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Some HTML basics

HTML files are essentially text files that contain:

◆ Text that appears on the web page.

◆ HTML tags that define document formatting and 
structure, and link to images and other HTML 
documents (web pages).

HTML tags are enclosed in brackets and look 
something like this:

<tag> affected text </tag> 

Like the example above, most HTML tags use both an 
opening tag and a closing tag, which together define the 
beginning and ending of the affected text. Some tags, 
however, need only an opening tag. Many tags allow 
additional variables to be added to control how the tag 
affects the selected range of text. For example:

<font color=”blue”>Fireworks</font>

This tag would color the word Fireworks blue.

Common HTML tags

Most HTML documents contain these tags:

<HTML></HTML> —Mark the beginning and ending 
of the HTML document.

<TITLE></TITLE> —Set the name of the document 
that appears on the top of the browser window.

<HEAD></HEAD> —Information in this section 
describes various characteristics of the document such as 
the document title, background color, text color, and 
font usage. JavaScript code is placed within this section 
of the document.

<META></META>—Store extra information about 
the HTML document such as what application created 
it, keywords for search engines, and other information 
used by various applications. Many HTML editors or 
utilities add meta information to an HTML document. 

<SCRIPT></SCRIPT>—Mark the beginning of code 
for a scripting language, such as JavaScript.

<BODY></BODY>—Text or links in this section go 
into the main body of the document.

<IMG>—Display an image on the web page. For 
example:

<IMG SRC=”Picture.gif”>

Display the image Picture.gif on the page.

<A></A> —Create a link from text or an image to 
another HTML document. For example:

<A HREF=”http://www.macromedia.com”>Link</A> 

In this case, clicking the word ¨Link¨ in the browser 
jumps to www.macromedia.com, if the computer is 
connected to the Internet.

To place an image and also make that image a link, use 
two tags:

<A HREF=”http://www.getfireworks.com”>

<IMG SRC=”Explosion.jpg”></A>—The image 
Explosion.jpg is displayed on the web page. Clicking it 
navigates to www.getfireworks.com. Note that the link 
to the image is placed within the link tags, between <A> 
and </A>.

<MAP></MAP> —Information within this tag 
describes the shape of a hotspot using coordinates and 
contains the URL destination of the hotspot.

Note: For more explanation on specific HTML tags and 
their usage, consult any of many available books or web 
sites about HTML.
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Copying and pasting from a Fireworks 
HTML file

When copying HTML exported from Fireworks, it is 
important to paste it to the correct place within the 
destination HTML document.

When copying and pasting Fireworks HTML into 
other HTML documents, you do not have to copy the 
<HTML> or <BODY> tags. Those tags should already be 
included in the destination HTML document.

Note: Exporting as a Dreamweaver 2 library (.lbi) file 
makes copying and pasting HTML unnecessary when 
inserted in Dreamweaver.

JavaScript

When Fireworks exports HTML with JavaScript 
behaviors, the exported HTML includes JavaScript 
code for executing behaviors, as well as all other 
necessary HTML. When pasting JavaScript into other 
HTML documents, be sure to do the following:

◆ Paste the entire <SCRIPT> section between the 
<HEAD> and </HEAD> tags. Be sure that the 
script section begins with a <SCRIPT> and ends 
with a </SCRIPT>. If a script section already exists 
in the destination HTML document, do not copy 
the <SCRIPT> tags. Copy the code from the source 
script and paste it at the end of the destination 
<SCRIPT> section before the </SCRIPT> tag.

◆ Paste the image's link in the <BODY> section where 
you want the image to appear on the page.

Client-side image maps

HTML exported by Fireworks for client-side image 
maps includes a link to the graphic and <MAP> 
information to define the image map's hotspot areas. 
When pasting image maps into other HTML 
documents, be sure to do the following:

◆ Paste the image's link into the <BODY> section of 
the destination HTML document where you want 
the image map to appear on the page.

◆ Paste everything in the <MAP> section immediately 
after the link to the graphic.

Sliced images

When exporting slices of an image, the HTML 
exported by Fireworks includes a table that reassembles 
slices on a web page. If you export JavaScript rollovers or 
image maps with your slices, then the HTML will also 
include JavaScript code and a <MAP> section. When 
pasting a sliced graphic into other HTML documents, 
be sure to do the following:

◆ Paste all of the <TABLE> section, including the tags, 
where you want the sliced graphic to appear on the 
page.

◆ Paste any JavaScript into the <SCRIPT> section, or 
paste the entire <SCRIPT> section between the </
HEAD> and <BODY> tags.

◆ Paste any <MAP> sections immediately after the </
TABLE> tag for the sliced graphic.
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INDEX

A
actions

see Scriptlets
activating

image edit mode 52
object mode 52

adaptive palette 97
Add Swatches command 22
Add to Transparency tool 101
adding

active color to current palette 57 (steps)
colors to Swatches panel 96 (steps)
guides 39
layers 73
styles 63 (steps)

Adobe Illustrator
see Illustrator files

alpha channel 129
alpha opacity 56
Alt key

drawing centered shapes (Windows) 49
Alt tag

assigning with Object inspector 20
Alter Path commands

Crop 48
Expand Stroke 48
Inset Path 48
Intersect 48
Punch 48
Simplify 48
Union 48

alternate text
attached to web objects 114

alternate tools
displaying 16

anchor points
see paths

animated GIFs 124Ð129
controlling 127
creating an animation 125
creating from multiple files 124
defined 124
disposal method 127
exporting 129
Fireworks features for 124
Frames panel 124
importing 90
Layers panel 124
managing frames 125
onion skinning 126
opening 124
optimizing 127
playing 128
previewing 128
setting frame delay 127
setting looping 128
sharing layers across frames 125
transparency 127
turning frames on and off 128
using symbols and instances 127

Animation panel
in Export Preview 102

anti-aliasing
edges 61
text 67

Apple Color Picker 58
AppleScript

see Scriptlets
applying effects 65
applying multiple effects 66
arranging

frames 74
objects on a layer 72

Attach to Path command 69
Auto-Apply

effect changes 25
fill settings 24
stroke settings 24

auto-kerning 68
auto-naming

slice objects 119
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B
background color

see canvas
Background image

Fireworks 1 documents 53
backing up

during batch processing 109
baseline shift 68
basic shape tools 48
Batch Export dialog box 107
batch processing 106Ð109

backing up original files 109
Batch Export dialog box 107
changing file settings 107
creating Scriptlets 109 (steps)
file formats 107
finding and replacing during 107
Project Log 109
running Scriptlets 109 (steps)
Scriptlets 109
setting conversion options 108 (steps)
using Scriptlets 109

behaviors
attached to web objects 114
slice objects as targets 117

Behaviors inspector 29
bevel effect 65
bitmap images 44

importing 40
black and white palette 97
blending modes 81Ð82

behavior 82
setting 21

Blur Xtra 54, 67
BMP

defined 106
bold text 68
bounding box 53
browser detection

in JavaScript rollover code 123
browser-save palette 97
Brush tool 17, 60
brushes

apply color using Color Mixer 23
editing 60
saving 61

button rollovers 120
assigning URL links 121
button states 120
creating toggle groups 123
customizing HTML code 123
defined 120
Down state 121
exporting HTML code 123
Over state 120
OverDown state 120
pre-caching 123
specifying swap images 121
Up state 120
using bevel effects 121
using external files 122
using irregularly shaped images 122

buttons
making rounded corners 49
rollover states 120

C
cameras

digital 90
canvas

custom color 59
setting color 37
setting size 37
transparent 59
trimming 54

centerpoint
basic shapes 49
relocating after transforming 55
transform 54

Circle Hotspot tool 18, 115
circles 48
Clear Swatches command 22
clearing guides 39
client-side image maps 117
clipping path 83
clone

using Rubber Stamp tool 45
closed paths 46
CMY color model 56
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color 55Ð59
adding active color to current palette 57 (steps)
adding to Gradient fills 62
adding to Swatches panel 96 (steps)
appending a palette 57 (steps)
blending modes 81
canvas 59
choosing from color bar 56
choosing from Effect panel 25
choosing from Fill panel 24
choosing from Stroke panel 24
choosing from Text Editor 26
Color Mixer 56
creating in Color Mixer 56 (steps)
default 58
deleting from Swatches panel 57 (steps)
displaying in Color Mixer 56
filling a selection 62
filling areas of similar colors 62
finding and replacing 77
Gradient fills 61
Info panel 56
information 56
models. See color models.
palettes 57
pop-up color well 59
replacing a swatch 57 (steps)
replacing swatches 96 (steps)
saving custom palettes 100 (steps)
setting opacity 81
specifying in System color picker 23
swap stroke and fill colors 58
Swatches panel 57
switch brush and fill color 23
transparency 129
Web Dither fill 63

color bar
choosing a color 56
choosing a color model 56
switching color models 23

color depth
setting in Export Preview 95

color lookup table
see color palettes

Color Mixer 23
applying color to selected text 23
applying effect color 23
applying fill color 23
applying stroke color 23
applying text color 23
creating colors 56 (steps)
displaying a document color in 56
reverting to default colors 23
showing and hiding 31
switching brush and fill colors 23
switching color models 23
using 56

Color Mixer button (Windows only) 19
color models

browser-safe 97
choosing from color bar 23
choosing from Color Mixer 23
choosing in the color bar 56
CMY 56
Grayscale 56
Hexadecimal 56
HSB 56
Info panel 56
Web 216 97
web-safe 97
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color palettes
adaptive 97
available on export 97
black and white 97
browser-safe 97
considerations for export 96
custom 97
dithering 100
editing colors 98, 99
exact 97
grayscale 97
locking colors 98
optimizing 102
overview 96
removing edits 100
saving custom 100
setting number of colors 97
setting transparency during export 101
System 97
uniform 97
Web 216 97
web-safe colors 100
Websnap adaptive 97

color pickers
see palettes

color ramp
Edit Gradient dialog box 61
Gradient editor 61

color well
Apple Color Picker 58
effect 58
fill 58
pop-up color box 59
stroke 58
System color picker 58

combine commands
Crop 48
Intersect 48
Punch 48
Union 48

compositing 21, 81Ð??
defined 81

compression
in GIF images 103
in JPEG images 104
in PNG images 105

constraining
Alt key (Windows) 49
marquees 53
Option key (Macintosh) 49
rotation 55
scaling bi-directionally 54
Shift key 48
Shift-Alt keys (Windows) 49
Shift-Option keys (Macintosh) 49
while drawing from centerpoint 49

context-sensitive menus 33
converting

CorelDRAW files 89Ð90
files 89
FreeHand files 89
Illustrator files 89
objects to images 54
text to an image 69
text to paths 69

Copy button (Windows only) 18
copying

pixels 53
copying and pasting

client-side image maps 133
from Fireworks HTML 133
JavaScript 133
resampling graphics 87
sliced images 133
to import graphics 87

CorelDRAW files
converting 89Ð90
importing 89Ð90

correcting mistakes
see Undo
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creating
batch Scriptlets 109 (steps)
clipping path mask 84 (steps)
color in Color Mixer 56 (steps)
colors in the Color Mixer 56
hotspots 116
image maps 116Ð117
instances 79
layers 73
mask similar to layer mask 84 (steps)
slice objects 117
symbols 78, 79
textures 64
vector objects 44
web objects 115

Crop command 48
Crop tool 16
cropping

canvas 37
images 53

CSS layers 131
custom palettes 97
Cut button (Windows only) 18

D
default colors 58

applying using Color Mixer 23
deleting

color from Swatches panel 57 (steps)
instances 79
layers 73
multiple effects 67
styles 64
symbols 79
URLs 30

Deselect command 53
Detach from Path command 69
digital camera images

importing 90
display mode

Draft Display 34
Full Display 34

displaying
paths 46
points 47

disposal method (animated GIFs) 127
Distort tool 17
distorting objects 54
dithering 100
document

canvas color 37
canvas size 37
Draft Display View 34
enlarging view 32
exporting a portion 103 (steps)
finding and replacing elements 74 (steps)
Full Display View 34
highest magnification 33
image size 70
lowest magnification 33
magnification 32Ð33
multiple views 33
navigating in 32Ð34
opening a second view 34
optimizing redraw 34
organizing 71Ð74
reducing view 32
resizing 70 (steps)
rulers 38
setting resolution 37
setting size and resolution 70
setting up 37Ð39
units of measurement 38
viewing in Full Display or Draft Display 34
window 15
zoom in 33
zoom out 33

Document Properties dialog box 42
document rulers

units of measurement 38
Down state

JavaScript rollovers 121
Draft Display mode 34
Draft Display View mode 34
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Drag and Drop
Scriptlets 109
to import graphics 87

drawing
Bézier curves 60
buttons 49
by dragging 48
by plotting points 49
centered shapes 48
circles 48
constraining centered shapes 49
in object mode 48
lines 46Ð51
rounded corners 49
squares 48
using Pen tool 49 (steps)
with the Brush tool 60
with the Pen tool 60

Dreamweaver
copying HTML into 112
copying JavaScript into 112
editing Fireworks images 110 (steps)
editing Fireworks images in 110
exporting libraries 111 (steps)
optimizing images in Fireworks 111
placing Fireworks images on web 110 (steps)
using Fireworks with 110Ð112

drop shadow effect 36, 65

E
edges

anti-alias 61
feather 61
hard edge 61
showing and hiding 47

Edit Gradient dialog box 61
adding colors 62

Edit Stroke dialog box 24
Edit Stroke panels 60

editing
areas of similar colors 62
Bézier curves 47
brushes 60
effects 66
fills 61
fills interactively 62
Gradient fills 61
grid 38
guides 39
Live Effects 65
object mode 50
paths 47
pixels 52
strokes 24, 60
styles 64
URLs 30
with Paint Bucket 62

effect color
applying using Color Mixer 23

Effect panel 25, 66
Effect preview

showing and hiding 25
effects

applying 65
applying multiple 66 (steps)
applying to objects 66 (steps)
bevel 65
Blur Xtra 65
color well 58
deleting 66
drop shadow 65
editing 66 (steps)
editing multiple 66 (steps)
emboss 65
examples 65
finding and replacing 77
glow 65
Invert Xtra 65
Live 65
multiple 66
renaming 66
saving 66
subselecting 67
superselecting 67
Unsharp Mask Xtra 65
Xtras 54, 67
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Ellipse Marquee tool 16, 53
Ellipse tool 17, 48
emboss effect 65
entering text 67 (steps)
Eraser tool 18, 50, 51
exact palette 97
exiting Image Edit mode 52
Expand Stroke command 48
Export Area tool 16, 103
Export button (Windows only) 18
export commands 92

Export Again 92
Export Area 92
Export as CSS Layers 92
Export Special 92
Export Wizard 92

Export dialog box 42, 91
export presets

in Export Preview 94
Export Preview 41, 93

Animation panel 102
comparing alternatives 94
components of 93
magnification in 94
Options panel 95
pan control 94
preview area 94
saving export presets 94
scaling images 102
setting color depth 95
split view 94

Export to Size Wizard 92
Export Wizard 42, 92

exporting 40Ð42, 91Ð109
adaptive palette 97
animated GIFs 129
areas 92
black and white palette 97
BMP images 106
commands 92
CSS layers 92
custom palettes 97
dithering 100
editing colors in palette 98, 99
exact palette 97
Export Area tool 103
Export Preview 93
Export Preview Animation panel 102
Export Preview Options panel 95
formats supported 95
GIF images 103
graphics 91Ð109
grayscale palette 97
HTML output styles 130
HTML styles 92
HTML with Fireworks file 130
HTML with graphics 112
image maps 117
images 42 (steps)
images as file 92
including Dreamweaver libraries 111 (steps)
interlacing 102
JavaScript rollover code 123
JavaScript with graphics 112
JPEG images 104
locking colors in palette 98
optimizing colors 102
palettes available during 97
PICT images 106
PNG images 105
portion of documents 103 (steps)
removing edits in palette 100
saving custom palettes 100
saving export settings 94
scaling images 102
setting color depth on export 95
setting number of colors 97
setting transparency types 101
slicing options 92
styles 64
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swatches 22
System palette 97
TIFF images 106
to Size Wizard 92
transparency Eyedropper tools 101
uniform palette 97
URLs 30
using Export Area tool 103 (steps)
using Export Preview 91 (steps)
using matte color 101
Web 216 palette 97
web formats 103Ð106
web-safe colors 100
Websnap adaptive palette 97
Wizard 42, 92
xRes LRG images 106

Eyedropper tool 17
placing a color in the Color Mixer 56

F
feather 67
features

for animation 124
for web production 114
unique to Fireworks 13

file conversion 89
File panel 102
files

backing up during batch processing 109
batch processing 106Ð109
changing settings with batch processing 107
export formats 95
processing groups of 106 (steps)

Fill button (Windows only) 19
fill color

applying using Color Mixer 23
Fill panel 24, 61
Fill preview

showing and hiding 24

fills 61Ð64
adding texture 64
adjusting Pattern and Gradient fills 62
anti-aliasing edges 61
categories 61
color well 58
Edit Gradient dialog box 61
editing 61
editing with Paint Bucket tool 62
feathering edges 61
filling areas of similar colors 62
finding and replacing 77
Gradient 61
hard edges 61
saving 61
setting tolerance 62
Web Dither 63

filters 54
Find & Replace 74

colors 77
during batch processing 107
elements in a document 74 (steps)
fonts 77
managing multiple file searches 75
managing with Project Log 75
selecting elements 107 (steps)
selecting source for search 75
text 76
URLs 78

Find & Replace panel 28
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Fireworks
animation features 124
case study 34Ð37
copying and pasting HTML 133
dragging and dropping 87 (steps)
editing images in Dreamweaver 110
editing images placed in Dreamweaver 1.2 111 (steps)
editing images placed in Dreamweaver 2 110 (steps)
editing PNGs in other editors 112
features in 13
image types 44
importing Fireworks files 88
installing 11
installing and starting 11 (steps)
new features 13
newsgroup 12
overview 14
package contents 10
placing images on web pages 110 (steps)
resources for learning 12
starting 11
tutorials 12
uninstalling 12 (steps)
using Fireworks HTML 130
using with Dreamweaver 110Ð112
web production features 114
workflow 86

Fireworks 1 documents
opening 53

Fireworks Help 12
fonts

changing attributes 68
choosing 68
finding and replacing 77

formats
export 95
import 86

frame delay (animated GIFs) 127

frames
adding 125
arranging 74
copying 125
creating 28
deleting 125
duplicating 28
icon buttons 28
inserting 125
managing 125
onion skinning 126
setting delay 127
setting looping 128
sharing layers 73, 125
turning on and off 128
working with 74

Frames panel 27, 124
Freeform tool 17, 51
FreeHand files

converting 89
importing 89

Full Display mode 34
Full Display View mode 34

G
GIF

animated 124Ð129
compared to other web formats 105
compression 103
defined 103
exporting 103
transparency 129

glow effect 65
Gradient fills 61

adding colors 62
editing 61
saving 61
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graphics
animated GIFs 124Ð129
backing up during batch processing 109
batch processing 106Ð109
bitmap 44
BMP 106
button rollovers 120
changing settings with batch processing 107
creating thumbnail 108
edit mode 52
editing 52
editing in Dreamweaver 110
exporting 91Ð109
exporting a graphic 42 (steps)
exporting GIFs 103
exporting HTML with 112
exporting JavaScript with 112
exporting to size 92
filters 54
importing 40, 86Ð90
importing a graphic 40 (steps)
including Dreamweaver libraries 111 (steps)
JPEGs 104
leaving edit mode 52
optimizing animated GIFs 127
optimizing using Fireworks in Dreamweaver 111
PICT 106
PNG 105
scaling images on export 102
selecting in object mode 53
slicing when exporting 117
TIFF 106
using with Dreamweaver 110
vector 44
web formats 103Ð106
web formats compared 105
xRes LRG 106
Xtras 54

Grayscale color model 56
grayscale palette 97

grid 38
editing 39
modify 39
showing and hiding 39
snapping to 39
working with 39

grouping objects 71
grouping panels 31
guides 39

adding 39
changing color 39
clearing 39
editing 39
locking 39
showing and hiding 39
snapping to 39
working with 39

H
Hand tool 17
handles

paint bucket 62
point 47
transform 54

Help button (Windows only) 19
Hexadecimal color model 56
Hide Edges command 47
Hide Panels command 31
hiding

edges 47
grid 39
guides 39
layers 73
marquees 47
panels 31
rulers 38
selected objects 73
Selection highlight 47
slice guides 39
Toolbox 21

hotspots
creating 116
defined 116

HSB color model 56
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HTML
adding alerts to output code 131
assigning Alt tag 20
basics 132
copying and pasting from Fireworks 133
customizing output 123
editing output styles 131
exporting CSS layers 131
exporting image maps 117
exporting with a Fireworks file 130
exporting with graphics 112
JavaScript rollover code 123
JavaScript rollovers 120Ð123
output styles 130
overview 132
tags 132
using Fireworks HTML 130

HTML styles
available when exporting 92

hyperlinks
see URLs

I
Icon buttons 28
Illustrator files

converting 89
importing 89

image edit mode 52Ð54
activating 52
activities 52
leaving 52
marquees 53
tools 52
using drawing and editing tools 44

image maps
choosing source graphic 116
client-side 117
copying and pasting from Fireworks HTML 133
creating 116Ð117
creating hotspots 116
exporting 117
generating HTML files 117
server-side 117
server-side map files 117
setting options 116

image mode
blending mode behavior 82
pasting 88

image objects 53
Image Size command 70
images

animated GIFs 124Ð129
backing up during batch processing 109
batch processing 106Ð109
bitmap 44
BMP 106
button rollovers 120
changing settings with batch processing 107
converting text to 69
creating thumbnail 108
cropping 53
edit mode 52
editing 52
editing in Dreamweaver 110
exporting 42 (steps)
exporting GIFs 103
exporting HTML with 112
exporting JavaScript with 112
exporting to size 92
filters 54
importing 40 (steps)
interlacing 102
JPEGs 104
leaving edit mode 52
opening animated GIFs 124
optimizing animated GIFs 127
optimizing using Fireworks in Dreamweaver 111
PhotoShop plug-ins 54
PICT 106
placing on web pages 110 (steps)
PNG 105
Res LRG 106
resizing 70
resizing an image 70 (steps)
scaling during batch processing 108
scaling on export 102
selecting in object mode 53
slicing when exporting 117
TIFF 106
using with Dreamweaver 110
vector 44
web formats 103Ð106
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web formats compared 105
Xtras 54

Import button (Windows only) 18
Import File dialog box 86
importing 40Ð42, 86Ð90

animated GIFs 90
ASCII files 88
bitmap images 40
CorelDRAW files 89Ð90
digital camera images 90
file conversion 89
Fireworks files 88
formats supported 86
FreeHand files 89
from scanner or digital camera 90
graphics 40, 86Ð90
Illustrator files 89
images 40 (steps)
pasting in image mode 88
pasting in object mode 88
Photoshop Acquire plug-ins (Macintosh) 90
resampling during Copy and Paste 87
RTF files 88
scanner images 90
styles 64
text 88
URLs 30
using Copy and Paste 87
using Drag and Drop 87, 87 (steps)
using Import File dialog box 86 (steps)
vector art 40
Vector File Options 89

Info panel 19
unit of measurement 38
viewing color information 56

Inset Path command 48
inspectors

Behavior 29
Object 20
showing and hiding 31

installing
Fireworks (Macintosh) 11 (steps)
Fireworks (Windows) 11 (steps)

instances
breaking link with symbol 79
creating 79
defined 78
deleting 79
modifying 79
moving with symbol 79
tweening 80

interlacing 102
Intersect command 48
Invert Xtra 54, 67
italic text 68

J
JavaScript

adding alerts to output code 131
assigning URL links 121
browser detection 123
button rollovers 120
copying and pasting from Fireworks HTML 133
exporting with graphics 112
rollovers 120Ð123

JavaScript rollovers 120Ð123
browser detection 123
creating toggle groups 123
customizing HTML code 123
defined 120
Down state 121
exporting HTML code 123
Over state 120
OverDown state 120
pre-caching 123
specifying swap images 121
Up state 120
using bevel effects 121
using external files 122
using irregularly shaped images 122

JPEG
compared to other web formats 105
compression 104
defined 104
exporting 104
progressive 104
sharpening color edges 104
smoothing 104
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K
kerning 68
keyboard shortcuts 16Ð18

magnification 33
Knife (Eraser) tool 51

L
Lasso tool 16, 53
layers

adding 73
creating 28, 73
deleting 73
duplicating 28, 73
editing current layer 73
editing objects on 72
icon buttons 28
inserting 73
locking and unlocking 73
moving 73
moving objects to 73
sharing across frames 73, 125
showing and hiding 73
Web Layer 73
working with 72

Layers button (Windows only) 19
Layers panel 27

animated GIFs 124
choosing frames from 27

leading 68
learning Fireworks

resources for 12
tutorials 12

Line tool 17, 48
lines

45 degree increments 48
drawing 46Ð51

links
see URLs

Live Effects 65
locking guides 39
looping (animated GIFs) 128

M
Macintosh

Apple Color Picker 58
installing and starting Fireworks 11 (steps)
System requirements for 10
uninstalling Fireworks 12

Macromedia web site 12
Magic Wand tool 17, 53
magnification

document 32Ð33
in Export Preview 94
keyboard shortcut for 33
page 32Ð33
setting to 100% 33

Magnify tool 17
Main toolbar (Windows only) 18Ð19
manager

URL 29
map files 117
Marquee tool 16, 53
marquees 53

deselecting 53
ellipse 53
removing 53
showing and hiding 47

mask group 83
selecting objects within 84

masking 83, 129
creating clipping path 84 (steps)
creating similar to layer mask 84 (steps)

matte color 101
measurement, units of 38
memory (RAM)

see System requirements
menus

context-sensitive 33
Merge Images command 54
modes

object and image edit 44
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modifying
canvas color 37
canvas size 37
effects 66
fills 61
instances 79
paths 48
strokes 60
symbols 79

moving
brush stroke 50 (steps)
in document 32Ð34

multiple document views 33
multiple effects

applying 66
deleting 67
renaming 67
saving 67
settings 67

multiple file searches 75

N
navigating

in document 32Ð34
New button (Windows only) 18
New Document dialog box

setting resolution in 37
Numeric Transform command 55

O
object editing tools 50, 51
Object inspector 20Ð21

adjusting opacity with 81
blending modes 21, 81
button (Windows only) 19
components 20
opacity mode 21
setting links 115

object mode 44Ð51
activating 52
activities 45
blending mode behavior 82
drawing 48
editing tools 50
pasting 88
pushing and pulling an area 51
pushing and pulling paths 51
redrawing paths 51
selecting an image 53
slicing a path 51
using drawing and editing tools 44

objects
adjusting opacity 81
applying effects 66 (steps)
applying Live Effects 65
applying multiple effects 66 (steps)
arranging on layers 72
blending 81
convert text to 69 (steps)
converting to images 54
displaying points 47
distorting 54
editing effects 66 (steps)
editing multiple effects 66 (steps)
grouping 71
masking 83
moving to another layer 73
rotating 54
scaling 54
selecting 46
selecting additional objects 47
selecting objects behind 47
selecting within a mask group 84
showing and hiding 73
skewing 54
transforming 54
transforming by dragging 54
transforming numerically 55
tweening 80 (steps)
ungrouping 71

onion skinning 126
opacity 81
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opacity mode
setting 21

Open button (Windows only) 18
open paths 46
opening

Fireworks 1 documents 53
multiple documents 33
Text Editor 26

optimizing
animated GIFs 127
colors 102
images 111

Option key
drawing centered shapes (Macintosh) 49

Options panel
in Export Preview 95
Tool Options panels 21

organizing your document 71Ð74
Over state

JavaScript rollovers 120
OverDown state

JavaScript rollovers 120
overview of Fireworks 14

P
package

contents of Fireworks package 10
page magnification

setting 32Ð33
Paint Bucket tool 18, 62

adjusting fills interactively 62
editing fills 62
filling a selection 62
handles 62
setting tolerance 62

painting 60

palettes
adaptive 97
appending to current palette 57 (steps)
available on exporting 97
black and white 97
changing 22
considerations for export 96
custom 97
dithering 100
editing colors 98, 99
exact 97
exporting 100 (steps)
grayscale 97
locking colors 98
optimizing 102
overview 96
removing edits 100
replacing swatches 96 (steps)
saving 100
saving custom 100 (steps)
setting number of colors 97
setting transparency during export 101
Swatches panel 57
System 97
uniform 97
Web 216 97
web-safe colors 100
Websnap adaptive 97

pan control
Hand tools 17
in Export Preview 94
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panels
Color Mixer 23
Edit Stroke 60
Effect 25, 66
File 102
Fill 24, 61
Find & Replace 28
Frames 27
grouping 31
hiding 31
Info 19
Project Log 29
removing 31
setting to defaults 31
showing 31
Stroke 24, 60
Styles 30, 63
Swatches 22
Text Editor 26
Tool Options 21
using 31
viewing 31

Paste button (Windows only) 19
paste inside 83
pasting

in image mode 88
in object mode 88

Path Redraw tool 51
Path Scrubber tool 17, 50
paths 44

adding points 47
attaching text 69
closing 46
convert text to 69
converting text to 69 (steps)
displaying points 47
displaying without points 46
drawing 46, 48
drawing by dragging 48
editing 45, 47
editing attached text 69
editing when attached to text 69
editing without point handles 51
modifying 48
moving points 47
moving text starting point 69 (steps)
open and closed 46

placing text on 69 (steps)
pushing and pulling 51
redrawing 51
removing points 48
reshaping 48
selecting 46
simplifying 48

Pen tool 17, 60
Pencil tool 17
perspective 54
Photoshop Acquire plug-ins

importing 90
Photoshop effects 65
Photoshop plug-ins 54, 67
PICT

defined 106
pixels 44

copying 53
cutting 53
editing 52
moving 53
selecting 53

playing animated GIFs 128
PNG

alpha channel 129
compared to other web formats 105
compression 105
defined 105
editing in other editors 112
exporting 105
transparency 129

point size 68
Pointer tool 16

selecting paths 46
points

corner 47
curve 47
handles 47

Polygon Hotspot tool 18
Polygon Lasso tool 16, 53
Polygon tool 17, 48
polygons

angle 49
number of sides 49

pop-up color wells 59
pre-caching JavaScript rollovers 123
Index150



preview area
in Export Preview 94

Print button (Windows only) 18
printing

Project Log 76
progressive JPEGs 104
Project Log 109

logging Find & Replace changes 74
managing searches 75
viewing and printing 76

Project Log panel 29
properties

document 42
web objects 115

pulling paths 51
Punch command 48
pushing and pulling an area 51
pushing paths 51

R
Rectangle Hotspot tool 18, 115
Rectangle tool 17, 48

rounded corners 49
rectangles

rounded corners 49
Redo button (Windows only) 18
Redraw Path tool 17
redrawing paths 51
removing panels 31
Replace Swatches command 22
replacing 74

all colors in Swatches panel 96 (steps)
swatch in Swatches panel 57 (steps)

replaying animated GIFs 128
resampling 70

during Copy and Paste 87
Reshape Area tool 17, 51
reshaping paths 48
resizing

bitmap images 70
document 70 (steps)

resolution
setting 37

resources for learning Fireworks 12
RGB color model 56
Rich Text Format (RTF) 88
right mouse button (in Windows) 33

rollovers
assigning URL links 121
creating toggle groups 123
customizing HTML code 123
Down state 121
exporting HTML code 123
Over state 120
OverDown state 120
pre-caching 123
specifying swap images 121
Up state 120
using bevel effects 121
using external files 122
using irregularly shaped images 122

rotating objects 54
rounded corners 49
Rubber Stamp tool 18

cloning 45
rulers 38

showing and hiding 39
zero point 38

running
Scriptlets 109 (steps)

S
Save button (Windows only) 18
Save Swatches command 22
saving

brushes 61
custom color palettes 100 (steps)
effects 66
export settings 94
fills 61
Gradient fills 61
multiple effects 67
stroke settings 61
swatches to external set 22

Scale tool 17
scaling

while transforming 54
scaling images

during batch processing 108
on export 102

scaling objects 54
Scan command 90
scanner images

importing 90
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Scriptlets 109
creating 109 (steps)
dragging and dropping 109
running 109 (steps)

searching 74
Select Behind tool 16, 47
Select Transparency tool 101
selected text

applying color using Color Mixer 23
selecting

additional objects 47
all within a group 67
an image in object mode 53
deselecting 53
elements for Find & Replace 107 (steps)
group containing a selection 67
objects 46
objects behind objects 47
paths 46
pixels 53
subselecting 67
superselecting 67
within a masked group 84
working with groups 71

selection
filling 62

Selection highlight
showing and hiding 47

server-side image maps 117
setting

image map options 116
web object properties 115

setting up
document 37Ð39

Sharpen Xtra 54, 67
sharpening color edges 104
Shift key

constraining shapes 48
plotting point by point 49

shortcut. See keyboard shortcut.

showing
edges 47
grid 39
guides 39
layers 73
marquees 47
panels 31
rulers 38
selected objects 73
Selection highlight 47
slice guides 39
Toolbox 21

Simplify command 48
Skew tool 17
skewing objects 54
slice guides

changing color 39
showing and hiding 39

slice objects
as event areas 117
auto-naming 119
creating 117
creating based on selected objects 118
naming 119
slice guides 118
slicing when exporting 117
specifying export settings 119

Slice tool 18
sliced images

copying and pasting from Fireworks 133
slicing

options when exporting 92
slicing a path 51
smart cursor 44
smoothing JPEG images 104
Snap to Grid command 38
Snap to Guide command 39
split view

in Export Preview 94
squares 48

rounded corners 49
stars

angle 49
number of points 49

starting Fireworks 11
status bar (Windows only) 15
striped border 52
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Stroke button (Windows only) 19
Stroke panel 24, 60
Stroke preview

showing and hiding 24
strokes 59Ð61

adding texture 64
brush stroke preview 60
categories 60
changing centering 50
choosing a stroke 60
color well 58
edge 60
editing 60
finding and replacing 77
moving 50 (steps)
names 60
reorienting 50
saving settings 61
texture 60

styles
adding 63 (steps)
deleting 64
editing 64
exporting 64
importing 64
using 63

Styles panel 30, 63
Subselect command 67
Subselection tool 16, 47
Subtract from Transparency tool 101
Superselect command 67
swap colors 58
swatches

adding to Swatches panel 22
deleting from Swatches panel 22
exporting to external set 22
replacing in Swatches panel 22
saving from Swatches panel 22
sorting from Swatches panel 22
using export palette 22

Swatches panel 22, 57
adding active color 57 (steps)
adding colors 96 (steps)
appending a palette 57 (steps)
applying color 57
changing palette 22
deleting a color 57 (steps)
eyedropper cursors 57
replacing a color 57 (steps)
using the current export palette 57

Symbol Options command 79
symbols

adding items to 79
breaking link with instances 79
creating 78, 79
defined 78
deleting 79
finding 79
inserting 79
modifying 79
moving with instances 79
options 79
tweening 80

symbols and instances 78Ð80
breaking links 79
moving 79
use in animation 127

System color picker
canvas 59
color wells 58
defining colors using 23

System palette 97
System requirements 10
Index 153



T
target 121
templates

HTML output styles 131
text 67Ð69

aligning 68
anti-aliasing 67
attaching to paths 69
baseline shift 68
block alignment 68
bold 68
bold italic 68
changing attributes 68
choosing fonts 68
converting to images 69 (steps)
converting to paths 69 (steps)
detaching from paths 69
direction 69
direction of flow 68
editing path attached to 69
editing when attached to path 69
entering 67 (steps)
feathering 67
finding and replacing 76
fonts 68
horizontal scale 68
importing 88
importing ASCII 88
importing RTF 88
italic 68
kerning 68
leading 68
moving starting point on path 69 (steps)
orientation 68
placing on paths 69 (steps)
point size 68
range kerning 68
resizing 67
underlining 68
using 67
vertical 69

text color
applying using Color Mixer 23

Text Editor 26, 68
opening 26

Text tool 17
texture 64

transparency 61
thumbnail images

creating 108
TIFF

defined 106
tool groups

contents 16
displaying 16

toolbars
Info panel 19
showing and hiding 31
using 21
View Controls 21

Toolbox 16
contents 16Ð18
displaying alternate tools 16
showing or hiding 21
showing tool groups 16

tools
Brush 17
Circle Hotspot 18
Crop 16
Distort 17
Ellipse 17
Ellipse Marquee 16
Eraser 18
Export Area 16
Export Area tool 103
Eyedropper 17
Freeform 17
Hand 17
in Toolbox 16Ð18
Lasso 16
Line 17
Magic Wand 17
Magnify 17
Marquee 16
Paint Bucket 18
Path Scrubber 17
Pen 17
Pencil 17
Pointer 16
Polygon 17
Polygon Hotspot 18
Polygon Lasso 16
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Rectangle 17
Rectangle Hotspot 18
Redraw Path 17
Reshape Area 17
Rubber Stamp 18
Scale 17
Select Behind 16
Skew 17
Slice 18
Subselection 16
Text 17

ToolTips 19
Transform tools 54
transforming

by dragging 54
numerically 55

transforming objects 54
transparency

Add to Transparency tool 101
adding to fill textures 64
alpha channel transparency 129
animated GIFs 127
compositing 81
Eyedropper tools 101
GIF images 129
overview 129
Select Transparency tool 101
setting during export 101
Subtract from Transparency tool 101
texture 61
types 101

Trim Canvas command 54
turning panels on and off 31
tutorials 12
Twain importing 90
Tween Instances command 80
tweening

characteristics 80
defined 80
objects 80 (steps)

U
underlining 68
Undo

command 38
levels 38

Undo button (Windows only) 18
ungrouping objects 71
uniform palette 97
uninstalling

Fireworks 12 (steps)
Union command 48
units of measurement 38
Unsharp Mask Xtra 65
Up state

JavaScript rollovers 120
URL Manager 29

working with 30
URLs

adding 30
adding from Fireworks file 30
assigning 30
assigning to image maps 116
assigning to JavaScripts 121
attached to web objects 114
creating new library 30
defined 29
deleting 30
determining 30
editing 30
exporting 30
finding and replacing 78
importing 30
managing 29
setting using Object inspector 115
target 121
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V
vector art

importing 40
vector drawing 44
Vector File Options

when importing 89
View Controls toolbar 21
viewing document

Full Display or Draft Display 34
viewing panels 31
views, multiple 33

W
Web 216 palette 97
Web Dither fill 63
web export formats 103Ð106
web formats compared 105
Web Layer 73
web layers 114
web objects 114Ð115

alternate text 114
auto-naming slice objects 119
behaviors 114
characteristics 114
creating 115
creating toggle groups 123
customizing HTML code 123
export settings 119
exporting image maps 117
location in document 73
naming slice objects 119
pre-caching JavaScript rollovers 123
setting properties 115
slicing when exporting 117
specifying swap images 121
URLs 114
using bevel effects 121
using external files for rollovers 122
using irregularly shaped images 122
web layers 114

web-safe palette 97, 100
Websnap adaptive palette 97
Windows

installing and starting Fireworks 11 (steps)
System requirements for 10
uninstalling Fireworks 12

workflow
How is Fireworks unique? 34Ð37
importing and exporting 86

working with URL Manager 30

X
xRes LRG

defined 106
Xtras 54, 67

Blur 54, 67
Invert 54, 67
Sharpen 54, 67

Xtras menu 65

Z
zero point 38
zooming in 32
zooming out 32
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