Présentation de Microsoft FrontPage Express

FrontPage Express est un éditeur de pages Web qui vous donne accès à toute la puissance du langage HTML (Hypertext Markup Language). Vous pouvez utiliser FrontPage Express pour créer des pages Web au format HTML tout en travaillant dans un affichage « tel écrit tel écran » (ou WYSIWYG) qui vous permet de visualiser la mise en forme et la disposition réelles de votre page.

FrontPage Express fonctionne également avec l'Assistant Personnaliser ce dossier (dans le menu Affichage du Poste de travail) de sorte que vous pouvez facilement personnaliser l'affichage de vos dossiers.

Grâce aux fonctionnalités simples d'emploi de FrontPage Express, vous pouvez créer des pages Web attrayantes et très élaborées. Vous pouvez, par exemple, effectuer les tâches suivantes :

  • Appliquer des balises HTML à partir de la liste de la barre d'outils sans avoir à les taper manuellement.

  • Sélectionner du texte ou des paragraphes et appliquer une mise en forme et un alignement en cliquant simplement sur un bouton de la barre d'outils.

  • Insérer des images que vous avez créées ou des images provenant de vos collections favorites (aucune collection n'est incluse dans FrontPage Express).

  • Ouvrir des pages Web existantes directement à partir du Web (si vous avez installé l'Assistant de publication de sites Web) ou d'un fichier situé sur votre ordinateur ou sur un réseau.

  • Enregistrer votre travail directement sur le Web (à l'aide de l'Assistant de publication de sites Web) ou dans un fichier.

  • Ajouter des bannières (texte déroulant).

FrontPage Express offre de nombreuses fonctionnalités de l'éditeur Microsoft FrontPage, dans un coffret de moindre taille. La mise à niveau vers FrontPage s'effectue facilement, sans qu'il soit nécessaire d'apprendre un nouveau programme ou une nouvelle méthode de création de pages Web. FrontPage combine les fonctionnalités de l'éditeur et du navigateur FrontPage.


Personnalisation de vos dossiers en utilisant le style du Web

Désormais, il vous est possible de faire sur tout dossier de votre disque dur l'ensemble des opérations que vous effectuez sur une page Web !

Lorsque vous affichez le contenu de votre ordinateur en utilisant le style du Web, vous pouvez personnaliser l'arrière-plan de tout dossier en utilisant l'Assistant Personnaliser ce dossier (dans le menu Affichage du Poste de travail). Vous pouvez faire encore mieux en transformant tout dossier en page Web à l'aide de l'Assistant et de FrontPage Express.

Une fois votre dossier transformé en page Web, vous pouvez utiliser FrontPage Express pour ajouter des liens vers Outlook Express ou vers d'autres composants, insérer des contrôles ActiveX, personnaliser les styles et tailles de police ou ajouter des filigranes. Utilisez cette fonctionnalité juste pour vous amuser ou pour partager les informations professionnelles de dernière minute dans des dossiers partagés personnalisés. Quel que soit l'usage que vous en faites, vous pouvez créer des dossiers qui correspondent exactement à vos besoins.


Fonctionnalités avancées de FrontPage Express

Grâce aux fonctionnalités simples d'emploi de FrontPage Express, vous pouvez donner à vos pages Web un aspect attrayant et recherché. Vous pouvez, par exemple, effectuer les tâches suivantes :

  • Ajouter des couleurs et des filigranes d'arrière-plan.

  • Utiliser les composants WebBot pour ajouter une fonctionnalité avancée sans programmation complexe. Un WebBot est un « objet dynamique » d'une page Web qui s'exécute lorsque l'auteur de cette page l'enregistre sur le serveur Web ou, dans certains cas, lorsque l'utilisateur affiche la page. FrontPage Express comprend des composants WebBot qui ajoutent dans des pages Web les fonctionnalités Horodateur, Insertion de fichiers et Rechercher. (Pour obtenir la gamme complète des composants WebBot, notamment la gestion de formulaires et les barres de navigation, effectuez une mise à niveau vers Microsoft FrontPage.)

  • Utiliser les contrôles ActiveX pour augmenter l'impact de votre page Web.

  • Insérer de nouvelles balises HTML à mesure de leur disponibilité, à l'aide de la commande Balise HTML.

  • Afficher et modifier toutes les balises HTML directement dans la page Web. Le codage à l'aide de couleurs de FrontPage Express permet de distinguer facilement les balises du contenu.


Mise à niveau vers FrontPage

Mise à niveau vers Microsoft FrontPage

Lorsque vous êtes prêt à créer des pages Web plus compliquées, la mise à niveau de Microsoft FrontPage Express vers Microsoft FrontPage est simple. Le produit vous semblera déjà familier, puisque FrontPage Express a été conçu en s'inspirant de l'éditeur FrontPage compris dans Microsoft FrontPage.

Microsoft FrontPage est un coffret complet pour les auteurs de pages Web et les administrateurs de sites Web. FrontPage Express et FrontPage représentent une combinaison idéale pour les organisations dans lesquelles les besoins de chacun varient, allant du simple affichage ou de la simple édition (FrontPage Express) à l'édition ou à l'affichage illimités, voire à l'administration du Web (FrontPage).

FrontPage propose un environnement complet d'édition de pages Web avec les composants suivants :

  • L'éditeur FrontPage vous permet de créer, d'afficher et d'enregistrer des documents HTML. Il comprend des modèles, des Assistants et des composants WebBot afin de pouvoir facilement créer des pages Web attrayantes. Dans la mesure où l'éditeur FrontPage fonctionne aussi comme un mininavigateur, vous pouvez l'utiliser pour importer des pages en provenance de tout emplacement sur Internet ou sur un intranet.

  • Le navigateur FrontPage vous permet de gérer, d'afficher et de manipuler un site Web. Vous pouvez élaborer et tester un site Web sur votre ordinateur personnel, puis copier l'intégralité du site sur un serveur Web. Vous pouvez aussi utiliser le navigateur FrontPage comme serveur Web personnel pour exécuter un site Web directement à partir de votre Bureau, soit en tant que partie intégrante d'un intranet, soit en tant que site public sur le World Wide Web.