جدولة مهامTopnode

جدولة المهام

يمكنك استخدام جدولة المهام لجدولة الأوامر، البرامج، أو النصوص للتشغيل في أوقات محددة:

  • قبل استخدام جدولة المهام، راجع قائمة الاختيار.
  • للمساعدة في مهام محددة، راجع كيفية.
  • للحصول على معلومات خلفية عامة، راجع مفاهيم.
  • للحصول على إرشادات لحل المشاكل، راجع استكشاف الأخطاء وإصلاحها.


قائمة تحقق جدولة المهام

قائمة التحقق

يسرد الجدول التالي الإجراءات التي تقوم بإجرائها أكثر الأحيان في جدولة المهام. للحصول على قائمة كاملة من إرشادات جدولة المهام، راجع كيفية.

خطوة | مرجع
قبل أن تتمكن من جدولة مهمة للتشغيل، يجب عليك إضافة المهمة. | جدولة مهمة جديدة
حالما يتم إنشاء المهام المجدولة، يمكنك تعديل البرنامج، الجدول، أو التعيينات لمهمة معينة. | تعديل مهمة مجدولة
بالنسبة للمهام المجدولة التي لست بحاجة إليها بعد الآن، يمكنك إزالتها بشكل كامل. | إزالة مهمة مجدولة
في الحدث الذي تبدأ به مهمة مجدولة أثناء استخدام الكمبيوتر، يمكنك إيقاف المهمة ومن ثم إعادة البدء بها مرة أخرى. | إيقاف مهمة مجدولة وهي قيد التشغيل
يمكنك وبشكل مؤقت إيقاف أو إيقاف مؤقت كافة المهام المجدولة عن التشغيل ومن ثم إلغاء إيقافها المؤقت في وقت لاحق. | إيقاف كافة المهام المجدولة بشكل مؤقت


كيفية...

  • جدولة المهام
  • إدارة جدولة المهام


جدولة المهام
  • بدء تشغيل برنامج جدولة المهام
  • جدولة مهمة جديدة
  • تعديل مهمة مجدولة
  • إزالة مهمة مجدولة
  • إيقاف مهمة مجدولة قيد التشغيل
  • تشغيل مهمة حالاً


البدء بجدولة المهام

للبدء بجدولة المهام

  • يمكنك البدء بجدولة المهام بالنقر نقراً مزدوجاً فوق جهاز الكمبيوتر، ومن ثم النقر نقراً مزدوجاً فوق جدولة المهام.
  • انقر نقراً مزدوجاً فوق جدولة المهام،ومن ثم نقراً مزدوجاً فوق إضافة مهمة مجدولة لفتح معالج المهمة المجدولة، والذي يتابع معك خلال جدولة مهمة.


جدولة مهمة جديدة

لجدولة مهمة جديدة
  1. قم ببدء تشغيل برنامج جدولة المهام.
  2. انقر نقراً مزدوجاً فوق إضافة مهمة مجدولة.
  3. اتبع الإرشادات التي تظهر في معالج إضافة المهمة المجدولة.

ملاحظات

  • إذا أردت تكوين تعيينات متقدمة للمهمة، حدد خانة الاختيار فتح الخصائص المتقدمة لهذه المهمة عند النقر فوق إنهاء في شاشة المعالج النهائية.
  • لتشغيل المهمة الجديدة في كل مرة يتم فيها تشغيلها، قم بتحديد خانة الاختيار فتح الخصائص المتقدمة لهذه المهمة عند النقر فوق إنهاء في شاشة المعالج النهائية، ثم انقر فوق علامة التبويب جدولة ثم انقر فوق خيارات متقدمة.
  • إذا تطلب برنامج المهمة معلمات، قم بتحديد خانة الاختيار فتح الخصائص المتقدمة لهذه المهمة عند النقر فوق إنهاء في شاشة المعالج النهائية، ثم انقر فوق علامة التبويب المهمة ثم اكتب المعلمات في المربع تشغيل، بعد مسار المهمة.
  • تأكد من دقة تاريخ النظام ووقته في جهاز الكمبيوتر. ويعتمد برنامج جدولة المهام على هذه المعلومات لمعرفة متى يجب تشغيل المهام المجدولة. للتدقيق في التاريخ والوقت أو تغييرهما، انقر نقراً مزدوجاً فوق الوقت في شريط المهام.


تعديل مهمة مجدولة

لتعديل مهمة مجدولة
  1. قم ببدء تشغيل برنامج جدولة المهام.
  2. انقر بزر الماوس الأيمن فوق المهمة التي تريد تعديلها، ثم انقر فوق خصائص.
  3. قم بواحد أو أكثر مما يلي:
    • لتغيير البرنامج الذي تقوم بتشغيله، في تشغيل، قم بكتابة المسار للبرنامج الجديد.
    • لتغيير جدول المهمة، انقر فوق علامة التبويب جدولة.
    • لتخصيص إعدادات للمهمة، انقر فوق علامة التبويب إعدادات.

ملاحظات

  • إذا تم تغيير حساب المستخدم أو البرنامج الذي يتم تشغيله، يجب توفير كلمة المرور لحساب المستخدم.
  • إذا كان برنامج المهمة يتطلب خيارات سطر أوامر، اكتب الخيارات في تشغيل، بعد مسار المهمة.
  • إذا تضمن المسار إلى برنامج المهمة مسافات، عليك وضع علامات اقتباس مزدوجة ("")حول مسار المهمة بأكمله.
  • تأكد من دقة وتاريخ وقت النظام في الكمبيوتر، حيث أن برنامج المهام المجدولة يعتمد على هذه المعلومات لتشغيل المهام المجدولة. للتدقيق في الوقت والتاريخ أو تغييرهما، انقر نقراً مزدوجاً فوق مؤشر الوقت في شريط المهام.


إزالة مهمة مجدولة

لإزالة مهمة مجدولة
  1. ابدأ تشغيل برنامج جدولة المهام.
  2. انقر بزر الماوس الأيمن على المهمة التي تريد إزالتها، ثم انقر فوق حذف.

ملاحظات

  • إن إزالة المهمة المجدولة يقوم فقط بإزالة الجدول من قائمة الجداول. ولا تتم إزالة ملف البرنامج من القرص الثابت.
  • يمكنك أيضاً إزالة مهمة مجدولة بواسطة الضغط على المفتاح DELETE.


إيقاف مهمة مجدولة قيد التشغيل

لإيقاف مهمة مجدولة قيد التشغيل
  1. ابدأ تشغيل برنامج جدولة المهام.
  2. انقر بزر الماوس الأيمن فوق المهمة التي تريد إيقافها، ثم انقر فوق إنهاء المهمة.

ملاحظات

  • إذا كانت المهمة المجدولة تؤدي إلى بدء تشغيل برنامج آخر، فإن هذا الأمر يقوم بإيقاف المهمة المجدولة الأصلية فقط، ولا يؤدي إلى إيقاف المهمة الثانية.
  • لإعادة تشغيل مهمة تم إيقافها، انقر بزر الماوس الأيمن فوق المهمة، ثم انقر فوق تشغيل.


تشغيل مهمة فوراً

لتشغيل مهمة فوراً
  1. ابدأ تشغيل برنامج جدولة المهام
  2. انقر بزر الماوس الأيمن فوق المهمة التي تريد البدء بتشغيلها، ثم انقر فوق تشغيل.

ملاحظات

  • يمكنك إيقاف المهمة بالنقر فوق إنهاء المهمة في القائمة ملف.
  • إذا كان يجب ان يتم تشغيل المهمة ولم يحدث ذلك، في القائمة خيارات متقدمة، انقر فوق عرض السجل لفحص سجل المهمة.


إدارة جدولة المهام
  • عرض تسجيل دخول لما بعد المهام المجدولة.
  • عرض المهام المجدولة على أجهزة الكمبيوتر البعيدة
  • إيقاف كافة المهام المجدولة بشكل مؤقت
  • إيقاف مؤقت لجدولة المهام
  • تعيين حساب خدمة At


عرض سجل لمهام مجدولة سابقة

لعرض سجل لمهام مجدولة سابقة
  1. ابدأ تشغيل برنامج جدولة المهام.
  2. في القائمة خيارات متقدمة، انقر فوق عرض السجل.


عرض المهام المجدولة على أجهزة الكمبيوتر البعيدة

لعرض المهام المجدولة على أجهزة الكمبيوتر البعيدة

  1. على سطح المكتب، انقر نقراً مزدوجاً فوق جوار شبكة الاتصال.
  2. انقر نقراً مزدوجاً فوق جهاز الكمبيوتر الذي تريد عرض المهام المجدولة عليه.
  3. انقر فوق مهام مجدولة.

ملاحظات

  • يمكنك عرض المهام على كمبيوتر بعيد يقوم بتشغيل Windows فقط إذا كنت المسؤول عن ذلك الكمبيوتر البعيد.
  • يمكنك تحرير المهام على كمبيوتر بعيد يقوم بتشغيل Windows فقط إذا كان لدى ذلك الكمبيوتر البعيد برنامج تسجيل بعيد تم تثبيته ويشارك المشاركة x$، حيث يكون x هو القرص الثابت الذي تتوضع عليه المهام المجدولة للمجلد.يجب أيضاً أن يسرد Windows وبشكل خاص حساب المستخدم كونه لديه وصول بعيد إلى التسجيل. يمكنك تحديد أي من المستخدمين لديه وصول بعيد إلى التسجيل للكمبيوتر الذي يقوم بتشغيل Windows بالنقر فوق كلمات المرور في لوحة التحكم.


إيقاف كافة المهام المجدولة بشكل مؤقت

لإيقاف كافة المهام المجدولة بشكل مؤقت
  1. ابدأ تشغيل برنامج بجدولة المهام.

  2. في القائمة خيارات متقدمة، انقر فوق إيقاف مؤقت لبرنامج جدولة المهام.

ملاحظات

  • يكون هذا الأمر مفيداً إذا كنت تقوم بتشغيل برنامج آخر (مثل لعبة) أو تثبيت برنامج، ولاتريد تشغيل المهمة المجدولة في نفس الوقت.
  • تكون المهام التي يتم تشغيلها أثناء إيقاف جدولة المهام بشكل مؤقت ليست قيد التشغيل حتى وقت الجدولة التالي.
  • لاستئناف الجداول لكافة المهام، في القائمة خيارات متقدمة، انقر فوق متابعة برنامج جدولة المهام.


إيقاف مؤقت لبرنامج جدولة المهام

لإيقاف مؤقت لبرنامج جدولة المهام
  1. ابدأ تشغيل برنامج جدولة المهام.
  2. في القائمة خيارات متقدمة، انقر فوق إيقاف استخدام برنامج جدولة المهام.

ملاحظة

  • عندما يتم إيقاف تشغيل برنامج جدولة المهام، فلن يتم تشغيل المهام المجدولة ولن يتم بدء تشغيل برنامج جدولة المهام تلقائياً في المرة التالية التي يتم فيها تشغيل Windows.


تعين حساب خدمة AT

لتعيين حساب خدمة At
  1. ابدأ تشغيل برنامج جدولة المهام.
  2. في قائمة خيارات متقدمة، انقر فوق حساب خدمة At.
  3. انقر فوق هذا الحساب، ثم قم بكتابة حساب المستخدم الذي سيقوم بتشغيل المهام المجدولة باستخدام الأمر at.
  4. في كلمة المرور وتأكيد كلمة المرور، اكتب كلمة المرور الصحيحة للحساب.

ملاحظات

  • إن خدمة AT متوفرة فقط في Windows NT.
  • يمكنك النقر بشكلٍ اختياري فوق حساب النظام. إذا قمت بذلك، فإن برنامج جدولة المهام يقوم بتشغيل مهام الأمر at بواسطة استخدام حساب LocalSystem، الذي يتطلب حقوقاً إدارية.

  • إن حساب المستخدم الذي تقوم بتحديده يجب ان يكون لديه أذونات مناسبة لتشغيل أية مهام تقوم بجدولتها بواسطة استخدام الأمر at.على سبيل المثال، إذا قمت بجدولة برامج يمكن تشغيلها فقط من قبل الإداريين، يجب أن يكون الحساب الذي تحدده حساباً إدارياً.


مفاهيم جدولة المهام

مفاهيم

يوفر هذا المقطع معلومات عامة عن جدولة المهام:

  • مقدمة لجدولة المهام
  • استخدام جدولة المهام
  • جدولة المهام والأمر AT
  • جدولة المهام وعامل الأمان
  • استكشاف الأخطاء وإصلاحها


مقدمة لـ "مهام مجدولة"

بواسطة استخدام "مهام مجدولة"، يمكن القيام بجدولة المهام (كملغي تجزئة الأقراص) لتشغيلها عند الوقت الأكثر ملاءمةً لك. يبدأ "مهام مجدولة" بالعمل في كل مرة تقوم فيها ببدء تشغيل Windows، ثم يقوم بالعمل في الخلفية.

يمكن باستخدام "مهام مجدولة" القيام بما يلي:

  • جدولة مهمة لتشغيلها يومياً، أسبوعياً، شهرياً، أو في بعض الأوقات (مثلاً عند بدء نظام التشغيل).
  • تغيير جدولة مهمة.
  • إيقاف مهمة مجدولة.
  • تخصيص كيفية تشغيل مهمة عند وقت مجدول.


استخدام جدولة المهام

يقوم نظام تشغيل Windows بتثبيت جدولة المهام بشكل تلقائي. لاستخدام خدمة الجدولة، انقر نقراً مزدوجاً فوق المهام المجدولة في جهاز الكمبيوتر.

يمكنك إضافة المهام عن طريق النقر المزدوج فوق إضافة مهمة مجدولة، والتي تبدأ بمعالج المهمة المجدولة.يمكنك إضافة مهام عن طريق سحب النصوص، البرامج، أو المستندات من Windows Explorer أو سطح المكتب إلى إطار المهام المجدولة.

يمكنك أيضاً استخدام جدولة المهام لتعديل، حذف، إيقاف مؤقت، أو إيقاف المهام التي قمت بجدولتها، أو لعرض ملف السجل بعد المهام المجدولة، أو لعرض المهام المجدولة على كمبيوتر بعيد.

للحصول على إرشادات مفصلة حول استخدام جدولة المهام، راجع كيفية.

أفضل التمارين لجدولة المهام

في نظام تشغيل Windows، يمكنك استخدام جدولة المهام لجدولة أي تطبيق لتشغيله. للاستفادة من جدولة المهام، تأكد من دقة تاريخ ووقت النظام للكمبيوتر قبل إضافة مهمة.


استخدام برنامج جدولة المهام والأمرat

برنامج جدولة المهام والأمر At

بالإضافة لاستخدام برنامج جدولة المهام، يمكنك أيضاً استخدام الأمر at لتشغيل المهمات تلقائياً.

إن برنامج جدولة المهام ليس مماثلاً للأمر at، لكن الاثنان يعملان معاً. عندما تقوم بجدولة مهمة باستخدام الأمر at، يقوم الأمر بالظهور في قائمة المهام في إطار برنامج جدولة المهام.

يمكن استخدام برنامج جدولة المهام لتعديل خصائص المهمة التي تمت جدولتها بواسطة الأمر at. مهما يكن، إذا قمت بذلك، عليك الإستمرار باستخدام برنامج جدولة المهام للوصول للمهمة. يمكنك عدم الوصول إلى المهمة باستخدام الأمر at.

لتحديد حساب المستخدم الذي سيقوم بتشغيل المهام المجدولة باستخدام الأمر at، في جهاز الكمبيوتر، انقر فوق مهام مجدولة، وفي القائمة خيارات متقدمة، انقر فوق حساب خدمة AT.

ملاحظة

  • إن خدمة AT متوفرة في Windows NT فقط.


عامل أمان جدولة المهام

جدولة المهام وعامل الأمان

في جدولة المهام، يمكنك تعيين عامل الأمان عن طريق تعيين اسم مستخدم وكلمة مرور لمهمة معينة. حالما يتم تعيين اسم مستخدم وكلمة مرور لمهمة معينة، لايمكن إلغاء المهمة أو حذفها من قبل مستخدم آخر.

ملاحظات

  • هذه الميزة متوفرة فقط على Windows NT.
  • يجب عليك إدخال اسم مستخدم في معالج المهام المجدولة قبل أن تتمكن من متابعة جدولة مهمة. إن كلمات المرور غير مطلوبة.
  • يمكنك تغيير أو تعيين كلمة مرور جديدة عن طريق تحديد خانة الاختيار فتح الخصائص المتقدمة لهذه المهمة عند النقر فوق إنهاء في الشاشة النهائية للمعالج.


جدولة مهام استكشاف الأخطاء وإصلاحها

إذا كانت مهمة تقوم بجدولتها لا تعمل عندما تتوقع عملها، انقر بزر الماوس الأيمن فوق المهمة، ومن ثم انقر فوق خصائص. على علامة التبويب المهمة، تحقق من تحديد خانة الاختيار تمكين. على علامة التبويب جدولة، تحقق من أن الجدول معين بشكل صحيح.

إذا كان برنامج مهمة لايعمل بشكل صحيح، فربما تحتاج لإضافة خيارات سطر الأوامر. لمعرفة أكثر حول برنامج معين وخيارات سطر أوامره، حاول أحد الأمرين التاليين:

  • اعرض التعليمات الفورية للبرنامج، إذا كانت متوفرة لديك.

  • عند المطالبة بأمر، اكتب التالي: (حيث يمثل Program اسم البرنامج)

    • ‎Program /?‎


مكوّن Windows NT غير مثبت

لا يمكن القيام ببدء تشغيل هذا البرنامج.

الأسباب المحتملة هي:

    • تمت إزلة البرنامج بواسطة مسؤول النظام.
    • مسؤول النظام قام بتغيير النهج المقترن بهذا الملف.
    • البرنامج غير مثبت على جهاز الكمبيوتر.
    • تم حذف البرنامج بطريق الخطأ.
    • الملف معطوب.

إذا كان مسؤول النظام يقوم بالتحكم بالجهاز، يجب الاتصال بالمسؤول لمعرفة سبب عدم التمكن من بدء تشغيل البرنامج.