
Commands

Add Sheet Entry
Add/Remove Library
Align Objects
Align objects on bottom
Align objects on left
Align objects on right
Align objects on top
Annotate
Back Annotate
Bill of Materials
Bring To Front
Bring To Front Of
Center objects around horizontal axis
Center objects around vertical axis
Change
Change Object Graphically or Move
Change Object Graphically or Set Focus
Change Single Object
Clear
Convert Complex To Simple Hierarchy
Copy
Create Netlist
Create Sheet From Sheet Symbol
Create Sheet Symbol From Sheet
Cross Probe Net On PCB
Cross Probe Part on PCB
Cross Probe Pin on PCB
Cursor Down
Cursor Left
Cursor Right
Cursor Up
Cut
De-Select All
De-Select Inside Area
De-Select Outside Area
Delete
Delete Single Object
Distribute equally along horizontal axis
Distribute equally along vertical axis
Down Hierarchy
Drag
Drag Selection
Drag Single Item
Edit Component
Edit Object From Browser
Electrical Rules Check
Execute Paste Array
File Close
File Close Project
File Exit
File New
File Open Project
File Open Sheet



File Print
File Save
File Save All
File Save As
File Save Project
Find Component in Library
Find Next Text
Find Text
Find and Replace Text
Help
Help About
Help Basic Concepts
Help Commands
Help DOS Schematic
Help Index
Help OrCAD
Help Printing
Help Reference
Hot Keys
Increment Part Number
Information Selected Pins
Information System Status
Jump Location Mark 1
Jump Location Mark 10
Jump Location Mark 2
Jump Location Mark 3
Jump Location Mark 4
Jump Location Mark 5
Jump Location Mark 6
Jump Location Mark 7
Jump Location Mark 8
Jump Location Mark 9
Jump New Location
Jump Origin
Jump To Next Error
Jump to Object
Make Project Library
Memory Monitor Setup
Move
Move Selection
Move Single Object
Move To Front
Netlist Compare
Open Environment Configuration File
Paste
Paste Array
Place Annotation
Place Arcs
Place Beziers
Place Bus
Place Bus Entry
Place Ellipses
Place Elliptical Arcs
Place Graphic
Place Junctions
Place Lines



Place Net Label
Place No ERC
Place PCB Layout
Place Part from Browser
Place Parts
Place Pie Charts
Place Polygons
Place Port
Place Power Port
Place Probe
Place Rectangles
Place Round Rectangle
Place Sheet Symbol
Place Stimulus
Place Test Vector Index
Place Text Frame
Place Wire
Popup Alignment Menu
Popup De-Select Menu
Popup Edit Menu
Popup File Menu
Popup Help Menu
Popup Info Menu
Popup Jump Menu
Popup Library Menu
Popup Location Mark Menu
Popup Move Menu
Popup Options Menu
Popup Place Menu
Popup Select Menu
Popup Tools Menu
Popup Window Menu
Popup Zoom Menu
Preferences
Redo
Remove Template
Rename Object Text
Report Cross Reference
Report Project Hierarchy
Run Analog Simulator
Run CSV Editor
Run Calculator
Run Clock
Run Control Panel
Run Digital Simulator
Run File Manager
Run Library Editor
Run Mixed Signal Simulator
Run Notepad
Run PCB Editor
Run PLD/FPGA Compile
Run Picture Editor
Run Text Editor
Run User Program 1
Run User Program 2
Run User Program 3



Run User Program 4
Run Windows Setup
Save Environment Configuration File
Screen Redraw
Search For Net
Select All
Select Connection
Select Inside Area
Select Net
Select Outside Area
Send To Back
Send To Back Of
Set Location Mark    10
Set Location Mark    2
Set Location Mark    3
Set Location Mark    4
Set Location Mark    5
Set Location Mark    6
Set Location Mark    7
Set Location Mark    8
Set Location Mark    9
Set Location Mark 1
Set Template File Name
Setup Autopan
Setup Printer
Setup Run Options
Sheet Options
Shift Cursor Down
Shift Cursor Left
Shift Cursor Right
Shift Cursor Up
Toggle Command Status Bar
Toggle Component Browser
Toggle Drawing Toolbar
Toggle Electrical Grid
Toggle Main Toolbar
Toggle Project Manager
Toggle Scroll Bars
Toggle Selection
Toggle Single Object
Toggle Snap Grid
Toggle Status Bar
Toggle Visible Grid
Toggle Wiring Toolbar
Undo
Up Hierarchy
Update Current Template
Update Parts
Using Help
View Read Only Part Fields
Window Arrange Icons
Window Cascade
Window Close All
Window Tile
Zoom 100%
Zoom 200%



Zoom 400%
Zoom 50%
Zoom All
Zoom In
Zoom Out
Zoom Pan
Zoom Point
Zoom Sheet
Zoom Window



File Open Sheet

Summary Open and load a schematic worksheet file.

To Launch  F O    -    

Purpose The file open command is used to load and display the contents of a schematic 
worksheet file into a new document window, ready to visually check or edit. You can load any number of 
schematic worksheet files into separate windows.

Outcome Once the schematic worksheet file has been selected it will load into a new 
document window and all the sheet preferences will be restored. This is because Advanced Schematic 
stores the sheet options in the worksheet whenever you save the file.

Comments Advanced Schematic can load any number of schematic worksheet files into separate 
windows using the Multiple Document Interface (MDI). Advanced Schematic will load old 
Protel Schematic 2.xx and 3.xx files as well as OrCAD STD III and STD IV. 

          When no document file is open, the Menu bar displays four options: File, Info, Library 
and Help. 

          You can abort the drawing (or redraw) of the document window, at any time, by pressing 
the SPACEBAR. This allows you to move directly to another menu command or Tool button
without waiting for the entire screen redraw to be completed.

Procedure To open a previously created file:

          1. Choose Open from the File menu.

          2. Type the filename (include the full path, if different from the path listed after Directory)

          3. Click OK to open the file.

          You can also double-click on the desired filename in the Files window, if any. To change 
directories, click under any of the options listed in the Directories window.

See also
File Open Project
Opening Schematic Files



File Open Project

Summary Open and load all schematic sheets in a project.

To Launch  F J

Purpose The Open Project command is used to load and display the contents of all the 
hierarchical worksheet files contained in a schematic project.

Outcome Once the schematic project file has been selected, all the hierarchical schematic 
worksheet files will load into new document windows. The Project Manager will be 
displayed at the left side of the schematic application window, listing all the currently 
loaded schematic files.

Comments The Project Manager may be toggled off by clicking on the Project Manager button on 
the Main toolbar or by choosing Project Manager from the Options menu.

Procedure To open a schematic project:

          1. Choose Open Project from the File menu.

          2. Type the filename (include the full path, if different from the path listed after Directory)

          3. Click OK to open the project file.

          You can also double-click on the desired filename, if any, in the Files window. To change 
directories, double-click on any of the options listed in the Directories window.

See also
File Open Sheet
Opening Schematic Files



File Save Project

Summary Save all the sheets in the current project.

Outcome When you select the File Save Project command, the contents of the current schematic 
project will be saved to the Advanced Schematic binary file format using the existing 
paths and filenames. A backup file is created for each of the sheets in the project, with 
".bak" extension.

Comments If the schematic project has been created with the File New command and has not been 
previously saved, the Save File As dialog box will open. You can save the file to a new 
path, new name or format.

Procedure To save the current schematic project:

          1. Choose Save Project from the File menu.

See also
File Save All
File Save As
File Save
Save and Save As information



File New

Summary Create a new, empty schematic worksheet.

To Launch  F N

Purpose The File New command is used to create a new blank schematic worksheet.

Outcome When you choose the File New command, an empty document window is displayed and 
becomes the current window with the title "SCH_#".

Comments You can change and define various sheet settings, such as sheet styles, size, 
orientation, color and other options that apply to the worksheet by choosing Sheet from 
the Options menu.

Procedure To create a new schematic worksheet:

          1. Choose New from the File menu.

See also
Sheet Options



File Save All

Summary Save all loaded schematic project and worksheet files.

To Launch Alt F L

Purpose The File Save All command can be used to save all of the schematic worksheet files in 
all currently opened document windows.

Outcome When you select the File Save All command, this will save the contents of all the 
document windows to the Advanced Schematic binary file format, using the existing 
paths and file names.

Procedure To save all schematic worksheets which are currently opened:

          1. Choose Save All from the File menu.

See also
File Save
File Save As
File Save Project
Save and Save As information



File Exit

Summary Quit from Advanced Schematic.

To Launch  F X

Purpose The File Exit command is used to close down all opened schematic worksheets, and end
the current work session of Advanced Schematic.

Outcome When the File Exit command is selected, the current session of Advanced Schematic 
ends and the program prompts you to save modified files.

Procedure To quit the current session of Advanced Schematic:

          1. Choose Exit from the File menu.

          2. If any document window has been modified since last saving, a dialog box will be 
displayed that prompts to save the file(s). Choose Yes to save the file(s), choose No to 
exit without saving the file(s)    or Cancel to ignore the File Exit command.



Hot Keys

Summary Setup Hot Key assignments.

To Launch  O H

Purpose The Options Hot Keys command is used to assign keyboard keys and mouse button 
clicks to Advanced Schematics command processes, such as "Place Wire," "Select Net,"
"Toggle Snap Grid" or any other command.

Comments There are three other buttons in this dialog box; Load is used to open a previously saved
hot key assignments file. Save is used to save the current hot key assignments to a file. 
Finally, Defaults is used to restore the current hot key assignments to the Advanced 
Schematic default settings which are listed at the back of this reference.

Procedure To assign keyboard keys and mouse button clicks to command processes;

          1. Choose Hot Keys from the Options menu.

          2. Select a command from the Menu Commands window.

          3. Select a keyboard key or mouse button such as 'Right Click' from the Keys window. 
You can also use a combination of the CTRL and SHIFT keys.

          4. Click the Assign button to accept the hot key assignment.

          Assign more commands to hot keys or click OK to close the Hot Keys dialog box.

See also
Hot Key Information



Preferences

Summary Setup System Preferences.

To Launch  O P

Purpose The Options Preferences command is used to define various system settings, such as 
cursor shape, default template file, grid display type, selection color, auto-junction, dialog
text font and other options that apply to all document windows.

Outcome The following are preferences that can be set within the preferences dialog box.

          Selections - The default color for selected objects can be changed by clicking in the 
color box and choosing another color from the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

          Grid Color - The visible can be assigned a default color. To assign new color to the 
visible grid, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

          Cursor Type - Three options are available for the physical (or sheet) cursor, a large 90 
degree cross, small 90 degree cross or a 45 degree cross. The sheet cursor is displayed
when making selections, moving or placing objects. The sheet cursor snaps to each grid 
point if the snap grid is turned on, making it easier to control objects being placed or 
moved. The system 'arrow' is able to select objects independently of the snap grid being 
on or off, which makes selection easier when zoomed-out or when dealing with off-grid 
objects. The default cursor type is the small 90 degree cross.

          Visible Grid - The visible grid can be displayed as lines or dots.

          Project Manager Colors - The default colors of the Top, Real and Complex sheets that 
are displayed in the Project Manager panel may be changed at any time by clicking in 
the corresponding color box.    

          Undo Limit - This option allows the user to set the number of Undo/Redo levels. The 
default is 50. This allows the user to backtrack through (and restore) 50 individual 
operations. The legal range is 0-16000. Because each operation must be stored in 
memory to enable Undo/Redo, setting a higher number may result in performance 
deterioration, while 

          editing. If you notice Advanced Schematic slowing down after using the application for a 
while, try selecting a lower number. 

          The more memory you have installed in your machine, the higher the limit you can set 
without hurting the performance of your 

          system. Setting this option to 0 will clear the Undo/Redo memory stack and disable the 
Undo/Redo command. 

          Dialog Text Font - The default font that is used for all dialog boxes can be changed with 
this command. The Schematic Editor must be closed and re-opended in order for this 
new font to change. 



          Save Defaults - When this option is enabled, user settings, preferences and defaults are
saved in an initialization file when exiting Advanced Schematic. Save Defaults is enabled
by default.

          Clipboard Reference - When this option is enabled, you will be prompted to select a 
reference point when copying and cutting selected objects to the clipboard.

          Add Template to Clipboard - When this option is enabled, the current sheet template 
including border, title block, and any additional graphics will be copied to the Windows 
clipboard when the Copy or Cut command is used. This option only affects the Windows 
clipboard where objects are stored in WMF format. The sheet template is not added to 
the Advanced Schematic internal clipboard. 

          Convert Special Strings - When this option is enabled, the special strings that have 
been placed onto the worksheet, for example, ".DATE", are converted to show their true 
representations, in this case the current system date would be displayed. The following 
special strings may be placed on the schematic 
worksheet, .DATE, .TIME, .DOC_FILE_NAME, .organization, .address1, .address2, .add
ress3, .address4, .sheetnumber, .sheettotal, .title, documentnumber and .revision.

          Drag Orthoganal - When this option is enabled, dragging electrical objects will enforce 
wires to remain at 45/90 placement angle modes. Any angle or ruberbanding wire 
placement is used if this option is disabled. The spacebar can be used at anytime while 
moving objects to toggle through the 45/90/any angle placement modes.    

          Use Printer Fonts on Screen - When this option is enabled the fonts that have been 
used on the screen will be substituted for the closest matching fonts that the current 
selected printer supports. For example, if a vector plotter is selected and true type fonts 
are used on the schematic sheet, all the true type fonts on the screen will be displayed 
with the closest matching font that the plotter supports. This option is disabled by default.

          Auto Zoom - When enabled, redraws the workspace with the object centered in the 
window (not active when using Find command or Jump from the Browser). For example, 
when using the Window-Tile command this option re-draws the whole sheet centered in 
the window. 

          OrCAD Ports - When this option is enabled, the length of all the Ports in a schematic 
design/project are re-sized to the OrCAD equivalent and the length of the Port is 
restricted from being manually edited.

          Copy OrCAD Footprint From/To - This option is used to map an OrCAD part field to 
Advanced Schematic Footprint field.    This mapping is bi-directional, ie. used when 
loading and saving OrCAD files.

          Object's Snap-to-Cursor Point - If the Center of Object option is enabled the cursor will
jump to the center of an object when it is moved. If the Object's Electrical Hot Spot is 
enabled the cursor will jump to the nearest electrical hot spot when it is moved.

          Default Template File - Specifies the default template (.DOT) file to be loaded when the 
File-New command is chosen.

          Browse button - Allows user to browse available template (.DOT) files.

Procedure To setup the system preferences:



          1. Choose Preferences from the Options menu.

          2. Choose or type in new system settings.

          3. Click OK to accept the new settings.

See also
Sheet Options
Preference Information



Toggle Component Browser

Summary Turn the Component Browser on or off.

To Launch  O B    -    

Purpose The Toggle Component Browser command is used to turn the Component 
Browser on or off at the left hand side of the Advanced Schematic application window.

Comments The Component Browser allows browsing of component names, placement of 
parts onto the current worksheet, renaming of part designators and jumping to a part that has been 
placed on a worksheet in a project. Refer to the User Guide for detailed descriptions about the 
Component Browser.

Procedure To turn the Component Browser on or off:

          1. Choose Component Browser from the Options menu.



Toggle Main Toolbar

Summary Turn the Main Toolbar on or off.

To Launch  O M

Purpose The Toggle Main Toolbar command is used to turn the Main Toolbar on or off.

Comments A listing of all the Main Toolbar buttons and commands can be found in the Tool Bars 
section, at the back of this reference manual.

Procedure To turn the Main Toolbar on or off:

          1. Choose Main Toolbar from the Options menu.

See also
Toggle Wiring Toolbar
Toggle Drawing Toolbar



Toggle Wiring Toolbar

Summary Turn the Wiring Toolbar on or off.

To Launch  O W    -    

Purpose The Toggle Wiring Toolbar command is used to turn the wiring Toolbar on or off.
Outcome Choosing Wiring Toolbar from the Options menu will turn the Wiring Toolbar on or

off.
Comments A listing of all the Wiring Toolbar buttons and commands can be found in the Tool 

Bars section, towards the back of this reference manual.
Procedure To turn the wiring toolbar on or off:

          1. Choose Wiring Toolbar from the Options menu.

See also
Toggle Main Toolbar
Toggle Drawing Toolbar



Toggle Drawing Toolbar

Summary Turn the Drawing Toolbar on or off.

To Launch  O R    -    

Purpose The Toggle Drawing Toolbar command is used to turn the Drawing Toolbar on or 
off.

Comments A listing of all the Drawing Toolbar buttons and commands can be found in the 
Tool Bars section, towards the back of this reference manual.

Procedure To turn the Drawing Toolbar on or off:
          1. Choose Drawing Toolbar from the Options menu.

See also
Toggle Main Toolbar
Toggle Wiring Toolbar



Toggle Status Bar

Summary Turn the Status Line on or off.

To Launch  O T

Purpose The Toggle Status Bar command is used to turn the Status line on or off at the bottom of 
the Advanced Schematic application window. Turning off the Status line shows more 
screen region.

Outcome Choosing Status line from the Options menu will turn the Status line on or off.    This can 
also turn on/off the Command Status Bar (if it is toggled on in the Options menu).

Comments The status line displays information about the current activity or mode. When a 
command is selected, the left side of the status line briefly describes the chosen 
command. The left side of the status line also indicates the current cursor position.

Procedure To turn the Status line on or off:

          1. Choose Status line from the Options menu.



Toggle Project Manager

Summary Turn the Project Manager on or off.

To Launch  O J    -    

Purpose The Toggle Document Manager command is used to turn the Project Manager on
or off at the left hand side of the Advanced Schematic application window.

Comments The Project Manager lists all the currently loaded schematic files and shows the 
hierarchical file structure of the project. The Project Manager is used to visually navigate through sheets 
in a flat-sheet or hierarchical project. You can view a schematic worksheet by clicking on a sheet within 
the Project Manager. Refer to the User Guide for detailed descriptions about Project Management and the
Project Manager.

Procedure To turn the Project Manager on or off:

          1. Choose Project Manager from the Options menu.



Popup Location Mark Menu

Summary Popup the Place Location Marks menu.

Purpose The Popup Location Mark Menu command is used to directly access the Place Location 
Marks menu at the current cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To pop up the Place Location Marks menu at the current cursor position.

          1. Press the T keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup Edit Menu

Summary Popup the Edit menu.

Purpose The Popup Edit Menu command is used to directly access the Edit menu at the current 
cursor position.

Procedure To popup the Edit menu at the current cursor position.

          1. Press the E keyboard hot key. (Default hot key assignment)

          You can change the default hot key by using the Options Hot Keys command.

See also
Hot Keys



Popup Place Menu

Summary Popup the Place menu.

Purpose The Popup Place Menu command is used to directly access the Place menu at the 
current cursor position.

Procedure To popup the Place menu at the current cursor position.

          1. Press the P keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup Jump Menu

Summary Popup the Edit Jump menu.

Purpose The Popup Jump Menu command is used to directly access the Edit Jump menu at the 
current cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Edit Jump menu at the current cursor position.

          1. Press the J keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup Select Menu

Summary Popup the Edit Select menu.

Purpose The Popup Select Menu command is used to directly access the Edit Select menu at the
current cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Edit Select menu at the current cursor position.

          1. Press the S keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup De-Select Menu

Summary Popup the Edit De-Select menu.

Purpose The Popup De-Select Menu command is used to directly access the Edit De-Select 
menu at the current cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Edit De-Select menu at the current cursor position.

          1. Press the X keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup Zoom Menu

Summary Popup the Zoom menu.

Purpose The Popup Zoom Menu command is used to directly access the Zoom menu at the 
current cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Zoom menu at the current cursor position.

          1. Press the Z keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup Options Menu

Summary Popup the Options menu.

Purpose The Popup Options Menu command is used to directly access the Options menu at the 
current cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Options menu at the current cursor position.

          1. Press the O keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup Help Menu

Summary Popup the Help menu.

Purpose The Popup Help Menu command is used to directly access the Help menu at the current 
cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Help menu at the current cursor position.

          1. Press the H keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup File Menu

Summary Popup the File menu.

Purpose The Popup File Menu command is used to directly access the File menu at the current 
cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the File menu at the current cursor position.

          1. Press the F keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup Library Menu

Summary Popup the Library menu.

Purpose The Popup Library Menu command is used to directly access the Library menu at the 
current cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Library menu at the current cursor position.

          1. Press the L keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup Info Menu

Summary Popup the Info menu.

Purpose The Popup Info Menu command is used to directly access the Info menu at the current 
cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Info menu at the current cursor position.

          1. Press the I keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Popup Window Menu

Summary Popup the Window menu.

Purpose The Popup Window Menu command is used to directly access the Window menu at the 
current cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Window menu at the current cursor position.

          1. Press the W keyboard hot key. (Default hot key assignment.)

See also
Hot Keys



Information System Status

Summary Display system information.

To Launch  I S

Purpose The Infoformation System Status command is used to display system information, such 
as available disk space, free memory, date and time settings.

Comments System Status Information

          Disk Usage

          Total Disk Space - total storage space of your hard disk in MegaBytes.

          Free Disk Space - amount of disk storage space available on your hard disk in 
MegaBytes. 

          Virtual Memory Swap file - size of your virtual memory swap file. Use the Control Panel 
to change the virtual memory settings.

          System Resources

          Free System Resources - resources currently available on your system, displayed in 
percentage.

          Free Memory

          Held by Windows - total free memory Windows is holding (in kilobytes), includes physical
and virtual memory. 

          Held by this application - total free memory Advanced Schematic is holding (in kilobytes),
includes physical and virtual memory. This memory is released back to Windows when 
Advanced Schematic application is closed.    

          Total memory - total free memory (in kilobytes), includes physical memory and virtual 
memory. 

          Physical memory - amount of physical memory (in kilobytes) your system currently has 
free, does not include virtual memory.

          Date/Time

          System Date - the current date of your system. Use the Control Panel to change the 
system date.

          System Time - the current time of your system. Use the Control Panel to change the 
system time.

Procedure To display the current system settings:

          1. Choose System Status from the Info menu.

          A dialog box will open displaying the current system settings.





Help About

Summary Display the version number and copyright of Advanced Schematic.

To Launch  H A

Purpose The Help About command is used to display the application name, version number and 
copyright information. This command can be used to find version number of Advanced 
Schematic before calling technical support.

Outcome When you choose the Help About command a dialog box will open displaying the current
version number and copyright information for Advanced Schematic.

Procedure To display the version number of Advanced Schematic:

          1. Choose About from the Help menu.

See also
Help Index



Help Basic Concepts

Summary Basic information about Advanced Schematic.

To Launch  H B

Purpose The Help Basic Concepts menu option displays an index of basic operational topics of 
Advanced Schematic, such as the design environment, system options etc.

Outcome Once the Help Basic Concepts command is selected the Advanced Schematic on-line 
help system is loaded and displays an index of basic operational topics.

Procedure To display the index of basic operational topics:

          1. Choose Basic Concepts from the Help menu.

          2. Then choose the specific topic from the help index list.

See also
Help Index



Help Commands

Summary Help information organized by menu structure.

To Launch  H C

Purpose The Help Commands menu option displays the Advanced Schematic index of menu 
commands, the topics offer access to detailed information about each command.

Outcome Once the Help Command option is selected the Advanced Schematic on-line help 
system is loaded and displays an index of the menu commands available in Advanced 
Schematic.

Procedure To display the index of menu commands:

          1. Choose Commands from the Help menu.

          2. Then choose the specific topic from the help index list.

See also
Help Index



Using Help

Summary Information about the Windows Help System.

To Launch  H H

Purpose The Using Help command displays the introductory topic about how to access and use 
the on-line help system.

Outcome Once the Using Help command is selected the Advanced Schematic on-line help system
is loaded and displays instructions on how to use help.

Procedure To display the information on how to use the help system:

          1. Choose Using Help from the Help menu.

          2. Then choose the specific topic from the help index list.

See also
Help Index



Help Index

Summary Help system topic index.

To Launch  F1    -      H C    -    

Purpose The Help Index menu option displays the cross-referenced topics available under
the help system.

Outcome Once the Help Index command is selected the Advanced Schematic on-line help 
system is loaded and displays the index of contents.

Procedure To display the Help index:
          1. Choose Index from the Help menu.

          2. Then choose the specific topic from the help index list.



Help OrCAD

Summary Command Cross Reference for OrCAD SDT    users.

To Launch  H O

Purpose The Help OrCAD menu option displays the command cross-reference for OrCAD STD    
users.

Outcome Once the Help OrCAD command is selected the Advanced Schematic on-line help 
system is loaded and displays a cross-reference of command topics. Refer to the User 
Guide and reference supplement for information about OrCAD compatibility.

Procedure To display the OrCAD command cross-reference:

          1. Choose OrCAD from the Help menu.

          2. Then choose the specific topic from the help index list.

See also
Again
Block
Conditions
Delete
Edit
Find
Get
Hardcopy
Inquire
Jump
Library
Macro
Place
Quit
Repeat
Set
Tag
Zoom



Help Printing

Summary Information about generating hard copy output.

To Launch  H P

Outcome Once the Help Printing command is selected the Advanced Schematic on-line help 
system is loaded and displays an index of printing output topics.

Procedure To display the index of printing topics:

          1. Choose Printing from the Help menu.

          2. Then choose the specific topic from the help index list.

See also
File Print
Generating print or plot
Help Index



Help Reference

Summary Advanced Schematic Reference.

To Launch  H R

Purpose The Help Reference menu option displays an index of additional topics covering some of
the automation features of Advanced Schematic.

Outcome Once the Help Reference command is selected the Advanced Schematic on-line help 
system is loaded and displays an index of reference topics.

Procedure To display the index of Reference topics:

          1. Choose Reference from the Help menu.

          2. Then choose the specific topic from the help index list.

See also
Help Index



Window Tile

Summary Tile all open schematic windows.

To Launch  Shift F4    -    Alt W T

Purpose The Window Tile command is used to arrange all open schematic document windows so 
that they are all visible and do not overlap.

Outcome Once the Tile command has been chosen all the open and non-minimized schematic 
document windows will be re-sized and arranged so that they are all visible and do not 
overlap.

Procedure To tile all the non-minimized schematic document windows:

          1. Choose Tile from the Window menu.

See also
Window Cascade



Window Cascade

Summary Cascade all open schematic windows.

To Launch  Shift F5    -    Alt W C

Purpose The Window Cascade command is used to arrange all open, non-minimized schematic 
document windows so that they all overlap and each document title bar is visible.

Outcome Once the Cascade command has been chosen all the open and non-minimized 
schematic document windows will be re-sized and arranged so that they all overlap and 
each document title bar is visible.

Procedure To Cascade all the non-minimized schematic document windows:

          1. Choose Cascade from the Window menu.

See also
Window Tile



Window Arrange Icons

Summary Arrange all minimized open schematic windows.

To Launch Alt W I

Purpose The Window Arrange Icons command is used to arrange the icons of all minimized 
schematic documents across the bottom of the Advanced Schematic application window.

Procedure To Arrange all the minimized schematic document icons:

          1. Choose Arrange Icons from the Window menu.



Window Close All

Summary Close all open schematic windows.

To Launch Alt W L

Purpose The Window Close All command is used to close all document windows and icons.

Outcome Once the Close All command has been chosen all the opened document windows and 
icons will be closed. If any document window has been modified since the last save a 
dialog box will be displayed and prompt you to save the file(s).

Procedure To close all the opened document windows and icons:

          1. Choose Close All from the Window menu.

          2. If any document window has been modified since last saving, a dialog box will be 
displayed that prompts to save the file(s). Choose Yes to save the file(s), No to close the 
file(s) without    saving or choose Cancel to ignore the Close All command.

See also
File Close



Run Library Editor

Summary Switch to the Schematic Library Editor.

To Launch  L E    -    

Purpose The Run Library Editor command is used to switch to the Schematic Library 
Editor. The Schematic Library Editor allows creation, management, browsing and placement of 
components.

Outcome Launches the specified Library Editor.
Comments User can specify the Library Editor application under the Tools-Setup command. 

If the Library Editor has been previously loaded then the focus will switch to the Library Editor application 
window, otherwise the Library Editor will be launched, automatically loading previously opened Library 
files.

Procedure Choose the Library command from the Tools menu.

See also
Edit Component



Add/Remove Library

Summary Add and remove libraries from the library list.

To Launch  L A    -    

Purpose The Add/Remove Libraries command is used to add or remove libraries from the 
library list.

Outcome Once the library file has been selected it will appear in the Current File List 
window. All the added libraries will appear in the library list box in the Component Browser Panel.

Comments The library components are not loaded into memory, only their names. Therefore,
an unlimited number of libraries may be added to this list.

Procedure To add or remove libraries from the library list:

          1. Choose Add/Remove from the Library menu, or click the Add/Remove button in the 
Component Browser panel.

          2. Type the library name or wild card mask (e.g. *.LIB) in the file name box.

          3. Click OK to list the file(s) in the Files window of this dialog box.

          4. Select a file and then click the Add button to add the library to the list.

          You can also double-click on the desired filename in the Files window. To change 
directories, click under any of the options listed in the Directories window.

See also
Adding libraries to the current list



Increment Part Number

Summary Toggle part number on multi-part component.

To Launch Alt E I    -    

Purpose The Increment Part Number command is used to visually toggle through the 
available part numbers for a specific multi-part component.

Outcome As you click on the part its next part number is displayed.
Procedure To toggle through the part numbers:
          1. Choose Increment Part Number from the Edit menu.

          2. Position the cursor over a part on the worksheet and click ENTER or LEFT MOUSE.



Place Part from Browser

Summary Place a part from the Component Browser.

Purpose The Place Part from Browser command is used to place the currently    highlighted part in
Component Browser. The command is represented by    the Place button on the Browser.

Comments You can also place parts from the Library Editor or by using the Place Part command.

Procedure To Place a part from the Component Browser:

          Make sure that the part you wish to place is highlighted in the    Components In Library 
window on the Component Browser. 

          1. Press the Place button on the Component Browser. The part will    then be displayed in
the workspace. 

          While moving the part, you can rotate it 90 degrees around the cursor by pressing the 
SPACEBAR and flip it along its x or y axis by pressing the X and Y keys. Press TAB to 
manually change the default values of the Part by typing new values directly into a dialog
box.

          2. Position the cursor where the part is to be placed and press ENTER or LEFT MOUSE    
once.

See also
Place Parts



Edit Component

Summary Switch to the Schematic Library Editor and edit component.

Purpose The Edit Component command is used to switch to the Library Editor    and edit the 
component currently displayed in the schematic editor Component    Browser. The 
command is represented by the EDIT button on the    Browser.

Outcome The focus will switch to the Library Editor application and the component will    then be 
displayed in the workspace.

Comments To reflect changes made to the component, save the library and then select Update 
Schematic from the library editor File menu.

          Note: All the sheets currently opened will be affected by this.

Procedure To edit a component from the Component Browser:

          Make sure that the Advanced Schematic Library Editor is already running and the part 
you wish to edit is highlighted in the    Components In Library window on the Component 
Browser. 

          1. Press the Edit button on the Component Browser.

See also
Run Library Editor



Rename Object Text

Summary Changes the text field associated with an object from the Browser.

Purpose Changes the designator of the current part (or text associated with other objects) in the 
Browser. The command    is represented by the TEXT button on the Browser.

Outcome The new object text field will be listed within the Browser.

Procedure To change an object's text, first make sure that the object you wish to rename is 
highlighted in the Browser. 

          1. Press the Text button on the Browser.

          2. Type the new text into the dialog box and press ENTER or click OK.



Jump to Object

Summary Jump to an object within a single sheet or project.

Purpose The Jump button in the Browser allows you to conveniently locate a specific object that 
has been placed within a schematic project, without having to zoom, pan or scroll 
through multiple screens or windows.

Outcome The object will be positioned in the center of the schematic document window and be 
placed in focus. The current window focus will change if the part is not on the current 
active document window.

Procedure To Jump to an object:

          Make sure that the object type you wish to jump to is selected in the Browser and that 
the object name is highlighted in the Browser list box. 

          1. Press the Jump button on the Browser.

See also



File Print

Summary Print the current document with the last set printer options.

To Launch Alt F P

Purpose The File Print command is used to print or plot the active document window, using the 
current printer/plotter settings defined in the Printer Setup dialog box.

Outcome The schematic drawing will be sent to the printer or plotter. A small dialog box is 
displayed showing the output device and page count. The status line shows the 
percentage complete.

Comments If you have selected a file as the output port, then you will be asked for an output file 
name.

Procedure To print the current document window:

          1. Choose Print from the File menu.

See also
Setup Printer



Setup Printer

Summary Printer and page setup.

To Launch Alt F I    -    

Purpose The Setup Printer command is used to change printers and to control printing 
options on the selected printer. This command is also used to setup the scale, color mode and margins of 
your schematic sheet.

Outcome The following are options that can be set within the Printer Setup dialog box.
          Select Printer - The available output device options will include those that have been 

installed using the Windows Control Panel, (see your Microsoft Windows User's Guide for details).
          Batch Type - Allows you to choose between Single Document or All Documents. Single 

Document, prints the current document window, All Documents, prints all the schematic 
sheets in the current project.

          Color Mode - Allows you to choose between Color or Monochrome modes. Color mode 
allows you to print the schematic sheet(s) in color, if you are using a color-capable output
device supported by a Windows 3 driver. Monochrome will print the schematic in a single
color, regardless of the color capabilities of the output device.

          Margins - Allows you to define the Top, Bottom, Left and Right margins.

          Scale - Allows you to enlarge or reduce the size of your schematic sheet by specifying a 
scale factor. If you wish to enlarge the sheet by 200% set the Scale to 2.000. The default
value is 1.000.

          Scale to Fit Page - The schematic sheet will be expanded/contracted to fit    within the 
defined margins for the current printer page size.

Comments Advanced Schematic printing and pen-plotting are handled similarly to other Windows 3 
applications. Windows manages the printing (or plotting) process and provides a range 
of raster and Postscript printer drivers and vector plotter drivers. These range from 9 pin 
dot matrix printers and multi-pen plotters, to high-resolution linotronic imagesetters.

Procedure To setup your printer or plotter configuration:

          1. Choose Setup Printer from the File menu.

          2. Setup the output options in the Printer Setup dialog box.

          3. Press the OK button to accept the printer settings and return to the editor without 
printing the document or;

          4. Press the Print button to execute the File Print command. 

          The Preview button is used to update the right portion of the dialog box, showing the 
orientation, positioning, margins and number of pages, before sending the file to the 
printer.

See also
File Print



Generating a print or plot



File Close

Summary Close the current window.

To Launch Alt F C

Purpose The File Close command is used to close the current schematic document window.

Procedure To close the current document window:

          1. Choose Close from the File menu.

          2. If the schematic document window has been modified since last saving, a dialog box 
will be displayed that prompts to save the file. Choose Yes to save the file, No to close 
without saving or choose Cancel to ignore the Close command.

See also
Window Close All



File Save

Summary Save current schematic worksheet with same file name.

To Launch Alt F S    -    

Purpose The File Save command is used to save the current schematic document 
window.

Outcome When you select the File Save command, the contents of the current schematic   
document window will be saved to the Advanced Schematic binary file format using the existing paths and
filenames.

Comments If the schematic worksheet has been created with the File New command and 
has not been previously saved, the Save File As dialog box will open. You can save the file to a new path,
new name or format. A backup file of the original file with an extension ".bak" is made before the new file 
is saved.

Procedure To save the current schematic worksheet:

          1. Choose Save from the File menu.

See also
File Save All
File Save As
File Save Project



File Save As

Summary Save current schematic worksheet with new file name.

To Launch Alt F A

Purpose The File Save As command can be used to save the active file to a new path, new name 
or format.

Outcome When you select the File Save As command, the Save Schematic File As dialog box will 
open. Once you click OK the file will be saved to the new file name and/or directory that 
you specified.

Comments There are three file format options:

          Protel Binary This is the default setting - an efficient format that enables Advanced 
Schematic to open or save files more quickly than the OrCAD or text version.

          Protel Text Protel's published (ASCII) text format for schematic files. The format of this 
file is described in the on-line help. ASCII files are less efficient than the binary version, 
but allow the user direct access to the design database for translation into other formats 
or other manipulation. If you open a Protel Text format file in Advanced Schematic, it will 
be automatically saved in the default binary format when you choose File Save.

          OrCAD This format allows you to export an Advanced Schematic file into OrCAD STD IV
format. When you load an OrCAD file into Advanced Schematic, it will be automatically 
saved in the default binary file format when you choose File Save. If you save your files 
in OrCAD format you should be aware of the limitations that OrCAD database imposes 
on Advanced Schematic data objects, in particular, most of the drawing tools including, 
elliptical arcs, ellipses, pie charts, rounded rectangles, beziers and graphic images will 
not be included in the OrCAD format files. Advanced Schematic also includes special 
attributes not supported by OrCAD, such as color for individual objects, True Type fonts, 
Port length etc.

          Refer to the User Guide and on-line help for complete descriptions on Orcad 
compatability.

Procedure To save the current schematic document window to a new path, file name or format.

          1. Choose Save As from the File menu.

          2. Type a new file name for the schematic worksheet. To change the output format of the 
file, choose one of the options listed in the File Format window. 

          3. Click OK to save the file.

          To change directories, click under any of the options listed in the Directories window.

See also
File Save All
File Save
File Save Project



Up Hierarchy

Summary Switch to the parent sheet of the current sheet.

To Launch Alt F H U    -    

Purpose The Up Hierarchy command is used to move the focus to the next level up the 
design hierarchy from the current, active window.

Outcome Once the Up Hierarchy command is selected you are prompted to choose one of 
the sheet symbols, once a sheet symbol has been selected the focus moves to the next level up the 
design hierarchy from the current, active window.

Comments To move up hierarchy the top level sheet needs to be already open.

Procedure To move up the hierarchy structure:

          1. Choose Up Hierarchy from the File-Hierarchy menu.

          2. Position the cursor over a Sheet Symbol and click LEFT MOUSE or ENTER.

See also
Down Hierarchy
Sheet Symbol



Down Hierarchy

Summary Switch to a child sheet of the current sheet.

To Launch Alt F H W    -    

Purpose The Down Hierarchy command is used to move the focus to the next level down 
the design hierarchy from the current, active window.

Outcome Once the Down Hierarchy command is selected you are prompted to choose one
of the sheet symbols, once a sheet symbol has been selected the focus moves to the next level down the 
design hierarchy from the current, active window. If the child sheet is not already opened Advanced 
Schematic will automatically open the sheet.

Procedure To move down the hierarchy structure:

          1. Choose Down Hierarchy from the File-Hierarchy menu.

          2. Position the cursor over a Sheet Symbol and click LEFT MOUSE or ENTER.

See also
Up Hierarchy
Sheet Symbol



Annotate

Summary Re-Designate all Parts in schematic project.

To Launch Alt F T

Purpose The Annotate command is used to rename all the Parts on a schematic worksheet or 
Project so they are unique and in consecutive order.

Outcome Once the Annotate command is selected all Parts in your schematic design will be re-
designated.

Comments Refer to the on-line help system and the reference supplement for further information 
about the Annotate command. Annotate will re-designate all the parts in the opened 
sheets in the current project.

Procedure To Annotate all Parts in a schematic design:

          1. Choose Annotate from the File menu.

See also
Back Annotate



Back Annotate

Summary Back Annotate Part and Pin information from a PCB Was/Is File.

Purpose The Back Annotate command is used to update the schematic component designators 
and pin information from a PCB Was/Is file.

Comments Refer to the on-line help system and the reference supplement for further information 
about the Back Annotation command. Applies to the entire project, all the sheets used in 
the project need to be opened, at the time of back annotation.

Procedure To Back Annotate from a PCB Was/Is file:

          1. Choose Back Annotate from the File menu.

          2. Type the name of the PCB Was/Is file.

          3. Click OK to change the schematic design.

See also
Annotate



Bill of Materials

Summary Generate a Bill of Materials.

To Launch Alt F R B

Purpose The Report Bill of Materials command is used to generate an ASCII parts list file of the 
Parts (including quantities) used in a schematic design.

Outcome Two BOM formats are generated: The CSV (comma separated value) format includes all 
sheet-level and library part text fields for each instance of a part. The condensed Protel 
(ASCII) format that displays the designator, type and count for each part.

Comments The CSV file format can be loaded directly into a spreadsheet or database application.

Procedure To generate a Bill of Materials file:

          1. Choose Reports Bill of Material from the File menu.

See also
Report Project Hierarchy
Report Cross Reference



Report Project Hierarchy

Summary Generate a text listing to represent the design hierarchy.

To Launch Alt F R P

Purpose The Report Hierarchy Tree command is used to generate an ASCII file of the hierarchy 
tree structure used in a schematic design.

Outcome Once the Hierarchy tree command is selected a dialog box will open prompting to select 
the type of format for the output file, once the format has been chosen, a second dialog 
box will open asking for an output file name. Type a file name and click OK to save the 
hierarchy tree file.

Comments The CSV file format should be used when exporting the hierarchy tree file into a 
spreadsheet or database application.

          Refer to the on-line help system and the reference supplement for further information 
about the Report Project Hierarchy command.

Procedure To generate a hierarchy tree file:

          1. Choose Project Hierarchy from the File menu.

          2. Select the type of format for the hierarchy tree file (CSV or Protel) then click OK.

          3. Type a file name for the Hierarchy Tree file.

          4. Click OK to generate the file.

See also
Bill of Materials
Report Cross Reference



Report Cross Reference

Summary Generate a part/sheet cross reference for the current project or sheet.

To Launch Alt F R C

Purpose The Report Cross Reference command is used to generate an ASCII file of the 
part/sheet cross reference used in a schematic design.

Outcome Once the Cross Reference command is selected a dialog box will open prompting to 
select the type of format for the output file, once the format has been chosen a second 
dialog box will open asking for an output file name. Type a file name and click OK to save
the Cross Reference file.

Comments The CSV file format should be used when exporting the Cross Reference file into a 
spreadsheet or database application.

          Refer to the on-line help system and the reference supplement for further information 
about the Report Cross Reference command.

Procedure To generate a Cross reference file:

          1. Choose Cross reference from the File menu.

          2. Select the type of format for the Cross Reference file (CSV or Protel) then click OK.

          3. Type a file name for the Cross Reference file.

          4. Click OK to generate the file.

See also
Bill of Materials
Report Project Hierarchy



Undo

Summary Undo previous command.

To Launch  Alt BackSpace    -    Alt E U    -    

Purpose The Undo command is used to restore a document to its state previous to the 
last operation. Multiple levels of undo are supported.

Outcome Reverses the effect of the previous edit(s), step-by-step, back to the number of 
operations specified under the Undo Limit option (Options-Preferences command).

Comments Advanced Schematic stores operations as a stack in memory. Depending on the 
amount of memory available, you will eventually experience a noticeable decline in performance as the 
Undo/redo stack fills with large scale changes, such as global edits. User sets the limit of Undo/Redo 
steps under Options-Preferences. If set to 0, then the stack is cleared, releasing additional memory. Does
not support Annotate or BackAnnotate commands.

          Note: When using Undo/Redo after complex cross-project global edits, only the current 
sheet (in focus) will be affected.

Procedure To undo the last operation:

          1. Choose Undo from the Edit menu.

See also
Redo



Redo

Summary Redo previous undo command.

To Launch  Ctrl BackSpace    -    Alt E R    -    

Purpose The Redo command is used to restore changes made by the last Undo 
command. Multiple levels of Redo are supported.

Comments Advanced Schematic stores operations as a stack in memory. Depending on the 
amount of memory available, you will eventually experience a noticeable decline in performance as the 
Undo/redo stack fills with large scale changes, such as global edits. User sets the limit of Undo/Redo 
steps under Options-Preferences. If set to 0, then the stack is cleared, releasing additional memory. Does
not support Annotate or BackAnnotate commands.

          Note: When using Undo/Redo after complex cross-project global edits, only the current 
sheet (in focus) will be affected.

Procedure To redo the last operation:

          1. Choose Redo from the Edit menu.

See also
Undo



Electrical Rules Check

Summary Perform an Electrical Rules Check on the current project or sheet.

To Launch Alt F R E

Purpose The Electrical Rules Check command is used to automatically check the logical integrity 
of your schematic design. This feature should be used prior to generating a netlist.

Outcome Depending upon the options specified, running ERC can produce two results.    First, a 
text report listing of electrical and logical violations and warnings for the current active 
sheet, hierarchical or multi-sheet flat project. Secondly, error markers are placed in 
sheets at the site of specific ERC violations as an aid in tracking and correcting reported 
problems.

          The following are options that can be set within the Electrical Rules Check dialog box.

          Multiple Net Names On Net

          Reports physical nets with net identifiers with different names.

          Unconnected Net Labels

          Reports net labels that are not physically connected to at least one other electrical item 
in the sheet.

          Unconnected Power Objects

          Reports power objects that are not physically connected to at least one other electrical 
item.

          Duplicate Sheet Numbers

          Reports sheets that have been assigned the same sheet number(Options-Sheet dialog, 
Document Info option).

          Duplicate Component Designators

          Reports parts that have identical designator labels. This condition can occur when the 
Annotate command has not been used or when the File-Hierarchy-Complex to Simple 
command has not been used to "flatten" a complex hierarchical project (project with 
duplicate sheets).

          Bus Label Format Errors

          Reports net labels attached to buses which are not legally formatted to reflect a range of 
signals. Logical connectivity for buses can be assigned by placing a net label on the bus.
Generally, this net label will include all bus signals, e.g. HA[0..19] represents nets named
HA0, HA1, HA2, etc. to HA19.

          Floating Input Pins

          Reports unconnected part pins whose function is identified as "Input."



          Suppress Warnings

          This option generates a report and error markers for error conditions only. Warning 
conditions (see Pin / Sheet Entry / Port Rule Matrix, below) are ignored. This allows the 
designer for perform quick ERCs for all error-level problems.

          Create Report File

          This option generates a text report listing all ERC report information. 

          Add Error Markers

          This option generates special error markers in sheets, at the site of each reported 
warning or error. Special facilities in the sheet editor allow the user to jump from error 
marker to error marker.

          Descend Into Sheet Parts

          This options treats sheet parts as hierarchical sheet symbols. A sheet part is a part 
whose unconnected pins are associated with ports on sheet which descends 
hierarchically from the sheet part. The "descending" sheet is defined in the part's Sheet 
Part path field.

          Current Sheet Only

          This option is used to restrict the check to be done on the current sheet or the entire 
project.

          Net Identifier Scope

          This option is used to define the use of net identifiers (net labels, ports and sheet entries)
in the project.

          Net Labels and Ports Global

          With this option, net labels are assumed to apply to all sheets in a project. In other 
words, nets are global and each instance of a net name or port is deemed to be 
connected to all other identically named identifiers.

          Only Ports Global

          This option treats net labels as local only. All identically named nets on a sheet are 
deemed to be connected. Intersheet connections occur only through identically labeled 
ports. This model works like the OrCAD SDT "flat" project model.

          Sheet Symbol / Port Connections

          This option makes intersheet net connections only through sheet symbol entries and 
subsheet ports. Ports are deemed to be connected only to identically named nets 
entering through their sheet symbols on parent sheets. This model works like the OrCAD
SDT "hierarchical" project model.

          Pin / Sheet Entry / Port Rule Matrix

          An error or warning can be specified using a matrix of pin, port or sheet entry connection



or non-connection conditions. For example, connected input pins would not normally be 
regarded as an error condition but connected output pins would be regarded as an error. 
The default values for each of these conditions reflects this. The user can specify either 
errors or warnings for connections of pin types, ports or sheet entries. Items which are 
set as warnings give the user the option to supress warnings when performing 
preliminary checks, which will keep these initial ERC reports short and manageable. 
Warnings can then be comprehensively checked by the designer, later in the design 
validation process.

          To change the default settings in the matrix, the user need only click LEFT MOUSE in 
any matrix square. With each click the square will toggle from No Report (green), 
Warning (yellow) and Error (red), then back to No Report, etc.

Comments No ERC symbols can be placed on pins and other electrical objects, such as un-
connected net labels to suppress the ERC checking.

Procedure To perform an Electrical Rules Check on the current design or sheet:

          1. Choose Reports and then Electrical Rules Check from the File menu.

          2. Specify the ERC options for the project:

          3. Click OK to generate the report file anderror markers.

See also
Error Marker
ERC Information



Select Connection

Summary Find physical connection between pins.

To Launch Alt E S C

Purpose The Select Connection command is used to select the free primitives (wires, junctions, 
net labels) that connect any two Part pins. This command is useful for identifying two 
Part pins that are physically connected and, therefore, will be processed when 
generating a netlist.

Outcome Once a wire, junction or some other electrical object has been chosen, the connection 
will be selected in the color that is defined for selections in the Options Preferences 
dialog box.

Comments The selected primitives that make up the connection can be cleared, copied or cut to the 
clipboard and then pasted into the current document window or to another schematic 
worksheet.

Procedure To physically select a connection:

          1. Choose Select connection from the Edit menu.

          2. Then click on a wire, junction or Part pin to select the connection.

See also
Select Net
Information Selected Pins



Select Net

Summary Find physical connection from a point.

To Launch Alt E S N

Purpose The Select Net command is used to select the free primitives (wires, junctions, net labels
etc.) that connect a physical net. This command is useful to identify all the pins physically
connected by wires or by net labels. To see a listing of all the selected pins use the Info 
Selected Pins command.

Outcome Once a wire, junction or some other electrical object has been chosen, the net will be 
selected in the color that is defined for selections in the Options Preferences dialog box.

Comments The selected primitives that make up the net can be cleared, copied or cut to the 
clipboard and then pasted into the current document window or to another schematic 
worksheet.

Procedure To physically select a Net:

          1. Choose Select Net from the Edit menu.

          2. Then click on a wire, junction or Part pin to select the Net.

See also
Select Connection
Information Selected Pins



Create Netlist

Summary Generate a netlist from the current project or sheet.

To Launch Alt F E

Purpose The Create Netlist command is used to generate an ASCII text netlist file in the Protel 
format, a large number of other netlist output formats are supported. The typical netlist 
format includes descriptions of Parts, such as the designator and package type 
combined with the pin-to-pin connections that define each net. Loading a netlist into a 
printed circuit board layout package automates many of the tedious and error prone 
operations inherent in the design process.

Outcome All netlist formats supported by Advanced Schematic are generated as ASCII text files 
that carry two types of information.

          1. Descriptions of the Parts in the circuit.

          2. A list of all pin-to-pin connections in the circuit.

          Some netlist formats combine both sets of data in a single description, others, including 
the Protel format, separate the data into two sections.

           Netlist formats 

          Algorex, AppliconBRAVO, AppliconLEAP, Cadnetix, Calay, Calay90, Case, CBDS, 
ComputerVision, EDIF 2.0, EDIF 2.0 Hierarchical, EEDesigner, EEsof Libra, EEsof 
Touchstone, FutureNet, Hilo, Integraph, Mentor BoardStation 6, Multiwire, Orcad - 
PLDnet, Orcad - PCB II, PADS Ascii, PCAD, PCAD NLT, Protel - Advanced PLD, Protel, 
Protel 2, Protel - Hierarchical, Protel Wirelist, Racal Redac, Scicards, Spice, Spice 
Hierarchical, Star Semiconductor, Tango, Telesis and Vectron.

Comments If you intend to manually edit a netlist, make sure that you save the results in an 
"unformatted" or "text only" form, as hidden formatting or control characters can render a
netlist unreadable by Protel for Windows.

          The "Action after netlist generation" option is used to launch a specified application (eg. 
a Digital Simulation package) after generating a netlist.

Procedure To generate a netlist file:

          1. Choose Create Netlist from the File menu.

          2. Select the netlist output format, the net identifier scope.

          3. Click OK to generate and save the netlist file.

See also
Generating Netlists
Electrical Rules Check



Cut

Summary Copy selected objects to clipboard and remove from sheet.

To Launch  Shift Delete    -    Alt E T    -    

Purpose The Edit Cut command is used to clear the current selected objects from the 
worksheet and copies it to the clipboard. The Edit Paste command can be used to place the selection 
back into any open Advanced Schematic document window or to another application that supports the 
Windows .WMF clipboard format.

Outcome Removes the selected item(s) from the workspace and keeps a copy of the selection in 
the clipboard. The clipboard holds the last selection only, each time you use the Cut or 
Copy command, you overwrite the previous selection, stored in the clipboard.

Comments The Clipboard can be used to paste the selection to other Windows applications that 
support .WMF (Windows MetaFile) format. The Add Template to Clipboard option 
(Options-Preferences command) includes the sheet template (border and title block, 
etc.) along with the selection copied to the clipboard.

Procedure To cut the current selection from the active window:

          1. Make sure that the current selection includes only those objects you wish to cut;

          You can use Edit De-Select to de-select objects that are not to be removed and then use
Edit Select to select the objects that will be removed. You can also use the shortcut 
SHIFT+LEFT MOUSE to add objects to the current selection or to de-select any selected 
objects.

          2. Choose Cut from the Edit menu. (shortcut: SHIFT+DELETE);

          You will be prompted to select a reference point if the Clipboard Reference option is 
enabled in the Preferences dialog box. A reference point is a coordinate relative to the 
selected object(s). If the clipboard reference option is off then the current cursor position 
is used as the reference point. When you paste the selection, the reference point will 
locate the cursor at this same relative position, allowing you to accurately position the 
selection.

See also
Paste
Copy



Copy

Summary Copy all selected objects to the clipboard.

To Launch  Ctrl Insert    -    Alt E C

Purpose The Edit Copy command is used to copy the objects that are currently selected in the 
worksheet to the clipboard. The Edit Paste command can be used to place a copy of the 
selection back into any open Advanced Schematic document window or into any 
application which supports the .WMF (Windows MetaFile) clipboard format.

Outcome Makes a copy of the selection in the clipboard. The clipboard holds the last selection 
only, each time you use the Copy or Cut command, you overwrite the previous selection.

Comments The Clipboard can be used to paste the selection to other Windows applications that 
support .WMF (Windows MetaFile) format. The Add Template to Clipboard option 
(Options-Preferences command) includes the sheet template (border and title block, 
etc.) along with the selection copied to the clipboard.

Procedure To copy the current selection from the active window:

          1. Make sure that the current selection includes only those objects you wish to copy;

          You can use Edit De-Select to de-select objects that are not to be copied and then use 
Edit Select to select the objects that will be copied. You can also use the shortcut 
SHIFT+LEFT MOUSE to add objects to the current selection or to de-select any selected 
objects.

          2. Choose Copy from the Edit menu. (shortcut: CTRL+INSERT);

          You will be prompted to select a reference point if th Clipboard Reference option is 
enabled in the Preferences dialog box. A reference point is a coordinate relative to the 
selected object(s). If the clipboard reference option is off (Options-Preferences) then the 
current cursor position is used as the reference point. When you paste the selection, the 
reference point will locate the cursor at this same relative position, allowing you to 
accurately position the selection.

See also
Paste
Cut



Paste

Summary Place clipboard contents onto current worksheet.

To Launch  Shift Insert    -    Alt E P    -    

Purpose The Paste command is used to place the current clipboard contents into any 
open Advanced Schematic document window. Advanced Schematic has its own clipboard format. The 
standard Windows clipboard is not used when Pasting.

Comments You can repeat the Paste command to duplicate the selection.
Procedure To Paste selected objects from the clipboard to an open document:

          1. Choose Paste from the Edit menu. (shortcut: SHIFT+INSERT);

          You will be prompted to select a location and a highlighted outline of the selected objects
will be displayed. The cursor position relative to the selection is determined by the 
reference point designated when Cut or Copy was used to add the selection to the 
clipboard.

          2. Position the selection in the worksheet and click LEFT MOUSE or press ENTER.

See also
Cut
Copy



Clear

Summary Delete all selected objects from the current worksheet.

To Launch  Ctrl Delete    -    Alt E L

Purpose The Clear command is used to remove selected objects from the worksheet without 
copying the selection to the clipboard.

Outcome The selection will be cleared from the display.

Comments You can use the Edit Undo command (shortcut: S8 ALT+BACKSPACE) to restore the 
cleared selection.

Procedure To clear the current selection from the active window:

          1. Make sure that the current selection includes only those objects you wish to clear.

          You can use Edit De-Select to de-select objects that are not to be deleted and then use 
Edit Select to select the objects that will be deleted. You can also use the shortcut 
SHIFT+LEFT MOUSE to add objects to the current selection or to de-select any selected 
objects.

          2. Choose Clear from the Edit menu. (shortcut: CTRL+DELETE).

See also
Undo
Cut
Delete
Delete Single Object



Move Selection

Summary Move selected objects to another area of the worksheet.

To Launch Alt E M S    -    

Purpose The Move Selection command is used to reposition an individual selected object 
or a complex selection containing many objects as a single entity.

Comments While moving a selection, you can rotate it around the cursor and flip it along its x
or y axis using the following hot key shortcuts.

          SPACEBAR
          Each key press rotates the selection 90 degrees counter-clockwise.

           X

          Flips the selection along its X axis.

           y

          Flips the selection along its Y axis.

Procedure To move selected objects in an open worksheet:

          1. Make sure that the current selection includes only those objects you wish to move.

          You can use Edit De-Select to de-select objects that are not to be moved and then use 
Edit Select to select the objects that will be moved. You can also use the shortcut 
SHIFT+LEFT MOUSE to add objects to the current selection or to de-select any selected 
objects.

          2. Choose Move and then Move Selection from the Edit menu.

          You will be prompted to select a reference point if the Clipboard Reference option is 
enabled in the Preferences dialog box. A reference point is a coordinate relative to the 
selected object(s). If the clipboard reference option is off then the current cursor position 
is used as the reference point. When you move the selection, the reference point will 
locate the cursor at this same relative position, allowing you to accurately position the 
selection.

          3. Position the selection in the worksheet and click ENTER or LEFT MOUSE.

See also
Move
Drag
Drag Selection



Select Inside Area

Summary Select all objects inside an area.

To Launch Alt E S I    -    

Purpose The Select Inside Area command is used to select all objects that lie completely 
within a user-defined rectangle in an open document window.

Outcome The newly selected objects will be highlighted using the selection color defined in
the Options Preferences dialog box. Any previously selected objects will remain selected.

Procedure To select objects within an area:

          1. Choose Select and then Inside Area from the Edit menu.

          You will be prompted to "Select First Corner."

          2. Move the cursor and then press ENTER or LEFT MOUSE to define the first corner of the 
selection rectangle.

          The prompt changes to "Select Second Corner."

          3. Move the cursor to enclose the area to be selected in the highlighted rectangle.

          4. Press ENTER or LEFT MOUSE to complete the selection.

See also
Select Outside Area
Select All



Select Outside Area

Summary Select all objects outside an area.

To Launch Alt E S O

Purpose The Select Outside Area command is used to select all objects that lie completely 
outside a user-defined rectangle in an open document window.

Outcome The newly selected objects will be highlighted using the selection color defined in the 
Options Preferences dialog box. Any previously selected objects will remain selected.

Procedure To select objects outside an area:

          1. Choose Select and then Outside Area from the Edit menu.

          You will be prompted "Select First Corner."

          2. Move the cursor and then press ENTER or LEFT MOUSE to define the first corner of the 
selection rectangle.

          You will then be prompted to "Select Second Corner."

          3. Move the cursor to enclose the area to remain de-selected with the highlighted 
rectangle.

          4. Press ENTER or LEFT MOUSE to complete the selection.

See also
Select Inside Area
Select All



Select All

Summary Select everything on the current worksheet.

To Launch Alt E S A

Purpose The Select All command is used to select all of the objects on the current worksheet.

Outcome The selected objects will be highlighted using the selection color defined in the Options 
Preferences dialog box.

Comments Select all will not select borders or title blocks but will include text frames or annotations 
within title blocks.

Procedure To select all objects from an open document:

          1. Choose Select and then All from the Edit menu.

See also
Select Inside Area
Select Outside Area



De-Select Inside Area

Summary De-Select all objects inside an area.

To Launch Alt E E I

Purpose The De-Select All command is used to de-select all of the objects on the current 
worksheet.

Procedure To de-select all objects from an open document:

          1. Choose De-Select and then All from the Edit menu.

See also
De-Select Outside Area
De-Select All



De-Select Outside Area

Summary De-Select all objects outside an area.

To Launch Alt E E O

Purpose The De-Select Outside Area command is used to de-select all objects that lie completely 
outside a user-defined rectangle in an open document window.

Procedure To de-select objects outside an area:

          1. Choose De-Select and then Outside Area from the Edit menu.

          You will be prompted "Select First Corner."

          2. Move the cursor and then press ENTER or LEFT MOUSE to define the first corner of the 
selection rectangle.

          You will then be prompted "Select Second Corner."

          3. Move the cursor to enclose the area to remain selected with the highlighted rectangle.

          4. Press ENTER or LEFT MOUSE to complete the selection.

See also
De-Select Inside Area
De-Select All



De-Select All

Summary De-Select all selected objects.

To Launch Alt E E A    -    

Purpose The De-Select All command is used to de-select all of the objects that are 
currently selected in the schematic document window.

Procedure To de-select all objects from an open document:
          1. Choose De-Select and then All from the Edit menu.

See also
De-Select Inside Area
De-Select Outside Area



Toggle Selection

Summary Toggle selection-state of objects.

To Launch Alt E N

Purpose The Toggle Selection command is used to select and de-select objects on a schematic 
worksheet by moving the cursor over the object and clicking LEFT MOUSE or ENTER.

Outcome Objects that are selected will be outlined in the selection color defined in the Options 
Preferences dialog box.

Comments The Toggle Selection command is especially useful when working on a densely 
populated area of a worksheet or when you wish to quickly add and remove a number of 
objects.

Procedure To toggle the selection of any object in an open document:

          1. Choose Toggle Selection from the Edit menu.

          2. Select or de-select the objects in the worksheet by moving the cursor over the object 
and pressing ENTER or LEFT MOUSE.

          3. Press ESC or RIGHT MOUSE to leave this command.

See also
Toggle Single Object



Toggle Single Object

Summary Toggle selection-state of objects.

Purpose The Toggle Single Object command is used to select and de-select objects on a 
schematic worksheet by moving the cursor over the object and clicking SHIFT + LEFT 
MOUSE.

Outcome Objects that are selected will be outlined in the selection color.

Comments The Toggle Single Object command can only be accessed using the mouse, unless its 
hot key is changed in the Assign Hot Keys dialog box.

Procedure To toggle the selection of a single object in an open document:

          1. Move the cursor over the object to be selected.

          2. Press SHIFT + LEFT MOUSE to select or de-select the object.

See also
Toggle Selection
Hot Keys



Delete

Summary Select and delete objects on schematic worksheet.

To Launch Alt E D

Purpose The Delete command is used to delete objects on a schematic worksheet.

Comments All deletions can be restored by using the Edit Undo command (ALT+BACKSPACE). If you 
have deleted a series of objects, they will be restored individually, starting with the last 
object deleted.

Procedure To Delete objects in an open document:

          1. Choose Delete from the Edit menu.

          2. Delete the objects from the worksheet by moving the cursor over an object and 
pressing ENTER or LEFT MOUSE.

          As you click on an object, it will be cleared from the worksheet and the status line will 
continue to prompt you to select another object.

          4. Press ESC or RIGHT MOUSE to leave this command.

See also
Undo
Delete Single Object



Delete Single Object

Summary Delete object that currently has the focus.

Purpose The Delete Single Object command is used to delete an object that currently has the 
focus.

Comments All deletions can be restored by using the Edit Undo command (ALT+BACKSPACE). If you 
have deleted a series of objects, they will be restored individually, starting with the last 
object deleted.

          Accidental deletion of objects may be further safe-guarded by enabling the Question 
Delete option. If this option is enabled a Confirm Delete dialog box will be displayed as 
you select an object. You can enable or disable this message from the Preferences 
dialog box in the Options menu.

Procedure To delete an object that currently has the focus;

          1. Move the cursor over the object to be deleted and click S8 LEFT MOUSE. The object 
will then be displayed with graphical editing handles.

          3. Press the DELETE key.

          When you press the DELETE key, the object will be cleared from the worksheet.

See also
Undo
Delete
Clear



Change Object Graphically or Set Focus

Summary Select and change objects on schematic sheet.

Purpose This command is used to set the focus on an object. If the object already has the focus 
then this command interactively changes the object by physically moving the position of 
the objects handles.

Comments The Change Single Object Graphically command can normally only be accessed using 
the mouse. This can be changed using Option-Hotkeys command. You can use the Edit 
Undo command (shortcut: ALT+BACKSPACE) to restore the edited objects.

Procedure To set the focus on an object;

          1. Move the cursor over the object to be graphically edited and click LEFT MOUSE. The 
object will then be displayed with graphical editing handles.

          2. Use the mouse to graphically change the object by clicking left mouse on a graphical 
handle and dragging that handle to a new location.

See also
Change



Change

Summary Select and use dialog to change objects.

To Launch Alt E H

Purpose The Change command is used to modify specific attributes of placed objects on the 
schematic worksheet. Each object or primitive has its own range of editable attributes. 
You can change one object or extend changes across your entire design using powerful 
global editing options.

Outcome Opens the object's dialog box, displaying all editable attributes.

Comments The system will not prevent changes that violate specific design rules. An Electrical Rule 
Check (ERC) should always be performed before generating a netlist.

          Global ChangesChanges can be made to a single selected object or they can be applied
globally across the entire worksheet using flexible, powerful global editing options. 
Virtually every editable attribute can be globally applied. A simple example would be 
changing the font style assigned to a single text string. Typically, the engineer would 
want this new font style applied to other strings as well. However, it might be important 
that the new font style be applied only to strings with the same size as the selected 
string, or perhaps strings of a specific style or size only, etc. 

          All of these options (and more) are supported by the Change command in Advanced 
Schematic. The possible applications for global changes are limited only by the 
imagination of the engineer. The large number of global change options may make this 
feature appear somewhat complex at first. However, the principles of applying global 
changes are reasonably simple, once understood. When mastered, this feature can be 
an important productivity tool. Matching attributes for global changes can be assigned by
clicking the Options button in any of the Change object dialog boxes. When you click 
Options, the dialog box expands to display the parameters for global matches.

          Each Change object dialog box may contain different options since every type of object 
has a unique set of attributes. For example, junctions have five changeable attributes X-
location, Y-location, size, color and selection. While Ports have eleven. For detailed 
descriptions of all objects and assigned attributes, see the Data Primitives section.

          Global change options

          Any attribute can be globally changed if the object's dialog box 

          includes a Match By and Copy field with the Attribute field.

          Match By

          There are three options for this field: Same (apply global 

          changes if this object attribute is matched in the target object); 

          Different (apply global changes if this attribute is not a match 

          in the target object) and Any (the default) which applies the 



          change irrespective of whether the attribute has the same value 

          in both objects.

          Copy

          If the Copy box is checked, then this attribute will be copied to 

          the target object. These fields allow the designer to select a 

          range of attributes that will be copied to other objects.

          Change Scope

          These three options define the extent of changes: Change This 

          Item Only (no global changes); Change Matching Items In 

          Current Document; Change Matching Items In All (currently 

          opened) Documents. The latter option extends your changes 

          across all open sheets, allowing you to globally edit an entire 

          project.

          Using wildcards when globally editing text

          Many objects include text fields. These text fields can also be 

          globally edited with the additional capability of using wildcards to 

          define changes. This applies to parts, net labels, annotations (single 

          line text), sheet symbols, sheet entries, ports and power ports. 

          Separate Edit-Find Text and Edit-Replace Text commands allow 

          text replacement across different object types. These commands 

          also support the wildcard search and replace sytax, described 

          below.

          Syntax for wildcard search and replace edits

          The Match By field defines which strings will be edited. If * is 

          displayed (the defaualt), all strings for this field are available to be globally edited. This 
can be limited by defining specific cases, for example S* will limit the fields to strings 
beginning with S, etc. 

          Wildcards are case in-sensitive. 



          The Copy field for text strings is used to define the changes to be 

          made to the string. Braces "" and "" are used to define the rules 

          for text replacement. If this field is empty    then the entire string 

          will be replaced.

          Defining the change follows this syntax: oldtext=newtext. This 

          means change portion of the string "oldtext" to "newtext". You 

          can use multiple sets of brackets to define complex replacements. 

          In this case the leftmost replacement is made, then the next on, etc. 

          Although this is very powerful, you must take care, because the 

          first change can effect subsequent replacements, possibly 

          generating an unexpected result. 

          Any mistakes can be corrected with the Undo command, however. You can 

          further limit the replacement by typing !Text=text to make the changes case sensitive. In 
this case, "Text" becomes "text". Otherwise replacement is case in-sensitive by default.

Procedure To change any placed item, move the cursor over the item and 

          double-click LEFT MOUSE. This shortcut will open the Change 

          (item) dialog box for the selected item.

          You can also use the Change command from the Edit menu:

          1. Choose Edit-Change (shortcut: E, C);

          The prompt "Select (item)" will appear on the status line.

          2. Position the cursor over the target item and press ENTER or 

          LEFT MOUSE;

          A dialog box opens, displaying the editable attributes for the item.

          It is now possible to change any or all attributes of the selected item, such as a wire 
width or color.

See also
Change Object Graphically or Move
Change Single Object



Change Single Object

Summary Use dialog to change object under the cursor.

Purpose The Change Single Object command is used to modify specific attributes of placed 
objects on the schematic worksheet. This command is similar to the Change Command, 
except that when an object has been edited you will not be prompted to select another 
object. This command is activated by using the shortcut of double clicking the LEFT 
MOUSE on the object to be changed.

Comments The system will not prevent changes that violate specific design rules. An Electrical Rule 
Check (ERC) should always be performed before generating a netlist.

          The Change Single Object command can only be accessed through the    mouse, unless 
its hot key is changed in the Assign Hot Keys dialog box.

Procedure To change any placed object:

          1. Position the cursor over the target object and double click LEFT MOUSE.

          A dialog box opens displaying the editable attributes for the object. It is    possible to 
change any or all attributes of the selected object.

          2. Press ENTER or click OK to accept your changes. To cancel the change and close the 
dialog box press ESC or click CANCEL.

See also
Change



Move

Summary Select and move objects on schematic sheet.

To Launch Alt E M M

Purpose The Move command is used to interactively change the location of placed objects on the 
schematic worksheet.

Comments Advanced Schematic automatically stacks objects, text and graphics in layers on    a 
schematic sheet. Each object is on a different layer depending on the creation    order. 
The objects created or added recently are always on the top layer. When    you move and
place an object it retains its original order in the stack.

          While moving the object, you can rotate it 90 degrees around the cursor by pressing    
the SPACEBAR and flip it along its x or y axis by pressing the X and Y keys. Press TAB to 
manually change the location of the object by typing new coordinates directly into a 
dialog box.

Procedure To move any placed object:

          1. Choose Move, Move from the Edit menu.

          2. Position the cursor over the target object and press ENTER or LEFT MOUSE.

          If the object does not move with the cursor you may not be exactly over the object when 
you tried to select it. Use the Zoom options (or press PGUP) to enlarge your view of the 
layout and try again.

          3. Move the object to the desired location and press ENTER or LEFT MOUSE. To cancel the 
move press ESC or click RIGHT MOUSE.

          4. Select another object to be moved or press ESC or RIGHT MOUSE to leave the move 
command.

See also
Move Single Object



Move Single Object

Summary Select and move objects on the schematic worksheet.

Purpose The Move Single object command is used to interactively change the location of placed 
objects on the schematic worksheet. This command is similar to the Move command, 
except that when an object has been moved you will not be prompted to select another 
object. This command is activated by using the default shortcut: CTRL + LEFT MOUSE.

Comments Advanced Schematic automatically stacks objects, text and graphics in layers. Each 
object is on a different layer depending on the creation order. The objects created or 
added recently are always on the top layer. When you move an object by using the 
default shortcut of CTRL + LEFT MOUSE and then place the object, it retains its original 
order in the stack.

          While moving the object, you can rotate it 90 degrees around the cursor by pressing the 
SPACEBAR and flip it along its x or y axis by using the X and Y keys. Press TAB to manually
change the location of the object by typing new coordinates directly into a dialog box.

          The Move Single Object command can only be accessed using the mouse,    unless its 
hot key is changed in the Assign Hot Keys dialog box.

Procedure To move any placed object:

          1. Position the cursor over the target object and press CTRL + LEFT MOUSE.

          2. Move the object to the desired location and press ENTER or LEFT MOUSE.

          If the object does not move with the cursor you may not be exactly over the object when 
you tried to select it. Use the Zoom options (or press PGUP) to enlarge your view of the 
layout and try again.

          3. To cancel the move press ESC or click RIGHT MOUSE.

See also
Move



Move To Front

Summary Move and place an object in the front of all other objects.

To Launch Alt E M V

Purpose The Move To Front command is used to interactively change the location of placed 
objects on the schematic worksheet. This command is similar to the Move command, 
except that when an object has been moved and placed on the worksheet it will be 
positioned in front of all the other stacked objects on the sheet.

Comments Advanced Schematic automatically stacks objects, text and graphics in layers. Each 
object is on a different layer depending on the creation order. The objects created or 
added recently are always on the top layer. When you use the Move To Front command 
and place an object it will be positioned at the top of the stack in front of all the other 
objects on the sheet. Note: This feature has no connectivity significance.

          While moving the object, you can rotate it 90 degrees around the cursor by pressing the 
SPACEBAR and flip it along its x or y axis by using the X and Y keys. Press TAB to manually
change the location of the object by typing new coordinates directly into a dialog box.

Procedure To move any placed object to the front of all other objects on the worksheet:

          1. Choose Move, Move To Front from the Edit menu. The prompt "Select object" will 
appear on the status line.

          2. Position the cursor over the target object and press ENTER or LEFT MOUSE.

          If the object does not move with the cursor you may not be exactly over the object when 
you tried to select it. Use the Zoom options (or press PGUP) to enlarge your view of the 
layout and try again.

          3. Move the object to the desired location and press ENTER or LEFT MOUSE. To cancel the 
move press ESC or click RIGHT MOUSE.

          The status line will prompt "Select object". Select another object to be moved or

          4. Press ESC or RIGHT MOUSE to leave the Move To Front command.

See also
Bring To Front



Bring To Front

Summary Bring an object graphically to the front of all other objects.

To Launch Alt E M F

Purpose The Bring To Front command is used to move objects on the schematic worksheet to the
front of all other objects.

Comments Advanced Schematic automatically stacks objects, text and graphics in layers . Each 
object is on a different layer depending on the creation order. The objects created or 
added recently are always on the top layer. When you use the Bring To Front command 
and click on an object it will be positioned at the top of the stack in front of all the other 
objects on the sheet. Note: This feature has no connectivity significance.

Procedure To move any placed objects to the front of all other objects on the worksheet:

          1. Choose Move, Bring To Front from the Edit menu. The prompt "Select object" will 
appear on the status line.

          2. Position the cursor over the target object and press ENTER or LEFT MOUSE.

          When the object has been selected it will be positioned in front of all the other objects on
the sheet. Click on another object to bring it the front or;

          3. Press ESC or LEFT MOUSE to leave the Bring To Front command.

See also
Move To Front



Send To Back

Summary Send an object to the back of all other objects.

To Launch Alt E M B

Purpose The Send To Back command is used to send objects on the schematic worksheet to the 
back of all other objects.

Comments Advanced Schematic automatically stacks objects, text and graphics in layers. Each 
object is on a different layer depending on the creation order. The objects created or 
added recently are always on the top layer. When you use the Send To Back command 
and click on an object it will be positioned at the bottom of the stack, behind all the other 
objects on the sheet. Note: This feature has no connectivity significance.

Procedure To send an object to the back of all other objects on the worksheet:

          1. Choose Move, Send To Back from the Edit menu. The prompt "Select object" will 
appear on the status line.

          2. Position the cursor over the target object and press ENTER or LEFT MOUSE.

          When the object has been selected it will be positioned at the back of all the other 
objects on the sheet. Click on another object to send it to the back or;

          3. Press ESC or RIGHT MOUSE to leave the Send To Back command.

See also
Send To Back Of



Bring To Front Of

Summary Bring an object to the front of another object.

To Launch Alt E M O

Purpose The Bring To Front Of command is used to move an object on the schematic worksheet 
to the front of another object. This command is similar to the Bring To Front command, 
except that you will be prompted to indicate the object that the selected object will be 
placed in front of.

Comments Advanced Schematic automatically stacks objects, text and graphics in layers. Each 
object is on a different layer depending on the creation order. The objects created or 
added recently are always on the top layer. When you use the Bring To Front Of 
command and click on an object it will be positioned at the bottom of the stack, behind all
the other objects on the sheet. Note: This feature has no connectivity significance.

Procedure To move a placed object to the front of another object on the worksheet:

          1. Choose Move, Bring To Front Of from the Edit menu. The prompt "Select object" will 
appear on the status line.

          2. Position the cursor over the target object and press ENTER or LEFT MOUSE.

          The object will temporarily disappear from the worksheet exposing any objects behind it. 
The prompT "Select object" will appear on the status line again.

          3. Click on the object that the original object will be placed in front of.

          4. Click on another object or press ESC or RIGHT MOUSE to leave the Bring To Front 
command.

See also
Bring To Front



Send To Back Of

Summary Send an object to the back of another object.

To Launch Alt E M T

Purpose The Send To Back Of command is used to move an object on the schematic worksheet 
behind another object. This command is similar to the Send To Back command, except 
that you will be prompted to select the object that the original object will be placed 
behind.

Comments Advanced Schematic automatically stacks objects, text and graphics in layers. Each 
object is on a different layer depending on the creation order. The objects created or 
added recently are always on the top layer. When you use the Send To Back command 
and click on an object it will be positioned at the bottom of the stack, behind all the other 
objects on the sheet. Note: This feature has no connectivity significance.

Procedure To move a placed object behind another object on the worksheet:

          1. Choose Move, Send To Back Of from the Edit menu. The prompt "Select object" will 
appear on the status line.

          2. Position the cursor over the target object and press ENTER or LEFT MOUSE.

          The object will temporarily disappear from the worksheet exposing any objects behind it. 
The prompt "Select object" will appear on the status line again.

          3. Click on the object that the original object will be placed behind.

          4. Press ESC or RIGHT MOUSE to leave the Send To Back Of command.

See also
Send To Back
Bring To Front



Place Arcs

Summary Place graphical arcs on the worksheet.

To Launch Alt P D A

Purpose The Place Arc command is used to place an arc on the worksheet using the center of the
arc as the starting point. Arcs are used for adding reference information to a schematic 
design, such as building graphical or mechanical symbols.

Comments When using the Place Arcs command the default placement field values are determined 
by the last placed arc. Press TAB to change the default arc line width and color during 
placement.

Procedure To place an arc on the current worksheet:

          1. Choose Drawing Tools and then Arcs from the Place menu.

          While moving the arc, you can rotate it 90 degrees around the cursor by pressing the 
SPACEBAR and flip it along its x or y axis by using the X and Y keys. Press TAB to manually
change the default values of the arc by typing new values directly into a dialog box.

          2. Position the cursor where the center of the arc is to be placed and press ENTER or 
LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted arc will be displayed.

          3. Position the cursor to establish the desired radius then press ENTER or LEFT MOUSE.

          4. Position the cursor to define the start angle of the arc, then press ENTER or LEFT MOUSE
again.

          5. Position the cursor to define the end angle of the arc, then press ENTER or LEFT MOUSE.

          Start a new arc by selecting a center point or press ESC or RIGHT MOUSE to exit this 
command.

See also
Arc
Place Elliptical Arcs



Place Polygons

Summary Place graphical polygon shapes on the worksheet.

To Launch Alt P D P    -    

Purpose The Place Polygons command is used to place graphical polygon objects on the 
current schematic worksheet. Polygons can be used for adding reference information to a worksheet, 
such as building graphical symbols, custom sheet borders, and title blocks.

Comments When using the Place Polygons command the default placement field values are 
determined by the last placed polygon. Press TAB to change the default polygon line width, line color and 
fill color during placement.

Procedure To place a polygon on the current worksheet:

          1. Choose Drawing Tools and then Polygons from the Place menu.

          Press TAB to manually change the default values of the polygon by typing new values 
directly into a dialog box.

          2. Position the cursor where the first polygon segment is to be placed and press ENTER 
or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted polygon outline will be 
displayed.

          You may continue to add polygon line segments as desired by clicking the LEFT MOUSE or
pressing the INSERT key. If you make a mistake, you can press DELETE to remove the last
line segment. You can also press ESC or RIGHT MOUSE to cancel the current segment.

          5. To exit this command press ESC or RIGHT MOUSE a second time.

See also
Polygon



Place Lines

Summary Place graphical lines on the sheet.

To Launch Alt P D L    -    

Purpose The Place Lines command is used to place graphical lines on the current 
schematic worksheet. Lines are used for adding reference information to a worksheet, such as building 
graphical symbols, custom sheet borders, and title blocks.

Comments When using the Place Lines command the default placement field values are 
determined by the last placed polyline. Press TAB to change the default polyline width and color during 
placement.

Procedure To place a line on the current worksheet:

          1. Choose Line from the Place menu.

          Press TAB to manually change the default values of the polyline by typing new values 
directly into a dialog box.

          2. Position the cursor where the first polyline segment is to be placed and press ENTER or
LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted polyline segment will be 
displayed.

          3. Position the cursor to establish the length and angle of the polyline segment, then 
press ENTER or LEFT MOUSE to end this first segment of the polyline.

          You may continue to add line segments as desired by clicking the LEFT MOUSE or 
pressing the INSERT key. If you make a mistake, you can press DELETE to remove the last
line segment. You can also press ESC or RIGHT MOUSE to cancel the current segment.

          5. To exit this command press ESC or RIGHT MOUSE a second time.

See also
Line



Place Beziers

Summary Place bezier curves on the sheet.

To Launch Alt P D B    -    

Purpose The Place Bezier command is used to place curved line segments on the current 
worksheet. Beziers are used for adding reference information to a worksheet, such as building graphical, 
mechanical or electrical symbols.

Comments When using the Place Beziers command the default placement field values are 
determined by the last placed Bezier. Press TAB to change the default Bezier curve width and color during 
placement.

          Remember, it takes four points to make a curve segment, (two control points and two 
end points). Therefore, if you add two points to an existing curve, you will not get a full 
segment.

Procedure To place a Bezier on the current worksheet:

          1. Choose Drawing Tools and then Beziers from the Place menu.

          Press TAB to manually change the default values of the Bezier by typing new values 
directly into a dialog box.

          2. Position the cursor where the first Bezier vertex is to be placed and press ENTER or 
LEFT MOUSE once. A Bezier must have at least four vertices to form a curve. The 
maximum number of vertices supported by a single Bezier object is fifty.

          As you move the mouse or press the arrow keys, a highlighted Bezier will be displayed.

          You may continue to add Bezier vertices as desired by clicking the S8 LEFT MOUSE or 
pressing the INSERT key. If you make a mistake, you can press DELTE to remove the last 
line segment. You can also press ESC or RIGHT MOUSE to cancel the current segment.

          5. To exit this command press ESC or RIGHT MOUSE a second time.

See also
Bezier



Place Ellipses

Summary Place elliptical shapes on the sheet.

To Launch Alt P D E    -    

Purpose The Place Ellipses command is used to place elliptical shapes on the worksheet 
using the center of the ellipse as the starting point. Ellipses are used for adding reference information to a
schematic design, such as building graphical or mechanical symbols.

Comments When using the Place Ellipses command the default placement field values are 
determined by the last placed ellipse. Press TAB to change the default ellipse border width, border color 
and fill color during placement.

Procedure To place an ellipse on the current worksheet:

          1. Choose Drawing Tools and then Ellipses from the Place menu.

          While moving the ellipse, you can rotate it 90 degrees around the cursor by    pressing 
the SPACEBAR and flip it along its x or y axis by pressing the X and Y keys. Press TAB to 
manually change the default values of the ellipse by typing new values directly into a 
dialog box.

          2. Position the cursor where the center of the ellipse is to be placed and press ENTER or 
LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted ellipse will be displayed.

          3. Position the cursor to establish the desired x-radius then press ENTER or LEFT MOUSE.

          4. Position the cursor to establish the desired y-radius then press ENTER or LEFT MOUSE.

          Start a new ellipse by selecting a center point or press ESC or RIGHT MOUSE to exit this 
command.

See also
Ellipse
Place Elliptical Arcs



Place Text Frame

Summary Place multi-line text frames on the sheet.

To Launch Alt P T F    -    

Purpose The Place Text Frame command is used to place detailed notes or descriptive 
text on the worksheet. Uses might include placing revision history, circuit and logic documentation or 
some other description on the sheet.

Comments When using the Place Text Frame command the default placement field values 
are determined by the last placed text frame. Press TAB to change the default text, font style, text color, 
border width etc. during placement.

Procedure To place text on the current worksheet:

          1. Choose Text and then Text Frame from the Place menu.

          While Text Frames can be rotated or flipped along the x or y axis, this has no effect on 
the orientation of the text. Press TAB to manually change the default values of the text 
frame by typing new values directly into a dialog box.

          2. Position the cursor where the center of the text frame is to be placed and press ENTER 
or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted text frame will be 
displayed.

          3. Position the cursor to establish the desired shape, then press ENTER or LEFT MOUSE.

          4. Place another text frame or press ESC or RIGHT MOUSE to exit this command.

See also
Text Frame
Place Annotation



Place Annotation

Summary Place single line text on the sheet.

To Launch Alt P T A    -    

Purpose The Place Annotation command is used to place single line notes or descriptive 
text on the worksheet. Uses might include placing section headings, revision history, timing information or 
some other description on the sheet.

Comments When using the Place Annotation command the default placement field values 
are determined by the last placed annotation. Press TAB to change the default text, font style, color and 
orientation during placement.

Procedure To place single line text on the current worksheet.

          1. Choose Text and then Annotation from the Place menu.

          While moving the annotation, you can rotate it 90 degrees around the cursor by pressing
the SPACEBAR and flip it along its x or y axis by pressing the X and Y keys. Press TAB to 
manually change the default values of the annotation by typing new values directly into a
dialog box.

          2. Position the cursor where the Annotation is to be placed and press ENTER or LEFT 
MOUSE once.

          Place another annotation or press ESC or RIGHT MOUSE to exit this command.

See also
Annotation
Place Text Frame



Place Pie Charts

Summary Place pie shapes on the sheet.

To Launch Alt P D C    -    

Purpose The Place Pie Charts command is used to place pie shaped graphical objects 
(closed ellipses with angular cutouts) on the worksheet. Pies can be placed as reference information, 
used in building graphical symbols, custom sheet borders, or title blocks.

Comments When using the Place Pie Charts command the default placement field values 
are determined by the last placed pie chart. Press TAB to change the default pie chart border width, border
color and fill color during placement.

Procedure To place a pie chart on the current worksheet:

          1. Choose Drawing Tools and then Pie Charts from the Place menu.

          While moving the pie chart, you can rotate it 90 degrees around the cursor by    pressing 
the SPACEBAR and flip it along its x or y axis by using the X and Y keys. Press TAB to 
manually change the default values of the pie chart by typing new values directly into a 
dialog box.

          2. Position the cursor where the center of the pie chart is to be placed and press ENTER 
or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted pie chart will be 
displayed.

          3. Position the cursor to establish the desired radius then press ENTER or LEFT MOUSE.

          4. Position the cursor to define the start angle of the pie chart, then press ENTER or LEFT 
MOUSE again.

          5. Position the cursor to define the end angle of the pie chart, then press ENTER or LEFT 
MOUSE.

          Place another pie chart or press ESC or SRIGHT MOUSE to exit this command.

See also
Pie Chart



Place Graphic

Summary Place PCX/BMP/GIF/TIFF/WMF/EPS graphical images on the sheet.

To Launch Alt P D G    -    

Purpose The Place Graphic command is used for adding reference information to a 
worksheet, such as company logos, mechanical and electrical symbols or customized images.

Comments Images are linked during loading, they are not stored in the library. Only the 
image file path is stored in the library.

          Advanced Schematic supports the import of the following image formats;

          BMP - All uncompressed Bit map images. Windows device-independent bit map format, 
introduced with Windows 3.0 and increasingly supported by Windows applications.

          PCX - Paintbrush format, used in Windows Paintbrush and other paint programs and 
supported by many desktop publishing and graphics programs. Supported colors 
include, monochrome, 16 color, 256 color, 24-bit color.

          TIFF - Tag Image File Format, supported by many desktop publishing programs. 
Supported compression types, uncompressed, LZW, Packbits, Modified Huffman 
encoding, CCITT Group 3 1D, CCITT Group 3 2D, CCITT Group 4. Supported colors 
include, monochrome, 16 color, 256 color, 24-bit color

          GIF - All non-interlaced Graphic Image files.

          EPS - Encapsulated postscript files with and without display images. If the EPS file 
doesn't contain a TIFF or Windows Metafile display image then the filename of the EPS 
image will be displayed.

          WMF - Only Windows Metafiles which conform to the Aldus Placeable Metafile Format 
are supported. Most applications which export or import Metafiles support this format.

Procedure To place graphical objects onto the worksheet; 

          1. Choose Drawing Tools and then Graphic from the Place menu.

          2. Type the image filename (include the full path, if different from the path listed after 
Directory) and click OK or press ENTER.

          You can also double-click on the desired filename in the Files window, if any. To change 
directories, click under any of the options listed in the Directories window.

          While moving the graphic, press TAB to manually change the default values of the 
graphic by typing new values directly into a dialog box.

          3. Position the cursor where the center of the text frame is to be placed and press ENTER 
or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted rectangle will be 
displayed.

          4. Position the cursor to establish the desired size of the image, then press ENTER or 



LEFT MOUSE.

          5. The Image file dialog box will be displayed again, choose another graphic image or 
press ESC or cancel to exit this command.

See also
Graphic



Place Round Rectangle

Summary Place round rectangles on the worksheet.

To Launch Alt P D O    -    

Purpose The Place Round Rectangle command is used to place a rounded rectangle on 
the worksheet using the center of the rounded rectangle as the starting point. Rounded rectangles are 
used for adding reference information to a schematic design, such as building graphical or mechanical 
symbols.

Comments When using the Place Round Rectangle command the default placement field 
values are determined by the last placed round rectangle. Press TAB to change the default round 
rectangle border width, border color and fill color during placement.

Procedure To place a rounded rectangle on the current worksheet:

          1. Choose Drawing Tools and then Round Rectangle from the Place menu.

          While moving the rounded rectangle, you can rotate it 90 degrees around the cursor and 
flip it along its x or y axis by pressing the X and Y keys. Press TAB to manually change the
default values of the rounded rectangle by typing new values directly into a dialog box.

          2. Position the cursor where the center of the rounded rectangle is to be placed and 
press ENTER or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted rounded rectangle will be 
displayed.

          3. Position the cursor to establish the desired shape, then press ENTER or LEFT MOUSE.

          Place another rounded rectangle or press SESC or RIGHT MOUSE to exit this command.

See also
Round Rectangle
Place Rectangles



Place Elliptical Arcs

Summary Place elliptical arcs on the worksheet.

To Launch Alt P D I    -    

Purpose The Place Elliptical Arcs command is used to place an elliptical arc on the 
worksheet using the center of the elliptical arc as the starting point. Elliptical arcs are used for adding 
reference information to a schematic design, such as building graphical or mechanical symbols.

Comments When using the Place Elliptical Arcs command the default placement field values 
are determined by the last placed elliptical arc. Press TAB to change the default arc line width and color 
during placement.

Procedure To place an elliptical arc on the current worksheet:

          1. Choose Drawing Tools and then Elliptical Arcs from the Place menu.

          While moving the elliptical arc, you can rotate it 90 degrees around the cursor    by 
pressing the SPACEBAR and flip it along its x or y axis by pressing the X and Y keys. Press
TAB to manually change the default values of the elliptical arc by typing new values 
directly into a dialog box.

          2. Position the cursor where the center of the elliptical arc is to be placed and press 
ENTER or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted arc will be displayed.

          3. Position the cursor to establish the desired x-radius then press ENTER or LEFT MOUSE.

          4. Position the cursor to establish the desired y-radius then press ENTER or LEFT MOUSE.

          5. Position the cursor to define the start angle of the elliptical arc, then press ENTER or 
LEFT MOUSE again.

          6. Position the cursor to define the end angle of the elliptical arc, then press ENTER or 
LEFT MOUSE.

          Start a new elliptical arc by selecting a center point or;

          Press ESC or RIGHT MOUSE to exit this command.

See also
Elliptical Arc
Place Arcs



Place Bus

Summary Place bus lines on the worksheet.

To Launch Alt P B    -    

Purpose The Place Bus command is used to place a graphical Bus line on the current 
worksheet. A Bus line is used to represent a common pathway for multiple signals on a worksheet.

Comments When using the Place Bus command the default placement field values are 
determined by the last placed Bus. Press TAB to change the default Bus width, and color during 
placement.

          Buses can be attached to Ports or sheet symbols, for connection to other schematic 
sheets.

Procedure To place a Bus connection:

          1. Choose Bus from the Place menu.

          Press TAB to manually change the default values of the Bus line by typing new values 
directly into a dialog box.

          2. Position the cursor where the first Bus line segment is to be placed and press ENTER 
or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted Bus line segment will be 
displayed. You can change the Bus placement mode by pressing the SPACEBAR.

          3. Position the cursor to establish the length and angle of the Bus line segment, then 
press ENTER or LEFT MOUSE to end this first segment of the Bus.

          You may continue to add line segments as desired by clicking the S8 LEFT MOUSE or 
pressing the INSERT key. If you make a mistake, you can press DELETE to remove the last
placed line segment. You can also press ESC or RIGHT MOUSE to cancel the current 
segment.

          5. To exit this command press ESC or RIGHT MOUSE a second time.

See also
Bus
Place Bus Entry



Place Bus Entry

Summary Place bus entry on the worksheet.

To Launch Alt P U    -    

Purpose The Place Bus Entry command is used to place a graphical Bus Entry object on 
the current worksheet. A Bus Entry is used to connect wires to a bus line.

Comments When using the Place Bus Entry command the default placement field values are
determined by the last placed Bus Entry. Press TAB to change the default Bus Entry line width and color 
during placement.

Procedure To place a Bus Entry:

          1. Choose Bus Entry from the Place menu.

          Press TAB to manually change the default values of the Bus line by typing new values 
directly into a dialog box. As you move the mouse or press the arrow keys, a highlighted 
Bus Entry segment will be displayed. You can change the Bus Entry angle by pressing 
the SPACEBAR.

          2. Position the cursor where the bus entry is to be placed and press ENTER or LEFT 
MOUSE once.

          You may continue to add bus entry objects as desired by moving and clicking the mouse.

          3. To exit this command press ESC or RIGHT MOUSE.

See also
Bus Entry
Place Bus



Place Parts

Summary Place parts on the worksheet.

To Launch Alt P P    -    

Purpose The Place Part command is used to retrieve a library part for placement on the 
current worksheet. During placement the part may be rotated or mirrored.

Comments The component library must be listed in the Library File List dialog box, before 
you can place it on the worksheet, use the Add/Remove Library command to add a library to the list. 
Refer to the user guide for detailed descriptions about Component and Part management.

Procedure To Place Parts on the current worksheet.

          1. Choose Parts from the Place menu.

          The Component Library Reference Name dialog box opens, displaying the name of the 
last placed Part. 

          2. Enter the Library Reference Name (74LS00, for example) into the dialog box and click
OK or press ENTER.

          3. Press ENTER or click OK to accept the default designator or type in a new designator 
then click OK or press ENTER. The Part will then be displayed in the workspace.

          While moving the part, you can rotate it 90 degrees around the cursor by pressing the 
SPACEBAR and flip it along its x or y axis by pressing the X and Y keys. Press TAB to 
manually change the default values of the Part by typing new values directly into a dialog
box.

          4. Position the cursor where the Part is to be placed and press ENTER or LEFT MOUSE 
once.

          5. The Component Library Reference Name dialog box will be displayed again, type in 
another Library Reference Name or press ESC or Cancel to exit this command.

          You can also place parts from the Browser by clicking the place button. The Browser 
allows browsing of component names, placement of parts onto the current worksheet, 
renaming of part designators and jumping to a part that has been placed on a worksheet 
in a project.

See also
Add/Remove Library
Place Part from Browser



Place Rectangles

Summary Place rectangles on the worksheet.

To Launch Alt P D R    -    

Purpose The Place Rectangle command is used to place a graphical rectangle on the 
current schematic worksheet. Rectangles can be used for adding reference information to a worksheet, 
such as building graphical symbols, custom sheet borders, and title blocks.

Comments When using the Place Rectangle command the default placement field values 
are determined by the last placed rectangle. Press TAB to change the default rectangle border width, 
border color and fill color during placement.

Procedure To place a rectangle on the current worksheet:

          1. Choose Drawing Tools and then Rectangle from the Place menu.

          While moving the rectangle, you can rotate it 90 degrees around the cursor and flip it 
along its x or y axis by pressing the X and Y keys. Press TAB to manually change the 
default values of the rectangle by typing new values directly into a dialog box.

          2. Position the cursor where the center of the rectangle is to be placed and press ENTER 
or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted rectangle will be 
displayed.

          3. Position the cursor to establish the desired shape, then press ENTER or LEFT MOUSE.

          Place another rectangle or press ESC or RIGHT MOUSE to exit this command.

See also
Rectangle
Place Round Rectangle



Place Junctions

Summary Place a junction on the current worksheet.

To Launch Alt P J    -    

Purpose Junctions are used to electrically connect intersecting wires on a sheet.
Comments Crossed or tangent wires in a schematic worksheet are not deemed to be 

connected unless a junction is placed where they intersect. Junctions are also placed where a wire 
crosses component pins.

          When using the Place Junction command the default placement field values are 
determined by the last placed junction. Press TAB to change the default junction size and color during 
placement.

          When the Auto Junction option (Options-Preferences command) is enabled, junctions 
are automatically added/removed from the sheet as wires and/or parts are placed and 
moved.

Procedure To place a junction on the current worksheet:

          1. Choose Place and then Junction from the Edit menu.

          Press TAB to manually change the default values of the junction by typing new values 
directly into a dialog box.

          2. Position the cursor where the center of the junction is to be placed and press ENTER or
LEFT MOUSE once. You can tell when electrical hot spots are in contact because their 
shape changes into a large dot.

          Place another Junction or press ESC or RIGHT MOUSE to exit this command.

See also
Junction



Place Port

Summary Place a port on the sheet.

To Launch Alt P R    -    

Purpose Ports are used to indicate connections between a net on two individual sheets in 
both flat and hierarchical designs.

Comments All Ports with the same name, within one sheet, are considered to be electrically 
connected. Ports can be used within a worksheet or across multiple sheets within a project.

          A Ports 'Style' is independent from its I/O Type. For example, a Port with the Style of 'Left 
& Right' does not necessarily mean the Port is Bi-directional.

          When using the Place Port command the default placement field values are determined 
by the last placed port. Press TAB to change the default port attributes, style, I/O type, 
alignment, border color, fill color and text color during placement.

Procedure To place a Port on the schematic worksheet:

          1. Choose Port from the Place menu.

          Press TAB to manually change the default values of the Port by typing new values directly
into a dialog box.

          2. Position the cursor where the Port is to be placed and press ENTER or LEFT MOUSE 
once.

          As you move the mouse or press the arrow keys, a highlighted Port will be displayed.

          3. Position the cursor to establish the desired length of the Port, then press ENTER or 
LEFT MOUSE.

          Place another Port or press ESC or RIGHT MOUSE to exit this command.

See also
Port



Place Net Label

Summary Place a net label on the worksheet.

To Launch Alt P N    -    

Purpose The Place Net Labels command is used to assign a wire and its entire physical 
net to a specific net name. Net labels are also used to connect signals (wires) together without actually 
physically connecting them. You can place labels horizontally or vertically on a worksheet.

Comments Within a sheet, all Net Labels with the same name are considered to be 
electrically connected. Net labels can also be made global -- applying to nets with the same name on all 
project sheets. This is done by changing the Net Identifiers Scope to Nets and Ports Global, under the 
File Create Netlist command.

          When using the Place Net label command the default placement field values are 
determined by the last placed net label. Press TAB to change the default net label 
attributes, orientation, color and font style during placement.

Procedure To place a Net Label on the schematic worksheet.

          1. Choose Net Label from the Place menu.

          While moving the Net Label, you can rotate it 90 degrees around the cursor by    pressing
the SPACEBAR and flip it along its x or y axis by pressing the X and Y keys. Press TAB to 
manually change the default values of the Net Label by typing new values directly into a 
dialog box.

          2. Position the cursor where the Net Label is to be placed and press ENTER or LEFT 
MOUSE once.

          You can tell when electrical hot spots are in contact because their shape changes into a 
large dot.

          As you move the mouse or press the arrow keys, a highlighted Net Label will be 
displayed.

          3. Place another Net Label or press ESC or RIGHT MOUSE to exit this command.

See also
Net Label



Place Sheet Symbol

Summary Place hierarchical sheet symbols on the worksheet.

To Launch Alt P S    -    

Purpose The Place Sheet Symbol command is used to represent another schematic sheet
in a hierarchical design. Sheet symbols include Sheet Entrys, which provide a connection point for signals
between the parent and child sheets, similarly to the way that Ports provide connections between sheets 
in a flat-sheet design.

Comments When using the Place Sheet Symbol command the default placement field 
values are determined by the last placed sheet symbol. Press TAB to change the default sheet symbol 
border width, border color and fill color during placement.

Procedure To place a Sheet Symbol onto the schematic worksheet.

          1. Choose Sheet Symbol from the Place menu.

          Press TAB to manually change the default values of the Sheet Symbol by typing new 
values directly into a dialog box.

          2. Position the cursor where one corner of the Sheet Symbol is to be placed and press 
ENTER or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted rectangle will be 
displayed.

          3. Position the cursor to establish the desired shape, then press ENTER or LEFT MOUSE.

          Place another Sheet Symbol or press ESC or RIGHT MOUSE to exit this command.

See also
Sheet Symbol



Add Sheet Entry

Summary Add net connections to sheet symbols.

To Launch Alt P E    -    

Purpose The Add Sheet Entry command is used to direct signals to another sheet in a 
hierarchical design. There are four types of Sheet Entry symbols, Input, Output, Bi-directional and 
Unspecified.

Comments Sheet Entry symbols are similar to Ports in that they direct a signal to another 
sheet. Sheet Entry symbols provide a connection point for signals going into and out of Sheet Symbols.

          When using the Place Add Sheet Entry command the default placement field values are 
determined by the last placed sheet entry. Press TAB to change the default sheet entry 
name, electrical type, style, border color, fill color, and text color during placement.

Procedure To place a Sheet Entry onto the schematic worksheet.

          1. Choose Add Sheet Entry from the Place menu.

          Press TAB to manually change the default values of the Sheet Symbol by typing new 
values directly into a dialog box.

          2. Position the cursor over a Sheet Symbol where the Sheet Entry is to be placed and 
press ENTER or LEFT MOUSE once.

          If the system beeps you may not be exactly over a Sheet Symbol. Use the Zoom options
(or press PGUP) to enlarge your view of the layout and try again.

          Place another Sheet Entry or press ESC or RIGHT MOUSE to exit this command.

See also
Sheet Entry



Place Wire

Summary Place electrical wires on the worksheet.

To Launch Alt P W    -    

Purpose The Place Wire command is used to place electrical Wire connections on the 
current schematic worksheet. The wires represent electrical connections between Parts on the schematic 
sheets.

Comments When using the Place Wire command the default placement field values are 
determined by the last placed wire. Press TAB to change the default wire width and color during 
placement.

Procedure To place a wire on the current worksheet:

          1. Choose Wire from the Place menu.

          Press TAB to manually change the default values of the Wire by typing new values 
directly into a dialog box.

          2. Position the cursor where the first Wire segment is to be placed and press ENTER or 
LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted Wire segment will be 
displayed. You can change the Wire placement mode by pressing the SPACEBAR. 

          3. Position the cursor to establish the length and angle of the Wire segment, then press 
ENTER or LEFT MOUSE to end this first segment of the Wire.

          You may continue to add Wire segments as desired by clicking the LEFT MOUSE or 
pressing the INSERT key. If you make a mistake, you can press DELETE to remove the last
placed line segment. You can also press ESC or RIGHT MOUSE to Cancel the current 
segment.

          4. To exit this command press ESC or RIGHT MOUSE a second time.

See also
Wire



Place Power Port

Summary Place power ports on the worksheet.

To Launch Alt P O    -    

Purpose The Place Power Port command is used to place Power Ports on the schematic 
worksheet. Power Ports are used to tie signals and pins to a power or ground net, without having to place 
net labels .

Comments When using the Place Power Port command the default placement field values 
are determined by the last placed power port. Press TAB to change the default power port name, style, 
orientation and color during placement.

Procedure To place a Power on the schematic worksheet.

          1. Choose Power Port from the Place menu.

          While moving the Power Port, you can rotate it 90 degrees around the cursor and flip it 
along its x or y axis by pressing the X and Y keys. Press TAB to manually change the 
default values of the Power Port by typing new values directly into a dialog box.

          2. Position the cursor on the wire or pin where the Power Port is to be placed and press 
ENTER or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted Power Port will be 
displayed.

          3. Place another Power Port or press ESC or RIGHT MOUSE to exit this command.

See also
Power Port



Place No ERC

Summary Suppress no-connection error message for nets.

To Launch Alt P I N    -    

Purpose No ERCs are special symbols that identify a pin on a part that is to be left 
unconnected. During electrical design rules checking, unconnected pins with No ERC symbols will be 
ignored.

Comments No ERC symbols must be placed on the end of pins in order for the No ERC to 
be effective.

          When using the Place No ERC command the default placement field values are 
determined by the last placed No ERC symbol. Press TAB to change the default No ERC color during 
placement.

Procedure To place a No ERC symbol on the schematic worksheet.

          1. Choose Directives and then No ERC from the Place menu.

          Press TAB to manually change the default values of the No ERC symbol by typing new 
values directly into a dialog box.

          2. Position the cursor where the No ERC symbol is to be placed and press ENTER or LEFT
MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted No ERC symbol will be 
displayed.

          3. Place another No ERC symbol or press ESC or RIGHT MOUSE to exit this command.

See also
No ERC



Place Probe

Summary Add net to list of nets to be traced by digital simulator.

To Launch Alt P I P    -    

Purpose A Probe is a special marker which is placed on the worksheet to identify nodes 
for digital simulation.

Comments When using the Place Probe command the default placement field values are 
determined by the last placed probe. Press TAB to change the default probe attributes and color during 
placement.

          Probes are used in OrCAD digital simulation tools, refer to your OrCAD documentation 
for further information about using simulation probes.

Procedure To place a Probe on the schematic worksheet.

          1. Choose Directives and then Probe from the Place menu.

          Press TAB to manually change the default values of the Probe by typing new values 
directly into a dialog box.

          2. Position the cursor on the wire where the Probe is to be placed and press ENTER or 
LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted Probe symbol will be 
displayed.

          3. Place another Probe or press ESC or RIGHT MOUSE to exit this command.

See also
Probe



Place Test Vector Index

Summary Mark nets to identify which simulation vector to use.

To Launch Alt P I T

Purpose Test Vectors are special symbols used to identify a node with a simulation test vector. 
The test vectors are referred to by a column number, which indicates the column of the 
test vector file to use when the simulation is run.

Comments When using the Place Test Vector Index command the default placement field values are
determined by the last placed Test Vector Index. Press TAB to change the default Test 
Vector Index attributes and color during placement.

          Test Vector Index symbols are used in OrCAD digital simulation tools, refer to your 
OrCAD documentation for further information about using simulation vectors.

Procedure To place a Text Vector Index on the schematic worksheet.

          1. Choose Directives and then No ERC from the Place menu.

          Press TAB to manually change the default values of the Test Vector Index by typing new 
values directly into a dialog box.

          2. Position the cursor on the wire where the Test Vector Index is to be placed and press 
ENTER or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted Test Vector Index symbol 
will be displayed.

          3. Place another Test Vector Index or press ESC or RIGHT MOUSE to exit this command.

See also
Test Vector Index



Place Stimulus

Summary Add stimulus information to nets for digital simulation.

To Launch Alt P I S    -    

Purpose A Stimulus is a special symbol which is used to identify a node to be stimulated 
when the digital simulation is run. The stimulus is an expression describing the pattern of states present in
the circuit logic.

Comments When using the Place Stimulus command the default placement field values are 
determined by the last placed Stimulus. Press TAB to change the default Stimulus attributes and color 
during placement.

          Stimulus symbols are used in OrCAD digital simulation tools, refer to your OrCAD 
documentation for further information about using simulation stimulus.

Procedure To place a Stimulus on the schematic worksheet.

          1. Choose Directives and then Stimulus from the Place menu.

          Press TAB to manually change the default values of the Stimulus by typing new values 
directly into a dialog box.

          2. Position the cursor on the wire where the Stimulus is to be placed and press ENTER or 
LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted Stimulus symbol will be 
displayed.

          3. Place another Stimulus symbol or press ESC or RIGHT MOUSE to exit this command.

See also
Stimulus



Place PCB Layout

Summary Add directives to nets for PCB routing.

To Launch Alt P I P    -    

Purpose PCB Layouts are special symbols that allow you to attach board layout 
information to a specific net. This information is saved into the netlist file which is later passed to 
Advanced PCB, OrCAD PCB or other compatible board layout systems.

Comments When using the Place PCB Layout command the default placement field values 
are determined by the last placed PCB Layout. Press TAB to change the default probe attributes and color 
during placement.

Procedure To place a PCB Layout symbol on the schematic worksheet.

          1. Choose Directives and then PCB Layout from the Place menu.

          Press TAB to manually change the default values of the PCB Layout symbol by typing 
new values directly into a dialog box.

          2. Position the cursor on the wire where the PCB Layout symbol is to be placed and 
press ENTER or LEFT MOUSE once.

          As you move the mouse or press the arrow keys, a highlighted PCB Layout symbol will 
be displayed.

          3. Place another PCB Layout symbol or press ESC or RIGHT MOUSE to exit this command.

See also
PCB Layout



Paste Array

Summary Define an array placement of clipboard contents.

To Launch Alt E Y    -    

Purpose The Paste Array command is used to define a multiple placement of    the 
clipboard contents.

Outcome The following are options that can be set within the Setup Array Placement dialog
box.

          Item Count - The number of repeat placements to be performed. For example, typing 5 
will place 5 of the current selection, contained in the clipboard.

          Text Increment - This option is used for net labels, annotations and part designators. 
Setting this to 1 will automatically increment. For example, an initial Net Label of Net1 
will automatically increment to Net2, Net3, Net4 and so on, and a Net Label of 1Net will 
increment 2Net, 3Net, 4Net.

          Incrementing can be numeric (1,2,3) or alphabetic (A, B, C) or a combination of alpha 
and numeric (A1, A2, or 1A, 1B or 1A, 2A, etc.).

          Horizontal - Specifies the distance along the x-axis between each clipboard selection as
it is placed. Positive and negative values are supported.

          Vertical - Specifies the distance along the y-axis between each clipboard selection as it 
is placed. Positive and negative values are supported.

Comments The clipboard holds the last selection only, each time you use the Cut or Copy 
command, you overwrite the previous selection.

Procedure To setup an array placement:

          1. Choose Paste Array from the Edit menu.

          The Setup Array Placement dialog box appears.

          2. Type in new array placement settings.

          3. Press the OK button to accept the array definition and return to the editor without 
executing the placement or;

          4. Press the PLACE button to execute the array placement with the current clipboard 
contents. Position the cursor at the desired reference point for the array placement and 
click LEFT MOUSE or ENTER.

See also
Cut
Copy
Execute Paste Array
Place Array Information



Execute Paste Array

Summary Place array with the last set array placement options.

Purpose The Execute Paste Array command is used to paste an array using the current clipboard 
contents and the last array setup options. This command is accessed using the PLACE 
button on the Setup Array Placement dialog box.

Outcome The clipboard contents will be placed according to the array setup you have defined, 
starting at the reference point you indicated.

Comments The Execute Paste Array command may be assigned a hot key (Options-Hot Keys 
command) to allow quick array placements.

Procedure To execute an array placement using the current clipboard contents

          1. Choose Paste Array from the Place menu.

          The Setup Array Placement dialog box appears.

          2. Press the PLACE button to execute the array placement with the current clipboard 
contents.

          3. Position the cursor at the desired reference point for the array placement and click 
LEFT MOUSE or ENTER.

See also
Paste Array
Hot Keys



Search For Net

Summary Search for and jump to the closest point of a net.

Purpose The Search for Net process allows you to conveniently locate a specific net on the 
worksheet without having to zoom, pan or scroll through multiple screens.

Outcome Once the net name has been entered or selected from a list the cursor will jump to the 
nearest pin that belongs to the selected net.

Comments The Browser supports jumping directly to nets. This process allows users to jump to nets
when the Browser is hidden. The Find Text command can also be used to search for net 
labels (or any object with text).

Procedure To search for a Net:

          1. Assign the process Search For Net to any key combination (Options-Hot Keys 
command).

          2. When activated, this process will open the Search For Net dialog box.

          3. Type the net name in the Search For dialog box and click OK.

See also



Find Text

Summary Search for and jump to a text string on any sheet.

To Launch  Ctrl F    -    Alt E F

Purpose The Find Text command allows you to conveniently locate specific text that has been 
placed on any worksheet without having to zoom, pan or scroll through multiple screens.

Comments The wildcard character "*" can be used to extend the definition of 

          target strings. For example, S* will limit the fields to strings 

          beginning with S, etc. Wildcards are case in-sensitive. 

          The find text command can find text anywhere on a sheet or across a multi-sheet 
project. Extends across all objects with visible text, including Part Fields and Text 
Frames.

Procedure To search for text:

          1. Choose the Find Text from the Edit menu.

          2. Type the search text into the Text to find field in the Find Text Dialog box.

          3. Choose the Scope for the change.

          Changes can be applied to the Current Docuement Only or to All 

          Open Documents. Objects with text to be changed can be 

          restricted to selected or unselected items.

          4. Choose any other Options.

See also



Jump Origin

Summary Jump to the origin of the worksheet (lower left).

To Launch Alt E J O

Purpose The Jump Origin command is used to move the cursor to the lower left corner of the 
schematic worksheet. This can save you from having to constantly zoom in and out to 
navigate around your design and is particularly useful for large or complex schematics.

Outcome Once the Jump Origin command has been selected the cursor will jump to the lower left 
corner (0,0 coordinate) of the worksheet.

Procedure To move the cursor to the origin of the worksheet:

          1. Choose Jump Origin from the Edit menu.

See also
Jump New Location



Jump New Location

Summary Type in and jump to a new location on the worksheet.

To Launch Alt E J L

Purpose The Jump Location command is used to move the cursor to a specified location by 
typing in X and Y coordinates. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome The cursor is placed on the specified location.

Procedure To move the cursor to a specified location.

          1. Choose Jump Location from the Edit menu.

          2. Type an X coordinate (a distance from the left hand side of the worksheet), the default 
is the current X position.

          3. Type a Y coordinate (a distance from the bottom of the worksheet), the default is the 
current Y position.

          3. Click OK to jump to the specified location.

See also
Jump Origin



Jump Location Mark 1

Summary Jump to a location previously specified by setting Location Mark 1-10..

To Launch Alt E J 1

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to the Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark 1



Jump Location Mark 2

Summary Jump to a location previously specified by setting Location Mark 1-10..

To Launch Alt E J 2

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to the Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark    2



Jump Location Mark 3

Summary Jump to a location previously specified by setting Location Mark 1-10..

To Launch Alt E J 3

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to the Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark    3



Jump Location Mark 4

Summary Jump to a location previously specified by setting Location Mark 1-10..

To Launch Alt E J 4

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to the Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark    4



Jump Location Mark 5

Summary Jump to a location previously specified by setting Location Mark 1-10..

To Launch Alt E J 5

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to the Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark    5



Jump Location Mark 6

Summary Jump to a location previously specified by setting Location Mark 1-10..

To Launch Alt E J 6

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to the Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark    6



Jump Location Mark 7

Summary Jump to a location previously specified by setting Location Mark 1-10..

To Launch Alt E J 7

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to the Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark    7



Jump Location Mark 8

Summary Jump to a location previously specified by setting Location Mark 1-10..

To Launch Alt E J 8

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to the Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark    8



Jump Location Mark 9

Summary Jump to a location previously specified by setting Location Mark 1-10..

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to the Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark    9



Jump Location Mark 10

Summary Jump to a location previously specified by setting Location Mark 1-10..

Purpose The Jump Location Mark command is used to move the cursor to a pre-defined location 
on the schematic worksheet. This can save you from having to constantly zoom in and 
out to navigate around your design and is particularly useful for large or complex 
schematics.

Outcome Once the Jump Location Mark command has been selected the cursor will jump to the 
location that was set for the Location Mark.

Comments The Location Mark is set by using the Location Mark commands in the Place menu. If 
the Location Mark has not been set the cursor will remain at the current location.

Procedure To move the cursor to Location Mark:

          1. Choose Jump Location Mark (1-10) from the Edit menu.

See also
Set Location Mark    10



Set Location Mark 1

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 1

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 1



Set Location Mark    2

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 2

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 2



Set Location Mark    3

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 3

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 3



Set Location Mark    4

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 4

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 4



Set Location Mark    5

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 5

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 5



Set Location Mark    6

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 6

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 6



Set Location Mark    7

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 7

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 7



Set Location Mark    8

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 8

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 8



Set Location Mark    9

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 9

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 9



Set Location Mark    10

Summary Set location mark (1-10) on the current worksheet.

To Launch Alt P L 0

Purpose The Set Location Mark command is used to tag or mark a specific location on the 
schematic worksheet. The Jump Location Mark command is used to move the cursor to 
this set location.

Outcome Once the Set Location Mark command has been selected you will be prompted to select 
a location to be stored for the Location Mark, move the cursor to the desired location and
click OK or press ENTER.

Comments To move the cursor to this location you must use the Jump Location Mark command.

Procedure To define a new location for the Location Mark:

          1. Choose Jump Location Mark from the Edit menu.

          2. Position the cursor at the desired location and click LEFT MOUSE or press ENTER.

          The location will be recorded for the Location Mark.

See also
Jump Location Mark 10



Zoom Window

Summary Select a rectangular area of the sheet and fit that area in the window.

To Launch Alt Z W

Purpose The Zoom Window command is used to re-set the magnification of a selected area in the
current document window.

Procedure To magnify a selected area in an open document:

          1. Choose Window from the Zoom menu. 

          2. Move the cursor and then press ENTER or LEFT MOUSE to define the first corner of the 
zoom rectangle.

          3. Move the cursor to enclose the area to be magnified with the highlighted rectangle.

          4. Press ENTER or LEFT MOUSE to complete zoom window.

See also
Zoom Point
Zoom In
Zoom Out



Zoom Point

Summary Select a rectangular area of the sheet and fit that area in the window.

To Launch Alt Z P

Purpose The Zoom Point command is used to re-set the magnification from a selected point and 
defined area in the current document window.

Procedure To magnify a selected area in an open document:

          1. Choose Point from the Zoom menu.

          You will be prompted to "Select First Corner."

          2. Move the cursor and then press ENTER or LEFT MOUSE to define the starting point the 
zoom rectangle.

          You will then be prompted to "Select Second Corner."

          3. Move the cursor to enclose the area to be magnified with the highlighted rectangle.

          4. Press ENTER or LEFT MOUSE to complete the zoom window.

See also
Zoom Window
Zoom In
Zoom Out



Zoom Sheet

Summary Show entire sheet.

To Launch Alt Z S    -    

Purpose The Zoom Sheet command is used to view the entire area of the current 
worksheet.

Procedure To view all of the current worksheet:
          1. Choose Sheet from the Zoom menu.

See also
Zoom All



Zoom All

Summary Fit all objects on the current sheet in the window.

To Launch  Ctrl PgDn    -    Alt Z A

Purpose The Zoom All command is used to fit all of the objects on the current worksheet into the 
current document window.

Comments The zoom window region is defined by objects at the highest and lowest coordinate 
points.

Procedure To fit all objects on the current worksheet into the current document window:

          1. Choose All from the Zoom menu.

See also
Zoom Sheet



Zoom In

Summary Show less of the current worksheet (higher magnification).

To Launch  PgUp    -    Alt Z I    -    

Purpose The Zoom In command is used to increase the magnification of the current 
worksheet.

Comments The Zoom In command is most effective when initiated with its shortcut: PGUP or 
z, i.

Procedure To increase the magnification of the current worksheet:
          1. Press PGUP or z, i.

See also
Zoom Out
Zoom All



Zoom Out

Summary Show more of the current worksheet (lower magnification).

To Launch  PgDn    -    Alt Z O    -    

Purpose The Zoom Out command is used to decrease the magnification of the current 
worksheet.

Comments The Zoom Out command is most effective when initiated with its shortcut: PGDN 
or z, o.

Procedure To decrease the magnification of the current worksheet:
          1. Press PGDN or z, o.

See also
Zoom In
Zoom All



Zoom Pan

Summary Re-Center the screen around the cursor.

To Launch  Home    -    Alt Z N

Purpose The Zoom Pan command is used to redraw the current document window with the 
previous cursor location at the center of the window.

Comments The Zoom Pan command is most effective when initiated with its shortcut HOME or z, n.

Procedure To center the worksheet view around the current cursor location:

          1. Move the cursor to the area or object you wish to position at the center of the current 
document window.

          2. Press HOME or z, n.



Screen Redraw

Summary Update the screen display.

To Launch  End    -    Alt Z R

Purpose The Screen Redraw command is used to update or refresh all objects on the current 
worksheet.

Procedure To re-draw the objects on the current worksheet:

          1. Choose Redraw from the Zoom menu.



Zoom 400%

Summary Set zoom scale to 4x (highest magnification).

To Launch  Ctrl 4    -    Alt Z 4

Purpose The Zoom 400% command is used to set the magnification of the current worksheet to a 
factor of 4 times the normal scale. This is the highest zoom magnification.

Outcome The view of the current worksheet will be re-set to a magnification of 400%, centered 
around the current cursor location.

Comments The Zoom 400% command is most effective when initiated with its shortcut z, 4.

Procedure To set the magnification of the current worksheet to 400%:

          1. Position the cursor on the area to be magnified.

          2. Choose 400% from the Zoom menu or shortcut: z, 4.

See also
Zoom All



Zoom 200%

Summary Set zoom scale to 2x.

To Launch  Ctrl 2    -    Alt Z 2

Purpose The Zoom 200% command is used to set the magnification of the current worksheet to a 
factor of 2 times the normal scale.

Outcome The view of the current worksheet will be re-set to a magnification of 200%, centered 
around the current cursor location.

Comments The Zoom 200% command is most effective when initiated with its shortcut z, 2.

Procedure To set the magnification of the current worksheet to 200%:

          1. Position the cursor on the area to be magnified.

          2. Choose 200% from the Zoom menu or shortcut: z, 2.

See also
Zoom All



Zoom 100%

Summary Set zoom scale to 1x (normal magnification).

To Launch  Ctrl 1    -    Alt Z 1

Purpose The Zoom 100% command is used to set the magnification of the current worksheet to 
its normal scale.

Outcome The view of the current worksheet will be re-set to a magnification of 100%, centered 
around the current cursor location.

Comments The Zoom 100% command is most effective when initiated with its shortcut z, 1.

Procedure To set the magnification of the current worksheet to 100%:

          1. Position the cursor on the area to be magnified.

          2. Choose 100% from the Zoom menu or shortcut z, 1.

See also
Zoom All



Zoom 50%

Summary Set zoom scale to 0.5x.

To Launch  Ctrl 5    -    Alt Z 5

Purpose The Zoom 50% command is used to set the magnification of the current worksheet to a 
factor of half the normal scale.

Outcome The view of the current worksheet will be re-set to a magnification of 50%, centered 
around the current cursor location.

Comments The Zoom 50% command is most effective when initiated with its shortcut z, 5.

Procedure To set the magnification of the current worksheet to 50%:

          1. Position the cursor on the area to be magnified.

          2. Choose 50% from the Zoom menu or shortcut z, 5.

See also
Zoom All



Information Selected Pins

Summary List all selected pins.

To Launch Alt I E

Purpose The Information Selected Pins command is used to display a list of the part and pin 
designators currently selected on the worksheet. This command is useful to identify that 
your nets contain all the necessary pin information.

Comments This command provides a list of selected pins, plus sheet entries and ports. If you click 
on any listed items and press OK, the workspace will zoom to display that object.

Procedure To get information about the selected pins on the current worksheet:

          1. Select pins by using the Select Net or Select Connection commands.

          2. Choose Selected Pins from the Info menu.

          A dialog box will appear with a list of the selected pins on the current worksheet.

See also
Select Net
Select Connection



Sheet Options

Summary Setup options for current worksheet.

To Launch Alt O S

Purpose The Options Sheet command is used to define various sheet settings, such as sheet 
styles, size, orientation, background and border colors and other options that apply to 
the worksheet.

Outcome The following are options that can be set within the schematic sheet dialog box.

          Border Style - Advanced Schematic provides two default borders. You can use either 
the Standard or the ANSI border that uses the ANSI convention to provide a reference 
grid system.

          Standard Size - Advanced Schematic supports 10 standard imperial and metric sheet 
sizes. They include A, B, C, D, E (or metric sizes A4-A0).

          Custom Size - This is the flag that allows you to use Schematic Editor standard 
worksheet sizes or to define your own custom worksheet size.

          Custom X - The worksheet size along the x-axis. The maximum X size is 65 inches, 
(6500 units).

          Custom Y - The worksheet size along the y-axis. The maximum Y size is 65 inches, 
(6500 units).

          Orientation - Defines the orientation of the schematic worksheet. The sheet can be 
displayed in landscape (default) mode or in portrait mode.

          Border - If this option is enabled, the sheet border will be displayed. If you want to 
design a custom border, turn this option off and use Advanced Schematic's drawing 
tools.

          Title Block - Advanced Schematic provides a default title block. You can use either the 
Standard title block or the ANSI standard title block. Some of the information in the title 
block is provided automatically, e.g. the sheet size, file name and creation date. Other 
information can be added using Annotations or Text Frames. You can hide the supplied 
title block by disabling this option and then use Advanced Schematics' Drawing tools to 
create custom title blocks.

          Border Color - The surrounding border and title block of your schematic worksheet can 
be assigned a default color. To assign a new color to the sheet border and title block, 
click in the color box to open the Color Selector dialog box. Advanced Schematic will 
display all the available colors that your graphics card and monitor supports. The border 
color only applies to Advanced Schematics' default border and default title block. 
Customized borders and title blocks will not be affected by this option.

          Color - A worksheet can be assigned a color. To assign a new color to the worksheet, 
click in the color box to open the Color Selector dialog box. Advanced Schematic will 
display all the available colors that your graphics card and monitor supports.

          Visible Grid - If this option is enabled, the visible grid is displayed. The visible grid can 



be assigned any color and can be displayed as lines or dots.

Procedure To setup and define sheet settings;

          1. Choose Sheet from the Options menu

          2. Type in new sheet settings.

          3. Click OK to accept the new settings.

See also
Preferences



Toggle Scroll Bars

Summary Turn the scroll bars on or off.

To Launch Alt O C

Purpose The Toggle Scroll Bars command is used to turn the Scroll Bars on or off in the current 
document window. Turning the scroll bars off will display more of the schematic 
worksheet.

Outcome Once the Scroll Bars command has been chosen the scroll bars at the edge of the 
current document window will toggle on or off depending on their previous state.

Procedure To toggle the scroll bars on or off:

          1. Choose Scroll Bars from the Options menu.



Toggle Visible Grid

Summary Turn the visible grid on or off.

To Launch Alt O V

Purpose The Toggle Visible Grid command is used to turn the visible grid on or off in the current 
document window. The visible grid provides visual reference as you move around the 
schematic worksheet and can be displayed as dots or straight lines.

Outcome Once the Visible Grid command has been chosen the visible grid will toggle on or off 
depending on its previous state.

Comments The visible grid can also be toggled on or of in the Options Sheet dialog box.

Procedure To turn the visible grid on or off:

          1. Choose Visible Grid from the Options menu.

See also
Preferences
Sheet Options



Toggle Snap Grid

Summary Turn the snap grid on or off.

To Launch Alt O G

Purpose The Toggle Snap Grid command is used to turn the cursor snap grid on or off. The snap 
grid defines an array of points in the workspace which restrict cursor movement and the 
placement of primitives. Turning the snap grid off allows you to place primitives at any 
location on the worksheet without any restrictions.

Outcome Once the Snap Grid command has been chosen the cursor snap grid will toggle on or off
depending on its previous state.

Procedure To turn the snap grid on or off:

          1. Choose Snap Grid from the Options menu.



Shift Cursor Up

Summary Move the cursor up 10 snap grid points.

Purpose The Shift Cursor Up command is used to move the cursor up 10 grid points in the 
schematic worksheet.

Outcome When the Shift and Up arrow keys are pressed the cursor will move up 10 grid points, 
along the X axis.

Procedure To move the cursor up 10 snap grid points:

          1. Press UP ARROW on the keyboard while holding down SHIFT.

See also
Cursor Up



Shift Cursor Down

Summary Move the cursor down 10 snap grid points.

Purpose The Shift Cursor Down command is used to move the cursor down 10 grid points in the 
schematic worksheet.

Outcome When the Shift and Down arrow keys are pressed the cursor will move down 10 grid 
points, along the Y axis.

Procedure To move the cursor down 10 snap grid points:

          1. Press DOWN ARROW on the keyboard while holding down SHIFT.

See also
Cursor Down



Shift Cursor Left

Summary Move the cursor up 10 snap grid points.

Purpose The Shift Cursor Left command is used to move the cursor to the left 10 grid points in the
schematic worksheet.

Outcome When the Shift and Left arrow keys are pressed the cursor will move to the left 10 grid 
points, along the X axis.

Procedure To move the cursor left 10 snap grid points:

          1. Press LEFT ARROW on the keyboard while holding down SHIFT.

See also
Cursor Left



Shift Cursor Right

Summary Move the cursor right 10 snap grid points.

Purpose The Shift Cursor Right command is used to move the cursor to the right 10 grid points in 
the schematic worksheet.

Outcome When the Shift and Right arrow keys are pressed the cursor will move to the right 10 grid
points, along the X axis.

Procedure To move the cursor right 10 snap grid points:

          1. Press RIGHT ARROW on the keyboard while holding down SHIFT.

See also
Cursor Right



Cursor Up

Summary Move the cursor up one snap grid point.

Purpose The Cursor Up command is used to move the cursor up one snap grid point in the 
schematic worksheet.

Outcome When the Up arrow key is pressed the cursor will move up one grid point, along the Y 
axis.

Procedure To move the cursor up one snap grid point:

          1. Press UP ARROW on the keyboard.

See also
Shift Cursor Up



Cursor Down

Summary Move the cursor down one snap grid point.

Purpose The Cursor Down command is used to move the cursor down one snap grid point in the 
schematic worksheet.

Outcome When the Down arrow key is pressed the cursor will move down one grid point, along 
the Y axis.

Procedure To move the cursor down one snap grid point:

          1. Press DOWN ARROW on the keyboard.

See also
Shift Cursor Down



Cursor Left

Summary Move the cursor left one snap grid point.

Purpose The Cursor Left command is used to move the cursor left one snap grid point in the 
schematic worksheet.

Outcome When the Left arrow key is pressed the cursor will move left one grid point, along the X 
axis.

Procedure To move the cursor left one snap grid point:

          1. Press LEFT ARROW on the keyboard.

See also
Shift Cursor Left



Cursor Right

Summary Move the cursor right one snap grid point.

Purpose The Cursor Right command is used to move the cursor right one snap grid point in the 
schematic worksheet.

Outcome When the Right arrow key is pressed the cursor will move right one grid point, along the 
X axis.

Procedure To move the cursor right snap grid point:

          1. Press RIGHT ARROW on the keyboard.

See also
Shift Cursor Right



Make Project Library

Summary Make a library of parts contained in the current project.

To Launch Alt L M

Purpose The Make Project Library command is used to automatically build a component library of
all the parts that have been placed in a project.

Outcome The library file will be saved to the new file name, format and directory that you specified.

Comments The Make Project Library command can be used to generate an exact working library of 
your finished project. The library could accompany your schematic project files when you
send them to other engineers, instead of sending your original libraries.

Procedure To make a component library of parts:

          1. Choose Make Project Library from the Library menu.

          2. Type a new file name for the component library. To change the output format of the 
file, choose one of the options listed in the File Format window. 

          3. Click OK to save the file.

          To change directories, click under any of the options listed in the Directories window.



Update Parts

Summary Update all parts from library information.

To Launch Alt L U

Purpose The Update Part command is used to update all parts in every single sheet that is open, 
from libraries listed in the Change Library File List dialog box.

Outcome Any changes that have been made to parts in the Library Editor will be    reflected in 
those parts in the current project.

Comments Generates a text report listing any parts that have been updated.

Procedure To update the parts on the current project:

          1. Choose Update Parts from the Library menu.



Netlist Compare

Summary Compare two Protel format netlists and generate a report.

To Launch Alt F R N

Purpose To generate a text report listing the differences between two Protel format netlists. This is
used to compare the differences between two revisions of a project, or to compare the 
difference between a schematic netlist and the netlist of the completed board generated 
by the PCB application.

Outcome A text report is generated, listing differences between two netlist files.

Comments Works with Protel, Protel 2 and Tango format netlists. This report does not report 
component differences.

Procedure Choose File Reports Netlist Compare. You will be prompted to load two netlist files. Type
in the name for the first netlist or search the available directories for the desired .NET 
file. Then type or choose the second netlist and click OK.

          A report file is generated and opened, using the Notepad utility. This text file lists all 
matched nets (by name) and reports:

          Total Matched Nets                                                

          Total Partially Matched Nets                          

          Total Extra Nets in the first netlist

          Total Extra Nets in the second netlist 

          Total Nets in the first netlist

          Total Nets in in the second netlist



Create Sheet Symbol From Sheet

Summary Create a sheet symbol that represents the current sheet.

To Launch Alt F H Y

Purpose Used in hierarchical designs, to speed creation of sheet symbols for a "child" sheet. After
creating a sheet, this command will automatically generate a sheet symbol, labeled with 
its file name, including sheet entries for each port in the sheet. Sheet entry electrical 
characteristics and and styles complement the ports in the original sheet.

Comments For each Port on the sheet, an a sheet entry will be created on the sheet symbol. If the 
Port is input, then the sheet entry will be output etc.

Procedure Go to the sheet where the new sheet symbol will be placed. Run this process. A list of all
sheets will be displayed. Choose the sheet and a sheet symbol representing that sheet 
will be created in the current sheet. The name and file name of the sheet symbol will 
reflect the chosen sheet.

          When this process is run, the user is presented the option to "Reverse Input/Output 
Directions." This option changes the sheet entry electrical types to be opposite the ports 
that they represent in the sheet symbol.

See also
Create Sheet From Sheet Symbol
Hierarchical and multi sheet support



Create Sheet From Sheet Symbol

Summary Creates a new sheet (File New command) and adds ports for sheet entries on the sheet 
symbol.

To Launch Alt F H S

Purpose Used in hierarchical design. After creating a sheet symbol (if following a top down design
methodology), automatically creates a new sheet with ports for all sheet entries present 
in the sheet symbol. Ports electrical characteristics and styles complement the sheet 
entries in the original sheet symbol.

Comments Use the Save As command after using this process. Otherwise, the new sheet will not be
saved and hence there will be no file to represent it. Warning: if you crate a sheet for a 
sheet symbol and a sheet of that name already exists in the same directory, the previous
sheet will be over-written when the new sheet is saved.

Procedure Place a Sheet Symbol, add sheet Entries, setting their electrical characteristics. Run this 
process. A new empty sheet will be created with Ports placed for each sheet entry. The 
file name of the sheet will reflect the sheet symbol filename. 

          When this process is run, the user is presented the option to "Reverse Input/Output 
Directions." This option changes the new sheet's port electrical types to be opposite the 
sheet entries that they represent.

See also
Create Sheet Symbol From Sheet
Hierarchical and multi sheet support



Run Control Panel

Summary Run the Windows Control Panel program.

To Launch  T W P

Purpose This command is used to launch Windows Control Panel utility directly from Advanced 
Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome The Windows Control Panel utility will be launched.

Comments This is not a user-selectable Run command option.

Procedure Choose the Windows Tools command from the Tools menu then choose Control Panel.

See also
Setup Run Options



Run Windows Setup

Summary Run the Windows Setup program.

To Launch  T W S

Purpose This command is used to launch the Windows Setup utility directly from Advanced 
Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome The Windows Setup utility will be launched.

Comments This is not a user-selectable Run command option.

Procedure Choose the Windows Tools command from the Tools menu then choose Windows Setup.

See also
Setup Run Options



Run Text Editor

Summary Run the user-specified text editor (defaults To NOTEPAD.EXE).

To Launch  T W T

Purpose This command is used to launch a user-specified text editor directly from Advanced 
Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome Launches the specified text editor application.

Comments User can specify the Text Editor application under the Tools-Setup command.

Procedure Choose the Windows Tools command from the Tools menu then choose Text Editor.

See also
Setup Run Options



Run Picture Editor

Summary Run the user-specified paint/draw program (default is PBRUSH.EXE).

To Launch  T W I

Purpose This command is used to launch a user-specified paint/draw application directly from 
Advanced Schematic. Tools menu commands provide convenient ways to launch 
frequently used applications and utilities.

Outcome Launches the specified Picture Editor application.

Comments User can specify the Picture Editor application under the Tools-Setup command.

Procedure Choose the Windows Tools command from the Tools menu then choose Picture Editor.

See also
Setup Run Options



Run File Manager

Summary Run the Windows File Manager program.

To Launch  T W F

Purpose This command is used to launch the Windows File Manager utility directly from 
Advanced Schematic. Tools menu commands provide convenient ways to launch 
frequently used applications and utilities.

Outcome Launches the Windows File Manager utility.

Comments This is not a user-selectable Run command option.

Procedure Choose the Windows Tools command from the Tools menu then choose File Manager.

See also
Setup Run Options



Run Calculator

Summary Run the Windows Calculator program.

To Launch  T W C

Purpose This command is used to launch the Windows Calculator utility directly from Advanced 
Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome Launches the Windows Calculator utility.

Comments This is not a user-selectable Run command option.

Procedure Choose the Windows Tools command from the Tools menu then choose Calculator.

See also
Setup Run Options



Run Clock

Summary Run the Windows Clock program.

To Launch  T W L

Purpose This command is used to launch the Windows Clock utility directly from Advanced 
Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome Launches the Windows Clock utility.

Comments This is not a user-selectable Run command option.

Procedure Choose the Windows Tools command from the Tools menu then choose Clock.

See also
Setup Run Options



Run User Program 1

Summary Run user specified Program 1.

To Launch  T U 1

Purpose This command is used to launch an application directly from Advanced Schematic. Tools 
menu commands provide convenient ways to launch frequently used applications and 
utilities.

Outcome Launches the specified User Program (application/utility) #1.

Comments User can specify the User Program #1 application under the Tools-Setup command.

Procedure Choose the User Tools command from the Tools menu then choose User Program 1.

See also
Setup Run Options



Run User Program 2

Summary Run user specified Program 2.

To Launch  T U 2

Purpose This command is used to launch an application directly from Advanced Schematic. Tools 
menu commands provide convenient ways to launch frequently used applications and 
utilities.

Outcome Launches the specified User Program (application) #2.

Comments User can specify the User Program #2 application under the Tools-Setup command.

Procedure Choose the User Tools command from the Tools menu then choose User Program 2.

See also
Setup Run Options



Run User Program 3

Summary Run user specified Program 3.

To Launch  T U 3

Purpose This command is used to launch an application directly from Advanced Schematic. Tools 
menu commands provide convenient ways to launch frequently used applications and 
utilities.

Outcome Launches the specified User Program (application) #3.

Comments User can specify the User Program #3 application under the Tools-Setup command.

Procedure Choose the User Tools command from the Tools menu then choose User Program 3.

See also
Setup Run Options



Run User Program 4

Summary Run user specified Program 4.

To Launch  T U 4

Purpose This command is used to launch an application directly from Advanced Schematic. Tools 
menu commands provide convenient ways to launch frequently used applications and 
utilities.

Outcome Launches the specified User Program (application) #4.

Comments User can specify the User Program #4 application under the Tools-Setup command.

Procedure Choose the User Tools command from the Tools menu then choose User Program 4.

See also
Setup Run Options



Setup Run Options

Summary Setup user specific Programs to use with Tools Menu.

To Launch  T S

Purpose This command is used to set-up applications to be launched directly from Advanced 
Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome Opens the Setup Run Options dialog box.

Comments Note:Some DOS applications cannot be run from inside Windows. Attempting to launch 
incompatible DOS applications from the Tools menu could cause unexpected results, 
including system hangs.

          The Analog Simulator, Digital Simulator, Mixed Signal Simulator or the PLD/FPGA 
Compiler options specified in this dialog box can be launched automatically when 
generating a netlist (specified in the File-Netlist Generate dialog box).

Procedure 1. Choose the Setup command from the Tools menu to open the Setup Run Options 
dialog box.

          2. Type the path (if necessary) and application name for each option in the appropriate 
box. Options include:

          Schematic Library Editor - Editor for schematic library files. Default is LIBEDIT.EXE.

          PCB Layout - Application for Printed Circuit Board layout files. Default is PFW.EXE.

          PLD/FPGA Compiler - Compiler for PLD/FPGA files. Default is PLD.EXE.

          Analog Simulator -    Application for Analog Simulator. Default is ANASIM.EXE.

          Digital Simulator - Application for Digital Simulator. Default is DIGSIM.EXE.

          Mixed Signal Simulator - Application for Mixed Signal Simulator. Default is MIXSIM.EXE.

          Text editor - Editor for Reports (other than BOM CSV format). Default is NOTEPAD.EXE.

          Picture editor - Editor for Image files. Default is PBRUSH.EXE. 

          CSV editor - Editor for BOM (CSV portion) reports. Default is NOTEPAD.EXE.

          User Program 1 to 4 - any user specified application or utility. None specified by default.

See also
User Command Information
Run File Manager
Run Control Panel
Run Calculator
Run Clock
Run Notepad



Run Text Editor
Run Picture Editor
Run CSV Editor
Run User Program 1
Run User Program 2
Run User Program 3
Run User Program 4



Run CSV Editor

Summary Run the user specified program for editing CSV files.

To Launch  T W V

Purpose This command is used to launch an application directly from Advanced Schematic. Tools 
menu commands provide convenient ways to launch frequently used applications and 
utilities.

Outcome Launches the specified CSV Editor application.

Comments User can specify the CSV Editor application under the Tools-Setup command.

          Note:Some DOS applications cannot be run from inside Windows. Attempting to launch 
incompatible DOS applications from the Tools menu could cause unexpected results, 
including system hangs.

Procedure Choose the Windows Tools command from the Tools menu then choose CSV Editor.

See also
Setup Run Options



Help DOS Schematic

Summary Command Cross Reference for Protel DOS Schematic users.

To Launch  H D

Purpose The Help DOS Schematic menu option displays the command cross-reference for Protel 
DOS Schematic users.

Outcome Once the Help DOS Schematic command is selected the Advanced Schematic on-line 
help system is loaded and displays a cross-reference of command topics. Refer to the 
User Guide and reference supplement for information about Protel DOS Schematic 
compatibility.

Procedure To display the Protel DOS Schematic command cross-reference:

          1. Choose DOS Schematic from the Help menu.

          2. Then choose the specific topic from the help index list.

See also
Schematic 3 commands
Schematic 3 libraries
Block, highlighting, etc
Utilities



Jump To Next Error

Summary Jump to the next Error Marker in the Project.

To Launch Alt E J E

Purpose Finding the next error in any sheet of the current project (starting at the current sheet).

Outcome Once the Jump to Error Marker command has been selected the cursor will jump to the 
next Error Marker in the Project.

Comments After running the Electrical Rule Checker use this command to jump to error marker 
which have been placed on the sheet. After correcting the error, delete the error marker 
or run the Electrical Rule Checker again. Place down a No ERC marker if you do not 
want this error to be reported.

Procedure To find the next error in the Project:

          1. Choose Jump from the Edit menu and then Jump to Error Marker command.

See also
No ERC
Electrical Rules Check



Cross Probe Part on PCB

Summary Select part to cross probe to PCB.

To Launch Alt E O

Purpose Cross probing parts allows user to jump directly to a specified part (component footprint) 
in Protel for Windows PCB applications.

Outcome When the Cross Probe Part command is chosen, the PCB layout becomes the focus 
window and the selected component in the PCB layout is displayed in the center of the 
window.

Comments Implemented in Protel for Windows Advanced PCB version 1.5 or later.

Procedure To cross probe a part in the PCB layout:

          1. Open the Protel for Windows PCB file that corresponds to the active schematic sheet 
file;

          2. Choose Cross Probe Part from the Edit menu. You will be prompted to select a part;

          3. Position the cursor directly over the part you wish to cross probe and click LEFT MOUSE.

          The focus will move to the PCB window and the corresponding part will displayed in the 
center of the window.

See also
Cross Probe Net On PCB
Cross Probe Pin on PCB



Run Notepad

Summary Run the Windows Notepad program.

To Launch  T W N

Purpose This command is used to launch the Windows Notepad program directly from Advanced 
Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome Launches the Windows Notepad utility.

Comments This is not a user-selectable Run command option.

Procedure Choose the Windows Tools command from the Tools menu then choose Notepad.

See also
Setup Run Options



Popup Move Menu

Summary Popup the Move Menu.

Purpose The Popup Move Menu command is used to directly access the Move menu at the 
current cursor position.

Procedure To popup the Move menu at the current cursor position.

          1. Press M. (Default hot key assignment)

          You can change the default hot key by using the Options Hot Keys command.

See also
Hot Keys



Drag Single Item

Summary Focus on and move a single object (and drag connected wires).

Purpose Allows the user to move an item using focus, rather than selection, and drag electrically 
connected items.

Outcome As you move the item, any wires that are connected will drag to maintain the connection.

Comments While dragging wires the wire placement mode can be changed interactively by using 
the SPACEBAR. Objects can also be restricted to only move along the x-axis by holding 
down the SHIFT+CTRL keys, or along the y-axis by holding down the SHIFT key. To rotate 
the object press the CTRL+SPACEBAR keys.

Procedure 1. Click LEFT MOUSE on an item to place it in focus.

          You can tell an item is in focus, because it is displayed using a dashed line and its 
graphical editing handles are visible.

          2. Hold CTRL and click LEFT MOUSE again. 

          This command can also be assigned to a hot key by using the Hot Keys command from 
the Options menu.

See also
Drag
Drag Selection



Drag

Summary Select and move objects together with connected wires/buses.

To Launch Alt E M D

Outcome As you move the item, any wires or busses that are connected will drag to maintain the 
connection.

Comments While dragging wires the wire placement mode can be changed interactively by using 
the SPACEBAR. Objects can also be restricted to only move along the x-axis by holding 
down the SHIFT+CTRL keys, or along the y-axis by holding down the SHIFT key. To rotate 
the object press the CTRL+SPACEBAR keys.

Procedure 1. Choose Move Drag from the Edit menu;

          The prompt "Choose Object to Drag" is displayed on the Status Line.

          2. Position the cursor over the object to be moved and click LEFT MOUSE to move the 
object;

          3. When the move is completed, click LEFT MOUSE again;

          Note that the prompt "Choose Object to Drag" is still displayed on the Status Line.

          4. Choose another item to move or press RIGHT MOUSE or ESC to exit this option. 

See also
Drag Single Item
Drag Selection



Cross Probe Net On PCB

Summary Select power object / Net Label to cross probe to PCB.

To Launch Alt E B

Purpose Cross probing nets allows user to jump directly to a specified highlighted net in Protel for 
Windows PCB applications.

Outcome When the Cross Probe Net command is chosen, the PCB layout becomes the focus 
window and the selected net in the PCB layout is highlighted.

Comments Implemented in Protel for Windows Advanced PCB version 1.5 or later.

Procedure To cross probe a net in the PCB layout:

          1. Open the Protel for Windows PCB file that corresponds to the active schematic sheet 
file;

          2. Chosse Cross Probe Net from the Edit menu. You will be prompted to select the net 
label or power port to cross probe;

          3. Position the cursor directly over the power port or net label you wish to cross probe 
and click LEFT MOUSE.

          The focus will move to the PCB window and the corresponding net will be highlighted.

See also
Cross Probe Part on PCB
Cross Probe Pin on PCB



Drag Selection

Summary Move selected object(s) and drag connected objects.

To Launch Alt E M R

Purpose The Move Drag Selection command is used to reposition a selection containing one or 
more objects as a single entity, and to drag any electrically connected objects.

Outcome When selected objects are moved, the electrically connected wires and/or buses stretch 
to move with the selection.

Comments While dragging wires the wire placement mode can be changed interactively by using 
the SPACEBAR. Objects can also be restricted to only move along the x-axis by holding 
down the SHIFT+CTRL keys, or along the y-axis by holding down the SHIFT key. To rotate 
the object press the CTRL+SPACEBAR keys.

Procedure To move selected objects and drag connected objects in an open worksheet:

          1. Make sure that the current selection includes only those objects you wish to move.

          You can use Edit De-Select to de-select objects that are not to be moved and then use 
Edit Select to select the objects that will be moved. You can also use the shortcut SHIFT +
Click LEFT MOUSE to add objects to the current selection or to de-select any selected 
objects.

          2. Choose Move and then Drag Selection from the Edit menu.

          3. You will be prompted to move the selected objects, click ENTER or LEFT MOUSE 
anywhere on the worksheet.

          If the Object's Electrical Hot Spot option is enabled in the Preferences dialog box the 
cursor will jump to the Electrical Hot Spot of the closest object, otherwise the cursor will 
remain relative to the selected objects and the original chosen cursor position. 4. 
Position the selection in the worksheet and click ENTER or LEFT MOUSE.

See also
Drag
Move Selection



Help

Summary Information on new features.

To Launch  H N

Purpose Contains information on new features that have been added to Advanced Schematic 
since publication of the i User Guide and reference manuals.

Outcome Once the Help New Features command is selected the Advanced Schematic on-line help
system is loaded and displays a list of new features.

Procedure To display information about new features:

          1. Choose New features from the Help menu.

See also
New Features for Release 2.00



File Close Project

Summary Close all open schematic windows.

Purpose The Close Project command is used to close all document windows and icons in the 
current project.

Outcome All sheets in the current (active) project are closed.

Procedure To close all sheets in the current (active) project:

          1. Choose Close Project from the File menu;

          You will be prompted "Changed. Save before Close?"

          2. Click OK to close all sheets in the current project.

          Sheets outside the project will remain opened.

See also
Window Close All



Run PCB Editor

Summary Switch to the PCB Layout Editor.

To Launch  T P    -    

Purpose This command is used to launch or swithch to the PCB Editor application directly 
from Advanced Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome Launches the specified PCB Layout Editor.
Comments User can specify the PCB Layout Editor application under the Tools-Setup 

command.
          If the PCB Layout Editor has been previously loaded then the focus will switch to the 

PCB application window, otherwise the PCB Editor will be launched, automatically 
loading previously opened PCB files.

Procedure Choose the PCB Layout Editor command from the Tools menu.

See also
Setup Run Options



Edit Object From Browser

Summary Changes the attributes associated with an object from the Browser.

Purpose The Edit Object From Browser command is used to change the current object from the 
Browser. The command    is represented by the EDIT button on the Browser.

Outcome The object's attributes will be updated, all text and graphical changes such as object 
colors will be updated on the sheet.

Procedure To edit an object's attributes, first make sure that the object you wish to edit is highlighted
in the Browser. 

          1. Press the Edit button on the Browser.

          2. Type the new attributes into the dialog box and press ENTER or click OK.

See also
Part



View Read Only Part Fields

Summary View read-only fields for a part..

Purpose The View Read Only Part Fields command is used to view the read-only fields of a part 
on the wroksheet. The command    is represented by the VIEW LIBRARY FIELDS button in 
the Part dialog box.

Comments The fields in the Read Only Part Fields dialog box cannot be changed.

Procedure To view the read-only fields of a part;

          1. Edit a Part

          2. Press the Global button in the Part dialog box and Choose the View Library Fields 
Button.

          3. The Read Only Part Fields dialog box opens displaying field information for the Library
Reference, Designator, Part Type, Part Description and Library Part Field 1 thru to 
Library Part Field 8.

          This command can also be assigned to a hot key by using the Hot Keys command from 
the Options menu. To open the Read Only Part Fields dialog box with a hot key, make 
sure the object is focused and then activate the shortcut key.

See also
Part



Toggle Electrical Grid

Summary Turn the electrical grid on or off.

To Launch Alt O E

Purpose The Toggle Electrical Grid command is used to turn the cursor Electrical grid on or off. 
The Electrical grid defines an array of points in the workspace that restricts cursor 
movement and the placement of objects. Turning the Electrical grid off allows you to 
place objects at any location on the worksheet without any restrictions.

Outcome Once the Electrical Grid command has been chosen the cursor snap grid will toggle on 
or off depending on its previous state.

Procedure To turn the electrical grid on or off:

          1. Choose Electrical Grid from the Options menu.

See also
Sheet Options



Toggle Command Status Bar

Summary Turn the Command Status Line on or off.

Purpose The Toggle Command Status Bar command is used to turn the lower half of the Status 
line (which displays the current command status) on or off at the bottom of the Advanced
Schematic application window. Turning off the process status line shows more screen 
region.

Outcome Choosing Command Status Bar from the Options menu will turn the Command Status 
line on or off.    The Status line must be enabled for this command to be effective.

Comments The Command status line displays the name of the currently running command.

Procedure To turn the Command Status line on or off:

          1. Choose Command Status Bar from the Options menu.



Find Next Text

Summary Search for and jump to the next matching text string.

To Launch  F3    -    Alt E X

Purpose The Find Next Text command allows you to conveniently locate specific text that has 
been placed on any worksheet without having to zoom, pan or scroll through multiple 
screens.

Comments You can also Find and Replace text.

Procedure To find the next occurence of a string:

          1. Choose Find Next from the Edit menu.

See also
Find Text
Find and Replace Text



Find and Replace Text

Summary Search for and replace text strings.

To Launch  Ctrl G    -    Alt E A

Purpose The Search for and replace text command allows you to conveniently locate and replace 
specific text that has been placed on any worksheet without having to zoom, pan or 
scroll through multiple screens.

Outcome Matching text will be replaced by the new replacement text.

Comments The wildcard character "*" can be used to extend the definition of 

          target strings. For example, S* will limit the fields to strings 

          beginning with S, etc. Wildcards are case in-sensitive. 

          Braces "" and "" can also be used used to define the rules for 

          text replacement. Defining the change follows this syntax: oldtext=newtext. This means 
change portion of the string "oldtext" to "newtext". You can use multiple sets of brackets 
to define complex replacements. In this case the leftmost replacement is made, then the 
next on, etc. Although this is very powerful, you must take care, because the first change
can effect subsequent replacements, possibly 

          generating an unexpected result. Any mistakes can be corrected with the Undo 
command, however.

          The find and replace text command can find and replace text 

          anywhere on a sheet or across a multi-sheet project. Extends across all objects with 
visible text, including Part Fields and Text Frames.

Procedure To search and replace text:

          1. Choose Replace Text from the Edit menu. The Text Find And Replace dialog box 
opens.

          2. Type the Text To Find string.

          3. In the New Text field, type the replacement text.

          4. Choose the Scope for the change. Sheet Scope, Current Document or All documents. 
Selection, Selected Objects, Deselected Objects, All Objects.

          5. Choose any other Options. Case Sensitive, Prompt On Replace, Restrict To Net 
Identifiers (net labels, power ports, ports and sheet 

          entries).

          6. Click OK to perform the text replacement.



See also
Find Text
Find Next Text



Update Current Template

Summary Update the current sheet from its template file..

To Launch Alt O D

Purpose The Update Current Template command is used to update the current sheets template 
information from its template file.

Outcome Any changes that have been made to the current sheet's template file    will be reflected 
in the current sheet.

Comments The current contents of the sheets template will be deleted and new contents will be 
loaded. If the template file no longer exists in the original template path then the system 
path is checked if the template filename still cannot be found then there would be no 
action taken. Settings in the Options Sheet dialog box will be changed along with the 
Organization Name and Address information that is contained in the Document Info 
dialog box.    Sheet Number, Sheet Total, Document Title, Document Number and 
Document Revision fields are not changed.

Procedure To update the current sheet's template

          1. Choose Update Current Template from the Options menu.

          2. A message box prompting to update template for all currently open sheets will be 
displayed. Choose YES to update the templates of all the sheets that are currently open, 
Choose NO to update only this sheet or CANCEL to exit from this command without any 
changes.

See also
Set Template File Name
Remove Template
Preferences



Convert Complex To Simple Hierarchy

Summary Convert Complex Hierachical Design To Simple Hierarchical Design.

To Launch Alt F H X

Purpose A simple hierachical design is one where each sheet is only used once in the design. A 
Complex hierarchy is one where a sheet can be used more than once. This makes the 
design much simpler, but when transfering to a physical design, such as a PCB, each 
part and net must be unique.

          This command will convert a complex hierarchy to a simple hierarchy by duplicating the 
sheets that are used more than once.

Outcome New sheet windows will be created for the duplicated sheets

Procedure 1. Load the whole project to be converted

          2. Set the focus on any window in the project to be converted

          3. Choose Hierarchy from the File menu and then choose Complex To Simple.



Cross Probe Pin on PCB

Summary Select pin to cross probe to PCB.

To Launch Alt E P

Purpose Cross probing parts allows user to jump directly to a specified pin in Protel for Windows 
PCB applications.

Outcome When the Cross Probe Pin command is chosen, the PCB layout becomes the focus 
window and the selected pin in the PCB layout is displayed in the center of the window.

Comments Implemented in Protel for Windows Advanced PCB version 2.0 or later

Procedure To cross probe a pin in the PCB layout:

          1. Open the Protel for Windows PCB file that corresponds to the active schematic sheet 
file;

          2. Chosse Cross Probe Pin from the Edit menu. You will be prompted to select a pin;

          3. Position the cursor directly over the pin you wish to cross probe and click LEFT MOUSE.

          The focus will move to the PCB window and the corresponding pin will displayed in the 
center of the window.

See also
Cross Probe Net On PCB
Cross Probe Part on PCB



Change Object Graphically or Move

Summary Select and change objects on schematic sheet.

Purpose This command is used to set the focus on an object. If the object already has the focus 
then this command interactively changes the object by physically moving the position of 
the objects handles.

Comments The Change Single Object Graphically or Move command can only be accessed using 
the mouse. This can be changed using setup hotkeys command. You can use the Edit 
Undo command (shortcut: ALT+BACKSPACE) to restore the edited objects.

          While moving wires or busses pressing INSERT or DELETE) will add or remove a 
vertex/break in the wire or bus at the current cursor location.

Procedure To move an object;

          1. Move the cursor over the object to be graphically edited and click and hold LEFT 
MOUSE. 

          If the cursor is over a handle then the handle can be move, otherwise the whole object 
will be moved.

          2. Use the mouse to move the object. 

          While editing or moving an object you can press the F1 key at anytime to open the 
Graphical Editing Hotkey List dialog box. This dialog box lists all the hot key commands 
that can be used while editing or moving the object.

See also
Change



Run PLD/FPGA Compile

Summary Launch the PLD Compiler spcified in the Tools-Options Dialog.

To Launch  T F

Purpose This command is used to launch the PLD/FPGA Compiler directly from Advanced 
Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome Launches the specified PCB Layout Editor.

Comments User can specify the PLD/FPGA Compiler application under the Tools-Setup command.

Procedure Choose the PCB Layout Editor command from the Tools menu.

See also
Setup Run Options



Popup Tools Menu

Summary Popup the Tools menu.

Purpose The Popup Tools Menu command is used to directly access the Tools menu at the 
current cursor position.

Procedure To popup the Tools menu at the current cursor position.

          1. Press the T keyboard hot key. (Default hot key assignment)

          You can change the default hot key by using the Options Hot Keys command.

See also
Hot Keys
Setup Run Options



Run Digital Simulator

Summary Launch the Digital Simulator spcified in the Tools-Options Dialog.

To Launch  T D

Purpose This command is used to launch the Digital Simulator directly from Advanced Schematic.
Tools menu commands provide convenient ways to launch frequently used applications 
and utilities.

Outcome Launches the specified Digital Simulator.

Comments User can specify the Digital Simulator application under the Tools-Setup command.

Procedure Choose the Digital Simulator command from the Tools menu.

See also
Setup Run Options



Run Analog Simulator

Summary Launch the Analog Simulator spcified in the Tools-Options Dialog.

To Launch  T A

Purpose This command is used to launch the Analog Simulator directly from Advanced 
Schematic. Tools menu commands provide convenient ways to launch frequently used 
applications and utilities.

Outcome Launches the specified Analog Simulator.

Comments User can specify the Analog Simulator application under the Tools-Setup command.

Procedure Choose the Analog Simulator command from the Tools menu.

See also
Setup Run Options



Run Mixed Signal Simulator

Summary Launch the Mixed-Signal Simulator spcified in the Tools-Options Dialog.

To Launch  T X

Purpose This command is used to launch the Mixed Signal Simulator utility directly from 
Advanced Schematic. Tools menu commands provide convenient ways to launch 
frequently used applications and utilities.

Outcome Launches the specified Mixed Signal Simulator.

Comments User can specify the Mixed Signal Simulator application under the Tools-Setup 
command.

Procedure Choose the Mixed Signal Simulator command from the Tools menu.

See also
Setup Run Options



Set Template File Name

Summary Change the current template to a different template file.

To Launch Alt O N

Purpose The Set Template File Name command is used to change the current template of a sheet
to a new template file name. A template is a special graphical entity that holds user-
defined sheet size, border and title block descriptions. Users can create custom sheet 
templates and apply these templates to schematic sheets at any time, replacing the 
system's standard sheet definitions.    They can be customized for specific organizations 
or purposes.

Outcome Any changes that have been made to the current sheet's template file    will be reflected 
in the current sheet.

Comments The default file extension is .DOT. Sheet templates can be created from any schematic 
sheet at any time. The current contents of the sheets template will be removed and 
changed to the contents of the specified template file. Settings in the Options Sheet 
dialog box will be changed along with the Organization Name and Address information 
that is contained in the Document Info dialog box.    Sheet Number, Sheet Total, 
Document Title, Document Number and Document Revision fields are not changed.

Procedure To change the current template.

          1. Choose Set Template File Name from the options menu.

          2. Type the filename (include the full path, if different from the path listed after Directory)

          3. Click OK to open the file.

          You can also double-click on the desired filename in the Files window, if any. To change 
directories, click under any of the options listed in the Directories window.

See also
Remove Template
Update Current Template
Preferences



Align Objects

Summary Align selected objects using alignment dialog box.

To Launch Alt E G A

Purpose The Align Objects command is used to align a group of selected objects on both x and y 
axis at the same time. Objects can be aligned by their left/right/top/bottom sides, center 
alignment, distributed horizontally or vertically or moved to the placement grid. You can 
align objects on one axis, by choosing the other Align menu commands.

                            

Outcome The selection will be aligned according to the chosen options.

Procedure To align selected objects using the Align Objects dialog box:

          1. Add all items to be aligned to the current selection, making 

          sure that only items to be aligned are selected. You can use 

          the Edit-DeSelect-All command (shortcut: x, a) to clear the 

          current selection.

          2. Choose Align from the Edit menu and then choose the Align command. 

          3. Select the desired horizontal and/or vertical alignment combination. You can also 
choose the Align To Grid option to constrain alignment to the nearest grid point.

          4. Click OK to close the dialog box and align the selection.

See also
Distribute equally along vertical axis
Distribute equally along horizontal axis
Center objects around vertical axis
Center objects around horizontal axis
Align objects on bottom
Align objects on top
Align objects on right
Align objects on left



Align objects on left

Summary Align selected objects on the left side of their bounding rectangle.

To Launch  Ctrl L    -    Alt E G L

Purpose The Align objects on left command is used to align a group of selected objects along the 
left side of their bounding rectangle.

Outcome All selected objects will be aligned on the left edge of their bounding rectangle.

Procedure To align objects using the Align Left command:

          1. Add all items to be aligned to the current selection, making 

          sure that only items to be aligned are selected. You can use 

          the Edit-DeSelect-All command (shortcut: x, a) to clear the 

          current selection.

          2. Choose Align from the Edit menu and then choose the Align Left command.

See also
Distribute equally along vertical axis
Distribute equally along horizontal axis
Center objects around vertical axis
Center objects around horizontal axis
Align objects on bottom
Align objects on top
Align objects on right



Align objects on right

Summary Align selected objects on the right side of their bounding rectangle.

To Launch  Ctrl R    -    Alt E G R

Purpose The Align objects on right command is used to align a group of selected objects along 
the right side of their bounding rectangle.

Outcome All selected objects will be aligned on the right edge of their bounding rectangle.

Procedure To align objects using the Align Right command:

          1. Add all items to be aligned to the current selection, making 

          sure that only items to be aligned are selected. You can use 

          the Edit-DeSelect-All command (shortcut: x, a) to clear the 

          current selection.

          2. Choose Align from the Edit menu and then choose the Align Right command.

See also
Distribute equally along vertical axis
Distribute equally along horizontal axis
Center objects around vertical axis
Center objects around horizontal axis
Align objects on bottom
Align objects on top
Align objects on left



Center objects around horizontal axis

Summary Center objects around the vertical center line of the bounding rectangle.

To Launch  Ctrl H    -    Alt E G C

Purpose The Center objects around horizontal axis command is used to align a group of selected 
objects along their horizontal center line.

Outcome All selected objects will be aligned along their horizontal center line.

Procedure To align objects using the Center Horizontal command:

          1. Add all items to be aligned to the current selection, making 

          sure that only items to be aligned are selected. You can use 

          the Edit-DeSelect-All command (shortcut: x, a) to clear the 

          current selection.

          2. Choose Align from the Edit menu and then choose the Center Horizontal command.

See also
Distribute equally along vertical axis
Distribute equally along horizontal axis
Center objects around vertical axis
Align objects on bottom
Align objects on top
Align objects on right
Align objects on left



Distribute equally along horizontal axis

Summary Distribute equally the selected objects along the horizontal axis.

To Launch  Ctrl Shift H    -    Alt E G D

Purpose This command is used to space a group of selected objects equally along the horizontal 
axis.

Outcome All selected objects will be distributed equally along the horizontal axis.

Procedure To distribute objects equally along the horizontal axis:

          1. Add all items to be distributed to the current selection, making 

          sure that only items to be distributed horizontally are selected. You can use the Edit-
DeSelect-All command (shortcut: x, a) to clear the 

          current selection.

          2. Choose Align from the Edit menu and then choose the Distribute Horizontally 
command.

See also
Distribute equally along vertical axis
Center objects around vertical axis
Center objects around horizontal axis
Align objects on bottom
Align objects on top
Align objects on right
Align objects on left



Align objects on top

Summary Align selected objects on the top side of their bounding rectangle.

To Launch  Ctrl T    -    Alt E G T

Purpose The Align objects on top command is used to align a group of selected objects along the 
top edge of their bounding rectangle.

Outcome All selected objects will be aligned on the top edge of their bounding rectangle.

Procedure To align objects using the Align Top command:

          1. Add all items to be aligned to the current selection, making 

          sure that only items to be aligned are selected. You can use 

          the Edit-DeSelect-All command (shortcut: x, a) to clear the 

          current selection.

          2. Choose Align from the Edit menu and then choose the Align Left command.

See also
Distribute equally along vertical axis
Distribute equally along horizontal axis
Center objects around vertical axis
Center objects around horizontal axis
Align objects on bottom
Align objects on right
Align objects on left



Align objects on bottom

Summary Align selected objects on the bottom side of their bounding rectangle.

To Launch  Ctrl B    -    Alt E G B

Purpose The Align objects on bottom command is used to align a group of selected objects along 
the bottom edge of their bounding rectangle.

Outcome All selected objects will be aligned on the bottom edge of their bounding rectangle.

Procedure To align objects using the Align Bottom command:

          1. Add all items to be aligned to the current selection, making 

          sure that only items to be aligned are selected. You can use 

          the Edit-DeSelect-All command (shortcut: x, a) to clear the 

          current selection.

          2. Choose Align from the Edit menu and then choose the Align Bottom command.

See also
Distribute equally along vertical axis
Distribute equally along horizontal axis
Center objects around vertical axis
Center objects around horizontal axis
Align objects on top
Align objects on right
Align objects on left



Center objects around vertical axis

Summary Center objects around the vertical center line of the bounding rectangle.

To Launch  Ctrl V    -    Alt E G V

Purpose The Center objects around vertical axis command is used to align a group of selected 
objects along their vertical center line.

Outcome All selected objects will be aligned along their vertical center line.

Procedure To align objects using the Center Vertical command:

          1. Add all items to be aligned to the current selection, making 

          sure that only items to be aligned are selected. You can use 

          the Edit-DeSelect-All command (shortcut: x, a) to clear the 

          current selection.

          2. Choose Align from the Edit menu and then choose the Center Vertical command.

See also
Distribute equally along vertical axis
Distribute equally along horizontal axis
Center objects around horizontal axis
Align objects on bottom
Align objects on top
Align objects on right
Align objects on left



Distribute equally along vertical axis

Summary Distribute equally the selected objects along the vertical axis.

To Launch  Ctrl Shift V    -    Alt E G I

Purpose This command is used to space a group of selected objects equally along the vertical 
axis.

Outcome All selected objects will be distributed equally along the vertical axis.

Procedure To distribute objects equally along the vertical axis:

          1. Add all items to be distributed to the current selection, making 

          sure that only items to be distributed vertically are selected. You can use the Edit-
DeSelect-All command (shortcut: x, a) to clear the 

          current selection.

          2. Choose Align from the Edit menu and then choose the Distribute Verticallly command.

See also
Distribute equally along horizontal axis
Center objects around vertical axis
Center objects around horizontal axis
Align objects on bottom
Align objects on top
Align objects on right
Align objects on left



Open Environment Configuration File

Summary Open and load an environment configuration file.

To Launch  O O

Purpose This command is used to open and load an environment configuration file. This includes 
all options, preferences and the current set of open files.

Outcome Once an environment configuration file has been selected, the current environment 
settings will be cleared and the new settings will be loaded, this includes all options, 
preferences and any files that were open when the original environment file was saved.

Comments All current settings will be lost and all files will be closed. Advanced Schematic will 
prompt you to save any open files first.

Procedure To open a previously saved environment configuration file:

          1. Choose Open from the Options menu.

          2. Type the filename (include the full path, if different from the path listed after Directory)

          3. Click OK to open the file.

          You can also double-click on the desired filename in the Files window, if any. To change 
directories, click under any of the options listed in the Directories window.

See also
Save Environment Configuration File



Save Environment Configuration File

Summary Save current environment configuration to a file.

To Launch  O A

Purpose This command is used to save the current environment configuration to a file. This 
includes all options, preferences and the list of all currently open files.

Outcome When you select the Options Save As command, the Save Environment File As dialog 
box will open. Once you click OK the file will be saved to the new file name and/or 
directory that you specified.

Procedure To save the current environment configuration to a new path or file name.

          1. Choose Save As from the Options menu.

          2. Type a new file name for the environment configuration. 

          3. Click OK to save the file.

          To change directories, click under any of the options listed in the Directories window.

See also
Open Environment Configuration File



Setup Autopan

Summary Setup Autopan options.

To Launch Alt O U

Purpose This command is used to configure the effect of Autopanning aroung the screen.

Outcome Opens the Setup Autopan dialog box, and allows customization of autopanning around 
the screen.

Comments When the Options Auto Pan feature is enabled, your 

          view of the current window will automatically pan up-down-left-

          right as you place, move or draw objects in the sheet. Panning 

          takes place when the cursor reaches the edge of the display when 

          placing, moving or re-sizing objects.

Procedure To change the autopan settings:

          1. Choose Auto-Pan from the Options menu

          2. The Setup Autopan dialog box will open.

          Three options can be set within this dialog box;

          Style - while autopanning the cursor can jump by a pre-defined step size, a full screen at
a time with the cursor re-centering in the middle of the screen or can be disabled.

          Step Size - distance the cursor will jump while autopanning, the autopan Style must be 
set to Fixed Size Jump.    

          Shift Step Size - distance the cursor will jump while autopanning and holding down the 
SHIFT key, the autopan Style must be set to Fixed Size Jump.



Remove Template

Summary Remove any template information from the current sheet.

To Launch Alt O L

Purpose The Remove Template command is used to remove template information from the 
current sheet.

Procedure To remove graphical template information from the current sheet.

          1. Choose Remove Template from the Options menu.

          2. A message box prompting to remove templates from all currently open sheets will be 
displayed. Choose YES to remove the templates of all the sheets that are currently open,
Choose NO to remove the template for the active sheet only or CANCEL to exit from this
command without any changes.

See also
Set Template File Name
Update Current Template
Preferences



Popup Alignment Menu

Summary Popup the Alignment menu.

Purpose The Popup Alignment Menu command is used to directly access the Align menu at the 
current cursor position.

Comments You can change the default hot key by using the Options Hot Keys command.

Procedure To popup the Alignment menu at the current cursor position.

          1. Press the A keyboard hot key. (Default hot key assignment)

See also
Align Objects
Hot Keys



Memory Monitor Setup

Summary Setup low memory/resources warning thresholds..

To Launch  O Y

Purpose This command is used to monitor the system memory and system resources.

          In the Memory Monitor dialog box the user can define minimum levels for system 
memory and system resources. These thresholds are used by the application to 
determine when a warning message is to be issued.

Outcome The following are options that can be set within the Memory Monitor dialog box.

          Frequency - specifies when memory is checked. By default it is checked after every 
16KB of memory is allocated.

          Memory Warning - enables/disables the warning and specifies the memory threshold. 
By default the warning threshold is 2000KB.

          System Resources Warning - enables/disables the warning and specifies the system 
resource threshold. By default the warning threshold is 30%.

Comments When either of these two options are enabled and the available memory or system 
resources fall below the defined thresholds a warning dialog box will open stating the 
problem and appropriate actions.

          Note: When the system resources fall below 10% Windows can behave unexpectedly, 
therefore it is not recommended to set the resource threshold warning lower than 10%.

Procedure To define the warning thresholds for system memory and system resources.

          1. Choose Memory Monitor from the Options menu.

          2. Choose or type in new memory monitor settings.

          3. Click OK to accept the new settings.

See also
Popup Info Menu



Find Component in Library

Summary Search for a component in a specified path..

To Launch Alt L F

Purpose The Find Component in Library command is used to search for a component that is in a 
specified drive/path, in the current listed libraries, or on all drives across a network. The 
component can be found by library reference name and/or by component description.

Outcome As components are found that match the search criteria, the component libraries are 
listed in the Found Libraries list box.

Comments To display the found components click on the library name in the Found Libraries list box,
all the found component instances in that library will be listed in the Components list box.
Clicking on the library name will display the library description and file details at the 
bottom of this dialog box, clicking on the component name will display the component 
description. The library and component descriptions are specified in the Library Editor. 
Press the Add To Library List button to automatically add the library to the Library File 
List.

          Note: This command only searches for components in Advanced Schematic binary 
libraries. The time to search for a component by Description is considerably longer than 
searching by Library Reference.

Procedure To find a component in an Advanced Schematic binary library:

          1. Choose Find Component from the Library menu.

          2. The Find Component dialog box will open.

          3. Type in the library reference name and/or component description    into the Find 
Component fields. You can use wildcards such as * or ? to define the search criteria, for 
example, you can type in *74LS* to find all the components that have "74LS" in their 
name.

          4. Specify the search criteria. The search scope can restrict the find to a specified 
drive/path, to the current libraries listed in the Library Add/Remove dialog box, or can 
search all the drives across a network or multiple networks.

          5. Press the Find button to start the search. You can abort the search at anytime by 
pressing the Stop button.

          You can also activate the Find Component dialog box from the Browser by clicking the 
Find button.



Data Primitives

Annotation
Arc
Bezier
Bus
Bus Entry
Ellipse
Elliptical Arc
Error Marker
Graphic
Junction
Line
Net Label
No ERC
PCB Layout
Part
Part Description
Part Designator
Part Type
Pie Chart
Polygon
Port
Power Port
Probe
Rectangle
Round Rectangle
Sheet Entry
Sheet Part File Name
Sheet Symbol
Sheet Symbol File Name
Sheet Symbol Name
Stimulus
Test Vector Index
Text Frame
Wire



Rectangle

Overview Rectangles are filled or unfilled graphic elements placed on sheets, used for adding 
reference information to a worksheet, such as building graphical symbols, custom sheet 
borders, title blocks, etc..

Fields
X1-Location The left hand edge reference point coordinate of the rectangle, along the x-axis.
Y1-Location The bottom edge reference point coordinate of the rectangle, along the y-axis.

X2-Location The right hand edge reference point coordinate of the rectangle, along the x-axis.

Y2-Location The top edge reference point coordinate of the rectangle, along the y-axis.

Border Width Specifies the border outline thickness of rectangles. There are four selectable border 
widths; smallest, small, medium and large.

Border Color The surrounding border of Rectangles can be assigned a color. To assign a new color to 
the border, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Fill Color The inside area of Rectangles can be assigned a color. To assign a new color to the 
inside area, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 



supports.

Selection Toggle the selection state of Rectangles by turning this option on or off. If this option is 
on, the Rectangle will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Draw Solid Advanced Schematic allows you to turn the inside area color of Rectangles on or off. If 
this option is on, the inside area of the Rectangle will be displayed in the fill color. If this 
option is off, then only the Rectangles border will be shown.

Comments Rectangles are graphical objects only, they have no logical or physical connectivity 
features.

See also
Place Rectangles
Round Rectangle



Bus Entry

Overview Bus Entry objects are special graphical objects that are used to connect wires to a bus 
line. Using wires to connect to a bus can be limiting, especially when connecting different
signals to the opposite sides of the bus line, thus causing an unwanted connection.

Fields
X1-Location The starting reference point coordinate of the bus entry, along the x-axis.
Y1-Location The starting reference point coordinate of the bus entry, along the y-axis.

X2-Location The ending reference point coordinate of the bus entry, along the x-axis.

Y2-Location The ending reference point coordinate of the bus entry, along the y-axis.

Line Width Specifies the line thickness of individual bus entry segments. There are four selectable 
line widths; smallest, small, medium and large.

Color Bus entry symbols can be assigned a color. To assign a new color to the bus entry    
segment, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Selection Toggle the selection state of bus entry symbols by turning this option on or off. If this 
option is on, the bus entry will be outlined in the selection color defined in the Options 



Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

See also
Place Bus Entry
Bus



Arc

Overview Arcs are circular line segments, used for adding reference information to a sheet, such 
as building graphical symbols, custom sheet borders, or title blocks.

Fields
X-Location The center point coordinate of an arc, along the x-axis.
Y-Location The center point coordinate of an arc, along the y-axis.
Radius Advanced Schematic allows you to change the radius of Arcs. The radius can be any 

integer (whole number) value. A value of 1 = 10mil = .254mm.
Line Width Specifies the line thickness of Arc segments. There are four selectable Arc widths; 

smallest, small, medium and large.

Start Angle Advanced Schematic allows you to change the start angle of an Arc. The start angle can 
be any degree from 1 to 360, (Real number).

End Angle Advanced Schematic allows you to change the end angle of an Arc. The start angle can 
be any degree from 1 to 360, (Real number).

Color Arcs can be assigned a color. To assign a new color to the Arc, click in the color box to 
open the Color Selector dialog box. Advanced Schematic will display all the available 
colors that your graphics card and monitor supports.

Selection Toggle the selection state of Arcs by turning this option on or off. If this option is on, the 



Arcs will be outlined in the selection color defined in the Options Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Comments Arcs have no logical or physical connectivity features. They cannot be used with or in 
place of wires.

See also
Place Arcs
Elliptical Arc



Elliptical Arc

Overview Elliptical Arcs are graphical objects with a user-defined line width and start/end 
coordinates. Elliptical Arcs are used for adding reference information to a worksheet, 
such as building graphical symbols, custom sheet borders, or title blocks.

Fields
X-Location The reference point coordinate of the elliptical arc, along the x-axis.
Y-Location The reference point coordinate of the elliptical arc, along the y-axis.

X-Radius Advanced Schematic allows you to change the horizontal width of Elliptical Arcs. The x-
radius can be any integer (whole number) value. A value of 1 = 10mil = .254mm.

Y-Radius Advanced Schematic allows you to change the vertical height of Elliptical Arcs. The y-
radius can be any integer (whole number) value. A value of 1 = 10mil = .254mm.

Line Width Specifies the line thickness of elliptical arc segments. There are four selectable elliptical 
arc widths; smallest, small, medium and large.

Start Angle Advanced Schematic allows you to change the start angle of Elliptical Arcs. The start 
angle can be any degree from 1 to 360, (Real number).

End Angle Advanced Schematic allows you to change the end angle of Elliptical Arcs. The start 
angle can be any degree from 1 to 360, (Real number).

Color Elliptical Arcs can be assigned a color. To assign a new color to the Elliptical Arc, click in 



the color box to open the Color Selector dialog box. Advanced Schematic will display all 
the available colors that your graphics card and monitor supports.

Selection Toggle the selection state of Elliptical Arcs by turning this option on or off. If this option is 
on, the Elliptical Arc will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

See also
Place Elliptical Arcs



Round Rectangle

Overview Rounded Rectangles are graphical objects with a user-defined line width, start/end 
coordinates, and fill color.

Fields
X1-Location The left hand edge reference point coordinate of the rounded rectangle, along 

the x-axis.
Y1-Location The bottom edge reference point coordinate of the rounded rectangle, along the 

y-axis.
X2-Location The right hand edge reference point coordinate of the rounded rectangle, along 

the x-axis.
Y2-Location The top edge reference point coordinate of the rounded rectangle, along the y-axis.

          Advanced Schematic allows you to change the horizontal corner radius of rounded 
rectangles. The corner radius can be any integer (whole number) value. A value of 1 = 
10mil = .254mm.

          Advanced Schematic allows you to change the vertical corner radius of rounded 



rectangles. The corner radius can be any integer (whole number) value. A value of 1 = 
10mil = .254mm.

Border Width Specifies the border outline thickness of Rounded Rectangles. There are four selectable 
border widths; smallest, small, medium and large.

Border Color The surrounding border of Rounded Rectangles can be assigned a color. To assign a 
new color to the border, click in the color box to open the Color Selector dialog box. 
Advanced Schematic will display all the available colors that your graphics card and 
monitor supports.

Fill Color The inside area of Rounded Rectangles can be assigned a color. To assign a new color 
to the inside area, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Selection Toggle the selection state of Rounded Rectangles by turning this option on or off. If this 
option is on, the Rounded Rectangle will be outlined in the selection color defined in the 
Options Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Draw Solid Advanced Schematic allows you to turn the inside area color of Round Rectangles on or 
off. If this option is on, the inside area of the Rounded Rectangle will be displayed in the 
fill color. If this option is off, then only the Rounded Rectangles border will be shown.

See also
Place Round Rectangle



Graphic

Overview Graphic images are special graphical objects, used for adding reference information to a 
worksheet, such as company logos, mechanical and electrical symbols or customized 
images.

Fields
File Name The path and file name of the image file.
X1-Location The left hand edge reference point coordinate of the imported graphic image, 

along the x-axis.
Y1-Location The bottom edge reference point coordinate of the imported graphic image, along

the y-axis.
X2-Location The right hand edge reference point coordinate of the imported graphic image, along the 

x-axis.



Y2-Location The top edge reference point coordinate of the imported graphic image, along the y-axis.

Border Width Specifies the border outline thickness of imported graphic images. There are four 
selectable border widths; smallest, small, medium and large.

Border Color The surrounding border of imported graphic images can be assigned a color. To assign a
new color to the border, click in the color box to open the Color Selector dialog box. 
Advanced Schematic will display all the available colors that your graphics card and 
monitor supports.

Selection Toggle the selection state of imported graphic images by turning this option on or off. If 
this option is on, the graphic image will be outlined in the selection color defined in the 
Options Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Border On The surrounding border of imported graphic images can be toggled on or off. If this 
option is enabled, the border around the graphical image will be displayed in the border 
color. If this option is off, then only the graphic image will be shown.

X:Y Ratio 1:1 Graphical images may be re-sized by moving one of its handles, when this option is on, 
the image retains the original x and y aspect ratio.

Comments Advanced Schematic supports the import of the following image formats;

          BMP - All uncompressed Bit Map images. Windows device-independent Bit Map format, 
introduced with Windows 3.0 and increasingly supported by Windows applications.

          PCX - Paintbrush format, used in Windows Paintbrush and other paint programs and 
supported by many desktop publishing and graphics programs. Supported colors 
include, monochrome, 16 color, 256 color, 24-bit color.

          TIFF - Tag Image File Format, supported by many desktop publishing programs. 
Supported compression types, uncompressed, LZW, Packbits, Modified Huffman 
encoding, CCITT Group 3 1D, CCITT Group 3 2D, CCITT Group 4. Supported colors 
include, monochrome, 16 color, 256 color, 24-bit color

          GIF - All non-interlaced Graphic Image files.

          EPS - Encapsulated postscript files with and without display images. If the EPS file 
doesn't contain a TIFF or Windows Metafile display image then the filename of the EPS 
image will be displayed.

          WMF - Only Windows Metafiles which conform to the Aldus Placeable Metafile Format 
are supported. Most applications which export or import Metafiles support this format.

See also
Place Graphic



Pie Chart

Overview Pies are circular graphic objects with a user-defined line width, radius, starting angle and
ending angle. Pies are used for adding reference information to a worksheet, such as 
building graphical symbols, custom sheet borders, or title blocks.

Fields
X-Location The reference point coordinate of the Pie object, along the x-axis.
Y-Location The reference point coordinate of the Pie object along the y-axis.
Radius Advanced Schematic allows you to change the radius of Pie objects. The radius can be 

any integer (whole number) value. A value of 1 = 10mil = .254mm.

Start Angle Advanced Schematic allows you to change the start angle of Pie objects. The start angle
can be any degree from 1 to 360, (Real number).

End Angle Advanced Schematic allows you to change the end angle of Pie symbols. The end angle 
can be any degree from 1 to 360, (Real number).

Border Color The surrounding border of Pie objects can be assigned a color. To assign a new color to 



the border, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Fill Color The inside area of Pie objects can be assigned a color. To assign a new color to the 
inside area, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Draw Solid Advanced Schematic allows you to turn the inside area color of Pie objects on or off. If 
this option is on, the inside area of the Pie will be displayed in the fill color. If this option 
is off, then only the Pie objects border will be shown.

Selection Toggle the selection state of Pie objects by turning this option on or off. If this option is 
on, the Pie will be outlined in the selection color defined in the Options Preferences 
dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

See also
Place Pie Charts



Text Frame

Overview Text frames hold free text. Text frames are used to place detailed notes or descriptive 
text on the worksheet. Uses might include placing revision history, circuit and logic 
documentation or some other description on the sheet.

Fields



Text Text frames support up to 32000 characters of text. To add or change text to a text frame 
click the change button within the text frame dialog box.

X1-Location The left hand edge reference point coordinate of the text frame, along the x-axis.
Y1-Location The bottom edge reference point coordinate of the text frame, along the y-axis.

X2-Location The right hand edge reference point coordinate of the text frame, along the x-axis.

Y2-Location The top edge reference point coordinate of the text frame, along the y-axis.

Border Width Specifies the border outline thickness of Text Frames. There are four selectable border 
widths; smallest, small, medium and large.

Border Color The surrounding border of Text Frames can be assigned a color. To assign a new color 
to the border, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Fill Color The inside area of Text Frames can be assigned a color. To assign a new color to the 
inside area, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Text Color The text within text frames can be assigned a color. To assign a new color to the text, 
click in the color box to open the Color Selector dialog box. Advanced Schematic will 
display all the available colors that your graphics card and monitor supports.

Font Text Frames support text formatting, such as, True Type fonts, definable character sizes, 
italic, bold, underline, and strikeout styles.

Draw Solid Advanced Schematic allows you to turn the inside area color of Text Frames on or off. If 
this option is on, the inside area of the Text Frame will be displayed in the fill color. If this 
option is off, then only the Text Frames border (if enabled) and text within the border will 
be shown.

Show Border The surrounding border of Text Frames can be toggled on or off. If this option is enabled,
the border around the Text Frame will be displayed in the border color. If this option is off,
then only the text will be shown.

Alignment Text can be aligned within the Text Frame boundary. Three alignment options are 
provided, Center, Left and Right.

Word Wrap Enable this option to wrap text within the Text Frame boundary.

Clip To Area Enable this option to confine the text within the Text Frame boundary. When enabled, 
only the text that can fit within the defined text frame border will be displayed. When this 
option is turned off, the text will flow beyond the text frame and all text will be displayed.

Selection Toggle the selection state of Text Frames by turning this option on or off. If this option is 
on, the Text Frame will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.



Comments Text Frames support the cut, copy and paste commands for text editing. It is possible to 
copy text to the Windows clipboard from another application and then paste the text into 
the text editing window.

See also
Place Text Frame



Ellipse

Overview Ellipses are graphical objects with a user-defined line width, x and y radius, and fill color. 
Ellipses are used for adding reference information to a worksheet, such as building 
graphical symbols, custom sheet borders, or title blocks.

Fields
X-Location The reference point coordinate of an ellipse, along the x-axis.
Y-Location The reference point coordinate of the ellipse, along the y-axis.

X-Radius Advanced Schematic allows you to change the horizontal width of Ellipses. The x-radius 
can be any integer (whole number) value. A value of 1 = 10mil = .254mm.

Y-Radius Advanced Schematic allows you to change the vertical height of Sheet Symbols. The y-
radius can be any integer (whole number) value. A value of 1 = 10mil = .254mm.

Border Width Specifies the border outline thickness of Ellipses. There are four selectable border 
widths; smallest, small, medium and large.

Border Color The surrounding border of Ellipses can be assigned a color. To assign a new color to the 
border, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports.

Fill Color The inside area of Ellipses can be assigned a color. To assign a new color to the inside 



area, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports.

Draw Solid Advanced Schematic allows you to turn the inside area color of Ellipses on or off. If this 
option is on, the inside area of the Ellipse will be displayed in the fill color. If this option is
off, then only the Ellipses border will be shown.

Selection Toggle the selection state of Ellipses by turning this option on or off. If this option is on, 
the Ellipse will be outlined in the selection color defined in the Options Preferences 
dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

See also
Place Ellipses
Elliptical Arc



Junction

Overview Junctions are small circular objects used to logically join intersecting wires on the 
schematic.

Fields
X-Location The reference point coordinate of the junction, along the x-axis.
Y-Location The reference point coordinate of the junction, along the y-axis.
Size Specifies the size of junctions. There are four selectable junction sizes; smallest, small, 

medium and large.
Color Junctions can be assigned a color. To assign a new color to the Junction, click in the 

color box to open the Color Selector dialog box. Advanced Schematic will display all the 
available colors that your graphics card and monitor supports.

Selection Toggle the selection state of Junctions by turning this option on or off. If this option is on, 
the Junction will be outlined in the selection color defined in the Options Preferences 
dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Locked If checked, the auto-junction feature of Advanced Schematic will not delete the junction.

Comments On a worksheet, many wires and buses can either connect or cross. Junctions are 
placed on the worksheet to distinguish a connection from a cross-over. If you place a 



junction at any intersection of wires, they will be processed as a single net.

See also
Place Junctions



Polygon

Overview Polygons are graphical objects with a user-definable line width, vertex coordinates, and 
fill color. Each vertex of a polygon can be independently moved. Polygons are used for 
adding reference information to a worksheet, such as building graphical symbols, custom
sheet borders, or title blocks.

Fields
Border Width Specifies the border outline thickness of Polygons. There are four selectable 

border widths; smallest, small, medium and large.
Border Color The surrounding border of Polygons can be assigned a color. To assign a new color to 

the border, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Fill Color The inside area of Polygons can be assigned a color. To assign a new color to the inside 
area, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports.

Draw Solid Advanced Schematic allows you to turn the inside area color of Polygons on or off. If this
option is on, the inside area of the Polygon will be displayed in the fill color. If this option 
is off, then only the Polygons border will be shown.

Selection Toggle the selection state of Polygon by turning this option on or off. If this option is on, 
the Polygon will be outlined in the selection color defined in the Options Preferences 
dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 



by using the Edit Select and De-select commands to define a selection group.

See also
Place Polygons



Line

Overview Lines are graphical objects with any number of joined segments and a user defined 
width, start and end point, vertices and color. Each vertex of a polyline object can be 
independently moved. Lines are used for adding reference information to a worksheet, 
such as building graphical symbols, custom sheet borders, or title blocks.

Fields
Line Width Specifies the line thickness of Polyline segments. There are four selectable 

Polyline widths; smallest, small, medium and large.
Line Style Specifies the line display type of Polyline segments. There are three selectable Polyline 

styles; solid, dashed and dotted. The dashed and dotted styles only apply to 'smallest' 
width Polylines.

Color Polylines can be assigned a color. To assign a new color to the Polyline, click in the color
box to open the Color Selector dialog box. Advanced Schematic will display all the 
available colors that your graphics card and monitor supports.

Selection Toggle the selection state of Polylines by turning this option on or off. If this option is 
enabled, the Polyline will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Comments Lines are graphic objects only and do not support Advanced Schematics connectivity 
features.



See also
Place Lines



Wire

Overview Wires are straight line segments, which are placed on the worksheet to represent 
electrical connections.

Fields
Wire Width Specifies the line thickness of the wire segments. There are four selectable wire 

widths; smallest, small, medium and large.
Color Wire lines can be assigned a color. To assign a new color to the Wire line segments, click

in the color box to open the Color Selector dialog box. Advanced Schematic will display all the available 
colors that your graphics card and monitor supports.

Selection Toggle the selection state of Wires by turning this option on or off. If this option is on, the 
Wire will be outlined in the selection color defined in the Options Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Comments Wires are graphically similar to lines and polylines, but have logical and physical 
connectivity features.

See also
Place Bus
Place Bus Entry



Bus

Overview Buses are special graphical objects that represent a common pathway for multiple 
signals on a worksheet.

Fields
Bus Width Specifies the line thickness of bus segments. There are four selectable bus 

widths; smallest, small, medium and large.
Color Bus lines can be assigned a color. To assign a new color to the Bus line segment, click in 

the color box to open the Color Selector dialog box. Advanced Schematic will display all the available 
colors that your graphics card and monitor supports.

Selection Toggle the selection state of Buses by turning this option on or off. If this option is on, the
Buses will be outlined in the selection color defined in the Options Preferences dialog 
box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Comments A special graphical primitive, Bus Entry, is needed when connecting a wire to a bus.

See also
Place Wire
Bus Entry



Bezier

Overview Beziers are curved line segments, used for adding reference information to a worksheet, 
such as building graphical, mechanical or electrical symbols.

Fields
Curve Width Specifies the line thickness of the Bezier curves. There are four selectable line 

widths; smallest, small, medium and large.
Color Beziers can be assigned a color. To assign a new color to the lines and curves of the 

Bezier, click in the color box to open the Color Selector dialog box. Advanced Schematic will display all 
the available colors that your graphics card and monitor supports.

Selection Toggle the selection state of Bezier curves by turning this option on or off. If this option is
on, the Bezier curve will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and by 
using the Edit Select and De-select commands to define a selection group.

See also
Place Beziers



Annotation

Overview An annotation is a single line of text used to place notes or comments on the worksheet. 
Uses might include placing section headings, revision history, timing information or some
other description on the sheet.

Fields
Text Text up to 255 characters of text.
X-Location The reference point coordinate of the Annotation, along the x-axis.
Y-Location The reference point coordinate of the Annotation, along the y-axis.

Orientation Annotations can be rotated through 360 degrees using 90 degree increments. There are 
four selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. 
While moving an annotation, you can rotate it around the cursor by pressing the 
SPACEBAR.

Color Annotations can be assigned a color. To assign a new color to the Annotation, click in the
color box to open the Color Selector dialog box. Advanced Schematic will display all the 
available colors that your graphics card and monitor supports.

Font Annotations support text formatting, such as, True Type fonts, definable character sizes, 
italic, bold, underline, and strikeout styles.

Selection Toggle the selection state of Annotations by turning this option on or off. If this option is 
on, the Annotation will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

See also



Place Annotation
Text Frame



Net Label

Overview Net Labels assign a wire and its entire physical net to a specific net name. Net Labels 
are also used to connect signals (wires) together without actually physically connecting 
them. You can place Net Labels horizontally or vertically on a worksheet.

Fields
Net Net Labels support up to 255 characters of text. The label will be used as the identifier for

connecting to other signals in the worksheet or across multiple sheets in a project.
X-Location The reference point coordinate of the Net Label, along the x-axis.

          The reference point coordinate of the Annotation, along the x-axis.

Y-Location The reference point coordinate of the Net Label, along the y-axis.

          The reference point coordinate of the Annotation, along the y-axis.

Orientation Net labels can be rotated through 360 degrees using 90 degree increments. There are 
four selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. 
While moving a net label, you can rotate it around the cursor by pressing the SPACEBAR.

          Annotations can be rotated through 360 degrees using 90 degree increments. There are 
four selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. 
While moving an annotation, you can rotate it around the cursor by pressing the 
SPACEBAR.



Color Net Labels can be assigned a color. To assign a new color to the net name, click in the 
color box to open the Color Selector dialog box. Advanced Schematic will display all the 
available colors that your graphics card and monitor supports.

          Annotations can be assigned a color. To assign a new color to the Annotation, click in the
color box to open the Color Selector dialog box. Advanced Schematic will display all the 
available colors that your graphics card and monitor supports.

Font Net labels support text formatting, such as, True Type fonts, definable character sizes, 
italic, bold, underline, and strikeout styles.

          Annotations support text formatting, such as, True Type fonts, definable character sizes, 
italic, bold, underline, and strikeout styles.

Selection Toggle the selection state of Net Labels by turning this option on or off. If this option is 
on, the Net Label will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Text up to 255 characters of text.

          Toggle the selection state of Annotations by turning this option on or off. If this option is 
on, the Annotation will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Comments The Net Label must be placed directly on the wire or bus. The snap grid can be used to 
ensure that the label is in a legal position. All Net Labels with the same name are 
considered to be electrically connected and signals connected externally to other 
worksheets in a project may use Net Labels and/or Ports.

          An inversion bar may be placed over net label characters by typing a backslash \ after 
each character. For example, to place an inversion bar over the net label 'ENABLE', type
'E\N\A\B\L\\'. To place the inversion bar over the first two characters, type 'E\N\ABLE'.

See also
Place Net Label
Port



Sheet Part File Name

Overview Sheet parts represent another schematic worksheet, the Sheet Part Filename is the link 
to the schematic worksheet.

Fields
X-Location The reference point coordinate of the sheet part filename, along the x-axis.
Y-Location The reference point coordinate of the sheet part filename, along the y-axis.
Orientation Sheet part filenames can be rotated 360 degrees using 90 degree increments. 

There are four selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. While 
moving one of the fields, you can rotate it around the cursor by pressing the SPACEBAR.

Color Sheet part filenames can be assigned a color. To assign a new color to a sheet part 
filename, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Font Sheet part filenames support text formatting, such as, True Type fonts, definable 
character sizes, italic, bold, underline, and strikeout styles.

Selection Toggle the selection state of the Sheet part filename by turning this option on or off. If 
this option is on, the field will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 



SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Hide If this option is enabled, the Sheet part filename is hidden and is not displayed on the 
worksheet. By default this option is enabled.

Comments Similar to Sheet Symbols, however can be defined with any graphic representation in the
library editor, the parts pins act as sheet entries.    You can use the hierarchy, Up, Down, 
Create Sheet from Symbol commands with Sheet Parts. 

          Note. The default sheet Part Filename is an asterix (*), this can cause file loading 
problems when exporting the schematic file back to Orcad format. Make sure to remove 
all asterix symbols from the sheet Part filename fields before saving and loading the file 
into Orcad. You can globally edit these fields.

See also
Part
Sheet Symbol
Sheet Symbol File Name



Part Designator

Overview The part designator is the name identifier for each part placed on the schematic 
worksheet. The designator may be changed by either double clicking on this field or 
using the Rename button in the Component Browser.

Fields
Text Part designators may have up to 255 characters.
X-Location The reference point coordinate of the part designator, along the x-axis.
Y-Location The reference point coordinate of the part designator, along the y-axis.

Orientation Part designators can be rotated 360 degrees using 90 degree increments. There are four
selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. While 
moving the part designator, you can rotate it around the cursor by pressing the 
SPACEBAR.

Color Part designators can be assigned a color. To assign a new color to a part designator, 
click in the color box to open the Color Selector dialog box. Advanced Schematic will 
display all the available colors that your graphics card and monitor supports.

Font Part designators support text formatting, such as, True Type fonts, definable character 
sizes, italic, bold, underline, and strikeout styles.

Selection Toggle the selection state of the part designator by turning this option on or off. If this 
option is on, the part designator will be outlined in the selection color defined in the 
Options Preferences dialog box.



          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Hide If this option is enabled, the designator is hidden and is not displayed on the worksheet.

See also
Part



Part Type

Overview The Part Type is the name of the component on the schematic worksheet. For example, 
10k can be chosen as the part type for the resistor.

Fields
Type Part names may have up to 255 characters.
X-Location The reference point coordinate of the part type, along the x-axis.
Y-Location The reference point coordinate of the part type, along the y-axis.
Orientation Part type names can be rotated 360 degrees using 90 degree increments. There 

are four selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. While moving the 
part type name, you can rotate it around the cursor by pressing the SPACEBAR.

Color Part type names can be assigned a color. To assign a new color to a part type, click in 
the color box to open the Color Selector dialog box. Advanced Schematic will display all 
the available colors that your graphics card and monitor supports.

Font Part type names support text formatting, such as, True Type fonts, definable character 
sizes, italic, bold, underline, and strikeout styles.

Selection Toggle the selection state of the part type by turning this option on or off. If this option is 
on, the part type will be outlined in the selection color defined in the Options Preferences
dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 



by using the Edit Select and De-select commands to define a selection group.

Hide If this option is enabled, the part type is hidden and is not displayed on the worksheet.

Comments You can move and position the part type anywhere on the worksheet, if you move the 
part later, the type name will move with the part.

See also
Part



Part Description

Overview Parts have eight extra description fields that are used for adding reference information to
a part on the schematic worksheet or for inclusion in a Bill of Materials file. The fields can
be moved and positioned individually. They also remain associated with the part, so if 
you move the part later, the fields will move with the part.

Fields
Text Each description field can be 255 characters long.

X-Location The reference point coordinate of the description field, along the x-axis.

Y-Location The reference point coordinate of the description field, along the y-axis.

Orientation Part description fields can be rotated 360 degrees using 90 degree increments. There 
are four selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. 
While moving one of the fields, you can rotate it around the cursor by pressing the 
SPACEBAR.

Color Part description names can be assigned a color. To assign a new color to a description 
field, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports.

Font Part description fields support text formatting, such as, True Type fonts, definable 
character sizes, italic, bold, underline, and strikeout styles.



Selection Toggle the selection state of the description field by turning this option on or off. If this 
option is on, the field will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Hide If this option is enabled, the description field is hidden and is not displayed on the 
worksheet. By default this option is enabled.

Comments These eight description fields belong to this instance of this part only. They are in 
additional to the eight text fields that are defined for a specific component in the library 
editor.

See also
Part



Sheet Symbol Name

Overview The Sheet symbol name is a description field used to label a sheet symbol.

Fields
Name Sheet symbol names support up to 255 characters of text.
X-Location The reference point coordinate of the sheet symbol file name, along the x-axis.
Y-Location The reference point coordinate of the sheet symbol file name, along the y-axis.
Orientation Sheet symbol names can be rotated 360 degrees using 90 degree increments. 

There are four selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. While 
moving the name, you can rotate it around the cursor by pressing the SPACEBAR.

Color Sheet symbol names can be assigned a color. To assign a new color to the file name, 
click in the color box to open the Color Selector dialog box. Advanced Schematic will 
display all the available and dithered colors that your graphics card and monitor 
supports.

Font Sheet symbol names support text formatting, such as, True Type fonts, definable 
character sizes, italic, bold, underline, and strikeout styles.

Selection Toggle the selection state of the sheet symbol name by turning this option on or off. If 
this option is on, the name will be outlined in the selection color defined in the Options 
Preferences dialog box.



          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Hide If this option is enabled, the sheet symbol name is hidden and is not displayed on the 
worksheet.

Comments You can move and position the sheet symbol name anywhere on the worksheet, if you 
move the sheet symbol later, the name will move with the sheet symbol.

See also
Sheet Symbol



Sheet Symbol File Name

Overview Sheet Symbols represent another schematic worksheet, the file name is the link to the 
schematic worksheet.

Fields
Name The name of the schematic worksheet file, including the full path. (e.g., C:\SCHFILES\

SHEET1.SCH)
X-Location The reference point coordinate of the sheet symbol file name, along the x-axis.
Y-Location The reference point coordinate of the sheet symbol file name, along the y-axis.

Orientation Sheet symbol file names can be rotated 360 degrees using 90 degree increments. There
are four selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. 
While moving the file name, you can rotate it around the cursor by pressing the 
SPACEBAR.

Color Sheet Symbol file names can be assigned a color. To assign a new color to the file 
name, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports.

Font Sheet symbol file names support text formatting, such as, True Type fonts, definable 
character sizes, italic, bold, underline, and strikeout styles.

Selection Toggle the selection state of the sheet symbol file name by turning this option on or off. If



this option is on, the file name will be outlined in the selection color defined in the 
Options Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and by 
using the Edit Select and De-select commands to define a selection group.

Hide If this option is enabled, the sheet symbol file name is hidden and is not displayed on the
worksheet.

Comments You can move and position the file name anywhere on the schematic worksheet, if you 
move the sheet symbol later, the file name will move with the sheet symbol.

See also
Sheet Symbol
Sheet Part File Name



No ERC

Overview No ERC are special symbols that identify a pin on a part that is to be left unconnected. 
During electrical design rules checking, unconnected pins with No ERC symbols will be 
ignored.

Fields
X-Location The reference point coordinate the No ERC symbol, along the x-axis.
Y-Location The reference point coordinate of a No ERC symbol, along the y-axis.
Color No ERC symbols can be assigned a color. To assign a new color to the No ERC symbol, 

click in the color box to open the Color Selector dialog box. Advanced Schematic will display all the 
available colors that your graphics card and monitor supports.

Selection Toggle the selection state of No ERC symbols by turning this option on or off. If this 
option is on, the No ERC symbol will be outlined in the selection color defined in the 
Options Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and by 
using the Edit Select and De-select commands to define a selection group.

See also
Place No ERC
Jump To Next Error



Error Marker

Overview Error Markers are special symbols that flag ERC error violations, generated after an 
Electrical Rules Check report.

Fields
Error The description of the error violation. This error and description is also written to the ERC 

report file.
X-Location The reference point coordinate of the Error Marker, along the x-axis.
Y-Location The reference point coordinate of the Error Marker, along the y-axis.
Color The color of the Error Marker flag, defined in the Options Preferences dialog box.

Selection Toggle the selection state of Error Markers by turning this option on or off. If this option is
on, the Error Marker will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

See also
Electrical Rules Check



PCB Layout

Overview PCB Layouts are special symbols that allow you to attach board layout information to a 
specific net. This information is saved into the netlist file which is later passed to 
Advanced PCB, OrCAD PCB or other compatible board layout systems.

Fields
Track Width Sets the routing track width that will be used by a board layout program to auto 

route the net flagged by this PCB layout directive. The width can be any integer (whole number) value, 
the default is 10mil. Protel for Windows Advanced PCB allows track widths of 1 to 9999mil. Refer to your 
board layout documentation for details on maximum and minimum track routing widths.

Via Width Sets the routing via diameter that will be used by a board layout program to auto route 
the net flagged by this PCB layout directive. The width can be any integer (whole 
number) value, the default is 50mil. Protel for Windows Advanced PCB allows track 
widths of 1 to 9999mil.    Refer to your board layout documentation for details on 
maximum and minimum track routing widths.

Topology Sets the optimization method that will be used by a board layout program to sort the 
connections flagged by this PCB layout directive. Six selectable optimization methods 
are available (all supported by Advanced PCB); X-Bias, Y-Bias, Shortest, Daisy Chain, 
Minimum Daisy Chain and Start/End Daisy Chain, the default is Shortest. Refer to your 
board layout documentation for details on supported optimization methods.

Priority Sets the routing priority that will be used by a board layout program to auto route the net 
flagged by this PCB layout directive. Five selectable routing priorities are available (all 
supported by Advanced PCB); Highest, High, Medium, Low and Lowest, the default is 
Medium. Refer to your board layout documentation for details on supported routing 



priorities.

Layer Sets the routing track layer that will be used by a board layout program to auto route the 
net flagged by this PCB layout directive. Thirty four selectable routing track layers are 
available (all supported by Protel for Windows    Advanced PCB). Undefined will not 
assign a routing track layer to the net, the board layout program will use any available 
layers when auto routing this net. Refer to your board layout documentation for details 
on supported track routing layers.

X-Location The reference point coordinate of the PCB layout directive, along the x-axis.

Y-Location The reference point coordinate of the PCB layout directive, along the y-axis.

Color PCB Layout directives can be assigned a color. To assign a new color to the PCB Layout
directive, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Selection Toggle the selection state of Board Layout Directives by turning this option on or off. If 
this option is on, the Board Layout Directive will be outlined in the selection color defined
in the Options Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

See also
Place PCB Layout



Stimulus

Overview A Stimulus is a special symbol which is used to identify a node or net to be stimulated 
when the digital simulation is run.

Fields
Code The stimulus value is an expression describing the pattern of states present in the circuit 

logic. 
X-Location The reference point coordinate of the Stimulus, along the x-axis.
Y-Location The reference point coordinate of the Stimulus, along the y-axis.
Color A Stimulus can be assigned with a color. To assign a new color to the Stimulus, click in 

the color box to open the Color Selector dialog box. Advanced Schematic will display all 
the available colors that your graphics card and monitor supports.

Selection Toggle the selection state of Stimulus objects by turning this option on or off. If this option
is on, the Stimulus will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Comments Stimulus symbols are used in OrCAD digital simulation tools, Refer to your OrCAD 
documentation for further information about using simulation stimulus.

See also
Test Vector Index
Probe
Place Stimulus



Test Vector Index

Overview Test Vectors are special symbols used to identify a node with a simulation test vector. 
The test vectors are referred to by a column number, which indicates the column of the 
test vector file to use when the simulation is run.

Fields
Column Name of the Test Vector Index, this indicates which column of the test vector file to use 

when the simulation is run. 
X-Location The reference point coordinate of the Test Vector Index, along the x-axis.

Y-Location The reference point coordinate of the Test Vector Index, along the y-axis.

Color Test Vectors can be assigned a color. To assign a new color to the Test Vector, click in 
the color box to open the Color Selector dialog box. Advanced Schematic will display all 
the available colors that your graphics card and monitor supports.

Selection Toggle the selection state of Test Vector Indexes by turning this option on or off. If this 
option is on, the Test Vector Index will be outlined in the selection color defined in the 
Options Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Comments Test Vector Index symbols are used in OrCAD digital simulation tools, refer to your 
OrCAD documentation for further information about using simulation vectors.

See also
Place Test Vector Index
Probe
Stimulus





Probe

Overview A Probe is a special marker which is placed on the worksheet to identify nodes for digital 
simulation.

Fields
Name The name that is used when tracing the timing of the circuit in digital simulation.
X-Location The reference point coordinate of a Probe, along the x-axis.
Y-Location The reference point coordinate of a Probe, along the y-axis.
Color Probes can be assigned a color. To assign a new color to the Probe, click in the color box

to open the Color Selector dialog box. Advanced Schematic will display all the available colors that your 
graphics card and monitor supports.

Selection Toggle the selection state of Probes by turning this option on or off. If this option is on, 
the Probe will be outlined in the selection color defined in the Options Preferences dialog
box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and De-select commands to define a selection group.

Comments Probes are used in OrCAD digital simulation tools, refer to your OrCAD documentation 
for further information about using simulation probes.

See also
Place Probe
Test Vector Index
Stimulus



Port

Overview Ports are special symbols that are used to direct a signal (wire or bus) to another 
schematic sheet, they may also be used internally within a sheet. All Ports with the same
name are considered to be electrically connected.

Fields
Name Port names or labels support up to 255 characters of text. The label will be used as the 

identifier for connecting to signals on other sheets in a flat sheet design.
Style Four display styles are available for Ports, left arrow, right arrow, left and right arrow and 

none. A Ports 'Style' is independent from its I/O Type. For example, a Port with the Style 
of 'Left' does not necessarily mean the Port is 'Output'.

I/O Type Specifies the type of signal processing characteristics of the port. There are four I/O 
types, Input, Output, Bi-directional and Unspecified. The Electrical Rules Check 
recognizes Sheet Entry types and reports violations.

Alignment Port names can be aligned within the Port boundary. Three alignment options are 
provided, Center, Left and Right.

Width Advanced Schematic allows you to change the horizontal width of Ports. The width can 
be any integer (whole number) value. A value of 1 = 10mil = .254mm. When the option 
'OrCAD Ports' is enabled in the Options Preferences dialog box, the length of all Ports in 
a schematic project are re-sized to the OrCAD equivalent and the length of the Port is 
restricted from being manually edited. This option is used when exporting a schematic 



file out to the OrCAD format. First, enable this option, then manually clean-up any Port-
to-Wire connections that may have been disconnected.

X-Location The reference point coordinate of a Port, along the x-axis.

Y-Location The reference point coordinate of a Port, along the y-axis.

Border Color The surrounding border of Ports can be assigned a color. To assign a new color to the 
border, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports.

Fill Color The inside area of Ports can be assigned a color. To assign a new color to the inside 
area, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports.

Text Color Port names or labels can be assigned a color. To assign a new color to the Name, click 
in the color box to open the Color Selector dialog box. Advanced Schematic will display 
all the available colors that your graphics card and monitor supports.

Selection Toggle the selection state of Ports by turning this option on or off. If this option is on, the 
Port will be outlined in the selection color defined in the Options Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and
by using the Edit Select and De-select commands to define a selection group.

Comments When exporting a schematic project to OrCAD format, make sure to enable the option 
"OrCAD Ports" in the Options Preferences dialog box. Note: Manual clean-up of Port-to-
Wire connections may be necessary, if this option was disabled during the course of 
design.

See also
Place Port
Net Label



Power Port

Overview Power Ports are special symbols that represent a power supply net. These allow you to 
indicate a power net conveniently at various locations on the sheet by connecting Power 
Ports to pins or to the end of wires.

Fields
Net Power Port names or labels support up to 255 characters of text. The Label will be used 

as the identifier for connecting to signals on other sheets in a flat or hierarchical design. Common used 
names include, +5, VCC, -12, GND, VSS etc.

Style Power Ports can be represented by five different styles; Circle, Arrow, Bar, Wave and 
Ground. The styles are graphical options only and have no electrical properties.

X-Location The reference point coordinate of a Power Port, along the x-axis.

Y-Location The reference point coordinate of a Power Port, along the y-axis.

Orientation Power Ports can be rotated through 360 degrees using 90 degree increments. There are
four selectable orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. 
While moving a Power Port, you can rotate it around the cursor by pressing the 
SPACEBAR.



Color Power Ports can be assigned a color. To assign a new color to the Power Port, click in 
the color box to open the Color Selector dialog box. Advanced Schematic will display all 
the available colors that your graphics card and monitor supports.

Selection Toggle the selection state of Power Ports by turning this option on or off. If this option is 
on, the Power Port will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and by 
using the Edit Select and De-select commands to define a selection group.

Comments When generating a netlist, signals that are connected directly to Power Ports are 
automatically tied to the name of the Power Port.

See also
Place Power Port



Sheet Entry

Overview Sheet Entry symbols direct signals to another sheet in a hierarchical design.

Fields
Name Sheet Entry Names or Labels support up to 255 characters of text. The Label will be used

as the identifier for connecting to signals on other sheets in the hierarchy.
I/O Type Specifies the type of signal processing characteristics of the sheet entry. There 

are four I/O types, Input, Output, Bi-directional and Unspecified. The Electrical Rules Check (ERC) 
recognizes Sheet Entry types and reports violations. A Sheet Entry will connect to a port on the sheet 
represented by the Sheet Symbol. Although the ERC is programmable and connection errors can have 
their interpretation altered, the following rules should be followed. 

          if Sheet Entry is input, the connecting port should be output.

          if sheet Entry is output, the connecting port should be input.

          if sheet Entry is Bi-directional, the port should be Bi-directional.



          if sheet Entry is Unspecified, the port should be Unspecified.    

Style Four display styles are available for Sheet Entry symbols, left arrow, right arrow, left and 
right arrow and none. A Sheet Entry symbols 'Style' is independent from its Electrical 
type. For example, a Sheet Entry with the Style of 'Left & Right' does not necessarily 
mean the Sheet Entry is 'I/O'.

Side The Sheet Entry may be positioned on either the left or right hand side of the Sheet 
Symbol. The Sheet Entry has a fixed size and is positioned within the surrounding border
of the Sheet Symbol.

Position The relative position of the Sheet Entry from the top of the Sheet Symbol. The number in
this field indicates the grid spacing from the top of the Sheet Symbol. The number of 
Sheet Entry symbols that can be placed along the vertical sides of the Sheet Symbol will 
vary with different Sheet Symbol sizes.

Border Color The surrounding border of a Sheet Entry can be assigned a color. To assign a new color 
to the border, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Fill Color The inside area of a Sheet Entry can be assigned a color. To assign a new color to the 
inside area, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Text Color Sheet Entry names or labels can be assigned a color. To assign a new color to the 
Name, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports.

Selection Toggle the selection state of the Sheet Entry by turning this option on or off. If this option 
is on, the Sheet Entry will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and 
by using the Edit Select and DeSelect commands.

See also
Add Sheet Entry
Sheet Symbol



Sheet Symbol

Overview Sheet symbols represent another schematic sheet in a hierarchical design. Sheet 
symbols include Sheet Entry symbols, which provide a connection point for signals 
between the parent and child sheets.

Fields
X-Location The reference point coordinate of a Sheet Symbol, along the x-axis.
Y-Location The reference point coordinate of a Sheet Symbol, along the y-axis.
X-Size Advanced Schematic allows you to change the horizontal width of Sheet Symbols. The 

width can be any integer (whole number) value. A value of 1 = 10mil = .254mm.
Y-Size Advanced Schematic allows you to change the vertical height of Sheet Symbols. The 

height can be any integer (whole number) value. A value of 1 = 10mil = .254mm.

Border Width Specifies the border outline thickness of Sheet Symbols. There are four selectable 
border widths; smallest, small, medium and large.



Border Color The surrounding border of Sheet Symbols can be assigned a color. To assign a new 
border color, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Fill Color The inside area of Sheet Symbols can be assigned a color. To assign a new color to the 
inside area, click in the color box to open the Color Selector dialog box. Advanced 
Schematic will display all the available colors that your graphics card and monitor 
supports.

Selection Toggle the selection state of Sheet Symbols by turning this option on or off. If this option 
is on, the Sheet Symbol will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and by 
using the Edit Select and De-select commands to define a selection group.

Draw Solid Advanced Schematic allows you to turn the inside area color of Sheet Symbols on or off. 
If this option is on, the inside area of the Sheet Symbol will be displayed in the fill color. If
this option is off, then only the Sheet Symbols border will be shown.

Show Hidden Sheet Symbols have two text fields attached to them, a 'sheet name' and a 'sheet file 
name', both of these fields can be hidden from the worksheet. If this option is enabled 
then the hidden names will be displayed. Enabling this option does not change the 
'hidden' attribute of the names. The 'hidden' attribute can only be changed by editing the 
individual sheet name and sheet file name.

See also
Place Sheet Symbol
Sheet Symbol File Name
Sheet Symbol Name
Sheet Entry
Up Hierarchy
Down Hierarchy



Part

Overview Parts are groups of primitives you place on the schematic worksheet to represent the 
electronic devices in a design.

          Depending upon the part, these can be displayed using standard ANSI schematic 
notation, the De-Morgan equivalent (for gates) and IEEE standard notation.

Fields
X-Location The reference point coordinate of a Part, along the x-axis.



Y-Location The reference point coordinate of a Part, along the y-axis.
Mode Parts can be displayed in three different modes, Normal, De-Morgan and IEEE.

Fill Color The inside area of Parts can be assigned a color. To assign a new color to the inside 
area, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports. This 
color will only be used if the local color field is enabled.

Line Color The surrounding border of Parts can be assigned a color. To assign a new color to the 
border, click in the color box to open the Color Selector dialog box. Advanced Schematic 
will display all the available colors that your graphics card and monitor supports. This 
color will only be used if the local color field is enabled.

Pin Color Pins can be assigned a color. To assign a new color to the Pin, click in the color box to 
open the Color Selector dialog box. Advanced Schematic will display all the available 
colors that your graphics card and monitor supports. This color will only be used if the 
local color field is enabled.

Local Colors When this option is enabled, the default colors of the Part defined in the Library Editor 
will be over ridden by the Fill color, Line color and Pin color defined in this dialog box.

Mirrored When this option is enabled, the Part is flipped along its x-axis. While moving a part, you 
can flip it along its x or y axis by pressing the X and Y keys.

Orientation Parts can be rotated 360 degrees using 90 degree increments. There are four selectable
orientations, 0 degrees, 90 degrees, 180 degrees and 270 degrees. While moving a part,
you can rotate it around the cursor by pressing the SPACEBAR.

Selection Toggle the selection state of Parts by turning this option on or off. If this option is 
enabled, the Part will be outlined in the selection color defined in the Options 
Preferences dialog box.

          Selections are generally made three ways; using the option in a dialog box, using 
SHIFT+LEFT MOUSE to add (or remove) individual objects to the current selection and by 
using the Edit Select and De-select commands to define a selection group.

Part This field signifies the part number of the component, such as U5:A or U5:1 signifies the 
first part of the component. If the component has multiple parts then changing this value 
will update the components part. You can also change the components part by choosing 
Increment Part Number from the Edit menu and then clicking on the component to toggle
through the available parts.

Hidden Fields Parts have several attached fields, a Part Type, Part Designator, and eight text 
description fields, any one of these fields can be hidden from the worksheet. If this option
is enabled then the hidden names will be displayed. Enabling this option does not 
change the 'hidden' attribute of the field names. The 'hidden' attribute can only be 
changed by editing the individual names.

Hidden Pins If this option is enabled then all the hidden pins on the part will be shown. Power pins are
commonly defined as being hidden, such as +5, VCC, -12, GND, VSS etc. Enabling this 
option does not change the 'hidden' attribute of pins. The 'hidden' attribute can only be 
change in the Library Editor.

Lib Ref Specifies the Parts' library paSheet symbols represent another schematic sheet in a 
hierarchical design. Sheet symbols include Sheet Entry symbols, which provide a 



connection point for signals between the parent and child sheets.

Comments Global editing of parts is performed at a more sophisticated level compared to the 
ordinary global editing of other objects. The "Copy To" fields allows direct reference to all
the text attributes of a part.    This provides a powerful text manipulation capability that 
can be used to copy any combination of text fields to any other fields within a part. 
Please refer to the "New Features" section for a detailed description of this feature.

See also
Place Parts
Part Description
Part Type
Part Designator
Sheet Part File Name



MainMenu

File Nested Menu
Edit Nested Menu

Place Nested Menu
Library Nested Menu

Tools Nested Menu
Options Nested Menu

Zoom Nested Menu
Info Nested Menu

Window Nested Menu
Help Nested Menu



File

New Create a new, empty schematic worksheet
Open Sheet... Open and load a schematic worksheet file

Open Project... Open and load all schematic sheets in a project
Close Close the current window

Close Project Close all open schematic windows
Save Save current schematic worksheet with same file name

Save As... Save current schematic worksheet with new file name
Save All Save all loaded schematic project and worksheet files

Save Project Save all the sheets in the current project
Setup Printer... Printer and page setup

Print Print the current document with the last set printer options
Annotate... Re-Designate all Parts in schematic project

Back Annotate... Back Annotate Part and Pin information from a PCB Was/Is File
Create Netlist... Generate a netlist from the current project or sheet

Hierarchy Nested Menu
Reports Nested Menu

Exit Quit from Advanced Schematic



Hierarchy

Down Hierarchy Switch to a child sheet of the current sheet
Up Hierarchy Switch to the parent sheet of the current sheet

Complex To Simple Convert Complex Hierachical Design To Simple Hierarchical Design
Create Sheet From Symbol Creates a new sheet (File New command) and adds ports for sheet 

entries on the sheet symbol
Create Symbol From Sheet Create a sheet symbol that represents the current sheet



Reports

Bill of Material... Generate a Bill of Materials
Project Hierarchy... Generate a text listing to represent the design hierarchy
Cross Reference... Generate a part/sheet cross reference for the current project or sheet

Electrical Rules Check... Perform an Electrical Rules Check on the current project or sheet
Netlist Compare... Compare two Protel format netlists and generate a report



Edit

Undo Undo previous command
Redo Redo previous undo command

Cut Copy selected objects to clipboard and remove from sheet
Copy Copy all selected objects to the clipboard
Paste Place clipboard contents onto current worksheet

Paste Array... Define an array placement of clipboard contents
Clear Delete all selected objects from the current worksheet

Find Text... Search for and jump to a text string on any sheet
Replace Text... Search for and replace text strings

Find Next Search for and jump to the next matching text string
Select Nested Menu

DeSelect Nested Menu
Toggle Selection Toggle selection-state of objects

Delete Select and delete objects on schematic worksheet
Change Select and use dialog to change objects

Move Nested Menu
Align Nested Menu
Jump Nested Menu

Increment Part Number Toggle part number on multi-part component
Cross Probe Part On PCB Select part to cross probe to PCB
Cross Probe Pin On PCB Select pin to cross probe to PCB
Cross Probe Net On PCB Select power object / Net Label to cross probe to PCB



Select

Inside Area Select all objects inside an area
Outside Area Select all objects outside an area

All Select everything on the current worksheet
Net Find physical connection from a point

Connection Find physical connection between pins



DeSelect

Inside Area De-Select all objects inside an area
Outside Area De-Select all objects outside an area

All De-Select all selected objects



Move

Drag Select and move objects together with connected wires/buses
Move Select and move objects on schematic sheet

Move Selection Move selected objects to another area of the worksheet
Drag Selection Move selected object(s) and drag connected objects
Move To Front Move and place an object in the front of all other objects
Bring To Front Bring an object graphically to the front of all other objects
Send To Back Send an object to the back of all other objects

Bring To Front Of Bring an object to the front of another object
Send To Back Of Send an object to the back of another object



Align

Align... Align selected objects using alignment dialog box
Align left Align selected objects on the left side of their bounding rectangle

Align Right Align selected objects on the right side of their bounding rectangle
Center Horizontal Center objects around the vertical center line of the bounding rectangle

Distribute Horizontally+Shift Distribute equally the selected objects along the horizontal axis
Align Top Align selected objects on the top side of their bounding rectangle

Align Bottom Align selected objects on the bottom side of their bounding rectangle
Center Vertical Center objects around the vertical center line of the bounding rectangle

Distribute Vertically+Shift Distribute equally the selected objects along the vertical axis



Jump

Jump To Error Marker Jump to the next Error Marker in the Project
Origin Jump to the origin of the worksheet (lower left)

New Location... Type in and jump to a new location on the worksheet
Location Mark 1 Jump to a location previously specified by setting Location Mark 1-10.
Location Mark 2 Jump to a location previously specified by setting Location Mark 1-10.
Location Mark 3 Jump to a location previously specified by setting Location Mark 1-10.
Location Mark 4 Jump to a location previously specified by setting Location Mark 1-10.
Location Mark 5 Jump to a location previously specified by setting Location Mark 1-10.
Location Mark 6 Jump to a location previously specified by setting Location Mark 1-10.
Location Mark 7 Jump to a location previously specified by setting Location Mark 1-10.
Location Mark 8 Jump to a location previously specified by setting Location Mark 1-10.
Location Mark 9 Jump to a location previously specified by setting Location Mark 1-10.

Location Mark 10 Jump to a location previously specified by setting Location Mark 1-10.



Place

Bus Place bus lines on the worksheet
Bus Entry Place bus entry on the worksheet

Part Place parts on the worksheet
Junction Place a junction on the current worksheet

Power Port Place power ports on the worksheet
Wire Place electrical wires on the worksheet

Net Label Place a net label on the worksheet
Port Place a port on the sheet

Sheet Symbol Place hierarchical sheet symbols on the worksheet
Add Sheet Entry Add net connections to sheet symbols

Drawing Tools Nested Menu
Text Nested Menu

Directives Nested Menu
Location Marks Nested Menu



Drawing Tools

Arcs Place graphical arcs on the worksheet
Elliptical Arcs Place elliptical arcs on the worksheet

Ellipses Place elliptical shapes on the sheet
Pie Charts Place pie shapes on the sheet

Line Place graphical lines on the sheet
Rectangle Place rectangles on the worksheet

Round Rectangle Place round rectangles on the worksheet
Polygons Place graphical polygon shapes on the worksheet

Beziers Place bezier curves on the sheet
Graphic... Place PCX/BMP/GIF/TIFF/WMF/EPS graphical images on the sheet



Text

Text Frame Place multi-line text frames on the sheet
Annotation Place single line text on the sheet



Directives

No ERC Suppress no-connection error message for nets
Probe Add net to list of nets to be traced by digital simulator

Test Vector Index Mark nets to identify which simulation vector to use
Stimulus Add stimulus information to nets for digital simulation

PCB Layout Add directives to nets for PCB routing



Location Marks

Set Location Mark 1 Set location mark (1-10) on the current worksheet
Set Location Mark 2 Set location mark (1-10) on the current worksheet
Set Location Mark 3 Set location mark (1-10) on the current worksheet
Set Location Mark 4 Set location mark (1-10) on the current worksheet
Set Location Mark 5 Set location mark (1-10) on the current worksheet
Set Location Mark 6 Set location mark (1-10) on the current worksheet
Set Location Mark 7 Set location mark (1-10) on the current worksheet
Set Location Mark 8 Set location mark (1-10) on the current worksheet
Set Location Mark 9 Set location mark (1-10) on the current worksheet

Set Location Mark 10 Set location mark (1-10) on the current worksheet



Library

Add/Remove... Add and remove libraries from the library list
Run Library Editor... Switch to the Schematic Library Editor

Make Project Library... Make a library of parts contained in the current project
Update Parts In Cache Update all parts from library information

Find Component... Search for a component in a specified path.



Tools

Schematic Library Editor Switch to the Schematic Library Editor
Analog Simulator Launch the Analog Simulator spcified in the Tools-Options Dialog
Digital Simulator Launch the Digital Simulator spcified in the Tools-Options Dialog

Mixed-Signal Simulator Launch the Mixed-Signal Simulator spcified in the Tools-Options Dialog
PCB Layout Editor Switch to the PCB Layout Editor

PLD/FPGA Compiler Launch the PLD Compiler spcified in the Tools-Options Dialog
Windows Tools Nested Menu

User Tools Nested Menu
Setup... Setup user specific Programs to use with Tools Menu



Windows Tools

File Manager Run the Windows File Manager program
Control Panel Run the Windows Control Panel program

Windows Setup Run the Windows Setup program
Calculator Run the Windows Calculator program

Clock Run the Windows Clock program
Notepad Run the Windows Notepad program

Text Editor Run the user-specified text editor (defaults To NOTEPAD.EXE)
Picture Editor Run the user-specified paint/draw program (default is PBRUSH.EXE)

CSV Editor Run the user specified program for editing CSV files



User Tools

User Program 1 Run user specified Program 1
User Program 2 Run user specified Program 2
User Program 3 Run user specified Program 3
User Program 4 Run user specified Program 4



Options

Preferences... Setup System Preferences
Sheet... Setup options for current worksheet

Hot Keys... Setup Hot Key assignments
Auto-Pan... Setup Autopan options

Memory Monitor... Setup low memory/resources warning thresholds.
Update Current Template Update the current sheet from its template file.
Set Template File Name... Change the current template to a different template file

Remove Template Remove any template information from the current sheet
Status Bar Turn the Status Line on or off

Command Status Bar Turn the Command Status Line on or off
Scroll Bars Turn the scroll bars on or off

Main Toolbar Turn the Main Toolbar on or off
Wiring Toolbar Turn the Wiring Toolbar on or off

Drawing Toolbar Turn the Drawing Toolbar on or off
Project Manager Turn the Project Manager on or off

Component Browser Turn the Component Browser on or off
Visible Grid Turn the visible grid on or off

Snap Grid Turn the snap grid on or off
Electrical Grid Turn the electrical grid on or off

Open... Open and load an environment configuration file
Save As... Save current environment configuration to a file



Zoom

Window Select a rectangular area of the sheet and fit that area in the window
Point Select a rectangular area of the sheet and fit that area in the window
50% Set zoom scale to 0.5x

100% Set zoom scale to 1x (normal magnification)
200% Set zoom scale to 2x
400% Set zoom scale to 4x (highest magnification)

In Show less of the current worksheet (higher magnification)
Out Show more of the current worksheet (lower magnification)
Pan Re-Center the screen around the cursor

Redraw Update the screen display
All Fit all objects on the current sheet in the window

Sheet Show entire sheet



Info

System Status... Display system information
Selected Pins... List all selected pins



Window

Tile Tile all open schematic windows
Cascade Cascade all open schematic windows

Arrange Icons Arrange all minimized open schematic windows
Close All Close all open schematic windows



Help

New Features Information on new features
Contents Help system topic index

Using Help Information about the Windows Help System
Basic Concepts Basic information about Advanced Schematic

Commands Help information organized by menu structure
Printing Information about generating hard copy output

Reference Advanced Schematic Reference
DOS Schematic Command Cross Reference for Protel DOS Schematic users

Orcad SDT Command Cross Reference for OrCAD SDT    users
About... Display the version number and copyright of Advanced Schematic



Hot Keys

 M Popup Move Menu Popup the Move Menu
E Popup Edit Menu Popup the Edit menu
P Popup Place Menu Popup the Place menu
J Popup Jump Menu Popup the Edit Jump menu
S Popup Select Menu Popup the Edit Select menu
X Popup De-Select Menu Popup the Edit De-Select menu
Z Popup Zoom Menu Popup the Zoom menu
O Popup Options Menu Popup the Options menu
H Popup Help Menu Popup the Help menu
F Popup File Menu Popup the File menu
L Popup Library Menu Popup the Library menu
T Popup Tools Menu Popup the Tools menu
A Popup Alignment Menu Popup the Alignment menu
I Popup Info Menu Popup the Info menu

W Popup Window Menu Popup the Window menu
F1 Help Index Help system topic index

Shift F4 Window Tile Tile all open schematic windows
Shift F5 Window Cascade Cascade all open schematic windows

Alt BackSpace Undo Undo previous command
Ctrl BackSpace Redo Redo previous undo command

Shift Delete Cut Copy selected objects to clipboard and remove from sheet
Ctrl Insert Copy Copy all selected objects to the clipboard

Shift Insert Paste Place clipboard contents onto current worksheet
Ctrl Delete Clear Delete all selected objects from the current worksheet

Shift MouseLeft Toggle Single Object Toggle selection-state of objects
Delete Delete Single Object Delete object that currently has the focus

MouseLeft Change Object Graphically or Set Focus Select and change objects on 
schematic sheet

MouseDblLeft Change Single Object Use dialog to change object under the cursor
Ctrl MouseLeft Drag Single Item Focus on and move a single object (and drag connected 

wires)
Ctrl MouseLeftHold Drag Single Item Focus on and move a single object (and drag connected 

wires)
Ctrl Shift MouseLeft Move Single Object Select and move objects on the schematic worksheet

MouseLeftHold Change Object Graphically or Move Select and change objects on 
schematic sheet

Ctrl PgDn Zoom All Fit all objects on the current sheet in the window
PgUp Zoom In Show less of the current worksheet (higher magnification)
PgDn Zoom Out Show more of the current worksheet (lower magnification)
Home Zoom Pan Re-Center the screen around the cursor

End Screen Redraw Update the screen display
Ctrl 4 Zoom 400% Set zoom scale to 4x (highest magnification)
Ctrl 2 Zoom 200% Set zoom scale to 2x
Ctrl 1 Zoom 100% Set zoom scale to 1x (normal magnification)
Ctrl 5 Zoom 50% Set zoom scale to 0.5x



Shift Up Shift Cursor Up Move the cursor up 10 snap grid points
Shift Down Shift Cursor Down Move the cursor down 10 snap grid points

Shift Left Shift Cursor Left Move the cursor up 10 snap grid points
Shift Right Shift Cursor Right Move the cursor right 10 snap grid points

Up Cursor Up Move the cursor up one snap grid point
Down Cursor Down Move the cursor down one snap grid point

Left Cursor Left Move the cursor left one snap grid point
Right Cursor Right Move the cursor right one snap grid point
Ctrl F Find Text Search for and jump to a text string on any sheet

F3 Find Next Text Search for and jump to the next matching text string
Ctrl G Find and Replace Text Search for and replace text strings
Ctrl L Align objects on left Align selected objects on the left side of their bounding 

rectangle
Ctrl R Align objects on right Align selected objects on the right side of their 

bounding rectangle
Ctrl H Center objects around horizontal axis Center objects around the vertical 

center line of the bounding rectangle
Ctrl Shift H Distribute equally along horizontal axis Distribute equally the selected 

objects along the horizontal axis
Ctrl T Align objects on top Align selected objects on the top side of their bounding

rectangle
Ctrl B Align objects on bottom Align selected objects on the bottom side of their 

bounding rectangle
Ctrl V Center objects around vertical axis Center objects around the vertical 

center line of the bounding rectangle
Ctrl Shift V Distribute equally along vertical axis Distribute equally the selected 

objects along the vertical axis



Tool Bars

Tools

Wiring Tools

Drawing Tools



Tools

              Toggle Project Manager Turn the Project Manager on or off

              Toggle Component Browser 
Turn the Component Browser on or off

              File Open Sheet Open and load
a schematic worksheet file



              File Save Save current 
schematic worksheet with same file name

              Setup Printer Printer and page 
setup

              Zoom In Show less of the current 
worksheet (higher magnification)



              Zoom Out Show more of the 
current worksheet (lower magnification)

              Zoom Sheet Show entire sheet

              Down Hierarchy Switch to a 
child sheet of the current sheet



              Up Hierarchy Switch to the 
parent sheet of the current sheet

              Cut Copy selected objects to clipboard 
and remove from sheet

              Paste Place clipboard contents 
onto current worksheet



              Select Inside Area Select all 
objects inside an area

              De-Select All De-Select all 
selected objects

              Move Selection Move selected 
objects to another area of the worksheet



              Toggle Drawing Toolbar Turn the 
Drawing Toolbar on or off

              Toggle Wiring Toolbar Turn 
the Wiring Toolbar on or off

              Add/Remove Library Add and 
remove libraries from the library list



              Run Library Editor Switch to 
the Schematic Library Editor

              Run PCB Editor Switch to the 
PCB Layout Editor

              Increment Part Number Toggle part 
number on multi-part component



              Undo Undo previous command

              Redo Redo previous undo 
command

              Help Index Help system topic 
index



Wiring Tools

              Place Wire Place electrical wires on the 
worksheet

              Place Bus Place bus lines on 
the worksheet

              Place Bus Entry Place bus 
entry on the worksheet



              Place Net Label Place a net 
label on the worksheet

              Place Power Port Place power 
ports on the worksheet

              Place Parts Place parts on the 
worksheet



              Place Sheet Symbol Place 
hierarchical sheet symbols on the worksheet

              Add Sheet Entry Add net 
connections to sheet symbols

              Place Port Place a port on the 
sheet



              Place Junctions Place a 
junction on the current worksheet

              Place Probe Add net to list of nets to be
traced by digital simulator

              Place Stimulus Add stimulus 
information to nets for digital simulation



              Place No ERC Suppress no-
connection error message for nets

              Place PCB Layout Add 
directives to nets for PCB routing



Drawing Tools

              Place Lines Place graphical lines on 
the sheet

              Place Polygons Place 
graphical polygon shapes on the worksheet

              Place Elliptical Arcs Place 
elliptical arcs on the worksheet



              Place Beziers Place bezier 
curves on the sheet

              Place Annotation Place single 
line text on the sheet

              Place Text Frame Place multi-line text 
frames on the sheet



              Place Rectangles Place 
rectangles on the worksheet

              Place Round Rectangle Place 
round rectangles on the worksheet

              Place Ellipses Place elliptical 
shapes on the sheet



              Place Pie Charts Place pie 
shapes on the sheet

              Place Graphic Place 
PCX/BMP/GIF/TIFF/WMF/EPS graphical images on the sheet

              Paste Array Define an array 
placement of clipboard contents



Error Messages

Unrecognized File Format
Too Many Files Open
Text not found
Sector Not Found
Printing Aborted
Print Manager Aborted
Path not found
Out of Memory
Out Of Memory While Printing
Out Of Disk Space While Printing
No selection
No selected pins
No printer found
No memory left
No Error Markers Found
No Duplicate Components
Library Must Be Protel Advanced Schematic Format
Orcad STDXTEND.EXE must be in the PATH to Load Orcad 32-bit Binary File
Orcad 32To16.EXE must be in the PATH to Load Orcad 32-bit Binary Schematic
Orcad DECOMP.EXE (Renamed to DECOMP32.EXE) must be in the PATH to Load Orcad 32-
bit Binary Library
Orcad DECOMP.EXE must be in the PATH to Load Orcad Binary Library
Not Enough Memory To Start Application
No more Space For Access Codes
Invalid OrCAD library file format
Invalid File Handle
Invalid File Access
Invalid Drive
Invalid Code, Please Re-Enter
Incorrect Access Code For Schematic
I/O Error Number : 
Hard Lock Device Not Found
General Error While Printing
File Not Open
File not found
File is Read Only
File Error : 
File Corruption Error
File Access Denied
Feature Not Enabled In This Version
Drive Write Error
Drive Seek Error
Drive Read Error
Drive Not Ready
Disk Is Write Protected
Cannot Switch To Target Application, Multiple Copies of Application Running



Unrecognized File Format

              This message occurs whenever a sheet file or library file Open command encounters an 
unrecognized format. Advanced Schematic will load Protel Schematic and STD IV sheet 
files automatically. The Library Editor will load Protel Advanced Schematic binary and 
OrCAD binary formats plus decompiled Protel (DOS) and OrCAD text format libraries. 
Other formats will generate this error message.

See also
Error Messages



Too Many Files Open

              The number of files specified in the FILES= command in your CONFIG.SYS file has 
been exceded. Close one or more files or increase the number of files specified in 
CONFIG.SYS.

See also
Error Messages



Text not found

              In the Text find and replace commands, the text that you specified was not found 
anywhere on the worksheet.

See also
Error Messages



Sector Not Found

              Internal error. Contact Protel for assistance.

See also
Error Messages



Printing Aborted

              You have pressed Cancel in the Print dialog box. Choose the Print command and re-print
the job, if desired.

See also
Error Messages



Print Manager Aborted

              You have closed the print manager while a job is printing. Choose the Print command 
and re-print the job.

See also
Error Messages



Path not found

              You have specified a path that doesn't exist.

See also
Error Messages



Out of Memory

              While placing items, loading a file or general editing, the program has run out of memory.
Clear the Undo stack or close other applications to make more memory available. 
Alternatively exit and restart Windows. If none of these options work, then you will need 
to add additional memory to your system to perform this operation.

See also
Error Messages



Out Of Memory While Printing

              The program has run out of memory. Clear the Undo stack or close other applications to 
make more memory available. Alternatively exit and restart Windows. If none of these 
options work, then you will need to add additional memory to your system to perform this
operation.

See also
Error Messages



Out Of Disk Space While Printing

              When printing to file, sufficient disk space must be available. Either select another drive 
or clear enough disk space for the print file and re-attempt printing.

See also
Error Messages



No selection

              Use the Editcommands or SHIFT+LEFT MOUSE to select some items.

See also
Error Messages



No selected pins

              You have selected Information Selected Pins with no pins currently selected.

See also
Error Messages



No printer found

              You must selected a windows printer in File Plot/Print before choosing Generate Prints. 
Use Window Control Panel to install printers.

See also
Error Messages



No memory left

              While placing items, loading a file or general editing, the program has run out of memory.
Clear the Undo stack or close other applications to make more memory available. 
Alternatively exit and restart Windows. If none of these options work, then you will need 
to add some more memory.

See also
Error Messages



No Error Markers Found

              The Jump to error markers command could not find any error markers in the current 
sheet. Use File:Reports:ERC to find errors.

See also
Error Messages



No Duplicate Components

              Remove Duplicates command has not found any duplicate components in the library.

See also
Error Messages



Library Must Be Protel Advanced Schematic Format

              The library file which you have tried to load, merge or Add to the libaray list, is not saved 
in a valid Protel or Orcad format. It may not be the right file (a Protel Schematic file for 
example) or it may have been damaged. If it is damaged, then you    will have to resort to
a back-up version.

See also
Error Messages



Orcad STDXTEND.EXE must be in the PATH to Load Orcad 32-bit Binary File

              The DOS memory 32 bit memory utility STDXTEND.EXE is supplied with the OrCAD 
SDT 386-32 Bit system and is used by their 32 bit applications. Make sure that it is in 
your PATH.

See also
Error Messages



Orcad 32To16.EXE must be in the PATH to Load Orcad 32-bit Binary Schematic

              The DOS application 32To16.EXE is supplied with the OrCAD SDT 386-32 Bit system. 
Make sure that it is in your PATH. Advanced Schematic needs this utility to load Orcad 
32 bit schematics.

See also
Error Messages



Orcad DECOMP.EXE (Renamed to DECOMP32.EXE) must be in the PATH to Load 
Orcad 32-bit Binary Library

              The DOS application DECOMP.EXE is supplied with the OrCAD SDT 386-32 bit system. 
Copy this file to DECOMP32.EXE and make sure that it is in your PATH. This allows 
Advanced Schematic to load both 16 and 32 bit Orcad Libraries.

See also
Error Messages



Orcad DECOMP.EXE must be in the PATH to Load Orcad Binary Library

              The DOS application DECOMP.EXE is supplied with the OrCAD SDT 16 Bit system. 
Make sure that it is in your PATH.

See also
Error Messages



Not Enough Memory To Start Application

              There is not memory and/or resource space to start the application

See also
Error Messages



No more Space For Access Codes

              Only 40 access codes can be added at one time

See also
Error Messages



Invalid OrCAD library file format

              The library file which you have tried to load or merge from (extension SRC) is not saved 
in a valid Orcad ASCII (decompiled) format. It may not be the right file (an Orcad file for 
example) or it may have been damaged. If this occurs, try loading the file in LIB (OrCAD 
binary) format. Advanced Schematic will perform the de-compilation automatically in this 
case. If the library has been succesfully Decompiled but still generates this error, then 
you should used the Orcad utility CONVERT.EXE to convert it to 16 bit before loading it 
into Library Editor.

See also
Error Messages



Invalid File Handle

              Internal error. Contact Protel for assistance.

See also
Error Messages



Invalid File Access

              Internal error. Contact Protel for assistance.

See also
Error Messages



Invalid Drive

              The requested drive is not recognized by the system. Please specify the correct drive.

See also
Error Messages



Invalid Code, Please Re-Enter

              You have entered an access code with an incorrect format. Correct format is four 
hexadecimal characters, followed by a hyphen (-) and four additional hexadecimal 
characters. Be sure that you type zero (0) and not the letter "O" where it appears in the 
code sequences.

See also
Error Messages



Incorrect Access Code For Schematic

              You have attempted to run this module without having typed the correct access code into
the Set Acces Codes dialog box. To open this dialog box, choose the Help About 
command and click Set Access Codes. Carefully type the correct code into the box for 
this module and press Test to verify each code. Be careful to type zero (0) and not the 
letter "O" where it appears in the code sequences.

See also
Error Messages



I/O Error Number : 

              Internal error. Note the error message/number and contact Protel for assistance.

See also
Error Messages



Hard Lock Device Not Found

              You have attempted to run a protected Protel for Windows application without having first
connected the external security device supplied with the system. Make sure that the 
device is properly connected to a parallel port and re-start Protel for Windows. If this is 
unsuccessful, the device may be either damaged or defective. In this case,

          contact your Protel representative for assistance. Warning: incorrect connection may 
damage the device -- make sure that the device is connected to a parallel, not serial 
port, with the "arrow" pointing toward the printer.

See also
Error Messages



General Error While Printing

              Communication with the printer has been interrupted. Check the printer connections, 
cabling, etc. and retry.

See also
Error Messages



File Not Open

              Internal error. Contact Protel for assistance.

See also
Error Messages



File not found

              The file name selected could not be found.

See also
Error Messages



File is Read Only

              You are trying to save to a file that is Read Only. Either change the files attributes or use 
Save As to write to a new file name.

See also
Error Messages



File Error : 

              Internal error. Note the error message/number and contact Protel for assistance.

See also
Error Messages



File Corruption Error

              The Schematic worksheet file which you have tried to load from (extension ASC) 
contains text which does not conform to the Protel Schematic file format. This error 
indicates that the program recognized the file as a valid schematic file, but then while 
actually loading it, some part of it was invalid. If you have been editing the file manually 
(with a text editor) then see the manual for more information or contact Protel Technical 
support. Or , if the file is a foriegn format, OrCAD for example, it may contain elements 
that are not recognised by the Protel loader.

See also
Error Messages



File Access Denied

              The file you are attempting to open is either currently in use or you are attempting to 
write to a read-only file.

See also
Error Messages



Feature Not Enabled In This Version

              This feature is not available in the the currently installed version.

See also
Error Messages



Drive Write Error

              The requested drive or file cannot be accessed. Make sure that the correct drive has 
been specified.

See also
Error Messages



Drive Seek Error

              The requested drive or file cannot be accessed. Make sure that the correct drive has 
been specified.

See also
Error Messages



Drive Read Error

              The requested drive or file cannot be accessed. Make sure that the correct drive has 
been specified.

See also
Error Messages



Drive Not Ready

              The requested drive is not available or responding. Make sure that the correct drive has 
been specified.

See also
Error Messages



Disk Is Write Protected

              The diskette is write protected. Remove or open the write protect tab.

See also
Error Messages



Cannot Switch To Target Application, Multiple Copies of Application Running

              For inter-application communications, multiple target copies create ambiguities. This can 
occur from Place Component from the library editor, Edit component from Schematic and
cross probing from any application.

See also
Error Messages





Using Schematic Editor Help

This on-line guide provides an introduction to the Advanced Schematic design system, 
including many of the features, key concepts and terminology used throughout the system. 
The guide is intended to provide the general information you need to get up and running with 
the system and to learn to use the basic features required to design a circuit, generate a netlist
and print artwork. Detailed information can be found in your Advanced Schematic 
documentation, including the Protel for Windows Environment Guide, Advanced Schematic 
User Guide, Schematic Editor Reference and Library Editor Reference.
Help methods
There are three methods for using On-line Help.

        1. You can run the Help application and switch to Help, as needed, using the Contents and 
Search facilities to browse the available topics.

        2. A second, powerful way to use help is to use context sensitivity. By default the F1 key is linked 
to the Help system. When you are running Advanced Schematic, pressing F1 will open the 
relevent topic when you are in placement mode or when a menu is selected.

        3. You can press the Help button in most dialog boxes. This will run context sensitive help for that
dialog.

System overview
Assumptions made by this guide



System overview

Advanced Schematic includes two independent applications: the Schematic Editor and the 
Schematic Library Editor.
Advanced Schematic can generate single sheet, multiple sheet and fully hierarchical designs 
of virtually any size, limited only by the available memory and storage capacity of your system.
Sheet sizes include A, B, C, D, E (or metric sizes A4-A0) plus user-defined sheets of up to 65 
inches square. Standard component libraries include over 15,000 parts, with standard ANSI, 
DeMorgan and IEEE display options (where applicable). 

Schematic Editor
Schematic Library Editor



Schematic Editor

The Schematic Editor is the primary Advanced Schematic application. This application allows 
the user to create, edit, check and print the sheet files that comprise a design project. All the 
tools and utilities needed to generate valid netlists, design reports and presentation quality 
schematic drawings are integrated into the Schematic Editor application. 
Open and view as many sheets and design files as desired. Any number of Advanced 
Schematic sheets can be opened in their own windows, limited only by available memory. Run
multiple Windows (and Windows-compatible DOS) applications. Switch between sheets, files 
and applications with a click of the mouse.



Schematic Library Editor

The Library Editor is an independent application used to create, edit and manage parts 
libraries and their components. You can run the Schematic Editor concurrently with the Library 
Editor with special links that allow you to move conveniently back and forth between the two 
applications. The Schematic Library Editor includes many of the features of the Schematic 
Editor application, plus specialized tools and features for component part creation and library 
management.



File, Netlist and output format options

Advanced Schematic loads OrCAD SDT and Protel-Schematic (DOS version 3.3) files, along 
with Advanced Schematic files. Translation of imported drawings is 100% and full support is 
provided for all Protel and OrCAD SDT design objects and functions. De-compiled OrCAD 
SDT libraries (and Protel-Schematic (DOS) libraries) can be translated into Advanced 
Schematic format, as well. A large number of netlist output formats are supported. Windows 3 
features support for many output devices including dot matrix printers, PostScript printers and 
imagesetters, as well as plotters of many different types. 

See also
Trace Netlist Report



Hierarchical and multi-sheet support

Advanced Schematic supports single sheet, multiple sheet and fully hierarchical designs. An 
entire multi-sheet project can be opened (or saved) with a single command. Projects can be 
navigated visually using the Project Manager tree display. A single mouse click moves the 
designer from sheet-to-sheet, even in complex hierarchies. Any number of multi-sheet projects
or individual sheets can be open at any time. 



About editing

Attributes can be edited by double-clicking directly on the item to open a dialog box. In 
Advanced Schematic, changes can be globally applied across an entire design using specific 
conditions to define the targets. For example, when editing wires you can change the color or 
wire size or both attributes. These changes can be globally applied to other wires on the sheet,
or to other open sheets. Similar global options are provided for components and other objects.



About Libraries

Advanced Schematic includes a powerful system for managing schematic component 
libraries. Any number of part libraries can be opened and accessed simultaneously while you 
create your drawings. Comprehensive standard manufacturer libraries are included with Protel
for Windows. Components can be browsed and placed directly from the independent 
Schematic Library Editor application. Simultaneous multi-user library access is supported for 
network installations.



Special strings

Special purpose pre-defined strings allow the user to place date, sheet name, filename, 
component count or other information to be automatically generated when printing or plotting 
the sheet file. For example, a string called ".DATE_PRINT," when plotted, places the current 
system date on the plot. 
Place these stringsbin the sheet, using the Place Text (not Text Frame) command. Special 
strings print using the font type size and color assigned during placement. Special strings 
include:

        .DATE Prints the date from the system calendar;

        .TIME Prints the time from the system clock,

        .DOC_FILE_NAME Prints the name of the schematic sheet file;

In the Options Sheet dialog box, the user can specify information which is added to the sheet 
title block when the ANSI title block option is selected. The Document button allows the user to
include the organization name, address, sheet number, total sheets, title, number and revision.
These will be ignored is the normal title block is selected.

Document options



Array placement options

Linear array placement allows automated step-and-repeat placement of objects in the sheet. 
This can include individual objects or complex selections of objects. The users can specify the 
number of repeats and set pre-defined x and y offsets, and text increments.

See also
Using the clipboard
Place Array command



Design verification tools

Electrical Rule Check allows quick verification of large or complex drawings. ERC checks are 
performed in accordance with user-specified physical and logical properties.



Windows support for printing and plotting

Dot matrix and laser printing, color printing, pen plotting and PostScript output are all 
controlled from a common Print command. Any device supported by Windows can be 
selected. Advanced Schematic graphical design tools support the production of presentation 
quality artwork. 

Windows display options



Windows display options

Protel for Windows makes full use of all standard and 24 bit color graphics cards and monitors
supported under Windows 3. On standard graphics adapters such as VGA, dithering can be 
used to simulate colors beyond the standard 20 Windows solid tones. Over 700 pre-defined 
standard colors on a special palette are provided, along with the ability to define custom 
colors. Protel for Windows makes full use of the Windows graphical environment, allowing the 
user to place TrueType fonts, place bitmap and vector graphics images and to assign colors 
independently to all display items.



Assumptions made by this guide

The documentation makes four assumptions about Advanced Schematic users:

        1. That users have a sound knowledge of the principles and terminology of schematic design and
capture;

        2. That users are familiar with Windows 3 icons, menus, windows and using the mouse to make 
selections.

        3. That users have a basic understanding about how Windows manages applications (programs 
and utilities) and documents (data files) to perform routine tasks such as starting applications, 
opening documents and saving work. If you are new to Windows, please start with your 
Microsoft Windows 3.0 User's Guide.

        4. That users have a basic understanding of Microsoft DOS and its use of directories, file naming
conventions, etc. 



Protel for Windows Environment Guide

The Protel for Windows design system currently includes printed circuit board layout, PCB 
design automation and schematic design applications. The Protel for Windows Environment 
Guide, delivered with your Advanced Schematic package, provides an overview of the Protel 
for Windows design environment, including many of the features and concepts used 
throughout the various modules of the system. It provides step-by-step instructions for 
installing PfW software, some applicable Windows fundamentals and information regarding 
technical support and product upgrades.



Advanced Schematic User Guide

The User Guide is designed to guide the new user through the many features of Advanced 
Schematic. It includes general coverage of the basic principles used througout the Advanced 
Schematic system, including concepts and an introduction to Advanced Schematic objects, 
tools and processes.



Advanced Schematic Reference

The Schematic Editor Reference includes detailed descriptions for each tool, command and 
dialog box option available in the Schematic Editor application. A comprehensive Index is 
included, making it easy to search for specific information, either by topic or by key word.

Menus and commands
Data Primitives
Hot Keys
Tool Bars
Menus
Error Messages



Schematic Library Editor Reference

The Schematic Library Editor is a separate Windows application used to create and edit and 
manage the contents of schematic parts libraries. The Library Editor has many of the same 
features as the main Advanced Schematic application, plus additional features for component 
editing. The Schematic Library Editor Reference provides detailed descriptions for the design 
objects, menu commands and dialog box options used with Library Editor, in a convenient 
separate volume.



The computer model of a circuit

Outwardly, the use of schematic capture is similar to the traditional drafting process, where 
graphical symbols for wires and components are rendered in drawings, which become a 
record of the design. Performing the process electronically provides many benefits in the form 
of automating the process of drafting, and more importantly, revising the design over time.
However, it's the capture part of the process that provides the main benefit -- the integral link 
between the design and production process.
Schematic capture also incorporates many data management facilities that exploit the 
capabilities of computerized design. For example, each Advanced Schematic sheet is an 
independent file. An automated system links these sheets when they are part of a common 
design project.

The Advanced Schematic component model
Libraries of component models
Connectivity
Wiring
Net Identifiers



The Advanced Schematic component model

In Advanced Schematic, component parts are organized into libraries that correspond to 
manufacturer data books.
Each component name in the library is associated with one or more component parts 
descriptions that become the representation of the component on the schematic sheet.
Because components can have multiple devices (e.g., the individual gates in TTL logic 
components), it is extremely convenient to be able to work with each part of a multi-part 
component individually while laying out the design.



Libraries of component models

While an image of the component part is "placed" into the schematic, the component 
information is always stored in the library. Component creation and editing are always 
performed at the library level, not on the sheet. This approach maintains library integrity and 
allows library changes to be used to globally update components in existing designs.
As parts are placed in sheets, a back-up image of each component is placed in a special 
cache, attached to each sheet file. This back-up library allows the user to distribute the 
schematic sheet files without having to supply the complete set of libraries used to create the 
design. The back-up library also allows the user to generate a permanent project library for the
design. The component images stored in the back-up library can be updated by the source 
libraries, each time the sheet is loaded in the Schematic Editor.



Connectivity

Connectivity refers to a special feature of the Advanced Schematic environment -- the ability of
the software to recognize the physical connections between certain electrical design objects 
inside the sheet and the ability to associate the logical connections that exist between various 
sheets in a multi-sheet design. Connectivity is also used to "anchor" objects together when 
wiring the circuit. For example, you can reposition a part in the sheet and any attached wires 
will drag with the part as it is moved. 
Most importantly, connectivity allows the schematic to perform netlisting and electrical rules 
checks.

Netlists and connectivity



Wiring

The process of placing electrical objects in the sheet is often referred to as wiring. This is 
because the connectivity features allow you to work with electrical objects as though you were 
physically hooking-up the circuit. 
Basic electrical objects, used in wiring your schematic include special wires, which are 
connective lines that carry signals or power between components; buses which graphically 
represent grouped nets; bus entries that graphically attach wires to buses; junctions which are 
used to connect crossing wires and parts that represent the component devices and their pins.
Two other special classes of electrical objects are provided as well: directives, which are used 
to indicate simulation points, unconnected pins (No ERC) and PCB layout attributes on 
individual nets and net identifiers, which are used to make electrical connections between 
sheets.



Net identifiers

Net identifier objects support connections between schematic sheets. These objects include: 

        net labels Identify common nets on a sheet (or globally, across multiple sheets if the user 
specifies); 

        ports Identify net connections between two sheets; 

        sheet entries Identify net connections into a sub-sheet (referenced by a sheet symbol) and 

        power ports Special symbols which represent a global power (or other user-specified) net.

        hidden pins Represent connections to global power (or other) nets, from placed parts.

Place Net Labels process
Place Ports process
Place Power Objects process
Place Sheet Nets process
Place Sheet Symbols process

See also

Hidden Pins
About netlists



Using connectivity

Connectivity is derived from the placement of certain electrical (or wiring) objects in the sheet 
workspace. However, not all wiring objects have connective behavior. Some objects use their 
physical geometry to establish connections. Other objects include logical connectivity in their 
behavior.

Physical connectivity
Logical connectivity



Physical connectivity

Physical connectivity is derived by placing two connective objects in physical contact. For 
example, a wire touching a component pin is deemed to be connected to that pin, and 
Advanced Schematic can extract that logical connection from the physical contact between the
two items.
In general terms, when the "hot" points of any two connective objects "touch" they are deemed
to be connected. However, there are some special rules that apply to certain classes of 
connections.
The Info Selected Pins command (shortcut: I, E) can be used to verify connections during 
schematic layout.

        Wire to wire Wires that butt or have co-linear terminations are deemed to be connected. Co-linear 
wires that terminate elsewhere are not deemed to be connected. Wires that cross 
perpendicularly are not deemed to be connected unless a junction is placed at their 
intersection.

        Wire to bus Buses are graphical representations of grouped signals only, and do not have any 
special connective properties. Net labels must be used to indicate connectivity on either 
side of the bus connection.Pins that touch or cross wires at any angle are deemed to be 
connected.

        Wire to port Port connections are defined by their names (which reference a specific net name). 

        Wire to Sheet entry No special connectivity is present when wires and sheet entries are in contact. 
Connectivity is provided by the net label associated with the wire and the sheet entry net 
name.

        Bus to object Buses are graphical representations of grouped nets only and have no special 
connective properties. Logical connectivity is used in these cases.

        Net label to wire Net labels associate a wire with single net. To achieve this association, the net 
lable must be placed on the same grid point as the wire, either vertically or horizontally. 
Labels cannot be placed on 45 degree or non-orthogonal lines.

        Net label to busBuses are graphical entities and cannot be connectively net labeled.

        Net label to pin Net labels cannot be directly connected to pins. The net label must be placed on a wire, 
connected to the pin.

        Pin to pin Pins are deemed to be connected if they are in contact at any angle.

        No ERC No ERC objects are deemed to be connected to pins or wires if they are in contact.



Logical connectivity

Logical connectivity depends upon the presence of net identifiers (net labels, ports, sheet 
entries, power ports and hidden pins) on the sheet. Logical connectivity does not require 
special placement or physical contact but relies on the matching of the net names that 
associate these objects within a single sheet or across multiple sheets in a project.



Design verification

Design verification is a general term for validating the electrical and logical contents of your 
design. A number of tools are provided that allow you to perform design verification from within
the Schematic Editor, by generating various reports and by running the Electrical Rules Check 
(ERC) feature.
Because Window's multi-document environment allows you to switch between multiple 
application, you can generate netlists, reports and Electrical Rules Checks and examine these
items without exiting the Schematic Editor or Library Editor.

Checking sheets and projects
Generating reports



Checking sheets and projects

While creating a schematic, a number of useful design verification features are available 
directly in the sheet workspace. The Edit Select Net and Edit Select Connection commands 
can be used to highlight all objects associated with a net or a single connection (component 
pins do not select in these cases). These commands are useful in verifying connections. The 
Info Components and Info Selected Pins commands display a list of all sheet components or 
all pins who are connected to the current selection.



Generating reports

Advanced Schematic design verification tools include four report generators which produce 
ASCII format text files:

Bill of Materials
Project Hierarchy
Cross Reference
Electrical Rules Check



Bill of Materials

The File Reports Bill of Materials (BOM) feature generates a report for all sheets in the current
active project. Two versions of the BOM report are available. The (default) condensed pre-
formatted version lists part type fields, description fields, quantities of each type and the 
designator fields associated with each type. This condensed version is produced in a tabulated
ASCII format. The Expanded BOM format is produced in CSV (Comma Separated Value) 
format and includes several additional fields: 8 (internal) library component text fields, 8 part 
text fields and 4 package description fields. This format is intended for export to database or 
spreadsheet applications. You may need to specify CSV format when importing this BOM 
format to your database or spreadsheet.

About this process
About the CSV Editor



Project Hierarchy

The File Reports Project Hierarchy command (shortcut: F, R, P) generates a listing of project 
files for the current active sheet, hierarchical or multi-sheet flat project. This report is output in 
ASCII text format.

About this process



Cross Reference

The File Reports Cross Reference command (shortcut: F, R, C) generates a listing of part 
types and designator labels, and the sheet location (filename) for each item. The report is 
generated for the current active sheet, hierarchical or multi-sheet flat project. This report is 
output in ASCII text format.

About this process



Electrical Rules Check

Electrical Rules Check (ERC) report is a listing of electrical (and certain logical) violations and 
warnings for the current active project. A wide variety of basic electrical errors are reported. 
For example, open input pins on parts and shorts between two differently named power nets. 
The user can select the specific rules used to validate the project. No ERC symbols can be 
placed on sheets wherever the user prefers specific violations to be ignored by the ERC 
system. 
An error or warning can be specified using a matrix of pin, port or sheet entry conditions.
Special symbols are overlaid on the sheet, indicating the location of the reported conditions. 
These symbols can be deleted individually as the design is checked.
The process of running an ERC is integral to producing a valid netlist for a project. The 
presence of electrical or logical violations will not prevent Advanced Schematic from 
generating a netlist, however incomplete or invalid. Carefully check and resolve all reported 
errors prior to netlist generation.
Setup Electrical Rules Check

The following options are provided in the Setup Electrical Rules Check dialog box:

        Report Options

        Multiple Net Names on Net - reports nets which have more than one net label associated
with the physical net.

        Duplicate Sheet Numbers - reports sheets with the same sheet number.

        Duplicate Component Designators - reports components with the same reference 
designator (label) such as U1, etc.

        Bus Label Format Errors - To be identified properly as a Bus label, the label must be in 
the following format: AB[0..9]. Errors that are reported include: Missing prefix; Missing 
bracket; Missing two dots (or decimal points); Numbers outside of the legal range (0-
32000).

        Supress Warnings - this option supresses reporting of Warnings. This allows you to 
generate a quick report of Errors only.

        Output Options

        Create Report File - Generates a text file which will be opened using the default text file 
application assigned in the File Run Setup dialog.

        Add Error Markers - Generates graphical Error Markers which are placed in project 
sheets.

        Net Identifier Scope

        Specifies the use of net identifiers when creating a netlist (preparatory to generating an 
error report).

        Pin/Sheet Entry/Port Rule Matrix

        Sets the specific connection rules that are and the Error/Warning status for electrically 
connected items. Click inside the matrix to toggle through No Report, Error or Warning. 
For example, two output pins cannot be connected, so the two points on the matrix 
where these two items intersect are set to Error. Warnings can be supressed when 
generating ERC reports. 

Report ERC process
Jump to Next Error process





Linking to other applications

Advanced Schematic provides a number of special tools for linking the product of schematic 
designs to other applications, from PCB design and circuit simulation -- to spreadsheets and 
databases. Topics include:

Netlists
Special links to PCB systems
PCB Layout directive
Back annotation
Cross probing by part
Cross probing by net
Cross probing by pin



PCB layout links

Advanced Schematic supports a number of links to PCB systems beyond basic netlisting.

        PCB Layout directive The PCB Layout directive, object (supported by OrCAD SDT and PCB) allows the 
engineer to specify routing characteristics on a net-by-net basis. User definable 
fields for the PCB Layout object include routing track width and via size, layer and 
route priority. Protel for Windows Advanced PCB version 2 will provide 
comprehensive support for PCB Layout directives from Advanced Schematic.

        Back Annotation The File Back Annotate command updates schematic part designators (U1:1, R32, 
etc.) based on a "was-is" list generated by the PCB layout package. Protel for 
Windows Advanced PCB 2 and a number of other layout packages support back 
annotation.    

        Forward Annotion Forward annotation is the process of implementing changes to an existing PCB 
layout from a schematic editor. This system will allow users to delete nets, add 
nets, delete nodes and add nodes at the schematic. Advanced PCB 2 will compare
the current layout with the new netlist and remove existing routes on the PCB and 
convert these back into unrouted connections.

        Cross-probing Protel for Windows fully supports multi-document and multi-application use of the 
Windows environment. This allows the user to open Advanced Schematic and a 
Protel for Windows PCB application at the same time. When a schematic sheet (or 
project) and its PCB layout are open at the same time, Advanced Schematic and 
Advanced PCB version 2 will support cross probing. For example, the user will be 
able to select a component in the schematic, and the PCB editor will jump to the 
same component, in real time. 

Place Layout Directive process

See also
About netlists



Project management

A schematic design can consist of a single sheet drawing or multiple linked sheets. 
Irrespective of the number of sheets, Advanced Schematic treats each design as a project.
Multiple sheet projects support large or complex designs that cannot be served by a single 
sheet, irrespective of the sheet size. Even when the design is not particularly complex, there 
can be advantages in organizing the project across multiple sheets. For example, the design 
may include various modular elements. Maintaining these modules as individual files can be 
very convenient.
When two or more sheet files are associated or linked in some way, we refer to this as a multi-
sheet project. There are a number of methods for organizing multiple sheet projects. Choosing
one approach or another is based upon the type of design, its size and structure. 
Project management is the process of defining and maintaining the links between the sheet 
files that make up a project. These links allow the user to open and save projects in a single 
operation. They provide a means of navigating, or viewing and accessing each individual 
sheet in a project and also support multi-sheet netlist generation and Electrical Rules Checks 
(ERC).
In Advanced Schematic, each sheet is stored as an individual file that is opened in its own 
independent window. Any sheet can be opened and edited independently of all other sheets, 
using the File Open Sheet command. Multi-sheet projects are opened using the File Open 
Project command.
Many Advanced Schematic features such as netlist generation, re-annotation and printing 
apply to the open sheet files associated with a project. Therefore, in many cases an entire 
project (which includes a Master sheet and all associated sheets) will need to be opened at 
once to perform these operations.
 

Four models of hierarchy
Using the Project Manager



Master sheet

All Advanced Schematic multi-sheet projects have a special sheet file called the master sheet. 
The master sheet is the top, or first sheet in the design hierarchy. The term hierarchy refers to 
the relationship between master sheets and other sheets (or subsheets) that make up the 
project. This hierarchical structure can have a number of forms, defined by the method used to
connect the sheets together.
Hierarchical organization supports a truly modular approach by allowing the designer to work 
with functional blocks. These blocks have a spatial relationship on the sheets which natural 
support for either a "top down" or "bottom up" design methodology.



Subsheets

In multi-sheet designs, the master sheet always includes at least one sheet symbol. The sheet
symbol is a special object that provides a graphical representation of another sheet (called a 
subsheet) in the hierarchy.
Along with its graphical display attributes (color, size, location, etc.) the sheet symbol has two 
additional fields: a sheet name and a file name. The sheet name field is a text label, and is 
provided for reference only. The file name refers to a specific sheet file that the sheet symbol 
represents and provides a link between the master sheet and its subsheet, and thereby 
defines a project. 



Four models of hierarchy

Hierarchies can have two levels or many levels, depending upon the hierarchical model and 
the method of intersheet (electrical) connection. This is accomplished by defining the scope of 
net identifiers. Advanced Schematic supports four models of intersheet connections, defined 
by the scope of three special net identifier objects, which provide the connective "glue" that 
defines the sheet-to-sheet hierarchy.
The relationship between project sheets and net identifiers is best described by illustrating the 
four possible models of project organization under Advanced Schematic.

1. Global ports define intersheet connections
2. Global net labels and ports
3. Sheet entries define simple hierarchies
4. Complex hierarchies defined by sheet entries

See also
More about hierarchical design



Global ports define intersheet connections

This model for intersheet connections uses global ports. This model is sometimes referred to 
as a "flat" design. Global ports point to a net on another sheet. The Master sheet includes a 
sheet symbol for all sheets in the project, however no connections are made into these 
symbols on the master sheet. Net names in each sheet are local, meaning that the net name 
applies across a single sheet only, not other project sheets. In flat sheet designs, each sheet is
always unique.
Ports route connections that pass from sheet to sheet. This model of sheet organization treats 
your design as though it were laid out on a single large sheet that has been cut into individual 
pages. While this approach works fine for designs of limited size, management of large 
designs can be somewhat awkward, as this method, relies on the designer to maintain unique 
labels for each pair of ports that define a single intersheet connection.

Using net labels and ports to implement inter-sheet connectivity

See also
More about hierarchical design
OrCAD net identifiers



Global net labels and ports

In this hierarchical model, intersheet connections are provided by global net labels. This model
supports multi-sheet designs from "flat" schematic capture systems, such as Protel Schematic 
3 (DOS). In Advanced Schematic, global ports can also be used with this model, providing the 
user takes care to avoid conflict between port and label names. A sheet symbol for each sheet
must be placed in the Master sheet to allow the Project Manager to associate (or link) the 
Subsheets as a single project.

Using net labels and ports to implement inter-sheet connectivity

See also
More about hierarchical design
OrCAD net identifiers



Using net labels and ports to implement inter-sheet connectivity

The sheet symbols in flat projects are not connected to nets. Flat design intersheet 
connections are accounted for on each sheet separately, using either net label, ports or both 
net labels and ports together.
Placing a sheet symbol does not create a new sheet, it only establishes a link to a sheet with 
the same filename.

Place Ports process
Place Net Labels process



Sheet entries define simple hierarchies

This hierarchy model is sometimes referred to as simple hierarchy. Simple hierarchy supports 
multi-level or block design, where the hierarchy can be represented by a tree-like structure 
and all intersheet connections are vertical, defined by sheet entry symbols in each sheet 
symbol. In this model, the sheet symbol represents a child sheet, which descends from the 
parent. In simple hierarchies, each sheet symbol is used once in the design. In other words, 
each sheet in a simple hierarchy is unique. Net identifiers are local, not global, in this model.

Using sheet symbols to implement hierarchy
Master sheet
PlaceSheetSymbolsPlace Sheet Symbol process
AddSheetNetsPlace Sheet Entry process

See also
More about hierarchical design
OrCAD net identifiers



Complex hierarchies defined by sheet entries

This design model is sometimes referred to as complex hierarchy. The same sheet symbol can
be placed more than once in a project, either by being placed more than once on a single 
sheet, or by being placed on multiple sheets.
This model fits projects that are highly modular. An example would be a stereo amplifier, 
where left and right channels are identical circuits. 
Hierarchy in Advanced Schematic is not exclusively linked to the electrical links that make up a
multi-sheet circuit. You can also create projects which group unlinked sheet files for 
convenience.

Using sheet symbols to implement hierarchy
Master sheet
PlaceSheetSymbolsPlace Sheet Symbol process
AddSheetNetsPlace Sheet Entry process

See also
More about hierarchical design
OrCAD net identifiers



Using sheet symbols to implement hierarchy

The sheet entry symbol, links the subsheet to a net on the parent sheet. Every subsheet has a
"parent" sheet, either the master sheet, or another subsheet from which it descends. 
Similarly, so-called "flat" design master sheets (the first two models, above) include sheet 
symbols, labeled with the filenames of each subsheet. These sheet symbols are not "wired" 
together, using sheet entries.

Place Sheet Symbol process
Place Sheet Entry process
Create Sheet Symbol from Sheet process
Create Sheet from Sheet Symbol process



More about hierarchical design

So-called "simple" ane "complex" hierarchical models show the most powerful way to organize
multiple sheet designs. In both of these models, sheet symbols represent functional blocks, 
with the sheet entry symbols serving as connectors that tie circuitry on the sheet to the sub-
sheet. This hierarchical structure can be represented by thinking of the first sheet as the 
"parent" and the sheet represented by sheet symbols as the "child." In the terminology of 
hierarchical design, we can say that the child is descended from the parent. Naturally, the child
can have its own "children," -- additional sheets that descend, in this top-down structure, to 
lower and lower levels.
Hierarchy can be either simple, where each sheet is unique or complex, where the same child 
sheet (and its children) can appear more than once in the design -- a modular approach. 
Because each Advanced Schematic sheet is opened in its own window, you can display any 
number of sheets simultaneously (memory permitting). Moving from sheet to sheet can be a 
simple as clicking in the window to make it active.
This association of sheets resides on two levels. At the project level, the association is 
maintained by the presence of sheet symbols in the master sheet. Projects are also defined at 
the electrical (or connective) level by net identifiers. Net identifiers provide the links that 
connect circuits across multiple sheets.

OrCAD project management



Using the Project Manager

Advanced Schematic supports single sheet, multiple sheet and fully hierarchical designs. An 
entire multi-sheet project can be opened (or saved) with a single command. Projects can be 
navigated visually using the Project Manager tree display. A single mouse click moves the 
designer from sheet-to-sheet, even in complex hierarchies. Any number of multi-sheet projects
or individual sheets can be open at any time.

Opening schematic files
Opening hierarchical or multi-sheet projects
Adding and removing individual sheets from a project
Simple or complex hierarchical designs
Save Project and Save All commands
Navigating projects
Loading OrCAD files
Loading Protel (DOS) schematics
Create Sheet Symbol from Sheet process
Create Sheet from Sheet Symbol process



Opening schematic files

Under Advanced Schematic you can load any number of schematic sheet files into separate 
windows using the Multiple Document Interface (MDI). Advanced Schematic will load the 
following formats: Advanced Schematic (text and binary); Protel Schematic (DOS version 3) 
and OrCAD SDT (version 3 or 4) files.
When no open document (file) is displayed, the Menu bar displays three options: File, Info and
Help. The Open Sheet File dialog box will display the current directory and any files with the 
(default) Advanced Schematic file extension of .SCH. You can change the extension to filter 
the directory contents. For example, typing "*.*" in the File Name box will display all files in the 
current directory. 
Advanced Schematic allows the use of user-defined filenames (to the DOS limit of 8 
characters) and (optional) extensions of up to 3 characters. Extension use is unrestricted -- 
any extension can be used for schematic sheet files.

File Open process
Open Project process



Opening hierarchical or multi-sheet projects

The File Open Project command is used to open all sheet files associated with a hierarchical 
or multi-sheet project. To open a previously created project:

        Type the filename for any project sheet (include the full path, if different from the path 
currently listed). If the project is hierarchical, you can use any file in the project to open 
that sheet and any sheet that is lower in the hierarchy;

You can also double-click on the master sheet filename in the Files window. To change 
directories, double-click on any the available options in the Directories window.
This command can be used at any time and any number of hierarchical, flat and single sheet 
projects can be open simultaneously, limited only by available memory.
As a project loads, an icon for each sheet file is placed in the Project Manager window as a 
sheet window opens for each file inside the    Schematic Editor window. These sheet file 
windows will cascade to reveal the sheet name in each title bar.
Any number of projects and individual sheets can be opened and displayed in the project 
window, limited only by available memory. If the window fills, a scroll bar is added to the 
project window.

File Open process
Open Project process



Adding and removing individual sheets from a project

The contents of a multi-sheet project are defined by sheet symbols placed in the topmost or 
master sheet. To add an existing sheet to a project, place a sheet symbol in the master sheet 
with a matching sheet filename field. To remove a sheet from the project, simply delete the 
sheet symbol with that sheet's filename.

File New process
Create Sheet Symbol from Sheet process
Create Sheet from Sheet Symbol process



Loading    files    ( OrCAD)

File Open process
Flat designs
Simple or complex hierarchical designs



Flat designs

OrCAD "flat" projects automatically create their own master sheet the first time they are loaded
as a project (Open Project command). Sheet symbols will be placed in the master sheet for 
each subsheet, based upon the "pipelink" strings placed in the original OrCAD root schematic.



Simple or complex hierarchical designs

Simple and Complex "hierarchical" projects load just like Advanced Schematic files. Master (or
root) and subsheet references are maintained by the OrCAD sheet symbol filenames, sheet 
net symbol names and net labels.
In Advanced Schematic, all OrCAD design object types can be displayed on the sheet at all 
times, including simulation and layout directive objects.
Warning: Saving files in OrCAD (SDT 4) binary format will cause the loss of primitives and 
other file information that is not supported by the OrCAD format. Lost information will include 
vector graphical objects placed in the sheet, design object text fields exceeding 128 
characters, imported images, color and font assignments, etc. Consult your OrCAD 
documentation to determine supported data types and limits.



Loading files (Schematic 3 )

Protel Schematic 3 (DOS) files are handled similarly to "flat" OrCAD projects. If the files have a
common root name, e.g., CONTROL, then all files that are named CONTROL.S01-.S99 will be
included in the new project. A master sheet, with sheet symbols referencing each file will be 
automatically created.
For example, if you use OPEN Project on DEMO.S01 the DEMO.PRJ will be created and 
DEMO.S01, DEMO.S02 will be loaded. A Sheet symbol for each will be placed in DEMO.PRJ.

File Open process



Save Project and Save All commands

        Save Project Edit Save Project compliments the Open Project command, updating all the open sheet 
files, associated with the current active project, in a single operation. To use this 
command, first move the focus to any sheet in the project by clicking directly on the file's 
open sheet, or the icon representing the sheet in the Project Manager window. 

To save all the sheet files that constitute a single hierarchical or multi-sheet flat project, use 
the File Save Project command. Sheets will be saved using the default Protel binary format. All
sheets that belong to the project will be updated.

        Save All The Edit Save All command extends this concept, updating all open files, whether or not 
they are part of the current active project.

You can abort the drawing (or redraw) of the document window, at any time, by pressing 
SPACEBAR. This allows you to move directly to another window, menu command or tool 
button without waiting for the entire screen redraw to be completed.
The Save All command (shortcut: F, L) can be used to save all of the printed circuit boards in 
all currently opened windows. All files will be saved in binary format.

File Save process
File Save All process
File Save As process
File Save Project process



Navigating projects

When you use the Open Project command, click the Project Manager button on the main tool 
bar or choose the Options Project Manager command, the main Advanced Schematic 
application window displays a special project window to the left of the workspace. This window
is used do display all the current schematic master sheet and sheet files that are currently 
opened. The active sheet file icon is highlighted. 
You can click on any sheet icon to move the current focus to that sheet window. If the file is 
currently opened, the file window will be displayed in the    Schematic Editor window. If the file 
has been closed or minimized, the window will be opened. Double-clicking on the file icon will 
maximize the sheet file window.

Toggle Project Manager



Library and component management

In order to manage and use Advanced Schematic libraries efficiently, it is important that users 
understand the relationship between libraries, the component names used to access libraries 
and parts, which are the physical representations of components (symbols), placed in 
schematic sheets.
The Schematic Library Editor is an independent application for creating or modifying 
component parts and managing and editing libraries. Under Windows, the Schematic Editor 
and Library can be run simultaneously -- including multiple instances of either application, 
memory permitting. While the Schematic Editor and Library Editor run independently, special 
features provide convenient links between the two applications. For example, you can move 
directly from a part symbol in the sheet -- to editing its component information inside the 
source library.

Basic library concepts
Management of libraries
Schematic Library Editor
Component Browser panel



Advanced Schematic Libraries

Advanced Schematic libraries consist of component descriptions, represented by the 
individual part symbols that are placed in schematic sheets. Components can have one or 
many parts or subparts (e.g., the gates that comprise a multi-part component like a 74LS00 in 
the TTL library). The term component always refers to its complete library description -- either 
a specific manufacturer data book entity or a generic device (e.g., resistor, capacitor, diode, 
led, etc.). 
Many components share the same packaging -- they have identical graphical depictions, but 
exist as individual names in libraries. Perhaps these are identical devices from different 
manufacturers, or components that share the same packages but vary on some specification, 
such as a 120ns versus 80ns RAMs. While it is convenient to access these otherwise 
duplicate parts using either description, it would be wasteful to create and store a separate 
graphical version of each item.
Advanced Schematic uses the concept of component groups to associate multiple component 
names with a single description stored in the library. This keeps libraries efficient and 
manageable. For example, while the TTL library contains nearly 1800 component names, the 
graphical and data descriptions that represent these components number only about six 
hundred.
When a component part is placed in a schematic sheet, the displayed version of the part is a 
representation of the library version only. The actual component exists only in the library. This 
means that components and their parts are changed or edited only at the library level -- never 
at the sheet level. Library level changes are globally applied to each instance of a part when a 
sheet is loaded. 
This principle maintains strict data integrity in parts libraries and has been adopted by 
Advanced Schematic as the preferred model for most engineering environments, particularly 
where common libraries are shared by multiple users.
To allow for flexible use of library components, a special cache library is maintained for the 
current project. Any components used in a sheet are appended to the sheet file, each time the 
sheet is saved. This file includes a "read only" version of the library component for each part in
the sheet. The user can protect the backup library, so that it will not be updated from libraries 
when the sheet is re-loaded. The backup library allows users to exchange or supply schematic
sheet files, without having to distribute all of the component libraries used to create the design.

Component management
Component models
Management of libraries
Schematic Library Editor
Component Browser panel



Part information in the sheet file

While the component description is stored in the library, information is added to the sheet, at 
each instance when a part is placed. For example, the designator (or label) for each 
placement is part of the sheet, not a library attribute. Other sheet level attributes include 
information about the components position in the sheet, orientation, color assignments, 8 user-
definable text fields, etc.
At the same time that the part is placed in any project sheet, the library component information
for the part is added to a cache. As individual sheet files are saved, the cache information is 
used to create a backup library in the sheet.
Components are grouped in libraries, by the component type or manufacturer, for 
convenience.

Change process



Components

Each component library consists of three general types of data:

        Graphical representations of each component part;

        The descriptions of component, including component text fields and other attributes;

        A separate listing of component names associated with the component attributes and 
graphics.

Place Parts process
Run Library Editor process
Edit Component from Browser process



Graphical representation of components

Parts are graphical representations of components, component devices, logic and generic 
devices. Some components are represented by a single part, such a resisters or diodes, etc. 
Other components are represented by multiple parts for example, TTL logic components that 
include multiple gates. In Advanced Schematic, you place each of these parts independently. 
Depending upon the component, parts can be displayed using standard ANSI schematic 
notation, the DeMorgan equivalent (for gates) and IEEE standard notation.



Part graphics

All Advanced Schematic parts use vector graphics. This means that each graphic element in 
parts is defined by its coordinates, line width, etc. -- not by a bitmap array. One key advantage 
of vector graphics is their device independence. This means that vectors can be displayed or 
printed at the highest available resolution -- resulting in smooth arcs and angles, while also 
providing a precision environment for complex graphics. Vector graphics also require less 
memory when displayed and have more compact library records.
Libraries from OrCAD SDT include display bitmap representations and vector information used
by OrCAD SDT for printing and plotting. Advanced Schematic uses OrCAD vector information 
for both display and output when these libraries are used. 
Libraries from Protel Schematic 3 are bitmap images and do not include vector descriptions. 
When loading Protel Schematic sheets, Advanced Schematic will substitute vector versions of 
any component names that match the names in Advanced Schematic libraries. Other parts, for
example user-generated parts, may exist as unique bitmaps only. These components will be 
converted to simple vector "block-type" parts when sheets are loaded into Advanced 
Schematic.

Run Library Editor process
Edit Component from Browser process



IEEE component representations

Many components in the standard Advanced Schematic libraries have IEEE equivalents. 
Protel IEEE versions are not superficial shapes, but complete component descriptions that 
reflect the comprehensive depth of this standard. 
IEEE standards allow a number of alternative expressions of component attributes, and each 
manufacturers data book varies in its presentation of IEEE components. The graphical 
descriptions for IEEE versions are fully user-editable in the Schematic Library Editor, and a 
rich set of IEEE graphical tools are included. Protel's IEEE components were compiled from a 
proprietary natural language environment that yields extremely consistent (and therefore 
useful) representations.
IEEE equivalents can be specified before or after part placement and IEEE versions can be 
globally displayed to some or all parts placed in the current sheet.

Run Library Editor process
Edit Component from Browser process



DeMorgan logic

This option can be specified before, during or after part placement and if desired these 
equivalents can be globally assigned to some or all logic devices placed in the current sheet.

Run Library Editor process
Edit Component from Browser process



Parts of a component

Along with graphical depictions, libraries store a number of other component attributes. These 
attributes are all editable at the library level only -- not after parts are placed in schematic 
sheets.

Update Parts from Library process

Cross Probe Part (PCB) process
Increment Part Number process



Text fields

Each library component has 8 user definable text fields. These fields can hold up to 255 
characters. Library text fields cannot be edited from placed parts in schematic sheet files, but 
can be included in custom Bill of Materials reports.

In addition to the 8 library component text fields, 8 additional user-definable fields are available
for each part, at the sheet level. These fields can be displayed or hidden (click Hidden Fields 
in the Change Component dialog box) and are editable in the sheet, with user definable fonts, 
sizes and colors. These fields can be up to 255 characters long and are available for Bill of 
Materials reports.

Run Library Editor process
Edit Component from Browser process



Footprint

Four fields are provided for naming PCB footprint patterns for the component. The first field is 
the default value and will be used in (Protel format) netlist generation. Four fields allow the 
user to nominate alternate patterns for SMD versions, etc.

Run Library Editor process
Edit Component from Browser process



Description

A description field of up to 255 characters is provided for part value or similar information. This 
field is displayed in the component browser when placing parts in the Schematic Editor and 
can be included in custom Bill of Materials reports.

Run Library Editor process
Edit Component from Browser process



Default designator

A default designator prefix can be stored with each library item. When components are placed,
designators will automatically include this prefix.

Run Library Editor process
Edit Component from Browser process



Subparts

Multi-device components include graphical descriptions for each subpart. Each can be 
independently modified in the Schematic Library Editor.

Run Library Editor process
Edit Component from Browser process
Increment Part Number process



Pins

Component pins are independent electrical objects. Inside the Schematic Library Editor, the 
user can define pin names and numbers for each component part. 
There are no restrictions of pin placement relative to other component graphics -- pins need 
not be placed in any particular order nor in contact with any other component graphic 
elements (body, etc.) to be functional.

Run Library Editor process
Edit Component from Browser process



Hidden pins

Any pin can be defined as hidden. Normally, hidden pins are used for component power nets. 
These pins are deemed to be connected to the named power nets during netlisting, assuming 
that power nets with matching labels are available on the sheet. Components vary in their 
identification of power nets and it is common for labels such as VCC, PWR,    +5, etc., to be 
used interchangeably. One way to avoid missing nets is to wire variously named equivalent 
power ports together somewhere on the schematic sheet, to avoid missing hidden (and 
therefor overlooked) power nets. When pins are displayed, they are always deemed to be un-
connected and it is assumed that the user will connect these pins manually.
The Hide/Display status of all hidden pins on a part can be changed at any time. Any pin can 
be defined as hidden in the Library Editor. Normally, hidden pins are used for component 
power nets. When hidden, these pins are deemed to be connected to the named power nets 
during netlisting, assuming that power nets with matching labels are available on the sheet. 
Once displayed, pins are deemed to be un-connected until the user connects them manually.

Run Library Editor process
Edit Component from Browser process

See also
Local hidden pins



Parts on sheet

When parts are placed in schematic sheets, a number of additional attributes are available for 
editing. These attributes are associated with the specific instance of the part in the sheet only 
-- they are not library attributes. To change any part, double-click on the placed part or use the 
Edit Change command. Each editable attribute can be globally edited, which changes applied 
to some, or all of the parts on the sheet.

Run Library Editor process
Edit Component from Browser process



Part type

A part type text field is provided for component part names. This field can be up to 255 
characters long and is available for Bill of Materials reports.

Run Library Editor process
Edit Component from Browser process



Designator

Part designators can have their prefix default predefined in the Library Editor (see Default 
designator, above). The user can override this default manually, when placing or editing parts 
in the sheet. If no initial numeric value is defined for a designator prefix, it will be placed as U?,
R?, etc. Once a numeric value is used, designators will automatically increment to the next 
digit: U1, U2, etc. Complex cases for multi-device components are also supported, yielding: 
U1:1, U1:2, U2:1, U2:2, etc. Alpha a numeric designation is allowed. The File Annotate 
command automatically re-numbers all designators in a project.

Run Library Editor process
Edit Component from Browser process



Part number

A special text field is reserved for part numbers. This field can be up to 255 characters long 
and is available for Bill of Materials reports.

Run Library Editor process
Edit Component from Browser process



Library name

This field identifies the source library for the component. It is user-editable at the sheet level 
and can be included in custom Bill of Materials reports.

Run Library Editor process
Edit Component from Browser process



Colors

Part outline, pin color and (in many parts) fill colors are user selectable attributes. If parts are 
un-filled, changes made to this field will be ignored. Default colors can be assigned to each 
part at the library editor level, but these assignments can be overridden when editing placed 
parts. To apply the local (rather than default library) color, click Local Colors in the Change 
component dialog box.

Run Library Editor process
Edit Component from Browser process



About component text

Part text fields are created and stored at both the library level (when the part is defined) and at
the sheet level when the part is placed. These text fields can be up to 255 characters long.
Be aware that the length of fields used in netlists: designator (label) type (description) and package (footprint 
or decal) may be limited, may not support (empty) spaces and may be case sensitive. 
The designator, type description and other text fields created at placement can be either 
hidden or displayed and can independently moved/rotated. Displayed text supports any 
TrueType font, with user-definable size (in points), style and color. Eight text fields are 
available when creating component parts in the Schematic Library Editor. These fields cannot 
be displayed in sheet files, but can be included in expanded format Bill of Materials reports.

Run Library Editor process
Edit Component from Browser process



Opening libraries

The Library Add/Remove command    (shortcut: L, A) in the Schematic Editor is used to add 
libraries to the current open list in the Library Browser. There is no fixed limit on the number of 
libraries that can be opened concurrently.
Opening libraries is a pre-requisite to opening OrCAD files that have not been previously 
saved in Advanced Schematic format. Because OrCAD files cannot display components 
unless all libraries used in the file are accessible, opening sheet files without first opening 
libraries will result in missing components in the sheet.

Library Add/Remove process



Management of libraries

When a component part is placed in a schematic sheet, the displayed version of the part is 
only a representation of the library version. Components are edited only at the library level. 
Restricting component editing to libraries maintains strict data integrity in parts libraries.

Component cache and backup libraries
Archiving the component cache
Updating



Component cache and backup libraries

To make library access efficient, a special library cache is created as parts are placed in 
sheets. A single cache is maintained for all opened projects and this cache holds copies of 
components placed in any sheet in each project.
Each time any sheet in the project is saved, the cache is used to generate a backup library. 
This file includes a "read only" version of the library component for each part in the sheet. The 
user can protect the backup library, so that it will not be updated from libraries when the sheet 
is re-loaded. The backup version allows users to supply schematic sheet files, without having 
to distribute their complete component libraries.
It is useful to note that the cache holds copies of all the components currently "in use" in the 
environment. As you open another project, all of its components are copied from the sheet 
back-up libraries into the cache. If you remove sheets or close projects the components in 
those projects are not cleared from the cache. The cache is cleared when you exit the 
Schematic Editor. 
In extreme cases, where many sheets are being loaded during a session, it may be possible to
fill the cache to the extent where system performance begins to slow. If this happens, save 
your projects, exit the editor and re-start the application.



Archiving the component cache

A benefit of caching is the ability to archive the cache contents into a single project library. 
Because the source libraries may change over time, archiving provides a convenient way of 
being able to work with an accurate version of the project at some future date. The Make 
Project Library (shortcut: L, M) command generates a project library based on the current 
sheet back-up library.

Make Project Library process



Updating

The Library Update All Parts command updates all parts in project sheets to be updated from 
current versions of source component libraries. This command allows changes in current 
source libraries to be globally applied to each instance of a component in an entire project.

Updating Parts from Library process



Library Menus

Most of the menu commands in Library Editor match the form and function of the same 
commands in the main Advanced Schematic application. Some options are specific to Library 
Editor.

Menu Commands



File menu

        New Opens a new (empty) library file with the default name LIB_1.LIB. Any number of libraries can 
be opened at once, limited only by available memory;

        Open Opens an existing library file. The normal mask and path specifications can be used to 
screen for specific library types, by extension;

        Merge Opens a second library and adds all components to the current active library file;

        Close Closes the current library; If the library has not been saved (or saved as) the prompt 
"Save Library before closing?" will be displayed;

        SaveSaves the current active library;

        Save As Saves a renamed version of the current active library;

        Save All Saves all open library files;

        Plot/print Prints the content of the current active Library Editor edit workspace;

        Report Generates an ASCII text file report of all component type descriptions in current active 
library;

        Exit Quits the Library Editor application.

Menu Commands



Edit menu

These commands work identically to the same commands in the main Advanced Schematic 
application, applying to library rather than sheet files.

Menu Commands



Place menu

The graphical objects that can be placed from this menu (or from the Drawing toolbar) are 
identical to the same objects in the main Advanced Schematic application. Special Library 
Editor commands include:

        IEEE Symbol Places special IEEE graphical symbols in the current active library window. 
These symbols generally conform to ANSI/IEEE standard 91-1984, although some minor 
modifications have been made to symbol proportions to facilitate on-screen display and 
printing. Symbols can be placed inside or outside the component body (or outline), without 
restriction;

        Pins Places a single component pin in the current active library window. Pins are automatically 
designated, as placed. Pins can be freely placed and do not have to be in direct contact with 
the component body (or outline, as in OrCAD SDT) to be functional;

        Text Places a single line of text, similar to the Place Annotation command in the main Advanced 
Schematic application.

Menu Commands



Component menu

The component menu includes a number of special commands for library editing:

        New component Opens a new, empty component window;

        vAuto Create Opens the Auto Create dialog box. Allows user to create complex components, by 
describing pin parameters;

        Remove component Removes the current component from the current library;

        Rename Component Prompts user to supply a new name for the current component;

        Remove Comp Name Removes a component from the current group;

        Add Component Name Adds a user-specified component name to the current group;

        Copy Component Copies the current component into another library. User is prompted to supply the 
name of the destination library;

        Move Component Moves the current component into another library. User is prompted to supply the 
name of the destination library;

        New Part Adds a subpart to the current component;

        Remove Part Deletes a subpart from the current component;

        Component Next Part/Previous Part -- toggles through the subparts for the current component. 
Next/Previous/First/Last component -- toggles through components in current 
library;

        Show Normal Toggles to Normal representation of part;

        Show DeMorgan Toggles to DeMorgan equivalent representation of part;

        Show IEEE Toggles to IEEE representation of part;

        Description Opens the Component Text Fields dialog box. User can specify a type Description, 
Default Designator (e.g., U? will generate incremented designators U1, U2, etc.), 
Footprint (e.g., decal or pattern) 1-4 (used to specify pattern for netlist), Text Fields 
1-8 (user-definable text, up to 255 characters per field) -- can be added to Bill of 
Materials (expanded format).

Menu Commands



Options Zoom Windows and Help menus

These menus and commands work identically to the main Advanced Schematic application: 
applying to library rather than sheet files.

Menu Commands



Tool buttons

Tool buttons are shortcuts for launching frequently used menu commands. Advanced 
Schematic includes a main toolbar, across the top of the workspace and floating toolbars, 
which the user can position anywhere in the workspace. All toolbars can be hidden. Each 
toolbar-launched process is available from menus, if preferred.

        Main toolbar This toolbar include a number of general purpose commands, such as File Open, Print 
and Zoom-In, Zoom-Out and Zoom-Sheet. Other buttons are provided for toggling the 
show/hide status of other toolbars and panels.

        Drawing tools Drawing tool buttons provide access to the Place commands for graphical objects: lines, 
text, ellipeses and arcs, rectangles, etc.

        Wiring tools Buttons on the Wiring toolbar provide access to the Place commands for electrical 
objects: wires, buses, bus entries, components, junctions, etc.

        IEEE tools Buttons on the IEEE toolbar provide direct access to IEEE graphical symbols used in 
component creation (Schematic Library Editor).

        Library tools This tool bar includes a special collection of tools used during component creation 
(Schematic Library Editor).

Toggle Main Toolbar process
Toggle Library Toolbar process
Toggle IEEE Toolbar process



Library Editor panel

All component editing is performed at the library level. To change an existing component, or to 
add a new component to an existing library, you must first open that library from the Library 
Editor. 
Opening a library is similar to opening a sheet file in the main Advanced Schematic 
application. Libraries can be loaded from Advanced Schematic, OrCAD SDT (in de-
compiled .SRC format), or Protel Schematic 3.x (.LIB binary format). 
The File New command (shortcut: F, N), opens an empty library named LIB_1.LIB. If the File 
New command is repeated, a second library named LIB_2.LIB will be opened, etc. Each 
library will open in its own window, with the library name displayed in the Title Bar. If you save 
a library in Protel (ASCII) text format, the default extension .ASC is used. Loading and saving 
of libraries is independent of the file extension used. Users are free to use any extension of up
to three non-reserved characters.
Using the Library Editor is a straightforward process of loading a current library (or creating a 
new library file), searching for existing components and editing those components and their 
parts or creating new components from scratch. This process can be accomplished totally 
from within the Library Editor. You can place new components directly into any open sheet 
from the Library Editor.
When a library is loaded, all component names are listed in the Components window. You can 
view component parts (each device included in the component record) by moving the selection
bar through this list. The four buttons, just below this window allow you to scroll through the 
entire library. The leftmost buttons move up the component list one item at a time; the left 
center button moves to the top of the component list; the right center button moves to the end 
of the list; the rightmost button moves down one component. 
The Group window, to the right, displays the names of other components in the current library 
that share the same component description as the highlighted component name, at left. The 
Add and Delete buttons, just below the Group window are used to add a new component 
name to the current group or delete a component name from the current group.
When a component is deleted from a group, it is removed from the library. 
The Component New Component command (shortcut: ALT C, N) adds a new component 
name, (COMPONENT_1) to the current library. If the command is repeated, a second 
component name, COMPONENT_2 will be added, etc.

Library menus



Creating new components

Components are created in the Library Editor workspace similarly to the same way that 
schematics are created in sheets. The main difference between these two activities is that the 
tools used vary with either task. For example, library components to not incorporate wires, 
buses or sheet entries but they do include pins, which are not placed in the sheet editor.
A component description -- the actual record in the library including the graphical 
representation of one or more component parts -- is independent of the name or group of 
names assigned to that description. It is the complete description that is the library entity, not 
the component name field(s).
When you use the Component New (Component) command, a name is added to the list for 
the current library, irrespective of whether you have created a description for that name. You 
can save even libraries with names of components that are not linked to any description. 
When you load these libraries, choosing these names in the component list box will open an 
empty workspace.
Advanced Schematic components can have any number of pins or parts, restricted only by the
memory available to handle the individual item. Library workspace, where components are 
graphically created is limited to a "B" size sheet. The user can exercise absolute freedom in 
terms of the placement of pins, vector objects and even graphical objects (including bitmap 
formats). Pins do not have to be in contact with the component "body" as in other systems in 
order to function.
Using imported graphic images in components is allowed, however it is important to note that 
the graphic record is not stored "in" the library -- rather the library entry "points" to the filename
for the graphic. If the path to the graphic object record file changes, Advanced Schematic may 
not be able to display the item.



Component Description fields

The Component Description command opens a dialog box that allows the user to edit 
additional fields that correspond to the graphical representation of a component's parts. Fields 
include:

        Description This field is provided to assign a name or component type description to the library 
entry. This description is displayed when you use the Library Browser as an aid in 
placing component parts in sheets. The description can be up to 255 characters in 
length and can be included in Bill of Materials reports.

        Default Designator This field is provided to assign a default designator prefix (U?, R?, etc.) to the 
library entry. The designator is numerically incremented as component parts are 
placed in sheets. The description can be up to 255 characters in length and can be 
included in Bill of Materials reports.

        Text fields (8) These fields are provided for any user-defined text, up to 255 characters in length. 
These fields can be used for manufacturer part numbers, house part numbers, 
price or substitution data, specifications, etc. This text is not displayed nor editable 
from the Schematic Editor but can be included in user-defined Bill of Materials 
reports.

        Footprint fields (4) These fields are provided for assigning up to four package description footprints (or
decals) for the component. This data is used for netlist generation. The first field is 
the default.

        Sheet Part This field allows the user to assign component pin names to nets in other 
hierarchical sheets. The component then operates as though it were a sheet 
symbol, with the pins acting as sheet entries. To connect to the other sheet, ports 
with that sheet name must be present in another sheet in the project.



Component Browser panel

The Component Browser is provided as an aid in searching for, and placing component parts 
into sheets during schematic editing. This panel can be displayed as needed or hidden, to free
additional workspace.

Library Add/Remove
Adding libraries to the current list



Library Add/Remove

The Library List command is used to add or remove component libraries from a current 
internal list maintained by Advanced Schematic. Holding this list in memory speeds library 
access, when placing parts in schematic sheets. 
When loading OrCAD SDT files, the required libraries must first be loaded into the current 
library list, prior to loading these files, or components will be missing from the sheets. This is 
not true for Advanced Schematic files, which have a cached back-up library of components 
used in the sheet, attached to each file.



Adding libraries to the current list

To add a library to the current library list, choose Library List (shortcut L, L) or click the Library 
List tool button on the main toolbar.
The Library List dialog box opens. Features of this dialog box include:

        Current File List This window lists all currently loaded libraries and is updated as libraries and 
added or removed from the list.

        File Name This window lists the name of the highlighted library from the Files window, described 
below. You can type the desired library name, if known, directly into this window. The 
current path and directory are also shown.

        Files This window lists files in the current directory that match the current file mask used in the
File Name window. You can use this feature to specify the file type, by extension. 
Advanced Schematic does not restrict the use of extensions to identify library types. 
OrCAD SDT 3/4 libraries (in decompiled .SRC format), Advanced Schematic and Protel 
Schematic 3.x libraries can be loaded.

        Directories This window changes the current path and directory as you search for the desired library.

To add a library to the current list, move the selection bar through the files listed in the Files 
window and click the Add button. The library will be added to the Current File List window. 
To remove a library, move the selection bar through the Current File List and highlight the 
desired library, then click Remove. 
Click OK to close the Library List window and re-set the updated library list.



Configuration

Managing the configuration of your Advanced Schematic installation is covered under the 
following topics:

About Preferences
Sheet options
Workspace options



About Preferences

Advanced Schematic stores many user settings, such as printer/plotter setups, display colors, 
and many other options in a special file called SCH.INI that is automatically added to the 
Windows directory, the first time that you Exit the application. Thereafter, SCH.INI is updated 
each time you exit the application. When you start Advanced Schematic, the program looks for
this file and your preferred settings are restored. Other settings belong to a specific workfile, 
such as the current sheet and color assignments used when the schematic file was created. 
When you re-load any schematic file, these settings are restored. If you select File New, the 
normal system defaults or (where applicable) user preferences are restored.
Managing Preferences
You can restore all original (system) default settings by deleting the Advanced Schematic 
SCH.INI file from the Windows directory. You can keep more than one .INI file (with different 
settings for different types of projects) by temporarily re-naming the file, or by moving it into 
another directory. For example, you might wish to create a directory that includes all 
documents for a project with a special .INI file.

Workspace options
Other preferences



Sheet options

The Options Sheet dialog box is used to assign colors to the sheet and sheet border/title 
block. These assignments are saved with the sheet and are also used as defaults when a new
file is created.



Workspace options

The Options Preferences command is used to set-up the workspace design environment.
Options dialog box
Workspace colors
Saving default settings
Auto Backup
Grid options
Other preferences



Workspace colors

Colors can be assigned to workspace display elements. 
The Options Preferences dialog box is used to assign colors to selections and the visible grid. 
These assignments are saved as system defaults in the SCH.INI and LIBEDIT.INI files.

Sheet Options process



Other preferences

Along with color assignments for the workspace, the Options Preferences command (shortcut:
o, p) sets-up a number of environmental conditions for Advanced Schematic. Options include:
Cursor Shape
Visible Grid
Auto Pan
Question Delete
Snap to Center 
Save Defaults
OrCAD Port Length
Drag Wires
Auto Backup

See also
Preferences
About Preferences



Schematic Editor workspace

This section describes the workspace for schematic/library design.
Sheets

When you choose the File New command, an empty sheet is displayed. This is where your 
design is displayed. Sheet windows are titled with the current path and file name, if any.
Borders

Protel provides two default borders. Use either the standard border or the ANSI standard 
border that follows the ANSI reference grid convention (for additional information, please refer 
to ANSI standard Y14.1-1980). You also have the option to turn-off the supplied border and 
use Advanced Schematic's drawing tools to create a custom border. You should be aware that 
not all devices can print all the way to the edge of the page. This can make it impossible to 
include all of the standard or ANSI borders when printing at 100% scale. You can change the 
print scale to accommodate the maximum printable area of your printer.
Title block

Protel provides two default title block formats. You can use the either standard title block or the
ANSI standard title block that is somewhat larger. Some of the information in the title block is 
provided automatically, e.g., the sheet size, file name and creation date. Other information can
be added using the Place Annotation and Place Text Frame commands. You also have the 
option of hiding the supplied title block and use Advanced Schematic's drawing tools to create 
a custom title block.

Library Editor workspace
Coordinate system
Sheet navigation
Changing your view of the sheet
Cursor control
Grids
Sheet Options process



Choosing a sheet size

Choose the Options Sheet command to open the Sheet Options dialog box to choose from 
one of the available sheet sizes or define a custom sheet.
Advanced Schematic allows you to choose from 10 standard imperial and metric sheet sizes, 
or to define a custom sheet size up to 65 inches (1650 mm) square.
Schematic sheets are conventionally displayed and printed in "landscape" (wide) rather than 
"portrait" (tall) orientation. Advanced Schematic allows you to display and print your drawings 
in either orientation. 
The maximum available work area in a sheet (with the border hidden) will depend upon the 
target device. Many printers and plotters cannot print to the edge of the sheet, so some trial 
and error may be necessary to determine the exact available work area. Because of this, the 
standard ANSI and ISO border specifications cannot be applied when targeting these devices. 
Advanced Schematic can compensate for this by allowing you to scale the output during 
printing or plotting.
A smaller work area will be available when sheet borders are displayed. The default sheet 
boarder removes .2 -- .4 inch (approximately 5 - 10 mm) from the working area, depending 
upon the sheet size selected.

Sheet Options process



Library Editor workspace

The Library Editor environment is very similar to the Schematic Editor. However, the Library 
Editor does not use standard or user defined sheet sizes. A standard library workspace area is
provided. This is equal to a "B" size sheet and can be oriented in either landscape or portrait 
orientation. You can print the current contents of the Library workspace(s), using the File Print 
command.

See also
Schematic Editor workspace



Coordinate system

To provide an absolute spatial reference as you work in the Schematic Editor and Library 
Editor, a coordinate system is linked to the workspace cursor and to the reference point of 
each placed object.
Coordinates are displayed at the left end of the status bar and in each object's Change dialog 
box. Some object Change dialogs list coordinates for individual vector or control points.
Each coordinate unit is equal to .01 inch (.254 mm). The absolute 0,0 coordinate or workspace
origin is at the extreme lower left corner of the sheet (or Library Editor workspace). The range 
of coordinate units is 0-6500.
OrCAD SDT and Protel (DOS) Schematic origins are located at the top left corner of the 
workspace. Objects coordinate from these systems are converted in Advanced Schematic 
units, when the files are opened.

Toggle Snap Grid process
Toggle Visible Grid process



Sheet navigation

This section describes how processes and process launchers allow easy navigation of the 
sheet.

Search For
Jump
Using Location markers



Search For

The Edit Search For command allows you to conveniently locate a specific component, net or 
text string without having to zoom, pan or scroll through multiple screens. Search For 
commands include:

        Component Type the designator in the Search For dialog box. If you do not know the 
designator, type ? and press ENTER or click LEFT MOUSE to scan the board for 
all placed components; Choose from the Components Placed dialog box.

The cursor will jump to the center of the reference pin (usually pin 1 or A1) of the selected 
component.

        Net Type the net name in the Search For dialog box. If you do not know the net, type ? 
and press ENTER or click LEFT MOUSE to scan the board for all nets; Choose 
from the Nets Loaded dialog box.

The cursor will jump to the nearest pin that belongs to the selected net.

        Pin Choose a placed component to open the Jump to Pin Number dialog box; Type the
pin number. The cursor will jump to the center of the named pin.

        String Type the target string in the Jump to String dialog box.

The cursor will jump to the named string. This option works with free text strings only -- not 
component text strings. The system will perform three searches:
First -- for a string that matches the specified string in both case, characters and length;
Then -- for a string with same characters and length but ignoring case;
Finally -- for a string with a partial character match (and ignoring case). 
For example, typing "Component" would find the string "Component" first. If no match is found 
it would next find the string "CompONENT" and finally "CompONENTs." When the string is 
found, the cursor will be relocated to the specified string.
With all of these options, Advanced Schematic will only re-draw the screen if the search target 
is off the present screen. When a re-draw is needed, the target will be centered in the active 
window.

Search for Net
Search for text
Search for And Replace text
Search for next instance of text



Jump

The Jump command options allow you to quickly move the cursor to a pre-determined 
coordinate. This can save you from having to constantly zoom in and out to navigate around 
your design and is particularly useful for large or complex layouts. 
Origin

        Jumps to Origin Jumps to the absolute (0,0) coordinate. In the Advanced Schematic system, this 
is the lower-left corner of the workspace (see "Setting a new origin," below).

        New Location This option allows you to type in the desired coordinates for the jump. 

Type an X coordinate (a distance from the left hand side of the work space), the default is the 
current X position. Type the desired location and press ENTER or LEFT MOUSE. 
Type a Y coordinate (a distance from the bottom of the work space), the default is the current 
Y position. Type the desired location and press ENTER or LEFT MOUSE. The cursor will now 
be moved to the specified location.

Jump Location process
Jump Origin process
Jump to Error Marker process



Using Location markers

Ten user-definable location markers are provided, which allow the user to move to a pre-
determined position in each sheet, with a single command. These markers can be placed in 
the sheet at any time, using the Place Location Mark command. The coordinates are stored for
each of ten locations.    
When any of the location markers have been set by the user (see above), the Edit Jump 
command can be used to re-draw the screen at the center of the pre-set location. The current 
zoom setting remains unchanged when jumping, so it may be desirable to zoom-in prior to 
jumping to the new location.

Set Location Mark process
Jump Location Mark process



Jumping to locations

    
Jump Location process
Jump Origin process
Jump to Error Marker process



Changing your view of the sheet

As you click to move from document window (sheet) to window, you are moving the focus of 
the Windows environment. This also happens when you click in another application window to 
make that application active. The current focus determines the way that Advanced Schematic 
tools and features affect your design. One example is the way the current window is affected 
by scroll bars, panning and zooming.

Scrolling
Auto Pan
Zoom commands
Interrupting screen re-draws
Special navigation keys



Scrolling

Note the shaded bars along the right and bottom sides of the sheet window. Mouse users can 
use scroll bars to move horizontally or vertically in document windows. The position of the 
scroll box in the scroll bar indicates the relative position of the displayed portion of the 
document inside window. Drag the buttons to scroll in real time. Click over or under the button 
in the shaded area to scroll the visible portion of the screen with each click. Finally, click the 
arrow buttons at the end of the scroll bar to scroll one unit at a time. You can hide or display 
toolbars by using the Options Scroll Bars command.
Whenever the document window is sized to display the entire sheet (or library workspace), the
scroll bars are automatically hidden, to provide a wider viewing area. 



Auto Pan

When the Options Preferences Auto Pan feature is enabled, your view of the current window 
will automatically pan up-down-left-right as you place, move or draw objects in the sheet. 
Panning takes place when the cursor reaches the edge of the display when placing, moving or
re-sizing objects.

About Preferences



Zoom commands

The Zoom menu commands (and associated shortcuts) also affect your view of the current 
sheet window. You can set the zoom to view the entire sheet (up to 65 inches square) or zoom
all the way in, to about a 4X magnification.
The Zoom command takes advantage of an 8087 (or equivalent) numeric co-processor, if 
present in your system. In some modes, zooming will be faster if you have an add-in co-
processor or a 486DX system.
Three zoom command shortcuts are provided: Pressing pgup    increases the screen 
magnification to the next highest level. Pressing pgdn will decrease the magnification to the 
next lowest level. Pressing shift+pgup will increase magnification in 0.1 increments; shift+pgdn
will decrease magnification the same amount. Pressing ctrl+pgup will zoom to the highest 
magnification; ctrl+pgdn is equivalent to Zoom All.

Menu Commands



Interrupting screen re-draws

Whenever you change the size and/or position of your view of the screen, the contents of the 
workspace will be re-drawn to reflect the change. You can terminate the re-drawing process by
pressing SPACEBAR anytime when the re-draw is in progress. This saves time whenever you 
wish to immediately scroll or zoom again, without waiting for the re-draw to complete.



Special navigation keys

        PGUP Equivalent to the Zoom In command. Press SHIFT to Zoom at smaller intervals.

        PGDN Equivalent to the Zoom Out command. Press SHIFT to Zoom at smaller intervals.

        HOME Re-centers the screen at the current cursor position.

        END Re-draws the screen at the current cursor position.

        Arrow keys Control the cursor, alternative to using the mouse. Once click moves the cursor one snap
grid unit (default is .10 inch). 

        SHIFT + arrows Move cursor at 10X snap grid units per click.



Cursor control

The cursor is the special pointing object that allows you to navigate Windows and Windows 
applications. When running Advanced Schematic, two basic cursor types are provided:

Windows cursor
Workspace cursor



Windows cursor

The familiar "pointer" cursor is used for all standard Windows operations, such as choosing 
from menus and dialog boxes. This cursor shape is automatically selected when the edge of 
the document window (workspace) is crossed, as when re-sizing the window, making menu, 
dialog box or toolbar selections.



Workspace cursor

Inside the workspace, the pointer (Windows) cursor changes to perform object placements 
and editing. This cursor operates on a gridded system, snapping from grid point to grid point, 
when Options Snap grid is toggled "on." The workspace cursor will cause the display to pan 
left/right/up/down when the edge of the workspace is contacted -- as when moving or re-sizing
an object. Auto Pan can be enabled/disabled in the Options Preferences dialog box. This 
dialog box also provides three workspace cursor options:

        Large 90 This is a "bombsight" style cursor, useful for aligning placed or drawn object with other 
items in the sheet;

        Small 90 This is the default shape, a small cross with 90 degree orientation;

        Small 45 This shape is similar to the Small 90 option, but is oriented at 45 degrees. 



Grids

Advanced schematic provides reference coordinate units of .01 inch. These X and Y 
coordinates are displayed at the left end of the Status line. As you move the cursor inside the 
sheet, the coordinate display updates constantly to show your position. As an aid in accurately
sizing and positioning objects in sheets, two grid systems are provided:

Snap grid
Visible grid



Snap grid

The snap grid defines an array of points in the workspace that restrict cursor movement and 
the placement of electrical design objects. When using the mouse to control the cursor, you 
will notice that the cursor moves freely between snap grid points unless you are using the 
mouse to place or move a selection. When the cursor keys are used, the cursor always 
"snaps" to the grid. The default Advanced Schematic grid is 10 units (1/10 inch or 2.54 mm). 
Users can specify a grid from 1 (1/100 inch or .254 mm) to 100 units (1 inch or 25.4 mm).
If you are using the cursor keys to move the cursor, you will find that Choosing SHIFT and a 
cursor key makes the cursor jump move 10 snap grid points for each click.

Toggle Snap Grid process



Visible grid

A visible grid is provided as a visual reference for placing and moving items. The grid can be 
toggled between display and hide.
The default visible grid is 10 units (1/10 inch or 2.54 mm). Users can specify a grid from 1 
(1/100 inch or .254 mm) to 100 units (1 inch or 25.4 mm).
Options include (default) line grid and dot visible grid. These grids are displayed using the Grid
color assignment in the top of the dialog box. 

Toggle Visible Grid process



Processes

The Advanced Schematic environment, whether creating and editing sheets, or working in the 
Library Editor, consists of two basic types of elements: objects (or primitives) that describe the 
data in a design and processes, which are used by the system or the user to create, modify, 
save and report on the data objects. Objects include the sheet workspace, components, pins, 
wires, lines, graphical images, etc. Processes include menu commands and other discrete 
processes that manipulate data, such as report generators.    
Various methods of launching these processes are provided. For a detailed description of each
menu command or other process, go to Processes and click on the process name.

Process launchers



Process launchers

A process launcher is any method that the user can access to invoke a process. Various 
methods are provided:

Menus
Tool buttons
Dialog box options
Mouse and keyboard
Toolbars
Hot keys



Menus and commands

Menus provide access to all commands. Advanced Schematic menu commands are organized
to be as consistent with the Windows model as possible. This means that standardized 
operations, such as opening and saving files, printing or using standardized Windows editing 
operations such as Cut or Paste is handled in Advanced Schematic using the same methods 
that other Windows applications use. This makes an application more productive in an 
integrated environment where the typical user is working with a number of Windows 
applications. Some processes exist outside the menu command structure. These processes 
include items like poping-up menus or placing a component from the Browser dialog box. All 
processes can be assigned to key stroke combinations, using the Hot Keys dialog box.

Menu bar



Mouse and keyboard

Many processes are mapped to mouse and/or keyboard sequences. This provides convenient 
shortcuts for frequently used operations. A Hot key editing system allows the user to 
customize hot key assignments. Many generic processes (beyond menu commands) can be 
assigned. A number of default assignments are provided with Advanced Schematic.
For example, pressing P, J allows you to place a junction without having to open the Edit 
menu, then choose the Place and Junction commands. Using the LEFT MOUSE button for 
ENTER and the RIGHT MOUSE button for ESC will allow you to perform many operations 
without using the keyboard. Some keyboard commands provide the only practical way of 
performing an operation when you don't wish to move the mouse in the workspace such as 
choosing a new zoom level while moving a selection. 
If you double-click on any placed item, the Change dialog box for that item will be opened, 
allowing you to edit its attributes.

See also
Hot keys



Menu bar

The Menu bar displays the main menu commands for Advanced Schematic: File, Edit, Place, 
Library, Current, Options, Zoom, Info, Window and Help. Each menu command and dialog box
option is documented in the Schematic Editor Reference.

Short menus
Pop-up Menus



Short menus

When no files are opened, a short menu bar is available, displaying the File, Library, Info and 
Help menus.



Pop-up Menus

Advanced Schematic includes special default hot key assignments for accessing menu 
commands. For example, pressing E (when the focus is on the application window) will "pop 
up" the Edit menu. This also provides a convenient way to avoid having to press ALT to enter a
command key sequence. 
Processes are available to launch these and can be hooked to hot keys.



File

File menu commands are used to create new files, open files or entire projects, close files, 
save the current file, save the current file under as new filename, save all open files, print or 
plot the current file, export a file in a new format, generate reports for the current files or exit 
the Advanced Schematic program.



Edit

Edit menu commands are used to make changes to the current sheet window, including: Undo
or redo actions; cut, copy, paste or clear a selection; make selections of items in the window; 
de-select items; delete items; change items; move items; search for items; jump to sheet 
locations.



Place

Place menu commands are used to place graphical and electrical items in the current sheet 
document window.



Library

Library menu commands are used to browse libraries and open the Library Manager.
A comprehensive library of manufacturers components is included in the Advanced Schematic 
package. The Advanced Schematic library system also includes a complete set of commands 
for creating, editing and using library components. The user can create different component 
libraries for various uses. Multiple libraries can be opened simultaneously.



Options

Options menu commands are used to change system defaults and user preferences, display 
attributes for objects; to assign hot keys to menu commands; and to toggle display elements, 
e.g., scroll bars, on or off.



Zoom

Zoom menu commands are used to change the display area in the current document window.



Info

Info menu commands are used to check the current system status; current design statistics; 
list the components in the current sheet and list the components and pins associated with a 
selected net.



Window

Window menu commands are used to re-arrange or close all of the current open document 
windows.



Help

Help menu commands are used to open any Windows help file, direct the user to specific help 
topics and provide information about the current application.
Details about individual menu commands can be found in the Advanced Schematic Reference 
and the On-line Help system.



Toolbars

Many Advanced Schematic menu commands can be accessed from toolbars. Many of these 
tool button assignments are shortcuts for Place menu commands.
Place commands are used to create and place an object in a schematic and to create library 
components, which are special collections of objects.    Some objects, e.g., library parts are 
composed of a number of individual primitives or objects that are grouped together and 
manipulated as a single entity.
The Advanced Schematic Reference    and On-line Help system include detailed 
documentation for each tool.

Main tool bars
Wiring tools
Drawing tools
Library tools
IEEE tools



Main tool bars

The main toolbar, displayed across the top of the Schematic Editor and Library Editor 
application windows, includes a number of general purpose tools. Differences in the two 
applications reflect the special requirements of sheet level and library level editing. These fixed
tool bars cannot be repositioned by the user, however they can be displayed or hidden from 
the Options menu.

Toggle Main Toolbar



Wiring tools

Includes tools for creating and placing objects that represent the electrical elements of a 
schematic. Electrical objects are objects that work with connectivity features. 
These include wires, buses, junctions, parts. Advanced schematic recognizes the connections 
that exist when these items are graphically joined, and uses this information to generate 
netlists, maintain connections when items are moved and perform electrical rules checking.

Toggle Wiring Toolbar



Drawing tools

Includes tools for creating graphical objects, including single line text and text frames. 
Graphical objects include items that are not regarded by these connectivity features. 
Examples of non-electrical items include lines, polygons, bezier curves, rectangles, text 
frames, etc. Graphical objects are used a general purpose drawing and documentation tools 
for your schematic.

Toggle Drawing Toolbar



Library tools

The Library tools palette includes a special selection of general, electrical and graphical tools 
that support library-level component editing, including pins, arrays, text fields, etc.



IEEE tools

Included special graphical objects used when creating or editing IEEE library component 
representations.
All toolbar objects and processes can be accessed from menus, if preferred. This allows the 
user to hide the toolbars (including the Schematic Editor and Library Editor main toolbars), 
freeing additional workspace for editing sheets or components.



Hot keys

Advanced Schematic allows users to create custom hot key assignments for processes and 
save these assignments in key shortcut files, which can be saved and loaded for specific jobs.
Key assignments can be assigned to any process, not just the processes that are available 
from menu commands. Key assignments are made from the Options Hot Keys dialog box. 
Options include:
Keys
Process
Current Process
Description
Assign
Load
Save
Defaults

Setup Hot Keys process



Objects in the workspace

Your design is created by placing component parts (groups of objects that are stored as 
individual entities in component libraries) and individual objects (wires, buses, junctions, text, 
etc.) in the workspace. Not all objects are user created or placed. Some, such as Electrical 
Rule Check error markers and Special strings are generated by the system. 
The number of parts and individual objects in a schematic sheet (or project) is limited by 
available memory only (including virtual memory, supported by Windows 386 Enhanced 
mode).
For a detailed description of each data object, go to Data Primitives and click on the object 
name.

Creating objects
Special objects
Selection
Focusing on objects
Changing Objects



Creating objects

A number of different methods are provided for creating and placing objects. For example, you
can place individual part any time using the Place Part command or Part tool button.

Object tutorial -- Placing wires
Polyline behavior
Creating other objects



Object tutorial - Placing wires

Object creation is very straightforward in Advanced Schematic. Once you are familiar with a 
few basic concepts, you will be able to create the full range of objects available in the 
Schematic Editor and Library Editor applications. 
To place a wire in the current sheet window:

        Zoom in on the sheet (press PGUP two or three times) until you can see the visible grid. 
Choose the Wire command from the Place menu (shortcut: W, P or click the Wire tool 
button);

        The prompt "Select Wire Start Point" is displayed on the Status line. Note that the 
Windows, pointer-style cursor changes into a    cross hair shape. This is the workspace 
cursor and is used each time you create or move an object.

        Click LEFT MOUSE (or press ENTER) once to define a start point for the wire;

        The prompt "Place Wire" is displayed on the status line.

        Drag the wire segment in any direction. Click LEFT MOUSE (or press ENTER) to end 
this first segment of the wire;

        Note that the coordinates on the status line change as you move the cursor and the end 
of the wire and that the prompt "Place Wire" is still displayed.

        Move the cursor to continue with a new wire segment, which is extended from the 
existing segment. Click LEFT MOUSE or press ENTER again to define this segment;

        If you make a mistake, you can press BACKSPACE to remove the last wire segment. 
You can also press ESC or RIGHT MOUSE to "cancel" the current segment currently 
being placed.

        Click LEFT MOUSE again to end the segmented wire;

        Note that "Place Wire" is still displayed on the Status line. This allows you to end one 
series of connected wires and then begin a new series of wire segments elsewhere in 
the workspace without having to choose the Place Wire command again.

Place Wire process



Polyline behavior

The segmented line created when you place a graphical line, wire or bus is a single polyline 
object. If you position the pointer cursor anywhere directly over the line and click LEFT 
MOUSE again the line will change. It will now be highlighted (as a dashed line) and at each 
point where the line changes direction, a small square handle is displayed. These handles 
mark each vertex in the polyline object. If you position the cursor directly over the handle and 
click LEFT MOUSE again, you will be able to drag the vertex to a new position and the 
attached line segments will stretch. Clicking a second time anywhere on, or inside the 
boundary of a polyline object allows you to move the object to a new position. Click once again
to "release" the focus on the object. You can add additional vertices by focusing on a polyline 
object, clicking on a line segment and pressing INSERT. To remove vertices, repeat this action, 
pressing DELETE. You can also rotate polyline objects by pressing SPACEBAR as they are 
moved.
Every object that has its shape created during placement: wires, buses, non-electrical lines, 
polygons, bezier curves, rectangles, rounded rectangles, arcs and ellipses all share this 
common polyline behavior as they are placed and graphically edited.

See also
Wire/bus placement mode
Selection and Focus



Line placement mode

Advanced Schematic provides two line, wire and bus placement modes that can be selected 
by pressing SPACEBAR as you create these items. Options include two orthogonal modes 
and any angle mode.

        Any Angle Allows wire to be placed at any angle;

        90/90 Line Constrains wire placement to horizontal or vertical orientation;

        45/90 Line Constrains wire placement to 0, 45, 90, 135, 180, 225, 270 or 315 degree orientation;



Creating other objects

Other objects are created and placed similarly to wires, buses and lines. These include objects
like rectangles, polygons and arcs, ellipses and bezier curves. Some objects are predefined, 
such as vias or power ports.
For more information about creating and placing these items, see the Advanced Schematic 
Reference and Library Editor References. For more information about working with objects 
after placement, see the sections on Selection and Modifying Objects, later in this chapter.



Error markers

Error markers are placed in schematic project sheets automatically during ERC (Electrical 
Rules Check) generation. These objects cannot be placed manually. A 360 degree arc is 
placed at the site of each connective error or warning. The ERC error markers can be deleted 
from the sheet by clicking over the object with LEFT MOUSE and pressing DELETE.

Report ERC process
Jump to Next Error process



Selection and Focus

Focus and selection provide two distinct and independent methods for changing objects in the 
workspace. These two methods distinguish Advanced Schematic from other Windows 
applications where focus and selection are merged in a single operation. For example, other 
applications display graphical editing handles on each item in a selection, although graphical 
editing is limited to one item at a time.
Providing two methods of changing items simplifies the display of selections and provides 
additional control over processes to be performed on individual items and groups. For 
example, you can focus on, and graphically edit a series of selected single items, without 
changing the current selection.

Focusing on a single item
Selection
Moving items
Select and De-select commands
Selection and other Windows commands



Focusing on a single item

When you position the cursor over an item and click LEFT MOUSE it becomes the current 
focus. Only one item can be in focus at a time. This is similar to the way you can change the 
focus in Windows by clicking on an open window to make it active. Inside Advanced 
Schematic sheets, you can tell which object is the current focus, because its graphical editing 
handles, are displayed and the item is displayed in outline form. To move the focus, click on 
another item or click in a clear area of the sheet to release the focus.

Graphical editing
Handles and polyline behavior
Add a vertex or control point
Remove a vertex or control point

See also
Selection and Focus



Graphical editing

When an item is the focus, you can graphically edit its characteristics. For example, you can 
change its size or shape by dragging any of the handles. You can also move the object in 
focus by dragging the center handle (arrows). You can also use the shortcut CTRL+LEFT 
MOUSE to move an item. Finally, the item in focus can be deleted by pressing DELETE. 
Moving and deleting individual items is described in more detail under Moving items, below.

Change (Graphically) or set focus process
Change (Graphically) or move process



Handles and polyline behavior

Some design objects have special graphical editing characteristics that derive from their 
polyline behavior. For example, when you place wires, buses or graphical lines, you define a 
vertex each time the wire, bus or line changes directions. These vertices are displayed as 
handles when the item is in focus. These items can have complex shapes (hence "polyline"), 
but can be manipulated (moved, cut, copied, pasted, cleared or deleted) as a single item.
Similarly, polygons have movable vertices and bezier curves have control points which 
function similarly to vertices. 
One key characteristic that all of these objects have in common is the ability to add or delete 
vertices (or in the case of beziers, control points) from a placed item.

Change (Graphically) process



Add a vertex or control point

To add a vertex or control point to a polyline object:

        Click on a polyline object to place it in focus;

        Click on the outline (or anywhere inside a solid object). You can tell that the object is in 
focus, because it will be displayed as an outline, with the graphical editing handles 
visible.

        Move the cursor over any line segment. Click on the segment and press INSERT;

        A handle, representing the new vertex (or control point) will be displayed under the 
cursor.

        Drag the handle to define the shape of the polyline object.

Change (Graphically) process



Remove a vertex or control point

Sometimes you will want to remove a vertex (or control point) handle when reshaping a 
polyline object. To remove a vertex to control point:

        Click on a polyline object to place it in focus;

        Click on the outline (or anywhere inside a solid object). You can tell that the object is in 
focus, because it will be displayed as an outline, with the graphical editing handles 
visible.

        Move the cursor over any handle. Click LEFT MOUSE to grab the handle;

        The handle will be free to move, under the cursor.

        Press DELETE to remove the vertex (or control point).

Change (Graphically) process



Selection

In Advanced Schematic, individual items can be edited one at a time or you can designate 
groups of items to be changed together.
Selection is performed on both individual items and groups of items and is generally used with 
clipboard operations: copy, cut, paste and clear. Selection also works with Advanced 
Schematic's global editing feature, which can apply global edits to selected or unselected 
items only.
Unlike focus, selection does not display an object's graphical editing handles. Items are 
selected, added to a current group of selected items or removed from the current selection 
using a variety of methods. The simplest method is to move the cursor over an individual and 
press SHIFT+LEFT MOUSE. This adds the item to the current selection. Pressing 
SHIFT+LEFT MOUSE again will remove the item from the selection.
Items can be added to (or removed from) the current selection either singly or in groups, using
both menu commands and mouse/keystroke shortcuts. Once selected, items can be moved, 
grouped, un-grouped, exported to another file, cut, copied, pasted into another window or 
location in the current sheet window or cleared.

Selection and highlighting
Making selections
Selection and Focus
Select and De-select commands
Toggle Selection
Using the clipboard - Cut/Copy/Paste
Moving items
Selection and other Windows commands
Importing selections



Selection and highlighting

When you select an object, its outline color changes from its normal layer color to the 
Selection color (default black) assigned from the Options Preferences dialog box. The item 
remains selected until you remove it from the selection using either the De-select command or
the SHIFT+LEFT MOUSE shortcut.
Highlighting is related to selection but works within an operation, such as re-routing a wire or 
when generating a netlist. You can see wires highlight during both of these processes. As 
objects highlight, you will notice that highlighted item is not displayed in the Selections color 
but is temporarily outlined in black.
Both selection and highlighting are based on the geometry of objects in the workspace. In 
other words, physically connected items are included in the selection. This allows you to use 
selection to trace the connectivity of your design -- like a "continuity" check as you manually 
route connections and to perform other selection-based operations, such as Cut, Copy or 
Paste. 
Selection is very powerful, but can cause unexpected results, because items remain selected 
until de-selected. Use the Edit De-Select All command (shortcut: x, a) to clear the current 
selection before you begin a "new"process that uses selection. If you forget to de-select, use 
the Edit Undo command to step back to the point of the unintentional result (see below).



Making selections

Selections are made using one of three methods:

        Use direct selection: SHIFT+LEFT MOUSE to add or delete individual items to the 
current selection;

        Use the Edit Select, De-select and Toggle Selection commands to define the objects in a
selection;

        Use the Change dialog boxes to change the selection status of a single object or of a 
group of objects, by using global editing.

Because items remain selected until they are de-selected, you can combine these methods.
A fourth method achieves the effect of selection without changing the selection status of the 
items involved:

        Choose a process, like the Edit Cut command, then select a single target item for that 
action.

This method, allows you to perform selection-oriented processes on single items, without 
requiring pre-selection.

Using the mouse and keyboard



Direct selection using the mouse and keyboard

Direct selection is the most flexible way to designate one or more items to be moved, copied, 
cut and pasted into a new location or deleted. To select one item at a time:

        Hold down SHIFT and click LEFT MOUSE with the cursor position over an item;

        The item will be re-drawn in the Selection color (see the Options Preferences command).
You can do this repeatedly, each time adding another item to the current selection.

        If you hear a "beep" or nothing appears to be selected, try zooming in closer (press 
PGUP) and make sure that the cursor is directly over the item you wish to select.

        The Snap to Center option (Options Preferences command) will cause the cursor to 
"snap" to the nearest object, when making the selection. This can make it easier to 
select items from a dense layout, or when zoomed out from the drawing.

        To add another item to the current selection:

        Hold down SHIFT and click LEFT MOUSE over another item;

        To release individual items from the selection:

        Hold down SHIFT and click on any selected item.

        When released, the item will be re-drawn in its original (layer) color. Other selected items
remain selected until they are either individually released (SHIFT+LEFT MOUSE) or until
an Edit De-select command is executed.

        You can use the Zoom commands (and hot key shortcuts PGUP and PGDN) at any time 
when making or releasing selections.



Moving items

Items can be moved individually whenever they are the current focus -- that is, whenever you 
position the cursor over an item and click LEFT MOUSE to display an object's graphical 
editing handles. Click again and the object will be free to move. A final click will place the 
object at the cursor position. 

Moving or deleting one object
Moving selections
Rotating selections

What gets moved?
Bring to front, Send to back



Moving or deleting one object

Note: the special Move Handle, illustrated in the User Guide and Reference manuals is 
no longer displayed when objects are in focus.
To move a single object:

        Move the cursor inside the object and click LEFT MOUSE once to focus the item and 
display its handles;

        Move the cursor anywhere inside the object and click LEFT MOUSE again;

        Drag the highlighted object to a new location;

        Note that the status line displays the reference coordinates of the object during the 
move. Items will "snap" to the snap grid during the move. You can rotate or flip most 
objects during this kind of move (see also, Move Selection, below). To rotate an object 
90 degrees press SPACEBAR. To flip the object along its vertical axis, press X. To flip 
the object along its horizontal axis, press Y.

        Click LEFT MOUSE to complete the move. To clear the object from the sheet, simply 
press DELETE while the item is in focus.

        You can click LEFT MOUSE on an empty area of the sheet to remove the focus from the 
object.



Moving selections

The Edit Move Selection command (shortcut: ALT m, s) allows you to move a complex 
selection as a single entity.
Moving selections within a routed schematic can sometimes produce unexpected results. For 
example, if a part is partially within a selection and some wires connected to it are inside the 
selection, then the wires will be dragged off the part during the move, possibly undoing the 
connective integrity of the drawing. Use the Undo and Redo commands to recover from an 
unitended change.
A complex selection containing many items can be moved as a single entity. When you select 
a Move command the current cursor location becomes the reference point for moving. This 
process is performed using the Edit Move options:

        Choose Edit Move Selection (shortcut: E, M, S);

        You will be prompted "Select Reference Point"

        Position the cursor at a convenient referen ce point and press ENTER or LEFT MOUSE;

        The reference point will be used to provide a convenient way of aligning the selection 
when completing the move. The selection will be highlighted and free to move. Note how
the cursor maintains its relative position to the selection

        Move the selection to a new location and press ENTER or LEFT MOUSE;

        You will again be prompted "Select Reference Point."

        Select another reference point to move the selection to another location or press ESC or 
RIGHT MOUSE to leave this command.



Rotating selections

While moving a selection, you can rotate it around the cursor and flip it along its x or y axis 
using the following hot key shortcuts: 

        SPACEBAR each press rotates the selection 90 degrees clockwise.

        X flips the selection along its X axis;

        Y flips the selection along its Y axis.

Note: Many individual items need not be selected in order to be rotated. Focus on a single 
object (component, symbol, etc.) and click a second time to move the object. The commands 
listed above are effective for most objects.



What gets moved?

If one end of a wire is inside the selection rectangle, only that end will be moved. If the center 
of pins and junctions fall within the selection, the whole item will be selected with the selection.
Wires or parts are only moved if they lie entirely within the selection. If a part with wires is 
partially within a selection and some wires connected to it are completely within the selection, 
then the wires will be dragged off the part damaging the connective integrity of the schematic 
layout.



Bring to front, Send to back

Graphical objects can be placed in sheets so that they overlap. When you place a new item, it 
is placed at the "front" of other items, by default. When you move items, they retain their 
position in the display, relative to other overlapping items. Four special move commands are 
provided for changing the "stacking" order of items in the display:

Bring to Front
Send to Back
Bring to Front Of
Send to Back Of



Select and De-select commands

The Edit Select commands allows you to select all items inside or outside of an area, all items 
in one sheet, or all objects. You can also select by net or physical connection. These options 
allow you to extend the selection (or de-selection) beyond a few items. 
Edit De-Select provides the same options, less the Net and Connection commands. These 
commands are used to define complex selections that can be moved, copied or deleted, etc. 
as a single item. The Edit Toggle Selection command allows you to turn the selection state of 
individual objects "off" or "on" which duplicates "direct" selection performed using 
SHIFT+LEFT MOUSE, described above. Shortcut: press X to choose from the De-Select 
options.
Select and De-select commands include:

Inside Area
Outside Area
All
Net
Connection
Toggle Selection



Importing selections from another schematic

Any part of a schematic sheet can be imported into another schematic file. This is done by: 

        Opening a new file document window (File Open Sheet command);

        Using the Edit Copy command to copy the file (or a selection of the file) into the Protel 
clipboard;

        Using the Edit Paste command to add the file (or selection) to the current schematic.

        The imported selection will be displayed with the cursor positioned at the pre-defined 
reference point. The selection can be moved, rotated or flipped during placement. The 
following section, "Moving a selection," describes the process of positioning a selection 
in the workspace.

        When a selection has been added to the current layout, any duplication of existing part 
designators (U1, R1, etc.) is left unresolved. The File Annotate command can be used to 
automatically resolve all duplicate designators in the sheet.



Selection and other Windows commands

As illustrated above, standard Windows commands, such as Cut and Paste, can be used to 
manipulate a selection. These commands work with the internal Advanced Schematic 
clipboard that operates like the standard Windows clipboard. 
For example, the Edit Cut command (shortcut: SHIFT+DELETE) will copy a selection to the 
clipboard and remove the selection from the workspace, and the Clear command simply 
deletes the current selection and no copy of it is retained in the clipboard.
Under Windows each application has its own range of supported clipboard formats. The 
internal Protel clipboard is not the same as the clipboard used by other Windows applications. 
This is because the Protel clipboard stores object attributes, such as net assignment, that are 
not supported in other Windows applications. However, you can generally Copy or Cut text 
from another application and Paste that text into Text frame (text) windows.



Using the clipboard - Cut/Copy/Paste

Cutting a selection
Clipboard Reference option
Copying a selection
Pasting a selection
Clearing a selection
Delete
Place Array



Cutting a selection

The Edit Cut command clears the current selection from the workspace and copies it to the 
Advanced Schematic clipboard. The Edit Paste command can be used to place the selection 
back into any open Advanced Schematic sheet window.
Advanced Schematic uses its own internal clipboard format for graphical selections, not the 
standard Windows clipboard.
To cut the current selection from the active window:

        Make sure that the current selection includes only those items you wish to cut;

        Use the shortcut SHIFT+RIGHT MOUSE to add items to the current selection or to de-
select any selected items.

        Choose Edit Cut (shortcut: SHIFT+DELETE);

        You will be prompted "Select Reference Point." A reference point is a coordinate relative 
to the selected item(s). When you paste the selection, the reference point will locate the 
cursor at this same relative position, allowing you to accurately position the selection.

        The clipboard holds the last selection only, each time you use the Cut command, you 
overwrite the previous selection.

        Position the cursor at the desired reference point and click LEFT MOUSE or press 
ENTER.

        The selection will be cleared from the display and copied to the clipboard

        When using a mouse, the cursor is not "tied" to the current snap grid. However, when 
you designate a reference point during Cut or Copy, the grid point nearest to the cursor 
will be used.

Cut process



Clipboard Reference option

The Options Preferences dialog box includes a Clipboard Reference option which 
enables/disables the (default) process that prompts the user to designate a reference point 
when using the Edit Cut and Edit Copy commands.
The reference point pre-sets a cursor position for placing/moving the clipboard contents back 
into a sheet.



Copying a selection

The Edit Copy command copies the current selection to the (internal) Advanced Schematic 
clipboard (not the standard Windows clipboard). The Edit Paste command can be used to 
place a copy of the selection back into any open Protel document window.
The clipboard holds the last selection only, each time you use the Copy command, you 
overwrite the previous selection. 

        To copy the current selection from the active window:

        Make sure that the current selection includes only those items you wish to copy;

        Use the shortcut SHIFT+LEFT MOUSE to add items to the current selection or to de-
select any selected items.

        Choose Edit Copy (shortcut: CTRL+INSERT);

        You will be prompted "Select Reference Point." A reference point is a coordinate relative 
to the selected item(s). When you paste the selection, the reference point will locate the 
cursor at this same relative position, allowing you to accurately position the selection.

        Position the cursor at the desired reference point and click LEFT MOUSE or press 
ENTER.

        The selection will be copied to the clipboard.

        When using a mouse, the cursor is not "tied" to the current snap grid. However, when 
you designate a reference point during Cut or Copy, the grid point nearest to the cursor 
will be used.

Copy process



Pasting a selection

The Edit Paste command can be used to place the current clipboard contents into any open 
Protel document window. Advanced Schematic has its own clipboard format. The standard 
Windows clipboard is not used.
To copy the current selection from the clipboard:

        Choose Edit Paste (shortcut: SHIFT+INSERT);

        You will be prompted "Select Location to Place Selection" and a highlighted outline of the
selection will be displayed. The cursor position relative the selection is determined by the
Reference Point designated when Cut or Copy was used to add the selection to the 
clipboard

        Position the selection in the workspace and click LEFT MOUSE or press ENTER.

        You can repeat the Paste command to duplicate the selection.

        When a selection has been added to the current layout, any parts that have been added 
will be not be re-designated to avoid duplication of existing designators. Resolving 
duplicate designators is done using the File Annotate command.

Paste process



Clearing a selection

The Edit Clear command deletes the current selection from the workspace without copying it 
to the clipboard.
To clear the current selection from the active window:

        Make sure that the current selection includes only those items you wish to clear;

        Use the shortcut SHIFT+LEFT MOUSE to add items to the current selection or to de-
select any selected items.

        Choose Edit Clear (shortcut: CTRL+DELETE).

The selection will be cleared from the display. Use the Edit Undo command (shortcut: 
ALT+BACKSPACE) to restore the cleared selection.

Clear process



Delete

Using the Edit Delete command is similar in many ways to using selection and the Cut or 
Clear command described in the previous section. However, with Delete, you simply the 
cursor over the item, click LEFT MOUSE and it is deleted from the sheet. If you "miss," the 
system will simply "beep" allowing you to try again. This provides an efficient way to clear 
several objects from the layout. 
Unlike the Edit Clear command, Delete is independent of selection. In other words, the current
selection is not discarded when you use the Delete command. 
If the Question Delete option is enabled (Options Preferences dialog box), the warning 
message "Confirm Delete will be displayed as you select each deletion. 
All deletions can be restored by using the Edit Undo command (shortcut: ALT+BACKSPACE). 
If you have deleted a series of items, they will be restored one-at-a-time starting with the last 
deleted item. The Edit Redo command uses the same first-in/last-out logic. Redo reverses the 
Undo operations, one-at-a-time.

Delete process
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Delete key



Place Array

When you use the Edit Cut (or Copy) command, you are placing a copy of the current 
selection in the clipboard. The Place Array command provides a powerful way to place multiple
duplicates of any clipboard selection into the workspace. To use this feature:

        Select the item(s) that you wish to repeat place as an array;

        Choose Edit Cut if you wish to clear the selection from the workspace prior to placing the 
array, or choose Edit Copy if you wish to retain the selection in the workspace;

        clipboard. This allows you to pre-designate the cursor position when pasting the selection back
into the workspace from the clipboard.

        Being careful to keep the cursor on the snap grid, press ENTER or LEFT MOUSE to designate
a reference point;

        The reference point can be at any position relative the selection and will be used in positioning
the items in your array.

        Choose Place Array (shortcut: p, y)

        The Array dialog box options define the array. Array parameters include:

        Placement Variables
        Item Count This option sets the number of times the selection is to be placed.

        Text increment This option is used for designators on pins or parts. Setting this to 1 (default) will assign 
array designators in-series, for example U1, U2, U3 and so on. This feature follows the 
same rules as the automatic designator incrementing when placing parts or pins.

        Repeated items are placed in a linear array, using the spacing values specified under 
Spacing.

        Spacing
        These values specify the horizontal (and/or vertical) distance between each item as it is 

placed. Each unit is equal to .1 inch. To place an array:

        Enter the desired values and click Place. Click OK to store the current parameters for later use
or Cancel to return the parameters to their previous settings;

        "Select Starting Point For Array."

        Position the cursor where you want the array to begin, then press ENTER or LEFT MOUSE;

        Use the arrow keys (rather than the mouse) to keep the starting point (and thereby the 
selection) on the snap grid.

        The selection will be placed as an array in the drawing window. If a portion of the array will be 
placed outside the workspace boundaries the warning message "Selection Is Outside Drawing
Window"

        You can disable the requirement to provide a reference point when placing a selection into the 
clipboard (Cut or Copy command) by turning the Clipboard Reference option "off" in the 
Options Preferences dialog box.

Setup Array process
Place Array process



Changing Objects

The Change command is used to modify specific attributes of placed items. Each item or 
object has its own range of editable attributes. You can change one item or extend changes 
across your entire design using powerful global editing options. All changes to objects are 
simply changes to fields of the object.
Moving and object is modifying its location field(s), either graphically or using a dialog.
To change any placed item, move the cursor over the item and double-click LEFT MOUSE. 
This shortcut will open the Change (item) dialog box for the selected item.
You can also use the Change command from the Edit menu:

        Choose Edit Change (shortcut: E, C);

        The prompt "Select (item)" will appear on the status line.

        Position the cursor over the target item and press ENTER or LEFT MOUSE;

        A dialog box opens, displaying the editable attributes for the item. It is now possible to 
change any or all attributes of the selected item, such as a wire width or color. These 
options are described in the next section, Global Changes.

        The system will not prevent changes that violate specified electrical design rules. An 
Electrical Rules Check (ERC) should always be performed before a netlist is generated.

Change process
Global changes
Undo/Redo



Global changes

Changes can be made to a single selected item or they can be applied globally across the 
entire drawing using flexible, powerful global editing options. Virtually every editable attribute 
can be globally applied. A simple example would be changing the color assigned to a wire. 
Typically, the designer would want this new applied to the whole net associated with that wire. 
Perhaps the color change should be made to a whole range of selected wires. These options 
(and more) are supported by the Change commands described below. The possible 
applications for global changes are limited only by the imagination of the design engineer. 
The large number of global change options may make this feature appear somewhat complex 
at first. However, the principles of applying global changes are reasonably simple, once 
understood. When mastered, this feature can be an important productivity tool that can save a 
great deal of manual editing of a schematic.
Matching attributes for global changes can be assigned by clicking the Options button in any 
of the Change (item) dialog boxes. When you click Options, the dialog box expands to display 
the parameters for global matches. 
Each Change (item) dialog box may contain different options since every object type has some
unique attributes.
The power of these options can contribute to some unanticipated results -- particularly when 
complex selections are globally edited. It's always safest to De-Select All (shortcut: X, A), then 
create a fresh selection before you globally edit a selection. Remember, the Undo/Redo 
features can allow you to recover several operations, if required.
Special criteria are used to search and replace strings in all primitives that have text fields.

Aligning items
Object colors
Using text field Wildcards

See also
Editing objects graphically



Aligning items

Globally editable attributes include the location coordinates for each item. Using coordinates in
global editing provides a very powerful system for aligning items in the sheet.

Global changes



Editing objects graphically

If you position the pointer cursor anywhere directly over any polyline item and click LEFT 
MOUSE, the item will change as it is placed in focus. It will now be highlighted (as a dashed 
line) and at each point where the line changes direction, a small square handle is displayed. 
These handles mark each vertex in the polyline wire. If you position the cursor directly over the
handle and click LEFT MOUSE again, you will be able to drag the vertex to a new position and
the attached wire segments will stretch. At the center of the line will be a special handle with 
four arrows. This is called the move handle. Clicking on this handle allows you to move the 
entire polyline object without changing its shape.
Every object that has its shape created during placement: wires, buses, non-electrical lines, 
polygons, bezier curves, rectangles, rounded rectangles, arcs and ellipses all share this 
common polyline behavior as they are placed and graphically edited. Editable attributes are 
described in the Advanced Schematic Reference and Library Editor Reference.

Change (graphically) process



Editing objects using dialogs

Change (Single item) process



Object colors

Each object primitive (everything that is placed) in the sheet be assigned individual color 
attributes. This allows the user to color code wires, classes of parts or individual items. For 
example, the user might want to display all VCC net objects in red and GND objects in green. 
Color assignments can be used for printing schematic sheets as well, if the output device 
supports the use of color by standard Windows device drivers. Examples include multi-pen 
plotters and color PostScript printers.
Many types items have a separate color assignment for their outline and fill area. Examples 
include graphical rectangles, block components and text frames. Items with text fields can 
have colors individually assigned to each text field as well.



Undo/Redo

Advanced Schematic includes a full multi-level Undo and Redo facility. Each procedure is 
stored in a stack-like arrangement. When the Undo command is called, the last completed 
process is undone. Choosing the Undo command again will undo the next-to-last process, and
so on. Processes are grouped together in Undo for convenience. For example, if you choose 
Delete Wire and then delete two wires, undoing this operation will return both of the wires. A 
new set of processes is started every time you select a new command.
The Redo facility is also multi-level and will reverse all of the previous "Undos" during the 
current session. Every time you undo something, the operation is stored in a separate stack. If
you then select Redo, the last undo operation that you did will be reversed and then the next-
to-last and so on.
Undo (and Redo) store each change you make to your sheet from the time you begin the 
current editing session. To clear the Undo stack, choose Edit Save As. If you perform many 
complex operations, you may find that system performance will noticeably slow, as Advanced 
Schematic maintains an increasingly large Undo stack. Clearing the Undo stack will restore 
lost performance and will also de-fragment and compact the current sheet file, which will also 
improve response during hard disk access.

Undo process
Redo process



Dot matrix impact printers

Dot matrix printers create letters and images with arrays of dots. The most common of this 
type of printer creates dots by driving pins against an ink ribbon and into paper. These types 
printers can produce output quickly but do not provide very good resolution. Resolution refers 
to the ability of a printer to reproduce an image accurately, usually measured in dots per inch 
(dpi). A few dot matrix printers produce resolutions up to about 150dpi. Some dot matrix 
printers have the ability to print colors, please refer to your printer's documentation for more 
information. If you need to produce presentation quality output, dot matrix printers are not 
recommended.

Print process



Plotters

Plotters use one or more pens to draw lines on a page. Plotters are especially useful for 
producing large-scale drawings for presentation. Some plotting devices    have the ability to 
produce color by assigning a different pen number to colors. Windows 3 is supplied with driver 
support for color plotting. The resolution of a plotter is limited by point size of its pen(s). For 
example, the smallest dot a plotter can make is the size of its pen's nib. About .3mm is the 
smallest practical size for fluid ink. Color plots are usually generated using disposable 
cartridge pins with fiber tips, which are much coarser than high quality pen points. Detail about
communicating with and controlling the output quality of pen plotters is provided in the chapter 
titled Hardcopy.

Using pen plotters presents several problems and limitations. Most pen plotters are vector 
devices. The Windows environment is biased toward rasterized output and the more 
contemporary printing technologies that it supports. The reproduction of fonts on plotters, for 
example is limited by the page description language that a plotter uses to produce output. 
Reproduction of colors will also be limited to the colors of your plotters pens and the 
combination of those colors. Unfortunately, most Windows plotter drivers do a very poor job of 
handling color plotting. Advanced Schematic has been written to work around the tendency of 
these drivers attempts to "rasterize" the plotter output. For example, in many applications, 
Windows drivers attempt to recreate the dithering of non-solid colors found on screen. Under 
the best conditions, plotters tend to produce uneven tones when printing larger areas of color, 
this is because a plotter usually overlaps pen strokes to fill an area.

Print process



Ink jet printers

Ink jet or bubble jet printers create images by spraying ink on a page. Ink jet printers produce 
fairly good resolution (about 240 to 300dpi), but are fairly slow. Edges of images and letters 
can be blurred and softened when reproduced on an ink jet printer because the ink tends to 
spread out on the page.
Ink jet printers can produce fonts and images of fairly good quality, because most are well 
supported by rasterized Windows output. The TrueType fonts used in Advanced Schematic will
be shown fairly accurately. However, caution should taken when trying to print a design with 
fine detail, very fine lines will tend to thicken and smaller type sizes will blur or become 
illegible. Some models are now being produced with "plotter" size sheet capacity. Excellent 
results can be obtained with color ink jet printers.

Print process



Laser printers

Laser printers have recently become a very popular printing device for producing presentation 
quality output. These devices provide high quality rendering of line (solid black) and grayscale 
artwork. Laser printers can produce resolutions from 300 to 600 dpi. 
Many laser printers support the PostScript page description language, which allows highly 
accurate reproduction of TrueType fonts that are supported by Advanced Schematic. Since 
laser printers use toner instead of ink, edges of fonts and images tend to be very sharp. Laser 
printers are an excellent choice for presentation quality output. While still relatively expensive, 
color laser printers are beginning to be widely available, especially from service bureaus in the
desktop publishing field.

Print process



Using color

To assign a new color to workspace elements or objects:

Click inside the color box for the workspace element or object;
Object color boxes are found in the Change dialog box for the object. To open the Change 
dialog box, double-click on the placed object or choose the Edit Change command, then click 
to select the item.

Choose from over 200 pre-defined colors by clicking on your choice in the Color dialog box; 
Click OK to complete the color assignment.

Customizing display colors
More about color assignment



Customizing display colors

To customize one of the more than 200 available colors from the Color Selector dialog box: 
You can set the Red/Green/Blue values between 0 and 255 units.

As you make color assignments, it is important to make sure that your assignments don't 
conflict in some way that will obscure vital details when you edit your layout. It is 
recommended that you start with the sheet and selection assignments, if you wish to change a
number of the defaults. 



More about color assignment

If your system supports 256 colors, your system color palette on will be set to display as many 
available colors as possible. Advanced Schematic dynamically reprograms the palette as 
colors are assigned.
Unless the graphics Card/driver you are using is supplied with a Windows 24 bit driver, 
Windows will use a system palette that allows multiple applications to share color 
assignments. Windows will take the first 20 colors in this palette for itself and simulate 
unavailable colors using dithering (mixing two or more solid colors). All 20 defaults are defined 
by Microsoft and all drivers are expected to provide color matches as close as possible to 
these.
When using applications that take advantage of 256 color palettes, use of more than the 
standard 20 Windows default colors may cause "stealing" of colors from the system or from 
other applications. For example, if you have a bit-map as your background for Windows that 
used 256 colors then the quality of the display of the bit-map will deteriorate as you select 
more colors for Advanced Schematic.
In standard VGA and EGA there are only 16 available colors. Windows "takes" all 16 and color
requests from applications are either dithered or matched to the nearest solid color. The 
application can request either dithered or solid colors.



Using fonts

Advanced Schematic directly supports TrueType fonts, including bold and italic formats and 
scaling. TrueType fonts and supplied with Windows and are available from third-party 
suppliers in a wide variety of typefaces. Postscript scaleable fonts, and Windows non-
scaleable raster fonts can be used, when they are part of vector image files imported into 
Advanced Schematic sheets.

Note: Some printing or plotting devices do not have full support for scaling and rotation, in 
particular they may not support vertical text. 

Place Text (Single line) process
Place Text Frame process



Image files

The Place Graphic command (shortcut: P, G) is used to import a graphic image into schematic 
sheets or the library workspace. Bitmap and vector images can be imported and scaled 
directly in sheets from a variety of graphics formats.
Images are linked during loading, they are not stored in the library. Only the image file path is 
stored in the library.
Advanced Schematic supports the import of the following image formats;

        BMP All uncompressed Bit map images. Windows device-independent bit map format, 
introduced with Windows 3.0 and increasingly supported by Windows applications.

          PCX Paintbrush format, used in Windows Paintbrush and other paint programs and supported
by many desktop publishing and graphics programs. Supported colors include, 
monochrome, 16 color, 256 color, 24-bit color.

          TIFF Tag Image File Format, supported by many desktop publishing programs. Supported 
compression types, uncompressed, LZW, Packbits, Modified Huffman encoding, CCITT 
Group 3 1D, CCITT Group 3 2D, CCITT Group 4. Supported colors include, 
monochrome, 16 color, 256 color, 24-bit color

        GIF All non-interlaced Graphic Image files.

          EPS Encapsulated postscript files with and without display images. If the EPS file doesn't 
contain a TIFF or Windows Metafile display image then the filename of the EPS image 
will be displayed.

          WMF Only Windows Metafiles which conform to the Aldus Placeable Metafile Format are 
supported. Most applications which export or import Metafiles support this format.

Because the image "points" to a source file, this file will need to be accessible, when printing. 
These files must be supplied with sheet files, if you are sending files off-site for printing.

Place Graphic process



Hardcopy

Completing the schematic layout is only part of the design process. In most cases you will 
need to generate permanent drawings that can be filed and viewed "off-line." Advanced 
Schematic includes support for a wide variety of "hard copy" options for this stage of the 
design process. Virtually any device that is supported by Windows 3.x can be used to print or 
plot your drawings.
Advanced Schematic provides a wide range of output options when you are ready to turn your 
layout into artwork.

PostScript options
Generating a print or plot
Large format and pen plots
Special strings



PostScript printing

Many laser printers support the PostScript page description language, which allows highly 
accurate reproduction of TrueType fonts that are supported by Advanced Schematic. Since 
laser printers use toner instead of ink, edges of fonts and images tend to be very sharp. Laser 
printers are an excellent choice for presentation quality output. Color PostScript printings are 
now widely available, as well.
Windows is supplied with drivers for PostScript-compatible imagesetting equipment. This 
technology, which produces output at 1000 to 2400 dpi, was developed to generate typeset 
quality images for the graphic arts and printing industries and is widely available in service 
bureaus. For information about PostScript imaging, contact a service bureau. 

See also
More about PostScript prints



Generating a print or plot

Advanced schematic printing and pen-plotting are handled similarly to other Windows 3.0 
applications. Windows manages the printing (or plotting) process and provides a range of 
raster and PostScript printer drivers and vector plotter drivers. These range from 9 pin dot 
matrix printers and multi-pen plotters, to high-resolution raster imagesetters. 
To print or plot from the active Schematic Editor or Library Editor windows, choose the File 
Setup Printer command. Options include:

Select printer
Batch mode prints
Color mode
Setting margins
Print command
Setup Printer command

See also
Setting-up pen plotters
Scaling prints and plot
Tiling
Options



Scaling prints and plots

Prints and plots can be scaled to a known factor or automatically scaled to fit within pre-
defined page margins. 

        Scale Type a scale factor from .001 % to 400%. 

        Fit on Page The check print or plot will be expanded or contracted to fit within your pre-defined 
margins, on the page size selected up for the target printer. The plot will be shrunk or 
expanded to use the available space, keeping the correct aspect ratio. 

        Orientation Set the portrait/landscape mode on the printer to match the sheet orientation.

Print process
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Setting margins



Tiling Prints

When the size of the sheet or library document to be printed exceeds the print area available 
on the target device, Advanced Schematic will automatically cut the print into two or more 
sheets or tiles. A pre-defined overlap maintained, so that no area of the print will be lost at the 
tile edge. You can preview the result of tiling    by pressing the Preview button. 
It is often possible to reduce the number of sheets required to tile a print, by changing the 
printer page orientation and adjusting margins. Experiment while in Preview mode to obtain 
the best match, before choosing the Print/Plot command.
Note: if you have defined too wide a margin for the sheet and have not selected the 
Scale for Fit option, the sheet will be printed again, for each overlap - so you could end 
up with as many as four prints - one for each user-defined margin.

Print process
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Print Options

This button opens the standard Printer Setup dialog box, where options for the target device 
are available. Depending upon the device, options include: sheet size/orientation, the number 
of copies of each document, etc.    

        Printer Options

This Options button from this dialog box provides direct access to the Printer's own setup 
dialog box, also available from the Windows Control Panel. These options add, remove or 
configure or set-up communications for the specific output device. The available options vary 
with the features of the selected device. Windows supports background printing from the Print 
Manager. The queuing of prints and other options can also be controlled from the Print 
Manager. See your Microsoft Windows User's Guide or printer or plotter documentation for 
additional information.
If printing or plotting from another computer, plots will need to be generated as files. To do this,
open the Control Panel's Printer dialog box and click Configure. Select File from the ports 
menu. You will be prompted to name the file when generating the plot.
This dialog box is supplied by the printer driver and is not generated by Advanced Schematic. 
Once all options have been entered, Click Print to proceed with the print or plot, OK to save all
the set-ups or Cancel to leave the Printer Setup dialog box without saving the new 
parameters. As the print or plot is generated (either directly to the output device, or to a 
filename) the current page and layer being printed is displayed in a dialog box.
If printing or plotting to a file, you will be prompted to supply an Output File Name.

Print process



More about PostScript prints

Some PostScript printers will "time out" and discard the current data when they don't receive 
the end of page marker within a specified time. This can cause problems where you seem to 
be missing pages from your plots. If you experience this problem using a PostScript printer or 
any other printing device then you should go to the Control Panel, select the printer icon, 
select the printer and click the Configure button. Change the Transmission Retry to 500 
seconds, or some other large number. This will allow the printer sufficient time to catch up 
before the Print Manager gives up.

Print process



Large format and pen plots

Windows is currently shipped with drivers for a number of large format plotters, particularly the
new ink jet and electrostatic plotters.
Support is also provided for a number of traditional pen plotters, including Hewlett Packard 
HP-GL format models. Many other plotters can be configured to support the HP-GL language. 
See your plotter documentation for more information about available emulation modes. 
Current Windows pen plotting drivers, particularly for older model plotters, have a number of 
reported limitations. This is because some drivers, including the generic HP-GL driver, treat 
vector pen plotting similarly to raster plotting. This results in a number of problems, for 
example, poor rendering of filled arcs, inefficient (slow) plotting and other problems, especially 
when handling complex geometry. New or improved plotter drivers are reportedly under 
development for some types of plotters. For up-to-date information about plotter driver support
under Windows, contact Microsoft or your plotter manufacturer.
If you plan to do your plotting from another computer, you will need to generate your plot as a 
file. To do this, open the Control Panel's Printer dialog box and click Configure. Select File 
from the ports menu. You will be prompted to name the file when you generate the plot.

Print process



Setting-up pen plotters

The options available will depend upon the type and model plotter selected. Guidelines should
be documented in your plotter manual. Most plotters will require the following setup decisions:

        Pen speed

Determining the correct pen Speed is largely a matter of trial-and-error. Some users may find 
they have to choose a slower speed to get properly "filled" solid areas. The condition of the 
pen points, freshness of ink, etc., can have a significant impact on plot quality. Some plotters 
have force and acceleration options in addition to pen speed. Consult you plotter manual for 
recommended setting for the paper or film and pen combination you intend to use.

        Assigning pens

If generating pen plots for a multi-pen plotter, you can assign different pens to different colors. 
Pen size and pen number assignments are made from the Printer Options dialog box.

Producing good quality pen plots
Plotter pens and plotting inks
Setting the pen speed
Communications with Serial plotters
Baud rate, data bits, etc
Communication problems



Producing good quality pen plots

Pen plotters can be used to produce very sophisticated design artwork, when the many 
variables affecting plot quality are understood and applied to the process. But, there are 
inherent problems with pen plotting that need consideration. The variables that directly effect 
plot quality include:
Accuracy of the plotter -- particularly its "repeatability" or ability to return accurately to specific 
coordinates, over the entire plot area; 
Type and condition of plotting pens;
Plotting film or paper;
Type and age of the ink selected;
Environmental factors - i.e. temperature and humidity;
Pen speed and pen size settings.
Other factors include the experience of the operator and the maintenance and storage of 
equipment and materials. Following a few simple rules ensures that the best quality possible is
obtained. 
Perhaps the most important factor is the quality of the paper (or drafting film) and the pens that
you use. Use inexpensive paper and fibre tip pens for check plots - save the best pens and 
film for the final plot. 

Print process



Plotter pens and plotting inks

There are a wide range of plotting pens on the market. Felt, and plastic tipped pens are 
convenient to use, but only suitable for draft plots. Pens used for master artwork must be 
capable of providing a consistent ink flow, must not dry out when the pen is lifted off the film for
short periods and must be of the correct diameter for the selected plot scale.
The pens that have been found to be the most suitable are those with tungsten carbide, cross-
grooved points. A latex-based ink will provide a dense plot without the ink running or drying out
in the pen. Your local plotter supplier will make specific recommendations.



Setting the pen speed

Pen speed is a critical, and often overlooked factor in plot quality. It will be worthwhile to make 
a series of experimental plots to determine the optimum settings for your combination of 
plotter and materials. You may also improve the plot result by making small adjustments to the
pen size selection. Slight changes will adjust the amount of "overlap" obtained when filling in 
solid areas -- with further adjustments needed as the pen wears during normal use. 



Communications with Serial plotters

Most plotters are controlled via an RS232-C (serial) interface. A cable connects the plotter and
computer to provide two-way communication. Correctly configuring this combination of 
computer software, serial port, cable and plotter can be a challenge, even for experienced 
engineers. 
If you are installing a serial plotter for this first time, this section explains the relevant RS232-C
conventions. 
The RS232-C standard defines the signals for bi-directional communication where there is no 
inherit distinction between the computer and the output device. In the jargon of serial 
communications both devices are referred to as DTE, or Data Terminal Equipment. Signals, 
such as Transmitted Data are assigned to the same pins in both devices, unlike the parallel 
standard where each pin has a single function.
Each serial "terminal" needs an intermediary device or devices to connect the "transmitted" 
data pin of one DTE to the "received" data pin of the other, and vice versa, and to correctly 
configure the handshaking signals. 
These intermediate devices are called Data Communications Equipment (DCE), which 
connects to DTE, transmits and receives the data over a channel but is neither the source nor 
the final destination of the data. A modem is a DCE - it both modulates data for transmission 
over a single voice channel and demodulates it back to digital data.

More about plot communication
Having problems?



Baud rate, data bits, etc

Once a correct serial connection between the computer and plotter is achieved, the correct 
communications parameters must be selected.
Windows allows you to change these settings using the Control Panel Printer dialog box.
Your plotter manual should indicate the default settings of the plotter and will contain 
information on changing the communications setup. Some plotters do not have default 
settings, as such, but use DIP switch settings which must be configured before the plotter is 
operated. 
You will need to match these parameters using the Printer dialog box. Once set, these settings
are stored with your Windows preferences (Exit Windows, enabling the Save Settings option). 
A baud rate of 2400 bps is standard for many plotters, and a good place to start, if you don't 
know the specific recommendations for your plotter. This is an intermediate baud rate and 
should yield error-free data transmission with cables up to 50 feet (15 meters).
Your plotter manual should also document interfacing and handshaking settings.

See also
Having problems?



Pen plot problems

If you are having problems plotting and you are confident that you have the right cabling and 
parameter settings, check the following:
Inspect the cable connections and make sure that no wires have broken. Also check that your 
Windows settings match the plotter baud rate, parity, etc.;
Confirm that you are using the selected serial port;
If your plot progresses normally at first, then starts putting stray lines or arcs all over the 
layout, this generally indicates improper handshaking. You may also have a problem with one 
or more pin assignments and your cabling may need modification;
Another possible solution is to keep the plotter cable as short as possible and keep it away 
from power cords and other "noise" sources.
If you are using a long cable, you may have to reduce the baud rate to obtain error-free 
transmission. Due to the distributed resistance and capacitance of cables, there is a trade-off 
between cable length and baud rate for reliable data transmission; 
Remember, if you change the communications settings at the plotter, you will have to match 
the new settings in Windows under the printer's Set-up dialog box.
Make sure that you have specified the correct plotter driver. For example, is your plotter a 
"true" Hewlett-Packard (HP-GL) or a "compatible"? Many plotters emulate HP-GL in addition to
their own plotting language. If you are using a dual-language plotter you may have to 
configure the plotter for the correct language. This is done using Control Panel or dip switch 
settings, depending upon the plotter type and model. See you plotter manual for details.
Finally, erratic plotter behavior can be the result of plot file corruption -- usually the result of a 
disk failure or system error during file creation. If you have been unable to solve your plotting 
problem, try plotting one of the (supplied) demonstration files, as a cross-check.



Running Electrical Rules Checks

The File Reports Electrical Rules Check command runs the Electrical Rules Check (ERC) 
process and generates a listing of electrical and logical violations and warnings for the current 
active sheet, hierarchical or multi-sheet flat project. A wide variety of basic electrical errors are 
reported. For example, open input pins on parts and shorts between two differently named 
power nets. The user can select the specific rules used to validate the project. No ERC 
symbols can be placed on sheets wherever the user prefers specific violations to be ignored 
by the ERC system. 
An error or warning can be specified using a matrix of pin, port or sheet entry conditions.
When the report is generated, special symbols are placed on the sheet, indicating the location 
of the reported conditions.
The process of running an ERC is integral to producing a valid netlist for a project. The 
presence of electrical or logical violations will not prevent Advanced Schematic from 
generating a netlist, however incomplete or invalid. Carefully check and resolve all reported 
errors prior to netlist generation.
This feature was still under development at the time this guide was printed. Please refer to the 
README.TXT file and On-line Help system for further information. 



Netlists

Netlists provide the "capture" of the schematic capture process. Normally, netlists are text 
files that list the component parts and pin-to-pin connections that allow schematic information 
to be imported into a simulation or layout environment. Simply stated, a netlist is a summary of
all the connections (or networks) that comprise a circuit. 
Generally, netlists are simple ASCII text files. The typical netlist format includes descriptions of
components, such as the designator and package type combined with the pin-to-pin 
connections that define each net. Loading a netlist into a printed circuit board layout package 
automates many of the tedious and error prone operations inherent in the design process. In 
Advanced Schematic, you can quickly generate and examine a netlist of your current design 
without leaving the editor. 

Generating netlists
Connectivity and netlists
About netlists

See also
Trace Netlist Report



Connectivity and netlists

A key element of electronics design automation is the ability of schematic capture and PCB 
layout systems to recognize the connections within a circuit. This concept -- connectivity -- is 
used at several levels during the design process. Two types of connectivity are employed 
under Advanced Schematic:

        Logical Logical connectivity is the connection information derived from netlisted 
information. For example, the pin-to-pin connections in your schematic are 
transferable, via a netlist, to the PCB editor. In Protel for Windows, these 
connections are stored and used during the layout process.

        Physical Protel for Windows uses the physical geometry of your layout to perform 
connectivity-based operations. One example is the ability to select a connection or 
net. Physical connectivity is used, along with logical connectivity, when generating 
a netlist from a design. It also allows wire-to-pin connections to be maintained as 
components are moved, etc.

See also
Trace Netlist Report



About netlists

Netlists come in many different formats, but are usually generated as ASCII text files that carry
two basic types of information:

        1. Descriptions of the components in the circuit;

        2. A list of all pin-to-pin connections in the circuit.

Some netlist formats combine both sets of data in a single description, Others, including 
Protel, separate the two data into separate netlist sections.
As straight-forward text files, netlists are readily translated into other formats using a simple, 
user-written program. Netlists can also be created (or modified) manually using a simple text 
editor or word processor. 
If you intend to manually edit a netlist, make sure that you save the results in an "un-
formatted" or "text only" form, as hidden "control characters" can render the netlist un-readable
by Protel for Windows.
Some netlist formats can include additional information in component text or net text fields. 
This information is used to link netlists with simulators and board layout and routing in ways 
that aren't covered by basic connectivity.

See also
Trace Netlist Report



Protel netlist format

The standard Protel netlist format is a simple ASCII text file, split into two sections. The first 
part of a Protel netlist describes each component: 

        [ marks the start of each component description;

        U8 the Component Designator (label);

        DIP6 the Package Description (pattern). An identical description (or Type) will be required in 
the PCB library;

        74LS38 is the Comment, (or value);

        (blank) three lines are left blank for future provision;

        (blank)

        (blank)

        ] marks the end of the component description.

The component description section is followed by a listing for each net within the netlist:

        ( marks the start of each net;

        CLK is the name of the net;

        U8-3 shows the first component (by designator) and pin number. Pin numbers in Protel for 
Windows library components must be an exact match;

        J2-1 indicates the second node in the net;

        U5-5 indicates another node;

        ) marks the end of the net. 

Note that net descriptions are distinguished from component descriptions by the use of 
rounded, rather than square brackets. The extension .NET is reserved for Protel format 
netlists.
An extended version of this netlist, called Protel 2, supports additional information for 
simulation and PCB layout. 



Netlist parameters

The following parameters apply to Protel netlists:
Protel (1) netlist format
Designators and Package Descriptions (Type) are limited to 12 alphanumeric characters. 
Comment fields can be up to 32 characters long. Net names can be 20 characters. Pin 
numbers in netlists are limited to 4 alphanumeric characters. Blank spaces (or other hidden 
characters) are not allowed in designators, package descriptions and pin numbers.
This format is supported by Protel Autotrax and Protel for Windows PCB layout systems and 
Tango PCB.
Protel 2 extended netlist format
All fields can be any length, up to 255 characters. Blank spaces (or other hidden characters) 
are not allowed in designators, package descriptions and pin numbers.
Any number of components or nodes can be included in a Protel for Windows netlist, limited 
only by available memory.
This format is supported by Protel for Windows Advanced PCB version 2.0 or later.
Other netlist formats
For information about field length limits and other constraints in other netlist formats, please 
refer to the appropriate manufacturer documentation.

About netlists

See also
Trace Netlist Report



Other netlist formats

Netlists generated or used by systems other than Protel) normally have many similarities to 
the Protel format. These are universally ASCII text formats that include component 
descriptions and net listings. However, the order in which component or net information is 
displayed may vary, and package names (e.g., DIP6), component designators and Pin 
identifiers may require editing to match Protel for Windows field restrictions. Often, translation 
of the netlist is an option in the schematic package. Netlists created using either a Protel or 
"Tango" output option will usually be fully compatible with Protel for Windows. 
Package description (type or footprint) names and pin numbers must have exact matches in 
the Protel for Windows library for all components and connections in the netlist. Protel for 
Windows accepts either a dash ( - ) or comma ( , ) delimiter between the designator and pin 
number (e.g. U-6 or U,6). 

Generating other netlist formats
About netlists
Netlist format notes
Generating SPICE netlists



Netlists and PCB layout

Protel for Windows PCB systems (and some other board layout packages) report missing 
component patterns or missing pins when two factors are present in the netlist:
One or more Package Descriptions (or Type) is missing from schematic component 
information in the netlist, or the package in the schematic does not match any Protel for 
Windows library component. The names of missing components and pins will be listed in a 
Netlist Report file, if desired; 
It may be necessary to re-edit the schematic or netlist to include the Type information, or 
additional Protel for Windows library components may be created to match any unique 
descriptions in the netlist.
If all components are present but pins are reported missing, the cause is usually that the 
schematic package's pin numbering differs from Protel for Windows.
Schematic libraries contain specific components and devices. PCB footprint (decal) libraries 
contain generic footprints which can belong to various specific components -- each having 
different pin assignments. 
For example, a transistor shape can represent various combinations of "E," "B" and "C," -- 
each of which must be assigned to the correct pin number in the PCB layout system. 
Capacitors are a similar case, with pins often named "A" and "K" in the schematic. 
One solution is to leave the Schematic pin designations as "E," "B" and "C" and then place 
components on the PCB and change the pad designators to match. If you have a lot of pin 
outs in the same orientation, you may want to make a special version of the component in the 
library using the correct pin identifiers.



Generating netlists

You can generate a netlist for a project at any time while using the Schematic Editor File 
Create Netlist command. When you choose this command, Setup for Netlist dialog box opens.

Output format
Net identifier scope
Protel netlist format
Netlist parameters

About netlists
Other netlist formats
Netlist format notes
Generating SPICE netlists
Create Netlist command

See also
Trace Netlist Report



Output format

Advanced Schematic currently supports the following netlist output formats:
Protel (original format)
Protel 2
Protel Wirelist
EDIF 2.0
Algorex
Applicon Leap
Applicon Bravo
Cadnetix
Calay
CBDS
Computervision
EE Designer
Futurenet
HiLo
Intergraph
Mentor Boardstation 6
Multiwire
OrCAD PCB II
OrCAD PLD
PADS ASCII
PCAD
PCAD nlt
Racal Redac
Scicards
Spice
Tango
Telesis
Vectron

About netlists
Other netlist formats
Netlist format notes
Generating SPICE netlists



Net identifier scope

Three options are provided that define the method used to associate netlist identifiers (ports, 
net labels and sheet entries) with nets on each project sheet. The method used to identify 
global or local nets, defines the netlist contents. The three options are:
Net Labels and Ports Global
With this option, net labels are assumed to apply to all sheets in a project. In other words, nets
are global and each instance of a net name or port is deemed to be connected to all other 
identically named identifiers. This model works like Protel Schematic 3 (DOS), where netlabels
are always global to all project sheets. 
Only Ports Global
This option treats net labels as local only. All identically named nets on a sheet are deemed to 
be connected. Intersheet connections occur only through identically labeled ports. This model 
works like the OrCAD SDT "flat" project model.
Sheet Symbol / Port Connections
This option makes intersheet net connections only through sheet symbol entries and subsheet
ports. Ports are deemed to be connected only to identically named nets entering through their 
sheet symbols on parent sheets. This model works like the OrCAD SDT "hierarchical" project 
model.

About netlists



OrCAD compatibility

Both schematic sheet files and libraries from OrCAD SDT 3/4 can be used with Advanced 
Schematic. OrCAD SDT 3/4 3 files are loaded using the File Open Sheet command, just like 
Advanced Schematic files. All OrCAD SDT 3/4 design objects are supported by the Schematic 
Editor. When you choose File Save, the file will be saved in any of the three following formats: 
Protel binary (the Advanced Schematic native format), Protel ASCII (a text version of the 
Advanced Schematic format) or OrCAD binary.

OrCAD commands
STD Sheet files
SDT Design Objects
SDT libraries
SDT Utilities
Backward compatibility to SDT



OrCAD    sheet files

When you open an OrCAD SDT 3/4 file in Advanced Schematic, all SDT 3/4 design objects 
and data are available for editing. These sheets can be edited, saved in OrCAD SDT 4 format 
then re-opened and edited in SDT 4.

See also
Loading files (OrCAD)



Backwards compatibility to OrCAD SDT

Advanced Schematic supports all OrCAD SDT 3/4 design objects and other database 
elements when you open OrCAD sheets. When you save an Advanced Schematic file in 
OrCAD SDT format, most sheet elements are supported at some level. However, Advanced 
Schematic primitves can include attributes that are not supported by OrCAD, for example, 
color or font assignments for individual objects and text fields longer than 128 characters. This 
information will not be recognized by OrCAD, but you should still be able to save a compatible 
OrCAD format file in virtually every case. Fully-compatible means that the feature will be 
translated back to its normal OrCAD version, without the need to perform any manual editing 
or clean-up.

        Saving OrCAD files

Organization (title block).
Junctions
Wires and buses
Dashed lines
Bus entries
Module Ports
Net Labels
Sheet Symbols and Sheet Nets
Parts
Power Objects
Trace Name
Vector Column
Stimulus
Error Markers
No Connect
Layout Directive
Libraries
Loading OrCAD schematics
Connectivity
Warning Saving files in OrCAD (SDT 4) binary format will cause the loss of some file and 
primitive information that is not fully-supported by the OrCAD format. Lost information may 
include some graphical objects, design object text fields exceeding 128 characters, imported 
images, color and font assignments, etc. Consult your OrCAD documentation to determine 
supported data types and limits.



OrCAD Design Objects

OrCAD Design Objects types are listed below, along with Advanced Schematic equivalents. 
Other OrCAD terms and procedures (and the Protel equivalents) are defined in the Glossary 
and relevant sections of the User Guide and Reference Manual.

        OrCAD object Protel object

        Module Port Port

        Sheet Symbol Sheet symbol

        Sheet Net Sheet entry

        Power Object Power port

        No Connect No ERC (electrical rules check)

        Trace Probe

        Vector Test Vector Index

        Stimulus Stimulus 

        Layout Directive PCB layout

        Tag Location marker 

        Part Part (e.g., device, what is placed)

        Pipelink Not required (place sheet symbol in master sheet).



OrCAD    libraries

OrCAD SDT 3/4 component libraries can be converted into Advanced Schematic libraries. The
first step is to convert the OrCAD format library into its decompiled (.SRC) format. Load the 
decompiled version into the Protel Schematic Library Editor and then save in Protel Binary 
Format.



Protel Schematic 3 (DOS) compatibility

As with OrCAD SDT 3/4 files and libraries, both schematic sheet (.S**) files and libraries from 
Protel Schematic 3.x can be used with Advanced Schematic. Protel Schematic 3 files are 
loaded using the File Open Sheet command, just like Advanced Schematic files. When you 
choose File Save, the file will be saved in any of the three following formats: Protel binary (the 
Advanced Schematic native format), Protel ASCII (a text version of the Advanced Schematic 
format) or OrCAD binary. There is no option for saving files in the Protel Schematic 3 format. 
Users of earlier version Protel Schematic or Tango Schematic system must first convert files to
Protel Schematic 3 format before these files can be opened in Advanced Schematic.

Schematic 3 commands
Schematic 3 libraries
Block, highlighting, etc
Utilities



Libraries (Schematic 3)

The way that Advanced Schematic handles libraries, components and library editing is 
fundamentally different than the way these functions are performed in Protel Schematic 3. 
Please refer to the relevant sections of this guide for detailed explanations regarding 
Advanced Schematic library concepts.
Protel Schematic libraries are organized into a "flat" structure where each component has a 
unique description. All graphical representations of Schematic 3 library components (except 
their pins) are rendered as bitmap images. Advanced Schematic library parts are vector 
graphic based. When converting files into Advanced Schematic format, the differences 
between the two library systems must be reconciled to preserve connectivity. This is done in 
two basic ways: a library of equivalent vector (Advanced Schematic) components is 
maintained. These components are automatically substituted for like-named standard 
Schematic 3 versions. For custom components, a substitute vector component is created.

PROTELLIB
Other bitmap components
Pin Editing
Connector components
Advanced Schematic Libraries



PROTEL.LIB (Schematic 3)

This library contains substitute vector parts for all bitmap components from the standard 
libraries delivered with Protel Schematic 3.3. When you load Schematic 3.3 sheet files, these 
components will be substituted automatically for the bitmap versions.



User created bitmaps (Schematic 3)

Protel Schematic 3 libraries and sheets may include user-generated bit map graphics that are 
not substituted when Schematic 3 sheet files are loaded into Advanced Schematic. Advanced 
Schematic creates and substitutes a block-type representation of this component parts when 
loading these files. These parts are fully functional, but will not include details from the user-
created bitmaps.



Pin Editing (Schematic 3)

Schematic 3 allows users to edit pin attributes, including pin positions, on the fly, from inside 
the schematic editor. This is not possible in Advanced Schematic, where all changes must be 
made at the library level, using the Schematic Library Editor application. Because the Library 
Editor can be run at the same time the Schematic Editor is running, it is a simple matter to 
switch tasks and make library level changes, then return to the editor. Special links are 
provided that allow the user the move directly from one editor to another. For example, from 
the Library Browser window in the Schematic Editor, the Edit button will switch the user 
directly into the Library Editor. The library for the selected part will be opened and the 
component will be displayed in the edit workspace. Similarly, pressing the Place button on the 
Library Editor main panel will return the user directly to the Schematic Editor, with the part 
ready to place in the current sheet window.



Block, highlighting, etc (Schematic 3)

In Advanced Schematic the functions of the Block and Highlight commands (such as Block 
Define or Highlight Net) have been merged into the concept of selection. If you wish to perform
an operation on a group of objects on the sheet, you first select the items, then use one of the 
Edit menu commands.



ASCII file formats

Advanced Schematic sheet and library files have default binary formats. These binary files are 
compact and efficient when loading or saving. To make it easier for users to directly access 
data, the system includes options to generate ASCII versions of these files. 
Other files are generated in ASCII format only. These include netlists, Bills of Material and 
other reports.    Complete descriptions of the following file formats are documented in the 
Advanced Schematic User Guide.

- Schematic Editor File Format
- Schematic Library Editor File Format
- SCH.INI Format
- LIBEDIT.INI Format



Advanced Schematic Glossary

        annotation Component reference designators (or labels) that appear on the schematic sheet, 
in netlists or on a printed circuit board.

        ANSI International standard for technical drafting. See also ISO.

        any angle Non-orthogonal drawing mode where (non-electrical) lines or wires that can be 
placed at angles other than 45 or 90 degrees.

        arc Circular or semi-circular design elements. Protel for Windows generates arcs of 
degree resolution.

        array Multiple instances of a single item, placed using the Place Array command.

        ascend To move from a child sheet, back to its parent sheet in a hierarchical design. 

        ASCII American Standard Code for Information Interchange. Standard seven bit code for 
representing alphanumeric data and computer instructions.

        attributes The characteristics of an item that can be edited, or changed. For example, wire 
attributes include width, color, etc.

        back annotate Updating schematic information from changes made to the printed circuit board 
layout.

        backup library A special library that includes component records for each part placed in a 
schematic sheet. This library is attached to the sheet file when the sheet is saved. 

        bezier curve Complex graphical curves, placed as precision arcs defined by a series of control 
points.

        Bill of Materials Or, BOM. A list of the components (including quantities). 

        body See outline.

        border Graphical device outlining the edge of the sheet workspace, normally including 
coordinate references for the sheet.

        browse Viewing library names from the Protel for Windows workspace.

        bus A special wire type that symbolically represents a collection of individual nets.

        cache A temporary record of each component used in a project. This cache is used to 
create a backup library, attached to each sheet file. See also, backup library.

        child A subsheet descended from another (parent) sheet in a hierarchical design.

        Clear To remove a selection permanently from the workspace. Same effect as Delete. 
See also Cut, Copy.

        clearance Air gap specified for routing a net. Field of the directive primitive

        clipboard Reserved memory used to hold Cut or Copy command selections.

        clock Pin type that symbolically represents clock function, represented by a small 
triangular shape at the pin base.

        command Any process that is performed by choosing a menu option, e.g., Place Component 
or File Save.

        comment Optional component text field created when a component is placed. Normally used 
to hold a component value, description or part number.



        complex (in hierarchy), when a sheet can appear more than once in a project.

        component The specific schematic library package that represents either a manufacturer 
catalog listing or a generic type. See also part.

        component field Any of 8 different library fields that hold optional component text.

        component txt Text that is associated with a schematic part or PCB component.

        connection The logical or physical link between any two netlist nodes.

        connectivity The logical relationship of components and wires.

        control point The special graphical handles used to define a bezier curve. 

        de-select Releasing the selected condition of an item (or group) in the document window. 

        default Program settings or options that remain activated until changed by the user. 

        descend To move from a schematic sheet, to a child sheet, represented by a sheet symbol, 
in a hierarchical design.

        designator Also called component label. The unique identifier assigned to each component in 
a circuit.

        device See part.

        directive A special symbol used to attach PCB layout information to a specific net, such as 
routing priority, track width, etc.

        discrete Generic component types such as transistors, capacitors, etc.

        dot Pin type that symbolically indicates inversion, represented by a small circular 
shape at the pin base.

        DXF Format for AutoCAD files.

        electrical rules Connectivity-based features that check for shorts, undriven inputs, unconnected 
wires and similar electrical design violations.

        fill Color or pattern assignment for the inside of graphical items.

        flat design A non-hierarchical multi-sheet schematic where Ports are used to indicate 
connections to other sheets.

        fwd annotate Updating a printed circuit board layout with changes made to the schematic.

        focus The current active individual which displays its graphical editing handles. The 
object in focus can be moved, deleted or re-sized. See also selection, handle.

        global In relation to the use of net identifiers (net label, port, sheet entry), refers to 
identifiers whose scope includes an entire project. See also local.

        global change Any change that can be assigned to like attributes of other primitives of the same 
type. 

        group Refers to one or more library component names associated with the same 
component description. Library entries can have any number of component names 
that share the same specification and graphical description.

        handle Small arrows displayed on an object that is the current focus.

        hardware arc When plotting, arcs which are created by the plotter, from coordinate, line width 
and radius information.

        hidden pin Component power-type pin that is normally hidden when the component is 



displayed. 

        hierarchy The concept of hierarchy applies generally to any multi-sheet schematic. Sheet 
Symbols are placed within one sheet to represent another sheet (or subsheet).    

        highlight A special display state that outlines items as an aid to identification or editing. For 
example, when placing or moving wires, they are displayed in a highlighted 
condition. See also selection.

        hot key Any key that has a process assigned in Advanced Schematic. 

        IEEE International ANSI/IEEE Standard 9-984 for graphical representation of circuits.

        IGES Initial Graphics Exchange Specification. A general use standard for exchanging 
graphical information between platforms or applications.

        intersheet (connection) In multi-sheet flat designs, these are connections that represent a net 
that crosses from one sheet to another.

        ISO International Standards Organization. See also metric.

        isolation See clearance.

        junction Special symbol, used to electrically (logically) connect two wires. 

        label See designator.

        library Collection of components, devices or symbols, stored in Advanced Schematic 
library form.

        line Any line that is non-electrical in the drawing. Electrical lines are referred to as 
wires.

        link The process of listing all associated sheets for a design.

        local In relation to net identifiers, refers to net labels whose scope is limited to a single 
sheet.

        master sheet The "topmost" sheet in a multi-sheet design project. 

        merge To move components from one library to another.

        min X, Y The minimum X or Y coordinate of items in the Protel for Windows workspace. This
describes the left-most and bottom-most coordinates used in the file or plot.

        Module port See port.

        multi Multi-device component. Schematic component whose devices (gates) can be 
represented by individual logic symbols.

        net label Special text symbol used to associate a wire with a specific net.

        netlist A text file that lists all the connections of an electronic circuit. 

        object Any individual item that can be placed in Advanced Schematic sheets. 

        orthogonal Drawing mode, where wires are constrained to either vertical, horizontal or 45 
degree placement. See also any angle.

        outline The symbolic shape used to describe individual components or devices.

        package The physical description, or "footprint" of a component, e.g., DIP6, defined by the 
number and location of pins, dimensions, etc.

        parent Any sheet that includes sheet symbols for another subsheet (child) in a hierarchical
design. 



        part field Optional text fields added when placing the component. See also component field.

        part Graphical representation of a library component or one part of a multi-device 
component. 

        pin Graphical representation of a component pin on schematic component symbols. 
Schematic pins are connected using wires.

        pipe-link An OrCAD design element, used to list the subsheets associated with a master 
sheet in a flat, multi-sheet design.

        polygon Multi-sided filled graphical (non-electrical) object.

        polyline Lines that can be rendered with multiple joined segments and manipulated as an 
individual entity. Wires, buses and graphical lines are all polylines in Advanced 
Schematic.

        port A symbol used to indicate a connection to another sheet in a flat design.

        power port Special component symbol, normally used to indicate a power source.

        primitive Refers to any individual object, or object primitive. See object.

        process Any event generated by Advanced Schematic, including menu commands, dialog 
box options or shortcuts that either changes an attribute of an object, imports data 
into, creates data or exports data from Advanced Schematic. 

        process launcher Any user initiated action that begins a process. 

        project All the sheet files that are associated within a single design, irrespective of their 
hierarchical or flat organization.

        Project Mgr Advanced Schematic system for opening, saving and manipulating multi-sheet 
schematics. 

        project window Special windows displayed at the left of the sheet window when the Project 
Manager is active. This window displays an image representing each open sheet 
file.

        root sheet See master sheet.

        selection A method of grouping items which are manipulated as a single entity.

        serial Refers to RS-232C and RS-422 standard for data terminal equipment (DTE) 
communications. 

        sheet An individual schematic file, displayed in its own window. Each schematic sheet, 
including hierarchical subsheets, are saved as individual files.

        sheet symbol A graphic representation of a schematic sheet that can be placed on another sheet,
indicating hierarchy. 

        signal Any net. Generally used to refer to any non-power net.

        Simple (hierarchy) where each sheet in a project is unique. See also Complex hierarchy.

        snap grid An invisible array of regularly spaced points on the screen that defines the possible
cursor positions.

        software arc When plotting, arcs which are generated by Protel for Windows using straight line 
chord segments. See also hardware arcs.

        Status line The window at the bottom-left of the screen that displays the current X and Y 
cursor coordinates, defaults; and user prompts.



        step-and-repeat See array.

        stimuli A special symbol used to indicate the point at which the function of a signal 
(expressed as an algorithm) is applied to a circuit during simulation.

        string Individual element of free or component text.

        subpart see device.

        subsheet In multi-sheet schematics, any schematic sheet file associated with a master or 
parent sheet. See also hierarchical design.

        symbols Various graphical and electrical or logical objects placed on the schematic to 
represent components, devices or blocks of circuits.

        test vector A special symbol used to indicate the point at which a non- algorithmic stream of 
signal values is applied to a circuit during simulation.

        text frame A graphical object placed on the schematic sheet that holds up to 32,000 
characters of formattable text. Parts, netlabels and other objects have their own 
text fields of up to 255 characters.

        title block Area of the schematic sheet reserved for the drawing title, revision information, etc.

        tool Any menu command that is available as a push button on a Tool palette.

        trace see probe.

        vertex The joint of any two straight line segments in polyline objects: wires, buses, lines 
and polygons. 

        visible grid A user-definable display layer that provide a visual reference for positioning items 
accurately on-screen.

        wire An electrical (logical) conductor in the schematic drawing, represented by a special
line type.

        worksheet See sheet.



OrCAD SDT Help

Again
Block
Conditions
Delete
Edit
Find
Get
Hardcopy
Inquire
Jump
Library
Macro
Place
Quit
Repeat
Set
Tag
Zoom



Again (OrCAD)

Advanced Schematic Editor does not have an equivalent to the Again command.



Block (OrCAD)

Move 
Drag
Fixup
Get
Save
Import
Export
ASCII Import
Text Export



Move (OrCAD)

To move selected objects,
Choose Move and then Move Selection from the Edit menu.
Make sure that the current selection includes only those objects you wish to move. You can 
use the Edit Select and De-Select menu commands to select and de-select objects.

See also
MoveSelection



Drag (OrCAD)

To move objects and still maintain bus/wire connectivity,
Choose Move and then Move from the Edit menu.
Wires will retain their orthogonality as objects are moved around the worksheet. You can also 
use the shortcut CTRL+LEFT MOUSE to pick up and move an object.
      

See also
Move 



Fixup (OrCAD)

The Change Object Graphically command can be used to move and clean up individual bus 
and wire segments. There is not a specific menu command for this process.
While moving wires or bus segments you can use the SPACEBAR to toggle through the different 
angle modes of wire and bus placement. The INSERT and DELETE keys can be used to add and 
remove line segments.

See also
Change Object Graphically



Get (OrCAD)

To place objects onto the worksheet from the Advanced Schematic Editor clipboard,
Choose Paste from the Edit menu,
The Edit Copy and Cut commands can be used to copy selected objects to the Schematic 
Editor clipboard.

See also
Paste



Save (OrCAD)

To copy objects to the Advanced Schematic Editor clipboard,
Choose Copy from the Edit menu.
The Edit Cut command can also be used to copy selected objects to the Schematic Editor 
clipboard.

See also
Copy



Import (OrCAD)

The Edit Copy and Paste commands are used to copy and place sections of a schematic 
worksheet into any open schematic document window.

See also
Copy
Paste



Export (OrCAD)

To save a block or group of objects to a file. Paste a selection of objects into a blank document
window, then use the File Save As command to save the document to a new schematic file 
name.
              

See also
Paste
File Save AS



ASCII Import (OrCAD)

To import text into the schematic worksheet from an ASCII file, copy text to the Windows 
clipboard from another application (such as, Notepad or Write) and then paste the text into the 
text editing window of a Text Frame.

        

See also
Paste
Place Text Frame



Text Export (OrCAD)

To export text into an ASCII file, copy text to the clipboard from the text editing window of a 
Text Frame and then paste the text into another Windows application (such as, Notepad or 
Write).    Once in the text editing application it can be saved as an ASCII text file.

See also
Text Frame
Copy 



Conditions (OrCAD)

To display information about your computer system,
Choose Status from the Info menu.
Additional inforamtion about the current schematic worksheet can be obtained by using the 
Info Schematic and Info Components menu commands.

See also
Information System Status



Object (OrCAD)

To delete objects from your schematic worksheet,
Choose Delete from the Edit menu.
The Delete Single Object command can also be used to delete an individual object that has 
the focus.    All deletions can be restored by using the Edit Undo command (ALT+BACKSPACE).

See also
Delete
Delete Single Object



Delete (OrCAD)

Object
Block
Undo



Delete Block (OrCAD)

To delete groups of objects from your schematic worksheet,
Choose Clear from the Edit menu.
The Edit Cut command can also be used to remove selected objects from the worksheet and 
copies the selection to the Schematic Editor clipboard.

See also
Clear 



Undo (OrCAD)

To restore deleted objects back onto the schematic worksheet,
Choose Undo from the Edit menu.
Multiple levels of undo are supported. The Edit Redo command can be used to restore 
changes made by the Undo command.

See also
Undo



Edit (OrCAD)

Edit
Find
Jump
Zoom



Edit (OrCAD)

To edit the attribues of an object on the schematic worksheet,
Choose Change from the Edit menu.
You can also position the cursor over the target object and double click LEFT MOUSE, or simply 
use the mouse to graphically change the object by by physically moving the position of the 
objects handles.

See also
Change



Find (OrCAD)

Equivalent options can be found in the Edit Search For menu. Such as searching for a text 
string, net label, part or a pin on the current worksheet.

See also
Find Text
Find And Replace Text
Find Next Text
Search for Net
Search for Part



Jump (OrCAD)

Equivalent options can be found in the Edit Jump menu. Such as jumping to a location mark, 
new location or to the origin of the current worksheet.

See also
Jump Location Mark
Jump New Location
Jump Origin
Jump Net
Find Text
Find And Replace Text
Find Next Text



Zoom (OrCAD)

Equivalent options can be found in the Zoom menu. Such as zooming by a defined area 
(zoom window, zoom point), magnification level (50%-400%), viewing the whole sheet (zoom 
sheet), viewing only the objects placed on the sheet (zoom all), zooming in and out on objects 
(zoom in, zoom out), redrawing the current document window (zoom redraw) and redrawing 
the current document window with the previous cursor location at the center of the window 
(zoom pan).

See also
Zoom Window
Zoom Point
Zoom 50%
Zoom 100%
Zoom 200%
Zoom 400%
Zoom Sheet
Zoom All
Zoom In
Zoom Out
Screen Redraw
Zoom Pan



Find (OrCAD)

Equivalent options can be found in the Edit Search For menu such as searching for a text 
string or net label. Parts (and their pins) and found by using the Jump button in the Library 
Browser.

See also
Find Text
Find And Replace Text
Find Next Text
Search for Net



Get (OrCAD)

To place parts on the schematic worksheet:

        Choose Parts from the Place menu.

You can also place parts by pressing the Place button on the Component Browser.

See also
Place Parts
Place Part from Browser



HardCopy (OrCAD)

To print or plot a schematic worksheet:

        Choose Print from the File menu.

The Setup Printer option in the File menu is used to select a printer or plotter
model, control printing options such as paper size, orientation, quality etc. and is also used to 
setup the scale, color mode and margins of your schematic sheet.

See also
File Print
Setup Printer



Inquire (OrCAD)

To view/change the text and name attributes associated with a probe, test vector index, 
stimulus, PCB layout and error marker objects,
Choose Change from the Edit menu.
You can also position the cursor over the target object and double click the LEFT MOUSE to 
view/change the text and name attributes.

See also
Change Items



A - H Tag (OrCAD)

To jump to a specified location on the schematic worksheet,
Choose one of the Location Mark options from the Jump menu.
Advanced Schematic supports up to 10 location marks, they are set by using the Location 
Marks command in the Place Menu.

See also
Jump Location Marks
Set Location Marks



Reference (OrCAD)

To move the cursor to a specified border reference or cell on the schematic worksheet,
There is no equivilent command in Advanced Schematic.



X Location (OrCAD)

To move the cursor to a specified X location on the schematic worksheet,
Choose Jump Location from the Edit menu.
This command allows you to specify both an X and Y coordinate.

See also
Jump New Location



Y Location (OrCAD)

To move the cursor to a specified Y location on the schematic worksheet,
Choose Jump Location from the Edit menu.
This command allows you to specify both an X and Y coordinate.

See also
Jump New Location



Library (OrCAD)

Directory
Browse



Directory (OrCAD)

In Advanced Schematic, various methods are provided for reporting the components in sheets,
projects and libraries.For example, all components in the current sheet (or project) are listed in
the Part Designators list box in the Component Browser panel. The designator and part type 
are listed. 
The File Reports Cross Reference command (shortcut: F, R, C) generates a listing of part 
types and designator labels, and the sheet location (filename) for each item. The report is 
generated for the current active sheet, hierarchical or multi-sheet flat project. This report is 
output in ASCII text format.
Detailed listings of sheet or project components are generated by the File Reports Bill of 
Materials command. When you generate this report, the Notepad utility is used to display the 
results on-screen immediately.    

Bill of Materials report
Cross Reference report



Browse (OrCAD)

To browse and view the componets in a library file,
Choose Run Library Editor from the Library menu.
The Run Library Editor command is used to switch to the Schematic Library Editor. You can 
use the Main Panel or Component menu in the Library Editor to browse through the 
components in a library. Refer to the Schematic Library Editor reference manual and on-line 
help for further information.

See also
Run Library Editor



Macro (OrCAD)

Advanced Schematic supports the assignment of Hot Keys not keyboard Macros. Hot Keys 
allows you to assign keyboard keys and mouse button clicks to all of Advanced Schematic's 
command processes.
Choose Hot Keys from the Options menu.                
A number of macro editing applications are available for recording keyboard
and mouse commands. The Windows Recorder for example, which is supplied with your 
Windows application can be used to record your keystrokes and mouse actions, and then play
them back later by just pressing a key.

See also
Hot Keys



Place (OrCAD)

Wire
Bus
Junction
Entry (Bus)
Labels
Module Port
Power Object
Sheet Symbols
Text
Dashed Line
Trace
Test Vectors
Stimulus
NoConnect
Layout Directive



Wire (OrCAD)

To place wires on the schematic worksheet,
Choose Wire from the Place menu.
While placing the wire, you can popup the Search For, Jump or Zoom menus by pressing the 
default hotkeys R, J, or Z.

See also
Place Wire



Bus (OrCAD)

To place bus lines on the schematic worksheet,
Choose Bus from the Place menu.
While placing the bus line, you can popup the Search For, Jump or Zoom menus by pressing 
the default hotkeys R, J, or Z.

See also
Place Bus



Junction (OrCAD)

To place junctions on the schematic worksheet,
Choose Junction from the Place menu.
While placing the junction, you can popup the Search For, Jump or Zoom menus by pressing 
the default hotkeys R, J, or Z.

See also
Place Junctions



Entry (OrCAD bus)

To place a bus entry on the schematic worksheet,
Choose Bus Entry from the Place menu.
While placing the bus entry, you can change the placement angle by pressing the SPACEBAR. 
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place Bus Entry



Label (OrCAD)

To place labels on the schematic worksheet,
Choose Net Label from the Place menu.
While placing the net label, press the TAB key to manually change the default orientation, net 
name and size of the net label by typing new values directly into a dialog box.
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place Net Label



Module Port (OrCAD)

To place a Module Port on the schematic worksheet,
Choose Port from the Place menu.
While placing the port, press the TAB key to manually change the default name, type and style 
of the port by typing new values directly into a dialog box.
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place Port



Power (OrCAD)

To place power objects on the schematic worksheet,
Choose Power Port from the Place menu.
While placing the power port, press the TAB key to manually change the default orientation, 
value and type of the power port by typing new values directly into a dialog box.
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place Power Port



Sheet Symbol    (OrCAD)

To place a sheet symbol onto the schematic worksheet,
Choose Sheet Symbol from the Place menu.
Sheet nets are placed in the sheet symbol by using the Add Sheet Entry command. Use the 
Delete command from the Edit menu to delete a sheet entry. The name and file name of the 
sheet symbol can be changed by double clicking on them with the mouse or using the Change
command from the Edit menu.
        

See also
Place Sheet Symbol
Add Sheet Entry



Text (OrCAD)

To place comments on the schematic worksheet,
Choose Text and then Annotation from the Place menu.
While placing the annotation, press the TAB key to manually change the
default orientation, text and size of the net label by typing new values directly
into a dialog box.
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place Annotation



Dashed Line (OrCAD)

To place a dashed line on the schematic worksheet,
Choose Drawing Tools and then Line from the Edit menu.
While placing the line, press the TAB key to manually change the default width and style of the 
line by typing new values directly into a dialog box. There are three selectable line styles; 
solid, dashed and dotted. The dashed and dotted styles only apply to 'smallest' width lines.
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place Line (Polylines)



Trace (OrCAD)

To place a trace on the schematic worksheet,
Choose Directives and then Probe from the Place menu.
While placing the probe, press the TAB key to manually change the default values of the probe 
by typing new values directly into a dialog box.
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place Probe



Test Vectors (OrCAD)

To place a vector on the schematic worksheet,
Choose Directives and then Test Vector Index from the Place menu.
While placing the Test Vector Index, press the TABS key to manually change the default values 
by typing new values directly into a dialog box.
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place Test Vector Index



Stimuli (OrCAD)

To place a stimulus on the schematic worksheet,
Choose Directives and then Stimulus from the Place menu.
While placing the stimulus, press the TAB key to manually change the default values by typing 
new values directly into a dialog box.
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place Stimulus



NoConnect (OrCAD)

To place a no-connect symbol on the schematic worksheet,
Choose Directives and then No ERC from the Place menu.
While placing the No ERC symbol, you can also popup the Search For, Jump or Zoom menus 
by pressing the default hotkeys R, J, or Z.

See also
Place No ERC



Layout Directive (OrCAD)

To place a layout directive on the schematic worksheet,
Choose Directives and then PCB Layout from the Place menu.
While placing the PCB Layout, press the TAB key to manually change the default values by 
typing new values directly into a dialog box.
You can also popup the Search For, Jump or Zoom menus by pressing the default hotkeys R, 
J, or Z.

See also
Place PCB Layout



Quit (OrCAD)

Enter Sheet
Leave Sheet
Update File
Write to File
Initialize
Suspend to System
Abandon Edits
Run User Commands



Enter Sheet (OrCAD)

To view a schematic worksheet represented by a sheet symbol in a hierarchical design,
Choose either Up Hierarchy or Down Hierarchy from the File menu.
When moving down the hierarchy, if the child sheet is not already opened Advanced 
Schematic will automatically open the sheet (any number of schematic worksheet files can be 
opened at the same time). To move up the hierarchy, the parent sheet needs to be already 
open.
You can also use the Project Manager to visually navigate through the schematic worksheets 
in a project.

See also
Up Hierarchy
Down Hierarchy
Toggle Project Manager



Leave Sheet (OrCAD)

To move up one level in the schematic hierarchy,
Choose Up Hierarchy from the File menu.
To move up the hierarchy, the parent sheet needs to be already open. You can also use the 
Project Manager to visually navigate through the schematic worksheets in a project.

See also
Up Hierarchy
Toggle Project Manager



Update File (OrCAD)

To save the changes made to the current schematic worksheet,
Choose Save from the File menu.
If the schematic worksheet has not been previously saved, the Save File As dialog box will 
open, prompting for a file name.

See also
File Save



Write To File (OrCAD)

To save the current schematic worksheet to a new path, file name or format.
Choose Save As from the File menu.

See also
File Save As



Initialize (OrCAD)

To load a schematic worksheet file,
Choose Open Sheet from the File menu.
To create a new blank schematic worksheet,
Choose New from the File menu.

See also
File Open Sheet
File Open Project
File New



Suspend To System (OrCAD)

Use the Windows Program Manager to switch to the DOS operating system.
1. While you are in the Advanced Schematic Editor press the ALT+TAB keys to switch to the 
Program Manager,
2. Click on the DOS icon (usually stored in the Main program group), or
3. Choose Run from the File menu and type Command, then click OK or press ENTER.



Abandon Edits (OrCAD)

To quit the current session of Advanced Schematic Editor,

        Choose Exit from the File menu.

If any schematic worksheet has been modified since last saving, a dialog box will be displayed
that prompts to save the file(s).
    

See also
File Exit



Run User Commands (OrCAD)

Use the Windows Program Manager to run external DOS commands.

        1. While you are in the Advanced Schematic Editor press the ALT+TAB keys to switch to the 
Program Manager,

        2. Choose Run from the File menu and type in the DOS command, then click OK or press 
ENTER.



Repeat (OrCAD)

To duplicate the last placed object, or to place an array of objects on the worksheet:

        First cut or copy the object(s) to be repeated to the clipboard, then choose Paste or 
Paste Array from the Edit menu.

See also
Paste Array
Execute Paste Array



Set (OrCAD)

Auto Pan
Backup File
Drag Buses
Error Bell
Left Button
Macro Prompts
Orthogonal
Show Pins
Title Block
Worksheet Size
X,Y Display
Grid Parameters
Visible Lettering



Backup File (OrCAD)

A backup file with the extension of .BAK, is created every time you save a schematic 
worksheet or project.
Advanced Schematic also supports the creation of additional backup files during an editing 
session. In the Preferences dialog box, you can set the interval for generating an automatic 
backup file and set the number of automatic backup files used in a rotating file system.

See also



Drag Buses (OrCAD)

To enable/disable dragging of bus and wire segments,

        Choose Preferences from the Options menu and enable/disable the drag option.

See also
Preferences



Error Bell (OrCAD)

To turn the Windows warning beep and system sounds on or off,

        Choose the Sound icon from the Windows control panel and click on the Enable System 
Sounds check box.



Left Button (OrCAD)

Advanced Schematic Editor does not have an equivalent to the Left Button command. 



Macro Prompts (OrCAD)

Advanced Schematic Editor does not have an equivalent to the Macro Prompts command.



Orthogonal (OrCAD)

While you are placing wire or bus segments you can toggle through the placement angle 
modes by pressing the SPACEBAR. Wires and buses can be drawn at 90, 45 and any angle 
degrees.

See also
Place Wire
Place Bus



Show Pins (OrCAD)

To show/hide pin numbers,

        Choose Preferences from the Options menu and click on the Pin Numbers check box.

See also
Preferences



Title Block (OrCAD)

To turn the Advanced Schematic (Standard or ANSI) title block on or off,

        Choose Sheet from the Options menu and click on the Title Block check box.

See also
Sheet Options



Worksheet Size (OrCAD)

To select a schematic worksheet size,

        Choose Sheet from the Options menu and select a sheet size.

Advanced Schematic supports 10 standard imperial and metric sheet sizes. They include A, B,
C, D, E (or metric sizes A4-A0). You can also define your own custom sheet size up to 65 
inches square.

See also
Sheet Options



X,Y Display (OrCAD)

To turn the current cursor position on or off, you need to turn the whole status line on or off,

        Choose Status from the Options menu.

The left side of the status line indicates the current cursor position (the origin is the bottom left 
corner of the worksheet). The status line also displays information about the current activity or 
mode.

See also
ToggleStatus line



Grid Parameters (OrCAD)

Grid References
To turn the worksheet border on or off, choose Sheet from the Options menu and click on the 
Border check box.
Stay on Grid
To turn the snap grid on or off, choose Snap Grid from the Options menu.
Visible Grid Dots
To turn the visible grid on or off, choose Sheet from the Options menu and click on the Visible 
Grid check box. You can also choose Visible Grid from the Options menu.

See also
Sheet Options
Toggle Snap Grid
Toggle Visible Grid



Repeat Parameters (OrCAD)

To set up the paste array parameters,

        Choose Paste Array from the Edit menu.

In the Paste Array dialog box the Horizontal option refers to X Repeat Step, Vertical refers to Y
Repeat Step and Text Increment refers to Label Repeat Delta.
There is an option in the Preferences dialog box to turn on/off text and number incrementing.

See also
Paste Array
Preferences



Visible Lettering (OrCAD)

Advanced Schematic Editor does not have an equivalent to the Visible Lettering commands.



Tag (OrCAD)

To tag a specified location on the schematic worksheet,

        Choose one of the Location Mark options from the Place menu.

Advanced Schematic supports up to 10 location marks. Use the Jump Location Mark options 
from the Edit menu to move the cursor to these set locations.

See also
Set Location Marks
Jump Location Marks



Center (OrCAD)

To center the worksheet view around the current cursor location,

        Choose Pan from the Zoom menu.

The Zoom Pan command is most effective when initiated with its shortcut key, HOME or Z, N.

See also
Zoom Pan



Zoom (OrCAD)

Center
In
Out
Select



In (OrCAD)

To zoom in on the schematic worksheet,

        Choose In from the Zoom menu.

The Zoom In command is most effective when initiated with its shortcut key, PGUP or Z, I.

See also
Zoom In



Out (OrCAD)

To zoom out, showing more of the schematic worksheet,

        Choose Out from the Zoom menu.

The Zoom Out command is most effective when initiated with its shortcut key, PGDN or Z, O.

See also
Zoom Out



Select (OrCAD)

To select a zoom scale,

        Choose one of the four zoom scales from the Zoom menu.

See also
Zoom 100%
Zoom 200%
Zoom 100%
Zoom 50% 



Printing



Screen Regions



Reference



Protel Schematic 3 (DOS) Help

Block
Current
Delete
Edit
File
Highlight
Information
Jump
Library
Move
Place
Repeat
Setup
Undelete
Zoom



Copy (Schematic 3)

To make a copy of the objects that are currently selected,

        Choose Copy and then Paste from the Edit menu.

Make sure that the current selection includes only those objects you wish to copy. You can use
the Edit Select and De-Select menu commands to select and de-select objects.

Copying a selection

See also
Copy
Paste



Block (Schematic 3)

Copy
Define
Hide
Inside Delete
Move
Outside Delete
Read
Write



Define (Schematic 3)

There are several ways to select a group of objects,

        1. Use the Select and Toggle Selection commands from the Edit menu. The Select Inside 
Area command is equivalent to Block Define.

        2. Use SHIFT+LEFT MOUSE to add individual objects to the current selection group,

        3. Enable the objects' selection field within its dialog box, it is also possible to use global 
editing commands to select multiple objects.

Advanced Schematic allows more than one block or group of objects to be selected at any one
time. As you select objects they are added to the current selection group.

See also
Select Inside Area
Toggle Selection
Toggle Single Object



Hide (Schematic 3)

There are several ways to de-select objects,

        1. Use the De-select and Toggle Selection commands from the Edit menu. The De-select 
All command is equivalent to Block Hide.

        2. Use SHIFT+LEFT MOUSE to remove individual objects from the current selection group,

        3. Disable the objects' selection field within its dialog box, it is also possible to use global 
editing commands to de-select multiple objects.

See also
De-Select Inside Area
Toggle Selection
Toggle Single Object



Inside Delete (Schematic 3)

To delete all the selected objects from the schematic worksheet,

        Choose Cut or Clear from the Edit menu.

Make sure that the current selection includes only those objects you wish to delete. You can 
use the Edit Select and De-Select menu commands to select and de-select objects.

See also
Cut
Clear



Move (Schematic 3)

To move selected objects,

        Choose Move and then Move Selection from the Edit menu.

Make sure that the current selection includes only those objects you wish to move. You can 
use the Edit Select and De-Select menu commands to select and de-select objects.

See also
Move Selection



Outside Delete (Schematic 3)

To delete objects outside a defined area,

        Choose Select Outside Area to select the objects to be deleted and then choose Cut or 
Clear from the Edit menu.

See also
Select Outside Area
Cut
Clear



Read (Schematic 3)

The Copy and Paste commands from the Edit menu are used to copy and place sections of a 
schematic worksheet into any open schematic document window.

See also
Copy
Paste



Write (Schematic 3)

To save a block or group of objects to a file. Paste a selection of objects into a blank document
window, then use the File Save As command to save the document to a new schematic file 
name.

See also
Paste
File Save As



Current (Schematic 3)

There is no equivilent command in Advanced Schematic. The current default settings for most 
items changes with the last placement of the item.

Line Type
Sheet Size
Junction Size



Line Type (Schematic 3)

Advanced Schematic Editor supports three different types of objects, wires, buses and lines.
Wires are used instead of Thin Signal and Thick Signal lines. There are four wire sizes, 
smallest, small, medium and large.
Buses are used instead of the Bus line. There are four bus sizes, smallest, small,
medium and large.
Lines are used instead of the Dashed line. Lines have three selectable line styles, solid, 
dashed and dotted. The dashed and dotted styles only apply to 'smallest' width lines.

See also
Place Wire
PlaceBuss
Place Line (Polylines)



Sheet Size (Schematic 3)

To select a schematic worksheet size,

        Choose Sheet from the Options menu and select a sheet size.

Advanced Schematic supports 10 standard imperial and metric sheet sizes. They include A, B,
C, D, E (or metric sizes A4-A0). You can also define your own custom sheet size up to 65 
inches square.

See also
Sheet Options



Junction Size (Schematic 3)

Advanced Schematic Editor supports four junction sizes, smallest, small,medium and large.
While placing a junction, press the TAB key to manually change the default junction size. When
using the Place Junction command the default size is determined by the last placed junction.

See also
Place Junctions



Delete (Schematic 3)

To delete objects from your schematic worksheet,

        Choose Delete from the Edit menu, you do not need to specify the type of object to be 
deleted, (e.g. Delete Junction).

The Delete Single Object command can also be used to delete an individual object
that has the focus.    All deletions can be restored by using the Edit Undo
command (ALT+BACKSPACE).

See also
Delete
Delete Single Object



Utilities (OrCAD)

        ANNOTATE.EXE
        DRAFT.EXE
        LIBLIST.EXE
        LIBARCH.EXE
        BACKANNO.EXE
        COMPOSER.EXE
        TREELIST.EXE
        PARTLIST.EXE
        HFORM.EXE
        LIBEDIT.EXE
        PRINTALL.EXE



ANNOTATE.EXE (OrCAD)

To rename all the Parts on a schematic worksheet or project.

        Choose Annotate from the File menu.

See also
Annotate



DRAFT.EXE (OrCAD)

Advanced Schematic Editor Application.



LIBLIST.EXE (OrCAD)

To add and remove libraries from the library list,

        Choose Add/Remove from the Library menu, or click the Add/Remove button in the 
Component Browser panel.

An unlimited number of libraries may be added to this list. Advanced Schematic only stores the
names of the library components into memory.
        

See also
Add/Remove Library



LIBARCH.EXE (OrCAD)

To make a component library of all the parts in a schematic project,

        Choose Make Project Library from the Library menu.

See also
Make Project Library



BACKANNO.EXE (OrCAD)

To back annotate part and pin information from a PCB was/is File,

        Choose Back Annotate from the File menu.

See also
Back Annotate



COMPOSER.EXE, DECOMP.EXE (OrCAD)

To compile and decompile library files, use the Open and Save As commands from the 
Schematic Library Editor File menu.
When using the Open command, Schematic Library Editor automatically recognises OrCAD 
library source files and Advanced Schematic library text files.
When using the Save As command, simply specify the type of output format for the Library file.



TREELIST.EXE (OrCAD)

To generate a text listing to represent the design hierarchy of a schematic project,

        Choose Reports and then Project Hierarchy from the File menu.

See also
Report Project Hierarchy



PARTLIST.EXE (OrCAD)

To generate a bill of materials file,

        Choose Reports and then Bill of Material from the File menu.

See also
Bill of Materials



HFORM.EXE, IFORM.EXE (OrCAD)

To create a hierarchical or flat netlist file,
Choose Create Netlist from the File menu.    
Net Check Report
To perform an Electrical Rules Check on the current project,

        Choose Reports and then Electrical Rules Check from the File menu.                    

Two other report files can be generated from the File Reports menu, a cross reference file and
a project hierarchy file.

See also
Create Netlist



LIBEDIT.EXE (OrCAD)

Advanced Schematic Library Editor Application.
To create, edit and manage your component libraries.

        Choose Edit Library from the Library menu. You can also launch the Library Editor as a 
separate application from the Windows Program Manager.

See also
Run Library Editor



PRINTALL/ PLOTALL.EXE (OrCAD)

To print or plot a schematic worksheet,

        Choose Print from the File menu.

The Setup Printer option in the File menu is used to select a printer or plotter
model, control printing options such as paper size, orientation, quality etc., and is also used to 
setup the scale, color mode and margins of your schematic sheet.

See also
File Print
Setup Printer



Edit (Schematic 3)

To edit the attribues of an object on the schematic worksheet,

        Choose Change from the Edit menu, you do not need to specify the type of object to be 
changed, (i.e. Change Junction).

You can also position the cursor over the target object and double click the LEFT MOUSE, or 
simply use the mouse to graphically change the object by physically moving the position of the
objects handles.
Part pins can not be edited or moved within the Schematic Editor. Pin changes must be made 
at library level, using the Schematic Library Editor. Please refer to the Schematic User Guide, 
for detailed explanations regarding library and component management concepts.
To edit the text within a text frame, click the change button in the text frames Change dialog 
box.

See also
Change



File (Schematic 3)

Clear
Dos
Files
Load
Path
Quit
Save



Clear (Schematic 3)

To create a new blank schematic worksheet,

        Choose New from the File menu.

See also
File New



DOS (Schematic 3)

Use the Windows Program Manager to switch to the DOS operating system.

        1.  While you are in the Advanced Schematic Editor press the ALT+TAB keys to switch to the 
Program Manager,

        2.  Click on the DOS icon (usually stored in the Main program group), or

        3.  Choose Run from the File menu and type COMMAND, then click OK or press ENTER.



Files (Schematic 3)

You can use the Open Sheet or Save As commands from the File menu to display a directory 
listing of files.    The Windows File Manager can also be used to view and organize your files 
and directories.



Load (Schematic 3)

To load a schematic worksheet file,

        Choose Open Sheet from the File menu.

The Open Project command is used to load and display the contents of all the hierarchical 
worksheet files contained in a schematic project.

Converting Protel 3 libraries

See also
File Open Sheet
File Open Project



Path (Schematic 3)

Use the Windows Program Manager to set a new working directory for your worksheet files.

        1. Select the Schematic Editor icon,

        2. Choose Properties from the Program Manager File menu,

        3. Change the working directory in the Program Item Properties dialog box.



Quit (Schematic 3)

To quit the current session of Advanced Schematic Editor,
Choose Exit from the File menu.
If any schematic worksheet has been modified since last saving, a dialog box will be displayed
that prompts to save the file(s).

See also
File Exit



Save (Schematic 3)

To save the changes made to the current schematic worksheet,
Choose Save from the File menu.
To save the current schematic worksheet to a new path, file name or format.
Choose Save As from the File menu.

See also
File Save
File Save As



Highlight (Schematic 3)

To select all the connections making up a Net,
Choose Select and then Net from the Edit menu.
The Select Connection command can be used to select the wires, junctions and net labels that
are connected between two pins.

See also



Components, listing sheet (Schematic 3)

To display a list of Parts on the current worksheet,
Choose the File Reports Bill of Materials command or File Reports Cross Reference 
command. These reports will be quickly generated for the current file/project and will be 
opened using the Notepad utility. You can also map these report text files to other text editors, 
using the File Run options.

Report BOM process
Report Cross Reference process

See also
Setup User Programs process



Information (Schematic 3)

Components
Highlighted Pins
Library
Status



Highlighted Pins (Schematic 3)

To display a list of the pins that are currently selected on the worksheet,
Choose Selected Pins from the Info menu.
The listing can be saved as a text file and can be sent directly to the printer port by entering 
the DOS reserved name PRN when you are prompted to supply a file name.
You can use the Schematic Library Editor to display a complete listing of the contents of a 
library file. Refer to the Schematic Library Editor reference manual and on-line help for further 
information.

See also
Information Selected Pins



Information    (Schematic 3 library)

The Schematic Library Editor can be used to display a complete listing of the contents of a 
library file. Refer to the Schematic Library Editor reference manual and on-line help for further 
information.



Status (Schematic 3)

To display information about your computer system,
Choose Status from the Info menu.

See also
Information System Status



Jump (Schematic 3)

Component
Location
Net
Origin
Text



Jump Component    (Schematic 3)

To jump to a component on the current worksheet,
Choose Search for and then Part from the Edit menu,
When the Component Browser is displayed, you can jump to a part within the current Project 
by first highlighting a component with the selection bar in the Components list box, then 
pressing the Jump To button.

See also
Toggle Component Browser process
Jump to Part process



Location (Schematic 3)

To move the cursor to a specified location,
Choose Jump and then New Location from the Edit menu.

See also
Jump New Location



Net (Schematic 3)

To move the cursor to a specified Net,
Choose Search for and then Net from the Edit menu.

See also
Search for Net



Origin (Schematic 3)

To move the cursor to the lower left corner of the schematic worksheet,
Choose Jump and then Origin from the Edit menu.

See also
Jump Origin



Text (Schematic 3)

To search for text on the schematic worksheet,
Choose Search for and then String from the Edit menu.

See also
Find Text
Find And Replace Text
Find Next Text



Library (Schematic 3)

Browse
Components
Load



Components, listing library (Schematic 3)

Components in the current sheet are listed (Reference designator and name)in the 
Components box in the Browse window. You can quickly generate a list of components by 
choosing either File Reports Bill of Materials or File Reports Cross Reference. These options 
generate text files which list components. The reports are opened as Notepad documents 
when either command is selected.

Report BOM process
Report Cross Reference process

See also
(Toggle) Component Browser process



Load (Schematic 3)

To add and remove libraries from the library list,
Choose Add/Remove from the Library menu, or click the Add/Remove button in the 
Component Browser panel.
An unlimited number of libraries may be added to this list. Advanced Schematic only stores the
names of the library components into memory.

See also
Add/Remove Library



Move (Schematic 3)

To move objects around the schematic worksheet,
Choose Move and then Move from the Edit menu.
Wires will retain their orthogonality as objects are moved around the worksheet. You can also 
use the shortcut 16 CTRL + LEFT MOUSE to pick up and move an object.

The Change Object Graphically command can be used to move and clean up individual bus, 
wire and line segments. There is not a specific menu command for this process.
While moving wires or bus segments you can use the SPACEBAR to toggle through the different 
angle modes of wire and bus placement. The INSERT and DELETE keys can be used to add and 
remove line segments.

See also
Move
Change Object Graphically



Place (Schematic 3)

Annotation
Component
Documentation Box
Junction
Line
Net Label



Annotation (Schematic 3)

To place comments on the schematic worksheet,
Choose Text and then Annotation from the Place menu.
While placing the annotation, press the TAB key to manually change the
default orientation, text and size of the annotation by typing new values directly
into a dialog box.

See also
Place Annotation



Component, placing (Schematic 3)

To place components on the schematic worksheet,
Choose Parts from the Place menu or click the Component tool button on the Wiring tools 
palette.
You can also place parts by clicking the PLACE button on the Component Browser.

See also
Place Parts
Place Part from Browser



Documentation Box (Schematic 3)

To place detailed descriptions and comments on the schematic worksheet,
Choose Text and then Text Frame from the Place menu.
While placing the text frame, press the TAB key to manually change the
default text, font style, text color, border width etc., by typing new values
directly into a dialog box.
Text Frames support the cut, copy and paste commands for text editing. It is possible to copy 
text to the Windows clipboard from another application and then paste the text into the text 
editing window.

See also
Place Text Frames



Junction (Schematic 3)

To place junctions on the schematic worksheet,
Choose Junction from the Place menu.
While placing the junction, press the TAB key to manually change the default junction size and 
color by typing new values directly into a dialog box.

See also
Place Junctions



Line (Schematic 3)

Advanced Schematic Editor supports wires, buses and lines as separate objects.
Wires are used instead of Thin Signal and Thick Signal lines. There are four
wire sizes, smallest, small, medium and large. 
Buses are used instead of the Bus line. There are four bus sizes, smallest, small,
medium and large.
Lines are used instead of the Dashed line. Lines have three selectable line styles, solid, 
dashed and dotted. The dashed and dotted styles only apply to smallest width lines.

See also
Place Wire
Place Bus
Place Line (Polylines)



Net Label (Schematic 3)

To place net labels on the schematic worksheet,
Choose Net Label from the Place menu.
While placing the net label, press the TAB key to manually change the default orientation, net 
name and size of the net label by typing new values directly into a dialog box.

See also
Place Net Label



Repeat    (Schematic 3)

To set up the repeat array parameters,
Choose Paste Array from the Edit menu.
In the Paste Array dialog box the Place button and the Execute Paste Array command
refers to the Execute Repeat command, Item Count refers to Default Count, Text Increment 
refers to Component Increment, Horizontal and Vertical option refers to the X and Y Offsets.

See also
Paste Array
Execute Paste Array



Setup (Schematic 3)

Keys
Menu Colors
Options
Display Colors
String Defaults



Keys (Schematic 3)

Advanced Schematic supports the assignment of Hot Keys not keyboard Macros. Hot
Keys allows you to assign keyboard keys and mouse button clicks to all of Advanced
Schematic Editor command processes.
Choose Hot Keys from the Options menu.
A number of macro editing applications are available for recording keyboard and mouse 
commands. The Windows Recorder for example, which is supplied with your Windows 
application can be used to record your keystrokes and mouse actions, and then play them 
back later by just pressing a key.

See also
Hot Keys



Menu Colors (Schematic 3)

You can use the Windows Program Manager to change the color of Windows screen 
elements. Such as menu text, menu bar, window frame, window background, title bar text, 
buttons, etc.
Choose the Color icon from the Windows control panel and select a new color scheme or use 
the color palette to customize your own.



Options (Schematic 3)

Auto Pan
Choose Preferences from the Options menu and click on the Auto Pan check box.
Backup
In the Preferences dialog box, you can set the interval for generating an automatic backup file 
and set the number of automatic backup files used in a rotating file system.
Cursor Type
In the Preferences dialog box, three options are available for the physical (or sheet) cursor, a 
large 90 degree cross, small 90 degree cross or a 45 degree cross. The sheet cursor is 
displayed when making selections, moving or placing objects.
Drag
Choose Preferences from the Options menu and enable/disable the drag option.
Ortho Mode
While you are placing wire or bus segments you can toggle through the placement angle 
modes by pressing the SPACEBAR. Wires and buses can be drawn at 90, 45 and any angle 
degrees.
Title Block
Choose Sheet from the Options menu and click on the Title Block check box.
Sheet Border
Choose Sheet from the Options menu and click on the Border check box.
View Device Pins
Device Suffix
Question Delete
Choose Preferences from the Options menu and click on the Question Delete check box.
Flash Cursor
Advanced Schematic Editor does not support the Flash Cursor command. You can use the 
Desktop settings from within the Windows Control Panel to change the blink rate of the text 
cursor. The text cursor is used for text input windows, such as, name fields or the text editing 
window of text

See also
Preferences
Sheet Options



Display Colors (Schematic 3)

BackGround
Choose Sheet from the Options menu and click in the Color, color box.
Sheet
Choose Sheet from the Options menu and click in the Border Color, color box.
Highlight
Choose Preferences from the Options menu and click in the Selections, color box.
Grid
Choose Preferences from the Options menu and click in the Grid Color, color box.
Objects
Each object primitive on the schematic worksheet can be assigned individual color attributes, 
color changes can also be applied globally. This allows you to color code wires, classes of 
parts or individual items. Many objects such as rectagles, ellipses and text frames have a 
separate color assignment for their outline and fill area.
To assign a new color to objects,
Click inside the color box within the objects change dialog box.

See also
Preferences
Sheet Options
Change



String Defaults (Schematic 3)

Advanced Schematic Editor does not have an equivalent to the String Defaults command. The
default text size and style is determined by the last placed text string. Text sizes and styles can
be globally changed across the schematic worksheet.



Undelete (Schematic 3)

To restore deleted objects back onto the schematic worksheet,
Choose Undo from the Edit menu.
Multiple levels of undo are supported. The Edit Redo command can be used to restore 
changes made by the Undo command.

See also
Undo



Zoom (Schematic 3)

Redraw
Pan
Expand
Contract
Select
All



Redraw (Schematic 3)

To redraw the objects on the current schematic worksheet.
Choose Redraw from the Zoom menu.

See also
Screen Redraw



Pan (Schematic 3)

To center the worksheet view around the current cursor location,
Choose Pan from the Zoom menu.
The Zoom Pan command is most effective when initiated with its shortcut key, HOME or Z, N.

See also
Zoom Pan



Expand (Schematic 3)

To zoom in on the schematic worksheet,
Choose In from the Zoom menu.
The Zoom In command is most effective when initiated with its shortcut key, PGUP or Z, I.

See also
Zoom In



Contract (Schematic 3)

To zoom out, showing more of the schematic worksheet,
Choose Out from the Zoom menu.
The Zoom Out command is most effective when initiated with its shortcut key, PGDN or Z, O.

See also
Zoom Out



Select (Schematic 3)

To select a zoom scale,
Choose one of the four zoom scales from the Zoom menu.

See also
Zoom 400%
Zoom 200%
Zoom 100%
Zoom 50%



All (Schematic 3)

To fit all objects on the current sheet in the window
Choose All from the Zoom menu.

See also
Zoom All



Utilities (Schematic 3)

ANNOTATE.EXE
POST.EXE
NETTRAN.EXE
NETCHECK.EXE
SLM.EXE
SCHEDIT.EXE
SCHPLOT.EXE



ANNOTATE.EXE (Schematic 3)

To rename all the Parts on a schematic worksheet or project.
Choose Annotate from the File menu.

See also
Annotate



POST.EXE (Schematic 3)

Netlist
To generate a Protel netlist file,
Choose Create Netlist from the File menu, select Protel format.    
Net Check Report
To perform an Electrical Rules Check on the current project,
Choose Reports and then Electrical Rules Check from the File menu.
BOM
To generate a bill of materials file,
Choose Reports and then Bill of Material from the File menu.
Two other report files can be generated from the File Reports menu, a cross reference file and
a project hierarchy file.

See also
Create Netlist
Bill of Materials



NETTRAN.EXE (Schematic 3)

To generate a netlist file in another format, other than Protel.
Choose Create Netlist from the the File menu, select the desired output format.
Advanced Schematic Editor supports many more netlist output formats than NETTRAN.

See also
Create Netlist



NETCHECK.EXE (Schematic 3)



SLM.EXE (Schematic 3)

Advanced Schematic Library Editor Application.
To create, edit and manage your component libraries,
Choose Edit Library from the Library menu. You can also launch the Library Editor as a 
separate application from the Windows Program Manager.

See also
Run Library Editor



SCHEDIT.EXE (Schematic 3)

Advanced Schematic Editor Application.



SCHPLOT.EXE (Schematic 3)

To print or plot a schematic worksheet,
Choose Print from the File menu.
The Setup Printer option in the File menu is used to select a printer or plotter model, control 
printing options such as paper size, orientation, quality etc., and is also used to setup the 
scale, color mode and margins of your schematic sheet.

See also
File Print
Setup Printer



Data Primitives
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Concepts

Project management
Library and component management
Configuration
Workspace
Processes
Objects in the workspace
Presentation quality schematics
Hardcopy
Design verification
Netlist generation
Report generation
OrCAD compatibility
Protel DOS schematic compatibility
ASCII file formats
Glossary



Presentation quality schematics

Protel for Windows Advanced Schematic provides extensive graphic capabilities for designing 
schematics. By using graphical features such as colors, TrueType fonts, and graphical images 
you can highlight, emphasize and illustrate important elements of the design. Advanced 
Schematic also supports high-resolution printing and plotting of schematic sheets, using a 
wide range of Windows-supported monochrome and color devices.
Using color
Using fonts
Image files
Printing



Select Printer

The available output device options will include those that have been installed using the 
Windows Control Panel (see your Microsoft Windows User's Guide for details). Most devices 
are supported by drivers delivered with your Windows software. You should note that new and 
updated drivers are released for both new and existing devices on a regular basis. For the 
latest information about print drivers, contact Microsoft Windows support or the device 
manufacturer. 
Rotation of fonts is not supported for all printers and the substituted fonts will only be used if 
the text on your schematic is in a standard horizontal (or landscape) orientation, and within the
size capability of the printer. PostScript printers support rotation of fonts at any angle



Batch Mode prints

When using this option from the Schematic Editor, this option prints either a single sheet or a 
batch of all open sheets (including all opened projects). When using this option from the 
Library Editor, prints a single component (from the window that is the current focus) or all 
components in the current library. The latter option allows you to print out an entire component
library in a single operation. When you choose this option, all representations of a component 
are printed, including each part (or device) DeMorgan and IEEE equivalents, when applicable. 
Component description fields are also added to the sheet. This option works with all other 
print/plot options, including scaling, etc.



Color mode (printing)

Two choices are available: color mode takes Advanced Schematic screen color assignments 
and uses these to assign colors to the print or plot, based upon the options available in the 
print or plot driver. Monochrome PostScript or HP-PCL devices will print grayscale 
representations of color. The number of gray levels, and the assignment of color to grayscale 
depends upon the driver and device. The Monochrome option, prints images in solid 
black/white only. No dithering or grayscale support is provided. This option is appropriate for 
low resolution dot matrix and single pen plotting.



Setting margins (printing)

The user has total control over margins, limited only by the margin limits built into printers or 
plotters that do not allow printing to the sheet edge (e.g., PostScript printers). When used with 
the Scale and Scale to Fit Page options (described below), this option will size the print area to
fit as closely within the margins as allowed by the aspect ratio of the print area. The Preview 
option allows you to preview the result of all settings and make adjustments before printing.

See also
Scaling prints and plots
Tiling prints



Basic library concepts

Libraries consist of component descriptions, represented by the individual part symbols that 
are placed in schematic sheets. Components can have one or many parts or subparts (e.g. 
gates in TTL components). The term component always refers to a complete library 
description -- either a specific manufacturer data book entity or a generic device (e.g., resistor,
capacitor, diode, LED, etc.).
Many components share the same packaging -- they have identical graphical depictions, but 
exist as individual names in libraries. These can be equivilent devices from different 
manufacturers, or components with the same package but a different function (e.g. 120ns 
versus 80ns RAM). While it is convenient to access these otherwise duplicate parts using 
either description, it    would be wasteful to create and store a separate graphical version of 
each item.
Advanced Schematic uses the concept of component groups to associate multiple component 
names with a single description stored in the library. This keeps libraries efficient and 
manageable. For example, while the TTL library contains 
nearly 1800 component names, the graphical and data descriptions that represent these 
components number only 600 or so.
When a component part is placed in a schematic sheet, the displayed version of the part is a 
representation of the library version only. The actual component exists only in the library. This 
means that components and their parts are changed or edited only at the library level -- never 
at the sheet level. Library level changes are globally applied to each instance of a part when a 
sheet is loaded. 
This principle maintains strict data integrity in parts libraries.

Component management
Component models



Keys (Hotkey)

Select the key (or mouse button) for hot key assignments. Assignments can include the ALT, 
CTRL and SHIFT keys.



Process (Hotkey)

Selects the process for hot key assignment.



Current Process (Hotkey)

This box lists the current process assigned to the selected key combination.



Description (Hotkey)

This box describes the purpose or use of the current process.



Assign (Hotkey)

Adds the key and process selections to the current hot key file (.KEY extension).



Load (Hotkey)

Loads an existing key file (.KEY extension) for editing.



Save (Hotkey)

Updates the current key file (.KEY extension) with items assigned during the current editing 
session. Overwrites any previous assignments in the current hot key file.



Defaults (Hotkey)

Resets the default hot key assignments. Any new assignments that have not been saved as a 
new hot key file will be over-written.



Special objects

        Error markers
Error markers are placed in schematic project sheets automatically 
during ERC (Electrical Rules Check) generation. These objects cannot be placed manually. A 
360 degree arc is placed at the site of each connective error or warning. The ERC error 
markers can be deleted from the sheet by clicking over the object with LEFT MOUSE and 
pressing DELETE.

        Special strings
Special strings are special pre-defined single line text objects you place in sheets, which 
generate automatic output when a sheet is printed or plotted.

Special strings



Move Handle

The Move Handle, referred to in the reference manuals and User Guide is no longer displayed
when the object is in focus. You can now move (focused) objects by placing the cursor 
anywhere inside the boundary of the object and clicking LEFT MOUSE. When the object is in the 
desired position, click LEFT MOUSE again.

See also
Selection and Focus



Capture

Capture refers to the ability of schematic editors to export the connectivity in a circuit in the 
form of a netlist.



Inside Area (Select)

Allows you to define a rectangular selection area. Only those objects that lie completely inside 
the area are included.
To choose the items inside a selection rectangle: 

        Choose the Edit Select Inside Area command (shortcut: s, i);

        You will be prompted "Select First Corner."

        Move the cursor then press ENTER or LEFT MOUSE to define the first corner of the 
selection rectangle;

        The prompt changes to "Select Second Corner."

        Move the cursor to enclose the selection area in the highlighted rectangle;

        Press ENTER or LEFT MOUSE to complete the selection.

The newly selected objects will be highlighted using the selection color. Any previously 
selected items will remain selected until de-selected.

See also
Outside Area



Outside Area (Select)

This option selects everything in the sheet outside the selection rectangle. The rules for 
inclusion in the selection are the same as for the Inside Area command. The procedure for 
defining the selection rectangle is the same as for Inside Area.



All (Select)

This command selects everything placed in the sheet.



Net (Select)

This command selects all wires and pins that connect a physical/logical net on the current 
sheet and nets on all other open sheets with the same net label. To use this feature:

        Choose Edit Select Net;

        You will be prompted "Select Net."

        Position the cursor over a wire within the desired net and press ENTER or LEFT 
MOUSE.

        The continuous net extending from the selected wire will be displayed in the selection 
color.

See also
Connection (Select)



Connection (Select)

Choose Select Connection (shortcut: S, C) to select the free objects (wires, buses, junctions,) 
that connect using the physical geometry of the system. Non-electrical objects will not be 
selected, even if they touch the connected items.

See also
Net (Select)



Toggle Selection

The Edit Toggle Selection command allows you to turn the selection state of individual objects 
"off" or "on" which duplicates "direct" selection performed using SHIFT+LEFT MOUSE. 
Shortcut: press X to choose from the De-Select options.
To use this feature:

        Choose the Edit Toggle Selection command (shortcut E, N);

        You will be prompted "Select object"

        Click on an object type to add or remove the item from the current selection;

        The prompt "Select object" will be continuously displayed.

        Press ESC to leave the Toggle Selection command.

See also
Select and De-Select commands



Bring to Front

This command moves an object to the front of other items in the display. When you use this 
command, you are prompted to choose the item to be moved. When you click on the item, it 
moves to the front of the display without changing its x or y coordinates.



Send to back

This command sends an object to the back of other items in the display. When you use this 
command, you are prompted to choose the item to be moved. When you click on the item, it 
moves to the back of the display without changing its x or y coordinates.



Bring to Front Of

This command moves an object to the front of another item. When you use this command, you
are prompted to choose the item to be moved. When you click on the item, you are then 
prompted to choose the "target" item. The item to be moved will be re-located in front of the 
"target" without changing its x or y coordinates.



Send to Back Of

This command moves an object behind another item. When you use this command, you are 
prompted to choose the item to be moved. When you click on the item, you are then prompted
to choose the "target" item. The item to be moved will be re-located behind the "target" without
changing its x or y coordinates.



OrCAD net identifiers

In OrCAD SDT, ports are called module ports and sheet entries are called sheet nets. The 
OrCAD model of hierarchy refers to horizontal intersheet connections, using module ports as a
flat design.



Cursor shape

Options include: large 90 degree cross (cross hair type), small cross or 45 degree cross.



Question Delete option

When enabled, prompts the user to confirm deletion, before the deletion is completed.



Snap to Center

If Snap to Center is enabled the cursor will jump to the center of a pin, wire, etc., as it is 
moved. If you have the Snap to Center off, the cursor position will remain relative to the point 
where the selection was made.
When you select a component with Snap to Center Option on, then the cursor will jump to the 
reference point of the component (generally pin 1). If this option is off then when you select a 
component the cursor will remain in the same position relative to the component.



Save Defaults

This option allows user settings, preferences and defaults to be written to SCH.INI and 
LIBEDIT.INI files when exiting the Schematic Editor and Library Editor applications. These 
settings, preferences and defaults are then loaded the next time you run Advanced Schematic.



OrCAD Port Length

Advanced Schematic allows the user to set ports to any length. This option preserves a fixed 
length for ports, so that these items will be compatible with OrCAD SDT, which sets module 
port length based upon the number of text characters in the port's label. Choose this option if 
you intend to export the sheet in OrCAD format, otherwise the port may not be aligned with the
connecting wire or bus, resulting in an error condition.



Drag Wires

When enabled, this option maintains wire-to-component pin and bus connections when 
components are moved. As you move components, the wires will drag (stretch) to maintain the
connection. Within reason, orthogonality will be maintained -- that is, wires will keep their 
horizontal/vertical orientation as far as possible. If you rotate the components, change the grid 
or move the component beyond the reach of the orthogonality feature, some segments may 
"rubberband" to an "any angle" placement mode. Use the Move Break Wire command (or 
press CTRL+SHIFT while clicking on wire segments) to restore orthogonal placement.



Auto Backup

A backup version of your sheet file is created whenever you save a file or project. This is 
named with the extension *.BAK.



OrCAD project management

OrCAD SDT users will be familiar the concept of master sheets, although this system handles 
project management somewhat differently. OrCAD using special objects, called pipelines to 
link "flat" project sheets. Under Advanced Schematic, sheet symbols represent each sheet in 
all multi-sheet projects.



Dialog boxes

Dialog boxes launch processes and other perform other functions, such as changing the 
attributes of data primitives. An example would be using a Change dialog box to enter new 
coordinates for an object. Some dialog box functions launch processes. For example, clicking 
the OK button in the Array dialog box launches the process Execute Paste Array process. 



Objects

Object (for object primitive, or primitive) is a generic term that refers to the individually editable
items that are the building blocks in your design, such as a wire or a junction.



NETCHECK.EXE (Schematic 3)

NETCHECK reads and compares the net (not component) information in two netlists.
To compare two netlists in Advanced Schematic, choose the File Reports Netlist Compare 
command.

Netlist Format notes

See also
Netlist Compare



Connector components (Schematic 3)

Schematic 3 allows the user to define a special component type: Connector. Connector 
components (usually a single bitmap part) are a special catagory of multi-part component, 
where each placed "part" represents an individual pin with a common designator. This feature 
is not supported in Advanced Schematic.
To acheive the effect of "connectors" simply place a port, linked to the component and pin 
number (located elsewhere on the sheet). This allows the same flexibility with pin location 
across a single (or multiple) sheets. 



Local hidden pins

One problem with hidden pins is that all hidden pins are deemed to be "global" when a netlist 
is generated. In other words, all hidden pins labeled VCC on all sheets are connected together
in a common net. This can be a problem if the designer intends to split these supply nets. In 
simple cases, the designer can merely un-hide and manually wire the individual pins. 
However, this can quickly grow into a tedious task, in complex, hierarchical designs.
To overcome this limitation, the user can place an "unspecified" type port on the sheet, wired 
with a net label which matches the hidden pins net (e.g. VCC). The port should be given a 
unique name. This will make all pins with the same label "local" to the sheet. These pins will 
not be connected to other hidden nets with the same names on other sheets.      

Place Port process
Place Net Labels process



Set Auto Pan (OrCAD)

Turns OrCAD Auto Pan off/on.
Preferences



Document

This option, in the Options Sheet dialog box, allows the user to specify information which is 
added to the sheet title block when the ANSI title block option is selected, including the 
organization name, address, sheet number, total sheets, title, number and revision. These will 
be ignored is the normal title block is selected.
Each of these fields can be defined as Special Strings. If you place a string, the text stored in 
its field in this dialog box will be printed with the sheet:
.organization
.address1
.address2
.address3
.address4
.sheetnumber
.sheettotal
.title
.documentnumber
.revision



Run command options

Tool menu commands allow the user to execute other applications directly. This allows the 
user to avoid using the Windows run command or searching through the Program Manager to 
launch other programs. 
File Manager, Control Panel, Calculator, Clock and Notepad are default options.

Tools Setup is also used to assign Editors to three    Advanced Schematic processes:
Text Editor: assigns the editor for editing and viewing report files;
Picture Editor: assigns the editor for placed graphic images;
CSV Editor: assigns the editor for CSV format Bill of Materials files.

Tools Setup is also used to assign links to other EDA applications and four additional User 
Commands.

Run command setup



Browser

The Browse window provides search for and jump to functions for all primitives placed in all 
open sheets.

Browser panel
The Browser panel is provided as an aid in searching for, and placing component parts into 
sheets and for locating other objects during schematic editing. This panel can be displayed as 
needed or hidden, to free more of the display area for the sheet workspace.

Text button
Click the text button at the extreme bottom left of the Browser panel to change the text of the 
designator (for parts) or label (other objects with text). If the object does not have a text label, 
clicking the button is ignored.

Jump button
Click the Jump button to jump the the highlighted primitive name in the list box. The display will
pan to center the object and the object will be placed in focus, displaying its graphical editing 
handles or control points, if any (see Focus, below).

Edit button
Click the Edit button to open the primitives dialog box, which provides access to all object 
attributes (see Changing objects, below).

Read Only button
The Read Only button allows users view the Read Only fields of a component. Use the Read 
Only button by selecting a component from the list above and then clicking the Read Only 
button. This action makes the display jump to the selected part and opens a dialog box with 
the part's Read Only Fields information.

Read Only Fields are created with a description a part in its library. These fields are not 
displayed on the schematic sheet nor are they printed.

Change button
The Change button allows users to directly access a listed part's dialog box. Scroll through the
Components in Library list to choose a component, then click the Change button. This action 
makes the display jump to the selected part and opens the part's dialog box.

Browse Nets option
Selecting the object type "Net Identifiers" allows viewing all net identifiers in the current 
project, including net labels, ports, power objects, and sheet entries. Listings include the name
of the net, type of object, sheet name and coordinates. Users can jump to or change Net 
objects with the Jump and Change buttons.



Report ERC process
Electrical Rules Check process

See also
Jump to Error command



Using Wildcard search fields

Wildcards can be used to define text strings when global editing all primitives that have text 
fields. This applies to parts,net labels, annotations (single line text), sheet symbols, sheet 
entries, ports and power ports.
Global text fields
When the Change dialog box for these primitives is opened, pressing the Global button opens 
the global editing options for that primitive. Three text entry boxes are displayed for each text 
field. The leftmost box shows the current text information for the item. The center field (under 
Attributes to Match By) is labeled Wildcard. The rightmost field is under Copy Attributes.
Syntax for Wildcard searches
The center field (Wildcard) defines which strings will be edited. If * is displayed (the defaualt), 
all strings for this field are available to be globally edited. This can be limited by defining 
specific cases, for example S* will limit the fields to strings beginning with S, etc. Wildcards 
are case in-sensitive.
The Copy Attributes (right) field defines the changes to be made to the string. Defining the 
change follows this syntax: {oldtext=newtext}. This means change portion of the string 
"oldtext" to "newtext". You can use multiple sets of brackets to define complex replacements. 
In this case the leftmost replacement is made, then the next on, etc. Although this is very 
powerful, you must take care, because the first change can effect subsequent replacements, 
possibly generating an unexpected result. Any mistakes can be corrected with the Undo 
command, however. You can further limit the replacement by typing {!Text=text} to make the 
changes case sensitive. In this case, "Text" becomes "text". Otherwise replacement is case in-
sensitive by default.
    

Global changes



Undo Limit option

This option, under Options Preferences, allows the user to set the number of Undo/Redo 
levels. The default is 50. This allows the user to backtrack through (and restore) 50 individual 
operations. The legal range is 0-16000. Because each operation must be stored in memory to 
enable Undo/Redo, setting a higher number may result in performance deterioration, while 
editing. If you notice Advanced Schematic slowing down after using the application for a while,
try selecting a lower number. The more memory you have installed in your machine, to higher 
the limit you can set without hurting the performance of your system. 



Change Part Dialog Box

This dialog box has changed considerably since the Advanced Schematic Reference was 
printed (see page 231 in the manual). The following additional fields are now part of this dialog
box:

        Lib Ref

        This is the library component identifier. You can change the component from this box and
make global changes, using the Wildcard:Wildcard and Change From/To fields.

        Designator

        This component field, the reference designator for the component on the sheet, is now 
editable directly from the Change box and can be used in global edits.

        Part Type

        This component field, normally used to display a value, is now editable directly from the 
Change box and can be used in global edits.

        Footprint

        Up to four footprints (or component patterns) can be assigned to components, using the 
Component Description command to access all component text fields.

        Once a component is placed. The Change Component dialog box provides access to the
footprint description fields. By default, the footprint pattern named in Footprint Field 1 (in 
the Component Description dialog) will be displayed.

        Attributes

        Up to 8 text strings (of up to 255 characters each) can be defined for parts, when they 
are played on the sheet. You can display these fields by enabling the Hidden Fields 
option. These fields can also be used when performing global edits.

        These 8 part attribute fields are separate from the 8 text fields which can be stored for a 
component in the library. Library text fields cannot be displayed in the sheet, but are 
included in CSV format Bill of Materials reports.



Netlist format notes

        Protel Part Types can contain up to 12 characters

        Footprint descriptions can be up to 12 characters

        Part designators can be up to 12 characters

        Net Names can contain up to 20 characters

        Pin Numbers are limited to 4 characters

        Wirelist Footprints can contain up to 29 characters

        Designators can contain up to 9 characters

        Pin Numbers are limited to 7 characters

        Pin Names are limited to 15 characters.

        Tango Part Types can be up to 16 characters in length

        Foot Prints can be up to 16 characters in length

        Designators can be up to 16 characters in length

        Net Names can be up to 16 characters in length

        Designator and ModuleName must be uppercase only

        Cadnetix Part Types can contain up to 17 characters

        Module Names can contain up to 15 characters

        Designators    plus Pin Numbers can contain up to 12 characters

        Net Names can contain up to 16 characters

        Node Numbers are not checked for length

        Pin Numbers can contain up to 3 digits

        Calay Part Names can contain up to 19 characters

        Module Names can contain up to 19 characters

        Reference Strings can contain up to 19 characters

        Node Names can contain up to 8 characters (see legal characters below)

        Node Numbers are limited to 5 digits (plus the leading 'N')

With the Calay netlist format, components are written into a separate file, named <project 
filename>.PRT. Nets will be written into <project filename>.NET.

        CBDS Net Names can contain up to 20 characters

        ComputerVision Net Names are limited to 18 characters

        EEDesigner Designators are limited to 8 characters

        Net Names are NOT supported

        Net Numbers are limited to 3 digits (plus the leading 'UN')

There are no net names in this format and each net name is converted into a sequential 
netnumber with the leading string "UN".



        FutureNet Part Types are limited to 16 characters

        Designators are limited to 6 characters

Currently only the Pinlist version of the format is supported. Netlist will be added in the future. 
Both lists contain the same information using a different format.

        HiLo Part Names are not checked for length

        Net Names are limited to 14 characters

        Intergraph No special notes

        Mentor Part Names are limited to 19 characters

        Module Names are limited to 19 characters

        Reference Strings are limited to 19 characters

A separate part file is generated, named <project name>.PRT. Net information is written into a 
file named <Project name>.NET.

        MultiWire Designators plus the Pin Number are limited to 32 characters

        Net Names are limited to 16 characters

        OrCad PCB II, Part Types are limited to 8 characters

        Footprints are limited to 8 characters

        Designators are limited to 8 characters

        Net Names are limited to 8 characters

        Pin Names are limited to 4 charactes

        PADS Designators are limited to 6 characters

        Net Names are limited to 6 characters

A separate part file is generated, named <project name>.PRT. Net information is written into a 
file named <Project name>.NET.

        PCAD, NLT Net Names are limited 8 characters

        Vectron Designators can contain up to 8 characters

        Net Names can contain up to 12 characters

A separate part file is generated, named <project name>.PRT. Net information is written into a 
file named <Project name>.NET.

About netlists
Other netlist formats



Library conversion (Schematic 3)

Advanced Schematic uses vector, rather than bitmap graphics to display parts. A special 
library, PROTEL.LIB contains substitute vector parts for all bitmap components from the 
standard libraries delivered with Protel Schematic 3.3 (the DOS version).    
When you load Schematic 3.3 sheet files, these components will be substituted automatically 
for the bitmap versions.
When a user-created component bitmap shape cannot be matched to PROTEL.LIB, Advanced
Schematic will automatically "vectorise" these parts and report them as "unmatched." In many 
cases, the automatically vectorised components are perfectly acceptable, however, in some 
cases you may wish to improve their vector rendering. 
The follow procedure can be used to edit these un-matched components and add these 
additional parts to PROTEL.LIB so that they can be automatically substituted the next time you
load a Schematic 3 sheet file.

        1. In the Schematic (sheet) Editor, use Library Add to open the special PROTEL.LIB, which 
should be in the same directory as the Advanced Schematic applications. PROTEL.LIB 
parts are named using a special Bitmap ID#    which "describes" the orginal bitmap 
shape in the DOS version.

        2. Open your Schematic DOS sheet file.    Any components which cannot be matched 
(based upon shape) will be reported after the sheet is loaded. A text file named 
(filename).$$$ listing un-substituted parts will be generated and displayed using the 
default text editor (see under Run command). Leave this text file open -- you will need 
the information in this file later in this procedure.

        3. Use the Library Make Project Library command to create a new library from the open 
sheet (or sheets). This library will include all project parts -- both substituted and non-
substituted. Make sure that you save the library in Binary (.LIB) format.

        4. Launch the Schematic Library Editor. 

        5. Open both your Project library AND the PROTEL.LIB library.

        6. Using the text report, search the project library for the unmatched components. Click in 
the Components list box to display the first unmatched part. Advanced Schematic will 
have "vectorised" this part, substituting vectors, where possible for the bitmap patterns. 
Although some patterns may not be completely or optimally vectorised, it is a simple 
matter to manually clean-up the component, if desired, using the standard graphical 
editing tools in the Library Editor.

        7. Using Rename Component, name the component using the Bitmap ID# in the report 
text, including the minus (-) sign, if any.

        8. Using the Component Copy or Move command, add the renamed component into the 
PROTEL.LIB library.      

        9. Repeat this process for each unmatched component, being careful to rename the 
component with the precise Bitmap ID# in the report.

        10. Save the PROTEL.LIB library, which now includes your newly vectorised parts. You can 
discard the project library.

When loading any subsequent Schematic 3 files, parts which match the (now cleaned-up) 
original bitmap version will be automatically substituted. So, it is only necessary to perform 
one "clean-up" per unique pattern.



Organization section of the sheet (OrCAD)

For fields in the Organization section, the following limits will be observed when writing a sheet
out to OrCAD format:
The date string is clipped to 18 characters.
The document number is clipped to 36 characters.
The revision string is clipped to 3 characters.
The title is clipped to 44 characters.
The Organization is clipped to 44 characters.
The 4 Address fields are clipped to 44 characters.
(In Advanced Schematic all fields can be 255 characters)



Junctions (OrCAD)

Advanced Schematic supports 4 junction sizes. In OrCAD there is only one junction size so 
the size information is clipped to the single OrCAD type.



Wires and buses (OrCAD)

There is only one size available for these items in OrCAD, so all width information is lost. Also,
line or buses loses their polyline behavior and is broken into individual line segments.



Dashed lines (OrCAD)

Dashed lines are written out to OrCAD as individual Dashed line segments, polyline behavior 
is lost when saving Dashed lines in OrCAD format.



Bus Entries (OrCAD)

OrCAD bus entries are always 10x10 grid points, so only default size Protel bus entries will be 
written out as OrCAD bus entries.



Module Ports (OrCAD)

The most important element of OrCAD Module Ports is the length of the Port. In OrCAD the 
length is totally dependent upon the number of characters in the Port name. In the Advanced 
Schematic Options-Preferences dialog box, the user can specifiy OrCAD Ports. This simulates
the behavior of OrCAD Module Ports so that the port length is dependent upon the number of 
characters, preserving connectivity when the port is written out to an OrCAD file.
CAUTIONUsers must take care that this option is not enabled when loading sheets created 
without this option -- because the Ports may be automatically re-sized, changing their 
connectivity in the sheet. The user can close the file without saving, then reload with OrCAD 
Ports disabled, to fix this problem.
Inversion of characters in Port names

OrCAD does not support the use of the inverson bar over characters in Module Ports. 
Advanced Schematic ports with inversion will be displayed as originally entered (backslashes 
before the inverted character).



Net Labels (OrCAD)

When writing files out in OrCAD format, all font information is lost when the Net name is 
converted to OrCAD monospace text. Size information is retained using the closest OrCAD 
font size. In Advanced Schematic, there are 4 orientations for Net Labels: 0, 90, 180, 270 deg. 
OrCAD restrict Net Labels to horizontal or vertical orientation and characters are not rotated. 
This can cause distortions when vertical netlabels are written out to OrCAD files. This will not 
effect netlisting, if the netlabel is placed properly on the wire. 
Recommended Practice Restrict net label orientations to 90 or 270 degrees when writing out 
to OrCAD format.



Sheet Symbols and Sheet Nets (OrCAD)

When writing out sheets in OrCAD format, the same restrictions apply regarding use of the 
inversion bar in Module Port names (see Module Ports).



Parts (OrCAD)

Most important restrictions involve OrCAD libraries (see Libraries). When writing an OrCAD 
file, the 8 Description fields, the Sheet Part filename, the Designator and the Part Type. These 
are clipped to 128 characters in OrCAD (can be 255 characters in Advanced Schematic). 
OrCAD supports only standard and DeMorgan representations. IEEE mode parts will be 
written out to OrCAD files as standard mode versions. 
Note: OrCAD Power Objects can be loaded as parts (rather than Power Ports) in Advanced 
Schematic but this is not recommended as it results in inefficient memory use.



Power Objects (OrCAD)

OrCAD supports the first 4 Advanced Schematic types only (Circle, Arrow, Bar or Wave). 
Power GND, GND Signal and GND Earth are not supported. When saving files in OrCAD 
format, these will be converted to Bar in OrCAD sheets.
Note OrCAD Power Objects can be loaded in Advanced Schematic sheets as parts (rather than
Power Port objects) but this is not recommended as it results in inefficient memory use.



Trace Name (OrCAD)

This primitive is converted into a Simulation Probe when loaded in Advanced Schematic and is
converted back to Trace Name when written out as an OrCAD file. The only restriction is on 
the length of the string (128 characters in OrCAD vs. 255 characters in Protel).



Vector Column (OrCAD)

This primitive is converted into a Simulation Vector when loaded in Advanced Schematic and 
is converted back to Vector Column when written out as an OrCAD file. The only restriction is 
on the length of the string (128 characters in OrCAD vs. 255 characters in Protel).



Stimulus (OrCAD)

This primitive is converted into a Simulation Stimulus when loaded in Advanced Schematic 
and is converted back to Stimulus when written out as an OrCAD file. The only restriction is on
the length of the string (128 characters in OrCAD vs. 255 characters in Protel).



Error Markers (OrCAD)

These objects are converted into Protel Error Markers when OrCAD files are loaded and 
converted back to the OrCAD version transparantly, when written out as an OrCAD file. The 
only restriction is on the length of the string (128 characters in OrCAD vs. 255 characters in 
Protel).



No Connect (OrCAD)

These objects are converted into Protel No ERC symbol and converted back to the OrCAD 
version transparantly, when written out as an OrCAD file. In Advanced Schematic, placing this 
symbol in Advanced Schematic will supress all error messges, in OrCAD it will only supress 
Unconnected Pin ERC messages.



Layout Directive (OrCAD)

The OrCAD version of this object is a string only. When loaded from OrCAD the Track, Via and
Layer information are split out from the other information. When written back out to OrCAD, 
these three items are written back into OrCAD format (length is restricted to 128 characters for
the total string). Advanced Schematic re-formats Layout information for use with Protel PCB 
systems and provides additional fields which are not supported by OrCAD.



Libraries (with OrCAD sheet files)

When writing out a sheet file in OrCAD format, the parts list for the sheet is added to the end 
of the file, as per OrCAD. There is no support in the current version for creating an OrCAD 
library from Advanced Schematic, so users must create all required components using 
OrCAD's library management tools.



Loading schematics (OrCAD)
Hierarchy support

Hierarchical OrCAD projects are opened recursively, with each sheet being opened and 
converted into an Advanced Schematic project. When opening "flat" multi-sheet OrCAD 
projects, where "Pipestring" links list the other sheets in the project, these are converted into 
empty Sheet Symbols. Advanced Schematic then "descends" through the Sheet Symbols to 
open the sheet that was represented by the Pipestring. Therefore, OrCAD flat projects are 
converted in Advanced Schematic "simple" hierarchical projects, with a Master Sheet and 
(unconnected) Sheet Symbols for each sheet in the project. The Pipestring is lost. When 
writing our these projects to OrCAD, they are writting using the same "simple" hierarchical 
structure. The user must add the Pipestrings back to the master sheet to convert the project 
back into OrCAD's "flat" format.
Sheet Sizes

In OrCAD, five size labels are available in the system: A, B, C, D, E. These "sizes" do not 
represent an actual set of dimensions, but can be defined by the user to represent any actual 
sheet size and stored in the OrCAD environment (not in the sheet file). When loading OrCAD 
sheets, the user must use Advanced Schematic's custom sheet size option to define the actual
required size, as no absolute information is provided by the OrCAD file.



Connectivity (OrCAD files)

OrCAD may not deem some overlapped wires/pins as connected, even when these 
connections are recognized by Advanced Schematic. All butted connections are recognized in 
both Advanced Schematic and in OrCAD SDT.



SPICE netlist generation

The SPICE netlist option has some unique options, compared to other netlist formats. These 
options allow the user to extract the necessary information to generate a SPICE netlist file 
directly from the schematic. 

Net Identifiers

Berkeley Spice currently supports both numeric (Net Numbers) and alphanumeric    (Net 
Names) net identifiers. Earlier versions of SPICE (and some commercial SPICE programs) 
only support net numbers.

When you generate a SPICE format netlist, Advanced schematic will give the option of net 
names or net numbers. If you choose to use net numbers, then Advanced schematic will 
generate net identifiers starting at 10000. If you place net labels on the schematic sheet, they 
will be ignored unless they are numeric. For example the netlabel    27 will be used in the 
netlist, but the netlabel VCC1 will be overidden by a numeric net identifier greater than 10000.
If    you choose net names instead of numbers then all netlabels from the schematic will be 
used.

SPICE Text Frames
If you have a text frame with the word "Spice" as the first line, then all the information stored in
that text frame will be dumped directly at the beginning of the Spice netlist file.
So, the format is:
Spice

xxxxxxxxxxxxxx

xxxxxxxxxxxxxx

xxxxxxxxxx

etc...
You can have any number of these Spice text frames, anywhere in the schematic project and 
all will be included at the beginning of the Spice netlist file, so things like model information for 
components, etc. will be placed here along with directives to the Spice compile, such as 
probe. 
The Spice keyword is not added to the netlist.
OrCAD Pipe directives are converted to text frames when loading OrCAD schematics. 

Voltage and Current Sources
In the SPICE.LIB library there are special components for voltage and current sources. These 
should be used to insert stimulus information into the netlist file. For Example, if an 
independent 
voltage source is required between net 13 and Ground then the required line in the file may be

VIN 13 0 AC 1 SIN(0 0.1 5MEG)    

To create this line, set the designator of the volatge source component to VIN, and the part 



type to "AC 1 SIN(0 0.1 5MEG)" , Advanced Schematic will add the required nodes numbers.
 

Spice Power Ports
For compatibility with OrCAD, Power Ports can be used to pass information about power 
inputs to the Spice netlist. If the string "AC" or "DC" appears in a power object, then a special 
conversion is done on the string net power object and it is written to the Spice netlist in a 
special format. For example, if you have a power object and the string in the power object is 
"VCC DC 12" then one of the nets that is created as VCC, will have the attribute DC 12 
attached to it in Spice format. In addition, in the MAP file, that same information will be written 
out as the net 
name VCC DC 12.

Map files
 The Spice format creates two MAP files in addition to the netlist files. A list of the node 
numbers, cross referenced to the net names is placed in the first MAP file because the 
netnames 
in the Spice file are numbers starting at 10000 and incrementing sequentially, because many 
Spice systems can't handle alphanumeric net names. Also, it's important to use the Spice 
library, 
because Spice systems can only support numeric node numbers (or pin names). So, for 
example, if you have a transistor, you have to convert E,B and C to 1,2 and 3, etc. Protel will 
add a library 
called SPICE which will have components in those formats. Users should either restrict 
component use to the Spice library, or modify their transistor libraries, etc.to support those 
conventions.

About netlists
Other netlist formats
Netlist format notes

See also
Create Netlist



Choose Schematic Sheet



New Features (Release 2.0)

A number of new features have been added to Advanced Schematic. Select a topic for 
information about these features:

        Concepts

        Additional Part Fields
        Additional Sheet Options
        Additional Special Strings
        Additional System Information
        Advanced Pld Netlist
        Advanced Global Editing For Parts
        Automatic Junctions
        Autopan Options
        Command Status Bar
        Communication between Applications
        Complex Hierarchy support
        Component Browser Changes
        Cross Probing
        Cross Project Global Editing
        Direct Selection
        Drag and Drop editing
        EESOF Support
        Environment Files
        File Dialog Changes
        File Open Filters
        Font Manager
        Forward Annotation to Advanced PCB
        Graphical Editing Hotkey List
        Guided Wiring
        Improved Connection Dragging
        Memory Monitor
        Object Alignment
        OrCAD SDT 386+ support
        Part Field Names
        Part Update reporting
        Project Manager Changes
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        Quick copy attributes
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        Save Object Defaults
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        Trace Netlist Generation Options
        Windows .WMF Clipboard support

        Commands

        Align Objects
        Align objects on bottom
        Align objects on left
        Align objects on right
        Align objects on top
        Center objects around horizontal axis
        Center objects around vertical axis
        Convert Complex To Simple Hierarchy
        Cross Probe Pin on PCB
        Distribute equally along horizontal axis
        Distribute equally along vertical axis
        Edit Object From Browser
        Find and Replace Text
        Find Component in Library
        Find Next
        Find Text
        Memory Monitor Setup
        Open Environment Configuration File
        Popup Alignment Menu
        Popup Tools Menu
        Remove Template
        Run Analog Simulator
        Run Digital Simulator
        Run Library Editor
        Run Mixed Signal Simulator
        Run PCB Editor
        Run PLD/FPGA Compile
        Save Environment Configuration File
        Set Template File Name
        Setup Autopan
        Toggle Command Status Bar
        Toggle Electrical Grid
        Update Current Template
        View Read Only Part Fields



Using Protel Advanced Schematic With HP EEsof Touchstone and Libra

Advanced Schematic includes netlist output format for HP EEsof Libra and Touchstone and a 
simulation model library, EESOF.LIB. Advanced Schematic outputs two EEsof formats: EEsof 
Touchstone, for linear simulation; and EEsof Libra, for non-linear simulation. Both EEsof netlist
formats are saved using the special file extension ".CKT."

Setting component parameters
Component objects have been specially extended to encompass the EEsof simulation 
parameters. Users can define simulation parameters in an existing part using the extended 
part field controls in the library editor and the Part dialog box.
 
Attributes fields region of a Part dialog box for an EEsof part. In this library, part fields have 
been named for the simulation parameters. These parameters are compiled into the CKT 
block of an EEsof Libra or EEsof Touchstone netlist.

When an EEsof netlist is output from Advanced Schematic, any text in the part fields of a 
component are compiled directly into the netlist. These parameters are defined in the dialog 
box for the part in the part fields and using the part field names definable in the library editor. 
See the "Part Fields" section for more information.

When an EEsof netlist is output any text in the part fields of a component are compiled into the
CKT section of the netlist and an equal sign "=" is automatically placed between the part field 
name and the part field text.

Several conventions are used to conform to the syntax of the EEsof netlist. See your EEsof 
documentation for more information on netlist syntax, usage and parameter definitions. The 
following marks are used in part field names (set from the library editor) to indicate the use or 
syntax:

{} indicates an optional parameter; the Part Field Name is not added to the CKT section if a 
value is not specified.

< > indicates the text in the part field will appear in the CKT section without the Part Field 
Name, used when specifying datafiles. 

[ ] indicates the Part Field Name and the text in the part field will be enclosed within open and 
closed brackets. 

(=) indicates no "=" (equal sign) will be inserted between the part field name and the text in the
part field.

The following mark is used only in a part field:
^ inserted before a character in a part field overrides the default "=" inserted between the part 



field name and the part field.

Source Block Components
Source Components that are to be included into the Source Block of the CKT file need to have
"(Source Block)" included in the description field for the part.    This is defined in the Library 
Editor.

Embedded text blocks
You can embed text in a schematic which will be compiled into an EEsof netlist by placing a 
text frame(s) on any part of your project. Each text frame must start with the syntax 
"EESOF_<DataBlockName." on the first line (by itself) and any further information placed on 
subsequent lines, per the example below.

Embedded text frames are used to place information into a section of an EEsof netlist, 
specified by the data block name, on the first line of the text frame. This example is from the 
file EESOF3.SCH.

General simulation settings
When the EEsof Touchstone or Libra netlist format is designated during netlisting, a special 
dialog box is displayed:

A dialog box opens when the File-Create Netlist    command is used and an EESof format is 
designated. This dialog box allows users to select the desired unit values for each simulation 
measurement field. For example, for Frequency the designer can choose from the units GHz, 
Hz, KHz or MHz. This information is attached to the DIM section of an EEsof netlist.

See also
Create Netlist



Automatic Junction Insertion and Removal

When enabled, automatically places a junction tie when placing wires or other electrical items. 
Junctions are placed when a wire is placed across another object's electrical hot spot(s) (e.g. 
across component pins, power ports, etc.). Junctions are also placed when a wire is 
terminated on another wire segment. When this option is active, junctions are also removed 
automatically when electrical object connections are broken.

See also
Options Preferences



Sheet Templates

Sheet templates are created in the same environment used for schematic editing. Once 
created, these pre-defined templates can be applied to new or existing projects. To define a 
template, first choose File-New to load an empty sheet into the workspace, then:

1. Choose Options-Sheet from the menu bar. Unmark the Title Block check box. Click OK.

Notice that the standard title block no longer appears on the page. Zoom-in to the bottom right 
corner of the page to start a custom title block. Draw a new title block:

2. Choose the graphical line tool from the Drawing Tools palette or use the Place-Drawing 
tools line command.

3. Before starting the line, press the TAB key. The Line dialog box opens.

4. Click in the Color box to open the Color Selector, then scroll up to color number 4 (black). 
Click OK to close the Color Selector dialog box then click OK in the Line dialog box to accept 
this change.

5. Now, position the cursor in the sheet workspace and click to begin the first title block line 
segment. Click to mark the end of each segment, continue until you have defined a box.

6. Press ESC key once to end the line and press ESC again to exit the Place Line command. 
Now place text in the title block:

7. Choose Place-Text-Annotation from the menu bar.

8. Before placing the text, press the TAB key to change the text attributes. Press the Font 
Change button.

9. In the Size field, type 10 and Click OK.

10. In the Text field type .ORGANIZATION and then click OK.

The special string .ORGANIZATION is mapped to a field in the Document Info dialog box. This
box is accessed from the Options-Sheet dialog box. Use of special strings is outlined in the 
next tutorial, below. Continue to define your custom title block:

11. Position the cursor inside your new title block, then click OK. Press ESC to exit the place 
text annotation command. Now save this sheet as a template:



12. Choose File-Save As from the menu bar. Type MY_SHEET.DOT in the Filename field and 
click OK. 
 
The extension .DOT defines this file as a sheet template. This template can be loaded into a 
single existing sheet or an entire hierarchical project. Open a new sheet and load your 
template:

13. Choose File-New from the menu bar. A new schematic sheet is created. Now load the file 
MY_SHEET.DOT as a template.
 
14. Choose Options-Load Template To Sheet from the menu bar. Choose MY_SHEET.DOT 
and click OK.

15. Choose Options-Sheet from the menu bar. The Schematic Sheet dialog box appears.

16. Mark the Enable Sheet Template check box and click OK.

This new sheet now include the template information you saved. Sheet templates can be 
created from any schematic sheet at any time.

See also
Set Template File Name
Update Template
Remove Template
Options Preferences



Cross Probing

Advanced Schematic fully supports multi-document and multi-application use of the Windows 
environment. This allows the user to open Advanced Schematic and Advanced PCB at the 
same time. When a schematic sheet (or project) and its PCB layout are open at the same 
time, Advanced Schematic and Advanced PCB version 2 support bi-directional cross probing.
For example, the user can select a part in the schematic, and the PCB editor will jump to and 
display the corresponding component. The corresponding PCB-to-Advanced Schematic cross 
probe is also supported: pick a component footprint on the PCB and display the corresponding
schematic part. Schematic pin-to-PCB pad cross probing and net label-to-physical net cross 
probing are also supported.

See also
Communication with Advanced PCB
Cross Probe Part
Cross Probe Pin
Cross Probe Net



Find and replace text editing

Advanced Schematic allows users to find and replace text anywhere on a sheet or across a 
multi-sheet project. For example, you may wish to rename a net across a multi-sheet project.
 
To search and replace text:

1. Choose the Edit-Replace Text command. The Text Find And Replace dialog box opens.
    
Text Find and Text Find And Replace dialog boxes are similar. This process supports the use 
of wildcards (*) when searching for text and allows the use of conditional replacement x=Y.

2. Type the Text To Find string.
The Find Text and Replace Text commands support the use of the asterisk "*" as a wildcard 
character for variable length text strings (see below).

3. In the New Text field, type the replacement text. Replacement can be made conditional (see
below).

4. Choose the Scope for the change. Changes can be applied to the Current Docuement Only 
or to All Open Documents. Objects with text to be changed can be restricted to selected or 
unselected items, if desired.

5. Choose any other Options. Changes can be made on a Case Sensitive basis (upper and 
lower case must match exactly when searching). Replacement text always matches the case 
used whentypeing text into the New Text field. If you wish, you can have Advanced Schematic 
prompt you before the replacement is made for each item.

Restricting changes to net identifiers
This option allows the user to restrict find and replace text editing to net identifier objects: net 
labels, power ports, ports and sheet entries.

6. Click OK to perform the text replacement.

See also
Find Text
Replace Text
Find Next



Component Browser Changes for version 2

The Browser panel is provided as an aid in searching for, and placing component parts into 
sheets and for locating other objects during schematic editing. This panel can be displayed as 
needed or hidden, to free more of the display area for the sheet workspace. The Browser has 
three sections, Library, Components In Library and Browse.

Additions to Components In Library
Find Button - Opens the Find Component dialog box, this command is used to search for a 
component that is in a specified drive/path, in the current listed libraries, or on all drives across
a network. The component can be found by library reference name and/or by component 
description.

Additions to Browse
All electrical objects can now be listed in the Browse list box.
Whole Project checkbox - specifies if all objects in a project are listed or only the objects on 
the current sheet.
Mask field - used to list specific objects. Wildcard characters (*) can be used in the Mask field.
Partial Info checkbox - if enabled, only partial object information is listed in the object list box.
Text button - Click the text button at the extreme bottom left of the Browser panel to change 
the text of the designator (for parts) or label (other objects with text). If the object does not 
have a text label, clicking the button is ignored.
Jump button - Click the Jump button to jump the the highlighted primitive name in the list box. 
The display will pan to center the object and the object will be placed in focus, displaying its 
graphical editing handles or control points.
Edit button
Click the Edit button to open the primitive's dialog box, which provides access to all object 
attributes.

See also
Edit Object From Browser
Find Component in Library



Guided Wiring

Special automation features speed the connection of electrical items in the schematic sheets. 
An electrical grid provides true "snap to" wiring of all electrical items: ports, sheet entries, 
buses, bus entries, net identifiers, wires and parts. When this feature is active, the cursor will 
jumps to any nearby electrical "hot spots" and then change shape to indicate the connection 
point. The user need only click (or release LEFT MOUSE) to complete the connection.

Options allow the user to turn the electrical grid off or on and to automatically place junctions 
when terminating a wire tangent to an existing wire. Junctions are also automatically placed 
when wires cross pins of parts or power objects. Connections between electrical objects are 
maintained as the objects are "dragged" to a new location on the sheet. The system will even 
add or remove wire segments to maintain orthogonal routing during complex moves.

See also
Options Sheet
Options Preferences



Spice Netlist Changes and additions for verison 2

See also
Create Netlist



Part Field Names

The names of part text fields can be defined in the Schematic Library Editor (Component-
Description command). Up to 255 characters can be used, but only the end of the character 
string will be displayed in the Part dialog box if the length of the string exceeds the display 
area. There is room for 14 characters and/or spaces, when 12 point 'Helvetica' is used as the 
dialog box font (Options-Preferences command). Custom field names are not used for column 
headers in CSV format Bill of Material reports.

See also
Part Fields



Protel-2 Netlist Format

This option is an extended version of the Protel netlist. It is distinguished by the additional field
support and detail that supports Advanced PCB 2.0 and simulation packages. Note that this 
format has three sections and that each field is first named, with the field data on the following 
line.

The first part of a Protel netlist describes each component

        PROTEL NETLIST 2.0  File header identifies Protel 2 format;

        [  Bracket marks the start of each component

        DESIGNATOR  Each field is first identified;

        C8  Component designator (label);

        FOOTPRINT

        RAD0.2  Footprint/package description

        PARTTYPE

        0.1uf  Comment, (or value);

        DESCRIPTION

        *  Sheet part description field;

        Part Field 1

        *  Sheet text fields (1-16) of up to 255 characters;

        Part Field 2

        *

         (etc.)... (continues to Part Field 16)

        Part Field 16

        *

        LIBRARYFIELD1  Library text fields (1-8) of up to 255 characters;

        LIBRARYFIELD2

(etc.)...(continues to Library Field 8)

        LIBRARYFIELD8

        ]  End component delimiter;

The component description section is followed by a listing for each net within the netlist.

        (  Begin net delimiter;

        H/-E  Name of first net;

        DECA1-1C DEC36-1C PASSIVE  First node in net. Includes: component-pin designator (single blank 



space) part type-pin name (single blank space) Pin electrical type;

        U16-1 74HC00-_A INPUT  Next node in net;

        U16-2 74HC00-_A INPUT     Last node in net;

        )  End net delimiter;

Any number of components or nodes can be included in a Protel or Protel2 netlist, limited only 
by available memory.
 
Note that net descriptions are distinguished from component descriptions by the use of 
rounded, rather than square brackets. The extension .NET is reserved for Protel format 
netlists. A simple Protel netlist format, supports basic netlist-based auto component 
placement and autorouting in Protel Autotrax and Protel for Windows PCB layout packages.

See also
Create Netlist



Advanced Pld Netlist

Protel's Advanced PLD application uses this netlist to compile logic for FPGA/PLD 
programming. This format also supports the CUPL FPGA/PLD environment from Logical 
Devices, Inc. The format is the input to the LIAISON program from Logical Devices, Inc.

See also
Create Netlist



Object Alignment

Two alignment methhods are provided. You can align a group of selected objects on both axis,
by choosing Edit-Align-Align. Or, you can align objects on one axis, by choosing the other 
Align menu commands.

Align objects by selecting them and then choosing Edit-Align command, or by choosing Edit-
Align--Align Left, Align-Right, etc. 
To align objects using the Align Objects dialog box:

1. Add all items to be aligned to the current selection, making sure that only items to be 
aligned are selected. You can use the Edit-DeSelect-All command (shortcut: x, a) to clear the 
current selection.

2. Choose Edit-Align-Align and designate the desired horizontal and/or vertical alignment 
combination. You can also choose the Align To Grid option to constrain alignment to the 
nearest grid point.

3. Click OK to close the dialog box and align the selection.

To align objects using the other Align commands:

1. Add all items to be aligned to the current selection, making sure that only items to be 
aligned are selected. You can use the Edit-DeSelect-All command (shortcut: x, a) to clear the 
current selection.

2. Choose Edit-Align and the desired alignment command (Align Left, Align Right, etc).

3. The selection will be aligned according to the command selected.

Remember, if you are not happy with the alignment, you can use Edit-Undo to remove this 
change.

See also
Align Objects
Align objects on bottom
Align objects on left
Align objects on right
Align objects on top
Center objects around horizontal axis
Center objects around vertical axis
Distribute equally along horizontal axis
Distribute equally along vertical axis



Popup Alignment Menu



Part Fields Changes for version 2

Parts have special text fields, some of which are created and stored at the library level and 
others that are created and stored at the sheet level when the part is placed. Advanced 
Schematic supports sixteen part (sheet-level) text fields and eight component (library-level) 
text fields, of up to 255 characters each.

Special text fields, which are included in netlists: designator (label) type (description) and 
package (footprint), may be limited in the number of characters supported. These netlist fields 
may or may not support empty spaces and/or be case sensitive.
 
When parts are placed in sheets the designator, type description and other text fields created 
at placement can be either hidden, displayed or moved relative the part position and 
orientation. Displayed text supports any TrueType font, including user-definable size and style.

Library text fields
Each library component has eight user-definable text fields. These fields can hold up to 255 
characters each. Library text fields cannot be edited from placed parts in schematic sheet files,
but are automatically included in CSV format Bill of Materials reports. An additional 16 text 
fields are editable for each instance of a part, placed in sheets. These part fields can be 
viewed (along with other read only attributes) from the Parts dialog box after placement in 
schematic sheets by clicking the View Read-Only Library Fields button.

Part text fields
In addition to the eight library component text fields, sixteen additional user-definable fields are
available for each part, at the sheet level. These fields can be displayed or hidden (clickHidden
Fields in the Change Component dialog box) and are editable in the sheet, with user definable
fonts, sizes and colors. These fields can be up to 255 characters long and are automatically 
included in CSV format Bill of Materials reports.

See also
Part Field Names



Communication with Advanced PCB

Advanced Schematic supports full forward annotation of PCB files in Advanced PCB. Updated 
netlists can be used to make engineering changes to fully or partially routed PCBs. See your 
Advanced PCB 2.0 documentation for more information.
The Protel 2 netlist format is supported by Advanced PCB version 2.0 or later and includes 
routing directives defined in the schematic.

Bi-directional cross probing
Advanced Schematic supports cross probing of Nets, Pins and Parts to and from Advanced 
PCB 2.0. You can use Schematic/PCB cross probing while running Advanced Schematic and 
Advanced PCB simultaneously, with a PCB file open and its source schematic open. Cross 
probe from either program by choosing Edit-Cross Probe, and clicking on an object. Missing 
components or pins (PCB layout) Advanced PCB reports missing component patterns or 
missing pins when two factors are present in the netlist:

One or more Package Descriptions (or Type) is missing from schematic component 
information in the netlist, or the package in the schematic does not match any Advanced PCB 
library component. The names of missing components and pins will be listed in a netlist report 
file (an option, when you load a netlist in Advanced PCB).
It may be necessary to re-edit the schematic or netlist to include the Type information, or 
additional Advanced PCB library components may be created to match any unique 
descriptions in the netlist.

If all components are present but pins are reported missing, the cause is usually that the 
schematic package's pin numbering differs from Advanced PCB.
Schematic libraries contain specific components and devices. PCB footprint (decal) libraries 
contain generic footprints which can belong to various specific components -- each having 
different pin assignments.

For example, a transistor shape can represent various combinations of "E," "B" and "C" -- 
each of which must be assigned to the correct pin number in the PCB layout system. 
Capacitors are a similar case, with pins often named "A" and "K" in the schematic. One 
solution is to leave the schematic pin designations as "E," "B" and "C" and then place 
components on the PCB and change the pad designators to match. If you have a lot of pin 
outs in the same orientation, you may want to make a special version of the component in the 
library using the correct pin identifiers.

See also
Cross Probe Part
Cross Probe Pin
Cross Probe Net



Drag and Drop editing

Advanced Schematic allows quick "drag and drop" editing of placed objects. Any placed object
can be moved with a simple point, click and drag sequence. Test this feature on any placed 
item:

1. Move the cursor over the object.

2. Press and hold LEFT MOUSE, then drag the object without releasing the LEFT MOUSE 
button.

3. Release LEFT MOUSE. The drag object feature allows quick movement of schematic 
objects but does not maintain connectivity while moving.

When moving a connected electrical object, maintain connectivity with the drag object feature 
by holding down CTRL while clicking LEFT MOUSE. Once the object begins to move, you can 
release the CTRL key.



Quick copy attributes

The "quick copy attributes" feature allows you to copy the attributes of one object into a 
second object of the same type. To demonstrate this feature place a port on a sheet:

1. Double click on the Port to open its Port dialog box.

2. In the Name field, type Port_1.

3. In the Width field, type 90.

4. Click OK to accept these changes and close the dialog box. Now place a second port on the
sheet.

5. Chose Place-Port or click on the Port button on the Wiring Tools palette.

6. Move the new port over the first port, so that the center of the cross hairs is within the 
boundaries of "Port_1."

7. While holding the port over "Port_1," press the INSERT key. The new port will jump "over" 
the first port.

8. Move the new port away from the original, then finish placing the port by clicking to define 
its length. All attributes of "Port_1" should now be copied into the new port. If the port has not 
"inherited" the attributes of the first port, the cursor crosshairs may not have been inside the 
first port when pressing INSERT.

The quick attribute copy function can be used to "clone" the attributes of all placed schematic 
object types, except sheet symbols. This process works whether placing a new object or can 
be used when moving an already-placed item. It does not work when dragging connected 
electrical objects.



Connection Dragging

Connectivity between electrical hot spots is automatically maintained. To examine this feature:

1. Place any part on a schematic sheet. The type of part does not matter.

2. Place another part so that any pin on the first part butts up against a pin on the second part.
Press ENTER to place the second part and then press ESC to cancel the Place Part 
command. When any two hotspots are connected, as in this example, the connection will be 
maintained when dragging any connected electrical item. To see this feature in operation, drag
one of the components away from the other:

3. Hold down CTRL and click LEFT MOUSE over one of the parts. Release the CTRL key and 
the mouse button. The system is now              in Drag Single Item mode.

4. Now, move the mouse slowly to drag one part away from the other. At the moment the part 
is moved, the point where the two pins were connected was transformed into a wire, which 
stretches as you drag to maintain the connection. As you move the part, special rules govern 
the placement of the wire. These rules are applied similarly to using the Place-Wire command.
You can change the placement rules while dragging by pressing the SPACEBAR.

5. While dragging the part, press SPACEBAR to toggle between the four available wire 
placement modes.

Modes include Any Angle, 90 degrees, 90 degrees constrained on one axis or 90/45. 
Connection maintenance is an invaluable tool for quickly connecting any two electrical objects:
parts, ports, wires, power objects, busses, bus entries, and sheet symbol entries.

See also
Dragging Selections
Dragging Objects



Re-entrant editing commands

Advanced Schematic allows users to execute commands from within other commands. A 
simple application of this feature is to change views while placing schematic objects. In 
continuing this example, you can test this feature by placing a sheet symbol while dragging 
connections. Begin by again dragging the left most part to the upper right-hand corner of the 
screen.

1. Choose Edit-Move-Drag from the menu bar and drag the part on the left to the top right 
corner of the screen.
Now place an new schematic object while still dragging the part. Use the keystroke shortcuts 
to place a sheet symbol:

2. Press P and then the S key to start the place sheet symbol command.

3. Press the TAB key to change the attributes of the sheet symbol before you place it. The 
Sheet Symbol dialog box appears.

4. In the Filename field, type SCH_3.SCH.

5. In the Name field, type SubSheet1.

6. Click OK once to continue placing the sheet symbol.

7. Place the sheet symbol in the bottom left corner of your screen. Make the sheet symbol box
0.5-inch by 0.5-inch (5x5 grid units on a 0.1-inch grid) by moving the cursor, clicking the LEFT 
MOUSE button once to set the height and moving and clicking a second time to set the width.

8. Press ESC once to exit the Place Sheet Symbol command.
Now finish the drag connection function by dragging the part under the cursor to the upper 
right corner.

9. Finish the drag connection command by pressing ENTER.

Re-entrant editing commands lets users to work more flexibly and intuitively. For instance, a 
user can start placing a wire, then remember that it is to be connected to a port, place the port 
and then connect the wire to it.

Any number of commands may be executed within another command and up to three 
uncompleted commands can be nested within each other.



Direct Selection

Hold down LEFT MOUSE and drag a selection rectangle over the desired area in the sheet. All
objects inside the selection rectangle will be added to the current selection. To delete objects 
from the selection, hold LEFT MOUSE+SHIFT while dragging a selection rectangle.

Remember, these processes can be re-assigned to different mouse/key shortcuts in the 
Options-Hot Keys dialog box. You can use the Zoom commands (and hot key shortcuts PGUP 
and PGDN) at any time when making or releasing selections.



Special Strings

Special text string are used to place automatically updated information or information that can 
change from sheet to sheet. Support for special strings is provided for use in sheet templates. 
The MY_SHEET template created previously, included the text string .ORGANIZATION in the 
title block. This special string is linked to a text field that can be accessed from the Options-
Sheet command. With the new sheet open and the MY_SHEET.DOT template loaded, enter 
your company information for this sheet:

1. Choose Options-Sheet from the menu bar.

2. Click once on the Document Options button.
This dialog box holds information that can be displayed on a schematic sheet automatically 
with the special text strings. Enter your company information in the Organization field:

3. In the Organization field, type the name of your company. Click OK. The view returns to the 
Schematic Sheet dialog box.

4. Click OK to accept the change and close the dialog box. 
Now convert the strings so that they display your company information:

5. Choose Options-Preferences from the menu bar.

6. Mark the Covert Special Strings check box and click OK.
When you return to the sheet, note that the string .ORGANIZATION has been converted to the
company name you typed in the Organization dialog box, above. Special text strings can be 
placed in sheet templates or on normal sheets. 

The following special strings automatically display the information entered in the Document 
Options dialog box, accessed from within the Schematic Sheet options dialog box: 
.ORGANIZATION      Lists Organization field text.
.ADDRESS1              Lists text from first Address field.
.ADDRESS2              Lists text from second Address field.
.ADDRESS3              Lists text from third Address field.
.ADDRESS4              Lists text from fourth Address field.
.SHEETNUMBER        Lists text from Sheet No. field.
.SHEETTOTAL          Lists text from Sheet Total field.
.TITLE                    Lists the Document Title text.
.DOCUMENTNUMBER Lists the Document No. text.
.REVISION              List the Document Revision text.



The following special strings automatically insert the current information at the time the 
document is printed.
.DOC_FILE_NAME    The name of the schematic sheet file.
.TIME                      The current time.
.DATE                      The current date.

See also
Options Sheet
Options Preferences



Sheet Options

The Schematic Sheet dialog box is used to assign sheet-level preferences and defaults (these
are items associated with a single sheet, rather than the system level preferences described 
above).
    
The Options Sheet command opens the Schematic Sheet dialog box which is used to define 
sheet level defaults. These assignments are saved with the sheet and are also used as 
defaults when a new file is created.

Style
Selects from available standard sheet formats.
Use Custom Style
Uses Custom Width, Height, Ref (Reference) Region count and Margin Width settings. Units 
are .01 inch. Ref (Reference) Region count refers to the number of divisions in sheet borders. 
Border references are indicated by 1, 2, 3, etc. (X axis) and A, B, C, etc. (Y axis). References 
begin at the sheet origin (lower left corner) Margin refers to the area between the border 
reference and the edge of the sheet.
Colors
Colors can be independently assigned to the sheet background and to the template items 
(border and title block regions). Clicking in the color box opens the Color selector dialog box. 
Any of 224 pre-defined or user-defined RGB colors can be assigned.
Grids
Any sheet can have a pre-defined Snap grid and Visible grid pitch.
Electrical Grid
The special electrical Snap grid allows the cursor to jump to the nearest electrical hot spot 
when placing or moving electrical objects (wires, buses, ports, parts, etc.). The Grid Range 
value determines how near the cursor need be to snap to the nearest electrical hot spot (units 
of .01 inch). Other sheet options
Orientation
Designates either Landscape (default) orientation or Portrait orientation. Landscape is "wide" 
orientation, Portrait is "tall" orientation.
Title Block
Designates either Standard or ANSI format for the title block region. Users can define custom 
title blocks and save these using template (.DOT) formats, which can be applied to any new or
existing sheets.
Show Reference Zones
When enabled, this option includes the reference information (1, 2, 3, A, B, C, etc.) divisions 
within standard or custom borders. Has no effect when the border region is disabled (see 
below).
Show Border
When enabled, the border region is displayed.
Show Template Graphics
When enabled, displays any linked graphics associated with the current template. Disabling 
this option can speed sheet re-draw, if    the template includes large or complex graphics.



Document Info...
Opens the Document dialog box. This dialog box provides access to all organization 
information. This information is used to pre-define the contents of sheet title blocks.
Change System Font...
Opens the Font Manager. Allows user to define a font, font size and font style for all system-
level sheet text, including port names, power port names, pin numbers and sheet entry names.

See also
Options Sheet dialog box



Forward Annotation to Advanced PCB

Forward annotation is the process of implementing changes to an existing PCB layout from 
the schematic editor. This system will allow users to move, add or delete connections on the 
schematic sheet. Adding, removing or re-naming of parts or nets in the schematic is also 
supported. When the updated netlist is loaded into Advanced PCB 2, the system will compare 
the new netlist with the physical design and update the PCB to reflect all netlist level changes. 
This can include substitution of component footprints and removal of obsolete routed tracks 
with conversion back into unrouted (ratsnested) PCB connections.



Special links to PCB systems

Advanced Schematic supports a number of links to PCB systems beyond basic netlisting.

Back annotation
The File-Back Annotate command updates schematic part designators (U1:1, R32, etc.) based
on a "was-is" list generated by the PCB layout package. Advanced PCB 2 and a number of 
other layout packages support back annotation. The "was-is" information is supplied by 
a .WAS file. This file is in ASCII text format.

Forward annotation
Forward annotation is the process of implementing changes to an existing PCB layout from 
the schematic editor. This system will allow users to move, add or delete connections on the 
schematic sheet. Adding, removing or re-naming of parts or nets in the schematic is also 
supported. When the updated netlist is loaded into Advanced PCB 2, the system will compare 
the new netlist with the physical design and update the PCB to reflect all netlist level changes. 
This can include substitution of component footprints and removal of obsolete routed tracks 
with conversion back into unrouted (ratsnested) PCB connections.

PCB Layout directive
The PCB Layout object (supported by OrCAD SDT and PCB) allows the engineer to specify 
topology, priority and design rules for routing on a net-by-net basis. User definable fields for 
the PCB Layout object include routing track width and via size, layer and route priority. 
Directives are included in the Protel 2 netlist format. Advanced PCB (version 2) is fully-
compatible with the Protel 2 netlist format.

Cross probing
Advanced Schematic fully supports multi-document and multi-application use of the Windows 
environment. This allows the user to open Advanced Schematic and Advanced PCB at the 
same time. When a schematic sheet (or project) and its PCB layout are open at the same 
time, Advanced Schematic and Advanced PCB version 2 support bi-directional cross probing. 
For example, the user can select a part in the schematic, and the PCB editor will jump to and 
display the corresponding component. The corresponding PCB-to-Advanced Schematic cross 
probe is also supported: pick a component footprint on the PCB and display the corresponding
schematic part. Schematic pin-to-PCB pad cross probing and net label-to-physical net cross 
probing are also supported.

See also
Cross Probe Part
Cross Probe Pin
Cross Probe Net
Create Netlist
PCB Layout Directives
Back Annotate



Windows .WMF Clipboard support

You can use the Windows clipboard to Cut, Copy or Paste sheet elements, text or graphics 
from one sheet to another. Windows metafile (.WMF) support allows you to use the clipboard 
to Paste selections from Advanced Schematic sheets into other applications. You can also 
copy text from other applications, via the Windows clipboard and paste this text into Advanced 
Schematic text frames. An Add Templates to Clipboard option (Options-Preferences 
command) allows the user to Copy an entire sheet (including border and title lock) to the 
clipboard.

See also
Edit Cut
Edit Copy
Options Preferences



Cross Project Global Editing

Advanced Schematic supports global editing of schematic objects throughout a multi-sheet, 
hierarchical project. This feature allows users to change items located in various parts of a 
project or impose style changes throughout all open sheets in the current project.
Change Scope
These three options define the extent of changes:
Change This Item Only (no global changes);
Change Matching Items In Current Document;
Change Matching Items In All (currently opened) Documents.
The latter option extends your changes across all open sheets, allowing you to globally edit an
entire project.



Complex Hierarchy support

Advanced Schematic supports single sheet, multiple sheet and fully hierarchical designs 
including complex hierarchy where multiple instances of a single sheet file can be used in a 
project. 
Multi-sheet projects can be opened, closed or saved with a ingle File menu command. 
Projects can be navigated visually using the Project Manager, a special display window that 
resembles the Windows File Manager. The Project Manager displays all open files in a 
hierarchical tree structure. Users can click on sheet icons to move from sheet-to-sheet.

The Project Manager displays three types of sheet icons:
Master sheets - These icons represent the top level of hierarchical projects or "flat" multi-sheet
projects, which have two levels only.
Subsheets - These icons represent sheets that are "descend" from master sheets.
Complex sheets These icons represent duplicates of other subsheets, used in complex 
hierarchies. When you click on a Complex sheet icon, the focus moves to the subsheet it 
represents. Colors can be assigned to these three icon types (Options-Preferences 
command).

See also
Options Preferences



Trace Netlist Generation Options

The Trace Netlist Generation option is a special design validation tool that allows users to 
examine details of netlist generation. This allows the user to track netlist discrepancies back to
a specific cause or condition.
The Trace Netlist Generation options are in the Create Netlist dialog box.

Enable Trace - turns netlist tracing report on or off. If enabled, the trace information is written 
to <filename.tng>
Netlist before any resolving - internal netlist after spatial to connective conversion, but before 
any merging of nets.
Netlist after resolving sheets - internal netlist after merging only inside sheets, but before any 
merging of sheets into one project.
Netlist after resolving project - internal netlist after merging and resolving of nets inside a 
project.
Include Net Merging Information - if enabled all merging information is written to the report file.

See also
Create Netlist



Project Manager Changes for version 2

You can click on any sheet icon to move the current focus to that sheet window. You can also 
use the (up, down, left, right, home, end, pgup, and pgdn) keyboard keys to move up and 
down the project hierarchy tree.

The Rebuild button at the top of the Project Mananger window, is used to update the hierarchy
tree when changes are made to the projects organization (as when adding or deleting sheet 
symbols from parent sheets).

Expanding and Collapsing the Project Hierarchy Tree
In the Project Manager, you can view the subsheets by expanding the hierarchy tree. You can 
also choose not to view the subsheets by collapsing the hierarchy.
To display subsheets.
Double-click the parent sheet you want to expand. The sheets that have subsheets are 
marked with a plus sign (+).
Or select the sheet you want to expand and then choose the Expand One Level (->),    Expand
Branch (-->>), or Expand All (All) button at the top of the Project Manager.
To hide subsheets
Double-click the parent sheet you want to collapse.
Or select the sheet you want to collapse and then choose the Collapse Branch (<<--) button at
the top of the Project Manager.

The width of the Project Manager can be changed by dragging its right hand side toward the 
center of the screen.    The cursor will change into a left-right arrow when the cursor is over the
right edge of the window. To see more of the hierarchy tree, hold LEFT MOUSE and drag to 
adjust the width.

Project Manager display options
The Project Manager displays three types of sheet icons:
Master sheets - These icons represent the top level of hierarchical projects or flat multi-sheet 
projects, which have two levels only.
Subsheets - These icons represent sheets that are descend from master sheets.
Complex sheets These icons represent duplicates of other subsheets, used in complex 
hierarchies. When you click on a Complex sheet icon, the focus moves to the subsheet it 
represents. Colors can be assigned to these three icon types (Options-Preferences 
command).

See also
Options Preferences
Toggle Project Manager



File Open Filters

Clicking the button under File Types allows you to assign a new a new file mask. For example,
you may wish to change the defaultextension to search for other file types. When adding a 
new file type the description can be any character and the extension must be enclosed within 
round brackets.



File Dialog Changes

The File dialog boxes feature a number of control options, including direct access to the 
Windows File Manager (for browsing and modifying directories), and networks (for accessing 
networks and network drives). Clicking the button under File Types allows the user to assign a 
new file mask. For example, you may wish to change the default extension to search for other 
file types.
Information about the specified file (the filename currently highlighted by the selection bar in 
the File list), is displayed in the bottom of this dialog box. File masks are non-restrictive when 
opening files. Advanced Schematic identifies file types independently of the extension and 
converts other file types into Advanced Schematic formats automatically.



Font Manager

Using fonts
Advanced Schematic directly supports the TrueType fonts that are delivered with Windows, 
including bold and italic formats and display font scaling. TrueType fonts and supplied with 
Windows and are available from third-party suppliers in a wide variety of typefaces. Postscript 
scaleable fonts, and Windows non-scaleable raster fonts can be used, when they are part of 
vector image files imported into Advanced Schematic sheets.

Font Style dialog box
Advanced Schematic includes a powerful Font manager utility which allows users to monitor 
the available (installed) windows fonts and make intelligent font selections for both display and
printing of schematic sheet. Font manager routines are available whenever you access the 
font assignment options for sheets or for design objects that include user-definable text. These
objects include text annotation, text blocks, components, etc. Clicking the Font Change button 
(in the object's dialog box) opens the Font Style dialog box. This dialog box displays installed 
system fonts (by font type) including the fonts available for the current output device (if the 
driver for the device includes font information). The user can examine the installed fonts, 
change the font size and style or change the current output device from this dialog box. If you 
have problems rendering fonts used in the sample sheet files supplied with Advanced 
Schematic, make sure that the appropriate TrueType fonts have been installed and enabled. If 
a font is not rendering properly, double click the object and click Font to see the name of the 
font. You can assign another available font or check to see it the font is enabled. 
Fonts are installed from the Windows Control Panel, Fonts utility. To enable installed TrueType
fonts, click the TrueType button and then the Enable TrueType fonts checkbox in the TrueType
dialog box. See your Microsoft Windows Users Guide for details about font management 
under Windows.

Font Management System
Font management in Advanced Schematic gives users extensive information about available 
font resources and capabilities. Users can exercise broad control over font usage, including 
the ability
to apply a System font used for rendering part pin names, port names, power objects and 
sheet (border) references.

Font Technology
Font technology and behavior can vary widely within the Window environment. Two main 
types of fonts are used in the Windows environment: Screen fonts, which are used by a 
display driver to show letters on a monitor, and printer fonts, which are geometric 
descriptions of letters used by a printer to draw text on a page. Since screen fonts and printer 
fonts are designed for specific purpose, they can produce undesirable results when used with 
a device for which they were not intended. For instance, if a font intended for screen use only 
is used on an high-resolution printer, the text will have jagged, blocky letters.

Font Manager
The Font Manager gives users more control over font resources and provides extensive 
information about font technologies for more predictable display and output results. Advanced 
Schematic's font management system allows users to access printer-resident fonts, even if no 



screen font is available. If you choose a printer-resident font that lacks a screen 
representation, the font will be displayed on screen with the closest matching screen font. 
Advanced Schematic's font management system recognizes and identifies TrueType, Vector 
fonts (including PostScript and printer/plotter-resident fonts) and Raster font technology. 
TrueType fonts describe letters using vector outline descriptions of letter shapes and are 
managed directly by Windows. These fonts scale smoothly, can be rotated include a display 
version for accurate on-screen rendering (what you see is what you get).

Vector or plotter fonts used vector rather than bitmap descriptions. Vector fonts are used 
primarily by plotting devices and some dot-matrix printers. These fonts are scaleable and 
rotatable, but usually do not include accompanying screen font.
Raster or bitmap fonts describe letters with small dots on printer or pixels on a monitor. Raster 
fonts are primarily intended for screen display and cannot be rotated.

PostScript fonts are similar to TrueType fonts. These outline fonts are not directly supported 
by Windows and must be managed using a system extension such as Adobe Type Manager 
for Windows. PostScript outline fonts are downloadable to PostScript compatible printers 
allowing you to print smooth representations of letters even if the font is not resident in your 
printer. These fonts scale smoothly, are rotatable and are usually accompanied by a screen 
font for accurate screen rendering.

System font control
With Advanced Schematic, users can set the default font for sheets. The Options-Sheet dialog 
box has been expanded to include a Change System Font control, which allow users to control
the standard font used for boarder display and title blocks. The system font controls use the 
same font dialogs used in the new font selector dialog.

See also
Options Sheet



Tools Menu

The Tools menu allow users to run other Windows applications and utilities from the Advanced 
Schematic editors. The Tools menu can be configured by choosing Tools-Setup from the menu
bar.    
Configure the Tools menu by typing the name of the executable for an application file in one of 
the fields of the Setup Run Options dialog box. If the program you wish to run is not in the 
DOS path, you must type in the complete path (limited to 255 characters).

See also
Setup Run Options



Part Update reporting

Updates of parts from schematic libraries are recorded in a report file. When the command 
Library-Update Parts In Cache is executed, a report file is generated which lists parts that 
were updated. This list is automatically saved and displayed in Windows Notepad. The report 
only includes components that where actually changed.

See also
Update Parts from Library command



OrCAD STD 386+ support

Orcad 386+ schematic sheet files and library files must be converted to Orcad 16bit files 
before they can be loaded into Advanced Schematic.

When importing Orcad 386+ schematic files, Advanced Schematic looks in the current path for
Orcad's 32TO16.EXE utility, if found, Advanced Schematic uses this utility to automatically 
convert and load the 32bit schematic file.    The 32TO16.EXE utility also requires the Orcad file
SDTXTEND.EXE to be in the path.
Loading Orcad 386+ library files into the Library Editor is similar. Advanced Schematic Library 
Editor looks in the current path for a utility called DECOMP32.EXE. Orcad 386+ application is 
supplied with two utilities DECOMP16.EXE and DECOMP.EXE. DECOMP.EXE is the 32bit 
library decompiler, this file must be renamed to DECOMP32.EXE, in order for Advanced 
Schematic Library Editor to automatically decompile and load Orcad 386 binary libraries.

When importing Orcad 386 files, Part field 'Module Name' is converted to 'Text Field 8' in 
Advanced Schematic.



Graphical Editing Hotkey List

While editing, moving or placing an object you can press the F1 key at anytime to open the 
Graphical Editing Hotkey List dialog box. This dialog box lists all the hot key commands that 
can be used while graphically editing, moving or placing an object. This command is context 
sensitive, therefore the hot listing will change depending on the command and object being 
editted.

See also
Hot Keys



Save Object Defaults

Advanced Schematic does not have a separate menu or dialog box for defining the current 
wire size, junction size, text size, etc. Rather, the system remembers the last size, color etc. 
selected by the user and holds this value until a new value is defined. This also works for 
objects like rectangles or arcs, whose size and shape is retained during placement. If the 
Options Preferences Save Defaults option is enabled, these defaults will be saved into your 
Windows directory in a file called SCH.DFT and LIBEDIT.DFT. The object defaults will be 
reloaded between editing sessions.

See also
Options Preferences



Communication between Applications

The Protel for Windows system allows the user to launch more than one "instance" of an 
application or document. For example, you can have two instances of the Schematic Editor 
running, each dedicated to a different project. When launching another application from the 
Schematic (sheet) editor, for example, choosing the Run Library Editor command, the 
outcome is influenced by the number of active instances of the application. If you have a 
single instance of the Library Editor running, the focus will simply switch to that instance, 
which then becomes the "active" window. If no instances are running, the program will be both 
launched and made active. If you have multiple instances running, the application will warn the
user that more than one instance of the application is running and no action will occur. 
Similarly, the Edit button in the Component Browser will display a warning, if more than one 
instance of the Schematic Editor is running, because the system cannotchoose between open 
applications.

See also
Run Library Editor
Setup Run Options



Edit File Types

File Types allows the user to assign a new file mask. For example, you may wish to change 
the default extension to search for other file types.
File masks are non-restrictive when opening files. Advanced Schematic identifies file types 
independently of the extension and converts other file types into Advanced Schematic formats 
automatically.



Advanced Global Editing For Parts

When Global Editing Parts the contents of a text field can be automatically copied to another 
text field within the part, (eg. it is possible to copy the contents in Part Field 1 to Part Field 5, 
or copy the the text in the Part Type field to the Foot Print field).    This is done by using special
reserved key words to specify the text field that is to be copied.    The following is a list of all 
the fields and corrsponding reserved words that can be used.
 
Field Name      Key Word
Lib Ref                  .LIB_REF
Footprint              .FOOTPRINT
Designator            .DESIGNATOR
Part Type              .PART_TYPE
Sheet Path            .SHEET_PATH
Part Field 1        .PART_FIELD_1
Part Field 2        .PART_FIELD_2
Part Field 3        .PART_FIELD_3
Part Field 4        .PART_FIELD_4
Part Field 5        .PART_FIELD_5
Part Field 6        .PART_FIELD_6
Part Field 7        .PART_FIELD_7
Part Field 8        .PART_FIELD_8
Part Field 9        .PART_FIELD_9
Part Field 10      .PART_FIELD_10
Part Field 11      .PART_FIELD_11
Part Field 12      .PART_FIELD_12
Part Field 13      .PART_FIELD_13
Part Field 14      .PART_FIELD_14
Part Field 15      .PART_FIELD_15
Part Field 16      .PART_FIELD_16

Fields in Schematic Library Editor
Default Designator      .DEFAULT_DESIGNATOR
Sheet Part Filename    .DEFAULT_SHEET_PART_FILENAME
Foot Print 1                  .FOOT_PRINT_1
Foot Print 2                  .FOOT_PRINT_2
Foot Print 3                  .FOOT_PRINT_3
Foot Print 4                  .FOOT_PRINT_4
Description                    .DESCRIPTION
Text Field 1                  .LIBRARY_PART_FIELD_1
Text Field 2                  .LIBRARY_PART_FIELD_2



Text Field 3                  .LIBRARY_PART_FIELD_3
Text Field 4                  .LIBRARY_PART_FIELD_4
Text Field 5                  .LIBRARY_PART_FIELD_5
Text Field 6                  .LIBRARY_PART_FIELD_6
Text Field 7                  .LIBRARY_PART_FIELD_7
Text Field 8                  .LIBRARY_PART_FIELD_8
Part Field Name 1        .PART_FIELD_NAME_1
Part Field Name 2        .PART_FIELD_NAME_2
Part Field Name 3        .PART_FIELD_NAME_3
Part Field Name 4        .PART_FIELD_NAME_4
Part Field Name 5        .PART_FIELD_NAME_5
Part Field Name 6        .PART_FIELD_NAME_6
Part Field Name 7        .PART_FIELD_NAME_7
Part Field Name 8        .PART_FIELD_NAME_8
Part Field Name 9        .PART_FIELD_NAME_9
Part Field Name 10      .PART_FIELD_NAME_10
Part Field Name 11      .PART_FIELD_NAME_11
Part Field Name 12      .PART_FIELD_NAME_12
Part Field Name 13      .PART_FIELD_NAME_13
Part Field Name 14      .PART_FIELD_NAME_14
Part Field Name 15      .PART_FIELD_NAME_15
Part Field Name 16      .PART_FIELD_NAME_16






