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SuperClip    is a clipboard viewer that can print or save a displayed graphic image to a 
BMP, GIF, JPG, PCX, PNG, or TIF file, or text to an ASCII file.    Capturing the screen is done by 
pressing the PrtSc key while SuperClip is minimized.    Normally, SuperClip will pop up and 
display the capture when you press PrtSc, but with the Auto print screen option enabled, it 
will stay minimized and send the captured image to the printer instead.    

In Windows, the entire screen can be captured to the clipboard at any time by pressing the 
PrtSc key, or just the currently active window by pressing Alt+PrtSc.    Pressing PrtSc will also
capture text to the clipboard from DOS applications running full-screen in character mode.

The entire clipboard image can be saved or it can be cropped by using the mouse to frame a
rectangle before printing or saving to disk.    Text can also be converted to a bitmap and 
cropped.

DosClip is an associated utility that works in conjunction with SuperClip to capture 
graphical screens to the Windows clipboard from DOS applications running full-screen.    See 
"Capturing a DOS Screen" in the SuperClip Manual (sclip.rtf) for more information about 
DosClip.



File Menu Item:    Save as    >    BMP
Select this item from the File menu to save the contents of the clipboard to an 
uncompressed Windows Bitmap File with the filename extension BMP.      Monochrome, 16-
color, 256-color, and    24-bit TrueColor modes are supported.

If text is the currently-displayed clipboard format, it will be converted to a graphic image and
saved to a monochrome BMP file.



File Menu Item:    Save as    >    GIF
Select this item from the File menu to save the contents of the clipboard to a CompuServe 
Graphics Interchange Format file with the filename extension GIF.    This format utilizes LZW 
compression, and supports Monochrome, 16-color and 256-color modes.    The GIF format is 
palette-based and does not support more than 256 colors, so if the number of colors in the 
image on a 24-bit TrueColor display exceeds that number, the Windows 3.1 version of 
SuperClip will abort the save, but the Windows 95/NT version of SuperClip will create a 
palette of 256 colors, map the image to those colors, and save it to a GIF file.    In that case, 
you will be prompted to choose one of two palette types: Optimal, or Safety.

The Optimal palette will give the best possible color rendition when the GIF file is viewed on 
a graphical viewer or printed on a color printer.

The Safety palette will allow the GIF file to be embedded into an HTML page and viewed on a
Web browser without dithering of colors.    Web browsers running on 256-color displays will 
dither all colors that are not in the Safety palette.    Either type of palette can be used for GIF
images in HTML pages, and which one is better depends on the image.    Dithering tends to 
work better for a photographic image, so the Optimal palette may be preferable in that 
instance.    The Safety palette works better for line art, where dithering of solid colors would 
be objectionable.

Any one of the colors in an image can be selected to be a transparent color in a GIF file.    
See Options for details.

If text is the currently-displayed clipboard format, it will be converted to a graphic image and
saved to a monochrome GIF file.



File Menu Item:    Save as    >    JPG
Select this item from the File menu to save the contents of the clipboard to a JPEG file with 
the filename extension JPG.    This is a 24-bit TrueColor format that utilizes variable-quality 
lossy compression.    SuperClip promotes monochrome and palette-based 16 and 256-color 
images to 24-bit TrueColor before saving to JPG.    The compressed file size is inversely 
proportional to the quality setting, which may be set to any value from 1 to 100 in the 
Options menu.    The default Q setting is 75.



File Menu Item:    Save as    >    PCX
Select this item from the File menu to save the contents of the clipboard to a PC Paintbrush 
file with the filename extension PCX.    Monochrome, 16-color, 256-color, and 24-bit TrueColor
modes are supported.

If text is the currently-displayed clipboard format, it will be converted to a graphic image and
saved to a monochrome PCX file.



File Menu Item:    Save as    >    PNG
Select this item from the File menu to save the contents of the clipboard to a Portable 
Network Graphics file with the filename extension PNG.    Monochrome, 16-color, 256-color, 
and 24-bit TrueColor modes are supported.

If text is the currently-displayed clipboard format, it will be converted to a graphic image and
saved to a monochrome PNG file.



File Menu Item:    Save as    >    TIF

Select this item from the file menu to save the contents of the clipboard to a Tagged Image 
Format File with the filename extension TIF.    Three different compression schemes are 
available: LZW, PackBits, and no compression, any of which may be selected from the 
Options menu.    The defaults are LZW for 24-bit TrueColor images, and PackBits for 
monochrome and palette color images. 



File Menu Item:    Save as    >    TXT
Select this item from the File menu to save clipboard text to an ASCII TXT file.    Select OEM 
for the DOS-compatible, IBM extended-ASCII character set, or ANSI for the Windows-
compatible character set.

If you select a file that already exists, clipboard text will be appended to that file.    The text 
that will be saved extends from the top of the Window, as set by the current vertical scroll 
position, to the end of the clipboard text.



Cropping the Clipboard Image
To mark a rectangular area for cropping, move the cursor to the top-left corner of the desired
rectangle, depress the left mouse button, move the cursor to the lower-right corner and 
release.    Repeat this procedure to erase the rectangle and draw a new one.    

To save the cropped image, select the desired format from the File menu.    To erase the 
rectangle, press Esc or click and release the left mouse button.

Only bitmapped images can be cropped.    To crop text, it must first be converted to a 
monochrome bitmap by selecting "Save as BMP" from the File menu, then "Open BMP" to 
place the newly-created bitmap on the clipboard.    In most cases, it would be more practical 
to save text to an ASCII file, then open that file in a word processor and edit the text before 
pasting it into an application.



Options        
The following options are available.

Option:    Auto print screen
Select this menu item to enable the true print screen mode.    When the "Auto print screen" 
option is enabled, SuperClip runs minimized and sends the screen to the printer, without 
popping up, whenever you press the PrtSc key.    It is recommended that before enabling this 
option, you select "Page layout & margins" from the Print menu and set the desired margins 
and image size, then select "Print setup" and print a test page to be sure the setup is 
satisfactory.    

While a DOS text-mode program is running in a full-screen DOS session (not in a window), 
the text screen will also be sent to the printer whenever the PrtSc key is pressed.    If the 
DOS program is running in a window, it can be toggled to full-screen mode by pressing 
Alt+Enter.    

"Auto print screen" does not work for graphical DOS applications, unless Windows is able to 
capture the DOS screen to the clipboard when you press PrtSc, which it is seldom able to do 
in the current versions of Windows.    To print such screens, you may first use DosClip to 
capture the graphical DOS screen to the clipboard, then select "Print" in SuperClip.    For 
information about DosClip, refer to the SuperClip Manual (sclip.rtf).    

All of the other features of SuperClip remain available while "Auto print screen" is enabled.    
That is, you can click on the SuperClip icon on the taskbar to make SuperClip pop up and 
display the clipboard, and you may perform any of the image transformations available in 
the Options menu and save the image to disk.    You may then minimize SuperClip again, 
leaving "Auto print screen" enabled.

Option:    Capture cursor
Select this menu item to include the mouse cursor as part of the screen image when you 
press PrtSc. The cursor is not captured when you press Alt+PrtSc to capture the currently-
active window.

Option:    Capture rectangle

Select this menu item to capture the current rectangle to the clipboard.    You must first draw
a rectangle with the mouse or by entering coordinates from the keyboard.

Option:    Clear clipboard

Select this menu item to empty the clipboard.    Both text and graphics will be discarded.

Option:    Enter coordinates

Select this menu item to modify or draw a rectangle by entering its coordinates from the 
keyboard.    The values that appear in the dialog box are those of the current rectangle, if 
one has been previously entered or drawn with the mouse.    If there is no current rectangle, 
the values default to a rectangle that contains the entire client area of the SuperClip window.
Coordinates may be entered that exceed the boundaries of this client area, and may include 
the entire image on the clipboard, up to a full screen.



The origin of the rectangle coordinates is the upper-left corner of the clipboard image.    To 
erase the rectangle, press Esc or click the left mouse button.

Option:    Interlace GIF

Use this menu item to select whether or not GIF files will be interlaced.

Option:    Interlace JPG 

Use this menu item to select whether or not JPG files will be interlaced.

Option:    Interlace PNG

Use this menu item to select whether or not PNG files will be interlaced.

Option:    Invert colors

Select this menu item to invert the colors of the image on the clipboard, creating a negative 
image.    The original colors can be restored by selecting this menu item again.

Option:    Popdown mode

When this option is selected, SuperClip will automatically minimize itself after saving an 
image or text to disk.    This feature is independent of popup mode.

Option: Popup mode

The default mode of SuperClip is to pop up only when you press the PrtSc key.    You may turn
popup mode off or select the option to pop up on all clipboard events, such as when you 
select Copy from the Edit menu of another Windows application, putting an image or text 
onto the clipboard..

Option:    Restore defaults

Select this menu item to restore all settings to the default values that are present the first 
time you run SuperClip.

Option:    Reverse x-axis

Select this menu item to flip the clipboard image horizontally.    This will result in a mirror 
image.
    

Option:    Reverse y-axis

Select this menu item to flip the clipboard image vertically.    The effect is the same as 
flipping a transparency over, top-to-bottom, and viewing it from the back.    To simulate the 



effect of turning an image upside-down, it is necessary to reverse both x and y axes.

Option:    Set JPG Quality

Select this menu item to adjust the quality setting for JPG files. The size of the JPG file will be
inversely proportional to this setting, which may be set anywhere from 1 to 100.    The 
default Q setting is 75.

Option:    Stretch bitmap

Select this menu item to stretch or compress the clipboard image along the horizontal 
and/or vertical axes.    Dimension limits are 1280 pixels horizontally by 1024 pixels vertically.

Option: Text colors

This menu item allows you to choose the displayed colors of clipboard text.    The choices are
black-on-white (the default) and white-on-black.

Options: Text to bitmap

Select this menu item to convert clipboard text to a monochrome bitmap image, so that it 
can be cropped or subjected to any of the other transformation options, and/or saved to disk
in any of the graphical formats.

The text that will be converted to a graphical image extends from the top of the window, as 
set by the current vertical scroll position, to the bottom of a full-screen image.
    

Option: TIF compression

This menu item allows you to select the compression scheme for TIF files.    The choices are 
no compression, PackBits, and LZW (Lempel, Ziv, & Welch).    In the Windows 95/NT version 
of SuperClip, two modes of LZW compression are available: LZW 8k and LZW 16k.    The k 
refers to the number of kilobytes of raw pixel data compressed into each strip.    The 
conventional strip size in TIF files is 8k, but 16k yields better compression.    The defaults are 
LZW 8k for 24-bit TrueColor images, and PackBits for monochrome and palette color images.

Option: Transparent GIF

Select this menu item to turn GIF transparency on.    This will make the selected color of 
subsequent GIF files transparent.    To select a color to be transparent, point the mouse 
cursor on the image to the color you want to be transparent, then click the right mouse 
button.    It is not necessary to select this menu item to turn GIF transparency on; simply 
select a color to be transparent, and this feature will be enabled.    The selected color will be 
the transparent color for all subsequent GIF files, until you select a different color or select 
this menu item to turn GIF transparency off, which will remove the checkmark next to this 
menu item.

If you select this menu item to turn GIF transparency back on, the previously-selected color 
will be transparent, unless you select a different color.





File Menu Item:    Open BMP
Select this item from the File menu to open a BMP file and place the image it contains onto 
the clipboard.    If a graphic image already exists on the clipboard, the entire contents of the 
clipboard will first be discarded.



File Menu Item:    Open TXT as...
Select this item from the File menu to open a TXT file and place it onto the clipboard, from 
where it can be printed or converted to a graphic image on the clipboard (See "Options - 
Text to bitmap.")    The text can be placed onto the clipboard using either of two character 
sets: ANSI or OEM.    The font for displaying text can be selected from the Display menu.



Main Menu Item:    Print
Print (Ctrl+P)
Select this menu item to print using the default page settings or page settings that were 
previously selected from either the "Print setup" or the "Page layout & margins" menu items.
When you select "Print," either from the Print menu or by pressing Ctrl+P, the printer is 
immediately activated, bypassing all dialog boxes.

Print setup 
Select this menu item to open the dialog boxes normally displayed before starting a print 
job.    To set page margins, select "Page layout & margins" before selecting this menu item.

Page layout & margins
Select this menu item to set margins and other page attributes, without printing.    These will
become the default settings when you select "Print" or "Print setup."

Select printer font
Select this menu item to choose the font used for the printing of clipboard text.

Cancel print job
Select this menu item to abort a print job in progress.

Reset LPT port (Ctrl+K)
Select this menu item to send a CLEAR command to the printer, which resets the printer and
erases all document data from the printer's memory.



Main Menu Item:    Display
Select this menu item to choose which clipboard format to display.    There are three possible
formats.

Bitmap
This is the format to display a graphic image.

OEM
This is the format to display text in the DOS-compatible, IBM extended-ASCII character set.

ANSI
This is the format to display text in the Windows-compatible character set.

From the Display menu you may select the font for displaying clipboard text.    For an 
explanation of the "Next DOS capture" item, refer to "Capturing the DOS Screen" in the 
SuperClip manual.



GLOSSARY
ANSI text
The set of text characters used by Windows.    Most of the alphanumeric characters and 
standard punctuation symbols in this set (ASCII codes 32 through 127) are equivalent to 
those in the OEM character set used by DOS.    However, the extended portion of the ANSI 
character set (ASCII codes 0 through 31 and 128 through 255) are mapped to different 
characters and symbols than those of the OEM character set.    ANSI stands for American 
National Standards Institute.

ASCII text
A text file format in which each character or symbol is represented by a one-byte numeric 
code in the range 0 through 255.    ASCII stands for American Standard Code for Information 
Interchange.

bitmap
An array of bytes that encodes a graphic image.    Each pixel is represented by 1 bit for 
monochrome, 4 bits for 16 color, 8 bits for 256 color, and 3 bytes (24 bits) for TrueColor 
graphics.

character mode
The non-graphical screen mode used by many DOS applications to display text.    Each 
character is represented by two bytes in memory, one for the ASCII code and one for the 
color attribute, and the displayed font is the same hardware font seen in DOS directory 
listings.

clipboard
An area of memory allocated by Windows for the temporary storage of data.    Applications 
can cut to or paste from the clipboard.    The entire screen can be copied to the clipboard at 
any time by pressing the PrtSc key (Shift-PrtSc on 84-key keyboards), or just the currently 
active window by pressing Alt-PrtSc.

interlace
Both PNG and JPG files can be interlaced or non-interlaced.    An interlaced file consists of 
seven sequential fields that are superimposed during display so that the image appears 
quickly in low resolution, which becomes progressively higher resolution as the remaining 
fields are subsequently
superimposed.

lossy compression
The kind of compression used in JPG files, where the degree of compression is a trade-off 
against the quality of the image.    A lower quality setting will produce a smaller file, while a 
highter quality setting will produce a bigger file.

LZW compression
A file-compression algorithm that encodes repetitious byte sequences as tokens stored in 
lookup tables to substantially reduce file size.    LZW stands for Lempel, Ziv, & Welch.

monochrome bitmap
A bitmap that has only two colors, usually black and white.    Each pixel is represented in the 
bitmap by one bit, so that one byte can encode eight pixels.

SuperClip will display and save monochrome bitmaps if the Windows "VGA with Monochrome
display" screen driver is running.    This driver can also display Windows in monochrome on a
color monitor.



OEM text
The IBM extended-ASCII character set used by DOS.    Most of the alphanumeric characters 
and standard punctuation symbols in this set (ASCII codes 32 through 127) are equivalent to
those in the ANSI character set used by Windows.    However, the extended portion of the 
OEM character set (ASCII codes 0 through 31 and 128 through 255) are mapped to different 
characters and symbols than those of the ANSI character set.    OEM stands for Original 
Equipment Manufacturer.

PackBits compression
A run-length encoding scheme used to compress TIF files.    This is the default compression 
scheme for monochrome and palette color images.    PackBits does not compress a file as 
densely as LZW, but is faster to write to and read from disk.

palette
Each pixel in a palette color image is represented in a graphics file as an index into a 16 or 
256 color palette.    A palette color image cannot use a color that does not exist as an entry 
in the palette.

transparent GIF color
A color selected to be transparent in a GIF file will not be visible when the image is 
displayed.    Instead, the background or whatever was on the screen before displaying the 
GIF file will show through.

TrueColor
A bitmap format that maps each pixel on the screen to three bytes in memory, one for each 
of the primary colors red, green, and blue.    The number of possible colors that can be 
represented for each pixel is therefore 256 to the 3rd power, or 16,777,200 different colors.   
A Super-VGA monitor can display TrueColor graphics only if the proper Windows screen 
driver is running and the video adapter card supports that display mode.




