
Specify the file names you wish to search for. You can specify multiple file names. Wild cards can be used in all. The specified file 
names must be separated by semi-colons or spaces and their total length must be limited a maximum of 255 characters. You can 
specify fully or partially qualified file names. All partially qualified file names must be specified with respect to the path specified in 
the Directory box. You can also drag-drop files from the File Manager window. 



Specify the path name of the directory whose files are to be searched. You can also drag and drop a directory path name from the 
File Manager window. This path is set as the base directory for the search.



Specify the text to be searched in this edit box. The specified text must be limited to a maximum of 255 characters. Any leading or 
trailing spaces typed are considered part of the search text. If no text is given, the search text is considered a don't care string and 
search takes place only for matching file names. 



Specify the earliest date for a search of files created on or after this date.



Specify the latest date for a search of files created on or before this date.



Specify the largest size of files to be searched.



Specify the smallest size of files to be searched.



Click this if you want only the base directory to be searched.



Click this if you want the base directory and all its sub-directories to be searched.



Click this if you want the base directory and all its sub-directories within and including    the specified depth level to be searched. 
This numeric value should not exceed 99.



Click this to find text occurrences with the exact combination of uppercase and lowercase letters. 



Click this to find text occurrences that are words, and not part of a larger word.



Click this to find text occurrences whose pattern matches the specified pattern. Pattern specifications consists of operators and 
expressions which allows you to search for texts conforming to a pattern rather than text conforming to an exact match of 
characters.



This displays the current directory of Find++.



This is the File Info List. It lists the file infos of all files matching the given search criteria. The files are listed in the sort order 
specified by you. The index of the current selection and the count of File Info items are displayed in the status bar. The file infos are 
displayed under their respective column headers Filename, Size, Date, Time and Path. Double-clicking on a column header sorts 
the list using that column item as the primary sorting key. Double-click a file info item if you wish to open its file for editing in 
FileView.



This status bar provides help and indicates the current status of the search operation. It also indicates the current index and number
of items in the File Info List.



This status bar provides help and indicates the status of Caps Lock, Num Lock and Insert control keys. It also indicates the current 
index and number of items in LineView.



This pane containing EditView displays the selected file's contents using an internal editor. Use the edit menu commands to edit the
text. You can edit selectively and quickly by double-clicking on a particular line in LineView. EditView then scrolls to display the 
context of that line for you to edit. Or you can just edit the entire file. All the navigation and editing keys are the same as those of 
Windows Notepad. You can change the size of the pane containing EditView by dragging the splitter.



This pane containing LineView lists all the lines in the file containing the search text. The file context of any of these listed lines can 
be scrolled into view in the EditView by double-clicking on that line. This helps you to quickly edit the context of that line. The 
selected line's index and the total count of lines are indicated in the status bar.



Click this if you want FileView to open with the EditView pane displaying the selected file contents. This option enables the internal 
editor of Find++. The internal editor can edit the file only if its file size is less than 60KB. Otherwise it treats it as a read-only file and 
displays only the context of the selected line.



Click this if you want FileView to open with the file contents being displayed in a new window belonging to the associated program of
the selected file. The EditView window will not displayed.



Click this if you want FileView to open with the file contents being displayed in a new window belonging to the Windows Notepad 
program. The EditView window will not displayed.



Click this if you want FileView to open with the file contents being displayed in a new window belonging to the program entered in 
the program name field. The EditView window will not displayed.



Type the file name of your editor here.



Click this to open this dialog box every time before opening FileView. This option is useful for editing different types of files. 



Click this to open this dialog box only if the file to be viewed is larger than 60KB. This option is useful for files greater than 60KB 
where you can specify a different editor to edit the file.



Click this if you do not want to open this dialog box before opening FileView.



Click this to perform sort in ascending order.



Click this to perform sort across directories. If this option is cleared, sort will be performed within directories.



Click this for no sort order. Files are listed in the order they are found.



Click this to use the file name as the primary sort key.



Click this to use the file size as the primary sort key.



Click this to use file date with time as the primary sort key.



Specify or select a default file type for file names. This default file type will be applied to file names specified without an extension in 
the Filename box in the Find++ window.. 



This combo box    displays the list of filenames that is to be excluded from the file search. To add to its list, type a file name in its edit 
box and then click Add. To delete an item, click on the item, and then click Delete.



Check this to enable the Excluded Files list. In this case, all file names matching any of the file names in this list are excluded from 
the search.



Click this button to add the file name you specify in the edit box of the Excluded Files' combo to it's list.



Click this button to delete a selected item from the Excluded Files.



Type the destination directory or filename here.



Click this to browse directories and select one.



Type the text to find here.



Click this to open this dialog for every file name(except the first) specified in the Filename box during a search. Clearing this causes
search to be conducted using the Sub-Directory Options in the Find++ window for all the specified file names.



Type the replace text here.



Click this option on for Find++ to query you for save every time replace is completed in a file. Clearing this option would make 
Find++ query you for save only after replace has been completed in all the specified files.



Click this to replace the search text in all the enabled files in the File Info List.



Display the status of the replace operation.



Drag this to change the relative sizes of the panes in FileView.



Enter the tab value here.



Type the number of lines above the line containing the search text you want to be displayed.



Type the number of lines below the line containing the search text you want to be displayed.



Type the level value here. You can also click on the Up or Down arrows to increase or decrease the value.



List of non-text files where search was not possible. You can add their file extensions to the Exclude Files list to be excluded from 
further searches.



Count of files displayed in the list box below.



Enter your Registration Key code.



Enter your first name exactly as you registered it.



Enter your last name exactly as you registered it.



Enter or select a default file type for filenames. Use Ctrl+F to set or remove focus.



Enter or select the text you wish to find in EditView.



Enter the minimum size of files to be searched. 



Enter the maximum size of files to be searched.
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File menu Commands (Find++ window)
This menu has the Find Files, Open File, Browse Directory and Exit commands.

 Find Files
This command in the Find++ window's File menu searches for new files using the specified search 
criteria. The filenames that match the searched criteria are listed in the File Info List in the sort order 
specified by you in the Sort Options dialog box. Any previous contents of the File Info List are cleared. 
The search can be stopped anytime by pressing the Esc key. The search also stops if the application 
runs out of memory.
If the search text is an empty string then the search text is considered a don't care string and the search 
is reduced to a search for files matching File name, Date and Size specifications only.
Note. All listed files have their check-boxes checked or marked.

Find in Selected Files
This command in the Find++ window's File menu searches the selected files listed in the File Info List 
using the specified search criteria. Files in the File Info List that match the new search criteria are 
marked in the File Info List and the others will be unmarked. The search can be stopped anytime by 
pressing the Esc key. The search also stops if the application runs out of memory.
You can use this command to narrow your search to files that match different sets of search criteria. 
Ex. To find the files containing the text "first name" and "Tom", 
1. Enter "first name" in the Search Text box and specify any other search criteria you wish.
2. Give the Find Files command to fill the File info List with infos of files containing "first name".
3. Enter the "Tom" in the Search Text box, check Case.
4. Select the files of interest in the File Info List.
5. Give the Find in Selected Files command. 

Now the files that contain the texts "first name" and "Tom" with be marked and the others will be 
unmarked..

Find in Marked Items
This command in the Find++ window's File menu searches the marked files in the File Info List using the
specified search criteria. Choose new search criteria for this command to narrow your search still further.
Files in the File Info List that match the new search criteria are marked in the File Info List and the others
are unmarked. The search can be stopped anytime by pressing the Esc key. The search also stops if 
the application runs out of memory.
You can use this command to narrow your search to files that match different sets of search criteria. 
Ex. To find the files containing the text "first name", "Bonnie" and "Clyde", 
1. Enter "first name" in the Search Text box and specify any other search criteria you wish.
2. Give the Find Files command to fill the File info List with infos of files containing "first name".
3. Enter the "Bonnie" in the Search Text box, check Case.
4. Give the Find in Marked Files command to fill the File info List with infos of files containing "first 

name" and "Bonnie. 
5. Enter the "Clyde" in the Search Text box, check Case.
6. Give the Find in Marked Files command. 

Now the files that contain the texts "first name", "Bonnie" and "Clyde" with be marked and the others will 
be unmarked.

 Open File
This command in the Find++ window File menu opens the file of the file info having the caret. The file 
data are displayed in a new window called FileView. Within FileView the EditView displays the file 
contents, and the LineView lists all the lines in the file containing the search text. 
The file size should be less 60K bytes for the editing option, else only the context of the line containing 
the search text is displayed in the EditView. 
To open a particular file listed in the File Info List, double-click the appropriate file info item in the File 



Info List. The FileView window opens displaying file data. By keyboard, you can use the Up and Down 
arrow keys to select the file info item in the File Info List, open the File menu, and select the Open File 
command.

 Browse Directory
This command in the Find++ window menu opens the Browse Directories dialog box. Directories can be 
browsed and the directory to be searched can specified.

Rename
This command in the Find++ window opens the Rename dialog box. You can rename the selected file in 
this dialog.

Delete
This command in the Find++ window deletes the selected file infos' files from the disk.

Copy
This command in the Find++ window opens the Copy dialog box. You can copy the selected file infos' 
files to the destination you specify in this dialog.

Move
This command in the Find++ window opens the Move dialog box. You can move the selected file infos' 
files to the destination you specify in this dialog.

Add to Zip
This command in the Find++ window opens the Zip dialog box. You can zip the selected file infos' files if 
WinZip© for Windows is installed in your system.

Note. WinZip© is copyright software of Nico Mak Computing Inc.

Exit
This command in the Find++ window exits the Find++ application to Windows.

See also
Specifying search criteria
File Info List



 Browse Directories
The Browse Directories command in the Find++ window's File menu opens the Browse Directories 
dialog box. Directories can be browsed and you can specify or select the directory to be searched. This 
directory path is entered in the Directory field of the Find++ window,    and Find++ sets this directory as 
its current directory. If you wish to search even its sub-directories, choose the sub-directory options as 
appropriate.

Dialog box options.
Directories
You can specify the directory to be searched by double-clicking a directory name in this list box. To open
a directory containing sub-directories, click on the directory name. Using the keyboard press the Up and 
Down arrow keys to select a directory name and then press the Select button.

Drive
Specify a drive if necessary by selecting one of the available drives in the Combo box’s drop-down list.

See also
Set File Filter
File Name



Rename
In this dialog box you can specify the new file name of the file info item under focus.

Dialog Box Options
Destination
Specify the new file title in this dialog. This title should be unique in the selected file info's directory.

See also
File Name
Browse Directory
File Info List



Zip
In this dialog box you can specify the destination zip file name.

Dialog Box Options
Destination
Specify the destination zip file name. The default file name extension is ".zip". You can zip the selected 
files in the File Info List if WinZip© for Windows is installed in your system. The files are added to the zip 
file along with their path names. The zip program's command line parameters can be found in 
"FINDPP32.INI" in the Find++ directory under the Section Find as:

ZipOptions = -a -P
i.e. (a)dd files, save directory (P)ath name info. 

To use a program other than WinZip© for Windows, specify the destination file name with its extension. 
If the extension is associated with an executable program, Find++ runs that program using the 
ZipOptions string as command line parameters. So you must change the value of ZipOptions as 
appropriate. Your new zip program should have the same format as WinZip's command line format 
which is:

Winzip -Action [-Options] Filename[.zip] @Listfile
where

Action
-a for add, -f for freshen, -u for update, and -m for move.

Option
-r and -P correspond to the "Recurse Directories" and "Save Extra Directory Info".
-ex, -en, -ef, -es, and -e0 options determine the compression method: eXtra, Normal, Fast, Super 

fast, and no compression. The default is "Normal".

Filename
is the name of destination zip file specified by you.

Listfile
is the name of the file name containing the list of file names to be zipped and is generated by Find++.

Check at WinZip's website http://www.winzip.com for their documentation on WinZip's command line 
parameters.

Note. WinZip© is copyright software of Nico Mak Computing Inc.

See also
File Name
File Info List



Copy
In this dialog box you can specify the destination to which you wish to copy the files to.

Dialog Box Options
Destination
Specify the destination to which you wish to copy the selected files to. The destination must be a valid 
directory if you are copying more than one file. Click the Browse button to change the current directory.

See also
File Name
Browse Directory
File Info List



Move
In this dialog box you can specify the destination to which you wish to move the selected files to.

Dialog Box Options
Destination
Specify the destination to which you wish to move the selected files to. The destination must be a valid 
directory if you are copying more than one file. Click the Browse button to change the current directory.

See also
File Name
Browse Directory
File Info List



Edit menu commands (Find++ window)
This menu has the Delete File Infos, Copy File Infos, Clear All File Infos, Select All File Infos, 
Deselect All File Infos and Sort File Infos commands.

 Copy File Infos
This command copies the selected items in the File Info List to the clipboard.

 Delete File Infos
This command deletes the selected file infos from the File Info List. 

 Clear All File Infos
Clears the File Info List of all file info items.

Select All File Infos
Selects all the file infos in the File Info List.

Deselect All File Infos
Deselects all the file infos in the File Info List.

 Sort File Infos
Sorts the File Info list in the order specified by the Sort Option dialog box. Set the Sort Option to sort by 
file name, file size or file date. You can also sort across directories instead of within them by setting its 
option in the Sort Option dialog box.

See also
Sort Option
Specifying search criteria
Editing a file in the FileView



Options menu commands (Find++ window)
This menu has the Sort Options, FileView Settings, Set File Filter, Save Setting Now and Save 
Settings commands.

Sort Options
Opens the Sort Options dialog box. You can choose a file name, file size or file date as the key value for 
the Sort command.
You can also choose the sort across directories option. If this option is not set, sorting is performed 
within directories.

FileView Settings
Opens the FileView Settings dialog box where you can choose the editor or viewer with which you wish 
to edit or view the file you open in the FileView window.

Set File Filter
Opens File Filter dialog box where you can specify the default file type for file names specified by you in 
the File Name field of Find++ window. You can also specify the file names that you want excluded from 
the search.

Program Locations
Opens the Program Locations dialog box where you can specify the location of your zip program and its 
parameters.

Note. This command is not available in the unregistered version of Find++.

Save Settings Now
Saves all the options set during the current session immediately.

Save Settings
Saves all the options set during the current session when Find++ closes.



Set File Filter
The Set File Filter command in the Options menu in the Find++ window opens the Set File Filter dialog
box. 

Dialog box options.
Set File Type
Specify or select a default file type for file names. This default file type will be applied to any file name 
specified without an extension in the search criteria.

Excluded Files
This is a simple combo box that displays the list of filenames that is to be excluded from the file search. 
Specify the file name you wish to exclude from the search in its edit box. Wildcards are allowed. For 
instance, you can specify file names like myold*.txt, myold*.c, or badfile.pas, etc. Press the Add    
push button to add the specified file name to the Excluded Files list.
If you wish to delete an item, select the item by clicking it and then click on the Delete push-button. You 
can also use the Up and Down arrow keys to select an item and then select the Delete push button to 
delete the item.

Enable Exclude Files
Checking this check-box enables the Exclude Files list. In this case, all file names matching any of the 
file names in this list are excluded from the search. This is a useful option when certain unimportant files 
in a project need to be excluded from file searches.

Note. You can also specify or select a default file type in the combo-box in the 
Find++ window's toolbar. Type Ctrl-F to set or remove focus from this combo-box.

See also
File Name
File name examples
Browse Directory



Sort Options
The Sort Options command in the Options menu in the Find++ window opens the Sort Options dialog 
box. You can choose a file name, file size or file date as the key value for the Sort command or the Find 
Files command. After every successful search, files are sorted and listed in the File Info List. You can 
also use the Sort command to sort a non-empty File Info List. You may wish to do so to view the list 
sorted to different keys.

Dialog box options.
Sort across directories
Setting this option causes sort to ignore the directory names of the files during sort. Consequently 
sorting is performed across directories. If this option is not set, sorting is performed within directories.

No order
No sort order. Files are listed in the order they are found by the search.

By file name
Uses the file name as the key for sorting.

By file size
Uses the file size as the key for sorting.

By file date
Uses the file date as the key for sorting.

See also
Sort
File Info List



FileView Settings
The FileView Settings command in the Options menu opens the FileView Settings dialog box. You can
choose the editor you wish to use for editing the file you select in the File Info List. You can also choose 
the condition for Find++ opening this dialog box every time you give the Open File command in the 
Find++ window's File menu.

Dialog box options.
Find++ internal editor
FileView opens with the EditView window displaying the selected file contents. This option enables the 
internal editor of Find++. The internal editor can edit the file only if its file size is less than 60KB. 
Otherwise it treats it as a read-only file and displays only the context of the selected line in the EditView.

Associated editor/viewer
FileView opens with the file contents being displayed in a new window belonging to the associated 
program of the selected file. The EditView window is not displayed.

Notepad
FileView opens with the file contents being displayed in a new window belonging to the Windows 
Notepad program. The EditView window is not displayed.

Any other editor
FileView opens with the file contents being displayed in a new window belonging to the program entered
in the program name field. The EditView window is not displayed.

Always
Open this dialog box every time you give the Open File command. This option is useful for editing 
different types of non-text files.

Only if the Find++ internal editor cannot edit the file.
Open this dialog box after the Open File command only if the file to be viewed is larger than 60KB. This 
option is useful for files greater than 60KB where you can specify a different editor to edit the file.

No
Do not open this dialog box after you give the Open File command.

See also
File Info List
Editing a file in FileView
EditView



Using the File Info List
This is a multiple select list box that lists file names matching the given search criteria. The files are 
listed in the sort order specified by you in the Sort Options dialog box. The list is columnar and has 5 
columns displaying file name, file size, date and    time of file creation, and the file path of all the files 
under the column headers Filename, Size, Date, Time and Path respectively. The index of the current 
selection and the count of File Info items are displayed in the Status bar.
Double-clicking on a column header sorts the list using that column item as the primary sorting key. For 
instance, double-clicking on the Filename header sorts the list using the file name of the File Info item 
as the sorting key. Double-clicking on the Path header sorts the list using the path name as the sorting 
key. 
Use the window's Edit menu to Delete, or Copy to clipboard the selected file info items. Double-click a 
file info item if you wish to view and edit its file. By keyboard, select a file info item using the Up and 
Down arrow keys and then press Return. A new window called the FileView window opens displaying 
the file contents in the EditView pane and a list of lines containing the search text in the LineView pane. 
You can also use Open File command in the File menu to open the file of the info item having the caret 
in the FileView window.

Note. In previous versions of Find++, this was a single select list box.

See also
Specifying search criteria
Open File
FileView window



FileView window
When you double-click a file info item in the File Info List, this window opens. The window's workspace 
is divided into two panes. The top pane contains the EditView and the bottom pane contains the 
LineView. The file contents are displayed in the EditView(a multiline edit box), and all the lines in the file 
matching the search criteria are listed in the LineView(a single-select list box). It has various menu 
commands like File menu, Edit menu, Options menu and Help menu to help you find the contexts of the 
lines containing the search text and edit these lines. It has a Status bar at the bottom displaying status 
information for both the EditView and the LineView. 
This window's two panes position and size is controlled by the Splitter located between the two panes. 
The Splitter can be dragged by a mouse or by using the Split Window menu command. The FileView 
window itself can be sized, maximized or restored.
The LineView serves to help you get to the context of all the lines containing the search text in the file. 
When you can double-click a line item in the LineView, the EditView contents are scrolled till the 
selected line's context is in view, with the search text selected. Similarly, the contexts of all the lines 
listed in the LineView can be visually inspected in the EditView. If any editing is required, you can click 
on the EditView and use the Edit menu commands to edit the file contents. By keyboard, you can use 
the Display Context command in the File menu to display the context of the selected line in the 
LineView. Then select EditView in the Window menu. Use the commands in the Edit menu for editing 
the file.
The internal editor can edit the file only if its size is less than 60KB. Otherwise it treats it as a read-only 
file and displays only the context of the selected line in the EditView. Use the Set Context Size 
command in the Options menu to set the number of lines above and below the line containing the 
search text.

Note. You can also use short-cut keys ‘F6’ or ‘Ctrl-Tab’ to move the focus from the 
EditView to the LineView or vice versa.

See also
File Info List
Editing a file in FileView
EditView
LineView
Window menu



Using the EditView window
This window pane displays the selected file's contents using an internal editor. Use the Edit menu 
commands to edit the text. You can edit selectively and quickly by clicking on different lines in LineView 
and editing its context, or you can just edit the entire file.
All the navigation and editing keys are the same as those of    Windows Notepad. However, one more 
desirable editing function has been added. The Insert key can now be toggled to set Insert or Overwrite
mode as indicated by the Status bar at the bottom of the FileView window. This Status bar also indicates
the state of the Caps Lock and Num Lock keys. You can print the contents of EditView using the Print 
command. If you like you can choose a new font for printing by selecting the Font command in the 
Options menu. You can change the size of the EditView pane by dragging the Splitter.
The editing feature is not supported for files greater than 60KB. In this case, you can only view the 
context of the line containing the search text in the EditView. Files of any size can be viewed in this 
read-only mode. Use the Set Context Size command in the Options menu to set the number of lines 
above and below the line containing the search text.
If you choose an editor other than the internal editor in the FileView Settings dialog box, then the 
EditView is not displayed, and the file contents are displayed in the selected editor's own window.

See also
FileView window
Editing a selected file
Finding and Replacing in EditView
LineView
Window menu



Using the LineView
This is a single select list box that lists all the lines in the file containing the search text. The lines are 
numbered from 1 to maximum of 32768. Line numbers greater than 32768 are not listed. The search 
also stops if the application runs out of memory.
The file context of any of these listed lines can be displayed in the EditView. This helps you to quickly 
view or edit the line context. The current line index and the total count of lines is indicated by the Status 
bar at the bottom of the FileView window. You can copy the LineView to the clipboard by using the Copy
LineView to Clipboard command in the Edit menu. You can also print the contents of the LineView. 
Choose a new font for printing if you like by selecting the Font command in the Options menu.

Note. If you choose an editor other than the internal editor in the FileView Settings
dialog box, then the EditView is not displayed, and the file contents are displayed 
in the selected editor's own window.

To display an line's context    by mouse
1. Double click the line in the LineView.

To display an line's context    by keyboard
1. Select the line in the LineView by moving the UP or DOWN arrow keys.
2. From the FileView window's File menu select Display Context or press Return.

See also
FileView window
Editing a selected file
EditView
Window menu



Sub-Directory Options Dialog
In this dialog box you can specify the sub-directory option and the depth to which sub-directories must 
be searched by Find++ when searching for matching file names. This dialog box is displayed only when 
Find++ searches with multiple file names. Find++ uses the sub-directory specifications in the Find++ 
window for the first file name, and opens this dialog box to obtain the sub-directory specifications for the 
second file name and every file name thereafter.

Dialog box options.
None
Only the current directory will be searched.

All
The current directory and all its sub-directories will be searched.

Level
Only the current directory and all its sub-directories within and including    the specified depth level will 
be searched. Specify the level value as appropriate. This numeric value should not exceed 99.

Note. The sub-directory options here are similar to the Sub-directory Options in the 
Find++ window.

Use this setting for rest of search
Check this as appropriate. Checking it will stop this dialog box opening again and Find++ uses the 
specified sub-directory options for the rest of the search.

See also
File Name
File name examples
Search Text
File Info List
Browse Directory



File name examples
In the following examples the Search Text and Date specifications are ignored.

Ex. 1. Specify the filenames:
*.txt *.c

Find++ first searches for file names matching *.txt in the directory specified in the Directory box and all 
the specified sub-directories. It then opens the Sub-Directory Options Dialog requesting a new sub-
directory specification and searches for file names matching *.c in the same directory and the newly 
specified sub-directories.

Ex. 2. Specify the filenames:
*.txt; hlp\*.rtf; c:\test\

Find++ first searches file names matching *.txt in the directory specified in the Directory box and all the
specified sub-directories. It then searches in the hlp sub-directory for file names matching *.rtf. Finally it 
searches in the c:\test directory for file names matching the default file type.

Note. Specify sub-directory names like "c:\test\" with the terminating '\'.

Ex. 3. Specify the filenames:
c:\ d:\ e:\

In this example, if you had specified a search for All sub-directories in the Find++ window, Find++ would
proceed to search all the directories in all the specified drives for file names matching the default file 
name.
Find++ does not list a particular file name more than once in the File Info List. Only the first file matching
the search criteria is listed.



Specifying search criteria in the Find++ window
The various specification fields in the Find++ window are the Directory, File name(s), Search Text and 
the From and To date fields. You specify your search criteria in these fields. 

Directory
Specify the path name of the directory whose files are to be searched. You can also drag and drop a 
directory path name from the File Manager window. This path is set as the current directory of Find++ 
when the search begins. If you wish to search sub-directories too, then specify the path name of the 
base directory, then set the sub-directory as appropriate.

File Name(s)
Specify the file or files you wish to search for. You can specify multiple file names in the File Name(s) 
box. Wild cards can be used in all. The specified file names must be separated by semi-colons or 
spaces and their total length must be limited a maximum of 255 characters. Long file names having 
embedded spaces or semi-colons must be within double quotes(eg. "C:\Program Files\MyDir\*.txt").
You can specify fully or partially qualified file names. All partially qualified file names must be specified 
with respect to the path specified in the Directory box. For everyone of these additional file name 
specification, Find++ searches in the specified path for files matching the given search criteria. If the file 
extension is not specified for any file name the default file name extension(See Set File Filter) is 
assumed.
Find++ requests you for a new sub-directory specification before continuing search with the second and 
every additional file name specification(See Sub-Directory Options Dialog). By specifying appropriate 
choices each time, you can tune your search among sub-directories(See File name examples).
You can also drag-drop files from the File Manager window. In this case you will be searching for file 
names without any wildcards. As before Find++ opens the Sub-Directory Options Dialog before 
continuing the search with the second file name specification. In this case, you may wish to stop this 
dialog box opening again. If so, check on the Use this setting for rest of search option.
If no valid file name is specified, Find++ gives an error message.

Search Text
Specify the text to be searched in this edit box. The specified text must be limited to a maximum of 255 
characters. Any leading or trailing spaces typed are considered part of the search text. If no text is given,
the search text is considered a don't care string and search takes place only for matching file names. 
You can also specify further search criteria such as case, word, or regular expression.

From
Specify the earliest date for a search of files created on or after this date.

To
Specify the latest date for a search of files created on or before this date.

Less
Specify this value for a search of files whose sizes are less than this value.

More
Specify this value for a search of files whose sizes are more than this value.

None
Only the current directory will be searched.

All
The current directory and all its sub-directories will be searched.

Level
Only the current directory and all its sub-directories within and including    the specified depth level will 
be searched. Specify the level value as appropriate. This numeric value should not exceed 99.



Match Case
Finds only those occurrences with the exact combination of uppercase and lowercase letters specified in
the Search Text box. 

Whole Word
Finds occurrences that are words, and not part of a larger word.

Regular Expression
This option uses a regular expression to find text occurrences whose pattern matches the specified 
pattern. Pattern specifications consists of operators and expressions which allows you to search for 
texts conforming to a pattern rather than text conforming to an exact match of characters.

When you have specified all the necessary search criteria, use the Find Files command in the File menu
to begin the search. Find++ lists all files matching the specified search criteria in the File Info List.

See also
File Info List
Set File Filter
File name examples



File menu commands (FileView window)
This menu has the Display Context, Save, Save As, Print Setup, Print and Exit commands.

Display Context
This command in the File menu displays the file context of the selected line in LineView in the EditView 
window. The specified search text is shown selected with the cursor at the end of the selection in the 
EditView. If the file is less than 60KB the contents are scrolled, if necessary, to display the new context. 
On files larger than 60KB lines are read from the disk if the context lines lie outside the current context's 
block of lines.
A Display Context's block of lines is defined by specifying the Lines Above and the Lines Below 
parameters in the Display Context Settings dialog box.

 Save
Saves the opened file with the same name and in the same location. When you want to save in a 
different name or location use the Save As command.

Save As
Displays the Windows Save As dialog box, where you specify the name and location to save the file 
opened in FileView.

Print Setup
Displays the Print Setup dialog box, where you can set up the printer and page options.

 Print
Displays the Print dialog box, where you can set up the printer and specify your print options. You can 
print either the contents of EditView or the contents of LineView.

Exit
Closes the FileView window.

See also
Print
Print Setup
EditView
LineView



Print Setup (FileView window)
This command in File menu displays the Print Setup dialog box, where you can select the printer and 
specify your print paper size, paper feeding and orientation options.



Save As (FileView window)
This command in the File menu displays the File Save As dialog box. Specify the path to save the file in
the EditView. You can specify your file name title in the File name field and selecting the appropriate 
options in the Directory and Drive fields.



 Print command (FileView window)
This command in the File menu displays the Print dialog box, where you can set up the printer and 
specify your print options.

Dialog box options.
EditView
Select this option if you wish to print the contents of the file in EditView.

LineView
Select this option if you wish to print the contents of the LineView.

All
Prints the entire file.

Selection 
Prints only the selected text in file.

Note. Not present in the current version.
Pages 
Prints only the pages you specify. Type page numbers separated by commas, or a range of pages with a
hyphen between the page numbers. For example, to print pages 2, 4, 6,    7 and 8, type 2,4, 6-8 

Note. Not present in the current version
Set-up
Choose this option if you want to change the default printer, printer resolution, and print intensity.

See also
EditView
LineView
Print Setup



Edit menu commands (FileView window)
This menu has the Undo, Delete, Cut, Copy, and Paste basic editing commands. It has search and 
replace commands like Find, Find Again, and Replace. It also has other commands like Select All, 
Change Case and Copy LineView to Clipboard. 
The commands in the Edit menu are:

 Undo
Reverses the most recent change in the file under edit. Only the delete, cut, copy, paste operations can 
be undone.

Del
Deletes the selected text without saving it to the clipboard.

 Cut
Deletes the selected text and saves it to the clipboard.

 Copy
Copies the selected text to the clipboard.

 Paste
Inserts the contents of the clipboard at the cursor position.

Select All
Selects the entire contents of the file.

Change Case
Selecting this menu command opens a sub-menu with 3 sub-menu commands Upper Case, Lower 
Case and Toggle Case. The Upper Case command changes the selected text to upper case. The 
Lower Case command changes the selected text to lower case. The Toggle Case command toggles 
the case of the selected text.

Find
Opens a Find dialog box and searches the open file for the specified text, using the specified options in 
the dialog box.

 Find Next
Finds and selects the next occurrence of the text specified in the Find What box during the previous Find
operation.

Note. You can also specify your text to search for in the toolbar Find Next combo 
box. Pressing Return searches for the text entered or selected in the combo box. You 
can use Ctrl-F to set or remove focus from this combo box.

Replace
Opens the Replace dialog box with its Find What box containing the same text specified during the 
previous Find command. You can replace this text by a specified replace text one by one by using the 
Replace command in the dialog box. You can also replace text throughout the file without being queried 
each time by using the Replace All command in the dialog box. Further, you can replace the specified 
text in all the files listed in the File Info List using the Replace In Files command in the dialog box.

Copy LineView to Clipboard
Copies the contents of the LineView to the clipboard.

See also
EditView
LineView





Find
This command in the FileView window's Edit menu opens the Find dialog box where the Find Next 
command searches the open file for the specified text, using the specified options in the dialog box. This
command applies only to EditView.

Dialog box options.
Find What
Type, or insert the information you want to find.

Up
Searches from the insertion point or end of the selection to the beginning of the file.

Down
Searches from the insertion point or beginning of the selection to the end of the file.

Match Case
Finds only those occurrences with the exact combination of uppercase and lowercase letters specified in
the Find What box. 

Whole Word
Finds occurrences that are words, and not part of a larger word.

Find Next
Finds and selects the next occurrence of the text    specified in the Find What box.

See also
FileView window
EditView



Replace
This command in the FileView window's Edit menu opens the Replace dialog box with its Find What 
box containing the same specified text during the previous Find command. Type the replacement text, 
and then specify any options you want to apply. This command applies only to EditView.    

Dialog box options.
Find What
Type, or insert the information you want to find.

Replace With
Type the text you want to use as replacement text, or paste it from the Clipboard. To delete the text in 
the Find What box, leave the Replace With box empty.

Text Options
Select an option.

Case
Finds only those occurrences with the exact combination of uppercase and lowercase letters specified in
the Find What box. 

Word
Finds occurrences that are words, and not part of a larger word.

Regular
Finds occurrences that match the specified pattern in the Find What box.

Files Option
Select an option if you wish to use the Replace in Files command. These options are ignored if you 
choose the Replace or Replace All commands.

All Files
Select this option if you wish to search and replace in all the files in the File Info List.

Selected Files Only
Select this option if you wish to search and replace in the selected files in the File Info List.

Marked Files Only
Select this option if you wish to search and replace in the marked files in the File Info List.

Find Next
Finds and selects the next occurrence of the text    specified in the Find What box.

Replace
Changes the selected text to the text    in the Replace With box, and then finds the next occurrence.

Replace All
Finds and replaces all occurrences of the text in the Find What box with the text in the Replace With 
box without confirmation.

Replace In Files
You can also replace the specified text in the files in the File Info List using this command in the 
Replace dialog box. Choose the Files Option as appropriate(See Finding and Replacing in EditView). 
All occurrences of the specified text are replaced throughout in every file.

Confirm File Save
Check this option if you want the Replace in Files command to prompt you for confirmation for a file 
save every time the specified text has been replaced in a file. If this checkbox is cleared, you are asked 
for confirmation only once after the specified text has been replaced in all the files selected in the File 



Info List. In this case, all the files will be saved together on confirmation.

See also
FileView window
EditView



Options menu commands (FileView commands)
This menu has the Font, Tabs, Wrap Lines and Set Context Size commands.

Font 
Select this option to open the Font dialog box. The font in the FileView window's workspace, i.e. 
EditView and LineView, is set to the selected font.

Tabs
Select this option to open the Tabs dialog box. Specify the Tab length as appropriate. Tabs in the 
FileView window's workspace are set according to the selection.

Wrap Lines
Select this option if you wish to wrap lines of text in the EditView window.

Set Context Size
Opens the Set Context Size settings dialog box. The total number of lines displayed in the EditView 
window in read-only mode is set by the user specifying the number of lines displayed above and below 
the line containing the search text in this dialog box.

See also
FileView window
EditView
LineView
Context Lines



Font
This option in the FileView window's Options menu opens the Font dialog box. Specify the font name, 
style(such as bold or italic) and the point size in the dialog box. A sample text for the chosen font is 
displayed in the Sample box. The font in the FileView window's workspace, i.e. the EditView and 
LineView, is set according to the selection.



Tabs
This option in the FileView window's Options menu opens the Tabs dialog box. Specify the Tab length 
as appropriate. Tabs in the FileView window's workspace, i.e. the EditView and LineView, are set 
according to the selection.



Set Context Size
This command in the FileView window's Options menu opens the Set Context Size dialog box.    You 
can specify the total number of lines displayed in the EditView in read-only mode by specifying the 
number of lines displayed above and below the line containing the search text in this dialog box.

Dialog box options.
Lines Above
Specify a value below 1024.

Lines Below
Specify a value below 1024.

See also
FileView window
EditView
LineView



Window menu commands (FileView commands)
This menu has the EditView, LineView and Split Window commands.

EditView 
Select this option to work in the EditView.

LineView
Select this option to work in the LineView.

Split Window
Use this command for splitting the two panes of the FileView window. The two panes relative sizes can 
be changed by dragging the Splitter or using this menu command. 

See also
Using the Splitter
LineView
EditView



Help menu
This menu is found in both the Find++ and FileView windows. It has the Contents, Search for Help on, 
Registration and About Find++ commands.

Contents
This command in the Help menu displays the opening screen of Help. From the opening screen, you 
can jump to various Find++ Help topics. From any open Help topic, you can click the Contents button 
whenever you want to return to the opening screen.

Search for Help on
This command on the Help menu searches for any topic on Find++. It opens the Help Search dialog 
box where topics are listed depending on specified key values.

Install Registration Key
This command in the Find++ window opens the Install Registration Key dialog box where you can install 
the registration key you received from the author on registering your copy of Find++.

Registration
This command displays a shareware notice and registration details of Find++.

About    Find++
This command on the Help menu displays the copyright notice and version number of your copy of 
Find++.

See also
Registering Find++
Install Registration Key



Registration Key Installation.
This dialog box allows you to install the registration key you receive from the author on registering Find+
+. After installing the key, all options of the registered version will be available when you restart Find++.

Dialog box options.
First Name
Enter your first name as registered with the author.

Last Name
Enter your last name as registered with the author.

Registration Key
Enter the registered key you received from the author.

Note. Please contact the author if by any chance your installation fails. You could 
be having an old version of Find++.



Using the Splitter

    The splitter
Dragging the splitter changes the relative heights of the two panes in the FileView window. Enlarging the
top pane automatically enlarges the EditView, and enlarging the bottom pane automatically enlarges the 
LineView. If    you wish to enlarge the view area of the EditView drag the Splitter down. If you wish to 
view a large number of lines in the LineView, you can similarly enlarge the view area of the LineView by 
dragging the Splitter up.
You can also increase the size of the FileView window itself through the System menu or by dragging its 
border as appropriate.

Note. If you choose an editor other than the internal editor in the FileView Settings
dialog box, then the EditView is not displayed, and the file contents are displayed 
in the selected editor's own window.

To split the FileView window by the mouse
1. Point the mouse at the Splitter.
2. When mouse pointer changes shape to the splitter indicator, drag it to the desired position.

To split the FileView window by keyboard
1. From FileView window's    Window menu select the Split Window command.
2. When mouse pointer changes shape to the splitter indicator, use the Up and Down arrow keys to 

move the indicator to the desired position and type Return.

See also
Using the Splitter
LineView
EditView



Find++ Status bar
This status bar on the Find++ window has different fields which display useful status information.

Field           Information
1. Shows status and help information on selected menu item or 

control
2. Shows a prompt message.
3. Shows the index of the current selection in File Info List.
4. Shows the count of lines in File Info List.

See also
File Info List



FileView window's Status bar
This status bar in the FileView window displays useful status information in 7 fields.

Field           Information
1. Shows status and help information on selected menu item or control.
2. Shows status of CapsLock key.
3. Shows status of NumLock key.
4. Shows Insert/Overwrite mode.
5. Shows the line number of edit cursor in EditView window.
6. Shows the character column of edit cursor in EditView window.
7. Shows the line index of selected line in LineView box.
8. Shows the count of lines in LineView box.

See also
EditView
LineView



Overview - Find++ : A Multi-File Search, Replace and Edit Utility
Find++ is a Windows utility that gives you a powerful and friendly tool to quickly search and replace text 
in multiple files. Find++ lists all the files matching your search criteria. It then provides you with powerful 
commands with which you can quickly replace or edit all the occurrences of the specified text, saving 
you time and energy over conventional methods. Full context sensitive help on all Find++ topics helps 
you quickly grasp its simple user-friendly interface.
For a search you can specify multiple file names with or without wild-cards or you can just drag-drop 
files from the File Manager. You can search files in all sub-directories or up to a specified sub-directory 
depth. You can search for a case-sensitive, whole word or a regular expression match. You can even 
specify an earliest and a latest file creation date as a search criterion. 
Find++ lists the files containing the search text with full file information like path, file size, and date of 
creation. You can search again through these listed files with new search criteria to narrow your search 
even further.
You can sort the listed files using the file name, size or date as the sorting key and you can specify the 
sort to be within or across directories. 
You can rename any file in the list, and delete, copy, move or zip selected files in the list.    
You can then open any of these listed files for editing. An internal editor displays the selected file 
contents in an edit window, and a list box lists the lines containing the search text. Double-clicking a line 
in this list scrolls the edit window to bring the context of that line into view for quick editing. This way, 
editing the search text throughout a file can be completed in the shortest possible time. 
The internal editor provides you with powerful editing features like a search and replace command that 
replaces all occurrences of a specified text in a file. You can also replace text throughout in selected or 
all the listed files. You can search for any text using case, word or regular expression options. You can 
change or toggle case in selected text. You can do a word wrap of text lines.
Find++ also gives you the option of using an editor of your choice or the associated program to open 
and edit the file.



A simple step by step example

Follow the steps given below for a typical usage of Find++.
Specify the directory you wish to search in the Find++ window If necessary, you can browse directories 

and select the directory using the Browse Directory command in the File menu. Find++ sets this 
directory as the current directory.

Specify the file names. If more than one file name is specified, separate the file names by spaces. Wild 
cards can be used. You can also drag-drop files from File Manager.

Specify the search text to be searched in these files. You can use regular expressions in the text.
Specify the file dates in the From and To fields as appropriate. All file dates matching the From date up 

to and on the To date are searched.
Specify the search text options, such as case, word or regular expression.
Specify the sub-directory option as appropriate. If the search should be restricted only up to a specific 

depth, specify the depth level value.
Click on the Find Files button or select Find Files on the File menu. The files matching the search 

criteria are listed in the File Info List.
You can use the Find in Selected Files command to search through the files in the File Info List with 

additional search criteria to narrow your search further and form a more restricted File Info List.
To open a file listed in the File Info List, double-click its file info item or use the Up or Down arrow keys 

to select its file info item and then select the Open File menu command in the File menu.
The FileView window is displayed. The file contents are displayed in EditView, and all the lines in the file

containing the search text are displayed in the LineView.
Double clicking on any line in the LineView would display the context of the selected line in the EditView.

You can also use the Up or Down arrow keys to select the line and then selecting the Display 
Context command in the File menu.

If the file size is less than 60KB you can view and edit the file contents in the EditView. The edit 
commands are same as that of Windows Notepad. You can also view the file contents in an editor of 
your choice(See the FileView Settings in the Find++ window's Options menu).

To replace a common text in all the files in the File Info List, select the All Files option and then select 
Replace In Files in the Replace dialog box.

Save the file after editing using the Save or Save As command in the File menu.
Exit the FileView window.
Open another file in the File Info List if you wish.

Note. The editing feature is not supported for files greater than 60KB. In this case,
you can only view the context of the line containing the search text in the EditView.



Wild card
To apply    an approximate condition for search, wild card characters such as (?) and (*) are used. The 
character (?) signifies that the search condition is true for any character in its position, and the character 
(*) signifies that the search condition is true for any number of characters in its position.
For instance, specifying    s?t in a text would signify that texts such as sat or sit are considered to satisfy
the search condition. Similarly, specifying sh* would signify that texts such as shame or shy are 
considered to satisfy the search condition.



System Menu
This menu include commands for restoring, moving, sizing, minimizing, maximizing the window. It also 
includes commands for closing the window and switching to another application.



Notepad
This is a Microsoft Windows text editor and forms part of the Microsoft's Windows Operating System. 
Refer to Microsoft's Windows documentation for information on how to use its editing features.



Regular Expressions
You can tune searches to meet your needs when you wish to search for occurrences of text that are 
similar but not the same. For matching such generalized occurrences you need to use operators and 
expressions. An example would be the regular expressions used in Microsoft Word© 6.0. Find++ has 
similar features for its implementation of regular expressions. 

List of operators
Operator Description Example

? Matches any single character ma?e matches male, mate, maze, etc.

* Matches none or many occurrences of a 
previous character or expression.

bo*y matches by, boy

@ Matches    one or more occurrences of a 
previous character or expression

sho@t matches shot, shoot, etc.

[] Matches one of the specified characters 
within brackets.

b[ae]t matches bat, bet, beet, beat.

[-] Matches any single character in this range ca[p-s]e matches cape, care, case

[!] Matches any single character except the 
characters or range of characters in the 
brackets.

Cas[p-s]e matches cafe, cage, cave, etc.

For example in Find++, 
You can use WM_[A-Z] as your regular expression to find some C words like WM_PAINT and 

WM_CREATE. 
You can use complicated expressions like [_a-z]@[_a-z0-9]@ to search for C variables or names.

Note. Choose your expressions and operators  carefully to get meaningful results.



Editing a file in FileView
The Edit menu has the Undo, Delete, Cut, Copy, and Paste commands for cursor based editing. It has 
search and replace editing commands like Find, Find Again, and Replace. It also has other commands 
like Select All, Change Case and Copy LineView to Clipboard. 
Using the aforementioned commands you can change text quickly in the EditView. You can delete, cut, 
copy or paste text. You can search for text using the Find command for case, word, and regular 
expression match. You can also use the Replace command to replace a specified text in a file or even in
all the files listed in the File Info List. Cursor movements are the same as Windows Notepad. You can 
also type in Overwrite mode by pressing the Insert key.
Double-click a line in the LineView to quickly get to the context of the line in the EditView. With the 
keyboard, select the required line in the LineView using Up and Down arrow keys, then type Return. 
After editing the context, double-click on another line in LineView to edit another context. Thus the entire
file can be selectively and quickly edited.
Once your editing is complete, save your file using the Save command in the File menu. Exit FileView. 
Open another file in the File Info List for editing if you wish. 
On the other hand if you wish to search and replace a specified text in all the files listed in the File Info 
List use the Replace in Files command.

Note. The editing feature is not supported for files greater than 60KB. In this case,
you can only view the context of the line containing the search text in the EditView.

See also
Edit menu 
EditView
LineView



Copying, Moving, Deleting and Zipping Files
You can copy, move or zip selected files in the File Info List by using the Copy or the Move or the Add to 
Zip command in the Find++ window's File menu. 
To delete selected files, select their file infos and select the Delete command in the Find++ window's File
menu or press the Delete key.

See also
File Info List
Copy 
Delete
Move



Finding and Replacing in EditView
EditView  has powerful search and replace commands to help you replace text. Open the Replace 
Dialog box by selecting Replace in the Edit menu in FileView. 
Specify your search text in the Find What box. Here you can choose the case, word, or regular 
expression option. Use the regular expression option to search for different texts which are similar to 
each other(See examples in Regular Expression).
Choose Replace to replace the text in Find What with the text you specify in the Replace With box. 
Choose Replace All to replace the text box throughout the file opened in EditView. 
If you wish to replace the search text in a number of files in the File Info List, select the appropriate 
option in the Files Option group and then select Replace In Files. Check the Confirm File Save 
check-box, if you wish Find++ to ask you to confirm every file save after replacing text throughout that 
file. If you do not check Confirm File Save, Find++ will ask you only once to confirm saving all the files 
after it has completed replacing text in all the files.

See also
File Info List
Editing a file in FileView
EditView



Ordering through Kagi
You can place secure credit card orders with MasterCard, Visa, American Express, or First Virtual 
through Kagi, a shareware payment processing service.
Kagi provides an online registration service on a secure web-site. The Find++ page on their web-site is 
at http://order.kagi.com/?4A. You can also connect to a secure version of the Find++ page at 
http://order.kagi.com/?4A&S. This provides the fastest way to register. You will receive an payment 
acknowledgment y email within 2 days from Kagi.
You can also use the included Register program to send your order to Kagi. This program provides a 
simple and convenient method of ordering by e-mail. You can also use it to print your order form and 
place your order by fax or postal mail. Sensitive information, like credit card numbers, is encoded for 
better security.    Each payer receives a payment acknowledgment by e-mail within 3 days from Kagi. 
Payments    sent via fax take up to 10 days and if you provide a correct    Internet e-mail address you will 
receive an payment acknowledgment by e-mail.
For all payments Kagi sends a copy of your payment acknowledgment by email to the author. The 
author will send you the registration key by email within 2 days of receiving this acknowledgment from 
Kagi.

The author will soon authorize Kagi to send the Registration Key themselves on payment. This will lead 
to even faster processing of your order.

You can contact Kagi for additional information about your method of payment at http://www.kagi.com or 
by email at sales@kagi.com.

Kagi requires the following information: 
Credit Card Method(MasterCard, VISA, AMEX, or First Virtual),
Credit Card Number, Expiration Date, Name On Card, and Billing Address.

If you are paying by postage mail, it is fairly simple. Open the Register program that accompanies Find+
+. Enter your name, your e-mail address, and the number of licenses you desire for each program you 
wish to purchase. Save or Copy(to clipboard) or Print the registration data from the Register program 
and send the data and payment to Kagi.
If you are paying by Credit Card or First Virtual, you can e-mail or fax    the registration data to Kagi. The 
e-mail address is sales@kagi.com and the fax number is (+1) 510 652-6589. You can either Copy the 
registration data from    Register and paste into the body of an e-mail message or you can Save the data
to a file and you can attach that file to an e-mail message. There is no need to compress the data file, 
it's already pretty    small. If you have a fax modem, just Print the data to the Kagi fax    number.
If you are paying with Cash or USD Check you should print the data using the Register application and 
send it to the address shown on the form, which is:

Kagi
1442-A Walnut Street #392-4A
Berkeley, California 94709-1405
USA
The best way to reach Kagi is by fax to (+1) 510 652-6589 or by Internet mail to sales@kagi.com.    You 
can also call Kagi at 1-510-601-5244 between the hours of 10:00 am and 5:00 PM(Pacific Time Zone) 
Monday-Friday.

The author cannot be reached at the numbers above. These numbers are for the Kagi service only. Any 
questions about the status of the shipment of an order, product details, technical support, product 
upgrades, etc., must be directed to the author, Pravin Paul, at:PravinPaul@kagi.com

Or at his postal address:
Suite 220, 101 Queensway West
Mississauga
Ontario, L5B2P7
Canada.



Register Now



Registration of Find++
Find++ is a shareware program and is a copyright of the author Pravin Paul. This copy is for evaluation 
purposes only. You are allowed to evaluate it for a period of 21 days only. If you continue to use it after 
21 days you are required to register it with the author. You are encouraged to pass a copy of Find++ to 
your friends for evaluation. 

You can register it at Kagi, a shareware order taking service. Kagi provides an online registration service
on a secure web-site. The Find++ page on their web-site is at http://order.kagi.com/?4A. You can also 
connect to a secure version of the Find++ page at http://order.kagi.com/?4A&S. Use your Credit Card 
for secure online registration.
Kagi also accepts orders through email or post by Credit Card, Cheque, Cash, First Virtual or Invoice. 
Use the Register program that comes along in your Find++ package to register. Ordering details, like 
credit card numbers, are encoded by the program so you can send your order by email, fax or post.
On receipt of your payment details from Kagi, the author will send you a registration key. Please install 
this registration key to unlock your unregistered version of Find++(See Registration Key Installation for 
details). Once it is installed, your copy of Find++ becomes a registered copy. All options of the 
registered version will be enabled and all nag screens will be absent on restarting Find++. 
Registered users will receive the registration key by e-mail within two days(excluding holidays) of receipt
of registration. Registered users will be informed by email of future upgrades which they can download 
for free. They will also receive support from the author for a period of 90 days from the date of their 
registration. The author is available at PravinPaul@kagi.com.
Please check out at the author's website given below for announcements of new upgrades.

Registered Version
Registered copies cannot be distributed or used by anyone else other than the registered user or 
organization.
A single Personal License entitles you to use one registered copy of Find++ on a single workstation or 
computer. Use of Find++ on multiple workstations or computers requires a license for every workstation 
or computer.
Organizations that wish to use the registered version of    Find++ on a number of workstations or 
computers within their organization should purchase a Site License.    A Site License entitles such an 
organization to purchase a single copy of the registered software to be used by a number of users on 
different workstations or computers within a building. One big advantage of a Site License is that you do 
not need to keep track of how many people at your site are using the software. 
A World-Wide License covers use of Find++ in all locations for your organization worldwide.

Limited warranty and disclaimer of liability:
The author cannot and does not warrant the performance or results that may be obtained by using 
Find++.    Find++ is provided "as is" without warranty of any kind, either expressed or implied, including, 
without limitation, the warranties of merchantability and of fitness for any purpose. In no event will the 
author be liable to users for any damages arising out of the use or inability to use Find++ or any 
modifications thereof, or due to its contents.

Find++ Pricing
Personal License Fee: $16.00 $__________
Site License Fee: $150.00 $__________
World-wide License Fee: $1000.00 $__________
Total: $__________

All payments should be made through Kagi only. Any questions about the status    of an order, product 
details, product upgrades, technical support, etc., must be directed to the author, Pravin Paul, through 
email at:PravinPaul@kagi.com

Or at this postal address:
Suite 220, 101 Queensway West



Mississauga
Ontario, L5B2P7
Canada.

See also
Kagi






