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Getting Started

This tutorial introduction to Sympathy shows how the program can be used to construct different 
types of grids. It is divided into the following main sections:

A. General principles (blocked grid construction)
B. Fully checked grid construction
C. Barred grid construction
D. Exploring Sympathy

All users should work through section A, as this covers Sympathy's main features.

Sections B and C cover specialized features for the construction of fully checked and barred 
grids; users need only work through these sections if they are interested in constructing these 
types of grids.

Section D gives some pointers to users wishing to explore Sympathy's more advanced features.

Before starting the tutorial, run Sympathy by double clicking on the Sympathy icon, and then 
selecting Evaluate Sympathy on the Introduction Screen (only applicable if you are still 
evaluating the program).



A. General Principles (blocked grid construction)

This section illustrates Sympathy's main features by constructing a 9 by 9 blocked grid, with 90 
degree symmetry.

1. Changing the grid size

Sympathy starts with a default grid size of 15 columns by 15 rows (if you cannot see the full grid 
in the window, you may wish to click on the Maximize Icon at the top right hand corner of the 
Sympathy window to enlarge it to fill the whole screen).

We need to create a different-sized grid, so we must change the grid size first. To do this, select 
the New... command from the File menu; this will open the Grid Aspect Ratio dialog box.

Change the number of columns to 9 and the number of rows to 9. You can do this either by using 
the down arrows to the right of the numbers, or by clicking in the entry boxes and changing the 15
to a 9.

The radio button next to the No lights selection of the Start with option should be filled in to 
indicate that the grid will be empty of lights at the start. If this isn't the case, click on No lights to 
select that option.

When the number of columns and the number of rows are both shown as 9, and No lights is 
selected, click on the OK button. The grid should resize to look like this (note that the pictures in 
this tutorial don't show the fine lines between cells):

TIP: the status bar at the bottom of the Sympathy window shows what each menu command 
would do as you select it; to get more help about any Sympathy command, select the menu item and 
press the F1 key just before releasing the mouse button.

TIP: to get help about any Sympathy dialog box, click on the Help button or press the F1 key 
when you are working in the dialog box.

TIP: to change the size of the default grid which Sympathy uses at start up, change to the desired 
number of columns and rows in the Aspect Ratio dialog box and click on Save As Defaults.



2. Changing the symmetry

Sympathy starts with a default of 180 degree symmetry. We need to create a 90 degree 
symmetrical grid, so we next need to change the grid symmetry.

To do this, select the Properties... command from the Grid menu; this will open the Grid 
Properties dialog box. The symmetry can be changed using the combo box to the right of the 
Symmetry: label in the Editing section; select the following icon from the combo box (it's the 
third icon down in the scrolling list):

TIP: because Sympathy supports so many different symmetry modes, the symmetry icons are held 
in a scrolled list: you can use the combo box scroll bar to view the icons above and below the part of
the list currently displayed; alternatively, the up and down arrow keys can be used to select each 
icon in turn when the combo box is highlighted.

TIP: if the box to the left of a property is checked (has a cross or tick in it), the property is 
customized at the level displayed by the dialog box (grid, light or cell); if the box isn't checked, the 
property is not customized and the default setting for the property is shown.

TIP: dialogs without OK and Cancel buttons can be kept open while you continue to work on the
grid in the main window. They can be closed at any time, by clicking on Close or iconized by 
clicking on the Minimize Icon in the top right hand corner of the dialog.



3. Adding Lights

In this step, we will add spaces for words in the grid, technically known as "lights". Because the 
grid has been set to 90 degree symmetry, whenever a light is added, 3 others will be added in the
appropriate places.

Lights are added by "dragging" the mouse: place the pointer in the square at the top left hand 
corner of the grid, then press and hold the left mouse button down, while moving the pointer two 
squares to the right; now release the mouse button.

This should create a space for a three letter across word. Note that 3 other lights are created at 
the same time; also that the grid is numbered by default in the conventional manner. Your grid 
should now look like this:

TIP: to get help about mouse actions in Sympathy, press the F1 key in the main window.
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4. Moving Lights

In this step, we will move the lights along one space.

Lights are moved by dragging them at their long edges: place the pointer over the upper edge of 
the top left hand light (1 across) around the center of its length. The cursor should change to the 
following shape:

now press and hold the left mouse button down, while moving the pointer one square to the right; 
now release the mouse button.

The complete light should have flipped over one square to the right. Note that the 3 symmetrical 
lights will have moved consistently. Your grid should now look like this:



TIP: if you change your mind halfway through a mouse action you can abandon it completely by 
hitting the Esc key.
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5. Resizing lights

In this step, we will resize the lights so that they can fit 4 letter words.

To resize lights, you drag them at their ends: place the pointer over the left end of the top left 
hand light (1 across). The cursor should change to the following shape:

now press and hold the left mouse button down, while moving the pointer one square to the left; 
now release the mouse button.

The left end of the light should have flipped over one square to the left. Note that the 3 
symmetrical lights will have changed consistently. Your grid should now look like this:

TIP: you can also resize an across light at its right end, or a down light at its top or bottom; the 
cursor changes to a special shape to indicate when this is possible.
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6. Selecting lights and entering words

In this step, we will enter words into lights. To do this, the lights must first be selected.

During the previous steps you may have noticed that the light you were changing had a rectangle 
just inside it and a caret cursor in one of the cells. This indicates that it is selected; the caret 
shows where text would appear if you typed in some letters.

You can select a light without moving or resizing it by simply clicking on its edge with the mouse. 
When a light is selected, you can enter text at the cursor by typing the appropriate letters.

Try this out by selecting the light at the bottom right hand corner of the grid (4 across): click over 
the leftmost cell (labeled 4) to position the cursor at the beginning of the light; then type in the 
letters a, t, h, y. Note that the text "flows" into the light from the start as you'd expect. Your grid 
should look like this.

TIP: you can also change which light is selected by using the tab key or the arrow keys with the 
Ctrl key held down.

TIP: when a light is selected, you can use the arrow keys to move the caret cursor: the left and 
right arrows move the cursor in an across light; the up and down arrows move the cursor in a down 
light.

TIP: letters typed in can insert into or overwrite existing text at the cursor depending on the 
overtype mode: in overtype mode, OVR is displayed at the right hand side of the status bar. You can 
use the Ins key to toggle the mode.

TIP: to delete characters, use the backspace, Del or Delete keys: backspace removes characters to
the left of the cursor, whereas Del or Delete remove characters to the right of the cursor.
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7. Changing light orientations

In this step, we will swing a down light round so that it becomes an across light. This is done 
using the same action as resizing (step 5).

Position the cursor over the bottom of the light at the top right hand corner of the grid (2 down). 
The cursor should change to the following shape:

now press and hold the left mouse button down, while moving the pointer three squares to the left
and three squares up. Your grid should look like this:

Note that the text entered into 4 across will have moved along with its light to become the text in 3
down. Like all the light properties, light text is anchored to the light and moves along with it; by 
default, the numbering changes automatically as you adjust the grid.
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8. Selecting cells

In this step, we select an individual square in the grid, technically known as a "cell", and enter text
into a light using a different technique.

During the previous steps, you have been positioning the mouse over the edges of the squares to
select lights. To select a cell, you position the mouse over the center of a square and click the 
mouse button.

Try this by clicking over the center of the top left hand square in the grid. Then type the letter s. 
Press the down arrow and type the letter y; then press the down arrow and press m; finally press 
the down arrow and press p. This is another way of entering text into a light. Your grid should look
like this:

TIP: you can clear the text at a cell using the space bar or the backspace, Del or Delete keys.

TIP: you can enter text anchored to a cell rather than a light by typing in with the Caps Lock key
enabled; this text doesn't move with the lights and is useful for entering characters that aren't 
associated with individual lights, such as messages on diagonals.
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9. Drawing a complete grid

Using all the techniques learnt above, use Sympathy to complete the grid so it looks like this:

Take care to position the mouse in the middle of a cell when dragging out a light in the opposite 
direction to an existing light - if you position the mouse at the edge of the cell you are liable to 
move or resize the existing light, rather than create a new light.

If you make a mistake, you can delete a light (which will also delete any lights symmetrical to it) 
by selecting the light, then using the Delete command on the Light menu (you can use the Del 
key while the Ctrl key is held down as a short-cut).

After any change to a grid, you can use the Undo command on the Edit menu to revert to the 
previous form of the grid. The undo icon on the tool bar can be used to do the same thing.

TIP: to find out the meaning of any icon on the toolbar, move the pointer over it and read the 
description shown in the status bar at the bottom of the Sympathy main window.

TIP: if you have difficulty using the mouse in the above exercise, you may find it easier to work 
with a zoomed in view of the grid: to change the zoom setting, select  the  Properties... command 
from the View menu to open the View Properties dialog box; then click on 150% to get a 
zoomed in view of the grid.

TIP: if you make a complete mess of a grid and want to start again, use the Restart command on 
the Grid menu. Any grid properties that have been customized will still be in effect.
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10. Grid properties

The overall appearance and editing behavior of a grid is determined using grid properties. You 
have already changed one of the Editing properties when you set the Symmetry: property to 90 
degree symmetry.

In this step, we will change the background color of the whole grid by changing one of the 
appearance properties in the Grid Properties dialog. To do this, select the Properties... 
command from the Grid menu; this will open the Grid Properties dialog box.

The background can be changed by clicking on the colored area to the right of the Background: 
label in the Appearance section; select a light gray color from the palette and click on the OK 
button. Note that the box to the left of the Background: label is now checked to indicate that the 
property has been customized for the grid. The grid should now look like this:

TIP: the background color of the grid is one of many properties that can be customized using the 
Grid Properties dialog box: to find out about these other properties, click on the Help button or 
press F1.

TIP: each set of properties can be committed as the default that Sympathy uses by clicking on 
Save As Defaults in the corresponding section. When you do this, the box to the left of any 
changed properties becomes unchecked to indicate that the property is now the default.
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11. Light properties

The appearance of an individual light is determined using light properties; you have already 
indirectly changed the text property of lights when entering text with a light or cell selected. Some 
of the properties that you can set for the whole grid can also be set for a single light, and you'll 
see that property settings for lights override those for the whole grid.

As an example, we will change the background color of a light. To do this, first select light 9 
across, then select the Properties... command from the Light menu; this will open the Light 
Properties dialog box.

The background can be changed by clicking on the colored area to the right of the Background: 
label; select a mid gray color from the palette and click on the OK button. Note that the box to the 
left of the Background: label is now checked to indicate that the property has been customized 
for the light. The grid should now look like this:

TIP: as a short cut, the Light Properties dialog can be opened in one step by double-clicking on 
the edge of a light.

TIP: the background color of a light is one of many properties that can be customized using the 
Light Properties dialog box: to find out about these other properties, click on the Help button or 
press F1.
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12. Cell properties

The appearance of an individual cell is determined using cell properties. Some of the properties 
that you can set for the whole grid and/or for a light can also be set for a single cell, and you'll see
that property settings for cells override those for lights which in turn override those for the whole 
grid.

As an example, we will change the background color of a cell. To do this, first select the cell at the
center of the grid, then select the Properties... command from the Cell menu; this will open the 
Cell Properties dialog box.

The background can be changed by clicking on the colored area to the right of the Background: 
label; select the white color from the palette and click on the OK button. Note that the box to the 
left of the Background: label is now checked to indicate that the property has been customized 
for the cell. The grid should now look like this:

TIP: as a short cut, the Cell Properties dialog can be opened in one step by double-clicking in 
the center of a cell.

TIP: the background color of a cell is one of many properties that can be customized using the 
Cell Properties dialog box: to find out about these other properties, click on the Help button or 
press F1.
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13. Cutting, copying and pasting properties

Customized properties can be cut or copied from selected lights and cells and then pasted 
elsewhere. This is useful for cloning a particular customized appearance; it is also a way in which 
the text for a light can be copied to and from other Windows applications, since the text in a light 
or cell is just another property.

We'll first use copy and paste to duplicate the customized properties for a cell into another cell: 
select the cell at the center of grid which should still have the different color customized for it in 
the previous step; now use the Copy command on the Edit menu to copy the customized cell 
properties to the clipboard.

The customized properties can now be pasted where they are desired: hit the left arrow key once 
to select the cell to the left of the one at the center of the grid; then use the Paste command on 
the Edit menu to paste the customized properties into the cell. Now hit the right arrow key twice 
to select the cell to the right of the one at the center of the grid; then use the Paste command on 
the Edit menu to paste the same customized properties into that cell. Your grid should now look 
like this:

We'll now use cut and paste to remove customized properties from a cell and then add them to a 
light: select the cell at the center of grid which should still have a different color customized for it; 
now use the Cut command on the Edit menu to move the customized cell properties to the 
clipboard. The cell should now have the same color as was customized for light 9 across.

The customized properties in the clipboard can now be pasted where they are desired: select 
light 7 down, then use the Paste command on the Edit menu to paste the customized properties 
into it. Your grid should now look like this.

This illustrates what happens when crossing lights have conflicting properties: we've seen that 
cell properties override light properties, which in turn override grid properties. When customized 
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light properties differ, the convention is that the property in the across light takes precedence 
(conflicting text or number properties for crossing lights are also shown in reverse video).



14. Filling a light using Word Search

Sympathy includes a word search function that allows you to find words that match a particular 
pattern. This feature can be used to fill the grid a light at a time.

Try this out now by selecting light 16 across and selecting the Word Search... command from the
Filling menu: the Word Search dialog opens and automatically sets the pattern to one that will 
find all the words that fit the selected light, in this case ...Y.

Click on the Start button to start the search. A progress bar indicates that a search is running: 
when this is completely filled in, you should see ably at or near the top of the list. Select this entry
in the list, then click on the Commit button: this will copy the word you have chosen into the light:

You can fill part of all of a grid using this feature.

TIP: the One-shot Fill command on the Light menu is an alternative way of filling the grid a 
light at a time.

TIP: if you have a supported third party dictionary installed on your computer and want to check 
the meaning of any word in the list produced by a word search,  select the entry with the word you 
are interested in and click on the Lookup button (you can use Enter with Ctrl held down as a 
short-cut).

TIP: the Word Search function is a powerful general purpose word matching tool: you can specify 
patterns to find anagrams as well as words matching a template. To find out about what patterns are 
possible, click on the Help button or press F1.
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15. Filling a grid automatically

Sympathy incorporates a powerful robot filler which will enter words from a dictionary to complete 
a grid for you.

Try this out now by selecting the Normal Fill command from the Filling menu. In a few seconds, 
this will have completed the grid. Note that words are fitted correctly around the light text you 
entered.

The results of the filling process are shown in the Fill In Progress dialog. Click on the OK button 
to dismiss it.

Sympathy allows you to preview the filled grid before you "commit" the automatically filled words; 
the uncommitted words are shown in a different color. Commit the text now by selecting the 
Commit Fill command on the Filling menu; the automatically filled words are now part of the 
grid, just as if you had entered it yourself. Your grid should look something like this (the actual 
words used may be different):

You don't have to take any special action to avoid duplicate words in the grid: Sympathy's 
automatic filler ensures that it doesn't reuse any words that have already been placed into the 
grid (either by you, or by Sympathy itself).

TIP: if you want to throw away (rather than commit) all the words that Sympathy has filled, you 
can do this by selecting the Undo Fill command on the Filling menu.

TIP: if you don't like a word that Sympathy has used, you can stop it being used again in the grid 
by adding it to the "kill list": to do this, select the light with the word you want to kill, then select the
Kill Word command from the Light menu (you can use K with Ctrl held down as a short-cut).

TIP: if you have a supported third party dictionary installed on your computer and want to check 
the meaning of any word in the grid,  select the light with the word you are interested in, then select 
the Lookup command from the Edit menu (you can use Enter with Ctrl held down as a short-
cut).
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16. Filling a grid interactively

Sympathy has an interactive filling mode that allows you to take a more active part in the filling 
process. This is particularly useful for constructing relatively unconstrained grids, such as blocked
grids, where a good choice of words is regarded as more important.

Since the grid was completely filled in the previous step and the text committed, we need to clear 
all the existing text before a new fill can be started. Do this now by selecting the Clear All 
command on the Light menu. Your grid should look like this:

To start a fill in interactive mode, select the Properties... command from the Filling menu; this 
will open the Filling Properties dialog box. The filling mode can be changed using the combo 
box to the right of the Start Mode: label: select the Manual setting.

You can now try out interactive mode by selecting the Normal Fill command from the Filling 
menu. In a few seconds, you will be presented with a list of words that could fill the light selected 
in the grid and shown to the right of the Light: label; select a word you like, then click on the Next
button to advance to the next light. Do this until the grid is completely filled.

If you select a word that is later found to be impossible to fill around, Sympathy will backtrack and
invite you to select different words until it is able to complete a fill. You can also manually 
backtrack using the Back button.

When the fill has completed, click on the OK button to dismiss the Fill In Progress dialog, then 
commit the text by selecting the Commit Fill command on the Filling menu.

TIP: if you have a supported third party dictionary installed on your computer and want to check 
the meaning of any word listed during automatic filling,  select the word you are interested in, then 
click on the Lookup button (you can use Enter with Ctrl held down as a short-cut).

TIP: if you don't like a word that Sympathy displays in the Fill In Progress dialog, you can stop
it being shown again by adding it to the "kill list": to do this, select the word you want to kill, then 
click on the Kill button. This will also stop the word being used in automatic filling.

TIP: even if you normally use automatic filling, it can be useful to drop into interactive mode 
temporarily if you believe Sympathy has made a bad choice of word and is getting "stuck" as a 
result: interrupt the fill, then backtrack to the level where the bad choice was made, then select a 
different word and use Continue rather than Next.

TIP: several more features are available during interactive filling: to find out about these, click on 
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the Help button or press F1 when filling is interrupted.

TIP: many more parameters affecting filling can be changed using the Filling Properties dialog 
box: to find out about these other properties, click on the Help button or press F1.



17. Printing a grid

This step shows how you can print out the completed grid.

To print out the grid, select the Print... command on the File menu. The Print Grid dialog box will 
open. Here you can select parameters that will affect the way the grid is printed. In particular, you 
can decide whether to print out the blank grid (without answers for the solver), or the solution grid 
(with answers), or both, using the Print check boxes in the Blank Grid and Solution Grid areas.

For now, just leave the options as their defaults and click on Print... to print out the solution grid. 
The standard Windows Print dialog box will open, allowing you change further printer options if 
you wish; click on OK to print the grid.

TIP: parameters affecting the size of the grid, and the size and position of all the elements within 
it, can be changed using the Grid Dimensions dialog box: to open this, select the Dimensions... 
command from the Grid menu.

TIP: the Grid Alignment, Grid Offset X and Grid Offset Y parameters determine the position 
of the grid on the page; these default to the settings for the grid shown in the Grid Dimensions 
dialog box: they can be overridden in the Print Grid dialog box for a single print-out.



18. Including a grid in another document

This step shows how you can include the grid as part of a bigger document, typically the title, 
clues and so on, that make up your complete puzzle. Before doing this, you will need to open a 
document in your word processing or desktop publishing software.

To include a grid in the target document, select the Export... command on the File menu within 
Sympathy. The Export dialog box will open. Here you can select parameters that will affect the 
way the grid is exported.

For now, export the grid as a Picture to the Clipboard (if this is the first time you have used 
the Export dialog box, these will be the default options). When you press OK, the grid will be 
copied to the clipboard in Windows Metafile (.WMF) format.

Now select the target document in the word processor or desktop publisher and paste in the grid; 
most programs will include a Paste command on their Edit menu for this. Because the grid is in 
picture format, it can be scaled up or down satisfactorily in the target document.

Note that the grid will look slightly different to how it appears in Sympathy because it will be 
scaled to map onto the display (Sympathy knows that the grid is a regular structure and does its 
own scaling to make the grid look nice). Despite this, the printed grid should look the same as it 
does when printed from Sympathy.



19. Including a set of answers in another document

This step shows how you can include the set of words filled in by Sympathy as part of a bigger 
document. This gives you a template for a set of clues.

To include the answers, you go through the same actions as in the previous step, but this time, 
export the grid as a List of answers.



B. Fully Checked Grid Construction

This section illustrates the extra options for constructing fully checked puzzles by creating an 8 by
8 grid with 180 degree symmetry.

1. Changing the grid size

We first need to change the grid size. To do this, select the New... command from the File menu; 
this will open the Aspect Ratio dialog box.

Change the number of columns to 8 and the number of rows to 8. You can do this either by using 
the up and down arrows to the right of the numbers, or by clicking in the entry boxes and 
changing the number displayed to 8.

Now choose the All lights selection of the Start with option, since we will construct the grid by 
adding blocks to a grid initially containing all lights (if All lights is already selected nothing more 
need be done).

When the number of columns and the number of rows are both shown as 8, and All lights is 
selected, click on the OK button. The grid should resize to look like this:

TIP: if you mainly construct fully checked grids, you will probably want to start with All lights 
as the default: Sympathy will do this if you select All lights then click on Save As Defaults.
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2. Selecting 100% checking mode and 180 degree symmetry

Sympathy has two checking modes: Unconstrained mode is the least restrictive, allowing 
anything to be done; but 100% is more convenient for creating fully checked grids, since fewer 
key presses and mouse actions are needed.

To change to 100% mode, select the Properties... command from the Grid menu; this will open 
the Grid Properties dialog box. The mode can be changed using the combo box to the right of 
the Checking Mode: label in the Editing section; select the 100% option (in some distributions 
100% mode may already be the default).

Also ensure that 180 degree symmetry is selected. The symmetry can be changed using the 
combo box to the right of the Symmetry: label in the Editing section; make sure the following 
icon is selected in the combo box (it's the second icon down in the scrolling list):

TIP: if you mainly construct fully checked grids, you will probably want to use 100% Checking 
Mode as the default: Sympathy will do this if you select 100% then click on Save As Defaults in
the Editing section. 



3. Adding Blocks

In this step, we will add blocks to the grid to define the boundaries of the lights.

Blocks are added by selecting the desired cell and using the Cell Block command: place the 
pointer in the center of the fourth cell from the left on the top row (labeled 4) and click the left 
mouse button to select the cell; then hit the return key or the Enter key by the numeric keypad to 
create a block (this is actually just a short-cut for the Block command on the Cell menu).

This should add a block. Note that one other block is created at the same time to preserve the 
180 degree symmetry; also that the grid is automatically renumbered. Your grid should now look 
like this:

Now hit the down arrow key to select the cell below (labeled 9) and hit return or Enter again. 
Repeat this to create a column of three blocks. Your grid should now look like this:
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4. Removing Blocks

In this step, we will remove a block added in the previous step, turning the cell back into one used
by lights.

First ensure the cell containing the last block added in the previous step (4 columns along, 3 rows
down) is still selected. Then hit the return key or the Enter key again to remove the block (the 
Block command on the Cell menu acts as a toggle). 

This should convert the cell back into a light cell. Note that a block can only created in this way in 
100% Checking Mode, since your intention is otherwise ambiguous (in Unconstrained 
Checking Mode, the mouse is used to extend lights). Your grid should now look like this:

Now hit the right arrow key and hit return or Enter. Your grid should look like this:
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5. Changing lights with the mouse

In this step, a light will be resized using the mouse. In 100% Checking Mode, lights can still be 
changed with the mouse, but the result may be different to that in Unconstrained Checking 
Mode, since Sympathy ensures that the grid stays fully checked.

To create the desired grid, we need to resize a light, and this is done by dragging it from one end: 
place the pointer over the left end of the light in the fifth row down (15 across). The cursor should 
change to the following shape:

now press and hold the left mouse button down, while moving the pointer two squares to the 
right; now release the mouse button.

The left end of the light should have flipped over two squares to the right. Note that the 
symmetrical light will have moved consistently and that down lights will have been cut in two so 
that the grid stays fully checked. Your grid should now look like this:
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6. Filling the grid

In this step, thematic lights will be added and the grid filled in automatic mode.

First select the light marked as 10 across and enter s y m p; then select the light marked as 20 
across and enter a t h y. Your grid should look like this:

Now fill the grid by selecting the Normal Fill command from the Filling menu. In a few seconds, 
the fill should have completed and the grid should look something like this:
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C. Barred Grid Construction

This section illustrates how to construct barred puzzles by creating a 9 by 7 asymmetric grid.

1. Changing the grid size

We first need to change the grid size. To do this, select the New... command from the File menu; 
this will open the Aspect Ratio dialog box.

Change the number of columns to 9 and the number of rows to 7. You can do this either by using 
the up and down arrows to the right of the numbers, or by clicking in the entry boxes and 
changing the number displayed to what it needs to be.

Now ensure the No lights selection of the Start with option is enabled, since we will create the 
grid by adding lights to an empty grid (if No lights is already selected nothing more need be 
done).

When the number of columns is shown as 9 and the number of rows as 7, and No lights is 
selected, click on the OK button. The grid should resize to look like this:

TIP: if you mainly construct barred grids, you will probably want to start with No lights as the 
default: Sympathy will do this if you select No lights then click on Save As Defaults.



2. Selecting unconstrained checking mode and no symmetry

Sympathy has two checking modes: 100% and Unconstrained. Barred grids can only be 
constructed in Unconstrained mode.

To change to Unconstrained mode, select the Properties... command from the Grid menu; this 
will open the Grid Properties dialog box. The mode can be changed using the combo box to the 
right of the Checking Mode: label in the Editing section; select the Unconstrained option (in 
some distributions Unconstrained mode may already be the default).

Also ensure that the "no symmetry" icon is selected. The symmetry can be changed using the 
combo box to the right of the Symmetry: label in the Editing section; select the topmost icon in 
the scrolling list, which looks like this:

TIP: if you mainly construct blocked or barred grids, you will probably want to use 
Unconstrained checking mode as the default: Sympathy will do this if you select 
Unconstrained then click on Save As Defaults in the Editing section. 



3. Adding lights

Barred grids are constructed in much the same way as blocked grids, except that the lights are 
butted up to each other (not separated by blocks). Sympathy automatically places bars to delimit 
the lights in barred grids.

We will first add the across lights from top to bottom. Start with 1 across: place the pointer in the 
square at the top left hand corner of the grid, then press and hold the left mouse button down, 
while moving the pointer to the right hand side of the grid; now release the mouse button. The 
grid should look like this:

Now add the two lights on the second row: drag from the leftmost cell of the second row to the 
fifth cell along on the second row and release the mouse button; then drag from the sixth cell 
along on the second row to the right hand side of the grid and release the mouse button. The grid
should look like this:

Note that a vertical bar is automatically added to separate the two lights on the second row; also, 
bars have been added between the light on the top row and the lights on the second row - most 
of these will disappear when the down lights are added.
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Now use the same technique to add more across lights to create the following pattern:

Finally add in the down lights to complete the grid:

TIP: if you construct lots of barred grids, you will probably find it helpful to activate the 
Ximenean unch model. To do this, select  the  Unch Model... command from the Grid menu to 
open the Unch Model dialog box; then click on Ximenean barred and OK. By default, 
overunched lights will marked with a red arrow, and underunched lights with a blue arrow (these 
colors can be changed using the View Properties dialog box).
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4. Filling a grid

In this step, a thematic light will be added and the grid filled.

First select the light marked as 18 across and enter s y m p a t h y. Your grid should look like 
this:

Now fill the grid by selecting the Normal Fill command from the Filling menu. In a few seconds, 
the fill should have completed and the grid should look something like this:
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D. Exploring Sympathy

The above tutorial only describes the most commonly used features of the program. To illustrate 
the power and flexibility of the program, a set of example grids are included with the release:

checked.sym a simple fully checked US style grid
blocked.sym a simple 15x15 blocked grid
jumbo.sym a simple 27x27 blocked grid
barred.sym a simple 12x12 barred grid

shapes.sym a fully checked grid with a non-orthogonal shape
colors.sym a fully checked grid demonstrating light and cell colors
text.sym a barred grid demonstrating light and cell text
numbers.sym a barred grid demonstrating light and cell numbers
reverse.sym a barred grid with reverse sense lights
fonts.sym a barred grid demonstrating light and cell fonts

Open these files to discover some of the effects you can achieve with Sympathy. Most of these 
are set up by changing the properties of the grid, lights and cells: viewing these properties, in 
conjunction with the on-line help, will show you how they are achieved.


