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1 Introduction

Thank you for your interest in Composer Notes. We recommend you print this 14 page document using your
favorite word processor.  This will make it easier for you to follow the tutorial.

The Composer Notes  Demo Version documentation consists of this printed Short  Tutorial  and the context-
sensitive on-line help file. The purpose of the printed manual is to get you started using Composer Notes. We
recommend that you first follow the tutorial in this manual. The full version of  Composer Notes includes a very
comprehensive manual. The table of contents for the Composer Notes manual is enclosed in the Appendix.

If you need help on a certain feature, please use the on-line help. To call the main index of the on-line help file,
press F1. To access the help topic related to your mouse location, press CTRL F1. The on-line help has been
linked to Composer Notes, of course, by using Composer Notes instead of the standard methods.

1.1 Instruction Conventions

Fundamental Composer Notes concepts, such as menu items, commands and titles are printed in bold.

Sentences and paragraphs that begin with a number [1.] instruct you to take certain actions.

When you are instructed to select, choose or click on a menu item or button, you should point to it and click
once with the left mouse button. 

When you are asked to highlight a menu item, click on it once using the mouse or select it using the arrow keys.

When you are instructed to highlight a word or phrase, place the mouse cursor on the first character while
holding down the left mouse button, drag the cursor to the end of the desired text and release the mouse button.
The text will appear inverted on a dark background.

1.2 Contacting UDI Software

If you would like to buy the full version of Composer Notes for only US $129, or if you have any comments
concerning Composer Notes, please let us know. You can contact us at 800-289-1948, or if outside U.S. 415-
382-8840.  You  can  also  send  us  email  on  CompuServe  at  74674,30,  or  via  Internet  at
74674.30@compuserve.com.

Since Composer Notes is a development tool that is highly dependent on the programs it is used with, we can
only  help  you  with  problems  associated  directly  with  the  functionality  of  Composer  Notes.  If  you  have
problems  capturing  certain  Windows  objects,  you  should  experiment  with  the  options  available  to  find  a
solution that works well for you. 

We have not limited the access to the object capturing options, even though it may cause problems in some
applications. If you can capture objects but experience problems when testing or running your application, it
usually means that some key component that is used to identify different objects in Composer Notes is changing
constantly and cannot be recognized reliably. In this case you should trace back your steps and remove the link
that is causing problems, or replace it with a link to some other object instead.

1.3 Trademarks

WYSI-Help,  WYSI-Help  Composer,  Composer  Notes  and  Surveillance  Engine  are  trademarks  of  UDI
Software.  MS-DOS  is  a  registered  trademark  of  Microsoft  Corporation;  Word,  Excel  and  Windows  are
trademarks of Microsoft Corporation. 1-2-3 is a registered trademark of Lotus Corporation. WordPerfect is a
registered trademark of WordPerfect Corporation. Paradox is a trademark of Borland International. All other
trademarks are copyright of their respective owners.
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2 Quick Overview of Composer Notes’ Features

Composer  Notes is  the  new  Windows  interface  and  helpfile  “glutility”  for  Windows®  users.  Without
programming or the need for source code, Composer Notes allows you to stick custom messages and help topics
to any element in one or more Windows applications. Composer Notes, an easy to use, point & click, cross
application development  tool  becomes your “SuiteStick” and  turns  your standard  application software into
company specific customized application suites. 

Link any Windows object to help instantly!

· Point & click capture of most Windows objects without programming or needing source code.

· Windows objects include menus, individual menu items, dialog boxes, buttons in dialog boxes and editable
fields—offering a comprehensive scope of message attachment.

· Capturing objects is easy and only requires a single mouse click.

· Object ID display changes color for easy recognition of captured objects.

· Choose what message the object is linked to—a title bar message, bubble help or help topics. Linked help
topics can contain anything available to the standard Windows help engine, WinHelp, including hotspots,
program launches, buttons, etc.

· Create links for the captured objects immediately upon capture, or later.

· Composer Notes conveniently lists which objects are captured and which have already been linked to a
help topic, bubble help or title bar message.

· Capture objects from any number of applications and vendors for true cross-application personalized online
procedures.

Comprehensive  Editing features

· Customize background color and text styles within title bar messages and bubble help for easy recognition
of your personalized help application.

· Customize the timing for title bar message and bubble help display.

· Define separate key combinations for context-sensitive help, title bar messages, bubble help, and display of
your  custom help  index.  Your  customized  help  file  can  be  complementary  to  the  target  application’s
context-sensitive help, or replace it.

· Link to help topics created with any Help Authoring Tool

· Automatic launch and edit function for help topics created with WYSI-Help Composer.

· Create  your  online  messages  in  one  file  and  customize  their  display  to  the  level  of  your  user.  Turn
individual object links on or off for novice or advanced users.

· Group link multiple objects to a single help topic, title bar or bubble help message—ensuring the same
message appears for related objects.

· Create and benefit from cross-application procedures in a matter of minutes. 
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Context-sensitive help

· Glue company specific information to any number of Windows applications.

· Attach context-sensitive information without programming or need for the application' s source code.

· Put your company procedures online and attach them in context to your Windows application suite.

· Option to supersede the original help file or offer the user both the original and custom help files.

· Provide Short Help messages quickly without the user having to access the help engine.

Composer Notes Applications/Benefits:

· Write context-sensitive helpfiles for any Windows application without programming or source code!

· Capture objects from any number of applications for true cross-application personalized online procedures.

· Write additional help and instructions that ease challenging applications using bubble help.

· Create bubble help in foreign languages, and stick it to your applications for your multilingual office needs.

· Save time training office temps and new employees! Create an online routine for basic office functions  in
less time that it takes to train an employee!

· Eliminate the use of “stickies” around your screen with your online messages.

Composer Notes Surveillance Engine

After the objects are captured and linked, the Composer Notes application can be run on any computer with a
small runtime surveillance component. This Surveillance engine monitors mouse movements and help requests
for the user. It then launches the appropriate action you (or someone else in your organization) defined when the
captured object comes into “focus.”
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3 CREATING  YOUR  FIRST  COMPOSER  NOTES
APPLICATION

This chapter  is  a  tutorial  consisting of  step-by-step instructions for  creating a very basic Composer Notes
application.

Creating Context-sensitive help involves linking a Short Help message and a help topic to an object in the target
application. The first step is to select the target application to which you want to attach the help to. After you
have selected the right target application, you need to identify the individual objects to which you want to link
help. For this practice session, choose any Windows based word processing application. The examples here will
use Windows Write, but you may use any word processor if you want to.

Tasks to be accomplished are as follows:

· Opening Composer Notes and preparing to create a Composer Notes application

· Loading an application

· Capturing an object

· Defining a link

· Editing a Short Help message

· Testing the link

3.1 Opening Composer Notes and preparing to create a Composer Notes
application

1. Start Composer Notes by double-clicking its icon in the Composer Notes 2.1 group window.
Once Composer Notes loads, the main window opens.

Composer Notes uses the extension  .SRV for its files. When Composer Notes is launched, it  automatically
opens the most recent .SRV file used. If your main window looks a little different from the one shown in Figure
3.1, it may be that someone has already created a file with this copy of Composer Notes. Sometimes people
capture objects and create links and then save the file with the default name UNTITLED.SRV. For this reason, it
is good to make sure you are creating a new file by selecting the New command from the File menu. Figure 3.1
shows what a new, untitled Composer Notes file looks like.
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Figure 3.1 A new, untitled file

2. Select New from the File menu. Composer Notes will open a new file named UNTITLED.SRV.

For this tutorial, you want Composer Notes’ Preferences set to their default settings. To make sure that the
Preferences are set properly, take a look at them.

3. Select Preferences from the Edit menu. The Preferences dialog box opens (Figure 3.2).

4. A preference is on when there is an X in the box in front of it. Click on the box to turn preferences on and
off. Make sure the preferences are set as shown. In particular, make sure that  Immediate Definition and
Automatic Launch are on. Immediate Definition allows you to define a link for an object immediately
upon capture of  the object.  Automatic Launch causes  Composer Notes to load applications you select
automatically.

Figure 3.2 The Preferences dialog box

You are now ready to load an application.

3.2 Loading an application

To create context-sensitive help for an application both Composer Notes and the selected application must be
running. You may load the selected application from within Composer Notes.

1. Choose Applications to Load from the Define Menu. The Applications to Load dialog box opens (Figure
3.3).

Figure 3.3 The Applications to Load dialog box
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2. Click the Browse button. You will see the standard Windows Browse dialog box.

3. Browse through your files until you find the file name for your favorite Windows based word processor.
(The illustrations for this tutorial use Windows Write, but you may choose any word processor that runs in
Windows.) If you use Windows Write, you can usually find it in the WINDOWS directory. The file to look
for is WRITE.EXE. Select the file name, and click OK.

4. In the  Applications to Load dialog box, click on the  Add button to add the selected application to the
Applications list (Figure 3.4).

Figure 3.4 Designating an application to load

Click on the OK button. The Applications to Load dialog box will close. Composer Notes will load the word
processor you selected.
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Once you have added an application to the Applications to Load list, Composer Notes will automatically load
that  application  every  time  your  Composer  Notes  file  is  opened,  provided  that  the  Automatic  Launch
preference is on. You may enter multiple applications using  Applications to Load and Composer Notes will
load them all. This allows you to create cross-application context-sensitive help files.

3.3 Capturing an object

Now that your selected word processor has loaded, note the presence of the Control  window. The Control
window is a bar shaped window attached to the top or bottom of your application. The Control window tells you
what object  the mouse is pointing to,  and whether it  is  captured and linked. The name “Composer Notes”
appears in the Control window in red. The rest of the text in the Control window is blue.

Figure 3.5 The Control window

1. Activate your target application by clicking anywhere in its window. Use the Windows Task List if it is
hidden by the Composer Notes window by clicking ALT TAB until you find the right application.

2. Point to the File menu in your word processor’s window. Click the right mouse button once. A new hand
shaped pointer will appear. You may have to wait a moment for the pointer to change shape.

* If  the  right  mouse  button has  a  special  function within the application from which you are  capturing
objects, you may, instead, capture an object by pointing to it and pressing the  Pause key. The  Capture
objects: use Pause key preference must be on. Use the Preferences command on the Edit menu to toggle
this preference on and off.

3. Move the pointer over the menu names. Note that the menus open, and the text in the Control window
changes, depending upon what object the pointer is resting on.

4. Move the pointer back to the File menu. The menu will open. Point to the New command. This is the object
you will capture.

5. Click the right mouse (or press the Pause key) button again. The text in the Control window will turn
yellow., and the Link Object(s) dialog box will open.

You may now define a link for the New command and create a Short Help message to go with the link.

3.4 Defining a link

The  Link Object(s) dialog box will display a suggested link name in the  Destination Link Name edit box
(Figure 3.6). The suggested link name is the title of the object. In this case, the title of the New command is
“New,” so New appears in the Destination Link Name edit box. You may keep this link name or change it. For
this tutorial, you should keep New as the link name.
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Figure 3.6 The Link Object(s) dialog box with a suggested link name

To simply define the link, you could go ahead and close the dialog box and the link would be defined. Do not do
this now! You are going to link a Short Help message to the link. 

If you clicked on OK by accident, just go back to your target application and capture another object, such as the
Open command. You will then be able to follow the tutorial easily by linking the help to another command
instead of the New command. 

3.5 Editing a Short Help message

1. Click the  Edit Short Help>> button in the  Link Object(s) dialog box. The  Link Object(s) dialog box
closes and the Short Help Text Editor opens (Figure 3.7).

2. In the top left edit box the link name New appears. This is the link for which you will create a Short Help
message. The edit box on the top right has a blinking cursor. Enter the text “Opens a new, untitled file.” in
the top right field.
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Figure 3.7 The Short Help Text Editor

3. Click the Add/Modify button. The link name is moved to the Link Name list, and the Short Help message
text is moved to the Short Help Text list.

4. Before completing the link, you want to turn the Short help display on. The default setting for Short help
display is unchecked, so your Short Help message will not be displayed until you turn this setting on. To do
this, make sure that an X appears in the small box next to the words Short help display in the bottom left
of the Short Help Text Editor. If not, click in the box. Short help display is now on (Figure 3.8)

Figure 3.8 Turning on Short help display

5. Click the Done button to complete the link. If you click only on Done, without clicking on Add/Modify
button, the Short Help text does not get updated.

You will now create another link, for practice. 

6. Click on the word processor window to activate it.

7. Point to the  File menu and click the right mouse button (or press the Pause key) once. The hand shaped
pointer appears.

8. If the File menu does not open automatically, move the pointer to the right and back onto File. Point to the
Open command. Click the right mouse button (or press the Pause key) once to capture it.

The suggested link name will be Open. You may change it if you wish, but it is typically easier to keep track of
the captured objects if you use the same names as for the menu commands.

9. Click the Edit Short Help>> button to open the Short Help Text Editor.

10. In the top right edit box, enter “Allows you to open an existing file.”  Figure 3.9 shows what the Short Help
Text Editor should look like at this point.

11. Click the Add/Modify button to keep your Short Help text. The link name is moved to the Link Name list,
and the Short Help message text is moved to the Short Help Text list.

Figure 3.9 Editing Short Help in the Short Help Text Editor
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12. Click on the Done button.

You may now capture and create Short Help messages for other objects.

3.6 Testing the link

After you have finished capturing objects and linking them to Short Help, you can test your new Composer
Notes application to see the Short Help messages. If you had also created Topic Help, you could test your links
to Topic Help and see the Help Window open and display the relevant topic. In this tutorial you defined Short
Help only, so no Topic Help will display.

You can test your help file from within Composer Notes by putting Composer Notes into  Test mode. This
feature allows you to test your context-sensitive help as you develop it.

From the Surveillance Menu, choose Test Mode or click on the test button on the toolbar.

 
When you exit  Edit mode, by switching to Test mode, Composer Notes automatically saves your file if you
made any changes to it. In this case, the Save As... dialog box appears because you are working on a new file. 

1. In the  Save As  dialog box, set the directory to save your Composer Notes file in to the  TUTORIAL
directory  that  is  inside  the  main Composer  Notes  directory  (probably  CNOTES).  Enter  the  file  name
LESSON1 and click OK to save your file.

* If you do not specify a directory in which to save your Composer Notes application, Composer Notes will
save your file into the directory containing the most recent application you designated to load.

Since  you  have  switched  to Test  mode,  Composer  Notes  automatically  switches  to  the  word  processor
application once your Composer Notes file is saved. Note that the Control window now only displays the title
Composer Notes in red. This is to let you know that Composer Notes is in Test mode. The Control Window
will not appear in your final Composer Notes application.
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2. Pull down the  File menu and position your mouse cursor on the  New command  without selecting the

command. Do not click your left mouse button. Wait a moment and look for the Short Help message to
appear.  It  will  either  appear in a  bubble next  to  the pointer  or  in the title  bar  of  the word processor,
depending upon the Display setting that was selected in the Short Help Text Editor.

It takes a moment for Short Help messages to appear because they are purposely set to appear after a delay. This
way the messages only appear when the user pauses a moment to wait for a help message. Later on in this
manual you will see how to change the delay setting. You will also learn how to change the colors and fonts
used to display Short Help, and how to switch between bubble display and title bar display.

3. Move the pointer onto the Open command and see the Short Help message appear.

4. Move the pointer over any other menu items that you captured and linked to a Short Help message.

After you have finished testing all of your links it is necessary to switch from Test mode back to Edit mode to
be able to modify your Composer Notes file.

5. Switch back to the Composer Notes window. (Use the Windows Task List if necessary). 

6. To disable Test mode, choose Test Mode from the Surveillance menu, click on the end test icon, or click
once on the Control window.

This completes the creation of your first help file.

7. Exit Composer Notes by selecting Exit from the File menu.
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