
A..Z
Once you've selected the topics you wish to print, use the A..Z button to sort the topic in 
alphabetical order. 



About
The About box provides you with information regarding the WYSI-Help Composer. Information 
such as version number, serial number and the name of the licensee.



Add/Modify button
Click on this button to add the new tab setting to the list. Enter a new tab setting in the 
Tabulation/Position edit field to the left of this button.



Add topics button
Add Topic(s) to the list of topics to print.



Adding footnotes to a topic, Topic Preferences

This command lets you add footnote type commands to a topic. Footnote type statements define 
topic specific information such as the topic build tags, and alternative search keywords lists as 
well as topic macros. Other footnote type information such as topic titles and context strings that 
are defined else where in the WYSI-Help Composer are not accessible from the Preferences 
menu Item.    

Procedure

1. Select the topic whose footnotes you wish to modify.

2. Select the Properties command from the Topic menu, (ALT, T, P).

3. You may now modify the footnotes list of the topic, clicking the OK button    to save the 
changes made, or the Cancel button to ignore them.

When this dialog box is first opened the cursor will be positioned in an editing region where you 
may create new footnotes or modify existing ones. Each footnote must be preceded by a special 
character and a space.

Build tag statement *
Alternative keyword list Any letter other than K

Note
Certain rules exist regarding the format of topic footnotes, besides the conventions used for the 
special characters as described above. In particular, the help compiler requires that build tag 
footnote statements be the first footnote to be entered. For further information regarding the use 
of this feature you should refer to the Microsoft Windows SDK manual.

Related Topics

Working directly with the help project file
Inserting topic macros



Project editor command

The WYSI-Help Composer allows you to work directly with the Project editor. In Interactive mode,
the Project Editor allows you to easily set the Contents topic for your help file, add secondary 
windows, size and color main and secondary windows, change the level of compression for the 
compiled help file, and designate an error log file. You may also change the appearance of the 
icon which displays on the Windows desktop when the help file is minimized.    In File mode the 
Project Editor gives you direct access to the help project file(.HPJ file).

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Selecting a contents topic
Selecting a help icon
Setting the help window title
Defining window properties
Selecting an error log file
Defining the warning level
Compressing the hypertext file
Adding footnotes to a topic
Inserting file macros



Inserting topic macros

Macros may be inserted at topic level. This means that the macros will be executed when their 
associated topic is opened. Two methods of inserting topic macros exist. The first one and 
probably the easiest option, is the Macro Editor. The other method is to create macros and    insert
them as footnote statements.    The later method should be attempted only by experience help 
authors.

Procedure 1

1. To insert a macro into a hypertext file at the topic level, you must first make sure that the 
topic to be modified is the current one displayed.

2. Select the Topic macros command from the Topic menu, (ALT, T, T).

3. You may now modify the current definition as you wish, clicking on the OK button when you 
have finished to save the changes, or clicking on Cancel to ignore them.

Click in the picture below to learn more about a command or an element of the dialog box.

The information bar, situated at the bottom of the dialog box, contains information concerning the 
cursor position within the current definition entry field. Error messages will also be displayed in 
this bar if the current definition becomes invalid, for instance if you type an illegal value for a 
parameter. The error message will also include a position reference to the position of the error in 
the current definition.



Note
Certain help macros, in particular those which remain active until the hypertext file is closed, are 
unsuitable for use as topic macros. In this case, when a topic is first viewed the macro will be 
executed properly, but then if the user changes to view another topic and then returns to the first 
topic, WinHelp will try to execute the same macro again. However, this will not be possible and so
an error message will be displayed. Such macros to avoid using as topic macros include those 
which add buttons to the button bar, or menu items to the menus in the WinHelp window.

Related Topics

Using Help macros
Inserting file macros
Creating a macro link



Aligning a paragraph

The WYSI-Help Composer allows you to align paragraphs as you wish. You may use the ruler to 
do this or the Paragraph menu item.    The settings of the ruler are reflected in the dialog box 
invoked by the menu option.

Procedure 1

1. Placing the cursor in a particular paragraph will result in only that paragraph being modified. 
To change several paragraphs at once you should highlight the ones you wish to modify.

2. By clicking on the lower button situated on the left hand side of the ruler, you may change the
alignment for the paragraphs selected.

3. Three possible alignments exist: left aligned, centered, and right aligned. These are arranged in 
sequence so that clicking on the button again will change the alignment to the next type in the sequence. 

For example, when the selected paragraphs have right alignment (the last in the sequence 
left, centered, right), clicking on the button once more will change the alignment to left, (the 
first one in the sequence left, centered, right).

Procedure 2

You may also change the paragraph alignment by selecting the Paragraph command from the 
Format menu and changing the value in the dialog box which opens. This will affect only the 
paragraphs selected, as for the first method. See Defining the format of a paragraph.

Related Topics

Showing or hiding the ruler
Using the ruler
Defining page margins
Indenting the first line of a paragraph
Defining tabulations
Creating a non-wrapping line
Defining the format of a paragraph
Using return characters to format paragraphs



Showing or hiding the ruler

Using the ruler is one way of defining the format of paragraphs in your topics. It is situated just 
below the toolbar, and like the toolbar, it resizes itself as you resize the WYSI-Help Composer 
window. You choose not to display the ruler so as to maximize the space for editing the contents 
of your topics. The method for doing this is described now.

Procedure

1. Select the Display command from the Preferences menu.

2. To remove the ruler, simply remove the check mark from the box labeled Show ruler. Placing 
a check mark in this box will ensure that the ruler is displayed.    The short cut keys ALT+U 
can be used to remove or place a check mark in this check box.

3. Confirm the change you have made by clicking on OK.

Related Topics

Using the ruler
Preferences menu
Display preferences
Defining the format of a paragraph



Using the ruler

If the option Show ruler has been selected in the Display Preferences dialog box, the ruler will be 
displayed just below the toolbar.

The ruler contains several buttons and markers which may be used to perform the formatting 
functions available in the dialog box opened by selecting the Paragraph command from the 
Format menu.

The top triangle marker, , represents the starting position of the first line in the current paragraph.

The bottom triangle marker, , represents the starting position for the rest of the lines in the current
paragraph.

The triangle situated on the right hand side of the ruler, , represents the right margin.

The position of tab stops is also shown by markers on the ruler:

The marker used to represent the tab stop may take three forms, as shown above, to represent the type of 
alignment associated with it. In the example above, text typed after the first tab stop will be right aligned, text 
typed after the middle tab stop will be centered, and the last tab stop has left alignment. See Defining 
tabulations for more information on this feature.

The ruler also contains two buttons on the left hand side which perform paragraph formatting 
operations.

The top button may be used to transform the current paragraph, i.e. the one in which the cursor is
currently positioned, into a single, non-wrapping line.The lower button may be used to change the
alignment of the current paragraph. Clicking on this button will cause the alignment to run through
the order: left aligned, centered, right aligned.

Procedure

1. Select the paragraph whose format you wish to modify.

2. Perform the modification you require by dragging the markers,  , clicking on one of 
the buttons,

 , or by defining or modifying some tab stops.

Note
You may hide the ruler from the WYSI-Help Composer window to maximize the editing region 
available to you. In this case, you will have to use the menu option to format your paragraphs.

Related Topics

Showing or hiding the ruler
Defining page margins
Indenting the first line of a paragraph
Aligning a paragraph



Defining tabulations
Creating a non-wrapping line
Defining the format of a paragraph
Using return characters to format paragraphs



Defining page margins

Since the window that a help topic is displayed can be any size,    page margins are measured 
from the edge of the windows.    The ruler allows you to quickly and easily modify the page 
margins.

On the left side of the ruler the top triangle marker, , represents the starting position of the first 
line in the current paragraph. The bottom triangle marker,

, represents the starting position for the rest of the lines in the current paragraph. Collectively, these two 
triangular markers represent the left margin.

The triangle situated on the right hand side of the ruler, , represents the right margin.

Procedure 1

1. Placing the cursor in a particular paragraph will result in any modifications being applied to 
that paragraph only. To change several paragraphs at once you should highlight the ones 
that you wish to modify.

2. To change the position of the left margin, drag the two triangle markers on the left hand side 
of the ruler, , to a new position, one at a time. It is not possible to drag both at the same 
time. A guide wire will appear from the marker that you are moving down to the bottom of the 
editing region to help you obtain the position that you require.

3. To change the position of the right margin, simply drag the right margin marker,  , to a new position 
on the ruler. The paragraphs selected will instantly change according to the modification made. A guide wire will
also appear for this marker.

Procedure 2

You may also change the size of the page margins by selecting the option Paragraph from the 
Format menu and changing their values in the dialog box which opens. This will affect only the 
paragraphs selected, as for the first method. See Defining the format of a paragraph.

Note
The position of the left margin cannot be less than zero. No limit exists for the position of the right 
margin.

Related Topics

Showing or hiding the ruler
Using the ruler
Indenting the first line of a paragraph
Aligning a paragraph
Defining tabulations
Creating a non-wrapping line



Defining the format of a paragraph
Using return characters to format paragraphs



Indenting the first line of a paragraph

The ruler allows you to indent the first line of a paragraph.

Collectively, the triangular markers on the left hand side of the ruler represent the left margin. 
However, the top marker alone represents the position of the first line in a paragraph, while the 
lower one represents the position of the following lines in the paragraph.

Procedure 1

1. Placing the cursor in a particular paragraph will result in only the indentation of its first line 
being altered. To change several paragraphs at once you should highlight the ones you wish 
to modify.

2. By dragging the top triangular marker, , on the left side of the ruler you can change the 
indentation of the first line for the paragraphs selected. A guide wire will appear from the 
triangular marker down to the bottom of the editing region to help you position the marker as 
you like. The paragraphs selected will change according to the modification made.

Procedure 2

You may also change the indentation of the first line by selecting the option Paragraph from the 
Format menu and changing the value in the dialog box which opens. This will affect only the 
paragraphs selected, as for the first method. See Defining the format of a paragraph.

Related Topics

Showing or hiding the ruler
Using the ruler
Defining page margins
Aligning a paragraph
Defining tabulations
Creating a non-wrapping line
Defining the format of a paragraph
Using return characters to format paragraphs



Defining tabulations

Tab markers are defined either using the menu command (Format - Paragraphs), or the ruler.    
The parameters for a tab marker are its position and its alignment.

Procedure 1

1. Position the cursor in the paragraph for which you wish to modify the tab stops. If you wish to
change the tab stops for several paragraphs at once, then you can do this by selecting the 
paragraphs you want to change.

2. Position the mouse on the black line, the tab stop definition line, on the ruler at the position 
where you want to place the tab stop. The cursor will change its form to a cross.

3. Pressing the left mouse button will cause a tab stop marker to appear on the ruler at the position you 
chose. By default, every new tab stop created will have left alignment.

4. To change the alignment of the tab stop, position the cursor over the bottom half of the tab stop. The 
cursor will change its form to a hand pointer. Pressing the left mouse button will change the alignment of the 
tab stop from left to centered. Clicking once more will change it to right aligned. Clicking again will make the tab
stop left aligned.

A left aligned tab stop.

A center aligned tab stop.

A right aligned tab stop.

5. To move an existing tab stop, position the cursor over the top half of the tab stop so that the 
cursor becomes two opposing arrows. You may now drag the tab stop to a new position. A 
guide wire will be drawn from the tab stop to the bottom of the editing region to help you 
position it.

6. You can remove a tab stop by holding down the left mouse button when the mouse cursor is 
positioned over the top half of a tab stop, then drag the cursor vertically away from the ruler.

Procedure 2

You may also define tab stops by selecting the Paragraph command from the Format menu. 
This will affect only the paragraphs selected, as for the first method. See Defining the format of a 
paragraph.



Related Topics

Showing or hiding the ruler
Using the ruler
Defining page margins
Indenting the first line of a paragraph
Aligning a paragraph
Creating a non-wrapping line
Defining the format of a paragraph
Using return characters to format paragraphs



Creating a non-wrapping line

You may wish to transform a paragraph into a single, non-wrapping line. This could be useful if 
you are including a particularly long command in one of your topics. The wrapping which normally
occurs for a paragraph may make the command less clear to read for the user. In this case, the 
user may use the horizontal scroll bar to view the entire line.

Two methods exist for transforming a paragraph into a non-wrapping line. You may either use a 
menu option, or the ruler to perform this operation.

Procedure 1

1. If the cursor is in a paragraph, only this single paragraph will be modified. To change several 
paragraphs at once you should highlight the ones that you want to modify.

2. Click on the top button situated on the left    side of the ruler.

3. The paragraph(s) selected will be transformed into single, non-wrapping lines.

4. To transform a non-wrapping line back into a wrapping paragraph, simply perform the steps above 
again.

Procedure 2

You may also change a paragraph into a non-wrapping line by selecting the Paragraph 
command from the Format menu. This will affect only the paragraphs selected, as for the first 
method. See Defining the format of a paragraph.

Related Topics

Showing or hiding the ruler
Using the ruler
Defining page margins
Indenting the first line of a paragraph
Aligning a paragraph
Defining tabulations
Defining the format of a paragraph
Using return characters to format paragraphs



Defining the format of a paragraph

Good presentation of the text in your topics will improve the readability and effectiveness of your 
hypertext file. You may change the format of the current paragraph by selecting Paragraph 
from the Format menu. The formatting options available include margins, indentation of the first
line, alignment of the text and    position and alignment of the tab stops.

Procedure

1. To format a single paragraph, position the cursor somewhere within this paragraph. To 
format several paragraphs at once, use the mouse to select those paragraphs you wish to 
modify.

2. Select the Paragraph command from the Format menu.

3. You may now modify the format of the paragraph(s) selected by changing the values and 
options contained in the Paragraph Format dialog box.

4. When you have finished, clicking on the OK button will confirm the changes that you have 
made and apply the style to the selected paragraph.

Click in the picture below to learn about a command or an element of the dialog box.

Related Topics

Showing or hiding the ruler
Using the ruler
Defining page margins
Indenting the first line of a paragraph
Aligning a paragraph
Defining tabulations
Creating a non-wrapping line
Using return characters to format paragraphs



Using return characters to format paragraphs

By using the Copy and Paste commands, you may give one paragraph the attributes of a different
paragraph. This feature saves considerable time when defining the format of a paragraph.

To perform this operation, the option Show paragraph markers must be turned on. You will 
find this in the Display Options dialog box when you select the Display command from the 
Preferences menu.

Procedure

1. Select the return character,  , preceding the paragraph whose properties you wish to copy.

2. Select the Copy command from the Edit menu, (ALT, E, C, or CTRL+C) or click the Copy      
button on the toolbar.

3. Select the return character,  , preceding the paragraph whose properties you wish to replace.

4. Select the Paste command from the Edit menu, (ALT, E, P, or CTRL+V) or click the Paste     
button on the toolbar.

5. The paragraph following the return character    you just selected will now have the format of 
the first paragraph.

Related Topics

Showing or hiding the ruler
Using the ruler
Defining page margins
Indenting the first line of a paragraph
Aligning a paragraph
Defining tabulations
Creating a non-wrapping line
Defining the format of a paragraph
Copying a block
Pasting the contents of the clipboard



Aligning an image

After inserting an image, it may require some adjustments in order to align it and to let you enter 
text beside it. The default setting is Floating and as you notice in the sample below, the line height
for the text is increased to that of the image.

Procedure

1. Select the image that you wish to modify by double clicking on it. When the image is selected
it appears in reverse video.

2. Select the Image command from the Format menu.

3. Make the changes you require, then click on the OK button to confirm them.

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Inserting a BMP image file
Inserting an image from the clipboard
Inserting a snapshot image



Changing the format of an image
Inserting a line break



Inserting an Image

The use of images in your hypertext files will greatly improve their effectiveness. The WYSI-Help 
Composer lets you insert images in the .BMP format.

Procedure

1. Position the cursor where you wish to insert the image.

2. Select the Image command from the Insert menu. The browse dialog box will    appear 
allowing you to search through your directories to find the image you want.

3. Select the file containing the image that you wish to insert.

4. Click on the OK button to confirm your choice and insert the image into the topic.

5. The Image will appear at the cursor position.

Note:
The image will be treated as though it were a single character. Only one line of text may be 
written to the side of an image since the line that it has been inserted on will increase its height to
that of the image. To write several lines of text down the length of an image, its alignment must 
be changed, (see Aligning an image).

Related Topics

Inserting an image from the clipboard
Inserting a snapshot image
Aligning an image
Changing the format of an image
Inserting a line break



Inserting an image from the clipboard

You may use the clipboard to cut and paste images from the clip board into your help file.    Since 
the Windows Help engine supports only 16 color bitmaps, all other color resolution bitmaps are 
converted to 16 colors by the WYSI-Help Composer.

To avoid inserting large blank areas around an image, as may be the case when inserting a BMP 
image file, you may use the clipboard to store just the part of an image that you require.

Procedure

1. Using a graphics application (i.e. Windows Paintbrush) or select the Edit Image command

from the Edit    menu (ALT+E, I), or click the Graphic Editor  button on the toolbar. Load
the file containing the image that you want to insert.

2. Define the part of the image that interests you and place it in the clipboard.

3. Return to the WYSI-Help Composer and position the cursor where you want to insert the image.

4. Paste the contents of the clipboard, either by selecting the Paste command from the Edit menu, by 

using the short cut key CTRL+V, or by clicking on the Paste  button on the toolbar.

Note
The image will be treated as though it were a single character. Only one line of text may be 
written to the side of an image since the line that it has been inserted on will increase its height to 
that of the image. To write several lines of text down the length of an image its alignment must be 
changed, (see Aligning an image).

WYSI-Help Composer will store the graphic information for the images you've inserted from the 
clipboard in files such as DUMP01.BMP, DUMP02.BMP, DUMP03.BMP and so on. These DUMP 
files will be created in the WYSI-Help Composer directory during saving. Avoid using this type of 
file names for graphics that are referenced. The wrong image may appear in a topic if you do.

Related Topics

Inserting a BMP image file
Inserting a snapshot image
Aligning an image
Changing the format of an image
Inserting a line break



Inserting a snapshot image

If your hypertext file is being used as a help file, for example to explain the use of a piece of 
software, then it may be useful to obtain and insert screen captures into your topics of the target 
application.    Screen captures are also a simple way to insert graphics.    The WYSI-Help 
Composer provides an integrated facility to do screen captures.

Procedure

1. Position the cursor at the point in your topic where you wish to insert the screen capture.

2. Select the Screen photo command from the Insert menu, (ALT, I, S).

3. The Screen Photo dialog will appear while the WYSI-Help Composer remains in background.

4. Change to the application from which you want to take a screen capture.

5. If necessary, open the menu or the window that you wish to capture.

6. Clicking on the Start button, or clicking on the right mouse button will make the mouse cursor change
its form to a hand symbol. A broken rectangle will surround the current window. To capture a menu which has 
been opened you will have to move and resize this rectangle.

7. To resize the zone that you wish to capture, position the mouse cursor over the handles on the sides of
the rectangle, and drag the handles to produce the size of rectangle that you require. The edges of the 
rectangle are included in the photo.

8. To move the rectangle to a new position, simply hold down the left mouse button while the mouse 
cursor is inside it, and then move the mouse to position it as you desire.

9. Double clicking inside the defined zone using the right mouse button will capture it and return you to 
the WYSI-Help Composer. The screen capture that you have taken will be inserted into the current topic at the 
last position of the cursor, before you selected the Screen photo option.

Note
If you select the wrong menu or window, you can deselect it by moving the mouse cursor outside 
of the selected region and clicking again on the left mouse button.

To cancel the screen photo operation, press the Esc key or click on the Cancel button inside the
Screen Photo dialog box. Since two stages exist in the capture process, pressing Esc when you 
have a defined region will first restore the Screen Photo dialog box. It will be necessary to press 
the Esc key once more to cancel the capture operation and return to the WYSI-Help Composer.



The images captured using the screen photo utility are not placed on the clipboard. Hence any 
important information which is stored there before you do a screen capture will still be stored 
there after you have completed the screen photo operation.

Related Topics

Inserting a BMP image file
Inserting an image from the clipboard
Aligning an image
Changing the format of an image
Inserting a line break



Changing the format of an image

Three types of images may exist in your topics. The first type are internal images. These are 
stored with the rest of the contents of the topics in .DHF files. Typically, internal images are those 
which are inserted from the clipboard into topics, or those captured using the screen photo utility.

The second type of image are reference images. This type of image is stored in a separate .BMP 
file.

The third type of image are hypergraphic images. These are images which have sensitive zones 
defined within them. Hot Spots are linked to topics or macro commands. Thus, when the 
hypertext file is being used, these sensitive zones act in just the same way as linked regions of 
text. This type of image is also stored externally, in separate .SHG files.

Procedure

1. Select the image whose format you wish to change.

2. Select the Image command from the Format menu, (ALT, O, I).

3. In the Image Format dialog box, change the format of the image to the one you desire. 
Remember to supply a path and filename for referenced or hypergraphic images.

4. Confirm your changes by clicking on the OK button.

Click in the picture below to learn more about a command or an element of the dialog box.

Note: To select a right or left formatted image, select the alignment marker, not the bitmap itself.

Related Topics

Inserting a BMP image file
Inserting an image from the clipboard
Inserting a snapshot image
Inserting a hypergraphic image



Editing a hypergraphic image



Inserting a line break

Even when an image has been left or right aligned, it is only possible to write one paragraph to 
the side of the image. The next paragraph will begin on the first line below the image.    To have 
the text appear next to the graphic, use line breaks instead of starting a new paragraph. A special 
character exists to represent a line break, and this is shown below.

The line break character: 

However, this character will only be displayed if the appropriate display option is turned on, (see Display 
Preferences).

Procedure

1. Type the text that you wish to enter around the image.

2. To begin a new paragraph, select the Line break command from the Insert menu, or use
the short cut key Shift+Return.

3. A line break will be inserted. You may continue to type text which will appear around the 
aligned image.

Example

Related Topics

Inserting a BMP image file
Inserting an image from the clipboard
Inserting a snapshot image
Inserting a hypergraphic image
Aligning an image
Changing the format of an image
Display preferences



Windows controls

The Windows interface uses basic conventions in the behavior of an application. The information 
below outlines the basic features of a window.

Application Control-Menu

Double click the top left corner of the window to access the Application Control-menu. When the Application 
Control-menu appears, items that are dimmed are not available for that action with the current settings. For 
example, you cannot maximize a window that is already maximized.



Apply Button
Replace the style of the selected text with the style indicated in the dialog box.



Applying a text style

A text style is a collection of formatting information that can be used to modify certain text through 
out the document only by modifying its style.

Applying a text style before you type any text sets the style for the newly typed text. You may also 
highlight a block of text, and apply an existing text style to this region.

Procedure

1. Highlight the block of text to which you wish to apply a different style, or simply position the 
cursor where you wish to begin typing new text.

2. Select the Apply style command from the Format menu, (ALT, O, Y), or click on the 

Styles  button on the toolbar. The Apply style dialog box will open.

3. Select a style from the list. You can see exactly the effects of the style that you are choosing due to the
WYSIWYG nature of WYSI-Help Composer.

4. Clicking on the Apply button will apply the chosen style to the block selected.

Click in the picture below to learn more about a command or an element of the dialog box.

Note
Defining a short cut key for styles that you use regularly will save you a significant amount of time 
in applying those styles to blocks of text. Instead of performing steps 2 to 4, simply pressing the 
short cut keys will apply a particular style (see. Assigning a short cut key).

Related Topics

Defining the attributes of a region of text
Defining a text style
Default text styles
Modifying a style
Assigning a short cut key



Defining the attributes for a selected block of text or a text 
style

Use this command to change the attributes of the selected text. As in a word processor, you can 
change the attributes of the text in your topics, (font, size, effects, colors).

Procedure

1. Select the text you wish to change.

2. Select the Attributes command from the Format menu.

3. In the Attributes dialog box, select the font, size, style and color you wish to use.

4. Click on the OK button to confirm your selection and apply these attributes to the selected 
text.

Click in the picture below to learn more about a command or an element of the dialog box.

The first set of attributes used in the selected block will be used as a starting point for the 
modifications that you wish to make.

The box labeled Sample shows an example of the attributes chosen.

Related Topics

Composing a topic
Defining a text style
Applying a text style
Default text styles
Modifying a style



Defining a text style

To maintain uniformity in the presentation of the topics that you develop, and also to work more 
efficiently, the WYSI-Help Composer lets you define styles which define the appearance of text 
(its font, size, color and effects).

Defining a text style:

1. Select the Define Style command from the Format menu or click the Style  button 
on the toolbar.

2. Click the define button in the Define Style dialog and the Font dialog will appear.

3. Select from the Font dialog box, font, attribute, font size and color. Once all the elements are selected, 
click the OK button. The new style is then created.

Note:
The text styles you create are listed by the font and attributes you've selected. For example, the 
sample below displays two styles. The first one uses a 14 point bold font in blue with underline. 
The second style uses a 12 point bold font only.

Note:
The WYSI-Help Composer will not allow you to define a style with the same attributes as one 
already created. Trying to do this will display a warning message:

You may define a maximum of 1024 styles.

A default style always exists which has the attributes Arial, Normal, 10. If you type text in a new 
file without having defined a style to use, then this style will be used. It is possible to modify this 
default style if you wish, however, the changes you make will have no effect on the existing text. 
Only the new text you enter will take on the effect the changes.

Related Topics

Defining the attributes of a region of text
Applying a text style
Default text styles
Modifying a style



Default text styles

To ensure the presentation of the topics you create is consistent with one another, and to allow 
you to work more efficiently, you may specify styles to be used by default.

The WYSI-Help Composer allows you to specify a style to be used for the first paragraph in a new
topic, and another style for the paragraphs thereafter. Thus, you may choose a style to be used 
for the titles of your topics, and another one for the text following these titles.

Specifying the styles to use is performed quickly and easily by selecting one from a list of existing 
styles.

Procedure

1. Select the Default style command from the Format menu.

2. In the Default style dialog box, select the style you wish to use for the first paragraph by 
selecting one from the list.

3. Select the Next style you wish to use for the following paragraphs in the same way. 

4. Confirm your selection by clicking on the OK button.

Note
These styles will only be applied to new topics. You should not expect to be able to position the 
cursor in the middle of an existing topic and use a default style that you have just defined.

Changing the initial or next style will not affect existing topics containing text written using 
previous default styles. All new topics though, will make use of the new default styles, as you 
would expect.

Related Topics

Defining a text style
Applying a text style
Modifying a style
Defining the attributes of a region of text



Modifying a style

If, during the development of your hypertext files, you decide to change a particular style of text 
used, the WYSI-Help Composer allows you to modify any of the styles that you have defined. It 
will then automatically apply these changes to all of the text using that particular style. This 
feature ensures that no text is missed out when you want to change the look of your file, and it is 
particularly beneficial for large files which would otherwise require a lot of time to change by 
hand.

Procedure

1. Select the Modify style command from the Format menu.

Note :
If a block is selected, the style of the selected text is automatically selected in the Modify style 
dialog.

2. In the Modify Style dialog select the style you wish to modify and click the Modify button. 
Clicking on the Modify button will cause the Font dialog box to appear.

4. The attributes of the style you selected will be shown in this dialog box. You may modify 
these as you wish and then click on the OK button to confirm your changes.

5. The Style dialog box will be restored and an example of the style that you modified will be 
shown in the box marked Style. If you wish to make further changes, click on the Modify 
button once more to reopen the Font dialog box. It is not possible to define a new style at 
this point, since you chose earlier to modify an existing style. Hence the Define button will 
be dimmed. Clicking on the OK button will confirm the changes that you have made and 
apply them to all the text which uses the style you have modified. Clicking on Cancel will 
cancel the operation and restore the WYSI-Help Composer main window.

Click on the picture below for a description of each element of the dialog box.

If you modify a style to give it the same attributes as an existing style, the WYSI-Help Composer 
will display a dialog box, asking you if you wish to merge the two styles together.

Answering Yes will merge the two styles together, while answering No will create the new style, 
even though it has the attributes of an existing one. There will be two identical styles. Clicking on 
Cancel will close this dialog box and restore the Style dialog box.

Related Topics

Defining a text style



Applying a text style
Defining the attributes of a region of text



Ask for Confirmation
Enabling this options prompts you with a dialog box before making a replacement.    Disabling this 
option executes the replacement without pausing.    



Ask for confirmation
Check this box to display a confirmation box for each reference expression found in the search. 
The topic containing the matching expression will also be displayed, and the expression found 
will be highlighted.

In the dialog box, clicking on the Delete button will result in the found link being deleted, and the
search continuing. Click on the Next button to skip this link and continue the search. Click on 
the Cancel button to stop the deleting process. Check the Cancel confirmation box to 
continue the deleting process automatically without confirmation.



Ask for confirmation
Check this box to display a confirmation box each time a matching expression is found. You may 
then choose whether to replace the occurrence found, or to skip to the next one.



Assigning short cut keys to text styles

You can define a short cut to assign a frequent style to a block of text. The Ctrl key, coupled with 
another assigned key will automatically apply the style to the selected text. You can only assign a
short cut to a style in the Define Style dialog box. 

Assigning a short cut key to a style:

1. Choose the Define style command from the Format menu.

2. In the Define Style dialog box, choose the text style for which you wish to assign a short 
cut key.

3. Place the cursor in the short cut key box and type the character you wish to use. Only alpha 
characters are allowed (A...Z).

4. Press the Define button and click the OK button in the Font dialog box.

Note
You cannot use the following character as they are already assigned to other WYSI-Help 
Composer commands: V, C, X, Z,

Related Topics

Applying style
Defining a style
Modifying a style



Bounding box display
You may wish to make the sensitive regions in a hypergraphic image more obvious to the user by 
drawing a single pixel black border around them. To do so, the parameter Visible should be 
selected for this option. The parameter Invisible will result in no border being drawn.



Bounding box size
This box contains the data which defines the size of the zone, in a similar way as left and right 
margins are defined. Adjusting these values will allow you to define exactly the size and position 
of the rectangle you want.



Context string/macro
Enter the name of the target topic of the link here. In the case where you define a region as a 
macro link, you should enter a macro command and its parameters.



Hotspot ID
The Hotspot Editor assigns a unique value to identify each region, and this is displayed here.



Type
From this pull down menu you may select the type of link to create, either Jump (hypertext), Pop-
up or Macro.



Choose hypertext style
Opens the Font dialog box, allowing you to define the style to be used for hypertext links.



Composing a topic

Composing a topic is done according to the usual Windows editing conventions.

You may define the attributes of text, (font, effects and colors), and store them as styles. A ruler 
allows you to define the position of margins and tab stops.

The topics you define may contain various kinds of links, (hypertext, pop-up, external program, 
macro or sound), which you can associate with regions of text, images, or even particular regions 
in an image, (hypergraphic images).

The WYSI-Help Composer also allows you to insert images, either from .BMP files or by using the
clipboard, while hypergraphic images may be created by launching a program called the Hotspot 
Editor included with this product.

Finally, the WYSI-Help Composer is totally WYSIWYG, (meaning What You See Is What You 
Get),    allowing you to see the topics you are developing just as the final user will.

Ways to access Topics

1. To edit a particular topic, double-click on its name in any of the three topic lists, (Comes from 
list, the topics list, or the Goes to list). The content of the selected topic will be displayed in 
the editing region of the screen.

2. Clicking on the Previous topic  or Next topic 

 buttons displayed below the lists, will also result in the contents of that topic 
being displayed in the editing region.

3. You may display a particular topic for editing by using the Jump to link option contained in the
Link menu. This will display the contents of the target topic of the link which was selected.

4. When you create a new topic, clicking on the Edit button will allow you to edit its contents 
straight away.

Related Topics

Defining the attributes of a region of text
Defining a text style
Creating a hypertext link
Creating a pop-up link
Choosing a hypertext style
Choosing a pop-up style
Inserting a BMP image file
Inserting an image from the clipboard
Aligning an image
Changing the format of an image
Using the ruler



Choose
Opens the Font dialog box, allowing you to define a new style to be used for pop-up links.



Generating links automatically

Automatic link generation is an extremely powerful feature of the WYSI-Help Composer. It 
facilitates the linking of topics by automatically create hypertext links from    expressions to a 
topic.

With the function turned on, the WYSI-Help Composer utilizes a list containing three fields of 
information:

1.    Reference expression
2.    Target topic
3.    Link type

Each time that you type a word or phrase that matches a reference expression, the WYSI-Help 
Composer automatically transforms it into a link towards a defined target topic.

If you modify a paragraph of text, the WYSI-Help Composer examines the paragraph to see if a 
reference expression has been produced. If this is the case, it will be transformed into a link. 
Equally, if an existing link, generated automatically, has become modified so that it no longer 
corresponds to a listed reference expression, then the WYSI-Help Composer will remove it.

Procedure

1. To turn on the automatic link generation function, select the Automatic generation 
command, from the Link menu.

2. The WYSI-Help Composer main window will now be restored and the automatic link 
generation function will be turned on. You may verify this by opening the Link menu once 
more, where a check mark will appear next to the option Automatic generation.

3. To turn off the automatic link generation function is simply a case of selecting the menu 
option once more so that the check mark disappears.

Related Topics

Saving a reference expression
Editing the list of reference expressions
Regenerating links automatically
Deleting links automatically



Saving a reference expression

WYSI-Help Composer can only perform automatic link operations if it has a list of reference 
expressions (i.e. expressions to transform into links), their target topic and their link type. The 
Edit automatic links option allows you to modify this list, but new reference expressions can also 
be added to the list when you create a topic or when you create a link by hand.

Procedure 1

1. Select the New topic command    from the Topic menu, (ALT, T, N). A dialog box like the 
one below will be displayed.

2. Normally you will proceed to enter a name for the topic to be created. Note however the 
option Add reference expression situated at the bottom of the dialog box. To add a 
reference expression to the list, check this box.

Click in the picture below to learn more about a command or an element of the dialog box.

Procedure 2

1. Select a region of text in a topic.

2. Choose either the Hypertext or Pop-up commands from the Link menu. A dialog box 
such as the one below will be displayed.

3. Normally you would select a target topic from the list and confirm the creation of a link by 
clicking on the OK button. Note however the box named Automatic link situated at the 
bottom of this dialog box. Check this box to add the link name to the list of reference 
expressions.

Click in the picture below to learn more about a command or an element of the dialog box.



Related Topics

Generating links automatically
Editing the list of reference expressions
Regenerating links automatically
Deleting links automatically



Editing the list of reference expressions

When you start a new hypertext file, each topic created will have at most one reference 
expression associated with it. However, it will almost certainly be necessary to modify the list of 
reference expressions associated with a topic if you wish to make the most of the automatic link 
generation function. Some topics might need more than one reference expression as they do with
keywords and some topics do not need any reference expression.

Procedure

1. Ensure the topic whose list of reference expressions you wish to modify is the current topic.

2. Select the Reference expressions command from the Link menu.

3. To add a new link, type the new reference expression in the Text entry field, and select the 
type of link to be created by clicking on one of the radio buttons. Click on the Add button to 
add the expression to the list.

4. To delete a link, select a reference expression from the list and click on the Delete button. 
The link will then be removed from the list.

5. To modify an existing link, select it using the mouse and click on the Delete button to 
remove it from the list. It will however remain in the Text entry field. You may now carry out 
the modifications required before putting the link back in the list using the Add button.

Related Topics

Generating links automatically
Saving a reference expression
Regenerating links automatically
Deleting links automatically



Regenerating links automatically

WYSI-Help Composer's ability to generate links in real time as you type text is an extremely 
useful function, which will save both time and effort as you build hypertext files. WYSI-Help 
Composer also has the ability to scan an entire file and transform certain text strings into links. 
This will be particularly useful in the following situations:

- you wish to add a new reference expression, and scan the file to transform matching text 
into links.

- you have copied large amounts of text using the clipboard, and wish to generate links where 
appropriate.

- you have been using files produced with an old version of WYSI-Help and wish to check the 
links they contain.

Procedure

1. Select the Regenerate links command from the Link menu.

2. Select the reference expressions to regenerate.

3. Click on the OK button to commence the regeneration process.

Click in the picture below to learn more about a command or an element of the dialog box.

A dialog box will appear when the regeneration process has finished.

Clicking on the OK button will then return you to the WYSI-Help Composer main window.

Note



The regeneration process may take some time for a large number of topics or for a long list of 
reference expressions. You can reduce the time required for this process by carefully selecting 
only those reference expressions which need to be regenerated.

Related Topics

Generating links automatically
Saving a reference expression
Editing the list of reference expressions
Deleting links automatically



Deleting links automatically

If you want to delete hypertext or pop-up links in a particular file it is possible to do this 
automatically. The automatic link deletion option will only delete links that have originally been 
created automatically. It will not delete links created manually.

Procedure

1. Select the Delete certain links command from the Link menu.

2. Choose the links to be deleted from the Links list.

3. By default the confirmation option is turned on, but you may turn it off if you wish.

4. Start the operation by clicking on the OK button.

Click in the picture below to learn more about a command or an element of the dialog box.

An information box will appear when the deleting process is completed to inform you that the links
have been deleted.

Clicking on the OK button will restore the main window of WYSI-Help Composer.

Related Topics

Generating links automatically
Saving a reference expression
Editing the list of reference expressions
Regenerating links automatically



Automatic save
Check this box to activate the automatic save option. This feature saves your changes to 
the .DHF and .HPJ files every 5 minutes. If a power interruption occurs during editing, a backup 
can be generated when opening WYSI-Help Composer the next time. The backup will contain all 
the changes you have made to the hypertext file at the last automatic save.



Browse sequence
A browse sequence allows you to group related topics together. When a user selects a topic from 
the browse sequence, all other related topics included in the browse sequence can be accessed 
from the displayed list.





Cancel button
Click the Cancel button to cancel the command selected in this dialog box and to return to 
WYSI-Help Composer.



Changing a topic title

A topic may be identified by three things: its context-id, its link name or its title.

The context-id is a unique number assigned by WYSI-Help Composer to each topic created. 
Generally it is not used by you, although it can be used to identify topics in another file when you 
are creating extended links.

The link name of a topic is the name you give to the topic when you create it. This is hidden from 
the final user. It is this type of identifier that appears in the Goes to and Comes from lists etc.    
The link name is also the Context String.

The title of a topic is the identifier which is visible to the final user. It may be displayed in two 
situations:

- in the History list which is maintained by the help engine,

- in the list of topics associated to a search keyword.

A title should be unique and descriptive to a particular topic.

Procedure

1. Ensure that the topic whose title you wish to change is the current one.

2. Select the Title/search keywords command from the Topic menu.

3. You may enter a new topic title in the edit field under the title Type a topic title.

4. Clicking on OK will confirm the changes you have made and restore the WYSI-Help 
Composer main window.

Note
By default, when a topic is created, its title will be the same as its link name.

Related Topics

Selecting a contents topic
Modifying the list of search keywords
Creating an extended link



Selecting a contents topic

When the user access the help file, in the absence of a contents topic, the first topic which was 
created is displayed. Defining a contents topic will ensure that a particular topic is displayed. 

Clicking on the Contents  button in the button bar of the help window will also display 
the contents topic that you have defined.

Procedure

1. Select the Project editor command from the File menu

2. Open the menu labelled Contents topic by clicking on the pull-down button.

3. Select the topic that you wish to define as the contents topic.

4. Click on the OK button to confirm your selection.

Related Topics

Changing a topic title
Modifying the list of search keywords



Modifying search keywords

In order to allow the final user greater flexibility in accessing the topics in your hypertext files, a 
list of search keywords may be defined for each topic. 
WinHelp supports this feature through the use of the Search command. When used, the final 
user may type a word or phrase, or select one from the list provided. Doing this will display 
another list, this time containing topic titles which are associated to the phrase, or rather, search 
keyword, entered. The user may then select one of these topics to be displayed.

Procedure

1. Make the topic you wish to modify the current one.

2. Select the Title/search keywords command from the Topic menu, (ALT, R, T).

3. To add a Search keyword, type a phrase in the edit field below the Search keywords label 
and click the Add button.

4. To delete a Search keyword, select a Search keyword from the list and click the Delete 
button.

5. To modify a Search keyword, double click on a Search keyword in the list.    Make the 
changes you wish in the edit field above the list and click the Add button.    Now delete the 
previous Search keyword.

6. Click the OK button when you have finished to save the changes you have made.

Click in the picture below to learn more about a command or an element of the dialog.

Note
A particular search keyword does not have to be unique. It may be associated to more than one 
topic.



Related Topics

Selecting a contents topic
Changing a topic title



Creating an extended link

An extended link is a link where the target topic may be contained in another hypertext file or 
where the target topic is to be displayed in a secondary window defined in the Project Editor. 

Procedure

1. Select a block of text or an image.

2. Select the Extended link command from the Link menu, or click the Extended link  
button on the toolbar.

3. In the Extended link dialog box, enter the name of the secondary hypertext file, or use the browse 
button to locate the file.

4. Once the secondary hypertext file has been selected, choose the target topic from the list of topics to 
choose from. 

5. If the link will display in a secondary window, enter a new name or choose one from the list of names 
under Target Window. This is the name to appear in the Tile bar of the secondary window in the Help Engine 
window.

 

Click in the picture below to learn more about a command or an element of the dialog box.

Note



WYSI-Help Composer will remove the path of a file since the help engine ignores it. When the 
user of your hypertext files clicks on an extended link, the help engine searches the current 
directory, the Windows directory, the Windows system directory, and finally the DOS path until it 
finds the hypertext file containing the topic specified. If it cannot find the file it will display an 
appropriate error message to the user. A hypertext file containing a topic which is the target of an 
extended link, must be in HLP format for the initial hypertext file to be used.

WYSI-Help Composer does not perform any checking on the existence of external files named, 
when an extended link is created. This allows you to define links to files which do not yet exist on 
your machine. This is particularly useful if you are working in a team.

Related Topics

Link menu
Using the floating menu
Defining window properties
Creating a hypertext link
Creating a pop-up link



Pop-up box
Here is a sample pop-up box. The text displayed here is contained in its own topic. 



Comes from
This list contains the topic names which have links pointing to the current help topic.



Comes from list
This list contains the topics which have links pointing to the current topic.



Compiling a Hypertext file

WYSI-Help Composer produces files with the extension .DHF. In order for these files to be used 
by the help engine, they must be converted into .HLP format. This is achieved in two stages.

First, WYSI-Help Composer converts the .DHF file into RTF format. The help compiler then 
performs the second stage of compiling a .HLP file from the .RTF file.

In order to perform the conversion and compilation processes, the option Convert on save in 
the Save Options dialog box must be checked. However, since it is not necessary to convert 
and compile your work each time you save it, you are advised to select this option only when you 
wish to test or use your files.

Related Topics

File formats
Saving a hypertext file
Saving preferences
Quitting the WYSI-Help Composer



File formats

Working with WYSI-Help Composer involves the use of several different kinds of files. An 
explanation of each of these is given here.

.DHF

This file contains information concerning the contents of the topics you create. WYSI-Help 
Composer produces this file when you select the Save command.

.HPJ

This file, known as the help project file, contains special information about the hypertext file    you 
have produced; the contents topic chosen, the name of the icon file, the warning level chosen for 
the help compiler, the name of the error log file, the definition of the windows used (size, color, 
etc.), the compression rate chosen for the final .HLP file, etc.

.H

This file contains the context-id numbers for all of the topics that form the hypertext file. It is used 
by the help compiler.

.RTF

RTF, (meaning Rich Text Format), is an intermediate file format to allow WYSI-Help Composer 
files, (those in DHF format), to be converted into files usable by the Windows help engine, (files in
HLP format).

.HLP

This is the file format required by the Windows help engine. The help compiler produces files in 
this format from files initially in RTF format.

.LOG

The error log file will use this file extension, if you have chosen to create one.

.BMP

Files with this extension contain reference images.

.SHG

Files with this extension contain hypergraphic images.

.WAV

Files with this extension contain a sound sequence.

To ensure you have a complete backup of all of your work, you should check that you have files 
with the following extensions: .DHF, .HPJ. If your hypertext file contains reference images, 
hypergraphic images or sound sequences, then you should also have files with the extensions
.BMP, .SHG, and .WAV, respectively.

Related Topics



Creating a new hypertext file
Opening a hypertext file
Opening an RTF file
Saving a hypertext file
Saving a hypertext file as...
Compiling a hypertext file
Saving preferences
Quitting the WYSI-Help Composer
Selecting an error log file
Working directly with the help project file



Save command

Use the Save command from the File menu or click the Save  button on the toolbar to save 
changes to your hypertext files. If you haven't named the project yet, the Save As dialog box 
appears. 

When you save a named file, WYSI-Help Composer updates the .DHF and .HPJ file to reflect the updates to 
the project.    When saving a project file, you are    prompted to convert the project file to .RTF and .HLP 
formats. If you don't intend to test your project and wish to continue editing your topics, click the No button, this
will save the changes to DHF format only. 

To disable the file conversion prompt for the conversion to take place every time you save a 
project, pull down the Preferences menu and choose Display.

When saving and converting a file, changes made during editing will be updated to the .DHF 
and .HPJ files. During the conversion to .RTF, WYSI-Help Composer will generate an .RTF, .CTX
and .H files. The last step of the conversion will create a new .HLP file if one doesn't exist or 
update the current one. 

Related Topics

File open command
File save as command
Most Recently Used Hypertext File List
File formats



Saving options

WYSI-Help Composer allows you to modify its behavior relating to saving your hypertext files. 

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Preferences menu
Saving a hypertext file
Compiling a hypertext file
Testing the hypertext file



Exit command

Use the Exit command on the File menu to close an open project and exit WYSI-Help 
Composer. If you made changes to a project since the last time you saved it, a message will ask
if you want to save the changes.

If you choose Yes, and the document is untitled, the Save as dialog box appears so you can 
name the project. If the project is already named, it is saved and you exit WYSI-Help Composer.

If you choose No, the project is closed without saving the changes.

Related Topics
Application Control Menu
File Menu
Save Command
Save as Command



Creating a hypertext link

To provide detailed explanation for a word, an expression or an image (an object) in one topic 
with the information in another topic, you create a hypertext link in the other topic. When the user 
clicks the mouse on the object, the topic linked to the object will appear. 

What is Hypertext?    

Procedure

1. Select the block of text, or the image, you wish to link to another topic.

2. Select the Hypertext command from the Link menu, (ALT, L, H) or click on the Hypertext

 button on the toolbar.

3. In the Choose or create the hypertext topic dialog box, choose the name of the topic you 
wish to link to. You may enter a new topic name, or select an existing one from the list provided.

4. By default, the text    you selected to assign to a link, will be saved and added to the list of reference 
expressions, for the purpose of automatic link generation. You may choose, however, not to add this expression
to the list, by removing the check mark from the box labeled Memorize link.

5. Confirm your choices by clicking on the OK button. The WYSI-Help Composer main window 
will be restored. To edit the target topic of the link, click on the Edit button.

If you selected a region of text to be transformed into a link, this selection will now be written in 
the hypertext style. The destination list will also be updated accordingly.

Click in the picture below to learn more about a command or an element of the dialog box.



Note
To link an image that has been left or right aligned using the Format-Image command,    you 
must select its entry point to select the image. The entry point marker appears as a variation of 

this image:

Related Topics

Creating an extended link
Using the floating menu
Choosing a hypertext style
Saving a reference expression
Create a pop-up link
Deleting a link
Renaming a link



Creating a pop-up link

A help topic is usually displayed in the main window of WinHelp, and its contents replace the 
contents of the previous topic.

You may display a topic in a smaller window whose size and position is determined by the help 
engine according to the size of the topic itself (see sample below).    This smaller window is 
displayed over the original window and does not modify the original window.    A topic is displayed 
in a pop-up window via the pop-up link. Pop-up links are particularly useful when you wish to 
display a fairly short explanation of something mentioned in another topic.

Sample pop-up window

Procedure

1. Select the text or image to display a pop-up window.

2. Select the Pop-up command from the Link menu, (ALT, L, P), or click the Pop-up     
button on the toolbar.

3. In the Choose or create the pop-up topic dialog box, enter the name of the topic you wish to 
display in the pop-up window. You may enter a new topic name, or select an existing one from the list provided.

4. By default the text that you selected to transform into a link will be saved and added to the list of 
reference expressions for the purpose of automatic link generation. If you choose not to add this expression to 
the list,    remove the check mark from the box labeled Memorize link.

5. Confirm your choices by clicking on the OK button. The WYSI-Help Composer main window 
will be restored. To edit the target topic of the link, click on the Edit button.

If you selected a region of text to be transformed into a link, this will now be written in the pop-up 
style. The destination list will be updated accordingly.

Click in the picture below to learn more about a command or an element of the dialog box.



Related Topics

Creating an extended link
Choosing a pop-up style
Saving a reference expression
Creating an Hypertext link
Using the floating menu
Deleting a link
Renaming a link



Choosing a hypertext style

WYSI-Help Composer allows you to redefine the text style used for hypertext links. You may 
change the font, size and style of the hypertext style, but not the color or the underlining effects.

Procedure

1. Select the Hypertext style command from the Format menu.

2. Click on the Choose button to open The Font dialog box, allowing you to modify the 
existing hypertext style.

3. Click the OK button when you have finished to store the changes you have made.

Click in the picture below to learn more about a command or an element of the dialog box.

Note
Changing the hypertext style will result in all the existing links in a hypertext file changing their 
style accordingly. You can change the color used for all types of hypertext links, but not from 
within WYSI-Help Composer. Instead,    you need to modify the WIN.INI file for your machine. 
However, this will only affect your particular machine, and other users of your hypertext files will 
still have hypertext links in the color defined in their WIN.INI file, which is normally green 
underlined text.

Related Topics

Choosing a pop-up style
Examining the properties of a link
Deleting a link
Jumping to the target of a link



Choosing a pop-up style

WYSI-Help Composer allows you to redefine the text style to be used for pop-up links. You may 
change the font, size and style of the pop-up style, but not the color or the underlining effects.

Procedure

1. Select the Pop-up style from the Format menu.

2. Click on the Choose button to display the Font dialog box. The Font dialog box allows you
to modify the existing pop-up style.

3. Clicking on the OK button when you have finished will store the changes you made.

Click in the picture below to learn more about a command or an element of the dialog box.

Note
Changing the pop-up style will result in all the existing links in a hypertext file changing their style 
accordingly. You can change the color used for all types of pop-up links, but not from within 
WYSI-Help Composer. Instead you need to modify the WIN.INI file for your machine. However, 
this will only affect your particular machine, and other users of your hypertext files will still have 
pop-up links in the color defined in their WIN.INI file, which is normally green underlined text.

Related Topics

Choosing a hypertext style
Examining the properties of a link
Deleting a link
Jumping to the target of a link



Compressing the .HLP file

If you have created particularly large hypertext files,    you may want to compress them to make 
the best use of the memory resources available.

Procedure

1. Select the Project Editor command from the File menu, (ALT, F, E)

2. Towards the bottom of the dialog box is a menu labeled Compression. Select the level of 
compression you require.

3. Clicking on the OK button stores the changes you have made and returns you to the WYSI-
Help Composer main window. Clicking on Cancel will ignore the changes you made.

Three levels of compression exist:

No : The file is not compressed at all.
Medium : The file is partially compressed.
High : The file is compressed as much as possible.

Note
The greater the level of compression, the longer the time required to save and reload the file. For 
this reason, we advise you to compress only the final version of your hypertext file.

Related Topics

Hypertext files



Hypertext

The term "hypertext" was coined in the mid-1960's by computer scientist, Ted Nelson. The 
original idea of hypertext came from Vannevar Bush, President Roosevelt's wartime science 
advisor. He proposed a machine called "Memex" in the Atlantic Monthly magazine article in July 
1945 entitled, "As We May Think."

The strict theoretical vision of hypertext proposes that every piece of text, every word in every 
document, should be treated as a linkable element of an information system. Large amounts of 
data can, therefore, be accessed with just a few key words or data associations. This process 
allows you to find the information you are looking for in a heartbeat.

An encyclopedia is a good example of the hypertext concept. In an encyclopedia, each subject 
may be consulted independently of the others. At the same time, it may contain references to 
other subjects. This is very similar to how a hypertext file works. In this case, information on 
different subjects may be displayed according to choices made by the user. When two or more 
subjects are closely related to each other, links may be created between them to allow the user 
to access all the relevant information in the easiest and most efficient way possible.

WYSI-Help Composer has added more types of links to extend the possibilities of hypertext 
documents. You can now create :

- links to external programs
- links to sound sequences
- links to macro commands
- links to topics contained in different files
- links to your library functions (dPP's)

Furthermore, you can create links from images, and even from different regions in an image, as 
well as from blocks of text. Using the project editor, you can also personalize your hypertext files 
by changing the background color, defining your own secondary windows, etc.

Hypertext files may be used thanks to the Windows help engine. However, the files produced by 
WYSI-Help Composer need to be converted to a form readable by the help engine, and this is 
performed in two stages.

The first stage of the process is for WYSI-Help Composer to convert its .DHF files into .RTF 
(Rich Text Format) files. Once the conversion has taken place, the help compiler, provided in this 
package performs the second stage of the process. It is launched by WYSI-Help Composer and 
it compiles the .RTF file into a Windows .HLP file. This file is then readable by the WinHelp 
engine.

The range of uses for hypertext files is as broad as your imagination. Of course, hypertext lends 
itself easily for use with electronic documents, (reference manuals, on-line help files, catalogs, 
encyclopedias, etc.)

A hypertext file may also be used as an Electronic Document Manager, in order to organize 
access to a series of related texts. The file can contain links to consultation tools which can open 
a particular document, (or image, or table), when the user clicks on the icon linked to a particular 
application.

Hypertext files may also be used as models for human computer interfaces. By creating 
hypergraphic images, you can simulate the behavior of a future application. The models will be 
tested for their usability and ease of use. Changes are easy to apply at this early stage of the 
development before writing the code.

By incorporating graphics into a hypertext file and linking them to your applications, the creation 



of a personalized electronic desktop becomes a possibility for everyone, without the need for 
specialist programming knowledge.

Related Topics

Hypertext links
Pop-up links



Contents
Check this box to print the contents of each topic in the list of selected topics. This is the default 
selection.



Convert after save
Check this box to create .RTF then .HLP files each time you save your hypertext or .DHF file. It 
will ask you if you want to convert your file to RTF format first. Answering yes to this question will 
perform the conversion and create a file with the same name as the .DHF file but in .RTF format.  
Another dialog box will then appear asking you if you want to compile a .HLP version of your 
hypertext file. This process may take some time if you have a large file and it is recommended 
that converting to .HLP be done infrequently.



Copy command

Copies the selected text and images and places them on the Clipboard.

Procedure

1. Select the text or the image(s) you want to copy.

2. Choose the Copy command from the Edit menu or click the Copy  button on the 
toolbar.

The selection remains in your topic and is also placed on the Clipboard. Use the Paste 

command on the Edit menu or the Paste  button from the toolbar to paste the copied 
selection into the same topic or another topic.

Related Topics

Cutting a block of text
Pasting a block of text
Delete Command

Edit Menu



Cut command

Removes the selected text or images from a topic and places them on the Clipboard.

Procedure

1. Select the text or image(s) you want to cut.

2. Choose the Cut command from the Edit menu or click the Cut  button on the toolbar.

The selection is removed from your topic and placed on the Clipboard. Use the Paste command 

on the Edit menu or the Paste button on the toolbar to paste the cut selection into the same 
topic or another topic.

Related Topics

Copy Command
Cutting, Copying and Pasting Buttons
Delete Command
Edit Menu
Paste Command



Paste command
Use the Paste command from the Edit menu or the Paste  Button on the toolbar    to place a 
copy of the content from the clipboard into the current topic displayed in the edit window. 



Deleting an object

The Delete command will allow you to remove a selected region of text or an image without 
having to place it in the clipboard.

Procedure

1. Select the item you wish to delete.

2. Select the Delete command from the Edit menu or you can press the Del key on the 
keyboard .

3. The selected region will now be removed.

Note
You may use the Undo command to cancel the Delete operation.

Related Topics

Composing a topic
Cutting a block
Undoing/redoing the last edit operation



Edit menu
Click on a menu item to get help on that item.



Copy command

Use the Copy command from the Edit menu or the Copy  button on the toolbar to place a 
copy of the selected text or images on the Clipboard. 

You must highlight the text or the image(s) you wish to copy before using this command.



Creating browse sequences
When several topics deal with the same subject, you can group them together into a browse 
sequence, guiding the final user along. It will ensure your help file is used most effectively

When the hypertext file being displayed contains a browse sequence, the help (WinHelp) engine 

will display two browse buttons,

 , on its button bar to allow the user to display the previous/next topic in a sequence.

Related Topics

Defining a browse sequence
Inserting a topic into a browse sequence
Displaying the previous or next topic
Deleting a topic from a browse sequence
Deleting a browse sequence
Cutting a browse sequence in two



Defining a browse sequence

You may create a browse sequence in order to group together topics which are related to one 
particular subject.    Browse sequences are then accessed by the end user with the Browse 

buttons, .

A browse sequence is initially created by selecting two topics, and placing one of them in front of the other.

Procedure

1. Make the topic you wish to put at the start of the browse sequence the current topic.

2. Select the Insert topic after command from the Sequence menu, (ALT, S, A), or click 

on the arrow  button situated to the left of the Next topic box 
in the WYSI-Help Composer main window.

3. A dialog box will display which is similar to the one for creating a new topic. In particular, it contains a 
list of those topics which you may insert into the browse sequence. From this list, select the topic that you wish 
to place in the sequence.

4. Clicking on the OK button will restore the WYSI-Help Composer main window and confirm 
your choice. The name of the topic you selected will now appear in the Next topic box. 
Clicking on this name will cause this topic to become the current one.

Note
You may also create a browse sequence by inserting one topic in front of another. In this case, 
you would use the command Insert topic before. This will have the same effect as using the 
command above, but later on, when you add more topics to browse sequences, each of these 
two commands will have a different purpose.

Related Topics

Inserting a topic into a browse sequence
Displaying the previous or next topic
Deleting a topic from a browse sequence
Deleting a browse sequence
Cutting a browse sequence in two
Editing a topic
Generating links automatically
Display preferences



Inserting a topic into a browse sequence

Once you have created a browse sequence, you can modify it by inserting more topics into it. The
position where a topic will be inserted, depends on the position in the browse sequence of the 
current topic at the time you choose to insert another topic. The current topic must be displayed in
the Main Window of WYSI-Help Composer before inserting a topic before or after in the 
sequence.

Procedure

1. Make the current topic the one that you wish to insert another topic either before or after.

2. To insert a topic before the current topic, select the Insert topic before command from 

the Sequence menu, (ALT, S, B), or click on the arrow  
button situated to the left of the Previous topic box. Alternatively, to insert a topic after the 
current topic select the Insert topic after command from the Sequence menu, (ALT, 
S, A), or click on the arrow 

 button situated to the left of the Next topic box.

3. The Choose or Create the Next Topic    dialog box will open. It contains a list of those
topics which you may insert into the browse sequence. From this list, select the other topics   
that you wish to place in the sequence.

4. Clicking on the OK button will restore the WYSI-Help Composer Main Window and confirm 
your choice. The name of the topic you selected will now appear in the Previous/Next topic 
box as appropriate. Clicking on this name will cause this topic to become the current one.

Related Topics

Defining a browse sequence
Displaying the previous or next topic
Deleting a topic from a browse sequence
Deleting a browse sequence
Cutting a browse sequence in two
Editing a topic
Generating links automatically
Display preferences



Displaying the previous or next topic

As you are developing hypertext files in which you have created browse sequences, you may 
wish to check the order of the topics in that sequence. To do this you may of course use the 
Execute help file option, but two methods also exists for viewing topics in a sequence within 
WYSI-Help Composer itself.

Procedure 1

1. Select as the current topic one which is part of the browse sequence you wish to examine.

2. The names of the previous and next topics, if they exist, are shown in the boxes with the 
arrows below the Comes from and Goes to lists, respectively.

As you move the mouse cursor over these names it will change to a hand pointer. Clicking on one
of these names will result in that topic being displayed in the editing region of the screen. The 
Comes from, Goes to, Previous topic and Next topic boxes will be updated accordingly.

Procedure 2

1. Select as the current topic one which is part of the browse sequence that you wish to examine.

2. From the Sequence Menu, select the Next topic or Previous topic menu items.

This will make the appropriate topic in WYSI-Help Composer active.    It will appear in the edit 
window and the Topics Lists will be updated.

Related Topics

Defining a browse sequence
Inserting a topic into a browse sequence
Deleting a topic from a browse sequence
Deleting a browse sequence
Cutting a browse sequence in two
Editing a topic



Deleting a topic from a browse sequence

You may, at any time, remove a topic from a browse sequence by simply selecting a command 
from the Sequence menu.

Procedure

1. Make the topic that you wish to remove from a sequence the current one.

2. Select the Delete from sequence command from the Sequence menu, (ALT,S,D). 
The Previous topic and Next topic boxes will become empty to indicate that the topic no 
longer belongs to a browse sequence.

Note
The effects of this command cannot be reversed by using the Undo command.

Related Topics

Defining a browse sequence
Inserting a topic into a browse sequence
Displaying the previous or next topic 
Deleting a browse sequence
Cutting a browse sequence in two
Editing a topic



Deleting a browse sequence

WYSI-Help Composer has a command to completely delete a browse sequence if you do not 
wish to include one in your hypertext files.    The topics that were members of the browse 
sequence will not be modified in any other way.

Procedure

1. Make the current topic one which belongs to the sequence that you wish to delete. Verify this
by looking at the contents of the Previous / Next topic boxes, or by browsing through the 
sequence by clicking on the topics contained in these boxes.

2. Select the Delete sequence command from the Sequence menu, (ALT, S, S). The 
sequence will be deleted, and the Previous / Next topic boxes will be empty to indicate this.

Note
Any topics belonging to a sequence you delete may be inserted into a different sequence. The 
effects of this command cannot be reversed by using the Undo command.

Related Topics

Defining a browse sequence
Inserting a topic into a browse sequence
Displaying the previous or next topic 
Deleting a topic from a browse sequence
Cutting a browse sequence in two
Editing a topic



Cutting a browse sequence in two

As    you develop topics in a hypertext file, a browse sequence may become too long to be 
manageable. Alternatively, as more topics are added to a browse sequence,    it might become 
too general. In these situations, you may use a special command offered by WYSI-Help 
Composer to split a sequence in two.

Procedure

1. Select the topic after which you wish to cut the sequence in two. Hence after the operation 
has taken place, this topic will form the last topic in the first sequence.

2. Select the Cut after command from the Sequence menu, (ALT, S, C). The sequence will
be cut in two, and the Next topic box for the current topic will become empty as a result of 
this.

Note
You cannot reverse the effects of this command using the Undo option, but instead you may 
rejoin the two sequences together by selecting the last topic in the first sequence and inserting 
the first topic of the second sequence after it.

If the current topic is the first or the last one in a sequence then the option Cut after will be 
dimmed.

Related Topics

Defining a browse sequence
Inserting a topic into a browse sequence
Displaying the previous or next topic 
Deleting a topic from a browse sequence
Deleting a browse sequence
Editing a topic



Creating a hypergraphic image

WYSI-Help Composer    comprises a utility called the Hotspot Editor. Using this you will be able to 
transform an ordinary image into a hypergraphic image. Two methods exist for doing this, 
depending on the format of the image you wish to convert into a hypergraphic. Converting internal
images is discussed first. The second procedure shows how to convert an image held in an 
external .BMP file into a hypergraphic image.

Procedure 1

1. Select the image you wish to convert into a hypergraphic image by double clicking on it so it 
appears in inverse video.

2. Select the Image command from the Format menu, (ALT, O, I).

3. Change the type of the image to hypergraphic by selecting this option from the Type menu. 
(See Changing the format of an image).

4. Give a file name in which the hypergraphic image is to be stored. The default file extension is
.SHG.

5. Confirm the information you have given by clicking on the OK button.

6. While the image is still selected, select the Edit hypergraphic command from the Edit 

menu, (ALT, E, H), or click the Hypergraphic  button on the toolbar. The Hotspot Editor 
will be launched and the image will be displayed in the editing region of the window.

7. To define a sensitive zone in the image, position the arrow pointer at one corner of the area you wish 
to mark. Then press and hold down the left hand mouse button.

8. You may now move the mouse which will make guide wires appear between the starting 
position and the arrow pointer. Note that the zones you create using the Hotspot Editor may 
only be rectangular.

9. When you have covered the region of the image you wish to use, releasing the left hand 
mouse button will fix the guide wires, and create a new zone.

10. Should you make a mistake when defining the size of the zone you can easily rectify this. 
Position the cursor over one of the handles, (the small squares on each corner and edge of 
the rectangle), it will change its form to an arrow pointer. You may now change the size of the
region, by holding down the left mouse button and dragging the handles to a new position.

11. To link a defined zone, select the Attributes command from the Edit menu.

12. Define the type of link you wish to use for the zone by selecting one of the options from the 
Type menu. It may either be a hypertext link, (choose the Jump option), a pop-up link, or a 
macro link.

13. Depending on the type of link that you have chosen, the text box above the Type menu will 
either be labeled as Context string, or Macro. For a macro link, provide a correct macro 
definition. For a hypertext or pop-up link , type the name of the target topic here. Once you 
have selected Jump or Pop-up as the link type option, a secondary window will appear 
containing a list of the topics existing in the current hypertext file. An example is shown 
below. You may double click on one of these to select it and place it in the text box. 
Alternatively, you may type a name of a topic which does not yet exist. In this case, when 



you return to WYSI-Help Composer, a blank topic will be created with the name you 
provided.

14. You may define that a single pixel border should be drawn around the zone when it is used, 
in order to make it visible to the final user. This can be done by selecting the option Visible 
from the Attribute menu. Selecting the other option, Invisible, will result in no border being 
drawn.

15. Repeat the steps 7 to 14 to define more zones, then select the Save as option from the File 
menu when you have finished.

16. Selecting the Exit option will close the Hotspot Editor and restore the main window of the 
WYSI-Help Composer.

Note
You do not have to close the Hotspot Editor. Simply saving the hypergraphic file is sufficient for 
the changes to be visible in WYSI-Help Composer.

Procedure 2

1. Launch the Hotspot Editor from the Program Manager.

2. From the File menu, select the Open command.

3. In the File open dialog select the .BMP file containing the image you wish to transform into
a hypergraphic image. The image will now be displayed in the editing region of the Hotspot 
Editor window.

4. To define a sensitive zone in the image you must position the arrow pointer at one corner of 
the area you wish to select. Then press and hold down the left mouse button.

5. Now move the mouse which will make guide wires appear between the starting position and 
the arrow pointer. Note that the zones you create using the Hotspot Editor may only be 
rectangular.

6. When you have covered the region of the image you wish to use, releasing the left mouse 
button will fix the guide wires, and create a new zone.

7. If you make a mistake when defining the size of the zone you can easily rectify this. 
Positioning the cursor over one of the handles, (the small squares on each corner and edge 
of the rectangle), will change its form to an arrow pointer. You may now change the size of 
the region by holding down the left mouse button and dragging the handles to a new 
position.

8. To link a defined zone, select the Attributes command from the Edit menu. The following 
dialog box will open:

Click in the picture below to learn more about a command or an element of the dialog box.



9. Define the type of link you wish to use for the zone by selecting one of the options from the 
Type menu. It may either be a hypertext link, (choose the Jump option), a pop-up link, or a 
macro link.

10. Depending on the type of link you have chosen, the text box above the Type menu will either 
be labeled as Context string, or Macro. For a hypertext or pop-up link, type the name of the 
target topic here. It doesn't matter if this does not yet exist. For a macro link, provide a 
correct macro definition.

11. You may define a single pixel border to drawn around the zone when it is used, in order to 
make it visible to the final user. This can be done by selecting the option Visible from the 
Attribute menu. Selecting the other option, Invisible, will result in no border being drawn.

12. Repeat the steps 4 to 11 to define more hot spots, then select the Save as command from 
the File menu when you have finished.

13. Selecting the Exit option will close the Hotspot Editor. You may use the hypergraphic file you 
have created later on when you use WYSI-Help Composer, (see Inserting a hypergraphic 
image).

Note
Using this method will mean that the list of topics will not be available to you when you are 
specifying the links for the hot spots that you have defined.

Related Topics

Inserting a hypergraphic image
Editing a hypergraphic image
Changing the format of an image



Inserting a hypergraphic image

Inserting a hypergraphic image into a topic is performed in much the same way as a single image 
is inserted into a topic.

Procedure

1. Position the cursor in the topic where you wish to insert the hypergraphic image.

2. Select the Hypergraphic command from the Insert menu.

3. The Browse dialog box will open allowing you to select the .SHG file containing the 
hypergraphic you wish to insert. Click on the OK button, the main window of WYSI-Help 
Composer will be restored and the hypergraphic image you have chosen will be inserted into
the topic. The    list above the edit window will be updated appropriately.

Note:
If the topics linked by the regions in the image do not yet exist, WYSI-Help Composer will 
automatically create blank topics with these names.

Related Topics

Creating a hypergraphic image
Editing a hypergraphic image
Inserting an image
Inserting an image from the clipboard



Editing a hypergraphic image

Once a hypergraphic image is inserted in a topic, you can choose the Edit hypergraphic 
command from the Edit menu to edit or modify it. The Hotspot Editor is automatically launched 
from WYSI-Help Composer with this command.

Procedure

1. Select the hypergraphic image you wish to edit by double clicking on it.

2. Select the Edit hypergraphic    command from the Edit menu or choose the Edit 

Hypergraphic  button on the toolbar. The Hotspot Editor will be launched allowing you to 
edit the hotspots in the image. See the section entitled Creating a hypergraphic image for more 
information on how to do this.

3. When you have finished, save the modifications you have made by selecting the Save 
command from the File menu. Then select the Exit command from the File menu to quit the 
Hotspot Editor and return to WYSI-Help Composer.

Related Topics

Creating a hypergraphic image
Inserting a hypergraphic image
Changing the format of an image



Using Help macros

Macros are commands which you may use to extend the possibilities of your hypertext files. Two 
kinds of macro exist. Firstly, a range of macros are provided for you by WinHelp. These are 
generally involved with defining new buttons or menu items which will be displayed in the help 
window. However, using one particular help macro you may define your own macros. The second 
type of macros are those which are user-defined.    User-defined macros usually require some 
programming knowledge.

WYSI-Help Composer allows you to insert macros at three levels within your hypertext files:

1. The file level. This means that the macro will be executed when the file is first opened.

2. The topic level. In this case the macro will be executed when a topic is opened.

3. The text level. WYSI-Help Composer permits you to create a link from an image or a region 
of text to a macro. Here the macro will be executed when the final user clicks on the 
sensitive region with the mouse.

A full list of the WinHelp macros is provided in the Macro Editor which comes into operation when 
you decide to insert a macro somewhere within your hypertext files. The Macro Editor uses the 
same dialog box for all three levels.

Procedure

1. Select a block of text or an image.

2. Select the Macro command from the Link menu.

3. Select the macro command(s) you wish to associate with the link.

Click in the picture below to learn more about a command or an element of the dialog box.



The information bar, situated at the bottom of the dialog box, contains information concerning the 
cursor position within the current definition entry field. Error messages will also be displayed in 
this bar if the current definition becomes invalid, for instance if you type an illegal value for a 
parameter. The error message will also include a position reference referring to the position of the
error in the current definition.

A user defined macro is in fact a function in a dynamic link library (DLL). To define a function in a 
DLL as a macro command, you need to use the macro called RegisterRoutine. The exact form of 
this command is as follows:

RegisterRoutine ("DLL-name", "function-name", "format-spec")

DLL-name
Specifies the filename of the DLL.

function-name
Specifies the name of the function to execute in the designated DLL.

format-spec
Specifies a string indicating the formats of parameters passed to the function. The format string 
must be enclosed in quotation marks. Characters in the string represent C parameter types:

Character Description

u unsigned short (WORD)
U unsigned long (DWORD)
i short int
I int
s near char * (PSTR)
S far char * (LPSTR)



v Void

Macros that you create yourself will not be present in the macro list contained in the Macro Editor.
Hence to insert a user defined macro you must type its name and parameters yourself in the 
current definition entry field.

Related Topics

Inserting file macros
Inserting topic macros
Creating a macro link



Link menu
Click on a menu item to get help on that item.



Creating a non-scrolling region for a topic

When the user of your hypertext files is viewing a topic which is too big for the display area of the 
window, scroll bars will appear allowing the user to view the entire topic. In this situation, it may 
be useful to make the top part of the topic fixed to keep the title of the topic and other important 
information visible.

You may define the size of the non-scrolling region for a topic, and there are two ways to insert a 
non-scrolling region into your topics.

1. When you create a new topic. In this case the topic will have the default value for the size of 
a non-scrolling region. See Preparing a new topic to have a non-scrolling region.

2. By selecting the option Non-scrolling region from the Topic menu. This method is discussed 
here.

Procedure

1. Make the topic for which you wish to create a non-scrolling region the current one.

2. Select the Non-scrolling region command from the Topic menu, (ALT, T, S).

3. In the Non-scrolling dialog box, enter the number of paragraphs that you wish to be included 
in the non-scrolling region.

4. Confirm your choice by clicking on the OK button.

Note
You may place links in the non-scrolling region of a topic if you wish.

The combination of topics with non-scrolling regions which are target topics of pop-up links is not 
supported by WinHelp. In this situation, only the non-scrolling region of the topic will be displayed
in the pop-up window.

Related Topics

Topic menu
Preparing a new topic to have a non-scrolling region
Removing a non-scrolling region



Topic menu
Click on a menu item to get help on that item.



Removing a non-scrolling region

During the development of your topics you may wish to remove a non-scrolling region from a 
particular topic. The technique for achieving this is discussed here.

Procedure

1. Select as the current topic the one whose non-scrolling region you wish to remove.

2. Select the Non-scrolling region command from the Topic menu.

3. In the Non-scrolling region dialog box, enter 0 as the size of the non-scrolling region.

4. Confirm the modification by clicking on the OK button.

Related Topics

Topic menu
Creating a non-scrolling region for a topic

Preparing a new topic to have a non-scrolling region



WYSI-Help toolbar
Click on each individual button in the picture below to see a description of the command associated to 
the button.



Pasting the contents of the clipboard

The Paste command allows you to copy the contents of the clipboard into your topics at any 
position you choose. The Paste function may only be used when the clipboard contains 
something, i.e. when a Cut or a Copy operation has taken place.

Procedure

1. Position the cursor where you wish to insert the contents of the clipboard.

2. Select the Paste command from the Edit menu, (CTRL+V), or click the Paste  button 
on the toolbar.

3. The contents of the clipboard will now be inserted at your chosen position.

Note
The Paste function takes a copy of the contents of the clipboard, leaving the original intact. Hence 
you may use the Paste function as many times as you like to paste the same item.

You may use the Undo function to cancel the effects of the Paste function.

Related Topics

Composing a topic
Copying a block
Cutting a block
Undoing or redoing the last edit operation
Inserting an image from the clipboard



Deleting a topic

After creating a project, you may find that one or more topics are no longer needed. The 
procedure for deleting a topic is described below.

Procedure

1. Make the topic you wish to delete the current one.

2. Select the Delete topic command from the Topic menu, (ALT, T, D). A confirmation box 
will be displayed on the screen:

3. Clicking on the OK button in the confirmation box will delete the current topic.

Note
If the topic you have chosen to delete is part of a browse sequence, it won't be deleted and a 
message will be displayed.

To delete the topic, you will first have to remove it from the browse sequence using the Delete 
from sequence command from the Sequence menu.

If the topic you have chosen to delete is the target topic of hypertext or pop-up links, it won't be 
deleted. WYSI-Help Composer will display a warning message.

To delete the topic you will first have to remove the links which point to it. The Comes from list 
tells you which topics have links pointing to the current one. Select each topic, find the link and 
remove it by choosing the Delete link command from the Link menu.

Related Topics

Composing a topic
Editing a topic
Deleting a link



Links
This box contains a list of all the memorized reference expressions. You may make your own 
selection of links to delete using the mouse. A selected link will be displayed with a blue band. If a 
check mark is present in the Delete all links box, then making a modification to the list will remove
this check mark.



Editing a topic

Once you have created some topics, you may want to edit them to fulfill the purpose of producing 
a hypertext file. To edit a topic, you must first make it the current one so that its contents are 
displayed in the editing region of the WYSI-Help Composer window.

Several ways exist of changing the current topic.

- You may select a topic from one of the lists in the WYSI-Help Composer window.
- You may select the next or previous topic in a browse sequence.
- You may display the target topic of a hypertext or pop-up link.

Procedure

1. In the main window of WYSI-Help Composer there are several lists. To make a topic 
displayed in one of these lists the current one, simply double click on its name.

2. Clicking on a topic name contained in the Next topic or Previous topic box will make 
that topic the current one, and its contents will be displayed in the editing region of the main 
window.

3. To make the target topic of a hypertext link the current topic, highlight the link and then select
the option Jump to link from the Link menu. This option is also available in the floating menu.
The contents of the target topic of the link will be displayed in the editing region of the 
window.

Note
You may also choose to edit a topic immediately after creating it, by pressing the Edit button in 
the topic creation dialog box. For the first topic you create in a hypertext file, its contents will 
always be displayed, (only a single carriage return), even if you clicked on the OK button.

Related Topics

Creating a new topic
The topics lists
Jumping to the target of a link



Cut command
Use the Cut command from the Edit menu or the Cut  button on the toolbar to remove the 
selected text or images from the edit window and place a copy on the Clipboard. 

You must highlight the text or the image(s) you wish to cut before using this command.



Inserting a topic into a browse sequence

Once you have created a browse sequence, you can modify it by inserting more topics into it. The
position where a topic will be inserted, depends on the position in the browse sequence of the 
current topic, at the time that you choose to insert another topic. The current topic must be 
displayed on the Main Window of WYSI-Help Composer before inserting a topic before or after in 
the sequence.

Procedure

1. Make the current topic the one you wish to insert another topic either before or after.

2. To insert a topic before the current topic, select the Insert topic before command from 

the Sequence menu, (ALT, S, B), or click on the arrow  
button situated to the left of the Previous topic box. Alternatively, to insert a topic after the 
current topic select the Insert topic after command from the Sequence menu, (ALT, 
S, A), or click on the arrow 

 button situated to the left of the Next topic box.

3. The Choose or Create the Next Topic    dialog box will open. It contains a list of those
topics which you may insert into the browse sequence. From this list, select the other topic 
that you wish to place in the sequence.

4. Clicking on the OK button will restore the WYSI-Help Composer Main Window and confirm 
your choice. The name of the topic you selected will now appear in the Previous/Next topic 
box as appropriate. Clicking on this name will cause this topic to become the current one.

Related Topics

Defining a browse sequence
Displaying the previous or next topic
Deleting a topic from a browse sequence
Deleting a browse sequence
Cutting a browse sequence in two
Editing a topic
Generating links automatically
Display preferences



Display Options

WYSI-Help Composer allows you a certain measure of flexibility in choosing what you wish the 
WYSI-Help Composer edit window to display. You may define your preferences by selecting the 
desired options in the Display Options dialog box.

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Inserting RTF commands
Inserting images
Aligning an image
The toolbar
Using the ruler
Inserting a line break
Defining tabulations
Inserting a non breaking space
Creating a non-scrolling region for a topic



Defining the warning level

Using the Project Editor you may define the level of errors that you wish to be informed of during 
the process of compiling the hypertext file into a help file. These errors will be recorded in the 
error log file if one exists.

Procedure

1. Select the Project Editor command from the File menu, (ALT, F, E).

2. Inside the Project dialog box is a selection menu allowing you to select a warning level.

Three levels of warning exist:

1 = Only the most severe errors will be reported.
2 = An intermediate number of errors will be reported.
3 = All errors and warnings will be reported.

3. Clicking on the OK button will store the changes you have made and return you to WYSI-
Help Composer's main window. Clicking on Cancel will ignore the changes you have made.

Related Topics

Selecting an error log file
Error messages



Selecting an error log file

You may wish for WYSI-Help Composer to create an error log file, store any error reports which 
may be produced during the compilation process.

Procedure

1. Select the Project Editor command from the File menu, (ALT, F, E).

2. Simply type in a file name for the error log file. There is no need to type the file extension as 
WYSI-Help Composer will add this for you. By default, the error log file will be stored in the 
same directory as the current hypertext file, although you may type a different path in the 
entry field if you wish.

3. Clicking on the OK button will store the changes you have made and return you to WYSI-
Help Composer's main window. Clicking on Cancel will ignore the changes you have made.

Note
The seriousness of errors contained in the error log file corresponds to the warning level defined 
in the Project Editor. If no errors occur during compilation, an error log file will still be created, 
containing simply a header which contains the path and filename of the error log file itself.

Related Topics

Defining the warning level



Modifying Help Windows

WYSI-Help Composer allows you to modify the size and position of the main WinHelp window 
which will be used to display your hypertext files.

You may also find it useful to define some secondary windows as you develop your hypertext 
files. This will allow topics such as glossaries to be displayed in a window whose size, position 
and color you yourself have defined while using the hypertext file.

Procedure

1. Select the Project Editor command from the File menu, (ALT, F, E).

2. In the Project editor dialog box, click the Modify button. The Windows Information dialog 
box will appear.

Click in the picture below to learn more about a command or an element of the dialog box.

Note

Secondary windows may only be used in conjunction with extended hypertext links, macro links and links to 
hypergraphic zones. The WinHelp menus and buttons are not available in secondary windows.

You should take care if you specify both the options Always on top and Maximized for one window definition. 
This could result in the final user having some difficulties changing to other applications.

Related Topics

Setting the help window title
Creating an extended link



Setting the help window title

Using the Project Editor you may define a name of your choice for the main help window.

Procedure

1. Select the Project Editor command from the File menu, (ALT, F, E).

2. Edit the window definition "Main" by selecting it and clicking on the Modify button. The 
following dialog box will appear:

3. Type the name you wish to use in the text box labeled Name.

4. Click on the OK button to confirm the changes made and return to the Project Editor. Click 
on OK once more to quit the Project Editor.

5. Save your hypertext file and let WYSI-Help Composer convert the file to RTF and HLP in 
order for the changes to be preserved. The changes are stored in the HLP file during the 
compilation to HLP. Save the file by selecting the Save command from the File menu or by

clicking the Save  button on the toolbar. Select Yes when prompted to convert to RTF 
and also to HLP.

Related Topics

Defining window properties
Saving a hypertext file



Delete all links
Place a check mark in this box to select all the links to include in the deletion.



Delete button
Clicking on this button will delete the tab definition currently selected from the list. However, the 
position of the tab will remain in the text box labeled Position, and the radio button 
corresponding to the alignment which was selected. This will allow you to modify the definition 
that you have just deleted.



Current topic only
Check this box to delete the current topic only.



Undoing or redoing the last edit operation

During the development of hypertext files, you may sometimes find it necessary to undo an 
editing operation you just performed. The Undo command can do this. It becomes active after a 
block has been cut, pasted or deleted, or simply if you are using the keyboard to type or delete 
text.

The Redo command will be active once an Undo operation has been performed. This will restore 
the topic to its state before the Undo command was performed.

Procedure

Select the Undo/Redo commands from the Edit menu, (Ctrl+Z), once you have performed an 

editing operation. You can also use the Undo/Redo  button on the toolbar as well.

Note

1. If you wish to cancel the deletion of a region of text, you must be aware that the Undo 
command will only apply to the text deleted up to the last time you moved the cursor position.
For example, if you delete one word, then move the cursor and delete another, it will only be 
the second word which will be restored if you execute the Undo command.

2. If you select a region of text and then hit a key on the keyboard, the text selected will be 
replaced by the character whose key you have typed. Using the Undo command now will 
remove the new character and replace the selected text.

Related Topics

Cutting a block
Pasting the contents of the clipboard
Deleting an object



Deleting a link

During the development of your hypertext files you will undoubtedly want to delete a link at some 
point, and the techniques for doing this are discussed here.

Procedure 1

1. Position the cursor at the beginning/end of the link.

2. Use the Delete/Backspace keys to delete the text or image forming the link.

Procedure 2

1. Select the link you wish to delete by double clicking on it. 

2. Select the link you wish to delete. You can select a block of text or an image.

3. Select the Delete link command from the Link menu. The link will be removed, but the 
text or the image which formed the link will remain.

In both cases above, the destination list will be updated accordingly. 

Note
The Delete link command is also included in the floating menu.

Related Topics

Choosing a hypertext style
Choosing a pop-up style
Examining the properties of a link
Jumping to the target of a link
Using the floating menu



Examining the properties of a link

Once you have created a link you have no direct way of determining its attributes. Only pop-up 
links are identifiable by their broken underlining, but its type is not the only important piece of 
information concerning a link. And as soon as more than a few links are created, it is not possible 
to determine the target topic of a link from the destination list. WYSI-Help Composer    provides a 
function which will provide you with a summary of the information concerning a selected link.

Procedure

1. Select an existing link.

2. Select the Link properties command from the Link menu.

3. When you have finished viewing the properties of the link you may click on the OK button to 
restore the main window of the WYSI-Help Composer.

Click in the picture below to learn more about a command or an element of the dialog box.

Note
The properties of the first link found in the block, whether it is a complete link or not, are always 
the ones that are displayed. The function is not affected by the presence of normal text in the 
block. If, for example, you have selected a section of text containing a few links, only the property 
of the first link will be displayed.

Related Topics

Choosing a hypertext style
Choosing a pop-up style
Deleting a link
Jumping to the target of a link



Jumping to the target of a link

Although the Link properties command and the Preview feature can tell you the target of a 
particular link, this command allows you to quickly jump to the target topic. Using the option 
Jump to link will display the target topic of a selected link in the main window of WYSI-Help 
Composer.

Procedure

1. Select the link whose target topic you wish to display by double clicking on it. It will then 
appear highlighted in the main window of WYSI-Help Composer.

2. Select the Jump to link command from the Link menu.

3. The target topic will now be displayed in WYSI-Help Composer's main window.

Note
This option is only available for hypertext or pop-up links.

Related Topics

Choosing a hypertext style
Choosing a pop-up style
Examining the properties of a link
Deleting a link



Using the floating menu

WYSI-Help Composer provides you with a floating menu (also referred to as a Context menu) 
when using the right mouse button. The commands    on the floating menu are those associated 
with hypertext.

Click on the image below to see information on the menu items.

Procedure

1. Select a region of text or an image as you would normally do for the creation of a particular 
kind of hypertext link.

2. Press the right mouse button so that a menu appears, somewhere near to the position of the 
mouse cursor.

3. You may now select one of the link creation options from the menu using the left mouse 
button.



Deleting a text style

You can delete text styles you created that are no longer in use. A style can only be deleted if it 
isn't being used anywhere within the project.

Procedure:

1. Select the Delete style command on the Format menu.

2. In the Delete style dialog, choose a style you wish to delete.

3. Click the Delete button to remove the style.

If the style is still in use, a message will appear informing you that the style is still in use and 
cannot be deleted. Otherwise, the style will be deleted.

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Defining a style
Applying a style
Modify a style



Inserting RTF commands

The topic entitled Using RTF commands describes what RTF commands are.    This topic details 
how to insert them into your help file. 

There are certain RTF commands, rather specialized ones, for which WYSI-Help Composer does 
not provide a direct interface. However, you may yourself include these commands by using the 
option RTF command from the Insert menu.

Procedure

1. Position the cursor where you wish to insert an RTF command.

2. Select the RTF command from the Insert menu.

3. You may now enter one or more strings of RTF commands in the editing region provided. 
You must enter the RTF command in lower case for it to be interpreted 
by the compiler.

4. If you click on the OK button, an RTF command entry point will be inserted at your chosen 
position. If you have chosen to include RTF command entry points in the list of items to 
display (see display options), they will be represented by a symbol such as the one below:

Otherwise, RTF commands that have been inserted will be invisible. 

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Using RTF commands
Editing RTF commands
Display preferences



Inserting a non breaking space

Both WYSI-Help Composer and the help engine will wrap lines if they exceed the width of the 
window. However, in certain circumstances, this might not be desirable. In this situation you may 
separate two words using a non breaking space. This is just the same as a normal space, except 
that the two words surrounding a non breaking space will be treated as an indivisible section of 
text. Hence no wrapping will occur between two words on each side of a non breaking space.

Procedure

1. Position the cursor where you wish to insert a non breaking space.

2. Select the Non breaking space command from the Insert menu, or press the keys 
CTRL + Space.

Note
To make the presence of a non breaking space more obvious while you are editing your topics, 
you may select the option Display non breaking spaces from the Display preferences menu. This 
will result in a non breaking space being represented by the symbol below:

This sentence contains a€non breaking space.'

For a non breaking space to be effective, you should not place a normal space before or after it.

Related Topics

Insert menu
Display preferences



Down button
Select a topic from the list of topics to print, then press the Down button to move it down the list 
so it appears in the order of your choice.



Add
Click on this button to add the reference expression in the Link Text editing field, and its 
associated link type, to the list.



Delete
Clicking on this button will remove the reference expression currently selected in the list and 
places it in the Link Text editing field. The appropriate Link Type radio button will be filled to 
represent the type of link that was associated with the reference expression.



Link text and type
Text
This editing field allows you to enter a new reference expression or modify an existing one.

Type
The type of link to be created is defined here by the radio button currently selected.



Reference expressions list
This box contains a list of all the reference expressions defined for the current topic. A scroll bar 
will appear when necessary to allow you to view the entire list.



Target
This information field contains the name of the current topic.



Editing RTF commands

Once you have entered some RTF commands, you may find it necessary to edit them or to 
modify the command you have originally entered.

Procedure

1. Select the RTF command you want to edit.

2. Select the Edit RTF command from the Edit menu, (ALT, E, F).

3. The editing region will contain a list of RTF commands represented by the entry point you 
selected.

4. After you have performed the modifications you desire, click on the OK button to confirm 
them.

Note
To delete an RTF command it is necessary to first highlight it, and then press the Delete or 
Backspace key. It is not possible to delete an RTF command without first highlighting it.

Related Topics

Using RTF commands
Inserting RTF commands



Using RTF commands

RTF stands for Rich Text Format. This standard also includes a range of commands and RTF 
statements to format the text and appearance of your help file. Many of these commands are 
already included in    WYSI-Help Composer, such as defining a bold region of text and underline.

However, there are a few, quite specialized commands for which WYSI-Help Composer does not 
provide an interface, which allows you to directly insert RTF commands into your topics. These 
commands are included in the list below. It is also possible, that, with later versions of Windows, 
new RTF commands may be created. 

Command Description

\box Draws a box around the current paragraph
\brdrb Draws a bottom border
\brdrbar Draws a vertical bar
\brdrdb Sets double-lined borders
\brdrdot Sets a dotted border
\brdrl Draws a left border
\brdrr Draws a right border
\brdrs Sets standard borders
\brdrt Draws a top border
\brdrth Sets thick borders
\cell Marks end of table cell
\cellx Sets the position of a cell's right edge
\ewc Allows a DLL to paint a window in text
\ewl Allows a DLL to paint a window at the left margin
\ewr Allows a DLL to paint a window at the right margin 
\fldrslt Result of a field
\intbl Marks paragraph as in table
\row Marks the end of a table row
\san Sets the spacing after a paragraph
\sbn Sets space before
\sect Marks the end of a section and paragraph
\sln Sets the spacing between lines
\trgraphn Sets space between text columns in a table
\trleftn Sets the left margin for the first cell
\trowd Sets table defaults
\trqc Sets relative column widths
\trql Left aligns table row

For a more detailed description of the commands listed above please consult the Microsoft 
Windows SDK manual.

Related Topics

Inserting RTF commands
Editing RTF commands
How do I insert an RTF command



Topics list
This list contains the link names of all of the topics in the current hypertext file. A vertical scroll 
bar will appear when necessary to allow you to scroll the entire list.



Element to search
You may select the type of element to search for by choosing one of these options: either text, 
hypertext link or pop-up link. By default, the preceding option will be chosen. If no searches have 
yet taken place, text will be the default.



Save as command

Use the Save As command from the File menu to name and save a new, untitled project, or to 
save a copy of an open hypertext file under a new name. In either case, all changes made to the 
file are saved, and you can continue working with the file under its new name.

When you save an untitled project or choose Save As from the File menu, the Save As dialog box
appears.

Procedure

1. Choose the Save as command from the File menu.

2. Select the location to save the document.

3. Type a name for the hypertext file in the Filename text box.

The filename can have up to eight characters plus a three-character extension. Any characters
that are valid for a DOS filename are acceptable. WYSI-Help Composer's extension default 
is .DHF for projects.

Although you can use any filename extension, using the defaults helps you distinguish these 
files from other files.

You can replace an existing file by selecting it from the list of filenames. When a message 
asks if you want to replace the existing file, choose Yes to replace the file or No to cancel the 
save activity.

5. Click OK. The project is saved and remains active in WYSI-Help Composer.

Related Topics

File Open Command
File Menu
File Save Command
File formats



File menu
Click a menu item to get help on that item.



Export
For the RTF commands you insert in hypertext file to be used, a check mark must be present in 
this box. Otherwise, the commands will be ignored when the hypertext file is compiled. By 
default, a check mark will be present in this box.



Browse
The browse button enables you to search for the hypertext file you wish to use.



File
Enter the name of the file containing the topic you wish to use. If you leave this field blank, WYSI-
Help Composer will assume you are defining an extended link to another topic in the current file. 
WYSI-Help Composer does not require you to enter a path for the file, and in fact if you do give 
one, WYSI-Help Composer will delete it. 

The hypertext file you create should be placed in one of the following locations:

- the same directory as the final hypertext file,
- the Windows directory,
- the Windows system directory,
- the DOS path.



Target window
Where you are creating a hypertext link, you may choose to use a secondary window you have 
defined elsewhere in the Project Editor. All of the windows that have been defined are contained 
in a menu which you may open by clicking on the pull-down button.



Link type
You may define the type of link to be created by clicking on one of the radio buttons. By default, 
the type Hypertext is selected. Selecting the type Pop-up will gray out the Target Window 
menu.



Extended links
Click on the Extended link icon to create a link to another hypertext file. You can also use the 
Extended link command from the Links menu.



Type of identifier

You must, in some way, identify the target topic of the link. Three methods exist to achieve this:

- you provide the topic name. You can use the Find topics button to display a list of the 
topics contained in the file, if you don't know the exact name.

- you provide the topic number, also known as the context-id. This is a unique number 
assigned by WYSI-Help Composer to each topic created.

- you provide the search keyword of the topic. This is the least preferable way of identifying
topics, since one search keyword may be associated with more than one topic. In this 
case, the first topic which was associated with the search keyword will be used.

The last two methods allow you to create links to files for which you don't have the sources.



Creating an external program link

WYSI-Help Composer allows you to create links to external programs. When the user of your 
hypertext file clicks on this type of link, the external program associated with the link will be 
launched.

A region of text linked to an external program is identified by green underlined text. It is not 
possible to redefine the style of text used for this kind of link. Images may also be linked to 
external programs.

The creation of external program links is performed in much the same way as are normal 
hypertext links.

Procedure

1. Select a block of text or an image.

2. Select the External program command from the Link menu.

3. Enter the name of the program and its eventual launching parameters.

4. Clicking the OK button to confirm the choices you have made returns you to the main 
window of WYSI-Help Composer. If you selected a region of text to be transformed into a link
then this will now appear as green underlined text. The destination list will remain 
unchanged.

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Extended links
Using the floating menu



File new

Creates a new untitled hypertext file.    If your current project has not been saved before you use 
this command, a message will appear to warn you that changes to the current hypertext file 
haven't been saved. You can then either save the changes, not save the changes or cancel the 
command. You can only have one project (.DHF file) open at a time. 

Related Topics

File open
File save
Most Recently Used Hypertext Files



Opening an existing hypertext file

Opens an existing hypertext file.    Use the Open command from the File menu or the Open

button on the toolbar. This command displays the Browse dialog. This dialog gives you 
the option of opening an existing WYSI-Help Composer .DHF file or of importing the contents of
an .RTF file into a new .DHF file. To select an RTF file, you must change the file type in the 
browse dialog to RTF (*.RTF) (See Opening an RTF file).

Change to a different drive and directory, if necessary. Choose a file to open from the list and 
click the OK button. WYSI-Help Composer displays the files with a .DHF extension in its own 
directory

You can only have one project (.DHF file) open at a time.    If you have    a current hypertext file that hasn't been
saved before you use this command, a message will appear to warn you that changes to the current hypertext 
file have not been saved.    You can then save the changes, not save them, or cancel the Open command.

 
Tip:
To open a help file you worked on recently, pull down the File menu and choose one of the 
hypertext files listed at the bottom of the menu. The Most Recently Used Hypertext File list 
displays up to five hypertext files in the order they were saved.

Related Topics

Most Recently Used Hypertext File List
File Save Command
File Save as Command
Opening an RTF    file



If the Activate explorer on Open HLP file option is checked, then the Explorer window will open 
every time the end user opens your help file.    The default for this option is unchecked.

Since opening the Explorer as the help file opens can slow down the opening of the help file, you may 
not wish to check this option.

If you check this option but do not check the Add Button option, then the Explorer window will open 
with the help file, but will not be available once the user closes it.    In this case, the only option the 
user would have for reopening the Explorer window would be to close and reopen the help file.



Inserting file macros

Macros may exist at three levels within your hypertext files, one of which is the file level. Macros 
inserted at this level will be executed when the file is first opened and remain in operation until the
file is closed, or until the user closes them down, (for example, a macro may open a secondary 
window that the user can close down).

Two methods of inserting file macros exists. You can use the Macro Editor or    the Project Editor 
in File    mode to associate macros to hypertext files.

Procedure 1

1. To insert a macro into a hypertext file at the file level, you must first make sure that the file 
you want to modify is open.

2. Select the File macro command from the File menu, (ALT, F, F). or click the File macro

 button on the toolbar.

3. You may now modify the current definition as you wish, clicking on the OK button when you have 
finished to save the changes, or clicking on Cancel to ignore them.

Click in the picture below to learn more about a command or an element of the dialog box.

The information bar, situated at the bottom of the dialog box, contains information concerning the 
cursor position within the current definition entry field. Error messages will also be displayed in 
this bar if the current definition becomes invalid, for instance if you type an illegal value for a 
parameter. The error message will also include a position reference referring to the position of the



error in the current definition.

Procedure 2

1. Ensure the file you want to modify is open.

2. Select the Project editor command from the File menu, (ALT, F, E).

3. Clicking on the File button will put the Project Editor into direct editing mode.

4. In the [CONFIG] section of the help project file you may now enter some file macro 
definitions, or modify those definitions already existing.

Note
Certain rules exist regarding the format of macro definitions in help project files, and these must 
be observed to avoid compilation errors later on.

- A line in the [CONFIG] section may not exceed 254 characters in length, although there is no
limit on the number of lines allowed.

- Certain macros expect other macro names to be included as part of their parameters. 
However, the WinHelp compiler enforces a limit whereby macros cannot be nested more 
than three deep.

Related Topics

Using Help macros
Inserting topic macros
Creating a macro link
Project editing a macro link



Most Recently Used List

Select one of the hypertext files listed at the bottom of the File menu to quickly access a 
previous project.    Or use the Short Cut: Alt-F-# where # is the number in front of the path in the 
list.    WYSI-Help Composer automatically opens the hypertext file without going through the File
open dialog.

WYSI-Help Composer will show

Related Topics

File open command 
File save command
File save as command



First line
The value in this box represents the position of the first line, in relation to the left margin, 
measured in pixels. If the value in this box is zero, the first line will not be indented in relation to 
the rest of the paragraph. Having a positive value above zero means the first line of a paragraph 
is indented to the right in relation to the following lines in that paragraph. Having a negative value 
means the first line of a paragraph is indented to the left in relation to the following lines in that 
paragraph.

You may change the value for the indentation of the first line by using the increase/decrease 

buttons,  , or by directly typing a new value into the text box.

The start of the first line cannot be less than zero pixels from the left side of the page. In other words, the value 
for the left margin added to the value for the indentation of the first line, cannot be less than zero. WYSI-Help 
Composer will display a warning if you attempt to enter an illegal value.



Font
Choose a font from the list of fonts. The list of fonts varies depending on the number of fonts you 
have installed on your system. 



Font colors

WYSI-Help Composer    offers a variety of colors to various text styles. The box below displays all
the colors available for your project.

Note:
Use color sparingly as some colors may be difficult to read on various monitors.



Font effects
You can choose between an underline or a strikeout effect. 

Related Topics

Inserting RTF commands



Font size
You can choose a point size from 8 to 72 points by selecting the pre-defined font size such as 8-
10-12-14-18-24...72. You can also enter a specific number from the keyboard for more precision 
(i.e. 11 point, 27, etc.). The minimum point size you can use is 4, and the maximum is 792. 



Font style
Choose a font style using either regular type face, bold, italic and a combination of bold-italic.



Format menu
Click a menu item to get help on that item.



Goes to
This list contains the topics which are the targets of links in the current topic.



Goes to list
This list contains the topics which are the targets of links in the current topic.



Macro list
The macro list contains a list of all the help macros already defined by WinHelp. This list may be 
scrolled using the scroll bar provided or by using the cursor keys.



Parameter list
The parameters list contains a list of the parameters which must be entered for the current 
macro to be valid.



Help command

Use the Index command from the Help menu or the Help  button on the toolbar to bring 
up WYSI-Help Composer's online help. 



Help macro definitions

Macros are commands you can use to extend the functionality of your hypertext files. Two kinds 
of macro exist. First, a range of macros is provided for you by WinHelp. These are generally 
involved with defining new buttons or menu items which will be displayed in the help window. 
However, one particular help macro lets you define your own macros. The second type of macros
are user-defined.

WYSI-Help    Composer allows you to insert macros at three levels within your hypertext files:

1. The file level - the macro will be executed when the file is first opened.

2. The topic level - the macro will be executed when a topic is opened.

3. The text level - WYSI-Help Composer permits you to create a link from an image or a region 
of text to a macro. Here, the macro will be executed when the final user clicks on the 
sensitive region with the mouse.

A full list of the WinHelp macros is provided in the Macro Editor which comes into operation when
you decide to insert a macro somewhere within your hypertext files. The Macro Editor uses the 
same dialog box for all three levels.

Click in the picture below to learn more about a command or an element of the dialog box.

The information bar, situated at the bottom of the dialog box, contains information concerning the 
cursor position within the current definition entry field. Error messages will also be displayed in 
this bar if the current definition becomes invalid, for instance if you type an illegal value for a 
parameter. The error message will also include a position reference referring to the position of the
error in the current definition.

A user defined macro is in fact a function in a dynamic link library (DLL). To define a function in a 
DLL as a macro command, you need to use the macro called RegisterRoutine. The exact form of 
this command is as follows:

RegisterRoutine ("DLL-name", "function-name", "format-spec")

DLL-name
Specifies the filename of the DLL.

function-name
Specifies the name of the function to execute in the designated DLL.

format-spec
Specifies a string indicating the formats of parameters passed to the function. The format string 
must be enclosed in quotation marks. Characters in the string represent C parameter types:

Character Description

u unsigned short (WORD)
U unsigned long (DWORD)
i short int
I int
s near char * (PSTR)
S far char * (LPSTR)
v Void



Macros you have created yourself will not be listed in the macro list contained in the Macro 
Editor. To insert a user defined macro, you must enter its name and parameters in the current 
definition edit box.

Related Topics

Inserting file macros
Inserting topic macros

Creating a macro link



Help menu
Click on a menu item to get help on that item.



Highlight bitmap links
The options draws a partial green box around bitmap images that are linked to other topics. It 
differentiates non-linked bitmaps from those with links. This option is turned off by default. To 
activate this feature, place a check mark in the box.



Adding sound to a help file

Sound is added to a topic by creating a link between an object in the topic and a sound sequence
file. The sound sequence can be linked to a section of text, an image or a hypergraphic.    The 
sound sequence file must be in .wav format because it is the only sound sequence file format 
supported by the Windows help engine.    To hear the sound, the user of the help file must have 
an active sound driver, and a copy of the sound sequence file must be supplied along with the 
help file. 

Click on the image below to listen to the sound linked to the guitar.

Click here to see the procedure for creating a sound link.



Creating a sound link

With WYSI-Help Composer, it is possible to link a region of text or an image to a sound file. This 
type of link adds yet another dimension to the possibilities available for the creation of hypertext 

files. Use the Sound command from the Link menu or click the Sound     button on the 
toolbar to link to a sound file. You must highlight the text or image you wish to link before you can
use this command.

This command will display the Sound Link dialog. 

Procedure

1. Select a block of text or an image.

2. Select the Sound command from the Link menu, or click the Sound     button on the 
toolbar.

3. Enter the name of the file containing the sound sequence.

4. Clicking the OK button will confirm the choices you have made and return you to the main window of 
WYSI-Help Composer. If you selected a region of text to be transformed into a link,    the text will appear green 
underlined. 

Click in the picture below to learn about a command or an element of the dialog box.

Note
For sound links to be effective in your hypertext files, their users must have an active sound 
driver. You must provide a copy of your sound file with your help file. When the user of your 
hypertext file clicks on a sound link, their sound driver will at least search the current directory 
and the Windows directory for the specified file. If it cannot find the file then it may display an 
error message to the user, sound a different sequence file or simply do nothing, depending on 
the sound driver used.

Related Topics

Hypertext links
Pop-up links
Link menu
Using the floating menu



If the Add button option is checked, then a new button will be added to the button bar of the help file.  
If the user clicks this button, the Explorer window will open, giving the end user access to all of the 
Explorer features.    The default title for this button is &Explorer, so the user will see a button labeled 
Explorer.    You can change this button name by typing a new name in the edit box next to the Add 
button option.

The default for this option is unchecked.    However, if you are going to make the Explorer available to 
your end users, it is recommended that you check this feature to give your users easy access to the 
Explorer.



How do I create a new topic

There are two main ways to create a topic: by using the New command in the File menu, or by 
creating a link to a topic that doesn't exist yet.

You can, if you wish, model the new topic on an existing topic.

Procedure

1. To create the first topic in your hypertext file, or to create a new topic without creating a link, 

select the New topic command from the Topic menu or click the New topic  button on 
the toolbar.

To create a new topic by creating a link, select the text or image you would like to link to a new topic.    
Select either the Hypertext command or the Popup command from the Link menu.    In the dialog box that 
appears, enter the name of the new    topic in the Link name edit box.

To model the new topic on an existing topic, choose a Model name from the drop down list.

2. Click on the Edit button in the dialog box to open your new topic.

3. Type the text you wish to see appear in the topic in the editing area of WYSI-Help 
Composer's main window.

WYSI-Help Composer lets you create paragraph styles you can apply to selected regions of text 
in your topics. Changing the appearance of the text greatly improves the readability of your help 
file or online documentation. 

Related Topics

Composing a topic
Editing a topic
Creating a hypertext link
Creating a popup link



How do I format help text?

You can format the text and paragraphs in your topics using WYSI-Help Composer's built-in word-
processor.

To format paragraphs, select the paragraphs you wish to modify and choose the Paragraph 
command from the Edit menu.    You can also use the ruler.

To format the text in the paragraphs, select the paragraphs you wish to modify and choose the 
Attributes commands from the Format menu. A font dialog box will open which allows you to 
select attributes for the selected text.

You may also define text styles that can be applied to selected text in any topic.    For example, 
you may create a standard text style to use for all headers.    Or you may define a style to use for 
text you wish to emphasize.

Related Topics

Formatting a paragraph
Aligning a paragraph
Aligning an image
Default text styles
Defining a text style
Applying a text style
Choosing a pop-up style
Choosing a hypertext style
Choosing a font
Editing a topic



Defining the format of a paragraph

Good presentation of the text in your topics will improve its readability and effectiveness. You 
may alter the format of the current paragraph by selecting Paragraph from the Format menu. The
formatting options available include the margins, the indentation of the first line, the alignment of 
the text and the position and alignment of the tab stops.

Procedure

1. To format a single paragraph, position the cursor somewhere within this paragraph. To 
format several paragraphs at once, use the mouse to select those paragraphs you wish to 
modify.

Note: To ensure that you have selected all of the paragraphs that you want to format, check the
Show Paragraph Markers item from the Preferences Display menu.    Now, make sure 
that the paragraph markers, ¶ ,are selected in the text you want to format. 

2. Select the Paragraph command from the Format menu.

3. You may now modify the format of the paragraph(s) selected by changing the values and 
the options contained in the Paragraph Format dialog box.

4. When you have finished, clicking on the OK button will confirm the changes you have 
made.

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Showing or hiding the ruler
Using the ruler
Defining page margins
Indenting the first line of a paragraph
Aligning a paragraph
Defining tabulations
Creating a non-wrapping line
Using return characters to format paragraphs



Getting more information on WYSI-Help Composer

Call UDI Software for pricing and information at:

(800) 289-1948 in the U.S. and Canada, (415) 382 8840 or fax at (415) 382-8868.

For WYSI-Help Composer upgrade information, see the WinHelp section in the WINSDK forum 
on Compuserve. Log into Compuserve, click the Go command, and type WINSDK.



Importing topics

WYSI-Help Composer offers a function which allows you to copy topics contained in one 
hypertext file (.DHF file) to your current hypertext file.

This feature is useful when multiple writers are working on one project. Each writer creates his/her
own hypertext file. To complete the project, the hypertext files can all be merged into one single 
hypertext file.

Procedure

1. Open the file into which you want to import topics.

2. Select the Import topics command from the Topic menu.

3. An Open dialog box similar to the Open file dialog box will appear, allowing you to select the
file containing the topics you want to import    Select the file and click the OK button.

4. The Topic to Import dialog box will open, allowing you to select the topics you wish to 
import and the mode of importing. Clicking on the OK button will import the topic(s) you have
selected.

Click in the picture below to learn more about a command or an element of the dialog box.

Note
If you import a topic containing either hypertext or a pop-up links to other topics, then the links will
be removed unless you also import their target topics. However, if duplicate names exist in both 
the source and target files, the links in the source file will be preserved. Extended links, sound 
links and macro links will always be preserved during the conversion process.

Related Topics

Composing a topic
Editing a topic
Topic menu



Basic Information About Importing RTF Files

WYSI-Help Composer provides the facility to open an RTF file directly from the File Open command.   
You can import two kinds of RTF files:

1. Existing hypertext files in RTF format.

The WYSI-Help Composer RTF import function can be used to import RTF files created by other 
help authoring tools.    This means that you can use WYSI-Help composer to update your existing 
help file projects, whether they were created with a word processor or with another help authoring 
tool.    WYSI-Help Composer also produces files in RTF format, so you can import RTF files 
produced by previous or current versions of WYSI-Help Composer if you wish.    This is the best 
way to open files created with earlier versions of WYSI-Help Composer.

2. Manuals and other RTF documents.

The RTF importer allows you to take an existing document, such as a manual, that has been 
saved in .RTF format and convert it into a hypertext file.    Most word processors support .RTF 
format, so all you have to do to create a help file out of an existing manual is to save the manual in
.RTF format, import it into WYSI-Help Composer, and create the links you desire within the file.

There are advantages to using the RTF importer to create online help out of a manual.    You need 
only write and edit the document once.    Once the manual has been created, it may be turned into 
online help quickly, which saves a great deal of time.    With the bulk of the information needed 
already online, the help author can concentrate on perfecting the help file.    This approach 
provides a consistent style and content for both manual and online help, which will improve the 
effectiveness of both.

For complete procedures to import RTF versions of hypertext documents or manuals, see the related 
topics.

Related Topics

Importing an existing hypertext file in RTF format
Importing a manual or document in RTF format



        How do I...
Use this index to get quick access to information on the most used WYSI-Help Composer 
procedures.

Getting Started
How do I create a topic?
How do I format help text?
How do I create and use text styles?

Links
How do I link a topic?
How do I create a hypertext (jump) link?
How do I create a popup link?
How do I add sound to a help file?
How do I link topics in separate hypertext files?
How do I create a link to an external program?
How do I use automatic links?
How do I link to a help macro?
How do I delete a link?
How do I create context sensitive links from an application to my help file?

Moving between topics in the WYSI-Help Composer File
How do I use the graphical Navigator?
How do I open the previous topic?
How do I open one of the recently edited topics?
How do I find a topic by the number listed in the Help Compiler's errorlog?
How do I use the Topics edit box to find a file?
How do I find a file using its context ID?
How do I quickly access a topic without scrolling through the topic names?

Working With Images
How do I insert an image?
How do I create a hypergraphic?
How do I insert a hypergraphic?
How to I take and insert a screen shot image?
How do I change the format of an image or hypergraphic?



Working With Help Files and RTF Files
How do I convert a hypertext file into a help file?
How do I import RTF files?
How do I import an existing document?
How do I import an existing hypertext file?
How do I preview my help file?
How do I test my help file?
How do run my help file outside of WYSI-Help Composer?

Using WYSI-Help Composer Features
How do I use the toolbar?
How do I set preferences?
How do I create and use text styles?
How do I import existing topics?
How do I use automatic links?
How do I use the spell checker?
How do I create a topic that is based on another topic?

Working With the Project Editor
How do I select a Contents topic?
How do I change the color of the help window?
How do I create a secondary window?
How do I compress the hypertext file?
How do I create an error log file?

Implementing Advanced Help Features
How do I create a non-scrolling region?
How do I create a browse sequence?
How do I attach Search keywords to a topic?
How do I change a topic title?
How do I insert an RTF command?
How do I use the Print Multiple Topics in my help file?
How do I do a partial compile?
How do I copy the same information into multiple topics at once?
How do I give my help topics a uniform look?

WYSI-Help Explorer
How do I use WYSI-Help Explorer?
How do I make a graphical topic navigator available to users of my help file?
How do I allow users to print multiple topics from my help file?
How do I make full text search available to users without WinHelp 4.0?
How do I allow users to customize display colors for links?
How do I deliver Explorer to the users of my help file?

Getting more information
How do I get more information on WYSI-Help Composer?
How do I learn about WYSI-Help Composer upgrades?
How do I get more information on creating Windows Help?



Running the help file outside the WYSI-Help Composer

You can easily look at your help file from within WYSI-Help Composer using the Preview mode, 
or by compiling the help file and using the Test mode.    The Test mode makes use of the 
Windows help engine provided with Windows 3.1, WINHELP.EXE.

You can also use the Windows help engine to run the help file created by WYSI-Help Composer 
without opening WYSI-Help Composer. There are three ways to run your help file outside of 
WYSI-Help Composer.

For a temporary way of accessing your help file outside WYSI-Help Composer:

Procedure 1

1. In the Program Manager, pull down the File menu and choose Run.

2. In the Run dialog box, type the path where your help file is located in the Command Line: 
box, or use the Browse... button to enter the path.    Press the OK button.    The help file will 
execute.

The example below will run the help file TOPIC.HLP.

Procedure 2

1. In the File Manager, select the directory where the file is located and double-click the file 

name in the list .
2. The help file will appear on screen.

For a permanent way to access your help file:

The description below will access a help file by double clicking an icon.

1. In the Program Manager, select the Group in which you want to place the new icon by 
double clicking it's icon if it is closed) or clicking on its window.

2. Pull down the File menu and choose New. Click the OK button to create the new item inside
the group.

3. In the    Program Item Properties dialog, type the description you want to have appear 
below the help file icon. 

4. In the Command Line: box, type the path for Windows 3.1 WinHelp.EXE followed by the 
path for your project HLP file and press the OK button.



Related Topics

Testing your help file
Preview your topics



RTF Command Basics

RTF stands for Rich Text Format, which is a standard format supported by many word 
processors. This standard includes contains no binary information, just ASCII text in the form of 
commands and the documents contents. Many of these commands, such as bolding or 
underlining text, can be implemented through the point and click    WYSI-Help Composer 
interface.    However, there are a few quite specialized RTF commands for which WYSI-Help 
Composer does not provide a point and click interface. WYSI-Help Composer allows you to 
directly insert such RTF commands into your topics using the RTF command option on the 
Insert menu.    Below are examples of two RTF commands that were inserted in this manner.

This command (\box) draws a box around the expression.

The new WYSI-HELP Composer.

This RTF command (\brdrt) draws a top border

The new WYSI-HELP Composer

For more information on RTF commands and a list of some specialized RTF commands you can 
use, see Using RTF Commands.

For the complete procedure to insert an RTF command, see Inserting an RTF Command.

Related Topics

Inserting an RTF command
Editing an RTF command
Using RTF commands
Display RTF command entry points



Linking a topic

To link a topic, you select a block of text or an image within the topic, and then choose the 
command for the type of link you wish to make.    You can choose a link to a popup, a jump 
(hypertext), a sound, a topic in another hypertext file or an external program.

For Popup links, choose the Popup command from the Link menu, or choose the Popup  
button on the toolbar. Popup links should be reserved for short descriptions of items or 
commands. 

For Hypertext links, choose the Hypertext command from the Link menu, or choose the 

Hypertext  button on the toolbar. Hypertext links should be used when you are relating to 
longer descriptions or procedures, normally exceeding 10 lines.

For Sound links, choose the Sound command from the Link menu, or choose the Sound  button on the 
toolbar.

For Extended links, choose the Extended link command from the Link menu, or choose the Extended link

 button on the toolbar.

For External program links, choose the External program command from the Link menu.

Related Topics

Composing a topic
Editing a topic
Creating a pop-up link
Creating a hypertext link
Creating a sound link
Creating a link to an external program
Creating a link to another hypertext file
Automatic link



Converting a hypertext file into a help file

WYSI-Help Composer makes it easy to convert your hypertext file to a help file.    You have the 
option of converting your file during the process of saving it.    WYSI-Help Composer has an 
option called Convert after Save which can be toggled on by using the Save command from the 
Preferences menu.    When this option is on, every time you save your hypertext file, WYSI-Help 
Composer will save your file and then display a dialog box which asks if you would like to convert 
your hypertext file to RTF format.    If you say yes, the file will be converted to RTF format, which 
is the file format required by the Windows help compiler.    Once the file has been converted to 
RTF format, another dialog box will display asking if you wish to compile the help file.    If you say 
yes again, WYSI-Help Composer will run the Windows help compiler and a help file will be 
created.

Converting and compiling your hypertext file as you save it will not affect the original file.    When 
the process is complete you will have your original WYSI-Help Composer file in DHF format, an 
interim file in RTF format, and an actual help file in HLP format.    You can continue to revise your 
WYSI-Help Composer file and choose to save it without converting, or convert and compile it 
again at a later time.

You must do the following to create a help file in HLP format:

1. Create a hypertext file containing one or more topics.

2. Select the Convert after save option using the Save command on the Preferences menu.

3. Save your hypertext file and answer yes to convert to RTF format and again to convert to 
HLP format.

Related Topics

Saving a hypertext file
Executing a hypertext file
Running the help file outside of WYSI-Help



Linking to a separate hypertext file

WYSI-Help Composer allows you to link topics from one hypertext file to target topics in another 
hypertext file. This allows you to create small, modular help files that can be linked together as 
needed.    For example, you may create a standard help file of glossary definitions that can be 
used with the help files of many different applications.

Links between different hypertext files are created using extended links.    Extended links also 
allow you to display a target topic in a secondary window.

To link a topic from one hypertext file to another, you first select the area you wish to link. Then 
use the Extended link command from the Link menu.    For the complete procedure, see 
Creating an Extended Link.

Related Topics

Link menu
Using the floating menu
Defining window properties



Executing your help file

 WYSI-Help Composer offers a function which automatically opens the current .HLP file in the 
Windows Help engine provided it has been saved, converted and compiled beforehand.

Procedure

1. Ensure that "Convert on save" has been selected in the Display options dialog box.

2. Select the Save command from the File menu, (ALT, F, S), or click on the Save topic  
button on the toolbar .

3. Answer yes to the two queries to convert and compile your hypertext file.    This may take some time 
but is a necessary step.    Use the Preview mode if you do not need to test macros.

4. Select the Execute help file command from the File menu, (ALT, F, H), or click the Test  
button on the toolbar to test you hypertext file. 

Note
The Execute help file option and its icon will be dimmed, if WYSI-Help Composer cannot find
a corresponding .HLP file.

If you haven't compiled your hypertext file, or if you forget to compile the latest changes, WYSI-
Help Composer will display a dialog box asking if you want to do so now.

Clicking on OK will use the help engine to display the last .HLP file produced. Clicking on 
Cancel will cancel the operation and restore the main window of WYSI-Help Composer. You 
may then compile the latest changes and select the Execute help file command again.

Related Topics

File menu
Previewing your hypertext file
Saving a hypertext file
The toolbar
Printing a hypertext file



The Preview Feature

WYSI-Help Composer offers a new feature, allowing you to view your hypertext file as it would 
appear in a Help window. This can save you valuable time when working with a hypertext file 
containing a few hundred topics because the preview feature doesn't require the hypertext file 
(*.DHF) to be compiled in order to see the changes.

Because the Preview mode does not use the Windows Help engine, any macros and some RTF 
commands in your help file will not execute and most of the buttons and menus are not active.    
To just test your macros, RTF commands, menu items and buttons without compiling your whole 
help file, check out the How do I do a partial compile section.    

Procedure

1. While editing your hypertext file, choose a topic you wish to preview.

2. Choose the Preview command from the File menu, or click on the Preview  button 
on the toolbar.

3. The selected topic will appear in a help window.

4. You can verify the links you have created with active hypertext jumps and pop-up links as you would in
a normal help window. 

Related Topics

File menu
Saving a hypertext file
The toolbar
Printing a hypertext file



Preferences    menu
Click on a menu item to get help on that item.



WYSI-Help Composer's main window

WYSI-Help Composer's main window contains all the elements you'll need to create professional
looking help files. Click in the picture below to learn more about the features in the main window.



Hypertext jumps

This is a sample hypertext jump. This topic is long enough to require its own window. The text 
below was used to lengthen this topic to provide as an example.

WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP 
COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. 
WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP 
COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. 
WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP 
COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. 
WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP 
COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. 
WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP 
COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. 
WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP 
COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. 
WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP 
COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. 
WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP COMPOSER. WYSI-HELP 
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Renaming a topic

You may wish to change the topic name of a particular topic during the development of your 
hypertext files. The technique for doing this is discussed here.

Procedure

1. Make the topic whose topic name you wish to change the current one.

2. Select the Qualifiers command from the Topic menu.

3. In the Topic Qualifiers dialog box,    type the new topic name in the Topic name 
(Context string) edit box.

4. Click the OK button to confirm the modification you have made.

Click in the picture below to learn more about a command or an element of the dialog box.

Note
WYSI-Help Composer will display a warning message if you try to enter a Topic name that 
already exists.

Changing the name of a topic will not change its title or search keywords. You will have to do this 
manually.

Changing the name of a topic will not affect any links to the topic.    They will automatically be 
updated.

Related Topics

Composing a topic
Editing a topic
Topic menu



Automatic link
By default, the text you selected to transform into a link will be saved and added to the list of 
reference expressions for the purpose of automatic link generation. You may choose, however, 
not to add expressions to the list by removing the check mark from the box labeled Memorize 
link.



Hypertext edit button
Once you enter a new hypertext link name or select one from the list, click on the Edit button to 
bring up the target topic into the Main Window.



Hypertext link name
Choose a name from the list or enter a new link name. The currently selected text or image will 
be the link to this topic.



Hypertext topic name
Choose an existing hypertext topic name to link the currently selected text or image. 



WYSI-Help Composer's Toolbar

WYSI-Help Composer provides you with a toolbar containing most of the commonly used 
commands. Place the cursor over the button icon and click to execute the command. Each button
command can also be accessed from the menu bar.

To get a description of the command attached to a button, navigate the cursor over the toolbar. A 
short description will appear on the title bar or as balloon help.

Related Topics

 Button commands



Alignment
You may select the type of alignment you require by clicking on one of the radio buttons under 
this heading. Left or right alignment will allow lines of text to be written along the whole length of 
the image. Floating alignment only allows a single line of text to be written to the side of the 
image. Aligning an image to the left or the right will also insert a special symbol into the topic 
called an aligned bitmap entry point. 



Example box

An example of the alignment you selected will be displayed (left, center or right).



File name
This edit field contains the name of the file which stores the current image if it is a reference or 
hypergraphic image. For internal images the contents of this field will be empty or dimmed.



Type
An image taken from the clipboard or captured using the screen photo utility will be an internal 
image. An image containing linked zones inside it, will be classified as a hypergraphic image, 
and stored in a .SHG file. A reference image is stored in a separate .BMP file.



Duplicate topics

Some of the topics you have selected to import could have the same names as those already in 
the current file. The following options let you select the mode of action to take place in this 
situation.

Ignore - click this button if you don't want the existing topic to be replaced by the one to be 
imported.

Replace - selecting this option will replace any existing files with ones to be imported if they 
share the same name.

Manually - selecting this option will allow you to decide what action to take for each case of a 
duplicate topic. A dialog box will appear giving you the option to    Replace or Rename options.

Replace - Replaces the topic already in the current hypertext file with the topic to be imported.

Rename - Type a new name in the topic to be imported text box, to rename the topic from
the target file.



Import
Click on this button to start the import process of the topics you've selected.



Select all
Check this box to select all of the topics in the list.



Topics list
This is a list of all the topics contained in the hypertext file that you selected in step 3.



Increase/decrease
Click on the left arrow to decrease the distance by one pixel or the right arrow to increase by one 
pixel. You can type the desired measurements directly into the position boxes.



Help index
Choose the Help index command to view the index of contents of WYSI-Help Composer's help 
file.



Initial style
When opened, this menu contains a list of examples of all of the current styles. Selecting one of 
these using the mouse will close the menu, displaying only the selected style in the box which 
remains. This style will then be used for the first paragraph of text in every new topic.

If you don't define an initial style to use automatically, a default style will be used by WYSI-Help 
Composer which has the attributes Arial, Normal, 10.



Insert menu
Click on a menu item to get help on that item.



WYSI-Help Composer

WYSI-Help Composer lets you create on-line help for your company specific needs. Build on-
line tutorials, reference documents, product demos, electronic brochures and Multi-media 
presentations. WYSI-Help Composer generates both RTF and HLP format files. The HLP 
file is displayed by The Windows Help engine (WinHelp.exe) which is part of the Windows 
Operating System.

WYSI-Help Composer allows you to insert text, images, hotspot images, sound files, etc. 
and link them to pop-ups and jumps containing related topic information.

Sample pop-up box linked to a hotspot on the image. Pop-ups are used for brief    definitions or 
descriptions.

You edit your topics in a similar fashion as you would in a word processor. Then link the topics 
via pop-ups, hypertext jumps, sound or other help files.

Pop-up

Hypertext Jump

External Applications

Other Help Files

RTF File Import



WYSI-Help Composer has a unique feature that lets you import existing RTF files created with 
your word processor or desktop publisher. This feature divides an entire RTF document into 
multiple topics to instantly create your help files.    

Click on the Back button, , or use the History button, 

, to return to the topic you came from.

 UDI Software

(800) 289-1948 in the U.S. and Canada,
(415) 382 8840 or fax at (415) 382-8868.



Keystrokes

This topic lists all of the commands available in the WYSI-Help Composer. Depending on your 
personal preferences, you can use either the menu command, the button on the toolbar or the 
keyboard equivalent to carry out a command. There isn't a button available for all menu 
commands. NA stands for 'not available'.

Menu Command Button Keystrokes

FILE

File-New NA ALT+F+N

File-Open ALT+F+O

File-Save ALT+F+S
File-Save as NA ALT+F+A

File-Print ALT+F+P
File-Print Setup NA ALT+F+R
File-Project Editor NA ALT+F+E

File-File Macros ALT+F+F

File-Navigate ALT+F+G

File-Preview ALT+F+V or F10

File-Execute Help File ALT+F+H

File-Spell Check ALT+F+L
File-Exit NA ALT+F+X

EDIT

Edit-Undo ALT+E+O or CTRL+Z

Edit-Cut ALT+E+T or CTRL+X

Edit-Copy ALT+E+C or CTRL+C

Edit-Paste ALT+E+P or CTRL+V
Edit-Delete NA ALT+E+D or Del key
Edit-Edit RTF NA ALT+E+F 

Edit-Hypergraphic ALT+E+H

Edit-Image ALT+E+I
Edit-Search NA ALT+E+S
Edit-Replace NA ALT+E+R
Edit-Search next NA ALT+E+N or F3
Edit-Replace next NA ALT+E+E or F4

FORMAT

Format-Attributes NA ALT+F+A
Format-Paragraph NA ALT+F+P



Format-Image NA ALT+F+I

Format-Apply Style ALT+F+Y

Format-Define Style ALT+F+Y
Format-Modify Style NA ALT+F+M
Format-Delete Style NA ALT+F+L
Format-Default Style NA ALT+F+D
Format-Hypertext Style NA ALT+F+H
Format-Pop-up Style NA ALT+F+O

INSERT

Insert-Image NA ALT+I+A
Insert-Hypergraphic NA ALT-I-H

Insert-RTF Command NA ALT+I+R
Insert-Non-Breaking Space NA ALT-I-N or CTRL+Space
Insert-Line Break NA ALT+I+L or Shift+RET
Insert-Screen Photo NA ALT-I-S

TOPIC

Topic-New Topic ALT+T+N
Topic-Rename Topic NA ALT+T+R
Topic-Delete Topic NA ALT+T+D
Topic-Import Topics NA ALT+T+I
Topic-Non-Scrolling Region NA ALT+T+S
Topic-Topic Macros NA ALT+T+T
Topic-Properties NA ALT+T+P
Topic-Title/Search Keywords NA ALT+T+K

LINK

Link-Hypertext ALT+L+H

Link-Pop-up ALT+L+P

Link-External Programs ALT+L+E
Link-Macro NA ALT+L+M

Link-Sound ALT+L+S

Link-Extended Links ALT+L+X
Link-Link Properties NA ALT+L+L
Link-Delete Link NA ALT+L+D
Link-Jump to Link NA ALT+L+J
Link-Automatic Generation NA ALT+L+A
Link-Edit Auto Link NA ALT+L+I
Link-Regenerate Links NA ALT+L+R

Link-Delete Certain Links NA ALT+L+T

SEQUENCE

Sequence-Next Topic NA ALT+S+N
Sequence-Previous Topic NA ALT+S+P
Sequence-Insert Topic After NA ALT+S+A
Sequence-Insert Topic Before NA ALT+S+B
Sequence-Delete from Sequence NA ALT+S+D



Sequence-Delete Sequence NA ALT+S+S
Sequence-Cut After NA ALT+S+C

PREFERENCE

Preferences-Save NA ALT+P+S
Preferences-Display NA ALT+P+D
Preferences-Other NA ALT+P+O

HELP

Help-Index ALT+H+I
Help-Settings NA ALT+H+S
Help-About NA ALT+H+A



Left margin
The value in this box represents the distance of the left margin from the left edge of the window, 
measured in pixels. You may alter this value using the increase/decrease buttons situated next to

the box,  , or you may place the cursor in the text box and type in a new value.

The minimum value for the size of the left margin, is zero pixels from the left edge of the window. WYSI-Help 
Composer will warn you if you try to enter a value below this limit.



Display window
For most types of links this field will be dimmed and contain the word "main", meaning that the 
main window is used. For extended links this field may contain the name of a secondary window, 
but for pop-up links the field will be empty.



Help file
This field will only become active in the case of extended links, where the name of the file 
containing the target topic will be given.



Target
This information field contains the target of the link selected.

- In the case of hypertext, pop-up and extended links this will be a topic name.
- For external program links a program name will be given.
- For macro links a macro name will be given, together with its parameters.
- For sound links the name of the sound file will be given.



Link type
This information field contains the type of link selected.



Add current definition 

To add a macro to the current definition, ensure the cursor is positioned at the end of the text in 
the current definition field. Click on the Add to current definition button. The macro 
currently selected from the list will then be placed at the end of the current definition. 

To replace one macro in the current definition with another macro selected from the list the cursor
must be positioned somewhere between the start of the macro and the following semi-colon (if 
one exists). Clicking on the Add to current definition button will then cause the message 
"The selected macro will replace the existing one" to be displayed. Clicking on the OK button will 
carry out the replacement operation, while clicking on the Cancel button will cancel the 
operation. 



Current definition
To replace one macro in the current definition with another macro selected from the list, the 
cursor must be positioned somewhere between the start of the macro and the following semi-
colon (if one exists). Click on the Add to current definition button. The message "The 
selected macro will replace the existing one" to be displayed. Clicking on the OK button will 
replace the macro while clicking on the Cancel button will cancel the operation.



History
The history list contains a list of the last ten macros added at this level. You can select a macro 
from this list    and add it to the current definition. 



Macro list
The macro list contains a list of all the help macros already defined by WinHelp. This list may be 
scrolled using the scroll bar provided or by using the cursor keys.



Parameter list
The parameter list contains a list of the parameters which must be entered for the current macro 
to be valid.



Status bar
The information bar, situated at the bottom of the dialog box, contains information concerning the 
cursor position within the current definition entry field. Error messages will also be displayed in 
this bar if the current definition becomes invalid. For instance, if you type an illegal value for a 
parameter. The error message will also include a position reference referring to the position of the
error in the current definition.



Creating a macro link

Macros are commands which you may use to extend the possibilities of your hypertext files. Two 
kinds of macro exist. First, a choice of macros are provided for you by WinHelp. These are 
generally involved with defining new buttons or menu items which will be displayed in the help 
window. However, it is also possible to create your own macros.

WYSI-Help Composer permits you to create a link from an image or a region of text to a macro. 
Here the macro will be executed when the final user clicks on the sensitive region with the mouse.

Procedure

1. Select a block of text or an image.

2. Select the Macro command from the Link menu.

3. Select the macro command(s) you wish to associate with the link.

Click in the picture below to learn more about a command or an element of the dialog box.

The information bar, situated at the bottom of the dialog box, contains information concerning the 
cursor position within the current definition entry field. Error messages will also be displayed in 
this bar if the current definition becomes invalid, for instance, if you type an illegal value for a 
parameter. The error message will also include a position reference referring to the position of the
error in the current definition.

Note
Certain help macros, in particular those which remain active until the hypertext file is closed, are 
unsuitable for use in macro links. In this case, when a macro link is first used the macro will be 
executed properly, but then if the user clicks on the macro link again, WinHelp will try to execute 
the same macros again. This will not be possible and so an error message will be displayed. Such
macros to avoid using in macro links include those which add buttons to the button bar, or menu 
items to the menus in the WinHelp window.

Related Topics

Using Help macros
Link menu



Make default
Clicking on this button will store the current paragraph definition as the default one. Hence all the 
information concerning paragraph alignment, page margins, first line indentation, tab stops etc. will be 
used for all new paragraphs.



WYSI-Help Composer main menu
Click the individual menus in the picture below to reveal the sub-menus and their functions.



WYSI-Help Composer menu bar

The menu bar displays the names of the main menus. You can access any of the WYSI-Help 
Composer commands from these menus, or use the corresponding button on the    toolbar. The toolbar
appears in the middle of the Main Window and provides for quick access to the most frequently 
used commands.

Related Topic

Menu commands



Browse button
Use the browse button to locate the graphic editor you wish to use when clicking on the graphics 

editor button on the toolbar. Click on the browse button to display the Windows Browse 
dialog box, and select a directory and executable application.



Browse button
This button allows you to browse the directory to locate the correct file.



Path for the graphic editor of your choice

Enter the path for the graphic editor you wish to use when clicking the graphic editor  button 
or selecting the Edit Image item in the Edit menu    while editing a Topic. Use the Browse button 
to find the application.



Language selection
WYSI-Help Composer's spell checker supports the US English language only. Although it has the
ability to use other languages, and other languages are listed here, they are not enabled. Contact
UDI Software for pricing and information on foreign language dictionaries at (800) 289-
1948 in the U.S. and Canada, (415) 382 8840 or fax at (415) 382-8868. 



Modify
Select a style to modify and click the Modify button. This button will remain dimmed until you 
have selected a style to modify. Clicking on this button will open the Font dialog box allowing 
you to modify the style you have chosen.



Navigator

WYSI-Help Composer provides a Navigator to allow you to see the position of the topic you're 
editing in relation to the other topics you've created.    It provides a visual representation of you 
help file.    You can also use the Navigator to move quickly through the file. The Navigator shows 
the relationship of topics to each other by representing each topic as an icon    and connecting the
icons with lines if there is a hypertext link between the topics.

The Icons:
A topic with its links displayed.
A topic that has appeared in the edit window and has its links displayed.
A topic with its links not displayed.
A topic that has appeared in the edit window and does not have its links displayed.
A topic with no links to display.
A topic with no links to display that has appeared in the edit window.
A topic that is already being displayed closer to the root topic in the navigator window.

To have a topic appear in the edit window, double click on the text next to the icon in the 
Navigator.

To display the hypertext links, you click on the icons.    Clicking on a closed book opens it and 
displays the icons of topics that it is linked to.    To close the book and hide the linked topic icons, 
click on the icon again.    The topic at the top of the Navigator's display is the root topic.    Any 
topic can become the root topic by clicking once on the text of the icon (a dashed line appears 
around the text), and selecting New Root from the Tree menu.

The above description of displaying links is    for the Goes To mode.    Opening the book icon of 
a topic displays all the hypertext linked topics associated with this topic. Below, the "Topic Editor 
Main Window" topic has links that 'goes to' the topics "status_bar","Topics","Text_Area", etc.



 Another type of display is the Comes From mode in the Options menu.    In this mode, the 
topics that are displayed from an open book are all the topics that the open book comes from. 
Below, the "Topic editor Main Window" has links displayed that Comes from the topics 
"Topic_Editor" and "How do I use the topic editor".

These two modes give a graphical representation of the Comes from and Goes to lists in 
WYSI-Help Composer.    

Procedure

1. Select the topic you wish to edit from the Topics list.

2. Choose the Navigator command from the File menu or click on the Navigator  
button on the toolbar. 



3. A separate window will appear with a tree structure of your hypertext file. The window can be 

expanded by grabbing the sides of the windows or by using the minimize/maximize  buttons on the 
title bar.

4. Click on a book to display the associated links.

5. Double-click on the topic name you wish to display in the editing window of WYSI-Help 
Composer.

Related Topics

Jumping to a topic



New link name
This edit field may be used to define a new link name for the current topic. When the dialog box 
is first opened, it will contain the current link name as a basis for modification.



Add reference expression
By default, this box is checked. A reference expression is used by the automatic link generation 
function. Briefly, when this function is turned on, and you type in text that matches a reference 
expression, WYSI-Help Composer will convert it into a link to a specified topic.

When a check mark is present, the link name of the topic will be added to the list of reference 
expressions stored by WYSI-Help Composer automatically. By default, the link type will be 
hypertext and the target will be the topic that is being created. When no check mark is present, 
no information will be added to the list of reference expressions stored by WYSI-Help Composer.
You may modify the reference expressions associated with a particular topic using the option Edit
auto links contained in the Link menu.



Add title/search keyword
By default this box is checked to automatically create a title and a search keyword for the new 
topic. The title and search keyword will be identical to the link name of the topic. However, the 
name can be changed later if you wish.

If you remove the check mark from this box, the topic will be created without a title or a search 
keyword. Having a hypertext file full of topics and no titles or search keywords would not be very 
useful, because the final user would not be able to use the Search or History functions of the 
help engine. He/she will only be able to access the topics using hypertext links in this case.



Link name
You may enter the link name of the topic to be created in this text box. The WYSI-Help Composer
will not allow you to enter a link name that already exists.



New topic edit button
Once you enter a new topic name, click on the Edit button to display the new topic in the main 
editing window. 



Creating a new topic

This command creates a new topic for your help file.    

Procedure

1. Select the New command from the Topic menu, (ALT, T, N), or click the New topic  
button on the toolbar:

2. In the Create new topic dialog box,    type the link name for the new topic.

3. By default, the options Add title/search keyword and Add reference expression are selected, and the 
option Non-scrolling region is not selected. You may change these if you wish.

4. Clicking on the OK button will create the new topic according to the choices you made.

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Hypertext Links
Pop-ups Link
Inserting an Image
Inserting a Hypergraphic
Editing a topic
Renaming a topic
Deleting a topic
Printing topics from the WYSI-Help Composer
Setting up the printer
Importing topics
Changing a topic title
Modifying the list of search keywords
Generating links automatically
Editing the list of reference expressions
Display preferences



Printing topics from WYSI-Help Composer

The WYSI-Help Composer has a command allowing you to print the contents of topics. You may 
also define the order in which to print a selection of topics, and you can select other information 
to be printed with each topic, such as its position in a browse sequence, its list of search 
keywords, etc.    The help file has to be compiled before the topic can be printed.

Procedure

1. Select the Print command from the File menu (ALT+F+P), or click the Print  button on
the toolbar.

2. In the Print dialog box, select the topics you wish to print. You may also define the order in which to 
print them. 

3. If necessary, you can configure your printer by clicking on the Printer setup button.

4. Please note that WYSI-Help Composer must compile the hypertext file before it can print. When you 
are ready, clicking on OK will start compiling your hypertext file. The help engine is then launched, and printing 
will start.

5. For each topic to be printed, a dialog box will be displayed.

This dialog box shows which topic is currently being printed, and what information is being 
printed about it. If only the contents are being printed, then the word "Contents" will appear in the
box. If other information is also being printed, then the dialog box will be refreshed when this 
happens, and the word "Information" will replace "Contents". You may cancel the printing 
operation, either entirely or just for the current topic, by clicking on the appropriate button. Note 
that due to the nature of the printing process, canceling a print operation will not be immediate.

Click in the picture below to learn more about a command or an element of the dialog box.

Related Topics

Printer setup





Non-scrolling region
By default, no check mark is present in this box. Inserting one creates a non-scrolling region at 
the top of the new topic. The size of this region will be the default size specified in the Display 
preferences dialog box.



Next topic
If the current topic belongs to a browse sequence, then this box contains the name of the next 
topic in the sequence, if one exists. This box also contains a button to insert a topic into the 
sequence after the current topic.



Next style
When opened, this menu displays a list of examples for    all the current styles available. 
Selecting a style using the mouse will close the menu. This style will be used for all of the 
secondary paragraphs in every new topic.

If you don't define a next style to use automatically, WYSI-Help Composer's default style will be 
used    with the attributes Arial, Normal, 10.



Non-wrapping line
Check this box to transform the paragraph(s) currently selected into a single, non-wrapping line.



Number of paragraphs in the non-scrolling region
Enter a default value for the number of paragraphs to be included in the non-scrolling region of a 
topic. This value will not affect existing topics. Instead, it will be used for new topics which include
a non-scrolling region.



OK button
Press the OK button to execute the command selected in this dialog box.



Old link name
This information field contains the old link name associated with the current topic.



Other preferences 

WYSI-Help Composer lets you customize the language for the spell checker and the graphic 
editor you wish to use while editing your hypertext file. WYSI-Help Composer can make use of 
other language dictionaries. Contact UDI Software at 800-289-1948 for pricing on add-on 
language dictionaries.

Related Topics

Spell checking a document



Spell checking a document

WYSI-Help Composer has a built-in spell checker. First, it spell checks the current topic, then 
after the spell checker completes checking the topic, it prompts you to continue spell checking 
the next topic, all other topics or to stop spell checking.

Procedure

1. Select the topic you wish to spell check from the Topics list.

2. Choose the Spell check command from the File menu, or you can click the Spell check

 button on the toolbar.

3. When a misspelled word is flagged, the speller will display a dialog box with the incorrect spelled word,
the best suited replacement word as well as other suggestions you can choose from.
 

4. If the flagged word    is correct, click the Ignore button to continue spell checking the topic. 
If this is a specialized word, you may click the Add button to add this word to the user 
dictionary.

Note: You can not delete words added to the user dictionary.

5. If the word is misspelled and the correct replacement word appears, click on the Replace 
button. The incorrectly spelled word will be replaced with the new word displayed in the 
Replace by box. If the word displayed in the Replace by box is incorrect and requires 
editing, place the mouse cursor in the Replace by box and make the necessary 
corrections. When satisfied with the corrections, click the Replace button to replace the 
word in the topic or the Add button to replace it and also save it to the user dictionary.

6. If the flagged word is incorrect and the replacement word suggested isn't suitable, you may 
use another suggested word displayed in the Suggestions drop down box. Double click 
the word, or select the word and click the Replace button.

Related Topics

Replace command
Other Preferences 



Editing an Image with a Graphics editor

WYSI-Help Composer provides you with a way to quickly access Windows Paintbrush or any 
other graphics editor. Use the Edit Image command from the Edit menu, or the graphic editor

 button on the toolbar. 

If you use a different graphic editor, you can easily change the properties of the Graphic editor command to 
bring up your own editor instead. To change the graphic editor selection attached to the button, refer to Other 
preferences.

Procedure

1. Select the image you wish to edit with the graphic editor.

2. Choose the Edit Image command (ALT, E, I) from the Edit menu or click on the Graphic 

editor  button on the toolbar.

3. The selected image will appear on the desktop of the graphic editor you have selected. If you didn't 
change the Graphic Editor default, then Windows Paintbrush will be used.

Related Topics

Other preferences
Inserting an image
Inserting an image from the clipboard
Toolbar



Automatic link
By default, the text that you selected to transform into a link will be saved and added to the list of 
reference expressions for the purpose of automatic link generation. You may choose however not
to add this expression to the list by removing the check mark from the box labelled Memorize link.



Pop-up edit button
Once you enter a new pop-up topic name, or select one from the list, click on the Edit button to 
make this new topic the current one in the editing region.



Pop-up topic name
Choose a name from the list, or enter a new topic name. The currently selected text or image will 
be linked to this new topic name.



Pop-up topic name
Choose a    topic name to link the currently selected text or image. This list includes all the topics 
that have been created in the current hypertext file.



Previous topic
If the current topic belongs to a browse sequence, this box contains the name of the previous 
topic in the sequence. This box also contains a button to insert a topic into the sequence before 
the current topic.



Inserting a topic into a browse sequence

Once you have created a browse sequence, you can modify it by inserting more topics into it. 
The topic to be inserted will appear in the sequence adjacent to the current topic. 

Procedure

1. Make the current topic the one that you wish to insert another topic either before or after.

2. To insert a topic before the current topic, select the Insert topic before command from 

the Sequence menu, (ALT, S, B), or click on the arrow  
button situated to the left of the Previous topic box. Alternatively, to insert a topic after the 
current topic select the Insert topic after command from the Sequence menu, (ALT, 
S, A), or click on the arrow 

 button situated to the left of the Next topic box.

3. The Choose or Create the Next Topic    dialog box will open.    It contains a list of 
those topics which you may insert into the browse sequence. From this list, select the topic 
that you wish to place in the sequence.

4. Clicking on the OK button will restore the WYSI-Help Composer Main Window and confirm 
your choice. The name of the topic that you selected will now appear in the Previous/Next 
topic box as appropriate. Clicking on this name in this box will cause this topic to become the
current one.

Related Topics

Defining a browse sequence
Displaying the previous or next topic
Deleting a topic from a browse sequence
Deleting a browse sequence
Cutting a browse sequence in two
Editing a topic
Generating links automatically
Display preferences



Print button
Click this button to start printing the selected topics.



Printer setup command

 The Print setup command lets you select the printer you wish to use among those installed 
on your system and configure the printer specific options. 

Procedure

1. Select the Printer setup from the File menu.

2. The usual Windows dialog box for setting up your printer will open. (This will differ slightly 
depending on your version of Windows, hence it is not explained in detail here).

3. You may now specify your printer configuration. Clicking on the Options button will open 
another dialog box containing more setup options.

4. Click on the OK button when you have finished to store the setup    you have defined.

Related Topics

Printing topics from the Composer
File menu



Printer setup button
Click on the print setup button to change or configure the current printer.



Browse
You may click on this button to open a dialog box similar to the one used for the opening of a 
hypertext file. This will allow you to search your disk(s) and directories to find out where a 
particular program is located.



Name
Enter the name of the external program you want to link.



Parameters
Enter the parameters for the program when it is launched.    This is a command line parameter 
and depend on the program being launched.    If the program is a graphics editor, specify a 
graphics file for it to load.



Window
Choose the size of the window to be used by the external program when it is launched.



Selecting a help icon

WYSI-Help Composer allows you to associate an icon to the hypertext file that you create for use
when the final user minimizes the WinHelp window.    This is not the icon that appears in the 
Program Manager when an icon setup is performed for a help file.    That icon is the WinHelp.EXE
icon. 

Procedure

1. Select the Project Editor command from the File menu, (ALT, F, E).

2. Situated under the help interface section of the dialog box, there is an entry field where you 
may type the path and name of the file containing the icon that you wish to use.

3. If you do not know the exact path of the file you wish to use, click on the Help Icon button 
to open a browse dialog box. This is the save dialog that appears when you choose the 
Open command from the File menu.    This dialog box will enable you to locate the file 
contain the icon.

4. Once you have given a valid path and file name, the icon contained in the icon file will be 
displayed in the dialog box.

5. Clicking on the OK button will store the changes you have made and return you to the 
Composer main window. Clicking on Cancel will ignore the changes that you have made.

Note
This is not the icon that will appear in the Program manager.    That Icon is the WINHELP.EXE 
Icon.

Related Topics

Project editor command



Redo command
The Redo command from the File menu or the Redo  button on the toolbar is only 
available after you've used the Undo command. This command toggles between the two states 
depending on the last action.



First occurrence
Check this box to find only the first occurrence of a reference expression in each topic.



Regenerate all links
Check this box to select all of the reference expressions in the list. Removing the check mark 
from this box will deselect all of the reference expressions in the list.



Ask for confirmation
Checking this box will display a confirmation box to appear for each reference expression found 
in text of the hypertext during the search. The topic containing the matching expression will also 
be displayed, and the expression found will be highlighted.

From this box you may decide to transform the matching text found into a link, by pressing the 
Generate button, or skip this occurrence by pressing the Next button. You may also choose to 
stop the regeneration process by clicking on the Cancel button. Placing a check mark in the 
Cancel confirmation box will result in the rest of the regeneration process being totally automatic.



Current topic only
Check this box to include only the reference expressions associated with the current topic in the 
scope of the regeneration process.



Links
This box contains a list of all the reference expressions to be included in the regeneration 
process.    When the option Regenerate all links has been selected, all the expressions in this 
list will become highlighted. However, you may still modify the selection using the mouse. Doing 
so will remove the check mark from the Regenerate all links box.



Remove topics button
Remove the selected topic(s) from the list of topics to print.



Replace button
Click the Replace button to start searching the topic(s) for the expression to be replaced.



Replace by
Type the replacement string here. You may also define the type of the element to be used as a 
replacement, either text, a hypertext, or a pop-up link.



Replace command

WYSI-Help Composer can    search and replace for a string of text or a particular topic link, (for 
hypertext and pop-up links only).    

Procedure

1. Select the Replace command from the Edit menu.

2. In the Replace dialog box, type the text string to search for, the type of element to search for,
and the scope of the search. In the case of text, you may also define attributes to be used 
when comparing text in the topics with the search string.

3. If the search type is a hypertext search,    enter the name of the topic that is the destination 
of the link.

Click in the picture below to learn more about a command or an element of the dialog box.

3. Define the replacement string, and its properties. If the replace type is hypertext,    enter the 
name of the topic that will be    the destination of the link.

4. Select the options Ask for confirmation or Continue search if you wish.

5. Clicking on the Replace button will start the search/replace operation, while clicking on 
Cancel will cancel the operation and return you to the main window of the Composer.

Note
If a matching expression is found, and the option Ask for confirmation was selected, the 
matching expression will be highlighted and displayed in the editing region. If the Ask for 
confirmation option was not selected, the replacement will be performed automatically for first
match found. If the option Continue search was also selected, the search/replace operation 
will be totally automatic and all matches will be replaced.

If the search does not produce any matches, a dialog box will be displayed informing you that 



there are no more elements to search.

The search criteria you specify will be stored and displayed when you next select the Replace 
command.

Related Topics

Searching for an item
Searching for the next item
Replacing the next item



Search command

You may occasionally wish to find the location of a particular item of text. The WYSI-Help 
Composer    can automatically search for a string of text or a particular link, (for hypertext and 
pop-up links only).

Procedure

1. Select the Search command from the Edit menu.

2. The Search dialog box will open, to let you enter the string to search for its type, (either 
text, hypertext or pop-up link), and the scope of the search. You may also decide if the the 
search will be case sensitive, and whether matching expressions must be whole, or whether 
they can form part of a larger expression.

Click the picture below to learn about a command or an element of the dialog box.

3. If the search type is a hypertext link,    enter the name of the topic that is the destination of 
the link.

4. Click on the Search button to start the search, or click on Cancel to return to the 
Composer Main Window.

Note
If a matching expression is found, the Composer will display the topic containing the matching 
expression at the position of this match, and will be highlighted. The command Search next 
will become active, allowing you to continue the search from the last match found.

If the search does not produce any matches, a dialog box will be displayed informing you that 
there are no more elements to search.

Related Topics

Searching for the next item
Replacing an item
Replacing the next item



Next item command (Search command)

This command allows you to continue the search from the position of a successful match in 
previous search. 

Procedure

1. Select the Search next command from the Edit menu, or press the F3 key on the 
keyboard.

Note
When a search has found a matching expression, the Search next command    will become 
available, otherwise it will be dimmed.

If another match is found by using the Search next command, the Composer will display this 
matching expression in the editing region and highlight it, just as it does when using the Search 
option. The Search next option will remain active.    A dialog box will be displayed informing you if 
the search does not produce any more matches. The command Search next will become 
dimmed.

Related Topics

Searching for an item
Replacing an item
Replacing the next item



Next item command (Replace command)

To continue replacing items after the replace operation has found a matching expression, use the
Next item command. 

Procedure

1. After a replacement has taken place the Replace next command on the Edit menu will 
become active. You may select this option to continue the replacement or press the F4 key 
on the keyboard.

Note:
If you specified a confirmation when you defined the original replacement criteria, a confirmation 
box will be displayed for any matching expressions found using the Replace next command.

Related Topics

Searching for an item
Searching for the next item
Replacing an item



Right margin
The value in this box represents the size of the right margin from the edge of the window. You 

may alter this value using the increase/decrease buttons situated next to the box,  , or you 
may place the cursor in the text box and type in the new value.



RTF text
You may enter RTF commands in this editing region. For a list of RTF commands, see Using RTF
commands. You must enter the RTF command in lower case for it to be interpreted by the 
compiler.



Ruler
The Ruler is graphically describes the format of a paragraph.    It shows the amount of white 
space from each edge,    the tabs available for a paragraph and the alignment of the text in the 
paragraph.

Related Topics

Using the ruler



Sample font box
This box displays a sample of the text style you've created.

aAbBcCdDeEfF
aAbBcCdDeEfF

aAbBcCdDeEfF



Sample paragraph
The example presented here provides you with a visual sample of the paragraph format.



Scope
You may define the scope of the search to be either the current topic only or the entire hypertext 
file. In the latter case, the search will begin with the first topic.



Search button
Click the Search button to start searching the topic(s) for the expression.



Continue search
Check this box to continue the search/replace operation after each replacement performed 
without prompting you to continue after a successful find.



Search
To search for text, type in the string to search for.    To search for hypertext links, enter the name 
of a topic the links point to.



Form
If the chosen type of element to search for is text, then this group of options will allow you to 
specify further details of the text string to search for. The options are:

Word
Placing a check mark in this box will report only those matches which form whole words. If no 
check mark is present, then matches found which constitute only parts of words will also be 
reported.

A word is delimited by spaces, or by the following punctuation marks:
( ) { } [ ] , ; : . / ! ?

Upper/Lowercase
Placing a check mark in this box will ensure that the search will be case-sensitive with respect to 
the search string you entered.

Attributes
Placing a check mark in this box will allow you to define the text style which matching 
expressions must have if they are to be reported.



Explorer options

The Explorer gives you the option of making extra help features accessible to the end user.    By 
selecting the appropriate Explorer options, you can:

Add a Navigator window that the end user can access.

Give the end user full text search capabilities with and/or parameters.

Allow the user to print multiple help topics at once.

Allow the user to configure the colors that designate different kinds of hypertext jumps.

Once your help file is finished, you must provide certain Explorer files to the end user, along with your 
help file, to make these Explorer features functional.

When you click the Explorer options command, the dialog box shown below opens.    Click on each 
option in the dialog box to learn more about that option.

Related topics
Delivering the Explorer to the end user



Making the Navigator available to the end user

When you click the Explorer Options command and check the Generate indexes on save option, you 
can make a Navigator available to the end user of your help file.    The Navigator works similarly to the 
Navigator that is available to you within WYSI-Help Composer.

Once your help file is finished, you must provide certain Explorer files to the end user, along with your 
help file, to make this Explorer feature functional.

Here is a sample Explorer Navigator window.

Related Topics:
Explorer Basics
Delivering the Explorer to the end user



Making Full Text Search available to the end user

When you click the Explorer Options command and check the Generate indexes on save option, you 
can make topic text search available to the end user of your help file.    The user can search for one or 
more words or phrases within the help file.    When searching for multiple words and/or phrases, the 
user has the option of invoking "And," "Or" and "Not" parameters by pressing the appropriate button.

Once your help file is finished, you must provide certain Explorer files to the end user, along with your 
help file, to make this Explorer feature functional.

Here is a sample Explorer Search window.

Related Topics:
Explorer Basics
Delivering the Explorer to the end user



Allowing the end user to print multiple help topics
There are two ways to provide the end user of your help file with the ability to print multiple help topics 
in one print file:

1. Implement the WYSI-Help Explorer
2. Implement the multiple topic print feature

If you choose not to provide the other WYSI-Help Explorer features to your end users, but do wish to 
make the multiple topic print feature available, you may use the multiple topic print feature.    However, 
since the WYSI-Help Explorer adds more functionality to your help file, it is recommended that you use
Explorer.

Once your help file is finished, you must provide certain Explorer files to the end user, along with your 
help file, to make this Explorer feature functional.

When you click the Explorer Options command and check the Generate indexes on save option, you 
can make it possible for the end user of your help file to print multiple help topics in a single print job.    
The user may select one, several, or all topics in the help file to print at once.    To select more than 
one topic to print, the user would click on the first topic name, then hold down the CTRL key while 
clicking on the name of each additional topic to be printed.

The Explorer Print feature is especially powerful when combined with the Explorer Search feature.    
The end user can use the Search feature to Search for topics.    Afterwards, the Explorer Print window 
will display all of the topics found in the search.    This makes it easy for a user to print some or all of 
the topics containing related information.

Here is a sample Explorer Print window.    The highlighted topics are the ones selected for printing.

Related Topics:
Explorer Basics
Delivering the Explorer to the end user



Select topics
Select the topic(s) you wish to print. You can choose any of the topics listed in this box. To 
choose multiple topics to print, hold down the Ctrl key while selecting the desired topics with the
mouse.

Once all topics are selected, press the Right Arrow  button to place them in the 
Topics to print box. This may take a few minutes.



Sequence Menu
Click a menu item to get help on that item.



Show aligned bitmap entry points

Check this box to display the symbol for aligned bitmap entry points; . Only left or right 
alignment will display a marker entry point. Floating images, (the default) will not display any 
markers.



Show toolbar
This option determines whether or not to display the toolbar; 



Show images
Check this box to display the images you inserted into a topic. If the box isn't checked, a frame 
containing a filename will appear replacing the image.



Show non breaking spaces

Check this box to display    non breaking spaces. Non breaking spaces will appear as . When 
the box isn't checked, the non breaking spaces will behave as they should but will not be 
identifiable by the graphic, 

.



Show paragraph markers

Place a check mark in this box to display the paragraph symbols ( ) and line break markers,
 in the editing area.



Show RTF command entry points

Place a check mark in this box to display the symbols, , for RTF command entry points in the 
editing area.



Show ruler
Check this box to display the ruler.



Show tabs

Check this box to display the tabulation marks,».



Browse button 

Click on this button to open a Search dialog box. This will allow you to search your disk(s) and 
directories to find out where a particular sound (*.WAV) is located.



File button
Enter the name of the file containing the sound sequence here. Acceptable files have a .WAV 
extension.



Listen button
Once you have provided a valid name in the File entry field, this button will become active 
allowing you to listen to the sound file you have selected.



Play mode
Wait until finished
Disables mouse and keyboard input until sound has completed.

Background
Sound completes playing in the background.

Continuous play
Sound plays until another sound begins playing. 



Spell checker

Choose the Spell check command from the File menu or click on the Spell check  button in 
the toolbar to check the spelling of the selected topic. After the topic has been checked, you will 
be prompted to continue spell checking the next topic, all topics or terminate spell checking.



Status bar
The status bar provides the current topic ID and the total number of topics in your hypertext file 
and other relevant information.



Styles list
By default, this list contain an example of the style currently in use. You may open the list by 
clicking on the pull down button. This will display a complete list of the text styles defined so far. 
Clicking on one of these examples will select it, close the list, and display that particular 
example in the box which will be restored.



Text styles

Click the Style button on the toolbar to apply a text style to a selected block of text.



Short cut key assignment
This box displays the key assigned to the style or will be blank if no short cut key has been 
assigned yet. This is also where you place the cursor when assigning a character to a style.



Tab stop alignment
This group contains three radio buttons representing the alignment of tab stops. Choose a tab 
position in the Position box and select the alignment you wish to use. All tab stop positions are 
independent from each other. One tab may be centered while all others are left aligned.    



Tab stop position
Enter a value for the position of a new tab stop here. 

Below the text box is a list containing the tab stops already defined. These are identified by their 
position, as each tab stop has a unique position. Selecting a tab stop from this list will display its 
position in the text box and the appropriate alignment radio button will be selected. 

The numbers are in pixels.    There are approximately 100 pixels to an 1 inch.



Text alignment
You may change the alignment of the paragraph(s) currently selected by clicking on one of the 
radio buttons in this group.



WYSI-Help Composer editing region

This is where you type the text and insert images for your help project.    What appears in this 
region is governed by the Display Options dialog box.    The appearance of    Paragraph symbols 
and tab markers is an example of the control you have over the editing region.

¶ A paragraph symbol represent a line break at the end of a line of text.

» Two right arrows represent a tab marker.

Related Topics

Editing a Topic File
Composition of a topic
Display preferences



Title bar
The title bar contains the following information:

The name of the application, the hypertext file and topic currently selected. The title bar also 
includes the Control-menu and minimize/maximize buttons.



    WYSI-Help Composer 2.1
Help Contents



Allowing the end user to configure display colors for hypertext 
links

When you click the Explorer Options command and check any of the options, you can make it 
possible for the end user of your help file to customize the display colors for hypertext jumps.    This 
allows the user to see at a glance the types of links in each topic.    The end user can define custom 
display colors for hypertext jumps, popups, interfile (extended) jump links, interfile (extended) popup 
links, and help macro links.    Links to programs and sound files will appear as help macro links since 
they are executed via help macros.

Once your help file is finished, you must provide certain Explorer files to the end user, along with your 
help file, to make this Explorer feature functional.

Here is a sample Explorer Colors window.

When a user clicks any of the buttons in the Explorer Colors window, a dialog box appears which allows the 
user to choose the display color for the type of link named on the button.    The picture below is an example of 
the dialog box that opens when the Hypertext button is pressed.

Related Topics:
Explorer Basics
Delivering the Explorer to the end user



Topics to print
The topics listed in this box have been selected to print. To deselect certain or all topics, you 

must select them here and press the left arrow  button to keep them from printing.   
To choose multiple topics to print, hold down the Ctrl key while selecting the desired topics with 
the mouse.



Topics list
This list contains the link names of all of the topics in the current hypertext file. A vertical scroll 
bar will appear when necessary to allow you to view the entire list.



Running the Microsoft Help Compiler in full screen

If you cannot see the error messages being displayed during the compilation because the 
window is too small, you can use the PIF editor to make it full screen.      A recommended method
for viewing the errors generated during a compile is to create an error log.

Procedure

1. In Program Manager, double click the Main group Icon.

2.  Double click the PIF Editor icon.

3. In the PIF Editor, choose the Open command from the File menu.

4. In the File Open dialog box, locate the directory that contains the WYSI-Help files and 
choose the file WHTOHL.PIF.

5. Change the display usage from Windowed to Full Screen.

6. Save the change by selecting the Save command from the File menu..

The next time you compile your hypertext file, the full DOS window will appear. In full screen 
mode, you should be able to read all error messages displayed by the compiler.    



Undo button

Use the Undo command on the Edit menu or the Undo  button on the toolbar to reverse 
the previous editing action.



Up button
Select a topic from the list of topics to print, then press the Up button to move it up the list so it 
appears in the order of your choice.



Choose a font

Changes the font of selected text in a topic.

This command changes the font of the selected text, but it does not change the font specified in the
paragraph style.

To change a font:

1. Select the text to change.

2. Choose the Attributes command from the Format menu. The Font dialog box appears 
with the current font highlighted. Choose the new font from the Font list. 

3. Click OK. The new font is then applied to the selected text.

Alternate Procedure

If you've previously created a style for a block of text, this style is also available for other sections of
text in the file. You can apply a style to the selected text to change the font. 

Related Topics

Defining a style
Modifying a style



Preparing a new topic to have a non-scrolling region

When creating a new topic, you may specify topics to have a non-scrolling region. A non-scrolling 
region lets you create a header/title at the top of the topic that is fixed in the display window.

Procedure

1. Select the New topic command from the Topic menu (ALT+T+N), or click the New topic

 button on the toolbar.

2. To create a non-scrolling region for the new topic, check the box labelled non-scrolling region in 
the create new topic dialog ( ALT+N).

3. After you have defined the other values for the new topic, you may click on OK or Edit to confirm the 
details given and to create the new topic.

4. As you are editing the new topic, the solid black line representing the lower boundary of the non-
scrolling region will appear once the number of paragraphs in the topic exceeds the number specified as the 
default value for the size of the non-scrolling region.

Note
You may change the default value by selecting the option Display from the Preferences menu.
In the Display options dialog box contains the current value for the default size of the non-
scrolling region. You may change this by simply entering a new value and confirming the change by
clicking on OK.

You may change the size of the non-scrolling region for this particular topic by selecting the Non-
scrolling region command from the Topic menu.

Related Topics

Topic menu
Creating a non-scrolling region for a topic
Removing a non-scrolling region
Display preferences



Inserting file macros

Two methods of inserting file macros exists. You may use the Macro Editor or you may also use 
the Project Editor in file mode to associate macros to hypertext files.

Procedure 1

1. Open the file you want to associate the macros with.

2. Select the File macro command from the File menu, (ALT, F, F).

3. You may now modify the current definition as you wish, clicking on the OK button when you 
have finished to save the changes, or clicking on Cancel to ignore them.

Click in the picture below to learn more about a command or an element of the dialog box.

The information bar, situated at the bottom of the dialog box, contains information concerning the 
cursor position within the current definition entry field. Error messages will also be displayed in this 
bar if the current definition becomes invalid. For instance if you type an illegal value for a 
parameter. The error message will also include a position reference referring to the position of the 
error in the current definition.

Procedure 2

1. Ensure that the file to be modified is the current file.



2. Select the Project editor command from the File menu, (ALT, F, E).

3. Clicking on the File button will put the Project Editor into file mode.

4. In the [CONFIG] section of the help project file you may now enter some file macro 
definitions, or modify existing definition. No error checking will occur when entering macros 
with this method.

Note
Certain rules exist regarding the format of macro definitions in help project files, and these must be
observed to avoid compilation errors later on.

- A line in the [CONFIG] section may not exceed 254 characters in length, although there is no 
limit on the number of lines allowed.

- The WinHelp compiler has a limit of no more than three nested macros.

Related Topics

Using Help macros
Inserting topic macros
Creating a macro link
Project editor



Help settings

WYSI-Help provides certain levels of control in the way it displays its context sensitive help. You 
can choose to have the context sensitive help displayed in the title bar or in a balloon beside the 
menu item. You may also customize the color and the style of text.

1. Click on the Check Box next to Display to disable/enable the short help display

Click in the picture below to learn more about a command or an element of the dialog box.



Topic name (context string)
This edit box contains the name of the current topic name. This is the name you assigned to the 
topic when you created the new topic. To rename the current topic, enter a new topic name in this 
box.



Topic title keyword
You may type a new title here or leave it unchanged. This is the title of the topic the will appear in 
the Topics    Go To field at the bottom of the WinHelp Search dialog box. 



Topic Qualifiers

Topic Qualifiers allows you to modify topics name, ID, search keywords and title.

Topic name is the name that will appear in the Topics list.

Topic ID is the context ID used by WinHelp for context sensitive help.

Search keywords are the expressions that the user will be using to search the content of your 
help file. The topic title is the expression that will display when the user clicks the Go To button 
after selecting a keyword. The search keywords and topic title selected for your help file will be 
displayed in the Windows help engine Search dialog box. 

Topic title is name listed in this box is the topic title that will display in the Windows help Search 
dialog box once you have typed a search keyword and click the Go To button in the dialog. This
title will only appear in the Windows help engine. By default, the WYSI-Help Composer uses the 
topic name you selected when you created the topic as search and title keywords.

Procedure for Modifying Search Keywords

Once you have selected a keyword, you click the Go To button to see all the topics related to the 
keyword. The search keywords are descriptions of a function or an action. For example, the search
keywords for a topic discussing the creation of a paragraph style could be as follows:

Paragraph style
Creating a paragraph style
Styles

A single topic can have multiple search keywords as shown in the example above. You select the 
keywords the user of your help file would be most likely to search for. 

Not every topic in your help file, however, will have a title and search keywords. Topics with    
limited information should not have search keywords. They would only clutter the list of search 
keywords. Only the topics containing information the user of your help file will search for should 
have title/search keywords.

Procedure

1. Select the topic for which you want to assign a title and search keywords.

2. Choose the Title/search keywords command from the Topic menu.

3. Enter the expression you wish to assign to the topic as a keyword and click the Add button. 
You can enter multiple keywords for any topics.

4. To remove a Search keyword, select it from the list by clicking once on it. Then click the 
Delete button. The search keywords will be deleted from the list.

5. To assign a topic title, enter a new title in the Topic title edit box and click the OK button.

Related Topics

Renaming a topic
Composition of a topic
Editing a topic
Topic menu





Title
Placing a check mark in this box will result in the title of the topic being printed.
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Accelerator
Alignment
Attributes
Auto save
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Bitmapped Graphic
Bold
Bookmark
Border
Browse Sequence
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Clipboard
Context Sensitive Help
Control Menu Box
Convert
Copy and Paste
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Default
Destination Link
Dialog Box
Directory
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External Program Links
Edit Field
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Field
Font
Footnotes
Function keys
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Graphic
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Hanging Indent
Header
Help Engine
Hot Spots Editor
Hourglass
Hypergraphic
Hypertext Link
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Icon
Import
Insertion Point
Italic

J

Jump

K

Keywords
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Macro
Main_Index
Main Window
Margins
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Non-Breaking Space
Non-Scrolling Region
Non-Wrapping Line
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Paragraph style
Paragraph symbols
Path
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Point
Popup Link
Preferences
Properties
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RTF (Rich Text Format)
Ruler
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Screen Photo
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Select (block)
Short Cut Key
Short Help Message
Status bar
Style
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Title Bar
Toolbar
Topic
Type style
Typeface
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Windows Controls Menu
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User dictionary
The file name displayed in this box will be used as the user dictionary when spell checking a 
document. The user dictionary contains words specific to a project you added during spell checking
a document. The default is userdict.eng. 

Note:
The user dictionary cannot be edited.



Main Dictionary
The file name displayed in this box is the name of    the main dictionary used during spell checking. 
The default is usa86.lex.



Most used words
The file name displayed in this box contains the most common words of the language selected. The 
default is eng16.clx.



A shortcut for accessing a menu command. For example, the accelerator command for saving a 
hypertext file is ALT+F+S.



A way a line of text is placed in a window. The options are alignment left, alignment center or alignment 
right.



Bold, italic, underline, font or point size make up the attributes of a text.    Select some text and modify 
their Attributes to change their appearance on the screen.



When this feature is selected, WYSI-Help Composer saves the current hypertext file into a backup file 
every 5 minutes as you work.    Use to the Save command to update your original file.



A graphic figure composed of dots or pixels (picture elements). WYSI-Help Composer treats bitmapped 
graphics as single objects, shown in their actual size.



Typeface that is darker and heavier than standard typeface.



A WinHelp feature that lets you mark certain topics as a references. These references can be accessed 
from the Bookmark menu in Windows Help.



A green line placed around an image when the    Highlight bitmap links option is selected. This option 
can be found when you select    the Display command from the Preferences menu.



A holding place for temporarily storing cut or copied text, or images while editing a hypertext file.    The 
contents of the Clipboard may be moved to any application that supports the Clipboard.



Specific information or procedures about a command available online for the user of an application. This
type of help can be accessed when selecting the command, in combination with a certain keystroke.



The small box located to the left of the Title Bar in the Main Window. You can click this box to display the
Control menu or double click it to exit the application.



Converting a file from one format to another. For example, when you open an RTF file, WYSI-Help 
Composer converts the RTF file to the DHF format.



Commands used to copy a section of text or an image to the clipboard, and then paste it in a different 
location in the topic, a separate topic or a different hypertext file.



Commands used to remove a section of text or an image from the original location, place it on the 
clipboard and then move it to a different location in the topic, a separate topic or a different hypertext 
file.



An option, command or device that is pre-selected by the system. For example, in most dialog boxes 
that contain command buttons, one of the buttons is selected (pushed in) when the dialog box appears. 
That selection is the default. You can override a default by selecting another option, command or device.
You can change some of WYSI-Help Composer defaults under the Preference menu.



The topic that a link is pointing to is the destination link. For example, in a link from topic 1 to topic 2, the
destination link is topic 2, as it originates from topic 1.



A box that appears when the WYSI-Help Composer needs more information before it can carry out a 
command, or when the WYSI-Help Composer provides you with certain information.



An area on the disk for storing files.



A link to an external executable application. It can be a Windows application, such as the Windows 
Calculator or Calendar.    It can also be a Windows video sequence player.



An element in a dialog box where you can modify what is presented to you.    An edit field appears filled 
with a default value or is blank for the user to enter a value.



A set of characters in the same type face and size. The set includes letters, punctuation and symbols.



In a Help File, the footnote acts as a the location to store information that applies to a single topic. 



The keys labeled F1, F2, F3, and so on the keyboard. The function key, F1, is used by most applications
to bring up online and context sensitive help.



A form of indentation in which all the lines except the first line in a block of text are indented.



A graphic is an image or picture.    A graphic can be edited in a graphic editor application.



Information that appears at the top of a topic. You can consider the non-scrolling region of a topic as the 
topic header.



The Help Engine is provided with Microsoft Windows (WinHelp.exe). This is the application that runs the
help file you create with WYSI-Help Composer.



The Hot Spot Editor (SHED.EXE) is the application provided with WYSI-Help Composer to create and 
edit your hypergraphic images. Hypergraphic images have hot spots or areas your user can click on to 
get additional information.



The symbol that appears on the screen to tell you the system is performing the operation you requested.
You can't perform other operations while the hourglass is displayed.



An image containing certain area or hot spots a user can click on to get additional information or to 
trigger an action. The hot spots can be linked to pop-ups, hypertext jumps, sound sequences, macros or
external applications.



Hypertext links associate one topic to another topic. The target topic is a full window with vertical scroll 
bars if the text exceeds a single window. The text where the link originate appears a green underlined 
on screen.



A graphic representation of a file or an application that appears on the screen. Clicking the icon with the 
mouse lets you access the file or the application.



A part of the Composer's Main Window. It displays buttons that execute commands. The toolbar doesn't 
contain all commands, but some common ones.



The translation of a different file format to the WYSI-Help Composer file format. For example, importing 
an RTF file will translate the RTF file and bring it into the current WYSI-Help Composer file in a format it 
can understand.



The flashing vertical line or block that indicates where the text will be inserted. When you type, the text 
appears to the left of the insertion point, which is pushed to the right as you type.



A type face that reflects some of the elements of handwritten script. Italic typefaces slant to the right.



A link to a help topic. When the user clicks on the text or image associated with the jump link, Help 
replaces the currently displayed topic with the Help Topic specified in the context string.



Keywords are descriptive names you assign to topics so that the users of your help file can quickly 
locate the information they are looking for. A topic may have multiple keywords associated with it to 
enhance its availability. 



A link connects one part or element of a topic to another topic, a sound sequence or an external 
program. 



Main_Index is the name of the first topic in a hypertext file. This is the first topic to display when the Help
Engine opens up the help file.



A defined set of attributes that determines the appearance of the text in a paragraph.



The main window that appears when you start WYSI-Help Composer. It contains the workspace, the 
menus and tools necessary to create hypertext files (help files).



An object is any part of a topic or topic element. For example, the selected text or image linked to 
another pop-up box is an object of the first topic.



The path tells WYSI-Help Composer the drive and directory where a file is located. The path normally 
includes the drive letter, a directory and file name (e.i. C:\WYSIHELP\TOPIC.DHF).



The margins are the amount of white space on the left and right sides of the Help Window.    



A sequence of actions that are saved and stored into a file. WinHelp will execute the sequence of 
actions when a user selects it.



WYSI-Help Composer symbols you can display or hide on-screen to make text editing easier. These 
symbols include carriage returns and tab characters. The paragraph symbols are not printed and do not 
display in WinHelp.



The smallest modifiable element (an object or a dot) in a screen display or on a printed page.



The size of a font is measured in points (a point is 1/72 of an inch or 72 points equals one inch).



This type of link is associated to a pop-up topic. In other words, the destination topic is a pop-up box.



Preferences are a group of program defaults that can be set by the user. Options such as display 
paragraph symbols, convert hypertext file after saving, etc.



A graphical device for moving vertically and horizontally through a topic with the mouse. Scroll bars are 
located to the right and bottom edges of the topic window.



Select ("block") a section of text or an image with the mouse. Selected text or images appear in reverse 
video. For example, if you want to make a section of text bold or copy it to another location, you select 
the area by holding down the mouse button and dragging the pointer over the text or image to highlight 
it. Then either choose a command from the menus or click a button on the toolbar to carry out the 
action.



RTF stands for Rich Text Format. It is a file format that can be produced by most word processors and 
many page layout applications. It contains many text attributes that are embedded within the document.



Properties are selected attributes given to a link or a file. For example, after you link a topic to a pop-up, 
the link has a pop-up attribute.



A non-scrolling region is a fixed header in a topic. You can scroll through the content of the topic while 
the non-scrolling region remains at the top of the scrolling window. 



A bar displayed at the top of the topic window. You can use the horizontal ruler to view and set 
paragraph indents, tab stops and page margins.

To display the horizontal ruler, choose Show Ruler from the Display Preference menu.



A bar displayed at the top of the topic window. You can use the horizontal ruler to view and set 
paragraph indents, tab stops and page margins.

To display the horizontal ruler, choose Show Ruler from the Display Preference menu.



A defined set of attributes that determines the appearance of the text in a paragraph.



A horizontal bar at the top of a window or dialog box that shows the name of the application and the 
name of the current topic or the name of the dialog box.



Text embellishments, such as bold, italic, underline and strikeout.



A variation of a particular typeface in a font. For example, in the Times New Roman font, there are 
differences in the weight (regular or bold), variation in the point size (1 through 72) and a variation in the 
posture (italic). All of these elements make up a type face family.



The Windows Help Engine is provided with Microsoft Windows. WinHelp loads and run the help file 
(*.HLP) you create with WYSI-Help Composer. WinHelp.exe can be found in the Windows directory.



A topic is similar to a word processing document. It contains either an explanation, a description or a 
procedure. A topic is one of many you create with WYSI-Help Composer.



The status bar, located at the bottom of the WYSI-Help window, provides the current topic's ID and the 
total number of topics in your hypertext file.



A screen photo is a screen shot you produce using WYSI-Help Composer Screen Photo feature. You 
can capture the entire window or a portion of it. The screen photo you create can then be inserted in a 
topic.



A short cut key is a key assigned to a paragraph style to quickly apply a style to a section of text. Short 
cut keys are a combination of the CTRL key and another character you assigned to the style.



The action of moving the text up and down in the main window during editing. You can also scroll 
through a list of terms in a list box, inside a dialog box. Scrolling is done by using the scroll bars located 
on the right edge of the window or list box. PgUp and PgDn can also be used to scroll the text in the 
main window.



Short help messages are small pop-up boxes containing a few word description of a command. Short 
help messages    are displayed as you move the mouse pointer over a command or button. It must be 
turned on in the Settings dialog under the Help menu. The default is on.



A continuous line that doesn't break inside a window, regardless of the size of the window.



The Search Keywords are names you assign to a topic so that a user can search for a particular topic 
when using the Windows Help Engine. The names you assign to the topics for Search Keywords aren't 
the same as the names you've assigned to the topics when they were created. 



A Non-Breaking space is a special tag you can insert between words. This keeps them together when 
the window they appear in is resized. 



Error messages

WYSI-Help Composer error messages,



I/O error messages

"Could not open file <filename>."
The file name you enter in the edit field in the Browse dialog box cannot be found. Choose a 
different name.

"File <filename> is in an old file format.    To convert to new format, open it 
and do save as"
The topic you are trying to import was created with a previous version of the Composer.    Use the 
RTF Importer to convert it to a later version.

"File <filename> is already open"
The file you're trying to open is already open.

"File <filename> is compressed.      To decompress this file, open it and do 
save as without compression"
Self explanatory.

"Topic contents cannot be read.    Do you want to reinitialize the topic?"
Reinitializing the topic removes the contents of the topic.

"Impossible to convert bitmap with the current configuration"
This message only happens for files which have been made with version 1.0.

"Not enough memory to finish operation"
Close some other applications and try again.



Styles error messages

"No more fonts available"
You have has reached the limit of 256 different fonts.

"No more colors available"
You have has reached the limit of 256 different colors.

"No more attributes available"
You have has reached the limit of 1023 different color/font combinations.

"These attributes are those of an existing style.    Do you want to merge 
these styles?"
You just modified a style, and it's properties are those of an existing style. Replying NO will result in
two similar styles being side by side. Replying YES will result in all topics being scanned for the 
style to be merged.

"These attributes are identical to those of an existing style"
You cannot define a style or the attributes of a style which already exists.

"Short cut key already used"
The short cut key to be used for a style is already in use elsewhere.

"This style is still in use. It cannot be deleted."
A style which is used in the text of a file cannot be deleted. The easiest way to get rid of it is to 
modify it, to one of the existing other styles and replying Yes to the merge styles question.

"Invalid short cut key"
You entered a non alphabetical character as a short cut key.



Image error messages

"Image too big"
When Images and text are copied together to the clipboard, no single image can be bigger than 64 
kB. To copy images bigger than that to the clipboard, select them individually.

"Could not create bitmap"
The bitmap could, for reasons unknown, not be created. The most common reason for this is a 
shortage of memory or resources. Try to free up some, by closing other applications.

"Please give the image a name"
To convert an internal image to a referenced image, the image needs a name.

"Unable to display : "
The image file referenced is either missing or damaged, or is in an unknown format. The only 
formats recognized are BMP and SHG.

"Cannot insert captured image"
An error occurred when using the screen capture function, resulting in the image not having been 
created. The most common reason for this is a shortage of memory or resources. Try to free up 
some resources, by closing other applications.

"This is neither a bitmap nor a hypergraphics file.    Do you want to insert it 
anyway?"
The requested image is in a format other than BMP or SHG. If you are is sure the format will be 
recognized by HLP compiler and motor, say yes to the message. In most cases however, the image
will not be recognized by WINHELP.

"Image file does not exist.    Do you want to insert it anyway?"
An image has been selected which the WYSI-Help Composer cannot find at the specified place. 
Answering yes will insert the reference. The screen display will show "Unable to display" and the 
help compiler will show an error message. You should ensure that the image is there before 
compiling.

"Could not load graphics editor"
The graphics editor set in the preferences dialog box could not be loaded. Causes can be : Not 
enough memory or resources or the editor name is incorrect or it simply does not exist in the 
search path.

"Could not load HotSpot editor"
SHED.EXE could not be loaded. Causes can be : Not enough memory or resources, or the editor 
name is incorrect or it was deleted from the WYSI-Help Composer directory.

"The image selected is an internal image. You have to externalize before 
editing it"
You selected an image and tried to edit it with the graphics editor.

"Use    edit hypergraphic to edit a hypergraphic"
You selected a hypergraphic and tried to edit it with the graphics editor. Hypergraphics can only be 
edited with the hypergraphics editor.

"Please make the selected image into a hypergraphic before editing it"
The user selected a referenced image and tried to edit it with the hypergraphic editor. Images can 
only be edited with the image editor.

"The image selected is an internal image. You have to externalize and make 
into a hypergraphic before editing it"



You selected an internal image and tried to edit it with the hypergraphic editor. Only hypergraphics 
can be edited with the hypergraphics editor.



File error messages

"File already exists. Overwrite ?"
The file name you selected already exists, you can overwrite the existing file with the current one, 
or cancel the save operation.

"File not found : "
The file you selected cannot be found. Select another file name.

"Cannot Find CTL3DV2.DLL"

If you get a file error “Cannot Find CTL3DV2.DLL” when launching WYSI-Help Composer, it means 
that you do not have the correct .DLL installed to run the 3D dialog boxes. WYSI-Help Composer 
installs this .DLL into your Windows System directory, but if you 
are using multiple operating systems it is possible that this .DLL is missing. To fix the problem, copy
CTL3DV2.DLL from your WYSIHELP (C:\WYSIHELP) directory to your Windows System (C:\
WINDOWS\SYSTEM) directory, and restart Windows.



Sound error messages

"Too many notes"
The WYSI-Help Composer has discovered too many notes in your hypertext file. The end user will 

not be able to play them all.

"The sound file specified is not in the Windows, Windows System or the 
current directory"
Since the WYSI-Help Composer will delete the path before any sound file, the sound driver used 
for the sound dialog box (MMSystem), expects the sound files to be in the Windows directory, or on
the path. Before executing the help file, make sure these are in the mentioned directories.



Memory error message
"Not enough memory to undo. Continue?"
If replying yes, you will not be able to undo the operation. Try to free up some memory, by closing 
other applications. You may also want to increase the size of the Windows swap file to increase the
amount of virtual memory.



Paragraph format error messages

"Position not valid"
"Position too small"
"Position too large"
The three preceding messages appear if you enters impossible tab values in the format paragraph 
dialog box.

"Illegal left margin value"
"Left margin too small"
"Illegal first line value"
"Illegal right margin value"
"First line value too small"
"Right margin cannot be negative"
"Invalid value entered"
The seven preceding messages tell you that the value entered for margins is invalid.

"Cannot have more than 255 non-scrolling paragraphs"
Self explanatory.

"Do you want to change the default ruler?"
Answering Yes will set the current values for paragraph formatting as the default in a new topic.



Conversion and compilation error messages

"Your file needs to be recompiled before printing. Do you want to compile 
now ?
Since the WYSI-Help Composer makes use of the WinHelp printing facilities, this message 
displays if    the current help file is not in sync with the editor. Replying Yes will recompile the help 
file.

"Error generating the help file"
This message follows the preceding compile step if for some reason the file could not be compiled.

Possible reasons for this are : 
- The file contains errors in the help statements, so the compiler cannot create a help file.

- The compiler is not found at the location specified in WHTOHLP.BAT.

- WHTOHLP.BAT is not found at the location specified in WHTOHLP.PIF    (the latter two may 
happen if WYSIHELP has been moved to another directory after Install ) Fix WHTOHLP.PIF 
with PIFEdit and WHTOHLP.BAT with Notepad.



Printing error messages

"Error loading WinHelp, could not print"
WINHELP.EXE could not be loaded. The most common reason for this is a shortage of memory. 
Try to free up some memory, by closing other applications. Another possible reason is that 
WINHELP.EXE is not found in the search path or the Windows directory.

"Problem reading <filename>, could not print"
The HLP file could not be opened to extract the index file.

"Cannot continue printing : error activating Winhelp"
An error occurred during printing. Winhelp stopped responding to your requests.

"Cannot print to a file"
The help file can only be printed to a printer port (local or on a network).



Project Editor error message

"Could not open DEFAULT.HPJ"
The file 'DEFAULT.HPJ', the file read if there is no project file yet, is not there in the WYSIHELP 
directory. Restore or recreate.

"Could not save file"
The project file could not be saved.This should not happen. It probably means that disk space has 
somehow dropped to zero.

"File not valid: no [FILES] section"
The project file always has to contain a [FILES] section. If it does not contain that section it 
probably means the HPJ file is corrupt. You can either recreate it or delete it, in which case 
WYSIHELP will recreate it from DEFAULT.HPJ.

"File contains non existent file entries"
Not all files referenced in the project file could be found in the directories specified.This should 
happen only if you added RTF, H or other files. Verify that the files mentioned in the sections : 
[FILES], [INCLUDE] or [BAGGAGE] exist in the directories specified.

"File integrity error"
The project file is not a text file or is corrupted.

"Memory allocation error"
One of the memory allocations for the project editor failed.

"I/O error"
The project file could not be read or saved for reasons unknown.

"Error opening icon"
You specified a help icon which the project editor could not read.

No name given for the window"
All secondary windows need a name of at most 8 characters. The name Main is reserved for the 
main window.

"This window already exists..      Do you want to overwrite its properties?"
You defined another window with the same name. Cancel and change the name, or click OK and 
overwrite the old with the new properties.

"You have positioned part of the window outside the screen"
The initial position of part of the secondary window will not be visible on the screen.



Search/Replace error messages

"Element to replace not found"
There is no occurrence in the given scope of the text or link searched.

"No more elements to replace"
There are no more occurrences in the given scope of the text or link searched.

"Element to search not found"
There is no occurrence in the given scope of the text or link searched.

"Link does not exist"
This happens when you want to replace text or a link with another    link(context string), and the 
replace link does not exist in the file.



Macro editor error messages

Macro string too long, modify it with the project editor"
If a macro string is more than 255 characters, the macro editor cannot handle it. Edit it with the 
project editor, File interface.

"I/O error"
The MACRO.INI file could not be read or saved.

"Memory allocation error"
One of the memory allocations for the macro editor failed.

"Syntax error"
The Macro string contains a non-specified error.

"Could not open MACRO.LST"
The macro template file MACRO.LST could not be opened.

"Not enough memory"
One of the memory allocations for the macro editor failed

"Unexpected character"
The character encountered in the macro definition string is not valid.

"Single quote expected"
At the column specified, a single opening or closing quote should be inserted. Usually this will 
happen if double quotes are entered within double quotes.

"Double quotes expected"
At the column specified, a double quote should be inserted. Usually this will happen if a single 
quote are entered within single quotes.

"Did not expect double quotes here"
At the column specified, a double quote appeared whereas it should not.

"Quotes not closed"
At the column specified, quotes should have been closed.

"Too many parameters"
The macro's definition specifies less parameters than actually were entered.

"No quotes"
At the column specified quotes were expected.

"Number expected"
A numeric value was expected at the column specified.

"Quotes expected"
At the column specified quotes were expected.

"Fixed value expected"
The macro definition allows for only one possible value at the position specified.

"This value is not listed"
The macro definition specified a value from a list to be entered at the specified position.

"String expected"



The macro definition specified a string to be entered at the specified position.

"Incoherent parentheses"
The number of closing parentheses does not match the number of opening parentheses.

"Parentheses expected"
At or before the specified position, parentheses were expected to be closed.

"Not enough parameters"
The macro's definition specifies more parameters than actually were entered.

"Cannot insert this string: the result would be longer than 255 characters"
A macro string cannot exceed 255 characters.

"Invalid macro string"
A general error was detected in the macro string at the specified position.

"Empty parameters"
One or more parameters were not filled in.

"Cannot have a macro inside a user macro"
Only predefined macro's can have embedded macros.

"The selected macro will replace the existing one"
The cursor is pointing to a macro in the macro definition field. Selecting a new one will replace it.

"No parameters"
The macro definition specifies that the macro needs parameters and there are none.

"Only 3 levels of embedding are permitted"
Currently, WINHELP allows only three levels of embedded macro Macro1(Macro2(Macro3())).

"The Macro editor has discovered mistakes in the string. Save anyway ?"
The editor encountered a mistake in the macro string. You can save it anyway and look for the error
at a later time.



Automatic link generation error messages
"No more links to delete"
The Option Delete auto links signals that it has finished.

"Regeneration finished"
The Option Regenerate auto links signals that it has finished.

"This text already references another topic"
You have tried to create a reference expression that all ready is in use by another topic.



Spell checker error messages

"Spell checker failed to initialize : no spell id"
The speller failed completely. Speller file may have been deleted or moved from the WYSI-Help 
Composer directory. You may need to re-install.

"Spell checker failed to initialize : could not    open phonetic dictionary    
<filename>"
The phonetic dictionary mentioned was not found.

"Spell checker failed to initialize : could not open    Most Used Words 
dictionary <filename>"
The most used words dictionary mentioned was not at the position specified in the preferences or 
the language does not match.

"Spell checker failed to initialize : could not open main dictionary 
<filename>"
The main dictionary mentioned was not at the position specified in the preferences or the language 
does not match.

"Spell checker failed to initialize : could not open or create user dictionary 
<filename>"
This will happen only if the path you specified in the preferences dialog box does not exist.    Modify
the path in the preferences dialog box.

"Spell checker failed to initialize : could not load <filename>"
One of the additional files needed by the spell checker could not be loaded. Restore the specified 
file to the WYSIHelp directory.

"Spell check search finished"
Self explanatory.



Conversion to RTF error messages

Cannot open source file"
The WYSI-Help Composer could not open the DHF file.

"Cannot open target file"
The WYSI-Help Composer could not create the RTF file. This happens only if the RTF file the 
WYSI-Help Composer tries to create already exists as a read only or system file.

"Invalid data in source file"
The DHF source file is corrupted.

"Error writing target"
The WYSI-Help Composer could not write to the RTF file. 

"Not enough memory"
Self explanatory. Close some other applications and try again.

"Conversion cancelled"
After one of the error messages, this message signals that the conversion to RTF has not been 
completed successfully. React to the previous message and try again.

"Cannot load Help compiler"
- The compiler is not found at the location specified in WHTOHLP.BAT
- WHTOHLP.BAT is not found at the location specified in WHTOHLP.PIF

This is likely to happen if WYSIHELP has been moved to another directory after install : the 
directories written in the above files will be incorrect. Fix WHTOHLP.PIF with PIFEdit and 
WHTOHLP.BAT with Notepad.

"Cannot convert an empty file"
This will happen if the user tries to convert a file before creating a topic. Create a topic and try 
again.

"Link name contains invalid characters"
This means that one of the link names contains characters other than Alphanumeric or the 
underscore character.

"Image target link name contains invalid characters"
This means that the target link name of a image hypertext link contains characters other than 
Alphanumeric or the underscore character.

"Invalid link id"
The target link id is invalid.

"Error writing index file"
The .H file, the one which maps context strings to context id's could not be created or written.

"Error writing header"
An error occurred writing of the RTF file header.

"Error initializing conversion"
An error occurred during the initialization of the conversion.

"Target link name contains invalid characters"
The target link name contains characters other than Alphanumeric or the underscore characters.

"File converted to RTF. Do you want to convert to HLP?"



Since the compile step can take a long time, this question is always asked before starting the 
compiler.

"The .HLP file is up to date. Convert anyway?"
This means that a HLP file has been detected with a later time stamp than the RTF. This should 
only happen if the user replaced a HLP file with one with a much later time stamp. 

"Do you want to convert the file to RTF format?"
Since the conversion step can take a long time, this question is always asked before starting the 
RTF converter.

"Target link does not exist"
The target of a link does not exist.

"Error loading topic"
One of the topics in the file could not be loaded. Close some applications and try again. If the error 
persists, load all topics one by one and see which one cannot be loaded. If there is no way of 
loading it, import all other topics to a new file.



Preview error messages

"This button is not available in preview mode"
Only a subset of WinHelp buttons are available in preview mode.

"Sorry, cannot execute interfile links in preview mode"
Preview mode is a limited implementation of the help system. In file hypertext jumps and popups 
are active as well as a few of the buttons.

"Sorry, cannot execute macros in preview mode"
Preview mode is a limited implementation of the help system. In file hypertext jumps and popups 
are active as well as a few of the buttons.

"Invalid context ID given in the extended link"
Since extended links allow you to pose non existing links, this message warns you that the target of
his jump does not exist.

"Sorry, cannot jump to keywords in preview mode"
The choice keyword jump is not active in preview mode.



General file and other error messages

"Memory initialization failed"
There is not enough memory available even to initialize the WYSI-Help Composer. Close other 
applications and try again. If the message persists, possibly the file UNTITLED.DHF is corrupt and 
needs to be deleted.

"Memory allocation failed"
There is not enough memory available even to initialize the WYSI-Help Composer. Close other 
applications and try again. If the message persists, possibly the file UNTITLED.DHF is corrupt and 
needs to be deleted.

"Create New Topic failed"
The requested topic cannot be created. This happens if the product is a demo version and the 
maximum number of topics is exceeded. In other cases, it means that not enough memory is 
available. Close other applications and try again.

"Load Topic failed"
The requested topic cannot be loaded.

"Free memory failed"
A block of memory could not be freed. Save your work, close the application and reload.

"File initialization failed"
Either there is not enough memory, in this case closing other applications should solve the 
problem, or the file is corrupt.

"Help file Open failed :"
The file is not a valid DHF file.

"Read file failed :"
A read operation reported the error indicated in the dialog box.

"Write file failed :"
A write operation reported the error indicated in the dialog box.

"Initialization of file or memory failed"
Either there is not enough memory, and case closing other applications should work, or the file is 
corrupt.

"Maximum number of topics exceeded"
Demo version only.

"Cross reference error"
Memory corruption.

"Invalid index table"
Memory corruption.

"Error saving, please retry"
Self explanatory.

"This file is write protected"
Memory corruption.

"This topic is part of a browse sequence, you cannot delete it"
This happens when the you try to delete a connected topic.



"This topic is called by others, you cannot delete it"
This happens when you try to delete a connected topic.

"Do you want to delete this topic"
Confirmation message.

"This topic already exists"
Two topics can not have the same name. Try another name.

"The file already exists, do you want to overwrite it?"
Displays    after a 'Save as' choice, if the requested file already exists.

"Definition of browse sequence not allowed"
The next or previous topic in a browse sequence already exists in another browse sequence. 
Delete it first from that sequence.

"Not enough free space on the drive"
A file open request will result in a temporary file which exceeds the size of the free space on the 
WYSIHELP drive (NOT the file's drive).

"To see the latest changes you must regenerate the help file"
When the user selects the view help file option, even though the help file exists, it is less recent 
than the current edited file. OK will launch it anyway.

"A backup file exists, do you want to recover it?"
After a system crash, the temporary file created by WYSI Help Composer (if automatic save was 
on), contains all modifications up to the last five minutes.

"The given directory does not exist, please retype"
The recovery file could not be created in the directory specified.

"This demonstration version does not allow more than 10 topics"
Self explanatory. This message will be followed by a 'could not create topic' message.

"This application need a Windows version 3.1 or higher"
Self explanatory.

"Composer is already in use on another machine"
The WYSI-Help Composer is a one machine application.



Link name
Placing a check mark in this box will result in the link name of each topic in the list being printed.



Topic name
The topic name displayed in this box is the name of the current topic. You can enter a new name if 
you want to rename a topic. This topic name is the name displayed in the WYSI-Help Composer 
Topics list and doesn't appear anywhere    in the Windows help Search dialog box. It is also 
referred to as the Context String.
 



Search keywords
The name(s) listed in this box are the search keywords that have been defined for the current topic.
You can have multiple keywords, all related to the current topic.



Add button
Click the Add button once you have entered a new topic search keyword. The name is then 
added to the list of search keywords.



Delete button
Click the Delete button once you've selected a topic search keyword from the list to delete. The
keyword will be deleted from the list.



Topic title
The name listed in this box is the topic title that will display in the Windows help Search dialog box 
once you have typed a search keyword and click the Go To button in the dialog.

This title will only appear in the Windows help engine. By default, the WYSI-Help Composer uses 
the topic name you selected when you created the topic as search and title keywords.



Style short-cut-key
The letter that appears in this box is the short-cut-key assigned to a style. To use the style short-
cut-key, select the text and press the Ctrl key and the key shown in this box. The style will be 
applied automatically .



Creating a secondary window

A secondary window is a separate window that stays open until closed by the user, or until the help
file is closed.    You can display a topic in a secondary window while a related topic remains 
displayed in the main window.    The main benefit of a secondary window is that, unlike a popup 
window, the secondary window remains open even when the user hides the main help window, 
minimizes the main help window, or jumps to another topic in the main help window.

Click on the Glossary button on the help button bar to see an example of a secondary window.    
The Glossary window will remain open until you close it.

A topic is displayed in a secondary window through the use of an extended link.    Before creating 
the extended jump link, it is necessary to create the secondary window in which the topic will 
display.    Secondary windows are created using the Project Editor. When you create a secondary 
window you can choose its size, colors, title, and its attributes (Always on top or maximized). After 
you create the secondary window, you then create the link to the topic which will display in the 
secondary window using the Extended link command from the Link menu

Procedure

1. Select the Project Editor command from the File menu.

2. In the Windows filed of the Project Editor dialog box, click the Add button and the Window 
Information dialog box will appear. 

3. In the Title edit box, enter the label you want to have appear in the window's title bar.    For 



example, if a glossary topic will display in the window, you would enter the title "Glossary."

4.  The default name of the first secondary window you create is sec1. This name is used to 
identify the secondary window when creating an extended link.    You don't need to change 
this name since it doesn't appear to the user of the help file, but if you will be creating a few 
secondary windows you may wish to give each window a name that will help you remember 
which window is which.

5. Use the drop down menus in the Colors area to set the colors of your secondary window. 
(See Changing the color of help windows for more information.)

6. Click the Size window button to customize the size of the window. (See Changing the size 
of help windows for more information.)

7. Click the OK button to save your changes and exit the Project Editor dialog box.

Related Topics

Changing the color of help windows
Changing the size of help windows
Creating an extended link
Displaying a topic in a secondary window
Using the Project Editor



If the Generate indexes on save option is checked, you will have the option of generating an index of
topics in your help file for use by Explorer.    The default for this option is checked.

When Generate indexes on save is checked, then after you save and compile your help file a dialog 
box appears asking whether to generate Explorer indexes.    You must click Yes in order to generate 
the indexes. However, this process takes a few minutes, so you may wish to wait until you have 
completed building and testing your help file before generating indexes.

Indexes must be generated to support Explorer's Navigator feature, Search feature, and multiple topic 
Print feature. If you do not check Generate indexes on save but do check either of the other Explorer 
options,    an Explorer window will be made available to the end user, but only the Colors feature will 
work.    The windows for the Navigator, Search, and Print features will be empty.    For this reason, it is 
recommended that you generate Explorer indexes if you are going to make the Explorer available to 
your end users.



Changing the color of help windows

WYSI-Help Composer allows you to change the colors used in the Main help window and in any 
secondary windows that you may define.      You can change the color of the non-scrolling region as 
well as the background color for the body of the window.

The default colors for a help window are the Windows default colors.

After changing the colors for a help window, its a good idea to use the Preview mode to see how 
the new colors look with the text styles you have defined.    You may need to adjust either the 
window colors or the font colors for better results.

Procedure

1. Select the Project Editor command from the File menu.

2 In the Project Editor dialog box, select the name of the window for which you want to change
the color. The main help window is labeled Main. Any other windows listed are secondary 
windows, and have whatever name you assigned when you created them.    The default 
names for secondary windows are sec1, sec2, sec3, and so on.

3. Once you've selected the window name, click the Modify button.    The Window Information 
dialog box will appear.

4. If you wish to change the color for the non-scrolling region, click the down arrow beside the 
Fixed-region box.
If you wish to change the background color of the window, click the down arrow beside the 
Background box.

5. Select one of the colors displayed by clicking on it.    To return to the Windows default color, 
choose Def from the color selection palette.

6. Click on OK in the Window Information dialog box to close the dialog box and register the 
color change.    Click on OK in the Project Editor dialog box when finished.

Note
The new colors will not display in the WYSI-Help Composer editing area.    To see the new colors 
you must either use the Preview mode or compile and run the help file.

Related Topics



Defining the attributes for a selected block of text or a text style
Changing the size of help windows
Creating an extended link
Displaying a topic in a secondary window
Using the Project Editor



Goes to list
Placing a check mark in this box will print the Goes to list for each of the topics to be printed. 
This list contains the names of topics which are pointed to by links in the current topic.



Comes from list
Placing a check mark in this box will print the Comes from list for each of the topics to be 
printed. This list contains the names of topics which have links pointing to the current topic.



Browse sequence
If a topic to be printed is part of a browse sequence, then placing a check mark in this box will 
result in the names of the previous and next topics in that sequence being printed also, provided 
they exist.



Surveillance Option
Lets you choose which configuration of short help you wish to use.    Modifying this file is usually 
unnecessary.



Display Option
This check box allows you to turn the short help display on and off.



Color & Style Option
In selecting these buttons, modify the format of the text that is displayed in short help.



Mouse move & Delay Option
Checking the Mouse move option displays the short help for an object based on the movement of the 
mouse. 
The Delay is the number of 1/10 sec. before the short help is displayed.



Title bar or Bubble Option
Short help either displays in a bubble next to the object it is associated with, or in the title bar.    Bubbles 
allow more text to be displayed.



Doing a partial compile

A partial compile is compiling your help file with only some of the topics found in the .DHF file.    Partial 
compiles make testing complicated macros quicker by eliminating the time it takes for the compilation 
of topics not included in the macro.    You may also use partial compiles to have different versions of 
the help file.

Build tags are used to identify which topics should be included in the compilation of the .HLP file. By 
default, all the topics that you produce will be included in the compilation, but having the ability to 
include or exclude a selection of topics can be very useful, allowing you to produce several 
different .HLP files from the same collection of topics in the hypertext file. The example below shows 
how this might be done:

[BUILDTAGS]
DEMO ; topics to include in a demo-build
MASTER ; topics to include in a master hypertext file
DEBUGBUILD ; topics to include in a debugging build
TESTBUILD ; topics to include in a mini-build for testing

Underneath the section heading [BUILDTAGS], each line forms a build group definition. The 
context string of a topic may be included in more than one build group, and up to 30 build groups 
may be contained in the [BUILDTAGS] section.

The [BUILDTAGS] section of the project file is optional (its absence meaning that all topics are to 
be included in the compilation). However, you can add it if you want to perform a special 
compilation of topics.

The command BUILD= defines how the .HLP file is to be compiled from the different build groups
specified. For example, including the command BUILD=MASTER in the help project file would 
result in only those topics with the build tag MASTER being included in the compilation. Logical 
expressions may also be used with this command. These are listed below in order of increasing 
precedence:

| OR operator The help compiler includes a topic if it belongs to either or both of the 
build groups listed.

& AND operator The help compiler includes a topic only if it belongs to both build groups
listed.

~ NOT operator The help compiler includes a topic only if it does not belong to the build 
group listed.

( ) Parentheses may be used to override the usual operator precedence. Expressions enclosed in
parentheses ( ) are always evaluated first.

Hence, the command,

BUILD = (DEMO&MASTER) | (TESTBUILD & ~DEBUGBUILD),

would result in the topics containing both the DEMO and MASTER build tags, or those containing
the TESTBUILD tags but not the DEBUGBUILD tags, to be included in the compilation.

A BUILD= statement belongs in the [BUILDTAGS] section after the build groups definitions. Only 
one BUILD= statement is permitted in a project file.



[BUILDTAGS]
DEMO
MASTER
BUILD =name of build

As well as defining the topics to include in build groups in the project file, each topic must also be
specially identified. This is done by adding topic footnote statements. For a fuller description of 
this option you should refer to the text entitled Adding footnotes to topics, but for now all you 
need to know is that a build tag footnote statement consists of an asterisk, followed by a space, 
followed by a list of the build groups to which the topic belongs. Each build group listed should be
separated by a semi-colon.

For example,

* DEMO;MASTER

this footnote would indicate to the help compiler that this topic should be included in the build 
groups DEMO and MASTER.

For detailed information about conditional compiles you should refer to the Microsoft Windows 
SDK manual.

Related Topics
Adding footnotes to a topic
Project Editor



Add
Clicking on the Add button will add the contents of the edit field to the end of the current definition list.



Delete
Clicking on the Delete button will remove the line selected in the current definition list and place
it in the editing region.



Edit Footnote
Edit the text to add to your footnote here.



Current Definition
Below the editing region is a current definition list containing the footnotes defined for the current topic.



Current contents of the footnote
This is a list of the contents of the topics footnote. This footnote does not contain footnote material that 
is handled automatically by the Composer such as Keywords, Context Strings and Titles.





Context Sensitive Help

You can use Composer Notes development tool to link your help application to any Windows program 
without having access to the source code. Composer Notes allows you to create the context sensitive 
links with point and click techniques, and allows you also to add bubble help to the target application.

If you are using WYSI-Help Composer with programming languages (C++, Pascal or Basic) or with 
rapid application development tools, such as Clarion for Windows, you can make your online help 
context sensitive easily by using the same context ID’s in your programming language and WYSI-Help 
Composer. 

The list of objects and their context ID’s is in a .H header file. A header file is a simple text file that is 
produced by C++, and can be read into most help authoring tools. WYSI-Help Composer will also 
create a .H file automatically. The Windows help compiler is using the header file when the help file 
gets compiled.

Editing Context ID’s Manually

If you are working on small project, or have started writing your help file before getting a copy of .H file,
the easiest method for changing the context ID’s is probably to edit the ID’s manually in WYSI-Help 
Composer by modifying the Topic Qualifyers for each help topic. 

Importing .H files

If you are using C++, you will have a .H created by your C++ language, which can be directly imported 
to WYSI-Help Composer. 

Procedure

Open WYSI-Help Composer and choose Open form File. Change the file type to open to .H., browse 
for your .H file and Click OK. WYSI-Help Composer will automatically create the framework for your 
help file. After the .H file has been imported, use Save As..
. command to save your help application to the location of your choice. Note that your have to use the 
same help file name both in your programming language and for the help file you are creating.

Creating .H Files Manually

If you are using other programming languages than C++, you can create the .H file manually. Pascal 
contains the context ID’s in the Const section of .PAS file. If you are using Visual Basic, you can 
search your code for WinHelp() function calls to produce a list of context ID’s. If you are using Clarion 
for Windows, you can search for HLP() and HELP() function calls to produce a list of context ID’s. You 
should also check the appropriate online forums for possible shareware tools for creating .H files from 
your program code. On CompuServe, WinHelp section in WINSDK forum usually contains most of the 
available shareware tools related to help authoring. You may also want to take a look at some of the 
reference books related to Windows help authoring.

The information you need to have in the header file is a list of the objects containing a help call and the
related context ID for each object. If you want to create .H file, you can use Notepad to create a new 
file and then save it with file extension .H
 to. The syntax for the header file is following:

#define    Object    ContextID

Where Object is the name of the object used in Visual Basic or Clarion, such as a button or a menu 
command. ContextID is the number or the ID text used to call for a certain help topic. 

#define    Button_Close    1



#define    Button_OK    2
#define    Button_Cancel    XYZ

The Object names can be different in WYSI-Help Composer compared to your program code, only the 
ContextID’s used in your program code and in WYSI-Help Composer must be the same. However, it is 
generally easier to use the same Object names as you are using
 in your program code to keep track of your help topics. 

After you have created the .H file manually, you can use the .H file import function in WYSI-Help 
Composer.



    Composer Notes

Composer Notes is the new Windows interface and helpfile “glutility” for Windows users.    Without 
programming or the need for source code, Composer Notes allows you to attach custom messages 
and help topics to any element in Windows applications. Composer Notes is an easy to use, point & 
click, cross application development tool that turns your standard application software into company 
specific customized application suites. 

Composer Notes -- Main features and benefits

- Link any Windows object to Help instantly!

- Point & click linking of most Windows objects to help without programming or the need for 
source code.

- Offers a comprehensive scope of message attachment as Windows objects include menus, 
individual menu items, dialog boxes, buttons in dialog boxes and editable fields.

- Choose what message the object is linked to - a title bar message, bubble help or help topics. 
Linked help topics can contain anything available to the standard Windows help engine, 
WINHelp, including hotspots, program launches, buttons, etc.

- Lists captured objects conveniently outlining those that have already been linked to a help 
topic, bubble help or title bar message.

- Link object to any number of applications and vendors for true cross-application personalized 
on-line procedures.

Comprehensive    Editing features

- Customize background color and text styles within title bar messages and bubble help for 
easy recognition of your personalized help application.

- Customize the timing for title bar message and bubble help display.

- Define separate key combinations for context sensitive help, title bar messages, bubble help, 
and display of your custom help index. Your customized help file can be complementary to the
target application’s context sensitive help, or replace it.

- Link to help topics created with any Help Authoring Tool.

- Automatic launch and edit function for help topics created with WYSI-Help Composer.

- Create your on-line messages in one file and customize their display to the level of your user. 
Turn individual object links on or off for novice or advanced users.

- Grouplink multiple objects to a single help topic, title bar or bubble help message - to ensure 
the same message appears for related objects.

- Create and benefit from cross-application procedures in a matter of minutes. 

Context Sensitive Help

- Glue company specific information to any number of Windows applications.

- Attach context sensitive information without programming; no need for the application' s 



source code.

- Put your company procedures on-line and attach them in context to your Windows application 
suite.

- Choose to supersede the original helpfile or offer the user both the original and custom help 
files.

- Provide short help messages quickly without the user having to access the help engine.

- Attach bubble help for further clarity to the linked help topics.



Quick Topic Search

Quick Topic Search edit box allows you to quickly find and open topics in your help file.

To use this feature, place your mouse cursor in the edit box above the Topics list. Type in the first 
few letters of the topic name you are looking for.    As you type, topic names will become 
highlighted.    For example, if you type C the name of the first topic starting with the letter C will be
highlighted.    If the next letter you type is O, then the first topic name starting with the letters CO 
will be highlighted.    To find a specific topic name you need to keep typing letters in the name until
you have entered a combination that is unique to that topic name.    Or you can locate a topic that 
has a similar name, then use the scroll bar to find the one you want.

Once you have found the correct topic, you can open it by double clicking on it, or by hitting Enter
when the correct topic is highlighted in the Topics list.

Below is an example of the Quick Topic Search feature in use.

Related Topics
Locate
History
Previous





Done Buttons
Click here when you are finished with the spell check.



Add Buttons
Click here when you want to add the word to a user dictionary.    This dictionary cannot be edited.



Replace Buttons
Click here to replace the suspect word with the suggested word.



Ignore Buttons
Click here to ignore the suspected word and continue with the spell check.



Replace by Field
The Replace by field accepts entries from the Suggested words below or can be modified by you.



Word not found Field
The Word not found field contains a word that the Composer could not find in its dictionary.    



File button
Click here to enter the Project Edit File    mode.    This allows you to edit your .HPJ or Help Project File 
directly.    Doing so requires expert knowledge in authoring windows help.See the Project Editor File 
mode for more information.



Error log file
Enter the name of the error log here.    If your help file contains any errors when it compiles, they will 
be stored in this help file.    See Selecting an Error log file for more information.



Help file Compression
Select a    level of help file compression here.    See Compressing a help file for more information.



Delete button
Click here to delete a window from the Windows list.



Modify Window Button
Click here to modify the selected help window.    This brings up a dialog box that lets you modify 
various features of the window your topics will display in such as color, size and position.    See 
Modifying Help Windows for more information.



Add button
Click here to create a new window for your project.



Help file Windows
This is a list of the windows that help topics may be displayed in. 



Help Icon
Select a new file for the Icon that appears when the Help file is minimized.    This is not the icon that 
will appear in the Program manager.    See Selecting a help icon for more information.



Help File Contents
This topic will be displayed when    the Contents button is pressed in the Help Window.



Project Editor File Mode

Although this method requires    greater knowledge about the format of help project files, it does 
allow you to enter commands which are not covered by the Project Editor in interactive mode.

Procedure

1. Open the file whose project file you wish to view/modify.

2. Select the Project Editor command from the File menu, (ALT, F, E).

3. Clicking on the File button will display a new dialog box containing a representation of the 
actual help project file.

As you can see, the main element of the dialog box is an editing region containing a 
representation of the help project file. In this region you may modify any of the settings created 
by the Project Editor in interactive mode, but you may also enter other statements concerning file
macros, (see Inserting file macros and build tags).

Related Topics

Project Editor Interactive Mode



Title
Enter the title of the window. This title will appear in the title bar when the window is opened.    
See Setting the windows title for more information.



Name
Enter a name for a secondary window. You will have to use this name to identify the secondary 
window when you wish to use it with an extended link. It must therefore be unique.



Colors
Select the colors to be used for the background of the scrolling and non-scrolling regions of the 
screen when a topic is being displayed in the window. The value "Def" means that the default 
Windows color will be used.    See How do I change the color of the help window for more 
information.



Always on top
Check this box to ensure that the window can never be covered, not even partially, by another 
window.



Maximized
Check this box to ensure that the window is maximized when it is opened.



Size Window
Click on this button to display an example window which you may size and position as you wish. 
When the window being defined is opened, it will take the last size and position of this example 
window. The example window will show the background colors currently selected. Once you 
have sized the window as you wish, you can close it to return to the dialog box. The new window
size will be saved when closing the window.



Changing the size and position of help windows

WYSI-Help Composer allows you to change the size of the Main help window and also of any 
secondary windows that you may define.

The default size and position for the main help window is the last size and position set by the user 
or by another help file.    Once you set the size and position of the main help window, it will always 
open to your set size and position, no matter what size it was or where on the screen it displayed 
last.

The default size for secondary windows is centered and nearly full screen.    You will probably want 
most of your secondary windows to be smaller than the default size and positioned so that they 
allow most of the main help window to remain visible.

Procedure

1. Select the Project Editor command from the File menu.

2 In the Project Editor dialog box, select the name of the window which you want to resize. 
The main help window is labeled Main. Any other windows listed are secondary windows, 
and have whatever name you assigned when you created them.    The default names for 
secondary windows are sec1, sec2, sec3, and so on.

3. Once you've selected the window name, click the Modify button.    The Window Information 
dialog box will appear.

4. Click on the Size window button.    The window you are sizing and positioning will open.

5. Size the window by moving the edges of the window with the mouse until the window has 
the desired dimensions. Position the window by dragging it to the desired location on the 
screen.

6. When you are satisfied with the size and location of the secondary window, click on OK in 
the Window Information dialog box to close the dialog box and register the change.    Click 
on OK in the Project Editor dialog box when finished.

Related Topics

Changing the color of help windows
Creating an extended link
Displaying a topic in a secondary window
Using the Project Editor



Displaying a topic in a secondary window

You can display a topic in a secondary window while a related topic remains displayed in the main 
window.    A topic is displayed in a secondary window through the use of an extended link.    Before 
creating the extended jump link, it is necessary to create the secondary window that the topic will 
display in.      After you create the secondary window, you then create the link to the topic which will 
display in the secondary window using the Extended link command from the Link menu.

Procedure

1. Select the text or image you wish to link to the target topic which will display in the 
secondary window.

2. Choose the Extended link command from the Link menu or choose the Extended link  
button on the toolbar. 

3. In the Extended link dialog box, enter the name of the file that contains the target topic using the 
Browse button or by typing the name in the File edit box. If the topic that will display in the secondary window is
in the current file, enter the name of the current file.    If the target topic is in another hypertext file, enter that file
name.    Do not add a file extension to the name; in other words, enter "filename," not "filename.dhf" or 
"filename.hlp."

4. Click on the arrow in the Target window field to display a drop down list of available display 
windows.    Select the name of the secondary window in which you want the target topic to 
display.    If you do not select a window name, the target topic will display in the main help 



window.

5. In the Type of identifier box, press the Find topic button to display a list of topic names from 
the chosen file. Choose the name of the desired target topic. Once the topic has been 
selected, click the OK button to save and exit the Extended link dialog box.

6. To test the extended link, use the Preview mode or compile and execute the help file. When 
you click on the extended link, the target topic should appear in the secondary window. 

Related Topics

Creating a secondary window
Creating an extended link
Using the Project Editor



Working with text styles

WYSI-Help Composer allows you to define your own text styles and apply them to a selected text. 
This is useful when you want to use the same style in several topics.    For example, you could 
define a style that will be used for all topic headers, as was done with this help file.

There are two ways to create a new text style in WYSI-Help Composer:

1. Select a block of text and format it using the Attributes command from the Format menu.    
WYSI-Help Composer automatically saves the formatting information as a new text style that
can now be applied using the Apply Style command from the Format menu.

2. Without selecting any text, use the Define style command from the Format menu to select 
the desired attributes for your text style.    The style can now be applied using the Apply 
Style command from the Format menu.

Once text styles have been created, it is easy to apply them, especially if you define a shortcut 
key combination that can be used to quickly apply the style.    You can also modify a text style.    
When a style is modified, all of the text using that style will display the change.    This makes it 
easy to reformat your text quickly.

For complete procedures to format text and to define, apply, and modify styles, see the 
appropriate topic from the Related Topics list below.

Related Topics

Defining the attributes for text or a text style
Defining a text style
Applying a text style
Assigning shortcut keys to text styles
Modifying a text style
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This book comes with Microsoft Visual C++.    It contains information about the help compiler including 
information about help compiler error messages.

Designing the User Interface by Ben Schneiderman
Published by Addison-Wesley
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Contents Topic
It is the first topic that appears when running a help file and often acts as the Table of Contents to a 
help file. The Contents Topic can be accessed from anywhere in the help file by clicking on the 
Contents button that appears at the top of the help window. 





Locate

The Locate Topic feature allows you to search for topics using various search keys. To use 
Locate feature, click on the button by the search key you want to use and type in the text or 
number to the edit box for that feature.

Topic Name allows you to search topics using the topic name.

Topic ID allows you to search the topics using the context ID of the topic.

Topic number for compiler is the number of a topic according to the Help Compiler. These 
numbers are assigned according to the order of the the topic names in the .H file.    For example, 
the fifth topic listed in the .H file will have the Topic number for compiler=5.    This number will not 
necessarily be the same as the Topic ID number.    Locating topics by their compiler number is 
useful when searching for topics using the error message data produced by the help compiler.

Error offset in RTF is the error code given by the help compiler. This feature is also useful when 
searching topics using the error message data produced by the help compiler.
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History

The History command allows you to go back to one of the topics you have recently had open.    It 
works the same way as the History feature in the Main Help Window.

When you select the History command from the Topic menu, the Topic History dialog box opens.    
This dialog box displays the names of the last eight topics that were open for editing.    If the same 
topic was opened two times out of the last eight it will be listed twice; if the same topic was opened 
three times out of the last eight it will be listed three times, and so on.

To open a topic listed in the Topic history dialog box, click once on the topic name and then click the 
Edit button, or double-click on the topic name.



Apply Model

The Apply Model command allows you to use an existing topic as the model for one or more existing 
topics.    When you select the Apply Model command the characteristics and contents of the model 
topic will be copied into the topic or topics that you select.    The selected topics will now have the 
same size non-scrolling region as the model topic, and will contain all of the text, graphics, styles, and 
links of the model topic.    The model topic's text, graphics, and links will be pasted in above any text, 
graphics, or links that were already present in the selected topics.

In the example shown below, a topic called Topic Modelling has been selected as the model topic.    
The model will be applied to the selected (highlighted) topics.

Apply Model is useful when, after you created one or more topics, you realize that the contents will be similar to
another topic.    You can then model the topics on the similar one, which will copy the contents of the model into
the selected topics.    You may then edit the contents to fit each selected topic.

Apply Model is also useful when you want to maintain a uniform look among your topics.    You can 
create a topic that uses the text styles and non-scrolling region you want to use in every topic, then 
apply the model to all appropriate topics.    If you have standard text, graphics, and/or links that will be 
used in several topics, you can add them to your model topic to save you the trouble of copying them 
to each topic separately.

Procedure

1. Select the Apply model command from the Topic menu.

2. Use the Model topic drop down list to select the name of the model topic.

3. In the Topics to modify box, select the names of the topics you wish to modify.    To select 
multiple names, click the name of the first topic, then hold down the CTRL key as you click on 
each additional topic name.

4. After selecting the names of all the topics you wish to modify, click Apply.    The following dialog 
box will open:



5. Click the appropriate button.

Yes will save the file, and then modify the topics.    If you don't like the modifications, reopen the saved 
version.

No will modify the selected topics without saving the file first.

Cancel will cancel the topic modelling operation.

Related Topics
Designating a model for a new topic



Modelling a new topic on an existing topic

Whenever you create a new topic you have the option of modelling it on an existing topic.    When you 
apply a model to an existing topic, the characteristics and contents of the model topic will be copied 
into the new topic.    The new topic will now have the same size non-scrolling region as the model 
topic, and will contain all of the text, graphics, styles, and links of the model topic.

Modelling a new topic on an existing topic is useful when you know that the new topic's contents will 
be similar to another topic.    You can then model the new topic on the similar one, which will copy the 
contents of the model into the new topic.    You may then edit the contents to fit the new topic.

Modelling a new topic on an existing topic is also useful when you want to maintain a uniform look 
among your topics.    You can create a topic that uses the text styles and non-scrolling region you want
to use in every topic, then apply the model to all appropriate new topics.    If you have standard text, 
graphics, and/or links that will be used in several topics, you can add them to your model topic to save 
you the trouble of copying them into each new topic separately.

Procedure

1. When creating a new topic, choose a topic from the Model name drop down list in the dialog box.

2. Make sure your new topic name is entered in the Link name edit box.

3. Click OK to create the new topic but not open it, or Edit to create the new topic and open it 
immediately.

The contents of the topic listed in the Model name edit box have now been copied into the new topic.

Related Topics
Designating a model for an existing topic



Previous
The Previous command opens the last topic that was open for editing. You can also use the F5 key to 
open the previous topic.



Delivering the Explorer to the end user of your help file

If you are going to make the Explorer available to end users, you must include several files with your 
final help file.    WYSI-Help Composer users can distribute these files with their help files for free.

The files you need are:
1. WHEDPRIN.DLL
2. EWHELP.DLL
3. HMMEM1.DLL
4. WHICONDL.DLL
5. EWHLOAD.EXE
6. EWHELP.HLP
7. myhelp.HYP    (replace MYHELP with the name of your help file)
8. myhelp.IDX    (replace MYHELP with the name of your help file)

WHEDPRIN.DLL needs to be installed in the end user's Windows directory.    All of the others should 
be installed into the same directory as your help file.    

The four DLLs are needed to implement Explorers features.

EWHLOAD.EXE is the actual Explorer program.

EWHELP.HLP is the Explorer help file, which helps end users use the Explorer.    It is activated by 

clicking the  button in the upper right corner of the Explorer window.

"myfile".HYP saves the user's custom color settings.

"myfile" .IDX is the Explorer index that is generated after compiling your help file.    It is needed for the 
proper working of the Navigator, Print, and Search features of the Explorer.



Importing an existing hypertext file in RTF format

Any RTF file that already contains topics and hypertext links can easily be imported into WYSI-Help 
Composer.    These files would include hypertext files created in word processors or by WYSI-Help 
Composer and other help authoring tools.

Procedure

1. Select the Open command from the File menu.    The Open dialog box will appear.

2. In the lower left corner of the Open dialog box, click on the drop down arrow for the List Files of 
Type drop down list.    Select RTF (*.RTF).

3. Enter the name of the hypertext file you want to import, or use the Browse... button to select the 
desired hypertext file.

4. Click on the OK button.    WYSI-Help Composer will automatically recognize that the RTF file 
being imported is a hypertext file by noting the presence of certain topic codes at the beginning of 
each topic.    The file will be imported with topics, links, titles, search keywords, and browse 
sequences intact.    You may now edit your hypertext file.

Note:
When you save the imported hypertext file, it will be saved in WYSI-Help Composer format (DHF 
format).    If you choose to convert the saved file to RTF format, it will create a new RTF version.    If 
the new file is in the same directory as the original RTF file, WYSI-Help will overwrite the original RTF 
file unless you have changed the file name for the new file.        Use the Save As command from the 
File menu if you want to change the name.

Related Topics

Basics of importing RTF files
Importing manuals and other documents in RTF format
File Open command
Save As command



Importing a manual or document in RTF format

RTF files can be produced by most word processors and many page layout applications.    This allows 
you to create and save a manual that can later be used as the basis for a help file.

When an RTF file is imported, WYSI-Help Composer will analyze the structure of the document to 
create the topics in your help file.    The RTF importer can also be configured to create an index topic, 
create a list of search keywords, and automatically generate hypertext links.

You configure the RTF importer through defining a set of import rules.    These import rules allow you 
to determine how WYSI-Help Composer will create topics, and whether to generate an index, 
keywords, or links.    You define these rules by making selections in a series of dialog boxes displayed 
by the RTF importer.    When you have completed your choices, the file will be imported according to 
the defined rules.    When the import is completed, you will be given to opportunity to save the rules as 
defined.    Doing so is useful when you have a number of similarly formatted documents to import.    For
example, your manual may be divided into several documents by chapter.    After defining the import 
rules for one chapter, you can quickly import the rest without having to redefine the rules each time.

Note:

What follows is the basic procedure for importing a manual in RTF format.    For more complete 
information on how to define each rule, click on the appropriate link.

Procedure

1. Select the Open command from the File menu.    The Open dialog box will appear.

2. In the lower left corner of the Open dialog box, click on the drop down arrow for the List Files of 
Type drop down list.    Select RTF (*.RTF).

3. Enter the name of the hypertext file you want to import, or use the Browse... button to select the 
desired hypertext file.

4. Click on the OK button.    WYSI-Help Composer will automatically recognize that the RTF file 
being imported is not a hypertext file by noting the absence of topic codes at the beginning of 
each topic.    Therefore, WYSI-Help Composer will identify the procedure as a document import 
and will display the Document Importation dialog box.    This dialog box allows you to define import
rules.



The Document importation dialog box opens in the Styles of titles view.    Here is an example of 
that dialog box for a manual file named RTFIMPRT.RTF:

Click on the various areas of the dialog box picture for information in the function of each area.

5. Define the rules for importing your document:

Decide how topics will be created.

Choose whether or not to ignore certain styles in the document.

Choose rules for creating a main index topic.

Choose rules for adding search keywords.

Define any automatic links desired.

Choose whether to include RTF commands.

6. When you have finished defining rules, click the Import button.    WYSI-Help Composer will import 
the document according to the rules defined.    You may now edit your hypertext file.

Note:
When you save the imported hypertext file, it will be saved in WYSI-Help Composer format (DHF 
format).    If you choose to convert the saved file to RTF format, it will create a new RTF version.    If 
the new file is in the same directory as the original RTF file, WYSI-Help will overwrite the original RTF 
file unless you have changed the file name for the new file.    Use the Save As command from the File 
menu if you want to change the name.



Related Topics

Basics of importing RTF files
Importing manuals and other documents in RTF format



RTF Import Rules:    Creating search keywords

Search keywords are descriptive words or phrases assigned to topics which allow the user of your 
help file to quickly locate the desired information. The Windows help engine possesses a search 
function which supports the use of keywords. If your document has an index (a list of words and 
phrases referring to parts of the document), the RTF importer may use this index to automatically build
a list of search keywords associated with each topic.

The ability to create a list of search keywords is controlled by the value in the Create keywords 
checkbox. When this rule is selected, a list of search keywords will automatically be generated for 
each topic, based on the index within the imported document.    The importer compares all of the 
words listed in the document's index to the words in each topic.    If a word appears both in the index 
and in a topic, that word will be listed as a search keyword for the topic.    If the document does not 
have an index, keywords will not be generated in this manner.

If the Create keywords rule is selected for a document without an index, then the RTF importer will 
compare the topic titles selected with titles within the document.    If    any titles match, they will be 
entered as keywords.

Related Topics

Importing manuals and other documents in RTF format
Creating new topics by page break
Creating new topics by title change
Choosing to ignore certain styles in the document
Creating a main index topic
Adding search keywords
Generating automatic links
Including RTF commands



RTF Import Rules: Creating new topics by page break

To use this method of topic creation, you must have inserted forced page breaks into your document.   
The contents of each page will be placed into a separate topic.    The RTF importer will automatically 
create topic names based on the first line of text on each page.

Once you select the New topic on page break option, you will no longer be able to select the Styles 
of titles view.    Instead, you will automatically be shifted to the Titles view.

You may now define any other rules you wish to use for the import.

Related Topics

Importing manuals and other documents in RTF format
Creating new topics by title change
Choosing to ignore certain styles in the document
Creating a main index topic
Adding search keywords
Generating automatic links
Including RTF commands



RTF Import Rules: Creating new topics by title change

To use this method of topic creation, you must have used different text styles to identify the chapter 
headings, subchapters, sections, and body text in your document.    Any change to the text attributes 
will be identified as a different style by the RTF importer.

When New topic on title change is selected, you must select the styles used by the titles in your 
document using the Styles of titles view.    You then need to switch to the Titles view to select the titles 
you wish to include in your help file..

Selecting the styles of titles

For the importer to convert a file, you must select the styles used by the titles in the document. You may 
also structure them by using the right and left indenting buttons. In the following example, the first three 
styles have been selected and indented in order to create a structure, which in this case, is based on the 
size and font of each style :

As far as the RTF importer is concerned, a style is composed of five properties:

- The name of the font, Times New Roman in this example.
- Attributes of the text : normal, bold, italic, underlined, strike-through, suffix, exponent.
- The size of the font, expressed in points.
- The color of the text.
- The alignment of the text.

Note:
A title style is generally bold and/or of a larger size than normal text.

Selecting topic titles

Once you have selected the styles of titles, you may select the Titles view and the importer will search for 
the corresponding titles.Before you launch the topic importing process, you may pick out those topics that 
you don't wish to import. At the beginning, the Titles view contains all of the titles found :



By default, all of the titles will be selected; in other words they are all ready to be imported.

In our example, the titles in levels 1 & 2 don't correspond to topics, since no text follows them in the document. 
Therefore, these titles have been deselected using the buttons labelled Select and Expand to level (no topic will
be created for these titles, and these titles will not be imported).

Related Topics

Importing manuals and other documents in RTF format
Creating new topics by page break
Choosing to ignore certain styles in the document
Creating a main index topic
Adding search keywords
Generating automatic links
Including RTF commands



RTF Import Rules: Choosing to ignore certain styles

When you are importing a document,you may want to exclude certain sections of the document from 
the hypertext file. There are two ways to leave certain parts of a document    out of the hypertext file :

1. By not selecting a particular title in the Titles view, you may indicate to the RTF importer that it
should not import anything which occurs between the current title and the following title.

2. By selecting the Ignore certain styles rule, you may define sections of the text not to import, 
which would otherwise have been contained inside the topics to be imported. 

When the Ignore certain styles rule is selected, the Ignored Styles view becomes available.    If you 
switch to Ignored Styles view, any style you select will be ignored during the import.    Text titles using 
those styles will not be turned into topics, and any text following those styles will also be left out, until 
the RTF importer reaches the next title that has been selected for import. 

Related Topics

Importing manuals and other documents in RTF format
Creating new topics by page break
Creating new topics by title change
Creating a main index topic
Adding search keywords
Generating automatic links
Including RTF commands



RTF Import Rules: Creating a Main Index topic

The RTF importer can set up a main index, or Contents, topic consisting of links to selected topics 
created from the imported document.      The importer will create a special topic, called Main Index, in 
which each title selected for import will have a hypertext link to an appropriate topic.    For the RTF 
importer to create an index, the Create main index rule must be selected.
When the Create main index rule is selected, the Main Index view of the Document Importation dialog
box becomes available.    You must select the Main Index view to set up the order of entries in the 
main index topic.    When this view is selected, a list of all the titles selected in the Titles view will be 
displayed.    These will be listed according to the hierarchical levels selected in the Styles of titles view. 
At least one style must have been selected in the Styles of titles view, and one title selected in the 
Titles view, in order for any titles to display.

Here is an example of the Main index view of the Document importation dialog box.    All of the topics 
are selected in this example.

By default, all of the titles selected in the Titles view will also be selected in the Compose index list in the Main 
index view.    You may exclude any titles by double clicking on them or by highlighting them and pressing the 
Selection button.    Excluding a topic doesn't mean that the topic of this name won't be imported, but simply that
its title won't appear in the index.

The order of the titles on the Compose index list determines the order of entries in the main index 
topic.    You may alter the title order by using the arrow buttons to move the current title up or down.    
This allows you to create your own order for the topics index.

The Alphabetical order button may be used to sort the titles in alphabetical order, while respecting 
the hierarchy of the titles (the ordering will be performed level by level).    The titles in the first level will 
be sorted into alphabetical order.    Under each title in the first level, the subtitles will then be sorted 



into alphabetical order, etc...    You may restore the titles to Document order by clicking on the same 
button.

Related Topics

Importing manuals and other documents in RTF format
Creating new topics by page break
Creating new topics by title change
Choosing to ignore certain styles in the document
Adding search keywords
Generating automatic links
Including RTF commands



RTF Import Rules: Generating automatic links

The importation rules field of the Document importation dialog box provides three choices for 
automatic hypertext link generation.
1. None: No links will be generated.
2. First occurrence: A link is generated for the first occurrence of the selected link text within a 
topic.
3. All: A link is generated for the every occurrence of the selected link text within a topic.
The default is First occurrence.

For the RTF importer to create hypertext links, it is necessary to choose either All or First occurrence
from the Links drop down menu.

Once links have been turned on, select the Titles view. If the current title happens to be a selected 
title, pressing the Link button will open the following dialog box:

In this example, the current title is named "Title 1.1.1" and the dialog box now allows the definition of hypertext 
links which will call the topic "Title 1.1.1". In other words, "Title 1.1.1" will become the target topic for the links 
which have been defined.

When first opened, the dialog box shown here contained the topic title as a default link. In this example, the 
default link was removed by selecting it and pressing the Remove button. Four new links were then defined.    
The currently highlighted link in this example, called "albatross", will be a popup link.



To define a new link,    type in the new reference text in the zone marked Text, and select the type of link it 
is to become. Then press the Add button.

During the import process, hypertext links are generated each time a reference text is found in a topic other 
than the target topic    In this example, every time one of the four bird names is encountered, it will be linked 
to the topic "Topic 1.1.1".. If the First occurrence option has been chosen, a link will only be created for the
first occurrence of a reference text in each topic.    If All has been chosen, a link will be created for every 
occurrence of a reference text in a topic.

Related Topics

Importing manuals and other documents in RTF format
Creating new topics by page break
Creating new topics by title change
Choosing to ignore certain styles in the document
Creating a main index topic
Adding search keywords
Including RTF commands



RTF Import Rules: Including RTF commands

 When the RTF commands import rule is selected, the RTF importer will search for RTF formatting 
commands and insert special WYSI-Help Composer RTF characters at each command's location.    
The RTF commands will then operate normally, formatting the paragraphs where the RTF characters 
appear.    After importing, the RTF commands may be edited or deleted by selecting the corresponding
RTF character and using the Edit RTF command from the Edit menu.

If the RTF commands import rule is not selected, the importer will not look for RTF formatting 
commands.    Any such commands found in the text will be imported as part of the text.

The default setting for this rule is off.

Related Topics

Importing manuals and other documents in RTF format
Creating new topics by page break
Creating new topics by title change
Choosing to ignore certain styles in the document
Creating a main index topic
Adding search keywords
Generating automatic links



Cancels the RTF import.    Changes to rule definitions will not be registered.



When this view is selected, a list of all the titles recognized by the importer will be displayed.

If the New topic on title change rule is selected, titles will be listed according to the hierarchical 
levels selected in the Styles of titles view.    At least one style must have been selected in the Styles 
of titles view in order for any titles to display.

If the New topic on page break rule is selected, the first sentence on each page will be displayed as a 
title.

Double click on a title to include it on the list of new topics to be created.



This view is available when the Ignore certain styles rule has been selected. When this view is 
selected, a list of all text styles used in the document will be displayed in the field to the upper right.    
Double click on a style name to exclude all text using that style from the document.



When this view is selected, a list of all text styles used in the document will be displayed in the field to 
the upper right.    Double click on a style name to include all titles using that style.    Each time a 
selected style is encountered during the import, the importer will turn any selected titles with that style 
into a new topic.    All text following will be included in the body of the topic, until the next selected style
is encountered.

If more than one style is selected, you may use the left and right arrow buttons to set up a hierarchy of 
styles.    Styles indented to the right will represent subtopics for the purpose of the main index.

Once styles have been selected and put into a hierarchy, the RTF importer can scan the document for 
text titles that use the selected styles.    Switch to the Titles view to see and select the potential topic 
titles.



Moves the selected title style one tab stop to the right, which moves it down one level in the current 
hierarchy.



Moves the selected title style one tab stop to the left, which moves it up one level in the current 
hierarchy.



Click on this button to select the highlighted topic.



The Expand to level button selects or deselects all topics that are on the same hierarchical level as the
currently highlighted topic.

If the currently highlighted topic is at the leftmost level and has already been selected, then pressing 
Expand to level will select all of the other topics at the leftmost level.    If the currently highlighted topic 
is indented to the right one level and has been selected, then pressing Expand to level will select all of 
the topics indented to the right one level.

If the currently highlighted topic has not been selected, then    pressing Expand to level will deselect all
topics on the same level.



Opens this help file.



RTF Import Rules: Choosing how new topics are created

You may select one of two ways to create new topics:

1. By page break

2. By title change

Which method you choose depends upon how your document is organized.    If you have separated 
topics in your document by forced page breaks, then use the page break method.    If your document is
organized into topics and subtopics that use different text styles, you can use the title change method.

An example of a document using different text styles is the following:

Chapter 1
Introduction

body text
RTF importer basics

body text

Chapter 2
Importing an existing hypertext file

body text
Why import a hypertext file?

body text
How WYSI-Help Composer recognizes a hypertext file

body text
Editing the hypertext file

body text
(etc.)

This document uses one text style for chapter headings, and two different styles for subheadings.    A 
fourth style is used for body text.    A new topic can be created every time the text style changes to a 
new type of heading style.

Creating new topics by page break
Creating new topics by title change



Begins the import of the RTF file according to the rules defined.



WYSI-Help Composer identifies an RTF file as a hypertext file by recognizing and interpreting the 
codes which are placed at the beginning of each topic. A topic begins with the characters # $ K +. 
Each character refers to information which is located in a footnote to the topic.

# this character refers to the topic identifier. This identifier becomes the name, or context id, of the 
imported topic.

$ this character refers to the topic title as well as to the different search keywords. The title and the 
search keywords will be visible to the final user of the help file through the Search and History 
functions.

K this character refers to the search keywords associated with a particular topic. The different 
keywords are separated by commas in the footnote.    If the topic does not possess any search 
keywords, this character will not be present at the beginning of the topic or in the footnote.

+ this character refers to information concerning the position of the topic in a browse sequence.



Allows you to link selected topic titles into browse sequences.



When this rule is selected, the RTF importer will create a main index, or Contents, topic, and the Main 
Index view of the Document Importation dialog box becomes available.    Select the Main Index view to
set up the order of entries in the main index topic.



When this rule is selected, a list of search keywords will automatically be generated for each topic, 
based on the index within the imported document.    The importer compares all of the words listed in 
the document's index to the words in each topic.    If a word appears both in the index and in a topic, 
that word will be listed as a search keyword for the topic.    If the document does not have an index, 
keywords will not be generated.



When this rule is selected, the Ignored Styles view becomes available.    If you switch to Ignored 
Styles view, any style you select will be ignored during the import.    Text titles using those styles will 
not be turned into topics, and any text following those styles will also be left out, unless the following 
text belongs to a style that has been selected for import. 



Allows you to select when and how to generate automatic links between topics.



Allows you to choose how the document will be broken up into topics.    New topics can be created 
after every page break, or each time the title style changes.



When this rule is selected, RTF formatting commands embedded in the text of your document will be 
imported.    Otherwise, embedded RTF commands will be ignored.    The default is for RTF commands 
to be ignored.



When the Styles of Titles view is selected, this field displays a list of all text styles used in the 
document.    Double click on a style name to include all titles using that style.    Each time a selected 
style is encountered during the import, the importer will turn any selected titles with that style into a 
new topic.    All text following will be included in the body of the topic, until the next selected style is 
encountered.

If more than one style is selected, you may use the left and right arrow buttons to set up a hierarchy of 
styles.    Styles indented to the right will represent subtopics for the purpose of the main index.

Once styles have been selected and put into a hierarchy, the RTF importer can scan the document for 
text titles that use the selected styles.    Switch to the Titles view to see and select the potential topic 
titles.



This view is available when the Create main index rule has been selected. When this view is 
selected, a list of all the titles selected in the Titles view will be displayed.    These will be listed 
according to the hierarchical levels selected in the Styles of titles view.    At least one style must have 
been selected in the Styles of titles view, and one title selected in the Titles view, in order for any 
titles to display.

The order of this list determines the order of entries in the main index, or Contents topic.    Use the 
buttons to select whether to list titles in alphabetical order, or in the order they appear within the 
document.    You may also select individual titles and move them up and down on the list by using the 
up and down arrow buttons.



Multiple Topic Print Feature
There are two ways to provide the end user of your help file with the ability to print multiple help topics 
in one print file:

1. Implement the WYSI-Help Explorer
2. Implement the multiple topic print feature

If you choose not to provide the other WYSI-Help Explorer features to your end users, but do wish to 
make the multiple topic print feature available, you may follow the instructions here.    However, since 
the WYSI-Help Explorer adds more functionality to your help file, it is recommended that you use that 
method.

To implement the multiple topic print feature, you need to edit the project file of your help file and 
include one WYSI-Help Composer .DLL with your help file. WYSI-Help Composer users can distribute 
this DLL with their help files for free. The necessary .DLL is WHEDPRIN.DLL, which should to be 
installed in the Windows directory on the computers using the multiple print feature.

To implement the multiple topic print feature, add following lines to the [CONFIG] section of your 
project file by using the Project Editor and replace MYHELP with the name of your help file:

[CONFIG]

RegisterRoutine("WHEDPRIN.DLL","ExtractFromHF","SSS")
CreateButton("DDTEC_Print_Button","P&rint","ExtractFromHF('MYHELP.HLP','MYHELP.H','MYHELP
.H'):ExecProgram('WYSIPRT.DLL MYHELP.H',0)")

Compile the .HLP file in the WYSI-Help Composer directory.

The topic titles are the topic identifiers that are used in the print dialog.

Click on the Image below to get more information.

Relate Topics

Printing topics from WYSI-Help Composer



Print Setup Button
Access the printer setup for the currently installed printer.



Print Button
Print the topics in the Print List in the order that it appears.



Down Button
Moves the selected topic in the Print List down through the print order.



Alphabetize Button
Sorts the list of topics so they print in alphabetical order.



Up Button
The up button moves the selected topic up in the order of Topics to Print. 



Topics to Print List
This is the list of topics that are to be printed.    They will print from top to bottom.



Remove Button
This button removes the selected topics from the Topics to Print list.



Add Button
Transfers the topics from the Available list to the Print list



Available Topics
These are the topic titles available in the help file to print. Transfer them to the Topics to Print list and 
click on the Print button.    






