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Introduction

The World Radio Amateur Directory (WRAD) is the worlds largest collection of callsigns, pictures, QSL cards and 
personal biographies from amateur radio operators around the world. It is a publication about radio amateurs, their 
friends, their lives and their accomplishments.    This immense collection of information is made even more powerful 
by the exclusive WRAD Browser software. It features a powerful index containing over 13 million keywords so that 
any callsign, callsign suffix, name, street, city, PO Box, or other minute item in the entire database is instantly 
locatable.    Want to know how many hams named Elmer live in California? The WRAD index will locate this 
information and tell you instantly.

With the WRAD browser software you can:

{button ,JI(`',`.searching')}        Search the directory
{button ,JI(`',`.lists')}        Create and/or edit lists of callsigns
{button ,JI(`',`.add_edit')}        Add and/or edit callsign data
{button ,JI(`',`.biographies')}        View biographies and pictures
{button ,JI(`',`.notebook')}        Maintain a detailed personal notebook



Searching the Directory

Searching the WRAD is very easy. 

 First, click on the DB List tab
 Next, enter some text into the Search Key box
 Then, click on Search

A number will apear In the lower left hand corner of the screen indicating how many records matched your 
unique search criteria.    The first match found will automatically be shown in the database list.    If more matches 
are available, you can click on one of the blue or green continue buttons to list the additional entries that match 
your search criteria.

Search Keys
You can put just about anything into the search key box.    Commas, periods and other punctuation marks are 
always ignored.    Upper and lowercase letters are considered the same.    When you specify more than one 
keyword, the search is extended to find only those records which contain all of the items that you input into the 
Key box (this is also known as a logical AND operation).    Don’t use the keyword AND, because it is 
automatically implied and will otherwise cause the engine to search for records which actually contain the word 
AND. 

Keyword example: suppose you are looking for folks in Dallas, Texas.    According to the WRAD search rules, any
of the following key phrases will return the same information:

Search Key:      dallas tx
Search Key:      tx dallas
Search Key:      Dallas, TX

Note that if you use the word “Texas” instead of “TX” you will get entirely different results.    The software does 
not know that TX is the same as Texas and will thus look for the actual word “Texas” in all of the records.

Every single word in the callsign database is indexed.    The master index contains over 13 million search keys, 
each of which points to a unique occurance of that word in the callsign database.

Words and text contained in the personal biographies and in your own notebook entries are not indexed and are 
therefore not found by the search engine.    Email addresses are also not searchable.

Callsign Suffixes
The WRAD browser software is also optimized to return groups of callsigns by suffix. A callsign suffix consists of 
the letters after the number.    For example, if you search for the letters BQ,    the system will return 4X1BQ, 
AA1BQ, AA2BQ, AA3BQ, and so on. 

 
Search Key Filters

When you search for Dallas, TX as in the example above, you will find not only people living in the city of Dallas 
but also folks who might live on “Dallas Street” in other Texas towns.    It might also return people whose first or 
last name is Dallas, living anywhere in Texas.    This is because the keyword search is literal, and it simply returns
every record which contains the given search keys.    To further narrow the search to a specific category of 
information, a search filter is used.    In our example, if you really want only those amateurs who live in the city of 
Dallas, you are given two basic choices:    either use search key filter or try searching for a particular zip code.

Above the Search Key box are a group of checkable filter items.    When the None item is checked, no filtering is 
performed and all fields are searched.    When a given filter is chosen, the search is limited to the selected filter 
item.    Therefore, to locate people specifically living in the city of Dallas, you may want to select the City filter.    
Note that unless you include TX with Dallas, that you’ll also find towns in other states that are also named Dallas.

To avoid ambiguity and make the most accurate city or town search, searching by Zip Code is always a good bet.
You may have to perform several searches when a metropolitan area has more than one Zip Code. 

If the search key that you have input returns too many irrelevent records, you can always narrow the search by 
being more specific (i.e. using more keywords).    With a little practice, you should get the hang of it quickly.

Limitations



The search engine will return at most, 200,000 records on any search.    You can’t locate the key ‘USA’ because 
of this (since it would return over 700,000 matches).



Using the Search Controls

The search controls are located at the bottom of the DB List screen.    The six check boxes along the top of the 
control area are the Search Filters.    They permit you to narrow the keyword search to a particular category of keys

Below the Search Filters is the Search Key box.    This is where you input key words that you wish to search for in the
database.    Notice that the Search Key box is a drop-down control which contains a history of the most recent keys 
that you’ve searched for.    This search history is saved when the program exits so that you can always instantly recall
the last few searches that you have performed.

Below the Search Key box are the Control Buttons.    Left to right, these are:
The Clear button – erases the current Search Key
The 1 button – advances to the next matching record
The 10 button – shows the next 10 matching records
The 100 button – shows the next 100 matching records
The All button – shows all of the matching records
The Red (Stop) button – interrupts a long listing
The Search button – begins a new search



Working with the Database List

The DB List (or database list) is where the main search results are shown.    When you click on any list item, it 
becomes the selected listing.    Once a listing is selected, you may then navigate to either the Bio page or to the 
Notes page for further information on that callsign.

As you continue to look up callsigns, the length of the list will grow.    Once you are satisfied with the contents of the 
list, you may Save the list by using the File->Save menu option.    This way, you can always reload this list whenever 
you restart the WRAD program.    Some folks will use the Save List capability to maintain a simple logbook of all their 
contacts (with detailed notesas well).

You can remove single list items by pressing either the Delete key on your keyboard, or by selecting the Edit->Delete
From List item from the main menu.    You can quickly clear the entire list by choosing the File->Clear List menu 
option.

The main DB List display consists of six columns.    The width of each column is adjustable by simply clicking on the 
column header dividing line and dragging the column left or right.    The column widths are saved and restored each 
time you start the program.    One column, the F column, is used to display certain flags which indicate whether 
biographies, pictures and/or notes are available.    When these items are available for a given listing, you’ll see one or
more periods in the F column.

Once a callsign is in the list, it may be edited to your liking.    Edited (or added) callsigns are a part of a special 
category of records which are searchable only by callsign.    Just as easily, you can add callsigns    to the database 
which were not available at the time the WRAD CDROM was published. 

Exporting Data
When you select File->Save List from the menu, you are given the option of saving to several different file types.
The choices are:

Wradlist file (.wlf) –    the default type used for saving callsign lists
Text by Name (.txt) - a regular .TXT file, name first on each line
Text by Callsign (.txt) – a regular .TXT file, callsign first on each line
CSV Data File (.csv) – a type recognized by many other databases
QRZ Raw Data (.qrz) – Raw QRZ database records (plain text)

The list can hold an unlimited number of callsigns, depending only on the amount of memory in your system. 
(Note: any one search may return at most 200,000 callsigns, however, you may perform multiple searches which 
total more than 200,000 callsigns.    If you’re going to do this then you had better have lots of memory.).

Reordering the List
After data has been placed in the list, it may be reordered (sorted) several ways.    To reorder the list, you may 
use the Reorder menu item which offers the choices of Callsign (the default), Name, Street, City and Country. 
For example, to reorder the list by last names, simply click on Reorder->Name.

Note that when the list contains more than about 1000 names, it may take up to several seconds for the 
reordering to complete.    On a very slow machine with a large list, it might take minutes.    Please be patient.    
Also, note that reordering only affects callsigns which are already in the list at the time the Reorder menu item is 
selected.    New items which are subsequently added to the list are aalways appended in Callsign order.





Adding and/or Editing Callsign Data

Any callsign which is displayed in the DB List may be edited by selecting Edit->Edit Callsign from the main menu.    
Callsigns that you edit are saved on your hard disk and become part of a separate private database that you control.   
Similarly, if you use the Edit->Add New Callsign menu option to add a callsign which was not included on the WRAD
CDROM, it too goes into your private callsign database.    

An important thing to remember is that callsigns from your private database (also known as My Listings in the 
Special menu) are treated differently when the WRAD search engine is used.    In summary, the records in your 
private database are searchable only by callsign. You will also notice that callsigns which were supplied by the 
WRAD CDROM and then later edited by yourself will also continue to appear in their original, unedited state 
whenever some other ordinary search key matches on one or more of their CDROM–listed components.

Here’s an example.    Suppose you have a friend whose license record shows that he lives at 1234 Main Street.    
Since his license was issued however, he has moved and now lives at 4567 E. Willow Street.    You can record this 
change in your private database by using the Edit->Edit Callsign function to input the new Willow Street address.    
Later, however, when you perform a routine search for “Main Street” addresses you will notice that your friend still 
shows up in the listing even though you changed his address to Willow Street. This happens because the original 
record, which is on CDROM, cannot be removed or altered.    On the other hand, when you search for your friend’s 
callsign, it will always show the new Willow Street address since since the private database is always searched first 
for a callsign match.

There is a special Edit menu function called Edit->Delete Callsign. This menu item is used to remove a callsign from
your private database.    This feature does not prevent callsigns which are still in the CDROM database from being 
listed.

Submitting your private database to the WRAD
The editors of the WRAD are pleased to accept non-USA listings that you have entered into your private 
database for inclusion into the next edition.    All you have to do is send us the file called wradnew.mdb which is 
located in the directory where you installed the WRAD browser software (typically in the same directory where 
wrad.exe is located.    You can use Start->Find to locate this file.

Free upgrade offer
If you send us a wradnew.mdb file with at least 1000 callsigns that are not in the current edition of the WRAD, 
you may be eligible to receive a free update to the next edition of the WRAD CDROM!    New listings must be as 
complete as possible, and must contain at a minimum, a callsign, a name, a mailing and/or QSL address, and a 
Country.    We will also gladly accept files containing 100 or more callsigns as a contribution to our main 
collection.    Your callsign will then be entered into our “valued contributors” list that will appear in the next edition
of the WRAD.    

Note that QRZ reserves the right to discontinue this offer at any time and/or not to award a free upgrade for any data file 
which appears to have been copied or shared from one WRAD user to another.    There is also a limit of one free upgrade 
per WRAD user per current edition.    Also, we cannot accept listings containing non-western character sets.

Please email your completed wradnew.mdb files to: editor@qrz.com or, send them on floppy disk to the WRAD     
postal address. 



Viewing Biographies and Pictures

To view biographies and pictures you simply click on the Bio tab at the top of the screen.    Not all callsigns have 
biographies and pictures but the collection is constantly growing.    If a callsign has a biography and/or picture on file, 
you will see one, two or three dots in the F (flags) column of the main DB List window.    There is also a Prev and a 
Next button on the Bio page.    You can use these buttons to advance to the next biography and/or next picture in the 
main list.

How to view All the Biographies and/or Pictures
There is a special key that is used to fetch only those callsigns which have biographies. The key is    ~B and it is 
shorthand for “has biography”.    The key may be used in conjunction with other keywords.    For example, to find 
only biographies of Texas amateurs, use “~B TX” as the Search Key.    The Special menu item is provided to 
automatically insert this key into the Search Key box. 

The special key for pictures is ~P and it works the same way as the biography key.    You can also specify “~P 
~B” to select only those records which have both a picture and a biography.

Note that the biographies may not be edited and you can not add new biographies.    You may use the notebook 
for recording this type of information.

{button ,JI(`',`.sendimage')}        How to submit your picture to the WRAD



The Notebook Feature

The notebook is a valuable feature that provides the capability of keeping a virtually unlimited number of detailed 
notes on each and every amateur that you come into contact with.    When combined with the ability to save and 
reload lists (from the File menu) it becomes possible to maintain a very comprehensive log of your operating 
activities.

A note is available for each and every callsign on the system.    To access a note, simply choose a callsign from the 
main DB List and then click on the Notes tab at the top of the window.    Once you have switched to the notes page, 
you may type anything that you like into it.    There is no “save” command, the system just remembers everything that
you type, automatically.    Whenever you return to this this callsign and this page, it will be there just as you last left it.

Backing up your notes
Don’t forget that you are responsible for backing up your notes.    Backup is important because in the event of a 
system crash, power failure or some other unforseen problem, you may need to reload the WRAD from CDROM 
and restore your own notes file.

The notes are kept in the file called wradnote.mdb and this file is located in the same directory where the main 
program executable, wrad.exe is found.    You can use the Start->Find command to locate this file.    If you use 
notes a lot, you may want to backup this file once per day (when you’re using it). You can keep it on a floppy or 
other disk device.    Just be sure that you have a spare copy if these notes are important to you. 

Removing notes
When you are on the notebook page, the Edit menu contains a special option called Delete Note that you can 
use to remove the current note from your system.    



Submitting Images to the WRAD

Adding your image to the collection:

If you would like to see your QSL card in an upcoming edition of the WRAD CDROM, there are several ways you
can do it.    All hams are invited to have their cards added to the collection.

Your card or picture can be of just about anything that you would like to represent you and your callsign to the 
world.    It can be a scanned image of your QSL card, a photo of your shack, your favorite antenna, etc. 

We reserve the right to refuse to publish any image which we believe is inappropriate.

Getting your card or picture to us:

Digital Images (.JPG Files)
All digital image files must be in .JPG format and must not exceed 400x300 pixels (as landsacpe) or 300x350 (as
portrait). The final file size must be less than 40KB. Images may be either color or black and white. If your system
cannot create a .JPG file then you can send to us in any of the popular formats such 
as .GIF, .PCX, .BMP, .TIF, .PSD,    and .TGA, and we’ll try and convert it for you. (Hint: to reduce a .JPG file size, 
select a quality factor of 2 or less).

How to submit your image file to the WRAD

By Email 
The easiest way to send us your image is to email it to us.    Please send your picture as a regular MIME Email 
attachment.    DO NOT send in .HQX or .BINHEX format as we do not have the ability to decode these types. If 
no other method is available, we can also accept UUENCODED files.

Anonymous FTP
You may use FTP to transfer your file to us.    Use the FTP address of ftp.qrz.com . Just place the file in our /tmp 
directory.    Be sure and name your file after your callsign such as W1ABC.JPG.    Don’t expect us to look at a 
photograph to try and figure out which callsign it belongs to.    We will discard any files which are not named after 
a callsign.

From your home page:
If you have an image already available via the World Wide Web, just drop us an e-mail and tell us where it can 
be found using a browser. 

Regular Mail:     
Floppy Disk - You can mail your favorite image on a 3 ½    inch MSDOS formatted floppy disk. Sorry but only one 
image per callsign is allowed.    A single floppy disk may contain images for multiple callsigns.

Actual Photo or Card
We will gladly digitize your hard copy photo or card on our color scanner. Just send it to us and we’ll see what we
can do.    Please allow 6 to 10 weeks for processing.

The WRAD mailing address is:

The World Radio Amateur Directory
8711 E. Pinnacle Peak Road #159
Scottsdale, AZ    85255      USA

If your image is accepted, it will first appear on the QRZ Web server, http://www.qrz.com.

We do not normally return cards or photos submitted by regular mail.    If you must have your card or photo returned, 
please include a self-addressed stamped envelope along with your letter.

Please do not send us any image or photo that contains copyrighted material.



Setting Fonts, Colors and other Options

To setup desired fonts, font sizes, colors and other options, use the Edit->Preferences item on the main menu.    
From here you can make settings to a wide variety of preferences to further customize your copy of the WRAD.

All color and font settings are remembered when you exit and restart the WRAD.



Printing Notes and Lists

The WRAD browser software is capable of printing lists of callsigns that you assemble in the DB List screen, and 
Notes that you create using the notebook feature.    To print, simply choose File->Print from the main menu.    You 
may also want to choose File->Print Setup to have better control of which printer is used, paper layout, etc.

The numbers at the bottom right of the DB List screen indicate what line you’re currently on and how many pages of 
text would be printed if the main list were sent to the printer.

Creating Mailing Labels
There is no builtin feature for creating mailing labels however the WRAD Browser software creates a type of file 
which is easily imported into most word processors.    Once you have assembled a list in the DB List screen, 
choose the File->Save menu option and select a file type of CSV File (.csv),    enter a file name and click Save.

Most word processors, database programs and spread sheets work well with the CSV file format.    Just choose 
the data import feature of your software and proceed as normal to create a mailing list and/or print to labels. 

Please consult your program’s documentation for specific instructions on how to create mailing labels by 
importing CSV files. 



Frequently Asked Questions

Q. Where are the WRAD browser data files located?

A. See the section on Setup Information

Q. Where is the County, Grid Square and/or Lat/Lon information?

A. The WRAD database does not support this information at this time.    Presently, there is no known method of 
mapping an individual amateur’s street address to a County and/or set of Lat/Lon coordinates.    You say that 
other CDROMS do it?    Not really, they’re guessing.    If you look carefully at those products you’ll notice that 
everybody in the same zip code has the same Lat/Lon coordinates.    While the WRAD home page at 
http://www.qrz.com does take a stab at it, it’s not yet accurate enough for publication in the CDROM – we’d 
rather not publish it if it’s not correct.

Q. How can I generate a list of email addresses?

A. You can’t.    QRZ does not authorize the use of its data for the purpose of generating mass email postings.    QRZ
protects its email database to prevent so-called “spam” operators from taking advantage of the amateur 
community.    QRZ will not furnish or sell its email lists to any party.

Q. Why isn’t my callsign in the database?

. It takes about two months to produce the WRAD CDROM. Your callsign or upgrade may have not reached the 
WRAD in time to make the most recent edition. The date on the most recent edition is the date that it was 
released, not the date of the last database update which may have been several weeks before. In addition, there 
can also be errors or omissions in the FCC’s master copy of the database. The QRZ Callsign database is as 
complete as we can make it at the time it is published, but we cannot guarantee that it is free of errors.

Q.    Why aren’t there more foreign (i.e. non-USA) callsigns?

. In many countries, the callsign data is copyrighted or otherwise restricted on privacy grounds. In some countries, 
the exclusive rights to the data has been sold to private companies and/or to radio clubs. When this is the case, it
is impossible for us to obtain legal copies of the information since others (competing callbooks) already hold the 
exclusive rights. In some countries, no computer readable form of the data exists anywhere and may well be 
nothing more than an old notebook in some remote government communications office.    We cannot make use of
printed lists either since we have no typing staff to convert the stuff into machine readable form.    Similarly, we 
have not found an acceptable OCR program that works well enough for this purpose.

At QRZ we’re always looking for more (free) callsign data.    See our section on Adding and Editing Data on how 
you can submit new callsigns to the WRAD and earn a free upgrade to the next    editon of the CDROM.

Q. The data shown for may USA callsign is incorrect. Will you please correct it?

. No, sorry, we can’t.    We receive all of our USA data directly from the FCC.    If any part of your data (except for 
your email address) is incorrect, you must submit a 610 from to the FCC.    You can download the appropriate 
FCC forms online at http://www.fcc.gov .    

If you are a non-US amateur, you may update your information using our online server at:

http://www.qrz.com/cgi-bin/web_add 

Q. One or more of the callsigns listed belonged to a Silent Key.    Why are these callsigns still in the 
database?

A. When an amateur passes away, the FCC rarely hears about it.    They must be notified so that the record can be 
removed from the database. Sometimes it can take several months or perhaps a year or more depending on 
whether the family formally notifies them. Typically, the FCC will not accept notification from non-family members,
however, we have been told that they will accept a newspaper obituary as evidence of death. 

Q. When I run the WRAD software, my system crashes with an Access Violation, Illegal instruction or some 



other fault.    What’s wrong and is there a fix for it?

. The most common cause for these sorts of problems are incompatible versions of DLL’s and OCX files which 
have been installed on your system since you first installed Windows.    Every time you install a new piece of 
software (including WRAD), new versions of existing DLL’s and OCX’s usually get installed. The WRAD 
installation program will not install an older version of the same DLL (or OCX) over a new one, however, there is 
no guarantee that we will work with the new one either. 

Microsoft has released so many different versions of DLL’s that it is sometimes impossible to get a set that is 
compatible with all of the programs you have loaded on your system.    You may, for instance, get one program 
running well at the expense of causing some others (possibly WRAD) to fail.    At present, there is no known 
solution to this problem and Microsoft, more than anybody, knows all about it.

For example, It is nearly always possible to install new software (like WRAD) on a system upon which Windows 
was just loaded.    Sadly, however, as you add more and more programs, things will eventually start going 
downhill. As Windows systems go, they tend to deteriorate with age and nearly every system gets corrupted if it’s
used long enough.    Eventually, you will always have to reinstall Windows, and most people usually wait until 
they buy another computer before doing this, thereby “solving” the problem.

The folks here at the WRAD cannot ever hope to solve this problem.    If you simply cannot get WRAD to run on 
your system then please, by all means, exercise your right to return the product and utilize our money-back 
staisfaction guarantee.    We don’t want you to own it if it doesn’t work on your system.

All of that being said however, we realize that we’re not perfect and that there are probably some problems with 
the software that we didn’t uncover during testing and need to fix.    We welcome your bug reports, suggestions 
and other operating observations that help us make a better product.    Please feel free to send email anytime to 
our developer,    aa7bq@qrz.com      Try and be as descriptive as possible about the nature of your problem, the 
configuration of your system, etc..

From time to time, we will post fixes and updates to the WRAD software on our Internet server (free for 
downloading) at ftp://ftp.qrz.com 

Q. When will the WRAD software be available for the Macintosh?

. Most likely, never.    The cost of developing a Mac version of this software could not possibly be offset by any 
forseeable sales due to the limited number of amateur radio Mac users.      Mac users can still enjoy the benefits 
of our online version of the WRAD at http://www.qrz.com 

Q. When will the WRAD software be available for the DOS and Windows 3.1?

. Most definately never.    If you’re reading this help file then you’ve already solved the problem. 



Setup and Installation Notes

Here are the data files used by the WRAD and where they should reside on your system:

The WRAD browser software uses the following data files (for example if D: is your CDROM):

Filename Default Location Purpose
wraddata.qrz D:\ The main WRAD database
wradkeys.qrz D:\ The main WRAD index
wradbios.mdb D:\ The WRAD Biographies
netaddr.qrz D:\ WRAD email support file*
\Pictures D:\Pictures\ WRAD Biography Photos

wradnew.mdb <install dir> Added/edited callsigns
wradnote.mdb <install dir> Your personal notes

*This file is encrypted.    No technical details are available.

<install dir> is the directory where WRAD was installed during the Setup procedure.

How to setup the WRAD to run entirely off of your hard drive:
If you didn’t elect to copy the files to your hard disk when you installed the WRAD browser, you can do so at any 
time by running the HARDCOPY.EXE program on the CDROM.    We highly recommend that you accept the 
directory that it chooses for you, however, it will still work if you choose your own disk and directory.    At a 
minimum, we recommend that you write down the location of the WRAD data files in case you need to find them 
again later.    Also note that if you should uninstall the WRAD browser that the uninstall program will not remove 
the datafiles – you must do this yourself.

If you really need to save space, the only two files which are required are wraddata.qrz and wradkeys.qrz.  
The software will work with reduced functionality without the other files.

Next, remove the CDROM disc from the drive and run the WRAD program.    The program, after not finding the 
CDROM disc, will put up a prompt asking you to specifiy the new data file location.    After the first time, the 
system will remember the new file location.    Later, if you decide to use the CDROM again, simply re-insert it into
the drive where it will be recognized (and take precedence) over the hard disk files.

How the WRAD browser searches for its data files (technical info):
When the WRAD browser is started, it looks at to see if the startup command (Target) contains anything after the
..\wrad.exe.    If a string is specified, it is assumed to be the full path name pointing to where the WRAD data 
files are located.    In most cases, this argument should be set to the drive letter of the CDROM drive (such as 
D:).    The given path should not have a trailing backslash character at the end.    

You can set this value to some other path by going into the C:\Windows\StartMenu\Programs    folder and 
adjusting the Shortcut Properties for the WRAD CDROM icon.    You should only alter the Target property.    If you 
really need to alter the Start In property, remember that you must relocate (move) any wradnew.mdb or 
wradnote.mdb files from their existing location to the new Start In location that you specify or risk losing your 
notes and/or your edited callsigns.

If no *.qrz data files are found at the location specified on the command line, the WRAD browser will then 
attempt to use the last known successful data file location (other than the one mentioned on the command line).   
Next, it will try the directory where the WRAD browser was originally installed.    Finally, if the data files are still 
not found, the browser will try the current working directory (i.e. the Start In directory).    Finally, if all of these 
attempts to locate the data files fail, a file open dialog box will pop up and prompt you to browse to the correct 
location of the data files.

If any of the strategies above are successful, the path name will be stored and reused the next time the WRAD 
software is run (command line overrides not withstanding).

To summarize, the data file path search order is:

 The path specified on the command line (the Target in Shortcut Properties)
 The last known good location



 The the original install directory
 The current Start In directory
 A path specified in the Not Found dialog box

If you select Cancel from the Not Found dialog box, the program will exit.    After all, it did try its best.

Which data source is currently in use?
If you are wondering where the WRAD browser found its data files when it started, look in the Help->About menu.  
The About box shows the current Data Path as well as the current command line parameters.

How WRAD uses the Registry
The WRAD browser software stores all of its current operating parameters, fonts, colors, most recently used 
files, data paths, etc., in the Windows Registry.    Unless you are familiar with the Registry then you should 
probably avoid touching it.    If on the other hand, you’re a die hard regedit user, then you can find all of the 
WRAD’s parameters under:

HKEY_CURRENT_USER\Software\VB and VBA Program Settings\WRAD

If you uninstall the WRAD browser, it does the good citizen thing and removes all traces of itself from the 
Registry.    Uninstall does not remove important stuff like your wradnew.mdb and wradnote.mdb files.



Error Messages

Below are some error messages which might show up while running the WRAD browser:

QRZ Text Library: Too many hits. Please narrow your search.
The search key that you gave returned more than 200,000 records.    You must choose a key or combination of 
keys that return fewer records.    Searching for the keyword ‘USA’ will return this error since there are over 
700,000 such callsigns.

WRAD: wradnote.mdb – Your personal notes file was not found, …
This means that the file used to store your WRAD Notes, wradnote.mdb was not found during initialization. If 
you answer NO to the question, WRAD will exit so that you can locate and possibly restore the file.    This file 
should be located in the directory where the WRAD software was installed, which is where the wrad.exe file is 
located (you can use Start->Find to locate wrad.exe).    Typically, it would be located in:

C:\Program Files\QRZ Ham Radio\World Radio Amateur Directory\wradnote.mdb

If your notes are important to you, you should make it a point to back up this file on a regular basis. A simple 
backup strategy would be to occasionally copy it to a floppy disk.    If it’s too large for a floppy, you can always 
use a ZIP drive or perhaps just a separate copy on a second hard disk. Depending on how often you change 
your notes, you may want to back up this file as often as once a day.

WRAD: wradnew.mdb – Your personal callsign file was not found, …
This means that the file used to store the callsigns that you edit and/or add to the database wradnew.mdb were 
not found during initialization. If you answer NO to the question, WRAD will exit so that you can locate and 
possibly restore the file. This file should be located in the directory where the WRAD software was installed, 
which is where the wrad.exe file is located (you can use Start->Find to locate wrad.exe).    Typically, it would 
be located in::

C:\Program Files\QRZ Ham Radio\World Radio Amateur Directory\wradnew.mdb

If the callsigns that you add to the database are important to you, should make it a point to back up this file on a 
regular basis. A simple backup strategy would be to occasionally copy it to a floppy disk.    If it’s too large for a 
floppy, you can always use a ZIP drive or perhaps just a separate copy on a second hard disk. Depending on 
how often you add or edit callsigns, you may want to back up this file as often as once a day.

Database Error: Email file not found
This means that the email address support file, netaddr.qrz, was not found in during initialization. This is 
probably because an unsuccessful attempt was made to copy the database files from the WRAD CDROM to the 
hard drive.    The program will work without this file (but without email addresses) and so it is considered non-
critical.    To suppress this message, create a dummy file (size and contents don’t matter) called netaddr.qrz 
in the same directory where the other *.qrz files are located.

Database Error: Index file not found
This message is generated when the wradkeys.qrz file is not found.    It probably means that you tried to copy 
the database files from the CDROM to your hard disk, but not all of the files were copied correctly.    For the 
database to work, both the wraddata.qrz and the wradkeys.qrz files are required.    If you want to have 
email addresses as well, then the netaddr.qrz file is also needed. To remedy, simply copy all of the *.qrz 
files from the CDROM to the desired hard disk directory.      To reverse the procedure (i.e. quit using the hard disk 
drive for WRAD data), simply delete all of the *.qrz files.    If needed, the program will ask you where to find the 
data once it has been removed from the hard disk.

Database Error: Data file not found
Although rare, you might see this message.    It means that the wraddata.qrz file was not found.    Since the 
WRAD browser software checks for this file before attempting to start the database, the appearance of this 
message probably means that something else is wrong.    If the file is on hard disk (instead of CDROM), it might 
be corrupted, or there may be a network problem if you are using shared services.    When in doubt, insert the 
WRAD CDROM and see if the program starts working correctly.

Invalid [Start In] directory…
The WRAD browser must be run in a directory where it can read, write and create new files.    An automatic 



check of the current working directory indicated that it was read-only (possibly write-protected).    You must 
configure a writable Start In directory in the WRAD icon’s shortcut properties, or, be in the WRAD install 
directory if you start the program from the command line.

Tag Refresh Error: Can’t find xx0xxx in local database
This happens when you are trying to restore a list (File ->Load) and an item exists in the list that can no longer 
be found in your private database.    You shoud either re-enter the listing for the indicated callsign, or, delete the 
entry from the list and re-save it.



How to Contact the WRAD Editor

The World Radio Amateur Directory CDROM is produced by QRZ, makers of the QRZ Ham Radio CDROM. The 
editor and author, Fred Lloyd, AA7BQ, may be contacted by email at: editor@qrz.com    All email inquiries will be 
answered, however, the same cannot be guaranteed for written (postal) mail, for which we cannot always answer.

WRAD/QRZ can be found on the Internet with the following services:

World Wide Web
http://www.qrz.com is the home of QRZ and the WRAD

Email
QRZ maintains the following email addresses for user correspondence. Except for the author’s, each of the 
addresses below are automated response servers:

Author aa7bq@qrz.com    Fred Lloyd, AA7BQ
Email Registration updates@qrz.com Automated e-mail registration

Email database lookups lookup@qrz.com Auto. database lookup system
Product Info info@qrz.com Automated Press Releases

By Postal Mail

The World Radio Amateur Directory
8711 E. Pinnacle Peak Road #159
Scottsdale, AZ    85255      USA




