XADM: High CPU in Store.exe with Incorrectly Formatted Attachment |
The information in this article applies to:
-
Microsoft Exchange Server, versions 5.0, 5.5
SYMPTOMS
When you monitor the activity of Store.exe using various tools, including
Performance Monitor, Store.exe runs near or at 100 percent CPU usage.
CAUSE
The messaging client is improperly formatting a message containing a MIME
attachment. This can occur for messages containing attachments that contain
a left parenthesis "(" within the file name but without the right or
closing parenthesis ")". This is interpreted as a comment rather then the
file name, and the store continuously searches for the closing parenthesis.
For example:
--PART.BOUNDARY.mailhub.4aba.34918213.0001
Content-Type: application/octet-stream
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename=(JPEG-IM.BMP <-HERE *****
Content-Description: (JPEG-IM.BMP
FTBP-Modification-Date: 12 Dec 2017 10:02:00 Z
FTBP-Object-Size: 167710
It is possible to check the files in the IMCDATA\IN or IMCDATA\OUT
subdirectories for the presence of messages that contain attachments with a
( in the file name. These files are text files. There is no need to check
the archive directories underneath IN or OUT.
RESOLUTION
Exchange Server 5.0
A supported fix that corrects this problem is now available from Microsoft, but
it has not been fully regression tested and should be applied only to systems
experiencing this specific problem. If you are not severely affected by this
specific problem, Microsoft recommends that you wait for the next Microsoft Exchange Server version 5.0 service pack
that contains this fix.
To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information on support costs, please go to the following
address on the World Wide Web:
http://www.microsoft.com/support/supportnet/overview/overview.asp
The English version of this fix should have the following file attributes or later:
Component: Information Store
File name |
Version |
Mdbmsg.dll |
5.0.1461.92 |
Store.exe |
5.0.1461.92 |
Exchange Server 5.5
To resolve this problem, obtain the latest service pack for Microsoft Exchange Server version 5.5. For additional information, please see the following article in the
Microsoft Knowledge Base:
Q191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes or later:
Component: Information Store
File name |
Version |
Store.exe |
5.5.2144.0 |
STATUS
Microsoft has confirmed this to be a problem in Microsoft Exchange Server versions 5.0 and 5.5. This problem was first corrected in Microsoft Exchange Server version 5.5 Service Pack 1.
Additional query words:
spin hog
Keywords :
Version : winnt:5.0,5.5
Platform : winnt
Issue type : kbbug