XADM: Euro Displayed Incorrectly After MIME Conversion |
The information in this article applies to:
-
Microsoft Exchange Server, versions 5.0, 5.5
SYMPTOMS
When you send a message with the euro currency symbol (a "C" with two
horizontal lines through the center) on the To, Cc, or Subject line, the
symbol may be displayed as a question mark (?) when you open the message in
an e-mail client, or when you view the message in the preview pane. This
problem also occurs when you view the Subject line in the Inbox, on the
taskbar, or on the title bar of the message window. However, euro currency
symbols in the body of the message are displayed properly.
Note that this problem only occurs when the following conditions are met:
- The message's character set is Western European (ISO-8859-1).
- The message is sent using Post Office Protocol version 3 (POP3) and
received using Internet Mail Access Protocol (IMAP) or POP3.
In addition, note that this problem is not dependent on the e-mail client
or operating system you are using. The problem can occur even if your e-mail
client, the operating system on which the e-mail client is running,
and the Microsoft Exchange Server computer all support the euro currency
symbol.
CAUSE
This problem occurs because the Western European character set does not
support the euro currency symbol. Therefore, the euro currency symbol is
not converted properly when the information store converts the message
from Multipurpose Internet Mail Extensions (MIME) format so that it can
be viewed in a Messaging Application Programming Interface (MAPI) or
POP3 e-mail client.
RESOLUTION
Exchange Server 5.0
A supported fix that corrects this problem is now available from Microsoft, but
it has not been fully regression tested and should be applied only to systems
experiencing this specific problem. If you are not severely affected by this
specific problem, Microsoft recommends that you wait for the next Microsoft Exchange Server version 5.0 service pack
that contains this fix.
To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information on support costs, please go to the following
address on the World Wide Web:
http://www.microsoft.com/support/supportnet/overview/overview.asp
The English version of this fix should have the following file attributes or later:
Component: Information Store
File name |
Version |
Mdbmsg.dll |
5.0.1461.85 |
Store.exe |
5.0.1461.85 |
After you apply the fix, if you are sending a message from a POP3 e-mail
client to a MAPI e-mail client, you must select the Allow 8-Bit
Characters In Headers check box in the POP3 e-mail client. If you
are sending a message from a POP3 e-mail client to another POP3 e-mail
client, you do not need to select this check box, but the euro currency
symbol is still displayed correctly if you do.
Exchange Server 5.5
First Fix
To resolve this problem, obtain the latest service pack for Exchange Server
version 5.5. For more information, please see the following article in the
Microsoft Knowledge Base:
Q191014 XGEN: How to
Obtain the Latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes or later:
Component: Information Store
File name |
Version |
Gapi32.dll |
5.5.2397.0 |
Mdbmsg.dll |
5.5.2397.0 |
Store.exe |
5.5.2397.0 |
After you apply the first fix, if you are sending a message from a POP3
e-mail client to a MAPI e-mail client, you must select the Allow 8-Bit
Characters In Headers check box in the POP3 e-mail client. However,
if you are sending a message from a POP3 e-mail client to another POP3
e-mail client and this check box is selected, the euro currency symbol
is not displayed correctly.
Second Fix
A supported fix that corrects this problem is now available from Microsoft, but
it has not been fully regression tested and should be applied only to systems
experiencing this specific problem. If you are not severely affected by this
specific problem, Microsoft recommends that you wait for the next Microsoft Exchange Server version 5.5 service pack
that contains this fix.
To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information on support costs, please go to the following
address on the World Wide Web:
http://www.microsoft.com/support/supportnet/overview/overview.asp
The English version of this fix should have the following file attributes or later:
Component: Information Store
File name |
Version |
Gapi32.dll |
5.5.2539.0 |
Mdbmsg.dll |
5.5.2539.0 |
Store.exe |
5.5.2539.0 |
After you apply the second fix, if you are sending a message from a
POP3 e-mail client to another POP3 e-mail client, the euro currency
symbol is still displayed correctly if the Allow 8-Bit Characters
In Headers check box is selected.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Exchange Server versions 5.0 and
5.5. This problem was first corrected in Exchange Server 5.5 Service
Pack 2.
MORE INFORMATION
After you apply the fixes, messages that are labeled with the ISO-8859-1
character set are labeled with the Windows-1252 character set instead. This
allows the euro currency symbol to be converted properly by the information
store. However, if your e-mail client, the operating system on which the
e-mail client is running, or the Microsoft Exchange Server computer do not
support the euro currency symbol, the symbol may still be displayed
incorrectly when you view the To, Cc, or Subject line in an e-mail client.
For information about the availability of the euro currency symbol in
Microsoft Windows NT character sets, please see the following article in
the Microsoft Knowledge Base:
Q182005 Euro Currency Not Available in Windows NT Character Sets
Additional query words:
imail
Keywords : exc55sp2fix
Version : winnt:5.0,5.5
Platform : winnt
Issue type : kbbug