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    What is Garant
Garant is a powerful system for working with hypertext databases in multi 

document interface (MDI) developed by Garant-Service. The system provides the 
following functions:

- Immediate access to a pointed document from another;
- Diverse types of search of the documents, including global and local context 

search, requisite search, keyword search, chronological search, thematic 
search;

- Comfortable means of work with a document (copy to file, print out, etc.);
- Look over the commentaries to a document;
- Individual adjustment of the system options (choose the screen fonts, type of 

printer, fonts for printer; save parameters after the end of session);
- Support of Clipboard.

Information bank of Garant contains the following databases:
Economic Legislation (in Russian and in English),
Bank Dealings (in Russian),
Customs Control (in Russian),
Land, Natural Resources and Environmental Protection (in Russian),
Form of Legal Documents (in Russian),
Moscow Municipal Legislation (in Russian),
Sr. Petersburg Municipal Legislation (in Russian).

Telephone Numbers of Moscow office :
939-18-88, 939-16-05,
939-08-04, 939-08-50.

Fax Numbers: 938-28-73, 939-00-71.

Post Address: Garant-Service, Moscow State
University,Leninskie Gory, Moscow,
119899 Russia



Clipboard

A temporary storage area for cut or copied text or graphics. You can paste the contents 
of the Clipboard into practically any application. The Clipboard holds the information 
until you cut or copy another piece of text or graphic.



Shortcuts

Shortcuts are used to make work with menu easier. There is an underlined letter in the 
name of each of menu items. Press of Alt key in combination with the above-mentioned 
letter makes the same effect as choosing the correspondent item of menu with the help 
of mouse or arrow keys.



Global Context Search

The result of Global Context Search is a list of documents which contain the specified 
words or word combination (context).
The word or word combination is specified in the fields of Context of Complex Search.

See also :
How to Start Search



Menu Search

Menu Search helps to find documents associated with one law aspect. The search is 
arranged by looking through the correspondent section of the Main Menu. To start Main 
Menu, choose item Main Menu in Search Menu



Requisite Search

The requisites of a document are: 
- Type of a document (Decree, Decision , Letter, etc.);
- Official body issuing the documents (Government of Russia, Central Bank of 

Russia, etc.);
- Number of a document;
- Issuing date of a document;
- Status (valid or abolished);
- Subjects

Requisites are specified in the correspondent fields of Complex Search    Dialog. 
You can use arbitrary combination of requisites; it is not necessary to fill in all fields.

See also :
How to Start Search



Complex Search

Complex Search combines the context search and requisite search, i.e. allows to find the
documents which contain the specified words and certain requisites. It is possible 
because the context and requisites are specified in one box called Complex Search. It is 
not necessary to fill in all fields; it is enough to specify only known information.

See also :
How to Start Search



Local Context Search

Local Context Search allows to find the desired word or word combination (context) in 
the current document. This context should be specified in Local Context Search.

See also :
How to Start Search



Keyword Search

Keyword Search allows to find documents direct or indirect associated with some notion 
or term. It is not necessary that the found documents contain the specified keyword but 
they direct associated with the subject. This is the main difference from the Global 
Context Search. The keyword is specified in Keyword Search. To make this search easier,
all keywords are divided into two levels basic and explanatory. Basic keywords are 
assigned to the basic notions and explanatory explain them.

See also :
How to Start Search



Chronological Search

Chronological Search is helpful when you have to find documents ussued within the 
certain period. To start chronological Search choose Chronological Menu in Search Menu.
Then choose the desired period (Year and Month).



Shortcuts DOS WINDOWS
Version Version

F1 Help Help
F2 Main Menu Main Menu
Alt+F2 Chronological Menu Chronological Menu
Ctrl+F2                           - All Bases List
F3 Reference on document Keyword Search
Alt+F3                           - Return to the last 

keyword
Ctrl+F3                           - Result of

Keyword Search
F4 Keyword Search                               -
Alt+F4 End of Session End of Session
Shift+F4 Return to the last Arrange windows in

keyword tile
F5 Split a window Complex Search
Ctrl+F5                           - Result of Complex

Search
Shift+F5 Arrange windows in Arrange windows in

cascade cascade
F7 Complex Search                               -
Alt+F7 Result of Complex                               -

Search
Shift-F7 Local context search
F8 Print a document                               -
Alt+F8 Copy a document into file                               -
Shift+F8 Spool a document                               -
F9 All bases list                               -
Shift+F9 Save Configuration                               -
F10 End of session Enter Menu
Alt+F10 Information about authors                               -

of Garant
Ñtrl+Ins                             - Copy selected fragment

to the Clipboard
Ctrl+C                           - Copy selected fragment

to the Clipboard
Ctrl+F                           - Local Context Search
Ctrl+P                           - Print the document
Ctrl+O                           - Open database
Escape Return to previous Return to previous



document document
Alt+BkSp                         - Return to previous

document

See also:
How to Choose Shortcuts



      New Functions
Below is described new functions of Garant for Windows





    File Menu Commands
Open...

Shortcuts:
Keys: Ctrl+O /WINDOWS/

Toolbar: 
Use this command to open one of the databases installed on your computer.
Close
Use this command to close current window containing the active database or document.
Close All
Use this command to close all windows containing the active database or document. 
Save As...

Shortcuts:
Keys: Alt+F8 /DOS/

Ctrl+S /WINDOWS/
Toolbar: 

Use this command to save current document into file.
Print

Shortcuts:
Keys: F8 /DOS/

Ctrl+P /WINDOWS/
Toolbar: 

Use this command to print out document or selected fragment of document.
Printer Setup...
Use this command to adjust printer options.
Exit

Shortcuts:
Keys: F10,Alt+F4 /DOS/

Alt+F4 /WINDOWS/
Use this command to quit GARANT.



    Edit Menu Commands
Select

Shortcuts:
Toolbar: 

Use this command to select a part of document.
Select All
Use this command to select an entire document.
Unselect
Use this command to unselect a selected part or entire document.
Copy

Shortcuts:
Keys: Ctrl+Ñ /WINDOWS/

Use this command to copy selected text into Clipboard. This command is unavailbale if 
you have noselected text. Copying text to the Clipboard replaces the previous context.



    Search Menu Commands
All Bases List...

Shortcuts:
Keys: F9 /DOS/

Ctrl+F2 /WINDOWS/
Tololbar: 

Use this command to open list of all database installed on computer.
Main Menu

Shortcuts:
Keys: F2 /DOS/

F2 /WINDOWS/
Toolbar: 

Use this command to search for document through main menu of database.
Chronological 

Shortcuts:
Keys Alt+F2 /DOS/

Alt+F2 /WINDOWS/
Toolbar: 

Use this command to search for document through chronological menu of database.
Previous Document

Shortcuts:
Keys: Esc,Ctrl+Z /DOS/

Esc,Ctrl+Z /WINDOWS/
Toolbar: 

Use this command to return to the previous document or list of documents.
Key Search...

Shortcuts:
Keys F4 /DOS/

F3 /WINDOWS/
Toolbar: 

Use this command to start search for document by keyword.
Last Key ...

Shortcuts:
Keys: Shift+F4 /DOS/

Alt+F3 /WINDWOS/
Toolbar: 

Use this command to return to the last choosen keyword.
Last Key List ...

Shortcuts:
Keys: Ctrl+F3 /WINDOWS/

Toolbar: 
Use this command to get the list of documents with last choosen keyword.
Search...

Shortcuts:
Keys: F7 /DOS/

F5 /WINDOWS/



Toolbar: 
Use this command to start context search and search on requisite. 
Search Result...

Shortcuts:
Keys: Alt+F7 /DOS/

Ctrl+F5 /WINDOWS/
Toolbar: 

Use this command to get the list of document after the last complex search.
Find...

Shortcuts:
Keys: Shift+F7 /DOS/

Ctrl+F /WINDOWS/
Toolbar: 

Use this command to start search for a word or expression within one document.



    Options Menu Commands
Display Font...
Use this command to control font, point size and character formats.
Printer Font...
Use this command to contro font and point size for printer.
Save Settings on Exit
Use this command to setup mode of saving settings after exit GARANT.
Save

Shortcuts:
Keys: Shift+F9 /DOS/

Use this command to save GARANT settings.
Language
Use this command to choose language for message (Russian or English).
Interfase
Use this command to choose DOS or WINDOWS shortcut keys.



    Windows Menu Commands
New

Shortcuts:
Keys: F5 /DOS/

Toolbar: 
Use this command to open a new window.
Cascade

Shortcuts:
Keys: Shift+F4 /WINDOWS/

Use this command to arrange open windows so that the title bar of each window is 
visible.
Tile

Shortcuts:
Keys: Shift+F5 /DOS/

Shift+F5 /WINDOWS/
Use this command to arrange open windows side by side so that all of them are visible.
Arrange Icons
Use this command to arrange into rows all program-item icons for a selected group or, if 
a group icon is selected, arranges all group icons into rows.



    Help Menu Commands
Contents

Shortcuts:
Keys: F1 /DOS/

F1 /WINDOWS/
Toolbar: 

Use this command to get help on GARANT.
Using Keys
Use this command to get help on keys purposes.
Document

Shortcuts:
Keys: F3 /DOS/

Toolbar: 
Use this command to get reference on current document. References are made by law 
department of GARANT-SERVICE.
About...

Shortcuts:
Keys: Alt+F10 /DOS/

Use this command to get reference on program.



Shortcut Keys
There are two sets of shortcut keys. The first set is the same as in GARANT for DOS, the 
second set is extention of standard Windows environment.

See Also:
How to Choose Shortcut Keys





    How to Work with the System
There are three ways execute any function of GARANT:
1. Choose command from menu. All functions are available from menu. Choose 

menu command by mouse or by key combination Alt + underlined letter.
2. Choose button from (Toolbar). To access function via toolbar place mouse 

cursor on the toolbar and click left mouse button. To get help on toolbar place mouse 
curson on the toolbar and holp pressing right mouse button. 

3. Choose "hot" keys .



    How to Open Database
To open database do one of the follwoing:

I.
From File menu choose Open.
In dialog box type the drive and directory with database.
Choose database from the list of databases.
Press Ok button.

II. 
From Search menu choose All Bases List.
Press Scan    button.
Choose database from the list of databases.
Press Ok button.

See Also:
Open Database Dialog
Select Database Dialog



    Find a Document
There are several search functions in GARANT. They are:
1. Context Search - search for document(s) by words and/or expressions.
2. Requisite Search - search for document(s) by type, number, date and etc.
3. Complex Search - combines context and requisite search.
4. Context Search Within One Document - search for word or expression within 

one document.
5. Keyword Search - search for document by keyword.
6. Chronological Search - search for document by date.
7. Menu Search - search for document in main menu of database.

See Also:
Start Search



    How to Start Search
There are complex search, keyword search, chronological search, menu search 

and search for context within one document in GARANT.

To start complex search
1. From Search menu choose Search.
2. Specify requisite of document your search for.
3. Press Ok button.

To start keyword search
1. From Search menu choose Key Search.
2. Choose keyword and additional keyword exprission.
3. Press Ok button.

To start search for context within one document
1. From Search menu choose Find
2. in diolog box Find type context.
3. Press Ok button.

To start chronological search
1. From Search menu choose Choronological

To start menu seach
1. From Search menu choose Base Contents

To get help press Help button.

See Also:
How to Find A Document



    How to Adjust Options
In GARANT you can adjust the following options:

- font for display text on screen;
- font for printer;
- type of printer;
- language of message and menu (Russian or English);
- hot keys (for Windows and for DOS).

See Also:
How to Change Font
How to Adjust Printing Options
How to Choose Language for Message and Menu
Hot to Choose Hot Keys



    How to Change Font
Changing font you can effect its readability and particular look. 

To change font
1. From Options menu choose Display Font.
2. In dialog box choose font, style and size.
3. Press Ok button.

To get help press Help button.

See Also:
How to Change Font



    How to Adjust Printing Options
To change type of printer
1. From File menu change Printer Setup.
2. In dialog box choose type of printer.
3. After choosing other printer options press Setup button.
3. Press Ok button.

To change font for printing
1. From Options menu choose Printer Font.
2. In dialog box choose type of font, style and size.
3. Press Ok button.

To get help press Help button.

See Also:
Change Font
Printer Setup



    How to Choose Language for Message and Menu
To change language for message and menu:
1. From Options menu choose Language.
2. Choose option.

If you choose Russian language be sure that there is driver of Russian font on computer.



    How to Change Hot Keys
To change Hot Keys
1. From Options menu choose Hot Keys.
2. Choose option.

See Also:
Hot Keys





    How to Print Current Document
To print the entire document from the File menu choose Print

To print block before start printing select a block.

See Also:
Select Fragment
File Menu Commands



    How to Select Fragment
To select block of text do one of the following:

1. Form Edit menu choose Select.
2. Hold down the left mouse button while moving mouse across the text you want to 
select.

To sekect the entire document form the Edit menu choose Select All.

See Also:
Print Current Document
Save Current Document Into File
Copy Current Document to Clipboard
Edit Menu Commands



      How to Save Current Document Into File
To save block of text or the entire document into file do the follwoing:

1. From the File menu choose Save As.
2. Type the filename or edit default name.
3. Choose the OK button.

See Also:
Select Fragment
File Menu Commands



    How to Copy Curent Documents to Clipboard
To copy fragment of document or entire document to CLIPBOARD, do the 

following:
1. Select fragment of document or entire document.
2. Form the Edit menu choose Copy.

See Also:
Select Fragment
Edit Menu Commands



    How to Get Reference on Current Document
Most of the documents from GARANT database have references made by law 

department of the Garant-Service. To get reference from Help menu choose Document.

Some documents from GARANT database have commentaries marked out by 
green color. Commentaries are made by law department of GARANT-SERVICE.

See Also:
Help Menu Commands





    Open Databases
Open database to start work with texts of documents from GARANT.

Databases
Select the database from directory you want to open.

Directories
Select the directory in which Garant stores the database file that you want to open.

Drives
Select the drive in which Garant stores the database file that you want to open.

See Also:
How to Open Database



    Save Document into File
To save current document into file choose the Save As Command.

Files
Type a new filename to save a document with a different name.

Directory
Select the directory in which you want to store your document.

Drives
Select the drive in which you want to store you document.

See Also:
How to Save Current Document Into File



    Printer Setup
To choose printer before start printing use Printer Setup Command.

Printer
Specify type of printer.

Setup
Specify printer options

See Also:
Options Adjustment



    Choose Database
Choose one of the GARANT databases installed on computer. 

Databases
Select the database from directory you want to open.

Scan
Search for the all GARANT databases installed on computer.

See Also:
How to Open Database



    Key Search
Search for document by keyword.

See Also:
How to Find Document



    Choose Document
Choose document from the list of found documents.

Delete
Delete current document from the list of found documents.



    Complex Search
Search for document by specified requisites.

Type
Type of document (Letter, Decree, Resolution and etc.)

Off. Body 
Name of official body issued document.

Date from ... to ...
Period of issuing document.

Number
Registed number of document.

Division
Thematic scope (taxation, lease, externalt economic activity, property etc.)

Status
Status of document: All, Active, Abolished.

Context
Context for search for document on context.

See Also:
How to Find a Document
How to Start Search



    Context Search Within One Document
Search for word or expression within one document.

Find
Type the word or expression for search.



    Change Font
Change the font of characters. Character formatting performes in all windows 
simulteniously.

Family
Select font from the list. 

Style
Add emphasis to characters by applying formats such as bold, italic and underline.

Size
Choose the appropriate size for text.

In example dialog box you can see the exapmle of settings.

See Also:
How to Format Characters





    Toolbar
You can navigate through GARANT either via menu or via Toolbar:

Toolbar gives quick mouse access to many tools used in GARANT. To access 
function via toolbar place mouse cursor on the toolbar and click left mouse button.

To get help on toolbar place mouse curson on the toolbar and holp pressing right 
mouse button.

Click To
get help on GARANT
open GARANT database
save document as text file
select a part of document
open new window with the same document
get list of all installed GARANT databases
search for document in main menu of database
search for document in chronological menu of database
return to the previous document or list of documents
search for document on keyword
get the last keyword
get list of documents after keyword search
start complex search (context and/or requisite)
get list of documents after complex search
search for context within document
get reference on document
print out current document




