KbMedia Player for Windows

このヘルプは、KbMedia Player Version 2.32β2(2003/09/02 公開) を対象としており、 それよりも新しいバージョンのものとは内容に食い違いが起こる可能性があります。また、このヘルプは KbMedia Player の製作者 Kobarin 氏ではなく、 Q.E.D. によって記述されています。そのため、同梱のその他のドキュメントや、実際の動作と異なる記述が含まれている可能性があります。 そのような場合、同梱のドキュメントの記述を優先するようにして下さい。

はじめに

KbMedia Player をダウンロードしていただき、ありがとうございます。
KbMedia Player は、Windows95/98/ME および WindowsNT4.0/2000/XP で
動作するマルチメディアプレイヤーです。エクスプローラライクな外観をもち、
多種多様な形式のファイルに対応しています。また圧縮ファイルも扱うことができ、
通常のファイルとほとんど区別することなく扱うことが可能です。

  • 対応フォーマット
  • インストール方法
  • アンインストール方法
  • 本ソフトとは別に導入が必要なものについて
  • 著作権・謝辞・転載について
  • 更新履歴
  • 最新バージョンの入手先

このヘルプは、スクロールバーが表示されない範囲で下の線が横一杯に表示される
環境で丁度よく読むことが出来るようになっています。
下の線を参考にしてウインドウサイズを調節していただけると作者は喜びます。(^-^;

またリンク以外の場所をダブルクリックしていただければ、ひとつ前の場所に戻ることが
出来ます。左上にある「戻る」をクリックするより楽でしょうから、ぜひご活用ください。

KbMedia Player が対応しているフォーマットの一覧です。
そのフォーマットを扱う上での簡単な注意点も記載してあります。
KbMedia Player をインストールする際に注意すべきことと、
展開されたファイルについての説明です。
KbMedia Player のアンインストール方法です。
設定の保存にレジストリを使用しているため、
ファイルを削除しただけでは完全に削除されません。
ご注意ください。
KbMedia Player 本体とは別に導入が必要なもの、
もしくは導入すると便利なものです。
著作権や謝辞、さらに KbMedia Player を転載・配布する上での
注意点が記してあります。
KbMedia Player の更新履歴です。
ヘルプが追いつかない場合、各自でご確認ください。(^^;
最新バージョンの入手先や、連絡先です。


対応フォーマット

KbMedia Player で扱うことのできる形式は以下の通りです。
ただし、本体だけですべての形式が再生可能になるわけではありません。
同梱のファイル以外に必要なものがある形式もあります。詳しくはこちらをご覧下さい。

  • Standard MIDI File (MID/RMI)
  • Recomposer MIDI File (RCP/G36/R36)
  • MIDI Stream (MDS)
  • MPEG Audio (MP1/MP2/MP3/RMP)
  • MPEG plus (MP+/MPC)
  • Windows Media Audio/Video (ASF/WMA/WMV)
  • Real Media (Real Audio / Real Video) (RA/RM/RMJ)
  • Liquid Audio (LQT)
  • QuickTime Movie (QT/MOV)
  • 動画 (AVI/MPG/MPE/MPEG/M1V/MPA/MPV2/OGM)
  • Audio CD (CD-Extra, MixedMode CD にも対応)
  • Direct Music (SGT/SGP)
  • Ogg Vorbis (OGG)
  • Monkey's Audio (APE)
  • FLAC - Free Lossless Audio Codec (FLAC)
  • FPD (FM/FPD)
  • FMP (OPI/OVI/OZI)
  • PMD (M/M2/MZ/MP/MS)
  • MOD (MOD/S3M/XM/IT/MDL/669/AMF/AMS/DBM/DSM/
    FAR/J2B/MED/MT2/MTM/OKT/PSM/PTM/ULT/UMX)
  • TwinVQ (VQF)
  • アルトラマリン (UM)
  • Shockwave Flash (SWF)
  • Vivo Active (VIV)
  • Muse (MUS)
  • MIO - Music Interleaved and Orthogonal transformed format (MIO)
  • T'SoundSystem (TSS/TSD)
  • WavPack (WV)
  • ZMUSIC (ZMS/ZMD)
  • 着メロ関係の形式 (MLD/PMD)
  • au 携帯の着声ファイル (QCP)
  • PlayStation のムービー (CSTR/STR)
  • その他のサウンド (WAV/AIF/AIFF/AIFC/AU/SND)

上記のほか、プラグインを導入することによって
さらに多くの形式に対応させることが出来ます。

  • 木下 菫氏によるもの (Kobarin 氏、黒羽氏、zilpa 氏も関わっています)
    • スーパーファミコンのサウンド (SPC/SP[0-9])
  • Mamiya 氏によるもの
    • ファミコンのサウンド (NSF/NSZ/NEZ/NSD)
    • ゲームボーイのサウンド (GBR/GBS)
    • PC エンジンのサウンド (HES)
    • MSX, SEGA-Mk3, GameGear のサウンド (KSS)
    • PC8801/9801 のゲームサウンドなど (S98/CYM/MYM/X1F/VGM/VGZ)
    • メガドライブ以前の家庭向け SEGA ハードのサウンド (GYM/SSL)
    • X68000 の音源 (MDX/MDC)
    • コモドール 64 の音源 (SID/C64)
    • Atari XE/XL の音源 (SAP)
    • BMS (BMS/BME/EMS/PMS)
    • ZX Spectrum のサウンド (AY)
    • Amstrad CPC のサウンド (CPC)
  • [OK] 氏によるもの
    • MSX のサウンド (MGS/MPK/BGM/BGR/OPX)

KbMedia Player は圧縮ファイルをフォルダのように扱うことができ、
以下のものに対応しています。

  • LZH/LHA
  • ZIP/MDZ/S3Z/XMZ/ITZ/NEO
  • CAB
  • RAR
  • GCA
  • TAR
  • 7Z

アーカイブを扱うのに基本的に DLL を必要とすることはありません。
ただし、一部の ZIP アーカイブ については UNZIP32.DLL が必要となることがあります。
またアーカイブ内のファイルが正常に再生できるかどうかは、アーカイブのサイズによります。
詳しくはこちらをご覧下さい。

Stored/Deflate/Implode/Shrunk 以外の形式の
ZIP ファイルを扱いたい場合や、
形式に関わらずパスワードつきのファイルを
扱いたい場合に必要です。
再生には RCPCV.DLL が必要となります。
Windows Media Player Version 6.4 以降が必要です。
Version 7 以降の導入を推奨します。
Real Player が必要です。
Real Player 8 以降を強く推奨し、
それ以前のものは動作保証対象外になります。
QuickTime が必要となります。
動作確認が取れているバージョンは 6.0.2 です。
FPD98.DLL が必要となります。
動作確認が取れている FPD98.DLL の
更新日時は 2001/06/02 01:19:32 です。
必ず Kbmplay.exe と同じディレクトリに置いて下さい。
システムディレクトリに置いても認識しません。
WINFMP.DLL が必要となります。
KBFMP.KPI または Kbmplay.exe と同じディレクトリか、
システムフォルダのいずれかに置いて下さい。
PMDWIN.DLL が必要となります。
KBPMD.KPI または Kbmplay.exe と同じディレクトリか、
システムフォルダのいずれかに置いて下さい。
UMUT.DLL が必要となります。
動作確認が取れているバージョンは 1.0.0.5 です。
必ず Kbmplay.exe と同じディレクトリに置いて下さい。
システムディレクトリに置いても認識しません。
Macromedia Flash Player が必要となります。
動作確認が取れているバージョンは 6.0.47.0 です。
Vivo Active Player が必要となります。
動作確認が取れているバージョンは 2.1.0.0 です。
MUSE.EXE が必要となります。
Kbmplay.exe と同じディレクトリや、
システムフォルダに置いただけでは認識しません。
[ツール] -> [環境設定] を開いたのち検索パス 2 のタブを選択し、
MUSE.EXE の場所を設定してください。
DirectX 8.0 以降が必要となります。
DirectX はアンインストール及びバージョンダウンが出来ません。
システムに与える影響も大きいため、導入の際は慎重に行ってください。
MPK, BGM, BGR, OPX を演奏するには、ドライバファイルが別途必要です。
  • MPK を再生するためには MPK.BIN, MPK103.BIN が必要です。
  • BGM/BGR を再生するためには KINROU5.DRV が必要です。
  • OPX を再生するためには OPX4KSS.BIN が必要です。
ZMC2/ZMC3/ZtoM/Z2M3 が必要となります。
Kbmplay.exe と同じフォルダに置いて下さい。

このソフトを導入することによって拡張される機能は動作保証対象外です。
また、再生できるのは MIDI だけです。内蔵音源を使用するデータには対応していません。
MID_MLD.EXE が必要となります。
Kbmplay.exe と同じフォルダに置いて下さい。
PsxMC が必要となります。
シェアウェア版とフリーウェア版のどちらでも構いません。
PsxMC を適当なフォルダに展開後、起動すれば CSTR/STR が再生可能になります。


インストール方法

適当なディレクトリに解凍するだけで OK です。
また旧バージョンをアンインストールする必要もありません。
ただし解凍の際には、必ずディレクトリ構造を再現するソフトをお使いください。
作者の意図どおりの解凍が行われた場合、以下のような構成になります。

  • Plugins
    • plugin.txt
  • TimeTag
    • TimeTag.html
    • TimeTagDev.html
  • codecs.txt
  • default.bmp
  • History.txt
  • kb7z.dll
  • kb7z.txt
  • kbcstr.dll
  • kbmov.dll
  • Kbmplay.chm
  • Kbmplay.exe
  • kbrunkpi.exe
  • kbswf.dll
  • kbunarc.dll
  • kbviv.dll
  • nwdll.dll
  • pitchscaler.dll
  • readme.txt
  • todo.txt
  • 質問する前に必ずお読み下さい.txt
このディレクトリに KbMedia Player のプラグインを置くことになります。
各プラグインの詳細については、同梱のドキュメントを参照してください。
KbMedia Player のプラグインを導入する上で、
注意する必要があることについて書かれています。
タイムタグ付き歌詞ファイルの仕様書が
収められているディレクトリです。
タイムタグ付き歌詞ファイルの仕様書です。
タイムタグ付き歌詞ファイルを作成してみたい方はお読みください。
タイムタグ付き歌詞ファイルの開発者向けの仕様書です。
タイムタグ付き歌詞ファイルに対応したソフトを
製作してみたい方はお読みください。
KbMedia Player 本体です。
KbMedia Player のヘルプです。
現在開いているこのファイルのことです。(^^;
KbMedia Player について簡単に説明してあります。
導入する前に軽く目を通しておくことをお勧めします。
更新履歴です。
変更点を知りたい場合は、これを参照してください。
AVI ファイルの video codec の判別表です。
名前の通りです。(^^;
掲示板への質問や、メールを送る前に最低限お読みください。
クロスフェードの際に KbMedia Player が呼び出します。
単体で実行しても何も起こりません。
圧縮ファイルを扱うときに使用します。
動画や Real Media ファイルを再生する際に使用します。
Shockwave Flash (SWF) を再生する際に使用します。
VivoActive (VIV) を再生する際に使用します。
NeoWRD 開発チームによって作成された DLL を、
Kobarin 氏が改造したものです。
NeoWRD を再生する際に使用します。
音程を変えずに再生速度を変更する際に使用します。
KbMedia Player のデフォルトスキンです。
7Z 形式の圧縮ファイルを解凍するために使用します。
kb7z.dll についてのライセンス等が記述されています。
CSTR/STR を再生する際に使用します。
今後の予定です。


アンインストール方法

KbMedia Player は設定の保存にレジストリを使用しています。
展開したファイルを削除しただけでは完全に削除されません。
以下の手順に従ってください。

  1. KbMedia Player (Kbmplay.exe) を実行します。
  2. [ファイル] -> [アンインストール用終了] を選択します。
  3. 表示されるダイアログボックスの質問に対して「はい」を選択します。
  4. インストールしたファイルを削除します。

KbMedia Player を一度でも実行した場合、default.kbm というファイルが作成されます。
このファイルも一緒に削除して構いません。

二重に圧縮されていたり (書庫ファイルの中の書庫ファイルの中に再生するファイルがある)、 書庫ファイル内にある Sherry WRD (PNG ファイル) を再生する場合、 テンポラリフォルダの中に kbmplay.$$$ というディレクトリを作り、 その中にテンポラリファイルを作成します。このディレクトリは終了時に削除されますが、 KbMedia Player が強制終了した場合などには残ってしまう可能性があります。 心配であればテンポラリフォルダも覗いてみてください。

また Crescendo Forte LiveSynth を利用して MIDI を再生した場合、 テンポラリファイルが削除されないという不具合が確認されています。 そのような場合にもテンポラリフォルダを覗いてみてください。

上記の手順に従わずに Kbmplay.exe を削除してしまった場合は
HKEY_CURRENT_USER\Software\Kobarin's Soft
以下を削除してください。意味がわからない方は放っておいても構いません。

自信がある方以外はいじらない方が無難です。関係のない場所をいじってしまった場合、
最悪の場合 Windows が起動しなくなる こともありえます。

レジストリ操作に自信のない方は、もう一度配布ファイルを解凍し、
Kbmplay.exe からアンインストールを試みることをお勧めします。


本ソフトとは別に導入が必要なものについて

本ソフト以外に導入が必要となるものや、導入した方がよいと推奨されるものです。
こちらもあわせてお読みください。

  • UNZIP32.DLL (shoda T. 氏製作)
    Stored/Deflate/Implode/Shrunk 以外の形式の ZIP ファイルを扱いたい場合や、
    形式に関わらずパスワードつきのファイルを扱いたい場合に必要です。
    http://www.csdinc.co.jp/archiver/
  • RCPCV.DLL (ふみぃ氏製作)
    RCP/G36/R36 を MID へコンバートする DLL です。
    これを導入することで RCP/G36/R36 を再生できるようになります。
    動作確認が取れているバージョンは 1.12 です。
    http://hp.vector.co.jp/authors/VA010012/
  • Windows Media Player 6.4 or later
    Windows Media (ASF/WMA/WMV) を再生するために必要です。
    Windows95/98/NT4.0 に標準で搭載されている「メディアプレイヤー」とは
    別物ですので、ご注意下さい。Version 7 以降の導入を推奨します。
    動作確認が取れているバージョンは 8.00.00.4487 です。
    http://www.microsoft.com/japan/windows/windowsmedia/download/
  • Real Player 8 or later
    Real Media (RA/RM/RMJ) および Liquid Audio (LQT) を再生するために必要です。
    Basic 版で OK です。Plus 版を導入する必要はありません。
    Version 6.0.9.1762 以降で確認していますが、Real Player 8 以降を強く推奨します。
    Real Player 8 よりも古い場合は動作保証対象外となります。
    http://www.jp.real.com/
  • Quick Time
    QuickTime Movie (QT/MOV) を再生するために必要です。
    動作確認が取れているバージョンは 6.0.2 です。
    http://www.apple.co.jp/quicktime/
  • WINFMP.DLL / PMDWIN.DLL (C60 氏製作)
    それぞれ FMP/PMD を再生させるために必要です。
    それぞれのファイルは、当該ファイルを再生するためのプラグインと同一のディレクトリ、
    Kbmplay.exe と同一のディレクトリ、システムフォルダのいずれかに置いてください。
    http://www.fmp.jp/~c60/
  • Macromedia Flash Player
    Shockwave Flash (SWF) を再生するために必要です。
    動作確認が取れているバージョンは 6.0.47.0 です。
    http://sdc.shockwave.com/jp/software/downloads/
  • Vivo Active Player
    Vivo Active (VIV) を再生するために必要です。
    動作確認が取れているバージョンは 2.1.0.0 です。
    http://www.real.com/vivo/
  • MUSE.EXE (加藤一郎氏製作)
    Muse (MUS) を再生するために必要です。
    動作確認が取れているバージョンは 4.6 (更新日時 : 2002/09/04 00:46:48) です。
    Kbmplay.exe と同じディレクトリや、システムフォルダに置いただけでは認識しません。
    [ツール] -> [環境設定] を開いたのち検索パス 2 のタブを選択し、
    MUSE.EXE の場所を設定してください。
    http://village.infoweb.ne.jp/~atomic/
  • DirecxX 8.0 or later
    Direct Music (SGT/SGP) の再生のために必要です。
    動作確認が取れているバージョンは DirectX 9.0 (4.09.00.0901) です。
    DirectX はアンインストール及びバージョンダウンが出来ません。
    システムに与える影響も大きいため、導入の際は慎重に行ってください。
    http://www.microsoft.com/japan/windows/directx/
  • 着メロコンバータ (MID_MLD.EXE)
    着メロ関係の形式 (MLD/PMD) の再生のために必要です。
    Kbmplay.exe と同じフォルダに置いて下さい。
    http://coolweb.kakiko.com/kana2/
  • PsxMC (シェアウェア版かフリーウェア版のいずれか)
    PlayStation のムービー (CSTR/STR) の再生のために必要です。
    適当なフォルダに解凍した後、起動すれば CSTR/STR が再生可能になります。
    http://homepage2.nifty.com/~mkb/

導入は必須ではありませんが、導入すると便利なソフトもあります。

  • mp3infp (T-Matsuo 氏製作)
    • プロパティから MP3/WAV/VQF などの詳細情報表示や、
      タグ情報の書き換えが出来ます。
    • Version 2.0 以降を導入すれば、MP3 の ID3v2 のタグ情報の
      書き換えも出来るようになります。
    動作確認が取れているバージョンは 2.32.3.0 です。
    http://www.win32lab.com/
  • Super Tag Editor (MERCURY 氏製作)
    • エクセル風の操作性で MP3/WMA 等のタグ情報書き換えが出来ます。
    • SuperTagEditor (以下 STE) を導入すると、KbMedia Player の
      Media エクスプローラの右クリックメニューの「SuperTagEditor 起動」や、
      演奏リストの右クリックメニューの「送る」で STE と連携が出来るようになります。
    • STE を一度でも実行すれば、KbMedia Player は自動的に
      STE のインストール場所を認識します。
    • Kobarin 氏による STE の改造版もあります。
      2001/12/31 現在公開中の版では本家の STE の機能をすべて含み、
      OggVorbis/WAV/AVI/SPC 対応している点が異なります。
    http://www5.wisnet.ne.jp/~mercury/

以下のソフトを導入することにより拡張される機能は動作保証対象外です。

  • ZMC2/ZMC3/ZtoM/Z2M3 (わいやぎ氏製作)
    • ZMUSIC 形式の MIDI データ (ZMS/ZMD) を再生できるようになります。
    • 再生できるのは MIDI だけです。内蔵音源を使用するデータには対応していません。
    http://www2s.biglobe.ne.jp/~yyagi/


著作権・謝辞・転載について
著作権・免責事項

KbMedia Player はフリーソフトウェアであり、著作権は Kobarin 氏が保有しています。
このプログラムを使用することによっていかなる損害が生じても、
作者はその責任を負いません。

  • RCPCV.DLL の著作権は ふみぃ氏が保有しています。
  • UNZIP32.DLL の著作権は shoda.T 氏が保有しています。
  • NWDLL.DLL の著作権は NeoWRD 開発チームが保有しています。
  • WINFMP.DLL/PMDWIN.DLL の著作権は C60 氏が保有しています。
  • FPD98.DLL の著作権は株式会社ラット様が保有しています。
  • Windows Media Player の著作権は Microsoft 社が保有しています。
  • RealPlayer の著作権は RealNetworks が保有しています。
  • QuickTime の著作権は Apple Computer が保有しています。
  • Kbmplay.chm の著作権は Q.E.D. が保有しています。
  • TimeTag.html, TimeTagDev.html の著作権は駄歌詞屋氏が保有しています。
  • Plugins フォルダ以下にあるプラグインおよび DLL の著作権は、
    それぞれのプラグインの作者が保有しています。
謝辞

KbMedia Player の開発に関わって下さったすべての方々に感謝いたします。
ここへの名前の列記は割愛させていただきます。(^-^;

転載・配布

readme.txt の冒頭の【転載の可否】に従って下さい。
単に「可」とされている場合は、作者に事前に連絡することなく配布することが可能です。

ただし雑誌への収録などの金銭が絡む場合は、事前にメールで連絡する必要があります。
しかし、雑誌への収録依頼メールは面倒なので返信しないことがあります。
もし返信しなかった場合、収録は許可したものと見なして結構です。
掲載誌の送付も不要です。もし作者 (Kobarin 氏) の住所がわかっている場合は
送付して頂ければ幸いですが、強制はしません。

雑誌など影響力の強いメディアで KbMedia Player をご紹介して頂く場合、
SPC, NSF, S98 などのゲームサウンド関係に対応していることについては
触れないようにして下さい。個人で運営しているサイトでは、
これらのフォーマットに対応していることを紹介して下さっても構いません。
すべて管理人様のご判断にお任せします。


更新履歴

更新履歴 (括弧内は公開日)
2.32beta2(2003/09/02)
  • 最新のヘルプとの連携に対応
  • クロスフェード時、直前に再生していたファイルのフェードアウトが
    されないことがあるのを修正
2.32beta(2003/07/05)
  • CSTR/STR（プレステのムービー）に対応
    • PsxMC (シェアウェア版 v3.06 以降、またはフリーウェア版 v2.46 以降)
      http://homepage2.nifty.com/~mkb/
      が必要
    • シェアウェア版、フリーウェア版どちらでも動作します
    • PsxMC を適当なフォルダに展開後、PsxMC を起動すれば CSTR/STR が
      再生可能になります
2.31(2003/06/20)
  • kbmp3.kpi に関する以下の修正
    • RIFF SIF を包んだ ID3v2 を含む MP3 を再生出来ないのを修正
  • リソース化しきれていなかった文字列をリソース化
  • 「単曲再生」に関する動作仕様を変更
    • 演奏メニューの「単曲再生」が有効なときは常に単曲再生モード
    • 演奏メニューの「単曲再生」が無効なときは
      • Media エクスプローラ上で「再生(S)」で選曲した場合
      • 「ダブルクリック時」の設定が「リストに追加しないで再生」のときに
        ファイル単体をドラッグアンドドロップした場合
      • 「ダブルクリック時」の設定が「リストに追加しないで再生」のときに
        ファイル単体をコマンドライン or DDE 起動し、/a が指定されていない場合
      • ファイル単体をコマンドライン or DDE 起動し、/na が指定されている場合
      に単曲再生モード
2.31β8(2003/06/16)
  • コマンドラインや DDE で
    /mx
    /mx:"ファイル名"
    を指定した場合は Media エクスプローラにタブを切り替えるようにし、
    ファイル名が指定されている場合は指定したフォルダを選択するようにした
  • 演奏リストの右クリックメニューと「演奏」メニューに「単曲再生」を追加
  • ハードコーディングしていた文字列の一部をリソース化 (他言語化しやすくなった)
  • 細かい修正
2.31β7(2003/06/07)
  • 「Crescend Forte LiveSynth」や「QuickTime Music Synthesizer」に
    切り替えるときは、他に開いている MIDI デバイスを閉じるようにした
  • 以下の条件のとき、起動時間が長くなり、プラグインの使用・不使用の設定が
    失われる (使用する設定に戻ってしまう) のを修正
    • plugin.dat に登録されているプラグインが１つでも削除されている
    • 8 バイト以上の拡張子に対応するプラグイン (kbwinamp & in_psf.dll など) が
      導入されている
  • 拡張子 minipsf2 のタイトル取得に対応 (データはまだ見たことがないが、
    おそらく psf と同じと思われる)
  • RAR を正しく解凍できないことがあるようなので、kbunarc.dll のコンパイル
    オプションを変更 (「エイリアスを使わないと仮定」を無効にした)
  • 細かい修正
2.31β6(2003/06/02)
  • kb7z.dll に関する以下の修正
    • 解凍できないことがあったのを修正 (BZIP/Deflate)
    • 圧縮ルーチンを省くことにより、ファイルサイズが縮小
  • PSF2 のタイトル取得に対応
  • デコードスレッドがハングアップしていると思われる場合はデコードスレッドの
    優先度を下げるようにした (優先度が「TimeCritical」の場合にシステムが
    操作不能状態に近くなるのを回避するため。スレッドの強制終了はしないので、
    最終的にはユーザーが手動で KbMedia Player を強制終了する必要がある)
2.31β5(2003/05/26)
  • kbunarc.dll に関する以下の修正
    • アーカイブファイルのサイズ (解凍後ではなく、アーカイブファイル
      そのもののサイズ) に関する制限を甘くした
      • LZH:512MB
      • ZIP:512MB
      • CAB:128MB
      • TAR:512MB
      • RAR:64MB
      • 7Z :64MB
      • GCA:32MB
    • 7Z 形式に関する以下の修正
      • 7-ZIP32.DLL の Kobarin による改造版 kb7z.dll を使うようにした
      • 解凍速度が 2 割程度高速化
      • テンポラリファイルを作らず、メモリ上に解凍するようにした
2.31β4(2003/05/21)
  • kbfpd.kpi に関する以下の修正
    • 読み取り専用の FPD の曲長取得に失敗するのを修正
  • GZIP 圧縮された SPU のタイトル取得に対応
  • プラグインのファイル名が bmse.kpi の場合は常に kbrunkpi.exe 経由で
    再生するようにした (プラグインからプラグインを使うタイプのプラグインは
    Deinit 時に問題を起こす可能性があるため)
  • MIDI を使う BMS の再生に失敗する (演奏が進まない) ことがあるのを修正
  • デコードの先読みがうまく機能しないことがあるのを修正
  • シーク直後等にプラグインが演奏終了を返すとフリーズすることがあるバグを修正
  • 「タスクトレイ」の表示設定が有効でかつ最小化状態のとき、エクスプローラが
    落ちるなどの理由でタスクバーが消えてしまうと KbMedia Player が行方不明に
    なってしまう(^^ゞのを修正 (タスクバーが復帰されたときにタスクトレイのアイコンを
    作り直すようにした)
2.31β3(2003/05/18)
  • kbfpd.kpi に関する以下の修正
    • エラーダイアログ表示時、約 5 秒程度経過したら自動的に閉じるようにした
    • 曲長取得に失敗することがあるのを修正 (？)
  • RealMedia 再生時、および「Crescendo Forte LiveSynth」で MIDI を
    再生時の安定性が向上
  • コマンドラインで /p or /play を指定し、かつファイル名を渡さずに
    起動したとき連続再生が単曲再生に切り替わるようになっていたのを修正
2.31β2(2003/05/12)
  • kbfpd.kpi に関する以下の修正
    • FPV の検索フォルダを無限階層下まで検索するようにした
    • データ制作者別に整理したい場合に便利かも
  • 演奏ルーチンを大幅に修正 (音飛びしづらくなった？)
  • ID3v2 タグ取得ルーチンを修正
  • GZ 圧縮された VGM/S98 のタイトルを取得時にメモリリークすることがあるのを修正
  • その他細かいバグ修正
2.31β(2003/05/05)
  • アルトラマリン再生のプラグイン化 (kbum.kpi)
    • クロスフェード、音量調節、再生速度変更等が可能になった
    • MMX を使用可能な環境では MMX を使うようにした
  • 内蔵のアルトラマリン再生ルーチンを削除 (kbum.kpi でないと再生不可とした)
  • 内蔵の FPD 再生ルーチンを削除 (kbfpd.kpi 経由でないと再生不可とした)
  • kbfpd.kpi に関する以下の修正
    • fpd98.dll/fpd98sub.dll を kbfpd.kpi と同じフォルダに存在するものしか
      ロードしないように仕様変更
    • fpd98.dll のバージョン違いによる誤動作を回避するため
      (kbfpd.kpi は fpd98.dll の内部実装に強く依存するため、将来的に公開される
      最新の dll で動作することを保証出来ない)
    • FPD 本体や開発キットに同梱の fpd98sub.dll では動作しないため
    • fpd98sub.dll がない場合の演奏時間を 0xFFFFFFFF (デフォルトの曲の長さ) に変更
    • 検索パス指定に関するバグを修正
    • 細かい修正
  • kbunarc.dll に関する以下の修正
    • RAR 解凍ルーチンを最新の unrar.exe のソースコードに差し替え
  • ID3v2.2 のコメントを取得できないのを修正
  • 非同期化された ID3v2 のタグ情報を正しく取得できないのを修正
2.31α1～α3(2003/04/24～2003/04/30)
  • FPD 再生のプラグイン化 (kbfpd.kpi)
    • クロスフェード、音量調節、再生速度変更等が可能になった
  • 細かい修正
2.30(2003/4/13)
  • in_msx.kpi を最新版 (安定版) に差し替え
  • kbflac.kpi に関する以下の修正
    • モノラルのデータが再生出来ないバグを修正
  • kbwv.kpi に関する以下の修正
    • ベースとしたソースコードを最新版 (3.97) に差し替え
  • kbfmp.kpi/kbpmd.kpi に関する以下の修正
    • winfmp.dll/pmdwin.dll がなくてもプラグインとして認識されるように修正
      (起動時間の短縮のため)
    • ファイルサイズが小さくなった
  • AU 携帯の着声 (QCP) に対応 (kbqcp.kpi)
  • プラグイン経由で拡張子が MIDI 関連のファイルを開こうとしたときにエラーが
    返ってきた場合は内蔵ルーチンでファイルを開き直すようにした
    (auPiECE.kpi が導入されていても着メロの PMD を再生出来るようになった)
  • MLD/PMD/SPU のタイトルの取得に対応
  • MPEG/AVI/WMV を「音声のみ」で再生中にシークすると動画ウィンドウが
    表示されてしまうのを修正
  • プラグインが返した SoundInfo::dwUnitRender の値が 0 のときに正しく動作しない
    ことがあるのを修正 (kbmeup.kpi でクロスフェードが出来ない問題などが解決)
  • クロスフェードがうまく動作しないことがある (特に MIDI → Audio) のを修正
  • UNICODE で書かれた ID3v2 タグを取得出来ないことがあるのを修正
2.30β9(2003/4/08)
  • 音程を変えずに再生速度変更時の音質設定を保存するようにした
    (再生速度自体は保存しない)
  • 演奏スレッドと液晶表示スレッド間の同期処理に関する修正
2.30β8(2003/2/26)
  • kbmp3.kpi と kbmad.kpi に関する以下の修正
    • 無圧縮 zip.mp3 の 1曲目が再生される可能性が高くなった
      (2曲目以降が再生されるかどうかは保証できない)
    • VBR な無圧縮 zip.mp3 の曲長計算の方法を修正 (1曲目の曲長と
      ファイルサイズを元に概算値を求め)
    • 本当はあまり気が進まなかったんだけど…
  • 細かい修正
2.30β7(2003/2/24)
  • MUS/ZMS/ZMD => MID 変換時にコンソールウィンドウが一瞬表示される
    ようになっていたのを修正
  • ツリーの自動更新が機能しなくなっていたのを修正
  • 32bit float => 32bit int 変換のバグを修正 (プラグインが返したビット数が
    32bit float で、デバイスへの出力設定が 32bit int だと正しく再生出来ないのを修正)
  • kbmp3.kpi に関する以下の修正
    • 本体からのビット数要求が 24bit 以上の場合は 32bit float で
      出力するように修正 (layer-3 の場合のみ)
  • kbmad.kpi に関する以下の修正
    • 本体からのビット数要求が 32bit/64bit float の場合は 32bit int で
      出力するように修正 (今までは 16bit int で出力していた)
2.30β6(2003/2/20)
  • SOUNDINFO::dwBitsPerSample = (DWORD)-32 の場合は 32bit float 出力要求と
    見なすようにした (-1.0～1.0 へのクリッピングの処理はプラグインではなく本体が行う)
  • デバイス設定ダイアログに関する以下の修正
    • 32bit FLOAT/INT の両方が有効な場合は FLOAT の方を優先的に
      使うように仕様変更
    • 32bit FLOAT/INT の表示順序を入れ替え (優先度が高いものほど上に位置する)
  • kbtvq.kpi/kbvorbis.kpi を 32bit float 出力要求に対応
2.30β5(2003/2/17)
  • 音程を変えない再生速度変更に関する以下の修正
    • 音質を選べるようにした (「低音質」が従来の音質。高音質なほど CPU 負荷が高い)
    • DirectSound 使用時に速度を切り替えたときに一瞬音程が切り替わるのを
      出来るだけ回避するようにした
2.30β4(2003/2/12)
  • 着メロ関係の形式 (MLD/PMD) に試験的に対応 (正式に対応するかどうかは未定)
    • http://coolweb.kakiko.com/kana2/
      にある「着メロコンバータ for DoCoMo503i」(MID_MLD.EXE) が必要です
    • MID_MLD.EXE を Kbmplay.exe と同じフォルダに置いて下さい
  • kbmov.dll に関する修正 (動画ウィンドウが表示されないことがあるのを修正？)
  • ツリーの自動更新が正常に機能しないことがあるのを修正
  • 拡張子 minipsf のタグ情報取得に対応 (PSF と同じ扱い)
  • 32bit => 16bit 出力 に切り替えるとノイズが鳴る (ブザーみたいな音が鳴る)
    ことがある (ドライバのバグ？) のを修正
2.30β3(2003/1/28)
  • WavPack に対応 (kbwv.kpi)
  • kbflac.kpi に関する以下の修正
    • デコーダを libFLAC 1.1.0 に差し替え
  • kbmov.dll に関する以下の修正
    • MPEG を最大化状態で再生時にシークすると最大化が解除されるのを修正
  • SC68/VGM/VTX のタグ情報取得に対応
  • PSF のタグ情報取得に失敗することがあるのを修正
2.30β2(2003/1/21)
  • kbmac.kpi に関する以下の修正
    • 再生中のデータを mp3infp 2.32 で情報取得出来ないのを修正
  • kbdshow.kpi に関する以下の修正
    • 作成した ini ファイルをメモ帳で開くとコメント (セミコロンで始まる行) に
      改行が入らないのを修正 (CR LF とするべきところを LF しか入れてなかった)
  • MPEGplus のタグ情報取得を強化 (ApeTag v1/v2 を使用したものに対応)
  • PSF のタグ情報取得に対応 (PSF の再生は in_psf.dll ＆ kbwinamp 経由で対応)
2.30β(2003/1/14)
  • kbdshow.kpi に関する以下の修正
    • 24 bit データを再生するとノイズになるバグを修正
    • kbwma.dll の Windows Media Format SDK を Version 9 に差し替え
    • 詳細は kbdshow.txt を参照
  • kbspc.kpi に関する以下の修正
    • KMPMODULE::Deinit で後始末処理をしていなかったのを修正
    • 演奏結果がおかしくなることがあったのを修正
    • MSVCRT.DLL がなくても動作するようにした
    • 内部的な修正
  • T'SoundSystem(*.tss / *.tsd) に対応 (kbtss.kpi)
    (KbMedia Player 本体も tss/tsd のタイトル読み込みに対応)
  • 「バージョン情報」ダイアログで DLL 等の更新日時を表示するようにした
  • Kbmplay.exe/kbrunkpi.exe/pitchscaler.dll のファイルサイズが小さくなった
  • kbrunkpi.exe が再利用のために待機しているときの物理メモリ使用量が
    減少 (NT 系のみ)
  • DirectSound:Default を選択すると落ちる可能性があったのを修正
  • 「環境設定」→「その他」の QuickTime に関する説明がなくなっていたのを修正
2.29a(2003/1/03)
  • kbspc.kpi に関する以下の修正
    • ロード時に落ちることがあるのを修正
    • このバグが原因で KbMedia Player を起動できないことがありました（汗；
  • kbmio.kpi に関する修正 (修正箇所は↑と同じだが、落ちることはない)
  • 「バージョン情報」に関する以下の修正
    • レジストリからの DirectX のバージョン取得に失敗した場合は ddraw.dll の
      存在チェックをして、見つかった場合はインストールされていると見なすように修正
      (バージョンの表示は "????" になる)
  • 7-ZIP32.DLL のバージョンを表示するようにした
  • UNZIP32.DLL の著作権を (DLL が存在する場合は) リソースから取得して
    表示するようにした
2.29(2003/1/02)
  • m_s98.kpi/m_gym.kpi/sidplay.kpi/nezplug.kpi/in_msx.kpi/kbspc.kpi を
    最新版に差し替え
  • kbrunkpi.exe に関する以下の修正
    • 必要がなくなっても終了しないで次回必要になったときに再利用するようにした。
      これにより、KMPMODULE::dwReentrant=0 なプラグインを使用時の曲長計算、
      クロスフェード再生時の曲切り替え等が高速化
      (使用されない状態が 15 分を超えたら終了する)
    • SOUNDINFO::dwUnitRender の値が大きすぎると動作しなかったのを修正
      (現実にはこの制限に引っかかるようなプラグインは存在しない)
  • MIDI 関係の拡張子に対応するプラグインが導入されていると、「プラグイン情報」
    で該当プラグインを無効にしても KbMedia Player 本体の MIDI 演奏ルーチンが
    使えなくなるのを修正
2.29β12(2002/12/19)
  • kbvorbis.kpi 以外の OggVorbis デコーダプラグインが使用される状態だと
    .ogg のタグ情報を取得できないのを修正 (取得するためには kbvorbis.kpi が必要)
  • kbflac.kpi に関する修正
    • libFLAC を 1.0.4 に差し替え
    • タグ情報の取得に対応
2.29β11(2002/12/16)
  • in_CDReader.kpi 等、プラグイン経由で X:\::AudioCD::nnnn を再生すると
    タイトルが表示されないのを修正
2.29β10(2002/12/09)
  • in_CDReader.dll を使えるようにするため、プラグインが *.cda に対応している場合は
    プラグインを使用するように修正。ただし、X:\::AudioCD::#### の場合は MCI を使う
  • codecs.txt を修正 (真空波動研 021203 での修正箇所と同じ)
    • VSSV -> Vanguard Software VSS Video
    • ZYGO -> ZyGo ZyGoVideo
2.29β9(2002/12/02)
  • 7-ZIP 形式のアーカイブ(*.7z) に対応
    • Akky さん制作の 7-ZIP32.DLL：http://akky.cjb.net/ が必要です
    • サイズに関する制限は以下の通り (GCA と同じで制限は結構厳しいです)
      • 解凍前のサイズ：16MB
      • 格納ファイル数：256
      • 解凍後 (全解凍後) サイズ：搭載メモリの 1/4
      • 上記の制限に引っかかる場合は全く解凍せず
    • 解凍速度は低速 (GCA と同じくらい)
    • SPC ファイル群を 7Z 形式で圧縮すると、CAB や RAR よりも小さくなるようです
  • 動画の Codec 判別を強化 (codecs.txt を修正)
    • DVIS -> DV Codec Iris
    • DVRS -> DV Codec Iris Ref AVI
  • 細かい修正
2.29β8 (2002/11/11)
  • MDS (MIDI Stream) に関する以下の修正
    • SysEx を使用する MDS を再生出来なかったバグを修正
    • ランニングステータスを使用する MDS を正しく再生出来ないのを修正
    • タイトルの取得に対応
  • 拡張子 OGM に対応 (CODEC を導入する必要あり。動作は未確認)
  • 細かい修正
2.29β7 (2002/10/06)
  • Alt を押しながらファイル・フォルダをドラッグアンドドロップした場合は
    Media エクスプローラをドロップしたフォルダに移動するようにした。
  • 「環境設定」ダイアログで Media エクスプローラやタスクトレイ、QuickTime 等の
    設定を変更できるようにした
    (QuickTime の設定変更は QuickTime Player の動作にも影響する)
2.29β6 (2002/09/24)
  • 起動時のコマンドラインにファイル名や /p or /play が指定されていない場合は、
    起動直後に前回終了時に開いていたファイルを開かないようにすることにより、
    起動時間が少し短縮 (演奏開始時にファイルを開く)
  • 動画再生に関する以下の修正
    • 「自動 (最小化時は音声のみ)」が有効なときに最小化状態から復帰しても
      動画ウィンドウが表示されなかったのを修正
    • 再生中に動画ウィンドウを閉じた場合は、演奏開始ボタン右側▼で
      サイズ設定をすればウィンドウが表示されるようにした
  • QuickTime 再生時、DirectDraw/DirectSound を使うかどうかを
    QuickTime の設定に合わせるようにした
  • 「バージョン情報」ダイアログで DirectX のバージョンと入手先を表示するようにした
2.29β5 (2002/09/10)
  • 旧バージョンとのレジストリの互換性の問題等が原因で前回起動時に
    異常終了した形跡があった場合は、起動時にその旨ダイアログを表示し、
    レジストリ等の設定を削除してから起動するかどうかを選択出来るようにした
  • ファイルを開くたびに SGT/SGP の曲の長さが微妙に変わるのをある程度修正
2.29β4 (2002/09/05)
  • DirectMusic (SGT/SGP) に関する以下の修正
    • 「単曲リピート」が有効な場合は無限ループさせるようにした。
    • 再生する度に音質が変わることがあるのを修正(？)
  • タスクバーが下以外の位置にあると、終了時のウィンドウ位置と
    次回起動時のウィンドウ位置がずれるのを修正
2.29β3 (2002/09/01)
  • DirectMusic (SGT/SGP) に対応 (DirectX8 以降必須)
  • Muse に関する以下の修正
    • Muse.exe のパスを設定できるようにした
    • WAVE を使う Muse に対応 (PlaySound を使っているのであまり出来は良くない)
    • 「ドキュメント」表示部に Muse データを表示するようにした
      (先頭の 16KB のみ。稀に関係ない部分を E-mail アドレスと
      勘違いしてしまうことがあるが、これは回避不可能)
    • Media エクスプローラで Muse のタイトル読み込みが
      うまくいかないことがあったのを修正
  • UltraMarine の PCM フォルダと DLS フォルダを設定できるようにした
    • UM PCM フォルダは設定しないと認識しない。Kbmplay.exe と同じフォルダの
      UM フォルダを認識しないように仕様変更されてるので注意
    • DLS フォルダは SGT/SGP と同じフォルダに必要な DLS が
      存在しない場合に参照される
  • AVI の映像 Codec の判別を強化
    • 真空波動研：http://www.kurohane.net/とほぼ同等の判別力。
    • 情報提供をして下さった黒羽さんに感謝！
    • 音声 Codec の判別には未対応
  • 「バージョン情報」ダイアログを修正 (Muse の情報表示を追加)
  • 「ドキュメント」表示部で E-Mail アドレスの誤判別をする確率が下がった
2.29β2 (2002/08/28)
  • Muse (*.mus) に対応 (WAV を使うものには未対応)
    http://www.c3-net.ne.jp/~kato/muses/index.html
    にある、Muse.exe を Kbmplay.exe と同じフォルダに置けば再生可能になる
2.29β (2002/08/26)
  • AVI/MOV/RM の映像 Codec の取得に対応
    (正しい情報を取得できない場合は情報提供お願いします。詳しくは codecs.txt を参照)
  • 「バージョン情報」ダイアログに関する以下の修正
    • UMUT.DLL/Macromedia Flash Player/Vivo Active Player が
      導入されているかどうかを確認出来るようにした
    • 導入されている FPD98.DLL のタイムスタンプを表示するようにした。
      (DLL の仕様上、バージョンを取得することは不可能)
2.28c (2002/08/19)
  • Windows95 で「アンインストール用終了」時にレジストリを
    削除し切れないことがあるのを修正
  • kbflac.kpi に関する以下の修正
    • デコーダを libFLAC 1.0.3 に差し替え
    • 24bit に対応
  • MusePack (MPEGplus) デコーダを差し替え (kbmpp.kpi)
  • OggVorbis デコーダを libvorbis 1.0 (正式版) に差し替え (kbvorbis.kpi)
  • Monkey's Audio デコーダを MAC SDK 3.97 に差し替え (kbmac.kpi)
2.28b (2002/07/23)
  • kbmp3.kpi 使用時、データによっては落ちることがあるのを修正
  • MP3 のタイトル取得時にフリーズすることがあったバグを修正
  • CAB の解凍時に落ちることがあったバグを修正
  • スキンの設定に関する以下の修正
    • ファイル名が空白の場合はスキンを使わないようにした。
    • デフォルトのスキンを使用するとき、文字色の設定が機能しないのを修正。
  • 起動直後のウィンドウ表示処理を修正 (ボリューム表示、情報表示部など)
  • ファイル読み込み時の「解析中」カーソルを廃止
2.28a (2002/06/24)
  • 起動時のコマンドラインにファイル名が渡された場合 (関連付けによる起動など)は
    Media エクスプローラタブを選択しないようにした
  • 起動時に落ちることがあったのを修正 (？)
  • 細かい修正
2.28 (2002/06/23)
  • mxdrvg.kpi を最新版に差し替え
  • ツリーの自動更新監視で、短時間で大量のフォルダが更新されたときの処理を改善
  • 「環境設定」ダイアログをモードレスダイアログに変更
  • 「アンインストール用終了」時に表示されるメッセージを修正
  • Media エクスプローラの「更新日時」順の並べ替えが実際には
    文字列順だったのを修正 (秒単位の差異しかない場合の並べ替えが正しくなかった)
  • デフォルトのスキン (default.bmp) を用意することにした
    (「環境設定」→「概観」→「スキン」の「ファイル名」が空文字列の場合は
    本体と同じフォルダにある default.bmp を読み込む。
    default.bmp の読み込みに成功した場合は「文字色」を「白」にし、
    読み込みに失敗した場合は文字色を「自動」にする)
2.28β8.2002.0616 (2002/06/16)
  • 「デバイス設定」に関する以下の修正
    • Version 2.28β7 の再生周波数要求に関する以下の仕様を廃止
      # 使用デバイスが DirectSound で 0 以外の場合はプライマリバッファの
      # 再生周波数を指定した値に設定 (0 の場合は 44100 Hz に設定)
      (常に 44100Hz に設定する仕様に戻した。これ用の設定項目を追加するべき？)
    • 「音質重視」をクリックした場合は最適な設定を検出するようにした。
    • ほぼ完成 (95%)
  • Mamiya さんが手がけたプラグイン (bmse.kpi/m_gym.kpi/mxdrvg.kpi/m_s98.kpi/
    sidplay.kpi/nezplug.kpi)を差し替え。変更点は再生周波数要求への対応など
  • kbdshow.kpi に関する以下の修正
    • kmp_GetTestModule が複数回呼ばれると
      KMP_MODULE::ppszSupportExts が壊れるのを修正
  • kbfmp.kpi/kbpmd.kpi に関する以下の修正
    • kmp_GetTestModule が複数回呼ばれると WINFMP.DLL/PMDWIN.DLL の
      解放が正しく行われなくなるのを修正
    • 再生周波数要求に対する応答に関する修正
  • kbtvq.kpi に関する以下の修正
    • 24bit/32bit 出力要求に対応
  • kbvorbis.kpi に関する以下の修正
    • 24bit 出力要求に対応
  • kbmio.kpi に関する以下の修正
    • ERINA-Library 1.0A に差し替え
  • 演奏終了時に異音を発することがあるバグを修正
  • MIO のタグ情報の取得に対応
  • kbrunkpi.exe に関する以下の修正
    • 再生周波数要求とビット数要求が正常に機能しないのを修正
    • Kbmplay.exe と kbrunkpi.exe 相互の異常終了検出を改善
2.28β7.2002.0610 (2002/06/10)
  • プラグインの仕様を以下のように拡張
    • kmp_Open の SOUNDINFO::dwSamplesPerSec が 0 以外の場合は
      再生周波数を要求しているとみなす (対応しない、あるいは対応しても
      音質的なメリットがない場合はプラグインのデフォルトで良い)
  • kbfmp.kpi と kbpmd.kpi に関する修正
    • 上記のプラグイン仕様拡張 (再生周波数要求)に対応
  • kbmad.kpi に関する以下の修正
    • エラーが見つかっても出来るだけ再生するように修正
  • デバイス設定に関する以下の修正
    • 「WAVE デバイス設定」と「MIDI デバイス設定」を１つに統合
    • デバイスごとに再生周波数を設定できるようにした。詳細は以下の通り
      • 0 の場合はプラグインのデフォルト
      • 0 以外の場合はプラグインに再生周波数を要求
        (プラグインが要求された周波数に対応しない場合はプラグインのデフォルト)
      • 使用デバイスが DirectSound で 0 以外の場合はプライマリバッファの
        再生周波数を指定した値に設定 (0 の場合は 44100 Hz に設定)
      • 設定できる値の最小値は 8000, 最大値は 96000
    • 実用上はほぼ完成したけどまだ一部未完成
  • RAR の解凍がうまくいかないことがあったバグを修正 (kbunarc.kpi)
2.28β6.2002.0527 (2002/05/27)
  • WAVE デバイス設定」に関する以下の修正
    • デバイスごとに設定を保存できるようになった
    • 再生バッファのサイズを設定できるようになった
      (大きいほど音とびしなくなるが、演奏開始や音量調節等のレスポンスが悪くなる)
    • 細かいところでまだ未完成
  • DirectSound 使用時、24bit/32bit に対応しないデバイスで 24bit/32bit の
    データを再生した場合の再生位置取得が変だったのを修正
  • プラグインに関する仕様拡張
    • 24bit/32bit 出力の設定に応じてプラグインに対して 24bit/32bit での出力を
      要求するようにした (kmp_Open の SOUNDINFO::dwBitsPerSample が
      32 になっていた場合は、対応していれば 32bit で出力することを
      要求していることを意味する) 例えば、
      • 24bit/32bit 出力の設定が「無効」の場合は
        SOUNDINFO::dwBitsPerSample に 0 が渡される (プラグインのデフォルトで出力)
      • 「詳細設定」で 32bit に関するものが１つでもチェックが入っている場合は
        SOUNDINFO::dwBitsPerSample に 32 が渡される
      • 「詳細設定」でチェックが入っているのが 24bit Int だけの場合は
        SOUNDINFO::dwBitsPerSample に 24 が渡される
    • プラグインは要求されたビット数で出力する義務はない。
      (対応しない場合は対応しているビット数で出力すれば良い)
  • kbmad.kpi と kbvorbis.kpi に関する以下の修正
    • 上述のプラグイン仕様の拡張に対応 (kbmad.kpi の INI ファイルによる設定は
      SOUNDINFO::dwBitsPerSample == 0 の場合だけ反映される)
2.28β5.2002.0525 (2002/05/25)
  • 24bit/32bit 再生に関する以下のような修正
    • スペアナ表示、再生速度変更、音量調節、エコー、シーク等が正しく
      機能しないことがあったのを修正
    • 24bit/32bit に対応しないデバイスで 24bit/32bit のデータを再生する場合は
      適切な形式に変換してから再生するようにした。変換の仕方は以下の通り
      • 入力データが 32bit(INT) の場合
        • 1. 32bit INT (WAVE_FORMAT_PCM)
        • 2. 32bit INT (KSDATAFORMAT_SUBTYPE_PCM)
        • 3. 32bit FLOAT (WAVE_FORMAT_IEEE_FLOAT)
        • 4. 32bit FLOAT (KSDATAFORMAT_SUBTYPE_IEEE_FLOAT)
        • 5. 24bit INT (WAVE_FORMAT_PCM)
        • 6. 24bit INT (KSDATAFORMAT_SUBTYPE_PCM)
        • 7. 16bit INT
      • 入力データが 24bit(INT) の場合
        • 1. 24bit INT (WAVE_FORMAT_PCM)
        • 2. 24bit INT (KSDATAFORMAT_SUBTYPE_PCM)
        • 3. 32bit INT (WAVE_FORMAT_PCM)
        • 4 32bit INT (KSDATAFORMAT_SUBTYPE_PCM)
        • 5. 32bit FLOAT (WAVE_FORMAT_IEEE_FLOAT)
        • 6. 32bit FLOAT (KSDATAFORMAT_SUBTYPE_IEEE_FLOAT)
        • 7. 16bit INT
    • 番号順にデバイスを開いて行き、オープンに成功した形式で再生する
    • 「WAVE デバイス設定」の「詳細設定」が有効な場合、
      チェックが外れている形式でのデバイスオープンは試みない。例えば、
      32bit INT (WAVE_FORMAT_PCM)
      に対応せず、
      32bit INT (KSDATAFORMAT_SUBTYPE_PCM)
      と
      32bit FLOAT (WAVE_FORMAT_IEEE_FLOAT)
      に対応するデバイスで 32bit データを再生する場合、通常は
      32bit INT (KSDATAFORMAT_SUBTYPE_PCM)
      で再生される。これを
      32bit FLOAT (WAVE_FORMAT_IEEE_FLOAT)
      の方で再生したい場合は
      32bit INT (KSDATAFORMAT_SUBTYPE_PCM)
      のチェックを外せば良い。
    • 実際にどの形式で再生しているかを知りたい場合は、
      「OutputDebugString 有効」のチェックを有効にし、OutputDebugString の出力を
      表示できるツール (VC++ など)を使用して出力結果を見る
      (開発ツールがないと見ることが出来ない？正式版の公開までには、
      一般ユーザーでも簡単に見られるようにする予定)
  • 再生時に「Error! in LCD Thread」と表示されてフリーズすることがあるのを修正
  • kbmad.kpi に関する以下の修正
    • デフォルトではディザを無効にした
    • 8/16/24/32 bit 出力とディザの有効・無効を ini ファイルで設定出来るようにした
2.28β4.2002.0519 (2002/05/19)
  • WinRAR 3.0 正式版で作成した RAR を解凍できなかったのを修正
  • 32bit 出力に暫定対応 (WAVE_FORMAT_IEEE_FLOAT に対応するサウンドカードのみ)
  • 8bit のデータにきちんと対応出来ていなかったのを修正
  • waveOut/DirectSound のデバイスを選択出来るようにした
  • waveOut/DirectSound のデバイスオープンに失敗するとフリーズするバグを修正
  • waveOut 使用時の演奏開始・終了処理が少しまずかったかもしれないのを修正
  • エコーのかかり具合を調整
2.28β3.2002.0515 (2002/05/15)
  • 「環境設定」ダイアログに関する以下の修正。
    • 「プラグイン情報」ダイアログを廃止し、「環境設定」ダイアログと統合
    • 使用するプラグインの設定がしやすくなった (変更が直ちに演奏に反映される)
    • 使用中のプラグインを表示するようにした
    • プラグインのリスト部分で Insert を押すと使用中のプラグインに移動するようにした
    • 「実行制御」タブを「優先度」に変更
    • 「演奏設定」の「フェードアウト時間」と「フェードアウト開始時間の位置を入れ替え
    • 「フェードアウト開始時間」で負の値を指定できるようにした
      (正の場合はフェードインが指定した時間だけ進行してからフェードアウトが始まり、
      負の場合はフェードアウトが指定した時間だけ進行してからフェードインが始まる)
  • クロスフェード時の重なり具合を修正
    (β2 で修正したつもりのところが修正しきれていなかった)
  • 認識可能なプラグインの数の制限値を 32 個から 64 個に変更
  • 細かい修正
2.28β2.2002.0513 (2002/05/13)
  • FLAC に対応 (kbflac.kpi)
  • Music Interleaved and Orthogonal transformed format (MIO)に対応(kbmio.kpi)
  • MAD - MPEG audio decoder ベースの MP3 デコードプラグイン(kbmad.kpi) を搭載
    (使用するためには、「プラグイン情報」で競合する
    MP3 プラグインを使用不可にする必要があります)
  • AAC の対応を中止
    • ソースのみの配布に変更
    • ソースは http://home7.highway.ne.jp/source/ にあります。
  • kbtvq.kpi に関する以下の修正
    • ファイルオープン・曲長計算が高速化
  • 使用するプラグインを選択出来るようにした (「ヘルプ」→「プラグイン情報」)
  • 「お気に入り」に関する以下の修正
    • ドライブ一覧のアイコンがきちんと表示されないのを修正
    • Shift+D でドライブ一覧、Shift+F でお気に入りのポップアップメニューを
      表示するようにした
    • お気に入りのポップアップメニューにフォルダのアイコンを表示するようにした
  • waveOut/DirectSound に渡すバッファサイズが小さすぎたのを修正
    (音とびが少し軽減する代わりに音量変更などの反映が遅くなる)
  • クロスフェード時、後に再生した方の発音タイミングを修正
  • ID3v2 のタグ情報を取得できないことがあったのを修正 (2.28βの修正とは別件)
  • 拡張子 MPA/MPV2 に対応したつもりが対応出来てなかったのを修正
  • 2.28βの Windows95 上における不具合の修正が完全ではなかったのを修正
2.28β.2002.0507 (2002/05/07)
  • 「お気に入り」に関する以下のような修正
    • クリックしたらウィンドウを表示するのではなく、
      ポップアップメニューを表示するようにした
    • お気に入りを編集したい場合は「お気に入りの整理」をクリック
    • ポップアップメニューに表示されるアイテムは先頭の 30 個まで
    • マウスのドラッグアンドドロップで順序を入れ替えられるようにした
    • カラムをクリックすると (表示上の) 名前順に並べ替えるようにした
  • 動画のウィンドウサイズを 640x480 よりも大きく (最大で 1280x960 まで)
    拡大出来るようにした
  • OggVorbis デコーダ (kbvorbis.kpi) を libvorbis 1.0RC3 ベースのものに差し替え
  • Monkey's Audio デコーダ (kbmac.kpi)を MAC SDK 3.97b1pre1 ベースに差し替え
  • AAC デコーダ (kbaac.kpi)を FAAD2 26012002 ベースものに差し替え。これにより
    • クロスフェード時のパフォーマンスが向上
    • 最新のエンコーダで作成した AAC が再生出来るようになった
    • 瞬間的なシークが出来るようになった (ただし、データによっては不可)
  • AAC のタグ情報の取得に対応 (MP3 と同様に扱う)
  • 拡張子 MPA/MPV2 に対応 (動画として扱う)
  • 拡張子 MP2 を kbmov.dll を介して再生するようにした
    (MPEG2 動画として扱うため。中身が MPEG Audio Layer2 でも再生は可能だが、
    クロスフェードや音程を変えない速度変更等は不可)
  • ID3v2 形式のタグ情報を正しく取得できないことがあるのを修正
  • RMX を再生できないことがあるのを修正 (kbmov.dll)
  • タスクバーが上または左にある場合にウィンドウスナップが
    正しく機能しないことがあるのを修正
  • Media エクスプローラツリービューの横幅を小さくして非表示にすると、
    次に起動するまで二度と表示できなくなることがあるのを修正
    (非表示まで小さく出来ないように制限することで対応)
  • NeoWRD を再生中に曲を切り替えると落ちることがあるのを修正 (nwdll.dll)
  • Windows95 で実行したときの以下の問題を修正
    • タイムタグ付き歌詞ファイルの検索パス指定が機能しない
    • 再生中に歌詞ファイルを更新した後にシークしたり最初から
      演奏し直した場合に歌詞の変更が自動的に反映されない
    • 圧縮ファイル内のデータを扱った場合に Media エクスプローラのツリーの
      自動更新機能が反応してしまう
2.27.2002.0316 (2002/03/16)
  • MSXplug, NEZplug, SID, BMS のプラグインを最新版 (正式版)に差し替え
  • 再生速度変更時に音程を変えるかどうか設定できるようにした
  • pitchscaler.dll がないとフリーズするバグを修正
  • Win95 でも pitchscaler.dll が動作するように修正
  • kbunarc.dll に関する以下のような修正
    • 格納ファイル名の長さが 100 バイトを超える TAR を扱えなかったバグを修正
    • TAR の格納ファイル数制限がなかったのを 2048 個までしか扱えないように修正
    • LZH/ZIP/TAR のファイルサイズ制限 (圧縮ファイル自体のサイズ)を 128 MB から
      256 MB に変更 (解凍後のサイズに関する制限は従来と同じ)
    • 無圧縮 ZIP の Media エクスプローラでの扱いが大幅に高速化
      (TAR とほぼ同じ程度になった)
  • nwdll.dll と kbunarc.dll の zlib/libpng を最新版に差し替え
2.27β.2002.0311 (2002/03/11)
  • 再生速度変更時の CPU 負荷と音とびが軽減
  • WaveMapper 使用時でも音程を変えずに再生速度が変更できるようになった
  • モノラルのデータを開くと落ちるのを修正
  • 「音程を変えずに速度 x2.0」と「速度を変えずに音程 x0.5」を廃止し、
    代わりに設定可能な速度を増やした
    (将来的には任意の再生速度を指定できるようにする予定)
2.27α.2002.0307 (2002/03/07)
  • 音程を変えずに再生速度を変更できるようになった
Version 2.26e.2001.1231 (2001/12/31)
  • SuperTagEditor 2.01 以降に対応 (インストールされていれば
    Media エクスプローラや演奏リストの右クリックメニューの「SuperTagEditor」を
    クリックしたときに STEにファイルを渡すことが出来るようになる)
  • GCA SDK を最新版に差し替え
Version 2.26d.2001.1215 (2001/12/15)
  • バージョン情報ダイアログの色が変だったのを修正
  • 動画再生が変だったのを修正 (kbmov.dll が壊れていた？)
  • 細かい修正
Version 2.26c.2001.1202 (2001/12/09)
  • WindowsXP に正式に対応 (作者自身が動作確認)
  • WindowsXP など、Windows エクスプローラが CAB/ZIP をフォルダとして
    扱うような環境だと、Media エクスプローラツリー部分で大量の CAB/ZIP を
    含むフォルダの扱いが低速になるのを修正
  • 瞬間的なシークをサポートしない形式でシーク中に再シークすると演奏が
    終わってしまうことがあるバグを修正
Version 2.26b.2001.1202 (2001/12/02)
  • [OK] さん制作の in_msx.kpi を最新版(0.19)に差し替え
  • 環境によっては SysEx を含む MIDI を再生すると演奏がもたりやすかったのを修正
  • Media エクスプローラでメモリリークしていたのを修正
  • 細かい修正
Version 2.26a.2001.1126 (2001/11/26)
  • WaveMapper を使用して長時間連続再生させると動作が不安定になる重大バグを修正
  • DirectSound 使用時のシークと曲の切り替えが高速化
  • Open/Save ダイアログの初期フォルダを保存しておくようにした
  • Open ダイアログで演奏リストファイルを開いたときの動作を修正
    (Media エクスプローラの右クリックメニューの「新規に開く」と同じ)
  • 終了処理に無意味に時間がかかっていた (1秒以上) のを修正
  • WindowsXP で MIDI Mapper が「YAMAHA CBX Driver」を使用する環境で
    SysEx を送信すると固まるらしいのを修正 (直ってないかもしれない)
  • 2GB 以上 4GB 未満の圧縮ファイルを解凍しようとしてしまうのを修正
Version 2.26.2001.1122 (2001/11/22)
  • 動画再生に関する以下のような修正
    • RealVideo でシークできるようにした (落ちるかもしれない)
    • RealVideo 再生で「常に手前に表示」の解除が出来ないバグを修正
    • MPEG/AVI/WMV を再生時にシークするとウィンドウサイズが元に
      戻ってしまうのを修正
    • MPEG/AVI/WMV を再生時に曲を切り替えるとウィンドウが
      一瞬表示されてしまうのを修正
    • 「常に手前に表示」しているときに MPEG/AVI/WMV/RealVideo に
      切り替えた場合はメインウィンドウが非アクティブにならないようにした
  • 「Crescendo Forte LiveSynth」で MIDI を再生中にシークバーを操作しても
    何もしないようにした (今までは最初から演奏していた)
    • x
  • DirectSound で MP3 等を再生した後に FPD を再生すると、ドライバによっては
    演奏開始時に雑音が入る (環境によっては再生もできなくなる？) ことがあるのを修正
  • RMI の DISP チャンク(？)と LIST チャンクに含まれている
    タイトル・アーティスト情報を取得できるようにした
  • 拡張子 *.CDF (チャンネルファイル？) が Media エクスプローラのツリー部分に
    表示されてしまうのを修正
  • Lyrics3v2 (MP3 に埋め込まれた歌詞) を認識しなくなっていたバグを修正
  • 「MIDI デバイス設定」ウィンドウで、テンプレート No.8 と No.9 のテンプレート名等を
    淡色表示しないようにした (編集は不可)
Version 2.25.2001.1119 (2001/11/19)
  • 曲の切り替えが高速化 (特に DirectSound 使用時)
  • クロスフェード中のメモリ使用量が減少
  • Media エクスプローラで LZH/ZIP/TAR で圧縮されたデータのタイトルを
    取得するとき、ファイルの先頭部分だけを調べればタイトルを取得できるような
    形式の場合のサイズ制限を甘くした
  • 動画等を再生時の波形取得の際に IDirectSoundCapture を使うのをやめ、
    waveIn 系 API を使うようにした (SoundBlaster Audigy で正常動作しないため)
  • Windows エクスプローラで CAB/ZIP などがフォルダとして扱われるような環境だと
    Media エクスプローラで圧縮ファイルを正しく扱えないことがあるのを修正
  • RIFF WAVE ヘッダがついた MP3 を再生できないことがあるバグを修正
  • 歌詞の検索パスが設定されていると終了時に固まることがあったバグを修正
  • Kbmplay.exe がハングアップしているときに二重起動しようとすると、
    新しく起動した Kbmplay.exe もハングアップしてしまうのを修正
  • kbmov.dll を修正 (ファイルサイズが少しだけ小さくなった)
  • その他内部的な修正
2.25β.2001.1115 (2001/11/15)
  • TAR/TGZ に暫定対応 (TGZ は次のバージョンで対応を中止する可能性大)
  • NeoWRD 開発チーム制作の nwdll.dll を以下のように改造
    • ファイルサイズが減少 (不必要な関数を削除、MSVCRT.DLL を使うようにする等)
    • 演奏停止処理が遅いのを修正
    • ファイル名を変更しておくべきでしょうか。(^^;
  • Media エクスプローラで圧縮ファイル内のタイトルを取得するとき、圧縮メソッドが
    無圧縮の場合は、サイズ制限を甘くする(2倍)ようにした
  • RAR/CAB の解凍時のメモリ使用量が減少
2.25β.2001.1112 (2001/11/12)
  • Mamiya さん制作の bmse.kpi/m_s98.kpi/m_sap.kpi を最新版に差し替え
  • KBMP3.KPI に関する以下のような修正
    • 実際は MP3 でないのに強引に再生してしまう確率が下がった(と思う)
    • ヘッダにゴミがついている MP3 を再生できる確率が上がった(と思う)
    • コンパイラの最適化オプションを変更 (Pentium Pro 用に最適化)
    • メモリの断片化が起こりやすい実装だったのを修正
  • KBFMP.KPI と KBPMD.KPI に関する以下のような修正
    • MSVCRT.DLL に依存しなくなった
  • kbunarc.dll に関する以下のような修正
    • 非SOLID 形式の RAR を正しく解凍できないことがあるバグを修正
    • 格納ファイル数が多い非SOLID 形式の RAR の解凍速度が高速化
      (データによっては 10 倍以上)
    • 解凍可能なサイズの制限を越える CAB を開くと落ちるバグを修正
    • 解凍可能な圧縮ファイルの制限を以下のように修正

      圧縮形式 | 解凍前のサイズ | 解凍後のサイズ | 格納ファイル数
      LZH/ZIP | 128MB | 個別展開後が搭載メモリの 1/4 | 2048 個
      CAB | 64MB | 全展開後が搭載メモリの 1/4 | 1024 個
      RAR | 32MB | 全展開後が搭載メモリの 1/4 | 512 個
      GCA | 16MB | 全展開後が搭載メモリの 1/4 | 256 個

      解凍前のサイズとは、圧縮ファイル自体のサイズのこと。
      例えば LZH/ZIP の場合は 128MB 以上の圧縮ファイルは無視される。
      解凍後のサイズ制限は以下の通り
      • 解凍後のサイズが搭載メモリの 1/4 以下で、かつ 2 の整数乗と
        なるような最大値 (例えば搭載メモリが 192 MB なら 32MB)
      • CAB/RAR で複数のファイルが格納されている場合、すべて展開した
        後の合計サイズが上記の制限値 (例えば 搭載メモリが 192MB なら 32MB)
        以下の場合のみ解凍可能。制限を越えている分のファイルは認識しない。
        (従来のバージョンでは解凍は出来たが、解凍結果は壊れていた)
      • GCA の場合、すべて展開した後のサイズの合計が制限値を
        超えている場合は全く解凍しない。
      • 格納ファイル数が制限値を超える場合は、制限値まで見つかった
        分までしか解凍しない。ただし、GCA の場合は格納ファイル数が
        制限値を超えた場合は全く解凍しない。
  • シーク直後にフェードインさせるのをやめた
  • M3U を読み込むと落ちることがあるバグを修正
  • 拡張子 NSD を１ファイル複数曲として扱うのをやめた
  • 拡張子 D00/NS0/NS1/NS2/TFX/XA を１ファイル複数曲として扱うようにした
2.25β.2001.1108 (2001/11/08)
  • Mamiya さん制作の bmse.kpi/m_gym.kpi/m_s98.kpi/m_sap.kpi を最新版に差し替え
  • Media エクスプローラで１ファイル複数曲を扱うときに落ちることがあるのを修正
  • Media エクスプローラで「サイズ」が文字化けして表示されることがあるのを修正
  • kbdshow.kpi/kbmac.kpi/kbspc.kpi を修正 (詳細はプラグインに同梱のドキュメントを参照)
  • kbunarc.dll のファイルサイズが減少 (msvcrt.dll に依存するようになった)
  • kbrunkpi.exe のファイルサイズが減少
  • kbrunkpi.exe を経由して再生するとき、演奏開始直後に演奏が
    止まってしまうことがあったのを修正
  • 拡張子 EMS を BMS と (タイトル読み込みと MIDI との同期再生処理に関して)
    同じものとして扱うようにした
  • 演奏リストの右クリックメニューに関する以下のような修正
    • 「ソート」を「並べ替え」に変更
    • 「削除」→「無効なデータ」を「存在しないデータ」に変更
  • MIDI 付き BMS の演奏終了処理がうまくいかない (フリーズに近い状態になる)
    ことがあるのを修正
  • BMS→MIDI にクロスフェードすると動作がおかしくなるバグを修正
2.25β.2001.1029 (2001/10/29)
  • MIDI を使う BMS の再生に関する以下のような修正
    • MIDI と WAV の同期処理を改善
    • 演奏開始直後やシーク直後に１～３秒程度操作不能状態になるのを修正
    • 演奏開始直後やシーク直後に液晶に「Pause」と表示されないようにした
    • プラグインが返す演奏時間よりも MIDI の方が演奏時間が長い場合は
      MIDI の方の演奏時間を採用するようにした
    • 演奏終了処理を修正 (プラグイン側 (WAV 再生) と MIDI の両方が
      演奏終了するまで演奏終了と見なさないようにした)
2.25β.2001.1028 (2001/10/28)
  • MIDI を使う BMS に対応
  • Mamiya さん制作の bmse.kpi を修正 (冒頭の無音を無視しないように修正)
Version 2.24 (2001/10/21)
  • Mamiya さん制作の bmse.kpi(v1.0r6) を同梱させて頂くことにした
  • [OK] さん制作の in_msx.kpi を最新版(v0.18beta)に差し替え
  • 演奏リストに１曲しか登録されていない状態で、かつ「未再生の曲だけ再生」が
    有効のとき、「リピート」が有効でもリピート再生されないのを修正
  • MIDI の演奏終了処理を修正 (最後のノートオフから１秒以上待ってから
    AllNoteOff/AllSoundOff を送信するようにした)
  • 瞬間的なシークをサポートしない形式で再生速度を変更した直後にノイズが
    混入することがあったのを修正
  • 使用するプラグインや再生周波数によっては「音程を変えずに再生速度x2」が
    正しく機能しないのを修正 (正しく機能しても音質が悪いことに変わりはない)
  • WAVE_MAPPER 使用時に「音程を変えずに再生速度x2」が正しく機能しないのを修正
Version 2.24β (2001/10/14)
  • KBSPC.KPI に関する以下のような修正
    • エコーの遅延時間の修正
    • 音色が正しく反映されない問題の修正
  • BMS/BME のタイトル読み込みに対応 (BMS/BME を再生するプラグインは
    同梱していません。再生したい場合は http://www.proc.org.tohoku.ac.jp/befis/ で
    bmse.kpi を入手して下さい)
  • クロスフェード中の CPU 負荷が減少
  • ファイルサイズ (解凍後のサイズではない) が大きすぎる (16 MB 以上)
    圧縮ファイルは開かないように修正
  • 演奏時間よりも後ろの位置にシークしようとすることがあるのを修正
  • 瞬間的なシークをサポートしない形式 (SPC など) でシーク中にフェードアウトすると
    動作がおかしくなっていたのを修正
  • DirectSound を使用して再生中に再生速度を変更すると再生位置取得が
    ずれるのを多分修正 (自信なし)
  • メドレー再生中に曲を切り替えようとするとき、演奏リストが空になっている場合は
    最後まで演奏するように修正
Version 2.24β_test20011009 (2001/10/09)
  • SPC/NSF 等の無音検出を改良 (無音部分を演奏する時間が短くなった)
  • 演奏開始直後が少し重いのを気持ち程度改善
  • KBWMA.DLL に関する以下のような修正
    • WMA のオープンに失敗したときにメモリリークするのを修正
    • 音とびと CPU 負荷が少し軽減 (気休め程度)
    • 演奏終了の約 5 秒前に CPU 使用率が 100% になるのを修正
Version 2.24β_test20011003 (2001/10/03)
  • KBWMA.DLL を使用して WMA を再生した場合の音とびが軽減
  • 演奏ルーチンを改良 (音とびがかなり軽減)
  • フェードイン・フェードアウト時間指定がミリ秒単位で機能するようになった
    (今までは秒単位に切り捨てていた)
  • シーク直後に少しだけ(500ms)フェードインさせるようにした
  • Media エクスプローラで Ctrl+A (全選択)が効かなくなっていたのを修正
Version 2.24β_test20010928 (2001/09/28)
  • kbspc.kpi を最新版に差し替え
  • kbrunkpi.exe を経由した再生が出来なくなっていたバグを修正
    (コマンドライン引数の解析がおかしくなっていた)
  • Media エクスプローラや演奏リストがアクティブのときに Alt+F4 での
    プログラムの終了が出来なかったのを修正
Version 2.24β_test20010927 (2001/09/27)
  • KBWMA.DLL に関する修正 (詳しくは kbdshow.txt を参照)
Version 2.24β_test20010926 (2001/09/26)
  • kbdshow.kpi に関する修正 (詳しくは kbdshow.txt を参照)
  • kbrun_pi.exe に関する以下のような修正
    • 実行ファイル名を kbrunkpi.exe に変更
    • kbrunkpi.exe を経由して再生しているときの音とびが軽減
      (「デコードスレッドの優先順位」の設定が反映されるようになった)
    • kbrunkpi.exe を経由してファイルオープンに失敗したときに
      リソースリークしていたのを修正
  • 「QuickTime Music Synthesizer」と「Crescendo Forte LiveSynth」を
    使用してMIDI を再生する場合は、単純な SMF (SMF Format0、テンポが一定、
    テンポ指定以外のメタイベントを使わない、ランニングステータスを使わない)に
    変換してからファイルを渡すようにした。これにより、
    • 強制終了・フリーズが起こりにくくなった (「Crescendo Forte LiveSynth」では
      まだ落ちることがあるが、落ちにくくなったのは確実)
    • 「Crescendo Forte LiveSynth」で再生時に曲の冒頭が鳴らないことが
      あるのを修正 (変換時に冒頭に約2秒間の無音を挿入することにより対処)
    • MDS を再生できるようになった
    • 通常の MIDI デバイスで RCP を再生するときに一時ファイルを作る
      必要がなくなった
Version 2.24β_test20010920 (2001/09/20)
  • kbmac.kpi を Monkey's Audio SDK 3.92 ベースに差し替え
  • kbunarc.dll で使用している GCA SDK を最新版(0.9g2)に差し替え
  • 圧縮ファイル内の MP3 等のタイトルを取得するときに出来るだけ
    一時ファイルを作成しないようにした
  • Media エクスプローラで大量のデータを含むフォルダやプレイリストを
    選択したときのメモリ使用量が減少
  • 終了時に Media エクスプローラに関する設定を保存しなくなっていたのを修正
Version 2.24β_test20010913 (2001/09/13)
  • 「お気に入り」を大幅に修正
  • Media エクスプローラでソートすると選択アイテムが変わってしまうのを修正
  • Media エクスプローラでインクリメンタルサーチが機能しなくなっていたのを修正
  • WaveMapper/DirectSound の切り替えがトグルスイッチ的に動作していたのを修正
Version 2.24β_test20010911 (2001/09/11)
  • Media エクスプローラが高速化
Version 2.23a (2001/09/09)
  • DirectSound を使用するとまともに再生されないことがあるのを今度こそ修正(？)
Version 2.23 (2001/09/09)
  • PMD のメモ欄の取得に対応
  • MPK のタイトル取得に対応
  • ホットキーが有効なときに Ctrl+Shift+K を押下した場合はウィンドウの
    最小化とアクティブ化を切り替えるように修正 (今まではアクティブ化のみだった)
  • 環境によっては DirectSound を使用するとまともに再生されないのを修正(？)
  • 実際は SMF Format1 なのに SMF Format0 と表示してしまうバグを修正
  • Media エクスプローラの「種類」に表示する文字列の長さの上限を大きくした
Version 2.22 (2001/09/04)
  • kbdshow.kpi に関する以下のような修正
    • 最後まで演奏した後に演奏を再開しても再開できないことがあったのを修正
      (根本的な解決は出来ていない)
    • WMA でシークすると演奏が終わってしまう確率が下がった
      (根本的な解決は出来ていない)
  • 演奏ルーチンで必要以上に CriticalSection を使用していたのを修正
  • MIDI デバイステンプレートの設定を変更すると落ちるバグを修正
Version 2.21 (2001/09/02)
  • [OK] さん制作の in_msx.kpi (kbmsx.kpi の最新版)を同梱させて頂くことにした
  • ランダム再生・メドレー再生時に曲を切り替えるとき、
    ランダムに切り替わらないことがあったのを修正
  • テンキーの 7 と 9 を押してシークするときの動作を修正
    (キーを離すまではシークしないようにした)
  • タスクトレイのメニューで & が下線になるバグを修正
  • 無限ループする曲で単曲リピートが効かないことがあったバグを修正
  • M3U/PLS→TAG へのコンバータ (レジストリを手動書き換えしないと使えない機能) が
    正しく機能していなかったのを修正
    (M3U→TAG への変換が出来ない、NSF の場合に曲番号が１つずれるなど)
  • SPC/NSF 等を再生時の無音の検出の仕方を修正
Version 2.21β5_test20010828 (2001/08/28)
  • エコーの ON/OFF を演奏開始ボタン右側の▼で指定するようにした
  • MOD 再生で MPPSDK.DLL を使うルーチンを削除 (エフェクト等は使えなくなった)
  • 「環境設定」ダイアログの「演奏設定」タブを修正
  • DirectX5 未満で DirectSound が使えなくなっていたバグを修正
  • 演奏ルーチンがおかしくなっていたバグを修正
  • 終了時に落ちることがあったバグを修正
  • DDE の XTYP_EXECUTE コマンドに /fileclose を追加 (再生中のファイルを閉じる)
Version 2.21β5_test20010825 (2001/08/25)
  • MPEGplus (MPC/MP+)に対応
  • MPEGplus のタイトルを取得できるようになった (MP3 と同じ)
  • MOD に関する以下のような修正
    • ModPlug XMMS Plugin v1.5a をベースとしてプラグイン化 (kbmod.kpi)
    • MPPSDK.DLL を必要としなくなった
      (kbmod.kpi がなければ mppsdk.dll を使います)
    • 音質が向上(？)
    • 瞬間的なシークが出来るようになった
    • 拡張子 669/amf/ams/dbm/dsm/far/j2b/med/
      mt2/mtm/okt/psm/ptm/ult/umx に対応
  • MIDI に関する以下のような修正
    • CVS.EXE, MML2MID.EXE, SNG2S.EXE のサポートを打ち切った
    • 「QuickTime Music Synthesizer」と「Crescendo Forte LiveSynth」で拡張子が
      MID 以外の MIDI ファイル (RMI, RCP など、MDS 以外のすべての MIDI ) や、
      マックバイナリヘッダがついた MIDI ファイルを再生出来るようになった
    • データの一部が壊れていると判断した MIDI データ
      (情報表示部の「フォーマット」に「警告 (一部のデータが壊れています)」と
      表示されるデータ) は「QuickTime Music Synthesizer」と
      「Crescendo Forte LiveSynth」では再生させないようにした
      (落ちる可能性が高いため。データが壊れてなくても落ちることは
      ありますが、これは私のせいじゃないです)
    • 「QuickTime Music Synthesizer」を使用して MIDI を再生しているときの
      再生位置取得で発音遅延を考慮に入れるようにした
      (「Crescendo Forte LiveSynth」の場合も発音遅延が生じるようだが、
      これはデータによって遅延の度合いがまちまちなので調整不可能)
    • G36 のメモ欄を取得すると落ちることがあるバグを修正
  • 液晶表示に関する以下のような修正
    • ウィンドウを最小化しているときはスレッドを完全に停止させるようにした
    • 演奏停止状態 (または一時停止状態)のときの CPU 負荷が少し軽減
    • 演奏ルーチンとの同期処理を修正 (曲の切り替えがスムーズになった？)
    • 「waveIn による波形取得を行わない」のチェックが無効な場合
      (波形取得を行う場合)、「QuickTime Music Synthesizer」と
      「Crescendo Forte LiveSynth」でMIDI を再生時はスペアナを表示するようにした
    • DirectX5 未満の環境 (DirectSoundCapture が使えない環境)で動画等を
      再生時に (ドライバが対応していても)スペアナを表示出来なかった
      ＆リソースリークしていたのを修正
    • 一時ファイルを削除するときに落ちることがあったバグを修正
    • 44100Hz, streo 以外のデータを再生時にエコーをかけると落ちるバグを修正
    • エコーをかけたときの音割れを起こりにくくした
Version 2.21β5_test20010821 (2001/08/21)
  • 演奏中にエコーをかける機能 (子供だましですが(^^ゞ)を試験的に搭載
    (機能するのはプラグインを使用して再生する形式のみ)
  • 液晶のスペアナの動きを修正
  • 演奏ルーチンを改良 (ほんの少しだけ軽くなった)
  • 圧縮ファイル内のデータの演奏終了直後に一時ファイルが削除できなかった場合
    (圧縮ファイル内の RealMedia を再生した場合にそうなる)は、しばらく待ってから
    削除するようにした (MIDI 再生で「Crescendo Forte LiveSynth」を使用した場合も
    同様の問題が発生しますが、こちらは未解決です)
Version 2.21β5_test20010818 (2001/08/18)
  • OggVorbis のコメントの取得に対応
  • SuperTagEditor にファイル名を渡すとき、複数のファイル名を一度に渡すように修正
    (ただし、KbSTE 0.00200α7_test20010818 でないと正常動作しない)
  • SuperTagEditor を起動するときに不正なファイル名を渡すことがあったのを修正
    (場合によっては落ちることもあったかもしれない)
  • WAVE Mapper 使用時に音量調節が出来なくなっていたバグを修正
  • Media エクスプローラツリービュー部分のフォルダの表示条件を修正
Version 2.21β4 (2001/08/15)
  • WindowsXP で Media エクスプローラが正常動作しない
    (「マイドキュメント」しか表示されない)のを修正
  • MSX のサウンド (MGS/MPK/BGM に対応)
    MGSDRV.COM, KINROU5.DRV, MPK.BIN, MPK103.BIN が必要です
    KBMSX.KPI と同じフォルダに置いて下さい
    http://www.gigamixonline.com/mgsdrv/ にあります。
  • MGS のタイトル読み込みに対応
  • KBDSHOW.KPI に関する以下のような修正
    • 対応する拡張子を INI ファイルで設定できるようにした
    • デフォルトでは拡張子 AC3 を認識しないようにした
      (再生したい場合は INI を書き換える必要があります)
  • KBVORBIS.KPI の OggVorbis デコーダを最新のものに差し替え
  • KBUNARC.DLL に関する以下のような修正
    • GCA SDK を最新版 (v0.9g)に差し替え
    • SOLID 形式で圧縮されていて、格納ファイル名が非常に
      長い GCA を展開すると落ちるバグを修正
  • 細かいバグを修正
  • 内部的な修正
Version 2.21β3 (2001/08/12)
  • 拡張形式の M3U での保存が正しく動作しなくなっていたバグを修正
    (曲の長さとタイトルの間に , が入っていない)
  • KBMAC.KPI を更新
  • 内部的な修正
Version 2.21β2 (2001/08/11)
  • Media エクスプローラで圧縮ファイルと非圧縮ファイルが混在する
    フォルダを選択すると落ちることがあるバグを修正
  • ホットキーが有効になっているときに Ctrl+Shift+K を押しても
    アクティブにならないことがあったバグを修正
  • 「プラグイン情報」でプラグインと同じフォルダにあるドキュメントファイルの
    読み込みを強化 (ファイル名が一致しないものも読み込んで表示するようにした)
  • 内部的な修正 (色々いじくり回したので不安定になったかも)
Version 2.21β (2001/07/27)
  • SWF 再生時に「単曲リピート」が有効になっている場合は
    演奏終了を検出しないようにした
    (演奏終了の検出処理がうまく機能しないデータを正常に 再生できるようになります)
Version 2.20 (2001/07/25)
  • Media エクスプローラで圧縮ファイル内データのタイトルを取得することが
    出来なかったり、取得時に落ちる可能性があったのを修正
  • RMX のタイトルを取得できていなかったのを修正
  • KBSWF.DLL を修正 (謎の右クリックメニューを表示していたのを修正(^^ゞ)
  • 細かい修正
Version 2.20β16 (2001/07/22)
  • SWF の演奏時間取得がある程度正確になった (完璧ではない)
  • Macomedia Flash Player がインストールされていない環境で
    SWF を開くと落ちるのを修正
  • VivoActive Player がインストールされていない環境で VIV を開くと落ちるのを修正
Version 2.20β16_test20010722 (2001/07/22)
  • SWF の演奏終了の検出の方法を修正 (正常に再生できるデータが増えた)
  • VivoActive(*.VIV) に対応 (VivoActive Player が必要)
  • KBMOV.DLL/KBSWF.DLL/KBVIV.DLL のインターフェースを変更
  • ある条件で無限ループに陥って固まることがあるバグを修正
Version 2.20β16_test20010721 (2001/07/21)
  • SWF の再生に関する以下のような修正
    • 再生方式を変更 (Macromedia Flash Player の機能を使うようにした)
    • 今まで正常に再生できなかった SWF のいくつかが再生できるようになった
    • データによってはブラウザを起動しまくって OS が落ちることがある不具合が
      発生しにくくなった (残念ながら完全に解決したとは言えません)
    • 演奏終了を検出できるようになった (一部のデータで正しく機能しないことがあります)
    • 演奏時間の取得が出来なくなった
      (表示する演奏時間はフレーム数で、1フレームを 1秒と見なした値になる)
    • 演奏中に動的にサイズ変更できなくなった (演奏開始ボタン右側の▼で変更可能)
    • 音量の調節と再生速度の変更ができなくなった
Version 2.20β16_test20010719 (2001/07/19)
  • Shockwave Flash(SWF) に対応 (QuickTime が必要)
    ただし、以下のような問題点があります
    • 一部のデータで音が鳴らない
    • 演奏終了を検出できない
    • 画像部分のクリックが出来ない
Version 2.20β15 (2001/07/18)
  • シークバーのつまみ以外の部分をクリックした場合は、
    クリックした位置に直ちにシークするようにした
  • テンキーの 7 と 9 でシーク出来るようにした (それぞれ 5 秒戻す、5 秒進む)
  • 音源判別に関する以下のような修正
    • タイトルから MU500/1000/2000 を判定するようにした
    • タイトルに "8820" が含まれている場合は SC-8850 と見なすようにした
    • XG の音源判別を強化 (MU500/1000/2000 の判別に対応)
    • 音源リセットが含まれていないデータでの音源判別率が向上
    • Korg 系音源でないのに Korg と誤判定する確率が下がった
      (Korg なのに Korg と判定できない確率が上がった)
  • 「MIDIデバイス設定」の「演奏開始前に送信するリセット系SysEx」で
    「XG SYSTEM ON」が選択されている場合に正しく動作しないのを修正
Version 2.20β14 (2001/07/12)
  • 音色から GS の音源を判別する処理が正しく動作しなくなっていたのを修正
  • 起動時のコマンドラインや DDE にショートファイル名を渡すと落ちるバグを修正
Version 2.20β13 (2001/07/10)
  • XG の音源判別率がかなり向上
    (XG の音色表を提供して下さった Saison Sei さんに感謝！)
  • 起動時のコマンドライン引数に /tray が指定されている場合、
    タスクトレイに入る前に一瞬ウィンドウが表示されていたのを修正
  • 起動時のコマンドラインに /a /na /p /np が明示的に指定されていない場合や、
    実行ファイルのアイコンにドラッグアンドドロップしたときの動作を KbMedia Player の
    ウィンドウにドラッグアンドドロップしたときの動作と同じにした
Version 2.20β12 (2001/07/08)
  • 起動時にレジストリの
    HKEY_CURRENT_USER\Software\Kobarin's Soft\KbMIDI Player\SearchPath\Kbmplay
    に KbMedia Player の実行ファイルのパスを記述するようにした
    (外部アプリから制御したいときに実行ファイルの場所を自動認識できるようにするため)
  • 起動済み Mutex オブジェクトの名称を "KbMIDI Player" から "KbMedia Player" に変更
  • DDE に関する以下のような修正
    • サービス名・トピック名を "KbMIDI Player" から "KbMedia Player" に変更
    • XTYP_EXECUTE に関する以下のような修正
      • /seek の仕様を以下のように変更
        • 単位のデフォルトは秒 (小数点も使用可能)
        • h:m:s 形式、ms 単位、s(秒)単位を受け付けるようにした
        • 例：/seek:1:35 /seek:95 /seek:95s /seek:95000ms
          /seek:1:35.75 /seek:95.75 /seek:95.75s /seek:95750ms
      • /fadeout でフェードアウト時間を指定できるようにした
        (書式は /seek と同じ。省略した場合はプレイヤーの設定に依存
        今のところ、MIDI のフェードアウト時間指定は無視される)
      • １ファイルに複数曲含むデータを渡したときの動作を修正
      • /play と /p の処理を区別するようにした (/play は常に最初から演奏開始、
        /p は演奏中の場合は何もしない。/play は /stop /p と同じ)
    • XTYP_REQUEST に関する以下のような修正
      • 旧バージョンで使用していたコマンドをすべて廃止
      • 大文字と小文字を区別しないようにした
      • 戻り値はすべて文字列 (終端の \0 を含む) とする
      • FileName を追加 (再生中のサウンドのファイル名を返す)
      • ListFileName を追加 (開いているリストファイルのファイル名を返す)
      • ListCount を追加 (リストに登録されている曲数を返す)
      • SupportExt を追加 (対応するサウンドの拡張子を返す。ピリオドを含む。
        拡張子の区切り文字はセミコロン ; とする)
      • SupportArc を追加
        (対応するアーカイブ形式の拡張子書式は SupportExt と同じ)
      • Artist を追加 (再生中のデータのアーティストを返す)
      • Length を追加 (再生中のデータの曲の長さを返す。単位はミリ秒、
        長さがわからない場合は -1 を返す)
      • Position を追加 (再生位置をミリ秒単位で返す)
      • Status を追加。戻り値は
        • Playing (演奏中)
        • Stop (演奏停止)
        • Pause (一時停止)
        • Seeking (シーク中)
      • ExeName を追加 (KbMedia Player が置かれているパス
        (実行ファイル名を含むフルパス)を返す)
      • Version を追加 (KbMedia Player のバージョンを返す)
  • １ファイルに複数の曲を含むデータをドラッグアンドドロップしたときの動作を修正
  • 細かい修正
Version 2.20β11 (2001/06/26)
  • Windows95 で起動できなくなっていたのを修正
  • 細かい修正
Version 2.20β10 (2001/06/24)
  • MIDI 以外と NeoWRD の同期再生に対応
  • nwdll.dll がないと起動できなかったのを修正
  • 演奏リストファイル (*.KBM) の仕様を変更
    (NeoWRD に対応、旧バージョンとの互換性はあります)
  • Monkey's Audio の APETag の取得に対応
  • kbmac.kpi を最新のもの (Monkey's Audio SDK 3.89 ベース) に差し替え
  • kbvorbis.kpi を最新のもの (1.00RC1 ベース) に差し替え
Version 2.20β9 (2001/06/22)
  • NeoWRD に対応
  • 「waveIn による波形取得を行わない」の設定に関わらず動画やFPD等を
    再生時にスペアナが表示されなくなっていたバグを修正
  • 液晶表示のスレッドで「Error! in LCD Thread」というダイアログを表示して
    落ちることがあったのを修正(？)
Version 2.20β8a (2001/06/18)
  • WinNT 系で環境設定画面の検索パス指定の「参照」ボタンが正しく
    機能しなくなっていたのを修正
Version 2.20β8 (2001/06/18)
  • Win9x 系でまともに動作していなかった (プラグインを認識できないなど) のを修正
  • QuickTime (QuickTime Music Synthesizer) と RealPlayer の MIDIプラグイン
    (Crescendo Forte LiveSynth) の機能を使って MIDI を再生できるようにした
    (それぞれ MIDI デバイスのテンプレートの 9番目と 10番目)
  • TAG ファイル付きでループ指定がある 1ファイル複数曲データをリストに追加した
    直後の曲の長さの表示が正しくないのを修正
  • Media エクスプローラのツリービューの自動更新時に落ちることがあるバグを修正
Version 2.20β7 (2001/06/17)
  • kbunarc.dll で解凍できるアーカイブのサイズ制限が 8MB 以下
    (RAR/CAB/GCA は合計が16MB以下)までだったのを、搭載されている
    物理メモリの 1/4 以下で 2 の整数乗になるような最大値まで扱えるようにした
    • サイズ制限は圧縮ファイル自体のサイズではなく、解凍後のサイズ
      (RAR/CAB/GCA の場合は圧縮ファイルを全部解凍したとした場合の
      解凍後の合計サイズ)の制限
    • 例えば、搭載メモリが 128 MB なら 32MB まで解凍可能、
      搭載メモリが 384MB なら 64MB まで解凍可能)
    • 搭載メモリが 64MB 未満でも 16MB までは解凍可能
      (メモリを確保できなかった場合は強制終了 (ぉぃ))
    • 搭載メモリがどんなに大きくても、128MB までしか解凍できない。
    • サイズ制限の範囲外のアーカイブの解凍結果は保証されない
  • ロードした kbunarc.dll に互換性がないときに落ちるのを修正
  • 圧縮ファイル内のサウンドを再生できないことがあったのを今度こそ修正
    (FMP/PMD など、外部ファイルを必要とするもの)
  • ファイル名の長さが MAX_PATH(=260)バイトを超えるファイルを正しく
    扱えないのを修正 (全部は修正しきれていないかも)
Version 2.20β6 (2001/06/11)
  • M_NEZ.KPI を最新のものに差し替え
  • キーボードのテンキーで演奏開始や音量調節、曲の切り替えが出来るようにした
    操作は以下の通り
    • 2:音量-5
    • 4:前の曲
    • 5:演奏開始
    • 6:次の曲
    • 8:音量+5
  • 小型化状態のときにキーボード操作の Alt+→ や Ctrl+P 等が効かなかったのを修正
  • MIDI (GS) の音源判別率が向上 (音色も調べるようにした)
  • NSF/GBS/SID のタイトル取得に対応
  • UMUT.DLL を Kbmplay.exe と同じフォルダにあるものしかロードしないようにした
    (Windows システムフォルダにあるものをロードするとなぜか不正終了するため)
  • データによってはアルトラマリンの再生が止まらないことがあるのを修正
  • RMJ を再生できなくなっていたバグを修正
  • S98 のタイトルを取得できないことがあったバグを修正
  • 圧縮されていない１ファイル複数曲データ (SAP など)のタイトル情報を
    表示できていなかった (液晶右側の情報表示部など) のを修正
  • 圧縮ファイル内の *.TAG 付きデータのタイトルを
    取得できないことがあったバグを修正
  • 拡張子 NEO を ZIP と同じものとして扱うようにした
    (NeoWRD に対応したわけではない)
Version 2.20β5 (2001/06/05)
  • アルトラマリン(*.UM) に対応 (UMUT.DLL が必要)
  • 圧縮ファイル内のサウンドを再生できないことがあったのを修正
    (FMP/PMD など、外部ファイルを必要とするもの)
  • 一部の FPD (ヘッダが FPDM なもの)のタイトル取得に FPD98.DLL を
    使わないようにした (圧縮ファイル内の FPD のタイトル取得が高速化)
  • ZMS/ZMD のタイトルを正しく取得できないことがあったのを修正
  • EUP のタイトル取得に対応 (EUP 再生のプラグインは別途入手する
    必要がありますが、現在ではおそらく入手不可能です (ぉ )
Version 2.20β4 (2001/06/03)
  • バージョン情報ダイアログの URL と動作確認済みバージョン等を修正
  • M_NEZ.KPI を最新版(010531) に差し替え
  • 細かい修正
Version 2.20β3 (2001/05/17)
  • 曲の先頭に GM SYSTEM ON が含まれていて、かつ GS RESET や
    SYSTEM MODE SET が含まれていない MIDI データで強制マップ切り替え
    (「Force 55/88/88Pro/8850 MAP」) が機能していなかったのを修正
  • 圧縮ファイル内のデータにタイムタグ付き歌詞が含まれる場合、
    「ドキュメント」を正しく表示できないバグを修正
  • タイムタグ付き歌詞の読み込み時に落ちることがあるバグを修正
Version 2.20β2 (2001/05/15)
  • MIDI でシーク中のシークバーの動作が変だったのを修正
  • 歌詞の検索パス指定が正しく処理できないことがあるバグを今度こそ修正
    (2.49 で修正し忘れた個所があった)
  • M3U 形式での保存時に圧縮ファイル内のデータの存在チェックが
    機能していなかったのを修正
  • M3U 形式での保存が出来なくなっていた (作成されたファイルが
    空っぽになっている) のを修正
  • 演奏リストがアクティブになっていると Alt+F4 で終了できないバグを修正
  • 演奏リストで Ctrl+A で全選択ができなくなっていたバグを修正
Version 2.20β (2001/05/09)
  • コンパイラを Borland C++ Builder5 に変更
  • M_NEZ.KPI を最新版 (Version 010506) に差し替え
  • 演奏リストに関する以下のような修正
    • 演奏リストの読み込みと破棄が大幅に高速化
    • 「タイトル」カラムと「アーティスト」カラムの区切り部分をダブルクリックしたときの
      カラム幅自動調整機能が正しく機能していなかった (少し狭くなっていた) のを修正
    • 演奏リストへの重複登録抑制のためのルーチン (ちょっと重い) を必要以上に
      呼び出していたのを修正 (追加処理が少し高速になった)
    • 起動直後のカラム幅が前回終了時の幅にならないことがあったのを修正
  • タスクトレイに関する以下のような修正
    • タスクトレイをダブルクリックすると、タスクバーの領域にメニューの残骸が
      残ることがあったのを修正 (OS のバグ？)
    • メインウィンドウが表示されている状態でタスクトレイを操作したときは
      「最小化」が出来るようにした
  • 音楽CD 再生時、一時停止から再開しようとしても再開されないことがあったのを修正
  • 「環境設定」の「検索パス」の設定画面の動作を修正
  • Ctrl や Shift を押しながらツリーのアイテムをダブルクリックしたときに
    リストに追加しないようにした。
  • Media エクスプローラで「サブフォルダ内のデータを検索」のチェックが有効だと、
    フォルダをダブルクリックしてもツリー部分で移動できなかったのを修正
  • 歌詞ファイルの検索パス指定が正しく機能しないことがあったバグを修正
  • ヘルプを起動すると終了時に落ちることがあるバグを今度こそ修正(？)
  • ヘルプとの連携で htmlhelp.dll を必要としなくなった
Version 2.11a (2001/04/28)
  • 本体は変更なし (日付とバージョン番号のみ修正)
  • KBMAC.KPI を Monkey's Audio SDK 3.88 ベースのものに差し替え
Version 2.11 (2001/04/21)
  • 単曲リピート時や単曲演奏時 (リストに追加しないで演奏時)は
    メドレー再生の設定を無視するようにした
  • M_NEZ.KPI を最新版 (Version 010416) に差し替え
Version 2.10 (2001/04/16)
  • KBSPC.KPI に関する以下のような修正
  • ENVX読み取りの修正 (パネルでポン、モンスタニア)
  • M_NEZ.KPI を最新版 (Version 010414) に差し替え
  • 別ウィンドウで Media エクスプローラを開いてからウィンドウを閉じた後に
    Mediaエクスプローラを操作すると落ちることがあるバグを修正
  • DDE で１ファイル複数曲 (NSF など)を開いたときの動作を修正
  • 曲の長さが TAG ファイルに記述されていて、
    フェードアウト時間が 0 であるような NSF 等を再生したとき、
    曲の最後の１秒程度が再生されていなかったのを修正
  • Media エクスプローラで TAG ファイルを含む 1ファイル複数曲のデータ
    (圧縮されていないもの) の一覧表示が高速化 (今までが遅すぎた)
  • 圧縮ファイル内のデータのタイトル読み込み時に必要以上に大きな
    メモリを確保していたのを修正
Version 2.09 (2001/04/14)
  • 本体は test20010414 とほとんど同じ (バージョン番号と日付の更新のみ)
  • Mamiya さん制作の m_nez.kpi を最新版(Version 010412)に差し替え。これにより、
    • ゲームボーイのサウンド (GBR/GBS) に対応
    • PC エンジンのサウンド (HES) に対応
  • Mamiya さん制作の m_s98.kpi を最新版(Version 010409) に差し替え
Version 2.09β_test20010414 (2001/04/14)
  • DDE の XTYP_REQUEST の GetSupportExt でサポートする拡張子を
    取得できるようにした (拡張子の区切りは \0 で、終端は２つの \0 で終わるような
    文字列、例えば ".MID\0.MP3\0.WMA\0\0" のような文字列を返す)
  • ヘルプを起動すると終了時に落ちるのを今度こそ修正(？)
Version 2.09β_test20010412 (2001/04/12)
  • KBSPC.KPI に関する修正 (詳しくはプラグインに同梱のドキュメントを参照)
  • 「プレイリスト作成・コンバータ」に関する以下のような修正
    • メニュー項目名を「PlS/TAG ファイル作成」に変更
    • ユーザーインターフェースを修正
    • PLS/TAG の作成処理中はアプリケーションを終了できないようにした
    • PLS/TAG の作成処理中でも PLS→TAG の変換が出来るようにした
    • 起動するとエクスプロ－ラも起動していたのを修正
    • PLS を読み書きするとき、NSF 以外の曲番号指定は 0 ベースとして扱うようにした
  • その他細かい修正
Version 2.09β_test20010407_2 (2001/04/07)
  • GBR/GBS/HES/PCE を 1ファイル複数曲として扱うようにした
    (GBR/GBS はゲームボーイのサウンド、HES/PCE は PCエンジンのサウンド)
Version 2.09β_test20010407 (2001/04/07)
  • 別ウィンドウで開く Media エクスプローラに関する以下のような修正
    • ウィンドウを閉じた場合はメモリを解放するようにした
    • 本体を最小化しても連動して最小化されないようにした
    • バーでのウィンドウの切り替えが出来るようにした
    • ツリービュー部分から演奏リストにドラッグアンドドロップした場合は
      リストに追加するようにした (Windows エクスプローラ上からドラッグアンドドロップ
      したときと動作を合わせるようにしなければ…)
    • タイトルの一覧表示の最中に終了させようとすると落ちるバグを修正
  • PVI の検索パスが指定されていないときに FMP/PMD を開くと落ちるバグを修正
  • 「未再生の曲だけ再生」のチェックを反転させると「連続再生」に戻ってしまうのを修正
  • 「環境設定」の「検索パス」で「初期設定に戻す」を押したとき、cdplayer.ini の
    パスが初期設定に戻らないのを修正
  • その他色々細かい修正
Version 2.09β_test20010405 (2001/04/05)
  • メインメニューとMedia エクスプローラと演奏リストの右クリックメニューを
    色々修正 (項目名を出来るだけ簡潔に)
  • 演奏リストからエクスプローラや STE を起動出来るようにした
  • 演奏リストで選択されている曲があるフォルダに Media エクスプローラ上で
    移動できるようにした
  • 演奏リストに登録されている曲のうち、曲長計算がまだ終わっていないものが
    あった場合はステータスバーの総演奏時間の部分に '+' を付加するようにした
  • hhctrl.ocx を直接 LoadLibrary して HtmlHelpA を GetProcAddress する方法
    ではヘルプとの連携が不安定 (終了時に不正終了することがある) なようなので、
    ヘルプを呼び出すための DLL を VC++ で作成 (htmlhelp.dll) してそれを
    ロードするようにした (BCB3 で HtmlHelp 関数とリンクする方法がわからない)
  • DirectSound 使用時にシークや一時停止／再開をすると再生速度が変わって
    しまうことがあるのを修正(？)
  • KBAAC.KPI のエラーチェックを強化
    (ファイルが存在しないときに不正終了していたバグなどを修正)
  • Media エクスプローラと演奏リストで、１ファイルに複数曲含むデータの
    一覧表示が高速化 (数が多い場合)
Version 2.08 (2001/04/03)
  • 演奏リストに重複する曲を追加すると再生済み情報が失われるのを修正
  • ファイルのオープンに失敗したときに表示されるダイアログで「キャンセル」を
    選択した場合はヘルプを開くようにした
Version 2.07β9_test20010402 (2001/04/02)
  • KBFMP.KPI/KBPMD.KPI で、PVI の検索パス指定に対応
  • 無限ループする曲 (SPC など)で演奏を打ち切るときの
    フェードアウト時間が 1 秒になっていたのを修正
  • 無限ループする曲で演奏を打ち切るときのフェードアウト開始時刻の
    算出方法を修正 (デコードしたサンプル数を元に算出するようにした)
  • ヘルプを起動すると落ちることがあるバグを修正 (呼び出し規約が間違っていた)
  • 一度でもヘルプを起動すると終了時に落ちることがあるのを修正(？)
    (↑とは別件だが原因がいまいちわからないので本当に直ってるかどうかは不明…)
  • ヘルプとの連携が動作しないことがあるバグを修正
  • 演奏リストの「曲の長さ」カラムを「長さ」に変更
  • KBUNARC.DLL の GCA 解凍ルーチンを GCA SDK 0.9f2 に差し替え
KbMedia Player Version 2.07β9_test20010331
  • Mediaエクスプローラと演奏リストの右クリックメニューに関する色々な修正
  • 演奏リストのカラムの表示順序を変更 (「ファイル名」を一番最後にした)
  • 演奏リストのチェックボックスの意味を 2.07β6 以前 (「再生済み」のときに
    チェックを入れる)に戻した (これで確定したわけではないです)
  • データによっては「音程を変えずに速度x2.0」すると落ちることがあるバグを修正
    (未確認。該当データを再生しても多分落ちなくなると思いますが、
    再生結果はひどいことになると思います(^^;)
  • 起動直後の液晶のサイズが極小のとき、液晶の上部と下部にゴミが
    表示されることがあるのを修正(？)
Version 2.07β8 (2001/03/30)
  • 演奏リストに関する以下のような修正
    • 「未再生の曲だけ再生」を「チェックされている曲だけ再生」に変更
    • 「選択アイテムをチェック」と「選択アイテムのチェックを解除」を追加 (必要ない？)
    • 「プロパティ」を追加
    • 曲長計算に関する設定をサブメニューに移動
    • 「リピート」が有効な場合はリストを循環させるようにした
      (最後の曲を選択時に「次の曲」を選んだ場合は先頭に移動するなど)
  • RealMedia 再生時、ドライバによっては強制的に音量が 0 にされてしまう
    不具合の対策のための設定を追加
    (チェックを有効にすると、RealMedia 関係のデータを再生する度に
    「ボリュームコントロール」の WAVE の音量が最大になる)
  • 動画やFPD、音楽CD を再生時のスペアナ表示のルーチンがまずかったのを修正
  • ファイル名が同じものが２つ以上格納されているようなアーカイブを開くと
    無限ループ状態に陥るのを修正
  • OggVorbis のシーク時にフリーズすることがあったのを修正
    (旧バージョンの kbvorbis.kpi でシーク時にフリーズしてしまうようなデータでは
    新バージョンでもシークできない)
  • バージョン情報ダイアログに「mp3infp」を追加
  • 歌詞ファイルの読み込みで落ちることがあったバグを修正
    (@TimeRatio がついているもの)
  • DirectX5 未満の環境で DirectSound が使えなくなっていたのを修正
  • その他細かい修正
Version 2.07β7 (2001/03/27)
  • 演奏リストに関する以下のような修正
    • チェックマークの意味を逆にした
      (チェックが入っているときの意味を「再生が完了」から「未再生」に変更)
    • 連続再生のモードに「未再生の曲だけ再生」を追加
      (チェックが入っているものだけ再生する)
    • ステータスバーの情報表示を強化
      (リストに登録されている曲数と総演奏時間、連続再生のモードを表示)
  • WaveMapper/DirectSound 切り替えと MIDI デバイス切り替えを「演奏」メニューから
    「ツール」メニューに移動 (「演奏」メニューが大きくなりすぎたため)
  • Media エクスプローラで、圧縮ファイル内の MP3 等のタグ情報は解凍後のサイズが
    1MB 以下のものだけ取得するようにした
Version 2.07β7_test20010325 (2001/03/25)
  • PVI/PDX/cdplayer.ini のパスを指定できるようにした
    (PVI の検索パス指定はまだ機能していない)
  • ツールバーの「WRD」ボタンを廃止し、代わりに「プロパティ」を追加
  • 環境設定に以下の設定項目を追加
    • F0 43 10 4C 00 00 7F 00 F7 無視
      (Windows2000+YMF7x4 のサウンドカードでMIDI 再生時にこの SysEx を
      送信すると OS が落ちる現象を回避するための設定。
      チェックが入っていると、データによっては正しく再生されなくなる)
    • waveOutGetPosition を使わない
      (WaveMapper 使用時に MP3 等を再生しているとき、
      再生位置取得にこの API を使うと一部のサウンドカードで
      動作が不安定になるのを回避するための設定。
      waveOutGetPosition を使った方が再生位置取得は正確になる
      DirectSound 使用時はこの設定は無視される)
    • waveIn による波形取得を行わない
      (チェックを外すと動画、FPD、音楽 CD 等でスペアナを表示出来るかもしれないが、
      ドライバによっては動作が重くなるだけでスペアナは表示できず、
      最悪の場合動作が不安定になる)
    • WAVE系を再生時はMIDIデバイスを閉じる
      (MP3等のWAVE系サウンドを再生中にMIDIデバイスを閉じるようにする。
      チェックを外すと MIDI←→WAVE系 への曲の切り替えがスムーズになるが、
      MIDI デバイスがソフトウェア音源だった場合に
      MIDI←→WAVE系 への曲の切り替えが不安定になることがある)
    • WaveMapper使用時はクロスフェード無効
  • メインメニューに関する以下のような修正。
    • 「オプション」を廃止して「ツール」に移動
    • 「ツール」メニューに以下の項目を追加
      • ボリュームコントロール起動
      • cdplayer.ini を開く
      • 歌詞フォルダを開く (演奏中のデータに対応する歌詞ファイルが存在する
        場合は、歌詞ファイルが存在するフォルダを開く。存在しない場合は
        「歌詞の検索パス」で指定されているフォルダを開く)
  • レジストリの設定に関わらず「高度な設定」が出来るようにした
    (大して高度ではないため)
  • kbvorbis.kpi に関する以下のような修正
    • 演奏開始直後や再生位置 0 にシークしたときに落ちる可能性があったのを修正
    • タグ情報取得が大幅に高速化
Version 2.07β7_test20010323 (2001/03/23)
  • 以下の設定項目を追加
    • クロスフェードに関する設定 (フェードイン時間、フェードアウト時間等)
    • メドレー再生の演奏時間
    • SPC などで曲の長さがわからないときのデフォルトの曲の長さ
  • ノンストップ CD をエンコードしたデータの連続再生のための再生モードを追加
    (演奏リストの「ノンストップ再生」) # いまいちなので正式に対応するかどうかは未定
  • MIDI 再生時 F0 43 10 4C 00 00 7F 00 F7 を無視するようにした
    (設定出来るようにする予定)
  • 「midiOutReset を使う」のオプションが無効になっている場合、All Note Off や
    All Sound Off を受信しない音源のための対策コードを実行しないようにした
    (シークや曲の切り替えが高速化)
  • 状況依存ヘルプで WinHelp と連動していたのを HTML ヘルプと連動するように変更
  • 演奏リストで Alt を押しながらダブルクリック or Enter を押した場合は選択されている
    曲のプロパティを表示するようにした
  • 演奏リストに ::AudioCD::#### を追加すると落ちる可能性があったのを修正
  • MOD の音量倍率を４倍に出来なかったバグを修正
Version 2.07β6 (2001/03/20)
  • Media エクスプローラで前回終了時に CD ドライブを選択していると、
    次回起動時に落ちるバグを修正 (Windows2000 では問題なし)
  • 「お気に入り」から CD ドライブにアクセスしようとすると落ちるバグを修正
    (Windows2000 では問題なし)
  • Media エクスプローラでの *.CDA のタイトル取得が高速化
  • 演奏リストに音楽CD のデータを追加したとき、直ちに曲長が表示されるようになった
  • TwinVQ のタグ情報を正しく取得できないことがあるバグを修正
  • メモリリークしていたのを修正
Version 2.07β5 (2001/03/19)
  • 音楽 CD に対応 (CD-Extra, Mixed-Mode CD にも対応)
  • ヘッダ部分が "LiQT" な LiquidAudio を再生出来なかったのを修正
  • 暗号化された GCA を開くと落ちるバグを修正
  • 再生形式と液晶の色の対応関係を修正
Version 2.07β4 (2001/03/08)
  • MIDI 再生時のエラーチェックを強化。
  • KbSTE (MERCURY さん制作の SuperTagEditor Version 2.00β4 を
    Kobarin が改造したもの)を Media エクスプローラ上で起動できるようにした。

Version 2.07β3 (2001/03/05)
  • OggVorbis デコーダ(KBVORBIS.KPI)を libvorbis 1.0beta4 ベースのものに差し替え
  • UTF-8 形式で埋め込まれた OggVorbis のタグ情報を正しく取得できるようにした
  • KBMAC.KPI を Monkey's Audio 3.85b2 SDK ベースのものに差し替え
  • 動画を再生時に別の動画に切り替えるとき、動画ウィンドウが消えた後に
    一瞬再表示されることがあるのを修正
  • 動画ウィンドウの「常に手前に表示」の設定が再生する度に失われてしまうバグを修正
Version 2.07β2 (2001/03/01)
  • MIDI を再生時、AllNoteOff/AllSoundOff を受信しない音源への
    対策コードが無効になっていたのを修正
  • MIDI を再生時、音源リセット送信後のウェイト時間が短くなっていたのを修正
  • RIFF SIF の情報を正しく取得できないことがあるバグを修正
  • MML2MID を起動するとき、コマンドラインスイッチに -w を指定するようにした
Version 2.07β (2001/02/26)
  • MPG のようにタグ情報を記述できないサウンドファイル形式にもタグ情報を
    記述する規格をでっちあげて対応 (情報の記述は別ファイルに行う)
  • mp3infp 2.00 Alpha5 以降に対応
    • mp3infp 2.00 Alpha5 以降を導入すれば、ID3v2 タグの詳細情報の表示や
      書き換えなどが出来るようになります
  • 1ファイル複数曲 (NSF など) の扱いに関する以下のような修正
    • Media エクスプローラツリー部分でフォルダのように表示するようにした
      (圧縮ファイル内のデータは除く)
    • Media エクスプローラやプレイリストに表示するとき、1ファイル 1アイテム
      だったのを 1曲 1アイテムで表示するようにした
    • 同じファイル内の異なる曲への切り替えでクロスフェードすることが
      出来るようになった
  • MIDI Stream (MDS) に対応
  • 以下のような特殊な MIDI 形式に対応 (動作保証は一切しません)
    • Z-MUSIC 形式 (ZMS/ZMD)に対応。ただし、
      • ZMD の再生には ZMC2.EXE or ZMC3.EXE が必要
        (両方ある場合は ZMC3.EXE を優先)
      • ZMS の再生には上記に加えてさらに ZtoM.EXE or Z2M3.EXE が必要
        (両方ある場合は Z2M3.EXE を優先)
      • 再生できるのは MIDI のみ
    • BALLADE 形式 (SNG)に対応
      • SNG2S.EXE が必要です
    • Music Macro Language (MML) に対応
      • MML2MID.EXE：Win32 コンソール版が必要です。
        16bit DOS 版や GUI 版では多分動作しません。
      • MML2MID.EXE で MID 形式に変換出来るものしか再生出来ません。
    • CVS.EXE がある場合は RCP/R36→MID への変換に CVS.EXE を使うようにした
      • RCPCV.DLL では正常に再生出来ないものが再生できるようになります
    • ZMC2.EXE/ZMC3.EXE/ZtoM.EXE/Z2M3.EXE/SNG2S.EXE/
      MML2MID.EXE/CVS.EXE は Kbmplay.exe と同じフォルダに置く必要があります。
    • これらの形式の再生は動作保証外です。必要なソフトはご自分でお探し下さい。
      ソフトをお持ちでない方は、探してまで導入するメリットはないです。
      (CVS.EXE はあった方がいいかもしれませんが)
  • メドレー再生時の選曲の方法をランダム (一度再生したものも再生することがある)
    からシャッフル (一度再生したものは再生しない)に変更
  • 歌詞の検索パスで見つかった TXT/LRC にタイムタグがついていない場合でも
    「ドキュメント」に表示するようにした
  • マルチメディア圧縮された RAR を正しく解凍できないバグを修正
  • 動画のウィンドウサイズの設定を正しく読み込んでいなかったバグを修正
Version 2.06a (2001/02/07)
  • 液晶が見えなくなることがあったのを修正 (今度こそ直ったはず)
  • クロスフェード時のフェードイン時間を調整 (4 秒→2 秒に変更
    そのうち設定出来るようにする予定です)
  • Media エクスプローラの設定が「圧縮ファイル：検索しない」や
    「圧縮ファイル：LZH/ZIP のみ検索」になっているとき、Media エクスプローラ
    リストビュー部分で無駄に圧縮ファイルを開いていた＆圧縮ファイルの
    「タイトル」部分の表示が 「********」にならないことがあったのを修正
  • Media エクスプローラでフォルダや圧縮ファイルの「種類」の表示が変だったのを修正
Version 2.06 (2001/02/06)
  • KBSPC.KPI に関する以下のような修正
    • SPC の ID666 に曲の長さが記述されていて、かつフェードアウト時間が
      0 ms の場合は、指定された時間が経過したらフェードアウトしないで直ちに
      演奏終了するようにした
    • 気休め程度最適化
    • KBSPC.KPI と同じフォルダにある KBSPC.INI に SPNSupport=1 を記述した
      場合は SP1,SP2,…,SP9 も再生できるようにした
  • 再生できない MP3 があったのを修正
  • GCA SDK の不具合が修正されたので、再度 GCA に対応
  • 「ファイル」メニューに「プロパティ」、「マルチメディアのプロパティ」、
    「ボリュームコントロール」を追加
  • Media エクスプローラと演奏リストのソート時の動作を修正
  • 「リピート」が無効なときにシャッフル再生ですべての曲を演奏し終わった場合に
    連続再生が終わらなかった (すべてのチェックマークを外して次の曲の再生が
    始まっていた) のを修正
  • FPD 再生時のシステムエフェクトの設定でリバーブ・コーラスが無効に
    なっていたのを修正
  • 液晶のサイズが「大」より小さいとき、情報表示部のビットマップの左端が
    表示されていなかったバグを修正
  • 情報表示部をスクロールするとボリューム値のボタンもスクロールされてしまう
    バグを修正
  • 液晶とボリューム調節のトラックバーが見えなくなってしまうことがあるバグを修正
  • Media エクスプローラに関する以下のような修正
    • 設定の保存場所を変更。
    • ツリー部分で選択アイテムが変更されてからリスト部分に反映されるまで
      一定時間のウェイトを置くようにした (フロッピーディスクドライブが選択された場合に
      ドライブアクセスが起こりにくくするため)
    • リストビュー部分で一部のアイコンが正常に表示されないことがあったのを修正
      (「My Pictures」、「近くのコンピュータ」など)
    • ツリーの自動更新のために CD ドライブを監視するのをやめた
  • Media エクスプローラリストビュー部分のソート情報を保存するようにした
  • DirectSound 使用時のシークと再生速度変更のレスポンスが向上
  • FMP/PMD のタイトル読み込み時に落ちる可能性があったのを修正
  • 「終了時にクロスフェード」が有効なときに「リストに追加しないで再生」すると
    演奏終了の約 5秒前でシークバーが止まってしまうバグを修正
  • 1ファイルに複数曲含むプレイリスト (M3U/PLS) の読み込みに対応
  • 1ファイルに複数曲含むデータを「リストに追加しないで再生」したとき、
    演奏が終わったら (同じファイルの) 次の曲に切り替わるようにした
  • WaveMapper 使用時の再生位置取得に waveOutGetPosition を使用しないようにした
    (ドライバによっては不具合が発生するため)
  • SAP のタグ情報の取得に対応
  • 拡張子 RGM/RSN を RAR と同じものとして扱うようにした
  • タイトルがスペースだけのときにデフォルトのタイトル ([ファイル名])を
    表示せずに空文字列を表示していたのを修正
Version 2.05 (2001/01/22)
  • Media エクスプローラで圧縮ファイル内の MP3、OggVorbis 等のタイトルを
    取得できるようにした (ただし、サイズが 8MB 未満のもののみ)
  • 歌詞の検索パスを指定していると「最新の情報に更新」したときや終了時に
    フリーズすることがあるバグを修正
  • KBFMP.KPI を更新
    (2001/01/21公開の WINFMP.DLL 0.03 以降がないと動作しません)
  • KBPMD.KPI を更新
    (2001/01/21公開の PMDWIN.DLL 0.17 以降がないと動作しません)
  • 情報表示を以下のように強化
    • 再生周波数、量子化ビット数、チャンネル数、動画のサイズの表示
      (ただし、ASF/WMV/QT/MOV/LQT の再生周波数、量子化ビット数、
      チャンネル数の取得は不可)
    • TwinVQ のタグ情報を正しく読み込めないことがあるバグを修正
    • AVI のタグ情報取得に対応
    • GYM のタグ情報取得に対応
    • UNICODE 形式で文字列が埋め込まれた ID3v2 タグを読み込むと落ちるバグを修正
Version 2.04 (2001/01/18)
  • 起動が少し高速化
  • GCA のサポートを中止 (GCA SDK の不具合が原因で、
    kbunarc.dll が GCA に限らず正常動作しなくなってしまうため)
  • 圧縮ファイルをフォルダのように表示するかどうか設定出来るようにした
    (実際は 「圧縮ファイル：すべて検索、LZH/ZIP のみ検索、検索しない」の
    設定と連動する)
  • メドレー再生時の１曲あたりの演奏時間をレジストリの
    HKEY_CURRENT_USER\Software\Kobarin's Soft\KbMIDI Player\Advanced\MedleyPlayTime
    で設定出来るようにした (単位は秒、今のところ手動書き換えのみ)
  • 演奏リストに登録されているアイテムのうち、ファイルが削除されて
    存在しなくなっているものをリストから削除する処理を途中で中断できるようにした
  • Windows エクスプローラの設定によっては、起動時に変なダイアログを
    表示することがあったのを修正
  • FPD の再生周波数が 33075Hz になっていたのを 44100Hz に修正
  • 「環境設定」ダイアログで歌詞の検索パスの設定を変更したら直ちに検索を
    開始するようにした
  • DDE の XTYP_EXECUTE で圧縮ファイル内の個別データ
    (C:\aa.zip>bb.mid みたいなもの) の指定を受け付けるようにした
  • 細かい修正
Version 2.03 (2001/01/13)
  • KBMDX.DLL/KBS98.DLL/KBNEZ.DLL の開発を終了
    (代わりに Mamiya さんが手がけたプラグインを同梱させて頂くことにしました)
  • プラグインの拡張子を DLL から KPI に変更
  • お気に入り機能
  • メドレー再生機能
  • ランダム再生とシャッフル再生の意味を逆にした
  • GCA に試験的に対応 (正式に対応するかどうかは、GCA SDK がどうなるかによります。
    現状ではソリッド形式の GCA が実用的な速度で扱えません)
  • 演奏リストでタイトル・曲の長さをバックグラウンドで計算できるようにした
    (右クリックメニューの「バックグラウンドで曲長計算」で設定)
  • フォルダが削除・移動されたとき、Media エクスプローラでも自動的に
    反映されるようにした。ただし、
    • ファイルは監視しないので、圧縮ファイルの削除・移動は反映されない
    • CD-ROM ドライブは挿入と取り出しのみ監視 (多連装ドライブで問題が起こるかも？)
    • ネットワークドライブやネットワークパスを含むフォルダ
      (\\ComputerName\\hogehoge\ みたいなやつ) や FDD/MO などの
      リムーバブルディスクドライブは監視しない
  • 導入されているプラグインの情報を表示できるようにした (「ヘルプ」→「プラグイン情報」)
  • ファイルを開き直さなくても、歌詞ファイルの更新が次回演奏開始時 or 再生位置
    変更時に即座に反映されるようになった
    (タイムタグ付き歌詞のみ。SherryWRD の更新は反映されない)
  • 歌詞の検索パスに関する以下のような修正
    • 歌詞フォルダで検索して見つかった歌詞を「ドキュメント」に表示するようにした
      (タイムタグがついているもののみ)
    • 歌詞ファイルの検索処理を別スレッドで行うようにした
    • Media エクスプローラでの歌詞ファイルの検索速度が向上 (歌詞ファイルが１万個
      以上置いてあっても Media エクスプローラの実行速度にはほとんど影響しなくなった)
    • 起動時に lyric.dat から歌詞ファイル情報を読み込むことにより起動の高速化
    • 歌詞フォルダ以下の更新が自動的に反映されるようにした
      (数が多いと反映されるまで少し時間がかかることがありますが、その間他の作業が
      出来なくなるようなことはありません)
  • 動画に関する以下のような修正
    • ウィンドウサイズを適当な倍率、大きさに拡大・縮小できるようにした
      (RealVideo 再生時にサイズ変更した場合は最初から演奏開始されてしまう)
    • RealVideo のウィンドウサイズが実際より少し小さかったのを修正
  • Monkey's Audio (APE) に対応
  • 起動直後に無駄に KBUNARC.DLL/RCPCV.DLL をロードしていたのを修正
  • RIFF WAVE 形式の SIF を取得できていなかったのを修正
  • 名前にスペースを含むファイル・フォルダを選択時に「エクスプローラ起動」が
    正しく動作しないバグを修正
  • FMP/PMD のタイトルの取得に WINFMP.DLL/PMDWIN.DLL を使用しないようにした
  • その他色々細かい修整多数
Version 2.02β5 (2000/12/22)
  • OggVorbis に関する以下のような修正
    • 最新のデコーダ (2000/12/16 のもの)に差し替え (CPU 負荷が大幅に軽減)
    • タグ情報を取得できるようになった (かなり低速)
  • KBAAC.DLL を最新のデコーダ (FAAD 0.6) に差し替え
    (Psytel のエンコーダで作成した AAC が再生できるようになったらしい (未確認))
  • ドラッグアンドドロップ時の動作を以下のように仕様変更
    • Shift だけを押しながらドロップした場合は「リストに追加」
    • Ctrl だけを押しながらドロップした場合は「リストに追加＋演奏開始」
    • Ctrl+Shift の場合は「リストに新規に追加」
      (プレイリスト破棄の確認をするかどうかは Media エクスプローラの設定に従う)
    • 何も押してない場合は Media エクスプローラの「ダブルクリック時」の設定に従う
      (ただし、複数のファイルやディレクトリ・アーカイブがドロップされた
      場合は「リストに追加＋演奏開始」)
  • 1ファイルに複数曲を含むデータ (NSF など) を再生中に Ctrl を押しながら
    シークバーを操作した場合は再生位置を変更できるようにした
  • 歌詞ファイルと FPV の検索パスを設定できるようにした
    (PVI/PDX のパス指定も設定画面だけ作っていますが、未実装です)
  • SPC/MOD の音量倍率を設定できるようにした
    (「高度な設定」が可能になっている場合のみ)
  • 音量の増幅を有効にするかどうか設定できるようにした
    (「高度な設定」が可能になっている場合のみ)
  • Media エクスプローラの「リストに新規に追加」「リストを新規に開く」で
    プレイリスト破棄の確認をするかどうか設定出来るようにした
  • 「高度な設定」と Media エクスプローラに関する設定を初期設定に戻せるようにした
  • プラグインを Plugins より２階層下まで検索するようにした
    (作者名ごとに置き場所を変えるように管理できるようにするため)
  • 環境によっては音が出なくなる不具合があるらしいので、QuickTime ムービーを
    再生時は DirectSound を使うようにした (実際には QuickTime の設定に従う)
  • 細かい修正
Version 2.02β4 (2000/12/13)
  • 実行ファイルを UPX で圧縮するのをやめた
    (ウィルス対策ソフトが常駐していると、起動時間が異常に長くなるなどの
    問題が発生することがあるため)
  • KBMDX.DLL に関する以下のような修正
    • コアを MXDRVg 1.42b 相当のものに差し替え
    • サイズが大きな PDX を使用する MDX を再生すると落ちることがあるバグを修正
  • KBMP3.DLL に関する以下のような修正
    • 少しくらい壊れていても出来るだけ再生するようにした
  • KBSPC.DLL に関する以下のような修正
    • ずっとDSPに潜んでいた致命的なバグを修正 (よく動いてたもんだ…)
    • 強制ノイズの判別を修正 (ライブ ア ライブ、モンスタニア)
    • DSPの0x7C(ENDX)を修正 (ドラゴンクエスト…？)
    • 補間修正を修正
  • バージョン情報ダイアログを修正
  • DirectSound の後始末処理がまずかったのを修正
Version 2.02β3 (2000/12/10)
  • Liquid Audio(LQT) に対応
    (再生するには RealPlayer の LiquidAudio 再生プラグインが必要)
  • 動画に関する以下のような修正
    • 動画全般に関する以下のような修正
      • 前回再生時のウィンドウ位置を保存するようにした
      • すべての動画形式 (RealAudio も含む) で音量を調節できるようになった
        (AVI/MPG/WMV 等は DirectX5 以降の場合のみ可能)
      • 動画のウィンドウを閉じた場合、シークバーや「動画再生オプション」の
        再設定でウィンドウを再表示するようにした
      • 音声部分、映像部分の切り替えの際に音が途切れなくなった
        (AVI/MPG/WMV 等の場合は音声のみ→映像に切り替えると途切れてしまう)
    • AVI/MPEG/WMV 等に関する以下のような修正
      • ウィンドウのタイトルバーにファイル名を表示するようにした
        (今までは"Active Movie Window" と表示していた)
      • 音声部分のみの再生の際に KBDSHOW.DLL を使用しないようにした
    • RealAudio/Video に関する以下のような修正
      • ウィンドウのタイトルバーにファイル名を表示するようにした
        (今までは"RMA Video Window" と表示していた)
      • 再生するとボリュームコントロールの設定に影響を与えることがあったのを
        ある程度修正 (演奏開始直後にバランスが中央に移動してしまうなど
        完全には解決できていない)
      • RealVideo の再生時に上側が正しく表示されていなかったのを修正
      • ウィンドウを最小化したり、閉じることが出来るようにした
      • 演奏を開始する前に曲の長さを計算できるようになった
    • QuickTime に関する以下のような修正
      • ウィンドウがメインウィンドウより常に手前に表示されていたのを手前に
        表示しないように変更
      • 再生時に DirectDraw を使わないようにした (不安定なので)
      • 再生時に DirectSound を使わないようにした (音が変なので)
      • 再生速度を変更できるようになった
      • 再生中に描画領域をクリックしても演奏が停止しないようにした
      • ウィンドウを最小化したり、閉じることが出来るようにした
      • QuickTime がインストールされていない環境で QT/MOV を再生しようとした
        場合は ActiveMovie を使用して再生を試みるようにした
        (実際にはほとんど再生できない)
      • タイトルなどの情報を取得できるようになった
  • KBSPC.DLL に関する修正 (詳しくは KBSPC.TXT を参照)
  • KBDSHOW.DLL で動画に関する拡張子のサポートを中止
    (動画の音声部分は KBMOV.DLLで再生する)
  • フェードアウト中にシークしたり再生速度を変更するとおかしくなるバグを修正
  • プラグインがバージョンアップしてサポートする拡張子の数が変更されたとき、
    正しく認識できていなかったのをある程度修正 (完全ではない)
  • 1ファイルに複数曲含むデータ (NSF など) を再生するプラグインを
    読み込んだときのシークバーの動作の切り替え方法を変更
    (SOUNDINFO::dwReserved2 == 1 のときに切り替える)
  • WAV を再生時の液晶の色が MP3 と同じだったのを修正
  • Winamp が出力した ID3v2 形式のジャンルを正しく取得できていなかったのを修正
  • kbrun_pi.exe を介して再生しているときに Kbmplay.exe が異常終了すると、
    kbrun_pi.exe がシステムにゴミプロセスとして残ってしまう不具合を修正
  • エラーのある CAB を開くと落ちることがあるバグを修正
  • メモリリーク修正
  • 別ウィンドウで Media エクスプローラを起動するとき、不正なメモリに
    アクセスしていたバグを修正
Version 2.02β2 (2000/11/30)
  • 演奏リストに関する以下のような修正
    • 追加処理時の進捗状況ダイアログを修正
    • 追加処理中にアプリケーションの終了、リストの保存等を出来ないようにした
    • プレイリストファイルの読み込みが高速化
      (数千曲・数万曲単位でないと違いがわからない)
    • ランダム再生で次に再生すべき曲 (まだ再生していない曲)の検索が高速化
      (これも数千曲以上ないと違いがわからない)
  • KBSPC.DLL に関する以下のような修正
    • Snes9x1.32 以降で作成した SPC を再生できなかったバグを修正
    • モジュレーションを修正
    • ピッチを修正
    • 音量を大きくした
  • TwinVQ 再生時のエラー処理がまずかったのを修正
  • 演奏リストとMediaエクスプローラのソート処理を修正
  • エラーのある MIDI データを開くと落ちるバグを修正
  • Media エクスプローラリストビュー部分で、特殊な名前のフォルダ
    (xxxx.mp3 のような名前のフォルダ)の表示がおかしかったのを修正
  • 圧縮ファイル内の SherryWRD 再生時に無駄に展開処理をしていたのを修正
  • 終了処理の高速化
  • ツールバーのビットマップ (「ボリュームコントロール起動」と
    「MIDI デバイス設定」)を変更
  • 動画再生時のオプションが「自動」になっている場合、RealAudio を再生中に
    最小化すると最初から演奏開始されてしまうバグを修正
  • 複数のファイルをドラッグアンドドロップしても、1つしか認識しなくなっていたバグを修正
  • 「オプション」→「高度な設定」→「Wave 系を再生時は MIDI デバイスを閉じる」が
    有効になっているときに演奏リストで曲の長さを計算すると、Wave 系で演奏開始
    ボタンを押してから発音するまで数秒かかるようになってしまうバグを修正
    (2.02βで修正したつもりだったけど直ってなかった(^^;)
  • MIDI のフェードアウト時 (特にクロスフェード)にテンポがよれることが
    あったのをある程度改善
  • プレイリストの右クリックメニューの「選択中の曲の長さを計算」で
    圧縮ファイル内のデータの曲の長さを調べると落ちるバグを修正
  • ZLIB 関係のルーチン (PNG 画像読み込みと GZIP の解凍ルーチン)を
    Kbmplay.exe本体から切り離して KBUNARC.DLL に組み込むことにした
Version 2.02β (2000/11/17)
  • TwinVQ (VQF) に対応
  • QuickTime 形式の動画 (Windows Media Player で再生できないもの) に対応
  • MPG/AVI/ASF/WMV などの動画の再生に MCI を使わないようにした。これにより、
    • Win9x 系でファイル名の長さが 98 バイトを超える動画ファイルが
      再生できなかった問題が解決
    • 再生速度を変更できるようになった (ASF/WMV は除く)
    • ウィンドウを最大化できるようになった
  • アーカイブを含むフォルダをドラッグアンドドロップしたとき、
    正しいファイル名が取得できないことがあるバグを修正
  • MIDI 演奏スレッド/デコーダスレッドの最初に CoInitialize を使うようにした
    (ドライバによっては midiOutOpen/waveOutOpen 等で問題が起こるかもしれないので。
    でも多分あまり関係ないと思う(^^;)
Version2.01 (2000/11/07)
  • NSF (ファミコンサウンド) と KSS (MSX のサウンド) に対応
  • Windows Media Video (WMV) に対応
  • RealVideo に対応
  • 動画と RealMedia ファイルの再生ルーチンを DLL 化 (KBMOV.DLL)
  • KBDSHOW.DLL を修正 (拡張子 WMV をサポート)
  • 必要なときにのみプラグインや DLL をロードするようにした
    (起動の高速化と省メモリ化)
  • FPD 再生時に「単曲リピート」が選択された場合は無限ループさせるようにした
  • FPD98.DLL を Kbmplay.exe と同じフォルダにあるものしかロードしないようにした
  • KBFMP.DLL と KBPMD.DLL の初期化処理がまずかったのを修正
  • S98 の演奏開始がうまくいかないことがあるバグを修正
  • 音源MAP制御が有効になっているときに曲の先頭に音源リセットが含まれて
    いない MIDI データの再生位置を進めると演奏がおかしくなるバグを修正
  • DirectX5 未満の環境で動画や FPD、RealAudio を再生すると落ちるバグを修正
  • MIDI→WAVE 系へのクロスフェード中に「オプション」→「高度な設定」→
    「WAVE 系を再生時は MIDI デバイスを閉じる」を選択すると落ちるバグを修正
    (かなりひどいことになります(^^;)
  • 中身が ASF or WMV な動画を再生中に音声部分のみの再生と映像部分の再生を
    切り替えると落ちるバグを修正
  • MIDI 再生、WaveMapper/DirectSound の切り替えを繰り返していると、演奏開始
    ボタンを押してから発音まで数秒かかるようになってしまうことがあるバグを修正
    (再現性がないバグだったので、本当に修正されているかどうかはわかりません)
  • 起動時に前回終了時の Media エクスプローラリストビュー部分のカラム幅を
    読み込んでいなかったのを修正
  • その他色々修正
Version2.00β11 (2000/11/21)
  • 長すぎて表示しきれない歌詞はスクロールさせるようにした
  • ショートカットを作ってウインドウの設定を最大化にして起動したときや、
    タスクマネージャで最大化をしたときに変なウィンドウが表示されるのを修正
    (タスクマネージャによる最大化は本体のウィンドウをマウスでドラッグしたときに直る)
  • リリックメタイベントよりもタイムタグ付き歌詞ファイルの方を優先するようにした
  • 壊れていて解凍できない圧縮ファイル内のデータを再生しようとしたとき、
    テンポラリディレクトリ内にゴミファイルが残ってしまうバグを修正
  • 「MIDIデバイス設定」の「テンプレート名」に & が含まれている場合に
    「タブのラベルにテンプレート名を表示」すると下線になるバグを修正
Version2.00β10 (2000/08/23)
  • FPD (拡張子 FPD/FM) に対応 (FPD98.DLL が必要)
  • FMP (拡張子 OPI/OVI/OZI) に対応 (WINFMP.DLL が必要)
  • PMD (拡張子 M/M2/MZ/MP/MS) に対応 (PMDWIN.DLL が必要)
  • 画面の隅にウィンドウをスナップするようにした
  • 未知のフォーマットであっても、ほとんどの場合に圧縮ファイル内のデータを
    正常に再生できるようになった
  • 一部の形式の LZH(-lh1-) を正しく解凍できないことがあったのを修正
  • SPC のデフォルトの曲の長さをレジストリから読み込んでいなかったのを修正
  • プレイリストファイル (*.KBM / *.M3U) を関連付けやアイコンへの
    ドラッグアンドドロップで起動すると、ランダム再生の再生済み情報が
    消えてしまうのを修正
  • 再生位置を戻すと歌詞表示が止まることがあるバグを修正
  • S98 に関する以下のような修正
    • データによっては S98 の再生時に落ちるバグを修正
    • gzip形式で圧縮された S98 のタイトルを取得できるようになった
    • KBS98.DLL と同じディレクトリにあるリズム音源を読み込むようにした
  • MDX に関する以下のような修正。
    • コアを MXDRVg 1.41a 相当のものに差し替え
    • 瞬間的なシークが出来るようになった
  • その他細かい修正多数
Version2.00β9 (2000/08/12)
  • β8 に同梱の KBSPC.DLL が、実際は最新のコアでなかったのを修正(^^ゞ
  • プラグインを使用して再生時、演奏終了の直前にシークすると動作が
    おかしくなるバグを修正
  • PDX を含む MDX を開くと落ちる可能性があったのを修正
  • 圧縮ファイル内の MDX (PDX を含むもの)に対応
  • 圧縮ファイル内の Script700 に対応
  • S98/MDX のタイトルを取得出来るようになった
  • 一部の環境で挙動不審だったのが修正されたかもしれない (自信がない…)
  • メモリリークを修正
Version2.00β8 (2000/08/05)
  • MDX に仮対応 (詳しくは KBMDX.TXT を参照)
  • レジストリに設定が保存されていない状態だと起動できない
    (起動で落ちる)致命的バグの修正(^^ゞ(T-T)
  • レジストリを手動設定することにより、「オプション」→「高度な設定」で
    ホットキーや M3U の保存形式などの高度な設定が行えるようにした
  • 「高度な設定」で「DirectSound 使用時のみクロスフェード」のチェックを
    外さない限り、WaveMapper ではクロスフェード出来ないようにした
    (ドライバの制限により、複数の WAVE デバイスを同時に開けない環境や、
    ソフトウェア音源がインストールされている環境で複数の WAVE デバイスを
    同時に開くと不安定になる問題への対策)
  • 「高度な設定」の「WAVE 系を再生時は MIDI デバイスを閉じる」のチェックが
    有効な場合は、WAVE デバイスを閉じてから MIDI デバイスを開くまで、
    あるいは逆に MIDI デバイスを閉じてから WAVE デバイスを開くまで約5秒間の
    ウェイトを置くようにした (ソフトウェア音源使用時に不安定になる問題への対策)
  • 「高度な設定」でMIDI→WAVE系に切り替えるときに MIDI デバイスを閉じるか
    どうか設定できるようにした (デバイスを閉じない設定にすると、MIDI←→WAVE系
    への切り替えがスムーズになり、クロスフェードも可能になる)
  • MIDI デバイステンプレート設定の「演奏開始前に送信するリセット系SysEx」に
    「SYSTEM MODE SET ONLY」と「GS RESET ONLY」を追加
  • MIDI デバイスを閉じてから別の MIDI デバイスを開くまで約5秒間の
    ウェイトを置くようにした
    (ソフトウェア音源から別のソフトウェア音源への切り替えに失敗する問題への対策)
  • MIDI デバイスのオープンを演奏スレッドで行わせるようにした
  • MIDI 再生時のフェードアウト処理を修正
  • DirectSound を使用して MP3 等を再生しているときのボリューム変更が液晶の
    スペアナに反映されてなかったのを修正
  • スレッドの管理方法を修正 (もしかしたら不安定になったかも？)
  • 演奏リストの「対応音源」の部分に MIDI の対応音源が
    表示されなくなっていたバグを修正
Version2.00β7 (2000/07/30)
  • 内部的にかなり大幅に作り直し
    (UPX で圧縮をかける前に換算して、ファイルサイズが 100KB ほど小さくなった)
  • DirectSound を使うか WaveOut を使うかを選択できるようにした
    (気が向いたら WaveMapper 以外の Wave デバイスも選択できるようにするかも)
  • SPC に関する以下のような修正 (詳しくは kbspc.txt を参照のこと)
  • KBSPC.DLL のプラグイン化。それに伴い、プラグインの仕様を少し拡張。
    kbrun_pi.exe も修正 (プラグインの仕様は従来と互換性があります)
  • Script700/7SE に対応 (詳しくは script.txt を参照)
  • 曲の長さが埋め込まれている場合は、曲の長さに達するまで
    無音の検出処理を行わないようにした
    (途中で 10秒以上の無音が含まれているようなデータであっても曲の
    長ささえ埋め込んであれば問題なく再生できるはず)
  • シークをサポートしないデコーダ (SPC, AAC など) の扱いに関する以下のような修正
    • 再生速度の変更が即座に反映されるようになった
      (実際は１秒以上かかることがある)
    • 再生位置を進める場合は、現在の再生位置からシークを開始するようにした
      (今まではシークの度に先頭に戻していた)
    • 強制シーク中に一時停止ボタンを押下したときの挙動を MIDI で
      シークしているときの挙動と同じくなるようにした
    • 強制シークしている最中に再生速度を変更すると、
      しばらくの間操作出来なくなってしまうのを修正
  • プラグインなしでも KbMedia Player 本体がサポートする形式にプラグインも
    対応していた場合は、プラグインを優先するようにした (MOD, RealAudio)
  • 終了時にクロスフェードに関する設定を保存するようにした
  • クロスフェード時に音量が急に小さくなってしまうことがあるのを修正
  • 単曲リピート時は「終了時にクロスフェード」の設定を無視するようにした
  • 動画再生時のシーク・一時停止からの再開処理を修正
  • プレイリストにデータを追加する処理がまずかったのを修正
  • 音程を変えない倍速再生時の再生位置取得がめちゃくちゃだったのを修正
  • 曲の最後の最後が演奏されないことがあるのを修正
  • テンプレート名に & を含むとメニュー項目の表示が下線になるのを修正
  • MIDI デバイステンプレートの設定が保存されないことがあるのを修正
  • MIDI エミュレーションの「切り替える直前から演奏開始」が機能していなかったのを修正
  • KbUnArc.DLL の仕様を大幅に変更
  • メニュー項目に出来るだけショートカットキーを割り当てるようにした
  • 他にもたくさん修正
Version2.00α6 (2000/07/14)
  • リエントラントでないプラグイン(AAC, SPC, S98)を使用時でもクロスフェード
    (AAC→AAC, SPC→SPC, S98→S98)が可能になった
    (MIDI←→MP3 などはまだ無理。MOD→MOD のクロスフェード時の雑音は未解決)
  • KBS98.DLL をほんの少し修正
  • クロスフェードするかしないか設定できるようにした
  • 再生中にログオフ・シャットダウンができなかったのを修正
  • 再生位置取得が変だったのを修正
  • 圧縮ファイル内のデータの更新日時を表示していなかったのを修正
  • Media エクスプローラの体感速度が向上 (人によってはかえって遅く感じるかも？)
  • CAB の解凍ルーチンをマルチスレッド化
  • 巨大すぎる CAB (解凍後のサイズの合計が 16MB を超える分)は
    解凍しないようにした (大量のメモリを必要とするため)
  • 圧縮ファイル内の MP3 等を再生するときに無駄に解凍処理をしていたのを修正
  • メモリリーク修正
  • 内部的に色々修正
Version2.00α5 (2000/07/03)
  • DirectSound に対応 (「ボリュームコントロール」のミキサーの設定に
    影響を与えずにボリュームの変更が即座に反映されるようになった)
  • 曲の切り替え時にクロスフェードさせるようにした
  • 動画やリアルオーディオ再生時のスペアナ表示の際に waveIn 系 API ではなく、
    IDirectSoundCapture を (使用できる環境ならば) 使用するようにした
    (演奏開始のレスポンスが向上？)
  • Media エクスプローラ右クリックメニューに「プロパティ」を追加
    (Alt+Enter or Alt+ダブルクリックでも表示可能。
    mp3infp がインストールされてると良いかも)
  • 起動を少し高速化
  • 省メモリ化
Version2.00α4 (2000/06/25)
  • RealAudio に関する以下のような修正
    • RMJ に対応 (多分 RealPlayer7 以降 or RealJukeBox が必要)
    • 曲の長さを正しく計算できるようになった (演奏を開始するまで計算できない)
    • タイトル情報を取得できるようになった (間違った情報を取得することがあるかも？)
    • シークできないことがあったのを修正
    • RealAudio を再生中にプレイリストで RealAudio のデータの曲の長さを
      調べると落ちる、または演奏が止まってしまうことがあるのを修正
      (Real Player G2 の場合に NG ？ Real Player7 Basic では問題ないみたい)
  • OggVorbis の曲の冒頭が再生されないことがあるバグを修正
  • OggVorbis 再生時の CPU 負荷を軽減
  • AAC 再生時のメモリリークを修正
  • AAC 再生時の CPU 負荷を軽減
Version2.00α3 (2000/06/21)
  • RealAudio(*.RA / *.RM) にとりあえず対応
  • OggVorbis(KBVORBIS.DLL) に関する以下のような修正
    • libvorbis を最新(？)のものに差し替え
    • 大規模なメモリリークが発生していたのを修正
    • 演奏開始時に落ちることがあったのを修正
    • 曲の先頭にシークすると落ちることがあったのを修正
    • 演奏中に 0 による浮動小数点除算で落ちることがあったのを修正
  • 最後の行のタイムタグの Winamp時間→標準時間の変換や @Offset の
    適用がなされていなかったバグを修正
Version2.00α2 (2000/06/11)
  • プラグインに試験的に対応 (KBMP3.DLL, KBDSHOW.DLL,
    KBAAC.DLL, KBS98.DLL, KBVORBIS.DLL はプラグインとして扱う)
  • 一部メモリリークしていたのを修正
Version2.00α (2000/06/01)
  • 名称を KbMedia Player に変更
  • アーカイブ解凍ルーチンの DLL 化 (KBUNARC.DLL)
  • CAB32.DLL を使わずに CAB に対応
    (Media エクスプローラでの一覧の取得が大幅に高速化)
  • AAC に対応 (KBAAC.DLL)
  • OggVorbis に対応 (KBVORBIS.DLL)
  • S98 に対応 (KBS98.DLL)
  • Media エクスプローラの設定が「圧縮ファイル：検索しない」や
    「圧縮ファイル：LZH/ZIP のみ検索」になっているとき、
    リストビュー部分に CAB が表示されないことがあるバグを修正


最新バージョンの入手先
最新のファイルの配布先
  • KbMedia Player : http://home7.highway.ne.jp/Kobarin/
  • Html Help for KbMedia Player : http://www.ne.jp/asahi/etc/qed/
メーリングリストについて

オメガ氏によって開設・管理されています。
参加をご希望の方はこちらまで。

連絡先
  • Kobarin : hidkob@pb.highway.ne.jp
    KbMedia Player についての感想・要望・苦情等はメールか掲示板、
    またはメーリングリストでお願いします。メールでの個別対応は辛くなってきたので、
    出来るだけ掲示板かメーリングリストにお願いします。
  • Q.E.D. : qed@digital.email.ne.jp
    ヘルプについて何かありましたらこちらへどうぞ。
    誤植や間違いを発見したらこっそり教えてください。(^^;
  • オメガ : megamega@vanilla.freemail.ne.jp


Main Window

操作方法

KbMedia Player のメインウインドウです。
知りたい場所をクリックしたり右クリックしてみたりして下さい。

ファイルメニュー 演奏メニュー 表示メニュー ツールメニュー ヘルプメニュー 開く 上書き保存 再生 再生速度変更 一時停止／再開 停止 前の曲 次の曲 エクスプローラ ボリュームコントローラ プロパティ デバイス設定 ボリュームコントロール 情報表示 シーク Media エクスプローラ 演奏リスト ドキュメント 小型化 ドライブ お気に入り Media エクスプローラ Media エクスプローラ Media エクスプローラ
テンキーでの操作

KbMedia Player は操作パネルだけでなく、テンキーからでもある程度の
操作が出来るようになっています。キーアサインは以下の通りです。

7 : 5秒戻る | 8 : 音量を 5上げる | 9 : 5秒進む
4 : 前の曲 | 5 : 演奏開始 | 6 : 次の曲
1 : 未定義 | 2 : 音量を 5下げる | 3 : 未定義
情報表示パネル

KbMedia Player は以下のような情報を取得して表示します。

MIDI その他
  • ファイル名
  • タイトル
  • 著作権
  • 曲の長さ
  • フォーマット
  • トラック数
  • 対応音源
  • 使用ポート
  • 歌詞形式
  • ファイル名
  • タイトル
  • アーティスト
  • 曲の長さ
  • アルバム
  • 年
  • ジャンル
  • コメント
  • 歌詞形式

情報表示部の背景は変更することが出来ます。詳しくはこちらをご覧下さい。
LCD は動かないようにすることも出来ます。
「表示」メニューの「液晶(スペアナ)」のチェックを外してください。
LCD を含む情報表示部のサイズは、「表示」メニューもしくは右クリックの
「液晶(サイズ)」から変更することが出来ます。
または表示部をダブルクリックすることで、大きさを順番に変えることも出来ます。

ボリュームコントロール

「表示」メニューの「ボリューム」にチェックを入れていると、
ボリュームコントロールを用いてボリュームを変更することが出来ます。
ただしボリューム調整に対応しないデータを再生中は、ボリューム調整トラックバーの
下にある数字が淡色表示されます。

  • ボリュームを変更すると、タイトルバーに現在の音量が１秒間表示されます。
  • 下の数字をクリックすると標準値(100)に戻すことが出来ます。
  • その他の設定で音量増幅機能を使用する設定にしていると、
    0 ～ 200% までの間で音量を設定する事ができます。
    ただし MIDI や 動画の音量は増幅できません。
再生位置変更

LCD の下のスクロールバーをクリックすることで、曲データの現在の位置を
変更することが出来ます。KbMedia Player は MIDI のコントローラ・パッチチェンジに
対する自動検索機能を持っていますので、たとえ曲の途中からでも、
常にその位置に対応した正しいパッチとコントロール値で再生を開始することができます。

エコー

エコー 左図のアイコンの右側の矢印をクリックすることで、エコーをかけることが出来ます。
ただしエコーをかけられるのはプラグインを使用して再生する形式に限ります。

再生速度変更

再生速度変更 左図のアイコンの右側の矢印をクリックすることで、
再生速度を変更することが出来ます。
ただし MIDI 再生時とその他を再生しているときでは設定できる倍率は異なり、
以下のようになっています。

MIDI ： 0.25, 0.5, 0.6, 0.7, 0.8, 0.9, 0.95, 1.0, 1.05, 1.1, 1.2, 1.3, 1.5, 2.0, 3.0
その他 : 0.5, 0.6, 0.7, 0.75, 0.8, 0.9, 0.95, 1.0, 1.05, 1.1, 1.2, 1.25, 1.3, 1.5, 2.0

テンポを変更すると、アイコンの色が変わります。
そのまま再生速度を変更すると音程も一緒に変わって
しまいますが、「音程を変えずに速度を変更」にチェックを
入れることで音程はそのままで再生速度だけ変更することが
出来ますが、その代わりにかなりの CPU パワーを喰います。
ご自身のマシンに合わせてクオリティを選んでください。

開く 上書き保存 名前をつけて保存 プロパティ マルチメディアのプロパティ アンインストール用終了 KbMedia Player の終了 再生 一時停止／再開 停止 フェードアウト 次の曲 前の曲 単曲再生 単曲リピート リピート 切り替え時にクロスフェード 終了時にクロスフェード ノンストップ再生 連続再生 ランダム再生 メドレー再生再生 未再生の曲だけ再生 液晶(パート) 液晶(色) 液晶(サイズ) 液晶(チャンネル番号) 液晶(スペアナ) タスクトレイ ボリューム お気に入り WRD Media エクスプローラ 最新の情報に更新 環境設定 デバイス設定 その他の設定 SuperTagEditor ボリュームコントロール cdplayer.ini 歌詞フォルダ Device Select 目次 トラブルシューティング FAQ DLL プラグイン ドキュメント Kobarin のホームページ バージョン情報 液晶(パート) 液晶(色) 液晶(サイズ) 液晶(チャンネル番号) 液晶(スペアナ) 環境設定 デバイス設定 タスクトレイ ボリューム お気に入り WRD Media エクスプローラ 追加＋再生 追加 新規に追加 最新の情報に更新 エクスプローラ SuperTagEditor プロパティ 設定 ヘルプ 再生 追加＋再生 追加 新規に追加 最新の情報に更新 エクスプローラ SuperTagEditor プロパティ 設定 ヘルプ


Menu

操作方法
メニュー

画像をクリックすることでメニューを表示することが出来ます。

開く 上書き保存 名前をつけて保存 プロパティ マルチメディアのプロパティ アンインストール用終了 KbMedia Player の終了 再生 一時停止／再開 停止 フェードアウト 次の曲 前の曲 単曲再生 単曲リピート リピート 切り替え時にクロスフェード 終了時にクロスフェード ノンストップ再生 連続再生 ランダム再生 メドレー再生再生 未再生の曲だけ再生 液晶(パート) 液晶(色) 液晶(サイズ) 液晶(チャンネル番号) 液晶(スペアナ) タスクトレイ ボリューム お気に入り WRD Media エクスプローラ 最新の情報に更新 環境設定 デバイス設定 その他の設定 SuperTagEditor ボリュームコントロール cdplayer.ini 歌詞フォルダ Device Select 目次 トラブルシューティング FAQ DLL プラグイン ドキュメント Kobarin のホームページ バージョン情報


File menu

ファイル(F)

開く 上書き保存 名前をつけて保存 プロパティ マルチメディアのプロパティ アンインストール用終了 KbMedia Player の終了


File -Open-

ファイル
開く(O)... Ctrl+O

ファイルを開くダイアログボックスを表示し、演奏リストを開くことができます。
KbMedia Player 独自の形式 (*.KBM) と ふみぃ氏作:「TMIDI Player」の
演奏リスト形式(*.TO2)、さらには MP3のリストデータ (m3u) を読み込むことが出来ますが、
曲データ (MID, RMI, RCP 等) は開けません。

ここからリストファイルを開く場合は Media エクスプローラから開くときと違い、
新規に開くか追加で開くかを選べず、常に新規で開きます。
ただし Mediaエクスプローラから開く場合でも、
ダブルクリックをして開こうとした場合は新規に開くことしかできません。


File -Save-

ファイル(F)
上書き保存(S) Ctrl+S

現在の演奏リストファイルを上書き保存します。
演奏リストをまだ作成していない場合は 「名前をつけて保存」 と同じ
ダイアログボックスを開きます。*.M3U でも保存することはできますが、
圧縮ファイル内のデータに関する情報は失われます。


File -Another-

ファイル(F)
名前を付けて保存(A)...

現在の演奏リストファイルに名前をつけて保存します。
*.M3U でも保存することはできますが、
圧縮ファイル内のデータに関する情報は失われます。


File -Property-

ファイル(F)
プロパティ(R)

現在再生しているファイルのプロパティを開きます。


File -Property of Multimedia-

ファイル(F)
プロパティ(R)

コントロールパネルの中にあるマルチメディアのプロパティを開きます。


File -Exit for Uninstall-

ファイル(F)
アンインストール用終了(U)

KbMedia Player をアンインストールする場合に選択します。
詳しくはアンインストール方法をご覧ください。


File -Exit-

ファイル(F)
KbMedia Player の終了(X)

KbMedia Player を終了します。


Play menu

演奏(P)

再生 一時停止／再開 停止 フェードアウト 次の曲 前の曲 単曲再生 単曲リピート リピート 切り替え時にクロスフェード 終了時にクロスフェード ノンストップ再生 連続再生 ランダム再生 メドレー再生再生 未再生の曲だけ再生


Play -Play-

演奏(P)
再生(P) Ctrl+P

曲の先頭から演奏を開始します。
MIDI 再生時は、右側の矢印をクリックすると簡易エミュレーションを
使用することができます。その他のファイルではエコーをかけることが出来ますが、
プラグインを使用して再生する形式に限ります。


Play -Halt-

演奏(P)
一時停止／再開(H) Ctrl+H

曲の演奏を一時停止／再開します。


Play -End-

演奏(P)
停止(E) Ctrl+E

曲の演奏を中止します。


Play -Fadeout-

演奏(P)
フェードアウト(F) Ctrl+F

フェードアウトするようにします。
Ctrl を押しながら「次の曲」「前の曲」ボタンをクリックした場合も
フェードアウトしながら演奏停止します。

フェードインやフェードアウトの時間は、「ツール」->「環境設定」->「演奏設定」 から可能です。
詳しくはこちらをご覧ください。

徐々に音量を下げていって演奏停止することです。


Play -Forward-

演奏(P)
次の曲(N) Alt+Right

演奏リストにある、現在演奏している曲の１つ後の曲を演奏します。


Play -Previous-

演奏(P)
前の曲(B) Alt+Left

演奏リストにある、現在演奏している曲の１つ前の曲を演奏します。


Play -Simply-

演奏(P)
単曲再生(A)

指定された曲のみを再生します。演奏した曲が終わっても、リストの次の曲を演奏しません。


Play -Single-

演奏(P)
単曲リピート(S)

現在演奏されている曲を繰り返し再生します。
指定された曲が SPC/MOD のときは無限ループします。
単曲リピート時は「終了時にクロスフェード」の設定を無視します。

ここにチェックを入れると入れることで SWF の演奏終了の検出を行わなくなります。
SWF が最後まで演奏できない場合にはここにチェックを入れてください。


Play -Single-

演奏(P)
リピート(R)

[演奏リスト] にリストアップされているすべて曲を繰り返し再生します。
ただし単曲リピート(S)のチェックがオンになっている場合はそちらを優先します。


Play -Crossfade-

演奏(P)
終了時にクロスフェード(C)

曲を切り替えるときにクロスフェードを試みます。
ここで言う曲の切り替えとは、その曲の再生が終了して演奏リストの次の曲を
演奏することではなく、次の曲や前の曲、またはリストアップされた曲目の
ダブルクリックなどによって次の曲を再生しようとしたときのことです。

フェードインやフェードアウトの時間は、「ツール」->「環境設定」->「演奏設定」 から可能です。
詳しくは こちらをご覧ください。

現在再生中の曲がフェードアウトする一方で、
次の曲がフェードインしながら曲が切り替わる方式のことです。


Play -Crossfade-

演奏(P)
終了時にクロスフェード(X)

曲の終了時にクロスフェードを試みます。曲の終了時とは
現在の曲の演奏が終了し、演奏リストの次の曲を演奏しようとするときを指します。

フェードインやフェードアウトの時間は、「ツール」->「環境設定」->「演奏設定」 から可能です。
詳しくは こちらをご覧ください。

現在再生中の曲がフェードアウトする一方で、
次の曲がフェードインしながら曲が切り替わる方式のことです。


Play -Nonstop-

演奏(P)
ノンストップ再生(N)

これはノンストップ CD を MP3 等にエンコードしたデータを連続再生するためのものです。
この機能を使用するためには演奏モードを「連続再生」にして、
かつ DirectSound で再生する必要があります。

ただしこの機能を用いても気休め程度にしかなりません。
MP3 の仕様上、完璧に繋げることは不可能です。最新の LAME でエンコードしたものならば
理論的には可能になるそうですが、KbMedia Player では未対応です。

WAV/APE/OGG であれば完璧に繋げることは理論上可能ですが、
現在の仕様では 2つの演奏ルーチンが完全に独立なため、
タイミングを合わせるのが困難です。ご了承ください。


Play -Sequence-

演奏(P)
連続再生(Q)

演奏リストに従って順番に再生します。


Play -Random-

演奏(P)
ランダム再生(R)

リストにある曲をランダムに再生します。
「未再生の曲だけ再生」のチェックが入っている場合はそちらに従います。


Play -Medley-

演奏(P)
メドレー再生(M)

リストにある曲をクロスフェードしながら繋げて再生します。
1曲あたりの演奏時間を設定する事ができます。
1曲あたりの再生時間は、「ツール」->「環境設定」->「演奏設定」 から可能です。
詳しくはこちらをご覧ください。

現在再生中の曲がフェードアウトする一方で、
次の曲がフェードインしながら曲が切り替わる方式のことです。


Play -Shuffle-

演奏(P)
未再生の曲だけを再生(K)

演奏リストにある曲を再生しますが、一度演奏した曲は演奏しません。
すべての曲が演奏され終り、リピート状態になっている
場合は、演奏されたかどうかのチェックがすべて外されます。


View menu

表示(V)

液晶(パート) 液晶(色) 液晶(サイズ) 液晶(チャンネル番号) 液晶(スペアナ) タスクトレイ ボリューム お気に入り WRD Media エクスプローラ 最新の情報に更新


Play -LCD Part-

表示(V)
液晶(パート)(P)

液晶画面で表示する MIDI パートを設定します。
次の３つから１つを選択します。
「自動」に設定すると、再生する MIDIデータを解析して自動的に表示を切り替えます。

  • 自動
  • 16パート
  • 32パート
16 Part | 32 Part


Play -LCD Color-

表示(V)
液晶(色)(L)

液晶画面の色を設定します。
Auto に設定すると再生するデータにあわせて自動的に表示を切り替えます。

MIDI (GS) | MIDI (XG) | MIDI (GM)
MIDI (KORG) | MIDI (????) | MPEG Audio
AudioCD / MOD | VQF / S3M | OggVorbis / XM
RealMedia / IT | Movie / MDX | WMA / FMP
SPC / PMD | AIF / AAC | AU / NSF
WAV etc... |  |


Play -LCD Size-

表示(V)
液晶(サイズ)(S)

液晶画面の大きさを設定します。
液晶画面やファイル情報部分をダブルクリックすることでも変更することが出来ます。

Large
Normal
Middle
Small
Tiny


Play -LCD Channel-

表示(V)
液晶(チャンネル番号)(N)

液晶画面に MIDI チャンネル番号を表示するかどうかを設定します。

チャンネル番号あり | チャンネル番号なし


Play -LCD Spectrum-

表示(V)
液晶(スペアナ)(A)

再生中にスペアナを動かすかどうかを設定します。


Play -Tasktray-

表示(V)
タスクトレイ(T)

タスクトレイに KbMedia Player のアイコンを表示するかどうかをを設定します。
タスクトレイのアイコンをクリックしてできることは以下の通りです。

  • 元のサイズに戻す(R) / 最小化(M)
  • 終了(X)
  • Media エクスプローラ(M)
  • 再生(P)
  • 一時停止／再開(H)
  • 停止(E)
  • フェードアウト(F)
  • 次の曲(N)
  • 前の曲(B)

タスクトレイのアイコンをクリックすると、上記のメニューの他に
現在再生中のデータに関する情報を表示します。
表示される内容は液晶の右にあるものと一緒です。


Play -Volume-

表示(V)
ボリューム(V)

ボリュームコントロールを表示するかどうかを設定します。
ここにチェックを入れていると、ボリュームコントロールを用いて
ボリュームを変更することが出来ます。
ただしボリューム調整に対応しないデータを再生中は、
ボリューム調整トラックバーの下にある数字が淡色表示されます。

  • ボリュームを変更すると、タイトルバーに現在の音量が 1秒間表示されます。
  • 下の数字をクリックすると標準値(100)に戻すことが出来ます。
  • その他の設定で音量増幅機能を使用する設定にしていると、
    0 ～ 200% までの間で音量を設定する事ができます。
    ただし MIDI や 動画の音量は増幅できません。


Play -Favorite-

表示(V)
お気に入り(F)

Media エクスプローラのお気に入りを表示するかどうかを設定します。
お気に入り


Play -SherryWRD-

表示(V)
WRD F11

SherryWRDウインドウを表示します。

MIDI ファイルに歌詞と画像をつけるための仕様です。
TMIDI の作者でもあるふみぃさんと、
沢渡みかげ さんとで作成された 256色 WRD の形式です。


Play -Media Explorer-

表示(V)
Media エクスプローラ(E) F12

Mediaエクスプローラ を開きます。ここで開かれるのは普通のエクスプローラではなく、
現在演奏中のファイルがあるフォルダが開かれた状態で
KbMedia Player の下部にある Media エクスプローラが別のウインドウで開かれます。

Media エクスプローラ


Play -Refresh-

表示(V)
最新の情報に更新(R) F5

Media エクスプローラのディレクトリツリー構造を再構築します。


Tool menu

ツール(T)

環境設定 デバイス設定 その他の設定 SuperTagEditor ボリュームコントロール cdplayer.ini 歌詞フォルダ Device Select


Tool -Configure-

ツール(T)
環境設定(C)

KbMedia Player の設定項目の数々です。
大抵の設定はここで出来るようになっているはずです。

外観 優先度 演奏設定 検索パス1 検索パス2 プラグイン その他 環境設定


Configure -Surface-

ツール(T)
環境設定(C) -外観-

KbMedia Player の外観の部分の環境設定ウインドウです。

見たまんまなのであえて説明はしません。 (^-^;
スキンを設定すれば情報表示部の背景を変更できますが、
*.BMP しか使用することは出来ません。
おまけのような機能ですし、これ以上の機能強化はありません。

スキンを使用しない場合はファイル名のボックスを空白にして下さい。

優先度 演奏設定 検索パス1 検索パス2 プラグイン その他 外観


Configure -Priority-

ツール(T)
環境設定(C) -優先度-

KbMedia Player の実行制御の部分の環境設定ウインドウです。
MP3 などの音とびがひどい場合は、デコードスレッドの優先順位を高くすることで
回避できるかもしれません。ただしプロセス、MIDI 演奏スレッド、LCD 描画スレッドの
優先度はなるべく初期設定のまま変更しないで下さい。
演奏の安定性という点においてはここの設定を変更してもさほど変わりません。
また、これらの 3つの設定は終了時に保存されません。

特にプロセスの優先順位を変えると、システムが不安定になるなどの
予期しない結果になることがあります。

外観 演奏設定 検索パス1 検索パス2 プラグイン その他 優先度


Configure -Playing-

ツール(T)
環境設定(C) -演奏設定-

KbMedia Player の演奏部分の諸設定です。

外観 優先度 検索パス1 検索パス2 プラグイン その他 エフェクト 動画 クロスフェード デフォルトの曲の長さ メドレー再生時間 F0 43 10 4C 00 00 7F 00 F7 を送信する waveOutGetPosition を使う waveIn による波形取得を行う WAVE / MIDI デバイスを排他的に開く WaveMapper 使用時もクロスフェード有効 RealMedia 再生時に強制的に音量を最大 演奏設定

エフェクト

ON にすると演奏時にエコーをかけることが出来ます。
ただしエコーをかけられるのはプラグインを使用して再生する形式に限ります。

動画

動画再生時の音声と映像についての設定です。
以下の 3つから選ぶことが可能です。

  • 自動 (最小化時は音声のみ)
  • 音声と映像
  • 音声のみ

メインウインドウで操作を行うと動画が隠れてしまって
困るような場合には、ここの「常に手前に表示」に
チェックを入れてください。

「詳細」をクリックすると右のメニューが出てきて、
上記の設定の他に動画を再生する際のサイズを
固定することが出来ます。このメニューは動画を
再生しているときに、左のアイコンの右側の
矢印をクリックすることでも表示できます。

ただし「最大化」というサイズ指定は今のところ
出来ません。ご了承ください。

クロスフェード

クロスフェードのフェードインやフェードアウトの時間を設定します。
1000ミリ秒 = 1秒 です。
各項目の設定は以下のようになっています。

  • フェードイン時間
    新しく開いた曲の演奏を開始してから音量が最大になるまでにかかる時間
  • フェードアウト時間
    フェードアウトを開始してから音量が 0 になるまでにかかる時間
  • フェードアウト開始時間
    新しい曲を開いてから、元々再生していた曲のフェードアウトが開始されるまでの時間
  • 終了時にクロスフェード
    「演奏」メニューの「終了時にクロスフェード」が有効になっている場合、
    演奏終了の何ミリ秒前からクロスフェードを開始するかです。
    フェードアウト開始時間には負の値も設定することができ、
    正の場合はフェードインが指定した時間だけ進行してから
    フェードアウトが始まり、負の場合はフェードアウトが
    指定した時間だけ進行してからフェードインが始まります。
その他
  • デフォルトの曲の長さ
    SPC/SAP/NSF/NSZ/NEZ/NSD/KSS/GBR/GBS/HES/AY/CPC などを
    再生する際に、データとして曲の長さが埋め込まれていない場合には
    この値を曲の長さとして再生します。
  • メドレー再生時間
    メドレー再生をしたときの 1曲あたりの再生時間を設定します。
ドライバ依存設定

ここの設定は慎重に行ってください。性能重視の設定では
ドライバによっては正常動作しなかったり、動作が不安定になる可能性があります。

  • F0 43 10 4C 00 00 7F 00 F7 を送信する
    Windows2000 で YMF7x4 チップ搭載サウンドカードを使用している環境で
    MIDI を再生するときに、この SysEx を送信すると OS が落ちるのを回避するための
    設定です。チェックを入れていると MIDI 再生で OS が落ちる可能性があります。
    チェックを外すと本来送信するべきデータを送信しないことになるので、
    MIDI データによっては正常に再生されなくなります。
  • waveOutGetPosition を使う
    WaveMapper を使って MP3 などを再生している場合の再生位置取得に
    Win32API の waveOutGetPosition を使うようにします。
    チェックを入れると再生位置取得が正確になりますが、
    サウンドカードのドライバによっては動作が不安定になります。
    DirectSound を使用して再生する場合はこの設定は無意味です。
  • waveIn による波形取得を行う
    チェックを入れると動画や RealAudio、音楽 CD を再生する時に
    スペアナを表示することが出来ますが、ドライバによってはチェックを
    入れても表示出来ません。
    場合によっては動作が不安定になることもあります。
    最近のサウンドカードなら問題ないと思いますが、チェックを入れてもスペアナが
    表示されない場合や、動作が不安定になったり重くなる場合はチェックを外しておくことを
    お勧めします。チェックを入れてもスペアナが表示されない場合でも、
    ドライバの設定を変更することで表示されることがあります。
    詳しくはトラブルシューティングの「液晶のレベルメータが動かない」を
    参照してください。
  • WAVE / MIDI デバイスを排他的に開く
    MP3 などを再生中に MIDI デバイスを閉じるかどうかを設定します。
    チェックを外すと、MIDI から MIDI 以外への曲の切り替えがスムーズになります。
    また、MIDI<==>MIDI 以外へのクロスフェードが出来るようになります。
    ただし VSC88, S-YXG50/100, WinGroove といったソフトウェア音源を
    使用している場合は、MIDI デバイスを閉じないと MP3 等を再生できなくなる
    可能性があります。(WAVE デバイスを開けなくなることがあるため)
    仮に再生は出来ても動作が不安定になる可能性があります。
    ソフトウェア音源を使用していない人だけがこのチェックを外すようにして下さい。
  • WaveMapper 使用時もクロスフェード有効
    チェックを入れると WaveMapper 使用時でもクロスフェードさせようとします。
    ただしサウンドカードのドライバによっては WaveMapper ではクロスフェード
    することが出来ません。DirectSound を使うとまともに再生されないけれど、
    クロスフェード機能は使いたいという人だけがお使いください。
    なおこのチェックを入れると、Windows 95/98 で ソフトウェア音源 (特に WinGroove) が
    インストールされている環境では動作が非常に不安定になるかもしれません。
    ソフトウェア音源をお使いの方はチェックをはずしておいた方が
    (DirectSound 使用時のみクロスフェードさせた方が) 無難です。
  • RealMedia 再生時に強制的に音量を最大
    ドライバによっては RealAudio / RealVideo を再生したときに、
    ボリュームコントロールの WAVE の音量が勝手に 0 にされてしまう
    不具合を回避するための設定です。チェックを有効にした場合、
    RealMedia を再生する度に WAVE の音量を強制的に最大にします。
    WAVE の音量が勝手に変更されるのがイヤな人はチェックを外してください。


Configure -Path1-

ツール(T)
環境設定(C) -検索パス1-

特定のファイルを演奏する際に必要なファイルを置く場所を設定することが出来ます。

外観 優先度 演奏設定 検索パス2 プラグイン その他 検索パス1

  • 歌詞ファイル
    歌詞ファイルの場所を指定します。指定された場所の下の階層をすべて検索します。
  • FPV
    一部の FPD(FM/FPD) の再生に必要な FPVの場所を指定します。
    指定された場所の下の階層をすべて検索します。
  • PDX
    一部の MDX(MDX/MDC) の再生に必要な PDXの場所を指定します。
    サブフォルダは検索しませんので、指定したフォルダにすべてまとめて入れてください。
  • DLS
    一部の Direct Music (SGT/SGP) の再生に必要な DLSの場所を指定します。
    サブフォルダは検索しませんので、指定したフォルダにすべてまとめて入れてください。
  • PAC
    一部の アルトラマリン(UM) の再生に必要な PACの場所を指定します。
    サブフォルダは検索しませんので、指定したフォルダにすべてまとめて入れてください。


Configure -Path2-

ツール(T)
環境設定(C) -検索パス2-

特定のファイルを演奏する際に必要なファイルを置く場所を設定することが出来ます。
cdplayer.ini の記述方法はこちらを参考にして下さい。

外観 優先度 演奏設定 検索パス1 プラグイン その他 環境設定

  • PVI
    一部の FMP (OPI/OVI/OZI) / PMD (M/M2/MZ/MP/MS) の再生に必要な
    PVI の場所を指定します。指定された場所の下の階層をすべて検索します。
  • cdplayer.ini
    音楽 CD のタイトルが記述されている cdplayer.ini の場所を指定します。
  • Muse.exe
    一部の Muse (MUS) の再生に必要な Muse.exeの場所を指定します。


Configure -Plugin-

ツール(T)
環境設定(C) -プラグイン-

KbMedia Player で認識されているプラグインの情報を一括してみる事ができ、
使用するプラグインを選択することが出来ます。
使用したくないプラグインがあれば、チェックを外してください。
拡張子が競合するプラグインが両方とも選択されている場合は、
上の方に表示されているものが使用されます。

外観 優先度 演奏設定 検索パス1 検索パス2 その他 プラグイン プラグイン


Configure -Others-

ツール(T)
環境設定(C) -その他-

外観 優先度 演奏設定 検索パス1 検索パス2 プラグイン その他

その他の設定です。
「Media エクスプローラ」では Media エクスプローラの挙動を
設定することが出来ます。詳しくはこちらをご覧下さい。
「表示」も同様です。

QuickTime は QuickTime の設定を KbMedia Player から変更ことが可能です。ただし、

  • QuickTime 設定」ダイアログを閉じる
  • KbMedia Player を再起動する

まで設定は反映されません。設定の中で KbMedia Player の動作に関係するのは、

  • ビデオ設定
  • サウンド出力
  • ミュージック

です。MOV 形式の再生が不安定な場合は「ビデオ設定」と「サウンド出力」を
変更してみてください。
「ミュージック」の設定は KbMedia Player の「デバイス設定」で
「QuickTime Music Synthesizer」を使用した場合の再生結果に影響します。
通常は「QuickTime ミュージック・シンセ」を選択します。詳しくはこちらをご覧下さい。


デバイス設定

出力デバイスの設定

KbMedia Player のデバイス設定ウインドウです。

ここでは、MIDI (MID/RMI/RCP/G36/R36/MDS) を再生するためのMIDI デバイスの設定と、
それ以外の形式 (MP3/WAV など) を再生するためのデバイスを設定します。

各設定はデバイスごとに保存することができ、デバイスの切り替えはこの画面の他にも
「ツール」メニューや、「デバイス設定」ボタン右側の▼でも行うことが出来ます。

WaveDevice の設定 Midi デバイス設定 デバイス設定

WaveOut/DirectSound の詳しい設定方法はこちら。
MIDI デバイスの詳しい設定方法はこちら。


WAVE デバイス設定

出力デバイスの設定
WaveOut/DirectSound の設定

KbMedia Player の WaveOut/DirectSound デバイス設定ウインドウです。
ここでは、WaveDevice の設定をします。

「デバイス設定」画面では、WaveOut/DirectSound デバイスごとに
個別に設定を保存することが出来ます。ここでの設定は少し高度です。
意味がよくわからない場合は、推奨設定値のまま変更しないで下さい。
24bit/32bit 出力は「安定性重視」か「音質重視」ボタンを押したときの設定にして下さい。
通常は「安定性重視」で問題ありません。「音質重視」にしても動作が重くなるだけで、
音質的な違いはほとんどありません。

ここで選択した WaveOut/DirectSound デバイスが
ソフトウェア音源を導入することで追加されたデバイスの場合、
音が鳴らない、または再生自体が出来ないことがあります。
そのような場合、ソフトウェア側の設定を見直してみてください。

各設定値の詳細は以下の通りです。

再生バッファサイズ 再生周波数 24bit/32bit 出力 安定性重視 音質重視 Midi デバイス設定 WAVE デバイス設定

  • 再生バッファサイズ (初期設定値 = 1000)
    WaveOut/DirectSound デバイスに渡すバッファのサイズを指定します。
    サイズが大きいほど音とびしにくくなりますが、シークや演奏開始、音量調節、
    エコー再生、再生速度変更等の応答が悪くなります。
    通常は 500～1500 が丁度良いと思います。
    音飛びを回避したい場合は、この設定と「ツール」→「環境設定」→
    「優先度」の「デコードスレッド」の設定を変えて調整して下さい。
  • 再生周波数 (初期設定値 = 0)
    プラグインに対して要求する再生周波数を指定します。
    プラグインが対応していれば、ここで指定した再生周波数で再生されます。
    元々 44100 Hz のデータを 48000 Hz にリサンプリングしたりするわけではありません。
    通常は 0 か 44100 を指定します。0 を指定した場合、プラグインのデフォルトの
    再生周波数で再生されます。多くの場合、0 を指定する場合が音質や
    パフォーマンスの面で最適な設定になります。
    音質を重視したい場合は 48000 を指定すると良いかもしれませんが、
    サウンドカードのドライバによっては却って音質が低下したり、
    再生できなくなってしまうことがあります。
  • 24bit/32bit 出力 (初期設定値 = 無効)
    量子化ビット数が 24bit/32bit のデータをどう扱うかを設定します。
    無効の場合は、プラグインが返した量子化ビット数が 24bit/32bit であっても、
    KbMedia Player 本体が内部的に 16bit に変換してから再生します。
    24bit/32bit 出力を有効にする場合は「詳細設定で設定」します。
    • 24bit/32bit 出力が有効な場合
      少し高度な設定を行うことになります。意味がわからない場合は、
      すべてのチェックを外すか、「音質重視」ボタンを押して最適な設定を
      自動検出するようにして下さい。24bit/32bit に対応しないデバイスで
      24bit/32bit のデータを再生する場合は、
      適切な形式に変換してから再生するようにしています。
      変換の仕方は以下の通りです。
      • 入力データが 32bit(INT) の場合
        • 1. 32bit FLOAT (WAVEFORMATEX)
        • 2. 32bit FLOAT (WAVEFORMATEXTENSIBLE)
        • 3. 32bit INT (WAVEFORMATEX)
        • 4. 32bit INT (WAVEFORMATEXTENSIBLE)
        • 5. 24bit INT (WAVEFORMATEX)
        • 6. 24bit INT (WAVEFORMATEXTENSIBLE)
        • 7. 16bit INT
      • 入力データが 24bit(INT) の場合
        • 1. 32bit INT (WAVEFORMATEX)
        • 2. 32bit INT (WAVEFORMATEXTENSIBLE)
        • 3. 24bit INT (WAVEFORMATEX)
        • 4. 24bit INT (WAVEFORMATEXTENSIBLE)
        • 5. 32bit FLOAT (WAVEFORMATEX)
        • 6. 32bit FLOAT (WAVEFORMATEXTENSIBLE)
        • 7. 16bit INT
      • 番号順にデバイスを開いて行き、オープンに成功した形式で再生する
      • チェックが外れている形式でのデバイスオープンは試みない。例えば、
        32bit INT (WAVEFORMATEX)
        に対応せず、
        32bit INT (WAVEFORMATEXTENSIBLE)
        と
        32bit FLOAT (WAVEFORMATEX)
        に対応するデバイスで 32bit データを再生する場合、通常は
        32bit INT (WAVEFORMATEXTENSIBLE)
        で再生される。これを
        32bit FLOAT (WAVEFORMATEX)
        の方で再生したい場合は 32bit INT (WAVEFORMATEXTENSIBLE) の
        チェックを外せば良い。
      • 実際にどの形式で再生しているかを知ることは出来ません。「音質重視」ボタン
        を押して最適な設定を検出したときに、チェックが無効になる形式での再生は
        行われませんので、それを参考にして下さい。
      • 24bit/32bit 出力設定が有効になっている場合、設定に応じてプラグインに
        出力ビット数を要求するようになります。例えば、32bit INT/FLOAT の
        設定のうち、少なくとも１つが有効になっている場合は、プラグインに対して
        32bit 出力を要求します。32bit INT/FLOAT のすべてが無効で、24bit INT の
        設定のうち少なくとも一方が有効ならば、プラグインに対して 24bit 出力を
        要求します。プラグインが要求されたビット数に対応していれば、要求された
        ビット数で出力され、通常の 16bit 出力の場合よりも音質がわずかに向上
        します。ただし、実際は聞き分けられるほどの差はありません。
      • 「音質重視」ボタンでチェックが無効になる形式での出力は出来ませんので、
        チェックを入れても無意味です。
  • 安定性重視
    再生周波数と 24bit/32bit 出力の設定を推奨設定値に戻します。
    サウンドカードのドライバとの相性問題が起こりにくく、
    音質とパフォーマンスのバランスが最も良い設定になります。
  • 音質重視
    選択されているデバイスを使用して、音質重視で再生したい場合の最適な
    設定を検出します。再生周波数と 24bit/32bit 出力の設定を最適値にします。
    最適な設定の検出をするためには、演奏を一度停止しなければなりません。
    サウンドカードやドライバによっては、他の音楽再生系アプリケーションが
    動作していると最適値の検出がうまくいかないことがありますので、
    出来るだけ他のソフトを終了してから検出を行って下さい。
    最適値の検出後、24bit/32bit 出力の設定でチェックが外れた形式での出力は
    出来ません。チェックが外れると同時にチェックを入れることも出来なくなります。
    すべてのチェックが外れている場合は、選択されているデバイスでは
    24bit/32bit での出力は出来ないことを意味します。

MIDI Device の設定はこちら。


MIDI デバイス設定

出力デバイスの設定
MIDI デバイスの設定

KbMedia Player の MIDI デバイス設定ウインドウです。
ここでは、MIDI (MID/RMI/RCP/G36/R36/MDS) を再生する際に
使用するデバイスの選択と、その設定をするためのウインドウです。

テンプレート名 使用ポート 音源リセット 遅延時間 midiOutResetを使う マルチデバイス再生 WaveDevice の設定 MIDIDeviceSetupImage

  • テンプレート名
    KbMedia Player 上で表示されるテンプレート名で、
    好きなテンプレート名に書き換えることができます。
  • 使用する音源ポート
    ご使用になる音源ポートを選んでください。
    Port-B, C, D、マルチポート対応のデータに対してのみ使用されるため、
    めったに使われることはありません。複数の音源をお持ちでなく
    ここの設定ができないとしても、ほとんど問題ありません。
  • 演奏開始時に送信するリセット
    • SYSTEM MODE SET:
      GM SYSTEM ON => GS RESET => SYSTEM MODE SET
    • GS RESET:
      GM SYSTEM ON => GS RESET
    のようにリセット系 SysEx を送信します。

    ただし、"SYSTEM MODE SET" を受信する音源に対してそれ以前に
    "GM SYSTEM ON" と "GS RESET" を送信しても、実際は無意味です。
    同じく "GS RESET" を受信する音源に対して "GM SYSTEM ON" を
    送信しても無意味です。

    "SYSTEM MODE SET ONLY" は文字通り "SYSTEM MODE SET" しか送信しません。
    お使いの音源が "SYSTEM MODE SET" を受信することがわかっている場合は
    "SYSTEM MODE SET ONLY" にした方が無駄なく音源リセットを送信しますので、
    演奏開始から発音まで要する時間が少し短くなります。
    さらに、再生位置を戻す処理も少しだけ速くなります。
    同じくお使いの音源が "GS RESET" を受信することがわかっていて
    かつ "SYSTEMMODE SET" は受信しないことがわかっているなら、
    "GS RESET ONLY" にした方が良いでしょう。

    この説明を読んでも意味がよくわからない人は "SYSTEM MODE SET" にして下さい。
    "SYSTEM MODE SET" を選択しておけばほとんどの音源を初期化できます。
  • 遅延時間
    これは音がデータ上でなっているはずの時間(液晶の表示)と、
    実際になっている時間とのずれを修正するものです。
    ソフトウェア音源使用時に設定して下さい。
    通常は 400ms 程度が丁度よいと思いますが、実際にはお使いの環境や
    ソフトウェア音源のドライバの設定によって最適な値は変わってきます。
    400ms が最適とは限りません。
  • midiOutReset を使う
    演奏停止時に midiOutReset を使うかどうか設定できます。
    環境によっては midiOutReset を使うときにシステムが 1～2 秒程度
    固まってしまうことがあります。そのような場合はチェックをはずしてみて下さい。
    チェックをはずせば、システムが固まることはなくなると思います。
    ただし、お使いの音源によっては演奏停止ボタンを押しても演奏が
    止まらなくなる可能性があります。特にデバイス名に
    「ＦＭシンセサイザー」といった文字列が含まれるものは怪しいです(^^;
  • マルチデバイス再生
    複数のポートに同じMIDI情報を同時に送信する機能です。
    1つの MIDI データを複数の音源で同時再生させるといったことが可能になります。

KbMedia Player は QuickTime Music Synthesizer や、Crescendo Forte LiveSynth を
使用して MIDI を再生することも可能です。
再生したい方はそれぞれの説明を読んで、適切なファイルを導入してください。

MIDI デバイスが複数ある方は、同じ事を他のテンプレートでもしてください。
最大で 8つ + 2 (QuickTime Music Synthesizer, Crescendo Forte LiveSynth) までです。

WaveDevice の設定はこちら。


Tool -Others-

ツール(T)
その他の設定(A)

その他のちょっとした設定です。
昔はレジストリを弄らなければ設定できなかったような項目群です。

M3U の保存形式(M)

M3U を保存するときにどのような形式で保存するかを設定します。

  • 拡張 M3U (E)
    WinAmp が出力する、拡張された M3U 形式です。
  • 相対パス (R)
    ファイルのパスを相対パスで記述します。
  • ドライブレター省略 (D)
    ファイルのパスをドライブレターを省略した形で記述します。
音量設定(V)
  • SPC (S)
    SPC に限り、再生時の音量の倍率を設定する事ができます。
  • 音量増幅(A)
    ここにチェックを入れると、ボリュームコントロールでの音量調節が
    0～100% から 0～200% の幅で出来るように拡張されます。
    ただし MIDI や 動画の音量は増幅できません。
ホットキー有効(H)

ここにチェックを入れるとホットキーで KbMedia Player を操作できるようになります。
キーの割り当ては以下のようになっています。

  • Ctrl+Shift+P : 演奏開始
  • Ctrl+Shift+H : 一時停止/再開
  • Ctrl+Shift+E : 演奏停止
  • Ctrl+Shift+F : フェードアウト
  • Ctrl+Shift+N : 次の曲
  • Ctrl+Shift+B : 前の曲
  • Ctrl+Shift+K : KbMedia Player をアクティブにする

これらは KbMedia Player が非アクティブ時でも機能します。
今のところキーの組み合わせは設定できませんし、追加することも出来ません。


Tool -STE-

ツール(T)
SuperTagEditor(T)

SuperTagEditor が導入されていれば、SuperTagEditor を起動します。


Tool -Volume Control-

ツール(T)
ボリュームコントロール(V)

システムのボリュームコントローラを開きます。


Tool -cdplayer.ini-

ツール(T)
cdplayer.ini(D)

cdplayer.ini を開きます。
cdplayer.ini の記述方法などはこちらを参考にして下さい。


Tool -Lyric-

ツール(T)
歌詞フォルダ(L)

検索パス1で設定された歌詞フォルダを開きます。


Tool -Device Select-

ツール(T)
WAVE Device(W) / MIDI Device(M)

デバイス設定で設定されたデバイス (テンプレート) のうち、
使用するデバイスを選択することが出来ます。


Help menu

ヘルプ(H)

目次 トラブルシューティング FAQ DLL プラグイン ドキュメント Kobarin のホームページ バージョン情報


Help -Contents-

ヘルプ(H)
目次(C)

KbMedia Player の HtmlHelp (このファイル) を表示します。


Help -FAQ-

ヘルプ(H)
FAQ(F)

HtmlHelp のFAQを表示します。


Help -DLL-

ヘルプ(H)
DLL(D)

HtmlHelp の本ソフトとは別に導入が必要なものについてのページを表示します。


Help -Plugin-

ヘルプ(H)
プラグイン(P)

HtmlHelp のプラグインについてのページを表示します。


Help -Document-

ヘルプ(H)
ドキュメント(D)

KbMedia Player の 各種ドキュメントを表示します。


Help -Kobarin's Home Page-

ヘルプ(H)
Kobarin のホームページ(K)

Kobarin のホームページを開きます。


Help -About-

ヘルプ(H)
バージョン情報(A)...

KbMedia Player の バージョン情報等を表示します。

本ソフトとは別に導入が必要なもののインストール状況やバージョン、
そして最新版の入手先などの情報も知ることができます。

バージョン情報


ウインドウ

KbMedia Player の各ウインドウについての説明です。

Media エクスプローラ 演奏リスト ドキュメント 小型化
  • Media エクスプローラ
    エクスプローラと同様の感覚でファイルを扱うことが出来ます。
    ただし移動や削除などを行うことは出来ません。
  • 演奏リスト
    演奏リストです。
  • ドキュメント
    現在演奏しているファイルに添付されているドキュメントを表示します。
  • 小型化
    kbMedia Player を小型化します。
  • ShrryWRD ウインドウ
    ShrryWRD を表示するウインドウです。


ウインドウ
Media エクスプローラ
演奏リスト ドキュメント 小型化 ドライブ お気に入り Media エクスプローラ Media エクスプローラ
Media エクスプローラに表示される情報
  • 名前
  • タイトル
  • アーティスト (MIDI の場合は著作権情報)
  • ファイルサイズ
  • 種類
  • 更新日時
  • 圧縮形式

カラムをクリックすることでソートすることも出来ます。
MIDI のタイトルと著作権情報は、処理速度を優先するためにあまり厳密に調べていません。
そのため、ごくまれに間違った情報を取得することがあります。

書庫ファイルやリストファイルの扱い

KbMedia Player では LZH/ZIP/LHA/RAR/CAB/GCA/TAR/TGZ/7Z のアーカイブ形式、
KBM/TO2/M3U のリスト形式に対応しており、それぞれフォルダと同じように扱います。
ただし、扱うことが出来るアーカイブのサイズには限界があります。(仕様です)
詳しくはこちらをご覧下さい。また書庫ファイル内の書庫ファイルを扱うことは出来ますが、
書庫ファイルの中の書庫ファイルの中の書庫ファイルにまでは対応していません。
さらに書庫ファイル内の書庫ファイルが 4MB を超えた場合は無視します。

その他の機能
  • ドライブへのショートカット
    ドライブのアイコンをクリックすると、各ドライブに直接飛ぶことが出来ます。
  • お気に入り
    よく使うフォルダなどをお気に入りとして登録しておくことが出来ます。
    「お気に入り」から「お気に入りの整理」を選択すると別のウインドウが開きますので、
    お気に入りに登録したいものをドラッグ & ドロップしてきて登録してください。
    アイテムを削除するにはキーボードから Delete です。
  • 対象フォルダに移動
    Alt を押したまま Media エクスプローラにファイルやフォルダをドラッグ & ドロップすると、
    対象のフォルダに移動します。
コンテキストメニューについて

このウィンドウ内で右クリックすると右のようなメニューが出ます。

再生 追加＋再生 追加 新規に追加 最新の情報に更新 エクスプローラ SuperTagEditor プロパティ 設定 ヘルプ
  • 再生(S)
    選択されたファイルを単曲再生します。
    選択されたものがフォルダやリスト、
    書庫ファイルの場合は表示されません。
  • 追加＋再生(P) Ctrl+Enter
    選択されたファイルを演奏リストに
    追加した上で演奏します。
    既に何らかの曲が演奏中の場合、演奏は
    選択されたファイルに切り替わります。
  • 追加(A) Shift+Enter
    選択されたファイルを演奏リストに追加します。
    演奏は開始されませんが、既に何らかのファイルが演奏中の場合、
    その演奏は継続されます。
  • 新規に追加(N) Shift+Ctrl+Enter
    現在の演奏リストを破棄し、選択されたファイルを演奏リストに追加します。
    演奏は開始されませんが、既に何らかのファイルが演奏中の場合、
    その演奏は継続されます。
  • 最新の情報に更新(R) F5
    Media エクスプローラのツリー構造を再構築します。
  • エクスプローラ(E) Alt+E
    選択されたファイルが存在するフォルダが開かれた状態のエクスプローラを開きます。
  • SuperTagEditor(T) Alt+T
    SuperTagEditor に選択されたファイルを渡します。
  • プロパティ(R) Alt+Enter
    選択されたファイルのプロパティを表示します。
    エクスプローラでプロパティを選択したものと同じです。
  • 設定(C)
    後述のサブメニューを開き、Media エクスプローラに関する設定をすることが出来ます。
  • ヘルプ(H)
    ヘルプの Media エクスプローラに関するページを開きます。このページのことです。

選択したファイルがフォルダやリストファイル、アーカイブだった場合、
メニューの上部は以下のように変化します。

追加＋再生 追加 新規に開く
  • 追加＋再生(P) Ctrl+Enter
    現在のリストに選択しているリストを追加し、
    なおかつ追加したリストのはじめから
    演奏します。現在あるリストの最初や、
    現在リストで選択しているファイルからではありません。
  • 追加(A) Shift+Enter
    現在のリストを破棄せず、現在のリストの最後に選択しているリストを
    追加する形で開きます。
  • 新規に開く(N) Shift+Ctrl+Enter
    現在のリストを破棄し、選択中のリストを新規で開きます。
Media エクスプローラの設定

コンテキストメニュー、または「ツール」=>「環境設定」=>「その他」=>「Media エクスプローラ」
から設定することが出来ます。

タイトル 圧縮ファイル 圧縮ファイルをフォルダのように表示 サブフォルダ内のデータを検索 行全体を選択 カラム幅の自動調整 新規に追加時確認 ダブルクリック時 初期設定に戻す
  • タイトル
    タイトルの取得の方法を選択します。
    • 常に取得
      通常ファイルと書庫ファイルの両方とも
      タイトルを取得します。
    • 通常ファイルのみ取得
      通常ファイルのみタイトルを取得し、
      書庫ファイル内の MIDI データの
      タイトルは取得しません。
    • 省略
      通常ファイル・書庫ファイルともに
      タイトルの取得しません。
  • 圧縮ファイル
    選択された書庫ファイルの中にあるデータを
    ファイル選択画面に表示するかどうかを設定します。
    また 「LZH/ZIP のみ検索する」 という事も出来ます。
  • 圧縮ファイルをフォルダのように表示
    圧縮ファイルをフォルダのように表示するようになります。
  • サブフォルダ内のデータを検索
    現在選択中のフォルダのサブフォルダまでファイルを検索して
    メディアエクスプローラに表示します。ただし検索するのは一階層下までです。
  • 行全体を選択
    これにチェックを入れると、ファイルを選択するときにファイル名だけではなく
    ファイルの列一列が選択対象になります。
  • カラム幅の自動調整
    これにチェックを入れると、ファイルを選択するウインドウのカラム幅を
    文字が途切れないように自動調整します。
  • 新規に追加時確認
    リストを破棄するような操作を行おうとしたとき、本当に現在のリストを
    破棄してよいかどうかの確認を求めるようになります。
  • ダブルクリック時

    ダブルクリックしたときにどのような動作をするかを設定します。
    それぞれの意味は各々の説明を参照してください。
  • 初期設定に戻す
    ここの設定項目を全て初期設定に戻します。
キーボードでの操作

Media エクスプローラではキーボードから以下の操作が可能です。

  • BackSpace
    一つ上の階層に移動します。
  • Insert
    現在演奏しているファイルが存在するフォルダに移動します。
  • Ctrl+Enter
    追加＋演奏
  • Shift+Enter
    追加
  • Shift+Ctrl+Enter
    新規に追加
  • F5
    最新の情報に更新
  • Alt+E
    選択されたファイルが存在するフォルダをエクスプローラで開きます。
  • Alt+T
    選択されたファイルを SuperTagEditor に渡します。
  • Alt+Enter
    選択されたファイルのプロパティを表示します。
追加＋再生 追加 新規に追加 最新の情報に更新 エクスプローラ SuperTagEditor プロパティ 設定 ヘルプ 再生 追加＋再生 追加 新規に追加 最新の情報に更新 エクスプローラ SuperTagEditor プロパティ 設定 ヘルプ


ウインドウ
演奏リスト
Media エクスプローラ ドキュメント 小型化 演奏リスト
演奏リストに表示される情報
  • タイトル
  • アーティスト (MIDI の場合は著作権情報)
  • 長さ
  • 種類
  • ファイル名

カラムをクリックすることでソートすることも出来ますし、ドラッグ & ドロップや
Alt+↑↓ でアイテムの並び替えも可能です。また、演奏リストにファイル名が重複する
データを複数個追加することは出来ません。追加時にすでに重複するデータが
存在していた場合は、既存のデータをリストから削除します。

MIDI のタイトルと著作権情報は、処理速度を優先するためにあまり厳密に調べていません。
そのため、ごくまれに間違った情報を取得することがあります。

ドラッグ & ドロップでのリスト登録

このウインドウにアイテムをドラッグ & ドロップすることでもリストの登録が可能ですが、
どのキーを押下しながらドラッグ & ドロップしたのかによって挙動が異なります。

  • Shift
    リストに追加します。
  • Ctrl
    リストに追加した上で演奏開始します。
  • Ctrl+Shift
    リストに新規に追加しますが、リストの破棄を確認するかどうかは
    Media エクスプローラの設定に従います。
  • 無し
    Media エクスプローラの「ダブルクリック時」の設定に従いますが、
    複数のファイルやディレクトリ、アーカイブなどがドロップされた場合は
    リストに追加＋演奏開始となります。
コンテキストメニューについて

このウィンドウ内で右クリックすると右のようなメニューが出ます。

削除 並び替え 曲長計算 検索 送る 単曲再生 連続再生 ランダム再生 メドレー再生 未再生の曲だけ再生 再生済みにする 未再生にする すべて未再生にする ヘルプ
  • 削除(D)

    • 選択範囲(D) Del
      現在選択されているアイテムをすべて削除します。
    • すべて(C) Ctrl+N
      現在の演奏リストを破棄します。
    • 存在しないデータ(E)
      演奏リストに登録されてはいるものの、
      現在は存在しないファイルを見つけ出し、
      リストから削除します。
  • 並び替え(S)

    演奏リストに登録されているアイテムをソートします。
    「登録順に設定」を選択すると、現在の並び順を新たな
    「登録順」として設定します。

  • 曲長計算(L)

    • 選択範囲(S) Shift+Enter
      現在選択中の曲の情報を調べ、結果を表示します。
    • 未計算データ(L) Ctrl+Enter
      リストにあるアイテムのうち曲長が計算されていないデータについての
      情報を取得し、結果を教示します。
    • すべて(A) Shift+Ctrl+Enter
      そのアイテムの曲長が計算済みかどうかに関わらず、
      すべてのデータについての情報を取得し、あるいはしなおして結果を表示します。
    • バックグラウンド(B)
      演奏しているバックグラウンドで曲の長さを計算するかどうかを設定します。
      • しない(N)
        バックグラウンドで曲の長さを計算しません。
      • 表示領域のみ(V)
        現在のリストに表示されている部分についてのみ
        バックグラウンドで計算します。表示されている部分とは、
        文字通り現在見えている部分についてのみです。
      • すべて(A)
        演奏リストにある未計算のアイテムを全てバックグラウンドで計算します。
  • 検索(F)

    • 演奏中の曲(V) Ins
      現在演奏されている曲を選択された状態にします。
  • 送る(N)

    • Media エクスプローラ(M) Alt+M
      そのファイルが置いてあるディレクトリを Media エクスプローラで開きます。
    • エクスプローラ(E) Alt+E
      そのファイルが置いてあるディレクトリをエクスプローラで開きます。
    • SuperTagEditor(T) Alt+T
      SuperTagEditor に対象のファイルを送ります。
    • プロパティ(R) Alt+Enter
      そのファイルのプロパティを開きます。

KbMedia Player では、以下のような演奏の仕方が可能です。

  • 単曲再生(A)
    指定した曲の演奏を終えた時点で演奏が止まります。
    リストの次の曲に移ったりすることはありません。
  • 連続再生(Q)
    リストに従って再生する、通常の演奏の仕方です。
  • ランダム再生(R)
    リストに登録されている曲をランダムに再生します。
  • メドレー再生(M)
    リストにある曲をクロスフェードしながら繋げて再生します。
    1曲あたりの演奏時間を設定する事ができます。詳しくはこちら。
    ただし「メドレー再生」が意味を持つのは、基本的にはクロスフェードが可能な形式と
    瞬間的なシークをサポートする形式のみです。(MP3/WMA など)
    MIDI や動画などのメドレー再生はあまり意味がありません。
  • 未再生の曲だけ再生(K)
    これにチェックを入れると、再生済みの曲は再生されなくなります。
    リスト中の曲が全て再生し終わると、全ての曲のチェックが外されます。
  • 再生済みにする(C)
    選択されたアイテムを再生済みの状態にします。
  • 未再生にする(U)
    選択されたアイテムを未再生の状態にします。
  • すべて未再生にする(F) F12
    リスト中のアイテムすべてを未再生の状態にします。
  • ヘルプ(H)
    ヘルプの演奏リストに関するページを開きます。このページのことです。
キーボードでの操作

演奏リストではキーボードから以下の操作が可能です。

  • Delete
    選択されたアイテムを削除します。
  • Ctrl+N
    リストを破棄します。
  • Shift+Enter
    選択されたアイテムの曲長を計算します。
  • Ctrl+Enter
    曲長が未計算なアイテムの曲長を取得します。
  • Shift+Ctrl+Enter
    リストに含まれるアイテム全ての曲長を計算しなおします。
  • Insert
    現在演奏中のアイテムを選択された状態にします。
  • Alt+M
    選択されたファイルが存在するフォルダを Media エクスプローラで開きます。
  • Alt+E
    選択されたファイルが存在するフォルダをエクスプローラで開きます。
  • Alt+T
    選択されたファイルを SuperTagEditor に渡します。
  • Alt+Enter
    選択されたファイルのプロパティを開きます。
  • Alt+↑↓
    選択されたアイテムを上下に移動します。
削除 並び替え 曲長計算 検索 送る 単曲再生 連続再生 ランダム再生 メドレー再生 未再生の曲だけ再生 再生済みにする 未再生にする すべて未再生にする ヘルプ


ウインドウ
ドキュメント
Media エクスプローラ 演奏リスト 小型化

再生するデータが置かれているディレクトリにあるドキュメントファイルを
以下のような順序で検索して表示します。

  • 1. ファイルに埋め込めるタイプのもの。
    • RCP の場合は RCP のメモ欄
    • MP3 の場合は LYRIC3 TAG v2.0 の内蔵歌詞
    • IT の場合はソングメッセージ
  • 2. file_id.diz
  • 3. ファイル名が同じで拡張子が hed/frm/nfo/txt/doc/ﾎｿｸ/log
  • 4. ディレクトリ名 (ディレクトリ階層がついていないアーカイブの場合は
    アーカイブファイル名) が同じで拡張子が hed/frm/nfo/txt/doc/ﾎｿｸ/log
  • 5. ファイル名が readme で拡張子が hed/frm/nfo/txt/doc/ﾎｿｸ/log
  • 6. 3～5以外で拡張子が hed/frm/nfo/txt/doc/ﾎｿｸ/log

1～6 までで見つかったファイルを、最大 8個まで読み込んで表示します。
3～5 までで 8個以上見つかった場合は、6 の検索処理は行いません。
ドキュメントに URI やメールアドレスが含まれていた場合は、
クリックすることでブラウザやメーラを起動することが出来ます。

制限事項

表示するファイルの大きさには制限があり、Windows 95/98/me では 32KB,
NT/2000/XP では 128KB までとなっています。
これは Windows の仕様の為です。95/98/me の仕様上は 64KB まで読めるはずですが、
念のため 32KB までに制限しています。Windows NT/2000/XP にはこのような
制限はありませんが、こちらも一応 128KB までに制限しています。

また MS-Word やワードパッドなどで作成された *.doc ファイルにはフォントなどの
書式情報が含まれているため、KbMedia Player では読めません。(読めないと表示されます)

カスタマイズ

表示するフォントやサイズ、色などをカスタマイズすることが出来ます。
「ツール」 => 「環境設定」 => 「外観」 から設定ウインドウを開くことが出来ます。
詳しくはこちらをご覧下さい。


ウインドウ
小型化

KbMedia Player の小型ウインドウです。

再生 再生速度変更 一時停止／再開 停止 前の曲 次の曲 エクスプローラ ボリュームコントローラ プロパティ デバイス設定 情報表示 シーク Media エクスプローラ 演奏リスト ドキュメント

液晶(パート) 液晶(色) 液晶(サイズ) 液晶(チャンネル番号) 液晶(スペアナ) 環境設定 デバイス設定 タスクトレイ ボリューム お気に入り WRD Media エクスプローラ


ウインドウ
Sherry WRD ウインドウ

KbMedia Player のSherry WRD ウインドウです。

Sherry WRD ウインドウ Sherry WRD コンテキストメニュー

このウインドウ上で右クリックすると右のようなメニューが表示されます。

  • 画面サイズ
    • 320x240 (0)
    • 480x360 (1)
    • 560x420 (2)
    • 640x480 (3)
    • 720x540 (4)
    • 800x600 (5)
    ウインドウのサイズを変更します。
  • 全画面(F)
    ウインドウのサイズを全画面にします。
  • メインウインドウ(M)
    KbMedia Player のメインウインドウを表示します。
    全画面表示を御使用中にご使用下さい。
  • タイトルバー(T)
    ウインドウのタイトルバーを表示するかを設定します。
  • 常に手前に表示(A)
    ウインドウを常に手前に表示するかどうかを設定します。
  • 閉じる(C)
    ウインドウを閉じます。
  • ヘルプ(H)
    このページを開きます。


導入から応用まで
演奏を始める前に

KbMedia Player をダウンロードして、すぐにでも演奏を始めようと思っている方も
多いかもしれません。KbMedia Player は初期設定のままでも問題なく使用できるように
配慮されていますが、設定しておけばより便利に使用できるものがいくつかあります。
どんな設定があるのかわからない。あるのはわかったけれど、どう設定すればいいのか
わからない。そんな方はこの章を読んでみて下さい。

  • 出力デバイスの設定
  • アーカイブの取り扱い
  • 外部ファイルが必要となる形式
  • Media エクスプローラの設定
  • その他の設定
演奏してみよう

以上の設定がすんだら、いよいよ演奏です。

  • いろいろな再生方法
  • ショートカットキー
応用編
  • タグを書き換えよう
  • KbMedia Player に関連付けしよう
  • コマンドラインオプションを使ってみよう


演奏を始める前に
出力デバイスの設定

演奏を始める前にまずしなくてはいけないこと。それは出力デバイスの設定です。
KbMedia Player で再生する際に、どのデバイスを使用して再生するのかを設定します。

デバイス設定 メニューの「ツール」から「デバイス設定」を選択するか、
左のアイコンをクリックして以下の設定画面を表示させてください。

WaveDevice の設定 Midi デバイス設定 デバイス設定

そうしたらこちらを参考にして設定を済ませてください。
面倒であれば初期設定のままでも構いません。

設定が済んだら、PCM データを再生するためのデバイスを選択します。
WaveOut と DirectSound 以下に列挙されているもののうち、
KbMedia Player で使用したいデバイスを選び、「開く」をクリックしてください。
同じデバイスが WaveOut と DirectSound の両方に列挙されていることと思いますが、
ここでは DirectSound の方を選択しておきましょう。
WaveOut と DirectSound というのは、内部的な演奏方法の違いです。特に問題がない限り、
(少なくとも KbMedia Player を使用する上で) WaveOut で再生するメリットは何もありません。

同様にして MIDI を再生するデバイスも設定してください。

ここに列挙されている Default を選択すると、「マルチメディアのプロパティ」の
オーディオタブで設定されているデバイスが使用されます。
コントロールパネルから開くか、KbMedi Player の「ファイル」メニューの
「マルチメディアのプロパティ」から確認することが出来ます。

マルチメディアのプロパティ


演奏を始める前に
アーカイブの取り扱い
対応形式

KbMedia Player ではアーカイブも扱うことができ、扱える形式は以下の通りとなります。

  • LZH/LHA
  • ZIP/MDZ/S3Z/XMZ/ITZ/NEO
  • CAB
  • RAR
  • GCA
  • TAR
  • 7Z
必要とする DLL

一部の ZIP を扱いたい場合には DLL が必要となります。

通常の ZIP を扱う際には DLL は必要ないと考えて構いませんが、
パスワードつきであったり、圧縮メソッドが Stored/Deflate/Implode/Shrunk 以外である
ZIP アーカイブを扱う際には DLL が必要となります。
このような ZIP アーカイブを扱いたい場合は、shoda T. 氏が製作された
UNZIP32.DLL が必要となります。以下のサイトで入手してください。
http://www.csdinc.co.jp/archiver/

アーカイブを扱う上での制限

KbMedia Player で扱えるアーカイブのサイズには上限があります。
メモリ上に展開しているため、大きすぎるアーカイブを扱うと危険だからです。
詳しくはこちらをご覧下さい。


演奏を始める前に
外部ファイルが必要となる形式

再生したい形式によっては、同梱されているもの以外の DLL などが必要な場合があります。
再生したい形式が、同梱されているファイル以外のものを必要とするかどうかを
以下の表を使って確かめてみましょう。

拡張子 | 担当プラグイン | 必要とする外部ファイル
669 | kbmod.kpi | 無し
AIF | kbdshow.kpi | Windows Media Player 6.4 or later
AIFC | kbdshow.kpi | Windows Media Player 6.4 or later
AIFF | kbdshow.kpi | Windows Media Player 6.4 or later
AMF | kbmod.kpi | 無し
AMS | kbmod.kpi | 無し
APE | kbmac.kpi | 無し
ASF | kbmov.dll | Windows Media Player 6.4 or later
AU | kbdshow.kpi | Windows Media Player 6.4 or later
AVI | kbmov.dll | 対応するコーデック
AY | nezplug.kpi | 無し
BGM | in_msx.kpi | KINROU5.DRV
BGR | in_msx.kpi | KINROU5.DRV
BME | bmse.kpi | 無し
BMS | bmse.kpi | 無し
C64 | sidplay.kpi | 無し
CDA | Kbmplay.exe | 無し
CPC | nezplug.kpi | 無し
CSTR | kbcstr.dll | PsxMC
CYM | m_s98.kpi | リズム音源の WAVE データ
DBM | kbmod.kpi | 無し
DSM | kbmod.kpi | 無し
EMS | bmse.kpi | 無し
FAR | kbmod.kpi | 無し
FLAC | kbflac.kpi | 無し
FM | kbfpd.kpi | FPV ファイル
FPD | kbfpd.kpi | FPV ファイル
G36 | Kbmplay.exe | RCPCV.DLL
GBR | nezplug.kpi | 無し
GBS | nezplug.kpi | 無し
GYM | m_gym.kpi | 無し
HES | nezplug.kpi | 無し
IT | kbmod.kpi | 無し
J2B | kbmod.kpi | 無し
KSS | nezplug.kpi | 無し
LQT | kbmov.dll | Real Player 8 or later
M | kbpmd.kpi | PMDWIN.DLL 他
M1V | kbmov.dll | 無し
M2 | kbpmd.kpi | PMDWIN.DLL 他
MDC | mxdrvg.kpi | PDX
MDL | kbmod.kpi | 無し
MDS | Kbmplay.exe | 無し
MDX | mxdrvg.kpi | PDX
MED | kbmod.kpi | 無し
MGS | in_msx.kpi | 無し
MID | Kbmplay.exe | 無し
MIO | kbmio.kpi | 無し
MLD | Kbmplay.exe | MID_MLD.EXE
MOD | kbmod.kpi | 無し
MOV | kbmov.dll | QuickTime
MP | kbpmd.kpi | PMDWIN.DLL 他
MP+ | kbmpp.kpi | 無し
MP1 | kbmad.kpi / kbmp3.kpi | 無し
MP2 | kbmov.dll | 無し
MP3 | kbmad.kpi / kbmp3.kpi | 無し
MPA | kbmov.dll | 無し
MPC | kbmpp.kpi | 無し
MPE | kbmov.dll | 無し
MPEG | kbmov.dll | 無し
MPG | kbmov.dll | 無し
MPK | in_msx.kpi | MPK.BIN / MPK103.BIN
MPV2 | kbmov.dll | 無し
MS | kbpmd.kpi | PMDWIN.DLL 他
MT2 | kbmod.kpi | 無し
MTM | kbmod.kpi | 無し
MUS | Kbmplay.exe | MUSE.EXE
MYM | m_s98.kpi | リズム音源の WAVE データ
MZ | kbpmd.kpi | PMDWIN.DLL 他
NEZ | nezplug.kpi | 無し
NSD | nezplug.kpi | 無し
NSF | nezplug.kpi | 無し
NSZ | nezplug.kpi | 無し
OGG | kbvorbis.kpi | 無し
OGM | Kbmplay.exe | 対応するコーデック
OKT | kbmod.kpi | 無し
OPI | kbfmp.kpi | WINFMP.DLL 他
OPX | in_msx.kpi | OPX4KSS.BIN
OVI | kbfmp.kpi | WINFMP.DLL 他
OZI | kbfmp.kpi | WINFMP.DLL 他
PMD | Kbmplay.exe | MID_MLD.EXE
PMS | bmse.kpi | 無し
PSM | kbmod.kpi | 無し
PTM | kbmod.kpi | 無し
QCP | kbqcp.kpi | 無し
QT | kbmov.dll | Quick Time
R36 | Kbmplay.exe | RCPCV.DLL
RA | kbmov.dll | Real Player 8 or later
RCP | Kbmplay.exe | RCPCV.DLL
RM | kbmov.dll | Real Player 8 or later
RMI | Kbmplay.exe | 無し
RMJ | kbmov.dll | Real Player 8 or later
RMP | kbmad.kpi / kbmp3.kpi | 無し
S3M | kbmod.kpi | 無し
S98 | m_s98.kpi | リズム音源の WAVE データ
SAP | m_sap.kpi | 無し
SGP | Kbmplay.exe | DirecxX 8.0 or later / DLS
SGT | Kbmplay.exe | DirecxX 8.0 or later / DLS
SID | sidplay.kpi | 無し
SND | kbdshow.kpi | Windows Media Player 6.4 or later
SP[0-9] | kbspc.kpi | 無し
SPC | kbspc.kpi | 無し
SSL | m_gym.kpi | 無し
STR | kbcstr.dll | PsxMC
SWF | kbswf.dll | Macromedia Flash Player
TSD | kbtss.kpi | 無し
TSS | kbtss.kpi | 無し
ULT | kbmod.kpi | 無し
UM | kbum.kpi | PAC ファイル
UMX | kbmod.kpi | 無し
VGM | m_s98.kpi | リズム音源の WAVE データ
VGZ | m_s98.kpi | リズム音源の WAVE データ
VIV | kbviv.dll | Vivo Active Player
VQF | kbtvq.kpi | 無し
WAV | kbdshow.kpi | Windows Media Player 6.4 or later
WMA | kbdshow.kpi | Windows Media Player 6.4 or later
WMV | Kbmplay.exe (kbmov.dll) | Windows Media Player 6.4 or later
WV | kbwv.kpi | 無し
X1F | m_s98.kpi | リズム音源の WAVE データ
XM | kbmod.kpi | 無し
ZMD | Kbmplay.exe | ZtoM/Z2M3
ZMS | Kbmplay.exe | ZMC2/ZMC3/ZtoM/Z2M3


必要となる外部ファイル
RCPCV.DLL

Recomposer MIDI File (RCP/G36/R36) を再生するために必要です。
動作確認が取れているバージョンは 1.12 です。
パスの通ったディレクトリに置いてください。
http://hp.vector.co.jp/authors/VA010012/


必要となる外部ファイル
Windows Media Player 6.4 or later

Windows Media (ASF/WMA/WMV) や、DirectShow を利用して再生を行う形式
(WAV/WMA/AIF/AIFF/AIFC/AU/SND) の再生に必要となります。
Windows95/98/NT4.0 に標準で搭載されている「メディアプレイヤー」とは
別物ですので、ご注意下さい。Version 7 以降の導入を推奨します。
動作確認が取れているバージョンは 8.00.00.4487 であり、
それより古いバージョンでは再生できない可能性があります。
http://www.microsoft.com/japan/windows/windowsmedia/download/


RealPlayer 8 or later

必要となる外部ファイル
Real Player 8 or later

Real Media (RA/RM/RMJ) および Liquid Audio (LQT) を再生するために必要となります。
Basic 版で OK です。Plus 版を導入する必要はありません。
Version 6.0.9.1762 以降で確認していますが、Real Player 8 以降を強く推奨します。
Real Player 8 よりも古いバージョンでは再生できない可能性があります。
http://www.jp.real.com/

Liquid Audio を再生するためには Real Player だけではなく、
プラグインをインストールする必要があります。LQT ファイルを Real Playerで
再生しようとすれば、自動的にダウンロードが開始されるはずです。
残念ながらネット環境にない方はこの方法ではインストールできません。

LQT のファイルは
http://www.liquidaudio.com/
にいくつかあります。


必要となる外部ファイル
Quick Time

QuickTime Movie (QT/MOV) を再生するために必要となります。
動作確認が取れているバージョンは 6.0.2 です。
それよりも古いバージョンでは再生できない可能性があります。
http://www.apple.co.jp/quicktime/


FPV ファイル

必要となる外部ファイル
FPD98.DLL

FPD (FM/FPD) を再生するために (kbfpd.kpi の動作に) 必要となります。
2003/05/18 現在の最新バージョンが同梱されています。
kbfpd.kpi の仕様上、同梱のとは異なるバージョンの fpd98.dll では
正常動作しない可能性がありますので、同梱のより新しいバージョンの
fpd98.dll が公開されていたとしても、dll は差し替えない方が良いかもしれません。

fpd98sub.dll

KYU 氏制作の fpd98sub.dll を導入することにより、FPD の演奏時間を
取得出来るようになり、無限ループにも対応出来ます。
kbfpd.kpi に最初から同梱されています。

最新の fpd98sub.dll は
http://www.platz.jp/~kyu/
にあります。
FPD98 や開発キットに同梱されている fpd98sub.dll では動作しません。

fpd98sub.dll がない場合、表示上の演奏時間は KbMedia Player の設定の
「デフォルトの曲の長さ」になります。
(実際には２回だけループした後、演奏終了します)

fpd98sub.dll は kbfpd.kpi と同じディレクトリから動かさないで下さい。
kbfpd.kpi と同じフォルダに置かないと動作しません。

FPV ファイル

FPD/FM ファイルを再生するために FPV ファイルが必要になることがあります。
必要な FPV ファイルは FPD/FM ファイルと同じフォルダに置くか、
専用の FPV フォルダに置いて下さい。FPV フォルダは KbMedia Player の
「環境設定」 => 「検索パス1」 で設定することが出来ます。
http://www.rat.co.jp/fpd98/
にある FPD98 本体をインストールした後、FPD98 のインストールフォルダに作成される

  • PCM95
  • PCM97

フォルダにある FPV ファイル群が必要となるデータが多いです。
少なくともこの２つのフォルダは必ず FPV フォルダに置いて下さい。

FPV フォルダはサブフォルダも検索します。階層は無限です。
例えば

  • C:\PcmDir\FPV\PCM95
  • C:\PcmDir\FPV\PCM97

のように
C:\PcmDir\FPV\
の下に PCM95/PCM97 のフォルダをコピーしておき、KbMedia Player の設定では
FPVフォルダを
C:\PcmDir\FPV\
のように設定しておけば良いです。


必要となる外部ファイル
WINFMP.DLL

FMP (OPI/OVI/OZI) を再生するために必要です。
kbfmp.kpi と同一のディレクトリ、Kbmplay.exe と同一のディレクトリ、
システムフォルダのいずれかに置いてください。WINFMP.DLL がない場合、
KbMedia Player 本体は kbfmp.kpi をプラグインとして認識しません。
また、WINFMP.DLL は出来るだけ最新バージョンをお使い下さい。
動作確認されているバージョンは 0.05 で、Version 0.03 未満は認識しません。 http://www.fmp.jp/~c60/

PVI ファイル

データによっては PVI ファイルを要求します。
お持ちでない方は以下のサイトからダウンロードしてください。
http://www.iris.dti.ne.jp/~wanis/
PVI ファイルは自由な場所において結構です。こちらで設定することが出来ます。

リズム音源の WAVE データ

リズム音源である以下のファイルをお持ちの方は、Plugins\fmpmd\ に置いてください。
今のところこれ以外の場所は検索しません。

  • 2608_BD.WAV
  • 2608_HH.WAV
  • 2608_RIM.WAV
  • 2608_SD.WAV
  • 2608_TOM.WAV
  • 2608_TOP.WAV


必要となる外部ファイル
PMDWIN.DLL

PMD (M/M2/MZ/MP/MS) を再生するために必要です。
kbpmd.kpi と同一のディレクトリ、Kbmplay.exe と同一のディレクトリ、
システムフォルダのいずれかに置いてください。PMDWIN.DLL がない場合、
KbMedia Player 本体は kbpmd.kpi をプラグインとして認識しません。
また、WINFMP.DLL は出来るだけ最新バージョンをお使い下さい。
動作確認されているバージョンは 0.19 で、Version 0.16 未満は認識しません。 http://www.fmp.jp/~c60/

PVI ファイル

データによっては PVI ファイルを要求します。
お持ちでない方は以下のサイトからダウンロードしてください。
http://www.iris.dti.ne.jp/~wanis/
PVI ファイルは自由な場所において結構です。こちらで設定することが出来ます。

リズム音源の WAVE データ

リズム音源である以下のファイルをお持ちの方は、Plugins\fmpmd\ に置いてください。
今のところこれ以外の場所は検索しません。

  • 2608_BD.WAV
  • 2608_HH.WAV
  • 2608_RIM.WAV
  • 2608_SD.WAV
  • 2608_TOM.WAV
  • 2608_TOP.WAV


必要となる外部ファイル
Macromedia Flash Player

Shockwave Flash (SWF) を再生するために必要となります。
動作確認が取れているバージョンは 6.0.47.0 です。
それより古いバージョンでは再生できない可能性があります。
http://sdc.shockwave.com/jp/software/downloads/


必要となる外部ファイル
Vivo Active Player

Vivo Active (VIV) を再生するために必要です。
動作確認が取れているバージョンは 2.1.0.0 です。
それより古いバージョンでは再生できない可能性があります。
http://www.real.com/vivo/


必要となる外部ファイル
MUSE.EXE

Muse (MUS) を再生するために必要となります。
動作確認が取れているバージョンは 4.6 (更新日時 : 2002/09/04 00:46:48) です。
Kbmplay.exe と同じディレクトリや、システムフォルダに置いただけでは認識しません。
[ツール] -> [環境設定] を開いたのち検索パス 2 のタブを選択し、
MUSE.EXE の場所を設定してください。
http://village.infoweb.ne.jp/~atomic/


DirecxX 8.0 or later / DLS

必要となる外部ファイル
DirecxX 8.0 or later

Direct Music (SGT/SGP) の再生のために必要となります。
動作確認が取れているバージョンは DirectX 9.0 (4.09.00.0901) です。
DirectX はアンインストール及びバージョンダウンが出来ません。
システムに与える影響も大きいため、導入の際は慎重に行ってください。
http://www.microsoft.com/japan/windows/directx/

DLS

一部の SGT/SGP は再生する際に DLS ファイルを要求します。
「ツール」->「環境設定」->「検索パス1」 で置き場所を設定できます。


必要となる外部ファイル
着メロコンバータ (MID_MLD.EXE)

着メロ関係の形式 (MLD/PMD) の再生のために必要となります。
Kbmplay.exe と同じフォルダに置いて下さい。
現在のところ試験的な対応となっており、正式に対応するかどうかは未定です。
http://coolweb.kakiko.com/kana2/


必要となる外部ファイル
PsxMC

PlayStation のムービー (CSTR/STR) の再生のために必要となります。
シェアウェア版とフリーウェア版のどちらでも構いません。
PsxMC を適当なフォルダに解凍した後に起動すれば、以後は KbMedia Player が
PsxMC のパスを自動認識して CSTR/STR が再生可能になります。
http://homepage2.nifty.com/~mkb/


必要となる外部ファイル
ZMC2/ZMC3/ZtoM/Z2M3

ZMUSIC 形式の MIDI データ (ZMS/ZMD) を再生できるようになります。
ただし再生できるのは MIDI だけで、内蔵音源を使用するデータには対応していません。
さらにこのソフトを導入することにより拡張される機能は動作保証対象外です。
各ソフトウェアは以下のような役割を果たします。

  • ZMC2
    Z-MUSIC V2 の ZMS を ZMD にコンバートする。
  • ZtoM
    Z-MUSIC V2 の ZMD を MID にコンバートする。
  • ZMC3
    Z-MUSIC V3 の ZMS を ZMD にコンバートする。
  • Z2M3
    Z-MUSIC V3 の ZMD を MID にコンバートする。

ZtoM/Z2M3 は ZMC2/ZMC3 の上位互換となっていますが、
Z-MUSIC V2 では ZMC2/ZMC3 を使うことが推奨されています。


必要となる外部ファイル
リズム音源の WAVE データ

リズム音源である以下のファイルをお持ちの方は、
m_s98.kpi と同じディレクトリに置いてください。
今のところこれ以外の場所は検索しません。

  • 2608_BD.WAV
  • 2608_HH.WAV
  • 2608_RIM.WAV
  • 2608_SD.WAV
  • 2608_TOM.WAV
  • 2608_TOP.WAV


必要となる外部ファイル
PAC ファイル

アルトラマリンの再生に必要な PCM ファイル（PAC ファイル）は、
アルトラマリンのデータと同じフォルダに置くか、または専用の検索フォルダに置いて下さい。
検索フォルダは KbMedia Player の「環境設定」 => 「検索パス1」で設定することが出来ます。
最新の umut.dll は
http://www7.big.or.jp/~suppoko/
で入手可能ですが、kbum.kpi の仕様上同梱されているのとは異なる
バージョンのumut.dll では動作しない可能性があります。
出来るだけ同梱されているumut.dll をそのままお使い下さい。
もしファイルを差し替える場合は、umut.dll は kbum.kpi と同じフォルダに置いて下さい。


必要となる外部ファイル
対応するコーデック

AVI/OGM を再生するためには、対応するコーデックがシステムにインストールされている
必要があります。動画部分と音声部分を圧縮する方法はたくさんあり、
再生したいファイルに対応するコーデックがシステムに無いと再生することが出来ません。

コーデックとは通訳のようなものです。圧縮されているデータをもとに戻してくれるのです。
ファイルには何語で話せばいいのかは書いてありますが、それを理解できる人が
システムにいなければならないのです。
「AVI を再生できます」 というのは、「地球語を話せます」 と言っているようなものです。
日本語、英語、ドイツ語、フランス語の通訳しかいないところに
ロシア語で話し掛けられても、理解できる人がいなければ会話は出来ません。
そうしたらどうするか。ロシア語の通訳をつれてくるわけですね。
これが 「コーデックをインストールする」 ということです。

世の中にコーデックはたくさんあり、どれを入れれば再生できるようになるかまでは
こちらではわかりませんが、恐らくこれであろうと思われるものを挙げておきます。

DivX : http://www.divx.com/divx/

OGM の場合、動画部分は XviD を使用しているのが普通です。
XviD : http://xvid.hopto.org/


必要となる外部ファイル
PDX

一部の MDX は再生する際に PDX ファイルを要求します。
「ツール」->「環境設定」->「検索パス1」 で置き場所を設定できます。


必要となる外部ファイル
ドライバファイル

MPK, BGM, BGR, OPX を演奏するには、ドライバファイルが別途必要です。

  • BGM/BGR を再生するためには KINROU5.DRV が必要です。
    IN_MSX.KPI と同じフォルダに置いて下さい。
    KINROU5.DRV の入手先は以下の通りです．
    http://www.interq.or.jp/white/white/fswold/music.html
  • MPK を再生するためには MPK.BIN, MPK103.BIN が必要です。
    IN_MSX.KPI と同じフォルダに置いて下さい。
    MPK の入手先は以下の通りです。
    http://mu.ice.uec.ac.jp/~kokubun/xray/mpk.html
  • OPX を再生するためには OPX4KSS.BIN が必要です。
    IN_MSX.KPI と同じフォルダに置いて下さい。
    OPX4KSS の入手先は以下の通りです。
    http://mika1000.tripod.co.jp/
  • OPX4KSS に加えて FMPAC.ROM を配置すると、OPX の演奏再現度が
    上がります。FMPAC.ROM の入手法に関しては一切お答えする事は
    できませんので、あしからずご了承ください。
    FMPAC.ROM が無い場合、拡張音色は全て PSG 風の音で再生されます。


演奏を始める前に
Media エクスプローラの設定

KbMedia Player は、基本的には Media エクスプローラからファイルを選択して演奏したり、
演奏リストに追加して再生するという形をとります。ここでは頻繁に使うであろう
Media エクスプローラの設定をすることにしましょう。
Media エクスプローラについて詳しく知りたい方は、こちらをご覧ください。

Media エクスプローラの表示
  • 行全体を表示
    これにチェックを入れると、ファイルを選択するときにファイル名だけではなく
    ファイルの列一列が選択対象になります。使いやすいほうを選んでおきましょう。
  • カラム幅の自動調整
    これにチェックを入れると、ファイルを選択するウインドウのカラム幅を
    文字が途切れないように自動調整します。
  • タイトル
    タイトルの取得の方法を選択します。お好きなものを選んでください。
    ただし、常に取得 > 通常ファイルのみ取得 > 省略 の順に時間がかかります。
  • 圧縮ファイル
    検索する設定にすると、一覧の中にアーカイブ中のファイルも表示されるようになります。
    ただしアーカイブを扱うためにそれ相応の時間がかかります。「LZH/ZIP のみ検索する」
    ということもできますので、使用方法に合わせて選択してください。
  • 圧縮ファイルをフォルダのように表示
    圧縮ファイルをフォルダのように表示するようになります。
    使いやすいほうを選択してください。
  • サブフォルダ内のデータを検索
    現在選択中のフォルダのサブフォルダまでファイルを検索して
    メディアエクスプローラに表示します。ただし検索するのは一階層下までです。
    このオプションを有効にした場合、例えばカレントディレクトリが C:\foo\ の場合は
    C:\foo\bar2.mp3, C:\foo\bar3.mp3, C:\foo\bar\baz2.mp3 などは表示されますが、
    C:\foo\bar1\baz1\quux2.mp3,C:\foo\bar1\baz1\quux3.mp3 などは表示されません。
    サブフォルダ内のデータを検索
それ以外の設定
  • 新規に追加時確認
    リストを破棄するような操作を行おうとしたとき、本当に現在のリストを
    破棄してよいかどうかの確認を求めるようになります。
    確認がわずらわしい場合はオフにしてください。
  • ダブルクリック時
    Media エクスプローラ上でファイルなどをダブルクリックしたときに、
    どのような挙動を取るかを設定します。使いやすい方を選んでください。
お気に入りの設定

KbMedia Player では、Internet Explorer のような「お気に入り」を設定することができます。
よく使うフォルダを登録しておくと便利です。

赤で囲まれた場所をクリックすると、
青で囲まれた部分が出てきます。
現在はまだ何も登録されていないので、
「お気に入りの整理(O)...」しか
表示されていません。
とりあえずはこれをクリックしてください。

右のようなボックスが出たら、ここに登録したいフォルダを Media エクスプローラからドラッグ & ドロップしてください。

ここでは
C:\Windows\Media\
を登録してみます。
ここではひとつしか登録していませんが、必要な分だけ登録してください。アイテムを削除したいときはキーボードから Delete で削除できます。

登録ウインドウを閉じて 「お気に入り」を
クリックすると、先ほど登録した
C:\Windows\Media\ が
追加されていることがわかります。
これをクリックすると、登録したフォルダが
Media エクスプローラのカレントになります。


演奏を始める前に
その他の設定

演奏するために必要な設定ではありませんが、KbMedia Player を便利に使うために
ぜひとも設定しておきましょう。

表示項目の設定

以下の三つは「表示」メニュー、もしくはメインウインドウのコンテキストメニューから
設定することができます。

  • タスクトレイ
    タスクトレイに KbMedia Player のアイコンを表示するかどうかをを設定します。
    タスクトレイのアイコンをクリックしてできることは以下の通りです。
    • 元のサイズに戻す(R) / 最小化(M)
    • 終了(X)
    • Media エクスプローラ(M)
    • 再生(P)
    • 一時停止／再開(H)
    • 停止(E)
    • フェードアウト(F)
    • 次の曲(N)
    • 前の曲(B)
    タスクトレイのアイコンをクリックすると、上記のメニューの他に
    現在再生中のデータに関する情報を表示します。
    表示される内容は液晶の右にあるものと一緒です。
  • ボリューム
    ボリュームコントロール
    ボリュームコントロールを表示するかどうかを設定します。
    ここにチェックを入れていると、ボリュームコントロールを用いて
    ボリュームを変更することが出来ます。
    ただしボリューム調整に対応しないデータを再生中は、
    ボリューム調整トラックバーの下にある数字が淡色表示されます。

    • ボリュームを変更すると、タイトルバーに現在の音量が１秒間表示されます。
    • 下の数字をクリックすると標準値(100)に戻すことが出来ます。
    • その他の設定で音量増幅機能を使用する設定にしていると、
      0 ～ 200% までの間で音量を設定する事ができます。
      ただし MIDI や 動画の音量は増幅できません。
  • お気に入り
    Media エクスプローラのお気に入りを表示するかどうかを設定します。
    お気に入りの登録の仕方はこちらをご覧ください。
    お気に入り
ホットキー

設定でホットキーを有効にしておくと非常に便利です。
「ツール」->「その他の設定」->ホットキー有効
で設定できますので、オンにしておきましょう。
キーバインドは以下のとおりです。

  • Ctrl+Shift+P : 演奏開始
  • Ctrl+Shift+H : 一時停止/再開
  • Ctrl+Shift+E : 演奏停止
  • Ctrl+Shift+F : フェードアウト
  • Ctrl+Shift+N : 次の曲
  • Ctrl+Shift+B : 前の曲
  • Ctrl+Shift+K : KbMedia Player をアクティブにする

これらは KbMedia Player が非アクティブ時でも機能しますが、
今のところキーの組み合わせは設定できませんし、追加することも出来ません。


演奏してみよう
いろいろな再生方法
演奏方法

KbMedia Player では、以下のような演奏の仕方が可能です。

  • 単曲再生(A)
    指定した曲の演奏を終えた時点で演奏が止まります。
    リストの次の曲に移ったりすることはありません。
  • 連続再生(Q)
    リストに従って再生する、通常の演奏の仕方です。
  • ランダム再生(R)
    リストに登録されている曲をランダムに再生します。
  • メドレー再生(M)
    リストにある曲をクロスフェードしながら繋げて再生します。
    1曲あたりの演奏時間を設定する事ができます。詳しくはこちら。
    ただし「メドレー再生」が意味を持つのは、基本的にはクロスフェードが可能な形式と
    瞬間的なシークをサポートする形式のみです。(MP3/WMA など)
    MIDI や動画などのメドレー再生はあまり意味がありません。

自分が選んだ曲を一曲ずつ再生していきたい場合は、「単曲再生」 にチェックを
入れておきましょう。ただ、「単曲再生」 は少々特殊な扱いをしています。
「単曲再生」が有効なときは常に単曲再生モードで再生するのですが、無効なときでも、

  • Media エクスプローラ上で 「再生(S)」 で選曲した場合
  • 「ダブルクリック時」 の設定が 「リストに追加しないで再生」 のときに
    • ファイル単体をドラッグアンドドロップした場合
    • ファイル単体をコマンドライン or DDE 起動し、/a が指定されていない場合
  • ファイル単体をコマンドライン or DDE 起動し、/na が指定されている場合

の場合には自動的に「単曲再生」モードに切り替わるようになっています。
ですので、Media エクスプローラから一曲ずつ再生していくような場合には
わざわざ「単曲再生」にチェックを入れる必要はありません。

リピート
  • 単曲リピート
    現在演奏中の曲を繰り返し演奏します。
    画面をクリックしないと進まないようなタイプの SWF をきちんと再生するには、
    ここにチェックを入れる必要があります。
  • リピート
    リストの曲をすべて再生し終わってしまったときに、また最初から演奏しなおします。
クロスフェード

KbMedia Player では、曲を切り替えるときにクロスフェードを行うことができます。
「演奏」メニューから 「切り替え時にクロスフェード」、「終了時にクロスフェード」に
チェックを入れてください。二つの違いは以下のとおりです。

  • 切り替え時にクロスフェード
    ここで言う曲の切り替えとは、その曲の再生が終了して演奏リストの次の曲を
    演奏することではなく、次の曲や前の曲、またはリストアップされた曲目の
    ダブルクリックなどによって次の曲を再生しようとしたときのことです。
    この切り替えが行われるときにクロスフェードを試みます。
  • 終了時にクロスフェード
    曲の終了時にクロスフェードを試みます。曲の終了時とは現在の曲の演奏が終了し、
    演奏リストの次の曲を演奏しようとするときを指します。
    この切り替えが行われるときにクロスフェードを試みます。

クロスフェードとは別に、現在の曲をフェードアウトさせることができます。
「演奏」メニューから「フェードアウト」を選ぶか、Ctrl+F を押下してください。
フェードインやフェードアウトの時間は、「ツール」->「環境設定」->「演奏設定」 から可能です。
詳しくはこちらをご覧ください。

エコー

エコー 左図のアイコンの右側の矢印をクリックすることで、エコーをかけることが出来ます。
ただしエコーをかけられるのはプラグインを使用して再生する形式に限ります。

再生速度変更

再生速度変更 左図のアイコンの右側の矢印をクリックすることで、
再生速度を変更することが出来ます。
ただし MIDI 再生時とその他を再生しているときでは設定できる倍率は異なり、
以下のようになっています。

MIDI ： 0.25, 0.5, 0.6, 0.7, 0.8, 0.9, 0.95, 1.0, 1.05, 1.1, 1.2, 1.3, 1.5, 2.0, 3.0
その他 : 0.5, 0.6, 0.7, 0.75, 0.8, 0.9, 0.95, 1.0, 1.05, 1.1, 1.2, 1.25, 1.3, 1.5, 2.0

テンポを変更すると、アイコンの色が変わります。
そのまま再生速度を変更すると音程も一緒に変わって
しまいますが、「音程を変えずに速度を変更」にチェックを
入れることで音程はそのままで再生速度だけ変更することが
出来ますが、その代わりにかなりの CPU パワーを喰います。
ご自身のマシンに合わせてクオリティを選んでください。

簡易エミュレーション

エコー MIDI 再生時は、左図のアイコンの右側の矢印をクリックすることで
簡易エミュレーションを使用することができます。
バンクセレクトを無視したり、** MAP に固定したりすることができます。
推奨音源と使用音源が異なる場合などにご使用ください。

現在再生中の曲がフェードアウトする一方で、
次の曲がフェードインしながら曲が切り替わる方式のことです。


演奏してみよう
ショートカットキー

KbMedia Player ではさまざまな機能にショートカットキーが割り当てられています。
すべてを覚える必要はありませんが、よく使う機能は覚えておいて損はないでしょう。

ホットキー

ホットキーはデフォルトではオンになっていません。詳しくはこちら。
KbMedia Player がアクティブじゃなくても動作します。

  • Ctrl+Shift+P : 演奏開始
  • Ctrl+Shift+H : 一時停止/再開
  • Ctrl+Shift+E : 現在再生している曲を停止する
  • Ctrl+Shift+F : 現在の曲をフェードアウトする
  • Ctrl+Shift+N : 次の曲を再生する
  • Ctrl+Shift+B : 前の曲を再生する
  • Ctrl+Shift+K : KbMedia Player をアクティブにする
メニューのショートカットキー

KbMedia Player のメニューに対するショートカットキーです。

  • Ctrl+O : リストファイルを開く
  • Ctrl+S : リストファイルを上書き保存
  • Ctrl+P : 再生
  • Ctrl+H : 一時停止/再開
  • Ctrl+E : 現在再生している曲を停止する
  • Ctrl+F : 現在の曲をフェードアウトする
  • Alt+Right : 次の曲を再生する
  • Alt+Left : 前の曲を再生する
  • F11 : WRD ウインドウを表示する
  • F12 : Media エクスプローラを表示する
  • F5 : 最新の情報に更新する
  • F1 : 状況に応じたヘルプファイルを表示します
テンキーでの操作

KbMedia Player は操作パネルだけでなく、テンキーからでもある程度の
操作が出来るようになっています。キーアサインは以下の通りです。

7 : 5秒戻る | 8 : 音量を 5上げる | 9 : 5秒進む
4 : 前の曲 | 5 : 演奏開始 | 6 : 次の曲
1 : 未定義 | 2 : 音量を 5下げる | 3 : 未定義
Media エクスプローラ

Media エクスプローラではキーボードから以下の操作が可能です。

  • BackSpace : 一つ上の階層に移動します。
  • Insert : 現在演奏しているファイルが存在するフォルダに移動します。
  • Ctrl+Enter : 現在のアイテムを「追加＋演奏」します
  • Shift+Enter : 現在のアイテムを追加します
  • Shift+Ctrl+Enter : 現在のアイテムを新規に追加します
  • F5 : Media エクスプローラのツリー構造を再構築します
  • Alt+E : 選択されたファイルが存在するフォルダをエクスプローラで開きます
  • Alt+T : 選択されたファイルを SuperTagEditor に渡します
  • Alt+Enter : 選択されたファイルのプロパティを表示します
演奏リスト

演奏リストではキーボードから以下の操作が可能です。

  • Delete : 選択されたアイテムを削除します。
  • Ctrl+N : リストを破棄します。
  • Shift+Enter : 選択されたアイテムの曲長を計算します。
  • Ctrl+Enter : 曲長が未計算なアイテムの曲長を取得します。
  • Shift+Ctrl+Enter : リストに含まれるアイテム全ての曲長を計算しなおします。
  • Insert : 現在演奏中のアイテムを選択された状態にします。
  • Alt+M : 選択されたファイルが存在するフォルダを Media エクスプローラで開きます。
  • Alt+E : 選択されたファイルが存在するフォルダをエクスプローラで開きます。
  • Alt+T : 選択されたファイルを SuperTagEditor に渡します。
  • Alt+Enter : 選択されたファイルのプロパティを開きます。
  • Alt+↑↓ : 選択されたアイテムを上下に移動します。


応用編
タグを書き換えよう

KbMedia Player では MP3 などのタグを書き換えることはできませんが、
外部ソフトとの連携が出来るようになっています。

  • mp3infp (T-Matsuo 氏製作)
    • プロパティから MP3/WAV/VQF などの詳細情報表示や、
      タグ情報の書き換えが出来ます。
    • Version 2.0 以降を導入すれば、MP3 の ID3v2 のタグ情報の
      書き換えも出来るようになります。
    動作確認が取れているバージョンは 2.32.3.0 です。
    http://www.win32lab.com/
  • Super Tag Editor (MERCURY 氏製作)
    • エクセル風の操作性で MP3/WMA 等のタグ情報書き換えが出来ます。
    • SuperTagEditor (以下 STE) を導入すると、KbMedia Player の
      Media エクスプローラの右クリックメニューの「SuperTagEditor 起動」や、
      演奏リストの右クリックメニューの「送る」で STE と連携が出来るようになります。
    • STE を一度でも実行すれば、KbMedia Player は自動的に
      STE のインストール場所を認識します。
    • Kobarin 氏による STE の改造版もあります。
      2001/12/31 現在公開中の版では本家の STE の機能をすべて含み、
      OggVorbis/WAV/AVI/SPC 対応している点が異なります。
    http://www5.wisnet.ne.jp/~mercury/

mp3infp はインストールするだけで KbMedia Player からも使用できるようになります。
Super Tag Editor は STE を一度でも起動すれば、KbMedia Player は自動的に
STE のパスを認識します。KbMedia Player で使用する前に一度起動しておいてください。


応用編
KbMedia Player に関連付けしよう
簡単な関連付け

KbMedia Player は Media エクスプローラから再生していくような
つくりになっておりますので、関連付けしてもあまりメリットはありませんが、
関連付けしたい方のために説明しておきます。

関連付けするいちばん簡単な方法は、「アプリケーションから開く」 を使う方法です。
関連付けしたいファイルを Shift を押下しながら右クリックしてください。
すると 「アプリケーションから開く」 という項目があると思いますので、
それを選択してください。ファイルタイプによっては 「アプリケーションから開く」 の
サブメニューである 「プログラムの選択」 を選ぶ必要があるかもしれません。

目的のダイアログボックスを開いたら、
「これらのファイルを開くときは、いつもこのアプリケーションを使う」
にチェックを入れ、「その他」 から KbMedia Player を選択してください。

この方法は簡単ですが、どちらかといえば次の方法を推奨します。

右クリックから開く

エクスプローラで対象のファイルを右クリックしたときに、
「KbMedia Player で開く」を追加する方法です。
以下の画像と手順は Windows Me のものなので、適宜読み替えてください。

エクスプローラから 「ツール」->「フォルダオプション」->「ファイルの種類」 とたどり、
以下のウインドウを表示させてください。

フォルダオプション

続いて 「詳細設定」 をクリックし、以下のウインドウを表示させてください。

ファイルの種類の編集

さらに 「新規」 をクリックし、出てきたウインドウに以下のように入力しましょう。

新しいアクション

画像ではアクションの名前を 「KbMedia Player で開く」 としていますが、
自分で表示させたいように設定してください。
また Kbmplay.exe のパスにスペースを含む場合、パスを 「""」 で囲ってください。
そしてその後ろにスペースをひとつ入れ、「"%1"」と追加してください。
これで OK をクリックすればアクションに 「KbMedia Player で開く」 が追加されます。

ダブルクリックしたときに KbMedia Player で開くようにするには
(通常よく言われる関連付けですね)、「KbMedia Player で開く」 のアクションを
選択した状態で、「規定値に設定」 をクリックしてください。
「KbMedia Player で開く」 が太字で表示されれば OK です。
元に戻したければ、以前太字であったアクションを選択して規定値に設定すれば OK です。


応用編
コマンドラインオプションを使ってみよう

KbMedia Player にはコマンドライン引数を与えることが出来ます。
コマンドライン引数をうまく用いれば、ショートカットからの起動や、
関連付けで今以上に便利に扱うことが出来ると思います。

与えられる引数の詳細はこちらをご覧ください。
DDE の XTYP_EXECUTE とコマンドライン引数の書式は共通となっています。

例えば起動したときに前回開いていたファイルを再生し、
さらにタスクトレイに格納するには、以下のようにします。

ショートカットのプロパティ

単純にあるリストファイルを再生したいのであれば、
"C:\Program Files\Kbmplay\Kbmplay.exe" default.kbm
のようにすればそのリストが読み込まれ、再生が始まります。

他にも関連付けしたファイルを再生はせずに、渡されたファイルを選択した状態で
Media エクスプローラにタブを切り替えるなんてことも出来ます。

新しいアクション

ここで

"C:\Program Files\Kbmplay\Kbmplay.exe" /mx:"%1"

とすれば実現することが出来ます。これに加えて再生もしたい場合は、

"C:\Program Files\Kbmplay\Kbmplay.exe" /p "%1" /mx:"%1"

さらにリストにも追加したい場合は

"C:\Program Files\Kbmplay\Kbmplay.exe" /p /a "%1" /mx:"%1"

とすれば実現できます。
引数をうまく使うことでいろいろなことが出来ると思いますので、ぜひご活用ください。


各種プラグインについて

KbMedia Player に同梱されているプラグインの紹介と解説です。

  • Kobarin
    • fmpmd
    • kbdshow
    • kbflac
    • kbfpd
    • kbmac
    • kbmad
    • kbmio
    • kbmod
    • kbmp3
    • kbmpp
    • kbqcp
    • kbtss
    • kbtvq
    • kbum
    • kbvorbis
    • kbwv
  • Mamiya
    • kpibmse
    • kpigym
    • kpimdx
    • kpis98
    • kpisap
    • kpisidplay
    • nezplug
  • [OK]
    • in_msx
  • S.Kino
    • kbspc
Pluginsディレクトリ以下に KbMedia Player のプラグインを置きます。
プラグインを導入することにより、さらに多くのファイル形式を再生できるようになります。

プラグインの拡張子は *.KPI で、ファイル名は任意です。
頭に KB がついているものが多いですが、つける必要はありません。

プラグインのディレクトリは階層を持つことが出来ますが、検索するのは２階層下までです。

例えば、

\Plugins\foo.kpi
\Plugins\foo\bar.kpi
\Plugins\foo\bar\baz.kpi

は検索対象になりますが、

\Plugins\foo\bar\baz\quux.kpi

は検索しません。

標準では、プラグインは作者ごとにフォルダ分けして置かれています。

Kobarin 以下にあるのは Kobarin 氏が作成したものです。
Mamiya 以下にあるのは Mamiya 氏が作成したものです。
OK 以下にあるのは [OK] 氏が制作したものです。
S_Kino 以下にあるのは木下菫氏が作成したものです。

実際は Plugins 以下で２階層下までであれば、どこに置いてもかまいません。

認識されているプラグインの一覧は「ツール」メニューの「環境設定」の
プラグインタブで見ることができ、使用するプラグインを選択することも出来ます。
拡張子が競合するプラグインが両方とも選択されている場合は、
上の方に表示されているものが使用されます。

万が一プラグインが認識されない場合は、Kbmplay.exe と同じフォルダにある
plugin.dat を削除後、KbMedia Player を起動し直して下さい。
あるいは、プラグインに同梱のドキュメントを読み、
必要な DLL がインストールされているかどうか確かめて下さい。

プラグインをバージョンアップした場合は、
出来るだけ古いプラグインは削除するようにして下さい。

不具合報告や要望は、プラグインの作者にして下さい。
ただし、KBSPC.KPI の不具合報告や要望は Kobarin 氏宛てで構いません。

なお、プラグインの数が増えても、KbMedia Player の起動時間やメモリ使用量、
実行速度は基本的にはほとんど変わりません。
プラグインをたくさん導入したからといって動作が重くなることはありません。

ただし例外的に、プラグインが依存する DLL が導入されていない場合は
起動時間が少し長くなることがあります。

これを回避したい場合は、必要な DLL を導入するか、プラグインを削除して下さい。
一度でもロードに成功したプラグインは、plugin.dat に登録され、次回起動時からは
plugin.dat を参照し、プラグインが本当に必要になるまではロードしません。
対応拡張子
  • kbfmp.kpi
    OPI/OVI/OZI
  • kbpmd.kpi
    M/M2/MZ/MP/MS
PC9801 関係のサウンド形式を再生するためのプラグインです。
対応拡張子 : WAV/WMA/AIF/AIFF/AIFC/AU/SND
Direct Show 経由でファイルを再生するためのプラグインです。
対応拡張子 : FLAC
FLAC (Free Lossless Audio Codec) を再生するためのプラグインです。
対応拡張子 : APE
Monkey's Audio を再生するためのプラグインです。
対応拡張子 : MP1/MP2/MP3/RMP
MAD (MPEG audio decoder) をベースにした MP3 デコーダプラグインです。
対応拡張子 : MIO
MIO (Music Interleaved and Orthogonal transformed format) を
再生するためのプラグインです。
対応拡張子 : MOD/S3M/XM/IT/MDL/669/AMF/AMS/DBM/
DSM/FAR/J2B/MED/MT2/MTM/OKT/PSM/PTM/ULT/UMX
MOD を再生するためのプラグインです。
対応拡張子 : MP1/MP2/MP3/RMP
MPEG Audio を再生するためのプラグインです。
対応拡張子 : MP+/MPC
MPEGplug を再生するためのプラグインです。
対応拡張子 : TSS/TSD
T'SoundSystem を再生するためのプラグインです。
対応拡張子 : VQF
TwinVQ を再生するためのプラグインです。
対応拡張子 : OGG
Ogg Vorbis を再生するためのプラグインです。
対応拡張子 : WV
WavPack を再生するためのプラグインです。
対応拡張子 : BMS/BME/EMS/PMS
BMS ファイルを再生するためのプラグインです。
対応拡張子 : GYM/SSL
メガドライブ以前の家庭向け SEGA ハードの
サウンドを再生するためのプラグインです。
対応拡張子 : MDX/MDC
MDX と一部の MDC を再生するためのプラグインです。
MIDI を使用する MDC 等は再生できません。
対応拡張子 : S98/CYM/MYM/X1F/VGM/VGZ
S98/CYM/MYM/X1F/VGM/VGZ を
再生するためのプラグインです。
対応拡張子 : SAP
Atari XE/XL の音源を再現する SAP フォーマットを
再生するためのプラグインです。
対応拡張子 : SID/C64
コモドール 64(C64) の音源を再現する
SID フォーマットを再生するためのプラグインです。
対応拡張子 : NSF/NSZ/NEZ/NSD/KSS/GBR/GBS/HES/AY/CPC
NSF などを再生するためのプラグインです。
対応拡張子 : MGS/MPK/BGM/BGR/OPX
MSX 関係のサウンドを再生するためのプラグインです。
対応拡張子 : SPC/SP[0-9]
SPC (スーパーファミコンのサウンドファイル形式)を
再生するためのプラグインです。
対応拡張子 : FPD/FM
FPD 形式を再生するためのプラグインです。
対応拡張子 : QCP
au 携帯の着声ファイル（QCP）を再生するためのプラグインです。
対応拡張子 : UM
アルトラマリン(UltraMarine) 再生プラグインです。


各種プラグインについて
Kobarin

Kobarin 氏が作成されたプラグインについてです。
以下のプラグインに対する不具合報告や要望は Kobarin 氏宛てにお願いします。

Kobarin : hidkob@pb.highway.ne.jp
http://home7.highway.ne.jp/Kobarin/

  • fmpmd
  • kbdshow
  • kbflac
  • kbfpd
  • kbmac
  • kbmad
  • kbmio
  • kbmod
  • kbmp3
  • kbmpp
  • kbqcp
  • kbtss
  • kbtvq
  • kbum
  • kbvorbis
  • kbwv
対応拡張子
  • kbfmp.kpi
    OPI/OVI/OZI
  • kbpmd.kpi
    M/M2/MZ/MP/MS
PC9801 関係のサウンド形式を再生するためのプラグインです。
対応拡張子 : WAV/WMA/AIF/AIFF/AIFC/AU/SND
Direct Show 経由でファイルを再生するためのプラグインです。
対応拡張子 : FLAC
FLAC (Free Lossless Audio Codec) を再生するためのプラグインです。
対応拡張子 : APE
Monkey's Audio を再生するためのプラグインです。
対応拡張子 : MP1/MP2/MP3/RMP
MAD (MPEG audio decoder) をベースにした
MP3 デコーダプラグインです。
対応拡張子 : MIO
MIO (Music Interleaved and Orthogonal transformed format) を
再生するためのプラグインです。
対応拡張子 : MOD/S3M/XM/IT/MDL/669/AMF/AMS/DBM/
DSM/FAR/J2B/MED/MT2/MTM/OKT/PSM/PTM/ULT/UMX
MOD を再生するためのプラグインです。
対応拡張子 : MP1/MP2/MP3/RMP
MPEG Audio を再生するためのプラグインです。
対応拡張子 : MP+/MPC
MPEGplug を再生するためのプラグインです。
対応拡張子 : TSS/TSD
T'SoundSystem を再生するためのプラグインです。
対応拡張子 : VQF
TwinVQ を再生するためのプラグインです。
対応拡張子 : OGG
Ogg Vorbis を再生するためのプラグインです。
対応拡張子 : WV
WavPack を再生するためのプラグインです。
対応拡張子 : FPD/FM
FPD 形式を再生するためのプラグインです。
対応拡張子 : QCP
au 携帯の着声ファイル（QCP）を再生するためのプラグインです。
対応拡張子 : UM
アルトラマリン(UltraMarine) 再生プラグインです。


fmpmd

この Plugins\fmpmd\ 以下には、
PC9801 関係のサウンド形式 (FMP/PMD) を再生するためのプラグインである

  • KBFMP.KPI
  • KBPMD.KPI

が置いてあります。
リズム音源の WAVE データである、

  • 2608_BD.WAV
  • 2608_HH.WAV
  • 2608_RIM.WAV
  • 2608_SD.WAV
  • 2608_TOM.WAV
  • 2608_TOP.WAV

をお持ちの方は、このディレクトリに置いて下さい。
現在はこれらのデータの置き場所を指定することは出来ません。

PVI ファイルの方は設定することが出来ます。詳しくはこちらをご覧下さい。
データによっては PVI ファイルを要求しますので、
お持ちでない方は以下のサイトからダウンロードしてください。
http://www.iris.dti.ne.jp/~wanis/


kbfmp

KBFMP.KPI Version 1.08
製作者 : Kobarin & 木下 菫 / 対応拡張子 : OPI/OVI/OZI

FMP を再生するためのプラグインです。
元々は木下菫氏が製作したものですが、現在は Kobarin 氏が開発を引き継いでいます。

KBFMP.KPI を使うためには、C60 氏制作の WINFMP.DLL が必要です。
C60 氏のページでダウンロードして下さい。
http://www.fmp.jp/~c60/

WINFMP.DLL は KBFMP.KPI と同じディレクトリ、Windows システムフォルダ、
Kbmplay.exe と同じディレクトリのいずれかに置いてください。WINFMP.DLL がない場合、
KbMedia Player 本体は KBFMP.KPI をプラグインとして認識しません。

WINFMP.DLL は出来るだけ最新バージョンをお使い下さい。
Version 0.03 未満は認識しません。動作確認されているバージョンは 0.05 です。

更新履歴
Version 1.08(2003/04/13)
  • winfmp.dll がなくてもプラグインが認識されるようにした。
    (DLL がない状態での起動時間の短縮のため)
  • ファイルサイズが小さくなった。
Version 1.07(2002/06/16)
  • kmp_GetTestModule が複数回呼ばれると
    WINFMP.DLL の解放が正しく行われなくなるのを修正。
  • 再生周波数要求に対する応答に関する修正。以下のような感じ。
    • 修正前
      if(dwSamplesPerSec != 48000 && dwSamplesPerSec != 22050){
      dwSamplesPerSec = 44100;
      }
    • 修正後
      if(dwSamplesPerSec >= 48000){
      dwSamplesPerSec = 48000;
      }
      else if(dwSamplesPerSec >= 44100){
      dwSamplesPerSec = 44100;
      }
      else if(dwSamplesPerSec >= 22050){
      dwSamplesPerSec = 22050;
      }
      else{
      dwSamplesPerSec = 44100;
      }
Version 1.06(2002/06/10)
  • 本体からの再生周波数要求に対応。(22050Hz, 44100Hz, 48000Hz のみ)
Version 1.05(2000/11/12)
  • MSVCRT.DLL に依存しなくなった。(C ランタイムを一切使わないようにした)
Version 1.04(2000/04/07)
  • PVI の検索パスが指定されていない状態だと落ちるバグを修正。
Version 1.03(2000/04/02)
  • PVI の検索パス指定に対応。(本体で「環境設定」で設定変更した場合、
    反映されるのは新しいファイルを開いてからです)
  • インストールされている WINFMP.DLL のバージョンがわかるようにした。
    (本体の「プラグイン情報」)
Version 1.02(2000/01/22)
  • WINFMP.DLL Version 0.03 (COM 風インターフェース) に対応。
  • WINFMP.DLL Version 0.02 未満は認識しないようになった。
  • クロスフェード時にプロセス間通信をする必要がなくなった。
Version 1.01(2000/11/06)
  • DLL の初期化処理がまずかったのを修正。
Version 1.0(2000/08/23)
  • 木下さんに代わって私(Kobarin) が開発を引き継ぐ。
  • WINFMP.DLL を動的にロードするようにした。
  • FMP→FMP にクロスフェードできなかったのを修正。
  • KbMedia Player で「単曲リピート」の設定になっている場合は
    無限ループさせるようにした。(KBSPC.DLL と基本的に同じ)
  • 実際は再生可能なのにエラーとして扱うことがあった
    (fmp_load の戻り値がエラーではなく警告を示すもの) のを修正。
  • PPZ8パートの一次補間を有効にするようにした。(元々有効だったかも)
  • KBFMP.DLL と同じディレクトリにあるリズム音源を読み込むようにした。
Version 0.0(2000/6/13)
  • 初版 (木下菫氏が開発)


kbpmd

KBPMD.KPI Version 1.08
製作者 : Kobarin & 木下 菫 / 対応拡張子 : M/M2/MZ/MP/MS

PMD を再生するためのプラグインです。
元々は木下菫氏が製作したものですが、現在は Kobarin 氏が開発を引き継いでいます。

KBPMD.KPI を使うためには、C60 氏制作の PMDWIN.DLL が必要です。
C60 氏のページでダウンロードして下さい。
http://www.fmp.jp/~c60/

WINFMP.DLL は KBFMP.KPI と同じディレクトリ、Windows システムフォルダ、
Kbmplay.exe と同じディレクトリのいずれかに置いてください。WINFMP.DLL がない場合、
KbMedia Player 本体は KBFMP.KPI をプラグインとして認識しません。

WINFMP.DLL は出来るだけ最新バージョンをお使い下さい。
Version 0.16 未満は認識しません。動作確認されているバージョンは 0.19 です。

更新履歴
Version 1.08(2003/04/13)
  • pmdwin.dll がなくてもプラグインが認識されるようにした。
    (DLL がない状態での起動時間の短縮のため)
  • ファイルサイズが小さくなった。
Version 1.07(2002/06/16)
  • kmp_GetTestModule が複数回呼ばれると
    PMDWIN.DLL の解放が正しく行われなくなるのを修正。
  • 再生周波数要求に対する応答に関する修正。以下のような感じ。
    • 修正前
      if(dwSamplesPerSec != 48000 && dwSamplesPerSec != 22050){
      dwSamplesPerSec = 44100;
      }
    • 修正後
      if(dwSamplesPerSec >= 48000){
      dwSamplesPerSec = 48000;
      }
      else if(dwSamplesPerSec >= 44100){
      dwSamplesPerSec = 44100;
      }
      else if(dwSamplesPerSec >= 22050){
      dwSamplesPerSec = 22050;
      }
      else{
      dwSamplesPerSec = 44100;
      }
Version 1.06(2002/06/10)
  • 本体からの再生周波数要求に対応。(22050Hz, 44100Hz, 48000Hz のみ)
Version 1.05(2000/11/12)
  • MSVCRT.DLL に依存しなくなった。(C ランタイムを一切使わないようにした)
Version 1.04(2000/04/07)
  • PVI の検索パスが指定されていない状態だと落ちるバグを修正。
Version 1.03(2000/04/02)
  • PVI の検索パス指定に対応。(本体で「環境設定」で設定変更した場合、
    反映されるのは新しいファイルを開いてからです)
  • インストールされている PMDWIN.DLL のバージョンがわかるようにした。
    (本体の「プラグイン情報」)
Version 1.02(2000/01/22)
  • PMDWIN.DLL Version 0.17 (COM 風インターフェース) に対応。
  • PMDWIN.DLL Version 0.17 未満は認識しないようになった。
  • クロスフェード時にプロセス間通信をする必要がなくなった。
Version 1.01(2000/11/06)
  • DLL の初期化処理がまずかったのを修正。
Version 1.0(2000/08/23)
  • 木下さんに代わって私(Kobarin) が開発を引き継ぐ。
  • PMDWIN.DLL を動的にロードするようにした。
  • PMD→PMD にクロスフェードできなかったのを修正。
  • KbMedia Player で「単曲リピート」の設定になっている場合は
    無限ループさせるようにした。(KBSPC.DLL と基本的に同じ)
  • 実際は再生可能なのにエラーとして扱うことがあった
    (music_load の戻り値がエラーではなく警告を示すもの) のを修正。
  • PPSパート、P86パート、PPZ8パートの一次補間を有効にするようにした。
  • KBPMD.DLL と同じディレクトリにあるリズム音源を読み込むようにした。
Version 0.0(2000/6/12)
  • 初版 (木下菫氏が開発)


kbdshow

KBDSHOW.KPI Version 1.15
製作者 : Kobarin / 対応拡張子 : WAV/WMA/AIF/AIFF/AIFC/AU/SND

WAV/WMA/AIF/AIFF/AIFC/AU/SND を再生するためのプラグインです。
このプラグインを使用するためには、Windows Media Player 6.4 以降が必要です。
できれば Version 7.1 以降の導入を推奨します。

デフォルトでは WAV/WMA/AIF/AIFF/AIFC/AU/SND を再生しますが、
これ以外にも再生したい拡張子がある場合は、KBDSHOW.KPI と同じディレクトリにある
KBDSHOW.INI を書き換えることで対応することが出来ます。
KBDSHOW.INI は KbMedia Player が KBDSHOW.KPI をロードすると自動的に作成されます。

ただしなんでも再生できるようになるわけではなく、
適切な Direct Show フィルタが導入されている必要があります。

例えば拡張子 AC3 が再生できる環境にある場合には、

[KBDSHOW]
SupportExt=WAV/WMA/AIF/AIFF/AIFC/AU/SND/AC3

のように記述します。

KbMedia Player の「ツール」->「環境設定」->「プラグイン」で
新しく追加した拡張子が正しく認識されたかどうかを確認することが出来ます。

ただし、設定の変更が反映されるのは次にプラグインをロードしたときです。
本体を再起動しただけでは反映されません。
確実に反映させるには KbMedia Player を終了し、Kbmplay.exe と同じディレクトリにある
plugin.dat を削除してから KbMedia Player を起動します。

Direct Show を使用して WMA を再生する場合、再生速度を速くすると音とびしたり、
シーク処理に時間がかかることがあります。
KBWMA.DLL を使用するようにすることでこの問題を回避することが出来ますが、
著作権で保護された形式の WMA は再生することが出来ません。
また、動作が不安定になる可能性があります。
KBWMA.DLL で再生できない場合は、通常通り Direct Show を用いて再生します。
KBWMA.DLL を用いて再生したい場合は、UseKbWMA=1 として下さい。

更新履歴
Version 1.15(2003/01/21)
  • 作成した ini ファイルをメモ帳で開くとコメント (セミコロンで始まる行) に
    改行が入らないのを修正。(CR LF とするべきところを LF しか入れてなかった)
Version 1.14(2003/01/14)
  • 24 bit データを再生するとノイズになるバグを修正。
  • kbwma.dll の Windows Media Format SDK を Version 9 に差し替え。
    (version 9 固有の機能は使用していない)
  • ↑により、なぜか kbwma.dll を FreeLibrary すると落ちるようになってしまった
    (旧版の kbwma.dllでも落ちるようになってしまった。wmvcore.dll の問題か？) ので、
    kbdshow.kpi のアンロード時は kbwma.dll を FreeLibrary しないようにした。
    初回のみ LoadLibrary し、２回目以降は GetModuleHandle するように修正)
  • kbdshow.kpi/kbwma.dll ともにファイルサイズが小さくなった。
Version 1.13(2002/06/16)
  • kmp_GetTestModule が複数回呼ばれると KMP_MODULE::ppszSupportExts が壊れるのを修正。
Version 1.12(2001/11/08)
  • DllMain で DisableThreadLibraryCalls() を呼ぶようにした。
  • KBWMA.DLL を使わずに WMA を再生するとき、演奏が途中で
    終了してしまうことがあったのを修正（再生速度を変更したときに発生しやすい）
Version 1.11(2001/10/09)
  • KBWMA.DLL に関する以下のような修正。
    • WMA のオープンに失敗したときにメモリリークするのを修正。
    • 音とびと CPU 負荷が少し軽減。(気休め程度)
    • 演奏終了の約 5 秒前に CPU 使用率が 100% になるのを修正。
Version 1.10(2001/10/03)
  • KBWMA.DLL を使用して WMA を再生しているときの音とびが軽減。
Version 1.09(2001/09/27)
  • KBWMA.DLL に関する以下のような修正。
    • ファイルオープン時にメモリリークしていたのを修正。
    • 演奏終了後に CPU 使用率が 100% になるのを修正。
    • 細かい修正。
Version 1.08(2001/09/26)
  • WMA の再生に DirectShow ではなく、
    KBWMA.DLL (Windows Media SDK 7.1 ベースの WMA デコーダ) を
    使用するかどうか設定できるようにした。KBWMA.DLL を使用すると、
    • 再生速度を速くしても音とびしない。
    • 通常再生時に CPU に負荷がかかった場合の音とびはむしろ発生しやすくなる。
    • シークが高速になる。
    • シークが不安定になる（シークすると固まる）かもしれない。
Version 1.07(2001/09/04)
  • 最後まで演奏した後に演奏を再開しても再開できないことがあったのを修正。
    (根本的な解決は出来ていない)
  • WMA でシークすると演奏が終わってしまう確率が下がった。
    (根本的な解決は出来ていない)
Version 1.06(2001/08/15)
  • INI ファイルで再生したい拡張子を設定できるようにした。
  • (デフォルトでは) 拡張子 AC3 を認識させないようにした。
    (再生したい場合は INI を書き換えて下さい)
Version 1.05(2001/08/02)
  • AC3 に対応。
Version 1.04以前
  • 不明。


kbflac

KBFLAC.KPI Version 0.05
製作者 : Kobarin / 対応拡張子 : FLAC

FLAC (Free Lossless Audio Codec) を再生するためのプラグインです。
FLAC については
http://flac.sourceforge.net/
を参照してください。

kbflac.kpi には Josh Coalson 氏作の libFLAC 1.1.0 が組み込まれており、
LGPL に従います。kbflac.kpi のソースが欲しい方は
http://home7.highway.ne.jp/Kobarin/source/
からダウンロードしてください。

更新履歴
Version 0.05(2003/04/13)
  • モノラルのデータを再生できなかったバグを修正。
Version 0.04(2003/01/28)
  • デコーダを libFLAC 1.1.0 に差し替え。
Version 0.03(2002/12/19)
  • デコーダを libFLAC 1.0.4 に差し替え。
  • タイトルの取得に対応。
Version 0.02(2002/08/19)
  • デコーダを libFLAC 1.0.3 に差し替え。
  • 24bit に対応。
Version 0.01(2002/05/12)
  • 初版


kbfpd

kbfpd.kpi Version 0.07
製作者 : Kobarin / 対応拡張子 : FPD/FM

FPD 再生プラグインです。対応拡張子は FPD/FM です。

従来の KbMedia Player (Version 2.31α3 以前）では、このプラグインがなくても
FPD に対応していましたが、このプラグインを導入することにより、

  • 再生デバイス (WaveOut/DirectSound) の選択
  • 音量調節
  • エコー再生
  • 再生速度変更
  • クロスフェード
  • シーク (少し時間がかかる)
  • 演奏時間取得
    • Kyu さん制作の fpd98sub.dll: http://www.platz.jp/~kyu/ が必要

などが可能になります。

FPD について詳しくは
http://www.rat.co.jp/fpd98/
を参照して下さい。

必要となるファイル
  • fpd98.dll
    kbfpd.kpi の動作に必要になります。
    2003/05/18 現在の最新バージョンを同梱しています。
    kbfpd.kpi の仕様上、同梱のとは異なるバージョンの fpd98.dll では
    正常動作しない可能性がありますので、同梱のより新しいバージョンの
    fpd98.dll が公開されていたとしても、dll は差し替えない方が良いかもしれません。
  • fpd98sub.dll
    KYU 氏制作の fpd98sub.dll を導入することにより、FPD の演奏時間を
    取得出来るようになり、無限ループにも対応出来ます。
    kbfpd.kpi に最初から同梱されています。

    最新の fpd98sub.dll は
    http://www.platz.jp/~kyu/
    にあります。
    FPD98 や開発キットに同梱されている fpd98sub.dll では動作しません。

    fpd98sub.dll がない場合、表示上の演奏時間は KbMedia Player の設定の
    「デフォルトの曲の長さ」になります。
    (実際には２回だけループした後、演奏終了します)
    fpd98sub.dll は kbfpd.kpi と同じディレクトリから動かさないで下さい。
    kbfpd.kpi と同じフォルダに置かないと動作しません。
  • FPV ファイル
    ダウンロードしてきた FPD/FM ファイルを再生するために FPV ファイルが
    必要になることがあります。必要な FPV ファイルは FPD/FM ファイルと同じ
    フォルダに置くか、専用の FPV フォルダに置いて下さい。FPV フォルダは
    KbMedia Player の「環境設定」で設定することが出来ます。

    http://www.rat.co.jp/fpd98/
    にある FPD98 本体をインストールした後、FPD98 のインストールフォルダに作成される
    • PCM95
    • PCM97
    フォルダにある FPV ファイル群が必要となるデータが多いです。
    少なくともこの２つのフォルダは必ず FPV フォルダに置いて下さい。

    FPV フォルダはサブフォルダも検索します。階層は無限です。
    例えば
    • C:\PcmDir\FPV\PCM95
    • C:\PcmDir\FPV\PCM97
    のように
    C:\PcmDir\FPV\
    の下に PCM95/PCM97 のフォルダをコピーしておき、KbMedia Player の設定では
    FPVフォルダを
    C:\PcmDir\FPV\
    のように設定しておけば良いです。設定はこちらで。
著作権
  • fpd98.dll の著作権は株式会社ラットが保有します。
  • fpd98sub.dll の著作権は KYU 氏が保有します。
  • kbfpd.kpi の著作権は Kobarin が保有します。
注意事項

kbfpd.kpi は KbMedia Player 以外のアプリケーションからは
利用出来ないように細工してあります。

KbMedia Player のプラグインを使用して WAVE ファイル出力を行う
アプリケーションがあると、FPD98 の未レジストユーザーでも FPD ファイルを
WAVE ファイルに変換することが出来てしまう可能性があるからです。ご了承下さい。

更新履歴
Version 0.07(2003/05/21)
  • 曲長取得に失敗することがあるのを今度こそ修正。
    (読み取り専用属性がついたファイルで失敗していた)
Version 0.06(2003/05/18)
  • エラーダイアログ表示時、約 5 秒程度経過したら自動的に閉じるようにした。
  • 曲長取得に失敗することがあるのを修正（？）
Version 0.05(2003/05/12)
  • FPV の検索フォルダを無限階層検索するようにした。
Version 0.04(2003/05/05)
  • fpd98.dll/fpd98sub.dll を kbfpd.kpi と同じフォルダに存在するものしか
    ロードしないように仕様変更。
    • fpd98.dll のバージョン違いによる誤動作を回避するため。
      (kbfpd.kpi は fpd98.dll の内部実装に強く依存するため、将来的に公開される
      最新の fpd98.dll で動作することを保証出来ない)
    • FPD 本体や開発キットに同梱の fpd98sub.dll では動作しないため。
  • fpd98sub.dll がない場合の演奏時間を 0xFFFFFFFF（デフォルトの曲の長さ）に変更。
  • 検索パス指定に関するバグを修正。
  • 細かい修正。
Version 0.03(2003/04/30)
  • FPD98.DLL に関する以下のバグを強引に回避。
    • PlayEnd 呼び出し時に落ちることがある。
      (まだ終了していないスレッドのハンドルを CloseHandle するのが原因)
    • 一度でも FreeLibrary すると次回以降 Play で落ちる。(UnregisterClass して
      いないため、次回以降適切な WndProc が呼ばれないのが原因)
    • リソースリーク回避 (CreateEvent したハンドルを CloseHandle し忘れている、
      InitializeCriticalSection したクリティカルセクションオブジェクトを
      DeleteCriticalSection し忘れている)
    • タイミングに依存して発生する (と思われる) 不具合
  • ↑の修正により、プラグインのロード・アンロードを繰り返しても落ちなくなった (はず)
  • タイトル取得に対応 (KbMedia Player Version 2.31α3 以降でのみ使用可能)
Version 0.02(2003/04/27)
  • fpd98.dll のバイナリを書き換えなくても動作するようにした。
  • fpd98sub.dll の API を呼び出し時に落ちる可能性があったのを修正。
  • fpd98sub.dll が導入されている場合は無限ループに対応。
    (「演奏」メニューの「単曲リピート」有効時)
  • 必要な FPV ファイルがない場合などのエラーダイアログ表示時、
    出来るだけ前面に表示する＆タスクバーに表示されるように修正。
  • 曲長計算用のテンポラリファイルをカレントフォルダに作成していたバグを修正。
    (エラーが発生して落ちた場合、タイミングによってはカレントフォルダに
    ゴミファイルが残ったかもしれない)
Version 0.01(2003/04/24)
  • 初版


kbmac

KBMAC.KPI Version 0.10
製作者 : Kobarin / 対応拡張子 : APE

Monkey's Audio を再生するためのプラグインです。
Monkey's Audio については
http://www.monkeysaudio.com/
を参照してください。

kbmac.kpi には Matthew T. Ashland 氏の Monkey's Audio SDK 3.97 が組み込まれています。

更新履歴
Version 0.10(2003/01/21)
  • 再生中のデータを mp3infp 2.32 で情報取得出来ないのを修正。
    (ファイルを開くときの共有モードの問題)
Version 0.09(2002/08/19)
  • デコーダを Monkey's Audio SDK 3.97 ベースのものに差し替え。
Version 0.08(2002/05/07)
  • デコーダを Monkey's Audio SDK 3.97b1pre1 ベースのものに差し替え。
Version 0.07(2001/11/08)
  • kbmac.kpi のファイルサイズが減少。(MSVCRT.DLL に依存するようにした)
Version 0.06(2001/09/20)
  • デコーダと同梱の DLL を Monkey's Audio SDK 3.92 ベースのものに差し替え。
Version 0.05(2001/08/12)
  • デコーダと同梱の DLL を Monkey's Audio SDK 3.90 ベースのものに差し替え。
Version 0.04(2001/06/24)
  • デコーダと同梱の DLL を Monkey's Audio SDK 3.89 ベースのものに差し替え。
Version 0.03(2001/04/27)
  • デコーダと同梱の DLL を Monkey's Audio SDK 3.88 ベースのものに差し替え。
Version 0.02β(2001/03/05)
  • デコーダと同梱の DLL を Monkey's Audio 3.85b2 SDK ベースのものに差し替え。
Version 0.01β(2001/01/13)
  • 初版


kbmad

kbmad.kpi Version 0.06
製作者 : Kobarin / 対応拡張子 : MP1/MP2/MP3/RMP

MAD (MPEG audio decoder) をベースにした MP3 デコードプラグインです。
KbMedia Player に標準で同梱されている kbmp3.kpi よりも音質が良いという話です。
ただし、再生時の CPU 負荷は kbmp3.kpi よりも高くなります。
MAD については
http://www.mars.org/home/rob/proj/mpeg/
を参照してください。

kbmad.kpi は標準では kbmp3.kpi よりも優先度が低いため、
プラグインフォルダに置いただけでは使用されません。
kbmad.kpi を使用して MP3 を再生したい場合は、
[ツール] -> [環境設定] -> [プラグイン] で kbmp3.kpi を使用しないように設定して下さい。

上の方に表示されているものほど優先順位が高いです。
kbmad.kpi より上に表示されているプラグインのうち、
対応拡張子が MP3 のものはすべて無効にして下さい。

なお、初回ロード時に自動的に作成される kbmad.ini ファイルを書き換えることによって、
24bit/32bit での出力等ができるようになります。

[kbmad.kpi]
BitsPerSample=16
EnableDither=0

BitsPerSample は 8/16/24/32 のいずれかを指定します。初期設定は 16 bit です。
24 や 32 を指定すると、少しだけ音質が向上しますが、その分再生負荷が高くなります。
使用する waveOut/DirectSound デバイスが対応していないと意味がありません。
(デバイスが対応していない場合は KbMedia Player 本体が 16bit に変換して再生します)

KbMedia Player 本体の 24bit/32bit 出力の設定が有効になっている場合は、
INI ファイルの内容は無視します。本体から適切なビット数が要求されるためです。

KbMedia Player 本体の 24bit/32bit 出力の設定が無効な場合、24bit/32bit は
KbMedia Player が内部的に 16bit に変換します。なので、実質的にはこの設定は
8bit 出力したいときしか意味を持ちません。8bit 出力するメリットはほとんどありませんので、
BitsPerSample の設定は限りなく無意味に近いです。

EnableDither は 0 で無効、1 で有効です。1 を指定すると音質が少し変わります。
8bit で再生している場合は音質が多少改善されるかもしれません。

設定の変更は、ファイルを開き直したときに反映されます。
KbMedia Player を起動し直す必要はありません。

kbmad.kpi には Robert Leslie 氏作の libmad 0.14.2 beta のソースコードが
組み込まれています。元ソースは GPL ですので、kbmad.kpi も GPL に従います。
一部ですが、柴田氏、Yunasoft 氏、Moka 氏、おたちゃん氏制作の

in_mpg123.dll(otmpg123.kpi)

のソースコードが組み込まれています。(演奏情報取得の部分)

kbmad.kpi のソースが欲しい方は
http://home7.highway.ne.jp/Kobarin/source/
からダウンロードしてください。

更新履歴
Version 0.06(2003/02/26)
  • 不本意ながら（ぉぃ）、無圧縮 ZIP.MP3 への対応を強化。
    • ZIP.MP3 の ZIP ヘッダ部分を無視することにより、１曲目が再生される
      可能性が高くなった。(２曲目以降が再生されるかどうかは保証出来ない)
    • VBR な無圧縮 zip.mp3 の曲長計算の方法を修正。
      (１曲目の曲長とファイルサイズを元に概算値を求める)
Version 0.05(2003/02/24)
  • 本体からのビット数要求が 32bit/64bit float の場合は
    32bit int で出力するように修正。(今までは 16bit int で出力していた)
Version 0.04(2002/06/10)
  • エラーが見つかっても出来るだけ再生するように修正。
Version 0.03(2002/05/28)
  • KbMedia Player 本体からのビット数の要求に対応。
  • INI の BitsPerSample の指定よりも本体からの要求を優先するため、
    INI での設定は事実上無意味になった（ぉ
Version 0.02(2002/05/19)
  • デフォルトではディザを無効にするようにした。
  • 8/16/24/32bit 再生とディザの有効・無効を ini で設定出来るようにした。
    (設定はファイルを開く度に読み込まれます)
Version 0.01(2002/05/13)
  • 初版


kbmio

kbmio.kpi Version 0.04
製作者 : Kobarin / 対応拡張子 : MIO

MIO (Music Interleaved and Orthogonal transformed format) を
再生するためのプラグインです。MIO については
http://www.entis.gr.jp/eri/
を参照してください。

kbmio.kpi には Leshade Entis 氏制作の ERINA-Library が組み込まれています。

ERINA-Library version 1.0A
Copyright (C) 2000-2002 Leshade Entis, Entis-soft.

更新履歴
Version 0.04(2003/01/03)
  • eriInitializeLibrary を呼ばずに eriCloseLibrary を
    呼ぶことがあったのを修正。(実害はない)
Version 0.03(2002/06/16)
  • ERINA-Library を 1.0A に差し替え。
Version 0.02(2002/05/13)
  • 「プラグイン情報」の「説明」を修正。
Version 0.01(2002/05/07)
  • 初版


kbmod

KBMOD.KPI Version 0.01
製作者 : Kobarin / 対応拡張子 : MOD/S3M/XM/IT/MDL/669/AMF/AMS/
DBM/DSM/FAR/J2B/MED/MT2/MTM/OKT/PSM/PTM/ULT/UMX

MOD を再生するためのプラグインです。
実際に動作確認が取れているのは MOD/S3M/XM/IT のみです。

GPL である ModPlug XMMS Plugin v1.5a のソースを参考にしています。
KBMOD.KPI のソースが欲しい人はメールを下されば差し上げます。

ModPlug XMMS Plugin については
http://modplug-xmms.sourceforge.net/
を参照してください。

ModPlug については
http://www.modplug.com/mods/
http://www.modplug.com/modplug/
を参照してください。

更新履歴
Version 0.01(2001/08/25)
  • 初版
  • MPPSDK.DLL 使用時の KbMedia Player からの変更点は以下の通り。
    • 音質向上。
    • 瞬間的なシークをサポート。
    • 対応形式の増加。(わけわからないものばっかりですが(^^;)


kbmp3

KBMP3.KPI Version 1.15
製作者 : Kobarin / 対応拡張子 : MP1/MP2/MP3/RMP

MPEG Audio を再生するためのプラグインです。

更新履歴
Version 1.15(2003/06/20)
  • RIFF SIF を包んだ ID3v2 を含む MP3 を再生出来ないのを修正。
Version 1.14(2003/02/26)
  • 不本意ながら（ぉぃ）、無圧縮 ZIP.MP3 への対応を強化。
    • ZIP.MP3 の ZIP ヘッダ部分を無視することにより、
      １曲目が再生される可能性が高くなった。
      (２曲目以降が再生されるかどうかは保証出来ない)
    • VBR な無圧縮 zip.mp3 の曲長計算の方法を修正。
      (１曲目の曲長とファイルサイズを元に概算値を求める)
Version 1.13(2003/02/24)
  • 本体からの出力ビット数要求が 24bit 以上の場合は 32bit float で
    出力するようにした(layer-3 の場合のみ)
Version 1.12(2002/07/23)
  • データによっては落ちることがあったのを修正。
Version 1.11(2001/11/19)
  • WAVE ヘッダがついた MP3 を再生できないことがあったバグを修正。
  • 再生できなくなっていた MP3 があったのを修正。
Version 1.10(2001/11/12)
  • 実際は MP3 でないのに強引に再生してしまう確率が下がった(と思う)
  • ヘッダにゴミがついている MP3 を再生できる確率が上がった(と思う)
  • コンパイラの最適化オプションを変更(Pentium Pro 用に最適化)
  • メモリの断片化が起こりやすい実装だったのを修正。
Version 1.09(2001/02/06)
  • 再生できない MP3 があったのを修正。
Version 1.08 以前
  • 不明(^^;


kbmpp

KBMPP.KPI Version 0.02
製作者 : Kobarin / 対応拡張子 : MP+/MPC

MPEGplug を再生するためのプラグインです。

MPEGplus については
http://www.stud.uni-hannover.de/user/73884/audiocoder_eng.html
http://www.mpegplus.org/
http://www.mpplus.nl.nu/
などを参照してください。

LGPL に従います。ソースコードは
http://home7.highway.ne.jp/Kobarin/source/
に置いてあるかもしれません。もしなかったらメールで催促して下さい。

更新履歴
Version 0.02(2002/08/19)
  • デコーダを (in_mpp.dll 0.96 をベースにしたものに) 差し替え。
Version 0.01(2001/08/25)
  • 初版


kbqcp

kbqcp.kpi Version 0.01
製作者 : Kobarin / 対応拡張子 : QCP

au 携帯の着声ファイル（QCP）を再生するためのプラグインです。
対応拡張子は QCP です。

作成方法など、詳しくは
http://www.cdmatech.com/solutions/products/purevoice_download.html
http://www3.karuizawa.ne.jp/~corgi/dark/ktai/chaku01.html
などを参照して下さい。

同梱の Qpl.dll は QUALCOMM 社が保有しています。
著作権は QUALCOMM 社が保有します。

Copyright(C) 2001 by QUALCOMM Incorporated. All rights reserved.

更新履歴
Version 0.01(2003/04/13)
  • 初版


kbtss

kbtss.kpi Version 0.01
製作者 : Kobarin / 対応拡張子 : TSS/TSD

T'SoundSystem を再生するためのプラグインです。

詳しくは
http://www.toyoshima-house.net/classic/
を参照してください。

kbtss.kpi に同梱の in_tss.dll は (多分) Yashiki Toyoshima 氏が制作したものです。
著作権は (多分) Yashiki Toyoshima 氏が保有します。

そもそも in_tss.dll が再配布可能なのかどうかわかってません。(ぉぃ)
まずかったらご指摘下さい。

更新履歴
Version 0.01(2003/01/14)
  • 初版


kbtvq

KBTVQ.KPI Version 0.04
製作者 : Kobarin / 対応拡張子 : VQF

TwinVQ を再生するためのプラグインです。

実際にはこのプラグイン単体では動作しません。
TVQDEC.DLL という DLL が別途必要になりますが、
すでに KbMedia Player に同梱されているのであまり気にする必要はありません。

TVQDEC.DLL は NTT によって開発されたものです。

TVQDEC.DLL は KBTVQ.KPI と同じフォルダに置いてあります。
Windows システムフォルダには置かないで下さい。
ファイル名が同一でもバージョンによってエクスポートされている関数が異なる場合が
あるため、システムフォルダに置くと他のアプリケーションに影響を及ぼす可能性があります。

ヘッダのバージョンが V2PP のものは再生出来ません。
ビットレートが 96kbps より大きいものは全滅だと思います。

更新履歴
Version 0.05(2003/02/20)
  • 本体からの 32bit float 出力要求に対応。
Version 0.04(2002/06/16)
  • 本体からの 24bit/32bit 出力要求に対応。
Version 0.03(2002/05/13)
  • ファイルオープン・曲長計算が高速化。
Version 0.02β(2000/11/30)
  • エラー処理がまずかったのを修正。
Version 0.01β(2000/11/17)
  • 初版


kbum

kbum.kpi Version 0.01
製作者 : Kobarin / 対応拡張子 : UM

アルトラマリン (UltraMarine) 再生プラグインです。対応拡張子は UM です。

従来の KbMedia Player (Version 2.31α3以前）では、このプラグインがなくても
アルトラマリンに対応していましたが、このプラグインを導入することにより、

  • 再生デバイス（WaveOut/DirectSound）の選択
  • 音量調節
  • エコー再生
  • 再生速度変更
  • クロスフェード
  • シーク (少し時間がかかる)

などが可能になります。

アルトラマリンについて詳しくは
http://ultramarine.org/
を参照して下さい。

アルトラマリンのデータは
http://www7.big.or.jp/~suppoko/
http://www4.big.or.jp/~tan-y/
http://www2s.biglobe.ne.jp/~GAY_LLA/
などにあります。というか、これしか知らないですが。（ぉ

アルトラマリンの再生に必要な PCM ファイル（PAC ファイル）は、
アルトラマリンのデータと同じフォルダに置くか、または専用の検索フォルダに置いて下さい。
検索フォルダは KbMedia Player の「環境設定」 => 「検索パス1」で設定することが出来ます。

著作権

同梱の umut.dll の著作権は「倶楽部すっぽこ/みあも」が保有します。

倶楽部すっぽこ/みあも
Copyright (c) Club Suppoko/Miamo

最新の umut.dll は
http://www7.big.or.jp/~suppoko/
で入手可能です。umut.dll は kbum.kpi と同じフォルダに置いて下さい。kbum.kpi の仕様上、
同梱されているのとは異なるバージョンの umut.dll では動作しない可能性があります。
出来るだけ同梱されている umut.dllをそのままお使い下さい。

kbum.kpi の著作権は Kobarin が保有します。

交信履歴
Version 0.01(2003/05/05)
  • 初版
  • MMX を使用可能な環境では MMX を使うようにした。


kbvorbis

KBVORBIS.KPI Version 1.15
製作者 : Kobarin / 対応拡張子 : OGG

Ogg Vorbis を再生するためのプラグインです。

詳しくは
http://www.vorbis.com/

を参照してください。

参考にしたソースは libvorbis/libogg/libvorbisfile の 1.00RC3 です。
良くわかりませんが、BSD ライセンスとかいうものに基づきます。(ぉ

更新履歴
Version 1.15(2003/02/20)
  • 32bit float 出力要求に対応。
Version 1.14(2002/08/19)
  • libvorbis を 1.0 (正式版) に差し替え。
Version 1.13(2002/06/16)
  • 本体からの 24bit 出力要求に対応。
Version 1.12(2002/05/27)
  • KbMedia Player 本体からのビット数の要求に対応。
    (ただし、24bit が要求された場合は 32bit で出力する)
Version 1.11(2002/05/07)
  • libvorbis を 1.0RC3 に差し替え。
Version 1.10(2001/08/18)
  • 「コメント」タグの取得に対応。
    (KbMedia Player Version 2.21β5_test20010818 以降が必要)
Version 1.09(2001/08/15)
  • デコーダを最新版 (1.0RC2 のもの) に差し替え。
Version 1.08(2001/06/24)
  • デコーダを最新版(1.0RC1 のもの）に差し替え。
Version 1.07β(2001/06/03)
  • デコーダを最新版(2001/06/03 のもの）に差し替え。
Version 1.06β(2001/03/30)
  • データによってはシークするとフリーズすることがあるバグを修正。
    (1.05β以前でフリーズするようなデータは 1.06βではシークできない)
Version 1.05β(2001/03/25)
  • 演奏開始直後や再生位置 0 にシークしたときに落ちる可能性があったのを修正。
    (直ってないかも…)
  • タグ情報取得が大幅に高速化。
Version 1.04β(2001/03/05)
  • デコーダを libvorbis 1.00β4 ベースのものに差し替え。
  • UTF-8 形式で埋め込まれたタグ情報を正しく取得できるようになった。
Version 1.03 以前
  • 不明(^^;


kbwv

kbwv.kpi Version 0.02
製作者 : Kobarin / 対応拡張子 : WV

WavPack を再生するためのプラグインです。対応する拡張子は WV です。

詳しくは

http://www.wavpack.com/

を参照してください。

kbwv.kpi には、WavPack 3.97 のソースコードが組み込まれています。
オリジナルのソースコードの著作権は Conifer Software が保有しています。
詳細は license.txt を参照して下さい。

更新履歴
Version 0.02(2003/04/13)
  • ベースとしたソースコードを最新版(3.97)に差し替え。
Version 0.01(2003/01/28)
  • 初版


各種プラグインについて
Mamiya

Mamiya 氏が作成されたプラグインについてです。
以下のプラグインに対する不具合報告や要望は Mamiya 氏宛てにお願いします。

Mamiya : mamiya@users.sourceforge.net
http://www.proc.org.tohoku.ac.jp/befis/

  • kpibmse
  • kpigym
  • kpimdx
  • kpis98
  • kpisap
  • kpisidplay
  • nezplug
対応拡張子 : BMS/BME/EMS/PMS
BMS ファイルを再生するためのプラグインです。
対応拡張子 : GYM/SSL
メガドライブ以前の家庭向け SEGA ハードの
サウンドを再生するためのプラグインです。
対応拡張子 : MDX/MDC
MDX と一部の MDC を再生するためのプラグインです。
MIDI を使用する MDC 等は再生できません。
対応拡張子 : S98/CYM/MYM/X1F/VGM/VGZ
S98/CYM/MYM/X1F/VGM/VGZ を
再生するためのプラグインです。
対応拡張子 : SAP
Atari XE/XL の音源を再現する SAP フォーマットを
再生するためのプラグインです。
対応拡張子 : SID/C64
コモドール 64(C64) の音源を再現する
SID フォーマットを再生するためのプラグインです。
対応拡張子 : NSF/NSZ/NEZ/NSD/KSS/GBR/GBS/HES/AY/CPC
NSF などを再生するためのプラグインです。


kpibmse

BMS/BME/EMS plugin for KbMediaPlayer version 1.0r11
製作者 : Mamiya / 対応拡張子 : BMS/BME/EMS/PMS

BMS ファイルを再生するためのプラグインです。

BMS/BME は某ゲーム互換ソフト用の記述ファイルです。
EMS は Angelic Pianizm 用の記述ファイルです。
PMS はふぃーりんぐ ぽみゅ用の記述ファイルです。
ドレミマニア用の PMS は再生できません。

KbMediaPlayer のプラグインを利用して WAV の代わりに MP3 や WMA 等を使用できます。
bmse.kpi と同じディレクトリに Plugins というディレクトリを作った場合
そちらを優先的に検索します。
kbmp3.kpi 以外を使用する場合は kbmp3.kpi をこちらに移動した方が無難です。

固定ディスク上以外のファイルは演奏開始前に全てメモリ上展開するため、
演奏開始に時間がかかります。

WAV/MP3 ファイル等は最終的には全てメモリ上に展開します。
低メモリ容量環境では注意が必要です。

MIDI 関連は KbMediaPlayer 本体に依存します。
現状では BGA 等の指定は無視します。

更新履歴
1.0r11
  • KbMedia Player Version 2.28beta7 以降の再生周波数要求に
    極力応じるようになりました。
1.0r10
  • ふぃーりんぐ ぽみゅの PMS を拡張子リストに追加しました。
    ただし動作確認はしておりません。
1.0r9
  • bmse.kpi で DisableThreadLibraryCalls を用いるようにしてみました。
  • bmse.exe で CoInitialize のエラーチェックを行うようにしました。
1.0r8
  • WAVファイル等の再生を終えるまで演奏停止しないようにしました。
    正確にすると時間がかかるので演奏時間取得は以前のままです。
1.0r7
  • MIDI との同期再生に対応するため、冒頭の無音をスキップしないようにしました。
    by Kobarin
1.0r6
  • さらに発覚したバグを修正しました。


kpigym

GYM plugin for KbMediaPlayer version 1.0r6+
製作者 : Mamiya / 対応拡張子 : GYM/SSL

メガドライブ以前の家庭向け SEGA ハードのサウンドを再現する GYM フォーマットを
再生するためのプラグインです。SMSPlus の出力する SSL は GYM の1種です。

再現するのは以下の音源です。

  • SEGA-SG/SC シリーズ、某オセロ、SEGA-MKIII、
    SEGA MASTER SYSTEM の PSG 音源
  • SEGA-MKIII、SEGA MASTER SYSTEM の FM 音源
  • MEGA DRIVE の PSG 音源とステレオ FM とステレオ PCM 音源
  • GAMEGEAR のステレオ PSG 音源

このプログラムは 以下のプログラム を元に作成しているため、
それぞれのライセンス に従ってください。
私が書いた部分については自由に扱ってください。

  • FM Sound Generator with OPN/OPM interface Copyright (C) by cisc 1998, 2000.
    cisc さんの FM エンジンをベースに OPN2 向けの改造を行っています。
    PCM の再現は不完全です(私が書いた部分で、cisc さんに責任はありません)。
    改変者 Mamiya(mamiya@users.sourceforge.net)
  • fmopl.c -- software implementation of FM sound generator
    Copyright (C) 1999,2000 Tatsuyuki Satoh ,
    MultiArcadeMachineEmurator development
    MAME の FMOPL エンジンは SEGA-MKIII の FM 音源ユニットの
    エミュレートに使っています。
    MAME のものをベースに YM2413 向けの改造を行っています。
    YM3812、Y8950、YM3526 の再現度も上がるはずです。
    改変者 Mamiya(mamiya@users.sourceforge.net)
  • zlib 1.1.4 (C) 1995-1998 Jean-loup Gailly and Mark Adler
    このプログラムは deflate の展開に zlib を使用しています。
  • libbzip2 1.0.2 copyright (C) 1996-2002 Julian R Seward. All rights reserved.
    このプログラムは EZPK の展開に libbzip2 のヘッダ変更版を使用しています。
  • 以下の音色ファイルを一部改変して組み込んでいます。
    fmpac_naruto by Narto

    音源部のプログラムが少々変更されてしまったため、
    現状では音色データ制作者の方々の意図通りには発声されません。
    また音源部のプログラムが不完全なためいくら音色を調整しても、
    完璧にはなるとは限りません。
更新履歴
1.0r6+
  • fmgen を m_s98.kpi v1.0r9 相当に更新しました。
  • gym_ezpk.exe のソースを同梱しました。
1.0r6
  • YMAMP v2.0b の EZPK 圧縮に対応しました。


kpimdx

MDX plugin for KbMediaPlayer version 2.00ar9
製作者 : Mamiya / 対応拡張子 : MDX/MDC

MDX と一部の MDC を再生するためのプラグインです。
MIDI を使用する MDC 等は再生できません。

普段は特に設定を変更する必要はありません。
mxdrvg.kpi と同じフォルダに mxdrvg.ini ができるはずなので
必要であればメモ帳などで書き換えて下さい。

[mxdrvg]
EnableMDC=True | 他のMDCプラグインを使いたい場合は False にします。
EnableReentrant=True | 現在では True のままで問題ないと思います。
Loop=2 | 単曲リピートが無効の時にループする回数を指定します。
SampleRate=44100 | 出力デバイスによって設定可能な値が異なります。
EnableLpf=True | サンプルレートが 48000 か 44100 の場合のみ FIR LPF を有効にできます。

based on
X68k MXDRV music driver version 2.06+17 Rel.X5-S
Copyright (c)1988-92 milk.,K.MAEKAWA, Missy.M, Yatsube
Converted for Win32 [MXDRVg] V2.00a Copyright (C) 2000 GORRY.
X68Sound.dll 20020615 by m_puusan

使用条件は MXDRV と同じ(X68的defaultのフリーソフトウェア扱いと思われる)です。

以下 mxdrv16.doc から抜粋

［最後に］

本来なら、ここで、「フリーウェア宣言」「無保証だよん」などの文章が
書かれるのですが、割愛させて頂きます。

バグなど見つけた場合は連絡お願いします。

更新履歴
2.00ar9]
  • MXDRVg 部を V2.00a(ROMEO には対応しないので実際は1.60a)相当に更新しました。
  • X68Sound.dll 部の 20020615版の修正は 1.50ar3 で対処済みです。
1.50ar8
  • X68Sound.dll 部の 20020607版の修正が反映されていなかった問題を修正しました。
1.50ar7
  • KbMedia Player Version 2.28beta7 以降の再生周波数要求に極力応じるように
    なりました。下記の INI ファイルより Player 側の設定が優先されます。
  • X68Sound.dll部を20020609版準拠に変更しました。原版と異なり任意の周波数を
    指定できますがLPFが有効になるのは原版と同じく 48kHz 時と 44.1kHz 時のみです。
    これは FIR の係数を動的に再設計しないためです。
  • 逆変換防止処理済み MDX データに一応対応しました。
    副作用として破損データの演奏時に不具合が起こる可能性があります。
1.50ar6
  • 本来なら動かないはずの問題を修正しました。
    結局 Kobarin さんに問題を指摘されるまで全く気付きませんでした。


kpis98

S98/CYM/MYM/X1F/VGM/VGZ plugin for KbMediaPlayer v1.0r9
製作者 : Mamiya / 対応拡張子 : S98/CYM/MYM/X1F/VGM/VGZ

S98/CYM/MYM/X1F/VGM/VGZ フォーマットを再生するためのプラグインです。
PDX 付き CYM は OPMD 互換ではないそうです。

MYM は MYMC 追加ヘッダで OPM クロックを補正することが可能ですが、
m_s98.kpiのみの追加仕様 ですのでご注意ください。

00-0F | .MYMと同じ
10-13 | 'MYMC'
14-1B | 'M', (c1), 'M', (c2), 'M', (c3), 'M', (c4)
1C- | .CYMと同じ

## clock = c1 * 0x1000000 + c2 * 0x10000 + c3 * 0x100 + c4;

X1F はファイル先頭に X1F と埋め込まれているもののみ正常に認識し、
MSX-YM (拡張子MYM) は CYM と誤認識します。

リズム音源の WAVE データ

  • 2608_BD.WAV
  • 2608_HH.WAV
  • 2608_RIM.WAV
  • 2608_SD.WAV
  • 2608_TOM.WAV
  • 2608_TOP.WAV

を持っている人は、m_s98.kpi と同じディレクトリに置いて下さい。
そのうち置き場所を指定できるようになると思います。

このプログラムは 以下のプログラム を元に作成しているため、
それぞれのライセンス に従ってください。
私が書いた部分については自由に扱ってください。

  • FM Sound Generator with OPN/OPM interface Copyright (C) by cisc 1998, 2001.
    cisc さんの fmgen をベースにバグ修正と OPN2 向けの改造を行っています。
    改変者 Mamiya(mamiya@users.sourceforge.net)
  • emu2413 -- YM2413 emulator written by Mitsutaka Okazaki 2001
    このプログラムは opll の再現に emu2413 を使用しています。
  • zlib 1.1.4 (C) 1995-1998 Jean-loup Gailly and Mark Adler
    このプログラムは deflate の展開に zlib を使用しています。
更新履歴
1.0r9
  • コンパイラの仕様により演奏位置指定が
    正常に機能していなかった問題を回避しました。
  • fmgen のリセット後に正常に発声しない場合がある問題を修正しました。
  • emu2413 を最新版 (0.XX:MSXplug version0.22相当) に差し替えました。


kpisap

SAP plugin for KbMediaPlayer version 1.54r2
製作者 : Mamiya / 対応拡張子 : SAP

Atari XE/XL の音源を再現する SAP フォーマットを再生するためのプラグインです。
曲の長さは SPC のデフォルトの曲の長さになります。(通常は 90 秒)

データによっては音が鳴らない場合があります。
また途中の番号から曲が入っているという場合もあるため注意が必要です。

このプログラムは 以下のプログラム を元に作成しているため、
それぞれのライセンス に従ってください。
私が書いた部分については自由に扱ってください。

SAP Library ver.1.54 by Adam Bienias

Disclaimer.

I, Adam Bienias, author of the SAP Library, I'm not responsible
for any kind of hardware or software damage caused by this library.
Use it on your risk. SAP Library is distributed as FREEWARE but
any changes in the library must be approved by me. If You use SAP
Library in Your program, then You must include information about
SAP library: "SAP Library ver.x.xx by Adam Bienias".

For contact send email to: adam@nautilus.com.pl

更新履歴
1.54r2
  • バージョン表記とそれに関するドキュメントを修正しました。
011019
  • (KbMediaPlayer には影響しませんが) スレッドに関する排他機構を修正しました。
  • SAP Libraryを最新版(1.54)に更新しました。


kpisidplay

SID plugin for KbMediaPlayer version 1.36.57r7
製作者 : Mamiya / 対応拡張子 : SID/C64

コモドール 64(C64) の音源を再現する SID フォーマットを再生するためのプラグインです。
このプログラムは libSIDPLAY と reSID を元に作成しているため
ライセンスは GPL となります。

reSID選択時はモノラル出力に固定されます。

このプログラムは 以下のプログラム を元に作成しているため、
GPLV2 ライセンスもしくは以降のバージョンが適用されます。
ただし私が書いた部分については自由に扱ってください。

reSID, a MOS6581 SID emulator engine.
Copyright (C) 2002 Dag Lem <resid@nimrod.no>

SIDPLAY, a C64 music player and SID chip emulator
Copyright (c) 1994-1997 Michael Schwendt <sidplay@geocities.com>

This version of the freely available SIDPLAY emulator engine source code
contains the following contributed or derived work, in no particular order:

Noise generation algorithm is used courtesy of Asger Alstrup Nielsen.
His original publication can be found on the SID home page.

Noise table optimization proposed by Phillip Wooller.

MOS-8580 R5 read-out combined waveforms by Dennis Lindroos.

MOS-6581 read-out combined waveforms by Dag Lem.

Peter Kunath provided an examplary source code to examine an Amiga
icon file.

Vincent Penn　contributed a fixed-point class.

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

更新履歴
1.36.57r7
  • libsidplayを最新版(1.36.57)に変更しました。


nezplug

NSF/KSS/GBR/GBS/HES/AY plugin for KbMediaPlayer v0.9.4.8
製作者 : Mamiya
対応拡張子 : NSF/NSZ/NEZ/NSD/KSS/GBR/GBS/HES/AY/CPC

NSF/KSS/GBR/GBS/HES/AY などを再生するためのプラグインです。
ILL ファイルはプラグイン(nezplug.kpi)と同じ場所に置いてください。
曲の長さは TAG ファイルが存在しない場合、
演奏設定のデフォルトの曲の長さになります。(通常は 90 秒)

このプログラムはフリーウェアです。
制作者はこのプログラムの使用に起因するあらゆる損害・障害について、
その責任を一切負わないものとします。

Mamiya の手によるソースについては自由に利用できます。

  • nezplug.kpi には以下のソフトが組み込まれています。
    使用条件はこれらに依存します。
    • zlib 1.1.4 (C) 1995-1998 Jean-loup Gailly and Mark Adler
      このプログラムは deflate の展開に zlib を使用しています。
      起源を詐称しない限り自由に使用できます。
  • nezplug.kpi には以下の音色ファイルが組み込まれています。
    • fmpac.ill
      modified by Mamiya (based on fmpac.ill by [OK])
    • fmunit.ill
      modified by Mamiya (based on fmpac.ill by [OK])
    • vrc7.ill
      by [OK]
Reference:
  • nessound.txt
    The NES sound channel guide 1.8 by Brad Taylor
  • disksystem.txt
    Disk System Infomation by goroh
  • konami.txt
    Konami Mapper infomation by goroh
  • mmc5.txt
    mmc5 infomation by goroh
  • namco.txt
    Namcot 106 Mapper infomation by goroh
  • ripper.html
    NSFripper road (beta) by Izumi (& Fukui.cat)
  • nsfspec.txt
    NES Music Format Spec v1.20 by Kevin Horton
  • vrcvi.txt
    VRCVI CHIP INFO v1.01 by Kevin Horton
  • vrcvii.txt
    VRCVII CHIP INFO v1.50 by Kevin Horton
  • disksys.htm
    Disksystem Information by NORI
  • Nintendo Disksystem Soundの資料
    by Norix
  • unspec.htm
    YM2413 Undocumented Spec by [OK]
  • pce_psg.txt
    PC Engine PSG by Paul Clifford
  • ppu.txt
    NTSC PPU timing bt Samus Aran
  • z80undoc.txt
    Z80 Undocumented Features by Sean Young
  • nestech.txt
    NES Documentation rev1.0 by Y0SHi
  • 6502.TXT
    6502 Microprocessor by <?>
  • gbmanual.txt
    GB(DMGSystem)Spec by <?>
  • 6502BUGS.TXT
    by <?> (posted by Ivo van Poorten)
  • vrc7ed
    by Fukui.cat & Kayama
  • fmpac_naruto
    by Narto
  • FMTONE_OK
    by [OK]
  • opll_sama
    by Sama
  • MDXDRV
    by 41568k
  • M88
    by cisc
  • in_gbr
    by cync
  • in_he2
    by cync
  • in_kss
    by cync
  • KexMP3
    by KLAUS
  • in_cnez
    by minachun
  • Bleep!
    by Neill Corlett
  • Famtasia
    by Nori/taka2
  • VirtuaNES
    by Norix
  • emu2149
    by [OK]
  • emu2413
    by [OK]
  • MSP
    by Sevy & Marp
  • Nosefart
    by Shady Matt Conte
  • kbnez
    by S.Kinoshita & Kobarin
  • fmopl.c
    by Tatsuyuki Satoh
  • MCDRV for Win32
    by toyoshima
更新履歴
v0.9.4.8
  • NSF の三角波のカウンタの挙動を一部を除き nessound.txt に合わせました。


各種プラグインについて
[OK]

[OK] 氏が作成されたプラグインについてです。
以下のプラグインに対する不具合報告や要望は [OK] 氏宛てにお願いします。

[OK] : okazaki@angel.ne.jp
http://www.angel.ne.jp/~okazaki/ym2413/

  • in_msx
対応拡張子 : MGS/MPK/BGM/BGR/OPX
MSX 関係のサウンドを再生するためのプラグインです。


in_msx

MSXplug for KbMediaPlayer
製作者 : [OK] / 対応拡張子 : MGS/MPK/BGM/BGR/OPX

MSX 関係のサウンドを再生するためのプラグインです。
GIGAMIXさんのご好意により MGSDRV version 3.18を内蔵しており、
IN_MSX.KPI単体でMGSを再生する事ができます。

  • ドライバファイルについて
    MPK, BGM, BGR, OPX を演奏するには、ドライバファイルが別途必要です。
    • BGM/BGR を再生するためには KINROU5.DRV が必要です。
      IN_MSX.KPI と同じフォルダに置いて下さい。
      KINROU5.DRV の入手先は以下の通りです．
      http://www.interq.or.jp/white/white/fswold/music.html
    • MPK を再生するためには MPK.BIN, MPK103.BIN が必要です。
      IN_MSX.KPI と同じフォルダに置いて下さい。
      MPK の入手先は以下の通りです。
      http://mu.ice.uec.ac.jp/~kokubun/xray/mpk.html
    • OPX を再生するためには OPX4KSS.BIN が必要です。
      IN_MSX.KPI と同じフォルダに置いて下さい。
      OPX4KSS の入手先は以下の通りです。
      http://mika1000.tripod.co.jp/
    • OPX4KSS に加えて FMPAC.ROM を配置すると、OPX の演奏再現度が
      上がります。FMPAC.ROM の入手法に関しては一切お答えする事は
      できませんので、あしからずご了承ください。
      FMPAC.ROM が無い場合、拡張音色は全て PSG 風の音で再生されます。
  • 設定ダイアログについて
    IN_MSX.KPI には設定ダイアログが装備されています。
    以下のメニューから起動してください。
    ただし、一度 MSXplug 用のファイルを演奏するまでメニューは出現しません。
    [ツール(T)]－[その他の設定(O)]－[音量設定(V)]－[MSX(X)...]
  • 音色ファイルについて
    ILL2 形式の音色ファイルに対応しています。
    音色ファイルを読み込ませる場合は、音色ファイル IN_MSX.ILL を
    IN_MSX.KPI と同じフォルダに置いて下さい。
  • KSSサポートについて
    IN_MSX.KPI で KSS ファイルを演奏させる場合、
    NEZplug 側の KSS サポートを無効にしてください。
  • 謝辞
    本プラグインは Kobarin 氏作の kbmsx.kpi のソースコードを元に、
    okazaki@angel.ne.jp が機能拡張を行ったものです。
    KSS サポートおよび KSS ファイル演奏時の諸問題の解決については
    Mamiya 氏からコードをご提供頂きました。

    本プラグインのベースとなった MSXplug は、Mamiya 氏作のZ80エミュレータ
    kmz80 を利用して作成されています。すばらしいソースをご提供くださった
    Kobarin 氏、 Mamiya 氏 に感謝いたします。

    OPX の KSS 化に際しては。Mikasen 氏作の OPX4KSS.BIN を使用させて
    頂きました。氏のご協力に感謝いたします。

    MGSDRV の内蔵に関しては GIGAMIX 様に多大なるご支援を頂きました。
    内蔵を快く了承していただいた GIGAMIX 様に感謝いたします。
  • 免責事項
    本プラグインは無保証であり、本プラグインを利用した結果生じた
    いかなる障害に対しても、作者は一切その責を負いません。
  • 注意
    本プラグインに内蔵している MGSDRV は GIGAMIX および Ain 氏の著作物です。
    本プラグインの配布条件は MGSDRV の配布条件に依存します。


各種プラグインについて
S.Kino

木下 菫 氏が作成されたプラグインについてです。

  • kbspc
対応拡張子 : SPC/SP[0-9]
SPC (スーパーファミコンのサウンドファイル形式)を
再生するためのプラグインです。


kbspc

KBSPC.KPI Version 3.20
製作者 : 木下 菫 / 対応拡張子 : SPC/SP[0-9]

SPC (スーパーファミコンのサウンドファイル形式) を再生するためのプラグインです。
対応する拡張子は SPC ですが、同梱の KBSPC.INI の
SPNSupport=0 を SPNSupport=1 と書き換えることで
SP1/SP2/SP3/SP4/SP5/SP6/SP7/SP8/SP9 も再生することが出来るようになりますが、
INI ファイルの書き換えが反映されるのは、次にプラグインがロードされたときです。
KbMedia Player を再起動しただけでは、まだ KBSPC.KPI がロードされていない
可能性があるため、Media エクスプローラには反映されないかもしれません。
確実にロードしなおすためには、Kbmplay.exe と同じフォルダにある plugin.dat を削除してから
KbMedia Player を起動するか、もしくは起動後に *.SPC を一度開いてください。

KBSPC.KPI の著作権は以下の４名が保有します。

Copyright (C) 2000-2003 Kobarin
Kobarinのホームページ : http://home7.highway.ne.jp/Kobarin/
Copyright (C) 2000-2003 Sumire Kinoshita
Insult
Copyright (C) 2000-2003 Kurohane
黒羽製作所 : http://www.kurohane.net/
Copyright (C) 2000-2003 zilpa
Sunny-side Up : http://osaka.cool.ne.jp/zilpa/

プラグインの開発に協力して下さった 木下さん、黒羽さん、zilpa さんに心から感謝いたします。

更新履歴 (特に断りが無い限り、木下さんによるものです。)
Version 3.20 (2003/01/14)
  • 以下、すべて Kobarin による修正。
    • KMPMODULE::Deinit で後始末処理をしていなかったのを修正。
    • 演奏結果がおかしくなることがあったのを修正。
    • MSVCRT.DLL がなくても動作するようにした。
    • 内部的な修正。
Version 3.19 (2003/01/03)
  • ロード時に落ちることがあるのを今度こそ修正。by Kobarin
Version 3.18 (2003/01/02)
  • ロード時に落ちることがあるのを修正(？) by Kobarin
Version 3.17 (2002/12/27)
  • Script700/7SE 読み込みに関する以下の修正。by Kobarin
    • エラーチェックを強化。(1行あたり 256 バイトを超えると落ちるのを修正等)
    • Script700/7SE の f コマンドとファイル名の区切り文字にタブ文字は使えても
      空白を使えないのを修正。by Kobarin
Version 3.16 (2002/12/22)
  • KMPMODULE::dwRentrant = 1 になった。これにより、
    • クロスフェード時の曲切り替えが高速化。
    • 曲長計算が高速化。
    by Kobarin
  • 内部的な修正。by Kobarin
Version 3.15 (2001/11/08)
  • user32.dll と gdi32.dll に依存しなくなった。by Kobarin
  • DllMain で DisableThreadLibraryCalls() を呼ぶようにした。by Kobarin
  • kbspc.ini の読み込みの仕方を修正。(INI ファイルの仕様は変わっていない) by Kobarin
Version 3.14 (2001/10/14)
  • エコーの遅延時間の修正。
  • 音色が正しく反映されない問題の修正。
Version 3.13 (2001/9/20)
  • プチノイズ除去ルーチンのデバック完了、復帰。(真・女神転生etc...)
Version 3.12 (2001/9/15)
  • プチノイズ除去ルーチンを削除。(バグがあったため)
Version 3.11 (2001/4/15)
  • ENVX読み取りの修正。(パネルでポン、モンスタニア)
Version 3.10 (2001/4/8)
  • 簡易プチノイズ対策。(簡易と言ってもそれなりに効果は大きい)
  • ピッチ算出方法の修正。(MOTHER2)
  • ボリューム決定部に変なコードが入っていたのを除去。
  • ENVX読み取りの修正。(パネルでポン)
  • OUTXの値が滅茶苦茶になるバグを修正。
  • 通常ノイズ (非強制ノイズ) ジェネレータを修正。(真・女神転生)
Version 3.07(2001/02/05)
  • ID666 に曲の長さが記述されていて、かつフェードアウト時間が 0ms の場合は、
    指定された時間が経過したら直ちに演奏終了するようにした。
    (ID666 に記述されているフェードアウト時間の部分が空文字列の場合は
    通常通り約5秒かけてフェードアウトします) (by Kobarin)
  • 気休め程度最適化 (全く変わってないかも) (by Kobarin)
  • KBSPC.KPI と同じフォルダにある KBSPC.INI に SPNSupport=1 を記述した場合は
    SP1,SP2,…,SP9 も再生できるようにした。(by Kobarin)
Version 3.06(2000/12/9)
  • ずっとDSPに潜んでいた致命的なバグを修正。(よく動いてたもんだ…)
  • 強制ノイズの判別を修正。(ライブ ア ライブ、モンスタニア)
  • DSPの0x7C(ENDX)を修正。(ドラゴンクエスト…？)
  • 補間修正を修正。
Version 3.05(2000/12/6)
  • 補間修正の方法を変更。(改悪かもしれぬ)
  • 音量を元に戻した。(やはりデメリットが大きすぎる)
Version 3.04(2000/12/3)
  • 通常ノイズの周波数の計算方法を修正。
  • 通常ノイズのボリュームの計算方法を修正。
  • 低域通過フィルタを最適化。(理論的には前バージョンの1/8の負担になった)
  • 低域通過フィルタの強さを調整。
  • 音にメリハリを付ける魔法を少々。
  • DSPの0x09(OUTX)を修正。(こんどこそ正しいはず…)
Version 3.03(2000/12/2)
  • DSPのエンベロープ読み取りの動作を修正。(ドラゴンクエスト、モンスタニア他)
  • DSPのボリューム書き込みの動作を修正。(スターオーシャン他)
  • DSPの0x09(OUTX)をある程度正しく返すようにした。
  • 前回のバージョンアップ時にピッチが異常になっていたのを修正 + 調整。
  • サンプルの終端チェックを修正。(プチノイズが僅かに軽減)
  • サンプル生成方法を少し変更。(プチノイズ軽減？)
  • 低域通過フィルタを実装。
  • 上記変更に伴い現存のIIRフィルタを廃止。
  • エコーの深さを調整。
Version 3.02(2000/11/30)
  • Snes9x1.32 以降で作成した SPC を再生できなかったバグを修正。(by Kobarin)
  • モジュレーションを修正。(by Kobarin)
  • 音量を大きくした。(データによっては音割れるので、次の版で元に戻すかも)
    (by Kobarin)
  • ピッチを修正。
Version 3.01b(2000/08/12)
  • 実は木下さんが手がけた Version 3.01 のコアが完全には (というよりほとんど)
    導入されていなかったのを修正。(^^ゞ (by Kobarin)
Version 3.01a(2000/07/30)
  • KbMedia Player のプラグインとして動作するように修正。(by Kobarin)
Version 3.01 (2000/7/27) (非公開)
  • サンプル生成方法を根本的に見直し。
  • 強制ノイズ、全体的に修正。(フィルタ、判定、その他)
  • ノイズ、強制ノイズにも補間修正を行なうようにした。
  • モジュレーションを実装した。(不完全極まりない)
  • Script700 SEで、スタートアップコマンド領域の、dコマンド (デチューン) が、
    何時の間にか機能しなくなっていたのを修正。
Version 3.00 (2000/7/20) (非公開)
  • Borland C++ でコンパイル出来るように、全体的に大幅書き直し。
  • 強制ノイズの判定を修正。(海外版 ぷよぷよ通)
  • Extra Noise Type 2のフィルタを変更。
Version 1.62 ～ 2.10
  • 記憶の彼方へ飛んでいった。(^^ゞ


Appendix
Format

KbMedia Player が対応している各種フォーマットについての説明です。

  • cdplayer.ini
  • Lyric
  • Script700 SE
  • SherryWRD
  • Tag ファイル
外部との連携
  • 外部プレイヤーを利用した MIDI 再生
    • QuickTime Music Synthesize
    • Crescendo Forte LiveSynth
  • 外部からの KbMedia Player の制御
その他
  • アーカイブのサイズ制限
  • MIDI 再生時の簡易エミュレーション
  • Winamp2 の input プラグインを利用する


Appendix
cdplayer.ini

音楽 CD のデータは、Media エクスプローラでは ::ID::xxxx のように表示します。

ID はメディアを識別するための ID 番号で、cdplayer.ini にタイトル情報を記述する
場合は、この値を使います。

xxxx はトラック番号です。
トラック番号 #### は少し特殊で、これを再生する場合は音楽 CD １枚を１曲と見なして
再生します。ノンストップ CD を再生したい場合などにお使い下さい。#### を再生中は、
演奏開始ボタン右側の▼で再生したいトラックを切り替えることが出来ます。

cdplayer.ini の編集機能はついていません。編集したい場合は、専用のツールを使うなり
手動で書き換えるなりして下さい。ID 番号は Media エクスプローラに表示されているものを
使えば大丈夫なはずです。手作業での編集でも、意外と大した手間はかかりません。
cdplayer.ini の書式は以下のような感じです。

[ID]
numtracks=xx (トラック数を数値で記述)
title=タイトル (アルバム)
artist=アーティスト
0=トラック 1 のタイトル
1=トラック 2 のタイトル
2=トラック 3 のタイトル
…

例えばトラック数が 10 で、Media エクスプローラで ::123abcd::xxxx と表示される
ような CD のタイトル情報は

[123abcd]
numtracks=10
title=タイトル (アルバム)
artist=アーティスト
0=トラック 1 のタイトル
1=トラック 2 のタイトル
2=トラック 3 のタイトル
…
9=トラック 10 のタイトル

のように書きます。cdplayer.ini の場所は Win9x 系なら Windows フォルダにあるはずです。
Windows2000 にはないので、自分で作る必要があります

さて、ここまでがんばって cdplayer.ini を作成したのならば、
きちんとパスも設定しておきましょう。設定方法はこちら。


Lyric with TimeTag

Appendix
タイムタグ付き歌詞の仕様

KbMedia Player は WinAmp の歌詞表示プラグインなどで使用される、
タイムタグ付き歌詞ファイルやカラオケタグに対応しています。
歌詞は液晶の下部に表示します。

ここでは歌詞ファイルの仕様について説明します。
とても簡単に作れるので、みなさんも作ってみて下さい。

歌詞の書式

タイムタグ
タグは[xx:yy:zz]のように記述してください。
xx … 分
yy … 秒
zz … 10ミリ秒（0.01秒）

zz は省略可能です。

例）
[00:05:00]1行目
[00:10]2行目
[01:18:53]3行目

この場合、5 秒のとき 1行目、10秒のとき 2行目、1分18.53秒のとき 3行目が
KbMedia Player の液晶下部に表示されます。

タイムタグで始まらない行は無視します。

例えば、

この行は無視され、何も表示されません。
チューリップの歌詞

[00:00]咲いた
[00:01]咲いた
[00:02]チューリップの
この行も無視
[00:03]花が

では、先頭の 3行は無視され、7行目の「この行も無視」も無視されて
表示されないということです。

タイムタグが不正だった場合の挙動は、KbMedia Player のバージョンに
依存します。最悪でも暴走はしないように作ってあるはずです。多分(^^ゞ
詳しくは \TimeTag\ 以下の TimeTag.html をお読みください。

ひょっとしたら、一般的なタイムタグ付き歌詞ファイルと仕様が違うかもしれません。
その場合は遠慮なくご指摘ください(^^;

歌詞ファイルを置く場所

歌詞を表示させたいファイルと同じ名前で、拡張子を txt/lrc にしたものを、
そのファイルと同じフォルダか、もしくは「環境設定」 の 「検索パス1」 で設定した
フォルダに置いてください。同じフォルダに置く場合は、

C:\MP3\hoge.mp3 なら C:\MP3\hoge.txt または C:\MP3\hoge.lrc となります。

MP3 だけでなく、MIDI や WAV/ASF などとも同期をとれます。MIDIの場合、
リリックメタイベント（*.MID 自体に含まれる歌詞情報）が含まれていれば、
歌詞を液晶の下部に表示しますが、タイムタグ付き歌詞ファイルが
含まれていれば、タイムタグ付き歌詞ファイルの方を優先します。

KbMedia Player は *.lrc ファイルの方を先に検索します。*.lrc が見つかれば、
それがタイムタグ付き歌詞かどうか調べ、タイムタグ付きでなければ *.txt を検索します。


Script700 SE

Appendix
Script700 SE (Sumire Edition) Manual

Script700 SE のマニュアルです。
以下のドキュメントは木下菫氏によるものであり、著作権も木下氏に帰属します。
元となるテキスト script.txt は kbspc.kpi と同じディレクトリにあります。

2000/7/20
Sumire Kinoshita
このドキュメントについて

理解するには、SPCに関しての、ある程度の知識を必要とします。
それを前提として説明しています。
普通にSPCを聴く方には関係ありませんので、このドキュメントは読まなくても大丈夫です。

Script700 SE について

Script700 SEの目的は…省略。わかる方だけ使用して下さい。
ようは現在のSPCの規格で再現出来ない、ドライバ周りの事情を、
手動でなんとかしようというものです。

Script700 SEは、よいこ氏のMDXDRVに搭載されているScript700を、
私が勝手に同一系の処理系を作成、拡張したものです。

基本的にMDXDRVのそれと互換性を持たせていますので、
現存するMDXDRV用のスクリプトは、ほとんどが流用可能と思われます。
詳しくは後述する「互換性について」を参照して下さい。

注意事項

Script700 SEは、私がMDXDRVのドキュメントを参考にして、同一の処理系を作ったもので、
MDXDRVのソースは一切含まれておらず、また、ソースの提供なども受けていませんので、
MDXDRVが実際に、どういったScript700の処理をしているかは、私にはわかりません。

そのため、細かい部分でMDXDRVのそれと、異なる動作をする可能性も、
無いとはいえません。（同一の処理にしたつもりですが）

ま、その辺は見逃して下さい。（ぉ

なお、Script700 SEの拡張された機能について、よいこ氏に質問したりするのは避けて
下さい。迷惑がかかりますので…。拡張された機能への質問は、私にお願いします。

互換性について

Script700 SEは、MDXDRVのScript700と互換性がありますが、サポートしていない機能が
あるため、完全互換とはいえません。以下はその互換性について説明するものです。

  • アドレッシングモード
    • p は未サポート。
  • コマンド
    • p は未サポート。
    • bt0 は未サポート。
    • n は未サポート。
  • 拡張コマンド領域
    • 全て未サポート。
      ただし、スタートアップコマンド領域（独自拡張）にて、
      拡張コマンド領域と完全互換の機能を提供しています。
スクリプトの仕様
  • Standard Command
    :[LABEL]
    m #[DATA],[PORT],W[NUM] [PORT],W[NUM]
    c #[DATA],[PORT],W[NUM] [PORT],W[NUM]
    a #[DATA],[PORT],W[NUM] [PORT],W[NUM]
    bxx [0～999]
    w []
    e
  • Startup Command
    ::
    f "FILENAME";
    m [0～255],!
    c [0～255] [0～255]
    fc [0～255] [0～255]
    d [0～255] [+-0～?]
    e
  • スタンダードコマンド領域の基本的な仕様
    • コマンドは大文字、小文字どちらでも可。
    • [] は数字を示す。表記は全て10進数にて行なう。
    • スペースかタブで区切っていれば、一行に複数コマンドを書いても可。
    • エラーチェック無し。即、例外になります。
      とりあえず、最低限の回避は行ないますが、基本的には落ちます。
    • コメントは使用不可。
  • アドレッシングモード
    • #[DATA] はデータ直結のsigned long型。
    • [PORT] はIAPU.RAMの0xF4～0xF7へ直結。つまり範囲は0～3。
    • W[NUM] は256個（0～255）のユーザーワークエリア。signed long型。
    • :[LABEL] は0～999の任意の値。
  • コマンド
    • m はデータのコピー。第1引数を、第2引数へコピー。
    • c はフラグへデータをセット。第1引数がFLAG1、第2引数がFLAG2。
    • a はデータの加算。第1引数の値だけ、第2引数へ加算。
      引き算を行なう場合は、#[DATA]でマイナスを指定すれば可。
    • bxx はフラグを参照し、条件を満たせば指定ラベルにジャンプします。
      以下はbxx系コマンドの一覧と条件です。
      • bra : if (TRUE)
      • beq : if (FLAG2 == FLAG1)
      • bne : if (FLAG2 != FLAG1)
      • bge : if ((signed long)FLAG2 >= FLAG1)
      • ble : if ((signed long)FLAG2 <= FLAG1)
      • bgt : if ((signed long)FLAG2 > FLAG1)
      • blt : if ((signed long)FLAG2 < FLAG1)
      • bcc : if ((unsigned long)FLAG2 >= FLAG1)
      • blo : if ((unsigned long)FLAG2 <= FLAG1)
      • bhi : if ((unsigned long)FLAG2 > FLAG1)
      • bcs : if ((unsigned long)FLAG2 < FLAG1)
    • w はウェイトの設定。
      指定されたSPC700のサイクル分、SPC700に処理を返します。
      このコマンドを呼ばない限り、スクリプトは処理を返しません。
      つまり、ループを行なう場合は、必ず定期的に呼ぶ必要があります。
    • e はスクリプトの終了。
  • スタートアップコマンド領域の基本的な仕様
    • ラベル記号を2つ続けて書くことによって宣言。
      それより以下はスタートアップコマンド領域になります。
      演奏開始前に、一度だけ実行されます。
    • コマンドは大文字、小文字どちらでも可。
    • [] は数字を示す。表記は全て10進数にて行なう。
    • "" は文字列を示す。末尾に ; を付けること。スペース可。
    • スペースかタブで区切っていれば、一行に複数コマンドを書いても可。
    • エラーチェック無し。即、例外になります。
      とりあえず、最低限の回避は行ないますが、基本的には落ちます。
    • コメントは使用不可。
  • コマンド
    • f は指定されたSPCファイルを、バッファに読み込みます。
      実際に読み込まれている（演奏される）SPCに影響はありません。
    • m は指定された音色をミュートします。もう一度指定すると、
      ミュートを解除します。つまり、フラグが反転します。
      ! と指定すると、全ての音色のフラグを反転します。
    • c は指定された音色の発音時に、
      指定された音色を代わりに発音させるようにします。
    • fc は指定された音色の発音時に、f によって読み込まれたSPCの、
      指定された音色を代わりに発音させるようにします。
    • d は指定された音色の周波数を、指定された値だけデチューンします。
    • e はスクリプトの終了。
スクリプトファイルの拡張子

通常は.700を使用して下さい。ただし、Script700 SEで拡張された、
独自の機能を使用したスクリプトの場合は、.7SEでお願いします。
トラブルを避けるためにも…。

サンプル

実際の記述例です。ただし、解説は書いていません。
Script700を自分で記述出来るくらいの方なら、これを見ただけで、
ある程度は理解できるでしょうから…。
下記のものは、自己責任において使用して下さい。
これらの転載などは、特に制限しません。ご自由にどうぞ…。

＜sp/65816.700 ＞
＜sp2/65816.700 ＞
＜sp2r/65816.700＞
＜snt/65816.700 ＞
＜魔道物語はなまる大幼稚園/65816.700＞
m 0 w0
:001
w 16384
a #1 w0
m w0 0
bra 1

＜Rpg2/65816.700＞
m 0 w0
:001
w 32768
a #1 w0
m w0 0
bra 1

＜ナージェリブール/65816.700＞
m 3 w0
:001
w 32768
a #1 w0
m w0 3
bra 1

上の3つのサンプルは、Script700レベルで記述されていますので、
MDXDRVでも使用可能です。（よって拡張子は.700）

最後に

Script700という素晴らしい規格を提唱された、よいこ氏に、
この場をかりてお礼申し上げます。Script700が存在したからこそ、
Script700 SEを作ることが出来ました。ありがとうございました。


Appendix
SherryWRD

KbMIDI Player Version 1.66 から、MP3 と SherryWRD の同期を
取れるようにしました。同期を取るには、以下のようにします。

  • 同期を取りたい SherryWRD 対応 MIDI データを MP3化する。
    (MP3 化の際は、録音開始時刻と MIDI データの
    演奏開始時刻を厳密に一致させる必要があります)
  • 作成した MP3 ファイルのファイル名 (から拡張子を取り除いた部分) を
    同期を取りたい .MID/.SRY (の拡張子を取り除いた部分) と同じにする。
  • MP3 ファイルを .MID/.SRY と同じフォルダに置く。
  • KbMIDI Player Version 1.66 以降で該当する MP3 を開く。

ただし、MP3 と同じフォルダには必ず対応する *.MID を置いておく必要があります。
現在の SherryWRD の仕様では、*.SRY 単体ではタイミング情報が確定しないからです。

*.SRY 単体でもタイミング情報が確定する新しい規格もあり、
KbMedia Player はその新しい規格の SRY も再生可能です。

ただ、少なくとも *.MID があれば *.SRY と同期を取れるのですから、
既存の *.SRY を新しい規格に変換したところで意味はないと思います。

新しい規格は、*.MID を介さずに作られた音楽データ (CD や MP3 など) との
同期をとるための規格です。*.MID を MP3化しただけのデータで
無理矢理新しい規格を使う必要はありません。

それでも新しい規格の SherryWRD を作りたいと思う人は、メールを下されば既存の
SRY を単体で MP3 と同期可能な形式の SRY に変換するツールを差し上げます。(^^;

ただし、そのツールで変換した SRY を再生できるソフトは今のところ
KbMedia Player だけです。ふみぃさん制作の TMIDI Player 3.5.5でも
再生できなくなります。

なお、録音時は、MIDIファイルの演奏開始時刻と録音開始時刻を厳密に
一致させることをお忘れなく。
厳密に一致してないと当然のことながら、演奏がずれます。(^^;


TagFile

Appendix
Tag ファイルの仕様

MPG のように、サウンドファイルにタイトルなどのタグ情報を記述できない形式でも
タグ情報を記述するための規格を作ってみました。以下のような特長があります。

  • KbMedia Player で対応しているあらゆるサウンドファイル形式にタイトルを記述できる。
  • 文字列の長さに制限がないので、タグ情報を埋め込めても長さに
    制限があるような形式に対しても使える。
  • テキスト形式なので、特別なツールがなくても、
    メモ帳さえあれば簡単に書き換えることが出来る。
  • サウンドファイル自体に埋め込むわけではないので、タイトルを記述することによって
    ファイルが破壊されたり、対応しないソフトで再生できなくなってしまうような
    問題は発生しない。
  • 少し応用すれば、CD-R に焼いてしまって書き換え不可能になってしまっている
    サウンドファイルのタグ情報を書き換えることも出来る。(現状ではまだ出来ません)
  • 仕様が単純なので、KbMedia Player 以外のソフトでも簡単に対応できる。
    (私はそれを望んでいます)

などがあります。本当は他にもあるのですが、話がややこしくなるので
これくらいにしておきます。(ぉ

Tag ファイルの名前と設置場所

タグ情報はサウンドファイルとは別ファイルに記述します。
ファイル名が同じで拡張子が TAG であるものか、
またはサウンドファイルと同じフォルダにある TAGINFO.TAG に記述します。

例えば C:\foo\bar.mpg の場合、C:\foo\bar.tag または
C:\foo\taginfo.tag に記述します。

Tag ファイルの書式

[bar.mpg]
Title=たいとる
Artist=あーてぃすと
Album=あるばむ
Date=2001/02/26
Genre=じゃんる
Comment=こめんと

アルバム単位で1つのフォルダに複数の曲データがまとめて置いてある場合は、
taginfo.tag に

[track1.aac]
Title=たいとる
Artist=あーてぃすと
Album=あるばむ
Date=2001/02/26
Genre=じゃんる
Comment=こめんと

[track2.aac]
Title=たいとる
Artist=あーてぃすと
Album=あるばむ
Date=2001/02/26
Genre=じゃんる
Comment=こめんと

のように1つの TAG ファイル(taginfo.tag) にまとめて書くことが出来ます。
bar.mpg とか track1.aac, track2.aac は、対象とするサウンドファイル名です。
今のところ MP3 の ID3TAG と互換性のある情報しか記述できませんが、
もっと色々な情報を記述できるようにする予定です。

1つのファイルに複数曲を含むデータへの対応

N 番目の曲の情報は
@SongN=title, length, loop, fadeout
のように記述してください。N は 1ベースの曲番号です。曲番号 0 は存在しません。
例えば下のような感じです。

[foo.nsf]
Title=ふぁみこんさうんど
Artist=ふぁみこんさうんどの作曲者
Genre=Game Music
@Song1=title1, 1:30, 30, 5
@Song2=title2, 30, 0-, 5
@Song3=title3
@Song4=title4,,,5
@Song6=,2:30,0

この例を見ればわかる通り、タイトル、曲の長さ、ループ、フェードアウトは
省略することが出来ます。
@SongN= が１つでも記述されている場合、曲番号が記述されていないものは
再生されなくなります。上記の例では、5 番目の曲が再生されなくなります。
さらに、Media エクスプローラで一覧表示するときにも 5 番目の曲は表示されなくなります。

@SongN= が１つも記述されていない場合は、すべての曲が再生されます。
全部の曲でタイトルやアーティスト、曲の長さ等が同じになります。

ループの意味については、NEZPLUG の PLS 形式と同じです。
ちょっとややこしいので今回は説明を省きます。(ぉ

PLS

NEZPLUG で拡張された PLS は、現在のバージョンでは読み込まなくなっています。
代わりに、PLS => TAG へのコンバータ機能を搭載しました。
ただしこの機能を使うためには、レジストリを書き換える必要があります。
KbMedia Player が終了している状態のときに、

HKEY_CURRENT_USER\Software\Kobarin's Soft\KbMIDI Player\Tool\PLS2TAG

の DWORD 値を 1 に書き換えて下さい。
するとメインメニューの「ツール」に「PLS/TAG ファイル作成」という項目が追加されます。
コンバータツールの使い方は、多分説明しなくてもわかると思うので省略します。

PLS => TAG へのコンバート機能の他に、１ファイル複数曲のデータから
TAG ファイルを自動生成したり、曲長計算の自動化を行う機能がついています。

レジストリ書き換えが必要にしたのは、デフォルトでこの機能が使えてしまうと、
多くの人に機能の意味や目的について誤解されそうだからです。
この機能で扱う PLS は、一般的に認識されている PLS ファイルとは全然違うものです。
そのことを十分に理解している人だけに使って欲しい機能だからです。ご了承下さい。

追記

誤解して欲しくないのですが、私がこの規格を提案するのは、
タイトルをサウンドファイルに埋め込むことに反発しているからではありません。
埋め込みたくても埋め込めない場合に対処するために提案した規格です。
すでに存在するタグ情報規格に取って代わることを目的としたものではなく、
すでに存在する規格では実現不可能なことを補うことを目的とした規格です。
ですので、MP3 のようにすでにタグ情報を記述するための規格が存在する
形式に対しては、使用するべきではありません。

とか言いつつ、NEZPLUG 拡張 PLS に関しては
「取って代わるべきもの」的な立場なんですが。（汗；


Appendix
外部プレイヤーを利用した MIDI 再生

KbMedia Player は外部プレイヤーを利用して MIDI を再生することができます。
QuickTime の QuickTime Music Synthesizer、
RealPlayer の Crescendo Forte LiveSynth を利用することが可能ですが、
以下のような制限があります。

まず KbMedia Player はこれらを MIDI デバイスと同様の扱いをしますが、
遅延時間や音源リセット等の設定を変更することは出来ませんし、
エミュレーションも機能しません。
また、これらを利用しての再生は少々不安定です。
出来るだけの対策は行っておりますが、KbMedia Player が落ちてしまう可能性もあります。

さらに、現時点では RealPlayer の Crescendo Forte LiveSynth を利用して
MIDI ファイルを再生するとテンポラリファイルが削除されないという問題があります。
テンポラリフォルダの Kbmplay.$$$ 以下にありますので、
気になる方は手動で削除してください。

具体的な設定方法はこちらです。

  • QuickTime Music Synthesize
  • Crescendo Forte LiveSynth


Appendix
QuickTime Music Synthesize

KbMedia Player は QuickTime Music Synthesizer を使用して
MIDI を再生することが可能です。

QuickTime 側の設定

これを使用して MIDI を再生するためには QuickTime5 以降が必要です。
お持ちでない方は
http://www.apple.co.jp/quicktime/
こちらからダウンロードしてください。

インストールが済んだら、QuickTime の設定から 「ミュージック」を選び、
"QuickTime Music Synthesizer" を選択します。"General MIDI" でも再生できますが、
"QuickTime Music Synthesizer" の方が良いと思います。
KbMedia Player 側で切り替えて使用することは出来ません。QuickTime の設定に従います。

KbMedia Player 側の設定

ここまでの設定を済ませれば、MIDI デバイスの設定で QuickTime Music Synthesizer を
選択するだけで QuickTime Music Synthesizer を使用してMIDI を再生することが出来ます。

ただし KbMedia Player はこれを MIDI デバイスと同様の扱いをしますが、
遅延時間や音源リセット等の設定を変更することは出来ませんし、
エミュレーションも機能しませんのでご了承ください。


Appendix
Crescendo Forte LiveSynth

KbMedia Player は Crescendo Forte LiveSynth を使用して
MIDI を再生することが可能です。

Real Player 側の設定

これを使用して MIDI を再生するためには RealPlayer8 以降と、
RealPlayer 用の MIDI 再生プラグインが必要です。お持ちでない方は
http://www.jp.real.com/
こちらからダウンロードしてください。

RealPlayer に MIDI 再生プラグインは標準添付されていませんが、RealPlayer で
MIDI を再生しようとすれば勝手にプラグインをダウンロードしようとしに行くはずです。
ネット環境にない方は申し訳ありませんがこの方法でインストールすることは出来ません。

プラグインをダウンロードすることが出来たら RealPlayer で適当な MIDI ファイルを開き、
停止させておいてください。再生中だと以下のものが淡色表示になってしまい、
選択することができません。

まず "Crescendo!" と表示されている画像の部分で右クリックをして、
"Crescendo Forte" から "LiveSynth" を選択して下さい。
"LiveSynth" 以外にも選択できますが、"LiveSynth" 以外を選択するメリットはありません。
KbMedia Player 本体でも選択できるからです。

KbMedia Player 側の設定

ここまでの設定を済ませれば、MIDI デバイスの設定で Crescendo Forte LiveSynth を
選択するだけで Crescendo Forte LiveSynth を使用してMIDI を再生することが出来ます。

ただし KbMedia Player はこれを MIDI デバイスと同様の扱いをしますが、
遅延時間や音源リセット等の設定を変更することは出来ませんし、
エミュレーションも機能しませんのでご了承ください。

さらに、現時点ではこれを利用して MIDI ファイルを再生するとテンポラリファイルが
削除されないという問題があります。テンポラリフォルダの Kbmplay.$$$ 以下に
ありますので、気になる方は手動で削除してください。


Appendix
外部からの KbMedia Player の制御

KbMedia Player はコマンドラインから引数を与えることによって制御することが可能です。
また DDE サーバとしての機能も備えており、外部アプリケーションから KbMedia Player を
制御することも可能になっています。

DDE のサービス名とトピック名は "KbMedia Player" です。( " は含みません)
XTYP_EXECUTE と XTYP_REQUEST をサポートしており、
入力した文字列をそのまま XTYP_EXECUTE として KbMedia Player に渡します。
起動済み Mutex オブジェクトの名称も "KbMedia Player" です。

KbMedia Player を制御するアプリケーションは、レジストリの

HKEY_CURRENT_USER\Software\Kobarin's Soft\KbMIDI Player\SearchPath\Kbmplay

を参照することにより、KbMedia Player の実行ファイルが置かれている
場所を取得することが出来ます。将来的には、

HKEY_CURRENT_USER\Software\Kobarin's Soft\KbMedia Player\Path\Kbmplay

に変更する予定ですが、色々事情があってしばらくの間変更できません。
将来に備えて KbMedia Player\Path\ の方を先に調べて、情報を取得できなかったら
KbMIDI Player\SearchPath\ の方を調べるようにした方が良いかもしれません。

XTYP_EXECUTE と起動時のコマンドライン引数とは書式が共通しており、
以下のコマンドが XTYP_EXECUTE で使用可能です。

/play | 演奏開始（再生中の場合は最初から演奏開始）
/p | 演奏開始（再生中の場合は何もしない）
  • /play, /p ともに、ファイル名とともに渡された場合は
    一番最初に渡されたファイルを直ちに演奏開始します。
  • 起動時（起動済みでない）のコマンドラインにファイル名を渡さずに
    /play や /p をつけた場合は、前回終了時に開いたファイルを直ちに
    演奏開始します。すでに起動済みの場合は、/play の場合は最初から
    演奏開始しますが、/p の場合はすでに演奏中だったときは何もしません。
    ショートカットの実行時引数で指定する場合は /p の方が良いと思います。
/np | 演奏を開始しない
  • リストに追加したいだけの場合に指定します。
/a | リストに追加
/na | リストに追加しない
/stop | 演奏停止
/pause | 一時停止・再開 (演奏中は一時停止、一時停止時は演奏再開)
/clear | リストを破棄 (確認しない)
/seek:xx | xx の位置にシーク
  • xx は h:m:s, s(秒), ms(ミリ秒) の３通りが指定可能。
    単位を省略した場合は秒と見なす。秒は小数点も使用可能
  • ex1:/seek:1:35
  • ex2:/seek:95
  • ex3:/seek:95s
  • ex4:/seek:95000ms
  • ex5:/seek:1:35.75
  • ex6:/seek:95.75
  • ex7:/seek:95.75s
  • ex8:/seek:95750ms
ex1～ex4 及び ex5～ex8 はそれぞれ同じ意味。
/fadeout:xx | フェードアウト
  • xx はフェードアウト時間、書式は seek と同様で、
    省略した場合はプレイヤーの設定に依存
/tray | タスクトレイに格納
  • 起動時のコマンドラインにつけた場合はタスクトレイに入った状態で起動します。
/mx | Media エクスプローラにタブを切り替え
  • /mx:"ファイル名" とすると、渡されたファイルを選択した状態で
    Media エクスプローラにタブを切り替えます。
/restore | タスクトレイ復帰
/next | 次の曲
/prev | 前の曲
/r1 | 単曲リピート有効
/nr1 | 単曲リピート無効
/fileclose | 再生中のファイルを閉じる
/quit | KbMedia Player を終了
  • 各種コマンドの大文字と小文字は区別しません。
    例えば /tray と /Tray と /TRAY は同じ意味。
  • ファイル名にスペースを含む場合は "" で括らなければならない。
  • ファイル名にスペースを含まない場合は "" で括っても括らなくてもどちらでも良い。
  • 複数のファイル名を渡した場合や、ディレクトリ・アーカイブ・演奏リスト・1ファイルに
    複数曲含むデータを渡した場合は /a, /na は無視して常にリストに追加する。
  • ファイル名が渡されていて、かつ /p, /np, /a, /na などが省略されていた場合の
    動作はドラッグアンドドロップ時の動作と同じになります。すなわち、
    • Ctrl だけが押されている場合は 「リストに追加＋演奏開始」 (/a /p)
    • Shift だけが押されている場合は 「リストに追加」 (/a /np)
    • Ctrl と Shift の両方が押されている場合は 「新規に追加」
      (リストを破棄してから「リストに追加＋演奏開始」) (/a /p /clear)
    • Ctrl, Shift がどちらも押されていない場合は Media エクスプローラの
      「ダブルクリック時」 の設定に従う

続いて XTYP_REQUEST で使用可能なコマンドです。

大文字と小文字は区別しません。例えば Status と status は同じと見なします。
すべての戻り値は文字列 (終端の \0 を含む) です。
認識しないコマンドなどが渡された場合は NULL を返します。

Status | 再生状態を返す。
  • 戻り値は
  • Playing (演奏中)
  • Stop (演奏停止)
  • Pause (一時停止)
  • Seeking (シーク中)
Position | 再生位置をミリ秒単位で返す。
Title | 再生中のサウンドのタイトルを返す。
Artist | 再生中のサウンドのアーティストを返す。
Length | 再生中のサウンドの曲の長さをミリ秒単位で返す。
  • 長さがわからない場合は -1 を返します。
FileName | 再生中のサウンドのファイル名を返す。
  • 戻り値は
  • ex1:C:\foo\bar.mp3
  • ex2:C:\foo.lzh>bar/baz.mid
  • ex3:C:\foo.rar>bar/baz.zip>quuz/hoge.spc
  • ex4:X:\::AudioCD::####
  • ex5:D:\emusound\foo.nsf::0003
ex2～ex5のように、戻り値の文字列が必ずしもファイルとして
存在するとは限らないことに注意。
ListFileName | 現在開いている演奏リストファイルのファイル名を返す。
  • 圧縮ファイル内の演奏リストファイルにも対応していることに注意。
    新規に作成されている場合は空文字列を返す。
ListCount | 演奏リストに登録されている曲の数を返す
SupportExt | 対応しているサウンドファイル形式の拡張子 (ピリオドも含む) を返す。
  • 拡張子はセミコロンで区切る。例えば
    .AAC;.MID;.MP3
    のような文字列を返す。将来的に先頭にピリオドを含まないものを
    返す可能性もあるが、その場合は無視すること。
    (.AAC;.MID;.MP3;FOO;BAR が返って来た場合は FOO と BAR は無視する)
SupportArc | 対応しているアーカイブ形式の拡張子を返す。書式は SupportExt と同じ。
ExeName | KbMedia Player の実行ファイル名 (フルパス) を返す
Version | KbMedia Player のバージョンを返す

以上です。
これを利用すると、リストファイルが前回開いていたものでよく、さらに再生される
ファイルも前回終了時に再生していたものでよいならば、KbMedia Player に
/p という引数を与えることによって起動すると同時に再生をはじめることができます。

KbMedia Player のショートカットをダブルクリックしたときに自動的に
再生が始まるようにするには、まず KbMedia Player のショートカットを作り、
プロパティのリンク先のところに /p を付け加えてください。
たとえば C:\KbMedia\Kbmplay.exe /p のようにします。

また単純にあるリストファイルを再生したいのであれば、
C:\KbMedia\Kbmplay.exe default.kbm
のようにすればそのリストが読み込まれ、再生が始まります。
引数の与え方次第でいろいろな事が出来ると思いますので、色々と試してみてください。


Appendix
アーカイブのサイズ制限

KbMedia Player で扱えるアーカイブのサイズには制限が設けてあります。
アーカイブを扱う際にメモリ上に展開しているため、あまりに大きなファイルを
扱うのは危険だからです。

全ての形式に共通する制限事項

上記のような理由により、アーカイブ内にあるファイルの解凍後のサイズが
あるサイズを超える場合は、そのファイルを再生することは出来ません。

このサイズの制限はご使用のマシンの環境によって異なり、
搭載されている物理メモリの 1/4 以下で 2の整数乗となる最大値までとなっています。
つまり搭載メモリが 128MB であれば 128/4 = 32MB まで再生することが出来ます。
ここで 192MB であった場合は 192/4 = 48MB となりますが、48を超えない範囲での
2の整数乗の最大値は 32 ですので、搭載メモリが 192MB であったとしても
実際に再生できるのは 32MB までとなります。

ただし搭載メモリが 64MB 以下の場合でも、16MB までは解凍可能です。
逆にどれだけ搭載メモリがあろうとも、128MB までしか再生することは出来ません。
仮にサイズ制限を越えるファイルを解凍できてしまったとしても、
その解凍結果は保証されません。

この制限はあくまでも 「アーカイブ内でサイズ制限を越えたファイル」 のみについて
適用されます。サイズ制限に引っかかってしまったファイルを含むアーカイブ内に含まれる、
全てのファイルが演奏不能になってしまうわけではありません。

各形式ごとの制限事項

上記の条件に加え、各アーカイブごとに以下のような条件がつきます。

アーカイブ | 解凍前のサイズ | 解凍後のサイズ | 格納ファイル数
LZH/ZIP/TAR | 512MB | 個別展開後が共通のサイズ制限以下 | 2048個
CAB | 128MB | 全展開合計が共通のサイズ制限以下 | 1024個
RAR | 64MB | 全展開合計が共通のサイズ制限以下 | 512個
7Z | 64MB | 全展開合計が共通のサイズ制限以下 | 256個
GCA | 32MB | 全展開合計が共通のサイズ制限以下 | 256個

解凍前のサイズとは、アーカイブ自体のサイズのことです。
例えば LZH/ZIP/TAR では 512MB より大きいファイルは無視されます。

格納ファイル数の制限以上のファイルが含まれるアーカイブの場合は、
制限に達するまでに見つかったファイルのみ再生することが可能です。
ただし GCA/7Z に関してはそのアーカイブ自体の解凍を中止します。

それぞれの制限の詳細は以下の通りです。

  • LZH/ZIP/TAR
    上記の制限の通りです。特筆すべきことはありません。
  • CAB/RAR
    複数のファイルが格納されている場合、全てを展開したときのサイズが
    共通のサイズ制限以下である場合のみ解凍可能です。
    サイズ制限を超えた分のファイルは認識しません。
  • GCA/7Z
    制限が一番厳しいアーカイブです。
    上記の制限のいずれかに引っかかった場合、一切の解凍を行いません。
無圧縮アーカイブ

Media エクスプローラでタイトルを取得する際に、対象アーカイブのの圧縮メソッドが
「無圧縮」である場合には、サイズ制限が 2倍まで緩和されます。

アーカイブ内のアーカイブ

書庫ファイル内の書庫ファイルには対応していますが、
書庫ファイルの中の書庫ファイルの中の書庫ファイルにまでは対応していません。
さらに書庫ファイル内の書庫ファイルが 4MB を超えた場合は無視します。


簡易エミュレーション

Appendix
MIDI 再生時の簡易エミュレーション

MIDI を再生する際に、簡単なエミュレーション機能を利用することができます。

Normal

特に何もしません。通常の演奏モードです。

Ignore Bank Select

バンクセレクトを無視します。
GS 音源を使用している場合で、使用音源がデータ側推奨音源の下位機種だった場合
(SC-88Pro用データを SC-88 で再生しようとしている場合など) にピアノで演奏されてしまう
パートがあるような場合などに使用すれば、ある程度まともに再生できるように
なるかもしれません。また XG 用のデータを GS 音源で再生させる場合にも
ある程度まともに再生できるようになる可能性があります。

** MAP

全チャンネルを ** MAP に切り替えます。
MIDI データの方が ** MAP以外 を使用する場合はそちらを優先します。
データ側推奨音源が SC-** で、使用音源がそれより上位互換機種だった場合などに
使用すれば、より SC-** 実機に近い音質で演奏できるかもしれません。

Force ** MAP

MIDI データの内容によらず、強制的に全チャンネルを指定されたMAP に切り替えます。

新しいファイルを開いたら通常演奏に戻す

チェックを入れておけば、新しいファイルを開くたびに「Normal」に戻ります。
ここのチェックを外すとすべてのデータでこのエミュレーション機能を使用します。

注意事項

音源 MAP 制御は、データの対応音源が GS でないと正常に動作しません。
さらに使用音源も GS 対応でないと無意味だと思います。


Winamp2 の input プラグインを利用する

Appendix
Winamp2 の input プラグインを利用する (kbwinamp)

KbMedia Player には Winamp2 用の input プラグインの利用を可能にする
プラグインがあります。ただし、正常に動作しない場合もありますし、
使用できたとしても大きな制限があったりします。
さらにこのプラグインはα版であり、動作保障もありません。
少なくとも以下の説明を読んで理解できないのならば、使うべきではありません。

対応するプラグイン及び制限事項

基本的に output プラグインを使用する、Winamp2 の input プラグインのみに対応します。
output プラグインを使用しないものも一応再生出来ますが、演奏停止やスペアナ表示が
出来ないなど、制限が非常に多いです。
また Winamp3 のプラグインには対応しておりません。

使用にあたっては以下の制限が課せられます。

  • input プラグインにのみ対応
  • output プラグインを使用しないタイプのプラグイン (in_midi.dll など) は
    基本的に再生不可 (再生だけなら出来るが演奏停止等が不可)
  • プラグインによっては output プラグインを使用するタイプでも
    正常動作しない可能性あり (報告を頂ければ対処してみます)
  • クロスフェード再生の処理が重い
  • 音飛びしやすい
  • 曲長計算が遅いことがある
  • 現状では設定ダイアログを開くことが出来ない
  • シーク後の再生位置が不正確 (歌詞表示で支障が出るかも)
プラグインの入手とインストール

kbwinamp は本体には同梱されていません。
Kobarin のホームページの「テスト版置き場」から入手してください。
http://home7.highway.ne.jp/Kobarin/
kbwinamp***_alpha.cab というのが目的のプラグインです。

インストールの方法は、同梱のインストーラを利用してインストールする方法と、
手動でインストールする方法の二通りあります。

  • インストーラ (kbwinamp_installer.exe) を使用する場合
    • 1. kbwinamp_installer.exe, kbwinamp.bin, 使用したい winamp の
      Input プラグインをすべてプラグインフォルダ以下の同一フォルダに置く
    • 2. kbwinamp_installer.exe を実行する
    プラグインを置く場所を \Plugins\kbwinamp\ にし、in_foo.dll と in_bar.dll を
    使うのであれば、\Plugins\kbwinamp\ 以下に kbwinamp_installer.exe,
    kbwinamp.bin, in_foo.dll, in_bar.dll を置いて、kbwinamp_installer.exe を実行します。

    インストーラに引数として /i を与えると、確認メッセージを出さないようにすることが
    出来ます。将来的には /u でアンインストールが出来るようにする予定です。
  • 手動でインストールする場合
    • kbwinamp.bin のファイル名を Input プラグインと同じファイル名
      (in_foo.dll なら in_foo.kpi) にしたものを in_foo.dll と同一フォルダにコピーする
    プラグインを置く場所を \Plugins\kbwinamp\ にし、in_foo.dll と in_bar.dll を
    使うのであれば、\Plugins\kbwinamp\ 以下に in_foo.dll, in_bar.dll, in_foo.kpi,
    in_bar.kpi を置けば OK です。
    ここで、in_foo.kpi/in_bar.kpi はともに kbwinamp.bin のコピーです。

これでインストールは終了です。プラグインを正しくインストールできたかどうかは、
「ツール」 -> 「環境設定」 -> 「プラグイン」 で確認できます。
インストールが完了したら kbwinamp.bin/kbwinamp_installer.exe は削除しても構いません。

アンインストール方法

手動で in_***.kpi をすべて削除して下さい。

動作確認済みプラグイン

以下のプラグインが動作することを確認しています。

◎ : 導入するメリットが大きい (KbMedia Player 用のプラグインがない形式など)
○ : 導入するメリットが少ない (すでに KbMedia Player 用のプラグインがある)
△ : 導入するメリットがほとんどない (速度変更、スペアナ表示が効かない、
演奏停止、一時停止が出来ない等、色々制限がある)
▲ : 導入するメリットが全くない
(△と同様の制限があり、KbMedia Player が標準ですでに対応している)
○in_mp3.dll | : Winamp2.x に同梱されています
○in_wav.dll | : Winamp2.x に同梱されています
○in_mod.dll | : Winamp2.x に同梱されています
○in_vorbis.dll | : Winamp2.x に同梱されています
○in_wm.dll | : Winamp2.x に同梱されています 著作権で保護された WMA も多分再生出来るようになります。 (お使いの PC にライセンスがあれば)
▲in_midi.dll | : Winamp2.x に同梱されています
○in_mpg123.dll | : http://www.aikis.or.jp/~otachan/
○in_mad.dll | : http://www.mars.org/home/rob/proj/mpeg/
○in_wv.dll | : http://www.wavpack.com/
○in_flac.dll | : http://flac.sourceforge.net/
◎in_rka.dll | : http://rksoft.virtualave.net/
◎in_la.dll | : http://www.lossless-audio.com/
◎in_shn.dll | : http://etree.org/
◎in_CDReader.dll | : http://www.url.ru/%7Ecopah/
◎in_mp3PRO.dll | : http://www.thomson.net/gb/00/
◎in_psf.dll | : http://lfx.org/~corlett/psf/
◎in_vtx.dll | : http://home.udmnet.ru/sav/zxay.htm (公式サイト不明)
△in_星野.dll | : http://www.proc.org.tohoku.ac.jp/befis/
○in_spc.dll |
○in_snes.dll |
更新履歴
Version 0.10α(2003/05/12)
  • in_wm.dll 使用時の演奏終了検出に失敗する (終了していないのに
    終了していると見なしてしまう) ことがあるのを修正
  • 細かい修正
Version 0.09α(2003/05/06) (in_wm.kpi という名前で公開)
  • in_wm.dll 使用時に通常のプラグインと同様に動作するようにした
  • 再生開始直後の音が失われることがあったのを修正
  • waveOutSetVolume を使用するプラグインが勝手にデバイスボリュームを
    変更するのを防ぐようにした (WAVE デバイスのみ)
Version 0.08α(2003/01/28)
  • モノラルのデータからステレオのデータに曲を切り替えたときなどに落ちるのを修正
  • in_vtx.dll が動作しないのを修正
Version 0.07α(2003/01/14)
  • ファイルオープン時、Out_Module::Open だけではなく、Out_Module::CanWrite も
    呼ばれるまで待つようにした。これにより、プラグインによっては演奏開始に
    失敗することがあったのを修正 (in_shn.dll)
  • 演奏停止に関する以下の修正
    • Out_Module::Write が少なくとも１回は呼ばれてから In_Module::Stop() を
      呼ぶようにした。
    • Out_Module::Stop を呼び出してから戻るまでの間は Out_Module::CanWrite が
      常にある程度大きな値を返すように修正
    • 上記 2つの修正により、プラグインによっては曲長計算に異常に時間がかることが
      あったのを修正 (in_vqf.dll/in_snes.dll)
    • Out_Module::Stop を呼出し後、Out_Module::CanWrite/Write が呼ばれる
      スレッドが終了するまで待つようにした。これにより、プラグインによっては曲長計算、
      曲切り替え時、アンロード時等に落ちることがあったのを修正 (in_vqf.dll v0.91)
    • これらの修正の副作用で却って曲長計算、曲切り替え等に異常に
      時間がかかるようになってしまうプラグインがあるかもしれない
  • In_Module::UsesOutputPlug == 0 なプラグインを使って再生する場合は、Play() の
    呼び出し前後の WAVE デバイスのボリュームが変化しないような対策を施すように
    した。これにより、in_wm.dll 使用時にボリュームが 0 になってしまう問題が解決
    (プラグインによってはこの方法でも問題が解決しないものがある)
  • Out_Module::GetOutputTime/GetWrittenTime をきちんと処理するように修正
  • 実際に再生するまでデコード用先読みバッファを確保しないようにした
    (曲長計算時の無駄が少しだけ省かれる)
Version 0.06α(2003/01/06)
  • 非常に重いプラグインを使用しているときや演奏開始直後、シーク直後の
    CPU 負担が気休め程度軽減
  • ファイルサイズが減少
  • 内部的に色々修正
Version 0.05α(2003/01/02)
  • メモリバッファのコピー頻度を減らして気持ち程度高速化
  • In_Module::UsesOutputPlug == 0 なプラグインでも強引に再生するようにしてみた
    (演奏停止、一時停止、音量調節、速度変更、エフェクト、スペアナ表示等は不可)
  • シーク後の再生位置取得の精度が向上
  • 内部的に色々修正
  • kbwinamp_installer.exe で、In_Module::UsesOutputPlug == 0 なプラグインを
    弾かないようにした
Version 0.04α(2002/12/28)
  • In_Module::UsesOutput != 0 な Input プラグインが本当に Output プラグインを
    使用するかどうかの判定方法を修正
  • プラグインによってはファイルオープン時やシーク時にフリーズすることがあるのを修正
  • 上記の修正により、in_lilith.dll が動作するようになった
Version 0.03α(2002/12/16)
  • Output プラグインを使わないのに In_Module::UsesOutput != 0 な
    Input プラグインを使用したときのファイルオープンの処理を修正
  • C ランタイムを一切使わないようにした
  • 細かい修正
  • kbwinamp_installer.exe を修正 (ファイルのコピーに失敗したときは標準エラー
    出力にメッセージを出力するようにした）
Version 0.02α(2002/12/15)
  • プラグイン本体のファイル名を kbwinamp.bin に変更し、インストーラ経由で
    プラグインをインストールするようにした
    • kbwinamp_installer.exe と kbwinamp.bin と使用したい Winamp の
      Input プラグインをすべて KbMedia Player のプラグインフォルダに置き、
      kbwinamp_installer.exe を起動すればインストール完了
    • インストール時の確認メッセージを省略したい場合は
      コマンドライン引数に /i を追加する
    • 手動でインストールしたい場合は kbwinamp.bin のファイル名を in_xxx.kpi に
      したものを in_xxx.dll と同一フォルダにコピーする
    • アンインストールは手動。in_xxx.kpi をすべて削除する
  • 24bit/32bit 再生時にシークするとノイズになるのを修正
  • 以下を KbMedia Player 本体の実装に依らず常に同一のスレッドで
    処理されるように修正
    • Input プラグインの LoadLibrary/FreeLibrary
    • In_Module::hMainWindow の作成
    • In_Module::Init/Quit/Play/Stop 等の呼び出し
  • in_midi.dll 等、In_Module::UsesOutput != 0 なのに Output プラグインを使用しない
    Input プラグインを使用時にファイルを開くとフリーズするのを多分修正
  • 以下の Input プラグインを使用すると落ちる or フリーズするのを多分修正
    • in_shn.dll
    • in_spc.dll
  • in_vqf.dll は未だに正常動作せず (曲の切り替えに異常に時間がかかる、
    プラグインのアンロード時に落ちる等)
Version 0.01α(2002/12/08)
  • 初版


トラブルシューティング

なにか問題がおきたときは、まずここをご覧になってください。
このヘルプは検索を行うことも出来ます。検索タブをクリックし、
調べたいキーワードを入力してください。

  • ファイルの再生に関するトラブル
    • 音が鳴らない
    • 特定の形式が再生できない
    • WMP9 を導入後 WMA が再生できなくなった
    • 動画を再生しても音声しか再生されない
    • アーカイブ内のファイルが再生できない
    • 再生が途中で終了してしまう
    • BMS で MIDI が再生されない
    • 音飛びがする
    • MIDI の演奏停止時に音がとまらない
    • フェードアウトしない
    • クロスフェードしない
    • 音量調節ができない
    • 再生速度が変更できない
    • 曲の切り替え時に Windows が固まってしまう
    • .zip.mp3 が再生できない
  • 液晶や情報の表示に関するトラブル
    • 液晶と演奏のタイミングがずれる
    • 液晶のレベルメータが動かない
    • MP3 ファイルのタグが正常に表示されない
    • タスクトレイのファイル情報が勝手に閉じたり開いたりする
    • 曲の並べ替えがうまくいかない
  • その他のトラブル
    • RealMedia 再生時に WAVE音量が 0 になってしまう
    • 起動時に OS ごと固まってしまう
    • プラグインが認識されない


トラブルシューティング
ファイルの再生に関するトラブル

再生に関するトラブル集です。近いと思われるものを選んでください。

  • 音が鳴らない
  • 特定の形式が再生できない
  • WMP9 を導入後 WMA が再生できなくなった
  • 動画を再生しても音声しか再生されない
  • アーカイブ内のファイルが再生できない
  • 再生が途中で終了してしまう
  • BMS で MIDI が再生されない
  • 音飛びがする
  • MIDI の演奏停止時に音がとまらない
  • フェードアウトしない
  • クロスフェードしない
  • 音量調節ができない
  • 再生速度が変更できない
  • 曲の切り替え時に Windows が固まってしまう
  • .zip.mp3 が再生できない


ファイルの再生に関するトラブル
音が鳴らない

ボリュームコントローラ ボリュームコントロールの音量が 0、もしくはミュートになっていないかを
確認してください。ボリュームコントロールを開くには、タスクトレイにある
スピーカのアイコンをダブルクリックするか、KbMedia Player のスピーカのアイコンを
クリックしてください。

タスクトレイにスピーカのアイコンが表示されていない場合は、コントロールパネルの
「サウンドとマルチメディア」 の 「サウンド」 タブの、「ボリュームコントロールを
タスクバーに表示する」のチェックをオンにすることで表示することが出来ます。
それでも解決しない場合は、ほとんどがデバイスが開けないために起こる問題です。

  • 他のアプリケーションがデバイスを占有している
    デバイスを使用するプレイヤーが KbMedia Player の他にも起動していると、
    そのプレイヤーがデバイスを占有してしまい、KbMedia Player の 方で
    デバイスのオープンに失敗してしまい、音が鳴らない可能性があります。
    現在の仕様ではデバイスのオープンに失敗してもエラーメッセージを出さず、
    液晶だけ動くようになっています。KbMedia Player の演奏をいったん停止し、
    他のプレイヤーを終了させてください。
  • デバイスが開きっぱなしになっている
    KbMedia Player (若しくは他のプレイヤー) などが強制終了などのため
    デバイスを閉じること無く終了してしまったために、2度と開けなくなって
    しまっている状態です。 Windows を再起動してください。
  • システムにそもそもを再生可能なデバイスが存在しない
    そもそも、システムに再生可能なデバイスが存在しない状態です。
    これはどうしようもありません。 KbMedia Player はシステムに再生可能な
    デバイスが存在しない場合は、「デバイス設定」にその旨表示するように
    していますが、動作確認が取れていないので動作しているかどうかわかりません。


ファイルの再生に関するトラブル
特定の形式が再生できない

KbMedia Player で対応しているはずの形式が再生できない場合、
その形式が同梱のファイル以外に必要とするファイルがないかどうかを調べてください。
KbMedia Player で再生できる形式の拡張子一覧がこちらにあります。
リンク先の指示に従って指定されたファイルを導入してください。


液晶や情報の表示に関するトラブル
WMP9 を導入後 WMA が再生できなくなった

「Windows Media Player 9 を導入後、WMA が再生できなくなってしまう」という
報告が多く寄せられていますが、これらの報告の大部分は著作権保護された
データに関するものであると思います。これを回避するためには、

  • kbwinamp & in_wm.dll の導入
  • kbdshow.ini の編集

が必要になります。少々面倒ですので、ヘルプをよく読んで対処してください。

kbwinamp & in_wm.dll の導入

kbwinamp とは、Winamp2 の input プラグインを利用するためのプラグインです。
こちらをよく読んで、kbwinamp と in_wm.dll を導入してください。

再生できるかどうかの確認

kbwinamp の導入が済んだら、「ツール」->「環境設定」->「プラグイン」 とたどり、
プラグインがきちんと認識されているかどうかを確かめてください。
認識されていない場合は、こちらをもう一度よく読んでください。

無事認識されていたら、とりあえず kbdshow.kpi のチェックを外してしまいましょう。
そして再生できなくなってしまったファイルを再生してみてください。

これで再生できるようになった方は、著作権保護機能に引っかかってしまっていただけです。
これで再生できるようになりましたが、まだやることがありますので先を読み進めてください。
これでも再生できない場合、現在対処のしようがありません。
申し訳ありませんが KbMedia Player ではその WMA ファイルを再生することは出来ません。
先ほどオフにした kbdshow.kpi のチェックを再びオンにして下さい。

kbdshow.ini の編集

先ほど kbdshow.kpi のチェックをはずしてしまいましたが、
このままでは WAV/AIF/AIFF/AIFC/AU/SND などが再生できなくなってしまいます。
これでは困りますので、ちょっとした細工を施します。

Plugins\Kobarin\kbdshow\ 以下にある KBDSHOW.ini をメモ帳などで開き、
SupportExt=WAV/WMA/AIF/AIFF/AIFC/AU/SND
と書いてある行の WMA を削除してから上書き保存してください。

KBDSHOW.ini の編集がすんだら、先ほどオフにした kbdshow.kpi をオンにしてください。
このとき、

このように Extension から WMA がきちんとなくなっていることを確認してください。
以上の操作によって、著作権保護された WMA が再生できるようになったはずです。
ただしお使いの PC にライセンスがあることが前提です。


液晶や情報の表示に関するトラブル
動画を再生しても音声しか再生されない

ほぼ間違いなく、対応するコーデックが導入されていません。
こちらをご覧になって対応するコーデックを導入してください。


ファイルの再生に関するトラブル
アーカイブ内のファイルが再生できない

まずはそのファイルを適当なアーカイバで開き、壊れていないかどうかを確かめてください。
そのファイルが正常であった場合、KbMedia Player のサイズ制限に引っかかっている
可能性があります。KbMedia Player では扱えるアーカイブのサイズに制限が設けてあります。
アーカイブを扱う際にメモリ上に展開しているため、あまりに大きなファイルを扱うのは
危険だからです。こちらをご覧になって、再生できないファイルが制限に引っかかって
いないかどうかをチェックしてください。

書庫ファイル内の書庫ファイルには対応していますが、
書庫ファイルの中の書庫ファイルの中の書庫ファイルにまでは対応していません。
さらに書庫ファイル内の書庫ファイルが 4MB を超えた場合は無視します。

再生できないファイルが ZIP ファイルの場合、めったに無い事だと思いますが
Stored/Deflate/Implode/Shrunk 形式以外の形式である可能性があります。
そのような場合や、圧縮メソッドによらずパスワード付きの書庫ファイルの場合は
UNZIP32.DLL が必要になります。入手先はこちらをご覧ください。


ファイルの再生に関するトラブル
再生が途中で終了してしまう

そのファイルは SPC/SAP/NSF/NSZ/NEZ/NSD/KSS/GBR/GBS/HES/AY/CPC のうちの
どれかではないでしょうか。それは仕様です。

TAG 情報に曲の長さが含まれていればそれを曲の長さとして扱いますが、
そうでない場合は曲の長さを 90秒として扱います。
この秒数は 「ツール」->「環境設定」->「演奏設定」 から変更することが出来ます。

その他に SWF を再生していても途中で終了してしまうことがあります。
SWF には演奏終了の概念がありません。
KbMedia Player では一定時間再生位置に変化の無いとき、または再生位置が
途中で戻ってしまう場合に演奏終了ということにしています。
これは単曲リピートにチェックを入れることで回避することが出来ます。
これにチェックを入れると演奏終了の検出を行わなくなるため、
最後まで再生できるようになります。


ファイルの再生に関するトラブル
BMS で MIDI が再生されない

「環境設定」->「演奏設定」 の 「WAVE/MIDI デバイスを排他的に開く」 の
チェックを外しておかないと MIDI は再生されません。

ただしこのチェックが外してある場合、使用する MIDI 音源やサウンドカードによって
は動作が不安定になったり、音が鳴らなくなる可能性があるのでご注意下さい。
ソフトウェア音源を使う場合は特に注意して下さい。

使用する MIDI デバイスは 「MIDI デバイス設定」 で設定した MIDI デバイスです。
MIDI 再生にソフトウェア音源を使用している場合、発音遅延によるタイミングのずれは
「MIDI デバイス設定」 の 「遅延時間」 の設定によって調整されます。
さらに 「遅延時間」 の設定とは別に、MIDI と WAV のタイミングには約 50ms 程度の
誤差があると思われます。(実際はもっと誤差が大きいかもしれない)

その他にも MIDI を使う BMS の再生中、音が途切れる可能性があります。
演奏開始直後やシーク直後に発生しやすいです。
この問題は MIDI と WAV のタイミングを合わせる際に発生します。
現状では仕様ということでご了承ください。

MIDI を使う BMS に対応したことにより、

MIDI -> BMS

および、

MIDI を使う BMS -> BMS (MIDI を使うものも使わないものも)

のクロスフェードは出来なくなりました。

MIDI を使わない BMS -> MIDI
MIDI を使わない BMS -> BMS

のクロスフェードは出来ます。


ファイルの再生に関するトラブル
音飛びがする

これはマシンパワーの問題なのでどうしようもありませんが、
デコードスレッドの優先順位を上げれば軽減されるかもしれません。
デコードスレッドの優先順位の変え方はこちら。

それでもだめな場合は、「ツール」->「デバイス設定」->「WAVE デバイス設定」 で
再生バッファサイズを大きくしてみてください。

音飛びが起きるファイルが WMA である場合は事情が異なってきます。
通常は Direct Show を使用して再生しますが、再生速度を速くすると音とびしたり
シーク処理に時間がかかることがあります。
KBWMA.DLL を使用するようにすることでこの問題を回避することが出来ます。
ただし著作権で保護された形式の WMA は再生することが出来ません。
動作が不安定になる可能性もあります。
KBWMA.DLL で再生できない場合は、通常通り Direct Show を用いて再生します。
KBWMA.DLL を用いて再生したい場合は、Plugins\Kobarin\kbdshow にある
KBDSHOW.ini の UseKbWMA を 1 にして下さい。詳しくはこちら。


ファイルの再生に関するトラブル
MIDI の演奏停止時に音がとまらない

ほとんどの場合は強制終了が原因です。
そうではない場合、お使いのデバイスが All Note Off/All Sound Off といった
メッセージを受けられないデバイスである可能性があります。
そのような場合は midiOutReset を使うことで回避できる可能性が高いです。
「MIDI デバイス設定」 で 「midiOutReset を使う」 にチェックを入れてください。
ただし環境によっては、 midiOutReset を使うときにシステムが 1～2 秒程度
固まってしまうことがあります。 ご注意ください。


ファイルの再生に関するトラブル
フェードアウトしない

フェードアウトはほとんどの場合においてきちんと動作するはずですが、
動画、音楽 CD、DirectMusic はフェードアウトさせることが出来ません。仕様です。


ファイルの再生に関するトラブル
クロスフェードしない

クロスフェードとは現在再生中の曲がフェードアウトし、
次の曲がフェードインしながら曲が切り替わる方式のことです。

クロスフェードはどんな場合にも可能なわけではありません。
切り替わるファイルの種類や、環境によっても左右されます。
クロスフェードさせるための条件は以下の通りです。

まず MIDI のように自身では音のデータを持たず、外部音源によって音を鳴らすものを
MIDI 系 、自身で音を持つ MP3 などや、FTP を デコード系、そして RealAudio/動画 の
ようなものをその他と呼ぶ事にすると、どんな環境でもクロスフェードが可能なのは

  • デコード系 <==> デコード系

の時のみです。 また逆にどんな環境でもクロスフェードが不可能なのは

  • その他 ===> MIDI 系
  • その他 ===> デコード系
  • その他 <==> その他

となります。KbMedia Player の設定によるものは、

  • MIDI 系 <==> デコード系

です。これは 「演奏設定」 の 「WAVE / MIDI デバイスを排他的に開く」 が
無効なときのみ可能です。最後に KbMedia Player の設定および環境に依存するものです。

  • MIDI 系 ===> その他
  • デコード系 ===> その他

この 2つは 「演奏設定」 の 「WaveMapper 使用時もクロスフェード有効」 が有効であり、
なおかつ動作するかどうかはサウンドボードおよびドライバに依存します。

また MIDI を使う BMS に対応したことにより、

  • MIDI ===> BMS
  • MIDI を使う BMS ===> BMS (MIDI を使うものも使わないものも)

のクロスフェードは出来なくなりました。

  • MIDI を使わない BMS ===> MIDI
  • MIDI を使わない BMS ===> BMS

のクロスフェードは可能です。


ファイルの再生に関するトラブル
音量調節ができない

AVI/MPG/ASF/WMV などの動画の音量調節が出来るかどうかは環境に依存します。
これらのファイルの音量を調節するのに DirectX 5.0 以降を必要としますので、
DirectX 5.0 が入ってない環境や Windows NT 4.0 では機能しません。

その他の設定で音量増幅機能を使用する設定にしていると、0 ～ 200% までの間で
音量を設定する事ができますが、MIDI や 動画の音量は増幅できません。

こちらもあわせてご覧ください。


ファイルの再生に関するトラブル
再生速度が変更できない

RealMedia, ASF, WMV の再生速度は変更できません。
それ以外のものについては基本的には可能ですが、WMA については再生速度を
速くすると音とびしたり、シーク処理に時間がかかることがあります。
そのような場合の対処法はこちらです。


ファイルの再生に関するトラブル
曲の切り替え時に Windows が固まってしまう

これは midiOutReset を使っていることが関係している可能性が高いです。
「MIDI デバイス設定」 で 「midiOutReset を使う」 にチェックをいれていると、
環境によっては midiOutReset を使うときにシステムが 1～2 秒程度
固まってしまうことがあります。ここのチェックをはずしてください。


ファイルの再生に関するトラブル
.zip.mp3 が再生できない

再生できないのが正常な動作です。
無圧縮 ZIP で固めたものの拡張子を .zip.mp3 としたものが出回っているようですが、
KbMedia Player では対応させていません。多くの要望が寄せられたため、
不本意ながら zip のヘッダを読み飛ばすことで 1曲目の再生が出来るようにはしましたが、
2曲目以降が再生される保障はありません。これ以上の対応をするつもりはありませんので、
拡張子を .zip と正常なものに戻すか、解凍して下さい。


トラブルシューティング
液晶や情報の表示に関するトラブル

液晶や情報の表示などに関するトラブル集です。近いと思われるものを選んでください。

  • 液晶と演奏のタイミングがずれる
  • 液晶のレベルメータが動かない
  • MP3 ファイルのタグが正常に表示されない
  • タスクトレイのファイル情報が勝手に閉じたり開いたりする
  • 曲の並べ替えがうまくいかない


液晶や情報の表示に関するトラブル
液晶と演奏のタイミングがずれる

ソフトウェア音源を使用している場合、LCD 表示や SherryWRD の歌詞表示と
演奏 (MIDI) のタイミングがずれてしまいます。
ソフトウェア音源での MIDI 再生は、MIDI メッセージを送信してから発音するまでに
一定時間のタイムラグがあるため、遅延が生じてしまいます。
KbMedia Player の LCD や SherryWRD の歌詞追いは MIDI メッセージを送信した
時刻に基づいて表示しているため、このタイムラグの分だけ発音と表示の
タイミングがずれてしまいます。この遅延時間をあらかじめ設定しておくことで、
表示と演奏のずれをある程度解消することが出来ます。

「MIDI デバイス設定」 の 「遅延時間」 で設定することができます。
通常は 400ms で問題ないと思いますが、環境によって差がありますので
ちょうどいいところを自分で見つけてください。


液晶や情報の表示に関するトラブル
液晶のレベルメータが動かない

まず 「表示」 メニューの 「液晶(スペアナ)」 にチェックが入っているか確かめてください。
それでも動かない場合は、環境依存である可能性があります。
動画や RealAudio、音楽 CD を再生する時に液晶のレベルメータが動くかどうかは
お使いの環境に依存します。

そのようなファイルを再生中にもスペアナを動かすには、まず前提条件として
ドライバ依存設定で「waveIn による波形取得を行う」にチェックが入っていることが必要です。
「ツール」->「環境設定」->「演奏設定」 とたどって、「waveIn による波形取得を行う」 に
チェックを入れてください。

これで KbMedia Player 側の設定は OK です。
これでスペアナが動くかどうかは、ドライバによります。


液晶や情報の表示に関するトラブル
MP3 ファイルのタグが正常に表示されない

そのファイルは書庫内のデータではないでしょうか。
KbMedia Player では書庫内の MP3 ファイルなどのタグを取得しない場合があります。
条件判定は複雑なので省略しますが、1MB 以上のファイルは省略されてしまう
可能性が強いです。無圧縮アーカイブの場合はかなり条件が緩和されますが、
制限があることに変わりはありません。高速で制限が甘い順に書くと、
TAR > ZIP(stored) > LZH(-lh0-) > ZIP = LZH > CAB > RAR > 7z > GCA
となります。さらに、アーカイブ自体の制限も存在します。
詳しくはこちらをご覧ください。

上記の制限に引っかかっているわけでもなく、他のソフトでは表示されるのに
KbMedia Player ではきちんと表示されない、というような事が起こる場合。
このような場合は、まず間違いなくその MP3 ファイルに ID3v1 Tag と ID3v2 Tag の
両方が存在しています。一般的に普及している MP3 の Tag の形式は ID3v1 ですが、
KbMedia Player では ID3v1 と ID3v2 の両方が存在する場合、ID3v2 の方を優先して
表示するようになっています。このような場合は ID3v2 Tag を書き換えるか、
または削除してください。

自分では ID3v2 Tag を作成したつもりが無くても、
ソフト側で勝手に生成してしまう場合もあります。
タグの書き換えについてはこちらを参考にしてください。


液晶や情報の表示に関するトラブル
タスクトレイのファイル情報が勝手に閉じたり開いたりする

タスクトレイのファイル情報を開いているときに次のファイルに移ってしまった場合、
曲情報を書き換えるため勝手にウインドウが閉じたり開いたりしてしまいます。
これについては今のところどうしようもありませんので、ファイルの切り替え時には
ウインドウを開かないようにしていただくより他にどうしようもありません。


液晶や情報の表示に関するトラブル
曲の並べ替えがうまくいかない

演奏リスト および Media エクスプローラでカラムをクリックしても、並び替えが
うまくいかないことがあります。まだ表示していない曲の 「タイトル」「アーティスト」 に
関しては並べ替えがうまく動作しません。

Media エクスプローラでは対処のしようがありませんが、演奏リストでは
以下のようにすることで回避することが出来ます。

並び替えをする前に、コンテキストメニューの 「曲長計算」 から 「未計算データ」、
あるいは 「すべて」 を選択してください。毎回手動でやるのは面倒でしょうから、
「バックグラウンド」 の 「すべて」 を選択しておくことをお勧めします。


トラブルシューティング
その他のトラブル

その他のトラブルです。近いと思われるものを選んでください。

  • RealMedia 再生時に WAVE音量が 0 になってしまう
  • 起動時に OS ごと固まってしまう
  • プラグインが認識されない


その他のトラブル
RealMedia 再生時に WAVE音量が 0 になってしまう

ドライバによっては RealAudio/RealVideo を再生したときに、ボリュームコントロールの
WAVE の音量が勝手に 0 にされてしまう不具合が存在するようです。
「環境設定」 の 「RealMedia 再生時に強制的に音量を最大」 で対処することが出来ます。


その他のトラブル
起動時に OS ごと固まってしまう

KbMedia Player を起動したときに、OS ごと固まってしまうという報告も寄せられています。
原因ははっきりしていませんが、おそらく ATI のグラフィックボードとの相性です。
まずはドライバを最新のものにしてみてください。

それでも解消されない場合は、コントロールパネルの 「画面のプロパティ」 の
「設定」 のページで 「詳細」 ボタンを押して表示される、ビデオカードの設定ダイアログの
「パフォーマンス」 のページで 「ハードウェアアクセラレータ」 の設定を 「基本」 または
「なし」 にすることで回避できる可能性があります。


その他のトラブル
プラグインが認識されない

プラグインがきちんと Plugins フォルダの中に入っていますか？
プラグインの検索は Plugins の更に 2階層下までです。
たとえば \Plugins\foo\bar\ は検索しますが、\Plugins\foo\bar\baz\ は検索しません。
詳しくはこちらをご覧になってください。

まずありえないとは思いますが、認識するプラグインの数の上限は 64 個です。
それ以上のプラグインがある場合は数を減らして下さい。


FAQ

よくある質問集です。やりたいことがあるんだけれども方法がわからない。
そのようなときにお使いください。

  • ソフト側で関連付けは出来ないの？
  • ディレクトリごとの再生は出来ないの？
  • 再生速度は変えられないの？
  • エフェクトはかけられないの？
  • 動画の再生で、常に手前に表示できないの？
  • アスペクト比を保ったままサイズ変更できないの？
  • フルスクリーンで再生出来ないの？
  • アルバムごとに圧縮したいんだけど……
  • 並び替えはどうやるの？
  • 検索は出来ないの？
  • ビットレートの表示は出来ないの？
  • 曲をつなげて再生することは出来ないの？
  • リストに追加しないで再生することは出来ないの？


FAQ
ソフト側で関連付けは出来ないの？

ソフト側では関連付けはできませんし、搭載されることも無いと思います。
Windows の設定を変更するようなことはしたくないというのが理由です。
下手に関連付けしてしまうと、アンインストールしたときに何も
再生できなくなってしまうようなことも起こりえます。
KbMedia Player の前に関連付けられていたアプリケーションも
アンインストールされてしまったような場合です。
そのような場合は、OS (もしくは Windows Media Player) が標準で
対応する形式は関連付けしなおすなどの対処が必要になると思いますが、
そこまでするのはかなり大変です。
こちらを参考にして手動で関連付けてください。


FAQ
ディレクトリごとの再生は出来ないの？

アルバムごとにまとめてあるなどの理由で、「ディレクトリごとまとめて再生したい」
という要望がよく寄せられますが、実装される可能性は限りなく低いです。
操作が複雑になってしまうという点と、「新規に追加」(Shift+Ctrl+Enter) で代用が
可能だからです。演奏リストをご利用ください。


FAQ
再生速度は変えられないの？

RealMedia, ASF, WMV 以外のファイルについては可能です。
再生速度変更 左図のアイコンの右側の矢印をクリックすることで再生速度を変更することが
出来ます。ただし MIDI 再生時とその他を再生しているときでは設定できる
倍率は異なり、以下のようになっています。

MIDI ： 0.25, 0.5, 0.6, 0.7, 0.8, 0.9, 0.95, 1.0, 1.05, 1.1, 1.2, 1.3, 1.5, 2.0, 3.0
その他 : 0.5, 0.6, 0.7, 0.75, 0.8, 0.9, 0.95, 1.0, 1.05, 1.1, 1.2, 1.25, 1.3, 1.5, 2.0

テンポを変更すると、アイコンの色が変わります。
そのまま再生速度を変更すると音程も一緒に変わって
しまいますが、「音程を変えずに速度を変更」にチェックを
入れることで音程はそのままで再生速度だけ変更することが
出来ますが、その代わりにかなりの CPU パワーを喰います。
ご自身のマシンに合わせてクオリティを選んでください。

ただし WMA に関しては問題が生じる可能性があります。
詳しくはこちらをご覧ください。


FAQ
エフェクトはかけられないの？

エコー 左図のアイコンの右側の矢印をクリックすることで、エコーをかけることが出来ます。
ただしエコーをかけられるのはプラグインを使用して再生する形式に限ります。

現在はエコーだけですが、いずれ強化する予定です


FAQ
動画の再生で、常に手前に表示できないの？

エコー 左図のアイコンの右側の矢印をクリックすることで、
常に手前に表示するオプションが出てきます。
または 「環境設定」->「演奏設定」->「動画」 からも設定が可能です。


FAQ
アスペクト比を保ったままサイズ変更できないの？

エコー 左図のアイコンの右側の矢印をクリックすることで、
アスペクト比を保ったままサイズを変更することが出来ます。


FAQ
フルスクリーンで再生出来ないの？

今のところ出来ません。そのうち出来るようにする予定ですが、
いつになるかわかりません。現在は仕様ということでお許しください。


FAQ
アルバムごとに圧縮したいんだけど……

速度とサイズ制限から考えると、TAR か無圧縮の ZIP でまとめることをお勧めします。

KbMedia Player では書庫内の MP3 ファイルなどのタグを取得しない場合があります。
無圧縮であれば条件は緩和されますが、制限があることには変わりありません。
またタグの取得だけでなく、再生にも別の制限がかかります。
KbMedia Player で扱えるものを、高速で制限が甘い順に並べると
TAR > ZIP(stored) > LZH(-lh0-) > ZIP = LZH > CAB > RAR > 7z > GCA
となります。


FAQ
並び替えはどうやるの？

カラム

カラムをクリックすることで並び替えることが出来ます。
演奏リストでは右クリックから「並び替え」でも可能です。


FAQ
検索は出来ないの？

現在は出来ません。一文字目だけはインクリメンタルサーチが可能ですが、それだけです。
いずれ強化するつもりの機能ですので、お待ちください。


FAQ
ビットレートの表示は出来ないの？

現在のプラグイン仕様では不可能です。
対応する予定はありますので、プラグインの新仕様が定まるまでお待ちください。


FAQ
曲をつなげて再生することは出来ないの？

ノンストップ CD をエンコードしたもので、曲間が繋がっているようなものを再生したいときは
「ノンストップ再生」 をご使用ください。この機能を使用するためには演奏モードを
「連続再生」にして、かつ DirectSound で再生する必要があります。

ただしこの機能を用いても気休め程度にしかなりません。
MP3 の仕様上、完璧に繋げることは不可能です。
最新の LAME でエンコードしたものならば理論的には可能になるそうですが、
KbMedia Player では未対応です。

WAV/APE/OGG であれば完璧に繋げることは理論上可能ですが、
現在の仕様では 2つの演奏ルーチンが完全に独立なため、
タイミングを合わせるのが困難です。ご了承ください。


FAQ
リストに追加しないで再生することは出来ないの？

Media エクスプローラのコンテキストメニューから、「設定」->「ダブルクリック時」 と
たどって、「リストに追加しないで再生」 を選択してください。


要望や不具合報告に関して
要望

KbMedia Player にはいろいろな要望が寄せられていますが、その中には技術的な
問題から実装できていなかったり、開発ポリシから実現されていないようなものもあります。
今後の予定をまとめておきましたので、ぜひご一読ください。

  • 今後の予定
不具合報告

ヘルプ及びその他ドキュメントを見ても問題が解決できないという方へ。
掲示板に書き込んだり Kobarin さん宛てにメールを出す前に、
もう一度以下のことをチェックしてみてください。

再起動

まずは Windows を再起動してみてください。長時間の連続起動で Windows が不安定に
なっているのかもしれません。長時間の連続起動でアプリケーションが正常に動かなく
なったりすることはよくあります。メモリやリソースが足りないのかもしれません。
他のアプリケーションや KbMedia Player がデバイスを閉じられなかったのかもしれません。
まずは再起動です。

他のアプリケーションで開く

再起動してもだめだった場合、トラブルの内容が「ファイルを再生できない」などであれば
問題のファイルを他のアプリケーションで開いてみてください。
他のアプリケーションでも音が出なかったり、再生自体が出来ないのであれば、
お使いの環境の問題であるか問題のファイルが壊れていることが考えられます。
そのトラブルは KbMedia Player に起因するものでしょうか？
それを確かめてください。

KbMedia Player のバージョンアップ

現在お使いの KbMedia Player は最新版でしょうか？
既に問題点が Fix されているバージョンが公開されている可能性があります。
β版を含む最新版を導入してみてください。
http://home7.highway.ne.jp/Kobarin/

各設定の確認

あとは各設定を確認していきましょう。

再生に必要な DLL がある場合、適切な場所に置いてあるか確認してみてください。
システムディレクトリに入れても動作しないものもあります。もう一度確かめてみてください。

  • 本ソフトとは別に導入が必要なものについて
  • 外部ファイルが必要となる形式

「環境設定」->「演奏設定」->「ドライバ依存設定」 にそれらしい項目がないでしょうか？
調べてみてください。

めったにないことだとは思いますが、常駐しているソフトがある場合はいったん
終了させてみてください。以前にウイルスバスターと干渉してしまったことがあります。
それでもだめな場合、以下のことを試してみてください。

  • MIDI を再生しようとしても音が鳴らない
    • 「MIDI デバイス設定」 は適切に設定されているでしょうか？
    • 簡易エミュレーションを使用してみてください。
  • MIDI 以外のファイルの音が鳴らない場合
    • 「Wave デバイス設定」 は適切に設定されているでしょうか？
    • ボリュームが 0 であったり、ミュートになっていたりしないでしょうか？
    • WaveMapper/DirectSound の設定を切り替えてみてください
    • DirectX の最新版を導入してみてください。
    • サウンドボードのドライバの最新版を導入してみてください。
  • 動画の再生が出来ない場合
    • DirectX の最新版を導入してみてください。
    • グラフィックボードのドライバの最新版を導入してみてください。

以上のことをしても解決できない場合はサポート掲示板へどうぞ。
その際にはこちらを利用していただけると助かります。


要望や不具合報告に関して
今後の予定

KbMedia Player の開発ポリシとしては、

  • ファイルの移動・削除・編集を伴う
  • 専用の代替ソフトが存在する (音楽再生ソフトの機能の範囲を超える)
  • 設定項目が増える
  • シンプルさが失われる
  • OS の設定を書き換える
  • 他のアプリケーションの動作に影響する

ような機能は出来るだけ実装しないことにしています。以下で実装しないと明言している
ものは、最初の 2つのいずれかか、もしくは両方に引っかかっているものです。
このような機能については、どんなにたくさんの要望を頂いても実装されることはありません。
それ以外の機能については、要望が多くなるほど優先度が上がりますので、
すでにリストアップされているようなものでも要望を出していただいてかまいません。

既知の不具合 (原因がわかっているもの) の修正
  • 「バージョン情報」ダイアログで DirectX のバージョンを正しく取得できないことがある
既知の不具合 (原因不明) の修正
  • ATI のグラフィックボードとの相性問題
    (起動時に OS を巻き込んで落ちる or フリーズ)
  • ATI 以外の環境でも起動直後に落ちることがあるらしい
  • QuickTime 再生時に 0 による浮動小数点除算等で落ちることがある
  • RealMedia 再生時に落ちることがある
  • RCP 再生時に落ちる or フリーズすることがある
  • FPD 再生時に落ちることがある
  • 「Crescendo Forte LiveSynth」(RealPlayer 用の MIDI 再生プラグイン)で
    MIDI 再生時に落ちることが非常に多い
要望があっても絶対に対応しない機能
  • Media エクスプローラによるファイル操作 (ファイルの削除・移動等)
  • タグエディタの搭載
  • エンコード機能
  • RCP -> MID 等、他形式への変換機能

KbMedia Player はあくまで "Player" です。開発ポリシにもあるように、ファイルの編集を
伴うような機能や、エンコーダ、デコーダ、コンバータの類の機能は実装されません。

ファイルの移動などはエクスプローラをお使いください。エクスプローラのアイコンを
クリックするか、Alt+E で現在演奏中のファイルがあるフォルダを開いた状態で
エクスプローラを起動させることが出来ます。タグの編集は外部ソフトをお使いください。

要望があっても対応する可能性が低い機能
  • Media エクスプローラをプレイリストのように扱う
    • 既存の機能 (新規に追加) でほぼ代替可能
    • 操作が複雑になる
  • スキン機能の強化
    • 個人的に全く必要としていない
  • WAV ファイルへのデコード機能
    • 個人的に全く必要としていない
    • ファイルの内容を書き換える・作成する
  • zip.mp3 への対応 (アーカイブとして扱う or 再生出来ない zip.mp3 への対応等)
    • 書庫としては拡張子が間違っているし、mp3 としても正常なものではない
  • 指定した時間になったらシャットダウンする機能 (おやすみタイマー)
    • プレイヤが扱う機能ではない
  • *.RAM ファイルへの対応
    • RAM ファイルは本来 URI を記述し、RA/RM ファイルの場所を示すもの
  • 関連付け機能
    • Windows の設定を変えてしまうことはしたくない
    • アンインストールした際に何も再生できなくなってしまう可能性がある
要望があったので検討中の機能
  • Media エクスプローラ、演奏リストでの表示カラムの選択 or 順序の設定
  • 演奏リストのカラムに「アルバム」を追加
  • アーカイブのサイズ制限の設定
  • Media エクスプローラ、演奏リスト上で Ctrl を押しながら右クリックした場合は
    滅多に使用しない機能が項目に追加されるようにする
  • Media エクスプローラ右クリックメニューに「お気に入りに追加」を追加
  • Cue Sheet 対応 (どういうものかまだよくわかっていない…)
  • マルチメディアキーへの対応 (参考になる資料が見つかれば…)
要望がなくても対応予定の機能
  • 動画再生時の操作性向上 (フルスクリーン再生等)
    • どうすれば操作性が向上するかアイデア募集中
    • KbMedia Player のインターフェースはあまり動画に向いてない
  • プラグイン仕様の見直し
    • ビットレート表示対応
    • ループ曲対応
    • 1ファイル複数曲完全対応
    • タグ情報取得対応
    • アーカイブ内の外部ファイル参照系形式への完全対応
    • ストリームからの読み込み対応
  • アーカイブ対応のプラグイン化
  • Media エクスプローラ、演奏リストでの「検索」機能の強化
  • 無圧縮アーカイブのサイズ制限をなくし、通常のファイルと同等のパフォーマンスで
    扱えるようにする (プラグイン仕様を変更する必要あり)
  • エフェクト機能の強化
  • ASIO 出力対応
  • MIDI デバイス自動切換え機能 (判別結果が XG のときは XG 音源に切り替え、
    GS のときは GS 音源に切り替えるなど)
  • MIDI 音源エミュレーション機能の強化
  • BGA に対応
  • ファイル名と拡張子が逆転した形式（mod.* など）に対応
対応したいが技術的に難しそうなので他人任せにしたい機能
  • MIMPI WRD に対応 (戸上山さんと連絡が取れれば…
  • オーディオ CD のデジタル再生 (プラグイン or 再生ライブラリ作って下さい)
    • kbwinamp と in_CDReader.dll を組み合わせれば現状でもデジタル再生可能
  • Timidity の再生エンジンを用いた MIDI 再生(同上)
  • その他、マイナーなサウンドファイル形式への対応
対応を打ち切る可能性が高い機能 (苦情が多ければ打ち切りは中止するかも)
  • Windows95 での動作保証
  • GCA 形式のアーカイブ対応 (GCA の SDK がもう少し使いやすくなれば…)
  • 「Crescendo Forte LiveSynth」での MIDI 再生 (動作が不安定すぎるため)


テンプレート作成フォーム

不具合を掲示板、またはメールで kobarin さんに送るときのテンプレートを作成できます。
分からない場所は空欄でもかまいませんが、* が付いているところは最低限必要です。
もちろんこれより詳しい状況が分かる方は付け加えて送ってください。

* Question 1 : KbMedia Player のバージョンは？
KbMedia Player Version
* Question 2 : ご使用の OS は？
Windows 95
Windows 95 OSR2
Windows 98
Windows 98 SE
Windows Me
Windows NT4.0
Windows 2000
Windows XP

NT4.0, 2000, XP の場合、ServicePack はいくつですか？
SP
* Question 3 : IE のバージョンは？
IE 5.01
IE 5.5
IE 6.0
Question 4 : DirectX のバージョンは？
分からない場合は DirectX 診断ツールを起動すればわかります。
下のリンクをクリックすれば起動できますが恐らく警告が出ます。(^^;
DirectX 診断ツールを起動

Version
Question 5 : Windows Media Player のバージョンは？
Windows Media Player Version
Question 6 : 使用しているサウンドボードは？
Question 7 : 使用しているグラフィックボードは？
Question 8 : 再生できないファイルの拡張子は？
Question 9 : 他のプレイヤー（Windows Media Player など）では再生出来ますか？
再生に関するトラブルではありません
はい
いいえ
KbMedia Player のほかに対応するソフトがありません。
出来るものと出来ないものがあります

再生できるものと出来ないものがある場合、具体的なソフトの名前を教えてください。
再生出来るもの
再生出来ないもの
Question 10 : 再生出来ないとはどういう状況ですか？
「データに誤りがあります」と表示される
Media エクスプローラ等で認識されない
KbMedia Player が強制終了する
OS ごと落ちる
音が鳴らない(スペアナは動く)
音が鳴らない(スペアナも動かない)
その他

その他の場合はここにお書きください。
Extra : その他ご自由にお書きください。


Help -Trouble-

ヘルプ(H)
トラブルシューティング(T)

HtmlHelp のトラブルシューティングを表示します。