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Introduction
Welcome to Bricklayer, the fast-paced falling blocks game!
Bricklayer is a fast-paced falling-blocks game with 256-color graphics, sound effects, 
and background music which add a pleasant twist to an apparently common game.

The rules of Bricklayer are simple.    Oddly-shaped blocks appear at the top of the pit 
and drop toward the bottom.    When a block reaches the bottom, it stops moving and a 
new block appears at the top.    When blocks are dropping, they may be rotated or 
moved left or right.    By manipulating blocks as they fall, you can control the place and 
orientation in which they land.    The object of the game is to drop blocks so that they 
completely fill horizontal rows of the pit.    When a horizontal row is completely filled with 
no gaps, it will disappear and the blocks in the rows above will drop down to take their 
place.    The game ends when the pit is entirely filled with blocks, so the more rows you 
clear, the more pieces you'll have room for, and the longer you'll be able to play.

Bricklayer 2.0 introduced two variations on these standard rules: heavy blocks and 
decaying pieces.

System Requirements
Bricklayer has been beta tested on i386, i486, and Pentium systems with 4-16MB of 
memory.    The memory requirements may be quite steep because Bricklayer needs to 
load close to 1MB of music files.    To enjoy the background music and sound effects, 
you will need to have a sound card with wave playing ability supported by Windows 
(such as Microsoft Sound System or Creative Labs Sound Blaster compatibles).

See troubleshooting for advice with common problems.

Related Topics:
How to play a Game
Controls
Scoring
AutoPlay



Scoring
You receive points for dropping 
pieces, and for clearing rows.

The number of points you receive for clearing a row increases if you clear more rows at 
once.    The first row eliminated by dropping a block is worth 100 points.    If dropping the
block eliminates two rows, you receive 100 for the first row and 200 for the second, for a
total of 300 points.    The third row is worth 300 points, and the fourth 400, so if you 
eliminate four rows with the placement of a single block, you are awarded 1000 
(100+200+300+400) points.    This makes eliminating two or more rows simultaneously 
more advantageous than eliminating them one at a time.    You also receive 1 point for 
each row that a block falls when you drop it.    In addition, there are ways of scoring 
large bonuses by making special plays, but you'll have to discover them for yourself!

Related Topics:
How to play a Game
Controls
AutoPlay



How to Play A Game
To quickly get started, select Begin Game from the File menu, or just use the key 
sequence Control-B.    If you are just starting out, you will begin playing on Level 1.    
Use the default J, K, and L keys to move the falling block left, rotate it, or move it right, 
respectively.    To drop the block, press the SPACE key.    You can change the key 
bindings for these actions by selecting the Change Controls option from the Options 
menu.

To play a two-player game, select Two Player Game from the File menu.    To play a two-
player game against a computer opponent, select Play Against Computer from the File 
menu.

Related Topics:
Controls
Scoring
AutoPlay



Registering
Bricklayer is $10 shareware and 
free for those people who've paid 
for previous versions.    
Registered users may order a 
Bonus Disk Set either at the time 
of registration, or at a later date.
CompuServe users may register 
electronically and get their codes 
by email!

If you enjoy and play Bricklayer, please send in the $10 shareware fee.
It is not very much compared to the cost of a commercial game, and it motivates me to 

keep improving Bricklayer as well as to work on new games.    If you play, please 
pay.    Upgrades to new versions of Bricklayer are always free for registered users.    
Those who register will also be kept informed of new version releases, as well as the
releases of any new products.

To register Bricklayer, please either
· send a US$10 check payable to Yevgeny Gurevich to the address listed below.    If 

you live outside of the U.S., please send an international money order (preferred) or 
cash, since checks drawn on foreign banks are sometimes difficult to clear.

· use the Software Registration option in CompuServe: GO SWREG and register 
Bricklayer - registration id #4732.    Users who use SWREG will receive their 
registration codes by email.

Click here to view the registration form (select File/Print to print it).

Site licenses are available - please contact me for more details.

post: Yevgeny Gurevich
Vanilla-Extract Software
P.O. Box 391
Falls Church, VA 22040-0391
U.S.A.

America Online: Yevg
Internet email: yevg@aol.com
CompuServe: 76101,2317
For fast response, request to have the code mailed to you electronically.

Once you have registered, you will receive registration information, containing your 
registration name and registration code.    Once you have the registration 
information, you should enter it into the game.    There are two ways to perform this 



step: select Register from the opening shareware notice window, or select the Register 
menu item from the Help menu once you see the main game window.

A box asking for your registration name and code will appear.    Enter your name and 
code exactly as they appear in your registration information (mailed to you after 
reception of your registration fee.)    If the code is correct, you will be notified 
immediately that the game has been registered.    From that point on, registration 
notices will no longer appear, and your copy will be clearly identified as registered to 
your or your organization.    You may opt to remove the Registered To: information from 
the bottom of the game window through the preferences dialog box.

You may be interested in ordering the Bonus Disk Set.

Related Topics:
Whats new in version 2.0



Bricklayer32 for Windows v2.1a Registration Form
[Name]
Title           _______
Last Name       ____________________  
First Name      ____________________         Initial __

[Address]
if USA:
    Address     _______________________________________________
    City        _______________________________________________
    State, Zip  __   _____-____

if Outside USA:
        Address ________________________________________________
                ________________________________________________
                ________________________________________________
                ________________________________________________
        Country ____________________________

email address   _____________________
Would you like to be notified about
new products/releases via email ?  [ ] Yes        [ ] No
[Additional Information]
Where did you find Bricklayer ?
[] Internet (FTP/WWW/Gopher)            [] Online Service
[] BBS                                  [] Friend
[] Software club                        [] store-bought CD
[] book CD                              [] Other
Pricing Information
Description                           Qty   Unit Price       Total
Single-User Registration                        $10.00
Additional Single-User License                  $ 5.00
10-machine site license                         $50.00
25-machine site license                        $100.00
Unlimited site license                         $150.00
Latest Version on disk                          $ 3.50*
Bonus Disk Set of Music and Graphics            $10.00*
(includes latest version)
Total Enclosed:
------------------------------------------------------------------
* Only registered users or users registering with this order are eligible
  to purchase disk sets.  Price includes media and shipping charges.

Thank you for registering Bricklayer32 for Windows v2.1a!
Please send US$10 for each copy of Bricklayer to be registered to:
      Yevgeny Gurevich

Vanilla Extract Software
P.O. Box 391
Falls Church, VA 22040-0391
USA



AutoPlay
The AutoPlay feature lets the computer play a game of Bricklayer.    The computer plays 
at two levels of intelligence - Quick n Dirty and Deep Thought.

The fast player thinks quickly but is not as good at playing the game as the slower and 
smarter player, which uses the Next Piece for lookahead.    On systems like i486DX2-
66's, the smart player is faster than the dumb player on an i486SX-33.

Related Topics:
None



Bonus Disk Set
The Bonus Disk Set is a collection of music and graphics files to make Bricklayer even 
more varied and exciting.    The disk set contains the latest version of Bricklayer, and 
additional disks, consisting of 5 original music compositions, 3 to 4 background graphics
modules, half a dozen new piece graphics designs, and several pit graphics.

This disk set is only available to registered Bricklayer users.

You may order the disk set together with your registration, or may do so separetely at a 
later time.    Users who have registered previous versions of Bricklayer are welcome to 
purchase it.

The price is just $10.00 which already includes the shipping and media costs.

Please specify that you are ordering the Bonus Disk Set for Bricklayer32, as music and 
graphics modules are not interchangeable between Bricklayer and Bricklayer32.

Related Topics:
Registering



Whats new in version 2.0 ?
Version 2.0 of Bricklayer 
introduces a host of new features 
and improves the user interface.

· This version of Bricklayer has support for selecting entire directories of graphics 
modules at a time.    Pit graphics are changed once per level, while backgrounds and piece 
graphics are changed once per game.    These options are available through the preferences dialog 
box, and by right-clicking to get a Properties menu (see next item).

· Graphics modules can now be selected simply by right-clicking in the main game 
window!    Right-click in the pit to change pit graphics, right-click on a piece inside the
pit to change piece graphics, or right-click outside of the pit over the background to 
change background graphics.    The list of available files is taken from the directory where the 
currently-selected graphic resides.    Most likely, this is the directory where Bricklayer is installed.    
You can select individual files or the entire directory.    If you select the directory, you can opt to have 
sequential selection of files (default) or select Randomize Directory to have Bricklayer choose 
modules at random.

· Joystick support has been added to Bricklayer.    The Change Controls menu option 
may be used to select joystick versus keyboard input.

· Two-player mode has been added!    You can now play Bricklayer against a human 
or computer    opponent.    More details are provided in the two-player page.

· Two new variations on the game have been added: heavy blocks and decaying 
pieces.

· The high-scores table has been expanded with room for 15 names, and now 
includes the number of rows cleared as well as the game playing date.    There are 
separate high-scores tables for single-player and two-player games.

New in Version 2.1a
· You can now use the numeric keypad keys and arrow keys in specifying game 

controls for the keyboard.    This allows you to use virtually any key on the keyboard 
to control pieces.

· Double-Sized blocks has been replaced with a general Block-Size slider.    You can 
select to play with normal-size pieces, and pieces which are 25%, 50%, 75%, or 
100% larger.    100% is equivalent to double-size blocks in versions 2.0b and earlier.

· The size of the game pit can be changed with sliders.    You can change the number 
of rows and columns in the game pit independently.    The default values are 10 
columns by 20 rows.

· Your high scores can be uploaded to the Microsoft Kids Space.    When you enable 
this option in the game Preferences, Bricklayer32 will attempt to contact the space 
and send your high scores (or they may be sent later if you are not logged on).    You
can view your current space high scores by selecting Game Space High Scores 
from the Options menu.    Only scores from default games (no decaying pieces or 
heavy blocks enabled , and a pit size of 10 by 20) will be eligible for uploads.



Related Topics:
Registering Bricklayer



Changing Background Graphics
Background graphics are bitmaps which are tiled in the main game window, usually 
different for each level in the game.    You may select alternate graphics modules in the 
Graphics sheet of the preferences dialog box, or by right-clicking on the main game 
window background to bring up the Background Properties menu.

You can select a file or an entire directory of modules.    If you select a directory, 
Bricklayer will select a new backgrounds module each time you start a new game.    By 
default, Bricklayer will cycle through the modules sequentially.    You can also direct 
Bricklayer to select modules randomly by selecting Randomize Directory from the 
background properties menu.

Once a new module is selected, it is loaded instantly and loads by default the next time 
that Bricklayer is executed.

If you are selecting alternate graphics modules by selecting Browse from the Graphics 
sheet of the preferences dialog box, the File-Open dialog box may not show the drive 
where Bricklayer is installed.    In this case, you will need to change to the directory 
where the alternate graphics modules are installed.

Related Topics:
Changing Piece Graphics
Changing Music Modules Changing Pit Modules



Changing Pit Graphics
Pit graphics are bitmaps which are drawn over the black pit area of the game.    By 
default, no graphics are shown to improve game performance.    You may select 
graphics modules to be drawn in the pit area (and enable them being shown) from the 
Graphics sheet of the preferences dialog box, or by right-clicking on the game pit to 
bring up the Pit Properties menu.

You can select a file or an entire directory of modules.    If you select a directory, 
Bricklayer will select a new pit module each time you start a new game.    By default, 
Bricklayer will cycle through the modules sequentially.    You can also direct Bricklayer to
select modules randomly by selecting Randomize Directory from the pit properties 
menu.

Once a new module is selected, it is loaded instantly and loads by default the next time 
that Bricklayer is executed.

Make sure to enable the drawing of the graphics by selecting the Show Pit Graphic 
checkbox in the Graphics sheet of the Preferences dialog box, or by selecting Show Pit 
Graphic from the pit properties menu.    Once this option is enabled, all future games will
use pit graphics.

New to version 2.0 are multipit modules.    These modules are similar to normal pit 
graphics, except that there are several graphics grouped into a single file.    As you play 
a game which uses a multipit module, a new graphic starts to inch its way up the game 
board to replace the previous graphic, controlled by the number of rows that you clear.

Please note that when playing with larger than normal blocks, the game performance 
will suffer heavily.

Related Topics:
Changing Piece Graphics
Change Music Modules
Change Background Graphics



Changing Music Modules
Music modules are used as the source of the music which plays in the background 
during a Bricklayer game. You may select alternate music modules from the Music 
sheet of the Preferences dialog box.

Once a new module is selected, it is loaded instantly and loads by default the next time 
that Bricklayer is executed.

The easiest way to select alternate music modules is to click on the Browse button in 
the Music sheet of the Preferences dialog box and double click on available .BM2 files.   
If the File-Open dialog box does not show the drive where Bricklayer is installed, you 
will need to change to the directory to one where the alternate music modules are 
installed.

Artists or programers may contact me for specification of the .BM2 file format so that they may 
develop third-party music modules for use with the game.    If you would like to have your music 
included in future distributions or bonus disk sets, please contact me.    Please ONLY send 
material which you have rights to distribute.

Related Topics:
Changing Piece Graphics
Changing Background Graphics
Changing Pit Modules



Changing Piece Graphics
Piece graphics are the little bitmaps which are drawn to represent each of the seven 
colored pieces in Bricklayer. You may select alternate graphics modules in the Graphics 
sheet of the preferences dialog box, or by right-clicking on the main game window 
background to bring up the Piece Properties menu.

You can select an file or an entire directory of modules.    If you select a directory, 
Bricklayer will select a new piece module each time you start a new game.    By default, 
Bricklayer will cycle through the modules sequentially.    You can also direct Bricklayer to
select modules randomly by selecting Randomize Directory from the piece properties 
menu.

Once a new module is selected, it is loaded instantly, and loads by default the next time 
that Bricklayer is executed.

Related Topics:
Changing Background Graphics
Changing Music Modules
Changing Pit Modules



Music and Sound    
Bricklayer contains terrific sound effects and 
background music.    Through the Options 
menu, you can elect to hear just the 
background music, just sound effects, or 
both.

Sound effects and background music can be individually toggled using the Music and 
Sound Effects menu items in the Options menu.    A check mark next to each of the 
items means that it is active for the current and all following games.

Control over whether background music and sound effects are loaded each time 
Bricklayer is executed is handled by the Load Music check box in the Music sheet of the
Preferences dialog box.    For users who do not have wave-output sound support, the 
Load Music option can be deselected (no check mark).    This will prevent Bricklayer 
from loading the background music and speed the total load time.    All sound and music
options will be disabled for future loads as well.    This option may be checked off to 
enable loading music at any time.

Wave Mixing
This version of Bricklayer32, 2.1A, uses the Microsoft DirectSound library.    You must 
have DirectX installed for the music and sound to work.    DirectX can be installed from 
DirectX distributions with the DXSETUP.EXE program.

The music .WAV files and .BM2 modules are Copyright Opinicus Microtechnologies, 
and may be freely distributed only as part of the Bricklayer32 for Windows game for use
by the Bricklayer32 program.    See the distribution information for more details.

Related Topics:
Changing Music Modules



Controls
Bricklayer may be played using keyboard controls or a joystick.    The default are 
keyboard controls shown below:

j Move Left
k Rotate
l Move Right
SPACE Drop
a Push Down

The numeric keypad keys are always active as control keys in addition to any user-
selectable settings.    On the numeric keypad, the 4, 5, 6, and 0 act the same as the j, k, 
l, and space.

Keyboard control is customizable with the Change Controls item in the Options menu.    
When you select Change Controls a dialog box lets you select the player for whom you 
are changing the controls, and the type of control (keyboard or joystick) that player will 
use.    For single-player games, the controls for Player 1 are used.

If you select Keyboard controls, five edit fields allow you to edit the keys that will be 
used to control the pieces.    These keys are saved in the Bricklayer preferences file and
are active in the current game of Bricklayer, and all future games as well.    In addition to
the alphanumeric keys, you can specify the cursor four keys, nine numeric keyad keys, 
or the special insert/delete/home/end/pageup/pagedown keys. Controls may be 
identical for both players in a two-player game.

If joystick controls is selected, you should select the Calibrate Joystick button to 
calibrate your joystick for use with Bricklayer.    Joystick control of pieces is as follows:

Move the piece left or right by moving the joystick left or right.
Rotate a piece by pressing button #1 on your joystick.
Drop a piece of pressing button #2 on your joystick.
Push a piece by moving the joystick down.

Related Topics:
How To Play A Game
Scoring



Comments, Suggestions, Bug Reports
I look forward to hearing from you.    If you encounter problems while playing Bricklayer, 
I would appreciate any information that you can provide, such as your system 
configuration and a detailed description of the problem.    Suggestions for improvements
are also welcome.

Send email to
yevg@aol.com

or, via CompuServe to
76101,2317



Bricklayer Preferences
Bricklayer has many options which you can set to customize the game to fit your taste.   
Select Preferences from the Options menu.    A preferences properties dialog box 
appears with tabs for different sheets.    Click on the tabs to select among general 
options, graphics options, and music options. Sheets contain check boxes to toggle 
system settings, and Browse buttons to select alternate graphics and music files.    The 
options available through these sheets are summarized below:

Fast Left/Right Motion If this option is on, holding down the move left or right key 
continuously will move pieces faster.

Pause on Lose Focus If this option is on, the game automatically pauses when 
you switch from Bricklayer to another program or window.   
With this option off, the game continues even if you move 
on to another program.    Unselecting this option is useful if 
you want to see the computer play in the background.    
The music will not play once you switch from Bricklayer so 
as not to hog the sound resources.

Force 16-Color Mode On some 16-color-only systems may speed up the game.

Load Music on startup By default this option is on and tells Bricklayer to load 
music files each time the program is loaded.    Setting this 
option off will prevent music from being loaded, speeding 
load time but preventing you from listening to the 
background music.

Blocks Size Specifies the size of the game blocks and the 
corresponding game window.    The slider ranges from 
normal to 25%, 50%, 75%, and 100% (double size) larger.  
The game window will be scaled according to this setting.   
If the game window will be larger than can be displayed on 
your system, a warning dialog box will come up, letting you
cancel the size-change.    Larger blocks and gameboards 
are useful for systems with high-resolution displays.    
Theyre easier for some children to play with as well.

Remove Notice Gets rid of the Registered To: information box at the bottom
of the game window, if checked.
 

Show Pit Graphic Enables the display of the pit graphic over the black game 
board.    When double-size blocks are also enabled, using 
this feature on will heavily impact the performance.
 



Columns Specifies the number of columns in game pit.    The default 
number of columns is 10.
 

Rows Specifies the number of rows in game pit.    The default 
number of rows is 20.
 

The input box in the General sheet allows you to enter how many levels of debris are 
placed on the screen at the start of each game.    You can challenge yourself or the 
computer by increasing the debris.

The Music, Background Graphics, Pit Graphics, and Piece Graphics browse buttons 
allow you to select alternate music and graphics modules.    Just click on the appropriate
browse button to get a listing of available files.

Related Topics:
Changing Background Graphics
Changing Piece Graphics
Changing Pit Modules
Music and Sound Options



Variations
Bricklayer 2.0 includes two variations on the standard game - heavy blocks and 
decaying blocks.    You can select either of these variants by selecting the entries in 
the Variations submenu of the Options menu.    If you get a high score while playing a 
variation game (as opposed to the standard game) your high-score entry will be marked
with an asterisk (*) to denote the fact that it was a variation game.

Heavy Blocks
Some pieces that drop from the top of the screen are outlined and consist of heavy 
blocks.    If a heavy block lands on a stack of other blocks, it will push the entire stack of 
blocks down by one square, if the stack is sitting atop an empty square.

Decaying Blocks
As you stack more and more rows without clearing them, blocks begin to disappear 
(decay) from the board.    To stop this decay, you must clear a row where the last block 
that had decayed, or drop a piece on top of a space where the last block had decayed.



Two-Player Games
Bricklayer 2.0 allows two-players to play a game together.    Select Begin Two 
Player Game from the File menu.    Players take turns on the same gameboard.    
Scoring is just as it is for single-player games, except that separate scores and number 
of rows cleared are kept track for each player.    At the end of the game, either or both 
players may earn high scores.    High scores for two player games are kept separate 
from single-player games.

Players may use the same keyboard bindings for movement, or use different controls.    
They may even have one player use a joystick while the other uses a keyboard.    See 
Controls for instructions on how to modify keyboard and joystick settings.

A human player can also elect to compete against the computer.    Select Play 
Against Computer from the File menu.    The human player alternates controlling 
pieces with the computer.    Scoring is just like it is for two-player games.    In the high-
scores table, entries for players which competed against the computer are marked with 
a C.



Common Problems and Solutions
Due to rather steep memory and processor requirements, some users may experience 
problems starting, or playing with Bricklayer.    This section details some common 
problems and their solutions:

Bricklayer won't start up Often due to insufficient memory or incompatibilities with sound 
hardware.

Try creating a file called BRICK32.INI in your WINDOWS 
directory and putting the following lines there:

[Settings]
LoadMusic=0

This will force Bricklayer to ignore the music and sound settings 
and not load any music files.    You will be able to play, but will 
have no music or sound effects.

Background music stops 
playing during the game

Some problems involved with mixing the sound effects and 
background music result in the background music 
sometimes stopping after a few minutes of playing.    You 
have several options.

· If you select to have music but no sound effects, this problem
does not seem to occur.

· You may press the TAB key to restart the music during play.

Game seems extremely 
slow

On some slower computers, the processing needed to play the 
background music and sound effects becomes the major time 
sink.

Try unchecking the music and/or sound options.    Without 
background music, the game will feel snappier on slower 
computers.

Audible clicks when 
pieces drop

The sound mixing is done in software and is not perfect.    Some 
audible clicks may be heard when pieces drop and background 
music is on.    This is especially evident when using AutoPlay.

If you like the background music, getting rid of the sound effects 
by unselecting them from the options menu will make the music 
sound much smoother.    If you value the sound effects more, try 
unselecting the music option.    The clicks will be less evident.

Make sure that your soundcard is supported by DirectSound for 
optimal performance.




