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This document outlines enhancements and bug fixes in version 2.0 of the
Pocket Recorder application, as well as items which will be addressed in 
future releases.

---------------------------
Enhancements in version 2.0:
---------------------------

I. Selecting A Region Of The Wave File.

It is possible to select a region of the wave file by clicking down on
a mouse button while in the waveform view area, and, while continuing to
hold the mouse button down, moving the mouse to a new position within the
same view area.  Similarly, 'shift-click' selection is possible by
simultaneously holding down the SHIFT key and clicking the mouse button
at a point in the waveform view area.  This will select a region between
the current position and the position where the mouse was clicked.

This functionality works exactly as similar selection functionality found
in many word processers, where you can select a region of text, with the
exception that you cannot scroll the waveform view while you are selecting
(i.e., you cannot hold down the mouse button and drag the mouse cursor
outside of the waveform view area to cause the waveform to scroll).
Waveform scrolling functionality will be added in a future release of
this application.

In the meantime, when the waveform view area is in 'zoomed-in' mode, it IS
possible to select a region larger than that which can be displayed in the
view area.  To do this, use the following 'shift-click' functionality:

Set the current-position-cursor (the red line in the waveform view area) to
the beginning of the region you wish to select, then scroll the view area
to the part of the waveform where you want the region to end.  Then, while
holding down the SHIFT key, simultaneously click on a mouse button, and the
region between the current position (which may have scrolled out of view),
and where you clicked the mouse, becomes the selected region.

Note that if there currently is a region selected, clicking on ANY mouse
button in the waveform view area will remove that selection.  This does
limit selecting to one zoom mode at a time.  That is, you cannot select a
region in 'zoomed-in' mode, then zoom-out while maintaining that selection,
because to zoom-out you must double click on the waveform view window, which
will remove any defined selection.

II. Cut, Copy, Paste And Delete.



The options in previous versions which allowed limited editing of the wave
file have been replaced with standard Cut, Copy, Paste, and Delete options.

To use Cut, Copy, and Delete, select a region of the wave file
as described above, and use one of options in the Edit menu to perform the
desired action.

These options behave similarly to other windows applications:  Cut will 
copy the deleted region to the clipboard, then delete the region from the
wave file; Copy will simply copy the selected region to the clipboard;
Delete will delete the selected region from the wave file without affecting
the contents of the clipboard.

To use the Paste function, place the current-position-cursor at the position
in the waveform view area where you want the paste to occur, and select the
Paste option from the Edit menu.

The Paste functionality differs slightly from many standard Windows applictions
in that it is not possible to paste into a region.  Instead, the wave data which
is pasted will always be pasted starting at the current position, and any selection
which had been defined will be removed.  Functionality to allow the pasting of
wave data into a selected region will be added in a future release of this
application.

It is only possible to paste data which is of the exact format as the wave
form which is being displayed.  Format includes sampling rate, bits per
sample, and number of channels.  You cannot paste a 44KHz, 16bit, stereo
region into a 22KHz, 8bit, mono file.  Functionality to allow the pasting
of different waveform formats will be added in a future release of this
application.

III. Settings Saving.

The application's settings, which include sample rate, bits per sample, and
number of channels, as well as the X and Y position of the window are now
automatically saved when the application exits.

In the interest of keeping the menu-interface as minimal as possible, and from
a consensus that in the vast majority of cases this settings saving functionality
will be desired in the vast majority of cases, the option to NOT save the
settings when you exit the application is not supported.

However, if you really want to change your settings in an instance of the
application, without having it save the settings when you exit, there are two 
suggested ways to bypass this limitation:

1. Change the command line of your application to include a wave file to be
loaded on program startup.  The application's record parameters (sample rate,
bits per sample, number of channels) will be set to those of the wave file
specified.  A deficiency of this method is that it will not save the X and Y
positions of the applications windows.

2. Run two instances of the application, and change the settings of only
one instance.  When you are done, close the changed instance first, followed by
the instance in which the settings were not changed.  The settings saved when



the first instance was closed will be overwritten by the settings of the
second instance, in which no settings were changed.  This method will allow
you to save all settings, but it does require you to execute two instances
of the application.

If enough people complain that the lack of functionality for NOT saving
settings is a problem, it will be added in a future release of this application.

IV. Downsampling To 8 Bits.

An option was added to the Effects menu which makes it possible to convert
(downsample) a 16 bit wave file to 8 bits.

Because of problems associated with some versions of 16 bit capable hardware,
recording in eight bits may introduce more noise into the recording than
necessary.  The solution to this problem is to record in 16 bits, then use
the Convert To 8 Bits menu option.

This option may also be used to effectively halve the size of a 16 bit file
when that quality of recording is not deemed worth the disk space it requires.

V. Setting Temporary Directory.

It is possible, through the Set Temp Directory option in the File menu, to
set the directory in which the application will create it's necessary 
temporary files.

In previous versions of the application, the directory for temporary files
was derived from the TEMP environment variable in DOS.  Because people often
set this variable to a RAM drive of limited size, it seriously limits the
size of recordings and/or file editing that can be achieved.

This option makes it possible to bypass the TEMP environment variable by
specifying a temporary directory which will only be used by this application.

To use this option, do the following:

1. Select the Set Temp Drive option in the File menu.

2.  If a file is loaded and has been modified, a message box querying whether
the modifications should be saved will appear.  Either the Yes or No option
must be chosen to change the temporary directory.

3.  A Set Temp Directory dialog box will appear in which it is possible to
select the current drive and directory for the applications temporary files.

Selecting the OK button in this dialog box will cause the applications
temporary files to be recreated on the newly specified drive and directory.

Selecting the Cancel button in this dialog will cause the application to
ignore any changes made to the specified drive and/or directory.

Selecting the Remember check box makes it possible for the specified temporary
drive and directory to be remembered in future instances of the application.

For example, if D: is a RAM drive, and the TEMP environment variable



in DOS is set to a directory on this drive, it may be desirable for this
application's temporary files to always be created on C:\TMP (or some other
directory not on the RAM drive).  In this case, use the Set Temp Directory
dialog box to change the drive and directory to the desired settings, and
check the Remember check box, followed by clicking on the OK button.  If
the application is able to create a file in the supplied directory, all
future instances of the application will default to the new temporary 
directory which was just defined.

As a justification for why any editing changes must be saved or discarded
prior to changing the temporary directory, it should be noted that in the
design of this application a trade off was made between speed of execution
and the size of files which can be recorded or edited.

Because the ability to handle large files was considered a primary design
criterion, all editing changes are stored in a temporary file which is
essentially a mirror image of the original file, plus (or minus) any
modifications.  This makes the Revert option possible, by simply
reinitializing the temporary file, and makes large amounts of editing
possible, because changes are not stored in memory.

In summary, it was decided that to specify a new temporary directory,
followed by the copying of the current temporary file to the new temporary
directory, with a possible failure condition due to lack or available space
or access privileges, was too clumsy.  With the file saved or with changes
discarded, the temporary file is not used, so it can simply be deleted
and recreated at a minimum size in the new directory.

VI. Auto-Stopping During Recording.

The application will no longer allow recording to be performed past the point
when the temporary recording file grows to large to be saved.  When this point
is reached, a message box will appear indicating that the recording will
be stopped.

It is suggested that the file be saved at this point if any editing is to be
done which will increase its size.  After any such editing, the file will
probably not be saveable.

To calculate the amount of disk space which can be used to record a file,
take the total free space of your temporary drive, subtract the size of the
file (if any) currently loaded by the application, and divide by two.

---------------------------------
Log of bug fixes and enhancements:
---------------------------------

* 05/23/92 MMQ - Fixed a bug which caused an incorrect time-to-sample 
conversion for wave files more than one hour long.

* 05/25/92 MMQ - Fixed a bug which allowed user to set the wave-display
cursor one pixel to the right of the interior of the wave-display view
window.  This fix also inhibits the ability to set the wave-display
cursor by clicking one pixel below the interior of the wave-display
view window.  This fix also inhibits the ability to hilight the meter-
display window by clicking one pixel to the right or one pixel below



that window.

* 05/25/92 MMQ - Added wave file select functionality.

* 05/25/92 MMQ - Added paste-from-clipboard functionality.  Currently
only allows you to paste from identical wave format.

* 05/26/92 MMQ - Added Cut, Copy and Delete editing functionality.

* 05/26/92 MMQ - Added accelerators for Open, Save and Save As in
the File menu, and for Cut, Copy, Paste and Delete in the Edit menu.

* 05/27/92 MMQ - Fixed a bug which caused PR to display 'untitled' in
the caption when called with a command line argument which was a simple
filename.  It worked correctly if you supplied a complete pathname.

* 05/27/92 MMQ - Fixed a bug in the Voice Dialog box in the Effects menu
which did not properly update the "1/n of a second" text when you
clicked on and dragged the scroll bar thumb.  Also modified it to
display the proper 'st', 'nd', 'rd', or 'th' suffix, depending on
the denominator of the fraction displayed.

* 05/27/92 MMQ - Made the "File/Save" menu item disabled if there have
been no changes or if their is no filename.

* 05/28/92 MMQ - Made the wave-time display in 1/100th of seconds instead
of the previous 1/10th of second.  Also made the current position part
of this display update while playing and recording.

* 05/28/92 MMQ - Fixed a bug which caused bogus .WAV files to be created
in various modes when recording.  Problem was due to invalid format
information being written to the wave file.

* 05/29/92 MMQ - Fixed bugs which cause waveOutUnprepareHeader messages
to occur while playing and recording.   This also caused associated
GlobalFree'ing a locked object bugs when exiting the application, all
under debug version of Windows only.

* 06/09/92 MMQ - Fixed a bug which caused wave files with a center-line
problem to be displayed incorrectly.

* 06/10/92 MMQ - Fixed a bug which caused the selected region in the
wave file view area to become completely hosed when you tried to
scroll it.

* 06/10/92 MMQ - Made the wavefile-length display change while recording.

* 06/10/92 MMQ - Made the "in" and "out" wave file positions disappear
when recording in ZOOMED IN mode.

* 06/10/92 MMQ - Fixed a bug which I had caused when implementing the
"update wave-position while recording" functionality. So recording
from the current position works correctly, again.

* 06/10/92 MMQ - Made the cursor update its position in PLAYBACK only
when ZOOMED OUT only.



* 06/12/92 MMQ - Added "shift-click" selecting functionality.  You can
select a region between the current position and the cursor by holding
the shift key and clicking a mouse button.  If there is already a 
region selected, the "pivot" point (that is, the point where you
initially clicked to start the selection) stays the same, and the 
position is changed to the point of the mouse click.

* 06/17/92 MMQ - Fixed display bugs in "shift-click" selecting.

* 06/18/92 MMQ - Made it so the cursor position is centered in zoomed-in
mode after playing, recording, cutting, deleting, and pasting.

* 06/19/92 MMQ - Made an OEM Version, which has no media vision logo,
author names, or copyright stamp in the about box.  To compile this
version, you should modify the DEF = line in the makefile like this:

DEF = -DOEM

* 06/19/92 MMQ - Changed the version to 2.0 in the about box.  Also
added my name (Mike McQueen) to the author line.

* 06/19/92 MMQ - Removed compression options from the New... dialog
box, and removed the display of the compression bitmap from the
main PR window.  All of this can be re-enabled by modifying the
DEF = line in the makefile like this:

DEF = -DUSE_COMPRESSION

* 06/19/92 MMQ - Added a settings save when you exit PREC.  It will
save the current record parameters including sample rate, bits per 
sample, and # of channels, as well as the X and Y position of the
window.

* 06/22/92 MMQ - Added an effects option for converting a 16 bit file
to 8 bits per sample.  This might still have some weird tweako bugs
for special rounding cases.

* 06/22/92 MMQ - Fixed display bug in wave view window which caused a
"drop-off" of the waveform on zero-length files.

* 06/22/92 MMQ - Fixed a bug which cased the "To go:" window and graphic
disk-space-free window to display data for the drive which the current
file was read from, and not the current "temporary" drive.

* 06/26/92 MMQ - Added the "File/Set Temp Directory..." menu item and
dialog box.  Per talk with KenNi, this was changed to directory vs.
drive only.  With the dialog box, you can set the drive and directory
for PR's temporary files.

* 06/26/92 MMQ - Changed and/or reworded a few error messages.
Specifically:
. A single error message dealing with the accessing of

temporary files has been made.
. An initial warning that you don't have any sound driver

loaded if that is the case.



. In the new parameters dialog box, a slightly more helpful
message occurs if you enter a bad "other" sample rate.

* 06/29/92 MMQ - Added auto-stopping during recording when the temp
drive runs out of space.

* 07/04/92 MMQ - Fixed a bug which was causing the cursor to not be
displayed in zoomed in mode when the file was fast forwarded, or when
the scroll bar thumb was dragged to the far right.

* 07/04/92 MMQ - Fixed a bug which caused the current position display
(in seconds) to not be updated if the rewind button was clicked when
the wave view window was scrolled to the far left in zoomed in mode.
Similarly, this bug occurred while fast forwarding when scrolled to the
far right.

* 07/04/92 MMQ - Made the File/Revert menu item disabled if there have
been no changes to the wave file.

* 07/10/92 MMQ - Fixed a bug relating to auto-stopping during recording
which caused the file to not be able to be saved.

* 07/14/92 MMQ - Made it 'nuke old tempfiles on startup'.  OOPS, this
probably should have been in here earlier. :)

* 07/14/92 MMQ - Added WAVE_MAPPER functionality.  What this does is
it leaves the decision up to windows as to which wave device will be
used when you are recording or playing back.  This essentially disables
all the functionality in PREC which no one probably ever even knew
about, which allowed you to specify which product and manufacturer
ID you wanted to use for these functions.  What this theoretically will
allow you to do is have two instances of PREC, each one recording (or
playing back, or both) from a different device, on a multiple wave-
device system (such as the PAS16).

-----------------------------
Wish-list for future releases:
-----------------------------

The following is the current list of features to be added in future versions
of the application.  We encourage feedback on these or any other ideas which
someone may have.

Pri Description
--- -----------

2 fix saving after recording so it doesn't copy again.

2 Make "scrolling-while-selecting" work.

2 Make "play-selection" work. - maybe.

2 Text strings to resource file.



2 Common file dialog.

2 Fix OLE bugs.

2 Add a progress meter for functions that take a while to complete.

3 Scroll bar for instantaneous playback rate changing.

3 HELP system.

3 Investigate why "Faster" and "slower" don't work as well as MS's.

3 Make "paste-into-selection" work.

3 Make a View option to switch between right/left channel.

3 Save directory in open/save dialog.

3 PREC.INI instead of WIN.INI.  Make it so if user has crap in WIN.INI,
it reads all that out, copies it to PREC.INI, and nukes WIN.INI.

3 While selecting a region of the wave file, it might be useful to show
some indication of how big of a region you are selecting.

3 It is possible to make an application part of the "Clipboard Viewer
Chain."  If you do this, your application can be responsible for 
displaying certain unsupported data formats in the Clipboard Viewer
application.  Although CF_WAVE is a defined constant in Windows.h
(CF for Clipboard Format), the clipboard viewer does not actually
display the data.  It would potentially be very trivial to use the
existing wave-display code in PR to make the Clipboard Viewer app
display wave data properly (that is, similar to how PR displays it),
given that PR was running as well.

4 Hi-Res version including new bitmaps.

4 Make an "undo" command for edit menu and possibly effects menu.

4 Allow paste to handle any type of wave format, including internal
waveform formats supported by WaveEdit, and compressed formats.

4 Make a View option to switch between samples/seconds.


