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Overview
Yacht-Z is a version of the classic dice game.    Now, in addition to triple scoring, single 
scoring is added for quicker, simpler games.    Due to popular request, up to four players 
can now play at one time.    A three dimensional look has been given to all windows and 
dialogs.

The basic premise of the game is to roll five dice up to three times to achieve the highest 
score using the standard scoring grid.    The specifics of scoring will be explained in the text 
that follows.    If you are familiar with the classic game, then you already know how to play.



Playing Yacht-Z
When you open Yacht-Z, you will be prompted to start a game.    If you choose yes, two 
windows will be shown.    They are the Dice window and a Scorecard. At this point a game is
ready to be played.    Many aspects of the game play can be setup from the Options menu.   
The selections available are described as follows:

Show Hints: toggle the hints display (described below).

Single Yacht-Z: toggle the game type between single and triple mode.    In triple 
mode, there are three columns to place scores into.    The example below describes this 
type of game.    Single mode has only one column of scores.

Hide Other Cards: If this item is checked, only the current scorecard will be 
displayed.    The others will be hidden until they become current.

No. of Players: choosing this selection will bring up a dialog box allowing the user 
to set the number of players (1-4) that will be playing.

Change Luck: This menu item is provided for those times when things just don't 
seem to be going your way.    If you register and ask, I will tell you how it works (however, it 
may be just a placebo!).

Some of the selections in the Options menu can be accessed while a game is being played. 
The No. of Players and Single Yacht-Z items are grayed out since they would change the 
format of any game in progress.

Open the File menu and select New Game.    The game windows are opened and drawn.    
These windows are:

Dice: The five dice are shown and controlled here.    To roll them press the Begin 
button.    Dice will roll when their 'backs' are shown (as is the case before the first roll) or 
when one or more dice are selected.    After the third roll, the Begin button indicates Done.   
Below the control button are the scores for all players.    This is helpful when any of the 
scorecards are obscured by others.

Scorecard: All scoring is done here.    Scoring is described in the following section.

Example Game

Probably the best way to describe how to play Yacht-Z is to provide a walk-thru.    Once all 
three windows are showing, press the Begin button in the Dice window.    If the dice tumble 
too slowly for you, open the File menu and select the Show Roll item.    This will cause the 
dice to rapidly update.    Open this menu again and assure that the Show Hints item is 
checked.    When a menu item is checked, it means that the function referred to is enabled.  
If there is no check shown, the function is disabled.

The condition of the Scorecard after a roll depends on the values on the dice.    Since we 
turned on Show Hints, the scorecard will show in black the items which will yield points if 
selected.    All others will be disabled (shown in gray).    You may place a score in any item, 
but if the combination of the dice does not match, you will receive zero points in that box.    
If Show Hints is not enabled, all scoring categories will be shown in black throughout the 
game.

However, since this was the first roll, there is no reason to select a scoring category quite 



yet.    You may select on any roll, but after the third roll you MUST select a scoring category 
(even if it is invalid).

To initiate a roll after the first roll, select which dice will be rolled again by clicking on them 
with the mouse pointer and pressing the Begin button.    If you make a mistake selecting a 
die, it can be corrected by clicking on it once again, which results in turning the selection 
off.    Try this by clicking twice on a die.

When you have selected a scoring category, the dice faces are replaced by the diceback 
design and the Undo! menu item becomes enabled for the first time.    This allows you to 
take back the scoring placement just made.    If you press it, the score is removed and the 
dice faces are restored.    You are now in the same position as before the scoring selection 
was made.    If you have another roll left you can highlight dice and roll again, or place the 
score in a different category.

When playing triple Yacht-Z, the scoring buttons are arranged in three columns.    This is the
essence of the triple scoring method.    The total of the left most column is multiplied by 
one, the second column is multiplied by two and the third column is multiplied by three.    
The totals of all three columns is combined to make up the Grand Total, which is your final 
score.    In single Yacht-Z, there is no score multiplying done, and there are fewer buttons to
press, which results in a quicker game.

The Scorecard is divided into four sections:    The top section comprises the matched value 
scoring.    If you have two fours showing on the dice and select a button on the Fours row, 
you would score eight (8) points on that button.    Only the dice matching the rows type are 
totaled in the first section.    The second section is the total area for the Upper section.    The
total of each column is shown in the Total row.    If this value is 63 or greater, a bonus of 35 
points is awarded and shown on the Bonus row.    The last row of the second section shows 
the Upper section total and is made up of the Total and Bonus rows.

The lower section begins with a portion showing scoring categories based on special 
sequences or combinations using different scoring methods:

Three of a Kind: If 3 or more of the dice match, the total of all dice is entered.

Four of a Kind: If 4 or more of the dice match, the total of all dice is entered.

Full House: If 3 of one face and 2 of another are shown on the dice, then 25 points 
is awarded.

Small Straight: If 4 consecutive values ( i.e. 1,2,3,4 ) are shown then, 30 points is 
awarded.

Large Straight: If 5 consecutive values ( i.e. 1,2,3,4,5 ) are shown then, 40 points 
is awarded.

Yacht-Z: If all dice are of the same value, 50 points is entered into the selected 
button.    If you are fortunate enough to get more than three Yacht-Z's, additional five-of-a-
kind combinations will be recorded in the Yacht-Z Bonus category (worth 100 points), 
starting in the leftmost column.    You must place the score into a valid category to receive 
this bonus (i.e. Four of a Kind).    Note that this only occurs when playing triple Yacht-Z.

Chance: The total of all dice is entered.    This is useful if the values of the dice are 
high, but are not applicable on any other button.    Some versions of the game require you 
to a play if possible and only use the Chance button as a last resort.    Yacht-Z does not 



impose this restriction ( where's the fun in that? ).    The Chance button can be used at any 
time.

The fourth section of the Scorecard is where your total score is computed.    The exact 
layout of this section is determined by the type of game you are playing.    If you are 
playing Single Yacht-Z, then only two totals are shown here: the Lower Section Total and the
Combined Total, which is your final score.    For a Triple Yacht-Z game, there are additional 
portions of this section.    The Lower Section Total is added to the Yacht-Z Bonus to give you 
a Combined Total.    Then this total is multiplied by the column it is located in to yield a 
Grand Total, which is your final score.    This sounds more complex than it is.    Try playing 
and you'll see how it works.

Game play continues until all playable buttons have a score in them.    At this point the 
'Game Over' dialog will appear.    If a Combined Total (Grand Total in triple scoring) is among
the ten highest, that player will be prompted for their name.    This will be placed in the 
High Score list with the date and score, in it's appropriate position.    To play again, select 
New Game from the File menu.

Notice that it is possible to save a game in progress by selecting the Save Game item from 
the File menu.    Any game which is saved can be restored at a later time by selecting the 
Load Game item from this same menu.

High Scores: The ten best single and triple scores are kept on disk along with the 
player's name and the date the game was played.    These scores are shown in the drop 
down menu labeled High Scores.



Strategy
There are as many strategies to playing Yacht-Z as there are players.    Every one in the 
beta-test of Yacht-Z developed their own methods to reaching the highest score possible.    
All were correct.    There are, however, several indisputable guidelines to follow:

-    When in doubt, always go for a Yacht-Z!
- Fill in the third column with your best scores first.
- Use combinations in Upper section first to get Upper Bonus.



Registration
Yacht-Z    is Copyright 1990, 1991, 1992, 1993, 1994 by Bob Dolan, All rights reserved.

Yacht-Z is distributed as shareware.    This means that if you regularly use the product and 
benefit from it, you should register with the author (address below).    The software you now
have is not crippled in any way.    This indicates a basic trust of the shareware concept by 
myself and other shareware authors who provide useful products with the hope of some 
type of return for their efforts.

Please print the registration form and fill in the requested information.

You may contact me electronically in the following ways:

GEnie: DOLAN
Compuserve: 71075,3256

------------------------------------------------------------
A big THANK YOU! to all of you who have taken the time to register Yacht-Z with me.    You 
now own this version as well and all future versions of Yacht-Z.    I appreciate your letters 
very much.
------------------------------------------------------------

Distribution

If you distribute Yacht-Z      to friends, associates, or to a computer bulletin board system 
(BBS),    you may only distribute the compressed file including the copyright and disclaimer.

Disclaimer

The Copyright Owner hereby disclaims all warranties relating to this software, whether 
express or implied, including without limitation any implied warranties of merchantability or
fitness for a particular purpose. The Copyright Owner will not be liable for any special, 
incidental, consequential, indirect or similar damages due to loss of data or any other 
reason, even if The Copyright owner or an agent of The Copyright Owner has been advised 
of the possibility of such damages.    In no event shall The Copyright Owner's liability for 
any damages ever exceed the price paid for the license to use the software, regardless of 
the form of the claim. The person using the software bears all risk as to the quality and 
performance of the software.



Update History
Version 2.5 -- June 1994

Fixed another reported bug regarding an error in handling Yacht-Z bonus scoring.    
The Borland 3D look is replaced with the Microsoft CTL3D look which is smaller and better, I
think.    Window size and position is saved, as is the position of the dice window and all 
scorecards.    The program now prompts to start a new game when the program is first run 
now.    Previously, it would just start a game and this was confusing to some players.    
Scorecard focus is now handled better.    Players cards that are not active have all text in 
them grayed out.    The scorecards are now smaller,    the buttons are bigger, and overall 
the design is improved.

Version 2.22 -- September 1993
Fixed a reported bug regarding an error in handling Yacht-Z bonus scoring.    A zero 

was being placed in the last column and all further bonuses were not scored. (This is really 
quite an impressive user catch.    I've never had more than 2 Yacht-Z's in one game and 
needed to use a special gadget to cheat the game in order to re-create the bug!)

Version 2.21 -- June 1993
Fixed a reported bug where the last player to play was always shown as the winner 

in the playing card caption.    This was noticeable only in multi-player games.

Version 2.20 -- May 1993
When the program starts, a new game is ready to play immediately.
P.O. Box is added to my address.

Version 2.10 -- March 20, 1993
Fix bug that did not allow Yacht-Z Bonus to be awarded (a rare event!)
Added online Help system, which you are now reading. Removed WRI file.

Version 2.00 -- October 31, 1992
Added multi-player capability.
Added Single scoring capability.
Added Hide Other Cards menu item.
Added Change Luck selection.
Removed Show Roll feature.
Removed Set Names dialog.    Names are taken after games.
Implemented COMMDLG.DLL for Load/Save game dialogs.
Implemented Borland BWCC.DLL for custom controls in dialogs.

Version 1.30 -- October 31, 1991
Added Load Game and Save game menu items to File Menu.    Some code 

optimization.

Version 1.20 - 1.28 -- Unreleased versions

Version 1.10 -- June 4, 1991
Moved High Score handling into a new menu item.    Eliminated the High Score 

window.    This made the main window requirements smaller, so its width has been reduced 
to 60% of the screen.    Hopefully any high score handling bugs are gone with this release.

Undo handling is now complete.    All scores are updated at Undo time rather then 
when the score handler gets around to it.    Undo handling is much more reliable.

The dice selection handling has been improved.    They were a bit sticky, and are 
now less annoying to use.

The pushbutton in the Dice window is now instructional.    It shows the current turn, 



as well as Begin and Done at the appropriate times.
There has been some interest in a 2 player version of Yacht-Z.    If this gets 

substantial, I will add that capability.    The only problem is that it takes up a lot of the 
screen.

Version 1.01 -- December 14, 1990
Ooops! A late bug report concerning High score handling caused this fix.    In 

addition child windows are not closeable using the F4 key now.    This caused some other 
obscure problems, which are now avoided.



Registration Form
To print this registration form, open the File menu and select Print Topic.

Please register me as a satisfied user of Yacht-Z (ver 2.5):

Mail to:
Bob Dolan
P.O. Box 16514
Rochester, New York 14616-0514

Please register me as a satisfied user of Yacht-Z    (ver 2.5):

Please enclose $15 in US funds.    Make checks or money orders out to Bob Dolan.    

Your registration entitles you to receive a disk containing the latest version of    Yacht-Z.    In 
addition, this disk will include evaluation copies of all of my other products.    These will be 
the latest versions available, including programs that were not available when this was 
written.    The disk will be a 1.4Mb    3.5 inch floppy unless you request otherwise.    All files 
will be in ZIP 2.0 format unless you request otherwise.

For orders from outside of the U.S., please add $3 to cover additional postage.

Name:_____________________________________________________

Address:___________________________________________________

City:______________________State:_______Zip:__________________

Phone(optional):_____________________________________________

GEnie/CompuServe/Internet mail address:__________________________

Where did you get this program (include address or phone number if 
possible)?__________________________________________________

__________________________________________________________

Comments:_________________________________________________

__________________________________________________________

__________________________________________________________

__________________________________________________________

__________________________________________________________



Other Products from Bob Dolan Software

Windows Shareware

DeskMenu! --    A low profile, text based Program Manager for Windows

There is probably no other program you can add to your system that will make better use 
of its screen and disk space than DeskMenu!    This easily configured program manager and 
resource monitor speeds access to all your applications.    DeskMenu! places a menubar on 
your desktop and allows you to setup the menu headings to reflect how you categorize 
your applications. An optional InfoBar shows time, date and up to six different system 
resources. DeskMenu! can be used in addition to the Program Manager or it can replace it 
as the Windows shell.    All of this functionality in a good looking, easy to use package!

Yacht-Z    --    A dice strategy game for Windows

Yacht-Z is a version of the classic dice game.    You can play single or triple scoring varieties 
of the game.    Up to four players can play at once. This is the original and most often 
reviewed of all Yacht-Z type dice games.    Several years of constant use and valuable input 
from users has honed this into one of the most enjoyable and challenging games available (
unless you prefer blowing up things! ).

WinGo! --    The classic Bingo for Windows

Finally, Bingo has arrived for Windows!    You match wits with Rosie, an alert and cunning 
adversary.    You can play with as many cards as you can handle at the speed you like.    
Fully configurable to adapt to your playing style.    The registered version includes digitized 
voice calling for the most realistic Bingo play possible.

The Joker -- Jokes On Demand

The Joker gives you a laugh whenever you need it. Just as your day is getting completely 
boring, a window will appear with a joke to break the ice.    If one joke doesn't do it for you, 
then press the ANOTHER button for more.    The program is easy to use, and once setup to 
your liking, it will require no maintenance.    You can load different joke files, order more 
from the author, and even create your own.

BattleGrid -- War in a window -- Battleship for Windows 3.x

BattleGrid is a version of the classic board game.    Play against the computer or another 
person.    Watch the computer play against itself using different strategies.    Several levels 
of a computer opponent are available, from idiot to genius.    

SCAT -- A strategic and daring card game

Don't get stuck with the lowest hand!    SCAT is a card game involving four players that can 
be as simple or challenging as you want.    Features include defining strategy levels, setting 
the game speed, and leaving the cards face up or face down as you play.    This game even 



includes conversational chit chat between the players!    Very addicting and fun!

WinDial -- A    Windows Phone Book that dials

An easy to use phone book that will automatically dial any selected number as long as you 
have a modem.    When a busy signal is detected, you can tell WinDial to retry until 
someone answers.    Other busy attempts can be placed into a queue, and all will be retried 
in order.

Mister Clean -- Clean up your hard drive

One of the most efficient ways to clean up those hidden but unwanted or unused files that 
take up needed space.    A slick Windows 3.x user interface makes this utility a must have 
for your toolbox.    Mister Clean finds files the you specify and sorts them by size.    You click 
on the ones you want deleted and then off they go, one-by-one (to be safe) or all at once.    
Not sure what the file is?    Then run it right from Mister Clean and check it out before 
dumping it!    Truly a unique way of managing precious disk space.

Windows Freeware

InstallWare -- An application installer
InstallWare is a small, easy to use application installation program for Windows 
applications.    It costs nothing to use if you are distributing shareware or freeware.

16 Tons -- Drop your sound files here!
Simply plays WAV and MIDI files.    Accepts drag & drop operations from the file manager.    
Most handy when used it as an icon.

Random Saver -- Variety in savers
Make full use of that collection of screen savers you've got.    Now you can get them out of 
your WINDOWS directory.    This utility will run them at random from any location when you 
install it as the default screen saver in the Windows Control Panel.




