
WELCOME

Thank you for obtaining the shareware version of FoneCost. This program is been marketed
on the principle of shareware and it’s only by this success and continuing user feedback has
been possible. APC would like to say thank you.

You are entitled to use this for 30 days after you which you must register.

This manual has been written with the assumption that you understand the basics of Microsoft
Windows™ such as Program Manager and File Manager.

ACKNOWLEDGEMENTS

Call charge data contained within this program or files for use with this program are included
with the kind permission of British Telecommunications plc and Mercury Communications
Ltd. British Telecommunications plc and Mercury Communications Ltd. accept no liability
for its accuracy.

All registered trademarks acknowledged.

There are a lot of people to thank for this release for Windows™, too numerous to mention,
who gave time, effort, bug reports and some splendid ideas that you can now see. The beta
test program lasted over 6 months and was conducted on CiX®.

SHAREWARE

As mentioned above,  FoneCost  is  available  as Shareware.  After  30 days you must  either
delete  all  files  concerned  with  this  program  or  register.  Shareware  relies  on  honesty  to
succeed. Registration brings benefits as shown below.

The latest version.
FONEDATA, a program that will allow you alter/amend call charge data, 

as well as altering the last 3 distance band names to suit your
requirements.

REGISTRATION

To register, you can either print out the form in the help file, by going to the register topic,
and clicking on the ‘print this form’, or by sending your name & address with a cheque for
£15 payable to APC to:

APC
16 Copyground Court
HIGH WYCOMBE
Bucks
HP12 3HG

There may be  a special offer that could be applicable to you. Please read the readme.1st file.



DISK CONTENTS

The accompanying disk should have the following files.

1. FONECOST.EXE The main program.
2. FONECOST.HLP The help file.
3. FONECOST.INI FoneCosts stored setting.
4. FONECOST.WRI File version of the manual.
5. SETUP.EXE The installation program.
6. CTL3DV2.DLLGives 3D effects

Additionally you may find README.1ST. This file will show additional information that was
added  after  this  manual  went  to  printed.  Please  read  this  file  as  it  may solve  any little
problems that you may have been suffering from.

IMPORTANT

This first thing you should do with the program disk is to make a copy for backup purposes.
Do this in the way you normally would, either in DOS or through File Manager. This protects
you should your cat/dog do unmentionable things to your floppy collection and your hard disk
falls over. (All guaranteed to happen within 30mins of each other). 

TECHNICAL SUPPORT

If you encounter problems, or you think you may have found a bug, please contact me by
post, or e-mail me on the following systems. The current mailing address is available in the
help file.

CiX raggorb@cix.compulink.co.uk
CompuServe 100014,2337

There is an open conference on CiX called FONECOST where problems may be reported.
There may be a closed conference for registered users.

For  those  with  INTERNET  access,  e-mail  to  CiX  will  produce  a  faster  response  than
CompuServe, although I do log onto both regularly. Please enclose details of your system,
particularly any tsrs that may be running.

RUNNING - REQUIREMENTS

FoneCost for Windows requires a minimum of Microsoft Windows™ 3.1 to run. Users of
Microsoft  Windows  NT™  will  probably  not  be  able  to  utilise  the  modem  features  of
FoneCost. See README.1ST on your disk for any updates to this.

SETUP will take care of your file locations, but all files must reside in the same directory
except CTL3DV2.DLL which should reside in your windows directory.
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COPYRIGHT

These  programs,  as  supplied,  are  copyright  R  A  Gorbutt  and  Ainley  Publishing  &
Communications 1991, 1992, 1993 & 1994. They may not be altered in any way. This version
is  the  shareware version and may be copied to  your  friends,  colleagues and uploaded to
BBS’s. Magazines wishing to place this on cover disk and/or cd-roms must contact APC for
the  latest  version  and possible  customisation.  Shareware  libraries  may place  this  is  their
library or cd-rom compilations provided that all files enclosed are left intact, and that only a
small sensible charge is made for copying. APC reserve the right to alter this or amend or
restrict at will and without notice. Any shareware library who advertises and doesn’t  state
clearly  in  the  advert  that  Shareware  programs  will  require  further  payment  to  the
programs author if  found useful  or  something similar  have  no  right  to  distribute  this
program.

R A Gorbutt & APC accept no liability for any errors whatsoever. All charge information is
supplied in good faith.

The  call  charge  data  is  copyright  British  Telecommunications  plc.  and  Mercury
Communications Ltd.

CTL3DV2.DLL is © Microsoft Corporation, 1993/94.

INSTALLING

To install  FoneCost  for  Windows,  place  the  supplied  disk  in  your  disk  drive,  and  from
Program Manager, select ‘Run...’ in the ‘File’ menu. Type ‘a:\setup.exe’, if ‘a’ is your disk
drive, amend to ‘b:\setup.exe’ if it’s ‘b’. Follow the prompts. The default directory offered is
‘c:\fonecost’, but change this to your preferred choice. If you want the setup program to place
the icons in a group in Program Manager, then leave the option selected. This has been tested
in ‘Norton Desktop for Windows®’ and ‘PC Tools for Windows®’ as well. 

In the event that ‘Setup’ fails, then the individual files will have to be copied manually to your
preferred directory, with CTL3DV2.DLL being placed in your windows directory.

OPERATING

Double-click on the FoneCost icon. The main window will appear. If you have any queries
when  running  FoneCost,  pressing  ‘F1’,  clicking  on  the  ‘?’ in  the  toolbar  at  the  top,  or
selecting  ‘Help’ from the  ‘Help’ menu  will  bring  up  the  help  file.  FoneCost  requires  a
duration of a call to work, and this can be entered in various ways:-

1. Manually, by typing a time
2. By Using Start/Stop Timer.
3. By the use of the Modem DCD feature.

Each way will be described in due course. The easiest way to start with is to type the duration
in manually, in minutes and seconds. If you enter a duration that’s too large (over 500mins) or
an illegal value, e.g. 2’67”, a warning will be given.

The call charge is then composed from the settings that you can alter, either by using the
mouse, or by pressing ‘ALT+’ the letter that has the underscore associated to it. The distance,
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time and carrier needs to be set. FoneCost has 10 different QuickChoice settings that allow
you to choose your frequently most used setting quickly & easily. See ‘QuickChoice’ later on.

Once you have entered a time, chosen your settings, click on Calculate. This will show how
much a call will have cost according to your details. If you want you can store these details in
the log file. 

MAIN WINDOW

TOOLBAR

Loads a new log file
Saves a log file (same as Save as log file)
Brings up the Logging details
Resets the settings to your default
Toggles Modem DCD
Show help file

DURATION

This will allow you to enter a duration, or it will show the duration of the previous timed call.

DISTANCE/TIME/CARRIER

These settings determine how your call is charged. As these settings can vary, please see the
current help file for the current choices, or the README.1ST file. The last three distance
bands can be altered in FoneData to suit your requirements.

START TIMER (STOP TIMER)

This  button  will  either  start  the  timer,  or  if  the  timer  is  already  running,  will  stop  it.
Depending on other settings in the ‘Options’ menu, when you start the timer FoneCost may
minimize and run as an icon, displaying the cost there, or may just show the accumulating
cost in the status display. 

Additionally the timer can be started and stopped via the system menu, this is mainly for the
use  when  FoneCost  is  running  as  an  icon,  also  the  timer  can  be  utilised  through  the
DDE(Dynamic Data Exchange) features of Windows. A macro is available for MS Word for
Windows V2 & V6.

The timer will take its settings from those selected when the timer is started. Once the timer is
stopped, the duration will be transferred to the duration box, although if ‘Autostore’ is set (in
the ‘Set options...’ menu) the call charge data will be transferred to the log automatically.

CALCULATE

This will  calculate the cost  of  the call  according to the various settings and the duration
entered. The price, both exclusive and inclusive of V.A.T. will be displayed. An option to save
the call information to the log file is available, just click on ‘Store’.
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STATUS

This small window will show you the current status of the timer, the ‘QuickChoice’ setting,
the number of calls stored in the log & the number of new calls in this session.

FILE MENU

IMPORT LOGGING DATA

This allows you to import a log file. FoneCost can automatically import a log file on start-up
if you so wish. This is set in the ‘Set Options...’ choice in the ‘Options’ menu. You will be
given a choice to save any previous unstored logged calls.

SAVE LOG DATA...

This will allow you to save the log file to disk. It will save it to the file you imported, or if a
new log, give you the option to name it. Any previous log files will be renamed with an ‘.old’
extension.  This  can  be  set  to  happen  automatically  when  you  quit  FoneCost.  See  ‘Set
Options...’ in the ‘Options’ menu.

SAVE AS LOG DATA...

This will allow you to save a previously imported log file with a different name. Additionally
the log file can be saved as a comma-delimited file for future import into either a spreadsheet
or database. To do this, click on ‘Save file as type’ in the file selector dialog box and then
click on ‘Comma delimited files’. The default extension of these files is .cdl

SAVE SETUP

This will allow you to save the current setup which includes your call settings, all choices set
in the ‘Options’ menu and QuickChoice settings. This can be set to happen automatically
when you quit FoneCost. See ‘Autosave Setup’ in the ‘Options’ menu.

EXIT

Will close down FoneCost. If ‘Autosave log’ and/or ‘Autosave setup’ are selected, then these
will be saved respectively.

LOGGING MENU

SHOW LOGGING DATA...

Brings up the logging dialog box from where stored call information can be altered, deleted or
viewed.

CLEAR THE LOG

Clears the logged call buffer. A prompt will appear if any calls are unsaved.
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OPTIONS MENU

MINIMIZE ON TIMER DCD

This will allow FoneCost to automatically minimize the main window so that an icon will
appear with the call price information when you either select ‘Start timer’ or ‘Use Modem
DCD for timer’. 

MINIMIZE ALWAYS ON TOP

This will allow the minimized icon to always remain visible (i.e. ‘on top’), so that during
comms sessions, word processing etc. you can see the cost of the call.

USE MODEM DCD FOR TIMER

This will allow the Modem DCD (Data Carrier Detect) line to trigger the timer. Modem users
will find this extremely useful. A prerequisite of this is that the lead between any external
modems and the PC, must have the DCD pins connected. Please see the appendix for some
trouble-shooting information regarding this. The com port information can be set in the ‘Set
Options...’ choice in the ‘options’ menu.

SET OPTIONS...

This will bring up a dialog box in which various options can be set. Most changes will take
place on selecting ‘OK’, but others may only take place after FoneCost is restarted. Further
information is shown in the ‘Options’ section of the manual.

DEFINE QUICKCHOICE

As  mentioned  before,  there  are  10  ‘QuickChoice’ settings.  They  are  defined  here.  See
‘QuickChoice’ for more information.

AUTOSAVE SETUP

OFF
Turns off the Autosave setup option.
AUTOSAVE SETUP EXCEPT MODEM DCD
This will  automatically save the setup when you exit  FoneCost,  except  the Modem DCD
setting will be ignored. This is could prevent the program appearing as an icon on start-up,
unless specifically requested...
AUTOSAVE SETUP INCLUDING MODEM DCD
This will automatically save the setup when you exit FoneCost, including the Modem DCD
setting.

0: QUICKCHOICE - 9: QUICKCHOICE

This will show the 10 (pre or un) defined QuickChoice settings.
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RESET TO DEFAULT

This will allow you quickly return FoneCosts call settings to your default.

HELP MENU

HELP

This will bring up the help file. This file should be up-to-date, so please consult this. The
main window & the ‘Set Options...’ dialog box appear as graphics in this file, and if you click
on the area you wish to know about, more information will appear.

ABOUT

A small dialog box will appear. This will show the version number which is essential for bug
reports.

SET OPTIONS DIALOG BOX

WARNING

This will determine what ‘noises’ can be made if a call cost exceeds the ‘Warn after (pence)’
setting. “Off” will prevent a sound warning. “Beep” will trigger the PC’s internal speaker to
beep. “WAV File” will allow soundcard users (such as Soundblaster® etc.) to play a digitised
sound. The WAV file can be selected by clicking on ‘Select WAV file’.

MODEM - COM PORT

This is applicable to modem users only who wish to utilise the automatic timing off calls. It
defaults to Com 2, but can be altered to any port required.

TITLE BAR

This will determine what can be seen on the title bar (the bar at the top of the main window)
and additionally what is shown in the title area of the minimized icon. Either the name of the
log file (if loaded) or the current QuickChoice setting can be selected.

AUTO STORE ON TIMER

This will automatically add a calls details to the log after the call terminates. This will work
whenever a ‘stop timer’ command is received, either from the user using the timer, or when a
modem call terminates and drops carrier (assuming ‘Use Modem dcd for Timer’ is selected).
If not selected, then after a call the duration is transferred to the duration box, and the call
details must be stored manually.
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WARNING MESSAGE TO APPEAR

Once a call exceeds the ‘Warn after (pence)’ setting, a box can appear telling you of this. This
works in  association with the  sound warning above.  The box will  NOT stop the normal
operation of Windows, particularly if you are downloading at that time. Press ‘Return’ or
click on ‘OK’ to clear the warning message. 

AUTO SAVE ON EXIT

This will allow you to automatically store the log file when you exit FoneCost, thus allowing
you to keep the log up to date.

WARN AFTER (PENCE)

The warning sound and messages  (shown above)  can be triggered if  the  cost  of  the  call
exceeds this amount. This can altered for an individual QuickChoice call. 

DEFAULT SETTING TEXT

This is the title that you want to give for running FoneCost in it’s normal mode of operation.
It will appear in the log as Default: <your text> and also in the title bar if QuickChoice is used
(see above)

MODEM TIME ALLOWANCE

When a modem connects, there is a small time that is used in getting the two modems in the
link to connect and talk. This can vary from a couple of seconds for a 2400baud link, to
approx. 8 sec’s for a V32bis with error correction. Entering a time for your most common
connection will automatically add the time to the end of the call, enabling a more accurate
cost to be established.

SELECT WAV FILE

This will enable you to enter a .WAV file for playing when the warning sounds are activated.

AUTOLOG IMPORT

This will allow you to set a log file to be automatically imported when FoneCost starts up.

Don’t forget to save your setup after you make changes that you would like to keep.

QUICKCHOICE

What is QUICKCHOICE?

QUICKCHOICE allows you quickly alter the settings for your calls by using either the mouse
or the keyboard. You can pre-set 10 different settings as well as your normal default. Uses for
this include a setting for different friends that you call, different clients that you frequently
call, along with different BBS’s that you might call. 
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HOW TO SET-UP QUICKCHOICE

To set-up QUICKCHOICE, select ‘Define QuickChoice’ from the ‘Options’ menu. A small
window will appear. Select either the first undefined call (0 if using for the first time), or a
setting you wish to completely alter. You can double-click or then click on ‘Define’. 

A window, similar to FoneCost will appear allowing you select the call settings, a comment
that will appear in the log, and will also allow you to alter the price at which the warnings will
appear if you wish.

After clicking on OK, you can check that the QUICKCHOICE setting is available, look at the
‘Options’ menu. In the menu you should now see your new QUICKCHOICE.

After setting up your new choices, don’t forget to save the set-up.

USING QUICKCHOICE

QUICKCHOICE settings  can be used by either  selecting it  in the ‘Options’ menu,  or  by
pressing  CTRL +  NUMBER  (From  the  numeric  keypad  only).  CTRL-B,  ‘Reset  to
Default’ in the ‘Options’ menu, or the Reset button in the toolbar will reset the settings to the
start-up values.

QUICKCHOICE settings  can  also  be  used  to  change  logged calls.  When in  the  logging
window, select ‘Quick’ and then select the QUICKCHOICE that you want to use. Currently
hot-keys are not available for this operation.

LOGGING

DETAILS

When you store call details, they go into the log buffer, which can accommodate as many
calls as your memory allows. Details stored include the time and date of the call, the settings
used, VAT inclusive and exclusive price and comments. 

The log buffer can be manipulated by selecting the log from the menu, via the hot-keys or by
clicking on the log symbol in the toolbar. The Logging window will appear showing the last 7
calls. You can scroll through the previous calls. From here the call details can be amended or
deleted. To do this select the call you wish to alter. Double-clicking on a call will perform the
same action as ‘Quick’ (see later)

DELETE

This will remove the call details from the log buffer. As it is a destructive request, you will be
asked if you are sure?

ALTER

This will allow you to amend details of the call such as distance, time    or carrier. A new
comment can be added here. Click on ‘OK’ to confirm the new settings. The details will be
amended in the log
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QUICK

This will bring up details of the ‘QuickChoice’ settings allowing you to alter the selected call
very quickly. The comment in the log will reflect the new settings. This action can be used by
double-clicking in the logging window.

LOG FILE FORMAT

The log file on disk is a pure ASCII file, which can be imported to a word processor, viewed
or printed. ‘Notepad’ as supplied with Windows is a good way to examine the file. However
please don’t edit this file outside of FoneCost as it could seriously corrupt the log when it is
next loaded into FoneCost.

The  log  file  can  also  be  saved  in  a  ‘comma-delimited’ format  for  import  into  either  a
spreadsheet or database. This has to be done manually in the ‘File - Save As...’ menu choice.
When the file selector dialog box appears, click on ‘Save File as Type’ and select ‘Comma-
delimited files’ and they will be saved with a .cdl extension. 

AUTOLOG IMPORT (Set Options)

A good way of working is to set the ‘Autolog import’ to your current log file so that every
time you start FoneCost, the log is automatically imported. This can be set in ‘Set Options...’
in the ‘Options’ menu. The log file can also be automatically saved when you quit FoneCost.
Again ‘Set Options...’ is the place to set this.
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