


Introduction

The key to successful brewing lies in keeping good records of each batch!  Like
most, I tend to learn from my experiences (good and bad).  My weak point has always
been in locating the scraps of paper where I invariably kept my brewing notes.

This was the inspiration for SUDS - the brewers database and log program.  From
a simple attempt to coordinate some recipe and log notes, SUDS turned into a year-long
project and has resulted in an extremely comprehensive brewer's program.

This is the third major release of SUDS for Microsoft Windows 3.1 and involved
almost a total rewrite of the DOS version.  The two versions are extremely similar and
share the same file structures.  You can move easily between both versions and can even
keep both in the same directory if you wish!

SUDSW includes the following features:
o DBASE III compatible recipe and log files which can be browsed by any 

utility capable of viewing DBASE III file formats.
o Comprehensive online help for program functions and general brewing 

information.
o Multi-windowing editor featuring undo, full cut and paste capability 

between windows, mouse support and Windows clipboard 
import/export.

o Ability to import and export standard ASCII text files to and from the 
SUDS recipe database allowing recipes to be shared with SUDS 

and 
non-SUDS brewers.

o Ability to import and export formatted SUDS SXF-files allowing you to
share your recipes easily with other SUDS and SUDSW users.

o Recipe and log printing and reporting capabilities.
o Recipe formulation feature to automatically calculate recipes based on the 

raw materials you enter.
o Ability to search recipes by category, alcohol content, gravities and/or by 

text contents.
o Ability to enter judging values and competition notes for log entries.
o Categorization of recipes by type (Pale Ale, Stout, etc.) and ability to

define your own recipe styles.
o Built-in pop-up calculator to help with calculations.
o Built-in access to Windows Calendar utility.
o Hop-IBU spreadsheet to calculate hop IBUs for beer batches.
o Printing of beer labels.



New for release 3.0:
o Added recipe formulator to program.  This function allows you to build 

custom recipes by simply entering in raw ingredients.  SUDS will 
calculate

your starting gravity, bitterness, alcohol content automatically for you.
o Added AHA style database with all current beer styles and ranges as of

March, 1994.
o Added Malt database for formulator with information for most common 

malts and sugars.  You can also add your own data to this!
o SUDSW now supports metric and english units of measure.
o Expanded Hop calculator to allow up to 6 hop entries per log entry.
o Log entries now have a button to automatically display their associated

recipe.
o Filter function now allows you to limit recipes shown to those that you 

have 
log entries for.

o Fixed problem with log selection screen only showing most recent log 
entry

for a recipe.
o Fixed problem with 'on the fly' alcohol calculation.
o Fixed incompatability with SUDSW and Central Point desktop for 

Windows.
o Expanded online help files.

SUDSW is not, nor has it ever been free software or "Public Domain".  SUDSW
is being distributed as shareware and continued use beyond the 30-day trial  period is
prohibited.

Unlike a new recipe, SUDSW is a no-lose proposition!  You're free to try out
SUDSW for a 30 day period after which you can pay the nominal $20 registration fee if
you are satisfied.  In exchange for your registration:

o You will receive full support for the product.
o You'll be notified of any upgrades or new releases.
o You'll receive discounts on any subsequent add-ins, etc.
o You'll be supporting the hundreds of hours that went into this program!
o You'll encourage the continuation of the 'shareware' status of SUDS.



Installing SUDSW

SUDSW is distributed in either a ZIP file or a self-extracting archive file called
SUDW22.EXE.  If you have SUDW22.ZIP, you will need a utility to "UNZIP" the file
(PKUNZIP, XTGold, etc.).

To install SUDSW do the following:
o Create a directory on your hard disk to house the SUDSW files (named SUDS or 

SUDSW for example).
o Copy the SUDW30.EXE or SUDW30.ZIP file into the directory.
o Change into the directory (ie CD \SUDS).
o Type "SUDW30" at a DOS command line (or DOS window) to extract 

SUDW30.EXE; or "unzip" SUDW30.ZIP with your unzip utility.

NOTE - Previous users of DOS SUDS:  The current release of SUDSW will only work 
with DOS releases 2.3 and later!  If you are using earlier versions of the DOS release 
along with SUDSW, they will no longer be compatible.  SUDSW will convert earlier 
version files to the new version, but you will have to use new releases of SUDSW after 
converting.

SUDSW should now be installed on your computer.  You may want to create a
group in Program Manager to add SUDSW to (See Windows documentation for details
on program manager).

Now that SUDSW is on your system, you should type "DIR" and see at a minimum the
following files:

SUDSW.EXE SUDSW program file
SUDSHST.DAT Configuration for for SUDSW
BWCC.DLL Needed to run SUDSW
SUDSW.HLP On-line Help file for SUDSW
SUDSW.WRI Documentation file for SUDSW
README.TXT Short introduction to SUDSW release
REGISTER.TXT SUDSW registration form
RECIPES.SXF "Starter" set of recipes to import into SUDSW.

Once your installation is complete, run SUDSW from the Program Manager 
group you set up or from File Manager. This will put you into the multi-windowing 
SUDSW desktop.

Select  the  Options menu  with  the  mouse  or  arrow  keys  and  then  select  the
Import SXF file option.  This option is used to import recipes that have been saved in the
SUDS "SXF"  file  format.   The  file  RECIPES.SXP provided  with  SUDSW contains
several recipes to get you started.  Select the "RECIPES.SXF" file from the Import list.
This will load the SUDS database with the starter-set of recipes.



The SUDSW Environment

If  you've  used  the  DOS  version  of  SUDS or  are  familiar  with  any  standard
Windows applications, you will quickly feel right at home with SUDSW.  You'll find a
menu along the top of the screen with pull-down options.  Take advantage of the help
function!  This describes all of the major functions of SUDSW.  You can also select most
options from the SUDSW 'button bar' across the top of the screen by pushing any of the
custom button commands.

Whenever you are editing recipe or log information, you will find vertical and
horizontal "scroll-bars" along the free-form editing areas.  You can page through textual
information with the standard keyboard keys, by clicking the mouse on the scroll-bars or
by dragging the scroll-bar indicator (small box) with the mouse.

The editor used in SUDSW is extremely easy to use and has full editing features
in the Edit menu including an "UNDO" command that will undo changes made.  

The right mouse button in several places is active to provide a "shortcut" to one of
the  menu  options.   For  example,  while  editing  an  existing  recipe,  pressing  the  right
mouse button will display a list of log entries for the recipe (if any exist) providing a
means to edit or add new log entries for the recipe.  The right mouse button is also active
in date fields and the HOP IBU field in the log detail screen.

The SUDSW environment allows any number of windows to be open at one time
(limited only by the memory on your PC).  The best way to get familiar with this is to
experiment  with  the  program.   Open one  or  10  windows!   You  can  switch  between
windows by clicking on any exposed portion of a window, or by selecting a window from
the Windows file option.  If a window is not visible (ie is covered by another), use the
Cascade or Tile option from the Windows menu at the top of the screen to rearrange the
windows.

When saving recipe information or log information, SUDSW uses dialog boxes to
enter field by field information.  Use the tab and back tab keys to skip from field to field.
If you use to mouse to go directly to a field, hold down the left button and drag across the
field if you intend to change it. If you then type something, the field will change to the
new information (you could also press delete to remove the old value before typing).  If
you use tab and back tab, you won't have to worry about this.  Again, explore and have a
home-brew!

All SUDSW screens provide on-line help available by pressing the F1 key or by
pressing the "?" toolbar button.  This provides context sensitive help particular to the
function you are attempting.  Use this frequently!



The  SUDSW  database  stores  information  in  DBASE  III+  compatible  files.
Information  within  SUDSW is  organized  into  recipes  within  beer  categories  and  log
entries  for  recipes.   To enter  a  log entry requires  that  a  recipe entry first  exist.  Hop
information can also be entered for any log entries. You must first have a log entry before
using the HOP IBU spreadsheet.

You can transfer text to and from different SUDSW windows (or within the same
SUDSW window) by using the commands found under the Edit menu.  SUDSW uses the
standard Windows "clipboard" to allow you to Cut, Copy and Paste text information to
and from windows or even other Windows applications.

To copy text into the "clipboard", you first must mark the block to copy.  With the
mouse this is done by holding down the left button and dragging across the desired text.
Once the text is marked select the Cut command to move the text into the clipboard, or
the Copy command to copy the text into the clipboard.

To copy text from the "clipboard", move the cursor to the desired location for the
text  and select  Paste  from the  Edit  window.   After  one  or  two tries,  this  should  be
intuitive.



Entering Recipes

Recipes can be entered into SUDSW in many ways.  You can key in a new recipe
entirely from scratch.  You can open any ASCII file (for instance a recipe downloaded
from CompuServe) and then save the recipe into the SUDS database. You can also do
combined functions such as opening a file, selecting recipe information and copying the
information into another window (ie for Internet newsletters).  New with release 3.0, you
can also 'formulate' recipes by selecting the Formulate Recipe option.  You simply enter
in  your  ingredients  and  SUDSW will  calculate  your  starting  gravity,  bitterness  and
alcohol percentage.

To enter a recipe from scratch, you would select New Recipe from the File menu
of SUDSW.  This opens up a blank edit window into which you would enter your recipe
text.  When you complete your keying, pressing F2, selecting the Save option or pressing
the Save toolbar button would display the Recipe details screen.  Here you enter any
pertinent information about the recipe such as starting and finishing gravities, category
(Pale Ale, etc.), method (ie Extract, Full Mash).  Selecting OK would then save the recipe
into the SUDSW database.

To import a recipe from a file you would select the Open File option from the File
menu.  This would bring up a list of files in the current directory.  You can select files
from other directories by clicking on any directory names from the Open file dialog box.
Once you select a file, an edit window will be opened showing the contents of the file.
Here you can edit or change any recipe information and then save it back to a file or into
the SUDSW database from the File menu.

A good source of recipes is  the Internet newsletter  available by Internet Email  or on
CompuServe in the Wine & Beer forum.  These newsletters often contain a wealth of
information as well as recipes.  To extract a recipe from within a file proceed as follows:

o  Use the Open File option to open the file
o Find the recipe in the file
o Mark the recipe with the mouse or keyboard commands  (See above)
o Select the Copy command from the Edit menu at the top of  the screen.
o Select New Recipe to open another empty window.
o Select the Paste command to copy the text you previously  copied into the 

"Clipboard" into the new window.
o Save the recipe from the new window into the SUDS  database.

This really is much easier than it sounds!  With a little trial and error, you'll find
that  cutting and pasting is  usually  the easiest  way to create a new recipe since most
recipes are variations of one kind or another.



With SUDSW you can also import recipes from other SUDS users! This is nicer
than importing ASCII files since SUDS "SXF" files already include any Recipe detail
information.  From the SUDS Options menu, you can export your database to any "SXF"
file or import any "SXF" file.

Note -  The  file  structures  are  IDENTICAL for  both  DOS  SUDS  users  and
Windows SUDS users so files may be easily exchanged and you can use either version
interchangably.

The import will list any "SXF" files in the current directory.  Selecting a file will
load any non-existing recipes into your database from the "SXF" file.  If the recipe name
already exists in your database, it will not be replaced!  This is how the SUDS STARTUP
recipes are distributed (in file RECIPES.SXF).

You are encouraged to share any "SXF" files you wish with other users via BBS's,
CompuServe or just among friends. Please be sure to let users of your "SXF" files know
that  SUDS or  SUDSW is  required  to  use  the  files.   Actually  "SXF" does  not  use  a
complex file format at all, so non-SUDS users could read the contents with any browse
utility!



Editing Existing Recipes

To edit existing recipes, you select the Get Recipe option from the File menu or
press the Get Recipe "Toolbar" button.  This brings up a list of all available recipes or a
limited list if a Filter is active.  

To limit  the number of Recipes displayed, you would select  the  Filter  SUDS
Recipes option from the Search menu or press the Filter toolbar button (Mug with "?").
This will display the Filter dialog box.  Here you can enter search criteria to limit the
number of recipes displayed in the recipe list.

You can limit  recipes to  specific Categories (Pale  Ale,  etc),  Brewing methods
(Extract, Full Mash, etc), gravities, alcohol content and/or specific contents in the recipe
text.  If you can, you should always specify anythin outside of the recipe text contents to
speed up the Filter search.  To be listed, a recipe must meet all of the non-text contents
that you enter and must contain at least one of the text strings that you specify.

For instance, to list all Pale Ales using Cascade hops, you would specify on this
screen the category of Pale Ale and would key "Cascade" in the text portion.  All recipes
listed would be Pale Ale recipes using Cascade hops.  Your recipe list can grow quite
large, so you will probably find this to be a useful function!



Entering Log Entries

Log entries can be entered into SUDSW only for recipes in your SUDS database.
If you wish to enter log entries for recipes that you do not wish to enter into SUDSW, you
will have to create a "dummy" recipe.  To do this, just create a recipe with no text, and
give it a name when you save it.

To enter a log entry for a recipe, you must first open the recipe file (see above).
When the desired recipe is displayed, either click the right mouse button, or select the
Open Log option from the SUDSW File menu.  If any log entries exist for this recipe, a
list will be displayed which allows you to select existing log entries or add new ones.  If
no log entries existed for the recipe, you are taken directly to the log detail screen.

The log detail screen contains a number of fields pertaining to a particular batch
of the selected recipe.  These include: Date started, Date bottled, Starting and Finishing
gravities, Hop IBUs and free form notes.

Here  you  fill  in  or  update  any  information  pertaining  to  your  recipe  batch.
Several "shortcuts" or help functions exist for these fields to assist you in entering.

Date fields: pressing "+" or "-" in a date field will increase or decrease the date
by one day.  Pressing either with a blank date will fill in the current date.  

Hop IBUs: Pressing the right mouse button or selecting HOP IBU Spreadsheet
from the tools menu will bring up the HOP IBU spreadsheet used to calculate HOP IBUs
(International Bittering units).  The Hop IBU spreadsheet allows you to enter up to 4
different hop lines to calculate the IBU value.

Log Notes: The log notes field works exactly like the recipe edit windows (see
above).  The only difference is that the tab key will jump you out of the log note field to
the next  field.   This  is  where you will  enter  any comments  about  the batch you are
brewing.

If no recipes are open when you select the Open Log option from the SUDS File
menu, you will get a chronological list of all log entries in your database.  Here you can
edit any existing log entry.



Printing Recipes, Log Entries or Labels

Selecting Print from the SUDS File menu (or pressing Alt-P)will bring up a print
confirmation box for the current recipe or log entry.

For a log entry, selecting "Yes" or clicking on the Yes button will print the current
entry.

For a recipe, 3 check boxes are displayed allowing you tospecify whether to print
recipe text, stats and log entries for the recipe.

When a log entry is displayed, you can select print labels from the SUDS tools
menu.  This will display a sample label that you can customize.  SUDS will print labels
on standard 1-up mailing labels.   You can edit  any of the information shown on the
sample label and can override the number of labels to print.



Appendix A - Technical information

SudsW was developed using Borland Pascal with Objects 7.0 and Topaz database
manager 4.5.

The files used are standard DBASE-III+ compatible files.  However,  the index
files (*.IND) are not DBASE compatible. If you intend to use DBASE against the files,
you will have to index the files yourself.  If you wish to run an external database program
against the SUDS files, please observe the following steps:

1. BACKUP the DBF and DBT files in your SUDS directory.
2. Go into the external program and make any desired updates.
3. Be sure that if you delete a Recipe from the SUDSRCP.DBF file

that you also delete corresponding log entries from SUDSLOG.DBF
(Compare ID_RCP to match these).

4. When finished, erase all IND files from SUDS directory.  SUDS will
need to rebuild these indexes and will do so when you start it up.

5. Select Pack database from Options menu.

In order for SUDSW to run efficiently, you should periodically select the Pack
option from the SUDS Options menu to optimize indexes and reclaim deleted space.

A non-Windows version of SUDS is also available and is functionally equivalent
to the Windows version. 



Appendix B - Troubleshooting

o SUDSW displays fatal error message box - Its likely that the indexes somehow got 
corrupted (power outage, reboot or other cause).  Delete all SUDSW index files :

DEL *.IND
SUDSW will rebuild all indexes when it starts up.

o No recipes appear after initial install - Use the Import option from the Options menu 
to load in the RECIPES.SXF file.

o Menu options or buttons are disabled - This is not a bug, nor are the functions 
disabled in 'unregistered' copies.  The menu options and buttons only become 'active' 
when they may be used.  For example, the option to 'cut' text is not enabled until you 
have marked some text with the mouse.  All versions of SUDS and SUDSW are complete
functioning versions and are not 'crippled' in any way.

If you still experience problems and are a registered user, don't hesitate to contact me.  I 
limit support to non-registered users to questions related to installing the product.



SUDSW REGISTRATION FORM.

 If you register before 12/31/94 and enclose one of your own recipes to be included with 
future releases of SUDSW (your name will also be included) you can register SUDSW 
for $15 rather than the full price of $20.  Currently REGISTERED users of DOS SUDS 
may upgrade to Windows version for $10.

 Just copy this file to your printer, fold, and mail to

Michael Taylor
1626 Main Street
Bethlehem, PA  18018-1905

  Enclosed please find $____ for the following:

[ ] $20 to register SUDSW 3.0

[ ] $15 to register SUDSW 3.0
    (I am enclosing recipe with order)
    $15 offer expires 12/31/94.

[ ] $10  to register SUDSW 3.0
    (Currently registered users of DOS SUDS only!)

Name: ________________________________________________
  Address: ________________________________________________

________________________________________________
    State: ___________________________ Zip:_______________
Compuserve or Internet ID: ____________________________________

  SUDSW 3.0 was acquired from:

 [ ]  friend
 [ ]  free BBS, name and phone #
 [ ]  pay BBS (i.e., CompuServe) name __________________
 [ ]  disk duplicating service, name
 [ ]  user group
 [ ]  other_________________________________________

  Comments, suggestions:


