But du jeu

Winbrique est un jeu de plateau. Le but est simple, il s’agit de déplacer les briques du plateau par des mouvements verticaux et horizontaux de manière à positionner la brique maître (master brick) sur son emplacement final.

Même si les premiers plateaux sont simples, ne vous y fiez pas les suivants sont particulièrement compliqués.

Winbrique c'est aussi un concours permanent sur http://www.winbrique.com .Le principe est simple, venez comparer vos scores à celui des champions et pourquoi pas les détrôner.

Winbrique est diffusé en Shareware, c'est à dire que vous pouvez le copier et le diffuser librement. Pour y jouer régulièrement, vous pouvez envoyer une participation de 50 FF aux auteurs. En retour , vous recevrez un package comprenant de nombreux autres plateaux et vos records seront mis en ligne sur le site de winbrique. Ce soutien nous permettra de faire évoluer Winbrique et tenir à jour son site Internet Voir enregistrement

WINBRIQUE est un logiciel certifié FULLTESTS

Site WEB http://www.winbrique.com

Les auteurs

Pascal FONTENEAU p.fonten@free.fr

et

Fabrice DUPRAT faduprat@club-internet.fr

Bon Jeu.


Enregistrement

Winbrique est diffusé en Shareware, c'est à dire que vous pouvez le copier et le diffuser librement. Pour y jouer régulièrement, vous pouvez envoyer une participation de 50 FF aux auteurs. En retour , vous recevrez un package de 50 plateaux personnel à ne pas diffuser et vos records pourront être mis en ligne sur le site de winbrique.

Ce soutien nous permettra de faire évoluer Winbrique.

Indiquez dans votre courrier vos nom et adresse, ainsi si possible votre adresse Email pour recevoir vos plateaux plus rapidement.

Afin de repartir équitablement les travaux des auteurs

Envoyez votre participation ( 50 FF )

**** les jours pairs ****

à

Pascal FONTENEAU

Combe plane SUD

83440 FAYENCE (FRANCE)

Email : p.fonten@free.fr ou pascal@fonteneau.com

***** les jours impairs *****

à

Fabrice DUPRAT

1, rue Pierre Renaudel

83400 HYERES (FRANCE)

Email : faduprat@club-internet.fr

Merci.


Interface

L’interface

Paramètres

Vous pouvez régler la vitesse de déplacement du magnétoscope. La vitesse de déplacement des pièces à la souris. Choisir un Skin. Appeler l'éditeur de plateau , charger un package de pièce supplémentaires, ouvrir la fenêtre de pub.

Plateaux supplémentaires

En envoyant une participation aux auteurs, vous recevrez en retour un package contenant de nombreux autres plateaux. Cet écran permet de les charger automatiquement.

Chargement et gestion des plateaux

Cliquez sur le bouton charger, une fenêtre s'affiche, rechercher dans les dossiers le plateau a charger. Une pré visualisation est disponible. Cette fenêtre est redimensionnable, elle permet un zoom sur le plateau et évite aussi le défilement de l'arborescence des dossiers. Vous pouvez créer de nouveaux dossiers et déplacer les plateaux par tirer - lâcher. Cette arborescence est celle du sous-répertoire 'plateaux 'contenu dans le répertoire d'installation de Winbrique .


Magnétoscope

MAGNETOSCOPE

Avec le magnétoscope, vous pouvez vous déplacer dans le plateau courant, et ceci entre la position de départ et la dernière position que vous avez atteint. Attention, après un retour arrière, le moindre déplacement réinitialise la position maxi.

Attention : Pour garder un compteur juste, le magnétoscope recule par coup complet et décrémente le compteur d'une unité. La fonction "Avancer" reste au pas à pas, ce qui est beaucoup plus fin.

Vous pouvez également enregistrer votre séquence de déplacement et la recharger plus tard. Pensez à donner un nom significatif pour votre sauvegarde, ceci afin de faciliter vos recherches lors des chargements. Si vous tentez de recharger une séquence prévue pour un plateau différent du plateau courant, Winbrique vous en avertira.


Editeur

L’éditeur de plateau

L’entrée ‘Editeur de plateau ‘ du menu ‘Paramètres ‘ permet l’accès à un éditeur. Son utilisation est relativement simple.

Attention:

La seule restriction à la création de plateaux est qu'ils doivent rester personnels .Si vous souhaitez les diffuser, utiliser le support fourni sur le site Winbrique. Nous souhaitons rester maître de la qualité des plateaux. La diffusion de plateaux quelqu'en soit le support est interdite sans accord préalable des auteurs de Winbrique.

Petit cas pratique (Tutorial)

1/ Cliquez le bouton ‘Nouveau’ de la barre d’outils ou sélectionnez l’option ‘Nouveau’ du menu ‘Fichier’.

2/ Entrez un nom de votre plateau. (Ce nom sera le nom de votre fichier de sauvegarde sur le disque dur).

3/ Spécifiez la taille de votre grille en nombre de case (largeur et hauteur).

4/ Utilisez les onglets Normales, Maîtres et Bords pour sélectionner les morceaux de brique nécessaires à la création du plateau. Il suffit de cliquez dans une case pour y poser le morceau de brique. Le morceau sélectionné est entouré de rouge dans la palette à onglet.

5/ N’oubliez pas de définir un emplacement final pour votre brique maître.

Nota

Les emplacements finaux peuvent être couverts par des briques normales voir maîtres. mais pas par des bordures.

6/ Vérifiez que le niveau est correct (sur le plan de la construction) en cliquant sur la loupe ou sur l’option de menu ‘Tester’. Les briques en erreur seront encadrées de rouge.

Types de problèmes

Les problèmes que vous pouvez rencontrer sont simples à résoudre.

6.1 Les bords des morceaux briques doivent être joints.

6.2 Les bords joints doivent appartenir à la même famille de briques.

6.3 Les blocs mitoyens de 4 briques doivent être fermés.

7/ Enregistrer votre plateau en cliquant sur la disquette de la barre d’outil ou en sélectionnant l’option ‘enregistrer’ du menu déroulant ‘Fichier’ .

Nota :

Si votre niveau n’est pas correct , il est néanmoins possible de l’enregistrer mais il sera impossible de le charger dans le jeu.

Conseils concernant la création de d’un niveau

Commencer par un petit plateau pour vous familiariser avec l’éditeur.

Mettez la brique maître à sa position finale, puis tentez de la déplacer vers l’emplacement que vous considérerez comme son l’emplacement de départ. Une fois positionné en position de départ , vous aurez la certitude que le plateau est réalisable.

Si c’est trop simple vous pouvez :

Ajouter une ou plusieurs briques.

Coller les morceaux de briques ensemble.

Ajouter des bordures pour gêner les déplacements.


Les plateaux officiels

L’éditeur de plateau vous permet de créer vos propres plateaux. Vous pourrez ainsi les proposer à vos amis. vous pourrez également nous les envoyer par Email à faduprat@club-internet.fr afin de les officialiser, si un plateau est retenu, il est placé dans un package et sur le site WEB de Winbrique avec votre nom et votre nombre de coup. Les autres joueurs tenteront de vous égaler ou de vous déposséder du record.

Recommandations pour l'envoi de plateau :

Votre envoi (plateau + séquence) doit être envoyé "zipé". Quelques serveurs de messagerie s'autorisent des libertés avec certains types de fichiers, le format des fichiers plateaux Winbrique notamment. Ceci rend impossible leur rechargement.

N'envoyer que les plateaux que vous trouvez digne d'intérêt (ceux que vos amis n'arrivent pas à finir par exemple). préférez envoyer un bon plateau plutôt que plusieurs moyens.

N'oubliez pas de joindre le fichier séquence de votre solution pour officialiser votre record.

Donnez votre nom complet.

Précisez si votre adresse mail doit apparaître à coté de votre nom

Attention :

Dans la mesure du possible, nous essaierons de vous donner des informations sur la suite donnée à vos plateaux. mais, ne pouvant maîtriser le volume de courrier à traiter, ne nous en veuillez pas si nous ne pouvons pas systématiquement répondre. Passez régulièrement sur le site pour vérifier si vous avez étés retenu.

Merci de votre compréhension.

Si vous battez un record officiel envoyer la séquence par mail , votre nom figurera sur les tablettes.

Nota :

N'envoyez pas un record égalé, car la séquence à de grande chance d'être la même.


Conseils

Winbrique est un jeu de réflexion. A ce titre, il fait appel à certaines qualités intellectuelles comme la logique, l'anticipation, l'abstraction et surtout l'imagination. Pour résoudre les plateaux, voici quelques conseils.

Attention ces conseils ne s'appliquent pas forcement à tous les cas et à tous les plateaux.

- Définir une stratégie d'ensemble avant de déplacer la moindre brique. En regardant attentivement le plateau et ne jouant que lorsque qu'une idée vous viens à l'esprit.

- Rechercher le parcours le plus court possible pour la brique maître.

- Choisir la route la moins encombrée.

- Les pièces gênantes en fin de partie sont souvent plus facile à déplacer au début, pensez à les pré-positionner.

- les cases libres seules sont souvent des cases perdues, évitez -les.

-Pour progresser, revoyez-vos plateaux en cherchant systématiquement à les optimiser.

Intérêt du Jeu

Il existe de 3 approches possibles.

La première est la plus évidente , tenter de résoudre le plateau quel qu'en soit la manière et le nombre de coups. Puis passer au plateau suivant.

La seconde, résoudre le plateau de la manière la plus élégante possible, en cherchant à minimiser le nombre de coups.

Enfin la dernière en créant de nouveaux plateaux, en recherchant complexité et harmonie. (voir Editeur)


Les skins

Un Skin est une peau avec laquelle vous pouvez habiller Winbrique Il est possible d’en télécharger sur le site de Winbrique.

Chargement d’un skin.

Pour charger un skin , il suffit de sélectionner l’entrée de menu Skin du bouton paramètres dans Winbrique

Téléchargement de skin

1/ Aller sur le site Internet de Winbrique http://www.winbrique.com

2/ Télécharger le ou les skins qui vous intéressent.

3/ Décompressez-le fichier dans le sous répertoire 'skins' de winbrique (normalement c:\program files\winbrique\skins)

4/ Lancez Winbrique, une entrée de menu supplémentaire est automatiquement disponible pour chaque nouveau skin

Création d’un skin

Vous pouvez également créer votre propre skin.

Pour cela

1/ Étudiez un skin existant ‘simsons' par exemple en ouvrant le fichier skin.ini et l’ensemble des images nécessaires.

[VERSION] // ne pas toucher

Ver=210 // ne pas toucher

[BITMAPINFO] // ne pas toucher

MaskBitmap=simsonmask.bmp //mettre le nom de votre fichier de masque

MouseUpBitmap=SimsonUp.bmp //mettre le nom de votre fichier

MouseDownBitmap=Simsondown.bmp //mettre le nom de votre fichier

MouseOnBitmap=simsonOver.bmp //mettre le nom de votre fichier

NumbersBitmap=numbers.bmp // contient les chiffres de 0 à 9

TextBitmap=text.bmp //contient les caractères possibles (respecter l’ordre et les lignes)

[HOTAREAINFO] // ne pas toucher

Count=7 // ne pas toucher

1=REDUIRE, 375, 29, 26, 26, Réduire // Emplacement en pixels des zones des boutons

2=QUITTER, 400, 52, 20, 21, Quitter

3=PARAM, 86, 179, 41, 42, Paramètres

4=CHARGER, 147, 179, 42, 43, Charger

5=RAZ, 209, 179, 42, 44, Recommencer

6=ENREG, 327, 179, 42, 44, Enregistrer

7=RETOUR, 269, 179, 41, 42, Retour arrière

[DISPLAYINFO] // ne pas toucher

Count=2 // ne pas toucher

// zone de titre en pixels ne toucher qu’aux 8,9,13,14 paramètres uniquement

1=TEXT_TITRE, Arial, FALSE, FALSE, 8, $000000, 83, 101, Text, , Titre, 275, 27

// zone de compteur en pixels ne toucher qu’aux 8,9,13,14 paramètres uniquement

2=TEXT_CPT, Arial, FALSE, FALSE, 8, $000000, 265, 40, Number, 0000, Compteur, 69, 27

Charset=1 // ne pas toucher

[TRACKBARINFO] // ne pas toucher

Count=0 // ne pas toucher

2/ Créer un répertoire dans le sous répertoire skins . Ce sera le nom de votre skin dans le menu de Winbrique.

3/ Dessiner vos bitmaps au format BMP et placez les dans votre répertoire.

(Écran principal et touches du magnétoscope)

4/ Faites une copie du fichier skin.ini contenu dans un répertoire d’un autre skin et placez le dans votre répertoire.

5/ Éditez ce fichier , localisez les emplacements des boutons et zone de texte.

6/ Créez vos pièces en respectant le format suivant.

La taille d’un morceau de brique est de 30 * 30 par défaut, vous pouvez la modifier. Mais attention restez dans des tailles raisonnables, sous peine de rendre votre skin inutilisable.


Liens

Historique et liens

Winbrique est une version revue de Klotski un jeu sur micro du début des années 90. Klotski est lui même une adaptation sur micro d’un jeu du siècle dernier inventé par un artiste et mathématicien Polonais. Initialement ce jeu était destiné à améliorer la logique et l’esprit des enfants. Klotski (ou klocki) signifie brique en Polonais.

Le niveau appelé FORGET ME NOT est également connu sous le nom de DONKEY RED ou l’âne Rouge en Français. Ce plateau est vendu par quelques fabricants de casse-têtes. Il existe également une multitude de sites sur Internet où vous pouvez jouer en ligne (voir liens Internet).

Pour les passionnés , un éditeur intégré vous permettra de confectionner vos propres plateaux. Vous pouvez également les proposer aux autres joueurs du monde entier en les plaçant sur le site de Winbrique http://www.winbrique.com .

Le niveau Forget me not en direct sur Internet (applet JAVA)

http://www.windarooss.qld.edu.au/Donkey_Puzzle/donkey_puzzle_nf.html

Quelques solutions

http://home.wirehub.nl/~berto/klotski.htm

Des infos

http://home.sprynet.com/~higsby/about.htm

http://home.sprynet.com/~higsby/klotski.htm


Mes programmes

Mes autres programmes

Sur http://p.fonten.free.fr le Site d'Edichèque

Edichèque est utilitaire qui permet l’impression sur chèques bancaires ,

Tous types de chéquier

Multi-Monnaies Francs, Euro, CFA, etc..

Convertisseur Franc <=> Euro

Gestion des archives

Paramétrage complet ( polices, attributs,taille, Etc...)

Exemple :

Copie d'écran


Responsabilités

Bien qu’ayant apporté un soin particulier à la réalisation de ce logiciel, l’auteur ne pourra être tenu responsable des problèmes pouvant résulter de l’installation et de l’utilisation du produit. L’utilisateur restera donc responsable de son utilisation. Ce logiciel dispose d’une installation et désinstallation automatique, il n’accède pas à la base de registre, ne pose aucun fichier dans le répertoire système de la machine qui l’héberge.


Le site WinBrick

LE SITE WinBrique

Adresse : http://www.winbrique.com

Sur le site vous pourrez :

1/ Télécharger :

-Les mises à jours de Winbrique

-Des Skins supplémentaires

2/ Consulter :

-La liste des records

-La liste des liens

3/ Proposer

-Vos solutions (si elles sont meilleures que le record courant)

-De nouveaux plateaux

-De nouveaux skins

-Envoyer les articles de presse concernant Winbrique (pour la mise à jour du site).

Vous pouvez également envoyer vos propositions (plateaux, skins, photocopies d’article) par courrier.