Novedades en Internet Explorer Administration Kit

Puede utilizar el Asistente para la personalización de Internet Explorer y el Administrador de perfiles de IEAK, que se incluyen en Internet Explorer Administration Kit, para personalizar, distribuir y mantener Internet Explorer. Para obtener más información acerca del contenido del IEAK, consulte Qué incluye Microsoft Internet Explorer Administration Kit

Éstas son algunas de las novedades más importantes del IEAK:

  • Personalice y distribuya el software de cliente de MSN Messenger Service Puede incluir el cliente de MSN Messenger Service en su paquete y marcarlo para que use el logotipo y el nombre de su organización. El programa de instalación del cliente del servicio de mensajería personalizado se empaqueta en su propio archivo ejecutable. Puede incluirlo como componente del programa de instalación de Windows Update o distribuir el programa de instalación para el cliente de forma independiente desde Internet Explorer.
  • Elija cuándo instalará los componentes personalizados. Puede instalar los componentes personalizados antes o después de instalar Internet Explorer o sólo si la instalación de Internet Explorer se completa correctamente. También puede especificar que se instalen después de reiniciar el sistema. Este grado de control resulta útil al empaquetar actualizaciones de sistema en uno o varios componentes personalizados. Para obtener más información, consulte Empaquetar actualizaciones de Microsoft en componentes personalizados.
  • Elija el tipo de directivas que configurará. Todas las directivas de sistema y restricciones que puede definir en el Asistente para la personalización de IEAK y administrar posteriormente en el Administrador de perfiles de IEAK pueden configurarse para usuarios que utilicen los sistemas operativos Windows 95, Windows 98 y Windows Millennium Edition. Sin embargo, sólo podrá configurar un subconjunto de estas directivas de sistema y restricciones para usuarios sin privilegios de administrador en las plataformas Windows NT o Windows 2000. En el IEAK, puede elegir qué directivas se mostrarán en función de la plataforma y los privilegios de usuarios que se apliquen a un paquete determinado. Para obtener más información, consulte Administrar Microsoft Internet Explorer en Windows 2000.
  • Instale paquetes que requieren privilegios de administrador después de haber reiniciado el sistema. Puede personalizar el paquete de modo que se retengan los privilegios de administrador después de reiniciar el equipo. Después puede distribuir el paquete a los usuarios manualmente o como parte de un método de distribución automatizado como Systems Management Server (SMS). En cualquier caso, no es necesario que los usuarios tengan privilegios administrativos la próxima vez que inicien una sesión en el sistema.
  • Quite los vínculos e iconos de Outlook Express, el Asistente para la conexión a Internet y los canales. Puede incluir Outlook Express en el paquete y configurar la instalación de modo que no aparezca ningún vínculo a dicho programa en el escritorio del usuario, el menú Inicio o la barra de inicio rápido. Del mismo modo, puede quitar los vínculos a los canales o al Asistente para la conexión a Internet de la barra de inicio rápido del usuario.
  • Genere paquetes para sistemas operativos Windows de 32 bits. Esta versión de Internet Explorer Administration Kit sólo genera paquetes del explorador personalizados para plataformas Windows de 32 bits. Si desea crear un paquete personalizado para Windows de 16 bits o para plataformas UNIX, use Internet Explorer Administration Kit 5.0x.

Para obtener más información acerca de las novedades de Internet Explorer 5.5, consulte la Ayuda en pantalla que se instala junto con el producto.


Qué incluye Internet Explorer Administration Kit

Microsoft Internet Explorer Administration Kit (IEAK) contiene programas y herramientas que le ayudan a personalizar y administrar Internet Explorer.

Puede:

  • Adaptar el explorador y otros componentes de Internet a su organización o a las necesidades de sus usuarios. Por ejemplo, puede personalizar la barra de vínculos y la lista de favoritos para promocionar su organización o proporcionar información útil.
  • Definir la configuración antes de la instalación, para que no sea necesario establecer las opciones en cada equipo.
  • Personalizar la instalación de forma que requiera menos participación del usuario e instale programas personalizados.
  • Si es administrador corporativo, puede controlar qué opciones de configuración pueden cambiar los empleados, para asegurarse de que la configuración de la seguridad, conexión y otros temas importantes se adapten siempre a las normas de la organización.

Antes de utilizar el IEAK, debe determinar qué opciones de configuración desea personalizar, preparar los gráficos o archivos personalizados que precise, y planear el método de distribución que piensa utilizar. También le conviene familiarizarse con los programas y herramientas que componen el IEAK.

Para obtener más información acerca de las novedades de esta versión del IEAK, consulte Novedades en Internet Explorer Administration Kit

Herramientas de Internet Explorer Administration Kit

Asistente para la personalización de Internet Explorer

El Asistente para la personalización incluye cinco pasos, con pantallas sucesivas, que le ayudan a crear paquetes personalizados de Internet Explorer.

Administrador de perfiles de Internet Explorer Administration Kit

El Administrador de perfiles le permite cambiar automáticamente las opciones de configuración y las restricciones de los usuarios, una vez instalado Internet Explorer. Para obtener más información, consulte Cómo utilizar el Administrador de perfiles de IEAK.

Kit de herramientas de IEAK

El Kit de herramientas de IEAK contiene herramientas, programas y ejemplos útiles, como son el Asistente para IExpress, archivos de ejemplos de suscripción y complementarios, imágenes gráficas y otras herramientas. Estos elementos se encuentran en la carpeta \Toolkit del directorio de instalación del IEAK.

Ayuda de Internet Explorer Administration Kit (IEAK)

Utilice el Índice, la Tabla de contenido y la búsqueda de texto para encontrar temas que solucionen sus dudas. Desde la Tabla de contenido es posible imprimir un "libro" o un grupo de temas relacionados.


Requisitos de hardware y del sistema

Requisitos para Internet Explorer

Para conocer los requisitos de hardware y del sistema de versiones específicas de Internet Explorer, consulte los archivos LÉAME de esas versiones.

Requisitos de hardware adicionales para crear paquetes de instalación personalizados

Antes de iniciar el Asistente para la personalización de Internet Explorer, compruebe la cantidad de espacio de disco disponible en la unidad de destino donde generará el paquete personalizado. La unidad de destino puede encontrarse en el mismo equipo desde el que está ejecutando el asistente para la personalización, pero no es un requisito indispensable.

Al generar paquetes de IEAK, debe aumentar los requisitos del sistema de Internet Explorer en los siguientes aspectos:

  • En función del número de componentes que descargue para incluir en un paquete de instalación, puede necesitar hasta 100 MB de espacio en disco.
  • Para cada paquete personalizado que genere, puede necesitar hasta 100 MB adicionales de espacio en disco. Cuando genera un mismo paquete para otro tipo de soporte de distribución, como puede ser el CD-ROM, se considera como otro paquete independiente.

Requisitos del IEAK

Debe generar los paquetes de IEAK desde un equipo con Internet Explorer 5.5 y cualquier sistema operativo Windows de 32 bits (excepto Windows NT 3.51).

Los equipos con Windows NT 4.0 también deben ejecutar Service Pack 3 (o versiones posteriores).

Esta versión de Internet Explorer Administration Kit sólo genera paquetes del explorador personalizados para plataformas Windows de 32 bits. Si desea crear un paquete personalizado para Windows de 16 bits o para plataformas UNIX, use Internet Explorer Administration Kit 5.0x. Si desea crear un paquete personalizado para Macintosh, use Internet Explorer Administration Kit para Macintosh.

Es posible ejecutar simultáneamente las versiones 5.0 y 5.5 de Internet Explorer Administration Kit en el mismo equipo; para ello, instale cada programa en un directorio diferente.

Requisitos para los usuarios

Si los usuarios utilizan Windows NT o Windows 2000, debe tener privilegios administrativos en el equipo la primera vez que inicien sus equipos tras la instalación y desinstalación de Internet Explorer desde el paquete de IEAK.

Para obtener información más detallada acerca de cómo instalar Internet Explorer en los equipos de los usuarios, consulte Cambiar desde otras versiones o productos y Administrar Microsoft Internet Explorer en Windows 2000.


Redistribuir Internet Explorer

El IEAK puede ayudarle a redistribuir Internet Explorer como parte del proceso de instalación de otro programa. Por ejemplo, si es fabricante independiente de software (ISV) puede que desee personalizar la instalación de Internet Explorer para que sea su programa personalizado, en lugar de Internet Explorer, el que presente al usuario las opciones y comentarios del programa de instalación.

Si desea redistribuir Internet Explorer, use el Asistente para la personalización de Internet Explorer a fin de crear un paquete IEAK. Elija la opción Proveedor de contenido/Programador en el paso 1 del Asistente para la personalización de Internet Explorer.

Puede personalizar la apariencia y funcionalidad del explorador y el programa de instalación de Windows Update, si se lo permite su contrato de licencia. También puede utilizar los siguientes elementos para controlar la funcionalidad y experiencia del usuario del programa de instalación de Windows Update.

  • Ejecutar la instalación por lotes
  • Modificadores de la instalación por lotes de Internet Explorer
  • Modificadores de la instalación por lotes de IExpress
  • Trabajar con archivos de información para la instalación (.INF)


Introducción para los proveedores de contenido Internet

Microsoft® Internet Explorer Administration Kit (IEAK) permite a los proveedores de contenido Internet (ICP) y a los fabricantes independiente de software (ISV) crear un explorador personalizado para los clientes que ya tienen cuentas de Internet.

Como los ICP, también puede crear un explorador personalizado si piensa utilizar el servidor de referencia de Microsoft como parte de su paquete personalizado. El mantenimiento de este servidor de referencia, que proporciona información acerca de los proveedores de servicios Internet de su área, lo realiza Microsoft. Puede vincular con servidores de suscripción mediante este servidor de referencia.

Puede utilizar este kit para realizar lo siguiente:

Personalizar el programa de instalación

  • Personalizar la apariencia del programa de instalación de Windows Update y configurar los modos de instalación (por ejemplo, las instalaciones Estándar y Mínima).
  • Dirigir a los usuarios a servidores de Internet para que tengan acceso a las versiones más recientes del producto.
  • Especificar la versión del idioma de Internet Explorer que incluirá en el paquete de instalación. Debe ejecutar una vez el Asistente para la personalización de Internet Explorer por cada versión de idioma que desee crear.

Personalizar el explorador y los canales

  • Establecer las páginas inicial, de búsqueda y de soporte.
  • Cargar vínculos y carpetas en la lista Favoritos.
  • Cambiar la barra de título y los logotipos del explorador.
  • Agregar un canal o una categoría de canal.

Utilizar el logotipo de Internet Explorer

De acuerdo con los términos del contrato de licencia, debe mostrar el logotipo de Internet Explorer en su paquete y materiales de promoción, así como en su sitio Web. Visite el sitio Web de IEAK para obtener información acerca del logotipo y de imágenes listas para usar, y ejemplos.

Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.

Importante

  • Puede que algunas características no estén disponibles, según su contrato de licencia. Para obtener más información, consulte su contrato.


ICP. Preparación para ejecutar el asistente

Imagen de título
Proveedor de
contenido Internet

Preparación para ejecutar el asistente

Antes de ejecutar el Asistente para la personalización de Internet Explorer, debe recopilar toda la información que necesite y crear los mapas de bits personalizados.

Determine los requisitos de plataforma iniciales

  • Compruebe que el equipo en el que va a generar el paquete y los equipos donde se instalará cumplen los requisitos de hardware y de software.
  • Determine los niveles de cifrado para los paquetes del explorador. Para obtener más información acerca del cifrado de Internet Explorer, visite el sitio Web del IEAK.

Elija el método de distribución

Decida cómo distribuirá su paquete personalizado (CD, descarga, red de área local o en discos). Una vez que el Asistente para la personalización de Internet Explorer haya generado el paquete, tendrá que mover los archivos al soporte seleccionado. Si genera un paquete descargable, debe moverlo al lugar apropiado de su servidor.

Si decide publicar su paquete del explorador en un servidor de Internet, necesitará la ruta de acceso del servidor y la dirección URL desde la que se descargarán los archivos. Después, cree una carpeta en el servidor Web, como CIE, para publicar todos los archivos y carpetas asociados al explorador personalizado. Por ejemplo, podría crear la ruta de acceso de servidor C:\Inetpub\Wwwroot\ie5\Cie. Si nombreDelEquipo es la raíz virtual de este servidor Web, la dirección URL correspondiente sería http://nombreDelEquipo/Cie/.

Obtenga un certificado digital

Realice los preparativos iniciales para firmar determinados archivos, como son los archivos de personalización creados por el Asistente para la personalización de Internet Explorer y los componentes personalizados, en el caso de que vaya a distribuirlos a través de Internet o de una intranet que no esté especialmente configurada. Con las características de seguridad del explorador, se advierte a los usuarios acerca de la descarga de archivos sin firmar o se les impide descargarlos. Las firmas digitales identifican el origen de los programas y garantizan que el código no ha cambiado desde que se firmó.

El Asistente para la personalización de Internet Explorer puede firmar los archivos si dispone de un certificado de publicación emitido por una entidad emisora de certificados. Para preparar los certificados de forma que los utilice el IEAK, puede importarlos en el equipo por medio del Asistente para la importación del Administrador de certificados. Si ha recibido un archivo con la extensión .SPC, puede iniciar el Asistente para la importación del Administrador de certificados si hace doble clic en el archivo .SPC en el Explorador de Windows o en Mi PC.

También puede abrir el Administrador de certificados desde Internet Explorer. Para hacerlo, haga clic en el menú Herramientas, Opciones de Internet, haga clic en la ficha Contenido y, finalmente, en Certificados. Haga clic en Importar para iniciar el Asistente para importación del Administrador de certificados y, después, siga los pasos que se indican en el asistente.

Cree la estructura en el equipo

Nombre de carpeta | Descripción
\CIE | Una raíz principal para todos los archivos generados por el IEAK o a los que el paquete personalizado haga referencia
\CIE\Bitmaps | Archivos de mapas de bits personalizados (archivos gráficos necesarios para el explorador personalizado)

Cree los gráficos apropiados

Tendrá la opción de personalizar los mapas de bits siguientes en el explorador. Coloque los mapas de bits en la carpeta \CIE\Bitmaps antes de ejecutar el Asistente para la personalización de Internet Explorer.

Los fondos y botones personalizados sólo se muestran en equipos con capacidad para mostrar 256 colores (8 bits). En los equipos con capacidad para mostrar 16 colores (4 bits) se muestra un conjunto estándar de botones y mapas de bits de fondo de baja resolución.

  • Un mapa de bits de fondo para la pantalla de ejecución automática del CD-ROM (si crea un paquete en CD-ROM).

    Si piensa distribuir el explorador personalizado en un disco compacto, debe crear mapas de bits como parte de la pantalla inicial del programa de ejecución automática que se muestra cuando el usuario ha insertado el disco compacto. Para crear este mapa de bits, consulte Crear un mapa de bits para la pantalla inicial del programa de ejecución automática.

  • Una imagen personalizada para los botones del CD-ROM (si crea un paquete en CD-ROM).
  • Dos mapas de bits personalizados para el Asistente para la instalación de Windows Update (si desea personalizar su apariencia): un mapa de bits de 162 por 312 píxeles para el lado izquierdo de la primera pantalla del asistente y un mapa de bits de 496 por 56 píxeles para la parte superior de las restantes pantallas del asistente.
  • Un mapa de bits personalizado de barra de herramientas (que se muestra como fondo de los botones y menús).
  • Dos imágenes de mapa de bits estáticas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo.
  • Dos imágenes de mapa de bits animadas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo animado.

    Con IEAK se incluyen dos herramientas para ayudarle a crear y obtener vistas previas de los mapas de bits animados personalizados para el explorador. Para obtener información acerca de cómo utilizar estas herramientas, consulte Herramientas para mapas de bits animados.

Recopile las direcciones URL de las páginas Principal, Búsqueda y Soporte.

Es conveniente crear una página de soporte que aparecerá si los usuarios tienen problemas al instalar el explorador. Se le pedirán las direcciones URL de esas páginas cuando ejecute el Asistente para la personalización de Internet Explorer.

Notas

  • Para obtener más información acerca del programa de instalación, consulte Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


ICP. Paso 1 del asistente: recopilar información

Imagen de título
Proveedor de
contenido Internet

Paso 1 del asistente: recopilar información

En el primer paso del Asistente para la personalización de Internet Explorer, se pedirá a los proveedores de contenido y los fabricantes independientes de software la información siguiente:

  • Nombre de su organización y código de personalización de diez dígitos. El código de personalización está incluido con el resto de información del kit que recibió de Microsoft.
  • Su función, que depende del contrato de licencia. Debe especificar si se trata de un programador o proveedor de contenido, un proveedor de servicios o un administrador corporativo.
  • La ubicación de los archivos necesarios para crear el paquete personalizado del explorador.
  • El idioma del paquete del explorador que está creando. Necesitará ejecutar el Asistente para la personalización de Internet Explorer para cada versión internacional que desee crear.
  • El medio de distribución que piense utilizar, como CD-ROM o descarga.
  • Las características que piensa personalizar. Por ejemplo, si sólo va a hacer pequeñas modificaciones al explorador, no tendrá que pasar por todas las pantallas del Asistente para IEAK.

Nota

  • El Asistente para la personalización de Internet Explorer no funcionará correctamente si no está instalado Internet Explorer 5.5. Para obtener más información, consulte Requisitos de hardware y del sistema.


ICP. Paso 2 del asistente: especificar los parámetros de instalación

Imagen de título
Proveedor de
contenido Internet

Paso 2 del asistente: especificar los parámetros de instalación

En este paso del Asistente para la personalización de Internet Explorer, los proveedores de contenido deben:

  • Descargar o actualizar componentes de Microsoft mediante la sincronización automática de versiones. Debe descargar Internet Explorer, pero puede elegir los demás componentes de Internet Explorer que descargará.
  • Seleccionar los componentes personalizados que desea incluir.

    También puede especificar hasta diez componentes adicionales, que pueden ser archivos ejecutables autoextraíbles (.EXE) o archivos contenedores (.CAB) comprimidos.


ICP. Paso 3 del asistente: personalizar la instalación

Imagen de título
Proveedor de
contenido Internet

Paso 3 del asistente: personalizar la instalación

En este paso del Asistente para la personalización de Internet Explorer, los proveedores de contenido pueden determinar cuál será la apariencia y funcionamiento del programa de instalación de Windows Update:

  • Personalice la pantalla de ejecución automática del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice otras opciones del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice el Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet. Estas opciones de configuración afectan a la apariencia del programa de instalación.
  • Especifique hasta diez opciones de instalación y determine los componentes que incluirá en cada opción.
  • Especifique hasta diez sitios desde los que se podrá descargar el paquete.
  • Especifique de qué forma recibirán los usuarios las actualizaciones de los componentes.
  • Especifique que el programa de instalación debe detectar si existe un componente dado y determine con precisión qué componentes pueden personalizar los usuarios.
  • Determine si los componentes que se han descargado pero no se han incluido en todos los paquetes deben ponerse a disposición de los usuarios por medio de la característica de instalación a petición de Internet Explorer.
  • Especifique los datos de la entidad emisora de certificados para que, si tiene un certificado digital, pueda firmar los programas al crear el paquete IEAK.

Notas

  • Para obtener más información acerca del programa de instalación, consulte Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.
  • Si desea ver un organigrama de lo que ocurre al usar el Asistente para la personalización de Internet Explorer con el fin de crear un paquete personalizado, consulte Cómo genera el IEAK paquetes personalizados.


ICP. Paso 4 del asistente: personalizar el explorador

Imagen de título
Proveedor de
contenido Internet

Paso 4 del asistente: personalizar el explorador

En este paso del Asistente para la personalización de Internet Explorer, los proveedores de contenido pueden personalizar lo siguiente:

  • El mapa de bits de fondo de la barra de herramientas y la barra de título del explorador. Cuando seleccione un mapa de bits, asegúrese de que los colores contrastan con el texto.
  • Los botones de la barra de herramientas del explorador. Puede agregar botones personalizados a la barra de herramientas para ejecutar secuencias de comandos y programas.
  • El logotipo de Internet Explorer de la esquina superior derecha del explorador.
  • Las páginas principal, de búsqueda y de soporte en línea del explorador.
  • Favoritos, carpetas de Favoritos y vínculos de la barra de vínculos.
  • Canales. Puede agregar un canal o una categoría de canales que es, simplemente, una carpeta de canales.
  • La página de bienvenida, que aparece cuando el usuario inicia el explorador por primera vez.
  • Una cadena agente de usuario. El identificador del agente de usuario es opcional; es una forma de realizar un seguimiento del uso de su explorador personalizado.

Notas

  • Para obtener más información acerca del programa de instalación, consulte Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


ICP. Paso 5 del asistente: personalizar componentes

Imagen de título
Proveedor de
contenido Internet

Paso 5 del asistente: personalizar componentes

En este paso del Asistente para la personalización de Internet Explorer, los proveedores de contenido pueden personalizar lo siguiente:

  • La configuración predeterminada del programa, como los programas específicos que se utilizarán para leer correo electrónico o modificar HTML.
  • La marca de MSN Messenger Service, si está incluyendo una instalación personalizada del cliente del servicio de mensajería en el paquete.
  • Los elementos multimedia de MSN Messenger Service, si desea cambiar los gráficos, el contenido promocional o los sonidos utilizados en la instalación personalizada del cliente del servicio de mensajería.
  • La información de cuenta de MSN Messenger Service, si desea cambiar las opciones predeterminadas de la cuenta Passport y la configuración de la integración de correo electrónico en una instalación personalizada del cliente del servicio de mensajería.
  • Directivas del sistema y configuración, para preestablecer las opciones de Internet.


ICP. Distribuir su paquete del explorador

Imagen de título
Proveedor de
contenido Internet

Distribuir su paquete del explorador

De forma predeterminada, el Asistente para la personalización de Internet Explorer crea archivos para descargar desde Internet. También puede distribuir el paquete del explorador personalizado en un CD-ROM. Para obtener una lista completa de todos los medios de distribución, consulte Selección del medio.

Archivos descargables

Si creó el paquete del explorador en un servidor de una intranet o de Internet, tiene que configurar su sitio Web para que los usuarios puedan descargar los archivos. Por ejemplo, podría crear una página en la que publicara la información de descarga y un vínculo al motor de instalación, IE5setup.exe.

Si creó el paquete del explorador en un disco duro o en una unidad de red, deberá mover los elementos siguientes al servidor de la intranet o de Internet:

  • La carpeta que contiene la versión del idioma que está publicando y los contenidos de la carpeta. Por ejemplo, la carpeta de la versión en inglés se llama En, por lo que debe mover la carpeta En y los archivos que contiene. Esta carpeta estará en las carpetas que correspondan al tipo de distribución, por ejemplo, Download (descarga), y plataforma. La única designación de plataforma de Internet Explorer Administrative Kit 5.5 es "Win32"; para clientes UNIX y Windows de 16 bits, use Internet Explorer Administrative Kit 5.0x.
  • El archivo denominado Ie5sites.dat. Este archivo señala el sitio de descarga o sitios especificados al ejecutar el Asistente para la personalización de Internet Explorer.

Para ver un ejemplo, consulte Cómo configurar los archivos para distribución.

Para ver un organigrama de los archivos que crea el Asistente para la personalización de Internet Explorer, consulte Cómo genera el IEAK paquetes personalizados.

Firmar los paquetes personalizados

Los exploradores Web tienen características de seguridad que ayudan a proteger a los usuarios frente a la descarga de programas perjudiciales. En función del nivel de seguridad y de la plataforma, se puede advertir al usuario o evitar que descargue programas que no estén firmados digitalmente.

Los archivos personalizados .CAB creados con el Asistente para la personalización de Internet Explorer deben estar firmados, a menos que se haya configurado la zona local de la intranet con un nivel bajo de seguridad. Cualquier componente personalizado que distribuya con el paquete del explorador y vaya destinado a esas plataformas también debe estar firmado. Si dispone de un certificado digital, el Asistente para la personalización de Internet Explorer puede firmar automáticamente esos archivos.

Notas

  • La firma de los archivos contenedores (.CAB) y los programas personalizados requiere que se lleven a cabo dos pasos: obtener un certificado digital y especificar los datos del certificado al ejecutar el Asistente para la personalización de Internet Explorer. Para obtener más información, consulte Firmar sus programas.
  • Es posible que deba cambiar las mayúsculas y minúsculas de los nombres de los archivos publicados en un servidor UNIX de FTP. A continuación se detallan las convenciones que debe usar para sistemas operativos UNIX específicos.
    • UNIX de Solaris
      Si está utilizando un servidor FTP de UNIX que distingue mayúsculas y minúsculas, debe asegurarse de que la carpeta contenedora no contiene mayúsculas, mientras que los archivos siguientes están en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT.
    • UNIX de AT&T
      Todos los nombres de archivo deben estar en mayúsculas en un servidor FTP de UNIX de AT&T.
    • UNIX de IRIX (Silicon Graphics)
      Los nombres de archivo siguientes deben estar en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT. Debe usar un procesador de textos a fin de modificar los nombres de archivos enumerados en IE.CIF para que la utilización de mayúsculas coincida con la de los archivos.

CD-ROM

Si distribuye el explorador personalizado para usuarios de Windows 95 o Windows 98, aparecerá una pantalla inicial del programa de ejecución automática cuando el usuario inserte el disco compacto. Este programa ofrece a los usuarios la posibilidad de instalar el explorador personalizado o ver más información. Si ya está instalada la versión actual de Internet Explorer, el programa de ejecución automática la detectará. Se mostrará el explorador en lo que se conoce como modo a pantalla completa con el archivo Start.htm cargado.

Para obtener más información

Para obtener información más detallada acerca de la instalación de Windows Update, consulte Instalación de Windows Update para Internet Explorer y otras herramientas para Internet. El proceso de descarga se muestra en el diagrama Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.


ICP. Cómo distribuir su cliente del servicio de mensajería

Imagen de título
Proveedor de
contenido Internet

Cómo distribuir su cliente del servicio de mensajería

Si ha incluido MSN Messenger Service como una opción de instalación , el Asistente para la personalización de Internet Explorer crea un paquete independiente para descargar el cliente del servicio de mensajería desde un servidor de intranet o Internet.

Archivos descargables

Si creó el paquete del cliente del servicio de mensajería en un servidor de Internet o de una intranet, asegúrese de configurar su sitio Web para que los usuarios puedan descargar los archivos. Por ejemplo, puede crear una página en la que se publique la información de descarga y un vínculo al archivo de instalación (mmssetup.exe) para el cliente del servicio de mensajería.

Si creó el archivo mmssetup.exe en un disco duro o en una unidad de red, deberá moverlo a un servidor de Internet o de la intranet para cada versión de idioma que esté publicando. Cada versión de idioma crea una subcarpeta en la carpeta Messenger del directorio de la compilación. Por ejemplo, la versión de la compilación en inglés de mmssetup.exe se encuentra en la subcarpeta En. Si ha especificado una dirección URL de descarga durante la personalización, cree un vínculo dentro de la página de la dirección URL de descarga que señale a mmssetup.exe. Todos los componentes necesarios para distribuir un cliente del servicio de mensajería personalizado se incluyen en este archivo ejecutable.

Firmar la instalación del cliente del servicio de mensajería

Si incluyó un certificado digital para firmar el paquete del explorador cuando ejecutó el Asistente para IEAK, se utilizará el mismo certificado para firmar el programa de instalación mmssetup.exe. Para obtener más información, consulte Firmas digitales y Firmar sus programas.

El cliente del servicio de mensajería como parte del paquete del explorador

El cliente del servicio de mensajería personalizado también se instalará como parte del paquete del explorador, siempre y cuando haya especificado que MSN Messenger Service se incluya en las opciones de instalación. Se crea un paquete .CAB distinto para el cliente del servicio de mensajería personalizado, que se incluirá como componente al ejecutar ie5setup.exe. Consulte Distribuir su paquete del explorador para obtener más información acerca de cómo distribuir todo el paquete del explorador.

Clientes de servicio de mensajería y servidores de seguridad

Si necesita especificar opciones de proxy avanzadas para servicios de mensajería que están detrás de un servidor de seguridad, no indique una dirección URL de descarga. Además, deberá modificar el texto para generar un archivo de instalación que configurará previamente las opciones de proxy. Consulte Personalización avanzada de un cliente de mensajería para obtener más información.


Introducción para proveedores de servicios Internet

Microsoft® Internet Explorer Administration Kit (IEAK) permite a los proveedores de servicios Internet (ISP) crear un explorador personalizado y un paquete de suscripción a servicios Internet para sus clientes.

Puede utilizar este kit para realizar lo siguiente:

Personalizar el programa de instalación

  • Personalizar la apariencia del programa de instalación de Windows Update y configurar los modos de instalación (por ejemplo, las instalaciones Estándar y Mínima).
  • Dirigir a los usuarios a servidores de Internet para que tengan acceso a las versiones más recientes del producto.
  • Distribuir programas adicionales, secuencias de comandos personalizadas o secuencias de comandos para mantenimiento con Internet Explorer.
  • Especificar la versión del idioma de Internet Explorer que incluirá en el paquete de instalación. Debe ejecutar una vez el Asistente para la personalización de Internet Explorer por cada versión de idioma que desee crear.

Personalizar el explorador y los canales

  • Establecer las páginas inicial, de búsqueda y de soporte.
  • Cargar vínculos y carpetas en la lista Favoritos.
  • Cambiar la barra de título y los logotipos del explorador.
  • Agregar un canal o una categoría de canal.

Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.

Controlar cómo se suscribirán los usuarios a su servicio

  • Implementar un paquete de servidores de suscripción: en caso de que un usuario todavía no se haya suscrito a su servicio, puede proporcionarle una cuenta completamente activa mediante un servidor de suscripción basado en HTML y muy fácil de implementar.
  • Implementar un paquete sin servidor: Si un usuario ya tiene una cuenta con su servicio u otro servicio, puede actualizar el sitio del usuario con un explorador personalizado mediante un proceso simplificado sin servidor. En este tipo de paquete el usuario debe especificar algunas opciones de configuración finales en el momento de la instalación.

Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.

Utilizar el logotipo de Internet Explorer

De acuerdo con los términos del contrato de licencia, debe mostrar el logotipo de Internet Explorer en su paquete y materiales de promoción, así como en su sitio Web. Las imágenes gráficas necesarias para su sitio Web, los paquetes de sus programas y otros materiales de promoción se encuentran en la carpeta \<carpeta de programa IEAK>\Toolkit\Graphics\Samples.

Importante

  • Puede que algunas características no estén disponibles, según su contrato de licencia. Para obtener más información, consulte su contrato.


ISP. Opciones de suscripción a Internet

Imagen de título
Proveedor de
servicios Internet

Opciones de suscripción a Internet

Los servidores de suscripción a Internet (ISS) automatizan la tarea de agregar nuevos clientes a la base de datos de clientes de un proveedor de servicios Internet (ISP, Internet Service Provider). El servidor de suscripción a Internet recopila información de cada nuevo cliente, la agrega a la base de datos de clientes del ISP y, después, devuelve al equipo del cliente un paquete de configuración. El paquete de configuración contiene la información utilizada para configurar el explorador de Internet del cliente para las conexiones subsiguientes a los servicios del ISP.

Para agregar un cliente nuevo a la base de datos del ISP, el servidor de suscripción a Internet:

  • Hace que el equipo cliente establezca una conexión HTTP con el servidor de suscripción.
  • Recopila la información de suscripción del cliente.
  • Controla la aceptación o el rechazo por parte del cliente de los servicios del ISP.

Al utilizar el IEAK, hay tres opciones de suscripción a Internet disponibles:

  • Suscripción con servidor mediante el Asistente para la conexión a Internet (ICW)
  • Suscripción con servidor mediante el explorador en modo a pantalla completa
  • Suscripción sin servidor

El sistema más aconsejable es la suscripción con servidor, a menos que no se pueda proporcionar un servidor de suscripción, ya que es más sencillo cambiar la configuración en el servidor que en el cliente. De entre las dos opciones con servidor, se recomienda el método con ICW, ya que utiliza una interfaz de asistente estándar que puede personalizarse de modo que satisfaga las necesidades de una organización. Si es proveedor de servicios Internet, puede especificar el ICW como la herramienta que utilizarán los usuarios para suscribirse a los servicios Internet y configurar sus equipos.

Para obtener más información, consulte Implementar un proceso de suscripción con servidor.

Importante

  • En caso de que use marcas en un solo disco, no utilice el mecanismo de suscripción con el Asistente para la conexión a Internet si prevé que alguno de los usuarios va a tener instalado Internet Explorer 4.01 Service Pack 1 (o versiones anteriores); en lugar de ello, para dichos usuarios cree un paquete independiente mediante la suscripción en el modo a pantalla completa.

Código de ejemplo del Kit de herramientas del IEAK

Las soluciones personalizables para la suscripción a Internet se encuentran en el Kit de herramientas de IEAK. El código se proporciona en páginas Active Server (ASP) así como en formato Perl, lo que permite generar un proceso de suscripción con ICW para servidores Web en plataformas diferentes con el mínimo esfuerzo. Si utiliza el código de ejemplo, lo único que tendrá que hacer es integrar el servidor de suscripción con sus sistemas de registro y facturación. Si está participando en el programa Windows Referral Server Program, el código del servidor de suscripción es similar para los registros de suscripciones con IEAK y Referral Server.

Nota

  • Puesto que la solución del IEAK incluye varios archivos de suscripción a Internet (.ISP) para diferentes tipos de usuarios, también debe incluir el componente Enlace de datos de HTML dinámico en el paquete personalizado.

Crear varias versiones personalizadas de Internet Explorer

Si está creando varias versiones personalizadas de Internet Explorer y hay configuraciones que permanecerán invariables en la misma o en todas las versiones, puede simplificar el proceso. Para obtener más información, consulte Crear varias versiones del explorador.


ISP. Implementar un paquete de suscripción con servidor

Imagen de título
Proveedor de
servicios Internet

Implementar un proceso de suscripción con servidor

El proceso de suscripción con servidor automatiza las tareas de registro y configuración para usuarios nuevos y existentes. En este proceso se emplea un servidor de suscripción a Internet (ISS) para recopilar la información de cada usuario. El servidor de suscripción agrega los datos a la base de datos de clientes y, después, devuelve al equipo del usuario un paquete de configuración. Este paquete configura el explorador para conexiones posteriores a los servicios Internet.

Los ISP disponen de los siguientes métodos de suscripción con servidor:

  • Asistente para la conexión a Internet: mediante el Asistente para la personalización de Internet Explorer, puede especificar el Asistente para la conexión a Internet (ICW, Internet Connection Wizard) como la herramienta que utilizarán los usuarios para suscribirse y configurar sus equipos para los servicios Internet. Este es el método recomendado, ya que utiliza una interfaz de asistente estándar que puede personalizarse de modo que cumpla las necesidades de la organización y los usuarios. La característica de configuración automática de ICW también permite establecer la configuración para aquellos usuarios que ya disponen de cuentas de Internet.
  • Modo a pantalla completa: mediante el Asistente para la personalización de Internet Explorer, puede especificar que las pantallas del proceso de suscripción creadas se muestren en pantalla completa.

Puede ver un ejemplo ilustrado del proceso de suscripción en Proceso de suscripción a un ISP.

Crear un paquete personalizado con un método de suscripción con servidor

Para crear un paquete de explorador personalizado que incluya un método de suscripción con servidor, especifique lo siguiente en el paso 4 del Asistente para la personalización de Internet Explorer:

  • Suscripción con servidor mediante el Asistente para la conexión a Internet o Suscripción con servidor mediante el modo a pantalla completa como método de suscripción.
  • La ruta de acceso de la carpeta de trabajo que contiene los archivos de suscripción personalizados. Estos archivos permiten a los usuarios configurar sus equipos para conectarse al servidor de suscripción.
  • La información del servidor de suscripción, incluidos los parámetros de acceso telefónico a redes que permiten a los usuarios conectarse con el servidor de suscripción y la dirección URL de la primera página de suscripción en línea.
  • La información de personalización de ICW, incluida la barra de título y las imágenes personalizados (si ha seleccionado Suscripción con servidor mediante el Asistente para la conexión a Internet).

Para garantizar que el paquete se instala correctamente, la carpeta que contiene los archivos de suscripción personalizados deben incluir los siguientes elementos:

  • Signup.htm: esta página HTML proporciona información relativa a los servicios Internet y debe incluir un vínculo a una página HTML apropiada en el servidor de suscripción. Es posible personalizar el archivo Signup.htm de ejemplo, que se encuentra en la carpeta de IEAK \Reskit\ISP\Server\Client. Por ejemplo, puede agregar información de soporte técnico o incluir vínculos a los archivos de suscripción a Internet (.ISP).
  • Signup.isp: este archivo de suscripción a Internet (al que se hace referencia en el archivo Signup.htm) se utiliza para marcar el servidor de suscripción. También debe contener un vínculo a la dirección URL de la secuencia de comandos del servidor que genera los archivos de configuración de Internet (.INS). Mediante el Asistente para la personalización de Internet Explorer, puede modificar los parámetros contenidos en este archivo de suscripción. El Asistente para la personalización de Internet Explorer también genera otros archivos .ISP para el proceso de suscripción.
  • El resto de los archivos de suscripción: todos los archivos relacionados, incluidos los archivos gráficos .GIF y .JPG, deben guardarse en la misma carpeta que los archivos de suscripción personalizados. Por ejemplo, puede ser aconsejable incluir sus propias versiones personalizadas del archivo Install.gif.

Distribuir un paquete personalizado con un método de suscripción con servidor

Si utiliza un método de suscripción con servidor, el proceso de suscripción del paquete del explorador personalizado se realiza en tres pasos:

  1. El equipo del usuario establece una conexión con el servidor de suscripción.
  2. Un cuadro de diálogo basado en HTML/HTTP recopila información del usuario y la agrega a la información de clientes de la base de datos de clientes.
  3. El servidor de suscripción envía un paquete de configuración al equipo del cliente. Este paquete incluye información acerca de la configuración y marca. También incluye el número de teléfono local para que el cliente pueda tener acceso al proveedor de servicios Internet.

    4. Tenga en cuenta que si el nivel de seguridad del usuario está establecido a alto, el servidor de suscripción no funcionará ya que los archivos necesarios no se descargarán en el equipo del usuario.

Establecer una conexión con el servidor de suscripción

El usuario abre el programa de suscripción, que inicia Internet Explorer, marca el servidor de suscripción y publica una solicitud de conexión inicial. A continuación, el servidor de suscripción realiza las siguientes acciones:

  • Acepta la solicitud procedente del equipo del usuario (el cliente HTTP) y establece una conexión HTTP.
  • Crea un almacenamiento local de datos para acumular toda la información que escriba el usuario.
  • Le asigna un identificador exclusivo de sesión que se incrustará en todas las sucesivas transacciones HTTP con ese cliente.

HTTP es un protocolo sin sesión; sin embargo, el servidor de suscripción opera en un modo orientado a la sesión y utiliza el identificador de sesión para identificar todas las transacciones asociadas con el proceso de suscripción de un usuario determinado. Por ejemplo, el identificador de sesión puede ser un número secuencial generado automáticamente y asignado a esta transacción por la base de datos.

Recopilar la información de suscripción del usuario

El servidor de suscripción recopila la información del usuario desde una secuencia de páginas HTML que guía al usuario a través del proceso de suscripción, de forma parecida a como lo hace el asistente de un programa para Windows. El servidor de suscripción carga las páginas, a petición, en el equipo del cliente. El proceso de suscripción concluye cuando el usuario hace clic en el botón apropiado en la página HTML final para aceptar o rechazar el contrato de suscripción.

Puede elegir un contenido y formato propio para las páginas HTML. Por lo general, todas las páginas HTML incluyen los siguientes elementos:

  • Un formulario que debe rellenar el usuario.
  • Botones de exploración en los que el usuario puede hacer clic si desea desplazarse hacia delante y hacia detrás en las páginas.
  • Un botón en el que el usuario puede hacer clic si desea cancelar la sesión de suscripción.

Cada formulario HTML incluye controles para recopilar texto escrito, desplazarse por las páginas e identificar la sesión. El formulario recopila información del usuario y la transfiere al servidor de suscripción cuando el usuario hace clic en un botón de exploración. Además, el servidor de suscripción puede validar los datos y publicar una página de edición en el equipo del usuario en caso de que la información no sea aceptable.

Nota

  • Asegúrese de guardar el archivo HTML en la carpeta correcta del servidor de suscripción; el archivo Signup.isp incluye un vínculo a los archivos del servidor para las versiones de Windows de 32 bits y el archivo Signup.htm incluye un vínculo para las versiones de Windows de 16 bits.

Devolver un paquete de configuración al equipo del usuario

Si el usuario acepta el contrato de suscripción, el servidor de suscripción crea un paquete de configuración con un archivo .INS (generado por el Asistente para la configuración de Internet Explorer) que incluye información relativa al usuario y los servicios Internet. El archivo .INS únicamente puede contener la configuración de conexión, o bien configuraciones de conexión, explorador y correo que incluyan gráficos.

El servidor de suscripción devuelve el paquete de configuración al equipo del usuario mediante el archivo .INS, que puede generarse de forma inmediata o simplemente redirigirse al equipo del cliente. A continuación, el equipo del usuario puede continuar el proceso de instalación del paquete del explorador personalizado. En caso de que el usuario rechace o salga del contrato de suscripción, el servidor de suscripción redirige el equipo del usuario a un archivo que cancela el proceso de suscripción.

El paquete de configuración incluye la siguiente información:

  • Datos para configurar las conexiones a Internet
  • Funciones de la cuenta del usuario (incluido correo electrónico y lectores de noticias)
  • Información de marca, que personaliza la apariencia de las páginas de suscripción de la organización.
  • El número de teléfono local para que el usuario pueda tener acceso a los servicios Internet.

Los primeros dos tipos de datos se crean como parte del servidor de suscripción. El Asistente para la personalización de Internet Explorer prepara el archivo .INS para marcarlo. Algunas opciones de configuración, como Entrada, Usuario, Teléfono, Dispositivo, Servidor y TCP/IP, no pueden especificarse en el asistente; deberá asignarlas manualmente en el archivo .INS.

Si desea proporcionar varias versiones personalizadas "con marca privada" de Internet Explorer para grupos de usuarios diferentes, puede mantener varios conjuntos de información de marca que el servidor de suscripción descargará en el archivo .INS. Por ejemplo, quizás desee personalizar versiones con diferentes logotipos, barras de título, favoritos, páginas de búsqueda, páginas de inicio, vínculos especiales o ubicaciones para la asistencia en línea. Todos los discos compactos que distribuya a los usuarios serán iguales, pero se marcarán de una forma diferente cuando los usuarios se suscriban a los servicios Internet.

Consideraciones del servidor de suscripción para Internet Information Server

Si utiliza IIS como servidor de suscripción, debe configurar el servidor de suscripción a Internet de modo que suministre una dirección IP DHCP al cliente cuando éste se conecte al servidor. Puesto que el proceso de suscripción es relativamente corto, el tiempo de caducidad de la concesión de la dirección IP puede ser corto, posiblemente de unos pocos minutos.

El proceso de suscripción se ha diseñado para que se utilice en una conexión punto a punto, por lo que las direcciones IP asignadas al servidor DHCP no necesitan ser direcciones IP asignadas oficialmente. Es responsabilidad suya determinar si las direcciones IP de DHCP serán direcciones válidas de Internet o direcciones arbitrarias.

Registrar el tipo MIME del archivo .INS

Para que el cliente procese automáticamente el archivo .INS, debe registrar el tipo MIME para el archivo .INS con el servidor de suscripción. Se ha designado el tipo MIME "application/x-Internet-signup". Cuando el cliente solicita un archivo .INS, el servidor de suscripción responde con este tipo MIME, que inicia la aplicación de instalación asociada en el cliente.

Debe modificar manualmente los tipos MIME en el Registro. Para agregar el tipo MIME del archivo .INS, utilice Regedt32.exe para agregar la información siguiente:

En esta clave:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\InetInfo\Parameters\MimeMap

Agregue este valor:
application/x-internet-signup,ins,,5

Este valor no tiene asociada una cadena. Para obtener más detalles acerca de cómo configurar los tipos MIME, también puede consultar la Ayuda de IIS.

Nota

  • Para que la configuración del Registro surta efecto, es necesario apagar todos los servicios de IIS tras agregar el nuevo tipo MIME. No basta con detener y reiniciar el servicio de publicación en Web. (En la práctica, no es probable que los servicios FTP y Gopher se ejecuten en la configuración del servidor de suscripción.)


ISP. Configurar un servidor de suscripción en modo a pantalla completa

Imagen de título
Proveedor de
servicios Internet

Configurar un servidor de suscripción en modo a pantalla completa

Un servidor de suscripción a Internet (ISS, Internet Sign-up Server) es un servidor de Protocolo de transferencia de hipertexto (HTTP) que automatiza la tarea de agregar clientes nuevos a la base de datos de clientes de un proveedor de servicios Internet (ISP). El ISS recopila información de cada cliente nuevo, la agrega a la base de datos de clientes del ISP y, después, devuelve los datos al equipo del cliente. El paquete de información configura el explorador de Internet del cliente para que use los servicios del ISP.

Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.

Para agregar un cliente nuevo a la base de datos del ISP, el ISS:

  1. Establece una conexión HTTP con el equipo de escritorio del cliente.
  2. Recopila la información de suscripción del cliente.
  3. Controla la aceptación o el rechazo por parte del cliente de los servicios del ISP.

Para controlar estas tareas, puede adaptar el ejemplo de código de suscripción a Internet mediante el Asistente para la conexión a Internet. Dicho código se encuentra en el Kit de herramientas de IEAK, en la carpeta \<carpeta de programa IEAK>\Toolkit\ISP\Server\ICW\ y sus subcarpetas.

En los temas siguientes se describe cómo desarrollar un proceso de suscripción para el Asistente para la conexión a Internet. Aunque estos temas describen un proceso de suscripción completo y probado, que se recomienda para la mayor parte de los casos, puede personalizarlo de forma que se adapte a las necesidades de su organización.

  • Suscribirse a Internet con el Asistente para la conexión a Internet
  • Requisitos de código para las pantallas del Asistente para la conexión a Internet
  • Trabajar con los archivos de suscripción de ejemplo del ICW
  • Crear el archivo Icwsign.htm, las páginas de error y la página de finalización para suscripciones con ICW
  • Crear las pantallas de suscripción del ICW


Suscribirse a Internet con el Asistente para la conexión a Internet

Si es proveedor de servicios Internet, puede especificar el Asistente para la conexión a Internet (ICW, Internet Connection Wizard) como la herramienta que utilizarán los usuarios para suscribirse y configurar sus equipos con el fin de usar los servicios Internet. Puede crear soluciones que utilicen un servidor para intercambiar información con las pantallas del ICW. Esta característica no está disponible para el método de suscripción sin servidor.

Las soluciones personalizables para la suscripción a Internet se encuentran en el Kit de herramientas de IEAK, en la carpeta \<carpeta de programa IEAK>\Toolkit\ISP\Server\ICW\ y sus subcarpetas. El código se proporciona en páginas Active Server así como en formato Perl, lo que permite generar un servidor de suscripción ICW para servidores Web en plataformas diferentes con el mínimo esfuerzo. Si utiliza el código de ejemplo, lo único que tendrá que hacer es integrar el servidor de suscripción con sus sistemas de registro y facturación.

Si está participando en el programa Windows Referral Server Program, el código del servidor de suscripción es similar para los registros de suscripciones con IEAK y Referral Server.

Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.

En los temas siguientes se describe cómo desarrollar un proceso de suscripción para el Asistente para la conexión a Internet. Aunque estos temas describen un proceso de suscripción completo y probado, que se recomienda para la mayor parte de los casos, puede personalizarlo para que se adapte a las necesidades de su organización.

  • Requisitos de código para las pantallas del Asistente para la conexión a Internet
  • Trabajar con los archivos de suscripción de ejemplo del ICW
  • Crear el archivo Icwsign.htm, las páginas de error y la página de finalización para suscripciones con ICW
  • Crear las pantallas de suscripción del ICW
  • Utilizar la configuración automática del ICW para suscripciones a ISP

Importante

  • En caso de que use marcas en un solo disco, no utilice el mecanismo de suscripción del Asistente para la conexión a Internet si prevé que alguno de los usuarios tenga instalado Internet Explorer 4.01 Service Pack 1 (o versiones anteriores); en lugar de ello, para dichos usuarios cree un paquete independiente mediante la suscripción en el modo a pantalla completa.


Trabajar con los archivos de suscripción de ejemplo del ICW

Si desea simular el proceso de suscripción antes de crear sus archivos, puede utilizar los archivos de ejemplo del kit de herramientas del IEAK, en la carpeta \<carpeta de programa IEAK>\Toolkit\ISP\Server\ICW\. Los archivos de ejemplo pueden ofrecerle una idea general del funcionamiento del proceso de suscripción y el tipo de información que tendrá que proporcionar.

Para ello, siga los pasos siguientes:

  1. Cree un directorio denominado Signup en el directorio wwwroot de su servidor.
  2. Copie los archivos del kit de herramientas del IEAK al directorio Signup.
  3. En los archivos, cambie todas las referencias para que señalen a su servidor de suscripción.
  4. En el código HTML de las páginas del servidor de suscripción, cambie todas las referencias a Acme ISP por el nombre de organización.
  5. Modifique la última página del servidor de suscripción para que refleje la configuración del archivo .INS.


Requisitos de código y accesibilidad para suscripciones con el Asistente para la conexión a Internet

Imagen de título
Proveedor de
servicios Internet

Requisitos de código para las pantallas del Asistente para la conexión a Internet

El mecanismo de suscripción del ICW en el IEAK se basa en la idea de que un servidor de suscripción de Internet debería parecerse a un asistente normal de Windows y actuar como tal. Aunque el ICW hace uso de la flexibilidad y eficacia del HTML, no utiliza el mismo formato.

Las páginas HTML del asistente usan los colores y las fuentes del sistema de Windows y también deben cumplir unos requisitos de accesibilidad. A menos que se especifique lo contrario, las páginas HTML del asistente no pueden contener formato especial de HTML como tablas con bordes visibles, imágenes o marcadores. Sólo se permite texto sin formato y elementos de formulario, cuando se necesitan. Las tablas con bordes invisibles se pueden usar como elementos de diseño.

Para coincidir con los colores del sistema del usuario, todas las páginas HTML, excepto Icwsign.htm, no deben tener atributos de fuente o color a menos que se especifique lo contrario. El asistente principal define los colores o estilos de fuente para que coincidan con los del sistema del usuario.

El único requisito para implementar formularios dentro de páginas HTML es que usen los parámetros NAME en los elementos <FORM> definidos en la especificación. Puede especificar todos los nombres de testigo para el resto de los elementos de sus páginas HTML y se enviarán al servidor de suscripción.

Funcionalidad de los botones Atrás y Siguiente

La suscripción con el ICW tiene requisitos específicos que se deben cumplir para que los botones Atrás y Siguiente del Asistente para la conexión a Internet funcionen correctamente.

El ejemplo de código de servidor de suscripción incluido en el IEAK ya cumple estos requisitos.

Botón Atrás

Para que el botón Atrás funcione adecuadamente, debe agregar un elemento FORM a la página del servidor de suscripción que especifica la dirección URL del botón Atrás. Para mantener los datos que se han recopilado previamente en el proceso de suscripción, debe anexar todos los datos que desee retener a la dirección URL usada para el botón Atrás.

El siguiente es el elemento FORM necesario para que el botón Atrás envíe al usuario a la página anterior del proceso de suscripción. Tenga en cuenta que los datos se anexan a la dirección URL en forma de par nombre-valor:

<FORM NAME="BACK"
      ACTION="http://myserver/page2.asp"?firstname=bob&lastname=smith&address=...">
</FORM>

Nota

  • El elemento NAME y su valor deben estar en mayúsculas porque el ICW distingue mayúsculas y minúsculas.

Botón Siguiente

Para que el botón Siguiente funcione adecuadamente, debe agregar un elemento FORM a la página del servidor de suscripción que especifica la dirección URL del botón Siguiente. Para que los datos recopilados se pasen a la página siguiente en el proceso de suscripción, debe agregar campos de formulario ocultos en cada una de las páginas del servidor de suscripción que contengan los elementos de datos recopilados en ésta y en todas las ventanas anteriores. La dirección URL a la que hace referencia debe contener código que recopile los datos de la página anterior y muestre la página siguiente del proceso de suscripción.

El siguiente es el elemento FORM necesario para que el botón Siguiente envíe al usuario a la página siguiente del proceso de suscripción:

<FORM NAME="NEXT"
      ACTION="http://myserver/page2.asp">
</FORM>

Requisitos de accesibilidad

Para asegurar que los elementos de la página son accesibles sólo mediante la utilización del teclado, cada elemento de formulario debe cumplir los requisitos siguientes:

  • Debe haber una tecla de acceso asociada al elemento de formulario. Use el parámetro ACCESSKEY= de Internet Explorer en la etiqueta <INPUT>. El carácter de la tecla de acceso se debe subrayar para resaltarla mediante la etiqueta <U>. Las letras b, f, g, n y o se reservan para el ICW y no se pueden usar como teclas de acceso. Para obtener más información acerca del parámetro ACCESSKEY, consulte el sitio MSDN Online Web Workshop.
  • Cada elemento de la página debe formar parte del orden de la tecla TAB del ICW (orden de tabulación). Para que se incluya en el orden de la tecla TAB del ICW,el elemento debe tener un identificador único en la etiqueta <INPUT>.
  • Cada uno de los elementos debe tener una etiqueta asociada. Si desea asociar una etiqueta para tipos de entrada de formulario HTML diferentes, use el parámetro LABEL= de Internet Explorer.

Ejemplo

El siguiente elemento de formulario (un botón de opción) cumple los requisitos de accesibilidad del ICW:

<INPUT ID="opción2"
       TYPE="radio"
       NAME="facturación"
       VALUE="hora"
       ACCESSKEY="h"
       CHECKED
>
<LABEL for="opción2">
    5 <U>H</U>horas mensuales por 10 dólares.
</LABEL>

Requisitos de diseño y HTML

Las páginas del Asistente para la conexión a Internet deben tener los elementos de diseño siguientes y cumplir las convenciones de diseño que se indican a continuación.

Importante

  • Sólo se permiten elementos de formulario HTML y texto. No están permitidas las imágenes, hipervínculos o barras de desplazamiento.

Hoja de estilo

No especificar atributos de color o estilo de fuente. El asistente principal establece estos atributos. Si utiliza una etiqueta <TABLE>> en las páginas de error, la etiqueta debe incluir el estilo siguiente:

<TABLE style="font: 8pt 'ms sans serif' buttontext"> </TABLE>

Elementos de formulario obligatorios

Esta página debe incluir cuatro elementos <FORM> HTML para especificar propiedades de página diferentes:

Elemento | Requisitos
Un identificador de página PAGEID exclusivo para la página | El nombre (NAME) del formulario debe ser "PAGEID" y se distinguen mayúsculas y minúsculas. El atributo ACTION del formulario debe ser un identificador exclusivo que no coincida con el identificador PAGEID de ninguna otra página de la sección ISP del asistente; por ejemplo, <FORM NAME="PAGEID" ACTION="pagina4"></FORM>).
La función del botón Atrás | El nombre (NAME) del formulario debe ser "BACK" y se distinguen mayúsculas y minúsculas. El atributo ACTION de este formulario debe ser la dirección URL absoluta de la página anterior (por ejemplo, ACTION="HTTP://signup/bin/page1.cgi"); sin embargo, no se enviará ningún dato a esta página.
Características de la página | El formulario se identifica con el nombre (NAME) "PAGETYPE" y se distinguen mayúsculas y minúsculas. Debido a que éste es un marco estándar donde el ISP define todo el espacio, el atributo ACTION del formulario debe ser una cadena vacía; por ejemplo, ACTION="".
La función del botón Siguiente | El nombre (NAME) del formulario debe ser "NEXT" y se distinguen mayúsculas y minúsculas. Éste es el formulario que contiene los elementos reales que se enviarán de vuelta al servidor de suscripción del ISP. No hay restricciones en los nombres de los testigos para los elementos <INPUT> dentro del formulario. El atributo ACTION del formulario debe ser la dirección URL absoluta donde se debe enviar la información del formulario. La dirección URL enviada al servidor debe contener una secuencia de comandos que reciba los datos y muestre a continuación la siguiente página HTML del asistente.


Utilizar la configuración automática del ICW para suscripciones a ISP

La configuración automática del ICW permite a los usuarios que ya disponen de una cuenta con un proveedor de servicios Internet volver a configurar su cuenta de forma automática. Cuando los usuarios compran un equipo nuevo, esta característica les ayuda a configurarlo para usar la misma cuenta de Internet que tenían en el equipo anterior o en un equipo del trabajo. También resulta de utilidad para los usuarios cuya configuración de Internet se haya dañado. La característica de configuración automática restaura sus opciones de configuración; el usuario sólo necesita conocer su identificador de usuario, contraseña y servidor POP.

En una versión personalizada de Internet Explorer, el usuario tiene acceso al servidor de configuración automática del disco compacto de Internet Explorer al hacer clic en un vínculo de la página Icwsign.htm. Este vínculo conecta al usuario con el servidor de registro de configuración automática. Una vez que el usuario se conecta al servidor de suscripción, éste puede preguntarle el nombre de usuario, la contraseña y el servidor POP. Con esta información puede enviar un archivo .INS al equipo del usuario para volver a configurar su cuenta.

Métodos para permitir la configuración automática del ICW

Hay dos modelos que puede usar para restaurar las cuentas de usuario mediante la configuración automática:

  • Preguntar al usuario su nombre, contraseña y servidor POP. Esta información debería ser suficiente para volver a crear el archivo .INS, enviarlo al usuario y volver a configurar la cuenta. Si le preocupa el uso abusivo de esta característica, quizás prefiera volver a recopilar el número de tarjeta de crédito del usuario y realizar una comprobación en la base de datos de registro.
  • Almacenar los archivos .INS con el resto de la información de la cuenta del usuario. Cuando un usuario se conecta al servidor de configuración automática, puede obtener el archivo .INS; para ello, únicamente debe proporcionar el nombre de usuario y la contraseña. El servidor de configuración automática buscaría entonces la cuenta del usuario y le entregaría una copia de su archivo .INS original. Al igual que en el modelo anterior, si le preocupa el uso abusivo de esta característica, puede ser aconsejable volver a recopilar el número de tarjeta de crédito del usuario y realizar una comprobación en la base de datos de registro.

Para establecer la configuración automática del ICW, siga las instrucciones que se indican en Requisitos de código para las pantallas del Asistente para la conexión a Internet y diseñe la página de correo electrónico o de inicio de sesión de la cuenta del ISP, la página de selección de POP del ISP y la página de finalización del ISP.


ISP. Implementar un paquete de suscripción sin servidor

Imagen de título
Proveedor de
servicios Internet

Implementar un paquete de suscripción sin servidor

El proceso de suscripción sin servidor permite a los usuarios instalar el explorador Internet Explorer personalizado mediante disco compacto, discos o archivos descargables. El proceso de instalación requiere que los usuarios escriban sólo su nombre de usuario, la contraseña e información de su conexión para configurar una cuenta y conectarse a Internet mediante el explorador personalizado. Los proveedores de servicios Internet pueden personalizar la configuración del usuario sin utilizar un servidor de suscripción. Dado que la información de configuración se distribuye con el paquete IEAK y, por lo tanto, está disponible localmente en el equipo del usuario, el proceso no es tan dinámico como una suscripción con servidor.

No puede utilizar el método de suscripción sin servidor para personalizar el Asistente para la conexión a Internet.

Crear un paquete personalizado con un método de suscripción sin servidor

Para crear un paquete del explorador personalizado que incluya un método de suscripción sin servidor, especifique lo siguiente en el paso 4 del Asistente para la personalización de Internet Explorer:

  • Suscripción sin servidor como método de suscripción.
  • La ruta de acceso de la carpeta que contiene los archivos de suscripción personalizados. Estos archivos permiten a los usuarios configurar sus equipos para los servicios Internet.
  • Los parámetros de acceso telefónico a redes que permiten a los usuarios establecer una conexión para obtener los servicios Internet.

Para garantizar que el paquete se instala correctamente, la carpeta que contiene los archivos de suscripción personalizados debe incluir los siguientes elementos:

  • Signup.htm: esta página HTML proporciona información relativa a los servicios Internet y debe incluir un vínculo al archivo .INS, que contiene las opciones de configuración del paquete del explorador personalizado.
  • El resto de los archivos de suscripción: todos los archivos relacionados, incluidos los archivos gráficos .GIF y .JPG, deben guardarse en la misma carpeta que los archivos de suscripción personalizados. Por ejemplo, quizás desee incluir sus propias versiones personalizadas del archivo Install.gif y Logohere.gif.

Distribuir un paquete personalizado con un método de suscripción sin servidor

El paquete personalizado incluye un archivo de configuración, llamado Install.ins, que contiene la configuración especificada para el explorador personalizado. Al contrario que en el método con servidor de suscripción Internet, este archivo .INS no contiene información de configuración específica del usuario. Cuando el usuario inicia el programa de suscripción, un vínculo de la página HTML local ejecuta el archivo .INS. El usuario proporciona su nombre de usuario, contraseña e información de conexión. A continuación, el archivo .INS configura la cuenta del usuario para conectarse a Internet mediante el explorador personalizado.

Desventajas del uso del proceso de suscripción sin servidor

Dado que el archivo de configuración se distribuye con el paquete IEAK, no puede cambiar dinámicamente las opciones de configuración de usuario en el servidor de suscripción.

El servidor de suscripción normal obtiene la información acerca de un usuario y después prepara un archivo de configuración personalizado que se descarga en el equipo del usuario. El software del paquete de instalación de Internet Explorer utiliza el archivo de configuración para configurar el equipo.

En la versión sin servidor, se crea el archivo de configuración antes de distribuir el paquete y se incluye en el paquete de instalación. Por tanto, el archivo de configuración no contiene información de configuración específica del usuario. Al archivo de configuración, Install.ins, se le llama como un vínculo desde la página HTML local y configura la mayor parte de las opciones de Internet Explorer. Dado que el archivo de configuración se incluye en el paquete de instalación, se almacena localmente en el equipo del usuario.

Para compensar esta desventaja, la opción avanzada del proceso de suscripción sin servidor emplea un control ActiveX (installx.exe), que permite generar un archivo .INS que incorpora la información del usuario. Internet Explorer utilizará a continuación el archivo generado por el control ActiveX para definir la configuración del usuario.


ISP. Preparación para ejecutar el asistente

Imagen de título
Proveedor de
servicios Internet

Preparación para ejecutar el asistente

Antes de ejecutar el Asistente para la personalización de Internet Explorer, debe recopilar toda la información que necesite y crear los mapas de bits personalizados.

Determine los requisitos de plataforma iniciales

  • Compruebe que el equipo en el que va a generar el paquete y los equipos donde se instalará cumplen los requisitos de hardware y de software.
  • Determine los niveles de cifrado para los paquetes del explorador. Para obtener más información acerca del cifrado de Internet Explorer, visite el sitio Web del IEAK.

Elija el método de distribución

Decida cómo distribuirá su paquete personalizado (CD, descarga, red de área local o en discos). Una vez que el Asistente para la personalización de Internet Explorer haya generado el paquete, tendrá que mover los archivos al soporte seleccionado. Si genera un paquete descargable, debe moverlo al lugar apropiado de su servidor.

Si decide publicar su paquete del explorador en un servidor de Internet, necesitará la ruta de acceso del servidor y la dirección URL desde la que se descargarán los archivos. Después, cree una carpeta en el servidor Web, como CIE, para publicar todos los archivos y carpetas asociados al explorador personalizado. Por ejemplo, podría crear la ruta de acceso de servidor C:\Inetpub\Wwwroot\ie5\Cie. Si nombreDelEquipo es la raíz virtual de este servidor Web, la dirección URL correspondiente sería http://nombreDelEquipo/Cie/.

Obtenga un certificado digital

Realice los preparativos iniciales para firmar determinados archivos, como son los archivos de personalización creados por el Asistente para la personalización de Internet Explorer y los componentes personalizados, en el caso de que vaya a distribuirlos a través de Internet o de una intranet que no esté especialmente configurada. Con las características de seguridad del explorador, se advierte a los usuarios acerca de la descarga de archivos sin firmar o se les impide descargarlos. Las firmas digitales identifican el origen de los programas y garantizan que el código no ha cambiado desde que se firmó.

El Asistente para la personalización de Internet Explorer puede firmar los archivos si dispone de un certificado de publicación emitido por una entidad emisora de certificados. Para preparar los certificados de forma que los utilice el IEAK, puede importarlos en el equipo por medio del Asistente para la importación del Administrador de certificados. Si ha recibido un archivo con la extensión .SPC, puede iniciar el Asistente para la importación del Administrador de certificados si hace doble clic en el archivo .SPC en el Explorador de Windows o en Mi PC.

También puede abrir el Administrador de certificados desde Internet Explorer. Para hacerlo, haga clic en el menú Herramientas, Opciones de Internet, haga clic en la ficha Contenido y, finalmente, en Certificados. Haga clic en Importar para iniciar el Asistente para importación del Administrador de certificados y, después, siga los pasos que se indican en el asistente.

Cree la estructura en el equipo

Cree la estructura de carpetas siguiente:

Nombre de carpeta | Descripción
\CIE | Una raíz principal para todos los archivos generados por el IEAK o a los que el paquete personalizado haga referencia
\CIE\Custom | Los archivos personalizados (como Signup.isp, Signup.htm, Icwsign.htm, Install.ins y Cancel.ins, dependiendo de su método de suscripción) para suscripción con servidor
\CIE\Dist | Directorio de destino de los archivos (esta carpeta sólo es necesaria si está creando su paquete del explorador en un disco duro o en una unidad de red)
\CIE\Bitmaps | Archivos de mapas de bits personalizados (archivos gráficos necesarios para el explorador personalizado)

Para copiar los archivos de suscripción necesarios para esta estructura

  1. Seleccione todos los archivos de las subcarpetas siguientes que se encontrarán donde se haya instalado el IEAK: \<carpeta de programa IEAK>\Toolkit\Isp\Servless, para suscripción a Internet sin servidor, o \<carpeta de programa IEAK>\Toolkit\Isp\Server\, para suscripción a Internet con servidor.
  2. Copie estos archivos a CIE\Custom.

Elija un método de suscripción y personalice los archivos de suscripción

En el paquete personalizado, puede especificar cómo se suscribirán los nuevos usuarios a su servicio y cómo se conectarán a Internet. Puede elegir un proceso de suscripción con o sin servidor, o deshabilitar por completo la característica de suscripción (para distribuir actualizaciones de software a usuarios existentes). En el kit de herramientas del IEAK se incluyen archivos de ejemplo de las páginas HTML necesarias para admitir cada método de suscripción.

Para obtener mas información acerca de las distintas opciones, consulte Opciones de suscripción a Internet.

Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.

Cree los gráficos apropiados

Tendrá la opción de personalizar los mapas de bits siguientes en el explorador. Coloque los mapas de bits en la carpeta \CIE\Bitmaps antes de ejecutar el Asistente para la personalización de Internet Explorer.

Los fondos y botones personalizados sólo se muestran en equipos con capacidad para mostrar 256 colores (8 bits). En los equipos con capacidad para mostrar 16 colores (4 bits) se muestra un conjunto estándar de botones y mapas de bits de fondo de baja resolución.

  • Un mapa de bits de fondo para la pantalla de ejecución automática del CD-ROM (si crea un paquete en CD-ROM).

    Si piensa distribuir el explorador personalizado en un disco compacto, debe crear mapas de bits como parte de la pantalla inicial del programa de ejecución automática que se muestra cuando el usuario ha insertado el disco compacto. Para crear este mapa de bits, consulte Crear un mapa de bits para la pantalla inicial del programa de ejecución automática.

  • Una imagen personalizada para los botones del CD-ROM (si crea un paquete en CD-ROM).
  • Dos mapas de bits personalizados para el Asistente para la instalación de Windows Update (si desea personalizar su apariencia): un mapa de bits de 162 por 312 píxeles para el lado izquierdo de la primera pantalla del asistente y un mapa de bits de 496 por 56 píxeles para la parte superior de las restantes pantallas del asistente.
  • Un mapa de bits personalizado de barra de herramientas (que se muestra como fondo de los botones y menús).
  • Dos imágenes de mapa de bits estáticas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo.
  • Dos imágenes de mapa de bits animadas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo animado.

    Con IEAK se incluyen dos herramientas para ayudarle a crear y obtener vistas previas de los mapas de bits animados personalizados para el explorador. Para obtener información acerca de cómo utilizar estas herramientas, consulte Herramientas para mapas de bits animados.

Para obtener una lista completa de todos los gráficos, consulte Crear gráficos personalizados.

Recopile las direcciones URL de las páginas Principal, Búsqueda y Soporte

Es conveniente crear una página de soporte que aparecerá si los usuarios tienen problemas al instalar el explorador. Se le pedirán las direcciones URL de esas páginas cuando ejecute el Asistente para la personalización de Internet Explorer.

Notas

  • Para obtener más información acerca del programa de instalación, consulte Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas para Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


ISP. Paso 1 del asistente: recopilar información

Imagen de título
Proveedor de
servicios Internet

Paso 1 del asistente: recopilar información

En el primer paso del Asistente para la personalización de Internet Explorer, los proveedores de servicios Internet deben proporcionar la información siguiente:

  • Nombre de su organización y código de personalización de diez dígitos. El código de personalización está incluido con el resto de información del kit que recibió de Microsoft.
  • Su función, que depende del contrato de licencia. Debe especificar si se trata de un programador o proveedor de contenido, un proveedor de servicios o un administrador corporativo.
  • La ubicación de los archivos necesarios para crear el paquete personalizado del explorador.
  • El idioma del paquete del explorador que está creando. Necesitará ejecutar el Asistente para la personalización de Internet Explorer para cada versión internacional que desee crear.
  • El medio de distribución que piense utilizar, como CD-ROM o descarga.
  • Las características que piensa personalizar. Por ejemplo, si sólo va a hacer pequeñas modificaciones al explorador, no tendrá que pasar por todas las pantallas del Asistente para IEAK.

Nota

  • El Asistente para la personalización de Internet Explorer no funcionará correctamente si no está instalado Internet Explorer 5.5. Para obtener más información, consulte Requisitos de hardware y del sistema.


ISP. Paso 2 del asistente: especificar los parámetros de instalación

Imagen de título
Proveedor de
servicios Internet

Paso 2 del asistente: especificar los parámetros de instalación

En este paso del Asistente para la personalización de Internet Explorer, los proveedores de servicios Internet deben:

  • Descargar o actualizar componentes de Microsoft mediante la sincronización automática de versiones. Debe descargar Internet Explorer, pero puede elegir los demás componentes de Internet Explorer que descargará.
  • Seleccionar los componentes personalizados que desea incluir.

    También puede especificar hasta diez componentes adicionales, que pueden ser archivos ejecutables autoextraíbles (.EXE) o archivos contenedores (.CAB) comprimidos.


ISP. Paso 3 del asistente: personalizar la instalación

Imagen de título
Proveedor de
servicios Internet

Paso 3 del asistente: personalizar la instalación

En este paso del Asistente para la personalización de Internet Explorer, los proveedores de servicios Internet pueden determinar cuál será la apariencia y funcionamiento del programa de instalación de Windows Update:

  • Personalice la pantalla de ejecución automática del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice otras opciones del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice el Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet. Estas opciones de configuración afectan a la apariencia del programa de instalación.
  • Especifique hasta diez opciones de instalación y determine los componentes que incluirá en cada opción.
  • Especifique hasta diez sitios desde los que se podrá descargar el paquete.
  • Especifique de qué forma recibirán los usuarios las actualizaciones de los componentes.
  • Especifique si el programa de instalación debe detectar si existe un componente dado y determine con precisión qué componentes pueden personalizar los usuarios.
  • Determine si los componentes que se han descargado, pero no se han incluido en todos los paquetes, deben ponerse a disposición de los usuarios por medio de la característica de instalación a petición de Internet Explorer.
  • Importe un perfil personalizado desde el Kit de administración del Administrador de conexión.
  • Especifique los datos de la entidad emisora de certificados para que, si tiene un certificado digital, pueda firmar los programas al crear el paquete IEAK.

Notas

  • Para obtener más información acerca del programa de instalación, consulte Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.
  • Para ver un organigrama de lo que ocurre al usar el Asistente para la personalización de Internet Explorer con el fin de crear un paquete personalizado, consulte Cómo genera el IEAK paquetes personalizados.


ISP. Paso 4 del asistente: personalizar el explorador

Imagen de título
Proveedor de
servicios Internet

Paso 4 del asistente: personalizar el explorador

En este paso del Asistente para la personalización de Internet Explorer, los proveedores de servicios Internet pueden personalizar lo siguiente:

  • El mapa de bits de fondo de la barra de herramientas y la barra de título del explorador. Cuando seleccione un mapa de bits, asegúrese de que los colores contrastan con el texto.
  • Los botones de la barra de herramientas del explorador. Puede agregar botones personalizados a la barra de herramientas para ejecutar secuencias de comandos y programas.
  • El logotipo de Internet Explorer de la esquina superior derecha del explorador.
  • Las páginas principal, de búsqueda y de soporte en línea del explorador.
  • Favoritos, carpetas de Favoritos y vínculos de la barra de vínculos.
  • Canales. Puede agregar un canal o una categoría de canales que es, simplemente, una carpeta de canales.
  • La página de bienvenida, que aparece cuando el usuario inicia el explorador por primera vez.
  • Una cadena agente de usuario. El identificador del agente de usuario es opcional; es una forma de realizar un seguimiento del uso de su explorador personalizado.
  • La configuración de la conexión del usuario al personalizarla, importarla o eliminar la configuración existente del usuario.
  • Configuración de proxy.
  • Certificado raíz.
  • Método de suscripción del usuario.
  • Archivos de suscripción. Puede especificar la ruta de acceso de la carpeta que contiene los archivos de suscripción y especificar si desea modificar estos archivos.
  • Parámetros de la conexión de acceso telefónico a redes y archivos de configuración de Internet que utilizarán los clientes para conectarse a su servidor de suscripción a Internet.
  • Configuración del Asistente para la conexión a Internet, si sus usuarios van a utilizar el asistente para suscribirse a sus servicios.

Notas

  • Para obtener más información acerca del programa de instalación, consulte Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


ISP. Paso 5 del asistente: personalizar componentes

Imagen de título
Proveedor de
servicios Internet

Paso 5 del asistente: personalizar componentes

En este paso del Asistente para la personalización de Internet Explorer, los proveedores de servicios Internet pueden personalizar lo siguiente:

  • La configuración predeterminada del programa, como los programas específicos que se utilizarán para leer correo electrónico o modificar HTML.
  • Los servidores de correo y noticias de los usuarios, si va a incluir Outlook Express en el paquete personalizado.
  • La configuración del servidor de correo electrónico IMAP para los usuarios, en el caso de que vaya a distribuir Outlook Express y tenga un servidor IMAP .
  • El contenido personalizado de Outlook Express, al agregar su propio mensaje de correo electrónico para dar la bienvenida a los usuarios y personalizar el panel de información que aparece cuando los usuarios inician el programa.
  • La configuración personalizada de Outlook Express, por ejemplo, con la definición de nuevos clientes predeterminados de correo y de noticias, el suministro de ayuda a los usuarios que necesitan disponer de cuentas de correo adicionales y la creación de un archivo de reglas predeterminadas para los mensajes de los usuarios.
  • La configuración de la interfaz de usuario de Outlook Express, como decidir si se muestran la barra de carpetas, la lista de carpetas, los contactos de MSN Messenger, la barra de estado o la barra de Outlook.
  • La configuración de redacción de Outlook Express, si desea definir una renuncia de responsabilidad corporativa o firma para incluirlas en los mensajes de correo electrónico o de grupos de noticias.
  • El servicio de directorio de la Libreta de direcciones de Windows, si desea ofrecer servicios de directorio de Internet a los usuarios y personalizar los servidores de Protocolo compacto de acceso a directorios (LDAP, Lightweight Directory Access Protocol).
  • La marca de MSN Messenger Service, si está incluyendo una instalación personalizada del cliente del servicio de mensajería en el paquete.
  • Los elementos multimedia de MSN Messenger Service, si desea cambiar los gráficos, el contenido promocional o los sonidos utilizados en la instalación personalizada del cliente del servicio de mensajería.
  • La información de cuenta de MSN Messenger Service, si desea cambiar las opciones predeterminadas de la cuenta Passport y la configuración de la integración de correo electrónico en una instalación personalizada del cliente del servicio de mensajería.
  • Directivas del sistema y configuración, para preestablecer las opciones de Internet.


ISP. Distribuir su paquete del explorador

Imagen de título
Proveedor de
servicios Internet

Distribuir su paquete del explorador

De forma predeterminada, el Asistente para la personalización de Internet Explorer crea archivos para descargar desde Internet. También puede distribuir el paquete del explorador personalizado en un CD-ROM. Para obtener una lista completa de todos los medios de distribución, consulte Selección del medio.

Archivos descargables

Los proveedores de servicios Internet pueden distribuir un único archivo a los usuarios que contenga el motor de instalación, el cual descargará los componentes de la aplicación desde un servidor de Internet.

Si creó el paquete del explorador en un servidor de Internet, debe configurar su sitio Web para que los usuarios puedan descargar los archivos. Por ejemplo, podría crear una página en la que publicara la información de descarga y un vínculo al motor de instalación, IE5setup.exe.

Si creó el paquete del explorador en un disco duro o en una unidad de red, deberá mover los elementos siguientes al servidor de Internet:

  • La carpeta que contiene la versión del idioma que está publicando y los contenidos de la carpeta. Por ejemplo, la carpeta de la versión en inglés se llama En, por lo que debe mover la carpeta En y los archivos que contiene. Esta carpeta estará en las carpetas que correspondan al tipo de distribución, por ejemplo, Download (descarga), y plataforma. La única designación de plataforma de Internet Explorer Administrative Kit 5.5 es "Win32"; para clientes UNIX y Windows de 16 bits, use Internet Explorer Administrative Kit 5.0x.
  • El archivo denominado Ie5sites.dat. Este archivo señala el sitio de descarga o sitios especificados al ejecutar el Asistente para la personalización de Internet Explorer.

    • Para ver un ejemplo, consulte Cómo configurar los archivos para distribución.

    Para ver un organigrama de los archivos que crea el Asistente para la personalización de Internet Explorer, consulte Cómo genera el IEAK paquetes personalizados.

Firmar los paquetes personalizados

Los exploradores Web tienen características de seguridad que ayudan a proteger a los usuarios frente a la descarga de programas perjudiciales. En función del nivel de seguridad y de la plataforma, se puede advertir al usuario o evitar que descargue programas que no estén firmados digitalmente.

Los archivos personalizados .CAB creados con el Asistente para la personalización de Internet Explorer deben estar firmados, a menos que se haya configurado la zona local de la intranet con un nivel bajo de seguridad. Cualquier componente personalizado que distribuya con el paquete del explorador y vaya destinado a esas plataformas también debe estar firmado. Si dispone de un certificado digital, el Asistente para la personalización de Internet Explorer puede firmar automáticamente esos archivos.

Notas

  • La firma de los archivos contenedores (.CAB) y los programas personalizados requiere que se lleven a cabo dos pasos: obtener un certificado digital y especificar los datos del certificado al ejecutar el Asistente para la personalización de Internet Explorer. Para obtener más información, consulte Firmar sus programas.
  • Es posible que deba cambiar las mayúsculas y minúsculas de los nombres de los archivos publicados en un servidor UNIX de FTP. A continuación se detallan las convenciones que debe usar para sistemas operativos UNIX específicos.
    • UNIX de Solaris
      Si está utilizando un servidor FTP de UNIX que distingue mayúsculas y minúsculas, debe asegurarse de que la carpeta contenedora no contiene mayúsculas, mientras que los archivos siguientes están en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT.
    • UNIX de AT&T
      Todos los nombres de archivo deben estar en mayúsculas en un servidor FTP de UNIX de AT&T.
    • UNIX de IRIX (Silicon Graphics)
      Los nombres de archivo siguientes deben estar en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT. Debe usar un procesador de textos a fin de modificar los nombres de archivos enumerados en IE.CIF para que la utilización de mayúsculas coincida con la de los archivos.

CD-ROM

Si distribuye el explorador personalizado para usuarios de Windows 95, aparecerá una pantalla de inicio del programa de ejecución automática cuando el usuario inserte el disco compacto. Este programa ofrece a los usuarios la posibilidad de instalar el explorador personalizado o ver más información. Si ya está instalada la versión actual de Internet Explorer, el programa de ejecución automática la detectará. Se mostrará el explorador en lo que se conoce como modo a pantalla completa con el archivo Start.htm cargado.

Para obtener más información

Para obtener información más detallada acerca de la instalación de Windows Update, consulte Instalación de Windows Update para Internet Explorer y otras herramientas para Internet. El proceso de descarga se muestra en el diagrama Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.


ISP. Cómo distribuir su cliente del servicio de mensajería

Imagen de título
Proveedor de
servicios Internet

Cómo distribuir su cliente del servicio de mensajería

Si ha incluido MSN Messenger Service como una opción de instalación, el Asistente para la personalización de Internet Explorer crea un paquete independiente para descargar el cliente del servicio de mensajería personalizado desde Internet.

Archivos descargables

Si creó el paquete del cliente del servicio de mensajería en un servidor de Internet, asegúrese de configurar su sitio Web para que los usuarios puedan descargar los archivos. Por ejemplo, puede crear una página en la que se publique la información de descarga y un vínculo al archivo de instalación ejecutable (mmssetup.exe) para el cliente del servicio de mensajería.

Si creó el archivo mmssetup.exe en un disco duro o en una unidad de red, deberá moverlo a un servidor de Internet para cada versión de idioma que esté publicando: Cada versión de idioma crea una subcarpeta en la carpeta Messenger del directorio de la compilación. Por ejemplo, la versión de la compilación en inglés de mmssetup.exe se encuentra en la subcarpeta En. Si ha especificado una dirección URL de descarga durante la personalización, cree un vínculo dentro de la página de la dirección URL de descarga que señale a mmssetup.exe. Todos los componentes necesarios para distribuir un cliente del servicio de mensajería personalizado se incluyen en este archivo ejecutable.

Firmar la instalación del cliente del servicio de mensajería

Si incluyó un certificado digital para firmar el paquete del explorador cuando ejecutó el Asistente para IEAK, se utilizará el mismo certificado para firmar el programa de instalación mmssetup.exe. Para obtener más información, consulte Firmas digitales y Firmar sus programas.

El cliente del servicio de mensajería como parte del paquete del explorador

El cliente del servicio de mensajería personalizado también se instalará como parte del paquete del explorador, siempre y cuando haya especificado que MSN Messenger Service se incluya en las opciones de instalación. Se crea un paquete .CAB distinto para el cliente del servicio de mensajería personalizado, que se incluirá como componente al ejecutar ie5setup.exe. Consulte Distribuir su paquete del explorador para obtener más información acerca de cómo distribuir todo el paquete del explorador.

Clientes de servicio de mensajería y servidores de seguridad

Si necesita especificar opciones de proxy avanzadas para servicios de mensajería que están detrás de un servidor de seguridad, no indique una dirección URL de descarga. Además, debe modificar el texto para generar un archivo de instalación que configurará previamente las opciones de proxy. Consulte Personalización avanzada de un cliente de mensajería para obtener más detalles.


Introducción para administradores corporativos

Microsoft Internet Explorer Administration Kit (IEAK) le permite crear una instalación no interactiva y personalizada de Microsoft Internet Explorer que se adapte totalmente a las necesidades de su organización.

Puede utilizar este kit para realizar lo siguiente:

Personalizar el programa de instalación

  • Personalizar la apariencia del programa de instalación de Windows Update y configurar los modos de instalación (por ejemplo, las instalaciones Estándar y Mínima).
  • Dirigir a los usuarios a servidores de Internet o de intranets para que tengan acceso a las versiones más recientes del producto.
  • Distribuir programas internos, secuencias de comandos personalizadas o secuencias de comandos de mantenimiento cuando los usuarios instalen Internet Explorer.
  • Especificar la versión del idioma de Internet Explorer que incluirá en el paquete de instalación. Debe ejecutar una vez el Asistente para la personalización de Internet Explorer por cada versión de idioma que desee crear.

Personalizar el explorador y la Actualización del escritorio de Windows

  • Especificar las páginas de inicio, búsqueda y soporte que desea utilizar.
  • Cargar vínculos y carpetas en la lista de Favoritos.
  • Cambiar la barra de título y los logotipos del explorador.
  • Configurar y controlar la Actualización del escritorio de Windows, incluidos los elementos y las barras de herramientas del escritorio, el Panel de control y Mi PC.
  • Controlar qué canales aparecen en los escritorios de la organización.
  • Crear un escritorio predeterminado para la organización y determinar qué opciones de configuración pueden cambiar los usuarios.

Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.

Administrar la seguridad y la clasificación de contenido

  • Instalar previamente certificados en los equipos de los usuarios e impedir que descarguen otros certificados.
  • Predefinir la configuración de la clasificación de contenido de los usuarios de forma que se adapten a las directivas de la organización.
  • Establezca una renuncia estándar de la empresa para las publicaciones de grupos de noticias creados por los usuarios de su organización.
  • Utilizar las zonas de seguridad para establecer distintos niveles de seguridad y zonas de confianza.
  • Especificar la configuración de proxy de direcciones y puertos.

Importante

  • Puede que algunas características no estén disponibles, según su contrato de licencia. Para obtener más información, consulte su contrato.


Administrador corporativo. Preparación para ejecutar el asistente

Imagen de título
Administrador
corporativo

Preparación para ejecutar el asistente

Antes de ejecutar el Asistente para la personalización de Internet Explorer, debe recopilar toda la información que va a necesitar y crear los mapas de bits personalizados.

Determine los requisitos de plataforma iniciales

  • Compruebe que el equipo en el que va a generar el paquete y los equipos donde se instalará cumplen los requisitos de hardware y de software.
  • Determine los niveles de cifrado para los paquetes del explorador. Para obtener más información acerca del cifrado de Internet Explorer, visite el sitio Web del IEAK.

Elija el método de distribución

Decida cómo distribuirá su paquete personalizado (CD, descarga, red de área local o en discos). Una vez que el Asistente para la personalización de Internet Explorer haya generado el paquete, tendrá que mover los archivos al medio seleccionado. Si genera un paquete descargable, debe moverlo al lugar apropiado de su servidor.

Si decide publicar su paquete del explorador en un servidor de Internet, necesitará la ruta de acceso del servidor y la dirección URL desde la que se descargarán los archivos. Después, cree una carpeta en el servidor Web, como CIE, para publicar todos los archivos y carpetas asociados al explorador personalizado. Por ejemplo, podría crear la ruta de acceso de servidor C:\Inetpub\Wwwroot\ie5\Cie. Si nombreDelEquipo es la raíz virtual de este servidor Web, la dirección URL correspondiente sería http://nombreDelEquipo/Cie/.

Obtenga un certificado digital

Realice los preparativos iniciales para firmar determinados archivos, como los archivos de personalización creados por el Asistente para la personalización de Internet Explorer y los componentes personalizados, en el caso de que vaya a distribuirlos a través de Internet o de una intranet que no esté configurada especialmente. Con las características de seguridad del explorador, se advierte a los usuarios acerca de la descarga de archivos sin firmar o se les impide descargarlos. Las firmas digitales identifican el origen de los programas y garantizan que el código no ha cambiado desde que se firmó.

El Asistente para la personalización de Internet Explorer puede firmar los archivos si dispone de un certificado de publicación emitido por una entidad emisora de certificados. Para preparar los certificados de forma que los utilice el IEAK, puede importarlos en el equipo por medio del Asistente para la importación del Administrador de certificados. Si ha recibido un archivo con la extensión .SPC, puede iniciar el Asistente para la importación del Administrador de certificados si hace doble clic en el archivo .SPC en el Explorador de Windows o en Mi PC.

También puede abrir el Administrador de certificados desde Internet Explorer. Para hacerlo, haga clic en el menú Herramientas, Opciones de Internet, haga clic en la ficha Contenido y, finalmente, en Certificados. Haga clic en Importar para iniciar el Asistente para importación del Administrador de certificados y, después, siga los pasos que se indican en la pantalla.

Decida si desea configurar la Actualización del escritorio de Windows para la organización.

Cree la estructura en el equipo

Nombre de carpeta | Descripción
\CIE | Una raíz principal para todos los archivos generados por el IEAK o a los que el paquete personalizado haga referencia
\CIE\Bitmaps | Archivos de mapas de bits personalizados (archivos gráficos necesarios para el explorador personalizado)

Cree los gráficos apropiados

Tendrá la opción de personalizar los mapas de bits siguientes en el explorador. Coloque los mapas de bits en la carpeta \CIE\Bitmaps antes de ejecutar el Asistente para la personalización de Internet Explorer.

Los fondos y botones personalizados sólo se muestran en equipos con capacidad para mostrar 256 colores (8 bits). En los equipos con capacidad para mostrar 16 colores (4 bits) se muestra un conjunto estándar de botones y mapas de bits de fondo de baja resolución.

  • Un mapa de bits de fondo para la pantalla de ejecución automática del CD-ROM (si crea un paquete en CD-ROM).

    Si piensa distribuir el explorador personalizado en un disco compacto, debe crear mapas de bits como parte de la pantalla inicial del programa de ejecución automática que se muestra una vez que el usuario ha insertado el disco compacto. Para crear este mapa de bits, consulte Crear un mapa de bits para la pantalla de inicio de ejecución automática.

  • Una imagen personalizada para los botones del CD-ROM (si crea un paquete en CD-ROM).
  • Dos mapas de bits personalizados para el Asistente para la instalación de Windows Update (si desea personalizar su apariencia): un mapa de bits de 162 por 312 píxeles para el lado izquierdo de la primera pantalla del asistente y un mapa de bits de 496 por 56 píxeles para la parte superior de las restantes pantallas del asistente.
  • Un mapa de bits personalizado de barra de herramientas (que se muestra como fondo de los botones y menús).
  • Dos imágenes de mapa de bits estáticas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo.
  • Dos imágenes de mapa de bits animadas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo animado.

    Con IEAK se incluyen dos herramientas para ayudarle a crear y obtener vistas previas de los mapas de bits animados personalizados para el explorador. Para obtener información acerca de cómo utilizar estas herramientas, consulte Herramientas para mapas de bits animados.

Para obtener una lista completa de todos los gráficos, consulte Crear gráficos personalizados.

Recopile las direcciones URL de las páginas Principal, Búsqueda y Soporte.

Es conveniente crear una página de soporte que aparecerá si los usuarios tienen problemas al instalar el explorador. Se le pedirán las direcciones URL de esas páginas cuando ejecute el Asistente para la personalización de Internet Explorer.

Planee las estrategias de seguridad y de la actualización del escritorio de Windows

Puede personalizar y controlar muchas opciones de usuario, como la seguridad y la actualización del escritorio de Windows. Debe diseñar su estrategia antes de ejecutar el Asistente para la personalización de Internet Explorer.

Notas

  • Para obtener más información acerca del programa de instalación, consulte Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


Administrador corporativo. Paso 1 del asistente: recopilar información

Imagen de título
Administrador
corporativo

Paso 1 del asistente: recopilar información

En este paso del Asistente para la personalización de Internet Explorer, los administradores corporativos deben proporcionar la información siguiente:

  • Nombre de su organización y código de personalización de diez dígitos. El código de personalización está incluido con el resto de información del kit que recibió de Microsoft.
  • Su función, que depende del contrato de licencia. Debe especificar si se trata de un programador o proveedor de contenido, un proveedor de servicios o un administrador corporativo.
  • La ubicación de los archivos necesarios para crear el paquete personalizado del explorador.
  • El idioma del paquete del explorador que está creando. Necesitará ejecutar el Asistente para la personalización para cada versión internacional que desee crear.
  • El medio de distribución que piense utilizar, como CD-ROM o la descarga desde Internet o una intranet.
  • Las características que piensa personalizar. Por ejemplo, si sólo va a hacer pequeñas modificaciones al explorador, no tendrá que pasar por todas las pantallas del Asistente para IEAK.

Nota

  • El Asistente para la personalización no funcionará correctamente si no está instalado Internet Explorer 5.5. Para obtener más información, consulte Requisitos de hardware y del sistema.


Administrador corporativo. Paso 2 del asistente: especificar los parámetros de instalación

Imagen de título
Administrador
corporativo

Paso 2 del asistente: especificar los parámetros de instalación

En este paso del Asistente para la personalización de Internet Explorer, los administradores corporativos deben:

  • Descargar o actualizar componentes de Microsoft mediante el sistema automático de sincronización de versiones. Debe descargar Internet Explorer, pero puede elegir los demás componentes de Internet Explorer que descargará.
  • Seleccionar los componentes personalizados que desea incluir.

    También puede especificar hasta diez componentes adicionales, que pueden ser archivos ejecutables autoextraíbles (.EXE) o archivos contenedores (.CAB) comprimidos.


Administrador corporativo. Paso 3 del asistente: personalizar la instalación

Imagen de título
Administrador
corporativo

Paso 3 del asistente: personalizar la instalación

En este paso del Asistente para la personalización de Internet Explorer, los administradores corporativos pueden determinar cuál será la apariencia y funcionamiento de la instalación de Windows Update:

  • Personalice la pantalla de ejecución automática del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice otras opciones del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice el Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet. Estas opciones de configuración afectan a la apariencia del programa de instalación.
  • Determine si desea instalar el paquete personalizado "silenciosamente", con pocos o ningún aviso al usuario.
  • Especifique hasta diez opciones de instalación y determine los componentes que incluirá en cada opción.
  • Especifique hasta diez sitios desde los que se podrá descargar el paquete. Puede especificar hasta diez sitios, a menos que sea administrador corporativo y realice una instalación silenciosa.
  • Especifique de qué forma recibirán los usuarios las actualizaciones de los componentes.
  • Especifique dónde desea que se instale Internet Explorer en los equipos de los usuarios y si éstos pueden cambiar la ubicación de la instalación.
  • Determine si los usuarios pueden personalizar el programa de instalación, si se debe instalar o no la información de desinstalación, si se puede instalar Internet Explorer junto con una versión anterior del programa y si Internet Explorer es el explorador predeterminado.
  • Especifique si la instalación de Windows Update debe detectar si existe un componente dado y determinar con precisión qué componentes pueden personalizar los usuarios.
  • Determine si los componentes que se han descargado pero no se han incluido en todos los paquetes deben ponerse a disposición de los usuarios por medio de la característica de instalación a petición de Internet Explorer.
  • Especifique si desea integrar la funcionalidad del explorador de Web en el escritorio y las carpetas. Esta funcionalidad ya está integrada en Windows 98.
  • Especifique los datos de la entidad emisora de certificados para que, si tiene un certificado digital, pueda firmar los programas al crear el paquete IEAK.

Notas

  • Para obtener más información acerca del programa de instalación, consulte Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.
  • Si desea ver un organigrama de lo que ocurre al usar el Asistente para la personalización de Internet Explorer con el fin de crear un paquete personalizado, consulte Cómo genera el IEAK paquetes personalizados.


Administrador corporativo. Paso 4 del asistente: personalizar el explorador

Imagen de título
Administrador
corporativo

Paso 4 del asistente: personalizar el explorador

En este paso del Asistente para la personalización de Internet Explorer, los administradores corporativos pueden personalizar lo siguiente:

  • El mapa de bits de fondo de la barra de herramientas y la barra de título del explorador. Cuando seleccione un mapa de bits, asegúrese de que los colores contrastan con el texto.
  • Los botones de la barra de herramientas del explorador. Puede agregar botones personalizados a la barra de herramientas para ejecutar secuencias de comandos y programas.
  • El logotipo de Internet Explorer de la esquina superior derecha del explorador.
  • Las páginas principal, de búsqueda y de soporte en línea del explorador.
  • Favoritos, carpetas de Favoritos y vínculos de la barra de vínculos.
  • Los canales que permiten a los usuarios recibir contenido actualizado automáticamente.
  • La página de bienvenida, que aparece cuando el usuario inicia el explorador por primera vez.
  • Personalización de Active Desktop, en el caso de que esté instalando también la Actualización del escritorio de Windows. Para que aparezca esta pantalla debe haber instalado previamente Active Desktop en el equipo.
  • Configuración de la barra de herramientas del escritorio. Puede importar la configuración de la barra de herramientas del escritorio de su propio equipo como barra de herramientas estándar de su organización. Para que aparezca esta pantalla debe haber instalado previamente Active Desktop en el equipo.
  • Mi PC y el Panel de control, mediante la especificación de sus propios archivos Mycomp.htt y Controlp.htt, en el caso de que esté instalando también la Actualización del escritorio de Windows. Para que aparezca esta pantalla debe haber instalado previamente Active Desktop en el equipo.
  • Una cadena agente de usuario. El identificador del agente de usuario es opcional; es una forma de realizar un seguimiento del uso de su explorador personalizado.
  • La configuración de la conexión del usuario, mediante la personalización, importación o eliminación de la configuración existente.
  • Configuración automática. Puede proporcionar la ruta de acceso de los archivos con los que se configura automáticamente el explorador.
  • Configuración de proxy.
  • Configuración de los certificados de seguridad y de Authenticode.
  • Configuración de las zonas de seguridad y de las clasificaciones.

Notas

  • Para obtener más información acerca del programa de instalación, consulte Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


Administrador corporativo. Paso 5 del asistente: personalizar componentes

Imagen de título
Administrador
corporativo

Paso 5 del asistente: personalizar componentes

En este paso del Asistente para la personalización de Internet Explorer, los administradores corporativos pueden personalizar lo siguiente:

  • La configuración predeterminada del programa, como los programas específicos que se utilizarán para leer correo electrónico o modificar HTML.
  • Los servidores de correo y noticias de los usuarios, si va a incluir Outlook Express en el paquete personalizado.
  • La configuración del servidor de correo electrónico IMAP para los usuarios, en el caso de que vaya a distribuir Outlook Express y tenga un servidor IMAP.
  • El contenido personalizado de Outlook Express, al agregar su propio mensaje de correo electrónico para dar la bienvenida a los usuarios y personalizar el panel de información que aparece cuando los usuarios inician el programa.
  • La configuración personalizada de Outlook Express, por ejemplo, con la definición de clientes nuevos predeterminados de correo y de noticias, el suministro de ayuda a los usuarios que necesitan disponer de cuentas de correo adicionales y la creación de un archivo de reglas predeterminadas para los mensajes de los usuarios.
  • La configuración de la interfaz de usuario de Outlook Express, como decidir si se muestran la barra de carpetas, la lista de carpetas, los contactos de MSN Messenger, la barra de estado o la barra de Outlook.
  • La configuración de redacción de Outlook Express, si desea definir una renuncia de responsabilidad corporativa o firma para incluirlas en los mensajes de correo electrónico o de grupos de noticias.
  • El servicio de directorio de la Libreta de direcciones de Windows, si desea ofrecer servicios de directorio de Internet a los usuarios y personalizar los servidores de Protocolo compacto de acceso a directorios (LDAP, Lightweight Directory Access Protocol).
  • La marca de MSN Messenger Service, si está incluyendo una instalación personalizada del cliente del servicio de mensajería en el paquete.
  • Los elementos multimedia de MSN Messenger Service, si desea cambiar los gráficos, el contenido promocional o los sonidos utilizados en la instalación personalizada del cliente del servicio de mensajería.
  • La información de cuenta de MSN Messenger Service, si desea cambiar las opciones predeterminadas de la cuenta Passport y la configuración de la integración de correo electrónico en una instalación personalizada del cliente del servicio de mensajería.
  • Las directivas y configuración del sistema, para predefinir o controlar la configuración, incluidas las opciones relacionadas con el explorador, el correo electrónico, la seguridad y el escritorio.
  • La elección de determinadas directivas del sistema y restricciones, dependiendo del sistema operativo que ejecuten los usuarios. Si utilizan Windows NT o Windows 2000, algunas directivas y restricciones deben administrarse mediante el Editor de directivas de Windows NT o el Editor de directivas de Windows 2000, respectivamente, en lugar del Asistente para la personalización del IEAK o el Administrador de perfiles del IEAK.


Administrador corporativo. Distribuir su paquete del explorador

Imagen de título
Administrador
corporativo

Distribuir su paquete del explorador

De forma predeterminada, el Asistente para la personalización de Internet Explorer crea archivos para descargar desde Internet. También puede distribuir un paquete de explorador personalizado en un CD-ROM. Para obtener una lista completa de todos los medios de distribución, consulte Selección del medio.

Archivos descargables

Si creó el paquete del explorador en un servidor de Internet o de una intranet, tiene que configurar su sitio Web para que los usuarios puedan descargar los archivos. Por ejemplo, podría crear una página en la que publicara la información de descarga y un vínculo al motor de instalación, IE5setup.exe.

Si creó el paquete del explorador en un disco duro o en una unidad de red, deberá mover los elementos siguientes a un servidor de Internet o de la intranet:

  • La carpeta que contiene la versión del idioma que está publicando y los contenidos de la carpeta. Por ejemplo, la carpeta de la versión en inglés se llama En, por lo que debe mover la carpeta En y los archivos que contiene. Esta carpeta estará en las carpetas que correspondan al tipo de distribución, por ejemplo, Download (descarga), y plataforma. La única designación de plataforma del Internet Explorer Administrative Kit 5.5 es "Win32"; para clientes UNIX y Windows de 16 bits, use Internet Explorer Administrative Kit 5.0x.
  • El archivo denominado Ie5sites.dat. Este archivo señala el sitio de descarga o sitios especificados al ejecutar el Asistente para la personalización de Internet Explorer.

Los usuarios instalan el explorador al hacer clic en IE5setup.exe. Este archivo se encuentra en la carpeta de la versión en su idioma y plataforma dentro de la carpeta \Download, por ejemplo, la versión en inglés se almacena en \Download\Win32\En o en \Download\Win16\En.

Para ver un ejemplo, consulte Cómo configurar los archivos para distribución.

Para ver un organigrama de los archivos que crea Asistente para la personalización de Internet Explorer, consulte Cómo genera el IEAK paquetes personalizados.

Firmar los paquetes personalizados

Los exploradores Web tienen características de seguridad que ayudan a proteger a los usuarios frente a la descarga de programas perjudiciales. En función del nivel de seguridad y del sistema operativo, se puede advertir al usuario o evitar que descargue programas que no estén firmados digitalmente.

Los archivos personalizados .CAB creados con el Asistente para la personalización de Internet Explorer deben estar firmados, a menos que se haya configurado la zona local de la intranet con un nivel bajo de seguridad. Cualquier componente personalizado que distribuya con el paquete del explorador y vaya destinado a esos sistemas operativos también debe estar firmado. Si dispone de un certificado digital, el Asistente para la personalización de Internet Explorer puede firmar automáticamente esos archivos.

Notas

  • La firma de los archivos contenedores (.CAB) y los programas personalizados requiere que se lleven a cabo dos pasos: obtener un certificado digital y especificar los datos del certificado al ejecutar el Asistente para la personalización. Para obtener más información, consulte Firmar sus programas.
  • Es posible que deba cambiar las mayúsculas y minúsculas de los nombres de los archivos publicados en un servidor UNIX de FTP. A continuación se detallan las convenciones que debe usar para sistemas operativos UNIX específicos.
    • UNIX de Solaris
      Si está utilizando un servidor FTP de UNIX que distingue mayúsculas y minúsculas, debe asegurarse de que la carpeta contenedora no contiene mayúsculas, mientras que los archivos siguientes están en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT.
    • UNIX de AT&T
      Todos los nombres de archivo deben estar en mayúsculas en un servidor FTP de UNIX de AT&T.
    • UNIX de IRIX (Silicon Graphics)
      Los nombres de archivo siguientes deben estar en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT. Debe usar un procesador de textos a fin de modificar los nombres de archivos enumerados en IE.CIF para que la utilización de mayúsculas coincida con la de los archivos.

CD-ROM

Si distribuye el explorador personalizado para usuarios de Windows 95 o Windows 98, aparecerá una pantalla inicial del programa de ejecución automática cuando el usuario inserte el disco compacto. Este programa ofrece a los usuarios la posibilidad de instalar el explorador personalizado o ver más información. Si ya está instalada la versión actual de Internet Explorer, el programa de ejecución automática la detectará. Se mostrará el explorador en lo que se conoce como modo a pantalla completa con el archivo Start.htm cargado.

Con el Asistente para la instalación de Windows Update puede publicar todos los archivos en un servidor de intranet o Internet. También puede crear versiones en CD-ROM para los usuarios que inicialmente no tengan acceso a Internet.

Para obtener más información

Para obtener información más detallada acerca de la instalación de Windows Update, consulte Instalación de Windows Update para Internet Explorer y otras herramientas para Internet. El proceso de descarga se muestra en el diagrama Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.


Administrador corporativo. Cómo distribuir su cliente del servicio de mensajería

Imagen de título
Administrador
corporativo

Cómo distribuir su cliente del servicio de mensajería

Si ha incluido MSN Messenger Service como una opción de instalación , el Asistente para la personalización de Internet Explorer crea un paquete independiente para descargar el cliente del servicio de mensajería personalizado desde Internet o un servidor de intranet.

Archivos descargables

Si creó el paquete del cliente del servicio de mensajería en un servidor de Internet o de una intranet, asegúrese de configurar su sitio Web para que los usuarios puedan descargar los archivos. Por ejemplo, puede crear una página en la que se publique la información de descarga y un vínculo al archivo de instalación (mmssetup.exe) para el cliente del servicio de mensajería.

Si creó el archivo mmssetup.exe en un disco duro o en una unidad de red, deberá moverlo a un servidor de Internet o de la intranet para cada versión de idioma que esté publicando. Cada versión de idioma crea una subcarpeta en la carpeta Messenger del directorio de la compilación. Por ejemplo, la versión de la compilación en inglés de mmssetup.exe se encuentra en la carpeta En. Si ha especificado una dirección URL de descarga durante la personalización, cree un vínculo dentro de la página de la dirección URL de descarga que señale a mmssetup.exe. Todos los componentes necesarios para distribuir un cliente del servicio de mensajería personalizado se incluyen en este archivo ejecutable.

Firmar la instalación del cliente del servicio de mensajería

Si incluyó un certificado digital para firmar el paquete del explorador cuando ejecutó el Asistente para IEAK, se utilizará el mismo certificado para firmar el programa de instalación mmssetup.exe. Para obtener más información, consulte Firmas digitales y Firmar sus programas.

El cliente del servicio de mensajería como parte del paquete del explorador

El cliente del servicio de mensajería personalizado también se instalará como parte del paquete del explorador, siempre y cuando haya especificado que MSN Messenger Service se incluya en las opciones de instalación. Se crea un paquete .CAB distinto para el cliente del servicio de mensajería personalizado, que se incluirá como componente al ejecutar ie5setup.exe. Consulte Distribuir su paquete del explorador para obtener más información acerca de cómo distribuir todo el paquete del explorador.

Clientes de servicio de mensajería y servidores de seguridad

Si necesita especificar opciones de proxy avanzadas para servicios de mensajería que están detrás de un servidor de seguridad, no indique una dirección URL de descarga. Además, deberá modificar el texto para generar un archivo de instalación que configurará previamente las opciones de proxy. Consulte Personalización avanzada de un cliente de mensajería para obtener más detalles.


Administrar la configuración de usuario

Una vez establecidas las opciones de los usuarios y distribuido el explorador, los administradores todavía pueden administrar estas opciones. Si almacenan un archivo .INS maestro en el servidor y lo descargan en cada inicio de sesión, los administradores pueden ajustar la configuración de las opciones de los usuarios de forma continua. Si escriben en los archivos de comandos de inicio de sesión existentes, los administradores pueden administrar y actualizar periódicamente las configuraciones de usuarios desde un servidor central.

Por medio del Administrador de perfiles de IEAK, puede administrar fácilmente los archivos de configuración. El Administrador de perfiles de IEAK permite abrir cualquier archivo .INS y realizar cambios en la configuración, por ejemplo, en la información del Protocolo compacto de acceso a directorios (LDAP), la barra de búsqueda, la página principal y proxy.

En sistemas que ejecuten Windows 2000, también puede usar la opción Directiva de grupo para administrar algunas opciones de usuario.

Una vez realizada la instalación, los administradores pueden administrar de forma remota todos los certificados de compañías (y de sitios) permitidos al agregar o quitar certificados de la lista de certificados permitidos.


Cómo utilizar el Administrador de perfiles de IEAK

Antes de instalar Internet Explorer, puede utilizar el Asistente para la personalización de Internet Explorer con el fin de configurar previamente los paquetes personalizados e incluir las características Configuración automática del explorador y Detección automática. Con estas características, los equipos de los usuarios pueden localizar automáticamente el archivo .INS de configuración automática (mantenido en el servidor) y utilizarlo para actualizar las opciones de configuración del explorador en intervalos de tiempo especificados.

Una vez que haya instalado Internet Explorer, podrá utilizar el Administrador de perfiles de IEAK para mantener las opciones de configuración del explorador en los equipos de los usuarios. Con el Administrador de perfiles de IEAK, puede abrir cualquier archivo .INS de configuración automática y cambiar los valores de configuración, por ejemplo, las opciones de firma digital y zona de seguridad.

También puede utilizar el Administrador de perfiles de IEAK para habilitar la configuración automática del explorador si no configuró previamente esta característica antes de la instalación. La característica Detección automática (si está habilitada) localizará el archivo .INS actualizado; también puede definirse manualmente la configuración automática del explorador en los equipos cliente.

Si es administrador de una empresa, el Administrador de perfiles de IEAK le puede ayudar a mantener las versiones de Internet Explorer ya que proporciona un acceso rápido y sencillo a la configuración del sistema desde una ubicación central. Para utilizar la configuración automática debe crear un perfil compuesto por un archivo .INS y todos los archivos contenedor (.CAB) generados por el Administrador de perfiles. El perfil contiene información que se utiliza para configurar los exploradores de los usuarios. Una vez que haya creado el perfil, deberá colocarlo en un servidor.

Cuando ejecute el Asistente para la personalización de Internet Explorer, escriba la ruta de acceso del servidor correspondiente al archivo .INS. Si necesita cambiar la configuración del usuario posteriormente, únicamente deberá modificar el archivo .INS. La próxima vez que los usuarios inicien el explorador (o de acuerdo con una programación especifica) los cambios se reflejarán en todos los equipos.

Para obtener más información acerca de cómo establecer la configuración automática del explorador, consulte Descripción de la configuración y restricciones.

Actualizar las opciones de configuración del explorador

El Asistente para la personalización de Internet Explorer crea un archivo de configuración automática .INS para cada paquete personalizado que se genere. El nombre predeterminado de este archivo es Install.ins, pero puede cambiarlo en cada paquete.

Una vez que haya instalado el explorador, podrá utilizar el Administrador de perfiles de IEAK para actualizar las opciones de configuración; para ello, abra el archivo .INS de configuración automática, modifíquelo y, después, guárdelo. El Administrador de perfiles de IEAK también mantendrá actualizados los archivos de complemento cada vez que guarde el archivo .INS.

Es posible cambiar dos tipos de opciones de configuración:

  • La configuración del asistente

    Esta configuración corresponde a las opciones del explorador y el componente configuradas inicialmente en los pasos del 2 al 5 del Asistente para la personalización de Internet Explorer.

  • Directivas y restricciones

    Esta configuración corresponde a las opciones configuradas inicialmente en la pantalla Directivas y restricciones durante el paso 5 del Asistente para la personalización de Internet Explorer.

Administrar la configuración automática

Puede usar una dirección URL de configuración automática para que los exploradores de los usuarios señalen automáticamente el Administrador de perfiles de IEAK. Puede especificar el archivo .INS o bien crear y especificar el archivo de Página Active Server (.ASP) que genera un archivo .INS automáticamente.

También puede especificar archivos de comandos con formato .JS, .JVS o .PAC que le permiten establecer y mantener la configuración de proxy avanzada. Si especifica direcciones URL para la configuración automática y para el proxy automático (auto-proxy), se incorporará la dirección URL de auto-proxy al archivo .INS. La forma correcta de la dirección URL es http://share/test.ins.

Para habilitar la configuración automática

  1. Active la casilla de verificación Habilitar la configuración automática.
  2. En Dirección URL de Configuración automática (archivo .INS), escriba la dirección URL para el archivo .INS o .ASP que desee.
  3. En Direcciones URL de Auto-proxy (archivos .JS, .JVS o .PAC), escriba la dirección URL para la secuencia de comandos de auto-proxy.

Para ejecutar el Administrador de perfiles de IEAK

  1. En el menú Inicio, seleccione Programas, Microsoft IEAK y, finalmente, haga clic en Administrador de perfiles de IEAK.
  2. En el menú Archivo, haga clic en Abrir y abra el archivo .INS que desea modificar, o bien haga clic en Nuevo para crear un nuevo archivo.

    Para trabajar con los archivos de directivas de un sistema operativo distinto, haga clic en la opción que desee en el menú Plataforma.

  3. Para modificar la configuración, haga clic en Configuración del Asistente o en Directivas de sistema y restricciones para mostrar las categorías de configuración.
  4. En la parte izquierda, haga clic en cada categoría que desee cambiar y, en la parte derecha, cambie las opciones que desee.
  5. En el menú Archivo, haga clic en Guardar.

    Escriba la ruta de acceso de su archivo .INS, la dirección URL de sus archivos .CAB y los nombres de sus archivos .CAB, en caso de que no coincidan con los valores predeterminados proporcionados.

La ubicación predeterminada para guardar el archivo de configuración automática .INS es la carpeta
\directorio de versión\Ins\sistema operativo\idioma. Por ejemplo, una versión española del archivo .INS creada para la plataforma de Windows de 32 bits se guardaría en la carpeta \Versión1\Ins\Win32\Es.

Para poder actualizar las opciones de configuración en los equipos de los usuarios, debe copiar el archivo de configuración automática .INS y los archivos .CAB de complemento generados por el Administrador de perfiles de IEAK en un directorio de trabajo y probar la configuración. Tras haber validado los cambios, copie el nuevo archivo de configuración automática .INS en el servidor de producción. A continuación, la característica de configuración automática del explorador actualizará las opciones de configuración en los equipos de los usuarios.

Notas

  • Si no cambia el número de versión del archivo .INS, no se descargarán los nuevos archivos .CAB. El número de versión consta de la fecha en la que se modificó en archivo .INS y el número de veces que se ha revisado.
  • Si conoce los archivos .ADM, use las directivas y restricciones que haya configurado en sus propios archivos .ADM. Para ello, haga clic en Directiva y, después, en Importar.
  • Si está usando la configuración automática y tiene instalados Internet Explorer 5 (o posteriores) e Internet Explorer 4.0 con el mismo archivo de configuración automática, algunos valores que difieren entre las versiones no serán configurados en Internet Explorer 4.0.

Archivos generados por el Administrador de perfiles de IEAK

Al actualizar y guardar las opciones de configuración, el Administrador de perfiles de IEAK genera los archivos siguientes:

Tipo de archivo | Función
Archivo de configuración automática .INS | Contiene la configuración del explorador y de los componentes que Internet Explorer usa para actualizar la configuración del explorador en los equipos de los usuarios. Puede especificar estas opciones en la sección Configuración del asistente en el Administrador de perfiles de IEAK.
Archivos contenedor (.CAB) | Se utilizan para organizar los archivos de instalación que se descargan en los equipos de los usuarios. Debe firmar digitalmente los archivos .CAB creados por el Administrador de perfiles de IEAK. Para obtener más información acerca de cómo firmar los archivos .CAB, consulte Firmar sus programas. Los archivos de configuración automática .CAB también contienen archivos de información (.INF).
Archivos de información (.INF) | Contienen las directivas del sistema y restricciones que el sistema operativo usa para actualizar la configuración del sistema en los equipos de los usuarios. Puede especificar estas opciones en la sección Directivas y restricciones del Administrador de perfiles de IEAK. Todos los archivos .INF también contienen información acerca de la versión. Al cambiar las opciones de configuración, el Administrador de perfiles de IEAK actualiza los archivos .INF afectados y su información de versión y vuelve a empaquetar los archivos .CAB de complemento.

Internet Explorer descarga y procesa el contenido del archivo de configuración automática .INF y lleva a cabo los cambios necesarios en los equipos de los usuarios. Además, descarga y desempaqueta los archivos .CAB de complemento para que el sistema operativo los procese. Si no cambia el número de versión del archivo de configuración automática .INS, no se descargarán los nuevos archivos .CAB. El número de versión consta de la fecha en la que se modificó en archivo .INS y el número de veces que se ha revisado.

Puede ver un ejemplo del proceso de configuración automática en Cómo funciona la configuración automática.

Crear configuraciones únicas para distintos grupos de usuarios

Si los usuarios tienen necesidades diferentes o si desea cambiar las opciones de configuración de determinados usuarios independientemente, puede crear varios archivos de configuración automática .INS. Puede utilizar el Administrador de perfiles de IEAK para especificar distintas opciones de configuración para cada grupo y guardarlas como archivos grupoDeUsuarios.ins, donde grupoDeUsuarios es el nombre único de cada grupo de usuarios. El Administrador de perfiles de IEAK genera automáticamente los archivos .CAB de complemento. Por ejemplo, podría especificar una configuración única para el departamento financiero y guardarla como Finanzas.ins. Después, el Administrador de perfiles de IEAK generaría los archivos .CAB necesarios.

Nota

  • Si crea varios archivos de configuración automática .INS, asegúrese de que los paquetes personalizados estén configurados para usar el archivo correcto. También puede utilizar una solución automatizada de servidor que le permita emplear varios archivos .INS sin que sea necesario volver a generar los paquetes personalizados.

Usar plantillas de directiva personalizadas

El Administrador de perfiles de IEAK usa un conjunto predeterminado de plantillas de directiva de Windows, o archivos de administración (.ADM), para definir las reglas de las directivas del sistema y las restricciones. Los archivos .ADM y las directivas y restricciones del sistema son características estándar de las plataformas Windows de 32 y 16 bits. Si está familiarizado con los archivos .ADM, podrá crear plantillas propias para definir restricciones adicionales. Para obtener más información, consulte la documentación de Windows.

Por medio del Administrador de perfiles de IEAK, puede importar sus propios archivos .ADM personalizados e incluirlos con las opciones de configuración actualizadas. El Administrador de perfiles de IEAK genera un archivo .INS asociado en el que se utiliza el prefijo de archivo correspondiente al archivo .ADM personalizado que se importa. Por ejemplo, si importa un archivo llamado Custom.adm, se genera un archivo Custom.inf que se agrega a los archivos .CAB de complemento. Para obtener más información acerca de cómo usar archivos .ADM personalizados, consulte Descripción de la configuración y restricciones.

Cambiar la ubicación del archivo de configuración automática .INS

Si tiene que mover el archivo .INS a un servidor de producción diferente, puede utilizar el Administrador de perfiles de IEAK para actualizar la dirección URL correspondiente a la configuración automática del explorador. En caso de que haya definido el archivo .INS de modo que se actualice en un intervalo de tiempo específico, después de actualizar la dirección URL para la configuración automática del explorador, deberá permitir que transcurran dos intervalos para que el cambio surta efecto.

Para actualizar la dirección URL correspondiente a la configuración automática del explorador

  1. En el menú Inicio, seleccione Programas, Microsoft IEAK y, finalmente, haga clic en Administrador de perfiles de IEAK.
  2. En el menú Archivo, haga clic en Abrir y abra el archivo de configuración automática .INS del paquete personalizado.
  3. En Configuración del asistente, haga clic en Configuración automática del explorador.
  4. En el cuadro Dirección URL de Configuración automática (archivo .INS), escriba la nueva ruta de acceso del servidor.
  5. En el menú Archivo, haga clic en Guardar como. Escriba el nombre del archivo manteniendo su extensión.
  6. Escriba la nueva ubicación del archivo .INS de modo que coincida con la dirección URL que escribió, la dirección URL de los archivos .CAB y los nombres de los archivos .CAB.

    Debe copiar todos los archivos .CAB creados en la carpeta de versión en la misma carpeta que contiene el archivo .INS.

Cuando el usuario inicie el explorador y la actualización de las opciones de configuración esté programada, el puntero a la dirección URL correspondiente a la configuración automática del explorador se actualizará en el equipo del usuario. En este momento, el explorador continúa utilizando las opciones de configuración del archivo .INS original (por ejemplo, http://ruta existente/Default.ins).

Cuando el usuario inicie el explorador por segunda vez y la actualización de las opciones de configuración vuelva a programarse, el explorador leerá el nuevo archivo de configuración automática .INS (por ejemplo, http://nueva ruta/Default.ins). Cuando esté seguro de que la configuración de todos los equipos de los usuarios se ha actualizado, elimine la copia del archivo .INS de su ubicación original.

Usar el Administrador de perfiles para administrar los sistemas Windows 2000

Si utiliza la instalación desatendida para distribuir Internet Explorer en Windows 2000, puede emplear el Administrador de perfiles de IEAK para especificar la configuración personalizada de Internet Explorer. Esta configuración se definirá cuando se ejecute la instalación desatendida. Mediante el Administrador de perfiles es posible crear archivos .INS y, si es necesario, archivos contenedor (.CAB). El archivo .INS se especifica en la sección [Branding] del archivo Unattend.txt. Para obtener más información, consulte la documentación del programa de instalación de Windows 2000.

Para especificar Windows 2000 como plataforma, haga clic en el menú Plataforma y, después, haga clic en Windows 2000. En Configuración del asistente, haga clic en los elementos que desea personalizar.

Las restricciones, que determinan qué opciones pueden cambiar los usuarios, no están disponibles para la plataforma Windows 2000 en el Administrador de perfiles de IEAK. Para definir restricciones en la plataforma Windows 2000, use las directivas de grupo. Para obtener más información, busque "Directiva de grupo" en la Ayuda de Windows 2000.

Las opciones de los certificados digitales no están disponibles para Windows 2000 en el Administrador de perfiles de IEAK, ya que Windows 2000 incluye características avanzadas de administración de certificados. Para obtener más información, busque "certificados digitales" en la Ayuda de Windows 2000.


Referencias del IEAK

Para obtener información general acerca del IEAK, consulte los temas siguientes:

  • Administrar Microsoft Internet Explorer en Windows 2000
  • Marcas y gráficos personalizados
  • Seguridad de Internet Explorer
  • Personalización del cliente del servicio de mensajería
  • Redistribuir Internet Explorer
  • Ejecutar la instalación por lotes
  • Actualizar periódicamente a los usuarios
  • Instalación de Windows Update para Internet Explorer y otras herramientas para Internet
  • Trabajar con archivos de información para la instalación (.INF)
  • Tipos de archivo
  • Configurar la búsqueda automática
  • Personalizar la barra y el ayudante de búsqueda

Recursos adicionales

Para examinar los últimos recursos y actualizaciones para la tecnología, visite los sitios Web siguientes:

  • El sitio Web IEAK
  • El sitio Web de Microsoft Security Advisor
  • MSDN Online Web Workshop
  • El sitio Web Corporate Windows Update


Configurar la búsqueda automática

Puede personalizar la búsqueda automática para que los usuarios escriban una palabra familiar en el cuadro Dirección y puedan buscar en las páginas usadas con más frecuencia en Internet Explorer. Los usuarios no necesitarán recordar las direcciones URL de las páginas que especifique, por lo que la información clave será más fácil de encontrar.

Por ejemplo, podría configurar una página Web de facturación de modo que aparezca cuando un usuario escriba factura en el cuadro Dirección, aunque la dirección URL de la página no incluya dicho término. Si es administrador corporativo, el tema siguiente le muestra cómo puede personalizar la búsqueda automática. Si es proveedor de contenido Internet o proveedor de servicios Internet, envíe un mensaje de correo electrónico a autosrch@microsoft.com para obtener más información.

Esta característica ya está habilitada para Internet. Por ejemplo, al escribir términos muy utilizados e inconfundibles en el cuadro Dirección, aparecerá el sitio Web asociado con dicho término. Cuando no se puede asociar claramente un sitio Web con un término, por ejemplo, si hay varias coincidencias importantes, se muestra una página Web que presenta los resultados con un mayor grado de coincidencia.

El sitio Web que aparece no tiene que contener, necesariamente, el término exacto que se busca en su dirección URL. Si un sitio Web cuyo dominio coincide con el término no coincide exactamente con el término de la búsqueda (por ejemplo, si éste coincide con la dirección URL sin "www." y ".com"), se redirigirá al usuario al sitio que más se acerque a dicho término. De manera predeterminada, se informa al usuario de que se va producir una redirección.

Para instalar la búsqueda automática

  1. Cree un archivo de comandos (.ASP) que compruebe condicionalmente los términos de la búsqueda y los envíe a un servidor de intranet que se encuentre en la siguiente ubicación:

    http://ieautosearch/response.asp?MT=%1&srch=%2

    Consulte Parametros para configurar la dirección URL de búsqueda automática más abajo para ver una descripción de los parámetros %1 y %2.

    En caso de que no use Internet Information Server (IIS), deberá reasignar esta dirección URL a la dirección donde se encuentra la secuencia de comandos.

  2. Si está configurando esta opción por medio del Asistente para la personalización de Internet Explorer, en la pantalla Directivas y restricciones del paso 5, haga clic en Configuración de Internet.

    O bien

    Si está configurando esta opción en el Administrador de perfiles, haga clic en Directivas y restricciones y, a continuación, haga clic en Configuración de Internet.

  3. Haga clic Configuración avanzada y, a continuación, en Buscando, en el cuadro Palabra clave del proveedor de búsqueda, escriba intranet.

Notas

  • Puede utilizar directivas y restricciones para redirigir a los usuarios a otro sitio en lugar de proporcionar resultados de búsqueda. Para ello, haga clic en Opciones avanzadas. En Buscando, en el cuadro Al buscar desde la barra de direcciones, seleccione Ir al sitio más probable.
  • Si es administrador corporativo en una organización sin acceso a Internet y no va a personalizar la búsqueda, quizás prefiera usar directivas y restricciones para deshabilitar la búsqueda automática. Para ello, haga clic en Opciones avanzadas. En Buscando, en el cuadro Al buscar desde la barra de direcciones, seleccione No buscar nunca desde la barra de direcciones.

Parámetros para configurar la dirección URL de búsqueda automática

Para configurar la dirección URL de búsqueda automática http://ieautosearch/response.asp?MT=%1&srch=%2, reemplace los dos parámetros marcados con el símbolo de porcentaje (%). Ambos valores deben formar parte de la dirección URL.

Parámetro | Valor
%1 | La cadena que el usuario escribe en el cuadro Dirección.
%2 | Tipo de búsqueda elegido por el usuario.
 | 3 | Mostrar los resultados e ir al sitio más probable.
 | 2 | Ir al sitio más probable.
 | 1 | Mostrar los resultados en la ventana principal.
 | 0 | No buscar desde el cuadro Dirección.

Ejemplo de secuencia de comandos de búsqueda automática .ASP

<%@ Language=VBScript %>
<%
    ' la búsqueda mantiene las palabras escritas en la barra Dirección
    ' por el usuario, sin "go" o
    ' "find" ni ningún delimitador como
    ' "+" para espacios.
    ' Si el usuario escribió
    ' "Pastel de manzana," search = "Pastel de manzana."
    ' Si el usuario escribió
    ' "buscar Pastel de manzana," search = "Pastel de manzana."
    search = Request.QueryString("MT")
    search = UCase(search)
    searchOption = Request.QueryString("srch")
    ' Se trata de un sencillo proceso if/then/else
    ' para redirigir el explorador al sitio
    ' que usted elija según lo que el
    ' usuario haya escrito.
    ' Ejemplo: expense report es una página de intranet
    ' que proporciona información acerca de cómo rellenar un informe de gastos
    if (search = "NEW HIRE") then
        Response.Redirect("http://admin/hr/newhireforms.htm")
    elseif (search = "LIBRARY CATALOG") then
        Response.Redirect("http://library/catalog")
    elseif (search = "EXPENSE REPORT") then
        Response.Redirect("http://expense")
    elseif (search = "LUNCH MENU") then
        Response.Redirect("http://cafe/menu/")
    else
        ' Si no hay ninguna coincidencia, use el
        ' servidor de búsqueda automática de IE predeterminado
        Response.Redirect("http://auto.search.msn.com/response.asp?MT="
        + search + "&srch=" + searchOption +
        "&prov=&utf8")
    end if
%>

Para obtener información acerca de otras maneras de personalizar la búsqueda para el usuario, consulte Personalizar la barra y el ayudante de búsqueda.


Personalizar la barra y el ayudante de búsqueda

La barra de búsqueda permite a los usuarios iniciar búsquedas y ver los resultados. Cuando el usuario hace clic en el botón Búsqueda, aparece la barra de búsqueda en una zona a la izquierda del explorador que se denomina barra del explorador.

El Ayudante de búsqueda de Microsoft Windows se abre en la barra de búsqueda y proporciona a los usuarios la sensación de realizar una búsqueda simple y unificada en lugar de diferentes tipos de búsqueda. Incluye botones de opción que permiten a los usuarios especificar el tipo de información que están buscando en lugar del motor de búsqueda que desean usar.

El usuario puede personalizar Internet Explorer de modo que la barra de búsqueda utilice un único motor de búsqueda. Como alternativa, si es proveedor de servicios Internet o administrador corporativo, puede personalizar la barra de búsqueda de modo que satisfaga las necesidades de su organización mediante JScript (compatible con las especificaciones de lenguaje ECMA 262), Visual Basic Scripting Edition (VBScript), controles ActiveX, HTML dinámico, conjuntos de marcos, hojas de estilos en cascada (CSS) y otras tecnologías compatibles con el explorador Internet Explorer. Especifique la dirección URL para la barra de búsqueda en la pantalla Direcciones URL importantes del paso 4 del Asistente para la personalización de Internet Explorer.

Los resultados de la búsqueda suelen aparecer en la barra de búsqueda. Para los usuarios es muy importante poder usar fácilmente los resultados de cualquier servicio de búsqueda. Puede usar la funcionalidad de la barra de búsqueda para almacenar información detallada como resúmenes de texto, direcciones URL o tamaños de archivo. Esta información se muestra en la información sobre herramientas que aparece cuando el puntero del mouse (ratón) pasa sobre un resultado. La información sobre herramientas mantiene la sencillez de la página de resultados, proporcionando al mismo tiempo información más detallada al usuario.

Instrucciones para personalizar la interfaz de usuario de la barra de búsqueda

Puede seguir estas instrucciones cuando vaya a diseñar su propia barra de búsqueda y así asegurar que funciona correctamente dentro de la barra del explorador.

  • Las páginas de resultados siempre deben proporcionar la posibilidad de iniciar una nueva búsqueda, con botones para modificar y ejecutar la búsqueda dentro del 20 por ciento superior del área de contenido.
  • Las páginas deben ajustarse al ancho de 200 píxeles de la barra de búsqueda. Si utiliza tablas u otros elementos de formato HTML, asegúrese de que se ajustan al ancho disponible. De lo contrario, hará que se muestren las barras de desplazamiento horizontales, que quitan espacio al contenido y obligan al usuario a realizar más trabajo. Si desea incluir más resúmenes u otra información sin usar espacio adicional, puede utilizar la información sobre herramientas.
  • Puede usar HTML dinámico, tecnología ActiveX, Java y hojas de estilos en cascada para obtener efectos dinámicos e implementar multimedia. Simplemente recuerde que el espacio para la barra de búsqueda es limitado.
  • El tamaño predeterminado para la barra de búsqueda es de 200 píxeles de ancho y todo el tamaño vertical de la ventana del explorador, que son 430 píxeles. Este área puede incluir anuncios o marcas, así como información de búsqueda, dependiendo de sus requisitos. El usuario puede cambiar el tamaño de esta área.
  • Puesto que la barra de búsqueda es un espacio limitado, debe establecer prioridades en la interfaz de usuario. La regla básica es proporcionar al usuario la mejor información sin crear desorden o confusión visual. Desde el principio al final de la página, la interfaz, normalmente, seguiría este orden:
    • Su marca
    • Campos de consulta de búsqueda que puedan definirse
    • Los resultados de la búsqueda
    • Anuncios u otros servicios
    Se recomienda que coloque los anuncios hacia el final de la página, de forma que los usuarios no tengan que desplazarse más allá de ellos para ver los resultados de la búsqueda.
  • Si la página requiere que el usuario se desplace, asegúrese de que un número sustancial de resultados reales (no resultados visibles) pueden verse de forma inmediata.
  • Los vínculos para los resultados de la búsqueda, o "coincidencias", se muestran normalmente en la barra de resultados. Cuando un usuario hace clic en cualquiera de estos vínculos, la página Web debe aparecer en el área principal del explorador. Evite abrir las páginas Web en la barra de búsqueda, ya que no contiene los botones Atrás y Siguiente.

Técnicas para personalizar el Ayudante de búsqueda

El Ayudante de búsqueda se puede personalizar para que satisfaga necesidades específicas. Por ejemplo, se puede almacenar información adicional acerca de los resultados de la búsqueda dentro de la información sobre herramientas y es posible destacar los resultados de la búsqueda en una página Web determinada.

Destacar coincidencias encontradas

El método NavigateAndFind puede utilizarse para buscar en páginas Web una palabra o frase. Este método carga una página Web especificada y busca en el documento una coincidencia con la cadena suministrada. Si se encuentra, la cadena que coincide se resalta en el documento.

Ejemplo

En el ejemplo siguiente se abre el sitio Web de Microsoft y se buscan las palabras "Microsoft Corporation".

window.external.NavigateAndFind("http://www.microsoft.com","Microsoft Corporation");

Información sobre herramientas y resúmenes de vínculos

Para ayudar a ahorrar espacio en la ventana del explorador y mejorar la legibilidad de los resultados de búsqueda, Internet Explorer permite definir información específica acerca de un vínculo determinado que se debe incluir en la información sobre herramientas. Para ello, defina el atributo TITLE de una etiqueta de marcador de HTML.

Ejemplo

En el ejemplo siguiente se ofrece más información acerca del vínculo:

<A HREF=="http://www.acme-sports.com" TITLE="Las noticias deportivas y clasificaciones más recientes,
actualizadas cada hora. Entrevistas con los jugadores de los equipos ganadores">Últimas noticias deportivas</A>

Señale a este vínculo para ver cómo aparecerían los resultados: Últimas noticias deportivas

Forzar saltos de línea en la información sobre herramientas

La información sobre herramientas introduce líneas nuevas automáticamente a algo más de siete centímetros (tres pulgadas) y puede contener, como mínimo, un párrafo de texto. No obstante, dentro del texto de la información sobre herramientas no se permite más de 1024 caracteres. También puede forzar una nueva línea o espacios de tabulación en el resumen si utiliza los caracteres reservados &#10; y &#13 para retorno de carro y avance de línea, y &#09 para los espacios de tabulación.

Ejemplo

En el ejemplo siguiente se incluye un retorno de carro y un avance de línea después de la línea 1 de la información sobre herramientas:

<A HREF="http://www.microsoft.com"
   TITLE="Texto mostrado en la línea1&#10;&#13;
   Texto mostrado en la línea2&#10
   &#09;Texto mostrado en la línea3&#10;
   &#09;Texto mostrado en la línea4>
Usar varias líneas en la información sobre herramientas</A>

Señale a este vínculo para ver cómo aparecerían los resultados: Usar varias líneas en la información sobre herramientas

Para obtener más información acerca de las secuencias de comandos y HTML dinámico, visite el sitio MSDN Online Web Workshop.

Para obtener información acerca de la característica de búsqueda automática, que permite a los usuarios escribir frases para buscar en la barra de herramientas Dirección, consulte Configurar la búsqueda automática.


Tipos de archivo

Tipo de archivo | Descripción
.adm | Los archivos de administración (.ADM) definen las directivas del sistema y restricciones para el escritorio, shell y la seguridad. Puede personalizar y restringir la configuración en un archivo .ADM mediante Internet Explorer Administration Kit (IEAK) o el Editor de directivas del sistema de Windows. Para ver una lista de las directivas del sistema y restricciones que pueden establecerse desde los archivos .ADM estándar, consulte Cómo utilizar el Administrador de perfiles de IEAK
.asp | Si distribuye Internet Explorer desde un servidor Web, puede incluir archivos de Página Active Server (.ASP) en el paquete del explorador personalizado. Mediante el uso de archivos .ASP, puede incrustar secuencias de comandos en las páginas HTML para crear contenido Web interactivo y dinámico. Por ejemplo, puede crear páginas de suscripción que permitan a los usuarios descargar el explorador y registrarse en los servicios Internet. Puede señalar a los archivos .ASP del Asistente para la personalización de Internet Explorer o el Administrador de perfiles de IEAK. El CD-ROM del kit de recursos incluye archivos .ASP de ejemplo.
.bat | Archivo de texto ASCII que contiene una secuencia de comandos del sistema operativo; a veces incluye parámetros y operadores admitidos por el lenguaje de comandos por lotes. Cuando el usuario escribe el nombre del archivo por lotes en el símbolo del sistema, el equipo procesa los comandos secuencialmente.
.BMP, .GIF, .JPEG, .JPG | Internet Explorer puede incluir gráficos estáticos y animados con formato de archivo .BMP, .GIF, .JPEG o .JPG. Además de utilizar los archivos gráficos suministrados con el IEAK, puede crear gráficos propios e incluirlos con el paquete del explorador personalizado. Por ejemplo, puede reemplazar el logotipo de Internet Explorer o la pantalla inicial del programa de ejecución automática con sus propios archivos gráficos animados o estáticos. El IEAK incluye dos herramientas para ayudarle a crear gráficos animados personalizados. Para obtener más información acerca de los requisitos para los gráficos que personalice, consulte Crear gráficos personalizados.
.cab | Los archivos contenedores organizan y almacenan los archivos de instalación comprimidos que se copian en el equipo del usuario. El programa de instalación de Windows Update (IE5Setup.exe) descarga los archivos .CAB necesarios para la instalación de Internet Explorer en el equipo del usuario. Estos archivos pueden contener el explorador y los componentes personalizados. Una vez que los archivos se han descargado correctamente, la instalación de Windows Update está completa. El IEAK incluye un conjunto de herramientas que pueden ayudarle a crear archivos .CAB para los componentes personalizados.
.cdf | Los archivos de formato de definición de canal (.CDF) permiten usar canales para distribuir contenido Web o actualizaciones de software a los usuarios. El archivo .CDF proporciona un índice de los recursos disponibles en un canal, junto con una programación recomendada para la actualización del canal en los equipos de los usuarios. La suscripción a un canal actualiza la caché local del equipo del usuario con información nueva, de acuerdo con lo especificado por la compañía de software en el archivo .CDF.
.cif | Un archivo de información de componente (.CIF) llamado IESetup.cif identifica los componentes que se pueden instalar con Internet Explorer, incluidos nuevos componentes o actualizaciones. En el archivo .CIF, todos los componentes tienen un IdComponente asociado. El programa de instalación de Windows Update lee el archivo .CIF para determinar si ya se ha instalado un componente con un IdComponente específico y si hay disponible una versión más reciente para la instalación.
.cmp | Los archivos de perfil de conexión (.CMP), creados por el CMAK, contienen información especificada por el usuario. No deben modificarse, ya que los usuarios podrían sobrescribir los cambios realizados.
.cms | Los archivos de proveedor de servicios (.CMS), creados por el CMAK, especifican la configuración de la libreta de teléfonos y la mayor parte del resto de las funciones de los perfiles de servicio. Para realizar la personalización avanzada de un perfil de servicio es necesario modificar el archivo .CMS correspondiente a dicho perfil.
.exe | El archivo ejecutable (.EXE) IE5Setup.exe es el programa que controla el proceso de instalación. Este archivo .EXE descarga los archivos .CAB que instalan el paquete del explorador personalizado en los equipos de los usuarios. A su vez, estos archivos .CAB incluyen archivos ejecutables (*.exe) autoextraíbles adicionales para el explorador y los archivos contenedores.
.htt | Los archivos de plantilla HTML (.HTT) proporcionan plantillas personalizables para Mi PC (Mycomp.htt), Panel de control (Controlp.htt), Impresoras (Printers.htt) y vista Web predeterminada de las carpetas (Folder.htt). Mediante un procesador de texto o HTML, puede personalizar estos archivos con instrucciones especiales, logotipos o vínculos a sitios Web. Puede incluir Mycomp.htt y Controlp.htt en el paquete del explorador personalizado. Las plantillas Printers.htt y Folder.htt deben personalizarse directamente en los equipos de los usuarios.
.inf | Por lo general, todos los archivos .CAB de Internet Explorer contienen un archivo de información asociada (.INF), que proporciona información adicional acerca de la instalación. El archivo .INF puede hacer referencia a archivos que se encuentran en el archivo .CAB, así como a otros archivos de otras direcciones URL.
.ins | El programa de instalación de Windows Update contiene un archivo de configuración de Internet (.INS), que configura el explorador y los componentes asociados. Puede crear varias versiones del paquete del explorador si personaliza varias copias del archivo .INS. El Administrador de perfiles de IEAK también le permite crear, guardar y cargar archivos .INS para actualizar las opciones de configuración de Internet Explorer.
.isp | Si está implementando un proceso de suscripción con el paquete del explorador personalizado, el archivo de suscripción a Internet (.ISP) Signup.isp proporciona la información de acceso telefónico necesaria para los servicios Internet. Mediante el Asistente para la personalización de Internet Explorer, puede modificar los parámetros contenidos en este archivo de suscripción a Internet. Si se utiliza el método de suscripción con servidor, este archivo de suscripción a Internet también contiene un vínculo a la dirección URL de la secuencia de comandos de servidor que genera el archivo de configuración (.INS).
.PAC, .JS, .JVS | Puede usar un procesador de texto para crear un archivo de comandos de proxy automático para el paquete del explorador personalizado. Este archivo puede ser un archivo de configuración de tipo .JScript (.JS), JavaScript (.JVS) o de configuración automática de proxy (.PAC). Al especificar un archivo de comandos de proxy automático, Internet Explorer usa la secuencia de comandos para determinar de forma dinámica si debería conectarse directamente a un host o utilizar un servidor proxy. En el paso 4 del Asistente para la personalización de Internet Explorer, puede especificar una dirección URL de proxy automático para configurar y mantener la configuración avanzada del proxy.
.pdf | Si utiliza Microsoft Systems Management Server para distribuir Internet Explorer, el paquete del explorador personalizado se compone de una carpeta de archivos de instalación y un archivo de definición de paquete (.PDF). Este archivo, llamado IE5.pdf, contiene un programa de instalación, opciones de instalación y la sintaxis de línea de comandos. Estos elementos son necesarios para instalar automáticamente Internet Explorer en el servidor o en los equipos de los usuarios. El archivo .PDF permite que la instalación se lleve a cabo sin la intervención del administrador o el usuario.
.pvk | Archivo de clave privada que contiene la clave privada asociada con una firma digital.
.pwl | Archivo que contiene la contraseña de Windows de un usuario de este equipo.
.sed | Los archivos de perfil de conexión (.SED), generados por el CMAK, contienen las instrucciones necesarias para crear un archivo ejecutable autoextraíble (.EXE) para los perfiles de servicio. Los archivos .SED no deben modificarse.
.spc | Archivo de certificado de publicación de software. Los certificados contienen el nombre y otra información que identifica al propietario del certificado, la clave pública asociada con el mismo, un número de serie, el período de validez y la firma digital de la entidad emisora de certificados que lo concedió.


Crear gráficos personalizados

Antes de preparar los gráficos que se van a utilizar como logotipo, debe consultar el contrato de su licencia para comprobar que puede realizar legalmente la personalización.

Programa de instalación de Windows Update

Gráfico | Tamaño y tipo | Notas adicionales
Vertical izquierdo | Archivo .BMP en 256 colores de 162 por 312 píxeles | El icono vertical aparece en la primera página del Asistente para la instalación de Windows Update.
Superior horizontal | Archivo .BMP en 256 colores de 496 por 56 píxeles | El icono horizontal aparece en todas las páginas del asistente después de la primera página. El título horizontal superior tiene que ser de tonos muy claros, como una "marca de agua", para que sea legible el texto de la interfaz de usuario.

Explorador Internet Explorer

Para ver un ejemplo de la ubicación de los distintos gráficos en el explorador personalizado, consulte Cómo funciona la personalización.

Gráfico | Tamaño y tipo | Notas adicionales
Logotipo estático Archivos .BMP de 38 por 38 píxeles y
22 por 22 píxeles 		Cree dos mapas de bits de 256 colores (38 por 38 píxeles y 22 por 22 píxeles). Guarde los archivos en la carpeta de mapas de bits personalizados (CIE\Bitmaps). Cuando el explorador no esté activo se utilizará como logotipo estático el primer marco del logotipo animado.
Logotipo animado Archivos .BMP de 38 por 38 píxeles y
22 por 22 píxeles para cada marco de la animación 		Para cada marco de la animación, cree dos mapas de bits de 256 colores (38 por 38 píxeles y 22 por 22 píxeles). Guarde los archivos en la carpeta de mapas de bits personalizados (CIE\Bitmaps). Cuando el explorador no esté activo se utilizará como logotipo estático el primer marco del logotipo animado.

Use las Herramientas para mapas de bits animados de IEAK para apilar los mapas de bits en el formato correcto y generar el logotipo animado. El logotipo animado debe contener una pila vertical de imágenes en celdas de animación que cumplan las reglas de animación de Internet Explorer.

Reglas de animación para el logotipo de Internet Explorer

  • Las celdas 1 a 4 son celdas de introducción que se reproducen cuando Internet Explorer comienza a explorar.
  • Las celdas 5 a X, donde X es el número total de celdas, se reproducen en bucle hasta que finaliza la operación.
Fondo de la barra de herramientas | Sin dimensiones específicas | El fondo debe tener el tamaño de la barra de herramientas y ser suficientemente claro para poder mostrar texto en negro.
Botón de la barra de herramientas del explorador | Dos archivos de icono con imágenes en blanco y negro, y en color para los estados activo e inactivo | Para obtener más información, consulte Diseñar iconos de la barra de herramientas para Internet Explorer.
Iconos para la lista Favoritos | Un archivo .BMP de 16 por 16 píxeles para cada elemento que desee personalizar
Pantalla inicial del programa de ejecución automática, si distribuye el paquete personalizado en un CD. | Mapa de bits de 540 por 357 píxeles, mostrado cuando el usuario inserta el CD | Antes de crear la pantalla de inicio, debe convertir las imágenes de 24 bits a la paleta común de 256 colores. Consulte Crear un mapa de bits para la pantalla inicial del programa de ejecución automática para obtener más información.
Canales Para cada canal:
  • un icono de 32 por 32 píxeles
  • un gráfico de 80 por 32 píxeles para la barra de canales
  • un gráfico de 194 por 32 píxeles para el panel de canales
 Los gráficos de 80 por 32 píxeles y 194 por 32 píxeles pueden estar en formato .GIF, .BMP o .JPEG.

Asistente para la conexión a Internet y suscripción a Internet

Gráfico | Tamaño y tipo
Imagen superior que aparece en la esquina superior derecha del Asistente para la conexión a Internet. | archivo .BMP de 49 por 49 píxeles
Imagen vertical que aparece en la esquina superior izquierda de las pantallas del Asistente para la conexión a Internet. | archivo .BMP de 164 por 458 píxeles

Nota

  • El Asistente para la conexión a Internet no está disponible para el método de suscripción sin servidor.

Servicio de directorio de la Libreta de direcciones de Windows (utilizado en Outlook Express)

Tamaño y tipo | Notas adicionales
archivo .BMP de 134 por 38 píxeles | Use la paleta de 16 colores de Windows

Personalización de MSN Messenger Service

Tamaño y tipo | Notas adicionales
archivo .GIF de 234 por 50 píxeles | Use un fondo blanco (valor RGB 255,255,255) y no emplee un canal de transparencia. Use una paleta para exploradores.


Herramientas para mapas de bits animados

Antes de preparar los gráficos que se van a utilizar como logotipo, debe consultar el contrato de su licencia para comprobar que puede realizar legalmente dicha personalización.

Con IEAK se incluyen dos herramientas independientes que le ayudan a crear mapas de bits animados personalizados para el explorador.

  • Animated Bitmap Creator toma una serie de mapas de bits numerados secuencialmente y los combina en un mapa de bits de la forma necesaria para que se puedan animar.
  • Animated Bitmap Previewer permite tener una vista previa del mapa de bits animado. Esta herramienta se puede usar también para presentar cualquier mapa de bits que tenga un formato correcto.

Asegúrese de utilizar el tamaño y formato correctos para los mapas de bits. Para obtener más información, consulte Crear gráficos personalizados.

Nota

  • Estas herramientas se incluyen para ayudar al administrador y no deben distribuirse como productos con soporte de Microsoft. Ambas se encuentran en la carpeta \<carpeta de programa IEAK>\Toolkit\Addons\HTML.

Animated Bitmap Creator (Makebmp.exe)

Para ejecutar esta herramienta, escriba el comando siguiente en el símbolo del sistema MS-DOS:

makebmp nombreBase númArchivos nombreSalida

Elemento de sintaxis | Significado
makebmp | Nombre de la herramienta
nombreBase | Nombre raíz utilizado en todos los archivos (sin números ni la extensión .bmp)
númArchivos | Número de mapas de bits que se agregarán en secuencia al archivo de animación
nombreSalida | Nombre del archivo de salida (debe incluir la extensión de archivo .bmp)

Ejemplo

Para combinar los archivos desde Bitmap0.bmp hasta Bitmap19.bmp, escriba lo siguiente:

makebmp bitmap 20 final.bmp

Nota

  • Numere secuencialmente los archivos a partir de 0. Por ejemplo, Iebmp0.bmp Iebmp1.bmp Iebmp2.bmp … Iebmp24.bmp. El nombre base de estos 25 archivos es Iebmp.

Animated Bitmap Previewer (Animbmp.exe)

Puede iniciar el programa de vista previa desde el símbolo del sistema MS-DOS o desde el Explorador de Windows. Después de iniciar Animbmp.exe, hay dos formas de tener una vista previa de un mapa de bits animado: arrastre el archivo al cuadro o haga clic en el menú Archivo y, después, haga clic en Abrir. Los marcos de introducción sólo aparecen una vez, mientras que los mapas de bits se muestran continuamente y de forma cíclica.


Crear un mapa de bits para la pantalla inicial del programa de ejecución automática

En estas instrucciones se supone que usted parte de archivos de mapa de bits RGB de 24 bits. Si el archivo no es de este tipo, debe convertirlo en primer lugar.

  1. Crear una imagen de mapa de bits de 256 colores (540 por 357 píxeles).

    Este mapa de bits debe proporcionar una introducción al producto y debería incluir etiquetas para dos botones: uno para instalar Internet Explorer y otro para mostrar más información.

  2. En un programa para gráficos, cree un archivo de trabajo para la paleta. Para ello, pegue sus archivos de botones y fondo en un único archivo. Asegúrese de que pega los archivos uno junto a otro.
  3. Guarde el archivo como Palette.bmp.

Nota

  • Las dimensiones del mapa de bits son importantes ya que el cuadro de diálogo cambiará de tamaño para ajustarse a ellas. Si el mapa de bits no es lo suficientemente ancho, el texto del cuadro de diálogo puede aparecer recortado.


Diseñar iconos de barra de herramientas para Internet Explorer

Para crear un icono de barra de herramientas, tendrá que proporcionar cada imagen en dos tamaños distintos para los dos estados de la barra de herramientas (en escala de grises para el estado predeterminado y en color para el estado activo, cuando el mouse (ratón) del usuario lo apunta) y en dos profundidades de color.

Crear sus imágenes

  1. Después de dibujar las imágenes con un programa de gráficos, coloque las imágenes de 16 y 256 colores en dos archivos independientes.
  2. Cada archivo debe tener como índice la paleta correspondiente, ya sea la paleta de 16 colores de Windows o la de medio tono. Reserve un color específico para denotar transparencia.
  3. Guarde cada archivo como un archivo .BMP.

A continuación se incluye un resumen de las imágenes necesarias:

Icono de estado Tamaño en píxeles Profundidad y paleta de colores Borde Apariencia Ejemplo
Activo 20 por 20 Paleta de medio tono de 256 colores de Windows Borde de estilo de icono: color en los bordes superior e izquierdo y color negro en los bordes inferior y derecho
  • Color de imagen
  • Más sombreado y profundidad visual que la imagen de 16 colores
  • Una fuente de luz desde la parte superior izquierda y sombreado donde proceda
 Estado activo: 256 colores (20 por 20 píxeles)
20 por 20 Paleta de 16 colores de Windows Negro, excepto cuando un borde interfiera con la legibilidad del icono
  • Color de imagen
  • Poco sombreado, apariencia plana
 Estado activo: 16 colores, 20 por 20 píxeles
16 por 16 Paleta de 16 colores de Windows Negro, excepto cuando un borde interfiera con la legibilidad del icono
  • Color de imagen
  • Poco sombreado, apariencia plana
 Estado activo: 16 colores, 16 por 16 píxeles
Predeterminado 20 por 20 Paleta de medio tono de 256 colores de Windows Borde de estilo de icono: tonos grises en los bordes superior e izquierdo y color negro en los bordes inferior y derecho
  • Imagen en escala de grises
  • Más sombreado y profundidad visual que la imagen de 16 colores
  • Una fuente de luz desde la parte superior izquierda y sombreado donde proceda
 Estado predeterminado: 256 colores (20 por 20 píxeles)
20 por 20 Paleta de 16 colores de Windows Negro, excepto cuando un borde interfiera con la legibilidad del icono
  • Imagen en escala de grises
  • Poco sombreado, apariencia plana
 Estado predeterminado: 16 colores, 20 por 20 píxeles
16 por 16 Paleta de 16 colores de Windows Negro, excepto cuando un borde interfiera con la legibilidad del icono
  • Imagen en escala de grises
  • Poco sombreado, apariencia plana
 Estado predeterminado: 16 colores, 16 por 16 píxeles

Asegúrese de que las transiciones visuales entre las imágenes predeterminada y activa del icono son suaves. Un sistema fácil para comprobarlo consiste en crear capas separadas para las imágenes predeterminada y activa en un programa de tratamiento de imágenes fotográficas, de forma que pueda ver ambas imágenes superpuestas.

Convertir las imágenes de mapas de bits en iconos

Tendrá que crear dos archivos .ICO para cada icono:

  • El primer archivo .ICO contiene las imágenes activas (en color) para ambos tamaños y profundidades de color.
  • El segundo archivo .ICO contiene las imágenes predeterminadas (en escala de grises) para ambos tamaños y profundidades de color.

Se recomienda utilizar un programa de gráficos para dibujar los iconos y un entorno de desarrollo, como puede ser Microsoft Visual C++ Development Studio, para crear los archivos .ICO.

Ejemplo

Los dos archivos del icono Inicio contienen las siguientes imágenes:

Estado activo | Estado predeterminado
Icono para estado activo | Icono para estado predeterminado

Para crear los archivos de icono en Visual C++

  1. Abra los archivos .BMP.
  2. En el menú Archivo, haga clic en Nuevo y, después, haga clic en Icono. De forma predeterminada, la ventana de icono que se abre muestra una imagen de dispositivo estándar de 32 por 32 píxeles.
  3. En la ventana de icono, haga clic en Nueva imagen de dispositivo. Haga clic en Personalizado y, después, cree estas imágenes:
    • Una imagen de 22 por 20 píxeles en 16 colores
    • Una imagen de 22 por 20 píxeles en 256 colores
    • Una imagen de 18 por 16 píxeles en 16 colores

    Nota

    • Las imágenes de dispositivo son dos píxeles más anchas que las imágenes. Centre sus imágenes en el área de la imagen de dispositivo.
  4. Elimine la imagen de dispositivo de 32 por 32 píxeles.
  5. Copie y pegue las imágenes en color desde los archivos .BMP a la imagen de dispositivo del tamaño y profundidad de color apropiados.
  6. Para hacer el fondo transparente, seleccione el color transparente en la paleta de colores y rellene el fondo de cada imagen en la que desee obtener transparencia.
  7. Guarde el archivo como un archivo .ICO.

Para crear el archivo .ICO predeterminado (en escala de grises), siga los mismos pasos.


Incluir una cadena agente de usuario

Algunas organizaciones realizan un seguimiento de las estadísticas de los sitios, por ejemplo, del número de veces que se tiene acceso a su contenido y con qué tipos de exploradores Web. Las cadenas agentes de usuario le ayudan a identificar el tipo de explorador.

Si recopila estadísticas del explorador y su información incluye la cadena agente de usuario, puede realizar el seguimiento del uso de su explorador personalizado. En el Asistente para la personalización de Internet Explorer, puede agregar caracteres al final de la cadena agente de usuario para personalizarla.

La cadena personalizada aparecerá en las estadísticas que incluyan la cadena agente de usuario. Tenga en cuenta que otras organizaciones que hagan el seguimiento de las estadísticas verán su cadena personalizada. Evite utilizar una cadena que no desee que vean los demás.

Ejemplo

A continuación se muestra un ejemplo de cadena agente de usuario:

Mozilla/4.0(compatible; MSIE 5.5; WindowsNT; SuCadenaPersonalizada)

Nota

El número máximo de caracteres recomendado para la cadena agente de usuario es 200.


Seguridad de Internet Explorer

Internet Explorer le permite controlar la seguridad de varias formas: mediante certificados de sitios, entidades emisoras de certificados Authenticode™ y zonas de seguridad. Puede instalar previamente certificados en los equipos de los usuarios y evitar que éstos descarguen otros certificados. También puede establecer restricciones en el contenido que ven los usuarios.

Los administradores corporativos pueden especificar la configuración de seguridad y las restricciones en los pasos 4 y 5 del Asistente para la personalización de Internet Explorer.

Acerca de las zonas de seguridad

Las opciones de seguridad de Internet Explorer le permiten asignar determinados sitios Web a diversas zonas, en función de la confianza que tenga en el contenido del sitio Web.

Cuando instala Internet Explorer se configuran las siguientes zonas de seguridad:

  • Una zona de Internet que contiene, de forma predeterminada, todos los sitios de Internet
  • Una zona de intranet local para los equipos conectados a una red local
  • Una zona de sitios de confianza, a la que puede asignar los sitios en los que confíe
  • Una zona de sitios restringidos, a la que puede asignar los sitios en los que no confíe
  • Una zona Mi PC, que contiene los archivos del equipo local

A estas zonas se les puede aplicar los cuatro niveles de configuración de seguridad predeterminados siguientes: alto, medio, medio-bajo y bajo. Además, puede definir niveles de seguridad personalizados para cada zona.

Puede ver todas las opciones de configuración de seguridad si hace clic en el icono Internet del Panel de control y, después, hace clic en la ficha Seguridad. Para obtener información específica acerca de estas opciones y de cómo interactúan, consulte Opciones de seguridad de Internet Explorer.

Recuerde que la seguridad en Internet será tan buena como lo sea su configuración. Internet Explorer le proporciona la información necesaria para tomar decisiones correctas en cuanto a la seguridad, así como herramientas flexibles para implementar esas decisiones.

Puede predefinir las opciones de seguridad cuando ejecuta el Asistente para la personalización de Internet Explorer y puede determinar si los usuarios pueden o no cambiar esas opciones. Si no predefine las opciones de seguridad, puede ser aconsejable recomendar el nivel de seguridad óptimo para los usuarios, en función de su experiencia y de las necesidades de la organización.

Notas

  • Si el idioma del paquete del explorador Internet Explorer que está generando difiere del idioma del explorador de su equipo y ha importado las zonas de seguridad, quizás aparezcan algunos caracteres no reconocibles en la interfaz que cree para las zonas de seguridad de los exploradores.
  • Sólo puede configurar la zona Mi PC desde el IEAK; sus opciones de configuración no están disponibles en la interfaz del explorador. Normalmente, se recomienda usar la configuración predeterminada para esta zona a menos que su organización tenga requisitos especiales. Una configuración con un nivel de seguridad menor podría crear riesgos de seguridad, mientras que una configuración de seguridad más estricta podría afectar a la funcionalidad.

Para obtener más información, consulte los temas siguientes:

Configurar la zona de Internet

La zona de Internet está formada por todos los sitios no incluidos en alguna de las otras zonas. De forma predeterminada, la zona de Internet tiene asignado el nivel de seguridad medio. Si le preocupan los problemas de seguridad que se puedan presentar al explorar Internet, puede ser aconsejable que cambie la configuración al nivel alto. Si aumenta el nivel de seguridad, algunas páginas Web no tendrán permiso para realizar operaciones potencialmente peligrosas, si bien esto puede obstaculizar cierta funcionalidad útil y hacer que algunas páginas no funcionen correctamente.

Puede elegir la configuración personalizada para controlar cada decisión individual de seguridad de la zona. Para ello, haga clic en el icono Internet del Panel de control, haga clic en la ficha Seguridad y, finalmente, haga clic en Personalizar nivel.

Agregar sitios a las zonas de sitios de confianza y sitios restringidos

Hay dos zonas a las que puede asignar sitios Web específicos en los que confía más o menos que los de la zona de Internet o la zona de intranet local. Para agregar sitios a estas zonas, elija primero la zona y, después, haga clic en Sitios.

La zona de sitios de confianza tiene asignado de forma predeterminada el nivel de seguridad bajo. Es recomendable para sitios de confianza elevada, como empresas con las que habitualmente mantiene relaciones comerciales, a veces conocidos como una extranet. Si asigna un sitio a la zona de sitios de confianza, el sitio podrá realizar operaciones más eficientes. Además, Internet Explorer le pedirá menos veces que tome decisiones relativas a la seguridad Agregue un sitio a esta zona sólo si confía en que el contenido nunca hará algo peligroso en su equipo. En la zona de sitios de confianza, le recomendamos encarecidamente que utilice el protocolo HTTPS o que se asegure de que las conexiones al sitio sean seguras.

La zona de sitios restringidos tiene asignado de forma predeterminada el nivel de seguridad alto. Si asigna un sitio a la zona de sitios restringidos, el sitio sólo tendrá permiso para realizar un número mínimo de operaciones que sean verdaderamente seguras. Esta zona sirve en el caso poco frecuente de que no confíe en un sitio. Para asegurar un alto grado de seguridad para contenido en el que no se confía, muchas páginas en esta zona no funcionarán correctamente.

Configurar la zona de intranet local (para administradores de red)

Para estar totalmente seguros, se impone configurar la zona de intranet local junto con el servidor proxy y el servidor de seguridad. Todos los sitios de la zona deben estar "dentro del servidor de seguridad" y los servidores proxy deben configurarse de manera que no permitan que se resuelva un nombre DNS externo en esta zona. Configurar la seguridad de la zona del cliente requiere tener un conocimiento detallado de la configuración de la red existente, los servidores proxy y los servidores de seguridad seguros. Si no conoce esta información, póngase en contacto con el administrador de la red.

De forma predeterminada, la zona de intranet local está compuesta por nombres de dominios locales y de los establecidos para suplantar al servidor proxy en la ficha Conexiones. Puede configurar estas opciones en la pantalla Configuración de conexión del Asistente para la personalización de Internet Explorer. Tenga en cuenta que ahora se pueden definir varias configuraciones de conexión para cada usuario. El administrador de la red debe confirmar que la configuración es realmente segura para la instalación o debe ajustarla para que lo sea.

Al configurar la zona puede especificar las categorías de direcciones URL que se considerarán. También puede agregar determinados sitios a la zona.

Para especificar categorías de direcciones URL que desea incluir en la zona desde el explorador:

  1. Haga clic en el menú Herramientas de Internet Explorer y, después, haga clic en la ficha Seguridad.
  2. Haga clic en la zona Intranet local y, después, haga clic en Sitios.
  3. Active las casillas de verificación que correspondan de entre las siguientes:

    Incluir todos los sitios locales (intranet) no listados en otras zonas
    Incluir todos los sitios que no utilicen el servidor proxy
    Incluir todas las rutas de acceso de red (UNC)

Notas

  • Para agregar un sitio específico a esta zona, haga clic en Opciones avanzadas, escriba la dirección URL y haga clic en Agregar. Para requerir que se use la comprobación del servidor, active la casilla de verificación Necesita comprobación del servidor (https:) para todos los sitios de esta zona.
  • Para especificar categorías de direcciones URL para los paquetes IEAK, haga clic en Personalizar la configuración de zonas de seguridad, en la pantalla Configuración de seguridad del Asistente para la personalización de Internet Explorer y, después, haga clic en Modificar configuración.

Las reglas siguientes se aplican a las opciones de la zona de intranet local. Tenga en cuenta que agregar un sitio a cualquier zona tiene prioridad sobre las reglas siguientes:

  • Incluir todos los sitios locales (intranet) no listados en otras zonas: los nombres de los sitios de intranet no incluyen puntos (por ejemplo, http://local). Un nombre de sitio como http://www.microsoft.com no es local, ya que contiene puntos. Este sitio se asignaría a la zona de Internet La regla sobre nombres de sitios de una intranet también se aplica a las direcciones URL file: y direcciones URL http: .
  • Incluir todos los sitios que no utilicen el servidor proxy: en las configuraciones intranet típicas se usa un servidor proxy para tener acceso a Internet con una conexión directa a servidores de intranets. Esta configuración usa este tipo de información de configuración para diferenciar la intranet del contenido Internet en relación con las zonas. Si el servidor proxy se configura de una manera distinta, debe desactivar esta opción y emplear otras opciones para designar archivos asignados a la zona de intranet local. En el caso de los sistemas que no disponen de servidor proxy, esta configuración no tiene ningún efecto.
  • Incluir todas las rutas de red (UNC): las rutas de red (por ejemplo, \\local\file.txt) suelen utilizarse con contenido de red local que debería incluirse en la zona de intranet Local. Si hay rutas de acceso de red que no deberían estar incluidas en la zona de intranet local, debe desactivar esta opción y usar otras opciones para designar archivos asignados a la zona de intranet local. Por ejemplo, en ciertas configuraciones del Sistema de archivos común de Internet (CIFS, Common Internet File System) es posible que una ruta de red se refiera a contenido Internet.

Una vez que se ha confirmado que la zona de intranet local es segura, piense en la posibilidad de cambiar el nivel de seguridad de la zona a medio-bajo o bajo para permitir que se realice una gama más amplia de operaciones. También puede definir niveles de configuración individuales de seguridad en el cuadro de diálogo Configuración personalizada.

Si hay partes de su intranet que son menos seguras o no son dignas de confianza, se pueden excluir de esta zona si las asigna a la zona de sitios restringidos.

La configuración de la zona de intranet local debe hacerse con el IEAK, aunque también puede utilizar las opciones de la ficha Seguridad del cuadro de diálogo Propiedades de Internet.

Trabajar con sufijos de nombres de dominio

Si desea hacer referencia a un servidor Web mediante una expresión más corta de su dirección que no contenga el dominio, puede usar un sufijo de nombre de dominio. Por ejemplo, puede hacer referencia a un servidor Web denominado ejemplo.microsoft.com como ejemplo y tendrá acceso al mismo contenido tanto si escribe http://ejemplo.microsoft.com como http://ejemplo.

Para establecer un sufijo de nombre de dominio debe agregar éste al orden de búsqueda del sufijo de dominio en las propiedades de TCP/IP; para ello, realice los siguientes pasos:

  1. Haga clic con el botón secundario del mouse (ratón) en el icono Entorno de red y, a continuación, haga clic en Propiedades.
  2. Haga clic en TCP/IP y, después, en Propiedades.
  3. Haga clic en la ficha Configuración DNS y, a continuación, agregue la información que desee en el área Orden de búsqueda del sufijo de dominio.

Es importante que establezca correctamente las zonas de seguridad para esta configuración. De forma predeterminada, se considera que la dirección URL sin puntos (http://ejemplo) se encuentra en la zona de intranet local, mientras que la dirección URL con puntos (http://ejemplo.microsoft.com) está en la zona de Internet. Por tanto, si usa esta configuración y no se omite el servidor proxy para asignar claramente el contenido a la zona apropiada, tendrá que cambiar la configuración de la zona.

En función de si el contenido al que se tiene acceso mediante el sufijo de dominio se considera contenido de intranet o contenido de Internet, tendrá que asignar las direcciones URL de los sitios ambiguos a las zonas apropiadas. Para asignar direcciones URL como http://ejemplo a la zona de Internet, desactive la casilla de verificación Incluir todos los sitios locales (intranet) no listados en otras zonas para la zona de intranet local, e incluya el sitio en la lista de sitios de la zona.

Otras notas acerca de la seguridad que son aplicables a todas las zonas

Es posible dirigir contenido del Web mediante un nombre de Sistema de nombres de dominio (DNS) o mediante una dirección de protocolo Internet (IP); para los sitios que usan ambos, es importante configurar ambas referencias a la misma zona. Normalmente, los sitios de la zona de intranet local son identificables tanto por su nombre local como por direcciones IP en la lista de derivación del servidor proxy; todos los demás nombres y direcciones IP se asignarían a la zona de Internet. No obstante, si el nombre de un sitio se introduce en la lista de zonas de sitios en los que se confía o de zonas de sitios restringidos, pero su intervalo de direcciones IP no está en la lista, puede que se trate el sitio como parte de la zona de Internet si se tiene acceso a ella mediante su dirección IP.

Es importante comprender que un usuario puede copiar contenido de una zona a otra, con lo que podría aumentar o disminuir el nivel de seguridad deseado para dicho contenido.

Si está usando configuración automática y tiene instalados Internet Explorer 5 (o posteriores) e Internet Explorer con el mismo archivo de configuración automática, algunos valores de configuración que difieren entre las versiones no serán configurados en Internet Explorer 4.


Opciones de seguridad de Internet Explorer

Las zonas de seguridad de Internet Explorer le permiten especificar las opciones de seguridad del contenido del Web. Una zona es un conjunto de sitios Web a los que se asigna el mismo nivel de confianza. El proceso consiste en agregar sitios Web a una zona determinada y, después, definir las opciones de seguridad para cada zona.

Puede adaptar la configuración predeterminada de Internet Explorer para que se ajuste de la mejor manera a las características de seguridad del sistema. En el caso de una intranet segura, por ejemplo, normalmente puede seleccionar el nivel de seguridad bajo o una configuración personalizada equivalente, después de que la zona de la intranet local se configure como corresponde al servidor de seguridad.

En los párrafos siguientes se describen las opciones de seguridad de Internet Explorer para ayudarle a tomar las decisiones correctas en relación a la seguridad para cada opción en cada zona. Todas las opciones de seguridad se aplican al explorador Internet Explorer; no abarcan todo el sistema. Otros programas de Internet pueden no respetar estas opciones.

Para configurar las opciones de seguridad de una empresa, debe modificar la configuración mediante el IEAK. El usuario puede ver las opciones de seguridad en el explorador si hace clic en el menú Herramientas, Opciones de Internet y, después, hace clic en la ficha Seguridad. Para ver las opciones de configuración personalizadas, el usuario debe seleccionar una zona de seguridad y, después, hacer clic en Personalizar nivel.

Para obtener más información, consulte los temas siguientes:

Controles y complementos ActiveX

Estas opciones controlan la forma en que el administrador aprueba, descarga, ejecuta y automatiza los controles y complementos ActiveX. Para obtener más información acerca de cómo se administran y aprueban los controles ActiveX, consulte Administrar controles ActiveX.

Cuando un usuario descarga un control ActiveX desde un sitio distinto a aquel donde se utiliza el control, Internet Explorer utiliza la configuración de zona más restrictiva de los dos sitios. Por ejemplo, si un usuario está viendo una página Web de una zona configurada para permitir descargas, pero el código se descarga desde otra zona configurada para preguntar antes al usuario, se utilizará la configuración que establece que se pregunte al usuario.

Controles ActiveX de secuencias de comandos marcados como seguros para ejecución
Esta opción determina si un control ActiveX marcado como seguro para ejecución puede interactuar con una secuencia de comandos. Tenga en cuenta que esta opción no afecta a los controles seguros para inicialización cargados con etiquetas PARAM. Esta opción se pasa por alto cuando en Inicializar y activar la secuencia de comandos de los controles ActiveX no marcados como seguros está establecido Activar, ya que esa configuración elude toda la seguridad del objeto. No puede utilizar secuencias de comandos con controles no seguros mientras bloquea las secuencias de comandos de los controles seguros.

Inicializar y activar la secuencia de comandos de los controles ActiveX no marcados como seguros
Los controles ActiveX se clasifican como seguros o no seguros. Esta opción controla si una secuencia de comandos está autorizada para interactuar con controles no seguros. Los controles no seguros no se deben utilizar en páginas Web de Internet, aunque en algunos casos se pueden utilizar en páginas en las que tenga absoluta confianza y piense que no utilizarán los controles de forma perjudicial. Debe exigirse la seguridad del objeto a menos que se pueda confiar en todos los controles ActiveX y secuencias de comandos que pueden interactuar con las páginas de esta zona. La configuración es la siguiente:

Ejecutar controles y complementos de ActiveX
Esta opción determina si los controles y complementos de ActiveX se pueden ejecutar en las páginas de la zona especificada. Al deshabilitar esta opción se impide que se ejecute cualquier control o complemento ActiveX, por lo que se pasan por alto las restantes opciones de configuración relacionadas con ActiveX . La descarga, ejecución y creación de secuencias de comandos de controles ActiveX son tres etapas diferenciadas y en cada una de ellas se aplican opciones distintas. Las opciones de descarga distinguen entre controles con firma y controles sin firma. Las opciones para la utilización de secuencias de comandos se pueden definir por separado para controles seguros y controles no seguros. El que un control sea o no seguro para ejecución en secuencias de comandos, o inicialización, depende del autor del control y no debe confundirse con la firma; las firmas y la seguridad son características distintas. Para obtener mas información y ejemplos, visite el sitio MSDN Online Web Workshop.

Descargar controles de ActiveX firmados
Esta opción permite a los usuarios descargar controles ActiveX firmados desde las páginas de esta zona. La configuración es la siguiente:

  • Activar permite a los usuarios descargar de forma "silenciosa" cualquier control que esté firmado.
  • Pedir datos muestra una advertencia antes de que los usuarios descarguen controles firmados por entidades emisoras de certificados en las que no se confía. Esta opción permite a los usuarios descargar código firmado por entidades emisoras de confianza.
  • Desactivar impide que los usuarios puedan descargar ningún control firmado.

Descargar controles de ActiveX no firmados
Esta opción permite a los usuarios descargar controles ActiveX no firmados desde las páginas de esta zona. Este tipo de código es potencialmente peligroso, especialmente cuando procede de una zona en la que no se confía.

  • Activar pasa por alto la seguridad del objeto. Los controles ActiveX se ejecutan, se cargan con parámetros y se automatizan sin configurar la seguridad de los objetos para los datos o los archivos de comandos que no sean de confianza. Esta opción no es aconsejable excepto en el caso de zonas seguras y administradas. Esta opción hace que los controles seguros y no seguros se inicialicen y ejecuten, y se pase por alto la opción Controles ActiveX de secuencias de comandos marcados como seguros para ejecución.
  • Pedir datos intenta exigir la seguridad del objeto. Sin embargo, si el control ActiveX no se puede considerar seguro para datos o secuencias de comandos que no sean de confianza, se ofrece al usuario la opción de permitir que se cargue el control con parámetros o en secuencias de comandos.
  • Desactivar exige la seguridad del objeto en los datos o secuencias de comandos que no sean de confianza. Los controles ActiveX que no puedan considerarse seguros no se descargarán con parámetros o en secuencias de comandos.

Java

Permisos de Java

Debe tener instalada la máquina virtual de Microsoft (Microsoft VM) para que estén disponibles las opciones de Java.

Estas opciones controlan la descarga y ejecución de código Java en la zona. En las descargas de Java, si se descarga un control desde un sitio diferente a aquel donde se utiliza la página, se utilizará la configuración de zona más restrictiva de los dos sitios. Por ejemplo, si un usuario tiene acceso a una página Web en una zona en la que está permitido descargar, pero el código se descarga desde otra zona configurada para preguntar antes al usuario, se utilizará la configuración que establece que se pregunte al usuario.

Cada opción de configuración determina lo siguiente:

  • El nivel máximo de permisos concedido silenciosamente a los subprogramas firmados que se descargan desde la zona.
  • Los permisos concedidos a los subprogramas no firmados que se descargan desde la zona.
  • Los permisos concedidos a las secuencias de comandos de páginas de la zona llamadas en los subprogramas.

Las cinco opciones son:

  • Personalizada controla la configuración de permisos individualmente. En el cuadro de diálogo Permisos personalizados, la ficha Sin firmar especifica los permisos para los subprogramas y secuencias de comandos no firmados de Java. La ficha Permitido sin advertencia previa especifica el umbral en que se concederán permisos silenciosamente a los subprogramas.
  • Seguridad baja permite a los subprogramas realizar todas las operaciones sin limitaciones.
  • Seguridad media permite a los subprogramas ejecutarse en su recinto de seguridad, un espacio de memoria fuera del cual el programa no puede hacer ninguna llamada. También se habilitan otras funciones como son el espacio para notas (un área de almacenamiento seguro en el equipo del cliente) y la entrada y salida de archivos controlada por el usuario.
  • Seguridad alta permite que los subprogramas se ejecuten en su recinto de seguridad.
  • Desactivar Java no permite la ejecución de subprogramas.

Automatización

Automatización activa
Esta opción determina si se ejecuta el código de secuencias de comandos de las páginas de esta zona.

Automatización de los subprogramas Java
Esta opción determina si las secuencias de comandos de la zona están autorizadas para usar objetos que existen dentro de subprogramas Java, lo que supone permitir a las secuencias de comandos de la página que interactúen con el subprograma Java.

Descargas

Descarga de archivos
Esta opción controla si están permitidas las descargas de archivos desde esta zona. Está determinada por la zona de la página que contiene el vínculo de descarga, no por la zona desde la que se descarga el archivo.

Descarga de fuentes
Esta opción determina si los usuarios pueden descargar fuentes HTML desde las páginas de esta zona.

Autenticación de usuario

Inicio de sesión

La autenticación HTTP respeta la directiva de seguridad de la zona para las credenciales del inicio de sesión, que puede tener uno de estos cuatro valores:

  • Inicio de sesión automático sólo en la zona de Intranet: pregunta el identificador y la contraseña de los usuarios de otras zonas. Una vez que se ha preguntado al usuario, se puede utilizar este valor silenciosamente durante el resto de la sesión.
  • Inicio de sesión anónimo: deshabilita la autenticación HTTP; utiliza la cuenta de invitado sólo en el Sistema de archivos común de Internet (CIFS, Common Internet File System).
  • Pedir nombre de usuario y contraseña: pide el identificador y la contraseña del usuario. Una vez que se ha preguntado al usuario, se puede utilizar este valor silenciosamente durante el resto de la sesión.
  • Inicio de sesión automático con el nombre de usuario y contraseña actuales: el sistema de autenticación por desafío y respuesta de Windows NT (NTLM), un protocolo de autenticación entre el cliente del usuario final y el servidor de aplicaciones, se utilizará para comprobar silenciosamente la credencial de inicio de sesión antes de preguntar.

Varios

Acceso a orígenes de datos de distintos dominios
Esta opción especifica si se debe permitir que los componentes que se conectan a orígenes de datos se puedan conectar a un servidor distinto para obtener información. Esta opción se aplica sólo a enlaces de datos, como son los objetos activos de datos. La configuración es la siguiente:

  • Activar permite tener acceso a bases de datos de cualquier origen, incluso en otros dominios.
  • Pedir datos pregunta al usuario antes de permitir que tenga acceso a bases de datos en cualquier origen de otros dominios.
  • Desactivar permite tener acceso a bases de datos sólo en el mismo dominio que el de la página.

Enviar formulario de datos no cifrados
Esta opción especifica si las páginas HTML de una zona pueden enviar o aceptar formularios de los servidores de la zona. Los formularios que se envían cifrados con codificación de Capa de sockets seguros (SSL, Secure Sockets Layer) siempre están permitidos; esta opción sólo afecta al envío de datos de formularios que no sean SSL.

Ejecutar programas y archivos en IFrame
Esta opción controla si los usuarios pueden iniciar aplicaciones y archivos desde una etiqueta IFRAME, que contiene un directorio de una carpeta, en las páginas Web de esta zona.

Instalación de elementos en el escritorio
Esta opción controla si los usuarios pueden instalar elementos del escritorio desde páginas Web de esta zona.

Arrastrar y colocar o copiar y pegar archivos
Esta opción controla si los usuarios pueden arrastrar o copiar archivos desde páginas Web de esta zona.

Permisos de los canales de software
Las opciones son las siguientes:

  • Seguridad baja permite:
    • Notificación de correo electrónico
    • Descarga automática
    • Instalación automática
  • Seguridad media permite:
    • Notificación de correo electrónico
    • Descarga automática
  • Seguridad alta permite:
    • Ninguna de las características de distribución de canales de software

Cookies

Habilitar cookies no almacenados
Determina la configuración de los cookies, que son archivos de texto donde se guardan las preferencias del usuario, que utilizan los sitios Web mientras los usuarios los visitan. Por ejemplo, esta opción determina si se permite crear un "carrito virtual de la compra" cuando un usuario compra en Internet. Los cookies de sesión no se conservan en el disco duro.

La configuración es la siguiente:

  • Activar significa que los cookies se aceptan automáticamente.
  • Pedir datos significa que se preguntará a los usuarios antes de que se cree un cookie.
  • Desactivar significa que no se pueden crear cookies. Si desactiva los cookies de sesión, es posible que algunos sitios Web no funcionen correctamente.

Habilitar cookies que se almacenaron en el equipo
Determina la configuración de los cookies que se almacenan en el disco duro del usuario para futuras sesiones de exploración. Por ejemplo, esta configuración determina si se conserva una lista de preferencias o el nombre de un usuario para la siguiente visita de éste al sitio.

La configuración es la siguiente:

  • Activar significa que los cookies que permanecen se aceptan automáticamente.
  • Pedir datos significa que se preguntará a los usuarios antes de que se cree un cookie de los que permanecen.
  • Desactivar significa que no se puede crear cookies de los que permanecen. Si deshabilita los cookies que permanecen, puede que algunos sitios Web no conserven su configuración cuando el usuario vuelva a visitarlos.

Opciones de seguridad que no se pueden configurar

Las opciones siguientes son fijas y el usuario no puede configurarlas. La configuración de zona alta, media, media-baja y baja no cambia el comportamiento de estas opciones.

Iniciar desde Vista Web
Esta opción controla si los usuarios pueden iniciar programas y archivos desde una carpeta vista como una página Web. Esta configuración se aplica a usuarios de Windows 98 y a los que han actualizado el explorador desde Internet Explorer 4 y utilizan la Actualización del escritorio de Windows. La configuración viene determinada por la zona del contenido Web personalizado, no por la zona de la propia carpeta:

Mi PC | Intranet local | Sitos de confianza | Internet | Sitios restringidos
Habilitar | Habilitar | Habilitar | Símbolo del sistema | Símbolo del sistema


Administrar controles ActiveX

IEAK 5 introduce una nueva característica que permite a los administradores especificar exactamente qué controles ActiveX se pueden ejecutar en una zona determinada. Hay dos situaciones principales en las que esta característica ofrece grandes posibilidades de control de la utilización de los controles ActiveX y, por lo tanto, un grado mayor de seguridad.

Situación 1: utilización limitada en Internet de controles ActiveX

Muchas organizaciones usan en gran medida los controles ActiveX en una intranet local, aunque desean limitar su uso fuera del servidor de seguridad (es decir, en la zona de Internet). Mientras que el contenido de la intranet local es de confianza y puede asegurarse que no hará un uso malicioso de los controles que utilice, estos controles no son apropiados para ser utilizados en las páginas Web de Internet. Si se especifica un conjunto de controles genéricos que apruebe el administrador para ser utilizados en Internet, será posible tener acceso a sitios que utilicen controles al tiempo que se impide el uso incorrecto de otros controles en esa zona.

Por ejemplo, supongamos que como administrador desea limitar el uso de los controles ActiveX aunque desea permitir que un sitio importante de Internet (por ejemplo, el de una empresa asociada o un proveedor de servicios) pueda utilizar controles ActiveX. Visite el sitio, vea qué controles ActiveX utiliza y anote las entradas nuevas que aparecen en la carpeta Downloaded Program Files de la carpeta Windows. Realice el procedimiento que se describe al final de este tema para especificar que el uso de esos controles está aprobado por el administrador.

Una vez realizada esa operación, sólo esos controles podrán ejecutarse en el sitio. De esta forma se impedirá que cualquier página de Internet utilice otros controles, como aquellos destinados para ser usados exclusivamente en la intranet.

Situación 2: uso restringido de los controles ActiveX

Puede tener un mayor grado de control si incluye en una lista todos los controles ActiveX aprobados y, después, sólo permite al explorador la ejecución de ese conjunto de controles. El costo que tiene este mayor grado de control es el esfuerzo adicional que supone enumerar todos los controles que permite usar el administrador, por lo que este sistema sólo se recomienda en el caso de que el conjunto de controles sea relativamente pequeño.

Evalúe qué controles se pueden utilizar en cualquier sitio. En las zonas que contienen sitios autorizados a usar esos controles, realice el procedimiento indicado al final de este tema para especificar que dichos controles están aprobados por el administrador. En las zonas que contienen sitios que no tienen autorización para usar esos controles, active Deshabilitar en el área Ejecutar controles y complementos ActiveX. De esta forma, en las páginas Web sólo se ejecutarán los controles especificados y en las zonas permitidas, exclusivamente.

Elegir los controles ActiveX

Algunos controles ActiveX de uso generalizado aparecen enumerados en el archivo de controles activos aprobados por el administrador, Axaa.adm, que se incluye con el IEAK. Esta lista no es una recomendación; simplemente presenta algunos de los controles ActiveX más utilizados en el Web. Como administrador, debe evaluar si dichos controles pueden utilizarse en su organización. Puede modificar el archivo y agregar los controles que desee. De forma predeterminada, ninguno de los controles aparece como aprobado en la lista. Si desea agregar más controles después de que los usuarios instalen Internet Explorer, puede usar la configuración automática.

Para especificar que los controles ActiveX deben ser aprobados por un administrador y definir los controles que desea aprobar, realice las operaciones siguientes:

  1. Examine la configuración de los controles ActiveX en el archivo Axaa.adm, que se encuentra en la subcarpeta \Policies\<idioma> de la carpeta del IEAK. Si desea agregar más controles a esta lista, como pueden ser los controles que haya creado su organización, utilice un procesador de textos para modificar el archivo Axaa.adm.

    Es aconsejable efectuar una copia de seguridad de este archivo por si desea recuperar en el futuro la configuración original.

  2. En la pantalla Configuración de seguridad del Asistente para la personalización de Internet Explorer, haga clic en Personalizar la configuración de zonas de seguridad y, después, haga clic en Modificar configuración.
  3. Seleccione la zona de contenido en la que desea administrar los controles ActiveX y, después, haga clic en Personalizar nivel.
  4. En el área Ejecutar controles y complementos ActiveX, haga clic en Aprobado por el administrador.
  5. Repita los dos últimos pasos hasta que haya configurado todas las zonas que desee.
  6. En la página Directivas y restricciones, en el paso 5 del Asistente para la personalización de Internet Explorer, haga clic en la categoría Administración de controles para expandir su contenido y, después, active las casillas de verificación de los controles que desee aprobar.


Firmar sus programas

Puede utilizar el IEAK para firmar digitalmente sus paquetes personalizados. Las firmas digitales muestran la procedencia de los programas y comprueban que no han sido alterados. Firme digitalmente sus paquetes personalizados de explorador, así como los programas personalizados, para garantizar que los usuarios no reciban advertencias cuando instalen el explorador personalizado.

Sin embargo, en primer lugar deberá obtener un certificado digital con el que firmar los archivos. Al ejecutar el Asistente para la personalización de Internet Explorer deberá especificar la ubicación de ese certificado; de esta forma, se firmarán los archivos cuando se cree el paquete. Para obtener información acerca de cómo obtener un certificado digital, consulte la siguiente sección, "¿Cómo puedo obtener certificados digitales?"

Si tiene la intención de distribuir paquetes personalizados a través de Internet, deberá hacer que el IEAK firme los archivos contenedores .CAB personalizados que crea. Si piensa distribuir los paquetes personalizados a través de una intranet, firme los archivos personalizados, a menos que haya configurado previamente la zona local de la intranet con un nivel bajo de seguridad. La configuración de seguridad predeterminada no permitirá a los usuarios la descarga de programas o códigos sin firmar. Para obtener información acerca de las zonas de seguridad, consulte Seguridad de Internet Explorer.

Se firmarán los archivos personalizados siguientes:

Nombre del archivo | Función del archivo
Branding.cab | Marcar información para el programa de instalación de Windows Update
Desktop.cab | Actualización del escritorio de Windows
Iecif.cab | Identifica qué componentes de Microsoft Internet se han instalado como parte de la instalación de Windows Update
IE5setup.exe | Programa de instalación de Windows Update
Mmssetup.exe | Programa de instalación del cliente MSN Messenger Service
MMSsetup.cab | Marca información para el cliente MSN Messenger Service
Custom<n>.cab | Componentes personalizados instalados después de haber reiniciado el sistema. Cada componente se empaqueta en un archivo contenedor (.cab) independiente y numerado.

Si desea ver un organigrama en el que se muestra cómo el Asistente para la personalización de Internet Explorer crea estos archivos, consulte Cómo genera el IEAK paquetes personalizados.

Notas

  • Se puede evitar que los usuarios instalen controles ActiveX y paquetes de Java que no estén firmados.
  • También tiene que firmar cualquier programa personalizado, tanto en formato .EXE como .CAB, que incluya en su paquete del explorador.
  • Si piensa que su organización utilizará la función de Instalación a petición a través de Internet, debe firmar los archivos .CAB y especificar en la configuración de la seguridad que el servidor que los almacena es un servidor de confianza o, en el caso específico del sitio de una intranet, seleccionar un nivel bajo de seguridad. Para obtener más información acerca de esta característica, consulte Administrar la instalación a petición.

    Si el nivel de seguridad de la intranet es medio o algún nivel superior, deberá especificar que los servidores de red son servidores en los que se confía. Para ello, siga los pasos siguientes:

    1. En la página Configuración de seguridad del asistente, haga clic en Importar la configuración de zonas de seguridad actual y, después, haga clic en Modificar configuración.
    2. Seleccione la zona Intranet local y, después, haga clic en Sitios.
    3. Desactive la casilla de verificación Incluir todas las rutas de red (UNC) y haga clic en Aceptar.
    4. Seleccione la zona Sitios de confianza, haga clic en Sitios, escriba la ruta de acceso del servidor de descarga y, después, haga clic en Agregar.
    5. Repita el paso anterior para cada servidor de descarga que desee especificar como servidor de confianza.

Para obtener más información, consulte los temas siguientes:

¿Cómo puedo obtener certificados digitales?

Los certificados digitales forman parte de la tecnología Authenticode™, que identifica la procedencia de los programas y comprueba que no hayan sufrido alteraciones. Para obtener esos certificados puede solicitarlos a una entidad emisora de certificados o un servidor de certificados de control privado. Los certificados pueden ser comerciales o individuales.

Para obtener más información acerca de Authenticode y temas de seguridad, visite el sitio Web Microsoft Security Advisor en http://www.microsoft.com/security/.

¿Cómo firmo mis archivos contenedores (CAB) o programas personalizados?

Después de obtener un certificado tendrá que firmar el código. Las herramientas que permiten firmar el código están disponibles en el sitio Microsoft Site Builder Network Workshop.

También necesitará conocer las claves públicas y privadas, que son un conjunto de claves coincidentes que crea la compañía de software para el cifrado y descifrado. Las claves se generan en el momento en que se solicita el certificado a la entidad emisora de certificados (CA). Se generan en el equipo del usuario y la clave privada no se envía nunca al CA ni a ningún otro equipo.

¿Qué ocurre cuando caducan los certificados?

La caducidad de los certificados es una medida adicional de seguridad. Por ejemplo, si una universidad certifica a todos sus estudiantes con identificadores digitales (Id.), podría establecer que cada identificador caducara cuando el alumno dejara la universidad. El código firmado con un certificado caducado no es válido. Cuando caduca el certificado, la compañía de software necesita volver a firmar el código y publicar nuevas versiones del mismo.

Las compañías de software pueden incluir información de fecha y hora al firmar el código con el fin de probar que el certificado era válido en el momento en que se firmó el código. De esta forma, el código firmado seguirá siendo válido después de que el certificado haya caducado.

¿Cómo se puede utilizar Authenticode para controlar lo que ven los usuarios?

Si es administrador de una empresa, puede configurar previamente las zonas de seguridad, preestablecer las restricciones y personalizar las entidades emisoras de certificados. También puede definir directivas del sistema y restricciones para controlar si los usuarios podrán modificar la configuración de la seguridad. Para obtener información acerca de configuraciones específicas, consulte Opciones de seguridad de Internet Explorer.

Puede garantizar que los usuarios recibirán advertencias cuando intenten ver contenido potencialmente no seguro. También puede evitar que los usuarios descarguen controles ActiveX y paquetes de Java sin firmar.

Cuando firmo mi código, ¿qué sucede?

La firma de código es un proceso sencillo y rápido. No es necesario conocer los detalles técnicos acerca del procedimiento de la firma de código para firmar su código.

Después de desarrollar y probar el código, la compañía de software firma el código. La compañía utiliza un programa de firma, como puede ser Signcode.exe, que ejecuta un algoritmo de hash con el código y crea un "resumen" del archivo. A través del sistema operativo, el programa cifra ese resumen con la clave privada, lo combina con el nombre del algoritmo de hash y con el certificado del CA (que contiene el nombre de la compañía, su clave pública, etc.) y forma así una estructura que se denomina bloque de firma. El programa inserta entonces ese bloque en el archivo de código, con lo que éste queda listo para su distribución a través de Internet. Tenga en cuenta que un archivo .CAB firmado incluye también un bloque de firma.

Cuando el usuario descarga el archivo desde Internet, la aplicación que realiza la descarga llama a una función de comprobación. Como consecuencia de esa llamada, el sistema operativo extrae el bloque de firma, determina qué CA validó el certificado y utiliza la clave pública para descifrar el resumen. El sistema utiliza después el algoritmo de hash indicado en el bloque de firma para crear un segundo resumen. Si el código no se modificó desde que se firmó, el resumen nuevo debe coincidir con el antiguo. Si los dos resúmenes no coinciden, significa que el código se ha modificado o que la clave pública no se corresponde con la clave privada. En cualquier caso, el código se convierte en sospechoso y se advierte al usuario.


Personalización avanzada del cliente de mensajería

Si el cliente del servicio de mensajería personalizado se va a utilizar detrás de un servidor de seguridad (por ejemplo, en una intranet corporativa), puede configurarlo previamente de modo que admita servidores proxy. Sin embargo, no podrá configurar los valores de proxy utilizados por el cliente del servicio de mensajería en el Asistente para el IEAK. En lugar de ello, para incluir la personalización del servidor proxy en el archivo de instalación del cliente del servicio de mensajería, debe modificar uno de los archivos de configuración y volver a ejecutar después el asistente. En la mayor parte de los casos, la personalización del servidor proxy no es necesaria, ya que el protocolo de mensajería está basado en TCP y, por lo general, funcionará en situaciones en las que el usuario no se encuentre detrás de un servidor de seguridad.

Importante

  • Si está configurando los valores de proxy, no especifique una dirección URL de descarga en la sección marca de MSN Messenger Service del Asistente para el IEAK. La dirección URL de descarga se incluye en el correo de invitación del cliente y las invitaciones no se restringen necesariamente a usuarios que se encuentren detrás del servidor de seguridad y utilicen el proxy. Deje la dirección URL de descarga en blanco, de modo que el correo de invitación señale al archivo de instalación predeterminado del cliente MSN Messenger Service e informe a los usuarios de que el correo de invitación no es un mecanismo adecuado para distribuir el cliente dentro del entorno de proxy personalizado.

Para configurar los valores de proxy del cliente del servicio de mensajería

  1. Ejecute el Asistente para el IEAK y establezca todas las configuraciones necesarias para el cliente del servicio de mensajería personalizado y otros componentes. De esta manera se generará una versión inicial de los archivos de configuración y los paquetes de instalación para Internet Explorer y para el cliente del servicio de mensajería. No utilice estos paquetes de instalación iniciales; los volverá a generar posteriormente.
  2. Busque el archivo msmsgs.in_, que se creó al ejecutar el asistente. Este archivo se encuentra en las subcarpetas de sistema operativo e idioma de la carpeta INS, en la carpeta de versión. (Por ejemplo: [carpeta de versión]\INS\WIN32\En\msmsgs.in_.) Mediante un procesador de textos, como el Bloc de notas, abra el archivo msmsgs.in_.
  3. Si está especificando un servidor proxy, agregue la siguiente línea de texto al final del archivo:
    ProxyOn=1
  4. Especifique el tipo de proxy como SOCKS4 o SOCKS5; para ello, agregue una de las siguientes líneas de texto:
    ProxyVersion=4
    o
    ProxyVersion=5
  5. Especifique la ubicación del servidor proxy; para ello, agregue la siguiente línea de texto:
    ProxyServer=[nombre de DNS o dirección IP]
  6. Especifique el puerto utilizado por el servidor proxy para las conexiones iniciales; para ello, agregue la siguiente línea de texto:
    ProxyPort=1080
    1080 es el puerto predeterminado para SOCKS4; escriba otro número de puerto si el proxy está configurado de manera diferente.
  7. Guarde el archivo con su nombre original y salga del procesador de textos.
  8. Vuelva a ejecutar el Asistente para el IEAK. En la página Ubicaciones de archivos del asistente, haga clic en el botón Opciones avanzadas.
  9. En el cuadro de diálogo Opciones avanzadas, busque la ubicación donde el asistente para el IEAK guardó el archivo install.ins y selecciónelo. Al señalar el archivo install.ins, se habilita la carga de todas las opciones de configuración anteriores, aunque la configuración de personalización del cliente del servicio de mensajería esté incluida en el archivo msmsgs.in_. Haga clic en Aceptar.
  10. Continúe ejecutando el asistente a fin de generar los nuevos archivos ejecutables y .CAB para el cliente del servicio de mensajería y los paquetes del explorador completos.

El programa de instalación no configurará previamente el cliente del servicio de mensajería para conectar con el servidor de mensajería mediante el servidor proxy especificado. Si utiliza el protocolo SOCKS5 con autenticación de usuario, para poder habilitar la conexión al servidor proxy, los usuarios deberán escribir sus nombres de usuario y contraseñas específicas de red en el cuadro de diálogo Opciones | Conexión del cliente del servicio de mensajería personalizado. Después de la instalación, los usuarios pueden configurar todas las opciones de proxy mediante las opciones del cliente del servicio de mensajería.


Contenido promocional en su cliente del servicio de mensajería personalizado

El archivo XML Promotions le permite promocionar su propio contenido en el área Promociones de la ventana principal del cliente del servicio de mensajería. MSN administra dicho contenido en el cliente de MSN Messenger Service. Si especifica un archivo XML Promotions, su contenido de promociones se alternará con el contenido previsto de MSN según la siguiente programación:

Contenido | Duración
Su logotipo (especificado en el campo Logo) | aprox. 7,5 segundos
Logotipo de compatibilidad de red MSN | aprox. 7,5 segundos
Su contenido de promociones (especificado en el archivo XML) | aprox. 45 segundos
Su logotipo (especificado en el campo Logo) | aprox. 7,5 segundos
Logotipo de compatibilidad de red MSN | aprox. 7,5 segundos
Contenido programado de MSN | aprox. 45 segundos

Esta programación se repetirá a intervalos de 120 segundos aproximadamente.

El archivo XML se sirve desde un servidor Web a su sitio. Es posible mantener el mismo archivo XML o intercambiarlo en la misma ubicación por un nuevo archivo para proporcionar contenido actualizado (la dirección URL no debe modificarse). El cliente del servicio de mensajería puede configurarse para comprobar y descargar nuevos archivos XML cada cinco minutos. Existe la posibilidad de continuar mostrando el mismo contenido en el área Promociones o de mostrar un contenido distinto en cada rotación de anuncios; para ello, especifique más de un grupo de artículos. Puede especificar cinco grupos de artículos, como máximo. Para obtener más información, consulte Formato de archivo XML para promociones del servicio de mensajería.

Sugerencias de formato

Los grupos de artículos pueden contener uno de los elementos siguientes:

  • Una imagen .GIF grande de hasta 234 píxeles de ancho por 60 de alto. Pueden utilizarse imágenes .GIF animadas.
  • Un máximo de tres vínculos de texto. Los vínculos aparecen como puntos de viñetas.
  • Un máximo de tres vínculos de texto y una imagen .GIF pequeña. Pueden utilizarse imágenes .GIF animadas. Los vínculos aparecen en el cliente como puntos de viñetas y la imagen se muestra justificada a la izquierda, junto a los vínculos. Puesto que el ancho de la imagen comprime el espacio disponible para los vínculos, el tamaño de imagen recomendado es de 60 por 60 píxeles, con un alto que no supere los 60 píxeles.

Si el texto de las promociones se trunca, los vínculos de texto no se ajustarán ni aparecerán las barras de desplazamiento. El texto truncado se mostraría mediante una elipsis (por ejemplo, "Aquí aparece un vínculo extremadamente largo" se mostraría en el cliente como "Aquí apare..."). Por lo tanto, para evitar este problema, procure que las imágenes y el texto de los vínculos no sean demasiado grandes. Aunque los usuarios pueden cambiar el tamaño de la ventana principal, lo más probable es que mantengan el tamaño estrecho predeterminado.

Nota

  • Por lo general, los grupos de artículos con vínculos tienen mejor apariencia y llaman más la atención si se especifica también una imagen en el grupo de artículos.


Formato de archivo XML para promociones del servicio de mensajería

El archivo XML Promotions se sirve desde un servidor a su sitio Web y es actualizado por un cliente del servicio de mensajería a intervalos configurables. El archivo debe estar formado por cadenas cifradas con UTF-8 (el texto ASCII sencillo se convierte automáticamente al cifrado UTF-8) y se permiten marcas de orden de bytes (BOM, Byte Order Mark). Para que los clientes del servicio de mensajería puedan ver el contenido correctamente, el formato especificado en el código XML debe seguirse estrictamente. Microsoft no se responsabiliza de códigos XML incorrectos ni de sus efectos. Consulte Contenido promocional del cliente del servicio de mensajería personalizado para obtener información general acerca de cómo incluir material de promoción en el cliente del servicio de mensajería personalizado.

Tabla de referencia de etiquetas

Etiqueta | Descripción | Principal
msn-data | Requerido. Contenedor de nivel superior del material de promociones. | (ninguna)
RefreshLogin | Requerido. Valor booleano que determina cuándo se descargará contenido nuevo. Si se establece a True, se descarga un nuevo archivo XML desde el servidor siempre que un usuario inicia una sesión y se restablece el temporizador de actualización a cero. Si se establece a False, el contenido no se actualiza automáticamente en cada inicio de sesión (sólo se actualiza al alcanzar el intervalo establecido) y el temporizador del intervalo de actualización se restablece entre inicios de sesión. Se recomienda RefreshLogin=True. Es aconsejable establecer RefreshLogin a False si le preocupa que el servidor XML reciba un exceso de solicitudes después de cortes del suministro eléctrico o en momentos de mucha actividad. | msn-data
RefreshInterval | Requerido. Número de minutos que debe transcurrir entre las actualizaciones de todo el archivo XML en el cliente. Si el usuario ha cerrado la sesión y RefreshLogin se establece a False, el valor del temporizador se restablece entre inicios de sesión. El valor mínimo es 5 y el máximo es 10080 (una semana). | msn-data
article-group | Contenedor para conjuntos de artículos. Cada parámetro article-group (grupo de artículos) determina el contenido que se mostrará dentro del área Promociones; si se incluye más de uno, se rotan secuencialmente. Debe especificarse al menos un grupo de artículos; en el archivo XML Promotions se permite un máximo de cinco. Cada grupo no debe incluir más de tres vínculos y una imagen. | msn-data
article | Contenedor de cada artículo individual. Puede estar formado por un vínculo (predeterminado) o una imagen, en cuyo caso debe especificarse <article type="image">. | article-group
image-url | Especifica la dirección URL de la imagen, que sólo se utilizará si el artículo es type="image". En el área Promociones sólo se pueden utilizar imágenes .GIF; los archivos JPEG no se mostrarán. El tamaño de imagen recomendado es de 60 píxeles de ancho por 60 píxeles de alto si muestra una imagen con varios vínculos. Si muestra una imagen sin vínculos (un título publicitario, por ejemplo) el tamaño máximo es de 234 píxeles de ancho por 60 píxeles de alto. Se admiten imágenes .GIF animadas. | article type="image"
url | Especifica la dirección URL que se carga en una nueva ventana del explorador cuando el usuario hace clic en un vínculo o una imagen. | article
title | Especifica el texto que se mostrará al usuario como un vínculo. Sólo debe utilizarse si el artículo no es type="image". | article

Ejemplo

<?xml version="1.0"?>
<msn-data>
  <RefreshLogin>True</RefreshLogin>
  <RefreshInterval>360</RefreshInterval>
  <article-group>
    <article type="image">
      <image-url>http://msdn.microsoft.com/workshop/graphics/icons/xml.gif</image-url>
      <url>http://msdn.microsoft.com/xml/index.asp</url>
    </article>
    <article>
      <title>Aprenda acerca de XML en MSDN</title>
      <url>http://msdn.microsoft.com/xml/index.asp</url>
    </article>
    <article>
      <title>Guía de XML para programadores de MSDN</title>
      <url>http://msdn.microsoft.com/xml/xmlguide/default.asp</url>
    </article>
    <article>
      <title>Charla acerca de XML</title>
      <url>http://msdn.microsoft.com/chats/xml.asp</url>
    </article>
  </article-group>
  <article-group>
    <article>
      <title> P+F acerca de MSN Messenger Service</title>
      <url>http://messenger.msn.com/support/knownissues.asp</url>
    </article>
    <article>
      <title> Descargas de MSN Messenger Service</title>
      <url>http://messenger.msn.com/download/download.asp</url>
    </article>
    <article>
      <title>MSN Messenger Service es internacional</title>
      <url>http://messenger.msn.com/support/intl_map.asp</url>
    </article>
  </article-group>
</msn-data>


Ejecutar la instalación por lotes

El Asistente para la personalización de Internet Explorer permite controlar la funcionalidad y experiencia del usuario de la instalación de Windows Update. Puede aumentar el control sobre el proceso de instalación mediante un archivo por lotes, modificadores de la línea de comandos o una combinación de ambos elementos. Estos métodos se pueden utilizar cuando se instala Internet Explorer independientemente o como parte de Microsoft Office.

En la mayor parte de los casos, el método que utiliza el archivo por lotes ofrece un mayor control sobre la instalación de componentes individuales y requiere realizar menos pasos. Los modificadores de la línea de comandos se incluyen para mantener la compatibilidad con las versiones anteriores y para permitir el uso de soluciones personalizadas.

Crear un archivo por lotes

Para crear un archivo por lotes, use un procesador de textos, como el Bloc de notas de Microsoft, y asigne al archivo el nombre IEbatch.txt. Si piensa llamar al archivo por lotes mediante modificadores de la línea de comandos puede utilizar un nombre diferente, siempre y cuando haga referencia al nombre de archivo correcto en la sintaxis de línea de comandos. Para obtener más información, consulte Sintaxis de archivos por lotes. Puede ver un ejemplo en la sección Ejemplo de archivo de instalación por lotes.

Usar archivos por lotes para distribuir Internet Explorer

Al distribuir Internet Explorer a través de Internet o de una intranet, puede publicar el archivo por lotes en el sitio desde el que los usuarios descargarán Internet Explorer. Si va a distribuir Internet Explorer por otro sistema, como puede ser en disco o CD, puede agregar el archivo por lotes al disco. Colóquelo en la misma carpeta que el archivo IE5Setup.exe.

Puede que prefiera conservar el archivo por lotes en una ubicación independiente, en el caso de que no estuviera listo cuando preparó el paquete IEAK o cuando desee cambiar de forma temporal o permanente las opciones de instalación especificadas en el paquete personalizado IEAK.

Ejecutar el programa de instalación mediante modificadores de la línea de comandos

Si Internet Explorer y los componentes asociados se van a incluir con el producto, normalmente deben usarse modificadores de la línea de comandos para instalar el paquete IEAK como parte del programa de instalación. En caso de que desee modificar la instalación mediante el uso de modificadores de la línea de comandos, puede usar el Asistente para IExpress, que se incluye con el IEAK, o puede utilizar otro programa de instalación para empaquetar los archivos de instalación.

Para obtener más información, consulte Modificadores de la instalación por lotes de Internet Explorer y Modificadores de la instalación por lotes de IExpress.

Motivos para ejecutar la instalación desde una línea de comandos o un archivo por lotes

A continuación se incluyen algunos motivos por los que sería aconsejable incluir controles adicionales en la instalación de Windows Update:

Realizar una instalación no interactiva

Si es administrador en una empresa, quizás prefiera distribuir Internet Explorer a los usuarios después de las horas laborales normales. Aunque el IEAK le ayuda a preparar una instalación "silenciosa" que requiere poca participación del usuario, quizás desee ir un paso más allá en el control de este proceso. Al utilizar las opciones del archivo de texto por lotes o los modificadores de la línea de comandos, puede determinar qué mensajes verá el usuario y si el equipo debe reiniciarse al terminar la instalación.

Redistribuir Internet Explorer

Si es fabricante independiente de software quizás prefiera alojar Internet Explorer en su programa e instalar Internet Explorer sin los iconos ni la interfaz del explorador. Para ello, use un archivo por lotes con la opción Redist o con el modificador /X. Para obtener más información, consulte Modificadores de la instalación por lotes de Internet Explorer.

Tener un mayor control sobre determinados componentes

El uso de un archivo por lotes permite instalar y controlar los componentes, independientemente de si se han incluido en el paquete IEAK. También es posible restringir los modos de instalación (como Estándar o Mínima) disponibles para los usuarios. Utilice el identificador del componente IdComponente, una cadena de texto como NetMeeting, para identificar los componentes. Puede localizar información relativa al identificador del componente en el archivo Iesetup.cif.

Cambiar las opciones de instalación sin tener que generar de nuevo el paquete IEAK

Quizás necesite instalar y configurar Internet Explorer de una forma peculiar y no desee volver a generar nuevamente el paquete IEAK. Puede utilizar un archivo por lotes o modificadores para cambiar configuraciones especificadas previamente en el Asistente para la instalación de Windows Update al crear el paquete.


Sintaxis de archivos por lotes

Puede utilizar un archivo por lotes para aumentar el control sobre el proceso de instalación y el Asistente para la instalación de Windows Update para Internet Explorer y herramientas de Internet. La tabla siguiente muestra las secciones y entradas que componen el archivo por lotes. Para obtener más información acerca de cómo usar un archivo por lotes, consulte Ejecutar la instalación por lotes. Para ver un archivo de ejemplo completo, consulte Ejemplo de archivo de instalación por lotes.

Secciones de un archivo por lotes:

[Options]

[Welcome]

[SetupChoice]

[Custom]

[Download]

[DownloadSite]

[PrepareSetup]

[Diskspace]

[Progress]

[RebootPartial]

[Finish]

[Reboot]

[Upgrade]

[Options]
SaveUninstallInfo=[0,1]
ExtraSection=
Quiet=[A,C,U]
ShowErrors=[0,1]
Display=[0,1]

Entradas en esta sección | Descripción
SaveUninstallInfo=[0,1] Determina si se debe conservar la información necesaria para quitar componentes.
  • 0 especifica que no se conserva esa información. Si utiliza este modificador, no podrá desinstalar Internet Explorer desde el Panel de control.
  • 1 (opción predeterminada) especifica que se conserva esa información.
ExtraSection=sección1[,sección2,...] | Ejecuta las secciones especificadas en el archivo Iesetup.inf. Separe las secciones mediante comas (por ejemplo, sección1,sección2,sección3).
Quiet=[A,C,U] Representa el modo silencioso, en el que no se requiere ninguna o casi ninguna intervención del usuario durante la instalación.
  • A especifica el modo de administrador, en el que el usuario no ve ejecutarse el programa de instalación y no se realiza la comprobación de errores.
  • C elimina el botón Cancelar de la página de información de desarrollo del proceso.
  • U especifica que el programa de instalación no se muestre al usuario a menos que necesite alguna entrada (por ejemplo, la ubicación de descarga) que no esté disponible.
ShowErrors=[0,1] Determina si los errores del programa de instalación se deben mostrar al usuario.
  • 0 especifica que el programa de instalación realiza la acción predeterminada para cada mensaje sin que el usuario tenga que especificar ningún dato.
  • 1 (opción predeterminada) especifica que los errores del programa de instalación se deben mostrar al usuario.
Ir al principio

[Welcome]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Determina si se debe mostrar la pantalla inicial del programa de instalación en el equipo del usuario.
  • 0 especifica que no se debe mostrar la pantalla inicial del programa de instalación.
  • 1 (opción predeterminada) especifica que se debe mostrar al usuario la pantalla inicial del programa de instalación.
Ir al principio

[SetupChoice]
Display=[0,1]
SetupChoice=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Determina si debe aparecer en el equipo del usuario la pantalla en la que éste puede elegir la opción de instalación que le permite personalizar la instalación.
  • 0 especifica que no se debe mostrar al usuario la pantalla de selección del tipo de instalación.
  • 1 (opción predeterminada) especifica que se debe mostrar al usuario la pantalla de selección del tipo de instalación.
SetupChoice=[0,1] Determina qué opción de instalación se elige.
  • 0 (opción predeterminada) especifica Instalar ahora - Instalación típica de componentes.
  • 1 especifica Instalación personalizada.
Ir al principio

[Custom]
Display=[0,1]
InstallDir=nombre de carpeta
InstallDirRO=[0,1]
UseInfInstallDir=[0,1]
SetupMode=[0,1,2]
SetupModeRO=[0,1]
Component=[IdComponente_1, IdComponente_2, ...]
ComponentListRO=[0,1]
DownloadOnly=[0,1]
DownloadOnlyRO=[0,1]
IECompat=[0,1]
IECompatRO=[0,1]
IECompatShow=[0,1]
ShowAdvanced=[0,1]
IEDefault=[0,1]
IEDefaultRO=[0,1]

Entradas en esta sección | Descripción
Display=[0,1] Determina si debe aparecer en el equipo del usuario la pantalla Opciones de componentes en la que los usuarios pueden seleccionar los componentes y hacer clic en Opciones avanzadas para especificar más opciones.
  • 0 especifica que no debe mostrarse al usuario la pantalla Opciones de componentes.
  • 1 (opción predeterminada) especifica que se debe mostrar al usuario la pantalla Opciones de componentes.
InstallDir=nombre de carpeta | Especifica la carpeta donde se deben instalar los archivos. Si no se incluye esta opción, el programa de instalación utiliza los parámetros existentes en el archivo Iesetup.inf. Si ha instalado una versión anterior de Internet Explorer, el programa de instalación utiliza dicha carpeta.
InstallDirRO=[0,1] Especifica si el usuario puede cambiar la carpeta de instalación.
  • 0 (opción predeterminada) especifica que el usuario puede cambiar la carpeta de instalación.
  • 1 especifica que el usuario no puede cambiar la carpeta de instalación.
UseInfInstallDir=[0,1] Especifica la carpeta donde se debe instalar Internet Explorer.
  • 1 (opción predeterminada) especifica que el programa de instalación usa la carpeta de instalación predeterminada o la misma carpeta en que ya se ha instalado una versión anterior de Internet Explorer.
  • 1 especifica que la carpeta de instalación es la indicada en el archivo Iesetup.inf.
SetupMode=[0,1,2] Especifica qué tipo de instalación debe realizarse.
  • 0 especifica una instalación mínima.
  • 1 (opción predeterminada) especifica una instalación típica.
  • 2 especifica una instalación completa.
SetupModeRO=[0,1] Determina si el usuario puede cambiar el tipo de instalación.
  • 0 especifica que el usuario puede cambiar el tipo de instalación.
  • 1 (opción predeterminada) especifica que el usuario no puede cambiar el tipo de instalación.
Component=[IdComponente_1[,IdComponente_2,...]]

Especifica que sólo se deben instalar los componentes especificados en el parámetro Component=. IdComponente es una cadena de texto que identifica de forma exclusiva un componente; puede encontrar la cadena que corresponde a cada componente en su sección dentro del archivo Iesetup.cif. Puede encontrar información acerca del identificador del componente (IdComponente) en el sitio Web de IEAK.
ComponentListRO=[0,1]

Determina si el usuario puede especificar qué componentes se deben instalar, además de los componentes correspondientes al tipo de instalación.

  • 0 (opción predeterminada) especifica que el usuario puede cambiar la lista de componentes.
  • 1 especifica que el usuario no puede cambiar la lista de componentes.
DownloadOnly=[0,1] Determina si Internet Explorer sólo debe descargarse, o debe descargarse e instalarse.
  • 0 (opción predeterminada) especifica que los archivos se descargan y después se instalan.
  • 1 especifica que los archivos se descargan pero no se instalan.
DownloadOnlyRO=[0,1] Determina si el usuario puede especificar que los archivos se descarguen, o se descarguen e instalen.
  • 0 (opción predeterminada) especifica que el usuario puede cambiar esta opción de configuración.
  • 1 especifica que el usuario no puede cambiar esta opción de configuración.
IECompat=[0,1] Determina si Internet Explorer 5 (o versiones posteriores) debe instalarse en un equipo que ya contiene Internet Explorer 4, de forma que esté disponible la funcionalidad de ambos programas.
  • 0 especifica que Internet Explorer 5 (o posterior) no puede instalarse en un equipo que contenga Internet Explorer 4.
  • 1 (opción predeterminada) especifica que Internet Explorer 5 (o posterior) puede instalarse de forma que funcione con características de Internet Explorer 4.
IECompatRO=[0,1] Determina si el usuario puede especificar o no que las características de Internet Explorer 4 puedan usarse con Internet Explorer 5 (o posteriores).
  • 0 (opción predeterminada) especifica que el usuario puede cambiar esta opción de configuración.
  • 1 especifica que el usuario no puede cambiar esta opción de configuración.
IECompatShow=[0,1] Determina si debe aparecer la casilla de verificación Compatibilidad, que permite a los usuarios ejecutar Internet Explorer 5 (o posterior) en un equipo que contiene Internet Explorer 4.
  • 0 especifica que la casilla de verificación no debe aparecer en el asistente.
  • 1 (opción predeterminada) especifica que la casilla de verificación debe aparecer en el asistente .
ShowAdvanced=[0,1] Determina si el botón Avanzadas debe aparecer en la pantalla Opciones de componentes del Asistente para la instalación de Windows Update. Al hacer clic en el botón Avanzadas aparecen las opciones Sólo descargar, Compatibilidad y No asociar tipos de archivo.
  • 0 especifica que el botón Avanzadas no debe aparecer en el asistente.
  • 1 (opción predeterminada) especifica que el botón Avanzadas debe aparecer en el asistente.
IEDefault=[0,1] Determina si Internet Explorer debe ser el explorador predeterminado.
  • 0 especifica que no lo es.
  • 1 (opción predeterminada) especifica que Internet Explorer es el explorador predeterminado.
IEDefaultRO=[0,1] Especifica si los usuarios pueden determinar si Internet Explorer debe ser su explorador predeterminado.
  • 0 especifica que los usuarios pueden determinar si Internet Explorer es su explorador predeterminado.
  • 1 (opción predeterminada) especifica que los usuarios no pueden determinar si Internet Explorer es su explorador predeterminado.
Ir al principio

[Download]
Display=[0,1]
DownloadDir=nombre de carpeta
DownloadDirRO=[0,1]
DownloadOS=[0,1]
DownloadOSRO=[0,1]

Entradas en esta sección | Descripción
Display=[0,1] Determina si debe aparecer en el equipo del usuario la opción de descargar o instalar archivos.
  • 0 especifica que la opción de descarga o instalación de archivos no debe mostrarse al usuario.
  • 1 (opción predeterminada) especifica que la opción de descarga o instalación de archivos debe mostrarse al usuario.
DownloadDir=nombre de carpeta | Especifica la carpeta en la que se descargan los archivos. Si no se incluye esta opción, el programa de instalación crea una carpeta denominada Windows Update Setup Files en la unidad de disco que tiene más espacio disponible.
DownloadDirRO=[0,1] Especifica si los usuarios pueden cambiar la carpeta en la que se descargan los archivos.
  • 0 (opción predeterminada) especifica que los usuarios pueden cambiar la carpeta de descarga.
  • 1 especifica que los usuarios no pueden cambiar la carpeta de descarga.
DownloadOS=[0,1] Especifica que se deben descargar los archivos de un sistema operativo determinado; esta opción sólo es válida cuando se están descargando archivos sin instalarlos (DownloadOnly=1).
  • 0 (opción predeterminada) especifica el sistema operativo actual.
  • 1 especifica Windows 95, Windows 98, Windows Millennium Edition, Windows NT y Windows 2000.
DownloadOSRO=[0,1] Determina si los usuarios pueden especificar el sistema operativo de los archivos que se van a descargar en su equipo.
  • 0 (opción predeterminada) especifica que los usuarios pueden cambiar esta opción de configuración.
  • 1 especifica que los usuarios no pueden cambiar esta opción de configuración.
Ir al principio

[DownloadSite]
Display=[0,1]
DownloadLocation=dirección URL
DownloadSiteList=dirección URL

Entradas en esta sección | Descripción
Display=[0,1] Determina si se deben mostrar al usuario los sitios de descarga.
  • 0 especifica que no se deben mostrar al usuario los sitios de descarga.
  • 1 (opción predeterminada) especifica que se deben mostrar al usuario los sitios de descarga.
DownloadLocation=dirección URL | Especifica la dirección del sitio Web desde la que los usuarios deben descargar los archivos .CAB, si la distribución se hace a través del Web. Si ha utilizado la opción Display=0 para esta sección o cualquier otro modificador que haga que no se muestre esta página, deberá escribir un sitio de descarga.
DownloadSiteList=URL | Especifica la ubicación de la lista de sitios de descarga; como opción predeterminada, esta lista está incluida en el archivo Ie5sites.dat. Si no se incluye esta opción, el programa de instalación utiliza los parámetros existentes en el archivo Iesetup.inf.
Ir al principio

[PrepareSetup]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Determina si se debe mostrar la pantalla Preparando la instalación en el equipo del usuario.
  • 0 especifica que no se debe mostrar.
  • 1 (opción predeterminada) especifica que se debe mostrar.
Ir al principio

[Diskspace]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Especifica si se debe mostrar en el equipo del usuario la cantidad necesaria de espacio en disco.
  • 0 especifica que la cantidad necesaria de espacio en disco no se debe mostrar en el equipo del usuario. Si el usuario no tiene espacio en disco suficiente, el programa de instalación se cerrará.
  • 1 (opción predeterminada) especifica que la cantidad necesaria de espacio en disco debe mostrarse en el equipo del usuario.
Ir al principio

[Progress]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Especifica si se debe mostrar al usuario el desarrollo del proceso de instalación.
  • 0 especifica que no se debe mostrar.
  • 1 (opción predeterminada) especifica que se debe mostrar.
Ir al principio

[RebootPartial]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Determina si se debe mostrar la pantalla Instalación incompleta cuando falla la instalación de algún componente.
  • 0 especifica que no se debe mostrar
  • 1 (opción predeterminada) especifica que se debe mostrar la pantalla Instalación incompleta cuando falla la instalación de algún componente.
Ir al principio

[Finish]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Especifica si se debe mostrar el mensaje que indica que el equipo se reinicia al haber terminado la instalación.
  • 0 especifica que no se debe mostrar el mensaje. Si piensa desactivar el reinicio posterior a la instalación, use 0.
  • 1 (opción predeterminada) especifica que se debe mostrar el mensaje que indica que el equipo se reinicia al haber terminado la instalación.
Ir al principio

[Reboot]
Reboot=[0,1]

Entradas en esta sección Descripción
Reboot=[0,1] Especifica si se debe reiniciar el equipo al terminar el proceso de instalación.
  • 0 especifica que no desea reiniciar el equipo al terminar el proceso de instalación. Si desactivó el reinicio, el programa debe ocuparse de reiniciar el equipo. Internet Explorer no se configurará correctamente hasta que se reinicie el equipo.
  • 1 (opción predeterminada) especifica que desea reiniciar el equipo al terminar el proceso de instalación.
Ir al principio

[Upgrade]
ReinstallAll=[0,1]

Entradas en esta sección Descripción
ReinstallAll=[0,1] Especifica si se deben volver a instalar todos los componentes en el caso de que el programa de instalación se ejecute por segunda vez.
  • 0 (opción predeterminada) especifica que no se ejecute nuevamente el programa de instalación si ya están instalados todos los componentes.
  • 1 especifica que deben volver a instalarse todos los componentes.
Ir al principio


Modificadores de la instalación por lotes de IExpress

El Asistente para IExpress le ayuda a pasar modificadores de instalación de un programa a otro. Al utilizar IExpress con modificadores de Internet Explorer, éstos se colocan dentro de la expresión de IExpress de la forma siguiente:

Ie5setup <modificadores de IExpress> /c:" ie5wzd <modificadores de Internet Explorer>"

Modificadores de IExpress

A continuación se muestran los modificadores de IExpress más utilizados que controlan el proceso de extracción durante la instalación. Estos modificadores no son específicos para Internet Explorer:

Modificador | Acción
/Q | Especifica el modo silencioso, o suprime las preguntas al usuario, cuando se extraen los archivos. Este modificador no suprime las preguntas mientras se ejecuta la instalación de Windows Update.
/Q:U | Especifica el modo silencioso de usuario, que le muestra algunos cuadros de diálogo.
/Q:A | Especifica el modo silencioso de administrador, que no muestra ningún cuadro de diálogo al usuario.
/C:<ubicación UNC> | Especifica la ruta de acceso y nombre de los archivos .INF o .EXE de la instalación.
/R:N | Nunca reinicia el equipo después de la instalación.
/R:A | Siempre reinicia el equipo después de la instalación.
/R:S | Reinicia el equipo después de la instalación sin consultar al usuario.
/T:<ruta de acceso de directorios> | Especifica la carpeta de destino desde la que se extraen los archivos.

Para obtener más información acerca de IExpress, consulte Tecnología IExpress y Asistente para IExpress.

Para obtener una lista completa de los modificadores de instalación de Internet Explorer, consulte Modificadores de la instalación por lotes de Internet Explorer.


Tecnología IExpress y Asistente para IExpress

La tecnología IExpress se ha diseñado para simplificar la creación de los programas de instalación. Mediante el asistente paso a paso para IExpress, puede crear archivos autoextraíbles que ejecuten automáticamente el programa de instalación que contienen. El programa de instalación puede crearse mediante un archivo .INI o un archivo ejecutable. La tecnología IExpress quita automáticamente los archivos de instalación una vez terminada la misma, lo que ahorra tiempo y frustraciones al usuario.

El Asistente para IExpress puede ayudarle a realizar instalaciones especializadas del paquete del explorador personalizado, al determinar, por ejemplo, si el equipo necesita o no ser reiniciado después de la instalación. Puede encontrar el asistente para IExpress (IExpress.exe) en la carpeta \<carpeta de programa IEAK>\Tools. Algunas opciones que seleccione en el asistente corresponden a determinados modificadores para instalación por lotes.

IExpress emplea un archivo de directiva de extracción automática (.SED) para almacenar información relativa al paquete. Cuando ejecute el Asistente para IExpress, puede empezar con un archivo .SED existente o crear uno nuevo mediante el asistente. El archivo .SED contiene información e instrucciones acerca del paquete de instalación.

Si está generando un archivo autoextraíble con IExpress y el idioma de este archivo es distinto del idioma del Asistente para la personalización de Internet Explorer, copie los archivos Wextract.exe y Advpack.dll de la carpeta \<carpeta de programa IEAK>\Iebin\<lang>\Optional en la carpeta \<carpeta de programa IEAK>\Tools (donde se encuentran los archivos Iexpress.exe, Makecab.exe, W95inf32.dll y W95inf16.dll). Incluya el archivo advpack.dll en el paquete.

Características de la tecnología IExpress

  • Instalación silenciosa y no interactiva de Internet Explorer.
  • Permite realizar actualizaciones sin necesidad de quitar una instalación anterior.
  • Permite actualizar o instalar sobre la misma versión.
  • Instalación sin necesidad de reiniciar equipos que ejecuten Windows 98 OSR2.

Opciones de configuración que pueden especificarse en los archivos .INF utilizados por IExpress

  • Determinar si el paquete que se instala automáticamente es para administradores o para usuarios en general.
  • Establecer múltiples formas de ejecutar el comando de instalación incrustado, como los modos normal o silencioso.
  • Determinar si se actualizarán las bibliotecas de vínculos dinámicos (archivos .DLL) de IExpress en el equipo del usuario, si son anteriores a las actuales.
  • Especificar versiones de destino, como el intervalo de versiones del sistema operativo, el intervalo de versión del explorador o el intervalo de versión de cualquier aplicación (identificado por una o varias versiones de archivo), con las que el paquete es compatible.
  • Determinar, en el modo de instalación por lotes, si cuando se esté ejecutando otra copia del paquete se indicará al usuario que evite que ambos paquetes se ejecuten simultáneamente o no realice ninguna acción.
  • Actualizar y agregar archivos al paquete de IExpress con la herramienta UPDFILE sin tener que volver a construir el paquete.
  • Reemplazar Runonce con RunOnceEx (si hay una versión más reciente del archivo Iernonce.dll), suministrando control al autor sobre la orden de ejecución del trabajo y la presentación del estado.
  • Proporcionar un mecanismo para que los administradores corporativos configuren la compatibilidad necesaria para los usuarios móviles.
  • Proporcionar a los ICP e ISP una forma de generar paquetes que incluyan escritorios configurados previamente que presenten contenido personalizado al usuario.
  • Proporcionar compatibilidad para múltiples sitios de descarga.
  • Proporcionar compatibilidad para desarrollos internos y externos, personalización, capacidad de ampliación y depuración avanzada.
  • Ahorrar espacio en disco mediante la limpieza del disco duro (Papelera de reciclaje, Occache, caché Wininet, carpeta Temp) durante la instalación, desinstalación y en modo de mantenimiento.
  • Proporcionar compatibilidad para el juego de caracteres extendidos distinto de SBCS.
  • Permitir el uso del formato de archivo .INF al descargar componentes de Internet.

Para obtener más información, consulte Trabajar con archivos de información para la instalación (.INF).


Modificadores de la instalación por lotes de Internet Explorer

A veces puede ser aconsejable controlar la manera en que se ejecuta la instalación de Windows Update en los equipos de los usuarios. Puede utilizar modificadores de la línea de comandos para elegir el modo de instalación, especificar un modo silencioso (que quita o reduce las preguntas que se hacen al usuario) o controlar si el equipo se reiniciará después de la instalación.

Puede hacer que los usuarios incluyan estos modificadores al ejecutar la instalación de Windows Update, pero lo más normal es empaquetar Internet Explorer con otro programa, como IExpress, para realizar una instalación por lotes.

Modificadores de Internet Explorer

Puede utilizar los modificadores siguientes para controlar la instalación de Internet Explorer:

Modificador | Acción
/Q | Especifica un modo silencioso no interactivo. Únicamente se pedirá al usuario la información que no esté especificada.
/Q:A | Especifica un modo silencioso sin ninguna pregunta al usuario.
/Q:C | Especifica un modo silencioso que no muestra el botón Cancelar, de forma que el usuario no pueda cancelar la instalación. El Asistente para la personalización de Internet Explorer utiliza este modificador si selecciona la opción Instalar paquete silenciosamente cuando lo instala como administrador corporativo.
/B:nombre del archivo | Especifica el archivo de comandos por lotes que se utilizará.
/M[:{0|1|2|3...10}] Especifica el modo de instalación. Para paquetes de IEAK personalizados, 0 hace referencia a la primera opción de instalación, 1 a la segunda opción y así sucesivamente. Por ejemplo, 0=mínima, 1=típica y 2=completa. Puede especificar un máximo de diez modos de instalación en el IEAK.

Si el modificador /M se utiliza sin número, el programa de instalación supone que no se ha especificado ningún modo y únicamente instala los componentes especificados. Si no se usa, el programa de instalación emplea el modo predeterminado especificado en el archivo .INF.
/E:IdComponente[, ...] | Especifica componentes adicionales que se deben instalar con independencia del modo de instalación. Utilice este modificador para especificar componentes que no forman parte del tipo de instalación especificado en el Asistente para la personalización. Este modificador pasa por alto lo especificado en el archivo de texto por lotes, en el caso de que se utilice. IdComponente es una cadena de texto que identifica de forma exclusiva un componente; puede encontrar la cadena que corresponde a cada componente en su sección dentro del archivo Iesetup.cif.
/S:""#e"" Indica la ruta de acceso de origen de Ie5setup.exe. ""#e"" hace referencia a la ruta de acceso y el nombre completos del archivo .EXE.

Nota

  • La ruta de acceso debe estar entre dos pares de dobles comillas.
/R:N | Indica que no se reinicie el equipo después de la instalación. Si el equipo no se reinicia después de la instalación de Windows Update, la instalación del componente personalizado deberá reiniciarlo. Internet Explorer no se configurará correctamente hasta que se reinicie el equipo.
/D | Especifica que desea descargar únicamente los archivos para el sistema operativo actual.
/D:1 | Especifica que desea descargar los archivos para los sistemas operativos Microsoft Windows y Windows NT.
/G:sección[, ...] | Ejecuta las secciones de instalación especificadas en el archivo Iesetup.inf. Las distintas secciones se separan mediante comas.
/X | Instala Internet Explorer sin shell, iconos ni vínculos. Esta opción es útil para almacenar los controles del explorador en su propia aplicación.
/X:1 | Instala Internet Explorer con shell, iconos y vínculos, pero no suplanta las asociaciones predeterminadas de explorador o protocolo http.
/P | Informa acerca de los componentes y espacio en disco necesarios para realizar una instalación. Esta opción permite ver cuánto espacio en disco va a utilizarse en función de las opciones de instalación seleccionadas. Para obtener más información, consulte la sección Estimar el tamaño de la instalación de Internet Explorer, en este mismo tema.

Nota

  • Si instala Internet Explorer en un equipo en el que nunca se ha ejecutado Internet Explorer 4 y desea que los usuarios dispongan de canales, incluya el paquete de exploración sin conexión como parte de los componentes de cada opción de instalación. En caso de que dicho componente no esté incluido en todas las opciones de instalación, agregue el paquete de exploración sin conexión como un componente requerido mediante el modificador /E: con MobilePk como identificador de componente.

Modificadores de línea de comandos de Internet Explorer utilizados con IExpress

El Asistente para IExpress le ayuda a pasar modificadores de instalación de un programa a otro. Al utilizar IExpress con modificadores de Internet Explorer, estos modificadores se colocan dentro de la expresión de IExpress de la forma siguiente:

Ie5setup <modificadores de IExpress> /c:" ie5wzd <modificadores de Internet Explorer>"

Si desea obtener una lista completa de los modificadores de la instalación de IExpress, consulte Modificadores de la instalación por lotes de IExpress.

Ejemplos

A continuación se incluyen algunos comandos de ejemplo utilizados para instalar Internet Explorer.

  • La expresión siguiente realiza una instalación silenciosa. No precisa la intervención del usuario y el equipo no se reinicia después de la instalación:

    ie5setup.exe /C:"ie5wzd /S:""#e"" /Q /R:N"

  • La expresión siguiente pasa por alto la lista de sitios de Ie5sites.dat e instala Internet Explorer desde la ubicación especificada. Se trata de una expresión única que se presenta en varias líneas de texto, lo que mejora su legibilidad.

    ie5setup.exe
    /C:"ie5wzd
    /S:""\\suservidor.com\directorio\ie5setup.exe"""

    Esta expresión se puede usar para indicar a los usuarios otra ubicación de descarga, por ejemplo, en otro país o región, sin tener que generar de nuevo su paquete IEAK.

Estimar el tamaño de la instalación de Internet Explorer

Puede utilizar los modificadores por lotes de Internet Explorer para pasar a su paquete personalizado del IEAK información acerca de la instalación de Internet Explorer. Hay dos razones principales para ello: mostrar la cantidad de espacio de disco necesario para instalar Internet Explorer (en función de las opciones elegidas por el usuario) y proporcionar información acerca del desarrollo del proceso de instalación.

Al utilizar el modificador /P, esta información queda almacenada en el Registro durante la instalación. De acuerdo con esta información, el programa de instalación de Windows Update devuelve la siguiente información adicional a la sección HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo del Registro:

Subclave | Tipo de datos | Valor
InstallSize | Cadena | número de KB (tamaño real de la instalación).
AdminRights | Datos binarios | 1 o 0
EstimatedCopy | Cadena | número de KB Este valor normalmente es mayor que InstallSize, ya que el proceso de instalación necesita más espacio. Se utiliza como estimación de la apariencia que tendrá la información acerca del desarrollo del proceso en formato de "medidor de combustible".

Códigos de retorno y estado de la instalación de Windows Update

Después de instalar una aplicación o si ésta falla, el programa de instalación tiene que informar del resultado del proceso. Dado que IE5wzd.exe está incluido en Ie5setup.exe, los códigos de retorno no se pueden devolver directamente. En su lugar, el programa de instalación devuelve esa información después de la instalación por medio de la sección HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo del Registro. Cualquier Failed HResult que aparezca en esta sección indica que se ha producido algún error.

Subclave | Tipo de datos | Valor
Complete | Cadena | DWORD refleja el parámetro HRESULT del programa de instalación, como se muestra a continuación:
 |  | 0 | Correcto
 |  | 0x80100003 | Faltan archivos necesarios para la instalación solicitada.
 |  | 0x80100001 | El programa de instalación se ha realizado correctamente de forma parcial. Uno o varios componentes no se han descargado o instalado. Busque en la subclave FailedComponents la lista de componentes.
 |  | 0x80100002 | El programa de instalación se ha realizado correctamente de forma parcial, pero el usuario ha cancelado la instalación. Uno o varios componentes no se han descargado o instalado.

Para los elementos que no se han instalado correctamente, el programa de instalación también devuelve la información siguiente:

Subclave | Tipo de datos | Valor
FailedComponents | MultiSZ | <Nombre de los componentes en CIFID>null<Nombre de componente...>
InstallStatus | Datos binarios | 0 | Instalación completada correctamente.
 |  | 1 | Suspender la instalación. El usuario canceló el programa de instalación y se le pide que lo confirme.
 |  | 2 | No cancelar, reanudar la instalación.
 |  | 3 | Sí, se confirma la cancelación, salir del programa de instalación lo antes posible. En algunos casos puede ser necesario completar alguna tarea que se esté ejecutando, como copiar o extraer archivos.


Actualizar periódicamente a los usuarios

Los usuarios pueden recibir automáticamente un aviso cuando haya disponible una nueva versión de Internet Explorer. Puede controlar si desea que Internet Explorer compruebe esos avisos y, si lo hace, con qué frecuencia debe hacerlo.

A continuación se explica cómo funciona este sistema:

  • Cuando se detecta una nueva versión de Internet Explorer, la página principal, o de inicio, del usuario se reemplaza temporalmente por una página de aviso de actualización. Desde esta página los usuarios pueden actualizar su explorador, agregar la página a la lista Favoritos o cancelar la actualización.
  • Como opción predeterminada, se utiliza como página de aviso de actualización la página de Microsoft Internet Explorer para Microsoft Windows Update. En lugar de dicha página, puede mostrar una página Web que proporcione información actualizada de productos o incluso noticias de la organización. Por ejemplo, podría crear una página Web para notificar a los usuarios la aparición de nuevas versiones de Internet Explorer o suministrarles nuevas rutas de acceso de servidor y noticias de la empresa.

    La página de aviso de actualización le permite distribuir periódicamente información en formato .HTM a los usuarios. Si desea distribuir esta información a los usuarios mediante el uso de canales y el formato .CDF, esta funcionalidad continúa estando disponible.

  • La siguiente vez que el usuario inicie el explorador, aparecerá la página principal predeterminada del usuario.

Mediante los pasos siguientes puede especificar la configuración de la página de aviso de actualización:

  1. Si cambia la configuración por medio del Asistente para la personalización de Internet Explorer, en la pantalla de Directivas y restricciones del paso 5, haga clic en Configuración de Internet.

    O bien

    Si cambia la configuración por medio del Administrador de perfiles, haga clic en Directivas y restricciones y, después, haga clic en Configuración de Internet.

  2. Active la casilla de verificación Comprueba automáticamente las actualizaciones de Internet Explorer.
  3. En la parte izquierda de la pantalla, haga clic en Actualizaciones de componentes.
  4. Si desea usar la página predeterminada de Windows Update, no sustituya la dirección URL predeterminada.

    Si desea utilizar una página personalizada, escriba la dirección de la página en el cuadro Dirección URL que se mostrará para las actualizaciones.

  5. En Intervalo de comprobación de actualizaciones, especifique el número de días que transcurrirán entre dos comprobaciones sucesivas de la información de actualización.

En caso de que decida crear una página personalizada para su organización, consulte el archivo de ejemplo ieupdate.htm, que se encuentra en la carpeta \<carpeta de programa IEAK>\Toolkit.

Nota

  • En la sección Restricciones de Internet, en las páginas Administrador de perfiles y Directivas y restricciones del asistente, puede elegir si se realizará una comprobación periódica de las actualizaciones de Internet Explorer y las herramientas de Internet en la pantalla Actualizaciones de componentes.


Detección y configuración automática de las opciones del explorador

Puede configurar la red de forma que Internet Explorer se personalice automáticamente la primera vez que se inicie. Esto puede ayudar a reducir el trabajo de administración y el número de llamadas a su servicio de asistencia técnica acerca de la configuración del explorador.

La detección automática de la configuración del explorador, que se basa en el protocolo Descubrimiento automático de proxy Web (WPAD, Web Proxy AutoDiscovery), es compatible con los protocolos de configuración dinámica de host (DHCP, Dynamic Host Configuration Protocol) y sistema de nombres de dominio (DNS, Domain Name System). Con la configuración adecuada, los servidores DHCP y DNS pueden detectar automáticamente un explorador y configurarlo. Esta característica se basa en tecnologías de configuración automática existentes, mediante las que un explorador puede configurarse desde una ubicación central con una configuración automática de direcciones URL (archivo .INS) o con un archivo Javascript para la configuración del proxy (.JS, .JVS, o .PAC).

Con la detección automática, el explorador puede configurarse automáticamente cuando se inicia aunque el administrador no lo haya personalizado previamente. Por ejemplo, si un usuario va a descargar un explorador sin personalizar desde Internet, en lugar de instalar una versión personalizada de los servidores corporativos, la detección automática puede configurar y personalizar automáticamente el explorador del usuario.

Para especificar en IEAK que desea establecer la detección automática de la configuración del explorador, seleccione Detectar configuración automáticamente en la pantalla Configuración automática del Asistente para la personalización de Internet Explorer. Puede ver un ejemplo del proceso de configuración automática en Cómo funciona la configuración automática.

Detección automática de la configuración del explorador para DHCP y DNS

Los servidores DHCP permiten al administrador especificar de forma central parámetros de TCP/IP globales y específicos de una subred, y definir parámetros para clientes mediante el uso de direcciones reservadas. Cuando un equipo cliente se mueve entre subredes, la configuración de TCP/IP se vuelve a establecer automáticamente cuando se inicia el equipo.

Importante

  • El servidor DHCP debe admitir el mensaje DHCPINFORM, al igual que lo hace en Windows 2000.

DNS es un conjunto de protocolos y servicios en una red TPC/IP que permite a los usuarios buscar en otros equipos que utilicen nombres descriptivos jerárquicos, también conocidos como "hosts", en lugar de direcciones IP numéricas.

Si utiliza DHCP con detección automática, obtendrá mejores resultados con usuarios de redes de área local, mientras que DNS habilita la detección de la configuración tanto para usuarios de redes de área local como de acceso telefónico. Aunque DNS puede controlar a usuarios de red y de acceso telefónico, DCHP proporciona un acceso más rápido para usuarios de una red de área local y les ofrece una mayor flexibilidad al configurar archivos.

Para habilitar la detección automática de los valores del explorador, tiene que configurar algunos valores en servidores DNS, en servidores DHCP o en ambos.

Para obtener más información, consulte los temas siguientes:

Habilitar la detección automática de la configuración del explorador en DHCP

Para establecer la detección automática de la configuración del explorador en un servidor DHCP, debe crear un nuevo tipo de opción con el número de código 252. Como valor asociado con el código, escriba la dirección URL que señala a su archivo de configuración. Este archivo puede ser un archivo de configuración de tipo .PAC, .JVS, .JS o .INS.

Para obtener información específica acerca de cómo configurar un servidor DHCP, consulte la documentación del servidor.

Ejemplos

http://www.microsoft.com/webproxy.pac

http://marketing/config.ins

http://###.#.###.#/account.pac

Habilitar la detección automática de la configuración del explorador en DNS

Para habilitar la detección automática de la configuración del explorador en un sistema DNS, tiene que configurar el registro del host o bien el registro con "alias" CNAME en la base de datos del archivo de DNS.

Registro de host

Un registro de host se utiliza para asociar estáticamente nombres de equipos host a direcciones IP dentro de una zona. Contiene entradas para todos los hosts que necesitan asignaciones estáticas, como estaciones de trabajo, servidores de nombres y servidores de correo.

La sintaxis es: <nombre del host> IN A <dirección IP del host>

Por ejemplo:

corserv | IN | A | 192.55.200.143
nombreDelServidor2 | IN | A | 192.55.200.2
servidorDeCorreo1 | IN | A | 192.55.200.51

registro CNAME

A veces a estos registros se les denomina "alias" pero nos referimos a ellos técnicamente como entradas de "nombre canónico" (CNAME). Estos registros permiten utilizar más de un nombre para señalar a un solo host. El uso de nombres canónicos facilita, por ejemplo, tener en un mismo equipo un servidor FTP y un servidor Web.

Para configurar un archivo de base de datos de DNS para la detección automática de la configuración del explorador

  • En el archivo de base de datos DNS, escriba un registro de host llamado wpad que señale a la dirección IP del servidor Web que contiene el archivo de configuración automática .PAC, .JVS, .JS o .INS.

    O bien escriba un alias CNAME llamado wpad que señale al nombre (el nombre resuelto, no la dirección IP) del servidor Web que contiene el archivo de configuración automática .PAC, .JVS, .JS o .INS.

Notas

  • Después de que se agrega al registro y de que el archivo de la base de datos se propaga al servidor, el nombre del DNS wpad.dominio.com debería convertirse en el mismo nombre de equipo que el servidor que contiene los archivos de configuración automática.

  • Cuando utilice DNS, Internet Explorer creará una plantilla predeterminada de dirección URL basada en el nombre del host wpad.

    Por ejemplo:

    http://wpad.dominio.com/wpad.dat

    Por lo tanto, en el servidor Web wpad, debe configurar un archivo o un punto de redirección llamado wpad.dat que suministre el contenido del archivo de configuración automática.


Administrar la instalación a petición

Cuando los usuarios instalan Internet Explorer, pueden elegir sólo los componentes que deseen para controlar el espacio en disco utilizado y reducir el tiempo de descarga y de instalación. Sin embargo, cuando los usuarios comienzan a explorar el Web pueden descubrir que necesitan componentes adicionales.

Cuando los usuarios visitan una página Web que precisa de un programa o componente que no está instalado, el programa de instalación a petición les pregunta si desean instalar los componentes necesarios.

Como administrador corporativo o ISP, puede controlar esta característica por medio del IEAK.

Nota

  • Si piensa que su organización utilizará la función de instalación a petición a través de Internet, debe firmar los archivos .CAB y especificar en la configuración de seguridad que el servidor que aloja los archivos .CAB es un servidor de confianza. En el caso específico de un sitio de intranet se puede seleccionar también un nivel bajo de seguridad. Para obtener más información, consulte Firmar sus programas.

    Si el nivel de seguridad de su intranet es medio o superior, y está especificando los servidores de red como servidores de confianza, tendrá que hacer lo siguiente:

    1. En la página Configuración de seguridad del asistente, haga clic en Personalizar la configuración de zonas de seguridad y, a continuación, haga clic en Modificar configuración.
    2. Seleccione la zona Intranet local y, después, haga clic en Sitios.
    3. Desactive la casilla de verificación Incluir todas las rutas de red (UNC) y haga clic en Aceptar.
    4. Seleccione la zona Sitios de confianza, haga clic en Sitios, escriba la ruta de acceso del servidor de descarga y, después, haga clic en Agregar.
    5. Repita el paso anterior para cada servidor de descarga que desee especificar como servidor de confianza.


Administrar la Actualización del escritorio de Windows

La Actualización del escritorio de Microsoft Windows hace que el escritorio y las carpetas tengan la misma apariencia que el Web. Aunque el programa de actualización del escritorio de Windows no forma parte de Internet Explorer 5 (o posteriores), puede incluirlo en el paquete IEAK. Si los usuarios están ejecutando Windows 98, Windows 98 Segunda edición, Windows Millennium Edition o Windows 2000, ya disponen de las características de escritorio.

Para poder instalar y personalizar la Actualización del escritorio de Windows, el equipo debe ejecutarla en una de las siguientes configuraciones:

  • Windows 98
  • Windows 98 Segunda Edición
  • Windows Millennium Edition
  • Windows 2000
  • En otras versiones de Windows deberá utilizar Internet Explorer 5.5 actualizado desde Internet Explorer 4.0 con la Actualización del escritorio de Windows instalada.

La actualización puede ser muy útil a la hora de definir escritorios estándar para empresas.

Una vez que la Actualización del escritorio de Windows esté instalada, los usuarios podrán examinar sus equipos como si estuvieran explorando el Web. Las características de exploración Web y los menús de Internet Explorer Ir a y Favoritos están disponibles en Windows. Los usuarios también pueden agregar "contenido activo", como un indicador de cotizaciones, a la barra de tareas o a las carpetas de su escritorio, así como abrir y ejecutar archivos con un único clic.

Puede controlar si los usuarios están autorizados o no a cambiar esta configuración, así como la configuración de la seguridad y de proxy. Puede especificar esta configuración en la pantalla Directivas y restricciones del paso 5 del Asistente para la personalización de Internet Explorer o por medio del Administrador de perfiles de IEAK. De esta manera puede controlar los perfiles de forma continuada mediante la característica de configuración automática.

Nota

  • En caso de que incluya la actualización del escritorio de Windows como un componente del paquete IEAK, el idioma utilizado en el paquete debe coincidir con el del sistema operativo del usuario. Si los usuarios intentaran instalar el explorador y la Actualización del escritorio de Windows en un idioma diferente, sólo se instalaría el explorador.


Descripción de la configuración y restricciones

Las directivas de sistema y restricciones para Internet Explorer constituyen un eficaz mecanismo que permite mejorar el control y la administración de los equipos. Estas directivas y restricciones, definidas en un archivo de directiva, controlan los privilegios de acceso de usuarios y equipos; para ello, suplantan valores predeterminados del Registro cuando el usuario inicia una sesión.

Puede utilizar el Asistente para la personalización de Internet Explorer con el fin de definir previamente las directivas de sistemas y restricciones, y crear una configuración estándar de Internet Explorer como parte del paquete del explorador personalizado. Tras instalar Internet Explorer, podrá utilizar el Administrador de perfiles de IEAK para administrar y actualizar las directivas de sistema y restricciones en los equipos de los usuarios desde una ubicación central. Asimismo, si hay distintos tipos de usuarios con necesidades únicas, puede utilizar el Administrador de perfiles de IEAK para crear archivos de directiva (.INS) para cada grupo.

Por ejemplo, podría implementar directivas de sistema y restricciones para conseguir lo siguiente:

  • Determinar las características que los usuarios pueden cambiar, como las barras de herramientas de Active Desktop e Internet Explorer.
  • Administrar el ancho de banda y controlar el comportamiento y la apariencia de Internet Explorer.
  • Especificar listas de servidores para los componentes, como Microsoft NetMeeting, y configurar una página para actualizar los usuarios periódicamente.
  • Determinar qué programas se usan para correo electrónico y para realizar llamadas en Internet.
  • Predeterminar la configuración de las conexiones del usuario. Si necesita administrar varias configuraciones de conexión, considere la posibilidad de importar un perfil personalizado desde el Kit de administración del Administrador de conexión (CMAK).

Para ver un ejemplo de esta característica, consulte Directivas del sistema y configuración.

Ventajas del uso de directivas del sistema y restricciones

Mediante la implementación de las directivas de sistema y restricciones, las organizaciones pueden obtener las siguientes ventajas:

  • Permiten implementar una configuración estándar de Internet Explorer. Es posible crear un paquete personalizado del explorador para los usuarios que incluya opciones de configuración frecuentes para las características y funciones del mismo.
  • Permiten restringir las características a las que los usuarios pueden tener acceso en Internet Explorer. Por ejemplo, es posible predefinir las opciones de NetMeeting para controlar el acceso a los elementos de audio y vídeo. Asimismo, existe la opción de bloquear determinadas características y funciones, de modo que no aparezcan o aparezcan atenuadas en los escritorios de los usuarios.
  • Permiten cambiar los valores predeterminados del Registro. Es posible utilizar la configuración de una directiva para cambiar los valores del Registro de varios equipos, lo que evita tener que especificar las opciones de configuración individualmente en cada uno de los equipos de los usuarios.

Factores que deben tenerse en cuenta al definir las directivas de sistema y las restricciones

Al implementar las directivas de sistema y las restricciones, debe tener en cuenta las cuestiones siguientes:

  • ¿Qué tipos de directivas de sistema y restricciones desearía definir y administrar de forma centralizada? Por ejemplo, ¿desea limitar el acceso a las características de NetMeeting?
  • ¿Desea usar un conjunto de directivas de sistema y restricciones para todos los usuarios y equipos, o crear varios archivos de directiva para grupos de usuarios? Probablemente cada grupo de usuarios tendrá necesidades distintas.
  • ¿Qué tipos de configuración de seguridad desea implementar? Puede bloquear todas las opciones de configuración, de modo que pueda controlarlas y, al mismo tiempo, permitir que los usuarios móviles puedan descargarlas, o bien personalizar las opciones mientras permite que los usuarios las modifiquen.

    Debe tener en cuanta el posible efecto de estas configuraciones, especialmente si hay usuarios móviles que comparten los equipos con otros usuarios. Por ejemplo, ¿qué implicaciones tendría el hecho de quitar los iconos del escritorio o impedir que los usuarios cambien su configuración de seguridad? Asegúrese de que los usuarios comprenden a qué características pueden tener acceso.

  • ¿Desea almacenar los archivos de directiva en una ubicación central o en los equipos de los usuarios? Quizá prefiera almacenar el archivo en un servidor, de modo que los usuarios móviles puedan tener acceso a la configuración desde distintos equipos. Esto podría resultar útil, por ejemplo, para un usuario que necesita una configuración de seguridad baja pero que utiliza un equipo en el que normalmente trabaja alguien con una configuración de seguridad más restringida.

Cómo administrar las directivas y restricciones para Windows NT y Windows 2000

Todas las directivas de sistema y restricciones que puede definir en el Asistente para la personalización de IEAK y administrar posteriormente en el Administrador de perfiles del IEAK pueden configurarse para usuarios que utilicen los sistemas operativos Windows 95, Windows 98 y Windows Millennium Edition.

Sin embargo, en las plataformas Windows NT o Windows 2000 sólo podrá configurar un subconjunto de estas directivas de sistema y restricciones para los usuarios sin privilegios de administrador. En lugar de ello, es aconsejable que use el Editor de directivas de Windows NT o el Editor de directivas de Windows 2000 para configurar las directivas y restricciones restantes correspondientes a dichos usuarios. Para obtener más información, consulte Administrar Microsoft Internet Explorer en Windows 2000.

Establecer y administrar las directivas de sistema y las restricciones

Puede definir las directivas y restricciones de dos formas distintas:

  • En el paso 5 del Asistente para la personalización de Internet Explorer.
  • En el Administrador de perfiles, mediante la configuración automática.

Para utilizar el Administrador de perfiles, cree un nuevo perfil de usuario o abra uno ya existente. Después, expanda las carpetas hasta que vea la configuración o restricción que desea cambiar. Puede encontrar más información acerca de la categoría Directivas y restricciones si hace clic en la carpeta de esa categoría.

Con la configuración automática, la configuración y restricciones del explorador se mantienen en la ubicación que especifique en el Asistente para la personalización de Internet Explorer o en el cuadro de diálogo Opciones de Internet.

Para comprobar los valores de configuración automática en los equipos de los usuarios:

  1. Haga clic en el menú Herramientas del explorador.
  2. Haga clic en Opciones de Internet.
  3. Haga clic en la ficha Conexiones y, después, haga clic en Configuración LAN.

    Compruebe que está seleccionada la opción Usar secuencia de comandos de configuración automática y compruebe la ruta de acceso del cuadro Dirección.

Crear y mantener directivas para los programas personalizados

Cuando utilice el Asistente para la personalización de Internet Explorer, puede usar las directivas y restricciones que haya configurado en sus propios archivos .ADM. Para ello, haga clic en Directiva y, después, en Importar. Puede encontrar archivos .ADM que es posible personalizar en el idioma apropiado para la carpeta de directivas de IEAK.


Utilizar la selección de proxy y las listas de derivación de servidores proxy

El uso de un servidor proxy permite al administrador limitar el acceso a Internet. Puede especificar un servidor proxy en el Asistente para la personalización de Internet Explorer, en el Administrador de perfiles de IEAK y por medio del explorador. También puede restringir la capacidad del usuario para cambiar la configuración del proxy por medio de la página Directivas y restricciones del Asistente para la personalización de Internet Explorer y del Administrador de perfiles.

Para obtener instrucciones detalladas acerca de cómo configurar la selección de proxy y la derivación de servidores proxy mediante IEAK, consulte las pantallas Configuración automática y Configuración de proxy del paso 4 del Asistente para la personalización de Internet Explorer.

Nota

  • La característica de derivación de servidores proxy puede evitar tener que utilizar JavaScript o JScript para seleccionar un servidor proxy.

Para configurar la selección de proxy y la derivación de servidores proxy en Internet Explorer

  1. Haga clic en el menú Herramientas en Internet Explorer y, después, haga clic en Opciones de Internet.
  2. Haga clic en la ficha Conexiones y, después, haga clic en Configuración LAN.
  3. En el área Servidor proxy, active la casilla de verificación Servidor proxy manual.
  4. Haga clic en Opciones avanzadas y escriba la ubicación de proxy y el número de puerto de cada protocolo Internet admitido.

    Notas

    • En la mayoría de los casos, sólo se utiliza un servidor proxy para todos los protocolos. En estos casos, escriba la ubicación del proxy y el número de puerto correspondiente a la opción HTTP y, a continuación, active la casilla de verificación Utilizar el mismo servidor proxy para todos los protocolos.
    • Se supone que las ubicaciones de proxy que no comiencen con un protocolo (como http://" o "ftp://") son proxy HTTP de tipo CERN. Por ejemplo, la entrada "proxy" se trataría igual que la entrada "http://proxy." En el caso de las puertas de enlace FTP, como la puerta de enlace FTP TIS y el proxy WinGate Win95 Modem FTP, el protocolo "ftp://" debe anteceder al nombre del proxy. Por ejemplo, la puerta de enlace FTP "ftpproxy" se debe escribir "ftp://ftpproxy".
  5. Para no utilizar direcciones más complejas, escriba las direcciones en el cuadro No usar proxy para las direcciones que comiencen con:.

    Una entrada de derivación de proxy puede comenzar con un tipo de protocolo, como http://, https://, ftp:// o gopher://. Si se utiliza un tipo de protocolo, la entrada de excepción sólo se aplica a las solicitudes de dicho protocolo. Tenga en cuenta que el valor del protocolo no distingue mayúsculas y minúsculas. Se deben separar varias entradas con un punto y coma (;).

    A continuación, se debe escribir una dirección Internet, una dirección IP o un nombre de dominio. Si no se especificó ningún protocolo, se derivarán las solicitudes que utilicen esa dirección. Si se especificó un protocolo, sólo se derivarán las solicitudes con la dirección si son del tipo de protocolo indicado. Como en el tipo de protocolo, las entradas de direcciones no distinguen mayúsculas y minúsculas.

    Finalmente, se puede agregar un número de puerto. Si se utiliza, la solicitud sólo se procesa si todos los requisitos previos se han cumplido y la solicitud usa el número de puerto especificado.

    El cuadro de diálogo de excepciones permite utilizar un carácter comodín ( * ) en lugar de cero o más caracteres.

Ejemplos de caracteres comodín

Puede usar caracteres comodín en las siguientes situaciones:

  • Escriba un comodín al principio de una dirección Internet, una dirección IP o un nombre de dominio para eludir los servidores que tengan una terminación común. Por ejemplo, use "*.ejemplo.com" para eludir cualquier entrada que termine con ".ejemplo.com" (por ejemplo, "algun.ejemplo.com" y "www.ejemplo.com").
  • Escriba un comodín en la mitad de una dirección Internet, una dirección IP o un nombre de dominio para eludir los servidores que tengan una terminación y un final común. Por ejemplo, la entrada "www.*.com" coincide con cualquier entrada que empiece con "www" y finalice con "com" (como "www.algunsitio.com", "www.casi.cualquiersitio.com", etc).
  • Escriba un comodín al final de una dirección Internet, una dirección IP o un nombre de dominio para eludir los servidores que tengan un comienzo común. Por ejemplo, use "www.algunlugar.*" para eludir cualquier entrada que comience con "www.algunlugar" (por ejemplo, "www.algunlugar.com", "www.algunsitio.org" y "www.algunsitio.mas.com").
  • Utilice varios comodines para eludir direcciones que tengan patrones similares. Por ejemplo, use "123.1*.66.*" para eludir direcciones como "123.144.66.12", "123.133.66.15" y "123.187.66.13".

Nota

  • Aunque los comodines son muy eficaces, debe utilizarlos con cuidado. Por ejemplo, la entrada "www.*.com," hará que Internet Explorer eluda el proxy de la mayoría de los sitios Web.


Administrar Microsoft Internet Explorer en Windows 2000

Puede utilizar Directiva de grupo para personalizar Microsoft Internet Explorer en equipos con Windows 2000 después de la distribución. Por ejemplo, es posible definir la página principal del usuario y personalizar sus vínculos favoritos. Directiva de grupo permite a los administradores de Windows 2000 controlar la configuración de usuarios y equipos en sitios, dominios y unidades de organización.

El método de inicio de Directiva de grupo depende del tipo de grupo que desee administrar. Para obtener más información acerca de cómo iniciar Directiva de grupo, consulte la Ayuda en pantalla de Directiva de grupo en Windows 2000.

Para obtener más información, consulte los temas siguientes:

Cómo usar Directiva de grupo para mantener y personalizar Internet Explorer

  1. En Directiva de grupo, haga clic en Configuración del usuario.
  2. Haga clic en Configuración de Windows y, después, en Mantenimiento de Internet Explorer.
  3. Seleccione el icono de la característica que desea cambiar.
  4. Haga doble clic en el título de la característica que desea administrar.
  5. Cambie las opciones de configuración que desee.

Notas

  • Si está utilizando el Administrador de perfiles de IEAK para administrar Internet Explorer en otras plataformas con configuración automática, puede ser aconsejable exportar la configuración de Directiva de grupo a un archivo .INS y, si procede, a archivos contenedores (.CAB). De esta manera, si define la configuración en Windows 2000, no será necesario que vuelva a hacerlo para utilizarla en otras plataformas.
  • Si usa el Kit de preinstalación de OEM, puede emplear el Asistente para la personalización de Internet Explorer con el fin de personalizar Windows 2000 antes de la distribución.
  • Si usa la instalación desatendida de Windows 2000, puede emplear el Administrador de perfiles de IEAK a fin de generar los archivos necesarios paramarcar el explorador. Para obtener más información, consulte la documentación de Windows 2000.

Configuración de la exportación de directivas de grupo para Internet Explorer

Puede utilizar Directiva de grupo en Windows 2000 para exportar toda la configuración de Internet Explorer a un archivo .INS y, si es necesario, a archivos contenedores (.CAB). Posteriormente podrá utilizar dicha configuración para configurar automáticamente equipos con otros sistemas operativos.

Para exportar la configuración de Internet Explorer en Windows 2000

  1. En Directiva de grupo, haga clic en Configuración del usuario.
  2. Haga clic en Configuración de Windows y, después, haga clic con el botón secundario del mouse (ratón) en la pantalla de Internet Explorer que contenga la configuración que desea exportar.
  3. Haga clic en Exportar configuración del explorador.
  4. Escriba el nombre del archivo .INS y, si procede, de los archivos contenedores (.CAB) a los que desea exportar la configuración.
  5. Escriba la dirección URL del servidor Web donde se encuentran los archivos.

Características que pueden configurarse con Directiva de grupo

Mediante Directiva de grupo es posible personalizar y administrar las siguientes áreas:

  • La interfaz del usuario y la apariencia del explorador
  • Configuración de las conexiones, como las de red de área local (LAN) y acceso telefónico, y las cadenas de agente de usuario
  • Direcciones URL personalizadas, como Favoritos, la barra de búsqueda y la página principal
  • Configuración de la seguridad, por ejemplo, zonas de seguridad y de las clasificaciones de contenido
  • Programas predeterminados para tareas frecuentes de Internet, como la lectura de correo electrónico y el acceso a grupos de noticias

Importante

  • Independientemente de las opciones de instalación configuradas para el paquete, el programa de instalación de Windows Update sólo presenta una opción de instalación para los usuarios que ejecuten el sistema operativo Windows 2000. Esta opción incluye todos los componentes de Internet de Microsoft, además de los componentes personalizados del paquete.


Instalar Internet Explorer con Microsoft Office

El Asistente para la instalación personalizada (CIW) de Microsoft Office le permite personalizar la manera en que distribuirá los programas de Office a los usuarios. Para simplificar el proceso de instalación, el IEAK ha sido diseñado para que funcione con el CIW.

Si piensa incluir Internet Explorer con el paquete personalizado de Office, tiene dos opciones:

  • Si no piensa personalizar Internet Explorer, puede instalar los componentes de Internet Explorer mediante el CIW, no es necesario que utilice el IEAK.
  • Si piensa incluir una versión personalizada de Internet Explorer como parte de la distribución de Office, haga clic en el botón Personalizar de la pantalla Personalizar las opciones de instalación de IE 5 del Asistente para la instalación de Office. El Asistente para la instalación personalizada iniciará el IEAK.

Ejecutar el IEAK desde el Asistente para la instalación personalizada de Office

El Asistente para la personalización de Internet Explorer se ejecuta en el modo de administrador corporativo con la configuración siguiente:

  • El medio de distribución es Simple (todos los archivos en una carpeta).
  • Hay dos opciones de instalación disponibles. Aunque los nombres de estas opciones no pueden modificarse, es posible especificar qué componentes se instalarán en cada opción de instalación.
  • Todos los archivos contenedores .CAB y los componentes personalizados que se crean con el IEAK se almacenan en la misma carpeta. El nombre predeterminado de esta carpeta es IE5_CUST.

Una vez que haya finalizado el paquete de personalización, en la pantalla Personalizar las opciones de instalación de IE 5 aparece el nombre de archivo y la ruta de acceso del programa de instalación de Windows Update (IE5Setup.exe).

Para utilizar el IEAK como parte del CIW, debe instalarse la versión adecuada de Internet Explorer e IEAK 5 en el equipo donde se está personalizando el paquete de instalación.

Nota

  • En los paquetes IEAK creados mediante el Asistente para la instalación personalizada de Office, las opciones del usuario del programa de instalación de Windows Update para Internet Explorer no se muestran durante la instalación. La interfaz de usuario del programa de instalación de Windows Update es la que determina el Asistente para la instalación personalizada de Office.


Cambiar desde otras versiones o productos

Antes de que sus empleados o clientes instalen Internet Explorer 5, debe identificar y resolver cualquier problema que pueda presentarse.

Actualizar desde Internet Explorer 5

El programa de instalación de Internet Explorer permite realizar una instalación sobre una versión instalada de Internet Explorer 5 e importa las opciones de configuración de proxy, favoritos y los cookies de la versión anterior.

Actualizar desde Internet Explorer 4

El programa de instalación de Internet Explorer permite realizar una instalación sobre una versión instalada de Internet Explorer 4 e importa las opciones de configuración de proxy, favoritos y los cookies de la versión anterior. Sin embargo, deberá volver a instalar los complementos que desee conservar.

Internet Explorer 4 e Internet Explorer 5.x pueden ejecutarse simultáneamente en el mismo equipo.

Si desea que los usuarios tengan Active Desktop de Internet Explorer 4.0, puede incluir el escritorio en los paquetes del explorador Internet Explorer para los usuarios de Windows 95 y Windows NT 4.0. Por ejemplo, si algunos de los usuarios ya utilizan Active Desktop de Internet Explorer 4.0, mientras que otros usuarios se actualizan desde Internet Explorer 3, puede que sea preferible que todos los usuarios tengan Active Desktop.

Active Desktop se incluye automáticamente en Windows 98.

Actualizar desde Internet Explorer 3

El programa de instalación de Internet Explorer permite realizar una instalación sobre una versión instalada de Internet Explorer 3 e importa las opciones de configuración de proxy, favoritos y los cookies de la versión anterior. Sin embargo, deberá volver a instalar los complementos que desee conservar.

Cambiar desde Netscape Navigator 3 y 4

Al instalar Internet Explorer, puede importar las opciones de configuración de proxy, favoritos y cookies de Netscape. Sin embargo, deberá volver a instalar los complementos que desee conservar. Una vez instalado Internet Explorer, puede elegir si desea convertirlo en su explorador predeterminado.

Instalar Internet Explorer con Microsoft Office

Consulte Instalar Internet Explorer con Microsoft Office para obtener más información.


Instalación de Windows Update para Internet Explorer y otras herramientas para Internet

El Asistente para la instalación de Windows Update (IE5Setup.exe) facilita a los administradores la distribución de Internet Explorer. También es más fácil para los usuarios la instalación de Internet Explorer y el proceso de recuperación después de errores en la instalación.

El Asistente para la instalación es pequeño y compacto; incluye sólo el código necesario para permitir al cliente el acceso a Internet y proporcionarle las funcionalidades básicas para la descarga de archivos.

Puede usar el IEAK con el fin de personalizar la instalación de Windows Update de modo que se ajuste a las necesidades de los usuarios.

Ventajas del Asistente para la instalación de Windows Update

Este paquete también permite al programa de instalación de Windows Update recopilar información relacionada con el equipo host antes de que comience la descarga. El programa de instalación utiliza esta información para administrar de forma inteligente la descarga de los archivos contenedores .CAB de Internet Explorer y hacer que la instalación sea lo más eficiente y carente de problemas posible. La descarga de este pequeño paquete de instalación al comenzar el proceso tiene muchas ventajas, entre las que se incluyen las siguientes:

  • Velocidad: sólo se tarda dos minutos en descargar IE5Setup.exe a través de un enlace de 28 kbps.
  • Los usuarios pueden recibir así, al comienzo del proceso de instalación, un aviso que les informa de la falta de espacio suficiente en disco (en lugar de esperar a que termine un largo proceso de descarga que puede fallar por esa razón).
  • Todas las opciones de usuario se recopilan al comienzo del proceso, de forma que los usuarios no tienen que estar presentes mientras se descargan e instalan los archivos.
  • Si el vínculo a un servidor de distribución no es confiable y se debe reanudar alguna conexión interrumpida, la descarga se inicia a partir del punto en que falló anteriormente. Este proceso permite que el usuario avance en el proceso de instalación cada vez que ejecuta el programa de instalación, en lugar de obligarle a iniciar el proceso desde el principio.
  • Cuando no es posible restablecer el vínculo con un servidor de distribución, automáticamente el programa de instalación trata de conectarse con otros servidores de distribución.
  • Los usuarios reciben información útil acerca del desarrollo del proceso de descarga (no sólo el número de bytes por segundo, sino el tiempo en minutos que aún falta para terminar la instalación).
  • En el caso de que la versión actual de algún componente ya esté instalada, esos archivos no se vuelven a instalar sin necesidad.
  • Puede crear y ejecutar un paquete de descarga personalizado sin tener que volver a escribir el programa de instalación.
  • Los archivos temporales que ya no son necesarios se pueden quitar del disco duro para dejar más espacio en disco disponible para la instalación.

El proceso se muestra en el diagrama Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet.

Instalar otros componentes con Internet Explorer

Además del explorador Internet Explorer, puede incluir numerosos componentes para Internet de Microsoft y otras organizaciones en la versión personalizada del programa de instalación de Windows Update. El Asistente para la personalización de Internet Explorer facilita la consulta de las versiones de software más recientes disponibles para descargar. El paquete personalizado simplifica a los usuarios la instalación de estos componentes, junto con otros programas personalizados, cuando instalan el explorador.

Los componentes de Microsoft incluyen desde las herramientas de creación de Web a la compatibilidad con múltiples idiomas. El conjunto de componentes disponibles se actualiza continuamente; la lista más reciente aparece en el Asistente para la personalización de Internet Explorer siempre y cuando disponga de una conexión a Internet.

Para obtener información acerca de las actualizaciones más recientes de los productos, visite sitio Web Corporate Windows Update.

Funcionamiento del programa de instalación de Windows Update

Una vez que IE5Setup.exe ha reunido toda la información necesaria acerca del usuario y el equipo, descarga los archivos contenedores .CAB necesarios desde uno de los servidores oficiales de distribución de Microsoft en Internet. Dado que el programa de instalación ya ha realizado un inventario con todos los componentes de Internet Explorer que hay en el equipo y ha preguntado al usuario qué componentes desea instalar, no se descarga ningún archivo .CAB que no se necesite.

La fase siguiente del Asistente para la instalación utiliza el programa de instalación (ACME) que utilizan tradicionalmente muchos productos de Microsoft. En este momento, la única diferencia entre el Asistente para la instalación y el programa tradicional de instalación es que los archivos .CAB están en una carpeta del disco duro local en lugar de en un disco extraíble o en una unidad de red.

Si es administrador de una intranet, puede crear un paquete de instalación personalizado (también conocido como paquete IExpress) sin volver a escribir el programa de instalación de Windows Update. Para ello, debe crear una versión personalizada de IE5Setup.exe mediante la tecnología IExpress.

Para ajustar con precisión el proceso de instalación, puede usar modificadores adicionales de la línea de comandos. Para obtener más información, consulte Modificadores de la instalación por lotes de Internet Explorer.

Personalizar la instalación de Windows Update

Es posible personalizar la instalación de Windows Update de varias maneras. Puede agregar componentes de Internet Explorer o crear un máximo de diez opciones de instalación diferentes. Esto permite ampliar las opciones Mínima, Típica y Completa predeterminadas de instalación de Internet Explorer. Agregar varias opciones de instalación puede resultar útil si los empleados tienen distintas necesidades de uso y restricciones en el espacio de disco.

Importante

  • Independientemente de las opciones de instalación configuradas para el paquete, el programa de instalación de Windows Update sólo presenta una opción de instalación para los usuarios que ejecuten el sistema operativo Windows 2000. Esta opción incluye todos los componentes de Internet de Microsoft, además de los componentes personalizados incluidos en el paquete.

Para reducir la confusión, puede ser aconsejable seleccionar determinadas opciones del programa de instalación en lugar de los usuarios. Puede configurar Internet Explorer de modo que su instalación requiera menos o ninguna participación del usuario. Este tipo de instalación a veces se denomina "instalación silenciosa".

Las instalaciones con participación limitada suelen utilizarse para instalar Internet Explorer después de la jornada laboral, cuando los empleados no utilizan sus equipos. Puede ampliar todavía más estos tipos de instalaciones mediante modificadores de la línea de comandos o archivos por lotes. Puesto que el usuario no elige ninguna opción, puede crear sólo una opción de "instalación silenciosa".

Si suprime todos los comentarios para el usuario, incluidos los mensajes de error y la información de estado, deberá garantizar que el plan de instalación incluye un sistema de control de errores. En caso de que reinicie el equipo después de la instalación, deberá supervisar el reinicio en el programa o secuencia de comandos personalizada a fin de asegurarse de que Internet Explorer está instalado correctamente. Para obtener mas información acerca de estas opciones, consulte Instalación silenciosa.

Es aconsejable que instale sus propios componentes personalizados (por ejemplo, secuencias de comandos o programas antivirus) al instalar Internet Explorer. Puede incluir un máximo de diez componentes personalizados en el paquete personalizado.

También puede alterar la apariencia del programa de instalación; para ello, agregue sus propios mapas de bits e incluya descripciones personalizadas en las diferentes opciones de instalación.

Para ver un ejemplo de cómo se aplican las marcas personalizadas a su explorador, consulte Cómo funciona la personalización. Si desea ver un organigrama de lo que ocurre al usar el Asistente para la personalización de Internet Explorer con el fin de crear un paquete personalizado, consulte Cómo genera el IEAK paquetes personalizados.

Archivos de registro que graban los problemas ocurridos durante la instalación

Las características mejoradas para el registro facilitan al usuario, administrador y a Microsoft la solución de los problemas de instalación. El Asistente para la instalación crea los dos archivos de registro siguientes que ayudan a identificar cualquier problema que pueda surgir. Los archivos de registro se crean en la carpeta Windows o WinNT:

  • Active Setup Log.txt: registra todas las acciones que tengan lugar durante la ejecución del Asistente para la instalación o la instalación de los componentes. Consulte este archivo de registro cuando no se hayan instalado correctamente los componentes de Internet Explorer. Para obtener más información, consulte Información del registro de errores de Active Setup Log.txt
  • RunOnceEx Log.txt: registra todas las acciones que tengan lugar durante el registro de las bibliotecas de vínculos dinámicos (DLL). Consulte este archivo de registro si recibe un mensaje en el que se indique que un archivo .dll específico no se registró correctamente o si aparece algún cuadro de diálogo inesperado durante la fase final del proceso de instalación.


Poner componentes adicionales a disposición de los usuarios

Tras crear su paquete del explorador personalizado, deseará publicarlo en sitios desde donde los usuarios puedan descargarlo. Especifique dichos sitios en el paso 3 del Asistente para la personalización de Internet Explorer. También puede especificar el lugar donde los usuarios obtendrán componentes nuevos o actualizaciones. Se llaman componentes adicionales.

Cuando el usuario hace clic en Herramientas y, después, en Windows Update, el explorador abre la dirección URL del componente adicional especificado. Esto también ocurre cuando el usuario hace clic en Agregar o quitar programas en el Panel de control, hace clic en Internet Explorer y Herramientas de Internet, hace clic en Agregar o quitar y, después, selecciona Agregar un componente.

Nota

  • La dirección URL del componente adicional especificado debe contener la ruta de acceso completa de Addon.htm, por ejemplo, http://miservidor/complementos/addon.htm.

Ejemplo de páginas Web de componentes adicionales

El kit de herramientas de IEAK contiene un ejemplo de página Web de componentes adicionales, Addon.htm, que puede personalizar. Esta página se encuentra en la carpeta \<carpeta de programa IEAK>\Toolkit\Addons\HTML. Esta página incluye, además, vínculos a los archivos Head.htm, Main.htm e Info.htm.

A continuación se muestra una descripción de los cuatro archivos de ejemplo de la carpeta \<carpeta de programa IEAK>\Toolkit\Addons\HTML:

  • Addon.htm: conjunto de marcos que hace referencia a estos dos archivos:
    • Head.htm: marco de encabezado para el título
    • Main.htm: marco principal con las secuencias de comandos de instalación y un vínculo a Info.htm
  • Info.htm: información acerca de todos los componentes disponibles

La mayoría de los cambios que realice se harán en Main.htm, que se compone de tres partes:

  • Secuencias de comandos de instalación
  • Tabla de casillas de verificación, nombres de componentes y tamaños
  • Control ActiveX de instalación

Usar los archivos de ejemplo

Copie los cuatro archivos de ejemplo a su ubicación de descarga o a la ubicación que especifique y modifíquelos en un procesador de textos o en un editor de HTML.

Para que la secuencia de comandos funcione correctamente, los archivos deben instalarse de la manera siguiente:

  • El archivo IEcif.cab debe estar almacenado en un servidor Web.
  • En la sección <SCRIPT> de Main.htm, la entrada L_cab_Address= debe señalar a la ubicación de IEcif.cab.
  • La tabla de Main.htm sólo debe contener los componentes que haya descargado de Microsoft y que desee proporcionar.

Para agregar nuevos componentes

  1. Asegúrese de que ha descargado los componentes durante la sincronización automática de versiones (AVS).
  2. Localice el nombre correcto del componente en el archivo IESetup.cif.
  3. Agregue una casilla de verificación con ese nombre a Addon.htm.

Si se trata de un autor experto de páginas Web, puede optar por no utilizar la plantilla proporcionada en IEAK.

Información para autores expertos de páginas Web

En Main.htm se utilizan dos lenguajes de secuencias de comandos: JScript y Visual Basic Script Edition (VBScript). El código de JScript contiene la función Install(). Se llama a esta función cuando el usuario hace clic en el botón Instalar que hay en la parte inferior de la página. La función controla el proceso de instalación. La función Install() realiza llamadas a varias subrutinas de VBScript.

Las secuencias de comandos utilizan la propiedad name (parte de la etiqueta input) de las casillas de verificación para leer el archivo IESetup.cif. Este archivo está incluido en el archivo IEcif.cab y lo abre la subrutina Window_onLoad().

Nota

  • Los componentes para los usuarios de Windows y Windows NT pueden tener nombres diferentes. Puede encontrar esta información en IESetup.cif.

Para averiguar si un componente ya está instalado, puede utilizar la subrutina de VBScript IsComponentInstalled().

IsComponentInstalled(IdComponente)

Donde IdComponente es el mismo nombre que el de la casilla de verificación y el valor en IESetup.cif.

Código devuelto | Significado
0 | Componente no instalado
1 | Componente ya instalado
2 | El componente está instalado, pero hay una versión más reciente disponible
3 | Bloqueo de seguridad del usuario: no se determinó el estado

Cuando se comprueba el primer componente mediante este método, el motor ActiveX activa un cuadro de diálogo de seguridad que solicita permiso para comprobar el estado de los componentes instalados en el equipo del usuario. Si el usuario elige "No", se devuelve el código 3 para todos los componentes.


Empaquetar actualizaciones de Microsoft en componentes personalizados

Quizás desee instalar una versión de un componente de Microsoft distinto del que está disponible mediante la Sincronización automática de versiones (AVS). Por ejemplo, es posible que desee proporcionar a los usuarios una revisión (QFE) que esté disponible en Windows Update, pero no en AVS. O, por ejemplo, su organización podría utilizar de forma estándar una versión diferente de un componente de Microsoft incluido con Internet Explorer, como NetMeeting, por lo que sería aconsejable que los usuarios emplearan esa versión en concreto en lugar de la versión que el asistente para el IEAK incluye en su paquete.

En este caso, puede empaquetar estos archivos en un componente personalizado que se incluirá en su paquete personalizado.

Para reducir el número de reinicios del sistema realizados por los usuarios, puede elegir el momento en que se instalará este componentes respecto al resto de los pasos del proceso de instalación. Puede instalar el componente antes o después de instalar Internet Explorer, o bien después del reinicio del sistema requerido.

Para obtener información adicional, consulte Sitio de descarga y Sincronización automática de versiones (AVS) y Agregar componentes personalizados: condiciones de instalación.


Desinstalar un componente personalizado

Al registrar el programa de desinstalación del componente personalizado durante la instalación de éste, los usuarios podrán quitar el programa si hacen clic en el icono Agregar o quitar programas del Panel de control. Para ver un ejemplo de archivo de desinstalación, consulte el archivo Uncheck.inf de la carpeta \<carpeta de programa IEAK>\Toolkit\Inf del Kit de herramientas de IEAK.

Para registrar el programa de desinstalación de modo que aparezca en Agregar o quitar programas del Panel de control, durante el proceso de instalación de componentes, la aplicación debe agregar las entradas enumeradas a continuación a la siguiente clave de Registro:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\Nombre de aplicación

El programa de instalación de Windows Update también utiliza esta clave del Registro para comprobar si el componente se instaló correctamente.

Subclave | Tipo de datos | Valor
DisplayName | Cadena | Nombre descriptivo de la aplicación.
UninstallString | Cadena | Línea de comandos completa (con la ruta de acceso) para desinstalar la aplicación. No utilice un archivo por lotes ni un subproceso.

El valor de Nombre de aplicación también debe coincidir con el valor de Uninstall Key, en la pantalla Agregar componentes personalizados del Asistente para la personalización de Internet Explorer.

Para obtener más información, consulte Proporcionar la funcionalidad de desinstalación en una secuencia de comandos .INF.


Trabajar con archivos de información para la instalación (.INF)

Un archivo de información (.INF) es un archivo de texto que especifica los archivos que deben estar presentes o se tienen que descargar para que el componente se ejecute en versiones de Windows de 32 bits. El servicio Descarga de componentes de Internet usa estas instrucciones para instalar y registrar los componentes software descargados de Internet y los archivos que éstos necesitan. El servicio Descarga de componentes de Internet lleva formando parte de Internet Explorer desde la versión 3.0.

Una unidad de distribución de software de Internet es un "paquete" que consta de un archivo contenedor (.CAB) que contiene un archivo .INF. Una unidad de distribución también puede contener un componente software como un control ActiveX (.OCX), un archivo .DLL, un archivo .EXE, un archivo de clase de Java o un subprograma. Cuando un atributo CODEBASE de un elemento OBJECT en una página Web hace referencia a un archivo contenedor que contiene un archivo .INF, Internet Explorer 3.0 y las versiones posteriores tratan automáticamente al archivo contenedor como una unidad de distribución de software.

Con los archivos .INF, puede crear instrucciones de instalación de software personalizadas que incluyan entradas del Registro y directorios de destino. Un archivo .INF ofrece una independencia limitada de la plataforma y especifica dependencias de software limitadas.

Los temas siguientes proporcionan más información acerca de cómo se trabaja con archivos .INF:

  • Definición del archivo de información para la instalación (.INF)
  • Tratar carpetas y archivos mediante la utilización de archivos de información para la instalación (.INF)
  • Extensiones del programa de instalación de Windows
  • Proporcionar la funcionalidad de desinstalación en una secuencia de comandos .INF
  • Personalización avanzada del cliente de mensajería
  • Usar la tecnología RunOnce
  • Ejemplo de archivo .INF para el servicio de descarga de componentes

Nota

  • Para obtener más información acerca del servicio Descarga de componentes de Internet, consulte el sitio MSDN Online Web Workshop.


Extensiones del programa de instalación de Windows

Puede ampliar el programa de instalación de Windows de tres formas:

  • Ejecutar los archivos .INF de Windows desde la línea de comandos mediante Rundll.exe.
  • Instalar componentes opciones de software de Windows desde un código de programa de 32 bits como alternativa a que el usuario instale software desde el cuadro de diálogo Agregar o quitar programas en el Panel de control.
  • Crear un icono en el escritorio de Windows en el que el usuario pueda hacer clic para ejecutar un archivo .INF; de esta forma ya no hay que desarrollar código para el programa de instalación.

Ejecutar archivos .INF desde la línea de comandos

Puede usar los comandos del sistema Rundll.exe o Rundll32.exe de Windows para ejecutar una sección Install en un archivo .INF. La sintaxis de la línea de comandos es la siguiente:

RunDll setupx.dll,InstallHinfSection <sección> <modo-de-reinicio> <nombre-inf>

El parámetro <sección> es una sección Install del archivo .INF. Por ejemplo, la línea de comandos siguiente instala el componente opcional Games y, si el programa de instalación determina que se debe reiniciar el equipo, le pregunta al usuario si desea reiniciar el equipo inmediatamente una vez que se complete la instalación. El significado de los valores del parámetro <modo-de-reinicio> se describe en "Utilizar el parámetro modo de reinicio", posteriormente.

RunDll setupx.dll,InstallHinfSection games 4 applets.inf

Notas

  • Este comando supone que el espacio en disco necesario para instalar los archivos está disponible. No realiza ninguna comprobación del espacio en disco.
  • La aplicación de instalación no debe ejecutar código después de que se realice una llamada a RUNDLL o RUNDLL32 porque, una vez que Setupx.dll tiene el control, puede ocasionar que se reinicie el equipo. Si el proceso de instalación tiene que ejecutar otro código después de que el suyo llame a RUNDLL o RUNDLL32, use la lista RunOnce del archivo .INF.
  • No use la lista RunOnce para ejecutar el componente opcional que está instalando.

Usar el parámetro modo de reinicio

Hay cinco modos de reinicio:

define HOW_NEVER_REBOOT 0
define HOW_ALWAYS_SILENT_REBOOT 1
define HOW_ALWAYS_PROMPT_REBOOT 2
define HOW_SILENT_REBOOT 3
define HOW_PROMPT_REBOOT 4

Si <nombre-inf> especifica su archivo .INF en lugar de un archivo .INF de Windows, sume 128 a los valores mostrados arriba. En el ejemplo anterior que instala el componente opcional Games, <modo-de-reinicio> se establece a 4. Esto se debe a que Applets.inf es un archivo .INF de Windows. Si está instalando un componente opcional que tiene su propio archivo .INF, establezca <modo-de-reinicio> a 132. Si suma 128 al parámetro <modo-de-reinicio>, todos los archivos que instale deben estar en la misma carpeta que su archivo .INF del disco de instalación.

Nota

  • Los únicos valores recomendados para <modo-de-reinicio> son 4, si el archivo .INF es un archivo .INF de Windows 95, o 132, si es un archivo .INF proporcionado por usted. Usar otro de los valores mostrados anteriormente puede ocasionar que el equipo se reinicie innecesariamente o que no lo haga cuando debiera.

La lista siguiente describe cada modo de reinicio:

NeverReboot
Establece <modo-de-reinicio> a 0 o 128. En cualquier caso, el equipo no se reiniciará. Es decisión del cliente determinar si el equipo debe reiniciarse. Para el programa de instalación, esto significa que hay un archivo C:\Windows\Wininit.ini que no tiene un tamaño de cero bytes.

AlwaysSilentReboot
Establece <modo-de-reinicio> a 1 o 129. No se pedirá al usuario que reinicie el equipo y éste se reiniciará siempre.

AlwaysPromptReboot
Establece <modo-de-reinicio> a 2 o 130. Siempre se pedirá al usuario que decida si desea reiniciar el equipo. El programa de instalación no intenta determinar si es necesario reiniciar el equipo.

SilentReboot
Establece <modo-de-reinicio> a 3 o 131. Si el programa de instalación determina que es necesario reiniciar el equipo, no hay interacción con el usuario.

PromptReboot
Establece <modo-de-reinicio> a 4 o 132. Si el programa de instalación determina que es necesario reiniciar el equipo, pregunta al usuario con un cuadro de diálogo.

Volver al principio del archivo

Instalar componentes opcionales desde el código de una aplicación de 32 bits

Una vez que Windows se instala en un equipo, puede ser necesario agregar uno o varios componentes opcionales de Windows, por ejemplo, Games. Este tipo de instalación, que ocurre después de que el programa de instalación instale inicialmente Windows, se denomina instalación en modo de mantenimiento. Normalmente, la instalación en modo de mantenimiento se inicia desde Windows al hacer clic en el icono Agregar o quitar programas del Panel de control. Sin embargo, hay una alternativa disponible para los fabricantes y proveedores del componente de software opcional: pueden instalarlo mediante una llamada a CreateProcess en una aplicación de 32 bis.

Nota

  • El método CreateProcess de instalación de un componente opcional descrito a continuación debe usarse sólo en aplicaciones de 32 bits.

Para instalar un componente opcional desde una aplicación de 32 bits, use una combinación de los métodos descritos a continuación.

Comprobar el Registro

En primer lugar, compruebe el Registro para ver si el componente opcional ya está instalado o busque los archivos. La clave del Registro que contiene información acerca de todos los componentes opcionales instalados actualmente es la siguiente:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents]

Habrá valores debajo de esta clave que señalen a subclaves y cada subclave contiene información acerca de los componentes opcionales instalados, así como información necesaria para instalar un componente opcional nuevo. Por ejemplo, suponga que desea instalar Games como componente opcional. Para ver si Games está instalado, busque el valor de la subclave siguiente debajo de la clave OptionalComponents:

"Games"="Games"

A continuación, abra la clave "Games" situada debajo de la clave de componentes opcionales para buscar lo siguiente:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents\Games]
"INF"="applets.inf"
"Section"="games"
"Installed"="0"

Esto indica que el componente opcional Games no está instalado en este equipo Windows, porque el indicador "Installed" tiene el valor 0.

Codificar una llamada a la función CreateProcess

Para instalar un componente opcional como Games, use los valores "INF" y "Section" de la clave anterior en una llamada a CreateProcess que ejecute Setupx.dll a través de RUNDLL. Este método hace exactamente lo mismo que Agregar o quitar programas en el Panel de control cuando instala un componente. La sintaxis del parámetro lpCommandLine en la llamada a CreateProcess es la siguiente:

RunDll setupx.dll,InstallHinfSection <sección> <modo-de-reinicio> <nombre-inf>

Los valores de los parámetros <sección> y <nombre-inf> son los de la clave del Registro descrita anteriormente (Section e INF). Por ejemplo, la llamada a CreateProcess siguiente instala el componente opcional Games y, si el programa de instalación de Windows determina que hay que reiniciar el equipo, pregunta al usuario si desea que se reinicie inmediatamente una vez que se complete la instalación. El significado de los valores del parámetro <modo-de-reinicio> se describe en la sección "Usar el parámetro modo de reinicio".

RunDll setupx.dll,InstallHinfSection games 4 applets.inf

Nota

  • Se recomienda que se compruebe el espacio en disco disponible antes de instalar el componente. Cuando se realice dicha comprobación, tenga en cuenta que debe haber espacio en disco para los archivos de intercambio del sistema .

La aplicación de instalación no debe ejecutar código después de que se realice una llamada a CreateProcess porque, una vez que Setupx.dll tiene el control, el código adicional puede ocasionar que se reinicie el equipo del usuario. Si el proceso de instalación tiene que ejecutar otro código después de que el suyo llame a CreateProcess, use la lista RunOnce del archivo .INF.

Nota

  • No use la lista RunOnce para ejecutar el componente opcional que está instalando.

Hacer clic con el botón secundario del mouse en un archivo .INF para ejecutarlo

El programa de instalación reconoce un nombre de sección Install determinada, DefaultInstall, en los archivo .INF que instalan componentes opcionales. Si usa una sección [DefaultInstall] en su archivo .INF, el usuario puede hacer clic con el botón secundario del mouse en un icono del archivo .INF en la interfaz de usuario de las versiones de Windows de 32 bits para ejecutar la sección [DefaultInstall]. Después de que el usuario haga clic con el botón secundario del mouse en el icono de un archivo .INF, se mostrará un menú emergente donde el usuario puede seleccionar la opción Install para ejecutar realmente la sección [DefaultInstall].

Si utiliza una sección Install denominada [DefaultInstall] en su archivo .INF, ofrece un método cómodo de instalar el componente opcional. Esto resulta de utilidad, particularmente, durante el desarrollo de su aplicación. Si va a escribir una aplicación de instalación, dispondrá de un método para instalar el componente opcional antes de desarrollar el código de la misma.

El siguiente es un ejemplo de sección DefaultInstall que contiene entradas típicas:

[DefaultInstall]CopyFiles=QCD.copy.prog, QCD.copy.hlp, QCD.copy.win, QCD.copy.sys, QCD.copy.inf
UpdateInis=QCD.LinksAddReg=QCD.reg, QCD.run
Uninstall=FlexiCD_remove


Tratar carpetas y archivos mediante la utilización de archivos de información para la instalación (.INF)

Puede usar archivos .INF para tratar archivos y carpetas de varias formas. Las más importantes son:

  • Crear carpetas y vínculos en carpetas
  • Crear y eliminar nombres de archivo largos
  • Establecer atributos para archivos y carpetas
  • Copiar archivos a la carpeta Archivos de programa

Crear carpetas y vínculos en carpetas

Crear una carpeta en la carpeta Archivos de programa o crear vínculos en una carpeta es una operación que realiza el shell una vez que el componente se ha instalado. El programa de instalación busca en el archivo Setup.ini una sección [progman.groups] y, a continuación, la analiza para crear carpetas y vínculos en esas carpetas.

Si instala un componente que necesitará una carpeta o vínculos en la carpeta Archivos de programa, cree una sección UpdateInis para crear las entradas apropiadas en el archivo Setup.ini. El archivo Setup.ini emplea la siguiente sintaxis para crear carpetas y vínculos. Tenga en cuenta que las carpetas son relativas al menú Inicio.

[progman.groups]
carpeta_1=nombreCarpeta_1
carpeta_2=nombreCarpeta_2
:
carpeta_n=nombreCarpeta_n

[carpeta_1]
nombreVínculo, .nombreExe, nombreArchivoIcono, índiceIcono, perfil

Si el campo perfil tiene NULL a la izquierda, el vínculo siempre se agregará a la carpeta.

Notas

  • Si .nombreExe es un elemento NULL, se eliminará del grupo si ya existe allí.
  • Si la descripción de una carpeta o vínculo tiene un espacio, debe usar comillas tipográficas dobles para conseguir que se refleje en el archivo Setup.ini. Vea los ejemplos siguientes.

Ejemplo: Games

[Optional Components]
games

[games]
OptionDesc= %GAMES_DESC%
CopyFiles= wingames.files
UpdateInis= wingames.links
[wingames.files]
cards.dll
freecell.exe
freecell.hlp
mshearts.exe
mshearts.hlp
sol.exe
sol.hlp
winmine.exe
winmine.hlp

[wingames.links]
setup.ini, progman.groups,, "gamesfolder=%GAMES_DESC%" ;crea una carpeta
setup.ini, gamesfolder,, """Juego Solitario"",SOL.EXE,,," ;crea un vinculo
setup.ini, gamesfolder,, "Buscaminas,WINMINE.EXE,,," ;crea un vinculo
setup.ini, gamesfolder,, ""Juego de cartas Corazones"",MSHEARTS.EXE,,,";crea un vinculo
setup.ini, gamesfolder,, """Carta blanca"",FREECELL.EXE,,," ;crea un vinculo

Resultado: la entrada para "Games" aparecerá en el cuadro de diálogo Opcional Components en el programa lde instalación y, si se selecciona, se creará una carpeta Games en la carpeta Archivos de programa con vínculos a Solitario, Buscaminas, Corazones y Carta blanca.

Crear y eliminar nombres de archivo largos

La rama raíz del Registro para las operaciones de cambio de nombre es la siguiente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RenameFiles

La rama raíz del Registro para las operaciones de eliminación es la siguiente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\DeleteFiles

Cada grupo de operaciones de cambio de nombre y eliminación se agrega a una subclave debajo de cada rama. Cada grupo de operaciones se limita a cambiar el nombre o eliminar los archivos de una única carpeta. Debe incluir, como mínimo, dos entradas en cada subclave para que surta efecto un cambio de nombre o una eliminación: la ruta de acceso de la carpeta de los archivos cuyo nombre se va a cambiar o se van a eliminar, y la operación de cambio de nombre o eliminación real.

La primera clave de cada grupo de operaciones es la entrada folder. Cada entrada para una operación de cambio de nombre en la carpeta relacionada es una entrada con el formato "nombreCortoAntiguo"="nombreLargoNuevo,[indicadorAtributo]".

El parámetro indicadorAtributo se usa para establecer atributos de archivo durante la operación de cambio de nombre. El indicador puede tener los valores siguientes.

1 | READONLY
2 | HIDDEN
3 | SYSTEM

Para establecer varios atributos en un archivo o carpeta, los indicadores se suman; por ejemplo, para establecer los atributos READONLY y HIDDEN, indicadorAtributo debe ser 3.

El ejemplo siguiente es una sección AddReg que establece los atributos SYSTEM y HIDDEN para la carpeta \Windows\System\Sample:

HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,,,%11% HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,SAMPLE,,"SAMPLE,6"

Nota

  • Debe usar letras mayúsculas para asegurar que el nombre de archivo siga siendo un nombre corto.

Cada entrada para una operación de eliminación en la carpeta relacionada tiene el formato "nombreClaveArbitrario"="nombreLargoQueEliminar".

El ejemplo siguiente es una sección AddReg que:

  • Cambia el nombre del archivo nombrant.txt a Nombre Largo Nuevo.txt en la carpeta C:\Samples.
  • Cambia el nombre del archivo Mileame.txt a Leame De Mi Aplicacion.txt en la carpeta Windows.

[MiAplCortoALargo]
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Samples,,,C:\Samples
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Samples,nombrant.txt,,"Nombre Largo Nuevo.txt"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,Mileame.txt,,"Leame De Mi Aplicacion.txt"

El ejemplo siguiente es una sección AddReg que:

  • Elimina Nombre Largo Nuevo.txt de la carpeta C:\Samples.
  • Elimina Leame De Mi Aplicacion.txt de la carpeta Windows.

[MiAplElimLargo]
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Samples,,,C:\Samples
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Samples,nombreant.txt,,"Nombre Largo Nuevo.txt"

HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,Mileame.txt,,"Leame De Mi Aplicacion.txt"

Tras procesar los cambios de nombre y eliminaciones, las entradas se quitan del Registro.

Nota

  • Durante la operación de cambio de nombre, el archivo de destino se elimina antes de que cualquier archivo se cambie de nombre. Si la misma operación de cambio de nombre se introduce en la cola dos veces, podría ocasionar la pérdida del archivo. Por ejemplo, suponga que hay un mapa de bits que tiene que cambiar de nombre de imagen.bmp a "Imagen 3D Realmente Buena.bmp". La segunda vez que se realizara una operación de cambio de nombre, "Imagen 3D Realmente Buena.bmp" ya existiría, de forma que se eliminaría antes de que se realizara la operación de cambio de nombre. La excepción a esta regla se produce cuando el nombre de archivo de destino existente es una carpeta.

Establecer atributos para archivos y carpetas

Para establecer los atributos de un archivo o carpeta, puede usar la misma convención que para crear nombres de archivo largos mediante un indicador opcional.

Para obtener más detalles, consulte la sección "Crear y eliminar nombres de archivo largos".

Copiar archivos a la carpeta Archivos de programa

En el ejemplo siguiente se copian tres archivos a la carpeta Archivos de programa\Accesorios y se crean vínculos a uno de los archivos:

[WordPadInstall]
CopyFiles = WordPadCopyFiles
UpdateInis = WordPadInis

[DestinationDirs]
WordPadCopyFiles = 24,%PROGRAMF%\%ACCESSOR%

[WordPadCopyFiles]
mswd6_32.wpc
wordpad.exe
write32.wpc
[WordPadInis]
setup.ini, progman.groups,, "group4=%APPS_DESC%" ;crea la carpeta Accesorios (si no está ya)
setup.ini, group4,, """%WORDPAD_LINK%"", ""%24%\%PROGRAMF%\%ACCESSOR%\WORDPAD.EXE""" ;crea un vínculo en la carpeta Accesorios

[Strings]
APPS_DESC = "Accesorios"
WORDPAD_LINK = "WordPad"
; Nombres de carpeta, tenga en cuenta que las versiones de nombre corto deben coincidir con las truncadas
; nombres de 8 caracteres para las versiones de nombre largo, o si no habrá problemas.
PROGRAMF = "Archiv~1" ; primeros 6 caracteres de Archivos_de_programa, + "~1"
ACCESSOR = "Acceso~1" ; primeros 6 caracteres de Accesorios, + "~1"

Limitaciones de los archivos .INF

  • No se puede eliminar directorios.
  • Los archivos no se pueden mover a una ubicación diferente cuando se utiliza RenFiles. El comando RenFiles sólo cambia el nombre de un archivo en un lugar.
  • No se puede hacer copias de un archivo. El comando CopyFiles sólo copia archivos desde un disco de origen a un directorio de destino.


Proporcionar la funcionalidad de desinstalación en una secuencia de comandos .INF

Puede proporcionar la funcionalidad de desinstalación en sus archivos .INF si agrega una sección Install que quite los archivos, las entradas del Registro y los accesos directos, y agrega a continuación su componente a la lista de programas que se pueden desinstalar desde el cuadro de diálogo Agregar o quitar programas del Panel de control. En la carpeta \<carpeta de programa IEAK>\Toolkit\inf\ del Kit de herramientas del IEAK se incluye un ejemplo.

Para agregar su componente al cuadro de diálogo Agregar o quitar programas, agregue una clave nueva y valores debajo de la clave del Registro siguiente:

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\nombreAplicación,"DisplayName",,"descripción"

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\nombreAplicación,"UninstallString",,"líneaComandos"

descripción Esta cadena se muestra en el cuadro de lista del cuadro de diálogo Agregar o quitar programas.

líneaComandos Es la línea de comandos que se ejecutará cuando el componente se seleccione en el cuadro de lista del cuadro de diálogo Agregar o quitar programas. Para ejecutar una sección de un archivo .INF, puede usar el punto de entrada InstallHinfSection de Setupx.dll, que se describe posteriormente.

Los ejemplos de entradas AddReg siguientes agregan "Mi aplicación de prueba" al cuadro de lista del cuadro de diálogo Agregar o quitar programas y ejecuta la sección Install Remove_TestApp en Test.inf:

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"DisplayName",,"Mi aplicación de prueba"

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"UninstallString",,"RunDll setupx.dll,InstallHinfSection Remove_TestApp 4 test.inf"

Notas

  • La secuencia de comandos de instalación debe copiar el archivo .INF a la carpeta Windows\Inf cuando se instale el componente. Ésta es la ubicación predeterminada que se busca cuando se llama al punto de entrada InstallHinfSection de Setupx.dll.
  • La secuencia de comandos de desinstalación debe quitar la clave que se haya creado debajo de la clave del Registro Uninstall de forma que su programa ya no la muestre más en el cuadro de lista de Agregar o quitar programas una vez que se haya desinstalado.


Ejemplo de archivo .INF para el servicio de descarga de componentes

;El ejemplo de archivo .INF que se muestra a continuación realiza las acciones siguientes:
; - Copia archivos a las carpetas Windows, System, Inf y Help.
; - Crea una serie de entradas del Registro, incluidas entradas que
; cambiarán el nombre de los archivos copiados a nombres de archivo largos.
; - Crea un vínculo en el menú Ayuda.
; - Tiene una sección para desinstalación que registra dicha acción
; en el cuadro de diálogo Agregar o quitar programas del Panel de control.
; - Usa cadenas reemplazables para facilitar la conversión a otros idiomas.

[Version]
Signature=$CHICAGO$

[DestinationDirs]
SampleCopy = 24,%PROGRAMF%\Sample
SampleDel = 24,%PROGRAMF%\Sample
SampleWinCopy = 25
SampleSysCopy = 11
SampleINFCopy = 17
SampleHLPCopy = 18

[DefaultInstall]
CopyFiles = SampleCopy, SampleWinCopy, SampleSysCopy, SampleINFCopy, SampleHLPCopy
AddReg = SampleRegisterApp, SampleRegUninstall, SampleRenameFiles
UpdateInis = SampleAddLinks

[RemoveSample]
DelFiles = SampleWinCopy, SampleSysCopy, SampleINFCopy, SampleHLPCopy
DelReg = SampleUnRegisterApp, SampleRegUninstall
AddReg = SampleRemoveLFNs
UpdateInis = SampleRemoveLinks

[SampleCopy]
sample.bmp

[SampleWinCopy]
sample.exe

[SampleSysCopy]
sample.dll

[SampleINFCopy]
sample.inf

[SampleHLPCopy]
sample.hlp

[SampleRegisterApp]
;Crea una entrada del Registro arbitraria, para uso privado de Sample.exe:
HKLM,Software\Sample,Installed,,"1"

[SampleUnRegisterApp]
;Elimina la entrada del Registro, tenga en cuenta que se elimina toda la clave:
HKLM,Software\Sample

[SampleRegUninstall]
;Agrega una entrada al cuadro de diálogo Agregar o quitar programas del
;Panel de control para desinstalar el programa:
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"DisplayName",,"Sample Application"
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"UninstallString",,"RunDll setupx.dll,InstallHinfSection RemoveSample 4 sample.inf"

[SampleRenameFiles]
;Vuelve a nombrar archivos con formato 8.3 a archivos con nombres largos
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,,,"%24%\%PROGRAMF%\Sample"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,sample.bmp,,"Bitmap de ejemplo.bmp"

[SampleRemoveLFNs]
; Elimina archivos con nombres de archivo largos durante el proceso de desinstalación:
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,,,"%24%\%PROGRAMF%\Sample"
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,sample.bmp,,"Bitmap de ejemplo.bmp"

[SampleAddLinks]
;Agrega un acceso directo a Sample.exe en el menú Inicio:
setup.ini, progman.groups,, "Sample=%SampleFolder%" ;crear carpeta
setup.ini, Sample,, """%SampleDesc%"", %25%\SAMPLE.EXE" ;crear vínculo

[SampleRemoveLinks]
;Quita accesos directos a Sample.exe en el menú Inicio durante la desinstalación:
setup.ini, progman.groups,, "Sample=%SampleFolder%" ;crea la carpeta
setup.ini, Sample,, """%SampleDesc%"" ;borra el vínculo

[SourceDisksNames]
99 = %DiskName%,Sample,0

[SourceDisksFiles]
sample.exe = 1,,13456
sample.dll = 1,,20987
sample.bmp = 1,,64098
sample.hlp = 1,,55441
sample.inf = 1,,5687

[Strings]
PROGRAMF = "PROGRA~1"
SampleFolder = "Samples"
SampleDesc = "Aplicación de ejemplo "
DiskName = "Disco de instalación de la aplicación de ejemplo"


Definición del archivo de información para la instalación (.INF)

Un archivo básico .INF contiene las secciones siguientes; los archivos .INF más complejos pueden tener secciones adicionales. Los nombres de sección en negrita son palabras clave reservadas. Los nombres de sección en cursiva son nombres arbitrarios creados por el autor del archivo .INF:

  • Sección Version
  • Sección Install
    • Secciones Copy File (CopyFiles)
    • Secciones Rename Files (RenFiles)
    • Secciones Delete Files (DelFiles)
    • Secciones Update .ini File (UpdateInis)
    • Secciones Update .ini Fields (UpdateIniFields)
    • Secciones Add Registry (AddReg)
    • Secciones Delete Registry (DelReg)
    • Secciones Add Ini File to Registry (Ini2Reg)
    • Secciones Update Config.sys (UpdateCfgSys)
    • Secciones Update Autoexec.bat (UpdateAutoBat)
  • Sección DestinationDirs
  • Sección SourceDisksNames
  • Sección SourceDisksFiles
  • Sección Strings
  • Sección Opcional Components
[Version] | Información elemental acerca de la versión para validar el archivo .INF.
[DefaultInstall] | Sección relativa a la instalación que se ejecuta de forma predeterminada. Contiene punteros a otras secciones que especifican archivos para copiar y eliminar, actualizaciones del Registro, actualizaciones de archivos .INI, etc.
[OtraInstall] | Usa el mismo formato que la sección [DefaultInstall], pero se debe llamar explícitamente. Resulta de utilidad para definir cómo se debe instalar un componente.
[DestinationDirs] | Especifica el lugar en el disco duro donde los archivos de una sección se van a copiar, eliminar o cambiar de nombre; por ejemplo, \Windows o Windows\System.
[Secciones FileCopy, Delete o Rename] | Enumera archivos que se van a copiar, eliminar o cambiar de nombre.
[Secciones RegistryUpdate] | Especifica eliminaciones o adiciones al Registro.
[Secciones IniFileUpdate] | Especifica actualizaciones de los archivos .INI. Los vínculos se crean en esta sección.
[SourceDisksNames] | Enumera los discos que contienen los archivos.
[SourceDisksFiles] | Enumera el disco determinado en el que se encuentra cada archivo.
[Strings] | Enumera las cadenas convertibles a otros idiomas usadas anteriormente.
Volver al principio del archivo

Sección Version

[Version]
Signature="$Chicago$"
LayoutFile=nombre archivo.inf
Define el encabezado estándar para los archivos .INF de Windows. Tenga en cuenta que, si la firma (Signature) no es $Chicago$, Windows no aceptará el archivo como un archivo .INF para ninguna de las clases de dispositivo que Windows reconoce.

Observe que al reconocerse la cadena de la firma no se distinguen mayúsculas y minúsculas. Por ello puede usar tanto $Chicago$ como $CHICAGO$, por ejemplo.

nombre archivo.INF
Nombre del archivo .INF que contiene la información de distribución (archivos y discos de origen) necesaria para instalar este componente. Esta línea es opcional. Si no se proporciona en ningún otro lugar, las secciones SourceDisksNames y SourceDisksFiles se deben especificar en este archivo .INF.

En el ejemplo siguiente se muestra una sección Version común:

[Version]
Signature="$CHICAGO$"

Volver al principio del archivo

Sección Install

[nombre-sección-install]

Copyfiles = sección-lista-archivo[,<sección-lista-archivo>]...
Renfiles = sección-lista-archivo[,sección-lista-archivo]...
Delfiles = sección-lista-archivo[,sección-lista-archivo]...
UpdateInis = sección-update-ini[,sección-update-ini]...
UpdateIniFields = sección-update-inifields[,sección-update-inifields]...
AddReg = sección-add-registry[,sección-add-registry]...
DelReg = sección-del-registry[,sección-del-registry]...
Ini2Reg = sección-ini-to-registry[,sección-ini-to-registry]...
UpdateCfgSys = sección-update-config
UpdateAutoBat =sección-update-autoexec

Identifica las secciones adicionales del archivo .INF que contienen información acerca de la instalación del componente.

No todos los tipos de elemento mostrados en la sintaxis anterior son necesarios u obligatorios en una sección Install. Si se usa un tipo de elemento, debe especificar el nombre de una sección en el archivo .INF. (Una excepción es el elemento CopyFiles, que puede usar el carácter "@" junto con un nombre de archivo para copiar un único archivo sin especificar un nombre de sección.) El nombre de sección debe estar formado por caracteres imprimibles.

En una sección Install, sólo se puede usar un elemento de cada tipo. En un elemento puede enumerarse más de un nombre de sección pero cada nombre adicional debe ir precedido por una coma.

nombre-sección-install Si asigna el nombre [DefaultInstall] a la sección install, se ejecutará al hacer clic con el botón secundario del mouse (ratón) en el archivo .INF y seleccionar Install. Ésta también es la sección que se ejecuta al seleccionar un archivo .INF como la opción de instalación mediante el Asistente Cabpack.

En el ejemplo siguiente se muestra una sección Install típica. Contiene elementos Copyfiles y AddReg que identifican las secciones que contienen la información acerca de los archivos que se instalarán.

[MiAplicación]
Copyfiles=MiApliArchivosWin, MiApliArchivosSys, @SRSutil.exe
AddReg=MiAplicEntradasReg

En este ejemplo, observe que al cambiar el nombre de la sección [MiAplicación] a [DefaultInstall], la sección Install se ejecutará al hacer clic con el botón secundario del mouse en el archivo .INF y seleccionar Install.

El elemento CopyFiles proporciona una notación especial que permite que un único archivo se copie directamente desde la línea copy. Puede copiar un archivo individual si antepone al nombre de archivo el símbolo @. El destino de los archivos copiados con esta notación es el directorio DefaultDestDir, como se define en la sección DestinationDirs. En el ejemplo siguiente se muestra cómo copiar archivos individuales:

CopyFiles=SeccionArchivo1,@miarchivo.txt,@otroarchivo.txt,NombreUltimaSeccion

Volver al principio del archivo

Secciones Copy Files (CopyFiles)

[nombre-sección-CopyFiles]
nombre-archivo-destino[, nombre-archivo-origen][,nombre-archivo-temporal][,indicador][nombre-archivo-destino[,nombre-archivo-origen][, nombre-archivo-temporal]][,indicador]

Enumera los nombres de los archivos que se copiarán de un disco de origen a un directorio de destino. El disco de origen y el directorio de destino asociados con cada archivo se especifican en otras secciones del archivo .INF. El nombre sección-lista-archivo debe aparecer en el elemento CopyFiles de una sección Install.

Tenga en cuenta que puede especificar la copia de un único archivo en el elemento CopyFiles de la propia sección Install, sin tener que generar una sección CopyFiles. Para ello, use el carácter especial "@" para forzar la copia de un único archivo. Hay un ejemplo de utilización del carácter "@" en un elemento del tipo CopyFiles en el tema "Referencia" de la sección Install. La copia de un único archivo realizada de esta forma está algo limitada porque los nombres de archivos de origen y de destino deben ser el mismo en este caso y no se puede usar un archivo temporal.

nombre-archivo-destino
Nombre del archivo de destino. Éste será también el nombre del archivo de origen, si no se proporciona ninguno.

nombre-archivo-origen
Nombre del archivo de origen. Si los nombres de los archivos de origen y de destino para la operación de copia son los mismos, este elemento no es necesario.

nombre-archivo-temporal
Nombre de un archivo temporal para la operación de copia de archivos. El instalador copia el archivo de origen pero le da el nombre del archivo temporal. La próxima vez que se inicie el sistema operativo, cambiará el nombre del archivo temporal al del archivo de destino. Esto resulta de utilidad para copiar archivos a un destino que está abierto o que está usando Windows.

indicador
Parámetro opcional que se utiliza para realizar acciones especiales durante el proceso de instalación. Se pueden usar varios indicadores si se suman sus valores para crear un indicador combinado. Se pueden usar los siguientes indicadores válidos:

1 | En CopyFiles: advertir si el usuario intenta omitir el archivo.
1 | En DelFiles: si el archivo se está usando, incluir en una cola la eliminación para que se realice después en Wininit.ini. En otro caso, si un archivo se está usando actualmente no se eliminará.
2 | Instalación crítica: no permitir al usuario que omita el archivo.
4 | Pasar por alto la comprobación de la versión y copiar siempre el archivo. Esta operación sobrescribirá un archivo más reciente.
8 | Forzar cambio de nombre. El programa de instalación trata este archivo como si se estuviera utilizando. Esto sólo sucede si el archivo ya existe en el equipo del usuario.
16 | No copiar el archivo si ya existe en el destino.
32 | Suprimir el cuadro de diálogo de conflicto de versión y no sobrescribir los archivos más recientes.

En el ejemplo siguiente se copian tres archivos:

[SeccCopiarEstosArchivos]
archivo11 ; se copia el archivo archivo11
archivo21, archivo22, archivo23 ; se copia el archivo22, se nombra temporalmente archivo23
archivo31, archivo32 ; se copia el archivo32 en el archivo31

Todos los nombres de archivo de origen de este ejemplo deben haberse definido en una sección SourceDisksFiles y los números de disco lógico que aparecen en la sección SourceDisksFiles deben haberse definido en una sección SourceDisksNames. También puede usar un archivo Layout.inf para proporcionar esta información.

Volver al principio del archivo

Secciones Rename Files (RenFiles)

[nombre-sección-rename-files]
nombre-archivo-nuevo, nombre-archivo-antiguo
.
.
Enumera los nombres de los archivos que se van a cambiar de nombre. El nombre de la sección debe aparecer en un elemento Renfiles de una sección Install del archivo .INF.

nombre-archivo-nuevo Nombre nuevo del archivo.

nombre-archivo-antiguo Nombre antiguo del archivo.

En el ejemplo siguiente se cambia el nombre de archivo42 a archivo41, archivo52 a archivo51 y archivo62 a archivo61:

[RenameOldFilesSec]
archivo41, archivo42
archivo51, archivo52
archivo61, archivo62

Todos los nombres de archivo que se utilizan en este ejemplo (archivo42, archivo52 y archivo62) deben definirse en una sección SourceDisksFiles y los números de disco lógico que aparecen en la sección SourceDisksFiles deben haberse definido en una sección SourceDisksNames.

Volver al principio del archivo

Secciones Delete Files (DelFiles)

[ sección-lista-archivo]
nombre-archivo[,,,indicador]
.
.
Una sección DelFiles enumera los nombres de los archivos que se van a eliminar. El nombre sección-lista-archivo debe aparecer en el elemento Delfiles de una sección Install.

nombre-archivo Identifica el archivo que se va a eliminar.

indicador
Parámetro opcional que se usa para forzar que Windows elimine el archivo especificado en el elemento si se está utilizando durante el proceso de instalación. Para indicar a Windows que introduzca en una cola la operación de eliminación de archivo hasta que se haya reiniciado el equipo, establezca el valor del parámetro indicador a 1. Si un archivo marcado con un parámetro indicador igual a 1 no se puede eliminar porque se está utilizando, se reiniciará el sistema una vez que se haya completado la instalación del dispositivo.

Si no usa el parámetro indicador con su valor establecido a 1 junto con un parámetro nombre-archivo, el archivo no se eliminará del equipo si se está utilizando cuando se ejecute la sección DelFiles.

En el ejemplo siguiente se eliminan tres archivos:

[SeccEliminarArchivosAntiguos]
archivo1
archivo2
archivo3

Volver al principio del archivo

Secciones Update .ini File (UpdateInis)

[ nombre-sección-update-ini]
archivo-ini, sección-ini, [entrada-ini-antigua], [entrada-ini-nueva], [indicadores]
.
.
Reemplaza, elimina o agrega entradas completas en el archivo .INI especificado. El nombre de la sección, nombre-sección-update-ini, debe aparecer en el elemento UpdateInis de una sección Install en el archivo .INF.

archivo-ini
Nombre del archivo .INI que contiene la entrada que se va a cambiar. Para obtener más información acerca de cómo especificar el nombre de archivo .INI, consulte los comentarios debajo.

sección-ini
Nombre de la sección que contiene la entrada que se va a cambiar.

entrada-ini-antigua
Opcional. Normalmente tiene el formato Clave=Valor.

entrada-ini-nueva
Opcional. Normalmente tiene el formato Clave=Valor. Tanto la clave como el valor pueden especificar cadenas reemplazables. Por ejemplo, la clave y el valor especificado en el parámetro entrada-ini-nuevapodría ser %Cadena1%, donde la cadena que sustituye a %Cadena1% se define en la sección Strings del archivo .INF.

indicadores
Indicadores de acción opcionales. Pueden ser uno de los valores siguientes:

0 Predeterminado. Si la clave entrada-ini-antigua está presente en una entrada de un archivo .INI, dicha entrada se reemplaza con la entrada-ini-nueva. Tenga en cuenta que sólo las claves del parámetro entrada-ini-antigua y la entrada del archivo .INF deben coincidir; el valor de cada entrada se pasa por alto.

Para agregar entrada-ini-nueva al archivo .INI incondicionalmente, establezca la entrada-ini-antigua a NULL. Para eliminar entrada-ini-antigua del archivo .INI incondicionalmente, establezca entrada-ini-nueva a NULL.

1 | Si la clave y el valor de entrada-ini-antigua existen en una entrada del archivo .INI, dicha entrada se reemplaza con entrada-ini-nueva. Tenga en cuenta que el parámetro entrada-ini-antigua y la entrada del archivo .INF deben coincidir tanto en la clave como en el valor para que se realice la sustitución, a diferencia de lo que sucede si se utiliza un indicador de acción con el valor 0: en este caso sólo deben coincidir las claves para que se lleve a cabo la sustitución.
2 Si la clave del parámetro entrada-ini-antigua no existe en el archivo .INI, no se realiza ninguna operación en el archivo .INI.

Si la clave del parámetro entrada-ini-antigua existe en una entrada del archivo .INI y la clave del parámetro entrada-ini-nueva existe en una entrada del archivo .INI, la entrada del archivo .INI que coincida con la clave del parámetro entrada-ini-nueva se elimina y la entrada del archivo .INI que coincida con el parámetro entrada-ini-antigua se utiliza de la manera siguiente: la clave de la entrada del archivo .INI se reemplaza con la clave del parámetro entrada-ini-nueva.

Si la clave del parámetro entrada-ini-antigua existe en una entrada del archivo .INI y la clave del parámetro entrada-ini-nueva no existe en una entrada del archivo .INI, se agrega una entrada al archivo .INI compuesta por la clave del parámetro entrada-ini-nueva y el valor antiguo.

Tenga en cuenta que la coincidencia del parámetro entrada-ini-antigua y una entrada del archivo .INI se basa sólo en la clave, no en la clave y su valor.

3 | Igual que lo que sucede con el valor 2 del parámetro indicador descrito anteriormente, excepto en que la coincidencia del parámetro entrada-ini-antigua y una entrada del archivo .INF se basa tanto en la clave como en el valor, no sólo en la clave.
Puede usar el carácter comodín asterisco (*) cuando especifique la clave y el valor, y se interpretará de forma correcta.

El nombre archivo-ini puede ser una cadena o una clave de cadena. Una clave de cadena tiene la forma %claveCad%, donde claveCad se define en la sección Strings del archivo .INF. En cualquier caso, el nombre debe ser un nombre de archivo válido.

Debe incluir el nombre de la carpeta que contiene el archivo, pero debe proporcionarse como un identificador de directorio lógico (LDID) en lugar de como un nombre real. El instalador reemplaza un LDID con un nombre real durante la instalación.

Un LDID tiene la forma %ldid%, donde ldid es uno de los identificadores predefinidos o un identificador definido en la sección DestinationDirs. Tenga en cuenta que, cuando se sustituyen las constantes LDID_BOOT y LDID_BOOTHOST, la barra diagonal inversa se incluye en la ruta de acceso. Por ejemplo, LDID_BOOT podría sustituirse por C:\. No obstante, en el archivo .INF puede usar el carácter barra inversa o no usarlo. Por ejemplo, tanto "%30%boot.ini" como "%30%\boot.ini" se pueden usar para hacer referencia a BOOT.ini en la raíz de la unidad de inicio.

Los ejemplos siguientes ilustran la utilización de elementos individuales de una sección Update .ini File en un archivo .INF:

%11%\ejemplo.ini, Seccion1,, Valor1=2 ; agrega una entrada nueva
%11%\ejemplo.ini, Seccion2, Valor3=*, ; elimina una entrada antigua
%11%\ejemplo.ini, Seccion4, Valor5=1, Valor5=4 ; reemplaza una entrada antigua

El conjunto de elementos siguiente de una sección del tipo Update .ini File de un archivo .INF funcionan juntos para operar en la sección Boot de SYSTEM..ini. La capacidad de establecer condiciones integrada en el parámetro indicadores de los elementos del archivo .INF se usa para agregar la entrada "comm.drv=comm.drv" a la sección Boot a menos que la entrada "comm.drv=*vcoscomm.drv" o "comm.drv=*r0dmdcom.drv" exista en la sección Boot, en cuyo caso la entrada existente se mantiene y la entrada "comm.drv=comm.drv" no se agrega al archivo .INI. En otras palabras, tras ejecutar las cuatro entradas del archivo .INF que se muestran debajo, habrá una entrada "comm.drv=" en la sección Boot del archivo .INI: "comm.drv=*vcoscomm.drv", "comm.drv=*r0dmdcom.drv" o "comm.drv=comm.drv."

system.ini, boot, "comm.drv=*vcoscomm.drv",""~CommDrvTemp~=*", 3
system.ini, boot, "comm.drv=*r0dmdcom.drv",""~CommDrvTemp~=*", 3
system.ini, boot,,"comm.drv=comm.drv"
system.ini, boot, "~CommDrvTemp~=*","comm.drv=*", 3

Volver al principio del archivo

Secciones Update .ini Fields (UpdateIniFields)

[ nombre-sección-update-inifields]
archivo-ini, sección-ini, nombre-perfil, [campo-antiguo], [campo-nuevo],[indicadores]
.
.
Reemplaza, agrega y elimina campos en el valor de una entrada .INI dada. A diferencia del tipo de sección Update .ini File, en este tipo de sección se reemplaza, agrega o elimina una parte de un valor de una entrada del archivo .INI en lugar de todo el valor. El nombre de la sección, nombre-sección-update-inifields, debe aparecer en el elemento UpdateIniFields de una sección Install del archivo .INF.

archivo-ini
Nombre del archivo .INI que contiene la entrada que se va a cambiar. Para obtener más información acerca de cómo especificar el nombre del archivo .INI, consulte el tema que describe el tipo de sección Update .ini File.

sección-ini
Nombre de la sección del archivo .INI que contiene la entrada que se va a cambiar.

nombre-perfil
Nombre de la entrada que se va a cambiar.

campo-antiguo
Valor del campo que se va a eliminar.

campo-nuevo
Valor del campo que se va a agregar, si no está allí ya.

indicadores
Especifica si se debe tratar el parámetro campo-antiguo y el parámetro campo-nuevo como si tuvieran un carácter comodín y qué carácter separador se va a utilizar cuando se anexe un campo nuevo a una entrada del archivo .INI. Puede ser uno de los valores siguientes:

Valor | Significado
0 | (Predeterminado) Tratar el carácter "*" literalmente cuando se busque la coincidencia de campos y no como un carácter comodín. Usar un espacio en blanco (" ") como separador al agregar un nuevo campo a una entrada.
1 | Tratar el carácter "*" como un comodín cuando se busque la coincidencia de campos. Usar un espacio en blanco (" ") como separador al agregar un nuevo campo a una entrada.
2 | Tratar el carácter "*" literalmente cuando se busque la coincidencia de campos y no como un carácter comodín. Usar una coma (",") como separador al agregar un nuevo campo a una entrada.
3 | Tratar el carácter "*" como un comodín cuando se busque la coincidencia de campos. Usar una coma (",") como separador al agregar un nuevo campo a una entrada.
Cualquier comentario en una línea del archivo .INI se quitará ya que podría no ser aplicable después de realizar los cambios. Cuando los campos de esta línea del archivo .INI se procesen, los espacios, tabulaciones y comas se usarán como delimitadores de campo. No obstante, se utiliza un espacio como separador cuando el campo nuevo se anexa a la línea.
Volver al principio del archivo

Secciones Add Registry (AddReg)

[ sección-add-registry]
cadena-raíz-reg, [subclave], [nombre-valor], [indicador], [valor]
[cadena-raíz-reg, [subclave], [nombre-valor], [indicador], [valor]]
.
.
Agrega subclaves o nombres de valor al Registro; opcionalmente se establece el valor. El nombre sección-add-registry debe aparecer en un elemento del tipo AddReg de una sección Install.

cadena-raíz-reg
Nombre raíz del Registro. Puede ser uno de los valores siguientes:

HKCR igual que HKEY_CLASSES_ROOT
HKCU igual que HKEY_CURRENT_USER
HKLM igual que HKEY_LOCAL_MACHINE
HKU igual que HKEY_USERS.
HKR significa relativo a la clave pasada en GenInstallEx

subclave
Opcional. Identifica la subclave que se va a definir. Tiene el formato clave1\clave2\clave3.... Este parámetro se puede expresar como una cadena reemplazable. Por ejemplo, podría usar %Subclave1%, donde la cadena que sustituye a %Subclave1% se define en la sección Strings del archivo .INF.

nombre-valor
Opcional. Identifica el nombre del valor para la subclave. Para el tipo cadena, si el parámetro nombre-valor está vacío a la izquierda, el valor de la subclave especificado en el parámetro subclave se establece a una cadena NULL. Tenga en cuenta que el parámetro nombre-valor se puede expresar como una cadena reemplazable. Por ejemplo, podría usar %NombreVal1%, donde la cadena que sustituye a %NombreVal1% se define en la sección Strings del archivo .INF.

indicador
Opcional. Determina tanto el tipo de valor como si la clave del Registro se reemplaza si ya existe.

Valor | Significado
0 | (Predeterminado) Valor es una cadena ANSI. Reemplazar la clave si existe.
1 | Valor es un número hexadecimal. Reemplazar la clave si existe.
2 | Valor es una cadena ANSI. No reemplazar la clave si existe.
3 | Valor es un número hexadecimal. No reemplazar la clave si existe.
valor
Opcional. El valor que se establece. Puede ser una cadena ANSI o un número en notación hexadecimal y formato de Intel. Cualquier elemento que contenga un valor binario puede superar el máximo de 128 bytes para la línea si se utiliza un carácter de barra diagonal inversa (\). También se puede proporcionar una clave de cadena con el formato %claveCad%. La claveCad debe definirse en la sección Strings del archivo .INF. Para usar un carácter % en la línea, use %%.

Son obligatorios dos campos, como mínimo; sin embargo, uno puede ser nulo. Por tanto, al utilizar este formato es obligatorio utilizar, como mínimo, una coma.

Los dos elementos del ejemplo de sección del tipo AddReg siguiente agregan dos nombres de valor al Registro. Tenga en cuenta que %25% se expandirá en la carpeta Windows del equipo.

[EntradasRegMiAplic]
HKLM,Software\MiApli,NombrePrograma,,"Mi Aplicación"
HKLM,Software\MiApli,"Ubicación de programa",,"%25%\MiApli.exe"

Volver al principio del archivo

Secciones Delete Registry (DelReg)

[ sección-del-registry]
cadena-raíz-reg, subclave, [nombre-valor]
[cadena-raíz-reg, subclave, [nombre-valor]]
.
.
Elimina una subclave o nombre de valor del Registro. El nombre sección-del-registry debe aparecer en un elemento DelReg de una sección Install.

cadena-raíz-reg
Nombre raíz del Registro. Puede ser uno de los valores siguientes:

HKCR igual que HKEY_CLASSES_ROOT
HKCU igual que HKEY_CURRENT_USER
HKLM igual que HKEY_LOCAL_MACHINE
HKU igual que HKEY_USERS.
HKR significa relativo a la clave pasada en GenInstallEx

subclave
Identifica la subclave que se va a eliminar. Tiene el formato clave1\clave2\clave3... Este parámetro se puede expresar como una cadena reemplazable. Por ejemplo, podría usar %Subclave1%, donde la cadena que sustituye a %Subclave1% se define en la sección Strings del archivo .INF.

nombre-valor
Opcional. Identifica el nombre del valor para la subclave. Tenga en cuenta que el parámetro nombre-valor se puede expresar como una cadena reemplazable. Por ejemplo, podría usar %NombreVal1%, donde la cadena que sustituye a %NombreVal1% se define en la sección Strings del archivo .INF.

Este tipo de sección puede contener cualquier número de elementos. Cada elemento elimina un subclave o nombre de valor del Registro.

Secciones Ini File to Registry (Ini2Reg)

[ sección-ini-to-registry]
archivo-ini, sección-ini, [clave-ini], cadena-raíz-reg, subclave[,indicadores]
.
.
Mueve líneas o secciones de un archivo .INI al Registro y crea o reemplaza una entrada del Registro debajo de la clave dada en el Registro. El nombre de sección sección-ini-to-registry debe aparecer en un elemento Ini2Reg de una sección Install del archivo .INF.

archivo-ini
Nombre del archivo .INI que contiene la clave que se va a copiar. Para obtener más información acerca de cómo especificar el nombre del archivo .INI, consulte los comentarios del tema "Referencia" acerca de la sección Update .ini File.

sección-ini
Nombre de la sección del archivo .INI que contiene la clave que se va a copiar.

clave-ini
Nombre de la clave del archivo .INI que se va a copiar al Registro. Si clave-ini está vacío, toda la sección se transfiere a la clave del Registro especificada.

cadena-raíz-reg
Nombre raíz del Registro. Puede ser uno de los valores siguientes:

HKCR igual que HKEY_CLASSES_ROOT
HKCU igual que HKEY_CURRENT_USER
HKLM igual que HKEY_LOCAL_MACHINE
HKU igual que HKEY_USERS.
HKR significa relativo a la clave pasada en GenInstallEx

subclave
Identifica la subclave que va a recibir el valor. Tiene el formato clave1\clave2\clave3...

indicadores
Indica si se debe eliminar la clave .INI después de transferirse al Registro y si se debe sobrescribir el valor en el Registro si ya existe la clave del Registro. Puede ser uno de los valores siguientes:

Valor | Significado
0 | (Predeterminado) No eliminar la entrada .INI del archivo .INI después de mover la información de la entrada al Registro. Si la subclave del Registro ya existe, no reemplazar su valor actual.
1 | Eliminar la entrada .INI del archivo .INI después de mover la información de la entrada al Registro. Si la subclave del Registro ya existe, no reemplazar su valor actual.
2 | No eliminar la entrada .INI del archivo .INI después de mover la información de la entrada al Registro. Si la subclave del Registro ya existe, reemplazar su valor actual con el valor de la entrada del archivo .INI.
3 | Eliminar la entrada .INI del archivo .INI después de mover la información de la entrada al Registro. Si la subclave del Registro ya existe, reemplazar su valor actual con el valor de la entrada del archivo .INI.
Por ejemplo, suponga que la entrada siguiente existe en el archivo Win.ini:

[Windows]
CursorBlinkRate=15

Si debajo de Control Panel\Desktop no hay una subclave CursorBlinkRate, el elemento siguiente de la sección Ini File to Registry crea la subclave, establece el valor de la subclave a 15 y no cambia la línea original de WIN..ini:

win.ini,Windows,CursorBlinkRate,HKCU,"Control Panel\Desktop"

Si la subclave ya existe, el elemento del archivo .INF establece el valor de la subclave a 15 y no cambia la línea original de WIN..ini.

Secciones Update Config.sys (UpdateCfgSys)

[ sección-update-config]
Buffers=número-búferes-dos-válido
DelKey=clave
DevAddDev=nombre-controlador,palabraClaveConfig[,indicador][,cadena-parám]
DevDelete=nombre-controlador-dispositivo
DevRename=nombre-dispositivo-actual,nombre-dispositivo-nuevo
Files=número-archivos-dos-válido
PrefixPath=ldid[,ldid]
RemKey=clave
Stacks=valores-pilas-dos

Proporciona comandos para agregar, eliminar o cambiar el nombre de comandos en el archivo Config.sys. El nombre de la sección, nombre-sección-update-ini, debe aparecer en el elemento UpdateInis de una sección Install en el archivo .INF.

No todos los tipos de elemento que se muestran en la sintaxis anterior son necesarios u obligatorios. Una sección Update Config.sys puede contener tantos elementos DevRename, DevDelete, DevAddDev, DelKey y RemKey como se necesiten, pero los elementos Buffers, Files y Stacks sólo se pueden usar una vez en una sección. Cuando se procesa una sección Update Config.sys, el instalador procesa todos los elementos DevRenames en primer lugar, todos los elementos DevDelete después y todos los elementos DevAddDev al final. La sintaxis y significado de cada uno de los tipos de elemento que se pueden usar en una sección Update Config.sys se proporcionan posteriormente en este tema.

Elemento Buffers

Buffers=número-búferes-dos-válido
Establece el número de búferes de archivo. Al igual que con el elemento Stacks, el instalador compara el valor existente con el propuesto y establece siempre el número de búferes al mayor de los dos valores.

número-búferes-dos-válido
Un número de búferes MS-DOS válido.

Elemento DelKey

DelKey=clave
Ocasiona que el comando Config.sys con la clave especificada se comente dentro del archivo Config.sys. Por ejemplo, el elemento de archivo .INF siguiente:

DelKey=Break

ocasionaría que un comando Break=on se comentara dentro del archivo Config.sys.

El elemento DelKey tiene el mismo efecto que el elemento RemKey . Puede haber varios elementos DelKey y RemKey en una sección de un archivo .INF.

clave La clave del comando de Config.sys que se va a comentar.

Elemento DevAddDev

DevAddDev=nombre-controlador,palabraClaveConfig[,indicador][,cadena-parám]
Agrega un comando device o install al archivo CONFIG.SYS.

nombre-controlador
Nombre del archivo ejecutable o controlador que agregar. El instalador valida la extensión del nombre de archivo y comprueba que sea .sys o .exe.

palabraClaveConfig
Nombre del comando. Puede ser device o install.

indicador
Indicador de posición opcional. Si es 0, el comando se coloca al final del archivo. Si es 1, se coloca al principio. Si no se proporciona ningún indicador, se utiliza 0 como opción predeterminada.

cadena-parám
Parámetros de comando opcionales. Deben ser válidos para el controlador de dispositivo o archivo ejecutable especificados.

Elemento DevDelete

DevDelete=nombre-controlador-dispositivo
Elimina las líneas que contengan el nombre de archivo especificado del archivo Config.sys.

nombre-controlador-dispositivo
Nombre de un archivo o controlador de dispositivo. El instalador busca en el archivo Config.sys el nombre y elimina cualquier línea que lo contenga. Ya que MS-DOS no permite extensiones de nombre de archivo implícitas en Config.sys, cada nombre-controlador-dispositivo debe especificar la extensión del nombre de archivo de forma explícita.

En el ejemplo siguiente, el elemento DevDelete de la sección Update Config.sys elimina las líneas 1 y 3, y deja la línea 2 del archivo Config.sys de ejemplo:

DevDelete=nombreArchivo.sys

;; líneas de Config.sys
Device=Filename.sys ;; línea nº 1
Install=Filename.exe ;; línea nº 2
Device=Filename.sys /d:b800 /I:3 ;; línea nº 3

Elemento DevRename

DevRename=nombre-dispositivo-actual,nombre-dispositivo-nuevo
Cambia el nombre de un controlador de dispositivo del archivo Config.sys.

nombre-dispositivo-actual
Nombre del controlador de dispositivo o archivo ejecutable cuyo nombre se va a cambiar. El instalador busca el nombre en la parte de la derecha de un comando device o install en el archivo Config.sys.

nombre-dispositivo-nuevo
Nombre nuevo para el controlador o archivo ejecutable.

Elemento Files

Files=número-archivos-dos-válido
Establece el número máximo de archivos abiertos en el archivo Config.sys. Al igual que con el elemento Stacks, el instalador compara el valor existente con el propuesto y establece siempre el número de búferes al mayor de los dos valores.

número-archivos-dos-válido
Número de archivos de MS-DOS válido.

Elemento PrefixPath

PrefixPath=ldid[,ldid]...
Anexa la ruta de acceso asociada con el LDID dado al comando path.

ldid
Puede ser cualquiera de los valores LDID predefinidos o un valor nuevo definido en el archivo .INF. Para obtener una definición de los valores LDID predefinidos, consulte el tema "Referencia" acerca de la sección DestinationDirs.

Elemento RemKey

RemKey=clave
Ocasiona que el comando de Config.sys con la clave especificada se comente en el archivo Config.sys. Por ejemplo, el elemento del archivo .INF siguiente:

RemKey=Break

ocasionaría que un comando Break=on se comentara en el archivo Config.sys.

El elemento RemKey tiene el mismo efecto que el elemento DelKey . Puede haber varios elementos RemKey y DelKey en una sección del archivo .INF.

clave
La clave del comando de Config.sys que se va a comentar.

Elemento Stacks

Stacks=valores-pilas-dos
Establece el número y tamaño de las pilas del archivo Config.sys. El instalador compara el valor existente con el propuesto y establece siempre el mayor de los dos. Por ejemplo, si Config.sys contiene stacks=9,218 y el archivo .INF contiene stacks=5,256, el instalador establece el nuevo valor a stacks=9,256.

número-pilas-dos-válido
Un número de pilas de MS-DOS válido.

Volver al principio del archivo

Secciones Update Autoexec.bat (UpdateAutoBat)

[ sección-update-autoexec]
CmdAdd=nombre-comando[,parámetros-comando]
CmdDelete=nombre-comando
PrefixPath=ldid[,ldid]
RemOldPath=ldid[,ldid]
TmpDir=ldid[,subdir]
UnSet=nombre-variable-entorno

Proporciona comandos para tratar líneas del archivo Autoexec.bat. El nombre de la sección, update-autoexec-section-name, debe aparecer en el elemento UpdateAutoBat de una sección Install en el archivo .INF.

No todos los tipos de elemento mostrados en la sintaxis anterior son necesarios u obligatorios en una sección Update Autoexec.bat. La sección puede contener tantos elementos CmdAdd, CmdDelete y UnSet como se necesiten pero, en un archivo .INF, sólo se puede usar un elemento PrefixPath, RemOldPath y TmpDir. La sintaxis y significado de cada uno de los tipos de elemento se describen posteriormente en este tema.

El instalador procesa todos los elementos CmdDelete antes de los elementos CmdAdd.

Elemento CmdAdd

CmdAdd =nombre-comando[,"parámetros-comando"]
Agrega el comando y los parámetros de comandos opcionales especificados al final del archivo Autoexec.bat.

nombre-comando
Nombre de un archivo ejecutable, con o sin extensión. Si el nombre de archivo se define también en las secciones SourceDisksFiles y DestinationDirs del archivo .INF, el instalador agrega la ruta de acceso correspondiente al nombre de archivo antes de escribirla en el archivo Autoexec.bat.

parámetros-comando
Cadena incluida entre comillas tipográficas o una cadena reemplazable como %Cadena1% o %MiParametro%, donde las cadenas que sustituyen a %Cadena1% y %MiParametro% se definen en la sección Strings del archivo .INF. El instalador anexa la cadena a nombre-comando antes de anexar la línea al final del archivo Autoexec.bat. El formato de esta línea depende de los requisitos de línea de comando del archivo ejecutable dado.

Elemento CmdDelete

CmdDelete=nombre-comando
Elimina las líneas de Autoexec.bat que incluyan el nombre de comando especificado. El instalador busca y elimina cualquier aparición del nombre especificado que tenga la extensión de nombre de archivo .EXE, .COM y .BAT.

nombre-comando
Nombre de un archivo ejecutable sin extensión.

Elemento PrefixPath

PrefixPath=ldid[,ldid]...
Anexa la ruta de acceso asociada con el LDID dado al comando path.

ldid
Puede ser cualquiera de los valores LDID predefinidos o un valor nuevo definido en el archivo .INF. Para obtener una definición de los valores LDID predefinidos, consulte el tema "Referencia" acerca de la sección DestinationDirs.

Elemento RemOldPath

RemOldPath=ldid[,ldid]
Quita la ruta de acceso asociada al LDID especificado del comando path. Por ejemplo, si el usuario instala una versión nueva de Windows en C:\Newwin y tiene una copia antigua de Windows en C:\Windows, el elemento del archivo .INF siguiente quita C:\Windows de la variable de entorno path:

RemOldPath=10

ldid puede ser cualquiera de los valores LDID predefinidos o un valor nuevo definido en el archivo .INF. Para obtener una definición de los valores LDID predefinidos, consulte el tema "Referencia" acerca de la sección DestinationDirs.

Elemento TmpDir

TmpDir=ldid[,subdir]
Crea una carpeta temporal dentro de la carpeta especificada en el LDID, si no existe.

ldid
Puede ser cualquiera de los valores LDID predefinidos o un valor nuevo definido en el archivo .INF. Para obtener una definición de los valores LDID predefinidos, consulte el tema "Referencia" acerca de la sección DestinationDirs.

subdir
Nombre de la ruta de acceso. Si ldid\subdir no existe, se crea.

Elemento UnSet

UnSet=nombre-variable-entorno
Quita cualquier comando set del archivo Autoexec.bat que incluya el nombre de la variable de entorno especificada.

nombre-variable-entorno
Nombre de una variable de entorno.

Volver al principio del archivo

Sección DestinationDirs

[DestinationDirs]
sección-lista-archivos =ldid[, subdir ]
.
.
[DefaultDestDir=ldid[, subdir ]]

La sección DestinationDirs define los directorios de destino para las operaciones especificadas en sección-lista-archivos, que son las secciones CopyFiles, RenFiles o DelFiles. Opcionalmente, se puede especificar una carpeta de destino predeterminada para las secciones CopyFiles, RenFiles o DelFiles en el archivo .INF que no se nombre explícitamente en la sección DestinationDirs.

sección-lista-archivos
Nombre de una sección CopyFiles,RenFiles o DelFiles. Se puede hacer referencia a este nombre en un elemento Copyfiles, RenFiles o DelFiles de una sección Install.

ldid
Identificador de disco lógico (LDID). Pueden ser uno de los valores siguientes:

00 | LDID nulo; se puede usar para crear un LDID nuevo
01 | Unidad de origen:\rombre de ruta de acceso
10 | Carpeta Machine (se asigna a la carpeta Windows en una instalación con servidor).
11 | Carpeta System
12 | Carpeta IOSubsys
13 | Carpeta Command
17 | Inffolder
18 | Carpeta Help
20 | Fonts
21 | Viewers
22 | VMM32
23 | Carpeta Color
24 | Raíz de la unidad que contiene la carpeta Windows
25 | Carpeta Windows
26 | Dispositivo de inicio garantizado para Windows (Winboot)
28 | Host Winboot
30 | Carpeta raíz de la unidad de inicio
31 | Carpeta raíz para el dispositivo host de una unidad de inicio virtual
subdir
Nombre de la carpeta dentro de la carpeta nombrada por el LDID como carpeta de destino.

El elemento opcional DefaultDestDir proporciona un destino predeterminado para los elementos CopyFiles que usen la notación de copia directa (@nombre de archivo) o las secciones CopyFiles, RenFiles o DelFiles no especificadas en la sección DestinationDirs . Si en una sección DestinationDirs no se utiliza DefaultDestDir, la carpeta predeterminada se establece a LDID_WIN.

En el ejemplo siguiente se establece la carpeta de destino para la sección MoveMiniPort a Windows\Iosybsys y se establece como carpeta predeterminada para otras secciones la carpeta Bin en la unidad de inicio:

[DestinationDirs]
MoveMiniPort=12 ; el destino para la sección MoveMiniPort es
; windows\iosubsys
DefaultDestDirs=30,bin ; la copia directa se hace en boot:\bin

Volver al principio del archivo

Sección SourceDisksNames

[SourceDisksNames]
ordinal-disco="descripción-disco",etiqueta-disco,número-serie-disco
.
.
Identifica y da nombre a los discos que contienen los archivos de origen para las operaciones de copia y cambio de nombre de archivos.

ordinal-disco
Un número exclusivo que identifica un disco de origen. Si hay más de un disco de origen, cada uno debe tener un número ordinal exclusivo.

descripción-disco
Una cadena o clave de cadenas que describe el contenido o propósito del disco. El instalador muestra esta cadena al usuario para identificar el disco. La descripción se incluye entre comillas tipográficas.

etiqueta-disco
Etiqueta de volumen del disco de origen que se define cuando se formatea el disco.

número-serie-disco
No se utiliza. El valor debe ser 0.

En este ejemplo se identifica un disco de origen. La descripción del disco se proporciona como una clave de cadenas:

[SourceDisksNames]
55 = %ID1%, Instd1, 0

[Strings]
ID1="Disco 1 de instalación de mi aplicación"

Volver al principio del archivo
Sección SourceDisksFiles

[SourceDisksFiles]
nombre archivo=número-disco[,subdir] [,tamaño-archivo]
.
.
.
Da nombre a los archivos de origen durante la instalación e identifica los discos de origen que contienen los archivos.

nombre archivo
Nombre del archivo en el disco de origen.

número-disco
Número ordinal del disco de origen que contiene el archivo. Este número ordinal se debe definir en la sección SourceDisksNames y debe tener un valor mayor o igual que 1 (cero no es un valor de parámetro número-disco válido).

subdir
Parámetro opcional que especifica la subcarpeta en el disco de origen donde reside el archivo. Si este parámetro no se usa, la carpeta raíz del disco de origen es la predeterminada.

tamaño-archivo Parámetro opcional que especifica el tamaño del archivo, en bytes.

El ejemplo de sección SourceDisksFiles siguiente identifica un único archivo de origen, SRS01.386, en el disco que tiene el número ordinal 1:

[SourceDisksFiles]
SRS01.386 = 1

Volver al principio del archivo

Sección Strings

[Strings]
clave-cadenas=valor
.
.
Define una o varias claves de cadenas. Una clave de cadenas es un nombre que representa una cadena de caracteres imprimibles. Aunque la sección Strings generalmente es la última del archivo .INF, una clave de cadenas definida en esta sección puede usarse en cualquier parte del archivo .INF en la que se usaría la cadena correspondiente. El instalador sustituye la clave de cadenas por la cadena especificada y la usa en el procesamiento posterior. Debe incluir una clave de cadenas entre signos de porcentaje (%).

clave-cadenas Nombre exclusivo que se compone de letras y dígitos.

valor Cadena que se compone de letras, dígitos u otros caracteres imprimibles. Debe incluirse entre dobles comillas tipográficas si la clave de cadenas correspondiente se utiliza en un tipo de elemento que las requiere.

La sección Strings facilita la conversión en mercados internacionales al colocar todas las cadenas que se pueden mostrar en la interfaz de usuario cuando el archivo .INF se usa en una única sección del archivo .INF. Las claves de cadenas se deben usar siempre que sea posible.

En el ejemplo siguiente se muestra la sección Strings para un archivo .INF de ejemplo.

[Strings]
String0="Mi Aplicación"
String1="Archivo Léame de mi aplicación"
String2="CX2590 SCSI Adapter"

Volver al principio del archivo

Sección Opcional Components

[Optional Components]
nombre-sección-install
[nombre-sección-install]
.
.
Enumera las secciones Install que se muestran cuando el usuario hace clic en el icono Agregar o quitar programas del Panel de control, hace clic en la ficha Instalación de Windows y, a continuación, hace clic en el botón Utilizar disco. La sección Install se presenta como casillas de verificación en la lista.

Tenga en cuenta que la sección Opcional Components se pasa por alto cuando se ejecuta un archivo .INF al hacer clic con el botón secundario del mouse (ratón) en el archivo y seleccionar el verbo "install". Al ejecutar un archivo .INF de esta forma, se ejecuta la sección [DefaultInstall]. La sección Optional Components también se pasa por alto si el archivo .INF se está ejecutando a través del punto de entrada InstallHinfSection de Setupx.dll. Al ejecutar un archivo .INF a través del punto de entrada SETUPX, se ejecuta la sección Install especificada en el parámetro para el punto de entrada.

Las secciones Install siguen el mismo formato que se describió anteriormente y las claves adicionales siguientes se pueden agregar a la sección Install para dirigir la interfaz en el cuadro de diálogo "Utilizar disco":

OptionDesc=descripción-opción
Sugerencia=descripción-sugerencia
InstallDefault=0 | 1;
Si se instala este componente de forma predeterminada. 1=Sí, 0=No.
IconIndex=índice-icono
Parent= nombre-sección-install
Needs=nombre-sección-install, [nombre-sección-install]
Include=archivo-inf, [archivo-inf]

descripción-opción
Cadena que se utiliza como nombre del componente en el cuadro de lista. El parámetro descripción-opción puede ser %Cadena1%, donde la cadena que sustituye a %Cadena1% se define en la sección Strings del archivo .INF.

descripción-sugerencia
Cadena que se muestra en el cuadro "descripción" cuando el componente se selecciona en el cuadro de lista. El parámetro descripción-sugerencia tiene un límite de 255 caracteres y puede ser %Cadena1%, donde la cadena que sustituye a %Cadena1% se define en la sección Strings del archivo .INF.

índice-icono
Valor numérico que determina el miniicono que se muestra junto al nombre del componente. Son valores válidos:
0 Equipo (base y pantalla)
1 Chip de circuitos integrados
2 Pantalla
3 Cables de red
4 Indicador de Windows
5 Mouse
6 Teclado (3 teclas)
7 Teléfono
8 Altavoz
9 Discos duros
10 Conector comm.
11 Diamond (valor predeterminado)
12 Casilla de verificación activada
13 Casilla de verificación desactivada
14 Impresora
15 Tarjeta de red
16 Igual que 0
17 Igual çççque 0 con una mano que ofrece
18 Desconocido (signo de interrogación)
19 Atwork
20 Casilla de verificación atenuada
21 Acceso telefónico a redes
22 Conexión directa por cable
23 Maletín
24 Exchange
25 Partial check
26 Grupo Accesorios
27 Grupo Multimedia
28 Vista rápida
29 MSN
30 Calculadora
31 Desfragmentador
32 Documento genérico
33 DriveSpace
34 Solitario
35 HyperTerminal
36 Empaquetador de objetos
37 Paint
38 Protector de pantalla
39 WordPad
40 Visor del Portapapeles
41 Accessibilidad
42 Copia de seguridad
43 Documento de mapa de bits
44 Mapa de caracteres
45 Punteros de mouse
46 Monitor de red
47 Marcador telefónico
48 Monitor de sistema
49 Help book
50 Globe (international settings)
51 Compresión de audio
52 Reproductor de CD
53 Reproductor multimedia
54 Esquema de sonidos
55 Clip de vídeo
56 Compresión de vídeo
57 Control de volumen
58 Musica sound scheme
59 Jungla - esquema de sonidos
60 Robotz sound scheme
61 Utopía - esquema de sonidos

Parent
El cuadro de lista mostrado en la interfaz de componentes opcionales puede contener niveles secundarios. Si el componente opcional es secundario, la palabra clave Parent= define la sección Install principal.

Needs
Si este componente tiene dependencias en otros componentes, este elemento define las secciones Install que este componente necesita. Si el componente se selecciona, se advertirá al usuario que el componente necesita los componentes descritos en las secciones Install enumeradas en Needs= línea.

Tenga en cuenta que las secciones Install enumeradas en Needs= línea deben estar en el mismo archivo .INF. Sin embargo, si los componentes dependientes de otros archivos .INF se enumeran en la Needs= línea, los archivos .INF deben especificarse en el Include= línea.

Include
El elemento Include permite especificar archivos .INF que el programa de instalación también debe cargar en la memoria cuando carga el archivo .INF, ya que estos archivos .INF contienen secciones que se deben ejecutar además de las secciones Install del archivo .INF. El elemento Needs especifica los nombres de las secciones que usted tiene intención de ejecutar en el archivo o archivos .INF incluidos.

En el ejemplo siguiente se definen dos secciones Install con componentes opcionales; cada sección usa las entradas adicionales para especificar dependencias y elementos de la interfaz:

[Optional Components]
InstalarMisJuegos
InstalarJuegos

[InstalarMisJuegos]
OptionDesc=%DESC_Juegos%
Tip=%TIP_Juegos%
IconIndex=35 ;miniicono de teléfono para los diálogos
Parent=AplicacionesCorreo
Needs=MSMAIL, MAPI, MicrosoftNetwork
Include=mos.inf, msmail.inf
CopyFiles=MisArchivosJuegos
UpdateInis=VínculosAMisJuegos
AddReg=ElementosRegMisJuegos

[InstallOtherApps]
OptionDesc=%DESC_Otros%
Tip=%TIP_Otros%
IconIndex=4 ;miniicono de ventana para cuadros de diálogo
CopyFiles=OtrosArchivos
UpdateInis=OtrosVinculos
AddReg=OtrosElementosReg

[Strings]
DESC_Juegos="Utilidades de correo"
TIP_Juegos="Utilidades adicionales para enviar y organizar correo"
DESC_Otros="Otras herramientas de utilidad"
TIP_Otros="Calculadora, comprobador de disco y monitor de sistema"

Volver al principio del archivo


Usar la tecnología RunOnce

Puede ejecutar cualquier programa después de ejecutar un archivo .INF si agrega entradas a la clave del Registro Runonce. Las entradas RunOnce se ejecutarán la próxima vez que se reinicie el equipo y el usuario inicie una sesión en el sistema (si el inicio de sesión en el sistema es aplicable).

La clave del Registro RunOnce permite iniciar programas en Windows y especificar si deben ejecutarse "silenciosamente", es decir, sin interactuar con el usuario, o como parte de una lista de programas o acciones que el usuario pueda ver. La referencia al programa se elimina entonces, de forma que el programa no se ejecute de nuevo.

Para ejecutar programas silenciosamente, agregue entradas cadenaDescripción=líneaComandos debajo de la clave del Registro siguiente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce

Para ejecutar programas sincrónicamente bajo el control del administrador Runonce de Windows, agregue entradas cadenaDescripción=líneaComandos debajo de la clave del Registro siguiente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup

En el ejemplo siguiente se muestra una sección AddReg que ocasiona que suceda lo siguiente:

  • Iniciar Miapli.exe, que se encuentra en la carpeta Windows, sin interfaz de usuario.

    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce,"SilentApp",,"%25%\miapli.exe"

  • Iniciar Test.exe, que se encuentra en la carpeta System, y mostrar un mensaje similar al siguiente "El programa de instalación de Windows está configurando los elementos siguientes":
    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup,"Herramienta Prueba",,"%11%\test.exe"

Nota

  • La cadena con la descripción que se encuentra debajo de la clave del Registro Setup aparece en la interfaz de usuario.


Ejemplos del IEAK

Esta carpeta contiene secuencias de comandos de configuración de proxy automático, archivos de instalación por lotes y un archivo .INS de ejemplo. La sección incluye además ejemplos ilustrados que pueden ayudarle a comprender algunos conceptos de Internet Explorer y del IEAK.

  • Archivos de ejemplo de proxy automático con JScript o JavaScript
  • Ejemplo de archivo .INF para el servicio de descarga de componentes
  • Ejemplo de archivo de instalación por lotes
  • Ejemplos ilustrados de conceptos del IEAK

También puede encontrar ejemplos adicionales, como archivos para crear un paquete de suscripción con servidor y páginas de ejemplo para descargar e instalar componentes adicionales, en el Kit de herramientas de IEAK.


Contenido del Kit de herramientas de IEAK

El Kit de herramientas de IEAK contiene herramientas, programas y archivos de ejemplo muy útiles. El contenido del kit de herramientas se encuentra en la carpeta \<carpeta de programa IEAK>\Toolkit y sus subcarpetas.

En la carpeta Toolkit encontrará una referencia a los archivos .ISP e .INS en el archivo Insref.xls.

Carpeta Addons

Esta carpeta contiene páginas de ejemplo de componentes adicionales.

Carpeta Corp

Esta carpeta contiene archivos .INS de ejemplo para configuración automática y secuencias de comandos personalizables de páginas Active Server (.ASP). Los archivos .ASP están diseñados para servidores Web en los que se ejecuta Internet Information Server 3.0 (y versiones posteriores), aunque pueden verse con cualquier explorador Web estándar.

Carpeta Graphics

Esta carpeta contiene imágenes y herramientas gráficas de ejemplo.

Carpeta Inf

Esta carpeta contiene un archivo .INF de ejemplo para crear un programa de desinstalación.

Carpeta ISP

Esta carpeta contiene varias herramientas y ejemplos para los proveedores de servicios Internet (ISP):

  • Una herramienta (Asistente para archivos ISP) que configura la información de acceso telefónico.
  • Una herramienta (Inetlogn.exe) que puede ayudarle a almacenar en caché las contraseñas de todos los usuarios, de modo que el usuario no tenga que escribirla en cada inicio de sesión.
  • Secuencias de comandos de ejemplo, herramientas y soluciones personalizables para paquetes de suscripción con servidor, con el Asistente para la conexión a Internet y sin servidor.


Ejemplos ilustrados de conceptos del IEAK

Los diagramas siguientes muestran características y conceptos clave del IEAK.

Experiencia del usuario al instalar Internet Explorer desde un paquete generado en el IEAK

Instalación de Windows Update para Internet Explorer y otras herramientas para Internet

Cómo funciona la personalización

Cómo funciona la configuración automática

Generar un paquete mediante el IEAK

Cómo genera el IEAK paquetes personalizados

Sincronización automática de versiones

Cómo configurar los archivos para distribución

Suscripción a Internet

Proceso de suscripción a un ISP

Administradores corporativos

Directivas del sistema y configuración


Archivos de ejemplo de proxy automático con JScript o JavaScript

Las secuencias de comandos siguientes proporcionan ejemplos de cómo utilizar un archivo .PAC para especificar una dirección URL de proxy automático. Para utilizar estas funciones, debe cambiar los nombres de proxy, los números de puerto y las direcciones IP.

Notas

  • La funciones isInNet, isResolvable y dnsResolve consultan a un servidor DNS.
  • Las referencias a objetos, métodos o propiedades del modelo de objetos provocan errores que no se notifican en el archivo de configuración automática del proxy. Por ejemplo, las referencias window.open(...), alert(...) y password(...) provocan errores en el archivo de configuración automática del proxy en Internet Explorer.

Ejemplo 1: los hosts locales se conectan directamente, los demás lo hacen a través del proxy

La función siguiente comprueba si el host es local y, si lo es, si la conexión es directa. Si no es un host local, se realiza la conexión a través de proxy (proxy).

function FindProxyForURL(url, host)
  {
    if (isPlainHostName(host))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

La función isPlainHostName() comprueba si hay puntos en el nombre del host. Si es así, devuelve falso; en caso contrario, la función devuelve verdadero.

Ejemplo 2: los hosts que hay dentro del servidor de seguridad se conectan directamente; los servidores que estén fuera se conectan a través del proxy

La función siguiente comprueba si el nombre del host no incluye el nombre del dominio (plain) o forma parte de un dominio particular (.company.com) que no sea www o home.

function FindProxyForURL(url, host)
  {
    if ((isPlainHostName(host) ||
      dnsDomainIs(host, ".company.com")) &&
      !localHostOrDomainIs(host, "www.company.com") &&
      !localHostOrDoaminIs(host, "home.company.com"))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Notas

  • La función localHostOrDomainIs sólo se ejecuta para las direcciones URL del dominio local.
  • La función dnsDomainIs devuelve verdadero si el dominio o el nombre de host coinciden con el dominio dado.

Ejemplo 3: si el host se puede resolver, se utiliza una conexión directa. En caso contrario, la conexión se realiza a través de un proxy.

La función siguiente pregunta al servidor DNS para intentar resolver el nombre de host que se le pasa. Si puede, se realiza una conexión directa. Si no puede, se realiza la conexión a través del proxy. Esto resulta de utilidad cuando se utiliza un servidor DNS interno para resolver todos los nombres de host internos.

function FindProxyForURL(url, host)
  {
    if (isResolvable(host))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Vea la nota de la función isResolvable al principio de la página.

Ejemplo 4: si el host se encuentra en una subred especificada, se utiliza una conexión directa. En caso contrario, la conexión se realiza a través de un proxy.

La función siguiente compara el modelo y la máscara de dirección IP dados con el nombre de host. Esto resulta útil si determinados hosts de una subred deben conectarse directamente y otros deben hacerlo mediante un proxy.

function FindProxyForURL(url, host)
  {
    if (isInNet(host, "999.99.9.9", "255.0.255.0"))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Vea la nota de la función isInNet al principio de la página.

La función isInNet (host, modelo, máscara) devuelve verdadero si la dirección IP del host coincide con el modelo especificado. La máscara indica qué parte de la dirección IP debe coincidir (255=coincidir, 0=pasar por alto).

Ejemplo 5: determinar el tipo de conexión en función del dominio del host

La función siguiente especifica que hay una conexión directa si el host es local. Si el host no es local, esta función determina qué proxy se utilizará según el dominio del host. Esto resulta de utilidad si el nombre de dominio del host es uno de los criterios de selección de proxy.

function FindProxyForURL(url, host)
  {
    if (isPlainHostName(host))
      return "DIRECT";
    else if (shExpMatch(host, "*.com"))
      return "PROXY comproxy:80";
    else if (shExpMatch(host, "*.edu"))
      return "PROXY eduproxy:80";
    else
      return "PROXY proxy";
  }

La función shExpMatch (cadena, expSh) devuelve verdadero si cadena coincide con expSh utilizando los modelos de expresión de shell.

Ejemplo 6: determinar el tipo de conexión según el protocolo utilizado

La función siguiente extrae el protocolo que se está utilizando y, de acuerdo con él, realiza la selección del proxy. Si no hay coincidencia con el protocolo, se realiza una conexión directa. Esto resulta de utilidad si el protocolo que se está utilizando es uno de los criterios de selección del proxy.

function FindProxyForURL(url, host)
  {
    if (url.substring(0, 5) == "http:") {
      return "PROXY proxy:80";
    }
    else if (url.substring(0, 4) == "ftp:") {
      return "PROXY fproxy:80";
    }
    else if (url.substring(0, 7) == "gopher:") {
      return "PROXY gproxy";
    }
    else if (url.substring(0, 6) == "https:") {
      return "PROXY secproxy:8080";
    }
    else {
      return "DIRECT";
    }
  }

La función substring extrae el número especificado de caracteres de una cadena.

Ejemplo 7: comprobar si el nombre de host coincide con la dirección IP para determinar la configuración de proxy

La función siguiente selecciona el proxy mediante la conversión del nombre de host en una dirección IP y su comparación con una cadena especificada.

function FindProxyForURL(url, host)
  {
    if (dnsResolve(host) == "999.99.99.999") {  // = http://secproxy
      return "PROXY secproxy:8080";
    }
    else {
      return "PROXY proxy:80";
    }
  }

Vea la nota de la función dnsResolve al principio de la página.

Ejemplo 8: si la dirección IP del host coincide con la dirección IP especificada, se conecta a través de proxy; de lo contrario se conecta directamente

La función siguiente es otra forma de seleccionar el proxy según una dirección IP especificada. En este ejemplo, a diferencia del ejemplo 7, se utiliza la llamada a la función para obtener explícitamente la dirección IP numérica (en el ejemplo 7 se utiliza la función dnsResolve para convertir el nombre de host en una dirección IP numérica).

function FindProxyForURL(url, host)
  {
    if (myIpAddress() == "999.99.999.99") {
      return "PROXY proxy:80";
    }
    else {
      return "DIRECT";
    }
  }

La función myIpAddress devuelve la dirección IP (en formato de enteros separados por puntos) del host en el que se está ejecutando el explorador.

Ejemplo 9: si hay puntos en el nombre de host, la conexión se realiza mediante un proxy. En caso contrario, se utiliza una conexión directa.

La función siguiente comprueba cuántos puntos hay en el nombre de host. Si hay puntos en el nombre de host, se establece una conexión a través de proxy. Si no los hay, se establece una conexión directa. Se trata de otra forma de determinar los tipos de conexión según las características del nombre de host.

function FindProxyForURL(url, host)
  {
    if (dnsDomainLevels(host) > 0) {  // si el número de puntos del host es > que 0
      return "PROXY proxy:80";
    }
    return "DIRECT";
  }

La función dnsDomainLevels devuelve un entero igual al número de puntos que haya en el nombre de host.

Ejemplo 10: especificar los días de la semana que se conectará a través de proxy; los demás días se conectará directamente

La función siguiente determina el tipo de conexión mediante la especificación de los días de la semana apropiados para conectarse a través de proxy. Los días que no estén entre los parámetros se utiliza una conexión directa. Esta función podría resultar de utilidad en situaciones en las que se desee utilizar un proxy cuando hay mucho tráfico y permitir una conexión directa en caso contrario.

function FindProxyForURL(url, host)
  {
    if(weekdayRange("WED", "SAT", "GMT"))
      return "PROXY proxy:80";
    else
      return "DIRECT";
  }

La función weekdayRange ( día1 [,día2] [,fGMT] ) devuelve un valor que indica si el tiempo actual del sistema está dentro del intervalo especificado por los parámetros día1, día2 y fGMT. Sólo es necesario el primer parámetro. El parámetro GMT supone que los valores de tiempo están en la hora media de Greenwich en lugar de la zona horaria local.


Ejemplo de archivo de instalación por lotes

;Ejemplo de un archivo sencillo Iebatch.txt que muestra la selección de la carpeta de instalación,
;realiza la primera opción de instalación de la lista y reinicia automáticamente el equipo.

[Welcome]
Display=0

[SetupChoice]
Display=0

[Custom]
Display=0
Mode=0
InstallDir=c:\Int_exp\en

[Download]
Display=0
DownloadDir=c:\Int_exp\descarga\

[Finish]
Display=0

[Reboot]
Reboot=1

Para obtener más información, consulte los temas siguientes:

  • Ejecutar la instalación por lotes
  • Sintaxis de archivos por lotes


Solucionar problemas relacionados con el paquete personalizado

Si el paquete personalizado no funciona como se había previsto en el equipo del usuario, compruebe las siguientes situaciones:

Se produce un error durante el proceso de instalación de Windows Update en el equipo de un usuario

Si se produce un error en la instalación de Windows Update, puede solucionar el problema con el archivo Active Setup Log.txt. Este archivo registra todo el proceso de desinstalación desde el momento en que se ejecuta IE5Setup.exe hasta que finaliza la descarga del último archivo .CAB.

Al ejecutar IE5Setup.exe, se crea el archivo Active Setup Log.txt en la carpeta en la que está instalado Windows (normalmente, en la carpeta C:\Windows). Si hay un archivo Active Setup Log.txt de una sesión de instalación de Internet Explorer anterior, se le cambiará el nombre a Active Setup Log.bak.

El registro comienza en la fecha y hora en que se inició el programa de instalación y termina con la fecha y hora en que se descargó correctamente el último archivo contenedor (.CAB). Al ir avanzando por el Asistente para la instalación, continuamente se efectúan anotaciones en ese registro. Es el archivo de registro que más información proporciona para determinar qué causó un error en la descarga y cuándo se produjo. La mayor parte de las entradas de este archivo también se escriben en el Registro de Windows; estos datos se registran para ayudarle a realizar una recuperación sin problemas.

Los códigos de error pueden ayudarle a determinar qué estaba haciendo el programa de instalación cuando falló y determinar así la causa del error. Para obtener más información acerca de los códigos de error, consulte Información del registro de errores en el archivo Active Setup Log.txt.

Los archivos no se descargan durante la instalación de Windows Update

El programa de instalación de Windows Update puede cambiar de servidores durante su ejecución para mantener el rendimiento máximo o recuperarse de un sitio de distribución que no responde. El cambio de servidores se produce cuando el programa detecta que no hay tráfico o que éste se ha reducido a menos de un byte en dos minutos.

Si se agota el tiempo de espera de una conexión , el programa de instalación tratará de conectarse al siguiente sitio de descarga en la lista y continuará el proceso de instalación desde el principio del archivo contenedor (.CAB) que quedó descargado parcialmente. Si se agota el tiempo de espera de conexión y el programa de instalación no cambia de servidor, tratará de volver a conectarse al mismo sitio de descarga para continuar el proceso de instalación en el punto en que se interrumpió. Si no puede establecerse esa nueva conexión con el sitio de descarga, el programa de instalación preguntará si desea cancelar la instalación o intentarlo nuevamente.

Si el primer sitio está inactivo, como resultado de problemas en el servidor, por ejemplo, el programa de instalación de Windows Update no podrá encontrar los sitios restantes de forma predeterminada. Una posible solución implica sobrescribir el primer sitio con el comando siguiente:

<ruta de acceso>\ie5setup.exe /C:"ie5wzd.exe /S:""<ruta de acceso>\ie5setup.exe"" /L:""http://mi servidor Web /mi sitio Web /ie5sites.dat"""

<ruta de acceso> es la carpeta en la que se encuentra el archivo IE5setup.exe.

Ejemplo

A continuación se incluye un ejemplo de la sintaxis que debe proporcionarse a los usuarios cuando el primer sitio esté inactivo. Se trata de una línea de comando única mostrada mediante tres líneas de texto para mejorar su legibilidad.

C:\ie5setup.exe /C:"ie5wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\ie5setup.exe""
/L:""http://<direcciónNuevoServidor>/<suDirecciónDeDescarga>/ie5sites.dat """

Los modos de instalación no están disponibles para usuarios de Windows 2000

Independientemente de las opciones de instalación configuradas para el paquete, el programa de instalación de Windows Update sólo presenta una opción de instalación para los usuarios que ejecuten el sistema operativo Windows 2000. Esta opción incluye todos los componentes de Internet de Microsoft, además de los componentes personalizados del paquete.

Los cambios de marca realizados durante la configuración automática no se aplican en los equipos con Windows 2000

Los cambios de marca distribuidos a los usuarios mediante la configuración automática no se aplican si se establece en Directiva de grupo de Windows 2000 la directiva Sin marcas externas. Esta directiva no permite que terceras partes, como proveedores de servicios o de contenido Internet, marquen los programas de Internet, por ejemplo, personalizando las barras de títulos y los logotipos de Internet Explorer y Outlook Express. Para obtener más información, consulte Administrar Microsoft Internet Explorer en Windows 2000.

La desinstalación de un paquete de la versión 5.5 deja en el equipo Internet Explorer 4, en lugar de Internet Explorer 5

Si se instala o desinstala el siguiente software por este orden, el equipo del usuario se configurará de la siguiente manera:

  1. Se comienza con Internet Explorer 4 en el equipo del usuario.
  2. Se instala Internet Explorer 5 en el equipo, desde el paquete IEAK personalizado o desde otro origen.
  3. Se instala Internet Explorer 5.5 en el equipo, desde el paquete IEAK personalizado o desde otro origen.
  4. Se desinstala Internet Explorer 5.5.

Después de haber seguido esta secuencia de pasos, el equipo del usuario tendrá Internet Explorer 4. Deberá reinstalar Internet Explorer 5 si desea usar esta versión del explorador.

No es posible desinstalar los componentes

Cuando falla el proceso de desinstalación, la herramienta más importante para solucionar los problemas y realizar la desinstalación es el registro de desinstalación, IE5 Uninstall Log.txt, que se encuentra en la carpeta \Windows. Este registro incluye todo el proceso de desinstalación de forma secuencial, incluidas las eliminaciones o adiciones de archivos, los cambios, inclusiones o eliminaciones en el Registro, así como los cuadros de diálogo que se van mostrando al usuario.

El registro está dividido en pasos, que corresponden a las distintas fases de una desinstalación. Las entradas en el registro también incluyen un número de objeto que coincide con el número de línea de la entrada correspondiente en el archivo Setup.stf. Las líneas que no tienen un número de objeto son el resultado de acciones personalizadas específicas de Internet Explorer 5 y están incluidas en el archivo IE5.inf o en un archivo .INF resultado de la desinstalación de un componente externo.

Si no puede utilizar la opción Agregar o quitar programas del Panel de control para desinstalar Internet Explorer, puede que se haya eliminado del equipo la información necesaria para la desinstalación. A continuación se enumeran los archivos fundamentales para la desinstalación:

  • IE5bak.dat
  • IE5bak.ini
  • Integrated Browser.dat
  • Integrated Browser.ini.

El cuadro de diálogo de desinstalación avanzada de Internet Explorer ofrece la posibilidad de desinstalar esta información, aunque al hacerlo no podrá desinstalar Internet Explorer en el futuro.

Para obtener información acerca de cómo desinstalar componentes personalizados, consulte Proporcionar la funcionalidad de desinstalación en una secuencia de comandos .INF y Desinstalar un componente personalizado.

La suscripción a Internet con ICW no funciona con marcas en un solo disco

En caso de que use marcas en un solo disco, no utilice el mecanismo de suscripción del Asistente para la conexión a Internet si prevé que alguno de los usuarios va a tener instalado Internet Explorer 4.01 Service Pack 1 (o versiones anteriores); en lugar de ello, para dichos usuarios cree un paquete independiente mediante la suscripción en el modo a pantalla completa.


Solucionar problemas mediante el Asistente para la personalización de Internet Explorer

Si no puede encontrar determinadas pantallas del Asistente para la personalización de Internet Explorer, compruebe lo siguiente:

  • Asegúrese de que ha seleccionado la función correcta (proveedor de contenido Internet (ICP), proveedor de servicios Internet (ISV) o administrador corporativo).
  • Asegúrese de que ha seleccionado el sistema operativo correcto.
  • En la pantalla Selección de características, asegúrese de que todas las características que desea personalizar están seleccionadas. Las pantallas correspondientes a una característica no se mostrarán si no se activa la casilla de verificación correspondiente.
  • Durante la personalización de Outlook Express, compruebe que ha descargado los archivos de Outlook Express y ha agregado Outlook Express a uno de los modos de personalización, como mínimo.

Si piensa personalizar la Actualización del escritorio de Windows, el equipo debe ejecutar esta utilidad en una de las siguientes configuraciones:

  • Windows 98
  • Windows 98 Segunda edición
  • Windows Millennium Edition
  • Windows 2000
  • En otras versiones de Windows deberá utilizar Internet Explorer 5.5 actualizado desde Internet Explorer 4.0 con la Actualización del escritorio de Windows instalada.

Nota

  • Si está configurando una instalación silenciosa o ejecutando el Asistente para la personalización de Internet Explorer desde el Asistente para la instalación de Office, algunas de las opciones de personalización no estarán disponibles.


Información del registro de errores de Active Setup Log.txt

El archivo Active Setup Log.txt puede ayudarle a solucionar errores producidos durante la instalación de Windows Update; contiene el estado del proceso cuando se produjo el error. En el registro puede encontrar las entradas siguientes:

Entrada de registro | Significado
0 | Inicialización; se crea una carpeta temporal y se comprueba si hay espacio en disco.
1 | Comprobación de todas las dependencias.
2 | Descarga de archivos desde el servidor.
3 | Copia de archivos desde la ubicación de descarga en una carpeta de instalación temporal.
4 | Reinicio de la descarga y reintento de la instalación debido a un error de tiempo de espera u otro error de descarga.
5 | Control de los permisos de confianza y comprobación.
6 | Extracción de archivos.
7 | Ejecución del programa de instalación (un archivo .INF o .EXE.)
8 | Instalación finalizada.
9 | Descarga finalizada, todos los archivos descargados.

He aquí algunos códigos de error comunes:

Código de error | Significado
80100003 | Faltan archivos en el directorio de descarga durante la instalación.
800bxxxx | Los códigos de error que empiezan con 800b son errores de permisos.
800Cxxxx | Los códigos de error que empiezan con 800C son errores de urlmon.

Ejemplos

Algunos ejemplos comunes son:

800C005: no se encontró el archivo o el servidor.

800C00B: se agotó el tiempo de la conexión.

8004004: el usuario canceló el programa de instalación.


Glosario

A

acceso telefónico a redes
Conexión a una red de comunicaciones de datos mediante una red pública conmutada de telecomunicaciones en lugar de un circuito dedicado u otro tipo de red privada.
Active Desktop
Uno de los dos componentes instalados con la Actualización del escritorio de Windows. Mediante Active Desktop los usuarios pueden agregar contenido activo, como un indicador de cotizaciones, a su escritorio, a la barra de tareas o a las carpetas. También pueden abrir y ejecutar archivos con un único clic. Es posible deshabilitar Active Desktop en el IEAK aunque se haya instalado la Actualización del escritorio de Windows.
Actualización del escritorio
Consulte Actualización del escritorio de Windows.
Actualización del escritorio de Windows
La Actualización del escritorio de Windows consta de dos componentes: Active Desktop e Integración de shell. Se incluye en Windows 98, Windows 98 Segunda Edición, Windows Millennium Edition y Windows 2000. Este componente no se reinstalará en equipos que utilicen cualquiera de dichos sistemas operativos.
administrador corporativo
Individuo responsable de configurar y mantener los equipos y aplicaciones en una corporación. Los administradores también se encargan de administrar cuentas de usuarios y de grupos, asignar contraseñas y permisos, y ayudar a los usuarios a solucionar problemas de red.
Administrador de conexión
Un versátil marcador de cliente para Internet que puede personalizarse mediante CMAK.
Administrador de perfiles
Herramienta de Internet Explorer Administration Kit que los administradores corporativos utilizan para crear y administrar la configuración automática del escritorio y el explorador dinámicamente.
archivo .ADM (archivo de plantilla de directivas del sistema)
Define las directivas del sistema y restricciones que pueden establecerse para el escritorio, shell y la seguridad del sistema. Consulte directivas de sistema.
archivo .INF (de información)
Archivo que proporciona al programa de instalación de Windows Update para Internet Explorer 5 y herramientas de Internet la información necesaria para instalar un dispositivo o programa. El archivo incluye una lista de configuraciones válidas, el nombre de los archivos del controlador asociados al dispositivo o programa, etc.
archivo .INS (archivo de configuración de Internet)
Archivo que proporciona al programa de instalación de Windows Update las opciones de configuración Internet necesarias para el explorador y los componentes asociados. Puede crear varias versiones del paquete de explorador si cambia el archivo .INS empleado por cada paquete. Utilice el Administrador de perfiles de IEAK para crear, guardar y cargar archivos .INS.
archivo contenedor (archivo .CAB)
Biblioteca de archivos de instalación comprimidos que se almacenan como un archivo único; se utilizan para reducir el tamaño de archivo, y el tiempo de descarga asociado, del contenido del Web que se encuentra en Internet o en los servidores de las intranets de una empresa. El IEAK contiene herramientas que permiten empaquetar componentes personalizados en uno o varios archivos .CAB que, a su vez, pueden incluirse en el paquete IEAK.
archivo por lotes (.BAT)
Archivo de texto ASCII que contiene una secuencia de comandos del sistema operativo; a veces incluye parámetros y operadores admitidos por el lenguaje de comandos por lotes. Cuando el usuario escribe el nombre del archivo por lotes en el símbolo del sistema, el equipo procesa los comandos secuencialmente.
archivos de comandos
Consulte secuencia de comandos de proxy automático.
asignación de la información de versión
Hay dos maneras de asignar la información de versión en Internet Explorer: a cada paquete de Internet Explorer se le asigna un número de versión; la asignación de la información de versión puede aplicarse de modo que se impida que los paquetes antiguos sobrescriban versiones más recientes del mismo paquete. A los componentes individuales de Internet Explorer también se les asigna información de versión; el componente no se descargará ni instalará si ya hay una versión compatible del componente en el equipo cliente. El número de versión contiene un código de dos letras que indica el modo utilizado para generar el paquete IEAK (IC para proveedores de contenido Internet, IS para proveedores de servicios Internet y CO para administradores corporativos).
Asistente para la conexión a Internet (ICW, Internet Connection Wizard)
Herramienta que ayuda a los usuarios a suscribirse a un servicio Internet y controla automáticamente los pasos de configuración del software necesarios para tener acceso a Internet. Los proveedores de servicios Internet pueden personalizar y configurar previamente el ICW de modo que satisfaga las necesidades de sus clientes.
Asistente para la personalización
Consulte Asistente para la personalización de Internet Explorer
Asistente para la personalización de Internet Explorer
El componente principal de Internet Explorer Administration Kit que se utiliza con el fin de generar versiones personalizadas de Internet Explorer para instalarlas en una organización específica.
Autenticación de contraseña segura (SPA, Secure Password Authentication)
Protocolo en el que el servidor utiliza una contraseña cifrada para confirmar la identidad del usuario.
Authenticode
Tecnología que permite identificar a la compañía o el individuo que ha publicado un programa de software y comprobar que no se ha modificado desde su publicación. Los administradores corporativos pueden configurar previamente zonas de seguridad, preestablecer una clasificación y personalizar las entidades emisoras de certificados para impedir que los usuarios descarguen software sin firmar. También pueden definir directivas del sistema y restricciones para controlar si los usuarios podrán modificar la configuración de seguridad.

B

barra del explorador
El lado izquierdo del explorador en el que aparecen las listas Búsqueda, Historial y Favoritos cuando el usuario hace clic en los botones correspondientes de la barra de herramientas. El usuario también puede crear una barra del explorador personalizada, así como un botón de barra de herramientas personalizada para abrirla.
barra Inicio rápido
Área especial de la barra de herramientas situada junto al botón Inicio, diseñada para proporcionar a los usuarios un acceso sencillo al Web, correo electrónico, escritorio y otros servicios del sistema básicos, y a programas u otros iconos que utilicen frecuentemente. La personalización de esta barra de herramientas suele reservarse para el usuario.
búsqueda automática
Característica de Internet Explorer que permite a los usuarios escribir una palabra familiar en la Barra de direcciones para buscar en las páginas usadas con más frecuencia. No es necesario que los usuarios recuerden las direcciones URL exactas de las páginas.

C

caché
Área del disco duro reservada para el almacenamiento de imágenes, texto y otros archivos que el usuario ha visto previamente en Internet.
cadena de agente de usuario
Texto que identifica la versión específica y el origen del explorador.
canales y categorías
Un canal es un sitio Web preparado para trabajar con programas de recepción de información. El mecanismo que lo permite es el archivo de formato de definición de canal (.CDF). Los canales pueden organizarse en categorías y colocarse en el escritorio del usuario.
Capa de sockets seguros (SSL, Secure Sockets Layer)
Protocolo que suministra comunicaciones de datos seguras mediante el cifrado y descifrado de los datos. Permite mantener la privacidad de las comunicaciones en la red mediante una combinación de criptografía de clave pública y cifrado masivo de datos.
carácter comodín
Carácter del teclado que puede utilizarse para representar uno o varios caracteres. El asterisco (*), por ejemplo, normalmente representa uno o varios caracteres, y el signo de interrogación (?) simboliza un único carácter. Los caracteres comodín suelen utilizarse en los sistemas operativos como medio para especificar más de un archivo por su nombre.
carpeta Vistas Web
Los administradores pueden personalizar la apariencia de Mi PC o del Panel de control en los equipos de una organización si personalizan los archivos HTTP que funcionan como plantillas para ellos. La carpeta Vista Web requiere la instalación de la Actualización del escritorio de Windows.
certificado
Consulte certificado digital.
certificado digital
Certificación electrónica emitida por entidades emisoras de certificados que muestra la procedencia de los programas y prueba que el paquete de instalación no se ha alterado. Los administradores deben firmar el código con un certificado digital si van a distribuir un paquete Internet Explorer por Internet.
charla
Consulte MSN Messenger Service.
cifrado
Método que permite cifrar datos para evitar que usuarios no autorizados puedan verlos o usarlos.
clasificación de contenido
Microsoft Internet Explorer ofrece una forma de ayudar a los administradores a controlar los tipos de contenido a los que puede tener acceso un equipo en Internet. El administrador puede ajustar la configuración de modo que refleje el contenido apropiado en las áreas de lenguaje obsceno, desnudos, sexo y violencia. Consulte también PICS.
clave del Registro
Identificador correspondiente a un registro o grupo de registros del Registro.
cliente
Consulte usuario.
cliente personalizado de Messenger Service
Software de cliente generado al marcar un cliente MSN Messenger Service a fin de incluir gráficos de logotipo propios, direcciones URL de descarga y otras opciones de personalización.
código de personalización
Código de licencia asignado a una organización cuando ésta descarga Internet Explorer Administration Kit (IEAK). No es necesario para instalar el IEAK, pero sí para generar paquetes IEAK.
componente
El administrador puede incluir numerosos componentes de Internet de Microsoft y otras organizaciones con el explorador Internet Explorer. Por ejemplo, Outlook Express, Microsoft NetMeeting y MSN Messenger.
componente personalizado
Componente incluido por el usuario en el paquete, además de los componentes de Internet descargados desde Microsoft mediante sincronización automática de versiones (AVS, Automatic Version Synchronization).
componentes adicionales
Componentes no incluidos en el paquete, pero que los usuarios podrán instalar cuando hayan completado la instalación de Windows Update.
configuración automática
Proceso que permite a los administradores corporativos administrar y actualizar las configuraciones de los usuarios, las directivas del sistema y las restricciones correspondientes a Microsoft Internet Explorer desde una ubicación central. Es posible definir manualmente un puntero a un archivo de configuración automática dentro del explorador o mediante la configuración de la instalación del explorador con el IEAK.
configuración de la conexión
Configuración utilizada por Internet Explorer para conectarse a Internet. Por lo general, la configuración de la conexión está compuesta por conjuntos de opciones para las entradas de acceso telefónico a redes, como opciones de configuración de proxy, cuentas, contraseñas y módems.

D

Descubrimiento automático de proxy Web (WPAD, Web Proxy AutoDiscovery)
Protocolo de red estándar utilizado para ayudar al software de cliente de Internet a localizar automáticamente los servicios de caché dentro de una red y servir de interfaz con ellos.
dirección
En relación con Internet, el nombre de un sitio Web al que los usuarios pueden conectarse, como www.microsoft.com, o la dirección de un destinatario de correo electrónico, por ejemplo nombre@compañía.com. Una dirección típica comienza con un nombre de protocolo (ftp:// o http://), seguido del nombre de la organización que mantiene el sitio. El sufijo identifica el tipo de organización. Por ejemplo, las direcciones de sitios comerciales suelen finalizar con .com.
dirección IP (dirección de Protocolo Internet)
Dirección numérica de un equipo. Algunos ISP proporcionan a los usuarios la dirección IP de su servidor. Si no está seguro de si tiene que escribir una dirección IP, póngase en contacto con su proveedor de servicios Internet.
dirección URL de configuración automática
Ubicación del archivo de configuración de Internet (.INS) utilizado para configurar el explorador de este paquete. Mediante este archivo es posible controlar la configuración de varios usuarios desde una ubicación central.
dirección URL de proxy automático
Ubicación del archivo de comandos de proxy automático. Si se cambia este archivo, es posible controlar la configuración de proxy de varios usuarios desde una ubicación central.
directiva
Consulte directivas de sistema.
Directiva de grupo
En Windows 2000, una herramienta de administración para administrar directivas del sistema.
directivas de sistema
Configuración que permite a los administradores definir y controlar el comportamiento de los programas, los recursos de red y el sistema operativo para los usuarios y equipos de una organización.
distribución
Proceso de distribución e instalación de un programa de software en una organización. Una distribución no es lo mismo que una implementación "piloto", en la que se suministra la aplicación de software a un grupo de usuarios más reducido a fin de identificar y evaluar los problemas que podrían producirse durante la distribución.

E

Ejecución automática
Consulte Pantalla de ejecución automática del CD
entidades emisoras de certificados (CA)
Organizaciones que emiten certificados digitales, como VeriSign o GTE. Actúan como un origen de confianza, ya que comprueban la autenticidad de los certificados empleados para firmar y autenticar digitalmente los paquetes de software.
Extensiones multipropósito de correo Internet (MIME, Multipurpose Internet Mail Extensions)
Estándar que amplía las capacidades de SMTP para permitir la transmisión de datos como vídeo, sonido y archivos binarios a través de Internet sin traducir los datos al formato ASCII.

F

Fabricante independiente de software (ISV, Independent Software Vendor)
Programador de software de otro proveedor; individuo u organización que crea software informático de forma independiente.
Favoritos
Vínculos predefinidos a sitios Web. Los favoritos también se denominan "marcadores". Los favoritos de Internet Explorer pueden configurarse para notificar automáticamente al usuario cualquier cambio de su contenido.
firma de código
Proceso de firma de un paquete de Internet Explorer finalizado con un certificado digital. La firma del paquete requiere dos pasos: obtener un certificado digital y firmar el código.
firma digital
Método de autenticación personal basado en el cifrado y en códigos de autorización secretos utilizado para "firmar" documentos electrónicos.

G

grupo piloto
Ejemplo representativo de los equipos de producción utilizados para probar un paquete de Internet Explorer antes de proceder a la distribución completa en toda la organización. Al contrario que en un laboratorio de prueba, en un grupo piloto se emplean usuarios y equipos de producción.
grupos de noticias
Consulte Usenet.
GUID
Identificador exclusivo global (GUID, Globally Unique Identifier) que distingue un programa u objeto de otro. Mediante el IEAK puede generar un GUID para cada componente personalizado. El número se basa en la información del sistema y otros parámetros, como la hora del día. Si su equipo contiene una tarjeta de red con una dirección hardware de tarjeta de red IEEE de 48 bits, esta dirección exclusiva global se incorporará al GUID. De lo contrario, se generará una falsa dirección aleatoria a partir de la información del estado del equipo.

H

HTML dinámico
Conjunto de características que amplía las capacidades del HTML tradicional, con lo que los autores Web consiguen más opciones de diseño y flexibilidad, y un mayor control creativo sobre la apariencia y comportamiento de las páginas Web.

I

IEAK
Consulte Internet Explorer Administration Kit
instalación a petición
Característica que pide al usuario que instale los componentes que todavía no están instalados en el equipo cuando éste ve una página Web que los requiere. El IEAK permite restringir la disponibilidad de esta característica para los usuarios.
instalación automática
Consulte instalación a petición.
instalación interactiva
Configuración del programa de instalación de Windows Update en la que se pide a los usuarios que tomen decisiones durante la instalación. Esta opción sólo está disponible para administradores corporativos. Compare con instalación no interactiva, instalación silenciosa.
instalación no interactiva
Configuración del programa de instalación de Windows Update en la que no se solicita a los usuarios que tomen decisiones y se les informa de los errores y el progreso de la instalación. Esta opción sólo está disponible para administradores corporativos. Compare con instalación silenciosa, instalación interactiva.
instalación por lotes
Ejecución del programa de instalación desde un comando en un archivo por lotes o directamente desde el símbolo del sistema.
instalación silenciosa
Configuración del programa de instalación de Windows Update en la que no se solicita a los usuarios que tomen decisiones acerca de las opciones de instalación ni se les informa de los errores y el progreso de la instalación. Esta opción sólo está disponible para administradores corporativos. Compare con instalación no interactiva, instalación interactiva.
Integración de shell
Uno de los dos componentes instalados con la Actualización del escritorio de Windows. La integración de shell permite a los usuarios examinar sus equipos como si estuvieran explorando el Web. Los usuarios encontrarán los menús Ir a y Favoritos desde cualquier parte.
Internet Explorer Administration Kit (IEAK)
Conjunto de herramientas que permite a los administradores corporativos, los proveedores de servicios Internet y los proveedores de contenido Internet crear, distribuir y administrar paquetes de Internet Explorer personalizados en una organización. El IEAK incluye el Asistente para la personalización de Internet Explorer, el Administrador de perfiles de IEAK y el Kit de herramientas de IEAK.

J

K

Kit de administración del Administrador de conexión (CMAK, Connection Manager Administration Kit)
Herramienta para crear, modificar y administrar perfiles del Administrador de conexión. El Administrador de conexión es un marcador de cliente. CMAK está disponible en Windows 2000 Server y en el Kit de administración de Windows 2000.

L

Lenguaje de marcado de hipertexto (HTML, Hypertext Markup Language)
Lenguaje utilizado para crear y diseñar páginas Web. HTML es un conjunto de etiquetas que los autores Web usan para crear diseños de página, dar formato a los textos, insertar gráficos y elementos multimedia, etc.
Localizador de recursos universal (URL, Uniform Resource Locator)
Una dirección Web, como "http://www.microsoft.com". Consulte dirección.

M

mapa de bits
Formato de archivo para imágenes utilizado con el fin de personalizar los gráficos de un paquete IEAK.
marca
Personalización del explorador Internet Explorer y sus componentes, el Asistente para la instalación de Windows Update y la pantalla de ejecución automática del CD con información de la configuración, opciones, logotipos e identificación de una organización. La marca de una instalación diferencia un paquete de una empresa de una instalación genérica de Internet Explorer.
marca de agua
Mapa de bits mostrado detrás de la barra de herramientas de Internet Explorer. Coloree la marca de agua de modo que no obscurezca el texto o los gráficos de los botones de la barra de herramientas.
marca en un solo disco
Personalización de una instalación de Internet Explorer existente, incluida la suscripción a un ISP, sin reinstalar Internet Explorer. Esta opción no le permite empaquetar ni instalar componentes adicionales.
medio
Material físico empleado para almacenar información del equipo. Las opciones más utilizadas para la distribución del paquete IEAK son el disco compacto, la descarga del Web o los discos.
modo
Subconjunto de funcionalidades del Asistente para la personalización del IEAK, basado en los requisitos de licencia de una organización. Los tres modos del Asistente para la personalización son proveedor de contenido Internet, proveedor de servicios Internet y administrador corporativo. El número de versión del paquete creado con el IEAK contiene un código de dos letras que indica el modo utilizado para generar el paquete IEAK (IC para proveedores de contenido Internet, IS para proveedores de servicios Internet y CO para administradores corporativos).
MSN Messenger Service
Servicio de mensajería instantánea de Microsoft que se utiliza para establecer comunicaciones con otros usuarios del Web. El cliente MSN Messenger Service, o una versión personalizada, puede integrarse con el paquete del explorador o también puede distribuirse como un archivo ejecutable de instalación independiente.

N

nombre de dominio
Nombre de la conexión de red utilizada por DNS que define al propietario de esa organización en un formato jerárquico: servidor.organización.tipo. Por ejemplo, www.CasaBlanca.gob identifica al servidor Web de la Casa Blanca, que forma parte del gobierno de los Estados Unidos. En una dirección de correo electrónico, el nombre de dominio se sitúa después del signo "@".

O

P

página de bienvenida
La página que se mostrará la primera vez que el usuario ejecute Internet Explorer. Posteriormente, Internet Explorer mostrará la página principal del usuario cada vez que éste inicie el explorador.
página de inicio en pantalla completa
Página que se muestra en pantalla completa, en la que no aparecerán la barra de herramientas del explorador ni la barra del menú, que se presenta cuando el usuario ha instalado Internet Explorer.
página principal
En el contexto de Internet Explorer, la página principal es la primera página que los usuarios ven al iniciar el explorador. "Página principal" también es un término general para la página de inicio de un sitio Web, que normalmente contiene un menú o tabla principal con vínculos a otras páginas del sitio.
Panel de información
Consulte Panel de información de Outlook Express.
Panel de información de Outlook Express
Área donde los proveedores de contenido pueden colocar información y vínculos útiles. Los administradores pueden personalizar este panel con los números de teléfono del servicio de asistencia, las preguntas más frecuentes (P+F) e información acerca de la organización.
Pantalla de ejecución automática del CD
Pantalla que se muestra automáticamente al insertar un disco compacto de instalación de Internet Explorer en una estación de trabajo. Esta pantalla suele constar de un botón "Instalar Internet Explorer 5.5", un botón "Cancelar" y un gráfico personalizable.
paquete
Conjunto de códigos de instalación personalizados para Internet Explorer. Un paquete contiene todos los archivos y códigos necesarios para instalar, configurar y ejecutar Internet Explorer. Internet Explorer Administration Kit (IEAK) puede configurar paquetes para varios tipos diferentes de medios de instalación. Consulte también paquete personalizado.
paquete de suscripción
Conjunto de páginas HTML que recopilan información de suscripción perteneciente al cliente y la transfiere, a petición, al servidor de suscripción del proveedor de servicios Internet. La secuencia de páginas guía al cliente a través del proceso de suscripción, de forma parecida a como lo hace el asistente de un programa para Windows.
paquete personalizado
Paquete que contiene versiones personalizadas de todas las herramientas de instalación, códigos de explorador y componentes adicionales necesarios para distribuir de una forma rápida y sencilla Internet Explorer en la organización.
Passport
Servicio de autenticación Web suministrado por Microsoft. Las cuentas de Passport se utilizan para iniciar una sesión en MSN Messenger Service o en un cliente de Messenger Service personalizado.
perfil del Administrador de conexión
Sistema de automatización de las conexiones de acceso telefónico, similar a las entradas del acceso telefónico a redes.
PICS (Parental Internet Content Selection)
Reglas que permiten a los proveedores de contenido Web utilizar metaetiquetas para clasificar de forma voluntaria su contenido de acuerdo con los criterios PICS acordados. Los exploradores pueden bloquear el acceso de los usuarios a los sitios Web en función de los valores de las etiquetas. Consulte también clasificación de contenido.
plataforma
Un tipo de cliente, como Windows 2000, Windows NT 4.0, Windows Millennium Edition, Windows 98, Windows 3.x, Macintosh o UNIX.
Programa de instalación de Windows Update
El programa que instala Internet Explorer y otros componentes de Internet. El IEAK permite personalizar el programa de instalación de Windows Update de modo que se adecue mejor a los usuarios.
Protocolo compacto de acceso a directorios (LDAP, Lightweight Directory Access Protocol)
Estándar abierto para el almacenamiento y la recuperación de nombres, direcciones de correo electrónico, números de teléfono y otra información de los usuarios. La Libreta de direcciones de Windows admite el protocolo LDAP para el acceso a los servicios de directorio y se distribuye con acceso integrado a muchos de los servicios de directorio más utilizados. Los administradores pueden especificar un servicio adicional para sus usuarios.
Protocolo de acceso a mensajes de Internet (IMAP, Internet Message Access Protocol)
Protocolo para recibir mensajes de correo electrónico de uso muy extendido. Permite a los clientes de correo electrónico tener acceso a un archivo de correo electrónico remoto y tratarlo sin descargarlo en el equipo local. Suelen utilizarlo usuarios de empresas que desean leer su correo electrónico desde una ubicación remota. Compare con POP3.
Protocolo de configuración dinámica de host (DHCP, Dynamic Host Configuration Protocol)
Protocolo TCP/IP estándar del sector que asigna configuraciones IP a los equipos. El equipo servidor DHCP lleva a cabo las asignaciones y el equipo cliente llama al equipo servidor para obtener la dirección.
Protocolo de control de transporte/Protocolo Internet (TCP/IP, Transmission Control Protocol/Internet Protocol)
Conjunto de protocolos de comunicación que permite a los equipos comunicarse entre sí.
Protocolo de oficina de correo 3 (POP3, Post Office Protocol 3)
Protocolo para recibir mensajes de correo electrónico de uso muy extendido. Los proveedores de servicios Internet lo utilizan con mucha frecuencia. Los servidores POP3 permiten tener acceso a una única bandeja de entrada, mientras que los servidores IMAP proporcionan acceso a múltiples carpetas en el servidor. Compare con IMAP y SMTP.
Protocolo de transferencia de hipertexto (HTTP, Hypertext Transfer Protocol)
Protocolo que hace que información de hipertexto, como páginas Web, esté disponible en Internet cuando un explorador se conecta al servidor apropiado.
Protocolo de transferencia de noticias a través de la red (NNTP, Network News Transfer Protocol)
Protocolo utilizado para distribuir los mensajes de noticias de red a servidores y clientes (lectores de noticias) asociados de Internet.
Protocolo simple de transferencia de correo (SMTP, Simple Mail Transfer Protocol)
Protocolo utilizado para transferir o enviar mensajes de correo electrónico entre servidores. Para recuperar los mensajes se utiliza otro protocolo (como POP3). Consulte POP3.
Proveedor de contenido Internet (ICP, Internet Content Provider)
Organización que prepara contenido para su publicación en el Web.
Proveedor de servicios Internet (ISP, Internet Service Provider)
Organización que mantiene un servidor conectado directamente a Internet. Normalmente, los usuarios que no están conectados a Internet directamente se conectan mediante un proveedor de servicios. Para adquirir dichas conexiones, los usuarios llaman al proveedor y configuran una cuenta.
proxy automático
Característica que permite a un administrador configurar Internet Explorer de modo que el explorador determine de forma dinámica si se conectará directamente a un host o utilizará un servidor proxy.
prueba de laboratorio
Conjunto de equipos no destinados a la producción utilizados para probar un paquete de Internet Explorer. No es lo mismo que un grupo piloto.
puerta de enlace o gateway
Equipo conectado a varias redes físicas capaz de enrutar o entregar paquetes entre las mismas.

Q

R

Red digital de servicios integrados o RDSI (ISDN, Integrated Services Digital Networking)
Sistema de interconexión de redes de comunicación digital disponible en la mayoría de las compañías telefónicas. La conexión RDSI se utiliza para establecer comunicaciones de alta velocidad con Internet, servicios comerciales en línea o redes de empresa.
Registro
Base de datos central y jerárquica utilizada para almacenar información relativa a la configuración de un equipo para uno o varios usuarios, aplicaciones o dispositivos de hardware. El Registro contiene información a la que el sistema operativo hace referencia continuamente durante su funcionamiento, como los perfiles de cada usuario, las aplicaciones instaladas en el equipo y los tipos de documentos que puede crear cada una, la configuración de las hojas de propiedades de las carpetas y los iconos de aplicación, los componentes de hardware del sistema y los puertos que se están utilizando.
resolución de nombres
Proceso utilizado en la red para convertir una dirección de equipo en un nombre de equipo. La resolución de nombres permite a los equipos buscar y establecer conexión con otros equipos de la red.
ruta de acceso de archivo
Ubicación física de los archivos de distribución en un servidor Web. Por ejemplo, "C:\inetpub\wwwroot\ie5\descarga".
ruta de acceso Web
En el contexto de Internet Explorer Administration Kit, es la ruta de acceso Web utilizada para conectar un explorador a los archivos de instalación de Internet Explorer. Por ejemplo, "www.miorganización.com/ie5.

S

secuencia de comandos de proxy automático
En el IEAK, los archivos con formato JScript (.JS), JavaScript (.JVS) o configuración automática de proxy (.PAC) que permiten configurar y mantener la configuración avanzada de proxy. Al especificar un archivo de comandos de proxy automático, Internet Explorer usa la secuencia de comandos para determinar de forma dinámica si se conectará directamente a un host o utilizará un servidor proxy.
Servicio de acceso remoto (RAS, Remote Access Service)
Servicio que proporciona conexión remota a redes a trabajadores a distancia, usuarios móviles y administradores de sistema que controlan y administran servidores.
Servicio de nombres Internet de Windows (WINS, Windows Internet Name Service)
Servicio de resolución de nombres que convierte los nombres de los equipos en red de Windows a direcciones IP en entornos con enrutamiento. Los servidores que utilizan este servicio controlan la asignación de nombres de los registros, consultas y versiones.
servicio Descarga de componentes de Internet
Servicio del sistema para la descarga e instalación de software desde sitios Web de Internet y de intranets. Este servicio también incluye la característica de comprobación de certificados. La Descarga de componentes de Internet es compatible con Microsoft Internet Explorer versión 3.0 y posteriores.
servidor de suscripción
Consulte servidor de suscripción de Internet.
Servidor de suscripción a Internet (ISS, Internet Sign-up Server)
Servidor HTTP que automatiza la tarea de agregar nuevos clientes a la base de datos de clientes de un ISP. El ISS recopila información de cada cliente, la agrega a la base de datos de clientes del proveedor de servicios Internet y, después, devuelve al equipo del cliente un paquete de configuración. El paquete de configuración contiene la información utilizada para configurar el explorador de Internet del cliente para las conexiones subsiguientes a los servicios del proveedor de servicios Internet.
servidor DNS
Equipo mantenido por un proveedor de servicios Internet (ISP) que hace coincidir direcciones IP con nombres de host. Algunos ISP proporcionan una dirección DNS específica.
servidor IMAP
Servidor que utiliza IMAP para proporcionar acceso a múltiples carpetas en el servidor. Compare con servidor POP3.
servidor POP3
Servidor que proporciona acceso a una única bandeja de entrada. Compare con servidor IMAP.
servidor proxy
Componente de servidor de seguridad que administra el tráfico de Internet a y desde una red de área local (LAN, Local Area Network) y puede proporcionar otras características, como el almacenamiento en caché de documentos y el control de acceso. Los servidores proxy pueden mejorar el rendimiento mediante el suministro de datos solicitados con frecuencia, por ejemplo, una página Web muy utilizada, y pueden filtrar y descartar aquellas solicitudes que el propietario considere inadecuadas, como solicitudes de acceso no autorizado a archivos con dueño. Los servidores proxy pueden configurarse automáticamente como parte de un paquete IEAK.
sin suscripción
Instalación de un proveedor de servicios Internet diseñada para proveedores con módem por cable. En esta instalación, que no incluye el Asistente para la conexión a Internet, el usuario no completa el proceso de suscripción a un servicio una vez que Internet Explorer está instalado en el equipo.
sincronización automática de versión (AVS, Automatic Version Synchronization)
Tecnología que comprueba automáticamente si hay versiones actualizadas de todos los componentes de Internet Explorer cada vez que se ejecuta Internet Explorer Administration Kit (IEAK). Los componentes actualizados pueden descargarse desde Microsoft e incluirse en paquetes IEAK.
Sistema de nombres de dominio (DNS, Domain Name System)
Conjunto de directrices y reglas desarrolladas por los usuarios de Internet en general que permite el uso de direcciones de nombre de dominio (como bluestem.prairienet.org) y direcciones IP (por ejemplo, 192.12.3.4) para explorar Internet. La dirección de nombre de dominio, utilizada por los usuarios, se traduce automáticamente a la dirección IP numérica empleada por el software de enrutamiento de paquetes.
sitio de descarga
Servidor HTTP o FTP desde el que los usuarios pueden descargar un paquete. Si caduca el tiempo de espera de una conexión , el programa de instalación de Windows Update tratará de conectarse al siguiente sitio de descarga especificado en IE5Sites.dat y continuará el proceso de instalación desde el principio del archivo contenedor (.CAB).
suscripción
Una vez que se ha instalado Internet Explorer, pueden utilizarse las características de suscripción para completar el proceso de registro del cliente. La suscripción con servidor aporta una flexibilidad total y se adapta dinámicamente a las distintas opciones de suscripción, pero requiere el uso de secuencias de comandos CGI o ActiveX en un servidor Web. La suscripción sin servidor no requiere un servidor de suscripción. Si selecciona el método sin servidor, el Asistente para la personalización de Internet Explorer le pedirá que proporcione la información necesaria para controlar el proceso de suscripción.
suscripción con servidor
Consulte suscripción.
suscripción sin servidor
Consulte suscripción.

T

territorios
Característica del Kit de administración del Administrador de conexión que proporciona un prefijo (como compañía) o un sufijo (como @compañía.com) a un nombre de usuario al conectar con un servicio del Administrador de conexión.
texto de la barra de título
Texto que aparece en la parte superior de la ventana de un programa. El texto de la barra de título puede marcarse en varias partes de un paquete de Internet Explorer, incluido el propio explorador, la pantalla de ejecución automática del CD, Outlook Express y MSN Messenger Service.

U

Usenet
Los grupos de Usenet también se denominan grupos de noticias. Se trata de grupos de noticias de texto que funcionan como boletines de noticias en los que cualquier usuario puede publicar contenido.
usuario
Persona que instala Internet Explorer y otros componentes en un equipo desde un paquete IEAK personalizado.
usuario final
Consulte usuario.

V

W

X

Y

Z

zona
Consulte zona de seguridad.
zona de seguridad
En Internet Explorer, un segmento de Internet o una intranet asignado a un nivel de seguridad determinado, en función de la confianza que tenga el administrador en el contenido del sitio Web. Las zonas de seguridad permiten a los administradores restringir al acceso de los usuarios a determinados sitios Web.


Descargar y distribuir un paquete de explorador personalizado

Al hacer clic en Finalizar, el asistente crea un paquete de explorador personalizado. En la mayor parte de los casos, los pasos siguientes consistirán en la preparación de los archivos para que sean descargados desde el Web y en la preparación de otros medios de almacenamiento, como pueden ser discos compactos, para su distribución. Para obtener más información acerca de los formatos de los medios, consulte Selección del medio.

Los programas y los archivos contenedores distribuidos a través de Internet o que se encuentren en una intranet que no está configurada específicamente deben firmarse digitalmente. Las firmas digitales muestran la procedencia de los programas y comprueban que no se han alterado. Para obtener más información, consulte Firmar sus programas. Si ha especificado que el Asistente para la personalización de Internet Explorer debe firmar los programas y archivos personalizados, el asistente los firmará al mismo tiempo que crea el paquete. Si no ha especificado que el asistente firme sus programas y archivos, tendrá que firmarlos antes de que los usuarios los descarguen.

A continuación, los pasos que siga para distribuir el explorador personalizado variarán dependiendo de su función y del medio que utilice para distribuir el paquete. Para obtener más información, haga clic en el vínculo que proceda.

  • Proveedor de contenido para Internet (ICP) o desarrollador
  • Proveedor de servicios Internet (ISP)
  • Administrador corporativo


¿Qué es un archivo contenedor (.CAB)?

Un archivo contenedor (.CAB) es una biblioteca de archivos comprimidos almacenados en un único archivo. Los archivos contenedores se utilizan para organizar los archivos de instalación que se copian en el sistema del usuario. Un archivo comprimido de gran tamaño puede dividirse en varios archivos .CAB.

Durante varios años, Microsoft ha utilizado archivos .CAB para comprimir el software que distribuía en discos. Originalmente, esos archivos se utilizaban para reducir al mínimo el número de discos que se incluían con un producto. En la actualidad, los archivos .CAB se utilizan para reducir el tamaño de archivo, y el tiempo asociado para su descarga, del contenido del Web que se encuentra en Internet o en los servidores de las intranets de empresa.

El archivo de información (.INF) se incluye habitualmente en todos los contenedores y proporciona información adicional de la instalación. El archivo .INF puede hacer referencia a archivos del contenedor o a otros archivos y direcciones URL.

El IEAK incluye un conjunto de herramientas que ayudan a crear archivos contenedor y utilizan la tecnología IExpress.

Formato de un contenedor

Cada archivo comprimido en un archivo .CAB se guarda, en su totalidad, en una única carpeta. Un archivo .CAB puede contener una o varias carpetas, o partes de una carpeta. Así, incluso en el caso de que un archivo comprimido no se pueda almacenar en un sólo archivo .CAB, se almacenará en una carpeta que está formada por varios archivos .CAB. Una serie de archivos .CAB de ese tipo forma un conjunto. Cada archivo .CAB contiene información acerca del nombre de los archivos .CAB adyacentes desde un punto de vista lógico.

El formato de archivos .CAB que se utiliza para la descarga de componentes de Internet Explorer de Internet es de uso genérico y está basado en el sistema de compresión Lempel-Ziv.

Firmas digitales

Un archivo .CAB puede tener una firma digital, de igual modo que un control ActiveX. Una firma digital permite identificar a la compañía o individuo que ha desarrollado el software. La firma relaciona el nombre de un proveedor de software con un archivo determinado. La tecnología Authenticode™ se puede usar para incluir la firma en el archivo .CAB.

Puede utilizar archivos .CAB para mejorar la experiencia del usuario final, ya que múltiples archivos se descargan al tiempo y sólo se presenta al usuario un certificado para todos ellos. Puede obtener más información acerca de esta tecnología en el sitio MSDN Online Web Workshop.

Al marcar su control como "seguro para ejecución" (safe for scripting), los usuarios saben que esa secuencia de comandos incluida en una página HTML no puede utilizar el control para dañar sus equipos ni para obtener información que no hayan proporcionado voluntariamente.

Al marcar un control como "seguro para inicialización" (safe for initialization), los usuarios saben que no hay ninguna forma de que un programador de HTML pueda dañar sus equipos al proporcionar al control datos no válidos cuando la página lo inicializa.

Nota

  • Es posible utilizar herramientas para firmar código que permiten firmar archivos .CAB completos mediante un certificado digital.


Trabajar con canales

Gracias a las características de los canales de Internet Explorer, puede especificar qué contenido se debe descargar y cuándo. De esta forma puede proporcionar a los usuarios las últimas noticias e información acerca de una organización. Si los usuarios se actualizan desde Internet Explorer 4 o ejecutan Windows 98, pueden hacer aparecer los canales en una barra especial en el escritorio.

Un canal es un sitio Web preparado para trabajar con programas de recepción de información. El mecanismo que lo permite es el archivo de formato de definición de canal (.CDF). En los canales puede utilizar el contenido que ya tenga, como pueden ser páginas Web y gráficos. Es posible que desee estructurarlo de forma distinta para asegurarse de que los usuarios reciben la cantidad correcta de información y de forma organizada.

Si va a crear canales para múltiples sistemas operativos, debe asegurarse de que el contenido funciona correctamente y se puede leer desde todas las plataformas.

Archivo de formato de definición de canal

El archivo .CDF proporciona un índice de los recursos disponibles en el canal, junto con una programación recomendada para la actualización del canal en el equipo local. Un archivo .CDF incluye algunas etiquetas que especifican los logotipos, los archivos que hay que actualizar y la programación para actualizarlos.

Si el archivo .CDF incluye el elemento ABSTRACT para cada elemento del canal, los usuarios podrán ver una descripción de los elementos. Las descripciones de resumen se muestran dentro de un cuadro de información sobre herramientas que aparece cuando el usuario coloca el cursor sobre el elemento. Los editores en el Web pueden utilizar esta característica para describir el contenido de una página Web determinada o para atraer la atención del usuario y animarle a examinar ese contenido inmediatamente.

Nota

  • Al especificar un archivo .CDF para un canal personalizado en el IEAK, el archivo .CDF no debe contener el elemento LOGO con el atributo IMAGE o ICON.

Recursos adicionales

El formato .CDF está, a su vez, basado en el Lenguaje de marcado extensible (XML, eXtensible Markup Language), un estándar para el almacenamiento y transmisión de datos estructurados. Al igual que el HTML, un documento basado en XML contiene texto con etiquetas. Para obtener mas información y ejemplos, visite el sitio MSDN Online Web Workshop.


Directivas del sistema y configuración


Instalación de Internet Explorer 5


Diagrama Proceso de suscripción a un ISP

 Proceso de suscripción a un ISP


Cómo funciona la personalización


Sincronización automática de versiones


Cómo funciona la configuración automática


Cómo configurar archivos para su distribución


Cómo genera el IEAK paquetes personalizados


Suscribirse a Internet con el Asistente para la conexión a Internet

Imagen de título
Proveedor de
servicios Internet

Crear las pantallas de suscripción del ICW

Todas las pantallas del Asistente para la conexión a Internet deben cumplir los requisitos estándar descritos en Requisitos de código para las pantallas del Asistente para la conexión a Internet.

Crear la pantalla de nombre y dirección para suscripciones con el ICW

Cuando el usuario se conecta a su servidor de suscripción, la primera página que ve en el servidor es la página de nombre y dirección.

La sección HTML para el nombre y la dirección se muestra en un marco dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

Crear la pantalla de opciones de facturación para suscripciones con el ICW

En la página de opciones de facturación, puede presentar las opciones de facturación del servicio entre las que el usuario puede elegir. Las opciones se presentan mediante un formulario HTML dentro de un marco en la ventana del asistente.

El usuario tiene que poder seleccionar una opción mediante un botón de opción HTML y una de las opciones de dichos botones debe estar seleccionada de forma predeterminada. Si el usuario tiene que hacer varias selecciones, también se pueden incluir casillas de verificación HTML en el marco.

El archivo HTML de opciones de facturación que proporcione se mostrará en un marco flotante dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

Crear la pantalla de métodos de pago para suscripciones con el ICW

En la página de métodos de pago, los usuarios especifican cómo desean pagar por el servicio Internet. Cada ISP controla los métodos de pago que están disponibles en la lista de métodos de pago. La información se recopila en el formulario que aparece en el marco situado debajo de la selección, que cambia en función de la opción de pago seleccionada en la lista.

Puede elegir si ofrece los métodos de pago:

  • Tarjeta de crédito; puede especificar el tipo de tarjeta, como Visa o American Express
  • Cargo
  • Factura
  • Cargos de factura de teléfono

Crear la pantalla de correo electrónico o inicio de sesión de la cuenta del ISP para suscripciones con el ICW

La cuarta página del servidor de suscripción es la página de correo electrónico o inicio de sesión de cuenta, que permite al usuario seleccionar un identificador de correo electrónico o un inicio de sesión de cuenta, y una contraseña.

La página HTML de correo electrónico o inicio de sesión de cuenta que el servidor de suscripción envía se muestra en un marco flotante dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

Crear la pantalla de selección de POP del ISP para suscripciones con el ICW

La página de selección del protocolo de oficina de correo (POP) es donde el usuario selecciona un número de teléfono local para el acceso a Internet.

La página HTML de selección de POP que envía el servidor de suscripción del ISP se muestra en un marco flotante dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

No se pedirá al usuario que escriba un código de área o un número de teléfono por segunda vez. Los campos de número de teléfono o código de área del marco se deben llenar previamente con la información enviada al servidor de suscripción del ISP desde el formulario Nombre y dirección.

Crear la pantalla de términos y condiciones del ISP para suscripciones con el ICW

En la página de términos y condiciones del ISP, el ISP muestra el contrato legal que el usuario debe leer para suscribirse al servicio. Para asegurar que el usuario acepta el contrato, el botón Siguiente del ICW no estará disponible hasta que el usuario haga clic en Acepto el contrato.

El usuario puede guardar los términos de la página HTML para verlos más tarde si hace clic en el botón Guardar copia. Cuando el usuario hace clic en el botón, se le pide que escriba un nombre de archivo y una ruta de acceso para guardarlo.

La página HTML de términos y condiciones que envía el servidor de suscripción del ISP se mostrará en un marco flotante con un borde de 2 píxeles dentro del asistente. El marco tiene 426 píxeles de ancho, sin el borde de 2 píxeles y la barra de desplazamiento vertical. La barra de desplazamiento horizontal no aparece si la página HTML supera las dimensiones del ancho.

La página de términos y condiciones debe comenzar con el título del documento e instrucciones que expliquen la forma en que el usuario puede encontrar una copia del documento legal en el sitio Web del ISP si desea verlo de nuevo o imprimirlo.

Nota

  • No hay requisitos de accesibilidad para esta página debido a que en ella no se permiten elementos de formulario HTML.


Crear el archivo Icwsign.htm, las páginas de error y la página de finalización para suscripciones con el ICW

Para suscripciones con el ICW, debe diseñar la pantalla inicial que ven los usuarios (el archivo Icwsign.htm), las páginas de error y la página de finalización.

La primera pantalla: Icwsign.htm

La primera página que el usuario ve después de instalar Internet Explorer y reiniciar el equipo es la página Icwsign.htm. En esta página, el usuario verá un mensaje de bienvenida del ISP y se le pedirá que haga clic en Siguiente para comenzar el proceso de suscripción, si sólo se necesita un archivo ISP para la suscripción, o que seleccione la ciudad y el estado desde los que marca, de forma que el ICW pueda seleccionar el archivo ISP del servidor de suscripción apropiado.

Cuando el usuario hace clic en Siguiente, el ICW marca y conecta al usuario con el servidor de suscripción del ISP. Esta página se especifica en el IEAK y está incluida en su versión de Internet Explorer. No se aloja en el servidor de suscripción.

Páginas de error para suscripciones con el ICW

Si los datos enviados al servidor de suscripción no son válidos en algún momento durante el proceso de suscripción, el servidor puede mostrar una página HTML con un mensaje descriptivo del error. Por ejemplo, si el cliente solicita un nombre de correo electrónico que ya está en uso, puede sugerir alternativas y pedirle que solicite una dirección de correo electrónico diferente.

La página HTML de error que el servidor de suscripción del ISP envía se muestra en un marco flotante dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

El marco debe contener texto que permita al usuario saber que los datos introducidos no eran válidos y proporcionar los elementos de formulario necesarios para que el usuario escriba otros datos.

Para obtener información acerca del diseño HTML y los elementos de formulario necesarios, consulte Requisitos de código para las pantallas del Asistente para la conexión a Internet.

Página de finalización para suscripciones con el ICW

Cuando el usuario hace clic en Siguiente en la página de finalización del ISP, se procesa el archivo .INS y el equipo se configura para la nueva cuenta de Internet. Una vez hecho esto, el ICW muestra su página de finalización, que informa al usuario de que la conexión de Internet está preparada y le indica cómo comenzar a explorar Internet. No hay una interfaz configurable por el ISP en esta página.

La página de finalización también ofrece la opción de comenzar la exploración inmediatamente cuando el usuario activa la casilla de verificación Comenzar la exploración inmediatamente.

Puede usar el valor StartURL del archivo .INF para especificar la página que muestra el explorador cuando se abre por primera vez.

Usar el archivo .INS para configurar el equipo de un usuario

Una vez que el usuario ha finalizado el proceso de suscripción, el servidor de suscripción debe devolver información acerca de cómo configurar el equipo del usuario para el acceso a Internet. El archivo .INS, que se descarga al final del proceso de suscripción, contiene esta información.


Buscar más información en Internet

Puede buscar más información y administrar su cuenta IEAK en Internet.

Para obtener más información, visite el sitio Web del IEAK. Este sitio Web se actualiza con frecuencia, por lo que debe visitarlo a menudo para obtener la información más reciente.


Crear múltiples versiones del explorador

Utilice este proceso para crear diferentes versiones del explorador, como versiones con servidores de correo distintos, que compartan buena parte de la configuración.

El Asistente para la personalización de Internet Explorer muestra la configuración especificada para la versión original del explorador personalizado. Estas opciones de configuración se guardan en el archivo Install.ins. Si cambia el nombre de los archivos .INS, puede realizar cambios rápidamente en todas las versiones del explorador personalizado.

  1. Cree una versión de su explorador personalizado mediante el asistente.
  2. Cambie el nombre del archivo Install.ins, que se encuentra en la carpeta CIE\Custom. Por ejemplo, si necesita una versión para usuarios de Toledo, puede dar al archivo el nombre Toledo.ins.
  3. Abra el archivo Signup.htm de la carpeta CIE\Custom. Cree un vínculo en este archivo al archivo Toledo.ins.
  4. Ejecute de nuevo el asistente y especifique la misma carpeta personalizada como directorio de destino de los archivos de salida.

    5. Procure que la configuración del asistente sea la misma en todas las versiones, a excepción de las siguientes opciones, que pueden personalizarse en cada versión:

    • Logotipo
    • Texto de la barra de título
    • Favoritos
    • Barra de vínculos
    • Página principal y página de búsqueda
    • Servidores de correo y dominio
  5. Repita los pasos del 2 al 4 hasta que haya creado todas las versiones del explorador personalizado.

Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


Crear un archivo .ISP

Si está implementando un proceso de suscripción con su paquete del explorador personalizado, el archivo de suscripción a Internet (.ISP) Signup.isp proporciona la información de acceso telefónico necesaria para los servicios Internet. Si se utiliza el método de suscripción con servidor, este archivo de suscripción a Internet también contiene un vínculo a la dirección URL de la secuencia de comandos del servidor que genera el archivo de configuración (.INS). El Kit de herramientas del IEAK incluye una herramienta (el Asistente para archivos ISP) que puede usar con el fin de generar su archivo .ISP automáticamente.

Para instalar este asistente, haga doble clic en Filewiz.exe en la carpeta \<carpeta de programa IEAK>\Toolkit\ISP\Wizard.

Para iniciar el asistente
  • Haga clic en el menú Inicio, seleccione Programas y, después, haga clic en Archivo ISP Wizard.
  • Siga las instrucciones del asistente para crear un archivo .ISP personalizado.

Nota

  • También puede impedir que se defina un código telefónico como predeterminado si utiliza un indicador en el archivo .ISP. La sintaxis de ese indicador es la siguiente:
    Dial_As_Is=Yes

    Puede utilizar ese indicador de la forma indicada cuando, por ejemplo, algunos usuarios puedan efectuar sus llamadas desde una zona con código telefónico distinto al predeterminado. Si los usuarios no tienen en cuenta que el código de área predeterminado es distinto de su código de área actual, podrían realizar accidentalmente llamadas a larga distancia.


Soporte Técnico

Para España

Los productos de consumo, los Sistemas Operativos Personales de Microsoft, como MS-DOS, Windows 3.x, Windows95 y WindowsNT Workstation, así como las aplicaciones de la familia Microsoft Office y los lenguajes y Kits de Desarrollo de Microsoft, cuentan con soporte Standard limitado gratuito.

Para el resto de productos Microsoft que no disponen de soporte Standard así como una vez que esta modalidad de soporte gratuito hubiese acabado, Microsoft Ibérica pone a su disposición una amplia gama de servicios de Soporte Técnico que van desde la contratación de un incidente individual o packs de incidentes, hasta contratos Priority con servicios y privilegios especiales.

Asimismo, en los Servicios de Información podrá encontrar toda la ayuda que necesite sin restricciones de horarios ni coste (excepto el de la llamada telefónica). Artículos técnicos, FAQ's (o las preguntas más comunes), Service Packs, Parches (correctores de errores concretos), Drivers actualizados y nuestra Base del Conocimiento (Knowledge Base).

Todos estos servicios se pueden localizar en Internet (http://www.microsoft.com/spain/support/)

Los Servicios de Información, también cuentan con suscripciones anuales a Microsoft TechNet y a MSDN.

También podrá encontrar ayuda en nuestros Servicios de Información. Para más información, consulte nuestra web en www.microsoft.com/spain/support/ y/o llame a nuestro teléfono de Servicio a Clientes 902 197198 ó 91 375 40 04

Nota: Microsoft se reserva el derecho de cambiar los servicios descritos sin previo aviso.

Para Latinoamérica

Microsoft Soporte Técnico está sujeto a los términos y condiciones vigentes en cada país donde se ofrece este servicio y está sujeto a cambio sin previo aviso.

Podrá encontrar la respuesta a las preguntas más frecuentes de los productos Microsoft y obtener las últimas actualizaciones disponibles a través de nuestro Servicio de Soporte Técnico en Internet, accediendo a http://www.microsoft.com/latam/soporte

Soporte Técnico Telefónico

Para llamar a soporte técnico debe tener disponible la documentación correspondiente del producto Microsoft y seguir los siguientes pasos:

  • Se le pedirá el número de la versión del producto que está usando.
  • El número de producto o PID (Product Identification).
  • El tipo de hardware que está usando.
  • El Sistema Operativo.
  • Las palabras exactas de los mensajes que aparecen en la pantalla.
  • Una descripción de lo que ha sucedido y de lo que estaba haciendo cuando el problema se presentó.
  • Una descripción sobre cómo trató de resolver el problema.
  • Los números telefónicos para soporte técnico se encuentran en la siguiente lista.

Argentina

Microsoft de Argentina S.A.

Servicios al Cliente: (54) (11) 4316-4600

Fax: (54) (11) 4316-4698

Soporte Técnico: (54) (11) 4316-4664

Bolivia

Soporte Técnico: 0800 3443

Atención a Clientes: (02) 334545

Brasil

Microsoft Informática Ltda.

Teléfono: (55) (11) 5514 - 7100

Fax: (55) (11) 5514 - 7106/5514-7107

Soporte Técnico: (55) (11) 5506 - 8087

Soporte Técnico Fax: (55) (11) 5506 - 7621

Bulletin Board Service (BBS): (55) (11) 5506 - 1234

Servicios al Cliente : (55) (11) 822 - 5764

Caribe y Centro América

Microsoft Caribbean, Inc. CARIBE

Teléfono: (787) 273-3600

Fax: (787) 273-3636

Soporte Técnico: (408) 953 8086

Correo Electrónico para soporte técnico: mscasup@microsoft.com

Centro de Servicios: (800) 297 5982, para códigos de áreas 787 & 809 solamente, 506-298-2000 (para otras áreas)

Correo Electrónico para Atención a Usuarios: msccatus@microsoft.com

Puerto Rico (EE:UU)

Soporte Técnico: (408) 953 8086

Correo Electrónico para soporte técnico: mscasup@microsoft.com

Centro de Servicios: (800) 297 5982 para códigos de áreas 787 & 809 solamente

Correo Electrónico para Atención a Usuarios: msccatus@microsoft.com

República Dominicana

Ver Caribbean

Centro América

Soporte Técnico: (506) 298 2020

Correo Electrónico para soporte técnico: mscasup@microsoft.com

Customer Service/Centro de Servicios: (506) 298 2000

Customer Service E-mail/Correo Electrónico para Atención a Usuarios: msccatus@microsoft.com

Panamá

Microsoft de Panamá, S.A.

Soporte Técnico: (506) 298 2020

Correo Electrónico para soporte técnico: mscasup@microsoft.com

Centro de Servicios: (800) 506-0001

Correo Electrónico para Atención a Usuarios: msccatus@microsoft.com

Chile

Microsoft Chile S.A.

Teléfono: 800-330-6000

Colombia

Microsoft Colombia

Línea de Respuesta Microsoft (Santafé de Bogotá D.C.)

Teléfono: (571) 524-0404

Para llamadas desde fuera de Bogotá: 9800-10595

Fax: (571) 524-0405

Correo de Voz: 503-4216

Ecuador

Microsoft del Ecuador S.A.

Teléfono: 02-25-80-25

PBX: (593) 2 - 263820

Fax: (593) 2 - 262894

México

Microsoft México, S.A. de C.V.

Aplicaciones y Sistemas Operativos de Escritorio: (52) (5) 265-3399

Herramientas de Desarrollo y Sistemas Avanzados: (52) (5) 267-2110

Atención a clientes: (52) (5) 265-3380

Bulletin Board Service: (52) (5) 628-6202 y 628-6200

(2400s/14400k baud, 8 bits, No parity, 1 stop bit, ANSI terminal emul.)

(28800k baud, 8 bits, No parity, 1 stop bit, ANSI terminal emulation)

User: MSMEXICO, NO Password

Paraguay

Soporte Técnico: 465 865

Perú

Microsoft Perú S.A.

Atención al Cliente: (511) 215-5002

Soporte Técnico: (511) 215-5005

InfoEmpresa: (511) 215-5006

Información sobre Eventos: (511) 215-5003

Fax: (511) 215-5004

Uruguay

Teléfono: (598) (2) 774934

Fax: (598) (2) 774935

Venezuela

Microsoft Venezuela S.A.

Teléfono: (582) 276-0500

Fax: (582) 276-0600

Soporte Técnico: (582) 993 6755

Atención al Cliente: (582) 237 7911


Ayuda de Microsoft Internet Explorer Administration Kit

Internet Explorer Administration Kit

le ayuda a personalizar, distribuir y mantener Internet Explorer.

Puede entregar "el Web a su gusto". Examinar la Ayuda en línea para averiguar cómo hacerlo.

viñeta cuadrada Examinar el índice

viñeta cuadrada Realizar una búsqueda de texto

viñeta cuadrada Imprimir temas

© 1999-2000 Microsoft Corporation. Reservados todos los derechos. Condiciones de uso.
Fotografía: Rob Goldman/CORBIS


Nombre de la organización y código de personalización

En esta pantalla, escriba el nombre de su organización y su código de personalización de diez dígitos, y seleccione la función que coincide con su contrato de licencia.

Nombre de la organización
Escriba el nombre de su organización. Este nombre no aparecerá en la barra de título del explorador; podrá definir esta opción posteriormente en el Asistente para la personalización de Internet Explorer.
Código de personalización
Debe haber recibido su código de personalización por correo o correo electrónico tras registrarse en el sitio Web de IEAK. Si desea obtener la licencia para redistribuir legalmente Internet Explorer y sus productos relacionados, debe registrarse en Microsoft.

Este código de personalización es imprescindible, no puede ejecutar el asistente sin él. Guárdelo en un lugar seguro y no lo proporcione a personas u organizaciones no autorizadas.

Notas

  • El Asistente para la personalización de Internet Explorer incluye un código de personalización predeterminado. Mediante este valor podrá completar todas las pantallas del asistente; sin embargo, no le permitirá crear un paquete de instalación personalizado.
  • Si ha perdido el código de personalización, visite el sitio Web de IEAK para obtener más instrucciones.
Función
Elija la función que coincida con las tareas que desea realizar con el IEAK.
  • Proveedor de contenido o programador si proporciona contenido personalizado, vínculos y funcionalidad a los usuarios
  • Proveedor de servicios si proporciona servicios Internet a los usuarios.
  • Administrador corporativo si administra el software y los servicios Internet de una organización.

Importante

  • La función elegida debe coincidir con el contrato de licencia.


Selección de idioma

Elija el idioma que desee en la lista Idioma de destino. Si el idioma que desea utilizar no aparece en la lista, salga del asistente, inserte el CD del IEAK que contiene el idioma que desea utilizar y, después, reinicie el asistente.

Debe ejecutar el Asistente para la personalización de Internet Explorer una vez para cada paquete de Internet Explorer traducido que desee crear. Para mantener la configuración en varias versiones, especifique la misma carpeta de destino para cada versión. Las versiones traducidas se guardarán en carpetas diferentes dentro de la carpeta de destino.

Ejemplo

Por ejemplo, EN es la abreviatura de English (inglés) y DE es la abreviatura de Deutsch (Alemán).

Si especifica C:\Cie\Build1\ como carpeta de destino, el paquete personalizado que contiene una versión descargable en idioma inglés de Internet Explorer se crea en la carpeta siguiente:
C:\Cie\Build1\Download\Win32\EN

El paquete personalizado que contiene una versión descargable en idioma alemán de Internet Explorer se crea en la carpeta siguiente:
C:\Cie\Build1\Download\Win32\DE

Notas

  • Los usuarios pueden instalar una versión de Internet Explorer que emplee un idioma diferente al utilizado en sus sistemas operativos.
  • Si incluye la Actualización del escritorio de Windows como un componente del paquete, el idioma utilizado en el paquete IEAK debe coincidir con el del sistema operativo del usuario. Si los usuarios intentan instalar el explorador y la Actualización del escritorio de Windows en un idioma diferente, sólo se instalará el explorador.
  • La única designación de plataforma en Internet Explorer Administrative Kit 5.5 es "Win32"; para clientes UNIX y Windows de 16 bits, use Internet Explorer Administrative Kit 5.0x.


Selección del medio

En esta pantalla se determina el tipo de medio que utilizará para distribuir el paquete.

Descargar
Seleccione esta opción con el fin de generar un paquete para descargar a través de una intranet o de Internet. Puede construir sus paquetes personalizados en su disco duro y moverlos después a un servidor de Internet o bien, si es administrador corporativo, a un servidor de intranet. También puede generar los paquetes directamente en el servidor; para ello, especifique la ruta de acceso del servidor como carpeta de destino. Para obtener más información, consulte Ubicaciones de archivos.
CD-ROM
Cuando crea una versión en CD-ROM, también puede especificar la información de Autorun. Esta opción agrupa el paquete personalizado en un conjunto de carpetas y permite utilizar el programa de ejecución automática (Autorun), que muestra la pantalla que verán los usuarios cuando inserten el CD-ROM en el equipo.
Simple (todos los archivos en un directorio)
Si genera los paquetes en una red de área local o si piensa moverlos a una, debe seleccionar esta opción para colocar todos los archivos necesarios en una carpeta situada bajo la carpeta de destino, por ejemplo, C:\Cie\Lan.
Marca en un solo disco
Seleccione esta opción para personalizar una instalación existente de Internet Explorer (versiones 4.01 Service Pack 1, incluido con Windows 98, y posteriores). Esta opción crea un el archivo Setup.exe en la carpeta BrndOnly de la ubicación de su compilación. Puede distribuir este archivo en cualquier medio o servidor. Cuando se ejecute este archivo, personalizará las características de Internet Explorer, incluida la suscripción a Internet con un ISP, sin instalar Internet Explorer. No es posible incluir componentes personalizados ni perfiles del Administrador de conexión en un paquete con marcas en un solo disco, ya que el tamaño del paquete superaría la capacidad del disco.

Importante

  • En caso de que use marcas en un solo disco, no emplee el mecanismo de suscripción con el Asistente para la conexión a Internet si prevé que alguno de los usuarios va a tener instalado Internet Explorer 4.01 Service Pack 1 (o versiones anteriores); en lugar de ello, para dichos usuarios cree un paquete independiente mediante la suscripción en pantalla completa.


Ubicaciones de archivos

Puede cambiar la carpeta de destino en la que se crea el paquete IEAK y la carpeta en la que se descargan los componentes.

Carpeta de destino
En la carpeta de destino se colocarán los paquetes personalizados cuando termine el asistente. Puede crear el paquete en el disco duro y moverlo después a un servidor de Internet o de intranet, o puede crearlo directamente en un servidor Web.

En la carpeta de destino que especifique para cada plataforma y soporte de distribución se crean subcarpetas para cada versión traducida.

Si crea el paquete en el disco duro o en una unidad de red, el destino recomendado es C:\Cie\Dist. Si lo crea en un servidor Web que se ejecuta desde el disco duro, el destino debe ser la ruta de acceso del servidor Web.

Para ver un ejemplo, consulte Cómo configurar los archivos para distribución.

Ejemplo: ubicación de la carpeta de destino

Por ejemplo, si especifica la carpeta de destino como C:\Inetpub\Wwwroot\Cie\Dist, la versión en inglés de las plataformas Windows será C:\Inetpub\Wwwroot\Cie\Dist\Download\Win32\En.

Opciones avanzadas
Para personalizar la ubicación y el proceso de descarga de archivos, o para importar opciones de configuración desde un archivo .INS existente, haga clic en Opciones avanzadas.
Compruebe los componentes más recientes mediante la Sincronización automática de versiones (AVS)
El IEAK puede buscar en Internet las versiones más recientes de los componentes mientras crea el paquete de Internet Explorer. Esta característica puede ayudarle a detectar si hay nuevas versiones disponibles desde la última vez que ejecutó el Asistente para la personalización de Internet Explorer.

Si ha descargado el IEAK desde Internet, debe ejecutar el Asistente para la personalización con Sincronización automática de versión (AVS) al menos una vez, para que el asistente pueda comprobar si hay versiones actualizadas de los componentes.

Ruta de acceso del archivo .INS para importar la configuración
Para importar opciones de configuración de un archivo .INS existente como primer paso para crear un nuevo paquete IEAK, escriba la ruta de acceso completa. Al importar la configuración puede ahorrar tiempo si el nuevo paquete tiene una configuración similar a la importada. Sin embargo, puede cambiar todas las opciones de configuración que desee.
Carpeta de descarga de componentes
Los componentes y archivos de instalación que descargue se guardarán en la carpeta que especifique. La característica de sincronización automática de versiones (AVS) examina automáticamente esa carpeta para determinar si están disponibles las versiones más recientes de los componentes. Con AVS, sólo se descargan los componentes que han cambiado desde la última vez que se descargaron. Es aconsejable que no cambie de carpeta, para que pueda mantener sincronizados los componentes.

Sólo debe cambiar esta carpeta si piensa conservar los archivos que descargó la última vez que ejecutó el asistente, aunque desee descargar un nuevo conjunto de componentes.


Selección de características

Para determinar qué otras pantallas del asistente se mostrarán, active o desactive las casillas de verificación de esta pantalla. Por ejemplo, si piensa personalizar sólo los vínculos y direcciones URL, puede desactivar el resto de las casillas de verificación para que no se muestren las pantallas correspondientes. Estas opciones le permitirán crear su paquete de una forma rápida y sencilla, ya que el Asistente para la personalización de Internet Explorer sólo mostrará las pantallas que necesite.

Para utilizar la configuración de un paquete IEAK creado previamente como base de este paquete, vuelva a la pantalla Ubicaciones de archivos y haga clic en el botón Opciones avanzadas para importar un archivo .INS. Mientras crea el nuevo paquete puede cambiar cualquiera de las configuraciones importadas.


Paso 1. Introducción: recopilar información

Imagen de título
Asistente

Paso 1: recopilar información

En este paso del Asistente para la personalización de Internet Explorer, se le pedirán los datos básicos, como el idioma, del paquete que va a crear y las características que desea personalizar en el mismo.

Las opciones disponibles dependerán de su función:

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo

Nota

  • El Asistente para la personalización de Internet Explorer no funcionará correctamente si no está instalado Internet Explorer 5.5. o una versión posterior. Para obtener más información, consulte Requisitos de hardware y del sistema.


Sitio de descarga y Sincronización automática de versiones (AVS)

En estos pasos va a descargar los programas y herramientas de Microsoft más recientes. Si ya tiene la versión más reciente de un componente, se le indicará que debe conservarla. Para descargar componentes es posible que tenga que desactivar temporalmente los programas de detección de virus; si fuera necesario, aparecería un mensaje que lo indica.

Sitio de descarga de Microsoft
Elija el sitio desde el que descargará la versión más reciente de Internet Explorer y de las herramientas de Internet, y haga clic en Siguiente para ver la página Sincronización automática de versiones en el Asistente para la personalización de Internet Explorer.
Descarga de componentes de Internet Explorer
Descargue las versiones más recientes de cualquiera de los componentes de Microsoft que se muestran en el cuadro. El estado de cada componente se indica como se muestra a continuación:
Símbolo | Significado
X roja | Este componente no se ha descargado actualmente.
signo de admiración amarillo | Hay una versión obsoleta de este componente en su ubicación de descarga.
marca de verificación verde | La versión más reciente de este componente se encuentra en su ubicación de descarga.

Debe descargar el explorador Internet Explorer para continuar más allá de este paso.

Para descargar o actualizar más de un componente, seleccione cada componente que desee y, después, haga clic en Sincronizar. Para descargar todos los componentes disponibles, haga clic en Sincronizar todo.

En algunas ocasiones, es posible que las versiones de algunos componentes y revisiones de software del sitio Web de Windows Update sean más recientes que los archivos de la Sincronización automática de versiones del IEAK. Si desea incluir otras versiones de los archivos en el paquete, puede agrupar los archivos asociados en un componente personalizado. Para obtener más información, consulte Empaquetar actualizaciones de Microsoft en componentes personalizados.

Para ver un ejemplo del sistema AVS, consulte Sincronización automática de versiones.

Para obtener información acerca de las actualizaciones más recientes de los productos, visite el sitio Web Corporate Windows Update.

En este paso del asistente se descargan en su equipo los archivos de instalación de Internet Explorer y otros componentes. Es aconsejable que mantenga una copia de estos archivos en el disco duro, lo que le permitirá volver a crear el paquete fácilmente. Cuando vuelva a crear el paquete, el Asistente para la personalización de Internet Explorer podrá comprobar si hay disponibles versiones más recientes de estos programas.

Notas

  • Si ha desactivado la casilla de verificación Buscar los componentes más recientes mediante la Sincronización automática de versiones (AVS) del cuadro de diálogo Opciones avanzadas, en el paso 1 de este asistente (consulte Ubicaciones de archivos), el Asistente para la personalización de Internet Explorer no podrá comprobar si dispone de la versión más reciente de los componentes. Los iconos no serán verdes, incluso aunque tenga la versión más reciente. Para los componentes que ya ha descargado, los iconos serán amarillos. Para los componentes que no haya descargado, los iconos serán rojos. Además, si ha deshabilitado la sincronización de versiones, no podrá descargar determinados componentes en este paso del asistente.
  • Para obtener información acerca de componentes y sus cadenas IdComponente asociadas, consulte el sitio Web de IEAK.


Agregar componentes personalizados

Es posible agregar hasta diez componentes personalizados que los usuarios pueden instalar al mismo tiempo que el explorador. Estos componentes pueden ser archivos contenedores (.CAB) comprimidos o archivos ejecutables (.EXE) autoextraíbles. Como alternativa, quizás desee instalar una versión de un componente de Microsoft distinto del que está disponible mediante la Sincronización automática de versiones (AVS).

Se aconseja que firme el código personalizado que vaya a descargar a través de Internet. La firma del código permite a los usuarios saber que pueden confiar en él antes de descargarlo en sus equipos. Con la configuración predeterminada de Internet Explorer se rechazará el código sin firmar.

Algunas de las opciones siguientes no están disponibles en todas las plataformas.

Comando
Si especifica un archivo .CAB, también debe especificar el comando que se debe ejecutar para extraerlo.
Componente
Escriba en este cuadro el nombre del componente. Este nombre aparecerá en la pantalla de instalación cuando los usuarios instalen el software.
Descripción
Escriba hasta un máximo de 511 caracteres para describir el componente. Este texto aparecerá en el programa de instalación cuando el usuario apunte al componente.
GUID
Si el programa ya tiene un identificador exclusivo global o GUID, escríbalo en este cuadro. Si el programa no tiene un GUID, se generará automáticamente. El GUID establece una identidad única para los programas, objetos y otros elementos.
Ubicación
Escriba la ruta de acceso de su programa o haga clic en Examinar para buscarlo.
Parámetro
Puede especificar los modificadores con que se ejecutará el programa personalizado. Por ejemplo, puede que desee instalar el programa de forma "silenciosa", con pocas o ninguna pregunta, para que no se pida al usuario ninguna información del programa ni de Internet Explorer. Para excluir específicamente las preguntas que hace el programa de instalación, use el modificador /Q:A.
Clave de desinstalación
El programa de instalación de Windows Update compara este valor con HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\Nombre de aplicación para comprobar dos veces que el componente se ha instalado correctamente.

Para obtener más información, consulte Desinstalar un componente personalizado.

Comprobar
Normalmente, los programas instalados a través de Internet necesitan una firma digital que identifique su origen y garantice que el código no se ha cambiado desde que se firmó. En función de la configuración de seguridad del explorador, los usuarios pueden recibir una advertencia antes de que se descargue el programa. Las entidades emisoras de certificados pueden proporcionar las claves públicas y privadas necesarias para firmar el código. Para averiguar si un programa está firmado digitalmente, haga clic en Comprobar. Si firma el resto de los archivos al ejecutar el Asistente para la personalización de Internet Explorer, este componente se firmará también con ese certificado.

Para obtener más información acerca de cómo firmar el código, visite el sitio Web Microsoft Security Advisor.

Versión
El programa de instalación utiliza el número de versión para comparar lo que se está instalando con lo que ya está instalado en el equipo. Al volver a instalar un componente, el programa de instalación no instalará una versión más antigua. El número de versión le ayuda a realizar el seguimiento de las versiones de su programa y a asegurarse de que está instalada la versión más actualizada. El formato correcto para escribir el número de versión es: xxxx,xxxx,xxxx,xxxx.

Condiciones de instalación

Instalar antes de Internet Explorer
Use esta opción si necesita instalar un componente personalizado antes de instalar Internet Explorer (por ejemplo, para ejecutar un archivo por lotes y establecer previamente la configuración del usuario).
Instalar después de Internet Explorer
Use esta opción si desea instalar una o más revisiones de software de Internet Explorer (QFE) o una versión diferente de un componente incluido en el paquete básico de Internet Explorer descargado mediante AVS.

Nota

  • Si elige una versión diferente de un componente básico de Internet Explorer (como DirectAnimation o NetMeeting) y empaqueta los archivos en un componente personalizado, aumentará el tiempo de descarga para los usuarios ya que, de hecho, estarán descargando el mismo subconjunto de archivos dos veces.
Instalar después de reiniciar el sistema
Use esta opción si su componente personalizado contiene Service Packs del sistema o actualizaciones para la Máquina virtual de Java de Microsoft (VM).
Instalar sólo si Internet Explorer se instaló correctamente
No se instala este componente a menos que Internet Explorer esté instalado en el equipo del usuario.

Notas

  • En IEAK se incluyen herramientas para crear secuencias de comandos de IExpress. Para obtener herramientas adicionales, visite el sitio MSDN Online Web Workshop. Para obtener información general acerca de la tecnología de instalación, consulte Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado y de la instalación de un componente personalizado, consulte Cómo funciona la personalización.


Paso 2. Introducción: especificar los parámetros de instalación

Imagen de título
Asistente

Paso 2: especificar los parámetros de instalación

En este paso del Asistente para la personalización de Internet Explorer, debe especificar qué componentes desea incluir en el paquete personalizado.

Las opciones disponibles dependerán de su función:

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo


Personalizar la instalación

Puede personalizar la apariencia con la que se muestra a los usuarios el programa de instalación de Windows Update. Puede cambiar la barra de título y el gráfico que aparece cuando los usuarios ejecutan el Asistente para la instalación de Windows Update. Si proporciona un grupo de componentes personalizados, puede asignarles un nombre.

Texto de la barra de título del asistente para la instalación
Este texto aparece en la barra de título del asistente para la instalación que ejecuten los usuarios. Este texto no aparece en la barra de título del explorador personalizado. Más adelante, en el Asistente para la personalización de Internet Explorer, puede personalizar el título del explorador.
Rutas de acceso de los mapas de bits del asistente para la instalación
Estos gráficos personalizarán la apariencia del asistente para la instalación. Debe evitar el uso de gráficos con líneas y patrones complejos.

Nota

  • El asistente para la instalación contiene dos mapas de bits de 256 colores. El mapa de bits vertical izquierdo de la primera página del asistente para la instalación es de 162 por 312 píxeles. El mapa de bits de la parte horizontal superior del resto de las páginas del asistente para la instalación es de 496 por 56 píxeles. El gráfico horizontal aparece detrás de algunas instrucciones del programa de instalación, por eso debe usar un mapa de bits que no interfiera con la legibilidad del texto.
Título de la instalación de componentes personalizados
Puede instalar los componentes personalizados al instalar el explorador personalizado. Si ha especificado más de un componente personalizado, puede asignarles un nombre de grupo; por ejemplo, podría tener un grupo de componentes denominado Programas del departamento de almacén de la compañía cafetera El Volcán. Este nombre aparecerá en el Asistente para la instalación de Windows Update cuando los usuarios instalen el paquete personalizado. Escriba el título que desea que aparezca.

Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado y de la instalación de un componente personalizado, consulte Cómo funciona la personalización.


Personalización del Administrador de conexión

El Kit de administración del Administrador de conexión (CMAK) es una herramienta que se emplea para configurar y administrar la forma en que se conectan los usuarios a Internet o a una red privada corporativa. Con el CMAK puede cambiar la apariencia y la configuración del marcador del Administrador de conexión de Microsoft mediante iconos personalizados, archivos de Ayuda adaptados y gráficos animados.

El CMAK no está disponible en Internet Explorer Administration Kit 5.5. CMAK está disponible en Windows 2000 Server y en Windows 2000 Administration Pack; hay una versión anterior de CMAK disponible en la versión 5 de Internet Explorer Administration Kit.

Si ya ha creado un perfil personal a través de CMAK, puede importarlo al paquete de instalación con el Asistente para la personalización de Internet Explorer.

Usar el perfil personalizado
Si ya ha creado un perfil de CMAK personalizado, escriba la ruta de acceso del perfil que desea utilizar con este paquete del explorador. El perfil especifica el contenido personalizado y los métodos de conexión.

Notas

  • El CMAK crea un archivo ejecutable autoextraíble (*.exe) que se instala a sí mismo en los equipos de los usuarios. Cuando un usuario hace clic en el icono personalizado para conectarse a Internet, aparece el cuadro de diálogo personalizado del marcador que creó anteriormente.
  • No es necesario firmar digitalmente el archivo .EXE creado por el CMAK antes de incluirlo en el IEAK. Al firmar los archivos del IEAK, se firma también el archivo del CMAK.

Para obtener más información, consulte la Ayuda en pantalla del Kit de administración del Administrador de conexión.


Experiencia de usuario

Puede determinar con precisión la experiencia del usuario durante la Instalación de Windows Update.

Instalación silenciosa

Si desea que los usuarios tomen decisiones durante la instalación de Windows Update, haga clic en Instalación interactiva. El usuario puede seleccionar el tipo de instalación, descargar el sitio y la carpeta de instalación, y ver todos los cuadros de diálogo y mensajes de error en curso.

Hay dos tipos de instalaciones silenciosas.

Si desea tomar todas las decisiones de instalación en lugar de los usuarios y mantenerles informados del desarrollo y los errores de la instalación, haga clic en Instalación no interactiva.

Si desea que los usuarios instalen el explorador personalizado sin que se les muestre ningún cuadro de diálogo o indicación del desarrollo del proceso, haga clic en Instalación totalmente silenciosa. Esta opción equivale a instalar Internet Explorer con el modificador /Q:A.

Para ajustar con mayor precisión la instalación, puede usar los modificadores adicionales Instalación por lotes de Internet Explorer e Instalación por lotes de IExpress.

¿Qué experimenta el usuario durante una instalación totalmente silenciosa o no interactiva?

Una instalación silenciosa (no interactiva o totalmente silenciosa) realiza las operaciones siguientes:

  • Contesta las preguntas de forma que pueda continuar el programa de instalación.
  • Acepta el contrato de licencia.
  • Especifica que Internet Explorer se instalará y no sólo se realizará su descarga.
  • Lleva a cabo el tipo de instalación (por ejemplo, Estándar o personalizado) especificado para este paquete de instalación.
  • Instala Internet Explorer en el lugar especificado, a menos que ya esté instalado. En ese caso, la nueva versión del explorador se instala en la misma ubicación que la versión anterior.
  • Conecta con el primer sitio de descarga especificado para este paquete.

Ninguno de estos modos es interactivo, por lo que los usuarios no tienen control sobre el proceso de instalación de Windows Update. Si una instalación totalmente silenciosa no se completa correctamente, los usuarios no ven ningún mensaje de error. Puede decidir utilizar esta característica en instalaciones que se distribuyen cuando el usuario no está presente.

Nota

  • En una instalación silenciosa sólo puede especificar una opción de instalación y un sitio de descarga para sus usuarios.

Derechos de usuario

El modelo de seguridad de Windows NT y Windows 2000 puede impedir que los usuarios instalen software en sus sistemas. Para registrar archivos de sistema importantes, es preciso tener privilegios de administrador durante la instalación del software y después de reiniciar el sistema. Este requisito complica la distribución de nuevas versiones de Internet Explorer en sistemas en los que usuarios sin privilegios de administrador inician una sesión después de la instalación del paquete.

Habilite el inicio de sesión después de reiniciar con el acceso de los usuarios
Seleccione esta casilla de verificación para personalizar el paquete de modo que se retenga el acceso a nivel de administrador después de reiniciar el equipo. Una vez que el equipo se reinicie y el usuario inicie la sesión, el componente Windows Installer completará el registro de los archivos de sistema de Internet Explorer. Después puede distribuir el paquete a los usuarios manualmente o como parte de un método de distribución automatizado como Systems Management Server (SMS). En cualquier caso, no es necesario que los usuarios tengan derechos de administrador la próxima vez que inicien una sesión en el sistema.

No necesita derechos de administrador para instalar un paquete IEAK en equipos con Windows 95, Windows 98 o Windows Millennium Edition, ya que el sistema operativo no administra el registro de archivos en dichos sistemas.

Cuando este paquete se instale en cualquier cliente SMS, el componente generará un archivo de estado .MIF. SMS lo usará para comprobar si el paquete se ha instalado correctamente.

Importante

  • Si selecciona esta opción, compruebe que el formato del medio para el paquete es simple, con todos los archivos en una carpeta.
  • Para poder usar esta opción, debe asegurarse de que ninguna otra instalación de Windows Installer se ejecutará cuando el usuario instale el paquete.
  • No utilice este método cuando Internet Explorer sea un componente de otra instalación de Windows Installer, como Microsoft Office 2000.
  • Si selecciona esta opción, pruebe completamente las interacciones potenciales antes de distribuir este paquete a los usuarios.


Opciones de instalación

Puede especificar hasta diez opciones de instalación, como son la instalación estándar o la instalación personalizada, y determinar el explorador y los componentes personalizados que se instalarán en cada modo. Si es administrador corporativo y ha especificado una instalación silenciosa para este paquete, sólo puede especificar una única opción (modo) de instalación.

Importante

  • Independientemente de las opciones de instalación configuradas para el paquete, el programa de instalación de Windows Update sólo presenta una opción de instalación a los usuarios que ejecuten el sistema operativo Windows 2000. Esta opción incluye todos los componentes de Internet de Microsoft, además de los componentes personalizados del paquete.
Opción
Seleccione la opción de instalación predeterminada que desee o haga clic en Nueva para crear una nueva opción de instalación. Escriba la descripción de la opción y haga clic en las flechas para agregar o quitar los componentes que desee.

Si es proveedor de servicios Internet, puede ser aconsejable crear una opción de instalación para un conjunto específico de clientes; si es administrador corporativo, quizá desee especificar opciones de instalación para distintas sucursales de su organización.

Descripción
Escriba la descripción de la opción de instalación, como la lista de componentes y programas instalados. Este texto aparece en el Asistente para la instalación de Windows Update que verán los usuarios.

Nota

  • Para crear un carácter de subrayado en el texto de la descripción, escriba un signo &. Para crear un signo "y" comercial escriba dos signos &&.
Componentes disponibles
La lista de componentes disponibles incluye los componentes de Internet Explorer que ha descargado y los componentes personalizados que haya definido. Para agregar componentes a esta lista, vuelva al paso 2 del asistente.
Componentes para instalar
Esta lista muestra los componentes que se instalarán con la opción que aparece en el cuadro Opción. Haga clic en las flechas simples para agregar o quitar un único componente, o haga clic en las flechas dobles para agregar o quitar todos los componentes disponibles.

Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado y de la instalación de un componente específico, consulte Cómo funciona la personalización.

Nota

  • Si instala Internet Explorer en un equipo en el que nunca se ha ejecutado Internet Explorer 4 y desea que los usuarios dispongan de canales, incluya el paquete de exploración sin conexión como parte de los componentes de cada opción de instalación.


Sitios de descarga de componentes

Debe especificar al menos un sitio de descarga, utilizando un servidor HTTP o FTP para que desde allí los usuarios descarguen el paquete. Puede especificar hasta diez sitios. Debe colocar todos los componentes de Microsoft y los componentes personalizados en cada dirección URL que especifique a continuación.

Nombre del sitio
Escriba el nombre de su sitio. Puede especificar un nombre descriptivo que ayude a identificar el sitio. No utilice comas en el nombre.
Dirección URL del sitio
Escriba la dirección URL de su sitio. Se agregará o actualizará el archivo Ie5sites.dat y se agregará a la dirección URL la subcarpeta del idioma del paquete, por ejemplo, EN para inglés.
Región del sitio
Escriba la región donde se encuentra el sitio, como la ciudad, estado, región del país o país.
Sitios de descarga personalizados
Los sitios que especifique aparecerán en esta columna.

Nota

  • Si es administrador corporativo y ha especificado una instalación silenciosa para este paquete, sólo puede especificar un único sitio de descarga.

Para ver un ejemplo, consulte Cómo configurar archivos para distribución e Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.

Qué hacer cuando la dirección URL del primer sitio no funciona

Si el primer sitio está inactivo, como resultado de problemas en el servidor, por ejemplo, el programa de instalación no podrá encontrar los sitios restantes de forma predeterminada. Una posible solución implica sobrescribir el primer sitio con el comando siguiente:

<ruta de acceso>\ie5setup.exe /C:"ie5wzd.exe /S:""<ruta de acceso>\ie5setup.exe"" /L:""http://mi servidor Web /mi sitio Web /ie5sites.dat"""

<ruta de acceso> es la carpeta en la que se encuentra el archivo IE5setup.exe.

Ejemplo

A continuación se incluye un ejemplo de la sintaxis que debe proporcionarse a los usuarios cuando el primer sitio esté inactivo. Se trata de una línea de comando única mostrada mediante tres líneas de texto para mejorar su legibilidad.

C:\ie5setup.exe /C:"ie5wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\ie5setup.exe""
/L:""http://<direcciónNuevoServidor>/<suDirecciónDeDescarga>/ie5sites.dat """


Descarga de componentes

Cuando hay disponible una nueva versión de Internet Explorer, los usuarios pueden actualizarlo si hacen clic en el menú Herramientas y, después, en Windows Update. Los usuarios también pueden ver esta página si hacen clic sucesivamente en Agregar o quitar programas en el Panel de control, en Internet Explorer y Herramientas de Internet y, finalmente, en Agregar o quitar.

La ubicación predeterminada para obtener las actualizaciones del producto es el sitio o sitios desde los que los usuarios descargaron sus exploradores personalizados, aunque se puede especificar una página de componentes adicionales personalizada donde podrán descargar componentes adicionales.

Descargar componentes desde Microsoft después de la instalación
Al activar esta casilla de verificación, se especifica que todos los componentes se descarguen desde sitios de Microsoft después de la instalación.
Dirección URL de la página de componentes adicionales
Si desea que los usuarios obtengan actualizaciones de software (componentes adicionales) desde otra ubicación, especifique una dirección URL distinta.

Nota

  • El identificador de configuración y el número de versión disponibles en versiones previas del IEAK, que antes aparecían en esta pantalla, ya no son necesarios. Estos valores se generan automáticamente. Las personalizaciones, o marcas, que genere con IEAK estarán siempre instaladas, independientemente del número de versión o el identificador de configuración.


Directorio de instalación

Si es administrador corporativo, puede especificar la ubicación en la que los usuarios instalarán Internet Explorer y el resto de los componentes de Internet. También puede determinar si los usuarios podrán cambiar la carpeta que especifique.

Para permitir al usuario cambiar la ubicación especificada, active la casilla de verificación Permitir que el usuario seleccione el directorio de instalación. Si activa esta casilla de verificación, la selección que haga a continuación aparecerá como ubicación predeterminada.

Si hace clic en Instalar en la carpeta especificada dentro de la carpeta Windows o Instalar en la carpeta especificada dentro de la carpeta Archivos de programa, Internet Explorer se instalará en la subcarpeta mostrada en el cuadro.

Si activa la casilla de verificación Especificar la ruta de acceso completa de una carpeta personalizada, podrá escribir la ruta de acceso que desee. Si la ruta de acceso no existe en el disco duro del usuario, se creará.

Nota

  • Si Internet Explorer ya está instalado en el equipo del usuario, la nueva versión se instalará sobre la existente. El explorador personalizado no se instalará en la ubicación personalizada que especificó.


Opciones de instalación corporativa

Puede determinar hasta qué punto los usuarios pueden personalizar la instalación de Windows Update.

Deshabilitar la opción de instalación personalizada
Los usuarios pueden agregar o quitar componentes para personalizar todavía más la instalación. Para evitar que los usuarios puedan agregar o quitar determinados componentes, active esta casilla de verificación.
No guardar información de desinstalación
El programa de instalación de Windows Update guarda automáticamente la información de desinstalación. Para ahorrar espacio en disco, puede deshabilitar esta característica si activa la casilla de verificación. Sin embargo, los usuarios ya no podrán quitar Internet Explorer al hacer clic en el icono Agregar o quitar programas del Panel de control.
Deshabilitar el modo de compatibilidad de Internet Explorer
Con la opción de compatibilidad de Internet Explorer, los usuarios pueden probar características de páginas Web de Internet Explorer 4 en el mismo equipo en el que está instalado Internet Explorer 5 y versiones posteriores. Para deshabilitar esta característica, active esta casilla de verificación.
Opciones del explorador predeterminado
Elija una de las tres opciones para determinar si Internet Explorer es el explorador predeterminado y si los usuarios pueden tomar esta decisión. El explorador predeterminado se ejecuta al abrir archivos .HTM, .HTML y otros tipos de archivo asociados. Esta opción también determina si el programa predeterminado para reproducir los archivos multimedia es el Reproductor multimedia de Windows.

Nota

  • Si está usando una instalación silenciosa o personalizando Internet Explorer para la distribución de Microsoft Office mediante el Asistente para la instalación personalizada de Office, las opciones del usuario para Internet Explorer no se mostrarán durante la instalación.


Actualización del escritorio de Windows

La Actualización del escritorio de Windows hace que el escritorio y las carpetas tengan la misma apariencia que el Web. Aunque el programa de actualización del escritorio de Windows no forma parte de Internet Explorer 5 y versiones posteriores, puede incluirlo en el paquete de IEAK. Si los usuarios ejecutan Windows 98 (o versiones posteriores del sistema operativo), ya disponen de las características de escritorio.

Si opta por instalar la Actualización del escritorio de Windows, puede personalizar más tarde sus parámetros de configuración en el asistente, siempre que el equipo donde se ejecute tenga una de las configuraciones siguientes:

  • Windows 98
  • Windows 98 Segunda edición
  • Windows Millennium Edition
  • Windows 2000
  • En otras versiones de Windows deberá utilizar Internet Explorer 5.5 actualizado desde Internet Explorer 4.0 con la Actualización del escritorio de Windows instalada.

La actualización puede ser muy útil a la hora de definir escritorios estándar para empresas.

¿Desea integrar la Actualización del escritorio de Windows en el paquete personalizado?
Para instalarla, haga clic en Sí. Si no desea instalarla, haga clic en No.


Opciones avanzadas de instalación

Imagen de título
Asistente

Opciones de instalación avanzadas

Puede personalizar aún más el programa de instalación de Windows Update si hace que detecte la existencia de un componente y define con precisión qué componentes pueden agregar los usuarios cuando lo personalizan.

Optimizar para descargar el Web
El programa de instalación puede detectar si la misma versión de un componente ya está instalada en el equipo del usuario. En caso de que ya haya instalada una versión del mismo componente y ésta funcione con Internet Explorer, el programa de instalación no descargará el componente. Esto puede reducir el tiempo de descarga para el usuario.

Nota

  • No optimice la descarga en el Web si desea instalar una versión específica de un componente que no sea el que se ha incluido en los archivos .CAB de Internet Explorer descargados anteriormente con AVS. Para obtener más información, consulte Empaquetar actualizaciones de Microsoft en componentes personalizados.
Impedir a los usuarios que personalicen el programa de instalación para componentes específicos
Si los usuarios pueden personalizar sus instalaciones, pero no desea que puedan personalizar determinados componentes, desactive las casillas de verificación de esos componentes en particular. En el programa de instalación de Windows Update, Forzar instalación aparece en la columna derecha al lado de los componentes que se instalarán automáticamente con el explorador.


Componentes en Multimedia

Los componentes de esta lista se han descargado en el equipo, pero no están incluidos en uno de los modos especificados para el programa de instalación de Windows Update. Los componentes que seleccione pueden quedar disponibles para ser instalados cuando los usuarios traten de utilizar alguna característica que los haga necesarios. Este sistema se denomina instalación a petición.


Firmas digitales

Si dispone de un certificado de editor emitido por una entidad emisora de certificados u obtenido en Microsoft Certificate Server, puede firmar su paquete personalizado en este paso del asistente. Para obtener más información acerca de los certificados, consulte Firmar sus programas.

Para preparar los certificados de forma que los utilice el IEAK, puede importarlos en el equipo por medio del Asistente para la importación del Administrador de certificados. Si ha recibido un archivo con la extensión .SPC, puede iniciar el Asistente para importación del Administrador de certificados si hace doble clic en el archivo .SPC en el Explorador de Windows o en Mi PC.

También puede abrir el Administrador de certificados desde Internet Explorer; para ello, haga clic sucesivamente en el menú Herramientas, en Opciones de Internet, en la ficha Contenido y, después, en Certificados. Haga clic en Importar para iniciar el Asistente para importación del Administrador de certificados y, después, siga los pasos que se indican en el asistente.

Nombre de la compañía en el certificado
Si en el equipo hay un certificado de editor, su nombre de compañía aparecerá en esta lista.
Archivos de Certificados de publicación de software (.spc)
Escriba el nombre del archivo .SPC asociado al certificado o haga clic en Examinar para buscarlo.
Archivo de clave privada (.PVK)
Escriba el nombre del archivo .PVK asociado al certificado o haga clic en Examinar para buscarlo.
Descripción
Escriba el texto que aparecerá en el cuadro de diálogo que se muestra cuando los usuarios descargan programas firmados con este certificado.
Más información (dirección URL)
Escriba la dirección URL en la que los usuarios pueden hacer clic para obtener información adicional acerca del certificado y la compañía.


Personalizar la pantalla de ejecución automática del CD

Si está creando una versión en CD-ROM de su explorador personalizado, puede crear una pantalla de ejecución automática que se mostrará cuando el usuario inserte el disco compacto en la unidad.

La imagen debe ser un mapa de bits de 256 colores con 540 por 357 píxeles. Para obtener más información acerca de cómo crear este gráfico, consulte Crear un mapa de bits para la pantalla de inicio de ejecución automática. Para obtener más información acerca de todos los gráficos, consulte Crear gráficos personalizados.

Si incluye una pantalla de ejecución automática, puede proporcionar un mapa de bits de fondo y etiquetas para dos botones: uno para instalar Internet Explorer y otro para mostrar más información. También puede personalizar la barra de título y el color del texto.

Texto de la barra de título
Este texto aparece en la barra de título de la pantalla de ejecución automática.
Ubicación del mapa de bits personalizado de fondo
Puede suministrar un mapa de bits que aparezca detrás del texto. Compruebe que el color de fondo no entrará en conflicto con el color del texto.
Color de texto estándar
Esta opción determina el color del texto que no forma parte de un vínculo.
Color de texto resaltado
Esta configuración determina el color de los vínculos de la página.
Estilo de botón
Puede determinar la apariencia de los botones en los que hacen clic los usuarios para instalar Internet Explorer y obtener más información.
  • Los botones estándar biselados son similares a los que aparecen en los programas estándar de software.
  • Los botones con mapa de bits 3D tienen una apariencia tridimensional.
  • Un mapa de bits personalizado se basa en el mapa de bits que proporcione. Para encontrar la ruta de acceso del archivo de imagen, haga clic en Examinar.


Más opciones del CD

Puede personalizar aún más la instalación desde discos compactos si agrega un archivo adicional de información, conocido en ocasiones como archivo "léame", e incluye una página Web especial que aparecerá después de la instalación.

Archivo de texto con más información
Especifique la ruta de acceso y el nombre del archivo que desea que vean los usuarios después de la instalación. De forma predeterminada, la pantalla de ejecución automática del CD incluye un vínculo a este archivo. Si cambia el nombre del archivo, tendrá que actualizar la ruta de acceso en la pantalla de ejecución automática.
Usar la página de inicio en pantalla completa
Especifique la ruta de acceso y el nombre del archivo .HTM que desea que aparezca después de que el usuario haya instalado Internet Explorer. Esta página aparecerá en pantalla completa y no se mostrarán la barra de herramientas del explorador ni la barra de menús. Los gráficos asociados a esta página deben guardarse en la misma ubicación que el archivo .HTM.


Paso 3. Introducción: personalizar la instalación

Imagen de título
Asistente

Paso 3: personalizar la instalación

En este paso del Asistente para la personalización de Internet Explorer, especificará cómo se va a personalizar el programa de instalación de Windows Update.

Las opciones disponibles dependerán de su función:

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo


Título del explorador

Puede personalizar el texto que aparece en la barra de título del explorador Web de Internet Explorer y Outlook Express si incluye Outlook Express en su paquete. Escriba el texto que desea que aparezca. Se agregará tras el texto "Microsoft Internet Explorer proporcionado por" o "Outlook Express proporcionado por".

Personalizar barras de título
Para personalizar las barras de título, active la casilla de verificación Personalizar barras de título y escriba el texto que desee en Texto de la barra de título.
Mapa de bits de fondo de la barra de herramientas
Puede especificar un mapa de bits personalizado para la barra de herramientas. Este mapa de bits se muestra como fondo de los botones y menús desplegables. El fondo debe tener el tamaño de la barra de herramientas y ser suficientemente claro para mostrar texto de color negro. Para obtener más información, consulte Crear gráficos personalizados.

Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


Botones de la barra de herramientas del explorador

Puede personalizar los botones de la barra de herramientas en el explorador del usuario. Puede especificar la secuencia de comandos o el programa que se inicia con cada botón, así como su apariencia. Para obtener mas información acerca de cómo diseñar programas personalizados, visite el sitio MSDN Online Web Workshop. Para obtener más información acerca de cómo diseñar iconos de la barra de herramientas, consulte Diseñar iconos de la barra de herramientas para Internet Explorer.

Eliminar los botones existentes en la barra de herramientas, si los hay (sólo administradores corporativos)
Para eliminar los botones existentes en la barra de herramientas del explorador del usuario, active esta casilla de verificación.
Agregar
Puede agregar barras de herramientas personalizadas que ejecuten secuencias de comandos o archivos ejecutables. Al hacer clic en Agregar, se le pedirá más información como cuál es el icono, el título y la acción que debe realizar el botón.
Título de la barra de herramientas (requerido)
Debe especificar un título, o etiqueta, que aparecerá debajo del botón cuando el usuario muestre el texto y el icono de los botones de la barra de herramientas. El tamaño máximo recomendado es diez caracteres.
Acción de la barra de herramientas: archivo de comandos o ejecutable (requerido)
Debe especificar el archivo de comandos o ejecutable que se ejecutará cuando el usuario haga clic en el botón de la barra de herramientas.
Icono de colores de la barra de herramientas (requerido)
Debe especificar el icono de colores que aparecerá en los botones de la barra de herramientas. El icono está formado por imágenes de 20 por 20 píxeles para los estados inactivo y activo. Para obtener mas información, visite el sitio MSDN Online Web Workshop.
Icono de escala de grises de la Barra de herramientas (requerido)
Puede especificar un icono de escala de grises para la barra de herramientas que aparecerá en los monitores en blanco y negro.
Este botón debe mostrarse en la barra de herramientas de manera predeterminada.
Active esta casilla de verificación para habilitar el botón de la barra de herramientas que se mostrará en el explorador del usuario de forma predeterminada.

Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


Logotipo de Internet Explorer

El logotipo de Internet Explorer de la esquina superior derecha del explorador aparece en dos estados: animado cuando el explorador está en uso y estático cuando no se está llevando a cabo ninguna acción. Puede reemplazar el mapa de bits del logotipo con su propio mapa de bits animado o estático.

Personalizar los mapas de bits animados

Si usa un mapa de bits animado, el primer marco aparecerá estático si no se lleva a cabo ninguna acción en el explorador. Los marcos restantes aparecerán animados cuando el explorador esté en uso.

Para usar su propio logotipo animado, debe proporcionar dos mapas de bits animados: uno debe ser de 22 por 22 píxeles y el otro de 38 por 38 píxeles.

Escriba las rutas de acceso de los mapas de bits animados personalizados pequeño y grande en los cuadros correspondientes. En el Kit de herramientas del IEAK, instalado en la carpeta \<carpeta de programa IEAK>\Toolkit, hay disponibles ejemplos de mapas de bits animados.

Personalizar el logotipo estático

Si usa un mapa de bits estático, aparecerá estático tanto si se lleva a cabo alguna acción en el explorador como si no. Para usar su propio logotipo estático, debe proporcionar dos mapas de bits; uno debe ser de 22 por 22 píxeles y el otro de 38 por 38 píxeles.

Escriba las rutas de acceso de los mapas de bits estáticos personalizados pequeño y grande en los cuadros de este panel.

Notas

  • Con IEAK se incluyen dos herramientas que ayudan a crear mapas de bits animados personalizados para el explorador. Una herramienta se utiliza para apilar mapas de bits con el formato descrito anteriormente, mientras que la otra se utiliza para realizar una vista previa de la animación. Para obtener información acerca de cómo utilizar estas herramientas, consulte Herramientas para mapas de bits animados.
  • Para obtener más información acerca de todos los gráficos que puede personalizar en el IEAK, consulte Crear gráficos personalizados.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado, consulte Cómo funciona la personalización.


Direcciones URL importantes

Puede especificar las direcciones URL de las páginas principal, de búsqueda y de soporte en línea.

Dirección URL de la página principal
La página principal, conocida a veces como página de inicio, se muestra cuando el usuario hace clic en el botón Inicio. Internet Explorer puede mostrar una página principal predeterminada o usted puede especificar la dirección URL de su propia página.

Escriba la dirección URL de la página principal que desea usar en el cuadro Dirección URL de la página principal. Si desea usar la página principal predeterminada de Internet Explorer, haga clic en Predeterminada.

Dirección URL de la barra de búsqueda
La barra de búsqueda aparece en la barra del Explorador, en la parte izquierda de la pantalla. Esta barra permite que el usuario vea la consulta de la búsqueda y sus resultados al mismo tiempo. La barra de búsqueda incluye opciones de motores de búsqueda. Puede cambiar la dirección URL de esta página si lo desea. Para obtener más información, consulte Personalizar la barra y el ayudante de búsqueda.
Dirección URL de la página de soporte en línea
En Internet Explorer se muestra información de soporte cuando se hace clic en Ayuda y, después, en Soporte en línea. Se recomienda que desarrolle una página de soporte y la ponga a disposición de sus usuarios.

Escriba la dirección URL de su página de soporte personalizada en el cuadro Dirección URL de la página de soporte en línea. Si desea usar la página de soporte predeterminada de Internet Explorer, haga clic en Predeterminada.


Favoritos y vínculos

Puede personalizar la carpeta Favoritos y la barra de vínculos si agrega vínculos a los sitios relacionados con su organización o servicios. Por ejemplo, si es proveedor de contenido Internet especializado en espectáculos, puede proporcionar vínculos a sitios relacionados con el mundo del espectáculo.

La barra de vínculos se muestra de forma predeterminada en la parte superior de la pantalla del usuario e incluye una serie de vínculos predeterminados. Puede agregar vínculos a las carpetas predeterminadas o agregar carpetas nuevas. Cuando un usuario hace clic en Favoritos, la lista Favoritos aparece en el lado izquierdo de la ventana.

çççColocar los Favoritos en la parte superior de la lista en el orden especificado a continuación
Active esta casilla de verificación para especificar que los favoritos que elija deben colocarse al principio de la lista Favoritos, para que sea más fácil que los encuentre el usuario. Al activar esta opción, los botones Mover arriba y Mover abajo estarán disponibles.
Eliminar los Favoritos y los Vínculos existentes, si los hay (administradores corporativos sólo)
Active esta casilla de verificación para eliminar los elementos de las listas Favoritos y Vínculos de los usuarios. Es aconsejable que utilice esta opción con precaución ya que quitará los vínculos y los favoritos que haya definido el usuario.
çççEliminar únicamente los Favoritos creados por el administrador (administradores corporativos sólo)
Active esta casilla de verificación para eliminar únicamente los elementos de las listas Favoritos y Vínculos de los usuarios que configuró para ellos.

Para ver un ejemplo de cómo aplicar marcas y vínculos personalizados a un explorador personalizado, consulte Cómo funciona la personalización.

Para agregar manualmente una carpeta a la lista Favoritos o a la barra Vínculos

  1. Seleccione Favoritos, Vínculos o una carpeta de Favoritos o Vínculos y, después, haga clic en Agregar carpeta.
  2. Escriba el nombre de la carpeta en el cuadro Nombre. Puede ser un nombre descriptivo que ayude a los usuarios a reconocer el tipo de vínculos que hay en la carpeta.

Nota

  • No se pueden usar signos de punto y coma (;) ni barras oblicuas (/) en los títulos de carpeta.

Para importar una carpeta de vínculos desde el equipo a la lista Favoritos o a la barra Vínculos

  1. Seleccione Favoritos, Vínculos o una carpeta de Favoritos o Vínculos y, después, haga clic en Importar.
  2. En el cuadro de diálogo Buscar carpeta, localice en el equipo la carpeta que contiene los vínculos que desea utilizar. La ubicación más probable de dichos vínculos es la carpeta \Windows\Favoritos.

Para agregar una página Web a la lista Favoritos o a la barra de vínculos

  1. Seleccione Favoritos, Vínculos o una carpeta de Favoritos o Vínculos y, después, haga clic en Agregar dirección URL.
  2. En el cuadro de diálogo Detalles, en el cuadro Nombre, escriba un nombre para esta página Web. Puede ser un nombre descriptivo que ayude al usuario a reconocer la dirección a la que hace referencia el vínculo.
  3. Escriba el destino del vínculo en el cuadro Dirección URL.
  4. Para especificar un icono personalizado de 16 por 16 píxeles para este vínculo, escriba el nombre del archivo de mapa de bits en el cuadro Icono.

    Para obtener más información, consulte Crear gráficos personalizados.

  5. Si es administrador corporativo y desea que esta página esté disponible para los usuarios cuando no estén conectados a Internet, active la casilla de verificación Disponible sin conexión. Esta opción a menudo es útil para usuarios con equipos portátiles.
  6. Haga clic en Aceptar para cerrar el cuadro de diálogo Detalles.

Notas

  • Para probar un vínculo, haga clic en la dirección URL de la lista y, después, haga clic en Probar dirección URL.
  • Puede agregar hasta 200 vínculos a la carpeta Favoritos.
  • Para quitar un elemento de la lista Favoritos o de la barra Vínculos, haga clic con el botón secundario del mouse (ratón) en el elemento y, después, haga clic en Eliminar


Página de bienvenida

Internet Explorer muestra una página de bienvenida la primera vez que se inicia el explorador. Puede mostrar la página predeterminada de bienvenida de Internet Explorer o puede especificar su propia página personalizada.

Mostrar la página predeterminada de bienvenida de Microsoft Internet Explorer
Seleccione esta opción para mostrar la página predeterminada de bienvenida de Microsoft Internet.
No mostrar página de bienvenida
Seleccione esta opción si no desea mostrar la página de bienvenida. La primera página que se mostrará es la página principal del usuario.
Usar una página de bienvenida personalizada
Seleccione esta opción si desea utilizar una página de bienvenida personalizada y, después, escriba la dirección URL en el cuadro que hay más abajo.

Nota

  • El usuario no verá la página de bienvenida a menos que esté conectado a Internet o a una intranet.


Canales

Puede agregar un canal personalizado o una categoría de canales, o carpeta, o importar desde el equipo la configuración de los canales. Cuando importe los canales podrá personalizarlos todavía más. Por ejemplo, puede importar la configuración de los canales pero eliminar uno de los canales importados.

Para agregar canales, debe disponer ya de información acerca del canal o de la categoría de canales, por ejemplo, la ruta de acceso de las imágenes y títulos que desea usar. También debe tener un archivo de formato de definición de canal (.CDF) para cada canal.

Si el paquete de Internet Explorer personalizado va a instalarse en un equipo sin Internet Explorer 4 y desea que los usuarios puedan utilizar los canales, asegúrese de incluir el paquete de exploración sin conexión en cada opción de instalación en el paquete personalizado. Si permite a los usuarios que personalicen las opciones de instalación, debe especificar que esta opción no aparezca como una opción de instalación personalizada. Para ello, en la página del asistente Opciones de instalación avanzadas, desactive la casilla de verificación Exploración sin conexión a la red. A continuación, en el programa de instalación de Windows Update, Forzar instalación aparece en la columna derecha correspondiente a este componente.

Eliminar canales existentes si los hay
Si es administrador corporativo, puede eliminar los canales existentes en el equipo del usuario si activa esta casilla de verificación.
Activar de forma predeterminada la Barra de canales del escritorio
Si es administrador corporativo y está configurando la Actualización del escritorio de Windows o instala Internet Explorer 5 en equipos con Windows 98, puede establecer que, de forma predeterminada, aparezca la barra de canales en el escritorio del usuario.
Agregar canal
Para agregar un canal, haga clic en Agregar canal y, después, especifique la información siguiente:
Título del canal (necesario)
Especifíque el título del canal. Este título aparecerá en la lista Favoritos del usuario.
Dirección URL del archivo de definición de canales en servidor Web (necesario)
Escriba la dirección URL del archivo .CDF correspondiente a este canal. El archivo .CDF proporciona información acerca de cuándo y cómo actualizar el contenido.
Ruta de acceso del archivo de definición de canales
Escriba la ruta de acceso (en el disco duro o la red) donde se encuentra el archivo .CDF o haga clic en Examinar para buscarlo.
Ruta de acceso de la imagen estrecha del canal
Escriba la ruta de acceso de la imagen estrecha del canal o haga clic en Examinar para buscarla.
Ruta de acceso del icono de canal
Escriba la ruta de acceso del icono de canal o haga clic en Examinar para buscarlo.
Disponible sin conexión
Active esta casilla de verificación para hacer que el canal esté disponible sin conexión. Si el contenido está disponible sin conexión, los usuarios pueden leerlo cuando sus equipos no están conectados a Internet. Por ejemplo, pueden ver el contenido en equipos portátiles cuando no dispongan de conexiones de red o a Internet.

Notas

  • Al especificar un archivo .CDF para un canal personalizado, asegúrese de que no contiene la etiqueta LOGO con el parámetro IMAGE o ICON.
  • Si agrega un canal dentro de una categoría de canales, utilice la sintaxis siguiente:
    <nombre de categoría>\<nombre del canal>

    Ejemplo
    Mi categoría\Mi canal

Agregar una categoría de canales (una carpeta de canales)
Para agregar una categoría de canales, haga clic en Agregar categoría y, después, especifique la información siguiente:
Título de categoría
Escriba el título de la categoría de canales.
Página HTML de la categoría
Escriba la dirección de la página HTML de la categoría.
Ruta de acceso de la imagen estrecha de categoría
Escriba la ruta de acceso de la imagen estrecha de categoría. Para obtener más información, consulte Crear gráficos personalizados.
Ruta de acceso del icono de la categoría
Escriba la ruta de acceso del icono que se mostrará para la categoría.
Modificar un canal
Para modificar un canal o categoría de canales que haya agregado o importado, haga clic en Modificar. Se mostrará entonces un cuadro de diálogo con la configuración de la imagen y ruta de acceso.
Quitar un canal
Para quitar un canal o categoría de canales que haya agregado o importado, seleccione el elemento y, después, haga clic en Quitar.
Importar canales
Para importar la configuración de canales del equipo, haga clic en Importar. Si desea cambiar la configuración de los canales antes de importarlos, no necesita cerrar el asistente. Basta con que cambie al explorador, cambie la configuración de los canales y vuelva a cambiar al asistente.
Eliminar el vínculo 'Ver canales' de la barra de inicio rápido
Si activa esta casilla de verificación, el vínculo 'Ver canales' se quitará de la barra de inicio rápido.


Active Desktop

Active Desktop permite a los usuarios colocar contenido Web en sus escritorios; por ejemplo, pueden incluir un mapa del tiempo que se actualice periódicamente. Puede importar la configuración de su escritorio como estándar para una organización, de forma que todos los usuarios tengan el mismo escritorio. En el siguiente paso del asistente puede determinar si los usuarios podrán cambiar esta configuración.

Para importar la configuración de Active Desktop debe incluir en el paquete del explorador la Actualización del escritorio de Windows y ejecutar el escritorio en el equipo donde se genere el paquete.

Para utilizar su configuración actual como escritorio estándar de una organización, haga clic en Importar los componentes actuales de Active Desktop. Haga clic en Modificar configuración para modificar la configuración actual y poder importarla. Si no desea personalizar los escritorios de los usuarios, haga clic en No personalizar Active Desktop.


Barras de herramientas del escritorio

Con el nuevo escritorio, los usuarios pueden agregar barras de herramientas a la barra de tareas de Windows en el paquete IEAK, lo que facilita el acceso a los programas, archivos, carpetas, suscripciones y páginas Web favoritas. También puede cambiar la ubicación y el tamaño de las barras de herramientas de cualquier parte del escritorio incluidas en el paquete IEAK.

Para especificar las barras de herramientas del escritorio, debe incluir en el paquete del explorador la Actualización del escritorio de Windows y ejecutar el escritorio en el equipo donde se genere el paquete.

Puede importar la configuración actual si hace clic en Importar la configuración actual de barras de herramientas del escritorio. Si desea que los usuarios tengan la configuración predeterminada de la barra de herramientas, haga clic en No personalizar las barras de herramientas del escritorio.

Puede agregar estas cuatro barras de herramientas en el lugar que desee:

  • La barra de herramientas de inicio rápido proporciona accesos directos a muchas de las características más utilizadas de Internet Explorer: el escritorio, el explorador Web, Outlook Express y canales.
  • La barra de herramientas de direcciones le permite escribir una dirección URL de Internet sin tener que abrir antes el explorador Internet Explorer.
  • La barra de herramientas de vínculos proporciona accesos directos a sitios Web importantes (por ejemplo, www.microsoft.com) de forma que pueda abrirlos sin tener que abrir antes el explorador.
  • La barra de herramientas del escritorio contiene todos los accesos directos del escritorio y los organiza de forma cómoda.

Además de las barras de herramientas ya existentes, puede crear una barra de herramientas a partir del contenido de cualquier carpeta. Por ejemplo, podría crear una barra de herramientas del Panel de control o una barra de herramientas que mostrara iconos para cada uno de sus informes de ventas mensuales.

Para crear una nueva barra de herramientas

  1. Haga clic con el botón secundario del mouse (ratón) en la barra de tareas, seleccione Barras de herramientas y haga clic en Nueva barra de herramientas.
  2. Escriba la ruta de acceso de la carpeta o la dirección del sitio de Internet que desea que aparezca como barra de herramientas, o bien selecciónelo en la lista.

Notas

  • Para mover una barra de herramientas al escritorio, arrástrela hasta la posición deseada y cambie su tamaño según sus necesidades.
  • Para obtener una cómoda barra de herramientas que contenga sus accesos directos favoritos, cree una carpeta en el disco duro, coloque allí los accesos directos que desee y convierta la carpeta en una barra de herramientas.


Carpeta Vistas Web

Puede personalizar la apariencia de Mi PC o del Panel de control en los equipos de una organización si personaliza los archivos que funcionan como plantillas de los mismos. Después, si el usuario instala la Actualización del escritorio de Windows, Mi PC y el Panel de control pueden aparecer como páginas Web. Una razón para personalizar estas carpetas es proporcionar instrucciones, el logotipo de la organización o vínculos a sitios de asistencia técnica o de la empresa.

Para especificar la carpeta Vistas Web debe incluir en el paquete del explorador la Actualización del escritorio de Windows y ejecutar el escritorio en el equipo donde se genera el paquete.

Para ello, utilice los archivos de plantilla siguientes:

  • Mycomp.htt para Mi PC
  • Controlp.htt para el Panel de control

Si ha instalado la Actualización del escritorio de Windows en el equipo, estos archivos se encuentran en la carpeta C:\Windows\Web o C:\WinNT. Puede abrirlos mediante un procesador de textos, como el Bloc de notas o un editor de HTML. Se recomienda que haga una copia de seguridad de estos archivos antes de trabajar con ellos, de forma que pueda restaurarlos a su estado original si fuera necesario.

Puede modificarlos de varias maneras de modo que se ajusten a las necesidades de su organización; para ello, agregue vínculos o gráficos propios, cambie los colores e, incluso, especifique qué contenido (iconos y nombres de archivo) se mostrará. Por ejemplo, podría elegir no mostrar iconos en el Panel de control, sino proporcionar botones gráficos en los que el usuario pudiera hacer clic sólo para las opciones de configuración que usted decidiera.

Estos archivos utilizan secuencias activas de comandos, como las que se crean con JavaScript, JScript o Visual Basic Scripting Edition (VBScript). Los archivos Mycomp.htt y Controlp.htt, y otros archivos relacionados con el escritorio, como Folder.htt y Printers.htt, utilizan JavaScript. Puede modificar algunas características de dichos archivos sin secuencias de comandos o bien, si está familiarizado con ellas, puede agregar o modificar las secuencias de comandos para que se adapten a sus necesidades.

Estos archivos de plantilla son muy similares a los archivos .HTM, excepto en tres variables: %THISDIRNAME%, %THISDIRPATH% y %TEMPLATEDIR%, que se procesan a través de un filtro MIME y son sustituidas por la información correcta de archivo o ruta de acceso. Estas variables son muy útiles cuando se especifican vínculos a archivos externos, como gráficos. Aunque estos archivos de plantilla se encuentran en la carpeta C:\Windows\Web o C:\WinNT, se procesan en la carpeta \Temp, por lo que se necesita la información de ruta de acceso para asegurarse de que funcionan los vínculos a otros elementos.

Es importante que se asegure de que las versiones personalizadas de Mi PC y el Panel de control cambian de tamaño de acuerdo con las resoluciones de pantalla de los usuarios y que se muestran correctamente. En los archivos Mycomp.htt y Controlp.htt se utiliza la sintaxis siguiente para garantizar un cambio de tamaño correcto:

<SCRIPT LANGUAGE="JavaScript">
  window.onresize = fixSize;
</SCRIPT>

Estos archivos utilizan el objeto FileList para representar el contenido (iconos y nombres de archivos) de Mi PC y del Panel de control. En Mi PC, el gráfico circular que muestra la cantidad de espacio libre se representa mediante el objeto PieChart. Estos objetos son opcionales.

Para obtener mas información acerca de las secuencias de comandos, visite el sitio MSDN Online Web Workshop.

En Mi PC y en el Panel de control, se muestran Sugerencias del Registro cuando el usuario señala un elemento. Las sugerencias proporcionan una breve descripción del elemento.

También puede modificar los archivos de plantilla Printers.htt, para impresoras, y Folders.htt, de la vista Web predeterminada de las carpetas, de la carpeta C:\Windows\Web o C:\WinNT en su equipo o en los equipos de los usuarios. No puede incluir estos archivos en el paquete personalizado de IEAK.

Si lo desea, puede proporcionar un archivo HTML en vez de modificar los archivos *.HTT. Para ello, debe cambiar las referencias asociadas a PersistMoniker en el Registro por PersistFile y señalar las referencias en su archivo personalizado.

Nota

  • La modificación de los valores del Registro puede provocar daños en el sistema operativo. Modifique los valores del Registro bajo su responsabilidad.


Componente personalizado del escritorio

Puede agregar un componente personalizado Active Desktop a los escritorios de los usuarios. Este componente puede ser un canal (archivo .CDF), una página Web (archivo HTML) o una imagen con formato .GIF o .BMP.

Para especificar un componente personalizado del escritorio, debe incluir en el paquete del explorador la Actualización del escritorio de Windows y ejecutar el escritorio en el equipo donde se genera el paquete.

Dirección URL o ruta de acceso al archivo para el componente de escritorio
Especifica el archivo y su ruta de acceso. Haga clic en Examinar para buscar el archivo. Si hace referencia a otros archivos desde este componente, por ejemplo, a archivos .GIF u otras páginas Web, asegúrese de que se encuentran en la misma carpeta que el componente.


Cadena agente de usuario

Algunas organizaciones realizan un seguimiento de las estadísticas de los sitios, por ejemplo, del número de veces que se tiene acceso a su contenido y con qué tipos de exploradores Web. Las cadenas agentes de usuario le ayudan a identificar el tipo de explorador.

Cadena personalizada que se anexará a la cadena agente de usuario
La cadena que escriba en este cuadro se anexará a la cadena agente de usuario del explorador personalizado. No es necesario que personalice la cadena agente de usuario, a menos que desee realizar un seguimiento del uso de su explorador personalizado y recopile estadísticas del explorador desde otros sitios de Internet. Tenga en cuenta que otras organizaciones que realicen el seguimiento de estadísticas del sitio podrán ver la cadena personalizada.


Configuración automática

Puede asignar direcciones URL a los archivos que configurarán automáticamente los exploradores personalizados. Esta característica es útil si desea controlar la configuración de varios usuarios desde una ubicación central.

Igualmente, puede configurar opciones mediante archivos .INS, también conocidos como perfiles de IEAK. Mediante estos archivos .INS puede incluir la configuración estándar de proxy. También puede especificar archivos de comandos con formato .JS, .JVS o .PAC que le permiten configurar y mantener la configuración de proxy avanzada.

Los servidores de red que utilicen el Sistema de nombres de dominio (DNS, Domain Name System) y el protocolo de configuración dinámica de host (DHCP, Dynamic Host Configuration Protocol) pueden detectar y configurar automáticamente la configuración del explorador cuando el usuario inicia el explorador por primera vez en una red. Para obtener más información, consulte Detección y configuración automática de las opciones de un explorador.

Si especifica direcciones URL para la configuración automática y el proxy automático (auto-proxy), se incorporará la dirección URL de auto-proxy al archivo .INS. La forma correcta de la dirección URL es http://share/test.ins.

Para habilitar la configuración automática, active la casilla de verificación Habilitar la configuración automática. En el cuadro Dirección URL de Configuración automática (archivo .ins), escriba la dirección URL para el archivo .INS que desee. En el cuadro Direcciones URL de Auto-proxy (archivos .JS, .JVS o .PAC), escriba la dirección URL para la secuencia de comandos de proxy automático.

Para obtener más información acerca de los archivos de proxy automático, consulte Archivos de ejemplo de proxy automático de JavaScript o JScript. Para obtener más información acerca de la selección y derivación de proxy, consulte Utilizar la selección de proxy y las listas de derivación de servidores proxy.

Para detectar automáticamente los valores de configuración del explorador, active la casilla de verificación Detectar automáticamente la configuración.

Configurar automáticamente cada xx minutos
Puede especificar el intervalo, en minutos, para la característica de configuración automática. Si escribe cero o no especifica ningún valor, la configuración automática sólo se realizará cuando se reinicie el equipo del usuario.


Configuración de la conexión

Puede preestablecer la configuración de la conexión para los usuarios mediante la importación de la configuración de la conexión desde su equipo.

Para ver qué configuración va a importar, haga clic en el menú Herramientas, Opciones de Internet y, finalmente, haga clic en la ficha Conexiones. Haga clic en Configuración para ver la configuración de acceso telefónico o haga clic en Configuración LAN para ver la configuración de la red. Sin embargo, no se importa la dirección utilizada para la configuración automática.

No personalizar la configuración de conexión
Seleccione esta opción si no desea prestablecer la configuración de personalización de los usuarios.
Importar la configuración de conexión actual
Seleccione esta opción si desea prestablecer la configuración de personalización de los usuarios para utilizar los valores importados desde el equipo. Si los valores de su equipo no son los que desea utilizar, haga clic en Modificar configuración para cambiarlos.
Eliminar la configuración de la conexión de acceso telefónico
Si es administrador corporativo, active esta casilla de verificación para borrar la configuración existente de los equipos de sus usuarios.
Eliminar todos los vínculos e iconos del Asistente para la conexión a Internet
Si activa esta casilla de verificación, los vínculos al Asistente para la conexión a Internet no aparecerán en la barra de inicio rápido.

Nota

  • Si es administrador de una empresa, también puede usar las directivas de sistema y restricciones para determinar si los usuarios pueden cambiar sus configuraciones de conexión. Puede definir las directivas y restricciones en el paso 5 del Asistente para la personalización de Internet Explorer o por medio de la configuración automática.


Configuración de proxy

Puede especificar los servidores proxy a los que se conectarán los usuarios. Los servidores proxy actúan como intermediarios entre los usuarios de estaciones de trabajo e Internet, y permiten habilitar servicios de almacenamiento en caché y control administrativo.

Si desea utilizar servidores proxy para cualquiera de los servicios enumerados a continuación, active la casilla de verificación Habilitar configuración de proxy.

Escriba la dirección del servidor proxy a la derecha de cualquiera de los servicios que se enumeran. Escriba el número de puerto, que en muchos casos es 80, en los cuadros apropiados situados bajo Puerto.

Para utilizar la misma configuración para todos los servicios, seleccione Utilizar el mismo servidor proxy para todas las direcciones.

En algunos casos, puede que no desee utilizar un servidor proxy, como para las direcciones de la intranet de su empresa. Puede escribir direcciones específicas en el cuadro situado bajo No usar proxy para las direcciones que comiencen por. Utilice un punto y coma para separar las entradas. Para no utilizar los servidores proxy para todas las direcciones de la intranet, active la casilla de verificación No usar el servidor proxy para direcciones locales (intranet).

Para obtener más información, consulte Utilizar la selección de proxy y las listas de derivación de servidores proxy.


Agregar un certificado raíz

Puede agregar un certificado raíz al paquete IEAK personalizado si escribe la dirección URL en el cuadro Ruta del nuevo certificado raíz. De esta forma se proporciona un grado de confianza que pueden heredar los certificados de menor nivel en la jerarquía. Cada certificado se inspecciona en busca de un certificado principal hasta que se llega al certificado raíz.


Método de suscripción

Si es proveedor de servicios Internet, puede especificar cómo se suscribirán los usuarios a su servicio y cómo se conectarán a Internet.

Suscripción con servidor mediante el Asistente para la conexión a Internet (recomendado)
El método con servidor de suscripción a Internet proporciona una flexibilidad absoluta y se adapta dinámicamente a distintas opciones de suscripción. Puede crear soluciones de servidor que intercambien información con las pantallas del Asistente para la conexión a Internet. Para obtener más información, consulte Suscribirse a Internet con el Asistente para la conexión a Internet.
Suscripción con servidor mediante el modo a pantalla completa
El método con servidor de suscripción a Internet proporciona una flexibilidad absoluta y se adapta dinámicamente a distintas opciones de suscripción. Puede crear soluciones de servidor que intercambien información con el explorador en modo de pantalla completa, sin que se muestren los botones de la barra de herramientas. Para obtener más información, consulte Configurar un servidor de suscripción en modo a pantalla completa.
Suscripción sin servidor
El método de suscripción sin servidor no requiere un servidor de suscripción. Si selecciona el método sin servidor, el Asistente para la personalización de Internet Explorer le pedirá que proporcione la información necesaria para controlar el proceso de suscripción. Si elige esta opción, se le pedirá la información relativa al marcado, gateway, o puerta de enlace, y contraseña. También puede probar la página de suscripción desde el Asistente para la personalización de Internet Explorer. No puede utilizar el método de suscripción sin servidor para personalizar el Asistente para la conexión a Internet.
Sin suscripción
Especifique este método si no desea que los usuarios tengan que pasar por un procedimiento de suscripción cuando instalen su explorador personalizado. Esta opción puede ser útil cuando se utilizan módems con cable.

Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.


Archivos de suscripción

Para permitir a los usuarios configurar sus equipos para conectarse a los servidores, debe crear archivos de suscripción personalizados. Para obtener más información, consulte Configurar un servidor de suscripción para el modo a pantalla completa y Suscribirse a Internet con el Asistente para la conexión a Internet.

El primer archivo debe ser una página HTML que contenga la información acerca de su servicio. Para suscribirse a Internet en el modo a pantalla completa, el archivo debe llamarse Signup.htm e incluir un vínculo a una página HTML apropiada en su servidor de suscripciones. Para suscribirse a Internet con el ICW, debe llamarse Icwsign.htm.

La pantalla Archivos de suscripción muestra el directorio de trabajo para los archivos de suscripción. Si ya ha modificado sus archivos de suscripción, haga clic en Copiar archivos para copiarlos a este directorio de trabajo. Si desea comprobar o especificar la configuración en archivos .ISP y archivos .ISN mediante las pantallas del asistente que aparecerán después en el paso 4, active las casillas de verificación çççComprobar o modificar las entradas de archivos ISP o çççComprobar o modificar las entradas de archivos INS.

Debe guardar en la misma carpeta todos los archivos de suscripción, incluso los archivos gráficos. Debe tener acceso total de lectura y escritura a esta carpeta, ya que el asistente necesita cambiar los atributos de todos los archivos a lectura y escritura.

Especificar archivos personalizados de suscripción
Escriba la ruta de acceso de la carpeta que contiene los archivos de suscripción o haga clic en Examinar para buscar la carpeta.

Nota

  • Para obtener más información acerca de los archivos .ISP, consulte Crear un archivo .ISP.


Información del servidor de suscripción y archivos de configuración de Internet

La pantalla Información del servidor de suscripción permite configurar las conexiones de acceso telefónico del usuario para que pueda conectarse al servidor de Internet.

Mediante la pantalla Archivos de configuración de Internet puede proporcionar la configuración que el Asistente para la personalización de Internet Explorer utilizará al generar un archivo .INS. Este archivo puede enviarse al servidor o incorporarse al paquete personalizado que esté creando para la suscripción sin servidor.

Nombre de la conexión
Escriba el nombre del servidor de suscripción. Puede ser un nombre descriptivo.
Nombre de archivo
Escriba un nombre para el archivo. En el caso de parámetros de suscripción, el archivo debe tener la extensión .ISP; para configuraciones de Internet, el archivo debe tener la extensión .INS.
Propiedades de la conexión
Escriba el código de área, el número de teléfono, el código de país o región y el identificador de país para esta conexión.
Número de teléfono de asistencia
Puede incluir un número de teléfono al que los usuarios puedan llamar para obtener asistencia técnica.
Dirección URL de la primera página de suscripción en línea
Escriba la dirección URL de la primera página del proceso de suscripción.
Configuración avanzada:
Para establecer las opciones de configuración siguientes para marcado y gateway, o puerta de enlace, haga clic en Opciones avanzadas.
Usar dirección DNS estática
El Sistema de nombres de dominio (DNS) es un conjunto de protocolos y servicios para redes de Protocolo de control de transporte/Protocolo Internet ( TCP/IP). DNS le permite especificar nombres descriptivos, como www.microsoft.com, en lugar de direcciones numéricas. Para asegurarse de que se buscará en todos los servidores DNS cuando se intente asignar nombres y direcciones IP, active esta casilla de verificación y escriba manualmente las direcciones principal y alternativa.
Requiere inicio de sesión
Establezca esta opción si necesita asegurarse de que la autenticación de inicio de sesión de Windows está activada en el equipo cliente. Al proporcionar una contraseña de Windows, se habilita el acceso a la caché de contraseñas de Windows donde está almacenada la contraseña ISP. Esta opción es especialmente útil si va a asignar cadenas largas y aleatorias como contraseñas. Sólo es válida para clientes Windows 95 y Windows 98.
Negociar TCP/IP
Especifica si se habilitará la negociación TCP/IP al establecer una conexión a Internet.
Deshabilitar LCP
Indica si se utilizarán las extensiones del Protocolo de control de vínculos (LCP) al establecer un vínculo de protocolo Punto a punto. Si el servidor de suscripción no puede controlar las extensiones LCP, debe deshabilitar LCP en el equipo cliente que se conectará a su servidor. Este valor únicamente es válido para clientes Windows NT 4.0.
Marque el número como se muestra
Evita que se establezca un código de área predeterminado. Es aconsejable establecer este indicador cuando, por ejemplo, varios usuarios llaman desde un código de área diferente al predeterminado. Si los usuarios no tienen en cuenta que el código de área predeterminado difiere de su código actual, podrían realizar accidentalmente llamadas a larga distancia.
Cifrar contraseñas
Especifica que sólo se puede enviar contraseñas cifradas a su equipo, o que sólo puede aceptarlas. Esto es útil si necesita seguridad adicional para esta conexión. El equipo al que se está conectando debe admitir contraseñas cifradas para que esta opción surta efecto.
Usar compresión de software
Especifica si la información entrante o saliente se comprimirá antes de enviarla. Esto resulta de utilidad para acelerar la transferencia de información. La compresión sólo se produce si ambos equipos están utilizando una compresión compatible.
Utilizar compresión de encabezado IP
La compresión de encabezados TCP/IP se ha diseñado para mejorar la eficacia del uso del ancho de bandas en vínculos serie de baja velocidad. Normalmente, de esta forma se optimiza la transferencia de datos entre equipos.

Si reconstruye un encabezado de menor tamaño que identifique la conexión e indique los campos que han cambiado, el nivel de transmisión de bytes podría reducirse. Para que la compresión funcione, los paquetes deben llegar en orden. La compresión no es siempre deseable. Por ejemplo, si utiliza equipos antiguos, es posible que no pueda utilizar la compresión. Por motivos de interoperabilidad, los controladores IP de línea serie que permiten la compresión del encabezado deben incluir algún tipo de etiqueta configurable por el usuario para deshabilitar dicha opción.

Usar gateway predeterminado remoto
Especifica si el tráfico Protocolo Internet (IP) se enrutará a la conexión de red de área extensa (WAN) de forma predeterminada. Una puerta de enlace, o gateway, es una conexión o punto de intercambio que conecta dos redes que en otro caso serían incompatibles.
çççAplicar toda la información de marca a este archivo
Active esta casilla de verificación si desea aplicar toda la información de marca personalizada que ha especificado en el Asistente para la personalización de Internet Explorer a este archivo de suscripción.
çççAplicar marca al nombre del archivo contenedor (.CAB)
Escriba un nombre para el archivo contenedor que contiene su información de marca. Tenga cuidado al especificar el nombre para no sobrescribir ningún archivo.
çççDirección URL del archivo contenedor (.CAB) con marca
Escriba la dirección URL de la ubicación en la que se publicará o almacenará al archivo contenedor (.CAB) con marca.

Nota

  • También puede impedir que se defina un código telefónico como predeterminado si utiliza un indicador en el archivo .ISP. La sintaxis de ese indicador es la siguiente:
    Dial_As_Is=Yes

    Para obtener más información, consulte Crear un archivo .ISP.


Asistente para la conexión a Internet

Puede especificar el Asistente para la conexión a Internet (ICW) como la herramienta que usarán los clientes para suscribirse a servicios Internet. Puede crear soluciones con servidor que intercambien información con las pantallas del ICW. Esta característica no está disponible para el método de suscripción sin servidor.

Texto de la barra de título
Active esta casilla de verificación para especificar que los clientes usen el Asistente para la conexión a Internet para suscribirse a sus servicios.
Imagen de título
Escriba la ruta de acceso del archivo .BMP de 164 por 458 píxeles que aparece en la parte izquierda del Asistente para la conexión a Internet.
Imagen superior
Escriba la ruta de acceso del archivo .BMP de 49 por 49 píxeles que aparece en la parte superior derecha del Asistente para la conexión a Internet.

Notas

  • Tendrá que incluir el componente Enlace de datos de HTML dinámico con el paquete del explorador para asegurarse de que el Asistente para la conexión a Internet puede interactuar con su servidor. El enlace de datos permite a las páginas del asistente mostrar la lista de archivos ISP en Signup.txt. Puede especificar que esta opción no aparezca como una opción de instalación personalizada que los usuarios pueden no instalar. Para ello, en la página del asistente Opciones de instalación avanzadas, desactive la casilla de verificación Vínculo de datos de HTML dinámico. A continuación, en el programa de instalación de Windows Update, Forzar instalación aparece en la columna derecha correspondiente a este componente.
  • Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.


Seguridad

Para administrar la seguridad puede utilizar entidades emisoras de certificados y Authenticode™.

Puede usar entidades emisoras de certificados para controlar los sitios desde los que los usuarios descargan cierto contenido, como controles ActiveX y subprogramas Java. Los certificados de sitio son una forma de certificado digital para un sitio de Internet. Mediante el uso de la tecnología Authenticode muestran de dónde provienen los programas y comprueban que no se han alterado.

Puede importar esta configuración desde su equipo. Si desea modificar la configuración que aplicará a los equipos de los usuarios, haga clic en Importar Entidades emisoras de certificados actuales y, después, haga clic en Modificar configuración.

Puede utilizar el Administrador de certificados para ver y administrar la información de las entidades emisoras. Los certificados pueden aplicarse a la autenticación de servidores de red, la autenticación de clientes de red, la autenticación de correo electrónico seguro y la publicación de software.

Puede usar la tecnología Authenticode para designar compañías de software y agencias de credenciales que sean de confianza. También puede importar la configuración desde su equipo. Si desea modificar la configuración que aplicará a los equipos de los usuarios, haga clic en Importar información actual de seguridad Authenticode y, después, haga clic en Modificar configuración.


Configuración de seguridad

Como administrador corporativo, puede administrar las zonas de seguridad y la clasificación de contenido de su organización. Puede personalizar la configuración de cada zona de seguridad. Mediante la clasificación de contenido puede evitar que los usuarios vean contenido que pueda ser considerado ofensivo.

Zonas de seguridad.
Si desea modificar la configuración que se instalará en los equipos de los usuarios, haga clic en Importar la configuración de zonas de seguridad actual y, después, haga clic en Modificar configuración. En el paso 5 también puede especificar si los usuarios podrán cambiar su configuración de seguridad.
Clasificación de contenido
Microsoft Internet Explorer le ofrece una forma de ayudarle a controlar los tipos de contenido a los que puede tener acceso su equipo en Internet. Puede ajustar la configuración para que refleje su opinión acerca del contenido apropiado en cuatro áreas: lenguaje obsceno, desnudos, sexo y violencia.

Si desea modificar las restricciones que aplicará a los equipos de los usuarios, haga clic en Importar la configuración actual de restricciones de contenido y, después, haga clic en Modificar configuración. A continuación puede modificar la configuración mediante el Asesor de contenido.

Notas

  • El Asesor de contenido utiliza unas normas de clasificación muy prudentes cuando se habilita por primera vez. Puede modificar estas opciones de modo que se ajusten a sus preferencias.
  • No todo el contenido de Internet está restringido. Si decide permitir que otros usuarios vean sitios sin clasificar, es posible que algunos contengan material inapropiado.


Paso 4. Introducción: personalizar el explorador

Imagen de título
Asistente

Paso 4: personalizar el explorador

En este paso del Asistente para la personalización de Internet Explorer, puede personalizar la apariencia y comportamiento de Internet Explorer.

Las opciones disponibles dependerán de su función:

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo

Nota

  • La disponibilidad de algunas opciones, como puede ser la personalización del logotipo, también depende del contrato de licencia. Para obtener más información, consulte su contrato.


Destino de las directivas y de las restricciones

La administración centralizada de las directivas de sistema y las restricciones puede ayudarle a mantener un entorno de escritorio coherente en la organización y reducir los costos de asistencia técnica subsiguientes.

Todas las directivas de sistema y restricciones que puede definir en el Asistente para la personalización de IEAK y administrar posteriormente en el Administrador de perfiles de IEAK pueden configurarse para usuarios que utilicen los sistemas operativos Windows 95, Windows 98 y Windows Millennium Edition.

Sin embargo, sólo podrá configurar un subconjunto de estas directivas de sistema y restricciones para usuarios sin privilegios de administrador en las plataformas Windows NT o Windows 2000. En lugar de ello, es aconsejable que use el Editor de directivas de Windows NT o el Editor de directivas de Windows 2000 para configurar las directivas y restricciones restantes correspondientes a dichos usuarios. Para obtener más información, consulte Administrar Microsoft Internet Explorer en Windows 2000.

Mostrar todas las directivas del IEAK
Es posible configurar todo el conjunto de directivas de sistema y restricciones para todos los usuarios de los sistemas operativos Windows 95, Windows 98 y Windows Millennium Edition y para usuarios con privilegios de administrador en Windows NT y Windows 2000.
Mostrar el subconjunto de directivas de IEAK para usuarios que no sean administradores
Elija esta opción para ver y configurar un subconjunto de directivas de sistema y restricciones que se apliquen a usuarios sin privilegios de administrador de los sistemas operativos Windows NT o Windows 2000.


Programas

Puede importar la configuración predeterminada de sus programas, por ejemplo, de los programas específicos que empleará para el correo electrónico o como editor de HTML. Estos valores se encuentran en la ficha Programas del cuadro de diálogo Opciones de Internet.

Si no desea preestablecer su configuración de usuario, haga clic en No personalizar la configuración de programas. Para importar su configuración sin cambiarla, haga clic en Importar la configuración actual de programas. Para cambiar su configuración y después importarla, haga clic en Importar la configuración actual de programas y, después, en Modificar configuración.


Cuentas y servidores de Outlook Express

Para obtener más información acerca de los servidores y cuentas de Outlook Express, consulte las secciones siguientes:

Servidores

Puede especificar los servidores de correo y de noticias para Outlook Express y solicitar a los usuarios que inicien sus sesiones utilizando el sistema de autenticación de contraseña segura (SPA, Secure Password Authentication) para tener acceso al servidor.

Elegir el tipo de servidor de correo
Seleccione el protocolo que ejecutarán los servidores de correo. Puede elegir POP3, utilizado para correo electrónico por la mayoría de los abonados a Internet, o IMAP, que principalmente es usado por usuarios de empresas que desean leer su correo electrónico desde una ubicación remota. Los servidores POP3 permiten tener acceso a una única bandeja de entrada, mientras que los servidores IMAP proporcionan acceso a múltiples carpetas en el servidor.
Servidor de correo entrante
Escriba la dirección completa del servidor en el cuadro de texto; por ejemplo, pop01.microsoft.com. Después, haga clic en Inicio de sesión con SPA en el caso de que el servidor POP3 o IMAP requiera la autenticación por medio de un proveedor SSPI como NTLM.
Servidor de correo saliente (SMTP)
El servidor SMTP es el servidor de correo saliente. En algunos casos, el servidor SMTP puede tener el mismo nombre que el servidor POP3, por ejemplo, smtp.microsoft.com. Escriba la dirección completa del servidor SMTP en el cuadro de texto. Después, haga clic en Inicio de sesión con SPA en el caso de que el servidor SMTP requiera la autenticación por medio de un proveedor SSPI como NTLM.
Servidor de noticias de Internet (NNTP )
El protocolo de transferencia de noticias a través de la red (NNTP, Network News Transfer Protocol) se usa para distribuir los mensajes de noticias de red a servidores NNTP y a clientes NNTP (lectores de noticias) en Internet. Escriba la dirección NNTP en el cuadro de texto; por ejemplo, nntp.microsoft.com. Después, haga clic en Inicio de sesión con SPA en el caso de que el servidor NNTP requiera la autenticación por medio de un proveedor SSPI como NTLM.

Cuentas

Las cuentas de usuario, como cuentas de correo o de noticias, se configuran de acuerdo con las restricciones que especifique.

Hacer de sólo lectura los nombres de servidor
Seleccione esta opción para crear configuraciones de cuentas que los usuarios puedan ver, pero no modificar.
Deshabilitar el acceso a las cuentas (no se podrá agregar, quitar o modificar cuentas)
Seleccione esta opción para evitar que los usuarios eliminen o modifiquen cuentas preconfiguradas, o creen cuentas adicionales. Esta opción sólo es recomendable para administradores corporativos.


Configuración IMAP de Outlook Express

Utilice esta pantalla para crear configuraciones IMAP predeterminadas para los usuarios. Estas opciones se preconfiguran para los usuarios cuando crean sus cuentas IMAP.

Ruta de la carpeta raíz
La ruta de la carpeta raíz es el buzón de correos que contiene todas las carpetas de usuario en el servidor IMAP. En el caso de servidores Cyrus, todas las carpetas de usuario deben estar en la carpeta Bandeja de entrada. En los servidores IMAP basados en UNIX, el correo suele almacenarse en una carpeta propia que se encuentra en la carpeta personal del usuario (por ejemplo, ~nombreusuario/Mail). No termine la ruta de la carpeta raíz con un carácter de jerarquía. Por ejemplo, ~nombreusuario/Mail es una ruta de acceso válida para una carpeta raíz, pero ~nombreusuario/Mail/ no lo es. Algunos servidores IMAP, como Microsoft Exchange Server, no precisan de una ruta de acceso de la carpeta raíz.
Almacenar las carpetas especiales en el servidor IMAP
Active esta casilla de verificación si desea especificar que se creen en el servidor IMAP carpetas para los mensajes enviados y los mensajes en curso de los usuarios.
Ruta de Elementos enviados
Presenta el nombre de la ruta de acceso de la carpeta Elementos enviados. Esta ruta de acceso será la que usen todos los usuarios que creen cuentas IMAP.
Ruta de la carpeta Borradores
Presenta el nombre de la ruta de acceso de la carpeta Borradores. Esta ruta de acceso será la que usen todos los usuarios para los que configure cuentas IMAP.
Buscar nuevos mensajes en todas las carpetas
Active esta casilla de verificación para comprobar automáticamente, cuando el usuario inicia Outlook Express y con la periodicidad que haya definido, si hay cambios en el número de mensajes en todas las carpetas a las que se ha suscrito un usuario IMAP. Si no se selecciona esta opción, Outlook Express sólo comprobará si hay mensajes nuevos en la Bandeja de entrada.


Contenido personalizado de Outlook Express

Puede proporcionar a Outlook Express una apariencia personalizada y dar la bienvenida a los nuevos usuarios con un mensaje de correo electrónico.

Panel de información

El Panel de información de Outlook Express es un área donde los proveedores de contenido pueden colocar información y vínculos útiles para el usuario. Puede personalizar este panel con los números de teléfono del servicio de soporte, las preguntas más frecuentes (P+F) e información acerca de su organización.

El Panel de información es un panel de 50 píxeles de alto situado en la parte inferior de la ventana principal de Outlook Express. Puede personalizar el Panel de información con un archivo HTML local o que se encuentre en una dirección URL de Internet. Si especifica un archivo local, ese archivo se copiará en el paquete de distribución del IEAK y, posteriormente, en el equipo del usuario durante la instalación.

Nota

  • El Panel de información no aparece como parte de la interfaz de usuario de Outlook Express a menos que se especifique una dirección URL o un archivo en el IEAK
Dirección URL
Escriba la dirección URL del archivo HTML que desea utilizar para el Panel de información.
Archivo local
Si no ha escrito una dirección URL en el cuadro de texto anterior, puede escribir la ruta de acceso del archivo local HTML que desea usar para el Panel de información o hacer clic en Examinar para buscar el archivo. Si especifica un archivo local, también puede especificar una imagen para copiar.

Mensaje de bienvenida

También puede proporcionar un mensaje de bienvenida como primer elemento de la Bandeja de entrada de cada usuario. El mensaje de bienvenida es un archivo HTML. Asimismo, debe proporcionar el nombre descriptivo del remitente, por ejemplo el nombre de su organización, y la dirección de correo electrónico del destinatario.

Nota

  • El IEAK no ofrece ningún sistema que permita incluir una imagen en el mensaje de bienvenida. Sin embargo, si modifica el mensaje de bienvenida fuera del IEAK, podrá agregar un vínculo a una imagen del Web.
Ruta HTML.
Escriba la ruta del archivo HTML que desea enviar o haga clic en Examinar para buscar el archivo.
Remitente
Escriba el nombre de la organización o la persona que envía el mensaje de bienvenida; por ejemplo, Departamento de administración de El Volcán. Este nombre aparecerá en la línea De del mensaje de bienvenida.
Responder a
Escriba la dirección de correo electrónico de la organización o persona que envía el mensaje de bienvenida. El usuario puede enviar correo a esta dirección si tiene alguna pregunta o duda.


Configuración personalizada de Outlook Express

Utilice esta pantalla para crear una configuración que se aplicará a todos los usuarios. Esta configuración predeterminada incluye un cliente de correo y noticias predeterminado. Además, puede proporcionar información que los usuarios necesitan para obtener cuentas adicionales de correo electrónico. Finalmente, puede proporcionar el archivo de reglas predeterminadas para mensajes para los usuarios.

Programas de mensajería predeterminados
Si desea que Outlook Express se inicie cada vez que un usuario haga clic en un vínculo de correo electrónico en Internet Explorer, active la casilla de verificación Outlook Express es el programa predeterminado para: Correo. La configuración de cliente de correo predeterminado la utilizan también muchos otros programas cuando un usuario envía documentos por correo electrónico. Tenga en cuenta que esta selección reemplaza a cualquier cliente de correo predeterminado que haya especificado el usuario.

Si desea que Outlook Express se inicie cada vez que un usuario haga clic en un vínculo de noticias en Internet Explorer, active la casilla de verificación Outlook Express es el programa predeterminado para: Noticias.

Grupos de noticias
Utilice este cuadro para escribir los nombres de uno o varios grupos de noticias a los que desea suscribir automáticamente a los usuarios. Por ejemplo, su proveedor de servicios Internet u organización pueden tener varios grupos de noticias que proporcionen asistencia e información a los usuarios. Puede utilizar esta característica para suscribir a esos grupos a los nuevos usuarios.
Nuevo servicio de cuentas
Puede agregar un elemento al menú que los usuarios pueden usar para obtener una cuenta adicional de correo del ISP. Esta entrada se agrega al menú Nueva cuenta de en Outlook Express. Escriba el nombre del ISP en el cuadro Nombre del servicio; por ejemplo, Acme ISP. Después, escriba una dirección URL en el cuadro Dirección URL del servicio. Cuando el usuario elija este Nombre de servicio en el menú, se abrirá la página Web. Cuando se abra la página Web, se enviarán al ISP un número de cuenta, que puede especificarse en el archivo .INS, y un identificador exclusivo del usuario.
Eliminar todos los vínculos e iconos de Outlook Express
Si activa esta casilla de verificación, no aparecerá ningún vínculo a Outlook Express en el escritorio ni en el menú Inicio del usuario y los iconos de Outlook Express se quitarán de la barra Inicio rápido.


Configuración de vistas de Outlook Express

Puede personalizar determinadas vistas que hacen que algunos elementos específicos de Outlook Express se muestren o no, o que determinan la forma en que lo hacen.

Básico
Utilice esta configuración para determinar qué elementos de la interfaz de Outlook Express se incluyen en la vista predeterminada para los nuevos usuarios.
  • Para incluir la barra de carpetas como opción predeterminada para los usuarios, active la casilla de verificación Barra de carpetas.
  • Para mostrar la barra de Outlook, una barra horizontal que muestra determinadas carpetas, como la Bandeja de entrada, active la casilla de verificación Barra de Outlook.
  • Para incluir en la columna de la izquierda una lista de correo electrónico y carpetas nuevas, active la casilla de verificación Lista de carpetas.
  • Para mostrar la barra de estado, que aparece en la parte inferior de la ventana de Outlook Express, active la casilla de verificación Barra de estado.
  • Para enumerar los contactos de MSN Messenger Service de los usuarios (si MSN Messenger Service está instalado y configurado), así como las direcciones de correo electrónico correspondientes, active la casilla de verificación Contactos.
  • Para que se muestre una sugerencia cada vez que se inicia Outlook Express, active la casilla de verificación Sugerencia del día.
Barra de herramientas
Puede elegir si los usuarios pueden ver la barra de herramientas y si desea incluir algún texto en ella. La barra de herramientas aparece en la parte superior de la ventana de Outlook Express. Contiene botones que corresponden a los comandos más usuales y puede ser configurada por el usuario.
Panel de vista previa
Tiene la posibilidad de incluir un panel de vista previa de mensajes para que los usuarios puedan tener una vista previa de los mensajes de correo y noticias. El panel de vista previa puede ser un panel horizontal situado debajo de la lista de mensajes o un panel vertical situado al lado y a la derecha de la lista de mensajes. El panel de vista previa incluye un área de encabezado del panel de vista previa que puede usarse para mostrar información del encabezado del mensaje como las líneas De, A, CC y Asunto.


Configuración de redacción de Outlook Express

Firmas
Puede incluir una firma predeterminada, como puede ser una renuncia de responsabilidad de la organización, que aparecerá en todos los mensajes de grupos de noticias o de correo electrónico de Outlook Express. A menudo se utiliza una renuncia de responsabilidad para indicar que los mensajes que envían los empleados a través de Internet no representan las directivas oficiales de una organización. El tamaño máximo de la firma es de 1 KB.

Puede agregar firmas sólo a los mensajes de grupos de noticias, sólo a los mensajes de correo electrónico o a ambos tipos de mensajes.

HTML frente a texto sin formato para mensajes de correo y noticias
De manera predeterminada, los mensajes de correo electrónico se redactan en HTML y las noticias en texto sin formato. Puede optar por cambiar esta configuración predeterminada. Por ejemplo, en un entorno donde el ancho de banda esté limitado o sean muchos los usuarios que utilicen programas de correo sencillos que no puedan entender mensajes HTML, puede ser razonable cambiar la configuración predeterminada para que los mensajes se redacten como texto sin formato. Por otra parte, en un entorno de empresa en el que todos los usuarios utilicen programas lectores de noticias compatibles con el formato HTML, puede ser aconsejable cambiar la configuración predeterminada para que las noticias se publiquen en HTML.


Servicio de directorio de la Libreta de direcciones de Windows

Los servicios de directorio son herramientas de búsqueda eficaces que ayudan a los usuarios a buscar personas y organizaciones en todo el mundo. La Libreta de direcciones de Windows admite el protocolo compacto de acceso a directorios (LDAP, Lightweight Directory Access Protocol) para el acceso a los servicios de directorio y se distribuye con acceso integrado a muchos de los servicios de directorio más utilizados. Puede especificar un servicio adicional para sus usuarios.

Nombre del servicio
Escriba el nombre descriptivo del servicio LDAP. Es el nombre que se mostrará a los usuarios.
Nombre del servidor
Escriba el nombre del servicio de directorio que desea agregar, por ejemplo, ldap.AcmeISP.com o ldap.switchboard.com. Si para que los usuarios tengan acceso a estos servicios es necesario que la autenticación se haga por medio de un paquete SSPI, como es el NTLM, active la casilla de verificación Iniciar sesión usando SPA. La autenticación básica, que utiliza una combinación de nombre de usuario y contraseña, se puede configurar por medio de los archivos .INS.
Sitio Web del servicio
Escriba la dirección URL de la página principal del servicio de directorio.

Cómo ven los usuarios la página principal del servicio de directorio en Windows 95, Windows 98 o Windows NT

  1. En Windows, haga clic en Inicio, seleccione Buscar y, a continuación, haga clic en Personas.
  2. En el cuadro de diálogo Buscar personas, seleccione la página principal del servicio de directorio en la lista Buscar en y, a continuación, haga clic en Sitio Web.

    Seleccione la página principal del servicio de directorio y, después, haga clic en Sitio Web.

Cómo ven los usuarios la página principal del servicio de directorio en Windows 2000 o Windows Millennium Edition

  1. En Windows, haga clic en Inicio, seleccione Buscar y, a continuación, haga clic en Personas.
  2. En el cuadro de diálogo Buscar personas, seleccione la página principal del servicio de directorio en la lista Buscar en y, a continuación, haga clic en Sitio Web.
Base de búsqueda
A veces conocida como raíz o ámbito, la Base de búsqueda es el nivel jerárquico en el que se busca un servidor LDAP específico. La base de búsqueda puede ser un país, organización o cualquier otro tipo de agrupamiento. El valor predeterminado en Outlook Express para la base de búsqueda, cuando no se especifica ninguna, es "c=us". Para especificar que no hay base de búsqueda, escriba NULL.
Mapa de bits del servicio
Puede especificar un archivo de mapa de bits (.BMP) personalizado de 16 colores y 134 por 38 píxeles. Para asegurar que la asignación de colores es coherente, es aconsejable que utilice exclusivamente la paleta de colores de 16 bits de Windows al generar el mapa de bits. Para encontrar el archivo .BMP en el equipo, haga clic en Examinar.
Tiempo de espera de la búsqueda
Puede especificar cuánto tiempo esperarán los usuarios antes de que se agote el tiempo de espera en una solicitud de búsqueda. Utilice el control deslizante para elegir un valor entre 30 segundos y 5 minutos.
Número máximo de coincidencias
Puede controlar el número máximo de resultados que se devolverán a los usuarios. Escriba el número en este cuadro.
Resolución de nombres
Para que Outlook Express resuelva los nombres en el servidor cuando un usuario envíe un mensaje, active la casilla de verificación Comprobar nombres en este servidor al enviar correo. Esta opción indica a Outlook Express que debe buscar las direcciones de correo electrónico para los nombres escritos en las líneas A, CC y CCO de un mensaje de correo.


Directivas y restricciones

Según su función, puede definir en la organización la configuración de varios aspectos de los equipos de los usuarios, como el escritorio, los componentes Internet, el sistema operativo y la seguridad.

Los proveedores de servicios Internet, proveedores de contenido Internet y administradores corporativos pueden especificar configuraciones predeterminadas para los usuarios. Además, los administradores corporativos pueden personalizar y restringir numerosas opciones de configuración, por ejemplo, si los usuarios pueden eliminar impresoras o si pueden agregar elementos a su escritorio.

Para obtener más información, consulte Descripción de la configuración y restricciones.

Todas las directivas de sistema y restricciones que puede definir en el Asistente para la personalización de IEAK y administrar posteriormente en el Administrador de perfiles de IEAK pueden configurarse para usuarios que utilicen los sistemas operativos Windows 95, Windows 98 y Windows Millennium Edition.

Sin embargo, en las plataformas Windows NT o Windows 2000 sólo podrá configurar un subconjunto de estas directivas de sistema y restricciones para usuarios sin privilegios de administrador. En lugar de ello, es aconsejable que use el Editor de directivas de Windows NT o el Editor de directivas de Windows 2000 para configurar las directivas y restricciones restantes correspondientes a dichos usuarios. Para obtener más información, consulte Administrar Microsoft Internet Explorer en Windows 2000.

Debe comprender el efecto de la configuración de la seguridad en los usuarios, especialmente si hay usuarios móviles que comparten los equipos con otros usuarios. Para obtener más información, vea la nota siguiente.

Para establecer las directivas del sistema y las restricciones

  1. Haga doble clic en cada categoría para mostrar las opciones.
  2. Active o desactive las casillas de verificación que desee.

Notas

  • Las opciones de configuración mostradas en el asistente se incluyen en los archivos de administración (.ADM) que se suministran con el IEAK. Si está familiarizado con los archivos .ADM, puede utilizar el Asistente para la personalización de Internet Explorer con el fin de establecer las directivas y restricciones configuradas en sus propios archivos .ADM; para ello, haga clic en Importar.

    Las opciones que elija para estas restricciones y directivas se almacenarán como archivos .INS. Estos archivos se utilizan para generar los archivos .INF del paquete personalizado. Para obtener más información acerca de la relación entre los archivos .ADM y los archivos .INF, consulte Directivas del sistema y configuración.

  • Para garantizar que la opción de configuración Compañías de confianza es eficaz para la sección Seguridad de Restricciones de Internet, debe comprobar que las zonas de seguridad y las directivas están configuradas correctamente.

La configuración de los usuarios se puede almacenar en una ubicación central y ponerse a su disposición cuando inicien una sesión desde un equipo en otro. Esto podría resultar útil, por ejemplo, con un usuario que necesita una configuración de seguridad baja pero que utiliza un equipo en el que normalmente trabaja alguien con una configuración de seguridad más restringida.

Personalizar la configuración de seguridad

Puede permitir tres niveles típicos de personalización de la configuración de seguridad:

  • Controlar, o "bloquear", todas las configuraciones.

    Para bloquear todas las configuraciones

    1. Haga clic en Restricciones de Internet y, después, en Seguridad.
    2. Active la casilla de verificación Usar sólo la configuración del equipo para zonas de seguridad.
  • Controlar la configuración de usuario a la vez que permite la descarga de perfiles para usuarios móviles.

    Puede especificar que la configuración no se puede cambiar sin bloquear a los usuarios móviles que tienen perfiles diferentes. La característica para usuarios móviles de Windows permite que los usuarios descarguen su configuración desde un servidor.

    Para evitar que un usuario cambie las directivas de una zona

    1. Haga clic en Restricciones de Internet y, después, en Seguridad.
    2. Active la casilla de verificación No permitir que los usuarios cambien las directivas de ninguna zona de seguridad.

    Para evitar que un usuario agregue o elimine sitios

    1. Haga clic en Restricciones de Internet y, después, en Seguridad.
    2. Active la casilla de verificación No permitir que los usuarios agreguen o eliminen sitios de una zona de seguridad.
  • Personalizar la configuración inicial, pero permitir que el usuario la modifique.

    En este paso del asistente puede personalizar muchas opciones de configuración del usuario, incluidos los niveles de seguridad y las clasificaciones. La personalización de la configuración en este paso no determina si el usuario podrá controlar la configuración.


Marca de MSN Messenger Service

Puede especificar un nombre de producto para el cliente del servicio de mensajería personalizado y una dirección URL de descarga para su cliente personalizado.

Nombre del producto
Elija una de las tres opciones siguientes para el nombre del producto:
  • Seleccione Opción 1 para utilizar "MSN Messenger Service" como nombre corto del producto. Escriba una cadena en el cuadro de texto tras "MSN Messenger Service: suministrado por". El nombre largo del producto será "MSN Messenger Service: suministrado por [su organización]". Se recomienda utilizar esta opción.
  • Seleccione Opción 2 para utilizar un nombre corto exclusivo del producto. Escriba dicho nombre en el cuadro de texto Nombre del producto. El nombre largo del producto será "[Nombre exclusivo del producto] (de MSN)". Tenga en cuenta que su organización es la única responsable de la selección del nombre del producto y el logotipo. Asegúrese de revisar el nombre y el logotipo seleccionados con su representante legal.

En el cliente personalizado, el nombre corto del producto aparece en la barra de herramientas, en la lista de procesos, en la Ayuda en pantalla y como texto integrado en varios cuadros de diálogo de otros productos. El nombre largo del producto aparece en el cuadro de diálogo Acerca de, en la barra de título de la ventana principal y en la barra de título del cuadro de diálogo Iniciar sesión. No utilice los caracteres siguientes en un nombre del producto: + " % / \ : * ? < > | & .

Versiones internacionales y nombre del producto
MSN Messenger Service se ha traducido a 27 idiomas, pero el IEAK se ha traducido a un número más reducido. En algunos casos, es posible que el Asistente para el IEAK no muestre la cadena traducida a algunos idiomas, pero la instalación personalizada resultante incluirá el nombre traducido correctamente. Además, las cadenas "suministrado por" o "(de MSN)" se traducirán correctamente a los 27 idiomas aunque el Asistente para el IEAK no las muestre traducidas. En caso de que el Asistente para el IEAK no traduzca adecuadamente las cadenas, abra el archivo de configuración msmsgs.in_ con un procesador de textos para asegurarse de que son correctas.
Dirección URL de descarga
Escriba una dirección URL de descarga para el cliente personalizado. El IEAK genera un paquete de instalación independiente para el cliente personalizado del servicio de mensajería . Cuando un usuario ejecuta el Asistente para agregar un contacto en el cliente, es posible generar una invitación de correo electrónico con un vínculo a la dirección URL de descarga y enviarla al nuevo contacto. La dirección URL de descarga proporcionada debe señalar a una página HTML del sitio Web que describa el cliente del servicio de mensajería y cómo instalarlo. La página HTML debe incluir un vínculo al archivo ejecutable de instalación personalizada que se encuentra en su sitio. Si no proporciona una dirección URL de descarga, se utilizará la página de instalación predeterminada del sitio Web de MSN Messenger Service.


Marca de MSN Messenger Service (medio)

Puede especificar que se utilice un logotipo personalizado como imagen de marca en distintas áreas del cliente del servicio de mensajería. También puede especificar sonidos personalizados para los sucesos de mensajería. En algunos casos, los nombres de archivo que especifique para los elementos siguientes deben tener formato ASCII, únicamente. Los nombres de archivo que no sean ASCII se reemplazarán con versiones ASCII predeterminadas.

Logotipo
Escriba una ubicación para su imagen .GIF personalizada o haga clic en Examinar para buscarla. La imagen debe tener 234 píxeles de ancho por 50 píxeles de alto. El logotipo aparecerá en áreas con fondo blanco, por lo que su color de fondo debe ser también blanco (valor RGB 255,255,255) sin capa de transparencia. El logotipo se muestra en el área Promociones, en el cuadro de diálogo Acerca de y en los asistentes para agregar un contacto y agregar un nuevo usuario. Se recomienda proporcionar un logotipo propio para la instalación. En caso contrario, se mostrará el logotipo "MSN Messenger Service".
Dirección URL del logotipo
Escriba la dirección URL, como la página principal del sitio, que se asociará a su logotipo .GIF. Cuando un usuario haga clic en el logotipo en el área Promociones del cliente del servicio de mensajería, se abrirá una nueva instancia del explorador a la ubicación especificada. Si no se especifica ninguna dirección URL, la imagen del logotipo no establecerá ningún vínculo.
Archivos de sonido
Para Contacto con conexión, Correo electrónico nuevo o Mensaje nuevo, escriba la ubicación de un archivo .WAV o haga clic en Examinar para buscar un archivo de sonido. La asignación de sonidos a estos sucesos de mensajería es opcional. Si no se especifica ningún sonido, el cliente utiliza los sonidos predeterminados. Los usuarios también pueden seleccionar sonidos en la ficha General del cuadro de diálogo Opciones del cliente. La frecuencia de muestreo de dichos archivos .WAV debe ser de 11,025 kHz, 22,05 kHz o 44,1 kHz. Pruebe los sonidos y asegúrese de que no afectan de forma adversa a la sensación del usuario al reproducirse repetidamente durante el uso normal del producto.
Contacto con conexión
Este sonido se reproduce siempre que un usuario de la lista de contactos se conecta.
Correo electrónico nuevo
Este sonido se reproduce siempre que un usuario recibe correo electrónico nuevo. En la actualidad esta característica sólo funciona con correo electrónico MSN Hotmail.
Mensaje nuevo
Este sonido se reproduce siempre que un usuario recibe un nuevo mensaje instantáneo o mensajes subsiguientes en una ventana oculta de mensajes instantáneos.
Archivo XML
Escriba la dirección URL del documento XML usado para generar el contenido del área Promociones del cliente. Consulte Formato de archivo XML para promociones del servicio de mensajería si desea obtener más información acerca del formato XML y definiciones. Consulte Contenido promocional en su cliente del servicio de mensajería personalizado para obtener información general. En caso de que no se especifique ningún archivo XML, el cliente del servicio de mensajería mostrará el contenido promocional de MSN Messenger Service.


Cuentas de MSN Messenger Service

Cuentas Passport e inicio de sesión en el servicio de mensajería

Los usuarios que inicien sesión en un servidor deben disponer de una cuenta Passport emitida por una de las entidades administradoras de dominios de Passport. Para iniciar la sesión, no es necesario que los usuarios tengan una cuenta Passport emitida en un dominio determinado; todas las cuentas Passport son igualmente aceptables. Visite el sitio Web de Passport para obtener más información acerca de las cuentas Passport y las entidades administradoras de dominios, y para consultar cuestiones generales acerca de las cuentas Passport y el servicio de mensajería.

Dominio
Seleccione un dominio emisor de cuentas Passport preferido en la lista. Éste será el dominio que aparezca en primer lugar en la lista de dominios que el usuario verá en el cuadro de diálogo Inicio de sesión, así como en determinadas áreas de los asistentes para agregar un contacto y para agregar un nuevo usuario. Le será de utilidad especificar este dominio si la mayoría de los usuarios utilizan cuentas Passport emitidas por una autoridad de dominio predeterminada. Es aconsejable que use "hotmail.com" o "passport.com" como autoridad de dominio.

Nota

  • Es posible que en el futuro haya autoridades de dominio de Passport que no están incluidas actualmente en esta lista. En caso de que una autoridad de dominio que desee utilizar no aparezca en esta lista, escriba su nombre directamente en el cuadro de texto Dominio.
Dirección URL de suscripción
Este campo especifica la dirección URL que se carga en una ventana del explorador cuando el usuario hace clic en Suscripción, en la ficha Cuentas del cuadro de diálogo Opciones del cliente. La especificación de esta dirección URL es opcional si eligió "hotmail.com" o "passport.com" en la lista Dominio, pero imprescindible si no especificó un dominio existente de la lista. Si no especificó una dirección URL y seleccionó "hotmail.com" o "passport.com" en la lista Dominio, los botones Obtener una cuenta Passport y Suscripción del cliente señalarán a las páginas de registro del dominio apropiado. Si se suministra, la dirección URL debe ser un vínculo directo a la página de registro de la autoridad de dominio de Passport o a una página personalizada que usted proporcione y que explique el proceso de registro Passport al usuario. Esta página personalizada debe incluir un vínculo a la página de registro de una autoridad de dominio de Passport.

Si su sitio tiene un identificador de sitio Passport, puede agregar este identificador (SiteID) y la dirección URL de devolución (returnURL) a la dirección URL que envíe a los usuarios al servidor de registro de Passport para permitir la marca conjunta. Consulte el SDK de Passport o el sitio Web para programadores de Passport para obtener más información acerca de los identificadores, la marca conjunta y el acceso a las páginas Web de la entidad administradorade dominios de Passport.

Servidores de correo
El cliente del servicio de mensajería puede configurarse para utilizar distintos servidores de correo en determinadas operaciones, asociadas principalmente al botón Correo de la barra de herramientas del cliente y a la opción de menú Enviar correo que aparece al hacer clic con el botón secundario del mouse (ratón) en un contacto. El servicio de correo predeterminado para los clientes del servicio de mensajería es MSN Hotmail. Esta opción es la única que admite la notificación de nuevo correo electrónico en la versión actual del cliente del servicio de mensajería. En el cliente hay otras dos opciones para la compatibilidad con servidores de correo:
  • Seleccione Proporcionar la dirección URL de la página principal de un servicio de correo electrónico si utiliza un servicio de correo electrónico basado en Web. En el cuadro de texto Dirección URL de correo electrónico, escriba la dirección URL de la página de redacción de mensajes de su servicio de correo. Cuando un usuario haga clic en el botón Correo o seleccione la opción Enviar correo para enviar correo electrónico a un usuario determinado, esta dirección URL se abrirá en una nueva ventana del explorador. La información específica del usuario no se transfiere a través de esta dirección URL, por lo que, a menos que su sistema de correo esté basado en cookies y el usuario iniciara previamente la sesión, es probable que el usuario tenga que volver a escribir la información de autenticación en el sistema de correo. Además, la dirección de correo electrónico de contacto no puede escribirse automáticamente en la línea Para: mediante esta opción. Las nuevas notificaciones de correo electrónico no están disponibles para este tipo de configuración de servicios basados en Web. Esta opción suele ser la más apropiada para los proveedores de contenido Internet.
  • Seleccione Usar el cliente de correo predeterminado del equipo del usuario final para usar el cliente de correo predeterminado del usuario. Éste es cualquier cliente de correo configurado en el Registro para usar el protocolo mailto:. Por lo general, se trata de un cliente de correo POP3. Escriba el nombre del equipo del servidor de correo (POP3) en el cuadro de texto Servidor de correo entrante. Seleccione Iniciar sesión usando SPA si el servidor de correo POP3 admite el intercambio de credenciales SPA.

    Cuando un usuario haga clic en el botón Correo o seleccione la opción Enviar correo para enviar correo electrónico a otro usuario, se iniciará la aplicación de correo predeterminada. El cliente MSN Messenger Service v2.1 no permite la comprobación de servidores POP3 externos para la notificación de correo nuevo. Si proporciona una ubicación de servidor de correo POP3 y la configuración adecuada de Iniciar sesión usando SPA, las notificaciones del correo nuevo comenzarán a funcionar en actualizaciones futuras del cliente del servicio de mensajería. Visite el sitio de MSN Messenger Service para obtener actualizaciones. Esta opción suele ser la más apropiada para los proveedores de servicios Internet.


Paso 5. Introducción: personalizar componentes

Imagen de título
Asistente

Paso 5: personalizar componentes

En este paso del Asistente para la personalización de Internet Explorer, puede especificar la configuración, directivas y restricciones para los componentes del paquete personalizado.

Las opciones disponibles dependerán de su función:

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo