Ayuda de Microsoft Internet Explorer Administration Kit

Microsoft Internet Explorer Administrator Kit
icono de Internet Explorer

Kit de administración

titular titular

Suministre "el Web a su gusto". Examine la Ayuda para saber cómo.

viñeta | Explorar el Índice.
viñeta | Realizar búsquedas de texto.
viñeta | Imprimir temas.

© 1999-2001 Microsoft Corporation. Reservados todos los derechos.


Novedades en Internet Explorer Administration Kit

Puede aprovechar la eficacia del Asistente para personalizar Internet Explorer 6 y el Administrador de perfiles de IEAK, ambos incluidos en el IEAK, para personalizar, distribuir y mantener Microsoft Internet Explorer. Para obtener más información acerca del contenido del IEAK, consulte Qué incluye Microsoft Internet Explorer Administration Kit

Nuevas características del IEAK 6

  • Comience a usar el IEAK rápidamente utilizando el contrato de lincencia integrado. De este modo, se elimina la necesidad de recibir y utilizar un código clave de licencia para ejecutar el IEAK.
  • Cree paquetes de Internet Explorer personalizados utilizando páginas perfeccionadas con asistente diseñadas para ofrecer mejores resultados que con versiones anteriores del IEAK.
  • Personalice el aspecto de su paquete de Internet Explorer mediante las personalizaciones de la barra de herramientas. Cree y utilice sus propias imágenes de mapa de bits para fondos de barras de herramientas e iconos de botones. También puede controlar las secuencias de comandos o archivos ejecutables vinculados a sus botones personalizados.
  • Utilice la eficacia del IEAK para planificar directivas de explorador antes de implementar el paquete personalizado de Internet Explorer utilizando la característica Conjunto resultante de directivas.

Temas relacionados


Qué incluye el IEAK

El IEAK contiene programas y herramientas que le ayudan a personalizar y administrar Microsoft Internet Explorer.

Puede:

  • Adaptar el explorador y otros componentes de Internet a su organización o a las necesidades de sus usuarios. Por ejemplo, puede personalizar la barra de vínculos y la lista de Favoritos para promocionar su organización o proporcionar información útil.
  • Definir la configuración antes de la instalación, para que no sea necesario establecer las opciones en cada equipo.
  • Personalizar la instalación de forma que requiera menos participación del usuario e instale programas personalizados.
  • Controlar qué opciones de configuración pueden cambiar los empleados, de modo que si es un administrador corporativo, pueda garantizar que la configuración de la seguridad, conexión y otros valores importantes se adapten siempre a las normas de la organización.

Antes de utilizar el IEAK, debe determinar qué opciones de configuración desea personalizar, preparar los gráficos o archivos personalizados que precise, y planear el método de distribución que va a utilizar. También le conviene familiarizarse con los programas y herramientas que componen el IEAK.

Para obtener más información acerca de las novedades de esta versión del IEAK, consulte Novedades en Internet Explorer Administration Kit

Herramientas del IEAK

Asistente para personalizar Internet Explorer 6

El Asistente para personalizar incluye cinco pasos, con pantallas sucesivas, que le ayudan a crear paquetes personalizados de Internet Explorer.

Administrador de perfiles de IEAK

El Administrador de perfiles le permite cambiar automáticamente las opciones de configuración y las restricciones de los usuarios, una vez instalado Internet Explorer. Para obtener más información, vea Descripción del Administrador de perfiles de IEAK.

Kit de herramientas de IEAK

El Kit de herramientas de IEAK contiene herramientas, programas y ejemplos útiles, como son el Asistente para IExpress, archivos de ejemplos de suscripción y complementarios, imágenes gráficas y otras herramientas. Estos elementos se encuentran en la carpeta \Toolkit del directorio de instalación del IEAK.

Ayuda del IEAK

Utilice el Índice, la Tabla de contenido y la búsqueda de texto para encontrar temas que solucionen sus dudas. Desde la Tabla de contenido es posible imprimir un "libro" o un grupo de temas relacionados.


Requisitos de hardware y del sistema

titular

Requisitos para Internet Explorer

Para conocer los requisitos de hardware y del sistema de versiones específicas de Microsoft Internet Explorer, consulte los archivos Léame de esas versiones.

Requisitos de hardware adicionales para crear paquetes personalizados

Antes de iniciar el Asistente para personalizar Internet Explorer 6, compruebe la cantidad de espacio de disco disponible en la unidad de destino donde generará el paquete personalizado. La unidad de destino puede estar en el mismo equipo desde el que está ejecutando el asistente para la personalización, pero no es un requisito.

Antes de generar paquetes IEAK, agregue lo siguiente a los requisitos del sistema para Internet Explorer:

  • Según el número de componentes que descargue para incluir en un paquete de instalación, puede necesitar hasta 100 MB de espacio en disco.
  • Por cada paquete personalizado que genere, puede necesitar otros 100 MB de espacio en disco. Cuando genera un paquete para otro tipo de soporte de distribución, como CD-ROM, se considera que es un paquete independiente.

Requisitos del IEAK

Debe generar los paquetes de IEAK desde un equipo con Internet Explorer 6 y cualquier sistema operativo Windows de 32 bits (excepto Windows NT 3.51).

Los equipos con Windows NT 4.0 también deben ejecutar Service Pack 3 o posterior.

Esta versión de IEAK sólo genera paquetes del explorador personalizados para plataformas Windows de 32 bits. Si desea crear un paquete personalizado para Windows de 16 bits o para plataformas UNIX, use IEAK5.x. Si desea crear un paquete personalizado para Macintosh, use el IEAK para Macintosh.

Puede ejecutar las versiones 5.5 y 6 del IEAK en el mismo equipo; sólo tiene que instalar cada programa en un directorio diferente.

Requisitos para los usuarios

Si los usuarios utilizan Windows NT, Windows 2000 o Windows XP, debe tener privilegios administrativos en el equipo la primera vez que los usuarios inicien sus equipos tras la instalación y desinstalación de Internet Explorer desde el paquete de IEAK.


Redistribuir Internet Explorer

El IEAK puede ayudarle a redistribuir Microsoft Internet Explorer como parte del proceso de instalación de otro programa. Por ejemplo, si es fabricante independiente de software (ISV) puede personalizar la instalación de Internet Explorer para que sea su programa personalizado, en lugar de Internet Explorer, el que presente al usuario las opciones y comentarios del programa de instalación.

Si desea redistribuir Internet Explorer, use el Asistente para personalizar Internet Explorer 6 a fin de crear un paquete IEAK. Elija la opción Proveedor de contenido/Programador en la Fase 1 del Asistente para personalizar Internet Explorer 6.

Puede personalizar la apariencia y funcionalidad del explorador y el programa de instalación de Windows Update, si se lo permite su contrato de licencia. También puede utilizar los siguientes elementos para controlar la funcionalidad y experiencia del usuario del programa de instalación de Windows Update.

  • Ejecutar la instalación por lotes
  • Modificadores de la instalación por lotes de Internet Explorer
  • Modificadores de la instalación por lotes de IExpress
  • Trabajar con archivos de información para la instalación (.inf)


Introducción a la Guía de implementación

La Guía de implementación proporciona información completa sobre cómo implementar las instalaciones personalizadas de Microsoft Internet Explorer utilizando el IEAK 6, uno de los métodos más rápidos y eficientes para ofrecer los beneficios de Internet Explorer a los usuarios. Esta guía le ayuda a:

  • Preparar la implementación realizando un ensayo piloto satisfactorio y otras tareas.
  • Administrar centralmente las instalaciones de Internet Explorer 6 tras la distribución.
  • Crear paquetes personalizados, utilizando los mejores métodos y consejos presentes en el IEAK 6.

La administración de las técnicas de exploración Web es cada vez más importante a medida que las intranets y extranets corporativas adquieren mayor relevancia. La mayoría de los departamentos de Tecnología de la información sitúan actualmente a los exploradores en el mismo nivel estratégico que los sistemas operativos, productividad y aplicaciones de línea de negocios (basadas muchas veces en el Web). Prácticamente todas las empresas incluyen un explorador en el escritorio estándar de los usuarios.

Puede distribuir exploradores personalizados para ayudar a los usuarios a:

  • Aumentar la productividad. Extienda la configuración del servidor proxy del explorador, la lista Favoritos, la configuración de seguridad y certificados digitales. Al implementar exploradores personalizados, está proporcionando a los usuarios acceso a las aplicaciones de intranet e Internet, garantizando que todos ellos poseen la misma funcionalidad y facilitándoles el soporte.
  • Aumentar la capacidad de administración y la confiabilidad. Mediante paquetes personalizados, puede probar componentes con aplicaciones claves de línea de negocios para maximizar la confiabilidad y reducir el coste de las distribuciones, el soporte y las actualizaciones. Puede administrar de forma central o dinámica los componentes del explorador del escritorio de los usuarios. Además, puede actualizar eficazmente los clientes de correo electrónico, por ejemplo, sin necesidad de actualizar otros componentes.


Opciones de implementación automatizada

Para automatizar la implementación del explorador personalizado, utilice una de las siguientes opciones:

  • Copia de imagen de disco

    • La copia de imagen de disco, en ocasiones denominada clonación, es uno de los métodos más rápidos para configurar nuevos escritorios. Crea una imagen de un escritorio estándar y, a continuación, copia esa imagen en equipos nuevos y existentes. Las opciones de configuración del explorador personalizado se configuran como parte de la imagen del escritorio estándar.

    La copia de imagen de disco es generalmente un método rápido y eficaz porque le permite completar la configuración sin la interacción de los usuarios. Prácticamente todos los componentes pueden configurarse, incluyendo el sistema operativo, las aplicaciones y las personalizaciones de escritorio.

    No obstante, la copia de imagen de disco no es apropiada para todas las situaciones y entornos. Las imágenes funcionan únicamente en hardware idéntico o de una configuración muy similar. Si está actualizando un equipo existente, todos los valores de configuración y datos del usuario deben almacenarse temporalmente en otra ubicación, como un servidor, pues la creación de una imagen de disco sobrescribe cualquier archivo existente en el equipo.

  • Distribución electrónica del software

    La distribución electrónica de software (ESD) utiliza aplicaciones especializadas para instalar el software en escritorios a través de una red. A diferencia de otros métodos de implementación, la ESD suele ser un componente de grupos de programas de administración empresariales más completos de compañías como Hewlett Packard, Intel, Microsoft y Tivoli.

    La ESD suele depender de las mismas secuencias de comandos de instalación utilizadas para instalar el sistema operativo, aunque algunas soluciones ESD proporcionan un entorno gráfico más amplio para crear estas secuencias de comandos y una mayor integración con los idiomas de instalación de las aplicaciones. Puede utilizar las soluciones ESD para generar informes sobre el progreso y la finalización de las implementaciones.

  • IEAK

    Puede utilizar grupos de programas de administración empresariales para administrar la implementación, por ejemplo, cuando necesita programar instalaciones remotas para mejorar el uso del ancho de banda de la red. Sin embargo, la ESD es más compleja que la copia de imagen de disco. Por ejemplo, crear una infraestructura para ESD consume mucho más tiempo que crear y copiar imágenes y algunas soluciones de ESD dependen de la presencia de determinadas tecnologías de hardware.


Principales capacidades de IEAK

IEAK 6 proporciona muchas capacidades mejoradas y nuevas frente a versiones anteriores. La mejor manera de familiarizarse con las características es avanzar a través del kit en modo de demostración y explorar todas las páginas del Asistente. He aquí algunas de las principales capacidades.

  • Opciones de medios de distribución

    Con diversos medios de distribución entre los que elegir, puede indicar cómo desea distribuir Microsoft Internet Explorer. Puede elegir entre una descarga del Web, CD-ROM, marca en un solo disco e implementación en LAN. La marca en un solo disco permite la configuración de Internet Explorer sin instalar el código en los equipos cliente. La marca en un solo disco se encuentra disponible únicamente para equipos que ejecuten Internet Explorer 4.01 SP1 o posterior.

  • Componentes personalizados y aplicaciones complementarias

    Puede incluir hasta 10 archivos ejecutables de extracción automática (.exe) y los archivos contenedores (.cab) pueden instalarse junto con Internet Explorer 6. Los componentes personalizados incluyen aplicaciones internas, shareware y otros programas que desee distribuir.

  • Condiciones de instalación

    Una posible condición es instalar los componentes antes de instalar Internet Explorer 6. Esto es especialmente útil para las herramientas que preparan los equipos para la instalación del explorador. Por ejemplo, puede ejecutar herramientas de limpieza del registro antes de instalar Internet Explorer, de modo que afecten a las claves del registro creadas por el explorador.

  • Experiencia del usuario durante la instalación

    Establezca el nivel de participación del usuario durante la instalación. Puede elegir entre instalaciones interactivas, no interactivas y completamente silenciosas. Durante las instalaciones interactivas, los usuarios pueden personalizar componentes. La instalación no interactiva muestra mensajes de error y de progreso pero no solicita información a los usuarios. Las instalaciones completamente silenciosas están ocultas de los usuarios, de modo que éstos pueden realizar la instalación sin necesidad de personalizar componentes ni ver mensajes de progreso.

  • Opciones de instalación

    Puede especificar 10 opciones de instalación, cada una de ellas con un conjunto específico de componentes. IEAK 6 incluye los tipos de instalación mínima, estándar y completa, que puede mantenerse, quitarse o personalizarse. Puede utilizar opciones de instalación para crear y distribuir un paquete único adaptable a múltiples grupos de usuarios.

  • Directorio de instalación

    Puede personalizar el directorio de instalación de Internet Explorer 6 y evitar que los usuarios cambien esta ubicación. Exigir una ubicación estándar para Internet Explorer 6 puede mejorar la administración y la solución de problemas, además de mejorar la precisión de las versiones, las mediciones y el inventario de software.

  • Implementación Web

    Las instalaciones de Web pueden configurarse para que utilicen un máximo de 10 sitios de descarga. Si se produce un problema de conectividad, el programa de instalación puede cambiar a otro sitio. El programa de instalación de Internet Explorer 6 también puede reanudar una descarga interrumpida. Esto ayuda a garantizar un proceso de instalación lo más sencillo posible para los usuarios.

  • Información sobre versiones

    IEAK 6 asigna automáticamente versiones a cada paquete y puede configurarse para que guarde o sobrescriba versiones anteriores del paquete. Cada componente de Internet Explorer 6 tiene una versión, que puede actualizarse sin necesidad de reinstalar todos los componentes. La asignación de versiones se utiliza para actualizar paquetes y garantizar la estandarización en toda la empresa.

  • Descarga del Web

    Optimice la instalación con descargas del Web. El programa de instalación de Internet Explorer 6 puede detectar componentes de Microsoft que ya se encuentren en los equipos de los usuarios. Los componentes existentes no se descargan de nuevo. Por ejemplo, el enlace dinámico de datos HTML no se vuelve a instalar aunque esté incluido en el paquete personalizado. La optimización de la descarga del Web ahorra ancho de banda y tiempo y es especialmente útil para los usuarios que realizan la descarga a través de una conexión lenta. Puede deshabilitar las descargas del Web para crear un entorno homogéneo y uniforme donde se garantice que cada equipo tiene exactamente la misma versión de cada componente.

  • Instalación automática

    Distribuya componentes únicamente cuando los usuarios los necesiten utilizando la instalación automática. Por ejemplo, si Internet Explorer 6 detecta que los usuarios necesitan el equipo virtual de Microsoft, Internet Explorer localiza automáticamente el punto de distribución (por ejemplo, un recurso compartido LAN) e instala los componentes necesarios. Esto ayuda a reducir el tiempo y espacio de disco utilizado al instalar componentes que los usuarios nunca van a necesitar.

  • Firma digital automática

    • Los paquetes de Internet Explorer 6 pueden firmarse digitalmente para la distribución. Al incluir una firma digital, está garantizando que el paquete no se ha modificado y que el origen es conocido.


Opciones de personalización del explorador

Con el Asistente para personalizar Internet Explorer, puede personalizar el explorador en las siguientes áreas:

  • Título del explorador
  • Barra de herramientas
  • Logotipo y mapas de bits animados
  • Direcciones URL importantes
  • Favoritos y vínculos
  • Página de bienvenida
  • Cadena de agente del usuario
  • Configuración de la conexión
  • Seguridad, con certificados y seguridad Authenticode
  • Configuración de la seguridad, con zonas de seguridad y clasificación de contenidos


Otras capacidades principales

Puede personalizar no sólo el propio explorador utilizando el IEAK, sino también la configuración de las siguientes áreas clave.

  • Controles ActiveX aprobados por el administrador

    Especifique los controles que desea ejecutar mientras bloquea el resto. Esto le ayudará a mantener una versión coherente de Microsoft Internet Explorer en toda la organización, reduciendo los problemas de exceso de configuración y de solución de problemas. El conjunto de controles Microsoft ActiveX aprobados puede habilitarse y administrarse dinámicamente utilizando las Directivas y restricciones del sistema en el Administrador de perfiles de IEAK.

  • Características de IEAK 6

    Muestre únicamente las características necesarias para el paquete personalizado. Por ejemplo, si está personalizando únicamente Favoritos, el resto de páginas del asistente permanecen ocultas para ahorrar tiempo y reducir la complejidad.

  • Un disco único con marca personalizada

    En los equipos que ejecutan Internet Explorer 4.01 SP1 o posterior, puede utilizar el asistente para la personalización para crear un solo disco que contenga la información de texto y del logotipo personalizada.

  • Configuración automática

    La configuración del explorador y de los componentes, además de las directivas y restricciones del sistema, puede actualizarse automáticamente a intervalos regulares o cada vez que se inicie el explorador. Esta característica permite configurar y distribuir fácilmente no sólo las opciones de Internet Explorer 6 sino también las opciones del Perfil de Windows a grupos de usuarios en toda la empresa.

  • Outlook Express

    Microsoft Outlook Express está disponible con Internet Explorer 6 y puede utilizarlo para completar la configuración del servidor de correo y de noticias. Asimismo, puede crear un mensaje de correo electrónico de bienvenida y un panel de información personalizado. Las opciones de personalización adicionales de Outlook Express incluyen la extensión de grupos de noticias, las reglas de los mensajes y las opciones de vista. Estas funciones facilitan la configuración del correo en equipos o usuarios nuevos y garantizan un cliente de correo estándar en toda la empresa.

  • Modo del Asistente para la instalación personalizada de Office (OCIW)

    Para facilitar la implementación de Internet Explorer 6 al mismo tiempo que Microsoft Office XP, el IEAK se presenta como un kit de herramientas de Office y puede tenerse acceso a él a través del OCIW.


Introducción a la personalización

La creación e implementación de paquetes personalizados de Microsoft Internet Explorer sigue el mismo proceso que la actualización o modificación de cualquier componente del escritorio. Microsoft recomienda seguir estos pasos para una implementación correctamente planeada:

  1. Reunir información y tomar decisiones.

    Utilice las listas de comprobación de versiones personalizadas para recopilar la información y los archivos necesarios. Las listas de comprobación le ayudan a tomar decisiones acerca de la implementación, como el tipo de ésta y los componentes que desea incluir.

  2. Aprender a utilizar el IEAK.

    Cree un paquete de distribución piloto utilizando el IEAK. Avance por el Asistente para la personalización para recopilar un paquete de prueba. Al hacerlo tendrá la oportunidad de ver todas las opciones disponibles y obtendrá una visión del proceso de creación de un paquete personalizado.

  3. Realizar la primera implementación de prueba.

    En primer lugar, pruebe el paquete de implementación piloto en equipos que no sean de producción en un laboratorio. Las instrucciones y pautas para realizar una prueba en laboratorio se incluyen en el apartado Crear un programa piloto. Deberá probar el proceso de instalación y la configuración del explorador en todas las plataformas y tipos de medios de instalación.

  4. Realizar la segunda implementación de prueba.

    Tras la implementación de prueba inicial, actualice el paquete de implementación con los cambios incorporados a partir de los resultados de las pruebas y asigne un número de versión al paquete del explorador. Pruebe la implementación final en equipos que no sean de producción en un laboratorio. No es seguro presuponer que los cambios, independientemente de lo insignificantes que sean, no afectan a la distribución.

  5. Realizar la implementación final.

    Una vez haya probada y aprobada la versión final del paquete, proceda a implementarlo en a la organización.

Este proceso reiterativo de planeamiento, desarrollo y prueba puede comprender un ciclo único o muchos ciclos antes de que el paquete esté listo para la implementación final.


Listas de comprobación para los paquetes personalizados

Puede utilizar las siguientes listas de comprobación para reunir la información necesaria para crear el paquete personalizado de Microsoft Internet Explorer.

  • Ubicación y distribución de archivos
  • Componentes personalizados
  • Personalizar el archivo de ejecución automática del CD
  • Personalizar de la barra de título y los mapas de bits
  • Experiencia de usuario
  • Opciones de instalación
  • Distribución mediante Web
  • Descarga de componentes
  • Directorio de instalación
  • Personalización del Administrador de conexión
  • Firmas digitales
  • Personalizar el explorador
  • Personalizar el certificado
  • Direcciones URL que se recopilarán
  • Cadena de agente del usuario
  • Conexión automática
  • Personalizar Outlook Express
  • Servidor de direcciones LDAP

Puede escribir la información en las listas de comprobación y, a continuación, imprimir cada una por separado. Si desea imprimir todas las listas de comprobación a la vez, en Contenido, haga clic en el libro Guía de implementación, haga clic con el botón secundario del mouse (ratón) en el libro Listas de comprobación para los paquetes personalizados, haga clic en Imprimir y, a continuación, seleccione Imprimir el encabezado seleccionado y todos los subtemas.


Lista de comprobación para la ubicación y distribución de archivos

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Ubicación de los archivos

Elemento personalizado | Ubicación
Carpeta de destino |

Métodos de distribución

Usar | Medio de distribución
 | Descargar
 | CD-ROM
 | Simple (todos los archivos en un directorio)
 | Un disco único con marca personalizada


Lista de comprobación para los componentes personalizados

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Componente

Elemento personalizado | Su información
Nombre |
Ubicación |
Comando (nombre de archivo .exe, para archivos contenedores .cab únicamente) |
Identificador único global (GUID) |
Descripción |
Parámetro |
Clave de desinstalación |
Versión |

Nota

  • Si el componente es un archivo contenedor .cab, deberá escribir el nombre de archivo .exe en el cuadro Comando en la página Componentes personalizados del Asistente durante la personalización.

Puede agregar diez componentes personalizados.

Sincronización de la instalación

Compruebe | Instalar (seleccione uno)
 | Antes de Internet Explorer
 | Después de Internet Explorer
 | Después de que el sistema se reinicie

Condición para la instalación

Compruebe | Condición
 | Instalar sólo si Internet Explorer se instaló correctamente.

A medida que trabaja con el IEAK, puede indicar que los componentes personalizados se instalen únicamente después de haber instalado correctamente Internet Explorer.


Lista de comprobación para personalizar la ejecución automática del CD

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Opciones de la ejecución automática del CD

Elemento personalizado | Su información
Texto de la barra de título |
Ubicación del mapa de bits personalizado de fondo |
Color de texto estándar (seleccione uno) |
Color de texto resaltado (seleccione uno) |

Estilo de botón

Puede elegir un estilo para los botones que aparecen durante la instalación.

Comprobar | Estilo de botón (seleccione uno)
 | Botones estándares biselados
 | Botones 3D con mapa de bits
 | Mapa de bits del botón

Nota

  • Si utiliza un mapa de bits de botones personalizados, deberá indicar la ubicación del archivo de mapa de bits.

Más opciones del CD

Elemento personalizado | Su información
Archivo de texto con más información |
Página de inicio en pantalla completa |

Si no abre el explorador en pantalla completa, no se utiliza la página de inicio en pantalla completa.


Lista de comprobación para la personalización de la barra de título y los mapas de bits

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Títulos y mapas de bits del Asistente para la instalación

Los siguientes títulos y mapas de bits aparecen cuando los usuarios ejecutan el Asistente para la instalación de Windows Update para instalar el paquete personalizado.

Elemento personalizado | Su información
Texto de la barra de título del Asistente para la instalación |
Ruta de acceso del mapa de bits de la izquierda (primera página) |
Ruta de acceso del mapa de bits del título superior (todas las páginas excepto la primera) |
Título de la instalación de componentes personalizados |


Lista de comprobación para la experiencia de usuario

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

La información siguiente afecta al nivel de interacción de los usuarios durante la instalación del explorador. Deberá determinar si tienen una participación en la instalación activa, parcial o nula.

Compruebe | Tipo de instalación (seleccione uno)
 | Interactiva
 | No interactiva
 | Completamente silenciosa


Lista de comprobación para las opciones de instalación

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja para cada opción de personalización y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Instalación mínima

La instalación mínima incluye el explorador Web. El resto de componentes se instalan a petición.

Instalación típica

La instalación típica incluye el explorador Web, Outlook Express, Windows Media Player y otras mejoras multimedia.

Instalación completa

La instalación completa incluye el explorador Web, Outlook Express, Windows Media Player, equipo virtual de Microsoft, fuentes Web adicionales y otras mejoras multimedia.

Instalación personalizada

Puede crear un máximo de diez opciones de instalación. Durante la instalación, los usuarios elegirán una de esas opciones.

Compruebe | Opción de instalación (seleccione una)
 | Mínima
 | Típica
 | Completa
 | Personalizada


Lista de comprobación para la distribución mediante Web

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Sitio de descarga

Los usuarios pueden descargar el paquete personalizado desde el sitio Web.

Elemento personalizado | Su información
Nombre del sitio |
Dirección URL del sitio |
Región del sitio |

Ejemplo de sitio de descarga

El siguiente ejemplo contiene información sobre la distribución mediante Web.

Elemento personalizado | Su información
Nombre del sitio | Microsoft
Dirección URL del sitio | http://www.microsoft.com/
Región del sitio | Norteamérica


Lista de comprobación para la descarga de componentes

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Opciones de Windows Update

Compruebe | Opción de Windows Update (seleccione una)
 | Quite la opción de Windows Update del menú Herramientas
 | Utilice la dirección URL predeterminada para Windows Update
 | Utilice una dirección URL adicional personalizada y el texto de menú

Nota

  • Si utiliza una dirección URL adicional personalizada y un texto de menú, será necesaria la información de la dirección URL complementaria y del elemento de menú.

Dirección URL personalizada y elemento de menú

Deberá proporcionar esta información si está utilizando una dirección URL adicional personalizada y texto de menú para acceder al Asistente para la instalación de Windows Update.

Elemento personalizado | Su información
Texto de menú para componentes adicionales |
Dirección URL de la página de componentes adicionales |


Lista de comprobación para el directorio de instalación

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Compruebe | Elemento personalizado
 | Permitir al usuario elegir el directorio de instalación.
 | Instalar en la carpeta especificada dentro de la carpeta Archivos de programa.
 | Especificar la ruta de acceso completa de una carpeta personalizada.

Nota

  • Si Internet Explorer ya está instalado en el equipo del usuario, la nueva versión se instalará sobre la existente. El paquete personalizado no se instalará en la ubicación personalizada que especificó.
Elemento personalizado | Su información personalizada
Ruta de acceso al paquete personalizado |


Lista de comprobación para la personalización del Administrador de conexión

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Elemento personalizado | Su información
Utilizar un perfil personalizado específico |
Ruta de acceso al perfil personalizado |

Nota

  • La ruta de acceso al perfil personalizado es necesaria únicamente si especifica que está utilizando un perfil personalizado.


Lista de comprobación para firmas digitales

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Elemento personalizado | Su información
Nombre de la organización en el certificado |
Ruta de acceso a Certificados de publicación de software (.spc) |
Ruta de acceso de clave privada (.pvk) |
Descripción |
Más información (dirección URL) |
Dirección URL de marca de tiempo |


Lista de comprobación para la personalización del explorador

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Los mapas de bits personalizados no son necesarios. Puede utilizar los logotipos e imágenes predeterminados de Internet Explorer.

Elemento personalizado | Su información
Texto de la barra de título |
Ubicación del mapa de bits de fondo de la barra de herramientas |
Ubicaciones del mapa de bits de los botones de la barra de herramientas |
Ubicación del mapa de bits del logotipo estático (mapa de bits pequeño) |
Ubicación del mapa de bits del logotipo estático (mapa de bits grande) |
Ubicación del mapa de bits del logotipo animado (mapa de bits pequeño) |
Ubicación del mapa de bits del logotipo animado (mapa de bits grande) |


Lista de comprobación para personalizar certificados

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Los certificados raíz proporcionan un grado de confianza que pueden heredar los certificados de menor nivel en la jerarquía. Se inspecciona si cada certificado tiene un certificado principal hasta que se llega al certificado raíz.

Elemento personalizado | Su información
Ruta del nuevo certificado raíz |


Lista de comprobación para las direcciones URL que se recopilarán

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Elemento personalizado | Su información
Dirección URL de la página principal |
Dirección URL de la barra de búsqueda |
Dirección URL de la página de soporte en línea |
Dirección URL favorita número 1 (hasta 200) |
Dirección URL favorita número 2 (hasta 200) |
Dirección URL favorita número 3 (hasta 200) |
Dirección URL de la página de actualización del producto |
Dirección URL de la página de bienvenida personalizada |


Lista de comprobación para la cadena agente del usuario

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Elemento personalizado | Su información
Texto para agregar a la cadena de agente del usuario |

Nota

  • Ejemplo de cadena agente del usuario: Mozilla/4.0(compatible;MSIE 6;Windows NT;Texto personalizado)


Lista de comprobación de conexión automática

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la siguiente información.

Puede imprimir esta hoja y después completar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Los archivos de suscripción necesarios se basan en el método de suscripción. Puede ser necesario copiar uno o varios archivos de los siguientes en su directorio de trabajo:

  • ICWSign.htm
  • Signup.htm
  • Archivo de suscripción a Internet (.isp)
  • Archivo de configuración de Internet (.ins)

Archivos de suscripción

Elemento personalizado | Su información
Ruta de acceso de los archivos de suscripción |

Información del servidor de suscripción

Elemento personalizado | Su información
Nombre de la conexión |
Nombre de archivo |
Código de área y número de teléfono para la conexión |
Id. o código de país |
Nombre de usuario |
Contraseña |
Dirección URL de la primera página de suscripción en línea |

También puede personalizar las siguientes opciones avanzadas del servidor de suscripciones:

Elemento personalizado | Su información
Dirección DNS estática (primaria) |
Dirección DNS estática (secundaria) |

Archivo de configuración de Internet

Elemento personalizado | Su información
Nombre de la conexión |
Nombre de archivo |
Código de área y número de teléfono |
Id. o código de país |
Nombre de usuario |
Contraseña |

Si los usuarios se conectan al servidor para suscribirse o si utiliza una suscripción sin servidor, puede aplicar su información de marca al archivo de configuración de Internet (.ins). Si lo hace, su marca aparecerá durante la suscripción. Para que aparezca la información de su marca, necesita la siguiente información:

Elemento personalizado | Su información
Nombre del archivo .CAB de marca |
Dirección URL del archivo .CAB de marca |


Lista de comprobación para la personalización de Outlook Express

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Cuentas de Outlook Express

Elemento personalizado | Su información
Servidor de correo entrante |
Servidor de correo saliente (SMTP) |
Servidor de noticias de Internet (NNTP ) |

Contenido personalizado de Outlook Express

Elemento personalizado | Su información
Dirección URL del panel de información |
Archivo HTML local para el panel de información |
Ruta de acceso del archivo HTML con mensaje de bienvenida |
Remitente del mensaje de bienvenida |
Nombre de respuesta del mensaje de bienvenida |

Configuración personalizada de Outlook Express

Elemento personalizado | Su información
Grupo de noticias nº1 |
Grupo de noticias nº2 |
Grupo de noticias nº3 |
Nombre del servicio para cuentas de correo adicionales |
Dirección URL de servicio para cuentas de correo adicionales |


Lista de comprobación para el servidor de direcciones LDAP

Antes de utilizar el IEAK para crear e implementar paquetes personalizados debe disponer de la información siguiente.

Puede imprimir esta hoja y después rellenar los espacios en blanco con su propia información. Mientras trabaja con el IEAK, puede utilizar la hoja para escribir sus datos.

Servicio de directorio de Libreta de direcciones

Elemento personalizado | Su información
Nombre del servicio (descriptivo) |
Nombre del servicio (LDAP) |
Sitio Web del servicio |
Base de búsqueda |
Ruta del archivo de mapa de bits del servicio |


Descripción del Administrador de perfiles de IEAK

Antes de instalar Microsoft Internet Explorer, puede utilizar el Asistente para personalizar Internet Explorer 6 e incorporar la configuración automática y la detección automática en el paquete personalizado. Con estas características, podrá actualizar automáticamente los equipos de los usuarios mediante el archivo .ins de configuración automática (almacenado en su servidor). Deberá indicar el intervalo de actualización de las opciones de configuración del explorador.

Una vez instalado Internet Explorer, podrá utilizar el Administrador de perfiles de IEAK para mantener las opciones de configuración del explorador en los equipos de los usuarios. Con el Administrador de perfiles de IEAK, puede abrir cualquier archivo .ins de configuración automática y cambiar los valores de configuración, por ejemplo, las opciones de firma digital y zona de seguridad.

También puede utilizar el Administrador de perfiles de IEAK para habilitar la configuración automática del explorador si no configuró previamente esta característica antes de la instalación. Puede dejar que la característica de detección automática localice el archivo .ins de configuración automática actualizado o definir la configuración automática en los equipos cliente.

Si es administrador corporativo, el Administrador de perfiles de IEAK le puede ayudar a mantener las versiones de Internet Explorer ya que proporciona un acceso rápido a la configuración del sistema desde una ubicación central. Para utilizar la configuración automática debe crear un perfil compuesto por un archivo .ins y todos los archivos contenedor (.cab) generados por el Administrador de perfiles. El perfil contiene información que se utiliza para configurar los exploradores. Una vez que haya creado el perfil, deberá almacenarlo en un servidor.

Cuando ejecute el Asistente para personalizar Internet Explorer 6, escriba la ruta de acceso del servidor correspondiente al archivo .ins. Si necesita cambiar la configuración del usuario posteriormente, deberá modificar el archivo .ins. La próxima vez que los usuarios inicien el explorador (o de acuerdo con una programación especifica) los cambios se reflejarán en todos los equipos de los usuarios.

Para ejecutar el Administrador de perfiles de IEAK

  1. Haga clic en Inicio, seleccione Todos los programas, Microsoft IEAK 6 y, finalmente, haga clic en Administrador de perfiles de IEAK.
  2. En el menú Archivo, haga clic en Abrir y abra el archivo .ins que desea modificar, o bien haga clic en Nuevo para crear un nuevo archivo.
  3. Seleccione la categoría deseada en Configuración del Asistente o en Directivas y restricciones del sistema.
  4. Modifique las opciones que desee cambiar.
  5. En el menú Archivo, haga clic en Guardar como.
  6. Escriba la ruta de acceso de su archivo .ins, la dirección URL donde están almacenados los archivos .cab y los nombres de sus archivos .cab, en caso de que no coincidan con los valores predeterminados proporcionados.

Notas

  • Deberá ejecutar el Asistente para personalizar Internet Explorer 6 como mínimo una vez antes de iniciar el Administrador de perfiles.
  • La ubicación predeterminada donde se guarda el archivo .ins de configuración automática es la carpeta siguiente: \directorio de versión\Ins\sistema operativo\idioma\. Por ejemplo, una versión española del archivo .ins creada para la plataforma de Windows de 32 bits se guardaría en la carpeta \Versión1\Ins\Win32\Es.
  • Para poder actualizar las opciones de configuración en los equipos de los usuarios, debe copiar el archivo de configuración automática .ins y los archivos .cab de complemento generados por el Administrador de perfiles de IEAK en un directorio de trabajo y probar la configuración. Tras haber validado los cambios, copie el nuevo archivo de configuración automática .ins en el servidor de producción. A continuación, la configuración automática actualiza las opciones de configuración en los equipos de los usuarios:
  • Si no cambia el número de versión del archivo .ins, no se descargarán los nuevos archivos .cab. El número de versión combina la fecha en la que se modificó el archivo .ins y el número de veces que se ha revisado el archivo.
  • Si conoce los archivos .adm, use las directivas y restricciones que haya configurado en sus propios archivos .adm. Para ello, haga clic en Directiva y, después, en Importar.
  • Si está usando la configuración automática y tiene instalados Internet Explorer 5 o posterior e Internet Explorer 4.0 con el mismo archivo de configuración automática, algunos valores que difieren entre las versiones no se configuran en Internet Explorer 4.0.


Actualizar las opciones de configuración del explorador

El Asistente para personalizar Internet Explorer crea un archivo de configuración automática .ins por cada paquete personalizado que se genere. El nombre predeterminado de este archivo es Install.ins, pero puede cambiarlo en cada paquete personalizado.

Una vez instalado el explorador, podrá utilizar el Administrador de perfiles de IEAK para actualizar las opciones de configuración; para ello, abra el archivo .ins de configuración automática, modifíquelo y, después, guárdelo. El Administrador de perfiles de IEAK también mantendrá actualizados los archivos de complemento cada vez que guarde el archivo .ins.

Puede cambiar la configuración del asistente, así como las directivas y restricciones.

Configuración del asistente

La configuración del asistente corresponde a las opciones del explorador y de los componentes configuradas inicialmente en las fases 2 a 5 del Asistente para personalizar Internet Explorer. Algunas de las opciones que puede cambiar son:

  • Título del explorador
  • Firmas digitales
  • Favoritos
  • Cadena de agente del usuario
  • Configuración de la conexión
  • Direcciones URL importantes
  • Cuentas de Outlook Express

Directivas y restricciones

La configuración de las directivas y restricciones corresponde a las opciones configuradas inicialmente en la pantalla Directivas y restricciones durante la Fase 5 del Asistente para personalizar Internet Explorer. Algunas de las opciones que puede cambiar son:

  • Microsoft NetMeeting
  • Configuración de Internet
  • Administrador de identidad
  • Restricciones corporativas
  • Microsoft Chat
  • Escritorio Web
  • Configuración corporativa

Para cambiar la configuración del asistente utilizando el Administrador de perfiles de IEAK

  1. Haga clic en Inicio, seleccione Todos los programas, Microsoft IEAK 6 y, finalmente, haga clic en Administrador de perfiles de IEAK.
  2. En el menú Archivo:
    • Haga clic en Abrir y, a continuación, abra el archivo .ins que desea modificar.
    • Haga clic en Nuevo para crear un nuevo archivo .ins.
  3. En Configuración del asistente, haga clic en una opción y, a continuación, modifique la información que desea cambiar.
  4. En el menú Archivo, haga clic en Guardar como y, a continuación, en el cuadro Nombre y ruta de acceso completos del archivo .INS, especifique la ruta completa del archivo .ins.

Para cambiar las directivas y restricciones del sistema utilizando el Administrador de perfiles de IEAK

  1. Haga clic en Inicio, seleccione Todos los programas, Microsoft IEAK 6 y, finalmente, haga clic en Administrador de perfiles de IEAK.
  2. En el menú Archivo:
    • Haga clic en Abrir y, a continuación, abra el archivo .ins que desea modificar.
    • Haga clic en Nuevo para crear un nuevo archivo .ins.
  3. Haga doble clic en una carpeta y, a continuación, seleccione una directiva o restricción.
  4. Modifique la información que desee cambiar.
  5. En el menú Archivo, haga clic en Guardar como y, a continuación, en el cuadro Nombre y ruta de acceso completos del archivo .INS, especifique la ruta completa del archivo .ins.
  6. En el cuadro Dirección URL de los archivos CAB, indique la ruta de acceso completa al archivo .cab.

Notas

  • Cuando guarda los cambios, el archivo .ins que especifica se utiliza para crear el nombre de archivo .cab en el cuadro Nombre del archivo CAB de configuración. Puede modificar este nombre de archivo en caso necesario.


Administrar la configuración automática

Puede usar una dirección URL de configuración automática para que los exploradores de los usuarios señalen automáticamente al perfil IEAK. Es posible especificar el archivo .ins, o bien, crear y especificar el archivo de página Active Server (.ASP) que genera un archivo .ins automáticamente.

También puede especificar archivos de comandos con formato .js, .jvs o .pac que le permitan establecer y mantener la configuración de proxy avanzada. Si especifica direcciones URL para la configuración automática y para el proxy automático (autoproxy), la dirección URL de autoproxy se incorporará al archivo .ins. La forma correcta de la dirección URL es http://share/test.ins.

Para habilitar la configuración automática

  1. Haga clic en Inicio, seleccione Todos los programas, Microsoft IEAK 6 y, finalmente, haga clic en Administrador de perfiles de IEAK.
  2. En el menú Archivo:
    • Haga clic en Abrir y, a continuación, abra el archivo .ins que desea modificar.
    • Haga clic en Nuevo para crear un nuevo archivo .ins.
  3. En Configuración del asistente, haga clic en Configuración automática del explorador.
  4. Active la casilla de verificación Habilitar la configuración automática.
  5. Escriba la dirección URL del archivo .ins en el cuadro Dirección URL de configuración automática (archivo .INS).
  6. Escriba la dirección URL de la secuencia de comandos de autoproxy en el cuadro Dirección URL de proxy automático (archivo .JS, .JVS o .PAC).

Nota

  • Puede definir un intervalo de actualización en el cuadro Configurar automáticamente cada nn . Aquí deberá especificar el número de minutos entre las actualizaciones. Si no indica ningún intervalo de actualización, el explorador se actualiza siempre que los usuarios lo abren y consultan una página Web.


Cambiar la ubicación del archivo de configuración automática .ins

Si tiene que mover el archivo .ins a un servidor de producción diferente, puede utilizar el Administrador de perfiles de IEAK para actualizar la dirección URL correspondiente a la configuración automática del explorador. En caso de que haya definido el archivo .ins de configuración automática de modo que se actualice en un intervalo de tiempo específico, después de actualizar la dirección URL para la configuración automática del explorador, deberá permitir que transcurran dos intervalos para que el cambio surta efecto.

Para actualizar la dirección URL de la configuración automática del explorador

  1. Haga clic en Inicio, seleccione Todos los programas, Microsoft IEAK y, finalmente, haga clic en Administrador de perfiles de IEAK.
  2. En el menú Archivo, haga clic en Abrir y abra el archivo de configuración automática .ins del paquete personalizado.
  3. En Configuración del asistente, haga clic en Configuración automática del explorador.
  4. Active la casilla de verificación Habilitar la configuración automática.
  5. En el cuadro Dirección URL de Configuración automática (archivo .INS), escriba la nueva ruta de acceso del servidor.
  6. En el menú Archivo, haga clic en Guardar como y, a continuación, en el cuadro Nombre y ruta de acceso completos del archivo .INS, escriba el nombre del archivo manteniendo su extensión .ins.

Importante

  • Debe copiar todos los archivos .cab creados en la carpeta de versión en la misma carpeta que contiene el archivo .ins.

Nota

  • Deje el archivo .ins anterior en el servidor hasta estar seguro de que se han actualizado todos los valores de configuración de los usuarios. Cuando los usuarios inicien el explorador y esté programada la actualización de las opciones de configuración, la dirección URL correspondiente a la configuración automática del explorador se actualizará en los equipos de los usuarios. En este momento, el explorador continúa utilizando las opciones de configuración del archivo .ins de configuración automática original (por ejemplo, http://ruta existente/Default.ins).

    Cuando los usuarios inicien el explorador por segunda vez y vuelva a programarse la actualización de las opciones de configuración, el explorador leerá el nuevo archivo de configuración automática .ins (por ejemplo, http://nueva ruta/Default.ins). Cuando esté seguro de que se ha actualizado la configuración de todos los equipos de los usuarios, elimine la copia anterior del archivo .ins de configuración automática de su ubicación original.


Generar archivos con el Administrador de perfiles de IEAK

Al actualizar y guardar las opciones de configuración, el Administrador de perfiles de IEAK genera los archivos siguientes:

Tipo de archivo | Función
Instalación de configuración automática (.ins) | Contiene la configuración del explorador y de los componentes que Microsoft Internet Explorer usa para actualizar la configuración del explorador en los equipos de los usuarios. Puede especificar estas opciones en la sección Configuración del asistente del Administrador de perfiles de IEAK.
Contenedores (.cab) | Contiene los archivos de instalación que se descargan a los equipos de los usuarios. Debe firmar digitalmente los archivos .cab creados por el Administrador de perfiles de IEAK. Para obtener más información acerca de cómo firmar los archivos .cab, consulte Firmar sus programas . Los archivos de configuración automática .cab también contienen archivos de información (.inf).
Información (.inf) | Contiene las directivas del sistema y restricciones que el sistema operativo usa para actualizar la configuración del sistema en los equipos de los usuarios. Puede especificar estas opciones en la sección Directivas y restricciones del Administrador de perfiles de IEAK. Todos los archivos .inf también contienen información acerca de la versión. Al cambiar las opciones de configuración, el Administrador de perfiles de IEAK actualiza los archivos .inf afectados y su información de versión y vuelve a empaquetar los archivos .cab de complemento.

Internet Explorer descarga y procesa el contenido del archivo de configuración automática .ins y lleva a cabo los cambios necesarios en los equipos de los usuarios. Además, descarga y desempaqueta los archivos .cab de complemento para que los procese el sistema operativo. Si no cambia el número de versión del archivo de configuración automática .ins, no se descargarán los nuevos archivos .cab. El número de versión está formado por la fecha en la que se modificó el archivo .ins y el número de veces que se ha revisado.


Crear configuraciones únicas para distintos grupos de usuarios

Si los usuarios tienen necesidades diferentes o si desea cambiar las opciones de configuración de determinados usuarios independientemente, puede crear varios archivos de configuración automática .ins. Utilice el Administrador de perfiles de IEAK para especificar distintas opciones de configuración de cada grupo y guardarlas como archivos grupoDeUsuarios.ins individuales, donde grupoDeUsuarios es el nombre exclusivo de cada grupo de usuarios. El Administrador de perfiles de IEAK genera automáticamente los archivos .cab de complemento. Por ejemplo, podría especificar una configuración exclusiva para el departamento financiero y guardarla como Finanzas.ins. Después, el Administrador de perfiles de IEAK generaría los archivos .cab necesarios.

Nota

  • Si crea varios archivos de configuración automática .ins, asegúrese de que los paquetes personalizados estén configurados para usar el archivo correcto. También puede utilizar una solución automatizada de servidor que le permita emplear varios archivos .ins sin que sea necesario volver a generar los paquetes personalizados.


Utilizar las plantillas de directiva personalizadas

El Administrador de perfiles de IEAK usa un conjunto predeterminado de plantillas de directiva de Windows, o archivos de administración (.adm), para definir las reglas de las directivas del sistema y las restricciones. Los archivos .adm y los archivos de las directivas y restricciones del sistema son características estándar de las ediciones Windows de 32 y 16 bits. Si está familiarizado con los archivos .adm, podrá crear plantillas propias para definir restricciones adicionales. Para obtener más información, consulte la documentación de Windows.

Con el Administrador de perfiles de IEAK, puede importar sus propios archivos .adm personalizados e incluirlos con las opciones de configuración actualizadas. El Administrador de perfiles de IEAK genera un archivo .inf asociado en el que se utiliza el prefijo de archivo correspondiente al archivo .adm personalizado que se importa. Por ejemplo, si importa un archivo llamado Custom.adm, se genera un archivo Custom.inf que se agrega a los archivos .cab de complemento. Para obtener más información acerca de cómo usar archivos .adm personalizados, consulte Descripción de la configuración y restricciones.


Administrar sistemas con Windows 2000 con el Administrador de perfiles

Si utiliza la instalación desatendida para implementar Microsoft Internet Explorer en Windows 2000, puede emplear el Administrador de perfiles de IEAK para especificar la configuración personalizada de Internet Explorer. Esta configuración quedará establecida cuando se ejecute la instalación desatendida. El Administrador de perfiles permite crear archivos .ins y, si es necesario, archivos contenedor (.CAB). El archivo .ins se especifica en la sección [Branding] del archivo Unattend.txt. Para obtener más información, consulte la documentación del programa de instalación de Windows 2000.

Para especificar Windows 2000 como plataforma, haga clic en el menú Plataforma y, después, haga clic en Windows 2000. En Configuración del asistente, haga clic en los elementos que desea personalizar.

Las restricciones, que determinan qué opciones pueden cambiar los usuarios, no están disponibles para Windows 2000 en el Administrador de perfiles de IEAK. Para definir restricciones en Windows 2000, use Directiva de grupo. Para obtener más información, busque "Directiva de grupo" en la Ayuda de Windows 2000.

Las opciones de los certificados digitales no están disponibles para Windows 2000 en el Administrador de perfiles del IEAK, ya que Windows 2000 incluye características avanzadas de administración de certificados. Para obtener más información, busque "certificados digitales" en la Ayuda de Windows 2000.


Crear un programa piloto

Es necesario crear una versión de prueba del paquete personalizado, instalarlo en varios equipos de laboratorio, probar y evaluar el rendimiento y, posteriormente, actualizar el paquete con los cambios que desee realizar. Se recomienda que prepare un plan de prueba y listas de comprobación para las pruebas de laboratorio y que posteriormente utilice las listas de revisión para registrar la finalización satisfactoria de las tareas y anotar todos los problemas surgidos durante el proceso. Asimismo, prepare una lista de comprobación para probar todas las estrategias de implementación y distribución.

Identifique y seleccione grupos piloto y prepárelos para el programa piloto. Si la organización es grande o presenta grupos con entornos informáticos claramente diferenciados, debería ejecutar un programa piloto para cada entorno o grupo diferente. Localice grupos que representen a los usuarios de la organización. Para garantizar un buen resultado, compruebe que los voluntarios disponen de tiempo suficiente en sus horarios para participar de lleno en el programa piloto.

Los siguientes procedimientos son ejemplos de cómo ejecutar un programa piloto. Estos procedimientos son sólo pautas ya que cada entorno es único.

Para preparar un programa piloto para la implementación

Identifique las tareas y recursos necesarios para llevar a cabo el programa piloto. Antes de implementar Microsoft Internet Explorer 6 en la organización, utilice los clientes de laboratorio para probar y perfeccionar las estrategias y configuraciones de implementación. Para planear el programa piloto:

  1. Seleccione los grupos piloto apropiados.
  2. Documente los recursos y tareas necesarias para el programa piloto.
  3. Desarrolle un plan de formación de usuarios.
  4. Desarrolle un plan de soporte de usuarios.

Para crear un paquete de prueba para el programa piloto

Deberá crear un paquete de prueba para el programa piloto.

  1. Instale Internet Explorer 6 en el equipo de prueba.
  2. Instale el IEAK 6 y, a continuación, inicie el Asistente para la configuración.
  3. Genere un paquete de prueba personalizado.
  4. Configure los archivos de configuración automática (.ins, .js, .pac).
  5. Configure los sitios de descarga e instale los archivos de distribución.
  6. Copie los archivos de distribución a discos compactos y disquetes.

Para implementar un programa piloto en clientes de laboratorio

Utilice los métodos de distribución apropiados para implementar los paquetes de prueba personalizados de Internet Explorer en los equipos de laboratorio. Por ejemplo, envíe mensajes de correo electrónico a los usuarios indicándoles cómo descargar el paquete personalizado.

De manera alternativa, adjunte archivos por lotes a los mensajes de correo electrónico indicando a los usuarios que hagan doble clic en el archivo por lotes y que instalen el paquete personalizado. Si va a distribuir los paquetes personalizados en discos compactos o disquetes, distribúyalos a los usuarios y proporcione instrucciones de instalación.

  1. Distribuya el paquete de prueba personalizado utilizando varios métodos de distribución.
  2. Utilice el programa de instalación de Internet Explorer para instalar el paquete de prueba personalizado en cada cliente.
  3. Inicie Internet Explorer en todos los clientes para garantizar que la instalación se ha realizado satisfactoriamente.

Para probar el programa piloto en los clientes de laboratorio

Deje un espacio físico para cada laboratorio y prepare una combinación de equipos que reflejen con precisión los entornos de hardware y de software. Si emplea equipos portátiles que marcan desde ubicaciones remotas o si se precisan servidores o equipos principales adicionales para los datos empresariales, proporcione a los equipos de laboratorio una línea de teléfono analógica y un acceso apropiado a la red.

Configure los clientes de laboratorio y los servidores para que representen las configuraciones de los usuarios y empresariales habituales. Asegúrese de incluir todas las configuraciones del sistema operativo y de las aplicaciones empresariales, además de las configuraciones de Internet y del explorador. Asimismo, documente el programa de instalación de laboratorio y registre cualquier cambio realizado en el programa de instalación.

Mantenga un registro de todos los aspectos y problemas que surjan. Estos registros le ayudarán a diseñar soluciones para corregir los problemas.

  1. Ejecute Internet Explorer 6 para probar todos los complementos y características.
  2. Ejecute las aplicaciones empresariales para comprobar si el funcionamiento es satisfactorio.
  3. Realice todas las tareas de implementación utilizando las listas de comprobación del plan de prueba.
  4. Identifique los problemas con el proceso de implementación y con los aspectos de migración.
  5. Revise el plan de implementación basándose en la información obtenida a partir de la prueba.

Para desinstalar el programa piloto de los clientes de laboratorio

  1. Desinstale Internet Explorer 6 y los complementos.
  2. Compruebe que se han quitado los componentes de Internet Explorer 6.
  3. Pruebe las aplicaciones de escritorio y empresariales.

Advertencia

  • Algunas configuraciones pueden impedir la desinstalación de Internet Explorer 6 y los componentes personalizados. Debe revisar los temas relacionados para asegurarse de que conoce los elementos personalizados que pueden ayudarle a realizar una desinstalación perfecta en los clientes de laboratorio.

Temas relacionados

Para desarrollar un plan de formación de los usuarios

Prepare un plan de formación que satisfaga las necesidades de los usuarios. Utilice el plan de formación como la base para la implementación final del paquete personalizado. Revise el plan basándose en la información obtenida a partir del programa piloto y utilice ésta para la formación de los usuarios en la implementación final.

  1. Designe el personal y los recursos de formación.
  2. Incluya formación en Internet Explorer 6 para los nuevos usuarios.
  3. Separe la formación para administradores de la formación para usuarios finales.
  4. Forme a los administradores en el Administrador de perfiles e IEAK.
  5. Instruya a los usuarios finales en el acceso y la exploración de la Ayuda.

Para desarrollar un plan de soporte a usuarios

Prepare un plan de soporte que satisfaga las necesidades de los usuarios.

  1. Designe el personal de soporte y sus recursos.
  2. Incluya soporte en línea para la implementación utilizando una página Web personalizada en la intranet.
  3. Instale un servicio de soporte para la asistencia administrativa a los usuarios finales.

Para realizar una prueba beta del programa piloto

Una vez creado correctamente el programa piloto de laboratorio, necesitará realizar una prueba beta del paquete personalizado. De este modo, se asegurará de que varios usuarios beta pueden trabajar con las configuraciones y personalizaciones del paquete. También tendrá la oportunidad de cambiar de opinión sobre algunos valores de configuración sin que esto afecte a todos los usuarios.

  1. Prepare paquetes personalizados para la implementación.
  2. Implemente paquetes personalizados para los usuarios piloto.
  3. Supervise y proporcione soporte a los usuarios mientras instalan y utilizan Internet Explorer 6.

Para crear un paquete personalizado

Instale Internet Explorer 6 y el IEAK 6 cuando esté preparado para crear el paquete personalizado. Si configura el equipo de trabajo optimizará la personalización, ya que en muchas áreas puede importar la configuración actual al paquete personalizado.

  1. Instale Internet Explorer 6 en el equipo de producción.
  2. Instale el IEAK 6 en el equipo de producción.
  3. Inicie una sesión como administrador y, a continuación, ejecute el Asistente para la personalización del IEAK.
  4. Cree los paquetes personalizados necesarios.
  5. Configure los sitios de descarga e instale los archivos de distribución.
  6. Si es necesario, copie los archivos de distribución a los discos compactos y disquetes.


Utilizar CMAK para las conexiones

Puede utilizar el Kit de administración de Connection Manager (CMAK) para crear y administrar perfiles para Connection Manager de Microsoft. El Connection Manager forma parte de Internet Connection Point Services para RAS, que se incluye en Windows NT Option Pack.

El Connection Manager es una aplicación cliente similar al Acceso telefónico a redes. Admite varios números de teléfono por perfil de Connection Manager y le proporciona la capacidad de ejecutar aplicaciones de manera automática antes, durante y después de que se produzca una conexión. También le permite configurar una red privada virtual.

Si integra el Connection Manager con Connection Point Services para Windows NT, formado por un administrador de directorio telefónico y un servicio de directorio telefónico, puede configurar automáticamente, administrar y actualizar dinámicamente números de conexión a un perfil cliente del Connection Manager.

Hay cuatro ventajas principales en la creación de conexiones automáticas con CMAK. Son las siguientes:

  • Utilizar varios números de teléfono por perfil de Connection Manager
  • Ejecutar las aplicaciones de manera automática antes, durante y después de la realización de una conexión
  • Actualizar dinámicamente los directorios telefónicos del Connection Manager cuando los números de acceso cambian
  • Personalizar los perfiles del Connection Manager con mapas de bits, contratos de licencia específicos, archivos de Ayuda y parámetros de línea de comandos.

Nota

  • El Kit de administración del Connection Manager (CMAK) no se incluye en IEAK 6. CMAK se encuentra disponible en Windows 2000 Server o posterior, así como en Windows 2000 Administration Pack. Una versión anterior de CMAK se encuentra disponible en IEAK 5.0.


Importar una conexión

Importar una conexión conlleva copiar la configuración del Acceso telefónico a redes (DUN) desde la estación de trabajo IEAK y, posteriormente, guardar la configuración de la conexión en el paquete personalizado. Si importa una conexión de esta forma, creará una entrada DUN común en las estaciones de trabajo de todos los usuarios. También se importa la configuración del marcado, el protocolo y el servidor proxy para cada conexión.

Si importa más de una entrada DUN, la conexión predeterminada en la estación de trabajo IEAK se convierte en la conexión predeterminada de las estaciones de trabajo de los usuarios. La ventaja principal de este enfoque es su simplicidad. Puede importar entradas DUN y utilizarlas junto con las existentes de los usuarios, tales como un ISP personal.

La utilización del IEAK para crear una configuración DUN es apropiada en situaciones donde un punto de marcado de presencia (como un servidor RAS) posee un único número de marcado que posiblemente no cambiará. Un inconveniente que presenta la importación de conexiones existentes es la naturaleza estática de una entrada DUN. Si los usuarios requieren varios números de marcado o los números de RAS tienden a cambiar con frecuencia, entonces perderá demasiado tiempo importando entradas DUN independientes.

Hay algunas situaciones en las que debería utilizar CMAK para crear configuraciones DUN:

  • Los usuarios remotos se conectan a múltiples números
  • Los paquetes se distribuyen a varios grupos de usuarios cuyos números de teléfono de conexión difieren entre ellos


Personalización para los proveedores de contenido Internet

El IEAK permite a los proveedores de contenido Internet (ICP) y a los proveedores independientes de software (ISV) crear un explorador personalizado para los clientes que ya tienen cuentas de Internet.

Como ICP, también puede crear un explorador personalizado si va a utilizar el servidor de referencia de Microsoft como parte de su paquete personalizado. El mantenimiento de este servidor de referencia, que proporciona información acerca de los proveedores de servicios Internet de su área, lo realiza Microsoft. Este servidor de referencia le permite vincular con servidores de suscripción.

Personalizar el programa de instalación

  • Personalice la apariencia del programa de instalación de Windows Update y configure los modos de instalación (por ejemplo, las instalaciones Estándar y Mínima).
  • Dirija a los usuarios a servidores de Internet para que tengan acceso a las versiones más recientes del producto.
  • Especifique la versión de idioma de Microsoft Internet Explorer que se incluirá en el paquete de instalación. Debe ejecutar una vez el Asistente para personalizar Internet Explorer 6 por cada versión de idioma que desee crear.

Personalizar el explorador

  • Establezca las páginas inicial, de búsqueda y de soporte.
  • Cargue vínculos y carpetas en la lista de Favoritos.
  • Cambie la barra de título y los logotipos del explorador y de Outlook Express. La barra de título de Outlook Express se actualiza tanto si distribuye Outlook Express en su paquete como si ya está instalado en el equipo de los usuarios.

Utilizar el logotipo de Internet Explorer

De acuerdo con los términos del contrato de licencia, debe mostrar el logotipo de Internet Explorer en su paquete y materiales de promoción, así como en su sitio Web. Visite el sitio Web de IEAK para obtener información y ejemplos acerca del logotipo y de imágenes listas para usar.

Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.

Importante

  • Puede que algunas características no estén disponibles, según su contrato de licencia. Para obtener más información, consulte su contrato.


ICP: Preparación para ejecutar el asistente

titular

Preparación para ejecutar el asistente

Antes de ejecutar el Asistente para personalizar Internet Explorer 6, debe recopilar toda la información que va a necesitar y crear los mapas de bits personalizados.

Determinar los requisitos iniciales de plataforma

  • Compruebe que el equipo en el que va a generar el paquete y los equipos en los que se va a instalar cumplen los requisitos de hardware y de software.
  • Determine los niveles de cifrado para los paquetes del explorador. Para obtener información acerca del cifrado de Microsoft Internet Explorer, visite el sitio Web del IEAK.

Elegir el método de distribución

Decida cómo va a distribuir el paquete personalizado. Una vez que el Asistente para personalizar Internet Explorer 6 genere el paquete, tendrá que mover los archivos al medio seleccionado. Si genera un paquete descargable, debe moverlo al lugar apropiado de su servidor.

Si decide publicar su paquete personalizado en un servidor de Internet, necesitará la ruta de acceso del servidor y la dirección URL desde la que se descargarán los archivos. Después, cree una carpeta en el servidor Web, como CIE, para publicar todos los archivos y carpetas asociados al paquete personalizado. Por ejemplo, podría crear la ruta de acceso de servidor C:\Inetpub\Wwwroot\Cie\. Si nombreDelEquipo es la raíz virtual de este servidor Web, la dirección URL correspondiente sería http://nombreDelEquipo/Cie/.

Obtener un certificado digital

Realice los preparativos iniciales para firmar determinados archivos, como son los archivos de personalización creados por el Asistente para personalizar Internet Explorer 6 y los componentes personalizados, en el caso de que vaya a distribuirlos a través de Internet o de una intranet que no esté especialmente configurada. Con las características de seguridad del explorador, se advierte a los usuarios acerca de la descarga de archivos sin firmar o se les impide descargarlos. Las firmas digitales identifican el origen de los programas y garantizan que el código no ha cambiado desde que se firmó.

El Asistente para personalizar Internet Explorer 6 puede firmar los archivos si dispone de un certificado de publicación emitido por una entidad emisora de certificados. Para preparar los certificados de forma que los utilice el IEAK, puede importarlos en el equipo mediante el Asistente para la importación del Administrador de certificados. Si ha recibido un archivo con la extensión .spc, puede iniciar el Asistente para la importación del Administrador de certificados haciendo doble clic en el archivo .spc en el Explorador de Windows o en Mi PC.

También puede abrir el Administrador de certificados desde Internet Explorer. Para hacerlo, haga clic en el menú Herramientas, Opciones de Internet, haga clic en la ficha Contenido y, finalmente, en Certificados. Haga clic en Importar para iniciar el Asistente para importación del Administrador de certificados y, después, siga los pasos que se indican en el asistente.

Crear la estructura en el equipo

Nombre de carpeta | Descripción
\CIE | Una raíz principal para todos los archivos generados por el IEAK o a los que el paquete personalizado haga referencia
\CIE\Bitmaps | Archivos de mapas de bits personalizados (archivos gráficos necesarios para el explorador personalizado)

Crear los gráficos apropiados

Tiene la opción de personalizar los mapas de bits del explorador citados más adelante. Antes de ejecutar el Asistente para personalizar Internet Explorer 6, coloque los mapas de bits en la carpeta \CIE\Bitmaps\.

Los fondos y botones personalizados sólo se muestran en equipos con capacidad para mostrar 256 colores (8 bits). En los equipos con capacidad para mostrar 16 colores (4 bits) se muestra un conjunto estándar de botones y mapas de bits de fondo de baja resolución.

  • Un mapa de bits de fondo para la pantalla de ejecución automática del CD-ROM (si crea un paquete en CD-ROM).

    Si piensa distribuir su explorador personalizado en un disco compacto, necesitará crear mapas de bits como parte de la pantalla inicial de ejecución automática que aparece cuando el usuario inserta el disco compacto.

  • Imágenes personalizadas para los botones del CD-ROM (si crea un paquete en CD-ROM).
  • Dos mapas de bits personalizados para el Asistente para la instalación de Windows Update (si desea personalizar su apariencia): un mapa de bits de 162 por 312 píxeles para el lado izquierdo de la primera pantalla del asistente y un mapa de bits de 496 por 56 píxeles para la parte superior de las restantes pantallas del asistente.
  • Un mapa de bits personalizado de barra de herramientas (que se muestra como fondo de los botones y menús).
  • Dos imágenes de mapa de bits estáticas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo.
  • Dos imágenes de mapa de bits animadas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo animado.

    El IEAK contiene dos herramientas que le ayudan a crear y obtener vistas previas de los mapas de bits animados personalizados para el explorador.

Recopilar las direcciones URL de las páginas Principal, Búsqueda y Soporte.

Es conveniente crear una página de soporte que aparezca si los usuarios tienen problemas al instalar el explorador. Se le pedirán las direcciones URL de esas páginas cuando ejecute el Asistente para personalizar Internet Explorer 6.

Notas

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.


ICP: Fase 1 del asistente: recopilar información

titular

Fase 1 del asistente: recopilar información

En la primera fase del Asistente para personalizar Internet Explorer 6, se pedirá a los proveedores de contenido y los proveedores independientes de software (ISV) la información siguiente:

  • La ubicación de los archivos necesarios para crear el paquete personalizado del explorador.
  • El idioma del paquete del explorador que está creando. Necesitará ejecutar el Asistente para personalizar Internet Explorer 6 para cada versión internacional que desee crear.
  • El medio de distribución que planee utilizar, como CD-ROM o descarga.
  • Las características que vaya a personalizar. Por ejemplo, si sólo va a hacer pequeñas modificaciones al explorador, no tendrá que pasar por todas las pantallas del Asistente para IEAK.

Nota

  • El Asistente para personalizar Internet Explorer 6 no funcionará correctamente si no está instalado Internet Explorer 6. Para obtener más información, consulte Requisitos de hardware y del sistema.


ICP: Fase 2 del asistente: especificar los parámetros de instalación

titular

Fase 2 del asistente: especificar los parámetros de instalación

En esta fase del Asistente para personalizar Internet Explorer 6, un proveedor de contenido debe:

  • Descargar o actualizar componentes de Microsoft mediante la sincronización automática de versiones (AVS). Debe descargar Microsoft Internet Explorer, pero puede elegir el resto de componentes de Internet Explorer que descargará.
  • Seleccionar los componentes personalizados que desea incluir.

    También puede especificar hasta 16 componentes adicionales, que pueden ser archivos ejecutables autoextraíbles (.exe) o archivos contenedores (.cab) comprimidos.


ICP: Fase 3 del asistente: personalizar la instalación

titular

Fase 3 del asistente: personalizar la instalación

En esta fase del Asistente para personalizar Internet Explorer 6, como proveedor de contenido puede determinar la apariencia y el funcionamiento del programa de instalación de Windows Update:

  • Personalice la pantalla de ejecución automática del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice otras opciones del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice el Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet. Estas opciones de configuración afectan a la apariencia del programa de instalación.
  • Especifique hasta diez opciones de instalación y determine los componentes que incluirá en cada opción.
  • Especifique hasta diez sitios desde los que se puede descargar el paquete.
  • Especifique de qué forma recibirán los usuarios las actualizaciones de los componentes.
  • Especifique si el programa de instalación debe detectar si existe un componente concreto y determine con precisión qué componentes pueden personalizar los usuarios.
  • Determine si los componentes que se han descargado pero no se han incluido en todos los paquetes deben ponerse a disposición de los usuarios por medio de la característica de instalación a petición de Internet Explorer.
  • Especifique los datos de la entidad emisora de certificados para que, si tiene un certificado digital, pueda firmar los programas al crear el paquete IEAK.

Notas

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.
  • Si desea ver un organigrama de lo que ocurre al usar el Asistente para personalizar de Internet Explorer 6 para crear un paquete personalizado, consulte Cómo genera IEAK los paquetes personalizados.


ICP: Fase 4 del Asistente: personalizar el explorador

titular

Fase 4 del asistente: personalizar el explorador

En esta fase del Asistente para personalizar Internet Explorer 6, los proveedores de contenido pueden personalizar lo siguiente:

  • La barra de título del explorador. El título del explorador personalizado aparece en Internet Explorer y en Outlook Express, tanto si se ha distribuido con su paquete como si ya está instalado en el equipo de los usuarios.
  • El fondo y los botones de la barra de herramientas del explorador. Puede agregar botones personalizados a la barra de herramientas para ejecutar secuencias de comandos y programas.
  • El logotipo de Internet Explorer de la esquina superior derecha del explorador.
  • Las páginas principal, de búsqueda y de soporte en línea del explorador.
  • Los favoritos, las carpetas de favoritos y los vínculos de la barra de vínculos.
  • La página de bienvenida, que ven los usuarios cuando inician el explorador por primera vez.
  • La cadena de agente del usuario. El identificador del agente del usuario es opcional. Es una forma de realizar un seguimiento del uso de su explorador personalizado.

Nota

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.


titular

Proveedor de contenido Internet

Fase 5 del asistente: personalizar componentes

En esta fase del Asistente para personalizar Internet Explorer 6, los proveedores de contenido pueden personalizar lo siguiente:

  • La configuración predeterminada del programa, como los programas específicos que se utilizarán para leer correo electrónico o modificar el Lenguaje de marcado de hipertexto (HTML).
  • Las directivas y la configuración del sistema, para preestablecer las opciones de Internet.


ICP: distribuir su paquete del explorador

titular

Proveedor de contenido Internet

Distribuir su paquete del explorador

De forma predeterminada, el Asistente para personalizar Internet Explorer 6 crea archivos para descargar desde Internet. También puede distribuir un paquete personalizado en un CD-ROM.

Archivos descargables

Si creó el paquete personalizado en un servidor de Internet o de una intranet, tiene que configurar su sitio Web para que los usuarios puedan descargar los archivos. Por ejemplo, puede crear una página en la que publique la información de descarga y un vínculo al motor de instalación, IE6setup.exe.

Si creó el paquete del explorador en un disco duro o en una unidad de red, deberá mover los elementos siguientes al servidor de la intranet o de Internet:

  • La carpeta que contiene la versión de idioma que está publicando y los contenidos de la carpeta. Por ejemplo, la carpeta de la versión en inglés se llama EN, por lo que debe mover la carpeta EN y los archivos que contiene. Esta carpeta se encuentra en las carpetas que correspondan al tipo de distribución, como Download (descarga) y plataforma. La única designación de plataforma del IEAK 6 es "Win32"; para clientes UNIX y Windows de 16 bits, use IEAK 5.x.
  • El archivo Ie6sites.dat. Este archivo señala el sitio (o sitios) de descarga que especificó al ejecutar el Asistente para personalizar Internet Explorer 6.

Notas

  • Para ver un ejemplo, consulte Cómo configurar los archivos para distribución.
  • Para ver un organigrama de los archivos que crea el Asistente para personalizar Internet Explorer 6, consulte Cómo genera IEAK paquetes personalizados.

Firmar los paquetes personalizados

Los exploradores Web tienen características de seguridad que ayudan a proteger a los usuarios frente a la descarga de programas perjudiciales. En función del nivel de seguridad y de la plataforma, se puede advertir al usuario o evitar que descargue programas que no estén firmados digitalmente.

Los archivos .cab personalizados creados con el Asistente para personalizar Internet Explorer 6 deben estar firmados, a menos que se haya configurado la zona local de la intranet con un nivel bajo de seguridad. Cualquier componente personalizado que distribuya con el paquete del explorador y vaya destinado a esas plataformas también debe estar firmado. Si dispone de un certificado digital, el Asistente para personalizar Internet Explorer 6 puede firmar automáticamente esos archivos.

Notas

  • La firma de los archivos contenedores (.cab) y los programas personalizados conlleva dos pasos: obtener un certificado digital y especificar los datos del certificado al ejecutar el Asistente para personalizar Internet Explorer 6. Para obtener más información, consulte Firmar sus programas.
  • Es posible que deba cambiar las mayúsculas y minúsculas de los nombres de los archivos publicados en un servidor UNIX de FTP. A continuación se detallan las convenciones que debe usar para sistemas operativos UNIX específicos.
    • Solaris UNIX

      Si está utilizando un servidor FTP de UNIX que distingue mayúsculas y minúsculas, debe asegurarse de que la carpeta contenedora no contiene mayúsculas, mientras que los archivos siguientes están en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE6SITES.DAT.

    • AT&T UNIX

      Todos los archivos deben estar en mayúsculas en un servidor FTP de UNIX de AT&T.

    • IRIX UNIX (Silicon Graphics)

      Los siguientes nombres de archivo deben ponerse en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE6SITES.DAT. Debe usar un procesador de textos a fin de modificar los nombres de archivos enumerados en IE.CIF para que la utilización de mayúsculas coincida con la de los archivos.

CD-ROM

Si distribuye el paquete personalizado para usuarios de Windows 95 o Windows 98, aparecerá una pantalla inicial del programa de ejecución automática cuando el usuario inserte el disco compacto. Este programa ofrece a los usuarios la posibilidad de instalar el explorador personalizado o ver más información. Si ya está instalada la versión actual de Microsoft Internet Explorer, el programa de ejecución automática la detectará. Se mostrará el explorador en lo que se conoce como modo de pantalla completa con el archivo Start.htm cargado.


Personalización para proveedores de servicios Internet

IEAK permite a los proveedores de servicios Internet (ISP) crear un explorador personalizado y un paquete de suscripción a servicios Internet para sus clientes.

Personalizar el programa de instalación

  • Personalice la apariencia del programa de instalación de Windows Update y configure los modos de instalación (por ejemplo, las instalaciones Estándar y Mínima).
  • Dirija a los usuarios a servidores de Internet para que tengan acceso a las versiones más recientes del producto.
  • Distribuya programas adicionales, secuencias de comandos personalizadas o secuencias de comandos para mantenimiento con Microsoft Internet Explorer.
  • Especifique qué idioma de Internet Explorer se incluirá en el paquete de instalación. Debe ejecutar una vez el Asistente para personalizar Internet Explorer 6 por cada versión de idioma que desee crear.

Personalizar el explorador

  • Establezca las páginas inicial, de búsqueda y de soporte.
  • Cargue vínculos y carpetas en la lista de Favoritos.
  • Cambie la barra de título y los logotipos del explorador y de Outlook Express. La barra de título de Outlook Express se actualiza tanto si distribuye Outlook Express en su paquete como si ya está instalado en los equipos de los usuarios.

Nota

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.

Controlar cómo se suscribirán los usuarios a su servicio

  • Implementar un paquete de servidores de suscripción: si el usuario no se ha suscrito todavía a su servicio, puede proporcionarle una cuenta totalmente activa mediante un servidor de suscripción basado en HTML y fácil de implementar.
  • Implementar un paquete sin servidor: si el usuario ya posee una cuenta con su servicio o con otro servicio, puede actualizar el sitio del usuario con un explorador personalizado mediante un sencillo proceso sin servidor. Este tipo de paquete requiere que el usuario especifique parte de la configuración final al realizar la instalación.

Nota

  • Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.

Utilizar el logotipo de Internet Explorer

De acuerdo con los términos del contrato de licencia, debe mostrar el logotipo de Internet Explorer en su paquete y materiales de promoción, así como en su sitio Web. Las imágenes gráficas necesarias para su sitio Web, los paquetes de sus programas y otros materiales de promoción se encuentran en la carpeta \<carpeta de programa IEAK>\Toolkit\Graphics\Samples.

Importante

  • Puede que algunas características no estén disponibles, según su contrato de licencia. Para obtener más información, consulte su contrato.


ISP: Preparación para ejecutar el asistente

titular

Preparación para ejecutar el asistente

Antes de ejecutar el Asistente para personalizar Internet Explorer 6, debe recopilar toda la información que va a necesitar y crear los mapas de bits personalizados.

Determinar los requisitos de plataforma iniciales

  • Compruebe que el equipo en el que va a generar el paquete y los equipos donde va a instalar cumplen los requisitos de hardware y de software.
  • Determine los niveles de cifrado para los paquetes del explorador. Para obtener información acerca del cifrado de Microsoft Internet Explorer, visite el sitio Web del IEAK.

Elegir el método de distribución

Decida cómo distribuirá su paquete personalizado (CD, descarga, red de área local o en discos). Una vez que el Asistente para personalizar Internet Explorer 6 genere el paquete, tendrá que mover los archivos al medio seleccionado. Si genera un paquete descargable, debe moverlo al lugar apropiado de su servidor.

Si decide publicar su paquete de explorador en un servidor de Internet, necesitará la ruta de acceso del servidor y la dirección URL desde la que se descargarán los archivos. Después, cree una carpeta en el servidor Web, como CIE, para publicar todos los archivos y carpetas asociados al explorador personalizado. Por ejemplo, podría crear la ruta de acceso de servidor C:\Inetpub\Wwwroot\ie5\Cie. Si nombreDelEquipo es la raíz virtual de este servidor Web, la dirección URL correspondiente sería http://nombreDelEquipo/Cie/.

Obtener un certificado digital

Realice los preparativos iniciales para firmar determinados archivos, como son los archivos de personalización creados por el Asistente para personalizar Internet Explorer 6 y los componentes personalizados, en el caso de que vaya a distribuirlos a través de Internet o de una intranet que no esté especialmente configurada. Con las características de seguridad del explorador, se advierte a los usuarios acerca de la descarga de archivos sin firmar o se les impide descargarlos. Las firmas digitales identifican el origen de los programas y garantizan que el código no ha cambiado desde que se firmó.

El Asistente para personalizar Internet Explorer 6 puede firmar los archivos si dispone de un certificado de publicación emitido por una entidad emisora de certificados. Para preparar los certificados de forma que los utilice el IEAK, puede importarlos en el equipo por medio del Asistente para la importación del Administrador de certificados. Si ha recibido un archivo con la extensión .spc, puede iniciar el Asistente para la importación del Administrador de certificados haciendo doble clic en el archivo .spc en el Explorador de Windows o en Mi PC.

También puede abrir el Administrador de certificados desde Internet Explorer. Para hacerlo, haga clic en el menú Herramientas, Opciones de Internet, haga clic en la ficha Contenido y, finalmente, en Certificados. Haga clic en Importar para iniciar el Asistente para la importación del Administrador de certificados y, después, siga los pasos que se indican.

Crear la estructura en el equipo

Cree la estructura de carpetas siguiente:

Nombre de carpeta | Descripción
\CIE | Una raíz principal para todos los archivos generados por el IEAK o a los que el paquete personalizado haga referencia
\CIE\Custom | Los archivos personalizados (como Signup.isp, Signup.htm, Icwsign.htm, Install.ins y Cancel.ins, dependiendo de su método de suscripción) para suscripción con servidor
\CIE\Dist | Directorio de destino de los archivos (esta carpeta sólo es necesaria si está creando su paquete del explorador en un disco duro o en una unidad de red)
\CIE\Bitmaps | Archivos de mapas de bits personalizados (archivos gráficos necesarios para el explorador personalizado)

Para copiar los archivos de suscripción necesarios para esta estructura

  1. Seleccione todos los archivos de las subcarpetas siguientes que se encontrarán donde se haya instalado el IEAK: \<carpeta de programa IEAK>\Toolkit\Isp\Servless, para suscripción a Internet sin servidor, o \<carpeta de programa IEAK>\Toolkit\Isp\Server\, para suscripción a Internet con servidor.
  2. Copie estos archivos a CIE\Custom.

Elegir un método de suscripción y personalizar los archivos de suscripción

En el paquete personalizado, puede especificar cómo se suscribirán los nuevos usuarios a su servicio y cómo se conectarán a Internet. Puede elegir un proceso de suscripción con o sin servidor, o deshabilitar por completo la característica de suscripción (para distribuir actualizaciones de software a usuarios existentes). En el kit de herramientas del IEAK se incluyen archivos de ejemplo de las páginas HTML necesarias para admitir cada método de suscripción.

Nota

  • Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.

Crear los gráficos apropiados

Tiene la opción de personalizar los mapas de bits del explorador citados más adelante. Antes de ejecutar el Asistente para personalizar Internet Explorer 6, coloque los mapas de bits en la carpeta \CIE\Bitmaps.

Los fondos y botones personalizados sólo se muestran en equipos con capacidad para mostrar 256 colores (8 bits). En los equipos con capacidad para mostrar 16 colores (4 bits) se muestra un conjunto estándar de botones y mapas de bits de fondo de baja resolución.

  • Un mapa de bits de fondo para la pantalla de ejecución automática del CD-ROM (si crea un paquete en CD-ROM).

    Si piensa distribuir el explorador personalizado en un disco compacto, tendrá que crear mapas de bits para la pantalla inicial de ejecución automática que aparece cuando el usuario inserta el disco compacto. Para crear este mapa de bits, consulte la sección Crear un mapa de bits para la pantalla inicial de ejecución automática.

  • Una imagen personalizada para los botones del CD-ROM (si crea un paquete en CD-ROM).
  • Dos mapas de bits personalizados para el Asistente para la instalación de Windows Update (si desea personalizar su apariencia): un mapa de bits de 162 por 312 píxeles para el lado izquierdo de la primera pantalla del asistente y un mapa de bits de 496 por 56 píxeles para la parte superior de las restantes pantallas del asistente.
  • Un mapa de bits personalizado de barra de herramientas (que se muestra como fondo de los botones y menús).
  • Dos imágenes de mapa de bits estáticas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo.
  • Dos imágenes de mapa de bits animadas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo animado.

    El IEAK contiene dos herramientas que le ayudan a crear y obtener vistas previas de los mapas de bits animados personalizados para el explorador.

Recopilar las direcciones URL de las páginas Principal, Búsqueda y Soporte.

Es conveniente crear una página de soporte que aparezca si los usuarios tienen problemas al instalar el explorador. Se le pedirán las direcciones URL de esas páginas cuando ejecute el Asistente para personalizar Internet Explorer 6.

Nota

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.


ISP: opciones de suscripción a Internet

titular

Opciones de suscripción a Internet

Los servidores de suscripción a Internet (ISS) automatizan la tarea de agregar nuevos clientes a la base de datos de clientes de un proveedor de servicios Internet (ISP, Internet Service Provider). El servidor de suscripción a Internet recopila información de cada nuevo cliente, la agrega a la base de datos de clientes del ISP y, después, devuelve al equipo del cliente un paquete de configuración. El paquete de configuración contiene la información utilizada para configurar el explorador de Internet del cliente para las conexiones siguientes a los servicios del proveedor de servicios Internet.

Para agregar un cliente nuevo a la base de datos del ISP, el servidor de suscripción a Internet:

  • Hace que el equipo cliente establezca una conexión HTTP con el servidor de suscripción.
  • Recopila la información de suscripción del cliente.
  • Controla la aceptación o el rechazo por parte del cliente de los servicios del ISP.

Al utilizar el IEAK, hay tres opciones de suscripción a Internet disponibles:

  • Suscripción con servidor mediante el Asistente para la conexión a Internet (ICW)
  • Suscripción con servidor mediante el explorador en modo a pantalla completa
  • Suscripción sin servidor

El sistema más aconsejable es la suscripción con servidor, a menos que no se pueda proporcionar un servidor de suscripción, ya que es más sencillo cambiar la configuración en el servidor que en el cliente. De las dos opciones con servidor, se recomienda el método con ICW, ya que utiliza una interfaz de asistente estándar que puede personalizarse de modo que satisfaga las necesidades de una organización. Si es proveedor de servicios Internet, puede especificar el ICW como la herramienta que utilizarán los usuarios para suscribirse a los servicios Internet y configurar sus equipos.

Importante

  • En caso de que use un disco único con marca personalizada, no utilice el mecanismo de suscripción del ICW si prevé que alguno de los usuarios tiene instalado Internet Explorer 4.01 Service Pack 1 (o versiones anteriores); en lugar de ello, para dichos usuarios cree un paquete independiente mediante la suscripción en el modo a pantalla completa.

Código de ejemplo del Kit de herramientas del IEAK

Las soluciones personalizables para la suscripción a Internet se encuentran en el Kit de herramientas de IEAK. El código se proporciona en páginas Active Server (ASP) así como en formato Perl, lo que permite generar un proceso de suscripción con ICW para servidores Web en plataformas diferentes con el mínimo esfuerzo. Si utiliza el código de ejemplo, lo único que tendrá que hacer es integrar el servidor de suscripción con sus sistemas de registro y facturación. Si está participando en el programa Windows Referral Server Program, el código del servidor de suscripción es similar para los registros de suscripciones con IEAK y Referral Server.

Nota

  • Puesto que la solución del IEAK incluye varios archivos de suscripción a Internet (.isp) para diferentes tipos de usuarios, también debe incluir el componente Enlace de datos de HTML dinámico en el paquete personalizado.

Crear varias versiones personalizadas de Internet Explorer

Si está creando varias versiones personalizadas de Internet Explorer y hay configuraciones que permanecerán invariables en la misma o en todas las versiones, puede simplificar el proceso. Para obtener más información, consulte Crear varias versiones del explorador.


ISP: Implementar un paquete de suscripción con servidor

titular

Implementar un proceso de suscripción con servidor

El proceso de suscripción con servidor automatiza las tareas de registro y configuración para usuarios nuevos y existentes. En este proceso se emplea un servidor de suscripción a Internet (ISS) para recopilar la información de cada usuario. El servidor de suscripción agrega los datos a la base de datos de clientes y, después, devuelve al equipo del usuario un paquete de configuración. Este paquete configura el explorador para conexiones posteriores a los servicios Internet.

Los ISP disponen de los siguientes métodos de suscripción con servidor:

  • Asistente para la conexión a Internet (ICW): mediante el Asistente para personalizar Internet Explorer 6, puede especificar el ICW como herramienta que utilizarán los usuarios para suscribirse y configurar sus equipos para los servicios Internet. Es el método recomendado, ya que utiliza una interfaz de asistente estándar que puede personalizarse de modo que cumpla las necesidades de la organización y los usuarios. La característica configuración automática de ICW también permite establecer la configuración para aquellos usuarios que ya disponen de cuentas de Internet.
  • Modo a pantalla completa: mediante el Asistente para personalizar Internet Explorer 6, puede especificar que las pantallas del proceso de suscripción creadas se muestren en toda la pantalla.

Nota

  • Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.

Crear un paquete personalizado con un método de suscripción con servidor

Para crear un paquete de explorador personalizado que incluya un método de suscripción con servidor, especifique lo siguiente en la Fase 4 del Asistente para personalizar Internet Explorer 6:

  • Suscripción con servidor mediante el Asistente para la conexión a Internet o Suscripción con servidor mediante el modo a pantalla completa como método de suscripción.
  • La ruta de acceso de la carpeta de trabajo que contiene los archivos de suscripción personalizados. Estos archivos permiten a los usuarios configurar sus equipos para conectarse al servidor de suscripción.
  • La información del servidor de suscripción, incluidos los parámetros de acceso telefónico a redes que permiten a los usuarios conectarse con el servidor de suscripción y la dirección URL de la primera página de suscripción en línea.
  • La información de personalización de ICW, incluida la barra de título y las imágenes personalizadas (si ha seleccionado Suscripción basada en servidor mediante el Asistente para la conexión a Internet).

Para garantizar que el paquete se instala correctamente, la carpeta que contiene los archivos de suscripción personalizados debe incluir los siguientes elementos:

  • Signup.htm. Esta página HTML proporciona información relativa a los servicios Internet y debe incluir un vínculo a una página HTML apropiada en el servidor de suscripción. Es posible personalizar el archivo Signup.htm de ejemplo, que se encuentra en la carpeta de IEAK \Reskit\ISP\Server\Client. Por ejemplo, puede agregar información de soporte técnico o incluir vínculos a los archivos de suscripción a Internet (.isp).
  • Signup.isp. Este archivo de suscripción a Internet (al que se hace referencia en el archivo Signup.htm) se utiliza para marcar el servidor de suscripción. También debe contener un vínculo a la dirección URL de la secuencia de comandos del servidor que genera los archivos de configuración de Internet (.ins). Mediante el Asistente para personalizar Internet Explorer 6, puede modificar los parámetros contenidos en este archivo de suscripción. El Asistente para personalizar Internet Explorer 6 también genera otros archivos .isp para el proceso de suscripción.
  • Todos los demás archivos de suscripción. Todos los archivos relacionados, incluidos los archivos gráficos .gif y .jpg, deben guardarse en la misma carpeta que los archivos de suscripción personalizados. Por ejemplo, puede ser aconsejable incluir sus propias versiones personalizadas del archivo Install.gif.

Distribuir un paquete personalizado con un método de suscripción con servidor

Si utiliza un método de suscripción con servidor, el proceso de suscripción del paquete del explorador personalizado se realiza en tres pasos:

  1. El equipo del usuario establece una conexión con el servidor de suscripción.
  2. Un cuadro de diálogo basado en HTML y HTTP recopila información del usuario y la agrega a la información de la base de datos de clientes.
  3. El servidor de suscripción envía un paquete de configuración al equipo del cliente. Este paquete incluye información acerca de la configuración y marca. También incluye el número de teléfono local para que el cliente pueda tener acceso al proveedor de servicios Internet.

    4. Tenga en cuenta que si el nivel de seguridad del usuario está establecido como alto, el servidor de suscripción no funciona ya que los archivos necesarios no se descargan en el equipo del usuario.

Establecer una conexión con el servidor de suscripción

El usuario abre el programa de suscripción, que inicia Microsoft Internet Explorer, marca el servidor de suscripción y publica una solicitud de conexión inicial. A continuación, el servidor de suscripción realiza las siguientes acciones:

  • Acepta la solicitud procedente del equipo del usuario (el cliente HTTP) y establece una conexión HTTP.
  • Crea un almacenamiento local de datos para acumular toda la información que escriba el usuario.
  • Le asigna un identificador exclusivo de sesión que se incrustará en todas las sucesivas transacciones HTTP con ese cliente.

HTTP es un protocolo sin sesión; sin embargo, el servidor de suscripción opera en un modo orientado a la sesión y utiliza el identificador de sesión para identificar todas las transacciones asociadas con el proceso de suscripción de un usuario determinado. Por ejemplo, el identificador de sesión puede ser un número secuencial generado automáticamente y asignado a esta transacción por la base de datos.

Recopilar la información de suscripción del usuario

El servidor de suscripción recopila la información del usuario desde una secuencia de páginas HTML que guía al usuario a través del proceso de suscripción, de forma parecida a como lo hace el asistente de un programa para Windows. El servidor de suscripción carga las páginas, a petición, en el equipo del cliente. El proceso de suscripción concluye cuando el usuario hace clic en el botón apropiado en la página HTML final para aceptar o rechazar el contrato de suscripción.

Puede elegir un contenido y formato propio para las páginas HTML. Por lo general, todas las páginas HTML incluyen los siguientes elementos:

  • Un formulario que debe rellenar el usuario.
  • Botones de exploración en los que el usuario puede hacer clic si desea desplazarse hacia adelante y hacia atrás en las páginas.
  • Un botón en el que el usuario puede hacer clic si desea cancelar la sesión de suscripción.

Cada formulario HTML incluye controles para recopilar texto escrito, desplazarse por las páginas e identificar la sesión. El formulario recopila información del usuario y la transfiere al servidor de suscripción cuando el usuario hace clic en un botón de exploración. Además, el servidor de suscripción puede validar los datos y publicar una página de edición en el equipo del usuario en caso de que la información no sea aceptable.

Nota

  • Asegúrese de guardar el archivo HTML en la carpeta correcta del servidor de suscripción; el archivo Signup.isp incluye un vínculo a los archivos del servidor para las versiones de Windows de 32 bits y el archivo Signup.htm incluye un vínculo para las versiones de Windows de 16 bits.

Devolver un paquete de configuración al equipo del usuario

Si el usuario acepta el contrato de suscripción, el servidor de suscripción crea un paquete de configuración con un archivo .ins (generado por el Asistente para configurar Internet Explorer 6) que incluye información relativa al usuario y los servicios Internet. El archivo .ins únicamente puede contener la configuración de conexión, o bien configuraciones de conexión, explorador y correo que incluyan gráficos.

El servidor de suscripción devuelve el paquete de configuración al equipo del usuario mediante el archivo .ins, que puede generarse de forma inmediata o simplemente redirigirse al equipo del cliente. A continuación, el equipo del usuario puede continuar el proceso de instalación del paquete del explorador personalizado. En caso de que el usuario rechace o salga del contrato de suscripción, el servidor de suscripción redirige el equipo del usuario a un archivo que cancela el proceso de suscripción.

El paquete de configuración incluye la siguiente información:

  • Datos para configurar las conexiones a Internet
  • Funciones de la cuenta del usuario (incluido correo electrónico y lectores de noticias)
  • Información de marca, que personaliza la apariencia de las páginas de suscripción de la organización.
  • El número de teléfono local para que el usuario pueda tener acceso a los servicios Internet.

Los primeros dos tipos de datos se crean como parte del servidor de suscripción. El Asistente para personalizar Internet Explorer 6 prepara el archivo .ins para marcarlo. Algunas opciones de configuración, como Entrada, Usuario, Teléfono, Dispositivo, Servidor y TCP/IP, no pueden especificarse en el asistente; deberá asignarlas manualmente en el archivo .ins.

Si desea proporcionar varias versiones personalizadas "con marca privada" de Internet Explorer para grupos de usuarios diferentes, puede mantener varios conjuntos de información de marca que el servidor de suscripción descargará en el archivo .ins. Por ejemplo, quizás desee personalizar versiones con diferentes logotipos, barras de título, favoritos, páginas de búsqueda, páginas de inicio, vínculos especiales o ubicaciones para la asistencia en línea. Todos los discos compactos que distribuya a los usuarios serán iguales, pero se marcarán de una forma diferente cuando los usuarios se suscriban a los servicios Internet.

Consideraciones del servidor de suscripción para Servicios de Internet Information Server

Si utiliza Servicios de Internet Information Server (IIS) como servidor de suscripción, debe configurar el servidor de suscripción a Internet de modo que suministre una dirección IP DHCP al cliente cuando éste se conecte al servidor. Como el proceso de suscripción es relativamente corto, el tiempo de caducidad de la concesión de la dirección IP puede ser corto, posiblemente de unos pocos minutos.

El proceso de suscripción se ha diseñado para que se utilice en una conexión punto a punto, por lo que las direcciones IP asignadas al servidor DHCP no necesitan ser direcciones IP asignadas oficialmente. Es responsabilidad suya determinar si las direcciones IP de DHCP serán direcciones válidas de Internet o direcciones arbitrarias.

Registrar el tipo MIME del archivo .ins

Para que el cliente procese automáticamente el archivo .ins, debe registrar el tipo MIME para el archivo .ins con el servidor de suscripción. Se ha designado el tipo MIME "application/x-Internet-signup". Cuando el cliente solicita un archivo .ins, el servidor de suscripción responde con este tipo MIME, que inicia la aplicación de instalación asociada en el cliente.

Debe modificar manualmente los tipos MIME en el Registro. Para agregar el tipo MIME del archivo .ins, utilice regedit.exe para agregar la información siguiente:

En esta clave:
HKEY_LOCAL_MACHINE\system32\CurrentControlSet\Services\InetInfo\Parameters\MimeMap

Agregue este valor:
application/x-internet-signup,ins,,5

Este valor no tiene asociada ninguna cadena. Para obtener más detalles acerca de cómo configurar los tipos MIME, también puede consultar la Ayuda de IIS.

Nota

  • Para que la configuración del Registro surta efecto, es necesario apagar todos los servicios de IIS tras agregar el nuevo tipo MIME. No basta con detener y reiniciar el servicio de publicación en Web. (En la práctica, no es probable que los servicios FTP y Gopher se ejecuten en la configuración del servidor de suscripción.)


ISP: Configurar un servidor de suscripción en modo a pantalla completa

titular

Configurar un servidor de suscripción en modo a pantalla completa

Un servidor de suscripción a Internet (ISS, Internet Sign-up Server) es un servidor de Protocolo de transferencia de hipertexto (HTTP) que automatiza la tarea de agregar clientes nuevos a la base de datos de clientes de un proveedor de servicios Internet ISP). El ISS recopila información de cada cliente nuevo, la agrega a la base de datos de clientes del ISP y, después, devuelve los datos al equipo del cliente. El paquete de información configura el explorador de Internet del cliente para que use los servicios del ISP.

Nota

  • Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.

Para agregar un cliente nuevo a la base de datos del ISP

Para agregar un cliente nuevo a la base de datos del ISP, el ISS:

  1. Establece una conexión HTTP con el equipo de escritorio del cliente.
  2. Recopila la información de suscripción del cliente.
  3. Controla la aceptación o el rechazo por parte del cliente de los servicios del ISP.

Para controlar estas tareas, puede adaptar el ejemplo de código de suscripción a Internet mediante el Asistente para la conexión a Internet. Dicho código se encuentra en el Kit de herramientas de IEAK, en la carpeta \<carpeta de programa IEAK>\Toolkit\ISP\Server\ICW\ y sus subcarpetas.

En los temas siguientes se describe cómo desarrollar un proceso de suscripción para el Asistente para la conexión a Internet. Aunque estos temas describen un proceso de suscripción completo y probado, recomendado para la mayor parte de los casos, puede personalizarlo para que se adapte a las necesidades de su organización.

  • Suscribirse a Internet con el Asistente para la conexión a Internet
  • Requisitos de código para las pantallas del Asistente para la conexión a Internet
  • Trabajar con los archivos de suscripción de ejemplo del ICW
  • Crear el archivo Icwsign.htm, las páginas de error y la página de finalización para suscripciones con el ICW
  • Crear las pantallas de suscripción del ICW


Suscribirse a Internet con el Asistente para la conexión a Internet

Si es proveedor de servicios Internet, puede definir el Asistente para la conexión a Internet (ICW, Internet Connection Wizard) como herramienta que utilizarán los usuarios para suscribirse y configurar sus equipos con el fin de usar los servicios Internet. Puede crear soluciones que utilicen un servidor para intercambiar información con las pantallas del ICW. Esta característica no está disponible para el método de suscripción sin servidor.

Las soluciones personalizables para la suscripción a Internet se encuentran en el Kit de herramientas de IEAK, en la carpeta \<carpeta de programa IEAK>\Toolkit\ISP\Server\ICW\ y sus subcarpetas. El código se proporciona en páginas Active Server así como en formato Perl, lo que permite generar un servidor de suscripción ICW para servidores Web en plataformas diferentes con el mínimo esfuerzo. Si utiliza el código de ejemplo, lo único que tendrá que hacer es integrar el servidor de suscripción con sus sistemas de registro y facturación.

Notas

  • Si está participando en el programa Windows Referral Server Program, el código del servidor de suscripción es similar para los registros de suscripciones con IEAK y Referral Server.
  • Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.

En los temas siguientes se describe cómo desarrollar un proceso de suscripción para el Asistente para la conexión a Internet. Aunque estos temas describen un proceso de suscripción completo y probado, que se recomienda para la mayor parte de los casos, puede personalizarlo para que se adapte a las necesidades de su organización.

  • Requisitos de código para las pantallas del Asistente para la conexión a Internet
  • Trabajar con los archivos de suscripción de ejemplo del ICW
  • Crear el archivo Icwsign.htm, las páginas de error y la página de finalización para suscripciones con el ICW
  • Crear las pantallas de suscripción del ICW
  • Utilizar la configuración automática del ICW para suscripciones a ISP

Importante

  • En caso de que use un disco único con marca personalizada, no utilice el mecanismo de suscripción del Asistente para la conexión a Internet si prevé que alguno de los usuarios tenga instalado Internet Explorer 4.01 Service Pack 1 o versiones anteriores; en lugar de ello, para dichos usuarios cree un paquete independiente mediante la suscripción en el modo a pantalla completa.


Trabajar con los archivos de suscripción de ejemplo del Asistente para la conexión a Internet

Si desea simular el proceso de suscripción antes de crear sus archivos, puede utilizar los archivos de ejemplo del kit de herramientas del IEAK, en la carpeta \<carpeta de programa IEAK>\Toolkit\ISP\Server\ICW\. Los archivos de ejemplo pueden ofrecerle una idea general del funcionamiento del proceso de suscripción y el tipo de información que tendrá que proporcionar.

Para usar archivos de ejemplo con el fin de simular el proceso de suscripción

  1. Cree un directorio denominado Signup en el directorio wwwroot de su servidor.
  2. Copie los archivos del kit de herramientas del IEAK al directorio Signup.
  3. En los archivos, cambie todas las referencias para que señalen a su servidor de suscripción.
  4. En el código HTML de las páginas del servidor de suscripción, cambie todas las referencias a Acme ISP por el nombre de su organización.
  5. Modifique la última página del servidor de suscripción para que refleje la configuración del archivo .ins.


Requisitos de código y accesibilidad para suscripciones con el Asistente para la conexión a Internet

titular

Requisitos de código para las pantallas del Asistente para la conexión a Internet

El mecanismo de suscripción del Asistente para la conexión a Internet (ICW) en el IEAK se basa en la idea de que un servidor de suscripción de Internet debería parecerse a un asistente normal de Windows y actuar como tal. Aunque el ICW hace uso de la flexibilidad y eficacia del Lenguaje de marcado de hipertexto (HTML), no utiliza el mismo formato.

Las páginas HTML del ICW usan los colores y las fuentes del sistema de Windows y también deben cumplir unos requisitos de accesibilidad. A menos que se especifique lo contrario, las páginas HTML del asistente no pueden contener formato especial de HTML como tablas con bordes visibles, imágenes o marcadores. Sólo se permite texto sin formato y elementos de formulario, cuando se necesitan. Las tablas con bordes invisibles se pueden usar como elementos de diseño.

Para coincidir con los colores del sistema del usuario, ninguna página HTML, excepto Icwsign.htm, debe tener atributos de fuente o color a menos que se especifique lo contrario. El asistente principal define los colores o estilos de fuente para que coincidan con los del sistema del usuario.

El único requisito para implementar formularios dentro de páginas HTML es que usen los parámetros NAME en los elementos <FORM> definidos en la especificación. Puede especificar todos los nombres de testigo para el resto de los elementos de sus páginas HTML. Estos elementos se enviarán al servidor de suscripción.

Funcionalidad de los botones Atrás y Siguiente

La suscripción con el ICW tiene requisitos específicos que se deben cumplir para que los botones Atrás y Siguiente del Asistente para la conexión a Internet funcionen correctamente.

El ejemplo de código de servidor de suscripción incluido en el IEAK ya cumple estos requisitos.

Botón Atrás

Para que el botón Atrás funcione adecuadamente, debe agregar un elemento FORM a la página del servidor de suscripción que especifica la dirección URL del botón Atrás. Para mantener los datos que se han recopilado previamente en el proceso de suscripción, debe anexar todos los datos que desee retener a la dirección URL usada para el botón Atrás.

El siguiente es el elemento FORM necesario para que el botón Atrás envíe al usuario a la página anterior del proceso de suscripción. Tenga en cuenta que los datos se anexan a la dirección URL en forma de par nombre-valor:

<FORM NAME="BACK"
 ACTION="http://myserver/page2.asp"?firstname=bob&lastname=smith&address=...">
</FORM>

Nota

  • El elemento NAME y su valor deben estar en mayúsculas porque el ICW distingue mayúsculas y minúsculas.

Botón Siguiente

Para que el botón Siguiente funcione adecuadamente, debe agregar un elemento FORM a la página del servidor de suscripción que especifica la dirección URL del botón Siguiente. Para que los datos recopilados se pasen a la página siguiente en el proceso de suscripción, debe agregar campos de formulario ocultos en cada una de las páginas del servidor de suscripción que contengan los elementos de datos recopilados en ésta y en todas las ventanas anteriores. La dirección URL a la que hace referencia debe contener código que recopile los datos de la página anterior y muestre la página siguiente del proceso de suscripción.

El siguiente es el elemento FORM necesario para que el botón Siguiente envíe al usuario a la página siguiente del proceso de suscripción:

<FORM NAME="NEXT"
 ACTION="http://myserver/page2.asp">
</FORM>

Requisitos de accesibilidad

Para asegurar que los elementos de la página son accesibles sólo mediante la utilización del teclado, cada elemento de formulario debe cumplir los requisitos siguientes:

  • Debe haber una tecla de acceso asociada al elemento de formulario. Use el parámetro ACCESSKEY= de Internet Explorer en la etiqueta <INPUT>. El carácter de la tecla de acceso se debe subrayar para resaltarla mediante la etiqueta <U>. Las letras b, f, g, n y o se reservan para el ICW y no se pueden usar como teclas de acceso. Para obtener más información acerca del parámetro ACCESSKEY, consulte el sitio MSDN Online Web Workshop.
  • Cada elemento de la página debe formar parte del orden de la tecla TAB del ICW (orden de tabulación). Para incluir el elemento en el orden de tabulación del ICW, debe tener un identificador exclusivo en la etiqueta <INPUT>.
  • Cada uno de los elementos debe tener una etiqueta asociada. Para asociar una etiqueta a cada tipo de entrada de formulario HTML, use el parámetro LABEL= de Internet Explorer.

Ejemplo

El siguiente elemento de formulario (un botón de opción) cumple los requisitos de accesibilidad del ICW:

<INPUT ID="opción2"
 TYPE="radio"
 NAME="facturación"
 VALUE="hora"
 ACCESSKEY="h"
 CHECKED
>
<LABEL for="opción2">
 5 <U>H</U>oras mensuales por 10 dólares.
</LABEL>

Requisitos de diseño y HTML

Las páginas del Asistente para la conexión a Internet deben tener los elementos de diseño siguientes y cumplir las convenciones de diseño que se indican a continuación.

Importante

  • Sólo se permiten elementos de formulario HTML y texto. No están permitidas las imágenes, hipervínculos ni barras de desplazamiento.

Hoja de estilo

No especifique atributos de color o estilo de fuente. El asistente principal establece estos atributos. Si utiliza una etiqueta <TABLE> en las páginas de error, la etiqueta debe incluir el estilo siguiente:

<TABLE style="font: 8pt 'ms sans serif' buttontext"> </TABLE>

Elementos de formulario obligatorios

Esta página debe incluir cuatro elementos <FORM> HTML para especificar propiedades de página diferentes:

Elemento | Requisitos
Un identificador de página PAGEID exclusivo para la página | El nombre (NAME) del formulario debe ser "PAGEID" y se distinguen mayúsculas y minúsculas. El atributo ACTION del formulario debe ser un identificador exclusivo que no coincida con el identificador PAGEID de ninguna otra página de la sección ISP del asistente; por ejemplo, <FORM NAME="PAGEID" ACTION="pagina4"></FORM>.
La función del botón Atrás | El nombre (NAME) del formulario debe ser "BACK" y se distinguen mayúsculas y minúsculas. El atributo ACTION de este formulario debe ser la dirección URL absoluta de la página anterior (por ejemplo, ACTION="HTTP://signup/bin/page1.cgi"); sin embargo, no se enviará ningún dato a esta página.
Características de la página | El formulario se identifica con el nombre (NAME) "PAGETYPE" y se distinguen mayúsculas y minúsculas. Debido a que éste es un marco estándar donde el ISP define todo el espacio, el atributo ACTION del formulario debe ser una cadena vacía; por ejemplo, ACTION="".
La función del botón Siguiente | El nombre (NAME) del formulario debe ser "NEXT" y se distinguen mayúsculas y minúsculas. Éste es el formulario que contiene los elementos reales que se enviarán de vuelta al servidor de suscripción del ISP. No hay restricciones en los nombres de testigo para los elementos <INPUT> dentro del formulario. El atributo ACTION del formulario debe ser la dirección URL absoluta donde la información del formulario debe ser enviada. La dirección URL que se exponga en el servidor debe contener una secuencia de comandos que reciba los datos y muestre, a continuación, la siguiente página HTML del asistente.


Utilizar la configuración automática del Asistente para la conexión a Internet para suscribirse a un ISP

Cuando los usuarios compran un equipo nuevo, la configuración automática de ICW les ayuda a configurarlo para usar la misma cuenta de Internet que tenían en el equipo anterior o en un equipo del trabajo. También resulta de utilidad para los usuarios cuya configuración de Internet se haya dañado. La característica de configuración automática restaura sus opciones de configuración de los usuarios; el usuario sólo necesita conocer su identificador de usuario, contraseña y servidor POP.

En una versión personalizada de Internet Explorer, el usuario tiene acceso al servidor de configuración automática del disco compacto de Internet Explorer al hacer clic en un vínculo de la página Icwsign.htm. Este vínculo conecta al usuario con el servidor de registro de configuración automática. Una vez que el usuario se conecta al servidor de suscripción, éste puede preguntarle el nombre de usuario, la contraseña y el servidor POP. Con esta información puede enviar un archivo .ins al equipo del usuario para volver a configurar su cuenta.

Dos métodos para permitir la configuración automática del ICW

Hay dos modelos que puede usar para restaurar las cuentas de usuario mediante la configuración automática:

  • Preguntar al usuario su nombre, contraseña y servidor POP. Esta información debería ser suficiente para volver a crear el archivo .ins, enviarlo al usuario y volver a configurar la cuenta. Si le preocupa que se pueda usar fraudulentamente esta opción, podría solicitar el número de la tarjeta de crédito del usuario y realizar una comprobación en la base de datos de registro.
  • Almacenar los archivos .ins con el resto de la información de la cuenta del usuario. Cuando un usuario se conecta al servidor de configuración automática, puede obtener el archivo .ins al proporcionar el nombre de usuario y la contraseña. El servidor de configuración automática buscaría entonces la cuenta del usuario y le entregaría una copia del archivo .ins original del usuario. Como con el primer modelo, si le preocupa que se pueda usar fraudulentamente esta opción, podría solicitar el número de la tarjeta de crédito del usuario y realizar una comprobación en la base de datos de registro.

Para instalar la configuración automática del ICW

  • Siga las instrucciones que se indican en Requisitos de código para las pantallas del Asistente para la conexión a Internet y diseñe la página de correo electrónico o de inicio de sesión de la cuenta del ISP, la página de selección de POP del ISP y la página de finalización del ISP.


ISP: Implementar un paquete de suscripción sin servidor

titular

Implementar un paquete de suscripción sin servidor

El proceso de suscripción sin servidor permite a los usuarios instalar el explorador Microsoft Internet Explorer personalizado mediante disco compacto, disquetes o archivos descargables. El proceso de instalación requiere que los usuarios escriban sólo su nombre de usuario, la contraseña e información de su conexión para configurar una cuenta y conectarse a Internet mediante el explorador personalizado. Los proveedores de servicios Internet pueden personalizar la configuración del usuario sin utilizar un servidor de suscripción. Dado que la información de configuración se distribuye con el paquete IEAK y, por lo tanto, está disponible localmente en el equipo del usuario, el proceso no es tan dinámico como una suscripción con servidor.

No puede utilizar el método de suscripción sin servidor para personalizar el Asistente para la conexión a Internet.

Crear un paquete personalizado con un método de suscripción sin servidor

Para crear un paquete del explorador personalizado que incluya un método de suscripción sin servidor, especifique lo siguiente en el paso 4 del Asistente para personalizar Internet Explorer 6:

  • Suscripción sin servidor como método de suscripción.
  • La ruta de acceso de la carpeta que contiene los archivos de suscripción personalizados. Estos archivos permiten a los usuarios configurar sus equipos para los servicios Internet.
  • Los parámetros de acceso telefónico a redes que permiten a los usuarios establecer una conexión para obtener los servicios Internet.

Para garantizar que el paquete se instala correctamente, la carpeta que contiene los archivos de suscripción personalizados debe incluir los siguientes elementos:

  • Signup.htm. Esta página HTML proporciona información referente a los servicios Internet y debe incluir un vínculo al archivo .ins, que contiene las opciones de configuración del paquete del explorador personalizado.
  • Todos los demás archivos de suscripción. Todos los archivos relacionados, incluidos los archivos gráficos .gif y .jpg, deben guardarse en la misma carpeta que los archivos de suscripción personalizados. Por ejemplo, podría incluir sus propias versiones personalizadas del archivo Install.gif y Logohere.gif.

Distribuir un paquete personalizado con un método de suscripción sin servidor

El paquete personalizado incluye un archivo de configuración, llamado Install.ins, que contiene la configuración especificada para el explorador personalizado. Al contrario que en el método con servidor de suscripción Internet, este archivo .ins no contiene información de configuración específica del usuario. Cuando el usuario inicia el programa de suscripción, un vínculo de la página HTML local ejecuta el archivo .ins. El usuario proporciona su nombre de usuario, contraseña e información de conexión. A continuación, el archivo .ins configura la cuenta del usuario para conectarse a Internet mediante el explorador personalizado.

Desventajas del uso del proceso de suscripción sin servidor

Dado que el archivo de configuración se distribuye con el paquete IEAK, no puede cambiar dinámicamente las opciones de configuración de usuario en el servidor de suscripción.

El servidor de suscripción normal obtiene la información acerca de un usuario y después prepara un archivo de configuración personalizado que se descarga en el equipo del usuario. El software del paquete de instalación de Internet Explorer utiliza el archivo de configuración para configurar el equipo.

En la versión sin servidor, se crea el archivo de configuración antes de distribuir el paquete y se incluye en el paquete de instalación. Por lo tanto, el archivo de configuración no contiene información de configuración específica del usuario. La llamada al archivo de configuración, Install.ins, se realiza como vínculo desde la página HTML local y configura la mayor parte de las opciones de Internet Explorer. Dado que el archivo de configuración se incluye en el paquete de instalación, se almacena localmente en el equipo del usuario.

Para compensar esta desventaja, la opción avanzada del proceso de suscripción sin servidor emplea un control ActiveX (installx.exe), que permite generar un archivo .ins para incorporar la información del usuario. Internet Explorer utilizará después el archivo generado por el control ActiveX para definir la configuración del usuario.


ISP: Fase 1 del asistente: recopilar información

titular

Fase 1 del asistente: recopilar información

En la primera fase del Asistente para personalizar Internet Explorer 6, los proveedores de servicios Internet (ISP) deben proporcionar la información siguiente:

  • La ubicación de los archivos necesarios para crear el paquete personalizado del explorador.
  • El idioma del paquete del explorador que se está creando. Necesitarán ejecutar el Asistente para personalizar Internet Explorer 6 por cada versión internacional que deseen crear.
  • El medio de distribución que vayan a utilizar, como CD-ROM o descarga.
  • Las características que van a personalizar. Por ejemplo, si sólo van a hacer pequeñas modificaciones al explorador, no tendrán que pasar por todas las pantallas del Asistente para IEAK.

Nota

  • El Asistente para personalizar Internet Explorer 6 no funcionará correctamente si no está instalado Microsoft Internet Explorer 6. Para obtener más información, consulte Requisitos de hardware y del sistema.


ISP: Fase 2 del asistente: especificar los parámetros de instalación

titular

Fase 2 del asistente: especificar los parámetros de instalación

En este paso del Asistente para personalizar Internet Explorer, como proveedor de servicios Internet debe:

  • Descargar o actualizar componentes de Microsoft mediante el sistema automático de sincronización de versiones. Es preciso descargar Internet Explorer, pero puede elegir los demás componentes de Internet Explorer que se descargarán.
  • Seleccionar los componentes personalizados que desea incluir.

    También puede especificar hasta 16 componentes adicionales, que pueden ser archivos ejecutables autoextraíbles (.exe) o archivos contenedores (.cab) comprimidos.


ISP: Fase 3 del asistente: personalizar la instalación

titular

Fase 3 del asistente: personalizar la instalación

En esta fase del Asistente para personalizar Internet Explorer 6, si desea determinar la apariencia y el funcionamiento del programa de instalación de Windows Update, como proveedor de servicios Internet puede:

  • Personalizar la pantalla de ejecución automática del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalizar otras opciones del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalizar el Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet. Estas opciones de configuración afectan a la apariencia del programa de instalación.
  • Especificar hasta diez opciones de instalación y determinar los componentes que incluirá en cada opción.
  • Especificar hasta diez sitios desde los que se puede descargar el paquete.
  • Especificar de qué forma recibirán los usuarios las actualizaciones de los componentes.
  • Especificar si el programa de instalación debe detectar si existe un componente dado y determinar con precisión qué componentes pueden personalizar los usuarios.
  • Determinar si los componentes que se han descargado pero no se han incluido en todos los paquetes deben ponerse a disposición de los usuarios mediante la característica de instalación a petición de Internet Explorer.
  • Importar un perfil personalizado desde el Kit de administración del Administrador de conexión.
  • Especificar los datos de la entidad emisora de certificados para que, si tiene un certificado digital, pueda firmar los programas al crear el paquete IEAK.

Notas

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.
  • Si desea ver un organigrama de lo que ocurre al usar el Asistente para personalizar Internet Explorer 6 para crear un paquete personalizado, consulte Cómo genera IEAK los paquetes personalizados.


ISP: Fase 4 del asistente: personalizar el explorador

titular

Fase 4 del asistente: personalizar el explorador

En esta fase del Asistente para personalizar Internet Explorer 6, un proveedor de servicios Internet puede personalizar lo siguiente:

  • La barra de título del explorador. El título del explorador personalizado aparece en Internet Explorer y en Outlook Express, tanto si se ha distribuido con el paquete como si ya está instalado en el equipo del usuario.
  • El fondo y los botones de la barra de herramientas del explorador. Puede agregar botones personalizados a la barra de herramientas para ejecutar secuencias de comandos y programas.
  • El logotipo de Internet Explorer de la esquina superior derecha del explorador.
  • Las páginas principal, de búsqueda y de soporte en línea del explorador.
  • Los favoritos, las carpetas de favoritos y los vínculos de la barra de vínculos.
  • La página de bienvenida, que ven los usuarios cuando inician el explorador por primera vez.
  • La cadena de agente del usuario. El identificador del agente del usuario es opcional. Es una forma de realizar un seguimiento del uso de su explorador personalizado.
  • La configuración de la conexión del usuario al personalizar, importar o eliminar la configuración existente del usuario.
  • La configuración de proxy.
  • El certificado raíz.
  • El método de suscripción del usuario.
  • Los archivos de suscripción. Puede especificar la ruta de acceso de la carpeta que contiene los archivos de suscripción y especificar si desea modificarlos.
  • Los parámetros de la conexión de acceso telefónico a redes y archivos de configuración de Internet que utilizarán los clientes para conectarse a su servidor de suscripción a Internet.
  • La configuración del Asistente para la conexión a Internet, si sus usuarios van a utilizar el asistente para suscribirse a sus servicios.

Nota

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.


ISP: Fase 5 del asistente: personalizar componentes

titular

Proveedor de servicios Internet

Fase 5 del asistente: personalizar componentes

En esta fase del Asistente para personalizar Internet Explorer 6, un proveedor de servicios Internet puede personalizar lo siguiente:

  • La configuración predeterminada del programa, como los programas específicos que se utilizarán para leer correo electrónico o modificar HTML.
  • Los servidores de correo y noticias de los usuarios, si va a incluir Outlook Express en el paquete personalizado.
  • La configuración del servidor de correo electrónico IMAP para los usuarios, en el caso de que vaya a implementar Outlook Express y tenga un servidor IMAP .
  • El contenido personalizado de Outlook Express, al agregar su propio mensaje de correo electrónico para dar la bienvenida a los usuarios y personalizar el panel de información que aparece cuando los usuarios inician el programa.
  • La configuración personalizada de Outlook Express, por ejemplo, con la definición de clientes nuevos predeterminados de correo y de noticias, la asistencia a los usuarios que necesitan cuentas de correo adicionales y la creación de un archivo de reglas predeterminadas para los mensajes de los usuarios.
  • La configuración de la interfaz de usuario de Outlook Express, como decidir si se muestran la barra de carpetas, la lista de carpetas, la barra de estado o la barra de Outlook.
  • La configuración de redacción de Outlook Express, si desea definir una renuncia de responsabilidad corporativa o firma para incluirlas en los mensajes de correo electrónico o de grupos de noticias.
  • El servicio de directorio de la Libreta de direcciones de Windows, si desea ofrecer servicios de directorio de Internet a los usuarios y personalizar los servidores de Protocolo compacto de acceso a directorios (LDAP, Lightweight Directory Access Protocol).
  • Las directivas y la configuración del sistema, para preestablecer las opciones de Internet.


ISP: Distribuir su paquete del explorador

titular

Proveedor de servicios Internet

Distribuir su paquete del explorador

De forma predeterminada, el Asistente para personalizar Internet Explorer 6 crea archivos para descargar desde Internet. También puede distribuir un paquete de explorador personalizado en un CD-ROM. Para obtener una lista completa de todos los medios de distribución, consulte Selección del medio.

Archivos descargables

Los proveedores de servicios Internet (ISP) pueden distribuir un único archivo a los usuarios que contenga el motor de instalación, para descargar los componentes de la aplicación desde un servidor de Internet.

Si creó el paquete del explorador en un servidor de Internet, debe configurar su sitio Web para que los usuarios puedan descargar los archivos. Por ejemplo, puede crear una página en la que publique la información de descarga y un vínculo al motor de instalación, IE6setup.exe.

Si creó el paquete del explorador en un disco duro o en una unidad de red, deberá mover los elementos siguientes al servidor de Internet:

  • La carpeta que contiene la versión de idioma que está publicando y los contenidos de la carpeta. Por ejemplo, la carpeta de la versión en inglés se llama EN, por lo que debe mover la carpeta EN y los archivos que contiene. Esta carpeta se encuentra en las carpetas que correspondan al tipo de distribución, por ejemplo, Download (descarga), y plataforma. La única designación de plataforma del IEAK 6 es "Win32"; para clientes UNIX y Windows de 16 bits, use IEAK 5.x.
  • El archivo Ie6sites.dat. Este archivo señala el sitio (o sitios) de descarga que especificó al ejecutar el Asistente para personalizar Internet Explorer 6.

    Para ver un ejemplo, consulte Cómo configurar los archivos para distribución.

    Para ver un organigrama de los archivos que crea el Asistente para personalizar Internet Explorer 6, consulte Cómo genera IEAK paquetes personalizados.

Firmar los paquetes personalizados

Los exploradores Web tienen características de seguridad que ayudan a proteger a los usuarios frente a la descarga de programas perjudiciales. En función del nivel de seguridad y de la plataforma, se puede advertir al usuario o evitar que descargue programas que no estén firmados digitalmente.

Los archivos .cab personalizados creados con el Asistente para personalizar Internet Explorer 6 deben estar firmados, a menos que se haya configurado la zona local de la intranet con un nivel bajo de seguridad. Cualquier componente personalizado que distribuya con el paquete del explorador y vaya destinado a esas plataformas también debe estar firmado. Si dispone de un certificado digital, el Asistente para personalizar Internet Explorer 6 puede firmar automáticamente esos archivos.

Notas

  • La firma de los archivos contenedores (.cab) y los programas personalizados conlleva dos pasos: obtener un certificado digital y especificar los datos del certificado al ejecutar el Asistente para personalizar Internet Explorer 6. Para obtener más información, consulte Firmar sus programas.
  • Es posible que deba cambiar las mayúsculas y minúsculas de los nombres de los archivos publicados en un servidor UNIX de FTP. A continuación se detallan las convenciones que debe usar para sistemas operativos UNIX específicos.
    • UNIX de Solaris. Si está utilizando un servidor FTP de UNIX que distingue mayúsculas y minúsculas, debe asegurarse de que la carpeta contenedora no contiene mayúsculas, mientras que los archivos siguientes están en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE6SITES.DAT.
    • UNIX de AT&T. Todos los archivos deben estar en mayúsculas en un servidor FTP UNIX de AT&T.
    • UNIX de IRIX (Silicon Graphics). Los siguientes nombres de archivo deben ponerse en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE6SITES.DAT. Debe usar un procesador de textos a fin de modificar los nombres de archivos enumerados en IE.CIF para que la utilización de mayúsculas coincida con la de los archivos.

CD-ROM

Si distribuye el explorador personalizado para usuarios de Windows 95, aparecerá una pantalla de inicio del programa de ejecución automática cuando el usuario inserte el disco compacto. Este programa ofrece a los usuarios la posibilidad de instalar el explorador personalizado o ver más información. Si ya está instalada la versión actual de Internet Explorer, el programa de ejecución automática la detectará. Se mostrará el explorador en lo que se conoce como modo de pantalla completa con el archivo Start.htm cargado.

Nota

  • El proceso de descarga se muestra en el diagrama Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.

    • Temas relacionados


Personalización para administradores corporativos

IEAK le permite crear una instalación no interactiva y personalizada de Microsoft Internet Explorer que se adapte a las necesidades de su organización.

Personalizar el programa de instalación

  • Personalice la apariencia del programa de instalación de Windows Update y configure los modos de instalación (por ejemplo, las instalaciones Estándar y Mínima).
  • Dirija a los usuarios a servidores de Internet o de intranets para que tengan acceso a las versiones más recientes del producto.
  • Distribuya programas internos, secuencias de comandos personalizadas o secuencias de comandos de mantenimiento cuando los usuarios instalen Internet Explorer.
  • Especifique la versión del idioma de Internet Explorer que incluirá en el paquete de instalación. Debe ejecutar una vez el Asistente para personalizar Internet Explorer 6 por cada versión de idioma que desee crear.

Personalizar el explorador y la Actualización del escritorio de Windows

  • Especifique las páginas de inicio, búsqueda y soporte que desea utilizar.
  • Cargue vínculos y carpetas en la lista de Favoritos.
  • Cambie la barra de título y los logotipos del explorador y de Outlook Express. La barra de título de Outlook Express se actualiza tanto si distribuye Outlook Express como parte de su paquete, como si ya está instalado en los equipos de los usuarios.
  • Cree un escritorio predeterminado para la organización y determine qué opciones de configuración pueden cambiar los usuarios.

Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.

Administrar la seguridad y la clasificación de contenido

  • Instale certificados en los equipos de los usuarios e impida que descarguen otros certificados.
  • Defina la configuración de la clasificación de contenido de los usuarios de forma que se adapten a las directivas de la organización.
  • Establezca una renuncia estándar corporativa para las publicaciones Install creadas por los usuarios de su organización.
  • Utilice las zonas de seguridad para establecer distintos niveles de seguridad y zonas de confianza.
  • Especifique la configuración de proxy para direcciones y puertos.

Importante

  • Puede que algunas características no estén disponibles, según su contrato de licencia. Para obtener más información, consulte su contrato.


Administrador corporativo: preparación para ejecutar el asistente

titular

Preparación para ejecutar el Asistente

Antes de ejecutar el Asistente para personalizar Internet Explorer 6, debe recopilar toda la información que va a necesitar y crear los mapas de bits personalizados.

Determinar los requisitos de plataforma iniciales

  • Compruebe que el equipo en el que va a generar el paquete y los equipos donde va a instalar cumplen los requisitos de hardware y de software.
  • Determine los niveles de cifrado para los paquetes del explorador. Para obtener información acerca del cifrado de Internet Explorer, visite el sitio Web del IEAK.

Elegir el método de distribución

Decida cómo distribuirá su paquete personalizado (CD, descarga, red de área local o en discos). Una vez que el Asistente para la personalización de Internet Explorer 6 genere el paquete, tendrá que mover los archivos al medio seleccionado. Si genera un paquete descargable, debe moverlo al lugar apropiado de su servidor.

Si decide publicar su paquete personalizado en un servidor de Internet, necesitará la ruta de acceso del servidor y la dirección URL desde la que se descargarán los archivos. Después, cree una carpeta en el servidor Web, como CIE, para publicar todos los archivos y carpetas asociados al explorador personalizado. Por ejemplo, podría crear la ruta de acceso de servidor C:\Inetpub\Wwwroot\Cie\. Si nombreDelEquipo es la raíz virtual de este servidor Web, la dirección URL correspondiente sería http://nombreDelEquipo/Cie/.

Obtener un certificado digital

Realice los preparativos iniciales para firmar determinados archivos, como son los archivos de personalización creados por el Asistente para personalizar Internet Explorer 6 y los componentes personalizados, en el caso de que vaya a distribuirlos a través de Internet o de una intranet que no esté especialmente configurada. Con las características de seguridad del explorador, se advierte a los usuarios acerca de la descarga de archivos sin firmar o se les impide descargarlos. Las firmas digitales identifican el origen de los programas y garantizan que el código no ha cambiado desde que se firmó.

El Asistente para personalizar Internet Explorer 6 puede firmar los archivos si dispone de un certificado de publicación emitido por una entidad emisora de certificados. Para preparar los certificados de forma que los utilice el IEAK, puede importarlos en el equipo por medio del Asistente para la importación del Administrador de certificados. Si ha recibido un archivo con la extensión .spc, puede iniciar el Asistente para la importación del Administrador de certificados haciendo doble clic en el archivo .spc en el Explorador de Windows o en Mi PC.

También puede abrir el Administrador de certificados desde Internet Explorer. Para ello, haga clic en el menú Herramientas, Opciones de Internet, seleccione la ficha Contenido y haga clic en Certificados. Haga clic en Importar para iniciar el Asistente para la importación del Administrador de certificados y, después, siga los pasos que se indican en la pantalla.

Decida si desea configurar la Actualización del escritorio de Windows para la organización.

Crear la estructura en el equipo

Nombre de carpeta | Descripción
\CIE | Una raíz principal para todos los archivos generados por el IEAK o a los que el paquete personalizado haga referencia
\CIE\Bitmaps | Archivos de mapas de bits personalizados (archivos gráficos necesarios para el explorador personalizado)

Crear los gráficos apropiados

Tiene la opción de personalizar los mapas de bits del explorador citados más adelante. Antes de ejecutar el Asistente para personalizar Internet Explorer 6, coloque los mapas de bits en la carpeta \CIE\Bitmaps\.

Los fondos y botones personalizados sólo se muestran en equipos con capacidad para mostrar 256 colores (8 bits). En los equipos con capacidad para mostrar 16 colores (4 bits) se muestra un conjunto estándar de botones y mapas de bits de fondo de baja resolución.

  • Un mapa de bits de fondo para la pantalla de ejecución automática del CD-ROM (si crea un paquete en CD-ROM).

    Si va a distribuir su explorador personalizado en un disco compacto, necesitará crear mapas de bits como parte de la pantalla inicial de ejecución automática que se muestra cuando el usuario inserta el disco compacto.

  • Una imagen personalizada para los botones del CD-ROM (si crea un paquete en CD-ROM).
  • Dos mapas de bits personalizados para el Asistente para la instalación de Windows Update (si desea personalizar su apariencia): un mapa de bits de 162 por 312 píxeles para el lado izquierdo de la primera pantalla del asistente y un mapa de bits de 496 por 56 píxeles para la parte superior de las restantes pantallas del asistente.
  • Un mapa de bits personalizado de barra de herramientas (que aparece como fondo de los botones y menús).
  • Dos imágenes de mapa de bits estáticas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo.
  • Dos imágenes de mapa de bits animadas de 256 colores (una de 38 por 38 píxeles y la otra de 22 por 22 píxeles), que se utilizarán para marcar el explorador Internet Explorer con su logotipo animado.

    El IEAK contiene dos herramientas que le ayudan a crear y obtener vistas previas de los mapas de bits animados personalizados para el explorador.

Recopilar las direcciones URL de las páginas Principal, Búsqueda y Soporte.

Es conveniente crear una página de soporte que aparezca si los usuarios tienen problemas al instalar el explorador. Se le pedirán las direcciones URL de esas páginas cuando ejecute el Asistente para personalizar Internet Explorer 6.

Planear las estrategias de seguridad y de actualización del escritorio de Windows

Puede personalizar y controlar muchas opciones de usuario, como la seguridad y la Actualización del escritorio de Windows. Debe diseñar su estrategia antes de ejecutar el Asistente para personalizar Internet Explorer 6.

Nota

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.


Administrador corporativo.: Fase 1 del asistente: recopilar información

titular

Fase 1 del asistente: recopilar información

En esta fase del Asistente para personalizar Internet Explorer 6, los administradores corporativos deben indicar:

  • La ubicación de los archivos necesarios para crear el paquete personalizado del explorador.
  • El idioma del paquete del explorador que se está creando. Necesitará ejecutar el Asistente para la personalización para cada versión internacional que desee crear.
  • El medio de distribución que piensen utilizar, como CD-ROM o la descarga desde Internet o una intranet.
  • Las características que van a personalizar. Por ejemplo, si sólo van a hacer pequeñas modificaciones al explorador, no tendrán que pasar por todas las pantallas del Asistente para IEAK.

Nota

  • El asistente para la personalización no funcionará correctamente si no está instalado Internet Explorer 6. Para obtener más información, consulte Requisitos de hardware y del sistema.


Administrador corporativo.: Fase 2 del asistente: especificar parámetros de instalación

titular

Fase 2 del asistente: especificar parámetros de instalación

En esta fase del Asistente para personalizar Internet Explorer 6, los administradores corporativos deben:

  • Descargar o actualizar componentes de Microsoft mediante el sistema automático de sincronización de versiones (AVS). Debe descargar Internet Explorer, pero puede elegir los demás componentes de Internet Explorer que descargará.
  • Seleccionar los componentes personalizados que desea incluir.

    También puede especificar hasta 16 componentes adicionales, que pueden ser archivos ejecutables autoextraíbles (.exe) o archivos contenedores (.cab) comprimidos.


Administrador corporativo.: Fase 3 del asistente: personalizar la instalación

titular

Fase 3 del asistente: personalizar la instalación

En esta fase del Asistente para personalizar Internet Explorer 6, los administradores corporativos pueden determinar la apariencia y funcionamiento de la instalación de Windows Update:

  • Personalice la pantalla de ejecución automática del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice otras opciones del CD-ROM, si está creando un paquete en CD-ROM.
  • Personalice el Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet. Estas opciones de configuración afectan a la apariencia del programa de instalación.
  • Determine si desea instalar el paquete personalizado "silenciosamente", con pocos o ningún aviso al usuario.
  • Especifique hasta diez opciones de instalación y determine los componentes que incluirá en cada opción.
  • Especifique hasta diez sitios desde los que se puede descargar el paquete. Puede especificar un máximo de diez sitios, a menos que sea administrador corporativo y realice una instalación silenciosa.
  • Especifique de qué forma recibirán los usuarios las actualizaciones de los componentes.
  • Especifique dónde desea que se instale Internet Explorer en los equipos de los usuarios y si éstos pueden cambiar la ubicación de la instalación.
  • Determine si los usuarios pueden personalizar el programa de instalación, si se debe instalar o no la información de desinstalación, si se puede instalar Internet Explorer junto con una versión anterior del programa y si Internet Explorer es el explorador predeterminado.
  • Especifique si la instalación de Windows Update debe detectar si existe un componente dado y determinar con precisión qué componentes pueden personalizar los usuarios.
  • Determine si los componentes que se han descargado pero no se han incluido en todos los paquetes deben ponerse a disposición de los usuarios por medio de la característica de instalación a petición de Internet Explorer.
  • Especifique si desea integrar la funcionalidad del explorador de Web en el escritorio y las carpetas. Esta funcionalidad ya está integrada en Windows 98.
  • Especifique si ha personalizado el marcador del Administrador de conexión utilizando el Kit de administración del administrador de conexión (CMAK).
  • Especifique los datos de la entidad emisora de certificados para que, si tiene un certificado digital, pueda firmar los programas al crear el paquete IEAK.

Notas

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.
  • Si desea ver un organigrama de lo que ocurre al usar el Asistente para personalizar de Internet Explorer 6 para crear un paquete personalizado, consulte Cómo genera IEAK los paquetes personalizados.


Administrador corporativo. Fase 4 del asistente: personalizar el explorador

titular

Fase 4 del asistente: personalizar el explorador

En esta fase del Asistente para personalizar Internet Explorer 6, los administradores corporativos pueden personalizar lo siguiente:

  • La barra de título del explorador. El título del explorador personalizado aparece en Internet Explorer y en Outlook Express, tanto si se ha distribuido con el paquete como si estuviera instalado en el equipo del usuario.
  • El fondo y los botones de la barra de herramientas del explorador. Puede agregar botones personalizados a la barra de herramientas para ejecutar secuencias de comandos y programas.
  • El logotipo de Internet Explorer de la esquina superior derecha del explorador.
  • Las páginas principal, de búsqueda y de soporte en línea del explorador.
  • Los favoritos, las carpetas de favoritos y los vínculos de la barra de vínculos.
  • La página de bienvenida que ven los usuarios cuando inician el explorador por primera vez.
  • La cadena de agente del usuario. El identificador del agente de usuario es opcional; es una forma de realizar un seguimiento del uso de su explorador personalizado.
  • La configuración de la conexión del usuario al personalizarla, importarla o eliminar la configuración existente del usuario.
  • La configuración automática. Puede proporcionar la ruta de acceso de los archivos con los que se configura automáticamente el explorador.
  • La configuración de proxy.
  • La configuración de los certificados de seguridad y de Authenticode.
  • La configuración de las zonas de seguridad y de las clasificaciones.

Nota

  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.


titular

Administrador corporativo

Fase 5 del asistente: personalizar los componentes

En esta fase del Asistente para personalizar Internet Explorer 6, los administradores corporativos pueden personalizar lo siguiente:

  • La configuración predeterminada del programa, como los programas específicos que se utilizarán para leer correo electrónico o modificar el Lenguaje de marcado de hipertexto (HTML).
  • Los servidores de correo y noticias de los usuarios, si va a incluir Outlook Express en el paquete personalizado.
  • La configuración del servidor de correo electrónico IMAP para los usuarios, en el caso de que vaya a distribuir Outlook Express y tenga un servidor IMAP .
  • El contenido personalizado de Outlook Express, al agregar su propio mensaje de correo electrónico para dar la bienvenida a los usuarios y personalizar el panel de información que aparece cuando los usuarios inician el programa.
  • La configuración personalizada de Outlook Express, por ejemplo, con la definición de clientes nuevos predeterminados de correo y de noticias, la ayuda a los usuarios que necesitan más cuentas de correo y la creación de un archivo de reglas predeterminadas para los mensajes de los usuarios.
  • La configuración de la interfaz de usuario de Outlook Express, como decidir si se muestra la barra de carpetas, la lista de carpetas, la barra de estado o la barra de Outlook.
  • La configuración de redacción de Outlook Express, si desea definir una renuncia de responsabilidad corporativa o firma para incluirlas en los mensajes de correo electrónico o de grupos de noticias.
  • El servicio de directorio de la Libreta de direcciones de Windows, si desea ofrecer servicios de directorio de Internet a los usuarios y personalizar los servidores de Protocolo compacto de acceso a directorios (LDAP, Lightweight Directory Access Protocol).
  • La elección de determinadas directivas del sistema y restricciones, dependiendo del sistema operativo que ejecuten los usuarios. Si utilizan Windows NT, Windows 2000 o Windows XP, algunas directivas y restricciones deben administrarse mediante el Editor de directivas de Windows NT o las Directivas de grupo de Windows 2000 o Windows XP, respectivamente, en lugar del Asistente para personalizar Internet Explorer 6 o el Administrador de perfiles del IEAK.
  • Las directivas y configuración del sistema, para predefinir o controlar la configuración, incluidas las opciones relacionadas con el explorador, el correo electrónico, la seguridad y el escritorio.


titular

Administrador corporativo

Distribuir su paquete del explorador

De forma predeterminada, el Asistente para personalizar Internet Explorer 6 crea archivos para descargar desde Internet. En caso necesario, puede cambiar el medio de distribución del paquete.

Archivos descargables

Si creó el paquete del explorador en un servidor de Internet o de una intranet, debe configurar su sitio Web para que los usuarios puedan descargar los archivos. Por ejemplo, podría crear una página en la que publicara la información de descarga y un vínculo al motor de instalación, IE6setup.exe.

Si creó el paquete del explorador en un disco duro o en una unidad de red, deberá mover los elementos siguientes a un servidor de Internet o de la intranet:

  • La carpeta que contiene la versión del idioma que está publicando y los contenidos de la carpeta. Por ejemplo, la carpeta de la versión en inglés se llama EN, por lo que debe mover la carpeta EN y los archivos que contiene. Esta carpeta se encuentra en las carpetas que correspondan al tipo de distribución, por ejemplo, Download (descarga), y plataforma. La única designación de plataforma del IEAK 6 es "Win32"; para clientes UNIX y Windows de 16 bits, use IEAK 5.0x.
  • El archivo llamado Ie6sites.dat. Este archivo señala el sitio (o sitios) de descarga que especificó al ejecutar el Asistente para personalizar Internet Explorer 6.

Los usuarios instalarán el explorador haciendo clic en IE6setup.exe. Este archivo se encuentra en la carpeta de la versión en su idioma y plataforma dentro de la carpeta \Download, por ejemplo, la versión en inglés se almacena en \Download\Win32\En o en \Download\Win16\En.

Firmar los paquetes personalizados

Los exploradores Web tienen características de seguridad que ayudan a proteger a los usuarios frente a la descarga de programas perjudiciales. En función del nivel de seguridad y del sistema operativo, se puede advertir al usuario o evitar que descargue programas que no estén firmados digitalmente.

Los archivos .cab personalizados creados con el Asistente para personalizar Internet Explorer 6 deben estar firmados, a menos que se haya configurado la zona local de la intranet con un nivel bajo de seguridad. Cualquier componente personalizado que distribuya con el paquete del explorador y vaya destinado a esos sistemas operativos también debe estar firmado. Si dispone de un certificado digital, el Asistente para personalizar Internet Explorer 6 puede firmar automáticamente esos archivos.

Notas

  • La firma de los archivos contenedores (.CAB) y los programas personalizados requiere que se lleven a cabo dos pasos: obtener un certificado digital y especificar los datos del certificado al ejecutar el Asistente para la personalización.
  • Es posible que deba cambiar las mayúsculas y minúsculas de los nombres de los archivos publicados en un servidor UNIX de FTP. A continuación se detallan las convenciones que debe usar para sistemas operativos UNIX específicos.
    • UNIX de Solaris
      Si está utilizando un servidor FTP de UNIX que distingue mayúsculas y minúsculas, debe asegurarse de que la carpeta contenedora no contiene mayúsculas, mientras que los archivos siguientes están en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE6SITES.DAT.
    • UNIX de AT&T
      Todos los nombres de los archivos deben estar en mayúsculas en un servidor FTP de UNIX de AT&T.
    • UNIX de IRIX (Silicon Graphics)
      Los nombres de archivo siguientes deben estar en mayúsculas: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE6SITES.DAT. Debe usar un procesador de textos a fin de modificar los nombres de archivos enumerados en IE.CIF para que la utilización de mayúsculas coincida con la de los archivos.

CD-ROM

Si distribuye el explorador personalizado para usuarios de Windows 95 o Windows 98, aparecerá una pantalla inicial del programa de ejecución automática cuando el usuario inserte el disco compacto. Este programa ofrece a los usuarios la posibilidad de instalar el explorador personalizado o ver más información. Si ya está instalada la versión actual de Internet Explorer, el programa de ejecución automática la detectará. Se mostrará el explorador en lo que se conoce como modo de pantalla completa con el archivo Start.htm cargado.

Con el Asistente para la instalación de Windows Update puede publicar todos los archivos en un servidor de intranet o Internet. También puede crear versiones en CD-ROM para los usuarios que inicialmente no tengan acceso a Internet.

Nota

  • El proceso de descarga se muestra en el diagrama Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.
  • Para ver un ejemplo, consulte Cómo configurar los archivos para distribución.
  • Para ver un organigrama de los archivos que crea el Asistente para personalizar Internet Explorer 6, consulte Cómo genera IEAK paquetes personalizados.


Administrar la configuración de usuario

Después de establecer las opciones de los usuarios y distribuir el explorador, los administradores todavía pueden modificar la configuración. Si almacenan un archivo .ins maestro en el servidor y lo descargan en cada inicio de sesión, los administradores pueden ajustar la configuración de las opciones de los usuarios de forma continua. También pueden escribir en las secuencias de comandos de inicio de sesión existentes para administrar y actualizar periódicamente las configuraciones de usuarios desde un servidor central.

Puede utilizar el Administrador de perfiles de IEAK para administrar fácilmente los archivos de configuración. El Administrador de perfiles de IEAK permite abrir cualquier archivo .ins y realizar cambios en la configuración, por ejemplo, en la información de proxy, del Protocolo compacto de acceso a directorios (LDAP), la barra de búsqueda o la página principal.

En sistemas que ejecuten Windows 2000 y Windows XP, también puede usar la opción Directiva de grupo para administrar algunas opciones de usuario.

Una vez realizada la instalación, los administradores pueden modificar de forma remota todos los certificados de compañías (y de sitios) permitidos, agregando o quitando certificados de la lista de certificados permitidos.


Utilizar el Complemento de conjunto resultante de directivas

Puede utilizar el Complemento de conjunto resultante de directivas (RSoP) para explorar la información de directivas configurada para equipos y usuarios. Cuando trabaja con el Asistente para RSoP, puede elegir entre el modo de registro o el modo de planeamiento. El modo de registro permite tener acceso a la información de directivas de un equipo y usuario existentes, mientras que el modo de planeamiento genera información de directivas basándose en Active Directory. En ambos casos, la información que puede explorar incluye la configuración del software, la configuración de la ventana y las plantillas administrativas.

Cuando trabaja con el Asistente para el Conjunto resultante de directivas, debe elegir si desea trabajar con información del equipo, del usuario, o ambas. El asistente configura la lista de carpetas que contienen las opciones de configuración que puede ver. Explorar la información puede ayudarle a planear las directivas. Una vez completado el planeamiento, puede utilizar el Asistente para personalizar Internet Explorer 6 o el Administrador de perfiles de Internet Explorer para definir las directivas. Una vez implementadas las directivas, puede utilizar el complemento RSoP para revisar las directivas establecidas.

Notas

  • Los usuarios de Windows 2000 y Windows XP pueden utilizar el complemento Directiva de grupo para explorar las directivas, y los usuarios de Windows NT pueden utilizar el Editor de directivas. Asimismo, puede seguir usando el Asistente para personalizar Internet Explorer 6 o el Administrador de perfiles de Internet Explorer para establecer las directivas que desea personalizar.
  • Utilice el Asistente para personalizar Internet Explorer 6 para establecer y distribuir las directivas en el paquete de Internet Explorer personalizado.
  • Utilice el Administrador de perfiles de Internet Explorer para establecer las directivas en equipos específicos o usuarios individuales.

En el modo de planeamiento, trabajará con nuevas directivas que no se han establecido en ningún equipo ni para ningún usuario. Por tanto, el complemento RSoP debe generar la información de Directiva de grupo. Sin embargo, en el modo de registro, la información reside en los equipos donde se aplicaron las directivas de grupo.

La utilización del complemento RSoP es un proceso de dos pasos. En primer lugar, deberá ejecutar el asistente para indicar qué información desea ver. A continuación, deberá abrir las carpetas de la ventana Consola que contienen la configuración que desea ver.

Para iniciar el Asistente para el conjunto resultante de directivas

  1. Haga clic en Inicio y después en Ejecutar.
  2. En el cuadro Abrir, escriba mmc y, a continuación, haga clic en Aceptar.
  3. En el menú Archivo, haga clic en Agregar o quitar complemento.
  4. Haga clic en Agregar en la ficha Independiente.

Para utilizar el Conjunto resultante de directivas para revisar la configuración de Internet Explorer

  1. En Conjunto resultante de directivas, haga clic en Configuración del usuario.
  2. Haga clic en Configuración de Windows y, después, en Mantenimiento de Internet Explorer.
  3. Seleccione el icono de la característica que desea revisar.
  4. Haga doble clic en el título de la característica que desea revisar.


Opciones de seguridad en IEAK

La mayor parte de la información relativa a las opciones de seguridad en el IEAK se encuentra disponible haciendo clic en Ayuda en el Asistente para la personalización de Internet Explorer 6. Puede ver esa información leyendo las siguientes opciones:

  • Seguridad
  • Configuración de seguridad
  • Directivas y restricciones
  • Experiencia de usuario
  • Cuentas de Outlook Express

Nota

  • Para localizar una página en particular mientras lee estas páginas del asistente, haga clic en Siguiente hasta llegar a ella.


Tipos de archivo

Tipo de archivo | Descripción
.adm | Los archivos de administración (.adm) definen las directivas del sistema y restricciones para el escritorio, shell y la seguridad. Puede personalizar y restringir la configuración en un archivo .adm mediante IEAK o el Editor de directivas del sistema de Windows. Para ver una lista de las directivas y restricciones del sistema que pueden establecerse desde los archivos .adm estándar, consulte Descripción del Administrador de perfiles de IEAK
.asp | Si distribuye Internet Explorer desde un servidor Web, puede incluir archivos de Página Active Server (.asp) en el paquete del explorador personalizado. Mediante el uso de archivos .asp, puede incrustar secuencias de comandos en las páginas HTML para crear contenido Web interactivo y dinámico. Por ejemplo, puede crear páginas de suscripción que permitan a los usuarios descargar el explorador y registrarse en los servicios Internet. Puede señalar los archivos .asp del Asistente para personalizar Internet Explorer 6 o el Administrador de perfiles de IEAK. El CD-ROM del kit de recursos incluye archivos .asp de ejemplo.
.bat | Archivo de texto ASCII que contiene una secuencia de comandos del sistema operativo; a veces incluye parámetros y operadores admitidos por el lenguaje de comandos por lotes. Cuando el usuario escribe el nombre del archivo por lotes en el símbolo del sistema, el equipo procesa los comandos secuencialmente.
.bmp, .gif, .jpeg, .jpg | Internet Explorer puede incluir gráficos estáticos y animados con formato de archivo .bmp, .gif, .jpeg o .jpg. Además de utilizar los archivos gráficos suministrados con el IEAK, puede crear gráficos propios e incluirlos con el paquete del explorador personalizado. Por ejemplo, puede reemplazar el logotipo de Internet Explorer o la pantalla inicial del programa de ejecución automática con sus propios archivos gráficos animados o estáticos. El IEAK incluye dos herramientas para ayudarle a crear gráficos animados personalizados. Para obtener más información acerca de los requisitos para los gráficos que personalice, consulte Crear gráficos personalizados.
.cab | Los archivos contenedores organizan y almacenan los archivos de instalación comprimidos que se copian en el equipo del usuario. El programa de instalación de Windows Update (IE5Setup.exe) descarga los archivos .cab necesarios para la instalación de Internet Explorer en el equipo del usuario. Estos archivos pueden contener el explorador y los componentes personalizados. Una vez que los archivos se han descargado correctamente, la instalación de Windows Update está completa. El IEAK incluye un conjunto de herramientas que pueden ayudarle a crear archivos .cab para los componentes personalizados.
.cif | Un archivo de información de componente (.cif) llamado IESetup.cif identifica los componentes que se pueden instalar con Internet Explorer, incluidos nuevos componentes o actualizaciones. En el archivo .cif, todos los componentes tienen un IdComponente asociado. El programa de instalación de Windows Update lee el archivo .cif para determinar si ya se ha instalado un componente con un IdComponente específico y si hay disponible una versión más reciente para la instalación.
.cmp | Los archivos de perfil de conexión (.cmp), creados por el CMAK, contienen información especificada por el usuario. No deben modificarse, ya que los usuarios podrían sobrescribir los cambios realizados.
.cms | Los archivos de proveedor de servicios (.cms), creados por el CMAK, especifican la configuración de la libreta de teléfonos y la mayor parte del resto de las funciones de los perfiles de servicio. Para realizar la personalización avanzada de un perfil de servicio es necesario modificar el archivo .cms correspondiente a dicho perfil.
.exe | El archivo ejecutable (.exe) IE5Setup.exe es el programa que controla el proceso de instalación. Este archivo .exe descarga los archivos .cab que instalan el paquete del explorador personalizado en los equipos de los usuarios. A su vez, estos archivos .cab incluyen archivos ejecutables (*.exe) autoextraíbles adicionales para el explorador y los archivos contenedores.
.htt | Los archivos de plantilla HTML (.htt) proporcionan plantillas personalizables para Mi PC (Mycomp.htt), Panel de control (Controlp.htt), Impresoras (Printers.htt) y vista Web predeterminada de las carpetas (Folder.htt). Mediante un procesador de texto o HTML, puede personalizar estos archivos con instrucciones especiales, logotipos o vínculos a sitios Web. Puede incluir Mycomp.htt y Controlp.htt en el paquete del explorador personalizado. Las plantillas Printers.htt y Folder.htt deben personalizarse directamente en los equipos de los usuarios.
.inf | Por lo general, todos los archivos .cab de Internet Explorer contienen un archivo de información asociada (.inf), que proporciona información adicional acerca de la instalación. El archivo .inf puede hacer referencia a archivos que se encuentran en el archivo .cab, así como a otros archivos de otras direcciones URL.
.ins | El programa de instalación de Windows Update contiene un archivo de configuración de Internet (.ins), que configura el explorador y los componentes asociados. Puede crear varias versiones del paquete del explorador si personaliza varias copias del archivo .ins. El Administrador de perfiles de IEAK también le permite crear, guardar y cargar archivos .ins para actualizar las opciones de configuración de Internet Explorer.
.isp | Si está implementando un proceso de suscripción con el paquete del explorador personalizado, el archivo de suscripción a Internet (.isp) Signup.isp proporciona la información de acceso telefónico necesaria para los servicios Internet. Mediante el Asistente para personalizar Internet Explorer 6, puede modificar los parámetros contenidos en este archivo de suscripción a Internet. Si se utiliza el método de suscripción con servidor, este archivo de suscripción a Internet también contiene un vínculo a la dirección URL de la secuencia de comandos de servidor que genera el archivo de configuración (.ins).
.pac, .js, .jvs | Puede usar un procesador de texto para crear un archivo de comandos de proxy automático para el paquete del explorador personalizado. Este archivo puede ser un archivo de configuración de tipo .JScript (.js), JavaScript (.jvs) o de configuración automática de proxy (.pac). Al especificar un archivo de comandos de proxy automático, Internet Explorer usa la secuencia de comandos para determinar de forma dinámica si debe conectarse directamente a un host o utilizar un servidor proxy. En la Fase 4 del Asistente para personalizar Internet Explorer 6, puede especificar una dirección URL de proxy automático para configurar y mantener la configuración avanzada del proxy.
.pdf | Si utiliza Microsoft Systems Management Server para distribuir Internet Explorer, el paquete del explorador personalizado se compone de una carpeta de archivos de instalación y un archivo de definición de paquete (.pdf). Este archivo, llamado IE5.pdf, contiene un programa de instalación, opciones de instalación y la sintaxis de línea de comandos. Estos elementos son necesarios para instalar automáticamente Internet Explorer en el servidor o en los equipos de los usuarios. El archivo .pdf permite que la instalación se lleve a cabo sin la intervención del administrador o el usuario.
.pvk | Archivo de clave privada que contiene la clave privada asociada con una firma digital.
.pwl | Archivo que contiene la contraseña de Windows de un usuario de este equipo.
.sed | Los archivos de perfil de conexión (.sed), generados por el CMAK, contienen las instrucciones necesarias para crear un archivo ejecutable autoextraíble (.exe) para los perfiles de servicio. Los archivos .sed no deben modificarse.
.spc | Archivo de certificado de publicación de software. Los certificados contienen el nombre y otra información que identifica al propietario del certificado, la clave pública asociada a él, un número de serie, el período de validez del certificado y la firma digital de la entidad emisora de certificados que lo concedió.


Seguridad de Internet Explorer

Microsoft Internet Explorer le permite controlar la seguridad de varias formas: mediante certificados de sitios, entidades emisoras de certificados Authenticode y zonas de seguridad. Puede instalar previamente certificados en los equipos de los usuarios y evitar que éstos descarguen otros certificados. También puede establecer restricciones en el contenido que ven los usuarios.

Los administradores corporativos pueden especificar la configuración de seguridad y las restricciones en las fases 4 y 5 del Asistente para personalizar Internet Explorer 6.

Zonas de seguridad

Las opciones de seguridad de Internet Explorer le permiten asignar determinados sitios Web a diversas zonas, en función de la confianza que tenga en el contenido del sitio Web.

Cuando instala Internet Explorer se configuran las siguientes zonas de seguridad:

  • Una zona de Internet que contiene, de forma predeterminada, todos los sitios de Internet
  • Una zona de intranet local para los equipos conectados a una red local
  • Una zona de sitios de confianza, a la que puede asignar los sitios en los que confíe
  • Una zona de sitios restringidos, a la que puede asignar los sitios en los que no confíe
  • Una zona Mi PC, que contiene los archivos del equipo local

Estas zonas pueden formar parte de los cuatro niveles de configuración de seguridad predeterminados siguientes: alto, medio, medio-bajo y bajo. Además, puede definir niveles de seguridad personalizados para cada zona.

Puede ver todas las opciones de configuración de seguridad haciendo clic en el icono Internet del Panel de control y, después, en la ficha Seguridad. Para obtener información específica acerca de estas opciones y de cómo interactúan, consulte Opciones de seguridad de Internet Explorer.

Recuerde que la seguridad en Internet será tan buena como lo sea su configuración. Internet Explorer le proporciona la información necesaria para tomar decisiones correctas en cuanto a la seguridad, así como herramientas flexibles para implementar esas decisiones.

Puede predefinir las opciones de seguridad cuando ejecuta el Asistente para personalizar Internet Explorer 6 y determinar si los usuarios pueden o no cambiar esas opciones. Si no predefine las opciones de seguridad, puede ser aconsejable recomendar el nivel de seguridad óptimo para los usuarios, en función de su experiencia y de las necesidades de la organización.

Notas

  • Si el idioma del paquete del explorador Internet Explorer que está generando es distinto al explorador de su equipo, e importa sus zonas de seguridad, podrían aparecer algunos caracteres no reconocibles en la interfaz de las zonas de seguridad de los exploradores generados.
  • Sólo puede configurar la zona Mi PC desde el IEAK; sus opciones de configuración no están disponibles en la interfaz del explorador. Normalmente, es aconsejable que utilice la configuración predeterminada para esta zona a menos que su organización tenga algún requisito específico. Una configuración con un nivel más bajo de seguridad puede suponer un riesgo, mientras que niveles más altos de seguridad pueden reducir mucho la funcionalidad.

Configurar la zona de Internet

La zona de Internet está formada por todos los sitios no incluidos en ninguna de las demás zonas. De forma predeterminada, la zona de Internet tiene el nivel de seguridad medio. Si le preocupan los problemas de seguridad que se puedan presentar al explorar Internet, puede que desee cambiar la configuración a Alta. Si aumenta la configuración de seguridad, algunas páginas Web no realizarán operaciones potencialmente peligrosas, si bien esto puede impedir cierta funcionalidad útil y hacer que algunas páginas no funcionen correctamente.

Puede elegir la configuración personalizada para controlar cada decisión individual de seguridad de la zona. Para ello, haga clic en el icono Internet del Panel de control, haga clic en la ficha Seguridad y, finalmente, haga clic en Personalizar nivel.

Agregar sitios a las zonas de sitios de confianza y sitios restringidos

Hay dos zonas a las que puede asignar sitios Web específicos en los que confía más o menos que los de la zona de Internet o la zona de intranet local. Para agregar sitios a estas zonas, elija primero la zona y, después, haga clic en Sitios.

La zona de sitios de confianza tiene asignado de forma predeterminada un nivel de seguridad bajo. Es recomendable para sitios de confianza elevada, como empresas con las que habitualmente mantiene relaciones comerciales, a veces conocidos como una extranet. Si asigna un sitio a la zona de sitios de confianza, el sitio podrá realizar operaciones más eficientes. Además, Internet Explorer le pedirá menos veces que tome decisiones relativas a la seguridad Agregue un sitio a esta zona sólo si confía en que el contenido nunca afectará negativamente a su equipo. En la zona de sitios de confianza, le recomendamos que utilice el protocolo HTTPS: o que se asegure de que las conexiones al sitio son seguras.

La zona de sitios restringidos tiene asignado de forma predeterminada el nivel de seguridad alto. Si asigna un sitio a la zona de sitios restringidos, el sitio sólo tendrá permiso para realizar un número mínimo de operaciones que sean verdaderamente seguras. Esta zona sirve en el caso poco frecuente de que no confíe en un sitio. Para asegurar un alto grado de seguridad para contenido en el que no se confía, muchas páginas en esta zona no funcionan correctamente.

Configurar la zona de intranet local (para administradores de red)

Para estar totalmente seguros, debe configurar la zona de Intranet local junto con el servidor proxy y el servidor de seguridad. Todos los sitios de la zona deben estar "dentro del servidor de seguridad" y los servidores proxy deben configurarse de manera que no permitan que se resuelva un nombre DNS externo en esta zona. Configurar la seguridad de la zona del cliente requiere tener un conocimiento detallado de la configuración de la red existente, los servidores proxy y los servidores de seguridad seguros. Si no conoce esta información, póngase en contacto con el administrador de la red.

De forma predeterminada, la zona de intranet local está compuesta por nombres de dominios locales y de los establecidos para suplantar al servidor proxy en la ficha Conexiones. Puede configurar estas opciones en la pantalla Configuración de conexión del Asistente para personalizar Internet Explorer 6. Tenga en cuenta que ahora se pueden definir varias configuraciones de conexión para cada usuario. El administrador de la red debe confirmar que la configuración es realmente segura para la instalación o debe ajustarla para que lo sea.

Al configurar la zona puede especificar las categorías de direcciones URL que se considerarán. También puede agregar determinados sitios a la zona.

Para especificar categorías de direcciones URL que desea incluir en la zona desde el explorador:

  1. En el menú Herramientas de Internet Explorer, haga clic en Opciones de Internet y, después, en la ficha Seguridad.
  2. Haga clic en la zona Intranet local y, después, haga clic en Sitios.
  3. Active las casillas de verificación que correspondan:

    Incluir todos los sitios locales (intranet) no listados en otras zonas
    Incluir todos los sitios que no utilicen el servidor proxy
    Incluir todas las rutas de la red (UNC)

Notas

  • Para agregar un sitio específico a esta zona, haga clic en Opciones avanzadas, escriba la dirección URL y haga clic en Agregar. Para requerir que se use la comprobación del servidor, active la casilla de verificación Requerir comprobación del servidor (https:) para todos los sitios de esta zona.
  • Para especificar categorías de direcciones URL para los paquetes del IEAK, haga clic en Personalizar la configuración de zonas de seguridad en la pantalla Configuración de la seguridad del Asistente para personalizar Internet Explorer 6 y, después, haga clic en Modificar configuración.

Las reglas siguientes se aplican a las opciones de la zona de intranet local. Tenga en cuenta que agregar un sitio a cualquier zona tiene prioridad sobre las reglas siguientes:

  • Incluir todos los sitios locales (intranet) no listados en otras zonas. Los sitios de una intranet tienen nombres que no incluyen puntos, por ejemplo, http://local. Un nombre de sitio como http: //www.microsoft.com no es local, ya que contiene puntos. Este sitio estaría asignado a la zona de Internet. La regla sobre nombres de sitios de una intranet también se aplica a los archivos, así como a las direcciones URL http.
  • Incluir todos los sitios que no utilicen el servidor proxy. las configuraciones típicas de las intranet usan un servidor proxy para tener acceso a Internet con una conexión directa a los servidores de la intranet. Esta configuración utiliza este tipo de información de configuración para diferenciar la intranet del contenido Internet en relación a las zonas. Si el servidor proxy tiene otra configuración, debe desactivar esta opción y utilizar otras opciones para indicar los archivos que están asignados a la zona de intranet local. En sistemas sin servidor proxy, esta configuración no tiene efecto.
  • Incluir todas las rutas de red (UNCs). las rutas de acceso de red (por ejemplo, \\local\archivo.txt) se usan habitualmente para contenidos de la red local que deben incluirse en la zona de Intranet local. Si hay rutas de red que no deberían estar en la zona de intranet local, debe desactivar esta opción y utilizar otras opciones para indicar los archivos que están asignados a la zona de intranet local. Por ejemplo, en ciertas configuraciones de Common Internet File System (CIFS, Sistema de archivos común de Internet) es posible que una ruta de red se refiera a contenido Internet.

Una vez que se ha confirmado que la zona de intranet local es segura, piense en la posibilidad de cambiar el nivel de seguridad de la zona a medio-bajo o bajo para permitir una gama más amplia de operaciones. También puede definir niveles de configuración individuales de seguridad en el cuadro de diálogo Configuración personalizada.

Si hay partes de su intranet que son menos seguras o no son de confianza, se pueden excluir de esta zona si las asigna a la zona de sitios restringidos.

La configuración de la zona de intranet local debe hacerse con el IEAK, aunque también puede utilizar las opciones de la ficha Seguridad del cuadro de diálogo Propiedades de Internet.

Trabajar con sufijos de nombres de dominio

Si desea hacer referencia a un servidor Web mediante una expresión más corta de su dirección que no contenga el dominio, puede usar un sufijo de nombre de dominio. Por ejemplo, puede hacer referencia a un servidor Web denominado ejemplo.microsoft.com como ejemplo y tendrá acceso al mismo contenido tanto si escribe http://ejemplo.microsoft.com como http://ejemplo.

Para establecer un sufijo de nombre de dominio debe agregar éste al orden de búsqueda del sufijo de dominio en las propiedades de TCP/IP; para ello, realice los siguientes pasos:

  1. Haga clic con el botón secundario del mouse (ratón) en el icono Mis sitios de red y, a continuación, haga clic en Propiedades.
  2. Haga clic en TCP/IP y, después, en Propiedades.
  3. Haga clic en la ficha Configuración DNS y, a continuación, agregue la información que desee en el área Orden de búsqueda del sufijo de dominio.

Es importante que establezca correctamente las zonas de seguridad para esta configuración. De forma predeterminada, se considera que la dirección URL sin puntos (http://ejemplo) se encuentra en la zona de intranet local, mientras que la dirección URL con puntos (http://ejemplo.microsoft.com) está en la zona de Internet. Por tanto, si usa esta configuración y no se omite el servidor proxy para asignar claramente el contenido a la zona apropiada, tendrá que cambiar la configuración de la zona.

En función de si el contenido al que se tiene acceso mediante el sufijo de dominio es contenido de intranet o contenido de Internet, tendrá que asignar las direcciones URL de los sitios ambiguos a las zonas apropiadas. Para asignar direcciones URL como http://ejemplo a la zona de Internet, desactive la casilla de verificación Incluir todos los sitios locales (intranet) no listados en otras zonas para la zona de intranet local e incluya el sitio en la lista de sitios de la zona.

Descripción de la seguridad que se aplica a todas las zonas

Es posible dirigir contenido del Web mediante un nombre de Sistema de nombres de dominio (DNS) o mediante una dirección de protocolo Internet (IP); para los sitios que usan ambos, es importante configurar ambas referencias a la misma zona. Normalmente, los sitios de la zona de intranet local son identificables tanto por su nombre local como por direcciones IP en la lista de derivación del servidor proxy; todos los demás nombres y direcciones IP se asignarían a la zona de Internet. No obstante, si el nombre de un sitio se introduce en la lista de zonas de sitios en los que se confía o de zonas de sitios restringidos, pero su intervalo de direcciones IP no está en la lista, puede que se trate el sitio como parte de la zona de Internet si se tiene acceso a ella mediante su dirección IP.

Es importante comprender que un usuario puede copiar contenido de una zona a otra, con lo que podría aumentar o disminuir el nivel de seguridad deseado para dicho contenido.

Si está usando configuración automática y tiene instalados Internet Explorer 5 (o posteriores) e Internet Explorer 4 con el mismo archivo de configuración automática, algunos valores de configuración que difieren entre las versiones no serán configurados en Internet Explorer 4.


Opciones de seguridad de Internet Explorer

Las zonas de seguridad de Internet Explorer le permiten especificar las opciones de seguridad del contenido del Web. Una zona es un conjunto de sitios Web a los que se asigna el mismo nivel de confianza. El proceso consiste en agregar sitios Web a una zona determinada y, después, definir las opciones de seguridad para esa zona.

Puede adaptar la configuración predeterminada de Internet Explorer para que mejor se ajuste a las características de seguridad del sistema. En el caso de una intranet segura, por ejemplo, normalmente puede seleccionar el nivel de seguridad bajo o una configuración personalizada equivalente, después de que la zona de la intranet local se configure como corresponde al servidor de seguridad.

Todas las opciones de seguridad se aplican al explorador Internet Explorer; no abarcan todo el sistema. Otros programas de Internet pueden no respetar estas opciones.

Para configurar las opciones de seguridad de una empresa, debe modificar la configuración mediante el IEAK. El usuario puede ver las opciones de seguridad en el explorador si hace clic en el menú Herramientas, Opciones de Internet y, después, hace clic en la ficha Seguridad. Para ver las opciones de configuración personalizadas, el usuario debe seleccionar una zona de seguridad y, después, hacer clic en Personalizar nivel.

Controles y complementos ActiveX

Estas opciones controlan la forma en que el administrador aprueba, descarga, ejecuta y automatiza los controles y complementos ActiveX. Para obtener más información acerca de cómo se administran y aprueban los controles ActiveX, consulte Administrar controles ActiveX.

Cuando un usuario descarga un control ActiveX desde un sitio diferente del sitio donde se utiliza el control, Internet Explorer utiliza la configuración de zona más restrictiva de los dos sitios. Por ejemplo, si un usuario está viendo una página Web de una zona configurada para permitir descargas, pero el código se descarga desde otra zona configurada para preguntar antes al usuario, se utilizará la configuración que establece que se pregunte al usuario.

Controles de secuencias de comandos de ActiveX marcados como seguros para ejecución
Esta opción determina si un control ActiveX marcado como seguro para secuencias de comandos puede interactuar con una secuencia de comandos. Tenga en cuenta que esta opción no afecta a los controles seguros para inicialización cargados con etiquetas PARAM. Esta opción se omite cuando en Inicializar y activar la secuencia de comandos de los controles de ActiveX no marcados como seguros está establecido como Activar, ya que esa configuración omite toda la seguridad del objeto. No puede utilizar secuencias de comandos con controles no seguros mientras bloquea las secuencias de comandos de los controles seguros.
Inicializar y activar la secuencia de comandos de los controles de ActiveX no marcados como seguros
Los controles ActiveX se clasifican como seguros o no seguros. Esta opción controla si una secuencia de comandos está autorizada para interactuar con controles no seguros. Los controles no seguros no se deben utilizar en páginas Web de Internet, aunque en algunos casos se pueden utilizar en páginas en las que tenga absoluta confianza y piense que no utilizarán los controles de forma perjudicial. Debe exigirse la seguridad del objeto a menos que se pueda confiar en todos los controles ActiveX y secuencias de comandos que pueden interactuar con las páginas de esta zona. La configuración es la siguiente:
Ejecutar controles y complementos ActiveX
Esta opción determina si se pueden ejecutar controles ActiveX y complementos en páginas de la zona especificada. Al deshabilitar esta opción se impide que se ejecute cualquier control o complemento ActiveX, por lo que se omiten las restantes opciones de configuración relacionadas con ActiveX . La descarga, ejecución y activación de secuencias de comandos de controles ActiveX son tres etapas diferenciadas y en cada una de ellas se aplican opciones distintas. Las opciones de descarga distinguen entre controles con firma y controles sin firma. Las opciones para la activación de secuencias de comandos se pueden definir por separado para controles seguros y no seguros. El hecho de que un control sea o no seguro para activar o inicializar secuencias de comandos depende del autor del control y no debe confundirse con la firma; las firmas y la seguridad son características distintas. Para obtener mas información, visite el sitio MSDN Online Web Workshop.
Descargar controles firmados para ActiveX
Esta opción permite a los usuarios descargar controles ActiveX firmados desde páginas de la zona. La configuración es la siguiente:
  • Activar permite a los usuarios descargar de forma "silenciosa" cualquier control firmado.
  • Pedir datos muestra una advertencia antes de que los usuarios descarguen controles firmados por entidades emisoras de certificados en las que no se confía. Esta opción permite a los usuarios descargar código firmado por entidades emisoras de confianza.
  • Desactivar impide que los usuarios puedan descargar ningún control firmado.
Descargar controles ActiveX no firmados
Esta opción permite a los usuarios descargar controles ActiveX no firmados desde páginas de la zona. Este tipo de código es potencialmente peligroso, especialmente cuando procede de una zona en la que no se confía.
  • Activar omite la seguridad del objeto. Los controles ActiveX se ejecutan, cargados con parámetros, y se activan como secuencias de comandos sin configurar la seguridad de los objetos para los datos o las secuencias de comandos que no sean de confianza. Esta opción no es aconsejable excepto en el caso de zonas seguras y administradas. Esta opción provoca la inicialización y ejecución de los controles seguros y no seguros, y la omisión de la opción Activar la secuencia de comandos de los controles de ActiveX marcados como seguros.
  • Pedir datos intenta exigir la seguridad del objeto. Sin embargo, si el control ActiveX no se puede considerar seguro para datos o secuencias de comandos que no sean de confianza, se ofrece al usuario la opción de permitir que se cargue el control con parámetros o en secuencias de comandos.
  • Desactivar exige la seguridad del objeto en los datos o secuencias de comandos que no sean de confianza. Los controles ActiveX que no puedan considerarse seguros no se descargarán con parámetros o en secuencias de comandos.

Descripción de Java

Permisos de Java

Para disponer de las opciones de Java, debe tener instalada la máquina virtual de Microsoft (Microsoft VM).

Estas opciones controlan la descarga y ejecución de código Java en la zona. En las descargas de Java, si se descarga un control desde un sitio diferente a aquel donde se utiliza la página, se utilizará la configuración de zona más restrictiva de los dos sitios. Por ejemplo, si un usuario tiene acceso a una página Web en una zona en la que está permitido descargar, pero el código se descarga desde otra zona configurada para preguntar antes al usuario, se utilizará la configuración que establece que se pregunte al usuario.

Cada opción de configuración determina lo siguiente:

  • El nivel máximo de permisos concedido silenciosamente a los subprogramas firmados descargados desde la zona.
  • Los permisos concedidos a los subprogramas no firmados que se descargan desde la zona.
  • Los permisos concedidos a las secuencias de comandos de páginas de la zona llamadas en los subprogramas.

Las cinco opciones son:

  • Personalizada controla la configuración de permisos individualmente. En el cuadro de diálogo Permisos personalizados, la ficha Sin firmar especifica los permisos para los subprogramas y secuencias de comandos no firmados de Java. La ficha Permitido sin advertencia previa especifica el umbral en que se concederán permisos silenciosamente a los subprogramas.
  • Seguridad baja permite a los subprogramas realizar todas las operaciones sin limitaciones.
  • Seguridad media permite a los subprogramas ejecutarse en su recinto de seguridad, un espacio de memoria fuera del cual el programa no puede hacer ninguna llamada. También se habilitan otras funciones como son el espacio para notas (un área de almacenamiento seguro en el equipo del cliente) y la entrada y salida de archivos controlada por el usuario.
  • Seguridad alta permite que los subprogramas se ejecuten en su recinto de seguridad.
  • Desactivar Java no permite la ejecución de subprogramas.

Descripción de la automatización

Automatización activa
Esta opción determina si se ejecutará el código de secuencias de comandos de las páginas de la zona.
Automatización de los subprogramas Java
Esta opción determina si las secuencias de comandos de la zona están autorizadas para usar objetos de subprogramas Java, lo que permite a las secuencias de comandos de la página interactuar con el subprograma Java.

Descripción de las descargas

Descargar archivos
Esta opción controla si se permite descargar archivos de la zona. Está determinada por la zona de la página que contiene el vínculo de descarga, no por la zona desde la que se descarga el archivo.
Descarga de fuentes
Esta opción determina si los usuarios pueden descargar fuentes HTML desde las páginas de esta zona.

Descripción de la autenticación de usuario

Inicio de sesión
La autenticación HTTP respeta la directiva de seguridad de la zona para las credenciales del inicio de sesión, que puede tener uno de estos cuatro valores:
  • Inicio de sesión automático sólo en la zona de Intranet. Pregunta el identificador y la contraseña de los usuarios de otras zonas. Una vez que se ha preguntado al usuario, se puede utilizar este valor silenciosamente durante el resto de la sesión.
  • Inicio de sesión anónimo. Desactiva la autenticación de HTTP; utiliza la cuenta de invitado sólo en el Sistema de archivos común de Internet (CIFS).
  • Pedir nombre de usuario y contraseña. Pide el Id. y la contraseña del usuario. Una vez que se ha preguntado al usuario, se puede utilizar este valor silenciosamente durante el resto de la sesión.
  • Inicio de sesión automático con el nombre de usuario y contraseña actuales. La respuesta de autenticación por desafío de Windows NT (NTLM), protocolo de autenticación entre el cliente del usuario final y el servidor de aplicaciones, probará silenciosamente la credencial de inicio de sesión antes de preguntar.

Descripción de la información miscelánea

Acceso a orígenes de datos de distintos dominios
Esta opción especifica si se debe permitir que los componentes que se conectan a orígenes de datos se puedan conectar a un servidor distinto para obtener datos. Esta opción se aplica sólo a enlaces de datos, como son los objetos activos de datos. La configuración es la siguiente:
  • Activar permite tener acceso a bases de datos de cualquier origen, incluso en otros dominios.
  • Pedir datos pregunta al usuario antes de permitir que tenga acceso a bases de datos en cualquier origen de otros dominios.
  • Desactivar permite tener acceso a bases de datos sólo en el mismo dominio que el de la página.
Enviar los datos no cifrados del formulario
Esta opción especifica si las páginas HTML de una zona pueden enviar o aceptar formularios de los servidores de la zona. Los formularios que se envían cifrados con codificación de Capa de sockets seguros (SSL, Secure Sockets Layer) siempre están permitidos; esta opción sólo afecta al envío de datos de formularios que no sean SSL.
Iniciar aplicaciones y archivos en IFrame
Esta opción controla si los usuarios pueden iniciar aplicaciones y archivos desde una etiqueta IFRAME, que contiene un directorio de una carpeta, en las páginas Web de esta zona.
Instalación de los componentes del escritorio
Esta opción controla si los usuarios pueden instalar componentes del escritorio desde páginas Web de esta zona.
Arrastrar y colocar o copiar y pegar archivos
Esta opción controla si los usuarios pueden arrastrar o copiar archivos desde páginas Web de esta zona.
Permisos de software
La configuración es la siguiente:
  • Seguridad baja permite:
  • Notificación de correo electrónico
  • Descarga automática
  • Instalación automática
  • Seguridad media permite:
  • Notificación de correo electrónico
  • Descarga automática
  • Seguridad alta permite:
  • Ninguna de las características de distribución de software

Descripción de las cookies

Habilitar cookies de sesión (no almacenados)
Determina la configuración de las cookies, archivos de texto donde se guardan las preferencias del usuario, que utilizan los sitios Web mientras los usuarios los visitan. Por ejemplo, esta opción determina si se permite crear un "carrito virtual de la compra" cuando un usuario compra en Internet. Las cookies de sesión no se conservan en el disco duro.

La configuración es la siguiente:

  • Activar significa que las cookies se aceptan automáticamente.
  • Pedir datos significa que se preguntará a los usuarios antes de que se cree una cookie.
  • Desactivar significa que no se pueden crear cookies. Si deshabilita las cookies de sesión, es posible que algunos sitios Web no funcionen correctamente.
Habilitar cookies que están almacenadas en el equipo
Determina la configuración para las cookies que se almacenan en el disco duro del usuario para futuras sesiones de exploración. Por ejemplo, esta configuración determina si se conserva una lista de preferencias o el nombre de un usuario para la siguiente visita de éste al sitio.

La configuración es la siguiente:

  • Activar significa que las cookies que permanecen se aceptan automáticamente.
  • Pedir datos significa que se preguntará a los usuarios antes de que se cree una cookie permanente.
  • Desactivar significa que no se puede crear cookies permanentes. Si deshabilita las cookies permanentes, algunos sitios Web no conservarán su configuración cuando el usuario vuelva a visitarlos.

Opciones de seguridad que no se pueden configurar

Las opciones siguientes son fijas y el usuario no puede configurarlas. La configuración de zona alta, media, media-baja y baja no cambia el comportamiento de estas opciones.

Iniciar desde Webview
Esta opción controla si los usuarios pueden iniciar programas y archivos desde una carpeta vista como una página Web. Esta configuración se aplica a usuarios de Windows 98 y a los que han actualizado el explorador desde Internet Explorer 4 y utilizan la Actualización del escritorio de Windows. La configuración viene determinada por la zona del contenido Web personalizado, no por la zona de la propia carpeta:
Mi PC | Intranet local | Sitos de confianza | Internet | Sitios restringidos
Habilitar | Habilitar | Habilitar | Pedir datos | Pedir datos


Administrar controles ActiveX

IEAK 5 incorporaba una nueva característica que permitía a los administradores especificar exactamente qué controles ActiveX se pueden ejecutar en una zona determinada. Hay dos situaciones principales en las que esta característica ofrece grandes posibilidades de control de la utilización de los controles ActiveX y, por lo tanto, un grado mayor de seguridad.

Situación 1: utilización limitada en Internet de controles ActiveX

Muchas organizaciones usan en gran medida los controles ActiveX en una intranet local, aunque desean limitar su uso fuera del servidor de seguridad (es decir, en la zona de Internet). Mientras que el contenido de la intranet local es de confianza y puede asegurarse que no hará un uso fraudulento de los controles que utilice, estos controles no son apropiados para ser utilizados en las páginas Web de Internet. Si se especifica un conjunto de controles genéricos aprobados por el administrador para ser utilizados en Internet, será posible tener acceso a sitios que utilicen controles al tiempo que se impide el uso incorrecto de otros controles en esa zona.

Por ejemplo, supongamos que como administrador desea limitar el uso de los controles ActiveX aunque desea permitir que un sitio importante de Internet (por ejemplo, el de una empresa asociada o un proveedor de servicios) pueda utilizar controles ActiveX. Visite el sitio, vea qué controles ActiveX utiliza y anote las entradas nuevas que aparecen en la carpeta Archivos de programa descargados de la carpeta Windows. Siga el procedimiento descrito al final de este tema para especificar que el uso de esos controles está aprobado por el administrador.

Cuando termine de configurar esta opción, sólo podrán ejecutarse en el sitio esos controles. De esta forma se impedirá que cualquier página de Internet utilice otros controles, como los destinados para su uso exclusivamente en la intranet.

Situación 2: uso restringido de los controles ActiveX

Puede tener un mayor grado de control si incluye en una lista todos los controles ActiveX aprobados y, después, sólo permite al explorador la ejecución de ese conjunto de controles. El costo de este nivel de control superior es el esfuerzo adicional que supone enumerar todos los controles que el administrador permite usar, por lo que este método sólo se recomienda cuando el conjunto de controles sea relativamente pequeño.

Evalúe qué controles se pueden utilizar en cualquier sitio. En las zonas que contienen sitios autorizados a usar esos controles, siga el procedimiento indicado al final de este tema para especificar que dichos controles están aprobados por el administrador. En las zonas que contengan sitios sin autorización para usar esos controles, active Deshabilitar en el área Ejecutar controles y complementos de ActiveX. De esta forma, en las páginas Web sólo se ejecutarán los controles especificados y únicamente en las zonas permitidas.

Elegir los controles ActiveX

Algunos controles ActiveX de uso generalizado aparecen enumerados en el archivo de controles activos aprobados por el administrador, Axaa.adm, que se incluye con el IEAK. Esta lista no es una recomendación; simplemente presenta algunos de los controles ActiveX más utilizados en el Web. Como administrador, debe evaluar si dichos controles pueden utilizarse en su organización. Puede modificar el archivo y agregar los controles que desee. De forma predeterminada, ninguno de los controles aparece como aprobado en la lista. Si desea agregar más controles después de que los usuarios instalen Internet Explorer, puede usar la configuración automática.

Para especificar controles a nivel del administrador

Para especificar que los controles ActiveX deben ser aprobados por un administrador y definir los controles que desea aprobar, realice las operaciones siguientes:

  1. Examine la configuración de los controles ActiveX en el archivo Axaa.adm, situado en la subcarpeta \Policies\<Idioma> de la carpeta del IEAK. Si desea agregar más controles a esta lista, como los controles que haya creado su organización, utilice un procesador de textos para modificar el archivo Axaa.adm.

    Es aconsejable efectuar una copia de seguridad de este archivo por si desea recuperar en el futuro la configuración original.

  2. En la pantalla Configuración de seguridad del Asistente para personalizar Internet Explorer 6, haga clic en Personalizar la configuración de zonas de seguridad y, después, haga clic en Modificar configuración.
  3. Seleccione la zona de contenido en la que desea administrar los controles ActiveX y, después, haga clic en Personalizar nivel.
  4. En el área Ejecutar controles y complementos ActiveX, haga clic en Aprobado por el administrador.
  5. Repita los dos últimos pasos hasta que haya configurado todas las zonas que desee.
  6. En la página Directivas y restricciones, de la Fase 5 del Asistente para personalizar Internet Explorer 6, haga clic en la categoría Administración de controles para expandir su contenido y, después, active las casillas de verificación de los controles que desee aprobar.


Firmar sus programas

Puede utilizar IEAK para firmar digitalmente sus paquetes personalizados. Las firmas digitales muestran la procedencia de los programas y comprueban que no han sido alterados. Firme sus paquetes personalizados de explorador y los programas personalizados para garantizar que los usuarios no reciban advertencias cuando instalen el explorador personalizado.

No obstante, antes deberá obtener un certificado digital con el que firmar los archivos. Al ejecutar el Asistente para personalizar Internet Explorer 6 deberá especificar la ubicación del certificado; de esta forma, se firmarán los archivos cuando se cree el paquete. Para obtener información acerca de cómo obtener un certificado digital, consulte la siguiente sección, "¿Cómo puedo obtener certificados digitales?"

Si piensa distribuir paquetes personalizados a través de Internet, deberá hacer que IEAK firme los archivos contenedores (.cab) personalizados que crea. Si piensa distribuir los paquetes personalizados a través de una intranet, firme los archivos personalizados o configure previamente la zona de intranet local con un nivel bajo de seguridad. La configuración de seguridad predeterminada no permitirá a los usuarios descargar programas o código sin firmar. Para obtener más información acerca de las zonas de seguridad, consulte Seguridad de Internet Explorer.

Se firmarán los archivos personalizados siguientes:

Nombre del archivo | Función del archivo
Branding.cab | Información de marca para el programa de instalación de Windows Update
Desktop.cab | Actualización del escritorio de Windows
Iecif.cab | Identifica qué componentes de Microsoft Internet se han instalado como parte de la instalación de Windows Update
IE5setup.exe | Programa de instalación de Windows Update
Custom<n>.cab | Componentes personalizados instalados después de haber reiniciado el sistema. Cada componente se empaqueta en un archivo contenedor (.cab) independiente y numerado.

Para ver un organigrama en el que se muestra cómo el Asistente para personalizar Internet Explorer 6 crea estos archivos, consulte Cómo genera IEAK los paquetes personalizados.

Notas

  • Es posible que los usuarios no puedan instalar controles ActiveX y paquetes de Java que no estén firmados..
  • También debe firmar cualquier programa personalizado, tanto en formato .exe como .cab, que incluya en su paquete del explorador.
  • Si piensa que su organización utilizará la función Instalación a petición a través de Internet, debe firmar los archivos .cab y especificar en la configuración de seguridad que el servidor que aloja esos archivos es de confianza. En el caso específico de un sitio de intranet, puede seleccionar también un nivel bajo de seguridad. Para obtener más información acerca de esta característica, consulte Administrar la instalación a petición.

Para especificar que los servidores de su red son de confianza

Si el nivel de seguridad de la intranet es Media o superior, deberá especificar que los servidores de red son servidores en los que se confía. Para ello, siga estos pasos:

  1. En la página Configuración de seguridad del asistente, haga clic en Importar la configuración actual de las zonas de seguridad y, después, haga clic en Modificar configuración.
  2. Seleccione la zona Intranet local y, después, haga clic en Sitios.
  3. Desactive la casilla de verificación Incluir todas las rutas de red (UNCs) y haga clic en Aceptar.
  4. Seleccione la zona Sitios de confianza, haga clic en Sitios, escriba la ruta del servidor de descarga y, después, haga clic en Agregar.
  5. Repita el paso anterior para cada servidor de descarga que desee especificar como servidor de confianza.

Obtener certificados digitales

Los certificados digitales forman parte de la tecnología Authenticode, que identifica la procedencia de los programas y comprueba que no hayan sufrido alteraciones. Para obtenerlos, puede solicitarlos a una entidad emisora de certificados o a un servidor de certificados de control privado. Los certificados pueden ser comerciales o individuales.

Para obtener más información acerca de Authenticode y la seguridad, visite el sitio Web Microsoft Security Advisor en http://www.microsoft.com/security/.

Firmar archivos contenedores o programas personalizados

Después de obtener un certificado tendrá que firmar el código. Las herramientas para firmar código están disponibles en el sitio Microsoft Site Builder Network Workshop.

También necesitará conocer las claves públicas y privadas, que son un conjunto de claves coincidentes que crea la compañía de software para el cifrado y el descifrado. Las claves se generan en el momento en que se solicita el certificado a la entidad emisora de certificados (CA). Se generan en el equipo del usuario y la clave privada no se envía nunca a la CA ni a ningún tercero.

Trabajar con certificados con caducidad

La caducidad de los certificados es una medida adicional de seguridad. Por ejemplo, si una universidad certifica a todos sus alumnos con identificadores digitales (Id.), puede establecer que cada identificador caduque cuando el alumno deje la universidad. El código firmado con un certificado caducado no es válido. Cuando el certificado caduca, la compañía de software debe volver a firmar el código y publicar nuevas versiones de éste.

Las compañías de software pueden incluir una marca de hora al firmar el código con el fin de probar que el certificado era válido en el momento en que se firmó el código. De esta forma, el código firmado seguirá siendo válido después de que el certificado haya caducado.

Utilizar Authenticode para controlar qué ven los usuarios

Si es un administrador corporativo, puede preconfigurar las zonas de seguridad, preestablecer las restricciones y personalizar las entidades emisoras de certificados. También puede definir directivas del sistema y restricciones para controlar si los usuarios podrán modificar o no la configuración de la seguridad. Para obtener información acerca de configuraciones específicas, consulte Opciones de seguridad de Internet Explorer.

Puede garantizar que los usuarios recibirán advertencias cuando intenten ver contenido potencialmente inseguro. También puede evitar que los usuarios descarguen controles ActiveX y paquetes de Java sin firmar.

Qué ocurre cuando firma su código

La firma de código es un proceso sencillo y rápido. Para firmar su código no es necesario conocer los detalles técnicos acerca del procedimiento.

Después de desarrollar y probar el código, la compañía de software firma el archivo de código. La compañía utiliza un programa de firma, como puede ser Signcode.exe, que ejecuta un algoritmo de hash con el código y crea un "resumen" del archivo. A través de la capa del sistema operativo, el programa cifra ese resumen con la clave privada, y lo combina con el nombre del algoritmo de hash y con el certificado de la CA (que contiene el nombre de la compañía, su clave pública, etc.) y forma así una estructura que se denomina bloque de firma. El programa inserta entonces ese bloque en el archivo de código, con lo que éste queda listo para su distribución a través de Internet. Tenga en cuenta que un archivo .cab firmado incluye también un bloque de firma.

Cuando el usuario descarga el archivo desde Internet, la aplicación que realiza la descarga llama a una función de comprobación. Como consecuencia de esa llamada, el sistema operativo extrae el bloque de firma, determina qué CA validó el certificado y utiliza la clave pública para descifrar el resumen. El sistema utiliza después el algoritmo de hash indicado en el bloque de firma para crear un segundo resumen. Si el código no se modificó desde que se firmó, el resumen nuevo debe coincidir con el antiguo. Si los dos resúmenes no coinciden, significa que el código se ha modificado o que las claves pública y privada no coinciden. En ambos casos, el código se convierte en sospechoso y se advierte al usuario.


Administrar Microsoft Internet Explorer en Windows 2000 y Windows XP

Puede utilizar Directiva de grupo para personalizar Microsoft Internet Explorer en equipos con Windows 2000 y Windows XP después de la implementación. Por ejemplo, es posible definir la página principal del usuario y personalizar sus vínculos favoritos. Directiva de grupo permite a los administradores de Windows 2000 y Windows XP controlar la configuración de usuarios y equipos en sitios, dominios y unidades de organización.

El método de inicio de Directiva de grupo depende del tipo de grupo que desee administrar. Para obtener más información acerca de cómo iniciar Directiva de grupo, consulte la Ayuda en pantalla de Directiva de grupo en Windows 2000 y Windows XP.

Para usar Directiva de grupo para mantener y personalizar Internet Explorer

  1. En Directiva de grupo, haga clic en Configuración de usuario.
  2. Haga clic en Configuración de Windows y, después, en Mantenimiento de Internet Explorer.
  3. Seleccione el icono de la característica que desea cambiar.
  4. Haga doble clic en el título de la característica que desea administrar.
  5. Cambie las opciones de configuración que desee.

Notas

  • Si utiliza el Administrador de perfiles de IEAK para administrar Internet Explorer en otras plataformas con configuración automática, puede exportar la configuración de Directiva de grupo a un archivo .ins y, en caso necesario, a archivos contenedores (.cab). De esta manera, si define la configuración en Windows 2000 o Windows XP, no será necesario que vuelva a hacerlo para utilizarla en otras plataformas.
  • Si utiliza el Kit de instalación previa OEM, puede usar el Asistente para personalizar Internet Explorer 6 para personalizar Windows 2000 o Windows XP antes de la implementación.
  • Si utiliza el programa de instalación desatendida de Windows 2000 o Windows XP, puede utilizar el Adminsitrador de perfiles de IEAK para generar los archivos necesarios para asignar una marca al explorador. Para obtener más información, consulte la documentación de Windows 2000 o Windows XP.

Para exportar la configuración de Directiva de grupo para Internet Explorer

Puede utilizar Directiva de grupo en Windows 2000 o Windows XP para exportar toda la configuración de Internet Explorer a un archivo .ins y, si es necesario, a archivos contenedores (.cab). Posteriormente podrá utilizar dicha configuración para configurar automáticamente equipos con otros sistemas operativos.

Para exportar la configuración de Internet Explorer en Windows 2000 o Windows XP

  1. En Directiva de grupo, haga clic en Configuración de usuario.
  2. Haga clic en Configuración de Windows y, después, haga clic con el botón secundario del mouse (ratón) en la pantalla de Internet Explorer que contenga la configuración que desea exportar.
  3. Haga clic en Exportar configuración del explorador.
  4. Escriba el nombre del archivo .ins y, si procede, de los archivos contenedores (.cab) a los que desea exportar la configuración.
  5. Escriba la dirección URL del servidor Web donde se encuentran los archivos.

Usar Directiva de grupo para configurar las características

Mediante Directiva de grupo es posible personalizar y administrar las siguientes áreas:

  • La interfaz del usuario y la apariencia del explorador
  • Configuración de las conexiones, como las de red de área local (LAN) y acceso telefónico, y las cadenas de agente del usuario
  • Direcciones URL personalizadas, como Favoritos, la barra de búsqueda y la página principal
  • Configuración de la seguridad, por ejemplo, zonas de seguridad y de las clasificación de contenidos
  • Programas predeterminados para tareas frecuentes de Internet, como la lectura de correo electrónico y el acceso a grupos de noticias

Importante

  • Independientemente de las opciones de instalación configuradas para el paquete, el programa de instalación de Windows Update sólo presenta una opción de instalación para los usuarios que ejecuten el sistema operativo Windows 2000 o Windows XP. Esta opción incluye todos los componentes de Internet de Microsoft, además de los componentes personalizados incluidos en el paquete.


Administrar la instalación a petición

Al instalar Internet Explorer, los usuarios pueden elegir los componentes que deseen para controlar el espacio en disco utilizado y reducir el tiempo de descarga y de instalación. Sin embargo, cuando comienzan a explorar el Web pueden descubrir que necesitan componentes adicionales.

Cuando los usuarios visitan una página Web que precisa de un programa o componente no instalado, el programa de instalación a petición les pregunta si desean instalar dichos componentes.

Como administrador corporativo o ISP, puede controlar esta característica mediante el IEAK.

Nota

  • Si piensa que su organización utilizará la función de instalación a petición a través de Internet, debe firmar los archivos .cab y especificar en la configuración de seguridad que el servidor que aloja los archivos .cab es de confianza. En el caso específico de un sitio de intranet se puede seleccionar también un nivel bajo de seguridad. Para obtener más información, consulte Firmar sus programas.

Para especificar que los servidores de su red son de confianza

Si el nivel de seguridad de su intranet es medio o superior, y está especificando los servidores de red como servidores de confianza, tendrá que hacer lo siguiente:

  1. En la página Configuración de seguridad del asistente, haga clic en Personalizar la configuración de zonas de seguridad y, después, haga clic en Modificar configuración.
  2. Seleccione la zona Intranet local y, después, haga clic en Sitios.
  3. Desactive la casilla de verificación Incluir todas las rutas de red (UNCs) y haga clic en Aceptar.
  4. Seleccione la zona Sitios de confianza, haga clic en Sitios, escriba la ruta del servidor de descarga y, después, haga clic en Agregar.
  5. Repita el paso anterior para cada servidor de descarga que desee especificar como servidor de confianza.


Referencias del IEAK

Para obtener información general acerca del IEAK, consulte los temas siguientes:

  • Administrar Microsoft Internet Explorer en Windows 2000 y Windows XP
  • Marcas y gráficos personalizados
  • Seguridad de Internet Explorer
  • Redistribuir Internet Explorer
  • Ejecutar la instalación por lotes
  • Actualizar periódicamente a los usuarios
  • Instalación de Windows Update para Internet Explorer y otras herramientas para Internet
  • Trabajar con archivos de información para la instalación (.inf)
  • Tipos de archivo
  • Configurar la búsqueda automática
  • Personalizar la barra y el ayudante de búsqueda

Recursos adicionales

Para examinar los últimos recursos y actualizaciones de la tecnología, visite los sitios Web siguientes:

  • El sitio Web del IEAK
  • El sitio Web de Microsoft Security Advisor
  • MSDN Online Web Workshop
  • El sitio Web Corporate Windows Update


Configurar la búsqueda automática

Es posible personalizar la búsqueda automática para que los usuarios escriban una palabra coloquial en el cuadro Dirección y busquen en las páginas usadas con más frecuencia en Internet Explorer. Los usuarios no necesitan recordar las direcciones URL de las páginas que especifique, por lo que la información clave será más fácil de encontrar.

Por ejemplo, podría configurar una página Web de facturación de modo que aparezca cuando un usuario escriba factura en el cuadro Dirección, aunque la dirección URL de la página no incluya dicho término. Si es administrador corporativo, el tema siguiente le muestra cómo puede personalizar la búsqueda automática. Si es proveedor de contenido Internet o proveedor de servicios Internet, envíe un mensaje de correo electrónico a autosrch@microsoft.com para obtener más información.

Esta característica ya está habilitada para Internet. Por ejemplo, al escribir términos muy utilizados e inconfundibles en el cuadro Dirección, aparecerá el sitio Web asociado con dicho término. Cuando no se puede asociar claramente un sitio Web con un término, por ejemplo, si hay varias coincidencias importantes, se muestra una página Web que presenta los resultados con un mayor grado de coincidencia.

El sitio Web que aparece no tiene que contener, necesariamente, el término exacto que se busca en su dirección URL. Si un sitio Web cuyo dominio coincide con el término no coincide exactamente con el término de la búsqueda (por ejemplo, si éste coincide con la dirección URL sin "www." y ".com"), se redirigirá al usuario al sitio que más concuerde con dicho término. De manera predeterminada, se informa al usuario cuando se va a producir una redirección.

Para instalar la búsqueda automática

  1. Cree un archivo de comandos (.ASP) que compruebe condicionalmente los términos de la búsqueda y los envíe a un servidor de intranet en la siguiente ubicación:

    http://ieautosearch/response.asp?MT=%1&srch=%2

    Consulte Parámetros para configurar la dirección URL de búsqueda automática más abajo para ver una descripción de los parámetros %1 y %2.

    En caso de que no use Servicios de Internet Information Server (IIS), deberá reasignar esta dirección URL a la dirección donde se encuentra la secuencia de comandos.

  2. Si está configurando esta opción mediante el Asistente para personalizar Internet Explorer 6, en la pantalla Directivas y restricciones de la Fase 5, haga clic en Configuración de Internet.

    —O bien—

    Si establece esta opción con el Administrador de perfiles, haga clic en Directivas y restricciones y, después, en Configuración de Internet.

  3. Haga clic en Configuración avanzada y, a continuación, en Buscando, en el cuadro Palabra clave del proveedor de búsqueda, escriba intranet.

Notas

  • Puede utilizar directivas y restricciones para redirigir a los usuarios a otro sitio en lugar de proporcionar resultados de búsqueda. Para ello, haga clic en Opciones avanzadas. En Buscando, en el cuadro Al buscar desde la barra de direcciones, seleccione Ir al sitio más probable.
  • Si es administrador corporativo en una organización sin acceso a Internet y no va a personalizar la búsqueda, quizás prefiera usar directivas y restricciones para deshabilitar la búsqueda automática. Para ello, haga clic en Opciones avanzadas. En Buscando, en el cuadro Al buscar desde la barra de direcciones, seleccione No buscar nunca desde la barra de direcciones.

Parámetros para configurar la dirección URL de búsqueda automática

Para configurar la dirección URL de búsqueda automática http://ieautosearch/response.asp?MT=%1&srch=%2, reemplace los dos parámetros marcados con el símbolo de porcentaje (%). Ambos valores deben formar parte de la dirección URL.

Parámetro | Valor
%1 | La cadena que el usuario escribe en el cuadro Dirección.
%2 | Tipo de búsqueda elegido por el usuario.
 | 3 | Mostrar los resultados e ir al sitio más probable.
 | 2 | Ir al sitio más probable.
 | 1 | Mostrar los resultados en la ventana principal.
 | 0 | No buscar desde el cuadro Dirección.

Ejemplo de secuencia de comandos de búsqueda automática .asp

<%@ Language=VBScript %>

<%
' la búsqueda mantiene las palabras escritas en la barra Dirección
' por el usuario, sin "go",
' "find" ni ningún delimitador como
' "+" para espacios.
' Si el usuario escribió
' "Pastel de manzana," search = "Pastel de manzana."
' Si el usuario escribió
' "buscar Pastel de manzana," search = "Pastel de manzana."
search = Request.QueryString("MT")
search = UCase(search)
searchOption = Request.QueryString("srch")

' Se trata de un sencillo proceso if/then/else
' para redirigir el explorador al sitio
' que usted elija según lo que el
' usuario haya escrito.
' Ejemplo: expense report es una página de intranet
' que proporciona información acerca de cómo rellenar un informe de gastos
if (search = "NEW HIRE") then
Response.Redirect("http://admin/hr/newhireforms.htm")
elseif (search = "LIBRARY CATALOG") then
Response.Redirect("http://library/catalog")
elseif (search = "EXPENSE REPORT") then
Response.Redirect("http://expense")
elseif (search = "LUNCH MENU") then
Response.Redirect("http://cafe/menu/")
else
' Si no hay ninguna coincidencia, use el
' servidor de búsqueda automática de IE predeterminado
Response.Redirect("http://auto.search.msn.com/response.asp?MT="
+ search + "&srch=" + searchOption +
"&prov=&utf8")
end if

%>


Personalizar la barra y el Asistente para buscar

La barra de búsqueda permite a los usuarios iniciar búsquedas y ver los resultados. Cuando el usuario hace clic en el botón Búsqueda, aparece la barra de búsqueda en una zona a la izquierda del explorador.

El Asistente para buscar de Microsoft Windows se abre en la barra de búsqueda y proporciona a los usuarios la capacidad de realizar una búsqueda sencilla y unificada utilizando diferentes tipos de búsqueda. Incluye botones de opción que permiten a los usuarios especificar el tipo de información que están buscando en lugar del motor de búsqueda que desean usar.

El usuario puede personalizar Internet Explorer de modo que la barra de búsqueda utilice un único motor de búsqueda. Como alternativa, un proveedor de servicios Internet o administrador corporativo puede personalizar la barra de búsqueda de modo que satisfaga las necesidades de su organización mediante JScript (compatible con las especificaciones de lenguaje ECMA 262), Visual Basic Scripting Edition (VBScript), controles ActiveX, HTML dinámico, conjuntos de marcos, hojas de estilos en cascada (CSS) y otras tecnologías compatibles con el explorador Internet Explorer. Especifique la dirección URL para la barra de búsqueda en la pantalla Direcciones URL importantes de la Fase 4 del Asistente para personalizar Internet Explorer 6.

Los resultados de la búsqueda aparecen generalmente en la barra de búsqueda. Para los usuarios es muy importante poder usar fácilmente los resultados de cualquier servicio de búsqueda. Puede usar la funcionalidad de la barra de búsqueda para almacenar información detallada como resúmenes de texto, direcciones URL o tamaños de archivo. Esta información se muestra en la información sobre herramientas que aparece cuando el puntero del mouse (ratón) pasa sobre un resultado. La información sobre herramientas mantiene la sencillez de la página de resultados, proporcionando al mismo tiempo información más detallada al usuario.

Instrucciones para personalizar la interfaz de usuario de la barra de búsqueda

Éstas son algunas pautas que puede seguir al diseñar su propia barra de búsqueda.

  • Las páginas de resultados siempre deben proporcionar la posibilidad de iniciar una nueva búsqueda, con botones para modificar y ejecutar la búsqueda dentro del 20 por ciento superior del área de contenido.
  • Las páginas deben ajustarse al ancho de 200 píxeles de la barra de búsqueda. Si utiliza tablas u otros elementos de formato HTML, asegúrese de que se ajustan al ancho disponible. De lo contrario, hará que se muestren las barras de desplazamiento horizontales, que quitan espacio al contenido y obligan al usuario a realizar más trabajo. Si desea incluir más resúmenes u otra información sin usar espacio adicional, puede utilizar la información sobre herramientas.
  • Puede usar HTML dinámico, tecnología ActiveX, Java y hojas de estilos en cascada para obtener efectos dinámicos e implementar multimedia. Recuerde que el espacio para la barra de búsqueda es limitado.
  • El tamaño predeterminado de la barra de búsqueda es 200 píxeles de ancho y el alto del tamaño vertical total de la ventana del explorador es 430 píxeles. Esta área puede incluir anuncios o marcas, así como información de búsqueda, según sus requisitos. El usuario puede cambiar el tamaño de esta área.
  • Puesto que la barra de búsqueda es un espacio limitado, debe establecer prioridades en la interfaz de usuario. La regla básica es proporcionar al usuario la mejor información sin crear desorden o confusión visual. Desde el principio al final de la página, la interfaz seguiría este orden:
    • Su marca
    • Campos de consulta de búsqueda que puedan redefinirse
    • Los resultados de la búsqueda
    • Anuncios u otros servicios

    Se recomienda que coloque los anuncios hacia el final de la página, de forma que los usuarios no tengan que desplazarse más allá de ellos para ver los resultados de la búsqueda.

  • Si la página requiere que el usuario se desplace, asegúrese de que una cantidad importante de resultados reales, no de categorías de resultados, es visible de forma inmediata.
  • Los vínculos para los resultados de la búsqueda, o "coincidencias", se muestran normalmente en la barra de resultados. Cuando un usuario hace clic en cualquiera de estos vínculos, la página Web debe aparecer en el área principal del explorador. Evite abrir las páginas Web en la barra de búsqueda, ya que no contiene los botones Atrás y Siguiente.

Técnicas para personalizar el Asistente para buscar

El Asistente para buscar se puede personalizar para que satisfaga necesidades específicas. Por ejemplo, se puede almacenar información adicional acerca de los resultados de la búsqueda dentro de la información sobre herramientas y es posible destacar los resultados de la búsqueda en una página Web determinada.

Destacar coincidencias encontradas

El método NavigateAndFind puede utilizarse para buscar en páginas Web una palabra o frase. Este método carga una página Web especificada y busca en el documento una coincidencia con la cadena suministrada. Si se encuentra, la cadena que coincide se resalta en el documento.

Ejemplo

En el ejemplo siguiente se abre el sitio Web de Microsoft y se buscan las palabras "Microsoft Corporation".

window.external.NavigateAndFind("http://www.microsoft.com","Microsoft Corporation");

Información sobre herramientas y resúmenes de vínculos

Para ayudar a ahorrar espacio en la ventana del explorador y mejorar la legibilidad de los resultados de búsqueda, Internet Explorer permite definir información específica acerca de un vínculo determinado que se debe incluir en la información sobre herramientas. Para ello, defina el atributo TITLE de una etiqueta de marcador de HTML.

Ejemplo

En el ejemplo siguiente se ofrece más información acerca del vínculo:

<A HREF="http://www.adventure-works.com/" TITLE="Las noticias deportivas y clasificaciones más recientes,
actualizadas cada hora. Entrevistas con los jugadores de los equipos ganadores">Últimas noticias deportivas</A>

Señale a este vínculo para ver cómo aparecerían los resultados: Últimas noticias deportivas

Forzar saltos de línea en la información sobre herramientas

La información sobre herramientas introduce líneas nuevas automáticamente a unos ocho centímetros (tres pulgadas) y puede contener, como mínimo, un párrafo de texto. No obstante, dentro del texto de la información sobre herramientas no se permite más de 1024 caracteres. También puede forzar una nueva línea o espacios de tabulación en el resumen si utiliza los caracteres reservados &#10; y &#13 para retorno de carro y avance de línea, y &#09 para los espacios de tabulación.

Ejemplo

En el ejemplo siguiente se incluye un retorno de carro y un avance de línea después de la línea 1 de la información sobre herramientas:

<A HREF="http://www.microsoft.com"
 TITLE="Texto mostrado en la línea1&#10;&#13;
 Texto mostrado en la línea2&#10;
 &#09;Texto mostrado en la línea3&#10;
 &#09;Texto mostrado en la línea4">
Usar varias líneas en la información sobre herramientas</A>

Señale a este vínculo para ver cómo aparecerían los resultados: Usar varias líneas en la información sobre herramientas

Para obtener más información acerca de las secuencias de comandos y HTML dinámico, visite el sitio MSDN Online Web Workshop.


Crear gráficos personalizados

Antes de preparar los gráficos que se van a utilizar como logotipo, debe consultar el contrato de su licencia para comprobar que puede realizar legalmente la personalización.

Programa de instalación de Windows Update

Gráfico | Tamaño y tipo | Notas adicionales
Vertical izquierdo | Archivo .bmp en 256 colores de 162 por 312 píxeles | El icono vertical aparece en la primera página del Asistente para la instalación de Windows Update.
Superior horizontal | Archivo .bmp en 256 colores de 496 por 56 píxeles | El icono horizontal aparece en todas las páginas del asistente después de la primera página. El título horizontal superior tiene que ser de tonos muy claros, como una "marca de agua", para que sea legible el texto de la interfaz de usuario.

Explorador Internet Explorer

Para ver un ejemplo de la ubicación de los distintos gráficos en el explorador personalizado, consulte Cómo funciona la personalización.

Gráfico | Tamaño y tipo | Notas adicionales
Logotipo estático Archivos .bmp de 38 x 38 píxeles y
22 x 22 píxeles 		Cree dos mapas de bits de 256 colores (38 x 38 píxeles y 22 x 22 píxeles). Guarde los archivos en la carpeta de mapas de bits personalizados (CIE\Bitmaps). Cuando el explorador no esté activo se utilizará como logotipo estático el primer cuadro del logotipo animado.
Logotipo animado Archivos .bmp de 38 por 38 píxeles y
22 por 22 píxeles para cada marco de la animación 		Para cada marco de la animación, cree dos mapas de bits de 256 colores (38 por 38 píxeles y 22 por 22 píxeles). Guarde los archivos en la carpeta de mapas de bits personalizados (CIE\Bitmaps). Cuando el explorador no esté activo se utilizará como logotipo estático el primer cuadro del logotipo animado.

Use las Herramientas para mapas de bits animados de IEAK para apilar los mapas de bits en el formato correcto y generar el logotipo animado. El logotipo animado debe contener una pila vertical de imágenes en celdas de animación que cumplan las reglas de animación de Internet Explorer.

Reglas de animación para el logotipo de Internet Explorer

  • Las celdas 1 a 4 son celdas de introducción que se reproducen cuando Internet Explorer comienza la exploración.
  • Las celdas 5 a X, donde X es el número total de celdas, se reproducen en bucle hasta que finaliza la operación.
Fondo de la barra de herramientas | Sin dimensiones específicas | El fondo debe tener el tamaño de la barra de herramientas y ser lo suficientemente claro para poder mostrar texto en negro.
Botón de la barra de herramientas del explorador | Dos archivos de icono con imágenes en blanco y negro, y en color para los estados activo e inactivo | Para obtener más información, consulte Diseñar iconos de la barra de herramientas para Internet Explorer.
Iconos para la lista Favoritos | Un archivo .bmp de 16 x 16 píxeles para cada elemento que desee personalizar
Pantalla inicial del programa de ejecución automática, si distribuye el paquete personalizado en un CD. | Mapa de bits de 540 por 357 píxeles, mostrado cuando el usuario inserta el CD | Antes de crear la pantalla de inicio, debe convertir las imágenes de 24 bits a la paleta común de 256 colores. Consulte Crear un mapa de bits para la pantalla inicial del programa de ejecución automática para obtener más información.

Asistente para la conexión a Internet y suscripción a Internet

Gráfico | Tamaño y tipo
Imagen superior que aparece en la esquina superior derecha del Asistente para la conexión a Internet. | archivo .bmp de 49 por 49 píxeles
Imagen vertical que aparece en la esquina superior izquierda de las pantallas del Asistente para la conexión a Internet. | archivo .bmp de 164 por 458 píxeles

Nota

  • El Asistente para la conexión a Internet no está disponible para el método de suscripción sin servidor.

Servicio de directorio de la Libreta de direcciones de Windows (en Outlook Express)

Tamaño y tipo | Notas adicionales
archivo .bmp de 134 por 38 píxeles | Use la paleta de 16 colores de Windows


Herramientas para mapas de bits animados

Antes de preparar los gráficos que se van a utilizar como logotipo, debe consultar el contrato de licencia para confirmar que puede realizar legalmente dicha personalización.

IEAK incluye dos herramientas diferentes que le ayudan a crear mapas de bits animados personalizados para el explorador.

  • Animated Bitmap Creator toma una serie de mapas de bits numerados secuencialmente y los combina en un mapa de bits con el formato adecuado para la animación.
  • Animated Bitmap Previewer proporciona una vista previa del mapa de bits animado. Esta herramienta puede utilizarse también para mostrar cualquier mapa de bits que tenga un formato correcto.

Asegúrese de utilizar el tamaño y el formato correctos para los mapas de bits. Para obtener más información, consulte Crear gráficos personalizados.

Nota

  • Estas herramientas se incluyen para ayudar al administrador y no deben distribuirse como productos con soporte de Microsoft. Ambas se encuentran en la carpeta \<carpeta de programa IEAK>\Toolkit\Graphics\Tools.

Animated Bitmap Creator (Makebmp.exe)

Para ejecutar esta herramienta, escriba el comando siguiente en el símbolo del sistema MS-DOS:

makebmp nombreBase númeroArchivos nombreSalida

Elemento de sintaxis | Significado
makebmp | Nombre de la herramienta
nombreBase | Nombre raíz utilizado en todos los archivos (sin números ni la extensión .bmp)
númeroArchivos | Número de mapas de bits que se agregarán secuencialmente al archivo de animación
nombreSalida | Nombre del archivo de salida (debe incluir la extensión de archivo .bmp)

Ejemplo

Para combinar los archivos desde Bitmap0.bmp hasta Bitmap19.bmp, escriba lo siguiente:

makebmp bitmap 20 final.bmp

Nota

  • Numere secuencialmente los archivos a partir de 0. Por ejemplo, Iebmp0.bmp Iebmp1.bmp Iebmp2.bmp … Iebmp24.bmp. El nombre base de estos 25 archivos es Iebmp.

Animated Bitmap Previewer (Animbmp.exe)

Puede iniciar el programa de vista previa desde el símbolo del sistema MS-DOS o desde el Explorador de Windows. Después de iniciar Animbmp.exe, hay dos formas de obtener una vista previa de un mapa de bits animado: arrastrar el archivo al cuadro o hacer clic en el menú Archivo y, después, en Abrir. Los marcos de introducción sólo aparecen una vez, mientras que los mapas de bits se muestran continuamente y de forma cíclica.


Crear un mapa de bits para la pantalla de bienvenida del programa de ejecución automática

En estas instrucciones se supone que usted parte de archivos de mapa de bits RGB de 24 bits. Si el archivo no es de este tipo, debe convertirlo en primer lugar.

  1. Crear una imagen de mapa de bits de 256 colores (540 x 357 píxeles).

    Este mapa de bits debe proporcionar una introducción al producto e incluir etiquetas para dos botones: una para instalar Internet Explorer y otra para mostrar más información.

  2. En un programa para gráficos, cree un archivo de trabajo para la paleta. Para ello, pegue sus archivos de botón y de fondo en un único archivo. Asegúrese de que pega los archivos uno junto a otro, sin que se superpongan.
  3. Guarde el archivo como Palette.bmp.

Nota

  • Las dimensiones del mapa de bits son importantes, ya que el cuadro de diálogo cambiará de tamaño para ajustarse a ellas. Si el mapa de bits no es lo suficientemente ancho, el texto del cuadro de diálogo puede aparecer recortado.


Diseñar iconos de barra de herramientas para Internet Explorer

Para crear un icono de barra de herramientas, tendrá que proporcionar cada imagen en dos tamaños distintos para los dos estados de la barra de herramientas (en escala de grises para el estado predeterminado y en color para el estado activo, cuando el usuario hace clic en él con el mouse (ratón)) y en dos profundidades de color.

Para crear sus imágenes

  1. Después de dibujar las imágenes con un programa de gráficos, coloque las de 16 y 256 colores en dos archivos independientes.
  2. Cada archivo debe tener como índice la paleta correspondiente, ya sea la paleta de 16 colores de Windows o la de medio tono. Reserve un color específico para denotar transparencia.
  3. Guarde cada archivo como un archivo .bmp.

A continuación se incluye un resumen de las imágenes necesarias:

Icono de estado Tamaño en píxeles Profundidad y paleta de colores Borde Apariencia Ejemplo
Activo 20 por 20 píxeles Paleta de medio tono de 256 colores de Windows Borde de estilo de icono: color en los bordes superior e izquierdo y color negro en los bordes inferior y derecho
  • Imagen en color
  • Más sombreado y profundidad visual que la imagen de 16 colores
  • Una fuente de luz desde la parte superior izquierda y sombreado donde proceda
 Estado activo: 256 colores, 20 por 20 píxeles
20 por 20 píxeles Paleta de 16 colores de Windows Negro, excepto cuando un borde interfiera con la legibilidad del icono
  • Imagen en color
  • Poco sombreado, apariencia plana
 Estado activo: 16 colores, 20 por 20 píxeles
16 por 16 píxeles Paleta de 16 colores de Windows Negro, excepto cuando un borde interfiera con la legibilidad del icono
  • Imagen en color
  • Poco sombreado, apariencia plana
 Estado activo: 16 colores, 16 por 16 píxeles
Predeterminado 20 por 20 píxeles Paleta de medio tono de 256 colores de Windows Borde de estilo de icono: tonos grises en los bordes superior e izquierdo y color negro en los bordes inferior y derecho
  • Imagen en escala de grises
  • Más sombreado y profundidad visual que la imagen de 16 colores
  • Una fuente de luz desde la parte superior izquierda y sombreado donde proceda
 Estado predeterminado: 256 colores, 20 por 20 píxeles
20 por 20 píxeles Paleta de 16 colores de Windows Negro, excepto cuando un borde interfiera con la legibilidad del icono
  • Imagen en escala de grises
  • Poco sombreado, apariencia plana
 Estado predeterminado: 16 colores, 20 por 20 píxeles
16 por 16 píxeles Paleta de 16 colores de Windows Negro, excepto cuando un borde interfiera con la legibilidad del icono
  • Imagen en escala de grises
  • Poco sombreado, apariencia plana
 Estado predeterminado: 16 colores, 16 por 16 píxeles

Asegúrese de que las transiciones visuales entre las imágenes predeterminada y activa del icono son suaves. Un sistema fácil para comprobarlo consiste en crear capas separadas para las imágenes predeterminada y activa en un programa de tratamiento de imágenes fotográficas, de forma que pueda ver ambas imágenes superpuestas.

Para convertir las imágenes de mapas de bits en iconos

Tendrá que crear dos archivos .ico para cada icono:

  • El primer archivo .ico contiene las imágenes activas (en color) para ambos tamaños y profundidades de color.
  • El segundo archivo .ico contiene las imágenes predeterminadas (en escala de grises) para ambos tamaños y profundidades de color.

Para crear los archivos .ico, se recomienda utilizar un programa de gráficos para dibujar los iconos y un entorno de desarrollo, como Microsoft Visual C++ Development Studio.

Ejemplo

Los dos archivos del icono Inicio contienen las siguientes imágenes:

Estado activo | Estado predeterminado
Icono para estado activo | Icono para estado predeterminado

Para crear los archivos de icono en Visual C++

  1. Abra los archivos .bmp.
  2. En el menú Archivo, haga clic en Nuevo y elija Icono. De forma predeterminada, la ventana de icono que se abre muestra una imagen de dispositivo estándar de 32 por 32 píxeles.
  3. En la ventana Icono, haga clic en Nueva imagen de dispositivo. Haga clic en Personalizado y, después, cree estas imágenes:
    • Una imagen de 22 por 20 píxeles en 16 colores
    • Una imagen de 22 por 20 píxeles en 256 colores
    • Una imagen de 18 por 16 píxeles en 16 colores

    Nota

    • Las imágenes de dispositivo son dos píxeles más anchas que las imágenes. Centre sus imágenes en el área de la imagen de dispositivo.
  4. Elimine la imagen de dispositivo de 32 por 32 píxeles predeterminada.
  5. Copie y pegue las imágenes en color desde los archivos .bmp a la imagen de dispositivo del tamaño y profundidad de color apropiados.
  6. Para hacer el fondo transparente, seleccione el color transparente en la paleta de colores y rellene el fondo de cada imagen en la que desee obtener transparencia.
  7. Guarde el archivo como un archivo .ico.

Para crear el archivo .ico predeterminado (en escala de grises), siga los mismos pasos.


Incluir una cadena de agente del usuario

Algunas organizaciones realizan un seguimiento de las estadísticas de los sitios, por ejemplo, del número de veces que se tiene acceso a su contenido y con qué tipos de exploradores Web. Las cadenas de agente del usuario le ayudan a identificar el tipo de explorador.

Si recopila estadísticas del explorador y su información incluye la cadena de agente del usuario, puede realizar el seguimiento del uso de su explorador personalizado. En el Asistente para personalizar Internet Explorer 6, puede agregar caracteres al final de la cadena de agente del usuario para personalizarla.

La cadena personalizada aparecerá en las estadísticas que incluyan la cadena de agente del usuario. Tenga en cuenta que otras organizaciones que hagan el seguimiento de las estadísticas verán su cadena personalizada. Evite utilizar una cadena que no desee que vean los demás.

Ejemplo

A continuación se muestra un ejemplo de cadena de agente del usuario:

Mozilla/4.0(compatible; MSIE 6; WindowsNT; SuCadenaPersonalizada)

Nota

  • El número máximo de caracteres recomendado para la cadena de agente del usuario es 200.


Ejecutar la instalación por lotes

El Asistente para personalizar Internet Explorer 6 permite controlar la funcionalidad y la experiencia del usuario del programa de instalación de Windows Update. Para controlar aún más el proceso de instalación, puede utilizar un archivo por lotes, modificadores de la línea de comandos o una combinación de ambos. Puede utilizar estos métodos si se instala Microsoft Internet Explorer independientemente o como parte de Microsoft Office.

En general, el método que utiliza el archivo por lotes proporciona un mayor control sobre la instalación de los componentes individuales y conlleva menos pasos. Los modificadores de la línea de comandos sirven para mantener la compatibilidad con versiones anteriores y con soluciones personalizadas.

Crear un archivo por lotes

Para crear un archivo por lotes, use un editor de textos, como el Bloc de notas de Microsoft, y asigne al archivo el nombre IEbatch.txt. Si piensa utilizar modificadores de la línea de comandos para llamar al archivo por lotes, puede asignarle un nombre diferente, siempre y cuando indique el nombre de archivo correcto en la sintaxis de la línea de comandos. Para obtener más información, consulte Sintaxis de los archivos por lotes. Para ver un ejemplo, consulte Ejemplo de archivo de instalación por lotes.

Usar archivos por lotes para distribuir Internet Explorer

Si distribuye Internet Explorer a través de Internet o en una intranet, puede publicar el archivo por lotes en el sitio desde el que los usuarios descargan Internet Explorer. Si va a distribuir Internet Explorer de otra forma, como puede ser en disco o en CD, puede agregar el archivo por lotes al disco. Colóquelo en la misma carpeta que el archivo IE5Setup.exe.

Puede que desee conservar el archivo por lotes en una ubicación independiente, en caso de que no esté listo en el momento de preparar el paquete de IEAK, o si va a cambiar temporal o definitivamente las opciones de instalación especificadas en el paquete personalizado de IEAK.

Ejecutar el programa de instalación mediante modificadores de la línea de comandos

Si va a combinar Internet Explorer con cualquier componente asociado a su producto, por lo general deberá utilizar modificadores de la línea de comandos para instalar un paquete de IEAK como parte del programa de instalación. Si desea modificar la instalación mediante modificadores de la línea de comandos, puede usar el Asistente para IExpress, incluido en IEAK, o bien puede usar otro programa para empaquetar los archivos de instalación.

Para obtener más información, consulte Modificadores de la instalación por lotes de Internet Explorer y Modificadores de la instalación por lotes de IExpress.

Motivos para ejecutar la instalación desde una línea de comandos o un archivo por lotes

A continuación se describen algunos motivos por los que puede incluir más controles en la instalación de Windows Update:

Realizar una instalación no interactiva

Si es un administrador corporativo, quizás desee distribuir Internet Explorer a los usuarios después de las horas laborales normales. Aunque IEAK le ayuda a preparar una instalación "silenciosa" que requiere poca participación del usuario, quizás desee ir un paso más allá en el control de este proceso. Mediante la configuración del archivo de texto por lotes o los modificadores de la línea de comandos, puede determinar qué mensajes verá el usuario y si el equipo debe reiniciarse al terminar la instalación.

Redistribuir Internet Explorer

Si es un proveedor de software independiente (ISV) puede alojar Internet Explorer en su aplicación e instalar Internet Explorer sin los iconos ni la interfaz del explorador. Para ello, utilice un archivo por lotes con la opción Redist o con el modificador /X. Para obtener más información, consulte Modificadores de la instalación por lotes de Internet Explorer.

Tener un mayor control sobre determinados componentes

Los archivos por lotes permiten instalar y controlar componentes, independientemente de que los haya incluido o no en el paquete de IEAK. También puede restringir los modos de instalación (Estándar o Mínima) disponibles para los usuarios. Utilice el identificador del componente IdComponente, una cadena de texto como NetMeeting, para identificar los componentes. Puede encontrar información relativa al identificador del componente en el archivo Iesetup.cif.

Cambiar las opciones de instalación sin tener que generar de nuevo el paquete de IEAK

Es posible que necesite instalar y configurar Internet Explorer de una forma especial, y no desee volver a generar el paquete de IEAK. Puede utilizar un archivo por lotes o modificadores de la línea de comandos para cambiar las configuraciones especificadas previamente en el Asistente para personalizar Internet Explorer 6 al crear el paquete.


Sintaxis de archivos por lotes

Puede utilizar un archivo por lotes para aumentar el control sobre el proceso de instalación y el asistente para la instalación de Windows Update para Internet Explorer y herramientas de Internet. La tabla siguiente muestra las secciones y entradas que componen el archivo por lotes. Para obtener más información acerca de cómo usar un archivo por lotes, consulte Ejecutar la instalación por lotes. Para ver un archivo de ejemplo completo, consulte Ejemplo de archivo de instalación por lotes.

Secciones de un archivo por lotes:

[Options]

[Welcome]

[SetupChoice]

[Custom]

[Download]

[DownloadSite]

[PrepareSetup]

[Diskspace]

[Progress]

[RebootPartial]

[Finish]

[Reboot]

[Upgrade]

[Options]
SaveUninstallInfo=[0,1]
ExtraSection=
Quiet=[A,C,U]
ShowErrors=[0,1]
Display=[0,1]

Entradas en esta sección | Descripción
SaveUninstallInfo=[0,1] Determina si se va a guardar la información necesaria para quitar componentes.
  • 0 especifica que no se guarda esa información. Si utiliza este modificador no podrá desinstalar Internet Explorer desde el Panel de control.
  • 1 (opción predeterminada) especifica que se guarda esa información.
ExtraSection=sección1[,sección2,...] | Ejecuta las secciones especificadas en el archivo Iesetup.inf. Utilice comas para separar las secciones (por ejemplo, sección1,sección2,sección3).
Quiet=[A,C,U] Representa el modo silencioso, en el que se requiere muy poca o ninguna intervención del usuario durante la instalación.
  • A especifica el modo de administrador, en el que el usuario no ve ejecutarse el programa de instalación y no se realiza la comprobación de errores.
  • C elimina el botón Cancelar de la página de información de desarrollo del proceso.
  • U especifica que el programa de instalación no se muestre al usuario a menos que necesite alguna entrada (por ejemplo, la ubicación de descarga) que no esté disponible.
ShowErrors=[0,1] Determina si los errores del programa de instalación se mostrarán al usuario.
  • 0 especifica que el programa de instalación realiza la acción predeterminada para cada mensaje sin que el usuario tenga que especificar ningún valor.
  • 1 (opción predeterminada) especifica que los errores del programa de instalación se mostrarán al usuario.
Ir al principio

[Welcome]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Determina si se mostrará la pantalla inicial del programa de instalación en el equipo del usuario.
  • 0 especifica que no se mostrará la pantalla inicial del programa de instalación.
  • 1 (opción predeterminada) especifica que se mostrará al usuario la pantalla inicial del programa de instalación.
Ir al principio

[SetupChoice]
Display=[0,1]
SetupChoice=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Determina si aparecerá en el equipo del usuario la pantalla en la que puede elegir la opción de instalación que le permite personalizarla.
  • 0 especifica que no se mostrará al usuario la pantalla de selección del tipo de instalación.
  • 1 (opción predeterminada) especifica que se mostrará al usuario la pantalla de selección del tipo de instalación.
SetupChoice=[0,1] Determina qué opción de instalación se elige.
  • 0 (opción predeterminada) especifica Instalar ahora - Instalación típica de componentes.
  • 1 especifica Instalación personalizada.
Ir al principio

[Custom]
Display=[0,1]
InstallDir=nombre de carpeta
InstallDirRO=[0,1]
UseInfInstallDir=[0,1]
SetupMode=[0,1,2]
SetupModeRO=[0,1]
Component=[IdComponente_1, IdComponente_2, ...]
ComponentListRO=[0,1]
DownloadOnly=[0,1]
DownloadOnlyRO=[0,1]
IECompat=[0,1]
IECompatRO=[0,1]
IECompatShow=[0,1]
ShowAdvanced=[0,1]
IEDefault=[0,1]
IEDefaultRO=[0,1]

Entradas en esta sección | Descripción
Display=[0,1] Determina si debe aparecer en el equipo del usuario la pantalla Opciones de componentes en la que los usuarios pueden seleccionar los componentes y hacer clic en Opciones avanzadas para especificar más opciones.
  • 0 especifica que no debe mostrarse al usuario la pantalla Opciones de componentes.
  • 1 (opción predeterminada) especifica que se mostrará al usuario la pantalla Opciones de componentes.
InstallDir=nombre de carpeta | Especifica la carpeta donde se deben instalar los archivos. Si no se incluye esta opción, el programa de instalación utiliza los parámetros existentes en el archivo Iesetup.inf. Si ha instalado una versión anterior de Internet Explorer, el programa de instalación utiliza dicha carpeta.
InstallDirRO=[0,1] Especifica si el usuario puede cambiar la carpeta de instalación.
  • 0 (opción predeterminada) especifica que el usuario puede cambiar la carpeta de instalación.
  • 1 especifica que el usuario no puede cambiar la carpeta de instalación.
UseInfInstallDir=[0,1] Especifica la carpeta donde se instala Internet Explorer.
  • 0 (opción predeterminada) especifica que el programa de instalación debe utilizar la carpeta predeterminada de instalación o la carpeta en la que ya está instalada una versión anterior de Internet Explorer.
  • 1 especifica que la carpeta de instalación es la indicada en el archivo Iesetup.inf.
SetupMode=[0,1,2] Indica qué tipo de instalación debe realizarse.
  • 0 especifica una instalación mínima.
  • 1 (opción predeterminada) especifica una instalación típica.
  • 2 especifica una instalación completa.
SetupModeRO=[0,1] Determina si el usuario puede cambiar el tipo de instalación.
  • 0 especifica que el usuario puede cambiar el tipo de instalación.
  • 1 (opción predeterminada) especifica que el usuario no puede cambiar el tipo de instalación.
Component=[IdComponente_1[,IdComponente_2,...]] | Indica que sólo se deben instalar los componentes especificados en el parámetro Component=. IdComponente es una cadena de texto que identifica de forma exclusiva un componente; puede encontrar la cadena que corresponde a cada componente en su sección dentro del archivo Iesetup.cif. Puede encontrar información acerca del identificador del componente (IdComponente) en el sitio Web de IEAK.
ComponentListRO=[0,1] Determina si el usuario puede especificar los componentes que se instalarán, además de los componentes correspondientes al tipo de instalación.
  • 0 (opción predeterminada) especifica que el usuario puede cambiar la lista de componentes.
  • 1 especifica que el usuario no puede cambiar la lista de componentes.
DownloadOnly=[0,1] Determina si Internet Explorer sólo debe descargarse, o debe descargarse e instalarse.
  • 0 (opción predeterminada) especifica que los archivos se descargan y después se instalan.
  • 1 especifica que los archivos se descargan pero no se instalan.
DownloadOnlyRO=[0,1] Determina si el usuario puede especificar que los archivos se descarguen, o se descarguen e instalen.
  • 0 (opción predeterminada) especifica que el usuario puede cambiar esta opción de configuración.
  • 1 especifica que el usuario no puede cambiar esta opción de configuración.
IECompat=[0,1] Determina si Internet Explorer 5 (o versiones posteriores) puede instalarse en un equipo que ya tenga Internet Explorer 4, de forma que esté disponible la funcionalidad de ambos programas.
  • 0 especifica que Internet Explorer 5 (o posterior) no puede instalarse en un equipo que contenga Internet Explorer 4.
  • 1 (opción predeterminada) especifica que Internet Explorer 5 (o posterior) puede instalarse de forma que funcione con las características de Internet Explorer 4.
IECompatRO=[0,1] Determina si el usuario puede especificar que las características de Internet Explorer 4 puedan usarse con Internet Explorer 5 (o posteriores).
  • 0 (opción predeterminada) especifica que el usuario puede cambiar esta opción de configuración.
  • 1 especifica que el usuario no puede cambiar esta opción de configuración.
IECompatShow=[0,1] Determina si aparecerá la casilla de verificación Compatibilidad, que permite a los usuarios ejecutar Internet Explorer 5 (o posterior) en un equipo que contiene Internet Explorer 4.
  • 0 especifica que la casilla de verificación no aparecerá en el asistente.
  • 1 (opción predeterminada) especifica que la casilla de verificación aparecerá en el asistente .
ShowAdvanced=[0,1] Determina si el botón Avanzadas aparecerá en la pantalla Opciones de componentes del asistente para la instalación de Windows Update. Al hacer clic en el botón Avanzadas se muestran las opciones Sólo descargar, Compatibilidad y No asociar tipos de archivo.
  • 0 especifica que el botón Avanzadas no aparecerá en el asistente.
  • 1 (opción predeterminada) especifica que el botón Avanzadas aparecerá en el asistente.
IEDefault=[0,1] Determina si Internet Explorer va a ser el explorador predeterminado.
  • 0 especifica que no lo es.
  • 1 (opción predeterminada) especifica que Internet Explorer es el explorador predeterminado.
IEDefaultRO=[0,1] Especifica si los usuarios pueden decidir que Internet Explorer sea su explorador predeterminado.
  • 0 especifica que los usuarios pueden decidir que Internet Explorer sea su explorador predeterminado.
  • 1 (opción predeterminada) especifica que los usuarios no pueden decidir si Internet Explorer será su explorador predeterminado.
Ir al principio

[Download]
Display=[0,1]
DownloadDir=nombre de carpeta
DownloadDirRO=[0,1]
DownloadOS=[0,1]
DownloadOSRO=[0,1]

Entradas en esta sección | Descripción
Display=[0,1] Determina si aparecerá en el equipo del usuario la opción de descargar o instalar archivos.
  • 0 especifica que la opción de descarga o instalación de archivos no debe mostrarse al usuario.
  • 1 (opción predeterminada) especifica que la opción de descarga o instalación de archivos debe mostrarse al usuario.
DownloadDir=nombre de carpeta | Especifica la carpeta en la que se descargan los archivos. Si no se incluye esta opción, el programa de instalación crea una carpeta denominada Windows Update Setup Files en la unidad de disco que tenga más espacio disponible.
DownloadDirRO=[0,1] Especifica si los usuarios pueden cambiar la carpeta en la que se descargan los archivos.
  • 0 (opción predeterminada) especifica que los usuarios pueden cambiar la carpeta de descarga.
  • 1 especifica que los usuarios no pueden cambiar la carpeta de descarga.
DownloadOS=[0,1] Especifica que se deben descargar los archivos de un sistema operativo determinado; esta opción sólo es válida cuando se están descargando archivos sin instalarlos (DownloadOnly=1).
  • 0 (opción predeterminada) especifica el sistema operativo actual.
  • 1 especifica Windows 95, Windows 98, Windows Millennium Edition, Windows NT, Windows 2000 y Windows XP.
DownloadOSRO=[0,1] Determina si los usuarios pueden especificar el sistema operativo de los archivos que se van a descargar en su equipo.
  • 0 (opción predeterminada) especifica que los usuarios pueden cambiar esta opción de configuración.
  • 1 especifica que los usuarios no pueden cambiar esta opción de configuración.
Ir al principio

[DownloadSite]
Display=[0,1]
DownloadLocation=dirección URL
DownloadSiteList=dirección URL

Entradas en esta sección | Descripción
Display=[0,1] Determina si se muestran al usuario los sitios de descarga.
  • 0 especifica que no se muestran al usuario los sitios de descarga.
  • 1 (opción predeterminada) especifica que se muestran al usuario los sitios de descarga.
DownloadLocation=dirección URL | Especifica la dirección del sitio Web desde la que los usuarios deben descargar los archivos .cab, si la distribución se hace desde el Web. Si ha utilizado la opción Display=0 para esta sección o cualquier otro modificador que haga que no se muestre esta página, deberá escribir un sitio de descarga.
DownloadSiteList=URL | Especifica la ubicación de la lista de sitios de descarga; como opción predeterminada, esta lista está incluida en el archivo Ie5sites.dat. Si no se incluye esta opción, el programa de instalación utiliza los parámetros existentes en el archivo Iesetup.inf.
Ir al principio

[PrepareSetup]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Determina si se mostrará la pantalla Preparando la instalación en el equipo del usuario.
  • 0 especifica que no se mostrará.
  • 1 (opción predeterminada) especifica que se mostrará.
Ir al principio

[Diskspace]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Especifica si se mostrará en el equipo del usuario la cantidad necesaria de espacio en disco.
  • 0 especifica que no se mostrará la cantidad necesaria de espacio en disco. Si el usuario no tiene espacio en disco suficiente, el programa de instalación se cerrará.
  • 1 (opción predeterminada) especifica que se mostrará la cantidad necesaria de espacio en disco.
Ir al principio

[Progress]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Especifica si se mostrará al usuario el desarrollo del proceso de instalación.
  • 0 especifica que no se mostrará.
  • 1 (opción predeterminada) especifica que se mostrará.
Ir al principio

[RebootPartial]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Determina si aparecerá la pantalla Instalación incompleta cuando falle la instalación de algún componente.
  • 0 especifica que no se mostrará la pantalla Instalación incompleta cuando falle la instalación de algún componente.
  • 1 (opción predeterminada) especifica que se mostrará la pantalla Instalación incompleta cuando falle la instalación de algún componente.
Ir al principio

[Finish]
Display=[0,1]

Entradas en esta sección Descripción
Display=[0,1] Especifica si se mostrará el mensaje que indica que el equipo se va a reiniciar al terminar la instalación.
  • 0 especifica que no se mostrará el mensaje. Si piensa desactivar el reinicio posterior a la instalación, use 0.
  • 1 (opción predeterminada) especifica que se mostrará el mensaje.
Ir al principio

[Reboot]
Reboot=[0,1]

Entradas en esta sección Descripción
Reboot=[0,1] Especifica si se debe reiniciar el equipo al terminar el proceso de instalación.
  • 0 especifica que no desea reiniciar el equipo al terminar el proceso de instalación. Si desactiva el reinicio, el programa debe ocuparse de realizarlo. Internet Explorer no se configurará correctamente hasta que se reinicie el equipo.
  • 1 (opción predeterminada) especifica que desea reiniciar el equipo al terminar el proceso de instalación.
Ir al principio

[Upgrade]
ReinstallAll=[0,1]

Entradas en esta sección Descripción
ReinstallAll=[0,1] Especifica si se deben volver a instalar todos los componentes en el caso de que el programa de instalación se ejecute por segunda vez.
  • 0 (opción predeterminada) especifica que no se ejecute nuevamente el programa de instalación si ya están instalados todos los componentes.
  • 1 especifica que deben volver a instalarse todos los componentes.
Ir al principio


Modificadores de la instalación por lotes de IExpress

El Asistente para IExpress le ayuda a pasar modificadores de instalación de una aplicación a otra. Al utilizar IExpress con modificadores de Internet Explorer, estos modificadores se colocan dentro de la expresión de IExpress de la forma siguiente:

Ie6setup <modificadores de IExpress> /c:" ie6wzd <modificadores de Internet Explorer>"

Modificadores de IExpress

A continuación se muestran los modificadores de IExpress más utilizados que controlan el proceso de extracción durante la instalación. Estos modificadores no son específicos de Internet Explorer:

Modificador | Acción
/Q | Especifica el modo silencioso, sin preguntas al usuario, al extraer los archivos. Este modificador no elimina las preguntas cuando se ejecuta el programa de instalación de Windows Update.
/Q:U | Especifica el modo silencioso de usuario, que le muestra algunos cuadros de diálogo.
/Q:A | Especifica el modo silencioso de administrador, que no muestra ningún cuadro de diálogo al usuario.
/C:<ubicación UNC> | Especifica la ruta de acceso y nombre de los archivos .inf o .exe de la instalación.
/R:N | Nunca reinicia el equipo después de la instalación.
/R:A | Siempre reinicia el equipo después de la instalación.
/R:S | Reinicia el equipo después de la instalación sin consultar al usuario.
/T:<ruta de acceso de directorios> | Especifica la carpeta de destino desde la que se extraen los archivos.

Para obtener más información acerca de IExpress, consulte Tecnología IExpress y Asistente para IExpress.


Tecnología IExpress y Asistente para IExpress

La tecnología IExpress se ha diseñado para simplificar la creación de los programas de instalación. Mediante el asistente paso a paso para IExpress, puede crear archivos autoextraíbles que ejecuten automáticamente el programa de instalación que contienen. El programa de instalación puede crearse mediante un archivo .ini o un archivo ejecutable. La tecnología IExpress quita automáticamente los archivos de instalación una vez terminada ésta, lo que ahorra tiempo y frustraciones al usuario.

El Asistente para IExpress puede ayudarle a realizar instalaciones especializadas del paquete del explorador personalizado, al determinar, por ejemplo, si el equipo necesita o no ser reiniciado después de la instalación. Puede encontrar el Asistente para IExpress (IExpress.exe) en la carpeta \<carpeta de programa IEAK>\Tools. Algunas opciones que seleccione en el asistente corresponden a determinados modificadores para instalación por lotes.

IExpress emplea un archivo de directiva de extracción automática (.sed) para almacenar información relativa al paquete. Cuando ejecute el Asistente para IExpress, puede empezar con un archivo .sed existente o crear uno nuevo mediante el asistente. El archivo .sed contiene información e instrucciones acerca del paquete de instalación.

Si está generando un archivo autoextraíble con IExpress y el idioma de este archivo es distinto del idioma del Asistente para personalizar Internet Explorer 6, copie los archivos Wextract.exe y Advpack.dll de la carpeta \<carpeta de programa IEAK>\Iebin\<lang>\Optional en la carpeta \<carpeta de programa IEAK>\Tools (donde se encuentran los archivos Iexpress.exe, Makecab.exe, W95inf32.dll y W95inf16.dll). Incluya el archivo advpack.dll en el paquete.

Características de la tecnología IExpress

  • Instalación silenciosa y no interactiva de Internet Explorer.
  • Permite realizar actualizaciones sin necesidad de quitar una instalación anterior.
  • Permite actualizar o instalar sobre la misma versión

Opciones de configuración que pueden especificarse en los archivos .inf utilizados por IExpress

  • Determinar si el paquete que se instala automáticamente es para administradores o para usuarios en general.
  • Establecer múltiples formas de ejecutar el comando de instalación incrustado, como los modos normal o silencioso.
  • Determinar si se actualizarán las bibliotecas de vínculos dinámicos (archivos .dll) de IExpress en el equipo del usuario, si son anteriores a las actuales.
  • Especificar versiones de destino, como el intervalo de versiones del sistema operativo, del explorador o de cualquier aplicación (identificado mediante una o varias versiones de archivos), con las que es compatible el paquete.
  • Determinar, en modo de lotes, si se advertirá al usuario cuando se esté ejecutando otra copia del paquete, si no se permitirá que se ejecuten al mismo tiempo dos paquetes o si no se hará nada.
  • Actualizar y agregar archivos al paquete de IExpress con la herramienta UPDFILE sin tener que volver a construir el paquete.
  • Reemplazar Runonce por RunOnceEx, si existe la versión más reciente de Iernonce.dll, de forma que se proporciona al autor control sobre el orden de ejecución y la presentación del estado.
  • Proporcionar un mecanismo para que los administradores corporativos configuren el soporte necesario para los usuarios móviles.
  • Proporcionar a los ICP e ISP una forma de generar paquetes que incluyan escritorios configurados previamente que presenten al usuario contenido personalizado.
  • Proporcionar compatibilidad para múltiples sitios de descarga.
  • Proporcionar compatibilidad para desarrollos internos y externos, personalización, capacidad de ampliación y depuración avanzada.
  • Ahorrar espacio en disco mediante la limpieza del disco duro (Papelera de reciclaje, Occache, caché Wininet, carpeta Temp) durante la instalación, desinstalación y en modo de mantenimiento.
  • Proporcionar compatibilidad para el juego de caracteres extendidos distinto de SBCS.
  • Permitir el uso del formato de archivo .inf al descargar componentes de Internet.

Para obtener más información, consulte Trabajar con archivos de información para la instalación (.inf).


Modificadores de la instalación por lotes de Internet Explorer

A veces puede ser aconsejable controlar la manera en que se ejecuta la instalación de Windows Update en los equipos de los usuarios. Puede utilizar modificadores de la línea de comandos para elegir el modo de instalación, especificar un modo silencioso en el que se quita o se reduce el número de preguntas que se hacen al usuario, o controlar si el equipo se reiniciará después de la instalación.

Puede hacer que los usuarios incluyan estos modificadores al ejecutar la instalación de Windows Update, pero lo más normal es empaquetar Internet Explorer con otro programa, como IExpress, para realizar una instalación por lotes.

Modificadores de Internet Explorer

Puede utilizar los modificadores siguientes para controlar la instalación de Internet Explorer:

Modificador | Acción
/Q | Especifica un modo silencioso no interactivo. Únicamente se pedirá al usuario la información que no esté especificada.
/Q:A | Especifica un modo silencioso sin ninguna pregunta al usuario.
/Q:C | Especifica un modo silencioso que no muestra el botón Cancelar, de forma que el usuario no pueda cancelar la instalación. El Asistente para personalizar Internet Explorer 6 utiliza este modificador si selecciona la opción Instalar paquete silenciosamente cuando lo instala como administrador corporativo.
/B:nombre del archivo | Especifica el archivo de comandos por lotes que se utilizará.
/M[:{0|1|2|3...10}] Especifica el modo de instalación. Para paquetes de IEAK personalizados, 0 hace referencia a la primera opción de instalación, 1 a la segunda opción y así sucesivamente. Por ejemplo, 0=mínima, 1=típica y 2=completa. Puede especificar un máximo de diez modos de instalación en el IEAK.

Si el modificador /M se utiliza sin número, el programa de instalación supone que no se ha especificado ningún modo y únicamente instala los componentes especificados. Si no se usa, el programa de instalación emplea el modo predeterminado especificado en el archivo .inf.
/E:IdComponente[, ...] | Especifica componentes adicionales que se deben instalar con independencia del modo de instalación. Utilice este modificador para especificar componentes que no forman parte del tipo de instalación especificado en el Asistente para la personalización. Este modificador pasa por alto lo especificado en el archivo de texto por lotes, en el caso de que se utilice. IdComponente es una cadena de texto que identifica de forma exclusiva un componente; puede encontrar la cadena que corresponde a cada componente en su sección dentro del archivo Iesetup.cif.
/S:""#e"" Indica la ruta de acceso de origen de Ie6setup.exe. ""#e"" hace referencia a la ruta de acceso y el nombre completos del archivo .exe.

Nota

  • La ruta de acceso debe estar entre dos pares de dobles comillas.
/R:N | Indica que no se reinicie el equipo después de la instalación. Si el equipo no se reinicia después de la instalación de Windows Update, la instalación del componente personalizado deberá reiniciarlo. Internet Explorer no se configurará correctamente hasta que se reinicie el equipo.
/D | Especifica que desea descargar únicamente los archivos para el sistema operativo actual.
/D:1 | Especifica que desea descargar los archivos para los sistemas operativos Microsoft Windows y Windows NT.
/G:sección[, ...] | Ejecuta las secciones de instalación especificadas en el archivo Iesetup.inf. Las distintas secciones se separan mediante comas.
/X | Instala Internet Explorer sin shell, iconos ni vínculos. Esta opción es útil para almacenar los controles del explorador en su propia aplicación.
/X:1 | Instala Internet Explorer con el shell, iconos o vínculos, pero no asume las opciones de asociaciones de protocolo http ni de explorador predeterminadas.
/P | Informa acerca de los componentes y espacio en disco necesarios para realizar una instalación. Esta opción permite ver cuánto espacio en disco va a utilizarse en función de las opciones de instalación seleccionadas. Para obtener más información, consulte la sección Estimar el tamaño de la instalación de Internet Explorer, en este mismo tema.

Modificadores de línea de comandos de Internet Explorer utilizados con IExpress

El Asistente para IExpress le ayuda a pasar modificadores de instalación de un programa a otro. Al utilizar IExpress con modificadores de Internet Explorer, estos modificadores se colocan dentro de la expresión de IExpress de la forma siguiente:

Ie6setup <modificadores de IExpress> /c:" ie6wzd <modificadores de Internet Explorer>"

Si desea obtener una lista completa de los modificadores de la instalación de IExpress, consulte Modificadores de la instalación por lotes de IExpress.

Ejemplos

A continuación se incluyen algunos comandos de ejemplo utilizados para instalar Internet Explorer.

  • La expresión siguiente realiza una instalación silenciosa. No hace ninguna consulta al usuario y el equipo no se reinicia después de la instalación:

    ie6setup.exe /C:"ie6wzd /S:""#e"" /Q /R:N"

  • La expresión siguiente pasa por alto la lista de sitios del archivo Ie6sites.dat e instala Internet Explorer desde el lugar especificado. Se trata de una expresión única que se presenta en varias líneas de texto, lo que mejora su legibilidad.

    ie6setup.exe
    /C:"ie6wzd
    /S:""\\suservidor.com\directorio\ie6setup.exe"""

    Esta expresión propia se puede usar para indicar a los usuarios otra ubicación de descarga, por ejemplo, en otro país o región, sin tener que generar de nuevo su paquete IEAK.

Estimar el tamaño de la instalación de Internet Explorer

Puede utilizar los modificadores por lotes de Internet Explorer para pasar a su paquete personalizado del IEAK información acerca de la instalación de Internet Explorer. Hay dos razones principales para ello: mostrar la cantidad de espacio de disco necesario para instalar Internet Explorer (en función de las opciones elegidas por el usuario) y proporcionar información acerca del desarrollo del proceso de instalación.

Al utilizar el modificador /P, esta información queda almacenada en el Registro durante la instalación. De acuerdo con esta información, el programa de instalación de Windows Update devuelve la siguiente información adicional a la sección HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo del Registro:

Subclave | Tipo de datos | Valor
InstallSize | Cadena | Número de KB (tamaño real de la instalación).
AdminRights | Datos binarios | 1 o 0
EstimatedCopy | Cadena | Número de KB Este valor normalmente es mayor que InstallSize, ya que el proceso de instalación necesita más espacio. Se utiliza como estimación de la apariencia que tendrá la información acerca del desarrollo del proceso en formato de "medidor de combustible".

Códigos de retorno y estado de la instalación de Windows Update

Después de instalar una aplicación o si ésta falla, el programa de instalación tiene que informar del resultado del proceso. Como IE6wzd.exe está incluido en Ie6setup.exe, los códigos de retorno no se pueden devolver directamente. En su lugar, el programa de instalación devuelve esa información después de la instalación por medio de la sección HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo del Registro. Cualquier Failed HResult que aparezca en esta sección indica que se ha producido algún error.

Subclave | Tipo de datos | Valor
Complete | Cadena | DWORD refleja el parámetro HRESULT del programa de instalación, como se muestra a continuación:
 |  | 0 | Correcto
 |  | 0x80100003 | Faltan archivos necesarios para la instalación solicitada.
 |  | 0x80100001 | El programa de instalación se ha realizado correctamente de forma parcial. Uno o varios componentes no se han descargado o instalado. Busque en la subclave FailedComponents la lista de componentes.
 |  | 0x80100002 | El programa de instalación se ha realizado correctamente de forma parcial, pero el usuario ha cancelado la instalación. Uno o varios componentes no se han descargado o instalado.

Para los elementos que no se han instalado correctamente, el programa de instalación también devuelve la información siguiente:

Subclave | Tipo de datos | Valor
FailedComponents | MultiSZ | <Nombre de los componentes en CIFID>null<Nombre de componente...>
InstallStatus | Datos binarios | 0 | Instalación completada correctamente.
 |  | 1 | Suspender la instalación. El usuario canceló el programa de instalación y se le pide que lo confirme.
 |  | 2 | No cancelar, reanudar la instalación.
 |  | 3 | Sí, se confirma la cancelación, salir del programa de instalación lo antes posible. En algunos casos puede ser necesario completar alguna tarea que se esté ejecutando, como copiar o extraer archivos.


Actualizar periódicamente a los usuarios

Los usuarios pueden recibir automáticamente un aviso cuando esté disponible una nueva versión de Microsoft Internet Explorer. Puede controlar si desea que Internet Explorer compruebe si hay información actualizada y, si lo hace, con qué frecuencia.

A continuación se explica cómo funciona este sistema:

  • Al detectarse una nueva versión de Internet Explorer, la página principal, o de inicio, del usuario se reemplaza de forma temporal por una página de aviso de actualización. Desde esa página, los usuarios pueden actualizar su explorador, agregar la página a su lista de Favoritos o cancelar la actualización.
  • De forma predeterminada, se utiliza como página de aviso de actualización la página de Microsoft Internet Explorer para Microsoft Windows Update. También puede mostrar una página Web personalizada en su lugar con la que podrá proporcionar otros datos acerca de la actualización del producto o incluir algunas noticias de la empresa. Por ejemplo, puede crear una página Web para avisar a los usuarios de las nuevas versiones de Internet Explorer disponibles, de las nuevas rutas de acceso del servidor y de las noticias de la compañía.

    La página de aviso de actualización le permite distribuir periódicamente información en formato .htm a los usuarios.

  • La próxima vez que el usuario inicie el explorador, aparecerá la página principal predeterminada del usuario.

Para especificar la configuración de la página de aviso de actualización, siga estos pasos:

  1. Si cambia la configuración mediante el Asistente para personalizar Internet Explorer 6, en la pantalla Directivas y restricciones del paso 5, haga clic en Configuración de Internet.

    —O bien,—

    Si cambia la configuración con el Administrador de perfiles, haga clic en Directivas y restricciones y, después, en Configuración de Internet.

  2. Active la casilla de verificación Comprobar automáticamente si hay actualizaciones de Internet Explorer.
  3. En el lado izquierdo de la pantalla, haga clic en Actualizaciones de componentes.
  4. Si desea utilizar la página predeterminada de Windows Update, no reemplace la dirección URL predeterminada.

    Si desea utilizar una página personalizada, escriba la dirección de la página en el cuadro Dirección URL que se mostrará para las actualizaciones.

  5. En Intervalo de comprobación de actualizaciones, especifique el número de días que transcurrirán entre dos comprobaciones sucesivas de la información actualizada.

Si decide crear una página personalizada para su organización, consulte el archivo de ejemplo ieupdate.htm en la carpeta \<carpeta de programa IEAK>\Toolkit.

Nota

  • En las páginas Administrador de perfiles y Directivas y restricciones de la sección Restricciones de Internet del asistente, puede elegir si se realizará una comprobación periódica de las actualizaciones de Internet Explorer y las herramientas de Internet en la pantalla Actualizaciones de componentes.


Detección y configuración automáticas de las opciones del explorador

Puede configurar la red de forma que Internet Explorer se personalice automáticamente la primera vez que se inicie. Esto puede ayudar a reducir el trabajo de administración y el número de llamadas a su servicio de asistencia técnica referentes a la configuración del explorador.

La detección automática de la configuración del explorador, basada en el protocolo Web Proxy AutoDiscovery (WPAD), es compatible con el Protocolo de configuración dinámica de host (DHCP) y el Sistema de nombres de dominio (DNS). Con la configuración adecuada, los servidores DHCP y DNS pueden detectar automáticamente un explorador y configurarlo. Esta característica se basa en tecnologías existentes de configuración automática, mediante las cuales se puede configurar un explorador desde una ubicación central con una dirección URL de configuración automática (archivo .ins) o con un archivo JavaScript para la configuración del proxy (.js, .jvs o .pac).

Con la detección automática, el explorador puede configurarse automáticamente cuando se inicia, incluso aunque el administrador no lo haya personalizado previamente. Por ejemplo, si un usuario va a descargar de Internet un explorador sin personalizar, en lugar de instalar una versión personalizada desde los servidores corporativos, la detección automática puede configurar y personalizar automáticamente el explorador del usuario.

Para especificar en IEAK que desea establecer la detección automática de la configuración del explorador, seleccione Detectar la configuración automáticamente en la pantalla Configuración automática del Asistente para personalizar Internet Explorer 6. Puede ver un ejemplo del proceso de configuración automática en Cómo funciona la configuración automática.

Detección automática de la configuración del explorador para DHCP y DNS

Los servidores DHCP permiten al administrador especificar de forma centralizada los parámetros de TCP/IP globales y específicos de una subred, además de definir los parámetros para los clientes mediante direcciones reservadas. Cuando un equipo cliente se mueve entre subredes, se vuelve a configurar automáticamente para TCP/IP cuando se inicia el equipo.

Importante

  • El servidor DHCP debe admitir el mensaje DHCPINFORM, al igual que ocurre en Windows 2000 y Windows XP.

DNS es un conjunto de protocolos y servicios de una red TCP/IP que permite a los usuarios buscar otros equipos mediante nombres descriptivos jerárquicos, también conocidos como "hosts", en lugar de direcciones IP numéricas.

El uso de DHCP con detección automática proporciona mejores resultados con usuarios conectados a una red de área local (LAN), mientras que DNS permite detectar la configuración tanto para usuarios de redes de área local como de acceso telefónico. Aunque DNS puede administrar usuarios de red y de acceso telefónico, DHCP proporciona un acceso más rápido a los usuarios de una red de área local y les ofrece mayor flexibilidad a la hora de especificar archivos de configuración.

Para habilitar la detección automática de la configuración del explorador, debe configurar algunos valores en servidores DNS, en servidores DHCP o en ambos.

Para obtener más información, consulte los temas siguientes:

Habilitar la detección automática de la configuración del explorador en DHCP

Para establecer la detección automática de la configuración del explorador en un servidor DHCP, debe crear un nuevo tipo de opción con el número de código 252. Como valor asociado al código, escriba la dirección URL que señala a su archivo de configuración. Este archivo puede ser un archivo de configuración de tipo .pac, .jvs, .js o .ins.

Para obtener información específica acerca de cómo configurar un servidor DHCP, consulte la documentación del servidor.

Ejemplos

http://www.microsoft.com/webproxy.pac
http://marketing/config.ins
http://###.#.###.#/account.pac

Habilitar la detección automática en DNS

Para habilitar la detección automática de la configuración del explorador en un sistema DNS, tiene que configurar el registro de host o el registro de "alias" CNAME en el archivo de base de datos de DNS.

Registro de host

Un registro de host se utiliza para asociar estáticamente nombres de host (equipo) a direcciones IP dentro de una zona. Contiene entradas para todos los hosts que requieren asignaciones estáticas, como estaciones de trabajo, servidores de nombres y servidores de correo.

La sintaxis es: <nombre del host> IN A <dirección IP del host>

Por ejemplo:

corserv | IN | A | 192.55.200.143
nombreDelServidor2 | IN | A | 192.55.200.2
servidorDeCorreo1 | IN | A | 192.55.200.51

Registro CNAME

Estos registros se conocen como "alias" pero nos referimos a ellos técnicamente como entradas de "nombre canónico" (CNAME). Estos registros permiten utilizar más de un nombre para señalar a un único host. El uso de nombres canónicos facilita, por ejemplo, tener en un mismo equipo un servidor FTP y un servidor Web.

Para configurar un archivo de base de datos de DNS para la detección automática de la configuración del explorador

  • En el archivo de base de datos de DNS, escriba un registro de host llamado wpad que señale a la dirección IP del servidor Web que contiene los archivos de configuración automática .pac, .jvs, .js o .ins.

    O bien, introduzca un alias de CNAME wpad que señale al nombre (el nombre resuelto, no la dirección IP) del servidor que contiene los archivos de configuración automática .pac, .jvs, .js o .ins.

Notas

  • Una vez agregado el registro y propagado el archivo de base de datos al servidor, el nombre DNS wpad.dominio.com debe resolverse como el mismo nombre de equipo que el del servidor que contiene el archivo de configuración automática.
  • Cuando se utiliza DNS, Internet Explorer crea una plantilla predeterminada de dirección URL basada en el nombre de host wpad.

    Por ejemplo:

    http://wpad.dominio.com/wpad.dat

    De esta manera, en el servidor Web wpad debe configurar un archivo o punto de redirección llamado wpad.dat, que entregará el contenido de su archivo de configuración automática.


Descripción de la configuración y restricciones

Las directivas de sistema y restricciones para Internet Explorer constituyen un eficaz mecanismo que permite mejorar el control y la administración de los equipos. Estas directivas y restricciones, definidas en un archivo de directiva, controlan los privilegios de acceso de usuarios y equipos; para ello, suplantan valores predeterminados del Registro cuando el usuario inicia una sesión.

Puede utilizar el Asistente para personalizar Internet Explorer 6 para definir las directivas de sistemas y restricciones, y crear una configuración estándar de Internet Explorer como parte del paquete del explorador personalizado. Tras instalar Internet Explorer, podrá utilizar el Administrador de perfiles de IEAK para administrar y actualizar las directivas de sistema y restricciones en los equipos de los usuarios desde una ubicación central. Asimismo, si hay distintos tipos de usuarios con necesidades exclusivas, puede utilizar el Administrador de perfiles de IEAK para crear archivos de directiva (.ins) para cada grupo.

Por ejemplo, podría implementar directivas de sistema y restricciones para:

  • Determinar las características que los usuarios pueden cambiar, como las barras de herramientas de Internet Explorer.
  • Administrar el ancho de banda y controlar el comportamiento y la apariencia de Internet Explorer.
  • Especificar listas de servidores para los componentes, como Microsoft NetMeeting, y configurar una página para actualizar los usuarios periódicamente.
  • Determinar qué programas se usan para correo electrónico y para realizar llamadas en Internet.
  • Predeterminar la configuración de las conexiones del usuario. Si necesita administrar varias configuraciones de conexión, considere la posibilidad de importar un perfil personalizado del Kit de administración del Connection Manager (CMAK).

Para ver un ejemplo de esta característica, consulte Directivas y configuración del sistema.

Nota

  • Entre las opciones de configuración incluidas en la nueva barar de herramientas Imágenes, incluida en Internet Explorer 6, están la barra de herramientas de imagen flotante, ajustar una imagen al tamaño de la pantalla y reproducir automáticamente los archivos multimedia en la barra multimedia. Puede configurar estas opciones en la sección Configuración de Internet, en Directivas y restricciones.

Ventajas del uso de directivas del sistema y restricciones

Mediante la implementación de las directivas de sistema y restricciones, las organizaciones pueden obtener las siguientes ventajas:

  • Permiten implementar una configuración estándar de Internet Explorer. Es posible crear un paquete personalizado del explorador para los usuarios que incluya opciones de configuración frecuentes para sus características y funciones.
  • Permiten restringir las características a las que los usuarios pueden tener acceso en Internet Explorer. Por ejemplo, es posible predefinir las opciones de NetMeeting para controlar el acceso al audio y vídeo. Asimismo, existe la opción de bloquear determinadas características y funciones, de modo que no aparezcan o aparezcan atenuadas en los escritorios de los usuarios.
  • Permiten cambiar los valores predeterminados del Registro. Es posible utilizar la configuración de una directiva para cambiar los valores del Registro de varios equipos, lo que evita tener que especificar las opciones de configuración individualmente en cada uno de los equipos de los usuarios.

Factores que deben tenerse en cuenta al definir las directivas de sistema y las restricciones

Al implementar las directivas de sistema y las restricciones, debe tener en cuenta las cuestiones siguientes:

  • ¿Qué tipos de directivas de sistema y restricciones desearía definir y administrar de forma centralizada? Por ejemplo, ¿desea limitar el acceso a las características de NetMeeting?
  • ¿Desea usar un conjunto de directivas de sistema y restricciones para todos los usuarios y equipos, o crear varios archivos de directiva para grupos de usuarios? Probablemente cada grupo de usuarios tendrá necesidades distintas.
  • ¿Qué tipos de configuración de seguridad desea implementar? Puede bloquear todas las opciones de configuración, de modo que pueda controlarlas y, al mismo tiempo, permitir que los usuarios móviles puedan descargarlas, o bien personalizar las opciones mientras permite que los usuarios las modifiquen.

    Debe tener en cuenta el posible efecto de estas configuraciones, especialmente si hay usuarios móviles que comparten los equipos con otros usuarios. Por ejemplo, ¿qué implicaciones tendría el hecho de quitar los iconos del escritorio o impedir que los usuarios cambien su configuración de seguridad? Asegúrese de que los usuarios comprenden a qué características pueden tener acceso.

  • ¿Desea almacenar los archivos de directiva en una ubicación central o en los equipos de los usuarios? Quizá prefiera almacenar el archivo en un servidor, de modo que los usuarios móviles puedan tener acceso a la configuración desde distintos equipos. Esto podría resultar útil, por ejemplo, para un usuario que necesita una configuración de seguridad baja pero que utiliza un equipo en el que normalmente trabaja alguien con una configuración de seguridad más restringida.

Cómo administrar las directivas y restricciones para Windows NT, Windows 2000 y Windows XP

Todas las directivas de sistema y restricciones que puede definir en el Asistente para personalizar Internet Explorer 6 y administrar posteriormente en el Administrador de perfiles de IEAK pueden configurarse para usuarios que utilicen los sistemas operativos Windows 95, Windows 98 y Windows Millennium Edition.

Sin embargo, en las plataformas Windows NT, Windows 2000 o Windows XP sólo podrá configurar un subconjunto de estas directivas de sistema y restricciones para los usuarios sin privilegios de administrador. En lugar de ello, es aconsejable que use el Editor de directivas de Windows NT o el Editor de directivas de Windows 2000 o Windows XP para configurar las directivas y restricciones restantes correspondientes a dichos usuarios. Para obtener más información, consulte Administrar Microsoft Internet Explorer en Windows 2000 y Windows XP.

Establecer y administrar las directivas de sistema y las restricciones

Puede definir las directivas y restricciones de dos formas distintas:

  • En la Fase 5 del Asistente para personalizar Internet Explorer 6.
  • En el Administrador de perfiles, mediante la configuración automática.

Para utilizar el Administrador de perfiles, cree un nuevo perfil de usuario o abra uno ya existente. Después, expanda las carpetas hasta que vea la configuración o restricción que desea cambiar. Puede encontrar más información acerca de la categoría Directivas y restricciones si hace clic en la carpeta de esa categoría.

Con la configuración automática, la configuración y restricciones del explorador se mantienen en la ubicación que especifique en el Asistente para personalizar Internet Explorer 6 o en el cuadro de diálogo Opciones de Internet.

Para comprobar los valores de configuración automática en los equipos de los usuarios:

  1. Haga clic en el menú Herramientas del explorador.
  2. Haga clic en Opciones de Internet.
  3. Haga clic en la ficha Conexiones y, después, haga clic en Configuración LAN.
  4. Compruebe que está seleccionada la opción Usar secuencia de comandos de configuración automática y compruebe la ruta de acceso que aparece en el cuadro Dirección.

Crear y mantener directivas para los programas personalizados

Cuando utilice el Asistente para personalizar Internet Explorer 6, puede usar las directivas y restricciones que haya configurado en sus propios archivos .adm. Para ello, haga clic en Directiva y, después, en Importar. Puede encontrar archivos .adm personalizables en el idioma apropiado para la carpeta de directivas de IEAK.


Utilizar la selección de proxy y las listas de derivación de servidores proxy

El uso de un servidor proxy permite al administrador limitar el acceso a Internet. Puede especificar un servidor proxy en el Asistente para personalizar Internet Explorer 6, en el Administrador de perfiles de IEAK y mediante del explorador. También puede restringir la capacidad del usuario para cambiar la configuración del proxy en la página Directivas y restricciones del Asistente para personalizar Internet Explorer 6 y del Administrador de perfiles.

Para obtener instrucciones detalladas acerca de cómo configurar la selección de proxy y la derivación de servidores proxy con el IEAK, consulte las pantallas Configuración automática y Configuración de proxy de la Fase 4 del Asistente para personalizar Internet Explorer 6.

Nota

  • La característica de derivación de servidores proxy puede eliminar la necesidad de usar JavaScript o JScript para seleccionar un servidor proxy.

Para configurar la selección de proxy y la derivación de servidores proxy en Internet Explorer

  1. Haga clic en el menú Herramientas en Internet Explorer y, después, haga clic en Opciones de Internet.
  2. Haga clic en la ficha Conexiones y, después, haga clic en Configuración LAN.
  3. En el área Servidor proxy, active la casilla de verificación Usar servidor proxy.
  4. Haga clic en Avanzadas y escriba la ubicación de proxy y el número de puerto de cada protocolo de Internet compatible.

    Notas

    • En la mayoría de los casos, sólo se utiliza un servidor proxy para todos los protocolos. En estos casos, escriba la ubicación de proxy y el número de puerto para la configuración HTTP y, después, active la casilla de verificación Usar el mismo servidor proxy para todos los protocolos.
    • Se supone que las ubicaciones de proxy que no empiezan con un protocolo (como "http://" o "ftp://") son un proxy HTTP de tipo CERN. Por ejemplo, la entrada "proxy" se podría tratar como la entrada "http://proxy". Para las puertas de enlace de FTP, como la de FTP TIS y el proxy FTP WinGate Win95 Modem se debe escribir el proxy con el protocolo "ftp://" delante del nombre. Por ejemplo, la puerta de enlace FTP "ftpproxy" se debe escribir "ftp://ftpproxy".
  5. Para derivar direcciones más complejas, escriba las direcciones en el cuadro No usar proxy para las direcciones que comiencen por:.

    Una entrada de derivación de proxy puede comenzar con un tipo de protocolo, como http://, https://, ftp:// o gopher://. Si se utiliza un tipo de protocolo, la entrada de excepción sólo se aplica a las solicitudes de dicho protocolo. Tenga en cuenta que el valor del protocolo no distingue mayúsculas y minúsculas. Se deben separar las entradas múltiples con un punto y coma (;).

    A continuación, se debe escribir una dirección Internet, una dirección IP o un nombre de dominio. Si no se especificó ningún protocolo, se derivarán las solicitudes que utilicen esa dirección. Si se especificó un protocolo, sólo se derivarán las solicitudes con la dirección si son del tipo de protocolo indicado. Como en el tipo de protocolo, las entradas de direcciones no distinguen mayúsculas y minúsculas.

    Finalmente, se puede agregar un número de puerto. Si se utilizó, sólo se procesará la solicitud si se cumplen todos los requisitos anteriores y la solicitud utiliza el número de puerto especificado.

    El cuadro de diálogo de excepciones permite utilizar un carácter comodín ( * ) en lugar de varios caracteres o ninguno.

Ejemplos de caracteres comodín

Puede usar caracteres comodín en las siguientes situaciones:

  • Escriba un comodín al principio de una dirección de Internet, una dirección IP o un nombre de dominio para derivar los servidores que tengan una terminación común. Por ejemplo, utilice "*.ejemplo.com" para derivar las entradas que terminen en ".ejemplo.com" (como "un.ejemplo.com" y "www.ejemplo.com").
  • Escriba un comodín en el centro de una dirección de Internet, una dirección IP o un nombre de dominio para derivar los servidores que tengan un principio y terminación comunes. Por ejemplo, la entrada "www.*.com" se corresponde con cualquier entrada que comienza con "www" y termina con "com" (como "www.ejemplo.com", "www.departamento.ejemplo.com", etc.).
  • Escriba un comodín al final de una dirección de Internet, una dirección IP o un nombre de dominio para derivar los servidores que tienen un principio común. Por ejemplo, use "www.ejemplo.*" para derivar cualquier entrada que comience por "www.ejemplo." (como "www.ejemplo.com", "www.ejemplo.org" y "www.ejemplo.microsoft.com").
  • Utilice varios comodines para derivar direcciones que tengan patrones similares. Por ejemplo, utilice "123.1*.66.*" para derivar direcciones como "123.144.66.12", "123.133.66.15" y "123.187.66.13."

Nota

  • Aunque los comodines son muy eficaces, debe utilizarlos con cuidado. Por ejemplo, la entrada "www.*.com," hará que Internet Explorer derive el proxy de la mayoría de los sitios Web.


Instalar Internet Explorer con Microsoft Office

El Asistente para la instalación personalizada (CIW) de Microsoft Office le permite personalizar la manera en que implementará los programas de Office a los usuarios. Para simplificar el proceso de instalación, el IEAK ha sido diseñado para funcionar con el CIW.

Si piensa incluir Internet Explorer en el paquete personalizado de Office, tiene dos opciones:

  • Si no va a personalizar Internet Explorer, puede instalar los componentes de Internet Explorer mediante el CIW; no es necesario que utilice el IEAK.
  • Si desea distribuir una versión personalizada de Internet Explorer como parte de la distribución de Office, haga clic en el botón Personalizar en la pantalla Personalizar las opciones de instalación de IE 6 en el Asistente para la instalación de Office. El Asistente para la instalación personalizada iniciará el IEAK.

Ejecutar el IEAK desde el Asistente para la instalación personalizada de Office

El Asistente para personalizar Internet Explorer 6 se ejecuta en el modo de administrador corporativo con la configuración siguiente:

  • El medio de distribución es Simple (todos los archivos en una carpeta).
  • Hay dos opciones de instalación disponibles. No puede cambiar los nombres de esas opciones, pero puede especificar qué componentes se instalarán con cada opción de instalación.
  • Todos los archivos contenedores .cab y los componentes personalizados que se crean con el IEAK se almacenan en la misma carpeta. El nombre predeterminado de esta carpeta es IE6_CUST.

Una vez que haya finalizado el paquete de personalización, en la pantalla Personalizar las opciones de instalación de IE 6 aparece el nombre de archivo y la ruta de acceso del programa de instalación de Windows Update (IE6Setup.exe).

Para utilizar el IEAK como parte del CIW, debe instalarse la versión adecuada de Internet Explorer e IEAK en el equipo donde se está personalizando el paquete de instalación.

Nota

  • En los paquetes IEAK creados mediante el Asistente para la instalación personalizada de Office, las opciones del usuario del programa de instalación de Windows Update para Internet Explorer no se muestran durante la instalación. La interfaz de usuario del programa de instalación de Windows Update viene determinada por el Asistente para la instalación personalizada de Office.


Cambiar desde otras versiones o productos

Antes de que sus empleados o clientes instalen Internet Explorer 5, debe identificar y resolver cualquier problema que pueda presentarse.

Actualizar desde Internet Explorer 5.x

El programa de instalación de Internet Explorer permite realizar una instalación sobre una versión instalada de Internet Explorer 5.x e importar las opciones de configuración de proxy, favoritos y los cookies de la versión anterior.

Actualizar desde Internet Explorer 4

El programa de instalación de Internet Explorer permite realizar una instalación sobre una versión instalada de Internet Explorer 4 e importa las opciones de configuración de proxy, favoritos y los cookies de la versión anterior. Sin embargo, deberá volver a instalar los complementos que desee conservar.

Internet Explorer 4 e Internet Explorer 5.x pueden ejecutarse simultáneamente en el mismo equipo.

Actualizar desde Internet Explorer 3

El programa de instalación de Internet Explorer permite realizar una instalación sobre una versión instalada de Internet Explorer 3 e importa las opciones de configuración de proxy, favoritos y los cookies de la versión anterior. Sin embargo, deberá volver a instalar los complementos que desee conservar.

Cambiar desde Netscape Navigator 3 y 4

Al instalar Internet Explorer, puede importar las opciones de configuración de proxy, favoritos y cookies de Netscape. Sin embargo, deberá volver a instalar los complementos que desee conservar. Una vez instalado Internet Explorer, puede elegir si desea convertirlo en su explorador predeterminado.

Instalar Internet Explorer con Microsoft Office

Para obtener más información acerca de esta característica, consulte Instalar Internet Explorer con Microsoft Office.


Instalación de Windows Update para Internet Explorer y otras herramientas de Internet

El asistente para la instalación de Windows Update (IE6Setup.exe) facilita a los administradores la distribución de Microsoft Internet Explorer. También es más sencillo para los usuarios instalar Internet Explorer y recuperar instalaciones con errores.

Este asistente es pequeño y compacto, pues incluye sólo el código mínimo necesario para proporcionar al cliente acceso a Internet y ofrecerle las funcionalidades básicas para la descarga de archivos.

Puede usar IEAK para personalizar la instalación de Windows Update de modo que se ajuste a las necesidades de los usuarios.

Ventajas del asistente para la instalación de Windows Update

Este paquete también permite al programa de instalación de Windows Update recopilar información relacionada con el equipo host antes de que comience la descarga. El programa de instalación utiliza esta información para administrar de forma inteligente la descarga de los archivos .cab de Internet Explorer y lograr una instalación lo más eficiente y sin problemas posible. La descarga de este pequeño paquete de instalación al comenzar el proceso tiene muchas ventajas, entre las que se incluyen las siguientes:

  • Velocidad: sólo se tarda dos minutos en descargar IE6Setup.exe con una conexión a 28 KBps.
  • En caso de que falte espacio en disco, los usuarios reciben un aviso al comienzo del proceso de instalación (en lugar de esperar hasta el final del proceso de descarga).
  • Todas las opciones de usuario se recopilan al comienzo del proceso, de forma que los usuarios no tienen que estar presentes mientras se descargan e instalan los archivos.
  • Si el vínculo a un servidor de distribución no es confiable y se debe reanudar alguna conexión interrumpida, la descarga se inicia a partir del punto en que falló anteriormente. Con este proceso el usuario avanza en el proceso de instalación cada vez que ejecuta el programa de instalación, en lugar de iniciar el proceso desde el principio.
  • Cuando no es posible restablecer el vínculo con un servidor de distribución, el programa de instalación trata de conectarse automáticamente con otros servidores de distribución.
  • Los usuarios reciben información útil acerca del progreso de la descarga (además del número de bytes por segundo, el tiempo en minutos que falta para terminar la instalación).
  • Si ya está instalada la versión actual de algún componente, los archivos no se vuelven a instalar sin necesidad.
  • Puede crear y ejecutar un paquete de descarga personalizado sin tener que volver a escribir el programa de instalación.
  • Los archivos temporales que ya no son necesarios se pueden quitar del disco duro para dejar más espacio libre para la instalación.

El proceso se muestra en el diagrama Asistente para la instalación de Windows Update para Internet Explorer y otras herramientas de Internet.

Instalar otros componentes con Internet Explorer

Además del explorador Internet Explorer, puede incluir en su versión personalizada del programa de instalación de Windows Update numerosos componentes de Internet de Microsoft y otras compañías. El Asistente para personalizar Internet Explorer 6 facilita la consulta de las versiones de software más recientes disponibles para descargar. El paquete personalizado simplifica a los usuarios la instalación de estos componentes, junto con otros programas personalizados, cuando instalan el explorador.

Los componentes de Microsoft incluyen desde herramientas de creación de Web a compatibilidad multilingüe. El conjunto de componentes disponibles se actualiza continuamente; la lista más reciente aparece en el Asistente para personalizar Internet Explorer 6, siempre y cuando disponga de una conexión a Internet.

Para obtener información acerca de las actualizaciones más recientes de los productos, visite el sitio Web Corporate Windows Update.

Funcionamiento del programa de instalación de Windows Update

Una vez que IE6Setup.exe ha recopilado toda la información necesaria acerca del usuario y el equipo, descarga los archivos .cab necesarios desde uno de los servidores oficiales de distribución de Microsoft en Internet. Puesto que el programa de instalación ya ha realizado un inventario de todos los componentes de Internet Explorer que hay en el equipo y ha preguntado al usuario qué componentes desea instalar, no se descarga ningún archivo .cab innecesario.

El paso siguiente del Asistente para la instalación utiliza el programa de instalación (ACME) tradicional de muchos productos de Microsoft. En este momento, la única diferencia entre el Asistente para la instalación y el programa de instalación tradicional es que los archivos .cab están en una carpeta del disco duro local, en lugar de estar en un disco extraíble o en una unidad de red.

Si es administrador de una intranet, puede crear un paquete de instalación personalizado (también conocido como paquete IExpress) sin volver a escribir el programa de instalación de Windows Update. Para ello, debe crear una versión personalizada de IE6Setup.exe mediante la tecnología IExpress.

Para ajustar con precisión el proceso de instalación, puede usar otros modificadores de la línea de comandos. Para obtener más información, consulte Modificadores de la instalación por lotes de Internet Explorer.

Personalizar la instalación de Windows Update

Hay varias formas de personalizar la instalación de Windows Update. Puede agregar componentes de Internet Explorer o crear un máximo de diez opciones de instalación diferentes. De esta forma puede ampliar las opciones Mínima, Típica y Completa predeterminadas de instalación de Internet Explorer. Agregar varias opciones de instalación puede resultar útil si los empleados tienen distintas necesidades de uso y restricciones en el espacio de disco.

Importante

  • Con independencia de las opciones de instalación que configure para el paquete, el programa de instalación de Windows Update sólo presenta una opción de instalación para los usuarios que ejecutan los sistemas operativos Windows 2000 y Windows XP. Esta opción incluye todos los componentes de Internet de Microsoft, además de todos los componentes personalizados incluidos en el paquete.

Para reducir la posible confusión, puede seleccionar por los usuarios determinadas opciones del programa de instalación. Puede configurar Internet Explorer de modo que su instalación requiera menos intervención del usuario o incluso ninguna. Este tipo de instalación a veces se denomina "instalación silenciosa".

Las instalaciones con intervención limitada suelen utilizarse para instalar Internet Explorer después de la jornada laboral, cuando los empleados no utilizan sus equipos. Puede adaptar aún más estos tipos de instalación mediante modificadores de la línea de comandos o archivos por lotes. Como el usuario no elige ninguna opción, usted sólo puede crear una opción de "instalación silenciosa".

Si suprime todos los comentarios para el usuario, incluidos los mensajes de error y la información de estado, deberá asegurarse de que el plan de instalación incluye el control de errores. Si suprime el equipo después de la instalación, deberá controlar el reinicio en el programa o la secuencia de comandos personalizados para asegurarse de que Internet Explorer está instalado correctamente. Para obtener más información acerca de estas opciones, consulte Instalación silenciosa.

Al instalar Internet Explorer, es aconsejable que instale sus propios componentes personalizados (por ejemplo, secuencias de comandos o programas antivirus). Puede incluir un máximo de diez componentes personalizados en el paquete personalizado.

También puede cambiar la apariencia del programa de instalación; para ello, agregue su propio mapa de bits e incluya descripciones personalizadas en las diferentes opciones de instalación.

Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización. Si desea ver un organigrama de lo que ocurre cuando utiliza el Asistente para personalizar Internet Explorer 6 para crear un paquete personalizado, consulte Cómo genera IEAK los paquetes personalizados.

Archivos de registro que graban los problemas ocurridos durante la instalación

Las características mejoradas de registro facilitan al usuario, al administrador y a Microsoft la solución de los problemas de instalación. El Asistente para la instalación crea los dos archivos de registro siguientes que ayudan a identificar cualquier problema que pueda surgir. Estos archivos se crean en la carpeta Windows o WinNT:

  • Active Setup Log.txt. Registra todas las acciones realizadas durante la ejecución del asistente para la instalación o la instalación de los componentes. Consulte este archivo de registro cuando no se hayan instalado correctamente los componentes de Internet Explorer. Para obtener más información, consulte Información del registro de errores de Active Setup Log.txt.
  • RunOnceEx Log.txt. Registra todas las acciones realizadas durante el registro de las bibliotecas de vínculos dinámicos (DLL). Consulte este archivo de registro cuando reciba algún mensaje que indique que un archivo .dll determinado no se ha registrado correctamente o cuando aparezca algún cuadro de diálogo inesperado durante la fase final del proceso de instalación.


Poner componentes adicionales a disposición de los usuarios

titular

Incluir componentes adicionales en el paquete

Tras crear su paquete del explorador personalizado, podrá publicarlo en sitios desde donde los usuarios puedan descargarlo. Especifique dichos sitios en el paso 3 del Asistente para personalizar Microsoft Internet Explorer 6. También puede especificar el lugar donde los usuarios obtendrán componentes nuevos o actualizaciones de éstos. Se llaman componentes complementarios.

Cuando el usuario hace clic en Herramientas y, después, en Windows Update, el explorador abre la dirección URL del componente complementario especificado. Esto también ocurre cuando el usuario hace doble clic en Agregar o quitar programas en el Panel de control, selecciona Internet Explorer y Herramientas de Internet, hace clic en Agregar o quitar y, después, selecciona Agregar un componente.

Nota

  • La dirección URL del componente complementario que especifique debe contener la ruta de acceso completa a Addon.htm (por ejemplo, http://miservidor/complementos/addon.htm).

Páginas Web de ejemplo de componentes complementarios

El kit de herramientas de IEAK contiene un ejemplo de página Web de componentes complementarios, Addon.htm, que puede personalizar. Esta página se encuentra en la carpeta \<carpeta de programa IEAK>\Toolkit\Addons\HTML. Esta página incluye también vínculos a los archivos Head.htm, Main.htm e Info.htm.

A continuación se muestra una descripción de los cuatro archivos de ejemplo de la carpeta \<carpeta de programa IEAK>\Toolkit\Addons\HTML:

  • Addon.htm. Conjunto de marcos que hace referencia a estos dos archivos:
    • Head.htm. Marco de encabezado para el título
    • Main.htm. Marco principal con las secuencias de comandos de instalación y un vínculo a Info.htm
  • Info.htm. Información acerca de todos los componentes disponibles

La mayoría de los cambios que realice se harán en Main.htm, que se compone de tres partes:

  • Secuencias de comandos de instalación
  • Tabla de casillas de verificación, nombres de componentes y tamaños
  • Control ActiveX de instalación

Usar los archivos de ejemplo

Copie los cuatro archivos de ejemplo a su ubicación de descarga o a la ubicación que especifique y modifíquelos utilizando un editor de texto o en un editor HTML.

Para que la secuencia de comandos funcione correctamente, los archivos deben instalarse de la manera siguiente:

  • El archivo IEcif.cab debe estar en un servidor Web.
  • En la sección <SCRIPT> de Main.htm, la entrada L_cab_Address= debe señalar a la ubicación de IEcif.cab.
  • La tabla de Main.htm sólo debe contener los componentes que haya descargado de Microsoft y que desee proporcionar.

Para agregar nuevos componentes

  1. Asegúrese de que ha descargado los componentes durante la Sincronización automática de versiones (AVS).
  2. Busque el nombre correcto del componente en el archivo IESetup.cif.
  3. Agregue una casilla de verificación con ese nombre a Addon.htm.

Notas

  • Los componentes para los usuarios de Windows y Windows NT pueden tener nombres diferentes. Puede encontrar esta información en IESetup.cif.
  • IESetup.cif incluye automáticamente cualquier componente nuevo o actualizado que haya descargado mediante actualizaciones de Sincronización automática de versiones.

Los autores expertos en páginas Web pueden omitir el uso de la plantilla proporcionada en IEAK.

Información para autores expertos de páginas Web

En Main.htm se utilizan dos lenguajes de secuencias de comandos: Microsoft JScript y Microsoft Visual Basic Scripting Edition (VBScript). El código de JScript contiene la función Install(). Esta función se inicia cuando el usuario hace clic en el botón Instalar que hay en la parte inferior de la página. La función controla el proceso de instalación. La función Install() realiza llamadas a varias subrutinas de VBScript.

Las secuencias de comandos utilizan la propiedad name (en la etiqueta input) de las casillas de verificación para leer el archivo IESetup.cif. Este archivo está incluido en el archivo IEcif.cab y lo abre la subrutina Window_onLoad().

Para averiguar si un componente ya está instalado, puede utilizar la subrutina IsComponentInstalled() de VBScript.

IsComponentInstalled(IdComponente)

Donde IdComponente es el mismo nombre que el de la casilla de verificación y el valor en IESetup.cif.

Código devuelto | Significado
0 | Componente no instalado
1 | Componente ya instalado
2 | El componente está instalado, pero hay una versión más reciente disponible
3 | Bloqueo de seguridad del usuario: no se determinó el estado

Cuando se comprueba el primer componente mediante este método, el motor ActiveX activa un cuadro de diálogo de seguridad que solicita permiso para comprobar el estado de los componentes instalados en el equipo del usuario. Si el usuario elige "No", se devuelve el código 3 para todos los componentes.


Empaquetar actualizaciones de Microsoft en componentes personalizados

Es posible que desee instalar una versión de un componente de Microsoft distinto del que está disponible mediante la Sincronización automática de versiones (AVS). Por ejemplo, sus usuarios podrían tener una revisión (QFE) que esté disponible en Windows Update, pero no en AVS. Asimismo, su organización podría utilizar de forma estándar una versión diferente de un componente de Microsoft incluido en Internet Explorer, como Microsoft NetMeeting, por lo que sería aconsejable que los usuarios emplearan esa versión en lugar de la que incluye el asistente para el IEAK en su paquete.

En este caso, puede empaquetar estos archivos en un componente personalizado que se incluirá en su paquete personalizado.

Importante

  • Antes de buscar en Windows Update componentes más recientes, compruebe si existen componentes actualizados o nuevos a través de AVS en el Asistente para personalizar Internet Explorer 6. El programa de instalación de Windows Update instala automáticamente cualquier componente descargado a través de AVS que desee incluir en el paquete. En este caso, no es necesario incluir los archivos equivalentes de Windows Update en un paquete personalizado. Para obtener más información sobre esta nueva característica, consulte Actualizaciones de sincronización automática de versiones (AVS).

Para reducir el número de reinicios del sistema realizados por los usuarios, puede elegir el momento en que se instalará este componente con relación al resto de las fases del proceso de instalación. Puede instalar el componente antes o después de instalar Internet Explorer, o bien después del reinicio requerido del sistema.


Desinstalar un componente personalizado

Al registrar el programa de desinstalación del componente personalizado durante la instalación de éste, los usuarios podrán quitar el programa haciendo clic en el icono Agregar o quitar programas del Panel de control. Para ver un ejemplo de archivo de desinstalación, consulte el archivo Uncheck.inf de la carpeta \<carpeta de programa IEAK>\Toolkit\Inf del Kit de herramientas de IEAK.

Para registrar el programa de desinstalación de modo que aparezca en Agregar o quitar programas del Panel de control durante el proceso de instalación de componentes, la aplicación debe agregar las entradas enumeradas a continuación a la siguiente clave de Registro:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\Nombre de aplicación

El programa de instalación de Windows Update también utiliza esta clave del Registro para comprobar si el componente se instaló correctamente.

Subclave | Tipo de datos | Valor
DisplayName | Cadena | Nombre descriptivo de la aplicación.
UninstallString | Cadena | Línea de comandos completa (con la ruta de acceso) para desinstalar la aplicación. No utilice un archivo por lotes ni un subproceso.

El valor de ApplicationName también debe coincidir con el valor de Uninstall Key, en la pantalla Agregar componentes personalizados del Asistente para personalizar Internet Explorer 6.


Extensiones del programa de instalación de Windows

Puede ampliar el programa de instalación de Windows de tres formas:

  • Ejecutar los archivos .inf de Windows desde la línea de comandos con Rundll.exe.
  • Instalar componentes opcionales de software de Windows desde un código de programa de 32 bits como alternativa a que el usuario instale software desde el cuadro de diálogo Agregar o quitar programas en el Panel de control.
  • Crear un icono en el escritorio de Windows en el que el usuario pueda hacer clic para ejecutar un archivo .inf; de esta forma no es necesario desarrollar código para el programa de instalación.

Ejecutar archivos .inf desde la línea de comandos

Puede usar los comandos del sistema Rundll.exe o Rundll32.exe de Windows para ejecutar una sección Install en un archivo .inf. La sintaxis de la línea de comandos es la siguiente:

RunDll setupx.dll,InstallHinfSection <sección> <modoDeReinicio> <nombreInf>

El parámetro <sección> es una sección Install del archivo .inf. Por ejemplo, la línea de comandos siguiente instala el componente opcional Games y, si el programa de instalación determina que se debe reiniciar el equipo, le pregunta al usuario si desea reiniciar el equipo inmediatamente una vez que se complete la instalación. El significado de los valores del parámetro <modoDeReinicio> se describe en "Utilizar el parámetro modo de reinicio", a continuación.

RunDll setupx.dll,InstallHinfSection games 4 applets.inf

Notas

  • Este comando supone que se dispone del espacio en disco necesario para instalar los archivos. No realiza ninguna comprobación del espacio en disco.
  • La aplicación de instalación no debe ejecutar código después de que se realice una llamada a RUNDLL o RUNDLL32 porque, una vez que Setupx.dll tiene el control, puede ocasionar que se reinicie el equipo. Si el proceso de instalación tiene que ejecutar otro código después de que el suyo llame a RUNDLL o RUNDLL32, use la lista RunOnce del archivo .inf.
  • No use la lista RunOnce para ejecutar el componente opcional que está instalando.

Usar el parámetro modo de reinicio

Hay cinco modos de reinicio:

defina HOW_NEVER_REBOOT 0
defina HOW_ALWAYS_SILENT_REBOOT 1
defina HOW_ALWAYS_PROMPT_REBOOT 2
defina HOW_SILENT_REBOOT 3
defina HOW_PROMPT_REBOOT 4

Si <nombreInf> especifica su archivo .inf en lugar de un archivo .inf de Windows, sume 128 a los valores mostrados arriba. En el ejemplo anterior que instala el componente opcional Games, <modoDeReinicio> se establece a 4. Esto se debe a que Applets.inf es un archivo .inf de Windows. Si está instalando un componente opcional que tiene su propio archivo .inf, establezca <modoDeReinicio> a 132. Si suma 128 al parámetro <modoDeReinicio>, todos los archivos que instale deben estar en la misma carpeta que su archivo .inf del disco de instalación.

Nota

  • Los únicos valores recomendados para <modoDeReinicio> son 4, si el archivo .inf es de Windows 95, o 132, si es un archivo .inf proporcionado por usted. Usar otro de los valores mostrados anteriormente puede ocasionar que el equipo se reinicie innecesariamente o que no lo haga cuando debiera.

La lista siguiente describe cada modo de reinicio:

NeverReboot
Establece <modoDeReinicio> a 0 o 128. El equipo no se reiniciará en ningún caso. El cliente decide si el equipo debe reiniciarse. Para el programa de instalación, esto significa que hay un archivo C:\Windows\Wininit.ini que no tiene un tamaño de cero bytes.

AlwaysSilentReboot
Establece <modoDeReinicio> a 1 o 129. No se pedirá al usuario que reinicie el equipo y éste se reiniciará siempre.

AlwaysPromptReboot
Establece <modoDeReinicio> a 2 o 130. Siempre se pedirá al usuario que decida si desea reiniciar el equipo. El programa de instalación no intenta determinar si es necesario reiniciar el equipo.

SilentReboot
Establece <modoDeReinicio> a 3 o 131. Si el programa de instalación determina que es necesario reiniciar el equipo, no hay interacción con el usuario.

PromptReboot
Establece <modoDeReinicio> a 4 o 132. Si el programa de instalación determina que es necesario reiniciar el equipo, pregunta al usuario con un cuadro de diálogo.

Volver al principio del archivo

Instalar componentes opcionales desde el código de una aplicación de 32 bits

Una vez que Windows se instala en un equipo, puede ser necesario agregar uno o varios componentes opcionales de Windows, por ejemplo, Games. Este tipo de instalación, que ocurre después de que el programa de instalación instale inicialmente Windows, se denomina instalación en modo de mantenimiento. Normalmente, la instalación en modo de mantenimiento se inicia desde Windows al hacer clic en el icono Agregar o quitar programas del Panel de control. Sin embargo, hay una alternativa disponible para los fabricantes y proveedores del componente de software opcional: pueden instalarlo mediante una llamada a CreateProcess en una aplicación de 32 bis.

Nota

  • El método CreateProcess de instalación de un componente opcional descrito a continuación debe usarse sólo en aplicaciones de 32 bits.

Para instalar un componente opcional desde una aplicación de 32 bits, use una combinación de los métodos descritos a continuación.

Comprobar el Registro

En primer lugar, compruebe el Registro para ver si el componente opcional ya está instalado o busque los archivos. La clave del Registro que contiene información acerca de todos los componentes opcionales instalados actualmente es la siguiente:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents]

Hay valores debajo de esta clave que señalan a subclaves y cada subclave contiene información acerca de los componentes opcionales instalados, así como información necesaria para instalar un componente opcional nuevo. Por ejemplo, suponga que desea instalar Games como componente opcional. Para ver si Games está instalado, busque el valor de la subclave siguiente debajo de la clave OptionalComponents:

"Games"="Games"

A continuación, abra la clave "Games" situada debajo de la clave de componentes opcionales para buscar lo siguiente:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents\Games]
"INF"="applets.inf"
"Section"="games"
"Installed"="0"

Esto indica que el componente opcional Games no está instalado en este equipo Windows, porque el indicador "Installed" tiene el valor 0.

Codificar una llamada a la función CreateProcess

Para instalar un componente opcional como Games, use los valores "INF" y "Section" de la clave anterior en una llamada a CreateProcess que ejecute Setupx.dll a través de RUNDLL. Este método hace exactamente lo mismo que Agregar o quitar programas en el Panel de control cuando instala un componente. La sintaxis del parámetro lpCommandLine en la llamada a CreateProcess es la siguiente:

RunDll setupx.dll,InstallHinfSection <sección> <modoDeReinicio> <nombreInf>

Los valores de los parámetros <sección> y <nombreInf> son los de la clave del Registro descrita anteriormente. Por ejemplo, la llamada a CreateProcess siguiente instala el componente opcional Games y, si el programa de instalación de Windows determina que hay que reiniciar el equipo, pregunta al usuario si desea que se reinicie inmediatamente una vez que se complete la instalación. El significado de los valores del parámetro <modoDeReinicio> se describe en la sección "Usar el parámetro modo de reinicio".

RunDll setupx.dll,InstallHinfSection games 4 applets.inf

Nota

  • Se recomienda que comprobar el espacio en disco disponible antes de instalar el componente. Cuando se realice dicha comprobación, tenga en cuenta que debe haber espacio en disco para los archivos de intercambio del sistema.

La aplicación de instalación no debe ejecutar código después de que se realice una llamada a CreateProcess porque, una vez que Setupx.dll tiene el control, el código adicional puede ocasionar que se reinicie el equipo del usuario. Si el proceso de instalación tiene que ejecutar otro código después de que el suyo llame a CreateProcess, use la lista RunOnce del archivo .inf.

Nota

  • No use la lista RunOnce para ejecutar el componente opcional que está instalando.

Hacer clic con el botón secundario del mouse en un archivo .inf para ejecutarlo

El programa de instalación reconoce un nombre de sección Install concreto, DefaultInstall, en los archivos .inf que instalan componentes opcionales. Si usa una sección [DefaultInstall] en su archivo .inf, el usuario puede hacer clic con el botón secundario del mouse en un icono del archivo .inf de la interfaz de usuario de las versiones de Windows de 32 bits para ejecutar la sección [DefaultInstall]. Cuando el usuario hace clic con el botón secundario del mouse en el icono de un archivo .inf, aparece un menú emergente donde el usuario puede seleccionar la opción Install para ejecutar realmente la sección [DefaultInstall].

Si utiliza una sección Install denominada [DefaultInstall] en su archivo .inf, estará ofreciendo un método cómodo de instalar el componente opcional. Esto es especialmente útil durante el desarrollo de su aplicación. Si va a escribir una aplicación de instalación, dispondrá de un método para instalar el componente opcional antes de desarrollar el código de la aplicación.

El siguiente es un ejemplo de sección DefaultInstall que contiene entradas típicas:

[DefaultInstall]
CopyFiles=QCD.copy.prog, QCD.copy.hlp, QCD.copy.win, QCD.copy.sys, QCD.copy.inf
UpdateInis=QCD.Links
AddReg=QCD.reg, QCD.run
Uninstall=FlexiCD_remove


Tratar carpetas y archivos mediante la utilización de archivos de información para la instalación (.inf)

Puede usar archivos .inf para tratar archivos y carpetas de varias formas. Las más importantes son:

  • Crear carpetas y vínculos en carpetas
  • Crear y eliminar nombres de archivo largos
  • Establecer atributos para archivos y carpetas
  • Copiar archivos a la carpeta Archivos de programa

Crear carpetas y vínculos en carpetas

Crear una carpeta en la carpeta Archivos de programa o crear vínculos en una carpeta es una operación que realiza el shell una vez que el componente se ha instalado. El programa de instalación busca en el archivo Setup.ini una sección [progman.groups] y, a continuación, la analiza para crear carpetas y vínculos en esas carpetas.

Si instala un componente que requerirá una carpeta o vínculos en la carpeta Archivos de programa, cree una sección UpdateInis para crear las entradas apropiadas en el archivo Setup.ini. El archivo Setup.ini aplica la siguiente sintaxis para crear carpetas y vínculos. Tenga en cuenta que las carpetas son relativas al menú Inicio.

[progman.groups]
carpeta_1=nombreCarpeta_1
carpeta_2=nombreCarpeta_2
:
carpeta_n=Nombre_Carpeta_n

[carpeta_1]
Nombre_Vínculo, .nombre_exe, nombre_archivo_icono, índice_icono, perfil

Si el campo perfil tiene NULL a la izquierda, el vínculo siempre se agregará a la carpeta.

Notas

  • Si .nombreExe es un elemento NULL, se eliminará del grupo si ya existe allí.
  • Si la descripción de una carpeta o vínculo tiene un espacio, debe usar comillas tipográficas dobles para conseguir que se refleje en el archivo Setup.ini. Vea los ejemplos siguientes.

Ejemplo: Juegos

[Opcional Components]
games
[games]
OptionDesc= %GAMES_DESC%
CopyFiles= wingames.files
UpdateInis= wingames.links
[wingames.files]
cards.dll
freecell.exe
freecell.hlp
mshearts.exe
mshearts.hlp
sol.exe
sol.hlp
winmine.exe
winmine.hlp
[wingames.links]
setup.ini, progman.groups,, "gamesfolder=%GAMES_DESC%" ;crea carpeta
setup.ini, gamesfolder,, """Juego Solitario"",SOL.EXE,,," ;crea vínculo
setup.ini, gamesfolder,, "Minesweeper,WINMINE.EXE,,," ;crea vínculo
setup.ini, gamesfolder,, ""Juego de cartas Corazones"",MSHEARTS.EXE,,,";crea vínculo
setup.ini, gamesfolder,, "FreeCell,FREECELL.EXE,,," ;crea vínculo

Resultado: la entrada para "Games" aparece en el cuadro de diálogo Opcional Components en el programa de instalación y, si se selecciona, se crea una carpeta Games en la carpeta Archivos de programa con vínculos a Solitario, Buscaminas, Corazones y Carta blanca.

Crear y eliminar nombres de archivo largos

La rama raíz del Registro para las operaciones de cambio de nombre es la siguiente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RenameFiles

La rama raíz del Registro para las operaciones de eliminación es la siguiente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\DeleteFiles

Cada grupo de operaciones de cambio de nombre y eliminación se agrega a una subclave debajo de cada rama. Cada grupo de operaciones se limita a cambiar el nombre o eliminar los archivos de una única carpeta. Debe incluir, como mínimo, dos entradas en cada subclave para que surta efecto un cambio de nombre o una eliminación: la ruta de acceso de la carpeta de los archivos cuyo nombre se va a cambiar o se van a eliminar, y la operación de cambio de nombre o eliminación real.

La primera clave de cada grupo de operaciones es la entrada folder. Cada entrada para una operación de cambio de nombre en la carpeta relacionada es una entrada con el formato "nombreCortoAntiguo"="nombreLargoNuevo,[indicadorAtributo]".

El parámetro indicadorAtributo se usa para establecer atributos de archivo durante la operación de cambio de nombre. El indicador puede tener los valores siguientes.

1 | READONLY
2 | HIDDEN
3 | SYSTEM

Para establecer varios atributos en un archivo o carpeta, los indicadores se suman; por ejemplo, para establecer los atributos READONLY y HIDDEN, indicadorAtributo debe ser 3.

El ejemplo siguiente es una sección AddReg que establece los atributos SYSTEM y HIDDEN para la carpeta \Windows\system32\Sample:

HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,,,%11%
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,SAMPLE,,"SAMPLE,6"

Nota

  • Debe usar letras mayúsculas para asegurar que el nombre de archivo siga siendo un nombre corto.

Cada entrada para una operación de eliminación en la carpeta relacionada tiene el formato "nombreClaveArbitrario"="nombreLargoQueEliminar".

El ejemplo siguiente es una sección AddReg que:

  • Cambia el nombre del archivo nombrant.txt a Nombre Largo Nuevo.txt en la carpeta C:\Samples.
  • Cambia el nombre del archivo Mileame.txt a Leame De Mi Aplicacion.txt en la carpeta Windows.
[MyAppShort2Long]
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Samples,,,C:\Samples
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Samples,nombrant.txt,,"Nombre
Largo Nuevo.txt"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,Mileame.txt,,"Leame De Mi Aplicacion.txt"

El ejemplo siguiente es una sección AddReg que:

  • Elimina Nombre Largo Nuevo.txt de la carpeta C:\Samples.
  • Elimina Leame De Mi Aplicacion.txt de la carpeta Windows.
[MyAppDelLong]
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Samples,,,C:\Samples
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Samples,nombrant.txt,,"Nombre
Largo Nuevo.txt"
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,myreadme.txt,,"Leame de Mi Aplicacion.txt"

Una vez se ha cambiado el nombre de estas entradas o se han eliminado y procesado, éstas se quitan del Registro.

Nota

  • Durante la operación de cambio de nombre, el archivo de destino se elimina antes de que cualquier archivo se cambie de nombre. Si la misma operación de cambio de nombre se introduce en la cola dos veces, podría ocasionar la pérdida del archivo. Por ejemplo, suponga que hay un mapa de bits que tiene que cambiar de nombre de imagen.bmp a "Imagen 3D Realmente Buena.bmp". La segunda vez que se realizara una operación de cambio de nombre, "Imagen 3D Realmente Buena.bmp" ya existiría, de forma que se eliminaría antes de que se realizara la operación de cambio de nombre. La excepción a esta regla se produce cuando el nombre de archivo de destino existente es una carpeta.

Establecer atributos para archivos y carpetas

Para establecer los atributos de un archivo o carpeta, puede usar la misma convención que para crear nombres de archivo largos mediante un indicador opcional.

Para obtener más detalles, consulte la sección "Crear y eliminar nombres de archivo largos".

Copiar archivos a la carpeta Archivos de programa

En el ejemplo siguiente se copian tres archivos a la carpeta Archivos de programa\Accesorios y se crean vínculos a uno de los archivos:

[WordPadInstall
CopyFiles = WordPadCopyFiles
UpdateInis = WordPadInis
[DestinationDirs]
WordPadCopyFiles = 24,%PROGRAMF%\%ACCESSOR%
[WordPadCopyFiles]
mswd6_32.wpc
wordpad.exe
write32.wpc
[WordPadInis]
setup.ini, progman.groups,, "group4=%APPS_DESC%" ;crea carpeta Accesorios (si todavía no existe)
setup.ini, group4,, """%WORDPAD_LINK%"",
""%24%\%PROGRAMF%\%ACCESSOR%\WORDPAD.EXE""" ;crea vínculo en carpeta Accesorios
[Strings]
APPS_DESC = "Accesorios"
WORDPAD_LINK = "WordPad"
; Nombres de carpetas - las versiones abreviadas deben coincidir con las truncadas
; nombre de 8 caracteres para las versiones largas, de no ser así surgirán problemas.
PROGRAMF = "Archiv~1" ; primeros 6 caract de Archivos_de_programa, + "~1"
ACCESSOR = "Acceso~1" ; primeros 6 caracteres de Accesorios, + "~1"

Limitaciones de los archivos .inf

  • No se puede eliminar directorios.
  • Los archivos no se pueden mover a una ubicación diferente cuando se utiliza RenFiles. (El comando RenFiles sólo cambia el nombre de un archivo en un lugar).
  • No se puede hacer copias de un archivo. (El comando CopyFiles sólo copia archivos desde un disco de origen a un directorio de destino).


Proporcionar la funcionalidad de desinstalación en una secuencia de comandos .inf

Puede proporcionar la funcionalidad de desinstalación en sus archivos .inf agregando una sección Install que quite los archivos, las entradas del Registro y los accesos directos, y agregue a continuación su componente a la lista de programas que se pueden desinstalar desde el cuadro de diálogo Agregar o quitar programas del Panel de control. En la carpeta \<carpeta de programa IEAK>\Toolkit\inf\ del Kit de herramientas del IEAK se incluye un ejemplo.

Para agregar su componente al cuadro de diálogo Agregar o quitar programas, agregue una clave nueva y valores debajo de la clave del Registro siguiente:

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\nombre-aplicación,"DisplayName",,"descripción"
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\nombre-aplicación,"UninstallString",,"líneaComandos"

descripción
Esta cadena se muestra en el cuadro de lista del cuadro de diálogo Agregar o quitar programas.

líneaComandos
Es el comando que se ejecuta cuando el componente se selecciona en el cuadro de lista del cuadro de diálogo Agregar o quitar programas. Para ejecutar una sección de un archivo .inf, puede usar el punto de entrada InstallHinfSection de Setupx.dll, que se describe posteriormente.

Los ejemplos de entradas AddReg siguientes agregan "Mi aplicación de prueba" al cuadro de lista del cuadro de diálogo Agregar o quitar programas y ejecuta la sección Install Remove_TestApp en Test.inf:

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"DisplayName",,"Mi
aplicación de prueba"
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"UninstallString",,"RunDll
setupx.dll,InstallHinfSection Remove_TestApp 4 test.inf"

Notas

  • La secuencia de comandos de instalación debe copiar el archivo .inf en la carpeta Windows\Inf cuando se instale el componente. Ésta es la ubicación predeterminada que se busca cuando se llama al punto de entrada InstallHinfSection de Setupx.dll.
  • La secuencia de comandos de desinstalación debe quitar la clave que se haya creado debajo de la clave del Registro Uninstall de forma que su programa deje de mostrarla en el cuadro de lista de Agregar o quitar programas una vez que se haya desinstalado.


Ejemplo de archivo .inf para el servicio de descarga de componentes

;El ejemplo de archivo .inf que se muestra a continuación realiza las acciones siguientes:
; - Copia archivos a las carpetas Windows, System, Inf y Help.
; - Crea diversas entradas del Registro (incluyendo entradas que
; cambiarán el nombre a los archivos copiados por nombres de archivo largos).
; - Crea un vínculo en el menú Ayuda.
; - Tiene una sección de desinstalación que registra la acción
; de desinstalación en el cuadro de diálogo Agregar o quitar programas del Panel de control.
; - Usa cadenas reemplazables para facilitar la conversión a otros idiomas.
[Version]
Signature=$CHICAGO$
[DestinationDirs]
SampleCopy = 24,%PROGRAMF%\Sample
SampleDel = 24,%PROGRAMF%\Sample
SampleWinCopy = 25
SampleSysCopy = 11
SampleINFCopy = 17
SampleHLPCopy = 18
[DefaultInstall]
CopyFiles = SampleCopy, SampleWinCopy, SampleSysCopy, SampleINFCopy,
SampleHLPCopy AddReg = SampleRegisterApp, SampleRegUninstall,
SampleRenameFiles UpdateInis = SampleAddLinks
[RemoveSample]
DelFiles = SampleWinCopy, SampleSysCopy, SampleINFCopy, SampleHLPCopy
DelReg = SampleUnRegisterApp, SampleRegUninstall
AddReg = SampleRemoveLFNs
UpdateInis = SampleRemoveLinks
[SampleCopy]
sample.bmp
[SampleWinCopy]
sample.exe
[SampleSysCopy]
sample.dll
[SampleINFCopy]
sample.inf
[SampleHLPCopy]
sample.hlp
[SampleRegisterApp]
;Crea una entrada del Registro arbitraria (para uso privado de Sample.exe):
HKLM,Software\Sample,Installed,,"1"
[SampleUnRegisterApp]
;Elimina la entrada del Registro (tenga en cuenta que se elimina toda la clave):
HKLM,Software\Sample
[SampleRegUninstall]
;Agrega una entrada al cuadro de diálogo Agregar o quitar programas del Panel de control para desinstalar el programa:
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"DisplayName",,"Sample
Application"
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"UninstallString",,"RunDll
setupx.dll,InstallHinfSection RemoveSample 4 sample.inf"
[SampleRenameFiles]
;Vuelve a nombrar archivos con formato 8.3 por archivos con nombres largos:
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,,,"%24%\%PROGRAMF%\Sample"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,sample.bmp,,"Sample
Bitmap.bmp"
[SampleRemoveLFNs]
;Elimina archivos con nombres de archivo largos durante el proceso de desinstalación:
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,,,"%24%\%PROGRAMF%\Sample"
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,sample.bmp,,"Sample
Bitmap.bmp"
[SampleAddLinks]
;Agrega un acceso directo a Sample.exe en el menú Inicio:
setup.ini, progman.groups,, "Sample=%SampleFolder%" ;crea carpeta
setup.ini, Sample,, """%SampleDesc%"", %25%\SAMPLE.EXE" ;crea vínculo
[SampleRemoveLinks]
;Quita accesos directos a Sample.exe en el menú Inicio durante la desinstalación:
setup.ini, progman.groups,, "Sample=%SampleFolder%" ;crea carpeta
setup.ini, Sample,, """%SampleDesc%""" ;elimina vínculo
[SourceDisksNames]
99 = %DiskName%,Sample,0
[SourceDisksFiles]
sample.exe = 1,,13456
sample.dll = 1,,20987
sample.bmp = 1,,64098
sample.hlp = 1,,55441
sample.inf = 1,,5687
[Strings]
PROGRAMF = "PROGRA~1"
SampleFolder = "Ejemplos"
SampleDesc = "Ejemplo de aplicación"
DiskName = "Ejemplo de disco de instalación de aplicación"


Definición del archivo de información para la instalación (.inf)

Un archivo básico .inf contiene las secciones siguientes (los archivos .inf más complejos pueden tener secciones adicionales). Los nombres de sección en negrita son palabras clave reservadas. Los nombres de sección en cursiva son nombres arbitrarios creados por el autor del archivo .inf:

  • Sección Version
  • Secciones Install
    • Secciones Copy File (CopyFiles)
    • Secciones Rename Files (RenFiles)
    • Secciones Delete Files (DelFiles)
    • Secciones Update .ini File (UpdateInis)
    • Secciones Update .ini Fields (UpdateIniFields)
    • Secciones Add Registry (AddReg)
    • Secciones Delete Registry (DelReg)
    • Secciones Add Ini File to Registry (Ini2Reg)
    • Secciones Update Config.sys (UpdateCfgSys)
    • Secciones Update Autoexec.bat (UpdateAutoBat)
  • Sección DestinationDirs
  • Sección SourceDisksNames
  • Sección SourceDisksFiles
  • Sección Strings
  • Sección Opcional Components
[Version] | Información elemental acerca de la versión para validar el archivo .inf.
[DefaultInstall] | Sección relativa a la instalación que se ejecuta de forma predeterminada. Contiene punteros a otras secciones que especifican archivos para copiar y eliminar, actualizaciones del Registro, actualizaciones de archivos .ini, etc.
[OtherInstall] | Usa el mismo formato que la sección [DefaultInstall], pero se debe llamar explícitamente. Resulta de utilidad para definir cómo se debe instalar un componente.
[DestinationDirs] | Especifica el lugar en el disco duro donde se van a copiar, eliminar o cambiar de nombre los archivos de una sección, por ejemplo, \Windows o Windows\System.
[Secciones FileCopy, Delete o Rename] | Enumeran los archivos que se van a copiar, eliminar o cambiar de nombre.
[Secciones RegistryUpdate] | Especifican eliminaciones o adiciones al Registro.
[Secciones IniFileUpdate] | Especifican actualizaciones de los archivos .ini. Los vínculos se crean en estas secciones.
[SourceDisksNames] | Enumera los discos que contienen los archivos.
[SourceDisksFiles] | Enumera el disco determinado en el que se encuentra cada archivo.
[Strings] | Enumera las cadenas convertibles a otros idiomas usadas anteriormente.
Volver al principio del archivo

Sección Version

[Version]
Signature="$Chicago$"
LayoutFile=nombre archivo.inf
Define el encabezado estándar para los archivos .inf de Windows. Tenga en cuenta que, si la firma (Signature) no es $Chicago$, Windows no aceptará el archivo como un archivo .inf para ninguna de las clases de dispositivo reconocidas por Windows.

Observe que el reconocimiento de la cadena de la firma no distingue mayúsculas y minúsculas. Por ello puede usar tanto $Chicago$ como $CHICAGO$, por ejemplo.

nombre archivo.INF
Nombre del archivo .inf que contiene la información de distribución (archivos y discos de origen) necesaria para instalar este componente. Esta línea es opcional. Si no se proporciona en ningún otro lugar, las secciones SourceDisksNames y SourceDisksFiles se deben especificar en este archivo .inf.

En el ejemplo siguiente se muestra una sección Version común:

[Version]
Signature="$CHICAGO$"
Volver al principio del archivo

Sección Install

[nombre-sección-install]

Copyfiles = sección-lista-archivo[,<sección-lista-archivo>]...
Renfiles = sección-lista-archivo[,sección-lista-archivo]...
Delfiles = sección-lista-archivo[,sección-lista-archivo]...
UpdateInis = sección-update-ini[,sección-update-ini]...
UpdateIniFields = sección-update-inifields[,sección-update-inifields]...
AddReg = sección-add-registry[,sección-add-registry]...
DelReg = sección-del-registry[,sección-del-registry]...
Ini2Reg = sección-ini-to-registry[,sección-ini-to-registry]...
UpdateCfgSys = sección-update-config
UpdateAutoBat =sección-update-autoexec

Identifica las secciones adicionales del archivo .inf que contienen información acerca de la instalación del componente.

No todos los tipos de elemento mostrados en la sintaxis anterior son necesarios u obligatorios en una sección Install. Si se usa un tipo de elemento, debe especificar el nombre de una sección en el archivo .inf. (Una excepción es el elemento CopyFiles, que puede usar el carácter "@" junto con un nombre de archivo para copiar un único archivo sin especificar un nombre de sección.) El nombre de sección debe estar formado por caracteres imprimibles.

En una sección Install, sólo se puede usar un elemento de cada tipo. En un elemento puede enumerarse más de un nombre de sección pero cada nombre adicional debe ir precedido por una coma.

nombre-sección-install Si asigna el nombre [DefaultInstall] a la sección install, se ejecutará al hacer clic con el botón secundario del mouse (ratón) en el archivo .inf y seleccionar Install. Ésta también es la sección que se ejecuta al seleccionar un archivo .inf como la opción de instalación mediante el Asistente Cabpack.

En el ejemplo siguiente se muestra una sección Install típica. Contiene elementos Copyfiles y AddReg que identifican las secciones que contienen la información acerca de los archivos que se instalarán.

[MiAplicación]
Copyfiles=MyAppWinFiles, MyAppSysFiles, @SRSutil.exe
AddReg=MyAppRegEntries

En este ejemplo, observe que al cambiar el nombre de la sección [MiAplicación] a [DefaultInstall], la sección Install se ejecutará al hacer clic con el botón secundario del mouse en el archivo .inf y seleccionar Install.

El elemento CopyFiles proporciona una notación especial que permite que un único archivo se copie directamente desde la línea copy. Puede copiar un archivo individual si antepone al nombre de archivo el símbolo @. El destino de los archivos copiados con esta notación es el directorio DefaultDestDir, tal como se define en la sección DestinationDirs . En el ejemplo siguiente se muestra cómo copiar archivos individuales:

CopyFiles=SeccionArchivo1,@miarchivo.txt,@otroarchivo.txt,NombreUltimaSeccion

Volver al principio del archivo

Secciones Copy Files (CopyFiles)

[nombre-sección-CopyFiles]
nombre-archivo-destino[, nombre-archivo-origen][,nombre-archivo-temporal][,indicador]
[nombre-archivo-destino[,nombre-archivo-origen][, nombre-archivo-temporal]][,indicador]

Enumeran los nombres de los archivos que se copiarán de un disco de origen a un directorio de destino. El disco de origen y el directorio de destino asociados a cada archivo se especifican en otras secciones del archivo .inf. El nombre sección-lista-archivo debe aparecer en el elemento CopyFiles de una sección Install.

Tenga en cuenta que puede especificar la copia de un único archivo en el elemento CopyFiles de la propia sección Install, sin tener que generar una sección CopyFiles. Para ello, use el carácter especial "@" para forzar la copia de un único archivo. Hay un ejemplo de utilización del carácter "@" en un elemento del tipo CopyFiles en el tema "Referencia" de la sección Install. La copia de un único archivo realizada de esta forma está algo limitada porque los nombres de archivos de origen y de destino deben coincidir en este caso y no se puede usar un archivo temporal.

nombre-archivo-destino
Nombre del archivo de destino. Éste será también el nombre del archivo de origen, si no se proporciona ninguno.

nombre-archivo-origen
Nombre del archivo de origen. Si coinciden los nombres de los archivos de origen y de destino para la operación de copia, este elemento no es necesario.

nombre-archivo-temporal
Nombre de un archivo temporal para la operación de copia de archivos. El instalador copia el archivo de origen pero le da el nombre del archivo temporal. La próxima vez que se inicie el sistema operativo, cambiará el nombre del archivo temporal por el del archivo de destino. Esto es útil para copiar archivos a un destino que está abierto o que está usando Windows.

indicador
Parámetro opcional que se utiliza para realizar acciones especiales durante el proceso de instalación. Se pueden usar varios indicadores si se suman sus valores para crear un indicador combinado. Se pueden usar los siguientes indicadores válidos:

1 | En CopyFiles: advertir si el usuario intenta omitir el archivo.
1 | En DelFiles: Si el archivo se está usando, incluir en una cola la eliminación para que se realice después en Wininit.ini. De lo contrario, un archivo que se esté usando actualmente no se elimina.
2 | Instalación crítica: no permitir al usuario que omita el archivo.
4 | Omitir la comprobación de la versión y copiar siempre el archivo. Esta operación sobrescribirá un archivo más reciente.
8 | Forzar cambio de nombre. El programa de instalación trata este archivo como si se estuviera utilizando. Esto sólo sucede si el archivo ya existe en el equipo del usuario.
16 | No copiar el archivo si ya existe en el destino.
32 | Suprimir el cuadro de diálogo de conflicto de versión y no sobrescribir los archivos más recientes.

En el ejemplo siguiente se copian tres archivos:

[CopyTheseFilesSec]
archivo11 ; copia archivo11
archivo21, archivo22, archivo23 ; copia archivo22, nombrarlo temporalmente archivo23
archivo31, archivo32 ; copia archivo32 a archivo31

Todos los nombres de archivo de origen que se usan en este ejemplo deben definirse en una sección SourceDisksFiles y el número de disco lógico que aparece en la sección SourceDisksFiles debe haberse definido en una sección SourceDisksNames . También puede usar un archivo Layout.inf para proporcionar esta información.

Volver al principio del archivo

Secciones Rename Files (RenFiles)

[nombre-sección-rename-files]
nombre-archivo-nuevo, nombre-archivo-anterior
.
.
Enumeran los nombres de los archivos cuyo nombre se va a cambiar. El nombre de la sección debe aparecer en un elemento Renfiles de una sección Install del archivo .inf.

nombre-archivo-nuevo
Nombre nuevo del archivo.

nombre-archivo-anterior
Nombre anterior del archivo.

En el ejemplo siguiente se cambia el nombre de archivo42 a archivo41, archivo52 a archivo51 y archivo62 a archivo61:

[RenameOldFilesSec]
archivo41, archivo42
archivo51, archivo52
archivo61, archivo62

Todos los nombres de archivo que se utilizan en este ejemplo (archivo42, archivo52 y archivo62) deben definirse en una sección SourceDisksFiles y los números de disco lógico que aparecen en la sección SourceDisksFiles deben haberse definido en una sección SourceDisksNames.

Volver al principio del archivo

Secciones Delete Files (DelFiles)

[ sección-lista-archivo]
nombre-archivo[,,,indicador]
.

Una sección DelFiles enumera los nombres de los archivos que se van a eliminar. El nombre sección-lista-archivo debe aparecer en el elemento Delfiles de una sección Install.

nombre-archivo
Identifica el archivo que se va a eliminar.

indicador
Parámetro opcional que se usa para forzar que Windows elimine el archivo especificado en el elemento si se está utilizando durante el proceso de instalación. Para indicar a Windows que introduzca en una cola la operación de eliminación de archivo hasta que se haya reiniciado el equipo, establezca el valor del parámetro indicador a 1. Si un archivo marcado con un parámetro indicador=1 no se puede eliminar porque se está utilizando, se reiniciará el sistema una vez que se haya completado la instalación del dispositivo.

Si no usa el parámetro indicador con su valor establecido a 1 junto con un parámetro nombre-archivo, el archivo no se elimina del equipo si se está utilizando cuando se ejecuta la sección DelFiles.

En el ejemplo siguiente se eliminan tres archivos:

[DeleteOldFilesSec]
archivo1
archivo2
archivo3

Volver al principio del archivo

Secciones Update .ini File (UpdateInis)

[ nombre-sección-update-ini]
archivo-ini, sección-ini, [entrada-ini-anterior], [entrada-ini-nueva], [indicadores]
.
.
Reemplaza, elimina o agrega entradas completas en el archivo .ini especificado. El nombre de la sección, nombre-sección-update-ini, debe aparecer en el elemento UpdateInis de una sección Install en el archivo .inf.

archivo-ini
Nombre del archivo .ini que contiene la entrada que se va a cambiar. Para obtener más información acerca de cómo especificar el nombre de archivo .ini, consulte los comentarios más adelante.

sección-ini
Nombre de la sección que contiene la entrada que se va a cambiar.

entrada-ini-anterior
Opcional. Normalmente tiene el formato Clave=Valor.

entrada-ini-nueva
Opcional. Normalmente tiene el formato Clave=Valor. Tanto la clave como el valor pueden especificar cadenas reemplazables. Por ejemplo, la clave y el valor especificado en el parámetro entrada-ini-nueva podría ser %Cadena1%, donde la cadena que sustituye a %Cadena1% se define en la sección Strings del archivo .inf.

indicadores
Indicadores de acción opcionales. Pueden ser uno de los valores siguientes:

0 Predeterminado. Si la clave entrada-ini-anterior está presente en una entrada de un archivo .ini, dicha entrada se reemplaza con la entrada-ini-nueva. Tenga en cuenta que sólo las claves del parámetro entrada-ini-anterior y la entrada del archivo .inf deben coincidir; el valor de cada entrada se omite.

Para agregar entrada-ini-nueva al archivo .ini incondicionalmente, establezca la entrada-ini-anterior a NULL. Para eliminar entrada-ini-anterior del archivo .ini incondicionalmente, establezca entrada-ini-nueva a NULL.

1 | Si la clave y el valor de entrada-ini-anterior existen en una entrada del archivo .ini, dicha entrada se reemplaza con entrada-ini-nueva. Tenga en cuenta que el parámetro entrada-ini-anterior y la entrada del archivo .inf deben coincidir tanto en la clave como en el valor para que se realice la sustitución, a diferencia de lo que sucede si se utiliza un indicador de acción con el valor 0: en este caso sólo deben coincidir las claves para que se lleve a cabo la sustitución.
2 Si la clave del parámetro entrada-ini-anterior no existe en el archivo .ini, no se realiza ninguna operación en el archivo .ini.

Si la clave del parámetro entrada-ini-anterior existe en una entrada del archivo .ini y la clave del parámetro entrada-ini-nueva existe en una entrada del archivo .ini, la entrada del archivo .ini que coincida con la clave del parámetro entrada-ini-nueva se elimina y la entrada del archivo .ini que coincida con el parámetro entrada-ini-anterior se utiliza de la manera siguiente: la clave de la entrada del archivo .ini se reemplaza con la clave del parámetro entrada-ini-nueva.

Si la clave del parámetro entrada-ini-anterior existe en una entrada del archivo .ini y la clave del parámetro entrada-ini-nueva no existe en una entrada del archivo .ini, se agrega una entrada al archivo .ini compuesta por la clave del parámetro entrada-ini-nueva y el valor anterior.

Tenga en cuenta que la coincidencia del parámetro entrada-ini-anterior y una entrada del archivo .ini se basa sólo en la clave, no en la clave y el valor.

3 | Igual que lo que sucede con el valor 2 del parámetro indicador descrito anteriormente, excepto en que la coincidencia del parámetro entrada-ini-anterior y una entrada del archivo .inf se basa tanto en la clave como en el valor, no sólo en la clave.

Puede usar el carácter comodín asterisco (*) cuando especifique la clave y el valor, y se interpretará de forma correcta.

El nombre archivo-ini puede ser una cadena o una clave de cadena. Una clave de cadena tiene la forma %claveCad%, donde claveCad se define en la sección Strings del archivo .inf. En cualquier caso, el nombre debe ser un nombre de archivo válido.

Debe incluir el nombre de la carpeta que contiene el archivo, pero debe proporcionarse como un identificador de directorio lógico (LDID) en lugar de como un nombre real. El instalador reemplaza un LDID con un nombre real durante la instalación.

Un LDID tiene la forma %ldid%, donde ldid es uno de los identificadores predefinidos o un identificador definido en la sección DestinationDirs. Tenga en cuenta que, cuando se sustituyen las constantes LDID_BOOT y LDID_BOOTHOST, la barra diagonal inversa se incluye en la ruta de acceso. Por ejemplo, LDID_BOOT podría sustituirse por C:\. No obstante, en el archivo .inf puede usar el carácter barra inversa o no usarlo. Por ejemplo, tanto "%30%boot.ini" como "%30%\boot.ini" se pueden usar para hacer referencia a BOOT..ini en la raíz de la unidad de inicio.

Los ejemplos siguientes ilustran la utilización de elementos individuales de una sección Update .ini File en un archivo .inf:

%11%\sample.ini, Section1,, Value1=2 ; agrega nueva entrada
%11%\sample.ini, Section2, Value3=*, ; elimina entrada anterior
%11%\sample.ini, Section4, Value5=1, Value5=4 ; reemplaza entrada anterior

El conjunto de elementos siguiente de una sección del tipo Update .ini File de un archivo .inf funcionan juntos para operar en la sección Boot de SYSTEM..ini. La capacidad de establecer condiciones integrada en el parámetro indicadores de los elementos del archivo .inf se usa para agregar la entrada "comm.drv=comm.drv" a la sección Boot a menos que la entrada "comm.drv=*vcoscomm.drv" o "comm.drv=*r0dmdcom.drv" exista en la sección Boot, en cuyo caso la entrada existente se mantiene y la entrada "comm.drv=comm.drv" no se agrega al archivo .ini. En otras palabras, tras ejecutar las cuatro entradas del archivo .inf que se muestran debajo, habrá una entrada "comm.drv=" en la sección Boot del archivo .ini: "comm.drv=*vcoscomm.drv", "comm.drv=*r0dmdcom.drv" o "comm.drv=comm.drv."

system.ini, boot, "comm.drv=*vcoscomm.drv","~CommDrvTemp~=*", 3
system.ini, boot, "comm.drv=*r0dmdcom.drv","~CommDrvTemp~=*", 3
system.ini, boot,,"comm.drv=comm.drv"
system.ini, boot, "~CommDrvTemp~=*","comm.drv=*", 3

Volver al principio del archivo

Secciones Update .ini Fields (UpdateIniFields)

[ nombre-sección-update-inifields]
archivo-ini, sección-ini, nombre-perfil, [campo-anterior], [campo-nuevo],[indicadores]
.
.
Reemplazan, agregan y eliminan campos en el valor de una entrada .ini dada. A diferencia del tipo de sección Update .ini File, en este tipo de sección se reemplaza, agrega o elimina una parte de un valor de una entrada del archivo .ini en lugar de todo el valor. El nombre de la sección, nombre-sección-update-inifields, debe aparecer en el elemento UpdateIniFields de una sección Install del archivo .inf.

archivo-ini
Nombre del archivo .ini que contiene la entrada que se va a cambiar. Para obtener más información acerca de cómo especificar el nombre del archivo .ini, consulte el tema que describe el tipo de sección Update .ini File.

sección-ini
Nombre de la sección del archivo .ini que contiene la entrada que se va a cambiar.

nombre-perfil
Nombre de la entrada que se va a cambiar.

campo-anterior
Valor del campo que se va a eliminar.

campo-nuevo
Valor del campo que se va a agregar, si no está allí ya.

indicadores
Especifica si se debe tratar el parámetro campo-anterior y el parámetro campo-nuevo como si tuvieran un carácter comodín y qué carácter separador se va a utilizar cuando se anexe un campo nuevo a una entrada del archivo .ini. Puede ser uno de los valores siguientes:

Valor | Significado
0 | (Predeterminado) Tratar el carácter "*" literalmente cuando se busque la coincidencia de campos y no como un carácter comodín. Usar un espacio en blanco (" ") como separador al agregar un nuevo campo a una entrada.
1 | Tratar el carácter "*" como un comodín cuando se busque la coincidencia de campos. Usar un espacio en blanco (" ") como separador al agregar un nuevo campo a una entrada.
2 | Tratar el carácter "*" literalmente cuando se busque la coincidencia de campos y no como un carácter comodín. Usar una coma (",") como separador al agregar un nuevo campo a una entrada.
3 | Tratar el carácter "*" como un comodín cuando se busque la coincidencia de campos. Usar una coma (",") como separador al agregar un nuevo campo a una entrada.

Cualquier comentario en una línea del archivo .ini se quitará ya que podría no ser aplicable después de realizar los cambios. Cuando los campos de esta línea del archivo .ini se procesen, los espacios, tabulaciones y comas se usarán como delimitadores de campo. No obstante, se utiliza un espacio como separador cuando el campo nuevo se anexa a la línea.

Volver al principio del archivo

Secciones Add Registry (AddReg)

[ sección-add-registry]
cadena-raíz-reg, [subclave], [nombre-valor], [indicador], [valor]
[cadena-raíz-reg, [subclave], [nombre-valor], [indicador], [valor]]
.
.
Agregan subclaves o nombres de valor al Registro y establecen opcionalmente el valor. El nombre sección-add-registry debe aparecer en un elemento del tipo AddReg de una sección Install.

cadena-raíz-reg
Nombre raíz del Registro. Pueden ser uno de los valores siguientes:

HKCR igual que HKEY_CLASSES_ROOT
HKCU igual que HKEY_CURRENT_USER
HKLM igual que HKEY_LOCAL_MACHINE
HKU igual que HKEY_USERS.
HKR significa relativo a la clave pasada en GenInstallEx

subclave
Opcional. Identifica la subclave que se va a definir. Tiene el formato clave1\clave2\clave3.... Este parámetro se puede expresar como una cadena reemplazable. Por ejemplo, podría usar %Subclave1%, donde la cadena que sustituye a %Subclave1% se define en la sección Strings del archivo .inf.

nombre-valor
Opcional. Identifica el nombre del valor para la subclave. Para el tipo cadena, si el parámetro nombre-valor está vacío a la izquierda, el valor de la subclave especificado en el parámetro subclave se establece a una cadena NULL. Tenga en cuenta que el parámetro nombre-valor se puede expresar como una cadena reemplazable. Por ejemplo, podría usar %NombreVal1%, donde la cadena que sustituye a %NombreVal1% se define en la sección Strings del archivo .inf.

indicador
Opcional. Determina tanto el tipo de valor como si la clave del Registro se reemplaza si ya existe.

Valor | Significado
0 | (Predeterminado) Valor es una cadena ANSI. Reemplazar la clave si existe.
1 | Valor es un número hexadecimal. Reemplazar la clave si existe.
2 | Valor es una cadena ANSI. No reemplazar la clave si existe.
3 | Valor es un número hexadecimal. No reemplazar la clave si existe.

valor
Opcional. El valor que se establece. Puede ser una cadena ANSI o un número en notación hexadecimal y formato de Intel. Cualquier elemento que contenga un valor binario puede superar el máximo de 128 bytes para la línea si se utiliza un carácter de barra diagonal inversa (\). También se puede proporcionar una clave de cadena con el formato %claveCad%. La claveCad debe definirse en la sección Strings del archivo .inf. Para usar un carácter % en la línea, use %%.

Son obligatorios dos campos, como mínimo; sin embargo, uno puede ser nulo. Por tanto, al utilizar este formato es obligatorio utilizar, como mínimo, una coma.

Los dos elementos del ejemplo de sección del tipo AddReg siguiente agregan dos nombres de valor al Registro. Tenga en cuenta que %25% se expandirá en la carpeta Windows del equipo.

[MyAppRegEntries]
HKLM,Software\MyApp,ProgramName,,"My Application"
HKLM,Software\MyApp,"Program Location",,"%25%\MyApp.exe"

Volver al principio del archivo

Secciones Delete Registry (DelReg)

[ sección-del-registry]
cadena-raíz-reg, subclave, [nombre-valor]
[cadena-raíz-reg, subclave, [nombre-valor]]
.
.
Eliminan una subclave o nombre de valor del Registro. El nombre sección-del-registry debe aparecer en un elemento DelReg de una sección Install.

cadena-raíz-reg
Nombre raíz del Registro. Pueden ser uno de los valores siguientes:

HKCR igual que HKEY_CLASSES_ROOT
HKCU igual que HKEY_CURRENT_USER
HKLM igual que HKEY_LOCAL_MACHINE
HKU igual que HKEY_USERS.
HKR significa relativo a la clave pasada en GenInstallEx

subclave
Identifica la subclave que se va a eliminar. Tiene el formato clave1\clave2\clave3... Este parámetro se puede expresar como una cadena reemplazable. Por ejemplo, podría usar %Subclave1%, donde la cadena que sustituye a %Subclave1% se define en la sección Strings del archivo .inf.

nombre-valor
Opcional. Identifica el nombre del valor para la subclave. Tenga en cuenta que el parámetro nombre-valor se puede expresar como una cadena reemplazable. Por ejemplo, podría usar %NombreVal1%, donde la cadena que sustituye a %NombreVal1% se define en la sección Strings del archivo .inf.

Este tipo de sección puede contener cualquier número de elementos. Cada elemento elimina un subclave o nombre de valor del Registro.

Secciones Ini File to Registry (Ini2Reg)

[ sección-ini-to-registry]
archivo-ini, sección-ini, [clave-ini], cadena-raíz-reg, subclave[,indicadores]
.
.
Mueven líneas o secciones de un archivo .ini al Registro y crean o reemplazan una entrada del Registro debajo de la clave dada en el Registro. El nombre de sección sección-ini-to-registry debe aparecer en un elemento Ini2Reg de una sección Install del archivo .inf.

archivo-ini
Nombre del archivo .ini que contiene la clave que se va a copiar. Para obtener más información acerca de cómo especificar el nombre del archivo .ini, consulte los comentarios del tema "Referencia" acerca de la sección Update .ini File.

sección-ini
Nombre de la sección del archivo .ini que contiene la clave que se va a copiar.

clave-ini
Nombre de la clave del archivo .ini que se va a copiar al Registro. Si clave-ini está vacío, toda la sección se transfiere a la clave del Registro especificada.

cadena-raíz-reg
Nombre raíz del Registro. Pueden ser uno de los valores siguientes:

HKCR igual que HKEY_CLASSES_ROOT
HKCU igual que HKEY_CURRENT_USER
HKLM igual que HKEY_LOCAL_MACHINE
HKU igual que HKEY_USERS.
HKR significa relativo a la clave pasada en GenInstallEx

subclave
Identifica la subclave que va a recibir el valor. Tiene el formato clave1\clave2\clave3...

indicadores
Indica si se debe eliminar la clave .ini después de transferirse al Registro y si se debe sobrescribir el valor en el Registro si ya existe la clave del Registro. Pueden ser uno de los valores siguientes:

Valor | Significado
0 | (Predeterminado) No eliminar la entrada .ini del archivo .ini después de mover la información de la entrada al Registro. Si la subclave del Registro ya existe, no reemplazar su valor actual.
1 | Eliminar la entrada .ini del archivo .ini después de mover la información de la entrada al Registro. Si la subclave del Registro ya existe, no reemplazar su valor actual.
2 | No eliminar la entrada .ini del archivo .ini después de mover la información de la entrada al Registro. Si la subclave del Registro ya existe, reemplazar su valor actual con el valor de la entrada del archivo .ini.
3 | Eliminar la entrada .ini del archivo .ini después de mover la información de la entrada al Registro. Si la subclave del Registro ya existe, reemplazar su valor actual con el valor de la entrada del archivo .ini.
Por ejemplo, suponga que la entrada siguiente existe en el archivo Win.ini:
[Windows]
CursorBlinkRate=15

Si debajo de Control Panel\Desktop no hay una subclave CursorBlinkRate, el elemento siguiente de la sección Ini File to Registry crea la subclave, establece el valor de la subclave a 15 y no cambia la línea original de WIN..ini:

win.ini,Windows,CursorBlinkRate,HKCU,"Control Panel\Desktop"

Si la subclave ya existe, el elemento del archivo .inf establece el valor de la subclave a 15 y no cambia la línea original de WIN..ini.

Secciones Update Config.sys (UpdateCfgSys)

[ sección-update-config]
Buffers=número-búferes-dos-válido
DelKey=clave
DevAddDev=nombre-controlador,palabraClaveConfig[,indicador][,cadena-parám]
DevDelete=nombre-controlador-dispositivo
DevRename=nombre-dispositivo-actual,nombre-dispositivo-nuevo
Files=número-archivos-dos-válido
PrefixPath=ldid[,ldid]
RemKey=clave
Stacks=valores-pilas-dos

Proporcionan comandos para agregar, eliminar o cambiar el nombre de comandos en el archivo Config.sys. El nombre de la sección, nombre-sección-update-ini, debe aparecer en el elemento UpdateInis de una sección Install en el archivo .inf.

No todos los tipos de elemento que se muestran en la sintaxis anterior son necesarios u obligatorios. Una sección Update Config.sys puede contener tantos elementos DevRename, DevDelete, DevAddDev, DelKey y RemKey como se necesiten, pero los elementos Buffers, Files y Stacks sólo se pueden usar una vez en una sección. Cuando se procesa una sección Update Config.sys, el instalador procesa todos los elementos DevRenames en primer lugar, todos los elementos DevDelete después y todos los elementos DevAddDev al final. La sintaxis y significado de cada uno de los tipos de elemento que se pueden usar en una sección Update Config.sys se proporcionan posteriormente en este tema.

Elemento Buffers

Buffers=número-búferes-dos-válido
Establece el número de búferes de archivo. Al igual que con el elemento Stacks, el instalador compara el valor existente con el propuesto y establece siempre el número de búferes al mayor de los dos valores.

número-búferes-dos-válido
Un número de búferes MS-DOS válido.

Elemento DelKey

DelKey=clave
Ocasiona que el comando Config.sys con la clave especificada se comente dentro del archivo Config.sys. Por ejemplo, el elemento del archivo .inf siguiente:

DelKey=Break

ocasionaría que un comando Break=on se comentara dentro del archivo Config.sys.

El elemento DelKey tiene el mismo efecto que el elemento RemKey . Puede haber varios elementos DelKey y RemKey en una sección de un archivo .inf.

clave
La clave del comando de Config.sys que se va a comentar.

Elemento DevAddDev

DevAddDev=nombre-controlador,palabraClaveConfig[,indicador][,cadena-parám]
Agrega un comando device o install al archivo CONFIG.SYS.

nombre-controlador
Nombre del archivo ejecutable o controlador que agregar. El instalador valida la extensión del nombre de archivo y comprueba que sea. sys o .exe.

palabraClaveConfig
Nombre del comando. Puede ser device o install.

indicador
Indicador de posición opcional. Si es 0, el comando se coloca al final del archivo. Si es 1, se coloca al principio. Si no se proporciona ningún indicador, se utiliza 0 como opción predeterminada.

cadena-parám
Parámetros de comando opcionales. Deben ser válidos para el controlador de dispositivo o archivo ejecutable especificados.

Elemento DevDelete

DevDelete=nombre-controlador-dispositivo
Elimina las líneas que contengan el nombre de archivo especificado del archivo Config.sys.

nombre-controlador-dispositivo
Nombre de un archivo o controlador de dispositivo. El instalador busca en el archivo Config.sys el nombre y elimina cualquier línea que lo contenga. Ya que MS-DOS no permite extensiones de nombre de archivo implícitas en Config.sys, cada nombre-controlador-dispositivo debe especificar la extensión del nombre de archivo de forma explícita.

En el ejemplo siguiente, el elemento DevDelete de la sección Update Config.sys elimina las líneas 1 y 3, y deja la línea 2 del archivo Config.sys de ejemplo:

DevDelete=filename.sys
;; líneas en Config.sys
Device=Filename.sys ;; línea nº1
Install=Filename.exe ;; línea nº2
Device=Filename.sys /d:b800 /I:3 ;; línea nº3

Elemento DevRename

DevRename=nombre-dispositivo-actual,nombre-dispositivo-nuevo
Cambia el nombre de un controlador de dispositivo del archivo Config.sys.

nombre-dispositivo-actual
Nombre del controlador de dispositivo o archivo ejecutable cuyo nombre se va a cambiar. El instalador busca el nombre en la parte de la derecha de un comando device o install en el archivo Config.sys.

nombre-dispositivo-nuevo
Nombre nuevo para el controlador o archivo ejecutable.

Elemento Files

Files=número-archivos-dos-válido
Establece el número máximo de archivos abiertos en el archivo Config.sys. Al igual que con el elemento Stacks, el instalador compara el valor existente con el propuesto y establece siempre el número de búferes al mayor de los dos valores.

número-archivos-dos-válido
Número de archivos de MS-DOS válido.

Elemento PrefixPath

PrefixPath=ldid[,ldid]...
Anexa al comando path la ruta de acceso asociada al LDID dado.

ldid
Puede ser cualquiera de los valores LDID predefinidos o un valor nuevo definido en el archivo .inf. Para obtener una definición de los valores LDID predefinidos, consulte el tema "Referencia" acerca de la sección DestinationDirs.

Elemento RemKey

RemKey=clave
Ocasiona que el comando de Config.sys con la clave especificada se comente en el archivo Config.sys. Por ejemplo, el elemento del archivo .inf siguiente:

RemKey=Break

ocasionaría que un comando Break=on se comentara dentro del archivo Config.sys.

El elemento RemKey tiene el mismo efecto que el elemento DelKey . Puede haber varios elementos RemKey y DelKey en una sección del archivo .inf.

clave
La clave del comando de Config.sys que se va a comentar.

Elemento Stacks

Stacks=valores-pilas-dos
Establece el número y tamaño de las pilas del archivo Config.sys. El instalador compara el valor existente con el propuesto y establece siempre el mayor de los dos. Por ejemplo, si Config.sys contiene stacks=9,218 y el archivo .inf contiene stacks=5,256, el instalador establece el nuevo valor a stacks=9,256.

número-pilas-dos-válido
Un número de pilas de MS-DOS válido.

Volver al principio del archivo

Secciones Update Autoexec.bat (UpdateAutoBat)

[ sección-update-autoexec]
CmdAdd=nombre-comando[,parámetros-comando]
CmdDelete=nombre-comando
PrefixPath=ldid[,ldid]
RemOldPath=ldid[,ldid]
TmpDir=ldid[,subdir]
UnSet=nombre-variable-entorno

Proporcionan comandos para tratar líneas del archivo Autoexec.bat. El nombre de la sección, nombre-sección-update-ini, debe aparecer en el elemento UpdateInis de una sección Install en el archivo .inf.

No todos los tipos de elemento mostrados en la sintaxis anterior son necesarios u obligatorios en una sección Update Autoexec.bat. La sección puede contener tantos elementos CmdAdd, CmdDelete y UnSet como se necesiten pero, en un archivo .inf, sólo se puede usar un elemento PrefixPath, RemOldPath y TmpDir. La sintaxis y significado de cada uno de los tipos de elemento se describen posteriormente en este tema.

El instalador procesa todos los elementos CmdDelete antes de los elementos CmdAdd.

CmdAdd Item

CmdAdd =nombre-comando[,"parámetros-comando"]
Agrega el comando y los parámetros de comandos opcionales especificados al final del archivo Autoexec.bat.

nombre-comando
Nombre de un archivo ejecutable, con o sin extensión. Si el nombre de archivo se define también en las secciones SourceDisksFiles y DestinationDirs del archivo .inf, el instalador agrega la ruta de acceso correspondiente al nombre de archivo antes de escribirla en el archivo Autoexec.bat.

parámetros-comando
Cadena incluida entre comillas tipográficas o una cadena reemplazable como %Cadena1% o %Miparámetro%, donde las cadenas que sustituyen a %Cadena1% y %Miparámetro% se definen en la sección Strings del archivo .inf. El instalador anexa la cadena a nombre-comando antes de anexar la línea al final del archivo Autoexec.bat. El formato de esta línea depende de los requisitos de línea de comando del archivo ejecutable dado.

Elemento CmdDelete

CmdDelete=nombre-comando
Elimina las líneas de Autoexec.bat que incluyan el nombre de comando especificado. El instalador busca y elimina cualquier aparición del nombre especificado que tenga la extensión de nombre de archivo .exe, .com y .bat.

nombre-comando
Nombre de un archivo ejecutable sin extensión.

Elemento PrefixPath

PrefixPath=ldid[,ldid]...
Anexa al comando path la ruta de acceso asociada al LDID dado.

ldid
Puede ser cualquiera de los valores LDID predefinidos o un valor nuevo definido en el archivo .inf. Para obtener una definición de los valores LDID predefinidos, consulte el tema "Referencia" acerca de la sección DestinationDirs.

Elemento RemOldPath

RemOldPath=ldid[,ldid]
Quita del comando path la ruta de acceso asociada al LDID especificado. Por ejemplo, si el usuario instala una versión nueva de Windows en C:\Newwin y tiene una copia anterior de Windows en C:\Windows, el elemento del archivo .inf siguiente quita C:\Windows de la variable de entorno path:

RemOldPath=10
ldid
Puede ser cualquiera de los valores LDID predefinidos o un valor nuevo definido en el archivo .inf. Para obtener una definición de los valores LDID predefinidos, consulte el tema "Referencia" acerca de la sección DestinationDirs.

Elemento TmpDir

TmpDir=ldid[,subdir]
Crea una carpeta temporal dentro de la carpeta especificada en el LDID, si no existe.

ldid
Puede ser cualquiera de los valores LDID predefinidos o un valor nuevo definido en el archivo .inf. Para obtener una definición de los valores LDID predefinidos, consulte el tema "Referencia" acerca de la sección DestinationDirs.

subdir
Nombre de la ruta de acceso. Si ldid\subdir no existe todavía, se crea.

Elemento UnSet

UnSet=nombre-variable-entorno
Quita cualquier comando set del archivo Autoexec.bat que incluya el nombre de la variable de entorno especificada.

nombre-variable-entorno
Nombre de una variable de entorno.

Volver al principio del archivo

Sección DestinationDirs

[DestinationDirs]
sección-lista-archivos =ldid[, subdir ]
.
.
[DefaultDestDir=ldid[, subdir ]]

La sección DestinationDirs define los directorios de destino para las operaciones especificadas en archivo-lista sección, que son las secciones CopyFiles, RenFiles o DelFiles. Opcionalmente, se puede especificar una carpeta de destino predeterminada para las secciones CopyFiles, RenFiles o DelFiles en el archivo .inf que no se nombre explícitamente en la sección DestinationDirs.

sección-lista-archivo
Nombre de una sección CopyFiles, RenFiles o DelFiles. Se puede hacer referencia a este nombre en un elemento Copyfiles, RenFiles o DelFiles de una sección Install.

ldid
Identificador de disco lógico (LDID). Pueden ser uno de los valores siguientes:

00 | LDID nulo; se puede usar para crear un LDID nuevo
01 | Unidad de origen:\nombre de ruta de acceso
10 | Carpeta Machine (se asigna a la carpeta Windows en una instalación con servidor).
11 | Carpeta System
12 | Carpeta IOSubsys
13 | Carpeta Command
17 | Inffolder
18 | Carpeta Help
20 | Fuentes
21 | Visores
22 | VMM32
23 | Carpeta Color
24 | Raíz de la unidad que contiene la carpeta Windows
25 | Carpeta Windows
26 | Dispositivo de inicio garantizado para Windows (Winboot)
28 | Host Winboot
30 | Carpeta raíz de la unidad de inicio
31 | Carpeta raíz para el dispositivo host de una unidad de inicio virtual

subdir
Nombre de la carpeta dentro de la carpeta nombrada por el LDID como carpeta de destino.

El elemento opcional DefaultDestDir proporciona un destino predeterminado para los elementos CopyFiles que usen la notación de copia directa (@nombre de archivo) o las secciones CopyFiles, RenFiles o DelFiles no especificadas en la sección DestinationDirs . Si en una sección DestinationDirs no se utiliza DefaultDestDir, la carpeta predeterminada se establece a LDID_WIN.

En el ejemplo siguiente se establece la carpeta de destino para la sección MoveMiniPort a Windows\Iosybsys y se establece como carpeta predeterminada para otras secciones la carpeta Bin en la unidad de inicio:

[DestinationDirs]
MoveMiniPort=12 ; Destino para la sección MoveMiniPort es
; windows\iosubsys
DefaultDestDirs=30,bin ; Copias directas van a boot:\bin

Volver al principio del archivo

Sección SourceDisksNames

[SourceDisksNames]
ordinal-disco="descripción-disco",etiqueta-disco,número-serie-disco
.
.
Identifica y da nombre a los discos que contienen los archivos de origen para las operaciones de copia y cambio de nombre de archivos.

ordinal-disco
Un número exclusivo que identifica un disco de origen. Si hay más de un disco de origen, cada uno debe tener un número ordinal exclusivo.

descripción-disco
Una cadena o clave de cadenas que describe el contenido o propósito del disco. El instalador muestra esta cadena al usuario para identificar el disco. La descripción se incluye entre comillas tipográficas.

etiqueta-disco
Etiqueta de volumen del disco de origen que se define cuando se formatea el disco.

número-serie-disco
No se utiliza. El valor debe ser 0.

En este ejemplo se identifica un disco de origen. La descripción del disco se proporciona como una clave de cadenas:

[SourceDisksNames]
55 = %ID1%, Instd1, 0
[Strings]
ID1="Mi disco de instalación de la aplicación 1"

Volver al principio del archivo

Sección SourceDisksFiles

[SourceDisksFiles]
nombre archivo=número-disco[,subdir] [,tamaño-archivo]
.
.
color=#000000Da nombre a los archivos de origen durante la instalación e identifica los discos de origen que contienen los archivos.

color=#000000nombre archivo
color=#000000Nombre del archivo en el disco de origen.

número-disco
color=#000000Número ordinal del disco de origen que contiene el archivo. Este número ordinal se debe definir en la sección SourceDisksNames y debe tener un valor mayor o igual que 1 (cero no es un valor de parámetro número-disco válido).

subdir
Parámetro opcional que especifica la subcarpeta en el disco de origen donde reside el archivo. Si este parámetro no se usa, la carpeta raíz del disco de origen es la predeterminada.

tamaño-archivo Parámetro opcional que especifica el tamaño del archivo, en bytes.

color=#000000El ejemplo de sección SourceDisksFiles siguiente identifica un único archivo de origen, SRS01.386, en el disco que tiene el número ordinal 1:

[SourceDisksFiles]
SRS01.386 = 1

Volver al principio del archivo

Sección Strings

[Strings]
clave-cadenas=valor
.
.
Define una o varias claves de cadenas. Una clave de cadenas es un nombre que representa una cadena de caracteres imprimibles. Aunque la sección Strings generalmente es la última del archivo .inf, una clave de cadenas definida en esta sección puede usarse en cualquier parte del archivo .inf en la que se usaría la cadena correspondiente. El instalador sustituye la clave de cadenas por la cadena especificada y la usa en el procesamiento posterior. Debe incluir una clave de cadenas entre signos de porcentaje (%).

clave-cadenas
Nombre exclusivo que se compone de letras y dígitos.

valor
Cadena que se compone de letras, dígitos u otros caracteres imprimibles. Debe incluirse entre dobles comillas tipográficas si la clave de cadenas correspondiente se utiliza en un tipo de elemento que las requiere.

La sección Strings facilita la conversión en mercados internacionales al colocar todas las cadenas que se pueden mostrar en la interfaz de usuario cuando el archivo .inf se usa en una única sección del archivo .inf. Las claves de cadenas se deben usar siempre que sea posible.

En el ejemplo siguiente se muestra la sección Strings para un archivo .inf de ejemplo.

[Strings]
String0="Mi aplicación"
String1="Archivo Léame de Mi aplicación"
String2="Adaptador CX2590 SCSI"

Volver al principio del archivo

Sección Opcional Components

[Optional Components]
nombre-sección-install
[nombre-sección-install]
.
.
Enumera las secciones Install que se muestran cuando el usuario hace clic en el icono Agregar o quitar programas del Panel de control, hace clic en la ficha Instalación de Windows y, a continuación, hace clic en el botón Utilizar disco. La sección Install se presenta como casillas de verificación en la lista.

Tenga en cuenta que la sección Opcional Components se omite cuando se ejecuta un archivo .inf al hacer clic con el botón secundario del mouse (ratón) en el archivo y seleccionar el verbo "install". Al ejecutar un archivo .inf de esta forma, se ejecuta la sección [DefaultInstall]. La sección Optional Components también se omite si el archivo .inf se está ejecutando a través del punto de entrada InstallHinfSection de Setupx.dll. Cuando se ejecuta un archivo .inf a través del punto de entrada SETUPX, se ejecuta la sección Install especificada en el parámetro al punto de entrada.

Las secciones Install siguen el mismo formato que se describió anteriormente y las claves adicionales siguientes se pueden agregar a la sección Install para dirigir la interfaz en el cuadro de diálogo "Utilizar disco":

OptionDesc=descripción-opción
Sugerencia=descripción-sugerencia
InstallDefault=0 | 1 ; Si se instala este componente de forma predeterminada. 1=Sí, 0=No.
IconIndex=índice-icono
Parent= nombre-sección-install
Needs=nombre-sección-install, [nombre-sección-install]
Include=archivo-inf, [archivo-inf]

descripción-opción
Cadena que se utiliza como nombre del componente en el cuadro de lista. El parámetro descripción-opción puede ser %Cadena1%, donde la cadena que sustituye a %Cadena1% se define en la sección Strings del archivo .inf.

descripción-sugerencia
Cadena que se muestra en el cuadro "descripción" cuando el componente se selecciona en el cuadro de lista. El parámetro descripción-sugerencia tiene un límite de 255 caracteres y puede ser %Cadena1%, donde la cadena que sustituye a %Cadena1% se define en la sección Strings del archivo .inf.

índice-icono
Valor numérico que determina el miniicono que se muestra junto al nombre del componente. Son valores válidos:
0 Equipo (base y pantalla)
1 Chip de circuitos integrados
2 Pantalla
3 Cables de red
4 Indicador de Windows
5 Mouse
6 Teclado (3 teclas)
7 Teléfono
8 Altavoz
9 Discos duros
10 Conector comm.
11 Rombo (valor predeterminado)
12 Casilla de verificación activada
13 Casilla de verificación desactivada
14 Impresora
15 Tarjeta de red
16 Igual que 0
17 Igual que 0 con una mano
18 Desconocido (signo de interrogación)
19 Atwork
20 Casilla de verificación atenuada
21 Acceso telefónico a redes
22 Conexión directa por cable
23 Maletín
24 Exchange
25 Marca parcial
26 Grupo Accesorios
27 Grupo Multimedia
28 Vista rápida
29 MSN
30 Calculadora
31 Desfragmentador
32 Documento genérico
33 DriveSpace
34 Solitario
35 HyperTerminal
36 Empaquetador de objetos
37 Paint
38 Protector de pantalla
39 WordPad
40 Visor del Portapapeles
41 Accessibilidad
42 Copia de seguridad
43 Documento de mapa de bits
44 Mapa de caracteres
45 Punteros de mouse
46 Monitor de red
47 Marcador telefónico
48 Monitor de sistema
49 Libro de Ayuda
50 Globo (international settings)
51 Compresión de audio
52 Reproductor de CD
53 Reproductor multimedia
54 Esquema de sonidos
55 Clip de vídeo
56 Compresión de vídeo
57 Control de volumen
58 Musica - esquema de sonidos
59 Jungla - esquema de sonidos
60 Robotz - esquema de sonidos
61 Utopía - esquema de sonidos

Parent
El cuadro de lista mostrado en la interfaz de componentes opcionales puede contener niveles secundarios. Si el componente opcional es secundario, la palabra clave Parent= define la sección Install principal.

Needs
Si este componente tiene dependencias en otros componentes, este elemento define las secciones Install que este componente necesita. Si el componente se selecciona, se advertirá al usuario que el componente necesita los componentes descritos en las secciones Install enumeradas en Needs= línea.

Tenga en cuenta que las secciones Install enumeradas en Needs= línea deben estar en el mismo archivo .inf. Sin embargo, si los componentes dependientes de otros archivos .inf se enumeran en la Needs= línea, los archivos .inf deben especificarse en el Include= línea.

Include
El elemento Include permite especificar archivos .inf que el programa de instalación también debe cargar en la memoria cuando carga el archivo .inf, ya que estos archivos .inf contienen secciones que se deben ejecutar además de las secciones Install del archivo .inf. El elemento Needs especifica los nombres de las secciones que usted tiene intención de ejecutar en el archivo o archivos .inf incluidos.

En el ejemplo siguiente se definen dos secciones Install con componentes opcionales; cada sección usa las entradas adicionales para especificar dependencias y elementos de la interfaz:

[Opcional Components]
InstallMyToys
InstallGames
[InstallMyToys]
OptionDesc=%Toys_DESC%
Tip=%Tomytoysys_TIP%
IconIndex=35 ;Mini-icono teléfono para diálogos
Parent=MailApps
Needs=MSMAIL, MAPI, MicrosoftNetwork
Include=mos.inf, msmail.inf
CopyFiles=MyToysFiles
UpdateInis=MyToysLinks
AddReg=MyToysRegItems
[InstallOtherApps]
OptionDesc=%Other_DESC%
Tip=%Other_TIP%
IconIndex=4 ;mini-icono windows para diálogos
CopyFiles=OtherFiles
UpdateInis=OtherLinks
AddReg=OtherRegItems
[Strings]
Toys_DESC="Programas Correo"
Toys_TIP="Programas adicionales para enviar y organizar correo"
Other_DESC="Otros programas útiles"
Other_TIP="Calculadora, revisor de disco y controlador de rendimiento"

Volver al principio del archivo


Usar la tecnología RunOnce

Puede ejecutar cualquier programa después de ejecutar un archivo .inf si agrega entradas a la clave del Registro Runonce. Las entradas RunOnce se ejecutarán la próxima vez que se reinicie el equipo y el usuario inicie una sesión en el sistema (si corresponde).

La clave del Registro RunOnce permite iniciar programas en Windows y especificar si deben ejecutarse "silenciosamente", es decir, sin interactuar con el usuario, o como parte de una lista de programas o acciones que el usuario pueda ver. La referencia al programa se elimina, de forma que el programa no se ejecute de nuevo.

Para ejecutar programas silenciosamente, agregue entradas cadenaDescripción=líneaComandos debajo de la clave del Registro siguiente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce

Para ejecutar programas sincrónicamente bajo el control del administrador Runonce de Windows, agregue entradas cadenaDescripción=líneaComandos debajo de la clave del Registro siguiente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup

En el ejemplo siguiente se muestra una sección AddReg que hace que suceda lo siguiente:

  • Iniciar Miapli.exe (ubicado en la carpeta Windows) sin interfaz de usuario.
    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce,"SilentApp",,"%25%\miapli.exe"
  • Iniciar Test.exe, que se encuentra en la carpeta System, y mostrar un mensaje similar al siguiente "El programa de instalación de Windows está configurando los elementos siguientes":
    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup,"Utilidad de comprobación",,"%11%\test.exe"

Nota

  • La cadena con la descripción que se encuentra debajo de la clave del Registro Setup aparece en la interfaz de usuario.


Archivos de configuración de Internet

El archivo de configuración de Internet (.ins) es el mecanismo utilizado para configurar equipos con acceso a Internet mediante marcado o banda ancha durante la pantalla de bienvenida de Windows. Al final de la suscripción a Internet, el servidor de suscripción del ISP crea un archivo .ins que contiene la configuración especificada de Internet y devuelve el archivo al equipo. A continuación, la pantalla de bienvenida de Windows procesa el archivo .ins y aplica la configuración al equipo.

El archivo .ins se utiliza para configurar el Acceso telefónico a redes, Connection Manager, Microsoft Internet Explorer y Microsoft Outlook Express. Para las conexiones de banda ancha a Internet, el archivo .ins también puede contener la configuración de TCP/IP y otros datos relacionados con la conexión.

Si desea más información, consulte Entradas de archivos de configuración de Internet para conexiones de banda ancha.

Las siguientes secciones aparecen en los archivos .ins:

Sección | Descripción
[Animation] | Especifique la ubicación de los archivos de mapa de bits animados y personalizados que aparecen en el Asistente para la instalación.
[ActiveSetup] | Especifique la ubicación de los archivos de mapa de bits personalizados que aparecen en el Asistente para personalizar Internet Explorer 6.
[ActiveSetupSites] | Especifique los nombres y ubicaciones de los paquetes personalizados que pone a disposición de los usuarios para descargar.
[Batch] | Especifique los tipos de medios de instalación disponibles para el paquete personalizado.
[Big_Logo] | Especifique el nombre y la ruta de acceso del archivo de mapa de bits de 38 por 38 píxeles que aparece en la esquina superior derecha del explorador.
[Branding] | Especifique información sobre la marca personalizada y la instalación incluida en el paquete del explorador.
[BrowserToolbars] | Personalice la apariencia de la barra de herramientas de Microsoft Internet Explorer.
[CabSigning] | Especifique la información que se utiliza para firmar los programas.
[ConnectionSettings] | Especifique información sobre la configuración de conexión de Acceso telefónico a redes (DUN) utilizada para instalar el paquete personalizado de Internet Explorer. De este modo se crea una configuración DUN común en todas las estaciones de trabajo de los usuarios.
[CustomBranding] | Especifique la dirección URL para el archivo contenedor de marca.
[CustomWallpaper] | Especifique los archivos HTML y complementarios para el papel tapiz personalizado.
[Device] | Especifique el tipo de conexión utilizado para la instalación.
[Entry] | Especifique si la información de este archivo .ins anula el nombre del Acceso telefónico a redes del paquete personalizado.
[ExtRegInf] | Especifique los nombres de los archivos de información (.inf) y el modo de instalación para los componentes.
[FavoritesEx] | Especifique la ruta de acceso al archivo de iconos para Favoritos y si Favoritos se encuentra disponible sin conexión. También puede especificar la dirección URL para cada sitio favorito.
[HideCustom] | Especifique si el identificador único global (GUID) está oculto. Cada componente personalizado posee un GUID basado en la información del sistema y en otros parámetros, como la hora del día en que se creó.
[ICW_IEAK] | Especifique la ruta de acceso a los mapas de bits personalizados que aparecen en el Asistente para la conexión de Internet.
[Internet_Mail] | Especifique la información personalizada de Outlook Express.
[Internet_News] | Especifique la información de noticias personalizada y si Outlook Express es el cliente de noticias predeterminado.
[ISP_Security] | Especifique el certificado raíz que va a agregar al paquete personalizado.
[LDAP] | Especifique la información para el servidor de Protocolo compacto de acceso a directorios (LDAP). Asimismo, especifique si Outlook Express siempre comprueba los nombres y direcciones de correo electrónico con el servidor LDAP.
[Mail_Signature] | Especifique una firma de correo electrónico para noticias y si desea utilizarla.
[Media] | Especifique los tipos de medio en que se encuentra disponible el paquete de instalación, como CD, descarga y disquete.
[Outlook_Express_Global] | Especifique la marca para el servicio de Outlook Express.
[Outlook_Express] | Especifique qué componentes de Outlook Express va a marcar o personalizar en su paquete.
[Phone] | Especifique la información telefónica que utiliza para la conexión de marcado.
[Proxy] | Especifique si va a utilizar un servidor proxy y los nombres de host del servidor proxy.
[Scripting] | Especifique los nombres y rutas a los archivos de comandos del acceso telefónico a redes.
[Script_File] | Especifique el texto del archivo de comandos asociado al acceso telefónico a redes.
[Security Imports] | Especifique si desea importar información de seguridad desde el equipo al paquete personalizado.
[Server] | Especifique información sobre el servidor de red.
[Signature] | Especifique si va a utilizar una firma de Outlook Express y el texto de esa firma.
[SignupFiles] | Especifique el nombre de los archivos que aparecen durante la suscripción, como sign-up.htm.
[Small_Logo] | Especifique el nombre y la ruta de acceso del archivo de mapa de bits de 22 por 38 píxeles que aparece en la esquina superior derecha del explorador.
[TCP/IP] | Especifique el número IP del servidor DNS que va a utilizar. También puede especificar si va a utilizar una puerta de enlace remota, una dirección IP y una dirección del servidor.
[URL] | Especifique si va a utilizar un servidor proxy de autoconfiguración y las direcciones URL para las páginas que aparecen cuando los usuarios se conectan a ese servidor.
[User] | Especifique la información de inicio de sesión necesaria para los usuarios.


Entradas del archivo de configuración de Internet para conexiones de banda ancha

titular

Entradas del archivo de configuración de Internet para las conexiones de banda ancha

En Windows Millennium Edition, la pantalla de bienvenida de Windows se ha mejorado para que pueda configurar una nueva cuenta de Internet de banda ancha. Las siguientes opciones son extensiones del formato de archivo .ini existente que habilita esta configuración de banda ancha. Estas opciones sustituyen a las similares descritas en las entradas .ins para las conexiones de acceso telefónico.

[Device]
Type = {módem, isdn (rdsi), atm, ethernet, ethernet_1483, cable(?)}
Módem, ISDN (RDSI) y ATM unirán entradas a RAS
Módem, ISDN (RDSI) y Ethernet (y cable) buscan únicamente el encabezado [TCP/IP]
ATM busca encabezados [TCP/IP] y [ATM]
Ethernet_1483 busca encabezados [TCP/IP] y [Ethernet_1483]
PPPOE busca encabezados [TCP/IP] y [PPPOE]
Nombre = {nombre descriptivo del dispositivo}
Pnpid = {Id. de Plug and Play del dispositivo, o para adaptadores
multifunción, sólo el dispositivo Plug and Play de red configurado necesario}

Nota

  • El OEM coloca el nombre del dispositivo y el Id. de Plug and Play del dispositivo de banda ancha en el equipo antes de suministrarlo. Esta información se transmite al proveedor de servicios Internet (ISP) durante la suscripción del usuario. A continuación, el ISP agrega estas entradas al archivo .ins de modo que se configure el dispositivo correcto durante la suscripción.
[TCP/IP]
Specify_IP_Address = {sí para estática, no para DHCP}
IP_Address = {dirección IP estática si se utiliza}
Subnet_Mask = {dirección ip}
Specify_DNS_Address = {sí si se utiliza, de otro modo no}
DNS List = {dirección ip},{dirección ip}, …
IP_Header_Compress = {sí si se utiliza, de otro modo no}
Gateway_On_Remote = {sí si se utiliza, de otro modo no}
Default_Gateway_List = {dirección ip},{dirección ip}, …
Domain_Name = {cadena},{cadena}, …
Host_Name = {cadena si se utiliza}
Domain_Suffix_Search_List = {dirección ip},{dirección ip}, …
Specify_WINS_Address = {sí,no}
WINS_List = {dirección ip},{dirección ip}, …
[PPPoverATM] o [Ethernet_1483]
Circuit_Speed = {señalizador}
0 = Velocidad de línea
1 = Usuario especificado
O valor real de velocidad en kilobytes (512, 1536, 25000, 155000)
Circuit_QOS = {señalizador}
0 = UBR
1 = VBR
2 = CBR
3 = ABR
Circuit_Type = {0 si SVC, 1 si PVC}
Speed_Adjust = {sí o no}
QOS_Adjust = {sí o no}
Encapsulation = {señalizador}
0 – PPP sobre ATM (encapsulación nula)
1 – PPP sobre ATM (LLC)
2 – Ethernet de puente/802.3 (LLC/SNAP) No definido para PPPOA
3 – IPv4 enrutado (LLC/SNAP) No definido para PPPOA
4 – Ethernet de puente/802.3 (encapsulación nula) No definido para
PPPOA
5 – IPv4 enrutado (encapsulación nula) No definido para PPPOA
VPI = {valor numérico} Sólo para PVC
VCI = {valor numérico}
Vendor_Config = {sí o no}
Show_Status = {sí o no}
Enable_Log = {sí o no}
[Phone]
PhoneNumber = dirección NSAP si ATM, de otro modo número de teléfono

Nota

  • Son extensiones al archivo .ins existente que funcionan únicamente en el momento inicial (pantalla de bienvenida de Windows) en Windows Me.


Ejemplos del IEAK

Esta carpeta contiene secuencias de comandos de configuración de proxy automático, archivos de instalación por lotes y un ejemplo de archivo .ins. La sección incluye además ilustraciones que pueden ayudarle a comprender algunos conceptos de Internet Explorer y del IEAK.

  • Archivos de ejemplo de proxy automático de JavaScript o JScript
  • Ejemplo de archivo .inf para el servicio de descarga de componentes
  • Ejemplo de archivo de instalación por lotes
  • Ejemplos de los conceptos del IEAK

También encontrará otros ejemplos, como archivos para crear un paquete de suscripción con servidor y ejemplos de páginas para descargar e instalar componentes complementarios, en el Kit de herramientas de IEAK.


Contenido del Kit de herramientas de IEAK

El Kit de herramientas de IEAK contiene herramientas, programas y archivos de ejemplo muy útiles. El contenido del kit de herramientas se encuentra en la carpeta \<carpeta de programa IEAK>\Toolkit y sus subcarpetas.

En la carpeta Toolkit encontrará una referencia a los archivos .isp e .ins en el archivo Insref.xls.

Carpeta Addons

Esta carpeta contiene páginas de ejemplo de componentes complementarios.

Carpeta Corp

Esta carpeta contiene archivos .ins de ejemplo para la configuración automática, además de secuencias de comandos personalizables de páginas Active Server (.asp). Los archivos .asp están diseñados para servidores Web en los que se ejecuta Internet Information Services 3.0 (y versiones posteriores), aunque pueden verse con cualquier explorador Web estándar.

Carpeta Graphics

Esta carpeta contiene imágenes y herramientas gráficas de ejemplo.

Carpeta Inf

Esta carpeta contiene un archivo .inf de ejemplo para crear un programa de desinstalación.

Carpeta ISP

Esta carpeta contiene varias herramientas y ejemplos para los proveedores de servicios Internet (ISP):

  • Una herramienta (Asistente para archivos ISP) que configura la información de acceso telefónico.
  • Una herramienta (Inetlogn.exe) que puede ayudarle a almacenar en caché las contraseñas de todos los usuarios, de modo que el usuario no tenga que escribirla en cada inicio de sesión.
  • Secuencias de comandos de ejemplo, herramientas y soluciones personalizables para paquetes de suscripción con servidor, con el Asistente para la conexión a Internet y sin servidor


Ejemplos de los conceptos del IEAK

Los diagramas siguientes muestran características y conceptos clave del IEAK.

Experiencia del usuario al instalar Internet Explorer desde un paquete generado en el IEAK

Instalación de Windows Update para Internet Explorer y otras herramientas para Internet

Cómo funciona la personalización

Cómo funciona la configuración automática

Generar un paquete mediante el IEAK

Cómo genera el IEAK paquetes personalizados

Sincronización automática de versiones

Cómo configurar los archivos para distribución

Suscripción a Internet

Proceso de suscripción a un ISP

Administradores corporativos

Configuración y directivas del sistema


Archivos de ejemplo de proxy automático de JavaScript o JScript

Las secuencias de comandos siguientes proporcionan ejemplos de cómo utilizar un archivo .pac para especificar una dirección URL de proxy automático. Para utilizar estas funciones, debe cambiar los nombres de proxy, los números de puerto y las direcciones IP.

Notas

  • La funciones isInNet, isResolvable y dnsResolve consultan a un servidor DNS.
  • Las referencias a los objetos, propiedades o métodos del Modelo de objetos provocan el fallo "silencioso" del archivo de configuración automática proxy. Por ejemplo, las referencias window.open(...), alert(...) y password(...) dan lugar a errores en el archivo de configuración automática del proxy en Internet Explorer.

Ejemplo 1: los hosts locales se conectan directamente, los demás lo hacen a través del proxy

La función siguiente comprueba si el host es local y, si lo es, si la conexión es directa. Si no es un host local, se realiza la conexión a través de proxy (proxy).

function FindProxyForURL(url, host)
 {
 if (isPlainHostName(host))
 return "DIRECT";
 else
 return "PROXY proxy:80";
 }

La función isPlainHostName() comprueba si hay puntos en el nombre de host. Si es así, devuelve falso; en caso contrario, la función devuelve verdadero.

Ejemplo 2: los hosts que hay dentro del servidor de seguridad se conectan directamente; los servidores que están fuera se conectan a través del proxy

La función siguiente comprueba si el host es un nombre de host "plano" (no incluye el nombre del dominio) o forma parte de un dominio particular (.empresa.com) que no sea www o home.

function FindProxyForURL(url, host)
 {
 if ((isPlainHostName(host) ||
 dnsDomainIs(host, ".empresa.com")) &&
 !localHostOrDomainIs(host, "www.empresa.com") &&
 !localHostOrDoaminIs(host, "home.empresa.com"))
 return "DIRECT";
 else
 return "PROXY proxy:80";
 }

Notas

  • La función localHostOrDomainIs sólo se ejecuta para las direcciones URL del dominio local.
  • La función dnsDomainIs devuelve verdadero si el dominio o el nombre de host coinciden con el dominio dado.

Ejemplo 3: si el host se puede resolver, se utiliza una conexión directa. En caso contrario, la conexión se realiza a través de un proxy.

La función siguiente pregunta al servidor DNS para intentar resolver el nombre de host que se le pasa. Si puede, se realiza una conexión directa. Si no puede, se realiza la conexión a través del proxy. Esto resulta de utilidad cuando se utiliza un servidor DNS interno para resolver todos los nombres de host internos.

function FindProxyForURL(url, host)
 {
 if (isResolvable(host))
 return "DIRECT";
 else
 return "PROXY proxy:80";
 }

Vea la nota de la función isResolvable al principio de la página.

Ejemplo 4: si el host se encuentra en una subred especificada, se utiliza una conexión directa. En caso contrario, la conexión se realiza a través de un proxy.

La función siguiente compara el modelo y la máscara de dirección IP dados con el nombre de host. Esto resulta útil si determinados hosts de una subred deben conectarse directamente y otros deben hacerlo mediante un proxy.

function FindProxyForURL(url, host)
 {
 if (isInNet(host, "999.99.9.9", "255.0.255.0"))
 return "DIRECT";
 else
 return "PROXY proxy:80";
 }

Vea la nota de la función isInNet al principio de la página.

La función isInNet (host, modelo, máscara) devuelve verdadero si la dirección IP del host coincide con el modelo especificado. La máscara indica qué parte de la dirección IP debe coincidir (255=coincidir, 0=omitir).

Ejemplo 5: determinar el tipo de conexión en función del dominio del host

La función siguiente especifica que hay una conexión directa si el host es local. Si el host no es local, esta función determina qué proxy se utilizará según el dominio del host. Esto resulta de utilidad si el nombre de dominio del host es uno de los criterios de selección de proxy.

function FindProxyForURL(url, host)
 {
 if (isPlainHostName(host))
 return "DIRECT";
 else if (shExpMatch(host, "*.com"))
 return "PROXY comproxy:80";
 else if (shExpMatch(host, "*.edu"))
 return "PROXY eduproxy:80";
 else
 return "PROXY proxy";
 }

La función shExpMatch (cadena, expSh) devuelve verdadero si cadena coincide con expShutilizando los modelos de expresión de shell.

Ejemplo 6: determinar el tipo de conexión según el protocolo utilizado

La función siguiente extrae el protocolo que se está utilizando y, de acuerdo con él, realiza la selección del proxy. Si no hay coincidencia con el protocolo, se realiza una conexión directa. Esto resulta de utilidad si el protocolo que se está utilizando es uno de los criterios de selección del proxy.

function FindProxyForURL(url, host)
 {
 if (url.substring(0, 5) == "http:") {
 return "PROXY proxy:80";
 }
 else if (url.substring(0, 4) == "ftp:") {
 return "PROXY fproxy:80";
 }
 else if (url.substring(0, 7) == "gopher:") {
 return "PROXY gproxy";
 }
 else if (url.substring(0, 6) == "https:") {
 return "PROXY secproxy:8080";
 }
 else {
 return "DIRECT";
 }
 }

La función substring extrae el número especificado de caracteres de una cadena.

Ejemplo 7: comprobar si el nombre de host coincide con la dirección IP para determinar la configuración de proxy

La función siguiente selecciona el proxy mediante la conversión del nombre de host en una dirección IP y su comparación con una cadena especificada.

function FindProxyForURL(url, host)
 {
 if (dnsResolve(host) == "999.99.99.999") {  // = http://secproxy
 return "PROXY secproxy:8080";
 }
 else {
 return "PROXY proxy:80";
 }
 }

Vea la nota de la función dnsResolve al principio de la página.

Ejemplo 8: si la dirección IP del host coincide con la dirección IP especificada, se conecta a través de proxy; de lo contrario se conecta directamente

La función siguiente es otra forma de seleccionar el proxy según una dirección IP especificada. En este ejemplo, a diferencia del ejemplo 7, se utiliza la llamada a la función para obtener explícitamente la dirección IP numérica (en el ejemplo 7 se utiliza la función dnsResolve para convertir el nombre de host en una dirección IP numérica).

function FindProxyForURL(url, host)
 {
 if (myIpAddress() == "999.99.999.99") {
 return "PROXY proxy:80";
 }
 else {
 return "DIRECT";
 }
 }

La función myIpAddress devuelve la dirección IP (en formato de enteros separados por puntos) del host en el que se está ejecutando el explorador.

Ejemplo 9: si hay puntos en el nombre de host, la conexión se realiza mediante un proxy. En caso contrario, se utiliza una conexión directa.

La función siguiente comprueba cuántos puntos hay en el nombre de host. Si hay puntos en el nombre de host, se establece una conexión a través de proxy. Si no los hay, se establece una conexión directa. Es otra forma de determinar los tipos de conexión según las características del nombre de host.

function FindProxyForURL(url, host)
 {
 if (dnsDomainLevels(host) > 0) {  // si el número de puntos del host es > que 0
 return "PROXY proxy:80";
 }
 return "DIRECT";
 }

La función dnsDomainLevels devuelve un número entero igual al número de puntos que haya en el nombre de host.

Ejemplo 10: especificar los días de la semana que se conectará a través de proxy; los demás días se conectará directamente

La función siguiente determina el tipo de conexión mediante la especificación de los días de la semana apropiados para conectarse a través de un proxy. Los días que no están entre los parámetros se utiliza una conexión directa. Esta función podría resultar de utilidad en situaciones en las que se desee utilizar un proxy cuando hay mucho tráfico y permitir una conexión directa en caso contrario.

function FindProxyForURL(url, host)
 {
 if(weekdayRange("WED", "SAT", "GMT"))
 return "PROXY proxy:80";
 else
 return "DIRECT";
 }

La función weekdayRange ( día1 [,día2] [,fGMT] ) devuelve un valor que indica si la hora actual del sistema está dentro del intervalo especificado por los parámetros día1, día2 y fGMT. Sólo es necesario el primer parámetro. El parámetro GMT asume que los valores de hora están en la hora media de Greenwich en lugar de la zona horaria local.


Ejemplo de archivo de instalación por lotes

;Ejemplo de un archivo sencillo Iebatch.txt que muestra la selección de la carpeta de instalación,
;realiza la primera opción de instalación de la lista y reinicia automáticamente el equipo.

[Welcome]
Display=0

[SetupChoice]
Display=0

[Custom]
Display=0
Mode=0
InstallDir=c:\Int_exp\en

[Download]
Display=0
DownloadDir=c:\Int_exp\descarga\

[Finish]
Display=0

[Reboot]
Reboot=1


Solucionar problemas relacionados con el paquete personalizado

Si el paquete personalizado no funciona como se había previsto en el equipo del usuario, compruebe las siguientes situaciones:

Error durante la instalación de Windows Update en el equipo de un usuario.

Si falla el programa de instalación de Windows Update puede solucionar los problemas y errores de instalación mediante el archivo Active Setup Log.txt. En este archivo se registra todo lo sucedido en el proceso de instalación desde el momento en que se inicia la ejecución de IE6Setup.exe hasta que termina la descarga del último archivo contenedor (.cab).

Al ejecutar IE6Setup.exe, se crea el archivo Active Setup Log.txt en la carpeta en la que está instalado Windows (normalmente, en la carpeta C:\Windows). Si hay un archivo Active Setup Log.txt de una sesión de instalación de Internet Explorer anterior, se le cambiará el nombre a Active Setup Log.bak.

El registro comienza en la fecha y hora en que se inició el programa de instalación y termina con la fecha y hora en que se descargó correctamente el último archivo contenedor (.cab). Al avanzar por el Asistente para la instalación, se van efectuando anotaciones en ese registro. Es el archivo de registro que más información proporciona para determinar qué causó un error en la descarga y cuándo se produjo. La mayor parte de las entradas de este archivo también se escriben en el Registro de Windows; estos datos se registran para ayudarle a realizar una recuperación sin problemas.

Los códigos de error pueden ayudarle a determinar qué estaba haciendo el programa de instalación cuando falló y determinar así la causa del error. Para obtener más información acerca de los códigos de error, consulte Información del registro de errores en el archivo Active Setup Log.txt.

Los archivos no se descargan durante la instalación de Windows Update.

El programa de instalación de Windows Update puede cambiar de servidores durante su ejecución para mantener el rendimiento máximo o recuperarse de un sitio de distribución que no responde. El cambio de servidores se produce cuando el programa detecta que no hay transmisión o que ésta se ha reducido a menos de un byte cada dos minutos.

Si se agota el tiempo de espera de una conexión , el programa de instalación tratará de conectarse al siguiente sitio de descarga en la lista y continuará el proceso de instalación desde el principio del archivo contenedor (.cab) que quedó descargado parcialmente. Si se agota el tiempo de espera de conexión y el programa de instalación no cambia de servidor, tratará de volver a conectarse al mismo sitio de descarga para continuar el proceso de instalación en el punto en que se interrumpió. Si no puede establecerse esa nueva conexión con el sitio de descarga, el programa de instalación preguntará si desea cancelar la instalación o intentarlo nuevamente.

Si el primer sitio está inactivo, como resultado de problemas en el servidor, por ejemplo, el programa de instalación de Windows Update no podrá encontrar los sitios restantes de forma predeterminada. Una posible solución conlleva sobrescribir el primer sitio con el comando siguiente:

<ruta de acceso>\ie6setup.exe /C:"ie6wzd.exe /S:""<ruta de acceso>\ie6setup.exe"" /L:""http://mi servidor Web/mi sitio Web/ie6sites.dat"""

<ruta de acceso> es la carpeta en la que se encuentra el archivo IE6setup.exe.

Ejemplo

A continuación se incluye un ejemplo de la sintaxis que debe proporcionarse a los usuarios cuando el primer sitio esté inactivo. Se trata de una línea de comando única mostrada mediante tres líneas de texto para mejorar su legibilidad.

C:\ie6setup.exe /C:"ie6wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\ie6setup.exe""
/L:""http://<direcciónNuevoServidor>/<suDirecciónDeDescarga>/ie6sites.dat """

Los modos de instalación no están disponibles para usuarios de Windows 2000 o Windows XP.

Independientemente de las opciones de instalación configuradas para el paquete, el programa de instalación de Windows Update sólo presenta una opción de instalación para los usuarios que ejecuten el sistema operativo Windows 2000 o Windows XP. Esta opción incluye todos los componentes de Internet de Microsoft, además de los componentes personalizados incluidos en el paquete.

Los cambios de marca realizados durante la configuración automática no se aplican en los equipos con Windows 2000 o Windows XP.

Los cambios de marca distribuidos a los usuarios mediante la configuración automática no se aplican si en Directiva de grupo de Windows 2000 o Windos XP se establece la directiva Sin marcas externas. Esta directiva no permite que terceras partes, como proveedores de servicios o de contenido Internet, marquen los programas de Internet, por ejemplo, personalizando las barras de títulos y los logotipos de Internet Explorer y Outlook Express. Para obtener más información, consulte Administrar Microsoft Internet Explorer en Windows 2000 y Windows XP.

No es posible desinstalar los componentes.

Cuando falla el proceso de desinstalación, la herramienta más importante para solucionar los problemas y realizar la desinstalación es el registro de desinstalación, IE6 Uninstall Log.txt, que se encuentra en la carpeta \Windows. Este registro incluye todo el proceso de desinstalación de forma secuencial, incluidas las eliminaciones o adiciones de archivos, los cambios, inclusiones o eliminaciones en el Registro, así como los cuadros de diálogo que se van mostrando al usuario.

El registro está dividido en pasos, que corresponden a las distintas fases de una desinstalación. Las entradas en el registro también incluyen un número de objeto que coincide con el número de línea de la entrada correspondiente en el archivo Setup.stf. Las líneas que no tienen un número de objeto son el resultado de acciones personalizadas específicas de Internet Explorer y están incluidas en el archivo IE6.inf o en un archivo .inf resultado de la desinstalación de un componente externo.

Si no puede utilizar la opción Agregar o quitar programas del Panel de control para desinstalar Internet Explorer, puede que se haya eliminado del equipo la información necesaria para la desinstalación. A continuación se enumeran los archivos fundamentales para la desinstalación:

  • IE6bak.dat
  • IE6bak.ini
  • Integrated Browser.dat
  • Integrated Browser.ini

El cuadro de diálogo de desinstalación avanzada de Internet Explorer ofrece la posibilidad de desinstalar esta información, aunque si lo hace no podrá desinstalar Internet Explorer en el futuro.

Para obtener información acerca de cómo desinstalar componentes personalizados, consulte Proporcionar la funcionalidad de desinstalación en una secuencia de comandos .inf y Desinstalar un componente personalizado.

La suscripción a Internet con ICW no funciona con un disco único con marca.

En caso de que use un disco único con marca personalizada, no utilice el mecanismo de suscripción con el Asistente para la conexión a Internet si prevé que alguno de los usuarios tiene instalado Internet Explorer 4.01 Service Pack 1 (o versiones anteriores); en lugar de ello, para dichos usuarios cree un paquete independiente mediante la suscripción en el modo a pantalla completa.


Solucionar problemas mediante el Asistente para personalizar Internet Explorer 6

Si no puede encontrar determinadas pantallas del Asistente para personalizar Internet Explorer 6, compruebe lo siguiente:

  • Asegúrese de que ha seleccionado la función correcta (proveedor de contenido Internet, ICP, proveedor de servicios Internet, ISV, o administrador corporativo).
  • Asegúrese de que ha seleccionado el sistema operativo correcto.
  • En la pantalla Selección de características, asegúrese de que están seleccionadas todas las características que desea personalizar. Las pantallas correspondientes a una característica no se mostrarán si no se activa la casilla de verificación.
  • Para la personalización de Outlook Express, compruebe que ha descargado los archivos de Outlook Express y ha agregado Outlook Express al menos a uno de los modos de instalación.

Nota

  • Si está configurando una instalación silenciosa o ejecutando el Asistente para personalizar Internet Explorer 6 desde el Asistente para la instalación de Office, algunas de las opciones de personalización no estarán disponibles.


Información del registro de errores de Active Setup Log.txt

El archivo Active Setup Log.txt puede ayudarle a solucionar errores producidos durante la instalación de Windows Update porque contiene el estado del proceso cuando se produjo el error. En el registro puede encontrar las entradas siguientes:

Entrada de registro | Significado
0 | Inicialización; se crea una carpeta temporal y se comprueba si hay espacio en disco.
1 | Comprobación de todas las dependencias.
2 | Descarga de archivos desde el servidor.
3 | Copia de archivos desde la ubicación de descarga en una carpeta de instalación temporal.
4 | Reinicio de la descarga y reintento de la instalación debido a un error de tiempo de espera u otro error de descarga.
5 | Control de los permisos de confianza y comprobación.
6 | Extracción de archivos.
7 | Ejecución del programa de instalación (un archivo .inf o .exe.)
8 | Instalación finalizada.
9 | Descarga finalizada, todos los archivos descargados.

He aquí algunos códigos de error comunes:

Código de error | Significado
80100003 | Faltan archivos en el directorio de descarga durante la instalación.
800bxxxx | Los códigos de error que empiezan con 800b son errores de permisos.
800Cxxxx | Los códigos de error que empiezan con 800C son errores de urlmon.

Ejemplos

Algunos ejemplos comunes son:

800C005: no se encontró el archivo o el servidor.

800C00B: se agotó el tiempo de la conexión.

8004004: el usuario canceló el programa de instalación.


Glossary

Símbolos A B C D E F G H I J K L M N O P Q R S T U V W XY Z

Símbolos

El glosario no tiene términos que comiencen con esta letra.

A

acceso telefónico a redes (DUN)

Una conexión a una red de comunicaciones de datos mediante una red pública conmutada de telecomunicaciones en lugar de un circuito dedicado u otro tipo de red privada.

Actualización del escritorio de Windows

La Actualización del escritorio de Windows consta de dos componentes: Active Desktop e Integración de shell. La Actualización del escritorio de Windows se incluye en Windows 98, Windows 98 Segunda Edición, Windows Millennium Edition, Windows 2000 y Windows XP. Este componente no se reinstala en equipos que utilizan cualquiera de esos sistemas operativos.

administrador corporativo

Individuo responsable de configurar y mantener los equipos y aplicaciones en una corporación. Los administradores también se encargan de administrar cuentas de usuarios y de grupos, asignar contraseñas y permisos, y ayudar a los usuarios a solucionar problemas de red.

Administrador de conexión

Un marcador cliente utilizado para obtener acceso a Internet.

Administrador de perfiles

Herramienta de Internet Explorer Administration Kit (IEAK) que los administradores corporativos utilizan para crear y administrar dinámicamente la configuración automática del escritorio y el explorador.

ancho de banda

En las comunicaciones analógicas, la diferencia entre la frecuencia más alta y más baja en un intervalo determinado. Por ejemplo, una línea de teléfono analógico tiene cabida para un ancho de banda de 3.000 hertzios (Hz), la diferencia entre la frecuencia más baja (300 Hz) y más alta (3.300 Hz) que puede transportar. En las comunicaciones digitales, el ancho de banda se expresa en bits por segundo (bps).

archivo .adm

Archivo plantilla de las directivas del sistema que define las directivas del sistema y restricciones que pueden establecerse para el escritorio, shell y la seguridad del sistema.

Vea también: directivas de sistema

archivo .bat

Archivo por lotes. Archivo de texto ASCII que contiene una secuencia de comandos del sistema operativo; a veces incluye parámetros y operadores admitidos por el lenguaje de comandos por lotes. Cuando el usuario escribe el nombre del archivo por lotes en el símbolo del sistema, el equipo procesa los comandos secuencialmente.

archivo .cab

Archivo contenedor. Un archivo contenedor único que almacena múltiples archivos comprimidos. Estos archivos se utilizan comúnmente en la instalación del software y para reducir el tamaño del archivo y el tiempo de descarga asociado para el contenido Web.

archivo .inf

Archivo de información. Archivo creado para un adaptador en particular que proporciona al sistema operativo la información necesaria para instalar un dispositivo, como una lista de configuraciones lógicas válidas para el dispositivo, los nombres de los archivos controladores asociados al dispositivo, etc. El archivo .inf se incluye generalmente en un disco que suministra el fabricante de dispositivos o puede incluirse en el sistema operativo.

archivo .ins

Archivo de configuración de Internet. Archivo que proporciona al programa de instalación de Windows Update las opciones de configuración de Internet necesarias para el explorador y los componentes asociados. Puede crear varias versiones del paquete de explorador si cambia el archivo .INS empleado por cada paquete. Utilice el Administrador de perfiles para crear, guardar y cargar archivos .INS.

asignación de la información de versión

Hay dos maneras de asignar la información de versión en Internet Explorer: a cada paquete de Internet Explorer se le asigna un número de versión; la asignación de la información de versión puede aplicarse de modo que se impida que los paquetes antiguos sobrescriban versiones más recientes del mismo paquete. A los componentes individuales de Internet Explorer también se les asigna información de versión; el componente no se descargará ni instalará si ya hay una versión compatible del componente en el equipo cliente. El número de versión contiene un código de dos letras que indica el modo utilizado para generar el paquete IEAK (IC para proveedores de contenido Internet, IS para proveedores de servicios Internet y CO para administradores corporativos).

Asistente para la personalización

Asistente para la personalización de Internet Explorer

El componente principal de Internet Explorer Administration Kit (IEAK) que se utiliza con el fin de generar versiones personalizadas de Internet Explorer para instalarlas en una organización específica.

Autenticación de contraseña segura (SPA, Secure Password Authentication)

Protocolo en el que el servidor utiliza una contraseña cifrada para confirmar la identidad del usuario.

Authenticode

Tecnología que permite identificar a la compañía o el individuo que ha publicado un programa de software y comprobar que no se ha modificado desde su publicación. Los administradores corporativos pueden configurar zonas de seguridad, preestablecer una clasificación y personalizar las entidades emisoras de certificados para impedir que los usuarios descarguen software sin firmar. También pueden definir directivas del sistema y restricciones para controlar si los usuarios podrán modificar la configuración de seguridad.

B

barra del explorador

El lado izquierdo del explorador en el que aparecen las listas Búsqueda, Historial y Favoritos cuando el usuario hace clic en los botones correspondientes de la barra de herramientas. El usuario también puede crear una barra del explorador personalizada, así como un botón de barra de herramientas personalizada para abrirla.

barra Inicio rápido

Área especial de la barra de herramientas situada junto al botón Inicio, diseñada para proporcionar a los usuarios un acceso sencillo al Web, correo electrónico, escritorio y otros servicios del sistema básicos, y a programas u otros iconos que utilicen frecuentemente. La personalización de esta barra de herramientas suele reservarse para el usuario.

búsqueda automática

Característica de Internet Explorer que permite a los usuarios escribir una palabra familiar en la barra de direcciones para buscar en las páginas usadas con más frecuencia. No es necesario que los usuarios recuerden las direcciones URL exactas de las páginas.

C

caché

Área del disco duro reservada para el almacenamiento de imágenes, texto y otros archivos que el usuario ha visto previamente en Internet.

cadena de agente de usuario

Texto que identifica la versión específica y el origen del explorador.

canales

Un canal es un sitio Web preparado para trabajar con programas de recepción de información. El mecanismo que lo permite es el archivo de formato de definición de canal (.CDF). Los canales pueden organizarse en categorías y colocarse en el escritorio del usuario.

Capa de sockets seguros (SSL)

Protocolo que suministra comunicaciones de datos seguras mediante el cifrado y descifrado de los datos. Permite mantener la privacidad de las comunicaciones en la red mediante una combinación de criptografía de clave pública y cifrado masivo de datos.

carácter comodín

Carácter del teclado que puede utilizarse para representar uno o varios caracteres cuando se realiza una consulta. El signo de interrogación (?) representa un carácter único y el asterisco (*) representa uno o más caracteres.

carpeta Vistas Web

Los administradores pueden personalizar la apariencia de Mi PC o del Panel de control en los equipos de una organización si personalizan los archivos HTTP que funcionan como plantillas para ellos. La carpeta Vista Web requiere la instalación de la Actualización del escritorio de Windows.

certificado

certificado digital

Certificación electrónica emitida por entidades emisoras de certificados que muestra la procedencia de los programas y prueba que el paquete de instalación no se ha alterado. Los administradores deben firmar el código con un certificado digital si van a distribuir un paquete Internet Explorer por Internet.

cifrado

El proceso de camuflar un mensaje o datos de modo que se oculte su contenido.

clasificación de contenido

Microsoft Internet Explorer ofrece una forma de ayudar a los administradores a controlar los tipos de contenido a los que puede tener acceso un equipo en Internet. El administrador puede ajustar la configuración de modo que refleje el contenido apropiado en las áreas de lenguaje obsceno, desnudos, sexo y violencia.

Vea también: Parental Internet Content Selection (PICS)

clave del Registro

Identificador correspondiente a un registro o grupo de registros del Registro.

código de personalización

Código de licencia asignado a una organización cuando ésta descarga Internet Explorer Administration Kit (IEAK). No es necesario para instalar el IEAK, pero sí para generar paquetes IEAK.

componente

El administrador puede incluir numerosos componentes de Internet de Microsoft y otras organizaciones con el explorador Internet Explorer. El administrador puede incluir numerosos componentes de Internet de Microsoft y otras organizaciones con el explorador Internet Explorer. Algunos ejemplos de componentes son Outlook Express y Microsoft NetMeeting.

componente personalizado

Componente incluido por el usuario en el paquete, además de los componentes de Internet descargados desde Microsoft mediante sincronización automática de versiones (AVS, Automatic Version Synchronization).

componentes adicionales

Componentes no incluidos en el paquete, pero que los usuarios podrán instalar cuando hayan completado la instalación de Windows Update.

configuración automática

Proceso que permite a los administradores corporativos administrar y actualizar las configuraciones de los usuarios, las directivas del sistema y las restricciones correspondientes a Microsoft Internet Explorer desde una ubicación central. Es posible definir manualmente un puntero a un archivo de configuración automática dentro del explorador o mediante la configuración de la instalación del explorador con el IEAK.

configuración de la conexión

Configuración utilizada por Internet Explorer para conectarse a Internet. Por lo general, la configuración de la conexión está compuesta por conjuntos de opciones para las entradas de acceso telefónico a redes, como opciones de configuración de proxy, cuentas, contraseñas y módems.

D

Descubrimiento automático de proxy Web (WPAD, Web Proxy AutoDiscovery)

Protocolo de red estándar utilizado para ayudar al software de cliente de Internet a localizar automáticamente los servicios de caché dentro de una red y servir de interfaz con ellos.

dirección URL de configuración automática

Ubicación del archivo de configuración de Internet (.INS) utilizado para configurar el explorador de este paquete. Mediante este archivo es posible controlar la configuración de varios usuarios desde una ubicación central.

dirección URL de proxy automático

Ubicación del archivo de comandos de proxy automático. Si se cambia este archivo, es posible controlar la configuración de proxy de varios usuarios desde una ubicación central.

directivas de sistema

Una directiva estilo Windows NT 4.0 basada en la configuración del Registro realizada con Poledit.exe, el Editor de directivas del sistema.

Vea también: Registro

dispositivo virtual

Programa que proporciona un entorno independiente del sistema operativo dentro de otro sistema operativo. Un dispositivo virtual que permite al usuario ejecutar programas originales de otro sistema operativo.

distribución

Proceso de distribución e instalación de un programa de software en una organización. Una distribución no es lo mismo que una implementación "piloto", en la que se suministra la aplicación de software a un grupo de usuarios más reducido a fin de identificar y evaluar los problemas que podrían producirse durante la distribución.

distribución electrónica de software (ESD)

Un sistema de comunicación seguro que los clientes emplean para descargar software pagando. Esto puede realizarse a través de Internet o mediante una conexión directa de módem a módem. Los sistemas ESD permiten a los usuarios utilizar el software durante un período de prueba antes de comprarlo.

E

Editor de directivas del sistema

La herramienta Poledit.exe, utilizada por los administradores para definir la directiva del sistema en equipos basados en Windows NT 4.0 y Windows 95.

Extensiones multipropósito de correo Internet (MIME)

Estándar que amplía las capacidades de SMTP para permitir la transmisión de datos como vídeo, sonido y archivos binarios a través de Internet sin traducir los datos al formato ASCII.

Vea también: SMTP

F

Fabricante independiente de software (ISV)

Programador de software de otro proveedor; individuo u organización que crea software informático de forma independiente.

Favoritos

Vínculos predefinidos a sitios Web. Los favoritos también se denominan "marcadores". Los favoritos de Internet Explorer pueden configurarse para notificar automáticamente al usuario cualquier cambio de su contenido.

firma de código

Proceso de firma de un paquete de Internet Explorer finalizado con un certificado digital. La firma del paquete requiere dos pasos: obtener un certificado digital y firmar el código.

Vea también: certificado digital

firma digital

Método de autenticación personal basado en el cifrado y en códigos de autorización secretos utilizado para "firmar" documentos electrónicos.

G

grupo piloto

Ejemplo representativo de los equipos de producción utilizados para probar un paquete de Internet Explorer antes de proceder a la distribución completa en toda la organización. Al contrario que en un laboratorio de prueba, en un grupo piloto se emplean usuarios y equipos de producción.

Vea también: distribución

H

herencia

Cualquier característica en el sistema informático basada en tecnología anterior cuya compatibilidad continúa manteniéndose en otros componentes del sistema.

HTML

Lenguaje utilizado para crear y diseñar páginas Web. HTML es un conjunto de etiquetas que los autores Web usan para crear diseños de página, dar formato a los textos, insertar gráficos y elementos multimedia, etc.

HTML dinámico

Conjunto de características que amplía las capacidades del HTML tradicional, con lo que los autores Web consiguen más opciones de diseño y flexibilidad, y un mayor control creativo sobre la apariencia y comportamiento de las páginas Web.

Vea también: HTML

HTTP

I

IEAK

IMAP

Protocolo de acceso a mensajes de Internet (IMAP) Protocolo para recibir mensajes de correo electrónico de uso muy extendido. Permite a los clientes de correo electrónico tener acceso a un archivo de correo electrónico remoto y tratarlo sin descargarlo en el equipo local. Suelen utilizarlo usuarios de empresas que desean leer su correo electrónico desde una ubicación remota.

Vea también: Protocolo de oficina de correo 3 (POP3, Post Office Protocol 3)

instalación a petición

Característica que pide al usuario que instale los componentes que todavía no están instalados en el equipo cuando éste ve una página Web que los requiere. El IEAK permite restringir la disponibilidad de esta característica para los usuarios.

instalación automática

instalación no interactiva

Configuración del programa de instalación de Windows Update en la que no se solicita a los usuarios que tomen decisiones y se les informa de los errores y el progreso de la instalación. Esta opción sólo está disponible para administradores corporativos.

Vea también: instalación silenciosa

instalación por lotes

Ejecución del programa de instalación desde un comando en un archivo por lotes o directamente desde el símbolo del sistema.

Vea también: archivo .bat

instalación silenciosa

Configuración del programa de instalación de Windows Update en la que no se solicita a los usuarios que tomen decisiones acerca de las opciones de instalación ni se les informa de los errores o progreso de la instalación. Esta opción sólo está disponible para administradores corporativos.

Vea también: instalación no interactiva

Integración de shell

Uno de los dos componentes instalados con la Actualización del escritorio de Windows. La integración de shell permite a los usuarios examinar sus equipos como si estuvieran explorando el Web. Los usuarios encontrarán los menús Ir a y Favoritos desde cualquier parte.

Internet Explorer Administration Kit (IEAK)

Conjunto de herramientas que permite a los administradores corporativos, los proveedores de servicios Internet y los proveedores de contenido Internet crear, distribuir y administrar paquetes de Internet Explorer personalizados en una organización. El IEAK incluye el Asistente para la personalización de Internet Explorer, el Administrador de perfiles de IEAK y el Kit de herramientas de IEAK.

ISDN

ISV

J

El glosario no tiene términos que comiencen con esta letra.

K

Kit de administración del Administrador de conexión (CMAK, Connection Manager Administration Kit)

Herramienta para crear, modificar y administrar perfiles del Administrador de conexión. El Administrador de conexión es un marcador de cliente. CMAK está disponible en Windows 2000 Server y en el Kit de administración de Windows 2000.

Vea también: Administrador de conexión; perfil del Administrador de conexión

L

LDAP

Lenguaje de marcado de hipertexto (HTML, Hypertext Markup Language)

Lenguaje de marcado simple utilizado para crear documentos de hipertexto que pueden trasladarse de una plataforma a otra. Los archivos HTML son simples archivos de texto ASCII con códigos integrados (indicados mediante etiquetas de marcado) para denotar el formato y los vínculos de hipertexto.

Localizador de recursos universal (URL, Uniform Resource Locator)

Una dirección Web, como "http://www.microsoft.com".

M

mapa de bits

Formato de archivo para imágenes utilizado con el fin de personalizar los gráficos de un paquete de Internet Explorer Administration Kit (IEAK).

marca de agua

Mapa de bits mostrado detrás de la barra de herramientas de Internet Explorer. Coloree la marca de agua de modo que no obscurezca el texto o los gráficos de los botones de la barra de herramientas.

marca en un solo disco

Personalización de una instalación de Internet Explorer existente, incluida la suscripción a un ISP, sin reinstalar Internet Explorer. Esta opción no le permite empaquetar ni instalar componentes adicionales.

medio

Material físico empleado para almacenar información del equipo. Las opciones más utilizadas para la distribución del paquete IEAK son el disco compacto, la descarga del Web o los discos.

MIME

N

nombre de dominio

Nombre de la conexión de red utilizada por DNS que define al propietario de esa organización en un formato jerárquico: servidor.organización.tipo. Por ejemplo, www.CasaBlanca.gob identifica al servidor Web de la Casa Blanca, que forma parte del gobierno de los Estados Unidos. En una dirección de correo electrónico, el nombre de dominio se sitúa después del signo "@".

O

El glosario no tiene términos que comiencen con esta letra.

P

página de bienvenida

La página que se mostrará la primera vez que el usuario ejecute Internet Explorer. Posteriormente, Internet Explorer mostrará la página principal del usuario cada vez que éste inicie el explorador.

página de inicio en pantalla completa

Página que se muestra en pantalla completa, en la que no aparecerán la barra de herramientas del explorador ni la barra del menú, que se presenta cuando el usuario ha instalado Internet Explorer.

página principal

En el contexto de Internet Explorer, la página principal es la primera página que los usuarios ven al iniciar el explorador. "Página principal" también es un término general para la página de inicio de un sitio Web, que normalmente contiene un menú o tabla principal con vínculos a otras páginas del sitio.

pantalla de ejecución automática del CD

La primera pantalla que aparece cuando los usuarios instalan la versión en CD-ROM del paquete personalizado de Internet Explorer. Puede personalizar la barra de título, el fondo y el color del texto que aparece en esta pantalla.

paquete de suscripción

Conjunto de páginas HTML que recopilan información de suscripción perteneciente al cliente y la transfiere, a petición, al servidor de suscripción del proveedor de servicios Internet. La secuencia de páginas guía al cliente a través del proceso de suscripción, de forma parecida a como lo hace el asistente de un programa para Windows.

Vea también: Lenguaje de marcado de hipertexto (HTML, Hypertext Markup Language)

paquete personalizado

Paquete que contiene versiones personalizadas de todas las herramientas de instalación, códigos de explorador y componentes adicionales necesarios para distribuir de una forma rápida y sencilla Internet Explorer en la organización.

Parental Internet Content Selection (PICS)

Reglas que permiten a los proveedores de contenido Web utilizar metaetiquetas para clasificar de forma voluntaria su contenido de acuerdo con los criterios PICS acordados. Un explorador puede bloquear el acceso de los usuarios a los sitios Web en función de los valores de las etiquetas.

Vea también: clasificación de contenido

pasaporte

Un servicio de inicio de sesión único que le permite utilizar un nombre y contraseña únicos en múltiples sitios Web de participación.

perfil del Administrador de conexión

Sistema de automatización de las conexiones de acceso telefónico, similar a las entradas del acceso telefónico a redes.

PICS

plataforma

Un tipo de cliente, como Windows 2000, Windows NT 4.0, Windows Millennium Edition, Windows 98, Windows 3.x, Macintosh o UNIX.

Programa de instalación de Windows Update

El programa que instala Internet Explorer y otros componentes de Internet. El IEAK permite personalizar el programa de instalación de Windows Update de modo que se adecue mejor a los usuarios.

Protocolo compacto de acceso a directorios (LDAP)

Estándar abierto para el almacenamiento y la recuperación de nombres, direcciones de correo electrónico, números de teléfono y otra información de los usuarios. La Libreta de direcciones de Windows admite el protocolo LDAP para el acceso a los servicios de directorio y se distribuye con acceso integrado a muchos de los servicios de directorio más utilizados. Los administradores pueden especificar un servicio adicional para sus usuarios.

Protocolo de oficina de correo 3 (POP3, Post Office Protocol 3)

Protocolo para recibir mensajes de correo electrónico de uso muy extendido. Los proveedores de servicios Internet lo utilizan con mucha frecuencia. Los servidores POP3 permiten tener acceso a una única bandeja de entrada, mientras que los servidores IMAP proporcionan acceso a múltiples carpetas en el servidor.

Vea también: SMTP; IMAP

Protocolo de transferencia de hipertexto (HTTP, Hypertext Transfer Protocol)

Protocolo que hace que la información de hipertexto, como páginas Web, esté disponible en Internet cuando un explorador se conecta al servidor apropiado.

Protocolo simple de transferencia de correo (SMTP)

Un miembro del conjunto de protocolos TCP/IP que controla el intercambio de correo electrónico entre agentes de transferencia de mensajes.

Proveedor de contenido Internet (ICP, Internet Content Provider)

Organización que prepara contenido para su publicación en el Web.

proxy

Un servidor caché del contenido y de seguridad que proporciona seguridad en Internet y mejora el rendimiento de la red.

proxy automático

Característica que permite a un administrador configurar Internet Explorer de modo que el explorador determine de forma dinámica si se conectará directamente a un host o utilizará un servidor proxy.

prueba de laboratorio

Conjunto de equipos no destinados a la producción utilizados para probar un paquete de Internet Explorer. No es lo mismo que un grupo piloto.

puerta de enlace o gateway

Dispositivo conectado a varias redes físicas de TCP/IP capaz de enrutar o entregar paquetes IP entre las mismas. Una puerta de enlace interpreta los diferentes protocolos de transporte o formatos de datos (por ejemplo, IPX e IP) y se agrega generalmente a una red principalmente por su capacidad de interpretación.

En el contexto de interfuncionamiento con redes NetWare de Novell, una puerta de enlace actúa como puente entre el protocolo de bloque de mensajes del servidor (SMB) que utilizan las redes de Windows y el protocolo de núcleo de NetWare (NCP) utilizado por redes de NetWare. Una puerta de enlace también se denomina enrutador IP.

Q

El glosario no tiene términos que comiencen con esta letra.

R

RAS

Red digital de servicios integrados o RDSI (ISDN)

Sistema de interconexión de redes de comunicación digital disponible en la mayoría de las compañías telefónicas. La conexión RDSI se utiliza para establecer comunicaciones de alta velocidad con Internet, servicios comerciales en línea o redes de empresa.

Registro

Depósito de base de datos con información sobre la configuración de un equipo. El Registro contiene información a la que Windows hace referencia continuamente durante el funcionamiento, como:

  • Perfiles para cada usuario.
  • Los programas instalados en el equipo y los tipos de documentos que cada uno puede crear.
  • La configuración de las propiedades de las carpetas e iconos de programa.
  • Qué hardware existe en el sistema.
  • Qué puertos se utilizan.

El Registro se organiza jerárquicamente como un árbol y está formado por claves y sus subclaves, celdas y entradas de valores.

resolución de nombres

Proceso utilizado en la red para convertir una dirección de equipo en un nombre de equipo. La resolución de nombres permite a los equipos buscar y establecer conexión con otros equipos de la red.

ruta de acceso de archivo

Ubicación física de los archivos de distribución en un servidor Web. Por ejemplo, "C:\inetpub\wwwroot\ie5\descarga".

ruta de acceso Web

En el contexto de Internet Explorer Administration Kit (IEAK), es la ruta de acceso Web utilizada para conectar un explorador a los archivos de instalación de Internet Explorer. Por ejemplo, "www.miorganización.com/ie5.

S

secuencia de comandos de proxy automático

En el IEAK, los archivos con formato JScript (.JS), JavaScript (.JVS) o configuración automática de proxy (.PAC) que permiten configurar y mantener la configuración avanzada de proxy. Al especificar un archivo de comandos de proxy automático, Internet Explorer usa la secuencia de comandos para determinar de forma dinámica si se conectará directamente a un host o utilizará un servidor proxy.

seguridad

En una red, protección de un sistema informático y de sus datos frente a daños o pérdidas, implementada especialmente de modo que sólo los usuarios autorizados pueden obtener acceso a los archivos compartidos.

Servicio de acceso remoto (RAS, Remote Access Service)

Servicio de Windows NT 4.0 que proporciona conexión remota a redes a trabajadores a distancia, usuarios móviles y administradores de sistema que controlan y administran servidores en múltiples oficinas.

Servicio de nombres Internet de Windows (WINS, Windows Internet Name Service)

Servicio de software que asigna dinámicamente direcciones IP a nombres de equipos (nombres de NetBIOS). Esto permite a los usuarios acceder a recursos por nombre en lugar de solicitarles que utilicen direcciones IP difíciles de reconocer y de recordar. Los servidores WINS admiten clientes que ejecuten Windows&nbsp;NT&nbsp;4.0 y versiones anteriores de los sistemas operativos de Microsoft.

servicio Descarga de componentes de Internet

Servicio del sistema para la descarga e instalación de software desde sitios Web de Internet y de intranets. Este servicio también incluye la característica de comprobación de certificados. La Descarga de componentes de Internet es compatible con Microsoft Internet Explorer versión 3.0 y posteriores.

Servidor de suscripción a Internet (ISS)

Servidor HTTP que automatiza la tarea de agregar nuevos clientes a la base de datos de clientes de un ISP. El ISS recopila información de cada cliente, la agrega a la base de datos de clientes del proveedor de servicios Internet y, después, devuelve al equipo del cliente un paquete de configuración. El paquete de configuración contiene la información utilizada para configurar el explorador de Internet del cliente para las conexiones subsiguientes a los servicios del proveedor de servicios Internet.

servidor DNS

Equipo mantenido por un proveedor de servicios Internet (ISP) que hace coincidir direcciones IP con nombres de host. Algunos ISP proporcionan una dirección DNS específica.

servidor IMAP

Servidor que utiliza IMAP para proporcionar acceso a múltiples carpetas en el servidor.

Vea también: IMAP; servidor POP3

servidor POP3

Servidor que proporciona acceso a una única bandeja de entrada.

Vea también: servidor IMAP

sincronización automática de versión (AVS)

Tecnología que comprueba automáticamente si hay versiones actualizadas de todos los componentes de Internet Explorer cada vez que se ejecuta Internet Explorer Administration Kit (IEAK). Los componentes actualizados pueden descargarse desde Microsoft e incluirse en paquetes IEAK.

Sistema de nombres de dominio (DNS, Domain Name System)

Conjunto de directrices y reglas desarrolladas por los usuarios de Internet en general que permite el uso de direcciones de nombre de dominio (como bluestem.prairienet.org) y direcciones IP (por ejemplo, 192.12.3.4) para explorar Internet. La dirección de nombre de dominio, utilizada por los usuarios, se traduce automáticamente a la dirección IP numérica empleada por el software de enrutamiento de paquetes.

sitio de descarga

Servidor HTTP o FTP desde el que los usuarios pueden descargar un paquete. Si caduca el tiempo de espera de una conexión , el programa de instalación de Windows Update tratará de conectarse al siguiente sitio de descarga especificado en IE5Sites.dat y continuará el proceso de instalación desde el principio del archivo contenedor (.CAB).

Vea también: archivo .cab

SMTP

suscripción con servidor

T

territorios

Característica del Kit de administración del Administrador de conexión (CMAK) que proporciona un prefijo, como organización, o un sufijo, como @organización.com, a un nombre de usuario al conectar con un servicio del Administrador de conexión.

Vea también: Kit de administración del Administrador de conexión (CMAK, Connection Manager Administration Kit); Administrador de conexión

texto de la barra de título

Texto que aparece en la parte superior de la ventana de un programa. El texto de la barra de título puede marcarse en varias partes de un paquete de Internet Explorer, incluido el propio explorador, la pantalla de ejecución automática del CD y Outlook Express.

Cuando se personaliza el texto de la barra de título para Internet Explorer, el texto también se agrega a Outlook Express. La barra de título de Outlook Express se actualiza tanto si incluye Outlook Express en su paquete como si ya está instalado en el equipo de los usuarios.

U

Usenet

Los grupos de Usenet también se denominan grupos de noticias. Se trata de grupos de noticias de texto que funcionan como boletines de noticias en los que cualquier usuario puede publicar contenido.

V

El glosario no tiene términos que comiencen con esta letra.

W

WINS

X

El glosario no tiene términos que comiencen con esta letra.

Y

El glosario no tiene términos que comiencen con esta letra.

Z

zona de seguridad

En Internet Explorer, un segmento de Internet o una intranet asignado a un nivel de seguridad determinado, en función de la confianza que tenga el administrador en el contenido del sitio Web. Las zonas de seguridad permiten a los administradores restringir al acceso de los usuarios a determinados sitios Web.


Descargar y distribuir un paquete de explorador personalizado

Al hacer clic en Finalizar, el asistente crea un paquete de explorador personalizado. En la mayor?a de los casos, los pasos siguientes consisten en preparar los archivos para descargarlos desde el Web y en preparar otros medios de almacenamiento (como discos compactos) para su distribución. Para obtener m?s información acerca de los formatos de los medios, consulte Selección del medio.

Los programas y los archivos contenedores distribuidos a través de Internet, o que se encuentran en una intranet que no esté configurada de manera especial, deben firmarse digitalmente. Las firmas digitales muestran la procedencia de los programas y comprueban que no se han alterado. Para obtener m?s información, consulte Firmar sus programas. Si ha especificado que el Asistente para personalizar Internet Explorer 6 debe firmar los programas y los archivos personalizados, el asistente los firmar? mientras crea el paquete. Si no ha especificado que el asistente firme sus programas y archivos, tendr? que firmarlos antes de que los usuarios los descarguen.

Los pasos que siga posteriormente para distribuir el explorador personalizado variar?n dependiendo de su función y del medio que utilice para distribuir el paquete. Para obtener m?s información, haga clic en el v?nculo correspondiente:

  • Proveedor de contenido Internet (ICP) o programador
  • Proveedor de servicios Internet (ISP)
  • Administrador corporativo


¿Qué es un archivo contenedor (.CAB)?

Un archivo contenedor (.cab) es una biblioteca de archivos comprimidos almacenados en un único archivo. Los archivos contenedores se utilizan para organizar los archivos de instalación que se copian en el sistema del usuario. Un archivo comprimido de gran tamaño puede dividirse en varios archivos .cab.

Durante varios años, Microsoft ha utilizado archivos .cab para comprimir el software que distribuía en discos. Originalmente, esos archivos se utilizaban para reducir al mínimo el número de discos que se incluían con un producto. En la actualidad, los archivos .cab se utilizan para reducir el tamaño de archivo, y el tiempo asociado para su descarga, del contenido del Web que se encuentra en Internet o en los servidores de las intranets corporativas.

El archivo de información (.inf) suele incluirse en todos los contenedores y proporciona información adicional de la instalación. El archivo .inf puede hacer referencia a archivos del contenedor o a otros archivos y direcciones URL.

El IEAK incluye un conjunto de herramientas que ayudan a crear archivos contenedor y utilizan la tecnología IExpress.

Formato de un contenedor

Cada archivo comprimido en un archivo .cab se guarda, en su totalidad, en una única carpeta. Un archivo .cab puede contener una o varias carpetas, o partes de una carpeta. Así, incluso en el caso de que un archivo comprimido no se pueda almacenar en un único archivo .cab, se almacenará en una carpeta que está formada por varios archivos .cab. Una serie de archivos .cab de ese tipo forma un conjunto. Cada archivo .cab contiene información acerca del nombre de los archivos .cab adyacentes desde un punto de vista lógico.

El formato de archivos .cab que se utiliza para la descarga de componentes de Internet Explorer de Internet es de uso genérico y está basado en el sistema de compresión Lempel-Ziv.

Firmas digitales

Un archivo .cab puede tener una firma digital, de igual modo que un control ActiveX. Una firma digital permite identificar a la compañía o individuo que ha desarrollado el software. La firma relaciona el nombre de un proveedor de software con un archivo determinado. La tecnología Authenticode se puede usar para incluir la firma en el archivo .cab.

Puede utilizar archivos .cab para mejorar la experiencia del usuario final, ya que múltiples archivos se descargan al mismo tiempo y sólo se presenta al usuario un certificado para todos ellos. Puede obtener más información acerca de esta tecnología en el sitio MSDN Online Web Workshop.

Al marcar su control como "seguro para ejecución" (safe for scripting), los usuarios saben que esa secuencia de comandos incluida en una página HTML no puede utilizar el control para dañar sus equipos ni para obtener información que no hayan proporcionado voluntariamente.

Al marcar un control como "seguro para inicialización" (safe for initialization), los usuarios saben que no hay ninguna forma de que un programador de HTML pueda dañar sus equipos al proporcionar al control datos no válidos cuando la página lo inicializa.

Nota

  • Es posible utilizar herramientas para firmar códigos que permiten firmar archivos .cab completos mediante un certificado digital.


Fecha de compilación

 Fecha de compilación: 2001-05-02


Información de copyright

La información contenida en este documento, incluidas las direcciones URL y las demás referencias a sitios Web e Internet, está sujeta a modificaciones sin previo aviso. A menos que se especifique lo contrario, los ejemplos de compañías, organizaciones, productos, nombres de dominio, direcciones de correo electrónico, logotipos, personas, lugares y acontecimientos ilustrados en el presente documento son ficticios y no se pretende asociarlos ni relacionarlos con ninguna compañía, organización, producto, nombre de dominio, dirección de correo electrónico, logotipo, persona, lugar o acontecimiento real. Es responsabilidad del usuario el cumplimiento de todas las leyes de derechos de autor aplicables. Sin limitación de los derechos bajo las leyes del copyright, ninguna parte de este documento puede ser reproducida, almacenada o incorporada a ningún sistema de recuperación, ni transmitida de ninguna forma, ni por ningún medio (ya sea electrónico, mecánico, fotocopias, grabación u otros) con ningún propósito, sin la previa autorización por escrito de Microsoft Corporation.

Microsoft puede ser titular de patentes, solicitudes de patentes, marcas, derechos de autor y otros derechos de propiedad intelectual sobre los contenidos de este documento. El suministro de este documento no le otorga ninguna licencia sobre estas patentes, marcas, derechos de autor u otros derechos de propiedad intelectual, a menos que ello se prevea en un contrato por escrito de licencia de Microsoft.

© 1999-2001 Microsoft Corporation. Reservados todos los derechos.

Active Directory, ActiveX, Authenticode, Developer Studio, DirectAnimation, DriveSpace, Hotmail, JScript, Microsoft, el logotipo de Microsoft Internet Explorer, MS-DOS, MSDN, MSN, NetMeeting, Outlook, Visual Basic, Visual C++, Windows, el logotipo de Windows, Windows Media, Windows NT y el logotipo de Windows Start son marcas comerciales registradas o marcas comerciales de Microsoft Corporation en Estados Unidos y/u otros países.

Macintosh es una marca comercial registrada de Apple Computer, Inc. Intel es una marca comercial registrada de Intel Corporation.

Los nombres de productos y compañías mencionados aquí pueden ser marcas comerciales de sus respectivos propietarios.


@@Título@@

titular

@@EncabezadoTemaConceptual@@

@@Textoaquí@@


Diagrama Configuración y directivas del sistema

 Configuración y directivas del sistema


Diagrama Instalación de Windows Update

 Instalación de Internet Explorer


Diagrama Proceso de suscripción a un ISP

 Proceso de suscripción a un ISP


Diagrama Cómo funciona la personalización

 Cómo funciona la personalización


Diagrama Sincronización automática de versiones

 Sincronización automática de versiones


Diagrama Cómo funciona la configuración automática

 Cómo funciona la configuración automática


Diagrama Cómo configurar los archivos para distribución

 Cómo configurar los archivos para distribución


Diagrama Cómo genera el IEAK paquetes personalizados

 Cómo genera el IEAK paquetes personalizados


Crear las pantallas de suscripción del Asistente para la conexión a Internet

Todas las pantallas del Asistente para la conexión a Internet (ICW) deben cumplir los requisitos estándar descritos en Requisitos de código para las pantallas del Asistente para la conexión a Internet.

Crear la pantalla de nombre y dirección para suscripciones con el ICW

Cuando el usuario se conecta a su servidor de suscripción, la primera página que ve en el servidor es la página de nombre y dirección.

La sección HTML para el nombre y la dirección se muestra en un marco dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

Crear la pantalla de opciones de facturación para suscripciones con el ICW

En la página de opciones de facturación, puede presentar las opciones de facturación del servicio entre las que el usuario puede elegir. Para ello, utilice un formulario HTML dentro de un marco en la ventana del asistente.

El usuario tiene que poder seleccionar una opción mediante un botón de opción HTML y una de las opciones de dichos botones debe estar seleccionada de forma predeterminada. Si el usuario tiene que hacer varias selecciones, también se pueden incluir casillas de verificación HTML en el marco.

El archivo HTML de opciones de facturación que proporcione se mostrará en un marco flotante dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

Crear la pantalla de métodos de pago para suscripciones con el ICW

En la página de métodos de pago, los usuarios especifican cómo desean pagar por el servicio Internet. Cada ISP controla los métodos de pago que están disponibles en la lista de métodos de pago. La información se recopila en el formulario que aparece en el marco situado debajo de la selección, que cambia en función de la opción de pago seleccionada en la lista.

Puede elegir si ofrece los métodos de pago:

  • Tarjeta de crédito; puede especificar el tipo de tarjeta, como Visa o American Express
  • Cargo
  • Factura
  • Cargos de factura de teléfono

Crear la pantalla de correo electrónico o inicio de sesión de la cuenta del ISP para suscripciones con el ICW

La cuarta página del servidor de suscripción es la página de correo electrónico o inicio de sesión de cuenta, que permite al usuario seleccionar un identificador de correo electrónico o un inicio de sesión de cuenta, y una contraseña.

La página HTML de correo electrónico o inicio de sesión de cuenta que el servidor de suscripción envía se muestra en un marco flotante dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

Crear la pantalla de selección de POP del ISP para suscripciones con el ICW

La página de selección del protocolo de oficina de correo (POP) es donde el usuario selecciona un número de teléfono local para el acceso a Internet.

La página HTML de selección de POP que envía el servidor de suscripción del ISP se muestra en un marco flotante dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

No se pedirá al usuario que escriba un código de área o un número de teléfono por segunda vez. Los campos de número de teléfono o código de área del marco se deben llenar previamente con la información enviada al servidor de suscripción del ISP desde el formulario Nombre y dirección.

Crear la pantalla de términos y condiciones del ISP para suscripciones con el ICW

En la página de términos y condiciones del ISP, el ISP muestra el contrato legal que el usuario debe leer para suscribirse al servicio. Para asegurar que el usuario acepta el contrato, el botón Siguiente del ICW no estará disponible hasta que el usuario haga clic en Acepto el contrato.

El usuario puede guardar los términos de la página HTML para verlos más tarde si hace clic en el botón Guardar copia. Cuando el usuario hace clic en el botón, se le pide que escriba un nombre de archivo y una ruta de acceso para guardarlo.

La página HTML de términos y condiciones que envía el servidor de suscripción del ISP se mostrará en un marco flotante con un borde de 2 píxeles dentro del asistente. El marco tiene 426 píxeles de ancho, sin el borde de 2 píxeles y la barra de desplazamiento vertical. La barra de desplazamiento horizontal no aparece si la página HTML supera las dimensiones del ancho.

La página de términos y condiciones debe comenzar con el título del documento e instrucciones que expliquen la forma en que el usuario puede encontrar una copia del documento legal en el sitio Web del ISP si desea verlo de nuevo o imprimirlo.

Nota

  • No hay requisitos de accesibilidad para esta página debido a que en ella no se permiten elementos de formulario HTML.


Crear el archivo Icwsign.htm, las páginas de error y la página de finalización para suscripciones con el ICW

Para suscripciones con el ICW, debe diseñar la pantalla inicial que ven los usuarios (el archivo Icwsign.htm), las páginas de error y la página de finalización.

La primera pantalla: Icwsign.htm

La primera página que el usuario ve después de instalar Internet Explorer y reiniciar el equipo es la página Icwsign.htm. En esta página, el usuario verá un mensaje de bienvenida del ISP y se le pedirá: que haga clic en Siguiente para comenzar el proceso de suscripción, si sólo se necesita un archivo ISP para la suscripción, o que seleccione la ciudad y el estado desde los que marca, de forma que el ICW pueda seleccionar el archivo ISP del servidor de suscripción apropiado.

Cuando el usuario hace clic en Siguiente, el ICW marca y conecta al usuario con el servidor de suscripción del ISP. Esta página se especifica en el IEAK y está incluida en su versión de Internet Explorer. No se aloja en el servidor de suscripción.

Páginas de error para suscripciones con el ICW

Si los datos enviados al servidor de suscripción no son válidos en algún momento durante el proceso de suscripción, el servidor puede mostrar una página HTML con un mensaje descriptivo del error. Por ejemplo, si el cliente solicita un nombre de correo electrónico que ya está en uso, puede sugerir alternativas y pedirle que solicite una dirección de correo electrónico diferente.

La página HTML de error que el servidor de suscripción del ISP envía se muestra en un marco flotante dentro del asistente. El marco tiene 444 píxeles de ancho por 273 píxeles de alto. Las barras de desplazamiento no aparecen si la página HTML supera estas dimensiones.

El marco debe contener texto que permita al usuario saber que los datos introducidos no eran válidos y proporcionar los elementos de formulario necesarios para que el usuario escriba otros datos.

Para obtener información acerca del diseño HTML y los elementos de formulario necesarios, consulte Requisitos de código para las pantallas del Asistente para la conexión a Internet.

Página de finalización para suscripciones con el ICW

Cuando el usuario hace clic en Siguiente en la página de finalización del ISP, se procesa el archivo .ins y el equipo se configura para la nueva cuenta de Internet. Una vez hecho esto, el ICW muestra su página de finalización, que informa al usuario de que la conexión de Internet está preparada y le indica cómo comenzar a explorar Internet. No hay una interfaz configurable por el ISP en esta página.

La página de finalización también ofrece la opción de comenzar la exploración inmediatamente cuando el usuario activa la casilla de verificación Comenzar la exploración inmediatamente.

Puede usar el valor [URL] del archivo .ins para especificar la página que muestra el explorador cuando se abre por primera vez.

Usar el archivo .ins para configurar el equipo de un usuario

Una vez que el usuario ha finalizado el proceso de suscripción, el servidor de suscripción debe devolver información acerca de cómo configurar el equipo del usuario para el acceso a Internet. El archivo .ins, que se descarga al final del proceso de suscripción, contiene esta información.


Buscar más información en Internet

Puede buscar más información y administrar su cuenta IEAK en Internet.

Para obtener más información, visite el sitio Web del IEAK. Este sitio Web se actualiza con frecuencia, por lo que debe visitarlo a menudo para obtener la información más reciente.


Trabajar con archivos de información para la instalación (.inf)

Un archivo de información (.inf) es un archivo de texto que especifica los archivos que deben estar presentes o se tienen que descargar para que el componente se ejecute en versiones de Windows de 32 bits. El servicio Descarga de componentes de Internet usa estas instrucciones para instalar y registrar los componentes de software descargados de Internet y los archivos que éstos necesitan. El servicio Descarga de componentes de Internet lleva formando parte de Internet Explorer desde la versión 3.0.

Una unidad de distribución de software de Internet es un "paquete" que consta de un archivo contenedor (.cab) que contiene un archivo .inf. Una unidad de distribución también puede contener un componente software como un control ActiveX (.ocx), un archivo .dll, un archivo .exe, un archivo de clase de Java o un pequeño programa. Cuando un atributo CODEBASE de un elemento OBJECT en una página Web hace referencia a un archivo contenedor que contiene un archivo .inf, Internet Explorer 3.0 o posterior trata automáticamente al archivo contenedor como una unidad de distribución de software.

Con los archivos .inf, puede crear instrucciones de instalación de software personalizadas que incluyan entradas del Registro y directorios de destino. Un archivo .inf ofrece una independencia limitada de la plataforma y especifica dependencias de software limitadas.

Los temas siguientes proporcionan más información acerca de cómo se trabaja con archivos .inf:

  • Definición del archivo de información para la instalación (.inf)
  • Tratar carpetas y archivos mediante archivos de información para la instalación (.inf)
  • Extensiones del programa de instalación de Windows
  • Proporcionar la funcionalidad de desinstalación en una secuencia de comandos .inf
  • Usar la tecnología RunOnce
  • Ejemplo de archivo .inf para el servicio de descarga de componentes

Nota

  • Para obtener más información acerca del servicio Descarga de componentes de Internet, consulte el sitio MSDN Online Web Workshop.


[Branding]

Dirección URL de complemento

Valor: http://server/addons/addon.htm

Dirección URL de complemento para el comando Actualizaciones del producto en el explorador.

BrowserDefault

Valor: 0 | 1 | 2

En el modo de administrador corporativo, establezca el valor a 0 para bloquear Internet Explorer como explorador predeterminado; establezca el valor a 1 para preservar el explorador predeterminado existente, o establézcalo a 2 para dejar que decida el usuario.

CMBitmapName

Valor: nombre_archivo

Nombre de archivo del mapa de bits personalizado del Connection Manager.

CMBitmapPath

Valor: ruta de acceso

Ruta de acceso completa al archivo de mapa de bits personalizado del Connection Manager.

CMProfileName

Valor: nombre_archivo

Nombre del perfil del Connection Manager.

CMProfilePath

Valor: ruta de acceso

Ruta de acceso completa al perfil del Connection Manager.

CMUseCustom

Valor: 0 | 1

Especifica si va a utilizar un perfil del Connection Manager personalizado. Establezca el valor 1 para utilizar un perfil personalizado.

CompanyName

Valor: nombre

Nombre de la empresa con una licencia válida de IEAK que está generando este archivo .ins.

EncodeFavs

Valor: 0 | 1

Establezca el valor a 1 para cifrar correctamente la sección [Favorites] generada por el IEAK, para versiones de Internet Explorer anteriores a 5.0.

FavoritesDelete

Valor: hexadecimal

Establezca este valor a 0 x 89 para quitar todos los elementos de Favoritos y de Vínculos rápidos. Esta opción sólo es recomendable para administradores corporativos.

FavoritesOnTop

Valor: 0 | 1

Establezca el valor a 1 para poner nuevos elementos favoritos en la parte superior del menú Favoritos.

IE4 Welcome Msg

Valor: 0 | 1

Establezca el valor a 1 para ir a una página de bienvenida la primera vez que se abra el explorador.

Language ID

Valor: número

Página de código del idioma utilizado.

Language Locale

Valor: Conf_regional

Configuración regional de la versión de Internet Explorer que se está personalizando, según denota una cadena de dos letras, por ejemplo, EN para inglés.

NoDial

Valor: 0 | 1

Para ISP: Establezca el valor a 1 si no utiliza ningún tipo de proceso de suscripción basado en IEAK.

NoIELite

Valor: 0 | 1

Establezca el valor a 1 si desea que el Asistente para la instalación activa optimice la descarga, utilizando archivos existentes si es posible.

Instalación silenciosa

Valor: 0 | 1

Para los administradores corporativos: establezca el valor a 1 si desea que la Instalación de Windows Update se ejecute de manera no interactiva, pero que muestre el progreso y los mensajes de error.

StealthInstall

Valor: 0 | 1

Para administradores corporativos: Establezca el valor a 1 si desea que la instalación de Windows Update se ejecute sin ninguna información visual de los resultados.

Mapa de bits de la barra de herramientas

Valor: ruta_y_nombre_archivo

Ruta de acceso completa al mapa de bits que aparece en la barra de herramientas del explorador.

Tipo

Valor: 0 | 1 | 2

Especifique el tipo de personalización que se utiliza: 2 = Administrador corporativo, 1 = Proveedor de servicios Internet, 0 = Proveedor de contenido Internet.

Agente del usuario

Valor: cadena

Cadena que se anexa a la cadena predeterminada de agente del usuario.

Versión

Valor: cadena

Versión del explorador, por ejemplo, 6, 0, 0, 1.

WebIntegrated

Valor: 0 | 1

Especifica si el shell integrado de Internet Explorer 4.x está incluido en este paquete. Establezca el valor a 1 si se ha incluido.

Win32DownloadSite

Valor: dirección url

Dirección URL desde la cual se descarga el archivo de instalación de Windows Update (IEsetup.exe).

Window_Title

Valor: cadena

Título de ventana personalizado para Internet Explorer

Window_Title_CN

Valor: cadena

El nombre de la empresa que se va a anexar al título de ventana.

WizardVersion

Valor: cadena

Versión del Asistente para IEAK que creó el archivo .ins, por ejemplo, 6.00.0707.2800.


[BrowserToolbars]

Action0

Valor: ruta_y_nombre_archivo

Ruta de acceso y nombre de archivo para el archivo ejecutable asociado a un botón de la barra de herramientas personalizado.

Caption0

Valor: leyenda

Leyenda del botón de la barra de herramientas personalizado.

DeleteButtons

Valor: 0 | 1

Especifica si se eliminan los botones de la barra de herramientas personalizados existentes en la instalación. Establezca el valor 1 para eliminar los botones.

HotIcon0

Valor: ruta_y_nombre_archivo

El icono resaltado (un archivo .ico) que aparece en el botón cuando se pasa el mouse (ratón) por encima.

Icon0

Valor: ruta_y_nombre_archivo

El icono atenuado (un archivo .ico) que aparece en el botón cuando no se pasa el mouse por encima.

Show0

Valor: 0 | 1

Especifica si se va a mostrar el botón nuevo en la barra de herramientas de manera predeterminada. Establezca el valor 1 para mostrar el botón.

ToolTipText0

Valor: texto

Texto de la información sobre herramientas para el botón personalizado.


[CDCustomFiles]

DisableStart

Valor: 0 | 1

Especifica si desea utilizar un programa de ejecución automática del CD. Establezca el valor 0 para utilizar un programa de ejecución automática del CD.

MoreInfo

Valor: ruta de acceso de archivo

El archivo que se abre cuando los usuarios hacen clic en Más Info en la pantalla de ejecución automática del CD.

StartHtm

Valor: ruta de acceso de archivo

Una página HTML a la que se accede desde la pantalla de ejecución automática del CD.


[ConnectionSettings]

ConnectName0

Valor: cadena

Nombre de la conexión.

ConnectName1

Valor: cadena

DeleteConnectionSettings

Valor: 0 | 1

Especifica si se elimina la configuración de la conexión existente en el momento de la instalación. Sólo en modo del administrador corporativo: Establezca el valor 1 para eliminar la configuración.

Option

Valor: 0 | 1

Establezca el valor a 1 si un usuario elige importar la configuración de la conexión al Asistente para IEAK.


[CustomBranding]

Branding

Valor: dirección url

Dirección URL para el archivo .cab de marca, por ejemplo, http://www.suservidor.net/cabs/branding.cab.


[CustomWallpaper]

File0

Valor: nombre_archivo

Archivo HTML que se utiliza para el tapiz personalizado.

File1

Valor: nombre_archivo

Archivos adicionales para el tapiz personalizado.

NumFiles

Valor: 2

Número total de archivos para el tapiz personalizado.


[Device]

Tipo

Valor: cadena

El tipo de conexión que se utiliza para la instalación de Windows Update, por ejemplo, mediante módem.


[Entry]

Cancel

Valor: Sí | No

Especifica si se cancela el proceso de suscripción. Lo utiliza el Asistente para la conexión a Internet. Establezca el valor a Sí para cancelar el proceso de suscripción.

Entry_Name

Valor: cadena

El nombre de la conexión de Acceso telefónico a redes.


[FavoritesEx]

IconFile1

Valor: ruta_y_nombre_archivo

Icono para el elemento favorito que se va a agregar.

Offline1

Valor: 0 | 1

Especifica si el elemento favorito se encuentra disponible para la exploración sin conexión. Establezca el valor 1 para que esté disponible.

Title1

Valor: cadena

Título del elemento favorito.

Url1

Valor: dirección url

Dirección URL del elemento favorito.


[Internet_Mail]

Default_Client

Valor: Sí | No

Especifica si Internet Mail es el cliente predeterminado (para Internet Explorer 4.x personalizado).

Infopane

Valor: ruta_y_nombre_archivo

Archivo HTML para el Panel de información con marca en Outlook Express personalizado.

Infopane_Bitmap

Valor: ruta_y_nombre_archivo

Archivo .gif con marca para Outlook Express personalizado.

Junk_Mail_Filtering

Valor: 0 | 1

Especifica si se activa la característica de filtro de correo no deseado de manera predeterminada. Establezca el valor a 1 para activar la característica.

Logon_Using_SPA

Valor: Sí | No

Especifica si se inicia una sesión utilizando la Autenticación de contraseña segura.

POP_Server

Valor: cadena

Nombre de host del servidor POP3 que se establece de manera predeterminada, por ejemplo, pop.suservidor.net.

SMTP_Logon_Required

Valor: 0 | 1

Especifica si se requiere iniciar una sesión en el servidor SMTP de manera predeterminada. Establezca el valor a 1 para requerir un inicio de sesión.

SMTP_Logon_Using_SPA

Valor: Sí | No

Especifica si se inicia una sesión en el servidor SMTP usando la Autenticación de contraseña segura.

SMTP_Server

Valor: cadena

Nombre de host del servidor SMTP que se establece de manera predeterminada, por ejemplo, smtp.suservidor.net.

Use_IMAP

Valor: Sí | No

Especifica si se utiliza el protocolo IMAP para el correo electrónico.

Welcome_Address

Valor: cadena

La dirección "De" para el mensaje de bienvenida en Outlook Express, por ejemplo, bienvenida@suservidor.net.

Welcome_Message

Valor: ruta_y_nombre_archivo

Ubicación del archivo HTML que contiene el mensaje de bienvenida.

Welcome_Name

Valor: cadena

Nombre descriptivo de la dirección "De" para el mensaje de bienvenida, por ejemplo, "Bienvenido a Internet Mail personalizado"

Window_Title

Valor: cadena

Título de ventana personalizado para Outlook Express.


[Internet_News]

Default_Client

Valor: Sí | No

Especifica si se utiliza Outlook Express como el cliente de noticias personalizado.

Logon_Required

Valor: 0 | 1

Especifica si el servidor NNTP requiere que los usuarios inicien una sesión en él. Establezca el valor a 1 si los usuarios deben iniciar una sesión.

Logon_Using_SPA

Valor: Sí | No

Especifica si el servidor NNTP utiliza la Autenticación de contraseña segura.

NNTP_Server

Valor: cadena

Nombre de host del servidor NNTP, por ejemplo, noticias.suservidor.net.


[ISP_Security]

RootCertPath

Valor: ruta_y_nombre_archivo

Un certificado raíz para agregar al sistema.


[LDAP]

AuthType

Valor: 0 | 2

Especifica cómo la Libreta de direcciones de Windows accede a los servicios de directorio. Establezca el valor a 0 para autenticar a través del acceso integrado a los directorios más utilizados. Establezca el valor a 2 para autenticar a través de SPA. Para más información, consulte el Servicio de directorio de la Libreta de direcciones.

Bitmap

Valor: ruta_y_nombre_archivo

C:\Mis Documentos\Branding\LDAP.bmp.

Checknames

Valor: 0 | 1

Especifica si Outlook Express debe comprobar siempre los nombres y direcciones de correo electrónico con el servidor LDAP. Establezca el valor a 1 para que Outlook Express siempre realice la comprobación.

FriendlyName

Valor: cadena

Nombre descriptivo para la cuenta del servidor LDAP.

HomePage

Valor: dirección url

Ubicación de la página principal del explorador.

SearchBase

Valor: dirección url

Ubicación de la página de búsqueda del explorador.

Server

Valor: cadena

Nombre de host del servidor LDAP, por ejemplo, LDAP-SRV-1.


[Mail_Signature]

Signature_Text

Valor: cadena

Texto fijo que se agrega automáticamente al final de los mensajes de correo electrónico o de las publicaciones en grupos de noticias. Termina con los caracteres "\n".

Use_Mail_For_News

Valor: 0 | 1

Especifica si se agrega el valor de Signature_Text al final de las publicaciones a los grupos de noticias. Establezca el valor a 1 para incluir la firma.

Use_Signature

Valor: 0 | 1

Especifica si se agrega el valor de Signature_Text al final de los mensajes de correo electrónico. Establezca el valor a 1 para incluir la firma.


[Media]

Build_CD

Valor: 0 | 1

Especifica si va a crear un paquete de instalación en CD. Establezca el valor a 1 para crear el paquete.

Build_Download

Valor: 0 | 1

Especifica si va a crear un paquete de instalación que los usuarios pueden descargar. Establezca el valor a 1 para crear el paquete.

Build_Floppy

Valor: 0 | 1

Especifica si va a crear un paquete de instalación de sólo marca en un único disquete. Establezca el valor a 1 para crear el paquete.

Build_LAN

Valor: 0 | 1

Especifica si va a crear un paquete de instalación basada en LAN. Establezca el valor a 1 para crear el paquete.

Build_MultiFloppy

Valor: 0 | 1

Especifica si va a crear un paquete de instalación en varios disquetes. Establezca el valor a 1 para crear el paquete.


[Outlook_Express]

Contacts

Valor: 0 | 1

Especifica si se mostrarán los contactos de manera predeterminada.

Folder_Bar

Valor: 0 | 1

Especifica si se mostrará la barra de carpetas de manera predeterminada.

Folder_List

Valor: 0 | 1

Especifica si se mostrará la lista de carpetas de manera predeterminada.

Outlook_Bar

Valor: 0 | 1

Especifica si se mostrará la barra de Outlook de manera predeterminada.

Preview_Pane

Valor: 0 | 1

Especifica si se mostrará el panel de vista previa de manera predeterminada.

Safe_Attachments

Valor: 0 | 1

Especifica si los datos adjuntos pueden guardarse o abrirse si se cree que pueden contener un virus. Establezca el valor a 0 para permitir que los datos adjuntos se guarden o se abran.

Show_Preview_Beside_Msgs

Valor: 0 | 1

Especifica si se mostrará la vista previa del mensaje de manera predeterminada. Establezca el valor a 1 para mostrar la vista previa del mensaje.

Show_Preview_Header

Valor: 0 | 1

Especifica si se mostrará la barra del encabezado del panel de vista previa de manera predeterminada.

Show_Toolbar_Text

Valor: 0 | 1

Especifica si se mostrará el texto de la barra de herramientas de manera predeterminada.

Status_Bar

Valor: 0 | 1

Especifica si se mostrará la barra de estado de manera predeterminada.

Tip_Day

Valor: 0 | 1

Especifica si se mostrará la sugerencia del día de manera predeterminada.

Toolbar

Valor: 0 | 1

Especifica si se mostrará el texto de la barra de herramientas de manera predeterminada.

Warn_on_Mapi_Send

Valor: 0 | 1

Especifica si desea que aparezca un mensaje de advertencia cuando otras aplicaciones envíen correo en su nombre. Establezca el valor a 1 para recibir un mensaje de advertencia.


[Outlook_Express_Global]

Read_Only

Valor: 0 | 1

Especifica si los nombres de servidor se muestran como sólo lectura en la configuración de Outlook Express. Establezca el valor a 1 para que los nombres de servidor sean de sólo lectura.

Service_Name

Valor: nombre

Nombre de la organización.

Service_URL

Valor: dirección url

Ubicación del servicio de correo.


[Phone]

Area_Code

Valor: número

Código de área para la conexión de acceso telefónico.

Country_Code

Valor: número

Código de país o región para la conexión de acceso telefónico.

Country_ID

Valor: número

Id. de país o región para la conexión de acceso telefónico.

Dial_As_Is

Valor: Sí | No

Marcar el número tal cual, sin agregar código de área ni otros números.

Phone_Number

Valor: número

Número de teléfono que debe marcarse.


[Proxy]

FTP_Proxy_Server

Valor: proxy

Nombre de host del servidor proxy.

Gopher_Proxy_Server

Valor: proxy

Nombre de host del servidor proxy.

HTTP_Proxy_Server

Valor: proxy

Nombre de host del servidor proxy.

Proxy_Enable

Valor: 0 | 1

Especifica si se usa un servidor proxy. Establezca el valor a 1 para usar un servidor proxy.

Proxy_Override

Valor: cadena

Nombre de host para un servidor proxy, por ejemplo, <LOCAL>.

Secure_Proxy_Server

Valor: proxy

Nombre de host del servidor proxy.

Socks_Proxy_Server

Valor: proxy

Nombre de host del servidor proxy.

Use_Same_Proxy

Valor: 0 | 1

Especifica si se utiliza un servidor proxy para todos los servicios. Establezca el valor a 1 para usar el mismo servidor proxy.


[Script_File]

1

Valor: texto

Primera línea del archivo de comandos.

2

Valor: texto

Segunda línea del archivo de comandos.

3

Valor: texto

Tercera línea del archivo de comandos.

n

Valor: texto

Texto de la línea n en el archivo de comandos.


[Scripting]

Name

Valor: nombre_archivo

Nombre de archivo de la secuencia de comandos de Acceso telefónico a redes, por ejemplo, dialup.scp.

Name16

Valor: nombre_archivo

Nombre de archivo de la secuencia de comandos de Acceso telefónico a redes (16 bits).

Name32

Valor: nombre_archivo

Nombre de archivo de la secuencia de comandos de Acceso telefónico a redes (32 bits).

Path16

Valor: ruta_y_nombre_archivo

Ruta de acceso completa a la secuencia de comandos de 16 bits.

Path32

Valor: ruta_y_nombre_archivo

Ruta de acceso completa a la secuencia de comandos de 32 bits.


[Security Imports]

ImportAuthCode

Valor: 0 | 1

Especifica si se importa la configuración de Authenticode existente.

ImportRatings

Valor: 0 | 1

Especifica si se importa la configuración de Clasificación de contenidos existente.

ImportSecZones

Valor: 0 | 1

Especifica si se importa la configuración de Zonas de seguridad existente.

ImportSiteCert

Valor: 0 | 1

Especifica si se importan las Entidades emisoras de certificados de sitios existentes.

Win16SiteCerts

Valor: 0 | 1

Especifica si se utilizan certificados de sitios en equipos con Windows de 16 bits.


[Server]

Disable_LCP

Valor: Sí | No

Especifica si se utiliza información acerca de cómo configurar los equipos de los clientes para el acceso a Internet. Esta información se utiliza al final del proceso de suscripción del Asistente para la conexión a Internet.

Negotiate_IPX/SPX

Valor: Sí | No

Especifica si se utiliza el protocolo IPX.

Negotiate_NetBEUI

Valor: Sí | No

Especifica si se utiliza el protocolo NetBEUI.

Negotiate_TCP/IP

Valor: Sí | No

Especifica si se utiliza el protocolo TCP/IP.

Network_Logon

Valor: Sí | No

Especifica si se inicia una sesión en la red.

PW_Encrypt

Valor: Sí | No

Especifica si se utiliza una contraseña cifrada.

SW_Compress

Valor: Sí | No

Especifica si se utiliza compresión de software.

SW_Encrypt

Valor: Sí | No

Especifica si requiere cifrado de datos.

Type

Valor: cadena

Tipo de servidor, por ejemplo, "ppp".


[Signature]

Signature_Text

Valor: cadena

Texto de una firma de correo electrónico. Termina con los caracteres "\n".

Use_Signature

Valor: 0 | 1

Especifica si se usa una firma.


[Small_Logo]

Name

Valor: nombre de archivo

El nombre del mapa de bits de 22 x 22 píxeles que aparece en la esquina superior derecha del explorador.

Path

Valor: ruta de acceso de archivo

La ruta de acceso del mapa de bits de 22 x 22 píxeles que aparece en la esquina superior derecha del explorador.


[TCP/IP]

DNS_Address

Valor: cadena

Número IP del servidor DNS que se va a utilizar, por ejemplo, 127.0.0.1 .

DNS_Alt_Address

Valor: cadena

Número IP del servidor DNS alternativo que se va a utilizar, por ejemplo, 127.0.0.1 .

Gateway_On_Remote

Valor: Sí | No

Especifica si se usa una puerta de enlace remota.

IP_Header_Compress

Valor: Sí | No

Especifica si se utiliza compresión del encabezado IP.

Specify_IP_Address

Valor: Sí | No

Especifica si se utiliza una contraseña IP.

Specify_Server_Address

Valor: Sí | No

Especifica si se usa una dirección del servidor.


[URL]

AutoConfig

Valor: 0 | 1

Especifica si se configura automáticamente el explorador personalizado. Establezca el valor a 1 para configurar automáticamente el explorador.

AutoConfigJSURL

Valor: dirección url

Dirección URL para el archivo proxy automático, escrito en JavaScript o Microsoft JScript.

AutoConfigTime

Valor: entero

Configura automáticamente el explorador una vez ha funcionado este número de minutos.

AutoConfigURL

Valor: dirección url

Dirección URL del archivo de proxy automático

FirstHomePage

Valor: dirección url

Página que se explorará la primera vez que ejecute el explorador personalizado.

Help_Page

Valor: dirección url

Dirección URL de una página Web que ofrece soporte técnico.

Home_Page

Valor: dirección url

Dirección URL de la página principal predeterminada.

NoWelcome

Valor: 0 | 1

Especifica si no se muestra una página de bienvenida la primera vez que se utiliza el explorador. Establezca el valor a 1 para no mostrar la página de bienvenida.

Quick_Link_1

Valor: dirección url

Dirección URL de Vínculos rápidos.

Quick_Link_1_Name

Valor: cadena

Nombre asociado a Quick_Link_1.

Quick_Link_2

Valor: dirección url

Segunda dirección URL de Vínculos rápidos.

Quick_Link_2_Name

Valor: cadena

Nombre asociado a Quick_Link_2.

Quick_Link_X

Valor: dirección url

Dirección URL de Vínculos rápidos.

Quick_Link_X_Icon

Valor: ruta_y_nombre_archivo

Icono de Vínculos rápidos.

Quick_Link_X_Name

Valor: cadena

Nombre asociado a Quick_Link_X.

Quick_Link_X_Offline

Valor: 0 | 1

Especifica si el vínculo rápido se encuentra disponible para la exploración sin conexión.

Search_Page

Valor: dirección url

Página de búsqueda predeterminada.

Signup

Valor: ruta_y_nombre_archivo

Ruta de acceso a la página que contiene un vínculo al archivo .ins para el servidor de suscripción.

UseLocalIns

Valor: 0 | 1

Especifica si se usa un archivo .ins local.


[User]

Display_Password

Valor: Sí | No

Especifica si se muestra la contraseña.

Name

Valor: cadena

Nombre de usuario.

Password

Valor: cadena

Contraseña.

Requires_Logon

Valor: Sí | No

Especifica si se requiere un inicio de sesión del usuario.


Entradas del archivo de configuración de Internet

Las siguientes secciones aparecen en el archivo de configuración de Internet (.ins):

  • [Animation]
  • [ActiveSetup]
  • [ActiveSetupSites]
  • [Batch]
  • [Big_Logo]
  • [Branding]
  • [BrowserToolbars]
  • [CabSigning]
  • [CDCustomFiles]
  • [ConnectionSettings]
  • [Custom Branding]
  • [Custom Wallpaper]
  • [Device]
  • [Entry]
  • [ExtRegInf]
  • [FavoritesEx]
  • [HideCustom]
  • [ICW_IEAK]
  • [Internet_Mail]
  • [Internet_News]
  • [ISP_Security]
  • [LDAP]
  • [Mail_Signature]
  • [Media]
  • [Outlook_Express_Global]
  • [Outlook_Express]
  • [Phone]
  • [Proxy]
  • [Scripting]
  • [Script_File]
  • [Security Imports]
  • [Server]
  • [Signature]
  • [SignupFiles]
  • [Small_Logo]
  • [TCP/IP]
  • [URL]
  • [User]


Crear múltiples versiones del explorador

Utilice este proceso para crear diferentes versiones del explorador, como versiones con servidores de correo distintos, que compartan buena parte de la configuración.

El Asistente para personalizar Internet Explorer 6 muestra la configuración especificada para la versión original del explorador personalizado. Estas opciones de configuración se guardan en el archivo Install.ins. Si cambia el nombre de los archivos .ins, puede realizar cambios rápidamente en todas las versiones del explorador personalizado.

  1. Cree una versión de su explorador personalizado con el asistente.
  2. Cambie el nombre del archivo Install.ins, que se encuentra en la carpeta CIE\Custom. Por ejemplo, si necesita una versión para usuarios de Toledo, puede dar al archivo el nombre Toledo.ins.
  3. Abra el archivo Signup.htm de la carpeta CIE\Custom. Cree un vínculo en este archivo al archivo Toledo.ins.
  4. Ejecute de nuevo el asistente y especifique la misma carpeta personalizada como directorio de destino de los archivos de salida.

    5. Mantenga la misma configuración del asistente en todas las versiones, excepto para los elementos siguientes, que puede personalizar en cada versión:

    • Logotipo
    • Texto de la barra de título
    • Favoritos
    • Barra de vínculos
    • Página principal y página de búsqueda
    • Servidores de correo y dominio
  5. Repita los pasos del 2 al 4 hasta que haya creado todas las versiones del explorador personalizado.

Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.


Crear un archivo .isp

Si está implementando un proceso de suscripción con su paquete del explorador personalizado, el archivo de suscripción a Internet (.isp) Signup.isp proporciona la información de acceso telefónico necesaria para los servicios Internet. Si se utiliza el método de suscripción con servidor, este archivo de suscripción a Internet también contiene un vínculo a la dirección URL de la secuencia de comandos del servidor que genera el archivo de configuración (.ins). El Kit de herramientas del IEAK incluye una herramienta (el Asistente para archivos ISP) que puede usar con el fin de generar su archivo .isp automáticamente.

Para instalar este asistente, haga doble clic en Filewiz.exe en la carpeta \<carpeta de programa IEAK>\Toolkit\ISP\Wizard.

Para iniciar el Asistente para archivos ISP
  • Haga clic en Inicio, señale Programas, y finalmente haga clic en Asistente para archivos ISP.
  • Siga las instrucciones del asistente para crear un archivo .isp personalizado.

Nota

  • También puede impedir que se defina un código de área como predeterminado si utiliza un indicador en el archivo .isp. La sintaxis de ese indicador es la siguiente:
    Dial_As_Is=Yes

    Puede utilizar ese indicador de la forma indicada cuando, por ejemplo, algunos usuarios puedan hacer sus llamadas desde una zona con código de área distinto del predeterminado. Si los usuarios no advierten que el código de área predeterminado es distinto al del área en la que se encuentran, podrían, inadvertidamente, realizar llamadas de larga distancia.


Soporte Técnico

Para España

Los productos de consumo, los Sistemas Operativos Personales de Microsoft, como MS-DOS, Windows 3.x, Windows95 y WindowsNT Workstation, así como las aplicaciones de la familia Microsoft Office y los lenguajes y Kits de Desarrollo de Microsoft, cuentan con soporte Standard limitado gratuito.

Para el resto de productos Microsoft que no disponen de soporte Standard así como una vez que esta modalidad de soporte gratuito hubiese acabado, Microsoft Ibérica pone a su disposición una amplia gama de servicios de Soporte Técnico que van desde la contratación de un incidente individual o packs de incidentes, hasta contratos Priority con servicios y privilegios especiales.

Asimismo, en los Servicios de Información podrá encontrar toda la ayuda que necesite sin restricciones de horarios ni coste (excepto el de la llamada telefónica). Artículos técnicos, FAQ's (o las preguntas más comunes), Service Packs, Parches (correctores de errores concretos), Drivers actualizados y nuestra Base del Conocimiento (Knowledge Base).

Todos estos servicios se pueden localizar en Internet (http://www.microsoft.com/spain/support/)

Los Servicios de Información, también cuentan con suscripciones anuales a Microsoft TechNet y a MSDN.

También podrá encontrar ayuda en nuestros Servicios de Información. Para más información, consulte nuestra web en www.microsoft.com/spain/support/ y/o llame a nuestro teléfono de Servicio a Clientes 902 197198 ó 91 375 40 04

Nota: Microsoft se reserva el derecho de cambiar los servicios descritos sin previo aviso.

Para Latinoamérica

Microsoft Soporte Técnico está sujeto a los términos y condiciones vigentes en cada país donde se ofrece este servicio y está sujeto a cambio sin previo aviso.

Podrá encontrar la respuesta a las preguntas más frecuentes de los productos Microsoft y obtener las últimas actualizaciones disponibles a través de nuestro Servicio de Soporte Técnico en Internet, accediendo a http://www.microsoft.com/latam/soporte

Soporte Técnico Telefónico

Para llamar a soporte técnico debe tener disponible la documentación correspondiente del producto Microsoft y seguir los siguientes pasos:

  • Se le pedirá el número de la versión del producto que está usando.
  • El número de producto o PID (Product Identification).
  • El tipo de hardware que está usando.
  • El Sistema Operativo.
  • Las palabras exactas de los mensajes que aparecen en la pantalla.
  • Una descripción de lo que ha sucedido y de lo que estaba haciendo cuando el problema se presentó.
  • Una descripción sobre cómo trató de resolver el problema.
  • Los números telefónicos para soporte técnico se encuentran en la siguiente lista.

Argentina

Microsoft de Argentina S.A.

Servicios al Cliente: (54) (11) 4316-4600

Fax: (54) (11) 4316-4698

Soporte Técnico: (54) (11) 4316-4664

Bolivia

Microsoft Bolivia

Soporte Técnico: 0800-3443

Atención a Clientes: 0800-2029

Brasil

Microsoft Informática Ltda.

Teléfono: (55) (11) 5504 - 2155

Fax: (55) (11) 5504 - 2227/5504-2228

Soporte Técnico: (55) (11) 3444 - 6844

Soporte Técnico Fax: (55) (11) 5506 - 7621

Fax Automático: (55) (11) 5506 - 8506

Servicios al Cliente: (55) (11) 5853 - 2345

Fax de Servicios al Cliente : (55) (11) 5853 - 2343

Caribe

Microsoft Caribbean, Inc.

Teléfono: (787) 268-8528

Fax: (787) 273-3636

Soporte Técnico: 1-877-672-3842

Correo Electrónico para soporte técnico: mscasup@microsoft.com

Centro de Servicios: (800) 297 5982, para códigos de áreas 787 & 809 solamente, 506-298-2000 (para otras áreas)

Correo Electrónico para Atención a Usuarios: msccatus@microsoft.com

Centro América

Soporte Técnico: (506) 298 2020

Correo Electrónico para soporte técnico: mscasup@microsoft.com

Customer Service/Centro de Servicios: (506) 298 2000

Customer Service E-mail/Correo Electrónico para Atención a Usuarios: msccatus@microsoft.com

Chile

Microsoft Chile S.A.

Teléfono: 800-330-6000

Colombia

Microsoft Colombia

Línea de Respuesta Microsoft (Santafé de Bogotá D.C.)

Teléfono: (91) 524-0404

Para llamadas desde fuera de Bogotá: 9800-5-10595 / 9800-9-10595

Fax: (91) 524-0405

Ecuador

Microsoft del Ecuador S.A.

Teléfono: (593) (2) 258 025

PBX: (593) (2) 263-820

Fax: (593) (2) 262-894

México

Microsoft México, S.A. de C.V.

Aplicaciones y Sistemas Operativos de Escritorio: (52) (5) 265-3399

Herramientas de Desarrollo y Sistemas Avanzados: (52) (5) 267-2190

Atención a Clientes: (52) (5) 265-3380

Atención a Distribuidores: (52) (5) 267-2110

Fax: (52) (5) 267-2119

Panamá

Microsoft de Panamá, S.A.

Soporte Técnico: (506) 298 2020

Correo Electrónico para soporte técnico: mscasup@microsoft.com

Centro de Servicios: (800) 506-0001

Correo Electrónico para Atención a Usuarios: msccatus@microsoft.com

Paraguay

Microsoft Paraguay

Atención al Cliente: (595) (21) 498-190

Soporte técnico: (595) (21) 495-865

Perú

Microsoft Perú S.A.

Atención al Cliente: (51) (1) 215-5002

Soporte Técnico: (51) (1) 215-5005

InfoEmpresa: (51) (1) 215-5006

Información sobre Eventos: (51) (1) 215-5010

Fax: (51) (1) 215-5004

Puerto Rico

Microsoft Puerto Rico

Soporte Técnico: (787) 268-8528 1-877-672-3842

Correo Electrónico para soporte técnico: mscasup@microsoft.com

Centro de Servicios: (800) 297 5982 para códigos de áreas 787 & 809 solamente

Correo Electrónico para Atención a Usuarios: msccatus@microsoft.com

República Dominicana

Ver Caribbean

Uruguay

Microsoft Uruguay

Soporte Técnico: (598) (2) 908-0998/1998

Atención a Clientes: (598) (2) 916-4445

Atención a Canal: (598) (2) 916-4446

Venezuela

Microsoft Venezuela S.A.

Teléfono: (58) (2) 276-0500

Fax: (58) (2) 276-0600

Soporte Técnico: (58) (2) 993-6755

Atención al Cliente: (58) (2) 800-MSVEN (800-67836)

Correo Electronico para Atención al Cliente: msven@microsoft.com.ve

Correo Electronico para Soporte Técnico: vsoporte@microsoft.com.ve

Atencion al Canal: (58) (2) 800-MSCANAL (800-67226)

Correo Electronico para Atencion al Canal: daccess@microsoft.com.ve

Registro de Eventos: (58) (2) 237-5122


Nombre de la organización y código de personalización

Para optimizar el proceso de instalación y utilizar el IEAK, ya no necesita escribir su nombre ni el código de personalización durante la instalación y configuración. A partir del IEAK 6, únicamente necesitará aceptar el contrato de licencia y seleccionar su función durante la instalación.

Función
Elija la función que coincida con las tareas que desea realizar con el IEAK:
  • Proveedor de contenido o programador si proporciona contenido personalizado, vínculos y funcionalidad a los usuarios
  • Proveedor de servicios si proporciona servicios Internet a los usuarios.
  • Administrador corporativo si administra el software y los servicios Internet de una organización.

Importante

  • La función elegida debe coincidir con la indicada en el contrato de licencia.


Selección de idioma

Elija el idioma que desee en la lista Idioma de destino. Si el idioma que desea utilizar no aparece en la lista, salga del Asistente para personalizar Internet Explorer 6, inserte el CD del IEAK que contiene el idioma que desea utilizar y, después, reinicie el asistente.

Debe ejecutar el Asistente para personalizar Internet Explorer 6 una vez para cada paquete personalizado de Internet Explorer localizado que desee crear. Para mantener la configuración en varias versiones, especifique la misma carpeta de destino para cada versión. Las versiones localizadas se guardarán en carpetas diferentes dentro de la carpeta de destino.

Ejemplo

Por ejemplo, EN es la abreviatura de English (inglés) y DE es la abreviatura de Deutsch (alemán).

Si especifica C:\Cie\Build1\ como carpeta de destino, el paquete personalizado que contiene una versión descargable en idioma inglés de Internet Explorer se crea en la carpeta C:\Cie\Build1\Download\Win32\EN\

El paquete personalizado que contiene una versión descargable en idioma alemán de Internet Explorer se crea en la carpeta C:\Cie\Build1\Download\Win32\DE\

Notas

  • Los usuarios pueden instalar una versión de Internet Explorer que emplee un idioma diferente al utilizado en sus sistemas operativos.
  • La única designación de la plataforma en el IEAK 6 es "Win32". Para los clientes UNIX y Windows de 16 bits, utilice el IEAK 5.x.


Selección del medio

En esta pantalla se determina el tipo de medio que utilizará para distribuir el paquete.

Descarga
Seleccione esta opción con el fin de generar un paquete para descargar a través de una intranet o de Internet. Puede crear sus paquetes personalizados en su disco duro y moverlos después a un servidor de Internet o bien, si es administrador corporativo, a un servidor de intranet. También puede generar los paquetes directamente en el servidor; para ello, especifique la ruta de acceso del servidor como carpeta de destino. Para obtener más información, consulte Ubicaciones de archivos.
CD-ROM
Cuando crea una versión en CD-ROM, también puede especificar la información de ejecución automática. Esta opción agrupa el paquete personalizado en un conjunto de carpetas y permite utilizar el programa de ejecución automática, que muestra la pantalla que verán los usuarios al insertar el CD-ROM en sus equipos.
Simple (todos los archivos en un directorio)
Si genera los paquetes en una red de área local o si va a moverlos a una, debe seleccionar esta opción para colocar todos los archivos necesarios en una carpeta situada bajo la carpeta de destino, por ejemplo, C:\Cie\Lan\.
Un disco único con marca personalizada
Seleccione esta opción para personalizar una instalación existente de Internet Explorer versiones 4.01 Service Pack 1, incluido con Windows 98, y posteriores. Esta opción crea un el archivo Setup.exe en la carpeta BrndOnly de la ubicación de su compilación. Puede distribuir este archivo en cualquier medio o servidor. Al ejecutar este archivo, se personalizan las características de Internet Explorer, incluida la suscripción a Internet con un ISP, sin instalar Internet Explorer. No es posible incluir componentes personalizados ni perfiles del Connection Manager en un paquete con marca en un único disco, ya que el tamaño del paquete superaría la capacidad del disco.

Importante

  • Si está utilizando la marca en un único disco y algunos de los usuarios tienen Internet Explorer 4.01 Service Pack 1 o versiones anteriores, no utilice el modo de suscripción con servidor del Asistente para la conexión a Internet en la página Método de suscripción. En lugar de ello, cree un paquete independiente utilizando la suscripción con servidor en modo a pantalla completa para estos usuarios.


Ubicaciones de archivos

Puede cambiar la carpeta de destino, en la que se crea el paquete IEAK, y la carpeta en la que se descargan los componentes.

Carpeta de destino
En la carpeta de destino se colocarán los paquetes personalizados cuando termine el asistente. Puede crear el paquete en el disco duro y moverlo después a un servidor de Internet o de intranet, o bien, directamente en un servidor Web.

En la carpeta de destino que especifique para cada sistema operativo y medio de distribución, se crean subcarpetas para cada versión traducida.

Si está creando el paquete en su disco duro o en una unidad de red, el destino recomendado es C:\Cie\Dist\. Si está creando el paquete en un servidor Web que se ejecuta desde su disco duro, utilice la ruta de acceso al servidor Web como destino.

Nota

  • Para ver un ejemplo, consulte Cómo configurar los archivos para distribución.

Ejemplo: ubicación de la carpeta de destino

Por ejemplo, si especifica la carpeta de destino como C:\Inetpub\Wwwroot\Cie\Dist, la versión en idioma inglés para las plataformas de Windows se crea como C:\Inetpub\Wwwroot\Cie\Dist\Download\Win32\En\.

Opciones avanzadas
Para personalizar la ubicación y el proceso de descarga de archivos, o para importar opciones de configuración desde un archivo .ins existente, haga clic en Opciones avanzadas.
Compruebe los componentes más recientes mediante la Sincronización automática de versiones
A medida que crea el paquete de Internet Explorer, el Asistente para personalizar Internet Explorer 6 puede conectarse a los servidores de Microsoft para detectar si hay nuevos componentes, actualizaciones de seguridad o versiones actualizadas de componentes existentes disponibles desde la última vez que ejecutó el citado asistente.

Si ha descargado el IEAK desde Internet, debe ejecutar el Asistente para personalizar Internet Explorer 6 con la Sincronización automática de versión (AVS) al menos una vez, para comprobar si hay versiones actualizadas de los componentes.

Nota

  • Si desactiva esta casilla de verificación, continúa utilizando el asistente y, posteriormente, decide que desea seleccionar esta característica AVS, observará que la casilla de verificación aparece en gris. Deberá cerrar el Asistente para personalizar Internet Explorer 6 e iniciarlo de nuevo para que esta casilla de verificación esté disponible.
Ruta de acceso del archivo .INS para importar la configuración
Para importar opciones de configuración de un archivo .ins existente como primer paso para crear un nuevo paquete IEAK, escriba la ruta de acceso completa. Al importar la configuración puede ahorrar tiempo si el nuevo paquete tiene una configuración similar a la importada. Sin embargo, puede cambiar todas las opciones de configuración que desee.
Carpeta de descarga de componentes
Los componentes y archivos de instalación que descargue se guardarán en la carpeta que especifique. La característica AVS examina automáticamente esa carpeta para determinar si están disponibles las versiones más recientes de los componentes. Con AVS, sólo se descargan los componentes que han cambiado desde la última vez que se descargaron. Es aconsejable que no cambie de carpeta, para mantener sincronizados los componentes.

Sólo debe cambiar esta carpeta si piensa conservar los archivos que descargó la última vez que ejecutó el asistente, aunque desee descargar un nuevo conjunto de componentes a una ubicación diferente.


Selección de características

Seleccione las características que desee personalizar. Éstas determinarán qué pantallas del asistente aparecen. Por ejemplo, si va a personalizar únicamente vínculos y direcciones URL, puede desactivar el resto de casillas de verificación para centrarse únicamente en esa personalización. Estas opciones le permitirán crear su paquete personalizado de una forma rápida y sencilla, ya que el Asistente para personalizar Internet Explorer 6 sólo mostrará las pantallas que necesite.

Nota

  • Haga clic en Activar todo para indicar rápidamente que está personalizando todas las características. Haga clic en Desactivar todo para indicar rápidamente que no está personalizando ninguna de las características enumeradas.

Para utilizar la configuración de un paquete IEAK creado previamente como base de este paquete, vuelva a la pantalla Ubicaciones de archivos y haga clic en el botón Opciones avanzadas para importar un archivo .ins. Mientras crea el nuevo paquete puede cambiar cualquiera de las configuraciones importadas.


Fase 1. Introducción: recopilar información

titular

Fase 1: recopilar información

En esta fase del Asistente para personalizar Internet Explorer 6, se le pedirán los datos básicos, como el idioma del paquete que va a crear y las características que desea personalizar.

Las opciones disponibles dependerán de su función como

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo

Nota

  • El Asistente para personalizar Internet Explorer 6 no funcionará correctamente si no está instalado Internet Explorer 6. Para obtener más información, consulte Requisitos de hardware y del sistema.


Sincronización automática de versiones

titular

Sincronización automática de versiones (AVS)

En esta fase del Asistente para personalizar Internet Explorer 6, los archivos de instalación para Internet Explorer y otros componentes se descargan a su equipo desde la ubicación de descarga especificada.

Si la versión de un componente en el equipo coincide con la que se incluye en el producto de Internet Explorer, se le solicita que mantenga la versión que ya se encuentra en su equipo. Para descargar componentes es posible que tenga que desactivar temporalmente los programas de detección de virus; si fuera necesario, aparecerá un mensaje que lo indica.

Es aconsejable conservar una copia de estos archivos en el disco duro, lo que le permitirá volver a crear el paquete fácilmente. Cuando vuelva a crear el paquete, haga clic en el botón Actualizaciones para comprobar si hay versiones más recientes de estos programas.

Componentes de Microsoft
Descargue las versiones más recientes de cualquiera de los componentes de Microsoft que se muestran en el cuadro. El estado de cada componente en su equipo se indica de la manera siguiente:
Símbolo | Significado
punto rojo | Este componente no está en la carpeta de descargas del equipo.
signo de admiración amarillo | La versión de este componente en la carpeta de descargas del equipo es anterior a la versión incluida en el nuevo producto de Internet Explorer, o ha deshabilitado AVS (en la Fase 1 del asistente).
marca de verificación verde | La versión de este componente coincide con la versión del producto de Internet Explorer.
flecha azul | Microsoft ha actualizado este componente desde el lanzamiento del producto de Internet Explorer y la versión actualizada se encuentra presente en la carpeta de descargas de su equipo.
estrella morada | Este componente es nuevo, no se incluía en la versión original de Internet Explorer.
Actualizaciones
Haga clic en Actualizaciones para comprobar si Microsoft ha actualizado algún componente de Internet desde que se lanzó Internet Explorer, o si hay algún componente nuevo de Internet disponible.

Por ejemplo, en el cuadro de diálogo Actualizaciones puede encontrar un único componente que contiene todos los parches de seguridad de Internet Explorer lanzados hasta la fecha.

Cualquier componente que seleccione en el cuadro de diálogo Actualizaciones se descarga a su equipo y se incluye en la lista en esta página del asistente.

Este botón no se encuentra disponible si ha deshabilitado AVS anteriormente.

Para obtener más información, consulte Actualizaciones de Sincronización automática de versiones (AVS).

Importante

  • Después de actualizar un componente a una nueva versión de ese componente, no puede regresar fácilmente a la versión anterior.
Sincronizar
Para descargar uno o más componentes, seleccione todos los componentes que desee y, después, haga clic en Sincronizar.

Notas

  • Para seleccionar elementos consecutivos, presione la tecla MAYÚS y manténgala presionada mientras hace clic en el último elemento.
  • Para seleccionar elementos no consecutivos, presione la tecla CTRL y manténgala presionada mientras hace clic en cada elemento.
Sincronizar todo
Para descargar todos los componentes disponibles, haga clic en Sincronizar todo.

Cuando haga clic en Sincronizar o en Sincronizar todo, se descarga la versión más reciente del producto de Internet Explorer. Esta sincronización no afecta a ningún componente nuevo o actualizado que haya descargado previamente del cuadro de diálogo Actualizaciones.

Espacio de disco
Especifica la cantidad de espacio de disco necesaria para los componentes seleccionados. Si no hay seleccionado ningún componente, especifica la cantidad de espacio de disco necesaria para todos los componentes de la lista.

Para regresar a la versión de un componente incluida en el lanzamiento del producto

  1. Haga clic en Cancelar para salir del Asistente para personalizar Internet Explorer 6.
  2. Reinicie el asistente.
  3. En la página Ubicaciones de archivos del asistente, haga clic en Opciones avanzadas.
  4. En el cuadro de diálogo Opciones avanzadas, cambie la carpeta Descarga de componentes a una ubicación diferente.
  5. Prosiga con el asistente.

Obtener archivos de Windows Update

En ocasiones, en el sitio Web de Windows Update podrá encontrar versiones más recientes de algunos componentes y revisiones de software. Sin embargo, si desea incluir en el paquete otros componentes de Windows Update, debe agrupar los archivos asociados en un componente personalizado. Por el contrario, los componentes descargados mediante AVS que incluya en su paquete se instalarán automáticamente mediante el Programa de instalación de Windows Update. Para obtener más información, consulte Empaquetar actualizaciones de Microsoft en componentes personalizados.

Para obtener información acerca de las actualizaciones más recientes de los productos, visite el sitio Web Corporate Windows Update.

Notas

  • Si ha desactivado la casilla de verificación Busque los componentes más recientes mediante la Sincronización automática de versiones del cuadro de diálogo Opciones avanzadas en la Fase 1 de este asistente (consulte Ubicaciones de archivos), el Asistente para personalizar Internet Explorer 6 no podrá comprobar si dispone de la versión más reciente de los componentes. Los iconos no serán verdes, aunque tenga la versión más reciente. Para los componentes que ya ha descargado, los iconos son amarillos. Para los componentes que no haya descargado, los iconos son rojos. Además, si ha deshabilitado la sincronización de versiones, no podrá descargar determinados componentes en esta fase del asistente.
  • IESetup.cif incluye automáticamente cualquier componente nuevo o actualizado que descargue utilizando las actualizaciones de Sincronización automática de versiones.
  • Para obtener información acerca de componentes y sus cadenas IdComponente asociadas, consulte el sitio Web de IEAK .
  • Para ver un ejemplo del sistema AVS, consulte Sincronización automática de versiones.


Sitio de descarga de Microsoft

Deberá seleccionar una ubicación para descargar los últimos programas y herramientas de Microsoft.

Sitio de descarga de Microsoft
Elija el sitio desde el que descargará la versión más reciente de Internet Explorer y herramientas de Internet, y haga clic en Siguiente para ver la página Sincronización automática de versiones en el Asistente para personalizar Internet Explorer 6.


Actualizaciones de Sincronización automática de versiones

Puede comprobar si Microsoft ha actualizado algún componente de Internet desde que se lanzó Internet Explorer, o si ahora hay algún componente nuevo de Internet disponible. Por ejemplo, en esta ubicación puede encontrar un único componente que contiene todos los parches de seguridad de Internet Explorer lanzados hasta la fecha.

Para abrir este cuadro de diálogo, haga clic en Actualizaciones en la página Sincronización automática de versiones del asistente. Este cuadro de diálogo no aparece si no hay ningún componente actualizado disponible para su descarga.

Componentes de Microsoft
Descargue las versiones más recientes de cualquiera de los componentes de Microsoft que se muestran en el cuadro. El estado de cada componente en el servidor se indica de la manera siguiente:
Símbolo | Significado
X roja | Microsoft ha actualizado este componente desde el lanzamiento del producto de Internet Explorer.
X roja | Este componente es nuevo, no se incluía en la versión original de Internet Explorer.
Seleccionar todo
Para seleccionar todos los elementos de la lista, haga clic en Seleccionar todo. Puede seleccionar un único componente con el mouse (ratón).

Notas

  • Para seleccionar elementos consecutivos, presione la tecla MAYÚS y manténgala presionada mientras hace clic en el último elemento.
  • Para seleccionar elementos no consecutivos, presione la tecla CTRL y manténgala presionada mientras hace clic en cada elemento.
Espacio de disco
Especifica la cantidad de espacio de disco necesaria para todos los componentes de la lista.
Sincronizar
Seleccione los componentes que desea descargar al equipo y, a continuación, haga clic en Suscribir. Esta acción cierra el cuadro de diálogo, descarga los componentes seleccionados al equipo y agrega los componentes a la lista de la página Sincronización automática de versiones (AVS) del asistente.

Este botón no se encuentra disponible si no ha seleccionado ningún componente de la lista.

Obtener archivos mediante Windows Update

En ocasiones, en el sitio Web de Windows Update podrá encontrar versiones más recientes de algunos componentes y revisiones de software. Sin embargo, si desea incluir en el paquete otros componentes de Windows Update, debe agrupar los archivos asociados en un componente personalizado. Por el contrario, los componentes descargados mediante AVS que incluya en su paquete se instalarán automáticamente mediante el Programa de instalación de Windows Update. Para obtener más información, consulte Empaquetar actualizaciones de Microsoft en componentes personalizados.

Para obtener información acerca de las actualizaciones más recientes de los productos, visite sitio Web Corporate Windows Update.

Notas

  • IESetup.cif incluye automáticamente cualquier componente nuevo o actualizado que haya descargado utilizando las actualizaciones de sincronización automática de versiones.
  • Para obtener información acerca de componentes y sus cadenas IdComponente asociadas, consulte el sitio Web de IEAK .
  • Para ver un ejemplo del sistema AVS, consulte Sincronización automática de versiones.


Agregar componentes personalizados

Es posible agregar 16 componentes personalizados como máximo, que los usuarios pueden instalar al mismo tiempo que el explorador. Estos componentes pueden ser archivos contenedores (.cab) comprimidos o archivos ejecutables (.exe) de extracción automática. Puede especificar la versión de un componente de Microsoft para que lo instalen los usuarios, así como instalar la última versión disponible mediante la Sincronización automática de versiones (AVS).

Se aconseja que firme cualquier código personalizado que vaya a descargar a través de Internet. La firma del código permite a los usuarios saber que pueden confiar en él antes de descargarlo en sus equipos. Con la configuración predeterminada de Internet Explorer se rechazará el código sin firmar.

Algunas de las opciones siguientes no están disponibles en todos los sistemas operativos.

Datos de identificación

Componente
Escriba en este cuadro el nombre del componente. Este nombre aparecerá en la pantalla de instalación cuando los usuarios instalen el software.
Ubicación
Escriba la ruta de acceso de su programa o haga clic en Examinar para buscarlo.
Comando
Si especifica un archivo .cab, también debe especificar el comando que se debe ejecutar para extraerlo.
GUID
El identificador único global (GUID) establece una identidad exclusiva para los programas, objetos y otros elementos. Si el programa ya tiene un GUID, escríbalo en este cuadro. Si el programa no tiene GUID, se generará automáticamente.
Descripción
Escriba 511 caracteres como máximo para describir el componente. Este texto aparecerá en el programa de instalación cuando el usuario señale al componente.
Parámetro
Puede especificar los modificadores con que se ejecutará el programa personalizado. Por ejemplo, puede que desee instalar el programa de forma "silenciosa", con pocas o ninguna pregunta, para que no se pida al usuario ninguna información del programa ni de Internet Explorer. Para excluir específicamente las preguntas que hace el programa de instalación, use el modificador /Q:A.
Clave de desinstalación
El programa de instalación de Windows Update compara este valor con HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\Nombre de aplicación para comprobar que el componente se ha instalado correctamente.

Para obtener más información, consulte Desinstalar un componente personalizado.

Versión
Escriba el número de serie que desee asignar al paquete personalizado de Internet Explorer que esté creando. El formato correcto para este número de versión es xxx,xxxx,xxxx,xxxx. La versión es un número y no incluye caracteres alfabéticos.
Agregar
Haga clic en Agregar para vaciar los campos y agregar un nuevo componente personalizado.
Quitar
Haga clic en Quitar para eliminar el componente actual del paquete personalizado.
Examinar
Haga clic en Examinar para cambiar la ubicación del componente personalizado.
Comprobar
Normalmente, los programas instalados a través de Internet requieren una firma digital que identifique su origen y garantice que el código no se ha cambiado desde que se firmó. En función de la configuración de seguridad del explorador, los usuarios pueden recibir una advertencia antes de que se descargue el programa. Las entidades emisoras de certificados pueden proporcionar las claves públicas y privadas necesarias para firmar el código. Para averiguar si un programa se ha firmado digitalmente, haga clic en Comprobar. Si firma el resto de los archivos al ejecutar el Asistente para personalizar Internet Explorer 6, este componente se firmará también con ese certificado.

Para obtener más información acerca de cómo firmar el código, visite el sitio Web Microsoft Security Advisor.

Condiciones de instalación

Instalar antes de Internet Explorer
Use esta opción si necesita instalar un componente personalizado antes de instalar Internet Explorer (por ejemplo, para ejecutar un archivo por lotes y establecer la configuración del usuario).
Instalar después de Internet Explorer
Use esta opción si desea instalar una o más revisiones de software de Internet Explorer (QFE) o una versión diferente de un componente incluido en el paquete básico de Internet Explorer descargado mediante AVS.

Nota

  • Si elige una versión diferente de un componente básico de Internet Explorer (como DirectAnimation o NetMeeting) y empaqueta los archivos en un componente personalizado, aumentará el tiempo de descarga para los usuarios ya que, de hecho, estarán descargando el mismo subconjunto de archivos dos veces.
Instalar después de reiniciar el sistema
Use esta opción si su componente personalizado contiene Service Packs del sistema o actualizaciones para la Máquina virtual de Java de Microsoft (VM).
Instalar sólo si Internet Explorer se instaló correctamente
No se instala este componente a menos que Internet Explorer esté instalado en los equipos de los usuarios.

Notas

  • El IEAK incluye herramientas para crear secuencias de comandos de IExpress. Para obtener otras herramientas, visite el sitio MSDN Online Web Workshop.
  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado y de la instalación de un componente personalizado, consulte Cómo funciona la personalización.


Fase 2 Introducción: especificar los parámetros de instalación

titular

Fase 2: especificar los parámetros de instalación

En esta fase del Asistente para personalizar Internet Explorer 6, debe especificar qué componentes desea incluir en el paquete personalizado.

Las opciones disponibles dependerán de su función:

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo


Personalizar la instalación

Puede personalizar la apariencia con la que se muestra a los usuarios el programa de instalación de Windows Update. Puede cambiar la barra de título y el gráfico que aparece cuando los usuarios instalan el paquete personalizado. Si proporciona un grupo de componentes personalizados, puede asignarles un nombre.

Texto de la barra de título del asistente para la instalación
Este texto aparece en la barra de título del Asistente para la instalación que ejecuten los usuarios. Este texto no aparece en la barra de título del explorador personalizado. Más adelante, en el Asistente para personalizar Internet Explorer 6, puede personalizar el título del explorador.
Ruta de acceso al mapa de bits de la izquierda del Asistente para la instalación (primera página)
Es el gráfico de 162 x 312 píxeles que la organización crea para la primera página del Asistente para la instalación. Este gráfico personaliza la apariencia del Asistente para la instalación del paquete personalizado. Debe evitar el uso de gráficos con líneas y patrones complejos.
Ruta de acceso del mapa de bits del título superior del Asistente para la instalación (todas las páginas excepto la primera)
Se trata del gráfico de 496 x 56 píxeles que aparece tras algunas instrucciones de instalación. Deberá utilizar un mapa de bits que no interfiera con la legibilidad.
Título de la instalación de componentes personalizados
Puede instalar los componentes personalizados al instalar el explorador personalizado. Si ha especificado más de un componente personalizado, puede asignarles un nombre de grupo; por ejemplo, podría tener un grupo de componentes denominado Programas del departamento de almacén de la compañía cafetera El Volcán. Este nombre aparecerá en el Asistente para la instalación de Windows Update cuando los usuarios instalen el paquete personalizado. Escriba el título que desea que aparezca.

Nota

  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado y de la instalación de un componente personalizado, consulte Cómo funciona la personalización.


Personalización del Connection Manager

El Kit de administración del Connection Manager (CMAK) es una herramienta que se emplea para configurar y administrar la forma en que se conectan los usuarios a Internet o a una red privada corporativa. Con el CMAK puede cambiar la apariencia y la configuración del marcador del Connection Manager de Microsoft mediante iconos personalizados, archivos de Ayuda adaptados y gráficos animados.

CMAK no se incluye en el IEAK 6. CMAK se encuentra disponible en Windows 2000 Server y en Windows 2000 y Windows XP Administration Pack; hay una versión anterior de CMAK disponible en la versión 5.0 del IEAK.

Si ya ha creado un perfil personal a través de CMAK, puede importarlo al paquete de instalación con el Asistente para personalizar Internet Explorer 6.

Utilizar el perfil personalizado especificado
Si ya ha creado un perfil de CMAK personalizado, escriba la ruta de acceso del perfil que desea utilizar con este paquete del explorador. El perfil especifica el contenido personalizado y los métodos de conexión. Los archivos de CMAK incluyen archivos .cmp y .cms. Las personalizaciones del proveedor de servicios se encuentran en el archivo .cms.

Notas

  • El CMAK crea un archivo ejecutable de extracción automática (*.exe) que se instala a sí mismo en los equipos de los usuarios. Cuando un usuario hace clic en el icono personalizado para conectarse a Internet, aparece el cuadro de diálogo personalizado del marcador que creó anteriormente.
  • No es necesario firmar digitalmente el archivo .exe creado por el CMAK antes de incluirlo en el IEAK. Al firmar los archivos del IEAK, se firma también el archivo del CMAK.

Para obtener más información, consulte la Ayuda en pantalla del Kit de administración del Connection Manager.


Experiencia del usuario

titular

Experiencia del usuario durante la instalación

Puede determinar con precisión la experiencia del usuario durante la Instalación de Windows Update.

Instalación interactiva
Los usuarios pueden elegir el tipo de instalación, el sitio de descarga y la carpeta de instalación cuando instalan el paquete personalizado de Internet Explorer. Todos los diálogos del desarrollo del proceso y mensajes de error aparecen durante la instalación.
Instalación no interactiva
Si desea tomar todas las decisiones de instalación en lugar de los usuarios y mantenerles informados del desarrollo y los errores de la instalación, haga clic en Instalación no interactiva.
Instalación totalmente silenciosa
Si desea que los usuarios instalen el explorador personalizado sin que se les muestre ningún cuadro de diálogo o indicación del desarrollo del proceso en pantalla, haga clic en Instalación totalmente silenciosa. Esta opción equivale a instalar Internet Explorer con el modificador /Q:A.

Notas

  • En una instalación silenciosa sólo puede especificar una opción de instalación y un sitio de descarga para sus usuarios.
  • Para ajustar con mayor precisión la instalación, puede usar los modificadores adicionales Instalación por lotes de Internet Explorer e Instalación por lotes de IExpress.

¿Qué experimenta el usuario durante una instalación totalmente silenciosa o no interactiva?

Una instalación silenciosa (no interactiva o totalmente silenciosa) realiza las operaciones siguientes:

  • Responde a las preguntas de forma que pueda continuar el programa de instalación.
  • Acepta el contrato de licencia.
  • Especifica que Internet Explorer se instalará y no sólo se realizará su descarga.
  • Lleva a cabo el tipo de instalación (por ejemplo, Estándar o personalizado) especificado para este paquete de instalación.
  • Instala Internet Explorer en el lugar especificado, a menos que ya esté instalado. En ese caso, la nueva versión del explorador se instala en la misma ubicación que la versión anterior.
  • Conecta con el primer sitio de descarga especificado para este paquete.

Ninguno de estos modos es interactivo, por lo que los usuarios no tienen control sobre el proceso de instalación de Windows Update. Si una instalación totalmente silenciosa no se completa correctamente, los usuarios no ven ningún mensaje de error. Puede utilizar esta característica en instalaciones que se implementen en ausencia del usuario.

Derechos de usuario

El modelo de seguridad de Windows NT, Windows 2000 y Windows XP puede impedir que los usuarios instalen software en sus sistemas. Para registrar archivos de sistema importantes, es preciso tener privilegios de administrador durante la instalación del software y después de reiniciar el sistema. Este requisito complica la implementación de nuevas versiones de Internet Explorer en sistemas en los que usuarios sin privilegios de administrador inician una sesión después de la instalación del paquete.

Habilitar inicio de sesión tras reiniciar con acceso de nivel de usuario
Seleccione esta casilla de verificación para personalizar el paquete de modo que se retenga el acceso a nivel de administrador después de reiniciar el equipo. Una vez que el equipo se reinicie y el usuario inicie la sesión, el componente Windows Installer completará el registro de los archivos de sistema de Internet Explorer. Después puede distribuir el paquete a los usuarios manualmente o como parte de un método de distribución automatizado como Systems Management Server (SMS). En cualquier caso, no es necesario que los usuarios tengan derechos de administrador la próxima vez que inicien una sesión en el sistema.

No necesita derechos de administrador para instalar un paquete IEAK en equipos con Windows 95, Windows 98 o Windows Millennium Edition, ya que el sistema operativo no administra el registro de archivos en dichos sistemas.

Cuando este paquete se instale en cualquier cliente SMS, el componente generará un archivo de estado .mif. SMS lo usará para comprobar si el paquete se ha instalado correctamente.

Importante

  • Si selecciona esta opción, compruebe que el formato del medio para el paquete es simple, con todos los archivos en una carpeta.
  • Para poder usar esta opción, debe asegurarse de que ninguna otra instalación de Windows Installer se ejecutará cuando el usuario instale el paquete.
  • No utilice este método cuando Internet Explorer sea un componente de otra instalación de Windows Installer, como Microsoft Office.
  • Si selecciona esta opción, pruebe completamente las interacciones potenciales antes de distribuir este paquete a los usuarios.
  • Derechos de usuario únicamente aparece si ha seleccionado el método de distribución Simple en la página Selección del medio en el paso 1 del asistente.


Opciones de instalación

Puede especificar hasta diez opciones de instalación, como son la instalación estándar o la instalación personalizada, y determinar el explorador y los componentes personalizados que se instalarán en cada modo. Si es administrador corporativo y ha especificado una instalación silenciosa para este paquete, sólo puede especificar una única opción (modo) de instalación.

Importante

  • Independientemente de las opciones de instalación configuradas para el paquete, el programa de instalación de Windows Update sólo presenta una opción de instalación a los usuarios que ejecuten el sistema operativo Windows 2000 y Windows XP. Esta opción incluye todos los componentes de Internet de Microsoft Internet Explorer, además de los componentes personalizados incluidos en el paquete.
Opción
Seleccione la opción de instalación predeterminada que desee o haga clic en Nueva para crear una nueva opción de instalación. Escriba la descripción de la opción y haga clic en las flechas para agregar o quitar los componentes que desee.

Si es un ISP, puede crear una opción de instalación para un grupo específico de clientes. Si es un administrador corporativo, puede especificar opciones de instalación para diferentes sucursales de su empresa.

Descripción
Escriba la descripción de la opción de instalación, como la lista de componentes y programas instalados. Este texto aparece en el Asistente para la instalación de Windows Update que verán los usuarios.

Nota

  • Para crear un carácter de subrayado en el texto de la descripción, escriba un signo &. Para crear un signo “y” comercial (&) escriba dos signos &.
Componentes disponibles
La lista de componentes disponibles incluye los componentes de Internet Explorer que ha descargado y los componentes personalizados que haya definido. Para agregar componentes a esta lista, vuelva a la Fase 2 del Asistente para personalizar Internet Explorer 6.
Componentes para instalar
Esta lista muestra los componentes que se instalarán con la opción que aparece en el cuadro Opción. Haga clic en las flechas simples para agregar o quitar un único componente, o haga clic en las flechas dobles para agregar o quitar todos los componentes disponibles.

Notas

  • Para ver un ejemplo de cómo aplicar marcas a un explorador personalizado y de la instalación de un componente específico, consulte Cómo funciona la personalización.


Sitios de descarga de componentes

Debe especificar como mínimo uno pero no más de 10 sitios de descarga desde los cuales los usuarios pueden descargar el paquete. Cada sitio debe utilizar un servidor HTTP o FTP. Además, debe colocar todos los componentes de Microsoft y los componentes personalizados en cada sitio.

Nombre del sitio
Escriba el nombre de su sitio. Puede especificar un nombre descriptivo que ayude a identificar el sitio. No utilice comas en el nombre.
Dirección URL del sitio
Escriba la dirección URL de su sitio. Se agregará o actualizará el archivo IE6Sites.dat y se agregará a la dirección URL la subcarpeta del idioma del paquete, por ejemplo, EN para inglés.
Región del sitio
Escriba la región donde se encuentra el sitio, como la ciudad, estado, región del país o país.
Sitios de descarga personalizados
Los sitios que agrega en esta página del Asistente para personalizar Internet Explorer 6 se enumeran en la siguiente columna.

Notas

  • Si es administrador corporativo y ha especificado una instalación silenciosa para este paquete, sólo puede especificar un único sitio de descarga.
  • Para ver un ejemplo, consulte Cómo configurar archivos para distribución e Instalación de Windows Update para Internet Explorer y otras herramientas para Internet.

Qué hacer cuando la dirección URL del primer sitio no funciona

Si el primer sitio está inactivo, como resultado de problemas en el servidor, por ejemplo, el programa de instalación no podrá encontrar los sitios restantes de forma predeterminada. Una posible solución sería sobrescribir el primer sitio con el comando siguiente:

<ruta de acceso>\IE6Setup.exe /C:"ie6wzd.exe /S:""<ruta de acceso>\IE6Setup.exe"" /L:""http://mi servidor Web /mi sitio Web /IE6sites.dat"""

<ruta de acceso> es la carpeta en la que se encuentra el archivo IE6Setup.exe.

Ejemplo

A continuación se incluye un ejemplo de la sintaxis que debe proporcionarse a los usuarios cuando el primer sitio esté inactivo. Se trata de una línea de comandos única que se presenta en varias líneas de texto, lo que mejora su legibilidad.

C:\IE6Setup.exe /C:"IE6wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\IE6Setup.exe""
/L:""http://<direcciónNuevoServidor>/<suDirecciónDeDescarga>/IE6sites.dat """


Descarga de componentes

Cuando se dispone de una nueva versión de Internet Explorer, los usuarios pueden actualizarlo haciendo clic en el menú Herramientas y, después, en Windows Update. También pueden ver esta página si hacen clic en Agregar o quitar programas en el Panel de control, en Internet Explorer y Herramientas de Internet y, finalmente, en Agregar o quitar.

Quitar la opción Windows Update del menú Herramientas
Si ha hecho clic en esta opción, cuando sus usuarios instalen el paquete personalizado, la opción Windows Update no se incluye en el menú Herramientas. Para actualizar Internet Explorer, debe crear un nuevo paquete personalizado y distribuirlo a los usuarios.
Usar la dirección URL predeterminada para Windows Update
Si ha hecho clic en esta opción, los usuarios deberán hacer clic en Windows Update en el menú Herramientas para instalar nuevas versiones de Internet Explorer.

La ubicación predeterminada para obtener las actualizaciones del producto es el sitio desde el que los usuarios descargaron sus exploradores personalizados, aunque se puede especificar una ubicación de componentes adicionales personalizada.

Usar una dirección URL de complemento y un texto de menú
Puede personalizar el nombre de la opción en el menú Herramientas que descarga nuevas versiones de Internet Explorer. Si personaliza el nombre de la opción, también puede especificar la Dirección URL de la página de los componentes de los complementos.
Texto de menú para la dirección URL de los componentes de los complementos
Escriba el texto que debería aparecer en el menú Herramientas en lugar de Windows Update. Los usuarios deberán hacer clic en esta opción de menú para instalar nuevas versiones del paquete personalizado.
Dirección URL de la página de los componentes de los complementos
Si desea que los usuarios obtengan actualizaciones de software (componentes de los complementos) desde otra ubicación, especifique una dirección URL distinta. Se trata de la ubicación de los componentes personalizados que los usuarios descargan cuando hacen clic en la opción de menú personalizada en el menú Herramientas.
Descargar componentes de Microsoft tras la instalación
Si activa esta casilla de verificación especifica que todos los componentes se descargan de los sitios de Microsoft después de la instalación del explorador, donde los usuarios pueden descargar componentes de los complementos.

Nota

  • El Id. de configuración y el número de versión que aparecían en esta pantalla en versiones anteriores de IEAK ya no son necesarios. Estos valores se generan ahora automáticamente. Las personalizaciones, o marcas, que genere con IEAK estarán siempre instaladas, independientemente del número de versión o el identificador de configuración.


Directorio de instalación

Si es administrador corporativo, puede especificar la ubicación en la que los usuarios instalarán Internet Explorer y el resto de los componentes de Internet. También puede determinar si los usuarios pueden elegir una carpeta de instalación diferente.

Para permitir que los usuarios cambien la ubicación, haga clic en Permitir que el usuario seleccione el directorio de instalación. Si activa esta casilla de verificación, la carpeta o ruta de acceso que especifique aparecerá como ubicación predeterminada.

Si hace clic en Instalar en la carpeta especificada dentro de la carpeta Windows o Instalar en la carpeta especificada dentro de la carpeta Archivos de programa, se instalará Internet Explorer en la subcarpeta mostrada en el cuadro.

Si hace clic en Especificar la ruta de acceso completa de una carpeta personalizada, podrá escribir la ruta de acceso que desee. Si la ruta de acceso no existe en el disco duro del usuario, se creará.

Nota

  • Si Internet Explorer ya está instalado en el equipo del usuario, la nueva versión se instalará sobre la existente. El explorador personalizado no se instalará en la ubicación personalizada que especificó.


Opciones de instalación corporativa

Puede determinar hasta qué punto los usuarios pueden personalizar la instalación de Windows Update.

Prohibir a los usuarios seleccionar la opción de instalación personalizada
Los usuarios de Internet Explorer instalan el paquete personalizado en su totalidad. No pueden utilizar la Instalación personalizada para instalar componentes individuales.
No guardar información de desinstalación
El programa de instalación de Windows Update guarda automáticamente la información de desinstalación. Para ahorrar espacio en disco, puede deshabilitar esta característica si activa la casilla de verificación. Sin embargo, los usuarios ya no podrán quitar Internet Explorer al hacer clic en el icono Agregar o quitar programas del Panel de control.
Prohibir a los usuarios instalar el modo de compatibilidad de Internet Explorer
Con la opción de compatibilidad de Internet Explorer, los usuarios pueden probar características de páginas Web de Internet Explorer 4 en el mismo equipo en el que está instalado Internet Explorer 5 y versiones posteriores. Para deshabilitar esta característica, active esta casilla de verificación.
Opciones del explorador predeterminado
Elija una de las opciones siguientes:
  • Configurar Internet Explorer como el explorador predeterminado
  • No configurar Internet Explorer como el explorador predeterminado
  • Permitir al usuario que elija

Notas

  • La opción Explorador predeterminado también determina si el Reproductor multimedia de Windows es el programa predeterminado para reproducir los archivos multimedia.
  • Si utiliza una instalación silenciosa o personaliza la distribución de Internet Explorer para Microsoft Office por medio del Asistente para la instalación personalizada de Office, durante el proceso de instalación no se mostrarán las opciones de usuario para Internet Explorer.


Actualización del escritorio de Windows

La actualización del escritorio de Windows hace que el escritorio y las carpetas tengan la misma apariencia y características que el Web. Aunque el programa de actualización del escritorio de Windows no forma parte de Internet Explorer 5 y versiones posteriores, puede incluirlo en el paquete de IEAK. Si los usuarios ejecutan Windows 98 o posterior, ya disfrutan de estas características en su escritorio.

Si opta por instalar la Actualización del escritorio de Windows, puede personalizar más tarde sus parámetros de configuración en el Asistente para personalizar Internet Explorer 6, siempre que el equipo donde se ejecute tenga una de las configuraciones siguientes:

  • Windows 98
  • Windows 98 Segunda edición
  • Windows Millennium Edition
  • Windows 2000
  • En otras versiones de Windows deberá utilizar Internet Explorer 6 con la Actualización del escritorio de Windows instalada.

La actualización puede ser muy útil a la hora de definir escritorios estándar para empresas.

¿Desea integrar la Actualización del escritorio de Windows en el paquete personalizado?
Para instalar la actualización del escritorio de Windows, haga clic en Sí. Si no desea instalarlo, haga clic en No.

Tema relacionado


Opciones de instalación avanzadas

Puede personalizar aún más el programa de instalación de Windows Update si hace que detecte la existencia de un componente y define con precisión qué componentes pueden agregar los usuarios cuando lo personalizan.

Optimizar para descargar de Web (no descargar si existe una versión compatible)
El programa de instalación puede detectar si la misma versión de un componente ya está instalada en el equipo del usuario. Si esa versión ya está instalada y funciona con Internet Explorer, el programa de instalación no descarga el componente. Esto puede reducir el tiempo de descarga para el usuario.

Nota

  • No optimice la descarga en el Web si desea instalar una versión específica de un componente que no sea el que se ha incluido en los archivos .cab de Internet Explorer descargados anteriormente con la Sincronización automática de versiones.
Impedir a los usuarios que personalicen el programa de instalación para componentes específicos
Si los usuarios pueden personalizar sus instalaciones, pero no desea que personalicen determinados componentes, desactive las casillas de verificación de esos componentes. En el programa de instalación de Windows Update, Forzar instalación aparece en la columna derecha al lado de los componentes que se instalarán automáticamente con el explorador.


Componentes en Medio

Los componentes de esta lista se han descargado en el equipo, pero no están incluidos en ninguno de los modos especificados para el programa de instalación de Windows Update. Si los usuarios intentan utilizar una característica que requiera estos componentes, podrán facilitarse para su instalación mediante la Instalación a petición.


Firmas digitales

Si dispone de un certificado de emisor de una entidad emisora de certificados u obtenido en Microsoft Certificate Server, puede firmar su paquete personalizado en esta fase del asistente.

Para preparar los certificados de forma que los utilice el IEAK, puede importarlos en el equipo mediante el Asistente para la importación del Administrador de certificados. Si ha recibido un archivo con la extensión .spc, puede iniciar el asistente haciendo doble clic en el archivo .spc en el Explorador de Windows o en Mi PC.

También puede abrir el Administrador de certificados desde Internet Explorer; para ello, haga clic sucesivamente en el menú Herramientas, Opciones de Internet, ficha Contenido y, después, en Certificados. Haga clic en Importar para iniciar el Asistente para importación del Administrador de certificados y, después, siga los pasos que se indican en el asistente.

Nombre de la organización en el certificado
Si en el equipo hay un certificado de editor, el nombre de su organización aparecerá en esta lista.
Archivo de Certificados de publicación de software (.spc)
Escriba el nombre del archivo .spc asociado al certificado o haga clic en Examinar para buscarlo.
Archivo de clave privada (.pvk)
Escriba el nombre del archivo .pvk asociado al certificado o haga clic en Examinar para buscarlo
Descripción
Escriba el texto que aparecerá en el cuadro de diálogo que se muestra cuando los usuarios descargan programas firmados con este certificado.
Más información (dirección URL)
Escriba la dirección URL en la que los usuarios pueden hacer clic para obtener información adicional acerca del certificado y la organización.
Dirección URL de marca de tiempo
Escriba la dirección URL donde los usuarios pueden hacer clic para confirmar la validez del certificado utilizando la fecha y hora de su emisión.


Personalizar la pantalla de ejecución automática del CD

Si está creando una versión en CD-ROM de su paquete personalizado, puede crear una pantalla de ejecución automática del CD que se mostrará cuando el usuario inserte el disco compacto en la unidad. La imagen debe ser un mapa de bits de 256 colores con 540 por 357 píxeles.

Si incluye una pantalla de ejecución automática del CD, puede proporcionar un mapa de bits de fondo y etiquetas para dos botones: uno para instalar Internet Explorer y otro para mostrar más información. También puede personalizar la barra de título y el color del texto.

Texto de la barra de título
Este texto aparece en la barra de título de la pantalla de ejecución automática.
Ubicación del mapa de bits personalizado de fondo
Puede suministrar un mapa de bits que aparezca detrás del texto. Compruebe que el color de fondo no entra en conflicto con el color del texto.
Color de texto estándar
Esta opción determina el color del texto que no forma parte de un vínculo.
Color de texto resaltado
Esta configuración determina el color de los vínculos de la página.
Estilo de botón
Puede determinar la apariencia de los botones en los que hacen clic los usuarios para instalar Internet Explorer y obtener más información.
  • Los botones estándar biselados son similares a los que aparecen en los programas estándar de software de Microsoft. Son botones grises y rectangulares.
  • Los botones con mapa de bits 3D tienen una apariencia tridimensional.
  • Un mapa de bits personalizado se basa en el mapa de bits que proporcione. Para encontrar la ruta de acceso del archivo de imagen, haga clic en Examinar.


Más opciones del CD

Puede personalizar aún más la instalación desde discos compactos si agrega un archivo de información (.inf), conocido en ocasiones como archivo "léame", e incluye una página Web especial que aparecerá después de la instalación.

Archivo de texto con más información
Especifique la ruta de acceso y el nombre del archivo que desea que vean los usuarios después de la instalación. De forma predeterminada, la pantalla de ejecución automática del CD incluye un vínculo a este archivo. Si cambia el nombre del archivo, tendrá que actualizar la ruta de acceso en la pantalla de ejecución automática.
Usar la página de inicio en pantalla completa
Active esta casilla de verificación para utilizar la ventana del explorador de Internet Explorer en pantalla completa.
Archivo HTML de la página de inicio en modo de pantalla completa
Especifique la ruta de acceso y el nombre del archivo .htm que desea que aparezca después de que el usuario haya instalado Internet Explorer. Esta página aparece en pantalla completa. Los gráficos asociados a esta página deben guardarse en la misma ubicación que el archivo .htm.


Fase 3 Introducción: personalizar la instalación

titular

Fase 3: personalizar la instalación

En esta fase del Asistente para personalizar Internet Explorer 6, puede especificar cómo va a personalizar el programa de instalación de Windows Update.

Las opciones disponibles dependerán de su función:

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo


Título del explorador

Puede personalizar el texto que aparece en las barras de título de Internet Explorer y Outlook Express. La barra de título de Outlook Express se actualiza tanto si incluye Outlook Express en su paquete como si ya está instalado en los equipos de los usuarios. Escriba el texto que desea que aparezca. Se agrega tras la frase "Microsoft Internet Explorer proporcionado por" o "Outlook Express proporcionado por".

Notas

  • Cuando seleccione un mapa de bits, asegúrese de que los colores contrastan con el texto. De este modo, los usuarios podrán leer mejor el texto.
  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.

Para personalizar las barras de título

  1. Active la casilla de verificación Personalizar barras de título.
  2. Escriba el texto que desea que aparezca en el cuadro Texto de la barra de título.


Personalizar la barra de herramientas

Puede personalizar la barra de herramientas que aparece en los exploradores de sus usuarios, lo que le permitirá aumentar su flexibilidad y modificar su diseño. Los elementos que puede modificar son el fondo de la barra de herramientas y la apariencia de los iconos de los botones estándar de la barra de herramientas, como Búsqueda e Historial.

Si desea personalizar aún más la barra de herramientas, puede cambiar la apariencia de los botones adicionales y su número. La capacidad de especificar la secuencia de comandos o el programa que ejecuta cada uno de estos botones permite controlar aún más la barra de herramientas incluida en su paquete personalizado. Para obtener mas información acerca de cómo diseñar programas personalizados, visite el sitio MSDN Online Web Workshop.

Fondo
Si no desea personalizar el fondo, haga clic en Usar el mapa de caracteres del fondo de la barra de herramientas predeterminada de Windows. Para personalizar el fondo, haga clic en Personalizar mapa de bits para el fondo de la barra de herramientas y, a continuación, indique el nombre y la ubicación del archivo de mapa de bits.
Botones
Si utiliza botones personalizados para la barra de herramientas, puede agregarles sus propios iconos, el archivo de secuencias de comandos o ejecutable asociado con cada botón y la ubicación de los archivos de los iconos de la barra de herramientas. Después de agregar los botones, siempre que lo desee puede volver a la página Personalización de la barra de herramientas del asistente para modificarlos o quitarlos.
Eliminar los botones existentes en la barra de herramientas, si los hay
Para eliminar todos los botones de la barra de herramientas del explorador del usuario, excepto los botones estándar que se instalan con Internet Explorer, active esta casilla de verificación. Esta opción sólo está disponible para administradores corporativos.

Notas

  • El fondo debe tener el tamaño de la barra de herramientas y ser suficientemente claro para mostrar texto de color negro.
  • Si habilita los temas en Windows, se omitirá el fondo personalizado de su barra de herramientas. Si desea utilizar un fondo personalizado para la barra de herramientas cambie al tema Windows clásico.
  • Al activar la casilla de verificación Eliminar los botones existentes en la barra de herramientas, si los hay sólo se eliminan los botones que se agregaron manualmente. Los botones estándar que se instalaron con Internet Explorer permanecen.

Para agregar un botón personalizado a la barra de herramientas

  1. Haga clic en Agregar.
  2. En el cuadro Título de la barra de herramientas (requerido), escriba el texto que debe aparecer cuando el usuario sitúa el cursor sobre la barra de herramientas. Debe especificar un título para la etiqueta del botón. El tamaño máximo recomendado es diez caracteres.
  3. En el cuadro Acción de la barra de herramientas: archivo de comandos o ejecutable (requerido), escriba el nombre del archivo de comandos o ejecutable, o haga clic en Examinar para buscarlo. Debe especificar el archivo de comandos o ejecutable que se inicia cuando el usuario hace clic en el botón de la barra de herramientas.
  4. En el cuadro Icono de colores de la barra de herramientas (requerido), escriba el nombre del archivo que representa el estado activo del botón, o haga clic en Examinar para buscarlo. Debe especificar el icono de colores para el botón que aparece en la barra de herramientas. El icono utiliza imágenes de 20 x 20 píxeles para los estados activo e inactivo. Para obtener mas información, visite el sitio MSDN Online Web Workshop.
  5. En el cuadro Icono de escala de grises de la barra de herramientas (requerido), escriba el nombre del archivo en escala de grises para la barra de tareas que aparece en monitores de blanco y negro, o haga clic en Examinar para buscarlo. Debe especificar el icono de escala de grises para el botón que aparece en la barra de herramientas.
  6. Active la casilla de verificación Mostrar el botón en la barra de herramientas de forma predeterminada para hacer que, de forma predeterminada, en el explorador del usuario se muestre el botón de la barra de herramientas que ha especificado.

Notas

  • Al indicar la ubicación de los mapas de bits, secuencias de comandos y aplicaciones, debe especificar la dirección y el nombre del archivo.
  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.

Para modificar un botón personalizado de la barra de herramientas

  1. En la lista de botones personalizados de la barra de herramientas, haga clic en el botón con el que desee trabajar. A continuación, haga clic en Modificar.
  2. Modifique la información que desee cambiar.

Para eliminar un botón personalizado de la barra de herramientas

  1. En la lista de botones de la barra de herramientas, haga clic en el elemento que desee eliminar.
  2. Haga clic en Quitar. El botón de la barra de herramientas se elimina de la lista inmediatamente. Cuando los usuarios instalen su paquete personalizado de Internet Explorer, el botón no estará disponible.


Logotipo y mapas de bits animados personalizados

El logotipo de Internet Explorer de la esquina superior derecha del explorador aparece en dos estados: estático cuando no se está llevando a cabo ninguna acción y animado cuando el explorador está en uso. Puede reemplazar los mapas de bits del logotipo con sus propios mapas de bits animados o estáticos.

Personalizar los logotipos estáticos

Si usa un mapa de bits estático, aparecerá sin animar tanto si se lleva a cabo alguna acción en el explorador como si no.

Si desea crear su propio logotipo estático, en primer lugar debe crear dos mapas de bits. Uno de ellos debe ser de 22 por 22 píxeles y el otro de 38 por 38 píxeles. A continuación, especifique la ruta de acceso a los logotipos en los cuadros de texto Mapa de bits (22x22) pequeño y Mapa de bits (38x38) grande.

Personalizar los logotipos animados

Si usa un mapa de bits animado, el primer marco aparecerá estático si no se lleva a cabo ninguna acción en el explorador. Los marcos restantes aparecerán animados cuando el explorador esté en uso.

Si desea crear su propio logotipo animado, en primer lugar debe crear dos mapas de bits animados. Uno de ellos debe ser de 22 por 22 píxeles y el otro de 38 por 38 píxeles. A continuación, especifique la ruta de acceso a los logotipos en los cuadros de texto Mapa de bits (22x22) pequeño y Mapa de bits (38x38) grande.

Encontrará ejemplos de mapas de bits animados en la carpeta \<Carpeta de programa de IEAK>\Toolkit\, en el kit de herramientas IEAK.

Notas

  • Con el IEAK se incluyen dos herramientas para ayudarle a crear mapas de bits animados personalizados para el explorador. Una de ellas se utiliza para apilar mapas de bits con el formato descrito anteriormente, mientras que la otra se utiliza para realizar una vista previa de la animación.
  • Para ver un ejemplo de cómo se aplican las marcas a su explorador personalizado, consulte Cómo funciona la personalización.


Direcciones URL importantes

Puede especificar las direcciones URL de las páginas principal, de búsqueda y de soporte en línea.

Dirección URL de la página principal
La página principal, conocida a veces como página de inicio, se muestra cuando el usuario hace clic en el botón Inicio. Internet Explorer puede mostrar una página principal predeterminada o usted puede especificar la dirección URL de su propia página.

Si desea personalizar la página principal, active la casilla de verificación Personalizar dirección URL de la página principal. Escriba la dirección URL de la página principal que desea usar en el cuadro Dirección URL de la página principal.

Dirección URL de la barra de búsqueda
La barras de búsqueda aparecen en el lado izquierdo de la ventana del explorador. La barra de búsqueda permite que el usuario vea la consulta de búsqueda y sus resultados al mismo tiempo. Incluye varios motores de búsqueda seleccionados. Si desea personalizar la dirección URL de la página de búsqueda, active la casilla de verificación Personalizar dirección URL de la barra de búsqueda. Después, escriba la dirección URL en el cuadro Dirección URL de la barra de búsqueda.
Dirección URL de la página de soporte en línea
En Internet Explorer se muestra información de soporte técnico cuando se hace clic en Ayuda y, después, en Soporte técnico en línea. Se recomienda que desarrolle una página de soporte técnico y la ponga a disposición de sus usuarios.

Si desea personalizar la página de soporte técnico, active la casilla de verificación Personalizar dirección URL de la página de soporte técnico. A continuación, escriba la dirección URL de su página de soporte técnico personalizada en el cuadro Dirección URL de la página de soporte técnico.


Favoritos y vínculos

Puede personalizar la carpeta Favoritos y la barra de vínculos si agrega vínculos a los sitios relacionados con su organización o servicios. Por ejemplo, si es proveedor de contenido Internet especializado en espectáculos, puede proporcionar vínculos a sitios relacionados con el mundo del espectáculo.

La barra de vínculos se muestra de forma predeterminada en la parte superior de la pantalla del usuario y proporciona una serie de vínculos predeterminados. Puede agregar vínculos a las carpetas predeterminadas o agregar carpetas nuevas. Cuando un usuario hace clic en Favoritos, la lista Favoritos aparece en el lado izquierdo de la ventana.

Colocar los Favoritos y vínculos en la parte superior de la lista en el siguiente orden
Active esta casilla de verificación para especificar que los favoritos y los vínculos que elija deben colocarse al principio de la lista Favoritos, para que sea más fácil que los encuentre el usuario. Al activar esta opción, estarán disponibles los botones Mover arriba y Mover abajo.
Eliminar los Favoritos y los Vínculos existentes, si los hay
Si es un administrador corporativo, puede activar esta casilla de verificación para eliminar todos los elementos de las listas Favoritos y Vínculos. Es aconsejable que utilice esta opción con precaución ya que quitará los vínculos y los favoritos que haya definido el usuario.
Eliminar solamente los favoritos creados por el administrador
Si es un administrador corporativo, puede activar esta casilla de verificación para eliminar todos los elementos de las listas Favoritos y Vínculos que configuró para los usuarios.
Eliminar canales existentes si los hubiera
Si es administrador corporativo, puede eliminar los canales existentes en los equipos de los usuarios si activa esta casilla de verificación.

Notas

  • Para probar un vínculo, haga clic en la dirección URL de la lista y, después, haga clic en Probar dirección URL.
  • Puede agregar 200 vínculos a la carpeta Favoritos.
  • Para quitar un elemento de la lista Favoritos o de la barra de vínculos, haga clic en el elemento y, después, haga clic en Quitar.
  • Para ver un ejemplo de cómo aplicar marcas y vínculos personalizados al explorador personalizado, consulte Cómo funciona la personalización.

Para agregar manualmente una carpeta a la lista Favoritos o a la barra Vínculos

  1. Haga clic en Favoritos, en Vínculos, o en una carpeta de Favoritos o Vínculos y, después, haga clic en Agregar carpeta.
  2. Escriba el nombre de la carpeta en el cuadro Nombre. Puede ser un nombre descriptivo que ayude a los usuarios a reconocer el tipo de vínculos que hay en la carpeta.

Para importar una carpeta de vínculos desde el equipo a la lista Favoritos o a la barra Vínculos

  1. Haga clic en Favoritos o Vínculos y, a continuación, haga clic en Importar.
  2. En el cuadro de diálogo Buscar carpeta, localice en el equipo la carpeta que contiene los vínculos que desea utilizar y haga clic en ella. La ubicación más probable de dichos vínculos es la carpeta \Windows\Favoritos.

Para agregar una página Web a la lista Favoritos o a la barra de vínculos

  1. Haga clic en Favoritos, en Vínculos o en una carpeta de Favoritos o Vínculos y, después, haga clic en Agregar dirección URL.
  2. En el cuadro Nombre del cuadro de diálogo Detalles, escriba un nombre para esta página Web. Puede ser un nombre descriptivo que ayude a los usuarios a reconocer a qué se refiere el vínculo.
  3. Escriba el destino del vínculo en el cuadro Dirección URL.
  4. Para especificar un icono personalizado de 16 por 16 píxeles para este vínculo, escriba el nombre del archivo de mapa de bits en el cuadro Icono o en Examinar si desea buscarlo.
  5. Si es un administrador corporativo, puede hacer que esta página esté a disposición de los usuarios que no estén conectados a Internet si activa la casilla de verificación Disponible sin conexión. Esta opción suele ser útil para usuarios con equipos portátiles.
  6. Haga clic en Aceptar para cerrar el cuadro de diálogo Detalles.


Página de bienvenida

Internet Explorer muestra una página de bienvenida la primera vez que un usuario inicia el explorador. Puede mostrar la página predeterminada de bienvenida de Internet Explorer 6 o especificar su propia página personalizada.

Mostrar la página de bienvenida predeterminada para Microsoft Internet Explorer 6
Seleccione esta opción para mostrar la página predeterminada de bienvenida de Microsoft Internet.
No mostrar página de bienvenida
Seleccione esta opción si no desea mostrar la página de bienvenida. La primera página que se mostrará es la página principal del usuario.
Usar una página de bienvenida personalizada (especificar la dirección URL)
Seleccione esta opción si desea utilizar una página de bienvenida personalizada y, después, escriba la dirección URL en el cuadro que hay más abajo.

Nota

  • Los usuarios no verán la página de bienvenida a menos que estén conectados a Internet o a una intranet.


Cadena de agente del usuario

Algunas organizaciones realizan un seguimiento de las estadísticas de los sitios, por ejemplo, del número de veces que se tiene acceso a su contenido y con qué tipo de explorador Web. Las cadenas de agente del usuario le ayudan a identificar el tipo de explorador.

Personalizar cadena que se anexará a la cadena de agente del usuario
Active esta casilla de verificación para personalizar la cadena de agente del usuario.
Cadena personalizada que se anexará a la cadena de agente del usuario
La cadena que escriba en este cuadro se anexará a la cadena de agente del usuario del explorador personalizado. No es necesario que personalice la cadena de agente del usuario a menos que desee realizar el seguimiento del uso de su explorador personalizado y obtener estadísticas del explorador de otros sitios de Internet. Tenga en cuenta que otras organizaciones que hagan el seguimiento de las estadísticas de sitios verán la cadena personalizada.


Configuración automática

Puede asignar direcciones URL a los archivos que configurarán automáticamente el explorador personalizado. Esta característica es útil si desea controlar la configuración de varios usuarios desde una ubicación central.

Igualmente, puede configurar opciones mediante archivos .ins, también conocidos como perfiles de IEAK. En estos archivos .ins puede incluir la configuración estándar de proxy. También puede especificar archivos de comandos con formato .js, .jvs o .pac que le permiten establecer y mantener la configuración de proxy avanzada.

Los servidores de red que utilicen el Sistema de nombres de dominio (DNS, Domain Name System) y el protocolo de configuración dinámica de host (DHCP, Dynamic Host Configuration Protocol) pueden detectar y configurar automáticamente la configuración del explorador cuando el usuario inicia el explorador por primera vez en una red. Para obtener más información, consulte Detección y configuración automática de las opciones del explorador.

Si especifica direcciones URL para la configuración automática y el proxy automático (autoproxy), se incorporará la dirección URL de autoproxy al archivo .ins. La forma correcta de la dirección URL es http://share/test.ins.

Para habilitar la configuración automática, active la casilla de verificación Habilitar la configuración automática. En el cuadro Dirección URL de configuración automática (archivo .INS), escriba la dirección URL para el archivo .ins que desee. En el cuadro Dirección URL de proxy automático (archivo .js, .jvs o .pac), escriba la dirección URL para la secuencia de comandos de proxy automático.

Para detectar automáticamente los valores de configuración del explorador, active la casilla de verificación Detectar automáticamente la configuración.

Configurar automáticamente cada n minutos
Puede especificar el intervalo de configuración automática en minutos. Si escribe cero 0 (cero) no especifica ningún valor, la configuración automática sólo se realizará cuando se reinicie el equipo del usuario.


Configuración de la conexión

Puede predefinir la configuración de la conexión para los usuarios si importa la configuración de la conexión desde su equipo.

Para ver qué configuración va a importar, haga clic en el menú Herramientas, Opciones de Internet y, finalmente, haga clic en la ficha Conexiones. Haga clic en Configuración para ver la configuración de acceso telefónico o haga clic en Configuración LAN para ver la configuración de la red. Tenga en cuenta que no se importará la dirección utilizada para la configuración automática.

No personalizar la configuración de conexión
Seleccione esta opción si no desea preestablecer la configuración de personalización de los usuarios.
Importar la configuración actual de conexión desde esta máquina
Seleccione esta opción si desea preestablecer la configuración de personalización de los usuarios para utilizar los valores importados desde el equipo. Si los valores de su equipo no son los que desea utilizar, haga clic en Modificar configuración para cambiarlos.
Eliminar la configuración de la conexión de acceso telefónico
Si es administrador corporativo, active esta casilla de verificación para borrar la configuración existente de los equipos de sus usuarios.

Nota

  • Si es administrador corporativo, también puede usar las restricciones y directivas del sistema para determinar si los usuarios pueden cambiar sus configuraciones de conexión. Puede definir las directivas y restricciones en la Fase 5 del Asistente para personalizar Microsoft Internet Explorer 6 o mediante la configuración automática.


Configuración de proxy

Puede especificar los servidores proxy a los que se conectarán los usuarios. Los servidores proxy actúan como intermediarios entre los usuarios de estaciones de trabajo e Internet, y facilitan el mantenimiento de los servicios de almacenamiento en caché y el control administrativo.

Si desea utilizar servidores proxy para cualquiera de los servicios enumerados a continuación, active la casilla de verificación Habilitar configuración de proxy.

Escriba la dirección del servidor proxy a la derecha de cualquiera de los servicios que se enumeran. Escriba el número de puerto, que en muchos casos es 80, en los cuadros situados bajo Puerto.

Para utilizar la misma configuración para todos los servicios, seleccione Utilizar el mismo servidor proxy para todas las direcciones.

En algunos casos, preferirá no utilizar servidores proxy, como para las direcciones de la intranet de su empresa. Puede escribir direcciones específicas en el área Excepciones, en el cuadro No usar proxy para las direcciones que comiencen por. Utilice un punto y coma para separar las entradas. Para no utilizar los servidores proxy en todas las direcciones de la intranet, active la casilla de verificación No usar servidor proxy en direcciones locales (intranet).


Agregar un certificado raíz

Puede agregar un certificado raíz al paquete IEAK personalizado si escribe la dirección URL en el cuadro Ruta del nuevo certificado raíz. De esta forma se proporciona un grado de confianza que pueden heredar los certificados de menor nivel en la jerarquía. Cada certificado se inspecciona en busca de un certificado principal hasta que se llega al certificado raíz.


Método de suscripción

Si es proveedor de servicios Internet, puede especificar cómo se suscribirán los usuarios a su servicio y cómo se conectarán a Internet.

Suscripción con servidor mediante el Asistente para la conexión a Internet (recomendado)
El método con servidor de suscripción a Internet proporciona una flexibilidad absoluta y se adapta dinámicamente a distintas opciones de suscripción. Puede crear soluciones de servidor que intercambien información con las pantallas del Asistente para la conexión a Internet (ICW). Para obtener más información, consulte Suscribirse a Internet con el Asistente para la conexión a Internet.
Suscripción con servidor mediante el modo a pantalla completa
El método con servidor de suscripción a Internet proporciona una flexibilidad absoluta y se adapta dinámicamente a distintas opciones de suscripción. Puede crear soluciones de servidor que intercambien información con el explorador en modo de pantalla completa, sin que se muestren los botones de la barra de herramientas. Para obtener más información, consulte Configurar un servidor de suscripción en modo a pantalla completa.
Suscripción sin servidor
El método de suscripción sin servidor no requiere un servidor de suscripción. Si selecciona el método sin servidor, el Asistente para personalizar Internet Explorer 6 le pedirá que proporcione la información necesaria para controlar el proceso de suscripción. Si elige esta opción, se le pedirá la información referente al marcado, gateway o puerta de enlace, y contraseña. También puede probar la página de suscripción desde el Asistente para personalizar Internet Explorer 6. No puede utilizar el método de suscripción sin servidor para personalizar el ICW.
Sin suscripción
Especifique este método si no desea que los usuarios tengan que pasar por un procedimiento de suscripción cuando instalen su explorador personalizado. Esta opción puede ser útil cuando se utilizan módems con cable.

Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.


Archivos de suscripción

Para permitir a los usuarios configurar sus equipos para conectarse a los servidores, debe crear archivos de suscripción personalizados. Para obtener más información, consulte Configurar un servidor de suscripción para el modo a pantalla completa y Suscribirse a Internet con el Asistente para la conexión a Internet.

El primer archivo debe ser una página HTML que contenga la información acerca de su servicio. Para suscribirse a Internet en el modo a pantalla completa, el archivo debe llamarse Signup.htm e incluir un vínculo a una página HTML apropiada en su servidor de suscripciones. Para suscribirse a Internet con el Asistente para la conexión a Internet, debe llamarse Icwsign.htm

La pantalla Archivos de suscripción muestra el directorio de trabajo para los archivos de suscripción. Si ya ha modificado sus archivos de suscripción, haga clic en Copiar archivos para copiarlos a este directorio de trabajo. Si desea comprobar o especificar la configuración en archivos .isp y archivos .ins mediante las pantallas del asistente que aparecerán después en la Fase 4, active las casillas de verificación Comprobar o modificar las entradas de los archivos .ISP y Comprobar o modificar las entradas de los archivos .INS.

Debe guardar en la misma carpeta todos los archivos de suscripción, incluso los archivos gráficos. Debe tener acceso total de lectura y escritura a esta carpeta, ya que el asistente necesita cambiar los atributos de todos los archivos a lectura y escritura.

Especificar archivos de suscripción personalizados
Escriba la ruta de acceso de la carpeta que contiene los archivos de suscripción o haga clic en Examinar para buscar la carpeta.

Nota

  • Para obtener más información acerca de los archivos .isp, consulte Crear un archivo .isp.


Información del servidor de suscripción

La pantalla Información del servidor de suscripción permite configurar las conexiones de acceso telefónico del usuario para que pueda conectarse al servidor de Internet.

Nombre de la conexión
Escriba el nombre del servidor de suscripción. Puede ser un nombre descriptivo.
Nombre de archivo
Escriba el nombre del archivo. El archivo que incluye los parámetros de suscripción debe tener la extensión .isp. El archivo para la Configuración de Internet debe tener la extensión .ins.
Código de área y número de teléfono
Escriba el código de área y el número de teléfono de la conexión.
Id. o código de país
Escriba el código país o de región, el número de teléfono y el identificador de país para esta conexión.
Nombre de usuario
Escriba el nombre de usuario predeterminado para esta conexión.
Contraseña
Escriba la contraseña predeterminada para esta conexión.
Teléfono de soporte técnico
Escriba el número de teléfono al que los usuarios pueden llamar para solicitar asistencia.
Dirección URL de la primera página de suscripción en línea
Escriba la dirección URL de la primera página del proceso de suscripción.
Opciones avanzadas
Para establecer las opciones de configuración siguientes para marcado y gateway, o puerta de enlace, haga clic en Opciones avanzadas.
Usar dirección DNS estática
El Sistema de nombres de dominio (DNS) es un conjunto de protocolos y servicios para redes de Protocolo de control de transporte/Protocolo Internet (TCP/IP). DNS permite utilizar nombres descriptivos, como www.microsoft.com, en vez de direcciones numéricas. Para asegurarse de que se buscará en todos los servidores DNS cuando se intente asignar nombres y direcciones IP, active esta casilla de verificación y escriba una dirección principal y una dirección alternativa.
Requiere inicio de sesión
Active esta casilla de verificación si necesita asegurarse de que la autenticación de inicio de sesión de Windows está activada en el equipo Al proporcionar una contraseña de Windows, se habilita el acceso a la caché de contraseñas de Windows donde está almacenada la contraseña ISP. Esta opción es especialmente útil si va a asignar cadenas largas y aleatorias como contraseñas. Esta opción sólo es válida para clientes Windows 95 y Windows 98.
Negociar TCP/IP
Active esta casilla de verificación para habilitar la negociación TCP/IP cuando el usuario establece una conexión con Internet.
Deshabilitar LCP
Active esta casilla de verificación para deshabilitar la utilización de las extensiones del Protocolo de control de vínculos (LCP) al establecer un vínculo de protocolo Punto a punto. Si el servidor de suscripción no puede controlar las extensiones LCP, debe deshabilitar LCP en el equipo cliente que se conectará a su servidor. Este valor únicamente es válido para clientes Windows NT 4.0.
Marcar número como se muestra
Active esta casilla de verificación para evitar que se establezca un código de área predeterminado. Puede utilizar este indicador de la forma indicada cuando, por ejemplo, los usuarios puedan hacer sus llamadas desde una zona con código telefónico distinto al predeterminado. Si los usuarios no advierten que el código de área predeterminado es distinto al del área en la que se encuentran, podrían, inadvertidamente, realizar llamadas interprovinciales.
Cifrar contraseñas
Active esta casilla de verificación para especificar que sólo se puede enviar a su equipo, o que éste sólo puede aceptar, contraseñas cifradas. Esto resulta de utilidad si necesita seguridad adicional para esta conexión. El equipo al que se está conectando debe admitir contraseñas cifradas.
Usar compresión de software
Active esta casilla de verificación para especificar que la información entrante y saliente se comprime antes de enviarla, lo que acelera la transferencia de información. La compresión sólo se produce si ambos equipos están utilizando un método de compresión compatible.
Utilizar compresión de encabezado IP
Active esta casilla de verificación para utilizar la compresión de encabezado TCP/IP, diseñada para aumentar la eficacia del uso del ancho de banda sobre enlaces serie de baja velocidad. Normalmente, de esta forma se optimiza la transferencia de datos entre equipos.

Al construir un pequeño encabezado que identifica la conexión e indica los campos que han cambiado, es necesario transmitir menos bytes. Para que la compresión funcione, los paquetes deben llegar en orden.

La compresión no siempre es aceptable. Por ejemplo, si utiliza equipos antiguos, es posible que no pueda utilizar la compresión. Para que haya una buena interoperabilidad, los controladores del Protocolo Internet de línea serie que permiten la compresión de encabezados deben incluir una especie de indicador configurable por el usuario para deshabilitar la compresión.

Usar puerta de enlace remota predeterminada
Active esta casilla de verificación para especificar si el tráfico de Protocolo de Internet (IP) se enruta a la conexión de red de área extensa (WAN) de forma predeterminada. Una gateway o puerta de enlace es una conexión o punto de intercambio que conecta dos redes que, de otra forma, serían incompatibles.

Nota

  • También puede impedir que se establezca un código de área predeterminado si utiliza un indicador en el archivo .isp. La sintaxis de ese indicador es la siguiente:
    Dial_As_Is=Yes


Asistente para la conexión a Internet

Puede especificar el Asistente para la conexión a Internet (ICW) como la herramienta que usarán los clientes para suscribirse a servicios Internet. Puede crear soluciones con servidor que intercambien información con las pantallas del ICW. Esta característica no está disponible para el método de suscripción sin servidor.

Personalizar la barra de título
Active esta casilla de verificación para especificar que los clientes usen el Asistente para la conexión a Internet para suscribirse a sus servicios.
Texto de la barra de título
Escriba el texto que desea que aparezca en la barra de título del Asistente para la conexión a Internet personalizado.
Imagen superior
Escriba la ruta de acceso del archivo .bmp de 49 por 49 píxeles que aparece en la esquina superior derecha del Asistente para la conexión a Internet.
Imagen de la izquierda
Escriba la ruta de acceso del archivo .bmp de 164 por 458 píxeles que aparece en la parte izquierda del Asistente para la conexión a Internet.

Notas

  • Tendrá que incluir el componente Enlace dinámico de datos HTML con el paquete del explorador para asegurarse de que el Asistente para la conexión a Internet puede interactuar con su servidor. El enlace de datos permite a las páginas del asistente mostrar la lista de archivos ISP en Signup.txt. Puede especificar que esta opción no aparezca como una opción de instalación personalizada que los usuarios pueden no instalar. Para ello, en la página Opciones de instalación avanzadas, desactive la casilla de verificación Enlace dinámico de datos HTML. A continuación, en el programa de instalación de Windows Update, Forzar instalación aparece en la columna correspondiente a este componente.
  • Puede ver un ejemplo del proceso de suscripción en Proceso de suscripción a un ISP.


Archivos de configuración de Internet

En la pantalla Archivos de configuración de Internet puede determinar la configuración que el Asistente para personalizar Internet Explorer 6 utilizará al generar un archivo .ins. Este archivo puede enviarse al servidor o incorporarse al paquete personalizado que esté creando para la suscripción sin servidor.

Nombre de la conexión
Escriba el nombre del servidor de suscripción. Puede ser un nombre descriptivo.
Nombre de archivo
Escriba el nombre del archivo. El archivo de los parámetros de suscripción debe tener la extensión .isp. El archivo para la Configuración de Internet debe tener la extensión .ins.
Código de área y número de teléfono
Escriba el código de área y el número de teléfono de la conexión.
Id. o código de país
Escriba el código país o de región, el número de teléfono y el identificador de país para esta conexión.
Nombre de usuario
Escriba el nombre de usuario predeterminado para esta conexión.
Contraseña
Escriba la contraseña predeterminada para esta conexión.
Opciones avanzadas
Para establecer las opciones de configuración siguientes para marcado y gateway, o puerta de enlace, haga clic en Opciones avanzadas.
Usar dirección DNS estática
El Sistema de nombres de dominio (DNS) es un conjunto de protocolos y servicios para redes de Protocolo de control de transporte/Protocolo Internet (TCP/IP). DNS permite utilizar nombres descriptivos, como www.microsoft.com, en vez de direcciones numéricas. Para asegurarse de que se buscará en todos los servidores DNS cuando se intente asignar nombres y direcciones IP, active esta casilla de verificación y escriba una dirección principal y una dirección alternativa.
Requiere inicio de sesión
Active esta casilla de verificación si necesita asegurarse de que la autenticación de inicio de sesión de Windows está activada en el equipo Al proporcionar una contraseña de Windows, se habilita el acceso a la caché de contraseñas de Windows donde está almacenada la contraseña ISP. Esta opción es especialmente útil si va a asignar cadenas largas y aleatorias como contraseñas. Esta opción sólo es válida para clientes Windows 95 y Windows 98.
Negociar TCP/IP
Active esta casilla de verificación para habilitar la negociación TCP/IP cuando el usuario establece una conexión con Internet.
Deshabilitar LCP
Active esta casilla de verificación para deshabilitar la utilización de las extensiones del Protocolo de control de vínculos (LCP) al establecer un vínculo de protocolo Punto a punto. Si el servidor de suscripción no puede controlar las extensiones LCP, debe deshabilitar LCP en el equipo cliente que se conectará a su servidor. Este valor únicamente es válido para clientes Windows NT 4.0.
Marcar número como se muestra
Active esta casilla de verificación para evitar que se establezca un código de área predeterminado. Puede utilizar este indicador de la forma indicada cuando, por ejemplo, los usuarios puedan hacer sus llamadas desde una zona con código telefónico distinto al predeterminado. Si los usuarios no advierten que el código de área predeterminado es distinto al del área en la que se encuentran, podrían, inadvertidamente, realizar llamadas interprovinciales.
Cifrar contraseñas
Active esta casilla de verificación para especificar que sólo se puede enviar a su equipo, o que éste sólo puede aceptar, contraseñas cifradas. Esto resulta de utilidad si necesita seguridad adicional para esta conexión. El equipo al que se está conectando debe admitir contraseñas cifradas.
Usar compresión de software
Active esta casilla de verificación para especificar que la información entrante y saliente se comprime antes de enviarla, lo que acelera la transferencia de información. La compresión sólo se produce si ambos equipos están utilizando un método de compresión compatible.
Utilizar compresión de encabezado IP
Active esta casilla de verificación para utilizar la compresión de encabezado TCP/IP, diseñada para aumentar la eficacia del uso del ancho de banda en enlaces serie de baja velocidad. Normalmente, de esta forma se optimiza la transferencia de datos entre equipos.

Al construir un pequeño encabezado que identifica la conexión e indica los campos que han cambiado, es necesario transmitir menos bytes. Para que la compresión funcione, los paquetes deben llegar en orden.

La compresión no es siempre deseable. Por ejemplo, si utiliza equipos antiguos, es posible que no pueda utilizar la compresión. Para que haya una buena interoperabilidad, los controladores del Protocolo Internet de línea serie que permiten la compresión de encabezados deben incluir una especie de indicador configurable por el usuario para deshabilitar la compresión.

Usar puerta de enlace remota predeterminada
Active esta casilla de verificación para especificar si el tráfico de Protocolo de Internet (IP) se enruta a la conexión de red de área extensa (WAN) de forma predeterminada. Una gateway o puerta de enlace es una conexión o punto de intercambio que conecta dos redes que, de otra forma, serían incompatibles.
No aplicar información de marca a este archivo
Especifica que no va a aplicar ninguna información de marca a este archivo .ins.
No modificar la información de marca de este archivo
Especifica que no va a cambiar la información de marca en el archivo .ins.
Aplicar la información de marca actual a este archivo
Especifica que va a incluir información de marca en el archivo .ins.
Nombre del archivo .CAB de marca
Especifica el nombre del archivo que contiene la información de marca. Esta información se agrega al archivo .ins. Si utiliza suscripciones sin servidor, o si los usuarios se conectan a su servidor para realizar la suscripción, su marca aparecerá en las pantallas de suscripción.
Dirección URL del archivo .CAB de marca
Escriba la dirección URL del archivo que contiene la información de marca. Esta información se agrega al archivo .ins. Si utiliza suscripciones sin servidor, o si los usuarios se conectan a su servidor para realizar la suscripción, su marca aparecerá en las pantallas de suscripción.

Nota

  • También puede impedir que se establezca un código de área predeterminado si utiliza un indicador en el archivo .isp. La sintaxis de ese indicador es la siguiente:
    Dial_As_Is=Yes


Seguridad

Para administrar la seguridad puede utilizar entidades emisoras de certificados y Authenticode.

Puede usar entidades emisoras de certificados para controlar los sitios desde los que los usuarios descargan cierto contenido, como controles ActiveX y subprogramas Java. Los certificados de sitio son una forma de certificado digital para un sitio de Internet. Mediante el uso de la tecnología Authenticode, muestra de dónde provienen los programas y permite comprobar que no fueron modificados.

No personalizar entidades emisoras de certificados
Seleccione esta opción si no desea personalizar las entidades emisoras de certificados. Aún puede personalizar la información de seguridad de Authenticode.

Puede importar de su equipo la configuración de las entidades emisoras de certificados. Si desea modificar la configuración que aplicará a los equipos de los usuarios, haga clic en Importar entidades emisoras de certificados actuales y, después, haga clic en Modificar configuración.

Puede utilizar después el Administrador de certificados para ver y administrar la información de las entidades emisoras. Los certificados pueden aplicarse a la autenticación de servidores de red, la autenticación de clientes de red, la autenticación de correo electrónico seguro y la publicación de software.

No personalizar seguridad Authenticode
Seleccione esta opción si no desea personalizar la información de seguridad de Authenticode.

Puede usar la tecnología Authenticode para designar fabricantes de software y agencias de credenciales como de confianza. También puede importar la configuración desde su equipo. Si desea modificar la configuración que aplicará a los equipos de los usuarios, haga clic en Importar información actual de seguridad Authenticode y, después, en Modificar configuración.


Configuración de seguridad y confidencialidad

Como administrador corporativo, puede administrar las zonas de seguridad, configuración de confidencialidad y la clasificación de contenidos de su organización. Puede personalizar la configuración de cada zona de seguridad. Puede establecer el nivel de confidencialidad con respecto a las cookies para todos los usuarios del explorador. Mediante la clasificación de contenidos puede evitar que los usuarios vean contenidos considerados ofensivos o inapropiados en el marco corporativo.

Zonas de seguridad y confidencialidad
Si desea modificar la configuración que se instale en los equipos de los usuarios, haga clic en Importar la configuración actual de las zonas de seguridad y, después, haga clic en Modificar configuración. En la Fase 5 también puede especificar si los usuarios tienen permiso para cambiar su configuración de seguridad y confidencialidad.

Notas

  • La configuración de seguridad incluye Internet, intranet local, sitios de confianza y sitios restringidos.
  • Los tres niveles de confidencialidad son alto, medio y bajo. Cuando establece el nivel de confidencialidad alto, los sitios de Internet no pueden definir cookies en los equipos de los usuarios. El nivel de confidencialidad medio comprueba que el sitio de Internet posee una directiva de confidencialidad, compara esa directiva con los equipos de los usuarios, permite que los sitios de Internet utilicen las cookies existentes y no deja que terceras personas no apropiadas utilicen las cookies. La configuración baja permite que los sitios de Internet definan cookies en los equipos de los usuarios.
No personalizar las zonas de seguridad
Si no desea modificar la configuración de la zona de seguridad y confidencialidad, haga clic en esta opción.
Clasificación de contenidos
Microsoft Internet Explorer le ofrece una forma de ayudarle a controlar los tipos de contenido a los que puede tener acceso su equipo en Internet. Puede ajustar la configuración para que refleje su opinión acerca del contenido apropiado en cuatro áreas: lenguaje obsceno, desnudos, sexo y violencia.

Si desea modificar las restricciones que aplicará a los equipos de los usuarios, haga clic en Importar la configuración actual de restricciones de contenido y, después, haga clic en Modificar configuración. A continuación puede modificar la configuración mediante el Asesor de contenido.

No personalizar las restricciones de contenido
Si no desea modificar la información de restricción de contenido, haga clic en esta opción.

Notas

  • El Asesor de contenido utiliza unas normas de clasificación muy prudentes cuando se habilita por primera vez. Puede ajustar la configuración para que coincida con sus preferencias.
  • No todo el contenido de Internet está restringido. Si opta por permitir que los usuarios vean sitios no restringidos, alguno de estos sitios puede contener material no apropiado.


Fase 4 Introducción: personalizar el explorador

titular

Fase 4: personalizar el explorador

En esta fase del Asistente para personalizar Internet Explorer 6, puede personalizar la apariencia y comportamiento de Internet Explorer.

Las opciones disponibles dependen de su función:

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo

Nota

  • La disponibilidad de algunas opciones, como puede ser la personalización del logotipo, también depende del contrato de licencia. Para obtener más información, consulte su contrato.


Destinatarios de las directivas y restricciones

La administración centralizada de las directivas y las restricciones del sistema puede ayudarle a mantener un entorno de escritorio coherente en la organización y reducir los consiguientes costos de asistencia técnica.

Todas las directivas de sistema y restricciones que puede definir en el Asistente para personalizar Internet Explorer 6 y administrar posteriormente en el Administrador de perfiles de IEAK pueden configurarse para usuarios que utilicen los sistemas operativos Windows 95, Windows 98 y Windows Millennium Edition.

No obstante, en las plataformas Windows NT, Windows 2000 o Windows XP sólo podrá configurar un subconjunto de estas directivas de sistema y restricciones para los usuarios sin privilegios de administrador. En lugar de ello, es aconsejable que use el Editor de directivas de Windows NT o la Directiva de grupo de Windows 2000 o Windows XP para configurar las directivas y restricciones restantes correspondientes a dichos usuarios. Para obtener más información, consulte Administrar Microsoft Internet Explorer en Windows 2000 y Windows XP.

Mostrar todas las directivas del IEAK
Es posible configurar todo el conjunto de directivas de sistema y restricciones para todos los usuarios de los sistemas operativos Windows 95, Windows 98 y Windows Millennium Edition, así como para usuarios con privilegios de administrador en Windows NT, Windows 2000 y Windows XP.
Mostrar el subconjunto de directivas de IEAK para usuarios que no sean administradores
Elija esta opción para ver y configurar un subconjunto de directivas de sistema y restricciones que se apliquen a usuarios sin privilegios de administrador de los sistemas operativos Windows NT, Windows 2000 y Windows XP.


Programas

Utilice estas opciones para configurar los programas de los usuarios, como el cliente de correo electrónico predeterminado y el editor HTML predeterminado.
No personalizar la configuración del programa
Seleccione este botón de opción si no desea configurar las opciones de los programas de los usuarios.
Importar la configuración actual del programa
Haga clic en este botón de opción si desea importar la configuración de los programas desde su equipo, por ejemplo, de los programas específicos que empleará para el correo electrónico y para la edición de HTML. Estos valores se encuentran en la ficha Programas del cuadro de diálogo Opciones de Internet.

Para cambiar su configuración y después importarla, haga clic en Importar la configuración actual del programa y, después, en Modificar configuración.


Cuentas de Outlook Express

Servidores

Puede especificar los servidores de correo y de noticias para Outlook Express y solicitar a los usuarios que inicien sus sesiones utilizando el sistema de autenticación de contraseña segura (SPA, Secure Password Authentication) para tener acceso al servidor.

Correo entrante
Seleccione el protocolo que ejecutan los servidores de correo. Puede elegir POP3, utilizado para correo electrónico por la mayoría de los abonados a Internet, o IMAP, que principalmente es usado por usuarios de empresas que desean leer su correo electrónico desde una ubicación remota. Los servidores POP3 permiten tener acceso a una única bandeja de entrada, mientras que los servidores IMAP proporcionan acceso a múltiples carpetas en el servidor.
Servidor
Escriba la dirección completa del servidor de correo entrante autorizado en el cuadro de texto (por ejemplo, pop01.microsoft.com). Después, haga clic en Inicio de sesión con SPA (Autenticación de contraseña segura) en el caso de que el servidor POP3 o IMAP requiera la autenticación por medio de un proveedor SSPI como NTLM.
Servidor de correo saliente (SMTP)
El servidor SMTP es el servidor de correo saliente. En algunos casos, el servidor SMTP puede tener el mismo nombre que el servidor POP3, por ejemplo, smtp.microsoft.com. Escriba la dirección completa del servidor SMTP en el cuadro de texto. Después, haga clic en Inicio de sesión con SPA en el caso de que el servidor SMTP requiera la autenticación por medio de un proveedor SSPI como NTLM.
Servidor de noticias de Internet (NNTP)
El protocolo de transferencia de noticias a través de la red (NNTP, Network News Transfer Protocol) se usa para distribuir los mensajes de noticias de red a servidores NNTP y a clientes NNTP (lectores de noticias) en Internet. Escriba la dirección NNTP en el cuadro de texto; por ejemplo, nntp.microsoft.com. Después, haga clic en Inicio de sesión con SPA en el caso de que el servidor NNTP requiera la autenticación por medio de un proveedor SSPI como NTLM.
Hacer de sólo lectura los nombres de servidor
Active esta casilla de verificación para bloquear la configuración de la cuenta del servidor. De este modo evitará que los usuarios cambien la configuración.
Deshabilitar el acceso a las cuentas (no se podrá agregar, quitar o modificar cuentas)
Active esta casilla de verificación para bloquear la configuración de la cuenta. De este modo evitará que los usuarios eliminen o modifiquen cuentas configuradas, o creen cuentas adicionales. Esta opción sólo es recomendable para administradores corporativos.

Notas

  • Las cuentas de usuario, como cuentas de correo o de noticias, se configuran de acuerdo con las restricciones que especifique.
  • Cuando bloquea la configuración del servidor y de las cuentas, los usuarios pueden ver la configuración, pero no modificarla.


Configuración IMAP de Outlook Express

Utilice esta pantalla para crear configuraciones IMAP predeterminadas para los usuarios. Estas opciones se preconfiguran para los usuarios cuando crean sus cuentas IMAP.

Ruta de la carpeta raíz
La ruta de la carpeta raíz es el buzón de correos que contiene todas las carpetas de usuario en el servidor IMAP. En el caso de servidores Cyrus, todas las carpetas de usuario deben estar en la carpeta Bandeja de entrada. En los servidores IMAP basados en UNIX, el correo suele almacenarse en una carpeta propia que se encuentra en la carpeta personal del usuario (por ejemplo, ~nombreusuario/Mail). No termine la ruta de la carpeta raíz con un carácter de jerarquía. Por ejemplo, ~nombreUsuario/Correo es una ruta de carpeta raíz válida, pero ~nombreUsuario/Correo/ no lo es. Algunos servidores IMAP, como Microsoft Exchange Server, no precisan de una ruta de acceso de la carpeta raíz.
Almacenar las carpetas especiales en el servidor IMAP
Active esta casilla de verificación si desea especificar que se creen en el servidor IMAP carpetas para los mensajes enviados y los mensajes en curso de los usuarios.
Ruta de Elementos enviados
Presenta el nombre de la ruta de acceso de la carpeta Elementos enviados. Esta ruta de acceso será la que usen todos los usuarios que creen cuentas IMAP.
Ruta de la carpeta Borrador
Presenta el nombre de la ruta de acceso de la carpeta Borrador. Esta ruta de acceso será la que usen todos los usuarios para los que configure cuentas IMAP.
Buscar nuevos mensajes en todas las carpetas
Active esta casilla de verificación para comprobar automáticamente, cuando el usuario inicia Outlook Express y con la periodicidad que haya definido, si hay cambios en el número de mensajes en todas las carpetas a las que se ha suscrito un usuario IMAP. Si no se selecciona esta opción, Outlook Express sólo comprobará si hay mensajes nuevos en la Bandeja de entrada.


Contenido personalizado de Outlook Express

Puede proporcionar a Outlook Express una apariencia personalizada y dar la bienvenida a los nuevos usuarios con un mensaje de correo electrónico.

Panel de información

El Panel de información de Outlook Express es un área donde los proveedores de contenido pueden colocar información y vínculos útiles para el usuario. Puede personalizar este panel con los números de teléfono del servicio de soporte, las preguntas más frecuentes y datos acerca de su organización.

El Panel de información es un panel de 50 píxeles de alto situado en la parte inferior de la ventana principal de Outlook Express. Puede personalizar el Panel de información con un archivo HTML local o que se encuentre en una dirección URL de Internet. Si especifica un archivo local, ese archivo se copiará en el paquete de distribución del IEAK y, posteriormente, en el equipo del usuario durante la instalación.

Nota

  • El Panel de información no aparece en la interfaz de usuario de Outlook Express a menos que se especifique un archivo o dirección URL en el IEAK.
Dirección URL
Escriba la dirección URL del archivo HTML que desea utilizar para el Panel de información.
Archivo local
Si no ha escrito una dirección URL en el cuadro de texto anterior, puede escribir la ruta de acceso del archivo local HTML que desea usar para el Panel de información en el cuadro Ruta HTML. De otro modo, haga clic en Examinar para buscar el archivo. Si especifica un archivo local, también puede especificar una imagen que se copie en el cuadro Ruta de la imagen.

Mensaje de bienvenida

También puede proporcionar un mensaje de bienvenida como primer elemento de la Bandeja de entrada de cada usuario. El mensaje de bienvenida es un archivo HTML. Asimismo, debe proporcionar el nombre descriptivo del remitente, por ejemplo el nombre de su organización, y la dirección de correo electrónico del destinatario.

Nota

  • El IEAK no ofrece ningún sistema que permita incluir una imagen en el mensaje de bienvenida. Sin embargo, si modifica el mensaje de bienvenida fuera del IEAK, puede agregarle un vínculo a una imagen del Web.
Ruta HTML
Escriba la ruta del archivo HTML que desea enviar o haga clic en Examinar para buscar el archivo.
Remitente
Escriba el nombre de la organización o la persona que envía el mensaje de bienvenida; por ejemplo, Departamento de administración de El Volcán. Este nombre aparecerá en la línea De del mensaje de bienvenida.
Responder a
Escriba la dirección de correo electrónico de la organización o persona que envía el mensaje de bienvenida. El usuario puede enviar correo a esta dirección si tiene alguna pregunta o duda.


Configuración personalizada de Outlook Express

Utilice esta pantalla para crear una configuración que se aplicará a todos los usuarios. Esta configuración predeterminada incluye un cliente de correo y noticias predeterminado. Además, puede proporcionar información que los usuarios necesitan para obtener cuentas adicionales de correo electrónico. Finalmente, puede proporcionar el archivo de reglas predeterminadas para mensajes para los usuarios.

Programas de mensajería predeterminados

Outlook Express es el programa predeterminado para
Si desea que Outlook Express se inicie cada vez que un usuario haga clic en un vínculo de correo electrónico en Internet Explorer, active la casilla de verificación Correo. La configuración de cliente de correo predeterminado la utilizan también muchos otros programas cuando un usuario envía documentos por correo electrónico. Tenga en cuenta que esta selección reemplaza a cualquier cliente de correo predeterminado que haya especificado el usuario.

Si desea que Outlook Express se inicie cada vez que un usuario haga clic en un vínculo de noticias en Internet Explorer, active la casilla de verificación Noticias.

Grupos de noticias

Puede facilitar la suscripción de los usuarios a grupos de noticias. Utilice el cuadro de texto en blanco para escribir los nombres de uno o varios grupos de noticias a los que desea suscribir automáticamente a los usuarios. Por ejemplo, su proveedor de servicios Internet u organización pueden tener varios grupos de noticias que proporcionen asistencia e información a los usuarios.

Nombre del servicio
Puede agregar un elemento al menú que los usuarios pueden usar para obtener una cuenta adicional de correo del ISP. Esta entrada se agrega al menú Nueva cuenta con en Outlook Express. Escriba el nombre del ISP en el cuadro Nombre del servicio; por ejemplo, Acme ISP.
Dirección URL del servicio
Escriba una dirección URL en el cuadro Dirección URL del servicio que se corresponda con las cuentas de correo adicionales que los usuarios pueden configurar. Cuando el usuario elija este Nombre de servicio en el menú, se abrirá la página Web. Cuando se abra la página Web, se enviarán al ISP un número de cuenta, que puede especificarse en el archivo .ins, y un identificador exclusivo del usuario.
Eliminar todos los vínculos de Outlook Express
Si activa esta casilla de verificación, no aparecerán vínculos al programa Outlook Express en el escritorio del usuario o en el menú Inicio.


Configuración de vistas de Outlook Express

Puede personalizar determinadas vistas que hacen que algunos elementos específicos de Outlook Express se muestren o no, o que determinan la forma en que lo hacen.

Básica
Utilice esta configuración para determinar qué elementos de la interfaz de Outlook Express se incluyen en la vista predeterminada para los nuevos usuarios.
  • Para incluir la barra de carpetas como opción predeterminada para los usuarios, active la casilla de verificación Barra de carpetas.
  • Para mostrar la barra de Outlook, una barra horizontal que muestra determinadas carpetas, como la Bandeja de entrada, active la casilla de verificación Barra de Outlook.
  • Para incluir en la columna de la izquierda una lista de correo electrónico y carpetas nuevas, active la casilla de verificación Lista de carpetas.
  • Para mostrar la barra de estado, que aparece en la parte inferior de la ventana de Outlook Express, active la casilla de verificación Barra de estado.
  • Para que aparezca una lista de contactos de MSN Messenger del usuario, en el caso de que ese servicio esté instalado y configurado, así como las direcciones de los usuarios con los que intercambia correo electrónico, active la casilla de verificación Contactos.
  • Para que se muestre una sugerencia cada vez que se inicia Outlook Express, active la casilla de verificación Sugerencia del día.
Barra de herramientas
Utilice esta configuración para si especificar si desea que aparezca la barra de herramientas y, si lo hace, si va a incluir texto.
  • Active la casilla de verificación Mostrar barra de herramientas para incluir la barra de herramientas. Aparece en la parte superior de la ventana de Outlook Express y contiene botones que corresponden a los comandos comunes. Los usuarios pueden configurar la barra de herramientas.
  • Active la casilla de verificación Mostrar texto en los botones de la barra de herramientas para incluir texto en los botones de la barra de herramientas.
Panel de vista previa
Utilice esta configuración para establecer las opciones del panel de vista previa.
  • Active la casilla de verificación Mostrar panel de vista previa para incluir un panel de vista previa de mensajes para que los usuarios puedan tener una vista previa de los mensajes de correo y noticias.
  • Haga clic en Debajo de los mensajes si desea que el panel de vista previa aparezca como un panel horizontal ubicado debajo de la lista de mensajes.
  • Haga clic en Junto a los mensajes si desea que el panel de vista previa aparezca como un panel vertical situado a la derecha de la lista de mensajes.
  • Active la casilla de verificación Mostrar encabezado del panel de vista previa para incluir una zona de encabezado en el panel de vista previa que puede usarse para mostrar información del encabezado del mensaje como las líneas De, A, Cc y Asunto del mensaje.


Configuración de redacción de Outlook Express

Puede incluir una firma predeterminada, como puede ser una renuncia de responsabilidad de la organización, que aparecerá en todos los mensajes de grupos de noticias o de correo electrónico de Outlook Express. A menudo se utiliza una renuncia de responsabilidad para indicar que los mensajes que envían los empleados a través de Internet no representan las directivas oficiales de una organización. El tamaño máximo de la firma es de 1 KB.

Agregar una firma a cada mensaje
Puede agregar firmas sólo a los mensajes de correo electrónico o a mensajes de correo electrónico y de noticias. Active la casilla de verificación Anexar una firma a cada mensaje para agregar texto a una firma para mensajes de correo electrónico.
Utilizar una firma diferente para los mensajes de noticias
Active esta casilla de verificación para agregar o modificar el texto de una firma para mensajes de noticias. Puede utilizar el mismo texto que el que ha utilizado para los mensajes de correo electrónico o escribir texto diferente para mensajes de noticias.
Para mensajes de correo, establecer como predeterminada la redacción HTML
De manera predeterminada, los mensajes de correo electrónico se redactan en HTML y las noticias en texto sin formato. Puede cambiar esta configuración predeterminada. Por ejemplo, en un entorno donde el ancho de banda esté limitado o sean muchos los usuarios que utilicen programas de correo sencillos que no puedan entender mensajes HTML, puede ser razonable cambiar la configuración predeterminada para que los mensajes se redacten como texto sin formato. Por otra parte, en un entorno corporativo en el que todos los usuarios utilicen programas lectores de noticias compatibles con el formato HTML, puede ser aconsejable cambiar la configuración predeterminada para que las noticias se publiquen en HTML.
Para mensajes de noticias, establecer como predeterminada la redacción HTML
Active esta casilla de verificación para utilizar el formato HTML de manera predeterminada para los mensajes de noticias.


Servicio de directorio de Libreta de direcciones

Los servicios de directorio son herramientas de búsqueda eficaces que ayudan a los usuarios a buscar personas y organizaciones en todo el mundo. La Libreta de direcciones de Windows admite el protocolo compacto de acceso a directorios (LDAP, Lightweight Directory Access Protocol) para el acceso a los servicios de directorio y se distribuye con acceso integrado a muchos de los servicios de directorio más utilizados. Puede especificar un servicio adicional para sus usuarios.

Nombre del servicio
Escriba el nombre descriptivo del servicio LDAP. Es el nombre que se mostrará a los usuarios.
Nombre del servidor
Escriba el nombre del servicio de directorio que desea agregar, por ejemplo, ldap.contoso.com o ldap.lucernepublishing.com. Si para que los usuarios tengan acceso a estos servicios es necesario que la autenticación se haga por medio de un paquete SSPI, como es el NTLM, active la casilla de verificación Inicio de sesión con SPA. La autenticación básica, que utiliza una combinación de nombre de usuario y contraseña, se puede configurar por medio de los archivos .ins.
Sitio Web del servicio
Escriba la dirección URL de la página principal del servicio de directorio.

Cómo ven los usuarios la página principal del servicio de directorio en Windows 95, Windows 98 o Windows NT

  1. En Windows, haga clic en Inicio, seleccione Buscar y, a continuación, haga clic en Personas.
  2. En el cuadro de diálogo Buscar personas, seleccione la página principal del servicio de directorio en la lista Buscar en y, a continuación, haga clic en Sitio Web.

    Seleccione la página principal del servicio de directorio y, después, haga clic en Sitio Web.

Cómo ven los usuarios la página principal del servicio de directorio en Windows 2000, Windows XP o Windows Millennium Edition

  1. En Windows, haga clic en Inicio, seleccione Buscar y, a continuación, haga clic en Personas.
  2. En el cuadro de diálogo Buscar personas, seleccione la página principal del servicio de directorio en la lista Buscar en y, a continuación, haga clic en Sitio Web.
Base de búsqueda
A veces conocida como raíz o ámbito, la Base de búsqueda es el nivel jerárquico en el que se busca un servidor LDAP específico. La base de búsqueda puede ser un país, organización o cualquier otro tipo de agrupamiento. El valor predeterminado en Outlook Express para la base de búsqueda, cuando no se especifica ninguna, es "c=us". Para especificar que no hay base de búsqueda, escriba NULL.
Mapa de bits del servicio
Puede especificar un archivo .bmp personalizado de 16 colores y 134 por 38 píxeles. Para asegurar que la asignación de colores es coherente, es aconsejable que utilice exclusivamente la paleta de colores de 16 bits de Windows al generar el mapa de bits. Para encontrar el archivo .bmp en el equipo, haga clic en Examinar.
Tiempo de espera de búsqueda
Puede especificar cuánto tiempo esperarán los usuarios antes de que se agote el tiempo de espera en una solicitud de búsqueda. Utilice el control deslizante para elegir un valor entre 30 segundos y 5 minutos.
Número máximo de coincidencias
Puede controlar el número máximo de resultados que se devolverán a los usuarios. Escriba el número en este cuadro.
Comprobar los nombres con este servidor al enviar el correo
Para que Outlook Express resuelva los nombres en el servidor cuando un usuario envíe un mensaje, active esta casilla de verificación. Esta opción indica a Outlook Express que debe buscar las direcciones de correo electrónico para los nombres escritos en las líneas A, Cc y Cco de un mensaje de correo.


Directivas y restricciones

Según su función, puede definir la configuración de varios aspectos de los equipos de los usuarios de la organización, como el escritorio, los componentes Internet, el sistema operativo y la seguridad.

Los proveedores de servicios Internet, proveedores de contenido Internet y administradores corporativos pueden especificar configuraciones predeterminadas para los usuarios. Además, los administradores corporativos pueden personalizar y restringir numerosas opciones de configuración, por ejemplo, si los usuarios pueden eliminar impresoras o si pueden agregar elementos a su escritorio.

Todas las directivas de sistema y restricciones que puede definir en el Asistente para personalizar Internet Explorer 6 y administrar posteriormente en el Administrador de perfiles de IEAK pueden configurarse para usuarios que utilicen los sistemas operativos Windows 95, Windows 98 y Windows Millennium Edition.

No obstante, en las plataformas Windows NT, Windows 2000 o Windows XP sólo podrá configurar un subconjunto de estas directivas de sistema y restricciones para los usuarios sin privilegios de administrador. En lugar de ello, es aconsejable que use el Editor de directivas de Windows NT o la Directiva de grupo de Windows 2000 o Windows XP para configurar las directivas y restricciones restantes correspondientes a dichos usuarios.

Debe conocer las consecuencias de la configuración de la seguridad en los usuarios, especialmente si hay usuarios móviles que comparten los equipos con otros usuarios.

Notas

  • Entre las opciones de configuración incluidas en la nueva función de la barra de herramientas Imágenes, incluida en Internet Explorer 6, están la barra de herramientas de imagen flotante, ajustar una imagen al tamaño de la pantalla y reproducir automáticamente los archivos multimedia en la barra multimedia. Puede configurar estas opciones en la sección Configuración de Internet, en Directivas y restricciones.
  • Las opciones de configuración mostradas en el asistente se incluyen en los archivos de administración (.adm) suministrados con el IEAK. Si está familiarizado con los archivos .adm, puede utilizar el Asistente para personalizar Internet Explorer 6 para establecer las directivas y restricciones configuradas en sus propios archivos .adm; para ello, haga clic en Importar.

    Las opciones que elija para estas restricciones y directivas se almacenarán como archivos .ins. Estos archivos se utilizan para generar los archivos .inf del paquete personalizado. Para obtener más información acerca de la relación entre los archivos .adm y los archivos .inf, consulte Configuración y directivas del sistema.

  • Para asegurarse de que es efectiva la configuración de entidades emisoras de confianza en la sección Seguridad de Restricciones de Internet, debe comprobar que están bien configuradas las zonas de seguridad y las directivas.

La configuración de los usuarios se puede almacenar en una ubicación central y ponerse a disposición de los usuarios cuando inicien una sesión desde un equipo en otro. Esto podría resultar útil, por ejemplo, para una persona que necesita una configuración de seguridad baja pero que utiliza un equipo en el que normalmente trabaja alguien con una configuración de seguridad más restringida.

Personalizar la configuración de seguridad

Puede permitir tres niveles típicos de personalización de la configuración de seguridad:

  • Controlar, o "bloquear", todas las configuraciones.
  • Controlar la configuración de usuario a la vez que se permite la descarga de perfiles para usuarios móviles.

    Puede especificar que la configuración no se pueda cambiar sin bloquear a los usuarios móviles que tienen perfiles diferentes. La característica para usuarios móviles de Windows permite que los usuarios descarguen su configuración desde un servidor.

  • Personalizar la configuración inicial, pero permitir que el usuario la modifique.

    En este paso del asistente puede personalizar muchas opciones de configuración del usuario, incluidos los niveles de seguridad y las clasificaciones. La personalización de la configuración en este paso no determina si el usuario puede controlar la configuración.

Para establecer las directivas del sistema y las restricciones

  1. Haga doble clic en cada categoría para mostrar las opciones.
  2. Haga clic en la directiva o restricción con la que desea trabajar.
  3. Active o desactive las casillas de verificación que desee.

Para bloquear todas las configuraciones

  1. Haga doble clic en Restricciones corporativas y, a continuación, haga clic en Página de seguridad.
  2. Active la casilla de verificación Usar sólo la configuración del equipo para zonas de seguridad.

Para evitar que un usuario cambie las directivas de una zona

  1. Haga doble clic en Restricciones corporativas y, a continuación, haga clic en Página de seguridad.
  2. Active la casilla de verificación No permitir que los usuarios cambien las directivas de ninguna zona de seguridad.

Para evitar que un usuario agregue o elimine sitios

  1. Haga doble clic en Restricciones corporativas y, a continuación, haga clic en Página de seguridad.
  2. Active la casilla de verificación No permitir que los usuarios agreguen o eliminen sitios de una zona de seguridad.


Fase 5 Introducción: personalizar componentes

titular

Fase 5: personalizar componentes

En este paso del Asistente para personalizar Internet Explorer, puede especificar la configuración, directivas y restricciones para los componentes del paquete personalizado.

Las opciones disponibles dependerán de su función:

  • Proveedor de contenido Internet
  • Proveedor de servicios Internet
  • Administrador corporativo