Informace

ForceExit

Verze 1.3
Copyright© 2003-2004 Mart

http://mart.webz.cz

Popis
Program ve stanovený čas vypne počítač. Stačí zadat datum a čas vypnutí.
Pokud probíhá nějaká operace, je násilně ukončena.
Program lze spustit s parametrem, který určí datum a čas vypnutí (viz. nápověda).

Program funguje pod Win 9x/Me/NT/2000/XP.

Verze
1.0 - První verze programu
1.1 - Přidána minimalizace do systémové oblasti (system tray)
1.2 - Upraven vzhled programu, přidána podpora spuštění s parametrem, nápověda.
1.3 - Opravena chyba při vícenásobném spuštění

Licence
Tento program je Freeware.
Šíření je povoleno pouze v původní podobě.
Autor neručí za škody způsobené přímo či nepřímo použitím tohoto programu.


Hlavní okno programu

Po spuštění programu se zobrazí hlavní okno.

Hlavní okno programu

1 - Do těchto políček se zadává datum vypnutí ve formátu D.M.RRRR
2 - Do těchto políček se zadává čas vypnutí ve formátu HH.MM.SS
3 - Aktuální datum
4 - Aktuální čas
5 - Zobrazí okno s informacemi o programu
6 - Spustí/Zastaví časování vypnutí
7 - Minimalizace do systémové lišty


Spuštění s parametrem

Program ForceExit jde spustit s parametrem, který určuje datum a čas vypnutí.

Tuto funkci můžete použít, pokud chcete program automaticky spustit (přes plánovač úloh, po startu windows, ...) a nastavit kdy má vypnout počítač.

Použití:

forceexit.exe start-D-M-R-h-m-s

D - den
M - měsíc
R - rok
h - hodiny
m - minuty
s - vteřiny

Příklad:
Potřebujete vytvořit zástupce, po jehož puštění se spustí ForceExit s nastaveným vypnutím 15.2.2004 v 17:03:00.

Normálním způsobem vytvoříte zástupce, kliknete na něj pravým tlačítkem a dáte Vlastnosti. Na kartě Zástupce zapíšete do políčka Cíl následující: "C:\...cesta k programu...\ForceExit\forceexit.exe" start-15-2-2004-17-03-00


Nápověda programu ForceExit

  • Informace

  • Hlavní okno programu

  • Spuštění s parametrem