first step

補償

これらのプログラムにおいて発生したいかなる問題に対しても、作者およびサークルは補償する責任を一切負いません。

アプリケーションの使用目的

テキストファイル等を ぶいぶい かっこよく 見るのに使用します。（ver 1.1 からテキストファイルの編集も出来るようになりました）

インストール

アンインストール

操作方法

環境設定

モジュール

ライセンス

最新版

マニュアルの変更個所

ver 1.1 以前のマニュアルとこのマニュアルでは、次の個所に変更があります。

操作方法

ver 1.0 以前のマニュアルと、このマニュアルでは、次の個所に変更があります。

操作方法

環境設定

モジュール

メディアプレイヤーコントローラー

動作環境。Windows 95/98,Windows 2000

メモリーが、いっぱいいります。
ビデオカードも、「つおい」のでひとつ、お願いします。
CPUも、スパコン並で。
スレッドはメインとファイル監視スレッドしか無いので、マルチでなくてもOKです。

Windows 95,NTでの動作確認は行っていません。

Contact : nakoru@io.ocn.ne.jp
Web page: http://www4.ocn.ne.jp/~techroid/
Vector Shareware Registration Service : SR006618


INDEX

VISION

- 4th -

version 1.4

synapse.jpg (1716 バイト)

TECHROID

導入

このマニュアルは、VISION version 1.4.1 公開時( date 03/24.2001)に作成されたものです。


INSTALL

インストール

ディレクトリつきで圧縮アーカイブを解凍してください。

解凍されたファイルをディレクトリごと好みの場所に移動して使用します。メインアプリケーションは、VISION4.EXE です。

アドオン(Module)のDLLファイルは、Moduleフォルダの中に存在しないと読みこまれません。

解凍後のディレクトリイメージは、こんな感じになります。VISIONのディレクトリごと移動するのであれば、あとで移動しても動作します。

VISION +
       +- (SETUP.exe)
       +- VISION4.EXE
       +- VISION4.CHM
       +- MANUAL.TXT
       +- README.TXT
       +- README2.TXT
       +- UNINSTALL.EXE
       +- 他
       +- MODULE +
                 +- IMAGELOAD.DLL
                 +- VWATCH.DLL
                 +- MEDIA.DLL
                 +- LINEBUF.DLL

インストーラ SETUP.exe が付属しているパッケージをダウンロードされた方は、SETUP.exe を実行してもらってもかまいません。

インストーラー は、ユーザーの指定するディレクトリ（Program Files等）にVISIONのファイルを移動します。また、送るメニューやスタートメニューにショートカットを登録します。

付属のアンインストーラーUnInstall.exeでそれらは削除可能です。

SETUP.exeのデュプリケイトは作成されないようになってますが、既にセットアップされた環境でSETUP.exeが実行されるとどうなるか検証してないので、それはやらないようにしてください＾＾；

ユーザーカスタマイズ情報の保存

レジストリを使うか、INIファイルを使うかユーザーが選択できます。

このアプリケーションは、初回起動時に、アプリケーション情報およびユーザーカスタマイズ情報を保存するために、レジストリを使用するかアプリケーションと同じフォルダに環境設定ファイルを作成して保存するか聞いてきます。問いに対し「いいえ」を選択すると、アプリケーションと同じフォルダに環境設定ファイルを作成します。レジストリを使うようにしたい場合は、「はい」と答えてください。

注意：旧VISION (First VISION,Second VISION, 199?-1999) の INI FILEは使えません。

レジストリ→INIファイルへの移行（または、その逆）

レジストリからINIファイルへ移行（または、その逆）がしたい場合、それらを切りかえるには、VISIONのフォルダ内に、REGINI.TXTという名前でテキストファイルを作成します。（内容は、空で結構です。）

そうすると、再び VISION 起動時に、レジストリを使うかINIファイルを使うか選択できるようになります。一度、起動すると、REGINI.TXTは、自動で削除されます。

レジストリを使うように一度設定した場合、UnInstall.exeで、それらのレジストリ情報は削除できます


UNINSTALL

アンインストール

アンインストールは、レジストリを使用した場合と、使用しなかった場合とで方法が違います。

レジストリを使わなかった場合

本アプリケーションのファイルを全て削除してください。

レジストリを使った場合

本アプリケーション付属のUnInstall.exeよりレジストリ情報を削除した上で、ファイルを全て削除してください。

レジストリキーを検索して確認したい場合などには TECHROID または VISIONで検索すれば、すぐに見つかると思います。


メインウィンドウ
機能
テキストを編集する方法 左上にある ■ をクリックするか、キーボードのF2キーを押すと、
観覧モードと編集モードを切り替えることが出来ます。

編集中、ウィンドウ内で右クリックをすると、編集メニューが開きます。
ドラッグで領域の選択なども出来ます。

編集モードの時の■の色は、アクティブカラー（デフォルトは赤）になります。
また、ファイルメニュー、モジュールメニューを操作した時、編集中のウィンドウが非アクティブになった時には、自動的に観覧モードに戻ります。

ウィンドウを閉じる方法 | 右上にある x をクリックします。（アプリケーションも終了します）
ウィンドウを最小化する方法 | 右上にある _ をクリックします。
ウィンドウの大きさを変える方法 | 右下にある / をドラッグするか、右端をドラッグします。
スクロールバー | スクロールバーは、右端にある幅１ドットの黄色の線です(^^;
File

 NEW

新しいウィンドウを作成します。

Open File

WINDOWSが提供するエクスプローラーでフォルダを開きます。
ファイル選択ダイアログ等は付けないことにしました。
これで開いたエクスプローラーからドラッグ＆ドロップでファイルを読みこませます。

Save File

読み込まれているテキストファイルの内容を保存します。

クリックすると、ファイル名入力ダイアログボックスが表示されるので、保存したいファイルの場所と名前を入力してOKを押すと保存します。同名のファイルがある場合は、上書き確認のダイアログが表示されます。

ファイル名入力ダイアログボックスに、フォルダやファイルをドロップすると、フォルダ名を代入することができます。

CLEAR.

現在、表示中のテキストをクリアします。（この時点で、ファイルには影響ありません）

SETUP

環境設定ダイアログを表示します。

Help

ヘルプ（マニュアル）を表示します。

CLOSE

ウィンドウを閉じます
Notify クリックすると、ファイルの監視を監視する・しないを切り替えます。
デフォルトは、「しない」です。
最終的に日時をみて判断しますので、日時が同じ場合、ファイルの更新検出しても無かったことにします(笑)
Auto テキストファイルの自動送りをする・しないを切り替えます。

旧バージョンの「マウスクリックでスクロール」みたいなものですが、今回は、オンにすると、勝手にテキストが流れます。また、テキストファイルの最後に到達すると先頭に戻って「つなげて」表示します。
Zoom 虫眼鏡のようなものです。ドラッグすると移動します。ダブルクリックで拡大。右クリックで、倍率を１倍に戻し、元のボタンの位置に戻ります。
倍率の変更はホイールマウスにも対応しています。
Module

 現在読みこまれているモジュールの一覧を表示します。モジュールリストをクリックすると各モジュールの表示・非表示状態を切り替えることが出来ます。（各モジュールの仕様に従います）

See also:

環境設定

モジュール


環境設定

環境設定 [ system ]

 | 機能
Version check | インターネットに接続し、TECHROIDのウェッブサイトの最新情報ページをブラウザで表示します。
refresh | 半透過の作業用画像を取得しなおします。 VISIONの背景が、VISIONの背景に焼き付いてしまったような状態になった時などにも利用できます。ウィンドウを非アクティブ・アクティブに切り替えただけでも同様の効果があります。通常は、後者の方法で良いと思います。
center | 半透過ウィンドウを画面の中央に持ってきます。
show | Layer機能を使う・使わないを切り替える時に、レイヤー構築システムがタイムアウトして全てのVISIONウィンドウを表示しない場合があるかも知れません。そんな時、このボタンを押してみてください。
hide | 意図的にVISIONウィンドウを全て閉じる場合に使用します。デバッグ用。
再描画の優先度 | VISIONにおいてアニメーション等を実現する場合に使用する、リアルタイム再描画スレッドの優先度です。Idleだと、アニメーションなどの処理中、他のアプリケーションなどでCPUに大きな負荷がかかっている場合、再描画の間隔が少なくなりますが、マウスやキー操作等に機敏に反応できるので推奨する設定です。HigherだとVISIONが実行中のモジュールで負荷が高い場合に、マウスやキー操作等への反応が鈍くなる場合があります。
Opening | チェックすると、新しくVISIONウィンドウを開く時にアニメーションします。
Notify- Retry | ファイル監視でファイルの再読み込みで問題が起こった場合のリトライ回数です。
Notify- Wait | リトライまでの待ち時間をmsec単位で入力します。（1000→1秒）
use W2K Layer | LayerをチェックするとMicrosoft Windows 2000でレイヤー機能を使用します。と同時にVISIONの半透過エンジンは使わない設定になります。 レイヤー機能を使った半透過では、文字なども半透過するため見にくいかもしれませんが、背景画像の取得を行わないためウィンドウの切り替えは高速になります。また、VISIONの部分拡大機能は使えなくなります。
Capture wait | VISION半透過エンジンがデスクトップをとりこむ際にＯＳに与える再描画のチャンスの時間をmsec単位で指定します。
Light Level | 半透過の度合いです。（1が最も明るい）
Scroll wait | スクロールスピードです。0 から 1000で指定します。0 が最も高速。 同時に、スクロールの滑らかさでもあります。0だと１行ずつスクロールします。1000だと1/1000行ずつスクロールします。P2 450Mhz Riva TNTで推奨は、3～5 程度です。
WordWrap | 半透過ウィンドウ部のテキストファイル表示で、ウィンドウからあふれた文字を折り返して次の行に表示させる場合には、チェックボックスをチェックします。折り返しする設定の場合、テキスト編集モードでちらつきます。
UPDATE | 変更した内容を適用します。
CLOSE | 環境設定ダイアログを閉じます。
以下は、ライセンス購入後、試用の状態を解除するのに使用します。 |
User name | ライセンスキー発行依頼で用いたユーザー名を入力します。
Licence Key | TECHROIDやライセンスキー発行の仲介業者から配布されたライセンスキーを入力します
regist | ユーザー名とライセンスキーを入力したら、このボタンを押すと、入力された内容が正しければ、試用の状態が解除されます。

環境設定 [ Color ]

左上の色のついている箱の部分をクリックすると各部の色やテキストファイルの表示に使用するのフォントの変更をすることができます。スクロールバーで、半透過ウィンドウの色情報減衰率にRGBのフィルタを設定することができます。

加算チェックボックスがチェックされていると、重なっている部分が徐々に白に近づきます。デスクトップの背景が白っぽい場合、チェックをはずし、黒っぽい場合、チェックするとよいかと思います。

blue thruとgreen thruの例

モジュールの描画領域には適用されません。VISIONウィンドウが重なれば、その影響は受けます。

環境設定 [ Modules ]

モジュールの設定を参照してください。

See also:

操作方法

モジュール


モジュール
モジュールとは

各VISIONウィンドウの右端に並んでいる上図のようなものです。これは、機能を拡張するもので、VISIONでは、時計や、画像ビュアーやMIDIプレイヤー、天気予報など様々な機能を後から追加する機能全般を言います。VISIONのモジュールの開発方法に関しては、TECHROIDのウェッブサイトをご覧下さい。

モジュールは、VISION起動時に読みこまれます。モジュールは、各ウィンドウ毎にモジュールの実体が作成されます。モジュールが非表示・表示状態の時にどのように動作するかは、各モジュールによります。

モジュールファイルの場所

また、モジュールのファイル(*.DLL)はVISIONのフォルダ下層のModuleフォルダに格納されていなければ、読みこまれません。

表示位置の移動

モジュールは通常、上図のように、縦に並びます。（描画の優先順位とは関係有りません）

モジュールは、クリックした後、キーボードの[ U ]と[ D ]キーで上下に移動させることができます。

ユーザーインターフェース

モジュールは、基本的に、VISIONウィンドウの右端に並びますが、下記の例の画像ビュアのようにそうでないものもあります。その場合、各モジュールの開発者は、モジュールの操作のためのインターフェースを本来のモジュール位置で提供するなどの工夫が必要です。

標準添付のモジュール

VISION WATCH (アナログ時計)

現在時刻を表示します。

LINEBUFFER VIEW

読みこまれているテキストファイルの１文字を１ドットで表示し、任意の単語をハイライト表示します。

IMAGE VIEW:

画像ファイルBMPとJPGを表示します。

MEDIA PLAYER CONTOROLLER

メディアプレイヤー を操作します。

※メディアプレイヤー: Windows Media Player ver 6.4を対象とします。
Windows Media Player version 6.4 (C)1992-1999 Microfost Corp.
web site: http://www.microsoft.com/

モジュールの設定
モジュール自体の設定がある場合は、モジュールごとのマニュアルを参照するかモジュール開発者に問い合わせるなどしてください。

ここでは、モジュールの描画の優先順位とモジュールをVISIONに読み込まない方法を説明します。

ファイルメニューからSETUPを表示させます。Modulesタブを開きます。

モジュールの描画の優先順位

通常、この操作は必要ありませんが、各モジュールが持つメニュー（ポップアップメニューなど）の文字が見にくい場合などに、優先順位を高くして見やすくする場合に操作します。

モジュールの描画の優先順位を変更するには、モジュールリストからモジュールを選択して、「上へ」と「下へ」でリストの順を変更します。

下にあるものほど、優先順位が高くなり、他のモジュールに重なるオブジェクトを持っている場合、そのオブジェクトを他のモジュールの上に描画することになります。

モジュールの描画の優先順位とは、VISIONウィンドウの再描画時に、モジュールを描画する順番の事で、遅いものほど上に描かれます。したがってモジュール開発者がモジュールの半透過率を低く設定した場合、そのモジュールが前に描かれたモジュールの上に重なるような何かを描画した時、前に描かれたモジュールが見づらくなります。見づらくなるのを防ぐには、そのモジュールより後に描く必要があるので、ここで、「下へ」を押して、そのモジュールの下に移動させます。

モジュールの読み込み

モジュールを読みこまないようにするには、各モジュールのチェックボックスをオフにします。

VISIONのメインメニューで、モジュールの表示・非表示状態の切り替えは出来ますが、VISION再起動後には、各モジュールの初期設定に応じて表示・非表示が決定されます。常に表示しないようにするには、モジュールの読み込みを行わないように、ここで設定してください。

変更の適用

UPDATEを押すと、VISIONのウィンドウを全て閉じてモジュール管理システムを再構築します。

補足

読み込まれていないモジュールの名前やバージョン情報は、( don't know )と表示されます。

See also:

操作方法

環境設定


MEDIA

モジュール #4 メディアプレイヤーコントローラー( MEDIA PLAYER CONTROLLER)
目的

VISIONからメディアプレイヤー( Windows Media Player)とActiveMovieを操作し、VISIONのウィンドウでメディアファイル(MIDIファイル や MOVIEファイル)を観覧するのに使用します。

※Windows Media Player, ActiveMovie (C)Microfost Corp.

基本操作

メディア定義で再生するように定義されたファイル(ムービーファイル等)を読みこんだ時、メディアプレイヤコントローラをユーザーが可視状態にした時、VISIONウィンドウの中央にブルースクリーンと右側のモジュール領域に、メディアプレイヤコントローラ（以下コントローラ）が表示されます。

中央のブルースクリーンは、クリックしても反応しません。操作は、モジュール領域のコントローラから操作します。

コントローラをクリックすると、再生・停止を行うことができます。コントローラで右クリックをするとポップアップメニューが開きます。

プレイリスト(*.M3U)を読み込んだ時は、コントローラーに、ポジションコントロールボタンが表示されます。

これをクリックすることで、プレイリストのポジションを戻したり、進めたりすることが出来ます。

 一番上

ファイル名表示
PLAY

再生

STOP

停止

prefense

CENTER

ウィンドウの中央に表示、モジュール領域に表示 の状態を切り替えます。

100%

メディアのオリジナルのサイズで表示、ウィンドウサイズにあわせて表示 の状態を切り替えます。

REPEAT

繰り返し再生

MUTE

音消しの有効・無効 の状態を切り替えます。

REALTIME

再生時にVISION本体にリアルタイム再描画を要求します。初期状態で有効になっています。

有効になっていると、CPUに余裕がある限り、再描画を繰り返します。無効になっているときは、アイドリング状態ならば0.5秒に１度、再描画します。

CLOSE

メディアを閉じます。

CENTERを解除すると、モジュール領域に表示されますが、この時の操作は、この領域の上で行います。

動作環境

Windows Media Player (C)1992-1999 Microfost Corp. version 6.4.07.1112 とActiveMovie 2.0コントロールが正しくインストールされている必要があります。

動作確認 WINDOW 98 + IE 5 + Media Player 6.4,
WINDOWS 2000
Think Pad 235 + WINDOWS 98 + IE 5 + Media Player 6.4;

このモジュールを使用しない場合は、モジュール自体を削除してください。

メディアプレイヤーに読みこませるファイルの設定

VISIONのモジュールフォルダに、Mediadll.ini (MediaDLL.INI)が存在する場合、その内容に従い、VISIONでファイルを開いた時に拡張子が一致すれば、メディアプレイヤーに渡します。

Mediadll.iniには、各行の先頭から大文字でピリオド付の拡張子を羅列します。

例

.AVI
.MPG
.WAV

このファイルが存在しない場合は、初期設定に従い処理します。
初期状態は次のとおり。

.MID
.MIDI
.RMI
.MP3
.M3U
.WAV
.WMV
.AVI
.IVF
.MPG
.MPEG
.MPE
.M1V
.MP2
.MPV2
.MP2V
.MPA
.MOV
.QT

プレイリスト

メディアプレイヤーはプレイリストに対応しているようです。
拡張子.M3U でファイルの内容には、ファイル名を羅列します。

例

godaigo\gandahra.mp3
godaigo\GEXP999.mp3
godaigo\holy&bright.mp3
godaigo\monkymagic.mp3
godaigo\namaste.mp3
godaigo\thankubaby.mp3

プレイリスト M3U ファイルがおいてある相対ディレクトリで構いません。

また、サウンドファイルとムービーファイルが混在していても構いません。

不具合

・VISION終了後、タスクバーにVISIONが残る不具合があります。
約 5 秒後にVISIONのターミネータが正常終了するように試みますので、そのままにしておいてください。

※メディアプレイヤー: Windows Media Player ver 6.4を対象とします。

copyright

Windows Media Player version 6.4 (C)1992-1999 Microfost Corp.
web site: http://www.microsoft.com/

See also:

操作方法

モジュール


オンラインアップデート

su_online.jpg (35733 バイト)

  1. VISIONウィンドウの[FILE]メニューからSETUPをクリックして、Vision Setupダイアログを表示します。
  2. Online Updateをクリックします。
  3. 最新のファイルがオンラインアップデートサーバーにある場合は、Patchボタンが押せる状態になるので押します。
  4. ウィンドウを閉じます。

VISION本体や、モジュールなどが更新された場合は、VISION本体の再起動が必要となります。

その場合、オンラインアップデートシステムが、本体の終了を要求してきます。

VISION本体を終了すると、自動でファイルの更新作業が行われVISIONが再び起動します。

注意

オンラインアップデートサーバーが、メンテナンス中であったり、サービスを中断している場合は、利用できません。

また、Online Updateボタンを押さないと、オンラインアップデートサーバーには接続されません。

オンラインアップデート利用者は、オンラインアップデート規約に同意しているものとします。
（規約に関しては、ライセンス　を参照してください）

仕様

オンラインアップデートシステムは、ローカルファイルのバージョン情報を local_version.txt で管理しています。
これに記載してあるバージョンは実際のバージョンと違う場合があります。オンラインアップデートシステムでのバージョン情報となっています。
このファイルを削除すると、全てのファイルのダウンロードしなおします。

proxyへの対応

proxyを介す場合は、VISION4.exeのあるディレクトリに、テキストファイル 「server.txt」 を作成し次のように編集します。

PROXYは半角大文字で書いてください。サーバーアドレスとポートの間を区切るのは半角のコロン「：」です。

PROXY=<proxy server address>:<port>

例

PROXY=192.168.0.5:8080
PROXY=www.proxyexample.corn:8080

など

www.proxyexample.cornは実在しないと思いますが定かでありません＾＾；

See also:

ライセンス


latest version

Contact : nakoru@io.ocn.ne.jp

Web page: http://www4.ocn.ne.jp/~techroid/

最新版のアプリケーション本体、マニュアル等は上記 Web page からダウンロードできます。


ライセンスについて

なんらかの業務に使用する場合、試用期間をすぎてご利用になるには、ライセンスを購入していただく必要があります。

以前、VISIONのライセンス購入いただいた方は、同一ライセンスでご利用いただいて結構です。同じライセンスキーでご利用になれます。

金額は、500円（消費税・各種手数料は含みません）です。

個人のライセンス

個人は、一人１ライセンスが必要です。インストールするコンピュータの台数は無制限です。ただし、このソフトウェアがライセンスを購入していない方に使用されることがあってはなりません。（試用期間は適用されます）

ライセンス購入の際の送金には、ベクター・シェアレジ（Vector Shareware Registration Service）を利用してください。
http://www4.ocn.ne.jp/~techroid/techroid/index.html にて、シェアレジサービスへリンクしています。ライセンスキー紛失時の再発行などもベクター・シェアレジでサポートしてくださっています。

または、銀行振込を利用してください。TECHROID指定の口座に振込にてライセンスを購入した場合、ベクター・シェアレジでのライセンスキーの発行・再発行などはできません。この場合は、TECHROIDから直接、電子メールにてライセンスキーの発行・再発行を行います。したがって、銀行振込を利用されるかたは、ご自分の電子メールアカウントをお持ちの方で常に電子メールが利用可能な方に限らせていただきます。

なお、返金は、いかなる理由があろうとも致しません。

法人のライセンス

法人でライセンスをご購入なさる方は、コンピュータ１台に１ライセンス必要です。

インストールするコンピュータの数×500円（消費税・各種手数料は含みません）をお支払いください。ライセンス購入分のコンピュータにインストールすることができ、そのコンピュータにインストールされた状態にあるこのアプリケーションは誰でも利用することが出来ます。法人でご登録なさる場合は、nakoru@io.ocn.ne.jp まで御連絡下さい。法人の場合、申し出があれば、ライセンスの証書、領収書を発行します。

なお、返金は、いかなる理由があろうとも致しません。

試用期間

はじめてこのソフトウェアを使用した日から数えて２週間です。

試用中の機能的制限

機能的制限は、ありません。試用中の間は、本アプリケーションの右下にTECHROIDのロゴにTRIALと書かれたバナーのようなものが表示されます。

←これ

オンラインアップデートについて

オンラインアップデートサーバーがメンテナンス中、あるいはサービスを中断している場合は、利用できません。

オンラインアップデート利用者は下記の規約に同意したものとします。

オンラインアップデート規約
・オンラインアップデートを利用した結果発生したいかなる問題に大しても、私および当サークルは保証する責任を一切負いません。各自の責任でご利用ください。

・オンラインアップデートサービスは、当方の独断によりサービスを中止する場合があります。

・オンラインアップデートサービスで得たファイルや情報の二次公開を禁止します。

・これらの規約は将来予告なく変更される場合があります。

・以上を利用者は了承しているものとします。

モジュールについて

モジュールは、VISION全体の機能を書きかえるだけのことが可能で、モジュール製作者の技術と意思により、どのようなアプリケーションへも変化します。したがって、モジュールを導入した結果、VISIONのマニュアルに書かれている内容と一致しない場合が出てきます。そのような場合モジュールの製作者に使用方法などを問い合わせてください。

モジュールの開発方法については、

TECHROIDのウェブサイトをご覧下さい。

モジュールのライセンス規定

1.これらのモジュールおよびプログラムコードを使用することによって発生した、いかなる問題に対しても、私および当サークルは補償する責任を一切負いません。

2.サンプルコード（コンパイル済み、ソースコードともに）の改変したものの配布は、非営利は良識に基づく範囲で自由。営利は、許可制とします。VISION本体とあわせての販売などは禁止。相談には乗るかもしれません。

3.モジュールサンプルコードおよび機能の改変されていない部分については、当方が著作権を保持し、後から追加した部分および改変した部分の著作権は各製作者の意思に従うものとします。

4.モジュールを製作し使用することは、改造行為にあたるものとします。したがって、その結果生じた損害等は各自の責任とし、私および当サークルへのなんらかの請求には応じません。

5.特許が主張されているものを組み込んで公開する場合などには、そのモジュールの管理者側で特許料の支払いなどを行ってください。私および当サークルはそれらが組み込まれて使用されることを想定していません。

6.公開されているモジュールに対し何らかの問題が発生した場合、(5.とか)モジュールの配布の中止を要求する場合があるかもしれません。その場合、すみやかに従っていただくものとします。

7.VISIONのライセンスを侵害するようなモジュールの公開を禁止します。

VISIONのパッケージに含まれるモジュールのライセンス

VISIONのパッケージに含まれるモジュール、

VISION WATCH,
LINEBUF VIEW,
IMAGE VIEW、
MEDIA PLAYER CONTROLLER

これらはフリーウェアとします。

これらのライセンス規定は、私の良識に従う範囲で将来予告無く変更される場合があります。ご了承下さい。

通常のバージョンアップは無料です。
ただし、入手にかかる費用（通信費など）は、各自でご負担ください。
フロッピー版の配布などは、現在のところ行っておりません。

最新版は、http://www.techroid.net/ で入手可能です。

オンラインアップデートを利用すると、最新版の状態になります。