Virtual Diskとは

Virtual Disk For Windows XP に関心をお持ちいただきありがとうございます。
これは、仮想CD-ROMドライブを作成して、本物のCD-ROMドライブを使用しなくてもCD-ROMを使用できるようにするためのアプリケーションです。また、おまけとして仮想ハードディスクを作成したり、任意のドライブをエクスプローラ上から見えないようにすることもできます。

Virtual Disk For Windows XP の使用によりたとえば以下のような利点があります。

  • CD-ROMの読み込み速度が向上します。
  • CD-ROMドライブを使わなくてもCD-ROMが使用できます。ノートパソコンでCD-ROMの必要な辞書や地図などをインストールしたい場合にも、いったん仮想CDを作成してしまえばCD-ROMドライブやCD-ROMを持ち運ばずにすむので快適です。
  • やたらとうるさいCDの回転音を聞かずにすみます。また、CDが回転し始めるのを待つ必要もありません。
  • よく使う複数のCDをいちいち入れ替える必要も無くタスクトレイから簡単にCDを切り替えることができます。
  • CDの出し入れでCDを傷つけたり失ったりする心配がなくなります。
  • CDファイルを圧縮して格納することもできるので、単純にファイルをコピーする場合と違ってハードディスクの空き容量が気になる場合も安心です。圧縮機能はOSのそれと比べてもはるかに強力です。

注意 : このドキュメントはリリース時の情報を元に書かれております。したがって予告なく内容等が変わることがございますがご了承ください。また、このアプリケーションはまだ開発途上ですので最新版が出ていないか適宜チェックしてください。特に最新版のページ(http://hp.vector.co.jp/authors/VA014116/soft/)以外の場所から入手された場合は今一度ご確認ください。

このアプリケーションがリリースされてから発見された既知のバグ及びFAQも最新版のページで随時紹介していきますので、何かあればこちらもご参照下さい。

また、設定アプリケーションには状況依存のヘルプがついていますので、知りたい項目があるところでヘルプボタンあるいはF1キーを押すと対応するヘルプが表示されます。


ご使用の前に

ご使用の前にとても重要な注意事項があります。

このアプリケーションは、私の動作確認環境では十分にテストいたしましたが、その他の環境では、特に以前のバージョンからの修正、変更点については十分にテストされていません。

仮想CD-ROMのデバイスドライバを私が作成している以上、それが原因で予期せぬ不具合を引き起こし、システムそのものが停止してしまう可能性があるのです(いくら堅固なWindows XPでも、カーネルモードのデバイスドライバはほんのわずかなミスでシステムそのものを止めてしまうのです…)。また、ありもしないCD-ROMドライブが突然システムに現れるというその性質から、ハードウェア的な相性の問題も考えられます。このアプリケーションはそのようなデバイスドライバを用いているという点において他のものと比べてかなり特殊だということを念頭においていただくようお願いします。

万一、ドライバのロード時(OSの起動中)にデバイスドライバの不具合や相性問題等によりシステムが停止してしまうと、Windows XPが起動できなくなってしまいますが、OSのインストールCD-ROMから起動し、回復コンソールを使用することによってドライバを削除すれば、起動することができます。以下でその方法について説明いたします。

念のため、以下の説明は印刷して保存しておくことをお勧めします。

もし、起動中にトラブルが発生して起動できなくなったら、
・いったん電源を切って、OSのインストールCD-ROMから起動します。
・"セットアップの開始"画面でRを押して、修復を選びます。
・どのWindowsにログオンするかと聞かれた場合はアプリケーションをインストールしたWindowsを選択します。
・Administratorのパスワードを聞かれるので入力します。
(XP HomeのAdministratorの初期パスワードは空です)
・WindowsXPのインストール先フォルダをカレントディレクトリとして、
プロンプトが現れるので、以下のコマンドを入力します。
disable vcddrv (Enterキー)
この時点で無効にされた旨のメッセージが出るので確認して、再起動のため次のコマンドを入力します。
exit (Enterキー)
・本アプリケーションが原因であった場合、その後システムが起動できるはずなので、オプションを変更するか、アプリケーションをアンインストールしてください。本アプリケーションが原因と関係ない場合はこの方法は無効です。

また、上記回復コンソールはOSの起動中、OSのインストールCD-ROMの \i386\winnt32.exe に /cmdcons オプションをつけて実行することにより、ハードディスクにインストールし、OS起動時のOS選択メニューから起動することができるようになります。別に本アプリケーションが原因でなくても、緊急時に修復が容易になるのでぜひハードディスクにインストールしておくことをお勧めします。

その他わからないことがあれば必ずインストール前にご質問下さい。
また、使用中、新規ハードウェア(特にCD-ROMやDVD-ROM)を追加された時にうまく動作しない場合、まず本アプリケーションとの相性問題でないかどうかを疑ってください。


動作環境

このアプリケーションはWindows XP Home Edition/Professional Edition build 2600 (正式リリース版)上でのみ動作します。その他のOSでは動作しませんし、インストールもできません。

作者が動作確認しているシステム

ノートPC
CPU: Mobile PentiumII 400 MHz
RAM: 192MBytes
HDD: 20GBytes
・Windows XP Professional Edition Japanese Build 2600


使い方

全体の流れ

ここでは、実際に仮想CD-ROMを作成して、それを使用するまでの流れを説明します。

  1. Virtual Disk for Windows XPを起動します。これは、スタートメニューの[プログラム]→[Virtual Disk for Windows XP] の中にあります。
  2. そこで、"CDから仮想CDの作成"タブを選択します。すると仮想CDを作成する画面に移動します。
  3. 読み出し元のCD-ROMのドライブレターと、仮想CD-ROMファイルの作成先を指定します。仮想CD-ROMファイルの拡張子は.qcdですが、ない場合自動的に付加されます。また、CDを区別するための名前も指定してください。なお、仮想CD-ROMファイルは、絶対パスで指定してください。圧縮する場合は圧縮にチェックを入れてください。
  4. 次に作成ボタンを押すと、仮想CD-ROMファイルを作成します。無事完成すると、メッセージが出ますのでOKを押してください。
  5. 仮想CD-ROMファイルを作成し終えたら、次に"CDリスト"タブを選択し、先ほど作成したファイルがリストに登録されているか確認してください。
  6. "仮想CDのマウント"タブを選択すると、仮想CD-ROMドライブとして割り当てられているドライブの状態がVirtual CD-ROMと表示されているので、その行を選択して変更ボタンを押すかあるいはダブルクリックします。
  7. するとダイアログが現れるので、先ほど登録した仮想CD-ROMファイルを指定してください。そしてOKを押してください。するとその仮想CD-ROMファイルが仮想CD-ROMドライブにマウントされます。
  8. 元のドライブ一覧の画面に戻ったら、状態の部分が指定した仮想CD-ROMファイル名になるのでそれでよければOKを押してください。
  9. また、先ほどのドライブのタイプを設定する画面で、"隠す"にチェックを入れると、そのドライブは再起動後に"エクスプローラで"表示されなくなります。ちなみに、その他のアプリケーションやコマンドプロンプトからはアクセスできるのでご注意ください。
  10. さらに、空いているドライブレターを選択して変更を選び、ドライブのタイプを仮想ハードディスクドライブにすると、任意のフォルダをハードディスクのドライブとして見せかけることができます。よく使うフォルダなどをドライブに割り当てるとすばやくアクセスできて便利かもしれません。


設定アプリケーションの使い方

設定アプリケーション(VDisk.exe)では、いろいろな設定を行います。各タブの詳細については以下をクリックしてください。

* 仮想CDのマウント
- ドライブタイプの変更
* CDリスト
- プロパティ
* CDから仮想CDの作成
* フォルダから仮想CDの作成
* オプション
* About


仮想CDのマウント

仮想CDのマウント : ここでは各ドライブの設定を変更します。

  • メインのリストビュー
    • ドライブ : ドライブレターです。
    • 種類 : ドライブの種類です。
      • Removable Drive : リムーバブルメディア(フロッピー、MOなど)です。
      • Fixed Drive : ハードディスクドライブです。
      • Network : ネットワークドライブです。
      • CD-ROM : 本物のCD-ROMドライブや、他の仮想CD-ROMアプリケーションのドライブです。
      • RAMDISK : RamDiskです。
      • Virtual CD-ROM : このアプリケーションが仮想的にマウントしたCD-ROMドライブを表します。
      • Virtual HDD : このアプリケーションが仮想的にマウントしたハードディスクドライブを表します。
      • Not Used : 現在使用されていないドライブです。
    • 状態 : ドライブの状態を表します。
      • System Drive : システムが使用しているドライブです。
      • 空 : 使用されていないか、中身が空の仮想CD-ROMドライブです。
      • ファイル名 : 仮想CD-ROMのファイル名です。
      • フォルダ名 : 仮想HDDにしているフォルダ名です。
      • (Hidden) : このドライブはエクスプローラから見えません。ただし、コマンドプロンプトなどからの直接指定などではアクセスできます。
      • (再起動後) : 再起動後に設定が有効になります。
  • 変更 : 選択されたドライブのタイプを変更します。


変更

変更 : 選択されたドライブのタイプを変更します。

  • ドライブのタイプ : ドライブのタイプを設定します。
    • システムドライブ : システムが使用しているドライブなので隠す以外の設定を変更できません。
    • 未使用 : そのドライブを未使用状態にします。
    • 仮想ハードディスクドライブ : そのドライブレターを仮想ハードディスクドライブとして使用します。このときには次のテキストフィールドが現れます。
      • 仮想ドライブ化フォルダ名 : 仮想ドライブとして使用するフォルダ名を指定します。存在しないフォルダは指定できません。また、Selectボタンを押すとフォルダを選択できます。フォルダ名の最後には'\'をつけないでください。付けるとあっても存在しないと判断されてしまいます。
    • 仮想CD-ROMドライブ : そのドライブレターを仮想CD-ROMドライブとして使用します。このときには次のテキストフィールドが現れます。また、ドライブのタイプは変更できません。
      • 仮想CD-ROMファイル名 : 仮想CD-ROMとして使用するファイル名を指定します。仮想CD-ROMファイルは、CDリストの編集で登録したものがコンボボックスに表示されるのでそこから選択してください。存在しないファイルは指定できません。また、ここを空にする(コンボボックスの一番下を選ぶ)と仮想CDをアンマウントできます。
      • ドライブレター : 仮想CD-ROMドライブのドライブレターを変更します。仮想CD-ROMドライブは、ここでしかドライブレターを変更できないのでご注意ください。
  • 隠す : このドライブレターをエクスプローラから見えないようにします。ただし、コマンドプロンプトなどからの直接指定などではアクセスできます。したがって、セキュリティ的な意味はまったくないので注意してください。
  • キャンセル : 設定をキャンセルする場合に押してください。
  • OK : その設定でよければ押してください。


CDリストの編集

CDリスト : 使用する仮想CDファイルを登録します。

仮想CDの選択はここに登録されているものからのみ可能です。 仮想CDの作成画面でCDリストに追加を選択しなかったり、すでに作成した仮想CDがある場合はこの画面で登録してください。エクスプローラから.qcdファイルをドラッグ&ドロップしても登録可能です。

  • 登録されたCDのリスト : 登録されているCDのリストを表示します。
  • 追加 : 選択画面が出ますので、追加したいCDを選んでください(複数選択可)。そのCDをリストの最後に追加します。
  • 削除 : 選択したCDをリストから削除します。
  • 上へ移動 : 選択したCDをリストのひとつ上へ移動します。
  • 下へ移動 : 選択したCDをリストのひとつ下へ移動します。
  • プロパティ : 選択したCDのプロパティを表示します。
  • 整理 : リストに登録されている仮想CDの中で、削除、移動などで実体がすでに無いファイルをリストから削除します。


プロパティ

プロパティ : 選択された仮想CDファイルのプロパティを表示します。

  • CDファイルのバージョン : 仮想CDファイルのバージョンを表示します。
    • バージョン3以下 : Virtual Disk for Windows NTを用いて作成されたものです。
    • バージョン4 : Virtual Disk for Windows 2000を用いて作成されたものです。
    • バージョン5 : Virtual Disk for Windows XPを用いて作成されたものです。

    バージョン3と4と5にはバージョン番号以外の違いはありません。

  • 圧縮レベル : 圧縮のレベルです。無圧縮の場合は"圧縮なし"と表示されます。現在は1のみです。
  • CDのタイトル : 作成時につけたCDのタイトルを表示及び変更します。


CDから仮想CDの作成

CDから仮想CDの作成 : CD-ROMから仮想CD-ROMファイルを新規に作成します。

  • 読み出し元CD-ROMドライブ : 仮想CDを作りたいCD-ROMの入っているドライブを指定してください。Physicalは物理ドライブ、Virtualは仮想ドライブです。
  • CDのタイトル : 仮想CDファイルを区別するための名前を決めてください。あなたがこの名前を見たときにこのCDだとわかるような名前をつけてください。これはエクスプローラから仮想CDを切り替える時などに表示されます。半角で31文字以内に限られますが、日本語を用いることもできます。
  • 仮想CDファイルの格納先 : 仮想CD-ROMファイルを保存するファイル名を絶対パスで指定してください。
    拡張子は.qcdです。付けない場合は作成時に自動的に付加されます。
    なお、参照ボタンを押すことでファイル名を指定できます。
    また、空き容量がCD-ROM全体のサイズ+5MBytes(念のため) 以上ないと、そのドライブ上には仮想CD-ROMファイルを作成できません。
  • Slow Mode : 一部のCD-ROMは、作成してもうまく読み出せないことがあります(仮想CDを設定してエクスプローラから仮想ドライブにアクセスすると、誤ったファンクションですというエラーが表示されます)。そのような場合はここにチェックを入れて作成しなおしてください。ここにチェックを入れると、他の方法で仮想CDを作成しますが、作成速度が遅くなります。
  • 圧縮する : 仮想CD-ROMファイルを圧縮して作成します。詳しくは圧縮についてをご覧ください。もちろんすでに作成している無圧縮の仮想CDをマウントして、それを使用して圧縮された仮想CD-ROMファイルを作成することも可能です。
    • 圧縮率 : 圧縮率を変更します。1が一番高速で、9が一番高圧縮な方法となっています。
      作成速度は1と9では数倍の差がありますが、どちらも解凍の速度はテストしてみた限りではどちらもほとんど変わりません。しかし、9にしても1と比べて圧縮率は数%程度しか変わらない(ex.Microsoft(R)/Shogakukan Bookshelf(R) Basicで、無圧縮で517MB,圧縮1で311MB,圧縮9で300MBでした。)
      上に、高圧縮にすると作成にとても時間がかかるので、間を取った6程度で圧縮するのがお勧めです。なお、Ver1.10以前の圧縮は、圧縮時の速度を考慮して1にしてありました。
  • CDリストに追加 : CDリストに、作成するCDを自動的に追加します。
  • 作成 : 仮想CD-ROMファイルを作成します。


フォルダから仮想CDの作成

フォルダから仮想CDの作成 : ハードディスクを含む任意のフォルダから仮想CD-ROMファイルを新規に作成します。一部のファイルだけを抜き出して仮想CD-ROMを作成したい際に使用します。

  • 読み出し元のフォルダ : 読み出し元となるフォルダを指定してください。そのフォルダをCD-ROMのルートフォルダと解釈して仮想CDを作成します。ドライブ全体を指定するとき以外は最後の\をつけないでください。たとえば d:\ や c:\cdrom のように指定してくださいという意味です。
  • ボリュームID : エクスプローラ等でドライブレターの横に表示されるボリュームIDです。英大文字と数字、アンダーバーのみしか使用できません。
  • CDのタイトル : 仮想CDファイルを区別するための名前を決めてください。あなたがこの名前を見たときにこのCDだとわかるような名前をつけてください。これはエクスプローラから仮想CDを切り替える時などに表示されます。半角で31文字以内に限られますが、日本語を用いることもできます。
  • 仮想CDファイルの格納先 : 仮想CD-ROMファイルを保存するファイル名を絶対パスで指定してください。
    拡張子は.qcdです。付けない場合は作成時に自動的に付加されます。
    なお、参照ボタンを押すことでファイル名を指定できます。
    また、空き容量がCD-ROM全体のサイズ+5MBytes(念のため) 以上ないと、そのドライブ上には仮想CD-ROMファイルを作成できません。
  • 圧縮する : 仮想CD-ROMファイルを圧縮して作成します。詳しくは圧縮についてをご覧ください。もちろんすでに作成している無圧縮の仮想CDをマウントして、それを使用して圧縮された仮想CD-ROMファイルを作成することも可能です。
    • 圧縮率 : 圧縮率を変更します。1が一番高速で、9が一番高圧縮な方法となっています。
      作成速度は1と9では数倍の差がありますが、どちらも解凍の速度はテストしてみた限りではどちらもほとんど変わりません。しかし、9にしても1と比べて圧縮率は数%程度しか変わらない(ex.Microsoft(R)/Shogakukan Bookshelf(R) Basicで、無圧縮で517MB,圧縮1で311MB,圧縮9で300MBでした。)
      上に、高圧縮にすると作成にとても時間がかかるので、間を取った6程度で圧縮するのがお勧めです。なお、Ver1.10以前の圧縮は、圧縮時の速度を考慮して1にしてありました。
  • CDリストに追加 : CDリストに、作成するCDを自動的に追加します。
  • 作成 : 仮想CD-ROMファイルを作成します。


オプション

オプション : オプションを設定します。

オプションは、Administrator権限を持ったユーザーのみが設定を行うことができます。Administratoｒ権限を持たないユーザの場合各項目は淡色表示されます。また、以下の設定を有効にするには、OKを押した後OSの再起動が必要です。

  • 物理CD-ROMのない環境で使用することがある : ノートPCなど、物理CD-ROMを着脱する環境で使用される場合において、物理CD-ROMがないときにうまく動作しない場合、まずここにチェックを入れてみてください。チェックを入れることにより読み出せるようになる可能性が高いです。
  • vcddrv.sysのロードの順番に問題がある : イ ンストールして再起動するとOSが起動できなくなったり、仮想CD-ROMドライブに正常にアクセスできない場合に入れてみてください。チェックを入れると仮想CD-ROMデバイスドライバのロードの順番を変えますが、これで問題が解決する場合もあります。通常はオフで結構です。
  • CD-ROMデバイスの名前に問題がある : イ ンストールして再起動するとOSが起動できなくなったり、 仮想CD-ROMドライブに正常にアクセスできない場合は、ここにチェックを入れてもう一度試してみてください。ただし、Adaptec Easy CD Creator3.x(4.xは大丈夫なようです)をご使用の方はチェックを入れると逆にOSが起動できなくなるのでご注意ください。こちらも通常はオフで結構です。
  • VDinitのCDチェックまでの遅延 : VDInit(初期化アプリケーション)が、それぞれのドライブをチェックに行くまでに遅延を設けたい場合、ここにその秒数を指定してください。これは、一部CD-ROMドライブとの相性問題回避用ですので通常は0で結構です。ごくわずかな場合を除き役に立たないと思います。
  • 次回の起動時も仮想CDドライバをロード :
    次回の起動時に仮想CD-ROMドライバをロードしない場合チェックをはずしてください。このアプリケーションのここでチェックを入れなおさない限り仮想CDのデバイスドライバはロードされません。もちろんここにチェックを入れていないと仮想CDは使用できません。
  • 仮想CDドライブの数 : 仮想CD-ROMドライブの数を指定してください。20個まで指定できるようにしていますので必要に応じて増やしてください。なお、ドライブの割り当ては、デフォルトではドライブでドライブレターの若い順(一部ドライブを除く)に割り当てられますが、ドライブｚを超えないようにしてください。ドライブzを超える数を指定してもドライブzまでの分作成した場合と同様に動作することを確認していますが、内部ではここで指定した値の分だけドライブごとに必要な分のメモリを消費してしまいます。


About

About : このアプリケーションのバージョン情報を表示します。

  • 登録 : 登録はここで行ってください。詳しくは登録方法をご覧ください。


エクスプローラのコンテキストメニュー

エクスプローラのコンテキストメニュー拡張について

エクスプローラ上で、コンテキストメニュー(マウス右クリックなどのメニュー)を出すと、拡張されたメニューが表示されます。本アプリケーションは常駐しているわけではありません。必要時にシステムによってロードされます。

今のところ、Administrator権限を持たないユーザでは何も出ませんのでご注意ください。

  • 物理CD-ROMドライブ上
    • 仮想CD-ROMの作成 : 選択したCD-ROMドライブから仮想CD-ROMを作成します。といってもあの仮想CD-ROM作成画面が表示されるだけです。
  • 仮想CD-ROMドライブ上
    • 仮想CD-ROMの取り出し : 仮想CD-ROMドライブにマウントしている仮想CD-ROMファイルを取り出します。同時に出るシステム標準の"取り出し"メニューからは取り出せないので注意してください。
    • 仮想CD-ROMのマウント : 仮想CD-ROMドライブに選択した仮想CD-ROMをマウントします。
  • 仮想CDファイル上
    • CDリストに追加 : 選択した仮想CD-ROMファイルをリストに登録します。すでにリストにあるファイルを登録しようとした場合はエラー表示がされます。
    • CDリストから削除 : 選択した仮想CD-ROMファイルをリストから削除します。リストにないファイルを削除しようとした場合はエラー表示がされます。
    • ドライブへのマウント : 選択した仮想CD-ROMファイルを選択した仮想CD-ROMドライブに挿入します。リストに未登録の場合は自動的に登録されます。


アンインストール方法

Administrator権限を持っているユーザーが、[スタートメニュー]→[設定]→[コントロールパネル]の中のアプリケーションの追加と削除から、"Virtual Disk for Windows XP"を選んで行ってください。完全に削除するかどうか問い合わせてきますので削除してよければOKを押してください。

アンインストール時に使用しているファイルについてはその場で削除できませんので、次回のOS起動時に自動的に削除されます。

また、アンインストールに失敗した項目については表示されますので各自で削除してください。インストールした後関連ファイルやレジストリを操作していない限り成功するはずです。もし、インストール後何も手動でディレクトリ構成やレジストリを書き換えていないにもかかわらずアンインストールに失敗した項目が表示される場合はご連絡下さい。


制限事項

以下の事項については、現在確認されている制限事項です。その他でおかしな動作をする場合はご連絡ください。

  • カーネルモードで動作するデバイスドライバというものは、その性質上、すべてのファイルを読み出すことができます。したがって仮想CDファイルのパスさえわかれば、そのファイルに関しては読み取り権限が無くてもファイルを読み出せてしまうので、それが困る場合は使用しないで下さい。ただし、仮想CDファイル以外のファイルに関しては何もできないはずです。
  • フォルダから仮想CDを作成する際、一般のCDよりも大きなサイズのフォルダを指定すると作成に失敗することがあります。
  • エクスプローラのドライブ右クリックによる"取り出し"メニューにより取り出すことはできません。"仮想CD-ROMの取り出し"を用いて取り出してください。
  • フォルダから仮想CDを作成する際、対象ファイル数が多い場合、作成ボタンを押した直後、"仮想CDのサイズを計算しています…"と出ている画面でしばらく時間がかかります(数分)。また、その間キャンセルボタンを押しても反応しません。
  • ネットワーク上の共有フォルダ中の仮想CDファイルの使用については、動作確認およびサポートしておりません。普通にやってもおそらく使用できないのではないかと思われます。
  • 仮想CD-ROMを入れ替えても、AuroRunが反応しません。Autorunを実行したい場合は、ドライブのアイコンの上で右クリックメニューから自動再生を選んでください。
  • 一部のCD-ROMにおいて仮想CDが作成途中で失敗する不具合が確認されています。この場合、"フォルダから仮想CDの作成"を用いて、"読み出し元のフォルダ"にCD-ROMドライブを指定して作成するとうまくいく可能性が高いです。


トラブルシューティング

ここではよく質問される、うまく動作しないときの解決法をいくつか示します。

  • 仮想CDファイルが消せない(消しても空き容量が増えない、再起動すると復活している)
    • 仕様上、OS起動中一度でもマウントした仮想CDファイルは、再起動後でないと削除できません。必ずアンマウント後一度OSを再起動してから、削除してください。
  • 仮想CDがうまく作成できないCD-ROMがある(エクスプローラ等からアクセスしても内容が見えない)
    • まずSlow Modeにチェックを入れてもう一度作成してみてください。
    • それでうまくいかない場合、"フォルダから仮想CDの作成"を用いて、読み出し元のフォルダにそのCD-ROMを指定して仮想CDを構築してみてください。MacintoshとのハイブリッドCD-ROMなどはたいていの場合この方法でうまく作成できます。
    • それで作成しても無理ならば残念ながら使用できない可能性が高いです。
  • 仮想CDは作成できる(エクスプローラからは見える)が、その中のセットアッププログラムや実行ファイル等を起動すると、CDを入れてくださいと要求される
    • この場合、ドライブレターが一番前にあるCD(普通は本物のCD-ROM)しか読みに行かない仕様になっているアプリケーションである可能性があります。
    • 対策としては仮想CDのドライブレターを本物のCD-ROMよりも前に持ってくるという方法がありますが、それを行うと今度は逆にそのアプリケーションが本物のCD-ROMから起動できなくなってしまいます。また、A,Bドライブは基本的にフロッピードライブに予約されているので空いていても使用しないほうがよいと思われます。
  • (主にノートPCで)物理CD-ROMを装着しているときには正常に動作するが、物理CD-ROMのない環境で起動すると、仮想CDドライブは作成されるが、アクセスしようとすると"パラメータに誤りがあります"と出てきてアクセスできない。
    • これは、物理CD-ROMが1台も装着されていない場合に発生します。オプションの"物理CD-ROMのない環境で使用することがある"にチェックを入れて、再起動してみてください。これで直る可能性がかなり高いです。
  • (主にノートPCで)物理CD-ROMドライブを着脱すると割り当てられているドライブレターが変わる
    • これは、物理CD-ROMがOSに先に認識されるため、物理CD-ROMのない場合にドライブレターが一つづつ前(のCD-ROMドライブのドライブレター)にずれるためです。頻繁に着脱され、問題になるようでしたらオプションの"vcddrv.sysのロードの順番に問題がある"にチェックを入れてください。すると常に物理CD-ROMよりも先に仮想CD-ROMが認識されるようになります。
  • その他、OS起動中にブルースクリーンになったり、仮想CD-ROMドライブがうまく動作しない
    • オプションのトラブルシューティング関係の項目のそれぞれのオン、オフの組み合わせを試してください。OSが起動できない場合、"物理CD-ROMのない環境で使用することがある"は、あまり関係のない可能性が高いので、オン、オフの組み合わせを試す場合はまずほかのものから試したほうがうまく動く設定を発見しやすくなると思います。
    • ご接続の周辺機器や、インストールされているCD-ROM関係のドライバやソフトウェア等との相性により、上記オプションを調整してもうまく動作しないこともあるかもしれません。


送金方法

このアプリケーションはシェアウェア(1800円)です。インストールしてから3週間の間試用できますが、3週間を超えると仮想CDドライブが使用できなくなります。継続して使用される場合はご送金ください。シェアウェア代金は本アプリケーションの更なる改良やコンパイラのバージョンアップ、(年間10万円以上かかる)MSDN購入費等の各種の費用とさせていただきます。

未登録時の制限は以下のとおりです。

  • OS起動時に試用中である旨のダイアログが出る。
  • 3週間を過ぎると仮想CD-ROMドライブが使用できなくなる。

また、ご使用の環境で正常に動作するかどうかを十分に確認した上でご送金ください。そのために試用期間中にも機能的な制限は一切つけておりません。ご送金後の返金には、いかなる場合にも応じられません。

また、必ずしもこのバージョンより新しいバージョンが出るという保証はいたしかねます。また、バグ修正も必ず行われるとは限りません。現状の機能でも十分送金の価値があるとご判断された場合にのみご送金ください。

今のところVer0.x/1.xのリリース中にご登録いただいた場合、Ver0.x/1.xでのバージョンアップ代金は無料とさせていただきます。ただし、Ver2.0以後、大きな変更を行う場合でそれ相応の時間や費用がかかる場合はバージョンアップ代金をいただくなどする可能性があります(おそらくないと思いますが…)。もちろんその際はVer1.xをそのままご使用いただくことも可能です。

このアプリケーションはシングルユーザーライセンスとさせていただきます。したがって、複数人でご使用の際は人数分の送金をお願いいたします。また、ご使用される人数分のライセンスを取得していただければその人数を超える複数台にインストールしていただいても結構です。なお、5人以上で一括登録される場合は以下のように割引いたします。この場合、送金手段は銀行振込のみとなります。また、こちらは一括して送金いただける場合にのみ適用されます。追加ライセンスは今のところございませんのでご了承ください。

5-10ライセンスの場合 | 1ライセンス1500円
11-50ライセンスの場合 | 1ライセンス1300円
51-100ライセンスの場合 | 1ライセンス1100円
100ライセンス以上 | 1ライセンス900円
300ライセンス以上 | 1ライセンス700円

500ライセンス以上の場合は uemura@kit.hi-ho.ne.jp まで別途ご相談ください。見積書、請求書が必要な場合も別途ご相談ください。5ライセンス以上の場合無償で発行させていただきます。領収書については銀行振込のご利用控えを持ってかえさせていただきます。

送金方法は以下の2種類とさせていただきます。なお、送金にかかる各種手数料等は勝手ながらご送金いただく方がご負担ください。なお、電子メールがご利用になれない場合は利用できる知り合いなど経由でお申し込みください。

  • ベクターのシェアレジを使用する方法
    http://www.vector.co.jp/ のシェアレジでご登録下さい。
    別途消費税(5%)および手数料(100円)がかかります。(要クレジットカード)
    シェアレジソフト番号 : [SR026188]
    シェアレジ作品名 : Virtual Disk for Windows XP
     https://sw.vector.co.jp/swreg/step1.reserve?srno=SR026188 から直接お申し込みいただけます。
  • 銀行振込
    別途銀行によって所定の手数料がかかります。電信扱いでご送金されるほうがこちらに早く到着します。
    銀行名 : 三井住友(みついすみとも)銀行
    支店名 : 五反田(ごたんだ)支店
    種類 : 普通預金
    口座番号 : 7664344
    名義 : ウエムラ タクヤ

銀行振込で送金された方は、作者が入金を確認したあと、電子メールでユーザー名と登録番号をお知らせしますので、以下の内容を uemura@kit.hi-ho.ne.jp までご連絡ください。

  • ライセンス形態(Virtual Disk for Windows XP新規ユーザーと記入してください)
  • 振込先口座(三井住友銀行と記入してください)
  • 送金日
  • 送金額
  • ライセンス数
  • メールアドレス
  • 名前(漢字)
  • ふりがな

以下のフォームを用いてご送信ください。

Subject : Virtual Disk Register
----8< cut here----
Virtual Disk の送金をしました。
ライセンス形態 : Virtual Disk for Windows XP新規ユーザー
振込先口座 : 三井住友銀行
送金日 :
送金額 :
ライセンス数 :
メールアドレス :
名前(漢字) :
ふりがな :
----8< cut here----

ふりがなはユーザー名を決定したり、入金の確認を行うのに必須ですので忘れずにお書き添えください。なお、送金名義と登録者が違う場合必ずその旨お書き添えください。また、もしメールを送信してから2週間程度たっても返事がない場合はもう一度お問い合わせください。また、メールのアドレス宛に返信できない、あるいは送金いただいたのにメールが来ないなどの特殊な状況の場合はWebページ上で問い合わせをする場合がありますので思い当たる場合はご覧ください。

取得されたユーザー名や登録番号を他人に譲渡することはできません。また、他人に教えたり不特定多数に対して公開することなども禁止します。それぞれのユーザーに対して一意になるように発行していますので、もし発覚した場合は当該番号は無効とし、また代金の返還もいたしません。

ユーザー名と登録番号を受け取ったら、登録作業を行ってください。登録方法についてはこちらをご覧下さい。


送金後の登録方法

ユーザー名と登録番号を受け取ったら、Virtual Disk for Windows XPを起動し、Aboutタブを表示します。そこで登録ボタンを押すと、ユーザー名と登録番号を入力するダイアログが表示されますので、受け取ったユーザー名と登録番号(複数記述されている場合は"登録番号(XP)")を入力してください。入力ミスを避けるためどちらも受け取ったものをそのままコピー&ペーストされることを強くお勧めします。その後OKを押せば登録が完了します。

登録に失敗した場合はエラーメッセージが出ますので登録番号等を確認してもう一度入力し直してください。

正規に登録していただいたにもかかわらず制限が解除できないあるいは方法がわからない場合は遠慮無くお問い合わせ下さい。なお、その場合はご登録いただいたメールアドレスを合わせてご連絡下さい。


圧縮について

圧縮をすると，仮想CDファイルのサイズを小さくすることができます。これによってハードディスクの使用量を減らすことができます。ただでさえCD-ROMという大きな媒体を相手にしているのですから，可能な限り圧縮を使用することをお勧めします。

仮想CDファイルの圧縮には、zlib1.1.2をベースにしてデバイスドライバにおいて使用できるように改造したものを用いています。したがって、圧縮率などはそれに準じるものですが、高速にランダムアクセスができるように工夫しているので、サイズは若干大きくなっているかもしれません。CDによるかもしれませんが、私が試してみた限りでは、LHAの圧縮形式lh5とほぼ同等の圧縮率を示す様です。

たとえば、すでに圧縮されているようなセットアッププログラムやアーカイブファイルなどが多数含まれているようなCD-ROMではそれほど圧縮は期待できません。しかし、テキストやビットマップ、無圧縮の音声ファイルなどが多数含まれているような場合は、数分の1程度になることが期待できます。

また、圧縮した仮想CDファイルは、読み出し時にまずディスクから読んでその部分を解凍しなければならず、しかもランダムアクセスができるような圧縮を行わなければならないため、どうしてもパフォーマンスが低下してしまいます(それでもCD-ROMよりは高速である可能性が高いですが)。場合によっては圧縮しない場合の約半分強にまで低下してしまう可能性があります。したがって、ゲーム等，読み出し速度を上げるのを目的で仮想CD-ROMを用いている場合は、圧縮を行わないほうがよいかもしれません。逆に、辞書CD-ROMなどでは、テキストベースでそれなりの圧縮が期待できる上に多少速度が低下しても(辞書の検索アルゴリズムが悪くなければ)気にならないので、圧縮に適しているといえます。

また、圧縮すると、そうでない場合と比べて展開に余分にCPUを使用しますが、逆にハードディスクからの読み出し量は少ないので、ハードディスクの読み出し速度が遅ければ遅いほど、また、CPUの速度が速ければ早いほど圧縮しない場合の速度に近づきます。

とりあえず、圧縮を一度試してみてハードディスクの空き容量と、パフォーマンスのどちらを取るかを仮想CDファイルごとに検討してください。

なお、zlibのドキュメントにあるように、圧縮解凍部分を用いたことについてのいかなる損害についてもzlibの作者は一切責任を負いません。また、このアプリケーションの作者も責任を負いません。

万一このアプリケーションに不具合があってもzlibの作者には関係がないので連絡しないでください。たとえそれが圧縮解凍の部分に起因することが明らかである場合も同様です。


ちょっと高度な使い方

ここでは，便利な使い方や高度な設定などを紹介させていただきます．

  • 仮想HDDの設定で，仮想ドライブ化フォルダ名のところにCD-ROMのドライブを指定すると，仮想CD-ROMや本物のCD-ROMドライブを複製して表示することができます．
  • 容量の大きいソフトで，
    ・ハードディスクに全体をインストール
    ・CD-ROMを用いて使用するように一部をインストール
    という二つのオプションをもっているソフトがある場合，あえてCD-ROMを用いて使用するようにインストールを行って，圧縮した仮想CDを用いればハードディスクの使用量を抑えることができるかもしれません．例えば私の場合、Office2000をすべて"CD-ROMから実行"でインストールし、使用しています。


著作権など

以下はご登録されているいないにかかわらず適用されます。

  • 本プログラムとその付属ファイル一式(これらを以下本プログラムと呼びます)についての著作権は私 上村 拓也 が所有しています。したがって許可なくファイル構成の変更、プログラム内容の改変等を行うことを禁止します。
  • 本プログラムのいかなる部分についても逆アセンブル、リバースエンジニアリングおよびそれに類する行為を禁止します。
  • 本プログラムはシェアウェアです。継続してご使用の場合は必ずご送金ください。詳しくはシェアウェアについてをご覧ください。
  • 転載および再頒布は自由ですが、以下の項目をお守りください。
    • 作者に不利益を与えないこと(著作権の保護など)
    • 最新版の場所 (http://hp.vector.co.jp/authors/VA014116/soft/) を明記すること
    • アーカイブの内容を改変しないこと
  • 要望については時間がある限り対応しますがそれについて返事を出したり、実現する義務は負わないものとします。
  • 本プログラムを使用した上で生じたいかなる損害についても、たとえそれがこのプログラムに起因することが明らかである場合、ならびに不具合が起こる可能性があらかじめ作者に知らされていた場合においても作者は一切の責任を負いません。ご自身の責任の範囲でご使用ください。いかなる場合においても、作者の責任は、本プログラムに対して使用者が実際に支払った金額を上限とします。
  • 発見された本プログラム上の不具合について、作者は改善する努力は致しますが修正の義務は負いません。
  • このヘルプ内に記載されている会社名、商品名は、各社の登録商標または商標です。


更新履歴

青色は大きな変更、追加などです．赤色はさらに大きな変更です。

Ver0.95 (2002/02/01)

  • ドライブ数が指定した数だけ作成されないことがあるのを修正
  • ドライブに指定した仮想CDファイルがOS再起動で外れてしまうことがあるのを修正

Ver0.90 (2001/11/16)

  • 仮想CDを入れ替えたときエクスプローラに反映されないことがあるのを修正
  • その他内部変更

Ver0.10 (2001/11/01)

  • 初公開


謝辞

このアプリケーションの、圧縮および解凍部分についてはzlib1.1.2をデバイスドライバにおいて使用できるように改造したものを用いています。

このすばらしいライブラリを作成されたJean-loup Gailly氏およびMark Adler氏をはじめとするzlib作成にかかわられたすべての方々に深く感謝いたします。

また、このアプリケーションおよび、その元となるVirtual Disk for Windows NT/2000を公開した直後から今まで、多数の方から、ご意見、ご要望、バグ報告、動作報告などをいただきましたが、それらは作者の大きな励みになりました。また、環境およびそれぞれのCD-ROMタイトルに依存するような相性的問題についても、私の環境だけでは発見できず、大変参考になりました。これらの方々無くしてこのアプリケーションのここまでの発展はありませんでした。この場を借りて厚く御礼申し上げます。そしてこれからもよろしくお願いいたします。


その他

  • 最新版は以下の場所からダウンロードできます。
    http://hp.vector.co.jp/authors/VA014116/soft/
  • このアプリケーションについて、要望、感想等がございましたら、ご登録されているいないにかかわらずお気軽に作者までご連絡ください。
  • また、バグを発見された場合もご連絡くだされば幸いです。作者はとても多忙なためすぐに応対できない場合がありますが気長にお待ちください。
  • このプログラムはその性格上、相性問題が発生する場合があるかと思いますが、それらに関しては、他の一般的不具合に比べて特に対応が難しいことをご了承下さい。基本的に対応できないものと思ってください。動作確認をした機種についてはすべて初期設定のままで問題無く動作することを確認しています。以前のバージョンでは正常動作していたが新しいバージョンでは動作しないといった場合に限ってはオプションを設けることなどにより対処できる可能性が高いです。
  • また、相性問題以外の不具合対処については、こちら側の問い合わせに対して適切にお答えいただければ修正できる可能性があがりますのでご協力お願いいたします。