Starting WinHand

    窓の手 ver6.0 for Windows XP

Copyright(C)1997-2002 Masami Ikawa

このソフトは、WindowsXP標準機能では手が届かないかゆいところに手が届くことを目指して開発したカスタマイズソフトウェアです。このソフトは様々な設定をWindowsのレジストリに設定するだけなので常駐しません。フォルダーやコントロールパネル等のアイコンの変更にはじまり、Windows標準機能では変更できない隠された様々な設定が変更可能です。


Configration

動作環境

「窓の手」を使用するためには、最低限以下のような環境が必要です。

  • 「窓の手」ソフトウェア
  • Pentium100MHz以上のCPUを搭載したコンピュータ
  • Microsoft WindowsXP
  • 32MB以上のメモリー
  • 5MB以上の空き容量のあるハードディスク
  • 800x600以上をサポートする16色以上のVGAモニタ

注意事項

窓の手を使用するには、Administrator権限が必要です。ご利用になるユーザーに権限を与えてからご利用下さい。会社等でご利用の場合は、システム管理者の方にご相談下さい。


Install of WinHand

インストール

再インストール又はバージョンアップの場合、上書きインストールで可能です。

アンインストール

スタートメニューからコントロールパネルを起動して下さい。 「アプリケーションの追加と削除」を起動し、「窓の手」を選んでダブルクリックして下さい。 この操作で以下のファイルは削除されませんので手動で削除下さい。

  • Setupxp.exe（インストーラ）
  • Setupxp.ini（インストール情報）
  • MySettings.ini（最近の設定情報）

又、各種バックアップファイルも削除されませんので手動で削除下さい。


Basis Using

基本的な使い方

「窓の手」は各種タブにそれぞれ設定項目を分類しています。各タブの設定項目を変更した後、設定反映ボタンを押して下さい。

あなたがこのボタンを押すと実際にWindowsに対して設定します。各設定を変更した後このボタンを押して下さい。このボタンを押さない限り「窓の手」はレジストリなどの各種設定を変更しません。

ファイルに保存ボタンで保存した設定情報を呼び出すことができます。

「窓の手」の各種設定をファイルに保存できます。例えば、数種類（MAC風、ちょっとおしゃれ風、BeOS風等）の設定情報を保存しておけば、好きなときにこのファイルを呼び出すことができます。反映方法はファイルを開くボタンで設定情報を呼び出し設定反映ボタンで反映されます。

（注意）

「アンインストール」、「自動実行」、「新規作成」タブの情報と起動ロゴ、終了ロゴの設定は保存されません。

これはWindowsインストール時の設定に一回の操作で簡単に戻す為にあります。但し、このボタンで戻らない設定もありますので気を付けてください。それは「アンインストール」、「自動実行」と「新規作成」タブの設定です。これらはWindows標準の設定に戻しても無意味だからです。また、これらの設定がPCによって異なることも理由です。


Icon

アイコン変更方法

「窓の手」に表示されているアイコンの上をクリックして下さい。

例えば、マイコンピュータアイコンをクリックした場合、explorer.exeに含まれている全てのアイコンが表示されます。

これはマイコンピュータのアイコンがexplorer.exeというファイルの中に含まれているからです。参照ボタンを押して下さい。

お気に入りのアイコンファイル（又はアイコンが含まれているファイル）を探して、該当ファイルを開いてください。そうするとそのファイルに含まれる全てのアイコンが表示されます。好きなアイコンの上でダブルクリックして下さい。


Desktop

デスクトップ

ショートカットアイコンを隠す

デスクトップなどにショートカットを作成すると自動的に矢印のマークのアイコンが左下につきますが、この設定を有効にすると隠すことが可能です。この設定を無効にする場合は、ショートカットアイコン(標準は通常c:\windows\system\shell32.dllの中に含まれています）を設定して下さい。

デスクトップにコントロールパネルを追加する

デスクトップにコントロールパネルのショートカット（本当はショートカットではありません）を追加します。ＩＥ５をインストールした環境ではこの設定は効果ありません。

デスクトップにプリンタを追加する

デスクトップにプリンタのショートカット（本当はショートカットではありません）を追加します。ＩＥ５をインストールした環境ではこの設定は効果ありません。

デスクトップにWindowsのバージョンを表示する

デスクトップの右下にWindows2000の種類とビルド番号を表示します。


Explorer

エクスプローラ

マイコンピュータをダブルクリックしたらエクスプローラを起動

デスクトップのマイコンピュータをダブルクリックするとエクスプローラが起動するようになります。

マイコンピュータウィンドウ内のドライブシンボルを隠す

この設定をOnにすると、マイコンピュータやエクスプローラからOnにしたドライブが表示されなくなります。アプリケーションソフトからも一部例外を除き見えなくなります。これは、隠しファイルならぬ隠しドライブ等として使えると思います。例えば、重要なファイル等をあるパーティション（ドライブ）に保存している場合、それを隠すことによってエクスプローラ等で間違って削除する等の操作ミス防止にもなります。この設定を有効にした場合、スタートボタンを右クリックすると表示されるメニューの「開く」と「エクスプローラ」が選択できなくなります。

ツールバーの背景を変更する

エクスプローラのツールバーの背景を変更します。40x40ピクセル又は80x80ピクセルくらいがちょうど良い大きさのようです。

ごみ箱の名前

普通は変更できないごみ箱の名前を変更できます。「Trash」「屑篭」とか英語Windows風に「Recycle Bin」等お好きな名前に変更して下さい。これはデスクトップのみならずあらゆる場面でこの名前が表示されます。

ごみ箱アイコンを隠す

ごみ箱をデスクトップ上から隠します。

マイコンピュータにごみ箱を表示する

マイコンピュータをダブルクリックして開くウィンドウにごみ箱を表示します。


Network and Recycle Bin

ネットワーク／ごみ箱

ネットワークコンピュータアイコンを隠す

デスクトップ等に表示されるネットワークコンピュータアイコンを隠します

ネットワーク全体アイコンを隠す

ネットワークコンピュータをダブルクリックすると表示される「ネットワーク全体」アイコンを隠します。

ワークグループアイコンを隠す

ネットワークコンピュータをダブルクリックすると表示される「ワークグループ」アイコンを隠します。

インターフェースが一度に転送可能な最大データサイズ (MTU)

MTUとはMax Transfer Unitの略で、ネットワークにおいてインターフェースが一度に転送可能な最大データサイズです。IPパケットサイズが下位層の最大転送サイズより大きい場合は複数に分割され送信先で再構成される為パフォーマンスが悪化します。反対に小さすぎると本来は一度に沢山のデータを転送できるのに少量ずつ送信するので効率が良くありません。

Windowsの初期値は1500です。推奨値は1500です。

確認応答無しに一度に受信可能なデータサイズ (RWIN)

これはデータのやり取りを行う相手先への応答なしに、無条件にデータを受け取ることができるバッファの量を表しています。データを送信する側は、送信先のRWINがいっぱいになるまでは、受信側の応答を待たずに一気に送信する事ができます。バッファがいっぱいになると受信側は、データを容量分受信し終わったことを送信側に伝えるという動作を行います。つまり、RWIN値を増やすとデータのやりとりのための、コンピュータ同士の応答が頻繁に発生しなくなり、送信側で応答を待つ機会が減るので、送受完了までの時間が短くなるのです。特に、インターネットのように反応の遅延時間が長い場合は、このRWINの値を大きめにした方が連続のデータ転送を行う場合に有利となります。このRWINの値は、MTUの値から40を引いた値の偶数倍で求められます。

WindowsXPの初期値は8760です。推奨値は256960です。

宛先に未到着のパケットがネットワーク内に存在できる最長時間 (TTL)

発信IPパケットのヘッダに設定するTTL値を変更できます。TTLとはTime To Liveの略です。宛先に未到着のパケットがネットワーク内に存在できる最長時間を意味します。実際には、この値によって IP パケットが破棄されるまでに通過できるルーターの数が制限されます。

WindowsXPの初期値は128です。推奨値は64です。

ブラックホールルータを検出する為の発見アルゴリズムを有効にする

これを有効にすると、TCP がパス MTU 発見の実行中に "ブラック ホール" ルーターを検出できるようになります。ブラック ホール ルーターとは、ICMP Destination Unreachable メッセージを返さずに Don't Fragment ビットが設定されている IP データグラムを断片化しようとするルーターです。TCP では、これらのメッセージを受信することを前提にパス MTU 発見を実行します。ブラック ホール ルーターの検出を有効にした場合、あるセグメントを数回再転送しても応答がなければ、TCP が Don't Fragment ビットの設定を解除してセグメントを送信しようとします11。その結果、セグメントへの応答があれば、MSS が減らされ、その接続を通じて今後送信するパケットに Don't Fragment ビットが設定されます。ブラック ホールの検出を有効にすると、1 つのセグメントに対して実行される再転送の最大回数が増えます。

Windowsの初期値は無効です。推奨値は無効です。

バス最大転送ユニットの発見アルゴリズムを有効にする

これを有効にする場合は、TCP がリモート ホストへのパスの最大転送ユニット (MTU または 最大パケット サイズ) の発見を試行します。TCP では、パス MTU を発見して TCP セグメントをそのサイズに制限することで、ネットワークを異なる MTU に接続するパスに沿って存在する各ルーターで断片化が行われるのを防ぐことができます。断片化は、TCP のスループットに悪影響を与え、ネットワークの輻輳を招きます。このパラメータを 0 に設定すると、ローカル サブネット上に存在しないホストへのすべての接続に対して、MTU が 576 バイトに設定されます。

Windowsの初期値は有効です。推奨値は有効です。


Context Menu

右クリックメニュー

フォルダーアイコン変更

この設定をOnにすると、マイコンピュータやエクスプローラ内のフォルダー上で右クリックすると表示されるメニューに「アイコン変更」が表示されます。この「アイコン変更」を選択すると、各フォルダーのアイコンを変更することができます。従来の機能の互換の為にこの機能を残しておりますがWindowsXPでは標準機能で可能ですので将来のバージョンではこの機能は削除するかもしれません。

この機能を利用してフォルダーのアイコンを変更した場合以下の制約が発生致します。

  • ジャストシステム社のソフトウェア（一太郎、花子等）のダイアログボックスで表示されなくなります。
  • MS-DOSプロンプトのDIRコマンドで表示されない場合があります。

任意のフォルダーから別ウィンドウで開く

この設定をOnにすると、任意のフォルダーから別のウィンドウが開きます。通常は新しいウィンドウを開かない設定ですが、任意に新しいウィンドウで開きたい場合などに使用します。インターネットエクスプローラー５を導入した環境では、ウィンドウではなくインタネットエクスプローラーが開きます。

未登録ファイルをダブルクリックしたらとりあえず以下のアプリで開く

これは、関連付けの無いファイルをダブルクリックした場合に通常だと「ファイルを開くアプリケーションの選択」画面になりますが、この画面を表示せずメモ帳、エディタ、バイナリエディタ等で開いてしまおうという設定です。

WindowsMeで上記設定を行うと、「アプリケーションで開く」のメニューを選択すると上記で設定したアプリケーションで開くようになります。これはWindowsMeから仕様が変更されたと思われます。

未登録ファイルでなく全てのファイルの右クリックメニューに追加

これは未登録ファイルだけではなく、全てのファイルの右クリックメニューに上記で設定したアプリケーションで開く設定です。マイクロソフトOfficeツールバー、FileViser等を使用する場合は、この設定は無効にして下さい。

任意のフォルダーからコマンドプロンプトを可能にする

この設定をOnにすると、任意のフォルダーからコマンドプロンプトが開きます。例えば、C:\Tempのフォルダで右クリックして選択した場合プロンプトはC:\Tempになります。


ShellNew

新規作成

デスクトップを右クリックすると表示されるメニューに「新規作成」というものがあります。様々なソフトを導入すると知らないうちにここにエントリが溜まっていきます。そうすると右クリックで画面のプロパティ等を表示する際、非常に見苦しくまた多くなると表示に時間がかかりますので操作性が悪くなります。ここでは、本当に必要なものだけにして操作性を向上させたい方の為に機能追加しました。


Window

ウィンドウ

スクロールを滑らかにする

この設定がOnの場合、メモリを余計に消費しているので、必要が無ければ停止させましょう。

最小化時のアニメーションをやめる

これをOnにすると、ウィンドウを最小化・最大化したときにでるウィンドウ軌跡（アニメーション）をやめることができます。これによって見た目のパフォーマンス改善やメモリ確保に効果があります。

プルダウンメニューを右揃えにする

プルダウンメニューは通常左揃えですが、この設定をOnにすると右揃えで表示されます。

従来のWindowsスタイルでウィンドウ表示する

この設定を有効にするとエクスプローラ等がWEBスタイルでの表示ではなくWindows95風になります。WEBスタイルでの表示は時間がかかり煩わしいと思っている方は一度お試しください。

設定の保存の無効化

Windowsはフォルダ等を開く度に、ウィンドウの位置や表示形式等を記憶しています。この機能により、一度開いたウィンドウは再起動後も同じ位置や表示形式で表示されます。この設定を有効にすると、ウィンドウの位置や表示形式を保存しなくなりますので、再起動後はWindowsの初期値の位置と表示形式で表示されます。

タスクバー上で点滅させない

既に起動しているアプリケーションで別セッションを作成した場合等で、新しいWindowがフォアグラウンドに表示されずタスクバー上で3回点滅することがあります。この動作自身はWindows2000標準動作ですが、結構煩わしいのでこれをフォアグラウンドに自動で表示するように変更できます。

コモンダイアログのプレースバー

プレースバーとは上記画面の左側（履歴、デスクトップ、マイドキュメント・・・）の部分です。これをよく使うフォルダ等に変更できます。デスクトップやマイドキュメント等の特殊フォルダは下記数値を入力することで表示できます（少し手抜きです（＾＾））

0 | デスクトップ
5 | マイドキュメント
6 | Favorites（お気に入り）
8 | 履歴
17 | マイコンピュータ
18 | マイネットワーク


Restriction

アクセスを制限

これを設定すると、コントロールパネルのシステム、パスワード、画面、ネットワーク等へのアクセスを制限できます。これはシステム管理者又は子供に設定を変更されたくない方のための設定項目です。

「窓の手」のパスワード変更

これを設定すると「窓の手」本体を起動する時にパスワードの入力が要求されます。

実行可能なアプリケーションを制限

1台のPCを複数の方で使用する場合（例えば会社、学校、講習会等）、実行可能なアプリケーションを制限して常に同じ環境を維持したいことがあります（特にシステム管理者の方）。ここに実行可能にしたいアプリケーションのexeファイルを指定して下さい。この機能を有効にすると、指定したアプリケーション以外を実行しようとすると下記のようなメッセージが表示されます。

（注意）

「窓の手」本体と「レジストリエディタ」は何も指定しなくても実行可能として設定されます。


Internet Explorer

インターネットエクスプローラ

ツールバーの背景を変更する

ツールバーの背景を変更します。40x40ピクセル又は80x80ピクセルくらいがちょうど良い大きさのようです。

アニメーションロゴを変更する

エクスプローラの右上で動いているアニメーションを変更します。1コマが26x26のビットマップを縦につなげたビットマップファイルを指定して下さい。サンプルが「窓の手」インストールディレクトリに含まれています。

インターネットエクスプローラのタイトル

タイトルは「Microsoft Internet Explorer」に固定されています。ところが、雑誌の付録等で配布されているYahooバージョンのIEは違うタイトルです。このように好みのタイトルに変更できます。

アウトルックエクスプレスのタイトル

IEのタイトルと同様にアウトルックエクスプレスのタイトルを変更できます。

「find」「?」で検索するページ

通常ホームページのアドレスを入力する欄に「find xxx」又は「? xxx」と入力するとマイクロソフトの検索画面で検索されます。これを好みのサイト(例:goo,excite等)に変更します。

anonymousFTPにログインするパスワード

Anonymousというのは匿名という意味です。FTPサイトでは本来ユーザーIDとパスワードが必要です。何もユーザーIDを入力しないのに入れるのは実はこの匿名IDでFTPサイトにログインしているわけです。このIDでログインしている場合、パスワードに自分のメールアドレスを入力するのが慣習ですが、標準では変更することができずie3.xであればie30user@、ie4.xであればie40user@というようになっています。これを変更する設定です。

ソースを表示するエディタ

Internet Explorerで右クリックし「ソースの表示」又は「表示」→「ソース」を選択すると、メモ帳が起動してソースコードが表示されます。これをメモ帳ではなく使い慣れたエディタで表示することができます。

１つのサーバーに同時に張れるコネクション数の上限

IE標準では同時に張れるコネクション数をHTTP1.0サーバーでは2、HTTP1.1サーバーでは4に制限されています。


Start Menu

スタートメニュー

スタートメニューの表示速度

スタートメニューをマウスでたどっていく時のメニューの出現時間が短くできます。

・・・を使用不可にする

WindowsXPでは終了だけを隠すことが出来ます。


Logon

ログオン

ログオンする前にダイアログを表示する

ログオンする前（Ctrl+Alt+Delを押したとき）にダイアログ画面を表示することができます。ダイアログのタイトルと表示するメッセージの内容を入力して下さい。

ログイン画面にAdministratorを表示する

WindowsXPのログイン画面には従来のAdministratorアカウントは表示されません。この機能は表示するようにします。

最後にログオンしたユーザー名を表示しない

通常最後にログインしたユーザーがログイン画面で初期表示されます。これを表示しないようにする設定です。（注意）自動ログオンする場合は無効にしておいて下さい。

自動ログオン

毎回決まったユーザーで使用したい場合で他のユーザーで使用頻度が少ない場合、又は個人でNT4.0WorkStationを使用する場合に便利な機能です。設定すると次回からそのユーザーで自動ログオンされます。

パスワードがなしの状態では、次回起動時に自動的に「自動ログオン」が無効になります。これはNT4.0の仕様です。 Administrator権限のないユーザーで設定した場合、別のユーザーでログオンできなくなりますが、次の手順で強制的にログオン画面を表示させることができます。ログオフしてShiftキーを押しっぱなしにして下さい。

ログオン画面の壁紙

ログオン画面での表示する壁紙を変更できます。ログオン画面が表示されない環境では、この設定は通常の壁紙と同じですので、変更する必要はありません。

ログオン画面の背景色

ログオン画面での表示する背景色（標準では深緑色）を変更できます。ログオン画面が表示されない環境では、この設定は通常のデスクトップの背景色と同じですので、変更する必要はありません。

ログオン時にTempフォルダ内のファイルを削除する

ログオン時に環境変数Tempで設定されているフォルダのファイルを削除します。

「最近使ったファイル」を起動時に削除する

スタートメニューの「最近使ったファイル」に表示される履歴を起動時に削除します。Windowsは「最近使ったファイル」をショートカットで実現しています。これは「C:\Windows\Recent」又は「C:\Windows\Profiles\(User)\最新」というフォルダに格納されます。この機能を有効にするとこのフォルダー内のファイル（即ちショートカット）も同時に削除されます。

「検索条件」で入力された文字列を起動時に削除する

スタートメニューの「検索」－「ファイルやフォルダ」でファイル検索画面が表示されますが、この機能はこの画面で入力した検索キーワードの履歴を削除します。

「ファイル名を指定して実行」で入力された文字列を起動時に削除する

スタートメニューの「ファイル名を指定して実行」で表示される画面で入力したコマンドの履歴を削除します。


Performance

パフォーマンス

カーネルを常に物理メモリに配置

WindowsXPではメモリの使用状況に応じてカーネルの一部を仮想メモリにスワップします。PCに十分なメモリを搭載している場合（推奨：256MB以上）、カーネルを常に物理メモリに配置するように設定することでパフォーマンスが向上する可能性があります。私のテスト環境では体感出来るほどは向上しませんでした。

アプリケーション起動用メモリをLargeモデルにする

PCに十分なメモリを搭載している場合（推奨：256MB以上）、アプリケーション起動用メモリをSmallモデル（デフォルトで4MB）からLargeモデルに変更することでパフォーマンスの向上が期待できます。

Pentium-IIIの２次キャッシュサイズを強制的に512KBで認識させる

PentiumIIIでは512KBの二次キャッシュを搭載しているものがあります。初期設定値は0KBでこの場合WindowsXPでは起動時にHALから自動的に二次キャッシュサイズを取得し（うまく取得できなかった場合は256KB）設定しています。これを強制的に512KBと認識させることによりパフォーマンスが向上する場合があります。現在のところ物理的に二次キャッシュサイズが256KBである場合でも512KBに設定することでパフォーマンスが向上するようです。私のテスト環境でのベンチマークテスト結果は約10%向上しました。


System

システム

登録情報

マイコンピュータのプロパティで表示される使用者名や会社名を変更できます。


Uninstall

アンインストール

アプリケーションをコントロールパネルの「アプリケーションの追加と削除」からアンインストールせず、直接フォルダ毎削除したような場合に「アプリケーションの追加と削除」にアンインストール情報が残ってしまい二度と消さないことがあります。そのような場合に削除する機能です。


AutoRun

自動実行

AUTOEXEC.BATに記述がないのに起動と同時に起動されるアプリケーションが多数あります。何かシステム設定を変更してアプリケーションを起動したくない場合やトラブルの原因追求するときに一時的に無効にしたい場合等に使用する機能です。


File Cleaner

不要ファイル掃除機

このツールはごみ箱に入れたり圧縮して別の場所に保存するというような機能は持っておりません。検索された内容は、必ず確認の上削除して下さい。

バックアップファイル

各アプリケーションが作成するバックアップファイルです。通常、拡張子がBAK,OLDか、拡張子の上1桁が「$」になっています。この条件に該当するファイルを検索します。

テンポラリファイル

各アプリケーションが作成する一時的な作業ファイルです。通常、各アプリケーションが終了時に削除されますが、一般保護違反等が発生するとその時点での作業ファイルが残ることがよくあります。通常、ファイル名の上1桁が「~」か拡張子が「TMP」なのでこの条件に該当するファイルを検索します。

最近使ったファイル

これはWindowsが勝手に保存する最近使ったファイルのショートカットファイルです。スタートメニューの最近使ったファイルで表示されるものを検索します。

ヘルプキャッシュファイル

これはヘルプファイルを開いたときにWindowsが勝手に作成するキャッシュファイルです。これを削除しても次回ヘルプファイルを開いたときにまた勝手に作成されますので問題はありません。このファイルは結構サイズも大きいのでディスク容量の観点からすると効果的です。通常、拡張子が「GID」なのでこの条件に該当するファイルを検索します。

Windowsフォルダ内テキストファイル

これはWindowsフォルダの中にあるテキストファイルです。Windowsのいろいろな情報が記載されているテキストファイルです。通常約490KByte程度容量を確保できます。詳細はC:.htmを参照してください。

破損クラスタファイル

スキャンディスクを実行したときに破損クラスタを見つけるとその内容をファイルに保存します。ところが、このファイルがあっても何か修復ツールがない限りを実際に役立ちません（中身をバイナリエディタ等で開けばある程度はわかる場合もあります）。

MSCREATE.DIR

マイクロソフト製品をインストールするとできている0バイトのファイルです。私が確認したレベルではこれを削除しても特に問題は発生しません。


Keyboard Cleaner

キーボード掃除機

これは電源を入れたままキーボードを掃除したい場合等にお使い下さい。私は昼休みにキーボード上に本を置いてそれを見ながら手前に弁当を置いて食べています（机が大きくなくデスクトップなので）。


Mouse Cleaner

マウス掃除機

突然マウスの動きが悪くなることありませんか？電源を切ってマウスを掃除するのが面倒くさい人は是非お使い下さい。


Copyright

使用許諾

作者は、本許諾書の条件に基づき、本ソフトウェアをインストールして使用する非独占的権利をユーザー１名のみに無償で許諾します。ユーザーは、本ソフトウェアをサーバー上にインストールし、複数台のコンピュータで同時に使用することができます。

著作権その他の権利の帰属

本ソフトウェアおよび付属文書に関する所有権、知的財産権その他一切の権限は作者に帰属します。本ソフトウェアは、著作権法および国際著作権条約をはじめ、その他の無体財産権に関する法律ならびに条約により保護されています。ユーザーは、本ソフトウェアあるいは本許諾書その他の付属文書に付された権利表示を改変あるいは除去してはいけません。

複製および頒布

ユーザーは、４条その他本許諾書のあらゆる条項を遵守することを条件に、本ソフトウェアを複製、頒布することができます。ただし、インターネット上において頒布する場合、雑誌、書籍等に収録、頒布する場合は、作者の事前の許諾を得なければならないものとします。

禁止条項

ユーザーは、以下のことを行うことはできません。

  1. 第三者に対し、本ソフトウェアを販売ならびに販売を目的とした宣伝、展示、使用、複製、営業等を行うこと。
  2. 第三者に対し、本ソフトウェアの使用権を譲渡あるいは再許諾すること。
  3. 第三者に対し、本ソフトウェアを貸与、リースもしくは担保設定すること。
  4. 本ソフトウェアをリバースエンジニアリング、逆コンパイル、逆アセンブルすること、または派生商品を作成すること。
  5. 本許諾書その他の付属文書を含め、本ソフトウェアの一部または全部を改変あるいは除去すること。

責任の制限

作者は、本ソフトウェアおよび付属文書について、その品質、性能または特定目的に対する適合性を含め一切保証はいたしません。いかなる場合においても、本ソフトウェアおよび付属文書の使用または使用不能から生じるコンピュータの故障または損傷、情報の消失、その他あらゆる直接的および間接的損害に関し、作者は一切責任を負いません。


Support

サポート

最新情報等は「WindowsHouseホームページ」(http://www.asahi-net.or.jp/~vr4m-ikw/)に掲載してあります。ご質問・ご要望は下記メールアドレスにお送り下さい。

vr4m-ikw@asahi-net.or.jp 猪川正巳

お問い合わせの際は、「窓の手」のインストールフォルダ内の「MySettings.ini」を添付して送っていただくと、より適切な回答ができると思います。私は仕事の関係上、基本的に日に一回しかアクセスできません。また、一日にくるメールも多い為、最低３日程度の余裕をもってお問い合わせ下さい。


Thanks

謝辞

「窓の手」のβテストで多数のご意見をいただいた杉本亮氏・住田富雄氏と貴重な情報を下さった祐基氏（http://www.yuuki.com）と健治氏（http://www.terra.dti.ne.jp/~ken-ji）に深く感謝致します。

また、多数のご意見ご要望をいただいたユーザーの皆様にも深く感謝致します。


History

改版履歴

ver6.0

  • [XP] WindowsXPで動作確認。WindowsXPでは不要な機能を削除しWindowsXP専用版として再構築
  • [XP] WindowsXPの場合新しいGUIスタイルで表示（不要ファイル掃除機を除く）
  • [XP] ログイン画面にAdministratorを表示する機能を追加
  • [XP] マイコンピュータの共有ドキュメントを隠す機能を追加
  • [XP] Windows Messengerの自動起動を無効にする機能を追加
  • ネットワーク関連設定(MTU,RWIN等)を変更できる機能を追加
  • 設定反映していない設定がある場合メッセージを表示するように修正
  • 不要ファイル掃除機で一部だけ削除した場合、誤った表示がされることがある不具合を修正
  • 不要ファイル掃除機で「TProgress Barの範囲を超えています」というエラーが表示されることがある不具合を修正
  • 不要ファイル掃除機でDESKTOP.INIは削除対象としないように修正
  • 不要ファイル掃除機でGoogleツールバー関連のファイルを削除対象としないように修正
  • 開発言語をC++Builder5からDelphi6 personalに移行

ver5.53

  • [Win2000,NT4] 「窓の手」の初回インストール時に誤ったインストール先パス名が提案されインストール出来ない問題を修正

ver5.52

  • Internet Explorer 6を導入すると「ごみ箱」の名前が変更できなくなる現象に対応
  • Outlook Express 6のタイトルが変更できない現象に対応
  • [Win2000] OSのインストール方法によって「窓の手」が導入できない場合があることに対応

ver5.51

  • アクティブデスクトップを無効にする機能を追加
  • パスワードに特殊文字が存在するとパスワード不一致となる不具合を修正
  • 不要ファイル掃除機でOfficeXPで使用されるDATA.BAKファイルを検索対象外に変更
  • その他の細かな操作性の改善

ver5.5

  • Internet Explorerでソース表示するエディタを変更できる機能を追加
  • [Win2000,WinMe] プレースバーに関する機能を追加
  • [Win2000] Pentium-IIIの２次キャッシュサイズを正しく認識させる機能を追加
  • [Win2000] カーネルを常に実メモリに配置する機能を追加
  • [Win2000] ファイルキャッシュサイズを変更できる機能を追加
  • [Win2000] アプリケーション起動用メモリモデルを変更する機能を追加
  • [Win9x,WinMe] タイムスライス値を最適にする機能を追加
  • [Win2000] 既に起動しているアプリケーションの別セッションを起動した場合にタスクバーで3回点滅させるのではなくフォアグラウンドで表示する機能を追加
  • 実行可能なアプリケーションを制限する機能を追加
  • パスワードの保存方法を変更
  • [Win98,WinMe] デスクトップにWindowsバージョンを表示する機能を追加
  • 削除したアンインストール情報をクリアする機能を追加
  • 窓の手本体の二重起動を防止
  • 不要ファイル掃除機の起動時に前回の検索対象ドライブを表示するように修正
  • 不要ファイル掃除機で<WinDir>\PCHEALTHフォルダ以下は検索対象外に変更
  • [WinMe] DOSプロンプトの背景色、文字色が2回目以降変更できない不具合を修正
  • [WinMe,Win2000] 検索履歴が正しくクリアされない不具合を修正
  • [Win2000] 画面のプロパティでマイコンピュータやネットワークコンピュータのアイコンを変更した後、窓の手からこれらのアイコンが変更できなくなる不具合を修正

ver5.01

  • WindowsMeでの動作確認と調整
  • [WinMe] 「標準に戻す」ボタンを押したときにFavoriteフォルダのアイコンが標準に戻らない点を修正
  • [WinMe] WindowsGUIを起動する設定を解除できないように変更
  • [WinMe] ブートロゴを表示する設定を解除できないように変更
  • [WinMe] シングルMS-DOSモードも変更できないように変更
  • [WinMe] 圧縮フォルダのアイコンを変更できる機能を追加
  • [WinMe] ごみ箱の名前が変わらない点を修正
  • [WinMe] スタートメニューのログオフを隠す設定をしても隠れない点を修正
  • [WinMe] 「標準に戻す」ボタンを押したときに背景色がWin9x系の緑色に戻る点を修正
  • [WinMe,Win2000] スタートメニューのヘルプを隠す設定を追加
  • [WinNT,Win2000] 管理者権限の無いユーザーの場合インストールできないように変更
  • スタートメニューのドラッグドロップ操作を禁止する機能を追加
  • 「標準に戻す」ボタンを押したときに起動ロゴをバックアップから戻すかどうかを尋ねるように変更
  • セットアップする際、存在しないフォルダの中に更にフォルダを指定してインストールすると正常にインストールされない不具合の修正
  • アイコン選択時のオープンダイアログのキャプションに現在変更中のアイコン種類を表示するように変更
  • 画面上のコメントを修正（対象外のOSの場合にグレーアウトするように変更）
  • IE5のツールバーの設定が「ファイルに保存」ボタンで保存したファイルを再度読み込むと正しく反映されない不具合の修正
  • Visio2000等がインストールされている環境で関係ないエントリーがアンインストールタブに表示される不具合の修正
  • コントロールパネルの表示フォントの大きさに関係なく同じ大きさの画面で表示するように変更
  • 不要ファイル掃除機で他のアプリケーションで使用中のファイルを削除する際に「読みとり専用属性が付いています」という誤ったメッセージが表示される問題を修正
  • コンパイラのバージョンアップ

ver5.0

  • Windows2000製品版での動作確認
  • [Win2000]マイドキュメントのアイコン変更機能を追加
  • [Win2000]ごみ箱アイコンが実際のものと異なる表示になる場合に対応
  • [Win2000]ごみ箱の名前が2回目以降反映されなくなる現象に対応
  • [Win2000]「標準に戻す」ボタンで「FavariteFolder」「検索-インターネット」「ビットマップ」のアイコンと「ログオン画面の背景色」が本来と異なる設定に戻る不具合を修正
  • [Win2000]マイドキュメントのアイコンが変更できない現象に対応
  • [Win2000]「シャットダウンと同時に電源断」機能を無効
  • [Win2000]「最後にログオンしたユーザー名を表示しない」機能を無効
  • [Win2000]「ダイヤルアップ」のアイコンが変更されない不具合を修正
  • [Win2000]バックアップボタンを押した場合にNTBACKUPを起動するように修正
  • [NT4.0][Win2000]起動時にNumLockキーをオンにする機能を追加
  • [Win2000]デスクトップにWindowsバージョンを表示する機能を追加
  • システムロケールが日本語以外の場合、英語で表示
  • OutlookExpress5のタイトルを変更できる機能を追加
  • 「新規作成」「アンインストール情報」「自動実行」でダブルクリックしても操作できるように変更
  • 何か変更した場合だけ「設定変更」ボタンが押せるように変更
  • 右クリックメニューした際に「アイコン変更」という表示から「アイコン変更(I)」という表示方法に変更
  • 右クリックメニューした際に「MS-DOSプロンプト」という表示から「MS-DOSプロンプト(C)」という表示方法に変更
  • 右クリックメニューした際に「別ウィンドウで開く」という表示から「別ウィンドウで開く(A)」という表示方法に変更
  • インストール時に使用許諾書を表示するように変更
  • ヘルプファイルをHTMLHELPに変更（Windows95,NTでIE4.0以上を導入していない環境では表示できません）
  • NT,Win2000でアイコン一覧の番号表示が間違って表示される現象を修正
  • コントロールパネルのアプリケーションの追加と削除で一覧表示される以外のエントリが「アンインストール情報」に表示される現象を修正
  • 受信トレイが一部の環境で隠れない現象の対策（クラスIDの判別論理を変更）
  • 不要ファイル掃除機：検索論理を見直し
  • 不要ファイル掃除機：「全てのローカルドライブ」で検索可能に変更
  • 不要ファイル掃除機：起動時に全てのローカルドライブを検索する機能を追加
  • 不要ファイル掃除機：検索対象外フォルダの指定を最大5まで拡張
  • 不要ファイル掃除機：検索実行後、設定変更し再度検索すると削除対象ファイルが見つからなくても削除ボタンが押せてしまう不具合を修正

ver4.5D

  • マイコンピュータ内のWEBフォルダを隠す機能を追加
  • コントロールパネル（システム、ネットワーク、画面、パスワード）の制限機能を追加
  • レジストリエディタの制限機能を追加
  • 「窓の手」自身にパスワードをかける機能を追加
  • 新規作成のエントリの削除機能を追加
  • ログオン時にTempフォルダ内を削除する機能に、ファイルだけでなくフォルダーも含めるオプションと削除したファイル・フォルダをごみ箱に入れるオプションを追加
  • 従来のWindowsスタイルで表示する機能を追加
  • フォルダー設定を保存しない機能を追加
  • スタートメニューをクリックするまで開かない機能を追加
  • ヘルプをHTMファイルに変更
  • 閉じるボタンの復活
  • Windows95 OSR2とNT4.0で受信トレイが隠れない不具合を修正
  • 「窓の手」をインストールしたドライブに「Program」というフォルダがあると自動削除機能が動作しない不具合を修正
  • ウィンドウサイズの変更、レイアウトの変更等
  • IE5を導入した環境で「標準に戻す」で履歴アイコンが元に戻らない不具合を修正
  • 「ショートカットアイコンを隠す」を無効にした際に標準の矢印アイコンを設定するように変更
  • 「ビットマップをアイコン表示する」を無効にした際に標準のアイコンを設定するように変更
  • NT4.0で右クリックのコマンドプロンプトを無効にしても右クリックメニュー内に表示だけが残る不具合を修正
  • アンインストール情報の削除機能で過去に同じソフトを削除した場合に削除されない不具合を修正
  • Windows2000β3での動作確認（全機能を動作検証したわけではありません）
  • Windows2000β3でごみ箱のアイコンが変更されない現象に対応

ver4.5C

  • IE5を導入した環境での動作確認
  • IE5ツールバー背景の変更機能を追加
  • 起動時にWindowsのTempフォルダ内のファイルを削除する機能を追加
  • Windows95+Plus!の環境でデスクトップテーマで変更したアイコンが表示されない現象及びデスクトップテーマで「マイコンピュータ」「ネットワークコンピュータ」が変更できなくなる現象に対応
  • マイコンピュータをダブルクリックしたらエクスプローラを有効にした場合にマイコンピュータを右クリックして表示されるメニューに「開く」が２つある現象及びタスクスケジューラを起動すると関係ない場所のエクスプローラが表示されてしまう現象に対応
  • 未登録ファイルをダブルクリックしたらメモ帳で開く機能を有効にした場合、マイクロソフトOfficeツールバーやFileViser等でメモ帳が起動してしまう現象に対応（従来全てのファイルの右クリックに「メモ帳で開く」等のメニューが表示されましたが、この対応により未登録ファイルのみか従来通り全てのファイルかを選択できるようにしました）
  • 最近使ったファイルの履歴をログオン時に削除するを有効にした場合、履歴だけではなく実体であるRecentフォルダ内のショートカットも削除するように変更
  • ツールバー背景を変更した場合、再起動又はログオフを促すメッセージを表示するように変更
  • 自動ログオン設定でパスワードが入力されない場合、入力を促すメッセージを表示

ver4.5B

  • WindowsNT4.0にIE4アクティブデスクトップをインストールした一部の環境で「窓の手」画面上にアイコンが表示されない不具合を改善
  • フォルダアイコン変更でフォルダ位置を保存するように変更
  • フォルダオプションを隠す機能を追加
  • アクティブデスクトップを隠す機能を追加
  • 起動終了ロゴ変更を「窓の手」本体に吸収
  • 一部のCompaqマシンでの不正なロゴファイルに対応

ver4.5A

  • Windows95版とWindows98版とWindowsNT4.0版を統合
  • ネットワーク全体アイコンを変更可能に
  • ワークグループアイコン、ワークグループコンピュータアイコンを変更可能に
  • サスペンドアイコンを変更可能に
  • 設定反映後、「窓の手」本体を終了しないように変更
  • Internet Explorer 5 Beta2で「検索－インターネット」が2つ現れる現象に対応
  • AnonymousFTPサーバーに通知するメールアドレスを設定可能に
  • 「最近使ったファイル」を起動時に削除する手法を変更(従来はAUTOEXEC.BATで実現)
  • 起動時に「ファイル名を指定して実行」で入力されたコマンド履歴を削除する機能を追加
  • 起動時に「検索」－「ファイルやフォルダ」で入力された検索文字列履歴を削除する機能を追加
  • ログオン画面の壁紙を設定する機能を追加
  • ログオン画面の背景色を設定する機能を追加
  • 「未登録ファイルをダブルクリック・・・」で参照ボタンを追加
  • Windowsインストールパスで参照ボタンを追加
  • アイコン一覧画面でダブルクリックするとアイコンを選択できるように変更
  • 各ドライブを隠す設定を変更後、再起動を促すメッセージが表示されないバグを修正
  • 設定ファイルの形式を変更（注：旧バージョンの設定ファイルとは互換性がありません）
  • コマンドボタンのデザイン変更
  • フォルダーアイコン変更で「標準に戻す」ボタンで標準に戻した場合フォルダーのシステム属性を解除するように修正
  • 【不要ファイル掃除機】検索除外フォルダーの指定を可能に
  • 【不要ファイル掃除機】MSCREATE.DIRを削除候補に追加
  • 【不要ファイル掃除機】削除対象拡張子の設定を最大5から最大10に拡張
  • 【不要ファイル掃除機】読み取り専用属性のファイルがある場合、確認メッセージを表示し強制削除を可能に変更
  • 【不要ファイル掃除機】コマンドボタンのデザイン変更
  • 初回起動時にレジストリとシステムファイルを自動バックアップ
  • 一部の環境でWindows直下のUser.datがバックアップされないバグを修正
  • MS-DOSプロンプトの背景色を変更する機能を追加
  • コントロールパネル－画面－効果でごみ箱アイコンを変更した場合、Recycleフォルダのアイコンがデスクトップのアイコンと異なる表示をするWindowsのバグを改善
  • 【起動終了ロゴ変更】コマンドボタンのデザイン変更
  • 受信トレイアイコンの変更機能を復活
  • MS-DOSプロンプトの輝度と色を変更する機能を復活
  • NameCache，PathCacheの誤りを訂正する機能の削除
  • ディスクキャッシュサイズ（vcache）の変更機能を追加

ver4.31

  • インターネットエクスプローラのタイトルの変更機能を追加
  • アウトルックエクスプレスのタイトルの変更機能を追加
  • Sony Vaioで「ショートカットアイコンを隠す」設定をOnにすると一般保護違反が発生する現象に対応
  • IE検索ページを変更が反映されない不具合を修正
  • 800x600以下の解像度で不要ファイル掃除機のボタンが隠れてしまう不具合を修正
  • アイコン変更時の「・・・」ボタンで開いたフォルダを記憶するように変更
  • アウトルックエクスプレスがアンインストールされた環境の場合に、スタートメニューの「検索－人」のアイコンが追加されてしまう不具合を修正

ver4.3

  • インストーラを変更、圧縮方式変更により書庫サイズをver4.2の約1/3に
  • 検索－インターネットのアイコン変更機能追加
  • 検索－人のアイコン変更機能追加
  • Active-Xキャッシュフォルダーのアイコン変更機能追加
  • 購読のフォルダーのアイコン変更機能追加
  • お気に入りアイコンとFavoriteフォルダーアイコンを別々に変更可能
  • スタートメニューにヒストリーを追加する機能を追加
  • キーボード掃除機でAlt+Tab，Ctrl+Alt+Delを無効にした
  • フォントを「MS Pゴシック」から「MS UI Gothic」に変更
  • キーボード掃除機、マウス掃除機の背景を黒に変更
  • ロゴ変更にプレビュー機能追加
  • ロゴ変更のドライブスペース対応（ホストドライブを指定可能に）
  • ロゴ変更でNEC PC-98xxでBドライブにWindowsをインストールしている環境で設定できない不具合を修正
  • MSDOS.SYSに読み取り属性があるときの不具合を修正
  • IE検索ページを変更できる機能を追加

ver4.2

  • マイドキュメント、タスクのアイコン変更機能を追加
  • 受信トレイ関連機能の削除
  • デスクトップにダイヤルアップネットワークを追加する機能の削除
  • 壁紙の位置を変更する機能の削除
  • MSDOSプロンプトの強調表示、表示色変更機能を削除
  • NameCache，PathCacheの誤りを訂正する機能の削除
  • 起動時に最近使ったファイルを削除する機能で、空白を含むユーザー名の場合に削除されない不具合を修正
  • 「$」で始まるファイルを対象外に変更
  • 検索オプションが保存できるように変更
  • 任意の拡張子を選択できるように変更
  • 最初の起動時に標準ロゴを自動バックアップする機能を追加
  • 色数をチェックする機能を追加
  • キーボード掃除機を追加
  • マウス掃除機を追加

ver4.1

  • 「拡張子．の画像形式は処理できません」というメッセージが表示され窓の手が起動できない不具合の修正
  • AUTOEXEC.BATが存在しない場合「ファイルC:.BATは開けません」というメッセージが表示され窓の手が起動できない不具合の修正
  • 十数回に及ぶアイコン変更を繰り返した場合、アイコン表示が正しくならない場合があることへの対応（アイコンキャッシュファイルの再構築）
  • 起動終了ロゴでロゴファイルが存在しない場合起動できない不具合の修正
  • 起動終了ロゴで指定されたファイルがビットマップ以外のファイルが指定された場合に起動できない不具合の修正

ver4.0

  • 各フォルダー毎にフォルダーアイコンを変更する機能を追加
  • アイコン変更やスタートメニュー隠蔽時に再起動しなくてもよいように変更
  • 設定内容を任意のファイルに保存可能に
  • インターネットエクスプローラのツールバーの背景を変更可能に
  • インターネットエクスプローラのアニメーションロゴを変更可能に
  • 壁紙の位置を変更可能に
  • 最近使ったファイルを起動時に削除可能に
  • アプリケーションの追加と削除のゴミエントリを削除可能に
  • 自動実行アプリケーションの削除・復活を可能に
  • MS-DOSコマンドプロンプトの文字を明るくしたり、文字色を変更可能に
  • 起動時、終了時のロゴを変更可能に
  • レジストリバックアップ機能を追加
  • 不要ファイルの削除を簡単にするプログラムの追加
  • ドライブ毎にアイコンを変更可能に
  • 共有アイコンの変更を可能に
  • スタートメニューのタスクバーアイコンを変更可能に
  • スタートメニューのアクティブデスクトップアイコンを変更可能に
  • ヒストリーフォルダアイコンを変更可能に
  • デスクトップにダイアルアップネットワークを追加できるように対応
  • 標準インストールに対応（アプリケーションの追加と削除に対応）
  • 「，」があるファイル名のアイコンを指定した後、起動できなくなる不具合を改善

ver3.3

  • アイコンを標準に簡単に戻せる機能を追加
  • スタートメニューのプログラムアイコンを指定した場合に、下位のアイコンも変更するように変更
  • ie4.0正式版のアイコン変更を可能にした
  • ie4.0でスタートメニューに追加された、ログオフとお気に入りのアイコンを変更する機能を追加
  • お気に入り、最近使ったファイル、ログオフを使用不可にする機能を追加
  • 「未登録ファイルを取り敢えずメモ帳で開く」をメモ帳以外のアプリーケーションも指定できるように変更
  • 「一般保護違反のログを出力する」のログファイル名を指定できるように変更
  • アイコン一覧ポップアップ画面でファイル名を表示するように変更
  • 所属名（会社名）も変更できるように変更
  • インストールパスを変更できる機能を追加
  • アイコン表示可能数を100から無制限に変更
  • 全てのファイルに特定のプログラムを関連付けをしている環境での不具合を改善
  • 任意のフォルダーの一つ上の階層で、DOS窓が開いてしまう不具合を改善

ver3.2

  • スタートメニューアイコンを変更する機能を追加
  • 一般保護違反のログを出力する機能を追加
  • アイコン表示可能数を50から100に拡張
  • ファイル候補に*.*を追加
  • 画面にコメントを追加
  • OSR2でエクスプローラアイコンが変わらない場合がある件に対応

ver3.1

  • マイコンピュータを右クリックのメニューにゴミが残るバグを修正
  • 任意のフォルダから別ウィンドウを開くオプションを追加
  • ショートカットアイコンを隠すオプションを追加
  • プルダウンメニューを右揃えにするオプションを追加
  • 「コンピュータの使用目的」の間違った値を訂正するオプションを追加

ver3.0

  • インターネットアイコンを変更する機能を追加
  • ブリーフケースアイコンを変更する機能を追加
  • 受信トレイアイコンを変更する機能を追加
  • コントロールパネルアイコンを変更する機能を追加
  • プリンタアイコンを変更する機能を追加
  • ダイアルアップアイコンを変更する機能を追加
  • スタートメニューの「設定」を使用不可にする機能を追加
  • 「Starting Windows95 ...」の表示時間を変更する機能を追加
  • 起動時GUIを起動するかの機能を追加
  • アニメーションロゴの表示有無を変更する機能を追加
  • ブートメニューの表示有無を変更する機能を追加
  • マイコンピュータにごみ箱を表示する機能を追加
  • フォルダーを右クリックしてDOS窓を開く機能を追加
  • DOS窓を使用不可にする機能を追加
  • シングルモードMS-DOSを使用不可にする機能を追加
  • DoubleSpace/DriveSpaceをメモリから外す機能を追加
  • 未登録ファイルは取りあえずメモ帳で開く機能を追加
  • ビットマップをアイコン表示するオプションが元に戻らないバグを修正
  • マイコンピュータをダブルクリックしたらエクスプローラを起動するオプションが元に戻らないバグを修正

ver2.2

  • IE4.0βがインストールされている環境での不具合に対応
  • エクスプローラでのビットマップファイルのアイコンを変更可能に
  • アイコンに*.CPL（コントロールパネル）ファイルも選択可能に

ver2.1

  • 一部の環境での不具合を修正

ver2.0

  • オプション「隠す」を多数追加

ver1.0

  • 初公開


Backup Registry and Restore Registry

レジストリのバックアップと復元

Windows95/98

「窓の手」はインストール後の初回起動時にレジストリを自動バックアップします。窓の手を操作する前には念のため「バックアップボタン」でバックアップして下さい。バックアップファイルは「窓の手」のインストールディレクトリのregbackというフォルダー内に保存されます。下記のファイルがバックアップされます（windowsディレクトリがc:\windowsの場合）。

  • c:\windows\system.dat
  • c:\windows\classes.dat (WindowsMeのみ)
  • c:\windows\user.dat
  • c:\windows\profiles\(user)\user.dat
  • c:\windows\system.ini
  • c:\windows\win.ini
  • c:\autoexec.bat
  • c:\config.sys
  • c:\msdos.sys

バックアップから復元する場合は、下記手順で復元して下さい。

  1. WindowsをDOSモードで再起動して下さい
  2. cd c:\Windows
  3. attrib -h -r -s system.dat
  4. attrib -h -r -s user.dat
  5. copy c:\winhand\regback\system.dat c:\windows
  6. copy c:\winhand\regback\user.dat c:\windows
  7. copy c:\winhand\regback\(user).dat c:\windows\profiles\(user)
  8. attrib +h +r +s system.dat
  9. attrib +h +r +s user.dat
  10. 再起動してください

Windows2000

「バックアップ」ボタンを押すと、Windows2000付属のバックアップツールを起動します。操作方法についてはヘルプをご参照下さい。


Boot

ブート関連

WindowsGUIを起動

この設定を無効にするとWindowsではなくMS-DOSが起動します。但し、その後Windows3.1の場合と同様にWINと入力すればWindowsが起動されます。

アニメーションロゴを表示する

この設定を無効にすると、起動ロゴが表示されずにWindowsが起動されます。

ブートメニューを表示する

この設定を有効にすると、起動時に必ずブートメニューが表示されます。

起動時にWindows\Tempファイルを削除する

Windowsやアプリケーションソフトは通常一時的なファイルをC:\Windows\Tempに作成しますが、予期せぬエラーや行儀の悪いアプリケーションによって、この中に知らないうちにファイルが溜まってしまいます。これを起動時（厳密にはログオンする時）に自動で削除します。

「Starting Windows95 ... 」を表示する時間

起動時のStarting Windows95と表示する時間を調整できます。Windows98では0で変更することはできません。

起動ロゴ

電源を入れたときと電源を切るときに表示される3つの絵は単にビットマップファイルです。以下のルールを守れば簡単に変更することができます。まず、ビットマップファイルを作成するためのソフトを用意してください。例えば、Windows付属のペイントブラシ、PhotoShop、Paint Shop Pro等です。私は、HappyPaint98 for Webというソフトを使っています。

【PC/AT互換機の場合】

  • グラフィックソフトを起動し好きな絵を書いてください。
  • 640x480ピクセルの256色ビットマップで保存して下さい。
  • 編集が終了したら320x400ピクセルの256色ビットマップに縮小して下さい

【NEC社製PC-98xxの場合】

  • グラフィックソフトを起動し好きな絵を書いてください。
  • 640x400ピクセルの16色ビットマップで保存して下さい。


FAQ

ＦＡＱ（よく受ける質問）

索引

  • アイコンの表示速度が遅くなった気がするのですが
  • アイコンが灰色っぽくなってしまったのですが？
  • [Win2000]デスクトップのアイコンは変わっているがエクスプローラ上では変わっていないのですが
  • [NT4.0]Administrator権限の無いユーザーで自動ログオン設定してしまったのですが
  • CDROMが自動起動しなくなった
  • スタートボタンの上で右クリックのメニューが表示されなくなった
  • スタートボタンの右クリックメニューの「開く」「エクスプローラ」が選択できなくなった
  • ＩＥで「リソースｘｘｘへのアクセスが禁止されてます」というメッセージが表示される
  • [NT4.0,Win2000]自動ログオンで２回目以降自動でログオンされない
  • デスクトップのコントロールパネルが動作しない
  • 起動ロゴ、終了ロゴを標準に戻したいのですが？
  • Windows95時代から窓の手を使用しWindows98にアップグレードした場合の注意点
  • デスクトップ上のコントロールパネルやプリンタアイコンが正常に動作しない
  • デスクトップ上のフォルダーのショートカットをダブルクリックするとエクスプローラが開く

アイコンの表示速度が遅くなった気がするのですが？

Windowsはアイコンを表示する際にキャッシュから表示しています。「窓の手」ではアイコンを変更した場合、このアイコンキャッシュをリセットしていますのでWindowsが再度キャッシュする時間が余分にかかります。一度キャッシュに溜まってしまえば従来と変わらないスピードでアイコンが表示されます。

アイコンが灰色っぽくなってしまったのですが？

２５６色アイコンでアイコン表示色が１６色に設定されているような場合（即ち実際のアイコンより低いアイコン表示色を設定している場合）やアイコン表示色が２５６でも画面解像度が２５６色以下の場合に発生致します。このような現象を改善するためには、アイコン表示色２５６以上、画面解像度を２５６より大きい設定（６万色以上）に設定して下さい。ＰＣによっては再起動が必要な場合もあります。

[Win2000]デスクトップのアイコンは変わっているがエクスプローラ上では変わっていないのですが

フォルダーオプションで「別プロセスでウィンドウを開く」が有効になっていると、この現象が発生します。

[NT4.0]Administrator権限の無いユーザーで自動ログオン設定してしまったのですが

Administrator権限のないユーザーで設定した場合、別のユーザーでログオンできなくなりますが、次の手順で強制的にログオン画面を表示させることができます。ログオフしてShiftキーを押しっぱなしにして下さい。

CDROMが自動起動しなくなった

デスクトップの「全てのデスクトップアイテムを隠す」を無効にして下さい。これを有効にするとにすると、デスクトップ上に表示されているマイコンピュータやごみ箱等が隠れますが、この設定はデスクトップ上の右クリックができなくなる、スタートボタン上での右クリックができなくなる、CD-ROMの自動起動が無効になる等の小さい問題点が出ます。Windows98では、この設定を使わなくても標準でデスクトップを隠すことが可能になっています。スタートメニューの設定－フォルダーオプションで「デスクトップがWebページで表示されている場合は、アイコンを表示しない」という項目をOnにして下さい。あとはデスクトップをWebページで表示すればOKです。

スタートボタンの上で右クリックのメニューが表示されなくなった

デスクトップの「全てのデスクトップアイテムを隠す」を無効にして下さい。これを有効にするとにすると、デスクトップ上に表示されているマイコンピュータやごみ箱等が隠れますが、この設定はデスクトップ上の右クリックができなくなる、スタートボタン上での右クリックができなくなる、CD-ROMの自動起動が無効になる等の小さい問題点が出ます。Windows98では、この設定を使わなくても標準でデスクトップを隠すことが可能になっています。スタートメニューの設定－フォルダーオプションで「デスクトップがWebページで表示されている場合は、アイコンを表示しない」という項目をOnにして下さい。あとはデスクトップをWebページで表示すればOKです。

スタートボタンの右クリックメニューの「開く」「エクスプローラ」が選択できなくなった

「マイコンピュータウィンドウ内のドライブシンボルを隠す」を無効にして下さい。

ＩＥで「リソースｘｘｘへのアクセスが禁止されてます」というメッセージが表示される

「ファイル名を指定して実行」を隠した場合、インターネットエクスプローラでローカルのファイルにアクセスすると「リソース○○○へのアクセスは禁止されています。」というメッセージが表示されます。

[NT4.0,Win2000]自動ログオンで２回目以降自動でログオンされない

「窓の手」の「ログオン」タブでパスワードを入力して下さい。

デスクトップのコントロールパネルが動作しない

これはＩＥ５が原因のようです。「スタートメニューにコントロールパネルを追加」は正常に動作し、「デスクトップにコントロールパネルを追加」は動作しないようです。両方とも同じ技術を使って実現しているのですが、前者は従来通り動作することを考えるとマイクロソフトが何らか理由によりこの部分に制限をかけたということだと思います。この不具合に関してはＩＥ５．０１を導入することで回避されます。

起動ロゴ、終了ロゴを標準に戻したいのですが？

窓の手をインストール後の初回起動時にバックアップを自動でとっています。バックアップ先は

C:\Program Files\WinHand\LogoOrg　　（「窓の手」のインストール先が「C:\Program Files\WinHand」の場合）

ここに以下のファイルがありますので、あとは窓の手で設定すれば戻ります。（「標準に戻す」ボタンを押すとこれを自動で行います。）

  • LOGO.SYS（起動ロゴ） ・・・・ 無い場合もあります。
  • LOGOW.SYS（しばらくお待ち下さい）
  • LOGOS.SYS（電源を切れる準備ができました）

但し、以下の場合は起動ロゴがバックアップされていません。

  • 初期のWindows95でPlus!をインストールしていない環境
  • Windows98でPlus!98がインストールされていない環境の場合
  • WindowsMe

これは元々ロゴがファイルとして存在しない為（Windowsがファイルからでなく自分自身で表示しています）に自動バックアップもとられていません。従って、ブートドライブにあるLOGO.SYSを削除又はリネームして再起動してみて下さい。標準の起動ロゴが表示されるはずです。

Windows95時代から窓の手を使用しWindows98にアップグレードした場合の注意点

上記で初回起動時に＜インストールフォルダ＞\LogoOrgにバックアップをとっておりますが、Windows95時代から窓の手をご利用されている方は当然ながらWindows95のロゴがバックアップされています。従って、この場合は「バックアップ」ボタンによりバックアップされた場所（＜インストールフォルダ＞\RegBack）の上記３ファイルとなります。

デスクトップ上のコントロールパネルやプリンタアイコンが正常に動作しない

これはＩＥ５が原因のようです。「スタートメニューにコントロールパネルを追加」は正常に動作し、「デスクトップにコントロールパネルを追加」は動作しないようです。両方とも同じ技術を使って実現しているのですが、前者は従来通り動作することを考えるとマイクロソフトが何らか理由によりこの部分に制限をかけたということだと思います。この不具合に関してはＩＥ５．０１を導入することで回避されます。

デスクトップ上のフォルダーのショートカットをダブルクリックするとエクスプローラが開く

これはバージョン４．５Ｃで仕様変更した為に発生致します。具体的には「マイコンピュータをダブルクリックしたらエクスプローラを起動」を有効にした場合に、以前のバージョンではこの言葉通りマイコンピュータをダブルクリックしたときだけエクスプローラが起動するようにレジストリを変更しておりましたが、以下の問題が発生しておりました。

  • マイコンピュータの右クリックメニューに「開く」が２つある
  • タスクスケジューラを起動すると関係ない場所のエクスプローラが表示されてしまう

以上２つの問題に対して、バージョン４．５Ｃでマイコンピュータをクリックしたときの標準値を「開く」から「エクスプローラ」に変更することで回避することに致しました。デスクトップ上のフォルダーのショートカットをダブルクリックするとエクスプローラが開いてしまう現象はこの回避策の副産物です。この問題については、従来の設定方法の復活も含めて検討したいと考えております。


Menu

はじめに
動作環境
インストール

基本的な使い方
アイコン
デスクトップ
エクスプローラ
ネットワーク/ごみ箱
右クリックメニュー
新規作成
ウィンドウ
制限
インタネットエクスプローラ
スタートメニュー
ログオン関連
パフォーマンス
システム
アンインストール
自動実行

不要ファイル掃除機
キーボード掃除機
マウス掃除機

著作権、免責事項
謝辞
サポート
改版履歴


MS-DOS

MS-DOSプロンプトを使用不可にする

MS-DOSが使用できなくなります。MS-DOSプロンプトを起動しようとすると「このコンピュータ上に制限が設けられているため、このプログラムを実行できません。システム管理者に問い合わせてください」というメッセージが表示され起動できません。

シングルモードMS-DOS機能を使用不可にする

スタートメニューの「Windowsの終了」を選択した場合に表示されるメニューで「MS-DOSモードで起動する」のメニューが隠れます。

MS-DOSプロンプトの表示を明るくする、背景色を変更、文字色を変更する

標準では背景が黒色で文字色が薄い白色です。これでは見にくいときに、変更します。


Shut down

シャットダウン

ログオン画面の「シャットダウン」を選択不可にする

ログオン画面で「シャットダウン」というボタンを選択不可にできます。即ち、ログオンしなければシャットダウンはできなくなります。

シャットダウンと同時に電源断する

PCによっては電源が切れずに再起動する機種もあります。メーカー系のPCではHAL(Hardware Abstraction Layer)を最新のものに置きかえれば自動電源断が可能になる場合があります。

終了時のロゴ

電源を入れたときと電源を切るときに表示される3つの絵は単にビットマップファイルです。以下のルールを守れば簡単に変更することができます。まず、ビットマップファイルを作成するためのソフトを用意してください。例えば、Windows付属のペイントブラシ、PhotoShop、Paint Shop Pro等です。私は、HappyPaint98 for Webというソフトを使っています。

PC/AT互換機の場合

  • グラフィックソフトを起動し好きな絵を書いてください。
  • 640x480ピクセルの256色ビットマップで保存して下さい。
  • 編集が終了したら320x400ピクセルの256色ビットマップに縮小して下さい。

NEC社製PC-98xxの場合

  • グラフィックソフトを起動し好きな絵を書いてください。
  • 640x400ピクセルの16色ビットマップで保存して下さい。