健康管理システムヘルプメニュー

１．健康管理システムユーテリティメニュー

１－１．はじめに

  このプログラムは、健康管理システムで使用しているデータベースに関する、補助的な機能をまとめたものです。
  なお、このユーテリティは、健康管理システム本体が、ユーザー登録（パスワード解除）されていないと利用できません。

１－２．機能の概要

・ 料理の取込み・取出し

  オプションの料理集データから、料理データをコピーするために使用します。
  また、自分で作成した料理データを取り出し、他者（他のコンピュータ）の健康管理システムデータベースに配布する場合にも利用できます。

注）
取り出すことのできる料理は、次の条件を満たす料理です。
一．自分で作成した料理データ、または、再配布が許可されている料理データであること。（最初からある料理データは、変更しても取り出すことはできません。）
二．料理の材料に、後から追加した食品が無いこと。（後から追加した食品を使用している料理も取り出すことはできません。）

・ 食品（成分表）の編集

  食品の成分値（食品成分表）を新規追加または内容を変更することができます。
  ただし、元からある食品の、変更・削除は、できません。
  なお、アミノ酸組成値および脂肪酸組成値については、現ユーテリティでは、行えません。

・食品（成分表）の取込み・取出し

  オプションの食品データから、食品の成分データをコピーするために使用します。
  また、自分で作成した食品の成分データを取り出し、他者（他のコンピュータ）の健康管理システムデータベースに配布する場合にも利用できます。

注）
取り出すことのできる食品データは、次の条件を満たす料理です。
一．自分で作成した食品データ、または、再配布が許可されている食品データであること。

・ データベースの最適化

  データベースで削除された部分は、見た目上は削除されていますが、実際は使わなくなったデータとして残っています。
  長い期間使用し、特に削除する回数が多い場合、最適化を実行することで、削除されたデータを消すことができ、容量の最小化、処理速度が向上します。

・ データベースの復旧

  データを編集中に、停電などにより、パソコンが止まってしまった場合、データベースが壊れてしまうことがあります。
  このような場合、データベースの復旧を試みます。
  ただし、絶対に直るものでは、有りません。万一の場合に備えて、データは、バックアップしておくことをお勧めします。

１－３．外部ＤＢ

  データのやり取りには、外部ＤＢ（外部データベース）を利用します。
  外部ＤＢには、料理データ及び食品（成分表）データが含まれます。
  外部ＤＢは、オプションデータとして配布されるか、本ユーテリティで作成します。

健康管理システムＤＢ
（健康管理ｼｽﾃﾑｲﾝｽﾄｰﾙﾌｫﾙﾀﾞ）\data\KKSD13.mdb

外部ＤＢ
（指定ﾌｫﾙﾀﾞ）\xxx.mdb

料理データ
食品（成分表）データ
その他のデータ

 →
←

料理データ
食品（成分表）データ


健康管理システムヘルプ料理ＩＯ

料理の取込み・取出し

  オプションの料理集データから、料理データを外部ＤＢに取り込みます。
  また、自分で作成した料理データを外部ＤＢに取り出し、他者（他のコンピュータ）の健康管理システムデータベースに配布する場合にも利用できます。

注）
取り出すことのできる料理は、次の条件を満たす料理です。
一．自分で作成した料理データ、または、再配布が許可されている料理データであること。
二．料理の材料に、後から追加した食品が無いこと。
（最初からある料理データは、変更しても取り出すことはできません。また、後から追加した食品を使用している料理も取り出すことはできません。）

１．ファイル指定

  取り込み元または、取り出し先の外部ＤＢファイルを指定します。
  初めて取出す場合には、ファイル指定画面で、 「新規」 で作成します。

２．コピー

  選択チェックボックスにチェックを付けた料理をコピーします。
  「コピー→」：料理の取り出し（外部ＤＢへコピー）
  「←コピー」：料理の取り込み（システムＤＢへコピー）

３．削除

  外部ＤＢから、選択（チェック）された料理を削除します。

４．選択欄の区分

  選択欄の色は、料理の出どこを表しています。
      赤色：元からある料理です。（再配布不可）
      黄色：オプションの料理です。（再配布不可）
      水色：オプションの料理です。（再配布可）
      緑色：自分で作成した料理です。（再配布可）


健康管理システムヘルプDB作成

外部ＤＢ選択

  取り込み元または、取り出し先の外部ＤＢファイルを指定します。

１．新規

  外部ＤＢファイルを新規に作成する場合に使用します。
  保管場所のフォルダと、ファイル名を指定し、「作成」を実行してください。
  外部ＤＢファイルの拡張子には、「mdb」が付加されます。

２．選択

  外部ＤＢを選択し、「選択」を実行すると、前画面に読み込まれます。


健康管理システムヘルプ食品編集

食品（成分表）の編集

  健康管理システムＤＢ内にある食品の成分値（食品成分表）を新規追加または編集を行います。

１．選択

  反転している行が、選択されている食品です。反転している食品に対して、編集します。

２．削除

  選択された食品を削除します。

３．変更

  選択された食品の成分値を変更します。 【変更・追加画面】

４．追加

  新規に食品の成分値を追加します。 【変更・追加画面】

５．コピー

  新規に食品の成分値を追加します。 【変更・追加画面】
  追加と違い、選択している食品の値がベースの値として、表示されています。

６．再表示

  新規追加した食品、編集した内容は、画面には、反映されていません。
  再表示を行うことで、編集内容を確認できます。

７．食品番号の区分

  食品番号欄の色は、食品の出どこを表しています。
      赤色：元からある食品です。（再配布不可、変更・削除不可）
      黄色：オプションの食品で、データの加工、再配布が禁止されたものです。（再配布不可、変更不可、削除可）
      水色：オプションの食品です。（再配布可、変更・削除可）
      緑色：自分で作成した食品です。（再配布可、変更・削除可）


健康管理システムヘルプ食品編集

食品（成分表）の編集－追加・変更画面

  前画面で、「変更」、「追加」、「コピー」で、表示される画面です。
  食品の可食部１００ｇ当たりの成分値を指定入力し、新規追加、または、値を変更できます。

１．食品番号

  「5桁の整数」+「-A」の番号が重複しないよう若い番号から順に発行されます。
  「-A」の付いた番号は、後から追加した食品になります。

２．食品群

  コンボボックスのリストから指定します。

３．食品名、細分

  １５文字以内の文字（全角文字を推奨）を入力します。

４．食品の成分値

  食品の可食部１００ｇ当たりの成分値を数値で、入力します。
  未入力（入力文字を消す）は、測定されてない成分値を示します。（栄養計算上は、０と扱われる。）

５．備考

  食品の補助的な説明があれば、指定します。
  ７０文字以内の文字（全角文字を推奨）を入力します。

６．補足

  食品の補助的な説明があれば、指定します。
  ７０文字以内の文字（全角文字を推奨）を入力します。
  注）備考との違い
      成分表の検索時に、この中の文字列も使われます。主用材料などの情報などに使います。

７．別名

  ５０文字以内の文字（全角文字を推奨）を入力します。

８．分量目安

  料理材料の分量を決める時の目安を入力します。
  ６０文字以内の文字（全角文字を推奨）を入力します。


健康管理システムヘルプ食品ＩＯ

食品（成分表）の取込み・取り出し

オプションの食品データ（未定）から、食品の成分表データを取り込みます。
  また、自分で作成した食品の成分表データを取り出し、他者（他のコンピュータ）の健康管理システムデータベースに配布する場合にも利用できます。

注）
取り出すことのできる食品データは、次の条件を満たす料理です。
一．自分で作成した食品データ、または、再配布が許可されている食品データであること。

１．ファイル指定

  取り込み元または、取り出し先の外部ＤＢファイルを指定します。
  初めて取出す場合には、ファイル指定画面で、 「新規」 で作成します。

２．コピー

  選択チェックボックスにチェックを付けた料理をコピーします。
  「コピー→」：料理の取り出し（外部ＤＢへコピー）
  「←コピー」：料理の取り込み（システムＤＢへコピー）

３．削除

  外部ＤＢから、選択（チェック）された食品データを削除します。

４．選択欄の区分

  選択欄の色は、食品の出どこを表しています。
      赤色：元からある食品です。（再配布不可）
      黄色：オプションの食品です。（再配布不可）
      水色：オプションの食品です。（再配布可）
      緑色：自分で作成した食品です。（再配布可）


健康管理システムヘルプDB最適化

データベースの最適化

  データベースで削除された部分は、見た目上は削除されていますが、削除データとして残されています。
  長い期間使用し、特に削除する回数が多い場合、最適化を実行することで、余計な削除データを消すことができ、容量の最小化、パフォーマンスも向上されることがあります。


健康管理システムヘルプDB復旧

データベースの復旧

  データを編集中に、停電などにより、パソコンが止まってしまった場合、データベースが壊れてしまうことがあります。
  このような場合、データベースの復旧を試みます。
  ただし、絶対に直るものでは、有りません。万一の場合に備えて、データは、バックアップしておくことをお勧めします。

  復旧できない場合には、バックアップした「KKSD13.mdb」ファイルまたは、初期状態の「KKSD13.mdb」を「DATA」フォルダの中に入れなおしてください。