Kurs języka HTML - poradnik webmastera

Ważna informacja

Kurs w postaci HTML Help ma dwa ograniczenia:

1 . Nie akceptuje większości multimediów

2 . Nie wyświetla komunikatów w pasku statusu co ma wpływ na pokazywanie niektórych skryptów

Zaletą takiej postaci jest

1 . Wszystkie pliki graficzne i HTML'e są skompilowane w jednym pliku .

2 . Kompresja przewyższa ZIP'A

3 . Wygodne narzędzia nawigacyjne i wyszukiwawcze ( panel z nimi można chować i ujawniać ) .

Witam w pierwszej części kursu Obsługi edytora UnrealEd . Edytor znajduje się wraz z pełną wersją gry Unreal Tournament w katalogu System . Kurs UnrealEd jest dla osób którzy chcą się czegoś dowiedzieć o tym edytorze i sprawdzeniu się w roli projektanta i konstruktora . Latwiej jest zagrać , stworzyć jest o wiele trudniej . Wymagana rozdzielczość to 1024 x 768 i 16 bit kolor .


Grasz sobie w Unreal ' a Tournament na twojej ulubionej dethmeczowej mapie . Wskaźnik TimeDemo przekracza 80 FPS w rozdzielce 1280 x 1024 i 32 biciolach . Zdobyłeś Racket Louncher z 1 nabojem , którą wziąłeś od sfragowanego Bota . Zostało ci 60 health . Myślisz sobie .....Hm ... mam giwerę i w grzyba naboi (aż 1) to idę kogoś zlikwidować . A tu nagle z za winkla wyskakuje BOT na GOODLIK ' u z Redemerem w grabiach . Strzelasz ostatnim nabojem ......... zez . Bot z palcem w dupie unika twojej biednej rakietki . Został ci tylko Impack Hamer . Bierzesz nogi za pas i dylasz po jakąś broń i Healta . Bot zaczyna cię gonić . Nagle staje i strzela z Redemar ' a .......... Ale niestety , fala Redemar ' a przeszyła cię jak robaka i została po tobie kałuża krwi w którą Bot później spluwa zieloną..... Myślisz dodał bym tu apteczkę 50 Healt'ową , przesunął ścianę i kopsnął Redemer ' a z 2 nabojami . Jeszcze inaczej . Zrobił mapę od zera .


Kurs UnrealEd - Konfiguracja

Minimalne wymagania

Procesor - 233MMX

Pamięć ram - 32 Mb

Karta Graficzna - Karta 4 Mb + 4 Mb Akcelerator lub Karta graficzna 8 Mb

Rozdzielczość - 800 x 600

Zalecane

Procesor - Pentium2 400Mhz

Pamięć ram - 128 Mb i więcej

Karta Graficzna - Karta graficzna z Akceleratorem 16 Mb najlepiej VooDoo2 lub 3 , 12 Mb - 16 Mb

Rozdzielczość - 1024 x 768 - 1600 x 1200

Mysz 3 Przyciskowa

Na samym początku (przed uruchomieniem edytora) trzeba pogrzebać trochę w plikach . W folderze ...\Unreal Tournament\System odnajdź plik o nazwie Unreal . ini czyli ustawienia konfiguracji . Dla bezpieczeństwa skopiuj ten plik do osobnego foldera . Jeżeli coś pójdzie nie tak to będziesz mógł go przywrócić. Otwórz go (jak by ktoś nie wiedział to nadal jesteśmy w katalogu System ) . Znajdź linijkę GameRenderDevice : (ta linijka odpowiada za wyświetlanie grafiki na pełnym ekranie) . Oczywiście modyfikujemy to co jest po dwukropku , a nie przed . Teraz zależnie od posiadanego Akceleratora wpisz :

Akcelerator | Sterownik | Co masz wpisać po dwukropku
Voodoo | Glide | GlideDrv.GlideRenderDevice
Riva TNT i pochodne | Direct X | D3DDrv.D3DRenderDevice
Matrox , Elsa ., Asus , Ati . | 1 Direct X lub 2 OpenGL | 1 D3DDrv.D3DRenderDeviceOpen , 2 GLDrv.OpenGLRenderDevice
S3 Savage | Nie wiem | MetalDrv.MetalRenderDevice
Power VR . To jest chyba pałer jak posiadasz Okulary Stereoskopowe . |  | SglDrv.SglRenderDevice
Bez akceleratora |  | SoftDrv.SoftwareRenderDevice
Aha i jeszcze jedno . W tym samym pliku odnajdź linijkę WindowedRenderDevice ( ta linijka odpowiada za wyświetlenie grafiki w oknie) i sprawdź czy po dwukropku jest wpisane SoftDrv.SoftwareRenderDevice inaczej nie można wpisać , ponieważ będzie wyskaiwać błąd oczywiście w edytorze (tak bynajmniej było u mnie ) . Trzeba to teraz przetestować . Uruchom edytor i otwórz jaką kolwiek mapę ( mapy znajdują się w katalogu ....Unreal Tournament\Maps ) . Uwaga : ci którzy nie posiadają akceleratora nie będą mogli korzystać z podglądu na pełnym ekranie , ale zawsze można spróbować . Kliknij Camera (w menu u góry) później Open Free Camera . Powinno pojawić się nowo otwarte okno teraz je zmaksymalizuj . Przez chwilę będzie ciemny obraz (poruszaj myszką) . Przypatrz się teksturom z bliska . Powinny być Akceleratowane ( jeśli posiadasz akcelerator ) . Jeżeli chcesz wyjść z podglądu to naciśnij F4 lub F8 , a jak to nie pomoże to klawisz windows . Teraz podgląd jest z dołu ekranu na pasku o nazwie Viewport i w każdej chwili możesz go przywrócić .
Teraz trzeba skonfigurować edytor pod twój sprzęt . Kliknij Options później Preferences . Pokazać się powinna taka oto tabelka .
Nas będzie interesować Rendering . Radzę innych opcji nie zmieniać bo ja raz tak namieszałem , że musiałem jeszcze raz instalować Unreala Tournament . Rozwiń Rendering i później wejdź w zakładkę odpowiadającą twojej karcie graficznej . Czyli jak ktoś ma 3dfx to 3dfx Glie support , Rive TNT to Direct3D support i tak dalej . Ja ustawiłem wszystko na MAXA i powiem wam szczerze , że chodziło nie za dobrze momentami stawał w miejscu i wisiał . To wszystko jest spowodowane małą ilością ramu . ( posiadam Pentium trzysete 32 ram i Voodoo , czyli ogólnie rzecz biorąc Gruchocik ) . Będzie trzeba jeszcze ustawić grafikę wyświetlaną w oknie czyli Softwere rendering . Ustaw tutaj wszystko na max , ponieważ jeżeli tego nie zrobisz nie będzie widać takich efektów jak np . mgły , flar ( wiadomo o co chodzi ) .


Kurs UnrealEd -- NARZĘDZIA

Narzędzi jest trochę dużo , ale i tak 1/3 będziesz rzadko używał .

Najczęściej trzymając klawisz CTRL .

Narzędzie | Oznaczenie | Sposób Wykonania
Camera 1 | Kamera . Poruszanie się w 3D . | Mamy tu parę możliwości . Z lewym przyciskiem myszy (do przodu do tyłu) z prawym (głowa do góry i na dół) oba na raz (skok do góry i na dół) . Służy też do przenoszenia obiektów z wciśniętym CTRL .
2 | Kamera . Poruszanie się w 3D . | To samo co Narzędzie 1 tylko trochę się ślizgasz .
3 | Nakładanie tekstury . | Jest to standardowa ściana . W widoku 2D figura zaznaczy się na niebiesko .
4 | Rotacja (ściana pochyła) . | Jeżeli chcesz obrócić ścianę musisz przytrzymać CTRL i klawisz myszki . Jest kilka sposobów (prawy , lewy , oba na raz) . Każda z tych możliwości odpowiada za inaczej obróconą ścianę np. - w pionie , w poziomie na ukos . Obracać można w trybie 2D jak i w 3D .
5 | Ściana pochyła względem podłogi i sufitu . | Trzymać wciśnięty CTRL i lewy klawisz myszy .
6 | Nakładanie tekstury . | Tą opcją robimy otoczenie mapy , jak mapa ma być duża i tak zwane portale (dziura w ścianie) . W widoku 2D ściana zaznaczy się na czerwono .
7 | Powiększa rozmiar figury . | Najpierw zaznacz daną figurę i rozciągnij z wciśniętym CTRL .
8 | To samo co wyżej tylko z tą różnicą , że możesz manipulować rozciąganie ( w pionie , poziomie ). | Prawy przycisk myszy i przytrzymany CTRL rozciąga w prawo i w lewo , lewy przycisk i CTRL do przodu i do tyłu , oba przyciski i CTRL w górę i w dół .
9 | Załadowanie tekstury do twojej mapy .Użyj tego jeżeli figurę poteksturowałeś narzędziem nr 6 . | Jeżeli poteksturujesz figurę zobaczysz , że jest jeszcze aktywna (czerwone kropkowane linie) , to użyj tego .
10 | Powiększanie rozmiaru figury z manipulacją ( w pionie , poziomie ) . |
11 | Zaznacza na mapie wszystkie tekstury . |
12 | Załadowanie tekstury do twojej mapy . Użyj tego jeżeli figurę poteksturowałeś narzędziem nr 3 . | Jeżeli poteksturujesz figurę zobaczysz , że jest jeszcze aktywna (czerwone kropkowane linie) , to użyj tego .
13 | Zaznacza wszystkie figury . |
14 |  |
15 | Add special brush . To narzędzie służy do wstawiania ścian specjalnych (woda , lawa , ) . O wodzie na następnej lekcji w dziale efekty FX . | Kliknij prawym przyciskiem myszy i wybierz (add movable brush) .
16 | Odznacza zaznaczone figury |
17 | Odznacza , zaznacza figury |
18 | Rzecz ruchoma (winda , drzwi odsuwane) |
19 |  |
20 |  |
21 | Sześcian (szczegóły w dziale figury) . Jeżeli chcesz zmienić wielkość to kliknij prawym przyciskiem na tą właśnie ikonę i wybierz Properties ... czyli preferencje . |
22 | Undo (wstecz) . Cofa ostatnią czynność . |
23 | Redo (powtórz). Powtarza ostatnią czynność . |
24 | Kula (szczegóły w dziale figury) . Jeżeli chcesz zmienić wielkość to kliknij prawym przyciskiem na tą właśnie ikonę i wybierz Properties ... czyli preferencje . |
25 | Przesuwa teksturę w pionie i poziomie . | Bądź w trybie 3D . Zaznacz teksturę i przytrzymaj CTRL z wciśniętym klawiszem myszki .
26 | Obraca teksturę względem osi . | Bądź w trybie 3D . Zaznacz teksturę i przytrzymaj CTRL z wciśniętym klawiszem myszki .
27 | Cylinder (szczegóły w dziale figury) . Jeżeli chcesz zmienić wielkość to kliknij prawym przyciskiem na tą właśnie ikonę i wybierz Properties ... czyli preferencje . |
28 | Usuwa wszystkie figury z mapy o prócz zaznaczonej . | Zaznaczanie odbywa się w trybie 2D .
29 | Wyłącza region . | .
30 | Stożek (szczegóły w dziale figury) . Jeżeli chcesz zmienić wielkość to kliknij prawym przyciskiem na tą właśnie ikonę i wybierz Properties ... czyli preferencje . |
31 | Usuwa zaznaczoną figurę . | Zaznaczanie odbywa się w trybie 2D
32 | Jest to coś takiego jak odświeżanie . Czasami jak rozciągasz ścianę zobaczysz że ściana aktywna znika wtedy użyj tego . |
33 | Schody (szczegóły w dziale figury) . Jeżeli chcesz zmienić wielkość to kliknij prawym przyciskiem na tą właśnie ikonę i wybierz Properties ... czyli preferencje . |
34 | Przeniesienie paska narzędzi na prawą stronę , lub odwrotnie . | Kliknij prawym przyciskiem myszy . Otworzy się menu i później (move toolbar) .
35 | Automatyczne przyciąganie wierzchołków ścian . Za miesiąc zastosujemy na naszej mapce . |
36 | Schody spiralne (szczegóły w dziale figury) . Jeżeli chcesz zmienić wielkość to kliknij prawym przyciskiem na tą właśnie ikonę i wybierz Properties ... czyli preferencje . |
37 | Pomoc UnrealEd . |
38 | Szybkość z jaką się poruszasz w trybie 2D , 3D i na pełnym ekranie . |
39 | Schody spiralne podłużne (szczegóły w dziale figury) . Jeżeli chcesz zmienić wielkość to kliknij prawym przyciskiem na tą właśnie ikonę i wybierz Properties ... czyli preferencje . |
40 | Wyłącza siatkę we wszystkich trybach 2D . Wszystkie figury przeciągamy po kratkach (siatce) . Czasami może się zdarzyć , że figura nie przystaje do obiektu . Wtedy wyłączamy tą opcję i możemy bardzo dokładnie przysunąć obiekt . Nie polecane przy zwykłych ścianach . |
41 | Wyłącza siatkę we wszystkich trybach 2D . Wszystkie figury obracamy po kratkach (siatce) . Czasami może się zdarzyć , że figura nie przystaje do obiektu . Wtedy wyłącz tą opcję i możesz bardzo dokładnie obrócić obiekt . |
42 | (Prześcieradło) .( szczegóły w dziale figury) Najchudszy prostokąt . Tym robimy np . szyby , płomienie . Jeżeli chcesz zmienić wielkość to kliknij prawym przyciskiem na tą właśnie ikonę i wybierz Properties ... czyli preferencje . |


Kurs UnrealEd - Figury

 | Wytłumaczenie
Height | Wysokość
Width | Głębokość
Breadth | Szerokość
Wall Thickness | Ile ma być odstępu po między sześcianem zewnętrznym , a wewnętrznym .
Group Name | Masz do wyboru : ściana , podłoga , sufit , zewnętrzny (tutaj nie trzeba wpisywać)
Solid | Sześcian zamknięty . To znaczy , że w środku jest wypełniony .
Hollow | Sześcian wydrążony od środka . Opcją Wall Thickness zdefiniujesz ile ma być odstępu po między sześcianem zewnętrznym , a wewnętrznym .
 | Wytłumaczenie
Outer Radius | Promień kuli .
Inner Radius | Promień kuli wewnętrznej .
Radial Sides | Ile ma mieć kula boków w poziomie .
Vertical Stripes | Ile ma mieć kula boków w pionie .
Solid | Stały , zamknięty . To znaczy , że w środku jest wypełniony .
Hollow | Kula wydrążona od środka . Opcją Inner Radius zdefiniujesz jaka ma być duża kula wewnętrzna .
 | Wytłumaczenie
Height | Wysokość
Outer Radius | Promień cylindra
Inner Radius | Promień cylindra wewnętrznego .
Sided | Ile ma miec cylinder boków , stron .
Solid | Stały , zamknięty . To znaczy , że w środku jest wypełniony .
Hollow | Cylinder wydrążony od środka . Opcją Inner Radius zdefiniujesz jak ma być duży cylinder wewnętrzny .
 | Wytłumaczenie
Height | Wysokość
Cap Height | Ile ma być odstępu po między czubkiem stożka wewnętrznego , a czubkiem stożka zewnętrznego .
Outer Radius | Promień stożka .
Inner Radius | Promień stożka wewnętrznego .
Sided | Ile ma mieć stożek boków , stron .
Solid | Stały , zamknięty . To znaczy , że w środku jest wypełniony .
Hollow | Stożek wydrążony od środka . Opcją Inner Radius zdefiniujesz jak ma być duży stożek wewnętrzny .
Capped | Stożek wewnętrzny ma (ściętą głowę) .
Align to side | Wyruwnanie boków .
 | Wytłumaczenie
Add to First Step | Wysokość pierwszego stopnia .
Step Lenght | Głębokość stopni .
Step Height | Wysokość stopni .
Step Width | Szerokość stopni
Number of steps | Ilość stopni (max. 45)
Group Name |
 | Wytłumaczenie
Clockwise | Jeśli to zaznaczysz , schody będą kręcić się zgodnie ze wskazówkami zegara .
Interrior | Po środku schodów jest pal . Czasami to się przydaje jak masz dużo stopni .
Exterior | Jest to ściana która otacza schody .
Surface | Ta grupa decyduje o górnych wierzchołkach stopni (to po czym BOT będzie mógł chodzić)
Steps | Stopnie normalne .
Sloped | Stopnie spadziste .
Ceiling | Ta grupa decyduje o dolnych wierzchołkach schodów .
Steps | Stopnie normalne .
Sloped | Stopnie spadziste .
Align to side | Wyrównanie stron , ścian .
Inner Stair Radius | Grubość pala środkowego schodów .
Outer Stair Radius | Szerokość stopni .
Outer Wall Radius | Grubość ściany która otacza schody .
Step Height | Przerwa po między schodami . Jeżeli chcemy zrobić odstęp po między schodami to wartość Step Height powinna być większa od Step Thickness . Podam przykład . Step Height wynosi 70 , a Step Thickness 50 . Proste równanie : 70 - 50 = 20 i taką przerwę będziemy mieli po między schodami . Brzmi to zabójczo skomplikowanie , ale jak trochę popraktykujesz to wejdzie ci to w nawyk . Acha . Autorom edytora coś się " popieprzyło ", ponieważ po angielsku Step Height oznacza wysokość stopnia , a nie przerwa po między schodami BIG BUG - end
Step Thickness | Wysokość stopni .
Steps per full circle | Ile ma być schodków na 360 stopni .
Total Steps | Łączna ilość stopni .
Total Height | Łączna wysokość całego obiektu .
Group Name | Masz do wyboru : Step (stopnie) wpisz to jak masz same schodki , ] Rise (podnosić się) wpisz to jak masz stopnie z przerwami , ] Celing (sufit , strop) jak w grupie Ceiling zaznaczysz Sloped to wpisz to ,] CenterPost (słup środkowy) wpisz to jak zrobiłeś schody ze słupem środkowym , ] Inner (wewnętrzny) , ] Outer (zewnętrzny) , ] Top (szczyt , czubek) , ] Base (baza) , wpisz to jak masz schody ścianę otaczającą schody i pal środkowy , ] Outerint (zewnętrzny) . Jak nie chcesz to nie musisz nic wybierać . Wystarczy , że wpiszesz Spiral (wybór deafultowy) .
 | Wytłumaczenie
Counter Clockwise | Schody kręcą się zgodnie ze wskazówkami zegara
Align to side | Wyrównanie stron , ścian .
Add to first Step | Ile dodać wysokości do pierwszego stopnia . Podam przykład . Jeżeli w Step Height wpiszesz 20 , a w Add to first Step 25 to wysokość pierwszego stopnia będzie wynosić 45 . Step Height + Add to first step = wysokość pierwszego stopnia .
Step Height | Wysokość stopni .
Inner radius | Ile ma być odstępu po między pierwszym schodem , a ostatnim . Wytłumaczenie macie na rysunku w edytorze .
Step Width | Szerokość stopni .
Angle of Curve | Zakręcenie schodów . Tutaj musisz wpisać liczbę od 1 do 360 , tyle właśnie ma pełen obrót . Jeżeli wpiszesz 90 to schody będą się kręcić od godziny 12 do godziny 3 . Kurna jak to wytłumaczyć . Przeczytaj to parę razy to coś zrozumiesz .
Number of Steps | Łączna liczba stopni .
Group Name | Możesz zostać przy ustawieniach domyślnych . Ustawienie deafultowe (Cstair) .
 | Wytłumaczenie
Flor / Ceiling | Pdłoga / Sufit
X - Wall | Pionowa ściana X
Y - Wall | Pionowa ściana Y
U : | Szerokość figury ( U )
V : | Długość figury ( V )
Group | Tutaj nic nie wpisuj . Zostaw tak jak jest czyli Sheet .


Kurs UnrealEd - Inne

Ikona | Co to jest | Jak dodać
 | Ten dżojstik ( player start ) to miejsce w którym rozpoczynasz grę. | Jeżeli chcesz dodać dżojstik do mapy to w przeglądarce po prawej ( tam gdzie jest napisane Browse ) wybierz Classes . Pokaże się taka malutka tabelka ( tak jak w edytorze rejestru ) . I teraz rozwiń : NavigationPoint i kliknij dwa razy lewym przyciskiem myszy na PlayerStart . Pojawi się niebieskie nowo otwarte okno zamknij je . Teraz na mapie kliknij prawym przyciskiem myszy i wybierz Add PlayerStart here . Jeżeli na mapie zaznaczysz dżojstik to pojawi się przy nim strzałka , symbolizuje ona w którą stronę będziesz zaczynał grę . Jeśli chcesz obrócić strzałkę w inną stronę to naciśnij na pasku narzędzi Rotate ( narzędzie nr 4 ) i przesuwaj z wciśniętym CTRL i prawym klawiszem myszki .
 | Zone Info . Czyli są to informacje o np oświetleniu , flarach , mgle itd . Jest to niezbędne do uruchomienia mapki . Ale Zone Info można podzielić na : Zone Sky ( informacje o niebie ) , Water Zone ( info wody ) , Lava Zone ( info lawy ) i jeszcze parę innych . Te zoniaki są potrzebne do robienia wody , lawy , nieba . | Classes - rozwiń Info - i teraz kliknij dwa razy na zone info ( nie rozwijać zone info tylko kliknąć dwa razy lewym przyciskiem !!! ) , zamknąc okno . Teraz kliknij prawym przyciskiem myszy na mapie wybierz pierwszą opcję od góry .
 | Te oko co widzisz obok to jest kamera . Symbolizuje ona gdzie się znajdujesz w widoku 3D i na podglądzie pełnoekranowym , a ta strzałeczka która znajduje się przyniej ma za zadanie poinformować w którą stronę patrzysz . Ta kamera znajduje się we wszystkich widokach . | BRAK
 | Ten tajemniczy obrazek obok znaczy światło . Dokładniej jeżeli zobaczymy taką pochodnię znaczy to , że w tamtym miejscu pada światło . | Kliknąć prawym przyciskiem myszy na mapie ( najlepiej z góry ) i wybrać Add Light here

Optymalizacja jest to sprawdzanie poprawności: 1] ścian \ figur ( pierwsza zakładka ) 2] poprawność tekstur ( druga zakładka ) 3] oświetlenie (trzecia zakładka ) . Są też tutaj podane informacje na temat ścian , tekstur itp .

Geometry

W tej zakładce są podane informacje o ścianach ( optymalizacja geometrii ) od góry wytłumacze te najważniejsze :

Brushes - Ilość wszystkich ścian ( czerwonych , niebieskich , szarych ) .

Add - Ilość ścian niebieskich i szarych .

Subtract - Ilość ścian czerwonych .

Special - ilość ścian specjalnych .

Average Polys - Średnia ilość tekstur pzrypadająca na jedną figurę .
BSP Stats

Ta zakładka odpowiada za tekstury nałożone na obiekt :

Polys - Ilość wszystkich nałożonych tekstur

Nodes - Ilość prostokątów ( czyli cięć ) przypadających na tekstury .

Ratio - Współczynnik . Liczbę Nodes dzieli się przez liczbę Polys i wychodzi nam liczba ratio . Czyli średnia ilość prostokątów przypadająca na jedną nałożoną teksturę . Tutaj wszystko wylicza Edytor .

Optymization

Lame - Słaba ale bardzo szybka

Good - Dobra ( wolniejsza )

Optimal - Najlepsza ( najwolniejsza )

Ten pasek niżej odpowiada za cięcie tekstur . Możemy sobie go regulować najlepiej jeżeli ustawisz go na 0 ( cięcie 0 )

Auto lighting - Czyli autooświetlenie . Zaznaczone ( normalne oświetlenie ) , Odznaczone ( outooświetlenie ) .
Jak dokonać najlepszej Optymalizacji

Przejdź na zakładkę BSP i teraz tam gdzie jest napisane ( Lame , Good , Opimal ) wciśnij Optimal a niżej przesuń suwak do oporu w lewą stronę . Zobacz czy jest zaznaczone Auto Lighting . Teraz przejdź na zakładkę Geometry i kliknij Rebuild Geometry . Najlepiej żebyś robił Optymalizację co jedną ścianę wtedy twoja mapka będzie zawierać mało Megabajtów i będzie bez bugów .

Widoki

Poruszanie się w widokach 2D : lewy przycisk myszy plansza się przesuwa do góry na dół , prawy tak samo tylko trochę szybciej , oba naraz przybliżenie i oddalenie ( poprubój to skumasz od razu ) . Mamy cztery widoki ( jak w każdym edytorze FPP ) : z góry , z boku , z przodu . Połączenie wszystkich tych trzech widoków daje nam 3D . Jeżeli chcesz żeby figura znajowała się tam gdzie być powinna , musisz ją ustawić w trzech pozycjach . ( Figury i inne przedmioty przesuwa się z wciśniętym CTRL i lewym klawiszem myszki ) . Najpierw ustaw figurę w widoku z góry , później w widoku z przodu i z boku i na końcu popatrz jak to wygląda z perspektywy ( 3D jak kto woli ) .

Menu nad widokami

Nad każdym widokiem jest takie małe menu , ale tylko w widoku 3D jest pokazane . Wystarczy nacisnąć taki trujkącik

- służy one do odkrywania i zakrywania menu .

- Jeżeli to naciśniesz w widoku 3D będzie się poruszać woda i będzie słychać odgłosy .

Mode :

Dynamic Lighting - Normalne oświetlenie w widoku 3D

Textures - Autooświetlenie . Przydaje się kiedy na mapie nie masz żadnego oświetlenia .

Polygons - W widoku 3D tekstury będą wyświetlane jako polygony . Jedna położona tekstura ma jeden kolor inna tekstura inny kolor .

Zone / Portal View - Podgląda . Każda położona tekstura jest cięta na mniejsze prostokąty . Im tych prostokątów jest mniej tym lepiej . Narzędziem Rebuild w zakładce BSP ( tam gdzie jest pasek przewijania ) , zdefiniujesz ile ma być cięć przypadającą na jedną teksturę .

BSP Cuts - To samo co wyżej tylko z tą różnicą , że teksturki będą w szarawym kolorze

Map Overhead - Dany widok zamienia na widok z góry .

Map XZ - Dany widok zamienia na widok z przodu .

Map YZ - Dany widok zamienia na widok z boku .

Map Persp - Dany widok zamienia na widok perspektywiczny czyli 3D .

View :

Show Active Brush - Pokazuje aktywną figurę czyli ta na którą nie jest jeszcze nałożona tekstura ( czerwone kropkowane linie ) .

Show Moving Brushes - Wyświetla wszystkie ruchome bloki \ figury np. windy , drzwi , przyciski itp .

Show Backdrop - Jeżeli to zaznaczysz to widoku 3D nie będzie wyświetlana siatka . Jak zaznaczysz siatka zniknie i jak wyjdziesz po za otoczenie mapy będą skakające trujkąty ( czasami ta opcja się przydaje jeżeli masz dziury w otoczeniu mapy . Pozwala na wykrycie prześwitów .

Show Coordinates - jeszcze tego nie rozgryzłem ( sprubujcie sami może wy coś zrozumiecie ) .

Show Paths - Jabłka ( czyli to po czym bot się porusza ) są połączone kreskami , jeżeli to zaznaczymy kreski będą wyświetlane w danym widoku .

Actors :

Wszystkie podpunkty zawarte w Actors dotyczą wyświetlania aktorów np . broni , apteczek , naboi , kamer

Full Actor View - Pełne wyświetlanie aktorów .

Icon View - Wszystkie aktory ( nie , nie , nie aktorzy ) zostają wyświetlone jako ikony .

Radi View - Po Polsku znaczy liczba mnoga , ale tu w edytorze to nie pasuje Hmmmmm ....

Hide Actors - Wszystkie aktory są ukryte ( nie wyświetlane ) .

Window :

16-bit color - szesnasto bitowa paleta kolorów .

32-bit color - trzydziesto dwu bitowa paleta kolorów .

Jak zrobić poprawną ścianę

1 . Najpierw trzeba podać wysokość , szerokość itd . figury .

2 . Ustawić bryłę we wszystkich widokach .

3 . Nałożyć wybraną teksturę

4 . Załadować figurę .
Grid \ Siatka

Grid jest to siatka po której przeciągamy figury . Jeżeli chcesz powiększyć lub pomiejszyć siatkę wystarczy kliknąć prawym przyciskiem myszy na jeden z widoków . Otworzy się menu przejdź na Grid i teraz wybierz liczbę jaka cię interesuje . Ja robie mapy na siatce 4 momentami 2 a Cliff Bleszynski ( gość który zrobił niektóre mapki do Unreal'a1 i Unreal'a Tournament ) i inni panowie z Epic Games robią na 4 .( łatwo to zauważyć otwierając ich mapę w edytorze ) . Tylko pamiętaj o jednym , że jak np. jak ustawisz siatkę na 4 to żeby figury przeciągały się po siatce, figury muszą mieć długość 4 , 8 , 12 , 16 i tak dalej , ale jeżeli będziesz chciał zrobić ścianę o szerokości 6 to wystarczy zmienić wielkość siatki na 2 .

Przeglądarka \ Browse

Przeglądarka - tekstury

1 . Pierwsze menu rozwijane odpowiada za przeglądanie i teraz masz kilka możliwości :

A ) Textures - Przegląda aktualnie załadowane teksturki . B ) Classes - Są tu różnego rodzaju skrypty . Wybieramy też rzecz którą chcemy dodać np . bronie , apteczki , światła itp . C ) SoundFX - Odzywki botów i inne dgłosy z Unreal Tournament . D ) Music - Muzyka z Unreala Tournament .

2 . Wybierasz aktualnie załadowany plik z teksturami .Te strzałki obok odpowiadają za :cofa na poprzedni plik z teksturami , następny plik z teksturami ( alfabetycznie ) .

3 . Każdy plik z teksturami jest podzielony na kategorie np Ceiling - tekstura na sufit , Door - tekstura na drzwi , Floor - na podłogę , Glass - na szyby , Light - teksturki na lampy , Panel - przeważnie teksturki na robienie przezroczystych komputerów , Pillar - na filary , Wall - na ściany , Window - teksturki z oknami . Możesz też wybrać All - wyświetla wszystkie tekstury z danego pliku . Strzałki poniżej to : poprzednia kategoria , następna kategoria .

4 . Aktualnie wyświetlane tekstury . Powyżej są takie cztery przyciski , odpowiadają za rozmiar wyświetlanych tekstur w przeglądarce . Pierwszy przycisk - największy rozmiar tekstur ( jedna tekstura szerokości przeglądarki ) , Drugi przycisk - średni rozmiar tekstur ( dwie tekstury szerokości przeglądarki ) , Trzeci przycisk - najmniejszy rozmiar tekstur ( cztery tekstury szerokości przeglądarki ) , Czwarty przycisk - jest to odświeżanie tekstur ( tak mi się zdaje ) .

5 . Mamy tutaj osiem przycisków . Wszystkie dotyczą tekstur .

Edit - Edytuje zaznaczoną teksturę , podaje informacje o niej .

Apply - Zastosuj . Zmienia zaznaczoną teksturę na figurze na zaznaczoną teksturę w przeglądarce .

Load - Tym otwieramy pliki z teksturami . Rozszerzenie .UTX . Jeden plik to kilkanaście tekstur .

Import - Otwiera pliki graficzne z rozszerzeniami BMP i PCX .

New - Nowa tekstura .

Delete - Usuwa zaznaczoną teksturę .

Save - Zapisuje tekstury z rozszerzeniem UTX

Export - Zapisuje teksturę jako plik graficzny z rozszerzeniem PCX i BMP .
Przeglądarka - muzyka

Play - odtwarza zaznaczoną muzyczkę w przeglądarce .

Load - Otwiera pliki z muzyką z rozszerzeniem UMX . Ten format jest otczytywany jako muzyka dla gry Unreal 1 i Unreal Tournament .

Import - Otwiera pliki z muzyką z rozszerzeniem : * . MOD , * . S3M , * . STM , * . IT , * . XM , * . FAR , * . 669 .

Stop - Muzyka stop .

Save - Zapisuje zaznaczoną muzykę jako plik z rozszerzeniem * . UMX .

Export - Zapisuje muzykę jako plik z rozszerzeniem * . S3M


Kurs UnrealEd - Robimy mapę

Robimy mapę

W edytorze UnrealEd możemy tworzyć mapy singlowe dla Unreal'a1 i multiplajerowe do Unreal'a Tournament . Na początku nauczymy się podstawowych rzeczy , a później tylko krok do zrobienia mapy singlowej dla Nierzeczywistego 1 ( Unreal'a1 ) . Jeżeli chcecie to w trzeciej części kursu wspomnę coś o Unreal'u1 . Ale jest BIG PROBLEM siadł mi modem i chyba przyszedł czas na nowy . Jak będzie to możliwe w następnej lekcji podam swój adres modemowy (jak to brzmi ) . UnrealEd ma tyle opcji , że wszystkich jeszcze nie odkryłem ( zapewniam was że jest ich sporo ) . I pomyśleć , że tym edytorem posługiwali się panowie z Epic Games co świadczy o zaawansowaniu mapek które zrobili w Unreal1 i Unrreal Tournament .

No dobra . Jeżeli zapoznałeś się z wszystkim co na tej lekcji jest przygotowane to możemy przystąpić do robienia mapki i później jej uruchomienia . Zaczniemy od małej mapy , składającą się z kilku ścian , a w następnej lekcji będziemy dodawać różne efekty do tej właśnie mapy . Otwórz przykładowe tekstury poprzez (LOAD) w przeglądarce po prawej . Tekstury znajdują się w katalogu .....Unreal Tournament\Textures z rozszerzeniem .utx . Jeden plik to kilkanaście tekstur .

1 .Na początku zmniejsz GRID (siatkę) do 1 lub 2 , wytłumaczone masz w dziale INNE . Przypominam , jak chcesz ustawić np . wysokość , szerokość bryły to wystarczy kliknąć prawym przyciskiem na ikonę danej figury na pasku narzędzi . Otworzy się menu i wybrać properties... .

Jeżeli byście mieli jakieś kłopoty z robieniem mapy to w katalogu ....KursUnrealEd1 \ Przyklad ---- macie Zzipowaną ( spakowaną zipem) przykładową mapę zrobioną prze zemnie .

2 . Sześcian jako otoczenie mapy . Najpierw zrób sześcian o wymiarach : 2000 x 2000 x 2000 . Wysokość BOTA to 100 pixeli. Teraz zaznacz wybraną przez ciebie teksturę i naciśnij nakładanie tekstury (narzędzie nr 6) na pasku narzędzi . Zobaczysz , że tekstura jest nałożona , ale stworzyła się figura aktywna w takim samym miejscu gdzie poprzedni poteksturowany sześcian , więc naciśnij narzędzie nr 9 i aktywna figura znika . Gotowe . Właśnie zrobiłeś otoczenie mapy . Jak w twojej mapie jest zupełnie ciemno ( a na pewno jest ) to kliknij Mode w menu nad widokiem 3D i zaznacz Tekstures . Jeżeli teraz chcesz dać inną teksturę na poprzednią ścianę , nie ma problemu . Zaznacz teksturę w widoku 3D ( powinna prześwitywać niebieską siatką ) i naciśnij teksturę w przeglądarce po prawej i na końcu w 3D odznacz teksturę .

3 . Schody proste . Zrób schody o wymiarach : Wysokość 16 , Szerokość 256 głębokość 25 . Oczywiście możesz wpisać własne wielkości , ale chodzi tu o to , żebyś skumał o co w tym biega . Ale na razie wpisuj podane wielkości . UWAGA !!! Wszystkie figury nie mogą się stykać z otoczeniem mapy . Pomiędzy ścianą a otoczeniem mapy musi być jedna krateczka przerwy w przeciwnym wypadku powstanie dziura na wylot mapy , a tak nie może być , ponieważ jak uruchomisz swoją mapę to będą widoczne znikające trójkąty !!!! Ustaw schody przy podłodze (jedna krateczka przerwy) . Przypominam , że przesuwanie obiektu odbywa się za pomocą CTRL ' a i lewym klawiszem myszki . Będzie trochę inaczej niż w przypadku wyżej omówionego sześcianu , więc przeczytaj sobie ten fragment parę razy . Naciśnij nakładanie tekstury ( narzędzie nr 3 ) . Zobaczysz , że tekstura jest nałożona , ale stworzyła się figura aktywna w takim samym miejscu gdzie poprzednie poteksturowane schody , więc naciśnij narzędzie nr 12 i aktywna figura znika . Zauważyłeś pewnie , że w widokach 2D schody zaznaczyły się na kolor niebieski , a to dlaczego ? Już tłumaczę . Figury z czerwonym kolorem to otoczenia mapy i wydrążenia w ścianach , a niebieskie to zwykłe ściany .

Efekt końcowy powinien być taki .

4 . Sześcian . Teraz stwórz sześcian , który będzie przystawał jedną ścianą do schodów , a drugą do podłogi . Po schodach będzie można wejść na ten blok .Wymiary to : wysokość 128 , szerokość 300 , głębokość , 256 . Zrób tak samo jak ze schodami . Najpierw ( narzędzie nr 3 ) i ( narzędzie nr 12 ) . Figura w widoku 2D musi się zaznaczyć na niebiesko ( tak samo jak schody ) .

Gdybyś nie wiedział o co chodzi , zawsze masz obrazek .

5 . Schody proste . Stwórz schody o takich samych wymiarach jak poprzednie i ustaw je na przeciwko pierwszych schodów . Tak żeby można wejść po pierwszych schodach na blok i zejść drugimi schodami . Figura w widoku 2D musi się zaznaczyć na niebiesko . Z tym chyba nie będzie problemu ( chyba ) .

6 . Sześcian jako portal . Stwórz sześcian o takich wymiarach żeby przecinał blok na wylot . Pamiętaj przejście będzie tak duże jaki duży będzie sześcian .Teraz zaznacz wybraną przez ciebie teksturę i naciśnij nakładanie tekstury (narzędzie nr 6) ( tym właśnie narzędziem wycinamy w ścianach otwory ) . Zauważyłeś , że zostało " wycięte " przejście . Popatrz na obrazek poniżej . Jeżeli coś poszło nie tak jak chciałeś , a nałożyłeś już teksturę i załadowałeś ścianę to w widoku 2D kliknij prawym przyciskiem na nieudaną ścianę i wybierz Delete ( usuń ) . Zauważyłeś , że w widoku 3D ściana nadal jest , wystarczy dokonać optymalizacji geometrii . Kliknij Options później Rebuild i przejdź na zakładkę Geometry i kliknij Rebuild Geometry .

Screen z portalem .

7 . Ściany mamy , ale żeby uruchomić mapę trzeba dodać Zone info ( wytłumaczone masz w dziale inne ) . Pamiętaj o jednym , że Zone info musi się znajdować w tym dużym czerwonym kwadracie . Możesz ustawić gdzie chcesz wyżej , niżej , ale pamiętaj nie może wystawać po za ten kwadrat . Jeżeli już wstawiłeś , kliknij prawym przyciskiem na Zone info i wybierz Zone info Properties (1 selected ...) . Pojawi się biała tabelka . Rozwiń ZoneLight . I teraz wpisz AmbientBrightness - wpisz tutaj coś koło 80 , AmbientHue - 255 , AmbientSaturation - 255 . Zone info są to informacje o oświetleniu , mgły , i w ogóle o wszystkich ścianach . Bez Zone info nie uruchomisz mapy . Teraz wystarczy dokonać optymalizacji . Kliknij Options później Rebuild i przejdź na zakładkę Geometry i kliknij Rebuild Geometry . Jak w widoku 3D zrobiło się szarawo to w porządalu ( popatrz na obrazek poniżej ) .

8. Teraz trzeba dać trochę światła bo jak widać bez światła jest trochę kijowo . Obejrzałem mapę Dm-Turbine na automatycznym oświetleniu bieda totalna , ale z normalnym oświetleniem miodzio . Kliknij prawym przyciskiem na mapie otworzy się menu i naciśnij Add light here . We wszystkich widokach pokazać się powinna taka oto pochodnia [image] . Ustaw tą pochodnie gdzie chcesz ( ja ustawiłem w wejściu przy suficie , ponieważ tam najefektowniej to wygląda ) . Jeżeli chcesz , dodaj więcej takich pochodni ( światła ) . Po ustawieniu świateł zrób Optymalizację \ Rebuild .

Screen z jednym światłem i ZoneInfo .

9 . Teraz ostatnia czynność mam nadzieję , że najłatwiejsza . Rozstawienie dżojstików czyli ( player start ) . Dżojstiki mówią nam gdzie będziesz rozpoczynał grę . Tym zajmiecie się sami , a niżej macie screeny z ukończonej mapy . Porozstawiaj dżoje przy podłodze . ( popatrz na obrazek po niżej ) . Oczywiście ja nałożyłem takie teksturki i tak porozstawiałem dżoje wy dajcie tekstury jakie wam się podobają i tak porozkładajcie player starty jak wam się podoba ( wszystko zależy od waszego gustu ) . Na samiutki koniec zrób Optymalizację \ Rebuild jak tego nie zrobisz nie pograsz sobie ( będzie wyskakiwał błąd ) . Jeżeli chcesz zagrać na tej mapie zapisz ją po przez Save As do katalogu ...Unreal Tournament \ Maps i wpisz np . DM-moja mapa1 . Ten przedrostek na początku ( DM-... ) musi być ponieważ , gra Unreal Tournament odczytuje wszystkie mapy do dethmeczu z przedrostkiem DM-... . Teraz możesz sprawdzić swoją mapę z mapą zrobioną przeze mnie . Mapa znajduje się w katalogu ....KursUnrealEd1 \ Przyklad .

Oto parę zrobionych skreniaczy ze zrobionej mapki .


Kurs UnrealEd - Co za miesiąc

Za miesiąc większość efektów specjalnych i ich bardzo szczegółowy opis : woda , lawa , slime , oświetlenie , płomienie i szyby .

Gra z botami : rozstawienie , broni i amunicji i parę innych rzeczy . Oczywiście wszystko z obrazkami . Cześć .