
О з в у ч и в а н и е  т е к с т о в  и  р а с п о з н а в а н и е  г о л о с а

äÓÏÔ¸˛ÚÂ, 

Возьму на себя смелость утверждать,

что хотя сейчас в мире разработки ПО

наблюдается относительное затишье,

новые версии программ появляются доста-

точно регулярно, и разработчики не забыва-

ют о своих детищах.

Несмотря на то что пока так и не произо-

шло качественного прорыва в такой инте-

ресной и перспективной области разработ-

ки, как распознавание речи и голосовое

управление, новые утилиты для существую-

щих технологий выпускаются с завидным

постоянством. Среди них можно встретить и

те, которые были созданы российскими раз-

работчиками, причем они ничем не хуже за-

рубежных аналогов. В представленном ва-

шему вниманию обзоре я не ставил перед

собой задачи выявить одного победителя —

все его участники предназначены для реше-

ния разных задач, следовательно, и работа-

ют по-разному.

Каждая из этих утилит имеет определен-

ные недостатки, и решать какие-либо серь-

езные задачи с помощью голосового управ-

ления невозможно. Но даже те функции,

которые имеются, ясно говорят о том, в ка-

ком направлении будут идти разработки ме-

тодов управления компьютером. Думаю, что

от возможности командовать своим «желез-

ным другом», вальяжно расположившись в

кресле, никто не откажется. 

Александр Евдокимов
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èÓÎÂÁÌ˚Â ÒÒ˚ÎÍË

ÖÒÎË Í‡Í‡fl-ÚÓ ËÁ ÔÓ„‡ÏÏ Û ‚‡Ò ÌÂ ·Û-

‰ÂÚ ‡·ÓÚ‡Ú¸ — Á‡„ÛÁËÚÂ Ë ÛÒÚ‡ÌÓ‚ËÚÂ

Ì‡·Ó „ÓÎÓÒÓ‚˚ı ·Ë·ÎËÓÚÂÍ Microsoft:

3 http://agent.microsoft.com/agent2/sdk/li-

set.exe (6,3 å·‡ÈÚ).

èÓ‰‰ÂÊÍ‡ ÛÒÒÍÓ„Ó flÁ˚Í‡:

3 http://activex.microsoft.com/activex/con-

trols/agent2/lhttsrur.exe (3 å·‡ÈÚ);

3 http://activex.microsoft.com/activex/con-

trols/agent2/tv_enua.exe (1,2 å·‡ÈÚ)

óÚÓ Í‡Ò‡ÂÚÒfl «‡„ÂÌÚÒÍËı» ÔÓ„‡ÏÏ, ÚÓ ‰Îfl

ÌËı ÔÓÚÂ·ÛÂÚÒfl ÓÚ‰ÂÎ¸Ì‡fl ÔÓ‰‰ÂÊÍ‡:

3 http://activex.microsoft.com/activex/con-

trols/agent2/msagent.exe (400 ä·‡ÈÚ).

3 http://activex.microsoft.com/activex/con-

trols/agent2/AgtX0419.exe (128 ä·‡ÈÚ).

Все чаще начинают появляться свободно распространяемые утилиты
распознавания голоса, практически ни в чем не уступающие коммер-
ческим аналогам. Правда, некоммерческие голосовые решения су-
ществовали и раньше, но только как оболочки для движков с агента-
ми или без таковых. Реальной же бесплатной альтернативы не было.

ÔÓ˜ËÚ‡È ÏÌÂ ÒÍ‡ÁÍÛ
èÓ„‡ÏÏ˚



Пожалуй, ни одна программа под Windows не

имеет так же много вариаций и надстроек,

как MS Internet Explorer. Что послужило при-

чиной тому — недостатки ли самого браузе-

ра или, напротив, его огромная популярность

среди пользователей, — сказать трудно, но

факт остается фактом: месяца не проходит,

чтобы не появился очередной клон «Иссле-

дователя».

И было бы, на мой взгляд, удивительно,

если бы разработчики голосового софта

остались в стороне от всеобщего увлече-

ния программирующей молодежи и не со-

здали бы «читающие» прибамбасы для In-

ternet Explorer. Не скомпилировали бы,

например, Web Talkster — бесплатный бра-

узер с поддержкой технологий text-to-spe-

ech и MS Agent. 

Построен он, соответственно, на движке

Explorer, но занимает при этом в полтора ра-

за больше оперативной памяти, нежели май-

крософтовский прародитель. 

Окно этого браузера, несмотря на объем-

ные кнопки и возможность разукрашивания

в разные цвета, все равно напоминает «Ис-

следователя». Правда, ряд важных функций

(копирования, печати, поиска на странице и

т. д.) спрятан в меню «Options -> File», но все

остальное сделано, как в оригинале. Плюс

три новых кнопки: «Speak» (чтение всего

текста на открытой web-страничке), «Selec-

ted» (чтение только выделенных абзацев) и

«Quit Spk» (отмена озвучивания).

Web Talkster использует симпатичных

мультипликационных персонажей — аген-

тов. Поддержка этой технологии вместе с

образом мага Мерлина устанавливается в

процессе инсталляции браузера. Впрочем,

библиотеки MS Speech API и английский ва-

риант Lernout & Hauspie тоже будут предло-

жены. Ваша задача, как и в случае со Speako-

nia, предварительно установить подходящий

русский вариант голосового движка.

Сам же голос, точнее его тембр и скорость

чтения, можно подстроить в меню «Options ->

Speech». К сожалению, настройка возможна

только приблизительная. Поэтому на уровне

скорости «Medium» браузер Web Talkster бу-

дет читать тексты слишком быстро, а в вари-

анте «Slow» чересчур медленно.

С помощью меню «Options -> Character

Options» вы сможете также оптимизиро-

вать своего агента, выбрать персонажа

(«Select character») или вовсе его отклю-

чить («Move -> Off screen»). Интересно, что

и без изображения агента Web Talkster бу-

дет продолжать зачитывать странички.

Из дополнительных возможностей «гово-

рящего» браузера отмечу встроенную функ-

цию поиска на Google.com, как в браузере

Opera, а также небольшой блокнотик для

«путевых» заметок «My Surf’n Notes». 

Загрузить Web Talkster можно прямо с сай-

та разработчика: www.code-it.com/downlo-

ads/WT_full.exe.

Web Talkster 3.9
èãûëõ/åàçìëõ

+ ‰Ó·‡‚ÎflÂÚ „ÓÎÓÒÓ‚˚Â ÙÛÌÍˆËË ‚ Internet Explorer

+ ËÒÔÓÎ¸ÁÛÂÚ ‡ÌËÏËÓ‚‡ÌÌ˚Â ÔÂÒÓÌ‡ÊË

– ÌÂÎ¸Áfl ÚÓ˜ÌÓ Ì‡ÒÚÓËÚ¸ Ô‡‡ÏÂÚ˚ ˜ÚÂÌËfl

– ÚÂ·ÛÂÚ ÏÌÓ„Ó ÓÔÂ‡ÚË‚ÌÓÈ Ô‡ÏflÚË 
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Web Talkster 3.9

ê‡Á‡·ÓÚ˜ËÍ 3 Code-it Software

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.code-it.com

ê‡ÁÏÂ ‰ËÒÚË·ÛÚË‚‡ 3 9 å·‡ÈÚ

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 freeware

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows

Отрадно, что и наши российские разработ-

чики не забывают о любимом в народе го-

лосовом ПО, регулярно выпуская интерес-

ные утилиты, причем в большинстве случаев

превосходящие зарубежные аналоги. Так,

скажем, GUI Reader Андрея Ефимова под-

держивает все необходимые функции для

подобного рода программ, но при этом за-

нимает в пять (!) раз меньше оперативной

памяти, нежели Web Talkster и CyberBuddy.

800 Кбайт против 4 Мбайт — очевидное,

согласитесь, преимущество.

В состоянии покоя GUI Reader пред-

ставлен иконкой в трее и никак не ме-

шает работе пользователя. Для его ак-

тивизации нужно кликнуть правой кноп-

кой мыши по этому значку и выбрать в

выпадающем меню то, что требуется.

Можно попросить GUI Reader озвучить

TXT-файл («Read File») или содержимое

Буфера обмена («Read Clipboard»). 

К сожалению, настроек в этой про-

грамме почти нет. Те же, что имеются,

представляют собой стандартные сис-

темные меню «Свойства персонажа» и

«Дополнительные параметры персона-

жей». Только так здесь можно настроить

агента и его голос. Зато в GUI Reader

разрешено выбирать язык озвучиваемого

текста. Вы сами можете выставить хоть

финский, хоть грузинский или суахили —

главное, чтобы в вашей системе был уста-

новлен соответствующий голосовой дви-

жок с поддержкой необходимого вам

языка.

Дистрибутив GUI Reader вы найдете на

сайте разработчика: http://efimov.media-

pg.ru/programs/guireader/download/GUI%

20Reader%20V2.00.EXE. Оттуда можно за-

грузить все необходимое включая агента

Джина. Нет только голосовых движков, их

придется устанавливать отдельно.

GUI Reader 2.0
èãûëõ/åàçìëõ

+ ÌÂÚÂ·Ó‚‡ÚÂÎÂÌ Í ÂÒÛÒ‡Ï

+ ÏÓÊÌÓ ‚˚·‡Ú¸ flÁ˚Í ‰Îfl ÚÂÍÒÚ‡

– ÂÒÚ¸ ÚÓÎ¸ÍÓ Ó·˘ËÂ ÒËÒÚÂÏÌ˚Â Ì‡ÒÚÓÈÍË

GUI Reader 2.0

ê‡Á‡·ÓÚ˜ËÍ 3 ÄÌ‰ÂÈ ÖÙËÏÓ‚

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.mediapg.ru

ê‡ÁÏÂ ‰ËÒÚË·ÛÚË‚‡ 3 3,7 å·‡ÈÚ

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 freeware

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows



В этом году любимый мною Agent Reader

(www.aldoatools.com) перешел в разряд sha-

reware, без боя уступив лидерство в классе

бесплатных голосовых программ виртуаль-

ному секретарю Джона Дефино CyberBuddy.

И по праву. Эта утилита была весьма сущест-

венно переработана в последних версиях.

Во-первых, в ее настройках появилась воз-

можность выбора ключевых фраз для раз-

ных языков, включая русский («General ->

Advanced Options -> Select Language Files»),

а во-вторых, исправлена неприятная ошибка,

связанная с отсутствием корректного (без

нажимания «Ctrl+Alt+Del») выхода из про-

граммы по завершении работы. 

Теперь, избавившись от грехов молодости,

CyberBuddy представляет собой мощный

универсальный программный продукт, вы-

полняющий множество полезных для широ-

кого круга пользователей функций: «говоря-

щего» почтовика («E-mail»), органайзера

(«Remind»), интернет-пейджера («Buddies ->

Send»), агента новостей («News»), а также

наблюдателя за изменениями на web-стра-

ницах («WWW») и колебаниями курсов на

биржах («Stocks»). И все это озвучено, укра-

шено анимированными персонажами и абсо-

лютно бесплатно. Согласитесь, есть смысл

попробовать: http://thecyberbuddy.com/cy-

berbuddysetup.exe. Только вот голосовые

движки и библиотеки придется закачивать

отдельно: в дистрибутив CyberBuddy они

не входят. 

В этой программе все можно перестроить на

свой лад. Так, на закладке «General -> Cha-

racter and Speech Options» обязательно отре-

гулируйте «под себя» различные параметры

агентов и голосовых движков. На странице

«General -> Advanced Options» выберите

скин для основного окна программы и напи-

шите, если хотите, свои фразы для анимиро-

ванных персонажей («Custom Message»). 

На закладке «E-mail» вам необходимо будет

указать адрес своего почтового ящика, а так-

же логин и пароль доступа к нему. Теперь по

команде «Get E-mail Now» вы будете полу-

чать почту, а при выделении нужного письма

еще и озвучивать его содержание («Read E-

mail»). Тут, правда, есть одна закавыка. Про-

грамма CyberBuddy не только не понимает

русскую почтовую кодировку KOI8-R, но и не

позволяет скопировать текст писем в Буфер

обмена. А это значит, что нельзя использо-

вать внешние конвертеры. Единственный

выход — попросить друзей и приятелей

присылать письма в формате Windows. Или

использовать транслитерацию.

CyberBuddy 2.12
èãûëõ/åàçìëõ

+ ÏÌÓ„ÓÙÛÌÍˆËÓÌ‡Î¸ÌÓÒÚ¸

+ Ì‡ÎË˜ËÂ ‚ÒÚÓÂÌÌÓ„Ó ÔÓ˜ÚÓ‚ËÍ‡ Ë Ó„‡Ì‡ÈÁÂ‡

+ „Ë·Í‡fl ÒËÒÚÂÏ‡ Ì‡ÒÚÓÂÍ

– ÌÂ ÔÓÌËÏ‡ÂÚ ÍÓ‰ËÓ‚ÍÛ KOI8-R

C H I P é ä í ü Å ê ú  2 0 0 2
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Самый простой и доступный способ озвучить

текст, набранный на компьютере, — вос-

пользоваться программой Speakonia. Единст-

венное, что от вас потребуется, — устано-

вить русифицированный голосовой движок

(Lernout & Hauspie, Digalo или Sakrament).

Что касается библиотек MS Speech API и под-

держки американского английского языка, то

они уже приложены разработчиком к инстал-

ляционному дистрибутиву. 

Интерфейс Speakonia — образец мини-

мализма. Ничего лишнего, только основные

голосовые функции. Управление точь-в-точь

как в мультимедийных проигрывателях:

кнопка запуска чтения, паузы и полной оста-

новки. Параметры декламации, в принципе,

можно настраивать («Speech -> Properties»).

Вы вправе выбрать движок, скорость, тембр

и звучность голоса, правда, почему-то только

для движков Lernout & Hauspie. Но в любом

случае значения, выставленные по умолча-

нию, наверняка вам подойдут. Если запутае-

тесь с настройками, то смело кликайте по

кнопке «Reset» — не ошибетесь. Тем бо-

лее что качество чтения не зависит от Spe-

akonia — подправлять можно только в тех

движках, где это предусмотрено. В появля-

ющемся при щелчке мышкой по кнопке Lexi-

con «Редакторе пользовательских словарей»

на закладке «Правка» можно уточнить не-

верно озвучиваемые слова или аббревиату-

ры. Для этого следует задать свой вариант и

перевести его в специальное фонетическое

письмо («Преобразовать»). 

Впрочем, делать это вовсе не обязательно,

поскольку Speakonia и так будет неплохо оз-

вучивать текст из Буфера обмена, TXT-файлы,

страницы в Интернете («File -> Read Webpa-

ge»), а также текущие время и дату. После

регистрации на сайте программы («Tools ->

Options -> Registration») появится

возможность записи машинного чтения в

WAV-файл («File -> Save as Wav File»).

Загрузить Speakonia можно отсюда:

http://files.cfs-technologies.com/speakonia/

speakoniasetup-1.0.exe.

Speakonia 1.03
èãûëõ/åàçìëõ

+ ÔÓÒÚÓÈ ËÌÚÂÙÂÈÒ

+ ‚ÓÁÏÓÊÌÓÒÚ¸ Á‡ÔËÒË ÔÓ˜ËÚ‡ÌÌÓ„Ó ‚ WAV-Ù‡ÈÎ

– Ì‡ÒÚ‡Ë‚‡Ú¸ ÏÓÊÌÓ ÚÓÎ¸ÍÓ ‰‚ËÊÍË

Lernout & Hauspie

CyberBuddy 2.12

ê‡Á‡·ÓÚ˜ËÍ 3John M. DeFino

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 http://thecyberbuddy.com

ê‡ÁÏÂ ‰ËÒÚË·ÛÚË‚‡ 3 1,9 å·‡ÈÚ

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 freeware

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows

Speakonia 1.03

ê‡Á‡·ÓÚ˜ËÍ 3 CFS-Technologies

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.cfs-technologies.com

ê‡ÁÏÂ ‰ËÒÚË·ÛÚË‚‡ 3 2,6 å·‡ÈÚ

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 freeware

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows



Voice Navigator — единственная коммер-

ческая программа в настоящем обзоре и

единственная утилита, предназначенная

для голосового управления компьютером.

«Навигатора» создал известный петер-

бургский Центр речевых технологий, тот

самый, что занимался расшифровкой за-

писей с затонувшей в Баренцевом море

подводной лодки «Курск».

Любимое детище этого центра —

«Труффальдино», комплекс голосового уп-

равления бытовой и офисной техникой.

Разработчики обещают в нем полную под-

держку телевизоров, телефонов и даже

микроволновых печей. Правда, о том, как

это выглядит на практике, я могу лишь до-

гадываться — демоверсия «Труффальди-

но» ничего такого не демонстрирует. Но

команды там наверняка звучат в духе из-

вестного анекдота: «Телефона, телефона,

моя кушать хочет!»

А вот демоверсия Voice Navigator заре-

комендовала себя с самой лучшей сторо-

ны. Правда, не сразу, а после небольшой

тренировки.

Чтобы поупражняться, нужно выделить

мышкой один из пяти доступных в демон-

страционной версии пунктов, кликнуть по

кнопке «Improve Recognition» и четко

проговорить соответствующую команду.

Это может быть любое слово, даже звук.

«Калькулятор» я, например, вызываю по

свистку. 

Сразу после обучения попробуйте про-

изнести в микрофон команду для вызова

какой-нибудь программы, например Note-

pad, — и на экране тут же появится Блок-

нот. Скажите что-нибудь для Paint — и на

Рабочий стол подадут стандартный графи-

ческий редактор. Когда закончите работу,

назовите условную команду для Close —

и активное окно закроется. Приказы вы-

полняются довольно быстро и точно, но

время от времени их приходится повторно

разучивать.

Кроме всего прочего, для команд поль-

зователя можно задать определенный го-

лосовой ответ машины в так называемом

«Sound File Manager». Если вас не устроит

вариант, принятый по умолчанию, кликни-

те «Replace» и запишите или продиктуйте

свой собственный. 

Демонстрационную версию «Навигато-

ра», по-моему, найти нельзя нигде, кроме

сайта его разработчиков: ftp://ftp.spe-

echpro.com/pub/demos/navigator_eng.exe.

Само собой разумеется, для работы с этой

программой вам понадобится микрофон.
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Java-Â‡ÎËÁ‡ˆËfl

ëÓÎËÒÚ ê‡·Ó˜Â„Ó ÒÚÓÎ‡
çÂ ÁÌ‡˛, ÔÎÓıÓ ˝ÚÓ ËÎË ıÓÓ¯Ó, ÌÓ ÔÓ„‡Ï-

Ï˚, ÓÒÌÓ‚‡ÌÌ˚Â Ì‡ ÚÂıÌÓÎÓ„ËË MS Agent,

ÒÓÁ‰‡˛ÚÒfl ‚ ÓÒÌÓ‚ÌÓÏ ‰Îfl ÔÓÚÂıË ‰ÂÚË¯ÂÍ

‡ÁÌÓ„Ó ‚ÓÁ‡ÒÚ‡. äÓÌÂ˜ÌÓ, ÓÚ‰ÂÎ¸Ì˚Â ‡Á-

‡·ÓÚ˜ËÍË Ô˚Ú‡˛ÚÒfl ÔË‰‡Ú¸ Ò‚ÓËÏ ÔÓ„‡Ï-

Ï‡Ï ıÓÚ¸ Í‡ÍÓÈ-ÚÓ ÓÂÓÎ ÂÒÔÂÍÚ‡·ÂÎ¸ÌÓÒÚË

Ë ÒÂ¸ÂÁÌÓÒÚË, ÌÓ ÓÚ ˝ÚÓ„Ó Ëı Ú‚ÓÂÌËfl ÔÓÎÛ-

˜‡˛ÚÒfl Â˘Â ÍÓÏË˜ÌÂÂ. ÑÛ„ËÂ ÊÂ Ë ‚Ó‚ÒÂ ÌÂ

ÒÍ˚‚‡˛Ú ‡Á‚ÎÂÍ‡ÚÂÎ¸ÌÓ„Ó ı‡‡ÍÚÂ‡ Ò‚ÓËı

Ú‚ÓÂÌËÈ, Í‡Í, Ì‡ÔËÏÂ, ÒÓÁ‰‡ÚÂÎ¸ Java-ÛÚË-

ÎËÚ˚ MUSH.

MUSH — ˝ÚÓ ÒÓÍ‡˘ÂÌËÂ ÓÚ Music Scripting

Helper. ùÚ‡ ÛÚËÎËÚ‡ ÒÓÁ‰‡ÂÚ ÒÍËÔÚ˚ ‰Îfl ÏÛ-

Á˚Í‡Î¸Ì˚ı MIDI- Ë KAR-Ù‡ÈÎÓ‚.

èÓÎ¸ÁÓ‚‡Ú¸Òfl MUSH ÌÂÒÎÓÊÌÓ. çÛÊÌÓ ÚÓÎ¸ÍÓ

‚˚·‡Ú¸ ‡„ÂÌÚ‡ (ÊÂÎ‡ÚÂÎ¸ÌÓ ÒÓ‚Ô‡‰‡˛˘Â„Ó Ò

ÓÒÌÓ‚Ì˚Ï), ‡ÒÒÚ‡‚ËÚ¸ „‡ÎÓ˜ÍË ÔÓ ‚ÒÂÏ

ÔÛÌÍÚ‡Ï, ÍÓÏÂ «‘La’ the words», Â¯ËÚ¸, ÍÛ‰‡

ÓÚÔ‡‚ËÚ¸ „ÓÚÓ‚˚È ÍÎËÔ Ë, ÍÎËÍÌÛ‚ «Convert»,

Ì‡ÈÚË ÔÓ‰ıÓ‰fl˘ËÈ ‰Îfl Ó·‡·ÓÚÍË MIDI- ËÎË

KAR-Ù‡ÈÎ. èÓ‰ÓÈ‰ÂÚ Î˛·‡fl ÍÓÏÔÓÁËˆËfl, ÌÓ

ÚÓÎ¸ÍÓ Ò ‡Ì„ÎËÈÒÍËÏË ÒÎÓ‚‡ÏË — ÛÒÒÍËÂ

ÚÂÍÒÚ˚ MUSH ÌÂ ÔÓ‰‰ÂÊË‚‡ÂÚ. äÒÚ‡ÚË, ÂÒ-

ÎË ÍÎËÍÌÛÚ¸ ÔÓ ÍÌÓÔÍÂ «Find same Karaoke

Files», ‚ ·‡ÛÁÂÂ ÓÚÍÓÂÚÒfl ÒÚ‡ÌË˜Í‡ Ò

ÏÌÓÊÂÒÚ‚ÓÏ Ú‡ÍËı KAR-Ù‡ÈÎÓ‚.

äÓ„‰‡ ÓÔÂ‰ÂÎËÚÂÒ¸, ‡ÌËÏËÓ‚‡ÌÌ˚È ÔÂÒÓ-

Ì‡Ê ËÒÔÓÎÌËÚ ‚˚·‡ÌÌÛ˛ ‚‡ÏË ÔÂÒÂÌÍÛ.ç‡

ãÛ˜Ë‡ÌÓ è‡‚‡ÓÚÚË ˝ÚÓ ·Û‰ÂÚ, ÍÓÌÂ˜ÌÓ, Ï‡ÎÓ

ÔÓıÓÊÂ, ÌÓ Á‡ÚÓ ÓË„ËÌ‡Î¸ÌÓ Ë ÔÓ-Ò‚ÓÂÏÛ

„‰Â-ÚÓ ‰‡ÊÂ ‰Û¯Â‚ÌÓ. ÖÒÎË ËÒÔÓÎÌÂÌËÂ ‚‡Ò

ÛÒÚÓËÚ — MUSH ÒÓı‡ÌËÚ ÂÁÛÎ Ú̧‡Ú. àÁ ÚÂı

‚ÓÁÏÓÊÌ˚ı ‚‡Ë‡ÌÚÓ‚ fl ÎË˜ÌÓ ÔÂ‰ÔÓ˜ÂÎ Ò‡-

Ï˚È ÔÓÒÚÓÈ Ë ‰ÓÒÚÛÔÌ˚È — ˝ÍÒÔÓÚ ‚ Inter-

net Explorer («Basic web output»).

èÓÎÛ˜ÂÌÌ˚È HTML-Ù‡ÈÎ ·Û‰ÂÚ ÒÓÒÚÓflÚ¸ ‚ÒÂ„Ó

ËÁ Ó‰ÌÓÈ ÍÌÓÔÍË «Play», ÍÎËÍÌÛ‚ ÔÓ ÍÓÚÓÓÈ

ÏÓÊÌÓ ‚˚Á‚‡Ú¸ ÔÓ˛˘Â„Ó ‡„ÂÌÚ‡. èÓ„‡ÏÏÛ

MUSH Ë˘ËÚÂ Ì‡ Ò‡ÈÚÂ ‡Á‡·ÓÚ˜ËÍ‡: www.pe-

pedog.com/mush.zip (132 ä·‡ÈÚ).
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