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Printing multiple files from disk
There are two ways to print multiple files from disk:

1. Go through the Print file from disk choice on the File menu, and Shift- or 
Control-click to select several files.

2. Drag the selected files onto the GreenPrint icon or into the GreenPrint 
main window. You can use Windows File Manager (Win 3.1/95) or Explorer 
(Win 95) to help you group the files you wish to print: for example, by date or
by file type.
Use Explorer or File Manager from the File menu to run one of these 
programs if one is not already running.

TIP Press Ctrl+W to move the GreenPrint main window to the top left-hand 
corner of the screen, and free as much space as possible for Explorer or File 
Manager. See the list of keyboard shortcuts for other GreenPrint functions 
you can access from the keyboard.

GreenPrint will format the selected files so that each file begins on a new 
virtual page.





 Printing from a disk file

To print from a file on disk, you can go through the File-Print from disk 
menu option or drag files onto the GreenPrint icon or into the program's 
window once it is running.

The file open dialog looks like this:

It works like any other Windows 95 Explorer-style file open dialog. You can 
Shift- or Control-click to select several files. Once you have made your choice
by double-clicking on a filename or clicking the Open button, the next stage 
of the printing process is the Preprint dialog box. You can use the predefined 
filters to help you select files.

Note: The illustration shows GreenPrint running under Windows 95. The 16-
bit version of GreenPrint uses the Windows 3.1 file common dialogs, which 
also support Shift- and Control-clicking, but not the use of Ctrl-A to select all 
files.





Printing from the Windows clipboard
GreenPrint can print text in the Windows clipboard that originates from any 
Windows application. To access this feature, choose Print from clipboard 
from the File menu. If the clipboard is empty or does not contain text, 
GreenPrint will indicate this, and will not print. If there is valid text in the 
clipboard, this option will bring up the same print settings dialog box as you 
see on printing a file from disk, and you continue exactly as if you were 
printing a disk file. You can edit the text (use the Edit next button in the 
print settings dialog box) and save changes before printing.



 
Uninstalling GreenPrint, or installing a later

version
To uninstall GreenPrint32 under Windows 95, follow these steps:

Enter Control Panel, and double-click Add/Remove Programs

You should see GreenPrint32 listed. Double-click on its entry and all its files 
will automatically be removed from your system.

To install a later version of GreenPrint32 over your existing files, you can do 
one of the following: 
(1) rerun the setup program provided with the newer version of GreenPrint32

(2) copy the newer gprint32.exe and gprint32.hlp files over your existing 
files yourself. The default path for the GreenPrint32 files is 
c:\Program Files\GreenPrint32\

Note that the 16-bit GreenPrint files are named gprint16.exe and 
gprint16.hlp.



Printing options
Basic printing options are set through the Print Settings dialog box.

In addition to the options on this screen, you can press the Advanced print 
options buttons to set options such as margins, lines and columns per virtual 
page and expansion of tabs.

You can press the Edit button to view or edit your selected files with 
Windows notepad.

When you have finished setting print options, press OK to proceed to select 
a printer and print the selected file(s).

Pressing Cancel at this point will cancel printing. The dialog box will 
disappear and GreenPrint will discard any changes to print options that you 
may have made.





  Advanced print options
Advanced printing options include the number of lines and columns per 
virtual page, the number of spaces per tab stop, and margins and padding. 
(Padding refers to the gap between a page border and page text.)

Using the Recalculate, Lines++ and Lines-- buttons, you can alter the 
formatting options and immediately see the effect this will have on the 
number of physical and virtual pages.

For example, if you noticed that your selected file was going to amount to 
13.1 physical pages, hitting the Lines++ button a few times might ensure 
that it printed on 13, rather than 14, pages.

TIP Note that when you use GreenPrint to print several files, each file begins
on a new virtual page. This means that a small change in the number of lines
per page can sometimes cause a significant change in the number of virtual 
and/or physical pages. 



Saving and loading preferences
Each time you run GreenPrint, it loads the preferences saved in the 
gprint.prf file, located in the Windows directory. Initially, this file will hold 
the default preferences. However, each time you change a print setting, such
as the number of virtual pages per physical page or margin settings, 
GreenPrint remembers that change for the remainder of your session or until 
you alter the relevant settings again. If you want your new settings to 
become the settings that are automatically loaded when GreenPrint starts, 
choose Save current options from the Options menu, or type Ctrl+S.

If while running GreenPrint you have altered print settings unintentionally, 
you can choose Return to saved options from the Options menu to return to 
the most recently saved options.

You can return to the original default settings at any time by Return to 
default settings from the options menu. If you then choose Save current 
options, the default settings will again be loaded automatically when 
GreenPrint starts.

Note that the preference file format is the same for the 16 and 32-bit version
of GreenPrint.



Keyboard shortcuts

F1 Help contents

F7 Exit

F9 Select typeface

Ctrl+E Run Windows 95 Explorer (to allow file dragging into 
GreenPrint).

Ctrl+F Run legacy File Manager. Note that you can't drag and drop 
from File Manager onto the icon of a Windows32 program such as 
GreenPrint32. However, File Manager is still arguably more powerful than 
Explorer.

Ctrl+O Print file from disk

Ctrl+P " " "

Ctrl+Alt+P Bring up print settings dialog box

Ctrl+S Save current print options to disk

Ctrl+V Print from Windows clipboard

Ctrl+W Toggle the GreenPrint main window to/from the top left 
corner of the screen. (Useful in printing from the clipboard, or printing with 
drag and drop from a program such as Windows 95 Explorer).

Ctrl+1 1 up

Ctrl+2 2 up

Ctrl+4 4 up

Ctrl+8 8 up



About the main-window graphic
The grid in the main-window graphic indicates the current number of virtual 
pages per physical page. If the lines are dashed, GreenPrint is not configured
to print borders. A solid line below the grid indicates that caption printing is 
enabled. To change these options, use the Print Options dialog box.



Information about GreenPrint development

GreenPrint for Windows was written in C for Windows 16 and 32 APIs by 
Rod Johnson. 
rjohnson@extro.ucc.su.oz.au
http://www.usyd.edu.au/~rjohnson/frontpage.html
© June-October 1996

Thanks to Bob West.

Compiles

Both the Windows 95/NT version (gprint32) and the Windows 3.1 version 
(gprint16) were compiled with Watcom C/C++ v. 10.6 on a Pentium running 
Windows 95.

The 16-bit version will continue to be supported in the foreseeable future, 
although it may not include all the features available in the 32-bit version, 
which has always been the definitive version of the product.

Versions

I began writing GreenPrint for my own use in June, 1996, out of frustration 
with the lengthy printouts of source code and documentation that Windows 
programming demands. Since then I have worked to add features and make 
it of wider use.

The present version of GreenPrint is 1.0 (October 1996).



GreenPrint is not freeware, but shareware. The registration fee is $A15. 
(Follow this link for details on how to register). The benefits of registration 
include
- no more nag screens
- free updates as GreenPrint evolves
- the right to have your suggestions and bug reports taken seriously
- the satisfaction of supporting the shareware concept

Future developments

Future developments planned for GreenPrint include 
- syntax highlighting in a variety of languages including C/C++, Java and Perl
- user-defined indexing, allowing a user to define a list of words or symbols in
a file to be printed and have GreenPrint automatically generate and print an 
index -- an especially useful feature when printing long files of 
documentation.
- booklet printing
Suggestions from registered users are welcome.

For the latest information and the most recent version of the program, please
visit the GreenPrint homepage at
http://www.usyd.edu/au/~rjohnson/winapps/winapps.html





What this program is for
GreenPrint is a utility designed to print source code and text files, saving 
paper and time by enabling printing multiple virtual pages to each physical 
page and allowing control over the number of lines and columns per page, 
margins and other formatting variables.

Its functionality is similar to that of the venerable mpage, with the important
advantages of a more approachable Windows interface, and full functionality 
on any printer supported by Windows, rather than merely expensive 
PostScript lasers.

It is intended primarily for programmers, trouble-shooters and users 
intending to print out extensive documentation for shareware products.

The Print from clipboard function offers a fast way to print text from most 
Windows applications. Sources might include help files for other programs 
(including reference material such as that provided with the Windows SDK), 
and even documents in word processors.

GreenPrint offers a high degree of control over margins, numbers of lines 
and columns per virtual page and other aspects of the appearance of the 
printed text. Although originally intended to save paper by printing long files 
of source code at reduced font size, other uses could include enlarging 
output for users with poor eyesight.

Both Windows 95 and Windows 3.1 versions can be run from a server on a 
Windows network. Preferences files will automatically be saved in writable 
directories on the client machines.

Note: Text in this help file that appears in red refers only to the 
Windows 95 version of GreenPrint (GreenPrint32).



Order Form
Post to:

Rod Johnson
P.O. Box 41
Londonderry NSW 2753
AUSTRALIA

Name                                                                                                                                                    

E-mail                                                                                                                                                   

Street                                                                                                                                                    

Town/City                                                                                                                                             

Postcode/Zip                                                                                                                                      

Country                                                                                                                                                

Circle the product you wish to receive: 
        
GreenPrint32 (Windows 95/NT) GreenPrint16 (Windows 3.1)Both (no 

extra charge)

How did you find out about GreenPrint?

                                                                                                                                                                

                                                                                                                                                                

Comments/Suggestions about GreenPrint

                                                                                                                                                                

                                                                                                                                                                

                                                                                                                                                                

Payment



Circle appropriate amount. To receive update via e-mail To receive 
floppy disk

Within Australia
$A15 $A20

Outside Australia

Money order in $A $A15 $A20
Cheque in home currency $A20* $A25*

Australian or overseas

File server registration (> 3 clients): $A15 + $A8 x number of client 
machines

*Convert to your currency at the prevailing exchange rate at the time of your order.



GreenPrint shareware notice
GreenPrint © Rod Johnson, 1996.
All rights reserved.

Thank you for using GreenPrint! You are welcome to evaluate GreenPrint 
for 30 days after installing it on your computer. After that period, if you wish 
to continue using it, you must register, by filling in the order form. Failure to 
do so is a violation of copyright and the principles of shareware.

Registered users are entitled to free updates for the life of the product, and 
will benefit from any new functionality which may not be included in 
evaluation copies of the software.

You may distribute evaluation (but not registered) copies of the software, but
must not charge for them (except for any media).

Disclaimer

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND 
WITHOUT WARRANTIES AS TO PERFORMANCE OR MERCHANTABILITY OR ANY 
OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED. SPECIFICALLY, NO 
WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED. THE 
AUTHOR WILL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS
A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE.

Remember: Supporting the shareware concept benefits users as well 
as programmers!




