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What is Editeur ?

Nominee - 1996 Shareware Industry Awards - Best word processing applications/utilities

Editeur is a text editor. It affords creating and modifying text files.

What's new in Version 3

Version 3 has been specifically written for Windows 95 ant NT 4.0. It has an improved 
Windows 95 look and feel, and includes an improved context-sensitive help, delivering 
information when you actually need it : for example, using the  button in dialogs gives 
specific help on dialog items.

This version also brings syntax highlighting. Syntax highlighting affords using different font 
styles and colors for different text parts. This is a facility that you usually find in 
programming text editors. In Editeur, this facility has been designed to be usable with any 
kind of text, through the use of syntax libraries. 

More, a generic syntax library is provided, that you can duplicate and modify. This affords 
defining your own syntaxes. Syntaxes for C++, Pascal, and .bat files using this facility are 
released with the application. Specific libraries for .ini and TeX/LaTeX files are also released 
with the application.

Version 3 also brings multiple views per file, print previewing and Ole drag and drop for 
moving and copying text between documents and applications.

Features

· Affords editing texts with an unlimited number of lines of up to 64999 characters.
· Affords using both fixed or proportional fonts, and different fonts for viewing and printing.
· Affords editing multiple files with up to 4 views per file.
· Affords editing WindowsTM, Mac/OS®, and Unix® text files.
· Affords editing DOS text files throw the use of the MS Line draw font.
· Opening of multiple files in one single dialog.
· Use of the drag and drop feature to open files from the Explorer.
· "Find in files..." with recursive directory search.
· Print preview and print with customizable headers and footers.
· Word wrap at the margin or at a specified column, cutting words or not.
· Optional viewing of spaces, end of lines, and tabulations (as '·', ' ', and '¶').
· Use of the Ole drag and drop feature to move or copy text between documents.
· Right button selectable column and rectangle selection modes.
· Unlimited Undo/Redo capability.
· Append to clipboard, indent and unindent features.
· Possible text editing while driving a replacement dialog.
· Multitext search and replace.
· Bookmarks to quickly navigate in a text.
· Keystroke and mouse move Macro recorder.
· Spell checking in 4 languages with concurrent use of multiple dictionaries.
· Conversion of tabulation width.
· Fast sorting of lines.



Creating a text

To create a text

1 Choose New from the File menu.
2 Type in your text.

See also

Opening existing text files
Modifying a text



Opening existing text files

Using Editeur makes sense only with text files.

To open existing text files

1 Choose Open... from the File menu.
2 Choose the drive and the directory.
3 Select one or more files.
4 Choose the format.
5 Choose OK.

Editeur creates a text window for every file opened. The file opened last becomes active.

Remarks

Editeur affords editing any file as text. This proves helpful when handling binary files with 
text sections.

See also

Creating a text
Modifying a text



Saving texts

To save a text with a new name

1 Choose Save as... from the File menu.
2 Choose the drive and the directory.
3 Type in or select the file name.
4 Choose the format.
5 Choose OK.

To save a text with the same name

> Choose Save from the File menu.

To save all texts

> Choose Save all from the File menu.

Remark

If the Create backup files option is on and the file already exists, a backup copy is created 
before saving.

See also

Closing Texts
Exiting Editeur



Closing texts

To close the active text

> Choose Close from the File menu.

Editeur offers to save the text if it has been modified.

To close and automatically save the active text

> Choose Save and close from the File menu.

Editeur automatically saves the text if it has been modified.

Remark

If the Create backup files option is on and the file already exists, a backup copy is created 
before saving.

See also

Saving Texts
Exiting Editeur



Printing texts

To print

1 Choose Print... from the File menu.
2 Choose the options.
3 Choose OK.

See also

Print previewing texts
Changing the page layout
Changing the printing options
Sending through electronic mail



Print previewing texts

To print preview

1 Choose Print preview from the File menu.
2 Choose OK.

Remarks

- If there is a selection, only the selection lines are shown.

- If word-wrap is used, repagination takes place before the text is previewed.

See also

Printing texts
Changing the page layout
Changing the printing options
Sending through electronic mail



Changing the page layout

To change the page layout

1 Choose Page setup... from the File menu.
2 Modify the header and footer.
3 Modify the margins.
4 Choose OK.

Remark

The header and footer and margins are used only for printing and not for displaying the text.

See also

Printing texts
Print previewing texts
Changing the printing options
Sending through electronic mail



Changing the printing options

To change the printing options

1 Choose Print setup... from the File menu.
2 Choose the printer to use.
3 Choose Setup....
4 Change the options.
5 Choose OK.

See also

Printing texts
Print previewing texts
Changing the page layout
Sending through electronic mail 



Sending trough electronic mail

To send the active text trough electronic mail 

1 Choose Send... from the File menu.
2 Fill out the fields.
3 Choose OK. 

See also

Printing texts
Print previewing texts
Changing the page layout
Changing the printing options



Exiting Editeur

To exit Editeur

> Choose Exit from the File menu or
> Choose Close from the Editeur system menu.

Editeur offers to save every text modified.

To exit Editeur and automatically save the texts modified

> Choose Save and exit from the File menu.

Every text modified is automatically saved.

See also

Closing Texts
Saving texts



Modifying a text
The location where updates take place is called the insertion point. This point is highlighted 
with a blinking shape.

To insert characters

Make sure you are in insert mode, or switch to insert mode by pressing the Ins key (in insert 
mode, the second square of the status bar includes the word "Insert", and the blinking shape
is a vertical bar).

Then type in your text.

To replace characters

Make sure you are in overwrite mode, or switch to overwrite mode by pressing the Ins key 
(in overwrite mode, the second square of the status bar includes the word "Overwrite", and 
the blinking shape if a full rectangle).

Then type in your text.

See also

Moving in a text
Selecting text
Unselecting text



Moving in a text
To move the insertion point in a text

Use the direction and control keys as follows :

Key(s) Function
----------------------------------------------------------------------------------------
DOWN Move one line down.
UP Move one line up.
RIGHT Move one character right.
LEFT Move one character left.
END Move to the end of the line.
HOME Move to the beginning of the line.
PAGE DOWN Move one window down.
PAGE UP Move one window up.
CONTROL + DOWN Move to the window bottom.
CONTROL + UP Move to the window top.
CONTROL + RIGHT Move one word right.
CONTROL + LEFT Move one word left.
CONTROL + END Move to the end of the text.
CONTROL + HOME Move to the beginning of the text.
CONTROL + PAGE DOWN Move one window right.
CONTROL + PAGE UP Move one window left.

See also

Modifying a text
Selecting text
Unselecting text 



Selecting text
To select text with the keyboard

Press the Shift key while moving the insertion point with the direction and control keys as 
follows :

Key(s) Function
-----------------------------------------------------------------------------------------
SHIFT + DOWN Selects one line down.
SHIFT + UP Selects one line up.
SHIFT + RIGHT Selects one character right.
SHIFT + LEFT Selects one character left.
SHIFT + END Selects to the end of the line.
SHIFT + HOME Selects to the beginning of the line.
SHIFT + PAGE DOWN Selects one page down.
SHIFT + PAGE UP Selects one page up.
SHIFT + CONTROL + DOWN Selects to the window bottom.
SHIFT + CONTROL + UP Selects to the window top.
SHIFT + CONTROL + RIGHT Selects one word right.
SHIFT + CONTROL + LEFT Selects one word left.
SHIFT + CONTROL + END Selects to end of text.
SHIFT + CONTROL + HOME Selects to beginning of text.

To select text with the mouse

First, make the in-context menu appear with the mouse right button and choose the 
selection mode : in line, in column, or in rectangle. Then, press the mouse left button and 
move the mouse while maintaining down the left button. To select a word, double-click on it.

Remarks

- Causing the mouse to approach the window border makes the text scroll, allowing 
extension of the selection beyond what was initially visible in the window.

- In the case of a column or rectangle selection, the vertical alignment might not be 
respected if the selection includes tabulations.

To select the whole text

> Choose Select all from the Edit menu.

See also

Unselecting text
Modifying a text
Moving in a text
Ole drag and drop
Cut, copy, append, paste, clear, select all
Copy to, paste from
Indent, unindent
Uppercase, lowercase
Inserting date and time 



Unselecting text
To unselect all

Move the insertion point with the direction and control keys, or click the left button of the 
mouse (see Moving in a text).

To reduce the selection with the keyboard

Press the Shift key while moving the insertion point with the direction and control keys.

To reduce the selection with the mouse

Press the Shift key, then press the left or right button of the mouse, and then, move the 
mouse.

Causing the mouse to approach the window border makes the text scroll, allowing for 
reduction of the selection beyond what was initially visible in the window.

See also

Modifying a text
Moving in a text
Selecting text 



Ole drag and drop
To move the selected text

Press the mouse left button inside the selected text and keep it pressed. The mouse cursor 
shape is then modified. Still maintaining the button pressed, move the mouse until the 
insertion point is at the right place. Then, release the button.

To copy the selected text

Proceed as previously, but before, press and maintain pressed the shift key.

To cancel the move or copy

Get the insertion point back inside the selected text and release the mouse button.

See also

Selecting text
Cut, copy, append, paste, clear, select all
Copy to, paste from
Indent, unindent
Uppercase, lowercase
Inserting date and time



Cut, copy, append, paste, clear, select all
These commands from the Edit menu allow the text to interact with an intermediate system
memory called the Clipboard.

Cut

Copies the selection into the Clipboard and clears the original ; the copied text replaces the 
previous content of the Clipboard.

Copy

Copies the selection into the Clipboard, but does not delete the original ; the copied text 
replaces the previous content of the Clipboard.

Append

Appends the selection into the Clipboard, but does not delete the original.

Paste

Inserts a copy of the Clipboard at the insertion point.

Clear

Clears the selection.

Select all

Selects the whole active text.

See also

Selecting text
Ole drag and drop
Copy to, paste from
Indent, unindent
Uppercase, lowercase, invert, capitalize
Inserting date and time



Copy to, paste from
These commands from the Edit menu allow the selection to be copied to a file or characters 
to be inserted from a file.

To copy the selection to a file
1 Choose Copy to... from the Edit menu.
2 Choose the drive and the directory.
3 Type in or select the file name.
4 Choose the format.
5 Choose OK.

To insert characters from a file
1 Choose Paste from... from the Edit menu.
2 Choose the drive and the directory.
3 Select one file.
4 Choose the format.
5 Choose OK.

See also

Selecting text
Ole drag and drop
Cut, copy, append, paste, clear, select all
Indent, unindent
Uppercase, lowercase, invert, capitalize
Inserting date and time



Indent, unindent

These commands of the Edit menu afford shifting the selected text to the right or to the left 
by adding or removing tabulations before the selection beginning on each line.

To shift the selected text one tabulation position to the right
> Choose Indent in the Edit menu or
> Press the Tab key.

To shift the selected text one tabulation position to the left
> Choose Unindent in the Edit menu or
> Press the Shift+Tab keys.

See also

Selecting text
Ole drag and drop
Cut, copy, append, paste, clear, select all
Copy to, paste from
Uppercase, lowercase, invert, capitalize
Inserting date and time



Uppercase, lowercase, invert, capitalize
These commands from the Edit menu allow the selection to be set to uppercase or 
lowercase characters.

To set the selection to uppercase characters
> Choose Upper from the Edit menu.

To set the selection to lowercase characters
> Choose Lower from the Edit menu.

To change the case of the selected text
> Choose Invert from the Edit menu.

To set to uppercase the first letter of every word of the selected text
> Choose Capitalize from the Edit menu.

See also

Selecting text
Ole drag and drop
Cut, copy, append, paste, clear, select all
Copy to, paste from
Indent, unindent
Inserting date and time



Inserting date and time
To insert the date and time at the insertion point
> Choose Date/time from the Edit menu.

See also

Selecting text
Ole drag and drop
Cut, copy, append, paste, clear, select all
Copy to, paste from
Indent, unindent
Uppercase, lowercase, invert, capitalize



Handling updates
Editeur records your updates. You can then undo and redo these updates. The number of 
updates undone or redone is not limited.

To undo updates
> Choose Undo from the Edit menu as many times as necessary.

To redo updates
> Choose Redo from the Edit menu as many times as necessary.

To repeat the last update in another location
> Choose Repeat from the Edit menu.

Updates memory resetting

Any change after having undone updates without having redone them resets the update 
memory : undo or redo updates older than this change is subsequently impossible.

The update memory is also reset when the text is saved.

See also

Repeating the last update



Repeating the last update
Editeur records your last update in every text. You can then repeat this update in another 
location.

To repeat the last update in another location
> Choose Repeat from the Edit menu.

Remark

Only simple updates may be repeated. Complex updates, such as operations on the 
selection are not handled. The reason is the difficulty to transpose such actions in another 
place.

See also

Handling updates



Searching for a string

To search for a string

1 Choose Search... from the Search menu.
2 Type in or select the string being searched for.
3 Choose the options.
4 Choose OK.

To search again for the same string

> Choose Search next or Search previous from the    Search menu or

1 Choose Search... from the Search menu.
2 Choose the direction.
3 Choose Search again.

Remark

Special characters may be entered in the string searched for.

See also

Replacing a string by another
Finding in files
Special moves



Replacing a string by another

To replace a string by another

1 Choose Replace... from the Search menu.
2 Type or select in the string being searched for.
3 Type in or select the replacement string.
4 Choose the options.
5 Choose OK to confirm individual replacements or
> Choose Replace all for replacement without any confirmation.

String replacement dialog

Editeur sets up a dialog to drive the replacements. You can move from this dialog to the text 
and vice versa with a mouse click in the appropriate window : this affords a direct update of 
the text while driving the replacement dialog.

Remark

Special characters may be entered in the string searched for and in the replacing string.

See also

Searching for a string
Finding in files
Special moves



Finding in files

To find a string in files

1 Choose Find in files... from the Search menu.
2 Type in or select the string being searched for.
3 Type in or select the file filter to be used.
4 Type in or select the starting directory.
5 Choose the options.
6 Choose OK.

Remark

Special characters may be entered in the string searched for.

See also

Searching for a string
Replacing a string
Special moves



Special moves

To go to a line identified by its number

1 Choose Go to line number... from the Search menu.
2 Type in the line number.
3 Choose OK.

To go to the last update
> Choose Go to last update from the Search menu.

To set or unset a bookmark on the current line
> Choose Toggle bookmark from the Search menu.

To go to the next bookmark
> Choose Next bookmark from the Search menu.

To go to the previous bookmark
> Choose Previous bookmark from the Search menu.

To clear the bookmarks
> Choose    Clear all bookmarks from the Search menu.

See also

Searching for a string
Replacing a string
Finding in files



Running a program
This command affords running an external program. A Windows or DOS program may be 
selected as well. The initial directory and arguments may be specified. Keywords may also 
be used, that will expand to values depending on the file active at launch-time.

To run a program

1 Choose Run... from the Tools menu.
2 Choose the program to run, the current directory and the other arguments.
3 Choose OK.

See also

SpellChecking
Converting the tabulation width
Sorting 



Spell checking

This command affords spell checking the text. Multiple dictionaries may be used 
simultaneously. Dictionaries are available for US English, British English, German, French, 
and Italian. To create a custom dictionary, create an empty file with type .dic under the 
Editeur installation directory.

To spell check

1 Choose Spell check... from the Tools menu.
2 If applicable, choose Spell check all texts.
3 Choose OK.

Spell checking dialog

Editeur sets up a dialog to drive the spell checking. You can move from this dialog to the text
and vice versa with a mouse click in the appropriate window : this affords a direct update of 
the text while driving the spell checking dialog.

Remark

Due to the size, only one language dictionary is included in the Shareware release of Editeur.
To get additional dictionaries, access my home page at : 
http://ourworld.Compuserve.com/homepages/JPMenicucci.

See also

Running a program
Converting the tabulation width
Sorting



Converting the tabulation width

This command affords modifying the tabulation width without modifying the text 
appearance. Editeur ensures the same appearance by inserting the right number of 
tabulations and spaces.

To convert

1 Choose Convert... from the Tools menu.
2 Type in the tabulation width "from".
3 Type in the tabulation width "to".
4 If applicable, choose Convert all texts.
5 Choose OK.

Editeur effects the conversion, modifies the tabulation width, and displays again the texts.

See also

Running a program
SpellChecking
Sorting



Sorting

This command affords sorting the text in ascending or descending order, comparing the 
whole lines or a part of the lines. The empty lines or part of lines may be moved to the 
beginning or to the end of the text.

To sort

1 Choose Sort... from the Tools menu.
2 Choose the options.
3 If applicable, choose Sort all texts.
4 Choose OK.

Editeur effects the sorting and displays again the texts.

Warning

The sorting cannot be undone. If applicable, make sure that a backup copy has been made 
before proceeding.

See also

Running a program
SpellChecking
Converting the tabulation width



Options

This dialog affords accessing several property pages grouping some options conditionning 
Editeur general behaviour.

To change the options

1 Choose Options... from the Option menu.
2 Choose the property page.
3 Choose the options.
4 Choose OK.

The following property pages are available :

Options

This property page affords changing Editeur general options.

The options come into six families :

Aspect, to drive the way the text is displayed, Bars, to show or hide the various control bars,
Files, to define file history, titles and backups, Typing, to define various typing options, Word 
wrap, to define the word wrap options, Startup, to define the file loading behaviour at 
startup.

Colors

This property page affords handling colors and syntax coloring.

File filters

This property page affords modifying the File Filter specifications used in the Open and Save 
as dialogs.

See also

Changing the font



Changing the font
To change the screen font

1 Choose Screen font... from the Options menu.
2 Select the name of the font.
3 Select the style of the font.
4 Type in or select the size of the font.
5 Choose OK.

To change the printer font

1 Choose Printer font... from the Options menu.
2 Select the name of the font.
3 Select the style of the font.
4 Type in or select the size of the font.
5 Choose OK.

To use a font close to the screen font for printing

> Check the Mirror display font menu item

Remarks

- Font choice applies to the whole text, and not to parts of the text (the text file format does 
not include any typographic adornment).

- The font selected last becomes the default font.

See also

Options 



Setting up new syntaxes
The Editeur release includes a generic syntax Dll and initialization files that you can 
duplicate and modify to add new syntaxes to handle. This generic syntax affords highlighting
comments and a list of keywords. The Cpp and Pascal syntaxes also included in this release 
use this facility.

How to set up new syntaxes

Duplicate files Syntax.dll and Syntax.ini under new names, then modify the .ini file as follows
:

In section FileTypes, type the file extensions handled, delimited by semi colons :

[FileTypes]
Types=*.xxx;*.yyy

In section Comments, type the beginning and ending strings, delimited and followed by 
vertical bars. If a comment beginning string has no comment end counterpart, the field 
should be left empty. The following example uses two comments : the first begins with /* and
ends with */, and the second begins with // and ends with the end of line :

[Comments]
Beginning=/*|//|
End=*/||

In section Keywords, type the keywords handled, one by line :

[Keywords]
append
assign
...

Last, using Option Options Colors, press the New button and enter the library path in the list.
That's that simple.

Remarks

- No multiline comments are available in this release.

- Depending on your feedback, new syntax libraries will be written in future releases. 

How to upgrade new syntaxes to V3.4

Editeur V3.4 comes with a new version of the Syntax.dll library. So, if you had made copies 
of this library to handle your own syntaxes, these copies should be made again.



Setting up new syntaxes
The Editeur release includes a generic syntax Dll and initialization files that you can 
duplicate and modify to add new syntaxes to handle. This generic syntax affords highlighting
comments and a list of keywords. The Cpp and Pascal syntaxes also included in this release 
use this facility.

How to set up new syntaxes

Duplicate files Syntax.dll and Syntax.ini under new names, then modify the .ini file as follows
:

In section FileTypes, type the file extensions handled, delimited by semi colons :

[FileTypes]
Types=*.xxx;*.yyy

In section Comments, type the beginning and ending strings, delimited and followed by 
vertical bars. If a comment beginning string has no comment end counterpart, the field 
should be left empty. The following example uses two comments : the first begins with /* and
ends with */, and the second begins with // and ends with the end of line :

[Comments]
Beginning=/*|//|
End=*/||

In section Keywords, type the keywords handled, one by line :

[Keywords]
append
assign
...

Last, using Option Options Colors, press the New button and enter the library path in the list.
That's that simple.

Remarks

- No multiline comments are available in this release.

- Depending on your feedback, new syntax libraries will be written in future releases. 

How to upgrade new syntaxes to V3.4

Editeur V3.4 comes with a new version of the Syntax.dll library. This new version is not 
compatible with the previous versions. So, if you had made copies of this library, you should 
make them again.



The File menu commands
New

This command creates a new empty text. The new text becomes active and can be directly 
edited.

Open...

This command opens one or more existing files. The file opened last becomes active and can
be directly edited.

Find in files...

This command searches for    a string in a directory and its subdirectories. The files 
containing the string are opened and it is possible to move between the occurrences of the 
string using the Next and Previous commands.

Reload...

This command discards all updates in the texts and reloads the last copy saved.

Save

This command saves the active text in a file. If the Create backup files option is on and the 
file already exists, a backup copy is created before saving.

Save all

This command saves all open texts under their corresponding file names. If the Create 
backup files option is on, backup copies are created before saving files.

Save as...

This command saves the active text under a new name.

Close

This command closes the active text. Editeur offers to save the text if it has been modified.

Save and close

This command saves and closes the active text in one single operation.

Print...

This command prints the active text or all texts on the selected printer.

Print preview...

This command displays the text as it will be printed.

Page setup...

This command sets up the header and the footer and the margins used for printing.



Print setup...

This command allows a printer to be chosen and its options to be set up.

Send...

This command sends the active text through electronic mail.

Exit

This command is used to exit Editeur. All open texts are first closed. Editeur offers to save 
every text modified.

Save and exit

This command saves all texts and exits in one single operation.

1, 2, 3, 4, ...

These commands are created as files are opened and make up a files history including from 
0 to 9 files. Selecting one of these commands reopens the corresponding file.



The Edit menu commands
Undo

This command undoes one update. The update unit consists of a set of characters belonging
to a single line and typed in one single time (with no insertion point move or menu 
command call). There is no limitation on the number of updates that can be undone or 
redone, except when the update memory is reset : when the text is saved or when the text 
is modified after having undone updates without having redone them.

Redo

This command redoes one previously undone update.

Repeat

This command repeats the last update in another location.

Cut

This command copies the selection into the clipboard and clears the original ;    the copied 
text replaces the previous content of the clipboard.

Copy

This command copies the selection into the clipboard without clearing the original ; the 
copied text replaces the previous content of the clipboard.

Append

This command appends the selection into the clipboard without clearing the original.

Paste

This command inserts the clipboard content at the insertion point.

Clear

This command clears the selection.

Select all

This command selects the whole text.

Copy to...

This command copies the selection to a file.

Paste from...

This command inserts characters from a file.

Indent

This command moves the selection one tabulation to the right.



Unindent

This command moves the selection one tabulation to the left.

Upper

This command sets the selection to uppercase characters.

Lower

This command sets the selection to lowercase characters.

Invert

This command inverts the case of the selection.

Capitalize

This command sets to uppercase the first letter of every word of the selection.

Date/time

This command inserts the current date and time at the insertion point.



The Search menu commands
Search...

This command searches for a string. Various options are available : match upper/lower case, 
whole word, whole text/selected text/ from cursor, forwards/backwards, all texts.

Search next

This command is used for finding the next occurrences of the string selected when using the 
Search command.

Search previous

This command is used for finding the previous occurrences of the string selected when using
the Search command, going backwards into the texts.

Replace...

This command replaces a string by another. Different options are available : match 
upper/lowercase, whole word, whole text/selected text/ from cursor, forwards/backwards, all 
texts. The replacements are driven with a specific dialog. You can move from this dialog to 
the text and vice-versa with a mouse click in the appropriate window : this affords a direct 
update of the text while driving the replacement dialog.

Go to line number...

This command ensures positioning on a line identified by its number in the active text.

Go to last update

This command ensures positioning on the last update in the active text.

Toggle bookmark, Next bookmark, Previous bookmark, Clear all bookmarks

These commands handle locations in the active text between which quick moves are 
possible.



The Macro menu commands
Load...

This command loads a previously stored macro.

Store...

This command stores the current macro in a file so as to be able to replay it in a later Editeur
session.

Record macro

This command begins the recording of your actions. Beware, not all keystrokes are 
recorded : Actions on system boxes and window menu files are not. More, except in the 
search menu case, the recording stops "at the dialogs gates" : what you do inside the 
dialogs is not recorded and you will have to fill again these dialogs    during each replay.

Finish recording

This command stops the recording.

Replay

This command replays the current macro once.

Replay n times...

This command replays the current macro for a specified number of times. The replay may be
interrupted by pressing the escape key.

Replay indefinitely

This command replays the current macro until the end of the times or until an error occurs 
(e.g., a text searched is not found). The replay may be interrupted by pressing the escape 
key.



The Tools menu commands
Run...

This command affords running an external program. A Windows or DOS program may be 
selected as well.

Spell check...

This command affords spell checking the text. Multiple dictionaries may be used 
simultaneously. Dictionaries are available for US English, British English, German, French, 
and Italian. To create a custom dictionary, create an empty file with type .dic under the 
Editeur installation directory.

Convert...

This command affords modifying the tabulation width without modifying the text 
appearance. Editeur ensures the same appearance by inserting the right number of 
tabulations and spaces.

Sort...

This command affords sorting the text in ascending or descending sorting, comparing the 
whole lines or a part of the lines. The empty lines or part of lines may be moved to the 
beginning or to the end of the text.

1, 2, 3, 4, 5, 6, 7, 8, 9

These commands afford launching external tools that you define and name in the Option 
Tools menu.



The Option menu commands
Options...

This command affords accessing several property pages grouping some options 
conditionning Editeur general behaviour.

Screen font...

This command allows the font used for displaying to be chosen. The font selected becomes 
the default font.

Printer font...

This command allows the font used for printing to be chosen. The font selected becomes the
default font.

Mirror screen font...

Checking this menu item affords using a copy of the screen font for printing.

Tools...

This command affords defining up to 9 external tools that will be displayed at the bottom of 
the tools menu. Windows or Dos programs might be selected as well.



The Window menu commands
Cascade

This command rearranges the text windows in a cascade pattern.

Tile horizontal

This command tiles windows horizontally.

Tile vertical

This command tiles windows vertically.

Arrange icons

This command rearranges the minimized text icons on Editeur desktop.

Split

This command splits the active text window into panes.

Close all texts

This command closes all open texts. Editeur offers to save every modified text.

Save and close all texts

This command saves and closes all texts in one single operation.

1, 2, 3, 4, 5, 6, 7, 8, 9, ...

These commands are created as text windows are opened and make up a list of open text 
windows. Selecting one of these commands activates the corresponding text window.



The Help menu commands
Help topics

This command gives a summary of Editeur help topics.

Tip of the day

This command gives a short piece of advice about the use of Editeur.

About Editeur...

This command specifies the current version number and the name of the License owner.

Contact...

This command summarizes different means to contact the author of this program. 



Legal information

COPYRIGHT

© Copyright 1992-1997 Jean-Pierre Menicucci - All rights reserved. This sofware is subject to the terms of
the license agreement hereafter. This software may be used or copied only in accordance with the terms 
of this agreement. Purchasing a license does not mean purchasing the software, which is and remains 
the sole property of Jean-Pierre Menicucci.

LIMITED    WARRANTY

THIS SOFTWARE AND MANUAL ARE PROVIDED "AS IS" AND WITHOUT WARRANTIES AS TO 
PERFORMANCE OF MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED 
OR IMPLIED. BECAUSE OF THE VARIOUS HARDWARE AND SOFTWARE ENVIRONMENTS INTO 
WHICH THIS PROGRAM MAY BE PUT, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE
IS OFFERED. THE USER MUST ASSUME THE ENTIRE RISK OF USING THE PROGRAM. ANY 
LIABILITY OF THE SELLER WILL BE LIMITED EXCLUSIVELY TO PRODUCT    REPLACEMENT OR 
REFUND OF PURCHASE PRICE.

LICENSE    AGREEMENT

Using this software implies your acceptance of the following terms and conditions :

1. Unregistered software* :    the unregistered software may be freely tried out for a time period not to 
exceed 30 days. Continued use past this period requires registration. The unregistered software may be 
freely copied and distributed. However, the distribution must be complete and with no modification. 
Holding the software for redistribution does not require registration.

2. Registered software* : the number of copies installed must not exceed the number of licenses 
purchased. The redistribution of the registered software to third parties is prohibited.

3. Registered or unregistered software : reverse-engineering or modifying the software is strictly 
prohibited. 

* : The Software is unregistered when the license has not (yet) been purchased. The Software is 
registered when the license has been purchased. 



Registering

REGISTRATION

With your registration, you will receive an identification key that will eliminate the Shareware reminder 
messages, and the latest version of the product. Your name will also appear in the "About" menu, instead 
of "Unregistered copy".

Your registration also includes access to the future versions : you won't have to pay any additional fee for 
using these versions. Your key will work for these versions or I will provide you with a new one (just ask 
me). Notice however that I won't be able to send new diskettes for free when releasing new versions. So 
please, get these versions on the Web, or order additional diskettes.

Your registration finally includes support and bug fixes. Unless particular emergency, bug fixes will be 
integrated to the next version.

REGISTERING    -    Worldwide Web

Editeur can be registered via MasterCard, Visa, American Express, or Discover from the Public (software)
Library Web site. Both secure and normal payments are available. Access Editeur home page at 
http://www.studioware.com, and follow the links. PsL Web registrations are $ 20 US.

Note : Web registerees will receive their identification key via E-mail. The latest version will be available 
on Editeur home page at http://www.studioware.com. No diskettes will (need to) be shipped.

REGISTERING    -    E-mail,    Fax,    or    Mail

To register via E-mail, Fax, or Mail, fill in file order.doc and send it along with your payment to :

http://www.studioware.com Jean-Pierre Menicucci
E-mail : JPMenicucci@studioware.com 18 Rue de Brest, Apt 243
Fax : +33 2 9954-4273    /    Tel : +33 2 9954-4930 35000 Rennes - France

In adition to the license price (FF 100), e-mail, fax, or mail orders incur a charge for shipping and handling
(FF 25).



EDITEUR    ORDER    FORM

SEND    ORDER    FORM    TO:

An invoice will be attached to your shipment. Please E-mail, fax, or mail this order form to :

http://www.studioware.com Jean-Pierre Menicucci
mailto: JPMenicucci@studioware.com 18 Rue de Brest, Apt 243
Fax : +33 2 9954-4273    /    Tel : +33 2 9954-4930 35000 Rennes - France

YOUR    ORDER

Quantity : ________ licenses FF 100 / license. Amount : FF        _________
      (approximately $ 20 US, depending on the change rate)

                              shipping and handling. Amount : FF        _______25
      (approximately $ 5 US, depending on the change rate)

Total : FF                _________

Note: You can also register using http://www.studioware.com (secure payment). The price is $ 20 US. You will receive your 
registration key via e-mail and a receipt via mail.

YOUR    PAYMENT

MasterCard      [        ]        Visa      [        ]        Number :      ____      / ____      / ____      / ____        Expires : __    / 
__

American Express      [        ]      Number :      ____      / ______      / _____        Validity : __ / __ thru __ / __

Name on the card : __________________________________________________________

Money order        [        ]        Electronic funds transfer        [        ]        Check        [        ]

SHIP    PRODUCT    TO:

LICENSE OWNER : _________________________________________________________
                                                                (displayed in the "About" menu, Mr, Mrs, Miss X, or company name)

NAME : ________________________ COMPANY :    _______________________

ADDRESS : _____________________________________________________________

_____________________________________________________________

CITY : _________________________ STATE : _____        ZIP CODE :    _________

COUNTRY : _________________________

PHONE : _________________________ FAX : _____________________________



DATE : _________________________ SIGNATURE : ______________________

REMARKS    AND    SUGGESTIONS



New
Creates a new empty text. The new text becomes active and can be directly edited.

See also

Save as...



Open
Opens one or more existing files. The file opened last becomes active and can be directly 
edited.

The format may be specified :

Format

Different operating systems use different character codes and end-of-line character 
combinations for text files. Choose the format explicitly or choose Auto to let Editeur 
automatically determine the format.

Remarks

Editeur affords editing any file as text. This proves helpful when handling binary files with 
text sections. 



Operating systems use different character codes and end-of-line character combinations for text files. Choose Auto 
for automatic recognition or an explicit format.





Reload
Text with a title

Reloads the active text from the file, discarding all updates. 

Untitled text

The text is cleared. All updates are canceled.



Save
Writes the text to disk. For untitled texts, Editeur first asks for a file name.



Save all
Writes all open texts to disk. For untitled texts, Editeur first asks for file names.

Every text is saved using the format specified at Open time or at Save as... time.



Save as
Saves the active text to a new file.

This affords saving a text created using the New command in the File menu, or saving an 
existing text under a new name.

The format may be specified :

Format

Different operating systems use different character codes and end-of-line character 
combinations for text files. When saving, the most recommended format is the Windows 
format, but you could also save your texts to Dos, Mac, or Unix formats.



Operating systems use different character codes and end-of-line character combinations for text files. Choose here 
the format under which you wish the file to be saved.





Close
Closes the active text.

Editeur proposes to save the file if it has been modified.



Save and close
Saves the active text and closes it.

Remark

This command affords quickly closing a text by not asking whether it should be saved or not.



Print
Prints the active text.



Print Preview

Displays the active document as it would appear when printed. When you choose this 
command, the main window will be replaced with a print preview window in which one or 
two pages will be displayed in their printed format. The print preview toolbar offers you 
options to view either one or two pages at a time; move back and forth through the 
document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print setup
Affords choosing the active printer and its options.

Remark

The dialog proposed depends on the printer type. This dialog is called by Editeur, but is 
provided by the printer manufacturer.



Page setup
Affords specifying the page setup parameters used for printing. These parameters include : 
a header line, a footer line, and margins.

Macros

Macros afford printing variable data on the header and footer lines. &f affords printing the 
file name, &d the date and time, and &p the page number. 



Affords entering a line that will be printed on top of each page. The following strings will be replaced by :
&f : the file name
&d : the current date and time
&p : the current page number



Affords entering a line that will be printed at the bottom of each page. The following strings will be replaced by :
&f : the file name
&d : the current date and time
&p : the current page number 



Affords entering the size of spaces not to be used on the various sides of the printed page. The units may be inches 
(") or centimeters (cm).



Affords entering the size of spaces not to be used on the various sides of the printed page. The units may be inches 
(") or centimeters (cm).



Affords entering the size of spaces not to be used on the various sides of the printed page. The units may be inches 
(") or centimeters (cm).



Affords entering the size of spaces not to be used on the various sides of the printed page. The units may be inches 
(") or centimeters (cm).



Check this radio button if you wish the margins to be converted to inches.



Check this radio button if you wish the margins to be converted to centimeters.



Applies the updates to the page setup.



Cancels any update to the page setup.





Send

Sends the active text through electronic mail. It presents a mail window with the active text 
attached to it. You may then fill out the To: field, Subject: field, etc., and add text to the body
of the message if you wish. When you are finished you may click the "Send" button to send 
the message.



Exit
Terminates the program. Editeur proposes to save any file modified.



Save and exit
Terminates the program, automatically saving the files modified.

Remark

This command affords quickly quitting by not asking if the files modified have to be saved. 



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu.



Reopen
Editeur records the names of the files opened. These files may be reopened at any time 
using these commands in the File menu. 



Undo
Undoes, one at a time, the updates to the text.

Note

The number of updates undone is not limited, but modifying a text when updates have been 
undone and not redone resets the update memory ...



Redo
Redoes, one at a time, the previously undone updates.

Note

The number of updates undone or redone is not limited, but modifying a text when updates 
have been undone and not redone resets the update memory ...



Repeat
Repeats the current update in another place.

Remark

Only elementary updates may be repeated. For complex updates, using macros will make 
more sense ...



Cut
Copies the selected text on to the clipboard, then deletes it.



Copy
Copies the selected text to the clipboard.



Append
Appends the selected text to the text already present in the clipboard.



Paste
Inserts the clipboard content at the insertion point.



Clear
Deletes the selected text.



Select all
Selects the whole active text.



Copy to
Copies the selected text to a file.

The format may be specified :

Format

Different operating systems use different character codes and end-of-line character 
combinations for text files. When saving, the most recommended format is the Windows 
format, but you could also save your texts to Dos, Mac, or Unix formats.



Operating systems use different character codes and end-of-line character combinations for text files. Choose here 
the format under which you wish the file to be saved.





Paste from
Inserts the content of one or more files at the insertion point.

The format may be specified :

Format

Different operating systems use different character codes and character combinations for 
text files. Choose the format explicitly or choose Auto to let Editeur automatically determine 
the format.



Operating systems use different character codes and end-of-line character combinations for text files. Choose Auto 
for automatic recognition or an explicit format.





Indent
Moves the selected text by one tabulation to the right.



Unindent
Moves the selected text by one tabulation to the left. 



Join lines
Deletes the end-of-line characters in the selected text to set up a single word-wrappable 
line. 



Reformat
Inserts end-of-line characters in the selected text, to split it into separate lines. 



Upper
Changes the selected text to uppercase.



Lower
Changes the selected text to lowercase. 



Invert
Inverts the case of the selected text.



Capitalize
Changes to uppercase the first letter of every word of the selected text.



Date/Time
Inserts the date and time at the insertion point.



Search
Searches for a string in the active text or in all open texts.

Remark

Special characters may be entered in the string searched for. Notice however that end of line
CrLf's are not retained in Editeur memory and therefore will never be found at line ends.



Type here the string to search for or scroll the list and choose a string previously used.



Check this to use the case when searching. Uncheck it    for not using it.



Check this to search for the string as whole words only. Uncheck it to search for the string inside bigger words as 
well.



Check this to search for the string in the whole text.



Check this to search for the string within the text selected.



Check this to search for the string from the insertion point to the end of the text.



Check this to search forwards from the beginning of the text to the end of the text.



Check this to search backwards from the end of the text to the beginning of the text.



Check this to process all texts. Uncheck it to process only the active text.



Closes this dialog box and searches for another occurrence of the string.



Closes this dialog box and searches for the string.



Closes this dialog box without searching for the string.



Displays help about searching.





Search next
Searches for the next occurrence of a string.

Remark

This command is executed without calling a dialog, which affords keeping the whole screen 
estate to display useful information.



Search previous
Searches for the previous occurrence of a string.

Remark

This command is executed without showing a dialog. This affords keeping the whole screen 
estate to display useful information.



Replace
Replaces a string by another in the active text or in all open texts.

Remark

The replacements are driven with a specific dialog. You can move from this dialog to the text
and vice-versa with a mouse click in the appropriate window : this affords directly updating 
the text while driving the replacement dialog.

Special characters may be entered in the strings searched for and replacing. Notice however
that end of line CrLf's are not retained in Editeur memory and therefore will never be found 
at line ends. 



Type here the replacing string or scroll the list and choose a string previously used.



Closes this dialog box and replaces all occurrences of the string without asking any confirmation.



Closes this dialog box and replaces the occurrences of the string asking for a confirmation of every replacement.



Closes this dialog box without replacing.



Displays help about replacing.





Find in files
Searches for a string in a set of files, opening all the files including the string. After the files 
have been opened, you can navigate between occurrences of the string using Search next 
and Search previous.

Remarks

- Multiple file types may be specified in the filter, using the semicolon (;) separator.

- Special characters may be entered in the string searched for. Notice however that end of 
line CrLf's are not retained in Editeur memory and therefore will never be found at line ends. 



Type here the file search filter or scroll and choose a filter previously used. 



Type here the directory to search or scroll and choose a directory previously used.



Check this to search the sub-directories of the search directory. Uncheck it to search only the search directory.



Closes this dialog box and effects the search.



Displays a dialog to choose the directory.



Closes this dialog box without searching.



Displays help about searching.





Go to line number
Scrolls the display in order to show a line identified by its number.



Go to last update
Scrolls the display in order to show the last update.



Toggle bookmark
Puts or removes a bookmark on the current line.

The line including the bookmark is selected when the bookmark is put, and unselected when
the bookmark is removed.

Remark

This command affords moving cyclically on several locations in a text without cluttering up 
the screen with several views of the text.



Next bookmark
Scrolls the display to the next bookmark.

The line including the bookmark is selected, which affords seeing it. 



Previous bookmark
Scrolls the display to the previous bookmark.

The line including the bookmark is selected, which affords seeing it.



Clear all bookmarks

Clears all active bookmarks.



Load macro
Loads a previously recorded macro into memory.

Macro

A macro is a recording of a set of keystrokes and mouse moves. A macro is recorded to be 
replayed later, in order to automate some recurrent tasks.



Store macro
Stores the current macro in a file.

Macro

A macro is a recording of a set of keystrokes and mouse moves. A macro is recorded to be 
replayed later, in order to automate some recurrent tasks.



Record macro
A macro is a recording of a set of keystrokes and mouse moves. 

After having recorded a macro, you will be able to replay, and thus automate some recurrent
tasks.

Remark

The events recording stops with the dialogs : what you type inside the dialogs is not 
recorded by Editeur. Besides this, only one macro is active at a given moment.



Finish recording
Stops the macro recording.

From this moment, the macro may be reused.



Replay
Replays the macro once.



Replay n times
Replays the macro a number of times that you specify. However, the replay process may be 
interrupted at any time by pressing the "Escape" key.



Replay indefinitely
Replays the macro indefinitely. However, the replay process may be interrupted at any time 
by pressing the "Escape" key. 



Compare files
Shows the differences between two files. 



Run
Affords running an external program. A Windows or DOS program may be selected as well.

The initial directory and arguments may be specified. Keywords may also be used, that will 
expand to values depending on the file active at launch-time :

$basename the file name without the extension
$directory the drive and directory
$drive the drive where the file is located
$extension the file extension
$filepath the file path
$filename the file name without the drive and the directory

If no file is active when the tool is launched, the keywords will expand to "void".

All files will be saved before launching the program (if a file still has no name at this 
moment, Editeur will ask for one). Optionally, Editeur will be minimized when launching the 
program. You may also choose the launch size of the program. 



Command line used for running the program.



Displays an open dialog for searching for the program to run.



Optional initial directory. Let empty to use the current directory. 



Displays a directory search dialog for searching for the current directory.



Optional arguments to be added to the command line. The following keywords may be used :
$basename the file name without the extension
$directory the drive and directory
$drive the drive where the file is located
$extension the file extension
$filepath the file path
$filename the file name without the drive and the directory



Check this to minimize Editeur when launching the program. 



Choose this to launch the program minimized.



Choose this to launch the program with a normal size.



Choose this to launch the program maximized. 



Accepts the changes and closes this dialog box.



Cancels the changes and closes this dialog box.



Displays help about this dialog box.





Spell check

Checks the spelling in the active text or in all open texts. Multiple dictionaries may be used 
simultaneously. Dictionaries are available for US English, British English, German, French, 
and Italian. To create a custom dictionary, create an empty file with type .dic under the 
Editeur installation directory.



If checked, words must exactly match those in the dictionaries to be considered spelled correctly.    If not checked, 
words all lowercased in the dictionary can also be proper cased or fully capitalized in the text and be considered 
spelled correctly.



If checked, words completely capitalized (such as NASA) are considered spelled correctly without searching the 
dictionaries.



If checked, words partially composed of digits (such as 4th) are considered spelled correctly without searching the 
dictionaries.



If checked, words completely composed of digits (such as 456) are considered spelled correctly without searching 
the dictionaries.



If checked, words with hyphens in them which are not found in a dictionary are separated into individual words at 
the hyphens, and each separate word spellchecked.    For example, leaf-blower is considered spelled correctly if leaf 
and blower are each found in the dictionary.



If checked, suggestions are automatically generated for the misspelled word.



Check this to check the spelling in the whole text.



Check this to check the spelling within the text selected.



Check this to check the spelling from the insertion point to the end of the text.



Check this to spell check all texts. Uncheck it to spell check only the active text.



List of standard dictionaries. A standard dictionary is a language dictionary provided with the application and is not 
updateable. To use a dictionary during the spell checking, check the box on the left of its name. Else, uncheck it.



Press this button to add a standard dictionary to the list.



Press this button to remove the standard dictionnary currently selected.



List of custom dictionaries. A custom dictionary is a dictionary of yours. You can create an empty .dic file for this or 
use WinWord .dic personal dictionaries as well. To use a dictionary during the spell checking, check the box on the 
left of its name. Else, uncheck it. 



Press this button to add a custom dictionary to the list.



Press this button to remove the custom dictionnary currently selected.



Closes this dialog box and effects the spell checking.



Closes this dialog box without spell checking.



Displays help about spell checking.



Misspelled word.



List of suggestions to replace the misspelled word.



Press this button to get a list of suggestions to replace the misspelled word.



Press this button to keep on spell checking without replacing the misspelled word.



Press this button to accept the misspelled word spelling everywhere and keep on spell checking.



Press this button to keep on spell checking without replacing the misspelled word.



Press this button to replace the misspelled word by the value in the suggestion listbox edit box.



Press this button to replace the misspelled word everywhere by the value in the suggestion listbox edit box.



Press this button to stop spell checking immediately.



Press this button to add the misspellled word to the custom dictionary selected.



Affords selecting the custom dictionary where the misspelled words should be entered.





Convert
Changes the tabulation width without modifying the text presentation.

Editeur replaces the empty spaces by the number of tabulations and spaces required to 
ensure the same presentation.

Remark

A conversion processing cannot be undone with the undo command. So, saving the text 
before converting might make sense. 



Input tab size to use during conversion. The initial value is the current tab size.



Output tab size to use during conversion.



Check this to convert all texts. Uncheck it to convert only the active text. 



Closes this dialog box and effects the conversion.



Closes this dialog box without effecting the conversion.



Displays help about conversion.





Sort

Alphabetically sorts the text in ascending or descending order, comparing the whole lines or 
a part of the lines. The empty lines or part of lines may be moved to the beginning or to the 
end of the text.

Remark

A sort processing cannot be undone with the undo command. So, saving the text before 
sorting might make sense.



Check this to sort the lines in alphabetical ascending order.



Check this to sort the lines in alphabetical descending order. 



Check this to use local language sorting conventions for character comparison.



Check this to use character code order for character comparison.



Check this to sort the whole text.



Check this to sort only the selected text.



Check this to sort the text from the insertion point to the end of the file.



Check this to sort all texts. Uncheck it to sort only the active text.



Check this to move empty lines to the beginning of the text.



Check this to move empty lines to the end of the text. 



Check this to use case in character comparison.



Check this to not to use case in character comparison.



Check this to use whole lines for sorting.



Check this to use only a part of the lines for sorting. If no character is present in the sorting zone of a line, this line 
will be considered as empty.



Starting character position used for sorting.



Number of characters used for sorting.



Closes this dialog box and effects the sorting.



Closes this dialog box without effecting the sorting.



Displays help about sorting.





External tools
Launches the specified external tool. External tools are defined in the Tools command in the
Options menu.



External tools
Launches the specified external tool. External tools are defined in the Tools command in the
Options menu.



External tools
Launches the specified external tool. External tools are defined in the Tools command in the
Options menu.



External tools
Launches the specified external tool. External tools are defined in the Tools command in the
Options menu.



External tools
Launches the specified external tool. External tools are defined in the Tools command in the
Options menu.



External tools
Launches the specified external tool. External tools are defined in the Tools command in the
Options menu.



External tools
Launches the specified external tool. External tools are defined in the Tools command in the
Options menu.



External tools
Launches the specified external tool. External tools are defined in the Tools command in the
Options menu.



External tools
Launches the specified external tool. External tools are defined in the Tools command in the
Options menu.



Options

Affords accessing several property pages grouping some options conditionning Editeur 
general behaviour.



Options
This property page affords changing Editeur general options.

The options come into six families :

Aspect, to drive the way the text is displayed, Bars, to show or hide the various control bars,
Files, to define file history, titles and backups, Typing, to define various typing options, Word 
wrap, to define the word wrap options, Startup, to define the file loading behaviour at 
startup.



Number of spaces used between two tabulation positions. 



Number of pixels left blank on the left window border. 



Check this to view spaces, tabulations, or paragraph characters (as '·', ' ', and '¶').



Check this to simultaneously scroll pages when you view several texts.



Check this to show the toolbar. Uncheck it to hide the toolbar.



Check this to show the status bar. Uncheck it to hide the status bar.



Check this to show vertical scroll bars. Uncheck it to hide vertical scroll bars.



Check this to show horizontal scroll bars. Uncheck it to hide horizontal scroll bars.



Affords choosing the maximum number of files shown in the file history, at the bottom of the file menu.



Check this to use file paths as texts titles. Uncheck it to use file names instead.



Check this to backup files when saving. Uncheck it to not backup files.



Suffix used to backup files. Replaces the original suffix in the backup copy.



Check this to change tabulations to spaces when typing. Uncheck it to let tabulations unchanged within texts. 



Check this to delete the text selected when you enter new text. Uncheck it to append the new text to the selected 
text instead. 



Check this to copy the previous line leading spaces and tabulations when you press the Enter key. Uncheck it to 
begin a new line at the first display position.



Check this to automatically insert a new line when reaching the wrapping limit. Uncheck it to simply wrap the line 
instead. 



Choose this for not wrapping lines. Display and printing will be a bit faster.



Choose this to wrap lines when reaching the windows right borders.



Choose this to wrap lines when reaching the number of characters given.



Maximum number of characters displayed in one single line when using column word wrap.



Check this to afford cutting words whenever word wrapping. Uncheck it to try not to cut words but placing them on 
the following line instead.



Check this to reopen at startup the files that were open when you last quitted last. Uncheck it for not doing so. 



Check this to propose an "Open" dialog at startup. Uncheck it for not doing so.



Check this to create a new, empty file at startup. Uncheck it to for not doing so.





Colors
This property page affords handling colors and syntax coloring.

Syntaxes

The left part of the page shows which syntaxes are available, which file types are handled, 
and affords entering or removing syntaxes. A syntax is defined and handled by a syntax 
library DLL, that can recognize syntax items in a text and define default colors for these 
items.

Colors 
The right part of the page afford selecting syntax items individually and choosing colors and 
font attributes to use. You can also choose overall default foreground and background colors.

See also

Setting up new syntaxes



List of syntax libraries handled. The Syntax items list applies to the current syntax library. 



List of file types handled by the current syntax library. Multiple types may be specified, using the semicolon (;) 
separator.



Adds a new syntax library to the list.



Deletes the current syntax library from the list.



Reloads the current syntax default colors from the syntax library.



Shows the aspect of the current syntax item.



List of possible syntax items in the current syntax library. Colors and styles apply to the current syntax item.



Affords choosing the current syntax item text color. Choose Auto to select the default text color.



Affords choosing the current syntax item background color. Choose Auto to select the default background color.



Check this to display the current syntax item with a bold copy of the base font.



Check this to display the current syntax item with an italic copy of the base font.



Check this to display the current syntax item with an underlined copy of the base font.



Check this to display the current syntax item with a stroked out copy of the base font. 



Affords choosing the default text color. Choose Auto to select Windows default window text color.



Affords choosing the default background color. Choose Auto to select Windows default window background color.





File filters
This property page affords modifying the File Filter specifications used in the Open and Save 
as dialogs.

File filters lists

The left box shows the values that will be displayed in the "Type" combo box in the Open and
Save as dialogs. The right box shows the extensions that will be actually used when filtering 
files.

Handling buttons

The four buttons on the right afford handling the lists : adding and removing items, moving 
items in the lists.



Type here what you wish to be displayed in the "Type" combo box in the Open and Save as dialogs. 



Type here the actual extensions that will be used when filtering files.



After having typed values in the edit fields on the left, press this button to add the values to the lists.



After having selected an item in one of the lists on the left, press this button to remove it from the lists.



After having selected an item in one of the lists on the left, press this button to move it up in the lists.



After having selected an item in one of the lists on the left, press this button to move it down in the lists. 





Word wrap
Affords toggling the word wrap mode. To configure word wrap, choose Option Options.



Show spaces
Affords toggling the view option. Choose to view spaces, tabulations, or paragraph 
characters (as '·', ' ', and '¶').



Screen font
Affords choosing the font used for displaying the active text. The font selected becomes the 
default font.

There is no restriction on the font chosen. In particular, you can use proportional fonts 
(whose characters have not the same size).

Remark

The active text is immediately redrawn with the font specified, which affords immediately 
viewing its new aspect.



Printer font
Affords choosing the font used for printing. Pressing the "view" button affords viewing the 
text on screen with a font approximating the printer font selected.

Remark

This approximation will be good only if Windows finds a screen font close to the printer font 
that you will have selected.



Mirror screen font
Selecting this menu option affords using an approximation of the current screen font for 
printing.

Remark

This approximation will be good only if Windows finds a printer font close to the screen font 
that you will have selected



Tool arguments
Affords adding arguments to the command line build to launch the tool chosen.

To cancel the display of this dialog box, choose the Option Tools command, select the tool in 
the tool list, then uncheck the add argument check box. 



Command line used to launch the tool. Modify this line in any way you’d like.



Executes the command line.



Cancels the command line execution.



Displays help about this dialog box.





Tools
Affords defining up to 9 external tools that will be added at the bottom of the Tools menu. 
Windows or DOS programs may be selected as well.

The initial directory and arguments may be specified. Keywords may also be used, that will 
expand to values depending on the file active at launch-time :

$basename the file name without the extension
$directory the drive and directory
$drive the drive where the file is located
$extension the file extension
$filepath the file path
$filename the file name without the drive and the directory

If no file is active when the tool is launched, the keywords will expand to "void".

All files will be saved before launching the tool (if a file still has no name at this moment, 
Editeur will ask for one). Optionally, Editeur will be minimized when launching the tool. You 
may also choose the launch size of the tool. Last, you may specify that additional arguments
will systematically have to be asked for when launching the tool. 



List of tools currently appearing at the bottom of the tools menu. 



Adds a new tool to the list (9 tools maximum).



Deletes the currently selected tool.



Moves the currently selected tool one position up. 



Moves the currently selected tool one position down. 



Accepts the changes and closes this dialog box.



Cancels the changes and closes this dialog box.



Displays help about this dialog box.



Name of the tool, as it will appear at the bottom of the tools menu.



Command line used for launching the tool. 



Optional initial directory. Let empty to use the current directory.



Optional arguments to be added to the command line. The following keywords may be used :
$basename the file name without the extension
$directory the drive and directory
$extension the file extension
$filepath the file path
$filename the file name without the drive and the directory



Check this to minimize Editeur when launching the tool.



Check this to ask for additional arguments when launching the tool.



Check this to launch the tool minimized.



Check this to launch the tool with a normal size.



Check this to launch the tool maximized.





Cascade
Arranges the text windows in cascade.



Tile horizontal
Tiles the text windows horizontally.



Tile vertical
Tiles the text windows vertically.



Arrange icons
Rearranges the minimized text windows. 



Split
Use this command to split the active window into panes. You may then use the mouse or the
keyboard arrows to move the splitter bars. When you are finished, press the mouse button or
enter to leave the splitter bars in their new location. Pressing escape keeps the splitter bars 
in their original location.



Close all texts
Closes all open texts. 

Editeur proposes to save every file including unsaved updates.



Save and close all texts
Closes all open texts, automatically saving every text modified.

Remark

This command affords quickly closing all texts by not asking whether modified texts should 
be saved or not.



Move to another text
Editeur displays a list of currently open texts at the bottom of the Window menu. A check 
mark appears in front of the name of the active text. Choose a document from this list to 
make its window active. 



Help topics
Displays a summary of Editeur's help topics.



Context sensitive help
Displays help for clicked-on buttons, menus and windows.



Tip of the day
Gives a short information about Editeur. 



About Editeur
Gives Editeur Version and Copyright information, and the License owner name.



Contact
Gives a summary of the mail and e-mail addresses of the author of this program. Please, 
prefer e-mail when writing. It's faster and more efficient.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Editeur.

To hide or display the Toolbar, choose Toolbar from the Options menu (ALT, O, O).



Restore

Use this command to return the active window to its size and position before you choose the
Maximize or Minimize command.



Move

Use this command to display a four-headed arrow so you can move the active window with 
the arrow keys.

Note: This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Size

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Minimize

Use this command to reduce the Editeur window to an icon.

Shortcut
Mouse: Click the minimize icon  on the title bar.

Keys: ALT+F9



Maximize

Use this command to enlarge the active window to fill the available space.

Shortcut
Mouse: Click the maximize icon  on the title bar; or double-click the title bar.

Keys: CTRL+F10 enlarges a text window.



Close

Use this command to close the active text window or the application.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note: If you have multiple windows open for a single text, the Close command on the text 
Control menu closes only one window at a time. You can close all windows at once with the 
Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the Editeur window



Next Window

Use this command to switch to the next open text window. Editeur determines which window
is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window

Use this command to switch to the previous open text window. Editeur determines which 
window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Switch to

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap. This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Stay on top

Check this command to display Editeur on top of all other windows.



Title Bar

The title bar is located along the top of a window. It contains the name of the application and
document.

To move the window, drag the title bar. Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Toolbar

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in Editeur, such as File Open. A check mark appears next to the 
menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Editeur.

To hide or display the Toolbar, choose Toolbar from the Options menu (ALT, O, O).



Status Bar

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the Editeur window. To display or hide the status
bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus or when you place the mouse cursor on toolbar buttons.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down. 



Text file
A text file is a set of characters recorded in a raw state. The only characters used to control 
the presentation are the Tabulation and Line feed characters, and all other characters are 
displayed with their graphic representation.



Insertion point
The insertion point is the location where the next update is to take place. It is highlighted 
with a blinking shape.



Selection
The selection is the part of a text where the colors of the characters and the background 
have been inverted. The selection allows the scope of operations you ask to be specified and
allows a part of the text to be highlighted by Editeur.



Format
Editeur handles the following file formats :

Windows : end of line = cr + lf
Dos : end of line = cr + lf, code = OEM
Mac : end of line = cr
Unix : end of line = lf

When choosing "Auto", Editeur will determine the format for you by checking the end-of-line
characters in the first 64K bytes of the text.

Remark

Editeur can handle binary files transparently.



Format
Editeur handles the following file formats :

Windows : end of line = cr + lf
Dos : end of line = cr + lf, code = OEM
Mac : end of line = cr
Unix : end of line = lf



Transparency
Editing files transparently means editing these files without destroying their format and 
without changing their content in an unexpected way.



Special characters
A special character is entered using a dollar sign followed by a letter. Special characters 
currently handled are : $t (tabulation), $r (return), $n (newline) , $0 (null), and $$ (dollar).






