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,

SpanSoft is a member of the Association of Shareware Professionals (ASP). The ASP wants to
make sure that the shareware principle works for you. If you are unable to resolve a shareware-
related problem with an ASP member by contacting the member directly, the ASP may be able to
help. The ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but
does not provide technical support for members' products.

Please write to the ASP Ombudsman at 545 Grover Road, Muskegon, Ml 49442-9427 USA, FAX
616-788-2765 or send a CompuServe message via CompuServe Mail to ASP Ombudsman
70007,3536.



Using the Help file

To display the "Getting Started" help topic use Help|Getting started from the Kith and Kin main
menu.

The help file is a complete on-line manual for Kith and Kin. As well as providing context-sensitive
help direct from Kith and Kin, it contains all the technical information about the program and
usage tips in an easy-to-use format.

If you are not familiar with using Windows help files, read the 'help on help' information. Do this
by clicking the left mouse button on 'Help' in the menu above the help file and then on '‘How to
Use Help' in the pull-down menu.

You can get help by either selecting Help|Contents from the main menu or by pressing F1. You
can also get specific help on whatever task you are carrying out by selecting the Help button in
the current dialog.



Getting started

This help topic is displayed automatically the first time you start Kith and Kin. To come back to
this topic in future sessions use Help|Getting started from the main menu.

This help file is a complete on-line manual for Kith and Kin. As well as providing context-
sensitive help direct from Kith and Kin, it contains all the technical information about the
program and details on how to register in an easy-to-use format. If you wish to print out the
entire help file a text version suitable for printing is contained in the file KITHKIN.TXT.

Help

If you are not familiar with using Windows help files, read the 'help on help' information. Do this
by clicking the left mouse button on 'Help' in the menu above and then on 'How to Use Help' in
the pull-down menu.

You can get help by either selecting Help|Contents from the main menu or by pressing F1. You
can also get specific help on whatever task you are carrying out by selecting the Help button in
the current dialog.

Basics

Introducing Kith and Kin

Opening an existing tree

Creating a new tree



Introducing Kith and Kin

Kith and Kin is a software package for documenting and storing family trees which has been
specially designed for the MS-Windows operating system. It features an easy to use graphical
interface and powerful multi-level editing tools which makes it ideal for both large and small
trees.

The program supports date and place of births, baptisms, deaths, burials, marriages and divorces
as well as multiple marriages and aliases for each person. Each person has two user defined
fields which could be used for occupation, cause of death or any other suitable data. People and
families may have notes added as well as pictures, diagrams, sounds, etc (known as objects) via
Windows OLE.

The information which you enter into Kith and Kin is organised into families. The main screen is a
window into a tree area which displays each family as a rectangle. Relationships between families
are shown by parent lines. Using the mouse, you can drag and p05|t|on the family rectangles
within the tree area to form any tree layout you desire. You can zoom in and out of the tree to
give you an overview of the entire tree layout.

Once the tree has been built up, the family rectangles can be used for direct access to data by
double-clicking on the required family. You can then move through the tree by selecting people
and families from within the family and person data. This makes it very easy to follow a particular
route through the tree whilst examining, updating or even adding data.

Navigating the tree on the screen is made easier by automatically highlighting related families.
You select whether you want to choose all families descended from a particular root family, all

families containing ancestors of the root or just families which form a direct line between two
families.

Kith and Kin lets you see a timeline which displays the events associated with selected families
interspersed with notable historic events. These events can be edited and added to using the
TimeGen utility (supplied free with registered versions of Kith and Kin).

A printed book can be produced with family group details (which may incorporate pictures and
diagrams) and a complete, cross-referenced index to names and families. You have control over
the formatting and extent of all printed reports which also include person details, tree layout,
descendant and ancestral trees, indented tree, timeline, census report and missing data report.

International users can modify date descriptors and all the text used when printing reports. This
means that Kith and Kin will print reports (and display most data) in any language.

Compatibility with "Personal Ancestral File" GEDCOM files means you can export and import data
to and from other genealogy programs. You can also use this feature to prepare extracts from
tree files.

Kith and Kin will export text files which you can then use in other programs such as databases or
spreadsheets.



Opening an existing tree

A sample tree file has been provided which demonstrates a typical family tree. This file is named
SAMPLE.TRE and it should reside in the same directory as Kith and Kin (KITHKIN.EXE).

To open this tree click on the file open button in the button bar just below the main menu.
You will now see a file selection dialog. There are three different ways in which you can select
SAMPLE.TRE as follows.

1) You can type in SAMPLE.TRE in the Filename field and press the <ENTER> key or click on
the OK button.

2) You can click on SAMPLE.TRE in the Files list with the left mouse button and then click on
the OK button or press the <ENTER> key.

3) You can double-click the left mouse button on SAMPLE.TRE in the Files list.

If SAMPLE.TRE does not appear in the Files list, it may not have been copied from your release
disk into the Kith and Kin directory.

The sample tree file will then be opened and displayed on your screen.

Experiment with the PageUp, PageDown, Tab, arrow keys and the Home key which all move the
main window to a new part of the tree area. See Keyboard for explanations of what each key
does.

Try dragging a family rectangle to a new position by putting the cursor arrow over any family
rectangle and then pressing and holding the left mouse button. You will see the cursor change to

+ indicating that you can now reposition the family rectangle. While still holding the mouse
button down, move the mouse and you will see a rectangular outline move about the screen.
When you have moved this outline to the desired position, release the mouse button. The family
rectangle will now move to the new position. You can also drag more than one family at a time by
following the same procedure but with the Shift key held down each time you click on a family
rectangle. You can also select more than one family at a time by dragging with the left mouse
button not on any family. You will see a dotted marquee expand as you drag the mouse. When
the marquee has enclosed the required families release the mouse button to select them.

You can display a summary of a particular family by putting the cursor arrow over the family
rectangle and then holding down the right mouse button.

Now try zooming out so that you can see more of the tree by clicking on the @ zoom out button
in the button bar. As you continue to zoom out, notice that the text and people icons disappear.
This makes the display faster and you can set the magnification at which the details disappear in
Options|Preferences. All the normal functions can still be used when your have zoomed out. To
return to normal viewing click on the

zoom in button or press Ctrl+N.

Open the timeline window by clicking on the @ timeline button. Now click on family [F149] to
select it. In the timeline window will appear all the events associated with people in family [F149]
as well as some famous events of the period. Carefully click on the line which reads "10 Dec 1810
: [P423] Robert HUNTER born at Clackmannan". The line turns red to indicate that you have
selected it and notice that two other lines also turn red (you can find the last one by using the
scroll bar). This feature allows you to find quickly in the timeline window all events associated
with a particular person. To hide the timeline window again click on the

timeline button.

If you forget what a button in the button bar does, simply hold down the left mouse button over
the required button without releasing it. At the bottom of the screen the function of the button is



displayed. Slide the cursor off the button and release the mouse button.

To examine or modify a particular family's data, you can double-click the left mouse button on a
family rectangle. This will open a Family Data dialog which will allow you to edit this family's data.

A sample object (a Paintbrush Picture) has been embedded in family [F118]. Open the object list
by selecting the Objects button in the Family Data dialog. You can then examine the photo by
double clicking the left mouse button on it or selecting the photo in the list and then selecting
"Edit Paintbrush Picture Object" from the menu (by clicking on the minus sign in the top left of the
dialog). Note that the colour resolution of the photo is not high, because the number of colours
has been reduced to 4 to ensure compatibility with Paintbrush. If an error occurs, it may be that
Windows Paintbrush has not been set-up correctly on your computer.

You can examine or edit the data associated with the parents and children of this family by
selecting the appropriate edit button for parents or double-clicking on a child in the Children list.
This will open a Person Data dialog which will allow you to edit this person's data.




Creating a new tree

When you first start Kith and Kin you will be presented with a blank tree area. If you have been
looking at SAMPLE.TRE select New from the File menu to clear the tree.

Create your first family by selecting Add new family from the Edit menu or press Ctrl+F6. This will
bring up a family data dialog in which you may enter the details for this family. The only fields
which may be entered directly in this particular dialog are the marriage details of the parents. Do
this first if you are going to use them (remember all text edit fields are optional).

Next add the father by selecting the father add button (this action both adds a new person to the
tree and identifies him as the father of this family).

This will bring up a person data dialog in which you may enter the details for the father. To add
the family of which the father is a child select the child of family add button. This will again bring
up a family data dialog and details may be entered as above.

Multiple dialogs may be opened like this up to a maximum of six. Exit each dialog in turn by
selecting the Ok or Cancel button.

When all family data and person data dialogs have been closed any new families must be placed

4
on the tree area. This is indicated by the cursor changing to “1”. Move the cursor to the required
position and click the left mouse button. All new families will be displayed as family rectangles.
Note that whenever the cursor is this "inwards arrows" shape, you must click the left mouse
button to place the families before you can do anything else. Don't worry if the families are
placed in the wrong position, you can always move them afterwards.

Save your new family tree by selecting Save as from the file menu.



Edit menu

Either From the menu bar select Edit.
or Press AIt+E.

Menu items

Add new family
Add new person
Edit person
Edit family
Delete person
Delete family
Person notes
Family notes
Person objects
Family objects
Re-use code
Select families
Select all




Options menu

Either From the menu bar select Options.
or Press Alt+0.

Menu items

Startup file
Startup family
Page setup
Fonts

Snap to grid

Date error setup
Preferences




Search menu

Either From the menu bar select Search.
or Press Alt+S.

Menu items

Text search
Date search
People in limbo
On this day
Date errors

Go to family




View menu

Either From the menu bar select View.
or Press Alt+V.

Menu items

Statistics

Relationshi
Timeline window




File menu
Either From the menu bar select File.
or Press AlIt+F.

Menu items

New




Starting a new family tree

From the File menu select New.

This will first check to see if the current tree needs to be saved and then clear the tree.



Using the file selection dialog

The file selection dialog is displayed in response to various events in Kith and Kin. The dialog
allows you to choose an existing file or assign a filename to a new file.

Ensure that the Directory name is correct. The Files list only shows files of the selected type
within the current directory. It may sometimes be necessary to move to another drive or
directory, either to find the file you are looking for or to ensure that a new file is written in the
correct drive or directory. To select a different drive double-click on the drive letter in the
Directories list (eg. [-a-]1). To move through the directory structure double-click on a directory
name (eg. [kithkin]) to move down a level, or on [..] to move back a level. The Directory name
will change to show the current directory.

File|Open or Options|StartupFile:

Select the type of file to open, Kith and Kin tree (.TRE) or GEDCOM (.GED). Select the required file
from the available files list. In the case of a GEDCOM File|Open, a GEDCOM import dialog will then
open.

File|Save as:

Select the type of file to save, Kith and Kin tree (.TRE), GEDCOM (.GED) or Text (.TXT). Enter the
required file name in the Filename box ensuring that the "*" has been deleted and select the Ok
button. It is not necessary to enter the file extension (eg .TRE) as this is derived from the File
Type selection. In the case of a GEDCOM File|SaveAs, a GEDCOM export dialog will open. In the
case of a Text file a Delimited Text File dialog will open.

Export reports to text file:

Some reports can be sent to a text file instead of the printer. Enter the required file name in the
Filename box ensuring that the "*" has been deleted and select the Ok button. It is not necessary
to enter the file extension (ie .TXT) as this is derived from the File Type selection. Only .TXT file
types can be written.



Saving a family tree

Either From the File menu select Save.
or Press F2.

or Click on the lﬂ file save button in the button bar.

The tree will be saved with the name of the file shown in the main window title. If the tree has no
current filename the command will act as if Save As had been used.



Opening a family tree
Either From the File menu select Open.
or Click on the file open button in the button bar.

This will first check to see if the current tree needs to be saved and then bring up a file selection
dialog.

Use File|Open for loading Kith and Kin tree files (.TRE) and importing GEDCOM files (.GED).




Saving a tree with a different name or format

From the File menu select Save as.

This will bring up a file selection dialog.

Use File|SaveAs for saving Kith and Kin tree files (.TRE), exporting GEDCOM files (.GED) and
delimited text files (.TXT). If you save a Kith and Kin tree file with File|SaveAs, the name of the
current tree will be changed to the saved filename.




Opening a family tree automatically
From the Options menu select Startup file.

This will bring up the file selection dialog. You may select an existing file or enter a new file name.
The program will attempt to load the tree automatically each time the program is started unless
the program is launched from a tree file in the File Manager (you have to associate .TRE files with
KITHKIN.EXE to do this, using File|Associate in the Windows File Manager).



Positioning the tree area window automatically

From the Options menu select Startup family.
Selecting the Change button will bring up the Select Dialog. You may select any family in the
current tree. The program will attempt to move the tree area window to that family automatically

each time the current tree file is opened. If no family is selected the window will start in the upper
left corner of the tree area.

The tree area will be scrolled to this family each time the HOME key is pressed.



Importing a GEDCOM file

Either From the File menu select Open.
or Click on the file open button in the button bar.

then select GEDCOM from the file type list in the file selection dialog.

When you have selected the required file and the Ok button, you will be given the choice of
various options for importing a GEDCOM file, as follows.

Create new tree:

The current tree (if any) will be closed and the imported data will form the basis of a new tree,
untitled.

Import into current tree:

The current tree (if any) is retained and the imported data is added to it.

Store extra data in notes:

"Extra data", is GEDCOM data which Kith and Kin recognises, but has no specific field for. By
setting this option any extra data will be added to the appropriate set of notes. See Supported
GEDCOM data for a list of recognised extra data.

List extra data in GEDERR.TXT:
By setting this option any extra data will be added to the GEDCOM import error log, GEDERR.TXT.

Convert invalid dates to text:

By setting this option any dates encountered which are invalid (eg. they do not conform to the
GEDCOM standard date format DD MMM YYYY) are imported but are converted to date phrases.

Display file header and submitter:

The GEDCOM file header and any submitter information will be displayed as it is read from the
file.

IBM (DOS) character set code page:

GEDCOM files created with the IBMPC character set (usually from a DOS program) may have been
written using one of the alternative DOS code pages. These pages are generally used in non-
English speaking countries and contain extra characters such as "A" to cover the additional
diacritics used in their language.

You can select one of the following code pages and Kith and Kin will convert the incoming extra
characters into the appropriate ANSI characters for use in Windows. If you are in doubt about
which code page was used to create the GEDCOM file, assume it was 437 English.

Code pages supported:
437 English
850 Latin |
860 Portuguese
863 Canadian-French
865 Nordic



If the program encounters the end of a GEDCOM file before finding the TRLR record, it assumes
that the file has been split over more than one disk (or file). You will be prompted to insert the
disk containing the next file in sequence. GEDCOM files split into several files are named
<filename>.GED, <filename>.G00, <filename>.G01, etc, where <filename>.GED is the filename
specified for input in the file selection dialog.

Errors encountered during a GEDCOM import are always reported in GEDERR.TXT and you can
optionally open this file using Windows Notepad after the import.

See also: Known incompatibilities




Exporting a GEDCOM file

From the File menu select Save as then select GEDCOM from the file type list in the file selection
dialog.

When you have entered the filename and selected the Ok button, you will be given the choice of
various options for exporting a GEDCOM file, as follows.

All families:
Set this option to export all people and families from the current tree.

Selected families:

Export only the currently highlighted families and the people who appear in them by setting this
option.

One person:
A select dialog will open with which to select a single person for exporting.

Kith and Kin specific data:

If you are creating a GEDCOM file which will be used to transfer data to another program you
should ensure that this option is off. Many programs which should ignore the extra data which
Kith and Kin generates do not. This option must be on if you intend to use the GEDCOM file for
loading into Kith and Kin later.

Include objects:

If you want the GEDCOM file to include the objects associated with the people or families you are
exporting, set this option. Objects exported in this way can only be imported by Kith and Kin V2.0
or later, and will produce a very large amount of output.

External notes:

If you want the GEDCOM file to include notes from external files linked to the people/families
which are being exported, set this option.

If the "Kith and Kin specific data" option is set, the GEDCOM file will also contain the filenames of
the external notes files. Note that importing a GEDCOM file which was exported from Kith and Kin
with both these options set will not import the notes from the external files, only the filenames.
You must supply all the relevant external notes files as well as the GEDCOM file in order to import
all notes successfully into Kith and Kin.

Output character set:

Kith and Kin will produce GEDCOM files using either the Windows ANSI or ANSEL sets. The ANSEL
set is more appropriate for non-English languages and should also be used to comply with
GEDCOM V5.5. However, Windows ANSI is normally used for transferring data to most other
Windows programs.

Submitter information:

If you want to include your name, address, phone number and any comments relevant to the
particular GEDCOM file, enter them here. They will be output as part of the SUBM record. If all
four fields are empty, no SUBM record will be output.



If the GEDCOM file becomes too big for the disk it is being written to, the program will prompt you
to insert another blank disk and will repeat this as necessary until the entire file has been written.
Subsequent files will be named <filename>.G00, <filename>.G01, etc, where <filename>.GED is

the filename specified for output in the file selection dialog.



Exporting a delimited text file

From the File menu select Save as then select Text from the file type list in the file selection
dialog.

When you have entered the filename and selected the Ok button, you will be given the choice of
various options for exporting a delimited text file.

A delimited text file is useful for exporting data from Kith and Kin to other applications such as a
database or spreadsheet program. Once the data is in a database, for instance, you can produce
customised list reports.

A delimited text file is a standard ASCII text file which has a separate data record (for instance all
the data for a single person) on each line. Each field in a record is separated from the next by a
delimiting character (or field delimiter).

Families to export:

All prints every family, Selection prints all families which are currently highlighted, Range
prints all families which fall inside the range of code numbers specified in From and To.

Person record:

Select the fields which you want included in a person record by clicking on each check box. As
you select each field a number appears beside it. This number indicates the order in which the
fields will be placed in the person record. If you want to change the field order either click on the
Clear Fields button to start again, or click on a field which is already selected to deselect it. If no
fields are selected person records will not be exported.

Family record:

Select the fields which you want included in a family record in the same way as the Person record
above. Depending on the application you intend to transfer the data to, it may not be appropriate
to mix people and family records in the same text file. You may have to export people to one file
and families to another.

Field delimiter.

Select the character to use as the separator between fields. Tab, semicolon and comma are
pre-defined or you may enter another character in the Other box.

Use quotes:

You can make Kith and Kin enclose each field in quotes. This makes doubly sure that characters in
the data will not be regarded as field delimiters by accident (eg. you can have commas in your
data and use a comma as the field delimiter). Whether you use quotes or not depends on the
application you intend to transfer the data to since they are normally stripped out by the
receiving application. If your data contains quotes, Kith and Kin will double-up any quotes it finds.
Doubled-up quotes are normally reduced to a single quote by the receiving application.



Adding a person

Either From the Edit menu select Add new person.

or Press Ctrl+F5.

or New people are also added as a result of selecting the add button of a Child, Father or
Mother in a Family Data Dialog.

Any of these actions will bring up a Person Data Dialog.

See also: Re-using codes
See also: Database limits




Editing a person

Either From the Edit menu select Edit person. A Select Dialog will be displayed.
or Press F5. A Select Dialog will be displayed.

or Click on the |II edit person button in the button bar. A Select Dialog will be displayed.
or Select the edit button of a Child, Father or Mother in a Family Data Dialog.
or Double-click the left mouse button on a Child in a Family Data Dialog.

Any of these actions will bring up a Person Data Dialog.



Deleting a person

From the Edit menu select Delete person.

This will bring up a Select Dialog with which to select the person to be deleted. Selecting Ok will
immediately and irrevocably delete the person from the tree.



Adding and editing a person's notes

Either From the Edit menu select Person notes. This will bring up a Select Dialog from which to
select the appropriate person.

or Press Shift+F5. This will bring up a Select Dialog from which to select the appropriate
person.
or Select the notes button in a Person Data Dialog.

A Notes Dialog will then open in which to edit notes and maintain external notes files.

See also: Editing notes



Adding and editing a person's objects

Either From the Edit menu select Person objects. This will bring up a Select Dialog from which
to select the appropriate person.

or Press Alt+F5. This will bring up a Select Dialog from which to select the appropriate
person.

or Select the objects button in a Person Data Dialog.

An Objects Dialog will then open in which to edit the objects.

See also: Working with objects




Setting user-defined field descriptions
See: Setting preferences



Adding a family

Either From the Edit menu select Add new family.

or Press Ctrl+F6.

or New families are also added as a result of selecting the add button of a Marriage or a
Child of Family in a Person Data Dialog.

Any of these actions will bring up a Family Data Dialog.

1

Following the addition of a new family the cursor will change to 71", This indicates that the new
family rectangle(s) must be placed on the tree area. Move the cursor to the desired position and
click the left mouse button to place the families.

If you want to place the new family on part of the tree area which is not currently visible, move
the cursor to the edge of the window in the direction in which you want to move (eg. if you want
to place the family to the right of the currently displayed area, move the cursor up against the
right hand edge of the window). The window will scroll in small increments. You can scroll the
window in larger increments by holding down the CTRL key.

You can also scroll the window using the PageUp, PageDn, Tab, Home and cursor keys.

See also: Re-using codes
See also: Database limits




Editing a family
Either From the Edit menu select Edit family. If a single family is currently highlighted then that

or

or

or
or
or

family will be selected for editing otherwise a Select Dialog will be displayed.
Press F6. If a single family is currently highlighted then that family will be selected for
editing otherwise a Select Dialog will be displayed.

Click on the |E[ edit family button in the button bar. If a single family is currently
highlighted then that family will be selected for editing otherwise a Select Dialog will be
displayed.

Double-click the left mouse button on a family rectangle.

Select the edit button of a Marriage or a Child of Family in a Person Data Dialog.
Double-click the left mouse button on a Marriage in a Person Data Dialog.

Any of these actions will bring up a Family Data Dialog.



Deleting a family
From the Edit menu select Delete family.

If a single family is currently highlighted then that family will be immediately deleted otherwise a
Select Dialog will be displayed. Selecting Ok will immediately and irrevocably delete the family
from the tree.



Adding and editing a family's notes

Either From the Edit menu select Family notes. If a single family is currently highlighted then
the notes associated with that family will be selected for editing otherwise a Select Dialog
will be displayed.

or Press Shift+F®6. If a single family is currently highlighted then the notes associated with
that family will be selected for editing otherwise a Select Dialog will be displayed.

or Select the notes button in a Family Data Dialog.

A Notes Dialog will then open in which to edit notes and maintain external notes files.

See also: Editing notes



Adding and editing a family's objects

Either From the Edit menu select Family objects. If a single family is currently highlighted then
the objects associated with that family will be selected for editing otherwise a Select
Dialog will be displayed.

or Press Alt+F6. If a single family is currently highlighted then the objects associated with
that family will be selected for editing otherwise a Select Dialog will be displayed.

or Select the objects button in a Family Data Dialog.

An Objects Dialog will then open in which to edit the objects.

See also: Working with objects




Printing family details

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Family details from the Print Selection Dialog.

This will bring up the Print Family Details Dialog which will print one or more family group sheets
based on the selection of the following options. The fonts used will be those previously selected

using Options|Fonts.
All / Selection / Range:

Only one of these options may be selected. All prints every family, Selection prints all families
which are currently highlighted, Range prints all families which fall inside the range of code
numbers specified in From and To.

The following fields specify what details to include in the printout. One or more may be set.
Include person codes:

A person code will be printed beside the name of each person.

Include aliases:
Aliases will be included in places where a person's details are being printed.

Details everywhere:

A person's details will be printed wherever that person's name appears. If not set then the details
are only printed where the person appears as a child or, if the person has no child of family, then
wherever the person's name appears.

Export to text file:

This report may be sent to a text file instead of the printer. A File Selection Dialog will open where
you should enter the filename to be used for the text file. The default filename is PRINT.TXT. This
file may be then be used by a text editor or word processor. Objects are not included in a text file.




Printing person details

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Person details from the Print Selection Dialog.

This will bring up the Print Person Details Dialog which will print one or more person's details
based on the selection of the following options. The fonts used will be those previously selected

using Options|Fonts.
All / Selection / Range:

Only one of these options may be selected. All prints every person, Selection brings up a
Selection Dialog with which you may select a single person to print, Range prints all people
which fall inside the range of code numbers specified in From and To.

The following fields specify what details to include in the printout. One or more may be set.
Include person codes:

A person code will be printed beside the name of each person.

Include aliases:
Aliases will be included for the selected person(s).

Export to text file:

This report may be sent to a text file instead of the printer. A File Selection Dialog will open where
you should enter the filename to be used for the text file. The default filename is PRINT.TXT. This
file may be then be used by a text editor or word processor. Objects are not included in a text file.



Printing an index

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Index from the Print Selection Dialog.

This will bring up the Print Index Dialog which will print a family and/or person index for the
current tree based on the selection of the following options. The fonts used will be those

previously selected using Options|Fonts.

Sort:

Select either By name or By code. "By name" produces an alphabetic index sorted on the
surname and firstnames of each person or father of a family. A "By Code" index is sorted on the
code of each person or family.

Family index:
If set then an index to families will be printed.

The following fields specify what details to include in the family index. One or more may be set.

Person codes:
A person code will be printed beside the name of each person.

Marriage details:
The date and place of marriage will be included.

Person index:

If set then an index to people will be printed.

The following fields specify what details to include in the person index. One or more may be set.

Person codes:
A person code will be printed beside the name of each person.

Birth details:
The date and place of birth will be included.

Death details:
The date and place of death will be included.

Aliases:
Index entries will be generated for each alias of a person.

Export to text file:

This report may be sent to a text file instead of the printer. A File Selection Dialog will open where
you should enter the filename to be used for the text file. The default filename is PRINT.TXT. This
file may be then be used by a text editor or word processor. Objects are not included in a text file.




Printing the tree layout

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Tree layout from the Print Selection Dialog.

This will bring up the Print Tree Dialog which will print the entire tree area based on the selection
of the following options. The fonts used will be those previously selected using Options|Fonts.

Families:
Select All to print entire tree or Selection to print only the currently selected families.

Family code:
If set then the family code will be printed in each rectangle.

Marriage details:
If set then the marriage date and place will be printed in each rectangle.

Children icons:
If set then people icons representing children will be printed in each rectangle.

Text line spacing:

Enter a decimal number to indicate any deviation from the standard line spacing eg:

1 = use standard line spacing,
0.5 = reduce the line spacing to half of standard,

2 = increase line spacing to double spaced.

Female lines dotted:

If set then dotted lines will be used to represent female links. Solid lines as used for male links
will be used if not set.

Label format:

Only one of the following options may be selected to indicate the format of each rectangle label.

Father's surname:

Only the father's surname will be printed.

Father's and mother's surname:

Father's and mother's surname will be printed.

Father's and mother's full names:
The full names of both father and mother will be printed.
Print ? pages wide by ? tall:

By default, Kith and Kin will squeeze the entire tree onto a single page. If you want to print the
tree over several pages and join them together afterwards, enter suitable numbers here.

Keep aspect ratio:



If this option is set, Kith and Kin will print the entire tree keeping the width to height ratio the
same as it appears on the screen, in other words the overall shape of the tree will not change. If
you want to make the tree fill the page (or pages, see above) with no wasted space at top,
bottom or either side, turn this option off.



Printing an indented descendant tree

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Indented tree from the Print Selection Dialog.

This will bring up a Select Dialog with which to select the person to base the printout on. You will
then see the Print Indented Tree Dialog which will allow you to print a descendant tree based on
the following options. The fonts used will be those previously selected using Options|Fonts.
Report title:

You may enter any text to be printed at the top of the printout. The default is the name of the
root person.

The printout may include one or more of the following:

Codes:

Person and family codes are printed beside the name of the person or family.

Birth/baptism date:

Include the birth or (if no birth) baptism date for a person.

Death/burial date:
Include the death or (if no death) burial date for a person.

Marriage/div. date:
Include the marriage or (if no marriage) divorce date for a family.

Places:
Include the places for any of the above dates.

Generation nos.:

Print the number of generations that the current person is from the root person, against the left
margin.

Expand to ? generations:

If this figure is 0, the printout will include every descendant of the selected person. However,
large trees may produce printouts which are impossible to fit onto a single page. You may limit
how many generations the report will cover by changing this entry. For example, 2 generations of
descendants will produce the selected person, his children and his grandchildren.

Export to text file:

This report may be sent to a text file instead of the printer. A File Selection Dialog will open where
you should enter the filename to be used for the text file. The default filename is PRINT.TXT. This
file may be then be used by a text editor or word processor.

See also: Printing a person's descendants



Printing a person's descendants

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Descendant tree from the Print Selection Dialog.

This will bring up a Select Dialog with which to select the person to base the printout on. The
printout will be based on the options selected from the Print Descendants Dialog and the fonts
used will be those specified in Options|Fonts.

This printout will consist of a tree with the selected person at the top and all of his directly related
(blood) descendants and spouses below. The tree tends to be wide rather than long so use a
small font and print landscaped.

See also: Options for descendant and ancestral tree prints
See also: Printing an indented descendant tree



Printing a person's ancestors

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Ancestral tree from the Print Selection Dialog.

This will bring up a Select Dialog with which to select the person to base the printout on. The
printout will be based on the options selected from the Print Ancestors Dialog and the fonts used
will be those specified in Options|Fonts.

This printout will consist of a tree with the selected person at the bottom and all of his directly
related (blood) ancestors above. The tree tends to be wide rather than long so use a small font

and print Jlandscaped.

See also: Options for descendant and ancestral tree prints



Options for descendant & ancestral tree prints
Report title:

You may enter any text to be printed at the top of the printout. The default is the name of the
root person.

The printout may include one or more of the following:

Codes:
Person and family codes are printed beside the name of the person or family.

Child surnames:

The surname for every child is included. If not set, the surnames can still be determined from the
surname of the father of each family.

Birth details / Baptism details / Death details / Burial details:
Each of these dates and places associated with a person may also be included.

User defined fields:

Data from each field may be included in the printout. If there are no descriptions for these fields
in Options|Preferences then the check box labels will be blank.

Marriage details / Divorce details:

Each of these dates and places associated with a family may also be included. Note that these
details are not printed on an Ancestral Tree.
The following options may also be set:

Wrap surnames:

In order to save horizontal space, the surnames may be printed below the firstnames of each
person by setting this option.

Inside margins:

Trees which are too large to fit on a single page will be split onto multiple pages. When this option
is set, each page will have margins as defined in page setup. When this option is not set, margins
which would be along the "joins" of the printout will be set to zero. This is particularly useful when
printing a large tree landscape on continuous paper. If you find that data is missing from the
edges of your printout, particularly on page (laser) printers, try setting Inside Margins and
increasing the margin values until all the data is visible. A degree of overlapping text is printed to
make it easier to paste together adjoining sheets.

Expand to ? generations:

If this figure is 0, the printout will include every descendant or ancestor of the selected person.
However, large trees may produce printouts which are impossible to fit onto a single page. You
may limit how many generations the report will cover by changing this entry. For example, 2
generations of descendants will produce the selected person, his children and his grandchildren.



Printing a timeline

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Timeline from the Print Selection Dialog.

This will bring up the Print Timeline Dialog which will print a timeline report based on the
selection of the following options. The fonts used will be those previously selected using Options
Fonts.

Families:

Only one of these options may be selected. All prints every family, Selection prints all families
which are currently highlighted, Range prints all families which fall inside the range of code
numbers specified in From and To.

Dates:

Only one of these options may be selected. All makes every available date valid, Within
families only includes dates from the earliest date in the families selection above minus one
year to the latest date plus one year, Range includes dates which fall inside the range of dates
specified in From and To.

Report title:

You may enter any title to be printed at the top of the report. The default is "Timeline".

Include codes:
Person and family codes will be included in the report.

Include events:
Events from TIMELINE.TML between the selected dates above will be added to the report.

Export to text file:

This report may be sent to a text file instead of the printer. A File Selection Dialog will open where
you should enter the filename to be used for the text file. The default filename is PRINT.TXT. This
file may be then be used by a text editor or word processor. Objects are not included in a text file.




Printing a census report

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Census report from the Print Selection Dialog.

This will bring up the Print Census Dialog which will print one or more family group sheets based
on the selection of the following options. The fonts used will be those previously selected using

Options|Fonts.
All / Selection / Range:

Only one of these options may be selected. All prints every family, Selection prints all families
which are currently highlighted, Range prints all families which fall inside the range of code
numbers specified in From and To.

Date:

Enter the date of the census or other event. Kith and Kin will print family details for each family
selected above which apply on this date. For example, if only two children in a five children family
were born on or before the census date then only those two children will appear on the family
sheet.

The following fields specify options for the printout. One or more may be set.

Include person codes:
A person code will be printed beside the name of each person.

Include aliases:
Aliases will be included in places where a person's details are being printed.

Notes:
Include person and family notes.

Family per page:
Start each family on a new page.

Export to text file:

This report may be sent to a text file instead of the printer. A File Selection Dialog will open where
you should enter the filename to be used for the text file. The default filename is PRINT.TXT. This
file may be then be used by a text editor or word processor. Objects are not included in a text file.



Printing a missing data report

Either From the File menu select Print.
or Click on the print button in the button bar.

Then select Missing data report from the Print Selection Dialog.

This will bring up the Missing Data Report Dialog which will print a list of people or families which
have no data in selected fields. The fonts used will be those previously selected using Options
Fonts.

Person fields:

Select one or more fields from the list. Each field selected will be included in the search. If any of
the selected fields have no data for a particular person, that person is included in the report.
Family fields:

Select one or more fields from the list. Each field selected will be included in the search. If any of
the selected fields have no data for a particular family, that family is included in the report.
Export to text file:

This report may be sent to a text file instead of the printer. A File Selection Dialog will open where
you should enter the filename to be used for the text file. The default filename is PRINT.TXT. This
file may be then be used by a text editor or word processor.



Choosing fonts
From the Options menu select Fonts.

This will bring up the Fonts Dialog from which the fonts for various features of printed documents
and screen items may be set.

First select the Printer or Screen check box to display the appropriate font list.

Select a feature to change from the list and a sample of the currently selected font will appear in
the Sample Window. Selecting the Change button or double-clicking on the feature in the list will
bring up a standard font selection dialog. You can then change the typeface, style, size, effects
and colour of the font. Note that you are not limited to using the listed font sizes.

Printer fonts:

Desc/Anc tree : Title
The report title will be printed using this font in Descendant and Ancestral trees.

Desc/Anc tree : Names
The names of each person will be printed using this font in Descendant and Ancestral trees.

Desc/Anc tree : Details
Details such as date and place of birth and all other information is printed in this font in
Descendant and Ancestral trees.

Details/Census : Title
The surname of the family unit or person's hame which appears at the top of the page in
Family/Person and Census reports.

Details/Census : Code
The code number which appears in the top right corner in Family/Person and Census reports.

Details/Census : Headings
For family details the headings are "Parents", "Children" and "Family in Family/Person and Census
reports".

Details/Census : Names
The line containing the name of each parent and child in Family/Person and Census reports.

Details/Census : Notes
The text of notes and details in Family/Person and Census reports.

Indent tree : Title
Title line for the indented descendant tree printout.

Indent tree : Text
The text of the indented descendant tree printout.

Index : Title
The title for each index is either "Index to People" or "Index to Families".

Index : Text
The text of the index entries.

Timeline : Title
The title for a printed timeline.



Timeline : Text
The font used for dated events from the tree data in a printed timeline.

Timeline : Events
The font used for historical events taken from the TIMELINE.TML file in a printed timeline.

Missing data : Title
Title line for the missing data report.

Missing data : Text
The text of the missing data report.

Revision footer
In all printed documents a revision date is optionally printed at the bottom of each page. See
Formatting the page for details on how to modify the footer.

Tree layout : Text
All the text on the tree document will be printed using this font.
Screen fonts:

Family rectangle text
The font used for code and surnames within the family rectangles on the screen.

Family summary text
The font used for displaying a family summary (in response to a right mouse click) on the screen.

Timeline : Normal
The normal text within the timeline window.

Timeline : Highlight
The text within the timeline window which has been selected by clicking on it.

Timeline : Event
The text of historical events within the timeline window taken from the TIMELINE.TML file.



Formatting the page
From the Options menu select Page setup.

The page setup dialog allows you to format various features of the layout of all printed
documents.

Margins

Enter the measurement for each of the page margins. The unit of measure may be either inches
or millimetres. Note that problems with printouts may be encountered when setting small
margins. The printer you are using may have a non-printing area around the edge of the physical
page and this may lead to missing or garbled print. If you have problems like this, try increasing
the size of the margins.

Revision Footer

Set Include to print a revision date footer on every page of each printed document. It is useful to
have the current date printed on each report, particularly when the tree data is constantly being
updated and only updated sections are being reprinted. The footer is printed just below the
bottom margin and takes the following format: <document> <text> <date>

<document> is dependant on the type of document being printed, eg. "Tree", "Index", etc.

<text> is user defined text which may be entered in the Text field.

<date> is the current date and is formatted the style selected for date output format in
Options|Preferences.

eg. On the Family Details document for family F56, the current date is 5th September 1992
formatted DD-MM-YYYY and the text field is "Revision:", the following footer is printed: "[F56]
Revision: 5-9-1992"



Viewing a printout on the screen

Any report may be viewed on the screen instead of being sent to the printer. When Kith and Kin is
displaying a print preview the normal Tree Area display is hidden.

From the File menu select Print preview then select the required report from the Print Selection

Dialog.
The print preview window displays the printout a page at a time.

The following controls are available:

et
E Display the next page of the printout. This button becomes disabled when the end of the
printout has been reached.

a2z | Wiew
Page

Display the whole of the current page. This button is enabled when you have zoomed
into the page.

You can zoom into a specific area on the current page by dragging a marquee around the area of
the page. As you release the mouse button Kith and Kin displays the selected area magnified to
fill the screen.

To cancel the print preview either during or at the end of the printout, click on the Cancel button.
Kith and Kin returns to the normal tree area display.



Setting up or choosing the printer
From the File menu select Print setup.
This will display a list of available printers. Select the required printer and if you want to change

the settings for that printer (paper size, orientation etc), select the setup button to open the
printer driver's setup dialog.

See Windows or your printer driver documentation for further details of the setup dialog for
particular printers.



Positioning the tree area window

Either From the Search menu select Go to family.

or Press F9.
or Use PageUp, PageDn, Tab, Home or the cursor keys.
or Use the scroll bars along the right and bottom edges of the window to move the window

around the tree area.

Selecting Go to family or F9 will bring up a Select Dialog with which to select the family to move
to. The tree area window will then display a new area of the tree with the selected family in the
centre.

If you want to scroll the tree area window while repositioning or placing families, move the cursor
right up to the edge of the window. The window will scroll in small increments and you can scroll
in larger jumps by holding down the Ctrl key.



Choosing screen fonts
See: Choosing fonts



Using the timeline window

You can display or hide the Timeline Window by using the Timeline command in the View menu

or by clicking on the @ timeline button in the button bar. You can also hide the Timeline
Window by selecting the Hide command in its system menu.

The Timeline Window shows chronologically sorted dates from two sources. (a) it shows the
date/place of marriage and divorce of all the currently selected families as well as the date/place
of birth, baptism, death and burial of all the people associated with those families, ie. parents and
children. (b) the window shows historical events taken from the TIMELINE.TML file between the
earliest (a) date less one year and the most recent (a) date plus one year. Data from the
TIMELINE.TML can be excluded by using the "Include timeline file" option in Options|Preferences.

You can select new families whilst the Timeline Window is displayed and Kith and Kin will
automatically update the window. You can also resize the window in the normal manner.

You can highlight all the dates in the Timeline Window associated with a particular person by
clicking on any line in the Window which contains that person. So to highlight the birth, baptism,
marriage and death dates of Thomas GORDON you could click on "23 Sep 1810 : [P407] Thomas
GORDON baptised at Kinross". To change the highlight to another person simply click on someone
else's entry. You can clear the highlighting by clicking the right mouse button anywhere in the
Timeline Window.

The Timeline Window uses the fonts selected in Options|Fonts.

Registered users of Kith and Kin can modify the contents of TIMELINE.TML by using the TimeGen
utility. See the TimeGen help file for details.



Selecting families

F147

GORIMH = SCOTLAND

Family rectangles are displayed on the screen like this

Several operations require that you select one or more families so that they are highlighted like
F
. |coRDon = scoTLAND
this !

To highlight a single family rectangle click the left mouse button on it. To highlight several family
rectangles at once hold down the Shift key while clicking the left mouse button on each family
rectangle in turn. You can also select several families by dragging a marquee around them. Do
this by holding the left mouse button not on a family rectangle and then dragging. A dashed
rectangle will appear and should be positioned around the required families before releasing the
mouse button. The marquee can be used in conjunction with the Shift key to add more
selections.

Highlighted family rectangles may be moved around the tree area by dragging the outlines to a
new position. If you want to scroll the tree area window while repositioning families, move the
cursor right up to the edge of the window. The window will scroll in small increments and you can
scroll in larger jumps by holding down the Ctrl key.

See also: Selecting families by relationship.




Selecting families by relationship
From the Edit menu select Select families.
You can automatically select groups of families on the screen based on their relationship to each

other. This is useful when trying to navigate a large, complex tree or when selecting part of the
tree for printing, exporting, etc.

You can select which type of selection to make by double-clicking on one of the following options.

All:
Selects all families.

Descendants:

Selects all families containing people descended from any person in the root family. The
cursor changes to ™ indicating that you must now click on a root family to complete the
selection.

Ancestors:

Selects all families containing people who are ancestors of any person in the root family. The
cursor changes to ™ indicating that you must now click on a root family to complete the
selection.

Direct line:

Selects families on a direct line from one family to a second family. This selection requires
that you click on two different families, one after the other, when the cursor is . Watch the
status line at the bottom of the Kith and Kin window for instructions. If the two selected
families are not linked, no selection is made.

If you click on nothing or carry out any other command while the cursor is %l the selection
command will be cancelled.

See also: Selecting families.




Zooming in and out of the tree area

You can zoom in and out of the Tree Area on the screen.

Zoom out by clicking on the [@I zoom out button on the button bar.
Zoom in by clicking on the zoom in button on the button bar.

You can use the View menu to select a standard (100%, 50%, 25%, 10%) or other magnification
or press Ctrl+N to return to normal viewing.

To speed up the display of family rectangles on the screen at smaller magnifications you can set
a limit below which the text and person icons will not be displayed. Do this in Options
Preferences.



Custom view

Enter a percentage magnification between 10% and 100%.

100% is full (normal) size and 10% is one-tenth size.

To speed up the display of family rectangles on the screen at smaller magnifications you can set

a limit below which the text and person icons will not be displayed. Do this in Options
Preferences.



Snapping families to a grid
Either From the Options menu select Snap to grid.
or Click on the grid button on the button bar

Kith and Kin has an invisible grid which can help you position family rectangles vertically. When
the grid is on, dragged family rectangles will snap into position along the horizontal lines on the
grid so that all the family rectangles line up.

The grid button on the button bar can be used to turn the grid on or off. The status line at the
bottom of the screen will tell you which has happened.



Entering dates

Dates must be entered in the input format defined in Options|Preferences. The dates which follow
are in the DD-MMM-YYYY format.

The following dates are valid:

25-Dec-1995
1-Jan-1996
25-Dec-1 BC

Where part of the date is unknown "?" may be substituted. Note that the year may not be
omitted:

??7-Dec-1995

?-7-1995
The standard GEDCOM date modifiers may be used to indicate About, Before, After and

Estimated:

ABT 25-Dec-1995
BEF 25-Dec-1995
AFT 25-Dec-1995
EST 25-Dec-1995

A phrase may be entered in place of a date by placing an apostrophe before the text but phrases
are not used in date calculations:
'Sometime later

The day and month descriptions (January, Sunday, etc) can be non-English if the date
descriptions are changed in the KITHKIN.INI file.



Editing notes

Kith and Kin supports two types of notes, internal and external. Both types are maintained from
the Notes dialog.

Internal notes:

Internal notes are stored as part of a Kith and Kin tree file. The notes may be edited in a similar
manner to the Windows Notepad editor.

The standard edit functions Undo, Cut, Copy and Paste are provided in the dialog's system menu.
Use the Find button to search for a piece of text in the notes. If you want upper and lower case
letters to match exactly, set Case Sensitive. Once a piece of text has been found you can search
for further occurrences of the same piece of text by selecting the Find Next button.

To search for and replace a piece of text with new text, use the Replace button. Set Replace All to
replace every occurrence of the search text.

Lines will break automatically at the right hand edge of the notes dialog and at the right hand
margin of printed reports so you should only enter a hard return <ENTER> at the end of
paragraphs.

See also: Database limits

External notes:

External notes are stored in separate text files (.TXT) which you create and maintain using a
separate text editor or word processor (eg. Windows Notepad). Kith and Kin stores links to these
notes files.

You can start the application which will edit notes files from Kith and Kin if you set up the "Notes
file editor" option in Options|Preferences.

File=
To maintain links to notes files, click on the E files button. This opens up the External Notes
Files dialog.

Click on the Add button to add a new link. It does not matter if the file does not exist, you can
either create it now or later outside of Kith and Kin. You can give the file any name you like but
we suggest that, for simplicity, you use the P or F code as the file name, eg. a notes file for P 234
might be P234.TXT.

You can have links to as many notes files as you like for each person or family. You can even have
more than one link to the same file. When notes are printed as part of a Details report the
internal notes come first followed by the contents of any notes files in the order that the file
names appear in the External Notes Files dialog.

To edit a notes file either click on its file name in the list and click on the Edit button or double
click on its file name.

You can delete the link to a notes file by using the Delete button. This only deletes the link, not
the file.



Working with objects

You may link or embed one or more objects in each person or family. The objects may be created,
played, edited, deleted, copied to the clipboard or printed as part of a Family Details or Person
Details document.

Using the Paste Link, Paste or Insert commands will insert a new object into the objects list. The
object will be inserted before the currently selected object or added to the end of the list if there
is no current selection.

Linking objects:

Start the application which contains the object to be linked. Select the object and copy it to the
clipboard using the COPY command. Switch to Kith and Kin and open the Objects Dialog which is
going to receive the object. Select the Paste link command in the dialog's system menu. The
object will be inserted into the objects list. If the Paste link command is not available it probably
means that the object's source document has not been saved.

Embedding objects:

Start the application which contains the object to be embedded. Select the object and copy it to
the clipboard using the Copy command. Switch to Kith and Kin and open the Objects Dialog which
is going to receive the object. Click on the paste button or select the Paste command in the
dialog's system menu. The object will be inserted into the objects list.

Creating new objects:

Objects may be embedded by starting the source application within Kith and Kin.

To do this select the insert button. Select an object from the available object types in the Insert
Object Dialog. The associated application will start and you may create an object within it. When
you exit the source application the object will appear in the objects list.

Editing and playing objects:

The Object command in the dialog's system menu will be different for each object type. Select
the object command appropriate to the action which you wish to carry out. The commands
invariably include Edit and sometimes additional commands such as Play (eg. for sound objects)
are available.

Double-clicking the left mouse button on an object will perform the default action for that
particular object type. Normally this is Edit but it will vary depending on the object type (eg. Play
for sound objects).

Copying objects:

Select an object from the objects list. Select the Copy command in the dialog's system menu.
This will copy the object to the clipboard from which it may be pasted to another objects list or a
different application. If you want to delete the object from the list at the same time, use the Cut
command instead of Copy.

Deleting objects:

Existing objects may be deleted from the objects list by selecting the object delete button.

Each object in the objects list has the following attributes.

Description:
A short description of the object, initially set to the object type.

Print object with notes:



When set, the object is printed full-size (within the defined margins) along with any notes
belonging to the appropriate person or family in the Family Details or Person Details document.

See also: Known incompatibilities



Insert Object Dialog

The list includes all types of OLE object which exist on your system. Select the object to insert
into the objects list and select the OK button or double-click the left mouse button on an item.

The appropriate application will start to allow you to edit the object which has now been added to
the object list. Note that an object created from this dialog is always embedded into the tree.



Searching for a piece of text

Either From the Search menu select Text search.
or Press F8.

or Click on the text search button in the button bar.

This will bring up the Text Search dialog which will perform a search through the entire tree based
on the selection of the following options. When the search is complete, a list of people and/or
families is displayed. To edit a person or family from the list either double-click the left mouse
button on the item or select first the item and then the edit button.

Search for:

Enter the text which is to be searched for.

Case sensitive:

If set, the search will find text which exactly matches the sequence of upper and lower case
letters in the search text otherwise the case of both the search text and searched text is ignored.

The following options specify which fields in the tree are to be searched through. One or more
may be set.

Family - Marriage:
The place of marriage of a family's parents.

Family - Divorce:

The place of divorce of a family's parents.

Family - Notes:
The notes associated with a family. Both internal and external notes are searched.

Person - Name:

A person's surname and firstnames.

Person - Aliases:
All of a person's alias details in each of their aliases, ie surname, firstnames and date of change.

Person - Birth:
The place of birth of a person.

Person - Baptism:
The place of baptism of a person.

Person - Death:
The place of death of a person.

Person - Burial:

The place of burial of a person.

Person - User defined field 1:
Data as defined by the user. If no description for this field has been set up in Options|Preferences




then the check box label will be blank.

Person - User defined field 2:

Data as defined by the user. If no description for this field has been set up in Options|Preferences
then the check box label will be blank.

Person - Notes:

The notes associated with a person. Both internal and external notes are searched.



Searching for dates

Either From the Search menu select Date search.
or Press Shift+F8.

or Click on the date search button in the button bar.

This will bring up the Date Search dialog which will perform a search through the entire tree
based on the selection of the following options. When the search is complete, a list of people
and/or families is displayed. To edit a person or family from the list either double-click the left
mouse button on the item or select first the item and then the edit button.

Date options:

You may select either an exact date match with the given date, dates which fall before the given
date, dates which fall after the given date and dates which fall between two given dates.

Dates must be entered in the currently selected input format.

It is possible to enter partial dates to be matched. For instance requesting an exact match with "?
Jan 1950" will result in dates from 1 Jan 1950 to 31 Jan 1950 inclusive; before "? Jan 1950" will
give dates up to and including 31 Dec 1949.

The following options specify which fields in the tree are to be searched through. One or more
may be set.

Family - Marriage:

The date of marriage of a family's parents.

Family - Divorce:
The date of divorce of a family's parents.

Person - Birth:
The date of birth of a person.

Person - Baptism:
The date of baptism of a person.

Person - Death:
The date of death of a person.

Person - Burial:
The date of burial of a person.



Searching for people in limbo

From the Search menu select People in limbo.

The program will search the tree for all people who are neither parents nor children in any family
and therefor cannot be accessed via the family rectangles in the tree area.

When the search is complete, a list of people is displayed. To edit a person from the list either
double-click the left mouse button on the item or select first the item and then the edit button.



Searching for date errors/inconsistencies

Kith and Kin will check the entire tree for impossible and improbable date entries. For instance a
person should not have a birth date of 28 May 1960 and a death date of 1 Apr 1951.

From the Search menu select Date errors.
Kith and Kin will commence the search and display any resulting errors.

When the search is complete, a list of people and/or families is displayed. To edit a person or
family from the list either double-click the left mouse button on the item or select first the item
and then the edit button.

You can pre-define which criteria you would like to use for the date error search by using Options
DateErrorSetup.




Date error setup

From the Options menu select Date error setup.

This command lets you define which criteria Kith and Kin should use when carrying out a Date
Error Search.

The following criteria may be selected and hence regarded as errors. Where a date has not been
entered, the error check is not done.

Person:
Baptism before birth: The baptism date comes before the birth date.

Death/burial before birth/baptism: The death date comes before the birth date. The burial
date will be used if the death date has not been entered. The baptism date will be used if the
birth date has not been entered.

Over ? years old at death/burial: The person was more than the given number of years old
at death (the default is 150 years). The baptism date will be used if the birth date has not
been entered. The burial date will be used if the death date has not been entered. If no death
or burial date has been entered Kith and Kin will check today's date to see if the person could
still be alive.

Family:

Marriage/divorce before birth/baptism of parent: Marriage occurred before the birth of
either parent. The baptism date will be used if the birth date has not been entered. The
divorce date will be used if the marriage date has not been entered.

Death/burial of parent before marriage/divorce: Marriage occurred after the death of
either parent. The burial date will be used if the death date has not been entered. The divorce
date will be used if the marriage date has not been entered.

Divorce before marriage: The divorce date comes before the marriage date.

Child born/baptised before mother is ? years old: At least one child was born before the
mother was the given number of years old (the default is 10 years). The baptism date of the
child will be used if the birth date has not been entered. The baptism date of the mother will
be used if the birth date has not been entered.

Child born/baptised after mother is dead/buried: At least one child was born after the
mother was dead. The baptism date of the child will be used if the birth date has not been
entered. The burial date of the mother will be used if the death date has not been entered.

Child born more than ? weeks after father's death: At least one child was born more
than the given number of weeks after the father's death (the default is 40 weeks). The
baptism date of the child will be used if the birth date has not been entered. The burial date of
the father will be used if the death date has not been entered.



Searching for events of a particular day

From the Search menu select On this day.

The "On this day" function searches through the tree for all dates which match the specified day
of the year. The default entry is today's date but a new day and/or month may be chosen.

Click on the |_=& search button to commence the search. When the search is complete, a list
of people and/or families is displayed along with a description of the qualifying events.



Viewing tree statistics

From the View menu select Statistics.
Kith and Kin will display various interesting statistics about the current tree. These are:

Filename:
Full path name of the current tree.

File size:
Current file size in bytes. This is read from the disk so you should use File|Save before
viewing the statistics to get a true value.

People:
Total number of people and of males and females.

Families:
Total number of families.

Generations:
Longest direct line with the responsible root ancestor.

Earliest date:
Earliest recorded date.

Biggest family:
Family with the highest number of children (may be more than one family).

Oldest person:
Longest lived person. People with no death or burial dates have their death estimated using
the "Over ? years old at death/burial" value in Options|DateErrorSetup.



Finding the relationship between two people

Kith and Kin will calculate the relationship (if any) between any two people in the current tree.
From the View menu select Relationship.

Kith and Kin will display a Select Dialog from which to choose the first person. The program will
next display another Select Dialog from which to choose the second person. The order in which
you choose the two people is not important.

Kith and Kin then displays their relationship. Statements such as "great3grandson" indicates
"greatgreatgreatgrandson".



Choosing date formats
See Setting preferences



Handling foreign languages

The names of months, weekdays and all strings used in reports are read from the file KITHKIN.INI
when Kith and Kin first starts up. These entries can be modified if you require translation into
another language by using a text editor or word processor.

To rename the months, substitute for "January" the appropriate month name. Do the same for
"February" and so on. Do not modify anything which comes before "="oris in "[ ]". You can also
modify the weekday names and report strings.

After making changes and saving KITHKIN.INI back to disk you should exit and restart Kith and Kin
for the changes to take effect.

The default KITHKIN.INI file looks like this:

[Months]

1=January
2=February
3=March
4=April
5=May
6=June

7=July
8=August
9=September
10=October
11=November
12=December

[Days]

1=Sunday
2=Monday
3=Tuesday
4=Wednesday
5=Thursday
6=Friday
7=Saturday

[Reports]

Born=Born
Baptised=Baptised
Died=Died
Buried=Buried
Married=Married
Divorced=Divorced

Born2=b.
Baptised2=bap.
Died2=d.
Buried2=bur.
Married2=m.
Divorced2=div.

Surname=Surname
Firstnames=Firstnames



BirthD=Date of birth
BirthP=Place of birth
BapD=Date of baptism
BapP=Place of baptism
DeathD=Date of death
DeathP=Place of death
BuriD=Date of burial
BuriP=Place of burial
ChildF=Child's family
MarrD=Date of marriage
MarrP=Place of marriage
DivD=Date of divorce
DivP=Place of divorce
Father=Father
Mother=Mother

At=at
Unknown=Unknown
Alias=Alias
Parents=Parents
Children=Children
Family=Family
Desc=Descendants of
Anc=Ancestors of
Tree=Tree

Index=Index
IndexF=Index to Families
IndexP=Index to People
Census=Census report for
Missing=Missing Data Report
Timeline=Timeline

Start=Start of
End=End of
For example part of a Dutch KITHKIN.INI would look like:

[Reports]

Born=Geboren
Baptised=Gedoopt



Setting preferences
From the Options menu select Preferences.

This will bring up the Preferences Dialog and the following options may be set.

Date formats

Kith and Kin allows you to choose which of several available date formats it should use to verify
dates which you enter and to format dates for output.

The date input formats are:

DD MM YYYY eg. 2512 1995
DD MMM YYYY eg. 25 Dec 1995
MM DD YYYY eg. 12 25 1995
MMM DD YYYY eg. Dec 25 1995
YYYY MM DD eg. 199512 25
YYYY MMM DD eg. 1995 Dec 25

An input format definition must also include a separator. In the examples above the separator is a
space but any character may be used. The separator must be the same character in both
positions.

eg. 25/12/1995 25-12-1995 25.12.1995
The date output formats are:

(any of the input formats above plus...)

DD MMMM YYYY eg. 25 December 1995

MMMM DD YYYY eg. December 25 1995
WWWW DD MMMM YYYY eg. Monday 25 December 1995
wwww MMMM DD YYYY eg. Monday December 25 1995

These four output formats differ from the input formats in that they omit any "?"s from the date,
eg. December 1995.

As you select a different format or change a separator, Kith and Kin displays a sample date in the
selected format.

Users who need to use foreign-language versions of month names, etc can modify the entries in
the KITHKIN.INI file.

Marriage produces wife's alias:

When a person is identified as the mother of a family an alias is automatically generated
comprising her married surname, her firstnames and the date of marriage. This alias will not be
removed automatically in the event of a mother's deselection.

Display large objects:

The image of a large object may take a while to draw into the gobjects list, depending on the
speed of your PC. To overcome this problem you may display a simple grey rectangle in the list in
place of the image of large objects by turning this option off. Changing this option does not
affect the contents of the object or the way it is printed.

Sort children/marriages:

Kith and Kin will automatically sort children in a family (and marriages of a person) by date if this
option is set. If a birth date for a child has not been entered, the baptism date will be used if



present.

Include timeline file:

Allows you to choose whether to include historical dates from the TIMELINE.TML file in the
timeline window.

Display text to ? %:

To speed up the display of family rectangles on the screen you can set a magnification limit below
which the text and person icons will not be displayed.

User defined field names:

The Person Data Dialog has two fields which you can set up to hold any data you like. You should
enter the names of the fields and any associated GEDCOM tags here.

For example, if you wanted to store the person's occupation in field one, enter "Occupation" at 1
and "OCCU" in the corresponding GEDCOM tag field. Now when you open a Person Data Dialog
you will see an Occupation field which can be filled in.

The following GEDCOM tags are valid:

REFN *Reference number.
TITL *Title.

CAST Caste.

EDUC Education.

NATI Nationality.

OCcCU Occupation.

PROP Possessions.

RELI Religion.

SIGN Signature info.

SSN Social security number.

* denotes valid PAF GEDCOM tag.

Other tags are defined in GEDCOM standard but are not valid in PAF. Tags are always treated as
level 1 after 0 INDI with no subordinate levels only and users should ensure that any data
assigned to a GEDCOM tag conforms to any formatting requirements for that tag.

Notes file editor:

Enter the full pathname of an program to use to edit external notes files. You can click on the
Browse button to search for a program on your hard disk. For example, if you want to use
Windows Notepad, you would look in the C:\WINDOWS\ directory for a file called NOTEPAD.EXE.
The full pathname would then be C:\WINDOWS\NOTEPAD.EXE.

Kith and Kin executes your text editor by using the program filename given here followed by the
name of the notes file. Your text editor must accept a command line of this format.



Re-using codes from deleted people/families

From the Edit menu select Re-use code.

Kith and Kin allocates the "P" and "F" codes automatically when you add a new person or family.
When you delete an existing person/family or click on Cancel during an addition, the P or F code
is discarded.

In normal use you do not have to worry about the fact that Kith and Kin will discard codes. They
are simply unique identifiers used to make selecting people and families easier and they do not
have to be strictly sequential.

However, in some special circumstances you may wish to add a new person or family using one
of the discarded codes. This may be because you already have a numbering system for your data
which you want to continue to use in Kith and Kin.

To reuse a discarded P or F code simply double-click on the required code in the "Re-use
person/family code" dialog to add a person or family using that code. Only codes which have
previously been discarded from the current tree are available.



Exiting from the program

Either From the File menu select Exit.
or Press Alt+FA4.

This command will check to see if the current tree needs to be saved before exiting the program.



Printout selection dialog

The Printout Selection Dialog is used to select a report for printing, to send to a text file or to
print preview. Select a printout from the list and click on the OK button or double-click on a
printout name.

The printouts are:

Family details
Person details

Index

Tree layout
Descendant tree
Ancestral tree
Indented tree
Timeline

Census report
Missing data report




Select all

Either From the Edit menu select Select all.
or Press Ctri+A.
or Double-click on All in the Select Families dialog.

This command selects every family in the current tree.



Button bar

The button bar is located just below the menu bar at the top of the main window. Click on a
button in the picture of the button bar below to find out what it does.

You can display the function of each button in the status bar by pressing and holding the left
mouse button and then moving the cursor away from the bar before releasing the button.



Opens a tree or GEDCOM file from disk.



Saves the current tree to disk. If the tree has been saved previously it will be saved with the
same name and overwrite the existing file. If the tree is untitled the button acts like Save As.



Select report to print.



Edit a person's data.



Edit a family's data. If one family rectangle is currently highlighted Kith and Kin will edit that
family, otherwise you will be asked to select a family.



Search for text.




Search for dates.



Scroll the tree area to a family.




Show or hide the timeline window.




Toggles the snap-to grid on or off.




Zooms in to the next viewing scale.



Zooms out to the next viewing scale.



Opens the help file at the contents page.



Dialog buttons

(See Button bar for buttons on the button bar)

Click on a button below for its definition.
Person and/or family data dialogs

Lloid

5 \{| EEEMNEE

Alias dialog
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Objects Dialog
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Miscellaneous




An identify button is one of several buttons in Person and Family Data Dialogs which identify an
existing family or person and link it to the current person or family as a child of family, marriage,

father, mother or child depending on which button is selected.




An add button is one of several buttons in Person and Family Data Dialogs which both create a
new family or person and link it to the current person or family as a child of family, marriage,
father, mother or child depending on which button is selected.




An edit button is one of several buttons in Person and Family Data Dialogs which edit a family or
person which is identified as a child of family, marriage, father, mother or child depending on
which button is selected.



A remove button is one of several buttons in Person and Family Data Dialogs which remove the

link to a family or person which is identified as a child of family, marriage, father, mother or child
depending on which button is selected. You are given the option of deleting the family or person
from the tree at the same time.



The highlight off button cancels any selection made in either a child or marriage list. This

allows new items to be identified or added at the end of the list instead of prior to the highlighted
item.



The add button will add the entered data to the person's list of aliases.




The edit button will retrieve the selected alias to allow editing.



The delete button will remove the selected alias from the person's list of aliases.



]

The alias button allows the addition and editing of the current person's aliases. Only available
from a Person Data Dialog.
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The notes button opens a Notes Dialog in which to edit a person's or family's notes. A green
border around this button indicates that notes are present. Use for both internal and external
notes.
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The objects button opens an Objects Dialog in which to edit a person's or family's objects. A
green border around this button indicates that objects are present.




u Cloze

The close button exits from various dialogs. Any data in the dialog has already been accepted
and selecting close will neither update nor reject it.




F Inzet

The insert object button creates a new embedded object from within Kith and Kin and inserts it
into the objects list.
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The delete object button deletes the currently selected object from the objects list.




B

The paste object button embeds an object from the clipboard into Kith and Kin, inserting it into
the objects list.
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The OK button accepts the data currently displayed in the dialog and closes it. You can also use
Alt+Z.
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The cancel button ignores the data currently displayed in the dialog and closes it. You can also
use ESC.




? Help

The help button opens the on-line help file at a topic relevant to the current dialog.




Person data

The Person Data Dialog allows the addition, editing and display of a specific person's data.
Click the left mouse button on the item of interest below to get a definition.

Surname | GORDOR IEI @ Mlale
Eirstnames| Thomaz > Femnale “EK
Dates Flaces
Eirth 15 Sep 1810 Kinross
Eiaptism | 29 Sep 1510 Kinrozs Wiancs
Dizath B g 1893 Eennet, Clackmannan
Burial
Occupation | | Cause of death | Chionic diarrhoes | M

G % Child of Family
@ | [F147] - [P413] Thomas GOROOM = [P414] Izabel SCOTLAMND | I:Ihiunks
|E| flarriages
=

[X] _ s




Person Data - Code

The code is the letter 'P' followed by a number which uniquely identifies a particular person. The
code is assigned automatically and is not necessarily the next in sequence.



Person Data - Surname

The surname of the person (normally the surname at birth). Characters are converted to
uppercase.



Person Data - Firstnames

The first or christian names of the person.



Person Data - Alias

Selecting the alias button will bring up the Alias Dialog.
If the appropriate preference is set, an alias will be automatically added to the mother of a family

comprising her married surname, her firstnames and the date of marriage. This alias will not be
removed automatically in the event of a mother's deselection.




Person Data - Gender

A gender (male or female) must be supplied for the person. Only males may become fathers and
females mothers.



Person Data - Birth

The date and place of birth of this person. The date must be entered in the input format defined
in Options|Preferences.



Person Data - Baptism

The date and place of baptism or christening of this person. The date must be entered in the
input format defined in Options|Preferences. Baptism dates are used in lieu of birth dates if no
birth date is present when Kith and Kin is doing date calculations.



Person Data - Death

The date and place of death of this person. The date must be entered in the input format defined
in Options|Preferences.



Person Data - Burial

The date and place of burial of this person. The date must be entered in the input format defined
in Options|Preferences.



Person Data - User defined fields

These two fields may be configured to contain any data the user desires. Use Options|Preferences
to set the descriptions of these fields.



Person Data - Child of Family

A family identified as the family of which this person is a child. The names and marriage details of
the parents are displayed and may be scrolled by clicking the cursor in the display field and using
the left and right arrow keys.

A family may be identified as a child of family if it already exists in the tree by selecting the
child of family identify button.

A family which does not yet exist in the tree may be added by selecting the child of family add
button. This will bring up a Family Data Dialog.

If a child of family exists for this person, its Family Data may be edited or displayed by
selecting the child of family edit button.

If a child of family exists for this person, it may be deselected by selecting the child of family
remove button. The option of deleting the family from the tree is given at this time.



Person Data - Marriages

A list of families identified as having resulted from marriages of this person. The names and
marriage details of each families parents are displayed.

A family may be identified as a marriage of this person if it already exists in the tree by
selecting the marriage identify button. With the "Sort children/marriages" option off, the new
marriage is inserted into the list before the currently selected marriage (or at the end if none is
selected). If the "Sort children/marriages" option is on, the new marriage is inserted into the list
in the correct position based on the marriage date (or divorce date if marriage has not been
entered).

A marriage which does not yet exist in the tree may be added by selecting the marriage add
button. This will bring up a Family Data Dialog. The new marriage is inserted into the list in the
same way as "identify" above.

The Family Data of marriages in the list may be edited or displayed by first selecting the
family's name and then selecting the marriage edit button or by double-clicking the left mouse

button on the family's name.

Families may be deselected as resulting from a marriage of this person by first selecting the
family's name and then selecting the marriage remove button. The option of deleting it from the
tree is given at this time.

To identify or add a marriage to the end of the list, with the "Sort children/marriages" option off, it
is necessary to have no marriages selected in the list. The marriage highlight off button is
provided to achieve this.




Family data

The Family Data Dialog allows the addition, editing and display of a specific family's data.
Click the left mouse button on the item of interest below to get a definition.

FAMILY : [F14&] - [F407] Thomas GORDOM = [P402] Margaret DRUMMOND

Eather i @ @ [ather

[[P407] Thomas GORDOM b. 15 Sep 1310, | [[F405] Margaret DRURMMOND b. EST 77 |
Mlarriage Dake| 4 Mow 1832 Flaze | Kinross

DOivorce  Dake Flace

Children
= E F403] Jane Cairns GOROON bap. 27 Apr 1333, Saline par.
BA10) Thomas GORCIUN bap, 18 lay f33%, Saiine par.
@ Fa24] William Drommond GORDOM bap, 24 Mar 1338, Saline par., Fite
@ F411] James GOROOMN bap. & Mar 1845, Saline par.
F412] Margaret Drummond GORDOM bap. 26 Feb 1851, Saline par.
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Family Data - Code

The code is the letter 'F' followed by a number which uniquely identifies a particular family. The
code is assigned automatically and is not necessarily the next in sequence.



Family Data - Father

A person identified as the father for this family. His name and birth details are displayed and may
be scrolled by clicking the cursor in the display field and using the left and right arrow keys.

A person may be identified as father of this family if he already exists in the tree by selecting
the father identify button.

A father who does not yet exist in the tree may be added by selecting the father add button. This
will bring up a Person Data Dialog.

If a father exists for this family, his Person Data may be edited or displayed by selecting the
father edit button.

If a father exists for this family, he may be deselected as father of this family by selecting the
father remove button. The option of deleting him from the tree is given at this time.



Family Data - Mother

A person identified as the mother for this family. Her name and birth details are displayed and
may be scrolled by clicking the cursor in the display field and using the left and right arrow keys.
A person may be identified as mother of this family if she already exists in the tree by selecting
the mother identify button. An alias may be generated automatically if the preference is set.

A mother who does not yet exist in the tree may be added by selecting the mother add button.
An alias may be generated automatically if the preference is set. This will bring up a Person Data

Dialog.

If a mother exists for this family, her Person Data may be edited or displayed by selecting the
mother edit button.

If a mother exists for this family, she may be deselected as mother of this family by selecting
the mother remove button. The option of deleting her from the tree is given at this time.



Family Data - Marriage

The date and place of marriage of the parents of this family unit. The date must be entered in the

input format defined in Options|Preferences.



Family Data - Divorce

The date and place of divorce of the parents of this family unit. The date must be entered in the

input format defined in Options|Preferences.



Family Data - Children

A list of people identified as children of this family. Their names and birth details are displayed.

A person may be identified as a child of this family if (s)he already exists in the tree by selecting
the child identify button. With the "Sort children/marriages" option off, the new child is inserted
into the list before the currently selected child (or at the end if none is selected). If the "Sort
children/marriages" option is on, the new child is inserted into the list in the correct position
based on his/her date of birth (or date of baptism if birth has not been entered).

A child who does not yet exist in the tree may be added by selecting the child add button. This
will bring up a Person Data Dialog. The new child is inserted into the list in the same way as
"identify" above.

The Person Data of children in the list may be edited or displayed by first selecting the child's
name and then selecting the child edit button or by double-clicking the left mouse button on the
child's name.

Children may be deselected as belonging to this family by first selecting the child's name and
then selecting the child remove button. The option of deleting him/her from the tree is given at
this time.

To identify or add a child to the end of the list, with the "Sort children/marriages" option off, it is
necessary to have no children selected in the list. The child highlight off button is provided to
achieve this.




Alias Dialog

A person may have several aliases.

Aliases are added by entering the surname, firstnames and date of change then selecting the
add button. The date must be entered in the input format defined in Options|Preferences.

Edit an alias by first selecting the alias from the list then selecting the edit button or by double-
clicking the left mouse button on the alias. This will copy the data into the edit boxes where it
may be changed. Press return to put the alias back into the list.

An alias may be deleted by first selecting the alias from the list then selecting the delete button.



Select dialog

The select dialog is displayed in various circumstances when an action has been requested which
acts on a specific family or person, eg. deleting a person or printing descendants.

Selection may be done by either entering a code number (digits only, do not enter the P or F) or
selecting from the list of families or people. Pressing a letter key (A-Z) will scroll down the list
until a name beginning with that letter is found.



Keyboard / Mouse key assignments

Keyboard

F1l Help Open the Kith and Kin help file at the contents topic
Ctri+F1 Help search Search for keywords in the Kith and Kin help file
F2 Save Save the current tree (not available for untitled trees)
Alt+F4 Exit Exit Kith and Kin

F5 Edit person Edit an existing person's data

Ctrl+F5 Add person Add a new person to the tree

Shift+F5 Person notes Add or edit a person's notes

Alt+F5 Person objects Add or edit a person's objects

F6 Edit family Edit an existing family's data

Ctrl+F6 Add family Add a new family to the tree

Shift+F6 Family notes Add or edit a family's notes

Alt+F6 Family objects Add or edit a family's objects

F8 Text search Search for a piece of text

Shift+F8 Date search Search for dates

F9 Go to family Scroll the tree area to a specific family

Ctrl+A Select all Select all family rectangles

Ctrl+N View|Normal Normal view (100%)

Ctrl+0 View|Other Custom view

PageUp Scroll page up Moves the tree area window up one page
PageDn Scroll page down Moves the tree area window down one page
Tab Scroll page right Moves the tree area window right one page
Shift+Tab Scroll page left Moves the tree area window left one page
Home Scroll to Startup family (if any)

Left, right Scroll left or right

Up, down Scroll up or down

Dialog control :
Alt+Z

Mouse

OK

Tree area control :

Same as clicking OK button.

Left Select family Select a family (hold to drag to new position)

Double Left Edit family Edit a family's data

Shift+Left Select families Select more than one family

Ctri+Left Scroll page Moves tree area in large jumps when dragging families
Right Family summary Displays details of the family under the cursor

Timeline window control :

Left Select person Highlights all occurrences in the timeline of a particular

person.
Clears highlights.

Right Clear selection



Version information

This is a list of new features, enhancements and bug fixes which is updated with the release of
each new version of Kith and Kin. Any last minute bug fixes are included here and may not be
present in the flyers or readme files.

Tree (.TRE), options (.OPT) and KITHKIN.INI files created with earlier versions of the program may
require conversion before they can be used with this version. A data file conversion program
(KKCONV) is supplied with all registered versions of Kith and Kin.

Version 3.11 December 1996

Bug-fix release.

Printing a Census Report containing people with a place field entry but no corresponding date
field entry caused a crash at 0005:4E91 - fixed.

Large notes running over a page break in details/census reports sometimes overprinted the last
line of the page - fixed.

External notes printed in details/census reports were cut off at 255 characters per line - fixed.

Version 3.1 November 1996

Export delimited text files for transfer to databases.

Indented descendant tree printout added (text only).

Missing data report added.

Tree Layout print will now print all or only selected families.

Family Details report modified to make it clearer who owns details and notes.

You can now search on dates.

Now supports links to external notes files in addition to internal notes.

Select family boxes on screen by using All, Descendants, Ancestors or Direct Line.

Press a letter key to scroll down the Selection Dialog list.

GEDCOM input/output now compatible with "standard" V5.5. Also supports foreign DOS code
pages.

Command to re-use P and F codes from deleted people and families added.
OK hot-key for dialogs (ALT+Z) added.
New Timeline option to ignore dates from Timeline file.

Family summary window now uses output date format instead of input date format.
"Start of" and "End of" in the timeline can now be customised in KITHKIN.INI.
View|Other hot-key is now Ctrl+0 to avoid conflicts in WIN95.

Paste button added to Objects Dialog.

System menus in Objects and Notes dialogs did not contain correct commands in WIN95 - has
been fixed.

WIN95 fed a blank page at the end of each printout - fixed.
Date phrases over 60 chars caused a crash - has been fixed.



Status line now has text which doesn't disappear under another window.

The "Oldest person" in Options|DateErrorSetup was not being used in calculations for the View|
Statistics dialog - fixed.

New families appear on the screen in a "better" order.

Family/Person Details printout did not print details for spouses when the "Details everywhere"
option was set - fixed.

The order of a person's marriages was not saved in the Tree file - fixed.

Some GEDCOM files were being imported with marriages in the wrong order - fixed.

Version 3.03a June 1996

Help file now includes New Zealand registration point.

Version 3.03 February 1996

Bug-fix release.
Incorrect linkages printed in the Descendant Tree.
Some amendments to the User Guide, KITHKIN.TXT.

Version 3.02 January 1996

Bug-fix release.
Fixes some minor problems when exporting date phrases to a GEDCOM file.

Version 3.01 October 1996

Bug-fix release.

Kith and Kin could not find the timeline file TIMELINE.TML when launched from a .TRE file in
another directory.

Search|Text command would not find baptism, death and burial places.

Dual dates are now imported from GEDCOM files as text.

GEDERR.TXT file now reports invalid dates converted to text.

Individuals in GEDCOM files with no firsthnames had their surname used as a firstname.
Tree Layout print preview did not cancel properly.

The Descendant Tree printout incorrectly linked together children from multiple marriages.

Version 3.0 September 1995

Date validation. All entered dates are checked using the "Input format" selected in Options
Preferences.

Baptism and burial fields added to person data.

Two user-defined fields added to person data. Description of each field is entered in Options|
Preferences.



Divorce field added to family data.
Snap-to-grid function.
Auto-arrange children and marriages if the option has been selected in Options|Preferences.

Zoom in/out on screen display. Text/icons displayed in family rectangles only down to percentage
defined in Options|Preferences to speed up display.

Print preview, from the File menu.
All text reports (Details, Indices, etc) can be sent to a text file instead of the printer.

KITHKIN.INI holds descriptions for months, days and all report static text. These can be changed
by users requiring foreign-language output.

Timeline window. Displays events for currently selected families plus appropriate events from
TIMELINE.TML.

View|Relationship between two people.

"On this day" search.

View|Statistics display.

Date inconsistencies search. The parameters for this are defined in Options|DateErrorSetup.

Timeline report.
Census report. Basically a Family Details report for a specific date.

Descendant and Ancestral Trees and Timeline printouts have user-defined titles.

You can now drag a marquee around family rectangles on the screen to select them.
Edit|SelectAll command added.

Shift + left mouse button in the Tree Area will now deselect a single family.

Button bar.

New Options|Fonts dialog.

Customisable fonts for Screen (family rectangles), family summary window, timeline window and
timeline report. Census report uses Details report fonts.

File|SaveAs GEDCOM now has an option to include Kith and Kin specific tags - so that you can
exclude them.

Selection dialog for people and families now sorts using dates if person/family has the same
name.

Spouse details added to Descendant Trees.

Baptism, burial, divorce and user-defined fields added to appropriate reports.

Status line at bottom of main window for lengthy operations instead of pop-up bargraph.
File|Open GEDCOM has an option to convert invalid dates to date phrases.

File|SaveAs GEDCOM will export user-defined fields if tag names supplied in Options|Preferences.
File|Open GEDCOM now imports children/marriages in correct order.

Notes/Objects indicators in Person/Family Data Dialogs replaced with button highlights.

Tree Layout now prints over more than one page and has the option to print children icons or turn
off the dotted lines for females.

Range "from" and "to" boxes are now correctly greyed out in print dialogs when "Range" is not
selected.

Aspect ratio of the objects displayed in the Objects Dialog is now correctly maintained.



The Kith and Kin help file is now available in text format as KITHKIN.TXT for sending straight to
the printer.



Database limits

You can have up to 16383 people and families combined.

The size of the tree area is approx. 200 families wide by 350 high.

The maximum number of characters which can be held in each person or family notes is 9500.

The Descendant and Ancestral Tree Prints will handle up to 80 generations in a single printout.

Ultimately, the total amount of tree data will depend on the amount of available memory (RAM)
in your PC. However, a 4Mb PC with a 6Mb swapfile (the standard setup) should be sufficient to
hold the maximum tree size, depending on the size and number of notes, objects and other
Windows applications running.

To some extent the speed of your PC will govern the usability of the software with large amounts
of data.



OLE error codes

Occasionally Kith and Kin will display an error message "OLE operation failed" and give an error
code of the form <a>@<b>. The <b> number indicates the location in the program where the
error occurred and is only of use when requesting support from us. The <a> number indicates
the type of error from the list below and may be helpful in pinpointing the cause of the error.

OLE errors are generally caused by removing an application from your system which you used to
link or embed an object into Kith and Kin or by opening a tree file created on another PC which
contains objects which you don't have the source application for. Other causes include installing
an upgraded OLE server which is not backwards compatible or corruption in the registration
database.

Kith and Kin uses OLE version 1.

The client application is Kith and Kin, the server is the program user to link or embed the object.

Possible error codes:

3 The OLE function was called in real mode.

4 Either the OLE DLLs or the server could not allocate or lock memory.

5 An OLE stream error occurred; this is generally caused by a failure in the client
application's Get or Put callback functions.

6 A non-static object was expected by the OLE libraries.

7 There is critical data missing.

8 An error occurred while drawing the object.

9 The metafile specified is invalid.

10 The client application chose to cancel the metafile drawing.

11 The OLE libraries were unable to obtain the necessary data from the clipboard.
12 The requested format is not available.

13 The object is not valid.

14 An invalid operation occurred.

15 An invalid protocol was specified as part of a parameter to an OLE API.

16 An invalid pointer was used.

17 The objects are not equal.

18 An invalid handle was encountered.

19 An error of unknown cause occurred.

20 An invalid class was specified.

21 An invalid command syntax was specified.

22 The data format requested is not available.

23 An invalid colour palette was specified.

24 This is not a linked object.

25 The client application's document contains objects.

26 An incorrect buffer size was passed to a function that places string information in the
calling function's buffer.

27 The document name contains an invalid drive letter.

28 The client application failed to establish a connection with a network share on which the
document is located.

29 An invalid name was passed to the function.

30 The server application failed to load the specified template.

31 The server application failed to create a new document.

32 The server application failed to create an embedded instance for the object.
33 The server application failed to open the document; could also indicate an invalid link.

34 The object is not open for editing.

35 OLECLI.DLL failed to start the server application.

36 The client application failed to establish communication with the server application.
37 An error occurred while terminating the server application.



38
39

41
42

43
44
45
46
47

48
49
50
51
52
53
54
55

An error occurred in executing a DDE execute command.

An error occurred in showing the object.

An error occurred in executing a verb; this could also indicate an invalid verb.

The server application could not provide the native data for the specified item; this is
usually because the item was deleted in the client application.

A picture item could be missing or the server application doesn't recognise the
presentation format of the object.

The server application doesn't support renaming of the object.

The OLE DLLs failed to give the native data to the server application.

The server application failed to render the native data.

The server application failed to render the presentation data.

The client application is trying to block a server application that is already blocked, or the
client is trying to revoke a blocked server or document.

The server application is not registered in the system registration database.

The server application is trying to register the same document multiple times.

Either the server or client is trying to perform an invalid task.

The object is out of date.

The client application containing the embedded object doesn't accept updates.

An error occurred while trying to update the object in the client application.

The server application doesn't understand the format given to its SetData method.
The client application is trying to load a static object created in another operating system.



Known incompatibilities

OBJECTS

Some applications which produce objects for embedding or linking, do not provide a picture
image of the object. In these cases Kith and Kin will not be able to embed or link the object to a
person or family in the normal way. You can, however, use the Windows Object Packager to
associate an icon with the object. This will then allow Kith and Kin to use the object as normal.
See the on-line help in Object Packager or your Windows documentation for further details.

GEDCOM

Kith and Kin has problems importing GEDCOM files created by Pedigree. Pedigree exports an
older style of GEDCOM file which has no space character between the cross-reference ids and
certain tags. You can overcome this problem by editing the GEDCOM file directly using NOTEPAD,
a word processor or other text editor. Search for the text "@INDI" and "@FAM" and replace them
with "@ INDI" and "@ FAM" respectively throughout the entire GEDCOM file (do not enter the
guote marks). Save the file and you will now be able to import it into Kith and Kin successfully.



Supported GEDCOM data

Kith and Kin supports the PAF (Personal Ancestral File) variation of the GEDCOM (Genealogical
Data Communication) standard, as used by the majority of genealogical programs. There are
some quirks in PAF GEDCOM, which make it different from the GEDCOM standard proper, and so
there are no guarantees that Kith and Kin will correctly read GEDCOM files not designed to be
read by PAF. Some enhancements have been made to bring Kith and Kin into line with the
GEDCOM V5.5 standard in so far as they do conflict with backwards compatibility.

Fully supported tags: (have corresponding fields in Kith and Kin)
(* denotes tag excluded if "Kith and Kin specific data" check box is not set)

Record Tag

HEAD
SOUR
DEST
DATE
NAME
CHAR

_SFAM
SCHEMA

SUBM
NAME
ADDR
PHON
COMM

INDI
NAME

SEX
BIRT
CHR
DEAT
BURI
NOTE
FAMS
FAMC
BLOB
OBJS
UDF1
“UDF2

FAM
HUSB
WIFE
CHIL
MARR
DIV
NOTE
_FBLOB
“MBLOB

Description

File header.

Source system.

Destination system (PAF).

Date of file.

Name of file.

Character set. Kith and Kin assumes IBMPC unless a valid CHAR tag is
found. IBMPC, MACINTOSH and ANSEL sets are converted to ANSI for
use in Windows. Kith and Kin always exports in ANSI.

*(Kith and Kin GEDCOM files only).

*Kith and Kin ignores this tag on import, but inserts a SCHEMA tag in
exported files to define Kith and Kin specific tags.

File submitter.

Submitter's name.
Submitter's address.
Submitter's phone number.
Comments.

Person data (individual).

Firstnames and surname. If there is more than one NAME tag for a
particular person, the last one is regarded as the normal name and prior
ones are regarded as aliases.

Gender, male or female (male is assumed if missing).

Date and place of birth.

Date and place of christening/baptism.

Date and place of death.

Date and place of burial.

Notes.

Family id of which this person is a parent.

Family id of which this person is a child.

*(Kith and Kin GEDCOM files only).

*(Kith and Kin GEDCOM files only).

*(Kith and Kin GEDCOM files only).

*(Kith and Kin GEDCOM files only).

Family data.

Person id of the father of this family.
Person id of the mother of this family.
Person id of a child of this family.
Date and place of marriage.

Date and place of divorce.

Notes.

*(Kith and Kin GEDCOM files only).
*(Kith and Kin GEDCOM files only).



_PCODE *(Kith and Kin GEDCOM files only
_PNAME *(Kith and Kin GEDCOM files only
_FRECT *(Kith and Kin GEDCOM files only
_OBJS *(Kith and Kin GEDCOM files only

~_— — ~— ~—

Extra data tags: (are optionally inserted in notes)

Record Tag Description
INDI Person data (individual).
REFN Reference number.
TITL Title.
OCcCU Occupation.
EDUC Education.
RELI Religion.
NATI Nationality.
CAST Caste.
FAM Family data.
REFN Reference number.

If a user defined field has a GEDCOM tag associated with it in Options|Preferences then Kith and
Kin will import or export the data in the field accordingly. Only tags which appear at level 1 are
suitable (all the "Extra data tags" above are suitable). For instance, if a user defined field has
"Occupation" as its description and "OCCU" as its GEDCOM tag then any occupation data will be
exported from Person Data. Similarly, if the "OCCU" tag appears in an imported GEDCOM file the
associated data will be put in the user defined field.

Any other tags encountered in an imported GEDCOM file are ignored but are reported in the log
file GEDERR.TXT.



Frequently asked questions

Q Why does the order of children in a family sometimes change after editing the family?

A If you have set the "Sort children/marriages" option in Options|Preferences then Kith and
Kin will try to sort children into order of birth date. If some of the children have no birth/baptism
dates Kith and Kin will place them at the end of the list but cannot order them further. To ensure
that the order does not change, enter an estimated date for where dates are missing, eg. EST ? ?
1800.

Q When | select families which have dated events, why do they not appear in the timeline
window?

A Make sure that the dates have not been entered with an apostrophe in front of them,
indicating that they are only to be treated as text. This is particularly likely if you have converted
from a previous version of Kith and Kin.

Q How can | get reports printed which have dates without "?"s when part of a date is missing.

A Use one of the last 4 date formats as an output format in Options|Preferences. These 4
formats are specifically for outputting dates, so although a person's birth date may have been
entered as "? ? 1930" it will appear in reports as "1930". You can edit the KITHKIN.INI file if you do
not like the months/weekdays spelt out in full.




Tree area - the area in which the family tree appears. A selected part of this area is displayed in
the program's main window and the window may be moved around the tree area to view different
parts of the tree. The tree area contains a family rectangle for every family and these may be

positioned to provide the best layout. The tree area may be printed using the print tree
command.



Fa47

GORDOH = SCOTLAND

Family rectangle - a shape similar to the one above which is used for selecting a particular
family. F147 is the family code, GORDON is the surname of the father and SCOTLAND is the
surname of the mother. The blue (#) and pink (
t) icons denote male and female members of the family respectively, the two people along the
top edge are the parents, the seven along the bottom edge are the children. Parent Lines

emanate from appropriate people indicating links to other families. You can display a summary of
a family by holding down the right mouse button on it.

See also: Selecting families.
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GORDOH = SCOTLAND

Parent Lines - lines indicating the relationships between families. Shown here are (a) the father
of family F146, (b) the mother of family F146 and (c) the father of family F118 who is also the
first child of family F146. When moving family rectangles around the tree area, parent lines will
follow like rubber-bands.




Marriage - a family unit of which the current person is a parent. A person may have no
marriages or a list of marriages. The resulting families may or may not have any children.



Child of family - identifies the family unit of which the current person is a child. A person may or
may not be the child of a family.



Child - a person who appears in the list of children of the current family.



Mother - a person who is identified as the mother of the current family.



Father - a person who is identified as the father of the current family.



Alias - an alternative name for a person along with the date on which the alias was adopted.
Characters are converted to uppercase for the surname. Aliases are useful, for example, where a
person was commonly known by a name which was not their name at birth. You can use the alias
to look up the person in an printed index or selection dialog.



Object - a piece of information (typically a drawing, picture, slide, sound etc) which has been
created by a separate application and which has been embedded in or linked to a person or

family. You can use an object from any application which supports OLE (Object Linking and
Embedding).



System menu - also called the Control Menu. Each window has small pop-up menu with
commands to control the appearance of the window; usually Close, Maximise, Move, etc. The
Objects and Notes dialogs have had extra commands added to their system menus. To access a
window's system menu in Win3.1 click on the minus sign in the top left corner of the window. In
Win95 click on the icon in the top left corner or click the right mouse button on the caption bar at
the top of the window.



Linking - Linking an object to a person or family involves copying your selected object from
another application onto the clipboard and then pasting the link into the person's or family's
objects list. The primary difference between linking and embedding is the location of the actual
data for the object. The data for a linked object is stored outside the tree file in a separate source
document, eg. a .BMP file for Paintbrush.



Embedding - Embedding an object in a person or family involves copying your selected object
from another application onto the clipboard and then pasting it into the person's or family's
objects list or creating a new object directly. The primary difference between embedding and
linking is the location of the actual data for the object. The data for an embedded object is stored

inside the tree file.



How to contact us
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By mail: Nick ] Hunter
SpanSoft
11 Rowan Terrace
COWDENBEATH
Fife KY49)z
Scotland
By telephone: National: (01383) 510597

By E-Mail:
Web page:

International: +44 1383 510597

Voice and fax available 24hrs on this number.
If sending a fax ensure that your fax sends a
handshake tone immediately so that our phone
system knows it is not a voice call.

Calls by voice may be answered by machine.

100101.1155@compuserve.com
http://ourworld.compuserve.com/homepages/SpanSoft

SpanSoft is a member of the ASP.



Registration

Kith and Kin is a shareware product. This version has been provided so that you may evaluate its
features and suitability for a trial period of 30 days without payment. We hope that you enjoy
using it and that you will find it of use. In the event that you wish to continue using it after 30
days you must become a registered user.

The registration fee is £28. For this you will receive the latest registered version (without all the
boring shareware reminders), a file conversion program which allows you to use your data files
with the latest version, the full timeline events file (British history from 800AD to present day)
plus a timeline generator utility for creating your own timeline events, access to telephone
support, periodic notification of future releases and discounts on upgrades.

Special offer!
Register Kith and Kin and TreeDraw and receive both for only £38.
Find details of TreeDraw in the Help menu under Other Products.

SpanSoft supports the British Diabetic Association. £0.50 from every Kith and Kin
registration is donated to the BDA's Diabetes 2001 fund. The BDA is a charity helping people with
diabetes and supporting diabetes research, Charity Reg. No. 215199.

Click on the most convenient payment method from the following choices.

You can register on-line if you are a CompuServe member.

Alternatively, select from the list below if you live in:

ZhS Uk

EG erman
=T he Netherlands

USA

C

Australia

New Zealand

Rest of the World

Only with your financial support will | be able to provide you with upgrades and produce more
quality software. Without your support | will not be able to do so.

The survival of this program and of the shareware concept in general depends on your honesty.

See also: How to contact us and Terms of use.






Registering in the UK
Select payment method:

SC(E)

T
Credit card (Visa / MasterCard / Eurocard / Access / Delta)



Registering in the USA

Select payment method:

Check (US Dollars)

"-1.~'.l. l"'"‘

Credit card (Visa / MasterCard / Amex / Discover




Registering in the rest of the World

Select the country closest to you from this list:
USA, Australia, New Zealand, Germany, The Netherlands

or select payment method:

Bl S

Credit card (Visa / MasterCard / Eurocard / Access / Delta)

Check (US Dollars)



Registering on-line via CompuServe

If you are a CompuServe (CIS) member, you can register and pay the registration fee using the
CompuServe Shareware Registration Service.

Prices ($US):

Kith and Kin -
registration fee $48
shipping $4
CIS reg ID: 2537

Kith and Kin + TreeDraw (special offer price)
registration fees $65
shipping $4
CIS reg ID: 3201

Log onto CompuServe in the normal way and enter SWREG using Services|Go in WinCIM or at any
I prompt type GO SWREG. Use the appropriate CIS Registration ID above. Please follow the
instructions on-screen.

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Your registered copy of the latest version of Kith and Kin (and TreeDraw if you order it) will be
despatched air mail from SpanSoft within 2 working days of your request being entered onto
CompuServe. Delivery is normally around 1 week to most parts of the world but please allow at
least 2 weeks.

Prices correct at December 1996 for V3.11 but registration for later releases may be subject to price increases. Please check current
prices on CIS.



Order - Kith and Kin

Please print this order using Print Topic and mail to:

SpanSoft

11 Rowan Terrace
COWDENBEATH
Fife KY49)zZ
Scotland

Please send me the latest registered version of Kith and Kin at £28.

Please send me the latest registered versions of Kith and Kin and TreeDraw at £38.
(delete as appropriate)

| enclose a cheque/PO/cash for the registration fee(s) of £

Please make cheques/POs payable to SpanSoft.

Overseas customers please add £2 to cover shipping outside the UK and pay in pounds Sterling
only (notes or UK funds drawn on a UK bank).

Name Mr/Mrs/Miss/Ms

Address

Postcode

Country

Phone

E-mail

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Prices correct at December 1996 for V3.11 but registration for later releases may be subject to price increases.



Order - Kith and Kin

Please print this order using Print Topic and mail to:

SpanSoft

11 Rowan Terrace
COWDENBEATH
Fife KY49)zZ
Scotland

Please send me the latest registered version of Kith and Kin at $48.
Please send me the latest registered versions of Kith and Kin and TreeDraw at $65.
(delete as appropriate)

Add $4 shipping & handling.

| enclose a cheque for $ us
Please make checks payable to SpanSoft and pay in US$.

Name Mr/Mrs/Miss/Ms

Address

Zipcode

Country

Phone

E-mail

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Prices correct at November 1996 for V3.11 but registration for later releases may be subject to price increases.



Credit Card Order (UK) - Kith and Kin

Please print this order using Print Topic and mail to:

SpanSoft

11 Rowan Terrace
COWDENBEATH
Fife KY49)zZ
Scotland

or phone or fax with your credit card details:
(01383) 510597

or E-mail with your credit card details:
Internet: 100101.1155@compuserve.com

Please send me the latest registered version of Kith and Kin at £28.
Please send me the latest registered versions of Kith and Kin and TreeDraw at £38.
(delete as appropriate)

Please charge my Access/MasterCard/Visa/Eurocard/Delta card with £

Name Mr/Mrs/Miss/Ms

Address

Postcode

Phone

E-mail

Card no.

Expiry date

Signature

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

(A separate order form is available for overseas customers)

Prices correct at December 1996 for V3.11 but registration for later releases may be subject to price increases. Name and address
above must match those of your credit card. We regret that we cannot accept credit card orders for delivery to PO Box numbers.



Credit Card Order (Overseas) - Kith and Kin

Please print this order using Print Topic and mail to:

SpanSoft

11 Rowan Terrace
COWDENBEATH
Fife KY49)zZ
Scotland

or fax this form to:
+44 1383 510597

Please send me the latest registered version of Kith and Kin at £28.

Please send me the latest registered versions of Kith and Kin and TreeDraw at £38.
(delete as appropriate)

Add £2 shipping & handling.

Please charge my Access/MasterCard/Visa/Eurocard/Delta card with £ pounds Sterling

Name Mr/Mrs/Miss/Ms

Address

Postcode

Country

Phone

E-mail

Card no.

Expiry date

Signature

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Prices correct at December 1996 for V3.11 but registration for later releases may be subject to price increases. Name and address
above must match those of your credit card. We regret that we cannot accept credit card orders for delivery to PO Box numbers. We
regret that we cannot accept orders by phone or E-mail from outside the UK since we must receive a valid signature.



Credit Card Order - Kith and Kin

Please print this order using Print Topic and mail to:

Public (software) Library
PO Box 35705

Houston

TX 77235-5705

USA

or FAX this form to:
713-524-6398 (for orders only)

or phone with your credit card details:
800-242-4775 or 713-524-6394 (both numbers for orders only : 0700-1800 CST Mon-
Thurs, 0700-1230 CST Fri)

Please send me the latest registered version of Kith and Kin at $48 (PsL product number:
#11528).

Please send me the latest registered versions of Kith and Kin and TreeDraw at $65 (PsL
product numbers: #11528 & #11172).

(delete as appropriate)
Add $4 shipping & handling.

Please charge my credit card (Visa/MasterCard/Amex/Discover) with $ uUs.

Name Mr/Mrs/Miss/Ms

Address

Zipcode

Country

Phone

E-mail

Card no.

Expiry date

Signature

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.



Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, PsL will notify us
the day of your order and we will ship the product direct. Please allow two weeks for delivery. Name and address above must match

those of your credit card. Prices correct at December 1996 for V3.11 but registration for later releases may be subject to price
increases.



Order - Of that llk

(Kith and Kin is known as "Of that Ilk" in Australia and New Zealand)
Please print this order using Print Topic and mail to:

Budgetware

PO Box 496
Newtown NSW 2042
Australia

or FAX this form with your credit card details to:
(02) 516-4236

or phone with your credit card details:
(02) 519-4233

Please send me the latest registered version of Of that Ilk at $65.

Please send me the latest registered versions of Of that Ilk and TreeDraw at $87.
(delete as appropriate)

Add $6 shipping & handling.
| enclose a cheque / money order for $ Australian payable to Budgetware.

Please charge my credit card (Visa/MasterCard) with $ Australian.
(delete as appropriate)

Name Mr/Mrs/Miss/Ms

Address

Postcode

Country

Phone

E-mail

Card no.

Expiry date

Signature

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, Budgetware will
notify us the day of your order and we will ship the product direct. Please allow two weeks for delivery. If paying by credit card,
name and address above must match those of your card. Prices correct at December 1996 for V3.11 but registration for later



releases may be subject to price increases.



Order - Of that llk

(Kith and Kin is known as "Of that Ilk" in Australia and New Zealand)
Please print this order using Print Topic and mail to:

Simply Shareware Ltd
PO Box 229
Masterton 5901

New Zealand

or FAX this form with your credit card details to:
(06) 378-9915

or phone with your credit card details:
(06) 378-9916

Please send me the latest registered version of Of that Ilk at $65.

Please send me the latest registered versions of Of that Ilk and TreeDraw at $87.
(delete as appropriate)

Add $6 shipping & handling.
| enclose a cheque / money order for $ NZ payable to Simply Shareware Ltd.

Please charge my credit card (Visa/MasterCard/Bankcard/Diners/Amex) with $ NZ.
(delete as appropriate)

Name Mr/Mrs/Miss/Ms

Address

Postcode

Country

Phone

E-mail

Card no.

Expiry date

Signature

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, Simply
Shareware will notify us the day of your order and we will ship the product direct. Please allow two weeks for delivery. If paying by
credit card, name and address above must match those of your card. Prices correct at December 1996 for V3.11 but registration for



later releases may be subject to price increases.



Bestellung - Kith and Kin

Please print this order using Print Topic and mail to:

JDS - Software )Jens Driese
Postfach 1269

D-26302 Varel
Deutschland

Tel.: 04451 959195
Fax: 04451 959196
CIS: 100273,2252
BTX: DRIESE#

Bestellung:
[ ] Kith and Kin 66,00 DM
[ ] Kith and Kin und TreeDraw 89,00 DM

Porto- und Verpackingskosten (Post) + 5,00 DM

Zuschlage:
Gesamtbetrag = DM

[ 1Verrechnunsscheck liegt bei.

[ 1Lastschrifteinzug:
Ich/wir ermachtige/n die Fa. JDS-Software Jens Driese den Rechnungsbetrag von u.g. Konto
abzubuchen.

KtoNr: BLZ:
Bank:
Die Allgemeinen Geschaftsbedingungen erkenne ich an.

Unterschrift

Name
StraRe u. Nr.

PLZ + Wohnort

Tel./Fax
E-mail

Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, JDS will notify us
the day of your order and we will ship the product direct. Please allow two weeks for delivery. If paying by credit card, name and
address above must match those of your card. Prices correct at December 1996 for V3.11 but registration for later releases may be
subject to price increases.



Bestelling - Kith and Kin

Druk dit formulier af door gebruik te maken van Print Topic.
Stuur het ingevulde formulier naar:

C.S.D. - Computer Solutions Dorth
Postbus 59

NL-7213 ZH GORSSEL

Nederland

of, wanneer u gebruik maakt van een Credit Card:
FAX naar 057.549.1222
BEL naar 057.549.4545

Stuur mij de meest recente versie van:
[ IKith and Kin voor f1.93,-
[ ]Kith and Kin en TreeDraw voor f1.122,-

Alle bedragen zijn inclusief administratie- en verzendkosten en 17,5% BTW.

Bovenstaand bedrag voldoe ik vooruit op de volgende wijze:
[ lvia Postgirorekening nr. 27.47.162, C.S.D., Gorssel
[ lvia bankrekening ABN-Amro nr. 49.85.42.173, C.S.D., Gorssel
[ I(alleen in Belgie) per bank op rekening BBL-Brussel nr. 310.095.966.533

—

1 per Credit Card: AmEx / Diners / Euro-Master / Visa
Kaart nummer: Geldig tot: _ /
op nhaam van (indien afwijkend van besteller):

Handtekening:

—

]door bijsluiting van een volledig ingevulde en ondertekende Euro- of PostGiro-cheque.

Naam (M/V)
Adres

Postcode Plaats
Land
Telefoon (uitsluitend t.b.v. ordercontrole)

E-mail

De software wordt geleverd op 3,5" diskette.

Alle vragen betreffende orderstatus, registratieopties, produkt details, technische ondersteuning, site licenses, volume discounts,
dealer pricing, etc. dient u te richten aan SpanSoft. Om zeker te zijn dat u de laatste versie ontvangt, verwerkt C.S.D. op de dag van
uw betaling uw bestelling. Het programma wordt rechtstreeks door de auteur aan u verzonden. Levering vindt in principe binnen 2



weken plaats. Betaalt u per CreditCard, dan dienen de gegevens hierboven overeen te komen met die op de kaart. Prijzen gelden
voor versie 3.11 (December 1996). Prijswijzigingen voor nieuwere versies voorbehouden.



Terms of use
TRIAL USE LICENCE

Kith and Kin is NOT freeware or public domain software, it is shareware. This software,
associated on-line help and accompanying documentation are copyright © SpanSoft 1993-1996
and are protected by international copyright laws. BWCC.DLL is copyright © Borland International
1991-93.

SpanSoft grants you a limited licence to try out this software on your own system, in your own
working environment for a limited period of 30 days. If you decide that the software is suitable for
your needs and you wish to continue using it after this time, you must become a registered user
and pay the appropriate registration fee to SpanSoft. This simply means that you are allowed to
defer payment for the software until after you have decided that you want it. If, after 30 days,
you decide that you do not wish to continue using this program you must delete it from your
system.

You are free (and encouraged) to copy and distribute this version of the software to others on
condition that you include all the files on your distribution disk and that you adhere to the terms
of the limited distribution licence.

You may not use, copy, rent, lease, sell, modify, decompile, disassemble, otherwise reverse
engineer, or transfer the licensed program except as provided in this agreement. Any such
unauthorised use shall result in immediate and automatic termination of this licence. All rights
not expressly granted here are reserved by SpanSoft.

By using this software you are agreeing to the terms of this licence. If you do not agree to these
conditions, delete this software from your computer.

LIMITED DISTRIBUTION LICENCE

You may distribute this version of Kith and Kin, completely unaltered and including all the files (as
listed below), without further permission on condition that:

1) You identify it as shareware.
2) You leave all intellectual property (copyright) notices in place.
3) SpanSoft does not request that you stop distribution.

To distribute in modified form, you must consult the appropriate data record in the included
VENDINFO.DIZ file, which is hereby incorporated by reference. Any distribution satisfying all the
distribution requirements expressed in that data record is hereby authorised.

Permission to distribute the Kith and Kin package is not transferable, assignable, saleable, or
franchisable. Each person or organisation wishing to distribute the package must independently
satisfy the terms of this limited distribution licence.

Kith and Kin should not be distributed in Australia or New Zealand. The same product under the
name "Of that IIk" is available from SpanSoft or from Budgetware, PO Box 496, Newtown NSW
2042, Australia; phone (02) 519-4233, fax (02) 516-4236.

SpanSoft may revoke any permissions granted here, by notifying you in writing. All rights not
expressly granted here are reserved by SpanSoft.

Complete file list:
KITHKIN.EXE Kith and Kin program
KITHKIN.HLP Kith and Kin help file
KITHKIN.OPT Kith and Kin options file



KITHKIN.INI Kith and Kin date descriptors and report strings

BWCC.DLL Borland custom class DLL

SS DATE.DLL SpanSoft date processing DLL
TIMELINE.TML Historical event file

KITHKIN.TXT Kith and Kin manual in text format
SAMPLE.TRE Sample tree file

CATALOG.HLP SpanSoft product catalogue
FILE_ID.DIZ BBS file description
VENDINFO.DIZ Vendor / BBS information
README.TXT User information

VENDOR.TXT Vendor information

LIMITED WARRANTY
Please read carefully.
THIS SOFTWARE IS PROVIDED FOR EVALUATION ONLY, ON AN "AS IS" BASIS.

SPANSOFT DISCLAIMS ALL WARRANTIES RELATING TO THIS SOFTWARE, WHETHER EXPRESSED OR
IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE. NEITHER SPANSOFT NOR ANYONE ELSE WHO HAS BEEN
INVOLVED IN THE CREATION, PRODUCTION, OR DELIVERY OF THIS SOFTWARE SHALL BE LIABLE
FOR ANY INDIRECT, CONSEQUENTIAL OR INCIDENTAL DAMAGES ARISING OUT OF THE USE OR
INABILITY TO USE SUCH SOFTWARE, EVEN IF SPANSOFT HAS BEEN ADVISED OF THE POSSIBILITY
OF SUCH DAMAGES OR CLAIMS.

THE PERSON USING THIS SOFTWARE BEARS ALL RISKS AS TO THE QUALITY AND PERFORMANCE
OF THE SOFTWARE. ALTHOUGH THIS SOFTWARE HAS BEEN EXTENSIVELY TESTED, IT IS YOUR (THE
USER'S) RESPONSIBILITY TO DETERMINE IF IT WILL WORK RELIABLY ON YOUR EQUIPMENT AND IN
YOUR COMPUTING ENVIRONMENT.

Remember. Always keep up-to-date backup copies of all your data files.






