Program Plánovač úloh

Program Plánovač úloh môžete použiť, ak chcete naplánovať spustenie príkazov, programov alebo skriptov v stanovených termínoch.

  • Pred použitím programu Plánovač úloh pozrite Zoznam akcií.
  • Ak potrebujete pomôcť s konkrétnymi úlohami, pozrite Návod.
  • Základné všeobecné informácie nájdete v časti Základné koncepcie.
  • Návod na riešenie problémov nájdete v časti Riešenie problémov.


Zoznam akcií v programe Plánovač úloh

Zoznam akcií

Nasledovná tabuľka obsahuje zoznam akcií, ktoré najčastejšie vykonávate pomocou programu Plánovač úloh. Úplný návod k programu Plánovač úloh nájdete v časti Návod.

Krok | Vysvetlenie
Predtým, ako môžete naplánovať spustenie úlohy, musíte ju pridať. | Naplánovanie novej úlohy
Po vytvorení plánovaných úloh môžete zmeniť program, plán alebo špecifiká konkrétnej úlohy. | Úprava plánovanej úlohy
Plánované úlohy, ktoré už nepotrebujete, môžete úplne odstrániť. | Odstránenie plánovanej úlohy
Ak sa plánovaná úloha spustí v čase, keď pracujete na počítači, môžete ju zastaviť a neskôr znova spustiť. | Zastavenie spustenej plánovanej úlohy
Všetky plánované úlohy môžete dočasne zastaviť alebo pozastaviť a neskôr ich pozastavenie zrušiť. | Dočasné zastavenie všetkých plánovaných úloh


Návod na…

  • Naplánovanie úloh
  • Riadenie programu Plánovač úloh


Naplánovanie úloh
  • Spustenie programu Plánovač úloh
  • Naplánovanie novej úlohy
  • Úprava plánovanej úlohy
  • Odstránenie plánovanej úlohy
  • Zastavenie spustenej plánovanej úlohy
  • Okamžité spustenie úlohy


Spustenie programu Plánovač úloh

  • Program Plánovač úloh spustíte dvojitým kliknutím na ikonu Tento počítač (My Computer) a následným dvojitým kliknutím na ikonu Plánované úlohy.
  • Dvakrát kliknite na ikonu Plánované úlohy, potom dvakrát na ikonu Pridať plánovanú úlohu. Otvorí sa Sprievodca plánovanou úlohou, ktorý vás prevedie plánovaním úlohy.


Naplánovanie novej úlohy
  1. Spustite program Plánovač úloh.
  2. Dvakrát kliknite na ikonu Pridať plánovanú úlohu.
  3. Postupujte podľa pokynov sprievodcu pridaním plánovanej úlohy.

Poznámky:

  • Ak chcete vykonať konfiguráciu rozšírených nastavení pre úlohu, začiarknite začiarkavacie políčko Otvoriť rozšírené vlastnosti pre úlohy po kliknutí na tlačidlo Dokončiť na poslednej obrazovke sprievodcu.
  • Ak chcete úlohu pri každom spustení spúšťať opakovane, začiarknite na poslednej obrazovke sprievodcu začiarkavacie políčko Otvoriť rozšírené vlastnosti pre úlohy po kliknutí na tlačidlo Dokončiť, kliknite na kartu Plán a tlačidlo Spresniť.
  • Ak program spúšťaný úlohou vyžaduje parametre, začiarknite na poslednej obrazovke sprievodcu začiarkavacie políčko Otvoriť rozšírené vlastnosti pre úlohy po kliknutí na tlačidlo Dokončiť, potom kliknite na kartu Úloha a parametre napíšte do poľa Spustiť za cestou k programu.
  • Uistite sa, že systémový dátum a čas počítača je presne nastavený. Program Plánovač úloh spúšťa plánované úlohy na základe uvedených informácií. Ak chcete skontrolovať alebo zmeniť dátum a čas, dvakrát kliknite na čas na paneli úloh.


Úprava plánovanej úlohy
  1. Spustite program Plánovač úloh.
  2. Kliknite pravým tlačidlom myši na úlohu, ktorú chcete upraviť, a potom kliknite na príkaz Vlastnosti.
  3. Vykonajte jednu alebo viaceré z nasledovných akcií:
    • Ak chcete zmeniť spúšťaný program, v poli Spustiť zadajte cestu k novému programu.
    • Ak chcete zmeniť plánovanie úlohy, kliknite na kartu Plán.
    • Ak chcete prispôsobiť nastavenia úlohy, kliknite na kartu Nastavenia.

Poznámky:

  • Ak zmeníte konto používateľa alebo spúšťaný program, musíte pre konto používateľa zadať heslo.
  • Ak program spúšťaný úlohou vyžaduje parametre príkazového riadka, zadajte ich v poli Spustiť za cestou k programu.
  • Ak cesta k programu obsahuje medzery, vložte ju celú do dvojitých úvodzoviek ("").
  • Uistite sa o presnosti systémového dátumu a času počítača, keďže program Plánovač úloh spúšťa plánované úlohy na základe uvedených informácií. Ak chcete tieto informácie skontrolovať alebo zmeniť, dvakrát kliknite na indikátor času na paneli úloh.


Odstránenie plánovanej úlohy
  1. Spustite program Plánovač úloh.
  2. Kliknite pravým tlačidlom myši na úlohu, ktorú chcete odstrániť, a potom kliknite na príkaz Odstrániť.

Poznámky:

  • Odstránením plánovanej úlohy sa odstráni len plán zo zoznamu plánov. Programový súbor sa z pevného disku neodstráni.
  • Plánovanú úlohu môžete odstrániť aj stlačením klávesu DELETE.


Zastavenie spustenej plánovanej úlohy
  1. Spustite program Plánovač úloh.
  2. Kliknite pravým tlačidlom myši na úlohu, ktorú chcete zastaviť, a potom kliknite na príkaz Ukončiť úlohu.

Poznámky:

  • Ak plánovaná úloha spúšťa ďalší program, tento príkaz zastaví len pôvodnú plánovanú úlohu, nie druhú úlohu.
  • Ak chcete znova spustiť zastavenú úlohu, kliknite pravým tlačidlom myši na úlohu a potom kliknite na príkaz Spustiť.


Okamžité spustenie úlohy
  1. Spustite program Plánovač úloh.
  2. Kliknite pravým tlačidlom myši na úlohu, ktorú chcete spustiť, a potom kliknite na príkaz Spustiť.

Poznámky:

  • Úlohu môžete zastaviť kliknutím na príkaz Ukončiť úlohu v ponuke Súbor.
  • Ak sa plánovaná úloha nespustila, v ponuke Spresniť kliknite na príkaz Zobraziť denník a skontrolujte denník úlohy.


Riadenie programu Plánovač úloh
  • Zobrazenie denníka v minulosti plánovaných úloh
  • Zobrazenie plánovaných úloh na vzdialených počítačoch
  • Dočasné zastavenie všetkých plánovaných úloh
  • Pozastavenie programu Plánovač úloh
  • Nastavenie konta služby At


Zobrazenie denníka v minulosti plánovaných úloh
  1. Spustite program Plánovač úloh.
  2. V ponuke Spresniť kliknite na príkaz Zobraziť denník.


Zobrazenie plánovaných úloh na vzdialených počítačoch
  1. Na pracovnej ploche dvakrát kliknite na ikonu Počítače v tejto sieti (My Network Neighborhood).
  2. Dvakrát kliknite na počítač, ktorého plánované úlohy chcete zobraziť.
  3. Kliknite na ikonu Plánované úlohy.

Poznámky:

  • Úlohy na vzdialenom počítači, ktorý pracuje v systéme Windows, môžete zobraziť len vtedy, ak ste jeho správcom.
  • Úlohy na vzdialenom počítači, ktorý pracuje v systéme Windows, môžete upraviť len vtedy, ak má nainštalovanú vzdialenú databázu Registry a zdieľa x$, kde x predstavuje pevný disk, na ktorom je umiestnený priečinok Plánované úlohy. Počítač pracujúci v systéme Windows musí mať tiež konkrétne zaznamenané, že vaše konto používateľa má prístup pomocou vzdialenej databázy Registry. Po kliknutí na ikonu Heslá (Passwords) v okne Ovládací panel (Control Panel) môžete určiť, ktorí používatelia majú prístup pomocou vzdialenej databázy Registry k počítaču pracujúcemu v systéme Windows.


Dočasné zastavenie všetkých plánovaných úloh
  1. Spustite program Plánovač úloh.

  2. V ponuke Spresniť kliknite na príkaz Pozastaviť program Plánovač úloh.

Poznámky:

  • Použitie tohto príkazu je vhodné, ak je spustený ďalší program (napr. hra) alebo inštalácia softvéru a nechcete, aby sa v rovnakom čase spustili aj plánované úlohy.
  • Úlohy, ktoré sa majú spustiť počas pozastavenia programu Plánovač úloh, sa spustia až v najbližšom plánovanom termíne.
  • Ak chcete obnoviť plánovanie všetkých úloh, v ponuke Spresniť kliknite na príkaz Pokračovať v programe Plánovač úloh.


Pozastavenie programu Plánovač úloh
  1. Spustite program Plánovač úloh.
  2. V ponuke Spresniť kliknite na príkaz Zastaviť program Plánovač úloh.

Poznámka:

  • Po vypnutí programu Plánovač úloh sa plánované úlohy nespustia a program sa pri ďalšom spustení systému Windows nespustí automaticky.


Nastavenie konta služby AT
  1. Spustite program Plánovač úloh.
  2. V ponuke Spresniť kliknite na príkaz Konto služby AT.
  3. Kliknite na príkaz Toto konto a zadajte konto používateľa, ktoré spustí úlohy naplánované pomocou príkazu at.
  4. V poliach Heslo a Potvrdiť heslo zadajte správne heslo konta.

Poznámky:

  • Služba AT je dostupná len v systéme Windows NT.
  • Môžete tiež kliknúť na Systémové konto. Ak to urobíte, program Plánovač úloh spustí úlohy naplánované pomocou príkazu at použitím konta lokálneho systému, čo vyžaduje oprávnenia správcu.

  • Zadané konto používateľa musí mať príslušné povolenia na spustenie akýchkoľvek úloh, ktoré naplánujete pomocou príkazu at. Napríklad, ak naplánujete programy, ktoré môžu spustiť len správcovia, ako konto používateľa musíte zadať konto správcu.


Základné koncepcie programu Plánovač úloh

Základné koncepcie

Táto časť poskytuje základné všeobecné informácie o programe Plánovač úloh:

  • Úvod do programu Plánovač úloh
  • Práca s programom Plánovač úloh
  • Program Plánovač úloh a príkaz At
  • Zabezpečenie v programe Plánovač úloh
  • Riešenie problémov


Úvod do programu Plánovač úloh

Pomocou programu Plánovač úloh môžete naplánovať spustenie úloh (napr. defragmentáciu disku) v čase, ktorý vám najviac vyhovuje. Program Plánovač úloh sa spúšťa pri každom spustení systému Windows a pracuje na pozadí.

Pomocou programu Plánovač úloh môžete:

  • naplánovať spustenie úlohy denne, týždenne, mesačne alebo v konkrétnom čase (napr. pri štarte systému),
  • zmeniť plánovanie úlohy,
  • zastaviť plánovanú úlohu,
  • prispôsobiť spustenie úlohy v plánovanom čase.


Práca s programom Plánovač úloh

Operačný systém Windows automaticky inštaluje program Plánovač úloh. Ak chcete vykonať plánovanie, dvakrát kliknite na priečinok Plánované úlohy v okne Tento počítač (My Computer).

Úlohy môžete pridať dvojitým kliknutím na ikonu Pridať plánovanú úlohu, čím sa spustí Sprievodca plánovanou úlohou. Úlohy možno pridať aj presunutím skriptov, programov alebo dokumentov z Prieskumníka (Windows Explorer) alebo pracovnej plochy do okna Plánované úlohy.

Program Plánovač úloh možno použiť aj na úpravu, odstránenie, pozastavenie alebo zastavenie plánovaných úloh, zobrazenie denníka v minulosti plánovaných úloh, alebo zobrazenie úloh plánovaných na vzdialenom počítači.

Podrobný návod na prácu s programom Plánovač úloh nájdete v časti Návod.

Užitočné postupy pre program Plánovač úloh

V operačnom systéme Windows môžete pomocou programu Plánovač úloh naplánovať spustenie ľubovoľnej aplikácie. Uistite sa o presnosti systémového dátumu a času počítača pred tým, ako pridáte úlohu, aby ste tak čo najefektívnejšie využili možnosti programu Plánovač úloh.


Používanie programu Plánovač úloh a príkazu at

Program Plánovač úloh a príkaz At

Na automatické spúšťanie úloh môžete okrem programu Plánovač úloh použiť aj príkaz at.

Program Plánovač úloh nie je totožný s príkazom at, ale oba navzájom spolupracujú. Keď plánujete úlohu pomocou príkazu at, zobrazí sa v zozname úloh v okne programu Plánovač úloh.

Pomocou programu Plánovač úloh môžete upraviť vlastnosti úlohy, ktorá bola naplánovaná pomocou príkazu at. Ak však vlastnosti úlohy upravíte pomocou programu Plánovač úloh, budete k nej mať ďalej prístup len pomocou tohto programu. Pomocou príkazu at k nej už nebudete mať prístup.

Ak chcete zadať konto používateľa, ktoré spustí úlohy plánované pomocou príkazu at, v okne Tento počítač (My Computer) kliknite na ikonu Plánované úlohy a v ponuke Spresniť na príkaz Konto služby AT.

Poznámka:

  • Služba AT je dostupná len v systéme Windows NT.


Zabezpečenie v programe Plánovač úloh

V programe Plánovač úloh môžete nastaviť zabezpečenie tak, že konkrétnej úlohe priradíte meno používateľa a heslo. Po nastavení mena používateľa a hesla nemôže ďalší používateľ úlohu zrušiť alebo odstrániť.

Poznámky:

  • Toto zabezpečenie je k dispozícii len v systéme Windows NT.
  • Pred pokračovaním v plánovaní úlohy musíte zadať meno používateľa v Sprievodcovi plánovanou úlohou. Zadanie hesla sa nevyžaduje.
  • Nové heslo môžete zmeniť alebo nastaviť začiarknutím začiarkavacieho políčka Otvoriť rozšírené vlastnosti pre úlohy po kliknutí na tlačidlo Dokončiť na záverečnej obrazovke sprievodcu.


Riešenie problémov v programe Plánovač úloh

Ak sa plánovaná úloha nespustí v očakávanom čase, kliknite pravým tlačidlom myši na úlohu a potom kliknite na príkaz Vlastnosti. Overte, či je na karte Úloha začiarknuté začiarkavacie políčko Aktivovaná. Overte, či je na karte Plán správne nastavené plánovanie úlohy.

Ak sa plánovaný program nespustí správne, bude možno potrebné pridať parametre príkazového riadka. Ak sa chcete dozvedieť viac o konkrétnom programe a jeho parametroch príkazového riadka, skúste vykonať jednu z nasledovných akcií:

  • Prezrite si Pomocníka on-line pre program, ak je k dispozícii.

  • V príkazovom riadku zadajte nasledovné: (pričom program predstavuje názov programu)

    • program /?


Komponent systému Windows NT nie je nainštalovaný

Tento program sa nemohol spustiť.

Možné príčiny:

    • Správca systému odstránil program.
    • Správca systému zmenil politiku pridruženú k súboru.
    • Program nie je nainštalovaný na počítači.
    • Program bol neúmyselne odstránený.
    • Súbor je poškodený.

Ak váš počítač riadi správca systému, obráťte sa naňho, aby sa zistilo, prečo nemôžete spustiť program.