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Private Music Collection 

Private Music Collection is a database to gather information about your Music Collection. Private Music 
Collection is meant for use at home. It can cointain up to 8000 records. 

You can use Private Music Collection together with MC Cover Builder. MC Cover Builder supports the 
database made by Private Music Collection. 
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For questions or suggestions you can E-mail me at avdlogt@worldaccess.nl. Please use PMC in your 
subject line. For more details about updates and other applications check out my homepage 
http://www.tomb.demon.nl. 



The database

Creating a database 

When you start Private Music Collection for the first time you'll have to create a new database. You can 
create a database by clicking the NEW button or selecting New from the menu option File. Choose the 
directory where you want to create the database and enter a filename using eight caracters. An extension 
is not needed. 

Opening a database 

To open an excisting database, click on the Open button or select Open from the menu option File. Then 
select the diretory where the database is located and select the database or enter it's name. 

Closing a database 

Before you can open or create a database you must close the database that is currently open. To close 
your database Click the Close button or select Close from the menu option File. 

PMC will close the database automaticly when you Exit PMC. Do NEVER shut down the computer 
without closing the database. You may lose information or even loose the whole database because the 
index file is loaded into the memory of your computer. 

General 
The database of PMC needs three files: the index named <database>.ndx, <database>.alb containing the
general information about your albums and <database>.sng with information about the songs on the 
albums. Every record in the database will use about 1.5 kB diskspace (depending on the amount of 
songs). The images you can display in PMC are always displayed at a size of 125 x 125 pixels. A 
Windows BMP image of 125 x 125 pixels will use about 50 kB diskspace. You can save diskspace by 
using a small pallette or by saving the image at 100 x 100 pixels. 



Records

General 
The records of Private Music Collection are stored in two databases. The general information is stored in 
the <database>.alb file the information in the songlist is stored in the <database>.sng file. The index is 
used to sort the records and to link the records in the album file and the song file. 

Inserting a new record 

Before you can enter the data of a new record you'll have you click on the Insert button. Otherwise you 
will overwrite the data of the record currently displayed. When you click on the Insert button you get an 
empty screen. You must enter the fields Artist and Title before you can save the record. Before you can 
enter the songs you must enter the soundcarrier and the number of disks or tapes on the Details tab. 

Editing a record 

You can always change a record. Search the record you want to change and enter the field you want to 
change. Before you can save the record, you must enter the name of the Artist and the Title of the album. 

You can select the Genre from the list in the combo box, but you can also enter it yourself. If you have 
registered your copy of PMC you are able to edit your Genre list in the menu Options. 

You can enter the number of disks of tapes of an album. If you enter the number of disks or tapes you can
specify on which Disks or tape a song is located. 

You can use the field ID number for the ID number of the album or for your own code for this album. 

The Obtained by field is meant to specify from whom you got this album if you need to. For example to 
remember who recorded a tape for you. Then you know who to turn to when you lose this tape. 

When you have an album with songs from multiple atrists you can check the Show Artist Of Song box. 
Now you can enter the artist of each song in the songlist. This box can be checked by default when you 
choose so in the Options menu. 

Inserting an image to the record 

You can enter the filename of an image of the cover of an album. The filename can't be longer than eight 
caracters and the image has to be of the Windows bitmap format. The images must be in the same 
directory as the database they belong to. In the registered version of PMC you can select an image by 
clicking on the button at the right of the field where you must enter the filename. When an image is 
missing PMC won't prompt you it just can't show the image. You can give friends a copy of your database 
without the images. 

The songlist 
To enter the songs you must select the Soundcarrier and give the number of disks or tapes. It's also 
possible to insert more songs afterward if you want to. If you forgot a song then you can insert it between 
two other songs by pressing <SHIFT>-<INSERT>. To delete a song you can press <SHIFT>-<DELETE>. 

Sorting the records 

You can sort the records by clicking the Sort button. When you select Sort at close in the Options menu, 
PMC will sort the records when you close the database. When you use it as your default option you are 
always sure that your database is sorted when you open it. In the Options menu you can choose to sort 
the albums of an artist by alphabetic order of the title or by release date. When you choose one of these 



make sure to make it permanent for later sessions by selecting Save settings in the Options menu. 

Deleting, undeleting and purging records 

You can delete a record by clicking on the delete button. The record will no longer be shown in the 
database, although it still exists. You can view and select the deleted records on the tab Deleted Records.

You can undelete a record by selecting it from the list of deleted records. When you select a deleted 
record it's data will be shown together with the warning that it is an deleted record. The Undelete button 
will also be enabled and when you click it the current record wil be undeleted. 

To remove a record from your database you have to delete it. Be sure that you have selected Purge at 
Close in the menu Options. Now when you close the database all deleted records will be removed from 
the database. When you don't select Purge at close all deleted records will be kept save in the database. 



Searching

Searching records 

To look up a record click the Search button. A dialogbox will open where you can enter the searchstring 
and the field to search. The options Artist and Title are the fastest way to search the database. The other 
options are slower because PMC has to read from the disk for these options. You can also enable search 
in deleted records if you want to. All records found will be placed in the Search list and unless you check 
the 'Don't prompt' box you get a prompt for every matching record. 

You can export the Searchlist to ASCII or print the searchlist. 



Printing and exporting data

Selecting a font for your pinter 

PMC enables you to select a font for your printer. To do so Select Printer Font in the File menu. All your 
installed fonts can be selected at a fontsize of 10 to 14. 

To install a font as default Select Default Printer Font in the Options menu. 

Printing your whole list, the search list or the current record 

You can print your whole list by selecting whole list. When you select Search List the list generated during
your last search action will be printed By selecting Current record the current record will be printed. 

With the checkboxes you can specify which fields you want to be printed. 

Exporting data 

You can export your list or one record to a text file. Again you can choose between the whole list, the 
Search list or the current record. And choose the fields to be exported. 



Playing a CD

The CD player in PMC will only work properly    when you have both a CD-ROM and a soundcard. If one 
of these doesn't work properly PMC will prompt you with an error message when you start PMC and the 
CD display will say 'NOT READY'. To play a CD audio you must connect the audio cable between the CD-
ROM and your soundcard properly. Otherwise it might look as if the CD is playing but you won't hear any 
music. 

When you insert a new CD into your CD-ROM player, it is possible that the display still shows old 
information. Don't worry, it might take a few seconds to change the information. You can just click the play
button and your CD will start to play immediately. 



License

Private Music Collection Copyright (C)1996-1997 ALTernative Productions. All Rights Reserved 

License Agreement 

You should carefully read the following terms and conditions before using this software.    Unless you have
a different license agreement signed by ALTernative Productions. your use of this software you indicates 
your acceptance of this license agreement and warranty. 

Registered Version 

Private use 

A registered version of PMC may be used on any computer inside your house. To be clear: You have to 
register once to use as many copies as you like on computers inside your own house for private use. 

Organisations and commercial use 

Organisations of any type or individuals using PMC for commercial purposes must register for each copy 
they want to use. You may access the registered version of PMC through a network, provided that you 
have obtained individual licenses for the software covering all workstations that will access the software 
through the network.    For instance, if 8 different workstations will access PMC on the network, each 
workstation must have its own PMC license, regardless of whether they use PMC at different times or 
concurrently. 

Governing Law 

This agreement shall be governed by the laws of the Netherlands. 

Disclaimer of Warranty 

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND WITHOUT 
WARRANTIES AS TO PERFORMANCE OF MERCHANTABILITY OR ANY OTHER WARRANTIES 
WHETHER EXPRESSED OR IMPLIED.    Because of the various hardware and software environments 
into which PMC may be put, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS 
OFFERED. Try the Shareware version before you register to be sure PMC works fine on your computer. If
you like the program but find any problems contact me with as much details as you can give about when 
the problem occured (what were you doing at that moment) and your system. 

Good data processing procedure dictates that any program be thoroughly tested with non-critical data 
before relying on it. The user must assume the entire risk of using the program.    ANY LIABILITY OF THE
SELLER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF 
PURCHASE PRICE. 

Shareware Version 

This is not free software.    You are hereby licensed to use this software for evaluation purposes without 
charge for a period of 8 weeks. If you use this software after the evaluation period a registration fee of 
$25 is required. Payments must be in US dollars, German Marks or Dutch Guilders (Fl 30,-). Read 
ORDER.TXT to learn how to order and find a registration form. 

Unregistered use of PMC after the evaluation period is in violation of Dutch and international copyright 
laws. 



Distribution 

Provided that you verify that you are distributing the Shareware Version (select About from the Help menu
to check) you are hereby licensed to make as many copies of the Shareware version of this software and 
documentation as you wish; give exact copies of the original Shareware version to anyone; and distribute 
the Shareware version of the software and documentation in its unmodified form via electronic means.    
There is no charge for any of the above. It is NOT allowed to pass your registration key or the file 
PMC.KEY through to others. 

You are specifically prohibited from charging, or requesting donations, for any such copies, however 
made; and from distributing the software and/or documentation with other products (commercial or 
otherwise) without prior written permission. 



Inserting a record step by step

Creating a database 

Before you can start entering records you have to create a database to put the records in. To do so, click 
the [new] button. Now you will see a dialogbox. Use this dialogbox to select the directory where you want 
to locate your database. Now enter a name for your database. You can use up to 8 caracters. Click [OK] 
and you are ready to enter your records. 

Inserting a record The very first record can be entered immediately. When there are a few records 
in the database you must click the [insert] button at the database navigator. To cancel this operation 
simply click the [cancel] button. The artist and the title of the album must be entered before a record can 
be saved. 

entering the header data When you can a screen with empty fields you are ready to enter the 
data of the next album. You have to enter a value for the artist and title of this album. You may leave the 
other fields in the header empty if you want to. You have to enter most field yourself, but the Genres can 
be choosen from a pulldown menu. 

entering the details When you are finished with the data in the header that is allway visible you 
move on to the tab named 'details'. The important fields here are the 'Soundcarrier' and 'Number of disks'.
You have to enter these fields. These fields are used to help you with entering the songs. You can leave 
the other fields empty in this tab if you wish. 

You can enter your own ID code for an album in the field 'ID Number'. When you have an album with 
songs performed by various artists you can check 'Show Artist of Song' to be able to enter the performing 
artist in the songlist. When you have a lot of albums with various artists you can check 'Show Artists of 
Each Song'. Now 'Show Artist of Song' is checked by default when you insert a new record. 

To show an image of an album, make a Windows BMP image of it with the size of 125 x 125 pixels with 
your favorite graphical application. Place the images into the same directory as the database. Enter the 
name of the image or use the Browse button to choose one. When you give the database to friends you 
don't have to supply the images. PMC won't report that the image is missing that should be there 
according to the database. It will only show an error that it can't find a file when you enter a filename that 
doesn't exist. This is done to make it easy to transport a database to other systems. 

entering the songs When you've entered all the details you can move on to the 'Songs'. Click on 
the first column and enter the title of the first track. Press <TAB> to move to the next column. When you 
have selected 'Show Artist of Song' the cursor will be in the 'Artist' column, now enter the name of the 
artist and press <TAB> again. In the next column you can enter the playingtime of the song. ow you can 
press <TAB> until you are at the next row. PMC will enter this data automaticly. You only have to change 
it when the next song is on side B of a tape or on another disk. And PMC will restart counting the tracks. 
But you can allways change it manually. When you press <TAB> in the last column a new row will appear 
when you are at the last row of the list. 

When you've forgotten to enter a song somewhere in the middle move to the song that should be under 
that song and press <SHIFT-INS>. To delete a song move to it and press <SHIFT-DEL>. 

Now you are ready. The data will be save automaticly. You can do what you want now. Insert a new 
album, search, browse or print a list. 



Editting the Genrelist

To edit the Genrelist choose 'Edit Genrelist' in the menu 'Options'. You will see a window with the current 
genres in the list. You can insert new genres and delete genres the same way as in a normal editor. Every
genre must be on a next line. 


